Cisco Nexus 7000 Series NX-OS MPLS Configuration Guide
Configuring MPLS LDP Autoconfiguration
Downloads: This chapterpdf (PDF - 238.0KB) The complete bookPDF (PDF - 7.58MB) | The complete bookePub (ePub - 1.96MB) | The complete bookMobi (Mobi - 2.83MB) | Feedback

Table of Contents

Configuring MPLS LDP Autoconfiguration

Finding Feature Information

Information About MPLS LDP Autoconfiguration

Licensing Requirements for MPLS LDP Autoconfiguration

Prerequisites for MPLS LDP Autoconfiguration

Guidelines and Limitations for MPLS LDP Autoconfiguration

Default Settings for MPLS LDP Autoconfiguration

Configuring MPLS LDP Autoconfiguration

Configuring MPLS LDP Autoconfiguration for OSPF Interfaces

Configuring MPLS LDP Autoconfiguration for IS-IS Interfaces

Disabling MPLS LDP Autoconfiguration for Selected OSPF or IS-IS Interfaces

Verifying the MPLS LDP Autoconfiguration

Configuration Examples for MPLS LDP Autoconfiguration

Examples: Configuring MPLS LDP Autoconfiguration for OSPF Interfaces

Examples: Configuring MPLS LDP Autoconfiguration for IS-IS Interfaces

Additional References for MPLS LDP Autoconfiguration

Related Documents

MIBs

Feature History for MPLS LDP Autoconfiguration

Finding Feature Information

Your software release might not support all the features documented in this module. For the latest caveats and feature information, see the Bug Search Tool at https://tools.cisco.com/bugsearch/ and the release notes for your software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the “New and Changed Information” chapter or the Feature History table below.

Information About MPLS LDP Autoconfiguration

The MPLS LDP autoconfiguration feature enables you to globally configure LDP on every interface associated with a specified Interior Gateway Protocol (IGP) instance.

To enable LDP, you should configure it globally and on each interface where it is needed. Configuring LDP on many interfaces can be time consuming.

The MPLS LDP autoconfiguration feature is supported on Open Shortest Path First (OSPF) and Intermediate System-to-System (IS-IS) IGPs. Because you do not have to configure LDP separately on each interface, the autoconfiguration feature makes LDP configuration easier, faster, and error free. If desired, you can also disable LDP on selected interfaces after autoconfiguration is enabled.

Licensing Requirements for MPLS LDP Autoconfiguration

 

Product
License Requirement

Cisco NX-OS

MPLS LDP autoconfiguration requires an MPLS license. For a complete explanation of the Cisco NX-OS licensing scheme and how to obtain and apply licenses, see the Cisco NX-OS Licensing Guide .

Prerequisites for MPLS LDP Autoconfiguration

MPLS LDP autoconfiguration has the following prerequisites:

  • You must enable MPLS LDP.

Guidelines and Limitations for MPLS LDP Autoconfiguration

MPLS LDP autoconfiguration has the following configuration guidelines and limitations:

  • This feature is supported only on interfaces that are running OSPF or IS-IS processes. Other IGPs are not supported.
  • If you disable LDP globally, autoconfiguration fails and generates a console message explaining that you must first enable LDP globally.
  • If MPLS LDP autoconfiguration is configured for an IGP instance, you cannot enter the global shutdown command. To disable LDP, you must first enter the no mpls ldp igp autoconfig command .
  • This feature is not supported on traffic engineering (TE) tunnel interfaces.

Default Settings for MPLS LDP Autoconfiguration

Table 4-1 lists the default settings for MPLS LDP autoconfiguration parameters.

 

Table 4-1 Default MPLS LDP Autoconfiguration Parameters

Parameters
Default

MPLS LDP autoconfiguration

Disabled

Configuring MPLS LDP Autoconfiguration

This section includes the following topics:

Configuring MPLS LDP Autoconfiguration for OSPF Interfaces

You can configure MPLS LDP autoconfiguration for all interfaces that run OSPF processes. As a result, all interfaces that belong to an OSPF area are enabled for LDP.

Prerequisites

Ensure that you are in the correct VDC (or use the switchto vdc command).

Ensure that OSPF is enabled. ( You can enable it using the feature ospf command .)

Ensure that MPLS LDP is enabled.

SUMMARY STEPS

1. configure terminal

2. router ospf process-name

3. mpls ldp autoconfig area area-id

4. (Optional) show mpls ldp discovery detail

5. (Optional) copy running-config startup-config

DETAILED STEPS

Command
Purpose

Step 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2

router ospf process-name

 

Example:

switch(config)# router ospf p1
switch(config-router)#

Enables an OSPF routing process and enters router configuration mode.

You can enter up to 20 alphanumeric characters for the process-name argument.

Step 3

mpls ldp autoconfig area area-id

 

Example:

switch(config-router)# mpls ldp autoconfig area 10

Enables MPLS LDP autoconfiguration for all OSPF interfaces.

For the area-id argument, you can specify the area ID as an integer (from 0 to 4,294,967,295) or an IP address.

Step 4

show mpls ldp discovery detail

 

Example:

switch(config-router)# show mpls ldp discovery detail

(Optional) Displays the method used to enable LDP on an interface:

  • If LDP was enabled on a specific interface, the output displays “Interface config.”
  • If LDP was enabled using autoconfiguration, the output displays “IGP config.”
  • If LDP was enabled on a specific interface and using autoconfiguration, the output displays “Interface config, IGP config.”

Step 5

copy running-config startup-config

 

Example:

switch(config-router)# copy running-config startup-config

(Optional) Copies the running configuration to the startup configuration.

Configuring MPLS LDP Autoconfiguration for IS-IS Interfaces

You can configure MPLS LDP autoconfiguration for all interfaces that run IS-IS processes. As a result, all interfaces that belong to an IS-IS area are enabled for LDP.

Prerequisites

Ensure that you are in the correct VDC (or use the switchto vdc command).

Ensure that IS-IS is enabled. ( You can enable it using the feature isis command .)

Ensure that MPLS LDP is enabled.

SUMMARY STEPS

1. configure terminal

2. router isis process-name

3. mpls ldp autoconfig { level-1 | level-1-2 | level-2 }

4. (Optional) show mpls ldp discovery detail

5. (Optional) copy running-config startup-config

DETAILED STEPS

Command
Purpose

Step 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2

router isis process-name

 

Example:

switch(config)# router isis p1
switch(config-router)#

Enables an IS-IS routing process and enters router configuration mode.

You can enter up to 20 alphanumeric characters for the process-name argument.

Step 3

mpls ldp autoconfig {level-1 | level-1-2 | level-2}

 

Example:

switch(config-router)# mpls ldp autoconfig level-1

Enables MPLS LDP autoconfiguration for all level-1, all level-2, or all level-1 and level-2 IS-IS interfaces.

Step 4

show mpls ldp discovery detail

 

Example:

switch(config-router)# show mpls ldp discovery detail

(Optional) Displays the method used to enable LDP on an interface:

  • If LDP was enabled on a specific interface, the output displays “Interface config.”
  • If LDP was enabled using autoconfiguration, the output displays “IGP config.”
  • If LDP was enabled on a specific interface and using autoconfiguration, the output displays “Interface config, IGP config.”

Step 5

copy running-config startup-config

 

Example:

switch(config-router)# copy running-config startup-config

(Optional) Copies the running configuration to the startup configuration.

Disabling MPLS LDP Autoconfiguration for Selected OSPF or IS-IS Interfaces

You can disable LDP for specific OSPF or IS-IS interfaces after they were configured with the MPLS LDP autoconfiguration feature.

Prerequisites

Ensure that you are in the correct VDC (or use the switchto vdc command).

Ensure that MPLS LDP is enabled.

SUMMARY STEPS

1. configure terminal

2. interface ethernet slot/port

3. no mpls ldp igp autoconfig

4. (Optional) show mpls ldp discovery detail

5. (Optional) copy running-config startup-config

DETAILED STEPS

Command
Purpose

Step 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2

interface ethernet slot/port

 

Example:

switch(config)# interface ethernet 7/1
switch(config-if)#

Specifies the interface on which you are disabling LDP and enters interface configuration mode.

Step 3

no mpls ldp igp autoconfig

 

Example:

switch(config-if)# no mpls ldp igp autoconfig

Disables LDP for the specified interface.

Step 4

show mpls ldp discovery detail

 

Example:

switch(config-if)# show mpls ldp discovery detail

(Optional) Displays the method used to enable LDP on an interface. If LDP has been disabled on an interface, that interface does not appear in the output.

Step 5

copy running-config startup-config

 

Example:

switch(config-if)# copy running-config startup-config

(Optional) Copies the running configuration to the startup configuration.

Verifying the MPLS LDP Autoconfiguration

To display the MPLS LDP autoconfiguration, perform one of the following tasks:

 

Command
Purpose

show mpls ldp discovery detail

Displays the method used to enable LDP on an interface.

For detailed information about the fields in the output from these commands, see the Cisco Nexus 7000 Series NX-OS MPLS Command Reference .

Configuration Examples for MPLS LDP Autoconfiguration

This section provides configuration examples for MPLS LDP autoconfiguration and includes the following topics:

Examples: Configuring MPLS LDP Autoconfiguration for OSPF Interfaces

The following example shows how to configure MPLS LDP autoconfiguration for OSPF interfaces and verify the results:

switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# ip address 10.0.0.13 255.0.0.0
switch(config-if)# exit
switch(config)# router ospf 1
switch(config-router)# area 3 range 10.0.0.13 0.0.255.255
switch(config-router)# mpls ldp autoconfig area 3
switch(config-router)# show mpls ldp discovery detail
Local LDP Identifier:
10.0.0.13:0
Discovery Sources:
Interfaces:
Ethernet2/1 (ldp): xmit/recv
Enabled: IGP config;
Hello interval: 5000 ms; Transport IP addr: 10.0.0.13
LDP Id: 10.0.0.21:0
Src IP addr: 168.5.5.21; Transport IP addr: 10.0.0.21
Hold time: 15 sec; Proposed local/peer: 15/15 sec
Reachable via 10.0.0.21/32
Password: not required, none, in use
Clients: IPv4
Ethernet2/6 (ldp): xmit/recv
Enabled: Interface config, IGP config;
Hello interval: 5000 ms; Transport IP addr: 10.0.0.13
LDP Id: 10.0.0.22:0
Src IP addr: 168.6.6.22; Transport IP addr: 10.0.0.22
Hold time: 15 sec; Proposed local/peer: 15/15 sec
Reachable via 10.0.0.22/32
Password: not required, neighbor, in use
Clients: IPv4
 

The following example shows how to disable LDP on a specific interface after it was enabled using the MPLS LDP autoconfiguration feature:

switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# no mpls ldp igp autoconfig
switch(config-if)# show mpls ldp discovery detail
Local LDP Identifier:
10.0.0.13:0
Discovery Sources:
Interfaces:
Ethernet2/6 (ldp): xmit/recv
Enabled: Interface config, IGP config;
Hello interval: 5000 ms; Transport IP addr: 10.0.0.13
LDP Id: 10.0.0.22:0
Src IP addr: 168.6.6.22; Transport IP addr: 10.0.0.22
Hold time: 15 sec; Proposed local/peer: 15/15 sec
Reachable via 10.0.0.22/32
Password: not required, neighbor, in use
Clients: IPv4

Examples: Configuring MPLS LDP Autoconfiguration for IS-IS Interfaces

The following example shows how to configure MPLS LDP autoconfiguration for IS-IS interfaces and verify the results:

switch# configure terminal
switch(config)# interface ethernet 3/2
switch(config-if)# ip address 10.0.0.30 255.0.0.1
switch(config-if)# ip router isis p1
switch(config-if)# exit
switch(config)# router isis p1
switch(config-router)# mpls ldp autoconfig level-1-2
switch(config-router)# show mpls ldp discovery detail
Local LDP Identifier:
10.0.0.30:0
Discovery Sources:
Interfaces:
Ethernet3/2 (ldp): xmit/recv
Enabled: IGP config;
Hello interval: 5000 ms; Transport IP addr: 10.0.0.30
LDP Id: 10.0.0.31:0
Src IP addr: 60.0.0.2; Transport IP addr: 10.0.0.31
Hold time: 15 sec; Proposed local/peer: 15/15 sec
Reachable via 10.0.0.31/32
Password: not required, none, in use
Clients: IPv4

Additional References for MPLS LDP Autoconfiguration

For additional information related to implementing MPLS LDP autoconfiguration, see the following sections:

Related Documents

Related Topic
Document Title

CLI commands

Cisco Nexus 7000 Series NX-OS MPLS Command Reference

MIBs

MIB
MIBs Link

MPLS-LDP-STD-MIB

To locate and download MIBs, go to the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

Feature History for MPLS LDP Autoconfiguration

Table 4-2 lists the release history for this feature.

 

Table 4-2 Feature History for MPLS LDP Autoconfiguration

Feature Name
Releases
Feature Information

MPLS LDP autoconfiguration

5.2(1)

This feature was introduced.