Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.0(4)SV1(2)
Configuring Port Channels in Port Profiles
Downloads: This chapterpdf (PDF - 290.0KB) The complete bookPDF (PDF - 1.83MB) | Feedback

Configuring Port Channels in Port Profiles

Table Of Contents

Configuring Port Channels in Port Profiles

Information About Port Channels in Port Profiles

Standard Port Channels

vPC Host Mode

Subgroup Creation

Static Pinning

MAC Pinning

Guidelines and Limitations

Creating a Port Profile for a Port Channel

Connecting to a Single Upstream Switch

Connecting to Multiple Upstream Switches

Manually Configuring Subgroups

Pinning a vEthernet Interface to a Subgroup

Pinning a Control or Packet VLAN to a Subgroup

Feature History for Port Channels in Port Profiles


Configuring Port Channels in Port Profiles


This chapter describes port channels in port profiles and how to configure them, including the following:

Information About Port Channels in Port Profiles

Guidelines and Limitations

Creating a Port Profile for a Port Channel

Pinning a vEthernet Interface to a Subgroup

Pinning a Control or Packet VLAN to a Subgroup

Feature History for Port Channels in Port Profiles

Information About Port Channels in Port Profiles

A port channel is an aggregation of multiple physical interfaces that creates a logical interface. You can bundle up to eight individual active links into a port channel to provide increased bandwidth and redundancy. Port channels also balance the traffic across these physical interfaces. The port channel stays operational as long as at least one physical interface within the port channel is operational.

The Cisco Nexus 1000V is an end-host switch where the following port channels can be created:

A standard port channel that is configured on both the Cisco Nexus 1000V and the upstream switches.

A port channel that is configured only on the Cisco Nexus 1000V without the need to configure anything upstream.

This section includes the following topics:

Standard Port Channels

vPC Host Mode

Subgroup Creation

Static Pinning

MAC Pinning

Standard Port Channels

A standard port channel behaves like an EtherChannel on other Cisco switches and supports the Link Aggregation Control Protocol (LACP). All uplinks in the port channel must be in the same EtherChannel on the upstream switch.

Standard port channels can be spread across more than one physical switch if the physical switches are clustered, such as that available in the following:

Cisco Catalyst 6500 Virtual Switching System 1440

Virtual port channels on the Cisco Nexus 7000 Series Switches

Cisco Catalyst Blade Switch 3120 for HP

Clustered switches act as a single switch allowing the creation of EtherChannels across them. This clustering is transparent to the Cisco Nexus 1000V. When the upstream switches are clustered the Cisco Nexus 1000V should be configured to use LACP with one port profile using all available links. This makes greater bandwidth available for the Virtual Machines and improves the speed of VMotion.

Standard port channels do not use MAC pinning or virtual port channel—host mode (vPC-HM).

To configure a standard port channel, use the "Creating a Port Profile for a Port Channel" section.

vPC Host Mode

vPC-HM is a way of creating a port channel when connecting to multiple upstream switches that are not clustered because they do not support port channels. In the Cisco Nexus 1000V, the port channel is divided into subgroups or logical smaller port channels, each representing one or more uplinks to one upstream physical switch.

Links that connect to the same physical switch are bundled in the same subgroup automatically by using information gathered from the Cisco Discovery Protocol packets from the upstream switch. Interfaces can also be manually assigned a specific subgroup using interface configuration. For more information, see the Cisco Nexus 1000V Interface Configuration Guide, Release 4.0(4)SV1(2).

When vPC-HM is used, each vEthernet interface on the VEM is mapped to one of two subgroups in a round-robin method. All traffic from the vEthernet interface uses the assigned subgroup unless it is unavailable, in which case the vEthernet interface fails over to the remaining subgroup. When the original subgroup becomes available again, traffic shifts back to it. Traffic from each vEthernet interface is then balanced based on the configured hashing algorithm.

When multiple uplinks are attached to the same subgroup, the upstream switch must be configured in a port channel, the links bundled together. The port channel must also be configured with the channel-group auto mode on (active and passive modes use LACP).

If the upstream switches do not support port channels, you can use MAC pinning to assign each Ethernet port member to a particular port channel subgroup. For more information, see the "MAC Pinning" section.


Note Do not configure vPC-HM on the Cisco Nexus 1000V when the upstream switch ports that connect to the VEMs have vPC configured. In this case, the connection can be interrupted or disabled.


Figure 5-1 shows traffic separation using vPC-HM by assigning member ports 1 and 2 to subgroup ID 0 and member ports 3 and 4 to subgroup ID 1.

Figure 5-1 Using vPC-HM to Connect a Port Channel to Multiple Upstream Switches

To configure a port profile in vPC-HM, see the "Connecting to Multiple Upstream Switches" procedure.

Subgroup Creation

If Cisco Discovery Protocol (CDP) is enabled on the upstream switches, then subgroups are automatically created using information gathered from the Cisco Discovery Protocol packets. If not, then you must use the "Manually Configuring Subgroups" procedure.

Static Pinning

Static pinning allows you to pin the virtual ports behind a VEM to a particular subgroup within the channel. Instead of allowing round robin dynamic assignment between the subgroups, you can assign (or pin) a static vEthernet interface, control VLAN, or packet VLAN to a specific port channel subgroup. With static pinning, traffic is forwarded only through the member ports in the specified subgroup.

You can use the following procedures to designate the subgroup to communicate with the network.

"Pinning a vEthernet Interface to a Subgroup" section

"Pinning a Control or Packet VLAN to a Subgroup" section

You can also pin vEthernet interfaces to subgroups in interface configuration mode. For more information, see the Cisco Nexus 1000V Interface Configuration Guide, Release 4.0(4)SV1(2).

MAC Pinning

If you are connecting to multiple upstream switches that do not support port channels, then MAC pinning is the preferred configuration. MAC pinning divides the uplinks from your server into standalone links and pins the MAC addresses to those links in a round-robin method. This ensures that the MAC address of a virtual machine is never seen on multiple upstream switch interfaces. Therefore no upstream configuration is required to connect the VEM to upstream switches.

MAC pinning does not rely on any protocol to distinguish upstream switches so the configuration is independent of upstream hardware or design.

In case of a failure, the Cisco Nexus 1000V first sends a gratuitous ARP packet to the upstream switch indicating that the VEM MAC address will now be learned on a different link. It also allows for sub-second failover time.

Figure 5-2 shows each member port that is assigned to a specific port channel subgroup using MAC pinning.

Figure 5-2 Using MAC Pinning to Connect a Port Channel to Multiple Upstream Switches

To configure MAC pinning, see one of the following procedures:

"Connecting to a Single Upstream Switch" section

"Connecting to Multiple Upstream Switches" section.

Guidelines and Limitations

Before beginning the procedures in this section, you must know or do the following:

If you are connecting to an upstream switch or switches that do not support port channels, then MAC pinning is the preferred configuration. MAC pinning divides the uplinks from your server into standalone links and pins the MAC addresses to those links in a round-robin method. The drawback is that you cannot leverage the load sharing performance that LACP provides.

Once a port profile is created, you cannot change its type (Ethernet or vEthernet).

The server administrator should not assign more than one uplink on the same VLAN without port channels. It is not supported to assign more than one uplink on the same host to a profile without port channels or port profiles that share one or more VLANs.


Caution Disruption of connectivity may result if you configure vPC-HM on the Cisco Nexus 1000V when vPC is also configured on the ports of upstream switches that connect to its VEMs.

You must have already configured the Cisco Nexus 1000V software using the setup routine. For information, see the Cisco Nexus 1000V Getting Started Guide, Release 4.0(4)SV1(2).

The Cisco Nexus 1000V must be connected to the vCenter Server.

You are logged in to the CLI in EXEC mode.

When you create a port channel, an associated channel group is automatically created.

Creating a Port Profile for a Port Channel

You can use the procedures in this section to define upstream switch configurations for a port channel or to manually configure subgroups for a port channel.

Connecting to a Single Upstream Switch

Connecting to Multiple Upstream Switches

Manually Configuring Subgroups

Connecting to a Single Upstream Switch

You can use this procedure to configure a port channel whose ports are connected to the same upstream switch.

BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

If the ports are connected to multiple upstream switches, see the "Connecting to Multiple Upstream Switches" section.

The channel group number assignment is made automatically when the port profile is assigned to the first interface.

SUMMARY STEPS

1. config t

2. port-profile [type {ethernet | vethernet}] name

3. channel-group auto [mode {on | active | passive} [sub-group {cdp | manual}] [mac-pinning]

4. show port-profile [brief | expand-interface | usage] [name profile-name]

5. copy running-config startup-config

DETAILED STEPS

 
Command
Description

Step 1 

config t


Example:

n1000v# config t

n1000v(config)#

Enters global configuration mode.

Step 2 

port-profile [type {ethernet | vethernet}] name


Example:

n1000v(config)# port-profile AccessProf

n1000v(config-port-prof)#

Enters port profile configuration mode for the named port profile.

name—Specifies the port profile name, which can be up to 80 characters and must be unique for each port profile on the Cisco Nexus 1000V.

type—(Optional) Specifies the port profile as an Ethernet or vEthernet type. Once configured, this setting cannot be changed. The default is the vEthernet type.

Defining a port profile as an Ethernet type allows the port profile to be used for physical (Ethernet) ports. In the vCenter Server, the corresponding port group can be selected and assigned to physical ports (PNICs).

Note If a port profile is configured as an Ethernet type, then it cannot be used to configure VMware virtual ports.

Step 3 

channel-group auto [mode {on | active | passive}] mac-pinning


Example:

n1000v(config-port-prof)# channel-group auto mode on

n1000v(config-port-prof)#


Example:

n1000v(config-port-prof)# channel-group auto mode on mac-pinning

n1000v(config-port-prof)#


Defines a port channel group in which a unique port channel is created and automatically assigned when the port profile is assigned to the first interface.

Each additional interface that belongs to the same module is added to the same port channel. In VMware environments, a different port channel is created for each module.

mode—Sets the port channel mode to on, active, or passive (active and passive use LACP).

mac-pinning—If the upstream switch does not support port channels, this designates that one subgroup per Ethernet member port must be automatically assigned,

Step 4 

show port-profile [brief | expand-interface | usage] [name profile-name]

Example:

n1000v(config-port-prof)# show port-profile name AccessProf

(Optional) Displays the configuration for verification.

Step 5 

copy running-config startup-config


Example:

n1000v(config-port-prof)# copy running-config startup-config

(Optional) Saves the running configuration persistently through reboots and restarts by copying it to the startup configuration.

EXAMPLES

This example shows how to configure a port channel that connects to one upstream switch:

Example: 
n1000v# config t
n1000v(config)# port-profile AccessProf
n1000v(config-port-prof)# channel-group auto mode on
n1000v(config-port-prof)# show port-profile name AccessProf
port-profile AccessProf
  description: allaccess4
  status: disabled
capability l3control: no
  pinning control-vlan: -
  pinning packet-vlan: -
  system vlans: none
  port-group:
  max ports: 32
  inherit:
  config attributes:
    channel-group auto mode on
  evaluated config attributes:
    channel-group auto mode on
  assigned interfaces:
n1000v(config-port-prof)#

Connecting to Multiple Upstream Switches

You can use this procedure to create a port channel that connects to multiple upstream switches,.

BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

You are logged in to the CLI in EXEC mode.

If the ports are connected to a single upstream switch, see the "Connecting to a Single Upstream Switch" procedure.

You can use this procedure to configure an uplink port profile to be used by the physical NICs in the VEM in virtual port channel-host mode (vPC-HM) when the ports connect to multiple upstream switches.

If you are connecting to multiple upstream switches that do not support port channels, then MAC pinning is the preferred configuration. You can configure MAC pinning using this procedure. For more information about the feature, see the "MAC Pinning" section.

You can also configure vPC-HM on the interface. For more information, see the Cisco Nexus 1000V Interface Configuration Guide, Release 4.0(4)SV1(2).

The channel group mode must be set to on (active and passive modes use LACP).

You need to know whether CDP is configured in the upstream switches.

If configured, then CDP packets from the upstream switch are used to automatically create a subgroup for each upstream switch to manage its traffic separately.

If not configured, then, after completing this procedure, you must manually configure subgroups to manage the traffic flow on the separate switches. See the "Manually Configuring Subgroups" procedure.


Caution Connectivity may be disrupted for up to 60 seconds if the CDP timer is set to 60 seconds (the default).


Caution The VMs behind the Cisco Nexus 1000V receive duplicate packets from the network for unknown unicasts, multicast floods, and broadcasts if vPC-HM is not configured when port channels connect to two different upstream switches.

SUMMARY STEPS

1. config t

2. port-profile [type {ethernet | vethernet}] name

3. channel-group auto mode on [sub-group {cdp | manual}] [mac-pinning]

4. show port-profile [brief | expand-interface | usage] [name profile-name]

5. copy running-config startup-config

DETAILED STEPS

 
Command
Description

Step 1 

config t


Example:

n1000v# config t

n1000v(config)#

Enters global configuration mode.

Step 2 

port-profile [type {ethernet | vethernet}] name


Example:

n1000v(config)# port-profile uplinkProf

n1000v(config-port-prof)#

Creates an Ethernet type port profile (the default) and enters port profile configuration mode for that port profile.

name—Specifies the port profile name, which can be up to 80 characters and must be unique for each port profile on the Cisco Nexus 1000V.

type—An Ethernet type port profile can be used for physical ports, and in the vCenter Server, the corresponding port group can be selected and assigned to physical ports (PNICs).

Note If a port profile is configured as an Ethernet type, then it cannot be used to configure VMware virtual ports.

Note Once a port profile is created, you cannot change its type (Ethernet or vEthernet).

Step 3 

channel-group auto mode on [sub-group {cdp | manual}] [mac-pinning]



Example—CDP is configured on the upstream 
switches:

n1000v(config-port-prof)# channel-group auto mode on sub-group cdp

n1000v(config-port-prof)#



Example—CDP is not configured on the upstream 
switches:

n1000v(config-port-prof)# channel-group auto mode on manual

n1000v(config-port-prof)#



Example—Upstream switches do not support port 
channels:

n1000v(config-port-prof)# channel-group auto mode on mac-pinning

n1000v(config-port-prof)#


Creates a unique asymmetric port channel (also known as vPC-HM) and automatically assigns it when the port profile is assigned to the first interface.

Each additional interface that belongs to the same module is added to the same port channel. In VMware environments, a different port channel is created for each module.

The following options are also defined:

mode—Sets the port channel mode to on (active and passive use LACP).

sub-group—Identifies this channel group as asymmetric, or connected to more than one switch.

cdp—Specifies that CDP information is used to automatically create subgroups for managing the traffic flow.

manual—Specifies that subgroups are configured manually. This option is used if CDP is not configured on the upstream switches. To configure subgroups, see the "Manually Configuring Subgroups" procedure.

mac-pinning—Specifies that Ethernet member ports are assigned to subgroups automatically, one subgroup per member port. This option is used if the upstream switch does not support port channels.

Step 4 

show port-profile [brief | expand-interface | usage] [name profile-name]


Example:

n1000v(config-port-prof)# show port-profile name AccessProf

(Optional) Displays the configuration for verification.

Step 5 

copy running-config startup-config


Example:

n1000v(config-port-prof)# copy running-config startup-config

(Optional) Saves the running configuration persistently through reboots and restarts by copying it to the startup configuration.

EXAMPLES

This example shows how to create a port channel that connects to multiple upstream switches that support CDP:

n1000v(config)# port-profile UpLinkProfile2
n1000v(config-port-prof)# channel-group auto mode on sub-group cdp
n1000v(config-port-prof)# show port-profile name UpLinkProfile2
port-profile UpLinkProfile2
  description:
  type: ethernet
  status: disabled
  capability l3control: no
  pinning control-vlan: -
  pinning packet-vlan: -
  system vlans: none
  port-group:
  max ports: 32
  inherit:
  config attributes:
    channel-group auto mode on sub-group cdp
  evaluated config attributes:
    channel-group auto mode on sub-group cdp
  assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config


This example shows how to create a port channel that connects to multiple upstream switches that do not support CDP:

n1000v(config)# port-profile UpLinkProfile3

n1000v(config-port-prof)# channel-group auto mode on sub-group manual

n1000v(config-port-prof)# exit

n1000v(config)# interface ethernet3/2-3

n1000v(config-if)# sub-group-id 0

n1000v(config-port-prof)# show port-profile name 
n1000v(config-port-prof)# show port-profile name UplinkProfile3 
port-profile UplinkProfile3
  description:
  type: ethernet
  status: enabled
  capability l3control: no
  pinning control-vlan: -
  pinning packet-vlan: -
  system vlans: none
  port-group: UplinkProfile3
  max ports: -
  inherit:
  config attributes:
    channel-group auto mode on sub-group manual
  evaluated config attributes:
    channel-group auto mode on sub-group manual
  assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config


This example shows how to create a port channel that connects to multiple upstream switches that do not support port channels:

n1000v(config)# port-profile UpLinkProfile1
n1000v(config-port-prof)# channel-group auto mode on mac-pinning
n1000v(config-port-prof)# show port-profile name UpLinkProfile1
port-profile UpLinkProfile1
  description:
  type: ethernet
  status: disabled
  capability l3control: no
  pinning control-vlan: -
  pinning packet-vlan: -
  system vlans: none
  port-group:
  max ports: 32
  inherit:
  config attributes:
    channel-group auto mode on mac-pinning
  evaluated config attributes:
    channel-group auto mode on mac-pinning
  assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config

Manually Configuring Subgroups

You can use this procedure to manually configure port channel subgroups to manage the traffic flow on multiple upstream switches. This is required for a port channel that connects to multiple upstream switches where CDP is not configured.

BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

You are logged in to the CLI in EXEC mode.

You have already configured the port profile for the port channel using the "Connecting to Multiple Upstream Switches" procedure.

You know the interface range and the subgroup IDs (0-31) for traffic to the upstream switches.

SUMMARY STEPS

1. config t

2. interface ethernet range

3. sub-group-id number

4. Repeat step 2 and 3 for each port connected to an upstream switch where CDP is not configured.

5. show interface ethernet range

6. copy running-config startup-config

DETAILED STEPS

 
Command
Description

Step 1 

config t


Example:

n1000v# config t

n1000v(config)#

Enters global configuration mode.

Step 2 

interface ethernet range


Example:

n1000v(config)# interface ethernet3/2-3

n1000v(config-if)#

Enters interface configuration mode for the specified interface range.

Step 3 

sub-group id number


Example:

n1000v(config-if)# sub-group-id 0

n1000v(config-if)#

Manually configures a subgroup to manage traffic for the upstream switch.

Allowable subgroup numbers are from 0 to 31.

Step 4 

Repeat Step 2 and Step 3 for each port connected to an upstream switch where CDP is not configured.

Step 5 

show interface ethernet range


Example:

n1000v(config-if)# show interface ethernet 3/2-3

(Optional) Displays the configuration for verification.

Step 6 

copy running-config startup-config


Example:

n1000v(config-if)# copy running-config startup-config

(Optional) Saves the running configuration persistently through reboots and restarts by copying it to the startup configuration.

EXAMPLES

This example shows how to manually configure port channel subgroups for a host in module 3 which has four physical ports. The upstream switches do not support CDP. Ethernet ports 3/2 and 3/3 connect to one upstream switch and the Ethernet ports 3/4 and 3/5 connect to another.

n1000v# conf t
n1000v(config)# int eth3/2
n1000v(config-if)# sub-group-id 0
n1000v(config-if)# int eth3/3
n1000v(config-if)# sub-group-id 0
n1000v(config-if)# int eth3/4
n1000v(config-if)# sub-group-id 1
n1000v(config-if)# int eth3/5
n1000v(config-if)# sub-group-id 1
n1000v(config-if)# show running-config interface 
. . .
interface Ethernet3/2
  inherit port-profile system-uplink-pvlan
  sub-group-id 0
interface Ethernet3/3
  inherit port-profile system-uplink-pvlan
  sub-group-id 0
interface Ethernet3/4
  inherit port-profile system-uplink-pvlan
  sub-group-id 1
interface Ethernet3/5
  inherit port-profile system-uplink-pvlan
  sub-group-id 1

Pinning a vEthernet Interface to a Subgroup

You can use this procedure to pin a vEthernet interface to a specific port channel subgroup in the port profile configuration.


Note You can also pin a subgroup to a vEthernet interface in the interface configuration. For information, see the Cisco Nexus 1000V Interface Configuration Guide, Release 4.0(4)SV1(2).


BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

You are logged in to the CLI in EXEC mode.

You know the subgroup ID (0-31) for the vEthernet interface.

SUMMARY STEPS

1. config t

2. port-profile type vethernet name

3. pinning id subgroup_id

4. show port-profile [brief | expand-interface | usage] [name profile-name]

5. copy running-config startup-config

DETAILED STEPS

 
Command
Description

Step 1 

config t


Example:

n1000v# config t

n1000v(config)#

Enters global configuration mode.

Step 2 

port-profile type vethernet name


Example:

n1000v(config)# port-profile type vethernet PortProfile1

n1000v(config-port-prof)#

Enters port profile configuration mode for the named profile.

Step 3 

pinning id subgroup_id


Example:

n1000v(config-port-prof)# pinning id 3

For the named port profile, assigns (or pins) a vEthernet interface to a port channel subgroup (0-31).

Step 4 

show port-profile [brief | expand-interface | usage] [name profile-name]


Example:

n1000v(config-port-prof)# show port-profile PortProfile1

(Optional) Displays the configuration for verification.

Step 5 

copy running-config startup-config


Example:

n1000v(config-port-prof)# copy running-config startup-config

(Optional) Saves the running configuration persistently through reboots and restarts by copying it to the startup configuration.

EXAMPLES

This example shows how to create a vEthernet port profile and pin it to port channel subgroup 3:

n1000v# config t
n1000v(config)# port-profile type vethernet PortProfile1
n1000v(config-port-prof)# pinning id 3
n1000v(config-port-prof)# show port-profile name PortProfile1
port-profile PortProfile1
  description:
  type: vethernet
  status: disabled
  capability l3control: no
  pinning control-vlan: -
  pinning packet-vlan: -
  system vlans: none
  port-group:
  max ports: 32
  inherit:
  config attributes:
    pinning id 3
  evaluated config attributes:
    pinning id 3
  assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config

Pinning a Control or Packet VLAN to a Subgroup

You can use this procedure to pin a control or packet VLAN to a specific subgroup.

BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

You are logged in to the CLI in EXEC mode.

The existing port profile must be a system port profile.

The port profile must be an Ethernet type.

If you are pinning a control or packet VLAN, it must already be in the port profile.

If you are pinning a control VLAN, the control VLAN must already be one of the system VLANs in the port profile.

SUMMARY STEPS

1. config t

2. port-profile name

3. pinning {control-vlan | packet-vlan} subgroup_id

4. show port-profile [brief | expand-interface | usage] [name profile-name]

5. copy running-config startup-config

DETAILED STEPS

 
Command
Description

Step 1 

config t


Example:

n1000v# config t

n1000v(config)#

Enters global configuration mode.

Step 2 

port-profile name


Example:

n1000v(config)# port-profile SystemProfile1

n1000v(config-port-prof)#

Enters port profile configuration mode for the named port profile.

Step 3 

pinning {control-vlan | packet-vlan} subgroup_id


Example:

n1000v(config-port-prof)# pinning control-vlan 3

n1000v(config-port-prof)#

Assigns (or pins) a control VLAN or packet VLAN to a port channel subgroup (0-31).

Step 4 

show port-profile [brief | expand-interface | usage] [name profile-name]


Example:

n1000v(config-port-prof)# show port-profile SystemProfile1

(Optional) Displays the configuration for verification.

Step 5 

copy running-config startup-config


Example:

n1000v(config-port-prof)# copy running-config startup-config

(Optional) Saves the running configuration persistently through reboots and restarts by copying it to the startup configuration.

EXAMPLES

This example shows how to configure static pinning on a control VLAN:

n1000v# config t
n1000v(config)# port-profile SystemProfile1
n1000v(config-port-prof)# pinning control-vlan 3
n1000v(config-port-prof)# show port-profile SystemProfile1
port-profile SystemProfile1
  description:
  type: ethernet
  status: disabled
  capability l3control: no
  pinning control-vlan: 3
  pinning packet-vlan: -
  system vlans: 1
  port-group: SystemProfile1
  max ports: -
  inherit:
  config attributes:
    switchport mode trunk
    switchport trunk allowed vlan 1-5
    no shutdown
  evaluated config attributes:
    switchport mode trunk
    switchport trunk allowed vlan 1-5
    no shutdown
  assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config


This example shows how to configure static pinning on a packet VLAN:

n1000v# config t
n1000v(config)# port-profile SystemProfile1
n1000v(config-port-prof)# pinning packet-vlan 0
n1000v(config-port-prof)# show port-profile name SystemProfile1
port-profile SystemProfile1
  description:
  type: ethernet
  status: disabled
  capability l3control: no
  pinning control-vlan: -
  pinning packet-vlan: 0
  system vlans: 1
  port-group:
  max ports: -
  inherit:
  config attributes:
    switchport mode access
    switchport access vlan 1
    switchport trunk native vlan 1
    no shutdown
  evaluated config attributes:
    switchport mode access
    switchport access vlan 1
    switchport trunk native vlan 1
    no shutdown
  assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config

Feature History for Port Channels in Port Profiles

This section provides the feature history for port channels in port profiles.

Feature Name
Releases
Feature Information

Port Channels in Port Profiles

4.0(4)SV1(1)

This feature was introduced.

vPC-Host Mode

4.0(4)SV1(2)

Supports the following:

Manual creation of subgroups.

MAC pinning for upstream switches that do not support port channels.

MAC Pinning

4.0(4)SV1(2)

Connecting to upstream switches that do not support port channels using the MAC-pinning command.

Static Pinning

4.0(4)SV1(2)

Supports attaching (or pinning) a vEthernet interface, control VLAN, or packet VLAN to a specific port channel subgroup.