Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.0(4)SV1(2)
Verifying the Port Profile Configuration
Downloads: This chapterpdf (PDF - 108.0KB) The complete bookPDF (PDF - 1.83MB) | Feedback

Verifying the Port Profile Configuration

Table Of Contents

Verifying the Port Profile Configuration

Verifying the Port Profile Configuration

Feature History for Port Profile Verification


Verifying the Port Profile Configuration


This chapter describes the commands used to verify port profile configurations.

This chapter includes the following sections:

Verifying the Port Profile Configuration

Feature History for Port Profile Verification

Verifying the Port Profile Configuration

You can use the following commands to verify the port profile configuration.

Command
Purpose

show port-profile [brief | expand-interface | usage] [name profile-name]

Displays the port profile configuration.

show running-config interface {ethernet slot/port | mgmt 0 | vethernet number}

Displays the port profile configuration, including interface assignments.


For detailed information about the command output, see the Cisco Nexus 1000V Command Reference, Release 4.0(4)SV1(2).

EXAMPLES

The following example shows how to display information about all port profiles:

n1000v# show port-profile
port-profile UpLinkProfile1
  description:
  type: vethernet
  status: disabled
  capability l3control: no
  pinning control-vlan: -
  pinning packet-vlan: -
  system vlans: none
  port-group:
  max ports: 32
  inherit:
  config attributes:
    channel-group auto mode on mac-pinning
  evaluated config attributes:
    channel-group auto mode on mac-pinning
  assigned interfaces:
port-profile UpLinkProfile2
  description:
  type: vethernet
  status: disabled
  capability l3control: no
  pinning control-vlan: -
  pinning packet-vlan: -
  system vlans: none
  port-group:
  max ports: 32
  inherit:
  config attributes:
    channel-group auto mode on sub-group cdp
  evaluated config attributes:
    channel-group auto mode on sub-group cdp
  assigned interfaces:
port-profile UpLinkProfile3
  description:
  type: vethernet
  status: disabled
  capability l3control: no
  pinning control-vlan: -
  pinning packet-vlan: -
  system vlans: none
  port-group:
  max ports: 32
  inherit:
  config attributes:
    channel-group auto mode on sub-group manual
  evaluated config attributes:
    channel-group auto mode on sub-group manual
  assigned interfaces:n1000v#


The following example shows how to display information about a specific port profile:

n1000v# show port-profile name UpLinkProfile3
port-profile UpLinkProfile3
  description:
  type: vethernet
  status: disabled
  capability l3control: no
  pinning control-vlan: -
  pinning packet-vlan: -
  system vlans: none
  port-group:
  max ports: 32
  inherit:
  config attributes:
    channel-group auto mode on sub-group manual
  evaluated config attributes:
    channel-group auto mode on sub-group manual
  assigned interfaces:
n1000v#


The following example shows how to display summary information about all port profiles:

n1000v# show port-profile brief
--------------------------------------------------------------------------------
Port                                    Profile  Remote Conf  Eval  Child Child
Profile                                 State    Mgmt   Items Items Intfs Profs
--------------------------------------------------------------------------------
UplinkProfile1                          enabled  vmware     3     3     1     0
UplinkProfile2                          enabled  vmware     3     3     2     0
Ubuntu-Profile                          enabled  vmware     3     3     1     0
n1000v#


The following example shows how to display usage information about all port profiles:

n1000v# show port-profile usage
--------------------------------------------------------------------------------
Port Profile               Port        Adapter        Owner
--------------------------------------------------------------------------------
UplinkProfile1             Eth2/2      vmnic1         mcs-srvr26
UplinkProfile2             Eth2/3      vmnic2         mcs-srvr26
                           Eth2/4      vmnic3         mcs-srvr26
Ubuntu-Profile             Veth439                    ubuntu-2
n1000v#
    

The following example shows how to display expanded interface information about a specific port profile:

n1000v# show port-profile expand-interface name UplinkProfile1
port-profile UplinkProfile1
Ethernet2/2
    switchport mode trunk
    switchport trunk allowed vlan 110-119
    no shutdown
n1000v#

    

The following example shows how to display expanded interface information for all port profiles:

n1000v# show port-profile expand-interface
port-profile UplinkProfile1
Ethernet2/2
    switchport mode trunk
    switchport trunk allowed vlan 110-119
    no shutdown

port-profile UplinkProfile2
Ethernet2/3
    switchport mode trunk
    switchport trunk allowed vlan 117
    no shutdown
Ethernet2/4
    switchport mode trunk
    switchport trunk allowed vlan 117
    no shutdown

port-profile Ubuntu-Profile
Vethernet439
    switchport mode access
    switchport access vlan 118
    no shutdown
n1000v#


The following example shows how to display the running configuration of all port profiles:

n1000v# show running-config port-profile
port-profile type ethernet UplinkProfile1
  description "Profile for critical system ports"
  vmware port-group
  switchport mode access
  switchport access vlan 113
  switchport trunk native vlan 113
  channel-group auto mode on
  no shutdown
port-profile type vethernet UplinkProfile2
  vmware port-group
  vmware max-ports 5
  switchport mode trunk
  switchport trunk native vlan 112
  channel-group auto mode on sub-group cdp
  no shutdown
n1000v#

Feature History for Port Profile Verification

This section provides the feature history for port profile verification.

Feature Name
Releases
Feature Information

Port Profile verification

4.0(4)SV1(1)

This feature was introduced.

show running-config command

4.0(4)SV1(2)

This command output has the following changes:

Shows the port profile type (Ethernet or vEthernet).

Optionally, you can display running configurations for all port profiles or a specific port profile.

show port-profile name command

4.0(4)SV1(2)

This command output shows the port profile type, pinning, and channel-group configuration. The uplink capability is removed from the output of this command since port profiles used as uplinks are now configured as Ethernet type instead.