Guest

Cisco Interface Cards

Configuring Voice and Data on 1-Port and 2-Port T1/E1 VWIC3

  • Viewing Options

  • PDF (202.7 KB)
  • Feedback
Configuring Voice and Data Support on VWIC3s

Table Of Contents

Configuring Voice and Data Support on VWIC3s

Finding Feature Information

Contents

Restrictions for VWIC3s with Voice Support

Information About Voice and Data support on VWIC3s

Key Features of T1/E1 Multiflex Trunk Voice/WAN Interface Cards

Integrated Drop and Insert Capability

How to Configure Voice Support on T1/E1 VWIC3s

Configuring the T1/E1 VWIC3s

Configuration Examples for T1/E1 VWIC3s with voice support

Example: 2-Port T1 VWIC3

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Feature Information for Voice and Data Support on VWIC3s


Configuring Voice and Data Support on VWIC3s


First Published: July 21, 2010, OL-22847-01

This module describes how to configure voice and data support on the next generation of voice/WAN Interface Cards (VWICs) also known as VWIC3s.

The following Cisco products are covered in this document:

Cisco 1-Port and 2-Port T1/E1 VWIC3s

1-port SKU: VWIC3-1MFT-T1/E1

2-port SKU: VWIC3-2MFT-T1/E1

Cisco 1-Port and 2-Port T1/E1 VWIC3s with unframed E1

1-port SKU: VWIC3-1MFT-G703

2-port SKU: VWIC3-2MFT-G703

Platforms supported

Cisco 1-Port and 2-Port T1/E1 VWIC3s and Cisco 1-Port and 2-Port T1/E1 VWIC3s with unframed E1 are supported on Cisco 2901, Cisco 2911, Cisco 2921, Cisco 2951, Cisco 3925, Cisco 3925E,
Cisco 3945, and Cisco 3945E.

For the Cisco Integrated Services Router Generation 2 (Cisco ISR-G2) platforms, digital voice capability for 1-Port and 2-Port VWIC3s is only supported on motherboard (MB) VWIC slots.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature Information for Voice and Data Support on VWIC3s" section.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Restrictions for VWIC3s with Voice Support

Information About Voice and Data support on VWIC3s

How to Configure Voice Support on T1/E1 VWIC3s

Configuration Examples for T1/E1 VWIC3s with voice support

Additional References

Feature Information for Voice and Data Support on VWIC3s

Restrictions for VWIC3s with Voice Support

Features not supported

Supports Drop and Insert (DI) but not EADI

V.54 loop up/down code recognition

G.732

Network Time Reference clocking

Auto line detection

Nitro cabling

J1

Channel-groups supported

VWIC3-1MFT-T1/E1 supports two channel-groups per VWIC, up to two per port.

VWIC3-1MFT-G703 supports two channel-groups per VWIC, up to two per port.

VWIC3-2MFT-T1/E1 supports two channel-groups per VWIC, up to two per port.

VWIC3-2MFT-G703 supports two channel-groups per VWIC, up to two per port.

VWIC Support

The VWIC3s can only be plugged into EHWIC slots on ISR-G2 for voice support.

Independent Clocking Mode

The independent clocking mode is supported on the following modules:

VWIC3-1MFT-T1/E1

VWIC3-2MFT-T1/E1

VWIC3-1MFT-G703

VWIC3-2MFT-G703

To enable independent clocking mode, use the clock source line independent command to specify that the port can operate using an independent clocking domain. The independent keyword means that the specific port is independent from the VWIC3 controller clocking domain. Prior to the addition of the independent keyword, port 0 was the default primary clock source and ports 1, 2, and 3 were loop timed. With the clock source line independent command, independent clocking mode is enabled and the prior dependency no longer exists.

When independent clocking is configured, the port supports only data applications and voice applications are not supported. However, other ports that do not have independent clocking enabled but use the same controller still support voice applications.

For example, a VWIC3-2CE1T1-PRI has the following configurations:

network-clock-participate wic 3
......
controller T1 0/3/0
cablelength long 0db
!
controller T1 0/3/1
 cablelength long 0db
 clock source line independent
!
 
   

Port 1 enables independent clocking. It only supports channel group and data applications, and port 0/2/3 support all voice applications.

When using the clock source line independent and no clock source line independent commands, the channel group must be removed from the configuration.

Information About Voice and Data support on VWIC3s

This section provides information about the following:

Key Features of T1/E1 Multiflex Trunk Voice/WAN Interface Cards

Integrated Drop and Insert Capability

Key Features of T1/E1 Multiflex Trunk Voice/WAN Interface Cards

The 1-Port and 2-Port VWIC3s have the following key features:

Full support for T1 Facility Data Link (FDL)

Controller local loopbacks

Controller remote loopbacks

RFC 1406 and integrated CSU/DSU MIB

MIB and Simple Network Management Protocol (SNMP) management

Firmware to support T1 and E1 Layer 1 homologation

The G703 VWIC3 cards supports unframed E1. For more information on features and configuration samples of unframed E1, see "Related Documents" section.

User-initiated VWIC reset and field-programmable gate array (FPGA) download

Voice support (includes dso-group and pri-group configuration)

Integrated Drop and Insert Capability

The drop and insert feature enables the removal of DS0 time slots from one E1 interface and insertion into time slots of the other E1 interface. This feature is available in VWIC applications. If you configure drop and insert, be sure that the E1 framing under the controllers involved (the tdm-groups configuration location) is the same. If you use different frame types, the signaling bits may not be read properly. This failure occurs during the drop of a channel from one controller and insertion into a channel from another controller. Drop and insert time slots do not need to be contiguous.

How to Configure Voice Support on T1/E1 VWIC3s

To configure the 1-port and 2-port T1/E1 VWIC3s feature, perform the task described in the following section

Configuring the T1/E1 VWIC3s

Configuring the T1/E1 VWIC3s

Perform this task to configure a T1 or E1 interface with independent clocking enabled and integrated drop and insert on a multiflex trunk voice/WAN interface card.

SUMMARY STEPS

1. enable

2. configure terminal

3. card type {e1 | t1} slot subslot

4. voice-card slot

5. codec complexity {flex [reservation-fixed {high | medium}] | high | medium}

6. controller {e1 | t1} slot/port

7. framing {sf | esf}
or
framing {crc4 | no-crc4}

8. linecode {ami | b8zs}
or
linecode {ami | hdb3}

9. clock source {line [primary | bits | independent] | internal [independent] | free-running}

10. ds0-group ds0-group-number timeslots timeslot-list type {e&m-delay-dial | e&m-fgd | e&m-immediate-start | e&m-wink-start | ext-sig | fgd-eana | fxo-ground-start | fxo-loop-start | fxs-ground-start | fxs-loop-start}
or
pri-group [timeslots range]

11. voice-port {slot-number/subunit-number/port | slot/port:ds0-group-number}

12. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

card type {e1 | t1} slot subslot

Example:

Router(config)# card type t1 0 0

Sets or changes the card type to E1 or T1.

slot—Specifies the slot number. Range can be 0 to 6, depending on the platform.

subslot—Specifies the VWIC slot number. Range can be 0 to 3, depending on the host module or platform.

When the command is used for the first time, the configuration takes effect immediately. A subsequent change in the card type will not take effect unless you enter the reload command or reboot the router.

Note When you are using the card type command to change the configuration of an installed card, you must enter the no card type {e1 | t1} slot subslot command first. Then enter the card type {e1 | t1} slot subslot command for the new configuration information.

Step 4 

voice-card slot

Example:

Router(config)# voice card 1

Enters voice card interface configuration mode.

Specify the slot location using a value from 0 to 5.

Step 5 

codec complexity {flex [reservation-fixed {high 
| medium}] | high | medium}
Example:

Router(config-voicecard)# codec complexity flex

Specifies the codec complexity based on the codec standard you are using.

flex—Up to 16 calls can be completed per Digital Signal Processor (DSP). The number of supported calls varies from 6 to 16, depending on the codec used for a call. In this mode, reservation for analog Voice Interface Cards (VIC) may be needed for certain
applications such as CAMA E-911 calls because
oversubscription of DSPs is possible. If this is true, then the reservation-fixed option may be enabled. There is no reservation by default.

reservation-fixed—Not applicable to the VWIC or the T1/E1 VIC.

high—Up to six voice or fax calls can be completed per DSP, using the following codecs: G.711, G.726, G.729, G.729 Annex B, G.723.1, G.723.1 Annex A, G.728, and GSMEFR.

Note High-complexity codecs support lower call density than do medium-complexity codecs.

medium—Up to eight voice or fax calls can be completed per DSP, using the following codecs: G.711, G.726, G.729 Annex A, G.729 Annex B with Annex A, GSMFR, and fax relay.

Note All medium-complexity codecs are supported in high-complexity codecs.

The keyword that you specify for the codec complexity command affects the codecs available when you use the codec dial peer voice configuration command. If you select a codec that is not available, an error message appears.

You cannot change codec complexity while DS0 groups are defined. If they are already set up, follow these steps:

1. Shut down the voice port associated with the controller.

2. Remove the DS0 group or PRI group under the T1 or E1 controller.

3. Enter the voice-card slot command, and then change the codec complexity.

Note This procedure to change codec complexity applies only to T1 and E1 controllers. This is not valid for analog voice ports.

Step 6 

controller {e1 | t1} slot/port

Example:

Router(config-voicecard)# controller t1 0/0

Enters controller configuration mode for the VWIC.

Valid values for slot are 0 through 5 and for port are 0 and 1.

Step 7 

framing {sf | esf}

or

framing {crc4 | no-crc4}

Example:

Router(config-controller)# framing esf

Example:

Router(config-controller)# framing crc4

Specifies a frame type.

The controller command must be entered before this command can be used.

The frame type for T1 controllers can be specified as sf for superframe or esf for extended superframe.

The frame type for E1 controllers can be specified as crc4 or no-crc4.

Step 8 

linecode {ami | b8zs}

or

linecode {ami | hdb3}

Example:

Router(config-controller)# linecode b8zs

Example:

Router(config-controller)# linecode hdb3

Specifies a line encoding for a controller.

The controller command must be entered before this command can be used.

Line-code value for T1 can be ami or b8zs.

Line-code value for E1 can be ami or hdb3.

Step 9 

clock source {line [primary | bits | indepen- dent] | internal [independent] | free-running}

Example:

Router(config-controller)# clock source line independent

Specifies the clock source.

When both ports are set to line clocking with no primary specification, port 0 is the default primary clock source and port 1 is the default secondary clock source.

When both ports are set to line and one port is set as the primary clock source, the other port is by default the backup or secondary source and is loop-timed.

If one port is set to clock source line and the other is set to clock source internal, the internal port recovers clock from the clock source line port if the clock source line port is up. If it is down, then the internal port generates its own clock.

If both ports are set to clock source internal, there is only one clock source—internal.

The optional keywords primary and bits appear in the command-line interface, but they have no impact on this particular configuration.

The independent keyword expands on the clock source internal and clock source line to specify that the port can operate on an independent clocking domain. Port 0 is the default primary clock source, and port 1 is the default secondary clock source and is loop-timed. With independent clocking enabled, this dependency no longer exists, so the independent keyword means that both ports can be independently clocked.

Note When independent clocking is configured, the controller will support only one channel group and no voice applications. If more than one channel group is configured, the following error message occurs:

channel-group 2 timeslots 3
%Channel-group already created.
%Only 1 channel-group can be configured with 
independent clocking.
%Insufficient resources to create channel 
group
 
        

When you are configuring the clock source independent and no clock source independent, the channel group has to be removed from this configuration.

The free-running keyword specifies a free-running clock derived from the oscillator on the motherboard, which is used only for testing and back-to-back connections.

Step 10 

ds0-group ds0-group-number timeslots timeslot-list type {e&m-delay-dial | e&m-fgd | e&m-immediate-start | e&m-wink-start | ext-sig | fgd-eana | fxo-ground-start | fxo-loop-start | fxs-ground-start | fxs-loop-start}

or

pri-group [timeslots range]

Example:

Router(config-controller)# ds0-group 12 timeslots 1-3 type fxs-loop-start

or

Example:
Router(config-controller)# pri-group timeslots 
1-5

(Voice only) Defines the T1 channels for use by compressed voice calls and the signaling method the router uses to connect to the PBX or central office.

Set up DS0 groups after you have specified codec complexity in the voice-card configuration.

ds0-group-number—Value from 0 to 23 that identifies the DS0 group.

The ds0-group command automatically creates a logical voice port that is numbered as follows: slot/port:ds0-group-number. Although only one voice port is created, applicable calls are routed to any channel in the group.

The timeslot-list argument is a single number, numbers separated by commas, or a pair of numbers separated by a hyphen to indicate a range of time slots.

The signaling method selection for the type keyword depends on the connection that you are making:

The E&M interface allows connection for PBX trunk lines (tie lines) and telephone equipment.

The Foreign Exchange Station (FXS) interface allows connection of basic telephone equipment and PBX.

The Foreign Exchange Office (FXO) interface is for connecting the CO to a standard PBX interface where permitted by local regulations; it is often used for off-premises extensions (OPXs).

or

Specifies that the controller should be set up as a PRI interface.

For T1, the last defined channel is the D channel.

If a controller is configured as PRI, individual channel groups cannot be configured on that controller.

The controller command must be entered before this command can be used.

Note To use this command to create a PRI group, you must first enter the isdn switch-type command in global configuration mode.

 

Step 11 

voice-port {slot-number/subunit-number/port | slot/port:ds0-group-number}

Example:
Router(config-controller)# voice-port 3/0:0

Enters voice port configuration mode and specifies the voice port.

The slot-number argument identifies the slot where the VIC is installed. Valid entries are from 0 to 3, depending on the slot in which it has been installed.

The subunit-number identifies the subunit on the VIC where the voice port is located. Valid entries are 0 or 1.

The port argument identifies the voice port number. Valid entries are 0 and 1.

or

The slot argument is the slot in which the voice port adapter is installed. Valid entries are from 0 to 3.

The port argument is the voice interface card location. Valid entries are 0 to 3.

The ds0-group-number argument indicates the defined DS0 group number. Each defined DS0 group number is represented on a separate voice port. This allows you to define individual DS0s on the digital T1/E1 card.

Step 12 

exit

Example:
Router(config-voiceport)# exit

Exits controller configuration mode and returns the router to privileged EXEC mode.

Configuration Examples for T1/E1 VWIC3s with voice support

This section shows an example for the 2-port VWIC3 in T1 configuration.

Example: 2-Port T1 VWIC3

In this example, the 2-port VWIC3 is set to card type T1 and is configured with default settings. Channel groups are defined on ports 0 and 1.

informers# sh run 
Building configuration...
 
   
! voice-card 0:
! Mixed PVDM3 and PVDM2 C5510 DSP cards detected.
! Mixed DSP types in this slot is an unsupported configuration.
! PVDM2 C5510 DSP cards have been disabled.
Warning! DSPs1, 2, 3, 4, 5, 6,  in slot 0 are using non-default firmware from flash:
This is not recommended, the default version is 27.0.200
 
   
Current configuration : 2377 bytes
!
! Last configuration change at 13:59:20 PST Wed Mar 10 2010
!
version 15.1
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
!
hostname informers
!
boot-start-marker
boot system flash:c3900e-universalpi13k9-mz.SSA.argot
boot-end-marker
!
card type t1 0 1 
card type e1 0 2 
logging buffered 8000
no logging console
enable password lab
!
no aaa new-model
!         
clock timezone PST 16
!
network-clock-participate wic 1 
no network-clock-participate wic 2 
network-clock-select 1 T1 0/1/0
no ipv6 cef
ip source-route
!
!
ip cef
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-ni
!
!
!         
voice-card 0
 codec complexity medium
!
!
!
voice service pots
!
voice service voip
!
!
!
!
!
license udi pid C3900-SPE250/K9 sn FHH1334001J
!
!
!
redundancy
!
!
crypto ikev2 diagnose error 50
!
!         
controller T1 0/1/0
 cablelength long 0db
 ds0-group 1 timeslots 1-24 type e&m-immediate-start
!
controller T1 0/1/1
 cablelength long 0db
 pri-group timeslots 1-24
!
!
controller E1 0/2/0
!
! 
!
!
!
!         
!
!
interface GigabitEthernet0/0
 ip address 1.2.146.10 255.255.0.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/3
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1/1:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
interface Serial0/1/2:1
 no ip address
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 223.255.254.0 255.255.255.0 1.2.0.1
!
!
!
!         
!
nls resp-timeout 1
cpd cr-id 1
!
!
control-plane
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/1/0:1
!
voice-port 0/1/1:23
!
!
mgcp fax t38 ecm
!
!
!
!
!         
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 transport output all
 flowcontrol hardware
line aux 0
line vty 0 4
 session-timeout 300 
 exec-timeout 0 0
 password lab
 no login
 transport input all
!
exception data-corruption buffer truncate
scheduler allocate 20000 1000

end

Additional References

Related Documents

Related Topic
Document Title

Cisco IOS commands

Cisco IOS Master Commands List, All Releases

Information about the Second-Generation 1- and 2-Port T1/E1 Multiflex Trunk Voice/WAN Interface Cards

Second-Generation 1- and 2-Port T1/E1 Multiflex Trunk Voice/WAN Interface Cards

General information about voice configuration and command reference

Cisco IOS Voice Command Reference, Release 12.3T

General information on Cisco IOS Voice Port Configuration

Cisco IOS Voice Port Configuration Guide, Release 12.4T

Information and instructions for voice port configuration and hardware echo cancellation

Configuring Hardware Echo Cancellation on T1/E1 Multiflex Voice/WAN Interface Cards

Information on features and configuration samples for unframed E1(G703)

G.703 Configuration for Multiflex Voice/WAN Interface Cards on Cisco 2600 and 3600 Series Routers


Standards

Standard
Title

ITU-T G.164

Echo Suppressors

ITU-T G.165

Echo Cancellers

ANSI T1.168

Digital Echo Cancellers


MIBs

MIB
MIBs Link

RFC 1406 MIB

T1 CSU MIB Support

Port Module MIB

T1/E1 Line Status Reporting

To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

RFC 1406

Definitions of Managed Objects for the DS1 and E1 Interface Types


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html


Feature Information for Voice and Data Support on VWIC3s

Table 1 lists the release history for this feature.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 1 lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.


Table 1 Feature Information for Voice and Data Support on VWIC3s

Feature Name
Releases
Feature Information

1-Port and 2-Port VWIC3s - Voice WAN Interface Cards

15.0(1)M3, 15.1(2)T, 15.1(1)T1

Digital voice support is introduced on VWIC3-1MFT-G703(T1/E1), and VWIC3-2MFT-G703(T1/E1).

This feature is supported on Cisco 2901, 2911, Cisco 2921, Cisco 2951, Cisco 3925, Cisco 3925E, 3945, and Cisco 3945E.

The following sections provide information about this feature:

Information About Voice and Data support on VWIC3s

How to Configure Voice Support on T1/E1 VWIC3s