Guest

Cisco TDM Gateways

Configuring the Cisco Fourth-generation T1/E1 Voice and WAN Network Interface Module

  • Viewing Options

  • PDF (556.1 KB)
  • Feedback

Table of Contents

Configuring the Cisco Fourth-Generation T1/E1 Voice and WAN Network Interface Module

Supported Features

Restrictions

Platform and Hardware Support

Configuring the Cisco Network Interface Module

Configuring the Card Type

Changing the Card Type

Configuring the T1/E1 Network Interface Module for Data

Configuring T1/E1 for Voice

Configuration Examples T1/E1 for Voice

Encapsulation

H.323

Session Initiation Protocol

Configuration Examples for Data T1/E1

Configuring DSP Resources

DSP-farm Profiles

Conferenc ing

Configuring a DSP-farm Profile

Cisco Unified Border Element

Cisco Unified Survivable Remote Site Telephony

IVR and TCL

Troubleshooting

Related Documents

MIBs

RFCs

Configuring the Cisco Fourth-Generation T1/E1 Voice and WAN Network Interface Module

First Published: June 24, 2013

The Cisco Fourth-Generation T1/E1 Voice and WAN Network Interface Modules (NIM) are inserted into the NIM slot on the Cisco 4000 Series Integrated Services Router to provide T1, fractional T1, E1, and fractional E1 support for data and voice applications.


Note The Cisco Fourth-Generation T1/E1 Voice and WAN Network Interface Module requires a PVDM4 to be installed for voice support.


Table 1 lists the Cisco Fourth-Generation T1/E1 Voice and WAN Network Interface Modules.

 

Table 1 Cisco Fourth-Generation T1/E1 Voice and WAN Network Interface Modules

Network Interface Module
Description

NIM-1CE1T1-PRI

1-port channelized data module. Supports 24/31 channel groups for T1/E1 per port.

NIM-2CE1T1-PRI

2-port channelized data module. Supports 24/31 channel groups for T1/E1 per port.

NIM-8CE1T1-PRI

8-port channelized data module. Supports 24/31 channel groups for T1/E1 per port.

NIM-1MFT-T1/E1

1-port clear channel data and voice T1/E1 module. Supports 2 channel groups per port.

NIM-2MFT-T1/E1

2-port clear channel data and voice T1/E1 module. Supports 2 channel groups per port.

NIM-4MFT-T1/E1

4-port clear channel data and voice T1/E1 module. Supports 2 channel groups per port.

NIM-8MFT-T1/E1

8-port clear channel data and voice T1/E1 module. Supports 2 channel groups per port.

Supported Features

  • Data and voice support on T1/E1
  • TCL and IVR application
  • Support for DSP Media Services on the motherboard
  • Support for Cisco Unified Border Element
  • Support for Cisco Survivable Remote Site Telephony

Restrictions

  • When you configure a media address pool for TDM gateways and CUBE, you must configure the media address pool port range in voice service VoIP configuration mode.
  • The NIM-8T1E1-PRI module is only supported on Cisco IOS XE releases 3.10.3, 3.11.2, and 3.12.

Platform and Hardware Support

The Cisco Fourth-Generation T1/E1 Voice and WAN Network Interface Module is supported on the Cisco 4451-X Integrated Services Router and runs on Cisco IOS XE Release 3.9S and later.

The Cisco Fourth-Generation T1/E1 Voice and WAN Network Interface Module supports only the Cisco Packet Voice Digital Signal Processor Module version 4 (PVDM4).

Configuring the Cisco Network Interface Module

Configuring the Card Type

To configure the T1/E1 network interface module for T1 or E1 operation, perform the following task.


Note The T1/E1 network interface module will not be operational until a card type is configured.


SUMMARY STEPS

1. enable

2. configure terminal

3. card type { t1 | e1 } slot subslot

DETAILED STEPS

 

Command or Action
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

card type { t1 | e1 } slot subslot

 

 

Router(config)# card type t1 0 0

Specifies T1 or E1 connectivity for the network interface module.

Changing the Card Type

To change a card type from T1 to E1, or from E1 to T1, perform the following task:

SUMMARY STEPS

1. enable

2. configure terminal

3. no card type { t1 | e1 } slot subslot

4. card type { t1 | e1 } slot subslot

5. exit

6. write

7. reload

8. boot

DETAILED STEPS

Command or Action
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

no card type { t1 | e1 } slot subslot

 

 

Router(config)# no card type t1 0 2

(Optional) Removes the previous configuration.

Step 4

card type { t1 | e1 } slot subslot

 

 

Router(config)# card type e1 0 2

Specifies T1 or E1 connectivity for the network interface module.

Step 5

exit

 

Router(config)# exit

Exits the card configuration mode and returns to global configuration mode.

Step 6

write

 

Router(config)# write

Rebuilds the router configuration.

Step 7

reload

 

Router(config)# reload

Reloads router so that changes can take effect. After this command executes, the router goes into the ROM monitor (rommon) mode.

Step 8

boot

 

Router(rommon)# boot

Boots the router with the configuration for the newly selected card type.

Configuring the T1/E1 Network Interface Module for Data

To configure a T1 or E1 interface for data support, perform this task:

SUMMARY STEPS

1. enable

2. configure terminal

3. controller { t1 | e1 } slot / subslot / port

4. framing { sf | esf }

or

framing { crc4 | no-crc4 }

5. linecode { ami | b8zs }

or

linecode { ami | hdb3 }

6. fdl { att | ansi | both }

7. clock source {internal | line [primary | secondary] | network}

8. line-termination { 75-ohm | 120-ohm }

9. loopback { diagnostic | local { payload | line } | remote { iboc | esf { payload | line }}}

10. cablelength long db-loss-value

or

cablelength short length

11. channel group channel-group-number { timeslots range [ speed kbps ] | unframed }

12. national reserve N sa4 sa5 sa6 sa7 sa8

13. crc-threshold value

14. yellow { generation | detection }

15. bert pattern pattern interval time

DETAILED STEPS

 

Command or Action
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

controller { t1 | e1 } slot / subslot / port

 

Router(config)# controller t1 0/1/1

Enters controller configuration mode for the network interface module.

  • Valid values for slot is 0, subslot is 1 to 3, and port is 0 or 1.

Step 4

framing { sf | esf }


 

or

framing { crc4 | no-crc4 }

 

Router(config-controller)# framing esf

In T1 configurations, specifies super frame ( sf ) or extended super frame ( esf ) as the frame type for data lines. Default is esf .

In E1 configurations, specifies cyclic redundancy check 4 ( crc4 ) or no-crc4 as the frame type for data lines. Default is crc4 .

Step 5

linecode { ami | b8zs }


or

linecode { ami | hdb3 }

 

Router(config-controller)# linecode b8zs

In T1 configurations, specifies alternate mark inversion (AMI) or bipolar 8-zero substitution (b8zs) as the linecode. Default is b8zs .

In E1 configurations, specifies AMI or high-density bipolar 3 (hdb3) as the linecode. Default is hdb3 .

Note When using linecode AMI, we recommend that you select 56 kbps as the speed or make sure that the channel groups created do not contain all the timeslots. See Step 11Step 11. This is to avoid exceeding the “15 zeroes” threshold specified by standards.

Step 6

fdl { att | ansi | both }

 

Router(config-controller)# fdl both

T1 only. Sets the facility data link (fdl) exchange standard for T1 interfaces using esf framing. You can select the ATT standard (ATT TR54016), the ANSI standard (ANSI T1.403), or both standards. Default is ansi . To disable fdl, enter the no fdl command.

Step 7

clock source { internal | line [ primary | secondary ] | network }

 

Router(config-controller)# clock source network

Specifies the clock source. The options are as follows:

  • internal—Sets the controller framer as the clock master.

The clock source i nternal command is only applicable with the channel-group command and the pri-group (for data) command.

Note The pri-group command is supported on the NIM-xCE1T1-PRI for data without the keyword voice-dsp.

  • line—Specifies the phase-locked loop (PLL) on a port. When both a primary port and a secondary port are configured and the primary port fails, the PLL switches over to the secondary. When the PLL on the primary port becomes active again, the PLL automatically switches to the primary port.
  • network—Sets the controller to sync to the TDMSW clock for both TDM voice and data support. This configures the far end of the T1/E1 line as the clock line.

Default is line.

Step 8

line-termination { 75-ohm | 120-ohm }

 

Router(config-controller)# line-termination 75-ohm

E1 only. Sets the line termination on an E1 controller.

  • 75-ohm specifies 75-ohm unbalanced termination.
  • 120-ohm specifies 120-ohm balanced termination.

Step 9

loopback { diagnostic | local { payload | line } | remote { iboc | esf { payload | line }}}

 

Router(config-controller)# loopback remote esf line

Sets the loopback method for testing the interface. Options are:

  • diagnostic —Loops the transmit signal back to receive.
  • local —Puts the interface into local loopback mode at the payload or line level.
  • remote —Puts the interface into remote loopback mode through an inband bit oriented code (iboc) or, for T1 only, remote esf , which uses fdl codes to set payload or line levels.

Step 10

cablelength long db-loss-value

 

or

cablelength short length

 

Router(config-controller)# cablelength short 110

T1 only.The cablelength long command attenuates the pulse from the transmitter using pulse equalization and line build-out. This command applies to cables longer than 660 feet. Loss values are:

  • 0db
  • -7.5db
  • -15db
  • -22.5db

Default attenuation is 0db.

The cablelength short command sets transmission attenuation for cable lengths of 660 feet or less. When you use the cablelength short command, specify the length as follows:

  • 110 for cable lengths from 0 to 110 feet
  • 220 for cable lengths from 111 to 220 feet
  • 330 for cable lengths from 221 to 330 feet
  • 440 for cable lengths from 331 to 440 feet
  • 550 for cable lengths from 441 to 550 feet
  • 660 for cable lengths from 551 to 660 feet

There is no default cable length.

Step 11

channel group channel-group-number { timeslots range [ speed kbps ] | unframed }

 

 

Router(config-controller)# channel group 1 timeslots 1-4

Configures the serial WAN on a T1 or E1 interface by specifying channels and their timeslots.

For T1, values are as follows:

  • channel-group-number is from 0 to 23.
  • timeslots range is from 1 to 24.
  • Default value of speed for T1 is 64 kbps. Configuration of speed is optional.

For E1, values are as follows:

  • channel-group-number is from 0 to 30.
  • timeslots range is from 1 to 31.
  • Default value of speed for E1 is 64 kbps. Configuration of speed is optional.
  • unframed (E1 only) specifies that all 31 timeslots are to be used for data and that none are to be used for framing signals.

Step 12

national reserve N sa4 sa5 sa6 sa7 sa8

 

Router(config-controller)# national reserve 0 1 1 1 1 0

E1 only. Sets the six required national bits in E1 in the G.751 frame. Default is 1 1 1 1 1 1.

Step 13

crc-threshold value

 

Router(config-controller)# crc-threshold 500

T1 only. Defines a severely errored second by specifying the number of CRC errors that must occur in one second to reach the severely errored second state. Default is 320.

Step 14

yellow { generation | detection }

 

Router(config-controller)# no yellow detection

Enables generation and detection of yellow alarms. Default condition is that generation and detection of yellow alarms are enabled.

Use the no form of the command to disable yellow alarm detection.

Step 15

bert pattern pattern interval time

 

 

 

Router(config-controller)# bert pattern 2^11 interval 1440

(Optional) Activates the BERT with the chosen test pattern for a specified duration. Configure BERT patterns on the T1/E1 network interface modules as follows:

  • When the linecode is AMI, use patterns 2^11, 2^15, or 2^20-QRSS.
  • When the linecode is b8zs or hdb3, use patterns 2^11, 2^15, 2^20-QRSS, or 2^20-O.153.
  • The interval time is from 1 to 14,400 minutes.

Configuring T1/E1 for Voice

To configure a T1 or E1 interface for voice support, perform this task:

SUMMARY STEPS

1. enable

2. configure terminal

3. voice-card slot

4. codec complexity { flex [ reservation-fixed { high | medium }] | high | medium | secure }

5. exit

6. controller { t1 | e1 } slot / subslot / port

7. framing {sf | esf}
or
framing {crc4 | no-crc4}

8. linecode {ami | b8zs}
or
linecode { ami | hdb3 }

9. ds0-group ds0-group-number timeslots timeslot-list type { e&m-delay-dial | e&m-immediate-start | e&m-wink-start | fxo-ground-start | fxo-loop-start | fxs-ground-start | fxs-loop-start | none}

10. clock source {line [primary | secondary] | network}

11. tdm-group tdm-group-no timeslots timeslot-range type [ e&m | fxs [ loop-start | ground-start ] | fxo [ loop-start | ground-start ]]

12. voice-port { slot-number / subunit-number / port | slot / port : ds0-group-number }

13. pri-group timeslots timeslot-range [ nfas_d | service ][voice-dsp]

14. end

DETAILED STEPS

Command or Action
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

voice-card slot / subslot

 

Router(config)# voice-card 0/1

Enters voice card interface configuration mode.

  • Specify the slot location using a value from 0 to 5.

Step 4

codec complexity { flex [ reservation-fixed { high | medium }] | high | medium | secure }
 

Router(config-voicecard)# codec complexity flex

Specifies the codec complexity based on the codec standard that you are using. The number of calls that is supported on the router is dependent on the DSP density and the codec complexity.

  • flex —Provides support for both medium and high-complexity codec. The number of supported calls varies depending on the codec that is used for a call. In this mode, oversubscription of DSPs is possible. If reservations are needed for certain applications such as CAMA E-911 calls, you can enable the reservation-fixed option. There is no reservation by default.
  • high —Supports G.711, G.726, G.729, G.723.1, G.723.1 Annex A, G.729 Annex B, G.728, and GSMEFR.
  • medium —Supports G.711, G.726, G.729 Annex A, G.729 Annex B with Annex A, GSMFR, and fax relay.
  • secure —Specifies secure codec.

Note All medium-complexity codecs are supported in high-complexity codecs.

The keyword that you specify for the codec complexity command affects the codecs available when you use the codec dial peer voice configuration command. If you select a codec that is not available, an error message appears.

  • You cannot change codec complexity while DS0 groups are defined. If they are already set up, follow these steps:

1. Shut down the voice port associated with the controller.

2. Enter the voice-card slot command, and then change the codec complexity.

Note This procedure to change codec complexity applies only to T1 and E1 controllers. This procedure is not valid for analog voice ports.

Step 5

exit

 
Router(config-voicecard)# exit

Exits voice card configuration mode and returns to global configuration mode.

Step 6

controller { e1 | t1 } slot / subslot / port

 

Router(config)# controller t1 0/1/1

Enters controller configuration mode for the network interface module.

  • Valid values for slot is 0, subslot is 1 to 3, and port is 0 to 7.

Step 7

framing { sf | esf }

or

framing { crc4 | no-crc4 }

 

 

Router(config-controller)# framing esf

 

Router(config-controller)# framing crc4

Specifies a frame type.

  • The frame type for T1 controllers can be specified as sf for superframe or esf for extended superframe.
  • The frame type for E1 controllers can be specified as crc4 or no-crc4 .

Step 8

linecode { ami | b8zs }

or

linecode { ami | hdb3 }

 

 

Router(config-controller)# linecode b8zs

 

Router(config-controller)# linecode hdb3

Specifies a line encoding for a controller.

  • Line-code value for T1 can be ami or b8zs .
  • Line-code value for E1 can be ami or hdb3 .

Step 9

ds0-group ds0-group-number timeslots timeslot-list type { e&m-delay-dial | e&m-immediate-start | e&m-wink-start | fxo-ground-start | fxo-loop-start | fxs-ground-start | fxs-loop-start }

 

Router(config-controller)# ds0-group 12 timeslots 1-3 type fxs-loop-start

 

 

Defines the T1 channels for use by compressed voice calls and the signaling method that the router uses to connect to the PBX or central office.

  • Set up DS0 groups after you have specified codec complexity in the voice-card configuration.
  • ds0-group-number —Value from 0 to 23 that identifies the DS0 group.
  • The ds0-group command automatically creates a logical voice port that is numbered as follows: slot/port:ds0-group-number. Although only one voice port is created, applicable calls are routed to any channel in the group.
  • The timeslot-list argument is a single number, numbers separated by commas, or a pair of numbers separated by a hyphen to indicate a range of time slots.
  • The signaling method selection for the type keyword depends on the connection that you are making:

The E&M interface allows connection for PBX trunk lines (tie lines) and telephone equipment.

The Foreign Exchange Station (FXS) interface allows connection of basic telephone equipment and PBX.

The Foreign Exchange Office (FXO) interface is for connecting the CO to a standard PBX interface where permitted by local regulations; it is often used for off-premises extensions (OPXs).

 

Step 10

clock source { line [ primary | secondary ] | network }

 

Router(config-controller)# clock source network

Specifies the clock source. For voice, you can select either line or network. If internal clocking is required on the network interface module, configure clock source network.

  • line—Specifies the phase-locked loop (PLL) on a port. When both a primary port and a secondary port are configured and the primary port fails, the PLL switches over to the secondary. When the PLL on the primary port becomes active again, the PLL automatically switches to the primary port.
  • network—Sets the controller to sync to the TDMSW clock for both TDM voice and data support. This configures the far end of the T1/E1 line as the clock line.

Step 11

tdm-group tdm-group-no timeslots timeslot-list type [ e&m | fxs [ loop-start | ground-start ] | fxo [ loop-start | ground-start ]]

 

 

 

Router(config-controller)# tdm-group 20 timeslots 20 type fxs ground-start

 

(Optional) Defines TDM channel groups for the drop-and-insert (also called TDM Cross-Connect) function for a multiflex trunk interface card.

The tdm-group-no argument identifies the TDM group and is a value from 0 to 23 for T1 and from 0 to 30 for E1.

The timeslot-range argument indicates a range of time slots and is a single number, numbers separated by commas, or a pair of numbers separated by a hyphen. The valid range is from 1 to 24 for T1 and from 1 to 31 for E1.

The signaling method selection for the type keyword depends on the connection that you are making. The fxs and fxo options allow you to specify a ground-start or loop-start line.

Note The group numbers for controller groups must be unique. For example, a TDM group should not have the same ID number as a DS0 group or channel group.

Step 12

voice-port { slot-number / subunit-number / port | slot / port : ds0-group-number }

 
Router(config-controller)# voice-port 3/0:0

Enters voice port configuration mode and specifies the voice port.

  • The slot-number argument identifies the slot where the NIM is installed. Valid entries are from 0 to 3.
  • The subunit-number argument identifies the subunit on the NIM where the voice port is located. Valid entries are 0 or 1.
  • The port argument identifies the voice port number. Valid entries are 0 and 1.

or

  • The slot argument is the slot in which the voice port adapter is installed. Valid entries are from 0 to 3.
  • The port argument is the voice interface card location. Valid entries are 0 to 3.
  • The ds0-group-number argument indicates the defined DS0 group number. Each defined DS0 group number is represented on a separate voice port. This allows you to define individual DS0s on the digital T1/E1 card.

Step 13

pri-group timeslots timeslot-range [ nfas_d | service ][voice-dsp]

 

Router(config-controller)# pri-group timeslots 1-5

Specifies that the controller should be set up as ISDN PRI interface.

  • For T1,

timeslots range from 1 to 24

23rd channel is the D channel

  • For E1,

timeslots range from 1 to 31

15th channel is the D channel

Note Current “Service” is only for voice mgcp. So, when “Service” is selected, there is no “voice-dsp” required or needed.

Note NIM-xCE1T1-PRI—The option keyword voice-dsp is only available to the NIM-xCE1T1-PRI (x could be 1, 2, or 8) on the ISR 4000 series. Default is without the keyword voice-dsp.

The pri-group command on NIM-xCE1T1-PRI can be used for both data and voice.

When you use the pri-group command for data, then the voice-dsp keyword is not required.

When you use the pri-group command for voice, then the voice-dsp keyword is required.

Note NIM-xMFT-T1/E1—Since the pri-group command on the NIM-xMFT-T1/E1 is only used for voice, the keyword voice-dsp is not needed.

  • If a controller is configured as PRI, individual channel groups cannot be configured on that controller.
  • The controller command must be entered before this command can be used.

Step 14

end

 
Router(config-voiceport)# end

Returns to privileged EXEC mode.

Configuration Examples T1/E1 for Voice

The following example shows the running configuration of the router with the Fourth-Generation T1/E1 NIM installed and configured for voice support.

Router#sh run
Building configuration...
 
Current configuration : 3978 bytes
!
! Last configuration change at 17:12:33 UTC Wed Dec 3 2014
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
service internal
no platform punt-keepalive disable-kernel-core
!
hostname Router
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
card type t1 0 2
card type t1 0 3
logging buffered 10000000
!
no aaa new-model
!
!
no ip domain lookup
 
!
!
ipv6 rip vrf-mode enable
ipv6 multicast rpf use-bgp
!
!
subscriber templating
multilink bundle-name authenticated
!
!
isdn switch-type primary-5ess
!
!
voice service voip
address-hiding
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
bind control source-interface GigabitEthernet0/0/0
asymmetric payload full
!
!
application
service dsapp
param callWaiting TRUE
param callConference TRUE
param callTransfer TRUE
!
global
service default dsapp
!
!
voice-card 0/1
no watchdog
!
voice-card 0/2
dsp services dspfarm
no watchdog
!
voice-card 0/3
dsp services dspfarm
no watchdog
!
voice-card 0/4
no watchdog
!
license udi pid ISR4451-X/K9 sn FOC16474UZF
license accept end user agreement
license boot level appxk9
license boot level uck9
spanning-tree extend system-id
!
!
redundancy
mode none
!
controller T1 0/2/0
framing esf
linecode b8zs
cablelength long 0db
pri-group timeslots 1-24 voice-dsp
!
controller T1 0/3/0
shutdown
framing esf
linecode b8zs
cablelength long 0db
ds0-group 1 timeslots 1-4 type e&m-immediate-start
!
controller T1 0/3/1
framing esf
linecode b8zs
cablelength long 0db
channel-group 1 timeslots 1-24
!
!
vlan internal allocation policy ascending
!
ip tftp source-interface GigabitEthernet0/0/0
!
!
interface GigabitEthernet0/0/0
ip address 1.4.33.45 255.255.0.0
negotiation auto
no cdp enable
!
interface GigabitEthernet0/0/1
no ip address
shutdown
negotiation auto
no cdp enable
!
interface GigabitEthernet0/0/2
no ip address
shutdown
negotiation auto
no cdp enable
!
interface GigabitEthernet0/0/3
no ip address
shutdown
negotiation auto
no cdp enable
!
interface Service-Engine0/1/0
!
interface Service-Engine0/2/0
!
interface Service-Engine0/3/0
!
interface Serial0/2/0:23
encapsulation hdlc
isdn switch-type primary-5ess
no cdp enable
!
interface Serial0/3/1:1
no ip address
!
interface Service-Engine0/4/0
!
interface GigabitEthernet0
no ip address
shutdown
negotiation auto
!
interface Vlan1
no ip address
shutdown
!
ip default-gateway 1.4.0.1
ip forward-protocol nd
no ip http server
no ip http secure-server
ip route 223.255.0.0 255.255.0.0 1.4.0.1
!
!
control-plane
!
!
voice-port 0/2/0:23
!
voice-port 0/3/0:1
!
voice-port 0/1/0
!
voice-port 0/1/1
!
dial-peer voice 1000 voip
service dsapp
shutdown
destination-pattern 37..
session protocol sipv2
session target ipv4:1.4.31.70
codec g711ulaw
!
dial-peer voice 2000 pots
destination-pattern 38..
port 0/2/0:1
forward-digits all
!
dial-peer voice 1010 pots
destination-pattern 3710
port 0/1/0
!
!
line con 0
exec-timeout 0 0
stopbits 1
line vty 0 4
password lab
login
end
 

Encapsulation

To configure encapsulation on the interface:

1. enable

2. configure terminal

3. interface serial slot / subslot / port : channel-group

4. encapsulation {hdlc | frame-relay | ppp}

H.323

H.323 is an umbrella recommendation from the International Telecommunication Union (ITU) that defines the protocols to provide voice and video communication sessions on a packet network. The H.323 standard addresses call signaling and control, multimedia transport and control, and bandwidth control for point-to-point and multipoint sessions. For more information about H.323, see the Cisco IOS H.323 Configuration Guide .

For router configuration information, see the “Configuring H.323 Gateways” chapter of Cisco IOS H.323 Configuration Guide .

Session Initiation Protocol

Session Initiation Protocol (SIP) is a peer-to-peer, multimedia signaling protocol developed by the IETF (IETF RFC 3261). Session Initiation Protocol is ASCII-based. It resembles HTTP, and it reuses existing IP protocols (such as DNS and SDP) to provide media setup and teardown. For more information, see the Cisco IOS SIP Configuration Guide .

For router configuration information under SIP, see the ““Basic SIP Configuration” chapter of the Cisco IOS SIP Configuration Guide .

Voice gateways provide voice security through SIP enhancements within the Cisco IOS Firewall. SIP inspect functionality (SIP packet inspection and detection of pin-hole openings) is provided, as well as protocol conformance and application security. The user is given more granular control on the policies and security checks applied to SIP traffic, and the capability to filter unwanted messages. For more information, see “Cisco IOS Firewall: SIP Enhancements: ALG and AIC” at Cisco.com.

Configuration Examples for Data T1/E1

The following example shows the running configuration of the router with the Fourth-Generation T1/E1 NIM installed and configured for data.

Router# show running-config
Building configuration...
Current configuration : 2716 bytes
!
! Last configuration change at 14:07:42 UTC Sun Feb 3 2013
!
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
card type t1 0 2
!
no aaa new-model
 
!
ipv6 multicast rpf use-bgp
ipv6 multicast vrf Mgmt-intf rpf use-bgp
!
multilink bundle-name authenticated
!
license boot level appxk9
license boot level uck9
license boot level securityk9
spanning-tree extend system-id
!
!
redundancy
mode none
!
controller T1 0/2/0
framing esf
linecode b8zs
cablelength long 0db
channel-group 22 timeslots 11
!
controller T1 0/2/1
framing esf
linecode b8zs
cablelength long 0db
pri-group timeslots 1-24
!
controller T1 0/2/2
framing esf
linecode b8zs
cablelength long 0db
!
controller T1 0/2/3
framing esf
fdl both
linecode b8zs
cablelength long 0db
loopback remote esf line csu
!
controller T1 0/2/4
framing esf
linecode b8zs
cablelength long 0db
!
controller T1 0/2/5
framing esf
linecode b8zs
cablelength long 0db
!
controller T1 0/2/6
framing esf
linecode b8zs
cablelength long 0db
!
controller T1 0/2/7
framing esf
fdl both
linecode b8zs
cablelength long 0db
!
ip tftp source-interface GigabitEthernet0/0/0
!
interface GigabitEthernet0/0/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet0/0/1
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet0/0/2
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet0/0/3
no ip address
shutdown
negotiation auto
!
interface Serial0/2/0:22
no ip address
!
interface Serial0/2/1:23
encapsulation hdlc
isdn switch-type primary-5ess
no cdp enable
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
ip address 192.0.2.126 255.255.0.0
negotiation auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
ip route vrf Mgmt-intf 10.0.0.0 255.0.0.0 192.168.0.1
!
control-plane
!
line con 0
exec-timeout 0 0
stopbits 1
line vty 0 4
login
!
end
 

Configuring DSP Resources

The PVDM4 is a hardware module that provides DSP resources that enable Cisco Integrated Services Routers to provide voice, video, conference, transcoding, and other collaboration services.

DSP-farm Profiles

A DSP-farm is the collection of available DSP resources. DSP-farm profiles are created to allocate DSP-farm resources. A DSP-farm profile allows you to group DSP resources based on the service type. Under a DSP farm profile, you select the service type (conference, transcode, or Media Termination Point [MTP]), associate an application, and specify service-specific parameters such as codecs and maximum number of sessions. Applications associated with the profile, such as SCCP, can use the resources allocated under the profile. You can configure multiple profiles for the same service, each of which can register with one Cisco Unified Communications Manager group. The profile ID and service type uniquely identify a profile, allowing the profile to uniquely map to a Cisco Unified Communications Manager group that contains a single pool of Cisco Unified Communications Manager servers.

Conferencing

Voice conferencing involves adding several parties to a phone conversation. In a traditional circuit-switched voice network, all voice traffic passes through a central device such as a PBX. Conference services are provided within this central device. In contrast, IP phones normally send voice signals directly between phones, without the need to go through a central device. Conference services, however, require a network-based conference bridge.

In an IP telephony network using Cisco Unified Communications Manager, the Conferencing and Transcoding for Voice Gateway Routers feature provides the conference-bridging service. Cisco Unified Communications Manager uses a DSP farm to mix voice streams from multiple participants into a single conference-call stream. The mixed stream is played to all conference attendees, minus the voice of the receiving attendee.

The Ad Hoc and Meet-Me conferencing features are supported (a conference can be either of these types):

  • Ad Hoc—The person controlling the conference presses the telephone conference button and adds callers one by one.
  • Meet-Me—Participants call in to a central number and are joined in a single conference.

Participants whose end devices use different codec types are joined in a single conference; no additional transcoding resource is needed.

Configuring a DSP-farm Profile

Perform this procedure to define a DSP-farm. You must configure a separate profile for each conferencing, transcoding, and MTP profile.

SUMMARY STEPS

1. enable

2. configure terminal

3. voice-card slot / subslot

4. dsp services dspfarm

5. exit

6. dspfarm profile profile-identifier { conference | mtp | transcode [ universal ]}

7. description text

8. codec codec-type

9. maximum sessions number

10. associate application sccp

11. no shutdown

12. end

DETAILED STEPS

 

Command or Action
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

voice-card slot / subslot

 

Router(config)# voice-card 0/4

Enters voice-card configuration mode for the network module on which you want to enable DSP-farm services.

Step 4

dsp services dspfarm

 

Router(config-voicecard)# dsp services dspfarm

Enables DSP-farm services for the voice card.

Step 5

exit

 

Router(config-voicecard)# exit

Exits voice-card configuration mode.

Step 6

dspfarm profile profile-identifier { conference | mtp | transcode [ universal ]}

 

Router(config)# dspfarm profile 20 conference

Enters DSP-farm profile configuration mode to define a profile for DSP-farm services.

Note The profile-identifier and service type uniquely identify a profile. If the service type and profile-identifier pair is not unique, you are prompted to choose a different profile-identifier.

Step 7

description text

 

Router(config-dspfarm-profile)# description art_dept

(Optional) Includes a specific description about the Cisco DSP-farm profile.

Step 8

codec codec-type

 

Router(config-dspfarm-profile)# codec ilbc

Specifies the codecs supported by a DSP farm profile.

  • Repeat this step for each codec supported by the profile.

Note Hardware MTPs support only G.711 a-law and G.711 u-law. If you configure a profile as a hardware MTP, and you want to change the codec to something other than G.711, you must first remove the hardware MTP by using the no maximum sessions hardware command.

Note Only one codec is supported for each MTP profile. To support multiple codecs, you must define a separate MTP profile for each codec.

Step 9

maximum sessions number

or

maximum sessions { hardware | software } number

 

Router(config-dspfarm-profile)# maximum sessions 4

Specifies the maximum number of sessions that are supported by the profile.

  • number —Range is determined by the available registered DSP resources. Default is 0.

Note The hardware and software keywords apply only to MTP profiles.

Step 10

associate application sccp

 

Router(config-dspfarm-profile)# associate application sccp

Associates the SCCP protocol to the DSP-farm profile.

Step 11

no shutdown

 

Router(config-dspfarm-profile)# no shutdown

Enables the profile, allocates DSP-farm resources, and associates the application.

Step 12

end

 

Router(config-dspfarm-profile)# end

Exits DSP-farm profile configuration mode.

Cisco Unified Border Element

Cisco Unified Border Element (Cisco UBE) is a session border controller that provides the necessary services for interconnecting independent Unified Communications networks securely, flexibly, and reliably. Media packets can flow either through the gateway (thus hiding the networks from each other) or around the border element, if so configured. The Cisco UBE is typically used to connect enterprise networks to service provider SIP trunks, or to interconnect different nodes in an enterprise network where protocol or feature incompatibilities exist, or where extra secure demarcation between segments of the network is needed.

The Cisco Unified Border Element provides the following network-to-network interconnect capabilities:

  • Session Management: Real-time session setup and tear-down services, call admission control, ensuring QoS, routing of calls if an error occurs, statistics, and billing.
  • Interworking: H.323 and SIP protocol conversion; SIP normalization; DTMF conversion, transcoding, codec filtering.
  • Local Transcoder Interface (LTI) for audio transcoding.

For more information, see the Cisco Unified Border Element Configuration Guide at Cisco.com.

Cisco Unified Survivable Remote Site Telephony

Cisco Unified Survivable Remote Site Telephony (SRST) enables Cisco routers to provide call-handling support for Cisco IP phones when they lose connection to Cisco Unified Communications Manager (CUCM) installations or when the WAN connection is down. In a centralized deployment, under normal conditions, Cisco IP phones are controlled by the Cisco Unified Communications Manager located at a central site like the headquarters of an enterprise. When the connection to CUCM breaks, for example as a result of a failure in the network, Unified SRST automatically detects the failure and auto-configures the router to provide backup call processing functionality.

During a WAN failure, the router allows all the phones to re-register to the remote site router in SRST mode, allowing all inbound and outbound dialing to be routed off to the PSTN (on a backup FXO, BRI or PRI connection).

Unified SRST provides redundancy for both Cisco IP phones and analog phones to ensure that the telephone system remains operational during network failures. Both Skinny Client Control Protocol (SCCP) and Session Initiation Protocol (SIP) based Cisco IP phones are supported with Unified SRST.

When the WAN link or connection to the Cisco Unified Communications Manager is restored, call handling automatically reverts back to the Cisco Unified Communications Manager without the need for any human intervention.

For general Unified SRST information, see the Cisco Unified SRST System Administrator Guide .

For H.323, see H.323 Gateways and SRST on Cisco.com.

For MGCP, see MGCP Gateways and SRST on Cisco.com.

“Setting Up the Network”

“Setting Up Cisco Unified IP Phones”

“Setting Up Call Handling”

“Configuring Additional Call Features”

“Setting Up Secure SRST”

“Integrating Voice Mail with Cisco Unified SRST”

For SIP-specific SRST information, see the Cisco Unified SCCP and SIP SRST System Administrator Guide . To configure SIP SRST features, see the “ Cisco Unified SIP SRST 4.1” chapter.

IVR and TCL

IVR is a term that is used to describe systems that collect user input in response to recorded messages over telephone lines. User input can take the form of spoken words or, more commonly, dual tone multifrequency (DTMF) signaling.

For example, when a user makes a call with a debit card, an IVR application is used to prompt the caller to enter a specific type of information, such as a PIN. After playing the voice prompt, the IVR application collects the predetermined number of touch tones (digit collection), forwards the collected digits to a server for storage and retrieval, and then places the call to the destination phone or system. Call records can be kept and a variety of accounting functions can be performed.

The IVR application (or script) is a voice application designed to handle calls on a voice gateway, which is the router equipped with voice features and capabilities.

The prompts used in an IVR script can be either static or dynamic:

  • Static prompts are audio files referenced by a static URL. The name of the audio file and its location are specified in the Tool Command Language (TCL) script.
  • Dynamic prompts are formed by the underlying system assembling smaller audio prompts and playing them out in sequence. The script uses an API command with a notation form to instruct the system what to play. The underlying system then assembles a sequence of URLs, based on the language selected and audio file locations configured, and plays them in sequence. This provides simple Text-to-Speech (TTS) operations.

For example, dynamic prompts are used to inform the caller of how much time is left in their debit ccount, such as:

“You have 15 minutes and 32 seconds of call time left in your account.”


Note The above prompt is created using eight individual prompt files: youhave.au, 15.au, minutes.au, and.au, 30.au, 2.au, seconds.au, and leftinyouraccount.au. These audio files are assembled dynamically by the underlying system and played as a prompt based on the selected language and prompt file locations.


TCL is an interpreted scripting language. Because TCL is an interpreted language, scripts written in TCL do not have to be compiled before they are executed. TCL provides a fundamental command set, which allows for standard functions such as flow control (if, then, else) and variable management. By design, this command set can be expanded by adding extensions to the language to perform specific operations.

Cisco created a set of extensions, called TCL IVR commands, that allows users to create IVR scripts using TCL. Unlike other TCL scripts, which are invoked from a shell, TCL IVR scripts are invoked when a call comes into the gateway.

For more information on TCL IVR, see the Tcl IVR APi Version 2.0 Programming Guide .

Troubleshooting

Use the following commands to check the status of the modules.

  • show controller
  • show hw-module subslot
  • show interface serial
  • show platform hardware subslot (4400)

Related Documents

Related Topic
Document Title

Installation guide for the Cisco PVDM4

Installing the Cisco PVDM4

Installation guide for the Cisco Network Interface Module

Installing the Cisco Network Interface Module

Command reference information for interface and hardware components

Cisco IOS Interface and Hardware Component Command Reference

Installation of the Cisco 4451-X Series Integrated Services Router

Hardware Installation Guide for the Cisco 4451-X Integrated Services Router

Comprehensive command reference information for Cisco IOS voice commands

Cisco Unified Border Element (SP Edition) Command Reference: Unified Model

Configuration guides for different voice and video applications, H.332 networks, SIP devices, and Cisco Voice Gateway Routers.

Cisco Unified Border Element Configuration Guide Library, Cisco IOS XE Release 3S

System administrator’s guide for Cisco Unified SRST

Cisco Unified SCCP and SIP SRST System Administrator Guide .

Configuration information for Cisco Voice Gateway Routers that are configured for Cisco Unified Communications Manager

Cisco Unified Communications Manager and Cisco IOS Interoperability Guide

Regulatory compliance and safety information

Cisco Network Modules and Interface Cards Regulatory Compliance and Safety Information

MIBs

MIB
MIBs Link
  • CISCO-DSP-MGMT-MIB
  • CISCO ENTITY MIB
  • CISCO-ENTITY-ALARM-MIB
  • CISCO-ENTITY-SENSOR-MIB
  • CISCO-FRAME-RELAY-MIB
  • CISCO-SIP-UA-MIB
  • CISCO-SYSLOG-MIB
  • CISCO-VOICE-DIAL-CONTROL-MIB
  • CISCO-VOICE-IF-MIB
  • ENTITY-MIB
  • IF-MIB
  • RFC1315-MIB (Frame Relay MIB)
  • RFC1406-MIB (T1 MIB)

To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs

RFCs

RFC
Title

RFC 1315

Management Information Base for Frame Delay DTEs

RFC 1406

Definitions of Managed Objects for the DS1 and E1 Interface Types

RFC

SIP: Session Initiation Protocol