Guest

Cisco IOS Software Releases 12.4 T

VRF-Aware H.323 and SIP for Voice Gateways

  • Viewing Options

  • PDF (183.5 KB)
  • Feedback
VRF-Aware H.323 and SIP for Voice Gateways

Table Of Contents

VRF-Aware H.323 and SIP for Voice Gateways

Contents

Prerequisites for VRF-Aware H.323 and SIP for Voice Gateways

Restrictions for VRF-Aware H.323 and SIP for Voice Gateways

Information About VRF-Aware H.323 and SIP

How to Configure VRF-Aware H.323 and SIP for Voice Gateways

Prerequisites

Restrictions

Examples

Configuration Examples for VRF-Aware H.323 and SIP

VRF-Aware Voice Gateway: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

voice vrf

Glossary

Feature Information for VRF-Aware H.323 and SIP


VRF-Aware H.323 and SIP for Voice Gateways


First Published: December 22, 2006, OL-11379-01

VPN routing and forwarding (VRF) divides a physical router into multiple logical routers, each having its own set of interfaces and routing and forwarding tables. Adding VRF-awareness to voice gateways allows a voice gateway to exist in the same router as a customer edge (CE) or provider edge (PE) WAN router.

The VRF-Aware H.323 and SIP for Voice Gateways feature adds single voice VRF support to session-initiated protocol (SIP), H.323, and IP-to-IP gateways and to Cisco Survivable Remote Site Telephony (Cisco SRST) routers.

Finding Feature Information in This Module

Your Cisco IOS software release may not support all of the features documented in this module. To reach links to specific feature documentation in this module and to see a list of the releases in which each feature is supported, use the "Feature Information for VRF-Aware H.323 and SIP" section.

Finding Support Information for Platforms and Cisco IOS and Catalyst OS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for VRF-Aware H.323 and SIP for Voice Gateways

Restrictions for VRF-Aware H.323 and SIP for Voice Gateways

Information About VRF-Aware H.323 and SIP

How to Configure VRF-Aware H.323 and SIP for Voice Gateways

Configuration Examples for VRF-Aware H.323 and SIP

Additional References

Command Reference

Glossary

Feature Information for VRF-Aware H.323 and SIP

Prerequisites for VRF-Aware H.323 and SIP for Voice Gateways

Before you configure VRF-aware H.323 and SIP for voice gateways, you must do the following:

Be sure that you have the correct platform to support this feature. VRF-aware H.323 and SIP is supported on the following platforms:

For TDM-to-IP calls—Cisco 2600XM, 2691, 3700, 2800, 2801, 3800, 7200, AS5350XM, and AS5400XM

For IP-to-IP calls— Cisco 2600XM, 2691, 3700, 2800, 2801, 3800, 7301, 7200, AS5350XM, and AS5400XM

VRF support requires Cisco Express Forwarding switching to be enabled on the router. The above listed platforms all support Cisco Express Forwarding switching. However, customer edge (CE) or provider edge (PE) routers configured as voice gateways might require installation of additional voice interface cards and DSP modules.

Restrictions for VRF-Aware H.323 and SIP for Voice Gateways

Configuration restrictions for VRF-aware H.323 and SIP for voice gateways are as follows:

SIP proxy and registrar must be in the same VRF.

The following call types are not supported for voice VRF:

An IP-to-IP gateway and gatekeeper configured on the same router.

An IP-to-IP gateway with a VRF configured on one call leg and not on another call leg.

An IP-to-IP gateway with one VRF configured for the H.323 call leg and a different VRF configured for the SIP call leg.

Skinny Client Control Protocol (SCCP) on Cisco SRST routers.

SCCP on Cisco Unified Communications Manager Express (formerly known as Cisco Unified CallManager Express) routers.

SIP on Cisco Unified CME routers.

Call that involve transcoding, including both internal and external transcoders.

SIP calls support both TCP and UDP signaling. However, for H.323 calls, only TCP is supported. H.323 UDP signaling is not supported.

The following features are not supported by VRF-aware H.323 and SIP:

Call-fallback and RSVP features.

H.323 Annex E calls.

AAA and DNS components in voice-capable access routers. These routers communicate with AAA and DNS using the default routing table.

Information About VRF-Aware H.323 and SIP

Typically, service providers use a VRF between PE and CE routers to provide VPN support for customers. VRF is also used to segment data and voice traffic for improved traffic management, and VRF can be configured on an interface to process incoming packets according to the assigned VRF.

By configuring VRF-awareness on voice gateways you can specify a VRF for the voice traffic that is generated from within the gateway. The voice VRF is added to the VoIP service provider interface (SPI) of the gateway to send and receive signaling and media packets in the configured VRF. The SPI can send signaling and media packets only in the configured VRF, and receive signaling and media packets only from the configured VRF.

How to Configure VRF-Aware H.323 and SIP for Voice Gateways

To configure a voice VRF, you must shut down voice services on the gateway, assign a previously defined VPN VRF to the VoIP SPI, and then restart voice services.

This section describes the tasks required to configure VRF-aware H.323 and SIP for voice gateways.


Note If a voice VRF is not configured, signaling and media packets are sent using the default routing table.


Prerequisites

Be sure to check the following prerequisites before configuring a voice VRF:

To ensure there are no active calls on the voice gateway during a VRF change, you must shut down the voice gateway before you configure or make changes to a voice VRF.

If your configuration uses address binding, use the h323-gateway voip bind srcaddr ip-address command to bind the gateway to an interface that belongs to the voice VRF.

If the voice gateway configuration has H.323 RAS enabled, use the h323-gateway voip interface command to configure RAS on the interface that belongs to the voice VRF.

Restrictions

Restrictions for configuring VRF-aware H.323 and SIP are as follows:

If the voice gateway configuration has H.323 RAS enabled, the gatekeeper must be accessible to the gateway in the configured voice VRF.

When voice VRF is configured, the H.323 gateway and gatekeeper cannot communicate with each other if they are running on same router.

Voice VRF supports only the following call types:

A single VRF for SIP-to-SIP calls

A single VRF for H323-to-SIP calls

A single VRF for H323-to-H323 calls

A single VRF in IP-to-IP gateway call with a gatekeeper involved, but the gatekeeper is not on the same router.

A SIP SRST call

SUMMARY STEPS

1. enable

2. configure terminal

3. ip vrf vrfname

4. rd route-distinguisher

5. route-target {import | export | both} route-target-ext-community

6. exit

7. voice service voip

8. shutdown

9. exit

10. voice vrf vrfname

11. voice service voip

12. no shutdown

13. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

ip vrf vrfname

Example:

Router(config)# ip vrf vrf1

Defines a Virtual Private Network (VPN) routing/forwarding (VRF) instance and enters VRF configuration mode.

vrfname—Identifier for the VRF.

Step 4 

rd route-distinguisher

Example:

Router(config-vrf)# rd 1:1

Creates a routing and forwarding table for a VPN VRF.

route-distinguisher—Adds an 8-byte value to an IPv4 prefix to create a VPN IPv4 prefix.

Step 5 

route-target {import | export | both} route-target-ext-community

Example:

Router(config-vrf)# route-target export 1:2

Creates a list of import or export route target communities for the specified VRF.

import—Imports routing information from the target VPN extended community.

export—Exports routing information to the target VPN extended community.

both—Imports both import and export routing information to the target VPN extended community.

route-target-ext-community—Adds the route-target extended community attributes to the VRF's list of import, export, or both (import and export) route-target extended communities.

Step 6 

exit

Example:

Router(config-vrf)# exit

Exits VRF configuration mode.

Step 7 

voice service voip

Example:

Router(config)# voice service voip

Enters voice-service configuration mode.

Step 8 

shutdown

Example:

Router(config-voi-serv)# shutdown

Shuts down voice services.

Step 9 

exit

Example:

Router(config-voi-serv)# exit

Exits voice-service configuration mode.

Step 10 

voice vrf vrfname

Example:

Router(config)# voice vrf vrf1

Assigns a predefined VRF to voice services.

vrfname—Identifier for the VRF.

Step 11 

voice service voip

Example:

Router(config)# voice service voip

Enters voice-service configuration mode.

Step 12 

no shutdown

Example:

Router(config-voi-serv)# no shutdown

Restarts voice services.

Step 13 

end

Example:

Router(config-voi-serv)# end

Returns to privileged EXEC mode.

Examples

!
ip vrf vrf1
 rd 1:1
 route-target export 1:2
 route-target import 1:2
!
voice vrf vrf1
!
voice service voip
!!

Configuration Examples for VRF-Aware H.323 and SIP

This section provides an example configuration for a voice VRF configured on a voice gateway.

VRF-Aware Voice Gateway: Example

Router# show running config

Building configuration...

Current configuration : 1332 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router1
!
boot-start-marker
boot-end-marker
!
card type e1 4 0
card type t1 4 1
no logging buffered
no logging console
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 2
no network-clock-participate slot 4
ip cef
!
ip vrf stork-vrf
 rd 1:1
 route-target export 1:2
 route-target import 1:2
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice-card 2
 no dspfarm
!
voice-card 4
 no dspfarm
!
voice vrf stork-vrf
!
voice service voip
!
controller T1 4/0
 framing esf
 linecode b8zs
!
controller T1 4/1
 shutdown
 framing esf
 linecode b8zs
!
controller E1 4/0/0
 shutdown
!
controller E1 4/0/1
 shutdown
!
interface GigabitEthernet0/0
 no ip address
 no ip proxy-arp
 shutdown
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
!
ip route 0.0.0.0 0.0.0.0 9.13.32.1
!
ip http server
!
control-plane
!
voice-port 2/0/0
voice-port 2/0/1
!
gateway
!
line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
scheduler allocate 20000 1000
!
end

Additional References

The following sections provide references related to VRF-Aware H.323 and SIP for Voice Gateways.

Related Documents

Related Topic
Document Title

Troubleshooting VRF-aware services

VRF-Aware System Message Logging

IP Application Services Configuration

Cisco IOS IP Application Services Configuration Guide 12.4

IP Application Services Command Reference

Cisco IOS IP Application Services Command Reference 12.4

MPLS VPNs

MPLS Virtual Private Networks Configuration Guide 12.0(5)T

MPLS Command Reference

Cisco IOS Multiprotocol Label Switching Command Reference 12.4

All other Cisco IOS Command Reference guides

Various titles located at http://www.cisco.com/en/US/customer/products/ps6350/prod_command_reference_list.html

VRF-lite

Catalyst 4500 Series Switch Cisco IOS Software Configuration Guide, 12.2(25)SG, Configuring VRF-Lite

Routers Support Resources

Technical Support and Documentation for Routers

Information on Obtaining Documentation, Documentation Feedback, Cisco Product Security, Obtaining Technical Assistance, and Obtaining Additional Publications and Information

What's New publication, which lists all new and revised Cisco technical documentation.


Standards

Standard
Title

H.323 Annex E

Multiplexed call signaling over UDP (within H.323v4 and later).


MIBs

MIB
MIBs Link

No new or modified MIBs are supported, and support for existing MIBs has not been modified.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

No new or modified RFCs are supported, and support for existing RFCs has not been modified.


Technical Assistance

Description
Link

The Cisco Technical Support & Documentation website contains thousands of pages of searchable technical content, including links to products, technologies, solutions, technical tips, tools, and technical documentation. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/techsupport


Command Reference

This section documents new commands only.

New Command

voice vrf

voice vrf

To configure a voice VRF, use the voice vrf command in global configuration mode. To remove the voice VRF configuration, use the no form of this command.

voice vrf vrfname

no voice vrf vrfname

Syntax Description

vrfname

A name assigned to the voice vrf.


Command Default

No voice VRF is configured.

Command Modes

Global configuration

Command History

Release
Modification

12.4(11)XJ

This command was introduced.

12.4(15)T

This command was integrated into Cisco IOS Release 12.4(15)T.


Usage Guidelines

You must create a VRF using the ip vrf vrfname command before you can configure it as a voice VRF.

To ensure there are no active calls on the voice gateway during a VRF change, voices services must be shut down on the voice gateway before you configure or make changes to a voice VRF.

Examples

The following example shows that a VRF called vrf1 was created and then configured as a voice VRF:

ip vrf vrf1
 rd 1:1
 route-target export 1:2
 route-target import 1:2
!
voice vrf vrf1
!
voice service voip

Related Commands

Command
Description

ip vrf

Defines a VPN VRF instance and enters VRF configuration mode.


Glossary

VRF—VPN Routing and Forwarding table


Note See Internetworking Terms and Acronyms for terms not included in this glossary.


Feature Information for VRF-Aware H.323 and SIP

Table 1 lists the release history for this feature.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which Cisco IOS and Catalyst OS software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 1 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 1 Feature Information for VRF-Aware H.323 and SIP 

Feature Name
Releases
Feature Information

VRF-Aware H.323 and SIP

12.4(11)XJ

12.4(15)T

VRF awareness in voice stack of H.323 and SIP enables voice in TDM gateways and Session Border Controllers (SBC) to be in its own single VRF in VRF-lite and MPLS networks. Cisco SIP SRST is also available for the phones that are in the voice VRF.