Cisco ONS 15454 Procedure Guide, Release 4.0
Appendix A, CTC Information and Shortcuts
Downloads: This chapterpdf (PDF - 325.0KB) The complete bookPDF (PDF - 23.5MB) | Feedback

CTC Information and Shortcuts

Table Of Contents

CTC Information and Shortcuts

Displaying Node, Card, and Network Views

Manage the CTC Window

CTC Menu and Toolbar Options

CTC Mouse Options

Node View Shortcuts

Network View Tasks

Table Display Options

Equipment Inventory


CTC Information and Shortcuts


This appendix describes how to navigate in the Cisco Transport Controller (CTC), change CTC table data displays, and lists menu and tool options for the Cisco ONS 15454. This appendix also describes the shelf inventory data presented in CTC. For information about CTC, refer to the Cisco Transport Controller Operation chapter in the Cisco ONS 15454 Reference Manual, R4.0.

Displaying Node, Card, and Network Views

The Cisco Transport Controller provides three views of the ONS 15454 and ONS network:

Node view appears when you first log into an ONS 15454. This view shows a graphic of the ONS 15454 shelf and provides access to tabs and subtabs that you use to manage the node.

Card view provides access to individual ONS 15454 cards. This view provides a graphic of the card and provides access to tabs and subtabs that you use to manage the card.

Network view shows all the nodes in a ring. A Superuser can set up this feature so each user will see the same network view, or the user can create a custom view with maps. This view provides access to tabs and subtabs that you use to manage the network.

Table A-1 lists different actions for changing CTC views.

Table A-1 Change CTC Views 

To display:
Perform one of the following:

Node view

Log into a node; node view is the default view.

In network view, double-click a node icon, or right-click the node and select Open Node from the shortcut menu.

In network view, single-click a node icon, then select Go to Selected Object from the View menu.

From the CTC View menu, select Go to Other Node, then select the node you want from the shortcut menu.

Use the arrows on the CTC toolbar to navigate up or down views. For example, in network view, click a node, then click the down arrow.

Network view

In node view, click the up arrow or the Network View tool on the CTC toolbar.

From the View menu, select Go To Network View.

Card view

In node view, double-click a card or right-click the card and select Open Card.

In node view, single-click a card icon, then select Go to Selected Object from the View menu.

Use the arrows on the CTC toolbar to navigate up or down views. For example, in node view, click a card, then click the down arrow.


Manage the CTC Window

Different navigational methods are available within the CTC window to access views and perform management actions. You can double-click and right-click objects in the graphic area and move the mouse over nodes, cards, and ports to view popup status information (Figure A-1).

Figure A-1 CTC Node View With Popup Information

CTC Menu and Toolbar Options

The CTC window menu bar and toolbar provide primary CTC functions. Table A-2 shows the actions that are available from the CTC menu and toolbar.

Table A-2 CTC Menu and Toolbar Options 

Menu
Menu Option
Toolbar
Description

File

Add Node

Adds a node to the current session. See the "DLP-A62 Add a Node to the Current Session or Login Group" task on page 3-26.

Delete Selected Node

Deletes a node from the current session.

Lock CTC

Locks CTC without closing the CTC session. A user name and password are required to open CTC.

Print

Prints CTC data. See the "DLP-A138 Print CTC Data" task on page 7-2.

 

Export

Exports CTC data. See the "DLP-A139 Export CTC Data" task on page 7-4.

Exit

Closes the CTC session.

The exit icon only appears in the File menu.

Edit

Preferences

Displays the Preferences dialog box:

General tab—Allows you to change event defaults and manage preferences.

Login Node Groups tab—Allows you to create login node groups. See the "DLP-A61 Create Login Node Groups" task on page 3-25.

Map—Allows you to customize the network view. See the "DLP-A145 Change the Network View Background Color" task on page 10-8 and the "DLP-A268 Apply a Custom Network View Background Map" task on page 10-10.

Circuit—Allows you to change the color of circuit spans. See the "DLP-A232 Change Active and Standby Span Color" task on page 9-11.

Firewall—Sets the IIOP listener ports for access to the ONS 15454 through a firewall. See the "NTP-A27 Set Up the ONS 15454 for Firewall Access" procedure on page 4-18.

View

Go to Previous View

Displays the previous CTC view.

Go to Next View

Displays the next CTC view. Available only after you navigate to a previous view. Go to Previous and Go to Next are similar to forward and backward navigation in a web browser.

Go to Parent View

References the CTC view hierarchy: network view, node view, and card view. In card view, this command displays the node view; in node view, the command displays network view. Not available in network view.

Go to Selected Object View

Displays the object selected in the CTC window.

Go to Home View

Displays the login node in node view.

Go to Network View

Displays the network view.

Go to Other Node

Displays a dialog box allowing you to type in the node name or IP address of a a network node that you want to view.

Show Status Bar

Click this item to display or hide the status bar at the bottom of the CTC window.

Show Tool Bar

Click this item to display or hide the CTC toolbar.

Decreases the size of the map area in network view (toolbar only).

Increases the size of the map area in network view (toolbar only).

Increases the size of a selected area of the map in network view (toolbar only).

Tools

Circuits

Displays the following options:

Repair Circuits—Repairs incomplete circuits following replacement of the ONS 15454 AIP board. Refer to the Cisco ONS 15454 Troubleshooting Guide for more information.

Set Path Selector Attributes—Allows you to edit path protection configuration circuit path selector attributes. See the "DLP-A233 Edit Path Protection configuration Circuit Path Selectors" task on page 9-12.

Set Circuit State—Allows you to change a circuit state. See the "DLP-A230 Change a Circuit State" task on page 9-9.

Convert CTC Circuits to TL1 Cross Connects—If a cross-connect in a circuit gets deleted, this menu option allows a user to repair a circuit by separating an incomplete CTC circuit into TL1 cross-connects. Then, the user can replace the missing cross-connect. See the "NTP-A417 Upgrade TL1 Cross-Connects to CTC Circuits" procedure on page 9-15.

Upgrade TL1 Cross Connects to CTC Circuits—Allows you to convert TL1 cross-connects to CTC circuits. See the "NTP-A416 Convert a CTC Circuit to TL1 Cross-Connects" procedure on page 9-14.

Roll Circuit—Allows you to reroute live traffic without interrupting service.

Note This feature requires an ONS 15600 on your network. Refer to the Cisco ONS 15600 Procedure Guide.

Delete Rolls —This feature requires an ONS 15600 on your network. Refer to the Cisco ONS 15600 Procedure Guide.

Manage VLANs

Displays a list of VLANs that have been created and allows you to delete or create new VLANs. See Chapter 6, "Create Circuits and VT Tunnels."

Open TL1 Connection

Displays the TL1 session dialog box so you can create a TL1 session to a specific node. Refer to the Cisco ONS 15454 and Cisco ONS 15327 TL1 Command Guide.

Open IOS Connection

Displays the IOS command line interface dialog box if an IOS capable card (ML1000-2 or ML100T-12) is installed in the node. Refer to the Cisco ONS 15454 SONET/SDH ML-Series Multilayer Ethernet Card Software Feature and Configuration Guide.

Help

Contents and Index

Displays the online help window.

 

Manage Help

Displays the versions of online help loaded on your computer.

 

About CTC

Displays the software version and the nodes in the CTC session.


CTC Mouse Options

In addition to the CTC menu bar and toolbar, you can invoke actions by double-clicking CTC window items with your mouse, or by right-clicking an item and selecting actions from shortcut menus. Table A-3 lists the CTC window mouse shortcuts.

Table A-3 CTC Window Mouse Shortcuts 

Technique
Description

Double-click

Node in network view—Displays the node view.

Card in node view—Displays the card view.

Alarm/Event—Displays the object that raised the alarm or event.

Circuits—Displays the Edit Circuit window.

Right-click

Network view graphic area—Displays a menu that you can use to create a new domain, change the position and zoom level of the graphic image, save the map layout (if you have a Superuser security level), reset the default layout of the network view, and set, change, or remove the background image and color.

Node in network view—Displays a menu that you can use to open the node, reset the node icon position to the longitude and latitude set on the Provisioning > General tab, delete the node, fix the node position for auto layout, provision circuits, and update circuits with a new node.

Span in network view—Displays a menu that you can use to view information about the span's source and destination ports, the protection scheme, and the optical or electrical level. You can display the Circuits on Spans dialog box, which displays additional span information and allows you to perform path protection configuration protection switching. You can also perform span upgrades from this menu.

Card in node view—Displays a menu that you can use to open, delete, reset, and change cards. The card that is selected determines the commands that are displayed.

Card in card view—Displays a menu that you can use to reset the card, or go to the parent view (node view).

Empty slot in node view—Displays a menu with cards that you can select to preprovision the slot.

Move mouse cursor

Over node in network view—Displays a summary of node alarms and provides a warning if the node icon has been moved out of the map range.

Over span in network view—Displays circuit (node, slot, port) bandwidth and protection information.

Over card in node view—Displays card type and card status.

Over card port in node view—Displays card name, port state, and alarm profile status.

Over card port in card view—Displays port state, protection status (if applicable), and alarm profile status.


Node View Shortcuts

Table A-4 shows actions on ONS 15454 cards that you can perform by moving your mouse over the CTC window.

Table A-4 Node View Card-Related Shortcuts 

Action
Shortcut

Display card information

In node view, move your mouse over cards in the graphic to display tooltips with the card type, card present or card provisioned but not present, the highest level of alarm (if any), and the alarm profile used by the card.

Open, reset, or delete a card

In node view, right-click a card. Select Open to display the card in card view, Delete to delete it, or Reset to reset the card.

Preprovision a slot

In node view, right-click an empty slot. Select the card type that you want to provision the slot from the shortcut menu.

Change a card

In node view, right-click an OC-N card or a DS3 card, and select Change Card. In the Change Card dialog box, select the card type. Change card retains all card provisioning, including DCC terminations, protection, circuits, and ring.


Network View Tasks

Right-click the network view graphic area or a node, span, or domain to display shortcut menus. Table A-5 lists the actions that are available from the network view.

Table A-5 Network Management Tasks in Network View 

Action
Task

Open a node

Any of the following:

Double-click a node icon.

Right-click a node icon and choose Open Node from the shortcut menu.

Click a node and choose Go to Selected Object View from the CTC View menu.

From the View menu, choose Go To Other Node. Select a node from the Select Node dialog box.

Double-click a node alarm or event in the Alarms or History tab.

Move a node icon

Press the Ctrl key and the left mouse button simultaneously and drag the node icon to a new location.

Reset node icon position

Right-click a node and choose Reset Node Position from the shortcut menu. The node icon moves to the position defined by the longitude and latitude fields on the Provisioning > General tab in node view.

Provision a circuit

Right-click a node. From the shortcut menu, choose Provision Circuit To and select the node where you want to provision the circuit. For circuit creation procedures, see Chapter 6, "Create Circuits and VT Tunnels."

Update circuits with new node

Right-click a node and choose Update Circuits With New Node from the shortcut menu. Use this command when you add a new node and want to pass circuits through it.

Display a link end point

Right-click a span. From the shortcut menu, select Go To [node/slot/port] for the drop port you want to view. CTC displays the card in card view.

Display span properties

Do any of the following:

Move mouse over a span; the properties appear near the span.

Click a span; the properties appear in the upper left corner of the window.

Right-click a span; the properties appear at the top of the shortcut menu.

Perform a UPSR protection switch for an entire span

Right-click a network span and click Circuits. In the Circuits on Span dialog box, switch options are displayed in the UPSR Span Switching field.

Upgrade a span

Right-click a span and choose Upgrade Span from the shortcut menu.

Note For detailed span upgrade information and instructions, see Chapter 12, "Upgrade Cards and Spans."


Table Display Options

Right-clicking a table column displays a menu. Table A-6 shows table display options, which include rearranging or hiding CTC table columns and sorting table columns by primary or secondary keys. Figure A-2 shows the table shortcut menu.

Table A-6 Table Display Options 

Task
Click
Right-Click Shortcut Menu

Resize column

Left-click while dragging the header separator to the right or left.

Rearrange column order

Left-click while dragging the column header to the right or left.

Reset column order

Choose Reset Columns Order/Visibility.

Hide column

Choose Hide Column.

Show column

Choose Show Column > column_name.

Display all hidden columns

Choose Reset Columns Order/Visibility.

Sort table (primary)

Click a column header; each click changes sort order (ascending or descending).

Choose Sort Column.

Sort table (secondary sorting keys)

Press the Shift key and simultaneously click the column header.

Choose Sort Column (incremental).

Reset sorting

Choose Reset Sorting.

View table row count

View the number listed next to "Row Count," it is the last item on the shortcut menu.


Figure A-2 Table Shortcut Menu

Equipment Inventory

In node view, the Inventory tab (Figure A-3) displays information about the ONS 15454 equipment, including:

Delete Button—After highlighting a card with your mouse, use this button to delete the card from node view.

Reset Button—After highlighting a card with your mouse, use this button to reset the card.

Location—Identifies where the equipment is installed, either chassis or slot number.

Eqpt Type—Displays the type of equipment but not the specific card name, for example, OC-12 or DS-1.

Actual Eqpt Type—Displays the actual equipment type, for example, OC12 IR/STM4 SH 1310.

HW Part #—Displays the hardware part number; this number is printed on the top of the card or equipment piece.

HW Rev—Displays the hardware revision number.

Serial #—Displays the equipment serial number; this number is unique to each card.

CLEI Code—Displays the Common Language Equipment Identifier code.

Firmware Rev—Displays the revision number of the software used by the ASIC chip installed on the ONS 15454 card.

Figure A-3 Cisco ONS 15454 Hardware Information