Cisco IOS Multiprotocol Label Switching Configuration Guide, Release 12.2SR
VPLS Autodiscovery: BGP Based
Downloads: This chapterpdf (PDF - 241.0KB) The complete bookPDF (PDF - 10.81MB) | Feedback

VPLS Autodiscovery: BGP Based

Table Of Contents

VPLS Autodiscovery: BGP Based

Finding Feature Information

Contents

Prerequisites for VPLS Autodiscovery: BGP Based

Restrictions for VPLS Autodiscovery: BGP Based

Information About VPLS Autodiscovery: BGP Based

How the VPLS Feature Works

How the VPLS Autodiscovery: BGP Based Feature Works

How Enabling VPLS Autodiscovery Differs from Manually Configuring VPLS

Show Commands Affected by VPLS Autodiscovery: BGP Based

BGP VPLS Autodiscovery Support on a Route Reflector

How to Configure VPLS Autodiscovery: BGP Based

Enabling VPLS Autodiscovery: BGP Based

Prerequisites

Configuring BGP to Enable VPLS Autodiscovery

Customizing the VPLS Autodiscovery Settings

Configuration Examples for VPLS Autodiscovery: BGP Based

VPLS Autodiscovery: BGP Based: Basic Example

BGP VPLS Autodiscovery Support on Route Reflector: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Feature Information for VPLS Autodiscovery: BGP Based


VPLS Autodiscovery: BGP Based


First Published: February 19, 2007
Last Updated: November 20, 2009

VPLS Autodiscovery enables each Virtual Private LAN Service (VPLS) provider edge (PE) router to discover which other PE routers are part of the same VPLS domain. VPLS Autodiscovery also automatically detects when PE routers are added to or removed from the VPLS domain. You no longer need to manually configure the VPLS and maintain the configuration when a PE router is added or deleted. VPLS Autodiscovery uses the Border Gateway Protocol (BGP) to discover the VPLS members and to set up and tear down pseudowires in the VPLS.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature Information for VPLS Autodiscovery: BGP Based" section.

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for VPLS Autodiscovery: BGP Based

Restrictions for VPLS Autodiscovery: BGP Based

Information About VPLS Autodiscovery: BGP Based

How to Configure VPLS Autodiscovery: BGP Based

Configuration Examples for VPLS Autodiscovery: BGP Based

Additional References

Feature Information for VPLS Autodiscovery: BGP Based

Prerequisites for VPLS Autodiscovery: BGP Based

Before configuring VPLS Autodiscovery, if you are using a Cisco 7600 series router, perform the Cisco 7600 router-specific tasks listed in the section called "Virtual Private LAN Services on the Optical Service Modules" in the Cisco 7600 Series Router IOS Software Configuration Guide, 12.2SR.

Restrictions for VPLS Autodiscovery: BGP Based

VPLS Autodiscovery supports only IPV4 addresses.

VPLS Autodiscovery uses Forwarding Equivalence Class (FEC) 129 to convey endpoint information. Manually configured pseudowires use FEC 128.

VPLS Autodiscovery is not supported with Layer 2 Tunnel Protocol Version 3 (L2TPv3).

VPLS Autodisocovery is not supported with interautonomous system configurations.

You can configure both autodiscovered and manually configured pseudowires in a single virtual forwarding instance (VFI). However, the pseudowires cannot go to the same peer PE router.

If you manually configure a neighbor using the neighbor (VPLS) command after you have enabled VPLS Autodiscovery and both peers are in autodiscovery mode, manually configure the route target (RT) values to prevent each peer from receiving discovery data for that VPLS.

If you manually configure multiple pseudowires and target different IP addresses on the same PE router for each pseudowire, do not use the same virtual circuit identifier (VC ID) to identify the pseudowires terminated at the same PE router.

You cannot configure a pseudowire by manually configuring a neighbor on one PE router and using autodiscovery on the other PE router to configure the same pseudowire in the other direction.

Tunnel selection is not supported with autodiscovered neighbors.

You can have up to 16 route targets only per VFI.

The same RT is not allowed in multiple VFIs in the same PE router.

The BGP autodiscovery process does not support dynamic hierarchical VPLS. User-facing PE (U-PE) routers cannot discover the network-facing PE (N-PE) routers, and N-PE routers cannot discover U-PE routers.

Pseudowires for autodiscovered neighbors are provisioned with split horizon enabled. Therefore, manually configure the pseudowires for hierarchical VPLS. Make sure the U-PE routers do not participate in BGP autodiscovery for those pseudowires.

Do not disable split horizon on autodiscovered neighbors. Split horizon is required with VPLS Autodiscovery.

The provisioned peer address must be a /32 address bound to the peer's Label Distribution Protocol (LDP) router ID.

The peer PE router must be able to access the IP address that is used as the local LDP router ID. Even though the IP address need not be used in the xconnect command on the peer PE router, that IP address must be reachable.

VPLS Autodiscovery is supported on the Cisco 7600 router hardware. For details on supported shared port adapters and line cards, see the following documents:

Cisco 7600 Series Router Cisco IOS Software Configuration Guide

Release Notes for Cisco IOS Release 12.2SR for the Cisco 7600 Series Routers

Information About VPLS Autodiscovery: BGP Based

To understand VPLS Autodiscovery, you should understand the following concepts:

How the VPLS Feature Works

How the VPLS Autodiscovery: BGP Based Feature Works

How Enabling VPLS Autodiscovery Differs from Manually Configuring VPLS

Show Commands Affected by VPLS Autodiscovery: BGP Based

BGP VPLS Autodiscovery Support on a Route Reflector

How the VPLS Feature Works

VPLS allows Multiprotocol Label Switching (MPLS) networks to provide multipoint Ethernet LAN services, also known as Transparent LAN Services (TLS). All customer sites in a VPLS appear to be on the same LAN, even though those sites might be in different geographic locations.

How the VPLS Autodiscovery: BGP Based Feature Works

VPLS Autodiscovery enables each VPLS PE router to discover the other PE routers that are part of the same VPLS domain. VPLS Autodiscovery also tracks when PE routers are added to or removed from the VPLS domain. The autodiscovery and signaling functions use BGP to find and track the PE routers.

BGP uses the L2VPN Routing Information Base (RIB) to store endpoint provisioning information, which is updated each time any Layer 2 VFI is configured. Prefix and path information is stored in the L2VPN database, allowing BGP to make decisions on the best path. When BGP distributes the endpoint provisioning information in an update message to all its BGP neighbors, the endpoint information is used to configure a pseudowire mesh to support L2VPN-based services.

The BGP autodiscovery mechanism facilitates the configuration of L2VPN services, which are an integral part of the Cisco IOS Virtual Private LAN Service (VPLS) feature. VPLS enables flexibility in deploying services by connecting geographically dispersed sites as a large LAN over high-speed Ethernet in a robust and scalable IP MPLS network. For more information about BGP and the L2VPN address family in relation to VPLS Autodiscovery, see the following documents:

The section called "L2VPN Address Family" in the Cisco BGP Overview.

The document called BGP Support for the L2VPN Address Family

How Enabling VPLS Autodiscovery Differs from Manually Configuring VPLS

With VPLS Autodiscovery, you no longer need to manually set up the VPLS. The commands you use to set up VPLS Autodiscovery are similar to those you use to manually configure a VPLS, as shown in Table 1. VPLS Autodiscovery uses neighbor commands in L2VPN address family mode to distribute endpoint information to configure a pseudowire.

Table 1 VPLS Autodiscovery Configuration versus Manual VPLS Configuration

Manual Configuration of VPLS
VPLS Autodiscovery: BGP Based

l2 vfi vpls1 manual
 vpn id 100
 neighbor 10.10.10.1 encapsulation mpls
 neighbor 10.10.10.0 encapsulation mpls
 exit

l2 vfi vpls1 autodiscovery
 vpn id 100
 exit

router bgp 1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 bgp update-delay 1
 neighbor 10.1.1.2 remote-as 1
 neighbor 10.1.1.2 update-source Loopback1  
.
.
.
 address-family l2vpn vpls
 neighbor 10.1.1.2 activate
 neighbor 10.1.1.2 send-community extended  
exit-address-family 

When you configure VPLS Autodiscovery, you enter the l2vfi autodiscovery command. This command allows the VFI to learn and advertise the pseudowire endpoints. As a result, you no longer need to enter the neighbor (VPLS) command in L2 VFI configuration mode.

However, the neighbor (VPLS) command is still supported with VPLS Autodiscovery in L2 VFI command mode. You can use the neighbor (VPLS) command to allow PE routers that do not participate in the autodiscovery process to join the VPLS. You can also use the neighbor (VPLS) command with PE routers that have been configured using the Tunnel Selection feature. You can also use the neighbor (VPLS) command in hierarchical VPLS configurations that have U-PE routers that do not participate in the autodiscovery process and have split-horizon forwarding disabled.

Show Commands Affected by VPLS Autodiscovery: BGP Based

VPLS Autodiscovery changes the following show commands:

The show mpls l2transport vc command with the detail keyword has been updated to include FEC 129 signaling information for the autodiscovered VPLS pseudowires.

The show vfi command now displays information related to autodiscovered VFIs. The new information includes the VPLS ID, the route distinguisher (RD), the RT, and the router IDs of the discovered peers.

The show xconnect command has been updated with the rib keyword to provide RIB information about the pseudowires.

BGP VPLS Autodiscovery Support on a Route Reflector

VPLS Autodiscovery is normally run on PE routers to support endpoint discovery and the setup of pseudowires between the PEs (typically a full mesh). VPLS does not normally run on a BGP route reflector. In Cisco IOS Release 12.2(33)SRE, VPLS Autodiscovery support was added to route reflectors. The BGP route reflector can be used to reflect the BGP VPLS prefixes without having VPLS explicitly configured on the route reflector.

The route reflector does not participate in the autodiscovery, meaning that no pseudowires are set up between the route reflector and the PEs. The route reflector reflects the VPLS prefixes to other PEs, so that the PEs do not need to have a full mesh of BGP sessions. The network administrator configures only the BGP VPLS address family on the route reflector. For an example configuration of VPLS autodiscovery support on a route reflector, see the "BGP VPLS Autodiscovery Support on Route Reflector: Example" section.

How to Configure VPLS Autodiscovery: BGP Based

To configure VPLS Autodiscovery, perform the following tasks:

Enabling VPLS Autodiscovery: BGP Based (required)

Configuring BGP to Enable VPLS Autodiscovery (required)

Customizing the VPLS Autodiscovery Settings (optional)

Enabling VPLS Autodiscovery: BGP Based

Perform the following task to enable each VPLS PE router to discover the other PE routers that are part of the same VPLS domain.

Prerequisites

Before configuring VPLS Autodiscovery, perform the Cisco 7600 router-specific tasks listed in the "Virtual Private LAN Services on the Optical Services Modules" chapter in the Cisco 7600 Series Router Cisco IOS Software Configuration Guide, Release 12.2SR.

SUMMARY STEPS

1. enable

2. configure terminal

3. l2 vfi vfi-name autodiscovery

4. vpn id vpn-id

5. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

l2 vfi vfi-name autodiscovery

Example:

Router(config)# l2 vfi vpls1 autodiscovery

Enables VPLS Autodiscovery on the PE router and enters L2 VFI configuration mode.

Step 4 

vpn id vpn-id

Example:

Router(config-vfi)# vpn id 10

Configures a VPN ID for the VPLS domain.

Step 5 

exit

Example:

Router(config-vfi)# exit

Exits L2 VFI configuration mode. Commands take effect after the router exits L2 VFI configuration mode.

Configuring BGP to Enable VPLS Autodiscovery

In Cisco IOS Release 12.2(33)SRB, the BGP L2VPN address family was introduced with a separate L2VPN RIB that contains endpoint provisioning information for VPLS Autodiscovery. BGP learns the endpoint provisioning information from the L2VPN database which is updated each time a Layer 2 virtual forwarding instance (VFI) is configured. When BGP distributes the endpoint provisioning information in an update message to all its BGP neighbors, the endpoint information is used to configure a pseudowire mesh to support aL2VPN-based services.

SUMMARY STEPS

1. enable

2. configure terminal

3. router bgp autonomous-system-number

4. no bgp default ipv4-unicast

5. bgp log-neighbor-changes

6. neighbor {ip-address | peer-group-name} remote-as autonomous-system-number

7. neighbor {ip-address | peer-group-name} update-source interface

8. Repeat Step 6 and Step 7 to configure other BGP neighbors.

9. address-family l2vpn [vpls]

10. neighbor {ip-address | peer-group-name} activate

11. neighbor {ip-address | peer-group-name} send-community [both | standard | extended]

12. Repeat Step 10 and Step 11 to activate other BGP neighbors under L2VPN address family.

13. exit-address-family

14. exit

15. exit

16. show vfi

17. show ip bgp l2vpn vpls {all | rd vpn-rd}

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

router bgp autonomous-system-number

Example:

Router(config)# router bgp 65000

Enters router configuration mode for the specified routing process.

Step 4 

no bgp default ipv4-unicast

Example:

Router(config-router)# no bgp default ipv4-unicast

Disables the IPv4 unicast address family for the BGP routing process.

Note Routing information for the IPv4 unicast address family is advertised by default for each BGP routing session configured with the neighbor remote-as router configuration command unless you configure the no bgp default ipv4-unicast router configuration command before configuring the neighbor remote-as command. Existing neighbor configurations are not affected.

Step 5 

bgp log-neighbor-changes

Example:

Router(config-router)# bgp log-neighbor-changes

Enables logging of BGP neighbor resets.

Step 6 

neighbor {ip-address | peer-group-name} remote-as autonomous-system-number

Example:

Router(config-router)# neighbor 10.10.10.1 remote-as 65000

Adds the IP address or peer group name of the neighbor in the specified autonomous system to the IPv4 multiprotocol BGP neighbor table of the local router.

If the autonomous-system-number argument matches the autonomous system number specified in the router bgp command, the neighbor is an internal neighbor.

If the autonomous-system-number argument does not match the autonomous system number specified in the router bgp command, the neighbor is an external neighbor.

In this example, the neighbor at 10.10.10.1 is an internal BGP neighbor.

Step 7 

neighbor {ip-address | peer-group-name} update-source interface-type interface-number

Example:

Router(config-router)# neighbor 10.10.10.1 update-source loopback1

(Optional) Configures a router to select a specific source or interface to receive routing table updates.

This example uses a loopback interface. The advantage to this configuration is that the loopback interface is not affected by the effects of a flapping interface.

Step 8 

Repeat Step 6 and Step 7 to configure other BGP neighbors

Step 9 

address-family l2vpn [vpls]

Example:

Router(config-router)# address-family l2vpn vpls

Specifies the L2VPN address family and enters address family configuration mode.

The optional vpls keyword specifies that VPLS endpoint provisioning information is to be distributed to BGP peers.

In this example, an L2VPN VPLS address family session is created.

Step 10 

neighbor {ip-address | peer-group-name} activate

Example:

Router(config-router-af)# neighbor 10.10.10.1 activate

Enables the neighbor to exchange information for the L2VPN VPLS address family with the local router.

Step 11 

neighbor {ip-address | peer-group-name} send-community {both | standard | extended}

Example:

Router(config-router-af)# neighbor 10.10.10.1 send-community extended

Specifies that a communities attribute should be sent to a BGP neighbor.

In this example, an extended communities attribute is sent to the neighbor at 10.10.10.1.

Step 12 

Repeat Step 10 and Step 11 to activate other BGP neighbors under an L2VPN address family.

Step 13 

exit-address-family

Example:

Router(config-router-af)# exit-address-family

Exits address family configuration mode and returns to router configuration mode.

Step 14 

exit

Example:

Router(config-router)# exit

Exits router configuration mode.

Step 15 

exit

Example:

Router(config)# exit

Exits privileged EXEC mode.

Step 16 

show vfi

Example:

Router# show vfi

(Optional) Displays information about the configured VFI instances.

Step 17 

show ip bgp l2vpn vpls {all | rd vpn-rd}

Example:

Router# show ip bgp l2vpn vpls all

(Optional) Displays information about the Layer2 VPN VPLS address family.

Customizing the VPLS Autodiscovery Settings

Several commands allow you to customize the VPLS environment. You can specify identifiers for the VPLS domain, the route distinguisher, the route target, and the PE router. Perform the following steps to customize these settings.

SUMMARY STEPS

1. enable

2. configure terminal

3. l2 vfi vfi-name autodiscovery

4. vpn id vpn-id

5. vpls-id {autonomous-system-number:nn | ip-address:nn}

6. rd {autonomous-system-number:nn | ip-address:nn}

7. route-target [import | export | both] {autonomous-system-number:nn| ip-address:nn}

8. l2 router-id ip-address

9. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

l2 vfi vfi-name autodiscovery

Example:

Router(config)# l2 vfi vpls1 autodiscovery

Enables VPLS Autodiscovery on the PE router and enters L2 VFI configuration mode.

Step 4 

vpn id vpn-id

Example:

Router(config-vfi)# vpn id 10

Configures a VPN ID for the VPLS domain.

Step 5 

vpls-id {autonomous-system-number:nn | ip-address:nn}

Example:

Router(config-vfi)# vpls-id 5:300

(Optional) Specifies the VPLS domain. This command is optional, because VPLS Autodiscovery automatically generates a VPLS ID using the BGP autonomous system number and the configured VFI VPN ID. You can use this command to change the automatically generated VPLS ID.

There are two formats for configuring the VPLS ID argument. It can be configured in the autonomous-system-number:network number (ASN:nn) format, as shown in the example, or it can be configured in the IP-address:network number format (IP-address:nn).

Step 6 

rd {autonomous-system-number:nn | ip-address:nn}

Example:

Router(config-vfi)# rd 2:3

(Optional) Specifies the RD to distribute endpoint information. This command is optional, because VPLS Autodiscovery automatically generates an RD using the BGP autonomous system number and the configured VFI VPN ID. You can use this command to change the automatically generated route distinguisher.

There are two formats for configuring the route distinguisher argument.It can be configured in the autonomous-system-number:network number (ASN:nn) format, as shown in the example, or it can be configured in the IP-address:network number format (IP-address:nn).

Step 7 

route-target [import | export | both] {autonomous-system-number:nn | ip-address:nn}

Example:

Router(config-vfi)# route-target 600:2222

(Optional) Specifies the route target (RT). This command is optional, because VPLS Autodiscovery automatically generates a route target using the lower 6 bytes of the RD and VPLS ID. You can use this command to change the automatically generated route target.

There are two formats for configuring the route target argument. It can be configured in the autonomous-system-number:network number (ASN:nn) format, as shown in the example, or it can be configured in the IP-address:network number format (IP-address:nn).

Step 8 

l2 router-id ip-address

Example:

Router(config-vfi)# l2 router-id 10.10.10.10

(Optional) Specifies a unique identifier for the PE router. This command is optional, because VPLS Autodiscovery automatically generates a Layer 2 router ID using the MPLS global router ID. You can use this command to change the automatically generated ID.

Step 9 

exit

Example:

Router(config-vfi)# exit

Exits L2 VFI configuration mode. Commands take effect after the router exits L2 VFI configuration mode.

Configuration Examples for VPLS Autodiscovery: BGP Based

The following examples shows the configuration of a network using VPLS Autodiscovery and VPLS Autodiscovery supported on a route reflector:

VPLS Autodiscovery: BGP Based: Basic Example

BGP VPLS Autodiscovery Support on Route Reflector: Example

VPLS Autodiscovery: BGP Based: Basic Example

Figure 1 show a basic configuration of VPLS Autodiscovery.

Figure 1 Basic VPLS Autodiscovery Configuration

PE1


l2 router-id 10.1.1.1
l2 vfi auto autodiscovery
 vpn id 100
!
pseudowire-class mpls
 encapsulation mpls
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.255
!
interface Ethernet0/0
 description Backbone interface
 ip address 192.168.0.1 255.255.255.0
 mpls ip
!
router ospf 1
 log-adjacency-changes
 network 10.1.1.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.0.255 area 0
!
router bgp 1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 bgp update-delay 1
 neighbor 10.1.1.2 remote-as 1
 neighbor 10.1.1.2 update-source Loopback1  
 neighbor 10.1.1.3 remote-as 1  
 neighbor 10.1.1.3 update-source Loopback1  
!
 address-family ipv4
 no synchronization
 no auto-summary
 exit-address-family
 !
 address-family l2vpn vpls
 neighbor 10.1.1.2 activate
 neighbor 10.1.1.2 send-community extended  
 neighbor 10.1.1.3 activate  
 neighbor 10.1.1.3 send-community extended  
 exit-address-family 

PE2


l2 router-id 10.1.1.2
l2 vfi auto autodiscovery
 vpn id 100
!
 pseudowire-class mpls
 encapsulation mpls
!
interface Loopback1
 ip address 10.1.1.2 255.255.255.255
!
interface Ethernet0/0
 description Backbone interface
 ip address 192.168.0.2 255.255.255.0
 mpls ip
!
router ospf 1
 log-adjacency-changes
 network 10.1.1.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.0.255 area 0
!
router bgp 1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 bgp update-delay 1
 neighbor 10.1.1.1 remote-as 1
 neighbor 10.1.1.1 update-source Loopback1  
 neighbor 10.1.1.3 remote-as 1  
 neighbor 10.1.1.3 update-source Loopback1  
!
 address-family ipv4
 no synchronization
 no auto-summary
 exit-address-family
 !
 address-family l2vpn vpls
 neighbor 10.1.1.1 activate
 neighbor 10.1.1.1 send-community extended  
 neighbor 10.1.1.3 activate  
 neighbor 10.1.1.3 send-community extended  
 exit-address-family 

PE3


l2 router-id 10.1.1.3
l2 vfi auto autodiscovery
 vpn id 100
!
pseudowire-class mpls
 encapsulation mpls
!
interface Loopback1
 ip address 10.1.1.3 255.255.255.255
!
interface Ethernet0/0
 description Backbone interface
 ip address 192.168.0.3 255.255.255.0
 mpls ip
!
router ospf 1
 log-adjacency-changes
 network 10.1.1.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.0.255 area 0
!
router bgp 1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 bgp update-delay 1
 neighbor 10.1.1.1 remote-as 1
 neighbor 10.1.1.1 update-source Loopback1  
 neighbor 10.1.1.2 remote-as 1  
 neighbor 10.1.1.2 update-source Loopback1  
!
 address-family ipv4
 no synchronization
 no auto-summary
 exit-address-family
 !
 address-family l2vpn vpls
 neighbor 10.1.1.1 activate
 neighbor 10.1.1.1 send-community extended  
 neighbor 10.1.1.2 activate  
 neighbor 10.1.1.2 send-community extended  
 exit-address-family 

BGP VPLS Autodiscovery Support on Route Reflector: Example

In the following example, a host named PE-RR (indicating Provider Edge-Route Reflector) is configured as a route reflector capable of reflecting VPLS prefixes. The VPLS address family is configured by address-family l2vpn vpls below.

hostname PE-RR
!
router bgp 1
 bgp router-id 1.1.1.3
 no bgp default route-target filter
 bgp log-neighbor-changes
neighbor iBGP_PEERS peer-group
neighbor iBGP_PEERS remote-as 1
neighbor iBGP_PEERS update-source Loopback1  
neighbor 1.1.1.1 peer-group iBGP_PEERS  
neighbor 1.1.1.2 peer-group iBGP_PEERS  
!
address-family l2vpn vpls
  neighbor iBGP_PEERS send-community extended
  neighbor iBGP_PEERS route-reflector-client
  neighbor 1.1.1.1 peer-group iBGP_PEERS
  neighbor 1.1.1.2 peer-group iBGP_PEERS  
exit-address-family 

Additional References

The following sections provide references related to the VPLS Autodiscovery: BGP Based feature.

Related Documents

Related Topic
Document Title

Virtual Private LAN Services on the
Cisco 7600 series router

"Virtual Private LAN Services on the Optical Services Modules" chapter in the Cisco 7600 Series Router Cisco IOS Software Configuration Guide, Release 12.2SR

L2 VPNs on the Cisco 7600 router

Configuration information for Layer 2 VPNs on the Cisco 7600 router is included in the following documents:

The "Configuring PFC3BXL and PFC3B Mode Multiprotocol Label Switching" module of the Cisco 7600 Series Cisco IOS Software Configuration Guide, Release 12.2SR

The "Configuring Multiprotocol Label Switching on the Optical Services Modules" module of the OSM Configuration Note, Release 12.2SR

The "Configuring Multiprotocol Label Switching on FlexWAN and Enhanced FlexWAN Modules" module of the FlexWAN and Enhanced FlexWAN Modules Configuration Guide

The "Configuring Any Transport over MPLS on a SIP" section of the
Cisco 7600 Series Router SIP, SSC, and SPA Software Configuration Guide

The "Configuring AToM VP Cell Mode Relay Support" section of the
Cisco 7600 Series Router SIP, SSC, and SPA Software Configuration Guide

The Release Notes for Cisco IOS Release 12.2SR for the Cisco 7600 Series Routers

MPLS Commands

Cisco IOS Multiprotocol Label Switching Command Reference http://www.cisco.com/en/US/docs/ios/mpls/command/reference/mp_book.html


Standards

Standard
Title

draft-ietf-l2vpn-signaling-08.txt

Provisioning, Autodiscovery, and Signaling in L2VPNs

draft-ietf-l2vpn-vpls-bgp-08.8

Virtual Private LAN Service (VPLS) Using BGP for Autodiscovery and Signaling

draft-ietf-mpls-lsp-ping-03.txt

Detecting MPLS Data Plane Failures

draft-ietf-pwe3-vccv-01.txt

Pseudo-Wire (PW) Virtual Circuit Connection Verification (VCCV)


MIBs

MIB
MIBs Link

CISCO-IETF-PW-MIB (PW-MIB)

CISCO-IETF-PW-MPLS-MIB (PW-MPLS-MIB)

CISCO-IETF-PW-ENET-MIB (PW-ENET-MIB)

CISCO-IETF-PW-FR-MIB (PW-FR-MIB)

CISCO-IETF-PW-ATM-MIB (PW-ATM-MIB)

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

RFC 3916

Requirements for Pseudo-wire Emulation Edge-to-Edge (PWE3)

RFC 3981

Pseudo Wire Emulation Edge-to-Edge Architecture


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies. Access to most tools on the Cisco Support website requires a Cisco.com user ID and password. If you have a valid service contract but do not have a user ID or password, you can register on Cisco.com.

http://www.cisco.com/techsupport


Feature Information for VPLS Autodiscovery: BGP Based

Table 2 lists the release history for this feature.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Cisco IOS software images are specific to a Cisco IOS software release, a feature set, and a platform. Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.


Note Table 2 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 2 Feature Information for VPLS Autodiscovery: BGP Based 

Feature Name
Releases
Feature Information

VPLS Autodiscovery: BGP Based

12.2(33)SRB

VPLS Autodiscovery enables each Virtual Private LAN Service (VPLS) provider edge (PE) router to discover which other PE routers are part of the same VPLS domain.

In 12.2(33)SRB, this feature was introduced on the Cisco 7600 router.

The following commands were introduced or modified for this feature:

auto-route-target

l2 router-id

l2 vfi autodiscovery

neighbor (VPLS)

rd (VPLS)

route-target (VPLS)

show mpls l2transport vc

show vfi

show xconnect

vpls-id

xconnect

BGP VPLS Autodiscovery Support on Route Reflector

12.2(33)SRE

This feature was introduced on the Cisco 7600 series routers. This feature is documented in the following sections:

BGP VPLS Autodiscovery Support on a Route Reflector

BGP VPLS Autodiscovery Support on Route Reflector: Example