Cisco IOS Multiprotocol Label Switching Configuration Guide, Release 12.2SR
MPLS LDP Autoconfiguration
Downloads: This chapterpdf (PDF - 187.0KB) The complete bookPDF (PDF - 10.81MB) | Feedback

MPLS LDP Autoconfiguration

Table Of Contents

MPLS LDP Autoconfiguration

Finding Feature Information

Contents

Restrictions for MPLS LDP Autoconfiguration

Information About MPLS LDP Autoconfiguration

MPLS LDP Autoconfiguration on OSPF and IS-IS Interfaces

How to Configure MPLS LDP Autoconfiguration

Configuring MPLS LDP Autoconfiguration with OSPF Interfaces

Disabling MPLS LDP Autoconfiguration from Selected OSPF Interfaces

Verifying MPLS LDP Autoconfiguration with OSPF

Configuring MPLS LDP Autoconfiguration with IS-IS Interfaces

DETAILED STEPS

Disabling MPLS LDP Autoconfiguration from Selected IS-IS Interfaces

Verifying MPLS LDP Autoconfiguration with IS-IS

Troubleshooting Tips

Configuration Examples for MPLS LDP Autoconfiguration

MPLS LDP Autoconfiguration with OSPF: Example

MPLS LDP Autoconfiguration with IS-IS: Examples

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Feature Information for MPLS LDP Autoconfiguration


MPLS LDP Autoconfiguration


First Published: November 8, 2004
Last Updated: November 25, 2009

The MPLS LDP Autoconfiguration feature enables you to globally configure Label Distribution Protocol (LDP) on every interface associated with a specified Interior Gateway Protocol (IGP) instance.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature Information for MPLS LDP Autoconfiguration" section.

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Restrictions for MPLS LDP Autoconfiguration

Information About MPLS LDP Autoconfiguration

How to Configure MPLS LDP Autoconfiguration

Configuration Examples for MPLS LDP Autoconfiguration

Additional References

Feature Information for MPLS LDP Autoconfiguration

Restrictions for MPLS LDP Autoconfiguration

The MPLS LDP Autoconfiguration feature has the following restrictions:

In Cisco IOS Release 12.0(32)SY, the mpls ldp autoconfig command is supported only with OSPF. Other IGPs are not supported.

If LDP is disabled globally, the mpls ldp autoconfig command fails and generates a console message explaining that LDP must first be enabled globally by means of the global mpls ip command.

If the mpls ldp autoconfig command is configured for an IGP instance, you cannot issue the global no mpls ip command. To disable LDP, you must first issue the no mpls ldp autoconfig command.

For interfaces running IS-IS processes, you can enable Multiprotocol Label Switching (MPLS) for each interface, using the router mode command mpls ldp autoconfig or mpls ldp igp autoconfig at the interface level.

You specify that the default label distribution protocol is LDP for a router or for an interface. Tag Distribution Protocol (TDP) is not supported.

The MPLS LDP Autoconfiguration feature is not supported on traffic engineering tunnel interfaces.

Information About MPLS LDP Autoconfiguration

To enable LDP, you should configure it globally and on each interface where it is needed. Configuring LDP on many interfaces can be time-consuming. The following section provides information about autoconfiguration feature on OSPF and IS-IS interfaces:

MPLS LDP Autoconfiguration on OSPF and IS-IS Interfaces

MPLS LDP Autoconfiguration on OSPF and IS-IS Interfaces

The MPLS LDP Autoconfiguration feature enables you to globally enable LDP on every interface associated with an IGP instance. This feature is supported on OSPF and IS-IS IGPs. It provides a means to block LDP from being enabled on interfaces that you do not want enabled. The goal of the MPLS LDP Autoconfiguration feature is to make configuration easier, faster, and error free.

You issue the mpls ldp autoconfig command to enable LDP on each interface that is running an OSPF or IS-IS process. If you do not want some of the interfaces to have LDP enabled, you can issue the no form of the mpls ldp igp autoconfig command on those interfaces.

How to Configure MPLS LDP Autoconfiguration

This section contains the following procedures:

Configuring MPLS LDP Autoconfiguration with OSPF Interfaces (required)

Disabling MPLS LDP Autoconfiguration from Selected OSPF Interfaces (optional)

Verifying MPLS LDP Autoconfiguration with OSPF (optional)

Configuring MPLS LDP Autoconfiguration with IS-IS Interfaces (required)

Disabling MPLS LDP Autoconfiguration from Selected IS-IS Interfaces (optional)

Verifying MPLS LDP Autoconfiguration with IS-IS (optional)

Configuring MPLS LDP Autoconfiguration with OSPF Interfaces

The following steps explain how to configure LDP for interfaces running OSPF processes.

SUMMARY STEPS

1. enable

2. configure terminal

3. mpls ip

4. mpls label protocol ldp

5. interface type number

6. ip address prefix mask

7. exit

8. router ospf process-id

9. network ip-address wildcard-mask area area-id

10. mpls ldp autoconfig [area area-id]

11. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

mpls ip

Example:

Router(config)# mpls ip

Globally enables hop-by-hop forwarding.

Step 4 

mpls label protocol ldp

Example:

Router(config)# mpls label protocol ldp

Specifies LDP as the default label distribution protocol.

Step 5 

interface type number

Example:

Router(config)# interface POS 3/0

Specifies the interface to configure and enters interface configuration mode.

Step 6 

ip address prefix mask

Example:

Router(config-if)# ip address 10.0.0.11 255.255.255.255

Assigns an IP address to the interface.

Step 7 

exit

Example:

Router(config-if)# exit

Exits interface configuration mode.

Step 8 

router ospf process-id

Example:

Router(config)# router ospf 1

Enables OSPF routing and enters router configuration mode.

Step 9 

network ip-address wildcard-mask area area-id

Example:

Router(config-router)# network 10.0.0.0 0.0.255.255 area 3

Specifies the interface on which OSPF runs and defines the area ID for that interface.

Step 10 

mpls ldp autoconfig [area area-id]

Example:

Router(config-router)# mpls ldp autoconfig
area 3

Enables the MPLS LDP Autoconfiguration feature to enable LDP on interfaces belonging to an OSPF process.

If no area is specified, the command applies to all interfaces associated with the OSPF process. If an area ID is specified, then only interfaces associated with that OSPF area are enabled with LDP.

Step 11 

end

Example:

Router(config-router)# end

Exits router configuration mode and returns to privileged EXEC mode.

Disabling MPLS LDP Autoconfiguration from Selected OSPF Interfaces

When you issue the mpls ldp autoconfig command, all the interfaces that belong to an OSPF area are enabled for LDP. To remove LDP from some interfaces, use the no mpls ldp igp autoconfig command on those interfaces. The following configuration steps show how to disable LDP from some of the interfaces after they were configured with the MPLS LDP Autoconfiguration feature with the mpls ldp autoconfig command.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. no mpls ldp igp autoconfig

5. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Router(config)# interface POS 3/0

Specifies the interface to configure and enters interface configuration mode.

Step 4 

no mpls ldp igp autoconfig

Example:

Router(config-if)# no mpls ldp igp autoconfig

Disables LDP for that interface.

Step 5 

end

Example:

Router(config-if)# end

Exits interface configuration mode and returns to privileged EXEC mode.

Verifying MPLS LDP Autoconfiguration with OSPF

The following steps explain how to verify the MPLS LDP Autoconfiguration feature.

SUMMARY STEPS

1. enable

2. show mpls interfaces [type number | vrf vpn-name] [all] [detail] [internal]

3. show mpls ldp discovery [vrf vpn-name | all] [detail]

DETAILED STEPS


Step 1 enable

Enables privileged EXEC mode. Enter your password if prompted.

Step 2 show mpls interfaces [type number | vrf vpn-name] [all] [detail] [internal]

The show mpls interfaces command displays the method used to enable LDP on an interface:

If LDP is enabled by the mpls ldp autoconfig command, the output displays:

IP labeling enabled (ldp):
   IGP config

If LDP is enabled by the mpls ip command, the output displays:

IP labeling enabled (ldp):
  Interface config

If LDP is enabled by the mpls ip command and the mpls ldp autoconfig command, the output displays:

IP labeling enabled (ldp):
  Interface config
  IGP config

The following example shows that LDP was enabled on the interface by both the mpls ip and mpls ldp autoconfig commands:


Router# show mpls interfaces Serial 2/0 detail 

Interface Serial2/0:
        IP labeling enabled (ldp):
          Interface config
          IGP config
        LSP Tunnel labeling enabled
        BGP labeling not enabled
        MPLS operational
        Fast Switching Vectors:
          IP to MPLS Fast Switching Vector
          MPLS Turbo Vector
        MTU = 1500

Step 3 show mpls ldp discovery [vrf vpn-name | all] [detail]

The show mpls ldp discovery detail command also shows how LDP was enabled on the interface. In the following example, LDP was enabled by both the mpls ip and mpls ldp autoconfig commands:

Router# show mpls ldp discovery detail

Local LDP Identifier:
    10.11.11.11:0
    Discovery Sources:
    Interfaces:
        Serial2/0 (ldp): xmit/recv
            Enabled: Interface config, IGP config;
            Hello interval: 5000 ms; Transport IP addr: 10.11.11.11 
            LDP Id: 10.10.10.10:0
              Src IP addr: 10.0.0.1; Transport IP addr: 10.10.10.10
              Hold time: 15 sec; Proposed local/peer: 15/15 sec

Configuring MPLS LDP Autoconfiguration with IS-IS Interfaces

The following steps explain how to configure the MPLS LDP Autoconfiguration feature for interfaces that are running IS-IS processes.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. ip address prefix mask

5. ip router isis

6. exit

7. mpls ip

8. mpls label protocol ldp

9. router isis

10. mpls ldp autoconfig [level-1 | level-2]

11. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Router(config)# interface POS 0/2

Specifies the interface to configure and enters interface configuration mode.

Step 4 

ip address prefix mask

Example:

Router(config-if)# ip address 10.50.72.4 255.0.0.0

Assigns an IP address to the interface.

Step 5 

ip router isis

Example:

Router(config-if)# ip router isis

Enables IS-IS for IP on the interface.

Step 6 

exit

Example:

Router(config-if)# exit

Exits interface configuration mode.

Step 7 

mpls ip

Example:

Router(config)# mpls ip

Globally enables hop-by-hop forwarding.

Step 8 

mpls label protocol ldp

Example:

Router(config)# mpls label protocol ldp

Specifies LDP as the default label distribution protocol.

Step 9 

router isis

Example:

Router(config)# router isis

Enables an IS-IS process on the router and enters router configuration mode.

Step 10 

mpls ldp autoconfig [level-1 | level-2]

Example:

Router(config-router)# mpls ldp autoconfig

Enables the LDP for interfaces that belong to an IS-IS process.

Step 11 

end

Example:

Router(config-router)# end

Exits router configuration mode and returns to privileged EXEC mode.

Disabling MPLS LDP Autoconfiguration from Selected IS-IS Interfaces

When you issue the mpls ldp autoconfig command, all the interfaces that belong to an IS-IS process are enabled for LDP. To remove LDP from some interfaces, use the no mpls ldp igp autoconfig command on those interfaces. The following configuration steps show how to disable LDP from some of the interfaces after they were configured with the MPLS LDP Autoconfiguration feature with the mpls ldp autoconfig command.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. no mpls ldp igp autoconfig

5. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Router(config)# interface POS 3/0

Specifies the interface to configure and enters interface configuration mode.

Step 4 

no mpls ldp igp autoconfig

Example:

Router(config-if)# no mpls ldp igp autoconfig

Disables LDP for that interface.

Step 5 

end

Example:

Router(config-if)# end

Exits interface configuration mode and returns to privileged EXEC mode.

Verifying MPLS LDP Autoconfiguration with IS-IS

You can verify that the MPLS LDP Autoconfiguration feature is working correctly with the show isis mpls ldp command.

SUMMARY STEPS

1. enable

2. show isis mpls ldp

DETAILED STEPS


Step 1 enable

Enables privileged EXEC mode.

Step 2 show isis mpls ldp

The output of the following show isis mpls ldp command shows that IS-IS is configured on the interface and that LDP is enabled:

Router# show isis mpls ldp

Interface: POS0/2; ISIS tag null enabled
 ISIS is UP on interface
 AUTOCONFIG Information :
   LDP enabled: YES
 SYNC Information :
   Required: NO

The output shows :

IS-IS is up.

LDP is enabled.

If the MPLS LDP Autoconfiguration feature is not enabled on an interface, the output looks like the following:

Interface: Ethernet0; ISIS tag null enabled
 ISIS is UP on interface
 AUTOCONFIG Information :
   LDP enabled: NO
 SYNC Information :
   Required: NO

Troubleshooting Tips

You can use the debug mpls ldp autoconfig command to display events that are related to the MPLS LDP Autoconfiguration feature.

Configuration Examples for MPLS LDP Autoconfiguration

The following sections show examples for the MPLS LDP Autoconfiguration feature with OSPF and IS-IS processes.

MPLS LDP Autoconfiguration with OSPF: Example

MPLS LDP Autoconfiguration with IS-IS: Examples

MPLS LDP Autoconfiguration with OSPF: Example

The following configuration commands enable LDP for OSPF process 1 area 3. The mpls ldp autoconfig area 3 command and the OSPF network commands enable LDP on POS interfaces 0/0, 0/1, and 1/1. The no mpls ldp igp autoconfig command on POS interface 1/0 prevents LDP from being enabled on POS interface 1/0, even though OSPF is enabled for that interface.

configure terminal
 interface POS 0/0
  ip address 10.0.0.1 255.0.0.0
!
 interface POS 0/1
  ip address 10.0.1.1 255.0.0.1
!
 interface POS 1/1
  ip address 10.1.1.1 255.255.0.0
!
 interface POS 1/0
  ip address 10.1.0.1 0.1.0.255
  exit
!
 router ospf 1
  network 10.0.0.0 0.0.255.255 area 3
  network 10.1.0.0 0.0.255.255 area 3
  mpls ldp autoconfig area 3
  end
 interface POS 1/0
  no mpls ldp igp autoconfig

MPLS LDP Autoconfiguration with IS-IS: Examples

The following example shows the configuration of the MPLS LDP Autoconfiguration feature on POS0/2 and 0/3 interfaces, which are running IS-IS processes:

configure terminal
 interface POS 0/2
  ip address 10.0.0.1 255.0.0.1
  ip router isis
!
 interface POS 0/3
  ip address 10.1.1.1 255.0.1.0
  ip router isis
  exit

 mpls ip

 mpls label protocol ldp

 router isis

  mpls ldp autoconfig

Additional References

The following sections provide references related to the MPLS LDP Autoconfiguration feature.

Related Documents

Related Topic
Document Title

MPLS commands

Cisco IOS Multiprotocol Label Switching Command Reference

MPLS LDP

MPLS Label Distribution Protocol

The MPLS LDP-IGP Synchronization feature

MPLS LDP-IGP Synchronization

The MPLS LDP Session Protection feature

MPLS LDP Session Protection

Configuring integrated IS-IS

Integrated IS-IS Routing Protocol Overview


Standards

Standard
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature


MIBs

MIB
MIBs Link

MPLS LDP MIB

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

RFC 3036

LDP Specification

RFC 3037

LDP Applicability


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/techsupport


Feature Information for MPLS LDP Autoconfiguration

Table 1 lists the release history for this feature.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which Cisco IOS and Catalyst OS software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp. An account on Cisco.com is not required.


Note Table 1 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 1 Feature Information for MPLS LDP Autoconfiguration 

Feature Name
Releases
Feature Information

MPLS LDP Autoconfiguration

12.0(30)S
12.0(32)SY
12.2(28)SB
12.2(33)SRB
12.3(14)T
15.0(1)M
12.2(33)XNE

This feature enables you to globally configure LDP on every interface associated with a specified Interior Gateway Protocol (IGP) instance.

The following sections provide information about this feature:

Information About MPLS LDP Autoconfiguration

How to Configure MPLS LDP Autoconfiguration

In Cisco IOS Release 12.0(30)S, this feature was introduced with support for OSPF.

In Cisco IOS Release 12.0(32)SY, support for IS-IS was added.

This feature was integrated into Cisco IOS
Release 12.2(28)SB with support for OSPF.

This feature was integrated into Cisco IOS
Release 12.2(33)SRB.

This feature was integrated into Cisco IOS
Release 12.3(14)T with support for OSPF.

In Release 15.0(1)M, support for IS-IS was added.

This feature was integrated into Cisco IOS Release 12.2(33)XNE with support for IS-IS on the Cisco 10000 series router.

The following commands were modified: mpls ldp autoconfig, mpls ldp igp autoconfig, show isis mpls ldp, and show mpls ldp discovery.