Cisco IOS IP Routing: EIGRP Command Reference
A through H
Downloads: This chapterpdf (PDF - 461.0KB) The complete bookPDF (PDF - 1.0MB) | Feedback

EIGRP Commands

Table Of Contents

EIGRP Commands

address-family (EIGRP)

af-interface

authentication key-chain (EIGRP)

authentication mode (EIGRP)

autonomous-system (EIGRP)

auto-summary (EIGRP)

bandwidth-percent

clear eigrp address-family neighbors

clear ip eigrp neighbors

clear ip eigrp vrf neighbors

dampening-change

dampening-interval

default-information

default-metric (EIGRP)

distance eigrp

eigrp event-log-size

eigrp interface

eigrp log-neighbor-changes

eigrp log-neighbor-warnings

eigrp router-id

eigrp stub

exit-address-family

exit-af-interface

exit-af-topology

hello-interval

hold-time


EIGRP Commands


address-family (EIGRP)

To enter address-family configuration mode to configure an Enhanced Interior Gateway Routing Protocol (EIGRP) routing instance, use the address-family (EIGRP) command in router configuration mode. To remove the address-family from the EIGRP configuration, use the no form of this command.

EIGRP Autonomous-System Configuration

address-family ipv4 [unicast] vrf vrf-name [autonomous-system autonomous-system-number]

no address-family ipv4 [unicast] vrf vrf-name [autonomous-system autonomous-system-number]

EIGRP Named IPv4 Configuration

address-family ipv4 [multicast] [unicast] [vrf vrf-name] autonomous-system autonomous-system-number

no address-family ipv4 [multicast] [unicast] [vrf vrf-name] autonomous-system autonomous-system-number

EIGRP Named IPv6 Configuration

address-family ipv6 [unicast] [vrf vrf-name] autonomous-system autonomous-system-number

no address-family ipv6 [unicast] [vrf vrf-name] autonomous-system autonomous-system-number

Syntax Description

ipv4

Selects the IPV4 protocol address-family.

ipv6

Selects the IPV6 protocol address-family. IPv6 is supported only in EIGRP named configurations.

multicast

(Optional) Specifies the multicast address-family. This keyword is available only in EIGRP named IPv4 configurations.

unicast

(Optional) Specifies the unicast address-family.

autonomous-system autonomous-system- number

(Optional) Specifies the autonomous system number. This keyword/argument pair is required for EIGRP named configurations.

vrf vrf-name

(Optional) Specifies the name of the VRF. This keyword/argument pair is required for EIGRP AS configurations.


Command Default

No EIGRP process is running.

Command Modes

Router configuration (config-router)

Command History

Release
Modification

12.0(22)S

This command was introduced.

12.2(15)T

This command was integrated into Cisco IOS Release 12.2(15)T.

12.2(18)S

This command was integrated into Cisco IOS Release 12.2(18)S.

12.2(27)SBC

This command was integrated into Cisco IOS Release 12.2(27)SBC.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

15.0(1)M

This command was modified. The autonomous-system keyword is required for named configurations.

12.2(33)SRE

This command was modified. The autonomous-system keyword is required for named configurations.

12.2(33)XNE

This command was modified. The autonomous-system keyword is required for named configurations.

Cisco IOS XE Release 2.5

This command was modified. The autonomous-system keyword is required for named configurations.

12.2(33)SXI4

This command was modified. The autonomous-system keyword is required for named configurations.


Usage Guidelines

The address-family (EIGRP) command is used to configure IPv4 or IPv6 address-family sessions under EIGRP. To leave address-family configuration mode without removing the address family configuration, use the exit-address-family command.

EIGRP Autonomous-System Configuration

Use the router eigrp number command to configure an EIGRP autonomous-system (AS) configuration.

In this configuration, EIGRP VPNs can be configured only under IPv4 address-family configuration mode. A virtual routing and forwarding instance (VRF) and route distinguisher must be defined before the address family session can be created.

It is recommended that you configure an autonomous-system number when the address-family is configured, either by entering the address-family command or the autonomous-system command.

EIGRP Named Configuration

Use the router eigrp virtual-name command to configure an EIGRP named configuration.

In this configuration, EIGRP VPNs can be configured in IPv4 and IPv6 named configurations. A virtual routing and forwarding instance (VRF) and a route distinguisher may or may not be used to create the address-family.

If a VRF is not used in creating the address-family, the EIGRP VPN instance assumes the default route distinguisher and will communicate with the default route distinguisher of other routers in the same network.

EIGRP VPNs can be configured under EIGRP named configurations. A virtual routing and forwarding instance (VRF) and route distinguisher must be defined before the address-family session can be created.

A single EIGRP routing process can support multiple VRFs. The number of VRFs that can be configured is limited only by available system resources on the router, which is determined by the number of VRFs, running processes, and available memory. However, only a single VRF can be supported by each VPN, and redistribution between different VRFs is not supported.

MPLS VPN support between PE and CE routers is configured only on PE routers that provide VPN services over the service provider backbone. The customer site does not require any changes to equipment or configurations to support the EIGRP VPN. A metric must be configured for routes to be advertised to the CE router. The metric can be configured using the redistribute (IP) command or configured with the default-metric (EIGRP) command.

Examples

The following example configures an IPv4 address-family session for the VRF named RED in Cisco IOS releases prior to Cisco IOS Release 15.0(1)M, 12.2(33)SRE, 12.2(33)XNE and Cisco IOS XE Release 2.5:

Router(config)# ip vrf RED 
Router(config-vrf)# rd 1:1 
Router(config-vrf)# exit 
Router(config)# router eigrp 1 
Router(config-router)# address-family ipv4 vrf RED
Router(config-router-af)# autonomous-system 101 
Router(config-router-af)# network 172.16.0.0 
Router(config-router-af)# default-metric 10000 100 255 1 1500 
Router(config-router-af)# exit-address-family 

The following examples configure a single VRF named VRF-RED in Cisco IOS Release 15.0(1)M, 12.2(33)SRE, 12.2(33)XNE and Cisco IOS XE Release 2.5 and later releases:

Router(config)# ip vrf VRF-RED 
Router(config-vrf)# rd 1:1 
Router(config-vrf)# exit 
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 vrf VRF-RED autonomous-system 1
Router(config-router-af)# network 10.0.0.0 0.0.0.255
Router(config-router-af)# topology base
Router(config-router-topology)# default-metric 10000 100 255 1 1500 
Router(config-router-topology)# exit-af-topology
Router(config-router-af)# exit-address-family

The following example configures a non-VRF address-family in Cisco IOS Release 15.0(1)M, 12.2(33)SRE, 12.2(33)XNE and Cisco IOS XE Release 2.5, and later releases:

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 3
Router(config-router-af)# network 10.0.0.0 0.0.0.255
Router(config-router-af)# topology base
Router(config-router-af-topology)# default-metric 10000 100 255 1 1500 
Router(config-router-af- topology)# exit-af-topology
Router(config-router-af)# exit-address-family

Related Commands

Command
Description

autonomous-system (EIGRP)

Configures the autonomous-system number for an EIGRP routing process to run within a VRF instance.

default-metric (EIGRP)

Sets metrics for EIGRP.

exit-address-family

Exits address-family configuration mode.

network (EIGRP)

Specifies a list of networks for the EIGRP routing process.

redistribute (IP)

Redistributes routes from one routing domain into another routing domain.


af-interface

To enter address-family interface configuration mode and to configure interface-specific Enhanced Interior Gateway Routing Protocol (EIGRP) commands, use the af-interface command in address-family configuration mode. To reset the address-family interface setting to factory values, use the no form of this command.

af-interface {default | interface-type interface-number}

no af-interface {default | interface-type interface-number}

Syntax Description

default

Specifies the default address-family interface configuration mode. Commands applied under this mode affect all interfaces used by this address-family instance.

interface-type interface-number

Interface type and number of the interface that the address-family submode commands will affect.


Command Default

Address-family interface configuration mode is not entered.

Command Modes

Address-family configuration (config-router-af)

Command History

Release
Modification

15.0(1)M

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.


Usage Guidelines

The af-interface default command is useful for defining user defaults to apply to EIGRP interfaces that belong to an address-family when EIGRP is configured using the named method. For example, authentication mode is disabled by default, and you can enable MD5 authentication for all EIGRP interfaces in the address-family using address-family interface configuration mode and then selectively override the new default setting using different address-family interface configuration commands.


Note Use the af-interface default command with caution, because some default settings can be different depending on the interface type. For example, the default hello-interval is 5 seconds for most interfaces but is 60 seconds for slow NBMA interfaces, and changing the hello-interval in address-family interface configuration mode will affect all interfaces.


Examples

The following example shows how to enter address-family interface configuration mode and to configure EIGRP interface-specific commands:

Router(config)# router eigrp virtual-name 
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# af-interface default
Router(config-router-af-interface)# shutdown 
Router(config-router-af-interface)# exit
Router(config-router-af)# af-interface Ethernet 0/0 
Router (config-router-af-interface)# no shutdown 
Router (config-router-af-interface)# exit-af-interface
Router(config-router-af)# 

Related Commands

Command
Description

address-family (EIGRP)

Enters address-family configuration mode to configure an EIGRP routing instance.

exit-address-family

Exits address-family configuration mode.


authentication key-chain (EIGRP)

To specify an authentication key chain for Enhanced Interior Gateway Routing Protocol (EIGRP), use the authentication key-chain (EIGRP) command in address-family interface configuration mode or service-family interface configuration mode. To remove the authentication key-chain, use the no form of this command.

authentication key-chain name-of-chain

no authentication key-chain name-of-chain

Syntax Description

name-of-chain

Group of keys that are valid.


Command Default

No key chains are specified for EIGRP.

Command Modes

Address-family interface configuration (router-config-af-interface)
Service-family interface configuration (router-config-sf-interface)

Command History

Release
Modification

15.0(1)M

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.

12.2(33)SXI4

This command was integrated into Cisco IOS Release 12.2(33)SXI4.


Usage Guidelines

The key-chain command has no effect until the authentication mode md5 command is configured.

Only one authentication key chain is applied to EIGRP at one time. That is, if you configure a second authentication key-chain command, the first is overridden.

Examples

The following example configures EIGRP to apply authentication to address-family autonomous system 1 and identifies a key chain named SITE1:

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 1
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# authentication key-chain SITE1
Router(config-router-af-interface)# authentication mode md5

The following example configures EIGRP to apply authentication to service-family autonomous system 1 and identifies a key chain named SITE1:

Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 1
Router(config-router-sf)# sf-interface ethernet0/0
Router(config-router-sf-interface)# authentication key-chain SITE1 

Router(config-router-sf-interface)# authentication mode md5

Related Commands

Command
Description

authentication mode (EIGRP)

Specifies the type of authentication used in EIGRP address-family packets for the EIGRP instance.

key chain

Defines an authentication key chain needed to enable authentication for routing protocols.

router eigrp

Configures the EIGRP address-family process.


authentication mode (EIGRP)

To specify the type of authentication used in Enhanced Interior Gateway Routing Protocol (EIGRP) address-family or service-family packets for the EIGRP instance, use the authentication mode command in address-family interface configuration mode or service-family interface configuration mode. To disable a configured authentication type, use the no form of this command.

authentication mode md5

no authentication mode

Syntax Description

md5

Message Digest 5 (MD5) authentication.


Command Default

No authentication mode is provided for EIGRP packets.

Command Modes

Address-family interface configuration (config-router-af-interface)
Service-family interface configuration (config-router-sf-interface)

Command History

Release
Modification

15.0(1)M

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.

12.2(33)SXI4

This command was integrated into Cisco IOS Release 12.2(33)SXI4.


Usage Guidelines

Configure authentication to prevent unapproved sources from introducing unauthorized or false service messages.

When the authentication mode (EIGRP) command is used in conjunction with the authentication key-chain command, an MD5 keyed digest is added to each EIGRP packet.

Examples

The following example configures the interface to use MD5 authentication in address-family packets:

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 1
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# authentication key-chain TEST1 
Router(config-router-af-interface)# authentication mode md5

The following example configures the interface to use MD5 authentication in EIGRP service-family packets:

Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 1
Router(config-router-sf)# sf-interface ethernet0/0
Router(config-router-sf-interface)# authentication key-chain TEST1 
Router(config-router-sf-interface)# authentication mode md5

Related Commands

Command
Description

address-family (EIGRP)

Enters address-family configuration mode to configure an EIGRP routing instance.

af-interface

Enters address-family interface configuration mode to configure interface-specific EIGRP commands.

authentication key-chain

Specifies the type of authentication used in EIGRP address-family or service-family packets for the EIGRP instance.

key chain

Defines an authentication key-chain needed to enable authentication for routing protocols.

router eigrp

Configures the EIGRP address-family process.


autonomous-system (EIGRP)

To configure the autonomous-system number for an Enhanced Interior Gateway Routing Protocol (EIGRP) routing process to run within a VPN routing and forwarding (VRF) instance, use the autonomous-system command in address-family configuration mode. To remove the autonomous-system for an EIGRP routing process from within a VPN VRF instance, use the no form of this command.

autonomous-system autonomous-system-number

no autonomous-system autonomous-system-number

Syntax Description

autonomous-system-number

Autonomous system number of the EIGRP routing process.


Command Default

The autonomous-system number is not configured.

Command Modes

Address-family configuration (config-router-af)

Command History

Release
Modification

12.0(22)S

This command was introduced.

12.2(15)T

This command was integrated into Cisco IOS Release 12.2(15)T.

12.2(18)S

This command was integrated into Cisco IOS Release 12.2(18)S.

12.2(27)SBC

The command was integrated into Cisco IOS Release 12.2(27)SBC.

15.0(1)M

This command was modified. This command can now be configured as a keyword of the address-family (EIGRP) command. This command can still be configured as a separate command in address-family configuration mode.

12.2(33)SRE

This command was modified. This command can now be configured as a keyword of the address-family (EIGRP) command. This command can still be configured as a separate command in address-family configuration mode.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.

12.2(33)SXI4

The command was integrated into Cisco IOS Release 12.2(33)SXI4.


Usage Guidelines

This standalone autonomous-system command is not available in EIGRP named configurations. This command is present only in EIGRP autonomous-system (AS) configurations.

When configuring an EIGRP process, you must configure an autonomous-system value. You can configure an autonomous-system value using the standalone autonomous-system (EIGRP) command in address-family configuration mode or by configuring the address-family command in router configuration mode with the autonomous-system-number argument, or both.

Once configured, the standalone autonomous-system command can optionally be removed, but only if the autonomous-system argument is also configured on the address-family command.

Once configured, the autonomous-system-number argument on the address-family command cannot be removed without also removing the address-family itself.

Examples

The following example shows how to configure an EIGRP routing process within a VRF with the autonomous system configured by the autonomous-system command in address-family configuration mode:

Router(config)# router eigrp 65200
Router(config-router)# address-family ipv4 vrf VRF2 
Router(config-router-af)# autonomous-system 65500

The following example shows how to configure an EIGRP address family within a VRF with the autonomous system configured by the address-family autonomous-system-number command in router configuration mode:

Router(config)# router eigrp 65200
Router(config-router)# address-family ipv4 vrf VRF2 autonomous-system 65500

Related Commands

Command
Description

address-family (EIGRP)

Enters address-family configuration mode to configure an EIGRP routing instance.

router eigrp

Configures the EIGRP address-family process.


auto-summary (EIGRP)

To allow automatic summarization of subnet routes into network-level routes, use the auto-summary command in router configuration mode or address-family topology configuration mode. To disable this function and send subprefix routing information across classful network boundaries, use the no form of this command.

auto-summary

no auto-summary

Syntax Description

This command has no arguments or keywords.

Command Default

The behavior of this command is enabled by default (the software does not send subprefix routing information across classful network boundaries).

Cisco IOS Release 15.0(1)M, 12.2(33)SRE, 12.2(33)XNE, Cisco IOS XE Release 2.5, Cisco IOS Release 12.2(33)SXI4 and Later Releases

The behavior of this command is disabled by default (the software sends subprefix routing information across classful network boundaries).

Command Modes

Router configuration (config-router)
Address-family topology configuration (config-router-af-topology)

Command History

Release
Modification

10.0

This command was introduced.

12.2(8)T

The command default behavior changed to disabled.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

15.0(1)M

This command was modified. Address-family topology configuration mode was added. The default behavior was changed to disabled.

12.2(33)SRE

This command was modified. Address-family topology configuration mode was added. The default behavior was changed to disabled.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.

12.2(33)SXI4

This command was modified. Address-family topology configuration mode was added. The default behavior was changed to disabled.


Usage Guidelines

To allow the software to create summary subprefixes to the classful network boundary when crossing classful network boundaries, use the auto-summary command.

Enhanced Interior Gateway Routing Protocol (EIGRP) summary routes are given an administrative distance value of 5. You cannot configure this value.

Examples

The following example enables automatic summarization for EIGRP process 109:

Router(config)# router eigrp 109
Router(config-router)# auto-summary

The following example enables automatic summarization for EIGRP autonomous-system 4473:

Router(config)# router eigrp virtual-name 
Router(config-router)# address-family ipv4 autonomous-system 4473
Router(config-router-af)# topology base 
Router(config-router-af-topology)# auto-summary 

Related Commands

Command
Description

address-family (EIGRP)

Enters address-family configuration mode to configure an EIGRP routing instance.

ip summary-address eigrp

Configures a summary aggregate address for a specified interface.

router eigrp

Configures the EIGRP address-family process.

topology (EIGRP)

Configures an EIGRP process to route IP traffic under the specified topology instance and enters router address-family topology configuration mode.


bandwidth-percent

To configure the percentage of bandwidth that may be used by an Enhanced Interior Gateway Routing Protocol (EIGRP) address family or service family on an interface, use the bandwidth-percent command in address-family interface configuration mode or service-family interface configuration mode. To restore the default value, use the no form of this command.

bandwidth-percent maximum-bandwidth-percentage

no bandwidth-percent

Syntax Description

maximum-bandwidth- percentage

Percent of configured bandwidth that EIGRP may use to send packets. Valid range is 1 to 999999. The default is 50 percent.


Command Default

EIGRP limits bandwidth usage to 50 percent of the configured interface bandwidth.

Command Modes

Address-family interface configuration (config-router-af-interface)
Service-family interface configuration (config-router-sf-interface)

Command History

Release
Modification

15.0(1)M

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.

12.2(33)SXI4

This command was integrated into Cisco IOS Release 12.2(33)SXI4.


Usage Guidelines

Use the bandwidth-percent command to configure a different percentage of bandwidth for use by EIGRP than specified for the link by using the bandwidth interface command. Values greater than 100 percent may be configured. This option might be useful if the link bandwidth is set artificially low for other reasons. The default bandwidth percent uses 50 percent of the configured bandwidth of the link.

Examples

The following example uses up to 75 percent (42 kbps) of a 56-kbps serial link for address-family autonomous system 4453:

Router(config)# router eigrp virtual-name 
Router(config-router)# address-family ipv4 autonomous-system 4453 
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# bandwidth-percent 75 

The following example uses up to 75 percent (42 kbps) of a 56-kbps serial link for service-family autonomous system 4533:

Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# sf-interface serial 0
Router(config-router-sf-interface)# bandwidth-percent 75


Related Commands

Command
Description

address-family (EIGRP)

Enters address-family configuration mode to configure an EIGRP routing instance.

af-interface

Enters address-family interface configuration mode to configure interface-specific EIGRP commands.

router eigrp

Configures the EIGRP address-family process.

service-family

Configures VRF metrics for an EIGRP service-family.

sf-interface

Configures interface-specific commands for an EIGRP service-family.


clear eigrp address-family neighbors

To delete entries from the Enhanced Interior Gateway Routing Protocol (EIGRP) neighbor table, use the clear eigrp address-family neighbors command in privileged EXEC mode.

clear eigrp address-family {ipv4 [autonomous-system-number | vrf [vrf-name] | [autonomous-system-number]] | ipv6 [autonomous-system-number]} neighbors [ip-address] [interface-type interface-number] [soft]

Syntax Description

ipv4

Selects neighbors formed using the IPv4 protocol family.

ipv6

Selects neighbors formed using the IPv6 protocol family.

autonomous-system- number

(Optional) Autonomous system number of the EIGRP routing process. If no autonomous system number is specified, all autonomous systems are affected.

vrf

(Optional) Deletes entries from the neighbor table for the specified IPv4 VRF.

vrf-name

(Optional) Name of the VRF address-family to which the command is applied.

ip-address

(Optional) IPv4 or IPv6 address of the neighbor. Specifying an address removes all entries with this address from the neighbor table.

interface-type

(Optional) Interface type. Specifying this argument removes the specified interface type that all entries learned via this interface from the neighbor table.

interface-number

(Optional) Interface number. Specifying this arguments removes the specified interface number that all entries learned via this interface from the neighbor table.

soft

(Optional) Gracefully informs the peer that adjacency is being resynced. This method does not take the peer down and back up with a hard reset.


Command Default

Entries in the EIGRP neighbor table are not cleared.

Command Modes

Privileged EXEC (#)

Command History

Release
Modification

15.0(1)M

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.


Usage Guidelines


Caution This command causes peers to bounce and routes to be relearned. Use this command only with the guidance of Cisco technical support.

Specifying the interface-type and interface-number arguments clears the neighbors on the specified interface from the neighbor table.

Specifying the VRF for an IPv4 address family clears neighbors in that VRF only. If an autonomous-system number is provided along with the VRF, then only the neighbors of that autonomous-system number in the VRF are cleared.

Examples

The following example removes the neighbor whose address is 172.16.8.3:

Router# clear eigrp address-family ipv4 neighbors 172.16.8.3 

The following example clears EIGRP neighbors reached through the VRF named VRF1 in autonomous system 101:

Router# clear eigrp address-family ipv4 vrf VRF1 101 neighbors

The following example clears EIGRP neighbors reached through the VRF named VRF1 in autonomous system 101 learned through Ethernet interface 0/0:

Router# clear eigrp address-family ipv4 vrf VRF1 101 neighbors ethernet0/0

Related Commands

Command
Description

clear eigrp topology

Clears an EIGRP process for a topology instance.

clear ip eigrp neighbors

Deletes entries from the EIGRP neighbor table.

show eigrp address-family neighbors

Displays neighbors discovered by EIGRP.

show ip eigrp address-family neighbors

Displays neighbors discovered by EIGRP.


clear ip eigrp neighbors

To delete entries from the Enhanced Interior Gateway Routing Protocol (EIGRP) neighbor table, use the clear ip eigrp neighbors command in privileged EXEC mode.

clear ip eigrp [vrf vrf-name [autonomous-system-number] | autonomous-system-number] neighbors [ip-address | interface-type interface-number] [soft]

Syntax Description

vrf

(Optional) Deletes entries from the neighbor table for the specified IPv4 VRF.

vrf-name

(Optional) Name of the VRF address family to which the command is applied.

autonomous-system-number

(Optional) Autonomous-system (AS) number of the EIGRP routing process. If no autonomous-system number is specified, all autonomous systems are affected.

ip-address

(Optional) Address of the neighbor.

interface-type

(Optional) Interface type. Specifying this argument removes the specified interface type that all entries learned via this interface from the neighbor table.

interface-number

(Optional) Interface number. Specifying this argument removes the specified interface number that all entries learned via this interface from the neighbor table.

soft

(Optional) Gracefully informs the peer that adjacency is being resynced. This method does not take the peer down and back up with a hard reset.


Command Modes

Privileged EXEC (#)

Command History

Release
Modification

10.0

This command was introduced.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.

12.2(18)S

This command was integrated into Cisco IOS Release 12.2(18)S.

12.2(27)SBC

This command was integrated into Cisco IOS Release 12.2(27)SBC.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2(33)SXH

This command was integrated into Cisco IOS Release 12.2(33)SXH.

15.0(1)M

This command was modified. The vrf keyword, vrf-name argument, and soft keyword were added. This command replaces the clear ip eigrp vrf neighbors command.

12.2(33)SRE

This command was modified. The vrf keyword, vrf-name argument, and soft keyword were added. This command replaces the clear ip eigrp vrf neighbors command.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.


Usage Guidelines


Caution This command causes peers to bounce and routes to be relearned. Use this command only with the guidance of Cisco technical support.

Specifying the interface-type and interface-number arguments clears the neighbors on the specified interface from the neighbor table.

Specifying the VRF or AS clears the neighbors in that VRF or AS.

This is a IPv4-only command in that it clears only the specified EIGRP IPv4 neighbors.

Examples

The following example removes the neighbor whose address is 172.16.8.3:

Router# clear ip eigrp neighbors 172.16.8.3

The following example clears EIGRP neighbors reached through the VRF named VRF1 in autonomous-system 101:

Router# clear ip eigrp vrf VRF1 101 neighbors

The following example clears EIGRP neighbors reached through the VRF named VRF1 in autonomous-system 101 learned through Ethernet interface 0/0:

Router# clear ip eigrp vrf VRF1 101 neighbor ethernet0/0 

Related Commands

Command
Description

clear eigrp address-family neighbors

Deletes entries from the EIGRP neighbor table.

show ip eigrp interfaces

Displays information about interfaces configured for EIGRP.

show ip eigrp neighbors

Displays neighbors discovered by EIGRP.


clear ip eigrp vrf neighbors


Note Effective with Cisco IOS Release 15.0(1)M and 12.2(33)SRE, the clear ip eigrp vrf neighbors command is replaced by the clear ip eigrp neighbors command. See the clear ip eigrp neighbors for more information.


To clear neighbor entries of the specified Enhanced Interior Gateway Routing Protocol (EIGRP) virtual routing and forwarding instance (VRF) from the Routing Information Base (RIB), use the clear ip eigrp vrf neighbors command in privileged EXEC mode.

clear ip eigrp vrf vrf-name [autonomous-system-number] neighbors [interface-name interface-number]

Syntax Description

vrf-name

Name of the VRF whose EIGRP neighbors will be cleared. The * keyword can be used as a wildcard to specify all VRFs.

autonomous-system-number

(Optional) Autonomous system number of the VRF whose neighbors will be cleared.

interface-name interface-number

(Optional) Interface that VRF neighbors were learned through. The exact interface is specified by interface name and number using the interface-name and interface-number arguments.


Command Modes

Privileged EXEC (#)

Command History

Release
Modification

12.0(22)S

This command was introduced.

12.2(15)T

This command was integrated into 12.2(15)T.

12.2(18)S

This command was integrated into Cisco IOS Release 12.2(18)S.

12.2(27)SBC

This command was integrated into Cisco IOS Release 12.2(27)SBC.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

15.0(1)M

This command was replaced by the clear ip eigrp neighbors command.

12.2(33)SRE

This command was replaced by the clear ip eigrp neighbors command.


Examples

The following example shows how to clear EIGRP neighbors reached through the VRF named RED in autonomous system 45000:

Router# clear ip eigrp vrf RED 45000 neighbors 

The following example shows how to clear EIGRP neighbors reached through the VRF named GREEN in autonomous-system 101 learned through Ethernet interface 0/0:

Router# clear ip eigrp vrf GREEN 45000 neighbors ethernet 0/0

Related Commands

Command
Description

show ip eigrp vrf interfaces

Displays EIGRP interfaces that are defined under the specified VRF.

show ip eigrp vrf neighbors

Displays neighbors discovered by EIGRP that carry VRF information.

show ip eigrp vrf topology

Displays VRF entries in the EIGRP topology table.

show ip eigrp vrf traffic

Displays EIGRP VRF traffic statistics.

show ip route vrf

Displays routing protocol information that is associated with a VRF.


dampening-change

To set a threshold percentage to minimize or dampen the effect of frequent routing changes through an interface in an Enhanced Interior Gateway Routing Protocol (EIGRP) address family or service family, use the dampening-change command in address-family interface configuration mode or service-family interface configuration mode. To restore the default value, use the no form of this command.

dampening-change [change-percentage]

no dampening-change

Syntax Description

change-percentage

(Optional) The percentage a metric must change before the value is stored for future decisions on advertisements.

Value range is 1 to 100. If a change-percentage value is not specified, the default is 50 percent of the computed metric.


Command Default

No threshold percentage is configured.

Command Modes

Address-family interface configuration (config-router-af-interface)
Service-family interface configuration (config-router-sf-interface)

Command History

Release
Modification

15.0(1)M

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.

12.2(33)SXI4

This command was integrated into Cisco IOS Release 12.2(33)SXI4.


Usage Guidelines

The dampening-change command is supported only for Mobile Ad Hoc Networking (MANET) router-to-radio links.

When a peer metric changes on an interface that is configured with the dampening-change command, EIGRP multiplies the dampening-change percentage with the old peer metric and compares the result (the threshold) to the difference between the old and new metrics. If the metric difference is greater than the calculated threshold, then the new metric is applied and routes learned from that peer are updated and advertised to other peers. If the metric difference is less than the threshold, the new metric is discarded.

There are exceptions that will result in an immediate update regardless of the dampening-change setting:

An interface is down.

A route is down.

A change in metric which results in the router selecting a new next hop.

Peer metric changes that do not exceed a configured change percentage and that do not result in a routing change do not result in an update being sent to other adjacencies. Peer metric changes are based on the stored last-update of the peer. Peer metric changes that exceed the threshold value are stored and used for future comparisons.

Examples

The following example configures an EIGRP address family to accept a peer metric change if the change is greater than 75 percent of the last updated value:

Router(config)# router eigrp virtual-name 
Router(config-router)# address-family ipv4 autonomous-system 5400
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# dampening-change 75 

The following example configures an EIGRP service family to accept a peer metric change if the change is greater than 75 percent of the last updated value:

Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# sf-interface serial 0
Router(config-router-sf-interface)# dampening-change 75

Related Commands

Command
Description

address-family (EIGRP)

Enters address-family configuration mode to configure an EIGRP routing instance.

af-interface

Enters address-family interface configuration mode to configure interface-specific EIGRP commands.

dampening-interval

Sets a threshold time interval to minimize or dampen the effect of frequent routing changes through an interface in an EIGRP address family or service family.

router eigrp

Configures the EIGRP address-family process.

service-family

Specifies service-family configuration mode.

sf-interface

Configures interface-specific commands under a service family.


dampening-interval

To set a threshold time interval to minimize or dampen the effect of frequent routing changes through an interface in an Enhanced Interior Gateway Routing Protocol (EIGRP) address family or service family, use the dampening-interval command in address-family interface configuration mode or service-family interface configuration mode. To restore to the default value, use the no form of this command.

dampening-interval [interval]

no dampening-interval [interval]

Syntax Description

interval

(Optional) Time interval, in seconds, that must elapse before a route change will cause an update to occur. Value range is 1 to 65535. If an interval value is not specified, the default is 30 seconds.


Command Default

A dampening interval is not enabled.

Command Modes

Address-family interface configuration (config-router-af-interface)
Service-family interface configuration (config-router-sf-interface)

Command History

Release
Modification

15.0(1)M

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.

12.2(33)SXI4

This command was integrated into Cisco IOS Release 12.2(33)SXI4.


Usage Guidelines

The dampening-interval command is supported only in Mobile Ad Hoc Networking (MANET) Router-to-Radio links.

When a peer metric changes on an interface that is configured with a dampening interval, EIGRP will apply the metric change only if the time difference since the last metric changed exceeds the specified interval. If the time difference is less than the specified interval, the update is discarded.

There are exceptions that result in an immediate update regardless of the dampening interval settings:

An interface is down.

A route is down.

A change in metric that results in the router selecting a new next hop.

Examples

The following example configures EIGRP address-family Ethernet interface 0/0 to limit the metric change frequency to no more than one change in a 45-second interval:

Router(config)# router eigrp virtual-name 
Router(config-router)# address-family ipv4 autonomous-system 5400
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# dampening-interval 45

The following example configures EIGRP service-family Serial interface 0 to limit the metric change frequency to no more than one change in a 30 second interval:

Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# sf-interface serial0
Router(config-router-sf-interface)# dampening-interval 30

Related Commands

Command
Description

address-family (EIGRP)

Enters address-family configuration mode to configure an EIGRP routing instance.

af-interface

Enters address-family interface configuration mode to configure interface-specific EIGRP commands.

dampening-change

Sets a threshold percentage to minimize or dampen the effect of frequent routing changes through an interface in an EIGRP address family or service family.

router eigrp

Configures the EIGRP address-family process.

service-family

Specifies service-family configuration mode.

sf-interface

Configures interface-specific commands under a service family.

shutdown

Disables service family on the interface.


default-information

To accept exterior or default routing information into Enhanced Interior Gateway Routing Protocol (EIGRP) processes, use the default-information command in router configuration mode or address-family topology configuration mode. To suppress exterior or default routing information in inbound or outbound updates, use the no form of this command.

default-information {allowed {in | out} | in | out} [acl-number | acl-name]

no default-information {allowed {in | out} | in | out}

Cisco IOS Release 15.0(1)M, 12.2(33)SRE, 12.2(33)XNE, Cisco IOS XE Release 2.5 and Later Releases

default-information {in | out} [acl-number | acl-name]

no default-information {in | out} [acl-number | acl-name]

Syntax Description

allowed

Configures EIGRP to accept default routing information.

in

Configures EIGRP to accept exterior or default routing information.

out

Configures EIGRP to advertise external routing information.

acl-number

(Optional) Standard access list number from 1 to 99 or an expanded standard access list from 1300 to 1999.

acl-name

(Optional) Named standard access list.


Command Default

Exterior routes are always accepted and default information is passed between EIGRP processes when redistribution occurs.

Command Modes

Router configuration (config-router)
Address-family topology configuration (config-router-af-topology)

Command History

Release
Modification

10.0

This command was introduced.

11.2

The acl-number and acl-name arguments were added.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

15.0(1)M

This command was modified. Address-family topology configuration mode was added. The allowed keyword was removed.

12.2(33)SRE

This command was modified. Address-family topology configuration mode was added. The allowed keyword was removed.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.


Usage Guidelines

The default network of 0.0.0.0 used by Routing Information Protocol (RIP) can be redistributed by EIGRP.

Examples

The following example allows exterior or default routes to be received by the EIGRP process in autonomous system 23:

Router(config)# router eigrp 23
Router(config-router)# default-information in

The following example allows EIGRP exterior or default routes to be received by the EIGRP process in autonomous system 4473 in Cisco IOS Release 15.0(1)M, 12.2(33)SRE, 12.2(33)XNE, Cisco IOS XE Release 2.5 and later releases:

Router(config)# router eigrp virtual-name 
Router(config-router)# address-family ipv4 autonomous-system 4473
Router(config-router-af)# topology base 
Router(config-router-af-topology)# default-information in

Related Commands

Command
Description

address-family (EIGRP)

Enters address-family configuration mode to configure an EIGRP routing instance.

router eigrp

Configures the EIGRP address-family process.

topology (EIGRP)

Configures an EIGRP process to route IP traffic under the specified topology instance and enters router address-family topology configuration mode.


default-metric (EIGRP)

To set metrics for Enhanced Interior Gateway Routing Protocol (EIGRP), use the default-metric command in router configuration mode or address-family topology configuration mode. To remove the metric value and restore the default state, use the no form of this command.

default-metric bandwidth delay reliability loading mtu

no default-metric bandwidth delay reliability loading mtu

Syntax Description

bandwidth

Minimum bandwidth of the route in kilobytes per second. It can be from 1 to 4294967295.

delay

Route delay in tens of microseconds. It can be 1 or any positive number that is a multiple of 39.1 nanoseconds.

reliability

Likelihood of successful packet transmission expressed as a number from 0 through 255. The value 255 means 100 percent reliability; 0 means no reliability.

loading

Effective bandwidth of the route expressed as a number from 1 to 255 (255 is 100 percent loading).

mtu

The smallest allowed value for the maximum transmission unit (MTU), expressed in bytes. It can be from 1 to 65535.


Command Default

Only connected routes can be redistributed without a default metric. The metric of redistributed connected routes is set to 0.

Command Modes

Router configuration (config-router)
Address-family topology configuration (config-router-af-topology)

Command History

Release
Modification

10.0

This command was introduced.

12.0(22)S

Address family support was added.

12.2(15)T

Address family support was added.

12.2(18)S

Address family support was added.

12.4(6)T

Support for IPv6 was added.

12.2(28)SB

This command was integrated into Cisco IOS Release 12.2(28)SB.

12.2(33)SRB

This command was integrated into Cisco IOS Release 12.2(33)SRB.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

15.0(1)M

This command was modified. Address-family topology configuration mode was added. This command must be entered in address-family topology configuration mode when EIGRP is configured with a named router configuration.

12.2(33)SRE

This command was modified. Address-family topology configuration mode was added. This command must be entered in address-family topology configuration mode when EIGRP is configured with a named router configuration.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.


Usage Guidelines

You must use a default metric to redistribute a protocol into EIGRP, unless you use the redistribute command.

Metric defaults have been carefully set to work for a wide variety of networks. Take great care when changing these values.

Default metrics are supported only when you are redistributing from EIGRP or static routes.

Examples

The following example shows how the redistributed Routing Information Protocol (RIP) metrics are translated into EIGRP metrics with values as follows: bandwidth = 1000, delay = 100, reliability = 250, loading = 100, and MTU = 1500:

Router(config)# router eigrp 109
Router(config-router)# network 172.16.0.0
Router(config-router)# redistribute rip
Router(config-router)# default-metric 1000 100 250 100 1500

The following example shows how the redistributed EIGRP service family 6473 metrics are translated into EIGRP metric with values as follows: bandwidth = 1000, delay = 100, reliability = 250, loading = 100, and MTU = 1500.

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# af-interface default
Router(config-router-af-interface)# no shutdown
Router(config-router-af-interface)# exit
Router(config-router-af)# topology base
Router(config-router-af-topology)# default-metric 1000 100 250 100 1500

Related Commands

Command
Description

address-family (EIGRP)

Enters address-family configuration mode to configure an EIGRP routing instance.

af-interface

Enters address-family interface configuration mode to configure interface-specific EIGRP commands.

ipv6 router eigrp

Configures the EIGRP IPv6 routing process.

redistribute (IP)

Redistributes routes from one routing domain into another routing domain.

redistribute (IPv6)

Redistributes IPv6 routes from one routing domain into another routing domain.

router eigrp

Configures the EIGRP address-family process.

topology (EIGRP)

Configures an EIGRP process to route IP traffic under the specified topology instance and enters router address-family topology configuration mode.


distance eigrp

To allow the use of two administrative distances—internal and external—that could be a better route to a node, use the distance eigrp command in router configuration mode or address-family topology configuration mode. To reset these values to their defaults, use the no form of this command.

distance eigrp internal-distance external-distance

no distance eigrp

Syntax Description

internal-distance

Administrative distance for Enhanced Internal Gateway Routing Protocol (EIGRP) internal routes. Internal routes are those that are learned from another entity within the same autonomous system. The distance can be a value from 1 to 255. The default administrative distance for EIGRP internal routes is 90.

external-distance

Administrative distance for EIGRP external routes. External routes are those for which the best path is learned from a neighbor external to the autonomous system. The distance can be a value from 1 to 255. The default administrative distance for EIGRP external routes is 170.


Command Default

EIGRP uses the default internal and external administrative distances.

Command Modes

Router configuration (config-router)
Address-family topology configuration (config-router-af-topology)

Command History

Release
Modification

10.0

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

15.0(1)M

This command was modified. Address-family topology configuration mode was added. This command must be entered in address-family topology configuration mode when EIGRP is configured with a named router configuration.

12.2(33)SRE

This command was modified. Address-family topology configuration mode was added. This command must be entered in address-family topology configuration mode when EIGRP is configured with a named router configuration.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.


Usage Guidelines

An administrative distance is a rating of the trustworthiness of a routing information source, such as an individual router or a group of routers. Numerically, an administrative distance is an integer from 0 to 255. In general, the higher the value, the lower the trust rating. An administrative distance of 255 means the routing information source cannot be trusted at all and should be ignored.

Use the distance eigrp command if another protocol is known to be able to provide a better route to a node than was actually learned via external EIGRP, or if some internal routes should really be preferred by EIGRP.

Table 1 lists the default administrative distances.

Table 1 Default Administrative Distances 

Route Source
Default Distance

Connected interface

0

Static route

1

EIGRP summary route

5

External BGP

20

Internal EIGRP

90

Open Shortest Path First (OSPF)

110

Intermediate System-to-Intermediate System (IS-IS)

115

Routing Information Protocol (RIP)

120

EIGRP external route

170

Internal Border Gateway Protocol (BGP)

200

Unknown

255


To display the default administrative distance for a specified routing process, use the show ip protocols command.

Examples

In the following example, the router eigrp global configuration command sets up EIGRP routing in autonomous system number 109. The network router configuration commands specify EIGRP routing on networks 192.168.7.0 and 172.16.0.0. The distance eigrp command sets the administrative distance of all EIGRP internal routes to 80 and all EIGRP external routes to 130.

Router(config)# router eigrp 109 
Router(config-router)# network 192.168.7.0
Router(config-router)# network 172.16.0.0 
Router(config-router)# distance eigrp 80 130

In the following example, the distance eigrp command sets the administrative distance of all EIGRP address-family internal routes to 80 and all external routes to 130:

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4473
Router(config-router-af)# topology base
Router(config-router-af-topology)# distance eigrp 80 130

Related Commands

Command
Description

address-family (EIGRP)

Enters address-family configuration mode to configure an EIGRP routing instance.

router eigrp

Configures the EIGRP address-family process.

show ip protocols

Displays the parameters and current state of the active routing protocol process.

topology (EIGRP)

Configures an EIGRP process to route IP traffic under the specified topology instance and enters router address-family topology configuration mode.


eigrp event-log-size

To set the size of the Enhanced Interior Gateway Routing Protocol (EIGRP) event log, use the eigrp event-log-size command in router configuration mode or address-family topology configuration mode. To reset the size of the EIGRP event log to its default value, use the no form of this command.

eigrp event-log-size size

no eigrp event-log-size

Syntax Description

size

Size of the EIGRP event log; valid values are from 0 to half of the available memory on the system at the time of configuration. Default value is 500.


Command Default

The EIGRP event log size is 500.

Command Modes

Router configuration (config-router)
Address-family topology configuration (config-router-af-topology)

Command History

Release
Modification

12.2(18)SXF

This command was introduced in Cisco IOS Release 12.2(18)SXF.

15.0(1)M

This command was modified. Address-family topology configuration mode was added.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.


Usage Guidelines

When the configured size (number of lines) of the event log is exceeded, the last configured number of lines is retained, and the log becomes a rolling number of events with the most recent at the top of the log.

Examples

The following example shows how to set the size of the EIGRP event log to 5000010:

Router# configure terminal
Router(config)# router eigrp 2
Router (config-router)# eigrp event-log-size 5000010
Router (config-router)#

The following example shows how to set the size of the EIGRP event log in an EIGRP named configuration to 10000:

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 1
Router(config-router-af)# topology base
Router(config-router-af-topology)# eigrp event-log-size 10000

Related Commands

Command
Description

clear ip eigrp event

Clears the IP EIGRP event log.


eigrp interface


Note Effective with Cisco IOS Release 15.0(1)M, the eigrp interface command is replaced by the dampening-change command and the dampening-interval command. See the dampening-change and dampening-interval commands for more information.


To set a threshold value to minimize hysteresis in a router-to-radio configuration, use the eigrp interface command in interface configuration mode. To reset the hysteresis threshold to the default value, use the no form of this command.

eigrp vmi-interface-number interface [dampening-change value] [dampening-interval value]

no eigrp vmi-interface-number interface [dampening-change value] [dampening-interval value]

Syntax Description

vmi-interface-number

The number assigned to the VMI interface.

dampening-change value

(Optional) Value used to minimize the effect of frequent routing changes in router-to-radio configurations. Percent interface metric must change to cause update. Value range is 1 to 100.

dampening-interval value

(Optional) Specifies the time interval in seconds to check the interface metrics at which advertising of routing changes occurs. The default value is 30 seconds. Value range is 1 to 65535.


Command Default

Default for change-based dampening is 50 percent of the computed metric.

Default for interval-based dampening is 30 seconds.

Command Modes

Interface configuration (config-if)

Command History

Release
Modification

12.4(15)XF

This command was introduced.

12.4(15)T

This command was integrated into Cisco IOS Release 12.4(15)T.

15.0(1)M

This command was replaced. This command was replaced by the dampening-change command and the dampening-interval command.


Usage Guidelines

This command advertises routing changes for EIGRP traffic only.

The REPLY sent to any QUERY will always contain the latest metric information. Exceptions which will result in immediate UPDATE being sent:

A down interface

A down route

Any change in metric which results in the router selecting a new next hop

Change-based Dampening

The default value for the change tolerance will be 50% of the computed metric. It can be configured in the range from 0 to 100 percent. If the metric change of the interface is not greater (or less) than the current metric plus or minus the specified amount, the change will not result in a routing change, and no update will be sent to other adjacencies.

Interval-based Dampening

The default value for the update intervals is 30 seconds. It can be configured in the range from 0 to 64535 seconds. If this option is specified, changes in routes learned though this interface, or in the interface metrics, will not be advertised to adjacencies until the specified interval is met. When the timer expires, any changes detected in any routes learned through the interface, or the metric reported by the interfaces will be sent out.

Examples

Change-based Dampening Example

The following example sets the threshold to 50 percent tolerance routing updates involving VMI interfaces and peers:

interface vmi1
 ip address 10.2.2.1 255.255.255.0
 ipv6 address 2001:0DB1:2::1/96
 ipv6 enable
 eigrp 1 interface dampening-change 50
 physical-interface Ethernet0/0

Interval-based Dampening Example

The following example sets the interval to 30 seconds at which updates occur for topology changes that affect VMI interfaces and peers:

interface vmi1
 ip address 10.2.2.1 255.255.255.0
 ipv6 address 2001:0DB1:2::1/96
 ipv6 enable
 eigrp 1 interface dampening-interval 30

physical-interface Ethernet0/0

Related Commands

Command
Description

debug vmi

Displays debugging output for virtual multipoint interfaces (VMIs)

interface vmi

Creates a virtual multipoint interface (VMI) that can be configured and applied dynamically.


eigrp log-neighbor-changes

To enable the logging of changes in Enhanced Interior Gateway Routing Protocol (EIGRP) neighbor adjacencies, use the eigrp log-neighbor-changes command in router configuration mode, address-family configuration mode, or service-family configuration mode. To disable the logging of changes in EIGRP neighbor adjacencies, use the no form of this command.

eigrp log-neighbor-changes

no eigrp log-neighbor-changes

Syntax Description

This command has no arguments or keywords.

Command Default

Adjacency changes are logged.

Command Modes

Router configuration (config-router)
Address-family configuration (config-router-af)
Service-family configuration (config-router-sf)

Command History

Release
Modification

11.2

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

15.0(1)M

This command was modified. Address-family configuration mode and service-family configuration mode were added.

12.2(33)SRE

This command was modified. Address-family configuration mode and service-family configuration mode were added.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.


Usage Guidelines

This command enables the logging of neighbor adjacency changes to monitor the stability of the routing system and to help detect problems. Logging is enabled by default. To disable the logging of neighbor adjacency changes, use the no form of this command.

To enable the logging of changes for EIGRP address-family neighbor adjacencies, use the eigrp log-neighbor-changes command in address-family configuration mode.

To enable the logging of changes for EIGRP service-family neighbor adjacencies, use the eigrp log-neighbor-changes command in service-family configuration mode.

Examples

The following configuration disables logging of neighbor changes for EIGRP process 209:

Router(config)# router eigrp 209
Router(config-router)# no eigrp log-neighbor-changes

The following configuration enables logging of neighbor changes for EIGRP process 209:

Router(config)# router eigrp 209
Router(config-router)# eigrp log-neighbor-changes

The following example shows how to disable logging of neighbor changes for EIGRP address-family with autonomous-system 4453:

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453 
Router(config-router-af)# no eigrp log-neighbor-changes

Router(config-router-af)# exit-address-family


The following configuration enables logging of neighbor changes for EIGRP service-family process 209:

Router(config)# router eigrp 209
Router(config-router)# service-family ipv4 autonomous-system 4453 
Router(config-router-sf)# eigrp log-neighbor-changes
Router(config-router-sf)# exit-service-family

Related Commands

Command
Description

address-family (EIGRP)

Enters address-family configuration mode to configure an EIGRP routing instance.

exit-address-family

Exits address-family configuration mode.

exit-service-family

Exits service-family configuration mode.

router eigrp

Configures the EIGRP routing process.

service-family

Specifies service-family configuration mode.


eigrp log-neighbor-warnings

To enable the logging of Enhanced Interior Gateway Routing Protocol (EIGRP) neighbor warning messages, use the eigrp log-neighbor-warnings command in router configuration mode, address-family configuration mode, or service-family configuration mode. To disable the logging of EIGRP neighbor warning messages, use the no form of this command.

eigrp log-neighbor-warnings [seconds]

no eigrp log-neighbor-warnings

Syntax Description

seconds

(Optional) The time interval (in seconds) between repeated neighbor warning messages. The range is from 1 to 65535. The default is 10.


Command Default

Neighbor warning messages are logged at 10-second intervals.

Command Modes

Router configuration (config-router)
Address-family configuration (config-router-af)
Service-family configuration (config-router-sf)

Command History

Release
Modification

12.0(5)

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

15.0(1)M

This command was modified. Address-family and service-family configuration modes were added.

12.2(33)SRE

This command was modified. Address-family and service-family configuration modes were added.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.


Usage Guidelines

When neighbor warning messages occur, they are logged by default. With this command, you can disable and enable neighbor warning messages, and you can configure the interval between repeated neighbor warning messages.

To enable the logging of warning messages for an EIGRP address family, use the eigrp log-neighbor-warnings command in address-family configuration mode.

To enable the logging of warning messages for an EIGRP service family, use the eigrp log-neighbor-warnings command in service-family configuration mode.

Examples

The following command will log neighbor warning messages for EIGRP process 209 and repeat the warning messages in 5-minute (300 seconds) intervals:

Router(config)# router eigrp 209
Router(config-router)# eigrp log-neighbor-warnings 300

The following example logs neighbor warning messages for the service family with autonomous system number 4453 and repeats the warning messages in five-minute (300 second) intervals:

Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 4453
Router(config-router-sf)# eigrp log-neighbor-warnings 300

The following example logs neighbor warning messages for the address family with autonomous system number 4453 and repeats the warning messages in five-minute (300 second) intervals:

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# eigrp log-neighbor-warnings 300

Related Commands

Command
Description

address-family (EIGRP)

Enters address-family configuration mode to configure an EIGRP routing instance.

exit-address-family

Exits address-family configuration mode.

exit-service-family

Exits service-family configuration mode.

router eigrp

Configures the EIGRP routing process.

service-family

Specifies service-family configuration mode.


eigrp router-id

To set the router ID used by Enhanced Interior Gateway Routing Protocol (EIGRP) when communicating with its neighbors, use the eigrp router-id command in router configuration mode, address-family configuration mode, or service-family configuration mode. To remove the configured router ID, use the no form of this command.

eigrp router-id router-id

no eigrp router-id [router-id]

Syntax Description

router-id

EIGRP router ID in IP address format.


Command Default

EIGRP automatically selects an IP address to use as the router ID when an EIGRP process is started. The highest local IP address is selected and loopback interfaces are preferred. The router ID is not changed unless the EIGRP process is removed with the no router eigrp command or if the router ID is manually configured with the eigrp router-id command.

Command Modes

Router configuration (config-router)
Address-family configuration (config-router-af)
Service-family configuration (config-router-sf)

Command History

Release
Modification

12.1

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

15.0(1)M

This command was modified. Address-family configuration mode and service-family configuration mode were added.

12.2(33)SRE

This command was modified. Address-family configuration mode and service-family configuration mode were added.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.


Usage Guidelines

The router ID is used to identify the originating router for external routes. If an external route is received with the local router ID, the route is discarded. The router ID can be configured with any IP address with two exceptions; 0.0.0.0 and 255.255.255.255 are not legal values and cannot be entered. A unique value should be configured for each router.

In EIGRP named IPv4, named IPv6, and Cisco Service Advertisement Framework (SAF) configurations, the router-id is also included for identifying internal routes and loop detection.

Examples

The following example configures 172.16.1.3 as a fixed router ID:

Router(config)# router eigrp 209
Router(config-router)# eigrp router-id 172.16.1.3

The following example configures 172.16.1.3 as a fixed router ID for service-family autonomous-system 4533:

Router(config)# router eigrp 209
Router(config-router)# service-family ipv4 autonomous-system 4453
Router(config-router-sf)# eigrp router-id 172.16.1.3

The following example configures 172.16.1.3 as a fixed router ID for address-family autonomous-system 4533:

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453

Router(config-router-af)# eigrp router-id 172.16.1.3

Related Commands

Command
Description

address-family (EIGRP)

Enters address-family configuration mode to configure an EIGRP routing instance.

router eigrp

Configures the EIGRP routing process.

service-family

Specifies service-family configuration mode.


eigrp stub

To configure a router as a stub using Enhanced Interior Gateway Routing Protocol (EIGRP), use the eigrp stub command in router configuration mode or address-family configuration mode. To disable the EIGRP stub routing feature, use the no form of this command.

eigrp stub [receive-only] [leak-map name] [connected] [static] [summary] [redistributed]

no eigrp stub

Syntax Description

receive-only

(Optional) Sets the router as a receive-only neighbor.

leak-map name

(Optional) Allows dynamic prefixes based on a leak map.

connected

(Optional) Advertises connected routes.

static

(Optional) Advertises static routes.

summary

(Optional) Advertises summary routes.

redistributed

(Optional) Advertises redistributed routes from other protocols and autonomous systems.


Command Default

Stub routing is not enabled by default.

Command Modes

Router configuration (config-router)
Address-family configuration (config-router-af)

Command History

Release
Modification

12.0(7)T

This command was introduced.

12.0(15)S

This command was integrated into Cisco IOS Release 12.0(15)S.

12.2

The redistributed keyword was added.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

15.0(1)M

This command was modified. Address-family configuration mode was added to support EIGRP named configurations. The leak-map keyword and name argument were added. This command replaces the stub command.

12.2(33)SRE

This command was modified. Address-family configuration mode was added to support EIGRP named configurations. The leak-map keyword and name argument were added. This command replaces the stub command.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.

12.2(33)SXI4

This command was modified. Address-family configuration mode was added to support EIGRP named configurations. The leak-map keyword and name argument were added. This command replaces the stub command.


Usage Guidelines

Use the eigrp stub command to configure a router as a stub where the router directs all IP traffic to a distribution router, unless stub leaking is configured.

The eigrp stub command can be modified with several options, and these options can be used in any combination except for the receive-only keyword. The receive-only keyword will restrict the router from sharing any of its routes with any other router in that EIGRP autonomous system, and the receive-only keyword will not permit any other option to be specified because it prevents any type of route from being sent. The four other optional keywords (connected, static, summary, leak-map, and redistributed) can be used in any combination but cannot be used with the receive-only keyword.

If any of these five keywords is used with the eigrp stub command, only the route types specified by the particular keyword(s) will be sent. Route types specified by the remaining keywords will not be sent.

The connected keyword permits the EIGRP stub routing feature to send connected routes. If the connected routes are not covered by a network statement, it may be necessary to redistribute connected routes with the redistribute connected command under the EIGRP process. This option is enabled by default.

The static keyword permits the EIGRP stub routing feature to send static routes. Without the configuration of this option, EIGRP will not send any static routes, including internal static routes that normally would be automatically redistributed. It will still be necessary to redistribute static routes with the redistribute static command.

The summary keyword permits the EIGRP stub routing feature to send summary routes. Summary routes can be created manually with the summary address command or automatically at a major network border router with the auto-summary command enabled. This option is enabled by default.

The redistributed keyword permits the EIGRP stub routing feature to send other routing protocols and autonomous systems. Without the configuration of this option, EIGRP will not advertise redistributed routes.

The leak-map keyword permits the EIGRP stub routing feature to reference a leak map that identifies routes that are allowed to be advertised on an EIGRP stub router that would normally have been suppressed.

Examples

In the following example, the eigrp stub command is used to configure the router as a stub that advertises connected and summary routes:

Router(config)# router eigrp 1
Router(config-router)# network 10.0.0.0
Router(config-router)# eigrp stub

In the following named configuration example, the eigrp stub command is used to configure the router as a stub that advertises routes learned from a directly connected client:

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 10.0.0.0
Router(config-router-af)# eigrp stub connected

In the following example, the eigrp stub command is issued with the connected and static keywords to configure the router as a stub that advertises connected and static routes (sending summary routes will not be permitted):

Router(config)# router eigrp 1
Router(config-router)# network 10.0.0.0
Router(config-router)# eigrp stub connected static

In the following named configuration example, the eigrp stub command is issued with the connected and static keywords to configure the router as a stub that advertises connected and static routes (sending summary routes will not be permitted):

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 10.0.0.0
Router(config-router-af)# eigrp stub connected static

In the following example, the eigrp stub command is issued with the receive-only keyword to configure the router as a receive-only neighbor (connected, summary, and static routes will not be sent):

Router(config)# router eigrp 1
Router(config-router)# network 10.0.0.0 eigrp 
Router(config-router)# eigrp stub receive-only

In the following named configuration example, the eigrp stub command is issued with the receive-only keyword to configure the router as a receive-only neighbor (connected, summary, and static routes will not be sent):

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 10.0.0.0
Router(config-router-af)# eigrp stub receive-only

In the following example, the eigrp stub command is issued with the redistributed keyword to configure the router to advertise other protocols and autonomous systems:

Router(config)# router eigrp 1
Router(config-router)# network 10.0.0.0 eigrp 
Router(config-router)# eigrp stub redistributed

In the following named configuration example, the eigrp stub command is issued with the redistributed keyword to configure the router to advertise other protocols and autonomous systems:

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 10.0.0.0
Router(config-router-af) eigrp stub redistributed

In the following example, the eigrp stub command is issued with the leak-map name keyword/argument pair to configure the router to reference a leak map that identifies routes that would normally have been suppressed:

Router(config)# router eigrp 
Router(config-router)# network 10.0.0.0
Router(config-router) eigrp stub leak-map map1

In the following named configuration example, the eigrp stub command is issued with the leak-map name keyword/argument pair to configure the router to reference a leak map that identifies routes that would normally have been suppressed:

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 10.0.0.0
Router(config-router-af) eigrp stub leak-map map1

Related Commands

Command
Description

address-family (EIGRP)

Enters address-family configuration mode to configure an EIGRP routing instance.

network (EIGRP)

Specifies the network for an EIGRP routing process.

router eigrp

Configures the EIGRP address-family process.


exit-address-family

To exit from address-family configuration mode, use the exit-address-family command in address-family configuration mode.

exit-address-family

Syntax Description

This command has no arguments or keywords.

Command Default

The router remains in address-family configuration mode.

Command Modes

Address-family configuration (config-router-af)
VRF address-family configuration (config-vrf-af)

Command History

Release
Modification

12.0(5)T

This command was introduced.

12.0(22)S

Enhanced Interior Gateway Routing Protocol (EIGRP) support was added in Cisco IOS Release 12.0(22)S.

12.2(14)S

This command was integrated into Cisco IOS Release 12.2(14)S.

12.2(15)T

EIGRP support was added in Cisco IOS Release 12.2(15)T.

12.2(18)S

EIGRP support was added.

12.2(17b)SXA

This command was integrated into Cisco IOS Release 12.2(17b)SXA.

12.2(27)SBC

This command was integrated into Cisco IOS Release 12.2(27)SBC.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.


Usage Guidelines

Use the exit-address-family command to exit address-family configuration mode and return to router configuration mode.

This command can be abbreviated to exit.

Examples

The following example shows how to exit address-family configuration mode and return to router configuration mode:

Router(config)# router eigrp virtual-name 
Router(config-router)# address-family ipv4 autonomous-system 4453 
Router(config-router-af)# exit-address-family 
Router(config-router)#

The following example shows how to exit VRF address-family configuration mode and return to VRF configuration mode:

Router(config)# vrf definition vrf1
Router(config-vrf)# address-family ipv6
Router(config-vrf-af)# exit-address-family 
Router(config-vrf)#

Related Commands

Command
Description

address-family (EIGRP)

Enters address-family configuration mode to configure an EIGRP routing instance.

address-family ipv4

Enters IPv4 address family configuration mode.

address-family ipv6

Enters IPv6 address family configuration mode.

address-family nsap

Enters CLNS address family configuration mode.

address-family vpnv4

Enters VPNv4 address family configuration mode.

address-family (VRF)

Selects an address family type for a VRF table and enters VRF address-family configuration mode.

router eigrp

Configures the EIGRP address-family process.


exit-af-interface

To exit address-family interface configuration mode, use the exit-af-interface command in address-family interface configuration mode.

exit-af-interface

Syntax Description

This command has no arguments or keywords.

Command Default

The router remains in address-family interface configuration mode.

Command Modes

Address-family interface configuration (config-router-af-interface)

Command History

Release
Modification

15.0(1)M

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.


Usage Guidelines

Use the exit-af-interface command to exit address-family interface configuration mode and return to address-family configuration mode.

Examples

The following example shows how to exit address-family interface configuration mode:

Router(config)# router eigrp virtual-name 
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# af-interface default
Router(config-router-af-interface)# exit-af-interface
Router(config-router-af)#

Related Commands

Command
Description

address-family (EIGRP)

Enters address-family configuration mode to configure an EIGRP routing instance.

af-interface

Enters address-family interface configuration mode to configure interface-specific EIGRP commands.

router eigrp

Configures the EIGRP address-family process.


exit-af-topology

To exit address-family topology configuration mode, use the exit-af-topology command in address-family topology configuration mode.

exit-af-topology

Syntax Description

This command has no arguments or keywords.

Command Default

The router remains in address-family topology configuration mode.

Command Modes

Address-family topology configuration (config-router-af-topology)

Command History

Release
Modification

15.0(1)M

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.


Usage Guidelines

Use the exit-af-topology command to exit address-family topology configuration mode and return to address-family configuration mode.

Examples

The following example shows how to exit address-family topology configuration mode:

Router(config)# router eigrp virtual-name 
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# topology base
Router(config-router-af-topology)# exit-af-topology
Router(config-router-af)#

Related Commands

Command
Description

address-family (EIGRP)

Enters address-family configuration mode to configure an EIGRP routing instance.

af-interface

Enters address-family interface configuration mode to configure interface-specific EIGRP commands.

router eigrp

Configures the EIGRP address-family process.

topology (EIGRP)

Configures an EIGRP process to route IP traffic under the specified topology instance and enters address-family topology configuration mode.


hello-interval

To configure the hello interval for the Enhanced Interior Gateway Routing Protocol (EIGRP) address-family or service-family configurations, use the hello-interval command in address-family interface configuration mode or service-family interface configuration mode. To configure the default hello interval, use the no form of this command.

hello-interval seconds

no hello-interval

Syntax Description

seconds

Hello interval in seconds. The range is 1 to 65535. The default is 60 for low-speed nonbroadcast multiaccess (NBMA) networks, and 5 for all other networks.


Command Default

The EIGRP hello interval is 60 seconds for low-speed NBMA networks and 5 seconds for all other networks.

Command Modes

Address-family interface configuration (config-router-af-interface)
Service-family interface configuration (config-router-sf-interface)

Command History

Release
Modification

15.0(1)M

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.

12.2(33)SXI4

This command was integrated into Cisco IOS Release 12.2(33)SXI4.


Usage Guidelines

The 60-second default applies only to low-speed, NBMA media. Low speed is considered a rate of T1 or slower, as specified by the bandwidth command in interface configuration mode.

For the purposes of EIGRP, Frame Relay and Switched Multimegabit Data Service (SMDS) networks are considered to be NBMA if the interface has not been configured to use physical multicasting. Otherwise, Frame Relay and SMDS networks are not considered to be NBMA.

Examples

The following example configures a 10-second hello interval for address-family Ethernet interface 0/0:

Router(config)# router eigrp virtual-name 
Router(config-router)# address-family ipv4 autonomous-system 4453 
Router(config-router-af-interface)# af-interface ethernet0/0
Router(config-router-af-interface)# hello-interval 10

The following example sets a 10 second hello-interval for service-family Ethernet interface 0/0:

Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# sf-interface Ethernet 0/0
Router(config-router-sf-interface)# hello-interval 10

Related Commands

Command
Description

address-family (EIGRP)

Enters address-family configuration mode to configure an EIGRP routing instance.

af-interface

Enters address-family interface configuration mode to configure interface-specific EIGRP commands.

hold-time

Configures the hold time for EIGRP address-family or service-family configurations.

router eigrp

Configures the EIGRP address-family process.

service-family

Specifies service-family configuration mode.

sf-interface

Configures interface-specific commands under a service family.


hold-time

To configure the hold time for Enhanced Interior Gateway Routing Protocol (EIGRP) address-family or service-family configurations, use the hold-time command in address-family interface configuration mode or service-family interface configuration mode. To configure the default hold time, use the no form of this command.

hold-time seconds

no hold-time

Syntax Description

seconds

Interval, in seconds, before a neighbor is considered down. Valid range is 1 to 65535 seconds (approximately 18 hours). The default is 180 seconds for low-speed nonbroadcast multiaccess (NBMA) networks and 15 seconds for all other networks.


Command Default

The EIGRP hold time is 180 seconds for NBMA networks and 15 seconds for all other networks.

Command Modes

Address-family interface configuration (config-router-af-interface)
Service-family interface configuration (config-router-sf-interface)

Command History

Release
Modification

15.0(1)M

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

12.2(33)XNE

This command was integrated into Cisco IOS Release 12.2(33)XNE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.

12.2(33)SXI4

This command was integrated into Cisco IOS Release 12.2(33)SXI4.


Usage Guidelines

On very congested and large networks, the default hold time may not be sufficient for all routers and access servers to receive hello packets from neighbors. In this case, increase the hold time duration. The hold time should be at least three times the hello interval. If a router does not receive a hello packet within the specified hold time, services through this router are considered unavailable. Increasing the hold time will delay route convergence across the network.

Examples

The following example sets a 50-second hold time for address-family Ethernet interface 0/0:

Router(config)# router eigrp virtual-name 
Router(config-router)# address-family ipv4 autonomous-system 4453 
Router(config-router-af-interface)# af-interface ethernet0/0
Router(config-router-af-interface)# hold-time 50

The following example sets a 40-second hold time for service-family Ethernet interface 0/0:

Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# sf-interface Ethernet 0/0
Router(config-router-sf-interface)# hold-time 40

Related Commands

Command
Description

address-family (EIGRP)

Enters address-family configuration mode to configure an EIGRP routing instance.

af-interface

Enters address-family interface configuration mode to configure interface-specific EIGRP commands.

router eigrp

Configures the EIGRP routing process.

hello-interval

Configures the hello interval for EIGRP address-family or service-family configurations.

router eigrp

Configures the EIGRP address-family process.

service-family

Specifies service-family configuration mode.

sf-interface

Configures interface-specific commands under service-family.