Guest

Support

1-Port DSU/CSU T1 WIC for the Cisco 1700, Cisco 2600, Cisco 3600, and Cisco 3700 Series Routers

  • Viewing Options

  • PDF (156.6 KB)
  • Feedback
1-Port DSU/CSU T1 WIC for the Cisco 1700, Cisco 2600, Cisco 3600, and Cisco 3700 Series Routers

Table Of Contents

1-Port DSU/CSU T1 WIC for the Cisco 1700, Cisco 2600, Cisco 3600, and Cisco 3700 Series Routers

Feature Overview

Benefits

Related Documents

Supported Platforms

Supported Standards, MIBs, and RFCs

Prerequisites

Configuration Tasks

Configuring Short Cable Transmission Attenuation

Verifying Configuration of Short Cable Transmission Attenuation

Enabling Remote Loopback Testing

Verifying Enabling of Remote Loopback Testing

Configuration Example

Command Reference


1-Port DSU/CSU T1 WIC for the Cisco 1700, Cisco 2600, Cisco 3600, and Cisco 3700 Series Routers


Feature History

Release
Modification

11.2

This feature was introduced on the Cisco 1600 series and Cisco 3600 series routers.

12. 2( 15)ZL

Version 2 of this feature is introduced on the Cisco 1700, Cisco 2600, Cisco 3600 and Cisco 3700 series routers, and the Cisco ICS 7750 communications manager.


This feature module describes the 1-port data service unit/channel service unit (DSU/CSU) WAN interface card (WIC) for Cisco 1700, 2600, 3600, and 3700 series routers. It describes the benefits of the new feature, supported platforms, configuration, and related documents, and provides command reference information.

This document includes the following sections:

Feature Overview

Supported Platforms

Supported Standards, MIBs, and RFCs

Prerequisites

Configuration Tasks

Configuration Example

Command Reference

Feature Overview

The Cisco WIC-1DSU-T1-V2 is an integrated, managed, T1 or fractional T1 WAN interface card (WIC). It provides nonchannelized data rates of 1 to 24 X 64 kbps or 1 to 24 X 56 kbps and follows ANSI T1.403 and AT&T Publication 62411 standards.

The Cisco WIC-1DSU-T1-V2 interface management features include the following:

You can remotely configure the interface using Telnet and the Cisco IOS command line interface (CLI).

For monitoring purposes, the router and DSU/CSU are manageable as a single Simple Network Management Protocol (SNMP) entity, using CiscoWorks or CiscoView. DSU/CSU statistics are accessed from the CLI.

The SNMP agent supports the standard Management Information Base II (MIB II), Cisco integrated DSU/CSU MIB, and T1 MIB (RFC 1406).

Loopbacks (including a manual button for a network line loopback) are provided for troubleshooting.

Transmission attenuation can be tailored to cable length using the CLI.

Test patterns, alarm counters, and performance reports are accessible using the CLI.

The module has carrier detect, loopback, and alarm LEDs.

Benefits

This T1 DSU/CSU card works on the Cisco 1700, 2600, and 3600 series platforms, and allows customers to integrate more peripheral network components into the chassis. This is especially valuable to customers who deploy large scale, end-to-end Cisco-based branch networks.

Other benefits of this solution include the following:

Fewer devices to deploy and manage

Simplified management of the router

DSU/CSU as a single entity

Remote/local configuration, monitoring, and troubleshooting by using the CLI

Single vendor support

Enhanced reliability

Physical space savings

Related Documents

Cisco Interface Card Documentation

Cisco Interface Card Installation Guide

Quick Start Guide: Interface Cards for Cisco 1600 Series, Cisco 1700 Series, Cisco 2600 Series, Cisco 3600 Series, and Cisco 3700 Series Routers

Cisco 1700 Series Routers Documentation

Cisco 1720 Router Hardware Installation Guide

Quick Start Guide, Cisco 1720 Router

Cisco 1721 Router Hardware Installation Guide

Quick Start Guide, Cisco 1721 Router

Cisco 1751 Router Hardware Installation Guide

Cisco 1760 Router Hardware Installation Guide

Quick Start Guide, Cisco 1760 Router

Cisco 2600 Series Routers Documentation

Cisco 2600 Series Hardware Installation Guide

Cisco 3600 Series Routers Documentation

Cisco 3600 Series Hardware Installation Guide

Quick Start Guide, Cisco 3631 Router

Cisco 3700 Series Routers Documentation

Cisco 3700 Series Routers Hardware Installation Guide

Quick Start Guide, Cisco 3725 Router

Quick Start Guide, Cisco 3745 Router

Cisco ICS 7750 Documentation

ICS 7750 Documentation Roadmap

Supported Platforms

This feature is supported on the following platforms:

Cisco 1700 series routers

Cisco 2600XM and Cisco 2691 routers

Cisco 3631 routers

Cisco 3700 series routers

Cisco ICS 7750 communications manager

Determining Platform Support Through Cisco Feature Navigator

Cisco IOS software is packaged in feature sets that are supported on specific platforms. To get updated information regarding platform support for this feature, access Cisco Feature Navigator. Cisco Feature Navigator dynamically updates the list of supported platforms as new platform support is added for the feature.

Cisco Feature Navigator is a web-based tool that enables you to determine which Cisco IOS software images support a specific set of features and which features are supported in a specific Cisco IOS image. You can search by feature or release. Under the release section, you can compare releases side by side to display both the features unique to each software release and the features in common.

To access Cisco Feature Navigator, you must have an account on Cisco.com. If you have forgotten or lost your account information, send a blank e-mail to cco-locksmith@cisco.com. An automatic check will verify that your e-mail address is registered with Cisco.com. If the check is successful, account details with a new random password will be e-mailed to you. Qualified users can establish an account on Cisco.com by following the directions found at this URL:

http://www.cisco.com/register

Cisco Feature Navigator is updated regularly when major Cisco IOS software releases and technology releases occur. For the most current information, go to the Cisco Feature Navigator home page at the following URL:

http://www.cisco.com/go/fn

Availability of Cisco IOS Software Images

Platform support for particular Cisco IOS software releases is dependent on the availability of the software images for those platforms. Software images for some platforms may be deferred, delayed, or changed without prior notice. For updated information about platform support and availability of software images for each Cisco IOS software release, refer to the online release notes or, if supported, Cisco Feature Navigator.

Supported Standards, MIBs, and RFCs

Standards

No new or modified standards are supported by this feature.

MIBs

No new or modified MIBs are supported by this feature.

RFCs

No new or modified RFCs are supported by this feature.

Prerequisites

The following are prerequisites to enable the T1 CSU WIC:

Leased line from your telephone company

Configuration parameters as specified by your telephone company. For most connections, the following default settings should suffice:

service-module t1 clock source line

service-module t1 data-coding normal

service-module t1 timeslots all speed 64

service-module t1 framing esf

service-module t1 lbo none

service-module t1 linecode b8zs

no service-module t1 remote-alarm-enable

no service-module t1 fdl


Note In telephone company initiated loopback tests that use the QRSS test pattern, the WIC-1DSU-T1-V2 must be clocked from the line. Configuring the WIC-1DSU-T1-V2 and the telephone company to use the same clock source will result in errors.



Note To view the current configuration, enter the show service-module serial slot/port command. For further information about these commands and how to change them, refer to the Cisco IOS configuration guides and command references.


Configuration Tasks

See the following sections for configuration tasks for this feature.

Configuring Short Cable Transmission Attenuation

Enabling Remote Loopback Testing

Configuring Short Cable Transmission Attenuation

To configure transmission attenuation for short cable lengths (under 660 feet in length), use the following commands beginning in global configuration mode.

 
Command
Purpose

Step 1 

Router(config)# interface serial0/0

Enter the interface configuration mode.

Step 2 

Router(config-if)# service-module t1 cablelength short {110ft |220ft |330ft |440ft | 550ft |660ft}

Optional. Sets the transmission attenuation according to the length of the cable. For example, use the keyword 110ft if the cable length is from 0 to 110 feet. Use the keyword 220ft if the cable length is from 110 to 220 feet, and so on.

Verifying Configuration of Short Cable Transmission Attenuation

To verify the configuration of short cable transmission attenuation, enter the EXEC command show running-config interface serial<slot/port> replacing <slot/port> with the slot and port number of the serial interface. The following sample output shows transmission attenuation for a cable length between 0 and 110 feet:

Router#show running-config interface serial0/0 

Building configuration...

Current configuration : 252 bytes 
! 
interface Serial0/0 
 no ip address 
 load-interval 30 
 no keepalive 
 no fair-queue 
 service-module t1 cablelength short 110ft 
 service-module t1 framing sf 
 service-module t1 linecode ami 
 service-module t1 timeslots 1-24 speed 56 
 no cdp enable 
end

Enabling Remote Loopback Testing

To enable remote loopback testing for the WIC, use the following commands beginning in global configuration mode.

 
Command
Purpose

Step 1 

Router(config)# interface serial0/0

Enter the interface configuration mode.

Step 2 

Router(config-if)# service-module t1 remote-loopback {full | payload v54}

Optional. Specifies that the WIC-1DSU-T1-V2 card will enter loopback mode when it receives a loopback code on the line.

The keywords are as follows:

full—enables standard loopup codes: 1-in-5 pattern for loopup mode and 1-in-3 pattern for loopdown mode.

payload v54—enables v54 pseudo-random loopup and loopdown codes for loopup and loopdown modes.

Verifying Enabling of Remote Loopback Testing

To verify the loopback status of the current interface, after the far end has been put in loopback mode, enter the command show service-module serial<slot/port> replacing <slot/port> with the slot and port number of the serial interface. The output "Unit is currently in test mode: remote loopback is in progress", as shown in the following example, indicate that remote loopback testing is enabled:

Router#show service-module serial0/0 
Module type is T1/fractional 
    Hardware revision is 0.1, Software revision is 20021210, 
    Image checksum is 0x81277248, Protocol revision is 0.1 
Receiver has no alarms. 
Unit is currently in test mode: 
    remote loopback is in progress 
Framing is SF, Line Code is AMI, Current clock source is line, 
Fraction has 24 timeslots (56 Kbits/sec each), Net bandwidth is 1344 Kbits/sec. 
Last module self-test (done at startup): Passed 
Last clearing of alarm counters 01:52:27 
    loss of signal        :    1, last occurred 01:45:24 
    loss of frame         :    2, last occurred 01:45:24 
    AIS alarm             :    0, 
    Remote alarm          :    0, 
    Module access errors  :    0, 
Total Data (last 7 15 minute intervals): 
    255 Line Code Violations, 0 Path Code Violations 
    1 Slip Secs, 326 Fr Loss Secs, 6 Line Err Secs, 0 Degraded Mins 
    2 Errored Secs, 0 Bursty Err Secs, 7 Severely Err Secs, 327 Unavail Secs 
Data in current interval (445 seconds elapsed): 
    0 Line Code Violations, 0 Path Code Violations 
    0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins 
    0 Errored Secs, 0 Bursty Err Secs, 1 Severely Err Secs, 0 Unavail Secs 

Configuration Example

This section provides a configuration example for a Cis co 1751 router with a WIC-1DSU-T1-V2 card installed. It is in a short cable environment (between 330 and 440 feet here), and is set to enter loopback when a loopback code is received on the line.

Current configuration :
!
version 12.2
no parser cache
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 1751-uut1
!
interface Serial0/0
 ip address 10.0.0.51 255.0.0.0
 service-module t1 framing esf
 service-module t1 linecode b8zs
 service-module t1 timeslots 1-12 speed 64
 service-module t1 data-coding normal
 service-module t1 cablelength short 440ft
 service-module t1 remote-loopback full
!
interface FastEthernet0/0
 ip address 6.0.0.1 255.0.0.0
 speed auto
 full-duplex
!
ip classless
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Command Reference

The following new and modified commands are pertinent to this feature. To see the command pages for these commands and other commands used with this feature, go to the Cisco IOS Master Commands List, Release 12.4, at http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124mindx/
124index.htm
.

New Command

service-module t1 cablelength short

Modified Command

service-module t1 remote-loopback