Guest

Networking Software (IOS & NX-OS)

Using Link Layer Discovery Protocol in Multivendor Networks

  • Viewing Options

  • PDF (304.9 KB)
  • Feedback
Using Link Layer Discovery Protocol in Multivendor Networks

Table Of Contents

Using Link Layer Discovery Protocol in Multivendor Networks

Finding Feature Information

Contents

Prerequisites for Using Link Layer Discovery Protocol in Multivendor Networks

Restrictions for Using Link Layer Discovery Protocol in Multivendor Networks

Information About Using Link Layer Discovery Protocol in Multivendor Networks

IEEE 802.1ab LLDP

LLDP-MED

Classes of Endpoints

Types of Discovery Supported

Benefits of LLDP-MED

TLV Elements

Benefits of LLDP

How to Configure Link Layer Discovery Protocol in Multivendor Networks

Enabling and Disabling LLDP Globally

Enabling LLDP Globally

Disabling LLDP Globally

Disabling and Enabling LLDP on a Supported Interface

Disabling LLDP on a Supported Interface

Enabling LLDP on a Supported Interface

Setting LLDP Packet Hold Time

Setting LLDP Packet Frequency

Monitoring and Maintaining LLDP in Multivendor Networks

Enabling and Disabling LLDP TLVs

Enabling LLDP TLVs

Disabling LLDP TLVs

Enabling and Disabling LLDP-MED TLVs

Enabling LLDP-MED TLVs

Disabling LLDP-MED TLVs

Configuring Location TLV

Configuration Examples for Link Layer Discovery Protocol in Multivendor Networks

Example: Configuring LLDP on Two Routers

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Feature Information for Link Layer Discovery Protocol in Multivendor Networks


Using Link Layer Discovery Protocol in Multivendor Networks


First Published: August 21, 2007
Last Updated: February 7, 2011

Link Layer Discovery Protocol (LLDP), standardized by the IEEE as part of 802.1ab, enables standardized discovery of nodes, which in turn facilitates future applications of standard management tools such as Simple Network Management Protocol (SNMP) in multivendor networks. Using standard management tools makes physical topology information available and helps network administrators detect and correct network malfunctions and inconsistencies in configuration.

Media Endpoint Discovery (MED) is an LLDP enhancement that was formalized by the Telecommunications Industry Association (TIA) for voice over IP (VoIP) applications.

The Cisco implementation of LLDP is based on the IEEE 802.1ab standard. This document describes LLDP and LLDP-MED and how they are supported in Cisco IOS software.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature Information for Link Layer Discovery Protocol in Multivendor Networks" section.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for Using Link Layer Discovery Protocol in Multivendor Networks

Restrictions for Using Link Layer Discovery Protocol in Multivendor Networks

Information About Using Link Layer Discovery Protocol in Multivendor Networks

How to Configure Link Layer Discovery Protocol in Multivendor Networks

Configuration Examples for Link Layer Discovery Protocol in Multivendor Networks

Additional References

Feature Information for Link Layer Discovery Protocol in Multivendor Networks

Prerequisites for Using Link Layer Discovery Protocol in Multivendor Networks

Type-Length-Value (TLV) types 0 through 127

To support LLDP-MED, the following organizationally specific TLVs must be implemented:

Extended Power-via-Media Dependent Interface (MDI)

Inventory

LLDP-MED Capabilities

MAC/PHY Configuration Status

Network Policy

Port VLAN ID

Restrictions for Using Link Layer Discovery Protocol in Multivendor Networks

Use of LLDP is limited to 802.1 media types such as Ethernet, Token Ring, and Fiber Distributed Data Interface (FDDI) networks.

The maximum number of neighbor entries per chassis is limited on MED-capable network connectivity devices.

Information About Using Link Layer Discovery Protocol in Multivendor Networks

IEEE 802.1ab LLDP

LLDP-MED

TLV Elements

Benefits of LLDP

IEEE 802.1ab LLDP

IEEE 802.1ab LLDP is an optional link layer protocol for network topology discovery in multivendor networks. Discovery information includes device identifiers, port identifiers, versions, and other details. As a protocol that aids network management, LLDP provides accurate network mapping, inventory data, and network troubleshooting information.

LLDP is unidirectional, operating only in an advertising mode. LLDP does not solicit information or monitor state changes between LLDP nodes. LLDP periodically sends advertisements to a constrained multicast address. Devices supporting LLDP can send information about themselves while they receive and record information about their neighbors. Additionally, devices can choose to turn off the send or receive functions independently. Advertisements are sent out and received on every active and enabled interface, allowing any device in a network to learn about all devices to which it is connected. Applications that use this information include network topology discovery, inventory management, emergency services, VLAN assignment, and inline power supply.


Note LLDP and Cisco Discovery Protocol (CDP) can operate on the same interface.


Figure 1 shows a high-level view of LLDP operating in a network node.

Figure 1

LLDP Operating in a Network Node

When you configure LLDP or CDP location information on a per-port basis, remote devices can send Cisco medianet location information to the switch. For more information, refer to the Using Cisco Discovery Protocol module.

CDP allows only one wired switch to report the location information. CDP identifies and indicates the location of neighbor ports and ensures not to report the duplicate location information of the same device.

LLDP-MED

LLDP-MED operates between several classes of network equipment such as IP phones, conference bridges, and network connectivity devices such as routers and switches. By default, a network connectivity device sends out only LLDP packets until it receives LLDP-MED packets from an endpoint device. The network device then sends out LLDP-MED packets until the remote device to which it is connected ceases to be LLDP-MED capable.

To use LLDP-MED, you should understand the following concepts:

Classes of Endpoints

Types of Discovery Supported

Benefits of LLDP-MED

Classes of Endpoints

LLDP-MED network connectivity devices provide IEEE 802 network access to LLDP-MED endpoints. LLDP-MED supports the following three classes of endpoints:

Generic (class 1)—Basic participant endpoints; for example, IP communications controllers.

Media (class 2)—Endpoints that support media streams; for example, media gateways and conference bridges.

Communication Device (class 3)—Endpoints that support IP communications end users; for example, IP phones and Softphone.

Figure 2 shows an LLDP-MED-enabled LAN.

Figure 2

LLDP-MED Enabled LAN

Types of Discovery Supported

LLDP-MED provides support to discover the following types of information, which are crucial to efficient operation and management of endpoint devices and the network devices supporting them:

Capabilities—Endpoints determine the types of capabilities that a connected device supports and which ones are enabled.

Inventory—LLDP-MED support exchange of hardware, software, and firmware versions, among other inventory details.

LAN speed and duplex—Devices discover mismatches in speed and duplex settings.

Location identification—An endpoint, particularly a telephone, learns its location from a network device. This location information may be used for location-based applications on the telephone and is important when emergency calls are placed.

Network policy—Network connectivity devices notify telephones about the VLANs they should use.

Power—Network connectivity devices and endpoints exchange power information. LLDP-MED provides information about how much power a device needs and how a device is powered. LLDP-MED also determines the priority of the device for receiving power.

Benefits of LLDP-MED

Follows an open standard

Supports E-911 emergency service, which is aided by location management

Provides fast start capability

Supports interoperability between multivendor devices

Supports inventory management (location, version, etc.)

Provides MIB support

Supports plug and play installation

Provides several troubleshooting (duplex, speed, network policy) mechanisms

TLV Elements

LLDP and LLDP-MED use TLVs to exchange information between network and endpoint devices. TLV elements are embedded in communications protocol advertisements and used for encoding optional information. The size of the type and length fields is fixed at 2 bytes. The size of the value field is variable. The type is a numeric code that indicates the type of field that this part of the message represents, and the length is the size of the value field, in bytes. The value field contains the data for this part of the message.

LLDP-MED supports the following TLVs:

LLDP-MED capabilities TLV—Allows LLDP-MED endpoints to determine the capabilities that the connected device supports and has enabled.

Network policy TLV—Allows both network connectivity devices and endpoints to advertise VLAN configurations and associated Layer 2 and Layer 3 attributes for the specific application on that port. For example, the switch can notify a phone of the VLAN number that it should use. The phone can connect to any switch, obtain its VLAN number, and then start communicating with the call control.

By defining a network-policy profile TLV, you can create a profile for voice and voice signalling by specifying the values for VLAN, class of service (CoS), differentiated services code point (DSCP), and tagging mode. These profile attributes are then maintained centrally on the switch and propagated to the phone.

Power management TLV—Enables advanced power management between LLDP-MED endpoint and network connectivity devices. Allows switches and phones to convey power information, such as how the device is powered, power priority, and how much power the device needs. Supports advertisement of fractional wattage power requirements, endpoint power priority, and endpoint and network connectivity-device power status but does not provide for power negotiation between the endpoint and the network connectivity devices.
When LLDP is enabled and power is applied to a port, the power TLV determines the actual power requirement of the endpoint device so that the system power budget can be adjusted accordingly. The switch processes the requests and either grants or denies power based on the current power budget. If the request is granted, the switch updates the power budget. If the request is denied, the switch turns off power to the port, generates a syslog message, and updates the power budget. If LLDP-MED is disabled or if the endpoint does not support the LLDP-MED power TLV, the initial allocation value is used throughout the duration of the connection.


Note A system power budget is the default power allocated to a device based on its device class. However, the total power that can be sourced from a switch is finite, and there will be some power budgeting done by the power module based on the number of ports already being served, total power that can be served, and how much new ports are requesting.


Inventory management TLV—Allows an endpoint to send detailed inventory information about itself to the switch, including information hardware revision, firmware version, software version, serial number, manufacturer name, model name, and asset ID TLV.

Location TLV—Provides location information from the switch to the endpoint device. The location TLV can send this information:

Civic location information—Provides the civic address information and postal information. Examples of civic location information are street address, road name, and postal community name information.

ELIN location information—Provides the location information of a caller. The location is determined by the Emergency location identifier number (ELIN), which is a phone number that routes an emergency call to the local public safety answering point (PSAP) and which the PSAP can use to call back the emergency caller.

Benefits of LLDP

Follows IEEE 802.1ab standard.

Enables interoperability among multivendor devices.

Facilitates troubleshooting of enterprise networks and uses standard network management tools.

Provides extension for applications such as VoIP.

How to Configure Link Layer Discovery Protocol in Multivendor Networks

Enabling and Disabling LLDP Globally

Disabling and Enabling LLDP on a Supported Interface

Setting LLDP Packet Hold Time

Setting LLDP Packet Frequency

Monitoring and Maintaining LLDP in Multivendor Networks

Enabling and Disabling LLDP TLVs

Enabling and Disabling LLDP-MED TLVs

Configuring Location TLV

Enabling and Disabling LLDP Globally

LLDP is disabled globally by default. This section describes the tasks for enabling and disabling LLDP globally.

Enabling LLDP Globally

Perform this task to enable LLDP globally.

SUMMARY STEPS

1. enable

2. configure terminal

3. lldp run

4. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

lldp run

Example:

Router(config)# lldp run

Enables LLDP globally.

Step 4 

end

Example:

Router(config)# end

Returns the command-line interface (CLI) to privileged EXEC mode.

Disabling LLDP Globally

Perform this task to disable LLDP globally.

SUMMARY STEPS

1. enable

2. configure terminal

3. no lldp run

4. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

no lldp run

Example:

Router(config)# no lldp run

Disables LLDP globally.

Step 4 

end

Example:

Router(config)# end

Returns the CLI to privileged EXEC mode.

Disabling and Enabling LLDP on a Supported Interface

LLDP is enabled by default on all supported interfaces. This section describes the tasks for disabling and enabling LLDP on a supported interface.

Disabling LLDP on a Supported Interface

Perform this task to disable LLDP on a supported interface.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. no lldp {med-tlv-select tlv | receive | transmit}

5. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Router(config)# interface ethernet 0/1

Specifies the interface type and number and enters interface configuration mode.

Step 4 

no lldp {med-tlv-select tlv | receive | transmit}

Example:

Router(config-if)# no lldp receive

Disables an LLDP-MED TLV or LLDP packet reception on a supported interface.

Step 5 

end

Example:

Router(config-if)# end

Returns the CLI to privileged EXEC mode.

Enabling LLDP on a Supported Interface

LLDP information can be transmitted and received only on an interface where LLDP is configured and enabled. Perform this task to enable LLDP.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. lldp {med-tlv-select tlv | receive | transmit}

5. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Router(config)# interface ethernet 0/1

Specifies the interface type and number and enters interface configuration mode.

Step 4 

lldp {med-tlv-select tlv | receive | transmit}

Example:

Router(config-if)# lldp transmit

Enables an LLDP-MED TLV or LLDP packet transmission on a supported interface.

Step 5 

end

Example:

Router(config-if)# end

Returns the CLI to privileged EXEC mode.

Setting LLDP Packet Hold Time

Hold time is the duration that a receiving device should maintain LLDP neighbor information before aging it. Perform this task to define a hold time for an LLDP-enabled device.

SUMMARY STEPS

1. enable

2. configure terminal

3. lldp holdtime seconds

4. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

lldp holdtime seconds

Example:

Router(config)# lldp holdtime 100

Specifies the hold time.

Step 4 

end

Example:

Router(config)# end

Returns the CLI to privileged EXEC mode.

Setting LLDP Packet Frequency

Perform this task to specify an interval at which the Cisco IOS software sends LLDP updates to neighboring devices.

SUMMARY STEPS

1. enable

2. configure terminal

3. lldp timer rate

4. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

lldp timer rate

Example:

Router(config)# lldp timer 75

Specifies the rate at which LLDP packets are sent.

Step 4 

end

Example:

Router(config)# end

Returns the CLI to privileged EXEC mode.

Monitoring and Maintaining LLDP in Multivendor Networks

Perform this task to monitor and maintain LLDP in multivendor networks. This task is optional, and Steps 2 and 3 can be performed in any sequence.

SUMMARY STEPS

1. enable

2. show lldp [entry {* | word} | errors | interface [ethernet number] | neighbors [ethernet number | detail] | traffic]

3. clear lldp {counters | table}

4. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

show lldp [entry {* | word} | errors | interface [ethernet number] | neighbors [ethernet number | detail] | traffic]

Example:

Router# show lldp entry *

Displays summarized and detailed LLDP information.

Note When the show lldp neighbors command is issued, if the device ID has more than 20 characters, the ID is truncated to 20 characters in command output because of display constraints.

Step 3 

clear lldp {counters | table}

Example:

Router# clear lldp counters

Resets LLDP traffic counters and tables to zero.

Step 4 

end

Example:

Router# end

Returns the CLI to user EXEC mode.

Enabling and Disabling LLDP TLVs

LLDP TLV support is enabled by default if LLDP is enabled globally and locally on a supported interface. Specific TLVs, however, can be enabled and suppressed.

Enabling LLDP TLVs

Perform this task to enable an LLDP TLV on a supported interface.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. lldp tlv-select tlv

5. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Router(config)# interface ethernet 0/1

Specifies the interface type and number on which to enable LLDP-MED and enters interface configuration mode.

Step 4 

lldp tlv-select tlv

Example:

Router(config-if)# lldp tlv-select system-description

Enables a specific LLDP TLV on a supported interface.

Step 5 

end

Example:

Router(config-if)# end

Returns the CLI to privileged EXEC mode.

Disabling LLDP TLVs

Perform this task to disable an LLDP TLV on a supported interface.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. no lldp tlv-select tlv

5. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Router(config)# interface ethernet 0/1

Specifies the interface type and number on which to disable LLDP-MED and enters interface configuration mode.

Step 4 

no lldp tlv-select tlv

Example:

Router(config-if)# no lldp tlv-select system-description

Disables a specific LLDP TLV on a supported interface.

Step 5 

end

Example:

Router(config-if)# end

Returns the CLI to privileged EXEC mode.

Enabling and Disabling LLDP-MED TLVs

LLDP-MED TLV support is enabled by default if LLDP is enabled globally and locally on a supported interface. Specific TLVs, however, can be enabled and suppressed.

Enabling LLDP-MED TLVs

Perform this task to enable a specific LLDP-MED TLV on a supported interface.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. lldp med-tlv-select tlv

5. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Router(config)# interface ethernet 0/1

Specifies the interface type and number on which to enable LLDP-MED and enters interface configuration mode.

Step 4 

lldp med-tlv-select tlv

Example:

Router(config-if)# lldp med-tlv-select inventory-management

Enables a specific LLDP-MED TLV on a supported interface.

Step 5 

end

Example:

Router(config-if)# end

Returns the CLI to privileged EXEC mode.

Disabling LLDP-MED TLVs

Perform this task to disable a specific LLDP-MED TLV from a supported interface.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. no lldp med-tlv-select tlv

5. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Router(config)# interface ethernet 0/1

Specifies the interface type and number on which to disable LLDP-MED and enters interface configuration mode.

Step 4 

no lldp med-tlv-select tlv

Example:

Router(config-if)# no lldp med-tlv-select inventory-management

Disables a specific LLDP-MED TLV from a supported interface.

Step 5 

end

Example:

Router(config-if)# end

Returns the CLI to privileged EXEC mode.

Configuring Location TLV

Perform this task to enable the location TLV on a Cisco device.


Note When you configure location information from various modules, such as CDP, LLDP, and LLDP-MED, you can use the location prefer command to configure the priority. For more information on the location prefer command, see the Cisco IOS Network Management Command Reference Guide.


SUMMARY STEPS

1. enable

2. configure terminal

3. location {admin-tag string | civic-location identifier id | elin-location string identifier id}

4. exit

5. interface type number

6. location {additional-location-information word | civic-location-id id [port-location] | elin-location-id id}

7. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

location {admin-tag string | civic-location identifier id | elin-location string identifier id}

Example:

Router(config)# location admin-tag location1

Specifies the location information for an endpoint and enters civic location configuration mode.

Step 4 

exit

Example:

Router(config-civic)# exit

Returns the CLI to global configuration mode.

Step 5 

interface type number

Example:

Router(config)# interface fastethernet 0

Specifies the interface on which you are configuring the location information, and enters interface configuration mode.

Step 6 

location {additional-location-information word | civic-location-id id [port-location]| elin-location-id id}

Example:

Router(config-if)# location civic-location-id 1 port-location

Specifies location information for an interface, and enters civic location port configuration mode.

You can configure port-specific information in civic location port configuration mode.

Step 7 

end

Example:

Router(config-if-port)# end

Returns the CLI to privileged EXEC mode.

Configuration Examples for Link Layer Discovery Protocol in Multivendor Networks

Example: Configuring LLDP on Two Routers

Example: Configuring LLDP on Two Routers

The following example shows LLDP configurations for two routers in a network. Hold time, a timer value, and TLVs are configured for each router. In each case an assumption is made that the Ethernet interfaces being configured are in the UP state.

! Configure LLDP on Router 1 with hold time, timer, and TLV options.

Router1> enable
Router1# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.

Router1(config)# lldp run
Router1(config)# lldp holdtime 150
Router1(config)# lldp timer 15
Router1(config)# lldp tlv-select port-vlan
Router1(config)# lldp tlv-select mac-phy-cfg
Router1(config)# interface ethernet 0/0
Router1(config-if)# end

00:08:32: %SYS-5-CONFIG_I: Configured from console by console

! Show the updated running configuration. LLDP is enabled with hold time, timer, and TLV 
options configured.

Router1# show running-config

Building configuration...

Current configuration : 1397 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone PST -8
ip subnet-zero
!
!
lldp timer 15
lldp holdtime 150
!
!
!         
interface Loopback0
 ip address 127.0.0.1 255.255.255.255
!
interface Ethernet0/0
 no ip address
 shutdown
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Ethernet1/0
 no ip address
 shutdown
!         
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Serial2/0
 no ip address
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/2
 no ip address
 shutdown
 serial restart-delay 0
!         
interface Serial3/3
 no ip address
 shutdown
 serial restart-delay 0
!
ip classless
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end 

! Configure LLDP on Router 2 with hold time, timer, and TLV options.

Router2> enable
Router2# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.

Router2(config)# lldp run
Router2(config)# lldp holdtime 150
Router2(config)# lldp timer 15
Router2(config)# lldp tlv-select port-vlan
Router2(config)# lldp tlv-select mac-phy-cfg
Router2(config)# interface ethernet 0/0
Router2(config-if)# end

00:08:32: %SYS-5-CONFIG_I: Configured from console by console

! Show the updated running configuration on Router 2. LLDP is enabled with hold time, 
timer, and TLV options configured.

Router2# show running-config
Building configuration...

Current configuration : 1412 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone PST -8
ip subnet-zero
!
!
lldp timer 15
lldp holdtime 150
!
!
!         
interface Loopback0
 ip address 127.0.0.1 255.255.255.255
!
interface Ethernet0/0
 no ip address
 shutdown
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Ethernet1/0
 no ip address
 shutdown
!         
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Serial2/0
 no ip address
 no fair-queue
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/3
 no ip address
 shutdown
 serial restart-delay 0
!
ip classless
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!         
end
! After both routers are configured for LLDP, issue the show command from each router to 
view traffic and device information.

Router1# show lldp traffic

LLDP traffic statistics:
    Total frames out: 20
    Total entries aged: 0
    Total frames in: 15
    Total frames received in error: 0
    Total frames discarded: 0
    Total TLVs unrecognized: 0

Router1# show lldp neighbors

Capability codes:
    (R) Router, (B) Bridge, (T) Telephone, (C) DOCSIS Cable Device
    (W) WLAN Access Point, (P) Repeater, (S) Station, (O) Other

Device ID           Local Intf     Hold-time  Capability      Port ID
Router2             Et0/0          150        R               Et0/0

Total entries displayed: 1

Router2# show lldp traffic

LLDP traffic statistics:
    Total frames out: 15
    Total entries aged: 0
    Total frames in: 17
    Total frames received in error: 0
    Total frames discarded: 2
    Total TLVs unrecognized: 0

Router2# show lldp neighbors

Capability codes:
    (R) Router, (B) Bridge, (T) Telephone, (C) DOCSIS Cable Device
    (W) WLAN Access Point, (P) Repeater, (S) Station, (O) Other

Device ID           Local Intf     Hold-time  Capability      Port ID
Router1             Et0/0          150        R               Et0/0

Total entries displayed: 1

Additional References

Related Documents

Related Topic
Document Title

LLDP

Link Layer Discovery Protocol

Comparison of LLDP Media Endpoint Discovery (MED) and Cisco Discovery Protocol

LLDP-MED and Cisco Discovery Protocol

LLDP commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples

Cisco IOS Carrier Ethernet Command Reference

Cisco IOS commands: master list of commands with complete command syntax, command mode, command history, defaults, usage guidelines, and examples

Cisco IOS Master Commands List, All Releases


Standards

Standard
Title

IEEE 802.1ab

Station and Media Access Control Connectivity Discovery


MIBs

MIB
MIBs Link

PTOPO MIB

To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

RFC 2922

Physical Topology MIB


Technical Assistance

Description
Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html


Feature Information for Link Layer Discovery Protocol in Multivendor Networks

Table 1 lists the features in this module and provides links to specific configuration information.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 1 lists only the Cisco  software release that introduced support for a given feature in a given Cisco  software release train. Unless noted otherwise, subsequent releases of that Cisco  software release train also support that feature.


Table 1 Feature Information for Using Link Layer Discovery Protocol in Multivendor Networks 

Feature Name
Releases
Feature Information

IEEE 802.1ab LLDP (Link Layer Discovery Protocol)

12.2(33)SXH

LLDP, standardized by the IEEE as part of 802.1ab, enables standardized discovery of nodes, which in turn facilitates future applications of standard management tools such as SNMP in multivendor networks.

The following commands were introduced or modified: clear lldp, lldp and show lldp.

ANSI TIA-1057 LLDP-MED Support

12.2(33)SXH

MED is an LLDP enhancement that was formalized by the TIA for VoIP applications. The Cisco implementation of LLDP is based on the IEEE 802.1ab standard.

The following commands were introduced or modified: lldp, lldp (interface).

Per Port Location Configuration

12.2(55)SE

The Per Port Location Configuration feature provides a mechanism to configure the location attributes specific to different ports.

The following sections provide information about this feature:

IEEE 802.1ab LLDP

Configuring Location TLV

The following commands were introduced or modified: location, location (interface), location prefer, show location, show nmsp.

Duplication Location Reporting Issue

12.2(55)SE

The Duplication Location Reporting Issue feature ensures CDP to allow only one wired switch to report the location information by identifying and indicating the location of neighbor ports not to report the duplicate location information of the same device.

The following sections provide information about this feature:

IEEE 802.1ab LLDP

No commands were introduced or modified by this feature.