Guest

Cisco Network Modules

Cisco WLAN Controller Network Module Feature Guide

  • Viewing Options

  • PDF (811.5 KB)
  • Feedback
Cisco Wireless LAN Controller Module Feature Guide

Table Of Contents

Cisco Wireless LAN Controller Module Feature Guide

Contents

Prerequisites for the Cisco WLAN Controller Module

Information About the Cisco WLAN Controller Module

Hardware Overview

Power over Ethernet

Connecting Access Points

Software Features and Benefits

How to Configure the Cisco WLAN Controller Module

Overview of the Configuration Process

Accessing the CLI Through a Console Connection or Through Telnet

Understanding Interfaces on the Cisco WLAN Controller Module

Using Interface Configuration Mode

Configuring the Cisco WLAN Controller Module in the Router

Prerequisites

Running the Configuration Wizard

Configuring and Verifying Management and AP Manager Interfaces

Configuring WLANs on the Cisco WLAN Controller Module

Example

Upgrading the Cisco WLAN Controller Module Software

Restrictions

Example

Saving Configurations

Erasing and Resetting the WLAN Controller Module Configuration

Additional References

Related Documents

Technical Assistance

service-module wlan-controller

Open Source License Acknowledgements

OpenSSL/Open SSL Project

License Issues


Cisco Wireless LAN Controller Module Feature Guide


The Cisco wireless LAN (WLAN) controller module (WLCM) is designed to provide small and medium-sized businesses (SMBs) and enterprise branch office customers 802.11 wireless networking solutions for Cisco 2800 and Cisco 3800 series integrated services routers (ISRs) and Cisco 3700 series routers. The Cisco WLAN controller module enables Cisco ISRs and Cisco 3700 series routers to manage up to six WLAN access points (AP) and simplifies deploying and managing wireless LANs. The operating system manages all data client, communications, and system administration functions, performs Radio Resource Management (RRM) functions, manages system-wide mobility policies using the operating system security (OSS), and coordinates all security functions using the OSS framework. The Cisco WLAN controller module works in conjunction with Cisco Aironet lightweight access points, Cisco Wireless Control System (WCS), and the Cisco Wireless Location Appliance to support mission-critical wireless data, voice, and video applications.


Note The Cisco 2801 integrated services router does not support the Cisco WLAN controller module.


Feature History for the Cisco WLAN Controller Module

Release
Modification

3.2.78.0 (controller software)

This feature was introduced.

12.4T (router software)

This feature was introduced.


For more information about the Cisco WLAN solution, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html

Contents

Prerequisites for the Cisco WLAN Controller Module

Information About the Cisco WLAN Controller Module

How to Configure the Cisco WLAN Controller Module

Additional References

Prerequisites for the Cisco WLAN Controller Module

The Cisco WLAN controller module operating system on the Cisco WLAN controller module must be compatible with the Cisco IOS software release and feature set on the router. See the "Feature History for the Cisco WLAN Controller Module" section.

Use the following commands to view the IOS version on the router, and the OS version on the WLAN controller module.

To view the, Cisco IOS software release and feature set, enter the show version command in privileged EXEC mode on the router.

To view the Cisco WLAN controller module OS version, enter the show sysinfo: command at the WLAN controller prompt.

Information About the Cisco WLAN Controller Module

This section describes the features of and some important concepts about the Cisco WLAN controller module:

Hardware Overview

Software Features and Benefits


Note The WLAN controller module does not manage the integrated access points (HWIC-AP modules) on ISRs.


Hardware Overview

The Cisco WLAN controller module is supported on the following router platforms:

Cisco 3725 and 3745 routers

For information about Cisco 3700 series routers wireless support, see the following URL:

http://www.cisco.com/en/US/products/hw/routers/ps282/tsd_products_support_series_home.html

Cisco 2811, 2821, and 2851 integrated services routers

For information about Cisco 2800 integrated services routers wireless support, see the following URL:

http://www.cisco.com/en/US/products/ps5854/tsd_products_support_series_home.html

Cisco 3825 and 3845 integrated services routers

For information about Cisco 3800 integrated services routers wireless support, see the following URL:

http://www.cisco.com/en/US/products/ps5855/tsd_products_support_series_home.html

Cisco WLAN controller modules ship with and boot from an installed 256-MB CompactFlash memory card. The CompactFlash memory card contains the boot loader, Linux kernel, Cisco WLAN controller module and access points executable file, and Cisco WLAN controller module configuration.


Note The CompactFlash memory card in the Cisco WLAN controller module is not field-replaceable.


Figure 1 shows the faceplate of the Cisco WLAN controller module.


Note The external Fast Ethernet port on the faceplate of the Cisco WLAN controller module is not supported.


Figure 1 Cisco Wireless LAN Controller Module Faceplate


Note You can install only one Cisco WLAN controller module in a single router chassis.



Note The wireless LAN controller module is supported only in network module slots. It is not supported in EVM slots available in the Cisco 2821 and Cisco 2851 integrated services routers.



Figure 2 shows how the Cisco WLAN controller module can be simultaneously deployed across multiple floors and buildings in a wired branch office with secure data, voice, switching, and wireless.

Figure 2 Cisco WLAN Controller Module Deployment for Converged Wireless with Secure Data, Voice, Switching, and Wireless

The Cisco Wireless Control System (WCS) allows users to design, control, and monitor enterprise wireless networks from a centralized location. The Cisco WCS is an optional network component that works in conjunction with Cisco APs and Cisco WLAN controllers.

The Cisco 2700 series location appliance is also an optional network component that enhances the high-accuracy built-in Cisco WCS location-tracking abilities by computing, collecting, and storing historical location data. This data can be displayed in the Cisco WCS. In this role, the location appliance acts as a server to one or more Cisco WCS servers, collecting, storing, and passing on data from its associated controllers. For complete information about managing the Cisco WLAN location appliance, see the following URL:

http://www.cisco.com/en/US/products/ps6386/tsd_products_support_series_home.html

Power over Ethernet

Power over Ethernet (PoE) is supported on Cisco ISR routers. When using PoE, the installer runs a single CAT-5 cable from each access point to PoE-equipped network elements, such as a PoE compliant Cisco EtherSwitch service module on the integrated services router or a Cisco Catalyst 3750 switch with PoE. When the PoE equipment determines that the access point is PoE-enabled, it sends -48 VDC over the unused pairs in the Ethernet cable to power the access point.

Connecting Access Points

Access points can be connected to a separate switch or to a Cisco EtherSwitch service module on the ISR. The ISR family supports a range of integrated Cisco EtherSwitch service modules from 4 to 48 ports supporting PoE.


Note PoE is supported on Cisco EtherSwitch service modules only. Cisco Ethernet switch network modules (NM-16ESW and NMD-36ESW) do not support PoE.


Software Features and Benefits

The Cisco WLAN controller module and its associated Cisco access points can be concurrently managed by these operating system user interfaces:

Command line interface (CLI): The CLI is a full-featured but simple text-based, tree-structured interface that allows up to five users with Telnet-capable terminal emulators to simultaneously manage all aspects of the Cisco WLAN controller and associated Cisco access points. You can locally or remotely configure, monitor, and control individual Cisco WLAN controllers.

For more information about the CLI and a complete list of features available on the Cisco WLAN controller module, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html

Cisco WLAN controller module web GUI: The web user interface is built into each Cisco wireless LAN controller. The Web User Interface allows up to five users to simultaneously browse into the built-in Cisco wireless LAN controller http: or https: (http + SSL) web server, configure parameters, and monitor operational status for the Cisco wireless LAN controller and its associated access points.


Note Cisco recommends that you enable the https: and disable the http: interfaces to ensure more robust security for your Cisco WLAN solution.


Because the web user interface works with one Cisco wireless LAN controller at a time, the web user interface is especially useful when you wish to configure or monitor a single Cisco wireless LAN controller and its associated access points that support Lightweight Access Point Protocol (LWAPP). The web GUI is supported on Internet Explorer, version 6.0/SP1 or later.

For complete information about the GUI, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html

Cisco Wireless Control System (WCS): The Cisco Wireless Control System is the Cisco wireless LAN solution network management tool that adds to the capabilities of the web user interface and the CLI, moving from individual controllers to a network of controllers. The Cisco WCS runs on Windows 2000, Windows 2003, and Red Hat Enterprise Linux ES servers.

The Cisco WCS includes the same configuration, performance monitoring, security, fault management, and accounting options used at the Cisco wireless LAN controller level, but adds a graphical view of multiple controllers and managed access points.

For complete information about the Cisco WCS, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html

The Cisco WLAN controller module, together with the ISRs, supports IPSec security for wireless clients terminating on the ISR through the use of a VPN passthroughs on the Cisco WLAN controller module.

How to Configure the Cisco WLAN Controller Module

This section contains the following procedures:

Overview of the Configuration Process

Accessing the CLI Through a Console Connection or Through Telnet (required)

Understanding Interfaces on the Cisco WLAN Controller Module (optional)

Using Interface Configuration Mode

Configuring the Cisco WLAN Controller Module in the Router

Running the Configuration Wizard

Configuring and Verifying Management and AP Manager Interfaces

Configuring WLANs on the Cisco WLAN Controller Module

Upgrading the Cisco WLAN Controller Module Software

Saving Configurations

Erasing and Resetting the WLAN Controller Module Configuration


Note This section describes how to perform the initial configuration of a Cisco WLAN controller module installed in the router. This section does not provide configuration information on Cisco access points and other components (from the Cisco WLAN controller module). For this information, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html

Before installing, configuring, or upgrading a Cisco WLAN controller module, see the Cisco Wireless LAN Solution Product Guide.



Note Configuration of the Cisco WLAN controller module is possible only through the CLI wizard. Web Agent Configuration Wizard is not supported in this release.



Caution The router data rate is fixed at 9600. The data rate should not be changed on the router or on the Cisco WLAN controller module.

Overview of the Configuration Process

Table 1 shows the configuration process for the Cisco WLAN controller module.

Table 1 Configuration Process of the Cisco WLAN Controller Module 

 
What to Do
Location

Step 1 

Configure an WLAN interface on the router.

"Configuring the Cisco WLAN Controller Module in the Router" section

Step 2 

Open a session to the Cisco WLAN controller module.

"Configuring the Cisco WLAN Controller Module in the Router" section

Step 3 

Run the configuration wizard on the Cisco WLAN controller module.

"Running the Configuration Wizard" section

Step 4 

Configure management and AP-manager interfaces on the Cisco WLAN controller module.

"Configuring and Verifying Management and AP Manager Interfaces" section

Step 5 

Verify your connection from the router to the management and AP-manager interfaces.

"Configuring and Verifying Management and AP Manager Interfaces" section

Step 6 

Configure WLANs on the Cisco WLAN controller module.

"Configuring WLANs on the Cisco WLAN Controller Module" section


Accessing the CLI Through a Console Connection or Through Telnet

Before you can access the Cisco WLAN controller module CLI, you must first use one of these methods to establish a connection from the host router:

Connect to the router console using Telnet or SSH and open a session to the module using the service-module wlan-controller slot/unit session command in privileged EXEC mode on the router.


Note Before you can establish a connection between the router and the Cisco WLAN controller module, you must configure an IP address on the wlan-controller interface on the Cisco WLAN controller module.



Note When connecting to the router through the console using Telnet or SSH from a client station, you must have IP connectivity from the client station to the router.


Use any Telnet TCP/IP or encrypted SSH package from a remote management station. The router must have network connectivity with Telnet or SSH allowed from the clients, and an enable or enable secret password configured. After you connect through the CLI, a Telnet session, or an SSH session, the user EXEC prompt appears on the management station.

The Cisco WLAN controller module supports one secure SSH session and up to 16 simultaneous Telnet sessions. Changes made by one Telnet user are reflected in all other Telnet sessions.

If your Cisco WLAN controller module is already configured, you can directly open a session to the WLAN controller and configure it through its CLI.

Understanding Interfaces on the Cisco WLAN Controller Module

Communication between the host router and the Cisco WLAN controller module is through the wlan-controller interface connection between the router and the Cisco WLAN controller module.

The Cisco WLAN controller module supports the wlan-controller interface configuration command. The interface numbering format on the Cisco WLAN controller module is slot/port.

For more detailed information about interface types on the controller module, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html

Using Interface Configuration Mode


Note Although the configure interface port interface name port command is available, the software automatically sets the port value to port 1 and there is no need to manually configure the port.


The Fast Ethernet internal interface on the Cisco WLAN controller module connects internally to the wlan-controller interface 1/0 on the router (if the WLAN controller module is inserted in slot 1 of the router).

The port numbering scheme that you use in interface configuration mode is interface type/slot number/port number.

Type—The interface type interface wlan-controller.

Slot numberThe slot number on the router where the Cisco WLAN controller module is plugged in.

Port number—Port number within the Cisco WLAN controller module. For this release, the port number is always 0.

Configuring the Cisco WLAN Controller Module in the Router

This section describes how to perform the initial configuration of the router with a Cisco WLAN controller module installed. This section also describes the initial configuration of the Cisco WLAN controller module itself.

For advanced information about configuring the Cisco WLAN controller, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html

Prerequisites

Before installing, configuring, or upgrading the Cisco WLAN controller module, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html


Note For complete information about command syntax and attributes, see the Cisco Wireless LAN Controller Command Reference at the following URL:

http://www.cisco.com/en/US/products/ps6308/prod_command_reference_list.html


SUMMARY STEPS

1. enable

2. configure terminal

3. interface wlan-controller slot/port

4. ip address ip address/subnet mask

5. no shutdown

6. end

7. service-module wlan-controller slot/port session

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router# enable

Enters privileged EXEC mode.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface wlan-controller slot/port

Example:

Router(config)# interface wlan-controller 1/0

Enters interface configuration mode, and specifies an interface for configuration.

Step 4 

ip address ip address/subnet mask

Example:

Router(config-if)# ip address 192.0.2.254 255.255.255.0

Configures an IP address and subnet mask on this controller interface.

Step 5 

no shutdown

Example:

Router(config-if)# no shutdown

Enables the module port.

Step 6 

end

Example:

Router(config-if)# end

Returns you to privileged EXEC mode.

Step 7 

service-module wlan-controller slot/port session

Example:

Router# service-module wlan-controller 1/0 session

Opens a session to the WLAN controller module.

If the Cisco WLAN controller module has no prior configuration, the configuration wizard automatically starts. You cannot bypass the configuration wizard. Through the CLI, you must provide the information at the prompts provided. For information about the configuration wizard, see the Running the Configuration Wizard next.

Running the Configuration Wizard

When the controller boots at factory defaults, the bootup script runs the configuration wizard, which prompts the installer for initial configuration settings. Follow these steps to enter settings using the wizard on the CLI:


Step 1 The first wizard prompt is for the system name. Enter up to 32 printable ASCII characters.

Welcome to the Cisco Wizard Configuration Tool
Use the '-' character to backup
WLAN Controller:# anyname

Step 2 Enter an administrator username and password, each up to 24 printable ASCII characters.

Enter Administrative User Name (24 characters max): anyname
Enter Administrative Password (24 characters max): *****

Step 3 Enter the management interface IP address, netmask, default router IP address, optional VLAN identifier (a valid VLAN identifier, or 0 for untagged), and port number.

Management Interface IP Address: 192.0.2.24
Management Interface Netmask: 255.255.255.0
Management Interface Default Router: 192.0.2.254 
Management Interface VLAN Identifier (0 = untagged): 0
Management Interface Port Num [1]: 1

Step 4 Enter the IP address of the default DHCP server that will supply IP addresses to clients and the management interface if you use one.

Management Interface DHCP Server IP Address: 192.0.2.24

Step 5 Enter the IP addresses for the AP manager interface and AP manager DHCP server.

AP Manager Interface IP Address: 192.0.2.25
AP-Manager is on Management subnet, using same values
AP Manager Interface DHCP Server (192.0.2.24): 192.0.2.24

Step 6 Enter the virtual gateway IP address. This address can be any fictitious, unassigned IP address (such as 1.1.1.1) to be used by Layer 3 security and mobility managers.

Virtual Gateway IP Address: 1.1.1.1

Step 7 Enter the Cisco WLAN solution mobility group (RF group) name.

Mobility/RF Group Name: anyname-mg

Step 8 Enter the WLAN 1 service set identifier (SSID), or network name. This is the default SSID that access points use to associate to a controller.

Network Name (SSID): wlan-15

Step 9 Allow or disallow static IP addresses for clients. Enter yes to allow clients to supply their own IP addresses. Enter no to require clients to request an IP address from a DHCP server.

Allow Static IP Addresses [YES][no]: no

Step 10 If you need to configure a RADIUS Server, enter yes, and enter the RADIUS server IP address, the communication port, and the shared secret. If you do not need to configure a RADIUS server or you want to configure the server later, enter no.

Configure a RADIUS Server now? [YES][no]: no
Warning! The default WLAN security policy requires a RADIUS server.
Please see documentation for more details.

Enter a country code for the unit. To list the supported country codes, enter help or see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html

Enter Country Code (enter 'help' for a list of countries) [US]: US

Step 11 Enable or disable support for 802.11b, 802.11a, and 802.11g.

Enable 802.11b Network [YES][no]: yes
Enable 802.11a Network [YES][no]: yes
Enable 802.11g Network [YES][no]: yes

Enable or disable Radio Resource Management (RRM) (auto RF). For a complete description of RRM, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html

Enable Auto-RF [YES][no]: 

Configure a NTP server now? [YES][no]: yes 
Enter the NTP server's IP address: 192.0.2.24 
Enter a polling interval between 3600 and 604800 secs: 3600 

Configuration correct? If yes, system will save it and reset. [yes][NO]: yes

When you answer the last prompt, the controller saves the configuration, reboots with your changes, and prompts you to log in or to enter recover-config to reset to the factory default configuration and return to the wizard.

Configuration saved!
Resetting system with new configuration...

When the configuration wizard has completed initial configuration, the Cisco WLAN controller module automatically reboots with the new configuration and stops at the following:

User:

Step 12 You are prompted to configure the NTP server if necessary.

Configure a NTP server now? [YES][no]: yes 

Step 13 If you answer yes to configuring the NTP server, you are prompted to provide the NTP server IP address.

Enter the NTP server's IP address: 192.0.2.254 

Step 14 If you answer yes to configuring the NTP server, you are also prompted to provide the polling interval.

Enter a polling interval between 3600 and 604800 secs: 7200

Step 15 Supply the username and password.

User: anyname
Password: *****
(WLAN Controller)


Note Once the Cisco WLAN controller module interface has been configured and you boot the WLAN controller module image, you can switch back and forth between the router and the module by pressing Control-Shift-6, followed by x.


For more detailed information about initial configuration of the Cisco WLAN controller module, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html


Configuring and Verifying Management and AP Manager Interfaces

You can create any number of static or dynamic logical interfaces on the Cisco WLAN controller module, configured as VLAN tagged interfaces or untagged interfaces. By default, two static, untagged interfaces are assigned (management interface and ap-manager interface) and used for management and communication with APs. Since these interfaces are untagged, they must be assigned on the same subnet used to configure the WLAN controller interface on the router.

The management interface must have an IP address that can be reached from the workstation managing the interface. The AP manager interface allows the WLAN controller to communicate with APs.

WLAN Controller> config interface address management 192.0.2.24 255.255.255.0 192.0.2.254
WLAN Controller> config interface address ap-manager 192.0.2.25 255.255.255.0 192.0.2.254

The last IP address (192.0.2.254) is the default-gateway IP address for those interfaces and the IP address of the WLAN controller module interface on the router.

Send a ping from the router to the WLAN controller module management interface and AP manager interface.

Router:# ping 192.0.2.24
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.0.2.24, timeout is 2 seconds:
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

Router:# ping 192.0.2.25
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.0.2.25, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Router#

For information about configuring VLANs on the Cisco WLAN controller module, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html

Configuring WLANs on the Cisco WLAN Controller Module

The Cisco WLAN controller module can control up to 16 wireless LANs for access points. Each wireless LAN has a separate wireless LAN ID (1 through 16) and a separate wireless LAN SSID (wireless LAN name), and can be assigned unique security policies.


Note Cisco recommends that you assign one set of VLANs for wireless LANs and a different set of VLANs for management interfaces to ensure that controllers properly route VLAN traffic. Configure VLANs on the wlan-controller interface using IEEE 802.1Q trunking encapsulation. The number of VLANs configured on the router wlan-controller interface should be equal to the number of VLAN tags used on the Cisco WLAN controller module.

Native VLAN is not supported on the Cisco WLAN controller module; therefore, the router should not have any functional native VLANs configured.

For additional information about configuring VLANs on the Cisco WLAN controller module, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html


For complete information about configuring wireless LANs on the Cisco WLAN controller module, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html

To configure WLANs, activate them, assign the WLANs to a DHCP server, and assign WLANs to VLANs, follow the steps below.

SUMMARY STEPS

1. interface type slot/port

2. description string

3. ip address ip-address mask

4. load-interval seconds

5. duplex speed

6. speed speed

7. ip dhcp excluded-address low-address high-address

8. ip dhcp pool name

9. network (dhcp) network-number mask

10. default-router address

11. option code

12. interface wlan-controller slot/port

13. ip address ip-address mask

14. interface wlan-controller slot/port

15. encapsulation dot1q

16. ip address ip-address mask

17. interface wlan-controller slot/port

18. encapsulation dot1q

19. ip address ip-address mask

20. ip dhcp pool name

21. network (dhcp) network-number mask

22. default-router address

23. ip dhcp pool name

24. network (dhcp) network-number mask

25. default-router address

26. configure interface create interface_name vlan-id

27. configure interface address ap-manager IP_address netmask gateway

28. configure wlan create wlan_id wlan_name

29. configure wlan interface wlan_id wlan_name

30. configure interface dhcp ap-manager server1 [server2] management server1 [server2]

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

interface type slot/port

Example:

Router(config-if)# interface gigabitethernet 0/0

Configures an interface type and enters interface configuration mode.

Step 2 

description string

Example:

Router(config-if)# description: connected to AP

Specifies a description of the digital signal processor (DSP) interface.

Step 3 

ip address ip-address mask

Example:

Router(config-if)# ip address 100.100.100.1 255.255.255.0

Sets a primary or secondary IP address for an interface.

Step 4 

load-interval seconds

Example:

Router(config-if)# load-interval 30

Specifies the length of time to be used to calculate the average load for an interface.

Step 5 

duplex speed

Example:

Router(config-if)# duplex auto

Detects the transmission type of the device.

Step 6 

speed speed

Example:

Router(config-if)# speed auto

Detects the speed settings of the device.

Step 7 

ip dhcp excluded-address low-address high-address

Example:

Router(config-if)# ip dhcp excluded-address 100.100.100.1 100.100.100.100

Specifies IP addresses that a Dynamic Host Configuration Protocol (DHCP) server should not assign to DHCP clients.

Step 8 

ip dhcp pool name

Example:

Router(config-if)# ip dhcp pool lwapp-ap

Configures a Dynamic Host Configuration Protocol (DHCP) address pool on a DHCP server and enter DHCP pool configuration mode.

Step 9 

network (dhcp) network-number mask

Example:

Router(config-if)# network 100.100.100.0 255.255.255.0

Configures the subnet number and mask for a Dynamic Host Configuration Protocol (DHCP) address pool on a Cisco IOS DHCP server.

Step 10 

default-router address

Example:

Router(config-if)# default-router 100.100.100.1

Specifies the default router list for a Dynamic Host Configuration Protocol (DHCP) client.

Step 11 

option code ascii string hex string ip address

Example:

Router(config-if)# option 43 ascii 192.0.2.24

Configures Dynamic Host Configuration Protocol (DHCP) server options for the WLAN 1000 series AP.

Note To use the option command to configure DHCP server options on the WLAN 1100 series and 1200 series APs, use the option command specifying the hex string. For complete information about configuring DHCP on Cisco WLAN controller products, see the Cisco 440X Series Wireless LAN Controllers Deployment Guide at the following URL: http://www.cisco.com/en/US/products/ps6366/prod_technical_reference09186a00806cfa96.html

Step 12 

interface wlan-controller slot/port

Example:

Router(config-if)# interface wlan-controller 1/0

Enters interface configuration mode, and specifies an interface for configuration.

Step 13 

ip address ip-address mask

Example:

Router(config-if)# ip address 192.0.2.254 255.255.255.0

Sets a primary or secondary IP address for an interface.

Step 14 

interface wlan-controller slot/port

Example:

Router(config-if)# interface wlan-controller 1/0 15

Enters interface configuration mode, and specifies an interface for configuration.

Step 15 

encapsulation dot1q vlan-id

Example:

Router(config-if)# encapsulation dot1q 15

Enables IEEE 802.1q encapsulation of traffic on a specified subinterface in a virtual LAN (VLAN).

Step 16 

ip address ip-address mask

Example:

Router(config-if)# ip address 15.0.0.1 255.255.255.0

Sets a primary or secondary IP address for an interface.

Step 17 

interface wlan-controller slot/port

Example:

Router(config-if)# interface wlan-controller 1/0 16

Enters interface configuration mode, and specifies an interface for configuration.

Step 18 

encapsulation dot1q vlan-id

Example:

Router(config-if)# encapsulation dot1q 16

Enables IEEE 802.1q encapsulation of traffic on a specified subinterface in a virtual LAN (VLAN).

Step 19 

ip address ip-address mask

Example:

Router(config-if)# ip address 16.0.0.1 255.255.255.0

Sets a primary or secondary IP address for an interface.

Step 20 

ip dhcp pool name

Example:

Router(config)# ip dhcp pool client-15

Configures a Dynamic Host Configuration Protocol (DHCP) address pool on a DHCP server and enter DHCP pool configuration mode.

Step 21 

network (dhcp) network-number mask

Example:

Router(config)# network 15.0.0.0 255.255.255.0

Configures the subnet number and mask for a Dynamic Host Configuration Protocol (DHCP) address pool on a Cisco IOS DHCP server.

Step 22 

default-router address

Example:

Router(config)# default-router 15.0.0.1

Specifies the default router list for a Dynamic Host Configuration Protocol (DHCP) client.

Step 23 

ip dhcp pool name

Example:

Router(config)# ip dhcp pool client-16

Configures a Dynamic Host Configuration Protocol (DHCP) address pool on a DHCP server and enter DHCP pool configuration mode.

Step 24 

network (dhcp) network-number mask

Example:

Router(config)# network 16.0.0.0 255.255.255.0

Configures the subnet number and mask for a Dynamic Host Configuration Protocol (DHCP) address pool on a Cisco IOS DHCP server.

Step 25 

default-router address

Example:

Router(config)# default-router 16.0.0.1

Specifies the default router list for a Dynamic Host Configuration Protocol (DHCP) client.

Step 26 

configure interface create interface_name vlan-id

Example:

WLAN Controller> configure interface create Controller15 15

WLAN Controller> configure interface create Controller16 16

Adds a new dynamic interface.

Step 27 

configure interface address ap-manager IP_address netmask gateway

Example:

WLAN Controller> configure interface address Controller15 15.0.0.254 255.255.255.0 15.0.0.1

WLAN Controller> configure interface address Controller16 16.0.0.254 255.255.255.0 16.0.0.1

Configures the address information of an interface.

Step 28 

configure wlan create wlan_id wlan_name

Example:

WLAN Controller> configure wlan create 15 wlan-15

WLAN Controller> configure wlan create 16 wlan-16

Creates a wireless LAN.

Step 29 

configure wlan interface wlan_id wlan_name

Example:

WLAN Controller> configure wlan interface 15 Controller15

WLAN Controller> configure wlan interface 16 Controller16

Associates a wireless LAN with an existing interface.

Step 30 

configure interface dhcp ap-manager server1 [server2] management server1 [server2]

Example:

WLAN Controller> configure interface dhcp Controller15 15.0.0.1

WLAN Controller> configure interface dhcp Controller16 16.0.0.1

Configures DHCP options on an interface.

Example

The Wireless LAN controller module installed in the router can be logically considered equivalent to an external wireless LAN controller connected to the router through an Ethernet interface as shown in Figure 3.

Figure 3 Creating VLANs for the Cisco WLAN Controller Module

The following example assumes the network module is plugged into slot 1 of the router with these considerations:

The WLAN controller is connected to router through interface wlan-controller 1/0.

A Layer 2 switch is connected to router onboard FastEthernet interface f0/0. This switch can be an external stand alone switch or one of the integrated EtherSwitch HWIC/NM/NME switches.

An LWAPP AP is connected to the Layer 2 switch.

Wireless client1 and wireless client2 are associated with the AP: one in Wlan 15 and the other in Wlan 16.

Configure a DHCP server on the router to assign an IP address to the AP. Use the dhcp option 43 command to inform the AP contact information of the controller IP address. After performing the following steps, the AP can learn the IP address, and find the controller register.

Router(config-if)# interface GigabitEthernet0/0								
Description: Connected to AP							
Router(config-if)# ip address 100.100.100.1 255.255.255.0						
load-interval 30									
duplex auto									
speed auto
									
!										
Router(config-if)# ip dhcp excluded-address 100.100.100.1 100.100.100.100
!
Router(config-if)# ip dhcp pool lwapp-ap
Router(config-if)# network 100.100.100.0 255.255.255.0
Router(config-if)# default-router 100.100.100.1 
Router(config-if)# option 43 ascii "192.0.2.24"

This following example shows how two WLANs (wlan15 and wlan16) are created on the controller, mapped to the corresponding wired side vlan 15 and vlan 16, and how routing between vlan 15 and vlan 16 is done by the router through dot1Q sub-interfaces.

On the router, create one sub-interface under wlan-controller interface (in interface configuration mode) for every VLAN, assign it to the corresponding VLAN, and configure an IP address from the respective subnets.

Router(config-if)# interface wlan-controller1/0								
Router(config-if)# ip address 192.0.2.254 255.255.255.0							
!										
Router(config-if)# interface wlan-controller1/0.15								
Router(config-if)# encapsulation Dot1q 15								
Router(config-if)# ip address 15.0.0.1 255.255.255.0							
!										
Router(config-if)# interface wlan-controller 1/0.16							
Router(config-if)# encapsulation Dot1q 16								
Router(config-if)# ip address 16.0.0.1 255.255.255.0

On the router, create two DHCP pools from subnet 15.0.0.0/24 and 16.0.0.0/24 and assign IP address information to the wireless clients in wlan 15 and 16.


Note DHCP services for clients can also run on the controller but Cisco recommends to run DHCP services on the router since the controller is not a full-fledged DHCP server and will not pass on options like TFTP server required for applications like Cisco Call Manager Express.


Router(config)# ip dhcp pool client-15
Router(config)# network 15.0.0.0 255.255.255.0
Router(config)# default-router 15.0.0.1 

Router(config)# ip dhcp pool client-16
Router(config)# network 16.0.0.0 255.255.255.0
Router(config)# default-router 16.0.0.1

For every VLAN on the controller, create one dynamic interface to the corresponding VLAN and assign an IP address, a subnet mask, and default gateways from the above subnets.

Controller> configure interface create controller15 15
Controller> configure interface create controller16 16

Controller> configure interface address Controller15 15.0.0.254 255.255.255.0 
15.0.0.1
Controller> configure interface address Controller16 16.0.0.254 255.255.255.0 16.0.0.1

Create wlan 15 and wlan 16 with SSID wlan-15 and wlan-16.

Controller> configure wlan create 15 wlan-15
Controller> configure wlan create 16 wlan-16

Map these WLANs to corresponding dynamic VLAN interfaces on the controller.

Controller> configure wlan interface 15 Controller15
Controller> configure wlan interface 16 Controller16

Configure DHCP server info on the controller interfaces (for wireless clients) pointing to the respective sub-interface IP addresses on the router.

Controller> configure interface dhcp controller15 15.0.0.1
Controller> configure interface dhcp Controller16 16.0.0.1

The traffic from wlan 15 client destined to the wlan 16 client will be routed between the sub-interfaces w1/0.15 and w1/0.16 on the router.


Note The controller supports a maximum number of 16 VLANs.


Upgrading the Cisco WLAN Controller Module Software

Complete these steps to upgrade the controller software using the CLI.

Restrictions

Make sure you have a TFTP server available for the operating system software download.

You must first download the desired operating system software update file from Cisco.com website to the default directory on your TFTP server.

SUMMARY STEPS

1. ping server-ip-address

2. transfer download start

3. transfer download mode tftp

4. transfer download datatype code

5. transfer download serverip tftp-server-ip-address

6. transfer download filename filename

7. transfer download path absolute-tftp-server-path-to-file

8. transfer download start

9. reset system


Note The argument slot indicates the number of the router chassis slot for the module. The argument port indicates the number of the daughter card on the module. For Cisco WLAN controller module, always use 0. For more information on understanding interfaces, see "Understanding Interfaces on the Cisco WLAN Controller Module" section.

For information about module slot locations and numbering on Cisco routers, see the Cisco Network Modules Hardware Installation Guide at the following URL:

http://www.cisco.com/en/US/products/hw/modules/ps2797/products_module_installation_guide_book09186a00802d2910.html


Once the WLAN controller module software is successfully upgraded, enter reset system to reboot the Cisco WLAN controller network module and run the new code.

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

ping server-ip-address

Example:

WLAN Controller> ping 192.0.2.24

Verifies that the controller can contact the TFTP server.

Step 2 

transfer download start

Example:

WLAN Controller> transfer download start

Begins the file transfer process.

Note Answer n to the prompt to view the current download settings.

Step 3 

transfer download mode tftp

Example:

WLAN Controller> transfer download mode tftp

Sets the mode to TFTP.

Step 4 

transfer download datatype code

Example:

WLAN Controller> transfer download datatype code

Sets the datatype code.

Step 5 

transfer download serverip tftp-server-ip-address

Example:

WLAN Controller> transfer download serverip 192.168.88.5

Sets the IP address of the TFTP server.

Step 6 

transfer download filename filename

Example:

WLAN Controller> transfer download filename anyname

Sets the filename to download.

Step 7 

transfer download path relative-tftp-server-path-to-file

Example:

WLAN Controller> transfer download path C:/

Sets the relative TFTP path.

Note All TFTP servers require the full pathname. For example, in Windows, the path is C:\TFTP-Root. (In UNIX forward slashes (/) are required.)

Step 8 

transfer download start

Example:

WLAN Controller> transfer download start

Allows you to view the updated settings.

Note Answer y to the prompt to confirm the current download settings and start the operating system code download.

Step 9 

reset system

Example:

WLAN Controller> reset system

Saves the code update to non-volatile NVRAM and reboots the Cisco WLAN controller network module.

Example

Sample Output for the reset system Command

This example shows what appears when you enter the reset system command:

WLAN Controller>reset system
The system has unsaved changes. 
Would you like to save them now? (y/n) y

Saving Configurations

Controllers contain two kinds of memory: volatile RAM and nonvolatile RAM (NVRAM). At any time, you can save the configuration changes from active volatile RAM to NVRAM.

SUMMARY STEPS

1. clear configuration

2. reset system

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

clear configuration

Example:

WLAN Controller> clear configuration

Resets the configuration data to factory defaults.

Step 2 

reset system

Example:

WLAN Controller> reset system

Prompts you to confirm that you want to save configuration changes before the controller reboots.

Note Because you are resetting the configuration data to factory defaults, do not save the configuration when prompted.

Erasing and Resetting the WLAN Controller Module Configuration

To reboot the Cisco WLAN controller module and restore it to the factory defaults, perform the following steps.


Note For complete information about resetting the WLAN controller module and crash recovery, see the Cisco Wireless LAN Controller Command Reference at the following URL:

http://www.cisco.com/en/US/products/ps6308/prod_command_reference_list.html


SUMMARY STEPS

1. reset system

2. recover configuration

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

reset system

Example:

WLAN Controller> reset system

Prompts you to confirm that you want to save configuration changes before the controller reboots.

Step 2 

recover configuration

Example:

WLAN Controller> reset system

Prompts you to enter a username. After entering the username, the factory default configuration is restored. The Cisco WLAN controller module reboots and the configuration wizard starts automatically.

Additional References

Related Documents

Related Topic
Document Title

Hardware installation instructions for modules

Cisco Network Modules Hardware Installation Guide

General information about voice configuration and command reference

Cisco IOS Voice Command Reference

Software configuration information for the Cisco WLAN controller module

Cisco Wireless LAN Solution Product Guide

CLI command information for the Cisco WLAN controller module

Cisco Wireless LAN Controller Command Reference


Technical Assistance

Description
Link

Technical Assistance Center (TAC) home page, containing 30,000 pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/public/support/tac/home.shtml


service-module wlan-controller

To configure the Cisco WLAN controller network module from the router, use the service-module wlan-controller command in global configuration mode.

service-module wlan-controller slot/port {reload | reset | session [clear] | shutdown | status}

Syntax Description

slot/port

Specifies the router slot and port numbers for the WLAN controller network module.

reload

Reload the WLAN controller network module.

reset

Reset the WLAN controller network module.

session

Open a session to the WLAN controller network module.

clear

Clear the existing session to the WLAN controller network module.

shutdown

Shut down the WLAN controller network module.

status

Display information on the WLAN controller network module.


Defaults

No default behavior or values.

Command Modes

Global configuration mode.

Command History

Release
Modification

12.4(2)XA1

This command was introduced on the router software.


Usage Guidelines

If the Cisco WLAN controller module is free of any prior configuration, the configuration wizard is automatically invoked. You cannot bypass the configuration wizard. Through the CLI, you must provide the information at the prompts provided.

Examples

The following example shows how to clear the existing session with the WLAN controller network module:

Router# service-module wlan-controller 1/0 session clear [confirm]  [OK] boxer-bombor# 
Router#
Router#service-module wlan-controller 1/0 session      
Trying 192.0.2.254, 2066 ... Open

User:

Open Source License Acknowledgements

The following notices pertain to this software license.

OpenSSL/Open SSL Project

This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/).

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com).

This product includes software written by Tim Hudson (tjh@cryptsoft.com).

License Issues

The OpenSSL toolkit stays under a dual license, i.e. both the conditions of the OpenSSL License and the original SSLeay license apply to the toolkit. See below for the actual license texts. Actually both licenses are BSD-style Open Source licenses. In case of any license issues related to OpenSSL please contact openssl-core@openssl.org.

OpenSSL License:

Copyright © 1998-2007 The OpenSSL Project. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions, and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the following acknowledgment: "This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/)".

4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact openssl-core@openssl.org.

5. Products derived from this software may not be called "OpenSSL" nor may "OpenSSL" appear in their names without prior written permission of the OpenSSL Project.

6. Redistributions of any form whatsoever must retain the following acknowledgment:

"This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/)".

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT "AS IS"' AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com). This product includes software written by Tim Hudson (tjh@cryptsoft.com).

Original SSLeay License:

Copyright © 1995-1998 Eric Young (eay@cryptsoft.com). All rights reserved.

This package is an SSL implementation written by Eric Young (eay@cryptsoft.com).

The implementation was written so as to conform with Netscapes SSL.

This library is free for commercial and non-commercial use as long as the following conditions are adhered to. The following conditions apply to all code found in this distribution, be it the RC4, RSA, lhash, DES, etc., code; not just the SSL code. The SSL documentation included with this distribution is covered by the same copyright terms except that the holder is Tim Hudson (tjh@cryptsoft.com).

Copyright remains Eric Young's, and as such any Copyright notices in the code are not to be removed. If this package is used in a product, Eric Young should be given attribution as the author of the parts of the library used. This can be in the form of a textual message at program startup or in documentation (online or textual) provided with the package.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the following acknowledgement:

"This product includes cryptographic software written by Eric Young (eay@cryptsoft.com)".

The word `cryptographic' can be left out if the routines from the library being used are not cryptography-related.

4. If you include any Windows specific code (or a derivative thereof) from the apps directory (application code) you must include an acknowledgement: "This product includes software written by Tim Hudson (tjh@cryptsoft.com)".

THIS SOFTWARE IS PROVIDED BY ERIC YOUNG "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The license and distribution terms for any publicly available version or derivative of this code cannot be changed. i.e. this code cannot simply be copied and put under another distribution license [including the GNU Public License].