Wide-Area Networking Configuration Guide: Frame Relay, Cisco IOS Release 15M&T
PPP over Frame Relay
Downloads: This chapterpdf (PDF - 172.0KB) The complete bookPDF (PDF - 1.96MB) | Feedback

PPP over Frame Relay

PPP over Frame Relay

Last Updated: December 2, 2012

The PPP over Frame Relay feature allows a router to establish end-to-end Point-to-Point Protocol (PPP) sessions over Frame Relay.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Prerequisites for PPP over Frame Relay

Before you can configure PPP over Frame Relay, Frame Relay must be enabled on the router using the encapsulation frame-relay command.

Restrictions for PPP over Frame Relay

  • Only Frame Relay permanent virtual circuits (PVCs) are supported.
  • Only the Internet Protocol (IP) is supported.

Information About PPP over Frame Relay

Overview of PPP over Frame Relay

The PPP over Frame Relay feature allows a router to establish end-to-end Point-to-Point Protocol (PPP) sessions over Frame Relay. IP datagrams are transported over the PPP link using RFC 1973 compliant Frame Relay framing. This feature is useful for remote users running PPP to access their Frame Relay corporate networks as shown in the figure below.

Figure 1 PPP over Frame Relay Scenario


The figure below shows a connectivity scenario using the Cisco 90i D4 channel card, which is capable of supporting Integrated Services Digital Network (ISDN) Digital Service Loop (DSL), PPP, or Frame Relay, which connects to an Internet Service Provider (ISP) or corporate network.

Figure 2 PPP over Frame Relay Frame Format


PPP over Frame Relay is compliant with the functionality and encapsulation specifications as outlined in RFC 1973. The frame format is shown in the figure below.

Figure 3 PPP over Frame Relay Frame Format


A PPP connection is established over the Frame Relay PVC. The PPP session does not occur unless the associated Frame Relay PVC is in an "active" state. The Frame Relay VC can coexist with other circuits using different Frame Relay encapsulation methods, such as RFC 1490 and Cisco proprietary, over the same Frame Relay link. There can be multiple PPP-in-Frame-Relay circuits existing on one Frame Relay link.

One PPP connection resides on one virtual access interface, which is internally created from a virtual template interface. A virtual access interface is cloned from a virtual template interface. The virtual access interfaces is coexistent with the creation of the Frame Relay circuit when the corresponding DLCI is configured. One virtual template interface, containing all the necessary PPP and network protocol information, is shared by multiple virtual access interfaces. Hardware compression and fancy queuing algorithms, such as weighted fair queuing, custom queuing, and priority queuing, are not applied to virtual access interfaces. Once a Frame Relay circuit is established using PPP over Frame Relay, all incoming and outgoing packets on this circuit are under RFC 1973 PPP-in-Frame-Relay encapsulation compliance until this DLCI is removed from the configuration.

The breakdown of the Frame Relay frame format components is listed in the table below.

Table 1 PPP Frame Relay Format Descriptions

Field

Description

Flag

A single byte that indicates the beginning or end of a frame.

Address

A two-byte field that indicates the logical connection that maps to the physical channel; the DLCI.

Control

A single byte that calls for transmission of user data. PPP over Frame Relay uses a value of 0X03, which indicates that the frame is an unnumbered information (UI) frame.

NLPID

Network layer protocol ID, which is a single byte that uniquely identifies a PPP packet to Frame Relay.

PPP protocol

Identifies the PPP packet type.

Benefits

  • Allows end-to-end PPP sessions over Frame Relay.
  • Supports the 90i IDSL Channel Unit that supports both Frame Relay and PPP on an ISDN DSL.

How to Configure PPP over Frame Relay

Enabling PPP over Frame Relay

Perform the following task to configure the physical interface that carries the PPP session and links to the appropriate virtual template interface.

Before You Begin

After you configure the Cisco router or access server for Frame Relay encapsulation, you must configure the physical interface with the PVC and apply a virtual template with PPP encapsulation to the DLCI that it applies to.


SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number . subinterface-number {multipoint | point-to-point}

4.    frame-relay interface-dlci dlci [ppp virtual-template-name-string]

5.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number . subinterface-number {multipoint | point-to-point}


Example:

Router(config)# interface serial 2.1 point-to-point

 

Specifies the interface and enters interface configuration mode.

 
Step 4
frame-relay interface-dlci dlci [ppp virtual-template-name-string]


Example:

Router(config-if)# frame-relay interface-dlci

 

Defines the PVC and maps it to the virtual template.

 
Step 5
end


Example:

Router(config-if)# exit

 

Exits the current configuration mode and returns to privileged EXEC mode.

 

Configuration Examples for PPP over Frame Relay

Example PPP over Frame Relay DTE

The following example configures a router as a data terminating equipment (DTE) device for PPP over Frame Relay. Subinterface 2.1 contains the necessary DLCI and virtual template information. The virtual template interface (interface virtual-template 1) contains the PPP information that is applied to the PPP session associated with DLCI 32 on serial subinterface 2.1.

interface serial 2
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface serial 2.1 point-to-point
 frame-relay interface-dlci 32 ppp virtual-template1
!
interface Virtual-Template1
 ip unnumbered ethernet 0
 ppp authentication chap pap

Note


By default, the encapsulation type for a virtual template interface is PPP encapsulation; therefore, the encapsulation ppp command will not show up when viewing the running configuration on the router.

Example PPP over Frame Relay DCE

The following example configures a router to act as a data communications equipment (DCE) device. Typically, a router is configured as a DCE if connecting directly to another router or if connected to a 90i D4 channel unit, which is connected to a telco channel bank. The three commands required for this type of configuration are frame-relay switching, frame-relay intf-type dce, and frame-relay route commands.

frame-relay switching
!
interface Serial2/0:0
 no ip address
 encapsulation frame-relay IETF
 frame-relay lmi-type ansi
 frame-relay intf-type dce
 frame-relay route 31 interface Serial1/2 100
 frame-relay interface-dlci 32 ppp Virtual-Template1
!
interface Serial2/0:0.2 point-to-point
 no ip address
 frame-relay interface-dlci 40 ppp Virtual-Template2
!
interface Virtual-Template1
 ip unnumbered Ethernet0/0
 peer default ip address pool default
 ppp authentication chap pap
 !
interface Virtual-Template2
 ip address 209.165.200.225 255.255.255.224
 ppp authentication chap pap

Note


By default, the encapsulation type for a virtual template interface is PPP encapsulation; therefore, the encapsulation ppp command will not show up when viewing the running configuration on the router.

Additional References

Related Documents

Related Topic

Document Title

Cisco IOS commands

Cisco IOS Master Commands List, All Releases

WAN commands

Cisco IOS Wide-Area Networking Command Reference

Configuring Frame Relay

Configuring Frame Relay

Standards

Standard

Title

None

--

MIBs

MIB

MIBs Link

None

To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs

RFCs

RFC

Title

RFC 1973

PPP in Frame Relay

Technical Assistance

Description

Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html

Feature Information for PPP over Frame Relay

The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Table 2 Feature Information for PPP over Frame Relay

Feature Name

Releases

Feature Information

PPP over Frame Relay

11.3(4)T 15.0(1)S

The PPP over Frame Relay feature allows a router to establish end-to-end PPP sessions over Frame Relay.

The following commands were introduced or modified: debug frame-relay ppp, frame-relay interface-dlci, show frame-relay pvc.

Glossary

data-link connection identifier (DLCI) --A value that specifies a PVC or SVC in a Frame Relay network. In the basic Frame Relay specification, DLCIs are locally significant (connected devices might use different values to specify the same connection). In the LMI extended specification, DLCIs are globally significant (DLCIs specify individual end devices).

Integrated Services Digital Network (ISDN) --Communication protocols offered by telephone companies that permit telephone networks to carry data, voice, and other source traffic.

Link Control Protocol (LCP) --A protocol that establishes, configures, and tests data link connections used by PPP.

permanent virtual circuit (PVC) --Virtual circuit that is permanently established. PVCs save bandwidth associated with circuit establishment and teardown in situations where certain virtual circuits must exist all the time.

Point-to-Point Protocol (PPP) --A protocol that encapsulates network layer protocol information over point-to-point links. The RFC for PPP is RFC 1661.

virtual circuit (VC) -- A logical circuit created to ensure reliable communication between two network devices. A virtual circuit can be either permanent (a PVC) or switched (an SVC). Virtual circuits are used in Frame Relay and X.25.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

© 2012 Cisco Systems, Inc. All rights reserved.