IP Routing: OSPF Configuration Guide, Cisco IOS XE Release 3S
OSPFv2-OSPF Live-Live
Downloads: This chapterpdf (PDF - 1.26MB) The complete bookPDF (PDF - 5.95MB) | The complete bookePub (ePub - 1.28MB) | Feedback

OSPFv2-OSPF Live-Live

OSPFv2-OSPF Live-Live

The OSPFv2-OSPF Live-Live feature delivers multicast streams over non overlapping paths to various applications. The multicast traffic is split into multiple streams at the beginning of a protected network. All streams flow over non overlapping paths so that when a link failure occurs on one path, multicast traffic is still delivered through other paths. All streams are merged back at the end of the protected network. This module describes how to configure the OSPFv2-OSPF Live-Live feature.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Information About OSPFv2-OSPF Live-Live

Overview of OSPFv2-OSPF Live-Live

Many new applications driving the growth of networking market are multicast based. Applications such as Internet Protocol television (IPTV) are typically associated with simultaneously delivering massive amount of sensitive data streams to large audiences. Packet drop is a critical issue in multimedia traffic. There is a demand to reduce multicast traffic loss to the range of milliseconds or to zero packet loss. The zero packet loss solution for multicast in case of single link failure is also known as live-live.

In a live-live network, multicast streams (typically two flows) form their own reverse path forwarding (RPF)/shortest path trees (SPT) over diversified physical links, so that failure on one link does not affect multicast traffic on other link. The existing multi topology technology in Cisco IOS software supports the multiple multicast topologies.

The OSPFv2-OSPF Live-Live feature enables the protocol independent multicast (PIM) to handle multiple multicast topologies. When a multicast topology is created and enabled on OSPF, IP prefixes on each topology are injected into topology-based Routing Information Base (RIB). PIM then decides which RIB to use for RPF lookup.

PIM RPF topology is a collection of routes used by PIM to perform the RPF operation when building shared or source trees. In a multi topology environment, multiple RPF topologies can be created in the same network. A particular source may be reachable in only one of the topologies or in several of them through different paths.

To select the RPF topology for a particular multicast distribution tree, consider the following:
  1. Configure a policy that maps a group range to a topology. When RPF information needs to be resolved for the RP or the sources for a group within the range, the RPF lookup takes place in the specified topology. This can be used for PIM Sparse Mode (PIM-SM)/source-specific multicast (SSM)/Bidirectional(Bidir) PIM.
  2. Configure a policy that maps a source prefix range to a topology. This can be used for PIM-SM and PIM-SSM.
  3. Use the topology identified by the Join Attribute encoding in the received PIM packets.

The PIM Join Attribute extends PIM signaling to identify a topology that should be used when constructing a particular multicast distribution tree. For more details on the PIM Join Attribute, see PIM Multi-Topology ID (MT-ID) Join-Attribute IEEE draft.

How to Configure OSPFv2-OSPF Live-Live

Configuring OSPFv2-OSPF Live-Live

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    ip multicast-routing

    4.    ip multicast rpf multitopology

    5.    global-address-family ipv4 multicast

    6.    topology {topology-A | topology-B}

    7.    exit

    8.    interface type number

    9.    ip address address mask

    10.    ip pim sparse-dense-mode

    11.    ip ospf process-id area area-id

    12.    topology ipv4 multicast topology-name

    13.    exit

    14.    router ospf process-id

    15.    network ip-adddress mask area area-id

    16.    address-family ipv4 multicast

    17.    topology topology-name tid topology-id

    18.    end

    19.    configure terminal

    20.    ip multicast topology multicast topology-name tid topology-id

    21.    ip multicast rpf select topology multicast topology-name access-list number

    22.    ip access-list extended access-list-number

    23.    permit ip any ip-adddress

    24.    end

    25.    show ip multicast topology multicast topology-name

    26.    debug ip multicast topology


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Device> enable
     
    Enables privileged EXEC mode.
    • Enter your password if prompted.
     
    Step 2configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3ip multicast-routing


    Example:
    Device(config)# ip multicast-routing
     

    Enables IP multicast routing.

     
    Step 4ip multicast rpf multitopology


    Example:
    Device(config)# ip multicast rpf multitopology 
     

    Enables Multi Topology Routing (MTR) support for IP multicast routing.

     
    Step 5 global-address-family ipv4 multicast


    Example:
    Device(config)# global-address-family ipv4 multicast
     

    Enters global address family configuration mode and configures multi topology routing.

     
    Step 6topology {topology-A | topology-B}


    Example:
    Device(config-af)# topology live-A
     

    Configures an OSPF process to route IP traffic under the specified topology instance.

     
    Step 7exit


    Example:
    Device(config-af)# exit
     

    Exits address family configuration mode and returns to global configuration mode.

     
    Step 8interface type number


    Example:
    Device(config)# interface Gigabitethernet 1/0
     

    Configures an interface type and enters interface configuration mode.

     
    Step 9ip address address mask


    Example:
    Device(config-if)# ip address 192.108.1.27 255.255.255.0
     

    Sets a primary or secondary IP address for an interface.

     
    Step 10 ip pim sparse-dense-mode


    Example:
    Device(config-if)# ip pim sparse-dense-mode
     

    Enables PIM on an interface and treats the interface in either sparse mode or dense mode of operation, depending on which mode the multicast group operates in.

     
    Step 11 ip ospf process-id area area-id


    Example:
    Device(config-if)# ip ospf 10 area 0
     

    Enables OSPFv2 on an interface.

     
    Step 12topology ipv4 multicast topology-name


    Example:
    Device(config-if)# topology ipv4 multicast live-A
     

    Configures a multi topology instance on an interface.

     
    Step 13exit


    Example:
    Device(config-if)# exit
     

    Exits interface configuration mode and enters global configuration mode.

    • Repeat Steps 9 to 12 to configure the next topology (topology ipv4 multicast live-B).
     
    Step 14 router ospf process-id


    Example:
    Device(config)# router ospf 102
     

    Enables OSPF routing and enters router configuration mode.

     
    Step 15 network ip-adddress mask area area-id


    Example:
    Device(config-router)# network 192.168.129.16 0.0.0.3 area 20
     

    Defines an interface on which OSPF runs and defines the area ID for that interface.

     
    Step 16address-family ipv4 multicast


    Example:
    Device(config-router)# address-family ipv4 multicast
     

    Enters router address family configuration mode and configures OSPF to exchange IPv4 multicast prefixes.

     
    Step 17 topology topology-name tid topology-id


    Example:
    Device(config-router-af)# topology live-A tid 100
     

    Configures an OSPF process to route IP traffic under the specified topology instance.

    • Repeat this step to configure the OSPF process to route IP traffic under another topology instance (topology live-B tid 200).
     
    Step 18end


    Example:
    Device(config-router-af)# end
     

    Exits router address family configuration mode and returns to privileged EXEC mode.

     
    Step 19configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 20ip multicast topology multicast topology-name tid topology-id


    Example:
    Device(config)# ip multicast topology multicast live-A tid 100
     

    Configures topology selection for the multicast streams.

    • Repeat this step to configure another topology (ip multicast topology multicast live-B tid 200).
     
    Step 21ip multicast rpf select topology multicast topology-name access-list number


    Example:
    Device(config)# ip multicast rpf select topology multicast topology live-A 111
     

    Associates a multicast topology with a multicast group with a specific route entry.

    • Repeat this step to associate the topology with another multicast group (ip multicast rpf select topology multicast live-B 122).
     
    Step 22 ip access-list extended access-list-number


    Example:
    Device(config)# ip access-list extended 111
     

    Defines an IP access list to enable filtering for packets with IP helper-address destinations and enters extended named access list configuration mode.

     
    Step 23permit ip any ip-adddress


    Example:
    Device(config-ext-nacl)# permit ip any 203.0.113.1 
     

    Sets condition to allow a packet to pass a named IP access list.

    • Repeat Steps 22 and 23 to define another IP access list and to set conditions to allow a packet to pass another named IP access list.
     
    Step 24end


    Example:
    Device(config-ext-nacl)# end
     

    Exits extended named access list configuration mode and enters privileged EXEC mode.

     
    Step 25show ip multicast topology multicast topology-name


    Example:
    Device# show ip multicast topology multicast live-A
     

    Displays topology information for multicast streams.

     
    Step 26debug ip multicast topology


    Example:
    Device# debug ip multicast topology
     

    Enables debugging output for multicast stream topology.

     

    Configuration Examples for OSPFv2-OSPF Live-Live

    Example: Configuring OSPFv2-OSPF Live-Live

    ip multicast-routing
    ! 
    ip multicast rpf multitopology
    
    ! 
    global-address-family ipv4 multicast 
      topology live-A
      topology live-B
    
    int gigabitethernet 1/0
     ip address 192.0.2.1 255.255.255.0
     ip pim sparse-dense-mode
     ip ospf 10 area 20
     topology ipv4 multicast live-A
    !
    int gigabitethernet 2/0
     ip address 192.0.2.2 255.255.255.0
     ip pim sparse-dense-mode
     ip ospf 11 area 21   
     topology ipv4 multicast live-B
    !
    router ospf 1           
     network 192.168.129.16 0.0.0.3 area 20
      address-family ipv4 multicast 
      !! 
       topology live-A tid 10
       topology live-B tid 20
    !
    !! 
    ip multicast topology multicast live-A tid 100
    ip multicast topology multicast live-B tid 200
    !
    !! 
    ip multicast rpf select topology multicast live-A 111 
    ip multicast rpf select topology multicast live-B 122 
    
    ! 
     ip access-list extended 111 
     permit ip any 203.0.113.254 
    
    ip access-list extended 122 
     permit ip any 203.0.113.251
    
        
    
    

    Additional References for OSPFv2-OSPF Live-Live

    Related Documents

    Related Topic

    Document Title

    Cisco IOS commands

    Cisco IOS Master Command List, All Releases

    Configuring OSPF features

    IP Routing: OSPF Configuration Guide

    Technical Assistance

    Description

    Link

    The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

    To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

    Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

    http:/​/​www.cisco.com/​support

    Feature Information for OSPFv2-OSPF Live-Live

    The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

    Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

    Table 1 Feature Information for OSPFv2-OSPF Live-Live

    Feature Name

    Releases

    Feature Information

    OSPFv2-OSPF Live-Live

    Cisco IOS XE Release 3.11S

    The OSPFv2-OSPF Live-Live feature delivers multicast streams over non overlapping paths to various applications. The multicast traffic is split into multiple streams at the beginning of a protected network. All streams flow over non overlapping paths so that when a link failure occurs on one path, multicast traffic is still delivered through other paths. All streams are merged back at the end of the protected network.

    No commands were introduced or modified.