IP Routing: OSPF Configuration Guide, Cisco IOS XE Release 3S
Autoroute Announce and Forwarding Adjacencies For OSPFv3
Downloads: This chapterpdf (PDF - 1.26MB) The complete bookPDF (PDF - 5.86MB) | The complete bookePub (ePub - 1.23MB) | Feedback

Autoroute Announce and Forwarding Adjacencies For OSPFv3

Contents

Autoroute Announce and Forwarding Adjacencies For OSPFv3

The Autoroute Announce and Forwarding Adjacencies for OSPFv3 feature advertises IPv6 routes over MPLS/TE IPv4 tunnels. This module describes how to configure the Autoroute Announce and Forwarding Adjacencies for OSPFv3 feature.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for Autoroute Announce and Forwarding Adjacencies For OSPFv3

  • OSPFv3 must be configured in your network.
  • Cisco Express Forwarding (CEF) must be enabled.
  • MPLS/TE tunnels must be configured.

Restrictions for Autoroute Announce and Forwarding Adjacencies For OSPFv3

  • Autoroute announce and forwarding adjacency cannot be configured together in a same interface.
  • When an autoroute announce is used, OSPFv3 does not advertise the tunnel.
  • When forwarding adjacencies are used, OSPFv3 advertises the tunnel link in an LSA.

Information About Autoroute Announce and Forwarding Adjacencies For OSPFv3

Overview of Autoroute Announce and Forwarding Adjacencies For OSPFv3

The OSPFv3 support for Forwarding Adjacencies over MPLS Traffic Engineered Tunnels feature adds OSPFv3 support to the Multiprotocol Label Switching (MPLS) Traffic Engineering (TE) tunnels feature, which allows a network administrator to handle a traffic engineering, MPLS tunnel as a link in an Interior Gateway Protocol (IGP) network based on the shortest path first (SPF) algorithm. An OSPFv3 forwarding adjacency can be created between routers in the same area.

OSPFv3 includes MPLS TE tunnels in the OSPFv3 router link-state advertisement (LSA) in the same way that other links appear for purposes of routing and forwarding traffic. The user can assign an OSPFv3 cost to the tunnel to give it precedence over other links. Other networking devices will see the tunnel as a link in addition to the physical link.

OSPFv3 uses Autoroute Announce (AA) or Forwarding Adjacencies (FA) feature to install IPv6 routes over MPLS/TE IPv4 tunnels into the IPv6 routing table . The TE tunnels are created using IPv4, and requires the use of a routing protocol other than OSPFv3. OSPFv2 is used as the IPv4 IGP and provides data which TE uses to create the tunnels.

OSPFv3 is configured on the TE tunnel interfaces for either autoroute-annouce or forwarding-adjacency. It is also must be configured in router mode to advertise the address of the loopback interface which TE is using for the tunnels that terminate on the router. That address is advertised in the TE LSA .

How to Configure Autoroute Announce and Forwarding Adjacencies For OSPFv3

Configuring Autoroute Announce and Forwarding Adjacencies For OSPFv3

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    ip cef distributed

    4.    interface type number

    5.    ip address ip-address-mask

    6.    no shutdown

    7.    exit

    8.    interface type number

    9.    ospfv3 pid af mpls traffic-eng autoroute announce area aid

    10.    ospfv3 pid af mpls traffic-eng autoroute metric {metric | absolute metric | relative delta}

    11.    ip ospf cost cost

    12.    exit

    13.    interface type number

    14.    ospfv3 pid af mpls traffic-eng forwarding-adj areaaid

    15.    ospfv3[ pid [af ]] mpls traffic-eng forwarding-adj interface ID [ local ID ] [nbr ID]

    16.    ip ospf cost cost

    17.    exit

    18.    router ospfv3 router-ID

    19.    address-family ipv4 unicast [vrf vrf-name ]

    20.    area aid mpls traffic-engineering tunnel-tail af interface type

    21.    exit

    22.    show ospfv3 database

    23.    show ospfv3 mpls traffic-eng


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 ip cef distributed


    Example:
    Device(config)# ip cef distributed 
     

    Enables distributed Cisco Express Forwarding operation.

     
    Step 4interface type number


    Example:
    Device(config)# interface tunnel 0
     

    Configures an interface type and enters interface configuration mode.

     
    Step 5ip address ip-address-mask


    Example:
    Device (config-if)# ip address 192.108.1.27 255.255.255.0
    
     

    Sets a primary or secondary IP address for the specified interface.

     
    Step 6no shutdown


    Example:
    Device (config-if)# no shutdown
     

    Disables all functions on the specified interface.

     
    Step 7exit


    Example:
    Device (config-if)# exit
     

    Exits interface configuration mode and returns to privileged EXEC mode.

     
    Step 8interface type number


    Example:
    Device (config)# interface loopback 0
     

    Enables loopback interface and enters interface configuration mode.

     
    Step 9 ospfv3 pid af mpls traffic-eng autoroute announce area aid


    Example:
    Device(config-if)# ospfv3 1 af mpls traffic-eng autoroute announce 
    area 1 
     

    Enable Open Shortest Path First version 3 (OSPFv3) on an interface with the IP address family (AF).

     
    Step 10 ospfv3 pid af mpls traffic-eng autoroute metric {metric | absolute metric | relative delta}


    Example:
    Device(config-if)# ospfv3 1 af mpls traffic-eng autoroute metric
    1
     

    Specifies the MPLS traffic engineering auto route metric value for the SPF calculation.

     
    Step 11 ip ospf cost cost


    Example:
    Device(config-if)# ip ospf cost 60
     

    Explicitly specifies the cost of sending a packet on an OSPF interface.

     
    Step 12 exit


    Example:
    Device(config-if)# exit
     

    Exits interface configuration mode and returns to privileged EXEC mode.

     
    Step 13interface type number


    Example:
    Device (config)# interface tunnel 1
     

    Enables tunnel interface and enters interface configuration mode.

     
    Step 14 ospfv3 pid af mpls traffic-eng forwarding-adj areaaid


    Example:
    Device(config-if)# ospfv3 1 af mpls traffic-eng forwarding-adj area 
     1 
     

    Configure an MPLS traffic engineering forwarding adjacency.

     
    Step 15 ospfv3[ pid [af ]] mpls traffic-eng forwarding-adj interface ID [ local ID ] [nbr ID]


    Example:
    Device(config-if)# ospfv3 1 af mpls traffic-eng forwarding-adj 
    1
     

    Specifies the MPLS traffic engineering forwarding adjacency for the SPF calculation.

     
    Step 16 ip ospf cost cost


    Example:
    Device(config-if)# ip ospf cost 55
     

    Explicitly specifies the cost of sending a packet on an OSPF interface.

     
    Step 17 exit


    Example:
    Device(config-if)# exit
     

    Exits interface configuration mode and returns to privileged EXEC mode.

     
    Step 18 router ospfv3 router-ID


    Example:
    Device(config)# router ospfv3 18
     

    Enters OSPFv3 router configuration mode.

     
    Step 19 address-family ipv4 unicast [vrf vrf-name ]


    Example:
    Device(config-router)# address-family ipv4 unicast 
     

    Configures the IPv4 address family in the OSPFv3 process and enters IPv4 address family configuration mode.

     
    Step 20 area aid mpls traffic-engineering tunnel-tail af interface type


    Example:
    Device(config-router-af)# area 1 mpls traffic-engineering tunnel-tail
    af loopback
     

    Configures OSPFv3 on the tail end of the traffic engineering tunnels.

     
    Step 21 exit


    Example:
    Device(config-router-af)# exit
     

    Exits address family configuration mode and returns to global configuration mode.

     
    Step 22 show ospfv3 database


    Example:
    Device(config)# show ospfv3 database 
     

    (Optional) Displays list of information related to the OSPFv3 database for a specific router.

     
    Step 23 show ospfv3 mpls traffic-eng


    Example:
    Device(config)# show ospfv3 mpls traffic-eng
     

    (Optional) Displays autoroute announce, forwarding adjacency, and tunnel-tail information related to OSPFv3.

     

    Configuration Examples for Autoroute Announce and Forwarding Adjacencies For OSPFv3

    Example: Configuring Autoroute Announce and Forwarding Adjacencies For OSPFv3

    !
    ip cef distributed 
    interface tunnel 0
     ip address 192.108.1.27 255.255.255.0
     no shutdown
    
    interface loopback 0
     ospfv3 1 af mpls traffic-eng autoroute announce area 1
     ospfv3 1 af mpls traffic-eng autoroute metric 1
     ip ospf cost 60
    
    interface tunnel 1
     ospfv3 1 af mpls traffic-eng forwarding-adj area 1
     ospfv3 1 af mpls traffic-eng forwarding-adj nbr 1
     ip ospf cost 55
    
    router ospfv3 18
     address-family ipv4 unicast 
       area 1 mpls traffic-engineering tunnel-tail af loopback 
      
       !
      !
    !  
    
    
    

    Additional References for Autoroute Announce and Forwarding Adjacencies For OSPFv3

    Related Documents

    Related Topic

    Document Title

    Cisco IOS commands

    Cisco IOS Master Command List, All Releases

    Configuring OSPF features

    IP Routing: OSPF Configuration Guide

    Standards and RFCs

    Related Topic

    Document Title

    Advertising a Router's Local Addresses in OSPF Traffic Engineering (TE) Extensions

    RFC5786

    Traffic Engineering Extensions to OSPF Version 3

    RFC5329

    Traffic Engineering (TE) Extensions to OSPF Version 2

    RFC3630

    Technical Assistance

    Description

    Link

    The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

    To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

    Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

    http:/​/​www.cisco.com/​support

    Feature Information for Autoroute Announce and Forwarding Adjacencies For OSPFv3

    The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

    Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

    Table 1 Feature Information for Autoroute Announce and Forwarding Adjacencies For OSPFv3

    Feature Name

    Releases

    Feature Information

    Autoroute Announce and Forwarding Adjacencies For OSPFv3

    15.4(2)S

    Cisco IOS XE Release 3.12S

    The Autoroute Announce and Forwarding Adjacencies For OSPFv3 feature advertises IPv6 routes over MPLS/TE IPv4 tunnels.

    The following commands were introduced or modified: ospfv3 af mpls traffic-eng autoroute announce area , ospfv3 mpls traffic-eng autoroute metric, ospfv3 mpls traffic-eng forwarding-adj area .