IP Routing: OSPF Configuration Guide, Cisco IOS Release 15M&T
OSPF Support for Multi-VRF on CE Routers
Downloads: This chapterpdf (PDF - 1.3MB) The complete bookPDF (PDF - 5.36MB) | The complete bookePub (ePub - 1.13MB) | The complete bookePub (ePub - 1.08MB) | Feedback

OSPF Support for Multi-VRF on CE Routers

OSPF Support for Multi-VRF on CE Routers

The OSPF Support for Multi-VRF on CE Routers feature provides the capability of suppressing provider edge (PE) checks that are needed to prevent loops when the PE is performing a mutual redistribution of packets between the OSPF and BGP protocols. When VPN routing and forward (VRF) is used on a router that is not a PE (that is, one that is not running BGP), the checks can be turned off to allow for correct population of the VRF routing table with routes to IP prefixes.

OSPF multi-VRF allows you to split the router into multiple virtual routers, where each router contains its own set of interfaces, routing table, and forwarding table.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Information About OSPF Support for Multi-VRF on CE Routers

The OSPF Support for Multi-VRF on CE Routers feature provides the capability of suppressing provider edge (PE) checks that are needed to prevent loops when the PE is performing a mutual redistribution of packets between the OSPF and BGP protocols. When VPN routing and forward (VRF) is used on a router that is not a PE (that is, one that is not running BGP), the checks can be turned off to allow for correct population of the VRF routing table with routes to IP prefixes.

OSPF multi-VRF allows you to split the router into multiple virtual routers, where each router contains its own set of interfaces, routing table, and forwarding table. OSPF multi-VRF gives you the ability to segment parts of your network and configure those segments to perform specific functions, yet still maintain correct routing information.

How to Configure OSPF Support for Multi-VRF on CE Routers

Configuring the Multi-VRF Capability for OSPF Routing

Before You Begin

CEF must be running on the network.

SUMMARY STEPS

    1.    enable

    2.    show ip ospf [process-id]

    3.    configure terminal

    4.    router ospf process-id [vrf vpn-name]

    5.    capability vrf-lite


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Router> enable
     

    Enables higher privilege levels, such as privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 show ip ospf [process-id]


    Example:
    Router> show ip ospf 1
     

    Displays the status of the router. If the display indicates that the router is connected to the VPN backbone, you can use the capability vrf-lite command to decouple the PE router from the VPN backbone.

     
    Step 3 configure terminal


    Example:
    Router# configure terminal
     

    Enters global configuration mode.

     
    Step 4 router ospf process-id [vrf vpn-name]


    Example:
    Router(config)# router ospf 1 vrf grc
     

    Enables OSPF routing and enters router configuration mode.

    • The process-id argument identifies the OSPF process.
    • Use the vrf keyword and vpn-name argument to identify a VPN.
     
    Step 5 capability vrf-lite


    Example:
    Router(config)# capability vrf-lite
     

    Applies the multi-VRF capability to the OSPF process.

     

    Verifying the OSPF Multi-VRF Configuration

    No specific debug or show commands are associated with this feature. You can verify the success of the OSPF multi-VRF configuration by using the show ip ospf[process-id] command to verify that the router is not connected to the VPN backbone.

    This output from the show ip ospf processcommand indicates that the PE router is currently connected to the backbone.

    Router# show ip ospf 12
     Routing Process "ospf 12" with ID 151.1.1.1 and Domain ID 0.0.0.12
     Supports only single TOS(TOS0) routes
     Supports opaque LSA
     Connected to MPLS VPN Superbackbone
     SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
     Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
     Number of external LSA 0. Checksum Sum 0x0     
     Number of opaque AS LSA 0. Checksum Sum 0x0     
     Number of DCbitless external and opaque AS LSA 0
     Number of DoNotAge external and opaque AS LSA 0
     Number of areas in this router is 0. 0 normal 0 stub 0 nssa
     External flood list length 0
    

    When the OSPF VRF process is configured with the capability vrf-lite command under the router ospf command, the "Connected to MPLS VPN Superbackbone" line will not be present in the display.

    Configuration Examples for OSPF Support for Multi-VRF on CE Routers

    Example Configuring the Multi-VRF Capability

    This example shows a basic OSPF network with a VRF named grc configured. The capability vrf-lite command is entered to suppress the PE checks.

    !
    ip cef
    ip vrf grc
       rd 1:1
    interface Serial2/0
      ip vrf forwarding grc
      ip address 192.168.1.1 255.255.255.252
    !
    interface Serial3/0
      ip vrf forwarding grc
      ip address 192.168.2.1 255.255.255.252
    ...
    !
    router ospf 9000 vrf grc
      log-adjacency-changes
      capability vrf-lite
      redistribute rip metric 1 subnets
      network 192.168.1.0 0.0.0.255 area 0
    !
    router rip
      address-family ipv4 vrf grc
      redistribute ospf 9000 vrf grc
      network 192.168.2.0
      no auto-summary
      end
    Device# show ip route vrf grc
    Routing Table: grc
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    Gateway of last resort is not set
    O IA 192.168.192.0/24 [110/138] via 192.168.1.13, 00:06:08, Serial2/0
                          [110/138] via 192.168.1.9, 00:06:08, Serial3/0
    O IA 192.168.242.0/24 [110/74] via 192.168.1.13, 00:06:08, Serial2/0
    O IA 192.168.193.0/24 [110/148] via 192.168.1.13, 00:06:08, Serial2/0
                          [110/148] via 192.168.1.9, 00:06:08, Serial3/0
    O IA 192.168.128.0/24 [110/74] via 192.168.1.9, 00:06:08, Serial3/0
    O IA 192.168.129.0/24 [110/84] via 192.168.1.9, 00:06:08, Serial3/0
    O IA 192.168.130.0/24 [110/84] via 192.168.1.9, 00:06:08, Serial3/0
         172.16.0.0/24 is subnetted, 2 subnets
    O E2    172.16.9.0 [110/5] via 192.168.1.13, 00:06:08, Serial2/0
    O E2    172.16.10.0 [110/5] via 192.168.1.13, 00:06:08, Serial2/0
    O IA 192.168.131.0/24 [110/94] via 192.168.1.9, 00:06:20, Serial3/0
         192.168.1.0/30 is subnetted, 4 subnets
    C       192.168.1.8 is directly connected, Serial3/0
    C       192.168.1.12 is directly connected, Serial2/0
    O       192.168.1.0 [110/128] via 192.168.1.9, 00:06:20, Serial3/0
    O       192.168.1.4 [110/128] via 192.168.1.13, 00:06:20, Serial2/0
    

    Example Verifying the OSPF Multi-VRF Configuration

    This example illustrates the output display from the show ip ospf command after OSPF multi-VRF has been configured on the router.

    Device# show ip ospf 9000
               
     Routing Process "ospf 9000" with ID 10.0.0.1
     Supports only single TOS(TOS0) routes
     Supports opaque LSA
     Supports Link-local Signaling (LLS)
     Supports area transit capability
     Supports NSSA (compatible with RFC 3101)
     Event-log disabled
     It is an autonomous system boundary router
     Redistributing External Routes from,
        rip with metric mapped to 1, includes subnets in redistribution
     Router is not originating router-LSAs with maximum metric
     Initial SPF schedule delay 5000 msecs
     Minimum hold time between two consecutive SPFs 10000 msecs
     Maximum wait time between two consecutive SPFs 10000 msecs
     Incremental-SPF disabled
     Minimum LSA interval 5 secs
     Minimum LSA arrival 1000 msecs
     LSA group pacing timer 240 secs
     Interface flood pacing timer 33 msecs
     Retransmission pacing timer 66 msecs
     Number of external LSA 0. Checksum Sum 0x000000
     Number of opaque AS LSA 0. Checksum Sum 0x000000
     Number of DCbitless external and opaque AS LSA 0
     Number of DoNotAge external and opaque AS LSA 0
     Number of areas in this router is 1. 1 normal 0 stub 0 nssa
     Number of areas transit capable is 0
     External flood list length 0
     IETF NSF helper support enabled
     Cisco NSF helper support enabled
     Reference bandwidth unit is 100 mbps
        Area BACKBONE(0) (Inactive)
            Number of interfaces in this area is 1
            Area has no authentication
            SPF algorithm last executed 00:00:10.264 ago
            SPF algorithm executed 1 times
            Area ranges are
            Number of LSA 1. Checksum Sum 0x00B674
            Number of opaque link LSA 0. Checksum Sum 0x000000
            Number of DCbitless LSA 0
            Number of indication LSA 0
            Number of DoNotAge LSA 0
            Flood list length 0
    
    

    Additional References

    Related Documents

    Related Topic

    Document Title

    Configuring OSPF

    Configuring OSPF

    Multiprotocol Label Switching (MPLS)

    MPLS Multi-VRF (VRF Lite) Support

    Standards

    Standards

    Title

    No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.

    --

    MIBs

    MIBs

    MIBs Link

    No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

    To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

    http:/​/​www.cisco.com/​go/​mibs

    RFCs

    RFCs

    Title

    No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.

    --

    Technical Assistance

    Description

    Link

    The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    Feature Information for OSPF Support for Multi-VRF on CE Routers

    The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

    Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

    Table 1 Feature Information for OSPF Support for Multi-VRF on CE Routers

    Feature Name

    Releases

    Feature Information

    OSPF Support for Multi-VRF on CE Routers

    12.0(21)ST

    12.0(22)S

    12.2(8)B

    12.2(13)T

    12.2(14)S

    The OSPF Support for Multi-VRF on CE Routers feature provides the capability to suppress provider edge (PE) checks that are needed to prevent loops when the PE is performing a mutual redistribution of packets between the OSPF and BGP protocols. When VPN routing and forwarding (VRF) is used on a router that is not a PE (that is, one that is not running BGP), the checks can be turned off to allow for correct population of the VRF routing table with routes to IP prefixes.

    The following commands are introduced or modified in the feature documented in this module:

    • capability vrf-lite

    Glossary

    CE Router --Customer Edge router, an edge router in the C network, defined as a C router which attaches directly to a P router.

    C Network --Customer (enterprise or service provider) network.

    C Router --Customer router, a router in the C network.

    LSA --link-state advertisement . Broadcast packet used by link-state protocols that contains information about neighbors and path costs. LSAs are used by the receiving routers to maintain their routing tables.

    PE Router --Provider Edge router, an edge router in the P network, defined as a P router which attaches directly to a C router.

    P Network --MPLS-capable service provider core network. P routers perform MPLS.

    P Router --Provider router, a router in the P network.

    SPF --shortest path first. A routing algorithm that iterates on length of path to determine a shortest-path spanning tree.

    VPN --Virtual Private Network. Enables IP traffic to travel securely over a public TCP/IP network by encrypting all traffic from one network to another.

    VRF --VPN Routing and Forwarding.