IP Routing: BGP Configuration Guide, Cisco IOS Release 15S
VPLS BGP Signaling
Downloads: This chapterpdf (PDF - 1.36MB) The complete bookPDF (PDF - 12.26MB) | The complete bookePub (ePub - 2.96MB) | Feedback

VPLS BGP Signaling

VPLS BGP Signaling

The two primary functions of the Virtual Private LAN Service (VPLS) control plane are autodiscovery and signaling. The VPLS BGP Signaling feature enables you to use BGP as both an autodiscovery and a signaling protocol for VPLS, in accordance with RFC 4761.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for VPLS BGP Signaling

You are familiar with the concepts in the “Configuring Virtual Private LAN Services” and the “VPLS Autodiscovery BGP Based” modules of the MPLS Layer 2 VPNs Configuration Guide.

Information About VPLS BGP Signaling

Overview of VPLS BGP Signaling

Prior to the VPLS BGP Signaling feature, BGP was used for autodiscovery and Label Distribution Protocol (LDP) for signaling in accordance with RFC 6074. The VPLS BGP Signaling feature enables you to use BGP as the control plane protocol for both autodiscovery and signaling in accordance with RFC 4761.

As specified in RFC 4761, internal BGP (iBGP) peers will exchange update messages of the L2VPN AFI/SAFI with L2VPN information to perform both autodiscovery and signaling. The BGP multiprotocol Network Layer Reachability Information (NLRI) consists of a Route Distinguisher (RD), VPLS Endpoint ID (VE ID), VE Block Offset (VBO), VE Block Size (VBS), and Label Base (LB).

The figure below shows the format of the NLRI for RFC 4761.

Figure 1. RFC 4761 NLRI

Additional information, such as next-hop, route target (specified for a VPLS instance), and other Layer 2 data are carried in the BGP extended community attributes. A route target-based import/export mechanism similar to L3VPN is performed by BGP to filter L2VPN NLRIs of a particular VPLS instance.

Whether you use BGP signaling (RFC 4761) or LDP signaling (RFC 6074) depends on the commands you specify. To enable the VPLS BGP Signaling feature, use the autodiscovery bgp signaling bgp command in L2 VFI configuration mode. This command is supported on a per VPLS instance basis.

If a BGP session receives an invalid (that is, not matching the configuration) BGP update advertisement (update or withdraw), it is ignored.

BGP’s main task in supporting VPLS is route distribution via the L2VPN address family and interactions with L2VPN. Interactions between BGP and other components remain the same. Basic BGP functionalities like best-path selection, next-hop handling, and update generation, continue to operate in the same manner with VPLS BGP signaling. BGP RT constraint works seamlessly with the BGP VPLS Signaling feature.

How to Configure VPLS BGP Signaling

Configuring VPLS BGP Signaling

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    l2vpn vfi context name

    4.    vpn id vpn-id

    5.    autodiscovery bgp signaling {bgp | ldp} [template template-name]

    6.    ve id ve-id

    7.    ve range ve-range

    8.    exit

    9.    exit

    10.    router bgp autonomous-system-number

    11.    bgp graceful-restart

    12.    neighbor ip-address remote-as autonomous-system-number

    13.    address-family l2vpn [vpls]

    14.    neighbor ip-address activate

    15.    neighbor ip-address send-community [both | standard | extended]

    16.    neighbor ip-address suppress-signaling-protocol ldp

    17.    end

    18.    show bgp l2vpn vpls {all | rd route-distinguisher}


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3l2vpn vfi context name


    Example:
    Device(config)# l2vpn vfi context vfi1
     

    Establishes a L2VPN virtual forwarding interface (VFI) between two or more separate networks and enters Layer 2 VFI configuration mode.

     
    Step 4vpn id vpn-id


    Example:
    Device(config-vfi)# vpn id 100
     

    Configures a VPN ID for the VPLS domain.

     
    Step 5autodiscovery bgp signaling {bgp | ldp} [template template-name]


    Example:
    Device(config-vfi)# autodiscovery bgp signaling bgp
     

    Enables BGP signaling and discovery or LDP signaling and enters L2VPN VFI autodiscovery configuration mode.

    Note   

    For the VPLS BGP Signaling feature use the autodiscovery bgp signaling bgp command.

     
    Step 6ve id ve-id


    Example:
    Device(config-vfi-autodiscovery)# ve id 1001
     

    Specifies the VPLS endpoint (VE) device ID value. The VE ID identifies a VFI within a VPLS service. The VE device ID value is from 1 to 16384.

     
    Step 7ve range ve-range


    Example:
    Device(config-vfi-autodiscovery)# ve range 12
     

    Specifies the VE device ID range value. The VE range overrides the minimum size of VE blocks. The default minimum size is 10. Any configured VE range must be higher than 10.

     
    Step 8exit


    Example:
    Device(config-vfi-autodiscovery)# exit
     

    Exits L2VPN VFI autodiscovery configuration mode and enters L2VPN VFI configuration mode.

     
    Step 9exit


    Example:
    Device(config-vfi)# exit
     

    Exits L2VPN VFI configuration mode and enters global configuration mode.

     
    Step 10router bgp autonomous-system-number


    Example:
    Device(config)# router bgp 100
     

    Enters router configuration mode to create or configure a BGP routing process.

     
    Step 11bgp graceful-restart


    Example:
    Device(config-router)# bgp graceful-restart
     

    Enables the BGP graceful restart capability and BGP nonstop forwarding (NSF) awareness.

     
    Step 12neighbor ip-address remote-as autonomous-system-number


    Example:
    Device(config-router)# neighbor 10.10.10.1 remote-as 100
     

    Configures peering with a BGP neighbor in the specified autonomous system.

     
    Step 13address-family l2vpn [vpls]


    Example:
    Device(config-router)# address-family l2vpn vpls
     
    Specifies the L2VPN address family and enters address family configuration mode.
    • The optional vpls keyword specifies that VPLS endpoint provisioning information is to be distributed to BGP peers.
    In this example, an L2VPN VPLS address family session is created.
     
    Step 14neighbor ip-address activate


    Example:
    Device(config-router-af)# neighbor 10.10.10.1 activate
     

    Enables the neighbor to exchange information for the L2VPN VPLS address family with the local device.

     
    Step 15neighbor ip-address send-community [both | standard | extended]


    Example:
    Device(config-router-af)# neighbor 10.10.10.1 send-community extended 
     
    Specifies that a communities attribute should be sent to a BGP neighbor.
    • In this example, an extended communities attribute is sent to the neighbor at 10.10.10.1.
     
    Step 16neighbor ip-address suppress-signaling-protocol ldp


    Example:
    Device(config-router-af)# neighbor 10.10.10.1 suppress-signaling-protocol ldp 
     
    Suppresses LDP signaling and enables BGP signaling.
    • In this example LDP signaling is suppressed (and BGP signaling enabled) for the neighbor at 10.10.10.1.
     
    Step 17end


    Example:
    Device(config-router-af)# end
     

    Exits address family configuration mode and returns to privileged EXEC mode.

     
    Step 18show bgp l2vpn vpls {all | rd route-distinguisher}


    Example:
    Device# show bgp l2vpn vpls all 
     

    (Optional) Displays information about the L2VPN VPLS address family.

     

    Configuration Examples for VPLS BGP Signaling

    Example: Configuring and Verifying VPLS BGP Signaling

    l2vpn vfi context vfi1
     vpn id 100
     autodiscovery bgp signaling bgp
      ve id 1001
      ve range 10
     !
    !
    router bgp 100
     bgp graceful-restart
     neighbor 209.165.200.224 remote-as 100
     neighbor 209.165.200.224 update-source Loopback1
     !
     address-family l2vpn vpls
      neighbor 209.165.200.224 activate
      neighbor 209.165.200.224 send-community extended
      neighbor 209.165.200.224 suppress-signaling-protocol ldp
      exit-address-family
     !
    show bgp l2vpn vpls all
    
    Network                             Next Hop 			        Metric LocPrf Weight Path
    Route Distinguisher: 100:100
    *>100:100:VEID-1001:Blk-1001/136    0.0.0.0                             32768  ?    
    
    *>i 100:100:VEID-1003:Blk-1000/136  209.165.200.224               0      100     0     ?
    
    

    Additional References for VPLS BGP Signaling

    Related Documents

    Related Topic

    Document Title

    Cisco IOS commands

    Cisco IOS Master Command List, All Releases

    BGP commands: complete command syntax, command mode, defaults, command history, usage guidelines, and examples.

    Cisco IOS IP Routing: BGP Command Reference

    Configuring Virtual Private LAN Services

    MPLS Layer 2 VPNs Configuration Guide

    VPLS Autodiscovery BGP Based

    MPLS Layer 2 VPNs Configuration Guide

    Standards and RFCs

    Standard/RFC

    Title

    RFC 4761

    Virtual Private LAN Service (VPLS) Using BGP for Auto-Discovery and Signaling

    RFC 6074

    Provisioning, Auto-Discovery, and Signaling in Layer 2 Virtual Private Networks (L2VPNs)

    Technical Assistance

    Description

    Link

    The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    Feature Information for VPLS BGP Signaling

    The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

    Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

    Table 1 Feature Information for VPLS BGP Signaling

    Feature Name

    Releases

    Feature Information

    VPLS BGP Signaling

    15.3(2)S

    The VPLS BGP Signaling feature enables you to use BGP as both an autodiscovery and signaling protocol for VPLS, in accordance with RFC 4761.

    The following commands were introduced or modified: autodiscovery (MPLS), neighbor suppress-signaling-protocol, show bgp l2vpn vpls, and ve.