IP Routing: BGP Configuration Guide, Cisco IOS Release 15S
BGP — mVPN BGP sAFI 129 - IPv4
Downloads: This chapterpdf (PDF - 1.32MB) The complete bookPDF (PDF - 12.26MB) | The complete bookePub (ePub - 2.96MB) | Feedback

BGP — mVPN BGP sAFI 129 - IPv4

BGP — mVPN BGP sAFI 129 - IPv4

The BGP—mVPN BGP sAFI 129 IPv4 feature provides the capability to support multicast routing in the service provider’s core IPv4 network. This feature is needed to support BGP-based MVPNs. BGP MVPN provides a means for service providers to use different encapsulation methods (generic routing encapsulation [GRE], Multicast Label Distribution Protocol [MPDP], and ingress replication) for forwarding MVPN multicast data traffic in the service provider network.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Information About BGP--mVPN BGP sAFI 129 - IPv4

BGP — mVPN BGP sAFI 129 - IPv4 Overview

The Cisco BGP Address Family Identifier (AFI) model was introduced with multiprotocol BGP and is designed to be modular and scalable and to support multiple AFI and Subsequent Address Family Identifier (SAFI) configurations. SAFI provides additional information about the type of Network Layer Reachability Information (NLRI) that is used to describe a route and how to connect to a destination.

SAFI 129 provides the capability to support multicast routing in the service provider’s core IPv4 network. This feature is needed to support BGP-based MVPNs. The addition of SAFI 129 allows multicast to select an upstream multicast hop that may be independent of the unicast topology. Multicast routes learned from the customer edge (CE) router or multicast VPN routes learned from remote provider edge (PE) routers are installed into the multicast Routing Information Base (RIB), whereas previously unicast routes in the unicast RIB were replicated into the multicast RIB.

The address-family ipv4 command has been updated to support IP version 4 (IPv4) multicast address prefixes for a VPN routing and forwarding (VRF) instance, and the address-family vpnv4 command has been updated to support VPN version 4 (VPNv4) multicast address prefixes.

How to Configure BGP -- mVPN BGP sAFI 129 - IPv4

Configure BGP — mVPN BGP sAFI 129 - IPv4

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    vrf definition vrf1

    4.    rd route-distinguisher

    5.    route-target export route-target-ext-community

    6.    route-target import route-target-ext-community

    7.    address-family ipv4

    8.    mdt default group-address

    9.    exit

    10.    router bgp autonomous-system-number

    11.    address-family vpnv4 multicast

    12.    neighbor peer-group-name send-community extended

    13.    neighbor peer-group-name route-reflector-client

    14.    exit-address-family

    15.    address-family ipv4 vrf vrf-name

    16.    no synchronization

    17.    exit-address-family

    18.    address-family ipv4 multicast vrf vrf-name

    19.    no synchronization

    20.    exit-address-family

    21.    end

    22.    show running-config | b router bgp


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 vrf definition vrf1


    Example:
    Device(config)# vrf definition vrf1 
    
     

    Defines a VRF instance and enters VRF configuration mode.

     
    Step 4 rd route-distinguisher


    Example:
    Device(config-vrf)# rd 1:1
    
     

    Specifies a route distinguisher (RD) for a VRF instance.

     
    Step 5 route-target export route-target-ext-community


    Example:
    Device(config-vrf)# route-target export 1:1 
    
     

    Creates a route target export extended community for a VRF instance.

     
    Step 6 route-target import route-target-ext-community


    Example:
    Device(config-vrf)# route-target import 1:1 
    
     

    Creates a route target import extended community for a VRF instance.

     
    Step 7 address-family ipv4


    Example:
    Device(config-router)# address-family ipv4
    
     

    Configures a routing session using IPv4 address prefixes and enters address family configuration mode.

     
    Step 8 mdt default group-address


    Example:
    Device(config-vrf)# mdt default 239.0.0.1 
    
     

    Configures a default multicast distribution tree (MDT) group for a VRF instance.

     
    Step 9 exit


    Example:
    Device(config-vrf)# exit
    
     

    Exits VRF configuration mode and returns to global configuration mode.

     
    Step 10 router bgp autonomous-system-number


    Example:
    Device(config)# router bgp 50000
     

    Configures the BGP routing process and enters router configuration mode.

     
    Step 11 address-family vpnv4 multicast


    Example:
    Device(config-router)# address-family vpnv4 multicast
    
     

    Configures a routing session using VPN Version 4 multicast address prefixes and enters address family configuration mode.

     
    Step 12 neighbor peer-group-name send-community extended


    Example:
    Device(config-router-af)# neighbor client1 send-community extended
    
     

    Specifies that a communities attribute should be sent to a BGP neighbor.

     
    Step 13 neighbor peer-group-name route-reflector-client


    Example:
    Device(config-router-af)# neighbor client1 route-reflector-client
    
     

    (Optional) Configures the router as a BGP route reflector and configures the specified neighbor as its client.

     
    Step 14 exit-address-family


    Example:
    Device(config-router-af)# exit-address-family
    
     

    Exits address family configuration mode and enters router configuration mode.

     
    Step 15 address-family ipv4 vrf vrf-name


    Example:
    Device(config-router)# address-family ipv4 vrf vrf1 
    
     

    Places the router in address family configuration mode and specifies the name of the VRF instance to associate with subsequent IPv4 address family configuration mode commands.

     
    Step 16 no synchronization


    Example:
    Device(config-router-af)# no synchronization
    
     

    Enables the Cisco software to advertise a network route without waiting for the Interior Gateway Protocol (IGP) system.

     
    Step 17 exit-address-family


    Example:
    Device(config-router-af)# exit-address-family
    
     

    Exits address family configuration mode and enters router configuration mode.

     
    Step 18 address-family ipv4 multicast vrf vrf-name


    Example:
    Device(config-router)# address-family ipv4 multicast vrf vrf1 
    
     

    Configures a routing session using IPv4 multicast address prefixes for a VRF instance and enters address family configuration mode.

     
    Step 19 no synchronization


    Example:
    Device(config-router-af)# no synchronization
    
     

    Enables the Cisco software to advertise a network route without waiting for the IGP system.

     
    Step 20 exit-address-family


    Example:
    Device(config-router-af)# exit-address-family
    
     

    Exits address family configuration mode and enters router configuration mode.

     
    Step 21 end


    Example:
    Device(config)# end
    
     

    Exits router configuration mode and returns to privileged EXEC mode.

     
    Step 22 show running-config | b router bgp


    Example:
    Device# show running-config | b router bgp
    
     

    (Optional) Displays the running configuration for specified device.

     

    Configuration Examples for BGP--mVPN BGPsAFI 129 - IPv4

    Example: Configuring BGP - mVPN BGP sAFI 129 - IPv4

    This example uses the topology illustrated in the figure below.



    The following example configures BGP SAFI 129 on the route reflector (RR):

    !
    ip multicast-routing 
    !
    !<<< Define BGP update-source loopback0
    !<<< on RR as 192.0.2.10
    interface loopback0
     ip pim sparse-dense-mode
     ip address 192.0.2.10 255.255.255.255
    !
    .
    .
    .
    router bgp 65000
     no synchronization
     neighbor 192.0.2.1 remote-as 65000
     neighbor 192.0.2.1 update-source loopback0
     neighbor 192.0.2.2 remote-as 65000
     neighbor 192.0.2.2 update-source loopback0
     neighbor 192.0.2.3 remote-as 65000
     neighbor 192.0.2.3 update-source loopback0
     !
     .
     .
     address-family vpnv4 unicast
      neighbor 192.0.2.1 activate
      neighbor 192.0.2.1 send-community extended
      neighbor 192.0.2.1 route-reflector-client
      neighbor 192.0.2.2 activate
      neighbor 192.0.2.2 send-community extended
      neighbor 192.0.2.2 route-reflector-client
      neighbor 192.0.2.3 activate
      neighbor 192.0.2.3 send-community extended
      neighbor 192.0.2.3 route-reflector-client 
      exit-address-family
     !
     address-family vpnv4 multicast
      !<<< want route from CE1 with nexthop
      !<<< through PE3 in multicast routing table
      neighbor 192.0.2.1 activate
      neighbor 192.0.2.1 send-community extended
      neighbor 192.0.2.1 route-reflector-client
      neighbor 192.0.2.3 activate 
      neighbor 192.0.2.3 send-community extended
      neighbor 192.0.2.3 route-reflector-client
     exit-address-family
    ! 
    .
    .
    

    The following example configures BGP SAFI 129 on the PE1 router (PE2 and PE3 will have a similar configuration):

    
    Hostname PE1
    !
    vrf definition vrf1
     rd 1:1
     route-target export 1:1
     route-target import 1:1
     !
     address-family ipv4
      mdt default 239.0.0.1
     exit-address-family
    !
    ip multicast-routing
    ip multicast-routing vrf vrf1
    !
    .
    .
    .
    !<<< Define BGP update-source on Loopback0
    !<<< on PE1
    inteface loopback0
     ip pim sparse-dense-mode
     ip address 192.0.2.1 255.255.255.255
    !
    .
    .
    .
    !<<< Define vrf vrf1 interface on PE1 to CE1
    interface ethernet0/0
     vrf forwarding vrf1
     ip pim sparse-dense-mode
     ip address 192.0.2.1 255.255.255.0
    !
    .
    .
    ,
    router bgp 65000
     !<<<< PE peer neighbor with RR
     neighbor 192.0.2.10 remote-as 65000
     neighbor 192.0.2.10 update-source loopback0
     no synchronization
     .
     .
     .
     address-family vpnv4
      neighbor 192.0.2.10 activate
      neighbor 192.0.2.10 send-community extended
     exit-address-family
     !
     !<<< Define vpnv4 safi129 with neighbor
     !<<< to RR
     address-family vpnv4 multicast
      neighbor 192.0.2.10 activate
      neighbor 192.0.2.10 send-community extended
     exit-address-family
     !
     .
     .
     .
     !<<< Define unicast address-family vrf vrf1.
     !<<< PE-CE is eBGP in this case. 
     !<<< If PE-CE is not eBGP, please use
     !<<< redistribute cli, instead of 
     !<<< neighbor cli below.
     address-family ipv4 vrf vrf1 
      no synchronization
      redistribute connected
      neighbor 192.0.2.5 remote-as 65011
     exit-address-family
     !
     !<<< Define multicast address-family vrf vrf1
     !<<< (safi2. PE-CE is eBGP in this case. 
     !<<< If PE-CE is not eBGP, please use
     !<<< redistribute cli, instead of 
     !<<< neighbor cli below.
     address-family ipv4 multicast vrf vrf1
      no synchronization
      redistribute connected
      neighbor 192.0.2.5 remote-as 65011
     exit-address-family
     !
    

    The following example configures BGP SAFI 129 on the CE1 router. (In this case, PE-CE routing is eBGP. CE2 will have a similar configuration):

    
    interface ethernet0/0
     ip address 192.0.2.5 255.255.255.0
     ip pim sparse-dense-mode
    !
    .
    .
    .
    router bgp 65011
     bgp router-id 192.0.2.5
     bgp log-neighbor-changes
     !
     address-family ipv4 
      redistribute connected
      neighbor 192.0.2.1 remote-as 65000
     exit-address-family
     !
     address-family ipv4 multicast
      redistribute connected
      neighbor 192.0.2.1 remote-as 65000
     exit-address-family
    !
    

    Additional References

    Related Documents

    Related Topic

    Document Title

    Cisco IOS commands

    Cisco IOS Master Command List, All Releases

    BGP commands

    Cisco IOS IP Routing: BGP Command Reference

    Standards and RFCs

    Standard/RFC

    Title

    RFC 2547

    BGP/MPLS VPNs

    Technical Assistance

    Description

    Link

    The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    Feature Information for BGP - mVPN BGP sAFI 129 - IPv4

    The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

    Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

    Table 1 Feature Information for BGP - mVPN BGP sAFI 129 - IPv4

    Feature Name

    Releases

    Feature Information

    BGP - mVPN BGP sAFI 129 - IPv4

    15.2(2)S

    15.2(4)S

    Cisco IOS XE Release 3.6S

    The BGP - mVPN BGP sAFI 129 IPv4 feature provides the capability to support multicast routing in the service provider’s core IPv4 network. This feature is needed to support BGP-based MVPNs. BGP MVPN provides a means for service providers to use different encapsulation methods (generic route encapsulation (GRE), Multicast Label Distribution Protocol (MLDP), and ingress replication) for forwarding MVPN multicast data traffic in the service provider network. In Cisco IOS Release 15.2(4)S, support was added for the Cisco 7200 series router.

    The following commands were modified: address-family ipv4, address-family vpnv4.