Broadband Access Aggregation and DSL Configuration Guide, Cisco IOS Release 15MT
G.SHDSL Symmetric DSL Support for Cisco IAD2420 Series IAD
Downloads: This chapterpdf (PDF - 1.33MB) The complete bookPDF (PDF - 2.83MB) | The complete bookePub (ePub - 1.76MB) | Feedback

G.SHDSL Symmetric DSL Support for Cisco IAD2420 Series IAD

G.SHDSL Symmetric DSL Support for Cisco IAD2420 Series IAD

This document describes the Multirate Symmetrical High-Speed Digital Subscriber Line (G.SHDSL) feature supported on the Cisco IAD2420 series integrated access devices (IADs) in Cisco IOS Release 12.2(8)T.

G.SHDSL is ATM-based, multirate, high-speed (up to 2.3 MB), symmetrical digital subscriber line technology for data transfer between a single customer premises equipment (CPE) subscriber and a central office (CO). G.SHDSL refers to the approved standard officially designated in ITU-T G.991.2.

The Cisco IAD2420 series IADs support G.SHDSL in the following models: IAD2424-8FXS, IAD2424-16FXS, IAD2424-16FXS8FXO, and IAD2424-1T1. These models are compatible with the Cisco 6160 and Cisco 6260 Digital Subscriber Line Access Multiplexers (DSLAM). The DSLAM must be equipped with compatible G.SHDSL line cards.

The Cisco IAD2424 IAD supports ATM Adaption Layer 2 (AAL2), ATM Adaption Layer 5 (AAL5), and quality of service (QoS) features for both voice and data services.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for G.SHDSL Symmetric DSL Support

A compatible G.SHDSL line card must be installed in the DSLAM.

Restrictions for G.SHDSL Symmetric DSL Support

The wetting current function is not supported as part of G.SHDSL.

Information About G.SHDSL Symmetric DSL Support

Benefits

  • Enables business class broadband service with voice integration, scalable performance, flexibility, and security.

  • Aggregates G.SHDSL and other transport options into a single box.

  • Provides G.SHDSL high-speed digital data transmissions between CPE and the CO.

  • Supports AAL2 and AAL5 services and applications (including voice), ATM class of service (constant bit rate [CBR], variable bit rate-nonreal time [VBR-nrt], variable bit rate-real time [VBR-rt], and unspecified bit rate [UBR and UBR+]).

  • Provides ATM traffic management and quality of service (QoS) features to enable service providers to manage their core ATM network infrastructures.

How to Configure G.SHDSL Symmetric DSL Support

Configuring G.SHDSL on Cisco IAD2420 Series IADs

To configure G.SHDSL service on the Cisco IAD2420 series IAD that supports G.SHDSL, complete the following steps, beginning in global configuration mode:

SUMMARY STEPS

    1.    controller shdsl 0

    2.    mode atm

    3.    annex {a | b

    4.    line-rate auto | rate

    5.    exit

    6.    interface atm 0

    7.    ip addressIip-address

    8.    atm ilmi-keepaliveseconds

    9.    pvc [ name ] vpi/vci

    10.    protocol ipIP-address

    11.    vbr-rtpeak-rate average-rate burst

    12.    encapsulation aal1 | aal2 | aal5ciscoppp | aal5mux | aal5nlpid | aal5snap

    13.    exit

    14.    shutdown

    15.    Router(config-if)# no shutdown

    16.    Router(config-if)# exit

    17.    Router(config)# exit

    18.    Router> show interface atm 0


DETAILED STEPS
     Command or ActionPurpose
    Step 1 controller shdsl 0


    Example:
    Router(config)# controller shdsl 0
    
     

    Enters controller configuration mode and the controller number.

     
    Step 2 mode atm


    Example:
    Router(config-ctrl)# mode atm
    
     

    Enables ATM encapsulation and creates logical ATM interface 0. Controller framing is automatically set to Extended SuperFrame (ESF). The line code is automatically set to B8ZS.

     
    Step 3 annex {a | b


    Example:
    Router(config-ctrl)# annex a
    
     

    Specifies the regional operating parameters. Enter a for North America and b for Europe. The default is a.

     
    Step 4 line-rate auto | rate


    Example:
    Router(config-ctrl)# line-rate auto 1160
    
     

    Specifies the DSL line rate for the SHDSL port. The range is 192 to 2312 kbps. The default is auto (negotiated between the SHDSL port and the DSLAM).

    Note   

    If different DSL line rates are configured at opposite ends of the DSL uplink, the actual DSL line rate is always the lower rate.

    Note   

    The maximum peak cell rate is 8 kbps less than the line rate.

     
    Step 5 exit


    Example:
    Router(config-ctrl)# exit
    
     

    Exits from controller configuration mode.

     
    Step 6 interface atm 0


    Example:
    Router(config)# interface atm 0
    
     

    Enters ATM configuration mode for interface ATM 0.

     
    Step 7ip addressIip-address


    Example:
    Router(config-if)# ip address 10.1.0.1 255.255.255.0
    
     

    Assigns an IP address to the DSL ATM interface.

     
    Step 8 atm ilmi-keepaliveseconds


    Example:
    Router(config-if)# atm ilmi-keepalive 10
    
     

    (Optional) Enables Integrated Local Management Interface (ILMI) keepalives.

    If you enable ILMI keepalives without specifying the number of seconds, the default time interval is 3 seconds.

     
    Step 9 pvc [ name ] vpi/vci


    Example:
    Router(config-if)# pvc 110/110
    
     

    Enters atm-virtual-circuit (interface-atm-vc) configuration mode, and configures a new ATM PVC by assigning a name (optional) and VPI/VCI numbers.

    The default traffic shaping is UBR; the default encapsulation is AAL5+LLC/SNAP.

     
    Step 10 protocol ipIP-address


    Example:
    Router(config-if-vc)# protocol ip 10.1.0.2
    
     

    (Optional) Enables IP connectivity and creates a point-to-point IP address for the VC.

     
    Step 11 vbr-rtpeak-rate average-rate burst


    Example:
    Router(config-if-vc)# vbr-rt 2304 2304 65535
    
     

    (Optional) Configures the PVC for real-time variable bit rate (VBR) traffic shaping.

    • Peak rate = peak information rate (PIR)

    • Average rate = average information rate (AIR)

    • Burst = burst size in cells

     
    Step 12 encapsulation aal1 | aal2 | aal5ciscoppp | aal5mux | aal5nlpid | aal5snap


    Example:
    Router(config-if-vc)# encapsulation aal2
    
     

    (Optional) Configures the ATM adaptation layer (AAL) and encapsulation type.

    • Use the aal2 keyword for AAL2

    • Use the aal5ciscoppp keyword for Cisco PPP over AAL5

    • Use the aal5mux keyword for AAL5+MUX

    • Use the aal5nlpid keyword for AAL5+NLPID

    • Use the aal5snap keyword for AAL5+LLC/SNAP (the default)

     
    Step 13 exit


    Example:
    Router(config-if-vc)# exit
    
     

    Exits from interface-ATM-VC configuration mode.

     
    Step 14 shutdown


    Example:
    Router(config-if)# shutdown
    
     

    Ensures that the ATM interface is shut down.

     
    Step 15 Router(config-if)# no shutdown

    Example:
    Router(config-if)# no shutdown
    
     

    Activates the ATM interface.

     
    Step 16 Router(config-if)# exit

    Example:
    Router(config-if)# exit
    
    Exits from ATM interface configuration mode.
     
     
    Step 17 Router(config)# exit

    Example:
    Router(config)# exit
    
     

    Exits from global configuration mode.

     
    Step 18 Router> show interface atm 0

    Example:
    Router> show interface atm 0
    
     

    Verifies the ATM interface configuration.

     

    Verifying ATM Configuration

    You can verify the ATM interface configuration by doing the following:

    • To verify the ATM interface configuration, enter the show interface atm 0command in EXEC mode.

    Router# show interface atm 0
    ATM0 is up, line protocol is up 
      Hardware is DSLSAR (with Globespan G.SHDSL Module)
      MTU 4470 bytes, sub MTU 4470, BW 800 Kbit, DLY 2560 usec, 
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ATM, loopback not set
      Keepalive not supported 
      Encapsulation(s):AAL5 AAL2, PVC mode
      24 maximum active VCs, 256 VCs per VP, 2 current VCCs
      VC idle disconnect time:300 seconds
      Last input never, output 00:00:01, output hang never
      Last clearing of "show interface" counters 03:16:00
      Queueing strategy:fifo
      Output queue 0/40, 0 drops; input queue 0/75, 0 drops
      30 second input rate 0 bits/sec, 0 packets/sec
      30 second output rate 0 bits/sec, 0 packets/sec
         2527 packets input, 57116 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         10798 packets output, 892801 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 output buffer failures, 0 output buffers swapped out
    
    • For an SHDSL port, to verify the SHDSL controller status and view the statistics, enter the show controller shdsl 0 command in EXEC mode.

    Router# show controller shdsl 0
     SHDSL 0 controller UP
     SLOT 3: Globespan xDSL controller chipset
     Frame mode: Serial ATM
     Configured Line rate: 1160Kbps
     Line Re-activated 0 times after system bootup
     LOSW Defect alarm: None
     CRC per second alarm: None
     Line termination: CPE
     FPGA Revision: 9
            Current 15 min CRC: 0
            Current 15 min LOSW Defect: 0
            Current 15 min ES: 0
            Current 15 min SES: 0
            Current 15 min UAS: 7
            Previous 15 min CRC: 0
            Previous 15 min LOSW Defect: 0
            Previous 15 min ES: 0
            Previous 15 min SES: 0
            Previous 15 min UAS: 7
     Chipset Version:  1
     Firmware Version:  R1.2
     Modem Status:  Data
     Line rate:  1160 Kbps
     Framer Sync Status: In Sync
     Rcv Clock Status: In the Range
     Loop Attenuation:  0.0 dB
     Transmit Power:  13.5 dB
     Receiver Gain:  11.420 dB
     SNR Sampling:  40
     Last Fail Mode:  No Failure
     
    
    • To verify the SHDSL controller status and view the statistics, change state to administratively down and enter the show controller shdsl 0 command in EXEC mode.

    Router# 
    Router# conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    iad1(config)#contr shds 0
    iad1(config-controller)#shut
    iad1(config-controller)#
    01:30:46: %CONTROLLER-5-UPDOWN: Controller SHDSL 0, changed state to administratively down
    01:30:49: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed state to down
    iad1(config-controller)#end
    Router# show controller shdsl 0
     SHDSL 0 controller ADMINDOWN
     SLOT 3: Globespan xDSL controller chipset
     Frame mode: Serial ATM
     Configured Line rate: 1160Kbps
     Line Re-activated 2 times after system bootup
     LOSW Defect alarm: None
     CRC per second alarm: None
     Line termination: CPE
     FPGA Revision: 9
            Current 15 min CRC: 0
            Current 15 min LOSW Defect: 0
            Current 15 min ES: 0
            Current 15 min SES: 0
            Current 15 min UAS: 7
            Previous 15 min CRC: 0
            Previous 15 min LOSW Defect: 0
            Previous 15 min ES: 0
            Previous 15 min SES: 0
            Previous 15 min UAS: 0
     Chipset Version:  1
     Firmware Version:  R1.2
     Modem Status:  Idle
    

    Verifying Your Configuration

    You can perform the following tests at any time to verify the hardware or software configuration of the Cisco IAD2420 series IADs:

    • Display the hardware configuration with the show version command.

    • Display T1 and SHDSL controllers with the show controllers command.

    • Display the running configuration with the show running-config command

    Display the configuration stored in NVRAM using the show startup-config command.

    Configuration Examples for G.SHDSL Symmetric DSL Support

    The following example shows a typical running configuration with the initial configuration tasks completed:

    Router#
    Router# show running config
    Building configuration...
    Current configuration : 1654 bytes
    !
    version 12.2
    no service single-slot-reload-enable
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Router
    !
    boot system flash:c2420-a2i8sv5-mz.1.0.9
    logging rate-limit console 10 except errors
    !
    network-clock base-rate 56k
    ip subnet-zero
    !
    !
    !
    ip audit notify log
    ip audit po max-events 100
    no ip dhcp-client network-discovery
    lcp max-session-starts 0
    !
    !
    !
    !
    no voice confirmation-tone
    voice-card 0
    !
    !
    !
    controller SHDSL 0
     mode atm
    !
    controller T1 1
     mode cas
     framing esf
     clock source loop-timed
     linecode b8zs
     ds0-group 1 timeslots 1-24 type e&m-immediate-start
    !
    !
    !
    interface Loopback0
     ip address 3.3.3.3 255.255.0.0
    !
    interface Ethernet0
     ip address 1.3.95.50 255.255.0.0
     no ip mroute-cache
    !
    interface Serial0
     bandwidth 10000000
     ip address 180.100.9.11 255.255.255.0
     no keepalive
    !
    interface ATM0
     no ip address
     ip mroute-cache
     atm idle-cell-format itu
     atm enable-payload-scrambling
     no atm ilmi-keepalive
     pvc 110/110
      vbr-rt 2304 2304 65535
      vcci 2
      encapsulation aal2
     !
    !
    router eigrp 10
     network 10.0.0.0
     network 180.100.0.0
     no auto-summary
     no eigrp log-neighbor-changes
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 1.3.0.1
    ip route 2.2.2.2 255.255.255.255 10.10.10.2
    no ip http server
    !
    call rsvp-sync
    !
    voice-port 1:1
    !
    mgcp
    mgcp call-agent 1.4.173.1 service-type mgcp version 0.1
    mgcp tse payload 100
    no mgcp timer receive-rtcp
    mgcp timer net-cont-test 3000
    !
    mgcp profile default
    !
    dial-peer cor custom
    !
    !
    !
    dial-peer voice 1 pots
     application mgcpapp
     port 1:1
    !
    !
    line con 0
     exec-timeout 0 0
    line aux 0
    line 2 3
    line vty 0 4
     login
    !
    end
    

    Additional References

    Related Documents

    Related Topic

    Document Title

    Cisco IOS commands

    Cisco IOS Master Commands List, All Releases

    Broadband Access Aggregation and DSL commands

    Cisco IOS Broadband Access Aggregation and DSL Command Reference

    Technical Assistance

    Description

    Link

    The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    Feature Information for G.SHDSL Symmetric DSL Support

    The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

    Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

    Table 1 Feature Information for G.SHDSL Symmetric DSL Support

    Feature Name

    Releases

    Feature Information

    G.SHDSL Symmetric DSL Support

    12.2(4)T3 12.2(8)T

    In Cisco IOS Release 12.2(4)T3, the Multirate Symmetrical High-Speed Digital Subscriber Line (G.SHDSL) feature was supported on the G.SHDSL one-port WAN interface on the Cisco 2600 series and Cisco 3600 series routers.

    In Cisco IOS Release 12.2(8)T, the G.SHDSL feature was expanded to the Cisco IAD2420 series IADs.

    The following commands were introduced or modified: controller shdsl 0, mode atm, show controller shdsl 0.

    Glossary

    ADSL--Asymmetric DSL (ADSL) available through several telecommunications carriers to accommodate the need for increased bandwidth for Internet access and telecommuting applications.

    ATM --Asynchronous Transfer Mode. International standard for cell relay in which multiple service types (such as voice, video, or data) are conveyed in fixed-length (53-byte) cells. Fixed-length cells allow cell processing to occur in hardware, thereby reducing transit delays. ATM is designed to take advantage of high-speed transmission media such as E3, SONET, and T3.

    CLI--command line interface.

    CO--central office. Local exchange (local switch) that terminates individual local telephone subscriber lines for switching and connects to the public network. Known as a class 5 switch office. For example, 5ESS by Lucent and DMS 100 by Nortel.

    CPE--customer premises equipment. Devices such as channel service units, data service units, modems, and ISDN terminal adapters, required to provide an electromagnetic termination for wide-area network circuits before connecting to the router or access server. This equipment was historically provided by the telephone company, but is now typically provided by the customer in North American markets.

    DSL--Digital Subscriber Line available through several telecommunications carriers to accommodate the need for increased bandwidth for Internet access and telecommuting applications.

    FXO--Foreign Exchange Office. An FXO interface connects to a central office.

    FXS--Foreign Exchange Station: An FXS interface connects directly to a standard telephone, supplying ring voltage, dial tone, and so on.

    G.SHDSL--Multirate Symmetrical High-Speed Digital Subscriber Line.

    IAD--integrated access device. A CPE device used to combine services from various sources onto a common platform for transmission on a common transport span. Typically, an IAD combines various voice and data services such as circuit-based services like traditional telephone service and packet-switched services such as frame relay or ATM.