Application Visibility and Control Configuration Guide, Cisco IOS XE Release 3S
Easy Performance Monitor
Downloads: This chapterpdf (PDF - 1.34MB) The complete bookPDF (PDF - 2.31MB) | The complete bookePub (ePub - 250.0KB) | Feedback

Easy Performance Monitor

Contents

Easy Performance Monitor

The Easy Performance Monitor chapter describes how to configure Easy Performance Monitor (ezPM) for Application Visibility and Control (AVC).

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Easy Performance Monitor

The Easy Performance Monitor (Easy perf-mon or ezPM) feature provides an express method of provisioning monitors. This new mechanism adds functionality and does not affect the existing methods for provisioning monitors.

EzPM does not provide the full flexibility of the traditional perf-mon configuration model but provides ‘profiles’ that represent typical deployment scenarios. On selecting a profile and specifying a few parameters, ezPM provides the remaining provisioning information.

Profile

A profile is a pre-defined set of traffic monitors that contains default traffic monitor, and the traffic monitors can be enabled or disabled for a context. A profile also includes an exporter template. The following profiles are available for configuration:

  • Application Experience
  • Application Statistics

Traffic Monitor

A traffic monitor is a built-in definition of a perf-mon policy (that includes flow record, flow monitor, sampler, and monitor metrics) along with traffic classification on which it is activated.

Each traffic monitor defines the parameters that can be modified. While configuring the traffic monitor, the CLI displays the keywords based on the parameters that can be modified.

Traffic Monitors for Application Experience Profile

For an application experience profile, you can configure the following metrics:
  • Application response time (ART) metrics and counters for TCP traffic
  • Application level counters for DNS and DHT protocols
  • Conversational level counters for IP traffic
  • Media metrics and counters for rtp and telepresence media traffic
  • URL information, ART metrics, and counters for sampled HTTP traffic.

For each of the metrics for a traffic monitor, you can configure the number of flow entries per cache, reduce the default traffic classification, and activate traffic monitor for IPv4 and IPv6 traffic. For media metrics, you can also activate the traffic monitor in ingress and egress directions.

Traffic Monitors for Application Statistics Profile

For an Application Statistics profile, the following traffic monitors are available for configuration:

  • application-client-server-stats
  • application-stats

The application statistics profile provides only application statistics and not performance statistics. The monitors operate on both IPv4 and IPv6 traffic. You can monitor either application-client-server-stats or application-stats as the application-client-server-stats monitor provides the same information as that of application-stats along with additional information.

Context

A context represents a performance monitor policy map that is attached to an interface in ingress and egress directions. A context contains the information about the traffic-monitor that has to be enabled. When a context is attached to an interface, two policy-maps are created, one each in ingress and egress directions. Depending on the direction specified in the traffic monitor, the policy-maps are attached in that direction and the traffic is monitored. You can modify the context to override pre-defined directions.

You can create multiple contexts based on a single profile with different traffic monitors, different exporters, and different parameters for every selected traffic monitor.

An ezPM context can be attached to multiple interfaces.

A maximum of one (1) application experience profile context and three (3) application statistics profile contexts, for a total of four (4) contexts can be attached to a single interface.

You can modify the ezPM context only when the context is not attached to an interface. To detach the context from an interface, use the no performance monitor context context-name command.

Configuring Easy Performance Monitor

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    performance monitor context context-name profile profile-name

    4.    exporter destination {hostname | ipaddress} source interface interface-type number [port port-value transport udp vrf vrf-name]

    5.    (Optional) Repeat Step 4 to configure additional exporters.

    6.    traffic monitor {application-response-time | application-traffic-stats | conversation-traffic-stats | media [egress | ingress] | url} [cache-size max-entries] [cache-type [normal | synchronized]] [[class-and | class-replace] class-name] [ipv4 | ipv6] [sampling-rate number]

    7.    Repeat Step 6 to configure additional traffic monitor parameters.

    8.    exit

    9.    interface interface-type number

    10.    performance monitor context context-name

    11.    exit


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 performance monitor context context-name profile profile-name


    Example:
    Device(config)# performance monitor context perf-mon-test profile application-experience
     

    Enters performance monitor configuration mode, creates a context with application-experience profile.

     
    Step 4exporter destination {hostname | ipaddress} source interface interface-type number [port port-value transport udp vrf vrf-name]


    Example:
    Device(config-perf-mon)# exporter destination 10.1.1.1 source interface GigabitEthernet0/0/0 port 1 transport udp vrf vpn1
     

    Attaches the exporter to the context and configures exporter parameters.

     
    Step 5(Optional) Repeat Step 4 to configure additional exporters.  

     
    Step 6 traffic monitor {application-response-time | application-traffic-stats | conversation-traffic-stats | media [egress | ingress] | url} [cache-size max-entries] [cache-type [normal | synchronized]] [[class-and | class-replace] class-name] [ipv4 | ipv6] [sampling-rate number]


    Example:
    Device(config-perf-mon)# traffic monitor media egress cache-size 70 class-and cln ipv6
     

    Configures the traffic monitor to monitor the specified metrics.

    Note   

    The class-and and class-replace keywords are not available for application-statistics profile.

     
    Step 7 Repeat Step 6 to configure additional traffic monitor parameters.  

     
    Step 8 exit


    Example:
    Device(config-perf-mon)# exit
     

    Exits performance monitor configuration mode and enters global configuration mode.

     
    Step 9 interface interface-type number


    Example:
    Device(config)# interface gigabitethernet 0/1/0
     

    Enters interface configuration mode.

     
    Step 10 performance monitor context context-name


    Example:
    Device(config-if)# performance monitor context perf-mon-test
     

    Configures the specified performance monitor context on the interface.

     
    Step 11 exit


    Example:
    Device(config-if)# exit
     

    Exits interface configuration mode and enters global configuration mode.

     

    Example: Configuring a Performance Monitor Context with Default ART, Media, and URL Traffic Monitors

    The following example shows how to configure a performance monitor context to monitor the traffic metrics for ART, media, and URL:

    Device# configure terminal
    Device(config)# performance monitor context perf-mon-test profile application-experience
    Device(config-perf-mon)# exporter destination 10.10.1.1 source interface GigabitEthernet0/0/0 port 15 transport udp vrf in-vrf
    Device(config-perf-mon)# traffic-monitor application-response-time 
    Device (config-perf-mon)# traffic-monitor media 
    Device(config-perf-mon)# traffic-monitor url
    Device(config-perf-mon)# exit
    

    Example: Configuring a Performance Monitor Context With Traffic Monitor Enabling the Media Metrics for Ipv6 Traffic in Ingress and Egress Directions

    The following example shows how to configure a performance monitor context with traffic monitor enabling the media metrics for ipv6 traffic in ingress and egress directions:

    Device# configure terminal
    Device(config)# performance monitor context perf-mon-test profile application-experience
    Device(config-perf-mon)# exporter destination 10.10.1.1 source interface GigabitEthernet0/0/0 port 15 transport udp vrf in-vrf
    Device(config-perf-mon)# traffic-monitor media ingress ipv6
    Device(config-perf-mon)# traffic-monitor media egress ipv6
    Device(config-perf-mon)# exit
    

    Example: Configuring a Performance Monitor Context on Multiple Interfaces

    The following example shows how to configure a performance monitor context on multiple interfaces:

    Device# configure terminal
    Device(config)# interface gigabitethernet 0/1/0
    Device(config-if)# performance monitor context perf-mon-test
    Device(config-if)# exit
    Device(config)# interface gigabitethernet 0/2/0
    Device(config-if)# performance monitor context perf-mon-test
    Device(config-if)# exit

    Example: Verifying the Complete Configuration for a Performance Monitor Context

    The following example shows the complete underlying configuration of a performance monitor context that uses all traffic monitors. This configuration demonstrates how ezPM builds the configuration by applying the Application Experience profile definition to the context.

    Device# show running-config performance monitor context reference
    
    !
    performance monitor context reference profile application-experience
    exporter destination 5.4.3.2 source Ethernet0/0.1
    traffic-monitor all
    !
    Device# show performance monitor context reference configuration
    
    !===============================================================================
    ! Equivalent Configuration of Context reference !
    !===============================================================================
    !Exporters
    !==========
    !
    flow exporter reference-1
    description performance monitor context reference exporter
    destination 5.4.3.2
    source Ethernet0/0.1
    transport udp 4739
    export-protocol ipfix
    template data timeout 300
    option c3pl-class-table timeout 300
    option c3pl-policy-table timeout 300
    option interface-table timeout 300
    option vrf-table timeout 300
    option sampler-table timeout 300
    option application-table timeout 300
    option application-attributes timeout 300
    option sub-application-table timeout 300
    !
    !Access Lists
    !=============
    ip access-list extended reference-conv_ipv4_tcp
    permit tcp any any
    !
    ipv6 access-list reference-conv_ipv6_tcp
    permit tcp any any
    !
    ip access-list extended reference-conv_ipv4_udp
    permit udp any any
    !
    ipv6 access-list reference-conv_ipv6_udp
    permit udp any any
    !
    ip access-list extended reference-art_ipv4_tcp
    permit tcp any any
    !
    ipv6 access-list reference-art_ipv6_tcp
    permit tcp any any
    !
    ip access-list extended reference-media_ipv4_udp
    permit udp any any
    !
    ipv6 access-list reference-media_ipv6_udp
    permit udp any any
    !
    ip access-list extended reference-url_ipv4_tcp
    permit tcp any any
    !
    ipv6 access-list reference-url_ipv6_tcp
    permit tcp any any
    !
    !Class-maps
    !===========
    class-map match-any reference-app_ts
    match protocol dns
    match protocol dht
    !
    class-map match-any reference-conv_ts_ipv4
    match access-group name reference-conv_ipv4_tcp
    match access-group name reference-conv_ipv4_udp
    !
    class-map match-any reference-conv_ts_ipv6
    match access-group name reference-conv_ipv6_tcp
    match access-group name reference-conv_ipv6_udp
    !
    class-map match-all reference-art_ipv4
    match access-group name reference-art_ipv4_tcp
    !
    class-map match-all reference-art_ipv6
    match access-group name reference-art_ipv6_tcp
    !
    class-map match-any reference-media_app
    match protocol telepresence-media
    match protocol rtp
    !
    class-map match-all reference-media_ipv4_in
    match access-group name reference-media_ipv4_udp
    match class-map reference-media_app
    !
    class-map match-all reference-media_ipv4_out
    match access-group name reference-media_ipv4_udp
    match class-map reference-media_app
    !
    class-map match-all reference-media_ipv6_in
    match access-group name reference-media_ipv6_udp
    match class-map reference-media_app
    !
    class-map match-all reference-media_ipv6_out
    match access-group name reference-media_ipv6_udp
    match class-map reference-media_app
    !
    class-map match-any reference-url_app
    match protocol napster
    match protocol gotomypc
    match protocol yahoo-messenger
    match protocol tunnel-http
    match protocol baidu-movie
    match protocol flashmyspace
    match protocol directconnect
    match protocol audio-over-http
    match protocol skype
    match protocol video-over-http
    match protocol pando
    match protocol flashyahoo
    match protocol msn-messenger
    match protocol flash-video
    match protocol webthunder
    match protocol vnc-http
    match protocol activesync
    match protocol irc
    match protocol realmedia
    match protocol gmail
    match protocol google-earth
    match protocol gnutella
    match protocol rtmpt
    match protocol http
    match protocol ms-update
    match protocol rtsp
    match protocol http-alt
    match protocol share-point
    match protocol binary-over-http
    match protocol ms-sms
    match protocol megavideo
    !
    class-map match-all reference-url_ipv4
    match access-group name reference-url_ipv4_tcp
    match class-map reference-url_app
    !
    class-map match-all reference-url_ipv6
    match access-group name reference-url_ipv6_tcp
    match class-map reference-url_app
    !
    class-map match-all reference-art_url_ipv4
    match class-map reference-art_ipv4
    match class-map reference-url_ipv4
    !
    class-map match-all reference-art_url_ipv6
    match class-map reference-art_ipv6
    match class-map reference-url_ipv6
    !
    !Samplers
    !=========
    !Records and Monitors
    !=====================
    !
    flow record type performance-monitor reference-app_ts_in
    description ezPM record
    match routing vrf input
    match ipv4 version
    match ipv4 protocol
    match interface input
    match flow direction
    match application name account-on-resolution
    collect ipv4 dscp
    collect interface output
    collect counter bytes long
    collect counter packets
    collect timestamp sys-uptime first
    collect timestamp sys-uptime last
    collect connection new-connections
    collect connection sum-duration
    !
    !
    flow monitor type performance-monitor reference-app_ts_in
    record reference-app_ts_in
    exporter reference-1
    cache entries 1000
    cache timeout synchronized 60
    !
    !
    flow record type performance-monitor reference-app_ts_out
    description ezPM record
    match routing vrf input
    match ipv4 version
    match ipv4 protocol
    match interface output
    match flow direction
    match application name account-on-resolution
    collect ipv4 dscp
    collect interface input
    collect counter bytes long
    collect counter packets
    collect timestamp sys-uptime first
    collect timestamp sys-uptime last
    collect connection new-connections
    collect connection sum-duration
    !
    !
    flow monitor type performance-monitor reference-app_ts_out
    record reference-app_ts_out
    exporter reference-1
    cache entries 1000
    cache timeout synchronized 60
    !
    !
    flow record type performance-monitor reference-conv_ts_ipv4
    description ezPM record
    match routing vrf input
    match ipv4 protocol
    match application name account-on-resolution
    match connection client ipv4 address
    match connection server ipv4 address
    match connection server transport port
    collect ipv4 dscp
    collect ipv4 ttl
    collect interface input
    collect interface output
    collect timestamp sys-uptime first
    collect timestamp sys-uptime last
    collect connection new-connections
    collect connection sum-duration
    collect connection server counter bytes long
    collect connection server counter packets long
    collect connection client counter bytes long
    collect connection client counter packets long
    !
    !
    flow monitor type performance-monitor reference-conv_ts_ipv4
    record reference-conv_ts_ipv4
    exporter reference-1
    cache entries 6250
    cache timeout synchronized 60 export-spread 15
    !
    !
    flow record type performance-monitor reference-conv_ts_ipv6
    description ezPM record
    match routing vrf input
    match ipv6 protocol
    match application name account-on-resolution
    match connection client ipv6 address
    match connection server transport port
    match connection server ipv6 address
    collect ipv6 dscp
    collect ipv6 hop-limit
    collect interface input
    collect interface output
    collect timestamp sys-uptime first
    collect timestamp sys-uptime last
    collect connection new-connections
    collect connection sum-duration
    collect connection server counter bytes long
    collect connection server counter packets long
    collect connection client counter bytes long
    collect connection client counter packets long
    !
    !
    flow monitor type performance-monitor reference-conv_ts_ipv6
    record reference-conv_ts_ipv6
    exporter reference-1
    cache entries 6250
    cache timeout synchronized 60 export-spread 15
    !
    !
    flow record type performance-monitor reference-art_ipv4
    description ezPM record
    match routing vrf input
    match ipv4 protocol
    match application name account-on-resolution
    match connection client ipv4 address
    match connection server ipv4 address
    match connection server transport port
    collect ipv4 dscp
    collect ipv4 ttl
    collect interface input
    collect interface output
    collect timestamp sys-uptime first
    collect timestamp sys-uptime last
    collect connection new-connections
    collect connection sum-duration
    collect connection delay response to-server sum
    collect connection server counter responses
    collect connection delay response to-server histogram late
    collect connection delay network to-server sum
    collect connection delay network to-client sum
    collect connection client counter packets retransmitted
    collect connection delay network client-to-server sum
    collect connection delay application sum
    collect connection delay application max
    collect connection delay response client-to-server sum
    collect connection transaction duration sum
    collect connection transaction counter complete
    collect connection server counter bytes long
    collect connection server counter packets long
    collect connection client counter bytes long
    collect connection client counter packets long
    !
    !
    flow monitor type performance-monitor reference-art_ipv4
    record reference-art_ipv4
    exporter reference-1
    cache entries 2250
    cache timeout synchronized 60 export-spread 15
    !
    !
    flow record type performance-monitor reference-art_ipv6
    description ezPM record
    match routing vrf input
    match ipv6 protocol
    match application name account-on-resolution
    match connection client ipv6 address
    match connection server transport port
    match connection server ipv6 address
    collect ipv6 dscp
    collect ipv6 hop-limit
    collect interface input
    collect interface output
    collect timestamp sys-uptime first
    collect timestamp sys-uptime last
    collect connection new-connections
    collect connection sum-duration
    collect connection delay response to-server sum
    collect connection server counter responses
    collect connection delay response to-server histogram late
    collect connection delay network to-server sum
    collect connection delay network to-client sum
    collect connection client counter packets retransmitted
    collect connection delay network client-to-server sum
    collect connection delay application sum
    collect connection delay application max
    collect connection delay response client-to-server sum
    collect connection transaction duration sum
    collect connection transaction counter complete
    collect connection server counter bytes long
    collect connection server counter packets long
    collect connection client counter bytes long
    collect connection client counter packets long
    !
    !
    flow monitor type performance-monitor reference-art_ipv6
    record reference-art_ipv6
    exporter reference-1
    cache entries 2250
    cache timeout synchronized 60 export-spread 15
    !
    !
    flow record type performance-monitor reference-media_ipv4_in
    description ezPM record
    match routing vrf input
    match ipv4 protocol
    match ipv4 source address
    match ipv4 destination address
    match transport source-port
    match transport destination-port
    match transport rtp ssrc
    match interface input
    collect ipv4 dscp
    collect ipv4 ttl
    collect transport packets lost counter
    collect transport rtp jitter maximum
    collect interface output
    collect counter bytes long
    collect counter packets
    collect timestamp sys-uptime first
    collect timestamp sys-uptime last
    collect application name
    collect connection new-connections
    collect transport rtp payload-type
    collect transport rtp jitter mean sum
    !
    !
    flow monitor type performance-monitor reference-media_ipv4_in
    record reference-media_ipv4_in
    exporter reference-1
    cache entries 4000
    cache timeout synchronized 60 export-spread 15
    !
    !
    flow record type performance-monitor reference-media_ipv6_in
    description ezPM record
    match routing vrf input
    match ipv6 protocol
    match ipv6 source address
    match ipv6 destination address
    match transport source-port
    match transport destination-port
    match transport rtp ssrc
    match interface input
    collect ipv6 dscp
    collect ipv6 hop-limit
    collect transport packets lost counter
    collect transport rtp jitter maximum
    collect interface output
    collect counter bytes long
    collect counter packets
    collect timestamp sys-uptime first
    collect timestamp sys-uptime last
    collect application name
    collect connection new-connections
    collect transport rtp payload-type
    collect transport rtp jitter mean sum
    !
    !
    flow monitor type performance-monitor reference-media_ipv6_in
    record reference-media_ipv6_in
    exporter reference-1
    cache entries 4000
    cache timeout synchronized 60 export-spread 15
    !
    !
    flow record type performance-monitor reference-media_ipv4_out
    description ezPM record
    match routing vrf input
    match ipv4 protocol
    match ipv4 source address
    match ipv4 destination address
    match transport source-port
    match transport destination-port
    match transport rtp ssrc
    match interface output
    collect ipv4 dscp
    collect ipv4 ttl
    collect transport packets lost counter
    collect transport rtp jitter maximum
    collect interface input
    collect counter bytes long
    collect counter packets
    collect timestamp sys-uptime first
    collect timestamp sys-uptime last
    collect application name
    collect connection new-connections
    collect transport rtp payload-type
    collect transport rtp jitter mean sum
    !
    !
    flow monitor type performance-monitor reference-media_ipv4_out
    record reference-media_ipv4_out
    exporter reference-1
    cache entries 4000
    cache timeout synchronized 60 export-spread 15
    !
    !
    flow record type performance-monitor reference-media_ipv6_out
    description ezPM record
    match routing vrf input
    match ipv6 protocol
    match ipv6 source address
    match ipv6 destination address
    match transport source-port
    match transport destination-port
    match transport rtp ssrc
    match interface output
    collect ipv6 dscp
    collect ipv6 hop-limit
    collect transport packets lost counter
    collect transport rtp jitter maximum
    collect interface input
    collect counter bytes long
    collect counter packets
    collect timestamp sys-uptime first
    collect timestamp sys-uptime last
    collect application name
    collect connection new-connections
    collect transport rtp payload-type
    collect transport rtp jitter mean sum
    !
    !
    flow monitor type performance-monitor reference-media_ipv6_out
    record reference-media_ipv6_out
    exporter reference-1
    cache entries 4000
    cache timeout synchronized 60 export-spread 15
    !
    !
    flow record type performance-monitor reference-url_ipv4
    description ezPM record
    match routing vrf input
    match ipv4 protocol
    match application name account-on-resolution
    match connection client ipv4 address
    match connection server ipv4 address
    match connection server transport port
    collect ipv4 dscp
    collect ipv4 ttl
    collect interface input
    collect interface output
    collect timestamp sys-uptime first
    collect timestamp sys-uptime last
    collect connection new-connections
    collect connection sum-duration
    collect application http uri statistics
    collect connection delay response to-server sum
    collect connection server counter responses
    collect connection delay response to-server histogram late
    collect connection delay network to-server sum
    collect connection delay network to-client sum
    collect connection client counter packets retransmitted
    collect connection delay network client-to-server sum
    collect connection delay application sum
    collect connection delay application max
    collect connection delay response client-to-server sum
    collect connection transaction duration sum
    collect connection transaction counter complete
    collect connection server counter bytes long
    collect connection server counter packets long
    collect connection client counter bytes long
    collect connection client counter packets long
    collect application http host
    !
    !
    flow monitor type performance-monitor reference-url_ipv4
    record reference-url_ipv4
    exporter reference-1
    cache entries 1000
    cache timeout synchronized 60 export-spread 15
    !
    !
    flow record type performance-monitor reference-url_ipv6
    description ezPM record
    match routing vrf input
    match ipv6 protocol
    match application name account-on-resolution
    match connection client ipv6 address
    match connection server transport port
    match connection server ipv6 address
    collect ipv6 dscp
    collect ipv6 hop-limit
    collect interface input
    collect interface output
    collect timestamp sys-uptime first
    collect timestamp sys-uptime last
    collect connection new-connections
    collect connection sum-duration
    collect application http uri statistics
    collect connection delay response to-server sum
    collect connection server counter responses
    collect connection delay response to-server histogram late
    collect connection delay network to-server sum
    collect connection delay network to-client sum
    collect connection client counter packets retransmitted
    collect connection delay network client-to-server sum
    collect connection delay application sum
    collect connection delay application max
    collect connection delay response client-to-server sum
    collect connection transaction duration sum
    collect connection transaction counter complete
    collect connection server counter bytes long
    collect connection server counter packets long
    collect connection client counter bytes long
    collect connection client counter packets long
    collect application http host
    !
    !
    flow monitor type performance-monitor reference-url_ipv6
    record reference-url_ipv6
    exporter reference-1
    cache entries 1000
    cache timeout synchronized 60 export-spread 15
    !
    !Policy-maps
    !============
    policy-map type performance-monitor reference-in
    parameter default account-on-resolution
    class reference-app_ts
    flow monitor reference-app_ts_in
    class reference-art_url_ipv4
    flow monitor reference-url_ipv4
    class reference-art_url_ipv6
    flow monitor reference-url_ipv6
    class reference-art_ipv4
    flow monitor reference-art_ipv4
    class reference-art_ipv6
    flow monitor reference-art_ipv6
    class reference-url_ipv4
    flow monitor reference-url_ipv4
    class reference-url_ipv6
    flow monitor reference-url_ipv6
    class reference-media_ipv4_in
    flow monitor reference-media_ipv4_in
    class reference-media_ipv6_in
    flow monitor reference-media_ipv6_in
    class reference-conv_ts_ipv4
    flow monitor reference-conv_ts_ipv4
    class reference-conv_ts_ipv6
    flow monitor reference-conv_ts_ipv6
    !
    policy-map type performance-monitor reference-out
    parameter default account-on-resolution
    class reference-app_ts
    flow monitor reference-app_ts_out
    class reference-art_url_ipv4
    flow monitor reference-url_ipv4
    class reference-art_url_ipv6
    flow monitor reference-url_ipv6
    class reference-art_ipv4
    flow monitor reference-art_ipv4
    class reference-art_ipv6
    flow monitor reference-art_ipv6
    class reference-url_ipv4
    flow monitor reference-url_ipv4
    class reference-url_ipv6
    flow monitor reference-url_ipv6
    class reference-media_ipv4_out
    flow monitor reference-media_ipv4_out
    class reference-media_ipv6_out
    flow monitor reference-media_ipv6_out
    class reference-conv_ts_ipv4
    flow monitor reference-conv_ts_ipv4
    class reference-conv_ts_ipv6
    flow monitor reference-conv_ts_ipv6
    !
    !Interface Attachments
    !======================
    interface Ethernet0/0
    service-policy type performance-monitor input reference-in
    service-policy type performance-monitor output reference-out
    !
    
    
    

    Example: Verifying the Configuration of a Conversation Level Traffic Monitor Metrics for a Performance Monitor Context

    The following example from the show running-configuration performance monitor context command that displays the conversation level traffic monitor metrics configured on the performance monitor:

    Device# show running-configuration performance monitor context conv
    
    !===============================================================================
    ! Equivalent Configuration of Context conv !
    !===============================================================================
    !Exporters
    !==========
    !
    flow exporter conv-1
    description performance monitor context conv exporter
    destination 5.4.3.2
    source Ethernet0/0
    transport udp 4739
    export-protocol ipfix
    template data timeout 300
    option c3pl-class-table timeout 300
    option c3pl-policy-table timeout 300
    option interface-table timeout 300
    option vrf-table timeout 300
    option sampler-table timeout 300
    option application-table timeout 300
    option application-attributes timeout 300
    option sub-application-table timeout 300
    !
    !Access Lists
    !=============
    ip access-list extended conv-conv_ipv4_tcp
    permit tcp any any
    !
    ipv6 access-list conv-conv_ipv6_tcp
    permit tcp any any
    !
    ip access-list extended conv-conv_ipv4_udp
    permit udp any any
    !
    ipv6 access-list conv-conv_ipv6_udp
    permit udp any any
    !
    !Class-maps
    !===========
    class-map match-any conv-conv_ts_ipv4
    match access-group name conv-conv_ipv4_tcp
    match access-group name conv-conv_ipv4_udp
    !
    class-map match-any conv-conv_ts_ipv6
    match access-group name conv-conv_ipv6_tcp
    match access-group name conv-conv_ipv6_udp
    !
    !Samplers
    !=========
    !Records and Monitors
    !=====================
    !
    flow record type performance-monitor conv-conv_ts_ipv4
    description ezPM record
    match routing vrf input
    match ipv4 protocol
    match application name account-on-resolution
    match connection client ipv4 address
    match connection server ipv4 address
    match connection server transport port
    collect ipv4 dscp
    collect ipv4 ttl
    collect interface input
    collect interface output
    collect timestamp sys-uptime first
    collect timestamp sys-uptime last
    collect connection new-connections
    collect connection sum-duration
    collect connection server counter bytes long
    collect connection server counter packets long
    collect connection client counter bytes long
    collect connection client counter packets long
    !
    !
    flow monitor type performance-monitor conv-conv_ts_ipv4
    record conv-conv_ts_ipv4
    exporter conv-1
    cache entries 6250
    cache timeout synchronized 60 export-spread 15
    !
    !
    flow record type performance-monitor conv-conv_ts_ipv6
    description ezPM record
    match routing vrf input
    match ipv6 protocol
    match application name account-on-resolution
    match connection client ipv6 address
    match connection server transport port
    match connection server ipv6 address
    collect ipv6 dscp
    collect ipv6 hop-limit
    collect interface input
    collect interface output
    collect timestamp sys-uptime first
    collect timestamp sys-uptime last
    collect connection new-connections
    collect connection sum-duration
    collect connection server counter bytes long
    collect connection server counter packets long
    collect connection client counter bytes long
    collect connection client counter packets long
    !
    !
    flow monitor type performance-monitor conv-conv_ts_ipv6
    record conv-conv_ts_ipv6
    exporter conv-1
    cache entries 6250
    cache timeout synchronized 60 export-spread 15
    !
    !Policy-maps
    !============
    policy-map type performance-monitor conv-in
    parameter default account-on-resolution
    class conv-conv_ts_ipv4
    flow monitor conv-conv_ts_ipv4
    class conv-conv_ts_ipv6
    flow monitor conv-conv_ts_ipv6
    !
    policy-map type performance-monitor conv-out
    parameter default account-on-resolution
    class conv-conv_ts_ipv4
    flow monitor conv-conv_ts_ipv4
    class conv-conv_ts_ipv6
    flow monitor conv-conv_ts_ipv6
    !
    !Interface Attachments
    !======================
    interface Ethernet0/1
    service-policy type performance-monitor input conv-in
    service-policy type performance-monitor output conv-out
    
    

    Example: Configuring a Performance Monitor Context With Application Statistics Profile

    The following example shows how to configure a performance monitor context with traffic monitor enabling per interface, application, client, and server statistics:

    Device# configure terminal
    Device(config)# performance monitor context perf-mon-test profile application-statistics
    Device(config-perf-mon)# traffic-monitor application-client-server-stats cache-size 755 cache-type synchronized ipv6
    Device(config-perf-mon)# exit
    Device(config)# interface gigabitethernet 0/1
    Device(config-if)# performance monitor context perf-mon-test
    Device(config-if)# exit

    Additional References

    Related Documents

    Related Topic

    Document Title

    Cisco IOS commands

    Cisco IOS Master Commands List, All Releases

    Cisco Application Visibility and Control User Guide

    Cisco Application Visibility and Control User Guide for Cisco IOS XE Release 3.11S and Cisco IOS Release15.4(1)T.

    Cisco Application Visibility and Control User Guide for Cisco IOS XE Release 3.12S and Cisco IOS Release15.4(2)T.

    Cisco Application Visibility and Control User Guide for Cisco IOS XE Release 3.13S and Cisco IOS Release15.4(3)T.

    Technical Assistance

    Description

    Link

    The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    Feature Information for Easy Performance Monitor

    The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

    Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

    Table 1 Feature Information for Easy Performance Monitor

    Feature Name

    Releases

    Feature Information

    Easy Performance Monitor

    Cisco IOS XE Release 3.10S

    The Easy Performance Monitor chapter describes how to configure Easy Performance Monitor (ezPM) for Application Visibility and Control (AVC).

    This feature was introduced.

    Easy Performance Monitor Phase II

    Cisco IOS XE Release 3.12S

    The following command was modified: traffic monitor

    The sampler keyword was added.

    Adaptive AVC Reporting

    Cisco IOS XE Release 3.13S

    The support for Application Statistics profile was added.

    The following command was modified: performance monitor

    The application-statistics keyword was added.