Guest

Cisco Unity Express

Cisco CME Basic Automatic Call Distribution and Cisco Unity Express Auto Attendant Interoperation Configuration Example

Document ID: 67907

Updated: May 04, 2007

   Print

Introduction

This document provides configuration examples for using the Cisco CallManager Express (CME) basic automatic call distribution (ACD) and Cisco Unity Express Auto Attendant (AA) features.

Prerequisites

Requirements

General familiarity with Cisco CME and Cisco Unity Express configurations is required. This document focuses specifically on the Cisco CME Basic ACD and Cisco Unity Express AA interoperation configurations.

The following are the minimum releases for the functionality described in this configuration example:

  • Cisco CME 3.3

  • Cisco IOS® Software Release 12.4.3

  • Cisco Unity Express 2.1.3

Components Used

The information in this document is based on these software and hardware versions:

  • A Cisco 2821 router running Cisco CME and Cisco Unity Express

  • Cisco IOS Software Release 12.4.3

  • Cisco CME 3.3

  • Basic ACD script version 2.1.0.0

  • Cisco Unity Express 2.1.3

  • IP Voice Cisco IOS feature set

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Related Products

This configuration can also be used with Cisco 2600XM, Cisco 3700, Cisco 2800, or Cisco 3800 series routers with Cisco IOS Software Release 12.4.1 or later.

Conventions

Refer to the Cisco Technical Tips Conventions for more information on document conventions.

Background Information

These three scenarios are addressed in this document:

  • Scenario 1--Using the Cisco CME AA and ACD groups with Cisco Unity Express only as a voice mail destination

  • Scenario 2--Using the Cisco Unity Express as the main AA entry point and Cisco CME AA as a “sub-menu” within that AA

  • Scenario 3--Using the Cisco CME AA as the main AA entry point and the Cisco Unity Express AA to provide flexible “announcements” as part of the AA

Scenario 1 is most applicable when your Cisco CME AA is limited to providing a menu to direct calls into ACD groups. In this scenario, Cisco CME is used as the AA destination for incoming calls, and Cisco Unity Express is used exclusively as a voice mail server when the ACD agents are not available or do not answer the calls in a certain amount of time. The Cisco Unity Express AA is not used in this scenario.

Scenario 2 is the most flexible overall configuration for integrating Cisco CME basic ACD and Cisco Unity Express AA. The design used in Scenario 2 features Cisco Unity Express AA for general call-handling automation and for handing off calls to ACD agents. In this scenario, Cisco Unity Express is used as the AA destination for incoming calls; Cisco Unity Express also provides a variety of menu choices to the caller (such as dial-by-name, dial-by-extension, and recorded information segments). One of these choices directs some calls to the Cisco CME ACD groups. Cisco Unity Express voice mail is used in a similar manner as Scenario 1.

Scenario 3 is a variation of Scenario 1 in which the Cisco CME AA is used as the AA destination for incoming calls and the ACD is the main function required of the AA. However, Cisco Unity Express AA is used as an “announcement server” with the Cisco CME AA. This provides the ability to add some announcements (such as office hours or location) that are not available using only the Cisco CME AA.

Note: The GUI-based configuration procedures provided in this publication are used to illustrate the implementation processes associated with this configuration example and to summarize the steps needed to implement features described throughout the document. However, complete step-by-step procedures are not provided. This publication assumes that you have a working familiarity with the Cisco CME and Cisco Unity Express GUIs, as well as a working knowledge of the Cisco IOS CLI. Please refer to the appropriate Cisco CME and Cisco Unity Express administrator’s guide, configuration guide, and command reference for explicit details for procedures and command usage.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) to obtain more information on the commands used in this section.

Network Diagram

This document uses this network setup:

Figure 1 Network Diagram for Cisco CME Basic ACD and Cisco Unity Express AA

135345.jpg

Configurations

All three configuration scenarios have these general characteristics:

  • Single-site Cisco CME system

  • PSTN trunks integrated on the Cisco CME router

  • The configuration defines a 4-digit dialing plan with IP phone extensions in the 2000 to 2010 range, non-phone extensions (such as hunt groups) in the 2020 to 2099 range, and Cisco Unity Express entry points in the 21 xx range.

  • Nine IP phones are defined, extensions 2000 to 2009.

  • The ACD setup uses three hunt groups with three IP phones in each group.

  • Two receptionists are defined, which are also part of the nine IP phones in the ACD groups.

The network configuration uses a Cisco 2821 router with these characteristics:

  • IP network access via IP address b .168.1.1

  • Cisco CME configuration with nine IP phones--each with a 4-digit extension (2001 to 2010)

  • NM-CUE

  • Cisco Unity Express IP address a .1.11.2

This document uses these configurations:

General Implementation Configuration Notes

The PSTN connectivity used in this configuration is via a foreign exchange office (FXO) trunk. If you have a PRI trunk, the configurations look exactly the same as those given in the configuration examples presented in this publication, with the addition of these configuration entries:

controller T1 2/1
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
interface Serial2/1:23
 no ip address
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
voice-port 2/1:23
!
dial-peer voice 777 pots
 incoming called-number .
 direct-inward-dial
 port 2/1:23

The Cisco Unity Express AA scripts that are used in the examples presented in this publication are very simple and for clarity contain the minimum number of features to achieve the functionality illustrated by this document. Cisco Unity Express AA scripts deployed in a live network should have significantly more incoming-call handling capability compared to lab test networks. Additional call-handling “steps” can include the following:

  • Improved error handling (such as when the caller presses digits that are not on the menu)

  • Timeout handling (such as repeating menus a fixed number of times)

  • Ability to block the external transfer of calls to external PSTN destinations (to circumvent toll fraud).

Scenario 1 - Using Cisco CME Basic ACD with Cisco Unity Express Voice Mail

In Scenario 1, incoming calls are directed to the Cisco CME AA (extension 2040), which provides a welcome greeting and a menu with three options to the caller. Based on the caller’s choice, the call is directed to one of three ACD hunt groups. If the calls are not answered in the ACD group, calls are forwarded to a General Delivery Mailbox (GDM) to leave a message.

Note: You cannot set up a GDM to be copied to each user's mailbox (similar to a distribution list).

In this scenario described in this section, a single GDM is used so that all nine ACD agents in the ACD groups can log in to and retrieve messages. In other variations described as part of Scenario 2, the ability to have an individual GDM per ACD group is explored.

Call Flow

The call flow of the configuration in this section is illustrated in Figure 2.

Figure 2 Cisco Unity Express AA with Cisco CME Basic ACD Scenario 1 Call Flow

135346.jpg

Scenario 1 Configuration Notes

PSTN calls from the FXO port (0/3/0) are autoterminated (via the connection plar-opx 2040 command) to the Cisco CME AA pilot number (2040). The Cisco CME AA presents a welcome greeting and a welcome menu with three options--the spoken contents of the prompts are given in the call-flow picture in Figure 2 . The recorded welcome phrase resides in the flash file en_bacd_welcome.au, while the recorded menu phrases reside in the file en_bacd_options_menu.au.

The GDM greeting for extension 2070 is as follows: “Thank you for calling customer service; no one is available right now. Please leave a message and we will return your call as soon as we can.”

A Message Waiting Indication (MWI) for messages in the GDM is achieved by forwarding the Cisco CME AA (the param voice-mail 2070 command) to an intermediate extension (2070) which is CFA (call forward all) to the voice mail pilot (2105). This forwarding is done instead of pointing the Cisco CME AA directly to the voice mail pilot--which would be done with the param voice-mail 2105 command. Extension 2070 is button 2 on the agent phones, and this button indicates MWI for the GDM, which is associated with extension 2070--rather than with the ACD hunt-group numbers (2020, 2021 or 2022). “Final” numbers are not configured on the hunt-groups because the ACD logic bypasses final numbers in favor of the AA forwarding number (param voice-mail command).

Note: Any time that you make any change to the script, you need to load the application.

The Cisco CME AA script is associated with a loopback IP address (a .1.1.1) to ensure the Tool Command Language (TCL) script is always up--regardless of the state of the LAN interfaces (dial-peer voice 2040 voip command). A back-to-back dial peer is used to direct calls to the Cisco CME AA entry point (2040) to ensure that PSTN callers (as well as local IP phones) can call the AA (dial-peer voice 2041 voip command).

Configure Cisco CME for Scenario 1

These steps summarize the configuration for Cisco CME for Scenario 1:

  1. Choose Configure > System Parameters to configure three ACD hunt-groups 2020, 2021, and 2022 that are associated with three menu options of the Cisco CME AA. See Figure 3 .

    Figure 3 Specify Cisco Unity Express ACD Hunt Groups

    135352.jpg

  2. Choose Configure > System Parameters to configure the details for hunt-group 2020 with agents 2001, 2002, and 2003. See Figure 4 .

    Figure 4 Configure Details for Hunt Group 2020

    135353.jpg

  3. Choose Configure > Phones and click the MAC address of the phone that you want to change. The Change Phone window appears (see Figure 5).

  4. Enter extension 2070 on the ACD agent’s phone to get MWI for messages in the GDM.

    Figure 5 Associate Extension to Specific Button

    135354.jpg

The following is the complete (and annotated) Cisco CME router CLI configuration for Scenario 1 that results from the specific changes to the base configuration.

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!

!--- Define the parameters for the Cisco CME ACD TCL script. 
!--- The hunt groups for the
!--- ACD are 2020, 2021, and 2022.

!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2022
  param queue-len 30
 !

!--- Define the parameters for the Cisco CME AA TCL script. 
!--- The pilot number is 2040.
!--- The voice-mail destination is extension 2070, which is call forward all
!--- (CFA) routed to voice mail (2105).

!
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!

!--- Define the loopback address to which the TCL script is attached.

!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!

!--- PSTN calls are auto-terminated on the Cisco CME AA pilot number 2040.

!
voice-port 0/3/0
 connection plar opx 2040
!
voice-port 0/3/1
 connection plar opx 2040
!
voice-port 0/3/2
!
voice-port 0/3/3
!

!--- Calls to Cisco CME AA pilot number 2040 are associated with a loopback address
!--- a.1.11.1 to ensure that the TCL script is always up.

!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!

!--- The back-to-back dial-peer for Cisco CME AA 
!--- pilot number 2040 points to the
!--- AA TCL script and ensures that all PSTN and 
!--- internal callers can reach the AA.

!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!

!--- All calls in the 21xx range are directed to Cisco Unity Express.

!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!

!--- The following section shows nine ACD agents' extensions.

!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  7  dual-line
 number 2007
 name User27
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  8  dual-line
 number 2008
 name User28
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  9  dual-line
 number 2009
 name User29
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!

!--- Extension 2070 is associated with the GDM. 
!--- This extension is used to get MWI
!--- on the ACD agents' phone.

!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!

!--- The following section shows phone definitions for the nine ACD agents.
!--- Ephone-dn 11 (2070) is defined as button 2 on each phone, so that all
!--- agents can get MWI for the GDM.

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:11
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:11
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:11
!

!--- Three hunt-groups are used by the ACD scripts. 
!--- There are three agents in each group.

!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
ephone-hunt 3 longest-idle
 pilot 2022
 list 2007, 2008, 2009
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

Configure Cisco Unity Express for Scenario 1

These steps summarize the configuration for Cisco Unity Express for Scenario 1:

  1. Choose Configure > Groups. Then click the group (custservice) that you want to edit. The Group Profile window appears (see Figure 6 ).

  2. The Profile tab is the default display. Configure the custservice group associated with extension 2070.

    Figure 6 Configure Group Profile

    142424.jpg

  3. Click the Owners/Members tab (see Figure 7 ).

  4. Configure the members (all nine ACD agent users) of the custservice group.

    Figure 7 Configure Group Members

    135356.jpg

The following is the complete (and annotated) Cisco Unity Express CLI configuration for Scenario 1 that results from the specific changes to the base configuration:

cue#show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1
groupname Administrators create
groupname Broadcasters create
!

!--- The custservice group is defined as all the 
!---users that have access to the GDM.

!
groupname custservice create
!

!--- Nine ACD agents are defined as users.

!
username admin create
username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
username user27 create
username user28 create
username user29 create
!

!--- The custservice group (and therefore GDM) 
!--- is associated with extension 2070.

!
groupname custservice phonenumber "2070"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
username user27 phonenumber "2007"
username user28 phonenumber "2008"
username user29 phonenumber "2009"
groupname Administrators member admin
!

!--- Nine ACD agents users are members of the 
!--- custservice group, so they can have
!--- access to the GDM to retrieve messages.

!
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname custservice member user27
groupname custservice member user28
groupname custservice member user29
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
!

!--- The Cisco Unity Express system AA is defined 
!--- in the system by default, but
!--- is not used in this scenario.

!
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "false"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
!

!--- Define the GDM associated with 2070, 
!--- associated with the custservice group.

!
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
!

!--- Define personal mailboxes for nine ACD agents.

!
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000
description "user26 mailbox"
end mailbox
voicemail mailbox owner "user27" size 3000
description "user27 mailbox"
end mailbox
voicemail mailbox owner "user28" size 3000
description "user28 mailbox"
end mailbox
voicemail mailbox owner "user29" size 3000
description "user29 mailbox"
end mailbox
end

Scenario 2 - Use Cisco Unity Express AA as the First-Tier Menu and Basic ACD as the Second Tier Menu

In Scenario 2, incoming calls are directed to the Cisco Unity Express custom AA (pilot number 2100), which provides a welcome greeting and a menu with four options to the caller. Based on the caller’s choice, the call is directed to the Cisco CME ACD (option 1), one of two announcements (options 2 and 3), or to a general business mailbox (GDM for extension 2080) associated with the receptionists (option 4).

If the caller chooses option 1, the call is handed off to the Cisco CME ACD where the Cisco CME AA provides a second tier menu, which is similar to Scenario 1.

Scenario 2 Call Flow

The call flow of the configuration in this section is illustrated in Figure 8.

Figure 8 Call Flow for Scenario 2

135360.jpg

Scenario 2 Configuration Notes

PSTN calls from the FXO port (0/3/0) are autoterminated to the Cisco Unity Express AA (2100).

The first-tier menu (“Thank you for calling Widget Systems; press 1 for customer service; press 2 for office location; press 3 for office hours; press 4 to leave a voice message.”) is provided by the Cisco Unity Express custom AA (file S10_Main_Menu.wav).

The second-tier menu (“To help redirect your call: Press 1 for hardware-related questions; press 2 for software-related questions; press 3 for general questions.”) is provided by the Cisco CME AA prompt files. The first phrase (“To help redirect your call”) is contained in flash file en_bacd_welcome.au, while the remainder of the instructions are unchanged from the Scenario 1 configuration and contained in flash file en_bacd_options_menu.au.

You can bypass the Cisco CME welcome greeting altogether by recording a small empty file or by deleting the file from your router’s flash (which causes the Cisco CME software to bypass the greeting). In the Scenario 2 example depicted in this section, the menu phrases associated with the Cisco Unity Express and Cisco CME prompt files have been structured to flow as a single AA to the caller. You can also bypass the Cisco CME AA altogether (the welcome greeting and option choices) by using the param drop-through-option number command to transfer a call directly into the Cisco CME ACD while bypassing the Cisco CME AA.

Extension 2080 and the associated GDM are added to the configuration to provide a general mailbox for the receptionists. This mailbox is entered by choosing option 4 from the first-tier menu and is handled entirely within Cisco Unity Express. Extension 2080 has been added to IP phones 2001 and 2004--the phones associated with two employees who are receptionists (as well as ACD agents).

If a caller chooses 1 from the first-tier menu and is directed to the ACD groups, but the call remains unanswered, the call is forwarded to extension 2070--which is the GDM for the ACD agents.

Configure Cisco CME for Scenario 2

These steps summarize the configuration for Cisco CME for Scenario 2:

  1. Choose Configure > Phones. Then click the MAC address of the phone that you want to change. The Change Phone window appears (see Figure 9 ).

  2. Enter extension 2080 to button 3 of the receptionist’s phone, while the ACD GDM remains on button 2. With this setup, the employee gets MWI for both the receptionist and the ACD GDM mailboxes.

    Figure 9 Add Extension Button to Receptionist’s Phone

    135361.jpg

The following is the complete (and annotated) Cisco CME router’s CLI configuration for Scenario 2 that results from the specific changes to the base configuration.

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2022
  param queue-len 30
 !
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!

!--- PSTN calls are auto-terminated on the Cisco CUE AA pilot number 2100.

!
voice-port 0/3/0
 connection plar opx 2100
!
voice-port 0/3/1
 connection plar opx 2100
!
voice-port 0/3/2
!
voice-port 0/3/3
!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  7  dual-line
 number 2007
 name User27
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  8  dual-line
 number 2008
 name User28
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  9  dual-line
 number 2009
 name User29
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!

!--- Extension 2080 is associated with the receptionists' GDM. 
!--- This extension is used to get MWI on the receptionists' phones.

!
ephone-dn  10
 number 2080
 description Reception GDM
 name Reception GDM
 call-forward all 2105
!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!

!--- Ephone-dn 10 (2080) is defined as button 3 on 
!--- phones 2001 and 2004 so that all
!--- receptionists (ephones 1 and 4) get MWI for the GDM.

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11 3:10
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11 3:10
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:11
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:11
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:11
!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
ephone-hunt 3 longest-idle
 pilot 2022
 list 2007, 2008, 2009
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

Configure Cisco Unity Express for Scenario 2

These steps summarize the configuration for Cisco Unity Express for Scenario 2:

  1. Open the Cisco Unity Express Script Editor utility and create the custom Cisco Unity Express script. See Figure 10.

    Figure 10 Configure the Cisco Unity Express AA Script for the Top Tier Menu

    135362.jpg

  2. Choose Voice Mail > Auto Attendant and associate the script (S10_CUE-AA-BACD-script.aef) with pilot number 2100. See Figure 11.

    Figure 11 Associate the Script with a Pilot Number

    135363.jpg

  3. Record all the prompts for the AA script. You can either record this offline and upload the .wav files to Cisco Unity Express with the correct file name, or you can record it through the Administration via Telephony (AVT).

  4. (Optional) If you use the AVT, Cisco Unity Express assigns a generic file name that you can subsequently change to the desired file name. Choose Voice Mail > Prompts and click the system file name.

  5. (Optional) Edit the file name(s) as needed in the dialog box and click Ok. The Voice Mail > Prompts window now shows the corrected file name(s) in the list (see Figure 12 ).

    Figure 12 List of AA Script Prompts

    135364.jpg

  6. Choose Voice Mail > Auto Attendant and open the AA built in Step 1. Choose Script Parameters and associate the prompt file names with the correct parameter in the script.

  7. Choose Configure > Groups and click the group ( reception ) that you want to edit. The Group Profile window appears (see partial window at top of Figure 13 ). The Profile tab is the default display.

  8. Click the Owners/Members tab to configure members.

    Figure 13 Define the Reception Group

    142217.jpg

The following is the complete (and annotated) Cisco Unity Express CLI configuration for Scenario 2 that results from the specific changes to the base configuration.

cue#show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1

!--- Add the reception group.

!
groupname Administrators create
groupname Broadcasters create
groupname custservice create
groupname reception create
username admin create

username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
username user27 create
username user28 create
username user29 create
!

!--- The reception group (and therefore GDM) is associated with extension 2080.

!
groupname custservice phonenumber "2070"
groupname reception phonenumber "2080"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
username user27 phonenumber "2007"
username user28 phonenumber "2008"
username user29 phonenumber "2009"
!

!--- Add membership to group "reception".

!
groupname Administrators member admin
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname custservice member user27
groupname custservice member user28
groupname custservice member user29
groupname reception member user21
groupname reception member user24
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast

!--- Define a 09:00-17:00 Monday-Friday business schedule for the AA.

!
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "true"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
!

!--- Add the custom AA script for the first-tier menu.

!
ccn application s10-cue-aa-bacd
 description "s10-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s10-cue-aa-bacd-script.aef"
 parameter "S10_StoreHours" "S10_StoreHours.wav"
 parameter "S10_CustomerService" "2040"
 parameter "S10_GDM" "2080"
 parameter "S10_StoreLocation" "S10_StoreLocation.wav"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
!

!--- Associate the custom AA script with the pilot number 2100.

!
ccn trigger sip phonenumber 2100
 application "s10-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
!

!--- Add the GDM for "reception"

!
voicemail mailbox owner "reception" size 3000
 description "Receptionists mailbox"
 end mailbox
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000
description "user26 mailbox"
end mailbox
voicemail mailbox owner "user27" size 3000
description "user27 mailbox"
end mailbox
voicemail mailbox owner "user28" size 3000
description "user28 mailbox"
end mailbox
voicemail mailbox owner "user29" size 3000
description "user29 mailbox"
end mailbox
end

Scenario 2 Configuration Variation 1 - Individual GDMs per Hunt Group

The configuration for the main scenario described in the previous sections defines a single GDM for all messages left by callers into the three ACD groups (hardware support, software support and general questions). This granularity might not be sufficient for some situations because the agents for one group (such as software support) might not want to wade through the messages left for the hardware and general support groups before finding messages regarding software support. If the volume of messages is high, you can have a separate mailbox for each ACD group.

With normal Cisco CME hunt-groups (when not using the ACD), you can define a separate mailbox for each hunt group by associating individual GDMs with the hunt-group numbers (2020, 2021, 2022) and pointing the “final” destination of the hunt-group to voice mail--as illustrated in the following configuration examples.

Configure Cisco CME for Scenario 2 Variation 1

The following are Cisco CME configuration variations for individual GDMs:

ephone-hunt 1 sequential
 pilot 2020
 list 2001, 2002, 2003
 final 2105
 timeout 10
!
!
ephone-hunt 2 sequential
 pilot 2021
 list 2004, 2005, 2006
 final 2105
 timeout 10
!
!
ephone-hunt 3 sequential
 pilot 2022
 list 2007, 2008, 2009
 final 2105
 timeout 10

Configure Cisco Unity Express for Scenario 2 Variation 1

These steps summarize the configuration of the groups and GDMs on Cisco Unity Express for Scenario 2 Variation 1:

  1. Individual groups are defined in Cisco Unity Express for each of the three hunt-groups. Choose Configure > Groups to define groups. See Figure 14.

    Figure 14 Define Individual Groups

    135357.jpg

  2. From Configure > Groups, click the group (hardware) you want to edit. The default Profile tab window appears (see top of Figure 15 ).

    Figure 15 Configure Specific Groups

    135358.jpg

  3. Choose the Owners/Members tab (see bottom of Figure 15 ) and click the check box at left to select owners and members.

    The following are Cisco Unity Express configuration variations for individual GDMs:

    groupname hardware create
    groupname software create
    groupname general create
    groupname hardware phonenumber "2020"
    groupname software phonenumber "2021"
    groupname general phonenumber "2022"
    groupname hardware member user21
    groupname hardware member user22
    groupname hardware member user23
    groupname software member user24
    groupname software member user25
    groupname software member user26
    groupname general member user27
    groupname general member user28
    groupname general member user29
    voicemail mailbox owner "general" size 5520
     description "general mailbox"
     end mailbox
    voicemail mailbox owner "hardware" size 5520
     description "Hardware mailbox"
     end mailbox
    voicemail mailbox owner "software" size 5520
     description "software mailbox"
     end mailbox

Scenario 2 Configuration Variation 2 - Individual GDMs per ACD Group

There are two drawbacks to the configuration summarized in the “Scenario 2 Configuration Variation 1--Individual GDMs per Hunt group” section.

  • It works only if the hunt-groups are called directly (extensions 2020, 2021 and 2022), and does not work when the hunt-groups are used as an ACD when the ACD pilot number (2040) is called

  • It does not provide any means of providing MWI for the agents because hunt-group numbers cannot be put on phones as buttons.

To provide a configuration that solves these two drawbacks, you can use the xfermailbox system script in Cisco Unity Express. Define three groups in Cisco Unity Express (one each for hardware, software, and general), and associate each group with an interim extension (such as 2030, 2031, and 2032) which can be placed as buttons appearing on an agent phone (and as a result provide MWI). This configuration of the groups, extensions, and phones is summarized in Table 2.

Agent Extension Hunt-Group Number ACD Group Group Mailbox
user21 2001 2020 Hardware 2030
user22 2002 2020 Hardware 2030
user23 2003 2020 Hardware 2030
user24 2004 2021 Software 2031
user25 2005 2021 Software 2031
user26 2006 2021 Software 2031
user27 2007 2022 General 2032
user28 2008 2022 General 2032
user29 2009 2022 General 2032

The adjusted call flow for this modified setup is illustrated in Figure 16.

Figure 16 Adjusted Call Flow for xfermailbox Script Variation

135359.jpg

Directing calls into individual GDMs in Cisco Unity Express requires a custom script that calls the xfermailbox system script. Calls to the Cisco CME ACD can only be forwarded to Cisco Unity Express by using the single param voice-mail number command (the individual final destinations on the hunt-groups cannot be used for ACD call flows). This command delivers a single extension to Cisco Unity Express for entry into a mailbox (extension 2070 in preceding configurations). Cisco Unity Express has no way to distinguish which hunt-group is the intended recipient and cannot determine which of the three GDMs to enter.

Instead, direct the Cisco CME ACD voice-mail destination to a Cisco Unity Express pilot number (2110) that enters a custom script ( s12-xfer-to-mbox.aef ). This pilot number provides a menu to the user offering a choice of the groups for which a message can be left (hardware, software, or general). The content of this menu is shown at the bottom of the call flow in Figure 16 . Based on the caller’s response, the mbox variable is set to the appropriate extension (2030, 2031, or 2032), and the call is handed off (via the xfermailbox system script) to one of the three GDMs.

The steps associated with modifying the Scenario 2 configuration to handle the configuration changes outlined in Table 2 and Figure 16 are described in the following steps:

  1. Open the Cisco Unity Express Script Editor utility and write a custom Cisco Unity Express script called s12-xfer-to-mbox.aef. See Figure 17.

    Figure 17 Custom Cisco Unity Express Script Creation Window

    135347.jpg

  2. Choose Voice Mail > Auto Attendant. See Figure 18. Add a new Auto-Attendant and associate it with the script built in step 1.

  3. Associate the custom s12-xfer-to-mbox.aef Cisco Unity Express script with pilot number 2110. See Figure 18.

    Figure 18 Associate the Custom Cisco Unity Express Script with a Pilot Number

    135348.jpg

  4. Record the prompt (in this case named S12_Main_Menu.wav) for the new AA script. You can either record this offline and upload the .wav file to Cisco Unity Express with the correct file name, or you can record it through the Administration via Telephony (AVT).

  5. (Optional) If you use the AVT, Cisco Unity Express assigns a generic file name that you can subsequently change to the desired file name. Choose Voice Mail > Prompts and click the system file name.

  6. (Optional) Edit the file name in the dialog box as needed and click OK. The Voice Mail > Prompts window now shows the corrected file name in the list (see Figure 19 ).

  7. Choose Voice Mail > Auto Attendant and open the AA built during step 2. Choose Script Parameters and associate the prompt file name with the correct parameter in the script.

    Figure 19 List of Recorded Prompts

    135349.jpg

  8. Choose Configure > Extension to define extensions 2030, 2031, and 2032 to associate the GDMs with each of these extensions. See Figure 20.

    Figure 20 Define Extensions to Associate the GDMs with ACD Hunt-Groups

    135350.jpg

  9. Choose Configure > Phones and click the MAC address of the phone that you want to change. The Change Phone window appears (see Figure 21 ).

  10. Add buttons for 2030, 2031, or 2032 on the ACD agent phones to provide MWI.

    Figure 21 Window Illustrating Adding Buttons

    135351.jpg

The following is the annotated Cisco CME router CLI configuration for changes and additions in the Cisco CME configuration to the base scenario configuration associated with the “Configuring Cisco CME for Scenario 2” section.


!--- Set the Cisco CME AA voice mail destination 
!--- to 2110, the Cisco Unity Express
!--- script entrypoint for the transfer-to-mailbox functionality.

!
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2110
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!

!--- Define the group extensions (2030, 2031 and 2032) to 
!--- be used as button appearances
!--- on the agent phones so they can get MWI for the GDMs. 
!--- Put these extension in CFA
!--- so they never ring and do not disturb the agents.

!
ephone-dn  12
 number 2030
 description HW Cust Svc Mbox
 name HW Cust Svc Mbox
 call-forward all 2110
!
ephone-dn  13
 number 2031
 description SW Cust Svc Mbox
 name SW Cust Svc Mbox
 call-forward all 2110
!
ephone-dn  14
 number 2032
 description Gen Cust Svc Mbox
 name Gen Cust Svc Mbox
 call-forward all 2110
!

!--- Add a button appearance of the appropriate 
!--- group extension to each of the
!--- ACD Agent phones.

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:12 3:10
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:12
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:12
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:13 3:10
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:13
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:13
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:14
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:14
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:14

The following is the annotated Cisco Unity Express CLI configuration for changes and additions in the configuration to the base scenario configuration associated with the “Configuring Cisco Unity Express for Scenario 2” section and the preceding GUI changes:


!--- Define the three new groups, Hardware, Software and General.

!
groupname hardware create
groupname software create
groupname general create
!

!--- Define the new groups (and therefore GDMs) are associated with 
!--- extensions 2030, 2031 and 2032.

!
groupname hardware phonenumber "2030"
groupname software phonenumber "2031"
groupname general phonenumber "2032"
!

!--- Define the membership of  the Hardware, Software and General groups.

!
groupname hardware member user21
groupname hardware member user22
groupname hardware member user23
groupname software member user24
groupname software member user25
groupname software member user26
groupname general member user27
groupname general member user28
groupname general member user29
!

!--- Define the custom AA script that will branch 
!--- to the xfermailbox.aef system script
!--- when the caller selects the correct GDM from the menu.

!
ccn application s12-xfer-to-mbox
 description "s12-xfer-to-mbox"
 enabled
 maxsessions 8
 script "s12_cue-aa-bacd-script.aef"
 end application
!

!--- Define the pilot number 2110 to the custom script.

!
ccn trigger sip phonenumber 2110
 application "s12-xfer-to-mbox"
 enabled
 maxsessions 8
 end trigger
!

!--- Define the GDMs for each of the groups.

!
voicemail mailbox owner "hardware" size 3000
 description "hardware mailbox"
 end mailbox
voicemail mailbox owner "software" size 3000
 description "software mailbox"
 end mailbox
voicemail mailbox owner "general" size 3000
 description "general mailbox"
 end mailbox

Scenario 2 Configuration Variation 3 - Use the Drop Through CD Functionality

The drop through feature of the Cisco CME ACD can be used to bypass the Cisco CME AA menu and transfer a call directly into the ACD. With this feature, the entire AA menu can be consolidated in the Cisco Unity Express AA script. While using this feature requires additional configuration on the Cisco CME router, it simplifies maintenance of the AA script (menus) compared to splitting the menus and announcement recordings between the Cisco Unity Express AA (tier 1 menu) and the Cisco CME AA (tier 2 menu).

In the Scenario 2 Variation 3 configuration, both tiers of the AA menu are contained in the Cisco Unity Express AA script as follows:

  • Thank you for calling Widget Systems

    • Press 1 for Customer Service

      • Press 1 for Hardware related questions

      • Press 2 for Software related questions

      • Press 3 for General questions

    • Press 2 for Office location

    • Press 3 for Office hours

    • Press 4 to Leave a Voice Message

The tier 2 menu choices result in calls being handed off from Cisco Unity Express to an individual Cisco CME ACD pilot number for each of these groups:

  • Hardware—Cisco CME ACD pilot number 2040

  • Software—Cisco CME ACD pilot number 2041

  • General—Cisco CME ACD pilot number 2042

The configurations previously presented in this document defined a single ACD pilot number (2040). In this configuration variation, three different Cisco CME ACD pilot numbers are defined (2040, 2041, and 2042). This variation illustrates how you can enable the drop through functionality. Using the drop through feature bypasses the Cisco CME AA menu and specifies a particular option to follow (specified in the corresponding CLI command). The system acts as if the caller pressed the option specified statically in the CLI. In this scenario, Cisco CME AA configuration includes the following adaptations:

  • Configuration for ACD pilot number 2040 includes the param drop-through-option 1 command

  • Configuration for ACD pilot number 2041 includes the param drop-through-option 2 command

  • Configuration for ACD pilot number 2042 includes the param drop-through-option 3 command

Configure Cisco CME for Scenario 2 Variation 3

These steps summarize the configuration for Cisco CME for Scenario 2 Variation 3:

  1. Add the additional Cisco CME AA and ACD TCL configuration for pilot numbers 2040, 2041 and 2042, using the "drop-through" CLI.

  2. Add the dial-peers to enable dialing the new pilot numbers 2040, 204,1 and 2042.

    The following is the annotated Cisco CME router CLI configuration for the changes and additions to the Cisco CME configuration of the base scenario associated with the “Configuring Cisco CME for Scenario 2” section.

    application
     service acd flash:app-b-acd-2.1.0.0.tcl
      param queue-cme-debugs 1
      param aa-hunt1 2020
      param aa-hunt2 2021
      param number-of-hunt-grps 3
      param aa-hunt3 2022
      param queue-len 30
    !
    
    !--- Define the TCL configuration for the Hardware group, using pilot number 2040 
    !--- and "drop-through-option 1". Extension 2030 is associated with the GDM for
    !--- the Hardware group, so this is the voice mail destination.
    
    !
     service hardware-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param max-time-vm-retry 1
      paramspace english index 0
      param max-time-call-retry 60
      param voice-mail 2030
      param aa-pilot 2040
      param number-of-hunt-grps 1
      paramspace english language en
      param handoff-string hardware-aa
      param call-retry-timer 20
      paramspace english location flash:
      param service-name acd
      param drop-through-option 1
      param second-greeting-time 30
      paramspace english prefix en
    !
    
    !--- Define the TCL configuration for the Software group, 
    !--- using pilot number 2041 
    !--- and "drop-through-option 2". Extension 2031 is associated with the GDM for
    !--- the Software group, so this is the voice mail destination.
    
    !
     service software-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param number-of-hunt-grps 1
      paramspace english index 0
      param handoff-string software-aa
      paramspace english language en
      param call-retry-timer 20
      param service-name acd
      paramspace english location flash:
      param drop-through-option 2
      param second-greeting-time 30
      param max-time-vm-retry 1
      param voice-mail 2031
      paramspace english prefix en
      param max-time-call-retry 60
      param aa-pilot 2041
    !
    
    !--- Define the TCL configuration for the General group, using pilot number 2042 
    !--- and "drop-through-option 3". Extension 2032 is associated with the GDM for
    !--- the General group, so this is the voice mail destination.
    
    !
     service general-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param call-retry-timer 20
      paramspace english index 0
      param max-time-call-retry 60
      param voice-mail 2032
      param service-name acd
      param number-of-hunt-grps 1
      param drop-through-option 3
      paramspace english language en
      param handoff-string general-aa
      param max-time-vm-retry 1
      paramspace english location flash:
      param aa-pilot 2042
      param second-greeting-time 30
      paramspace english prefix en
    !
    
    !--- Define the dial-peers for pilot number 2040 and attach the Hardware
    !--- TCL script to this number.
    
    !
    dial-peer voice 2040 voip
     destination-pattern 2040
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20400 voip
     service hardware-aa
     incoming called-number 2040
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    
    !--- Define the dial-peers for pilot number 2041 and attach the Software
    !--- TCL script to this number.
    
    !
    dial-peer voice 2041 voip
     destination-pattern 2041
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20410 voip
     service software-aa
     incoming called-number 2041
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    �
    
    !--- Define the dial-peers for pilot number 2042 and attach the General
    !--- TCL script to this number.
    
    !
    dial-peer voice 2042 voip
     destination-pattern 2042
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20420 voip
     service general-aa
     incoming called-number 2042
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad

Configure Cisco Unity Express for Scenario 2 Variation 3

These steps summarize the configuration for Cisco Unity Express for Scenario 2 Variation 3:

  1. Open the Cisco Unity Express Script Editor utility and adjust script s10-cue-aa-bacd.aef to contain both tiers of the AA menu. See Figure 22.

    Figure 22 Configure the Cisco Unity Express AA Script for both Menu Tiers

    142220.jpg

  2. Choose Voice Mail > Auto Attendant and associate the new script (S10A_CUE-AA-BACD-script.aef) with pilot number 2100. See Figure 23.

    Figure 23 Associate the Script with a Pilot Number

    142221.jpg

  3. Record all the prompts required for the AA script. You can either record these offline and upload the .wav files to Cisco Unity Express with the correct file names, or you can record it through the Administration via Telephony (AVT).

  4. (Optional) If you use the AVT, Cisco Unity Express assigns a generic file names that you can subsequently change to the desired file name. Choose Voice Mail > Prompts and click the system file name.

  5. (Optional) Edit the file name(s) in the dialog box as needed and click OK. The Voice Mail > Prompts window now shows the corrected file name in the list.

The following is the annotated Cisco Unity Express CLI configuration for the changes and additions to the Cisco Unity Express configuration of the base scenario configuration associated with the Configuring Cisco Unity Express for Scenario 2 section.


!--- Define a new AA with script s10a-cue-aa-bacd.aef.

!
ccn application s10a-cue-aa-bacd
 description "s10a-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s10a_cue-aa-bacd-script.aef"
 parameter "S10_Hardware" "2040"
 parameter "S10_StoreHours" "S10_StoreHours.wav"
 parameter "S10_Software" "2041"
 parameter "S10_General" "2042"
 parameter "S10_GDM" "2080"
 parameter "S10_StoreLocation" "S10_StoreLocation.wav"
 end application
!

!--- Associate AA pilot number 2100 with the new script.

!
ccn trigger sip phonenumber 2100
 application "s10a-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger

Scenario 3 - Use Basic ACD as the First-Tier Menu and Cisco Unity Express AA as the Second Tier Menu

In the third scenario presented in this document, incoming calls are directed to the Cisco CME AA (pilot number 2040) exactly as in Scenario 1. The only difference is that there are only two ACD groups (hardware and software), while the third option from the Main Menu is to access an announcement that describes the store’s location and hours of operation.

Note: It is not possible to include free-form announcements with the Cisco CME AA. A Cisco Unity Express custom script is required instead.

You can achieve this same result (from a caller’s point of view) with a variation of Scenario 2. The Scenario 3 example is given to illustrate another way of structuring the application by handing off a call from the Cisco CME ACD processing to the Cisco Unity Express AA. Using a variation of Scenario 2 is probably the more typical way to build this application.

Scenario 3 Call Flow

The call flow of the configuration in this section is illustrated in Figure 24.

Figure 24 Scenario 3 Call Flow

135510.jpg

Scenario 3 Configuration Notes

PSTN calls from the FXO port (0/3/0) are auto-terminated to the Cisco CME AA (2040).

The Cisco CME ACD has only two groups of agents (2020 and 2021). Option 3 of the menu is used to hand off the call to the Cisco Unity Express AA for the announcement. Instead of listing a hunt-group number, when callers choose option 3 the system directs the callers to the Cisco Unity Express AA pilot number (2100)--resulting from the use of the param aa-hunt3 2100 command.

Configure Cisco CME for Scenario 3

The CLI configuration for the Cisco CME router is shown in the following example:

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!

!--- Point option 3 of the menu (aa-hunt3) to the 
!--- Cisco Unity Express AA (2100).

!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2100
  param queue-len 30
 !
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!
voice-port 0/3/0
 connection plar opx 2040
!
voice-port 0/3/1
 connection plar opx 2040
!
voice-port 0/3/2
!
voice-port 0/3/3
!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

Configure Cisco Unity Express for Scenario 3

These steps summarize the configuration for Cisco Unity Express for Scenario 3:

  1. Open the Cisco Unity Express Script Editor utility and write the custom Cisco Unity Express script. See Figure 25.

    Figure 25 Store Hours and Location Script

    135367.jpg

  2. Record the prompt (in this case named S11_Announcement.wav) for the AA script (S11_CUE-AA-BACD-script.aef). You can either record this offline and upload the .wav file to Cisco Unity Express with the correct file name, or you can record it through the Administration via Telephony (AVT).

  3. (Optional) If you use the AVT, Cisco Unity Express assigns a generic file name that you can subsequently change to the desired file name. Choose Voice Mail > Prompts and click the system file name.

  4. (Optional) Edit the file name in the dialog box and click OK. The Voice Mail > Prompts window now shows the corrected file name in the list (see Figure 26).

  5. Choose Voice Mail > Auto Attendant and open the AA built during Step 2. Choose Script Parameters and associate the prompt file name with the correct parameter in the script.

    Figure 26 Window Showing Prompt Options

    135368.jpg

  6. Choose Voice Mail > Auto Attendant and associate the script with the AA pilot number 2100. See Figure 27.

    Figure 27 Window Showing Association of Script to AA Pilot Number

    135369.jpg

The CLI configuration for the Cisco Unity Express system is shown in the following example:

cue# 
show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1
groupname Administrators create
groupname Broadcasters create
groupname custservice create
username admin create
username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
groupname custservice phonenumber "2070"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
groupname Administrators member admin
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "true"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
!

!--- Define the AA script that will provide the announcement.

!
ccn application s11-cue-aa-bacd
 description "s11-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s11_cue-aa-bacd-script.aef"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
!

!--- Associate the script with the 2100 AA pilot number.

!
ccn trigger sip phonenumber 2100
 application "s11-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000

description "user26 mailbox"
end mailbox
end

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

BACD Prompt for Single Auto Attendants not Playing

If the BACD file is in the flash:/bacdprompt/ folder, issue the paramspace english location flash:/bacdprompt/ command in the AA service.

Related Information

Updated: May 04, 2007
Document ID: 67907