Guest

Cisco Catalyst 6500 Series Switches

Configuration example to migrate Spanning Tree from PVST+ to MST

Document ID: 72844

Updated: Dec 13, 2006

   Print

Introduction

This document provides a sample configuration to migrate the spanning tree mode from PVST+ to Multiple Spanning Tree (MST) in the campus network.

Prerequisites

Requirements

Refer to Understanding Multiple Spanning Tree Protocol (802.1s) before you configure MST.

This table shows the support of MST in Catalyst switches and the minimum software required for that support.

Catalyst Platform MST with RSTP
Catalyst 2900 XL and 3500 XL Not Available
Catalyst 2950 and 3550 Cisco IOS® 12.1(9)EA1
Catalyst 3560 Cisco IOS 12.1(9)EA1
Catalyst 3750 Cisco IOS 12.1(14)EA1
Catalyst 2955 All Cisco IOS versions
Catalyst 2948G-L3 and 4908G-L3 Not Available
Catalyst 4000, 2948G, and 2980G (Catalyst OS (CatOS)) 7.1
Catalyst 4000 and 4500 (Cisco IOS) 12.1(12c)EW
Catalyst 5000 and 5500 Not Available
Catalyst 6000 and 6500 (CatOS) 7.1
Catalyst 6000 and 6500 (Cisco IOS) 12.1(11b)EX, 12.1(13)E, 12.2(14)SX
Catalyst 8500 Not Available

  • Catalyst 3550/3560/3750: TheMST implementation in Cisco IOS Release 12.2(25)SEC is based on the IEEE 802.1s standard. The MST implementations in earlier Cisco IOS releases are prestandard.

  • Catalyst 6500 (IOS): The MST implementation in Cisco IOS Release 12.2(18)SXF is based on the IEEE 802.1s standard. The MST implementations in earlier Cisco IOS releases are prestandard.

Components Used

This document is created with the Cisco IOS Software Release 12.2(25) and CatOS 8.5(8), but the configuration is applicable to the minimum IOS version mentioned in the table.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to the Cisco Technical Tips Conventions for more information on document conventions.

Background Information

The MST feature is the IEEE 802.1s and is an amendment to 802.1Q. MST extends the 802.1w Rapid Spanning Tree (RST) algorithm to multiple spanning trees. This extension provides for both rapid convergence and load balancing in a VLAN environment. PVST+ and Rapid-PVST+ run spanning tree instance for each VLAN. In MST, you can group VLANs into a single instance. It uses Bridge Protocol Data Unit (BPDU) version 3 which is backward compatible with the 802.1D STP which uses BPDU version 0.

MSTP Configuration: The configuration includes the name of the region, the revision number, and the MST VLAN-to-instance assignment map. You configure the switch for a region with the spanning-tree mst configuration global configuration command.

MST Region: An MST region consists of interconnected bridges that have the same MST configuration. There is no limit on the number of MST regions in the network.

Spanning-tree Instances Inside the MST Region: An instance is nothing but a group of VLANs mapped in the spanning-tree mst configuration command. By default, all the VLANs are grouped into IST0, which is called an Internal Spanning Tree (IST). You can manually create instances numbered 1 to 4094, and they are labeled MSTn (n =1 to 4094), but the region can support only up to 65 instances. Some of the releases supports only 16 instances. Refer the software configuration guide for your switch platform.

IST/CST/CIST: IST is the only instance that can send and receive BPDUs in the MST network. An MSTn instance is local to the region. ISTs in different regions are interconnected through a Common Spanning Tree (CST). The collection of ISTs in each MST region and the CST that connects the ISTs are called the Common and Internal Spanning Tree (CIST).

Backward Compatibility: MST is backward compatible with PVST+, Rapid-PVST+, and Prestandard MST (MISTP). MST switch is connected to the other STP (PVST+ and Rapid-PVST+) switches by the Common Spanning Tree (CST). Other STP (PVST+ and Rapid-PVST+) switches see the entire MST region as a single switch. When you connect the prestandard MST switch with the standard MST switch, you need to configure spanning-tree mst pre-standard in the interface of the standard MST switch, .

Configure

This example contains two sections. The first section shows the current PVST+ configuration. The second section shows the configuration that migrates from PVST+ to MST.

Note: Use the Command Lookup Tool (registered customers only) to obtain more information on the commands used in this section.

Network Diagram

This document uses this network setup:

This diagram includes these switches:

  • Distribution1 and Distribution2, which are in the distribution layer

  • Two access-layer switches called Access1 (IOS) and Access2 (CatOS)

  • Two server aggregation switches called Services1 and Services2

VLANs 10, 30, and 100 carry data traffic. VLANs 20, 40, and 200 carry voice traffic.

MST-1.gif

Configurations

This document uses these configurations:

PVST+ Configuration

The switches are configured in PVST+ to carry the data and voice traffic as per the network diagram. This is a short summary of the configuration:

  • The Distribution1 switch is configured to become a primary root bridge for the data VLANs 10, 30, and 100 with the Distribution1(config)# spanning-tree vlan 10,30,100 root primary command, and the secondary root bridge for the voice VLANs 20, 40, and 200 uses the Distribution1(config)# spanning-tree vlan 20,40,200 root secondary command.

  • The Distribution2 switch is configured to become a primary root bridge for the voice VLANs 20, 40, and 200 with the Distribution2(config)# spanning-tree vlan 20,40,200 root primary command, and the secondary root bridge for the data VLANs 10, 30, and 100 uses the Distribution2(config)# spanning-tree vlan 10,30,100 root secondary command.

  • The spanning-tree backbonefast command is configured on all the switches to converge the STP more quickly in case of indirect link failure in the network.

  • The spanning-tree uplinkfast command is configured on the access-layer switches to converge the STP more quickly in case of direct uplink failure.

Distribution1
Distribution1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 24576
spanning-tree vlan 20,40,200 priority 28672
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
 !
 end

You can see that the port Fa1/0/24 is configured with the spanning-tree vlan 20,40,200 port-priority 64 command. Distribution2 is the configured root for VLANs 20,40, and 200. Distribution2 has two links to Distribution1: Fa1/0/23 and Fa1/0/24. Both ports are designated ports for VLANs 20, 40, and 200 because Distribution2 is the root for those VLANs. Both ports have the same priority 128 (default). Also, these two links have the same cost from Distribution1: fa1/0/23 and fa1/0/24. Distribution1 chooses the lowest port number of the two ports in order to set the port into the forwarding state. The lowest port number is Fa1/0/23 but,, as per the network diagram, voice VLANs 20, 40, and 200 can flow through Fa1/0/24. You can accomplish this with these methods:

  1. Decrease the port cost in Distribution1: Fa1/0/24.

  2. Decrease the port priority in Distribution2: Fa1/0/24.

In this example, port priority is decreased to forward VLANs 20, 40, 200 through fa1/0/24.

Distribution2
Distribution2#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 28672
spanning-tree vlan 20,40,200 priority 24576
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 20,40,200 port-priority 64
 switchport trunk allowed vlan 10,20,30,40,100,200

end

You can see that port Fa0/5 in Services1, and both Fa0/6 and Fa0/48 in Services2 have the Spanning Tree port cost and port priority configuration. Here the STP is tuned so that VLAN 100 and 200 of Services1 and Services2 can pass through the trunk links between them. If this configuration is not applied, Services1 and 2 cannot pass traffic through the trunk links between them. Instead, it chooses the path through Distribution1 and Distribution2.

Services2 sees two equal cost paths to the VLAN 100 root (Distribution1): one through Services1 and the second one through Distribution2. The STP chooses the best path (root port) in this order:

  1. The path cost

  2. The bridge ID of the forwarding switch

  3. The lowest port priority

  4. The lowest internal port number

In this example, both the paths have the same cost, but the Distribution2 (24576) has a lower priority than Services1 (32768) for the VLAN 100, so Services2 chooses Distribution2. In this example, the port cost on Services1: fa0/5 is set lower to let Services2 choose the Services1. The path cost overrides the forwarding switch priority number.

Services1
Services1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 100 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
!
 end

The same concept is applied for Services1 to choose Services2 to forward VLAN 200. After you reduce the cost for VLAN 200 in Services2 - fa0/6, Services1 chooses fa0/47 to forward VLAN 200. The requirement here is to forward VLAN 200 through fa0/48. You can accomplish this with these two methods:

  1. Decrease the port cost in Services1: Fa0/48.

  2. Decrease the port priority in Services2: Fa0/48.

In this example, port priority in Services2 is decreased to forward VLAN 200 through fa0/48.

Services2
Services2#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 port-priority 64
 switchport trunk allowed vlan 100,200
!
 !
 end

Access1
Access1#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree backbonefast
!
vlan 10,20
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
 end

Access2
Access2> (enable)show config all 

#mac address reduction
set spantree macreduction enable
!
#stp mode
set spantree mode pvst+
!
#uplinkfast groups
set spantree uplinkfast enable rate 15 all-protocols off
!
#backbonefast
set spantree backbonefast enable
!
#vlan parameters
set spantree priority 49152  1
set spantree priority 49152  30
set spantree priority 49152  40
!
#vlan(defaults)
set spantree enable  1,30,40
set spantree fwddelay 15     1,30,40
set spantree hello    2      1,30,40
set spantree maxage   20     1,30,40
!
#vtp
set vlan 1,30,40
!
#module 3 : 48-port 10/100BaseTX Ethernet
set trunk 3/3  on dot1q 30,40
set trunk 3/4  on dot1q 30,40
!
 end

MST Migration

It is difficult to convert all the switches in the enterprise network to MST at the same time. Because of the backward compatibility, you can convert it phase by phase. Implement the changes in the scheduled maintenance window because the spanning tree reconfiguration can disrupt the traffic flow. When you enable MST, it also enables RSTP. The spanning tree uplinkfast and backbonefast features are PVST+ features, and it is disabled when you enable MST because those features are built within RSTP, and MST relies on RSTP. Within the migration, you can remove those commands in IOS. In catOS backbonefast and uplinkfast, commands are automatically cleared from the configuration, but the configuration of the features such as the PortFast, bpduguard, bpdufilter, root guard, and loopguard are also applicable in MST mode. The usage of these features is the same as in PVST+ mode. If you have already enabled these features in the PVST+ mode, it remains active after the migration to MST mode. When you configure MST, follow these guidelines and restrictions:

  • The first step in the migration to 802.1s/w is to properly identify point-to-point and edge ports. Ensure that all switch-to-switch links, on which a rapid transition is desired, are full-duplex. Edge ports are defined through the PortFast feature.

  • Choose a configuration name and revision number that are common to all switches in the network. Cisco recommends that you place as many switches as possible into a single region; it is not advantageous to segment a network into separate regions.

  • Carefully decide how many instances are needed in the switched network, and keep in mind that an instance translates to a logical topology. Avoid mapping any VLANs onto instance 0. Decide what VLANs to map onto those instances, and carefully choose a root and back-up root for each instance.

  • Ensure that trunks carry all the VLANs that are mapped to an instance or do not carry any VLANs at all for this instance.

  • MST can interact with legacy bridges that run PVST+ on a per-port basis, so it is not a problem to mix both types of bridges if interactions are clearly understood. Always try to keep the root of the CST and IST inside the region. If you interact with a PVST+ bridge through a trunk, ensure that the MST bridge is the root for all VLANs that are allowed on that trunk. Do not use PVST bridges as the root of CST.

  • Ensure that all PVST spanning tree root bridges have lower (numerically higher) priority than the CST root bridge.

  • Do not disable the spanning tree on any VLAN in any of the PVST bridges.

  • Do not connect switches with access links because access links can partition a VLAN.

  • Any MST configuration that involves a large number of either current or new logical VLAN ports must be completed within a maintenance window because the complete MST database gets reinitialized for any incremental change, such as the addition of new VLANs to instances or the movement of VLANs across instances.

In this example, the campus network has one MST region named region1 and two instances of MST1 - Data VLANs 10, 30, and 100, and MST2 - voice VLANs 20, 40, and 200. You can see that MST runs only two instances, but the PVST+ runs six instances. Distribution1 is chosen as CIST regional root. It means that Distribution1 is the root for IST0. In order to load balance the traffic in the network as per the diagram, Distribution1 is configured as the root for MST1 (instance for Data VLANs), and MST2 is configured as the root for MST2 (instance for voice VLANs).

You need to migrate the core first and work your way down to the access switches. Before you change the spanning-tree mode, configure the MST configuration on the switches. Then change the STP type to MST. In this example, migration occurs in this order:

  1. Distribution1 and Distribution2

  2. Services1 and Services2

  3. Access1

  4. Access2

  1. Distribution1 and Distribution2 migration:

    
    !--- Distribution1 configuration:
    
    Distribution1(config)#spanning-tree mst configuration
    Distribution1(config-mst)#name region1
    Distribution1(config-mst)#revision 10
    Distribution1(config-mst)#instance 1 vlan 10, 30, 100
    Distribution1(config-mst)#instance 2 vlan 20, 40, 200
    Distribution1(config-mst)#exit
    Distribution1(config)#spanning-tree mst 0-1 root primary
    Distribution1(config)#spanning-tree mst 2 root secondary
    
    
    !--- Distribution2 configuration:
    
    Distribution2(config)#spanning-tree mst configuration
    Distribution2(config-mst)#name region1
    Distribution2(config-mst)#revision 10
    Distribution2(config-mst)#instance 1 vlan 10, 30, 100
    Distribution2(config-mst)#instance 2 vlan 20, 40, 200
    Distribution2(config-mst)#exit
    Distribution2(config)#spanning-tree mst 2 root primary
    Distribution2(config)#spanning-tree mst 0-1 root secondary
    
    
    !--- Make sure that trunks carry all the VLANs that are mapped to an instance.
    
    
    Distribution1(config)#interface FastEthernet1/0/1
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/3
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/5
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/23
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/24
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    Distribution2(config)#interface FastEthernet1/0/2
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/4
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/6
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/23
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    
    !--- STP mode conversion.
    
    Distribution1(config)#spanning-tree mode mst
    Distribution2(config)#spanning-tree mode mst
    
    
    !--- MST tuning - to load balance data and voice VLAN traffic.
    
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#spanning-tree mst 2 port-priority 64
    
    
    !--- PVST+ cleanup.
    
    Distribution1(config)#no spanning-tree backbonefast
    Distribution2(config)#no spanning-tree backbonefast
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#no spanning-tree vlan 20,40,200 port-priority 64
    

    Note: It is recommended that you set the MST0 root manually. In this example, Distribution1 is chosen as the MST0 root, so Distribution1 becomes the CIST root.

    Now the network is in mixed configuration. It can be represented as per this diagram:

    MST-2.gif

    Distribution1 and Distribution2 are in MST region1, and the PVST+ switches see the region1 as a single bridge. The traffic flow after the reconverge is shown in Diagram 2. You can still tune the PVST+ (spanning-tree VLAN X cost) switches to loadbalance the data and voice traffic as per Diagram 1. After you migrate all the other switches as per steps 2 through 4, you get the final spanning tree topology as per Diagram 1.

  2. Services1 and Services2 migration:

    
    !--- Services1 configuration:
    
    Services1(config)#spanning-tree mst configuration
    Services1(config-mst)#name region1
    Services1(config-mst)#revision 10
    Services1(config-mst)#instance 1 vlan 10, 30, 100
    Services1(config-mst)#instance 2 vlan 20, 40, 200
    Services1(config-mst)#exit
    
    
    !--- Services2 configuration:
    
    Services2(config)#spanning-tree mst configuration
    Services2(config-mst)#name region1
    Services2(config-mst)#revision 10
    Services2(config-mst)#instance 1 vlan 10, 30, 100
    Services2(config-mst)#instance 2 vlan 20, 40, 200
    Services2(config-mst)#exit
    
    
    !--- Make sure that trunks carry all the 
    !--- VLANs that are mapped to an instance.
    
    Services1(config)#interface FastEthernet0/5
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services1(config)#interface FastEthernet0/47
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services1(config)#interface FastEthernet0/48
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/6
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/47
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/48
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    
    
    !--- STP Mode conversion:
    
    Services1(config)#spanning-tree mode mst
    Services2(config)#spanning-tree mode mst
    
    
    !--- MST tuning - to load balance data and voice VLAN traffic:
    
    Services1(config)#interface fastEthernet 0/46
    Services1(config-if)#spanning-tree mst 2 cost 200000
    Services1(config-if)#exit
    Services1(config)#interface fastEthernet 0/47
    Services1(config-if)#spanning-tree mst 2 cost 100000
    Services1(config-if)#exit
    
    Services2(config)#interface FastEthernet 0/6
    Services2(config-if)#spanning-tree mst 1 cost 500000
    Services2(config-if)#exit
    
    
    !--- PVST+ cleanup:
    
    Services1(config)#no spanning-tree uplinkfast
    Services1(config)#no spanning-tree backbonefast
    Services1(config)#interface FastEthernet0/5
    Services1(config-if)#no spanning-tree vlan 100 cost 18
    Services1(config-if)#exit
    
    Services2(config)#no spanning-tree uplinkfast
    Services2(config)#no spanning-tree backbonefast
    Services2(config)#interface FastEthernet0/6
    Services2(config-if)#no spanning-tree vlan 200 cost 18
    Services2(config-if)#exit
    Services2(config)#interface FastEthernet0/48
    Services2(config-if)#no spanning-tree vlan 200 port-priority 64
    Services2(config-if)#exit
    
  3. Access1 migration:

    
    !--- Access1 configuration:
    
    Access1(config)#spanning-tree mst configuration
    Access1(config-mst)#name region1
    Access1(config-mst)#revision 10
    Access1(config-mst)#instance 1 vlan 10, 30, 100
    Access1(config-mst)#instance 2 vlan 20, 40, 200
    Access1(config-mst)#exit
    
    
    !--- Make sure that trunks carry all the VLANs that are mapped to an instance.
    
    Access1(config)#interface FastEthernet0/1
    Access1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Access1(config)#interface FastEthernet0/2
    Access1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    !--- STP mode conversion:
    
    Access1(config)#spanning-tree mode mst
    
    
    !--- PVST+ cleanup:
    
    Access1(config)#no spanning-tree uplinkfast
    Access1(config)#no spanning-tree backbonefast
    
  4. Access2 migration:

    
    !--- Access2 configuration:
    
    Access2> (enable) set spantree mst config name region1 revision 10
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst 1 vlan 10,30,100
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst 2 vlan 20,40,200
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst config commit
    
    
    !--- Ensure that trunks carry all the VLANs that are mapped to an instance:
    
    Access2> (enable)set trunk 3/3  on dot1q 10,20,30,40,100,200
    Access2> (enable)set trunk 3/4  on dot1q 10,20,30,40,100,200
    
    
    STP mode conversion
    
    Access2> (enable) set spantree mode mst
    PVST+ database cleaned up.
    Spantree mode set to MST.
    
    
    !--- Backbonefast and uplinkfast configurations are cleaned up automatically.
    
    

Verify

It is recommended to verify the spanning tree topology every time the configuration is changed.

Verify that the Distribution1 switch is the root bridge for data VLANs 10, 30, and 100, and verify that the spanning-tree forwarding path matches as per the path in the diagram.

 Distribution1# show spanning-tree mst 0

##### MST0    vlans mapped:   1-9,11-19,21-29,31-39,41-99,101-199,201-4094
Bridge        address 0015.63f6.b700  priority      24576 (24576 sysid 0)
Root          this switch for the CIST
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.1    P2p
Fa1/0/3          Desg FWD 200000    128.3    P2p
Fa1/0/5          Desg FWD 200000    128.5    P2p 
Fa1/0/23         Desg FWD 200000    128.23   P2p
Fa1/0/24         Desg FWD 200000    128.24   P2p


Distribution1#show spanning-tree mst 1

##### MST1    vlans mapped:   10,30,100
Bridge        address 0015.63f6.b700  priority      24577 (24576 sysid 1)
Root          this switch for MST1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.1    P2p
Fa1/0/3          Desg FWD 200000    128.3    P2p
Fa1/0/5          Desg FWD 200000    128.5    P2p 
Fa1/0/23         Desg FWD 200000    128.23   P2p
Fa1/0/24         Desg FWD 200000    128.24   P2p

Distribution1#show spanning-tree mst 2

##### MST2    vlans mapped:   20,40,200
Bridge        address 0015.63f6.b700  priority      28674 (28672 sysid 2)
Root          address 0015.c6c1.3000  priority      24578 (24576 sysid 2)
              port    Gi1/0/24        cost          200000    rem hops 4

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi1/0/1          Desg FWD 200000    128.1    P2p
Gi1/0/3          Desg FWD 200000    128.3    P2p
Gi1/0/23         Altn BLK 200000    128.23   P2p
Gi1/0/24         Root FWD 200000    128.24   P2p

Distribution2#show spanning-tree mst 0

##### MST0    vlans mapped:   1-9,11-19,21-29,31-39,41-99,101-199,201-4094
Bridge        address 0015.c6c1.3000  priority      28672 (28672 sysid 0)
Root          address 0015.63f6.b700  priority      24576 (24576 sysid 0)
              port    Fa1/0/23        path cost     0
Regional Root address 0015.63f6.b700  priority      24576 (24576 sysid 0)
                                      internal cost 200000    rem hops 19
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/2          Desg FWD 200000    128.54   P2p
Fa1/0/4          Desg FWD 200000    128.56   P2p
Fa1/0/6          Desg FWD 200000    128.58   P2p
Fa1/0/23         Root FWD 200000    128.75   P2p
Fa1/0/24         Altn BLK 200000    128.76   P2p


!--- CIST root is Distribution1. All the 
!--- switches are in the same region "region1".
!--- Hence in all the switches in the region1 you can see the path cost as 0.


Distribution2#show spanning-tree mst 1

##### MST1    vlans mapped:   10,30,100
Bridge        address 0015.c6c1.3000  priority      28673 (28672 sysid 1)
Root          address 0015.63f6.b700  priority      24577 (24576 sysid 1)
              port    Gi2/0/23        cost          200000    rem hops 1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/0/2          Desg FWD 200000    128.54   P2p
Gi2/0/4          Desg FWD 200000    128.56   P2p
Gi2/0/23         Root FWD 200000    128.75   P2p
Gi2/0/24         Altn BLK 200000    128.76   P2p

Distribution2#show spanning-tree mst 2

##### MST2    vlans mapped:   20,40,200
Bridge        address 0015.c6c1.3000  priority      24578 (24576 sysid 2)
Root          this switch for MST2

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/0/2          Desg FWD 200000    128.54   P2p
Gi2/0/4          Desg FWD 200000    128.56   P2p
Gi2/0/6          Desg FWD 200000    128.58   P2p
Gi2/0/23         Desg FWD 200000    128.75   P2p
Gi2/0/24         Desg FWD 200000     64.76   P2p

Access2> (enable) show spantree mst 1
Spanning tree mode          MST
Instance                    1
VLANs Mapped:               10,30,100

Designated Root             00-15-63-f6-b7-00
Designated Root Priority    24577  (root priority: 24576, sys ID ext: 1)
Designated Root Cost        200000     Remaining Hops 19
Designated Root Port        3/3

Bridge ID MAC ADDR          00-d0-00-50-30-00
Bridge ID Priority          32769  (bridge priority: 32768, sys ID ext: 1)

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     forwarding    ROOT    200000   32 P2P
 3/4                     blocking      ALTR    200000   32 P2P

Access2> (enable) show spantree mst 2
Spanning tree mode          MST
Instance                    2
VLANs Mapped:               20,40,200

Designated Root             00-15-c6-c1-30-00
Designated Root Priority    24578  (root priority: 24576, sys ID ext: 2)
Designated Root Cost        200000     Remaining Hops 19
Designated Root Port        3/4

Bridge ID MAC ADDR          00-d0-00-50-30-00
Bridge ID Priority          32770  (bridge priority: 32768, sys ID ext: 2)

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     blocking      ALTR    200000   32 P2P
 3/4                     forwarding    ROOT    200000   32 P2P

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Dec 13, 2006
Document ID: 72844