Guest

IP Routing

Configuring IS-IS for IP on Cisco Routers

Document ID: 13795

Updated: Aug 10, 2005

   Print

Introduction

The purpose of this document is to demonstrate a basic configuration of Intermediate System-to-Intermediate System (IS-IS) for IP on Cisco routers. In addition to the configuration, how to monitor various IS-IS information is demonstrated, such as Designated Intermediate System (DIS) election information and IS-IS database information.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on Cisco IOS ® Software Release 12.1(5)T9.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

IS-IS Sample Configuration

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) to find more information on the commands used in this document.

In order to enable IS-IS for IP on a Cisco router and have it exchange routing information with other IS-IS enabled routers, you must perform these two tasks:

  • Enable the IS-IS process and assign area

  • Enable IS-IS for IP routing on an interface

Other configuration tasks are optional, however the above two tasks are required. For more information on optional configuration tasks, refer to Configuring Integrated IS-IS.

Network Diagram

This document uses this network setup:

is-is-ip-config.jpg

Configurations

This document uses these configurations:

The sample configurations below configure all the routers in the above topology with these parameters:

  • Area 49.0001

  • Level 1 (L1) and Level 2 (L2) routers (this is the default unless otherwise specified)

  • No optional parameters

  • Running IS-IS for IP only

  • Loopback interfaces (loopbacks are advertised by IS-IS, not IS-IS enabled)

Router 1
!
interface Loopback0
ip address 172.16.1.1 255.255.255.255

!--- Creates loopback interface and assigns
!--- IP address to interface Loopback0.

!
interface Ethernet0
ip address 172.16.12.1 255.255.255.0
ip router isis 


!--- Assigns IP address to interface Ethernet0 
!--- and enables IS-IS for IP on the interface.

!
router isis
passive-interface Loopback0
net 49.0001.1720.1600.1001.00
!

!--- Enables the IS-IS process on the router, 
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router.

Router 2
!
interface Loopback0
ip address 172.16.2.2 255.255.255.255

!--- Creates loopback interface and assigns 
!--- IP address to interface Loopback0.

!
Interface Ethernet0
ip address 172.16.12.2 255.255.255.0
ip router isis

!--- Assigns IP address to interface Ethernet0 
!--- and enables IS-IS for IP on the interface.

!
Interface Serial0
ip address 172.16.23.1 255.255.255.252
ip router isis

!--- Assigns IP address to interface Serial0 
!--- and enables IS-IS for IP on the interface.

!
router isis 
passive-interface Loopback0
net 49.0001.1720.1600.2002.00
!

!--- Enables the IS-IS process on the router,
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router. 

Router 3
!
interface Loopback0
ip address 172.16.3.3 255.255.255.255 

!--- Creates loopback interface 
!--- and assigns IP address to 
!--- interface Loopback0.

!
Interface Serial0
ip address 172.16.23.2 255.255.255.252
ip router Isis

!--- Assigns IP address to 
!--- interface Serial0 and enables 
!--- IS-IS for IP on the interface.

!
router isis 
passive-interface Loopback0
net 49.0001.1234.1600.2231.00
!

!--- Enables the IS-IS process on the router, 
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router.

Monitoring IS-IS

There are many show commands available for monitoring the state of IS-IS on a Cisco router. This document demonstrates some of the more basic commands based on the above router configurations.

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis of show command output.

Monitoring IS-IS Adjacencies

Use the show clns neighbor command to display the adjacencies for a specific router. This is the output of this command from Router 1 (R1) and Router 2 (R2):

R1# show clns neighbor
System Id   Interface  SNPA            State  Holdtime  Type Protocol
R2          Et0        0000.0c47.b947  Up     24        L1L2 ISIS
    
R2# show clns neighbor
System Id  Interface  SNPA             State  Holdtime  Type Protocol
R1         Et0        0000.0c09.9fea   Up     24        L1L2 ISIS
R3         Se0        *HDLC*           Up     28        L1L2 ISIS

In the above example, R1 recognizes R2 on its E0 interface with the adjacency type being L1L2. Because R1 and R2 are configured with default configurations, they send and receive both L1 and L2 hellos.

R2 recognizes R1 on its E0 interface, and Router 3 (R3) on its S0 interface. The same explanation as above is true for the adjacency type.

Since R1 and R2 are on the same Ethernet interface, there is a DIS for both L1 and L2. You can verify this using the show clns interface <int> command on Router 1, as shown below:

R1# show clns interface ethernet 0
Ethernet0 is up, line protocol is up
  Checksums enabled, MTU 1497, Encapsulation SAP
  Routing Protocol: ISIS
    Circuit Type: level-1-2
    Interface number 0x0, local circuit ID 0x1
    Level-1 Metric: 10, Priority: 64, Circuit ID: R2.01
    Number of active level-1 adjacencies: 1
    Level-2 Metric: 10, Priority: 64, Circuit ID: R2.01
    Number of active level-2 adjacencies: 1
    Next ISIS LAN Level-1 Hello in 5 seconds
    Next ISIS LAN Level-2 Hello in 1 seconds

In the above output, R2 is the DIS. It is the R2 (DIS) that generates the pseudonode Link State Packet (LSP) and is denoted with a non-zero LSP-ID - R2.01

Since the Metric/Priority are the same for both routers in L1/L2, the tiebreaker for the DIS is the highest Subnetwork Points of Attachment (SNPA) address on the LAN segment. The SNPA address refers to the data link address, and in this case is the MAC address. Other instance of data link addresses would be X.25 addresses and Frame Relay DLCI.

Notice that the DIS is elected for both levels, and that no backup DIS exists, as with Open Shortest Path First (OSPF), which has a backup Designated Router (DR).

Some other points of interest from the above output include:

  • Circuit Type: L1L2

  • L1 and L2 metrics and priorities are at default values: 10 and 64

  • L1 and L2 adjacencies: 1 (from R1 perspective on the Ethernet interface - it is R2 only)

  • IS-IS LAN hellos for L1 and L2

  • Maximum Transmission Unit (MTU): 1497. This is because the Open Systems Interconnection (OSI) IS-IS header is encapsulated inside a 3 byte 802.2 header.

Monitoring the IS-IS Database

The show isis database (detail) command displays the contents of the IS-IS database. This is the output of this command when issued on R2. Since IS-IS is a link state protocol, the link state database should be the same for any router in the same area.

R2# show isis database
ISIS Level-1 Link State Database:
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime    ATT/P/OL
R1.00-00      0x0000008B   0x6843        55              0/0/0
R2.00-00    * 0x00000083   0x276E        77              0/0/0
R2.01-00    * 0x00000004   0x34E1        57              0/0/0
R3.00-00      0x00000086   0xF30E        84              0/0/0
ISIS Level-2 Link State Database:
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime    ATT/P/OL
R1.00-00      0x00000092   0x34B2        41              0/0/0
R2.00-00    * 0x0000008A   0x7A59        115             0/0/0
R2.01-00    * 0x00000004   0xC3DA        50              0/0/0
R3.00-00      0x0000008F   0x0766        112             0/0/0

There are a few things to notice in the above output. First, about the LSP-ID:

The LSP-ID, R1.00-00, can be broken down into three sections: R1/00/00

  • R1 = system ID

  • 00 = non-zero value for the pseudonode. Notice R2.01-00 is the pseudonode LSP.

  • 00 = fragment number. In this case, there are only fragment numbers of 00, which indicates that all the data fit into this LSP fragment, and there was no need to create more fragments. If there had been information that did not fit into the first LSP, IS-IS would have created more LSP fragments, such as 01, 02, and so on.

The * denotes the LSPs that were generated by this router, the router that the show command was issued on. Also, since this router is an L1 and L2 router, it contains an L1 and L2 database.

You can also look at a specific LSP and use the detail keyword to show more information. An example of this is shown here:

R2# show isis database R2.00-00 detail
ISIS Level-1 LSP R2.00-00
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
R2.00-00    * 0x00000093   0x077E        71            0/0/0
  Area Address: 49.0001
  NLPID:        0xCC
  Hostname: R2
  IP Address:   172.16.2.2 
  Metric: 10         IP 172.16.12.0 255.255.255.0
  Metric: 0          IP 172.16.2.2 255.255.255.255
  Metric: 10         IP 172.16.23.0 255.255.255.252
  Metric: 10         IS R2.01
  Metric: 10         IS R3.00
ISIS Level-2 LSP R2.00-00
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
R2.00-00    * 0x0000009A   0x5A69        103           0/0/0
  Area Address: 49.0001
  NLPID:        0xCC
  Hostname: R2
  IP Address:   172.16.2.2
  Metric: 10         IS R2.01
  Metric: 10         IS R3.00
  Metric: 10         IP 172.16.23.0 255.255.255.252
  Metric: 10         IP 172.16.1.1 255.255.255.255
  Metric: 10         IP 172.16.3.3 255.255.255.255
  Metric: 0          IP 172.16.2.2 255.255.255.255
  Metric: 10         IP 172.16.12.0 255.255.255.0

The above output shows that the loopback address of this router is advertised with a value of 0. This is because the loopback is advertised with a passive-interface command under the router IS-IS process, and the loopback interface by itself is not enabled for IS-IS. All other IP prefixes have a value of 10, which is the default cost on the interfaces running IS-IS.

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Aug 10, 2005
Document ID: 13795