Guest

Cisco Services Modules

Troubleshoot and Configure Initial Wireless Services Module (WiSM) Setup

Document ID: 91473

Updated: Aug 04, 2008

   Print

Introduction

This document discusses the commands used to verify and troubleshoot the initial WiSM setup. This document also covers the basic steps necessary to configure the Catalyst 6500 Supervisor Engine 720 (Sup720) to communicate with the WiSM module that is installed in it.

Prerequisites

Requirements

Ensure that you have some basic knowledge about the Wireless LAN Controller and its configuration, as well as some basic knowledge of the Cisco Catalyst 6500 Switches that run Supervisor 720 and features such as the EtherChannel Link Aggregation (LAG). Apart from these, there are no specific requirements for this document.

Components Used

The information in this document is based on the Cisco WiSM module installed in a Catalyst 6500 Supervisor Engine 720 that runs Native Cisco IOS® Software Release 12.2(18)SXF2, but the commands apply to all the IOS versions that support the Supervisor 720 and the WiSM card.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Background Information

The Cisco WiSM is a member of the Cisco Wireless LAN Controller family. It works in conjunction with the Cisco Aironet Lightweight Access Points, Cisco WCS, and Cisco Wireless Location Appliance to deliver a secure and unified wireless solution that supports wireless data, voice, and video applications.

The Cisco WiSM smoothly integrates into the Cisco Catalyst 6500 Series Switch and a Cisco Catalyst 6500 Supervisor Engine 720. All Supervisor Engine 720 versions are supported. The WiSM is also supported on Cisco 7600 Routers that run only Cisco IOS Software Release 12.2(18)SXF5.

This table lists the supported slots on the Cisco Catalyst 6500 for the Cisco WiSM:

Slot 6503-E 6504-E 6506 6509 6513
1-3 X X X X  
4   X X X  
5-6     X X  
7-8       X  
9       X X
10-13         X

Note: Without any other service module installed, the Catalyst 6509 switch chassis can support up to seven Cisco WiSMs, the Catalyst 6506 with a Supervisor 720 can support up to four Cisco WiSMs, and any other Catalyst 6500 series switch chassis can support up to six Cisco WiSMs. If one or more service modules are installed, the chassis can support up to a maximum of four service modules (WiSMs included). Redundant supervisors cannot be used with these maximum configurations.

The Cisco WiSM consists of two Cisco 4404 Controllers, so the IT staff must be aware that two separate controllers exist on a single module. The first controller is considered the WiSM-A card, while the second controller is considered the WiSM-B card. Interfaces and IP addressing have to be considered on both cards independently. WiSM-A manages 150 access points, while WiSM-B manages a separate lot of 150 access points. These controllers can be grouped together in a mobility group that form a cluster.

There are multiple types of interfaces on each controller of the Cisco WiSM; three of them are pre-defined types that must be present and configured at setup time:

  • Management interface (pre-defined and mandatory)

  • AP-manager interface (pre-defined and mandatory)

  • Virtual interface (pre-defined and mandatory)

  • Operator-defined interface (user-defined)

  • Service-port interface (pre-defined and mandatory)

Read Configuring a Cisco Wireless Services Module and Wireless Control System for details of each of the type of interfaces.

On the WiSM, the service port is used to synchronize the Supervisor Engine and the WiSM.

Configure Communication Between the Supervisor 720 and Cisco WiSM

Note: If you have a WiSM trunk that includes VLANs in the range of 1 to 1000 and you intend to use only 1 to 10, enter the command: no wism module x controller y allowed-vlan 11-1000

After the Cisco WiSM controller is installed in a slot and detected by the Supervisor, these configurations are made on the Supervisor Engine to communicate with WiSM.

  1. Create a DHCP scope for the Service-Port of the Catalyst WiSM.

    ip dhcp excluded-address 192.168.10.1 192.168.10.2
    
    !
    ip dhcp pool wism-service-port
     
    network 192.168.10.0 255.255.255.0
    
    default-router 192.168.10.1
    
    

    Alternatively, you can also session (session slot X proc 1 or 2 ) or console directly into WiSM and set static IP addresses (config Interface Address Service-Port).

    Make sure that the service port IP address is not a routable IP address in your network because it is only used for communication between the Sup 720 and the WiSM.

  2. Create the WiSM Service Port Gateway and assign the IP address.

    Create a VLAN in the Supervisor 720. This VLAN is local to the chassis and is used for communication between Cisco WiSM and Catalyst Supervisor 720 over a Gigabit Interface on the Supervisor and a service port in the Cisco WiSM.

    interface Vlan192
    
    Description WiSM Service Port Gateway or Management Interface on CAT6K
    ip address 192.168.10.1 255.255.255.0
    
    

    Note: There should already be a network management VLAN interface to reach the Cat6k.

  3. Assign the WiSM Service Ports to a VLAN.

    Configure this command to use VLAN 192 to communicate with the service-port.

    wism service-vlan 192
    
    

    Note: The interface vlan for the vlan defined in wism service-wlan X needs to be on the same chassis as the controller, and the DHCP scope needs to be defined on the same chassis to which the WiSM is connected. For DHCP assignment to work, you need to have your interface vlan XX on the switch where the DHCP scope is defined.

  4. Create the WiSM Management/AP-Manager Gateway Interface on Cat6k.

    This is an example configuration:

    interface vlan40
    
    Description WiSM Management/AP-Manager Interface Gateway
    ip address 40.1.1.1
    
    

    Note: Software Release 12.2(18)SXF5 introduced new WiSM commands to use with auto-LAG ports (in the high 200 range). These commands can be used instead of steps 5 and 6.

    In a non-VSS envionment, issue the wism module <module/slot no> controller 1 native-vlan 40 wism module <module/slot no> controller 1 allowed-vlan native vlan id(40), vlan id1, vlan2, etc...

    commands. In a VSS envionment, issue the wism switch<module/slot no> controller 1 native-vlan 40 wism switch<module/slot no> controller 1 allowed-vlan native vlan id(40), vlan id1, vlan2, etc... commands. Services can be temporarily interrupted (for approximately two pings) after you enter this command.

    Enter this command to configure the QoS trust for the interface:

     wism module <module/slot no> controller 1 qos-trust dscp
  5. Create two port-channel interfaces on Cat6k with dot1q trunking, trust dscp, and native VLAN, which allows untagged packets from the management port.

    Create two port-channel interfaces for the two independent controllers in the Cisco WiSM and assign VLAN 40 as the native interface.

    interface Port-channel X
    
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 40
    
    switchport mode trunk
    mls qos trust dscp
    spanning-tree portfast trunk
    

    Similarly, create another port channel interface for the other controller on the WiSM.

  6. Configure the WiSM controller 1 and 2 interfaces.

    As soon as the Cisco WiSM controller is detected by the Supervisor at the beginning, eight Gigabit Interfaces are created, which range from Gig<slot number on which the module is installed>/1 to Gig<slot number>/8.

    Configure these Gigabit Interfaces as trunk ports with VLAN 40 as the native VLAN. Make sure that the native VLAN is not tagged while you do the Cisco WiSM configuration. This is a configuration example:

    router(config)# interface range gigabitEthernet
    <slot>/1 – 4 
    or 
    router(config)# interface range gigabitEthernet 
    <slot>/5 – 8
    
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 40
     
    switchport mode trunk
    mls qos trust dscp
    spanning-tree portfast trunk
    channel-group <port-channel no> mode on
    

    Note: When you have a WiSM installed on a switch that runs Cisco IOS Software Release 12.2.33SXI, defining a Port-Channel manually on the switch and applying it to the gigabit interfaces does not work. Auto-lag must be used.

Verification Steps

This section describes the commands used to verify the WiSM setup.

  1. In order to verify which Native (IOS) version is running, issue the show version command.

    Router#show version
    Cisco Internetwork Operating System Software 
    IOS (tm) s72033_rp Software (s72033_rp-ADVENTERPRISEK9_WAN-M), Version 12.2(18)SXF5, RELEASE SOFTWARE (fc3)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2006 by cisco Systems, Inc.
    Compiled Sat 08-Jul-06 02:54 by kellythw
    Image text-base: 0x40101040, data-base: 0x42D88000
    
    ROM: System Bootstrap, Version 12.2(14r)S1, RELEASE SOFTWARE (fc1)
    BOOTLDR: s72033_rp Software (s72033_rp-ADVENTERPRISEK9_WAN-M), Version 12.2(18)SXF5, RELEASE SOFTWARE (fc3)
    
    ... skip ...
    
    cisco WS-C6503-E (R7000) processor (revision 1.1) with 458720K/65536K bytes of memory.
    Processor board ID FOX0920047A
    SR71000 CPU at 600Mhz, Implementation 0x504, Rev 1.2, 512KB L2 Cache
    Last reset from power-on
    SuperLAT software (copyright 1990 by Meridian Technology Corp).
    X.25 software, Version 3.0.0.
    Bridging software.
    TN3270 Emulation software.
    3 Virtual Ethernet/IEEE 802.3 interfaces
    20 Gigabit Ethernet/IEEE 802.3 interfaces
    1917K bytes of non-volatile configuration memory.
    8192K bytes of packet buffer memory.
    
    65536K bytes of Flash internal SIMM (Sector size 512K).
    Configuration register is 0x2102

    Note: The WiSM requires a Supervisor 720 that runs Native IOS Version 12.2(18)SXF2 or later.

  2. In order to verify that the Cat6k has a Supervisor 720 and a WiSM card, use the show module command.

    Router#show module
    Mod Ports Card Type                              Model              Serial No.
    --- ----- -------------------------------------- ------------------ -----------
      1    2  Supervisor Engine 720 (Active)         WS-SUP720-BASE     SAD0717003H
      3   10  WiSM WLAN Service Module               WS-SVC-WISM-1-K9   SAD09280AZU
    
    
    Mod MAC addresses                       Hw    Fw           Sw           Status
    --- ---------------------------------- ------ ------------ ------------ -------
      1  000c.ce63.eb0c to 000c.ce63.eb0f   2.1   7.7(1)       12.2(18)SXF5 Ok
      3  0030.f274.ae36 to 0030.f274.ae45   0.3   12.2(14r)S5  12.2(18)SXF5 Ok
    
    
    Mod  Sub-Module                  Model              Serial       Hw     Status 
    ---- --------------------------- ------------------ ----------- ------- -------
      1  Policy Feature Card 3       WS-F6K-PFC3A       SAD071902DP  1.1    Ok
      1  MSFC3 Daughterboard         WS-SUP720          SAD071700L3  1.2    Ok
      3  Centralized Forwarding Card FARFEL             SAD0929038U  0.3    Ok
    
    Mod  Online Diag Status 
    ---- -------------------
      1  Pass
      3  Pass

    Note: The output of the show module command from the switch shows WISM with 10 ports. But only 8 ports are used for port-channel configuration, port-channel1 and port-channel2. The other 2 ports are used as service ports.

  3. In order to verify the slot in which the WiSM is installed, issue the show wism status command. This is an example output of this command:

    Router#sh wism status
    Service Vlan : 158, Service IP Subnet : 172.16.158.131/255.255.255.128
    WLAN
    Slot Controller Service IP Management IP SW Version Status
    ----+-----------+----------------+----------------+-----------+---------
    3 1 172.16.158.142 140.1.3.10 3.2.116.21 Oper-Up
    3 2 172.16.158.143 140.1.3.11 3.2.116.21 Oper-Up
    

    For 6503-E, only slots 1 through 3 work. For 6504 through 6506, only slots 1 through 4 work. For 6509, only slots 1 through 9 work. For 6913, it is completely opposite; only slots 9 through 13 work. For more detailed information refer to WiSM Troubleshooting FAQ.

  4. In order to verify the WiSM status from the Cat6k side, issue the show wism module X controller Y status command and look for Oper-Up and the LAG port in use (Verify LAG port). In order to verify whether there is no service IP address, verify the DHCP setup for service VLAN. Alternatively, session (session slot x proc 1 or 2 ) into the module, or console directly into WiSM for static IP addresses.

    Router#show wism module 3 controller 1 status 
    
    WiSM Controller 1 in Slot 3
    Operational Status of the Controller : Oper-Up
    Service VLAN                         : 250
    Service Port                         : 9
    Service Port Mac Address             : 0014.a9bd.d9a2
    Service IP Address                   : 172.16.158.142
    Management IP Address                : 140.1.3.10
    Software Version                     : 3.2.116.21
    Port Channel Number                  : 285
    Allowed vlan list                    : 5,10,15,25,35,45,55
    Native VLAN ID                       : 5
    WCP Keep Alive Missed                : 0
  5. In order to verify that trunking to the WiSM and VLANs is defined, issue the show interface trunk command. This is an example output of this command:

    Router#show interface trunk
             Port  Mode   Encapsulation Status Native vlan
             Po1   on     802.1q trunking 140
             Po2   on     802.1q trunking 140
  6. In order to verify correct load balancing algorithm (config #port-channel load-balance src-dst-ip), issue the show etherchannel load-balance command. This is an example output of the command:

    Router#show etherchannel load balance
    EtherChannel Load-Balancing Configuration:
                       src-dst-ip
    

    In order to verify correct ports on the EtherChannel, issue the show etherchannel load-balance command. This is an example output:

    Router#show etherchannel summary
    Group Port-channel Protocol Ports
    ------+-------------+-----------+-----------------------------------------
    1     Po1(SU)        -      Gi3/1(P) Gi3/2(P) Gi3/3(P) Gi3/4(P)
    2     Po2(SU)        -      Gi3/5(P) Gi3/6(P) Gi3/7(P) Gi3/8(P)
  7. In order to check the status from the WiSM side, session (session slot x proc 1 or 2 ) or console directly into WiSM, and check the LAG status under show interface summary (or under Controller -> Interfaces - > edit (management interface). Under Physical Information, it reads, “The interface is attached to a LAG.” This is an example:

    (WiSM-slot3-1) >show interface
    		  summary
    Interface Name     Port  Vlan Id   IP Address   Type   Ap Mgr
    --------------------------------   ----      -------   -------- ------- 
             ap-manager         LAG  untagged   192.168.3.9   Static   Yes
             management         LAG  untagged   192.168.3.10  Static    No

    Note: If the switch runs Cisco IOS Software Release 12.2.(18)SXF11, 12.2.(33)SXH or later and you have configured auto-LAG, the output of the show run command does not show the Gigabit interfaces for the WiSM.

Related Information

Updated: Aug 04, 2008
Document ID: 91473