Guest

ISDN, CAS

Configuring NFAS with Four T1s

Document ID: 9584

Updated: Sep 15, 2005

   Print

Introduction

ISDN Non-Facility Associated Signaling (NFAS) allows a single D channel to control multiple Primary Rate Interfaces (PRIs). You can configure a backup D channel when the primary NFAS D channel fails. When you configure the channelized T1 controllers for ISDN PRI, you only need to configure the NFAS primary D channel; its configuration is distributed to all the members of the associated NFAS group.

By using a single D channel to control multiple PRIs, one extra channel on each interface is free to carry data traffic. Any hard failure of the primary D-signaling channel results in an immediate switchover to the backup D channel without disconnecting currently connected users.

Note: If you configure a backup D channel, only 23 B channels can be used on the backup T1 controller because the D channel on the backup is unavailable. Therefore, only those T1s that are neither primary nor backup can have 24 B channels available. In this configuration, T1 controller 4/0 is the primary and has 23 available B channels, and T1 controller 4/1 is the backup and has 23 available B channels. T1 controllers 5/0 and 5/1 each have 24 available B channels.

Prerequisites

Requirements

The prerequisites for NFAS are as follows:

  • NFAS is supported only with a channelized T1 controller and, as a result, the T1 controllers must also be configured for ISDN PRI before implementing NFAS. For more information on configuring ISDN, refer to the ISDN Support Page.

  • The router configured for NFAS must connect to either a 4ess, dms250, dms100, or a National ISDN switch type.

    Note: NFAS is not supported on primary-5ess type switches. Consult your Service Provider or Telco to determine whether NFAS can be configured for your T1 line.

  • NFAS must be configured on your Telco's ISDN switch.

  • You must be using Cisco IOS® Software Release 11.3T or later.

Components Used

The information in this document is based on these software and hardware versions:

  • The following configuration was tested with a Cisco 7507 router running Cisco IOS Software Release 12.0(5).

  • This configuration illustrates how to set up four NFAS members within the same group. The primary NFAS interface is T1 4/0, and the backup is T1 4/1. T1 controllers 5/0 and 5/1 have 24 B channels available to them

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to Cisco Technical Tips Conventions.

Background Information

NFAS Terminology

Commonly used NFAS terms are as follows:

  • NFAS - An ISDN service that allows a single D channel to control multiple PRIs. Using a single D channel to control multiple PRIs allows one B channel on each interface to carry other traffic.

  • 24 B channel interface - A PRI channel group configured to have no NFAS D channel; all the 24 channels are B channels. This particular T1 uses the D channel configured in the primary controller for signaling.

  • NFAS group - A PRI channel grouping (the group of interfaces) under the control of a single D channel. The channel group can include all the ISDN channels on multiple T1 controllers.

    Note: NFAS can be configured with members in different slots on the router (for example, NFAS members are not restricted to being on the same slot or module). Also, within a single chassis, five NFAS groups are supported. In cases where T1s from multiple providers are used, they are often grouped by provider.

  • NFAS member - A PRI in an NFAS group. For example, an NFAS group might include serial interfaces 1/0:23, 1/1:23, and 2/0:23 if T1 controllers 1/0, 1/1, and 2/0 are configured in one NFAS group. To display the members of all NFAS group, use the show isdn nfas group privileged EXEC command.

Required Command

Note: Normal ISDN PRI configuration commands do not appear in this document. See the Related Information section for more information on configuring ISDN PRI.

pri-group timeslots 1-24 nfas_d function nfas_interface int_number nfas_group group_number

This controller configuration command assigns the T1 controller to the NFAS group and designates its function within the group. Specify the following values as appropriate:

  • function - The function to be performed by timeslot 24, either primary, backup, or none. Every NFAS group must have one primary. The router does not require a backup, however most NFAS implementations do have a backup D channel. Contact your telco to determine whether you should configure a backup D channel for your NFAS group. The rest of the controllers can be configured with none, which designates the 24th timeslot as a B channel.

    Note: Configure the primary and backup D channels exactly as specified by your Telco. A common error with an NFAS configuration is incorrectly desginating which T1 is the primary and which is the backup.

  • int_number - A value assigned by the service provider and used to uniquely identify the PRI. The values possible range from 0 to the highest t1 available on the router, minus one. For example, if the router has 10 T1s the NFAS interface number can range betweeen 0 and 9. The 0 interface must be assigned to the primary D channel and the 1 interface to the backup D channel.

    Note: In certain scenarios where the NFAS setup does not use a backup D channel, do not use the keyword nfas_interface 1 as it is reserved for the backup D channel. Configure only nfas_interfaces 0, 2, 3, 4 and so on.

    Note: When configuring multiple NFAS groups, the 0 interface must be assigned to each primary D channel and the 1 interface to each backup D channel, provided they are in a different nfas_group.

  • group_number - Group identifier unique on the router. Multiple NFAS groups can exist on the router. Each group must be configured with a primary and secondary controller.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup:

quadt1_nfas.gif

Configurations

This document uses these configurations:

Cisco 7507
! 
! 
Last configuration change at 13:07:00 cst Mon Jan 31 2000 
!
version 12.0 
no service pad 
service timestamps debug uptime 
service timestamps log datetime localtime show-timezone 
no service password-encryption 
! 
hostname Router 
! 
enable secret 
! 
ip subnet-zero 
no ip domain-lookup 
ip host west 172.22.173.21
isdn switch-type primary-dms100 

!--- Switchtype must be configured. 
!--- Contact your Telco for more information.
!--- Primary T1 controller.

controller T1 4/0 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d primary nfas_int 0 nfas_group 1 

!--- Primary D channel, nfas interface 0 and member of group 1.

controller T1 4/1 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d backup nfas_int 1 nfas_group 1 


!--- Backup D channel, nfas interface 1 and member of group 1. 


controller T1 5/0 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d none nfas_int 2 nfas_group 1 

!--- 24th timeslot used as B channel, nfas interface 2 and member of group 1.


controller T1 5/1 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d none nfas_int 3 nfas_group 1 

!--- 24th timeslot used as B channel, nfas interface 3 and member of group 1.

process-max-time 200 
! 
interface FastEthernet1/0/0   
 ip address 10.1.1.1 255.255.255.0 
 no ip directed-broadcast 
 no ip route-cache distributed 
 no ip mroute-cache 
 full-duplex 
! 
interface FastEthernet1/1/0 
 no ip address 
 no ip directed-broadcast 
 no ip route-cache distributed 
 no ip mroute-cache 
 shutdown 

!--- D channel for primary controller.
!--- Note: Other D channels in the group are not seen.
!--- All configuration changes made to the primary D channel propagate 
to all the NFAS group members.


interface Serial4/0:23 
 description primary d channel 
 no ip address 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer pool-member 1 
 isdn switch-type primary-dms100 
 isdn tei-negotiation first-call 
 ppp authentication chap 
 ppp multilink 
! 
interface Dialer0 
 ip address 192.168.10.1 255.255.255.0 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer remote-name C3620-EA-BCO 
 dialer pool 1 
 dialer-group 1 
 ppp authentication chap 
 ppp multilink 
!
router eigrp 200 
 redistribute static 
 network 10.0.0.0 
 network 192.168.10.0 

! 
no ip classless 
ip route 0.0.0.0 0.0.0.0 10.1.1.2 
! 
dialer-list 1 protocol ip permit 
! 
line con 0 
 transport input none 
line aux 0 
 password
   login
  modem InOut
  stopbits 1
 line vty 0 4
  exec-timeout 60 0
  password 
 login 
! 
end

Verify

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

  • show isdn status - Make sure that the router is properly communicating with the ISDN switch. In the output, verify that Layer 1 Status is ACTIVE, and that the Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED appears.

  • show isdn nfas group - Privileged EXEC command to display the members of a specified NFAS group or all NFAS groups.

  • show isdn service - Privileged EXEC command to show the state and service status of each ISDN channel. The D channels are indicated as reserved. This command can be used to verify if individual channels are busied out or are faulty.

  • show controller t1 - Displays the controller status specific to the controller hardware. It also displays information to troubleshoot physical layer and data link layer problems. In normal operation, the output should indicate that the controller is up and that there are no alarms.

Note: Make sure that the T1 connection designated as primary by the Telco and in your router configuration are connected to the correct port. A common error is having the wrong T1 line (cables) connected to the primary T1 port on your router.

Sample show Output

Following are some show command outputs from the router configured with NFAS.

Here is an example of the show isdn status command output:

Router#show isdn status 
Global ISDN Switchtype = primary-dms100 
ISDN Serial4/0:23 interface
         dsl 0, interface ISDN Switchtype = primary-dms100 : 
Primary D channel of nfas group 1
     Layer 1 Status:
         ACTIVE

!--- Primary D channel is active

    Layer 2 Status: 
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED 

!--- Layer 2 is established correctly

    Layer 3 Status: 
        23 Active Layer 3 Call(s) 
    Activated dsl 0 CCBs = 23 
        CCB:callid=0xA0B, sapi=0x0, ces=0x0, B-chan=1 
        CCB:callid=0xA0C, sapi=0x0, ces=0x0, B-chan=3 
        CCB:callid=0xA0D, sapi=0x0, ces=0x0, B-chan=4 
        CCB:callid=0xA0E, sapi=0x0, ces=0x0, B-chan=2 
        CCB:callid=0xA0F, sapi=0x0, ces=0x0, B-chan=5 
        CCB:callid=0xA10, sapi=0x0, ces=0x0, B-chan=6 
        CCB:callid=0xA11, sapi=0x0, ces=0x0, B-chan=7 
        CCB:callid=0xA12, sapi=0x0, ces=0x0, B-chan=8 
        CCB:callid=0xA13, sapi=0x0, ces=0x0, B-chan=9 
        CCB:callid=0xA14, sapi=0x0, ces=0x0, B-chan=10 
        CCB:callid=0xA15, sapi=0x0, ces=0x0, B-chan=11 
        CCB:callid=0xA16, sapi=0x0, ces=0x0, B-chan=12 
        CCB:callid=0xA17, sapi=0x0, ces=0x0, B-chan=13 
        CCB:callid=0xA18, sapi=0x0, ces=0x0, B-chan=14 
        CCB:callid=0xA1B, sapi=0x0, ces=0x0, B-chan=15 
        CCB:callid=0xA1C, sapi=0x0, ces=0x0, B-chan=16 
        CCB:callid=0xA1D, sapi=0x0, ces=0x0, B-chan=17 
        CCB:callid=0xA1E, sapi=0x0, ces=0x0, B-chan=18 
        CCB:callid=0xA1F, sapi=0x0, ces=0x0, B-chan=19 
        CCB:callid=0xA20, sapi=0x0, ces=0x0, B-chan=20 
        CCB:callid=0xA21, sapi=0x0, ces=0x0, B-chan=21 
        CCB:callid=0xA22, sapi=0x0, ces=0x0, B-chan=22 
        CCB:callid=0xA23, sapi=0x0, ces=0x0, B-chan=23 
    The Free Channel Mask:  0x80000000 
ISDN Serial4/1:23 interface
         dsl 1, interface ISDN Switchtype = primary-dms100 :
 Backup D channel of nfas group 1
     Layer 1 Status:
         DEACTIVATED
     Layer 2 Status:
         TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED 
    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 1 CCBs = 0 
    The Free Channel Mask:  0x7E7FFB 
ISDN Serial5/0:23 interface
         dsl 2, interface ISDN Switchtype = primary-dms100 :
 Group member of nfas group 1
     Layer 1 & 2 Status Not Applicable
 
!--- NFAS member: D channel is used as B channel.

    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 2 CCBs = 0 
    The Free Channel Mask:  0x0 
ISDN Serial5/1:23 interface
         dsl 3, interface ISDN Switchtype = primary-dms100 :
 Group member of nfas group 1 
    Layer 1 & 2 Status Not Applicable

!--- NFAS member-channel is used as B channel.

    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 3 CCBs = 0 
    The Free Channel Mask:  0x80000000 
    Total Allocated ISDN CCBs = 23

Note: The show isdn status output only displays information concerning the the D channel for the primary and the backup controllers. Also, only the primary D channel (Serial4/0:23) shows ACTIVE and MULTIPLE FRAME ESTABLISHED. The backup D channel status (Serial4/1:23) appears as DEACTIVATED and TEI_ASSIGNED.

The show isdn status output for Layer 1 and Layer 2 for the T1 5/0 and 5/1 are designated NOT APPLICABLE because the 24th channel (Serial5/0:23 and Serial 5/1:23) is being used as a B channel.

Here is the show isdn nfas group command output:

Router#show isdn nfas group 1 
ISDN NFAS GROUP 1 ENTRIES:The primary D is Serial4/0:23.    
The backup D is Serial4/1:23.    
The NFAS member is Serial5/0:23.    
The NFAS member is Serial5/1:23. 
There are 4 total nfas members.    
There are 68 total available B channels. 
The primary D-channel is DSL 0 in state IN SERVICE. 
The backup D-channel is DSL 1 in state OUT OF SERVICE. 
The current active layer 2 DSL is 0.

Note: The show isdn nfas group output shows the members of the group. The output shows that controller 4/0 is the primary and 4/1 is the backup. Controllers 5/0 and 5/1 are members of the group and have 24 B channels available to them.

The output also shows the total number of NFAS members and the number of channels available. It shows that the primary D channel is In Service while the backup is Out of Service.

Here is an example of a show isdn service command output:

Router# show isdn service 
PRI Channel Statistics:
 ISDN Se4/0:23, Channel [1-24]
      Configured Isdn Interface (dsl) 0
      Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
      0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 3
      Service State (0=Inservice 1=Maint 2=Outofservice)
      0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 
 ISDN Se4/1:23, Channel [1-24]
     Configured Isdn Interface (dsl) 1
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
     2 2 0 2 2 2 2 2 2 2 2 2 2 2 2 0 0 2 2 2 2 2 0 3  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 2 0 0 0 0 0 0 0 0 0 0 0 0 2 2 0 0 0 0 0 0 0  
ISDN Se5/0:23, Channel [1-24] 
     Configured Isdn Interface (dsl) 2 
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)    
     2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0  
ISDN Se5/1:23, Channel [1-24] 
     Configured Isdn Interface (dsl) 3 
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)    
     2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0  
Router#

The show isdn service output shows that the D channels for the primary and secondary are in state 3, which corresponds to Reserved. The D channels for the other members are in state 2, which indicates they are Busy and in use as B channels. A channel state of 0 indicates that the channel is available for use.

Note: In many devices (most commonly Access Servers) the Service State for the D channel is 2, indicating that the channel is Out of Service. This is a cosmetic issue and should not affect your connection. To determine whether the D channel is actually functioning use the show isdn status command as previously described

For controllers that are not designated as primary or backup (5/0 and 5/1), ensure that the 24th channel is in the Idle or Busy state. It should not be in the Reserved state.

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Commands

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

Note: Before issuing debug commands, refer to Important Information on Debug Commands:

  • debug isdn q931 - Show call setup and tear down of the ISDN network connection (Layer 3).

  • debug isdn q921 - Show data link layer messages (Layer 2) on the D channel between the router and the ISDN switch. Use this debug if the show isdn status command does not display Layer 1 and Layer 2 up.

If the Controller is Shut

What happens when the controller belonging to an NFAS group is shut? All the active calls on that shut controller will be cleared, and one of the following will apply:

  • If the shut controller is the primary and no backup is configured, all the active calls on the whole group are cleared.

  • If the shut controller is the primary, the active (IN SERVICE) D channel is on the primary, and a backup is configured, the active D channel switches to the backup controller.

  • If the shut controller is the primary and the active (IN SERVICE) D channel is on backup, the active D channel stays on the backup controller.

  • If the shut controller is the backup and the active D channel is on backup, the active D channel changes to the primary controller.

Note: The active D channel changeover between primary and backup controllers happens only when either of the links fail and not when the link comes up.

Related Information

Updated: Sep 15, 2005
Document ID: 9584