Guest

Asynchronous Connections

Configuring Dialout using a Modem on the AUX Port

Document ID: 5465

Updated: Mar 02, 2005

   Print

Introduction

This document shows how to use a modem on the AUX port to configure dialout. In this scenario, a router with a modem on the AUX port dials the Primary Rate Interface (PRI) of the central site router.

Note: We do not depict a backup scenario, but merely show dial-on-demand routing (DDR) dialup between routers with a modem on the AUX port.

Prerequisites

Requirements

Before attempting this configuration, ensure that you understand the various issues associated with modems on AUX ports. For more information on these issues, see Modem-Router Connection Guide.

Components Used

The information in this document is based on these software and hardware versions:

  • A Cisco 2600 Series Router that runs Cisco IOS?? Software Release 12.1(2).

  • A Cisco AS5300 Router that runs Cisco IOS Software Release 12.0(7)T.

Note: This configuration can be applied to any router with an AUX port or even a console port. However, due to RS232 modem control issues and some security related issues, it is not recommended to attach a modem to the console port. See the Modem-Router Connection Guide for more information.

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in the diagram below.

mod-aux-dialout.gif

Configurations

This document uses these configurations:

  • maui-slt-01 (2600)

  • maui-nas-03 (5300)

In this configuration, maui-slt-01(2600), uses the modem on the AUX port to dial the PRI of maui-nas-03 (an AS5300). The NAS (maui-nas-03) is configured to send the call to an internal digital modem.

maui-slt-01 (2600)
maui-slt-01#show running-config 
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-slt-01
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for PPP calls.

enable secret 5 <deleted>
!
username admin password 0 <deleted>
username maui-nas-03 password 0 cisco

!--- Defines username for remote router (maui-nas-03), and shared secret 
!--- password. Shared secret (used for CHAP authentication)
!--- must be the same on both sides.

!
memory-size iomem 30
ip subnet-zero
!
chat-script Dialout ABORT ERROR ABORT BUSY "" 
"AT" OK "ATDT \T" TIMEOUT 45 CONNECT \c

!--- Sets up chat script "Dialout" used for the dialout connection on aux 0.

modemcap entry MY_USR_MODEM:MSC=&F1S0=1

!--- Modemcap (MY_USR_MODEM) is applied to the AUX port line interface.
!--- This modemcap was created through the command:
!--- modemcap edit MY_USR_MODEM miscellaneous &F1S0=1
!--- See the Modem-Router Connection Guide for more information.

!
interface Loopback0
 ip address 172.17.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.16.1.1 255.255.255.0
 no keepalive
 duplex auto
 speed auto
!

!--- Irrelevant output has been removed.

!
interface Async65

!--- Async interface that corresponds to the AUX Port. 
!--- This was determined through the show line command.
!--- See External Modem Setup and Troubleshooting Tasks for more information.

 no ip address
 encapsulation ppp

!--- Use PPP encapsulation over this link.

 dialer in-band
 dialer pool-member 20

!--- Designate Async65 as member of dialer pool 20.
!--- The dialer pool 20 command is specified in interface Dialer 10.

 async default routing

!--- This permits routing over the async interface.
!--- This is required for a routing protocol to run accross the async link.

 ppp authentication chap callin
!
interface Dialer10

!---Dialer 10 is the logical interface for Dialer Pool 20.

 ip unnumbered Loopback0

!--- This uses the Loopback 0 IP address.

 encapsulation ppp
 ip ospf demand-circuit
 dialer remote-name maui-nas-03

!--- This specifies the remote router name. 
!--- This name must match the name that the remote router uses for 
!--- authentication.

 dialer pool 20

!--- Async 65 is a member of this pool.

 dialer idle-timeout 900
 dialer string 81690

!--- This defines the phone number of the destination router.

 dialer max-call 4096
 dialer-group 1

!--- Apply the definition of interesting traffic from dialer-list 1.


 ppp authentication chap callin

!--- Use CHAP authentication for incoming calls.

!
router ospf 5
 network 172.16.1.0 0.0.0.255 area 0
 network 172.17.1.0 0.0.0.255 area 0
 network 172.22.1.0 0.0.0.255 area 0

!---OSPF is used between the routers.
!---A routing protocol is unnecessary if you configure appropriate static routes.

!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer10

!--- Default route points to int dialer 10. 
!--- This is necessary because OSPF is not configured to send default routes.

no ip http server
!
access-list 101 remark Define Interesting Traffic
access-list 101 deny   ospf any any
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101

!--- Use access list 101 for interesting traffic definition.
!--- This is applied to interface Dialer 10 through dialer-group 1.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
!
line aux 0

!--- Line interface for the AUX port.

 exec-timeout 0 0

!--- This disables exec timeout on the interface.

 script dialer Dialout

!--- Use chat script "Dialout".

 modem InOut

!--- This enables incoming and outgoing calls.

 modem autoconfigure type MY_USR_MODEM

!--- Now apply the modemcap MY_USR_MODEM that you configured previously.

 transport input all
 stopbits 1

!--- Reduce async framing overhead to improve throughput. 

 speed 115200

!--- The AUX port on the 2600 supports a speed of 115200.
!--- Note: If you route through the AUX port, each character generates a 
!--- processor interrupt. This is an abnormally high load on the CPU, 
!--- which can be resolved if you use a lower AUX port speed.

 flowcontrol hardware

!--- This configures RTS/CTS flow control.

line vty 0 4
!
no scheduler allocate
end

maui-nas-03 (5300)
maui-nas-03#show running-config 
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-nas-03
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for PPP calls.

enable secret 5 <deleted>
!
username admin password 0 <deleted>
username maui-slt-01 password 0 cisco

!--- Defines username for remote router (maui-slt-01) and shared secret password.
!--- Shared secret(used for CHAP authentication) must be the same on both sides.

spe 1/0 1/7
 firmware location system:/ucode/mica_port_firmware
!
ip subnet-zero
!
isdn switch-type primary-ni
mta receive maximum-recipients 0
!
controller T1 0

!--- Primary T1.

 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!

!--- Irrelevant output has been removed.

!
interface Loopback0
 ip address 172.22.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 172.22.53.105 255.255.255.0
 no ip directed-broadcast
 no keepalive
!

!--- Irrelevant output has been removed.

!
interface Serial0:23

!--- D-channel for T1 0.

 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type primary-ni
 isdn incoming-voice modem

!--- This sends incoming async calls to the modems.

 fair-queue 64 256 0
 ppp authentication chap
!         

!--- Irrelevant output has been removed.

!
interface Group-Async0

!--- Group-Async interface is used to aggregate the modems.

 ip unnumbered Loopback0
 no ip directed-broadcast
 encapsulation ppp
 ip ospf network point-to-point

!--- This identifies the type of OSPF network. 

 async default routing

!--- This permits routing over the async interface.
!--- It is required for a routing protocol to run on the async link.

 async mode interactive
 peer default ip address pool clientpool

!--- This assigns an IP address from the pool named "clientpool" for the
!--- incoming call.

 ppp authentication chap
 group-range 1 96
!
router ospf 5
 network 172.22.1.0 0.0.0.255 area 0
 network 172.22.53.0 0.0.0.255 area 0
!
ip local pool clientpool 172.22.1.2 172.22.1.30

!--- IP addresses for dialin calls are given from this pool.

ip classless
no ip http server
!
line con 0
 login authentication NO_AUTHEN
 transport input none
line 1 96
 autoselect ppp
 modem InOut
 transport preferred lat pad telnet rlogin udptn v120 lapb-ta
 transport output lat pad telnet rlogin udptn v120 lapb-ta
line aux 0
line vty 0 4
!
end

Note: maui-nas-03 is not specially configured to accept calls only from maui-slt-01(the client). From the point of view of the NAS (maui-nas-03), the incoming call is just another dialin client. This configuration can be used for many remote clients to dial the PRI of the central site NAS, and connect to the corporate network.

Verify

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

Sample Show Output

Use the show ip route command to verify whether there is a route to the dialer or async interface. If there is no route to the async or dialer interface dialing cannot occur. Therefore, configure static routes as necessary.

maui-slt-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 is directly connected, Dialer10

Note: There is a default route to the dialer interface.

The router then initiates the dial, connect, negotiate PPP, and exchange the OSPF database. For more details on this process see the debug information that follows:

Use the show ip route command after the connection is successful. In this scenario, the routing protocol OSPF is used. Observe the OSPF routes added to the routing table.

maui-slt-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/1795] via 172.22.1.1, 00:00:03, Dialer10
C       172.22.1.1/32 is directly connected, Dialer10
S*   0.0.0.0/0 is directly connected, Dialer10

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

External Modem Setup and Troubleshooting Tasks

Complete these steps to setup the external modem and verify that the modem functions correctly. When you verify that the router can dial and connect with the help of this modem, the necessary DDR configuration as well as the PPP configuration and other higher level protocol configurations can be done on the router dialing out. This section assumes that the router that receives the call is configured correctly, as shown above.

  1. Attach the appropriate cable from the the AUX port to modem. For more information on cabling options, see the Modem-Router Connection Guide.

  2. Use the show line command to determine the async interface of the AUX port. Though most routers have the AUX port as interface async 1, Access servers have the AUX port interface after the TTY lines. For example, if your router has 16 async or modem lines, the AUX port is line 17. In such a case, the AUX port must be configured on interface async 17. Configure the AUX port based on the show line outputs. This example verifies that on maui-slt-01 the AUX port configuration is on interface Async65.

    maui-slt-01#show line
       Tty Typ   Tx/Rx    A Modem  Roty AccO AccI  Uses  Noise  Overruns  Int
    *    0 CTY            -    -      -    -    -     0      0     0/0      -
        65 AUX 9600/9600  -    -      -    -    -     0      1     0/0      -
        66 VTY            -    -      -    -    -     0      0     0/0      -
        67 VTY            -    -      -    -    -     0      0     0/0      -
        68 VTY            -    -      -    -    -     0      0     0/0      -
        69 VTY            -    -      -    -    -     0      0     0/0      -
        70 VTY            -    -      -    -    -     0      0     0/0      -
    
    Line(s) not in async mode -or- with no hardware support: 
    1-64
  3. Configure a modemcap for the modem connected to the AUX port. Refer to Modem-Router Connection Guide for the appropriate initialization string to be used for the modem platform. Create a new modemcap that includes that initialization (init) string. Here is an example for a new modemcap (named MY_USR_MODEM):

    maui-slt-01(config)#modemcap edit MY_USR_MODEM miscellaneous &F1S0=1

    In the above modemcap configuration &F1S0=1 is the init string. Refer to Creating a Modemcap for specific information on the init string appropriate for your modem.

  4. Apply the modemcap to the AUX port. We have previously verified that the AUX port is on line 65.

    maui-slt-01(config)#line 65
    maui-slt-01(config-line)#modem autoconfigure type MY_USR_MODEM

    You should also configure the AUX port line for modem connectivity. Refer to the Modem-Router Connection Guide for information on the line configuration. The sample configuration for maui-slt-01 shown previously also includes the necessary commands.

    Use debug confmodem to verify whether the modemcap is correctly applied. After you power cycle the modem, the router automatically configures the modem.

    maui-slt-01#debug confmodem
    Modem Configuration Database debugging is on
    maui-slt-01#
    
    !--- Power cycle the modem.
    
    *Mar  1 06:58:10.118: TTY65: detection speed (115200) response ---OK---
    *Mar  1 06:58:10.122: TTY65: Modem command:  --AT&F1S0=1--
    
    !--- Apply the init string specified in the modemcap.
    
    *Mar  1 06:58:10.758: TTY65: Modem configuration succeeded
    
    !--- Modem configuration is successful.
    
    *Mar  1 06:58:10.758: TTY65: Detected modem speed 115200
    *Mar  1 06:58:10.758: TTY65: Done with modem configuration
    maui-slt-01#
  5. Issue the show line aux 0 or show line aux-line command. Verify that all signals are up. For example, CTS, RTS, DTR, CD. If nothing appears next to them, they are up. If "No" appears next to them (for example, No CTS), it means they are down. If they are down, verify the the cable and configuration on the router. Also check whether you have the async interface and the line of the AUX port configured correctly. For more information on the cabling, refer to the Modem Router Connection Guide. Use the document on Troubleshooting Dialin Connections for information on how to troubleshoot issues. Here is an example:

    maui-slt-01#show line 65
       Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
    A   65 AUX 115200/115200- inout     -    -    -      8       1     1/0       -
      Ready
    
    Line 65, Location: "PPP: 172.22.1.1", Type: ""
    Length: 24 lines, Width: 80 columns
    Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits
    Status: Ready, Active, No Exit Banner, Async Interface Active
      Modem Detected, CTS Raised, Modem Signals Polled
    Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
      Modem Callout, Modem RI is CD, Modem Autoconfigure
    Modem state: Ready
    Group codes:    0
    Line is running PPP routing for address 172.22.1.1.
    0 output packets queued, 1 input packets.
     Async Escape map is 00000000000000000101000000000000
    Modem hardware state: CTS* DSR*  DTR RTS
    
    !--- All signals are up.
    
     TTY NUMBER 65
    Parity Error = 0 Framing Error = 536 Receive Error = 536 Overrun = 1
    Outcount = 0 totalout = 40615 incount = 0 totalin = 49805
    , Modem Configured
    Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation
                    ^^x    none   -     -       none                   
    Timeouts:    Idle EXEC    Idle Session   Modem Answer  Session   Dispatch
                 00:10:00        never                        none    not set
                              Idle Session Disconnect Warning
                                never 
                              Login-sequence User Response
                               00:00:30
                              Autoselect Initial Wait
                                not set 
    Modem type is MY_USR_MODEM.
    
    !--- Modemcap is MY_USR_MODEM.
    
    Session limit is not set.
    Time since activation: never
    Editing is enabled.
    History is enabled, history size is 10.
    DNS resolution in show commands is enabled
    Full user help is disabled
    Allowed transports are lat pad v120 mop telnet rlogin nasi. 
    Preferred is lat.
    No output characters are padded
    No special data dispatching characters
    maui-slt-01# 
  6. Perform r

    everse Telnet out the AUX port to the modem, and use the AT command set to manually dial and connect to the remote device. This can be used to verify that the modem hardware and telephone circuit function properly. In this example, because the AUX port is on line 65, you must reverse telnet to port 2065 on the router. For more information on Reverse Telnets refer to Establishing a Reverse Telnet Session to a Modem.

    maui-slt-01#telnet 172.17.1.1 2065 
    Trying 172.17.1.1, 2065 ...Open
    
    User Access Verification
    
    Username: admin Password:
    
    !--- Authentication performed by local router for the reverse Telnet.
    
    at
    OK
    atdt 81690 
    
    !--- The modem dials (81690), and connects. 
    !--- This process takes approximately 30 to 45 seconds.
    
    CONNECT 31200/ARQ/V34/LAPM/V42BIS
    
    !--- Connection speed and protocols that were negotiated.
    
    User Access Verification
     
    Username: maui-slt-01
    Password:
    
    !--- Authentication performed by the remote router for the incoming call.
    
    
    
    maui-nas-03>
    
    !--- Prompt on the remote router.
    
    

    As shown above, we perform reverse Telnet to the modem, and use the at command to verify whether the modem responds. When you receive the OK, dial the remote number with the help of the atdt number command. The call proceeds, and connects to the remote device. The remote router then authenticates the incoming call. If you observe that the external modem does not dial, verify that the cabling is correct, that the external modem is not faulty, and that the phone line is active. Refer to Configuring Modem Support and Other Asynchronous Features and Troubleshooting Dialin Connections for more information.

    When you have completed the above tasks and procedures, you can proceed to test whether the router can bring up the dialup connection automatically. Refer to the Sample Show Output and Sample Debug Output sections of theConfiguring Dialout using a Modem on the AUX Port document for more information.

Troubleshooting Commands

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

Note: Before issuing debug commands, please see Important Information on Debug Commands.

  • debug dialer???displays debug information about the packets received on a dialer interface. When DDR is enabled on the interface, information that concerns the cause of any call (called the Dialing cause) is also displayed. For more information, see the debug dialer command in debug clns - debug fras.

  • debug modem???displays the modem line activity, modem control and process activation messages on the router.

  • debug chat???monitors the execution of the chat script when async/POTS dialing is initiated. Refer to the Async Outbound Calling - Verify Chat Script Operation section of Dialup Technology: Troubleshooting Techniques for more information.

  • debug ppp negotiation???displays information on PPP traffic and exchanges as it negotiates the PPP components such as, Link Control Protocol (LCP), Authentication, and Network Control Protocol (NCP). A successful PPP negotiation first opens the LCP state, then Authenticates, and finally negotiates NCP.

  • debug ppp authentication???displays the PPP authentication protocol messages, that include Challenge Authentication Protocol (CHAP) packet exchanges and Password Authentication Protocol (PAP) exchanges.

Sample Debug Output

Use these debug commands to troubleshoot the connection:

maui-slt-01#debug dialer
Dial on demand events debugging is on
maui-slt-01#debug chat
Chat scripts activity debugging is on
maui-slt-01#debug modem
Modem control/process activation debugging is on
maui-slt-01#debug ppp negotiation
PPP protocol negotiation debugging is on
maui-slt-01#debug ppp authentication
PPP authentication debugging is on       
maui-slt-01#
maui-slt-01#show debug
General OS:
  Modem control/process activation debugging is on
Dial on demand:
  Dial on demand events debugging is on
PPP:
  PPP authentication debugging is on
  PPP protocol negotiation debugging is on
Chat Scripts:
  Chat scripts activity debugging is on
maui-slt-01#
maui-slt-01#ping 172.22.53.105

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.22.53.105, timeout is 2 seconds:

*Mar  1 05:37:44.858: As65 DDR: rotor dialout [priority]
*Mar  1 05:37:44.858: As65 DDR: Dialing cause ip (s=172.17.1.1, d=172.22.53.105)

!--- Dialing reason.

*Mar  1 05:37:44.858: As65 DDR: Attempting to dial 81690

!--- Phone number that is dialed.

*Mar  1 05:37:44.858: CHAT65: Attempting async line dialer script
*Mar  1 05:37:44.858: CHAT65: Dialing using Modem script: Dialout
 & System script: none

!--- Use the chat-script "Dialout".

*Mar  1 05:37:44.862: CHAT65: process started
*Mar  1 05:37:44.862: CHAT65: Asserting DTR
*Mar  1 05:37:44.862: TTY65: Set DTR to 1
*Mar  1 05:37:44.862: CHAT65: Chat script Dialout started

!--- Chat-script "Dialout" has started.

*Mar  1 05:37:44.862: CHAT65: Sending string: AT
*Mar  1 05:37:44.862: CHAT65: Expecting string: OK
*Mar  1 05:37:44.990: CHAT65: Completed match for expect: OK
*Mar  1 05:37:44.990: CHAT65: Sending string: ATDT \T<81690>
*Mar  1 05:37:44.990: CHAT65: Expecting string: CONNECT
*Mar  1 05:38:02.774: CHAT65: Completed match for expect: CONNECT
*Mar  1 05:38:02.774: CHAT65: Sending string: \c
*Mar  1 05:38:02.774: CHAT65: Chat script Dialout finished, status = Success

!--- Chat script is successful. 
!--- Notice the Expect/Send Attributes and the time elapsed.

*Mar  1 05:38:02.774: TTY65: destroy timer type 1
*Mar  1 05:38:02.778: TTY65: destroy timer type 0
*Mar  1 05:38:04.778: %LINK-3-UPDOWN: Interface Async65, changed state to up
*Mar  1 05:38:04.778: Async65 DDR: Dialer statechange to up
*Mar  1 05:38:04.778: %DIALER-6-BIND: Interface As65 bound to profile Di10
*Mar  1 05:38:04.782: Async65 DDR: Dialer call has been placed
*Mar  1 05:38:04.782: As65 PPP: Treating connection as a callout

!--- PPP LCP negotiation begins.

*Mar  1 05:38:04.782: As65 PPP: Phase is ESTABLISHING, Active Open
*Mar  1 05:38:04.782: As65 PPP: No remote authentication for call-out
*Mar  1 05:38:04.782: As65 LCP: O CONFREQ [Closed] id 43 len 20
*Mar  1 05:38:04.782: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:04.782: As65 LCP:    MagicNumber 0x314EFEBB (0x0506314EFEBB)
*Mar  1 05:38:04.786: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:04.786: As65 LCP:    ACFC (0x0802)
*Mar  1 05:38:06.782: As65 LCP: TIMEout: State REQsent
*Mar  1 05:38:06.782: As65 LCP: O CONFREQ [REQsent] id 44 len 20
*Mar  1 05:38:06.782: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:06.782: As65 LCP:    MagicNumber 0x314EFEBB (0x0506314EFEBB)
*Mar  1 05:38:06.782: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:06.782: As65 LCP:    ACFC (0x0802)
*Mar  1 05:38:08.782: As65 LCP: TIMEout: State REQsent
*Mar  1 05:38:08.782: As65 LCP: O CONFREQ [REQsent] id 45 len 20
*Mar  1 05:38:08.782: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:08.782: As65 LCP:    MagicNumber 0x314EFEBB (0x0506314EFEBB)
*Mar  1 05:38:08.782: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:08.782: As65 LCP:    ACFC (0x0802)

!--- Observe that two outgoing CONFREQs timed out.
!--- If you observe such a situation with no incoming CONFREQs, verify that the 
!--- autoselect ppp or async mode dedicated commands are configured
!--- on the router that receives the call.

*Mar  1 05:38:08.934: As65 LCP: I CONFREQ [REQsent] id 2 len 25
*Mar  1 05:38:08.934: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:08.934: As65 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 05:38:08.934: As65 LCP:    MagicNumber 0x515A1AC7 (0x0506515A1AC7)
*Mar  1 05:38:08.938: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:08.938: As65 LCP:    ACFC (0x0802)
*Mar  1 05:38:08.938: As65 LCP: O CONFACK [REQsent] id 2 len 25
*Mar  1 05:38:08.938: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:08.938: As65 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 05:38:08.938: As65 LCP:    MagicNumber 0x515A1AC7 (0x0506515A1AC7)
*Mar  1 05:38:08.938: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:08.938: As65 LCP:    ACFC (0x0802)
*Mar  1 05:38:08.942: As65 LCP: I CONFACK [ACKsent] id 45 len 20
*Mar  1 05:38:08.946: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:08.946: As65 LCP:    MagicNumber 0x314EFEBB (0x0506314EFEBB)
*Mar  1 05:38:08.946: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:08.946: As65 LCP:    ACFC (0x0802)
*Mar  1 05:38:08.946: As65 LCP: State is Open
*Mar  1 05:38:08.946: As65 PPP: Phase is AUTHENTICATING, by the peer
*Mar  1 05:38:09.066: As65 CHAP: I CHALLENGE id 1 len 32 from "maui-nas-03"
*Mar  1 05:38:09.066: As65 CHAP: O RESPONSE id 1 len 32 from "maui-slt-01"
*Mar  1 05:38:09.206: As65 CHAP: I SUCCESS id 1 len 4

!--- CHAP authentication is successful.

*Mar  1 05:38:09.206: As65 PPP: Phase is UP
*Mar  1 05:38:09.210: As65 IPCP: O CONFREQ [Not negotiated] id 13 len 10
*Mar  1 05:38:09.210: As65 IPCP:    Address 172.17.1.1 (0x0306AC110101)
*Mar  1 05:38:09.218: As65 IPCP: I CONFREQ [REQsent] id 1 len 10
*Mar  1 05:38:09.218: As65 IPCP:    Address 172.22.1.1 (0x0306AC160101)
*Mar  1 05:38:09.218: As65 IPCP: O CONFACK [REQsent] id 1 len 10
*Mar  1 05:38:09.218: As65 IPCP:    Address 172.22.1.1 (0x0306AC160101)
*Mar  1 05:38:09.350: As65 IPCP: I CONFNAK [ACKsent] id 13 len 10
*Mar  1 05:38:09.350: As65 IPCP:    Address 172.22.1.9 (0x0306AC160109)
*Mar  1 05:38:09.350: As65 IPCP: O CONFREQ [ACKsent] id 14 len 4
*Mar  1 05:38:09.478: As65 IPCP: I CONFACK [ACKsent] id 14 len 4
*Mar  1 05:38:09.478: As65 IPCP: State is Open

!--- IPCP negotiation is complete.

*Mar  1 05:38:09.482: As65 DDR: dialer protocol up
*Mar  1 05:38:09.482: Di10 IPCP: Install route to 172.22.1.1
*Mar  1 05:38:10.206: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65,
 changed state to up

!--- Interface is up.

Related Information

Updated: Mar 02, 2005
Document ID: 5465