Guest

Cisco ASR 1000 Series Aggregation Services Routers

RFC 2544 Latency Testing on Cisco ASR 1000 Series

  • Viewing Options

  • PDF (822.8 KB)
  • Feedback
This whitepaper examines and analyses traffic latency on the Cisco ASR 1000 Series Routers. The Cisco ASR 1000 has three forwarding engines known as Cisco ® ASR 1000 Series Embedded Services Processors (ESPs). This document will review the latency of two of those ESP forwarding engines, specifically the 10-Gbps Cisco ASR 1000 Series ESP (ASR1000-ESP10) and 20-Gbps Cisco ASR 1000 Series ESP (ASR1000-ESP20) forwarding engines. The goal of this whitepaper is to highlight how different forwarding rates impact the latency of the Cisco ASR 1000. This document highlights some of the choices that you must make while designing your network. This document covers the impact on overall latency relating to queuing, shaping and QoS which can impact the overall performance of your network.
The ASR1000-ESP20 was profiled in a WAN aggregation topology with services enabled to gain insight of how the system latency is affected while approaching the throughput non-drop rate (NDR).
This paper delivers results in two parts:

Phase 1: Reporting RFC 2544 latency results for IP routing with and without services enabled as detailed in the RFC 2544 Test Setup. The results reported are the latency at the calculated NDR for that packet size/test.

Phase 2: Profiling latency for different frame sizes at data points approaching the NDR in a WAN aggregation topology, in order to clearly illustrate and analyze the behaviour of the system.

Test results obtained from this testing are based on Cisco IOS XE release 2.2.2 for all tests. The routers were tested using procedures based on RFC 2544 Latency Testing.

Background on the RFC 2544 Latency Test

In the Latency Test, frames are transmitted for a fixed duration (120sec). Once per second, the test tags a frame and transmits it half way through the duration time. The test compares the tagged frame's timestamp when it was transmitted with the timestamp and when it was received. The difference between the two timestamps is the latency. The results taken will be the average latencies for 20 trials. To be certain of accurate results, the test was configured with a frame rate at which the Cisco ASR 1000 does not lose packets. RFC 2544 Throughput Test is performed; in order to know the maximum throughput rate. Results from the Throughput test will be used to choose a frame rate for the Latency test.

Model

ESP Type

LAN to LAN Connectivity

Traffic

Cisco ASR 1006

ASR1000-ESP10

GE-GE

IP

Cisco ASR 1006

ASR1000-ESP10

10 GE-10 GE

IP

Cisco ASR 1006

ASR1000-ESP20

GE-GE

IP

Cisco ASR 1006

ASR1000-ESP20

10 GE-10 GE

IP

Test Set-up Topologies

Refer to figure 1 for the RFC2544 latency testing topology. Figure 2 shows the WAN aggregation topology utilized for the RFC 2544 latency tests when services are enabled and not enabled.
The services configured for the test are; QoS queuing (and shaping) policy, access control lists, Netflow, uRPF and a dynamic routing protocol on each interface. The router learns, for the RFC2544 test, a nominal number of OSPF routes from it neighbors and must retain these adjacencies throughout the test. The configurations are further detailed in the configuration section below.

Figure 1. Physical topology for the RFC latency testing with and without features enabled.

Figure 2. Physical topology for the latency results in the WAN aggregation topology.

Figure 3 details the logical topology for the WAN aggregation latency test. In this test the services detailed in the prior paragraph are configured on the ASR1000-ESP20. However, in this instance the services are configured on all 205 sub-interfaces requiring a shaper to be configured on all 205 interfaces. In addition, the number of routes and routing adjacencies are significantly higher as detailed below in figure 3. The goal of this test topology was to utilize a likely deployed topology to examine latency under stress conditions. Traffic was sent to all 300,000 routes on all 205 interfaces, which allows for 120 million unique flows active during the test. In this situation all services, including Netflow, uRPF and QoS are subjected to a much higher load than normally found in static tests or real world WAN topologies.

Figure 3. Logical topology for the latency results in the WAN aggregation topology

RFC2544 Test Results and Analysis

All traffic sent in these tests is bidirectional and reported as such. All traffic being sent is default class or routine traffic. For the ASR1000-ESP10 the system bandwidth is 10Gbps, hence the NDR for the 10G test for ASR1000-ESP10 is 50% of line rate. 40,000 nanoseconds (ns) = .04 milliseconds (ms), 40000 nanoseconds (ns) = 40 microseconds (uSec)

Table 1. RFC2544 ASR1000-ESP10 Gigabit Ethernet Testing-No Services

Frame Size (bytes)

Agg Throughput (fps)

Max Throughput (fps)

Agg Throughput (Mbps)

Max Throughput (Mbps)

Agg Throughput (% Line Rate)

Agg Min Latency (ns)

Agg Max Latency (ns)

Agg Avg Latency (ns)

64

2976190

1488095

1523.809

761.905

100

19800

48760

45445

128

1689189

844594.3

1729.729

864.865

100

20820

49380

45968

256

905796.9

452898.4

1855.072

927.536

100

23980

50760

47124

512

469924.7

234962.3

1924.812

962.406

100

26640

55140

50876

1024

239463.5

119731.8

1961.685

980.843

100

33880

64460

59004

1280

192307.7

96153.83

1969.23

984.615

100

36380

63460

59490

1518

162548.7

81274.37

1973.992

986.996

100

39200

68320

64639

Table 2. RFC2544 ASR1000-ESP10 Gigabit Ethernet Testing -With Services (Non-Shaping QoS)

Frame Size (bytes)

Agg Throughput (fps)

Max Throughput (fps)

Agg Throughput (Mbps)

Max Throughput (Mbps)

Agg Throughput (% Line Rate)

Agg Min Latency (ns)

Agg Max Latency (ns)

Agg Avg Latency (ns)

64

2976190

1488095

1523.809

761.905

100

34740

56760

54275

128

1689189

844594.4

1729.729

864.865

100

30740

56460

54688

256

905796.8

452898.4

1855.072

927.536

100

32360

60000

55723

512

469924.7

234962.4

1924.812

962.406

100

41860

64480

59230

1024

239463.5

119731.8

1961.685

980.843

100

42520

70940

67424

1280

192307.7

96153.83

1969.23

984.615

100

45760

70960

67564

1518

162548.7

81274.37

1973.992

986.996

100

48400

75260

72632

Table 3. RFC2544 ASR1000-ESP10 Gigabit Ethernet Testing-With Services (Shaping with QoS)

Frame Size (bytes)

Agg Throughput (fps)

Max Throughput (fps)

Agg Throughput (Mbps)

Max Throughput (Mbps)

Agg Throughput (% Line Rate)

Agg Min Latency (ns)

Agg Max Latency (ns)

Agg Avg Latency (ns)

64

2976179

1488093

1523.804

761.903

100

36160

520980

315465

128

1689183

844593

1729.724

864.863

100

32980

469760

313213

256

905794.1

452897.2

1855.066

927.533

100

34420

487060

374726

512

469923.6

234961.8

1924.807

962.404

100

35820

439860

344002

1024

239462.6

119731.5

1961.678

980.841

100

50560

598100

410995

1280

192306.9

96153.49

1969.223

984.612

100

48060

485720

350397

1518

162548.3

81274.18

1973.987

986.994

100

50040

437960

342856

Table 4. RFC2544 ASR1000-ESP10 Ten Gigabit Ethernet Testing-No Services

Frame Size (bytes)

Agg Throughput (fps)

Max Throughput (fps)

Agg Throughput (Mbps)

Max Throughput (Mbps)

Agg Throughput (% Line Rate)

Agg Min Latency (ns)

Agg Max Latency (ns)

Agg Avg Latency (ns)

64

14880949

7440475

7619.046

3809.523

50

17700

47220

21927

128

8445948

4222974

8648.651

4324.326

50

17980

47500

23250

256

4528985

2264493

9275.361

4637.681

50

18800

48260

24857

512

2349624

1174812

9624.06

4812.03

50

20260

49600

26895

1024

1197318

598659

9808.429

4904.215

50

23080

51780

30072

1280

961538.4

480769.2

9846.154

4923.077

50

24360

53800

31447

1518

812743.8

406371.9

9869.96

4934.98

50

25500

55360

32754

Table 5. RFC2544 ASR1000-ESP10 Ten Gigabit Ethernet Testing-With Services (Non-Shaping QoS)

Frame Size (bytes)

Agg Throughput (fps)

Max Throughput (fps)

Agg Throughput (Mbps)

Max Throughput (Mbps)

Agg Throughput (% Line Rate)

Agg Min Latency (ns)

Agg Max Latency (ns)

Agg Avg Latency (ns)

64

9226193

4613097

4723.811

2361.906

31

26320

57160

29905

128

8445947

4222974

8648.65

4324.325

50

26980

62940

35372

256

4528985

2264492

9275.361

4637.681

50

27100

64880

36692

512

2349624

1174812

9624.061

4812.03

50

28180

66440

38534

1024

1197318

598659

9808.429

4904.215

50

31120

70540

41750

1280

961538.4

480769.2

9846.153

4923.077

50

32460

72060

43226

1518

811688.3

405844.1

9857.142

4928.571

50

33740

72520

44560

Table 6. RFC2544 ASR1000-ESP10 Ten Gigabit Ethernet Testing-With Services (Shaping with QoS)

Frame Size (bytes)

Agg Throughput (fps)

Max Throughput (fps)

Agg Throughput (Mbps)

Max Throughput (Mbps)

Agg Throughput (% Line Rate)

Agg Min Latency (ns)

Agg Max Latency (ns)

Agg Avg Latency (ns)

64

8333333

4166667

4266.666

2133.333

28

27860

473680

52847

128

8445942

4222974

8648.645

4324.325

50

28940

486280

119785

256

4528984

2264493

9275.359

4637.681

50

28600

486420

122446

512

2349622

1174811

9624.05

4812.028

50

29900

486460

127814

1024

1197317

598659

9808.425

4904.215

50

32900

488920

137298

1280

961537.9

480769.2

9846.148

4923.077

50

34180

491900

136665

1518

812743.4

406371.9

9869.956

4934.98

50

35460

491980

140409

Table 7. RFC2544 ASR1000-ESP20 Gigabit Ethernet Testing-No Services

Frame Size (bytes)

Agg Throughput (fps)

Max Throughput (fps)

Agg Throughput (Mbps)

Max Throughput (Mbps)

Agg Throughput (% Line Rate)

Agg Min Latency (ns)

Agg Max Latency (ns)

Agg Avg Latency (ns)

64

2976190

1488095

1523.809

761.905

100

17580

39700

36432

128

1689189

844594.4

1729.729

864.865

100

18900

40520

37173

256

905796.9

452898.4

1855.072

927.536

100

20440

41900

38904

512

469924.7

234962.4

1924.812

962.406

100

23980

45840

42691

1024

239463.6

119731.8

1961.685

980.843

100

30400

53240

49628

1280

192307.7

96153.84

1969.231

984.615

100

32840

46840

43482

1518

162548.7

81274.37

1973.992

986.996

100

36100

59040

55623

Table 8. RFC2544 ASR1000-ESP20 Gigabit Ethernet Testing-With Services (Non-Shaping QoS)

Frame Size (bytes)

Agg Throughput (fps)

Max Throughput (fps)

Agg Throughput (Mbps)

Max Throughput (Mbps)

Agg Throughput (% Line Rate)

Agg Min Latency (ns)

Agg Max Latency (ns)

Agg Avg Latency (ns)

64

2976190

1488095

1523.809

761.905

100

28220

44780

43130

128

1689189

844594.4

1729.729

864.865

100

25920

45320

43695

256

905796.9

452898.5

1855.072

927.536

100

27880

48380

45466

512

469924.7

234962.4

1924.812

962.406

100

31120

50820

49028

1024

239463.6

119731.8

1961.685

980.843

100

37520

58000

55724

1280

192307.7

96153.84

1969.231

984.615

100

40240

55500

49722

1518

162548.7

81274.37

1973.992

986.996

100

43500

63800

61676

Table 9. RFC2544 ASR1000-ESP20 Ten Gigabit Ethernet Testing-No Services

Frame Size (bytes)

Agg Throughput (fps)

Max Throughput (fps)

Agg Throughput (Mbps)

Max Throughput (Mbps)

Agg Throughput (% Line Rate)

Agg Min Latency (ns)

Agg Max Latency (ns)

Agg Avg Latency (ns)

64

20535701

10267852

10514.28

5257.14

69

15800

37900

20204

128

16891830

8445939

17297.23

8648.642

100

18540

447980

155395

256

9057938

4528982

18550.66

9275.355

100

18780

451080

157759

512

4699231

2349622

19248.05

9624.053

100

19140

453320

160180

1024

2394627

1197317

19616.79

9808.422

100

22620

455580

162461

1280

1923070

961537.8

19692.24

9846.147

100

23520

456500

163643

1518

1623376

811688.2

19714.28

9857.141

100

24380

46040

42693

Table 10. RFC2544 ASR1000-ESP20 Ten Gigabit Ethernet Testing-With Services (Non-Shaping QoS)

Frame Size (bytes)

Agg Throughput (fps)

Max Throughput (fps)

Agg Throughput (Mbps)

Max Throughput (Mbps)

Agg Throughput (% Line Rate)

Agg Min Latency (ns)

Agg Max Latency (ns)

Agg Avg Latency (ns)

64

12202381

6101191

6247.619

3123.81

41

22040

45340

25064

128

8943878

4526914

9158.532

4635.56

72

24460

53475

31045

256

9057937

4528981

18550.65

9275.353

100

25880

476700

176163

512

4699230

2349622

19248.05

9624.051

100

27420

478880

177912

1024

2394626

1197317

19616.78

9808.418

100

30140

484320

181518

1280

1923070

961537.6

19692.23

9846.145

100

31040

479420

180106

1518

1623376

811688.2

19714.28

9857.141

100

31920

53380

48921

The Tables above illustrate that the latency on the Cisco ASR 1000 platform at NDR is 20-30 microseconds without services. This is with the configuration detailed in table 12 below. Adding all of the services, as detailed in table 13, incurs only a 10usec delay as all services are performed on the QFP with hardware assists.
The ASR1000-ESP20 exhibits similar, though slightly lower latency when compared the ASR1000-ESP10 for the Gigabit ethernet testing, this is due to the fact that ASR1000-ESP20 is clocked slightly faster than ASR1000-ESP10. In the ten gigabit ethernet testing, the ASR1000-ESP20 can forward at the full 10Gbps bidirectional rate for packets greater than 200 bytes. With the ESP20 all interfaces are forwarding at line rate forcing an additional queuing operation at the interface level that is not realized on ASR1000-ESP10. (Note: Additional queuing not seen on ASR1000-ESP10 due to the bi-directional traffic flow allows 5Gbps on each 10Gbps interface) It is due to the 5Gbps transit on the ASR1000-ESP10 (see note) and the fact that the packet per second is doubled on the ASR1000-ESP20 from the ASR1000-ESP10 that the latency at NDR is around 100usecs higher for the ASR1000-ESP20 at NDR for 10Gbps testing.
When utilizing a hierachical QoS policy and shaping the latency increases by around 200usecs at NDR. Customers typically deploy shaping when configuring services on sub-interfaces or when a specific traffic rate is desired.  
In this test shaping is not explicitly required, but it is detailed to provide a comparison with a normal queuing policy. This minor increase in latency is due to the shaper monitoring the traffic rate and the allowed burst per interval, then queuing if the calculated rate is above the shaper rate for that time interval, or passing if it is below. At NDR, this equates to either the line rate of the Gig interface for the Gigabit Ethernet test, or the system bandwidth of 10Gbps. At these rates the shaper is quite naturally queuing traffic so as to not exceed the configured bandwidth and to average to the configured rate; it is this queuing at NDR that causes the increased latency. It is important to note that the goal of any shaper is to not drop any traffic, but instead to queue it as it is in this instance. This shaping capability and operation is a fundamental difference to the queuing normally configured on switches, where strict priority and weighted round robin are the configured. The main goal of shaping in any router platform is maximize throughput and control, or smooth, the traffic to the desired rate.
To simplify, when you configure a router to shape an interface and then oversubscribe the interface, the shaping will cause latency to rise. This is a normal and expected behavior of any router with queuing and shaping.
The latency when approaching NDR and the usage of differentiated classes of traffic is further explored in the WAN aggregation topology test, where same shaper configurations are configured on all 205 subinterfaces, along with all the other services.

WAN Aggregation Test Results and Analysis

The following table profiles the latency for two packet sizes at data points approaching NDR. The 256B and 1518B sizes were chosen as both can forward up to 100% line rate and together they represent a smaller and larger sized packet profile. It must be noted here that the 64B packet could forward at a similar rate and at a similar average latency to that detailed in table 10 previously. All traffic being sent is default class or routine traffic.

Table 11. ASR1000-ESP20 WAN Aggregation Testing-Tracking Latency Up To NDR with Services (Shaping QoS)

Frame Size
(bytes)

Load (%)

Tx Frame Rate (fps)

TxFrames

Rx Frames

Loss (%)

Latency Min (uSec)

Latency Avg (uSec)

Latency Max (uSec)

256

90

8138926

2440244180

2440244180

0

24.49

50.248

1151.8

256

91

8242754

2469908995

2469908995

0

24.45

52.204

1402.46

256

92

8333333

2500008355

2500008355

0

24.33

51.946

1205.01

256

93

8381762

2517370200

2517370200

0

24.54

53.42

1357.82

256

94

8485690

2544074130

2544074130

0

24.54

55.309

1142.58

256

95

8590314

2575015980

2575015980

0

24.63

57.418

1431.35

256

96

8695652

2606439830

2606439830

0

24.68

60.018

1267.87

256

97

8740396

2628470785

2628470785

0

24.51

62.953

1167.44

256

98

8845515

2651953030

2651953030

0

24.59

66.447

1322.03

256

99

8951366

2684403160

2684403160

0

24.96

73.196

1273.95

256

100

9057971

2717400515

2717400515

0

33.54

1179.081

2846.29

1518

90

1597567

479270100

479270100

0

29.53

99.23

481.87

1518

91

1605678

481703400

481703400

0

29.56

100.87

481.34

1518

92

1599576

479872800

479872800

0

29.67

101.39

483.85

1518

93

1623496

487048800

487048800

0

29.74

103.56

485.34

1518

94

1610984

483295200

483295200

0

29.73

103.98

491.98

1518

95

1599374

479812200

479812200

0

29.71

104.34

488.43

1518

96

1623465

487039500

487039500

0

29.74

106.76

490.22

1518

97

1613427

484028100

484028100

0

29.73

105.44

491.23

1518

98

1591964

477497848

477497848

0

29.74

106.277

497.11

1518

99

1608198

482387054

482387054

0

29.73

114.08

521.04

1518

100

1624432

487331255

487331255

0

30.06

132.71

806.7

The table above clearly shows that the latency remains low up to 99% of NDR, which in this case is the line rate bi-directional 10Gbps traffic. (Note: Even though there is a shaper and queuing operation configured it has no impact on the forwarding latency up to the point where it actually is in effect- 100% of load)  It is interesting to note that even at 99% of line rate the latency for both packet sizes is in the order of 50 to 100usecs. At or very close to NDR there is some queuing in effect with a shaper rate configured actively enforcing the burst rate and queuing accordingly. What is important to realize is that up until the point that the shaper is actually queuing traffic the latency remains low and deterministic, as illustrated in the charts below and table above, it is only at NDR that the shaper will begin queuing and hence the latency will increase ~ 200usec.
In the scenario where the traffic is approaching the NDR, or is in fact congested, then It is the goal of any routing platform to buffer non-priority traffic and maintain the throughput rate rather than immediately drop the traffic. Specifically with the Cisco ASR 1000 an additional millisecond, or N x 100 microseconds of latency is both tolerated and expected for the default traffic class. If the rate remains above the configured rate then the traffic will eventually be tail dropped when the configured queue is full for the class.
If a certain class/type of traffic is particularly latency/jitter sensitive and it must never incur any additional delay even when the system or link is approaching NDR or congested, then one must employ different classes of traffic where one traffic class is prioritized over another. In the case of the AR1000, there is support for two priority queues that could be used in this instance.
For this priority traffic the paradigm is obviously different, in this case latency remains consistently low and in this case the buffers are deliberately set shallower. The ultimate goal for priority, or low latency queuing (LLQ) traffic is just that, to keep latency low and in most cases the traffic profile is policed.
The test scenario above, where all traffic being sent is of the same class is not a test of QoS as such, to test QoS operation more completely one must have more that one traffic class configured then congest the interface and prioritize accordingly.
It must be noted that the Cisco ASR 1000 has a systemic notion of high and low priority traffic even within QFP and outside the queuing chipset, therefore low latency traffic is always guaranteed to be serviced first throughout the platform. In these test profiles, but outside of the RFC2544 testing, priority traffic was sent concurrently to help ensure LLQ operation. In all cases the priority traffic incurred latency in the order of 30 ~ 50usec, while default traffic was either buffered or tail dropped.

Conclusion

The overall goal of this whitepaper was to explain the Cisco ASR 1000 latency in response to different configuration and load conditions. In summary, the Cisco ASR 1000 has extremely good latency while running with basic routing functions as well as with multiple services turned on. It was also demonstrated that like any router with shaping turned latency will increase as you get to closer to the NDR. In these scenarios latency will be higher due to the need for the router to buffer and shape the packets while sustaining a 100% traffic load.
For further information, please see the Cisco ASR 1000 homepage at http://www.cisco.com/go/asr1000

RFC2544 Configurations Used In Testing

The configurations used in the RFC2544 test are detailed in this section.

Table 12. RFC 2544 Configurations-No Services

1 GigE Configuration Without Services

10 GigE Configuration Without Services

ASR#sh run
no service password-encryption
!
hostname ASR
!
no aaa new-model
!
resource policy
!
interface GigabitEthernet0/0/0
ip address 10.10.10.1 255.255.255.0
!
interface GigabitEthernet0/0/1
ip address 20.20.20.1 255.255.255.0
ASR#sh run
no service password-encryption
!
hostname ASR
!
no aaa new-model
!
resource policy
!
interface TenGigabitEthernet0/0/0
ip address 10.10.10.1 255.255.255.0
!
interface TenGigabitEthernet0/0/1
ip address 20.20.20.1 255.255.255.0

Table 13. RFC 2544 1Gigabit Configuration With Services With Hierarchal Shaping QoS Policy

1 GigE Configuration With Services Shaping QoS Configuration

ASR#
class-map match-any Voice-Out
  match ip dscp ef
class-map match-any Critical-Data-Out
  match ip dscp af23
class-map match-any Netwk-Control-Out
  match access-group 101 (match ospf)
!
policy-map LAN-CHILD-OUT
class Voice-Out
    priority level 1
class Network-Control-Out
    bandwidth remaining ratio 1
class Critical-Data-Out
    priority level 2
class class-default
    bandwidth remaining ratio 1
policy-map LAN-PARENT-OUT
class class-default
    shape average 1000000000
   service-policy LAN-CHILD-OUT
!
hostname ASR
!
interface GigabitEthernet0/0/0
ip address 10.10.10.1 255.255.255.0
ip access-group GIG000ACL_IN in   (100 Line ACL)
ip access-group GIG000ACL_OUT out (100 Line ACL)
ip verify unicast reverse-path allow-self-ping
ip flow ingress
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 ASR1000
no cdp enable
service-policy output LAN-PARENT-OUT
!
interface GigabitEthernet0/0/1
ip address 20.20.20.1 255.255.255.0
ip access-group GIG001ACL_IN in   (100 Line ACL)
ip access-group GIG001ACL_OUT out (100 Line ACL)
ip verify unicast reverse-path allow-self-ping
ip flow ingress
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 ASR1000
no cdp enable
service-policy output LAN-PARENT-OUT
!
router ospf 1
router-id 223.255.255.254
queue-depth update unlimited
ispf
nsf ietf restart-interval 120
network 223.255.255.254 0.0.0.0 area 0
network 20.20.20.1 0.0.0.0 area 0
network 10.10.10.1 0.0.0.0 area 0

Table 14. RFC 2544 Ten Gigabit Configuration With Services With Hierarchal Shaping QoS Policy

10 GigE Configuration With Services Shaping QoS Configuration

ASR#
class-map match-any Voice-Out
  match ip dscp ef
class-map match-any Critical-Data-Out
  match ip dscp af23
class-map match-any Netwk-Control-Out
  match access-group 101 (match ospf)
!
policy-map LAN-CHILD-OUT
class Voice-Out
    priority level 1
class Network-Control-Out
    bandwidth remaining ratio 1
class Critical-Data-Out
    priority level 2
class class-default
    bandwidth remaining ratio 1
policy-map LAN-PARENT-OUT
class class-default
    shape average 10000000000
   service-policy LAN-CHILD-OUT
!
hostname ASR
!
interface TenGigabitEthernet0/0/0
ip address 10.10.10.1 255.255.255.0
ip access-group TeGIG000ACL_IN in   (100 Line ACL)
ip access-group TeGIG000ACL_OUT out (100 Line ACL)
ip verify unicast reverse-path allow-self-ping
ip flow ingress
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 ASR1000
no cdp enable
service-policy output LAN-PARENT-OUT
!
interface TenGigabitEthernet0/1/0
ip address 20.20.20.1 255.255.255.0
ip access-group TeGIG001ACL_IN in   (100 Line ACL)
ip access-group TeGIG001ACL_OUT out (100 Line ACL)
ip verify unicast reverse-path allow-self-ping
ip flow ingress
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 ASR1000
no cdp enable
service-policy output LAN-PARENT-OUT
!
router ospf 1
router-id 223.255.255.254
queue-depth update unlimited
ispf
nsf ietf restart-interval 120
network 223.255.255.254 0.0.0.0 area 0
network 20.20.20.1 0.0.0.0 area 0
network 10.10.10.1 0.0.0.0 area 0

Table 15. RFC 2544 Gigabit Configuration With Services Non Shaping QoS Policy

1 GigE Configuration With Services No Shaping QoS Configuration

class-map match-any Voice-Out
  match ip dscp ef
class-map match-any Critical-Data-Out
  match ip dscp af23
class-map match-any Netwk-Control-Out
  match access-group 101 (match ospf)
!
policy-map LAN-QOS-OUT
class Voice-Out
    priority level 1
class Network-Control-Out
    bandwidth remaining ratio 1
class Critical-Data-Out
    priority level 2
class class-default
    bandwidth remaining ratio 1
!
interface GigabitEthernet0/0/0
ip address 10.10.10.1 255.255.255.0
ip access-group GIG000ACL_IN in   (100 Line ACL)
ip access-group GIG000ACL_OUT out (100 Line ACL)
ip verify unicast reverse-path allow-self-ping
ip flow ingress
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 ASR1000
service-policy output LAN-QOS-OUT
!
interface GigabitEthernet0/1/0
ip address 20.20.20.1 255.255.255.0
ip access-group GIG001ACL_IN in   (100 Line ACL)
ip access-group GIG001ACL_OUT out (100 Line ACL)
ip verify unicast reverse-path allow-self-ping
ip flow ingress
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 ASR1000
service-policy output LAN-QOS-OUT
------

Configuration for the Non-Shaping on Ten Gigabit ethernet is the Same as above.

For More Information

http://www.cisco.com/go/qos/

http://www.cisco.com/go/asr1000