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Introduction

Cisco Unity 3.0 contains a caveat in which the password for the installation account is not accepted. This
occurs only during the configuration setup of Cisco Unity version 3.0. Setup part two prompts the installer to
type the password and account used for the installation. The password that is entered is rejected even thou
is a valid password.

The reason for this caveat is that the Syscheck component no longer verifies the proper rights for the accou
Cisco bug ID CSCdv37418 addresses this situation, and can be found in the Release Notes for Cisco Unity
Release 3.0(2).

This document provides a workaround that describes how to give the Act as Part of the Operating System a
Log On as a Service rights to the installation account. Thus, it completes the configuration setup.

Note: Another symptom can also occur: When an attempt is made to install Cisco Unity, the setup program
can complain that the user does not have the rights to Act as part of the Operating System.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used
The information in this document is based on this software version:
« Cisco Unity 3.0
The information in this document was created from the devices in a specific lab environment. All of the

devices used in this document started with a cleared (default) configuration. If your network is live, make sul
that you understand the potential impact of any command.



Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Give Rights to an Installation Account

These sections explain how to give Act as Part of the Operating System and Log On as a Service rights to t
installation account in order to complete the configuration setup.

There are two different scenarios for this workaround, depending on whether the Cisco Unity server is used
as:

* A Member Server in a Windows 2000 Active Directory domain

« A Domain Controller of the Windows 2000 Active Directory domain (This is the typical scenario of
an all-in—one-box installation.)

Member Server Step—by-step Instructions
Complete these steps:
1. From the Windows desktop, select Start > Run.
This window appears:

f Type the name of a program, folder, document, or

Internet resource, and Windows will open it for you.

Open: | Z|

oK Cancel | Browse... |

2. Type mmc, then click OK.

The Console window appears:
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3. From the Console pull-down menu, select Add/Remove Snap-in.

The Add/Remove Snap-in window appears:

Add/Remove Snap-in

Standalone | Extensions |

Use this page to add or remove a standalone Snap-in from the console.

Root j @I

Shap-ins added to: I@ Console

— Description

Add... | Hemoye About... |

I oK I Cancel

4. Verify that the Standalone tab is the active tab, and click the Add button at the bottom of the window.

The Add Standalone Snap-in window appeatrs.

5. From the list of Available Standalone Snap—ins, select Active Directory Users and Computers.



6. Click the Add button at the bottom of the window, then click Close.

The Add/Remove Snap-in window reappears with the Active Directory Users and Computers
displayed in the main panel.
7.Click OK.

The Active Directory Users and Computers window appears.
8. Navigate to your domain and right—click on your domain. From the menu, select Properties, as
shown in this window:

Tree | Favories | Name | Type | Description |
(L Console Root JBuiltin builtinDomain
= 4 Active Directory Users | L Computers Container Default container for upar...
& B]W- FDennaie Sombe  Aoganizational ... Default container for new ...
Delegate Control... tainer Default container for secu...
And.., tainer Defaulk container for upagr...
Connect to Domain. ..
Connect to Domain Controller. ..
Operations Masters...
New 3
All Tasks »
View »
New Window from Here
New Taskpad View. ..
Refresh
Export List..,
Properties

The Properties window appears.
9. From the Properties window, select the Group Policy tab, then click Edit.

The Group Policy window appears.
10. As shown in this window, navigate to the User Rights option. Select Computer Configuration >
Windows Settings > Security Settings > Local Policies > User Rights to do this.



g & Group Policy

| acton vew || @ » | @@ X B2

Tree | Policy / [ Computer Setting
@ Default Domain Policy [monkey F & &%) Access this computer from the network Not defined
= @ Computer Configuration — ﬁﬂAct as part of the operating system Not defined
) (] Software Settings ,ﬁ,'{]hdd workstations to domain Not defined
=[] Windows Settings @Back up files and directories Not defined
= Scripts (StartupfShu ﬁ'oilBypass traverse checking Not defined
= Security Settings §,'{|Changa the system time Not defined
(#)-&# Account Policies #%)Create a pagefile Not defined
) 8 Local Policies 2] Create a token object Not defined
& £ Audit Policy E’Q’]Creae permanent shared objects Not defined
;]I 3’ ' %%ﬂoebtg programs . Not defined
I #18]Deny access to this computer From the network  Not defined
:i i—g ;:z;t.ct: Groug ;:T,:'joaw logon as a batch jyob Not defined
%1 (@ System Services 43’]Deny logon as a service Not defined
5-0@ Registry ;-,;]Deny logon locally Not defined
-@ Fle System 18] Enable computer and user accourks to be tru.., Not defined
@) (23 Public Key Policie p:T,"jForce shutdowen from a remote system Not defined
-8, 1P Security Polic— £8] Generate security audits Not defined
- (2 Administrative Template: | #8]Increase quotas Not defined
= o User Configuration 28] Increase scheduling priority Not defined
+-(_]) Software Settings -r:I #¥]Load and unload device drivers Not defined
4 > 2¥]Lock pages in memory Not defined

11.From the right panel, double—click the Act as part of the operating system option.

The Security Policy Setting window appears:
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12.Check the Define These Policy Settings checkbox, then click Add. If this option is already activated,
simply click the Add button.

The Add User or Group window appears:

Add user or group [ 2] X]

User and group names

I Browse ... I

(Ife |

13.Click Browse to locate the domain.

The Select Users or Groups window appears.



14.From the Look In field, select the account with which you are installing Unity.

i Select Users or Groups ﬂ m
Lookin: [ SHUNT =

Name P
ﬂzEveryo i 1
€7 Authenticated Users
€7 ANONYMOUS LOGON
€L BATCH
€7 CREATOR OWNER
€7 CREATOR GROUP

€T DIALUP 4|

Ldd I [Check Hames

|<< Type names separated by semicolons or choose from list >>
15.1n the main panel, select the type of user.

Note: For the purpose of this document, the Administrator was selected because the user logged in
an administrator.
16. After you select the user type, click Add, then click OK.

The Group Policy window reappears.
17.From the right panel, double—click the Log on as a service option, as shown in this window:

aton wew || & o (Om XB @

Tree | [Fobey [ Computer Settrg l
@ Def it Domain Polcy [mankery.Mon 28] Access this computer from the retwark Not defired
& ’ Computer Configuration RE)Act a5 part of the operating system MONKEY L\ Administr ator
%) () Software Settings #5] add warkstations to domain Not defined
=1 ] Windows Settings :'-_'"]Ee(" up files and drectones Not defred
'.'-‘. Sapts (Startupfhutdo gl‘g']L-,cez; traversa chadkng Net defred
Securty Settngs 2] Changes the system bme Mot defired
+ 89 Acoount Pokcies RYf] Craste & pagefie Not defired
= sj Local Polioes Y] Craats 5 token cbiect ot defired
4 8) Ak Policy Y] Creats permansct shared objects Nt defirnd
# 251 Uer RIgHRE 855 | 3100t programs Not definnd

+ 5 Security Opliore

E iﬂ]l’m',,- 00855 10 this computer from the network.  Not defired
: ;-rg ;;::_L!:: - ?ﬂ]l‘m-n,v logon as a batch job Not defired
- .r«_:uos 28]Denry bogon as a service Not defired

+ j System Services e L ) i
(@ Regetry 28] Dernry bogon kocaly Nt @rca
+- (1) Pl System #2]Enable computer and user accourts to be .. Not defired
& () Publc Key Pobcies #8]Force shutdown from a remote system Not defired
t S IP Security Poliges ¢ f-_'ﬂl}c’mate seorty sucks Not defired
4 (1] Adninitrative Templates | 2] Incrasse quotas Mot defired
= & User Corfiguration 2] Incrasss schaduing prority Nt defired
3 () Softvare Settings 2] Load and unkosd device drivers Net defired
+1-{] Windows Settings R Lock pages in memary Nt defired
1 (] Adninistrative Templates | R]Log on as a batch job Nt defired

. NONC VAL
] Log on ocaly Mot defirmd

,}H]M:rw;a auRing and securty g Not defirmd
R8]Mocky firmware ervronment vakues Nt defired
Ra|Profie sngle process Not defired

The Security Policy Setting window appears.
18.Repeat steps 12 through 16 for this option.
19.Reboot the Cisco Unity server.

After the server reboots, you are able to configure the second part of the configuration setup.



Domain Controller Step—by-step Instructions
Perform these steps:
1. Go to Start > Programs > Administrative Tools > Active Directory Users and Computers.
The Active Directory Users and Computers window appears.

2. Navigate to your domain. In the right panel, right—click the Domain Controllers folder. From the
menu, select Properties, as shown in this window:

4 Active Directory Users and Computers [_ 5] x]
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The Properties window appears.
3. From the Properties window, select the Group Policy tab, then click Edit.

The Group Policy window appears.
4. As shown in this window, navigate to the User Rights option. Select Computer Configuration >
Windows Settings > Security Settings > Local Policies > User Rights.
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| acton vew || @ » | @@ X B2

Tree | Policy / [ Computer Setting
@ Default Domain Policy [monkey F & &%) Access this computer from the network Not defined
= @ Computer Configuration — ﬁﬂAct as part of the operating system Not defined
) (] Software Settings ,ﬁ,'{]hdd workstations to domain Not defined
=[] Windows Settings @Back up files and directories Not defined
= Scripts (StartupfShu ﬁ'oilBypass traverse checking Not defined
= Security Settings §,'{|Changa the system time Not defined
(#)-&# Account Policies #%)Create a pagefile Not defined
) 8 Local Policies 2] Create a token object Not defined
& £ Audit Policy E’Q’]Creae permanent shared objects Not defined
;]I 3’ ' %%ﬂoebtg programs . Not defined
I #18]Deny access to this computer From the network  Not defined
:i i—g ;:z;t.ct: Groug ;:T,:'joaw logon as a batch jyob Not defined
%1 (@ System Services 43’]Deny logon as a service Not defined
5-0@ Registry ;-,;]Deny logon locally Not defined
-@ Fle System 18] Enable computer and user accourks to be tru.., Not defined
@) (23 Public Key Policie p:T,"jForce shutdowen from a remote system Not defined
-8, 1P Security Polic— £8] Generate security audits Not defined
- (2 Administrative Template: | #8]Increase quotas Not defined
= o User Configuration 28] Increase scheduling priority Not defined
+-(_]) Software Settings -r:I #¥]Load and unload device drivers Not defined
4 > 2¥]Lock pages in memory Not defined

5. From the right panel, double—click the Act as part of the operating system option.

The Security Policy Setting window appears:
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6. Check the Define These Policy Settings checkbox, then click Add. If this option is already activated,
simply click the Add button.

The Add User or Group window appears.

Add user or group [ 2] X]

User and group names

I Browse ... I

(Ife |

7. Click Browse to locate the domain.

The Select Users or Groups window appears.



8. From the Look In field, select the account with which you are installing Unity.

i Select Users or Groups ﬂ m
Lookin: [ SHUNT =

Name P
ﬂzEveryo i 1
€7 Authenticated Users
€7 ANONYMOUS LOGON
€L BATCH
€7 CREATOR OWNER
€7 CREATOR GROUP

€T DIALUP 4|
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|<< Type names separated by semicolons or choose from list >>
9. In the main panel, select the type of user.

Note: For the purpose of this document, the Administrator was selected because the user logged in
an administrator.
10. After you select the user, click Add, then click OK.

The Group Policy window appears.
11.From the right panel, double—click the Log on as a service option, as shown in this window:
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The Security Policy Setting window appears.
12.Repeat steps 6 through 11 for this option.
13.Reboot the Cisco Unity server.

After the server reboots, you are able to configure the second part of the configuration setup.



Verify the Procedure
Perform these steps in order to verify the configuration:

1. Go to Start > Programs > Administrative Tools > Local Security Policy and navigate to the Local
Security Settings window, as shown.

.'Tﬂ Local Security Settings
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2.In the right panel, look under the Local Setting and Effective Setting columns in order to verify that
the accounts just configured actually exist.

Verify the existence of the accounts in both the Act as Part of the Operating System and Log on as
a Service policies.

3. If the accounts do not exist, repeat the step—by-step instructions described in the configuration
procedures.
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