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Introduction

This document describes the step—by-step procedure you use to troubleshoot the Cisco Outbound Option
Dialer when the Dialer does not dial.

Prerequisites

Requirements
Cisco recommends you have knowledge of these topics:
« Cisco Intelligent Contact Management (ICM)

 Blended Agent Outbound Dialing
« Familiar with Dialogic Cards and software/drivers

Components Used
The information in this document is based on Cisco ICM version 5.0 and later.
The information in this document was created from the devices in a specific lab environment. All of the

devices used in this document started with a cleared (default) configuration. If your network is live, make sul
that you understand the potential impact of any command.
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Conventions

Refer to the Cisco Technical Tips Conventions for more information on document conventions.

Troubleshoot the Problem

There are twelve steps to follow when you troubleshoot the Cisco Outbound Option Dialer when the Dialer
does not dial.

Figure 1: Twelve Steps You Use to Troubleshoot the Cisco Outbound Option Dialer
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SkillGroup.OutboundControl Set

Contact Center Managers control the agent mode by setting a well-defined skill group variable, "Outbound
Control," to one of the values in Table 1.
Value String
Corresponding Numeric Value
Description
INBOUND
0
Dedicated Inbound Mode
PREDICTIVE_ONLY
1
Dedicated Outbound Mode
PREDICTIVE_BLENDED
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2
Call by Call Blending
PREVIEW_ONLY
3
Dedicated Outbound Mode
PREVIEW_BLENDED
4
Call by Call Blending
PROGRESSIVE_ONLY
5
Dedicated Outbound Mode
PROGRESSIVE_BLENDED
6
Call by Call Blending
Complete these steps in order to verify if it is configured correctly.
1. Double—click the Script Editor icon in the Cisco ICM Admin Workstation (AW) group. The Script
Editor window opens.
2.In Script Editor, choose File > Open.
3. Select the Administrative Script that controls the specific skill group that has the problem.
4. Click Open.
5. Double—click the Set Variable node that defines the OutboundControl variable for the specific skill
group that has the problem. The Set Proprieties dialogue menu opens, as Figure 2 shows.

6. Verify that Object type, Object, Variable, and Value are configured correctly.

Figure 2: Set Properties
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B set Properties m

Set Variable I Comment | Connection Labels |

Object type: Object: Variable:
[ SkilGroup ~| [PG2_CM_PIM1.5000bc_sg 100 v [T M|
Array index:

Formula Editor...
Value:
[INEOUND

Formula Editor... |

| oK I Cancel | Help |

SkillGroup.OutboundPercent Set

The OutboundPercent variable controls the percentage of agents, which are logged into a particular skill
group, and should be used to dial outbound. This variable does not allocate specific agents for outbound
dialing, just a total percentage.

1. Double—click the Script Editor icon in the Cisco ICM AW group. The Script Editor window opens.

2. In Script Editor, choose File > Open from the menu bar. The Open dialog box opens.

3. Select the Administrative Script that controls the specific skill group that has the problem. Click
Open.

4. Double—click the Set Variable node that defines the OutboundPercent variable for the specific skill
group that has the problem. The Set Proprieties dialogue menu opens, as Figure 3 shows.

5. Verify that Object type, Object, Variable, and Value are configured correctly.

Figure 3: Set Properties
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E set Properties E

Set Variable I Comment | Connection Labels |

Object type: Object: Variable:
[ SkilGroup ~| [PG2_CM_PIM15000bc_sg 100 v [T M|
Array index:

Formula Editor
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[505%

Formula Editor... |
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Skill Assigned to Campaign

Blended agent views campaigns and query rules as logical entities that group a set of contacts together. Us
the Blended Agent — Campaign tool in order to build a relationship between skill groups and campaigns.

Note: The maximum number of skill groups per campaign is 20.

1. From the Configuration Manager menu, select Blended Agent > Blended Agent — Campaign. The
Blended Agent Campaign window opens, as Figure 4 shows.

2.1n the Select filter data box, select the filters you want.

3. Click Retrieve. This displays a list of the retrieved blended agent campaign(s) in a list box..

4.In the list box, select the blended agent campaign whose records you want to view. The configuratiol
information of the selected blended agent campaign displays in the tabbed fields on the right.

5. Click the Skill Group Selection tab.

6. Verify the information in the Skill Group Selection tab fields.

Figure 4: Blended Agent Campaign
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Service Extension Value Configured for the Skill

Complete these steps in order to verify a service extension value is configured for the skill.

Select the target service in the left pane.

1.0n an AW, from the Configuration Manager menu, choose Tools > Explore Tools > Service

Explorer, as Figure 5 shows.
2.1In the Select filter data box, select the filters you want.

3. Click Retrieve.
4. Click the Advanced tab in order to verify the extension, as Figure 5 shows.

Figure 5: Service Explorer
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5. Click the Service Member tab in order to verify the Skill group name, as Figure 6 shows.

Figure 6: Service Explorer
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Does a Dialed Number Match the Service Extension Value?
Service Extension is used by the Dialer to reserve agents. This extension must match the dialed number the

configured in the Media Routing (MR) Peripheral Gateway (PG). Complete these steps in order to verify thai
a dialed number matches the service extension value.
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1. From the Configuration Manager menu, choose Service Explorer Tools > Explore Tools.
2.1In the Select filter data box, select the filters you want.
3. Click Retrieve.
4. Select the target service in the left pane.
5. Click the Advanced tab in order to verify the extension, as Figure 5 shows.
6. From the Configuration Manager menu, choose Tools > List Tools > Dialed Number/Script
Selector List.
7. Click Retrieve.
8. Select the target name in the Dialed Number/Script Selector section.
9. Click the Attributes tab in order to verify the Dialed number string/Script selector, as Figure 7 shows.

Figure 7: Dialed Number/Script Selector List
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Has a Routing Script Been Assigned to the DN?

Complete these steps in order to verify that a routing script is assigned to the dialed number (DN):
1. Launch Script Editor from the AW, the Script Editor menu appears.
2. Select Script > Call Type Associations. The Script/Call Type Association menu appears, as Figure 8
shows.

Figure 8: Script/Call Type Associations
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Script/Call Type Associations [ X|
Business entity: I[ﬁleraulr LI

Scripts: Help
uq_script_400

Date/Time: |5/29f’2003 317 PM
Dialed Number |cup |ceD [call Type | Enabled
CCS_PIM1.RC.bc_dn_: All All uq_calltype_400 ®
CEM_PIMZ2.RC.cem.cer All All uq_calltype_400 %
L'J > Schedule... I

3. Verify Scripts, Dialed Number, and other related information.

Have Customer Phone Numbers been Imported?

The BA Import component, which resides on the Cisco ICM Logger, imports a customer's contact list. BA
Import imports two types of lists:

« contact_list: Contains the phone number BA dials.
« do_not_call_list: Contains a list of customers that do not want to be called.

Complete these steps in order to check that customer phone numbers are imported:

1. From the Configuration Manager menu, choose Blended Agent > Blended Agent — Import. The
Blended Agent Import Rule window opens.

2.Click Retrieve. This displays a list of the retrieved Import Rule names in the left window.

3. Select the target Import Rule name and the Blended Agent Import Rule window refreshes.

4. Click Import Rule General, Definition, and Schedule. Figure 9, Figure 10, and Figure 11 appear

respectively.

Figure 9: Blended Agent Import Rule
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Figure 10: Blended Agent Import Rule
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Figure 11: Blended Agent Import Rule
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5. Verify all related information in Figure 9, Figure 10, and Figure 11.

Has a Query Rule been Assigned to the Import?

Complete these steps in order to check that a query rule is assigned to the Import.

1. From the Configuration Manager menu, choose Blended Agent > Blended Agent — Query Rule.

The Blended Agent Query Rule window opens.
2.In the Select filter data box, select the filters you want.

3. Click Retrieve. This displays a list of the retrieved Query Rule name in the left side of the window.
4. Select the target Query Rule name and the Blended Agent Query Rule window refreshes, as Figure

shows.

Figure 12: Blended Agent Query Rule
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5. Verify all related information in Figure 12.

Is the Query Rule Assigned to the Campaign?

Blended agent views campaigns and query rules as logical entities that group a set of contacts together. Us
the Blended Agent — Campaign tool to build relationship between query rules and campaigns.

1. From the Configuration Manager menu, choose Blended Agent > Blended Agent — Campaign. The
Blended Agent Campaign window opens.

2.In the Select filter data box, select the filters you want.

3. Click Retrieve. This displays a list of the retrieved blended agent campaign(s) in a list box on the left
pane of the window.

4.In the list box, select the blended agent campaign records you want to view. The configuration
information of the selected blended agent campaign displays in the tabbed fields on the right, as
Figure 13 shows.

5. Click the Query Rule Selection tab.

6. Verify the information in the Query Rule Selection tab fields.

Figure 13: Blended Agent Campaign
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Are Agents Logged in and Available in the Correct Skill?

Complete these steps in order to verify that agents are logged in and available in the correct skKill.

1. Connect Procmon to dialers.

2. Use the dumpalloc command to view how many records are available for dialing, how many agents
are logged in, and how many agents are available for dialing.

3. The dumpalloc command provides real-time skill group dialing information, as Figure 14 and Figure
15 show.

Figure 14: Real-time Skill Group Dialing Information

Column Description

-~ Campaign: campaign name associated with skill
— SKill: peripheral skill number

~1D: ICM skill id

—E: enabled (Y or N)

—M: mode (N-None, P-Preview, R-Predictive/Progressive, A-Callback)
- T: type or direction (N-None, |-Inbound, O-Outbound, B-Blended)
~H-RT: call hit rate

-~ Em: call error rate

— Abnd: call abandon rate

-~ R-dle: cached records available for dialing

~Used: cached records being used for dialing

- PreR: records reserved for future calls (should be 0 most of the time)

Figure 15: Real-time Skill Group Dialing Information

Column Description Continued

~PPA: ports allocated per agent in current skill
-~ SGPorts: ports allocated for skill group
— Login: logged in agents

— Av-Skl: “available” agents in skill group
- Av-Dir: agents the dialer considers available to receive reservation call
-~ Rsrve: active reservation calls

~Rsrvd: reserved agents

- Max: maximum agents the dialer will reserve at any one time

~ Dial: customer calls in progress

~Talk: agents talking with customers dialed by the dialer

-~ Agnt %: this value is conﬁgured via the script editor and indicates what % of agents within the
current skill group are available for outbound dialing

4. Check the Campaign, Skill, Login, and Av-Skl columns.
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Confirm All Processes in the Dialer Title Bar are Active

Confirm all processes in the dialer title bar are active. The detail of the Dialer title bar is shown in Figure 16.
This list shows the valid statuses:

* A: Active

* X : Disconnect

* U : Un-Initialized
* NR : Not Routable

Figure 16: Dialer Title Bar

Customer Instance Name Telephony Port Status Mode Inciicator
Ready Ports A —Active
Campaign Manager -
Pas 9 Blocked Ports | ¢ —Discomerted
U —Un-inttialized
J l NR — Not Routabie
T [cust1.Dialer.BADialer] [CM-A] [CTI-A] [Port: (=) 1l|

| |

Process Name Configured Ports

Node Name CTI Server MR PIM

Confirm Dialer System Option Time and Campaign Dialing
Time

For General System Time options, this time range applies to all campaigns which the BA system runs, and
supersedes any individual campaign time ranges. Complete these steps in order to check the General Syste

Time options.

1. From the Configuration Manager menu, choose Blended Agent > Blended Agent — System Options,
as Figure 17 shows.

2. Click General Options in order to verify the Start time and End time in the Customer Dialing Time
Range section.

Figure 17: Blended Agent System Options
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Complete these steps in order to check the individual Campaign Dialing Time option.

1. From the Configuration Manager menu, choose Blended Agent > Blended Agent — Campaign. The
Blended Agent Campaign window opens.

2. Select the query rule from the Query Rule drop—down list in the Select filter data section.

3. Click Retrieve. This lists all the existing campaigns in the left window under the Campaign section.

4. Select the target Campaign name.

5. Click the Query Rule Selection tab in the right window and the Blended Agent Campaign window
refreshes, as Figure 18 shows.

Figure 18: Blended Agent Campaign
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6. Verify Start Time and End Time in the corresponding row with Query Rule Name.
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Related Information

« Using Remote Process Monitor Console (Procmon)
» Technical Support & Documentation — Cisco Systems
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