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Introduction

The AvCsMgr service is the main Cisco Unity process in the system. If the AvCsMgr service fails to start,
Cisco Unity does not start. There are many reasons why the AvCsMgr service may fail to start. The most
common reason for this problem is that Cisco Unity is unable to log on to the Cisco Unity Messaging System
mailbox. This is sometimes caused by problems with the service account that you use in order to log on to the
Messaging System Services, or problems with the Cisco Unity Messaging System mailbox. Sometimes this
condition occurs after you run the Configuration Setup for Cisco Unity, but this problem occurs at other times
as well. (For more details, refer to Cisco bug ID CSCdz89018 ( registered customers only) ). When this happens,
you see various MALEx and DOH errors in the application event log, as described in the Problem section of
this document. This document provides troubleshooting steps for these issues.

Prerequisites

Requirements

Before you use the information in this document, make sure that you meet these requirements:

Cisco Unity Architecture• 
Active Directory Users and Computers• 
Exchange 2000 System Manager• 
Running queries on Structured Query Language (SQL) Server 2000 databases• 



Components Used

The information in this document is based on:

Cisco Unity 3.1(x) and later that use Cisco Exchange 2000 as a message store• 
Cisco Unity 4.0(x) and later that use Cisco Exchange 2000 as a message store• 

The information presented in this document was created from devices in a specific lab environment. All of the
devices used in this document started with a cleared (default) configuration. If your network is live, make sure
that you understand the potential impact of any command before you use it.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Background Theory

The Cisco Unity Messaging System mailbox:

Acts as a surrogate sender for messages from unidentified callers.• 
Receives Non−Delivery Receipts (NDRs) for voice messages that cannot be delivered, then forwards
them to the Unaddressed Messages public distribution list.

• 

Sends notification when a Cisco Unity report is complete.• 

The alias for this account is Unity_<ServerName>. The account cannot be seen in the Cisco Unity System
Administrator, but it can be seen in the Subscriber table in the SQL UnityDb database on the Cisco Unity
server. The account can also be seen in Active Directory Users and Computers, and the associated Exchange
mailbox appears in the Exchange System Manager.

Due to the importance of the Unity_<ServerName> account, if the account is missing when Cisco Unity starts
up, Cisco Unity attempts to create it again. If Cisco Unity cannot recreate the account, or if the account exists
but Cisco Unity is unable to log on to the Unity_<ServerName> mailbox, then AvCsMgr does not start.

Problem

When the AvCsMgr service fails to start because the MALEx (a subcomponent of the Cisco Unity DOH
component) is unable to log on to the Cisco Unity Messaging System mailbox, some of these errors can be
logged in the application event log:

Event
Type

Event Source
Event

ID
Description

Error
Doh_MC 32013

DOH logon failed due to messaging
component logon error: 8004052eH

Error
Doh_MC 32024

DOH logon failed due to outside caller
object access error: There is no
such object on the server.

Error MALEx_MC 30002 Last CategoryAn attempt to access
Exchange Private Store has failed:
8004011d. The Messaging Application
Programming Interface (MAPI)
subsystem returns this error: The



attempt to log on to the
Microsoft Exchange Server
computer has failed.

Error
MALEx_MC 30002

Last Category An attempt to access
Exchange Private Store has failed:
8004011c. The MAPI subsystem
returns this error: Your profile
is not configured.

Error
MALEx_MC 30002

Last Category An attempt to access
Exchange Private Store has failed:
8004aa00. The MAPI subsystem
returns this error: Your profile
is not configured.

Error
CiscoUnity_MALEx 30020

An attempt to create a search−result
folder for account /o=Business
Objects/ou=abc/cn=Recipients/cn=xyz
has failed. The MAPI subsystem
returned the following error:
80070005. This is typically an
indication of configuration issues with
Unity, Exchange, or the MAPI
subsystem.

Error
CiscoUnity_MALEx

30003
and
30012

The MAPI subsystem returns this error
when an attempt to access the
exchange by AvCsMgr via MAPI. The
reason: the MAPI profile got
corrupted.

1Error
CiscoUnity_CsServices1021

AvCSMgr: Component Arbiter
initialize failed

These event log errors are specific to Cisco Unity 3.1(5) and earlier. 1For Cisco Unity 4.0(x), the event source
is CiscoUnity_MalEx and CiscoUnity_Doh. The Event IDs may be different as well. In order to check Cisco
Unity error messages in the event log, refer to the Cisco Unity Error Message Finder .

If Cisco Unity failed to start for other reasons, different errors may be logged. The content of the different
errors can be used to begin troubleshooting, but that is not covered in this document.

Note: When you try to mount the Exchange database, if you get the error The database files in
this store are corrupted., perform the procedure mentioned in the Microsoft Knowledge Base
Article � 313184 (How to recover the information store on Exchange 2000 Server or Exchange Server 2003
in a single site) to resolve the issue.

Solution

Perform these troubleshooting tasks in the order listed:

Verify the Accounts that Cisco Unity Services Log On As.1. 
Verify that Cisco Unity is Configured for the Correct Partner Exchange Server.2. 
Verify that the AvCsMgr Service Startup Type is set to Manual.3. 
Delete the MAPI Profile.4. 
Verify the Unity_<ServerName> Account Is in Active Directory.5. 



Verify the Unity_<ServerName> Account Is in the SQL Database.6. 
Verify the Unity_<ServerName> Exchange Mailbox is Configured Correctly.7. 
Remove the Unity_<ServerName> Account from Active Directory and Recreate It.8. 
Check the Application Event Log for Other Errors.9. 

Verify the Accounts that Cisco Unity Services Logs On As

The AvCsMgr service does not start if the account that the service logs on does not have the appropriate rights
and permissions. Although you can set the rights and permissions manually for the AvCsMgr service, Cisco
advises you to run the 4.0 version of the Cisco Unity Permissions Wizard for Cisco Unity 3.x and later. This
utility can be downloaded for free from Cisco Unity Tools . The Cisco Unity Permissions Wizard 4.0 allows
you to set the domain accounts that Cisco Unity services log on as. When you run the Cisco Unity
Permissions Wizard 4.0, you make sure that all the Cisco Unity service accounts have the appropriate rights
and permissions.

The Cisco Unity Permissions Wizard is a �linear� tool, which means, it tries to assign all the rights and
permissions that you need for that particular account. However, it fails to check if there is a policy in the
hierarchy of your Active Directory structure that prevents these rights and permissions to be made effective
for the account that you attempt to set as a service account for the Cisco Unity Services.

The Cisco Unity Permissions Wizard 4.0 groups the Cisco Unity services as follows:

Cisco Unity directory services. These services keep subscriber data in the directory synchronized with
subscriber data in the Cisco Unity SQL Server database.

• 

Cisco Unity message store services. These services allow subscribers to send and receive voice
messages by means of the telephone user interface. The AvCsMgr service is one of the message store
interface services.

• 

Services that run only on the Cisco Unity server. By default, local Cisco Unity services log on as the
Local System account. Cisco advises you not to change this.

• 

For Cisco Unity 3.x, the Unity services must look like the image here. Use this image as a reference where
Rdomain\unitydirsvc is the Directory Service Account and Rdomain\us is the Message Store Service
Account in the image shown here. These service accounts must meet all the rights and permissions described
in Permissions Set By the Cisco Unity Permissions Wizard .

Note: Even though, Cisco Unity Tools Unity Permissions Wizard 4.0(½) states �For Unity 3.1(1) through
3.1(5) you must use the Permissions Wizard 3.x ,� it also explains that Permissions Wizard for Cisco Unity
3.1.6 and later is not Unity version dependent, which means you can run it in any Cisco Unity 3.x. For the
troubleshooting purposes of this document, you must run Cisco Unity Permissions Wizard 4.0..

Here are accounts that have to be logged as LocalSystem are AvDirChangeWriter, AvRepDirSvrSvc, and
AvTtsSvr:

Note: In the example from this image, Cisco Exchange 2000 has been used as the mailstore. If Cisco
Exchange 5.5 is chosen to be the mailstore, a service called AvDSEx instead of AvDSGlobalCatalog will be
in place (and this document would not apply).



For Cisco Unity 4.x, the Unity services must look like the image here. Use this image as a reference where
Rdomain\unitydirsvc is the Directory Service Account and Rdomain\us is the Message Store Service
Account. These service accounts must meet all the rights and permissions described in Permissions Set By the
Cisco Unity Permissions Wizard . Services that are run under local system are AvDirChangeWriter, AvLic,
AvMMProxySvr, AvRepDirSvrSvc, AvSqlChangeWriter,AvTtsSvr.

In this image, Rdomain\unitydirsvc is the Directory Service Account and Rdomain\us is the Message Store
Service Account. Refer to the Cisco documentation.

Note: In the example from this image, Cisco Exchange 2000 has been used as the mailstore. If Cisco
Exchange 5.5 is chosen to be the mailstore, a service called AvDSEx55 instead of AvDSGlobalCatalog is in
place (and this document does not apply).

Based on which version of Cisco Exchange is used, there must be created domain accounts or use domain
accounts that already exist for the Cisco Unity services as follows:

In this case, use Cisco Exchange 2000 as the message store for Cisco Unity. There must be an account
that Cisco Unity directory services logs on as and an account that Cisco Unity message store services
logs on as.

• 

For Cisco Exchange 5.5, the account that both directory services and message store services logs on
as (and this document would not apply).

• 

For Cisco Exchange 2000, the permissions required by the directory services account conflict with the
permissions required by the message store services account, so you must use separate accounts for the two



types of services. For the accounts that Cisco Unity services log on as, make sure that the password never
expires. If the password expires, Cisco Unity does not work the next time the server is restarted.

 Caution: If you use Cisco Exchange 2000, the account that Cisco Unity message store services logs on

as cannot be a member of the Domain Administrators group or be an Exchange 2000 administrator. Also, for
the Cisco Unity message store services account, you need to make sure that the Send−As, Receive−As, and
Administer Information Store permissions are checked on Exchange 2003 or Exchange 2000 mailstores.

Since Permissions Wizard 4.0 is typically run when Cisco Unity 4.x and Cisco Unity 3.1.6 are initially set up,
Permissions Wizard 4.0 requires that you specify domain accounts for a Cisco Unity installer and an
administrator. Cisco Unity 3.1.5 and earlier do not have this requirement, so Permissions Wizard 4.0 must be
run manually after you download it from Cisco Unity Tools .

Note: It is very important the accounts that are needed by Cisco Unity have been created according to the
Creating Accounts document.

Verify that Cisco Unity Is Configured for the Correct Partner Exchange
Server

If the AvCsMgr service still fails to start after the server is restarted, verify that the Cisco Unity server
is configured for the correct Exchange server.To do this you can verify that these registry keys are
present and set to the correct value in the Windows registry and the Doh Property Tester.

Note: You can also verify the Exchange server name in the Exchange System Manager for Exchange
2000 or the Exchange Administrator for Exchange 5.5. accordingly, as these registries apply to both
cases.

Start registry and look at these :

HKEY_LOCAL_MACHINE\SOFTWARE\Active Voice\Doh\1.0\Mail Server Name
HKEY_LOCAL_MACHINE\SOFTWARE \Active Voice\MalEx\1.0\ServerName

Both registry settings must be the name of the Exchange Server chosen during Configuration Setup.
(This is the partner Exchange server that Cisco Unity is connected to, through which Cisco Unity
communicates with the other Exchange servers.)

Note: If the AvCsMgr has never successfully logged into the Unity_<ServerName> mailbox on the
partner Exchange server, the MALEx key will not be present. You need to go to Start > Settings >
Control Panel > Add/Remove programs and remove the Cisco Unity Message Store
Configuration Wizard or the Cisco Configuration Setup Wizard based on the version of Cisco
Unity that you have. Go to commserver\configurationsetup and double−click on setup.exe to
reconnect Cisco Unity to its current Exchange partner. If either one or both of the above registry keys
do not match the partner server, edit the values of those keys so that they do point correctly.

1. 

Verify that the mailstore location for the Default Domain is correct. There must be a valid mailstore
for that value.

This setting is used to determine the location of Exchange mailboxes if they are created from Cisco
Unity for this Domain (which happens if you notice that the Unity_<ServerName> mailbox is not
there on start up).

Start DohPropTest in read−only mode.

Click AD Monitor.a. 

2. 



Click DEFAULT_DOMAIN in the Parameters list. The value displays in the box.b. 
Click the matching domain from the list.c. 
Click MAILBOX_STORE from the Parameters list.d. 
If there is only one domain, click MAILBOX_STORE.e. 
Verify the path to the mailbox store. This is where Cisco Unity thinks the Exchange mailbox
for the Unity_<ServerName> account is located. This is also the location where Cisco Unity
creates the Exchange mailbox for the Unity_<ServerName> account if it is not there. The
server name in this path must match the two registry keys that you just checked.

For example: CN=Mailbox Store (CPRYELLOWEX2KA1),CN=First Storage
Group,CN=InformationStore,CN=CPRYELLOWEX2KA1,CN=Servers,CN=First
Administrative Group,CN=Administrative Groups,CN=CPRYellowORG,CN=Microsoft
Exchange,CN=Services,CN=Configuration,DC=CPRYellowDOM,DC=ecsbu−lab−sea,DC=cisco,DC=com

f. 

If this value is not correct, modify it for the correct value in the DohPropTest (contact the Cisco
Technical Assistance Center (TAC) to enter the password of the day in the DohPropTest utility) or
uninstall and reinstall the ConfigSetup, by:� Click on Start > Settings > Add/Remove programs,
choose Cisco Unity Configuration Setup or Cisco Unity Message Store Configuration Wizard,
based on the Cisco Unity version. You must be logged on to the Cisco Unity server with a Unity
installation account to uninstall or reinstall the Cisco Unity Configuration Setup. This Cisco Unity
component probably have different names however it is the only thing that you can add and remove
from the Settings that the Unity software installs other than some add−on Unity utilities and the Unity
tsp).

After the Configuration setup is uninstalled, reinstall the configuration setup (or Cisco Unity Message
Store Configuration) �� double−click on \\commserver\configuration setup\setup.exe and enter the
correct values while you are logged onto the Cisco Unity server with a Cisco Unity installation
Account. (Run Permissions Wizard 4.0 to create a Unity installation account if you are not sure which
one is your Cisco Unity installation Account).

Note: You can also go to HKEY_LOCAL_MACHINE\SOFTWARE\Active Voice\Commserver
Setup\1.0\Private, rename this to Private.old and run the Message Store Configuration Wizard from



C:\CommServer\ConfigurationSetup\Setup.exe in order to resolve the issue.

Verify that the AvCsMgr Service Startup Type is set to Manual

A couple of Cisco Unity services are supposed to start manually, and AvCsMgr is one of those services.
AvCsMgr service cannot be started directly; it must be started and stopped by the AvCsGateway. If the
Startup Type for the AvCsMgr service is set as Automatic, it can fail to start. You need to set the Startup
Type to Manual for the AvCsMgr service to function properly.

Delete the MAPI Profile

After you complete and verify the above, you must delete the MAPI profile from the Windows registry and
restart Cisco Unity so that it creates a new profile. This ensures that you have a valid MAPI profile with the
right authentication that points to the correct Exchange, Global Catalog and Domain Controller servers. To do
this, perform these steps.

 Caution: When you change the wrong registry key or enter an incorrect value can cause the server to

malfunction. Before you edit the registry, confirm that you know how to restore it if a problem occurs. (Refer
to the "Restoring" topics in Registry Editor Help.) Note that for Cisco Unity failover, registry changes on one
Cisco Unity server must be made manually on the other Cisco Unity server, because registry changes are not
replicated. If you have any questions about changing registry key settings, contact Cisco TAC.

Log on to the Cisco Unity server with the help of an account which has Local Administrator
privileges. This is required to allow changes to the registry.

1. 

Go to the Start menu and choose Settings > Control Panel > Administrative Tools > Services.
Look for the AvCsMgr service and note what the "Log On As" value is set to for this service.
Specifically, note if it is the Local system or a domain account.

2. 

Check which domain account AvCsMgr is active as, and then log off from the current windows
session and log back on as the same account in which the AvCsMgr isactive, and continue with Step

3. 



4here. If AvCsMgr is active as the local system account, go back to the start of this document to make
sure that have assigned the correct Cisco Unity service accounts to the Cisco Unity services.
Go to the Start menu and choose Run.4. 
Type regedit.exe and click OK.5. 
If AvCsMgr was running as a domain account, go to:

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles

If AvCsMgr was running as the local system account, go to:

HKEY_USERS\Default \Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles

Note: Both places should be checked, as this account may be changed in the history of your system
from Local to Domain.

6. 

Right−click the Unity System Profile entry and choose Delete.7. 
Restart the Cisco Unity server.

Note: Another potential problem with the MAPI profile could be if your MAPI profile is not pointing
to the correct Global Catalog (GC) Server. Refer to Cisco bug ID CSCea26846 ( registered customers

only) for more details.

Once the accounts that Cisco Unity services uses to log on and the MAPI profile have been checked,
proceed with these troubleshooting steps, which verifies that the account Unity_<ServerName> is
configured correctly:

8. 

Verify the Unity_<ServerName> Account is in Active Directory

Verify that the Unity_<ServerName> exists in the Active Directory Users and Computers container
you specified during the installation of Unity as the container for your Unity Subscribers. Verify that
your Unity accounts have the correct rights and permissions over that container by running
Permissions Wizard and pointing the permissions Wizard to that container

To check that the Unity containers have the correct rights and permissions to create new users, run the
Permissions Wizard and verify that it corresponds to the container that you specified during the
installation:

1. 



The Unity_<ServerName> must be located under that container in Active Directory Users and
Computers.

If the Unity_<ServerName> account does not exist in Active Directory, test to see if you can create a
test account in Active Directory by the means of the same account Cisco Unity used during
Configuration Setup to create Active Directory accounts. (This would be the Windows account you

2. 



created as the Installation account for Unity. If you do not have that account anymore, you can
recreate this account with Cisco Unity Permission Wizard 4.0.)

If the Unity_<ServerName> account does exist, go to the next step however mak sure the
Unity_<ServerName> Active Directory account is mailbox enabled.

To create a test account, log on to the Cisco Unity server with the help of the same domain
account you were logged into when you ran Configuration Setup (the Install account or create
a new Install Account with Permissions Wizard 4.0).

a. 

From Active Directory Users and Computers, try to create a test user account in the same
container chosen during the Cisco Unity Configuration Setup.

b. 

If a test user can be created, verify that the Unity_<ServerName> account exists in the subscriber
table in SQL.

3. 

You must also verify that the Unity_<ServerName> account name is not longer than 14 characters,
which is unsupported.

4. 

Verify the Unity_<ServerName> Account is in the SQL Database

The Unity_<ServerName> account is recreated if it is not there when Cisco Unity reboots. For earlier versions
of Cisco Unity 3.x, this account probably needs to be recreated manually by this next procedure.

Follow the steps in this section if you have verified that:

The Unity_<ServerName> account does not exist in Active Directory.• 
The AvDSAD service account has the appropriate permissions.• 

Verify that the Unity_<ServerName> account exists in the Subscriber table in the SQL database.
(Note these steps are specific for Microsoft SQL Server 2000. If your Cisco Unity server uses
Microsoft SQL Desktop Edition (MSDE), make sure that you install the Enterprise Manager as
documented in the installation guide for your Cisco Unity version.)

1. 

On the Cisco Unity server, click Start > Programs > Microsoft SQL Server > Enterprise
Manager.

2. 

Expand the tree in the left pane so that UnityDb within the Databases container is fully expanded.3. 
In the tree, click Tables within the UnityDb database.4. 
In the right pane, scroll down until you see the Subscriber table.5. 
From the Windows Start menu, choose Programs > Microsoft SQL Server > Enterprise Manager.6. 
Expand the tree view as displayed in the following window: Microsoft SQL Servers >
<ServerName> > Databases > UnityDb > Tables.

7. 

Right−click the Subscriber table, and choose Open Table > Query.8. 



Run a query as the one in this image�click on the ! button. The query selects the alias for the field that
you are want to search the record for, and the criteria must be =Unity_ServerName. In this example,
the Cisco Unity server name is Unity_Alex. Once your press the ! button, the last pane returns the
record that you are trying to find (and the criteria changes to = N'Unity_ServerName'. Delete the
value in the field titled DirectoryId.

9. 

If the account does exist, go to Verify the Unity_<ServerName> Exchange Mailbox Is Configured10. 



Correctly.
If you run Cisco Unity 3.1.x or later and the account does not exist, continue with Remove the
Unity_<ServerName> Account from Active Directory and Recreate It, and reboot. The Cisco Unity
server must recreate this account when rebooting.

11. 

If you run Cisco Unity between version 3.0(1) and 3.1.x and the account does not exist, you have to
manually create the Unity_<ServerName> account, as described here for Cisco Unity 3.0(1). If you
are run Cisco Unity 3.0(2) or later, skip to Creating the Unity_<ServerName> Account Using a Script
in SQL Query Analyzer section here.

Creating the Unity_<ServerName> Account Manually in SQL

In SQL Enterprise Manager, go to the last row in the Subscriber table that you opened in step
6 above, which must be blank.

a. 

In the Alias column, enter Unity_<ServerName>.b. 
In the DisplayName column, enter Unity Messaging System − <ServerName>.c. 
In the FirstName column, enter Unity.d. 
In the IsSubscriber column, enter 0 (zero, which indicates false).e. 
In the LastName column, enter Messaging.f. 
In the LocationObjectID column, copy the ID from another subscriber, and paste it into the
column. (Make sure to copy from a �regular� subscriber and not from an AMIS, Bridge, or
VPIM subscriber.)

g. 

In the SubscriberType column, enter 0 (zero).h. 
In the Undeletable column, enter 1 (one, which indicates true).i. 
In the Uid column, enter Unity_<ServerName>.j. 
Close the query window. The row is automatically saved.k. 
Close SQL Enterprise Manager.l. 
Go to step 13 of this procedure.m. 
Creating the Unity_<ServerName> Account Using a Script in SQL Query Analyzer

On the Cisco Unity server, choose Start > Programs > Microsoft SQL Server > Query
Analyzer.

a. 

Click OK to use Windows Authentication.b. 
Copy this script and paste it into the Query Analyzer window.

/* Select the unity database */
Use UnityDb

DECLARE @servername as nvarchar(256)
DECLARE @alias as nvarchar(64)
DECLARE @displayname as nvarchar(256)

/* REPLACE WITH THE UNITY SERVER NAME HERE */
SET @servername = 'MYSERVER'
/* REPLACE WITH THE UNITY SERVER NAME HERE */

/* Setup server specific values */
SET @alias = 'Unity_' + @servername
SET @displayname = 'Unity Messaging System − ' + @servername

/* Find the default location's object id. */
DECLARE @loid as uniqueidentifier
SET @loid = (SELECT LocationObjectId FROM LOCATION where alias like 'default')

/* Create a new entry for the account in the subscriber */
/* table with the following values: */
/* Alias: Unity_<servername> */
/* Uid: Unity_<servername> */
/* DisplayName: Unity Messaging System − <servername> */
/* FirstName: Unity */

c. 

12. 



/* LastName: Messaging */
/* SubscriberType: 0 (non−subscriber) */
/* IsSubscriber: FALSE */
/* LocationObjectId: (location object id found above) */
/* Undeletable: TRUE */
INSERT INTO SUBSCRIBER
(Alias,Uid,DisplayName,FirstName,LastName,SubscriberType,IsSubscriber,LocationObjectId,Undeletable)
VALUES
(@alias,@alias,@displayname,'Unity','Messaging',0,0,@loid,1)
Go

Press F5 to execute the query.d. 
Close Query Analyzer.e. 
Close Enterprise Manager.f. 
Continue with step 13.g. 

Once the account exists in SQL, run Configuration Setup again to create the Unity_<ServerName>
account in Active Directory, as follows:

From the <Drive>:\Commserver\Configuration Setup directory, run setup.exe �sync.a. 
Reboot the Cisco Unity server.

The AvCsMgr service should start. If the AvCsMgr service still does not start, open a Cisco
TAC case and provide the most recent SqlSync log (it will be titled SqlSync_xxxxx.txt) from
the <Drive>:\Commserver\logs directory) as well as the application event log file from the
Event Viewer.

b. 

13. 

Verify the Unity_<ServerName> Exchange Mailbox Is Configured
Correctly

Verify that the Unity_<ServerName> account is mailbox enabled.

Open Active Directory Users and Computers. Choose Start > Programs > Administrative
Tools > Active Directory Users and Computers.

a. 

Choose View > Advanced.b. 
Right−click the Unity_<ServerName> Active Directory account, and choose Exchange
Tasks.

c. 

At the welcome screen, click Next.d. 
If the Create Mailbox option is displayed, then the Unity_<ServerName> account is not
mailbox−enabled. Proceed to Remove the Unity_<ServerName> Account from Active
Directory and Recreate It.

e. 

If the Create Mailbox option is not displayed, then the Unity_<ServerName> account is
mailbox−enabled, so click Cancel, and continue with next step to verify that the
Unity_<ServerName> account points correctly to the Cisco Unity�s Exchange partner.

f. 

1. 

Verify that the Unity_<ServerName> account correctly points to the associated Exchange Mailbox.

In Active Directory Users and Computers, right−click the Unity_<ServerName> account,
and choose Properties.

a. 

Click the Exchange General tab. Verify that a path is specified to the Unity_<ServerName>
Mailbox store, and the path is correct.

b. 

2. 



If the path does not exist or is incorrect, go to Remove the Unity_<ServerName> Account
from Active Directory and Recreate It.

c. 

Check is the Mailbox Rights with the help of these steps:

From the Active Directory Users and Computers MMC plug in, change the view to
Advanced.

a. 

Right−click the Unity_<ServerName> account, and choose the Exchange Advanced
tab.

b. 

Click Mailbox Rights.c. 
In addition to SELF, you must see Exchange Domain Servers. If the security
descriptor only includes SELF, send an e−mail message to the Unity_<ServerName>
account. This populates the Unity_<ServerName> security descriptor.

d. 

d. 

Verify that the mail database that contains the Unity_<ServerName> mailbox is mounted with the
help of these steps:

Use the Exchange System Manager, and open the tree.a. 
Scroll to the mail database in question.b. 
Right−click the database and make sure it shows that the store is mounted.c. 
If it is not mounted, steps continue with step e. Otherwise, close Exchange System Manager.d. 
Go to Exchange System Manager.e. 
Right−click on the store and choose Mount.f. 
Close Exchange System Manager.g. 

3. 

Remove the Unity_<ServerName> Account from Active Directory and
Recreate It

If the Active Directory account is not mailbox−enabled, the path to the Unity_<ServerName> mailbox store is
incorrect or does not exist, or the Mailbox Rights button does not appear and the AvDSAD and
AvDSGlobalCatalog services are not currently able to start�up with the help of the Cisco
Unity_<ServerName> account (that is, they still useg the local system account (default) or another domain
account), perform these steps to remove the Unity_<ServerName> account from Active Directory and recreate
it:



From the Windows Start menu, choose Programs > Microsoft SQL Server > Enterprise Manager.1. 
Expand the tree view as displayed in this window: Microsoft SQL Servers > <ServerName> >
Databases > UnityDb > Tables.

2. 

Right−click the Subscriber table, and choose Open Table > Query.3. 

Run a query by clicking the ! button. The query selects the Alias for the field that you are going to
search the record for, and the criteria should be =Unity_ServerName. In the example, the Cisco
Unity server name is Unity_Alex. Once you press ! button, the last pane returns the record that you
are trying to find (and the criteria will change to = N'Unity_ServerName'. Delete the value in the
field titled DirectoryId.

4. 



Close the table.5. 
From the Active Directory Users and Computers MMC plug in, delete the Unity_<ServerName>
account.

Note: Make sure you delete the account from the local domain controller so that when Cisco Unity
attempts to recreate the account later, replication from a remote domain controller does not force the
removal of the account again.

6. 

Log on to the Cisco Unity server by means of the same domain account you were logged in with
when you ran the Configuration Setup (Install account). Run the Configuration Setup from the
<Drive>:\Commserver\Configuration Setup directory, run setup.exe.

7. 

Run the DOHPropTest

On the Cisco Unity server, browse to the location where Cisco Unity is installed (the default is
C:\CommServer), and then browse to the TechTools folder.

1. 

Run DohPropTest.exe.2. 
In the DohPropTest logon dialog box, leave the Password box empty, and click OK.3. 
On the Warning dialog box, click Ignore to start the read−only mode of DohPropTest.4. 
Click GC Monitor to display the Directory Monitor dialog box, and click TotalResync.5. 
Close DohPropTest.6. 

Check the Application Event Log for Other Errors

Check the application event logs on the Exchange server on which the Unity_<ServerName> mailbox is
homed (or which Exchange Server has the physical mailstore for Unity_<ServerName>). Check for licensing
errors, RUS errors, and so on. If errors exist, try to investigate and resolve these errors. They might be
affecting Cisco Unity's functionality.

Check the event log errors on the partner Exchange server.



* AvMsgStoreMonitorSvr service applies to Cisco Unity 3.1(5) and later versions.

Related Information
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