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Introduction

The information in this document is based on Cisco Unity for Microsoft Exchange, all versions.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This document is not restricted to specific software and hardware versions.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Problem

When you attempt to open a voicemail message in ViewMail for Outlook (VMO), the user gets The
custom form could not be opened. Outlook uses the default form instead.
error message. The user is still able to listen to this same voicemail message with the use of the Media Player
in Microsoft Windows.



Solutions

This error can usually be resolved by one of two ways:

Make sure there are sufficient registry privileges and apply them.• 
Reinstall the VMO Client.• 

Make Sure There are Sufficient Registry Privileges

If there are insufficient registry privileges for the local non−administrative users of a subscriber computer, the
custom form available with VMO does not open for these users. This occurs even if the VMO installation was
completed successfully and without errors. When a subscriber who is a non−administrative user attempts to
open the VMO form, this error is displayed:

The custom form could not be opened. Outlook 
will use an Outlook form instead. An error occurred 
registering the form in the OLE registry.

Outlook custom forms require access to the registry key, HKEY_CURRENT_USER\Software\Classes. If the
proper permissions are not set for this key, non−administrative users are not able to open custom Outlook
forms, which includes the VMO form.

This document addresses the steps required to resolve insufficient registry privileges, but there can be other
reasons why a subscriber is not able to open the VMO form. You should first review the Problem section in
order to verify that insufficient registry privileges are the cause of your VMO form errors before you proceed
to the Solutions section.

There can be several explanations for why a subscriber cannot open a VMO form. Complete these steps in
order to verify that you experience insufficient registry privileges:

Log on to the computer as the subscriber who cannot open the VMO form, and start Outlook.1. 
Click New in order to open a blank e−mail message.2. 
In the Untitled Message form, choose Tools > Forms > Design This Form. This opens the form in
design mode.

3. 

Choose Tools > Forms > Publish Form As.4. 
In the Publish Form As dialog box, confirm that Personal Forms Library is selected in the Look In
menu.

5. 

In the Form Name field, enter test.6. 
Click Publish. When prompted, click No in order to indicate that you do not intend to send the form
to others.

7. 

Close the form. You do not need to save your changes.8. 
Complete these steps in order to open your test form:

Choose File > New > Choose Form.a. 
In the Choose Form dialog box, click Personal Forms Library from the Look In menu.b. 
Click your test form, and click Open.c. 

9. 

If this error message is displayed, you have successfully verified that the failure of the VMO form to
open is caused by insufficient registry privileges:

The custom form could not be 
opened. Outlook will use an Outlook form instead.
An error occurred registering the form in the OLE
registry.

10. 



Proceed to the How to Apply Proper Registry Privileges section in order to correct the problem. If you
did not receive the previous error, see the How to Reinstall the VMO Client section of this document.

How to Apply Proper Registry Privileges

Complete these steps in order to resolve insufficient registry privileges. SubscriberA represents any subscriber
who does not have local administrative rights on his or her computer, and who is unable to open the VMO
form due to insufficient registry privileges.

Grant local administrative rights to SubscriberA, and then log on to the computer of SubscriberA as
SubscriberA.

1. 

Start Regedt.32.exe. You cannot use Regedit.exe in order to perform this procedure.

 Caution: If you change the wrong registry key or enter an incorrect value, this can cause the

server to malfunction. Before you edit the registry, confirm that you know how to restore it if a
problem occurs. A typical backup of the Cisco Unity server does not back up the registry. For
additional information, refer to the Restoring the Registry Help topic in Regedit.exe or the Restoring a
Registry Key Help topic in Regedt32.exe. If you have any questions about changing this registry key
setting, contact the Cisco Technical Support.

2. 

If you do not have a current backup of the registry, choose Registry > Export Registry File, and save
the registry settings to a file.

3. 

Expand the HKEY_CURRENT_USER\Software\Classes key.4. 
While this key is highlighted, choose Security > Permissions.5. 
Complete these steps in the Permission For Classes dialog box:

Click SubscriberA in the Name box.a. 
Click the Read and Full Control boxes.b. 
Click OK.c. 

6. 

Close Regedt32.7. 
Log off the subscriber computer, and then log back on with an account that has local administrative
rights.

8. 

Remove SubscriberA from the local server administrative group.9. 
Log off the computer, and then log back on as SubscriberA.10. 
Start Outlook, and open the VMO form. You should be able to do so without error.

You can also change the registry privileges for a subscriber without the need to grant the subscriber
local administrative rights. In order to do so, first determine which key under HK_USERS belongs to
SubscriberA, and then change the permissions under the Software\Classes key as appropriate.

11. 

How to Reinstall the VMO Client

If you have set the proper registry privileges and still see the error message, you should consider the
reinstallation of the VMO client. Uninstall VMO on the client workstation with this procedure and then
reinstall the VMO Client.

Remove the \Program Files\Viewmail\ directory and all of its components.1. 
Remove all of these files (if they exist) from C:\Winnt\System32:

AvResLoaderSvrSL.dll♦ 
AvTrapConnectionHolderSvr.exe♦ 
AvTsmSL.dll♦ 
Avvox.acm♦ 
AvWavSl.dll♦ 

2. 



AvResSvr.dll♦ 
Unpublish the VMO form with this procedure:

From the menu in Microsoft Outlook, choose Tools > Options.a. 
Choose Other.b. 
Click Advanced Options.c. 
Click Custom Forms.d. 
Click Manage Forms.e. 
Make sure the Form Manager window is set to Personal Forms. Choose ViewMail for
Outlook, then click Delete.

f. 

Click Yes in order to delete the form.g. 
Click Close.h. 
Click OK to all the windows.i. 

3. 

Locate the file FRMcache.dat on the client workstation and rename the file to FRMcache.old.4. 
Reinstall the VMO client software. Instructions can be found in the Unity System Administration
Guide.

5. 

Note: You can find all the keys that VMO adds to the registry during the installation in the registry locations
localMachine > Software > Cisco Systems and localUser > Software > Cisco
Systems.

VMO Error in Windows XP

ActiveX one−off form error

During the attempt to listen to a voicemail with the ViewMail for Outlook in Windows XP, the To help
prevent malicious code from running, one or more objects in this form
were not loaded. For more information please contact your administrator.
error occurs.

Make sure there are no add−ons for Outlook that can block ActiveX controls.

Check for blocked ActiveX Controls in Outlook 2002 SP3 and Outlook 2003 that add restrictions on which
ActiveX controls run on one−off forms. In Outlook 2003, only the basic form controls, for example, text box,
combo box, and so forth, message body control, recipient control, and Outlook View Control load on a
one−off form. In Outlook 2002 SP3, the ActiveX controls that are not marked safe for scripting do not load.

The ideal solution for this issue is to avoid one−off forms completely. If you must use a one−off and you use
Outlook 2003, you can use a registry entry or policy in order to control the behavior.

Note: This option is not available in Outlook 2002 SP3.

In order to use a registry entry, add a DWORD value named AllowActiveXOneOffForms to the
HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\Security value and set it to one of these
values:

Set it to 0 in order to load only the frm20.dll controls, the Outlook View Control, Outlook Recipient
Control, and the docsite (message body) control.

• 

Set it to 1 in order to allow only controls marked as safe for initialization to load.• 
Set it to 2 in order to allow all ActiveX controls to load.• 



VMO error: Unknown problems are preventing the completion of the call

With VMO 3.x and 4.x that runs on Windows XP SP2, and the use of the phone as the playback/recording
device in order to play/record a voice mail with ViewMail for Outlook, the phone rings, and when the phone
is answered there is silence or the Unknown problems are preventing the completion of
the call. error message is displayed.

This is due to the Windows XP SP2 built−in firewall that blocks incoming traffic to TCP port 135. With
VMO telephone playback, Cisco Unity makes a DCOM callback to Outlook in order to fetch the audio stream
and since DCOM needs TCP port 135 to establish a connection, the callback fails. Other third party security
software such as anti−virus software and VPN software can also cause incoming DCOM calls to fail.

There are two options as the workaround:

Upgrade to VMO 4.0(4) and Cisco Unity 4.0 (4). The telephone record and playback feature in VMO
4.0(4) and Cisco Unity 4.0 (4) are redesigned such that there are no DCOM calls from Cisco Unity to
the Outlook. Therefore Cisco Unity is immune to client issues, such as RPC hang, DCOM traffic
blocked by third party security software, and so forth. Upgrade both Cisco Unity and VMO to version
4.0(4).

1. 

Set up the Windows XP SP2 Personal Firewall (add exceptions) in order to allow traffic to port 135
and also to allow the process C:\Windows\system32\AvTrapConnectionHolderSvr.exe process.

Refer to the Microsoft Knowledge Base article 842242 Some programs seem to stop working after
you install Windows XP Service Pack 2 for more information.

2. 

The Unknown problems are preventing the completion of the call error can also
occur when there is an IP address misconfiguration or a DNS problem. For example, you configured the IP
address of the Cisco CallManager instead of the Cisco Unity server, or, if you use a hostname, DNS resolution
is not successfully performed. You must configure the hostname or the IP address of the Cisco Unity server,
not the Cisco CallManager server, in order to configure Cisco Unity View Mail for Outlook (VMO) Media
Master to play back and record with the Cisco IP phone.

Complete these steps in order to resolve the issue:

Choose Options.1. 
On the Phone Record and Playback Settings window, enter your extension and the IP address or the
hostname of the Cisco Unity server. If you include a hostname, make sure that you can resolve the
name to the IP address of the Cisco Unity server.

If the previous steps did not resolve the issue, run Permissions Wizard  and make sure that the
Grant Dcomm rights and Enable the Media Master Control options are checked.

2. 

Prompt to enter credentials during an attempt to play a
voicemail with ViewMail for Microsoft Outlook

When you click the media bar play button on VMO in order to play a message, a prompt for credentials is
created. When you attempt to enter the correct credentials, login fails. If you choose the the cancel button, this
error messsage appears.

Access was denied when connecting to the voice server. To use the telephone you must be logged into windows using the account associated
         with your subscriber account.



Use DCOMCNFG

As a solution to the previous problem, run DCOMCNFG on both the Cisco Unity Server and user machine.
Choose Start > Run, type DCOMCNFG and press Enter.

Complete these steps:

Choose Default Properties and check Enable Distributed COM on this computer.1. 
Choose Connect for the Default Authentication level and Identify for the Default Impersonation
Level.

2. 

Run the Permission Wizard in the Cisco Unity server.3. 
Restart the Cisco Unity server.4. 

Users Experience Issues When the Voicemail Through PC
Speakers Using VMO Toolbar Plays

Some VMO users are unable to hear the voicemail messages, when PC speakers are selected as the playback
devices. There are no errors or warnings displayed in event viewer on the client PC and the Cisco Unity
server. If VMO users select their phone as playback device, it works just fine and it is possible to hear the
voicemail messages.

Solution

Check if the users who are not able to play messages shows the ViewMail add−on disabled in their Outlook
and if file that is disabled is tfxext32.dll. If so, choose Help > About Microsoft Office Outlook in the
Outlook client and click Disabled Items. Now, choose tfxext32.dll file and click Enable.



NetPro Discussion Forums − Featured Conversations

Networking Professionals Connection is a forum for networking professionals to share questions, suggestions,
and information about networking solutions, products, and technologies. The featured links are some of the
most recent conversations available in this technology.
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