簡介
本文檔介紹在vManage的實際分配計數不匹配時,如何清除CSSM門戶中的許可證分配。
問題
vManage例項和思科智慧軟體管理器(CSSM)門戶之間可能存在許可不匹配。這可能表現為不正確的許可證計數,在裝置刪除後未釋放許可證。
症狀
- vManage和CSSM門戶中的許可證計數顯示不同的值。
- vManage中的已刪除裝置不會在CSSM中釋放其分配的許可證,從而導致可用許可證的短缺。
- CSSM中的重複許可證報告(舊報告和新報告彙總)。
- 懷疑遇到以下錯誤:思科錯誤ID CSCwj27435或思科錯誤ID CSCwm39910
- vManage admin-tech檔案var/log/nms/vmanage-server.log中的錯誤消息類似於:
[vmanage-0] [SmartLicensingManager || SmartLicense: Failed to report license usage for tenant default : Exception: {"product_instance_identifier":["The identity for the instance is not valid.Please re-register the instance."]}
範例:
您可以在vManage中看到許可裝置數量為298,許可證總數為300。

但是,在許可門戶中,它顯示有598個許可證正在使用。它報告許可證使用量重複(300+298 = 598),在取消分配2個許可證之前報告了300個許可證,在取消分配兩個許可證之後報告了298個許可證。

根本原因
確定的主要原因是vManage資料庫中的過時許可證條目以及可能錯誤的智慧代理租戶元件資訊。這阻礙了與CSSM門戶的準確報告和同步。
解決方案
為了重新啟用vManage與CSSM門戶的同步,您需要開啟TAC案例,請求幫助以執行BUG中記錄的解決方法。
但是,如果CSSM門戶中的使用和可用許可證不匹配僅存在問題,則可以刪除當前許可分配並等待vManage生成新報告。
從思科中央門戶(CSSM)清除平衡
如果您沒有刪除任何重複或不正確報告的正確許可權,則此步驟通常需要與思科許可團隊接洽。
- 在思科軟體入口網站中,導覽至智慧軟體管理員>管理授權>選擇您的智慧和虛擬帳戶>清單>授權標籤,然後按一下授權。




- 現在,您會看到計數器Licenses in Use 0和所有可用的許可證。
在vManage中同步許可證
清理門戶後,從vManage啟動許可證同步。
至少等待24小時,使vManage再次同步到CSSM門戶。