简介
本文档介绍如何在Windows上的Webex应用中识别和解决常见的摄像头问题。
先决条件
要求
建议您熟悉以下主题:
使用的组件
此处列出的软件已用于进行测试并生成本文档中描述的结果:
- Windows 11
- 45.2版上的Webex应用
本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您的网络处于活动状态,请确保您了解所有命令的潜在影响。
常见摄像头问题概述
在Windows上使用Webex时,用户可能会遇到各种摄像头相关的问题,例如:
- 摄像头访问被拒绝。
- 摄像头已禁用或未检测到。
- 应用程序或驱动程序冲突。
- 未找到摄像头设备。
以下是一些摄像头连接问题示例以及解决这些问题的故障排除步骤。
问题 1:对摄像头的访问被拒绝
Error:

日志:
2024-11-25T15:41:28.579Z <Error> [0x3330][]WME:0 ::[WSE] CWseMFSourceReaderSink::CreateSourceReader() ActivateObject failed, hr=-2147024891
2024-11-25T15:41:28.579Z <Info> [0x3330][]WME:0 ::[WSE] CWSEMFVideoCapEngine::Start() Result = -2147024891
2024-11-25T15:41:28.579Z <Error> [0x3330][]WME:0 ::[WME] CWmeLocalVideoTrack::StartCamera, m_pVideoCapEngine start error, ret=1174552834
根本原因:
系统拒绝对摄像头的访问,可能是由于隐私设置。
解决方案:
1.在Windows中打开设置。
2.导航到隐私和安全>摄像头。
3.确保为应用启用摄像头访问,并允许Webex访问摄像头。
参考:摄像头隐私设置。

问题 2:摄像头已禁用
Error:

日志:
2024-11-25T17:14:42.426Z <Debug> [0x3330][]MediaConnection.cpp:7505 media::Connection::sendMediaErrorDirectly::media error: VideoCameraNoDevicePreCheck
2024-11-25T17:19:03.259Z <Debug> [0x326c][]AudioVideoSettingsViewModel::onMediaDeviceError::2, Media Device Error
根本原因:
摄像头在系统设置中禁用或未检测到。
解决方案:
1.打开“设备管理器”。
2.在“摄像头”下找到相机。
3.右键单击设备并选择启用。

问题 3:摄像头已在使用
Error:

日志:
2024-11-27T21:04:33.393Z <Warn> [0x2634][]CWseMFSourceReaderSink::OnReadSample failed! Result = -1072875772
2024-11-27T21:04:33.882Z <Debug> [0x1e50][]MediaConnection.cpp:10692 media::Connection::OnError::error type: VideoCameraOccupied
根本原因:
另一个应用程序(示例:Zoom、Microsoft Teams)正在使用摄像头,使Webex无法访问该摄像头。
解决方案:
1.关闭可能使用摄像头的任何其他应用程序。
2.重新启动Webex并重试。
问题 4:未找到摄像头设备
Error:

日志:
2024-11-22T03:06:53.268Z <Error> [0x492c][]CWseVideoCapDevice::InitCapCapability(), GetBaseFilter_i failed, hr=-2147024894
根本原因:
错误代码0x80070002(ERROR_FILE_NOT_FOUND)表示未找到摄像头设备。
解决方案:
1.打开Device Manager并卸载Integrated Webcam。
2.重新启动系统,并让Windows自动重新安装驱动程序。
3.确保摄像头驱动程序是最新的。
4.验证防病毒软件是否阻止了Webex访问设备。