简介

    本文档介绍如何对注册到Cisco Unified Communications Manager(CUCM)的IP电话上的“找不到主机”服务小程序进行故障排除。

    先决条件

    要求

    Cisco 建议您了解以下主题:

    • CUCM 10.0及更高版本
    • IP 电话
    • 批量管理工具(BAT)

    使用的组件

    本文档中的信息基于以下软件版本:

    • CUCM 10.0版
    • IP 电话

    本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

    问题

    如果您的电话出现上述任何一种行为,则您会受到问题的影响。

    • IP电话始终在处于空闲状态的屏幕上显示服务小程序
    • 即使不按服务按键,服务小程序也会出现在电话屏幕上
    • 如果是SIP电话,问题将显示在名为Idle Application的窗口中,并在屏幕上显示错误“Host Not Found”,如图所示

    原因

    • 在CUCM 10.0及更高版本中,自动注册由允许您选择模板的新参数管理
    • 参数为Universal Device Template,默认值为Auto-registration Template
    • 默认情况下,自动注册模板配置了空闲URL
    • 自动注册的电话,使用此模板,因此电话也在其配置中获得空闲URL
    • 因此,当电话处于空闲状态时,会弹出服务小程序

    解决方案

    步骤1:导航到用户管理>用户/电话添加>通用设备模板

    第二步:选择Auto-registration Template

     第三步:在Service Configuration Settings下,确保Idle URL为空,并且下拉列表设置为Override,如图所示。

    第四步:保存配置。

    第五步:在电话上,导航至主页并将Idle URL留空。

    第六步:保存应用配置

    步骤 7.重置电话。激活后,电话恢复正常。

    注意:如果多个电话受到影响,请使用BAT更新空闲URL并将其保存为空。