はじめに
このドキュメントでは、Finesse Supervisor Desktop に表示される情報が多すぎる場合に Cisco Unified Contact Center Express(UCCX)で発生する問題について説明し、さらにその問題の回避策についても説明します。
前提条件
要件
Finesse Desktop 搭載 UCCX バージョン 10.0 以降に関する知識があることが推奨されます。
使用するコンポーネント
このドキュメントの情報は、Finesse Desktop 搭載 UCCX バージョン 10.0 以降を基準にして記述しています。
このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されました。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼働中である場合には、どのようなコマンドについても、その潜在的な影響について確実に理解しておく必要があります。
問題
Finesse Supervisor Desktop では、Finesse の [キューデータ(Queue Data)] タブの [音声CSQ要約レポート(Voice CSQ Summary Report)] に、UCCX で設定されている各コンタクト サービス キュー(CSQ)の統計情報が表示されます。このレポートは、Cisco Unified Intelligence Center(CUIC)からライブ情報を取得する、組み込み型のライブ データ ガジェットです。 スーパーバイザは、エージェントの割り当て先チームを問わず、Finesse の [チームデータ(Team Data)] タブからログインしたエージェントをすべて参照することもできます。
これまでの観察によると、ログインされたすべてのキューおよびエージェントを参照できるのは、一部のスーパーバイザに限られています。この問題は、表示される情報が多すぎることが原因で発生し、コンタクト センター環境全体に影響を及ぼします。
原因
この問題が発生する原因は、スーパーバイザをレポート ユーザとして設定することも可能であるという点にあります。スーパーバイザを履歴レポート ユーザに設定すると、スーパーバイザは AllUsers.ReportingUsers グループにも割り当てられ、これによって、アクセス可能なコレクション リストが変更(範囲が拡張)されます。
Finesse Supervisor Desktop の [キューデータ(Queue Data)] タブには、CUIC ライブ データに基づいて、音声 CSQ 要約レポート、音声 CSQ エージェント詳細レポート、およびエージェント統計情報レポートからデータが取得されます。スーパーバイザの範囲に対応する CSQ エントリが表示されます。スーパーバイザはレポート ユーザでもあるため、ここではそれがすべての CSQ となります。
Finesse Supervisor Desktop の [チームデータ(Team Data)] タブには、CUIC ライブ データに基づいて、エージェント統計情報レポートからデータが取得されます。スーパーバイザの範囲に対応するエージェントが表示されます。スーパーバイザはレポート ユーザでもあるため、ここではそれがすべてのエージェントとなります。
注:デフォルトで、スーパーバイザには、『Cisco Unified Contact Center Express Report User Guide 10.6(1)』に記載されているライブデータレポートへのアクセス権のみが付与されます。
回避策
注:この問題は、Cisco Bug ID CSCus17605に関連する拡張要求として追跡されています。
この問題の回避策を実施することで、Finesse Supervisor Desktop に表示される統計情報の範囲が狭まります。これには、[Finesse管理(Finesse Administration)] ページを経由した XML レイアウトの変更も含まれます。ガジェットごとに URL を変更する必要があります。ランダム データの例は次のとおりです。
注:このセクションのXMLコードをコピーして貼り付けないでください。これは例として示したものです。Finesse の XML コードの変更は、個々の事例に応じて行います。
チーム「blue」のリソースであるスーパーバイザが、チーム「blue」とチーム「red」に割り当てられている CSQ の CSQ データを確認したいが、それ以外の、これら 2 つのチームに割り当てられていない CSQ の CSQ データは必要ないという場合は、次の例に示すように、[チームリソース(Team Resources)] タブの [Finesse管理(Finesse Administration)] ページで、チーム「blue」の Finesse レイアウト XML の queueData URL を編集します。
<id>queueData</id>
<label>finesse.container.tabs.supervisor.queueDataLabel</label>
<columns>
<column>
<gadgets>
<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveData
Gadget.jsp?gadgetHeight=620&viewId_1=C8E2DB1610000140000000A60A4E5E6B&filterId_1
=VoiceIAQStats.esdName=CL%20blue,%20red&viewId_2=9A7A14CE10000140000000ED0A
4E5E6B&filterId_2=VoiceCSQDetailsStats.agentId=CL%20blue,%20red&compositeFilterId
=VoiceCSQDetailsStats.AgentVoiceCSQNames.agentVoiceCSQName=CL%20blue,%20red
&viewId_3=C8EF510810000140000000EB0A4E5E6B&filterId_3=VoiceIAQStats.esdName
=CL%20blue,%20red&viewId_4=C8EE241910000140000000C30A4E5E6B&filterId_4
=VoiceIAQStats.esdName=CL%20blue,%20red</gadget>
同様に、チーム「blue」のリソースであるスーパーバイザが、チーム「blue」とチーム「red」のメンバーのチーム データを参照したいが、それ以外の、これら 2 つのチームに含まれないエージェントのチーム データは必要ないという場合は、次の例に示すように、チーム「blue」の teamData URL を編集します。
<id>teamData</id>
<label>finesse.container.tabs.supervisor.teamDataLabel</label>
<columns>
<column>
<gadgets>
<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=620&viewId_1=7291DCB410000140000000890A4E5B33&filterId_1=
ResourceIAQStats.resourceId=CL%20blue,%20red&viewId_2=728283C210000140000000530A4E5B33
&filterId_2=ResourceIAQStats.resourceId=CL%20blue,%20red</gadget>
この例についての重要な注記を次に示します。
- URL 内で CL のみを使用すると、スーパーバイザが権限を持っているすべてのコレクションの値がレポートに含まれます。
- URL内でCL%20<Team_Name>を使用する場合、<Team_Name>は、スーパーバイザがデータを参照したいチームの実際の名前に置き換えられます。そのため、<Team_Name>のデータのみが表示されます。URL 内の <Team_Name> はプレースホルダであり、CUIC サーバに送信される前に、Finesse から CUIC ガジェット コードに渡される実際の値に置き換えます。複数のチーム(たとえば「N」個のチーム)のデータを参照したい場合は、CL%20<Team_Name_1>,%20<Team_Name_2>,...,%20<Team_Name_N> のようにする必要があります。
- (blue が実際のチーム名であるという前提で)URL 内で CL%20blue を使用すると、blue のコレクションに所属する値のみが表示されます。
- (blue と red が実際のチーム名であるという前提で)URL 内で CL%20blue,%20red を使用すると、blue のコレクションと red のコレクションに所属する値のみが表示されます。
これらの変更は、その他のガジェットにも同様に実装する必要があります。ライブ データのガジェット定義およびガジェット URL に関する詳細については、『Cisco Unified CCX Administration Guide, Release 10.6』を参照してください。
注:デスクトップレイアウトのチームレベルで変更を完了する必要があるため、この回避策は慎重に評価して使用する必要があります。チーム レベルで編集を行うと、システムのデフォルト レイアウトを上書きすることができます。
注:スペースを含むチーム名を使用できますが、スペースを表すためにXMLレイアウトを%20で設定する必要があります。
機能の導入
UCCX 11.6 では、新しい機能が導入されて、この問題が全面的に解決されました。この機能は、Cisco bug ID CSCus17605 に関連する拡張要求を通じて追加されました。
UCCX 11.6 以降では、スーパーバイザは自身のチームの履歴レポートへのアクセス権限を持っているので、追加のレポート ユーザ ロールを設定する必要がありません。このようにして、Finesse Live Data レポートにはスーパーバイザ自身のチームのみが表示されるようになり、スーパーバイザは、レポート ユーザ ロールを持つ必要なく、引き続き自チームの履歴レポートにアクセスすることができます。任意のユーザにレポート ユーザ ロールを追加すると、すべてのレポートで全チームのエージェントおよび CSQ を参照できるアクセス権がそのユーザに付与され、Finesse ライブ データ レポートですべてのエージェントおよび CSQ を参照できるようになります。