はじめに
このドキュメントでは、Cisco Unified Contact Center Express(UCCX)スクリプト エディタ バージョン 10.5(1) の起動時に発生する問題について説明します。
問題
UCCXエディタバージョン10.5(1)(CiscoUnifiedCCXEditor.exe)を実行できません。
症状
起動すると、UCCXエディタウィンドウが1秒以内に表示されて消えます。アプリケーションが起動しようとするが、表示されない。
解決方法
この問題を解決するには、CCXエディタのファイルがC:\Program Files (x86)\wfavvid_1051フォルダにあるかどうかを確認する必要があります。これを確認するには、Editorアイコン(ショートカット)を右クリックし、Properties > Targetに移動します。インストールフォルダは直接C:\Program files(x86)にあります。
パスが正しくない場合があります。例:C:\Program Files (x86)\Cisco\Unified Serviceability\JRtmt\wfavvid_1051。
この問題を解決するには、次の手順を実行します。
- ワークステーションでCCX Script Editorアプリケーションをアンインストールするには、Control Panel > Add/Remove programsの順に選択します。
- エディタアプリケーション(管理者として実行)を直接Program Filesに再インストールし、C:\Program Files (x86)\wfavvid_1051のパスを明示的に定義します。
- テストするにはアプリケーションを実行します。
根本原因
この問題は、インストールのデフォルトの場所(パス)に関連しています。 その場所にハードコードされているファイルを検索し、それらのファイルが見つからない場合は起動しません。デフォルトでは、CCXエディタはC:\Program Files (x86)\wfavvid_1051にインストールする必要があります。そうでない場合、エディタは正常に動作しません。これをテストするには、wfavvid_1051フォルダを別の場所にコピーすると、問題が再現することがあります。
また、リアルタイム監視ツール(RTMT)が以前にワークステーションにインストールされている場合、UCCXエディタからC:\Program Files (x86)\Cisco\Unified Serviceability\JRtmt\wfavvid_1051の誤ったパスにインストールするように求めるメッセージが表示されることもわかっています。
正しくない場所にインストールすると、エディタの起動に失敗します。この時点で、前述の手順を実行して問題を解決する必要があります。回避策は実施されていますが、インストール関連の問題を簡素化して解決するための機能拡張不具合CSCur86817が公開されています。