Introducción
Este documento describe cómo limpiar las asignaciones de licencias del portal CSSM cuando hay una discordancia en el recuento de asignaciones reales de vManage.
Problema
Puede encontrar una discordancia de licencias entre la instancia de vManage y el portal de Cisco Smart Software Manager (CSSM). Esto puede manifestarse como recuentos de licencias incorrectos, las licencias no se liberan después de la eliminación del dispositivo.
Síntomas
- Los recuentos de licencias en vManage y el portal CSSM muestran valores diferentes.
- Los dispositivos eliminados en vManage no liberan sus licencias asignadas en CSSM, lo que provoca una escasez de licencias disponibles.
- Informes de licencias duplicados en CSSM (resumen de informes antiguos y nuevos).
- El sospechoso golpea algunos de estos errores: Id. de bug Cisco CSCwj27435 o Id. de bug Cisco CSCwm39910
- Mensajes de error en el archivo admin-tech de vManage var/log/nms/vmanage-server.log similar a:
[vmanage-0] [SmartLicensingManager || SmartLicense: Failed to report license usage for tenant default : Exception: {"product_instance_identifier":["The identity for the instance is not valid.Please re-register the instance."]}
Ejemplo:
Puede ver en vManage que el número de dispositivos con licencia es de 298 y el número total de licencias es de 300.

Sin embargo, en el portal de licencias se demostró que se están utilizando 598 licencias. Informa sobre un número duplicado de licencias en uso (300+298 = 598), 300 licencias notificadas antes de anular la asignación de 2 licencias y 298 licencias notificadas después de anular la asignación de las dos licencias.

Causa raíz
La causa principal identificada fueron entradas de licencia obsoletas en la base de datos de vManage e información del componente de arrendatario de Smart Agent potencialmente incorrecta. Esto impedía la generación de informes precisos y la sincronización con el portal CSSM.
Solución
Para reactivar la sincronización de vManage al portal CSSM, debe abrir un caso TAC para solicitar ayuda para realizar la solución alternativa documentada en los errores de funcionamiento.
Sin embargo, si solo hay un problema con la discordancia en el uso y las licencias disponibles en el portal CSSM, puede eliminar las asignaciones de licencias actuales y esperar hasta que vManage genere el nuevo informe.
Limpieza del saldo de Cisco Central Portal (CSSM)
Normalmente, este paso requiere la participación del equipo de licencias de Cisco si no tiene el privilegio correcto para eliminar los informes duplicados o incorrectos.
- En Cisco Software Portal, navegue hasta Smart Software Manager > Manage licenses > Select your Smart and Virtual Account >Inventory > Licenses y haga clic en la pestaña license.

- Navegue hasta Instancias de producto y haga clic en la Instancia.


- A continuación, elimine el uso de la licencia.

- Ahora, verá el contador Licencias en uso 0 y todas las licencias disponibles.
Sincronizar licencias en vManage
Después de limpiar el portal, inicie una sincronización de licencias desde vManage.
Espere al menos 24 horas para que vManage se sincronice de nuevo con el portal CSSM.