Introducción
Este documento describe un error que se ha producido al instalar Cisco TelePresence Management Suite (TMS) debido a un error en la instalación del lenguaje de consulta estructurado (SQL) 2008. También detalla cómo resolver este problema.
Antecedentes
Cisco TelePresence Management Suite (TMS) almacena todos sus datos de clientes en su base de datos SQL denominada tmsng. Este almacenamiento independiente permite realizar copias de seguridad y recuperar la información del cliente.
Para las nuevas instalaciones, el instalador crea tmsng con los valores predeterminados del servidor SQL. Las actualizaciones reutilizan una base de datos actual de Cisco TMS.
Versión del servidor SQL
Se requiere una de estas versiones de servidor:

Problema
La instalación de TMS falla cuando se ejecuta el instalador. En la fase de instalación cuando ejecuta la instalación SQL, se detiene con este error.


Cuando se vuelve a ejecutar el instalador, detecta el SQL parcialmente instalado y le pide que introduzca la contraseña sa. Pero después de introducirlo, el mensaje de error aparece de nuevo.

Causa
Los registros de instalación de SQL 2008 se pueden encontrar aquí: C:\Program Files (x86)\Microsoft SQL Server\100\Setup Bootstrap\Log.
Cuando se detiene la instalación, se crea una carpeta específica para los registros de instalación. En la carpeta, hay un archivo llamado detail.txt. Cuando la instalación falla para SQL, aparece este error.
2014-11-09 06:29:55 Slp: Error result: -2068643839
2014-11-09 06:29:55 Slp: Result facility code: 1203
2014-11-09 06:29:55 Slp: Result error code: 1
2014-11-09 06:29:55 Slp: Sco: Attempting to create base registry key HKEY_LOCAL_
MACHINE, machine
2014-11-09 06:29:55 Slp: Sco: Attempting to open registry subkey
2014-11-09 06:29:55 Slp: Sco: Attempting to open registry subkey Software\Microsoft\
PCHealth\ErrorReporting\DW\Installed
2014-11-09 06:29:55 Slp: Sco: Attempting to get registry value DW0200
2014-11-09 06:30:29 Slp: Submitted 1 of 1 failures to the Watson data repository
2014-11-09 06:30:38 Slp: Detected localization resources folder: 1033
2014-11-09 06:30:38 Slp: Detected localization resources folder: 1033
Este error ocurre porque el usuario no tiene el control completo de esta clave de registro: HKLM\Software\Policies\Microsoft\Windows\Installer.
Solución
Complete estos pasos para solucionar el problema:
- Desinstale SQL Server 2008 R2. Vaya al Panel de control, seleccione SQL Server 2008, haga clic con el botón derecho y seleccione Unistall. Siga este procedimiento para todos los componentes SQL instalados con la instalación.
- Elimine la carpeta Microsoft SQL Server en C:\Program Files (x86).
- Reinicie el sistema.
- Una vez que el sistema esté activo, agregue el usuario que realiza la instalación en este archivo:
Start | Run | Type: gpedit.msc | OK | Navigate to Computer Configuration\Windows
Settings\Security Settings\Local Policies\User Rights Assignment\Debug programs

- Haga doble clic en Depurar programas.

- Haga clic en Agregar usuario o grupo y seleccione el usuario que realiza la instalación.

- Haga clic en Apply (Aplicar).

- Reinicie el sistema y vuelva a ejecutar el instalador de TMS. Esta vez, la instalación debe realizarse correctamente.