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C H A P T E R 5

Monitoring Maps

This chapter describes how to add maps to the Cisco WCS database and use them to monitor your 
wireless LAN. With the WCS database, you can add maps and view your managed system on realistic 
campus, building, and floor maps. 

Note Additionally, you can enable location presence by mobility server to provide expanded Civic (city, state, 
postal code, country) and GEO (longitude, latitude) location information beyond the Cisco default 
setting (campus, building, floor, and X, Y coordinates). This information can then be requested by clients 
on a demand basis for use by location-based services and applications. Location Presence can be 
configured when a new campus, building, floor, or outdoor area is being added or configured at a later 
date.

Note A mobility server should be synchronized before Location Presence is enabled. For details on enabling 
location presence and assigning its parameters, refer to Cisco Context-Aware Services documentation at 
this location:

http://www.cisco.com/en/US/docs/wireless/mse/3350/5.2/CAS/configuration/guide/msecg_ch7_CAS.h
tml. 

This configuration guide also covers verifying location accuracy, using chokepoints, using Wi-FI TDOA 
receivers, applying calibration models and other context-aware planning and verification topics.

This chapter contains the following sections:

• Information About Maps, page 5-2

• Guidelines and Limitations, page 5-19

• Monitoring Maps, page 5-22

• Searching Maps, page 5-71

• Using Map Editors, page 5-71

• Inspecting Location Readiness and Quality, page 5-78

• Using Planning Mode, page 5-101

• Refresh Options, page 5-108

• Creating a Network Design, page 5-109

• Importing or Exporting WLSE Map Data, page 5-114
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• Device Details, page 5-115

Information About Maps
This section contains the following topics:

• Maps, page 5-2

• Campus, page 5-3

• Building, page 5-3

• Floor Area, page 5-4

• Access Points, page 5-4

• Chokepoints, page 5-4

• Wi-Fi TDOA Receivers, page 5-4

• Map Editor, page 5-4

• Floor Settings, page 5-5

Maps
Maps provide a summary view of all your managed systems on campuses, buildings, outdoor areas, and 
floors. The available information includes:

• Total APs—Number of total access points for each map.

• 802.11a/n Radios and 802.11b/g/n Radios—Number of 802.11a/n and 802.11b/g/n radios associated 
with each map.

• Out of Service (OOS) Radios—Number of 802.11a/n and 802.11b/g/n radios associated with each 
map.

• Clients—Number of clients associated to access points on the map. 

Note This number is based on the most recent Client Statistics Poll. The number of clients located on 
the map by MSE may not match this number.

• 802.11a/n and 802.11b/g/n Avg Air Quality—Indicates the average Air Quality (AQ) for 802.11a/n 
and 802.11b.g.n radios.

• 802.11a/n and 802.11b/g/n Min Air Quality—Indicates the minimum Air Quality (AQ) for 
802.11a/n and 802.11b/g/n radios.

• Status—Indicates the current status of the map.

– Red triangle—Critical fault

– Yellow triangle—Minor fault

– Green square—Ok

Note To view or edit current maps, choose Monitor > Maps (see Figure 5-1) and choose the appropriate map 
from the list. Use the Select a command drop-down list to access additional functionality.
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Figure 5-1 Maps Window

The left sidebar menu lists all campuses, buildings, and floors in a tree view. When you click a campus, 
building, or floor in the Maps Tree View menu, the main area of the window displays corresponding 
information.

Note Click Edit View to change the information displayed for the listed maps. See the “Configuring Edit 
View” section on page 5-23 for more information.

Note Root Area (listed in the Maps Tree View menu) displays a list of buildings that are not in campuses. 
Status and object counts for Root Area buildings are not aggregated.

Use the Select a command drop-down list for additional map functionality. 

To search for a specific map, use the WCS Search feature. See Advanced Search, page 2-35 for more 
information. You can search using the following map parameters:

• Search for—Choose All Maps, Campuses, Buildings, Floor Areas, or Outdoor Areas.

• Map Name

Campus
A campus is the area in which a building or set of surrounding buildings are situated.

Building
A building is a structure which has a roof and walls and stands more or less permanently in one place.
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Floor Area
The floor area is the area of each floor of the building measured to the outer surface of the outer walls 
including the area of lobbies, cellars, elevator shafts and in multi-dwelling buildings all the common 
spaces. 

Access Points
Access Points (APs) are specially configured nodes on wireless local area networks (WLANs). Access 
points act as a central transmitter and receiver of WLAN radio signals. Access points support Wi-Fi 
wireless communication standards.

Chokepoints
Installation of chokepoints provides enhanced location information for RFID tags. When an active Cisco 
Compatible Extensions version 1 compliant RFID tag enters the range of a chokepoint, it is stimulated 
by the chokepoint. The MAC address of this chokepoint is then included in the next beacon sent by the 
stimulated tag. All access points that detect this tag beacon then forward the information to the controller 
and location appliance.

Wi-Fi TDOA Receivers
TDoA technology uses a time-based method to calculate the location. Each Wi-Fi TDoA receivers report 
the time of arrival of the signal from the tag to its respective receiver. The Cisco Mobility Services 
Engine correlates the time of arrival for all the tag signals from all the TDoA receivers to find the 
intersection points of known distances. The greater the number of receivers used in the calculation, the 
more accurately the tag can be located. Wi-Fi TDoA receivers are typically used for calculating location 
information in manufacturing or retail warehouse environments (where there are lots of machines or high 
ceilings or both), in outdoor environments, or in other line-of-site environments.

Map Editor
You can use the WCS map editor to define, draw, and enhance floor plan information. The map editor 
enables you to create obstacles to consider when you computer RF prediction heat maps for access 
points. You can also add coverage areas for MSEs that locate clients and tags in that particular area. 
Follow these general guidelines to use the map editor.

Map Editor Functions

With the map editor, you can perform the following functions:

• Save—Saves the current map image.

• Recompute prediction—Updates the RF prediction heatmap if any changes are made to the existing 
floor map image.

• Reload Last Saved—Loads the last saved map image.

• Select all—Selects all the obstacles and coverage areas that you have created.
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• Unselect—Deselects the obstacles and coverage areas that are selected.

• Move selected Obstacles—Moves the selected obstacles to a different location on the map.

• Duplicate selected Obstacles—Creates a copy of the selected obstacles.

• Zoom in/Zoom out— Zoom in or out on the image you are currently viewing.

• Show floor image—Use this to display the floor image.

• Show obstacles—Use this to display the obstacles.

• Larger resolution/Medium resolution/Smaller resolution—Increase or decrease the resolution of the 
floor map image.

• SNAP Mode—Use this to snap an obstacle to its nearest obstacle while drawing.

• ORTHO Mode—Use to draw a horizontal or vertical obstacle. This is especially useful when you 
want to draw all the obstacles at right angles.

Floor Settings
You can modify the appearance of the floor map by selecting or unselecting Floor Settings check boxes. 
The selected Floor Settings are displayed in the map image. 

Note Depending on whether or not a mobility services engine is present in WCS, some of the floor settings 
may not be displayed. 

The Floor Settings options include the following:

• Access Points—See the “Filtering Access Point Floor Settings” section on page 5-6 for more 
information.

• AP Heatmaps—See the “Filtering Access Point Heatmap Floor Settings” section on page 5-10 for 
more information.

• AP Mesh Info—Appears only if mesh access points are present in outdoor areas. See the “Filtering 
AP Mesh Info Floor Settings” section on page 5-11 for more information.

• Clients—Displays data only if a mobility services engine was added in WCS. See the “Filtering 
Client Floor Settings” section on page 5-11 for more information.

• 802.11 Tags—See the “Filtering 802.11 Tag Floor Settings” section on page 5-13 for more 
information.

• Rogue APs—Displays data only if a mobility services engine was added in WCS. See the “Filtering 
Rogue AP Floor Settings” section on page 5-13 for more information.

• Rogue Adhocs—Displays data only if a location server was added in WCS. See the “Filtering Rogue 
Adhoc Floor Settings” section on page 5-14 for more information.

• Rogue Clients—Displays data only if a location server was added in WCS. See the “Filtering Rogue 
Client Floor Settings” section on page 5-14 for more information.

• Coverage Areas

• Location Regions

• Rails

• Markers

• Chokepoints—Appears only if chokepoints are added in WCS.
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• Wi-Fi TDOA Receivers

• Interferers—Displays details of the interferers on the wireless network. See the “Filtering Interferer 
Settings” section on page 5-14 for more information.

Use the blue arrows to access Floor Setting filters for access points, access point heatmaps, clients, 
802.11 tags, rogue access points, rogue adhocs, and rogue clients. When filtering options are selected, 
click OK.

Use the Display MSE data within last drop-down list to select the timeframe for mobility services engine 
data. Choose to view mobility services engine data from a range including the past two minutes up to 
the past 24 hours. This option only appears if a mobility services engine is present on the WCS.

Click Save Settings to make the current view and filter settings your new default for all maps.

Figure 5-2 Floor Settings Parameters

Filtering Access Point Floor Settings

If you enable the Access Point floor setting and then click the blue arrow to the right of the Floor 
Settings, the access point filter page opens with filtering options.

Figure 5-3 Access Point Filter
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Access point filtering options include the following:

• Show—Choose to display the radio status or access point status.

Note Because the access point icon color is based on the access point status, the icon color may 
vary depending on the status selected. The default on floor maps is radio status.

• Protocol—From the drop-down list, select which radio types to display (802.11a/n, 802.11b/g/n, or 
both).

Note The displayed heatmaps correspond with the selected radio type(s).

• Display—From the drop-down list, select what identifying information is displayed for the access 
points on the map image.

– Channels—Displays the Cisco Radio channel number or Unavailable (if the access point is not 
connected).

Note The available channels are defined by the country code setting and are regulated by 
country. Refer to:
http://www.cisco.com/en/US/prod/collateral/wireless/ps5679/ps5861/product_data_sh
eet0900aecd80537b6a_ps430_Products_Data_Sheet.html

– TX Power Level—Displays the current Cisco Radio transmit power level (with 1 being high) or 
Unavailable (if the access point is not connected).

Note The power levels differ depending on the type of access point. The 1000 series access 
points accept a value between 1 and 5, the 1230 access points accept a value between 1 
and 7, and the 1240 and 1100 series access points accept a value between 1 and 8. 

Table 5-1 lists the transmit power level numbers and their corresponding power setting.

Table 5-1 Transmit Power Level Values

Transmit Power
Level Number Power Setting

1 Maximum power allowed per country code setting

2 50% power

3 25% power

4 12.5 to 6.25% power

5 6.25 to 0.195% power
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Note The power levels are defined by the country code setting and are regulated by country. 
Refer to:
http://www.cisco.com/en/US/prod/collateral/wireless/ps5679/ps5861/product_data_sh
eet0900aecd80537b6a_ps430_Products_Data_Sheet.html

– Channel and Tx Power—Displays both the channel and transmit power level (or Unavailable if 
the access point is not connected).

– Coverage Holes—Displays a percentage of clients whose signal has become weaker until the 
client lost its connection, Unavailable for unconnected access points, or MonitorOnly for access 
points in monitor-only mode.

Note Coverage holes are areas in which clients cannot receive a signal from the wireless 
network. When you deploy a wireless network, you must consider the cost of the initial 
network deployment and the percentage of coverage hole areas. A reasonable coverage 
hole criterion for launch is between 2 and 10 percent. This means that between two and 
ten test locations out of 100 random test locations might receive marginal service. After 
launch, Cisco Unified Wireless Network Solution radio resource management (RRM) 
identifies these coverage hole areas and reports them to the IT manager, who can fill 
holes based on user demand.

– MAC Addresses—Displays the MAC address of the access point, whether or not the access 
point is associated to a controller.

– Names—Displays the access point name. This is the default value.

– Controller IP—Displays the IP address of the controller to which the access point is associated 
or Not Associated for disassociated access points.

– Utilization—Displays the percentage of bandwidth used by the associated client devices 
(including receiving, transmitting, and channel utilization). Displays Unavailable for 
disassociated access points and MonitorOnly for access points in monitor-only mode.

– Profiles—Displays the load, noise, interference, and coverage components of the corresponding 
operator-defined thresholds. Displays Okay for thresholds not exceeded, Issue for exceeded 
thresholds, or Unavailable for unconnected access points. 

Note Use the Profile Type drop-down list to select Load, Noise, Interference, or Coverage.

– CleanAir Status—Displays the CleanAir status of the access point, whether or not CleanAir is 
enabled on the access point.

– Average Air Quality—Displays the average air quality on this access point. The details include, 
the band, and the average air quality.

– Minimum Air Quality—Displays the minimum air quality on this access point. The details 
include, the band and the minimum air quality.

– Average and Minimum Air Quality—Displays the average and minimum air quality on this 
access point. The details include, the band, average air quality, and minimum air quality.

– Associated Clients—Displays the number of associated clients, Unavailable for unconnected 
access points, or MonitorOnly for access points in monitor-only mode.
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Note Click the client number to view client details. See “Monitor > Clients” for more 
information.

– Bridge Group Names

• RSSI Cutoff—From the drop-down list, choose the RSSI cutoff level. The RSSI cutoff ranges from 
-60 dBm to -90 dBm.

• Show Detected Interferers—Select the check box to display all interferers detected by the access 
point.

• Max. Interferers/label—choose the maximum number of interferer to be displayed per label from 
the drop-down list.

Click OK when all applicable filtering criteria are selected.

Understanding RF Heatmap Calculation

The RF heatmap calculation is based on an internal grid. Depending on the exact positioning of an 
obstacle in that grid, the RF heatmap, within a few feet or meters of the obstacle, may or may not account 
for the obstacle attenuation.

In detail, grid squares partially affected by an obstacle crossing the grid square may or may not 
incorporate the obstacle attenuation according to the geometry of the access point, obstacle, and grid.

For example, consider a wall crossing one grid square. The midpoint of the grid square is behind the wall 
from the AP, so the whole grid square is colored with attenuation, including (unfortunately) the top left 
corner that is actually in front of the wall (see Figure 5-4).

Figure 5-4 Access Point/Grid Example One (Actual Attenuation)

Figure 5-5 displays how the attenuation would ideally appear in this situation.
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Figure 5-5 Access Point/Grid Example One (Ideal Attenuation)

The midpoint of the grid square is on the same side of the wall as the AP, so the whole grid square is not 
colored with attenuation, including (unfortunately) the bottom right corner that is actually behind the 
wall from the AP (see Figure 5-6).

Figure 5-6 Access Point/Grid Example Two (Actual Attenuation)

Figure 5-7 displays how the attenuation would ideally appear in this situation.

Figure 5-7 Access Point/Grid Example Two (Ideal Attenuation)

Filtering Access Point Heatmap Floor Settings

If you enable the Access Point Heatmap floor setting and click the blue arrow to the right of the Floor 
Settings, the Contributing APs page opens with heatmap filtering options. 
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Access point heatmap filtering options include:

• Heatmap Type—Select IDS, Coverage, or Air Quality. If you choose Air Quality, you can further 
filter the heat map type for access points with average air quality or minimum air quality. Select the 
appropriate radio button.

Note If you have monitor mode access points on the floor plan, you have a choice between IDS 
or coverage heatmap types. A coverage heatmap excludes monitor mode access points.

Note Heatmap filtering type (“IDS” versus “Coverage”) will not be available unless an IDS 
(monitor) AP is on the map.

• Total APs—Displays the number of access points positioned on the map.

• Select the access point check box(es) to determine which heatmaps display on the image map.

Click OK when all applicable filtering criteria are selected.

Filtering AP Mesh Info Floor Settings

Note The AP Mesh Info option only appears when bridging access points are added to the floor. 

When this option is selected, Cisco WCS initiates a contact with the controllers and displays information 
about bridging access points. The following information is displayed:

– Link between the child and the parent access point.

– An arrow that indicates the direction from child to parent access point.

– A color coded link that indicates the signal-to-noise ratio (SNR). A green link represents a high 
SNR (above 25 dB), an amber represents an acceptable SNR (20-25 dB), and a red link 
represents a very low SNR (below 20 dB).

If you enable the AP Mesh Info floor setting and click the blue arrow to the right of the floor settings, 
the Mesh Parent-Child Hierarchical View page opens with mesh filtering options.

You can update the map view by choosing the access points you want to see on the map. From the Quick 
Selections drop-down list, choose to select only root access point, various hops between the first and the 
fourth, or select all access points.

Note For a child access point to be visible, its parent must also be selected.

Click OK when all applicable filtering criteria are selected.

Filtering Client Floor Settings

Note The Clients option only displays if a mobility server is added in WCS.

If you enable the Clients floor setting and click the blue arrow to the right, the Client Filter page opens.
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Figure 5-8 Client Filter Window

Client filtering options include:

• Show All Clients—Select the check box to display all clients on the map.

• Small Icons—Select the check box to display icons for each client on the map.

Note If you select the Show All Clients check box and Small Icons check box, all other drop-down 
list options are dimmed out. 

If you unselect the Small Icons check box, you can choose if you want the label to display MAC 
address, IP address, username, asset name, asset group, or asset category.

If you unselect the Show All Clients check box, you can specify how you want the clients 
filtered and enter a particular SSID.

• Display Label—Select the client identifier (IP address, username, MAC address, asset name, asset 
group, or asset category) to display on the map.

• Filter By—Select the parameter by which you want to filter the clients (IP address, username, MAC 
address, asset name, asset group, asset category, or controller). Once selected, type the specific 
device in the text box.

• SSID—Enter the client SSID in the available text box.

• Protocol—Select All, 802.11a/n, or 802.11b/g/n from the drop-down list.

– All—Displays all the access points in the area.

– 802.11a/n—Displays a colored overlay depicting the coverage patterns for the clients with 
802.11a/n radios. The colors show the received signal strength from red (–35 dBm) through 
dark blue (–85 dBm).

– 802.11b/g/n—Displays a colored overlay depicting the coverage patterns for the clients with 
802.11b/g/n radios. The colors show the received signal strength from red (–35 dBm) through 
dark blue (–85 dBm). This is the default value.

• State—Select All, Idle, Authenticated, Probing, or Associated from the drop-down list.

Click OK when all applicable filtering criteria are selected.
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Filtering 802.11 Tag Floor Settings

If you enable the 802.11 Tags floor setting and then click the blue arrow to the right, the Tag Filter page 
opens. 

Tag filtering options include the following:

• Show All Tags—Select the check box to display all tags on the map.

• Small Icons—Select the check box to display icons for each tag on the map.

Note If you select the Show All Tags check box and Small Icons check box, all other drop-down list 
options are dimmed out. 

If you unselect the Small Icons check box, you can choose if you want the label to display MAC 
address, asset name, asset group, or asset category.

If you unselect the Show All Tags check box, you can specify how you want the tags filtered.

• Display Label—Select the tag identifier (MAC address, asset name, asset group, or asset category) 
to display on the map.

• Filter By—Select the parameter by which you want to filter the clients (MAC address, asset name, 
asset group, asset category, or controller). Once selected, type the specific device in the text box.

Click OK when all applicable filtering criteria are selected.

Filtering Rogue AP Floor Settings

If you enable the Rogue APs floor setting and then click the blue arrow to the right, the Rogue AP filter 
page opens.

Rogue AP filtering options include the following:

• Show All Rogue APs—Select the check box to display all rogue access points on the map.

• Small Icons—Select the check box to display icons for each rogue access point on the map.

Note If you select the Show All Rogue APs check box and Small Icons check box, all other 
drop-down list options are dimmed out. 

If you unselect the Show All Rogue APs check box, you can specify how you want the rogue 
access points filtered.

• MAC Address—If you want to view a particular MAC address, enter it in the MAC Address text box.

• State—Use the drop-down list to select from Alert, Known, Acknowledged, Contained, Threat, or 
Unknown contained states.

• On Network—Use the drop-down list to specify whether or not you want to display rogue access 
points on the network.

Click OK when all applicable filtering criteria are selected.
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Filtering Rogue Adhoc Floor Settings

If you enable the Rogue Adhocs floor setting and then click the blue arrow to the right, the Rogue Adhoc 
filter page opens. 

Rogue Adhoc filtering options include the following:

• Show All Rogue Adhocs—Select the check box to display all rogue adhoc on the map.

• Small Icons—Select the check box to display icons for each rogue adhoc on the map.

Note If you select the Show All Rogue Adhocs check box and Small Icons check box, all other 
drop-down list options are dimmed out. 

If you unselect the Show All Rogue Adhocs check box, you can specify how you want the rogue 
adhocs filtered.

• MAC Address—If you want to view a particular MAC address, enter it in the MAC Address text box.

• State—Use the drop-down list to select from Alert, Known, Acknowledged, Contained, Threat, or 
Unknown contained states.

• On Network—Use the drop-down list to specify whether or not you want to display rogue adhocs 
on the network.

Click OK when all applicable filtering criteria are selected.

Filtering Rogue Client Floor Settings

If you enable the Rogue Clients floor setting and then click the blue arrow to the right, the Rogue Clients 
filter page opens. 

Rogue Clients filtering options include:

• Show All Rogue Clients—Select the check box to display all rogue clients on the map.

• Small Icons—Select the check box to display icons for each rogue client on the map.

Note If you select the Show All Rogue Clients check box and Small Icons check box, all other 
drop-down list options are grayed out. 

If you unselect the Show All Rogue Clients check box, you can specify how you want the rogue 
clients filtered.

• Assoc. Rogue AP MAC Address—If you want to view a particular MAC address, enter it in the MAC 
Address text box.

• State—Use the drop-down list to select from Alert, Contained, Threat, or Unknown contained states.

Click OK when all applicable filtering criteria are selected.

Filtering Interferer Settings

If you enable Interferer floor setting and then click the blue arrow to the right, the Interferers filter 
window opens. 

Interferer filtering options include:
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• Show active interferers only—Select the check box to display all active interferers.

• Small Icons—Select the check box to display icons for each interferer on the map.

• Show Zone of Impact—Displays the approximate interference impact area. The opacity of the circle 
denotes its severity. A solid red circle represents a very strong interferer that will likely disrupt WiFi 
communications, a light pink circle represents a weak interferer.

• Show All Interferer Labels—Select the check box to display all interferer lables detected by the 
access point.

• Maximum number of Interferers per label—Select the maximum number of interferer to be 
displayed.

• Click OK when all applicable filtering criteria are selected.

Defining Inclusion and Exclusion Regions on a Floor

To further refine location calculations on a floor, you can define the areas that are included (inclusion 
areas) in the calculations and those areas that are not included (exclusion areas).

For example, you might want to exclude areas such as an atrium or stairwell within a building but include 
a work area (such as cubicles, labs, or manufacturing floors).

Note In WCS, inclusion and exclusion regions are only calculated for clients.

Viewing Floor Component Details

To view details regarding the components displayed on the Floor View, hover your mouse cursor over 
the applicable icon. A dialog box displays detailed information. Table 5-2 displays floor map icons.

Table 5-2 Floor Map Icons

Icon Description

Access point icon. The color of the circle indicates the alarm status of the Cisco 
radios.

Note Each access point contains two Cisco radios. When a single protocol is 
selected in the Access Point filter page, the entire icon represents this radio. 
If both protocols are selected, the top half of the icon represents the state of 
the 802.11a/n radio and the bottom half represents the state of the 802.11b/
g/n radio.

Note If a Cisco radio is disabled, a small “x” appears in the middle of the icon.

Note Monitor mode access points are shown with gray label to distinguish from 
other access points.

Client icon. Hover your mouse cursor over the icon to view client details. See the 
“Client Details” section on page 5-117 for more information. 

Tag icon. Hover your mouse cursor over the icon to view tag details. See the “Tag 
Details” section on page 5-118 for more information. 
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Cisco 1000 Series Lightweight Access Point Icons

The icons indicate the present status of an access point. The circular part of the icon can be split in half 
horizontally. The darkest of the two Cisco Radio colors determines the color of the large triangular 
pointer.

Note When the icon is representing 802.11a/n and 802.11b/n, the top half displays the 802.11a/n status, and 
the bottom half displays the 802.11b/g/n status. When the icon is representing only 802.11b/g/n, the 
whole icon displays the 802.11b/g/n status. The triangle gets whatever color is more stronger.

Table 5-3 shows the icons used in the Cisco WCS user interface Map displays.

Rogue access point icon. The color of the icon indicates the type of rogue access 
point. For example, red indicates a malicious rogue access point and blue indicates 
an unknown type.

Hover your mouse cursor over the icon to view rogue access point details. See the 
“Rogue Access Point Details” section on page 5-118 for more information. 

Rogue adhoc icon.

Hover your mouse cursor over the icon to view rogue adhoc details. See the “Rogue 
Adhoc Details” section on page 5-119 for more information. 

Rogue client icon.

Hover your mouse cursor over the icon to view rogue client details. See the “Rogue 
Client Details” section on page 5-119 for more information. 

Chokepoint icon. See the “Chokepoints” section on page 5-4 for more information.

Wi-Fi TDOA receiver icon. See the “Adding WiFi TDOA Receivers to a Map” 
section on page 5-61 for more information.

Interferer device icon. See the “Interferer Details” section on page 5-119 for more 
information.

Icon Description

Table 5-3 Access Points Icons Description

Icon Description

The green icon indicates an access point (AP) with no faults. The top half of the circle 
represents the optional 802.11a Cisco Radio. The bottom half of the circle represents the 
state of the 802.11b/g Cisco Radio. 

The yellow icon indicates an access point with a minor fault. The top half of the circle 
represents the optional 802.11a Cisco Radio. The bottom half of the circle represents the 
state of the 802.11b/g Cisco Radio.

Note A flashing yellow icon indicates that there has been an 802.11a or 802.11b/g 
interference, noise, coverage or load Profile Failure. A flashing yellow icon 
indicates that there have been 802.11a and 802.11b/g Profile Failures. 
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The red icon indicates an access point (AP) with a major or critical fault. The top half of 
the circle represents the optional 802.11a Cisco Radio. The bottom half of the circle 
represents the state of the 802.11b/g Cisco Radio. 

The grayed-out icon with a question mark in the middle represents an unreachable access 
point. It is gray because its status cannot be determined. 

The grayed-out icon with no question mark in the middle represents an unassociated 
access point.

The icon with a red “x” in the center of the circle represents an access point that has been 
administratively disabled. 

The icon with the top half green and the lower half yellow indicates that the optional 
802.11a Cisco Radio (top) has no faults, and the 802.11b/g Cisco Radio (bottom) has a 
minor fault. The worst of the two Cisco Radio colors determines the color of the large 
triangular pointer.

The icon with the top half green and the lower half red indicates that the optional 802.11a 
Cisco Radio (top) is operational with no faults, and the 802.11b/g Cisco Radio (bottom) 
has a major or critical fault. The worst of the two Cisco Radio colors determines the color 
of the large triangular pointer.

The icon with the top half yellow and the lower half red indicates that the optional 
802.11a Cisco Radio (top) has a minor fault, and the 802.11b/g Cisco Radio (bottom) has 
a major or critical fault. The worst of the two Cisco Radio colors determines the color of 
the large triangular pointer.

The icon with the top half yellow and the lower half green indicates that the optional 
802.11a Cisco Radio (top) has a minor fault, and the 802.11b/g Cisco Radio (bottom) is 
operational with no faults. The worst of the two Cisco Radio colors determines the color 
of the large triangular pointer.

The icon with the top half red and the lower half green indicates that the optional 802.11a 
Cisco Radio (top) has a major or critical fault, and the 802.11b/g Cisco Radio (bottom) 
is operational with no faults. The worst of the two Cisco Radio colors determines the 
color of the large triangular pointer.

Table 5-3 Access Points Icons Description (continued)

Icon Description
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Each of the access point icons includes a small black arrow that indicates the direction in which the 
internal Side A antenna points.

Table 5-4 shows some arrow examples used in the Cisco WCS user interface map displays.

The icon with the top half red and the lower half yellow indicates that the optional 
802.11a Cisco Radio (top) has major or critical faults, and the 802.11b/g Cisco Radio 
(bottom) has a minor fault. The worst of the two Cisco Radio colors determines the color 
of the large triangular pointer.

The icon with a red “x” on the top half (optional 802.11a) shows that the indicated Cisco 
Radio has been administratively disabled. The rest of the color coding is as described 
above. There are six possibilities as shown.

Table 5-3 Access Points Icons Description (continued)

Icon Description

Table 5-4 Arrows

Arrow 
Examples Direction 

Zero degrees, or to the right of the map.

45 degrees, or to the lower right on the map.

90 degrees, or down on the map.

These examples show the first three 45-degree increments allowed, with an additional five at 45-degree 
increments. 
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Guidelines and Limitations
This section contains the guidelines and limitations for this feature:

• Guidelines for Using the Map Editor, page 5-19

• Guidelines for Placing Access Points, page 5-19

• Guidelines for Inclusion and Exclusion Areas on a Floor, page 5-21

Guidelines for Using the Map Editor
Consider the following when modifying a building or floor map using the map editor.

• We recommend that you use the map editor to draw walls and other obstacles rather than importing 
an .FPE file from the legacy floor plan editor. 

– If necessary, you can still import .FPE files. To do so, navigate to the desired floor area, choose 
Edit Floor Area from the Select a command drop-down list, click Go, select the FPE File 
check box, and browse to and choose the .FPE file.

• You can add any number of walls to a floor plan with the map editor; however, the processing power 
and memory of a client workstation may limit the refresh and rendering aspects of WCS. 

– We recommend a practical limit of 400 walls per floor for machines with 1-GB RAM or less.

• All walls are used by WCS when generating RF coverage heatmaps.

– However, the MSEs use no more than 50 heavy walls in its calculations, and the MSE does not 
use light walls in its calculations because those attenuations are already accounted for during 
the calibration process.

If you have a high resolution image (near 12 megapixels), you may need to scale down the image 
resolution with an image editing software prior to using map editor.

Guidelines for Placing Access Points
Place access points along the periphery of coverage areas to keep devices close to the exterior of rooms 
and buildings (see Figure 5-9). Access points placed in the center of these coverage areas provide good 
data on devices that would otherwise appear equidistant from all other access points.
5-19
Cisco Wireless Control System Configuration Guide

OL-21743-01



Chapter 5      Monitoring Maps
  Guidelines and Limitations
Figure 5-9 Access Points Clustered Together 

By increasing overall access point density and moving access points towards the perimeter of the 
coverage area, location accuracy is greatly improved (see Figure 5-10).

Figure 5-10 Improved Location Accuracy by Increasing Density

In long and narrow coverage areas, avoid placing access points in a straight line (see Figure 5-11). 
Stagger them so that each access point is more likely to provide a unique snapshot of a device location.

Figure 5-11 Refrain From Straight Line Placement

Although the design in Figure 5-11 may provide enough access point density for high bandwidth 
applications, location suffers because each access point view of a single device is not varied enough; 
therefore, location is difficult to determine.

Move the access points to the perimeter of the coverage area and stagger them. Each has a greater 
likelihood of offering a distinctly different view of the device, resulting in higher location accuracy (see 
Figure 5-12).
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Figure 5-12 Improved Location Accuracy by Staggering Around Perimeter

Designing a location-aware wireless LAN, while planning for voice as well, is better done with a few 
things in mind. Most current wireless handsets support only 802.11b/n, which offers only three 
non-overlapping channels. Therefore, wireless LANs designed for telephony tend to be less dense than 
those planned to carry data. Also, when traffic is queued in the Platinum QoS bucket (typically reserved 
for voice and other latency-sensitive traffic), lightweight access points postpone their scanning functions 
that allow them to peak at other channels and collect, among other things, device location information. 
The user has the option to supplement the wireless LAN deployment with access points set to 
monitor-only mode. Access points that perform only monitoring functions do not provide service to 
clients and do not create any interference. They simply scan the airwaves for device information.

Less dense wireless LAN installations, such as voice networks, find their location accuracy greatly 
increased by the addition and proper placement of monitor access points (see Figure 5-13).

Figure 5-13 Less Dense Wireless LAN Installations

Verify coverage using a wireless laptop, handheld, or phone to ensure that no fewer than three access 
points are detected by the device. To verify client and asset tag location, ensure that WCS reports client 
devices and tags within the specified accuracy range (10 m, 90%).

Note If you have a ceiling-mounted AP with an integrated omni-directional antenna, the antenna 
orientation does not really need to be set in WCS. However, if you mount that same AP on the 
wall, you must set the antenna orientation to 90 degrees.

Guidelines for Inclusion and Exclusion Areas on a Floor
Inclusion and exclusion areas can be any polygon shape and must have at least three points.

You can only define one inclusion region on a floor. By default, an inclusion region is defined for each 
floor when it is added to WCS. The inclusion region is indicated by a solid aqua line, and generally 
outlines the region.

You can define multiple exclusion regions on a floor.
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Newly defined inclusion and exclusion regions appear on heatmaps only after the mobility services 
engine recalculates location. 

Monitoring Maps
This section contains the following topics:

• Configuring Maps, page 5-22

• Configuring Buildings, page 5-29

• Configuring a Campus, page 5-36

• Configuring Outdoor Areas, page 5-39

• Configuring Floor Areas, page 5-41

• Configuring ChokePoints, page 5-57

• Configuring WiFi TDOA Receivers, page 5-61

• Managing RF Calibration Models, page 5-63

• Managing Location Presence Information, page 5-69

Configuring Maps
This section contains the following topics:

• Viewing a Map, page 5-22

• Editing a Map, page 5-24

• Deleting a Map, page 5-25

• Copying a Map, page 5-25

• Exporting a Map, page 5-26

• Importing a Map, page 5-27

• Editing Map Properties, page 5-28

Viewing a Map

To view a current campus map, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Click the name of the campus map to open its details page (see Figure 5-14).
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Figure 5-14 Building View Window

Step 3 The Select a command drop-down list provides the following options:

• New Floor Area—See the “Adding Floor Areas to a Campus Building” section on page 5-42 for 
more information.

• Edit Building—See the “Editing a Map” section on page 5-24 for more information.

• Delete Building— See the “Deleting a Map” section on page 5-25 for more information.

• Copy Building—See the “Managing RF Calibration Models” section on page 5-63 for more 
information.

• Edit Location Presence Information—See the “Managing Location Presence Information” section 
on page 5-69 for more information.

Note Use the Monitor > Maps > Campus View main navigation bar at the top of the campus image 
to enlarge or decrease the size of the map view and to hide or show the map grid (which displays 
the map size in feet or meters).

Configuring Edit View

The Edit View page enables you to choose which columns appear in the maps list page.

Note Name and Type are fixed columns. They cannot be moved or hidden.

Column names appear in one of the following lists:

• Hide Information—Lists columns that do not appear in the table. The Hide button points to this list.

• View Information—Lists columns that do appear in the table. The Show button points to this list.
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To display a column in a table, click it in the Hide Information list, then click Show. To remove a column 
from a table, click it in the View Information list, then click Hide. You can select more than one column 
by pressing the Shift or Control key.

To change the position of a column in the View Information list, click it, then click Up or Down. The 
higher a column is in the list, the farther left it appears in the table.

Edit View Command Buttons

The following command buttons appear in the Edit View page:

• Reset—Sets the table to the default display.

• Show—Moves the highlighted columns from the Hide Information list to the View Information list.

• Hide—Moves the highlighted columns from the View Information list to the Hide Information list.

• Up—Moves the highlighted columns upward in the list (further to the left in the table).

• Down—Moves the highlighted columns downward in the list (further to the right in the table).

• Submit—Saves the changes to the table columns and return to the previous page.

• Cancel—Reverts the changes to the table columns and return to the previous page.

Editing a Map

To edit a current campus map, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Click the name of the campus map to open its details page.

Step 3 From the Select a command drop-down list, choose Edit Campus.

Step 4 Make any necessary changes to the Campus Name, Contact, Number of Floors, Number of Basements, 
and Dimensions (feet).

Note To change the unit of measurement (feet or meters), choose Monitor > Maps and choose 
Properties from the Select a command drop-down list.

Step 5 Click Next.

Step 6 Make any additional changes to Maintain Aspect Ratio or Dimensions (feet).

Step 7 Click OK.

Note System Campus is part of all partitions. Also, you can not edit or delete a system campus. 

Note When you search a building in WCS, the search results does not show the buildings within a campus 
which are partitioned. The search result shows a permission denied page, if any one of the floors in the 
building is not assigned to you.
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Deleting a Map

To delete a map, follow these steps:

Step 1 In the Monitor > Maps window, Select the check box(es) for the map(s) that you want to delete.

Step 2 Click Delete at the bottom of the map list or choose Delete Maps from the Select a command drop-down 
list, and click Go.

Step 3 Click OK to confirm the deletion.

Note Deleting a campus or building also deletes all of its container maps. The access points from all 
deleted maps are moved to an Unassigned state. System Campus can not be deleted, however 
buildings or floors in system campus can be modified.

Copying a Map

The following guidelines apply to the copying process:

• Only the child elements are copied to the new map.

• The selected map is copied to the current applicable partition.

• Overlapping areas are not checked when buildings are copied. You should edit these after copying 
the map for proper positioning.

• If the selected map is above ground, the first available floor above ground is used for the copy.

• If the selected map is a basement, the first available basement is used for the copy.

• The following are not copied:

– Access points and their positioning coordinates.

– Planning mode data.

Note You can not copy a System Campus.
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To copy a map, follow these steps:

Step 1 From the Monitor > Maps window, select the check box of the map that you want to copy.

Step 2 From the Select a command drop-down list, choose Copy Maps. The Copy Maps window opens (see 
Figure 5-15).

Figure 5-15 Copy Maps Window 

Step 3 Enter the name of the new map to which you want to copy the current map.

Note If a map with the new name already exists, the copying process stops.

Step 4 Select the Copy Option (Map Only or Map and Map Details).

Note Map and Map Details includes coverage areas, perimeters, obstacles, location regions, markers, 
and rails.

Step 5 Click Copy to complete the copying process or Cancel to close the window without copying the current 
map.

Exporting a Map

The Export Map feature allows you to export map or calibration information to XML. The exported 
XML will be in an encrypted format and will not be readable. XML and images are bundled, tarred, and 
zipped into a file for a successful import into another WCS.
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To export a map, follow these steps:

Step 1 From the Monitor > Maps window, select the check box of the map that you want to export.

Step 2 From the Select a command drop-down list, choose Export Maps. The Export Map window appears. 
(see Figure 5-16)

Figure 5-16 Export Map Window 

Step 3 Select the maps that you want to export.

Step 4 Click Export to export the selected map data.

Importing a Map

The Import Map feature allows you to import map information from external sources such as XML, 
WLSE, and CSV. During import, the XML may be encrypted (if exported from WCS) or unencrypted. 

To import a map, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 From the Select a command drop-down list, choose Import Maps. The Import Map window appears.
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Figure 5-17 Import Map Window

Step 3 Choose the map format.

Step 4 Select one of the following formats:

• XML

• AP/WiFi TDOA Receiver/Chokepoint Placement

• WLSE Map and AP Location Data

Note The XML format option is available only to the root user.

Step 5 Click Next.

Step 6 Click Browse to select the file that you want to import.

Step 7 Click Import to import the selected data.

Editing Map Properties

To edit your map properties, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 From the Select a command drop-down list, choose Properties.

Step 3 Click Go.

Step 4 Edit the information in Table 5-5.
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Table 5-5 Map Properties Parameters

Filtering Maps

At the Monitor > Maps level, the list of maps can be filtered based on type and status. To filter your 
map list, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Select the map type from the Type drop-down list. Map types include All, Campus, Building, Outdoor 
Area, and Floor Area.

Step 3 To further sort the map list by status, select the status type from the Status drop-down list. Status types 
include All, Critical, Major, Minor.

Note Status indicates the most serious level of alarm on an access point located on this map or one of 
its children.

Step 4 When the filtering criteria is selected, click Go. The list displays maps which fit the filtering criteria.

Configuring Buildings
You can add buildings to the WCS database regardless of whether you have added campus maps to the 
database. This section explains how to add a building to a campus map or a standalone building (one that 
is not part of a campus) to the Cisco WCS database.

This section contains the following topics:

Parameter or Control Description

Unit of Dimension Set dimension measurement in feet or meters for 
all Cisco WCS maps.

Wall Usage Calibration Choose to use or not use walls, or set to automatic.

Refresh Map From Network Enable refresh of map data for Cisco WCS to 
update maps by polling the Cisco WLAN Solution 
each time an Cisco WLAN Solution operator 
requests a map update. Select disable for Cisco 
WCS to update maps from its stored database.

Note Updates to the database may not be 
frequent enough to keep the map data 
current.

Advanced Debug Mode This option must be enabled on both the location 
appliance and WCS to allow use of the location 
accuracy testpoint feature.
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• Adding a Building to a Campus Map, page 5-30

• Viewing a Building, page 5-34

• Editing a Building, page 5-35

• Deleting a Building, page 5-35

• Moving a Building, page 5-36

Adding a Building to a Campus Map

To add a building to a campus map in the WCS database, follow these steps:

Step 1 Choose Monitor > Maps to display the Maps page.

Step 2 Click the desired campus. WCS displays the Maps > Campus Name page.

Step 3 From the Select a command drop-down list, choose New Building, and click Go (see Figure 5-18).

Figure 5-18 New Building Window

Step 4 On the Campus Name > New Building page, follow these steps to create a virtual building in which to 
organize related floor plan maps:

a. Enter the building name.

b. Enter the building contact name.

c. Enter the number of floors and basements.

d. Enter the horizontal position (distance from the corner of the building rectangle to the left edge of 
the campus map) and the vertical position (distance from the corner of the building rectangle to the 
top edge of the campus map) in feet.
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Note To change the unit of measurement (feet or meters), select Monitor > Maps and choose 
Properties from the Select a command drop-down list.

e. Enter an approximate building horizontal span and vertical span (width and depth on the map) in 
feet.

Note The horizontal and vertical span should be larger than or the same size as any floors that you 
might add later.

Tip You can also use Ctrl-click to resize the bounding area in the upper left corner of the campus 
map. As you change the size of the bounding area, the Horizontal Span and Vertical Span 
parameters of the building change to match your actions.

f. Click Place to put the building on the campus map. WCS creates a building rectangle scaled to the 
size of the campus map.

g. Click the building rectangle and drag it to the desired position on the campus map.

Note After adding a new building, you can move it from one campus to another without having to 
recreate it.

h. Click Save to save this building and its campus location to the database. WCS saves the building 
name in the building rectangle on the campus map.

Note A hyperlink associated with the building takes you to the corresponding Map page.

Step 5 (Optional) To assign location presence information for the new outdoor area, do the following:

a. Choose Edit Location Presence Info from the Select a command drop-down list. Click Go. The 
Location Presence window appears (see Figure 5-19).

Note By default, the Override Child Element’s Presence Info check box is selected. This option should 
remain selected if you want to propagate the campus location to all buildings and floors on that 
campus. When adding buildings to the campus map, you can import the campus location 
information. The campus address cannot be imported to a building if the check box is deselected. 
This option should be deselected if you want to assign building-specific addresses to buildings 
on its campus rather than one campus address to all.
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Figure 5-19 Location Presence Window

b. Click either the Civic, GPS markers, or Advanced tab.

– Civic Address identifies the campus by name, street, house number, house number suffix, city 
(address line2), state, postal code, and country.

– GPS Markers identify the campus by longitude and latitude.

– Advanced identifies the campus with expanded civic information such as neighborhood, city 
division, country, and postal community name.

Note Each selected parameter is inclusive of all of those above it. For example, if you choose 
Advanced, it can also provide GPS and Civic location information upon client demand. The 
selected setting must match what is set on the location server level (Services > Mobility 
Services).

Note If a client requests location information such as GPS Markers for a campus, building, floor, 
or outdoor area that is not configured for that parameter, an error message is returned.

c. By default, the Override Child Element’s Presence Info check box is selected. There is no need to 
alter this setting for standalone buildings.

Step 6 Click Save.
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Adding a Standalone Building

To add a standalone building to the WCS database, follow these steps:

Step 1 Choose Monitor > Maps to display the Maps page.

Step 2 From the Select a command drop-down list, choose New Building, and click Go (see Figure 5-18).

Figure 5-20 New Standalone Building Window

Step 3 On the Maps > New Building page, follow these steps to create a virtual building in which to organize 
related floor plan maps:

a. Enter the building name.

b. Enter the building contact name.

Note After adding a new building, you can move it from one campus to another without having to 
recreate it.

c. Enter the number of floors and basements.

d. Enter an approximate building horizontal span and vertical span (width and depth on the map) in 
feet.

Note To change the unit of measurement (feet or meters), select Monitor > Maps and choose 
Properties from the Select a command drop-down list.

Note The horizontal and vertical span should be larger than or the same size as any floors that you 
might add later.

e. Click OK to save this building to the database.
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Step 4 (Optional) To assign location presence information for the new building, do the following:

a. Choose Location Presence from the Select a command drop-down list. Click Go. The Location 
Presence window appears (see Figure 5-19). 

b. Click either the Civic, GPS markers, or Advanced tab.

– Civic Address identifies the campus by name, street, house number, house number suffix, city 
(address line2), state, postal code, and country.

– GPS Markers identify the campus by longitude and latitude.

– Advanced identifies the campus with expanded civic information such as neighborhood, city 
division, county, and postal community name.

Note Each selected parameter is inclusive of all of those above it. For example, if you select 
Advanced, it can also provide GPS and Civic location information upon client demand. The 
selected setting must match what is set on the location server level (Services > Mobility 
Services).

Note If a client requests location information such as GPS Markers for a campus, building, floor, 
or outdoor area that is not configured for that parameter, an error message is returned.

c. By default, the Override Child Element’s Presence Info check box is selected.
This option should remain selected if you want to propagate the campus location to all buildings and 
floors on that campus. When adding buildings to the campus map, you can import the location 
information. The campus address cannot be imported to a building if the check box is deselected.
This option should be deselected if you want to assign building-specific addresses to buildings on 
its campus rather than one campus address to all.

Step 5 Click Save.

Note The standalone buildings are automatically placed in System Campus.

Viewing a Building

To view a current building map, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Click the name of the building map to open its details page. The Building View page provides a list of 
floor maps and map details for each floor.

Note From the Building View page, you can click the Floor column heading to sort the list ascending 
or descending by floor.

The map details include:

• Floor area
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• Floor index—Indicates the floor level. A negative number indicates a basement floor level.

• Contact.

• Status—Indicates the most serious level of alarm on an access point located on this map or one of 
its children.

• Number of total access points located on the map.

• Number of 802.11a/n and 802.11b/g/n radios located on the map.

• Number of out of service (OOS) radios.

• Number of clients—Click the number link to view the Monitor > Clients page. See the “Monitoring 
Clients” section on page 10-8 for more information.

Step 3 The Select a command drop-down list provides the following options:

• New Floor Area—See the “Adding Floor Areas to a Campus Building” section on page 5-42 or the 
“Adding Floor Plans to a Standalone Building” section on page 5-46 for more information.

• Edit Building—See the “Editing a Building” section on page 5-35 for more information.

• Delete Building—See the “Deleting a Building” section on page 5-35 for more information.

• Copy Building—See the “Copying a Map” section on page 5-25 for more information.

• Edit Location Presence Info—See the “Managing Location Presence Information” section on 
page 5-69 for more information.

Editing a Building

To edit a current building map, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Click the name of the building map to open its details page.

Step 3 From the Select a command drop-down list, choose Edit Building.

Step 4 Make any necessary changes to Building Name, Contact, Number of Floors, Number of Basements, and 
Dimensions (feet). 

Note To change the unit of measurement (feet or meters), choose Monitor > Maps and select 
Properties from the Select a command drop-down list.

Step 5 Click OK.

Deleting a Building

To delete a current building map, follow these steps:

Step 1 Choose Monitor > Maps. 

Step 2 Select the check box for the building that you want to delete.
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Step 3 Click Delete at the bottom of the map list (or choose Delete Maps from the Select a command 
drop-down list, and click Go).

Step 4 Click OK to confirm the deletion.

Note Deleting a building also deletes all of its container maps. The access points from all deleted maps 
are moved to an Unassigned state.

Moving a Building

To move a building to a different campus, follow these steps:

Step 1 Choose Monitor > Maps. 

Step 2 Select the check box of the applicable building.

Step 3 From the Select a command drop-down list, choose Move Buildings.

Step 4 Click Go.

Step 5 Select the Target Campus from the drop-down list.

Step 6 Select the buildings that you want to move. Unselect any buildings that will remain in their current 
location.

Step 7 Click OK.

Configuring a Campus
This section contains the following topics:

• Adding a Campus Map, page 5-36

• Viewing a Campus Map, page 5-37

• Editing a Campus Map, page 5-38

• Deleting a Campus Map, page 5-38

Adding a Campus Map

To add a single campus map to the WCS database, follow these steps:

Step 1 Save the map in .PNG, .JPG, .JPEG, or .GIF format.

Note The map can be of any size because WCS automatically resizes the map to fit its working areas.

Step 2 Browse to and import the map from anywhere in your file system.

Step 3 Choose Monitor > Maps to display the Maps page (see Figure 5-21).
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Figure 5-21 New Campus Window

Step 4 From the Select a command drop-down list, choose New Campus, and click Go.

Step 5 On the Maps > New Campus page, enter the campus name and campus contact name.

Step 6 Browse to and choose the image filename containing the map of the campus, and click Open.

Step 7 Select the Maintain Aspect Ratio check box to prevent length and width distortion when WCS resizes 
the map.

Step 8 Enter the horizontal and vertical span of the map in feet.

Note To change the unit of measurement (feet or meters), select Monitor > Maps and choose 
Properties from the Select a command drop-down list. The horizontal and vertical span should 
be larger than any building or floor plan to be added to the campus.

Step 9 Click OK to add this campus map to the WCS database. WCS displays the Maps page, which lists maps 
in the database, map types, and campus status.

Step 10 (Optional) To assign location presence information, click the newly created campus link at the Monitor 
> Maps window. See the ““Managing Location Presence Information” section on page 5-69” for more 
information.

Viewing a Campus Map

To view a current campus map, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Click the name of the campus map to open its details page.

Step 3 The Select a command drop-down list provides the following options:

• New Building—See the “Adding a Building to a Campus Map” section on page 5-30 for more 
information.

• New Outdoor Area—See the “Adding an Outdoor Area” section on page 5-39 for more information.

• Edit Campus—See the “Editing a Campus Map” section on page 5-38 for more information.

• Delete Campus—See the “Deleting a Campus Map” section on page 5-38 for more information.
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• Copy Campus—See the “Copying a Map” section on page 5-25 for more information.

• Edit Location Presence Information—See the “Managing Location Presence Information” section 
on page 5-69 for more information.

Note Use the Monitor > Maps > Campus View main navigation bar at the top of the campus image 
to enlarge or decrease the size of the map view and to hide or show the map grid (which displays 
the map size in feet or meters).

Editing a Campus Map

The edit feature allows you to make changes to a current campus map. You can change the campus name, 
contact person, image, and map dimensions.

To edit a current campus map, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Click the name of the campus map to open its details page.

Step 3 From the Select a command drop-down list, choose Edit Campus.

Step 4 Make any necessary changes to Campus Name, Contact, or Image File. 

Step 5 Click Next.

Step 6 Make any additional changes to Maintain Aspect Ratio or Dimensions (feet). 

Note To change the unit of measurement (feet or meters), choose Monitor > Maps and choose 
Properties from the Select a command drop-down list.

Step 7 Click OK.

Deleting a Campus Map

To delete a current campus map, follow these steps:

Step 1 Choose Monitor > Maps. 

Step 2 Select the check box for the campus that you want to delete.

Step 3 Click Delete at the bottom of the map list or choose Delete Maps from the Select a command drop-down 
list, and click Go.

Step 4 Click OK to confirm the deletion.
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Note Deleting a campus also deletes all of its container maps. The access points from all deleted maps 
are moved to an Unassigned state.

Configuring Outdoor Areas
This section contains the following topics:

• Adding an Outdoor Area, page 5-39

• Editing Outdoor Areas, page 5-40

• Deleting Outdoor Areas, page 5-41

Adding an Outdoor Area

Note You can add an outdoor area to a campus map in the WCS database regardless of whether you have added 
outdoor area maps to the database. 

To add an outdoor area to a campus map, follow these steps:

Step 1 If you want to add a map of the outdoor area to the database, save the map in .PNG, .JPG, .JPEG, or .GIF 
format. Then browse to and import the map from anywhere in your file system.

Note You do not need a map to add an outdoor area. You can simply define the dimensions of the area 
to add it to the database. The map can be any size because WCS automatically resizes the map 
to fit the workspace.

Step 2 Choose Monitor > Maps. 

Step 3 Click the desired campus to display the Monitor > Maps > Campus View page. 

Step 4 From the Select a command drop-down list, choose New Outdoor Area.

Step 5 Click Go. The Create New Area page opens.

Step 6 On the New Outdoor Area page, enter the following information:

• Name—The user-defined name of the new outdoor area.

• Contact—The user-defined contact name.

• Area Type (RF Model)—Cubes And Walled Offices, Drywall Office Only, Outdoor Open Space 
(default).

• AP Height (feet)—Enter the height of the access point.

• Image File—Name of the file containing the outdoor area map. Use the browse button to find the 
file.

Step 7 Click Next.

Step 8 Enter the following information:
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• Zoom—Use to zoom in or zoom out on the map that you are currently viewing.

• Maintain Image Aspect Ratio—Select this check box to maintain the aspect ratio (ratio of horizontal 
and vertical pixels) of the map image. Maintaining the aspect ratio prevents visual distortion of the 
map.

• Horizontal Position—Distance from the corner of the outdoor area rectangle to the left edge of the 
campus map, in feet or meters.

• Vertical Position—Distance from the corner of the outdoor area rectangle to the top edge of the 
campus map, in feet or meters.

• Horizontal Span—Horizontal measurement (left to right) of the outdoor area rectangle, in feet or 
meters.

• Vertical Span—Vertical measurement (up and down) of the outdoor area rectangle, in feet or meters.

Tip The horizontal and vertical spans should be larger than or the same size as any floors that may be added 
later. Use Ctrl-click to resize the bounding area in the upper-left corner of the campus map. The 
horizontal and vertical span parameters change to match.

Note To change the unit of measurement (feet or meters), choose Monitor > Maps and choose 
Properties from the Select a command drop-down list.

Step 9 Click Place to put the outdoor area on the campus map. WCS creates an outdoor area rectangle scaled 
to the size of the campus map. 

Step 10 Click and drag the outdoor area rectangle to the desired position on the campus map. 

Step 11 Click Save to save this outdoor area and its campus location to the database.

Note A hyperlink associated with the outdoor area takes you to the corresponding Map page. 

Step 12 (Optional) To assign location presence information for the new outdoor area, select Edit Location 
Presence Info, and click Go. See the “Managing Location Presence Information” section on page 5-69 
for more information.

Note By default, the Override Child Element Presence Info check box is selected. There is no need to 
alter this setting for outdoor areas.

Editing Outdoor Areas

To edit a current outdoor area, follow these steps:

Step 1 Choose Monitor > Maps. 

Step 2 Click the desired outdoor area map from the Name column.

Step 3 From the Select a command drop-down list, choose Edit Outdoor Area.

Step 4 Click Go. 
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Step 5 On the Campus Name > Outdoor Area page, edit the following information:

• Name—The user-defined name of the new outdoor area.

• Contact—The user-defined contact name.

• New Image File—Use the Browse button to import a new image file, if necessary.

• Maintain Image Aspect Ratio—Select this check box to maintain the aspect ratio (ratio of horizontal 
and vertical pixels) of the map image. Maintaining the aspect ratio prevents visual distortion of the 
map.

• Horizontal Position—Distance from the corner of the outdoor area rectangle to the left edge of the 
campus map, in ft. or meters.

• Vertical Position—Distance from the corner of the outdoor area rectangle to the top edge of the 
campus map, in ft. or meters.

• Horizontal Span—Horizontal measurement (left to right) of the outdoor area rectangle, in ft. or 
meters.

• Vertical Span—Vertical measurement (up and down) of the outdoor area rectangle, in ft. or meters.

Step 6 Click Place to put the outdoor area on the campus map. WCS creates an outdoor area rectangle scaled 
to the size of the campus map. 

Step 7 Click and drag the outdoor area rectangle to the desired position on the campus map. 

Step 8 Click Save to save this outdoor area and its campus location to the database.

Note A hyperlink associated with the outdoor area takes you to the corresponding Map page. 

Deleting Outdoor Areas

To delete a current outdoor area, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Select the check box for the outdoor area that you want to delete.

Step 3 Click Delete at the bottom of the map list (or choose Delete Maps from the Select a command 
drop-down list, and click Go).

Step 4 Click OK to confirm the deletion.

Configuring Floor Areas
This section explains on how to add floor plans to either a campus building or a standalone building in 
the WCS database and contains the following topics:

• Adding Floor Areas to a Campus Building, page 5-42

• Adding Access Points to a Floor Area, page 5-48

• Editing Floor Areas, page 5-53
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• Deleting Floor Areas, page 5-53

• Placing Access Points, page 5-54

• Import Map and AP Location Data, page 5-54

• Positioning Access Points, Wi-Fi TDOA Receivers, and Chokepoints by Importing or 
Exporting a File, page 5-56

• Changing Access Point Positions by Importing and Exporting a File, page 5-57

Adding Floor Areas to a Campus Building

After you add a building to a campus map, you can add individual floor plan and basement maps to the 
building. 

To add a floor area to a campus building, follow these steps:

Step 1 Save your floor plan maps in .PNG, .JPG, or .GIF format.

Note The maps can be any size because WCS automatically resizes the maps to fit the workspace.

Step 2 Browse to and import the floor plan maps from anywhere in your file system. You can also import CAD 
image files DXF and DWG.

Note If there are problems converting the auto-cad file, an error message is displayed. WCS uses a 
native image conversion library to convert auto-cad files into raster formats like PNG. If the 
native library cannot be loaded, WCS returns the “unable to convert the auto-cad file” message. 
If you receive this error, make sure all the required dependencies are met for the native library. 
To find any dependency problems, use Dependency Walker on Windows platforms or ldd on 
Linux platforms. The following dlls must be present under the /webnms/rfdlls WCS installation 
directory: LIBGFL254.DLL, MFC71.DLL, MSVCR71.DLL, and MSVCP71.DLL. If 
dependency problems occurred, you may need to install the required libraries and restart WCS.

Note An imported auto-cad file can become blurred when you zoom. Without the zoom, the clarity is 
about the same as the original auto-cad file. Make sure all relevant sections are clearly visible in 
the original auto-cad file (DWG/DXF) and then import the auto-cad file into PNG/GIF format 
rather than JPEG or JPG.

Step 3 Choose Monitor > Maps. The Maps page opens. (See Figure 5-22)
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Figure 5-22 Monitor > Maps Window

Step 4 From the Maps Tree View or the Monitor > Maps list, click the applicable campus building to open the 
Building View page.

Step 5 Hover your cursor over the name within an existing building rectangle to highlight it.

Note You can also access the building from the Campus View page. From the Campus View page, 
click the building name to open the Building View page.

Step 6 From the Select a command drop-down list, choose New Floor Area.

Step 7 Click Go. The New Floor Area page opens. (See Figure 5-23)

Figure 5-23 New Floor Area Window

Step 8 On the New Floor Area page, follow these steps to add floors to a building in which to organize related 
floor plan maps:

a. Enter the floor area and contact names.

b. Select the floor or basement number from the Floor drop-down list.

c. Choose the floor or basement type (RF Model).

d. Enter the floor-to-floor height in feet.
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Note To change the unit of measurement (feet or meters), select Monitor > Maps and choose 
Properties from the Select a command drop-down list.

e. Select the Image or CAD File check box. 

f. Browse to and choose the desired floor or basement image or CAD filename, and click Open.

Note If you are importing a CAD file, use the Convert CAD File drop-down list to determine the 
image file for conversion.

Tip A JPEG (JPG) format is not recommended for an auto-cad conversion. Unless a JPEG is 
specifically required, use a PNG or GIF format for higher quality images.

g. Click Next. At this point, if a CAD file was specified, a default image preview is generated and 
loaded. 

Note WCS uses a native image conversion library to convert auto-cad files into raster formats like 
.PNG. When there are issues loading the native library, WCS throws the following error: 
"Unable to convert the auto-cad file. Reason: Error while loading the auto-cad image 
conversion library. Please refer online or WCS documentation for more information."

If this error displays, make sure all the required dependencies are met for the native library.

On the Windows platform, you can use tools such as "Dependency Walker" to find out any 
dependency issues.

Also, please make sure that the following dlls are present under \webnms\rfdlls directory 
under your WCS installation directory: 

\webnms\rfdlls\LIBGFL254.DLL
\webnms\rfdlls\MFC71.DLL
\webnms\rfdlls\MSVCR71.DLL
\webnms\rfdlls\MSVCP71.DLL

On the Linux platform, you can use tools such as "ldd" to find out any dependency issues.

If there are any dependency issues, fix them by installing the required libraries for missing 
dependencies and then restart WCS.

The names of the CAD file layers are listed, with check boxes to the right side of the image 
indicating which are enabled.

Note When you choose the floor or basement image filename, WCS displays the image in the 
building-sized grid.
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Note The maps can be any size because WCS automatically resizes the maps to fit the workspace. 

Note The map must be saved in .PNG, .JPG, .JPEG, or .GIF format.

h. If you have CAD file layers, you can select or deselect as many as you want and click Preview to 
view an updated image. Click Next when you are ready to proceed with the selected layers. 

Enter the remaining parameters for the floor area.

Figure 5-24 Floor Area Parameters

i. Either leave the Maintain Aspect Ratio check box selected to preserve the original image aspect 
ratio or unselect the check box to change the image aspect ratio.

j. Enter an approximate floor or basement horizontal and vertical span (width and depth on the map) 
in feet.

Note The horizontal and vertical spans should be smaller than or the same size as the building 
horizontal and vertical spans in the WCS database.
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k. If applicable, enter the horizontal position (distance from the corner of the outdoor area rectangle to 
the left edge of the campus map) and vertical position (distance from the corner of the outdoor area 
rectangle to the top edge of the campus map) in feet or meters.

Tip User Ctrl-click to resize the image within the building-sized grid.

l. If desired, select the Launch Map Editor after floor creation check box to rescale the floor and 
draw walls.

m. Click OK to save this floor plan to the database. The floor is added to the Maps Tree View and the 
Monitor > Maps list.

Step 9 Click any of the floor or basement images to view the floor plan or basement map. 

Note You can zoom in or out to view the map at different sizes and you can add access points. See the “Adding 
Access Points to a Floor Area” section on page 5-48 for more information.

Adding Floor Plans to a Standalone Building

After you have added a standalone building to the WCS database, you can add individual floor plan maps 
to the building. 

To add floor plans to a standalone building, follow these steps:

Step 1 Save your floor plan maps in .PNG, .JPG, or .GIF format.

Note The maps can be any size because WCS automatically resizes the maps to fit the workspace.

Step 2 Browse to and import the floor plan maps from anywhere in your file system. You can import CAD files 
in DXF or DWG formats or any of the formats you created in Step 1.

Note If there are problems converting the auto-cad file, an error message is displayed. WCS uses a 
native image conversion library to convert auto-cad files into raster formats link PNG. If the 
native library cannot be loaded, WCS returns the “unable to convert the auto-cad file” message. 
If you receive this error, make sure all the required dependencies are met for the native library. 
To find any dependency problems, use Dependency Walker on Windows platforms or ldd on 
Linux platforms. The following dlls must be present under the /webnms/rfdlls WCS installation 
directory: LIBGFL254.DLL, MFC71.DLL, MSVCR71.DLL, and MSVCP71.DLL. If 
dependency problems occurred, you may need to install the required libraries and restart WCS.

Note An imported auto-cad file can become blurred when you zoom. Without the zoom, the clarity is 
about the same as the original auto-cad file. Make sure all relevant sections are clearly visible in 
the original auto-cad file (DWG/DXF) and then import the auto-cad file into PNG/GIF format 
rather than JPEG or JPG.

Step 3 Choose Monitor > Maps. 
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Step 4 From the Maps Tree View or the Monitor > Maps list, click the desired building to display the Building 
View page. 

Step 5 From the Select a command drop-down list, choose New Floor Area.

Step 6 Click Go. 

Step 7 On the New Floor Area page, add the following information:

• Enter the floor area and contact names.

• Select the floor or basement number from the Floor drop-down list.

• Choose the floor or basement type (RF Model).

• Enter the floor-to-floor height in feet.

• Select the Image or CAD File check box. 

• Browse to and choose the desired floor or basement Image or CAD file, and click Open.

Note If you are importing a CAD file, use the Convert CAD File drop-down list to determine the 
image file for conversion.

Tip A JPEG (JPG) format is not recommended for an auto-cad conversion. Unless a JPEG is 
specifically required, use a PNG or GIF format for higher quality images.

Step 8 Click Next. At this point, if a CAD file was specified, a default image preview is generated and loaded.

Note WCS uses a native image conversion library to convert auto-cad files into raster formats like 
.PNG. When there are issues loading the native library, WCS throws the following error: 
"Unable to convert the auto-cad file. Reason: Error while loading the auto-cad image conversion 
library. Please refer online or WCS documentation for more information."

If this error displays, make sure all the required dependencies are met for the native library.

On Windows platform, you can use tools such as "Dependency Walker" to find out any 
dependency issues.

Also, please make sure that the following dlls are present under \webnms\rfdlls directory under 
your WCS installation directory: 

\webnms\rfdlls\LIBGFL254.DLL
\webnms\rfdlls\MFC71.DLL
\webnms\rfdlls\MSVCR71.DLL
\webnms\rfdlls\MSVCP71.DLL

On Linux platform, you can use toolks such as "ldd" to find out any dependency issues.

If there are any dependency issues, fix them by installing the required libraries for missing 
dependencies and then restart WCS.

The names of the CAD file layers are listed, with check boxes to the right side of the image 
indicating which are enabled.
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Note When you choose the floor or basement image filename, WCS displays the image in the 
building-sized grid.

Note The maps can be any size because WCS automatically resizes the maps to fit the workspace. 

Note The map must be saved in .PNG, .JPG, .JPEG, or .GIF format.

If you have CAD file layers, you can select or deselect as many as you want and click Preview to 
view an updated image. Click Next when you are ready to proceed with the selected layers. 

Step 9 Enter the remaining parameters for the floor area.

• Either leave the Maintain Aspect Ratio check box selected to preserve the original image aspect 
ratio or unselect the check box to change the image aspect ratio.

• Enter an approximate floor or basement horizontal and vertical span (width and depth on the map) 
in feet.

Note The horizontal and vertical spans should be smaller than or the same size as the building 
horizontal and vertical spans in the WCS database.

• If applicable, enter the horizontal position (distance from the corner of the outdoor area rectangle to 
the left edge of the campus map) and vertical position (distance from the corner of the outdoor area 
rectangle to the top edge of the campus map) in feet or meters.

Tip User Ctrl-click to resize the image within the building-sized grid.

• Adjust the floor characteristics with the WCS map editor by selecting the check box next to Launch 
Map Editor. See the “Map Editor” section on page 5-4 for more information regarding the map 
editor feature.

Step 10 Click OK to save this floor plan to the database. The floor is added to the Maps Tree View and the 
Monitor > Maps list.

Step 11 Click any of the floor or basement images to view the floor plan or basement map. 

Note You can zoom in or out to view the map at different sizes and you can add access points. See the 
“Adding Access Points to a Floor Area” section on page 5-48 for more information.

Adding Access Points to a Floor Area

After you add the .PNG, .JPG, .JPEG, or .GIF format floor plan and outdoor area maps to the WCS 
database, you can position lightweight access point icons on the maps to show where they are installed 
in the buildings. To add access points to a floor area and outdoor area, follow these steps:
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Step 1 Choose Monitor > Maps. The Maps page opens. (See Figure 5-25)

Figure 5-25 Monitor Maps Window

Step 2 From the Maps Tree View or the Monitor > Maps list, click the applicable floor to open the Floor View 
page.

Figure 5-26 Floor View Window

Step 3 From the Select a command drop-down list, choose Add Access Points, and click Go.

Step 4 From the Add Access Points page, select the check boxes of the access points that you want to add to 
the floor area.
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Figure 5-27 Add Access Point Window

Note Only access points which are not yet assigned to any floor or outdoor area appear in the list.

Note Select the check box at the top of the list to select all access points.

Note WCS allows a maximum of 100 access points per floor map.

Step 5 When all of the applicable access points are selected, click OK located at the bottom of the access point 
list. 

The Position Access Points page opens.

Figure 5-28 Position Access Points Window

Each access point you have chosen to add to the floor map is represented by a gray circle (differentiated 
by access point name or MAC address) and is lined up in the upper left part of the floor map. 
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Step 6 Click and drag each access point to the appropriate location. Access points turn blue when selected. 

Note When you drag an access point on the map, its horizontal and vertical position displays in the 
boxes above.

Note The small black arrow at the side of each access point represents Side A of each access point, 
and each access point arrow must correspond with the direction in which the access points were 
installed. 
Side A is clearly noted on each 1000 series access point and has no relevance to the 802.11a/n 
radio.
To adjust the directional arrow, choose the appropriate orientation in the Antenna Angle 
drop-down list. 

When selected, the access point details display on the left side of the page. Access point details include:

• AP Model—Indicates the model type of the selected access point.

• Protocol—Select the protocol for this access point from the drop-down list.

• Antenna—Select the appropriate antenna type for this access point from the drop-down list.

• Antenna/AP Image—The antenna image reflects the antenna selected from the Antenna drop-down 
list. Click the arrow at the top right of the antenna image to expand the image size.

• Antenna Orientation—Depending on the antenna type, enter the Azimuth and the Elevation 
orientations in degrees. 

Note The Azimuth option does not appear for Omnidirectional antennas because their pattern is 
nondirectional in azimuth.

Note For internal antennas, the same elevation angle applies to both radios.

The antenna angle is relative to the map X axis. Because the origin of the X (horizontal) and Y 
(vertical) axes is in the upper left corner of the map, 0 degrees points side A of the access point to 
the right, 90 degrees points side A down, 180 degrees points side A to the left, and so on.

The antenna elevation is used to move the antenna vertically, up or down, to a maximum of 90 
degrees.

Note Make sure each access point is in the correct location on the map and has the correct antenna 
orientation. Accurate access point positioning is critical when you use the maps to find coverage 
holes and rogue access points.

Refer to this location for further information about the antenna elevation and azimuth patterns:
http://www.cisco.com/en/US/products/hw/wireless/ps469/tsd_products_support_series_home.html 
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Figure 5-29 Selected Access Point Details

Step 7 When you are finished placing and adjusting each access point, click Save.

Note Clicking Save causes the antenna gain on the access point to correspond to the selected antenna. 
This may cause radio reset.

WCS computes the RF prediction for the coverage area. These RF predictions are popularly known as 
heat maps because they show the relative intensity of the RF signals on the coverage area map.

Note This display is only an approximation of the actual RF signal intensity because it does not take 
into account the attenuation of various building materials, such as drywall or metal objects, nor 
does it display the effects of RF signals bouncing off obstructions.

Note Antenna gain settings have no effect on heatmaps and location calculations. Antenna gain is 
implicitly associated to the antenna name. Because of this, the following apply:
– If an antenna is used and marked as “Other” in WCS, it is ignored for all heatmap and location 
calculations; 
– If an antenna is used and marked as a Cisco antenna in WCS, that antenna gain setting (internal 
value on WCS) is used no matter what gain is set on the controller. 
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Figure 5-30 RF Prediction heatmaps

Note See the “Placing Access Points” section on page 5-54 for more information on placing access 
points on a map.

Note You can change the position of access points by importing or exporting a file. See the 
“Positioning Access Points, Wi-Fi TDOA Receivers, and Chokepoints by Importing or 
Exporting a File” section on page 5-56 for more information.

Editing Floor Areas

To edit a current floor area, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Click the name of the floor area to open its details page.

Step 3 From the Select a command drop-down list, choose Edit Floor Area.

Step 4 Make any necessary changes to Floor Area Name, Contact, Floor, Floor Height (feet), Floor Type (RF 
Model), Existing Image File, or Import New Image File.

Step 5 Click OK.

Deleting Floor Areas

To delete a current floor area, follow these steps:
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Step 1 Choose Monitor > Maps.

Step 2 Select the check box for the applicable floor area.

Step 3 From the Select a command drop-down list, choose Delete Maps.

Step 4 Click Go.

Step 5 Click OK to confirm the deletion.

Placing Access Points

To determine the best location of all devices in the wireless LAN coverage areas, you need to consider 
the access point density and location.

Ensure that no fewer than 3 access points, and preferably 4 or 5, provide coverage to every area where 
device location is required. The more access points that detect a device, the better. This high level 
guideline translates into the following best practices, ordered by priority:

1. Most importantly, access points should surround the desired location.

2. One access point should be placed roughly every 50 to 70 linear feet (about 17 to 20 meters). This 
translates into one access point every 2,500 to 5000 square feet (about 230 to 450 square meters).

Note The access point must be mounted so that it is under 20 feet high. For best performance, a mounting at 
10 feet would be ideal. 

Following these guidelines makes it more likely that access points will detect tracked devices. Rarely do 
two physical environments have the same RF characteristics. Users may need to adjust those parameters 
to their specific environment and requirements.

Note Devices must be detected at signals greater than –75 dBm for the controllers to forward information to 
the location appliance. No fewer than three access points should be able to detect any device at signals 
below –75 dBm. 

Note If you have a ceiling-mounted AP with an integrated omni-directional antenna, the antenna orientation 
does not really need to be set in WCS. However, if you mount that same AP on the wall, you must set 
the antenna orientation to 90 degrees.

The Table 5-6 describes the orientation of the access points.

Import Map and AP Location Data

When converting from autonomous to lightweight access points and from WLSE to WCS, one of the 
conversion steps is to manually re-enter the access point-related information into WCS. To speed up this 
process, you can export the information about access points from WLSE and import it into WCS. 
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Note WCS expects a .tar file and checks for a .tar extension before importing the file. If the file you are trying 
to import is not a .tar file, WCS displays an error message and prompts you to import a different file. 

Note For more information on the WLSE data export functionality (WLSE version 2.15), see
http://<WLSE_IP_ADDRESS>:1741/debug/export/exportSite.jsp.

To map properties and import a tar file containing WLSE data using the WCS web interface, follow these 
steps: 

Step 1 Choose Monitor > Maps. 

Step 2 From the Select a command drop-down list, choose Import WLSE Map and AP Location Data.

Step 3 Click Go. The Import WLSE Map and AP Location Data page opens.

Figure 5-31 Import WLSE Map and AP Location Data Window

Step 4 In the Import Data from WLSE section, click Browse to select the file to import. 

Step 5 Find and select the .tar file to import, and click Open. 

WCS displays the name of the file in the Import From text box.

Step 6 Click Import.

WCS uploads the file and temporarily saves it into a local directory while it is being processed. If the 
file contains data that cannot be processed, WCS prompts you to correct the problem and retry. Once the 
file has been loaded, WCS displays a report of what will be added to WCS. The report also specifies 
what cannot be added and why.

If some of the data to be imported already exists, WCS either uses the existing data in the case of 
campuses or overwrites the existing data using the imported data in the cases of buildings and floors.

Note If there are duplicate names between a WLSE site and building combination and a WCS campus 
(or top-level building) and building combination, WCS displays a message in the Pre Execute 
Import Report indicating that it will delete the existing building.
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Step 7 Click Import to import the WLSE data. 

WCS displays a report indicating what was imported. 

Step 8 Choose Monitor > Maps to view the imported data.

Positioning Access Points, Wi-Fi TDOA Receivers, and Chokepoints by Importing or Exporting a File

You can change an access point, Wi-Fi TDOA receiver, or chokepoint position by importing or exporting 
a file. The file contains only the lines describing the component you want to move. This option takes less 
time than manually changing multiple positions. Refer to the Cisco Context-Aware Services 
Configuration Guide for more information on chokepoints and Wi-Fi TDOA receivers.
To change an access point, Wi-Fi TDOA receiver, or chokepoint position, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 From the Select a command drop-down list, choose Properties.

Step 3 At the Unit of Dimension drop-down list, choose feet or meters.

Step 4 Select the Advanced Debug Mode Enable radio button.

Step 5 Click OK.

Step 6 From the Select a command drop-down list, choose Export/Import AP/WiFi TDOA 
Receiver/Chokepoint Placement.

Step 7 In the Import/Export AP/WiFi TDOA Receiver/Chokepoint Placement window, click Browse to find the 
file you want to import. 

Note The file must already be created and added to WCS.

Note The following is the correct file format:

[BuildingName], [FloorName], [AP/WiFi TDOA Receiver/Chokepoint Name], (aAngle), 
(bAngle), [X], [Y], ([aAngleElevation, bAngleElevation, Z]), (aAntennaType, aAntennaMode, 
(aAntennaPattern, (aAntennaGain)), bAntennaType, bAntennaDiversity, (bAntennaPattern, 
bAntennaGain)))))

The parameters in square brackets are mandatory, and those in parentheses are optional.

Note Angles must be entered in radians (X,Y), and the height is entered in feet. The aAngle and 
bAngle range is from –2Pi (-6.28...) to 2Pi (6.28...), and the elevation ranges from –Pi (-3.14...) 
to Pi (3.14...).

Step 8 Click Import. The RF calculation takes approximately two seconds per component.
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Changing Access Point Positions by Importing and Exporting a File

You can change an access point position by importing or exporting a file. The file contains only the lines 
describing the access point you want to move. This option takes less time than manually changing 
multiple access point positions. Follow these steps to change access point positions using the importing 
or exporting of a file.

Step 1 Choose Monitor > Maps.

Step 2 From the Select a command drop-down list, choose Import AP/WiFi TDOA Receiver/Chokepoint 
Placement or Export AP/WiFi TDOA Receiver/Chokepoint Placement, and click Go.

Step 3 In Import Data from File or Export Data from File, click Browse to find the file you want to import. The 
file in the [BuildingName], [FloorName], [APName], (aAngle), (bAngle), [X], [Y], ([aAngleElevation, 
bAngleElevation, Z]), (aAntennaType, aAntennaMode, (aAntennaPattern, (aAntennaGain)), 
bAntennaType, bAntennaDiversity, (bAntennaPattern, bAntennaGain))))) format must have already 
been created and added to WCS. (See the “Inspecting VoWLAN Readiness” section on page 5-79.)

Note The parameters in square brackets are mandatory, and those in parentheses are optional.

Note Angles must be entered in radians (X,Y), and the height is entered in feet. The aAngle and 
bAngle range is from –2Pi (-6.28...) to 2Pi (6.28...), and the elevation ranges from –Pi (-3.14...) 
to Pi (3.14...).

Step 4 Click Import. The RF calculation takes approximately two seconds per access point.

Configuring ChokePoints
Using chokepoints in conjunction with active compatible extensions compliant tags provides immediate 
location information on a tag and its asset. When a Cisco Compatible Extension tag moves out of the 
range of a chokepoint, its subsequent beacon frames do not contain any identifying chokepoint 
information. Location determination of the tag defaults to the standard calculation methods based on 
RSSIs reported by the access point associated with the tag.

This section contains the following topics:

• Using Chokepoints to Enhance Tag Location Reporting, page 5-58

• Adding Chokepoints to the WCS Database, page 5-58

• Adding a Chokepoint to a WCS Map, page 5-58

• Positioning Chokepoints, page 5-59

• Removing Chokepoints from the WCS Database and Map, page 5-60
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Using Chokepoints to Enhance Tag Location Reporting

Installation of chokepoints provides enhanced location information for RFID tags. When an active Cisco 
Compatible Extensions version 1 compliant RFID tag enters the range of a chokepoint, it is stimulated 
by the chokepoint. The MAC address of this chokepoint is then included in the next beacon sent by the 
stimulated tag. All access points that detect this tag beacon then forward the information to the controller 
and location appliance.

Using chokepoints in conjunction with active compatible extensions compliant tags provides immediate 
location information on a tag and its asset. When a Cisco Compatible Extension tag moves out of the 
range of a chokepoint, its subsequent beacon frames do not contain any identifying chokepoint 
information. Location determination of the tag defaults to the standard calculation methods based on 
RSSIs reported by the access point associated with the tag.

Adding Chokepoints to the WCS Database

Chokepoints are installed and configured as recommended by the Chokepoint vendor. After the 
chokepoint installation is complete and operational, the chokepoint can be entered into the location 
database and plotted on a WCS map.

To add a chokepoint to the WCS database, follow these steps:

Step 1 Choose Configure > Chokepoints. 

Step 2 From the Select a command drop-down list, choose Add Chokepoints.

Step 3 Click Go.

Step 4 Enter the MAC address and name for the chokepoint.

Step 5 Select the check box to indicate that it is an Entry/Exit Chokepoint.

Step 6 Enter the coverage range for the chokepoint. 

Note Chokepoint range is a visual representation only. It is product-specific. The actual range must 
be configured separately using the applicable chokepoint vendor software. 

Step 7 Click OK.

Note After the chokepoint is added to the database, it can be placed on the appropriate WCS floor 
map.

Adding a Chokepoint to a WCS Map

To add the chokepoint to a map, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 On the Maps page, choose the link that corresponds to the floor location of the chokepoint.

Step 3 From the Select a command drop-down list, choose Add Chokepoints. 
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Step 4 Click Go. 

Note The Add Chokepoints summary page lists all recently-added chokepoints that are in the database 
but not yet mapped.

Step 5 Select the check box next to the chokepoint that you want to place on the map. 

Step 6 Click OK. 

A map appears with a chokepoint icon located in the top-left hand corner. You are now ready to place 
the chokepoint on the map.

Step 7 Left-click the chokepoint icon and drag it to the proper location. 

Note The MAC address, name, and coverage range of the chokepoint appear in the left pane when you 
click the chokepoint icon for placement.

Step 8 Click Save.

You are returned to the floor map and the added chokepoint appears on the map.

Note The newly created chokepoint icon may or may not appear on the map depending on the display 
settings for that floor.

Note The rings around the chokepoint icon indicate the coverage area. When a CCX tag and its asset 
passes within the coverage area, location details are broadcast, and the tag is automatically 
mapped on the chokepoint coverage circle. When the tag moves out of the chokepoint range, its 
location is calculated as before and is no longer mapped on the chokepoint rings.

Note The MAC address, name, entry/exit chokepoint, static IP address, and range of the chokepoint 
appears when you hover your mouse cursor over its map icon.

Step 9 If the chokepoint does not appear on the map, select the Chokepoints check box located on the Floor 
Settings menu.

Note Do not select Save Settings unless you want to save this display criteria for all maps.

Note You must synchronize network design to the mobility services engine or location server to push 
chokepoint information.

Positioning Chokepoints

To position chokepoints on the map, follow these steps:
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Step 1 Left-click the chokepoint icon and drag it to the proper location.

Note The MAC address, name, and coverage range of the chokepoint appear in the left pane when you 
click the chokepoint icon for placement.

Step 2 Click Save when the icon is correctly placed on the map.

Step 3 The newly created chokepoint icon may or may not appear on the map depending on the display settings 
for that floor. If the icon does not appear, repeat Step 11.

Note The rings around the chokepoint icon indicate the coverage area. When a Cisco Compatible 
Extensions tag and its asset passes within the coverage area, location details are broadcast, and 
the tag is automatically mapped on the chokepoint coverage circle. The chokepoint range is 
given as a visual only, but chokepoint vendor software is required to actually configure the range. 
When the tag moves out of the chokepoint range, its location is calculated as before and is no 
longer mapped on the chokepoint rings.

Note MAC address, name, and range of a chokepoint display when you hover your mouse cursor over 
its map icon.

Step 4 If the chokepoint does not appear on the map, click Layers to view a drop-down list of possible elements 
to display on the map. Select the Chokepoints check box.

Step 5 Click X to close the Layers page.

Note Do not select Save Settings unless you want to save this display criteria for all maps.

Note You can change the position of chokepoints by importing or exporting a file. See the “Positioning Access 
Points, Wi-Fi TDOA Receivers, and Chokepoints by Importing or Exporting a File” section on 
page 5-56 for more information.

Removing Chokepoints from the WCS Database and Map

You can remove one or multiple chokepoints at a time.

To delete a chokepoint, follow these steps:

Step 1 Choose Configure > Chokepoints.

Step 2 Select the box(es) next to the chokepoint(s) to be deleted.

Step 3 From the Select a command drop-down list, choose Remove Chokepoints. 

Step 4 Click Go.
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Step 5 Click OK to confirm the chokepoint deletion.

Configuring WiFi TDOA Receivers
This section contains the following topics:

• Adding WiFi TDOA Receivers to the WCS Database, page 5-61

• Adding WiFi TDOA Receivers to a Map, page 5-61

• Positioning WiFi TDOA Receivers, page 5-62

• Removing WiFi TDOA Receivers from the Map, page 5-62

• Removing WiFi TDOA Receivers from the WCS Database, page 5-63

Adding WiFi TDOA Receivers to the WCS Database

To add a WiFi TDOA receivers to the WCS database, follow these steps:

Step 1 Choose Configure > WiFi TDOA Receivers. 

Step 2 From the Select a command drop-down list, choose Add WiFi TDOA Receivers. 

Step 3 Click Go.

Step 4 Enter the MAC address, name, and static IP address for the WiFi TDOA receiver.

Note WiFi TDOA receivers are configured separately using the WiFi TDOA receiver vendor software.

Step 5 Click OK to save the WiFi TDOA receiver entry to the database.

Note After the WiFi TDOA receiver is added to the database, place it on the appropriate WCS floor 
map. See “Adding WiFi TDOA Receivers to the WCS Database” for more information.

Adding WiFi TDOA Receivers to a Map

To add a WiFi TDOA receiver to a map, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Choose the link that corresponds to the floor location of the WiFi TDOA receiver. 

Step 3 From the Select a command drop-down list, choose Add WiFi TDOA Receivers. 

Step 4 Click Go.

Note The Add WiFi TDOA Receivers summary page lists all recently-added WiFi TDOA receivers 
that are in the database but not yet mapped.
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Step 5 Select the check box next to the WiFi TDOA receiver to be added to the map. 

Step 6 Click OK. 

A map appears with a green WiFi TDOA receiver icon located in the top-left hand corner. You are now 
ready to position the WiFi TDOA receiver on the map.

Positioning WiFi TDOA Receivers

To position WiFi TDOA receivers on the map, follow these steps:

Step 1 Left-click the WiFi TDOA receiver icon and drag it to the proper location.

Note The MAC address and name of the WiFi TDOA receiver appear in the left pane when you click 
the WiFi TDOA receiver icon for placement.

Step 2 Click Save when icon is correctly placed on the map.

Note The MAC address of the WiFi TDOA receiver appears when you hover your mouse cursor over 
its map icon.

Step 3 If the chokepoint does not appear on the map, click Layers to view a drop-down list of possible elements 
to display on the map. Select the WiFi TDOA Receivers check box.

Step 4 Click X to close the Layers page.

Note Do not select Save Settings unless you want to save this display criteria for all maps.

Note You can change the position of Wi-Fi TDOA Receivers by importing or exporting a file. See the 
“Positioning Access Points, Wi-Fi TDOA Receivers, and Chokepoints by Importing or Exporting a File” 
section on page 5-56 for more information.

Removing WiFi TDOA Receivers from the Map

To remove a WiFi TDOA receiver from a floor map, follow these steps:

Step 1 From the Select a command drop-down list on the applicable WCS floor map page, choose Remove 
WiFi TDOA Receivers. 

Step 2 Click Go.

Step 3 Select the check box(es) next to the WiFi TDOA receiver(s) to be deleted.

Note You can remove multiple WiFi TDOA receivers at a time from a map.
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Step 4 Click OK.

Removing WiFi TDOA Receivers from the WCS Database 

To remove a WiFi TDOA receiver from the WCS database, follow these steps:

Step 1 Choose Configure > WiFi TDOA Receivers.

Step 2 Select the check box(es) next to the WiFi TDOA receiver(s) to be deleted.

Note You can remove multiple WiFi TDOA receivers at a time from the database.

Step 3 From the Select a command drop-down list, choose Remove WiFi TDOA Receivers. 

Step 4 Click Go.

Step 5 Click OK to confirm the deletion.

Managing RF Calibration Models
If the provided RF models do not sufficiently characterize the floor layout, you can create a calibration 
model that is applied to the floor and better represents the attenuation characteristics of that floor. The 
calibration models are used as RF overlays with measured RF signal characteristics that can be applied 
to different floor areas. This enables the Cisco WLAN solution installation team to lay out one floor in 
a multi-floor area, use the RF calibration tool to measure, save the RF characteristics of that floor as a 
new calibration model, and apply that calibration model to all the other floors with the same physical 
layout.

You can collect data for a calibration using one of two methods:

• Point mode data collection—Calibration points are selected and their coverage area is calculated one 
location at a time.

• Linear mode data collection—A series of linear paths are selected and then calculated as you 
traverse the path. This approach is generally faster than the point mode data collection. You can also 
employ point mode data collection to augment data collection for locations missed by the linear 
paths.

Note Calibration models can only be applied to clients, rogue clients, and rogue access points. 
Calibration for tags is done using the Aeroscout System Manager. Refer to the following link for 
details on tag calibration at: http://support.aeroscout.com.

Note A client device that supports both 802.11a/n and 802.11b/g/n radios is recommended to expedite 
the calibration process for both spectrums.

Use a laptop or other wireless device to open a browser to the WCS server and perform the calibration 
process.
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This section provides the following:

• Accessing Current Calibration Models, page 5-64

• Applying Calibration Models to Maps, page 5-64

• Calibration Model Properties, page 5-64

• Calibration Model Details, page 5-65

• Creating New Calibration Models, page 5-65

• Starting Calibration Process, page 5-65

• Calibrating, page 5-68

• Applying to Maps, page 5-68

• Deleting Calibration Models, page 5-69

Accessing Current Calibration Models

To access current calibration models, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 From the Select a command drop-down list, choose RF Calibration Models. The Model Name and 
Status for each calibration model is listed.

Step 3 Click the Model Name to access a specific calibration model.

Applying Calibration Models to Maps

To apply a current calibration model to a map, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 From the Select a command drop-down list, choose RF Calibration Models.

Step 3 Click the Model Name to access the applicable calibration model.

Step 4 From the Select a command drop-down list, choose Apply to Maps.

Step 5 Click Go.

Calibration Model Properties

To view or edit current calibration models, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 From the Select a command drop-down list, choose RF Calibration Models.

Step 3 Click the Model Name to access the applicable calibration model.

Step 4 From the Select a command drop-down list, choose Properties.
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Step 5 Click Go to view or edit calibration model details. See Calibration Model Details, page 5-65 for more 
information.

Calibration Model Details

To edit calibration model details, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 From the Select a command drop-down list, choose RF Calibration Models.

Step 3 Click the Model Name to access the applicable calibration model.

Step 4 From the Select a command drop-down list, choose Properties.

Step 5 Click Go.

Step 6 The following parameters may be edited:

• Sweep Client Power for Location—Click to enable. You may want to enable this if a high density 
of access points exists and transmit power is reduced or unknown. The sweeping range of client 
transmit power may improve accuracy but scalability is negatively affected.

• HeatMap Binsize—Choose 4, 8, 16, or 32 from the drop-down list.

• HeatMap Cutoff—Determine the heatmap cutoff. A low heatmap cutoff is recommended especially 
if the access point density is high and RF propagation conditions are favorable. A higher cutoff value 
increases scalability but may cause difficulty when locating clients.

Step 7 When any necessary changes have been made or to exit the page, click OK.

Creating New Calibration Models

To create a new calibration model, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 From the Select a command drop-down list, choose RF Calibration Models.

Step 3 Click Go.

Step 4 From the Select a command drop-down list, choose Create New Model.

Step 5 Click Go.

Step 6 Enter a Model Name, and click OK.

The new model appears along with the other RF calibration models with a status of Not Yet Calibrated.

Starting Calibration Process

To start the calibration process, follow these steps:

Step 1 Click the Model Name to open the Calibration Model > Model Name page.
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Step 2 From the Select a command drop-down list, choose Add Data Points.

Step 3 Click GO.

Step 4 Enter the MAC address of the device being used to perform the calibration. Manually-entered MAC 
addresses must be delimited with colons (such as FF:FF:FF:FF:FF:FF).

Note If this process is being performed from a mobile device connected to WCS through the Cisco 
Centralized architecture, the MAC address text box is automatically populated with the device 
address.

Step 5 Choose the appropriate campus, building, floor or outdoor area where the calibration is performed.

Note The calibration in outdoor area is supported from 7.0.x release onwards. You can use this option 
to add the calibration data points to the outdoor area. The data points can be added to the outdoor 
area using the same procedure for calibration.

Step 6 Click Next.

Step 7 When the chosen floor map and access point locations display, a grid of plus marks (+) indicates the 
locations where data collection for calibration is performed.

Using these locations as guidelines, you can perform either a point or linear collection of data by 
appropriate placement of either the Calibration Point pop-up (point) or the Start and Finish pop-ups 
(linear) that display on the map when the respective options are displayed.

If you want to do a point collection of data for the calibration, do the following:

a. Select Point from the Collection Method drop-down list and select the Show Data points check box 
if not already selected. A Calibration Point pop-up appears on the map.

b. Position the tip of the Calibration Point pop-up at a data point (+), and click Go. A pane appears 
showing the progress of the data collection.

Note Rotate the calibrating client laptop during data collection so that the client is heard evenly by all 
access points in the vicinity.

c. When the data collection is complete for a selected data point and the coverage area is plotted on 
the map, move the Calibration Point pop-up to another data point, and click Go.

Note The coverage area plotted on the map is color-coded and corresponds with the specific 
wireless LAN standard used to collect that data. Information on color-coding is provided in 
legend on the left side of the page. Additionally, the progress of the calibration process is 
indicated by two status bars above the legend, one for 802.11a/n and one for 802.11b/g/n.

Note To delete data points for locations selected in error, click Delete and move the black square 
that appears over the appropriate data points. Resize the square as necessary by pressing 
Ctrl and moving the mouse.

d. Repeat point collection steps a to c until the calibrations status bar of the relevant spectrums 
(802.11a/n, 802.11b/g/n) display as ‘done.’
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Note The calibration status bar indicates data collection for the calibration as done, after roughly 
50 distinct locations and 150 measurements have been gathered. For every location point 
saved in the calibration process, more than one data point is gathered. The progress of the 
calibration process is indicated by two status bars above the legend, one for 802.11b/g/n and 
one for 802.11a/n.

If you want to do a linear collection of data for the calibration, do the following:

a. Select Linear from the Collection Method drop-down list and select the Show Data points check 
box if not already selected. A line appears on the map with both Start and Finish pop-ups.

b. Position the tip of the Start pop-up at the starting data point.

c. Position the Finish pop-up at the ending data point.

d. Position yourself with your laptop at the starting data point and click Go. Walk steadily towards the 
end point along the defined path. A pane appears to show that data collection is in process.

Note Do not stop data collection until you reach the end point even if the data collection bar 
indicates completion.

Note Only Intel and Cisco adapters have been tested.  Make sure the Enable Cisco Compatible 
Extensions and Enable Radio Management Support are enabled in the Cisco Compatible 
Extension Options.

e. Press the space bar (or Done in the data collection pane) when you reach the end point. The 
collection pane displays the number of samples taken before it closes to reveal the map. The map 
displays all the coverage areas where data was collected.

Note To delete data points for locations selected in error, click Delete and move the black square 
that appears over the appropriate data points. Resize the square as necessary by pressing the 
Ctrl and moving the mouse.

Note The coverage area is color-coded and corresponds with the specific wireless LAN standard 
used to collect that data. Information on color-coding is provided in legend on the left-hand 
side of the page.

f. Repeat linear collection steps b to e until the status bar for the respective spectrum is filled in (done).

Note You can augment linear collection with point mode data collection to address missed 
coverage areas.

Step 8 Click the name of the calibration model at the top of the page to return to the main page for that model 
to calibrate the data points.

Step 9 Choose Calibrate from the Select a command drop-down list, and click Go.
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Step 10 Click the Inspect Location Quality link when calibration completes. A map displays showing RSSI 
readings displays.

Step 11 To use the newly created calibration model, you must apply the model to the floor on which it was 
created (and on any other floors with similar attenuation characteristics as well). Navigate to Monitor 
> Maps and find the specific floor to which the model is applied. At the floor map interface, choose Edit 
Floor Area from the drop-down list, and click Go.

Step 12 From the Floor Type (RF Model) drop-down list, choose the newly created calibration model. Click OK 
to apply the model to the floor.

Note This process can be repeated for as many models and floors as needed. After a model is applied 
to a floor, all location determination performed on that floor is done using the specific collected 
attenuation data from the calibration model.

Calibrating 

To compute the collected data points, follow these steps:

Step 1 Click the Model Name to open the Calibration Model > Model Name page.

Step 2 In the Calibration Model > Model Name page, choose Calibrate from the Select a command drop-down 
list.

Step 3 Click Go. 

Applying to Maps

To use the newly created calibration model, you must apply the model to the floor on which it was 
created (along with other floors with similar attenuation characteristics). 

To apply the model to the floor, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Locate the specific floor to which the model is applied. 

Step 3 From the Select a command drop-down list, choose Edit Floor Area.

Step 4 Click Go. 

Step 5 From the Floor Type (RF Model) drop-down list, choose the newly-created calibration model. 

Step 6 Click OK to apply the model to the floor. 

This process can be repeated for as many models and floors as needed. After a model is applied to a floor, 
all location determination performed on that floor is done using the specific collected attenuation data 
from the calibration model. 
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Deleting Calibration Models

To delete a calibration model, follow these steps:

Step 1 Click the Model Name to open the Calibration Model > Model Name page.

Step 2 From the Select a command drop-down list, choose Delete Model. 

Step 3 Click Go. 

Managing Location Presence Information
You can enable location presence by mobility services engine to provide expanded Civic (city, state, 
postal code, country) and GEO (longitude, latitude) location information beyond the Cisco default 
setting (campus, building, floor, and X, Y coordinates). This information can then be requested by clients 
on a demand basis for use by location-based services and applications. See the “Enabling Location 
Presence for Mobility Services” section on page 12-43 for more information on enabling location 
presence.

To view or edit current location presence information for a current map, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Select the check box of the map.

Step 3 From the Select a command drop-down list, choose Location Presence. 

Step 4 Click Go. The Location Presence page appears.

Note The current map location information (Area Type, Campus, Building, and Floor) refer to the map 
you selected from the Monitor > Maps page. To select a different map, use the Select a Map to 
Update Presence Information drop-down list to select the new map location.
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Figure 5-32 Location Presence Window

Step 5 Click either the Civic, GPS Markers, or Advanced tab.

– Civic Address—Identifies the campus, building, or floor by name, street, house number, house 
number suffix, city (address line2), state, postal code, and country.

– GPS Markers—Identify the campus, building, or floor by longitude and latitude.

– Advanced—Identifies the campus, building, or floor with expanded civic information such as 
neighborhood, city division, county, and postal community name.

Note Each selected parameter is inclusive of all of those above it. For example, if you select 
Advanced, it can also provide GPS and Civic location information upon client demand. The 
selected setting must match what is set on the mobility services engine level. See the Enabling 
Location Presence for Mobility Services, page 12-43 for more information.

Note If a client requests location information such as GPS Markers for a campus, building, floor, or 
outdoor area that is not configured for that parameter, an error message appears.

Note By default, the Override Child Element Presence Info check box is selected. 
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Searching Maps
Use the controls in the left sidebar menu to create and save custom searches:

• New Search drop-down list: Opens the Search Maps window. Use the Search Maps window to 
configure, run, and save searches.

• Saved Searches drop-down list: Lists the saved custom searches. To open a saved search, choose it 
from the Saved Searches list.

• Edit Link: Opens the Edit Saved Searches window. You can delete saved searches in the Edit Saved 
Searches window.

• Audit Status: Allows you to search based on audit status of not available (audit status is not 
available), identical (no configuration differences were found during the last audit), or mismatch 
(configuration differences were found during the last audit). 

You can configure the following parameters in the Search Maps window:

• Search for

• Map Name

• Search in

• Save Search

• Items per page

After you click Go, the map search results window appears (see Table 5-7):

Using Map Editors
You can use the WCS map editor to define, draw, and enhance floor plan information. This section 
contains the following topics:

• Opening the Map Editor, page 5-72

• Using the Map Editor to Draw Polygon Areas, page 5-72

• Defining an Inclusion Region on a Floor, page 5-75

• Defining an Exclusion Region on a Floor, page 5-76

Table 5-7 Map Search Results

Parameter Options

Name Clicking an item in the Name list gives a map of an existing building 
with individual floor area maps for each floor.

Type Campus, building, or floor area.

WCS WCS name.

Total APs Displays the total number of Cisco radios detected.

a/n Radios Displays the number of 802.11a/n Cisco radios.

b/g/n Radios Displays the number of 802.11b/g/n Cisco radios.

OOS Radios Displays the number of Out of Service access points associated with 
this controller.
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• Defining a Rail Line on a Floor, page 5-77

Opening the Map Editor

To use the map editor, follow these steps:

Step 1 Choose Monitor > Maps to display the Maps page.

Step 2 Click the desired campus. WCS displays the Maps > Campus Name page.

Step 3 Click a campus building.

Step 4 Click the desired floor area. WCS displays the Maps > Campus Name > Building Name > Floor Area 
Name page.

Step 5 From the Select a command drop-down list, choose Map Editor, and click Go. WCS displays the Map 
Editor page. 

Note Make sure that the floor plan images are properly scaled so that all white space outside of the 
external walls is removed. To make sure that floor dimensions are accurate, choose the compass 
tool from the toolbar.

Step 6 Position the reference length. When you do, the Scale menu appears with the line length supplied. Enter 
the dimensions (width and height) of the reference length, and click OK.

Step 7 Determine the propogation pattern at the Antenna Mode drop-down list.

Step 8 Make antenna adjustments by sliding the antenna orientation bar to the desired degree of direction.

Step 9 Choose the desired access point.

Step 10 Click Save.

Using the Map Editor to Draw Polygon Areas

If you have a building that is non-rectangular or you want to mark a non-rectangular area within a floor, 
you can use the map editor to draw a polygon-shaped area. To draw a polygon area in the map, follow 
these steps:

Step 1 Add the floor plan if it is not already represented in WCS (see the “Adding Floor Areas to a Campus 
Building” section on page 5-42).

Step 2 Choose Monitor > Maps. 

Step 3 Click the Map Name that corresponds to the outdoor area, campus, building, or floor you want to edit.

Step 4 From the Select a command drop-down list, choose Map Editor, and click Go. 

Step 5 At the Map Editor screen, click the Add Perimeter icon on the toolbar (see Figure 5-33).

A pop-up dialog box appears.
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Figure 5-33 Map Editor Page

Step 6 Enter the name of the area that you are defining. Click OK.

A drawing tool appears.

Step 7 Move the drawing tool to the area you want to outline.

• Click the left mouse button to begin and end drawing a line.

• When you have completely outlined the area, double-click the left mouse button and the area is 
highlighted on the screen (see Figure 5-34).

The outlined area must be a closed object to highlight on the map.
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Figure 5-34 Polygon Area

Step 8 Click the disk icon on the toolbar to save the newly drawn area.

Step 9 Choose Command > Exit to close the window. You are returned to the original floor plan.

Note When you return to the original floor plan view, after exiting the map editor, the newly drawn 
area is not seen; however, it appears in the Planning Model window when you add elements.

Step 10 Choose Planning Mode from the Select a command drop-down list to begin adding elements to the 
newly defined polygon-shaped area.

The Table 5-8 explains the color coding of obstacles.

Table 5-8 Obstacle color coding

Type of obstacle Color coding Loss (in dB)

Thick wall 13

Light wall 2

Heavy door 15
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Note The RF prediction heatmaps for access points approximates of the actual RF signal intensity. It takes 
into account the attenuation of obstacles drawn using the Map Editor but it does not take into account 
the attenuation of various building materials, such as drywall or metal objects, nor does it display the 
effects of RF signals bouncing off obstructions. The thick wall (color-coded orange) with a loss of 13 
dB may not be enough to contain the RF signal beyond the walls of the heatmap.

Defining an Inclusion Region on a Floor

To define an inclusion area, follow these steps:

Step 1 Choose Monitor > Maps. 

Step 2 Click the name of the appropriate floor area.

Step 3 From the Select a command drop-down list, choose Map Editor.

Step 4 Click Go.

Step 5 At the map, click the aqua box on the toolbar.

Note A message box appears reminding you that only one inclusion area can be defined at a time. 
Defining a new inclusion region automatically removes the previously defined inclusion region. 
By default, an inclusion region is defined for each floor when it is added to WCS. The inclusion 
region is indicated by a solid aqua line and generally outlines the region.

Step 6 Click OK in the message box that appears. A drawing icon appears to outline the inclusion area.

Step 7 To begin defining the inclusion area, move the drawing icon to a starting point on the map and click once. 

Step 8 Move the cursor along the boundary of the area you want to include and click to end a border line. Click 
again to define the next boundary line.

Step 9 Repeat Step 8 until the area is outlined and then double-click the drawing icon. A solid aqua line defines 
the inclusion area.

Step 10 Choose Save from the Command menu or click the disk icon on the toolbar to save the inclusion region.

Light door 4

Cubicle 1

Glass 1.5

Table 5-8 Obstacle color coding (continued)

Type of obstacle Color coding Loss (in dB)
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Note If you made an error in defining the inclusion area, click the area. The selected area is outlined 
by a dashed aqua line. Next, click the X icon on the toolbar. The area is removed from the floor 
map.

Step 11 To return to the floor map to enable inclusion regions on heatmaps, choose Exit from the Command 
menu.

Step 12 At the floor map, click the Layers drop-down list.

Step 13 Select the Location Regions check box if it is not already selected. If you want it to apply to all floor 
maps, click Save settings. Close the Layers configuration pane. 

Step 14 To resynchronize the WCS and location databases, click Services > Synchronize Services.

Step 15 At the Synchronize page, select Network Designs from the Synchronize drop-down list and then click 
Synchronize.

Check the Sync. Status column to ensure that the synchronization is successful (two green arrows).

Note Newly defined inclusion and exclusion regions appear on heatmaps only after the mobility 
services engine recalculates location. 

Defining an Exclusion Region on a Floor

To further refine location calculations on a floor, you can define areas that are excluded (exclusion areas) 
in the calculations. For example, you might want to exclude areas such as an atrium or stairwell within 
a building. As a rule, exclusion areas are generally defined within the borders of an inclusion area.

To define an exclusion area, follow these steps:

Step 1 Choose Monitor > Maps. 

Step 2 Click the name of the appropriate floor area.

Step 3 From the Select a command drop-down list, choose Map Editor.

Step 4 Click Go.

Step 5 At the map, click the purple box on the toolbar.

Step 6 Click OK in the message box that appears. A drawing icon appears to outline the exclusion area.

Step 7 To begin defining the exclusion area, move the drawing icon to the starting point on the map and click 
once. 

Step 8 Move the drawing icon along the boundary of the area you want to exclude and click once to start a 
boundary line; click again to end the boundary line.

Step 9 Repeat Step 8 until the area is outlined and then double-click the drawing icon. The defined exclusion 
area is shaded in purple. when the area is completely defined. The excluded area is shaded in purple.

Step 10 To define additional exclusion regions, repeat Step 5 to Step 9. 

Step 11 When all exclusion areas are defined, choose Save from the Command menu or the disk icon on the 
toolbar to save the exclusion region.
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Note To delete an exclusion area, click the area to be deleted. The selected area is outlined by a dashed 
purple line. Next, click the X icon on the toolbar. The area is removed from the floor map.

Step 12 To return to the floor map to enable exclusion regions on heatmaps, choose Exit from the Command 
menu.

Step 13 At the floor map, click the Layers drop-down list.

Step 14 Select the Location Regions check box if it is not already selected and then click Save settings, close 
the Layers configuration pane when complete.

Step 15 To resynchronize the WCS and location databases, click Services > Synchronize Services.

Step 16 At the Synchronize page, select Network Designs from the Synchronize drop-down list and then click 
Synchronize.

Check the Sync. Status column to ensure that the synchronization is successful (two green arrows).

Defining a Rail Line on a Floor

You can define a rail line on a floor that represents a conveyor belt. Additionally, you can define an area 
around the rail area known as the snap-width to further assist location calculations. This represents the 
area in which you expect clients to appear. Any client located within the snap-width area is plotted on 
the rail line (majority) or just outside of the snap-width area (minority).

Note Rail line configurations do not apply to tags.

The snap-width area is defined in feet or meters (user-defined) and represents the distance that is 
monitored on either side (east and west or north and south) of the rail.

To define a rail with a floor, follow these steps:

Step 1 Choose Monitor > Maps. 

Step 2 Click the name of the appropriate floor area.

Step 3 Choose Map Editor from the Select a command drop-down list.

Step 4 Click Go.

Step 5 At the map, click the rail icon (to the right of the purple exclusion icon) on the toolbar.

Step 6 In the message pane that appears, enter a snap-width (feet or meters) for the rail and then click OK. A 
drawing icon appears.

Note The snap-width is defined in feet or meters (as defined by the user) and represents the distance 
that is monitored on either side (left and right) of the rail.

Step 7 Click the drawing icon at the starting point of the rail line. Click again when you want to stop drawing 
the line or change the direction of the line.

Step 8 Click the drawing icon twice when the rail line is completely drawn on the floor map. The rail line 
appears on the map and is bordered on either side by the defined snap-width region.
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Note To delete a rail line, click the area to be deleted. The selected area is outlined by a dashed purple 
line. Next, click the X icon on the toolbar. The area is removed from the floor map.

Step 9 To return to the floor map to enable rails on heatmaps, choose Exit from the Command menu.

Step 10 At the floor map, click the Layers drop-down list.

Step 11 Select the Rails check box for if it is not already selected and then click Save settings and close the 
Layers configuration pane when complete.

Step 12 To resynchronize the WCS and mobility services engine, click Services > Synchronize Services.

Step 13 At the Synchronize page, select Network Designs from the Synchronize drop-down list and then click 
Synchronize.

Check the Sync. Status column to ensure that the synchronization is successful (two green arrows).

Inspecting Location Readiness and Quality
You can configure WCS to verify the ability of the existing access point deployment to estimate the true 
location of a client, rogue client, rogue access point, or tag within 10 meters at least 90% of the time. 
The location readiness calculation is based on the number and placement of access points.

You can also check the location quality and the ability of a given location to meet the location 
specification (10 m, 90%) based on data points gathered during a physical inspection and calibration.

Inspecting Location Readiness
The Inspect Location Readiness feature is a distance-based predictive tool that can point out problem 
areas with access point placement.

To access the Inspect Location Readiness tool, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Select the applicable floor area name to view the map.

Note If RSSI is not displayed, you can enable AP Heatmaps under the Layer menu (top-left).

Note If clients, tags, and access points are not displayed, verify that their respective check boxes are 
selected in the Layers menu. Licenses for both clients and tags must also be purchased for each 
to be tracked.

Step 3 From the Select a command drop-down list, choose Inspect Location Readiness.

Step 4 Click Go.
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A color-coded map appears showing those areas that meet (indicated by Yes) and do not meet (indicated 
by No) the ten meter, 90% location specification.

Inspecting Location Quality Using Calibration Data
After completing a calibration model based on data points generated during a physical tour of the area, 
you can inspect the location quality of the access points. 

To inspect location quality based on calibration, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Choose RF Calibration Model from the Select a command list. Click Go.

A list of calibration models appears.

Step 3 Click the appropriate calibration model.

Details on the calibration including date of last calibration, number of data points by signal type 
(802.11a, 802.11 b/g) used in the calibration, location, and coverage are displayed.

Step 4 At the same page, click the Inspect Location Quality link found under the Calibration Floors heading.

A color-coded map noting percentage of location errors appears.

Note You can modify the distance selected to see the effect on the location errors.

Inspecting VoWLAN Readiness
Voice readiness tool (the VoWLAN Readiness tool) allows you to check the RF coverage to see if it is 
sufficient for your voice needs. This tool verifies RSSI levels after access points have been installed.

To access the VoWLAN Readiness Tool (VRT), follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Select the applicable floor area name.

Step 3 From the Select a command drop-down list, choose Inspect VoWLAN Readiness.

Step 4 Select the applicable Band, AP Transmit Power, and Client parameters from the drop-down lists.

Note By default the region map displays the region map for b/g/n band for Cisco Phone based RSSI 
threshold. The new settings cannot be saved.

Step 5 Depending on the selected client, the RSSI values may not be editable.

• Cisco Phone—RSSI values are not editable.

• Custom—RSSI values are editable with the following ranges:

– Low threshold between -95dBm to -45dBm
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– High threshold between -90dBm to -40dBm

Step 6 The following color schemes indicate whether or not the area is Voice Ready:

• Green—Yes

• Yellow—Marginal

• Red—No

Note The accuracy of the Green/Yellow/Red regions depends on the RF environment and whether or 
not the floor is calibrated. If the floor is calibrated, the accuracy of the regions is enhanced.

Troubleshooting Voice RF Coverage Issues
• Floors with either calibration or no calibration data:

– Set the AP Transmit parameter to Max (the maximum downlink power settings). If the map still 
shows some yellow or red regions, more access points are required to cover the floor.

– If calibrated model shows red or yellow regions (where voice is expected to be deployed) with 
the AP Transmit parameter set to Current, increasing the power level of the access points may 
help.

Monitoring Mesh Networks Using Maps
You can access and view details for the following elements from a mesh network map in Cisco WCS:

• Mesh Link Statistics

• Mesh Access Points

• Mesh Access Point Neighbors

This section describes how information is accessed and displayed for each of these items and contains 
the following sections:

• Monitoring Mesh Link Statistics Using Maps, page 5-80

• Monitoring Mesh Access Points Using Maps, page 5-83

• Monitoring Mesh Access Point Neighbors Using Maps, page 5-85

• Monitoring Mesh Health, page 5-88

• Mesh Statistics for an Access Point, page 5-92

• Using Mesh Filters to Modify Map Display of Maps and Mesh Links, page 5-98

Monitoring Mesh Link Statistics Using Maps
You can view the SNR for a specific mesh network link, view the number of packets transmitted and 
received on that link, and initiate a link test from the Monitor > Maps display.
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To view details on a specific mesh link between two mesh access points or a mesh access point and a 
root access point, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Click the Map Name that corresponds to the outdoor area, campus, building, or floor you want to 
monitor.

Step 3 From the left sidebar menu, Click the arrow to the right of AP Mesh Info(see Figure 5-35). A Mesh Filter 
dialog box appears. 

Figure 5-35 Mesh Filter Page

Step 4 Move the cursor over the colored dot next to each mesh access point child to view details on the link 
between it and its parent. Table 5-9 summarizes the parameters that display.

The color of the dot also provides a quick reference point of the SNR strength.

• A green dot represents a high SNR (above 25 dB). 

• An amber dot represents an acceptable SNR (20-25 dB).

• A red dot represents a low SNR (below 20 dB). 

• A black dot indicates a root access point.

The Bridging Link information appears.
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Step 5 Click either Link Test, Child to Parent or Link Test, Parent to Child. After the link test is complete, 
a results page appears. 

Note A link test runs for 30 seconds.

Note You cannot run link tests for both links (child-to-parent and parent-to-child) at the same time.

Step 6 To view a graphical representation of SNR statistics over a period of time, click the arrow on the link. A 
page with multiple SNR graphs appears (see Figure 5-36). 

The following graphs are displayed for the link:

• SNR Up—Plots the RSSI values of the neighbor from the perspective of the access point.

• SNR Down—Plots the RSSI values that the neighbor reports to the access point.

• Link SNR—Plots a weighed and filtered measurement based on the SNR Up value.

• The Adjusted Link Metric—Plots the value used to determine the least cost path to the root access point. 
This value is the ease to get to the rooftop access point and accounts for the number of hops. The lower 
the ease value, the less likely the path is used.

• The Unadjusted Link Metric—Plots the least cost path to get to the root access point unadjusted by the 
number of hops. The higher the value for the unadjusted link, the better the path. 

Table 5-9 Bridging Link Information 

Parameter Description

Information fetched on Date and time that information was compiled.

Link SNR Link signal-to-noise ratio (SNR).

Link Type Hierarchical link relationship.

SNR Up Signal-to-noise radio for the uplink (dB).

SNR Down Signal-to-noise radio for the downlink (dB).

PER The packet error rate for the link.

Tx Parent Packets The TX packets to a node while acting as a parent.

Rx Parent Packets The RX packets to a node while acting as a parent.

Time of Last Hello Date and time of last hello.
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Figure 5-36 Mesh SNR Graphs Page (Top)

Monitoring Mesh Access Points Using Maps
You can view the following summary information for a mesh access point from a mesh network map:

• Parent

• Number of children

• Hop count

• Role

• Group name

• Backhaul interface

• Data Rate

• Channel

Note This information is in addition to the information shown for all access points (MAC address, 
access point model, controller IP address, location, height of access point, access point up time, 
and LWAPP up time).
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Note You can also view detailed configuration and access alarm and event information from the map. 
For detailed information on the Alarms and Events displayed, see the “Alarm and Event 
Dictionary” section on page 14-1.

To view summary and detailed configuration information for a mesh access point from a mesh network 
map, follow these steps:

Step 1 In Cisco WCS, choose Monitor > Maps.

Step 2 Click the Map Name that corresponds to the outdoor area, campus, building, or floor location of the 
access point you want to monitor.

Step 3 To view summary configuration information for an access point, move the cursor over the access point 
that you want to monitor. A dialog box page with configuration information for the selected access point 
appears (see Figure 5-37).

Figure 5-37 Mesh AP Summary Dialog Box

Step 4 To view detailed configuration information for an access point, double-click the access point appearing 
on the map. The configuration details for the access point appears (see Figure 5-38).
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Note For more details on the View Mesh Neighbors link in the access point dialog box (see 
Figure 5-37), see the “Monitoring Mesh Access Point Neighbors Using Maps” section on 
page 5-85. If the access point has an IP address, a Run Ping Test link is also visible at the bottom 
of the mesh access point pane.

Figure 5-38 Mesh AP Detail Page 

Step 5 In the Access Point configuration page, follow these steps to view configuration details for the mesh 
access point.

a. Click the General tab to view the overall configuration of the mesh access point such as AP name, 
MAC address, AP Up time, associated controllers (registered and primary) operational status, and 
software version.

Note The software version for mesh access points is appended the letter m and the word mesh in 
parentheses.

b. Click the Interface tab to view configuration details for the interfaces supported on the mesh access 
point. Interface options are radio and Ethernet.

c. Click the Mesh Links tab to view parent and neighbor details (name, MAC address, packet error 
rate, and link details) for the mesh access point. You can also initiate link tests from this page.

d. Click the Mesh Statistics tab to view details on the bridging, queue, and security statistics for the 
mesh access point. For more details on mesh statistics, see the “Mesh Statistics for an Access Point” 
section on page 5-92.

Monitoring Mesh Access Point Neighbors Using Maps
To view details on neighbors of a mesh access point from a mesh network map, follow these steps:
5-85
Cisco Wireless Control System Configuration Guide

OL-21743-01



Chapter 5      Monitoring Maps
  Monitoring Mesh Networks Using Maps
Step 1 Choose Monitor > Maps.

Step 2 Click the Map Name that corresponds to the outdoor area, campus, building, or floor you want to 
monitor.

Step 3 To view detailed information on mesh links for a mesh access point, click the arrow portion of the access 
point label. The Access Points page appears.

Step 4 Click the Mesh Links tab (see Figure 5-39).

Figure 5-39 Access Points > Mesh Links Page

Note You can also view mesh link details for neighbors of a selected access point by clicking the View Mesh 
Neighbors link on the Mesh tab of the access point configuration summary page, which appears when 
you hover your mouse cursor over an access point on a map (see Figure 5-40).
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Figure 5-40 Access Point Configuration Summary Dialog Box

Note Signal-to-noise (SNR) appears on the View Mesh Neighbors page (see Figure 5-41).
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Figure 5-41 View Mesh Neighbors Dialog Box

Note In addition to listing the current and past neighbors in the page that appears, labels are added to the mesh 
access points map icons to identify the selected access point, the neighbor access point, and the child 
access point. Click the clear link of the selected access point to remove the relationship labels from the 
map.

Note The drop-down lists at the top of the mesh neighbors page indicate the resolution of the map (100%) 
displayed and how often the information displayed is updated (5 mins). You can modify these default 
values.

Monitoring Mesh Health
Mesh Health monitors the overall health of Cisco Aironet 1500 and 1520 series outdoor access points as 
well as Cisco Aironet 1130 and 1240 series indoor access points when configured as mesh access points, 
except as noted. Tracking this environmental information is particularly critical for access points that are 
deployed outdoors. The following factors are monitored:

• Temperature: Displays the internal temperature of the access point in Fahrenheit and Celsius (Cisco 
Aironet 1510 and 1520 outdoor access points only).

• Heater status: Displays the heater as on or off (Cisco Aironet 1510 and 1520 outdoor access points 
only)

• AP Up time: Displays how long the access point has been active to receive and transmit.

• LWAPP Join Taken Time: Displays how long it took to establish the LWAPP connection (excluding 
Cisco Aironet 1505 access points). 
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• LWAPP Up Time: Displays how long the LWAPP connection has been active (excluding Cisco 
Aironet 1505 access points). 

Mesh Health information is displayed in the General Properties page for mesh access points.

To view the mesh health details for a specific mesh access point, follow these steps:

Step 1 Choose Monitor > Access Points. A listing of radios belonging to access points appears (see 
Figure 5-42).

Note The radio status (not an access point status) is displayed when you choose Monitor > Access 
Points. The given status is updated frequently from traps and wireless status polling and takes 
several minutes to reflect actual radio status. The overall status of an access point can be found 
by viewing the access point on a map.

Note You can also use the New Search button to display the mesh access point summary shown 
Figure 5-42 . With the New Search option, you can further define the criteria of the access points 
that display. Search criteria include AP Type, AP Mode, Radio Type, and 802.11n Support. 

Figure 5-42 Monitor > Access Points

Step 2 Click the AP Name link to display details for that mesh access point. The General tab for that mesh 
access point appears (see Figure 5-43).

Note You can also access the General tab for a mesh access point from a Cisco WCS map page. To 
display the page, double-click the mesh access point label. A tabbed page appears and displays 
the General tab for the selected access point.
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Figure 5-43 AP Name > General Properties Tab

To add, remove, or reorder columns in the table, click the Edit View link In the Monitor > Access Points 
page. Table 5-10 displays optional access point parameters available from the Edit View page.

Table 5-10 Monitor Access Points Additional Search Results Parameters 

Column Options

AP Model Indicates the model of the access point.

AP Type Indicates the type of access point (unified or autonomous).

Antenna Azim. Angle Indicates the horizontal angle of the antenna.

Antenna Diversity Indicates if antenna diversity is enabled or disabled. Antenna 
diversity refers to the access point sampling the radio signal from 
two integrated antenna ports to choose the preferred antenna.

Antenna Elev. Angle Indicates the elevation angle of the antenna.

Antenna Gain The peak gain of the dBi of the antenna for directional antennas and 
the average gain in dBi for omni-directional antennas connected to 
the wireless network adapter. The gain is in multiples of 0.5 dBm. 
An integer value 4 means 4 x 0.5 - 2 dBm of gain.

Antenna Mode Indicates the antenna mode such as omni, directional, or 
non-applicable.

Antenna Name Indicates the antenna name or type.

Antenna Type Indicates whether the antenna is internal or external.
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Audit Status Indicates one of the following audit statuses:

• Mismatch—Config differences were found between WCS and 
controller during the last audit.

• Identical—No config differences were found during the last 
audit.

• Not Available—Audit status is unavailable.

Base Radio MAC Indicates the MAC address of a radio.

Bridge Group Name Indicates the name of the bridge group used to group the access 
points, if applicable.

CDP Neighbors Indicates all directly connected Cisco devices.

Channel Control Indicates whether the channel control is automatic or custom.

Channel Number Indicates the channel on which the Cisco radio is broadcasting.

Controller Port Indicates the number of controller ports.

Earth Location

Indicates whether a Google Earth location is assigned.

Location The physical location of the access point.

Node Hops Indicates the number of hops between access points.

OfficeExtend AP Specifies if OfficeExtend AP is enabled or disabled. If it is disabled, 
the access point is remotely deployed, which increases the security 
risk. 

POE Status Indicates the Power-over-Ethernet status of the access point. The 
possible values include:

• Low—The access point draws low power from the Ethernet.

• Lower than 15.4 volts—The access point draws lower than 15.4 
volts from the Ethernet.

• Lower than 16.8 volts—The access point draws lower than 16.8 
volts from the Ethernet.

• Normal—The power is high enough for the operation of the 
access point.

• Not Applicable—The power source is not from the Ethernet.

Primary Controller Indicates the name of the primary controller for this access point.

Reg. Domain Supported Indicates whether or not the regulatory domain is supported.

Serial Number Indicates the serial number of an access point.

Slot Indicates the slot number.

Tx Power Control Indicates whether the transmission power control is automatic or 
custom.

Tx Power Level Indicates the transmission power level.

Up Time Indicates how long the access point has been up in days, hours, 
minutes, and seconds.

Table 5-10 Monitor Access Points Additional Search Results Parameters  (continued)

Column Options
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Mesh Statistics for an Access Point
Mesh Statistics are reported when a child mesh access point authenticates or associates with a parent 
mesh access point.

Security entries are removed and no longer displayed when the child mesh access point disassociates 
from the controller.

The following mesh security statistics are displayed for mesh access points:

• Bridging

• Queue

• Security

To view the mesh statistics for a specific mesh access point, follow these steps:

Step 1 Choose Monitor > Access Points. A listing of radios belonging to access points appears (see 
Figure 5-42).

Note The radio status (not an access point status) is displayed when you choose Monitor > Access 
Points. The given status is updated frequently from traps and wireless status polling and takes 
several minutes to reflect actual radio status. The overall status of an access point can be found 
by viewing the access point on a map.

Note You can also use the New Search button to display the access point summary. With the New 
Search option, you can further define the criteria of the access points that display. Search criteria 
include AP Name, IP address, MAC address, Controller IP or Name, Radio type, and Outdoor 
area. 

Step 2 Click the AP Name link of the target mesh access point.

The General Properties tab appears for the selected access point.

Step 3 Click the Mesh Statistics tab (see Figure 5-44). A bridging tab appears.

WLAN Override Names Indicates the WLAN override profile names.

WLAN Override Indicates whether WLAN Override is enabled or disabled. Each 
access point is limited to sixteen WLAN profiles. Each access point 
broadcasts all WLAN profiles unless the WLAN override feature is 
enabled. The WLAN override feature allows you to disable any of 
the 16 WLAN profiles per access point.

Table 5-10 Monitor Access Points Additional Search Results Parameters  (continued)

Column Options
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Note The Mesh Statistics tab and its subordinate tabs (Bridging, Queue and Security) only appear for 
mesh access points. The Mesh Link Alarms and Mesh Link Events links are accessible from each 
of the three tabs.

Note You can also access the Mesh Securities page for a mesh access point from a Cisco WCS map. 
To display the page, double-click the mesh access point label.

Figure 5-44 Monitor > Access Points > AP Name > Mesh Statistics

Summaries of the Bridging, Queue and Security Statistics and their definitions are provided in 
Table 5-11, Table 5-12 and Table 5-13 respectively.

Table 5-11 Bridging Mesh Statistics

Parameter Description

Role The role of the mesh access point. Options are 
mesh access point (MAP) and root access point 
(RAP).

Bridge Group Name The name of the bridge group to which the MAP 
or RAP is a member. Assigning membership in a 
bridge group name is recommended. If one is not 
assigned, a MAP is by default assigned to a 
default bridge group name.

Backhaul Interface The radio backhaul for the mesh access point. 

Routing State The state of parent selection. Values that display 
are seek, scan, and maint. maint appears when 
parent selection is complete.
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Malformed Neighbor Packets The number of malformed packets received from 
the neighbor. Examples of malformed packets 
include malicious floods of traffic such as 
malformed or short DNS packets and malformed 
DNS replies.

Poor Neighbor SNR The number of times the signal-to-noise ratio falls 
below 12 dB on the backhaul link.

Excluded Packets The number of packets received from excluded 
neighbor mesh access points.

Insufficient Memory The number of insufficient memory conditions.

RX Neighbor Requests The number of broadcast and unicast requests 
received from the neighbor mesh access points.

RX Neighbor Responses The number of responses received from the 
neighbor mesh access points.

TX Neighbor Requests The number of unicast and broadcast requests sent 
to the neighbor mesh access points.

TX Neighbor Responses The number of responses sent to the neighbor mesh
access points.

Parent Changes The number of times a mesh access point (child) 
moves to another parent.

Neighbor Timeouts The number of neighbor timeouts.

Node Hops The number of hops between the MAP and the 
RAP. Click the value link to display a pane which 
enables you to configure details of what is 
reported, how often the node hop value is 
updated, and view a graphical representation of 
the report.

Table 5-11 Bridging Mesh Statistics (continued)

Parameter Description

Table 5-12 Queue Mesh Statistics

Parameter Description

Silver Queue The average and peak number of packets waiting 
in the silver (best effort) queue during the defined 
statistics time interval. Packets dropped and 
queue size is also summarized.

Gold Queue The average and peak number of packets waiting 
in the gold (video) queue during the defined 
statistics time interval. Packets dropped and 
queue size is also summarized.

Platinum Queue The average and peak number of packets waiting 
in the platinum (voice) queue during the defined 
statistics time interval. Packets dropped and 
queue size is also summarized.
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Bronze Queue The average and peak number of packets waiting 
in the bronze (background) queue during the 
defined statistics time interval. Packets dropped 
and queue size is also summarized.

Management Queue The average and peak number of packets waiting 
in the management queue during the defined 
statistics time interval. Packets dropped and 
queue size is also summarized.

Table 5-12 Queue Mesh Statistics (continued)

Parameter Description

Table 5-13 Security Mesh Statistics

Parameter Description

Packets Transmitted Summarizes the total number of packets 
transmitted during security negotiations by the 
selected mesh access point.

Packets Received Summarizes the total number of packets received 
during security negotiations by the selected mesh 
access point.

Association Request Failures Summarizes the total number of association 
request failures that occur between the selected 
mesh access point and its parent.

Association Request Timeouts Summarizes the total number of association 
request time outs that occur between the selected 
mesh access point and its parent.

Association Request Success Summaries the total number of successful 
association requests that occur between the 
selected mesh access point and its parent.

Authentication Request Failures Summarizes the total number of failed 
authentication requests that occur between the 
selected mesh access point and its parent.

Authentication Request Timeouts Summarizes the total number of authentication 
request timeouts that occur between the selected 
mesh access point and its parent.

Authentication Request Success Summarizes the total number of successful 
authentication requests between the selected mesh 
access point and its parent mesh node.

Reassociation Request Failures Summarizes the total number of failed 
reassociation requests between the selected mesh 
access point and its parent.

Reassociation Request Timeouts Summarizes the total number of reassociation 
request timeouts between the selected mesh 
access point and its parent.
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Viewing the Mesh Network Hierarchy
You can view the parent-child relationship of mesh access points within a mesh network in an easily 
navigable display. You can also filter which access points display on the Map view, by selecting only 
access points of interest.

To view the mesh network hierarchy for a selected network, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Select the map you want to display.

Step 3 Select the AP Mesh Info check box in the left sidebar menu if it is not already selected.

Reassociation Request Success Summarizes the total number of successful 
reassociation requests between the selected mesh 
access point and its parent.

Reauthentication Request Failures Summarizes the total number of failed 
reauthentication requests between the selected 
mesh access point and its parent.

Reauthentication Request Timeouts Summarizes the total number of reauthentication 
request timeouts that occurred between the 
selected mesh access point and its parent.

Reauthentication Request Success Summarizes the total number of successful 
reauthentication requests that occurred between 
the selected mesh access point and its parent.

Invalid Association Request Summarizes the total number of invalid 
association requests received by the parent mesh 
access point from the selected child mesh access 
point. This state might occur when the selected 
child is a valid neighbor but is not in a state that 
allows association.

Unknown Association Requests Summarizes the total number of unknown 
association requests received by the parent mesh 
access point from its child. The unknown 
association requests often occur when a child is an 
unknown neighbor mesh access point.

Invalid Reassociation Request Summarizes the total number of invalid 
reassociation requests received by the parent 
mesh access point from a child. This might 
happen when a child is a valid neighbor but is not 
in a proper state for reassociation.

Unknown Reassociation Request Summarizes the total number of unknown 
reassociation requests received by the parent 
mesh access point from a child. This might 
happen when a child mesh access point is an 
unknown neighbor.

Table 5-13 Security Mesh Statistics (continued)

Parameter Description
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Note The AP Mesh Info check box is only selectable if mesh access points are present on the map. It 
must be selected to view the mesh hierarchy. 

Step 4 Click the AP Mesh Info arrow to display the mesh parent-child hierarchy (see Figure 5-45).

Figure 5-45 Mesh Parent-Child Hierarchical View

Step 5 Click the plus (+) sign next to a mesh access point to display its children.

All subordinate mesh access points are displayed when a negative (-) sign appears next to the parent 
mesh access point entry. For example, in Figure 5-45, the access point, indoor-mesh-45-rap2, has only 
one child, indoor-mesh-44-map2.

Step 6 Move the cursor over the colored dot next to each mesh access point child to view details on the link 
between it and its parent. Table 5-14 summarizes the parameters that appears.

The color of the dot also provides a quick reference point of the SNR strength.

• A green dot represents a high SNR (above 25 dB). 

• An amber dot represents an acceptable SNR (20-25 dB).

• A red dot represents a low SNR (below 20 dB). 

• A black dot indicates a root access point.
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Using Mesh Filters to Modify Map Display of Maps and Mesh Links
In the mesh hierarchical page, you can also define mesh filters to determine which mesh access points 
display on the map based on hop values as well as what labels display for mesh links.

Mesh access points are filtered by the number of hops between them and their root access point.

To use mesh filtering, follow these steps:

Step 1 To modify what label and color displays for a mesh link, follow these steps:

a. In the Mesh Parent-Child Hierarchical View, select an option from the Link Label drop-down list. 
The options are None, Link SNR, and Packet Error Rate.

b. In the Mesh Parent-Child Hierarchical View, select an option from the Link Color drop-down list to 
define which parameter (Link SNR or Packet Error Rate) determines the color of the mesh link on 
the map.

Note The color of the link provides a quick reference point of the SNR strength or Packet Error Rate. 
Table 5-15 defines the different link colors.

Table 5-14 Bridging Link Information 

Parameter Description

Information fetched on Date and time that information was compiled.

Link SNR Link signal-to-noise ratio (SNR).

Link Type Hierarchical link relationship.

SNR Up Signal-to-noise radio for the uplink (dB).

SNR Down Signal-to-noise radio for the downlink (dB).

PER The packet error rate for the link.

Tx Parent Packets The TX packets to a node while acting as a parent.

Rx Parent Packets The RX packets to a node while acting as a parent.

Time of Last Hello Date and time of last hello.

Table 5-15 Definition for SNR and Packet Error Rate Link Color

Link Color Link SNR Packet Error Rate (PER)

Green Represents a SNR above 25 dB (high 
value)

Represents a PER of one percent (1%) or 
lower

Amber Represents a SNR between 20 and 25 dB 
(acceptable value)

Represents a PER that is less than ten 
percent (10%) and greater than one 
percent (1%)

Red Represents a SNR below 20 dB (low 
value)

Represents a PER that is greater than ten 
percent (10%)
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Note The Link label and color settings are reflected on the map immediately (see Figure 5-46). You 
can display both SNR and PER values simultaneously.

Step 2 To modify which mesh access points display based on the number of hops between them and their 
parents, choose the appropriate option from the Quick selection drop-down list (see Table 5-16 for the 
list of available options):

c. Click Update Map View to refresh the screen and redisplay the map view with the selected options.

Note Map view information is retrieved from the WCS database and is updated every 15 minutes.

Note You can also select or unselect the check boxes of access points in the mesh hierarchical 
view to modify which mesh access points are displayed. For a child access point to be 
visible, the parent access point to root access point must be selected.

Note If you want to have the MAC address appear with the client logo in the Monitor > Maps page, 
follow these steps:
a) Go to the Maps Tree View.
b) Click the > beside Clients.
c) Unselect the Small Icons check box.

Table 5-16 Quick Selection Drop-down list Options 

Parameter Description

Select only Root APs Choose this setting if you want the map view to 
display root access points only.

Select up to 1st hops Choose this setting if you want the map view to 
display 1st hops only.

Select up to 2nd hops Choose this setting if you want the map view to 
display 2nd hops only.

Select up to 3rd hops Choose this setting if you want the map view to 
display 3rd hops only.

Select up to 4th hops Choose this setting if you want the map view to 
display 4th hops only.

Select All Select this setting if you want the map view to 
display all access points.
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Figure 5-46 Mesh Filter and Hope Count Configuration Page

Monitoring Tags Using Maps
On a WCS map, you can review the name of the access point that generated the signal for a tagged asset, 
its strength of signal and when the location information was last updated for the asset. This information 
is display by simply passing the cursor over the asset tag icon on the map.

To enable tag location status on a map, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Choose Building > Floor for the applicable mobility services engine and tag. 

Step 3 Select the 802.11 Tags check box in the Floor Settings pane (left), if not already selected.

Note Do not click Save Settings unless you want to save changes made to the Floor Settings across 
all maps.

Step 4 Move the cursor over a tag icon (yellow tag) and a summary of its configuration appears in a dialog box.

Step 5 Click the tag icon to see tag details.
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Using Planning Mode
You can calculate the recommended number and location of access points based on whether data and/or 
voice traffic and/or location are active.

Note Based on the throughput specified for each protocol (802.11a or 802.11 b/g), planning mode calculates 
the total number of access points required that would provide optimum coverage in your network.

Accessing Planning Mode
To access the Planning Mode feature, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Select the desired campus or building from the Name list.

Step 3 Click the desired floor area in the Building. 

Step 4 From the Select a command drop-down list, choose Planning Mode.

Step 5 Click Go.

Note Planning mode does not use AP type or Antenna pattern information for calculating the number of access 
points required. The calculation is based on the access point coverage area or the number of users per 
access point.

Planning Mode options:

• Add APs—Enables you to add access points on a map. See the “Adding Access Points to a Floor 
Area” section on page 5-48 for details.

• Delete APs—Deletes the selected access points.

• Map Editor—Opens the Map Editor window. See the “Using Map Editors” section on page 5-71 for 
more details.

• Synchronize with Deployment—Synchronizes your planning mode access points with the current 
deployment scenario.

• Generate Proposal—View a planning summary of the current access points deployment.

• Planned AP Association Tool—Allows you to perform add, delete or import an AP Association from 
an excel or CSV file. Once an access point is defined, it can be associated to a base radio MAC 
address using the Planned AP Association Tool. If the AP is not discovered they get pushed into a 
standby bucket and get associated when discovered. 

Note AP association is subjected to a limitation that AP should not belong to any floor or outdoor area.  
If the AP is already assigned to a floor or outdoor area, then the standby bucket will hold the AP 
and when removed from the floor or outdoor, get positioned to the given floor. One Mac address 
cannot be put into bucket for multiple floor or outdoor areas.
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Note The map synchronizations works only if the AP is associated to a base radio MAC address and 
not to its ethernet MAC address. 

Using Planning Mode to Calculate Access Point Requirements
The WCS planning mode enables you to calculate the number of access points required to cover an area 
by placing fictitious access points on a map and allowing you to view the coverage area. Based on the 
throughput specified for each protocol (802.11a/n or 802.11b/g/n), planning mode calculates the total 
number of access points required to provide optimum coverage in your network. You can calculate the 
recommended number and location of access points based on the following criteria:

• traffic type active on the network: data or voice traffic or both

• location accuracy requirements

• number of active users

• number of users per square footage 

To calculate the recommended number and placement of access points for a given deployment, follow 
these steps:

Step 1 Choose Monitor > Maps.

The map pane appears (see Figure 5-47).

Figure 5-47 Monitor > Maps Page

Step 2 Click the appropriate location link from the list that appears.

A color-coded map appears showing placement of all installed elements (access points, clients, tags) and 
their relative signal strength (see Figure 5-48).
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Figure 5-48 Selected Floor Area Showing Current Access Point Assignments 

Step 3 Choose Planning Mode from the Select a command drop-down list (top-right) and click Go. A blank 
floor map appears. 

Step 4 Click Add APs. 

Step 5 In the page that appears, drag the dashed-line rectangle over the map location for which you want to 
calculate the recommended access points (see Figure 5-49).

Note Adjust the size or placement of the rectangle by selecting the edge of the rectangle and holding 
down the Ctrl key. Move the mouse as necessary to outline the targeted location.
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Figure 5-49 Add APs Page

Step 6 Select Automatic from the Add APs drop-down list. 

Step 7 Select the AP Type and the appropriate antenna and protocol for that access point.

Step 8 Select the target throughput for the access point.

Step 9 Select the box(es) next to the service(s) that will be used on the floor. Options are Data/Coverage 
(default), Voice, Location, and Location with Monitor Mode APs. (see Table 5-17).

Note You must select at least one service or an error occurs.

Note If you select the Advanced Options box, two additional access point planning options appear: 
Demand and Override Coverage per AP. Additionally, a Safety Margin parameter appears for the 
Data/Coverage and Voice safety margin options.

Table 5-17 Definition of Services Options 

Service Options Description

Data/Coverage Select if data traffic is transmitted on the wireless LAN. The 
following densities are used depending on the band and data rates:

Band Path Loss 
Model (dBm)

Date Rate 
(Mb/s)

Area (Sq. ft.)
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802.11a –3.3 10-12 6000

802.11a –3.3 15-18 4500

802.11a –3.5 10-12 5000

802.11a –3.5 15-18 3250

802.11bg –3.3 5 6500

802.11bg –3.3 6 4500

802.11bg –3.5 5 5500

802.11bg –3.5 6 3500

If you select the Advanced Options (check box), you can select the 
desired safety margin (aggressive, safe, or very safe) of the signal 
strength threshold for data.

• Aggressive = Minimum (–3 dBm)

• Safe = Medium (0 dBm)

• Very Safe = Maximum (+3 dBm)

Voice Select if voice traffic is transmitted on the wireless LAN.

If you select the Advanced Options (check box), you can select the 
desired safety margin (aggressive, safe, very safe or 7920-enabled) 
of the signal strength threshold for voice.

• Aggressive = Minimum [–78 dBm (802.11a/b/g)]

• Safe = Medium [–75 dBm (802.11a/b/g)]

• Very Safe = Maximum [(–72 dBm (802.11a/b/g)]

• 7920_enabled = [(–72 dBm (802.11a); –67 dBm (802.11b/g)]

Location Select to ensure that the recommended access point calculation 
provides the true location of an element within 10 meters at least 
90% of the time. 

To meet the criteria, access points are collocated within 70 feet of 
each other in a hexagonal pattern employing staggered and 
perimeter placement.

Note Each service option includes all services that are listed 
above it. For example, if you select the Location check box, 
the calculation considers data/coverage, voice, and location 
in determining the optimum number of access points 
required.

Table 5-17 Definition of Services Options  (continued)

Service Options Description
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Table 5-18 Definition of Advanced Services 

Service Options Description

Data/Coverage Select if data traffic is transmitted on the wireless LAN. The 
following densities are used depending on the band and data rates:

Band Path Loss 
Model (dBm)

Date Rate 
(Mb/s)

Area (Sq. ft.)

802.11a –3.3 10-12 6000

802.11a –3.3 15-18 4500

802.11a –3.5 10-12 5000

802.11a –3.5 15-18 3250

802.11bg –3.3 5 6500

802.11bg –3.3 6 4500

802.11bg –3.5 5 5500

802.11bg –3.5 6 3500

If you select the Advanced Options (check box), you can select the 
desired safety margin (aggressive, safe, or very safe) of the signal 
strength threshold for data.

• Aggressive = Minimum (–3 dBm)

• Safe = Medium (0 dBm)

• Very Safe = Maximum (+3 dBm)

Voice Select if voice traffic is transmitted on the wireless LAN.

If you select the Advanced Options (check box), you can select the 
desired safety margin (aggressive, safe, very safe or 7920-enabled) 
of the signal strength threshold for voice.

• Aggressive = Minimum [–78 dBm (802.11a/b/g)]

• Safe = Medium [–75 dBm (802.11a/b/g)]

• Very Safe = Maximum [(–72 dBm (802.11a/b/g)]

7920_enabled = [(–72 dBm (802.11a); –67 dBm (802.11b/g)]

Location Select to ensure that the recommended access point calculation 
provides the true location of an element within 10 meters at least 
90% of the time. 

To meet the criteria, access points are collocated within 70 feet of 
each other in a hexagonal pattern employing staggered and 
perimeter placement.

Note Each service option includes all services that are listed 
above it. For example, if you select the Location check box, 
the calculation considers data/coverage, voice, and location 
in determining the optimum number of access points 
required.

Demand Select if you want to use the total number of users or user ratio per 
access point as a basis for the access point calculation.
5-106
Cisco Wireless Control System Configuration Guide

OL-21743-01



Chapter 5      Monitoring Maps
  Using Planning Mode
Step 10 Click Calculate.

The recommended number of access points given the selected services appears (see Figure 5-50).

Figure 5-50 Recommended Number of Access Points Given Selected Services and Parameters

Note Recommended calculations assume the need for consistently strong signals unless adjusted 
downward by the safety margin advanced option. In some cases, the recommended number of 
access points is higher than what is required.

Override Coverage per AP Select if you want to specify square foot coverage as the basis for 
access point coverage.

Safety Margin Select option to qualify relative signal strength requirements for 
data and voice service in the access point calculation. The available 
options are: Aggressive, Safe, Very Safe, and 7920-enabled (voice 
only). Select Aggressive to require minimal signal strength require-
ments in the calculation and Very Safe to request the highest signal 
strength.

Table 5-18 Definition of Advanced Services  (continued)

Service Options Description
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Note Walls are not used or accounted for in planning mode calculations.

Step 11 Click Apply to generate a map that shows proposed deployment of the recommended access points in 
the selected area based on the selected services and parameters (see Figure 5-51).

Figure 5-51 Recommended Access Point Deployment Given Selected Services and Parameters

Step 12 Choose Generate Proposal to display a textual and graphical report of the recommended access point 
number and deployment based on the given input.

Refresh Options
To prepare for monitoring your wireless LANs, become familiar with the various refresh options for a 
map. 

• Load—The Load option in the left sidebar menu refreshes map data from the WCS database on 
demand (see callout 1 in Figure 5-52). 

• Auto Refresh—The Auto Refresh option (see callout 2 in Figure 5-52) provides an interval 
drop-down list to set how often to refresh the map data from the database.

• Refresh from network—By clicking the Refresh from network icon to the right of the Auto Refresh 
drop-down list (see callout 2 in Figure 5-52), you can refresh the map status and statistics directly 
from the controller through an SNMP fetch rather than polled data from the WCS database that is 
five to fifteen minutes older.
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Note If you have monitor mode access points on the floor plan, you have a choice between IDS 
or coverage heatmap types. A coverage heatmap excludes monitor mode access points, and 
an IDS heatmap includes them.

• Refresh browser—Above the map next to the Logout and Print option is another refresh option (see 
callout 3 in Figure 5-52). Clicking this refreshes the complete page, or the map and its status and 
statistics if you are on a map page.

Figure 5-52 Refresh Options

Creating a Network Design
After access points have been installed and have joined a controller, and WCS has been configured to 
manage the controllers, set up a network design. A network design is a representation within WCS of the 
physical placement of access points throughout facilities. A hierarchy of a single campus, the buildings 
that comprise that campus, and the floors of each building constitute a single network design. These 
steps assume that the location appliance is set to poll the controllers in that network, as well as be 
configured to synchronize with that specific network design, to track devices in that environment. The 
concept and steps to perform synchronization between WCS and the mobility service engine are 
explained in the Cisco 3350 Mobility Services Engine Configuration Guide. 

Designing a Network
To design a network, follow these steps:

Step 1 Open the WCS web interface and log in.

Note To create or edit a network design, you must log into WCS and have SuperUser, Admin, or 
ConfigManager access privileges.

Step 2 Choose Monitor > Maps.
5-109
Cisco Wireless Control System Configuration Guide

OL-21743-01



Chapter 5      Monitoring Maps
  Creating a Network Design
Step 3 From the drop-down list on the right-hand side, choose either New Campus or New Building, 
depending on the size of the network design and the organization of maps. If you chose New Campus, 
continue to Step 4. To create a building without a campus, skip to Step 14.

Step 4 Click Go.

Step 5 Enter a name for the campus network design, a contact name, and the file path to the campus image file. 
.bmps and .jpgs are importable. 

Note You can use the Browse button to navigate to the location.

Step 6 Click Next.

Step 7 Select the Maintain Aspect Ratio check box. Enabling this check box causes the horizontal span of the 
campus to be 5000 feet and adjusts the vertical span according to the aspect ratio of the image file. 
Adjusting either the horizontal or vertical span changes the other field in accordance with the image 
ratio. 

You should unselect the Maintain Aspect Ratio check box if you want to override this automatic 
adjustment. You could then adjust both span values to match the real world campus dimensions.

Step 8 Click OK.

Step 9 In the Monitor > Maps page, click the hyperlink associated with the above-made campus map. A window 
showing the new campus image is displayed.

Step 10 From the drop-down list on the upper right of the window, select New Building, and click Go.

Step 11 Enter the name of the building, the contact person, the number of floors and basements in the building, 
and the dimensions. Click OK.

Step 12 Indicate which building on the campus map is the correct building by clicking the blue box in the upper 
left of the campus image and dragging it to the intended location (see Figure 5-53). To resize the blue 
box, hold down the Ctrl key and click and drag to adjust its horizontal size. You can also enter 
dimensions of the building by entering numerical values in the Horizontal Span and Vertical Span fields 
and click Place. After resizing, reposition the blue box if necessary by clicking on it and dragging it to 
the desired location. Click Save.

Figure 5-53 Repositioning Building Highlighted in Blue
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Step 13 WCS is then returned to the campus image with the newly created building highlighted in a green box. 
Click the green box (see Figure 5-54).

Figure 5-54 Newly Created Building Highlighted in Green

Step 14 To create a building without a campus, choose New Building, and click Go.

Step 15 Enter the name of the building, contact information, number of floors and basements, and dimension 
information. Click Save. WCS is returned to the Monitor > Maps page.

Step 16 Click the hyperlink associated with the newly created building.
5-111
Cisco Wireless Control System Configuration Guide

OL-21743-01



Chapter 5      Monitoring Maps
  Creating a Network Design
Step 17 On the Monitor > Maps > [Campus Name] > [Building Name] window, go to the drop-down list and 
choose New Floor Area. Click Go.

Step 18 Enter a name for the floor, a contact, a floor number, floor type, and height at which the access points 
are installed and the path of the floor image. Click Next.

Note The Floor Type (RF Model) field specifies the type of environment on that specific floor. This 
RF Model indicates the amount of RF signal attenuation likely to be present on that floor. If the 
available models do not properly characterize a floor's makeup, details on how to create RF 
models specific to a floor's attenuation characteristics are available in the Cisco 3350 Mobility 
Services Engine Configuration Guide.

Step 19 If the floor area is a different dimension than the building, adjust floor dimensions by either making 
numerical changes to the text fields under the Dimensions heading or by holding the Ctrl key and 
clicking and dragging the blue box around the floor image. If the floor's location is offset from the upper 
left corner of the building, change the placement of the floor within the building by either clicking and 
dragging the blue box to the desired location or by altering the numerical values under the Coordinates 
of top left corner heading (see Figure 5-55). After making changes to any numerical values, click Place. 

Figure 5-55 Repositioning Using Numerical Value Fields 
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Step 20 Adjust the floor’s characteristics with the WCS map editor by selecting the Launch Map Editor after 
floor creation check box. For an explanation of the map editor feature, see the “Using Map Editors” 
section on page 5-71. 

Step 21 In the new floor’s image page (Monitor > Maps > [CampusName] > [BuildingName] > [FloorName]), 
choose Add Access Points from the drop-down list. Click Go.

Step 22 All access points that are connected to controllers are displayed. Even controllers that WCS is 
configured to manage but which have not yet been added to another floor map are displayed. Select the 
access points to be placed on the specific floor map by selecting the check boxes to the left of the access 
point entries. Select the check box to the left of the Name column to select all access points. Click OK.

Step 23 Each access point you have chosen to add to the floor map is represented by a gray circle (differentiated 
by access point name or MAC address) and is lined up in the upper-left part of the floor map. Drag each 
access point to the appropriate location. (Access points turn blue when you click them to relocate.) The 
small black arrow at the side of each access point represents Side A of each access point, and each access 
point’s arrow must correspond with the direction in which the access points were installed. (Side A is 
clearly noted on each 1000 series access point and has no relevance to the 802.11a/n radio.) 
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Step 24 To adjust the directional arrow, choose the appropriate orientation in the Antenna Angle drop-down list. 
Click Save when you are finished placing and adjusting each access point’s direction. 

Note Access point placement and direction must directly reflect the actual access point deployment 
or the system cannot pinpoint the device location.

Step 25 Repeat the above processes to create campuses, buildings, and floors until each device location is 
properly detailed in a network design.

Importing or Exporting WLSE Map Data
When you convert an access point from autonomous to CAPWAP and from WLSE to WCS, one of the 
conversion steps is to manually re-enter the access point information into WCS. This can be a 
time-consuming step. To speed up the process, you can export the information about access points from 
WLSE and import it into WCS.

Note WCS expects a .tar file and checks for a .tar extension before importing the file. If the file you are trying 
to import is not a .tar file, WCS displays an error message and prompts you to import a different file.

To map properties and import a tar file containing WLSE data using the WCS web interface, follow these 
steps. For more information on the WLSE data export functionality (WLSE version 2.15), see
http://<WLSE_IP_ADDRESS>:1741/debug/export/exportSite.jsp.

Step 1 Choose Monitor > Maps.

Step 2 Choose Properties from the Select a command drop-down list, and click Go.

Step 3 In the Export/Import AP/LS/SP Placement section, click Browse to select the file to import.

Step 4 Find and select the .tar file to import, and click Open.

WCS displays the name of the file in the Import From field.

Step 5 Click Import.

WCS uploads the file and temporarily saves it into a local directory while it is being processed. If the 
file contains data that cannot be processed, WCS prompts you to correct the problem and retry. After the 
file has been loaded, WCS displays a report of what will be added to WCS. The report also specifies 
what cannot be added and why.

If some of the data to be imported already exists, WCS either uses the existing data in the case of 
campuses or overwrites the existing data using the imported data in the cases of buildings and floors.

If there are duplicate names between a WLSE site and building combination and a WCS campus (or 
top-level building) and building combination, WCS displays a message in the Pre Execute Import Report 
indicating that it will delete the existing building.

Step 6 Click Import to import the WLSE data.

WCS displays a report indicating what was imported.
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Note Because a WLSE file has no floor number information, the structure of the floor index 
calculation after WLSE is imported into WCS is in descending order. You can click the floor 
image to go directly to the appropriate floor screen.

Step 7 Choose Monitor > Maps to verify the imported data.

Device Details

Access Point Details
Hold your mouse cursor over an access point icon to view access point details (Figure 5-56). Click the 
appropriate tab to view access point and radio information.

Note Monitor mode access points are shown with gray labels to distinguish them from other access points.

Figure 5-56 Access Point Details Page

The AP Info tab includes the following access point information:

• MAC address

• Access point model

• Controller

• Location

• Access point height

• Access point uptime

• LWAPP uptime

Note From the AP Info tab, you can run a ping test by clicking the Run Ping Test link.
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The 802.11 tabs (Figure 5-57) includes the following radio information:

• Channel number

• Extension channel

• Channel width

• Transmit power level

• Client count

Note The number of clients associated to access points may not match the total number of clients.

• Receiving and transmitting utilization percentages

• Channel utilization percentage

Note Total utilization = (Rx + Tx + Channel utilization) scaled to 100%.

• Antenna name and angle

• Elevation angle

Note From either of the 802.11 tabs, you can view Rx neighbors and radio details for this access point 
by clicking the appropriate link (View Rx Neighbors or View Radio Details).

• Dot11n Enabled

• CleanAir Status—Displays the CleanAir status of the access point, whether or not CleanAir is 
enabled on the access point.

• Average Air Quality—Displays the average air quality on this access point.

• Minimum Air Quality—Displays the minimum air quality on this access point.
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Figure 5-57 802.11 Tabs

Client Details
Hold your mouse cursor over a client icon to view client details (Figure 5-58).

Figure 5-58 Client Details Page

Client details information includes the following:

• Username

• IP address

• Asset name, group, and category

• Status

• Auth
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• SSID

• Access point name

• Protocol

• Port number

• Last location

Tag Details
Hold your mouse cursor over a tag icon to view tag details (Figure 5-59). 

Figure 5-59 Tag Details Page

Tag details includes the following:

• Asset name, group, and category

• Type

• Battery life

• Last located

Rogue Access Point Details
Hold your mouse cursor over an access point icon to view rogue access point details (Figure 5-60). 
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Figure 5-60 Rogue Access Point Details Page

Rogue access point details includes the following:

• Classification type—Friendly, malicious, or unknown.

• State

• Detecting access points

• Type

• Rogue clients

• First seen

• Last seen

• On network

• Last located

Rogue Adhoc Details
Hold your mouse cursor over an access point icon to view rogue ad hoc details. 

Rogue Client Details
Hold your mouse cursor over an access point icon to view rogue client details (Figure 5-61). 

Interferer Details
Hold your mouse cursor over an interferer icon to view its details. Interferer details includes the 
following:

• Interferer Name—The name of the interfering device.

• Affected Channels—The channel the interfering device is affecting.
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• Detected Time—The time at which the interference was detected.

• Severity—The severity index of the interfering device.

• Duty Cycle—The duty cycle (in percentage) of the interfering device.

• RSSI (dBm)—The Received Signal Strength Indicator of the interfering device.

Figure 5-61 Rogue Client Details Page

Rogue client details include:

• State

• Associated rogue access point

• Detecting access points

• First seen

• Last seen

• Last located

Floor View Navigation
The main Floor View navigation page (Figure 5-62) provides access to multiple map functions. 

Figure 5-62 Floor View Navigation Page

This navigation page includes the following functionality:
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• Zoom In/Zoom Out—Click the magnifying glass icon with the plus sign (+) to enlarge the map view. 
Click the magnifying glass icon with the minus sign (-) to decrease the size of the map view.

• Map Size—Use the map size drop-down list to manually select the map view size (ranging from 50% 
to 800%).

• Show Grid—Click to show or hide the grid that displays distance in feet on the map.

• RSSI Legend—Hold your mouse cursor over the RSSI Legend icon to display the RSSI color 
scheme (ranging from red/-35 dBm to dark blue/-90 dBm).

• Add Access Points—Click to open the Add Access Points window. See the “Adding Access Points 
to a Floor Area” section on page 5-48 for more information.

• Remove Access Points—Click to open the Remove Access Points window. Select the access points 
that you want to remove, and click OK.

• Position Access Points—Click to open the Position Access Points window. See “Placing Access 
Points” section on page 5-54 for more information.

• Add Chokepoints—Click to open the Add Chokepoints window. Refer to the Cisco Context-Aware 
Services Configuration Guide for more information.

• Add WiFi TDOA Receivers—Click to open the Add Wi-Fi TDOA Receivers window. Refer to the 
Cisco Context-Aware Services Configuration Guide for more information.

• Auto Refresh—From the drop-down list, select the length of time between each system refresh.

• Refresh from Network—Click to initiate an immediate refresh of the current data.

• Planning Mode—Click to open the Planning Mode window. See the “Using Planning Mode” section 
on page 5-101 for more information.

• Map Editor—Click to open the Map Editor. 

Full Screen—Click to increase the size of the map to full screen. Once there, click Exit Full Screen to 
return to the normal view.
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