Cisco Wireless Control System Configuration Guide

Software Release 7.0.172.0
April 2011

Americas Headquarters
Cisco Systems, Inc.
170 West Tasman Drive
San Jose, CA 95134-1706
USA
http://www.cisco.com
Tel: 408 526-4000
800 553-NETS (6387)
Fax: 408 527-0883

Text Part Number: OL-21743-02
CONTENTS

Preface viii

Audience viii

Purpose viii

Conventions viii

Related Publications 1

Obtaining Documentation and Submitting a Service Request 1

CHAPTER 1

Cisco WCS Overview 1-1

The Cisco Unified Wireless Network Solution 1-1

The WCS 1-2

WCS Versions 1-3

WCS Base 1-4

WCS Base + Location 1-4

Enabling Mobility Services and HA with WCSPLUS License 1-5

Using WCS Cisco Location Appliances 1-5

Comparison of WCS Base and WCS Location Features 1-7

Embedded Access Points 1-7

Access Point Communication Protocols 1-9

Guidelines and Restrictions for Using CAPWAP 1-9

The Controller Discovery Process 1-10

WCS Navigator 1-10

Cisco WCS Location 1-11

WCS User Interface 1-11

Menu Bar 1-11

Floor Plan Editor 1-14

Cisco Wireless LAN Controller Autodiscovery 1-14

Cisco WCS Location Calibration 1-15

Cisco 2700 Series Location Appliances 1-15

CHAPTER 2

Getting Started 2-1

Prerequisites 2-1

System Requirements 2-2

High-End Server 2-2
Tools Menu 2-30
Help Menu 2-30
Exploring Help 2-30
Sidebar Area 2-32
Command Buttons 2-32
Alarm Summary 2-33
Main Data Page 2-33
Administrative Tools 2-34
Using the Search Feature 2-34
Quick Search 2-34
Advanced Search 2-35
   Alarms 2-37
   Access Points 2-38
   Controllers 2-39
   Clients 2-40
   Chokepoints 2-41
   Events 2-42
   Interferers 2-42
   Wi-Fi TDOA Receivers 2-43
Maps 2-44
   Rogue Clients 2-44
   Shunned Clients 2-44
   Tags 2-45
   Controller Licenses 2-46
Saved Searches 2-46
Configuring the Search Results Display 2-47

CHAPTER 3
Configuring Security Solutions 3-1
Cisco Unified Wireless Network Solution Security 3-1
   Layer 1 Solutions 3-2
   Layer 2 Solutions 3-2
   Layer 3 Solutions 3-2
   Single Point of Configuration Policy Manager Solutions 3-2
Rogue Access Point Solutions 3-3
   Rogue Access Point Challenges 3-3
   Tagging and Containing Rogue Access Points 3-3
  Securing Your Network Against Rogue Access Points 3-3
Interpreting the Security Tab 3-4
   Security Index 3-5
Malicious Rogue Access Points 3-6
Adhoc Rogues 3-7
CleanAir Security 3-7
Unclassified Rogue Access Points 3-7
Friendly Rogue Access Points 3-8
Access Point Threats or Attacks 3-9
MFP Attacks 3-9
Attacks Detected 3-9
Recent Rogue AP Alarms 3-9
Recent Adhoc Rogue Alarm 3-9
Most Recent Security Alarms 3-9

Monitoring Rogue Access Points, Ad hoc Events, and Clients 3-10
  Monitoring Rogue AP Alarms 3-10
  Classifying Rogue Access Points 3-12
  Rogue Access Point Classification Types 3-13
  Viewing Rogue AP Alarm Details 3-15
  Viewing Rogue Client Details 3-17

Adhoc Rogue Alarms 3-19
  Monitoring Adhoc Rogue Alarms 3-19
  Viewing Adhoc Rogue Alarm Details 3-20

Rogue Access Point Location, Tagging, and Containment 3-21
  Detecting Access Points on a Network 3-22
  Viewing Rogue Access Points by Controller 3-23

Working with Alarms 3-24
  Monitoring Rogue Alarm Events 3-25
  Viewing Rogue AP Event Details 3-26
  Monitoring Adhoc Rogue Events 3-27
  Viewing Adhoc Rogue Event Details 3-28

Security Overview 3-28
  Security Vulnerability Assessment 3-29
  Security Index 3-29
  Top Security Issues 3-30

Switch Port Tracing 3-36
  Integrated Security Solutions 3-37

Using WCS to Convert a Cisco Unified Wireless Network Solution from Layer 3 to Layer 2 Mode 3-37
Configuring a Firewall for WCS 3-38
Access Point Authorization 3-39
Management Frame Protection (MFP) 3-39
Guidelines for Using MFP 3-41
Contents

Configuring Intrusion Detection Systems (IDS) 3-41
  Viewing IDS Sensors 3-41
Configuring IDS Signatures 3-41
  Uploading IDS Signatures 3-44
  Downloading IDS Signatures 3-45
  Enabling or Disabling IDS Signatures 3-46
Enabling Web Login 3-49
  Downloading Customized Web Authentication 3-50
  Connecting to the Guest WLAN 3-52
Certificate Signing Request (CSR) Generation 3-52

CHAPTER 4
Performing Maintenance Operations 4-1
  Information About Maintenance Operations 4-1
  Performing System Tasks 4-1
    Adding a Controller to the WCS Database 4-2
    Additional Functionality with Location Appliance 4-2
    Using WCS to Update System Software 4-3
    Downloading Vendor Device Certificates 4-4
    Downloading Vendor CA Certificates 4-5
    Using WCS to Enable Long Preambles for SpectraLink NetLink Phones 4-5
    Creating an RF Calibration Model 4-6
  Verifying the Status of WCS 4-6
    Checking the Status of WCS on Windows 4-7
    Checking the Status of WCS on Linux 4-7
  Stopping WCS 4-7
    Stopping WCS on Windows 4-7
    Stopping WCS on Linux 4-9
  Backing Up the WCS Database 4-9
    Scheduling Automatic Backups 4-9
    Performing a Manual Backup 4-10
      Backing Up the WCS Database (for Windows) 4-10
      Backing Up the WCS Database (for Linux) 4-11
  Restoring the WCS Database 4-11
    Restoring the WCS Database (for Windows) 4-12
    Restoring the WCS Database (for Linux) 4-13
    Restoring the WCS Database in a High Availability Environment 4-14
  Uninstalling WCS 4-14
    Uninstalling WCS on Windows 4-14
Configuring Maps 5-22
  Viewing a Map 5-22
  Editing a Map 5-24
  Deleting a Map 5-25
  Copying a Map 5-25
  Exporting a Map 5-26
  Importing a Map 5-27
  Editing Map Properties 5-28
  Filtering Maps 5-29
Configuring Buildings 5-29
  Adding a Building to a Campus Map 5-30
  Viewing a Building 5-34
  Editing a Building 5-35
  Deleting a Building 5-35
  Moving a Building 5-36
Configuring a Campus 5-36
  Adding a Campus Map 5-36
  Viewing a Campus Map 5-37
  Editing a Campus Map 5-38
  Deleting a Campus Map 5-38
Configuring Outdoor Areas 5-39
  Adding an Outdoor Area 5-39
  Editing Outdoor Areas 5-40
  Deleting Outdoor Areas 5-41
Configuring Floor Areas 5-41
  Adding Floor Areas to a Campus Building 5-42
  Adding Access Points to a Floor Area 5-48
  Editing Floor Areas 5-53
  Deleting Floor Areas 5-53
  Placing Access Points 5-54
  Import Map and AP Location Data 5-54
  Positioning Access Points, Wi-Fi TDOA Receivers, and Chokepoints by Importing or Exporting a File 5-56
  Changing Access Point Positions by Importing and Exporting a File 5-57
Configuring ChokePoints 5-57
  Using Chokepoints to Enhance Tag Location Reporting 5-58
  Adding Chokepoints to the WCS Database 5-58
  Adding a Chokepoint to a WCS Map 5-58
  Positioning Chokepoints 5-59
  Removing Chokepoints from the WCS Database and Map 5-60
Configuring WiFi TDOA Receivers  5-61
  Adding WiFi TDOA Receivers to the WCS Database  5-61
  Adding WiFi TDOA Receivers to a Map  5-61
  Positioning WiFi TDOA Receivers  5-62
  Removing WiFi TDOA Receivers from the Map  5-62
  Removing WiFi TDOA Receivers from the WCS Database  5-63
Managing RF Calibration Models  5-63
  Accessing Current Calibration Models  5-64
  Applying Calibration Models to Maps  5-64
  Calibration Model Properties  5-64
  Calibration Model Details  5-65
  Creating New Calibration Models  5-65
  Starting Calibration Process  5-65
  Calibrating  5-68
  Applying to Maps  5-68
  Deleting Calibration Models  5-69
Managing Location Presence Information  5-69
Searching Maps  5-71
Using Map Editors  5-71
  Opening the Map Editor  5-72
  Using the Map Editor to Draw Polygon Areas  5-72
  Defining an Inclusion Region on a Floor  5-75
  Defining an Exclusion Region on a Floor  5-76
  Defining a Rail Line on a Floor  5-77
Inspecting Location Readiness and Quality  5-78
  Inspecting Location Readiness  5-78
  Inspecting Location Quality Using Calibration Data  5-79
  Inspecting VoWLAN Readiness  5-79
Troubleshooting Voice RF Coverage Issues  5-80
Monitoring Mesh Networks Using Maps  5-80
  Monitoring Mesh Link Statistics Using Maps  5-80
  Monitoring Mesh Access Points Using Maps  5-83
  Monitoring Mesh Access Point Neighbors Using Maps  5-85
  Monitoring Mesh Health  5-88
  Mesh Statistics for an Access Point  5-92
Viewing the Mesh Network Hierarchy  5-96
  Using Mesh Filters to Modify Map Display of Maps and Mesh Links  5-98
Monitoring Tags Using Maps  5-100
Using Planning Mode  5-101
Contents

Accessing Planning Mode 5-101
Using Planning Mode to Calculate Access Point Requirements 5-102
Refresh Options 5-108
Creating a Network Design 5-109
Designing a Network 5-109
Importing or Exporting WLSE Map Data 5-114
Device Details 5-115
Access Point Details 5-115
Client Details 5-117
Tag Details 5-118
Rogue Access Point Details 5-118
Rogue Adhoc Details 5-119
Rogue Client Details 5-119
Interferer Details 5-119
Floor View Navigation 5-120

CHAPTER 6

Monitoring Wireless Devices 6-1
Information About Monitoring 6-1
Monitoring Controllers 6-1
Searching Controllers 6-2
Viewing Controller Search Results 6-2
Configuring the Search Results Display 6-3
Monitoring System Parameters 6-3
Monitoring System Summary 6-4
Monitoring Spanning Tree Protocol 6-5
Monitoring CLI Sessions 6-6
Monitoring DHCP Statistics 6-7
Monitoring WLANs 6-8
Monitoring Ports 6-8
Monitoring General Ports 6-8
Monitoring CDP Interface Neighbors 6-11
Monitoring Controller Security 6-12
Monitoring RADIUS Authentication 6-12
Monitoring RADIUS Accounting 6-13
Monitoring Management Frame Protection Summary 6-14
Monitoring Rogue AP Rules 6-15
Monitoring Guest Users 6-16
Monitoring Controller Mobility 6-17
Monitoring Mobility Stats 6-17
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monitoring the 802.11a/n Controller</td>
<td>6-19</td>
</tr>
<tr>
<td>Monitoring 802.11a/n Parameters</td>
<td>6-19</td>
</tr>
<tr>
<td>Monitoring 802.11a/n RRM Groups</td>
<td>6-20</td>
</tr>
<tr>
<td>Monitoring the 802.11b/g/n Controller</td>
<td>6-21</td>
</tr>
<tr>
<td>Monitoring 802.11b/g/n Parameters</td>
<td>6-21</td>
</tr>
<tr>
<td>Monitoring 802.11b/g/n RRM Groups</td>
<td>6-22</td>
</tr>
<tr>
<td>Monitoring Access Points</td>
<td>6-23</td>
</tr>
<tr>
<td>Searching Access Points</td>
<td>6-23</td>
</tr>
<tr>
<td>Viewing Access Points Search Results</td>
<td>6-24</td>
</tr>
<tr>
<td>Configuring the Search Results Display</td>
<td>6-25</td>
</tr>
<tr>
<td>Generating a Report for Access Points</td>
<td>6-26</td>
</tr>
<tr>
<td>Monitoring the Traffic Load</td>
<td>6-27</td>
</tr>
<tr>
<td>Monitoring Dynamic Power Control</td>
<td>6-28</td>
</tr>
<tr>
<td>Monitoring Access Points Noise</td>
<td>6-29</td>
</tr>
<tr>
<td>Monitoring Access Points Interference</td>
<td>6-29</td>
</tr>
<tr>
<td>Monitoring Access Points Coverage (RSSI)</td>
<td>6-30</td>
</tr>
<tr>
<td>Monitoring Access Points Coverage (SNR)</td>
<td>6-30</td>
</tr>
<tr>
<td>Monitoring Access Points Up/Down Statistics</td>
<td>6-30</td>
</tr>
<tr>
<td>Monitoring Access Points Voice Statistics</td>
<td>6-31</td>
</tr>
<tr>
<td>Monitoring Access Points Voice TSM Table</td>
<td>6-31</td>
</tr>
<tr>
<td>Monitoring Access Points Voice TSM Reports</td>
<td>6-32</td>
</tr>
<tr>
<td>Monitoring Access Points 802.11 Counters</td>
<td>6-33</td>
</tr>
<tr>
<td>Monitoring Access Points AP Profile Status</td>
<td>6-33</td>
</tr>
<tr>
<td>Monitoring Access Points Radio Utilization</td>
<td>6-33</td>
</tr>
<tr>
<td>Monitoring Access Points Traffic Stream Metrics</td>
<td>6-33</td>
</tr>
<tr>
<td>Monitoring Access Points Tx Power and Channel</td>
<td>6-33</td>
</tr>
<tr>
<td>Monitoring Access Points Details</td>
<td>6-34</td>
</tr>
<tr>
<td>General Tab</td>
<td>6-34</td>
</tr>
<tr>
<td>Interfaces Tab</td>
<td>6-39</td>
</tr>
<tr>
<td>CDP Neighbors Tab</td>
<td>6-40</td>
</tr>
<tr>
<td>Current Associated Clients Tab</td>
<td>6-40</td>
</tr>
<tr>
<td>Monitoring Access Point Radio Details</td>
<td>6-41</td>
</tr>
<tr>
<td>Monitoring On Demand Statistics</td>
<td>6-41</td>
</tr>
<tr>
<td>General Tab</td>
<td>6-43</td>
</tr>
<tr>
<td>CleanAir Tab</td>
<td>6-44</td>
</tr>
<tr>
<td>Monitoring Operational Parameters</td>
<td>6-45</td>
</tr>
<tr>
<td>Monitoring 802.11 MAC Counters</td>
<td>6-48</td>
</tr>
<tr>
<td>Monitoring View Alarms</td>
<td>6-49</td>
</tr>
<tr>
<td>Monitor View Events</td>
<td>6-49</td>
</tr>
<tr>
<td>Monitoring Mesh Access Points</td>
<td>6-50</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>-------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Mesh Statistics for an Access Point</td>
<td>6-51</td>
</tr>
<tr>
<td>Monitoring Channel Width</td>
<td>6-55</td>
</tr>
<tr>
<td>Viewing Clients Identified as WGBs</td>
<td>6-58</td>
</tr>
<tr>
<td>Retrieving the Unique Device Identifier on Controllers and Access Points</td>
<td>6-59</td>
</tr>
<tr>
<td>Monitoring Coverage Hole</td>
<td>6-62</td>
</tr>
<tr>
<td>Monitoring Pre-Coverage Holes</td>
<td>6-62</td>
</tr>
<tr>
<td>Monitoring Tags</td>
<td>6-64</td>
</tr>
<tr>
<td>Tag Summary</td>
<td>6-64</td>
</tr>
<tr>
<td>Searching Tags</td>
<td>6-65</td>
</tr>
<tr>
<td>Viewing Search Results</td>
<td>6-65</td>
</tr>
<tr>
<td>Viewing Tag List</td>
<td>6-66</td>
</tr>
<tr>
<td>Monitoring Chokepoints</td>
<td>6-67</td>
</tr>
<tr>
<td>Performing a Chokepoint Search</td>
<td>6-67</td>
</tr>
<tr>
<td>Monitoring Interferers</td>
<td>6-67</td>
</tr>
<tr>
<td>Monitoring AP Detected Interferers</td>
<td>6-68</td>
</tr>
<tr>
<td>Monitoring AP Detected Interferer Details</td>
<td>6-69</td>
</tr>
<tr>
<td>Monitoring AP Detected Interferer Details Location History</td>
<td>6-69</td>
</tr>
<tr>
<td>Configuring the Search Results Display</td>
<td>6-70</td>
</tr>
<tr>
<td>Monitoring WiFi TDOA Receivers</td>
<td>6-71</td>
</tr>
<tr>
<td>Monitoring Spectrum Experts</td>
<td>6-71</td>
</tr>
<tr>
<td>Spectrum Experts Summary</td>
<td>6-72</td>
</tr>
<tr>
<td>Interferers Summary</td>
<td>6-72</td>
</tr>
<tr>
<td>Interferers Search</td>
<td>6-73</td>
</tr>
<tr>
<td>Spectrum Experts Details</td>
<td>6-73</td>
</tr>
<tr>
<td>Monitoring Media Streams</td>
<td>6-73</td>
</tr>
<tr>
<td>Media Stream Details</td>
<td>6-74</td>
</tr>
<tr>
<td>Media Stream Search</td>
<td>6-75</td>
</tr>
<tr>
<td>Monitoring Interactive Graphs</td>
<td>6-75</td>
</tr>
<tr>
<td>Interactive Graphs Overview</td>
<td>6-75</td>
</tr>
<tr>
<td>Interactive Graph Features</td>
<td>6-75</td>
</tr>
<tr>
<td>Time-Based Graphs</td>
<td>6-76</td>
</tr>
<tr>
<td>Monitoring Radio Resource Management (RRM)</td>
<td>6-77</td>
</tr>
<tr>
<td>Channel Change Notifications</td>
<td>6-77</td>
</tr>
<tr>
<td>Transmission Power Change Notifications</td>
<td>6-78</td>
</tr>
<tr>
<td>RF Grouping Notifications</td>
<td>6-78</td>
</tr>
<tr>
<td>Viewing the RRM Dashboard</td>
<td>6-78</td>
</tr>
<tr>
<td>Monitoring Alarms</td>
<td>6-80</td>
</tr>
<tr>
<td>Alarms and Events Overview</td>
<td>6-80</td>
</tr>
</tbody>
</table>
Using the Alarm Summary 6-80
Customizing Alarm Summary Results 6-83
Configuring Alarm Severity 6-84
Viewing Alarms 6-85
Configuring the Search Results Display 6-85
Viewing Alarm Details 6-87
Monitoring Rogue Access Points 6-88
Challenges 6-89
Detecting Rogue Devices 6-89
Monitoring Rogue AP Alarms 6-89
  Select a command 6-92
Classifying Rogue Access Points 6-93
Rogue Access Point Classification Types 6-95
  Malicious Rogue APs 6-95
  Friendly Rogue APs 6-95
  Unclassified Rogue APs 6-96
Viewing Rogue AP Alarm Details 6-96
Viewing Rogue Client Details 6-101
  Select a command 6-101
Viewing Rogue AP History Details 6-102
Viewing Rogue AP Event History Details 6-102
Monitoring Adhoc Rogues 6-103
  Monitoring Adhoc Rogue Alarms 6-103
  Select a command 6-105
Using Advanced Search 6-106
  Viewing Adhoc Rogue Alarm Details 6-108
Monitoring Rogue Access Point Location, Tagging, and Containment 6-110
  Detecting Access Points 6-110
  Monitoring Rogue Alarm Events 6-111
  Viewing Rogue AP Event Details 6-112
  Monitoring Adhoc Rogue Events 6-114
  Viewing Adhoc Rogue Event Details 6-115
Monitoring Email Notifications 6-116
Monitoring Severity Configurations 6-116
Monitoring Cisco Adaptive wIPS Alarms 6-117
  Monitoring Cisco Adaptive wIPS Alarm Details 6-118
Working with Alarms 6-120
Monitoring Air Quality Alarms 6-121
Monitoring CleanAir Security Alarms 6-123
Monitoring Events  6-124
    Searching Events  6-126
    Monitoring Failure Objects  6-127
    Monitoring Events for Rogue APs  6-127
    Monitoring Events for Adhoc Rogues  6-128
    Monitoring Cisco Adaptive wIPS Events  6-129
    Monitoring CleanAir Air Quality Events  6-130
    Viewing Air Quality Event Details  6-131
    Monitoring Interferer Security Risk Events  6-131
    Viewing Interferer Security Risk Event Details  6-132
    Monitoring Health Monitor Events  6-132
    Viewing Health Monitor Event Details  6-133
    Working with Events  6-134

CHAPTER 7  7-1
Managing WCS User Accounts  7-1
    Managing WCS User Accounts  7-1
    Adding WCS User Accounts  7-2
    Deleting WCS User Accounts  7-4
    Changing Passwords  7-5
    Monitoring Active Sessions  7-5
    Viewing or Editing User Account Information  7-6
        Setting the Lobby Ambassador Defaults  7-7
    Viewing or Editing Group Information  7-9
        Editing the Guest User Credentials  7-10
    Viewing the Audit Trail  7-10
        Creating Guest User Accounts  7-11
        Logging in to the WCS User Interface as a Lobby Ambassador  7-12
    Managing WCS Guest User Accounts  7-13
        Scheduling WCS Guest User Accounts  7-13
        Printing or E-mailing WCS Guest User Details  7-14
        Saving Guest Accounts on a Device  7-15
        Editing the Guest User Credentials  7-15
    Adding a New User  7-15
        Adding User Names, Passwords, and Groups  7-16
        Assigning a Virtual Domain  7-17
    Managing Lobby Ambassador Accounts  7-19
        Creating a Lobby Ambassador Account  7-19
        Editing a Lobby Ambassador Account  7-21
        Logging in to the WCS User Interface as a Lobby Ambassador  7-21
CHAPTER 8

Configuring Mobility Groups 8-1
  Information About Mobility 8-1
  Symmetric Tunneling 8-5
  Overview of Mobility Groups 8-5
    When to Include Controllers in a Mobility Group 8-7
    Messaging among Mobility Groups 8-7
  Configuring Mobility Groups 8-8
    Prerequisites 8-8
      Setting the Mobility Scalability Parameters 8-12
  Mobility Anchors 8-13
    Configuring Mobility Anchors 8-14
  Configuring Multiple Country Codes 8-16
  Configuring Controller Config Groups 8-19
    Adding New Group 8-20
    Configuring Config Groups 8-21
    Adding or Removing Controllers from a Config Group 8-22
    Adding or Removing Templates from the Config Group 8-23
    Applying or Scheduling Config Groups 8-23
    Auditing Config Groups 8-24
    Rebooting Config Groups 8-25
  Reporting Config Groups 8-26
  Downloading Software 8-26
    Downloading IDS Signatures 8-27
    Downloading Customized WebAuth 8-27

CHAPTER 9

Configuring Wireless Devices 9-1
  Configuring Controllers 9-1
    Understanding the Controller Audit Report 9-3
    Adding Controllers 9-4
    Removing Controllers from WCS 9-7
    Rebooting Controllers 9-7
    Rebooting Controllers and APs by Swapping AP Images 9-7
    Rebooting Controllers and APs Without Swapping AP Images 9-8
  Downloading Software to Controllers 9-8
    Download Software (FTP) 9-9
    Download Software (TFTP) 9-10
Configure IPaddr Upload Configuration/Logs from Controller 9-12
Download IDS Signatures 9-13
Downloading a Customized WebAuthentication Bundle to a Controller 9-14
Download a Vendor Device Certificate 9-15
Download a Vendor CA Certificate 9-16
Saving the Configuration to Flash 9-17
Refreshing the Configuration from the Controller 9-17
Discovering Templates from the Controller 9-18
Viewing Templates Applied to a Controller 9-18
Using the Audit Now Feature 9-19
Viewing the Latest Network Audit Report 9-20
Configuring Existing Controllers 9-21
Viewing Controllers Properties 9-22
Configuring Controller System Parameters 9-23
Managing General System Properties for Controllers 9-24
Configuring Controller System Commands 9-30
Restoring Factory Defaults 9-31
Setting Controller Time and Date 9-32
Uploading Configuration/Logs from Controllers 9-32
Downloading Configurations to Controllers 9-33
Downloading Software to a Controller 9-34
Downloading a Web Admin Certificate to a Controller 9-34
Downloading IDS Signatures 9-35
Downloading a Customized Web Auth Bundle to a Controller 9-35
Configuring Controller System Interfaces 9-36
Adding an Interface 9-37
Viewing Current Interface Details 9-38
Deleting a Dynamic Interface 9-39
Configuring Controller System Interface Groups 9-39
Adding an Interface Group 9-39
Deleting an Interface Group 9-40
Viewing Interface Groups 9-41
NAC Out-of-Band Integration 9-42
Configuring Wired Guest Access 9-44
Creating an Ingress Interface 9-46
Creating an Egress Interface 9-47
Configuring Controller Network Routes 9-48
Viewing Existing Network Routes 9-48
Configuring Controller Spanning Tree Protocol Parameters 9-49
Configuring Controller Mobility Groups 9-49
Configuring Controller Network Time Protocol 9-52
Background Scanning on 1510s in Mesh Networks 9-52
Configuring Controller QoS Profiles 9-55
Configuring Controller DHCP Scopes 9-56
Configuring Controller User Roles 9-57
Configuring a Global Access Point Password 9-58
Configuring Global CDP 9-58
Configuring AP 802.1X Supplicant Credentials 9-59
Configuring Controller DHCP 9-60
Configuring Controller Multicast Mode 9-61
Configuring Access Point Timer Settings 9-62
Configuring Controller WLANs 9-63
Viewing WLAN Details 9-64
General Tab 9-65
Security Tab 9-65
QoS Tab 9-69
Advanced Tab 9-70
Adding a WLAN 9-73
Deleting a WLAN 9-74
Managing WLAN Status Schedules 9-75
Mobility Anchors 9-76
Configuring WLANs AP Groups 9-77
Adding Access Point Groups 9-77
Deleting Access Point Groups 9-79
Auditing Access Point Groups 9-79
Configuring Hybrid REAP Parameters 9-79
Configuring H-REAP AP Groups 9-79
Auditing an H-REAP Group 9-82
Configuring Security Parameters 9-82
Configuring Controller File Encryption 9-82
Configure Controllers > IPaddr > Security > AAA 9-83
Configuring AAA General Parameters 9-83
Configuring AAA RADIUS Auth Servers 9-83
Configuring AAA RADIUS Acct Servers 9-84
Configuring AAA RADIUS Fallback Parameters 9-85
Configuring AAA LDAP Servers 9-86
Configuring AAA TACACS+ Servers 9-88
Configuring AAA Local Net Users 9-88
Configuring AAA MAC Filtering 9-90
Configuring AAA AP/MSE Authorization 9-90
Contents

Configuring AAA Web Auth Configuration  9-91
Configuring AAA Password Policy  9-92
Configuring Controllers > IPaddr > Security > Local EAP  9-93
Configuring Local EAP General Parameters  9-93
Configuring Local EAP Profiles  9-95
Configuring Local EAP General EAP-FAST Parameters  9-96
Configuring Local EAP General Network Users Priority  9-96
Configuring User Login Policies  9-97
Managing Manually Disabled Clients  9-97
Configuring Access Control Lists  9-97
Configure IPaddr > Access Control List > listname Rules  9-98
Configuring CPU Access Control Lists  9-99
Configuring the IDS Sensor List  9-100
Configuring CA Certificates  9-100
Configuring ID Certificates  9-101
Configuring Controllers > IPaddr > Security > Web Auth Certificate  9-102
Configuring Wireless Protection Policies  9-102
Configuring Rogue Policies  9-103
Configuring Rogue AP Rules  9-104
Configuring Client Exclusion Policies  9-104
Configuring IDS Signatures  9-105
Configuring Controller Standard Signature Parameters  9-105
Configuring Custom Signatures  9-108
Configuring AP Authentication and MFP  9-109
Configuring Cisco Access Points  9-110
Sniffer feature  9-110
Configuring 802.11 Parameters  9-112
Configuring General Parameters for an 802.11 Controller  9-112
Configuring Aggressive Load Balancing  9-113
Configuring Band Selection  9-114
Configuring Preferred Call  9-116
Configuring 802.11 Media Parameters  9-117
Configuring 802.11a/n Parameters  9-117
Configuring 802.11a/n General Parameters  9-118
Configuring 802.11a/n RRM Thresholds  9-119
Configuring 802.11a/n RRM Intervals  9-120
Configuring 802.11a/n RRM Transmit Power Control  9-120
Configuring 802.11a/n RRM Dynamic Channel Allocation  9-121
Configuring 40-MHz Channel Bonding  9-122
Configuring 802.11a/n RRM Radio Grouping  9-124
Configuring 802.11a/n Media Parameters 9-124
Configuring 802.11a/n EDCA Parameters 9-127
Configuring 802.11a/n Roaming Parameters 9-127
Configuring 802.11a/n 802.11h Parameters 9-128
Configuring 802.11a/n High Throughput (802.11n) Parameters 9-129
Configuring 802.11a/n CleanAir Parameters 9-129
Configuring 802.11b/g/n Parameters 9-130
Configuring 802.11b/g/n General Parameters 9-131
Configuring 802.11b/g/n RRM Thresholds 9-132
Configuring 802.11b/g/n RRM Transmit Power Control 9-132
Configuring 802.11b/g/n RRM Intervals 9-133
Configuring an 802.11b/g/n RRM DCA 9-134
Configuring 802.11b/g/n RRM Radio Grouping 9-134
Configuring 802.11b/g/n Media Parameters 9-135
Configuring 802.11b/g/n EDCA Parameters 9-137
Configuring 802.11b/g/n Roaming Parameters 9-138
Configuring 802.11b/g/n High Throughput (802.11n) Parameters 9-139
Configuring 802.11b/g/n CleanAir Parameters 9-139
Configuring Mesh Parameters 9-140
Client Access on 1524SB Dual Backhaul 9-141
Backhaul Channel Deselection Using WCS 9-142
Configuring Port Parameters 9-143
Configuring Controllers Management Parameters 9-144
Configuring Trap Receivers 9-144
Configuring Trap Control Parameters 9-145
Configuring Telnet SSH Parameters 9-147
Configuring a Syslog for an Individual Controller 9-148
Configuring Multiple Syslog Servers 9-148
Configuring WEB Admin 9-148
Download Web Auth or Web Admin Certificate to Controller 9-149
Configuring Local Management Users 9-150
Configuring Authentication Priority 9-150
Configuring Location Configurations 9-150
Configuring Access Points 9-152
Setting AP Failover Priority 9-153
Configuring Global Credentials for Access Points 9-153
Configuring Ethernet Bridging and Ethernet VLAN Tagging 9-155
Ethernet VLAN Tagging Guidelines 9-156
Enabling Ethernet Bridging and VLAN Tagging 9-158
Autonomous to Lightweight Migration Support 9-160
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding Autonomous Access Points to WCS</td>
<td>9-160</td>
</tr>
<tr>
<td>Viewing Autonomous Access Points in WCS</td>
<td>9-162</td>
</tr>
<tr>
<td>Downloading Images to Autonomous Access Points</td>
<td>9-163</td>
</tr>
<tr>
<td>Supporting Autonomous Access Points in Work Group Bridge (WGB) mode</td>
<td>9-163</td>
</tr>
<tr>
<td>Upgrading Autonomous Access Points</td>
<td>9-163</td>
</tr>
<tr>
<td>Viewing Current Status of Cisco IOS Access Points</td>
<td>9-164</td>
</tr>
<tr>
<td>Disabling Access Points that are Ineligible</td>
<td>9-165</td>
</tr>
<tr>
<td>Configuring Access Point Details</td>
<td>9-165</td>
</tr>
<tr>
<td>Configuring an Ethernet Interface</td>
<td>9-173</td>
</tr>
<tr>
<td>Downloading Autonomous AP Images</td>
<td>9-174</td>
</tr>
<tr>
<td>Importing AP Configuration</td>
<td>9-174</td>
</tr>
<tr>
<td>Exporting AP Configuration</td>
<td>9-175</td>
</tr>
<tr>
<td>Configuring Access Points 802.11n Antenna</td>
<td>9-175</td>
</tr>
<tr>
<td>Configuring CDP</td>
<td>9-183</td>
</tr>
<tr>
<td>Configuring CDP on Access Point</td>
<td>9-183</td>
</tr>
<tr>
<td>Configuring Access Point Radios for Tracking Optimized Monitor Mode</td>
<td>9-184</td>
</tr>
<tr>
<td>Copying and Replacing Access Points</td>
<td>9-184</td>
</tr>
<tr>
<td>Removing Access Points</td>
<td>9-185</td>
</tr>
<tr>
<td>Scheduling and Viewing Radio Status</td>
<td>9-185</td>
</tr>
<tr>
<td>Scheduling Radio Status</td>
<td>9-186</td>
</tr>
<tr>
<td>Viewing Scheduled Tasks</td>
<td>9-186</td>
</tr>
<tr>
<td>Viewing Audit Status (for Access Points)</td>
<td>9-186</td>
</tr>
<tr>
<td>Searching Access Points</td>
<td>9-187</td>
</tr>
<tr>
<td>Viewing Mesh Link Details</td>
<td>9-188</td>
</tr>
<tr>
<td>Viewing or Editing Rogue Access Point Rules</td>
<td>9-188</td>
</tr>
<tr>
<td>Configuring Ethernet Switches</td>
<td>9-189</td>
</tr>
<tr>
<td>Configuring Ethernet Switch Credentials</td>
<td>9-189</td>
</tr>
<tr>
<td>Removing Ethernet Switch Credentials</td>
<td>9-191</td>
</tr>
<tr>
<td>Configuring Spectrum Experts</td>
<td>9-191</td>
</tr>
<tr>
<td>Adding a Spectrum Expert</td>
<td>9-192</td>
</tr>
<tr>
<td>Monitoring Spectrum Experts</td>
<td>9-192</td>
</tr>
<tr>
<td>Viewing Spectrum Experts Summary</td>
<td>9-192</td>
</tr>
<tr>
<td>Viewing Interferers Summary</td>
<td>9-193</td>
</tr>
<tr>
<td>Viewing Spectrum Experts Details</td>
<td>9-193</td>
</tr>
<tr>
<td>OfficeExtend Access Point</td>
<td>9-194</td>
</tr>
<tr>
<td>Licensing for an OfficeExtend Access Point</td>
<td>9-194</td>
</tr>
<tr>
<td>Configuring Link Latency Settings for Access Points</td>
<td>9-195</td>
</tr>
<tr>
<td>Configuring Chokepoints</td>
<td>9-196</td>
</tr>
<tr>
<td>Configure New Chokepoints</td>
<td>9-196</td>
</tr>
</tbody>
</table>
Adding a Chokepoint to WCS Database 9-196
Adding a Chokepoint to a WCS Map 9-197
Removing a Chokepoint from a WCS Map 9-198
Removing a Chokepoint from WCS 9-198
Editing Current Chokepoints 9-198
Configuring WiFi TDOA Receivers 9-199
Using WiFi TDOA Receivers to Enhance Tag Location Reporting 9-199
Adding Wi-Fi TDOA Receivers to Cisco WCS and Maps 9-200
Viewing or Editing Current Wi-Fi TDOA Receivers 9-201
Removing Wi-Fi TDOA Receivers from Cisco WCS and Maps 9-202
Configuring Scheduled Configuration Tasks 9-202
AP Template Tasks 9-202
Modifying a Current AP Template Task 9-203
Viewing AP Status Report for the Scheduled Task 9-203
Enabling or Disabling a Current AP Template Task 9-203
Viewing AP Template Task History 9-204
Deleting a Current AP Template Task 9-204
Configuring Config Groups 9-204
Modifying a Current Config Group Task 9-204
Viewing Controller Status Report for the Scheduled Task 9-205
Enabling or Disabling a Current Config Group Task 9-205
Viewing Config Group Task History 9-205
Deleting a Current Config Group Task 9-206
Viewing WLAN Configuration Scheduled Task Results 9-206
Downloading Software 9-207
Adding a Download Software Task 9-207
Modifying a Download Software Task 9-209
Selecting Controllers for the Download Software Task 9-209
Viewing Download Software Results 9-210
Deleting a Download Software Task 9-210
Enabling or Disabling a Download Software Task 9-211
Configuring wIPS Profiles 9-211
Profile List 9-212
Adding a Profile 9-213
Profile Editor 9-213
Deleting a Profile 9-216
Applying a Current Profile 9-216
Configure > wIPS > SSID Group List 9-217
Global SSID Group List 9-217
Contents

SSID Groups 9-218
Configuring ACS View Servers 9-220
  Configuring ACS View Server Credentials 9-221
Configuring TFTP Servers 9-221
  Adding a TFTP Server 9-222
  Deleting TFTP Servers 9-222
Interactive Graphs 9-222
  Interactive Graphs Overview 9-222
  Interactive Graph Features 9-222
  Time-based Graphs 9-223

CHAPTER 10 Managing Clients 10-1

Client Tab 10-2
  Client Distribution 10-3
  Client Protocol Distribution 10-3
  Client Count 10-4
  Client 10-5
  Client Traffic 10-6
  Client Authentication Type Distribution 10-7
  AP Join Taken Time 10-7
  AP Threats/Attacks 10-7
Monitoring Clients 10-8
  Monitoring Clients Summary 10-8
  Client Detail Page 10-10
  Configuring the Search Results Display 10-11
  Filtering the Client Summary 10-11
  Client Properties 10-15
  Client Association History 10-18
  Client Statistics 10-18
  Client Event Information 10-19
  Client Location Information 10-19
  Client CCxv5 Information 10-19
Enabling Automatic Client Troubleshooting 10-21
Viewing Client Details in the Access Point Page 10-21
Running Client Reports 10-21
Client Troubleshooting 10-21
  Troubleshooting from the Client Tab Dashboard 10-22
  Troubleshooting Using the Search Feature 10-22
<table>
<thead>
<tr>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Receiving Radio Measurements for a Client</td>
</tr>
<tr>
<td>Radio Measurement Results for a Client</td>
</tr>
<tr>
<td>Viewing Client V5 Statistics</td>
</tr>
<tr>
<td>Viewing Client Operational Parameters</td>
</tr>
<tr>
<td>Viewing Client Profiles</td>
</tr>
<tr>
<td>Disabling a Current Client</td>
</tr>
<tr>
<td>Removing a Current Client</td>
</tr>
<tr>
<td>Enabling Mirror Mode</td>
</tr>
<tr>
<td>Viewing a Map (High Resolution) of a Client Recent Location</td>
</tr>
<tr>
<td>Viewing a Map (High Resolution) of a Client Current Location</td>
</tr>
<tr>
<td>Viewing a Client Sessions Report for the Client</td>
</tr>
<tr>
<td>Viewing a Roam Reason Report for the Client</td>
</tr>
<tr>
<td>Viewing Detecting Access Point Details</td>
</tr>
<tr>
<td>Viewing Client Location History</td>
</tr>
<tr>
<td>Viewing Voice Metrics for a Client</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CHAPTER 11</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using Templates</td>
</tr>
<tr>
<td>Information About Templates</td>
</tr>
<tr>
<td>Accessing Controller Template Launch Pad</td>
</tr>
<tr>
<td>Adding Controller Templates</td>
</tr>
<tr>
<td>Deleting Controller Templates</td>
</tr>
<tr>
<td>Applying Controller Templates</td>
</tr>
<tr>
<td>Configuring Controller Templates</td>
</tr>
<tr>
<td>Configuring System Templates</td>
</tr>
<tr>
<td>Configuring General Templates</td>
</tr>
<tr>
<td>Configuring SNMP Community Controller Templates</td>
</tr>
<tr>
<td>Configuring an NTP Server Template</td>
</tr>
<tr>
<td>Configuring User Roles Controller Templates</td>
</tr>
<tr>
<td>Configuring AP Username Password Controller Templates</td>
</tr>
<tr>
<td>Configuring AP 802.1X Supplicant Credentials</td>
</tr>
<tr>
<td>Configuring a Global CDP Configuration Template</td>
</tr>
<tr>
<td>Configuring DHCP Templates</td>
</tr>
<tr>
<td>Configuring Dynamic Interface Templates</td>
</tr>
<tr>
<td>Configuring QoS Templates</td>
</tr>
<tr>
<td>Configuring AP Timers Templates</td>
</tr>
<tr>
<td>Configuring an Interface Group Template</td>
</tr>
<tr>
<td>Configuring a Traffic Stream Metrics QoS Template</td>
</tr>
</tbody>
</table>
## Contents

- Configuring WLAN Templates 11-22
  - Configuring WLAN AP Groups Templates 11-38
  - Adding Access Point Groups 11-39
  - Deleting Access Point Groups 11-40
- Configuring H-REAP Templates 11-41
  - Configuring H-REAP AP Groups Templates 11-41
  - Configuring H-REAP Users 11-43
- Configuring Security Templates 11-44
  - Configuring a General Security Controller Template 11-44
  - Configuring a File Encryption Template 11-45
  - Configuring a RADIUS Authentication Template 11-46
  - Configuring a RADIUS Accounting Template 11-49
  - Configuring a RADIUS Fallback Template 11-50
  - Configuring an LDAP Server Template 11-52
  - Configuring a TACACS+ Server Template 11-54
  - Configuring a Local EAP General Template 11-55
  - Configuring a Local EAP Profile Template 11-56
  - Configuring an EAP-FAST Template 11-58
  - Configuring a Network User Credential Retrieval Priority Template 11-60
  - Configuring a Local Network Users Template 11-61
  - Configuring a Guest User Template 11-63
  - Configuring a User Login Policies Template 11-65
  - Configuring a MAC Filter Template 11-66
  - Configuring an Access Point or MSE Authorization Template 11-68
  - Configuring a Manually Disabled Client Template 11-69
  - Configuring a Client Exclusion Policies Template 11-70
  - Configuring an Access Point Authentication and MFP Template 11-72
  - Configuring a Web Authentication Template 11-73
  - Configuring an External Web Auth Server Template 11-78
  - Configuring a Security Password Policy Template 11-78
- Configuring Security - Access Control Templates 11-79
  - Configuring an Access Control List Template 11-80
  - Configuring an ACL IP Groups Template 11-85
  - Configuring an ACL Protocol Groups Template 11-85
- Configuring Security - CPU Access Control List Templates 11-87
  - Configuring a CPU Access Control List (ACL) Template 11-87
Configuring Security - Rogue Templates 11-88
   Configuring a Rogue Policies Template 11-89
   Configuring a Rogue AP Rules Template 11-90
   Configuring a Rogue AP Rule Groups Template 11-92
   Configuring a Friendly Access Point Template 11-94
Configuring 802.11 Templates 11-96
   Configuring Load Balancing Templates 11-96
   Configuring Band Selection Templates 11-97
   Configuring Preferred Call Templates 11-97
   Configuring Media Parameters for Controller Templates 11-98
Configuring Radio Templates (802.11a/n) 11-99
   Configuring 802.11a/n Parameters Templates 11-99
   Configuring Media Parameters Controller Templates (802.11a/n) 11-102
   Configuring EDCA Parameters Through a Controller Template (802.11a/n) 11-104
   Configuring a Roaming Parameters Template (802.11a/n) 11-105
   Configuring an 802.11h Template 11-107
   Configuring a High Throughput Template (802.11a/n) 11-108
   Configuring CleanAir Controller Templates (802.11a/n) 11-109
   Configuring 802.11a/n RRM Templates 11-110
Configuring Radio Templates (802.11b/g/n) 11-116
   Configuring 802.11b/g/n Parameters Templates 11-116
   Configuring Media Parameters Controller Templates (802.11b/g/n) 11-119
   Configuring EDCA Parameters Controller Templates (802.11b/g/n) 11-121
   Configuring Roaming Parameters Controller Templates (802.11b/g/n) 11-121
   Configuring High Throughput (802.11n) Controller Templates (802.11b/g/n) 11-123
   Configuring CleanAir Controller Templates (802.11 b/g/n) 11-123
   Configuring 802.11b/g/n RRM Templates 11-124
Configuring Mesh Templates 11-129
   Configuring Mesh Setting Templates 11-129
Configuring Management Templates 11-130
   Configuring Trap Receiver Templates 11-131
   Configuring Trap Control Templates 11-132
   Configuring Telnet SSH Templates 11-135
   Configuring Legacy Syslog Templates 11-136
   Configuring Multiple Syslog Templates 11-137
   Configuring Local Management User Templates 11-138
   Configuring User Authentication Priority Templates 11-139
Applying a Set of CLI Commands 11-140
Configuring Location Configuration Templates 11-141
Configuring AP Configuration Templates 11-143
| Viewing and Adding Trap Destinations for a Mobility Services Engine | 12-24 |
| Editing Advanced Parameters for a Mobility Services Engine | 12-25 |
| Rebooting the Mobility Services Engine Hardware | 12-26 |
| Shutting Down the Mobility Services Engine Hardware | 12-26 |
| Clearing Mobility Services Engine Database | 12-27 |
| Working with Logs | 12-27 |
| Managing User and Group Accounts for a Mobility Services Engine | 12-29 |
| Monitoring Status Information for a Mobility Services Engine | 12-32 |
| Viewing Server Events for a Mobility Services Engine | 12-32 |
| Viewing Audit Logs from a Mobility Services Engine | 12-32 |
| Viewing WCS Alarms for a Mobility Services Engine | 12-33 |
| Viewing WCS Events for a Mobility Services Engine | 12-33 |
| Viewing NMS Connection Status for a Mobility Services Engine | 12-33 |
| Managing Maintenance for Mobility Services | 12-35 |
| Viewing or Editing Mobility Services Backup Parameters | 12-35 |
| Backing Up Mobility Services Engine Historical Data | 12-35 |
| Restoring Mobility Services Engine Historical Data | 12-36 |
| Enabling Automatic Location Data Backup | 12-36 |
| Downloading Software to a Mobility Services Engine Using Cisco WCS | 12-37 |
| Managing Cisco Adaptive wIPS Service Parameters | 12-37 |
| Managing Context Aware Service Parameters | 12-38 |
| Context-Aware General Parameters | 12-39 |
| Context-Aware Administration Parameters | 12-40 |
| Modifying Tracking Parameters for Mobility Services Engines | 12-40 |
| Modifying Filtering Parameters for Mobility Services | 12-41 |
| Modifying History Parameters for Mobility Services | 12-43 |
| Enabling Location Presence for Mobility Services | 12-43 |
| Importing Asset Information for Mobility Services | 12-44 |
| Exporting Asset Information for Mobility Services | 12-45 |
| Importing Civic Information for Mobility Services | 12-45 |
| Context Aware Wired Parameters | 12-46 |
| Monitoring Interferers | 12-49 |
| Context Aware Advanced Parameters | 12-53 |
| Modifying Location Parameters for Mobility Services | 12-53 |
| Modifying Notification Parameters for Mobility Services | 12-56 |
| Viewing Tag Engine Status | 12-58 |
| Viewing Notification Information for Mobility Services | 12-58 |
| Viewing the Notifications Summary for Mobility Services | 12-58 |
| Viewing and Managing Notifications Settings for Mobility Services | 12-59 |
| Viewing Notification Statistics | 12-60 |
About Event Groups 12-60
  Adding Event Groups 12-61
  Deleting Event Groups 12-61
  Working with Event Definitions 12-61
  Adding Event Definitions 12-64
  Deleting an Event Definition 12-68
Upgrading from 5.x to 6.0 or 7.0 12-68
Viewing the MSE Alarm Details 12-69
Overview of MSE License 12-71
  MSE License Structure Matrix 12-72
  Sample MSE License File 12-72
  Revoking and Reusing an MSE License 12-72
Location Assisted Client Troubleshooting from the ContextAware Dashboard 12-73
MSE Reports 12-74
Planning for and Configuring Context-Aware Software 12-74
wIPS Planning and Configuring 12-76

CHAPTER 13
Configuring Hybrid REAP 13-1
  Information About Hybrid REAP 13-1
    Hybrid-REAP Authentication Process 13-2
    Hybrid REAP Guidelines 13-4
  Configuring Hybrid REAP 13-4
    Configuring the Switch at the Remote Site 13-5
    Configuring the Controller for Hybrid REAP 13-6
    Configuring an Access Point for Hybrid REAP 13-9
    Connecting Client Devices to the WLANs 13-12
  Hybrid REAP Access Point Groups 13-12
    Hybrid-REAP Groups and Backup RADIUS Servers 13-13
    Hybrid-REAP Groups and CCKM 13-13
    Hybrid-REAP Groups and Local Authentication 13-14
    Configuring Hybrid-REAP Groups 13-14
    Auditing an H-REAP Group 13-16

CHAPTER 14
Alarm and Event Dictionary 14-1
  Notification Format 14-2
    Traps Added in Release 2.0 14-3
      AP_BIG_NAV_DOS_ATTACK 14-3
      AP_CONTAINED_AS_ROGUE 14-3
      AP_DETECTED_DUPLICATE_IP 14-3
AP_HAS_NO_RADIOS 14-4
AP_MAX_ROGUE_COUNT_CLEAR 14-4
AP_MAX_ROGUE_COUNT_EXCEEDED 14-4
AUTHENTICATION_FAILURE (From MIB-II standard) 14-4
BSN_AUTHENTICATION_FAILURE 14-5
COLD_START (FROM MIB-II STANDARD) 14-6
CONFIG_SAVED 14-6
IPSEC_IKE_NEG_FAILURE 14-6
IPSEC_INVALID_COOKIE 14-7
LINK_DOWN (FROM MIB-II STANDARD) 14-7
LINK_UP (FROM MIB-II STANDARD) 14-7
LRAD_ASSOCIATED 14-7
LRAD_DISASSOCIATED 14-8
LRADIF_COVERAGE_PROFILE_FAILED 14-8
LRADIF_COVERAGE_PROFILE_PASSED 14-8
LRADIF_CURRENT_CHANNEL_CHANGED 14-9
LRADIF_CURRENT_TXPOWER_CHANGED 14-9
LRADIF_DOWN 14-9
LRADIF_INTERFERENCE_PROFILE_FAILED 14-10
LRADIF_INTERFERENCE_PROFILE_PASSED 14-10
LRADIF_LOAD_PROFILE_FAILED 14-11
LRADIF_LOAD_PROFILE_PASSED 14-11
LRADIF_NOISE_PROFILE_FAILED 14-11
LRADIF_NOISE_PROFILE_PASSED 14-12
LRADIF_UP 14-12
MAX_ROGUE_COUNT_CLEAR 14-12
MAX_ROGUE_COUNT_EXCEEDED 14-13
MULTIPLE_USERS 14-13
NETWORK_DISABLED 14-13
NO_ACTIVITY_FOR_ROGUE_AP 14-13
POE_CONTROLLER_FAILURE 14-14
RADIOS_EXCEEDED 14-14
RADIUS_SERVERS_FAILED 14-14
ROGUE_AP_DETECTED 14-15
ROGUE_AP_ON_NETWORK 14-15
ROGUE_AP_REMOVED 14-16
RRM_DOT11_A_GROUPING_DONE 14-16
RRM_DOT11_B_GROUPING_DONE 14-16
SENSED_TEMPERATURE_HIGH 14-17
SENSED_TEMPERATURE_LOW 14-17
STATION_ASSOCIATE 14-17
STATION_ASSOCIATE_FAIL 14-18
STATION_AUTHENTICATE 14-18
STATION_AUTHENTICATION_FAIL 14-18
STATION_BLACKLISTED 14-19
STATION_DEAUTHENTICATE 14-19
STATION_DISASSOCIATE 14-19
STATION_WEP_KEY_DECRYPT_ERROR 14-20
STATION_WPA_MIC_ERROR_COUNTER_ACTIVATED 14-20
SWITCH_DETECTED_DUPLICATE_IP 14-20
SWITCH_DOWN 14-21
SWITCH_UP 14-21
TEMPERATURE_SENSOR_CLEAR 14-21
TEMPERATURE_SENSOR_FAILURE 14-22
TOO_MANY_USER_UNSUCCESSFUL_LOGINS 14-22
Traps Added in Release 2.1 14-22
ADHOC_ROGUE_AUTO_CONTAINED 14-22
ADHOC_ROGUE_AUTO_CONTAINED_CLEAR 14-23
NETWORK_ENABLED 14-23
ROGUE_AP_AUTO_CONTAINED 14-23
ROGUE_AP_AUTO_CONTAINED_CLEAR 14-23
TRUSTED_AP_INVALID_ENCRYPTION 14-24
TRUSTED_AP_INVALID_ENCRYPTION_CLEAR 14-24
TRUSTED_AP_INVALID_RADIO_POLICY 14-24
TRUSTED_AP_INVALID_RADIO_POLICY_CLEAR 14-24
TRUSTED_AP_INVALID_SSID 14-25
TRUSTED_AP_INVALID_SSID_CLEAR 14-25
TRUSTED_AP_MISSING 14-25
TRUSTED_AP_MISSING_CLEAR 14-25
Traps Added in Release 2.2 14-26
AP_IMPERSONATION_DETECTED 14-26
AP_RADIO_CARD_RX_FAILURE 14-26
AP_RADIO_CARD_RX_FAILURE_CLEAR 14-26
AP_RADIO_CARD_TX_FAILURE 14-27
AP_RADIO_CARD_TX_FAILURE_CLEAR 14-27
SIGNATURE_ATTACK_CLEARED 14-27
SIGNATURE_ATTACK_DETECTED 14-28
TRUSTED_AP_HAS_INVALID_PREAMBLE 14-28
TRUSTED_HAS_INVALID_PREAMBLE_CLEARED 14-28
Traps Added in Release 3.0 14-29
Contents

AP_FUNCTIONALITY_DISABLED  14-29
AP_IP_ADDRESS_FALLBACK  14-29
AP_REGULATORY_DOMAIN_MISMATCH  14-30
RX_MULTICAST_QUEUE_FULL  14-30
Traps Added in Release 3.1  14-31
  AP_AUTHORIZATION_FAILURE  14-31
  HEARTBEAT_LOSS_TRAP  14-31
  INVALID_RADIO_INTERFACE  14-32
  RADAR_CLEARED  14-32
  RADAR_DETECTED  14-32
  RADIO_CORE_DUMP  14-32
  RADIO_INTERFACE_DOWN  14-34
  RADIO_INTERFACE_UP  14-34
  UNSUPPORTED_AP  14-34
Traps Added in Release 3.2  14-35
  LOCATION_NOTIFY_TRAP  14-35
Traps Added In Release 4.0  14-36
  CISCO_LWAPP_MESH_POOR_SNR  14-36
  CISCO_LWAPP_MESH_PARENT_CHANGE  14-36
  CISCO_LWAPP_MESH_CHILD_MOVED  14-36
  CISCO_LWAPP_MESH_CONSOLE_LOGIN  14-37
  CISCO_LWAPP_MESH_AUTHORIZATION_FAILURE  14-37
  EXCESSIVE_ASSOCIATION  14-38
  CISCO_LWAPP_MESH_PARENT_EXCLUDED_CHILD  14-38
  CISCO_LWAPP_MESH_CHILD_EXCLUDED_PARENT  14-38
  CISCO_LWAPP_MESH_EXCESSIVE_PARENT_CHANGE  14-38
  IDS_SHUN_CLIENT_TRAP  14-39
  IDS_SHUN_CLIENT_CLEAR_TRAP  14-40
  MFP_TIMEBASE_STATUS_TRAP  14-40
  MFP_ANOMALY_DETECTED_TRAP  14-41
  GUEST_USER_REMOVED_TRAP  14-41
Traps Added or Updated in Release 4.0.96.0  14-42
  AP_IMPERSONATION_DETECTED  14-42
  RADIUS_SERVER_DEACTIVATED  14-42
  RADIUS_SERVER_ACTIVATED  14-42
  RADIUS_SERVER_WLAN_DEACTIVATED  14-43
  RADIUS_SERVER_WLAN_ACTIVATED  14-43
  RADIUS_SERVER_TIMEOUT  14-43
  DECRYPT_ERROR_FOR_WRONG_WPA_WPA2  14-43
Traps Added or Updated in Release 4.1  14-44
AP_IMPERSONATION_DETECTED 14-44
INTERFERENCE_DETECTED 14-44
INTERFERENCE_CLEAR 14-44
ONE_ANCHOR_ON_WLAN_UP 14-45
RADIUS_SERVER_DEACTIVATED 14-45
RADIUS_SERVER_ACTIVATED 14-45
RADIUS_SERVER_WLAN_DEACTIVATED 14-46
RADIUS_SERVER_WLAN_ACTIVATED 14-46
RADIUS_SERVER_TIMEOUT 14-46
MOBILITY_ANCHOR_CTRL_PATH_DOWN 14-46
MOBILITY_ANCHOR_CTRL_PATH_UP 14-46
MOBILITY_ANCHOR_DATA_PATH_DOWN 14-47
MOBILITY_ANCHOR_DATA_PATH_UP 14-47
WLAN_ALL_ANCHORS_TRAP_DOWN 14-47
MESH_AUTHORIZATIONFAILURE 14-48
MESH_CHILDEXCLUDEDPARENT 14-48
MESH_PARENCHANGE 14-48
MESH_CHILDMOVED 14-49
MESH_EXCESSIVEPARENTHCANGE 14-49
MESH_POORSNR 14-49
MESH_POORSNRCLEAR 14-50
MESH_CONSOLELOGIN 14-50
LRADIF_REGULATORY_DOMAIN 14-50
LRAD_CRASH 14-51
LRAD_UNSUPPORTED 14-51

Traps Added or Updated in Release 4.2 14-51
GUEST_USER_ADDED 14-51
GUEST_USER_AUTHENTICATED 14-52
IOSAP_LINK_UP 14-52
IOSAP_LINK_DOWN 14-52
IOSAP_UP 14-53
IOSAP_DOWN 14-53
WCS_EMAIL_FAILURE 14-53
AUDIT_STATUS_DIFFERENCE 14-54
LRAD_POE_STATUS 14-54
ROGUE_AP_NOT_ON_NETWORK 14-54

Traps Added or Updated in Release 5.0 14-55
GUEST_USER_LOGOFF 14-55
WCS_NOTIFICATION_FAILURE 14-55
WCS_LOW_DISK_SPACE 14-55
CHAPTER 15 Reports  15-1

Report Launch Pad  15-2

Creating and Running a New Report  15-3
Managing Current Reports  15-9
Managing Scheduled Run Results  15-9
  Sorting Scheduled Run Results  15-10
  Viewing or Editing Scheduled Run Details  15-11
Managing Saved Reports  15-11
  Sorting Saved Reports  15-12
  Viewing or Editing Saved Report Details  15-13
  Running a Saved Report  15-13

CleanAir Reports  15-15
Compliance Reports  15-48
  Configuration Audit Report  15-49
    Configuring a Configuration Audit Report  15-49
    Configuration Audit Report Results  15-50
  PCI DSS Detailed  15-52
    Configuring a PCI DSS Detailed Report  15-52
    PCI DSS Detailed Report Results  15-53
  PCI DSS Summary  15-54
    Configuring a PCI DSS Summary Report  15-55
    PCI DSS Summary Report Results  15-55
ContextAware Reports  15-57
  Client Location History  15-57
    Configuring a Client Location History  15-57
    Client Location History Results  15-58
  Client Location Tracking  15-58
    Configuring a Client Location Tracking  15-59
    Client Location Tracking Results  15-59
  Guest Location Tracking  15-60
    Configuring Guest Location Tracking  15-60
    Guest Location Tracking Results  15-61
  Location Notifications  15-61
    Configuring Location Notification  15-62
    Location Notification Report Results  15-63
  Rogue AP Location Tracking  15-63
    Configuring Rogue AP Location Tracking  15-63
    Rogue AP Location Tracking Results  15-64
  Rogue Client Location Tracking  15-65
    Configuring Rogue Client Location Tracking  15-65
    Rogue Client Location Tracking Results  15-66
  Tag Location History  15-66
    Configuring Tag Location History  15-66
    Tag Location History Results  15-67
  Tag Location Tracking  15-67
    Configuring Tag Location Tracking  15-68
    Tag Location Tracking Results  15-68
Device Reports  15-69
  AP Image Predownload  15-69
    Configuring an AP Image Predownload Report  15-69
    AP Image Predownload Report Results  15-71
  AP Profile Status  15-71
Nodes  15-101
  Configuring a Nodes Report  15-101
  Nodes Report Results  15-102
Packet Stats  15-102
  Configuring a Packet Stats Report  15-103
  Packet Stats Report Results  15-103
Packet Error Statistics  15-104
  Configuring a Packet Error Statistics Report  15-104
  Packet Error Statistics Report Results  15-105
Packet Queue Statistics  15-106
  Configuring a Packet Queue Statistics Report  15-106
  Packet Queue Statistics Report Results  15-107
Stranded APs  15-108
  Configuring a Stranded APs Report  15-108
  Stranded APs Report Results  15-109
Worst Node Hops  15-110
  Configuring a Worst Node Hops Report  15-110
  Worst Node Hops Report Results  15-112
Network Summary  15-113
  802.11n Summary  15-113
    Configuring an 802.11n Summary Report  15-113
    802.11n Summary Report Results  15-114
Executive Summary  15-115
  Configuring an Executive Summary Report  15-115
  Executive Summary Report Results  15-116
Preferred Calls  15-117
  Configuring a Preferred Calls Report  15-118
Performance Reports  15-118
  802.11 Counters  15-119
    Configuring an 802.11 Counters Report  15-119
    802.11 Counters Report Results  15-121
Coverage Hole  15-122
  Configuring a Coverage Hole Report  15-122
  Coverage Hole Report Results  15-123
Network Utilization  15-124
  Configuring a Network Utilization Report  15-125
  Network Utilization Report Results  15-125
Traffic Stream Metrics  15-126
  Configuring a Traffic Stream Metrics Report  15-126
  Traffic Stream Metrics Report Results  15-128
Contents

Tx Power and Channel 15-129
  Configuring a Tx Power and Channel Report 15-129
  Tx Power and Channel Report Results 15-130
VolP Calls Graph 15-131
  Configuring a VolP Calls Graph Report 15-131
  VolP Calls Report Results 15-132
VolP Calls Table 15-133
  Configuring a VolP Calls Table Report 15-133
  VolP Calls Table Results 15-134
Voice Statistics 15-135
  Configuring a Voice Statistics Report 15-135
  Voice Statistics Results 15-136
Security Reports 15-137
  Adaptive wIPS Alarm 15-138
    Configuring an Adaptive wIPS Alarm Report 15-138
    Adaptive wIPS Alarm Report Results 15-139
  Adaptive wIPS Alarm Summary 15-140
    Configuring an Adaptive wIPS Alarm Summary Report 15-140
    Adaptive wIPS Alarm Summary Report Results 15-141
  Adaptive wIPS Top 10 AP 15-142
    Configuring an Adaptive wIPS Top 10 AP Report 15-143
    Adaptive wIPS Top 10 AP Report Results 15-144
  Adhoc Rogue Count Summary 15-145
    Configuring an Adhoc Rogue Count Summary Report 15-145
    Adhoc Rogue Count Summary Report Results 15-146
  Adhoc Rogue Events 15-146
    Configuring an Adhoc Rogue Events Report 15-147
    Adhoc Rogue Events Report Results 15-148
  Adhoc Rogues 15-148
    Configuring an Adhoc Rogues Report 15-149
    Adhoc Rogues Report Results 15-149
  New Rogue AP Count Summary 15-150
    Configuring a New Rogue AP Count Summary Report 15-151
    New Rogue AP Count Summary Report Results 15-151
  New Rogue APs 15-152
    Configuring a New Rogue AP Report 15-152
    New Rogue AP Report Results 15-153
  Rogue AP Count Summary 15-154
    Configuring a Rogue AP Count Summary Report 15-154
    Rogue AP Count Summary Report Results 15-155
## Performing Administrative Tasks

15-166

Rogue Access Point Events 15-156
  Configuring a Rogue Access Point Events Report 15-157
  Rogue AP Events Report Results 15-158

Rogue APs 15-158
  Configuring a Rogue APs Report 15-159
  Rogue APs Report Results 15-160

Security Alarm Trending Summary 15-151
  Configuring a Security Alarm Trending Summary Report 15-161
  Security Alarm Trending Summary Report Results 15-162

### Chapter 16

#### Performing Administrative Tasks

16-1

Information About Administrative Tasks 16-1
  Background Tasks 16-2
  Data Management Tasks (Settings) 16-3
  Other Background Tasks 16-4
  Authentication, Authorization, and Accounting (AAA) 16-4
  Auto Provisioning 16-5
    Auto Provisioning Device Management (Auto Provisioning Filter List) 16-5
  High Availability 16-6
  User Preferences 16-7
  License Center 16-8
    WCS License Information 16-8
    WLC Controller License Information 16-9
    WLC Controller License Summary 16-11
    Mobility Services Engine (MSE) License Information 16-12
    Mobility Services Engine (MSE) License Summary 16-14

Performing Background Tasks 16-15
  Performing a Data Collection Task 16-15
    Data Collection Tasks 16-18
  Performing Other Background Tasks 16-19
    Performing a Configuration Sync 16-19
    Viewing Controller Configuration Backup Status 16-21
    Viewing Client Status 16-22
    Updating Controller License Status 16-23
    Viewing Data Cleanup Status 16-25
    Performing Device Data Collection 16-25
    Viewing Device Status 16-26
    Performing Guest Accounts Sync 16-27
    Performing Mobility Service Backup 16-29
<table>
<thead>
<tr>
<th>Task</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Viewing Mobility Service Status</td>
<td>16-30</td>
</tr>
<tr>
<td>Performing Mobility Service Synchronization</td>
<td>16-31</td>
</tr>
<tr>
<td>Viewing OSS Server Status</td>
<td>16-32</td>
</tr>
<tr>
<td>Viewing Wireless Status</td>
<td>16-33</td>
</tr>
<tr>
<td>Performing WCS Server Backup</td>
<td>16-34</td>
</tr>
<tr>
<td>Other Background Tasks</td>
<td>16-36</td>
</tr>
<tr>
<td>Importing Tasks Into ACS</td>
<td>16-40</td>
</tr>
<tr>
<td>Adding WCS to an ACS Server</td>
<td>16-40</td>
</tr>
<tr>
<td>Adding WCS as a TACACS+ Server</td>
<td>16-41</td>
</tr>
<tr>
<td>Adding WCS UserGroups into ACS for TACACS+</td>
<td>16-41</td>
</tr>
<tr>
<td>Adding WCS to an ACS Server for Use with RADIUS</td>
<td>16-43</td>
</tr>
<tr>
<td>Adding WCS UserGroups into ACS for RADIUS</td>
<td>16-44</td>
</tr>
<tr>
<td>Adding WCS to a Non-Cisco ACS Server for Use with RADIUS</td>
<td>16-47</td>
</tr>
<tr>
<td>Configuring Auto Provisioning</td>
<td>16-48</td>
</tr>
<tr>
<td>Adding an Auto Provisioning Filter</td>
<td>16-48</td>
</tr>
<tr>
<td>Editing an Auto Provisioning Filter</td>
<td>16-52</td>
</tr>
<tr>
<td>Deleting Auto Provisioning Filter(s)</td>
<td>16-52</td>
</tr>
<tr>
<td>Listing Auto Provisioning Filter(s) Device Info</td>
<td>16-53</td>
</tr>
<tr>
<td>Listing All Auto Provisioning Filter(s) Device Info</td>
<td>16-54</td>
</tr>
<tr>
<td>Exporting Auto Provisioning Filter(s)</td>
<td>16-54</td>
</tr>
<tr>
<td>Exporting All Auto Provisioning Filter(s)</td>
<td>16-55</td>
</tr>
<tr>
<td>Auto Provisioning Primary Search Key Settings</td>
<td>16-55</td>
</tr>
<tr>
<td>Establishing Logging Options</td>
<td>16-55</td>
</tr>
<tr>
<td>General Logging Options</td>
<td>16-56</td>
</tr>
<tr>
<td>SNMP Logging Options</td>
<td>16-58</td>
</tr>
<tr>
<td>Syslog Options</td>
<td>16-58</td>
</tr>
<tr>
<td>Using Logging Options to Enhance Troubleshooting</td>
<td>16-59</td>
</tr>
<tr>
<td>Configuring Administrative Settings</td>
<td>16-60</td>
</tr>
<tr>
<td>Configuring Alarms</td>
<td>16-60</td>
</tr>
<tr>
<td>Configuring an Audit</td>
<td>16-62</td>
</tr>
<tr>
<td>Audit Mode</td>
<td>16-63</td>
</tr>
<tr>
<td>Audit On</td>
<td>16-64</td>
</tr>
<tr>
<td>Configuring Clients</td>
<td>16-64</td>
</tr>
<tr>
<td>Configuring Protocols for CLI Sessions</td>
<td>16-67</td>
</tr>
<tr>
<td>Configuring Controller Upgrade</td>
<td>16-67</td>
</tr>
<tr>
<td>Configuring Data Management</td>
<td>16-69</td>
</tr>
<tr>
<td>WCS Historical Data</td>
<td>16-69</td>
</tr>
<tr>
<td>Configuring a Guest Account</td>
<td>16-70</td>
</tr>
<tr>
<td>Configuring Login Disclaimer</td>
<td>16-71</td>
</tr>
</tbody>
</table>
Configuring the Mail Server  16-71
Configuring the Notification Receiver  16-73
   Adding a Notification Receiver to WCS  16-74
   Removing a Notification Receiver  16-75
   MIB to WCS alert/event mapping  16-76
Setting Report  16-78
Configuring Server Settings  16-79
Severity Configurations  16-80
SNMP Credentials  16-82
   Viewing Current SNMP Credential Details  16-83
   Adding a New SNMP Credential Entry  16-84
SNMP Settings  16-86
Switch Port Tracing  16-88
   Establishing Switch Port Tracing  16-91
   Switch Port Tracing Details  16-91
   Switch Port Tracing Troubleshooting  16-91
Configuring High Availability  16-92
   Guidelines and Limitations for High Availability  16-93
   Failover Scenario  16-93
   High Availability Status  16-94
   Configuring High Availability on Primary WCS  16-94
   Deploying High Availability  16-96
   Adding a New Primary WCS  16-97
   Removing a Primary WCS  16-97
Setting User Preferences  16-97
Managing Individual Licenses  16-99
   Managing Controller Licenses  16-99
   Managing WCS Licenses  16-100
   Managing MSE Licenses  16-101
Configuring ACS 5.x  16-101
   Creating Network Devices and AAA Clients  16-101
   Adding Groups  16-102
   Adding Users  16-102
   Creating Policy Elements or Authorization Profiles  16-103
      Creating Policy Elements or Authorization Profiles for RADIUS  16-103
      Creating Policy Elements or Authorization Profiles For TACACS  16-104
   Creating Authorization Rules  16-105
      Creating Service Selection Rules for RADIUS  16-105
      Creating Service Selection Rules for TACACS  16-106
## Using On-demand Accuracy Testing to Test Location Accuracy

- Running Voice Diagnostic: 17-11
  - Starting the Voice Diagnostic Test: 17-13
  - Viewing Voice Diagnostic Test Reports: 17-14
    - Summary Tab: 17-14
    - Charts Tab: 17-16
    - Roam History Tab: 17-18
    - Events Tab: 17-19

- Configuring Audit Summary: 17-20
- Configuring Migration Analysis: 17-21
  - Upgrading Autonomous Access Points: 17-22
  - Viewing a Firmware Upgrade Report: 17-22
  - Changing Station Role to Root Mode: 17-22
  - Viewing a Role Change Report: 17-23
  - Running Migration Analysis: 17-23
  - Viewing a Migration Analysis Report: 17-23

- Configuring TAC Case Attachments: 17-23

## Configuring Virtual Domains

- Information About Virtual Domains: 18-1
  - Configuring a Virtual Domain: 18-2
    - Creating a New Virtual Domain: 18-2
  - Understanding Virtual Domain Hierarchy: 18-4
  - Managing a Virtual Domain: 18-7

- Virtual Domain RADIUS and TACACS+ Attributes: 18-10
  - Understanding Virtual Domains as a User: 18-10

## Monitoring Google Earth Maps

- Creating an Outdoor Location Using Google Earth: 19-1
  - Understanding Geographical Coordinates for Google Earth: 19-1
  - Creating and Importing Coordinates in Google Earth (KML File): 19-2
  - Creating and Importing Coordinates as a CSV File: 19-4
    - Importing a File into WCS: 19-5
  - Viewing Google Earth Maps: 19-6
  - Viewing Google Earth Map Details: 19-6
  - Adding Google Earth Location Launch Points to Access Point Pages: 19-7

- Google Earth Settings: 19-8
wIPS Policy Alarm Encyclopedia 20-1

Security IDS/IPS Overview 20-1

Intrusion Detection—Denial of Service Attack 20-2

Denial of Service Attack Against Access Points 20-3

  Denial of Service Attack: Association Flood 20-3
  Denial of Service Attack: Association Table Overflow 20-4
  Denial of Service Attack: Authentication Flood 20-5
  Denial of Service Attack: EAPOL-Start Attack 20-6
  Denial of Service Attack: PS Poll Flood 20-6
  Denial of Service Attack: Unauthenticated Association 20-7

Denial of Service Attack Against Infrastructure 20-8

  Denial of Service Attack: CTS Flood 20-9
  Denial of Service Attack: Queensland University of Technology Exploit 20-9
  Denial of Service attack: RF Jamming 20-10
  Denial of Service: RTS Flood 20-11
  Denial of Service Attack: Virtual Carrier Attack 20-12

Denial of Service Attack Against Client Station 20-13

  Denial of Service Attack: Authentication-Failure Attack 20-14
  Denial of Service Attack: Block ACK 20-15
  Denial of Service Attack: Deauthentication Broadcast Flood 20-16
  Denial of Service Attack: Deauthentication Flood 20-17
  Denial of Service Attack: Disassociation Broadcast Flood 20-19
  Denial of Service Attack: Disassociation Flood 20-20
  Denial of Service Attack: EAPOL-Logoff Attack 20-21
  Denial of Service Attack: FATA-Jack Tool 20-21
  Denial of Service Attack: Premature EAP-Failure 20-23
  Denial of Service Attack: Premature EAP-Success 20-23

Intrusion Detection—Security Penetration 20-24

  Airsnarf Attack 20-25
  Chopchop Attack 20-27
  RDay-0 Attack by WLAN Performance Anomaly 20-28
  Day-0 Attack by WLAN Security Anomaly 20-30
  Day-0 Attack by Device Performance Anomaly 20-31
  Day-0 Attack by Device Security Anomaly 20-32
  Device Probing for APs 20-33
  Dictionary Attack on EAP Methods 20-36
  EAP Attack Against 802.1x Authentication 20-36
  Fake Access Points Detected 20-37
  Fake DHCP Server Detected 20-37
Fast WEP Crack Tool Detected 20-38
Fragmentation Attack 20-39
Hot-Spotter Tool Detected 20-40
Malformed 802.11 Packets Detected 20-42
Man-in-the-Middle Attack 20-42
Monitored Device Detected 20-43
NetStumbler Detected 20-44
NetStumbler Victim Detected 20-45
Publicly Secure Packet Forwarding (PSPF) Violation Detected 20-46
ASLEAP Tool Detected 20-47
Honey Pot AP Detected 20-48
Soft AP or Host AP Detected 20-49
Spoofed MAC Address Detected 20-49
Suspicious After-Hours Traffic Detected 20-50
Unauthorized Association by Vendor List 20-50
Unauthorized Association Detected 20-51
Wellenreiter Detected 20-52

Troubleshooting Cisco Compatible Extensions Version 5 Client Devices A-1
   Diagnostic Channel A-1
   Configuring the Diagnostic Channel A-2

Web Auth Security on WLANs A-3
   Debug Commands A-4
   Debug Strategy A-4
   Best Practices A-8

Rogue AP Background Task Performance Tuning A-9

WCS Licenses B-1
   Types of Licenses B-1
   Licensing Enforcement B-2
   Product Authorization Key Certificate B-3
   Determining Which License To Use B-3
   Installing a License B-4
   Backup and Restore License B-4

Notices and Disclaimers B-5

Notices B-5
   OpenSSL/Open SSL Project B-5
   License Issues B-5

Disclaimers B-7

End-User License Agreement B-7

Supported Hardware C-2
Cisco WLSE Management Stations C-2
Autonomous Access Points Convertible to LWAPP C-2
Installation and Configuration C-2
  Installing Cisco WCS C-2
  Upgrading to Red Hat Enterprise Linux 4 or 5 C-3
Minor Upgrades to WCS C-3
Configuring the Converted Appliance C-4
Licensing C-7
  WLSE Upgrade License C-7
Running WCS as Non-Privileged Account D-1
  Creating a Non-Privileged User D-1
Tomcat Shutdown Prevention D-10
WCS Password Handling D-10
Setting Up SSL Certification D-11
  Setting Up SSL Client Certification D-11
  Setting Up SSL Server Certification D-12
Preface

The preface provides an overview of the *Cisco Wireless Control System Configuration Guide, Release 7.0*, references related publications, and explains how to obtain other documentation and technical assistance, if necessary. This chapter contains the following sections:

- Audience, page xlix
- Purpose, page xlix
- Conventions, page xlix
- Related Publications, page 1
- Obtaining Documentation and Submitting a Service Request, page 1

Audience

This guide describes the Cisco Wireless Control System (WCS). It is meant for networking professionals who uses WCS to manage a Cisco Unified Wireless Network Solution. To use this guide, you should be familiar with the concepts and terminology associated with wireless LANs.

Purpose

This guide provides the information you need to manage a Cisco Unified Wireless Network Solution using WCS.

*Note* This guide pertains specifically to WCS Release 7.0. Earlier versions of WCS software may look and operate somewhat differently.

Conventions

This publication uses the following conventions to convey instructions and information:

- Commands and keywords are in **boldface** text.
- Variables are in *italicized* text.
- Examples depict screen displays and the command-line in `screen` font.
• Information you need to enter in examples is shown in boldface screen font.

Note
Means reader take note. Notes contain helpful suggestions or references to material not contained in the manual.

Caution
Means reader be careful. In this situation, you might do something that could result in equipment damage or loss of data.

Related Publications
For more information about WCS and related products, see the following website:
http://www.cisco.com/cisco/web/psa/default.html

Obtaining Documentation and Submitting a Service Request
For information on obtaining documentation, submitting a service request, and gathering additional information, see the monthly What’s New in Cisco Product Documentation, which also lists all new and revised Cisco technical documentation, at:
Subscribe to the What’s New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free service and Cisco currently supports RSS version 2.0.
Cisco WCS Overview

This chapter describes the Cisco Unified Wireless Network Solution (CUWNS) and the Cisco WCS. This chapter contains the following sections:

- The Cisco Unified Wireless Network Solution, page 1-1
- The WCS, page 1-2
- WCS Versions, page 1-3
- Embedded Access Points, page 1-7
- Access Point Communication Protocols, page 1-9
- WCS Navigator, page 1-10
- WCS User Interface, page 1-11

The Cisco Unified Wireless Network Solution

The Cisco Unified Wireless Network solution provides 802.11 wireless networking solutions for enterprises and service providers. It simplifies the deployment and management of large-scale wireless LANs and enables you to create a unique best-in-class security infrastructure. The operating system manages all data client, communications, and system administration functions, performs radio resource management (RRM) functions, manages system-wide mobility policies using the operating system security solution, and coordinates all security functions using the operating system security framework.

The Cisco Unified Wireless Network Solution consists of Cisco Unified Wireless Network Controllers (hereafter called controllers) and their associated lightweight access points controlled by the operating system, all concurrently managed by any or all of the operating system user interfaces:

- An HTTPS full-featured web user interface hosted by Cisco controllers can be used to configure and monitor individual controllers.
- A full-featured command-line interface (CLI) can be used to configure and monitor individual controllers.
- WCS can be used to configure and monitor one or more controllers and associated access points. WCS has tools to facilitate large-system monitoring and control. It runs on Windows 2003 and Red Hat Enterprise Linux ES/AS 5.X servers.
- An industry-standard SNMP V1, V2c, and V3 interface can be used with any SNMP-compliant third-party network management system.
The Cisco Unified Wireless Network Solution supports client data services, client monitoring and control, and all rogue access point detection, monitoring, and containment functions. It uses lightweight access points, controllers, and the optional WCS to provide wireless services to enterprises and service providers.

Note

Unless specified otherwise, information pertaining to controllers applies to all Cisco Unified Wireless Network Controllers, including but not limited to Cisco 2000 and 2100 Series Unified Wireless Network Controllers, Cisco 4100 Series Unified Wireless Network Controllers, Cisco 4400 Series Unified Wireless Network Controllers, Cisco 5500 Series Wireless LAN Controllers, and controllers within the Cisco Wireless Services Module (WiSM) and Cisco 26/28/37/38xx Series Integrated Services Routers.

Figure 1-1 shows the Cisco Unified Wireless Network Solution components, which can be simultaneously deployed across multiple floors and buildings.

Figure 1-1 Cisco Unified Wireless Network Solution

The WCS

The Cisco Wireless Control System (WCS) is a Cisco Wireless LAN Solution network management tool that adds to the capabilities of the Web User Interface and the command-line interface (CLI). WCS enables you to manage a network of controllers.

In Windows and Linux, Cisco WCS is installed as a service. The service runs continuously and resumes after a reboot.
To receive the expected results with WCS, you should run no more than 3 concurrent WCS setups for standard server use (4 GB memory and 3 GHz CPU speed) and no more than 5 concurrent WCS setups for high-end server use (8 GB memory and 3 GHz CPU speed).

WCS enables you to configure and monitor one or more controllers and associated access points. WCS includes the same configuration, performance monitoring, security, fault management, and accounting options used at the controller level and adds a graphical view of multiple controllers and managed access points.

WCS runs on Windows 2003/SP2, Windows 2003 R2/SP2 32-bit installations, and Red Hat Linux Enterprise Server 5.X 32-bit installations. On both Windows and Linux, WCS runs as a service, which runs continuously and resumes running after a reboot.

You must use Internet Explorer 7.0 or later to control all permitted Cisco Unified Wireless Network Solution configuration, monitoring, and control functions through Internet Explorer 7.0 with the Flash plugin, or Mozilla Firefox 3.5 or later. The administrator defines permissions from the Administration menu, which also enables the administrator to manage user accounts and schedule periodic maintenance tasks.

We strongly advice that you do not enable third-party browser extensions. In Internet Explorer, you can disable third-party browser extensions by choosing Tools > Internet Options and unselecting the Enable third-party browser extensions check box on the Advanced tab.

WCS simplifies controller configuration and monitoring and reduces data entry errors. WCS uses the industry-standard SNMP protocol to communicate with the controllers.

WCS also includes the Floor Plan editor which allows you to do the following:
- Vectorize bitmapped campus, floor plan, and outdoor area maps.
- Add and change wall types.
- Import the vector wall format maps into the database.

The vector files allow the Cisco WCS RF Prediction Tool to make better RF predictions based on more accurate wall and window RF attenuation values.

This section contains the following topics:
- WCS Versions, page 1-3
- Embedded Access Points, page 1-7
- Access Point Communication Protocols, page 1-9
- WCS Navigator, page 1-10
- WCS User Interface, page 1-11

**WCS Versions**

You can install WCS with one of two capabilities: WCS Base or WCS Location. A license is required for both. This section contains the following topics:
- WCS Base, page 1-4
WCS Base

The WCS Base supports wireless client data access, rogue access point detection, and rogue ad hoc detection and containment functions (such as on-demand location of rogue access points that are mapped next to the detecting access point), and Cisco UWN Solution monitoring and control.

It also includes graphical views of the following:

- Autodiscovery of access points as they associate with controllers
- Autodiscovery and containment or notification of rogue access points
- Map-based organization of access point coverage areas, which is helpful when the enterprise spans more than one geographical area
- Ad hoc rogue detection
- User-supplied campus, building, and floor plan graphics, which show the following:
  - Locations and status of managed access points
  - Locations of rogue access points based on the signal strength received by the nearest managed Cisco access points
  - Coverage hole alarm information for access points based on the received signal strength from clients. This information appears in a table rather than map format.
  - RF coverage maps

The WCS Base also provides system-wide control of the following:

- Streamlined network, controller, and managed access point configuration using customer-defined templates
- Network, controller, and managed access point status and alarm monitoring
- Automated and manual data client monitoring and control functions
- Automated monitoring of rogue access points, rogue ad hoc events, coverage holes, security violations, controllers, and access points
- Full event logs for data clients, rogue access points, coverage holes, security violations, controllers, and access points
- Automatic channel and power level assignment by radio resource management (RRM)
- User-defined automatic controller status audits, missed trap polling, configuration backups, and policy cleanups
- Real-time location of rogue access points and rogue ad hoc events to the nearest Cisco access point
- Real-time and historical location of clients to the nearest Cisco access point

WCS Base + Location

WCS Location includes all the features of WCS Base as well as these enhancements:
• On-demand location of rogue access points and rogue ad hoc events to within 33 feet (10 meters)
• On-demand location of clients to within 33 feet (10 meters)
• Ability to use location appliances to collect and return historical location data viewable in the WCS Location user interface

### Enabling Mobility Services and HA with WCSPLUS License

A Cisco WCS PLUS license supports Cisco WCS base license features and the following capabilities:

- Location services
- High availability

A Cisco WCS PLUS license is backward compatible to existing Cisco WCS location and enterprise licenses. The process to provision a Cisco WCS PLUS license is the same as provisioning a current Cisco WCS license. A PLUS license is required to enable mobility services engines which are launched with the Motion campaign.

### Using WCS Cisco Location Appliances

When WCS Location is used, you can also deploy Cisco 2700 Series Location Appliances. The location appliance enhances WCS Location capabilities by computing, collecting, and storing historical location data, which can be displayed in WCS. In this role, the location appliance acts as a server to a WCS server by collecting, storing, and passing on data from its associated controllers.

When WCS is enhanced with a location appliance, it can display historical location data for up to 2,500 laptop clients, palmtop clients, VoIP telephone clients, radio frequency identifier (Wi-Fi tags) asset tags, rogue access points, rogue ad hoc events, and rogue clients for each location appliance in the Cisco Unified Wireless Network Solution. You can configure location appliances to collect this data and statistics at defined intervals.

You can also use WCS to configure location appliance event notification parameters. Event notification is a feature that enables you to define conditions that cause the location appliance to send notifications to the listeners that you specify in WCS.

In this way, WCS acts as a notification listener. It receives notifications from the location appliance in the form of the locationNotifyTrap trap as part of the bsnwras.my MIB file. WCS translates the traps into user interface alerts and displays the alerts in the following format:

**Absence:**
- Absence of Tag with MAC 00:0c:cc:5b:e4:1b, last seen at 16:19:45 13 Apr 2010.

**Containment:**
- Tag with MAC 00:0c:cc:5b:fa:44 is In the Area 'WNBU > WNBU > 4th Floor > wcsDevArea'

**Distance:**
- Tag with MAC 00:0c:cc:5b:fa:47 has moved beyond the distance configured for the marker 'marker2'.
- Tag with MAC 00:0c:cc:5b:f9:b9 has moved beyond 46.0 ft. of marker 'marker2', located at a range of 136.74526528595058 ft.

---

**Note**

See the Cisco Location Application Configuration Guide for more detailed information about the location appliance and its use with WCS.
The location appliance can be backed up to any WCS server into an operator-defined FTP folder, and the location appliance can be restored from that server at any time and at defined intervals. Also, the location appliance database can be synchronized with the WCS server database at any time. Operators can use the location appliance features and download new application code to all associated appliances from any WCS server.
Comparison of WCS Base and WCS Location Features

Table 1-1  WCS Base and WCS Location Features

<table>
<thead>
<tr>
<th>Features</th>
<th>WCS Base</th>
<th>WCS Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Location and tracking</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Low-resolution client location</td>
<td>Yes</td>
<td>—</td>
</tr>
<tr>
<td>High-resolution client location</td>
<td>—</td>
<td>Yes</td>
</tr>
<tr>
<td>Integration with location appliance</td>
<td>—</td>
<td>Yes</td>
</tr>
<tr>
<td>Low-resolution rogue access point location</td>
<td>Yes</td>
<td>—</td>
</tr>
<tr>
<td>High-resolution rogue access point location</td>
<td>—</td>
<td>Yes</td>
</tr>
<tr>
<td>Client data services, security, and monitoring</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Client access via access points</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Multiple wireless LANs (individual SSIDs and policies)</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Rogue access point detection and containment using access points</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>802.11a/b/g/n bands</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Radio resource management</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Real-time channel assignment and rogue access point detection and containment</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Real-time interference detection and avoidance, transmit power control, channel assignment, client mobility management, client load distribution, and coverage hole detection</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Automated software and configuration updates</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Wireless intrusion protection</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Global and individual Access Point security policies</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Controls Cisco Unified Wireless Network Controllers</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Supported workstations</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows 2003</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Red Hat Enterprise Linux ES 5.1</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Mozilla Firefox 2.0.0.11 or later</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

Embedded Access Points

WCS software Release 5.2 or later supports the AP801, which is the integrated access point on the Cisco 800 Series Integrated Services Routers (ISRs). WCS software Release 7.0.172.0 or later supports the AP802, which is the integrated access point on the Next Generation Cisco 880 Series Integrated Services Routers (ISRs). These access points use a Cisco IOS software image that is separate from the router Cisco IOS software image. It can operate as an autonomous access point that is configured and managed.
Embedded Access Points

locally, or it can operate as a centrally managed access point using CAPWAP or LWAPP protocol. The AP801 and AP802 are preloaded with both an autonomous Cisco IOS release and a recovery image for the unified mode.

When you want to use the AP801 or AP802 with a controller, you must enable the recovery image for the unified mode on the access point by entering this CLI command on the router in privileged EXEC mode: `service-module wlan-ap 0 bootimage unified`.

**Note**
If the `service-module wlan-ap 0 bootimage unified` command does not work, make sure that the software license is still current.

After enabling the recovery image, enter this CLI command on the router to shut down and reboot the access point: `service-module wlan-ap 0 reload`. After the access point reboots, it discovers the controller, downloads the full CAPWAP or LWAPP software release from the controller, and acts as a lightweight access point.

**Note**
To use the CLI commands mentioned previously, the router must be running Cisco IOS Release 12.4(20)T or later. If you experience any problems, refer to the “Troubleshooting an Upgrade or Reverting the AP to Autonomous Mode” section in the Integrated Services Router configuration guide at this URL:


To support CAPWAP or LWAPP, the router must be activated with at least the Cisco Advanced IP Services IOS license-grade image. A license is required to upgrade to this Cisco IOS image on the router. See this URL for licensing information:


After the AP801 or the AP802 boots up with the recovery image for the unified mode, it requires an IP address to communicate with the controller and to download its unified image and configuration from the controller. The router can provide DHCP server functionality, the DHCP pool to reach the controller, and setup option 43 for the controller IP address in the DHCP pool configuration. Use the following configuration to perform this task.

```config
ip dhcp pool pool_name
    network ip_address subnet_mask
    dns-server ip_address
    default-router ip_address
    option 43 hex controller_ip_address_in_hex

Example:
ip dhcp pool embedded-ap-pool
    network 209.165.200.224 255.255.255.224
    dns-server 209.165.200.225
    default-router 209.165.200.226
    option 43 hex f104.0a0a.0a0f /* single WLC IP address (209.165.201.0) in hex format */
```

The AP801 and the AP802 802.11n radios support lower power levels than the 802.11n radio in the Cisco Aironet 1250 series access points. The AP801 and the AP802 store the radio power levels and passes them to the controller when the access point joins the controller. The controller uses the supplied values to limit the user configuration.

The AP801 and the AP802 can be used in hybrid-REAP mode. See the “Configuring Hybrid REAP” section on page 13-1 for more information on hybrid REAP.
Access Point Communication Protocols

In controller software release 5.2 or later, Cisco lightweight access points use the IETF standard Control and Provisioning of Wireless Access Points Protocol (CAPWAP) to communicate between the controller and other lightweight access points on the network. Controller software releases prior to 5.2 use the Lightweight Access Point Protocol (LWAPP) for these communications.

CAPWAP, which is based on LWAPP, is a standard, interoperable protocol that enables a controller to manage a collection of wireless access points. CAPWAP is being implemented in controller software release 5.2 for these reasons:

- To provide an upgrade path from Cisco products that use LWAPP to next-generation Cisco products that use CAPWAP
- To manage RFID readers and similar devices
- To enable controllers to interoperate with third-party access points in the future

LWAPP-enabled access points are compatible with CAPWAP, and conversion to a CAPWAP controller is seamless. For example, the controller discovery process and the firmware downloading process when using CAPWAP are the same as when using LWAPP. The one exception is for Layer 2 deployments, which are not supported by CAPWAP.

Deployments can combine CAPWAP and LWAPP software on the controllers. The CAPWAP-enabled software allows access points to join either a controller running CAPWAP or LWAPP. The only exception is the Cisco Aironet 1140 Series Access Point, which supports only CAPWAP and therefore joins only controllers running CAPWAP.

This section contains the following topics:

- Guidelines and Restrictions for Using CAPWAP, page 1-9
- The Controller Discovery Process, page 1-10

Guidelines and Restrictions for Using CAPWAP

- CAPWAP and LWAPP controllers cannot be used in the same mobility group. Therefore, client mobility between CAPWAP and LWAPP controllers is not supported.
- If your firewall is currently configured to allow traffic only from access points using LWAPP, you must change the rules of the firewall to allow traffic from access points using CAPWAP.
- Make sure that the CAPWAP ports are enabled and are not blocked by an intermediate device that could prevent an access point from joining the controller.
- Any access control lists (ACLs) in your network might need to be modified if CAPWAP uses different ports than LWAPP.

**The Controller Discovery Process**

In a CAPWAP environment, a lightweight access point discovers a controller by using CAPWAP discovery mechanisms and then sends it a CAPWAP join request. The controller sends the access point a CAPWAP join response allowing the access point to join the controller. When the access point joins the controller, the controller manages its configuration, firmware, control transactions, and data transactions.

Lightweight access points must be discovered by a controller before they can become an active part of the network. The lightweight access points support these controller discovery processes:

- Layer 3 CAPWAP or LWAPP discovery—Can occur on different subnets from the access point and uses IP addresses and UDP packets rather the MAC addresses used by Layer 2 discovery.
- Over-the-air provisioning (OTAP)—This feature is supported by Cisco 4400 series controllers. If this feature is enabled on the controller (in the controller General page), all associated access points transmit wireless CAPWAP or LWAPP neighbor messages, and new access points receive the controller IP address from these messages. This feature is disabled by default and should remain disabled when all access points are installed.
- Locally stored controller IP address discovery—If the access point was previously associated to a controller, the IP addresses of the primary, secondary, and tertiary controllers are stored in the non-volatile memory of an access point. This process of storing controller IP addresses on access points for later deployment is called **priming the access point**.
- DHCP server discovery—This feature uses DHCP option 43 to provide controller IP addresses to the access points. Cisco switches support a DHCP server option that is typically used for this capability.
- DNS discovery—The access point can discover controllers through your domain name server (DNS). For the access point to do so, you must configure your DNS to return controller IP addresses in response to CISCO-CAPWAP-CONTROLLER.localdomain or CISCO-LWAPP-CONTROLLER.localdomain, where localdomain is the access point domain name. When an access point receives an IP address and DNS information from a DHCP server, it contacts the DNS to resolve CISCO-CAPWAP-CONTROLLER.localdomain or CISCO-LWAPP-CONTROLLER.localdomain. When the DNS sends a list of controller IP addresses, the access point sends discovery requests to the controllers.

**WCS Navigator**

The Cisco Wireless Control System Navigator (Cisco WCS Navigator) manages multiple Cisco WCSs (running the same version as Navigator) and provides a unified view of the network. It uses SOAP/XML over HTTPs to communicate with individual WCSs. With WCS Navigator, there is monitoring functionality and reporting capability across all WCSs. In addition, network wide searches are available. In Windows and Linux, Cisco WCS Navigator runs as a service, which runs continuously and resumes running after a reboot.
In order for the WCS Navigator to detect the regional WCSs, you must manually add them to the system using either the IP address or hostname and specify the login credentials for each of the regional WCSs. After being added, WCS Navigator provides summary information and links to the regional WCS systems.

**Cisco WCS Location**

In addition to the basic features, Cisco WCS Location adds the following enhancements:

- On-demand location of rogue access points and adhoc rogues to within 10 meters.
- On-demand location of clients to within 10 meters.
- Ability to use location appliances to collect and return historical location data viewable in the Cisco WCS Location user interface.

**WCS User Interface**

The WCS user interface enables the network operator to create and configure Cisco Unified Wireless Network Solution coverage area layouts, configure system operating parameters, monitor real-time Cisco Unified Wireless Network Solution operation, and perform troubleshooting tasks using an HTTPS web browser page. The WCS user interface also enables the WCS administrator to create, modify, and delete user accounts; change passwords; assign permissions; and schedule periodic maintenance tasks. The administrator creates new usernames and passwords and assigns them to predefined permissions groups.

**Menu Bar**

The following menus are available consistently across WCS: Monitor, Reports, Configure, Services, Administration, Tools, and Help. Hover your mouse cursor over any menu to access its drop-down options.

**Monitor Menu**

The Monitor menu provides you with a top-level description of your network devices. The following submenu options are available from the Monitor menu:

- Monitoring Maps
- Monitoring Google Earth Maps
- Monitoring Controllers
- Monitoring Access Points
- Monitoring Clients
- Monitoring Tags
- Monitoring Chokepoints
- Monitoring Interferers
- Monitoring WiFi TDOA Receivers
- Monitoring Spectrum Experts
• Monitoring Media Streams
• Monitoring Radio Resource Management (RRM)
• Monitoring Alarms
• Monitoring Events

Reports Menu

The Reports menu provides the following submenu options:
• Report Launch Pad
• Managing Scheduled Run Results
• Managing Saved Reports

Configure Menu

The Configure menu enables you to configure your network templates, controllers, and access points.
The following submenu options are available from the Configure drop-down menu:
• Configuring Controllers
• Configuring Access Points
• Configuring Ethernet Switches
• Configuring Chokepoints
• Configuring Spectrum Experts
• Configuring WiFi TDOA Receivers
• Accessing Controller Template Launch Pad
• Configuring Controller Config Groups
• Configuring Auto Provisioning
• Configuring AP Configuration Templates
• Configuring Autonomous AP Migration Templates
• Configuring Scheduled Configuration Tasks
• Configuring wIPS Profiles
• Configuring ACS View Servers
• Configuring TFTP Servers

Services Menu

The Services menu enables you to manage mobility services including mobility services engines and location servers.
The following submenu options are available from the Services drop-down menu:
• Mobility Services
• Synchronizing Services
• Viewing Synchronization History
• Viewing Notification Statistics
Note
Read/Write permissions are used by the location function of the location server. Write permissions allow a client application or location server operator to modify location data only (such as asset information), while Read permissions only allow a client to read location data.

Note
Full permissions are required for administration. All functions under the Locate menu in WCS are administrative functions, which means the administrator must always have full permissions.

Administration Menu
The Administration menu allows you to schedule tasks such as scheduling a backup, checking a device status, auditing your network, and synchronizing mobility services.

The following submenu options are available from the Administration drop-down menu:

- Background Tasks
- Authentication, Authorization, and Accounting (AAA)
- Configuring Virtual Domains
- Data Management Tasks (Settings)
- High Availability
- User Preferences
- License Center

Tools
The Tools menu provides access to the Voice Audit, Configuration Audit, and Migration Analysis features of WCS.

The following submenu options are available from the Tools drop-down menu:

- Voice Audit
- Location Accuracy Tool
- Running Voice Diagnostic
- Configuring Audit Summary
- Configuring Migration Analysis
- Configuring Migration Analysis

Help
The Help menu allows you to access online help, learning modules, submit feedback, and to verify the current version of WCS.

The following submenu options are available from the Help drop-down menu:

- Online Help
- Learning Modules
- Submit Feedback
- Product Improvement Program
WCS User Interface

Chapter 1  Cisco WCS Overview

• About Cisco WCS

To verify the version of WCS, choose About Cisco WCS. The following information is displayed:

• Product Name
• Version Number
• Host Name
• Feature
• AP Limit
• License Type
• Copyright statement

Floor Plan Editor

The Floor Plan editor:

• Converts architectural, mechanical, and technical drawings, graphics, and maps from raster bitmaps to wall (vector) formats.

The vector files allow the WCS RF Prediction Tool to make improved RF predictions based on access point signal strength and accurate wall, window, and cubicle RF attenuation.

• Allows operators to scan and digitize paper drawings into supported file formats.

The quality of floor plan editor recognition is higher for higher resolution data. Use 400 to 600 dots per inch (dpi) scans whenever possible.

• Automatically recognizes and represents data in a wall format which can then be imported into the Cisco WCS program.

Note

The output wall files can be saved as .DXF (AutoCAD), .AI (Adobe Illustrator), .EMF (enhanced metafile), .WMF (Windows metafile), and .TXT (ASCII XY) but Cisco WCS does not recognize these file types.

• Allows the editing of existing vector map files.

Note

There are no restrictions on the input or output image size.

Note

Images with the long axis horizontal (landscape format) are recommended to ensure quality viewing in the Cisco WCS.

Cisco Wireless LAN Controller Autodiscovery

Controller Autodiscovery is limited to the Cisco WLAN Solution mobility group subnets defined by the operator.

Autodiscovery:

• Allows operators to search for a single controller by IP address.
• Finds the controller on the network within the specified IP address range.
• Automatically enters the controller information into the Cisco WCS database.

**Note**
Controller Autodiscovery can take a long time in a Class C address range. Because of the large number of addresses in a Class B or Class A range, we recommend that you do not attempt Autodiscovery across Class B or Class A ranges.

As access points associate with a controller, the controller immediately transmits the access point information to Cisco WCS, which automatically adds the access point to the database.

Once the access point information is added to the Cisco WCS database, operators can add the access point to the appropriate spot on a Cisco WCS user interface map.

### Cisco WCS Location Calibration

The Cisco WCS calibration tool:

• Allows operators to accurately measure actual signal strength and attenuation in RF coverage areas which creates an accurate calibration model in the Cisco WCS database.
• Allows more precise client and rogue access point location after calibration is completed.
• Can be reused for areas with an identical access point layout and identical wall layout.

The calibration tool allows a technician to use a WCS-equipped laptop to measure actual signal strength and process the collected data points for multiple floor and outdoor locations.

See the “Managing RF Calibration Models” section on page 5-63 to view the current calibration models.

### Cisco 2700 Series Location Appliances

The location appliance acts as a server to one or more Cisco WCS Servers by collecting, storing, and relaying data from associated controllers. This data can be displayed in a Cisco WCS.

After a quick command-line interface (CLI) configuration, the remaining location appliance configuration can be completed using the Cisco WCS interface.

After configuration, each location appliance communicates directly with its associated controllers to collect operator-defined location data. The associated Cisco WCS Server operators can then communicate with each location appliance to transfer and display selected data.

The location appliance can be backed up to any Cisco WCS Server into an operator-defined FTP folder and the location appliance can be restored from that Cisco WCS Server at any time and at defined intervals. Also, the location appliance database can be synchronized with the Cisco WCS Server database at any time.

Operators can use the location appliance features and download new application code to all associated location appliances from any Cisco WCS Server.

When Cisco WCS is enhanced with a location appliance, Cisco WCS can display historical location data for up to 1,500 Laptop Clients, Palmtop Clients, VoIP Telephone Clients, RFID (Radio Frequency IDentifier) Asset Tags, Rogue Access Points, Adhoc Rogues, and Rogue Access Point Clients for each location appliance in the Cisco WLAN Solution.

Operators can configure location appliances to collect data for Cisco WLAN Solution clients, rogue access points and clients, RFID Asset Tags, and statistics at separate operator-defined intervals.
The location appliance uses two redundant back-panel 10/100/1000BASE-T ports to connect to one or two network segments. It also features a back-panel power cord and front-panel ON/OFF switch. The location appliance includes a back-panel DB-9 console port for initial configuration using a CLI console.

**Note** Each location appliance can be installed in any NOC (Network Operations Center) or wiring closet from which it can communicate with its associated Cisco WCS Server(s) and controllers.
Getting Started

This chapter describes how to prepare Cisco WCS for operation. It contains the following sections:

- Prerequisites, page 2-1
- System Requirements, page 2-2
- Installing WCS for Windows, page 2-6
- Installing WCS for Linux, page 2-13
- Starting WCS, page 2-15
- Logging into the WCS User Interface, page 2-16
- Customizing Home Page Tabs, page 2-23
- Using the Cisco WCS User Interface, page 2-29
- Using the Search Feature, page 2-34

Prerequisites

Before installing the Cisco WCS, ensure that you have completed the following:

- Meet the necessary hardware and software requirements as listed in the “System Requirements” section on page 2-2 for Cisco WCS.
- Update your system with the necessary critical updates and service packs.

**Note**  
See the latest release notes for information on the service packs and patches required for correct operation of Cisco WCS.

- To receive the expected results, you should run no more than 3 concurrent WCS setups for standard server use (4 GB memory and 3 GHz CPU speed) and no more than 5 concurrent WCS setups for high-end server use (8 GB memory and 3 GHz CPU speed).
- Verify that the following ports are open during installation and startup:
  - HTTP: configurable during install (80 by default)
  - HTTPS: configurable during install (443 by default)
  - 1315
  - 1299
System Requirements

Cisco WCS can be run on a workstation/server class system and access points can be distributed unevenly across controllers. The following requirements must be met for the different components. This section contains the following topics:

- High-End Server, page 2-2
- Standard Server, page 2-3
- Low-End Server, page 2-4
- Supported Operating Systems, page 2-5
- Client Requirements, page 2-5
- Supported WLC Releases, page 2-5
- WCS on WLSE, page 2-6
- WCS Navigator, page 2-6

High-End Server

- Up to 3000 Cisco Aironet lightweight access points, 1250 standalone access points, and 750 Cisco wireless LAN controllers.
- 3.16-GHz Intel Xeon or Quad processor.
- 8-GB RAM.
- 200-GB minimum free disk space on your hard drive.

Note

The free disk space listed is a minimum requirement but may be different for your system, depending on the number of backups.
Unified Computing System

**Note**  The following Cisco Unified Computing System (UCS) C-Series servers provide guidance to plan your system requirements for either UCS or equivalent hardware platform. Any server can be used if it meets the minimum requirements.

### Cisco UCS C-Series M1 Server

The following are the recommended specifications for the Cisco UCS C-Series M1 Server, but you can choose higher processing capabilities:

- One Intel Xeon 5500 series processor X5570 (4-core 2.93-GHz).

**Note**  If your processor speed is less than the one mentioned above, we recommend you to use two processors.

- 8-GB RAM.
- 200-GB minimum free disk space on your hard drive.

### Cisco UCS C-Series M2 Server

The following are the recommended specifications for the Cisco UCS C-Series M2 Server, but you can choose higher processing capabilities:

- One Intel Xeon 5600 series processor X5680 (6-core 3.33-GHz) or one Intel Xeon 5600 series processor X5670 (6-core 2.93-GHz).
- 8-GB RAM.
- 200-GB minimum free disk space on your hard drive.

### Standard Server

- Up to 2000 Cisco Aironet lightweight access points, 1000 standalone access points, and 450 wireless LAN controllers.
- 3.2-GHz Intel Dual Core processor.
- 2.13-GHz Intel Quad Core X3210 processor.
- 2.16-GHz Intel Core2 processor.
- 4 GB of RAM.
- 80-GB minimum free disk space on your hard drive.

Unified Computing System

**Note**  The following Cisco Unified Computing System (UCS) C-Series servers provide guidance to plan your system requirements for either UCS or equivalent hardware platform. Any server can be used if it meets the minimum requirements.
Cisco UCS C-Series M1 Server

The following are the recommended specifications for the Cisco UCS C-Series M1 Server, but you can choose higher processing capabilities:

- One Intel Xeon 5500 series processor X5570 (4-core 2.93-GHz) or one Intel Xeon 5500 series processor X5550 (4-core 2.66-GHz) or one Intel Xeon 5500 series processor E5540 (4-core 2.53-GHz).
- 4 GB of RAM.
- 80-GB minimum free disk space on your hard drive.

Cisco UCS C-Series M2 Server

The following are the recommended specifications for the Cisco UCS C-Series M2 Server, but you can choose higher processing capabilities:

- One Intel Xeon 5600 series processor X5650 (6-core 2.66-GHz) or one Intel Xeon 5600 series processor X5670 (6-core 2.93-GHz).
- 4 GB of RAM.
- 80-GB minimum free disk space on your hard drive.

Low-End Server

- Up to 500 Cisco Aironet lightweight access points, 200 standalone access points, and 125 Cisco wireless LAN controllers.
- 3.06-GHz Intel processor.
- 1.86-GHz Intel Dual core processor.
- 2 GB of RAM.
- 50-GB minimum free disk space on your hard drive.

Unified Computing System

Note

The following Cisco Unified Computing System (UCS) C-Series servers provide guidance to plan your system requirements for either UCS or equivalent hardware platform. Any server can be used if it meets the minimum requirements.

Cisco UCS C-Series M1 Server

The following are the recommended specifications for the Cisco UCS C-Series M1 Server, but you can choose higher processing capabilities:

- One Intel Xeon 5500 series processor X5550 (4-core 2.66-GHz).
- 2 GB of RAM.
- 50-GB minimum free disk space on your hard drive.
Cisco UCS C-Series M2 Server

The following are the recommended specifications for the Cisco UCS C-Series M2 Server, but you can choose higher processing capabilities:

- One Intel Xeon 5600 series processor X5650 (6-core 2.66-GHz).
- 2 GB of RAM.
- 50-GB minimum free disk space on your hard drive.

Supported Operating Systems

The following operating systems are supported:

  Windows 2003/SP2 64-bit installations are not supported.
  Windows 2003 32-bit installations provide support for up to 64 GB of RAM provided Physical Address Extension (PAE) is enabled. See Windows documentation for instructions on enabling this mode.
- Red Hat Linux Enterprise Server 5.X 32-bit operating system installations.
  Red Hat Linux Enterprise Server 5.X 64-bit operating system installations are not supported.
- Microsoft Windows Server 2003 and Red Hat Linux version support on VMware ESX version 3.0.1 and above with either local storage or SAN over fiber channel.

**Note** Individual operating systems running WCS in VMware must follow the specifications for the size of WCS you intend to use.

Client Requirements

The Cisco WCS user interface requires Internet Explorer 7.0 or later with the 9.0.X or later Flash plugin, or Mozilla Firefox 3 or 3.5. We recommend Mozilla Firefox 3.5 for best performance.

Browsing on Windows 2003 Cisco WCS servers is not recommended because recommended Windows 2003 security settings cause browsing problems.

The client running the browser must have a minimum of 1 GB of RAM and a 2-GHz processor. The client device should not be running any CPU or memory-intensive applications.

**Note** The screen resolution should be set to 1024 x 768 pixels for both WCS and Navigator.

Supported WLC Releases

Cisco WCS 7.0 can manage the following releases of the WLC as found on various controllers (such as 2106, 4400 series, WiSM, and so on):

- 4.2
- 5.2
Installing WCS for Windows

- 6.0
- 7.0

**Note**  See the release notes (http://www.cisco.com/en/US/products/p6305/prod_release_notes_list.html) for the exact version numbers.

**WCS on WLSE**

- Up to 1500 Cisco Aironet lightweight access points and 100/375 Cisco wireless LAN controllers.
- 3-GHz Intel Pentium4 processor with 3 GB of RAM.
- 38 GB of free space on your hard drive.

**WCS Navigator**

- Up to 20 WCSs
- Up to 30,000 access points

**Installing WCS for Windows**

Before installing Cisco WCS, refer to the “Prerequisites” section on page 2-1 and the “System Requirements” section on page 2-2. You must have administrator privileges on Windows. If you receive a message that a previous version of WCS was detected, you must continue with one of two upgrade options. See the “Upgrading WCS” section on page 4-15.

If installing WCS for Linux, see the “Installing WCS for Linux” section on page 2-13.

**Before You Begin**

- You cannot install the WCS software if the username used to log into the server contains special characters such as exclamation marks (!). To ensure successful installation, log into the server using a username with no special characters before installing the software.
- Cisco WCS does not support the underscore character (_) in the name of the Windows server running the WCS software. If the server name contains an underscore, you can install the WCS software, but WCS fails to start.
- You must install WCS on a dedicated Windows server with no other services running (including those running as primary or secondary domain controllers) to avoid conflict with WCS.
- No hard-coded limits exist regarding the number of users or the type of user activities, but a heavy memory and CPU load on the server may affect functionality.
- Provide the WCS installation rights to the domain administrator and not to the machine administrator.

To install Cisco WCS, follow these steps:
Step 1  Insert the Windows Cisco WCS CD into the CD-ROM drive and double-click the WCS-STANDARD-K9-7.0.XX.Y.exe file where 7.0.XX.Y is the software build. If you received the installer from Cisco.com, double-click the WCS-STANDARD-K9.7-0.XX.Y.exe file that you downloaded to your local drive.

Step 2  The Install Anywhere page appears and prepares the system for installation. After a few seconds, the Introduction window appears, followed by the license agreement window (see Figure 2-1). You must select the I accept the terms of the License Agreement radio button to continue.

![License Agreement Page](image)

Step 3  If the install wizard detects a previous version of WCS, you see a window similar to Figure 2-2 or Figure 2-3. If a previous version is detected, you must proceed as an upgrade and refer to the “Upgrading WCS” section on page 4-15. For a first-time installation, continue to Step 4.
**Figure 2-2** Ineligible for Automated Upgrade

![Image of Ineligible for Automated Upgrade dialog box]

**Figure 2-3** Previous Installation Detected

![Image of Previous Installation Detected dialog box]
Step 4  The Check Ports window appears (see Figure 2-4). In the Check Ports window, change the default HTTP and HTTPS ports if necessary. The default ports for HTTP and HTTPS are 80 and 443, respectively. HTTP Enabled is selected by default.

![Check Ports Window](image)

Step 5  Enter a Health Monitor Port. Click Next. The Select High Availability Mode window appears (see Figure 2-5).
Installing WCS for Windows

Step 6 Determine if this is a secondary, high availability WCS installation to support your primary WCS controller. The secondary WCS installation question refers to high availability only. You cannot install two different versions of WCS on the same server. If you are not enabling high availability, choose No (the default) and continue with Step 7. If this is a secondary installation for high availability purposes, choose Yes and follow Steps a through c.

a. Enter an authentication key for the primary WCS device, and click Next.

b. Choose a folder in which to install the secondary WCS in the Choose Install Folder window. Click Next to continue.

c. Choose a shortcut location for the secondary WCS.

Step 7 Enter and then re-enter the root password. The rules for a strong password are as follows:

- The minimum password length is 8 characters.
- No character can be used more than three times consecutively in the password.
- The password must contain three of the four following character classes: uppercase, lowercase, numbers, and special characters.

Step 8 Enter the root FTP password.

Step 9 In the FTP Server File page, choose a folder in which to store the FTP server files, and click Next to open the TFTP File Server window.

Note Store the FTP server files in a folder outside the main installation folder. This ensures that the FTP server files are not deleted if WCS is uninstalled.

Step 10 In the TFTP Server File window, choose a folder in which to store the TFTP server files, and click Next.
If you want to use a network-mounted drive for the TFTP root, you must configure WCS to run as a domain user (see the “Installing WCS for Windows” section on page 2-6) and then configure the TFTP root (see the “Configuring TFTP as a Network Drive” section on page 2-15).

Store the TFTP server files in a folder outside the main installation folder. This ensures that the TFTP server files are not deleted if WCS is uninstalled.

If you are installing Cisco WCS on a multi-homed server (a server having multiple interfaces), the installer automatically detects the presence of multiple interfaces. The Select Local Interfaces window appears (see Figure 2-6). Choose the interfaces to be used by the server for communicating with controllers, MSEs and remote FTP servers, and clients. Click Next.

Choose a folder in which to install the Cisco WCS at the Choose Install Folder window (see Figure 2-7). Click Next to continue.
Follow the prompts that appear in the window to complete the installation. After the installation is complete, the Install Complete window appears. Click **Done** to complete the installation.

**Note**
Look at the installation log to verify that nothing went wrong during the installation. The install log resides in the installation root directory if the installation completes. If the installation did not complete, the install log resides in the directory from which the installer was run or the install root directory.

---

**Configuring WCS to Run as a Domain User**

To configure WCS to run as a domain user, follow these steps:

**Step 1** Stop WCS.

**Step 2** Add the domain user that will be used to run the service to the Administrators group of the local machine.

a. Choose **Administrative Tools > Computer Management > Users and Groups > Groups**.

b. Double-click the Administrators group.

c. Add the domain user.

**Step 3** Install WCS as instructed in the “Installing WCS for Windows” section on page 2-6.

WCS consists of two services: Cisco Wireless Control System (A.B.C.D) and Nms_Apache_A_B_C_D, where A.B.C.D represents the current release number.
Installing WCS for Linux

You must have root privileges on Linux to install WCS. Provide the WCS installation rights to the domain administrator and not to the machine administrator.

Step 4
Set the WCS service to run as the domain user:


b. Right-click Cisco Wireless Control System (A.B.C.D) and choose Properties.

c. Click the Log On tab.

d. Click This Account.

e. Enter the domain user with “domain” before the name (such as DOMAIN\username), and the domain user password.

f. Click OK.

Step 5
Set the Apache service to run as the domain user:


b. Right-click Nms_Apache_A_B_C_D and choose Properties.

c. Click the Log On tab.

d. Click This Account.

e. Enter the domain user with “domain” before the name (such as DOMAIN\username), and the domain user password.

f. Click OK.

Step 6
Start WCS.
Step 6 Determine if this is a secondary, high availability WCS installation to support your primary WCS controller. Choose 1 for No (the default) or 2 for Yes. You cannot install two different versions of WCS on the same server. If you are not enabling high availability, choose 1 (No). If you are installing a secondary WCS for high availability mode and choose 2 (Yes), you will be prompted for an authentication key and a location for installing the secondary WCS.

Step 7 The Check HTTP Port prompt appears. In the Check HTTP Port window, change the default HTTP and HTTPS ports if necessary. The default ports for HTTP and HTTPS are 80 and 443, respectively.

Step 8 Specify whether you want to enable HTTP redirect. If HTTP redirect is enabled, any requests received on the HTTP port are redirected to the HTTPS port. If it is not enabled, the HTTP port is disabled.

Step 9 Determine whether you want the default Health Monitor port of 8082 or you need to change the port.

Step 10 Enter and then re-enter the root password. The rules for a strong password are as follows:
- The minimum password length is 8 characters.
- The password cannot contain the username or the reverse of the username.
- The password cannot be Cisco or oesic (Cisco reversed).
- The root password cannot be public.
- No character can be used more than three times consecutively in the password.
- The password must contain three of the four character classes: uppercase, lowercase, numbers, and special characters.

Step 11 Enter the root FTP password.

Step 12 Choose a folder in which to store the FTP server files.

Note If the folder does not already exist, you must enter the `mkdir` command and create it.

Step 13 Choose a folder in which to store the TFTP server files.

Note Store the TFTP server files in a folder outside the main installation folder. This ensures that the TFTP server files are not deleted if Cisco WCS is uninstalled.

Step 14 If you are installing Cisco WCS on a multi-homed server (a server having multiple interfaces), the installer automatically detects the presence of multiple interfaces. Choose the interfaces to be used by the server for communicating with controllers, MSEs and remote FTP servers, and clients.

Step 15 Choose a folder in which to install the Cisco WCS.

Step 16 Choose to create links from the default location (/opt/WCS5.2.98.0), from your home folder, or another location.

Step 17 Follow the prompts that appear to complete the installation. After the installation is complete, the Install Complete statement appears.

Note Look at the installation log to verify that nothing went wrong during the installation. The install log is located in the installation root directory if the installation completes. If the installation did not complete, the install log resides in the directory from which the installer was run or the install root directory.
Configuring TFTP as a Network Drive

To configure TFTP as a network drive, you must have completed the steps in the “Installing WCS for Linux” section on page 2-13. The desired drive must also be accessible from that domain.

Step 1 Make a backup of installDir/webnms/classes/com/cisco/packaging/PackagingResources.properties.
Step 2 Edit the following line:

TftpRoot=\\servername\resourcename

where your particular servername and resourcename are entered.

Choose Administration > ServerSettings.

At the TFTP Root setting, enter the desired network resource using the appropriate UNC format (such as \servername\resourcename) where your particular servername and resourcename are entered with only one set of backslashes.

Step 3 Restart WCS.

Starting WCS

This section provides instructions for starting WCS on either a Windows or Linux server.

In Windows and Linux, Cisco WCS is installed as a service. The service runs continuously and resumes after a reboot.

Note You can check the status of WCS at any time. To do so, follow the instructions in the “Verifying the Status of WCS” section on page 4-6.

This section contains the following topics:

- Starting WCS on Windows, page 2-15
- Starting WCS on Linux, page 2-16

Starting WCS on Windows

Follow these steps to start WCS when it is installed on Windows:

Note When WCS is installed as a Windows service, WCS runs automatically upon system bootup.

Step 1 Log into the system as administrator.
Step 2 Perform one of the following:

- From the shortcut location, choose (defaulted to Windows Start menu > Programs > Wireless Control System A.B.C.D) > StartWCS.
- From the command prompt, navigate to the WCS installation bin directory (the default is C:\Program Files\WCSA.B.C.D\bin) and enter the StartWCS command.
The WCS Admin window appears and displays messages indicating that WCS is starting.

**Note**  If WCS is installed as a service, messages also appear to indicate that the Nms_Server service is starting.

**Step 3**  Close the WCSAdmin window when the Close button becomes active.

**Step 4**  WCS is ready to host WCS user interfaces (clients). Go to the “Logging into the WCS User Interface” section on page 2-16 to use a web browser to connect to the WCS user interface.

### Starting WCS on Linux

Follow these steps to start WCS when it is installed on Linux:

**Note**  To see the version of WCS you currently have installed, enter the `nmsadmin.sh version` command.

**Note**  When WCS is installed as a Linux service, WCS runs automatically upon system bootup.

**Step 1**  Log into the system as root.

**Step 2**  Using the Linux command-line interface (CLI), perform one of the following:

- Navigate to the shortcut location (defaulted to `/opt/WCSA.B.C.D` directory) and enter the `./StartWCS` command.
- Navigate to the installation bin directory (the default is `/opt/WCSA.B.C.D/bin`) and enter the `./StartWCS` command.

The CLI displays messages indicating that WCS is starting.

**Step 3**  WCS is ready to host WCS user interfaces (clients). Go to the “Logging into the WCS User Interface” section on page 2-16 to use a web browser to connect to the WCS user interface.

### Logging into the WCS User Interface

Follow these steps to log into the WCS user interface through a web browser:

**Step 1**  Launch Internet Explorer 7.0 or later or Mozilla Firefox 3.5 or later on a different computer than the one on which you installed and started WCS.

**Note**  Some WCS features may not function properly if a browser and WCS are running on the same Windows workstation.
Step 2 In the address line of browser, enter `https://wcs-ip-address`, where `wcs-ip-address` is the IP address of the computer on which you installed and started WCS. The WCS user interface displays the Login window.

Step 3 Enter your username. The default username is `root`.

Step 4 Enter the root password you created during installation.

---

Note If any licensing problems occur, a message appears in an alert box. If you have an evaluation license, the number of days until the license expires is shown. You are also alerted to any expired licenses. You have the option to go directly to the licensing page to address these problems.

---

Step 5 Click **Login** to log into WCS. The WCS user interface is now active and available for use. The WCS home page appears. You can predefined what appears on the home page by choosing the monitoring components that are critical for your network. For example, you may want different monitoring components for a mesh network so that you can create a customized tab for a mesh dashboard.

---

Note If the database or Apache web server does not start, check the launchout.txt file in Linux or the wrapper.log file in Windows. You will see a generic “failed to start database” or “failed to start the Apache web server” message.

---

This page enables you to choose the information that you want to see. You can organize the information in user-defined tabs. The default view comes with default tabs and pre-selected components for each, and you can arrange them as you like.

---

Note When an upgrade occurs, the user-defined tabs arranged by the previous user in the previous version are maintained. Therefore, the latest components may not show. Look at the Edit Components link to find what new components are added.

---

This page provides a summary of the Cisco Unified Wireless Network Solution, including coverage areas, the most recently detected rogue access points, access point operational data, reported coverage holes, and client distribution over time. **Figure 2-8** shows a typical WCS home page.

You should see four tabs on the WCS home page: General, Client, Security, and Mesh.

---

Note When you use WCS for the first time, the network summary pages show that the Controllers, Coverage Areas, Most Recent Rogue APs, Top 5 APs, and Most Recent Coverage Holes databases are empty. It also shows that no client devices are connected to the system. After you configure the WCS database with one or more controllers, the WCS home page provides updated information.
To exit the WCS user interface, close the browser page or click Logout in the upper right corner of the page. Exiting a WCS user interface session does not shut down WCS on the server.

When a system administrator stops the WCS server during your WCS session, your session ends, and the web browser displays this message: “The page cannot be displayed.” Your session does not reassociate to WCS when the server restarts. You must restart the WCS session.

**WCS Home Page**

With the WCS home page, you can customize the predefined set of components depending on your network management needs.

The home page allows you to choose what information appears on each of the default home page tabs including General, Client, Security, Mesh, and CleanAir. You can also create new tabs in addition to the current (default) tabs.

**Note**

When an upgrade occurs, the arrangement of components in a previous version is maintained. Because of this, components or features added in a new release are not displayed. Click the Edit Contents link to discover new components. See the “Editing Content” section on page 2-26 for more information.

This chapter contains the following sections:

- General Tab, page 2-19
- Client Tab, page 2-20
- Security Tab, page 2-20
General Tab

Table 2-1 lists the factory default components for the General tab.

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inventory Detail Status</td>
<td>Displays the following:</td>
</tr>
<tr>
<td></td>
<td>• Controllers—Lists the number of controllers that are managed in WCS.</td>
</tr>
<tr>
<td></td>
<td>Graphically depicts reachable and unreachable controllers.</td>
</tr>
<tr>
<td></td>
<td>• Radios—Lists the number of radios managed in WCS.</td>
</tr>
<tr>
<td></td>
<td>Graphically depicts the number of radios in out-of-service (critical),</td>
</tr>
<tr>
<td></td>
<td>minor, and ok conditions.</td>
</tr>
<tr>
<td></td>
<td>• MSEs—Lists the number of MSEs that are managed in WCS.</td>
</tr>
<tr>
<td></td>
<td>Graphically depicts reachable and unreachable servers.</td>
</tr>
<tr>
<td></td>
<td>Look at the installation log to verify that nothing went wrong while</td>
</tr>
<tr>
<td></td>
<td>manually adding the servers to WCS. (The trace for MSEs must be turned on.)</td>
</tr>
<tr>
<td>Coverage Areas</td>
<td>Displays access points, radios, and client details for each coverage area.</td>
</tr>
<tr>
<td>Client Count</td>
<td>Displays the total number of clients in WCS over the selected period of</td>
</tr>
<tr>
<td></td>
<td>time.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Client count includes autonomous clients.</td>
</tr>
<tr>
<td>Recent Coverage Holes</td>
<td>Displays the five most recent coverage alarms.</td>
</tr>
<tr>
<td>Total APs not yet assigned to Maps</td>
<td>Indicates the number of unassigned access points. Click the number link</td>
</tr>
<tr>
<td></td>
<td>to view the list of these access points.</td>
</tr>
</tbody>
</table>
Client Tab

When you click the Client tab from the WCS home page, you see the following factory default components (see Table 2-2).

Table 2-2   Client Tab

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client Count</td>
<td>Displays the trend of associated and authenticated client counts in a given period of time.</td>
</tr>
<tr>
<td>Client Traffic</td>
<td>Displays the trend of both upstream and downstream client traffic in a given time period.</td>
</tr>
<tr>
<td>Client</td>
<td>Displays the failures and errors of the five most recent client alarms.</td>
</tr>
<tr>
<td>Client Protocol Distribution</td>
<td>Displays the distribution of each radio band and the total current client count.</td>
</tr>
<tr>
<td>Client Distribution</td>
<td>Displays the distribution of clients by protocol, EAP type, and authentication and the total current client count.</td>
</tr>
</tbody>
</table>

Additionally, see the “Troubleshooting from the Client Tab Dashboard” section on page 10-22 which describes the Client Troubleshooting portion of the Client tab.

Security Tab

When you click the Security tab from the WCS home page, you see the following factory default components (see Table 2-3).

Table 2-3   Security Tab

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AP Threats/Attacks</td>
<td>Displays threats or attacks to access points for the past hour, past 24 hours, and total active.</td>
</tr>
<tr>
<td>Attacks Detected</td>
<td>Displays wIPS and signature attacks for the past hour, past 24 hours, and total active.</td>
</tr>
<tr>
<td>Recent Rogue AP Alarms</td>
<td>Displays the five most recent rogue alarms. Click the number in parentheses to access the Alarms page. Click an item under MAC Address to view alarm details.</td>
</tr>
<tr>
<td>Recent Ad hoc Rogue Alarm</td>
<td>Displays the five most recent ad hoc rogue alarms. Click the number in parentheses to access the Alarms page. Click an item under MAC address to view ad hoc details.</td>
</tr>
<tr>
<td>Most Recent Security Alarms</td>
<td>Displays the five most recent security alarms. Click the number in parentheses to access the Alarms page.</td>
</tr>
<tr>
<td>MFP Attacks</td>
<td>Displays MFP attacks for the past hour, past 24 hours, and total active.</td>
</tr>
</tbody>
</table>
Table 2-3 Security Tab (continued)

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Malicious Rogue APs</td>
<td>Displays malicious rogue access points for the past hour, past 24 hours, and total active.</td>
</tr>
<tr>
<td>Cisco Wired IPS Events</td>
<td>Displays Wired IPS events for the past hour, past 24 hours, and total active.</td>
</tr>
<tr>
<td>Unclassified Rogue APs</td>
<td>Displays unclassified rogue access points for the past hour, past 24 hours, and total active.</td>
</tr>
<tr>
<td>Friendly Rogue APs</td>
<td>Displays friendly rogue access points for the past hour, past 24 hours, and total active.</td>
</tr>
<tr>
<td>Ad hoc Rogues</td>
<td>Displays ad hoc rogues for the past hour, past 24 hours, and total active.</td>
</tr>
<tr>
<td>Security Index</td>
<td>Indicates the security of the WCS managed network. The security index is calculated by assigning priority to the various security configurations and displaying them in visual form.</td>
</tr>
</tbody>
</table>

Mesh Tab

If you click the Mesh tab from the WCS home page, you see the following factory default components (see Table 2-4).

Table 2-4 Mesh Tab

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Most Recent Mesh Alarms</td>
<td>Displays the five most recent mesh alarms. Click the number in parentheses to access the Alarms page.</td>
</tr>
<tr>
<td>Worst SNR Link</td>
<td>Displays the worst signal-to-noise ratio (SNR) links. Data includes the Parent AP Name, the Child AP Name, and the Link SNR.</td>
</tr>
<tr>
<td>Worst Node Hop Count</td>
<td>Displays the worst node hop counts. Data includes the AP Name, the Hop Count, and the Parent AP Name.</td>
</tr>
<tr>
<td>Worst Packet Error Rate</td>
<td>Displays the worst packet error rates. Data includes the Parent AP Name, the Child AP Name, and the Packet Error Rate.</td>
</tr>
</tbody>
</table>

CleanAir Tab

*Note* To enable CleanAir on WCS, you need to have WCS Plus License installed.

The following factory default components appear on the CleanAir tab:
- 802.11a/n Avg Air Quality—Provides a line chart representing the average air quality for the entire network over a set period of time. Displays the average air quality on the 802.11 a/n band. Data includes time and the average air quality.

- 802.11b/g/n Avg Air Quality—Provides a line chart representing the average air quality for the entire network over a set period of time. Displays the average air quality on the 802.11 b/g/n band. Data includes time and the average air quality.

- 802.11a/n Min Air Quality—Provides a line chart representing the minimum air quality for the entire network over a set period of time. Displays the minimum air quality on the 802.11 a/n band. Data includes time and the minimum air quality.

- 802.11b/g/n Min Air Quality—Provides a line chart representing the minimum air quality for the entire network over a set period of time. Displays the minimum air quality on the 802.11 b/g/n band. Data includes time and minimum air quality.

- Worst 802.11a/n Interferers—Provides a list of active interferers with the worst severity level for the 802.11 a/n band. The graph displays the top ten worst interferers that are currently active. Data includes InterfererID, Type, Status, Severity, Affected Channels, Duty Cycle(%), Discovered, Last Updated, and Floor.

- Worst 802.11b/g/n Interferers—Provides a list of active interferers with the worst severity level for 802.11 b/g/n band. The graph displays the top ten worst interferers that are currently active. Data includes InterfererID, Type, Status, Severity, Affected Channels, Duty Cycle(%), Discovered, Last Updated, and Floor.

- 802.11a/n Interferer Count—Provides a line chart representing the total number of interferers on all channels over the selected period of time. Displays the number of devices interfering in the 802.11 a/n band. Data includes time and interferer count.

  **Note**  
  The air quality is calculated for all controllers in your network that have CleanAir-enabled access points. The report includes aggregated air quality data across your network.

- 802.11b/g/n Interferer Count—Provides a line chart representing the total number of interferers on all channels over the selected period of time. Displays the number of devices interfering in the 802.11 b/g/n band. Data includes time and interferer count.

  **Note**  
  The information in the worst interferer and interferer count charts is collected from Mobility Services Engines (MSE). If MSEs are not available, this chart will not show any results.

- Recent Security-risk Interferers—Provides a list of active interferers with the worst severity level for each band. Displays the recent security risk interferers on your wireless network. Data includes Type, Severity, Affected Channels, Last Detected, Detected AP.

  **Note**  
  This chart includes information for the interferers for which security alarms are enabled.

You can also view the data presented on this tab in different formats.

**ContextAware Tab**

The following factory default components appear on the ContextAware tab:
- MSE Historical Element Count—Displays the historical trend of tags, clients, rogue APs, rogue clients, interferers, wired clients, and guest client counts in a given period of time.

**Note** The MSE Historical Count information is presented in a time-based graph. For graphs that are time-based, there is a link bar at the top of the graph page that displays 6h, 1d, 1w, 2w, 4w, 3m, 6m, 1y, and Custom. When selected, the data for that time frame is retrieved and the corresponding graph is displayed. See the “Time-Based Graphs” section on page 6-76 for more information.

- Rogue Element Detected by CAS—Displays the indices of the Rogue APs and Rogue Clients in percentage. It also provides a count of the number of Rogue APs and Rogue Clients detected by each MSE within an hour, 24 hours as well as more than 24 hours.
  
  Rogue AP Index is defined as the percentage of total active tracked elements that are detected as Rogue APs across all the MSEs on WCS.
  
  Rogue Client Index is defined as the percentage of total active tracked elements that are detected as Rogue Clients across all the MSEs on WCS.

- Location Assisted Client Troubleshooting—You can troubleshoot clients using this option with location assistance. You can provide either a MAC Address, Username or IP Address as the criteria for troubleshooting.

  **Note** Username, IP Address, and partial MAC address-based troubleshooting is supported only on MSEs with version 7.0.200.0 and above.

  For more information about Location Assisted Client Troubleshooting, see the “Location Assisted Client Troubleshooting from the ContextAware Dashboard” section on page 12-73.

- MSE Tracking Counts—Represents the tracked and non-tracked count of each of the element types. The element type includes tags, rogue APs, rogue clients, interferers, wired clients, wireless clients, and guest clients.

- Top 5 MSEs—Lists the top five MSEs based on the percentage of license utilization. It also provides count for each element type for each MSE.

  **Note** If you have installed WCS Plus license but you have not added any MSE to WCS then the ContextAware tab will be empty. However a message would be displayed with a link to add an MSE.

  - In the component, click the count link to get a detailed report.
  - Use the icons in a component to switch between chart and grid view.
  - Use the Enlarge Chart icon to view the grid or chart in full screen.

## Customizing Home Page Tabs

You can customize the predefined set of components depending on your network management needs. This page enables you to choose the displayed information. You can organize the information in user-defined tabs. The default view comes with default tabs and pre-selected components for each. When you click the Edit Tabs link in the WCS home page, the Edit Tabs page appears in which customization can begin (see Figure 2-9).
When an upgrade occurs, the arrangement of components in a previous version is maintained. Because of this, components or features added in a new release are not displayed. Click the Edit Contents link to discover new components. See the “Customizing Home Page Tabs” section on page 2-23 for more information.

### Creating a New Tab

To create a new tab, follow these steps:

**Step 1**  
Click **Edit Tabs** from the WCS home page. The Edit Tabs page appears (see Figure 2-9).

![Figure 2-9 WCS Home > Edit Tabs](image)

- **Step 2**  
Enter the name of the new tab you are creating, and click **Add**. The tab name you add appears in the Tab Order page.

  **Note**  
  Add is the only function that does not require a Save after its operation. If you click **Delete**, **Rename**, **Move Up**, or **Move Down**, you must click **Save** for the changes to be applied.

- **Step 3**  
Click the tab names in the Tab Order page and assign placement by clicking **Move Up** or **Move Down**.

  **Note**  
  If you want to return to the restored factory defaults as shown in Figure 2-8, click **Reset to Factory Default**.
Customizing Home Page Tabs

To customize WCS home page tabs, follow these steps:

**Step 1**  In the WCS home page, click *Edit Tabs*.

**Step 2**  Enter the name of the new tab you are creating in the New Tab Name text box.

**Step 3**  Click *Add*. The new tab name appears in the Tab Order page.

**Step 4**  Click the new tab name and determine its placement by clicking *Move Up* or *Move Down*.

*Note*  If you want to return to the restored factory defaults, click *Reset to Factory Default*.

*Note*  You do not need to click *Save* after adding a new tab. If you click *Delete, Rename, Move Up, or Move Down*, you must click *Save* for the changes to be applied.

Customizing Home Page Content

Follow these steps to customize WCS home page components. You can add or delete components by selecting from the predefined list.

Also part of the customizable home page are time-based or non-time-based interactive graphs which you can display in graphical or chart form (by clicking the appropriate icon). (Interactive graphs also appear in Monitor > Clients.) These graphs refresh automatically within a predetermined time based on the default polling cycles of dependent tasks, or you can click the Refresh Component icon to get the most current status. When a graph is time based, an additional link bar at the top of the graph page displays the options as follows:

- 6h—the last six hours of data from the current time and current database table
- 1d—the last day of data from the current time and current database table
- 1w—the last week of data from the current time and the hourly aggregated table
- 2w—the last two weeks of data from the current time and hourly aggregated table
- 4w—the last four weeks of data from the current time and hourly aggregated table
- 3m—the last three months of data from the current time and daily aggregated table
- 6m—the last six months of data from the current time and the weekly aggregated table
- 1y—the last year of data from the current time and weekly aggregated table
- custom—the user can set both the days and hours for the start and end date. The appropriate aggregated source (either current, hourly, or daily) is chosen based on the starting date.

After you specify the timeframe, the data for that timeframe is retrieved and the corresponding graph is displayed. The link for which the graph is drawn is shown in a different color (orange) than the other links. The interactive graphs that are available within WCS include line graphs, area graphs, pie graphs, and stacked bar graphs.

You can click *Enlarge Chart* icon to enlarge the graph in a separate page.
Editing Content

Follow these steps to customize WCS home page components:

**Step 1**  
On the WCS home page, click **Edit Contents**. The Edit Content page appears (see Figure 2-10).

**Figure 2-10  Edit Content Page**

![Edit Content Page](image)

**Step 2**  
In the Available Components drop-down list, highlight the desired component and choose to add it to the left column or add it to the right column. The component moves to the appropriate column.

**Step 3**  
Click the component in the Left Side or Right Side Column page and move it up, down, or to the right or left.

**Note**  
To remove a component, choose it from the Left or Right Column list, and click **Remove**.

**Step 4**  
Click **Save**.

### Additional Edit Content Page Components

The WCS > Edit Content page lists the following available components:

- **AP Join Taken Time**—Displays the access point name and the amount of time (in days, minutes, and seconds) that it took for the access point to join.
- **AP Threats/Attacks**—Displays various types of access point threats and attacks and indicates how many of each type have occurred.
- **AP Uptime**—Displays each access point name and amount of time it has been associated.
- **Ad hoc Rogues**—Displays ad hoc rogues for the previous hour, previous 24 hours, and total active.
Customizing Home Page Tabs

- Attacks Detected
- Cisco Wired IPS Events—Displays wired IPS events for the previous hour, previous 24 hours, and total active.
- Client—Displays the five most recent client alarms with client association failures, client authentication failures, client WEP key decryption errors, client WPA MIC errors, and client exclusions.
- Client Authentication Type—Displays the number of clients for each authentication type.
- Client Count—Displays the trend of associated and authenticated client counts in a given period of time.
- Client Distribution—Displays how clients are distributed by protocol, EAP type, and authentication type.
- Client EAP Type Distribution
- Client Protocol Distribution—Displays the current client count distribution by protocols.
- Client Security Events—Displays client security events within the previous 24 hours including excluded client events, WEP decrypt errors, WPA MIC errors, shunned clients, and IPsec failures.
- Client Traffic—Displays the trend of client traffic in a given time period.
- Client Troubleshooting—Allows you to enter a MAC address of a client and retrieve information for diagnosing the client in the network.
- Clients Detected by Context Aware Service—Displays the client count detected by the context aware service within the previous 15 minutes.
- Controller CPU Utilization (%)—Displays the average, maximum, and minimum CPU usage.
- Controller Memory Utilization—Displays the average, maximum, and minimum memory usage as a percentage for the controllers.
- Coverage Areas
- Friendly Rogue APs—Displays friendly rogue access points for the previous hour, previous 24 hours, and total active.
- Guest Users Count
- Inventory Detail Status
- Inventory Status—Displays the total number of client controllers and the number of unreachable controllers.
- LWAPP Uptime—Displays the access point name and the amount of its uptime in days, minutes, and seconds.
- Latest 5 Logged in Guest Users
- MFP Attacks
- Malicious Rogue APs
- Mesh AP by Hop Count
- Mesh AP Queue Based on QoS
- Mesh Parent Changing AP—Displays the access point name, the parent name, and the number of changes made per minute.
- Mesh Top Over Subscribed AP
- Mesh Worst Node Hop Count
Customizing Home Page Tabs

- Mesh Worst Packet Error Rate
- Mesh Worst SNR Link
- Most Recent AP Alarms—Displays the five most recent access point alarms. Click the number in parentheses to open the Alarms page which shows all alarms.
- Most Recent Client Alarms
- Most Recent Mesh Alarms
- Most Recent Security Alarms—Displays the five most recent security alarms. Click the number in parentheses to open the Alarms page.
- Recent 5 Guest User Accounts
- Recent Alarms—Displays the five most recent alarms by default. Click the number in parentheses to open the Alarms page.
- Recent Coverage Holes
- Recent Malicious Rogue AP Alarms
- Recent Rogue Alarms—Displays the five most recent rogue alarms. Click the number in parentheses to open the Alarms page which shows alarms.
- Security Index
- Top APs by Client Count
- Unclassified Rogue APs—Displays unclassified rogue access points for the previous hour, previous 24 hours, and total active.

Guest Components for WCS Home Page

The guest user components listed in Table 2-5 are also available for the WCS home page General tab using the Edit Contents feature.

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Guest User Accounts</td>
<td>Status of the last five WCS guest accounts configured on the network. Account information includes the guest username, the time and date the account was created, who created or modified the account, the lifetime of the account (days, minutes, and seconds), and the account status (active, scheduled, not active).</td>
</tr>
<tr>
<td>Currently Logged Guest Users</td>
<td>List of guest users that are currently logged into the network. Guest user information includes guest username, profile name, date and time the guest user associated with WCS, and the amount of time remaining before the account expires.</td>
</tr>
<tr>
<td>Guest Count</td>
<td>Interactive graph showing the number of guest users in the network.</td>
</tr>
</tbody>
</table>
Using the Cisco WCS User Interface

A typical Cisco WCS user interface page consists of these elements:

- Icons, page 2-29
- Menu Bar, page 2-29
- Sidebar Area, page 2-32
- Command Buttons, page 2-32
- Alarm Summary, page 2-33
- Main Data Page, page 2-33
- Administrative Tools, page 2-34
- Using the Search Feature, page 2-34

Icons

The icons on the WCS home page and within the General, Client, Security, and Mesh tabs have the following functions.

<table>
<thead>
<tr>
<th>Table 2-6 Icons</th>
<th>Client Tab Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><img src="image" alt="Component Options Icon" /></td>
<td>The Component Options icon enables you to filter the data by variables. For example, you can compare client count trends for SSIDs, floor areas, controllers, and so on.</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Refresh Component Icon" /></td>
<td>The Refresh Component icon enables you to automatically adjust the dashboard so that it reflects the current network status.</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="View in Chart Icon" /></td>
<td>The View in Chart icon enables you to view the component in chart rather than table form.</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="View in Grid Icon" /></td>
<td>The View in Grid icon enables you to view the component in a table rather than chart form.</td>
</tr>
</tbody>
</table>

Menu Bar

There are seven menus on each page: Monitor, Reports, Configure, Services, Administration, Tools, and Help. When you hover your mouse cursor over any of the headings, a drop-down list appears.

Monitor Menu

The Monitor menu provides you with a top-level description of the devices on your network. You can monitor your network, maps, Google Earth maps, various devices (controllers, access points, clients, tags, chokepoints, Wi-Fi TDOA receivers), RRM, alarms, and events.
**Configure Menu**

The Configure menu enables you to configure templates, controllers, access points, Ethernet switches, chokepoints, Wi-Fi TDOA receivers, config groups, auto provisioning, scheduled configuration tasks, profiles, ACS view servers, and TFTP servers on your network.

**Administration Menu**

The Administration menu enables you to schedule tasks like making a backup, checking a device status, auditing your network, synchronizing the MSE, and so on. It also contains Logging to enable various logging modules and specify restart requirements. For user administration such as changing passwords, establishing groups, setting application security settings, and so on, choose AAA. From the Administration Menu, you can also access the licensing information, set user preferences, and establish high availability (a secondary backup device running WCS).

**Tools Menu**

The Tools Menu covers voice audit, location accuracy, config audit, and migration analysis.

**Help Menu**

Choosing Help > Online Help enables you to view online help. The online help is context sensitive and will open to documentation for the WCS window that you currently have open.

Choosing Help > Learning Modules allows you to access short video clips of certain WCS features.

Choosing Help > Submit Feedback allows you to access a page where you can enter feedback on the WCS product.

Choosing Help > Help Us Improve Cisco Products allows you to enable and provide permission to automatic collect data about how you and your organization use your Cisco wireless products, this data will be useful to improve product performance and usability. The data will be automatically collected and sent to Cisco in encrypted form. The data may contain information about your organization and it will not be shared or used outside of Cisco.

| Note | To get the automated feedback enabled, you must configure your Mail Server Configuration by choosing Administration > Settings > Mail Server Configuration. |

Choosing Help > About WCS allows you to verify the version of WCS that you are running. It provides the version, host name, feature, AP limit, and type.

**Exploring Help**

There are different ways to get help, depending on your needs (see Table 2-7). This section contains the following topics:

- Accessing Help Documentation, page 2-31
- Searching Topics, page 2-31
- Accessing Index, page 2-32
- Providing Feedback, page 2-32
**Table 2-7 Exploring Help**

<table>
<thead>
<tr>
<th>To...</th>
<th>Try...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Look for getting started information and more.</td>
<td>In the Help page, Contents pane, expand the listing.</td>
</tr>
<tr>
<td>Find information about any topic.</td>
<td>In the Help search field, type words you want to look for in the documentation and press Enter.</td>
</tr>
<tr>
<td>Find information about a specific topic.</td>
<td>Use the context-sensitive help, access the help using standard methods, such as Help button or press F1 button.</td>
</tr>
</tbody>
</table>

**Accessing Help Documentation**

The Help is the main tool you use to view documentation. To open the Help, from WCS, choose **Help > Online Help**. The Help browser shows Contents and Search Results in the left pane. When you select an item in the left pane, the right pane displays that page of documentation.

Use the Help to find and view documentation for all WCS topics (see **Table 2-8**).

**Table 2-8 Help Information**

<table>
<thead>
<tr>
<th>Help Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Book" /></td>
<td>To go to the previous page.</td>
</tr>
<tr>
<td><img src="image" alt="Forward" /></td>
<td>To go to the next page.</td>
</tr>
<tr>
<td><img src="image" alt="Print" /></td>
<td>To print the page.</td>
</tr>
<tr>
<td><img src="image" alt="Search" /></td>
<td>To search a topic.</td>
</tr>
<tr>
<td><img src="image" alt="Collapse All" /></td>
<td>To collapse the Table of Contents.</td>
</tr>
<tr>
<td><img src="image" alt="Expand All" /></td>
<td>To expand the Table of Contents.</td>
</tr>
</tbody>
</table>

**Searching Topics**

Use the Help to find documentation that contain your search terms:
In the Help Search field, enter the keywords you want to look for. Search lists the topics that contain the keywords, unless you use any of the following syntax options.

- Exact phrase, " " around phrase (quotation marks). For example “Word1 Word2”.
- Wildcards for partial word searching, * in place of characters. For example Word*.

Click the topic of the search result to view the page.

Accessing Index

The Index tab of the help browser allows you to search for index terms and display the associated topics.

To find a topic using the index, follow these steps:

**Step 1**
In the field at the top, type the keyword to be searched. As keywords are selected, one or more topic titles appear in the topics list below.

**Step 2**
Select a topic from the list, then click the Display button (Windows).

**Step 3**
Results from the Help index will not be exhaustive, so you should consider using the Search function as well.

Providing Feedback

If you are not able to find the relevant WCS topic which you are looking for, please provide your feedback. There are two feedback links, one for Bug Toolkit, and one for the bug details.

The feedback form allows users to report general feedback or problems with Bug Toolkit. Every feedback submission is reviewed by the Tool Project Team. We can only contact you if your information is provided at the bottom of the form. By providing your information, this gives us permission to contact you about the feedback submission.

The feedback link is available in bugs that contain bug details. It displays a feedback form where you can rate the overall quality of the bug details. This feedback mechanism is used for us to learn which bugs need improvements in data and which ones are most effective. If the bug does not contain enough information for you to know what actions to take to circumvent the issue, please speak with our Technical Assistance Center for assistance with your issue.

Sidebar Area

The sidebar area enables you to choose a new configuration page under the currently selected menu area. You may choose to display or configure any of the available data. The selector area options vary based on which menu you have chosen.

Some pages contain a group of menus in this area. Click the menu item to reveal a submenu and then click the item to choose it.

Command Buttons

The Cisco WCS user interface uses a number of command buttons throughout its pages. The most common of these are as follows:

- **Apply to Controllers**: Applies the selected information to the controllers
- **Delete**: Deletes the selected information
• Cancel: Cancels new information entered on the current page and returns to the previous page
• Save: Saves the current settings
• Audit: Discovers the present status of this access point
• Place AP: Audits the configuration of the selected entity by flagging the differences between WCS database device configurations

**Alarm Summary**

When WCS receives an alarm message from a controller, it displays an alarm indicator at the top of the WCS window (see Figure 2-11).

---

**Note**
The Administration > Settings > Alarms page has a Hide Acknowledged Alarms check box. You must unselect it if you want acknowledged alarms to appear in the WCS and alarms lists page. By default, acknowledged alarms are not shown.

Critical (red), Major (orange) and Minor (yellow) alarms appear in the alarm dashboard, left to right.

---

**Figure 2-11 WCS**

Critical (red), Major (orange) and Minor (yellow) alarms appear in the alarm dashboard, left to right.

---

**Note**
Alarm counts are refreshed every 15 seconds.

---

**Main Data Page**

The main data page is determined by the required parameter information. Active areas on the data pages include the following:

• Text boxes into which data may be entered using the keyboard
• Drop-down lists from which one of several options may be chosen
• Check boxes in lists allow you to choose one or more items from the displayed list
• Radio buttons allow you to turn a parameter on or off
• Hyperlinks take you to other pages in the Cisco WCS user interface

Input text boxes are black text on a white background. When data is entered or selected, it is not sent to the controller, but it is saved in the text box until you click Go.
Administrative Tools

The following provides information regarding the current WCS user:

- **User**—Indicates the username for the current WCS user.
  
  Click the User link to change the user password. See the “Change Password” section on page 16-114 for more information.

- **Virtual Domain**—Indicates the current virtual domain for this WCS user. See the “Configuring Virtual Domains” section on page 18-1 for more information.

  **Note**
  To switch domain names, click the blue inverted triangle to the right of the virtual domain name to open the Switch to another Virtual Domain page. Select the new virtual domain radio button, and click **Save**. Your privileges are changed accordingly.

### Table 2-9 Administrative Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
</table>
| ![Help Icon] | Click to access the WCS online help.  
**Note** The online help provides information applicable to your current WCS window. |
| ![Update Icon] | Click to update the data in the current WCS window. |
| ![Print Icon] | Click to access a print-friendly version of the current WCS window.  
**Note** Click **Print** to print the current WCS window or **Exit Print View** to return to the previous page. |
| ![Logout Icon] | Click to log out of WCS. |

Using the Search Feature

The enhanced WCS Search feature (see Figure 2-12) provides easy access to advanced search options and saved searches. You can access the search options from any page within WCS making it easy to search for a device or SSID (Service Set Identifier).

**Figure 2-12 WCS Search Feature**

Quick Search

For a quick search, you can enter a partial or complete IP address, MAC address, name, or SSID for clients, alarms, access points, controllers, maps, tags, or rogue clients (see Figure 2-12).

**Note**
You can also enter a username if you are searching for a client.

To quickly search for a device, follow these steps:
**Step 1**
Enter the complete or partial IP address, device name, SSID, or MAC address of the device in the Search text box (see Figure 2-13).

**Figure 2-13  Quick Search with Partial IP Address**

**Step 2**
Click Search to display all devices that match the Quick Search parameter.

The search results display the matching item type, the number of items that match your search parameter, and links to the list of matching results (see Figure 2-14). Click View List to view the matching devices from the Monitor or Configuration pages.

**Figure 2-14  Quick Search Results Advanced Search**

---

**Advanced Search**

To perform a more specific search for a device in WCS, follow these steps:

**Step 1**
Click Advanced Search located in the top right corner of WCS (see Figure 2-12).

**Step 2**
In the New Search page, choose a category from the Search Category drop-down list (see Figure 2-15).

---

Footnotes
1. The search was performed to match the entered text partially or fully with either IP Address or MAC Address or name or SSID as applicable for different item types such as Clients, Alarm, Access Points, Controllers, Maps, Tags & Rogue Clients.
Using the Search Feature

Chapter 2 Getting Started

Using the Search Feature

Figure 2-15 Search Category Drop-Down List

New Search

Search Category
Search for controller by
Select a Network
Audit Status
Items per page
Save Search

Note
Click each of the following category for more information.

Search categories include:

- Alarms
- Access Points
- Controllers
- Clients
- Chokepoints
- Events
- Interferers
- Wi-Fi TDOA Receivers
- Maps
- Rogue Clients
- Shunned Clients
- Tags
- Controller Licenses

Step 3 Select all applicable filters or parameters for your search (see Figure 2-16).

Note
Search parameters change depending on the selected category. The following pre-defined search filters have been added in release 6.0: Associated Clients, Authenticated Clients, Excluded Clients, Probing Clients, All Clients, New Clients detected in last 24 hours, unauthenticated clients, 2.4 GHz clients, and 5 GHz clients.
Step 4  Choose the number of items to display on the results page.

Step 5  To save this search, select the Save Search check box and enter a name for the search in the text box.

Step 6  When all filters and parameters are set, click Go.

Alarms

You can configure the following parameters when performing an advanced search for alarms (see Table 2-10):

<table>
<thead>
<tr>
<th>Table 2-10</th>
<th>Alarms</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameter</td>
<td>Options</td>
</tr>
<tr>
<td>Severity</td>
<td>Choose All Severities, Critical, Major, Minor, Warning, or Clear.</td>
</tr>
<tr>
<td>Condition</td>
<td>Use the drop-down list to select a condition. Also, you can enter a condition by typing it in this drop-down list.</td>
</tr>
<tr>
<td>Note</td>
<td>If you have selected an alarm category, this drop-down list would contain the conditions available in that category.</td>
</tr>
<tr>
<td>Time Period</td>
<td>Choose a time increment from Any Time to Last 7 days. The default is Any Time.</td>
</tr>
</tbody>
</table>
Using the Search Feature

You can decide what information appears in the alarm search results page. See the “Configuring the Search Results Display” section on page 2-47 for more information.

You can decide what information appears in the alarm search results page. See the “Configuring the
Search Results Display” section on page 2-47 for more information.

See the “Configuring Alarm Severity” section on page 6-84 for more information on alarms.

Access Points

You can configure the following parameters when performing an advanced search for access points (see Table 2-11).

Table 2-11  Access Points

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search By</td>
<td>Choose All APs, Base Radio MAC, Ethernet MAC, AP Name, IP Address, Controller Name, Controller IP, All Unassociated APs, Floor Area, Outdoor Area, Unassigned APs, or Alarms.</td>
</tr>
<tr>
<td>Note</td>
<td>Search parameters may change depending on the selected category. When applicable, enter the additional parameter or filter information to help identify the Search By category. For example, when you select Floor Area, you also must identify its campus and building. Or, if you select Alarms, you can search for access points based on the severity of the alarm.</td>
</tr>
<tr>
<td>AP Type</td>
<td>Choose All Types, LWAPP, or Autonomous.</td>
</tr>
<tr>
<td>AP Mode</td>
<td>Choose All Modes, Local, Monitor, H-REAP, Rogue Detector, Sniffer, Bridge, or SE-Connect.</td>
</tr>
<tr>
<td>Radio Type</td>
<td>Choose All Radios, 802.11a, or 802.11b/g.</td>
</tr>
</tbody>
</table>
Chapter 2: Getting Started

Using the Search Feature

Table 2-11 Access Points (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>802.11n Support</td>
<td>Check to search for access points with 802.11n support.</td>
</tr>
<tr>
<td>OfficeExtend AP Enabled</td>
<td>Check to search for OfficeExtend access points.</td>
</tr>
</tbody>
</table>

Note: You can decide what information appears in the access points search results page. See the “Configuring the Search Results Display” section on page 2-47 for more information.

Controllers

You can configure the following parameters when performing an advanced search for controllers (see Table 2-12).

Table 2-12 Controllers

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search for controller by</td>
<td>Choose All Controllers, IP Address, Controller Name, or Network.</td>
</tr>
<tr>
<td></td>
<td>Note: Search parameters may change depending on the selected category. When applicable, enter the additional parameter or filter information to help identify the Search By category.</td>
</tr>
<tr>
<td>Enter Controller IP Address</td>
<td>This text box appears only if you select IP Address from the Search for controller by text box.</td>
</tr>
<tr>
<td>Enter Controller Name</td>
<td>This text box appears only if you select Controller Name from the Search for controller by text box.</td>
</tr>
<tr>
<td>Select a Network</td>
<td>Choose All Networks or an individual network.</td>
</tr>
<tr>
<td>Audit Status</td>
<td>Choose one of the following from the drop-down list:</td>
</tr>
<tr>
<td></td>
<td>• All Status</td>
</tr>
<tr>
<td></td>
<td>• Mismatch—Config differences were found between WCS and controller during the last audit.</td>
</tr>
<tr>
<td></td>
<td>• Identical—No config differences were found during the last audit.</td>
</tr>
<tr>
<td></td>
<td>• Not Available—Audit status is unavailable.</td>
</tr>
</tbody>
</table>

Note: You can decide what information displays on the controllers search results page. See the “Configuring the Search Results Display” section on page 2-47 for more information.
## Clients

You can configure the following parameters when performing an advanced search for clients (see Table 2-13).

<table>
<thead>
<tr>
<th>Table 2-13</th>
<th>Search Clients Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Parameter</strong></td>
<td><strong>Options</strong></td>
</tr>
<tr>
<td>Search By</td>
<td>Choose All Clients, All Excluded Clients, All Wired Clients, All Logged in Guests, IP Address, User Name, MAC Address, Asset Name, Asset Category, Asset Group, AP Name, Controller Name, Controller IP, MSE IP, Floor Area, or Outdoor Area.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>Search parameters may change depending on the selected category. When applicable, enter the additional parameter or filter information to help identify the Search By category. For example, when you select IP address, you must enter the specific IP address for this search.</td>
</tr>
<tr>
<td>Clients Detected By</td>
<td>Choose WCS or MSEs.</td>
</tr>
<tr>
<td></td>
<td>Clients detected by WCS—Clients stored in WCS databases.</td>
</tr>
<tr>
<td></td>
<td>Clients detected by MSE—Clients stored on the mobility services engine that were detected by the MSE through controller polling.</td>
</tr>
<tr>
<td>Client States</td>
<td>Choose All States, Idle, Authenticated, Associated, Probing, or Excluded.</td>
</tr>
<tr>
<td>Restrict By Radio Band</td>
<td>Select the check box to indicate a specific radio band. Choose 5 GHz or 2.4 GHz from the drop-down list.</td>
</tr>
<tr>
<td>Restrict By Protocol</td>
<td>Select the check box to indicate a specific protocol. Choose 802.11a, 802.11b, 802.11g, 802.11n, or Mobile from the drop-down list.</td>
</tr>
<tr>
<td>Search on Controllers Now</td>
<td>Select the check box to indicate a search for clients on current controllers.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>When selected, the CCX and E2E Compatible check boxes become unavailable.</td>
</tr>
<tr>
<td>SSID</td>
<td>Select the check box and choose the applicable SSID from the drop-down list.</td>
</tr>
<tr>
<td>Profile</td>
<td>Select the check box to list all of the clients associated to the selected profile.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>Once the check box is selected, choose the applicable profile from the drop-down list.</td>
</tr>
</tbody>
</table>
**Table 2-13  Search Clients Parameters (continued)**

<table>
<thead>
<tr>
<th>Parameter (continued)</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>CCX Compatible</td>
<td>Select the check box to search for clients that are compatible with Cisco Client Extensions.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Once the check box is selected, choose the applicable version, All Versions, or Not Supported from the drop-down list.</td>
</tr>
<tr>
<td>E2E Compatible</td>
<td>Select the check box to search for clients that are End to End compatible.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Once the check box is selected, choose the applicable version, All Versions, or Not Supported from the drop-down list.</td>
</tr>
<tr>
<td>NAC State</td>
<td>Select the check box to search for clients identified by a certain Network Admission Control (NAC) state.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Once the check box is selected, choose the applicable state from the drop-down list. Select from Quarantine, Access, Invalid, and Not Applicable.</td>
</tr>
<tr>
<td>Include Disassociated</td>
<td>Select to include clients that are no longer on the network but for which WCS has historical records.</td>
</tr>
</tbody>
</table>

You can decide what information displays on the client search results page. See the “Configuring the Search Results Display” section on page 2-47 for more information.

**Chokepoints**

You can configure the following parameters when performing an advanced search for chokepoints (see Table 2-14).

**Table 2-14  Search Chokepoint Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search By</td>
<td>Choose MAC Address or Chokepoint Name.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Search parameters may change depending on the selected category. When applicable, enter the additional parameter or filter information to help identify the Search By category. For example, when you select MAC address, you must enter the specific MAC address for this search.</td>
</tr>
</tbody>
</table>
Events

You can configure the following parameters when performing an advanced search for events (see Table 2-14).

Table 2-15  Search Events Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Severity</td>
<td>Choose All Severities, Critical, Major, Minor, Warning, Clear, or Info. Color coded.</td>
</tr>
<tr>
<td>Event Category</td>
<td>Choose All Types, Access Points, Controller, Security, Coverage Hole, Rogue AP, Adhoc Rogue, Interference, Mesh Links, Client, Mobility Service, Location Notifications, Pre Coverage Hole, or WCS.</td>
</tr>
<tr>
<td>Condition</td>
<td>Use the drop-down list to select a condition. Also, you can enter a condition by typing it in this drop-down list.</td>
</tr>
<tr>
<td>Note</td>
<td>If you have selected an event category, this drop-down list would contain the conditions available in that category.</td>
</tr>
</tbody>
</table>

To optimize performance, Events search is limited to the most recent 40,000 events.

See the “Monitoring Rogue Alarm Events” section on page 6-111 for more information on events.

Interferers

You can configure the following parameters when performing an advanced search for interferers detected by access points (see Table 2-16).

Table 2-16  Interferers Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Detected By</td>
<td>Choose All Spectrum Experts or a specific spectrum expert from the drop-down list.</td>
</tr>
<tr>
<td>Search By</td>
<td>Choose All Interferers, Interferer ID, Interferer Category, Interferer Type, Affected Channel, Affected AP, Severity, Power, Duty Cycle or Location.</td>
</tr>
<tr>
<td>Note</td>
<td>Search parameters may change depending on the selected category. When applicable, enter the additional parameter or filter information to help identify the Search By category.</td>
</tr>
<tr>
<td>Severity greater than</td>
<td>Enter the severity index of the interferer search.</td>
</tr>
</tbody>
</table>
Using the Search Feature

You can decide what information displays on the interferers search results page. See the “Configuring the Search Results Display” section on page 2-47 for more information.

### Wi-Fi TDOA Receivers

You can configure the following parameters when performing an advanced search for Wi-Fi TDOA receivers (see Table 2-17).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search By</td>
<td>Choose MAC Address or Wi-Fi TDOA Receivers Name.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Search parameters may change depending on the selected category. When applicable, enter the additional parameter or filter information to help identify the Search By category.</td>
</tr>
</tbody>
</table>

You can configure the following parameters when performing an advanced search for Wi-Fi TDOA receivers (see Table 2-17).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Detected within the last</td>
<td>Choose the time range for the interferer detections. The times range from 5 minutes to 24 hours to All History.</td>
</tr>
<tr>
<td>Interferer status</td>
<td>Select Active from the drop down box to only include active interferers in your search. You can select All to select all or Inactive to search non active interferers.</td>
</tr>
<tr>
<td>Restrict By Radio Band/Channels</td>
<td>Select this checkbox if you want to restrict the interferer search by Radio Band or Channel.</td>
</tr>
<tr>
<td>Affected Channels</td>
<td>If you select Individual Channel as a restriction option, a text box is provided to you to enter the affected channels as a comma separated list and/or in ranges.</td>
</tr>
</tbody>
</table>

You can decide what information displays on the interferers search results page. See the “Configuring the Search Results Display” section on page 2-47 for more information.
Maps

You can configure the following parameters when performing an advanced search for maps (see Table 2-18).

**Table 2-18  Search Map Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search for</td>
<td>Choose All Maps, Campuses, Buildings, Floor Areas, or Outdoor Areas.</td>
</tr>
<tr>
<td>Map Name</td>
<td>Search by Map Name. Enter map name in the text box.</td>
</tr>
</tbody>
</table>

**Note**

You can decide what information displays on the maps search results page. See the “Configuring the Search Results Display” section on page 2-47 for more information.

See the “Information About Maps” section on page 5-2 for more information on maps.

Rogue Clients

You can configure the following parameters when performing an advanced search for rogue clients (see Table 2-19).

**Table 2-19  Search Rogue Client Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search By</td>
<td>Choose All Rogue Clients, MAC Address, Controller, MSE, Floor Area, or Outdoor Area.</td>
</tr>
<tr>
<td>Search In</td>
<td>Choose MSEs or WCS Controllers.</td>
</tr>
<tr>
<td>Status</td>
<td>Select the check box and choose Alert, Contained, or Threat from the drop-down list to include status in the search criteria.</td>
</tr>
</tbody>
</table>

See the “Monitoring Rogue Access Points, Ad hoc Events, and Clients” section on page 3-10 for more information on rogue clients.

Shunned Clients

**Note**

When a Cisco IPS sensor on the wired network detects a suspicious or threatening client, it alerts the controller to shun this client.
You can configure the following parameters when performing an advanced search for shunned clients (see Table 2-20).

### Table 2-20 Search Shunned Client Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search By</td>
<td>Choose All Shunned Clients, Controller, or IP Address.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Search parameters may change depending on the selected category. When applicable, enter the additional parameter or filter information to help identify the Search By category.</td>
</tr>
</tbody>
</table>

### Tags

You can configure the following parameters when performing an advanced search for tags (see Table 2-21).

### Table 2-21 Search Tags Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search By</td>
<td>Choose All Tags, Asset Name, Asset Category, Asset Group, MAC Address, Controller, MSE, Floor Area, or Outdoor Area.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Search parameters may change depending on the selected category. When applicable, enter the additional parameter or filter information to help identify the Search By category.</td>
</tr>
<tr>
<td>Search In</td>
<td>Choose MSEs or WCS Controllers.</td>
</tr>
<tr>
<td>Last detected within</td>
<td>Choose a time increment from 5 minutes to 24 hours. The default is 15 minutes.</td>
</tr>
<tr>
<td>Tag Vendor</td>
<td>Select the check box and choose Aeroscout, G2, PanGo, or WhereNet.</td>
</tr>
<tr>
<td>Telemetry Tags only</td>
<td>Check the Telemetry Tags only to search tags accordingly.</td>
</tr>
</tbody>
</table>
Controller Licenses

You can configure the following parameters when performing an advanced search for controller licenses (see Table 2-22).

### Table 2-22 Search Controller Licenses Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controller Name</td>
<td>Type the controller name associated with the license search.</td>
</tr>
<tr>
<td>Feature Name</td>
<td>Choose All, Plus, or Base depending on the license tier.</td>
</tr>
<tr>
<td>Type</td>
<td>Choose All, Demo, Extension, Grace Period, or Permanent.</td>
</tr>
<tr>
<td>% Used or Greater</td>
<td>Select the percentage of the license use. The percentages range from 0 to 100.</td>
</tr>
</tbody>
</table>

See the “License Center” section on page 16-8 for more information on licenses and the License Center.

Saved Searches

The Saved Search feature enables you to access and run any previously saved search (see Figure 2-17).

**Note**
When saving a search, you must assign a unique name to the search.

**Note**
Saved searches apply only to the current partition.

**Figure 2-17 Saved Search Page**

To access and run a saved search, follow these steps:

**Step 1** Click Saved Search.
**Step 2** Choose a category from the Search Category drop-down list.
Step 3  Choose a saved search from the Saved Search List drop-down list.

Step 4  If necessary, change the current parameters for the saved search.

Step 5  Click Go.

Configuring the Search Results Display

The Edit View page (see Figure 2-18) enables you to choose which columns appear in the Search Results page.

Figure 2-18  Edit View Page

Column names appear in one of the following lists:

- **Hide Information**—Lists columns that do not appear in the table. The Hide button points to this list.
- **View Information**—Lists columns that do appear in the table. The Show button points to this list.

To display a column in a table, click it in the Hide Information list, then click **Show**. To remove a column from a table, click it in the View Information list, then click **Hide**. You can select more than one column by holding down the shift or control key.

To change the position of a column in the View Information list, click it, then click **Up** or **Down**. The higher a column is in the list, the farther left it appears in the table.

**Command Buttons**

The following command buttons appear in the Edit View page:

- **Reset**—Sets the table to the default display.
- **Show**—Moves the highlighted columns from the Hide Information list to the View Information list.
- **Hide**—Moves the highlighted columns from the View Information list to the Hide Information list.
• Up—Moves the highlighted columns upward in the list (further to the left in the table).
• Down—Moves the highlighted columns downward in the list (further to the right in the table).
• Submit—Saves the changes to the table columns and returns to the previous page.
• Cancel—Undoes the changes to the table columns and returns to the previous page.
Configuring Security Solutions

This chapter describes the security solutions for wireless LANs. It contains the following sections:

- Cisco Unified Wireless Network Solution Security, page 3-1
- Interpreting the Security Tab, page 3-4
- Monitoring Rogue Access Points, Ad hoc Events, and Clients, page 3-10
- Adhoc Rogue Alarms, page 3-19
- Rogue Access Point Location, Tagging, and Containment, page 3-21
- Security Overview, page 3-28
- Switch Port Tracing, page 3-36
- Using WCS to Convert a Cisco Unified Wireless Network Solution from Layer 3 to Layer 2 Mode, page 3-37
- Configuring a Firewall for WCS, page 3-38
- Access Point Authorization, page 3-39
- Management Frame Protection (MFP), page 3-39
- Configuring Intrusion Detection Systems (IDS), page 3-41
- Configuring IDS Signatures, page 3-41
- Enabling Web Login, page 3-49
- Certificate Signing Request (CSR) Generation, page 3-52

Cisco Unified Wireless Network Solution Security

The Cisco Unified Wireless Network Solution bundles potentially complicated Layer 1, Layer 2, and Layer 3 802.11 access point security components into a simple policy manager that customizes system-wide security policies on a per wireless LAN basis. It provides simple, unified, and systematic security management tools.

One of the challenges to wireless LAN deployment in the enterprise is Wired Equivalent Privacy (WEP) encryption, which is a weak standalone encryption method. A more recent problem is the availability of low-cost access points that can be connected to the enterprise network and used to mount man-in-the-middle and denial of service attacks. Also, the complexity of add-on security solutions has prevented many IT managers from embracing the benefits of the latest advances in wireless LAN security.
This section contains the following topics:

- Layer 1 Solutions, page 3-2
- Layer 2 Solutions, page 3-2
- Layer 3 Solutions, page 3-2
- Single Point of Configuration Policy Manager Solutions, page 3-2
- Rogue Access Point Solutions, page 3-3

Layer 1 Solutions

The Cisco Unified Wireless Network Solution operating system security solution ensures that all clients gain access within an operator-set number of attempts. Should a client fail to gain access within that limit, it is automatically excluded (blocked from access) until the operator-set timer expires. The operating system can also disable SSID broadcasts on a per wireless LAN basis.

Layer 2 Solutions

If a higher level of security and encryption is required, the network administrator can also implement industry-standard security solutions such as 802.1X dynamic keys with Extensible Authentication Protocol (EAP) or Wi-Fi Protected Access (WPA) dynamic keys. The Cisco Unified Wireless Network Solution WPA implementation includes Advanced Encryption Standard (AES), Temporal Key Integrity Protocol + message integrity code checksum (TKIP + Michael MIC) dynamic keys, or static WEP keys. Disabling is also used to automatically block Layer 2 access after an operator-set number of failed authentication attempts.

Regardless of the wireless security solution selected, all Layer 2 wired communications between controllers and access points are secured by passing data through Lightweight Access Point Protocol (LWAPP) tunnels.

Layer 3 Solutions

The WEP problem can be further solved using industry-standard Layer 3 security solutions such as Virtual Private Networks (VPNs).

The Cisco Unified Wireless Network Solution supports local and RADIUS Media Access Control (MAC) filtering. This filtering is best suited to smaller client groups with a known list of 802.11 access card MAC addresses. The Cisco Unified Wireless Network Solution also supports local and RADIUS user/password authentication. This authentication is best suited to small to medium client groups.

Single Point of Configuration Policy Manager Solutions

When the Cisco Unified Wireless Network Solution is equipped with Cisco WCS, you can configure system-wide security policies on a per wireless LAN basis. Small office, home office (SOHO) access points force you to individually configure security policies on each access point or use a third-party appliance to configure security policies across multiple access points. Because the Cisco Unified Wireless Network Solution security policies can be applied across the whole system from WCS, errors can be eliminated, and the overall effort is greatly reduced.
Rogue Access Point Solutions

This section describes security solutions for rogue access points and contains the following topics:

- Rogue Access Point Challenges, page 3-3
- Tagging and Containing Rogue Access Points, page 3-3
- Securing Your Network Against Rogue Access Points, page 3-3

Rogue Access Point Challenges

Rogue access points can disrupt wireless LAN operations by hijacking legitimate clients and using plain text or other denial of service or man-in-the-middle attacks. That is, a hacker can use a rogue access point to capture sensitive information, such as passwords and usernames. The hacker can then transmit a series of clear-to-send (CTS) frames, which mimics an access point informing a particular wireless LAN client adapter to transmit and instructing all others to wait. This scenario results in legitimate clients being unable to access the wireless LAN resources. Thus, wireless LAN service providers have a strong interest in banning rogue access points from the air space.

The operating system security solution uses the Radio Resource Management (RRM) function to continuously monitor all nearby access points, automatically discover rogue access points, and locate them as described in the “Tagging and Containing Rogue Access Points” section on page 3-3 section.

Tagging and Containing Rogue Access Points

When the Cisco Unified Wireless Network Solution is monitored using WCS, WCS generates the flags as rogue access point traps and displays the known rogue access points by MAC address. The operator can then display a map showing the location of the access points closest to each rogue access point. The next step is to mark them as Known or Acknowledged rogue access points (no further action), Alert rogue access points (watch for and notify when active), or Contained rogue access points (have between one and four access points discourage rogue access point clients by sending the clients deauthenticate and disassociate messages whenever they associate with the rogue access point).

Securing Your Network Against Rogue Access Points

You can secure your network against any rogue access points and disallow access point attacks for those access points not defined in the MAC filter list. Follow these steps to set up MAC filtering:

**Step 1** Choose Configure > Controllers.

**Step 2** Click the IP address for which you want to enter MAC filters.

**Step 3** Choose Security > AAA > MAC Filtering from the left sidebar menu. The MAC Filtering page appears (see Figure 3-1).
Chapter 3  Configuring Security Solutions

Interpreting the Security Tab

Because unauthorized rogue access points are inexpensive and readily available, employees sometimes plug them into existing LANs and build ad hoc wireless networks without IT department knowledge or consent. These rogue access points can be a serious breach of network security because they can be plugged into a network port behind the corporate firewall. Because employees generally do not enable any security settings on the rogue access point, it is easy for unauthorized users to use the access point to intercept network traffic and hijack client sessions. Even more alarming, wireless users frequently publish insecure access point locations, increasing the odds of having the enterprise security breached.

Rather than having a person with a scanner manually detect rogue access points, the Cisco Unified Wireless Network Solution automatically collects information on rogue access points detected by its managed access points (by MAC and IP address) and allows the system operator to locate, tag, and contain them. It can also be used to discourage rogue access point clients by sending them deauthenticate and disassociate messages from one to four access points.

The RADIUS compatibility mode, MAC delimiter, MAC address, interface, and description appear.

Step 4  If you want to set the same configuration across multiple devices, you can choose Add MAC Filter from the Select a command drop-down list, and click Go. If a template exists, you can apply it. If you need to create a template, you can click the URL to get redirected to the template creation page.

Note  The ability to join a controller without specification within a MAC filter list is only supported on mesh access points.

Note  For releases prior to 4.1.82.0, mesh access points do not join the controller unless they are defined in the MAC filter list.

Step 5  To make changes to the profile name, interface, or description, click a specific MAC address in the MAC Address column.
For a summary of existing events and the security state of the network, click the Security tab from the WCS home page. The Rogue Clients page appears (see Figure 3-2).

**Figure 3-2  Rogue Clients Page**

The Security tab contains the following topics:

- Security Index, page 3-5
- Malicious Rogue Access Points, page 3-6
- Adhoc Rogues, page 3-7
- CleanAir Security, page 3-7
- Unclassified Rogue Access Points, page 3-7
- Friendly Rogue Access Points, page 3-8
- Access Point Threats or Attacks, page 3-9
- MFP Attacks, page 3-9
- Attacks Detected, page 3-9
- Recent Rogue AP Alarms, page 3-9
- Recent Adhoc Rogue Alarm, page 3-9
- Most Recent Security Alarms, page 3-9

You can customize the information you want the Security tab to display. Use the Edit Contents link to choose data you want collected and displayed. See the “Editing Content” section on page 2-26 for more information on using the Edit Content link. The default Security tab options are described below.

**Security Index**

The Security Index indicates the security of the WCS managed network, and it is calculated as part of daily background tasks. It is calculated by assigning weight to the various security configurations and displaying it in visual form. The combined weighting can vary from 0 to 100 where 0 signifies the least secured and 100 is the maximum secured. The weighting comes from the lowest scoring controller and the lowest scoring Location Server/Mobility Service Engine related security configurations that are maintained within WCS itself. The Security Index of the WCS managed network is equal to the lowest scoring controller plus the lowest scoring Location Service/Mobility Service Engine.

The security thermometer color range is represented as follows:

- Above or equal to 80 - Green
Interpreting the Security Tab

- Below 80 but greater than or equal to 60 - Yellow
- Below 60 - Red

**Note** Guest WLANs are excluded from the WLANs. A WLAN that has web authentication or web passthrough enabled is identified as a guest WLAN.

The security index of the latest release is the benchmark for the required security configurations. For example, if AES encryption was not present in an earlier version of code, the index is reduced by the number associated with the AES encryption security configuration. Likewise, if new security configurations are introduced, the weighting would be altered.

**Note** The configurations stored in WCS may not be current with the ones in the controllers unless the Refresh from Controller command is run from WCS. You can run Security Index calculations from the Configuration Sync task to get the latest configuration data from all the controllers. See the “Performing a Configuration Sync” section on page 16-19 for steps on enabling the security index.

### Malicious Rogue Access Points

This section provides information on rogue access points that are classified as *Malicious*. Table 3-1 describes the various parameters. For each of these parameters, a value is provided for last hour, last 24 hours, and total active. If you click an underlined number in any of the time period categories, a page with further information appears.

**Note** Malicious access points are detected but untrusted or unknown access points with a malicious intent within the system. They also refer to access points that fit the user-defined malicious rules or have been manually moved from the friendly access point classification.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alert</td>
<td>Indicates the number of rogues in an alert state.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> An access point is moved to Alert if it is not on the neighbor list or part of the user-configured Friendly AP list.</td>
</tr>
<tr>
<td>Contained</td>
<td>Indicates the number of contained rogues.</td>
</tr>
<tr>
<td>Threat</td>
<td>Indicates the number of threat rogues.</td>
</tr>
<tr>
<td>Contained Pending</td>
<td>Indicates the number of contained rogues pending.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Contained Pending indicates that the containment action is delayed due to unavailable resources.</td>
</tr>
</tbody>
</table>
**Adhoc Rogues**

The Adhoc Rogues section displays the rogues that have occurred in the last hour, last 24 hours, and the total active. Table 3-2 describes the various parameters. If you click the number in any of these columns, a page with further information appears.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alert</td>
<td>Indicates the number of ad hoc rogues in an alert state.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>An access point is moved to Alert if it is not on the neighbor list or part of the user-configured Friendly AP list.</td>
</tr>
<tr>
<td>Contained</td>
<td>Indicates the number of contained rogues.</td>
</tr>
<tr>
<td>Threat</td>
<td>Indicates the number of threat rogues.</td>
</tr>
<tr>
<td>Contained Pending</td>
<td>Indicates the number of contained rogues pending.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>Contained pending indicates that the containment action is delayed due to unavailable resources.</td>
</tr>
</tbody>
</table>

**CleanAir Security**

This section provides information on CleanAir security and provides information about the security-risk devices active during the last hour, 24 hours, and Total Active security-risk devices on the wireless network.

The following information is displayed:

- Severity
- Failure Source
- Owner
- Date/Time
- Message
- Acknowledged

To learn more about the security-risk interferers, see the “Monitoring CleanAir Security Alarms” section on page 6-123.

**Unclassified Rogue Access Points**

Table 3-3 describes the unclassified rogue access point parameters. For each of these parameters, a value is provided for last hour, last 24 hours, and total active. If you click an underlined number in any of the time period categories, a page with further information appears.
An unclassified rogue access point refers to a rogue access point that is not classified as either malicious or friendly. These access points can be contained and can be moved manually to the friendly rogue access point list.

Table 3-3     Unclassified Rogue Access Points

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alert</td>
<td>Number of unclassified rogues in alert state. Rogue access point radios appear as Alert when first scanned by the controller or as Pending when operating system identification is underway.</td>
</tr>
<tr>
<td>Contained</td>
<td>Number of contained unclassified rogues.</td>
</tr>
<tr>
<td>Contained Pending</td>
<td>Number of contained unclassified rogues pending.</td>
</tr>
</tbody>
</table>

Friendly Rogue Access Points

This section provides information on rogue access points that are classified as friendly. Table 3-4 describes the various parameters. For each of these parameters, a value is provided for last hour, last 24 hours, and total active. If you click an underlined number in any of the time period categories, a page with further information appears.

Note

Friendly rogue access points are known, acknowledged, or trusted access points. They also refer to access points that fit the user-defined friendly rogue access point rules. Friendly rogue access points cannot be contained.

Table 3-4     Friendly Rogue AP Details

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alert</td>
<td>Indicates the number of rogues in an alert state.</td>
</tr>
<tr>
<td></td>
<td>Note: An access point is moved to Alert if it is not on the neighbor list or part of the user-configured Friendly AP list.</td>
</tr>
<tr>
<td>Internal</td>
<td>Indicates the number of internal access points.</td>
</tr>
<tr>
<td></td>
<td>Note: Internal indicates that the detected access point is inside the network and has been manually configured as Friendly - Internal.</td>
</tr>
<tr>
<td>External</td>
<td>Indicates the number of external access points.</td>
</tr>
<tr>
<td></td>
<td>Note: External indicates that the detected access point is outside of the network and has been manually configured as Friendly - External.</td>
</tr>
</tbody>
</table>
Access Point Threats or Attacks

Table 3-5 describes the AP Threats or Attacks parameters. For each of these parameters, a value is provided for last hour, last 24 hours, and total active. If you click an underlined number in any of the time period categories, a page with further information appears.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fake Attacks</td>
<td>Number of fake attacks</td>
</tr>
<tr>
<td>AP Missing</td>
<td>Number of missing access points</td>
</tr>
<tr>
<td>AP Impersonation</td>
<td>Number of access point impersonations</td>
</tr>
<tr>
<td>AP Invalid SSID</td>
<td>Number of invalid access point SSIDs</td>
</tr>
<tr>
<td>AP Invalid Preamble</td>
<td>Number of invalid access point preambles</td>
</tr>
<tr>
<td>AP Invalid Encryption</td>
<td>Number of invalid access point encryption</td>
</tr>
<tr>
<td>AP Invalid Radio Policy</td>
<td>Number of invalid access point radio policies</td>
</tr>
<tr>
<td>Denial of Service (NAV related)</td>
<td>Number of Denial of Service (NAV related) request</td>
</tr>
<tr>
<td>AP Detected Duplicate IP</td>
<td>Number of detected duplicate access point IPs</td>
</tr>
</tbody>
</table>

MFP Attacks

A value is provided for Infrastructure and client MFP attacks in the last hour, last 24 hours, and total active. If you click an underlined number in any of the time period categories, a page with further information appears.

Attacks Detected

A value is provided for wIPS and signature attacks for the past hour, past 24 hours, and total active. If you click an underline number in any of the time period categories, a page with further information appears.

Recent Rogue AP Alarms

A value is provided for the five most recent rogue alarms. Click the number in parentheses to access the Alarms page. Then click an item under MAC address to view alarm details.

Recent Adhoc Rogue Alarm

Displays the five most recent ad hoc rogue alarms. Click the number in parentheses to access the Alarms page. Click an item under MAC address to view ad hoc details.

Most Recent Security Alarms

Displays the five most recent security alarms. Click the number in parentheses to access the Alarms page.
Monitoring Rogue Access Points, Ad hoc Events, and Clients

This section describes security solutions for rogue devices. A rogue device is an unknown access point or client that is detected by managed access points in your network.

Controllers continuously monitor all nearby access points and automatically discover and collect information on rogue access points and clients. When a controller discovers a rogue access point, it uses the Rogue Location Discovery Protocol (RLDP) to determine if the rogue is attached to your network.

Note

WCS consolidates all of the controllers’ rogue access point data.

You can configure controllers to use RLDP on all access points or only on access points configured for monitor (listen-only) mode. The latter option facilitates automated rogue access point detection in a crowded RF space, allowing monitoring without creating unnecessary interference and without affecting regular data access point functionality. If you configure a controller to use RLDP on all access points, the controller always chooses the monitor access point for RLDP operation if a monitor access point and a local (data) access point are both nearby. If RLDP determines that the rogue is on your network, you can choose to either manually or automatically contain the detected rogue.

This section contains the following topics:
- Monitoring Rogue AP Alarms, page 3-10
- Classifying Rogue Access Points, page 3-12
- Rogue Access Point Classification Types, page 3-13
- Viewing Rogue AP Alarm Details, page 3-15
- Viewing Rogue Client Details, page 3-17

Monitoring Rogue AP Alarms

Rogue access point radios are unauthorized access points detected by one or more Cisco Managed Series lightweight access points.

To open the Rogue AP Alarms page, do one of the following:

- Search for rogue access points. See the “Using the Search Feature” section on page 2-34 for more information about the search feature.
- In the WCS home page, click the Security tab. This page displays all the rogue access points detected in the past hour and the past 24 hours. Click the rogue access point number to view the rogue access point alarms. See the “Security Tab” section on page 2-20 for more information.
- Click the Malicious AP number link in the Malicious Rogue AP Panel. See the “Using the Alarm Summary” section on page 6-80 for more information.

Note

If there are multiple alarm pages, the page numbers are displayed at the top of the page with a scroll arrow on each side. Use it to view additional alarms.

The Rogue AP Alarms page contains the following parameters:

- Severity—Indicates the severity of the alarm.

You can use the Severity Configuration feature to determine the level of severity for the following rogue access point alarm types:
Rogue detected
Rogue detected contained
Rogue detected on network

- Rogue MAC Address—Indicates the MAC address of the rogue access points. See the “Viewing Rogue AP Alarm Details” section on page 3-15.
- Vendor—Rogue access point vendor name or Unknown.
- Classification Type—Malicious, Friendly, or Unclassified. See the “Rogue Access Point Classification Types” section on page 3-13 for additional information.
- Radio Type—Lists all radio types applicable to this rogue access point.
- Strongest AP RSSI—Displays the strongest AP RSSI for this rogue access point across the life of the rogue. The strongest AP RSSI over the life of the rogue displays to indicate the nearest distance that existed between the rogue access point and your building or location. The higher the RSSI, the closer the location.
- No. of Rogue Clients—Indicates the number of rogue clients associated to this rogue access point.

Note: This number comes from the WCS database. It is updated every two hours. In the Monitor > Alarms > Alarm Details page, this number is a real-time number. It is updated each time you open the Alarm Details page for this rogue access point.

- Owner
- Last Seen Time—Indicates the date and time that the rogue access point was last seen.
- State—Indicates the state of the alarm. Possible states vary depending on the classification type of rogue access point. See the “Rogue Access Point Classification Types” section on page 3-13 for additional information.
  - Malicious rogue states include: Alert, Contained, Threat, Contained Pending, and Removed. See the “Malicious Rogue Access Points” section on page 3-6 for more information.
  - Friendly rogue states include: Internal, External, and Alert. See the “Friendly Rogue APs” section on page 3-14 for more information.
  - Unclassified rogue states include: Pending, Alert, Contained, and Contained Pending.
- SSID—Indicates the service set identifier being broadcast by the rogue access point radio. It is blank if the SSID is not being broadcast.
- Map Location—Indicates the map location for this rogue access point.
- Acknowledged—Displays whether or not the alarm is acknowledged by the user. See the “Acknowledging Alarms” section on page 3-25 for more information.

Note: The alarm remains in WCS, and you can search for all Acknowledged alarms using the alarm search functionality.

Caution: When you choose to contain a rogue device, the following warning appears: “There may be legal issues following this containment. Are you sure you want to continue?” The 2.4- and 5-GHz frequencies in the Industrial, Scientific, and Medical (ISM) band are open to the public and can be used without a license. As such, containing devices on another network could have legal consequences.
Classifying Rogue Access Points

Classification and reporting of rogue access points occurs through the use of rogue states and user-defined classification rules that enable rogues to automatically move between states. You can create rules that enable the controller to organize and display rogue access points as Friendly, Malicious, or Unclassified.

Note
WCS consolidates all of the controllers’ rogue access point data.

By default, none of the classification rules are enabled. Therefore, all unknown access points are categorized as Unclassified. When you create a rule, configure conditions for it, and enable the rule, the unclassified access points are reclassified. Whenever you change a rule, it is applied to all access points (friendly, malicious, and unclassified) in the Alert state only.

Note
Rule-based rogue classification does not apply to ad-hoc rogues and rogue clients.

Note
The 5500 series controllers support up to 2000 rogues (including acknowledged rogues); the 4400 series controllers, Cisco WiSM, and Catalyst 3750G Integrated Wireless LAN Controller Switch support up to 625 rogues; and the 2100 series controllers and Controller Network Module for Integrated Services Routers support up to 125 rogues. Each controller limits the number of rogue containments to three per radio (or six per radio for access points in monitor mode).

When the controller receives a rogue report from one of its managed access points, it responds as follows:

1. The controller verifies that the unknown access point is in the friendly MAC address list. If it is, the controller classifies the access point as Friendly.
2. If the unknown access point is not in the friendly MAC address list, the controller starts applying rogue classification rules.
3. If the rogue is already classified as Malicious, Alert or Friendly, Internal or External, the controller does not reclassify it automatically. If the rogue is classified differently, the controller reclassifies it automatically only if the rogue is in the Alert state.
4. The controller applies the first rule based on priority. If the rogue access point matches the criteria specified by the rule, the controller classifies the rogue according to the classification type configured for the rule.
5. If the rogue access point does not match any of the configured rules, the controller classifies the rogue as Unclassified.
6. The controller repeats the previous steps for all rogue access points.
7. If RLDP determines that the rogue access point is on the network, the controller marks the rogue state as Threat and classifies it as Malicious automatically, even if no rules are configured. You can then manually contain the rogue (unless you have configured RLDP to automatically contain the rogue), which would change the rogue state to Contained. If the rogue access point is not on the network, the controller marks the rogue state as Alert, and you can manually contain the rogue.
8. If desired, you can manually move the access point to a different classification type and rogue state.
As mentioned previously, the controller can automatically change the classification type and rogue state of an unknown access point based on user-defined rules, or you can manually move the unknown access point to a different classification type and rogue state. Table 3-6 shows the allowable classification types and rogue states from and to which an unknown access point can be configured.

**Table 3-6  Allowable Classification Type and Rogue State Transitions**

<table>
<thead>
<tr>
<th>From</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Friendly (Internal, External, Alert)</td>
<td>Malicious (Alert)</td>
</tr>
<tr>
<td>Friendly (Internal, External, Alert)</td>
<td>Unclassified (Alert)</td>
</tr>
<tr>
<td>Friendly (Alert)</td>
<td>Friendly (Internal, External)</td>
</tr>
<tr>
<td>Malicious (Alert, Threat)</td>
<td>Friendly (Internal, External)</td>
</tr>
<tr>
<td>Malicious (Contained, Contained Pending)</td>
<td>Malicious (Alert)</td>
</tr>
<tr>
<td>Unclassified (Alert, Threat)</td>
<td>Friendly (Internal, External)</td>
</tr>
<tr>
<td>Unclassified (Contained, Contained Pending)</td>
<td>Unclassified (Alert)</td>
</tr>
<tr>
<td>Unclassified (Alert)</td>
<td>Malicious (Alert)</td>
</tr>
</tbody>
</table>

If the rogue state is Contained, you have to uncontaminate the rogue access point before you can change the classification type. If you want to move a rogue access point from Malicious to Unclassified, you must delete the access point and allow the controller to reclassify it.

**Rogue Access Point Classification Types**

Rogue access points classification types include:

- **Malicious**—Detected but untrusted or unknown access points with a malicious intent within the system. They also refer to access points that fit the user-defined malicious rules or have been manually moved from the friendly access point classification. See the “Malicious Rogue Access Points” section on page 3-6 for more information.

- **Friendly**—Known, acknowledged, or trusted access points. They also refer to access points that fit the user-defined friendly rogue access point rules. Friendly rogue access points cannot be contained. See the “Friendly Rogue APs” section on page 3-14 for more information. For more information on configuring friendly access point rules, see the “Configuring a Friendly Access Point Template” section on page 11-94.

- **Unclassified**—Rogue access point that are not classified as either malicious or friendly. These access points can be contained and can be moved manually to the friendly rogue access point list. See the “Unclassified Rogue APs” section on page 3-14 for more information.

**Malicious Rogue APs**

Malicious rogue access points are detected but untrusted or unknown access points with a malicious intent within the system. They also refer to access points that fit the user-defined malicious rules or have been manually moved from the friendly access point classification.

The Security tab of the WCS home page displays the number of malicious rogue access points for each applicable state for the past hour, the past 24 hours, and the total number of active malicious rogue access points.

Malicious rogue access point states include:
Monitoring Rogue Access Points, Ad hoc Events, and Clients

Chapter 3  Configuring Security Solutions

- Alert—Indicates that the access point is not on the neighbor list or part of the user-configured Friendly AP list.
- Contained—The unknown access point is contained.
- Threat—The unknown access point is found to be on the network and poses a threat to WLAN security.
- Contained Pending—Indicates that the containment action is delayed due to unavailable resources.
- Removed—This unknown access point was seen earlier but is not seen now.

Click an underlined number in any of the time period categories for detailed information regarding the malicious rogue access points. See the “Configuring Alarm Severity” section on page 6-84 for more information.

Friendly Rogue APs

Friendly rogue access points are known, acknowledged or trusted access points. They also refer to access points that fit the user-defined friendly rogue access point rules. Friendly rogue access points cannot be contained.

The Security tab of the WCS home page displays the number of friendly rogue access points for each applicable state for the past hour, the past 24 hours, and the total number of active friendly rogue access points.

Friendly rogue access point states include:
- Internal—If the unknown access point is inside the network and poses no threat to WLAN security, you would manually configure it as Friendly, Internal. For example, the access points in your lab network.
- External—If the unknown access point is outside the network and poses no threat to WLAN security, you would manually configure it as Friendly, External. For example, the access points belonging to a neighboring coffee shop.
- Alert—The unknown access point is not on the neighbor list or part of the user-configured Friendly AP list.

Click an underlined number in any of the time period categories for detailed information regarding the friendly rogue access points. See the “Configuring Alarm Severity” section on page 6-84 for more information.

Unclassified Rogue APs

An unclassified rogue access point refers to a rogue access point that is not classified as either malicious or friendly. These access points can be contained and can be moved manually to the friendly rogue access point list.

The Security tab of the WCS home page displays the number of unclassified rogue access points for each applicable state for the past hour, the past 24 hours, and the total number of active unclassified rogue access points.

Unclassified rogue access point states include:
- Pending—On first detection, the unknown access point is put in the Pending state for 3 minutes. During this time, the managed access points determine if the unknown access point is a neighbor access point.
- Alert—The unknown access point is not on the neighbor list or part of the user-configured Friendly AP list.
- Contained—The unknown access point is contained.
• Contained Pending—The unknown access point is marked Contained, but the action is delayed due to unavailable resources.

Click an underlined number in any of the time period categories for further information. See the “Configuring Alarm Severity” section on page 6-84.

### Viewing Rogue AP Alarm Details

Rogue access point radios are unauthorized access points detected by Cisco managed lightweight access points. Alarm event details for each rogue access point are available from the Rogue AP Alarms list page.

To view alarm events for a rogue access point radio, follow these steps:

**Step 1**

In the Monitor > Alarms list page for rogue access point alarms, click the rogue MAC address for the applicable alarm. The Alarm Details page opens.

**Note**

All Alarm Details page fields (except No. of Rogue Clients) are populated through polling and are updated every two hours. The number of rogue clients is a real-time number and is updated each time you access the Alarm Details page for a rogue access point alarm.

The Alarm Details page displays the following information:

- **General**
  - Rogue MAC Address—MAC address of the rogue access points.
  - Vendor—Rogue access point vendor name or Unknown.

**Note**

When a rogue access point alarm displays for Airlink, the vendor displays as Alpha instead of Airlink.

- Rogue Type—Indicates the rogue type such as AP.
- On Network—Indicates how the rogue detection occurred.
  - Controller—The controller detected the rogue (Yes or No).
  - Switch Port Trace—The rogue was detected by a switch port trace. Indicated by one of the following: Traced but not found, Traced and found, Not traced.
- Owner—Indicates the owner or is left blank.
- Acknowledged—Indicates whether or not the alarm is acknowledged by the user. See the “Acknowledging Alarms” section on page 3-25 for more information.
- Classification Type—Malicious, Friendly, or Unclassified. See the “Rogue Access Point Classification Types” section on page 3-13 for more information.
- State—Indicates the state of the alarm. Possible states vary depending on the classification type of rogue access point. See the “Rogue Access Point Classification Types” section on page 3-13 for additional information.
- SSID—Service Set Identifier being broadcast by the rogue access point radio. (Blank if SSID is not broadcast.)
- Channel Number—Indicates the channel of the rogue access point.
- Containment Level—Indicates the containment level of the rogue access point or Unassigned (not contained).
- Radio Type—Lists all radio types applicable to this rogue access point.
- Strongest AP RSSI—Displays the strongest AP RSSI for this rogue access point across the life of the rogue. The strongest AP RSSI over the life of the rogue displays to indicate the nearest distance that existed between the rogue access point and your building or location. The higher the RSSI, the closer the location.
- No. of Rogue Clients—Indicates the number of rogue clients associated to this rogue access point.

**Note**
The number of rogue clients is the only real-time field on the Monitor > Alarm > Alarm Details page. It updates each time you open the Alarm Details page for this rogue access point. All other fields on the Alarm Details page are populated through polling and are updated every two hours.

- First Seen Time—Indicates the date and time when the rogue access point was first detected. This information is populated from the controller.
- Last Seen Time—Indicates the date and time when the rogue access point was last detected. This information is populated from the controller.
- Modified—Indicates when the alarm event was modified.
- Generated By—Indicates how the alarm event was generated (either NMS or from a trap).
  - NMS (Network Management System)—Provided through polling.
  - Trap—Provided by the controller.
- Severity—The severity of the alarm.
  You can use the Severity Configuration feature to determine the level of severity for rogue access points.
- Previous Severity—The previous severity of the alarm: Critical, Major, Minor, Clear.

- Event Details—Click to open the Monitor > Rogue AP Alarm > Rogue AP Events page. See the “Monitoring Rogue Alarm Events” section on page 3-25 for more information.
- Switch Port Trace Status—Indicates the switch port trace status. See the “Switch Port Tracing” section on page 3-36 for more information regarding switch port tracing. Potential switch port trace statuses include:
  - Not traced—Switch port tracing was never executed.
  - Failed—The switch port trace failed. Please check the detail status page in the Switch Port Trace dialog for more information.
  - Traced and detected on network—Yes network means "wired" network. This state indicates that the switch port trace was executed, and a rogue access point was found on the wired network.
  - Traced but not detected on wire—The switch port trace was executed but no rogue access point was not found on the network.
  - Traced and wire contained—The switch port trace was executed, and the switch port to which a rogue access point was connected is now disabled. The rogue access point is now wire contained.
• Switch Port Tracing Details—Provides the most recent switch port tracing details. To view additional trace details, use the Click here for more details link. See the “Switch Port Tracing” section on page 3-36 for more information.

• Rogue Clients—Lists rogue clients for this access point including the client MAC address, the last date and time the client was heard, and the current client status. See the “Viewing Rogue Client Details” section on page 3-17 for more information.

  **Note**  
  The number of rogue clients is the only real-time field on the Monitor > Alarm > Alarm Details page. It updates each time you open the Alarm Details page for this rogue access point. All other fields on the Alarm Details page are populated through polling and are updated every two hours.

• Message—Displays the most recent message regarding this rogue access point. A message is sent for the following: When the rogue access point is first detected, for any trap sent, and for any changed state.

• Annotations—Lists current notes regarding this rogue access point. To add a new note, click New Annotation. Type the note and click Post to save and display the note or Cancel to close the page without saving the note.

  Location Notifications—Displays the number of location notifications logged against the client. Clicking a link displays the notifications.

• Location—Provides location information, if available.

  **Note**  
  The switch port tracing will not update any of the rogue attributes such as severity, state, and so on. As the rogue attributes are not updated by switch port tracing, alarms would not be triggered if a rogue is discovered to be ‘on network’ using switch port tracing.

### Viewing Rogue Client Details

You can view a list of rogue clients in several ways:

• Perform a search for rogue clients using the WCS Search feature. See the “Using the Search Feature” section on page 2-34 for more information.

• View the list of rogue clients for a specific rogue access point from the Alarm Details page for the applicable rogue access point. Click the Rogue MAC Address for the applicable rogue client to view the Rogue Client details page.

• In the Alarms Details page of a rogue access point, choose Rogue Clients from the Select a command drop-down list.

The Rogue Clients page displays the Client MAC Address, when it was last heard, its current status, its controller, and the associated rogue access point.

  **Note**  
  Rogue client statuses include: Contained (the controller contains the offending device so that its signals no longer interfere with authorized clients); Alert (the controller forwards an immediate alert to the system administrator for further action); and Threat (the rogue is a known threat).

Click the Client MAC Address for the rogue client to view the Rogue Client details page. The Rogue Client details page displays the following information:
Monitoring Rogue Access Points, Ad hoc Events, and Clients

- General—Information includes: client MAC address, number of access points that detected this client, when the client was first and last heard, the rogue access point MAC address, and the current status of the client.
- Location Notifications—Indicates the number of notifications for this rogue client including: absence, containment, distance, and all. Click the notification number to open the applicable Monitor > Alarms page.
- APs that detected the rogue client—Provides the following information for all access points that detected this rogue client: base radio MAC address, access point name, channel number, radio type, RSSI, SNR, and the date/time that the rogue client was last heard.
- Location Information

Select a command Menu

The Select a command drop-down list located on the Rogue AP Alarm Details page provides the following options. Select an option from the drop-down list and click Go.

- Assign to me—Assign the selected alarm(s) to the current user.
- Unassign—Unassign the selected alarm(s).
- Delete—Delete the selected alarm(s).
- Clear—Clear the selected alarm(s).
- Acknowledge Alarm—Acknowledge the alarm to prevent it from showing up in the Alarm Summary page. See the “Acknowledging Alarms” section on page 3-25 for more information.

Note The alarm remains in WCS and you can search for all Acknowledged alarms using the alarm search functionality.

- Unacknowledge—Unacknowledge an already acknowledged alarm.
- Trace Switch Port—Click to run a switch port trace for this rogue access point. See the “Switch Port Tracing” section on page 3-36 for more information.
- Event History—Click to view a list of events for this rogue access point. See the “Monitoring Rogue Alarm Events” section on page 3-25 for more information.
- Refresh from Network—Click to sync up the rogue APs from the network.
- View Detecting AP on Network—View the Cisco 1000 Series lightweight access points that are currently detecting the rogue access point. See the “Detecting Access Points on a Network” section on page 3-22 for more information.

Note Detecting AP Name, Radio, SSID information might be empty as the information is not available on controller. Refresh the page after the rogue AP task is completed to see the AP details.

- View Details by Controller—View the classification type and state of the rogue APs reported by the controller.

Note For more information about rogue AP Background Task Performance Tuning, see “Rogue AP Background Task Performance Tuning” section on page A-9.
Adhoc Rogue Alarms

If the MAC address of a mobile client operating in an adhoc network is not in the authorized MAC address list, then it is identified as an adhoc rogue.

- Monitoring Adhoc Rogue Alarms, page 3-19
- Viewing Adhoc Rogue Alarm Details, page 3-20

Monitoring Adhoc Rogue Alarms

The Adhoc Rogue Alarms page displays alarm events for adhoc rogues.

To access the Adhoc Rogue Alarms page, do one of the following:

- Map (High Resolution)—Click to display a high-resolution map of the rogue access point location.
- Rogue Clients—Click to view a list of rogue clients associated with this rogue access point. The Rogue Clients page displays the Client MAC Address, when it was last heard, its current status, its controller, and the Rogue access point. See the “Viewing Rogue Client Details” section on page 3-17 for more information. This information can also be accessed by using the WCS Search feature. See the “Quick Search” section on page 2-34 or the “Advanced Search” section on page 2-35 for more information.
- Set State to ‘Unclassified - Alert’—Choose this command to tag the rogue access point as the lowest threat, continue monitoring the rogue access point, and to turn off Containment. See the “Unclassified Rogue APs” for more information on Unclassified rogues.
- Set State to ‘Malicious - Alert’—Choose this command to tag the rogue access point as ‘Malicious’. See the “Malicious Rogue Access Points” section on page 3-6 for more information on Malicious rogues.
- Set State to ‘Friendly - Internal’—Choose this command to tag the rogue access point as internal, add it to the Known Rogue APs list, and to turn off Containment. See the “Friendly Rogue APs” section on page 3-14 for more information on Friendly rogues.
- Set State to ‘Friendly - External’—Choose this command to tag the rogue access point as external, add it to the Known Rogue APs list, and to turn off Containment. See the “Friendly Rogue APs” section on page 3-14 for more information on Friendly rogues.
- 1 AP Containment—Target the rogue access point for containment by one access point. (Lowest containment level.)
- 2 AP Containment—Target the rogue access point for containment by two Cisco 1000 Series lightweight access points.
- 3 AP Containment—Target the rogue access point for containment by three Cisco 1000 Series lightweight access points.
- 4 AP Containment—Target the rogue access point for containment by four Cisco 1000 Series lightweight access points. (Highest containment level.)

Note The higher the threat of the rogue access point, the higher the containment required.
• Perform a search for adhoc rogue alarms. See the “Using the Search Feature” section on page 2-34 for more information.

• In the WCS home page, click the Security tab. This page displays all the adhoc rogues detected in the past hour and the past 24 hours. Click the adhoc rogue number to view the adhoc rogue alarms.

If there are multiple alarm pages, the page numbers are displayed at the top of the page with a scroll arrow on each side. Use this to view additional alarms.

The Adhoc Rogue Alarms page contains the following parameters:

• Severity—Indicates the severity of the alarm.

• You can use the Severity Configuration feature to determine the level of severity for the following adhoc rogue alarm types:
  – Adhoc Rogue auto contained
  – Adhoc Rogue detected
  – Adhoc Rogue detected on network
  – Adhoc Rogue detected on network

• Rogue MAC Address—Indicates the MAC address of the rogue. See the “Viewing Adhoc Rogue Alarm Details” section on page 3-20 for more information.

• Vendor—Indicates the adhoc rogue vendor name, or Unknown.

• Radio Type—Lists all radio types applicable to this rogue access point.

• Strongest AP RSSI—Displays the strongest AP RSSI for this rogue across the life of the rogue. The strongest AP RSSI over the life of the rogue displays to indicate the nearest distance that existed between the rogue and your building or location. The higher the RSSI, the closer the location.

• No. of Rogue Clients—Indicates the number of rogue clients associated to this rogue access point.

Note: The number of rogue clients is the only real-time field on the Monitor > Alarm > Alarm Details page. It updates each time you open the Alarm Details page for this rogue access point. All other fields on the Alarm Details page are populated through polling and are updated every two hours.

• Owner—Indicates the owner or is left blank.

• Last Seen Time—Indicates the date and time that the alarm was last viewed.

• State—Indicates the state of the alarm. Possible states for adhoc rogues include Threat, Alert, Internal, External, Contained, Contained Pending, and Removed.

• SSID—The Service Set Identifier that is being broadcast by the rogue adhoc radio. It is blank if there is no broadcast.

• Map Location—Indicates the map location for this adhoc rogue.

• Acknowledged—Displays whether or not the alarm is acknowledged by the user. See the “Acknowledging Alarms” section on page 3-25 for more information.

### Viewing Adhoc Rogue Alarm Details

Alarm event details for each adhoc rogue are available from the Adhoc Rogue Alarms page.

• In the Adhoc Rogue Alarms page, click an item under Rogue MAC Address.
This page displays alarm events for a rogue access point radio. Rogue access point radios are unauthorized access points detected by Cisco managed lightweight access points. The following information is available:

- **General**
  - Rogue MAC Address—Media Access Control address of the adhoc rogue.
  - Vendor—Adhoc rogue vendor name or Unknown.
  - On Network—Indicates how the rogue detection occurred.
    - Controller—The controller detected the rogue (Yes or No).
    - Switch Port Trace—The rogue was detected by a switch port trace. Indicated by one of the following: Traced but not found, Traced and found, Not traced.
  - Owner—Indicates the owner or left blank.
  - Acknowledged—Indicates whether or not the alarm is acknowledged by the user.
  - State—Indicates the state of the alarm. Possible states for adhoc rogues include Threat, Alert, Internal, External, Contained, Contained Pending, and Removed.
  - SSID—Service Set Identifier being broadcast by the adhoc rogue radio. (Blank if SSID is not broadcast.)
  - Channel Number—Indicates the channel of the adhoc rogue.
  - Containment Level—Indicates the containment level of the adhoc rogue or Unassigned.
  - Radio Type—Lists all radio types applicable to this adhoc rogue.
  - Strongest AP RSSI—Indicates the strongest received signal strength indicator for this WCS (including all detecting access points for all controllers and across all detection times).
  - No. of Rogue Clients—Indicates the number of rogue clients associated to this adhoc.
  - Created—Indicates when the alarm event was created.
  - Modified—Indicates when the alarm event was modified.
  - Generated By—Indicates how the alarm event was generated.
  - Severity—Indicates the severity of the alarm.
  - Previous Severity—The previous severity of the alarm: Critical, Major, Minor, Clear. Color coded.

- **Annotations**—Enter any new notes in this box and click **Add** to update the alarm.
- **Message**—Displays descriptive information about the alarm.
- **Help**—Displays the latest information about the alarm.
- **Event History**—Click to access the Monitor > Events page. See “Monitoring Events” for more information.
- **Annotations**—Lists existing notes for this alarm.

## Rogue Access Point Location, Tagging, and Containment

When the Cisco Unified Wireless Network Solution is monitored using WCS, WCS generates the flags as rogue access point traps and displays the known rogue access points by MAC address. The operator can then display a map showing the location of the access points closest to each rogue access point. The next step is to mark them as **Known** or **Acknowledged** rogue access points (no further action), **Alert**
rogue access points (watch for and notify when active), or Contained rogue access points (have between one and four access points discourage rogue access point clients by sending the clients deauthenticate and disassociate messages whenever they associate with the rogue access point).

This built-in detection, tagging, monitoring, and containment capability enables system administrators to take the appropriate action:

- Locate rogue access points
- Receive new rogue access point notifications, eliminating hallway scans
- Monitor unknown rogue access points until they are eliminated or acknowledged
- Determine the closest authorized access point, making directed scans faster and more effective
- Contain rogue access points by sending their clients deauthenticate and disassociate messages from one to four access points. This containment can be done for individual rogue access points by MAC address or can be mandated for all rogue access points connected to the enterprise subnet.

- Tag rogue access points:
  - Acknowledge rogue access points when they are outside of the LAN and do not compromise the LAN or wireless LAN security
  - Accept rogue access points when they do not compromise the LAN or wireless LAN security
  - Tag rogue access points as unknown until they are eliminated or acknowledged
  - Tag rogue access points as contained and discourage clients from associating with the rogue access points by having between one and four access points transmit deauthenticate and disassociate messages to all rogue access point clients. This function applies to all active channels on the same rogue access point.

This section contains the following topics:

- Detecting Access Points on a Network, page 3-22
- Viewing Rogue Access Points by Controller, page 3-23

### Detecting Access Points on a Network

Use the Detecting Access Points feature to view information about the Cisco lightweight access points that are detecting a rogue access point.

To access the Rogue AP Alarms details page, follow these steps:

**Step 1** To display the Rogue AP Alarms page, do one of the following:

- Perform a search for rogue APs. See the “Using the Search Feature” section on page 2-34 for more information about the search feature.
- In the WCS home page, click the Security tab. This page displays all the rogue access points detected in the past hour and the past 24 hours. Click the rogue access point number to view the rogue access point alarms.
- Click the Malicious AP number link in the box. See the “Using the Alarm Summary” section on page 6-80 for more information.

**Step 2** In the Rogue AP Alarms page, click the Rogue MAC Address for the applicable rogue access point. The Rogue AP Alarms details page displays.

**Step 3** From the Select a command drop-down list, choose View Detecting AP on Network.

**Step 4** Click Go.
Click a list item to display data about that item:

- AP Name
- Radio
- Detecting AP Location
- SSID—Service Set Identifier being broadcast by the rogue access point radio. (Blank if SSID is not broadcast.)
- Channel Number—The channel on which the rogue access point is broadcasting.
- WEP—Enabled or disabled.
- WPA—Enabled or disabled.
- Pre-Amble—Long or short.
- RSSI—Received signal strength indicator in dBm.
- SNR—Signal-to-noise ratio.
- Containment Type—Type of containment applied from this access point.
- Containment Channels—Channels that this access point is currently containing.

**Viewing Rogue Access Points by Controller**

Use the Detecting Access Points feature to view information about the the rogue access points by controller.

To access the Rogue AP Alarms details page, follow these steps:

**Step 1**
To display the Rogue AP Alarms page, do one of the following:

- Perform a search for rogue APs. See the “Using the Search Feature” section on page 2-34 for more information about the search feature.
- In the WCS home page, click the Security tab. This page displays all the rogue access points detected in the past hour and the past 24 hours. Click the rogue access point number to view the rogue access point alarms.
- Click the Malicious AP number link in the box. See the “Using the Alarm Summary” section on page 6-80 for more information.

**Step 2**
In the Rogue AP Alarms page, click the Rogue MAC Address for the applicable rogue access point. The Rogue AP Alarms details page displays.

**Step 3**
From the Select a command drop-down list, choose View AP Details by Controller.

**Step 4**
Click Go.

Click a list item to display data about that item:

- Controller IP Address
- Detecting AP Name
- Radio
- Detecting AP Location
- SSID—Service Set Identifier being broadcast by the rogue access point radio. (Blank if SSID is not broadcast.)
Rogue Access Point Location, Tagging, and Containment

Channel Number—The channel on which the rogue access point is broadcasting.

RSSI—Received signal strength indicator in dBm.

Classification—Indicates if the rogue AP classification.

State—Indicates the state of the alarm. Possible states vary depending on the classification type of rogue access point. See the “Rogue Access Point Classification Types” section on page 3-13 for additional information.

On Network—Whether it belongs to this network “Yes” or “No”.

Containment Level—Indicates the containment level of the rogue access point or Unassigned (not contained).

Last Updated Time

<table>
<thead>
<tr>
<th>Working with Alarms</th>
</tr>
</thead>
<tbody>
<tr>
<td>You can view, assign, and clear alarms and events on access points and mobility services engine using Cisco WCS.</td>
</tr>
<tr>
<td>Details on how to have email notifications of alarms sent to you is also described. This section contains the following topics:</td>
</tr>
<tr>
<td>• Assigning and Unassigning Alarms, page 3-24</td>
</tr>
<tr>
<td>• Deleting and Clearing Alarms, page 3-24</td>
</tr>
<tr>
<td>• Acknowledging Alarms, page 3-25</td>
</tr>
</tbody>
</table>

Assigning and Unassigning Alarms

To assign and unassign an alarm to yourself, follow these steps:

**Step 1** Perform an advanced search for access point alarms. See the “Using the Search Feature” section on page 2-34 for more information.

**Step 2** Select the alarms that you want to assign to yourself by selecting their corresponding check boxes.

**Note** To unassign an alarm assigned to you, unselect the box next to the appropriate alarm. You cannot unassign alarms assigned to others.

**Step 3** From the Select a command drop-down list, choose Assign to Me (or Unassign), and click Go.

If you choose Assign to Me, your username appears in the Owner column. If you choose Unassign, the username column becomes empty.

Deleting and Clearing Alarms

To delete or clear an alarm from a mobility services engine, follow these steps:
Step 1  In the Monitor > Alarms page, select the alarms that you want to delete or clear by selecting their corresponding check boxes.

Note  If you delete an alarm, Cisco WCS removes it from its database. If you clear an alarm, it remains in the Cisco WCS database, but in the Clear state. You clear an alarm when the condition that caused it no longer exists.

Step 2  From the Select a command drop-down list, choose Delete or Clear, and click Go.

Note  To set up cleanup of old alarms and cleared alarms, choose Administration > Settings > Alarms.

Acknowledging Alarms

You may want certain alarms to be removed from the Alarms List. For example, if you are continuously receiving an interference alarm from a certain access point on the 802.11g interface, you may want to stop that access point from being counted as an active alarm on the page or any alarms list. In this scenario, you can find the alarm for the 802.11g interface in the Alarms list, select the check box, and choose Acknowledge from the Select a command drop-down list.

Now if the access point generates a new violation on the same interface, WCS will not create a new alarm, and the page shows no new alarms. However, if the interference violation is created on another interface, such as 802.11a, a new alarm is created.

Any alarms, once acknowledged, will not show up on either the page or any alarm list page. Also, no emails are generated for these alarms after you have marked them as acknowledged. By default, acknowledged alarms are not included for any search criteria. To change this default, choose Administration > Settings > Alarms page and disable the Hide Acknowledged Alarms preference.

Note  When you acknowledge an alarm, a warning displays as a reminder that a recurrence of the problem does not generate another alarm unless this functionality is disabled. Use the Administration > User Preferences page to disable this warning message.

You can also search for all previously acknowledged alarms to reveal the alarms that were acknowledged during the last seven days. WCS automatically deletes cleared alerts that are more than seven days old so your results can only show activity for the last seven days. Until an existing alarm is deleted, a new alarm cannot be generated for any managed entity for which WCS has already generated an alarm.

Monitoring Rogue Alarm Events

The Events page enables you to review information about rogue alarm events. WCS generates an event when a rogue access point is detected or if you make manual changes to a rogue access point (such as changing its state). The Rogue AP Events list page displays all rogue access point events.

To access the Rogue AP Events list page, follow these steps:

Step 1  Do one of the following:
Step 2  The Rogue AP Events list page displays the following event information.

- **Severity**—Indicates the severity of the alarm.
- **Rogue MAC Address**—Click the rogue MAC address to view the Rogue AP Event Details page. See the “Viewing Rogue AP Event Details” section on page 3-26 for more information.
- **Vendor**—Rogue access point vendor name or Unknown.
- **Classification Type**—Malicious, Friendly, or Unclassified. See the “Rogue Access Point Classification Types” section on page 3-13 for more information.
- **On Network**—Indicates how the rogue detection occurred.
  - **Controller**—The controller detected the rogue (Yes or No).
  - **Switch Port Trace**—The rogue was detected by a switch port trace. Indicated by one of the following: Traced but not found, Traced and found, Not traced.
- **Radio Type**—Lists all radio types applicable to this rogue access point.
- **Date/Time**—The date and time that the event was generated.
- **State**—Indicates the state of the alarm. Possible states vary depending on the classification type of rogue access point. See the “Rogue Access Point Classification Types” section on page 3-13 for additional information.
- **SSID**—Service Set Identifier being broadcast by the rogue access point radio. (Blank if SSID is not broadcast.)

---

### Viewing Rogue AP Event Details

To view rogue access point event details, follow these steps:

Step 1  In the Rogue AP Events list page, click the Rogue MAC Address link.

Step 2  The Rogue AP Events Details page displays the following information:

- **Rogue MAC Address**
- **Vendor**—Rogue access point vendor name or Unknown.
- **On Network**—Indicates how the rogue detection occurred.
  - **Controller**—The controller detected the rogue (Yes or No).
  - **Switch Port Trace**—The rogue was detected by a switch port trace. Indicated by one of the following: Traced but not found, Traced and found, Not traced.
- **Classification Type**—Malicious, Friendly, or Unclassified. See the “Rogue Access Point Classification Types” section on page 3-13 for more information.
- **State**—Indicates the state of the alarm. Possible states vary depending on the classification type of rogue access point. See the “Rogue Access Point Classification Types” section on page 3-13 for additional information.
Monitoring Adhoc Rogue Events

The Events page enables you to review information about adhoc rogue events. WCS generates an event when an adhoc rogue is detected or if you make manual changes to an adhoc rogue (such as changing its state). The Adhoc Rogue Events list page displays all adhoc rogue events.

To access the Rogue AP Events list page, follow these steps:

**Step 1**
Do one of the following:

- Perform a search for adhoc rogues events using the Advanced Search feature of WCS. See the “Using the Search Feature” section on page 2-34 for more information.
- In the Adhoc Rogue Alarms details page, choose Event History from the Select a command drop-down list. See the “Viewing Adhoc Rogue Alarm Details” section on page 3-20 for more information.

**Step 2**
The Rogue AP Events list page displays the following event information.

- Severity—Indicates the severity of the alarm.
- Rogue MAC Address—Click the rogue MAC address to view the Rogue AP Event Details page. See the “Viewing Adhoc Rogue Event Details” section on page 3-28 for more information.
- Vendor—Rogue access point vendor name or Unknown.
- On Network—Indicates how the rogue detection occurred.
  - Controller—The controller detected the rogue (Yes or No).
  - Switch Port Trace—The rogue was detected by a switch port trace. Indicated by one of the following: Traced but not found, Traced and found, Not traced.
- Radio Type—Lists all radio types applicable to this rogue access point.
- Date/Time—The date and time that the event was generated.
- State—Indicates the state of the alarm. Possible states for adhoc rogues include Threat, Alert, Internal, External, Contained, Contained Pending, and Removed.
- SSID—Service Set Identifier being broadcast by the rogue access point radio. (Blank if SSID is not broadcast.)
Viewing Adhoc Rogue Event Details

To view rogue access point event details, follow these steps:

**Step 1** In the Rogue AP Events list page, click the Rogue MAC Address link.

**Step 2** The Rogue AP Events Details page displays the following information:

- Rogue MAC Address
- Vendor—Rogue access point vendor name or Unknown.
- On Network—Indicates how the rogue detection occurred.
  - Controller—The controller detected the rogue (Yes or No).
  - Switch Port Trace—The rogue was detected by a switch port trace. Indicated by one of the following: Traced but not found, Traced and found, Not traced.
- State—Indicates the state of the alarm. Possible states for adhoc rogues include Threat, Alert, Internal, External, Contained, Contained Pending, and Removed.
- SSID—Service Set Identifier being broadcast by the rogue access point radio. (Blank if SSID is not broadcast.)
- Channel Number—The channel on which the rogue access point is broadcasting.
- Containment Level—Indicates the containment level of the rogue access point or Unassigned.
- Radio Type—Lists all radio types applicable to this rogue access point.
- Created—The date and time that the event was generated.
- Generated By—The method by which the event was generated (such as Controller).
- Device IP Address
- Severity—Indicates the severity of the alarm.
- Message—Provides details of the current event.

Security Overview

WCS provides a foundation that allows IT managers to design, control, secure, and monitor enterprise wireless networks from a centralized location.

Cisco WCS provides the following tools for managing and enforcing wireless security configurations and policies within the Cisco wireless network infrastructure:

- Network security policy creation and enforcement, such as user authentication, encryption, and access control
- Wireless infrastructure security configuration
- Rogue detection, location, and containment
- Wireless intrusion prevention system (wIPS)
- Wireless IPS signature tuning and management
- Management Frame Protection (MFP)
- Collaboration with Cisco wired Network IPS for monitoring and mitigating unauthorized or malicious wireless user activity
Chapter 3      Configuring Security Solutions

Security Overview

- Comprehensive security event management and reporting

Security Vulnerability Assessment

In Cisco Unified Wireless Network Version 5.1, an automated security vulnerability assessment is available to facilitate analysis of an enterprise's overall wireless security posture, as well as to provide WLAN operators with real-time benchmarking of their security services configurations against industry best practices. The automated security vulnerability assessment provides:

- Proactive vulnerability monitoring of the entire wireless network
- Comprehensive information on security vulnerabilities that could lead to loss of data, network intrusion, or malicious attack
- Reduction in the time and expertise required to analyze and remedy weaknesses in wireless security posture

The automated wireless vulnerability assessment audits the security posture of the entire wireless network for vulnerabilities. These vulnerabilities can result in:

- Unauthorized management access or using management protocols to compromise or adversely impact the network
- Unauthorized network access, data leakage, man-in-the-middle, or replay attacks
- Compromised or adverse impacts to the network through manipulation of network protocols and services, for example through denial of service (DoS) attacks

The Cisco WCS automatically scans the entire network and compares settings against Cisco recommended and industry best practices for wireless security configurations. The automated wireless security assessment functions within WCS scan wireless LAN controllers, access points, and network management interfaces for vulnerabilities in configuration settings, encryption, user authentication, infrastructure authentication network management, and access control.

Status of the wireless network security is graphically displayed to provide wireless network administrators with an easy-to-read dashboard of security events. The WCS displays the vulnerability assessment results through a Security Index on the WCS security dashboard. The Security Index summarizes the network security posture with a composite security score and prioritized summary of vulnerabilities. See the “Security Index” section on page 3-29 for more information.

Administrators can drill down to the Security Index Detailed Report if an event in the Security Summary warrants further investigation. The Security Index Detailed Report provides in-depth analysis of the vulnerabilities across the network. It also identifies optimal security settings and recommends changes that will remedy the vulnerabilities. Any changes the administrator makes are reflected in an updated Security Index score. See the “Security Index Detailed Report” section on page 3-30 for more information.

Security Index

Security Index gives an indication of the security of the WCS managed network. The security index is calculated by assigning weight to the various security configurations and displaying it in visual form. The combined weightages can vary from 0 to 100, where 0 signifies least secured and 100 maximum secured.

The weighting comes from the lowest scoring controller and the lowest scoring Location Server/Mobility Service Engine related security configurations that are maintained within WCS itself. For example, the security index of the WCS managed network is equal to the lowest scoring controller plus the lowest scoring Location Server/Mobility Service Engine.
Security Overview

The following color scheme applies for the security index:

- Above or equal to 80—Green
- Below 80 but above or equal to 60—Yellow
- Below 60—Red

Note

Guest WLANs are excluded from the WLANs. A WLAN which has web authentication or web passthrough enabled is identified as a guest WLAN.

The security index of the latest release is the benchmark for the required security configurations. For example, if AES encryption was not present in an earlier version of code, the index is reduced by the number associated with the AES encryption security configuration. Likewise, if new security configurations are introduced, the weighting would be altered.

The configurations stored in WCS may not be up-to-date with the ones in the controllers unless the Refresh from Controller command is run from WCS. You can run Security Index calculations from the Configuration Sync task to get the latest config data from all the controllers.

Top Security Issues

The Top Security Issues section displays the five top security issues. The View All and Devices links sort relevant columns and show a report of security issues occurring across all controllers. Click View All to open the Security Index Detailed Report. Click Devices to view the Security Index Controller Report.

- Security Index Detailed Report, page 3-30
- Security Index Controller Report, page 3-31
- Potential Security Issues, page 3-31

Security Index Detailed Report

The Security Index Detailed Report displays all security issues found across all controllers, location servers, and mobility service engines. It details problems found in a particular security configuration retrieved from the device. If a particular issue has been acknowledged (just like alarms), it is ignored when the next Configuration Sync task runs (if Security Index Calculation is enabled).

In some cases when an issue is acknowledged and it is ignored the next time the Configuration Sync task runs, the final security index score does not change. Some possible reasons for this may include:

- The acknowledged issue is on a controller which is not directly affecting the security index score (for instance, it is not the controller with the lowest score).
- The acknowledged issue is on a WLAN that is not directly affecting the security index score. Only the lowest scoring WLAN of the lowest scoring controller affects the security index score.

When SSH and Telnet are enabled on a controller and are both flagged as issues, the Telnet issue has a higher precedence than SSH. Even if SSH is acknowledged on the controller with the lowest score, no change would occur for the security index.

From the Select a command drop-down list, choose Show All to view all security issues (both acknowledged and unacknowledged). Choose Show Unacknowledged to only view unacknowledged security issues. This is the default view when View All is selected from the Security Summary page. Choose ShowAcknowledged to only view acknowledged security issues.
Note

In order for a user to Acknowledge or Unacknowledge security issues, the user has to have “Ack and Unack Security Index Issues permission enabled”.

Security Index Controller Report

This page shows the security violation report as a summary for each controller. By row, each controller shows the number of security issues that occurred on that controller and provides a link to all security issues.

If you click the number in the Security Issues Count column, the Security Index Detailed Report appears.

Potential Security Issues

The following tables describes potential security issues.

<table>
<thead>
<tr>
<th>Controller Security Issue</th>
<th>Why is this an Issue?</th>
<th>What is the Solution?</th>
</tr>
</thead>
<tbody>
<tr>
<td>WLAN SSID on the controller has a weak authentication method.</td>
<td>Weak authentication method for a WLAN which can be broken by using tools available online if WLAN packets are sniffed.</td>
<td>Use the most secured authentication method and one that is WPA+WPA2.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has a weak authentication method (CKIP) configured.</td>
<td>Weak authentication method for a WLAN.</td>
<td>Use the most secured authentication method and one that is WPA+WPA2.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has no user authentication configured.</td>
<td>No authentication method is a clear security risk for a WLAN.</td>
<td>Configure strong authentication methods such as WPA+WPA2.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has a weak encryption method (CKIP WEP 40 bits) configured.</td>
<td>Weak encryption method for a WLAN.</td>
<td>Configure strong authentication and encryption methods such as WPA+WPA2 with AES.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has a weak encryption method (CKIP WEP 40 bits with Key Permutation) configured.</td>
<td>Weak encryption method for a WLAN.</td>
<td>Configure strong authentication and encryption methods such as WPA+WPA2 with AES.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has a weak encryption method (CKIP WEP 40 bits with MMH) configured.</td>
<td>Weak encryption method for a WLAN.</td>
<td>Configure strong authentication and encryption methods such as WPA+WPA2 with AES.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has a weak encryption method (CKIP WEP 40 bits with MMH and Key Permutation) configured.</td>
<td>Weak encryption method for a WLAN.</td>
<td>Configure strong authentication and encryption methods such as WPA+WPA2 with AES.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has a weak encryption method (WEP 104 bits) configured.</td>
<td>Weak encryption method for a WLAN.</td>
<td>Configure strong authentication and encryption methods such as WPA+WPA2 with AES.</td>
</tr>
</tbody>
</table>
### Table 3-7 Potential Security Issues (continued)

<table>
<thead>
<tr>
<th>Controller Security Issue</th>
<th>Why is this an Issue?</th>
<th>What is the Solution?</th>
</tr>
</thead>
<tbody>
<tr>
<td>WLAN SSID on the controller has a weak encryption method (CKIP WEP 104 bits) configured.</td>
<td>Weak encryption method for a WLAN.</td>
<td>Configure strong authentication and encryption methods such as WPA+WPA2 with AES.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has a weak encryption method (CKIP WEP 104 bits with MMH) configured.</td>
<td>Weak encryption method for a WLAN.</td>
<td>Configure strong authentication and encryption methods such as WPA+WPA2 with AES.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has a weak encryption method (CKIP WEP 104 bits with Key Permutation) configured.</td>
<td>Weak encryption method for a WLAN.</td>
<td>Configure strong authentication and encryption methods such as WPA+WPA2 with AES.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has a weak encryption method (CKIP WEP 104 bits with MMH and Key Permutation) configured.</td>
<td>Weak encryption method for a WLAN.</td>
<td>Configure strong authentication and encryption methods such as WPA+WPA2 with AES.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has a weak encryption method (WEP 40 bits) configured.</td>
<td>Weak encryption method for a WLAN.</td>
<td>Configure strong authentication and encryption methods such as WPA+WPA2 with AES.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has a weak encryption method (WEP 128 bits) configured.</td>
<td>Weak encryption method for a WLAN.</td>
<td>Configure strong authentication and encryption methods such as WPA+WPA2 with AES.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has a weak encryption method (TKIP) configured.</td>
<td>Weak encryption method for a WLAN.</td>
<td>Configure strong authentication and encryption methods such as WPA+WPA2 with AES.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has no encryption configured.</td>
<td>No encryption method is a clear security risk for a WLAN.</td>
<td>Configure strong authentication and encryption methods such as WPA+WPA2 with AES.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has a weak encryption method (WEP 104 bits) configured.</td>
<td>Weak encryption method for WLAN.</td>
<td>Configure strong authentication and encryption methods such as WPA+WPA2 with AES.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has no key management methods configured (applicable only for WPA+WPA2).</td>
<td>A key management method enhances the security of keys; without one, WLAN is less secure.</td>
<td>Configure at least one key management methods such as CCKM.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has MFP Client Protection set to “Optional”.</td>
<td>With MFP Client Protection set to optional for a WLAN, authenticated clients may not be shielded from spoofed frames.</td>
<td>Set MFP Client Protection to “Required” to protect against clients connecting to a rogue access point.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has MFP Client Protection set to “Disabled”.</td>
<td>With MFP Client Protection set to disabled for a WLAN, authenticated clients may not be shielded from spoofed frames.</td>
<td>Set MFP Client Protection to “Required” to protect against clients connecting to a rogue access point.</td>
</tr>
</tbody>
</table>
### Table 3-7 Potential Security Issues (continued)

<table>
<thead>
<tr>
<th>Controller Security Issue</th>
<th>Why is this an Issue?</th>
<th>What is the Solution?</th>
</tr>
</thead>
<tbody>
<tr>
<td>WLAN SSID interface is set to “management” on the controller.</td>
<td>As recommended from SAFE, user traffic should be separated from management traffic.</td>
<td>WLAN interface should not be set to “management” on the controller.</td>
</tr>
<tr>
<td>Interface set to one which is VLAN for a WLAN.</td>
<td>As recommended from SAFE, user traffic should be separated from VLAN traffic.</td>
<td>WLAN needs its interface to be set to one which is neither management nor one which has a VLAN.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has “Client Exclusion” disabled.</td>
<td>With Client Exclusion policies disabled, an attacker is able to continuously try to access the WLAN network.</td>
<td>Enable “Client Exclusion” to secure against malicious WLAN client behavior.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has “Broadcast SSID” enabled.</td>
<td></td>
<td>Disable “Broadcast SSID” to secure your wireless network.</td>
</tr>
<tr>
<td>WLAN SSID on the controller has “MAC Filtering” disabled.</td>
<td></td>
<td>Enable “MAC Filtering” to secure your wireless network.</td>
</tr>
<tr>
<td>Protection Type is set to “AP Authentication” on the controller.</td>
<td>When AP Authentication is set, an access point checks beacon/probe response frames in neighboring access points to see if they contain an authenticated information element (IE) that matches that of the RF group. This provides some security but does not cover all management frames and is open to alteration by rogue access points.</td>
<td>Set Protection Type to “Management Frame Protection (MFP)” on the controller.</td>
</tr>
<tr>
<td>Protection Type is set to “None” of the controller.</td>
<td>No security for 802.11 management messages passed between access points and clients.</td>
<td>Set Protection Type to “Management Frame Protection (MFP)” on the controller.</td>
</tr>
<tr>
<td>Radio type is configured to detect rogues only on DCA channels.</td>
<td>Rogue detection, if done only on a subset of country/all channels, is less secure than one that is done on country/all channels.</td>
<td>Configure radio types 802.11a/n and 802.11b/g/n to detect rogues on country channels or all channels.</td>
</tr>
<tr>
<td>Radio type is configured to detect rogues on neither country channels nor DCA channels.</td>
<td>Rogue detection, if not configured on country nor DCA channels, is less secure than when done on country/all channels.</td>
<td>Configure radio types 802.11a/n and 802.11b/g/n to detect rogues on country channels or all channels.</td>
</tr>
<tr>
<td>The rogue policy to detect and report adhoc networks is disabled on the controller.</td>
<td>With detection and reporting of adhoc networks turned off, adhoc rogues go undetected.</td>
<td>Enable the rogue policy to detect and report adhoc networks</td>
</tr>
</tbody>
</table>
Table 3-7  **Potential Security Issues  (continued)**

<table>
<thead>
<tr>
<th>Controller Security Issue</th>
<th>Why is this an Issue?</th>
<th>What is the Solution?</th>
</tr>
</thead>
<tbody>
<tr>
<td>“Check for all Standard and Custom Signatures” is disabled on the controller.</td>
<td>If check for all Standard and Custom Signatures is disabled, various types of attacks in incoming 802.11 packets would go undetected. Various types of attacks in incoming 802.11 packets would go undetected.</td>
<td>Check for all Standard and Custom Signatures needs to be turned on to identify various types of attacks in incoming 802.11 packets.</td>
</tr>
<tr>
<td>Some of the Standard Signatures are disabled on the controller.</td>
<td>If only some of the Standard Signatures are disabled,</td>
<td>Enable all Standard Signatures on the controller.</td>
</tr>
<tr>
<td>The “Excessive 802.11 Association Failures” Client Exclusion Policy is disabled on the controller.</td>
<td>Excessive failed association attempts can consume system resources and launch potential a denial of service attack to the infrastructure.</td>
<td>Enable the “Excessive 802.11 Association Failures” Client Exclusion Policy on the controller.</td>
</tr>
<tr>
<td>The “Excessive 802.11 Authentication Failures” Client Exclusion Policy is disabled on the controller.</td>
<td>Excessive failed authentication attempts can consume system resources and launch potential Denial of Service attack to the infrastructure.</td>
<td>Enable the “Excessive 802.11 Authentication Failures” Client Exclusion Policy on the controller.</td>
</tr>
<tr>
<td>The “Excessive 802.1X Authentication Failures” Client Exclusion Policy is disabled on the controller.</td>
<td>Excessive 802.1X failed authentication attempts can consume system resources and launch potential denial of service attack to the infrastructure.</td>
<td>Excessive 802.1X Authentication Failures Client Exclusion Policy must be enabled to prevent denial of service attack to the infrastructure.</td>
</tr>
<tr>
<td>The “Excessive 802.11 Web Authentication Failures” Client Exclusion Policy is disabled on the controller.</td>
<td>If Excessive 802.11 Web failed web authentication attempts can consume system resources and launch potential Denial of Service attack to the infrastructure.</td>
<td>Enable the “Excessive 802.11 Web Authentication Failures” Client Exclusion Policy on the controller.</td>
</tr>
<tr>
<td>The “IP Theft or IP Reuse” Client Exclusion Policy is disabled on the controller.</td>
<td>If IP Theft or Reuse Client Exclusion Policy is disabled, then an attacker masquerading as another client would not be disallowed.</td>
<td>Enable the “IP Theft or IP Reuse” Client Exclusion Policy on the controller.</td>
</tr>
<tr>
<td>No CIDS Sensor configured on the controller.</td>
<td>If no enabled IDS Sensor is configured, then IP-level attacks would not be detected.</td>
<td>Configure at least one CIDS Sensor on the controller.</td>
</tr>
<tr>
<td>Controller is configured with default community strings for SNMP v1/v2.</td>
<td>If SNMP V1 or V2 with default Community is configured then it is open to easy attacks since default communities are well known.</td>
<td>Use SNMPv3 with Auth and Privacy Types.</td>
</tr>
</tbody>
</table>
Table 3-7  Potential Security Issues  (continued)

<table>
<thead>
<tr>
<th>Controller Security Issue</th>
<th>Why is this an Issue?</th>
<th>What is the Solution?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controller is configured with non-default community strings for SNMP v1/v2.</td>
<td>SNMP V1 or V2 with non-default Community is slightly more secure than default Community but still less secure than SNMP V3.</td>
<td>Use SNMPv3 with Auth and Privacy types.</td>
</tr>
<tr>
<td>SNMPv3 is configured with a default user on the controller.</td>
<td>Using a default user makes SNMP V3 connections less secure.</td>
<td>Use a non-default username for SNMPv3 with Auth and Privacy Types.</td>
</tr>
<tr>
<td>SNMPv3 is configured with either no Auth or Privacy Type on the controller.</td>
<td>SNMP V3 with either Auth or Privacy Type set to none reduces the security of SNMP V3 connection.</td>
<td>Use SNMPv3 with Auth and Privacy Types to secure your wireless network.</td>
</tr>
<tr>
<td>HTTP (Web Mode enabled but Secure Web Mode disabled) is enabled on the controller.</td>
<td>HTTP is less secure than HTTPS.</td>
<td>Enable HTTPS (both Web Mode and Secure Web Mode) on the controller.</td>
</tr>
<tr>
<td>Telnet is enabled on the controller.</td>
<td>If telnet is enabled, then the controller is at risk of being hacked into.</td>
<td>Disable telnet on the controller.</td>
</tr>
<tr>
<td>SSH is disabled and timeout value is set to zero on the controller.</td>
<td>If SSH is enabled and timeout is zero then the controller has risk of being hacked into.</td>
<td>Enable SSH with non-zero timeout value on the controller.</td>
</tr>
<tr>
<td>Telnet is enabled on the AP.</td>
<td>If telnet is enabled, then the access point is at risk of being hacked into.</td>
<td>Disable Telnet on all access points.</td>
</tr>
<tr>
<td>SSH is enabled on the AP.</td>
<td></td>
<td>Disable SSH on all the access points.</td>
</tr>
<tr>
<td>At least one of the APs is configured with default username or password.</td>
<td>If default password is configured, then access points are more susceptible to connections from outside the network.</td>
<td>Configure a non-default username and strong password for all access points associated to the controller.</td>
</tr>
</tbody>
</table>

Table 3-8  Potential Security Issues

<table>
<thead>
<tr>
<th>Location Server/ Mobility Server Engine Security Issue</th>
<th>Why is this an Issue?</th>
<th>What is the Solution?</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTTP is enabled on the location server.</td>
<td>HTTP is less secure than HTTPS.</td>
<td>Enable HTTPS on the location server.</td>
</tr>
<tr>
<td>A location server user has a default password configured.</td>
<td>If default password is configured, then Location Server/ Mobility Server Engine is more susceptible to connections from outside the network.</td>
<td>Configure a strong password for the location server users.</td>
</tr>
</tbody>
</table>
Switch Port Tracing

Currently, WCS provides rogue access point detection by retrieving information from the controller. The rogue access point table is populated with any detected BSSID addresses from any frames that are not present in the neighbor list. At the end of a specified interval, the contents of the rogue table are sent to the controller in an CAPWAP Rogue AP Report message. With this method, WCS would simply gather the information received from the controllers; but with software release 5.1, you can incorporate switch port tracing of Wired Rogue Access Point Switch Ports. This enhancement allows you to react to found wired rogue access points and prevent future attacks. The trace information is available only in the WCS log and only for rogue access points, not rogue clients.

Note
Rogue Client connected to the Rogue Access point information is used to track the switch port to which the Rogue Access point is connected in the network.

Note
If you try to set tracing for a friendly or deleted rogue, a warning message appears.

Note
For Switch Port Tracing to successfully trace the switch ports using SNMP v3, all of the OIDs should be included in the SNMP v3 view and VLAN content should be created for each VLAN in the SNMP v3 group.

Establishing Switch Port Tracing

To establish switch port tracing, follow these steps:

Step 1
In the WCS home page, click the Security tab.

Step 2
In the Rogue APs and Adhoc Rogues section, click the number URL which specifies the number of rogues in the last hour, last 24 hours, or total active.
Chapter 3    Configuring Security Solutions

Using WCS to Convert a Cisco Unified Wireless Network Solution from Layer 3 to Layer 2 Mode

Step 3    Choose for which rogue you are setting switch port tracking by clicking the URL in the MAC Address column. The Alarms > Rogue AP details page opens.

Step 4    From the Select a command drop-down list, choose Trace Switch Port. The Trace Switch Port page opens, and WCS runs a switch port trace.

When one or more searchable MAC addresses are available, the WCS uses CDP to discover any switches connected up to two hops away from the detecting access point. The MIBs of each CDP discovered switch is examined to see if it contains any of the target MAC addresses. If any of the MAC addresses are found, the corresponding port number is returned and reported as the switch port of a rogue.

Integrated Security Solutions

The Cisco Unified Wireless Network Solution also provides these integrated security solutions:

- Cisco Unified Wireless Network Solution operating system security is built around a robust 802.1X authorization, authentication, and accounting (AAA) engine, which enables operators to rapidly configure and enforce a variety of security policies across the Cisco Unified Wireless Network Solution.
- The controllers and access points are equipped with system-wide authentication and authorization protocols across all ports and interfaces, maximizing system security.
- Operating system security policies are assigned to individual wireless LANs, and access points simultaneously broadcast all (up to 16) configured wireless LANs. These policies can eliminate the need for additional access points, which can increase interference and degrade system throughput.
- Operating system security uses the RRM function to continually monitor the air space for interference and security breaches and notify the operator when they are detected.
- Operating system security works with industry-standard AAA servers, making system integration simple and easy.
- The Cisco intrusion detection system/intrusion protection system (CIDS/IPS) instructs controllers to block certain clients from accessing the wireless network when attacks involving these clients are detected.
- The operating system security solution offers comprehensive Layer 2 and Layer 3 encryption algorithms, which typically require a large amount of processing power. Rather than assigning the encryption tasks to yet another server, the controller can be equipped with a VPN/enhanced security module that provides extra hardware required for the most demanding security configurations.

Using WCS to Convert a Cisco Unified Wireless Network Solution from Layer 3 to Layer 2 Mode

Follow these steps to convert a Cisco Unified Wireless Network Solution from Layer 3 to Layer 2 LWAPP transport mode using the WCS user interface.

Note    Cisco-based lightweight access points do not support Layer 2 LWAPP mode. These access points can only be run with Layer 3.
This procedure causes your access points to go offline until the controller reboots and the associated access points reassociate to the controller.

### Step 1
Make sure that all controllers and access points are on the same subnet.

**Note**
You must configure the controllers and associated access points to operate in Layer 2 mode before completing the conversion.

### Step 2
Log into the WCS user interface. Then follow these steps to change the LWAPP transport mode from Layer 3 to Layer 2:

a. Click **Configure > Controllers** to navigate to the All Controllers page.
b. Click the desired IP address of a controller to display the **IP Address > Controller Properties** page.
c. From the left sidebar menu, click **System > General** to display the **IP Address > General** page.
d. Change LWAPP transport mode to **Layer2** and click **Save**.
e. If WCS displays the following message, click **OK**:

   Please reboot the system for the LWAPP Mode change to take effect.

### Step 3
Follow these steps to restart your Cisco Unified Wireless Network Solution:

a. Return to the **IP Address > Controller Properties** page.
b. Click **System > Commands** to display the **IP Address > Controller Commands** page.
c. Under Administrative Commands, choose **Save Config To Flash**, and click **Go** to save the changed configuration to the controller.
d. Click **OK** to continue.
e. Under Administrative Commands, choose **Reboot**, and click **Go** to reboot the controller.
f. Click **OK** to confirm the save and reboot.

### Step 4
After the controller reboots, follow these steps to verify that the LWAPP transport mode is now Layer 2:

a. Click **Monitor > Controllers** to navigate to the Controllers > Search Results page.
b. Click the desired IP address of a controller to display the Controllers > **IP Address > Summary** page.
c. Under General, verify that the current LWAPP transport mode is Layer2.

You have completed the LWAPP transport mode conversion from Layer 3 to Layer 2. The operating system software now controls all communications between controllers and access points on the same subnet.

## Configuring a Firewall for WCS

When a WCS server and a WCS user interface are on different sides of a firewall, they cannot communicate unless the following ports on the firewall are open to two-way traffic:

- 80 (for initial http)
- 69 (tftp)
Access Point Authorization

You can view a list of authorized access points along with the type of certificate that an access point uses for authorization.

Step 1  Choose Configure > Controllers.
Step 2  Click one of the URLs in the IP address column.
Step 3  From the left sidebar menu, choose Security > AP/MSE Authorization.
Step 4  The AP Policies portion of the page indicates whether the authorization of access points is enabled or disabled. It also indicates whether the acceptance of self-signed certificates (SSC APs) is enabled or disabled. Normally, access points can be authorized either by AAA or certificates. (SSC is only available for 4400 and 200 controllers.)

To change these values, choose Edit AP Policies from the Select a command drop-down list, and click Go.

Step 5  The AP Authorization List portion shows the radio MAC address of the access point, certificate type, and key hash. To add a different authorization entry, choose Add AP/MSE Auth Entry from the Select a command drop-down list, and click Go.

Step 6  From the drop-down list, choose a template to apply to this controller and click Apply. To create a new template for access point authorization, click the click here to get redirected to the template creation page. See the “Configuring an Access Point or MSE Authorization Template” section on page 11-68 for steps on creating a new template.

Management Frame Protection (MFP)

Management Frame Protection (MFP) provides security for the otherwise unprotected and unencrypted 802.11 management messages passed between access points and clients. MFP provides both infrastructure and client support. WCS software release 4.1 and later supports both infrastructure and client MFP while WCS software release 4.0 supports only infrastructure MFP.

- Infrastructure MFP—Protects management frames by detecting adversaries who are invoking denial of service attacks, flooding the network with associations and probes, interjecting as rogue access points, and affecting network performance by attacking the QoS and radio measurement frames. It also provides a quick and effective means to detect and report phishing incidents.

Specifically, infrastructure MFP protects 802.11 session management functions by adding message integrity check information elements (MIC IEs) to the management frame emitted by access points (and not those emitted by clients), which are then validated by other access points in the network. Infrastructure MFP is passive. It can detect and report intrusions but has no means to stop them.
• Client MFP—Shields authenticated clients from spoofed frames, preventing many of the common attacks against wireless LANs from becoming effective. Most attacks, such as deauthentication attacks, revert to simply degrading performance by contending with valid clients.

Specifically, client MFP encrypts management frames sent between access points and Cisco Compatible Extension clients so that both access points and clients can take preventive action by dropping spoofed class 3 management frames (that is, management frames passed between an access point and a client that is authenticated and associated). Client MFP leverages the security mechanisms defined by IEEE 802.11i to protect the following types of class 3 unicast management frames: disassociation, deauthentication, and QoS (WMM) action. Client MFP is active. It can protect a client-access point session from the most common type of denial of service attack. It protects class 3 management frames by using the same encryption method used for the session’s data frames. If a frame received by the access point or client fails decryption, it is dropped, and the event is reported to the controller.

To use client MFP, clients must support Cisco Compatible Extensions (version 5) MFP and must negotiate WPA2 using either TKIP or AES-CCMP. EAP or PSK may be used to obtain the PMK. CCKM and controller mobility management are used to distribute session keys between access points or Layer 2 and Layer 3 fast roaming.

To prevent attacks against broadcast frames, access points supporting Cisco Compatible Extensions (version 5) do not emit any broadcast class 3 management frames (such as disassociation, deauthentication, or action). Compatible extensions clients (version 5) and access points must discard broadcast class 3 management frames.

Client MFP supplements infrastructure MFP rather than replacing it because infrastructure MFP continues to detect and report invalid unicast frames sent to clients that are not client-MFP capable, as well as invalid class 1 and 2 management frames. Infrastructure MFP is applied only to management frames that are not protected by client MFP.

Infrastructure MFP consists of three main components:
• Management frame protection—The access point protects the management frames it transmits by adding a MIC IE to each frame. Any attempt to copy, alter, or replay the frame invalidates the MIC, causing any receiving access point configured to detect MFP frames to report the discrepancy.
• Management frame validation—In infrastructure MFP, the access point validates every management frame it receives from other access points in the network. It ensures that the MC IE is present (when the originator is configured to transmit MFP frames) and matches the content of the management frame. If it receives any frame that does not contain a valid MIC IE from a BSSID belonging to an access point that is configured to transmit MFP frames, it reports the discrepancy to the network management system. In order for the timestamps to operate properly, all controllers must be Network Transfer Protocol (NTP) synchronized.
• Event reporting—The access point notifies the controller when it detects an anomaly, and the controller aggregates the received anomaly events and reports the results through SNMP traps to the network management system.

Note

Client MFP uses the same event reporting mechanisms as infrastructure MFP.

Infrastructure MFP is enabled by default and can be disabled globally. When you upgrade from a previous software release, infrastructure MFP is disabled globally if access point authentication is enabled because the two features are mutually exclusive. After infrastructure MFP is enabled globally, signature generation (adding MICs to outbound frames) can be disabled for selected WLANs, and validation can be disabled for selected access points.

You set MFP in the WLAN template. See the “Configuring WLAN Templates” section on page 11-22.
Guidelines for Using MFP

Follow these guidelines for using MFP:

- MFP is supported for use with Cisco Aironet lightweight access points, except for the 1500 series mesh access points.
- Lightweight access points support infrastructure MFP in local and monitor modes and in REAP and hybrid-REAP modes when the access point is connected to a controller. They support client MFP in local, hybrid-REAP, and bridge modes.
- Client MFP is supported for use only with Cisco Compatible Extensions (version 5) clients using WPA2 with TKIP or AES-CCMP.
- Non-Cisco Compatible Extensions (version 5) clients may associate to a WLAN if client MFP is disabled or optional.

Configuring Intrusion Detection Systems (IDS)

The Cisco Intrusion Detection System/Intrusion Prevention System (CIDS/IPS) instructs controllers to block certain clients from accessing the wireless network when attacks involving these clients are detected. This system offers significant network protection by helping to detect, classify, and stop threats including worms, spyware/adware, network viruses, and application abuse. Two methods are available to detect IDS attacks:

- IDS sensors (for Layer 3)
- IDS signatures (for Layer 2)

Viewing IDS Sensors

When the sensors identify an attack, they alert the controller to shun the offending client. When you add a new IDS sensor, you register the controller with that IDS sensor so that the sensor can send shunned client reports to the controller. The controller also polls the sensor periodically.

Follow these steps to view IDS sensors:

1. Choose Configure > Controllers.
2. Choose a controller by clicking an IP address.
3. From the left sidebar menu, choose Security > IDS Sensor Lists. The IDS Sensor page appears. This page lists all of the IDS sensors that have been configured for this controller.

Configuring IDS Signatures

You can configure IDS signatures, or bit-pattern matching rules used to identify various types of attacks in incoming 802.11 packets, on the controller. When the signatures are enabled, the access points joined to the controller perform signature analysis on the received 802.11 data or management frames and report any discrepancies to the controller. If an attack is detected, an appropriate mitigation action is initiated.
Cisco supports 17 standard signatures on the controller as shown on the Standard Signatures and Custom Signatures page (see Figure 3-3). To open this page, choose Configure > Controllers, select a controller IP address, and then choose Security > Wireless Protection Policies > Standard Signatures from the left sidebar menu.

**Figure 3-3 Standard Signatures Page**

These signatures are divided into six main groups. The first four groups contain management signatures, and the last two groups contain data signatures:

- **Broadcast deauthentication frame signatures**—During a broadcast deauthentication frame attack, a hacker sends an 802.11 deauthentication frame to the broadcast MAC destination address of another client. This attack causes the destination client to disassociate from the access point and lose its connection. If this action is repeated, the client experiences a denial of service. When the broadcast deauthentication frame signature (precedence 1) is used to detect such an attack, the access point listens for clients transmitting broadcast deauthentication frames that match the characteristics of
the signature. If the access point detects such an attack, it alerts the controller. Depending on how your system is configured, the offending device is contained so that its signals no longer interfere with authorized clients, or the controller forwards an immediate alert to the system administrator for further action, or both.

- **NULL probe response signatures**—During a NULL probe response attack, a hacker sends a NULL probe response to a wireless client adapter. As a result, the client adapter locks up. When a NULL probe response signature is used to detect such an attack, the access point identifies the wireless client and alerts the controller. The NULL probe response signatures include:
  - NULL probe resp 1 (precedence 2)
  - NULL probe resp 2 (precedence 3)

- **Management frame flood signatures**—During a management frame flood attack, a hacker floods an access point with 802.11 management frames. The result is a denial of service to all clients associated or attempting to associate to the access point. This attack can be implemented with different types of management frames: association requests, authentication requests, reassociation requests, probe requests, disassociation requests, deauthentication requests, and reserved management subtypes.

  When a management frame flood signature is used to detect such an attack, the access point identifies management frames matching the entire characteristics of the signature. If the frequency of these frames is greater than the value of the frequency set in the signature, an access point that hears these frames triggers an alarm. The controller generates a trap and forwards it to WCS.

  The management frame flood signatures include:
  - Assoc flood (precedence 4)
  - Auth flood (precedence 5)
  - Reassoc flood (precedence 6)
  - Broadcast probe flood (precedence 7)
  - Disassoc flood (precedence 8)
  - Deauth flood (precedence 9)
  - Reserved mgmt 7 (precedence 10)
  - Reserved mgmt F (precedence 11)

  The reserved management frame signatures 7 and F are reserved for future use.

- **EAPOL flood signature**—During an EAPOL flood attack, a hacker floods the air with EAPOL frames containing 802.1X authentication requests. As a result, the 802.1X authentication server cannot respond to all of the requests and fails to send successful authentication responses to valid clients. The result is a denial of service to all affected clients. When the EAPOL flood signature (precedence 12) is used to detect such an attack, the access point waits until the maximum number of allowed EAPOL packets is exceeded. It then alerts the controller and proceeds with the appropriate mitigation.

- **NetStumbler signatures**—NetStumbler is a wireless LAN scanning utility that reports access point broadcast information (such as operating channel, RSSI information, adapter manufacturer name, SSID, WEP status, and the latitude and longitude of the device running NetStumbler when a GPS is attached). If NetStumbler succeeds in authenticating and associating to an access point, it sends a data frame with the following strings, depending on the NetStumbler version listed in Table 3-9.
When a NetStumbler signature is used to detect such an attack, the access point identifies the offending device and alerts the controller. The NetStumbler signatures include:

- NetStumbler 3.2.0 (precedence 13)
- NetStumbler 3.2.3 (precedence 14)
- NetStumbler 3.3.0 (precedence 15)
- NetStumbler generic (precedence 16)

- Wellenreiter signature—Wellenreiter is a wireless LAN scanning and discovery utility that can reveal access point and client information. When the Wellenreiter signature (precedence 17) is used to detect such an attack, the access point identifies the offending device and alerts the controller.

This section provides the instructions to configure signatures and contains the following topics:

- Uploading IDS Signatures, page 3-44
- Downloading IDS Signatures, page 3-45
- Enabling or Disabling IDS Signatures, page 3-46

### Uploading IDS Signatures

To upload IDS signatures from the controller, follow these steps:

**Step 1** Obtain a signature file from Cisco (hereafter called a *standard signature file*). You can also create your own signature file (hereafter called a *custom signature file*) by following the “Downloading IDS Signatures” section on page 3-45.

**Step 2** You can configure a TFTP server for the signature download. Keep these guidelines in mind when setting up a TFTP server:

- If you are downloading through the service port, the TFTP server must be on the same subnet as the service port because the service port is not routable. However, if you want to put the TFTP server on a different network while the management port is down, add a static route if the subnet where the service port resides has a gateway (config route add IP address of TFTP server).
- If you are downloading through the distribution system network port, the TFTP server can be on the same or a different subnet because the distribution system port is routable.
- A third-party TFTP server cannot run on the same computer as the Cisco WCS because built-in TFTP server of WCS and third-party TFTP server use the same communication port.

**Step 3** Choose Configure > Controllers.

**Step 4** Choose a controller by clicking an IP address.

**Step 5** From the left sidebar menu, choose Security and then Standard Signatures or Custom Signatures.
Step 6 From the Select a command drop-down list, choose Upload Signature Files from Controller. Figure 3-4 shows the page that appears.

Figure 3-4 Uploading Signature File

Step 7 Specify the TFTP server name being used for the transfer.

Step 8 If the TFTP server is new, enter the TFTP IP address in Server IP Address text box.

Step 9 Choose Signature Files from the File Type drop-down list.

Step 10 The signature files are uploaded to the root directory which was configured for use by the TFTP server. You can change to a different directory at the Upload to File parameter (this parameter only shows if the Server Name is the default server). The controller uses this local file name as a base name and then adds _std.sig as a suffix for standard signature files and _custom.sig as a suffix for custom signature files.

Step 11 Click OK.

Downloading IDS Signatures

If the standard signature file is already on the controller but you want to download customized signatures to it, follow these steps:

Step 1 Choose Configure > Controllers.

Step 2 Choose a controller by clicking an IP address.

Step 3 Choose System > Commands.

Step 4 From the Upload/Download Commands drop-down list, choose Download IDS Signatures, and click Go.
Step 5 Copy the signature file (*.sig) to the default directory on your TFTP server.

Step 6 Choose local machine from the File is Located On text box. If you know the filename and path relative to the server’s root directory, you can also choose TFTP server.

Step 7 Enter the maximum number of times the controller should attempt to download the signature file in the Maximum Retries parameter.

Step 8 Enter the maximum amount of time in seconds before the controller times out while attempting to download the signature file in the Timeout parameter.

Step 9 The signature files are uploaded to the c:\tftp directory. Specify the local file name in that directory or use the Browse button to navigate to it. A “revision” line in the signature file specifies whether the file is a Cisco-provided standard signature file or a site-tailored custom signature file (custom signature files must always have revision=custom).

Step 10 If the transfer times out for some reason, you can simply choose the TFTP server option in the File Is Located On parameter, and the Server File Name will be populated for you and retried. The local machine option initiates a two-step operation. First, the local file is copied from the administrator’s workstation to the built-in TFTP server of WCS. Then the controller retrieves that file. For later operations, the file is already in the WCS server’s TFTP directory, and the download web page now automatically populates the filename.

Step 11 Click OK.

Enabling or Disabling IDS Signatures

To enable or disable IDS signature, follow these steps:

Step 1 Choose Configure > Controllers.

Step 2 Choose a controller by clicking on an IP address.

Step 3 From the left sidebar menu, choose Security and then Standard Signatures or Custom Signatures. Figure 3-5 shows a sample of the page that appears.
### Step 4

To enable or disable an individual signature, click in the Name column for the type of attack you want to enable or disable. Figure 3-6 shows a sample of a detailed signature page.

The Standard Signature Parameters page shows the list of Cisco-supplied signatures that are currently on the controller. The Custom Signatures page shows the list of customer-supplied signatures that are currently on the controller. The following information is displayed either on the signature page or the detailed signature page:

- **Precedence** - The order, or precedence, in which the controller performs the signature checks.
- **Name** - The type of attack the signature is trying to detect.
- **Description** - A more detailed description of the type of attack that the signature is trying to detect.
- **Frame Type** - Management or data frame type on which the signature is looking for a security attack.

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Name</th>
<th>Frame Type</th>
<th>Action</th>
<th>State</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Boot attack</td>
<td>Management</td>
<td>Report</td>
<td>Enabled</td>
<td>Broadcast Deauthentication Frame</td>
</tr>
<tr>
<td>2</td>
<td>Mnl probe req 1</td>
<td>Management</td>
<td>Report</td>
<td>Enabled</td>
<td>NULL Probe Response - Zero length SSID element</td>
</tr>
<tr>
<td>3</td>
<td>Mnl probe req 2</td>
<td>Management</td>
<td>Report</td>
<td>Enabled</td>
<td>NULL Probe Response - No SSID element</td>
</tr>
<tr>
<td>4</td>
<td>Assoc flood</td>
<td>Management</td>
<td>Report</td>
<td>Enabled</td>
<td>Association Request Flood</td>
</tr>
<tr>
<td>5</td>
<td>Auth flood</td>
<td>Management</td>
<td>Report</td>
<td>Enabled</td>
<td>Authentication Request Flood</td>
</tr>
<tr>
<td>6</td>
<td>Resec flood</td>
<td>Management</td>
<td>Report</td>
<td>Enabled</td>
<td>Resecassociation Request Flood</td>
</tr>
<tr>
<td>7</td>
<td>Broadcast probe flood</td>
<td>Management</td>
<td>Report</td>
<td>Enabled</td>
<td>Broadcast Probe Request Flood</td>
</tr>
<tr>
<td>8</td>
<td>Disconnect flood</td>
<td>Management</td>
<td>Report</td>
<td>Enabled</td>
<td>Disconnect association Flood</td>
</tr>
<tr>
<td>9</td>
<td>Deauth/flood</td>
<td>Management</td>
<td>Report</td>
<td>Enabled</td>
<td>Deauthentication Flood</td>
</tr>
<tr>
<td>10</td>
<td>Res mgmt 7</td>
<td>Management</td>
<td>Report</td>
<td>Enabled</td>
<td>Reserved management sub-type 7</td>
</tr>
<tr>
<td>11</td>
<td>Res mgmt P</td>
<td>Management</td>
<td>Report</td>
<td>Enabled</td>
<td>Reserved management sub-type P</td>
</tr>
<tr>
<td>12</td>
<td>EAPOL flood</td>
<td>Data</td>
<td>Report</td>
<td>Enabled</td>
<td>EAPOL Flood Attack</td>
</tr>
<tr>
<td>13</td>
<td>netStumbler 3.2.6</td>
<td>Data</td>
<td>Report</td>
<td>Enabled</td>
<td>netStumbler 3.2.6</td>
</tr>
<tr>
<td>14</td>
<td>netStumbler 3.2.3</td>
<td>Data</td>
<td>Report</td>
<td>Enabled</td>
<td>netStumbler 3.2.3</td>
</tr>
<tr>
<td>15</td>
<td>netStumbler 3.2.0</td>
<td>Data</td>
<td>Report</td>
<td>Enabled</td>
<td>netStumbler 3.2.0</td>
</tr>
<tr>
<td>16</td>
<td>netStumbler generic</td>
<td>Data</td>
<td>Report</td>
<td>Enabled</td>
<td>netStumbler generic</td>
</tr>
<tr>
<td>17</td>
<td>WELL Stumbler</td>
<td>Management</td>
<td>Report</td>
<td>Enabled</td>
<td>WELL Stumbler</td>
</tr>
</tbody>
</table>

![Figure 3-5 Checking for Standard Signatures](image-url)
**Action** - What the controller is directed to do when the signature detects an attack. One possibility is *None*, where no action is taken, and another is *Report*, to report the detection.

**Frequency** - The signature frequency, or the number of matching packets per interval that must be identified at the detecting access point level before an attack is detected. The range is 1 to 32,000 packets per interval, and the default value is 50 packets per interval.

**Quiet Time** - The length of time (in seconds) after which no attacks have been detected at the individual access point level, and the alarm can stop. This time appears only if the MAC information is all or both. The range is 60 to 32,000 seconds, and the default value is 300 seconds.

**MAC Information** - Whether the signature is to be tracked per network or per MAC address or both at the detecting access point level.

**MAC Frequency** - The signature MAC frequency, or the number of matching packets per interval that must be identified at the controller level before an attack is detected. The range is 1 to 32,000 packets per interval, and the default value is 30 packets per interval.

**Interval** - Enter the number of seconds that must elapse before the signature frequency threshold is reached within the configured interval. The range is 1 to 3600 seconds, and the default value is 1 second.

**Enable** - Select this to enable this signature to detect security attacks or unselect it to disable this signature.

**Signature Patterns** - The pattern that is being used to detect a security attack.

---

**Figure 3-6  Standard Signature**

---

**Step 5** From the Enabled yes or no drop-down list, choose *yes*. Because you are downloading a customized signature, you should enable the files named with the _custom.sgi and disable the standard signature with the same name but differing suffix. (For example, if you are customizing broadcast probe flood, you want to disable broadcast probe flood in the standard signatures but enable it in custom signatures.)
Step 6  To enable all standard and custom signatures currently on the controller, choose **Edit Signature Parameters** (see Figure 3-5) from the Select a command drop-down list, and click **Go**. The Edit Signature Parameters page appears (see Figure 3-7).

**Figure 3-7  Global Setting for Standard and Custom Signature**

![Global Setting for Standard and Custom Signature](image)

**Step 7**  Select the Check for All Standard and Custom Signatures parameter **Enable** check box. This enables all signatures that were individually selected as enabled in **Step 5**. If this check box remains unselected, all files are disabled, even those that were previously enabled in **Step 5**. When the signatures are enabled, the access points joined to the controller perform signature analysis on the received 802.11 data or management frames and report any discrepancies to the controller.

**Step 8**  Click **Save**.

---

**Enabling Web Login**

With web authentication, guests are automatically redirected to web authentication pages when they launch their browsers. Guests gain access to the WLAN through this web portal. Wireless LAN administrators using this authentication mechanism should have the option of providing unencrypted or encrypted guest access. Guest users can then log into the wireless network using a valid username and password, which is encrypted with SSL. Web authentication accounts may be created locally or managed by a RADIUS server. The Cisco Wireless LAN controllers can be configured to support a web authentication client. See the “Configuring a Web Authentication Template” section on page 11-73 to create a template that replaces the Web authentication page provided on the controller.

**Step 1**  Choose **Configure > Controllers**.
Enabling Web Login

Step 2 Choose the controller on which to enable web authentication by clicking an IP address URL in the IP Address column.

Step 3 From the left sidebar menu, choose Security > AAA > Web Auth Configuration.

Step 4 Choose the appropriate web authentication type from the drop-down list. The choices are default internal, customized web authentication, or external.
- If you choose default internal, you can still alter the page title, message, and redirect URL, as well as choose whether the logo appears. Continue to Step 5.
- If you choose customized web authentication, skip to the “Downloading Customized Web Authentication” section on page 3-50.
- If you choose external, you need to enter the URL you want to redirect to after a successful authentication. For example, if the value entered for this text box is http://www.example.com, the user is directed to the company home page.

Step 5 Select the Logo Display check box if you want your company logo to be displayed.

Step 6 Enter the title you want displayed on the Web authentication page.

Step 7 Enter the message you want displayed on the Web authentication page.

Step 8 In the Customer Redirect URL parameter, provide the URL where the user is redirected after a successful authentication. For example, if the value entered for this text box is http://www.example.com, the user is directed to the company home page.

Step 9 Click Save.

**Downloading Customized Web Authentication**

Follow these steps if you chose the customized web authentication option in Step 4 of the previous section. You can download a customized Web authentication page to the controller. A customized web page is created to establish a username and password for user web access.

When downloading customized web authentication, these strict guidelines must be followed:
- A username must be provided.
- A password must be provided.
- A redirect URL must be retained as a hidden input item after extracting from the original URL.
- The action URL must be extracted and set from the original URL.
- Scripts to decode the return status code must be included.
- All paths used in the main page should be of relative type.

Before downloading, the following steps are required:

Step 1 Click the preview image to download the sample login.html bundle file from the server. See Figure 3-8 for an example of the login.html file. The downloaded bundle is a .TAR file.
Step 2  Open and edit the login.html file and save it as a .tar or .zip file.

Note  You can edit the text of the Submit button with any text or HTML editor to read “Accept terms and conditions and Submit.”

Step 3  Make sure you have a Trivial File Transfer Protocol (TFTP) server available for the download. Keep these guidelines in mind when setting up a TFTP server:

- If you are downloading through the service port, the TFTP server must be on the same subnet as the service port because the service port is not routable.
- If you are downloading through the distribution system network port, the TFTP server can be on the same or a different subnet because the distribution system port is routable.
- A third-party TFTP server cannot run on the same computer as the Cisco WCS because the built-in TFTP server of WCS and third-party TFTP server use the same communication port.

Step 4  Click here in the “After editing the HTML you may click here to redirect to the Download Web Auth Page” link to download the .tar or .zip file to the controller(s). The Download Customized Web Auth Bundle to Controller page appears.

Note  The IP address of the controller to receive the bundle and the current status are displayed.

Step 5  Choose local machine from the File is Located On parameter. If you know the filename and path relative to the server’s root directory, you can also choose TFTP server.

Note  For a local machine download, either .zip or .tar file options exists, but the WCS does the conversion of .zip to .tar automatically. If you chose a TFTP server download, only .tar files are specified.

Step 6  Enter the maximum amount of time in seconds before the controller times out while attempting to download the file in the Timeout parameter.

Step 7  The WCS Server Files In parameter specifies where the WCS server files are located. Specify the local file name in that directory or use the Browse button to navigate to it. A “revision” line in the signature file specifies whether the file is a Cisco-provided standard signature file or a site-tailored custom signature file (custom signature files must always have revision=custom).
Chapter 3  Configuring Security Solutions

Certificate Signing Request (CSR) Generation

Step 8  If the transfer times out for some reason, you can simply choose the TFTP server option in the File Is Located On parameter, and the Server File Name is populated. The local machine option initiates a two-step operation. First, the local file is copied from the administrator’s workstation to the built-in TFTP server of WCS. Then the controller retrieves that file. For later operations, the file is already in the WCS server’s TFTP directory, and the download web page now automatically populates the filename.

Step 9  Click OK.

If the transfer times out for some reason, you can simply choose the TFTP server option in the File Is Located On parameter, and the Server File Name is populated for you.

Step 10  After completing the download, you are directed to the new page and able to authenticate.

Connecting to the Guest WLAN

Follow these steps to connect to the guest central WLAN to complete the web authentication process. See the “Creating Guest User Accounts” section on page 7-11 for more explanation of a guest user account.

Step 1  When you are set for open authentication and are connected, browse to the virtual interface IP address (such as /1.1.1.1/login.html).

Step 2  When the WCS user interface displays the Login page, enter your username and password.

Note  All entries are case sensitive.

The lobby ambassador has access to the templates only to add guest users.

Certificate Signing Request (CSR) Generation

To generate a Certificate Signing Request (CSR) for a third-party certificate using WCS, refer to the following document for instructions on uploading the certificate:

Performing Maintenance Operations

You can perform the actions at the system level, such as updating system softwares or downloading certificates that can be used with many items.

This chapter describes the system level tasks to perform with Cisco WCS. It contains the following sections:

- Information About Maintenance Operations, page 4-1
- Performing System Tasks, page 4-1
- Verifying the Status of WCS, page 4-6
- Stopping WCS, page 4-7
- Backing Up the WCS Database, page 4-9
- Restoring the WCS Database, page 4-11
- Uninstalling WCS, page 4-14
- Upgrading WCS, page 4-15
- Upgrading WCS in a High Availability Environment, page 4-21
- Upgrading the Network, page 4-21
- Reinitializing the Database, page 4-21
- Recovering the WCS Password, page 4-22

Information About Maintenance Operations

A system-level task is a collection of tasks that relate to operations that apply to the WCS database as a whole. System tasks also includes restoring WCS database. For more information, see the “Restoring the WCS Database” section on page 4-11.

Performing System Tasks

This section describes how to use Cisco WCS to perform system-level tasks. It contains the following topics:

- Adding a Controller to the WCS Database, page 4-2
- Using WCS to Update System Software, page 4-3
Adding a Controller to the WCS Database

To add a controller to the WCS database, follow these steps:

**Step 1** Log into the WCS user interface.
**Step 2** Click **Configure > Controllers** to display the All Controllers page.
**Step 3** From the Select a command drop-down list, choose **Add Controller**, and click **Go**.
**Step 4** On the Add Controller page, enter the controller IP address, network mask, and required SNMP settings.
**Step 5** Click **OK**. WCS displays a Please Wait dialog box while it contacts the controller and adds the current controller configuration to the WCS database. It then returns you to the Add Controller page.
**Step 6** If WCS does not find a controller at the IP address that you entered for the controller, the Discovery Status dialog displays this message:

No response from device, check SNMP.

Check these settings to correct the problem:

- The controller service port IP address might be set incorrectly. Check the service port setting on the controller.
- WCS might not have been able to contact the controller. Make sure that you can ping the controller from the WCS server.
- The SNMP settings on the controller might not match the SNMP settings that you entered in WCS. Make sure that the SNMP settings configured on the controller match the settings that you entered in WCS.

**Step 7** Add additional controllers if desired.

Additional Functionality with Location Appliance

Cisco 2700 series location appliances operate within the Cisco Wireless LAN Solution infrastructure. Location appliances compute, collect, and store historical location data using Cisco wireless LAN controllers and access points to track the physical location of wireless devices.

The location appliance can track up to 2,500 elements. You can track the following elements: client stations, active asset tags, rogue clients and access points. Updates on the locations of elements being tracked are provided to the location server from the Cisco wireless LAN controller.
Only those elements designated for tracking by the controller are viewable in Cisco WCS maps, queries, and reports. No events and alarms are collected for non-tracked elements, and they are not used in calculating the 2,500 element limit.

You can modify the following tracking parameters using Cisco WCS:

- Enable and disable which element locations (client stations, active asset tags, and rogue clients and access points) you actively track.
- Set limits on how many of a specific element you want to track.
  
  You can set limits on how many of a specific element you wish to track. For example, given a limit of 2,500 trackable units, you could set a limit to track only 1,500 client stations. Once the tracking limit is met, the number of elements not being tracked is summarized on the Tracking Parameters page.
- Disable tracking and reporting of ad hoc rogue clients and access points.

**Note** Even though all clients are loaded in the map, the display has a limit of 250 clients per floor to prevent overcrowding. You can do an advanced search of the map to see the items of interest.

Selectable filters enable you to search collected data and display specific elements on a map. For example, a biomedical user may want to display only active Wi-Fi tags that are tracking key medical equipment rather than access points or clients for a given floor.

### Using WCS to Update System Software

To update controller (and access point) software using WCS, follow these steps:

**Step 1** Enter the `ping ip-address` command to be sure that the WCS server can contact the controller. If you use an external TFTP server, enter `ping ip-address` to be sure that the WCS server can contact the TFTP server.

**Note** When you are downloading through a controller distribution system (DS) network port, the TFTP server can be on the same or a different subnet because the DS port is routable.

**Step 2** Click **Configure > Controllers** to navigate to the All Controllers page.

**Step 3** Select the check box of the desired controller, choose **Download Software (TFTP or FTP)** from the Select a command drop-down list, and click **Go**. WCS displays the Download Software to Controller page.

**Step 4** If you use the built-in WCS TFTP server, select the **TFTP Server on WCS System** check box. If you use an external TFTP server, unselect this check box and add the external TFTP server IP address.

**Step 5** Click **Browse** and navigate to the software update file (for example, AS_2000_release.aes for 2000 series controllers). The files are uploaded to the root directory which was configured for use by the TFTP server. You can change to a different directory.

**Note** Be sure that you have the correct software file for your controller.
Performing System Tasks

Chapter 4      Performing Maintenance Operations

Step 6  Click Download. WCS downloads the software to the controller, and the controller writes the code to flash RAM. As WCS performs this function, it displays its progress in the Status field.

Downloading Vendor Device Certificates

Each wireless device (controller, access point, and client) has its own device certificates. For example, the controller is shipped with a Cisco-installed device certificate. This certificate is used by EAP-TLS and EAP-FAST (when not using PACs) to authenticate wireless clients during local EAP authentication. However, if you wish to use your own vendor-specific device certificate, it must be downloaded to the controller.

To download a vendor-specific device certificate to the controller, follow these steps.

Step 1  Choose Configure > Controllers.
Step 2  You can download the certificates in one of two ways:
   a.  Select the check box of the controller you choose.
   b.  Choose Download Vendor Device Certificate from the Select a command drop-down list, and click Go.
   or
   a.  Click the URL of the desired controller in the IP Address column.
   b.  Choose System > Commands from the left sidebar menu.
   c.  Choose TFTP or FTP in the Upload/Download Command section.
   d.  Choose Download Vendor Device Certificate from the Upload/Download Commands drop-down list, and click Go.
Step 3  In the Certificate Password text box, enter the password which was used to protect the certificate.
Step 4  Specify if the certificate to download is on the TFTP server or on the local machine. If it is on the TFTP server, the name must be supplied in the Server File Name parameter. If the certificate is on the local machine, you must specify the file path in the Local File Name parameter using the Browse button.
Step 5  Enter the TFTP server name in the Server Name parameter. The default is for the WCS server to act as the TFTP server.
Step 6  Enter the server IP address.
Step 7  In the Maximum Retries text box, enter the maximum number of times that the TFTP server attempts to download the certificate.
Step 8  In the Timeout text box, enter the amount of time (in seconds) that the TFTP server attempts to download the certificate.
Step 9  In the Local File Name text box, enter the directory path of the certificate.
Step 10  Click OK.
Downloading Vendor CA Certificates

Controllers and access points have a certificate authority (CA) certificate that is used to sign and validate device certificates. The controller is shipped with a Cisco-installed CA certificate. This certificate may be used by EAP-TLS and EAP-FAST (when not using PACs) to authenticate wireless clients during local EAP authentication. However, if you wish to use your own vendor-specific CA certificate, it must be downloaded to the controller. To download vendor CA certificate to the controller, follow these instructions:

Step 1  Click Configure > Controllers.

Step 2  You can download the certificates in one of two ways:

a. Select the check box of the controller you choose.

b. Choose Download Vendor CA Certificate from the Select a command drop-down list, and click Go.

or

a. Click the URL of the desired controller in the IP Address column.

b. Choose System > Commands from the left sidebar menu.

c. Choose Download Vendor CA Certificate from the Upload/Download Commands drop-down list, and click Go.

Step 3  Specify if the certificate to download is on the TFTP server or on the local machine. If it is on the TFTP server, the name must be supplied in the Server File Name parameter in Step 9. If the certificate is on the local machine, you must specify the file path in the Local File Name parameter in Step 8 using the Browse button.

Step 4  Enter the TFTP server name in the Server Name parameter. The default is for the WCS server to act as the TFTP server.

Step 5  Enter the server IP address.

Step 6  In the Maximum Retries text box, enter the maximum number of times that the TFTP server attempts to download the certificate.

Step 7  In the Timeout text box, enter the amount of time (in seconds) that the TFTP server attempts to download the certificate.

Step 8  In the Local File Name text box, enter the directory path of the certificate.

Step 9  Click OK.

Using WCS to Enable Long Preambles for SpectraLink NetLink Phones

A radio preamble (sometimes called a header) is a section of data at the head of a packet. It contains information that wireless devices need when sending and receiving packets. Short preambles improve throughput performance, so they are enabled by default. However, some wireless devices, such as SpectraLink NetLink phones, require long preambles.

To optimize the operation of SpectraLink NetLink phones on your wireless LAN, follow these steps to use WCS to enable long preambles.
Verifying the Status of WCS

This section provides instructions for checking the status of WCS on either a Windows or Linux server.

Creating an RF Calibration Model

If you would like to further refine WCS Location tracking of client and rogue access points across one or more floors of a building, you have the option of creating an RF calibration model that uses physically collected RF measurements to fine-tune the location algorithm. When you have multiple floors in a building with the same physical layout as the calibrated floor, you can save time calibrating the remaining floors by using the same RF calibration model for the remaining floors.

The calibration models are used as RF overlays with measured RF signal characteristics that can be applied to different floor areas. This allows the Cisco Unified Wireless Network Solution installation team to lay out one floor in a multi-floor area, use the RF calibration tool to measure and save the RF characteristics of that floor as a new calibration model, and apply that calibration model to all the other floors with the same physical layout. See Chapter 5 for calibration instructions.

Verifying the Status of WCS

This section provides instructions for checking the status of WCS on either a Windows or Linux server.

Step 1 Log into the WCS user interface.
Step 2 Click Configure > Controllers to navigate to the All Controllers page.
Step 3 Click the IP address of the desired controller.
Step 4 From the left sidebar menu, choose 802.11b/g/n > Parameters.
Step 5 If the IP Address > 802.11b/g/n Parameters page shows that short preambles are enabled, continue to the next step. However, if short preambles are disabled, which means that long preambles are enabled, the controller is already optimized for SpectraLink NetLink phones, and you do not need to continue this procedure.
Step 6 Enable long preambles by unselecting the Short Preamble check box.
Step 7 Click Save to update the controller configuration.
Step 8 To save the controller configuration, click System > Commands from the left sidebar menu, Save Config To Flash from the Administrative Commands drop-down list, and Go.
Step 9 To reboot the controller, click Reboot from the Administrative Commands drop-down list, and click Go.
Step 10 Click OK when the following message appears:

Please save configuration by clicking "Save Config to flash". Do you want to continue rebooting anyways?

The controller reboots. This process may take some time, during which WCS loses its connection to the controller.

Note You can view the controller reboot process with a CLI session.

Creating an RF Calibration Model

If you would like to further refine WCS Location tracking of client and rogue access points across one or more floors of a building, you have the option of creating an RF calibration model that uses physically collected RF measurements to fine-tune the location algorithm. When you have multiple floors in a building with the same physical layout as the calibrated floor, you can save time calibrating the remaining floors by using the same RF calibration model for the remaining floors.

The calibration models are used as RF overlays with measured RF signal characteristics that can be applied to different floor areas. This allows the Cisco Unified Wireless Network Solution installation team to lay out one floor in a multi-floor area, use the RF calibration tool to measure and save the RF characteristics of that floor as a new calibration model, and apply that calibration model to all the other floors with the same physical layout. See Chapter 5 for calibration instructions.

Verifying the Status of WCS

This section provides instructions for checking the status of WCS on either a Windows or Linux server.
Checking the Status of WCS on Windows

You can check the status of WCS at any time. To check the status of WCS when it is installed as a Windows application or Windows service, follow these steps:

Step 1 Log into the system as administrator.
Step 2 Perform one of the following:
   - From the Windows Start menu, choose Programs > Wireless Control System > WCSStatus.
   - From the command prompt, navigate to the WCS installation directory (such as C:\Program Files\WCS7.0.X.X) and enter WCSAdmin status.

The WCSAdmin window appears and displays messages indicating the status of WCS.

Step 3 Close the WCSAdmin window when the Close button becomes active.

Checking the Status of WCS on Linux

You can check the status of WCS at any time. To check the status of WCS when it is installed as a Linux application or Linux service, follow these steps:

Step 1 Log into the system as root.
Step 2 Using the Linux CLI, perform one of the following:
   - Navigate to the installation directory (such as /opt/WCS7.0.X.X) and enter ./WCSStatus.
   - Navigate to the installation directory (such as /opt/WCS7.0.X.X) and enter WCSAdmin status.

The CLI displays messages indicating the status of WCS.

Stopping WCS

This section provides instructions for stopping WCS on either a Windows or Linux server.

Stopping WCS on Windows

You can stop WCS at any time. To stop WCS when it is installed as a Windows application or Windows service, follow these steps:

Note If any users are logged in when you stop WCS, their WCS sessions stop functioning.

Step 1 Log into the system as administrator.
Step 2 Perform one of the following:
• From the shortcut location (defaulted to Windows Start menu > Programs > Cisco Wireless Control System A.B.C.D), enter the **StopWCS** command.

• From the command prompt, navigate to the WCS installation directory (defaulted to C:\Program Files\WCSA.B.C.D\bin) and enter the **StopWCS** command.

**Note** You can use the **StopWCS** command for a graceful shut down. A graceful shut down does not trigger the automatic failover. Use the CLI command `<WCSROOT>\nmsadmin.bat -switchover stop` to trigger automatic failover when shutting down WCS.

The WCSAdmin window appears and displays messages indicating that WCS is stopping.

**Note** If WCS is installed as a service, messages also appear to indicate that the Nms_Server service is stopping.

---

**Step 3** Close the WCSAdmin window when the Close button becomes active.
Stopping WCS on Linux

You can stop WCS at any time. To stop WCS when it is installed as a Linux application or Linux service, follow these steps:

<table>
<thead>
<tr>
<th>Note</th>
<th>If any users are logged in when you stop WCS, their WCS sessions stop functioning.</th>
</tr>
</thead>
</table>

Step 1 Log into the system as root.

<table>
<thead>
<tr>
<th>Note</th>
<th>To see which version of WCS you currently have installed, enter the <code>nmsadmin.sh version</code> command.</th>
</tr>
</thead>
</table>

Step 2 Using the Linux CLI, perform one of the following:

- Navigate to the shortcut location (defaulted to /opt/WCSA.B.C.D) and enter the `./StopWCS` command.
- Navigate to the installation bin directory (defaulted to /opt/WCSA.B.C.D/bin) and enter the `StopWCS` command.

The CLI displays messages indicating that WCS is stopping.

Backing Up the WCS Database

This section provides instructions for backing up the WCS database. You can schedule regular backups through the WCS user interface or manually initiate a backup on either a Windows or Linux server.

<table>
<thead>
<tr>
<th>Note</th>
<th>Machine specific settings (such as FTP enable and disable, FTP port, FTP root directory, TFTP enable and disable, TFTP port, TFTP root directory, HTTP forward enable and disable, HTTP port, HTTPS port, report repository directory, and all high availability settings) are not included in the backup and restore function if the backup is restored to a different device.</th>
</tr>
</thead>
</table>

Scheduling Automatic Backups

To schedule automatic backups of the WCS database, follow these steps:

Step 1 Log into the WCS user interface.
Step 2 Click Administration > Background Tasks to display the Scheduled Tasks page.
Step 3 Click WCS Server Backup to display the Task > WCS Server Backup page.
Step 4 Select the Enabled check box.
Step 5 At the Report History Backup parameter, select the Enabled check box to run history backup.
Step 6 In the Max Backups to Keep text box, enter the maximum number of backup files to save on the server. Range: 7 to 50
Performing a Manual Backup

This section provides instructions for backing up the WCS database on either a Windows or Linux server.

Backing Up the WCS Database (for Windows)

To back up the WCS database on a Windows server, follow these steps:

Step 1 Log into the system as administrator.

Step 2 Create a backup directory for the WCS database with no spaces in the name, such as C:\WCS7.0.X.X_Backup.

Note Make sure that the directory name does not contain spaces. Spaces can generate errors.

Step 3 Perform one of the following:

Follow these steps from the Windows Start menu:

a. Choose Programs > Wireless Control System > Backup. The Enter Information window appears.

b. Browse to the backup directory that you created and choose the filename or enter the full path of the backup directory that you created and a name for the backup file (such as C:\WCS7.0.X.X_Backup\Nov11), and click OK.

Follow these steps from the command prompt:

a. Navigate to the WCS installation directory (C:\Program Files\WCS7.0.X.X\bin).
b. Enter the **DBAdmin backup backup-filename** command, where *backup-filename* is the full path of the backup directory that you created plus a name for the backup file (such as C:\WCS7.0.X.X_Backup\Nov11).

The DBAdmin window appears and displays messages indicating the status of the backup.

**Step 4** Close the DBAdmin window when the Close button becomes active.

---

**Note** In the preceding example, the backup file would appear in the C:\WCS7.0.X.X_Backup directory as Nov11.nmsbackup.

---

### Backing Up the WCS Database (for Linux)

To back up the WCS database on a Linux server, follow these steps:

**Step 1** Log into the system as root.

**Step 2** Using the Linux CLI, navigate to the /opt/WCS7.0 directory (or any other directory).

**Step 3** Create a backup directory for the WCS database with no spaces in the name (for example, `mkdir WCS7.0.X.X_Backup`).

---

**Note** Make sure that the directory name does not contain spaces. Spaces can generate errors.

---

**Step 4** Perform one of the following:

- Navigate to the /opt/WCS7.0.X.0 directory (or the directory chosen during installation) and enter the `/Backup` command. Enter a name for the backup file when prompted (such as WCS7.0.X.X_Backup/Nov11).

- Navigate to the /opt/WCS7.0.X.X/bin directory (or the directory chosen during installation) and enter the **DBAdmin backup backup-filename** command, where *backup-filename* is the full path of the backup directory that you created plus a name for the backup file (such as WCS7.0.X.X_Backup/Nov11).

- Using KDE or X-Windows, enter the **DBAdmin - gui backup** command, browse to the backup directory, and choose the file.

The CLI displays messages indicating the status of the backup.

---

**Note** In the preceding example, the backup file would appear in the WCS7.0.X.X_Backup directory as Nov11.nmsbackup.

---

### Restoring the WCS Database

This section provides instructions for restoring the WCS database on either a Windows or Linux server.
Restoring the WCS Database (for Windows)

If you are restoring the WCS database in a high availability environment, refer to the “Restoring the WCS Database in a High Availability Environment” section on page 4-14. To restore the WCS database from a backup file on a Windows server, follow these steps:

Note
The server may incorrectly perceive the amount of free space available during a restore if a FAT32 file system is used. Microsoft’s recommended file system for Windows servers is NTFS.

Step 1
Log into the system as administrator.

Step 2
Perform one of the following:

Follow these steps from the Windows Start menu:

a. Choose Start > Programs > Wireless Control System> Restore. The DBAdmin and Enter Information window appears.

b. Browse to the backup directory that you created and choose the filename or enter the full path and filename of the backup file (such as C:\WCS7.0.X.X_Backup\Nov11.nmsbackup), and click OK.

or

Follow these steps from the command prompt:

a. Navigate to the WCS installation directory (C:\Program Files\WCS7.0.X.X\bin).

b. Enter the DBAdmin restore backup-filename command, where backup-filename is the full path and filename of the backup file (for example, C:\WCS7.0.X.X_Backup\Nov11.nmsbackup).

Note
When you perform a restore of a large database, you must instead enter the dbadmin.bat -gui -largedb restore command.

Step 3
If you have a large event table to migrate, you must limit the size of the event table. You cannot decline this process, but it generally only affects pre-5.1 to 5.2 or later migration. The following warning message appears:

WARNING: You are migrating from a pre-5.1 database to a post-5.1 database. This may take a very long time -- possibly several hours. You can considerably speed this migration by retaining only the most recent events from the restored database. Even if you do this, the event table will be repopulated within seven days. This does not affect current alarms. This does not affect the backed-up database.

Would you like to retain only recent events?

If you type Y or Yes (or click Yes from the GUI prompt), the restore retains only the most recent 40,000 events.

Note
When you perform a restore of a UBC database, we strongly recommend that you choose to retain only recent events.

Note
You can also enter the -dropoldevents command at the CLI prompt as an equivalent to answering yes here.
Step 4  Click Yes if a message appears indicating that WCS is running and needs to be shut down.

Step 5  The DBAdmin window appears and displays messages indicating that WCS is shutting down (if applicable) and the WCS database is being restored. Close the DBAdmin window when the Close button becomes active.

Note  If the restore process shuts down WCS, a restart is attempted after a successful restore.

---

**Restoring the WCS Database (for Linux)**

If you are restoring the WCS database in a high availability environment, see the “Restoring the WCS Database in a High Availability Environment” section on page 4-14. To restore the WCS database from a backup file on a Linux server, follow these steps:

Step 1  If possible, stop all WCS user interfaces to stabilize the database.

Step 2  Log into the system as root.

Step 3  Using the Linux CLI, perform one of the following:

- Navigate to the /opt/WCS7.0.X.X directory (or the directory chosen during installation) and enter the .Restore command to start the restoration process. Enter the backup filename when prompted (such as WCS7.0.X.X_Backup/Nov11.nmsbackup).

- Navigate to the /opt/WCS7.0.X.X/bin directory (or the directory chosen during installation) and enter the DBAdmin restore backup-filename command, where backup-filename is the full path and filename of the backup file (such as WCS7.0.X.X_Backup/Nov11.nmsbackup).

Note  If you are restoring from a WCS version prior to 3.2, you must enter a directory rather than a backup file because tar/gzip did not exist prior to 3.2. Enter the DBAdmin restore directory command, where directory is the backup directory that you created.

Step 4  Click Yes if a message appears indicating that WCS is running and needs to be shut down.

Step 5  The DBAdmin window appears and displays messages indicating that WCS is shutting down (if applicable) and the WCS database is being restored. Close the DBAdmin window when the Close button becomes active.

Note  If the restore process shuts down WCS, a restart is attempted after a successful restore.

The CLI displays messages indicating that the WCS database is being restored.
Restoring the WCS Database in a High Availability Environment

During installation, you were prompted to determine if a secondary WCS server would be used for high availability support to the primary WCS server. If you opted for this high availability environment and enabled it in the Administration > High Availability window, the status appears as HA enabled. Before restoring a database, you must convert the status to HA not configured.

Note
If you attempt to restore the database while the status is set to HA enabled, unexpected results may occur.

Follow one of these procedures to change the status from HA enabled to HA not configured:

- Click **Remove** in the HA Configuration window (Administration > High Availability).
- Restart the primary server. Go to the secondary HealthMonitor GUI (https://<SecondaryWCS>:8082), and click **Failback**.
  - Use this method when one of the following instances has occurred:
    - The primary server is down and failover has not been executed, so the secondary server is in SecondaryLostPrimary state.
    - The primary server is down and failover is already executed, so the secondary server is in the SecondaryActive state.

The primary server will now be in HA Not Configured mode, and you can safely restore the database.

Uninstalling WCS

This section provides instructions for uninstalling WCS on either a Windows or Linux server. You can uninstall WCS at any time, even while WCS is running.

Uninstalling WCS on Windows

To uninstall WCS on a Windows server, follow these steps:

**Step 1** Log into the system as administrator.

**Step 2** From the Windows Start menu, choose **Programs > Wireless Control System> Uninstall WCS**.

**Step 3** When the Uninstall Wireless Control System window appears, click **Uninstall**.

**Step 4** Follow the instructions on the window to continue the uninstall process.

**Step 5** When the WCS Uninstaller window indicates that the program is uninstalled, click **Finish** to close the window.
Uninstalling WCS on Linux

To uninstall WCS on a Linux server, follow these steps:

**Step 1** Stop WCS.
**Step 2** Log into the system as root through an X terminal session.
**Step 3** Using the Linux CLI, navigate to the /opt/WCS7.0.X.X directory (or the directory chosen during installation).
**Step 4** Enter the `./UninstallWCS` command.
**Step 5** Click Yes to continue the uninstall process.
**Step 6** Click Finish when the uninstall process is complete.

If any part of the /opt/WCS7.0.X.X directory remains on the hard drive, manually delete the directory and all of its contents. If you fail to delete the previous WCS installation, this error message appears when you attempt to reinstall WCS: “Cisco WCS already installed. Please uninstall the older version before installing this version.”

Upgrading WCS

This section provides instructions for upgrading WCS on either a Windows or Linux server. An automated upgrade is available in software release 4.2 and later. It handles the steps you would normally follow to accomplish an upgrade (shut down WCS, perform a backup, install new version, restore the backup, remove the old WCS version, and start WCS). If you choose to use the installer, it searches for any previous WCS versions.

If you are upgrading WCS in a high availability environment, see the “Upgrading WCS in a High Availability Environment” section on page 4-21.

If you are upgrading WCS in a high availability environment, see the “Upgrading WCS in a High Availability Environment” section on page 4-21.

**Note** You must have software release 4.1.91.0 before you can automatically upgrade to 4.2.
**Upgrading WCS**

**Note**

You should perform a Refresh Config from Controller after an upgrade of software to ensure that FTP details for the controller are retained. This Refresh Config from Controller drop-down option is available from the Configuration Commands section after choosing Configure > Controller > System > Commands.

If you choose to use the easy upgrade process, it provides error checking at each step and gives an informative message if an error causing an exit occurs. An upgrade-version.log is also produced and provides corrective measures. As part of the automatic upgrade process, machine specific settings are migrated.

If WCS is configured to use TACACS+ or RADIUS for external authentication, the custom vendor attribute list should be updated in the TACACS+ or RADIUS server with any new permissions. The attribute list for the appropriate UserGroup is found in Administration > AAA > UserGroups. Click the Export link for the appropriate user group.

**Note**

Scheduled task settings are not preserved when you upgrade from WCS 4.0 or earlier releases. Be sure to record your settings manually if you wish to retain them or go to Administration > Background Tasks after starting WCS to check or change the settings as necessary.

**Note**

If you upgrade to a WCS software release later than 4.0.87.0 from a release prior to 4.0.87.0, the users, user groups, tasks, and user passwords do not migrate. Upgrading to 4.0.87.0 before upgrading to a later release migrates the users, user groups, tasks, and user passwords.

**Using the Installer to Upgrade WCS for Windows**

To upgrade WCS (on a Windows platform) using the automated upgrade, follow these steps:

**Step 1**

Insert the Windows Cisco WCS CD into the CD-ROM drive and double-click the WCS-STANDARD-K9-7.0.X.Y.exe file where 7.0.X.Y is the software build. If you downloaded the installer from Cisco.com, double-click the WCS-STANDARD-WB-K9-7-0-X-Y.exe file that you downloaded to your local drive.

**Step 2**

The Install Anywhere window appears and prepares the system for installation. After a few seconds, the Introduction window appears, followed by the license agreement window. You must click the “I accept the terms of the License Agreement” option to continue.

**Step 3**

At this point, the install wizard detects whether a previous version of WCS is installed and specifies whether the current version is eligible for an automated upgrade. If your most recent WCS version cannot participate in the automated upgrade, you receive a notification as shown in Figure 4-1. If your WCS version is eligible for an automated upgrade, you receive a notification as shown in Figure 4-2.
Figure 4-1  Ineligible for Automated Upgrade

Install/Upgrade

Install Software Version: 5.0.55.0
Installed Software Version: 4.1.03.0

The installed version does not support automated upgrade.

Automated upgrade support begins in 4.1.01.0. Manual upgrade will have to be used; see documentation for details. Installing multiple versions is not recommended.

Would you like to install this version along with the one already installed (not recommended)?

[Install] [Exit]
Step 4 If you see a window similar to the one in Figure 4-1 and click Install because you cannot perform the automated upgrade, continue to the “Manually Upgrading WCS on Windows” section on page 4-20. If you see a window similar to the one in Figure 4-2 because a previous qualifying version of WCS is detected, choose Upgrade and continue to Step 5. This method is preferred.

Step 5 Several of the values from the previous install are retained and carried over as part of the upgrade. These include the following:
- the ports
- the root password
- the root FTP password
- the TFTP server file location
- the FTP server file location
- the multi-homed server interfaces

Step 6 Choose a folder in which to install the Cisco WCS at the Choose Install Folder window. It must be a different location than the previous install. Click Next to continue.

Step 7 Choose a folder location to store the shortcuts. It must be a different location than the previous install.

Step 8 Continue to follow the prompts that appear. You are notified of checking for required space, uninstalling of previous versions, backing up files, restoring, and so on. You then see a prompt asking if you are now ready to start WCS as a service. Click Yes.
Using the Installer to Upgrade WCS for Linux

To upgrade WCS (on a Linux platform) using the automated upgrade, follow these steps:

**Step 1** Using the command-line, perform one of the following:
- If you are installing from a CD, switch to the /media/cdrom directory.
- If you are installing from Cisco.com, switch to the directory in which the install file was downloaded. For example, if the install file was placed in /root/Desktop, enter the `cd /root/Desktop` command.

**Step 2** Enter the `/WCS-STANDARD-K9-7.0.X.Y.bin` command (for CD users) or `/WCS-STANDARD-LB-K9-7.0-X-Y.bin` command (for Cisco.com users) to start the install script.

**Step 3** The Install Anywhere message appears and prepares the system for installation. After a few seconds, the Introduction appears, followed by the license agreement statement. You must accept the license agreement to continue.

**Step 4** At this point, the install wizard detects whether a previous version of WCS is installed and specifies whether the current version is eligible for an automated upgrade. You receive a notification whether or not your most recent WCS version is eligible for the automated upgrade.

**Step 5** If you cannot continue to the automated upgrade because your current WCS version is not eligible, choose Install and continue to the “Manually Upgrading WCS on Linux” section on page 4-20. If you choose to do a manual upgrade rather than the recommended automated upgrade, choose Install and continue to the “Manually Upgrading WCS on Linux” section on page 4-20. If your current WCS version is eligible for the recommended automated upgrade, choose Upgrade and continue to Step 6.

**Step 6** Several of the values from the previous install are retained and carried over as part of the upgrade. These include the following:
- the ports
- the root password
- the root FTP password
- the TFTP server file location
- the FTP server file location
- the multi-homed server interfaces

**Step 7** Choose a folder in which to install the Cisco WCS. It must be a different location than the previous install. Click Next to continue.

**Step 8** Choose a folder location to store the shortcuts. It must be a different location than the previous install.

**Step 9** Continue to follow the prompts that appear. You are notified of checking for required space, uninstalling of previous versions, backing up files, restoring, and so on. You then see a prompt asking if you are now ready to start WCS as a service. Click Yes.
The upgrade log is located in the standard log directory (`/webnms/logs`) if the automated upgrade completes. For an incomplete automated upgrade, the upgrade log is located in the user home directory.

Manually Upgrading WCS on Windows

This type of upgrade is not recommended. To manually upgrade WCS on a Windows server, follow these steps:

- **Step 1** If possible, stop all WCS user interfaces to stabilize the database.
- **Step 2** Back up the WCS database by following the instructions in the “Backing Up the WCS Database (for Windows)” section on page 4-10.
- **Step 3** Uninstall the WCS application by following the instructions in the “Uninstalling WCS on Windows” section on page 4-14.
- **Step 4** Install the new version of WCS by following the instructions in the “Installing WCS for Windows” section on page 2-6.
- **Step 5** Restore the WCS database by following the instructions in the “Restoring the WCS Database (for Windows)” section on page 4-12.

Manually Upgrading WCS on Linux

This type of upgrade is not recommended. To upgrade WCS on a Linux server, follow these steps:

- **Step 1** If possible, stop all WCS user interfaces to stabilize the database.
- **Step 2** Back up the WCS database by following the instructions in the “Backing Up the WCS Database (for Linux)” section on page 4-11.
- **Step 3** Uninstall the WCS application by following the instructions in the “Uninstalling WCS on Linux” section on page 4-15.
- **Step 4** Install the new version of WCS by following the instructions in the “Installing WCS for Linux” section on page 2-13.
- **Step 5** Restore the WCS database by following the instructions in the “Restoring the WCS Database (for Linux)” section on page 4-13.
Upgrading WCS in a High Availability Environment

If you have a primary and secondary WCS, follow these steps for a successful upgrade:

**Step 1** You must first upgrade the secondary WCS with the following steps:

a. Shut down the secondary WCS. See the “Stopping WCS” section on page 4-7 for more information.

   **Note**
   You can use the **StopWCS** command for a graceful shut down. A graceful shut down does not trigger the automatic failover. Use the CLI command `<WCSROOT>\nmsadmin.bat -switchover stop` to trigger automatic failover when shutting down WCS.

b. Perform an auto upgrade on the secondary WCS. See the “Using the Installer to Upgrade WCS for Windows” section on page 4-16 or the “Using the Installer to Upgrade WCS for Linux” section on page 4-19 for more information.

c. Start the secondary WCS.

   **Note** It will attempt to reconnect to the primary WCS, but a version mismatch error is returned.

**Step 2** Upgrade the primary WCS.

a. Shut down the primary WCS. See the “Stopping WCS” section on page 4-7 for more information.

b. Perform an auto upgrade on the primary WCS. See the “Using the Installer to Upgrade WCS for Windows” section on page 4-16 or the “Using the Installer to Upgrade WCS for Linux” section on page 4-19 for more information.

c. Start the primary WCS.

   It connects to the Secondary WCS, and all data is resynchronized.

Upgrading the Network

Network upgrades must follow a recommended procedure so that databases can remain synchronized with each other. You cannot for instance upgrade the controller portion of the network to a newer release but maintain the current WCS version and not upgrade it. The supported order of upgrade is WCS first, followed by the controller, and then any additional devices.

Reinitializing the Database

If you need to reset the database because of a synchronization problem or a corruption of some type, enter the `{install directory}/bin/dbadmin.(sh|bat) reinitdb` command to reinitialize the database.
Recovering the WCS Password

You can change the WCS application root user or FTP user password. This option provides a safeguard if you lose the root password. An executable was added to the installer /bin directory (passwd.bat for Windows and passwd.sh for Linux). Follow these steps to recover the passwords and regain access to WCS. For password recovery on a wireless location device, refer to Chapters 8 or 9 of the Cisco 2700 Series Location Appliance Configuration Guide.

**Note**
If you are a Linux user, you must be the root user to run the command.

**Note**
In Linux, use the `passwd.sh` command to change the WCS password. The `passwd` command is a built-in Linux command to change the OS password.

---

**Step 1**
Change to the WCS bin folder.

**Step 2**
Perform one of the following:

Enter `passwd.bat root-user newpassword` command to change the WCS root password. The `newpassword` is the root login password you choose.

or

Enter `passwd.bat location-ftp-user newuser newpassword` command to change the FTP user and password. The `newuser` and `newpassword` are the FTP user and password you choose.

**Note**
For Linux:

Enter the `passwd.sh root-user newpassword` command to change the WCS root password. The `newpassword` is the root login password you choose.

or

Enter the `passwd.sh location-ftp-user newuser newpassword` command to change the FTP user and password. The `newuser` and `newpassword` are the FTP user and password you choose.

**Step 3**
The following options are available with these commands:

- `-q`—to quiet the output
- `-pause`—to pause before exiting
- `-gui`—to switch to the graphical user interface
- `-force`—to skip prompting for configuration

**Step 4**
Start WCS.
Monitoring Maps

This chapter describes how to add maps to the Cisco WCS database and use them to monitor your wireless LAN. With the WCS database, you can add maps and view your managed system on realistic campus, building, and floor maps.

Additionally, you can enable location presence by mobility server to provide expanded Civic (city, state, postal code, country) and GEO (longitude, latitude) location information beyond the Cisco default setting (campus, building, floor, and X, Y coordinates). This information can then be requested by clients on a demand basis for use by location-based services and applications. Location Presence can be configured when a new campus, building, floor, or outdoor area is being added or configured at a later date.

A mobility server should be synchronized before Location Presence is enabled. For details on enabling location presence and assigning its parameters, refer to Cisco Context-Aware Services documentation at this location:


This configuration guide also covers verifying location accuracy, using chokepoints, using Wi-Fi TDOA receivers, applying calibration models and other context-aware planning and verification topics.

This chapter contains the following sections:
- Information About Maps, page 5-2
- Guidelines and Limitations, page 5-19
- Monitoring Maps, page 5-22
- Searching Maps, page 5-71
- Using Map Editors, page 5-71
- Inspecting Location Readiness and Quality, page 5-78
- Using Planning Mode, page 5-101
- Refresh Options, page 5-108
- Creating a Network Design, page 5-109
- Importing or Exporting WLSE Map Data, page 5-114
Information About Maps

This section contains the following topics:

- Maps, page 5-2
- Campus, page 5-3
- Building, page 5-3
- Floor Area, page 5-4
- Access Points, page 5-4
- Chokepoints, page 5-4
- Wi-Fi TDOA Receivers, page 5-4
- Map Editor, page 5-4
- Floor Settings, page 5-5

Maps

Maps provide a summary view of all your managed systems on campuses, buildings, outdoor areas, and floors. The available information includes:

- Total APs—Number of total access points for each map.
- 802.11a/n Radios and 802.11b/g/n Radios—Number of 802.11a/n and 802.11b/g/n radios associated with each map.
- Out of Service (OOS) Radios—Number of 802.11a/n and 802.11b/g/n radios associated with each map.
- Clients—Number of clients associated to access points on the map.

Note This number is based on the most recent Client Statistics Poll. The number of clients located on the map by MSE may not match this number.

- 802.11a/n and 802.11b/g/n Avg Air Quality—Indicates the average Air Quality (AQ) for 802.11a/n and 802.11b/g/n radios.
- 802.11a/n and 802.11b/g/n Min Air Quality—Indicates the minimum Air Quality (AQ) for 802.11a/n and 802.11b/g/n radios.
- Status—Indicates the current status of the map.
  - Red triangle—Critical fault
  - Yellow triangle—Minor fault
  - Green square—Ok

Note To view or edit current maps, choose Monitor > Maps (see Figure 5-1) and choose the appropriate map from the list. Use the Select a command drop-down list to access additional functionality.
The left sidebar menu lists all campuses, buildings, and floors in a tree view. When you click a campus, building, or floor in the Maps Tree View menu, the main area of the window displays corresponding information.

**Note**
Click **Edit View** to change the information displayed for the listed maps. See the “Configuring Edit View” section on page 5-23 for more information.

**Note**
**Root Area** (listed in the Maps Tree View menu) displays a list of buildings that are not in campuses. Status and object counts for Root Area buildings are not aggregated.

Use the Select a command drop-down list for additional map functionality.

To search for a specific map, use the WCS Search feature. See Advanced Search, page 2-35 for more information. You can search using the following map parameters:

- **Search for**—Choose All Maps, Campuses, Buildings, Floor Areas, or Outdoor Areas.
- **Map Name**

**Campus**

A campus is the area in which a building or set of surrounding buildings are situated.

**Building**

A building is a structure which has a roof and walls and stands more or less permanently in one place.
Floor Area

The floor area is the area of each floor of the building measured to the outer surface of the outer walls including the area of lobbies, cellars, elevator shafts and in multi-dwelling buildings all the common spaces.

Access Points

Access Points (APs) are specially configured nodes on wireless local area networks (WLANs). Access points act as a central transmitter and receiver of WLAN radio signals. Access points support Wi-Fi wireless communication standards.

Chokepoints

Installation of chokepoints provides enhanced location information for RFID tags. When an active Cisco Compatible Extensions version 1 compliant RFID tag enters the range of a chokepoint, it is stimulated by the chokepoint. The MAC address of this chokepoint is then included in the next beacon sent by the stimulated tag. All access points that detect this tag beacon then forward the information to the controller and location appliance.

Wi-Fi TDOA Receivers

TDoA technology uses a time-based method to calculate the location. Each Wi-Fi TDoA receivers report the time of arrival of the signal from the tag to its respective receiver. The Cisco Mobility Services Engine correlates the time of arrival for all the tag signals from all the TDoA receivers to find the intersection points of known distances. The greater the number of receivers used in the calculation, the more accurately the tag can be located. Wi-Fi TDoA receivers are typically used for calculating location information in manufacturing or retail warehouse environments (where there are lots of machines or high ceilings or both), in outdoor environments, or in other line-of-site environments.

Map Editor

You can use the WCS map editor to define, draw, and enhance floor plan information. The map editor enables you to create obstacles to consider when you computer RF prediction heat maps for access points. You can also add coverage areas for MSEs that locate clients and tags in that particular area. Follow these general guidelines to use the map editor.

Map Editor Functions

With the map editor, you can perform the following functions:

- Save—Saves the current map image.
- Recompute prediction—Updates the RF prediction heatmap if any changes are made to the existing floor map image.
- Reload Last Saved—Loads the last saved map image.
- Select all—Selects all the obstacles and coverage areas that you have created.
• Unselect—Deselects the obstacles and coverage areas that are selected.
• Move selected Obstacles—Moves the selected obstacles to a different location on the map.
• Duplicate selected Obstacles—Creates a copy of the selected obstacles.
• Zoom in/Zoom out—Zoom in or out on the image you are currently viewing.
• Show floor image—Use this to display the floor image.
• Show obstacles—Use this to display the obstacles.
• Larger resolution/Medium resolution/Smaller resolution—Increase or decrease the resolution of the floor map image.
• SNAP Mode—Use this to snap an obstacle to its nearest obstacle while drawing.
• ORTHO Mode—Use to draw a horizontal or vertical obstacle. This is especially useful when you want to draw all the obstacles at right angles.

**Floor Settings**

You can modify the appearance of the floor map by selecting or unselecting Floor Settings check boxes. The selected Floor Settings are displayed in the map image.

**Note**

Depending on whether or not a mobility services engine is present in WCS, some of the floor settings may not be displayed.

The Floor Settings options include the following:

• Access Points—See the “Filtering Access Point Floor Settings” section on page 5-6 for more information.
• AP Heatmaps—See the “Filtering Access Point Heatmap Floor Settings” section on page 5-10 for more information.
• AP Mesh Info—Appears only if mesh access points are present in outdoor areas. See the “Filtering AP Mesh Info Floor Settings” section on page 5-11 for more information.
• Clients—Displays data only if a mobility services engine was added in WCS. See the “Filtering Client Floor Settings” section on page 5-11 for more information.
• 802.11 Tags—See the “Filtering 802.11 Tag Floor Settings” section on page 5-13 for more information.
• Rogue APs—Displays data only if a mobility services engine was added in WCS. See the “Filtering Rogue AP Floor Settings” section on page 5-13 for more information.
• Rogue Adhocs—Displays data only if a location server was added in WCS. See the “Filtering Rogue Adhoc Floor Settings” section on page 5-14 for more information.
• Rogue Clients—Displays data only if a location server was added in WCS. See the “Filtering Rogue Client Floor Settings” section on page 5-14 for more information.
• Coverage Areas
• Location Regions
• Rails
• Markers
• Chokepoints—Appears only if chokepoints are added in WCS.
• Wi-Fi TDOA Receivers
• Interferers—Displays details of the interferers on the wireless network. See the “Filtering Interferer Settings” section on page 5-14 for more information.

Use the blue arrows to access Floor Setting filters for access points, access point heatmaps, clients, 802.11 tags, rogue access points, rogue adhocs, and rogue clients. When filtering options are selected, click OK.

Use the Display MSE data within last drop-down list to select the timeframe for mobility services engine data. Choose to view mobility services engine data from a range including the past two minutes up to the past 24 hours. This option only appears if a mobility services engine is present on the WCS.

Click Save Settings to make the current view and filter settings your new default for all maps.

**Figure 5-2  Floor Settings Parameters**

<table>
<thead>
<tr>
<th>Floor Settings</th>
<th>Access Points</th>
<th>AP Heatmaps</th>
<th>Clients</th>
<th>802.11 Tags</th>
<th>Rogue APs</th>
<th>Rogue Adhocs</th>
<th>Rogue Clients</th>
<th>coverageAreas</th>
<th>Location Regions</th>
<th>Rails</th>
<th>Markers</th>
<th>Checkpoints</th>
<th>With TDOA Receivers</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display MSE data within last:</td>
<td>2 Minutes</td>
<td>Save Settings</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Filtering Access Point Floor Settings**

If you enable the Access Point floor setting and then click the blue arrow to the right of the Floor Settings, the access point filter page opens with filtering options.

**Figure 5-3  Access Point Filter**

<table>
<thead>
<tr>
<th>AP Filter</th>
<th>18 Total APs</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Radio Status</td>
<td>AP Status</td>
</tr>
<tr>
<td>Protocol 802.11b/g/n</td>
<td></td>
</tr>
<tr>
<td>Display</td>
<td>Names</td>
</tr>
<tr>
<td>RSSI Cutoff -75 dBm</td>
<td>OK</td>
</tr>
</tbody>
</table>
Access point filtering options include the following:

- **Show**—Choose to display the radio status or access point status.
  
  **Note** Because the access point icon color is based on the access point status, the icon color may vary depending on the status selected. The default on floor maps is radio status.

- **Protocol**—From the drop-down list, select which radio types to display (802.11a/n, 802.11b/g/n, or both).
  
  **Note** The displayed heatmaps correspond with the selected radio type(s).

- **Display**—From the drop-down list, select what identifying information is displayed for the access points on the map image.
  
  - **Channels**—Displays the Cisco Radio channel number or Unavailable (if the access point is not connected).
    
    **Note** The available channels are defined by the country code setting and are regulated by country. Refer to:
    

  - **TX Power Level**—Displays the current Cisco Radio transmit power level (with 1 being high) or Unavailable (if the access point is not connected).
    
    **Note** The power levels differ depending on the type of access point. The 1000 series access points accept a value between 1 and 5, the 1230 access points accept a value between 1 and 7, and the 1240 and 1100 series access points accept a value between 1 and 8.

  *Table 5-1* lists the transmit power level numbers and their corresponding power setting.

  **Table 5-1  Transmit Power Level Values**

<table>
<thead>
<tr>
<th>Transmit Power Level Number</th>
<th>Power Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Maximum power allowed per country code setting</td>
</tr>
<tr>
<td>2</td>
<td>50% power</td>
</tr>
<tr>
<td>3</td>
<td>25% power</td>
</tr>
<tr>
<td>4</td>
<td>12.5 to 6.25% power</td>
</tr>
<tr>
<td>5</td>
<td>6.25 to 0.195% power</td>
</tr>
</tbody>
</table>
Information About Maps

Note

The power levels are defined by the country code setting and are regulated by country. Refer to:

- Channel and Tx Power—Displays both the channel and transmit power level (or Unavailable if
  the access point is not connected).
- Coverage Holes—Displays a percentage of clients whose signal has become weaker until the
  client lost its connection, Unavailable for unconnected access points, or MonitorOnly for access
  points in monitor-only mode.

Note

Coverage holes are areas in which clients cannot receive a signal from the wireless
network. When you deploy a wireless network, you must consider the cost of the initial
network deployment and the percentage of coverage hole areas. A reasonable coverage
hole criterion for launch is between 2 and 10 percent. This means that between two and
  ten test locations out of 100 random test locations might receive marginal service. After
launch, Cisco Unified Wireless Network Solution radio resource management (RRM)
identifies these coverage hole areas and reports them to the IT manager, who can fill
holes based on user demand.

- MAC Addresses—Displays the MAC address of the access point, whether or not the access
  point is associated to a controller.
- Names—Displays the access point name. This is the default value.
- Controller IP—Displays the IP address of the controller to which the access point is associated
  or Not Associated for disassociated access points.
- Utilization—Displays the percentage of bandwidth used by the associated client devices
  (including receiving, transmitting, and channel utilization). Displays Unavailable for
disassociated access points and MonitorOnly for access points in monitor-only mode.
- Profiles—Displays the load, noise, interference, and coverage components of the corresponding
operator-defined thresholds. Displays Okay for thresholds not exceeded, Issue for exceeded
thresholds, or Unavailable for unconnected access points.

Note

Use the Profile Type drop-down list to select Load, Noise, Interference, or Coverage.

- CleanAir Status—Displays the CleanAir status of the access point, whether or not CleanAir is
  enabled on the access point.
- Average Air Quality—Displays the average air quality on this access point. The details include,
  the band, and the average air quality.
- Minimum Air Quality—Displays the minimum air quality on this access point. The details
  include, the band and the minimum air quality.
- Average and Minimum Air Quality—Displays the average and minimum air quality on this
  access point. The details include, the band, average air quality, and minimum air quality.
- Associated Clients—Displays the number of associated clients, Unavailable for unconnected
  access points, or MonitorOnly for access points in monitor-only mode.
Information About Maps

Note
Click the client number to view client details. See “Monitor > Clients” for more information.

– Bridge Group Names

• RSSI Cutoff—From the drop-down list, choose the RSSI cutoff level. The RSSI cutoff ranges from -60 dBm to -90 dBm.

• Show Detected Interferers—Select the check box to display all interferers detected by the access point.

• Max. Interferers/label—choose the maximum number of interferer to be displayed per label from the drop-down list.

Click OK when all applicable filtering criteria are selected.

Understanding RF Heatmap Calculation

The RF heatmap calculation is based on an internal grid. Depending on the exact positioning of an obstacle in that grid, the RF heatmap, within a few feet or meters of the obstacle, may or may not account for the obstacle attenuation.

In detail, grid squares partially affected by an obstacle crossing the grid square may or may not incorporate the obstacle attenuation according to the geometry of the access point, obstacle, and grid.

For example, consider a wall crossing one grid square. The midpoint of the grid square is behind the wall from the AP, so the whole grid square is colored with attenuation, including (unfortunately) the top left corner that is actually in front of the wall (see Figure 5-4).

Figure 5-4  Access Point/Grid Example One (Actual Attenuation)

Figure 5-5 displays how the attenuation would ideally appear in this situation.
The midpoint of the grid square is on the same side of the wall as the AP, so the whole grid square is not colored with attenuation, including (unfortunately) the bottom right corner that is actually behind the wall from the AP (see Figure 5-6).

**Figure 5-6  Access Point/Grid Example Two (Actual Attenuation)**

Figure 5-7 displays how the attenuation would ideally appear in this situation.

**Figure 5-7  Access Point/Grid Example Two (Ideal Attenuation)**

**Filtering Access Point Heatmap Floor Settings**

If you enable the Access Point Heatmap floor setting and click the blue arrow to the right of the Floor Settings, the Contributing APs page opens with heatmap filtering options.
Access point heatmap filtering options include:

- **Heatmap Type**—Select IDS, Coverage, or Air Quality. If you choose Air Quality, you can further filter the heat map type for access points with average air quality or minimum air quality. Select the appropriate radio button.

  **Note** If you have monitor mode access points on the floor plan, you have a choice between IDS or coverage heatmap types. A coverage heat map excludes monitor mode access points.

- **Total APs**—Displays the number of access points positioned on the map.

- Select the access point check box(es) to determine which heatmaps display on the image map.

Click **OK** when all applicable filtering criteria are selected.

### Filtering AP Mesh Info Floor Settings

**Note** The AP Mesh Info option only appears when bridging access points are added to the floor.

When this option is selected, Cisco WCS initiates a contact with the controllers and displays information about bridging access points. The following information is displayed:

- Link between the child and the parent access point.
- An arrow that indicates the direction from child to parent access point.
- A color coded link that indicates the signal-to-noise ratio (SNR). A green link represents a high SNR (above 25 dB), an amber represents an acceptable SNR (20-25 dB), and a red link represents a very low SNR (below 20 dB).

If you enable the AP Mesh Info floor setting and click the blue arrow to the right of the floor settings, the Mesh Parent-Child Hierarchical View page opens with mesh filtering options.

You can update the map view by choosing the access points you want to see on the map. From the Quick Selections drop-down list, choose to select only root access point, various hops between the first and the fourth, or select all access points.

**Note** For a child access point to be visible, its parent must also be selected.

Click **OK** when all applicable filtering criteria are selected.

### Filtering Client Floor Settings

**Note** The Clients option only displays if a mobility server is added in WCS.

If you enable the Clients floor setting and click the blue arrow to the right, the Client Filter page opens.
Information About Maps

Figure 5-8 Client Filter Window

Client filtering options include:

- **Show All Clients**—Select the check box to display all clients on the map.
- **Small Icons**—Select the check box to display icons for each client on the map.

**Note** If you select the **Show All Clients** check box and **Small Icons** check box, all other drop-down list options are dimmed out.

If you unselect the **Small Icons** check box, you can choose if you want the label to display MAC address, IP address, username, asset name, asset group, or asset category.

If you unselect the **Show All Clients** check box, you can specify how you want the clients filtered and enter a particular SSID.

- **Display Label**—Select the client identifier (IP address, username, MAC address, asset name, asset group, or asset category) to display on the map.
- **Filter By**—Select the parameter by which you want to filter the clients (IP address, username, MAC address, asset name, asset group, asset category, or controller). Once selected, type the specific device in the text box.
- **SSID**—Enter the client SSID in the available text box.
- **Protocol**—Select All, 802.11a/n, or 802.11b/g/n from the drop-down list.
  - **All**—Displays all the access points in the area.
  - **802.11a/n**—Displays a colored overlay depicting the coverage patterns for the clients with 802.11a/n radios. The colors show the received signal strength from red (−35 dBm) through dark blue (−85 dBm).
  - **802.11b/g/n**—Displays a colored overlay depicting the coverage patterns for the clients with 802.11b/g/n radios. The colors show the received signal strength from red (−35 dBm) through dark blue (−85 dBm). This is the default value.
- **State**—Select All, Idle, Authenticated, Probing, or Associated from the drop-down list.

Click **OK** when all applicable filtering criteria are selected.
Filtering 802.11 Tag Floor Settings

If you enable the 802.11 Tags floor setting and then click the blue arrow to the right, the Tag Filter page opens.

Tag filtering options include the following:
- Show All Tags—Select the check box to display all tags on the map.
- Small Icons—Select the check box to display icons for each tag on the map.

**Note** If you select the Show All Tags check box and Small Icons check box, all other drop-down list options are dimmed out.

If you unselect the Small Icons check box, you can choose if you want the label to display MAC address, asset name, asset group, or asset category.

If you unselect the Show All Tags check box, you can specify how you want the tags filtered.
- Display Label—Select the tag identifier (MAC address, asset name, asset group, or asset category) to display on the map.
- Filter By—Select the parameter by which you want to filter the clients (MAC address, asset name, asset group, asset category, or controller). Once selected, type the specific device in the text box.

Click OK when all applicable filtering criteria are selected.

Filtering Rogue AP Floor Settings

If you enable the Rogue APs floor setting and then click the blue arrow to the right, the Rogue AP filter page opens.

Rogue AP filtering options include the following:
- Show All Rogue APs—Select the check box to display all rogue access points on the map.
- Small Icons—Select the check box to display icons for each rogue access point on the map.

**Note** If you select the Show All Rogue APs check box and Small Icons check box, all other drop-down list options are dimmed out.

If you unselect the Show All Rogue APs check box, you can specify how you want the rogue access points filtered.
- MAC Address—If you want to view a particular MAC address, enter it in the MAC Address text box.
- State—Use the drop-down list to select from Alert, Known,Acknowledged, Contained, Threat, or Unknown contained states.
- On Network—Use the drop-down list to specify whether or not you want to display rogue access points on the network.

Click OK when all applicable filtering criteria are selected.
Filtering Rogue Adhoc Floor Settings

If you enable the Rogue Adhocs floor setting and then click the blue arrow to the right, the Rogue Adhoc filter page opens.

Rogue Adhoc filtering options include the following:

- Show All Rogue Adhocs—Select the check box to display all rogue adhoc on the map.
- Small Icons—Select the check box to display icons for each rogue adhoc on the map.

**Note**

If you select the **Show All Rogue Adhocs** check box and **Small Icons** check box, all other drop-down list options are dimmed out.

If you unselect the **Show All Rogue Adhocs** check box, you can specify how you want the rogue adhocs filtered.

- MAC Address—If you want to view a particular MAC address, enter it in the MAC Address text box.
- State—Use the drop-down list to select from Alert, Known, Acknowledged, Contained, Threat, or Unknown contained states.
- On Network—Use the drop-down list to specify whether or not you want to display rogue adhocs on the network.

Click **OK** when all applicable filtering criteria are selected.

Filtering Rogue Client Floor Settings

If you enable the Rogue Clients floor setting and then click the blue arrow to the right, the Rogue Clients filter page opens.

Rogue Clients filtering options include:

- Show All Rogue Clients—Select the check box to display all rogue clients on the map.
- Small Icons—Select the check box to display icons for each rogue client on the map.

**Note**

If you select the **Show All Rogue Clients** check box and **Small Icons** check box, all other drop-down list options are grayed out.

If you unselect the **Show All Rogue Clients** check box, you can specify how you want the rogue clients filtered.

- Assoc. Rogue AP MAC Address—If you want to view a particular MAC address, enter it in the MAC Address text box.
- State—Use the drop-down list to select from Alert, Contained, Threat, or Unknown contained states.

Click **OK** when all applicable filtering criteria are selected.

Filtering Interferer Settings

If you enable Interferer floor setting and then click the blue arrow to the right, the Interferers filter window opens.

Interferer filtering options include:


- Show active interferers only—Select the check box to display all active interferers.
- Small Icons—Select the check box to display icons for each interferer on the map.
- Show Zone of Impact—Displays the approximate interference impact area. The opacity of the circle denotes its severity. A solid red circle represents a very strong interferer that will likely disrupt WiFi communications, a light pink circle represents a weak interferer.
- Show All Interferer Labels—Select the check box to display all interferer labels detected by the access point.
- Maximum number of Interferers per label—Select the maximum number of interferers to be displayed.
- Click OK when all applicable filtering criteria are selected.

**Defining Inclusion and Exclusion Regions on a Floor**

To further refine location calculations on a floor, you can define the areas that are included (inclusion areas) in the calculations and those areas that are not included (exclusion areas).

For example, you might want to exclude areas such as an atrium or stairwell within a building but include a work area (such as cubicles, labs, or manufacturing floors).

**Note**

In WCS, inclusion and exclusion regions are only calculated for clients.

**Viewing Floor Component Details**

To view details regarding the components displayed on the Floor View, hover your mouse cursor over the applicable icon. A dialog box displays detailed information. *Table 5-2* displays floor map icons.

**Table 5-2  Floor Map Icons**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
</table>
| ![Access point icon](image) | Access point icon. The color of the circle indicates the alarm status of the Cisco radios.  
**Note** Each access point contains two Cisco radios. When a single protocol is selected in the Access Point filter page, the entire icon represents this radio. If both protocols are selected, the top half of the icon represents the state of the 802.11a/n radio and the bottom half represents the state of the 802.11b/g/n radio.  
**Note** If a Cisco radio is disabled, a small “x” appears in the middle of the icon.  
**Note** Monitor mode access points are shown with gray label to distinguish from other access points. |
| ![Client icon](image) | Client icon. Hover your mouse cursor over the icon to view client details. See the “Client Details” section on page 5-117 for more information. |
| ![Tag icon](image) | Tag icon. Hover your mouse cursor over the icon to view tag details. See the “Tag Details” section on page 5-118 for more information. |
Information About Maps

Cisco 1000 Series Lightweight Access Point Icons

The icons indicate the present status of an access point. The circular part of the icon can be split in half horizontally. The darkest of the two Cisco Radio colors determines the color of the large triangular pointer.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Rogue access point icon. The color of the icon indicates the type of rogue access point. For example, red indicates a malicious rogue access point and blue indicates an unknown type. Hover your mouse cursor over the icon to view rogue access point details. See the “Rogue Access Point Details” section on page 5-118 for more information.</td>
</tr>
<tr>
<td></td>
<td>Rogue adhoc icon. Hover your mouse cursor over the icon to view rogue adhoc details. See the “Rogue Adhoc Details” section on page 5-119 for more information.</td>
</tr>
<tr>
<td></td>
<td>Rogue client icon. Hover your mouse cursor over the icon to view rogue client details. See the “Rogue Client Details” section on page 5-119 for more information.</td>
</tr>
<tr>
<td></td>
<td>Chokepoint icon. See the “Chokepoints” section on page 5-4 for more information.</td>
</tr>
<tr>
<td></td>
<td>Wi-Fi TDOA receiver icon. See the “Adding WiFi TDOA Receivers to a Map” section on page 5-61 for more information.</td>
</tr>
<tr>
<td></td>
<td>Interferer device icon. See the “Interferer Details” section on page 5-119 for more information.</td>
</tr>
</tbody>
</table>

Table 5-3 Access Points Icons Description

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Green Icon]</td>
<td>The green icon indicates an access point (AP) with no faults. The top half of the circle represents the optional 802.11a Cisco Radio. The bottom half of the circle represents the state of the 802.11b/g Cisco Radio.</td>
</tr>
<tr>
<td>![Yellow Icon]</td>
<td>The yellow icon indicates an access point with a minor fault. The top half of the circle represents the optional 802.11a Cisco Radio. The bottom half of the circle represents the state of the 802.11b/g Cisco Radio. Note A flashing yellow icon indicates that there has been an 802.11a or 802.11b/g interference, noise, coverage or load Profile Failure. A flashing yellow icon indicates that there have been 802.11a and 802.11b/g Profile Failures.</td>
</tr>
</tbody>
</table>

Note When the icon is representing 802.11a/n and 802.11b/n, the top half displays the 802.11a/n status, and the bottom half displays the 802.11b/g/n status. When the icon is representing only 802.11b/g/n, the whole icon displays the 802.11b/g/n status. The triangle gets whatever color is more stronger.

Table 5-3 shows the icons used in the Cisco WCS user interface Map displays.
Table 5-3  Access Points Icons Description (continued)

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>The red icon indicates an access point (AP) with a major or critical fault. The top half of the circle represents the optional 802.11a Cisco Radio. The bottom half of the circle represents the state of the 802.11b/g Cisco Radio.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>The grayed-out icon with a question mark in the middle represents an unreachable access point. It is gray because its status cannot be determined.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>The grayed-out icon with no question mark in the middle represents an unassociated access point.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>The icon with a red “x” in the center of the circle represents an access point that has been administratively disabled.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>The icon with the top half green and the lower half yellow indicates that the optional 802.11a Cisco Radio (top) has no faults, and the 802.11b/g Cisco Radio (bottom) has a minor fault. The worst of the two Cisco Radio colors determines the color of the large triangular pointer.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>The icon with the top half green and the lower half red indicates that the optional 802.11a Cisco Radio (top) is operational with no faults, and the 802.11b/g Cisco Radio (bottom) has a major or critical fault. The worst of the two Cisco Radio colors determines the color of the large triangular pointer.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>The icon with the top half yellow and the lower half red indicates that the optional 802.11a Cisco Radio (top) has a minor fault, and the 802.11b/g Cisco Radio (bottom) has a major or critical fault. The worst of the two Cisco Radio colors determines the color of the large triangular pointer.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>The icon with the top half yellow and the lower half green indicates that the optional 802.11a Cisco Radio (top) has a minor fault, and the 802.11b/g Cisco Radio (bottom) is operational with no faults. The worst of the two Cisco Radio colors determines the color of the large triangular pointer.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>The icon with the top half red and the lower half green indicates that the optional 802.11a Cisco Radio (top) has a major or critical fault, and the 802.11b/g Cisco Radio (bottom) is operational with no faults. The worst of the two Cisco Radio colors determines the color of the large triangular pointer.</td>
</tr>
</tbody>
</table>
Each of the access point icons includes a small black arrow that indicates the direction in which the internal Side A antenna points.

Table 5-4 shows some arrow examples used in the Cisco WCS user interface map displays.

### Table 5-4  Arrows

<table>
<thead>
<tr>
<th>Arrow Examples</th>
<th>Direction</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Zero degrees, or to the right of the map.</td>
</tr>
<tr>
<td></td>
<td>45 degrees, or to the lower right on the map.</td>
</tr>
<tr>
<td></td>
<td>90 degrees, or down on the map.</td>
</tr>
</tbody>
</table>

These examples show the first three 45-degree increments allowed, with an additional five at 45-degree increments.
Guidelines and Limitations

This section contains the guidelines and limitations for this feature:

- Guidelines for Using the Map Editor, page 5-19
- Guidelines for Placing Access Points, page 5-19
- Guidelines for Inclusion and Exclusion Areas on a Floor, page 5-21

Guidelines for Using the Map Editor

Consider the following when modifying a building or floor map using the map editor.

- We recommend that you use the map editor to draw walls and other obstacles rather than importing an .FPE file from the legacy floor plan editor.
  - If necessary, you can still import .FPE files. To do so, navigate to the desired floor area, choose Edit Floor Area from the Select a command drop-down list, click Go, select the FPE File check box, and browse to and choose the .FPE file.
- You can add any number of walls to a floor plan with the map editor; however, the processing power and memory of a client workstation may limit the refresh and rendering aspects of WCS.
  - We recommend a practical limit of 400 walls per floor for machines with 1-GB RAM or less.
- All walls are used by WCS when generating RF coverage heatmaps.
  - However, the MSEs use no more than 50 heavy walls in its calculations, and the MSE does not use light walls in its calculations because those attenuations are already accounted for during the calibration process.

If you have a high resolution image (near 12 megapixels), you may need to scale down the image resolution with an image editing software prior to using map editor.

Guidelines for Placing Access Points

Place access points along the periphery of coverage areas to keep devices close to the exterior of rooms and buildings (see Figure 5-9). Access points placed in the center of these coverage areas provide good data on devices that would otherwise appear equidistant from all other access points.
By increasing overall access point density and moving access points towards the perimeter of the coverage area, location accuracy is greatly improved (see Figure 5-10).

In long and narrow coverage areas, avoid placing access points in a straight line (see Figure 5-11). Stagger them so that each access point is more likely to provide a unique snapshot of a device location.

Although the design in Figure 5-11 may provide enough access point density for high bandwidth applications, location suffers because each access point view of a single device is not varied enough; therefore, location is difficult to determine.

Move the access points to the perimeter of the coverage area and stagger them. Each has a greater likelihood of offering a distinctly different view of the device, resulting in higher location accuracy (see Figure 5-12).
Designing a location-aware wireless LAN, while planning for voice as well, is better done with a few things in mind. Most current wireless handsets support only 802.11b/n, which offers only three non-overlapping channels. Therefore, wireless LANs designed for telephony tend to be less dense than those planned to carry data. Also, when traffic is queued in the Platinum QoS bucket (typically reserved for voice and other latency-sensitive traffic), lightweight access points postpone their scanning functions that allow them to peak at other channels and collect, among other things, device location information. The user has the option to supplement the wireless LAN deployment with access points set to monitor-only mode. Access points that perform only monitoring functions do not provide service to clients and do not create any interference. They simply scan the airwaves for device information.

Less dense wireless LAN installations, such as voice networks, find their location accuracy greatly increased by the addition and proper placement of monitor access points (see Figure 5-13).

Verify coverage using a wireless laptop, handheld, or phone to ensure that no fewer than three access points are detected by the device. To verify client and asset tag location, ensure that WCS reports client devices and tags within the specified accuracy range (10 m, 90%).

Note: If you have a ceiling-mounted AP with an integrated omni-directional antenna, the antenna orientation does not really need to be set in WCS. However, if you mount the same AP on the wall, you must set the antenna orientation to 90 degrees.

Guidelines for Inclusion and Exclusion Areas on a Floor

Inclusion and exclusion areas can be any polygon shape and must have at least three points.

You can only define one inclusion region on a floor. By default, an inclusion region is defined for each floor when it is added to WCS. The inclusion region is indicated by a solid aqua line, and generally outlines the region.

You can define multiple exclusion regions on a floor.
Newly defined inclusion and exclusion regions appear on heatmaps only after the mobility services engine recalculates location.

## Monitoring Maps

This section contains the following topics:

- Configuring Maps, page 5-22
- Configuring Buildings, page 5-29
- Configuring a Campus, page 5-36
- Configuring Outdoor Areas, page 5-39
- Configuring Floor Areas, page 5-41
- Configuring ChokePoints, page 5-57
- Configuring WiFi TDOA Receivers, page 5-61
- Managing RF Calibration Models, page 5-63
- Managing Location Presence Information, page 5-69

### Configuring Maps

This section contains the following topics:

- Viewing a Map, page 5-22
- Editing a Map, page 5-24
- Deleting a Map, page 5-25
- Copying a Map, page 5-25
- Exporting a Map, page 5-26
- Importing a Map, page 5-27
- Editing Map Properties, page 5-28

### Viewing a Map

To view a current campus map, follow these steps:

**Step 1** Choose Monitor > Maps.

**Step 2** Click the name of the campus map to open its details page (see Figure 5-14).
Figure 5-14 Building View Window

Building View: SJ-14
Monitor > Maps > Building View

<table>
<thead>
<tr>
<th>Floor</th>
<th>Map</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- **Floor Area**: 4th Floor, Total APs: 18
- **Floor Index**: 4, a/n Radios: 18
- **Contact**: Saurabh Bhaskar
- **Status**: Out of Service Radios: 0
- **Clients**: 0

3

<table>
<thead>
<tr>
<th>Floor Area</th>
<th>3rd Floor</th>
<th>Total APs</th>
</tr>
</thead>
</table>
| Floor Index: 3, a/n Radios: 19
- **Contact**: Saurabh Bhaskar
- **Status**: Out of Service Radios: 0
- **Clients**: 0

**Step 3** The Select a command drop-down list provides the following options:

- **New Floor Area**—See the “Adding Floor Areas to a Campus Building” section on page 5-42 for more information.
- **Edit Building**—See the “Editing a Map” section on page 5-24 for more information.
- **Delete Building**—See the “Deleting a Map” section on page 5-25 for more information.
- **Copy Building**—See the “Managing RF Calibration Models” section on page 5-63 for more information.
- **Edit Location Presence Information**—See the “Managing Location Presence Information” section on page 5-69 for more information.

**Note** Use the Monitor > Maps > Campus View main navigation bar at the top of the campus image to enlarge or decrease the size of the map view and to hide or show the map grid (which displays the map size in feet or meters).

---

**Configuring Edit View**

The Edit View page enables you to choose which columns appear in the maps list page.

**Note** Name and Type are fixed columns. They cannot be moved or hidden.

Column names appear in one of the following lists:

- **Hide Information**—Lists columns that do not appear in the table. The Hide button points to this list.
- **View Information**—Lists columns that do appear in the table. The Show button points to this list.
To display a column in a table, click it in the Hide Information list, then click Show. To remove a column from a table, click it in the View Information list, then click Hide. You can select more than one column by pressing the Shift or Control key.

To change the position of a column in the View Information list, click it, then click Up or Down. The higher a column is in the list, the farther left it appears in the table.

**Edit View Command Buttons**

The following command buttons appear in the Edit View page:

- **Reset**—Sets the table to the default display.
- **Show**—Moves the highlighted columns from the Hide Information list to the View Information list.
- **Hide**—Moves the highlighted columns from the View Information list to the Hide Information list.
- **Up**—Moves the highlighted columns upward in the list (further to the left in the table).
- **Down**—Moves the highlighted columns downward in the list (further to the right in the table).
- **Submit**—Saves the changes to the table columns and return to the previous page.
- **Cancel**—Reverts the changes to the table columns and return to the previous page.

**Editing a Map**

To edit a current campus map, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Choose <strong>Monitor &gt; Maps</strong>.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Click the name of the campus map to open its details page.</td>
</tr>
<tr>
<td>Step 3</td>
<td>From the Select a command drop-down list, choose <strong>Edit Campus</strong>.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Make any necessary changes to the Campus Name, Contact, Number of Floors, Number of Basements, and Dimensions (feet).</td>
</tr>
</tbody>
</table>

**Note**

To change the unit of measurement (feet or meters), choose **Monitor > Maps** and choose Properties from the Select a command drop-down list.

| Step 5 | Click **Next**. |
| Step 6 | Make any additional changes to Maintain Aspect Ratio or Dimensions (feet). |
| Step 7 | Click **OK**. |

**Note**

System Campus is part of all partitions. Also, you can not edit or delete a system campus.

**Note**

When you search a building in WCS, the search results does not show the buildings within a campus which are partitioned. The search result shows a permission denied page, if any one of the floors in the building is not assigned to you.
Deleting a Map

To delete a map, follow these steps:

**Step 1** In the Monitor > Maps window, Select the check box(es) for the map(s) that you want to delete.

**Step 2** Click **Delete** at the bottom of the map list or choose **Delete Maps** from the Select a command drop-down list, and click **Go**.

**Step 3** Click **OK** to confirm the deletion.

---

**Note** Deleting a campus or building also deletes all of its container maps. The access points from all deleted maps are moved to an Unassigned state. System Campus can not be deleted, however buildings or floors in system campus can be modified.

---

Copying a Map

The following guidelines apply to the copying process:

- Only the child elements are copied to the new map.
- The selected map is copied to the current applicable partition.
- Overlapping areas are not checked when buildings are copied. You should edit these after copying the map for proper positioning.
- If the selected map is above ground, the first available floor above ground is used for the copy.
- If the selected map is a basement, the first available basement is used for the copy.
- The following are **not** copied:
  - Access points and their positioning coordinates.
  - Planning mode data.

---

**Note** You can not copy a System Campus.
To copy a map, follow these steps:

**Step 1** From the **Monitor > Maps** window, select the check box of the map that you want to copy.

**Step 2** From the Select a command drop-down list, choose **Copy Maps**. The Copy Maps window opens (see Figure 5-15).

**Figure 5-15 Copy Maps Window**

**Step 3** Enter the name of the new map to which you want to copy the current map.

**Note** If a map with the new name already exists, the copying process stops.

**Step 4** Select the Copy Option (Map Only or Map and Map Details).

**Note** Map and Map Details includes coverage areas, perimeters, obstacles, location regions, markers, and rails.

**Step 5** Click **Copy** to complete the copying process or **Cancel** to close the window without copying the current map.

**Exporting a Map**

The Export Map feature allows you to export map or calibration information to XML. The exported XML will be in an encrypted format and will not be readable. XML and images are bundled, tarred, and zipped into a file for a successful import into another WCS.
To export a map, follow these steps:

**Step 1**  
From the monitor > Maps window, select the check box of the map that you want to export.

**Step 2**  
From the Select a command drop-down list, choose Export Maps. The Export Map window appears. (see Figure 5-16)

**Figure 5-16  Export Map Window**

![Export Map Window](image)

**Step 3**  
Select the maps that you want to export.

**Step 4**  
Click Export to export the selected map data.

**Importing a Map**

The Import Map feature allows you to import map information from external sources such as XML, WLSE, and CSV. During import, the XML may be encrypted (if exported from WCS) or unencrypted.

To import a map, follow these steps:

**Step 1**  
Choose Monitor > Maps.

**Step 2**  
From the Select a command drop-down list, choose Import Maps. The Import Map window appears.
Figure 5-17  Import Map Window

Step 3  Choose the map format.

Step 4  Select one of the following formats:
   - XML
   - AP/WiFi TDOA Receiver/Chokepoint Placement
   - WLSE Map and AP Location Data

Note  The XML format option is available only to the root user.

Step 5  Click Next.

Step 6  Click Browse to select the file that you want to import.

Step 7  Click Import to import the selected data.

Editing Map Properties

To edit your map properties, follow these steps:

Step 1  Choose Monitor > Maps.

Step 2  From the Select a command drop-down list, choose Properties.

Step 3  Click Go.

Step 4  Edit the information in Table 5-5.
Table 5-5 Map Properties Parameters

<table>
<thead>
<tr>
<th>Parameter or Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unit of Dimension</td>
<td>Set dimension measurement in feet or meters for all Cisco WCS maps.</td>
</tr>
<tr>
<td>Wall Usage Calibration</td>
<td>Choose to use or not use walls, or set to automatic.</td>
</tr>
<tr>
<td>Refresh Map From Network</td>
<td>Enable refresh of map data for Cisco WCS to update maps by polling the Cisco WLAN Solution each time an Cisco WLAN Solution operator requests a map update. Select disable for Cisco WCS to update maps from its stored database.</td>
</tr>
</tbody>
</table>

**Note** Updates to the database may not be frequent enough to keep the map data current.

<table>
<thead>
<tr>
<th>Parameter or Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Advanced Debug Mode</td>
<td>This option must be enabled on both the location appliance and WCS to allow use of the location accuracy testpoint feature.</td>
</tr>
</tbody>
</table>

Filtering Maps

At the **Monitor > Maps level**, the list of maps can be filtered based on type and status. To filter your map list, follow these steps:

**Step 1** Choose **Monitor > Maps**.

**Step 2** Select the map type from the Type drop-down list. Map types include All, Campus, Building, Outdoor Area, and Floor Area.

**Step 3** To further sort the map list by status, select the status type from the Status drop-down list. Status types include All, Critical, Major, Minor.

**Note** Status indicates the most serious level of alarm on an access point located on this map or one of its children.

**Step 4** When the filtering criteria is selected, click **Go**. The list displays maps which fit the filtering criteria.

Configuring Buildings

You can add buildings to the WCS database regardless of whether you have added campus maps to the database. This section explains how to add a building to a campus map or a standalone building (one that is not part of a campus) to the Cisco WCS database.

This section contains the following topics:
Adding a Building to a Campus Map

To add a building to a campus map in the WCS database, follow these steps:

**Step 1** Choose Monitor > Maps to display the Maps page.

**Step 2** Click the desired campus. WCS displays the Maps > Campus Name page.

**Step 3** From the Select a command drop-down list, choose New Building, and click Go (see Figure 5-18).

**Step 4** On the Campus Name > New Building page, follow these steps to create a virtual building in which to organize related floor plan maps:

- Enter the building name.
- Enter the building contact name.
- Enter the number of floors and basements.
- Enter the horizontal position (distance from the corner of the building rectangle to the left edge of the campus map) and the vertical position (distance from the corner of the building rectangle to the top edge of the campus map) in feet.
To change the unit of measurement (feet or meters), select Monitor > Maps and choose Properties from the Select a command drop-down list.

Note

- Enter an approximate building horizontal span and vertical span (width and depth on the map) in feet.

Note

- The horizontal and vertical span should be larger than or the same size as any floors that you might add later.

Tip

- You can also use Ctrl-click to resize the bounding area in the upper left corner of the campus map. As you change the size of the bounding area, the Horizontal Span and Vertical Span parameters of the building change to match your actions.

f. Click Place to put the building on the campus map. WCS creates a building rectangle scaled to the size of the campus map.

g. Click the building rectangle and drag it to the desired position on the campus map.

Note

- After adding a new building, you can move it from one campus to another without having to recreate it.

h. Click Save to save this building and its campus location to the database. WCS saves the building name in the building rectangle on the campus map.

Note

- A hyperlink associated with the building takes you to the corresponding Map page.

Step 5

(Optional) To assign location presence information for the new outdoor area, do the following:

a. Choose Edit Location Presence Info from the Select a command drop-down list. Click Go. The Location Presence window appears (see Figure 5-19).

Note

- By default, the Override Child Element’s Presence Info check box is selected. This option should remain selected if you want to propagate the campus location to all buildings and floors on that campus. When adding buildings to the campus map, you can import the campus location information. The campus address cannot be imported to a building if the check box is deselected. This option should be deselected if you want to assign building-specific addresses to buildings on its campus rather than one campus address to all.
b. Click either the Civic, GPS markers, or Advanced tab.

- Civic Address identifies the campus by name, street, house number, house number suffix, city (address line2), state, postal code, and country.

- GPS Markers identify the campus by longitude and latitude.

- Advanced identifies the campus with expanded civic information such as neighborhood, city division, country, and postal community name.

Note Each selected parameter is inclusive of all of those above it. For example, if you choose Advanced, it can also provide GPS and Civic location information upon client demand. The selected setting must match what is set on the location server level (Services > Mobility Services).

Note If a client requests location information such as GPS Markers for a campus, building, floor, or outdoor area that is not configured for that parameter, an error message is returned.

c. By default, the Override Child Element’s Presence Info check box is selected. There is no need to alter this setting for standalone buildings.

Step 6 Click Save.
Adding a Standalone Building

To add a standalone building to the WCS database, follow these steps:

**Step 1**  
Choose **Monitor > Maps** to display the Maps page.

**Step 2**  
From the Select a command drop-down list, choose **New Building**, and click **Go** (see Figure 5-18).

**Step 3**  
On the Maps > New Building page, follow these steps to create a virtual building in which to organize related floor plan maps:

a. Enter the building name.

b. Enter the building contact name.

Note: After adding a new building, you can move it from one campus to another without having to recreate it.

c. Enter the number of floors and basements.

d. Enter an approximate building horizontal span and vertical span (width and depth on the map) in feet.

Note: To change the unit of measurement (feet or meters), select **Monitor > Maps** and choose **Properties** from the Select a command drop-down list.

Note: The horizontal and vertical span should be larger than or the same size as any floors that you might add later.

e. Click **OK** to save this building to the database.
Monitoring Maps

Step 4  (Optional) To assign location presence information for the new building, do the following:

a. Choose **Location Presence** from the Select a command drop-down list. Click **Go**. The Location Presence window appears (see Figure 5-19).

b. Click either the Civic, GPS markers, or Advanced tab.
   - Civic Address identifies the campus by name, street, house number, house number suffix, city (address line2), state, postal code, and country.
   - GPS Markers identify the campus by longitude and latitude.
   - Advanced identifies the campus with expanded civic information such as neighborhood, city division, county, and postal community name.

   **Note** Each selected parameter is inclusive of all of those above it. For example, if you select Advanced, it can also provide GPS and Civic location information upon client demand. The selected setting must match what is set on the location server level (Services > Mobility Services).

   **Note** If a client requests location information such as GPS Markers for a campus, building, floor, or outdoor area that is not configured for that parameter, an error message is returned.

c. By default, the Override Child Element’s Presence Info check box is selected. This option should remain selected if you want to propagate the campus location to all buildings and floors on that campus. When adding buildings to the campus map, you can import the location information. The campus address cannot be imported to a building if the check box is deselected. This option should be deselected if you want to assign building-specific addresses to buildings on its campus rather than one campus address to all.

Step 5  Click **Save**.

**Note** The standalone buildings are automatically placed in System Campus.

Viewing a Building

To view a current building map, follow these steps:

Step 1  Choose **Monitor > Maps**.

Step 2  Click the name of the building map to open its details page. The Building View page provides a list of floor maps and map details for each floor.

**Note** From the Building View page, you can click the Floor column heading to sort the list ascending or descending by floor.

The map details include:

- Floor area
• Floor index—Indicates the floor level. A negative number indicates a basement floor level.
• Contact.
• Status—Indicates the most serious level of alarm on an access point located on this map or one of its children.
• Number of total access points located on the map.
• Number of 802.11a/n and 802.11b/g/n radios located on the map.
• Number of out of service (OOS) radios.
• Number of clients—Click the number link to view the Monitor > Clients page. See the “Monitoring Clients” section on page 10-8 for more information.

Step 3 The Select a command drop-down list provides the following options:
• New Floor Area—See the “Adding Floor Areas to a Campus Building” section on page 5-42 or the “Adding Floor Plans to a Standalone Building” section on page 5-46 for more information.
• Edit Building—See the “Editing a Building” section on page 5-35 for more information.
• Delete Building—See the “Deleting a Building” section on page 5-35 for more information.
• Copy Building—See the “Copying a Map” section on page 5-25 for more information.
• Edit Location Presence Info—See the “Managing Location Presence Information” section on page 5-69 for more information.

Editing a Building

To edit a current building map, follow these steps:

Step 1 Choose Monitor > Maps.
Step 2 Click the name of the building map to open its details page.
Step 3 From the Select a command drop-down list, choose Edit Building.
Step 4 Make any necessary changes to Building Name, Contact, Number of Floors, Number of Basements, and Dimensions (feet).

Note To change the unit of measurement (feet or meters), choose Monitor > Maps and select Properties from the Select a command drop-down list.

Step 5 Click OK.

Deleting a Building

To delete a current building map, follow these steps:

Step 1 Choose Monitor > Maps.
Step 2 Select the check box for the building that you want to delete.
Step 3  Click **Delete** at the bottom of the map list (or choose **Delete Maps** from the Select a command drop-down list, and click **Go**).

Step 4  Click **OK** to confirm the deletion.

**Note**  Deleting a building also deletes all of its container maps. The access points from all deleted maps are moved to an Unassigned state.

### Moving a Building

To move a building to a different campus, follow these steps:

1. Choose **Monitor > Maps**.
2. Select the check box of the applicable building.
3. From the Select a command drop-down list, choose **Move Buildings**.
4. Click **Go**.
5. Select the Target Campus from the drop-down list.
6. Select the buildings that you want to move. Unselect any buildings that will remain in their current location.
7. Click **OK**.

### Configuring a Campus

This section contains the following topics:

- Adding a Campus Map, page 5-36
- Viewing a Campus Map, page 5-37
- Editing a Campus Map, page 5-38
- Deleting a Campus Map, page 5-38

### Adding a Campus Map

To add a single campus map to the WCS database, follow these steps:

1. Save the map in .PNG, .JPG, .JPEG, or .GIF format.
   **Note**  The map can be of any size because WCS automatically resizes the map to fit its working areas.
2. Browse to and import the map from anywhere in your file system.
3. Choose **Monitor > Maps** to display the Maps page (see Figure 5-21).
Step 4 From the Select a command drop-down list, choose New Campus, and click Go.

Step 5 On the Maps > New Campus page, enter the campus name and campus contact name.

Step 6 Browse to and choose the image filename containing the map of the campus, and click Open.

Step 7 Select the Maintain Aspect Ratio check box to prevent length and width distortion when WCS resizes the map.

Step 8 Enter the horizontal and vertical span of the map in feet.

Note To change the unit of measurement (feet or meters), select Monitor > Maps and choose Properties from the Select a command drop-down list. The horizontal and vertical span should be larger than any building or floor plan to be added to the campus.

Step 9 Click OK to add this campus map to the WCS database. WCS displays the Maps page, which lists maps in the database, map types, and campus status.

Step 10 (Optional) To assign location presence information, click the newly created campus link at the Monitor > Maps window. See the “Managing Location Presence Information” section on page 5-69 for more information.

Viewing a Campus Map

To view a current campus map, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Click the name of the campus map to open its details page.

Step 3 The Select a command drop-down list provides the following options:

- New Building—See the “Adding a Building to a Campus Map” section on page 5-30 for more information.
- New Outdoor Area—See the “Adding an Outdoor Area” section on page 5-39 for more information.
- Edit Campus—See the “Editing a Campus Map” section on page 5-38 for more information.
- Delete Campus—See the “Deleting a Campus Map” section on page 5-38 for more information.
Monitoring Maps

- Copy Campus—See the “Copying a Map” section on page 5-25 for more information.
- Edit Location Presence Information—See the “Managing Location Presence Information” section on page 5-69 for more information.

Note  Use the Monitor > Maps > Campus View main navigation bar at the top of the campus image to enlarge or decrease the size of the map view and to hide or show the map grid (which displays the map size in feet or meters).

Editing a Campus Map

The edit feature allows you to make changes to a current campus map. You can change the campus name, contact person, image, and map dimensions.

To edit a current campus map, follow these steps:

Step 1  Choose Monitor > Maps.
Step 2  Click the name of the campus map to open its details page.
Step 3  From the Select a command drop-down list, choose Edit Campus.
Step 4  Make any necessary changes to Campus Name, Contact, or Image File.
Step 5  Click Next.
Step 6  Make any additional changes to Maintain Aspect Ratio or Dimensions (feet).

Note  To change the unit of measurement (feet or meters), choose Monitor > Maps and choose Properties from the Select a command drop-down list.

Step 7  Click OK.

Deleting a Campus Map

To delete a current campus map, follow these steps:

Step 1  Choose Monitor > Maps.
Step 2  Select the check box for the campus that you want to delete.
Step 3  Click Delete at the bottom of the map list or choose Delete Maps from the Select a command drop-down list, and click Go.
Step 4  Click OK to confirm the deletion.
Configuring Outdoor Areas

This section contains the following topics:

- Adding an Outdoor Area, page 5-39
- Editing Outdoor Areas, page 5-40
- Deleting Outdoor Areas, page 5-41

Adding an Outdoor Area

Note You can add an outdoor area to a campus map in the WCS database regardless of whether you have added outdoor area maps to the database.

To add an outdoor area to a campus map, follow these steps:

Step 1 If you want to add a map of the outdoor area to the database, save the map in .PNG, .JPG, .JPEG, or .GIF format. Then browse to and import the map from anywhere in your file system.

Note You do not need a map to add an outdoor area. You can simply define the dimensions of the area to add it to the database. The map can be any size because WCS automatically resizes the map to fit the workspace.

Step 2 Choose Monitor > Maps.

Step 3 Click the desired campus to display the Monitor > Maps > Campus View page.

Step 4 From the Select a command drop-down list, choose New Outdoor Area.

Step 5 Click Go. The Create New Area page opens.

Step 6 On the New Outdoor Area page, enter the following information:

- Name—The user-defined name of the new outdoor area.
- Contact—The user-defined contact name.
- Area Type (RF Model)—Cubes And Walled Offices, Drywall Office Only, Outdoor Open Space (default).
- AP Height (feet)—Enter the height of the access point.
- Image File—Name of the file containing the outdoor area map. Use the browse button to find the file.

Step 7 Click Next.

Step 8 Enter the following information:
• Zoom—Use to zoom in or zoom out on the map that you are currently viewing.
• Maintain Image Aspect Ratio—Select this check box to maintain the aspect ratio (ratio of horizontal and vertical pixels) of the map image. Maintaining the aspect ratio prevents visual distortion of the map.
• Horizontal Position—Distance from the corner of the outdoor area rectangle to the left edge of the campus map, in feet or meters.
• Vertical Position—Distance from the corner of the outdoor area rectangle to the top edge of the campus map, in feet or meters.
• Horizontal Span—Horizontal measurement (left to right) of the outdoor area rectangle, in feet or meters.
• Vertical Span—Vertical measurement (up and down) of the outdoor area rectangle, in feet or meters.

**Tip**
The horizontal and vertical spans should be larger than or the same size as any floors that may be added later. Use Ctrl-click to resize the bounding area in the upper-left corner of the campus map. The horizontal and vertical span parameters change to match.

**Note**
To change the unit of measurement (feet or meters), choose Monitor > Maps and choose Properties from the Select a command drop-down list.

**Step 9** Click Place to put the outdoor area on the campus map. WCS creates an outdoor area rectangle scaled to the size of the campus map.

**Step 10** Click and drag the outdoor area rectangle to the desired position on the campus map.

**Step 11** Click Save to save this outdoor area and its campus location to the database.

**Note** A hyperlink associated with the outdoor area takes you to the corresponding Map page.

**Step 12** (Optional) To assign location presence information for the new outdoor area, select Edit Location Presence Info, and click Go. See the “Managing Location Presence Information” section on page 5-69 for more information.

**Note** By default, the Override Child Element Presence Info check box is selected. There is no need to alter this setting for outdoor areas.

**Editing Outdoor Areas**

To edit a current outdoor area, follow these steps:

**Step 1** Choose Monitor > Maps.

**Step 2** Click the desired outdoor area map from the Name column.

**Step 3** From the Select a command drop-down list, choose Edit Outdoor Area.

**Step 4** Click Go.
Chapter 5      Monitoring Maps

Step 5 On the Campus Name > Outdoor Area page, edit the following information:
- Name—The user-defined name of the new outdoor area.
- Contact—The user-defined contact name.
- New Image File—Use the Browse button to import a new image file, if necessary.
- Maintain Image Aspect Ratio—Select this check box to maintain the aspect ratio (ratio of horizontal and vertical pixels) of the map image. Maintaining the aspect ratio prevents visual distortion of the map.
- Horizontal Position—Distance from the corner of the outdoor area rectangle to the left edge of the campus map, in ft. or meters.
- Vertical Position—Distance from the corner of the outdoor area rectangle to the top edge of the campus map, in ft. or meters.
- Horizontal Span—Horizontal measurement (left to right) of the outdoor area rectangle, in ft. or meters.
- Vertical Span—Vertical measurement (up and down) of the outdoor area rectangle, in ft. or meters.

Step 6 Click Place to put the outdoor area on the campus map. WCS creates an outdoor area rectangle scaled to the size of the campus map.

Step 7 Click and drag the outdoor area rectangle to the desired position on the campus map.

Step 8 Click Save to save this outdoor area and its campus location to the database.

Note A hyperlink associated with the outdoor area takes you to the corresponding Map page.

Deleting Outdoor Areas

To delete a current outdoor area, follow these steps:

Step 1 Choose Monitor > Maps.
Step 2 Select the check box for the outdoor area that you want to delete.
Step 3 Click Delete at the bottom of the map list (or choose Delete Maps from the Select a command drop-down list, and click Go).
Step 4 Click OK to confirm the deletion.

Configuring Floor Areas

This section explains on how to add floor plans to either a campus building or a standalone building in the WCS database and contains the following topics:
- Adding Floor Areas to a Campus Building, page 5-42
- Adding Access Points to a Floor Area, page 5-48
- Editing Floor Areas, page 5-53
Adding Floor Areas to a Campus Building

After you add a building to a campus map, you can add individual floor plan and basement maps to the building.

To add a floor area to a campus building, follow these steps:

**Step 1**  
Save your floor plan maps in .PNG, .JPG, or .GIF format.

*Note*  
The maps can be any size because WCS automatically resizes the maps to fit the workspace.

**Step 2**  
Browse to and import the floor plan maps from anywhere in your file system. You can also import CAD image files DXF and DWG.

*Note*  
If there are problems converting the auto-cad file, an error message is displayed. WCS uses a native image conversion library to convert auto-cad files into raster formats like PNG. If the native library cannot be loaded, WCS returns the “unable to convert the auto-cad file” message. If you receive this error, make sure all the required dependencies are met for the native library. To find any dependency problems, use Dependency Walker on Windows platforms or ldd on Linux platforms. The following dlls must be present under the /webnms/rfdlls WCS installation directory: LIBGFL254.DLL, MFC71.DLL, MSVCR71.DLL, and MSVCP71.DLL. If dependency problems occurred, you may need to install the required libraries and restart WCS.

*Note*  
An imported auto-cad file can become blurred when you zoom. Without the zoom, the clarity is about the same as the original auto-cad file. Make sure all relevant sections are clearly visible in the original auto-cad file (DWG/DXF) and then import the auto-cad file into PNG/GIF format rather than JPEG or JPG.

**Step 3**  
Choose Monitor > Maps. The Maps page opens. (See Figure 5-22)
Figure 5-22  Monitor > Maps Window

Step 4 From the Maps Tree View or the Monitor > Maps list, click the applicable campus building to open the Building View page.

Step 5 Hover your cursor over the name within an existing building rectangle to highlight it.

Note You can also access the building from the Campus View page. From the Campus View page, click the building name to open the Building View page.

Step 6 From the Select a command drop-down list, choose New Floor Area.

Step 7 Click Go. The New Floor Area page opens. (See Figure 5-23)

Figure 5-23 New Floor Area Window

New Floor Area
Monitor > Maps > Campus 1 > campus buildings > New Floor Area

Floor Area Name
Contact
Floor
Floor Type (RF Model) Cubes And Walled Offices
Floor Height (Feet) 100

Image or CAD File

Step 8 On the New Floor Area page, follow these steps to add floors to a building in which to organize related floor plan maps:

a. Enter the floor area and contact names.

b. Select the floor or basement number from the Floor drop-down list.

b. Choose the floor or basement type (RF Model).

d. Enter the floor-to-floor height in feet.
Note: To change the unit of measurement (feet or meters), select Monitor > Maps and choose Properties from the Select a command drop-down list.

e. Select the Image or CAD File check box.

f. Browse to and choose the desired floor or basement image or CAD filename, and click Open.

Note: If you are importing a CAD file, use the Convert CAD File drop-down list to determine the image file for conversion.

Tip: A JPEG (JPG) format is not recommended for an auto-cad conversion. Unless a JPEG is specifically required, use a PNG or GIF format for higher quality images.

g. Click Next. At this point, if a CAD file was specified, a default image preview is generated and loaded.

Note: WCS uses a native image conversion library to convert auto-cad files into raster formats like .PNG. When there are issues loading the native library, WCS throws the following error: "Unable to convert the auto-cad file. Reason: Error while loading the auto-cad image conversion library. Please refer online or WCS documentation for more information."

If this error displays, make sure all the required dependencies are met for the native library. On the Windows platform, you can use tools such as "Dependency Walker" to find out any dependency issues.

Also, please make sure that the following dlls are present under \webnms\rfdlls directory under your WCS installation directory:

\webnms\rfdlls\LIBGFL254.DLL
\webnms\rfdlls\MFC71.DLL
\webnms\rfdlls\MSVCR71.DLL
\webnms\rfdlls\MSVCP71.DLL

On the Linux platform, you can use tools such as "ldd" to find out any dependency issues.

If there are any dependency issues, fix them by installing the required libraries for missing dependencies and then restart WCS.

The names of the CAD file layers are listed, with check boxes to the right side of the image indicating which are enabled.

Note: When you choose the floor or basement image filename, WCS displays the image in the building-sized grid.
Chapter 5  Monitoring Maps

Note  The maps can be any size because WCS automatically resizes the maps to fit the workspace.

Note  The map must be saved in .PNG, .JPG, .JPEG, or .GIF format.

h. If you have CAD file layers, you can select or deselect as many as you want and click Preview to view an updated image. Click Next when you are ready to proceed with the selected layers.

Enter the remaining parameters for the floor area.

Figure 5-24  Floor Area Parameters

- New Floor Area
  - Floor Area Name
  - Contact
  - Floor
  - Floor Type (RF Model)
  - Floor Height (feet)
  - Image File

- Dimensions (feet)
  - Horizontal Span
  - Vertical Span

- Coordinates of top left corner (feet)
  - Horizontal Position
  - Vertical Position

- Total Floor Area Size (sq. feet): 4633.3

- Use mouse to position the floor image by dragging it. And use CTRL key with mouse to resize the floor.

i. Either leave the Maintain Aspect Ratio check box selected to preserve the original image aspect ratio or unselect the check box to change the image aspect ratio.

j. Enter an approximate floor or basement horizontal and vertical span (width and depth on the map) in feet.

Note  The horizontal and vertical spans should be smaller than or the same size as the building horizontal and vertical spans in the WCS database.
k. If applicable, enter the horizontal position (distance from the corner of the outdoor area rectangle to the left edge of the campus map) and vertical position (distance from the corner of the outdoor area rectangle to the top edge of the campus map) in feet or meters.

Tip User Ctrl-click to resize the image within the building-sized grid.

l. If desired, select the Launch Map Editor after floor creation check box to rescale the floor and draw walls.

m. Click OK to save this floor plan to the database. The floor is added to the Maps Tree View and the Monitor > Maps list.

Step 9 Click any of the floor or basement images to view the floor plan or basement map.

Note You can zoom in or out to view the map at different sizes and you can add access points. See the “Adding Access Points to a Floor Area” section on page 5-48 for more information.

Adding Floor Plans to a Standalone Building

After you have added a standalone building to the WCS database, you can add individual floor plan maps to the building.

To add floor plans to a standalone building, follow these steps:

Step 1 Save your floor plan maps in .PNG, .JPG, or .GIF format.

Note The maps can be any size because WCS automatically resizes the maps to fit the workspace.

Step 2 Browse to and import the floor plan maps from anywhere in your file system. You can import CAD files in DXF or DWG formats or any of the formats you created in Step 1.

Note If there are problems converting the auto-cad file, an error message is displayed. WCS uses a native image conversion library to convert auto-cad files into raster formats like PNG. If the native library cannot be loaded, WCS returns the “unable to convert the auto-cad file” message. If you receive this error, make sure all the required dependencies are met for the native library. To find any dependency problems, use Dependency Walker on Windows platforms or ldd on Linux platforms. The following dlls must be present under the /webnms/rfdlls WCS installation directory: LIBGFL254.DLL, MFC71.DLL, MSVCR71.DLL, and MSVCP71.DLL. If dependency problems occurred, you may need to install the required libraries and restart WCS.

Note An imported auto-cad file can become blurred when you zoom. Without the zoom, the clarity is about the same as the original auto-cad file. Make sure all relevant sections are clearly visible in the original auto-cad file (DWG/DXF) and then import the auto-cad file into PNG/GIF format rather than JPEG or JPG.

Step 3 Choose Monitor > Maps.
Step 4  From the Maps Tree View or the Monitor > Maps list, click the desired building to display the Building View page.

Step 5  From the Select a command drop-down list, choose New Floor Area.

Step 6  Click Go.

Step 7  On the New Floor Area page, add the following information:

- Enter the floor area and contact names.
- Select the floor or basement number from the Floor drop-down list.
- Choose the floor or basement type (RF Model).
- Enter the floor-to-floor height in feet.
- Select the Image or CAD File check box.
- Browse to and choose the desired floor or basement Image or CAD file, and click Open.

Note  If you are importing a CAD file, use the Convert CAD File drop-down list to determine the image file for conversion.

Tip  A JPEG (JPG) format is not recommended for an auto-cad conversion. Unless a JPEG is specifically required, use a PNG or GIF format for higher quality images.

Step 8  Click Next. At this point, if a CAD file was specified, a default image preview is generated and loaded.

Note  WCS uses a native image conversion library to convert auto-cad files into raster formats like .PNG. When there are issues loading the native library, WCS throws the following error: "Unable to convert the auto-cad file. Reason: Error while loading the auto-cad image conversion library. Please refer online or WCS documentation for more information."

If this error displays, make sure all the required dependencies are met for the native library.

On Windows platform, you can use tools such as "Dependency Walker" to find out any dependency issues.

Also, please make sure that the following dlls are present under \webnms\rfdlls directory under your WCS installation directory:

\webnms\rfdlls\LIBGFL254.DLL
\webnms\rfdlls\MFC71.DLL
\webnms\rfdlls\MSVCR71.DLL
\webnms\rfdlls\MSVCP71.DLL

On Linux platform, you can use tools such as "ldd" to find out any dependency issues.

If there are any dependency issues, fix them by installing the required libraries for missing dependencies and then restart WCS.

The names of the CAD file layers are listed, with check boxes to the right side of the image indicating which are enabled.
Chapter 5  Monitoring Maps

Monitoring Maps

Note

When you choose the floor or basement image filename, WCS displays the image in the building-sized grid.

Note

The maps can be any size because WCS automatically resizes the maps to fit the workspace.

Note

The map must be saved in .PNG, .JPG, .JPEG, or .GIF format.

If you have CAD file layers, you can select or deselect as many as you want and click Preview to view an updated image. Click Next when you are ready to proceed with the selected layers.

Step 9

Enter the remaining parameters for the floor area.

- Either leave the Maintain Aspect Ratio check box selected to preserve the original image aspect ratio or unselect the check box to change the image aspect ratio.

- Enter an approximate floor or basement horizontal and vertical span (width and depth on the map) in feet.

  Note

  The horizontal and vertical spans should be smaller than or the same size as the building horizontal and vertical spans in the WCS database.

- If applicable, enter the horizontal position (distance from the corner of the outdoor area rectangle to the left edge of the campus map) and vertical position (distance from the corner of the outdoor area rectangle to the top edge of the campus map) in feet or meters.

  Tip

  User Ctrl-click to resize the image within the building-sized grid.

- Adjust the floor characteristics with the WCS map editor by selecting the check box next to Launch Map Editor. See the “Map Editor” section on page 5-4 for more information regarding the map editor feature.

Step 10

Click OK to save this floor plan to the database. The floor is added to the Maps Tree View and the Monitor > Maps list.

Step 11

Click any of the floor or basement images to view the floor plan or basement map.

Note

You can zoom in or out to view the map at different sizes and you can add access points. See the “Adding Access Points to a Floor Area” section on page 5-48 for more information.

Adding Access Points to a Floor Area

After you add the .PNG, .JPG, .JPEG, or .GIF format floor plan and outdoor area maps to the WCS database, you can position lightweight access point icons on the maps to show where they are installed in the buildings. To add access points to a floor area and outdoor area, follow these steps:
Step 1  Choose Monitor > Maps. The Maps page opens. (See Figure 5-25)

**Figure 5-25  Monitor Maps Window**

Step 2  From the Maps Tree View or the Monitor > Maps list, click the applicable floor to open the Floor View page.

**Figure 5-26  Floor View Window**

Step 3  From the Select a command drop-down list, choose Add Access Points, and click Go.
Step 4  From the Add Access Points page, select the check boxes of the access points that you want to add to the floor area.
Figure 5-27    Add Access Point Window

Add Access Points
Monitor > Maps > Campus1 > Campus2 > Floor 01 > Add Access Points

Add checked access points to Floor 01
Total AP Count: 9

<table>
<thead>
<tr>
<th>AP Name</th>
<th>MAC Address</th>
<th>AP Model</th>
<th>Controller</th>
</tr>
</thead>
<tbody>
<tr>
<td>sjc54-22b-ap1</td>
<td>00:17:df:65:4b:60</td>
<td>AIR-LAP1552AG-AK9</td>
<td>209.168.200.225</td>
</tr>
<tr>
<td>sjc54-22d-ap4</td>
<td>00:17:df:65:26:60</td>
<td>AIR-LAP1552AG-AK9</td>
<td>209.165.200.225</td>
</tr>
<tr>
<td>sjc54-15b-ap1</td>
<td>00:17:df:65:16:80</td>
<td>AIR-LAP1552AG-AK9</td>
<td>209.165.200.225</td>
</tr>
<tr>
<td>sjc54-22b-ap2</td>
<td>00:17:df:65:1c:80</td>
<td>AIR-LAP1552AG-AK9</td>
<td>209.165.200.225</td>
</tr>
<tr>
<td>sjc54-22b-ap3</td>
<td>00:17:df:65:1a:80</td>
<td>AIR-LAP1552AG-AK9</td>
<td>209.165.200.225</td>
</tr>
</tbody>
</table>

Note Only access points which are not yet assigned to any floor or outdoor area appear in the list.

Note Select the check box at the top of the list to select all access points.

Note WCS allows a maximum of 100 access points per floor map.

Step 5 When all of the applicable access points are selected, click OK located at the bottom of the access point list.

The Position Access Points page opens.

Figure 5-28    Position Access Points Window

Each access point you have chosen to add to the floor map is represented by a gray circle (differentiated by access point name or MAC address) and is lined up in the upper left part of the floor map.
Chapter 5  Monitoring Maps

Step 6  Click and drag each access point to the appropriate location. Access points turn blue when selected.

**Note**  When you drag an access point on the map, its horizontal and vertical position displays in the boxes above.

**Note**  The small black arrow at the side of each access point represents Side A of each access point, and each access point arrow must correspond with the direction in which the access points were installed. Side A is clearly noted on each 1000 series access point and has no relevance to the 802.11a/n radio. To adjust the directional arrow, choose the appropriate orientation in the Antenna Angle drop-down list.

When selected, the access point details display on the left side of the page. Access point details include:

- **AP Model**—Indicates the model type of the selected access point.
- **Protocol**—Select the protocol for this access point from the drop-down list.
- **Antenna**—Select the appropriate antenna type for this access point from the drop-down list.
- **Antenna/AP Image**—The antenna image reflects the antenna selected from the Antenna drop-down list. Click the arrow at the top right of the antenna image to expand the image size.
- **Antenna Orientation**—Depending on the antenna type, enter the Azimuth and the Elevation orientations in degrees.

**Note**  The Azimuth option does not appear for Omnidirectional antennas because their pattern is nondirectional in azimuth.

**Note**  For internal antennas, the same elevation angle applies to both radios.

The antenna angle is relative to the map X axis. Because the origin of the X (horizontal) and Y (vertical) axes is in the upper left corner of the map, 0 degrees points side A of the access point to the right, 90 degrees points side A down, 180 degrees points side A to the left, and so on. The antenna elevation is used to move the antenna vertically, up or down, to a maximum of 90 degrees.

**Note**  Make sure each access point is in the correct location on the map and has the correct antenna orientation. Accurate access point positioning is critical when you use the maps to find coverage holes and rogue access points.

Figure 5-29  Selected Access Point Details

802.11n Summary

Cisco Prime
Network Control System

Step 7  When you are finished placing and adjusting each access point, click Save.

Note  Clicking Save causes the antenna gain on the access point to correspond to the selected antenna. This may cause radio reset.

WCS computes the RF prediction for the coverage area. These RF predictions are popularly known as heat maps because they show the relative intensity of the RF signals on the coverage area map.

Note  This display is only an approximation of the actual RF signal intensity because it does not take into account the attenuation of various building materials, such as drywall or metal objects, nor does it display the effects of RF signals bouncing off obstructions.

Note  Antenna gain settings have no effect on heatmaps and location calculations. Antenna gain is implicitly associated to the antenna name. Because of this, the following apply:
– If an antenna is used and marked as “Other” in WCS, it is ignored for all heatmap and location calculations;
– If an antenna is used and marked as a Cisco antenna in WCS, that antenna gain setting (internal value on WCS) is used no matter what gain is set on the controller.
Chapter 5  Monitoring Maps

Monitoring Maps

Figure 5-30  RF Prediction heatmaps

Note  See the “Placing Access Points” section on page 5-54 for more information on placing access points on a map.

Note  You can change the position of access points by importing or exporting a file. See the “Positioning Access Points, Wi-Fi TDOA Receivers, and Chokepoints by Importing or Exporting a File” section on page 5-56 for more information.

Editing Floor Areas

To edit a current floor area, follow these steps:

Step 1  Choose Monitor > Maps.
Step 2  Click the name of the floor area to open its details page.
Step 3  From the Select a command drop-down list, choose Edit Floor Area.
Step 4  Make any necessary changes to Floor Area Name, Contact, Floor, Floor Height (feet), Floor Type (RF Model), Existing Image File, or Import New Image File.
Step 5  Click OK.

Deleting Floor Areas

To delete a current floor area, follow these steps:
Step 1 Choose Monitor > Maps.

Step 2 Select the check box for the applicable floor area.

Step 3 From the Select a command drop-down list, choose Delete Maps.

Step 4 Click Go.

Step 5 Click OK to confirm the deletion.

Placing Access Points

To determine the best location of all devices in the wireless LAN coverage areas, you need to consider the access point density and location.

Ensure that no fewer than 3 access points, and preferably 4 or 5, provide coverage to every area where device location is required. The more access points that detect a device, the better. This high level guideline translates into the following best practices, ordered by priority:

1. Most importantly, access points should surround the desired location.
2. One access point should be placed roughly every 50 to 70 linear feet (about 17 to 20 meters). This translates into one access point every 2,500 to 5000 square feet (about 230 to 450 square meters).

Note The access point must be mounted so that it is under 20 feet high. For best performance, a mounting at 10 feet would be ideal.

Following these guidelines makes it more likely that access points will detect tracked devices. Rarely do two physical environments have the same RF characteristics. Users may need to adjust those parameters to their specific environment and requirements.

Note Devices must be detected at signals greater than –75 dBm for the controllers to forward information to the location appliance. No fewer than three access points should be able to detect any device at signals below –75 dBm.

Note If you have a ceiling-mounted AP with an integrated omni-directional antenna, the antenna orientation does not really need to be set in WCS. However, if you mount that same AP on the wall, you must set the antenna orientation to 90 degrees.

The Table 5-6 describes the orientation of the access points.

Import Map and AP Location Data

When converting from autonomous to lightweight access points and from WLSE to WCS, one of the conversion steps is to manually re-enter the access point-related information into WCS. To speed up this process, you can export the information about access points from WLSE and import it into WCS.
WCS expects a .tar file and checks for a .tar extension before importing the file. If the file you are trying to import is not a .tar file, WCS displays an error message and prompts you to import a different file.

For more information on the WLSE data export functionality (WLSE version 2.15), see http://<WLSE_IP_ADDRESS>:1741/debug/export/exportSite.jsp.

To map properties and import a tar file containing WLSE data using the WCS web interface, follow these steps:

**Step 1** Choose Monitor > Maps.
**Step 2** From the Select a command drop-down list, choose Import WLSE Map and AP Location Data.
**Step 3** Click Go. The Import WLSE Map and AP Location Data page opens.

*Figure 5-31 Import WLSE Map and AP Location Data Window*

**Step 4** In the Import Data from WLSE section, click Browse to select the file to import.
**Step 5** Find and select the .tar file to import, and click Open.
WCS displays the name of the file in the Import From text box.
**Step 6** Click Import.
WCS uploads the file and temporarily saves it into a local directory while it is being processed. If the file contains data that cannot be processed, WCS prompts you to correct the problem and retry. Once the file has been loaded, WCS displays a report of what will be added to WCS. The report also specifies what cannot be added and why.

If some of the data to be imported already exists, WCS either uses the existing data in the case of campuses or overwrites the existing data using the imported data in the cases of buildings and floors.

*Note* If there are duplicate names between a WLSE site and building combination and a WCS campus (or top-level building) and building combination, WCS displays a message in the Pre Execute Import Report indicating that it will delete the existing building.
Positioning Access Points, Wi-Fi TDOA Receivers, and Chokepoints by Importing or Exporting a File

You can change an access point, Wi-Fi TDOA receiver, or chokepoint position by importing or exporting a file. The file contains only the lines describing the component you want to move. This option takes less time than manually changing multiple positions. Refer to the Cisco Context-Aware Services Configuration Guide for more information on chokepoints and Wi-Fi TDOA receivers.

To change an access point, Wi-Fi TDOA receiver, or chokepoint position, follow these steps:

Step 1  Choose Monitor > Maps.

Step 2  From the Select a command drop-down list, choose Properties.

Step 3  At the Unit of Dimension drop-down list, choose feet or meters.

Step 4  Select the Advanced Debug Mode Enable radio button.

Step 5  Click OK.

Step 6  From the Select a command drop-down list, choose Export/Import AP/WiFi TDOA Receiver/Chokepoint Placement.

Step 7  In the Import/Export AP/WiFi TDOA Receiver/Chokepoint Placement window, click Browse to find the file you want to import.

Note  The file must already be created and added to WCS.

Note  The following is the correct file format:

[BuildingName], [FloorName], [AP/WiFi TDOA Receiver/Chokepoint Name], (aAngle), (bAngle), [X], [Y], ([aAngleElevation, bAngleElevation, Z]), ([aAntennaType, aAntennaMode, (aAntennaPattern, (aAntennaGain)), bAntennaType, bAntennaDiversity, (bAntennaPattern, bAntennaGain))])

The parameters in square brackets are mandatory, and those in parentheses are optional.

Note  Angles must be entered in radians (X,Y), and the height is entered in feet. The aAngle and bAngle range is from –2Pi (-6.28...) to 2Pi (6.28...), and the elevation ranges from –Pi (-3.14...) to Pi (3.14...).

Step 8  Click Import. The RF calculation takes approximately two seconds per component.
Changing Access Point Positions by Importing and Exporting a File

You can change an access point position by importing or exporting a file. The file contains only the lines describing the access point you want to move. This option takes less time than manually changing multiple access point positions. Follow these steps to change access point positions using the importing or exporting of a file.

**Step 1** Choose Monitor > Maps.

**Step 2** From the Select a command drop-down list, choose Import AP/WiFi TDOA Receiver/Chokepoint Placement or Export AP/WiFi TDOA Receiver/Chokepoint Placement, and click Go.

**Step 3** In Import Data from File or Export Data from File, click Browse to find the file you want to import. The file in the [BuildingName], [FloorName], [APName], (aAngle), (bAngle), [X], [Y], ([aAngleElevation, bAngleElevation, Z]), (aAntennaType, aAntennaMode, (aAntennaPattern, (aAntennaGain)), bAntennaType, bAntennaDiversity, (bAntennaPattern, bAntennaGain))) format must have already been created and added to WCS. (See the “Inspecting VoWLAN Readiness” section on page 5-79.)

**Note** The parameters in square brackets are mandatory, and those in parentheses are optional.

**Note** Angles must be entered in radians (X,Y), and the height is entered in feet. The aAngle and bAngle range is from –2Pi (–6.28...) to 2Pi (6.28...), and the elevation ranges from –Pi (–3.14...) to Pi (3.14...).

**Step 4** Click Import. The RF calculation takes approximately two seconds per access point.

Configuring ChokePoints

Using chokepoints in conjunction with active compatible extensions compliant tags provides immediate location information on a tag and its asset. When a Cisco Compatible Extension tag moves out of the range of a chokepoint, its subsequent beacon frames do not contain any identifying chokepoint information. Location determination of the tag defaults to the standard calculation methods based on RSSIs reported by the access point associated with the tag.

This section contains the following topics:

- Using Chokepoints to Enhance Tag Location Reporting, page 5-58
- Adding Chokepoints to the WCS Database, page 5-58
- Adding a Chokepoint to a WCS Map, page 5-58
- Positioning Chokepoints, page 5-59
- Removing Chokepoints from the WCS Database and Map, page 5-60
Using Chokepoints to Enhance Tag Location Reporting

Installation of chokepoints provides enhanced location information for RFID tags. When an active Cisco Compatible Extensions version 1 compliant RFID tag enters the range of a chokepoint, it is stimulated by the chokepoint. The MAC address of this chokepoint is then included in the next beacon sent by the stimulated tag. All access points that detect this tag beacon then forward the information to the controller and location appliance.

Using chokepoints in conjunction with active compatible extensions compliant tags provides immediate location information on a tag and its asset. When a Cisco Compatible Extension tag moves out of the range of a chokepoint, its subsequent beacon frames do not contain any identifying chokepoint information. Location determination of the tag defaults to the standard calculation methods based on RSSIs reported by the access point associated with the tag.

Adding Chokepoints to the WCS Database

Chokepoints are installed and configured as recommended by the Chokepoint vendor. After the chokepoint installation is complete and operational, the chokepoint can be entered into the location database and plotted on a WCS map.

To add a chokepoint to the WCS database, follow these steps:

- **Step 1**: Choose **Configure > Chokepoints**.
- **Step 2**: From the **Select a command** drop-down list, choose **Add Chokepoints**.
- **Step 3**: Click **Go**.
- **Step 4**: Enter the MAC address and name for the chokepoint.
- **Step 5**: Select the check box to indicate that it is an **Entry/Exit Chokepoint**.
- **Step 6**: Enter the coverage range for the chokepoint.

**Note**: Chokepoint range is a visual representation only. It is product-specific. The actual range must be configured separately using the applicable chokepoint vendor software.

- **Step 7**: Click **OK**.

**Note**: After the chokepoint is added to the database, it can be placed on the appropriate WCS floor map.

Adding a Chokepoint to a WCS Map

To add the chokepoint to a map, follow these steps:

- **Step 1**: Choose **Monitor > Maps**.
- **Step 2**: On the Maps page, choose the link that corresponds to the floor location of the chokepoint.
- **Step 3**: From the Select a command drop-down list, choose **Add Chokepoints**.
Step 4  Click Go.

**Note** The Add Chokepoints summary page lists all recently-added chokepoints that are in the database but not yet mapped.

Step 5  Select the check box next to the chokepoint that you want to place on the map.

Step 6  Click OK.

A map appears with a chokepoint icon located in the top-left hand corner. You are now ready to place the chokepoint on the map.

Step 7  Left-click the chokepoint icon and drag it to the proper location.

**Note** The MAC address, name, and coverage range of the chokepoint appear in the left pane when you click the chokepoint icon for placement.

Step 8  Click Save.

You are returned to the floor map and the added chokepoint appears on the map.

**Note** The newly created chokepoint icon may or may not appear on the map depending on the display settings for that floor.

**Note** The rings around the chokepoint icon indicate the coverage area. When a CCX tag and its asset passes within the coverage area, location details are broadcast, and the tag is automatically mapped on the chokepoint coverage circle. When the tag moves out of the chokepoint range, its location is calculated as before and is no longer mapped on the chokepoint rings.

**Note** The MAC address, name, entry/exit chokepoint, static IP address, and range of the chokepoint appears when you hover your mouse cursor over its map icon.

Step 9  If the chokepoint does not appear on the map, select the Chokepoints check box located on the Floor Settings menu.

**Note** Do not select Save Settings unless you want to save this display criteria for all maps.

**Note** You must synchronize network design to the mobility services engine or location server to push chokepoint information.

**Positioning Chokepoints**

To position chokepoints on the map, follow these steps:
**Step 1** Left-click the chokepoint icon and drag it to the proper location.

*Note* The MAC address, name, and coverage range of the chokepoint appear in the left pane when you click the chokepoint icon for placement.

**Step 2** Click *Save* when the icon is correctly placed on the map.

**Step 3** The newly created chokepoint icon may or may not appear on the map depending on the display settings for that floor. If the icon does not appear, repeat Step 11.

*Note* The rings around the chokepoint icon indicate the coverage area. When a Cisco Compatible Extensions tag and its asset passes within the coverage area, location details are broadcast, and the tag is automatically mapped on the chokepoint coverage circle. The chokepoint range is given as a visual only, but chokepoint vendor software is required to actually configure the range. When the tag moves out of the chokepoint range, its location is calculated as before and is no longer mapped on the chokepoint rings.

*Note* MAC address, name, and range of a chokepoint display when you hover your mouse cursor over its map icon.

**Step 4** If the chokepoint does not appear on the map, click *Layers* to view a drop-down list of possible elements to display on the map. Select the *Chokepoints* check box.

**Step 5** Click *X* to close the Layers page.

*Note* Do not select *Save Settings* unless you want to save this display criteria for all maps.

*Note* You can change the position of chokepoints by importing or exporting a file. See the “Positioning Access Points, Wi-Fi TDOA Receivers, and Chokepoints by Importing or Exporting a File” section on page 5-56 for more information.

---

**Removing Chokepoints from the WCS Database and Map**

You can remove one or multiple chokepoints at a time.

To delete a chokepoint, follow these steps:

**Step 1** Choose *Configure > Chokepoints*.

**Step 2** Select the box(es) next to the chokepoint(s) to be deleted.

**Step 3** From the Select a command drop-down list, choose *Remove Chokepoints*.

**Step 4** Click *Go*.
Configuring WiFi TDOA Receivers

This section contains the following topics:

- Adding WiFi TDOA Receivers to the WCS Database, page 5-61
- Adding WiFi TDOA Receivers to a Map, page 5-61
- Positioning WiFi TDOA Receivers, page 5-62
- Removing WiFi TDOA Receivers from the Map, page 5-62
- Removing WiFi TDOA Receivers from the WCS Database, page 5-63

Adding WiFi TDOA Receivers to the WCS Database

To add a WiFi TDOA receivers to the WCS database, follow these steps:

Step 1 Choose Configure > WiFi TDOA Receivers.
Step 2 From the Select a command drop-down list, choose Add WiFi TDOA Receivers.
Step 3 Click Go.
Step 4 Enter the MAC address, name, and static IP address for the WiFi TDOA receiver.

Note WiFi TDOA receivers are configured separately using the WiFi TDOA receiver vendor software.

Step 5 Click OK to save the WiFi TDOA receiver entry to the database.

Note After the WiFi TDOA receiver is added to the database, place it on the appropriate WCS floor map. See “Adding WiFi TDOA Receivers to the WCS Database” for more information.

Adding WiFi TDOA Receivers to a Map

To add a WiFi TDOA receiver to a map, follow these steps:

Step 1 Choose Monitor > Maps.
Step 2 Choose the link that corresponds to the floor location of the WiFi TDOA receiver.
Step 3 From the Select a command drop-down list, choose Add WiFi TDOA Receivers.
Step 4 Click Go.

Note The Add WiFi TDOA Receivers summary page lists all recently-added WiFi TDOA receivers that are in the database but not yet mapped.
**Step 5** Select the check box next to the WiFi TDOA receiver to be added to the map.

**Step 6** Click **OK**.

A map appears with a green WiFi TDOA receiver icon located in the top-left hand corner. You are now ready to position the WiFi TDOA receiver on the map.

---

**Positioning WiFi TDOA Receivers**

To position WiFi TDOA receivers on the map, follow these steps:

**Step 1** Left-click the WiFi TDOA receiver icon and drag it to the proper location.

*Note* The MAC address and name of the WiFi TDOA receiver appear in the left pane when you click the WiFi TDOA receiver icon for placement.

**Step 2** Click **Save** when icon is correctly placed on the map.

*Note* The MAC address of the WiFi TDOA receiver appears when you hover your mouse cursor over its map icon.

**Step 3** If the chokepoint does not appear on the map, click **Layers** to view a drop-down list of possible elements to display on the map. Select the **WiFi TDOA Receivers** check box.

**Step 4** Click **X** to close the Layers page.

*Note* Do not select **Save Settings** unless you want to save this display criteria for all maps.

*Note* You can change the position of Wi-Fi TDOA Receivers by importing or exporting a file. See the “Positioning Access Points, WiFi TDOA Receivers, and Chokepoints by Importing or Exporting a File” section on page 5-56 for more information.

---

**Removing WiFi TDOA Receivers from the Map**

To remove a WiFi TDOA receiver from a floor map, follow these steps:

**Step 1** From the Select a command drop-down list on the applicable WCS floor map page, choose **Remove WiFi TDOA Receivers**.

**Step 2** Click **Go**.

**Step 3** Select the check box(es) next to the WiFi TDOA receiver(s) to be deleted.

*Note* You can remove multiple WiFi TDOA receivers at a time from a map.
Step 4  Click OK.

Removing WiFi TDOA Receivers from the WCS Database

To remove a WiFi TDOA receiver from the WCS database, follow these steps:

Step 1  Choose Configure > WiFi TDOA Receivers.
Step 2  Select the check box(es) next to the WiFi TDOA receiver(s) to be deleted.

Note  You can remove multiple WiFi TDOA receivers at a time from the database.

Step 3  From the Select a command drop-down list, choose Remove WiFi TDOA Receivers.
Step 4  Click Go.
Step 5  Click OK to confirm the deletion.

Managing RF Calibration Models

If the provided RF models do not sufficiently characterize the floor layout, you can create a calibration model that is applied to the floor and better represents the attenuation characteristics of that floor. The calibration models are used as RF overlays with measured RF signal characteristics that can be applied to different floor areas. This enables the Cisco WLAN solution installation team to lay out one floor in a multi-floor area, use the RF calibration tool to measure, save the RF characteristics of that floor as a new calibration model, and apply that calibration model to all the other floors with the same physical layout.

You can collect data for a calibration using one of two methods:

- Point mode data collection—Calibration points are selected and their coverage area is calculated one location at a time.
- Linear mode data collection—A series of linear paths are selected and then calculated as you traverse the path. This approach is generally faster than the point mode data collection. You can also employ point mode data collection to augment data collection for locations missed by the linear paths.

Note  Calibration models can only be applied to clients, rogue clients, and rogue access points. Calibration for tags is done using the Aeroscout System Manager. Refer to the following link for details on tag calibration at: http://support.aeroscout.com.

Note  A client device that supports both 802.11a/n and 802.11b/g/n radios is recommended to expedite the calibration process for both spectrums.

Use a laptop or other wireless device to open a browser to the WCS server and perform the calibration process.
This section provides the following:

- Accessing Current Calibration Models, page 5-64
- Applying Calibration Models to Maps, page 5-64
- Calibration Model Properties, page 5-64
- Calibration Model Details, page 5-65
- Creating New Calibration Models, page 5-65
- Starting Calibration Process, page 5-65
- Calibrating, page 5-68
- Applying to Maps, page 5-68
- Deleting Calibration Models, page 5-69

Accessing Current Calibration Models

To access current calibration models, follow these steps:

**Step 1** Choose Monitor > Maps.

**Step 2** From the Select a command drop-down list, choose RF Calibration Models. The Model Name and Status for each calibration model is listed.

**Step 3** Click the Model Name to access a specific calibration model.

Applying Calibration Models to Maps

To apply a current calibration model to a map, follow these steps:

**Step 1** Choose Monitor > Maps.

**Step 2** From the Select a command drop-down list, choose RF Calibration Models.

**Step 3** Click the Model Name to access the applicable calibration model.

**Step 4** From the Select a command drop-down list, choose Apply to Maps.

**Step 5** Click Go.

Calibration Model Properties

To view or edit current calibration models, follow these steps:

**Step 1** Choose Monitor > Maps.

**Step 2** From the Select a command drop-down list, choose RF Calibration Models.

**Step 3** Click the Model Name to access the applicable calibration model.

**Step 4** From the Select a command drop-down list, choose Properties.
Step 5  Click Go to view or edit calibration model details. See Calibration Model Details, page 5-65 for more information.

Calibration Model Details

To edit calibration model details, follow these steps:

Step 1  Choose Monitor > Maps.
Step 2  From the Select a command drop-down list, choose RF Calibration Models.
Step 3  Click the Model Name to access the applicable calibration model.
Step 4  From the Select a command drop-down list, choose Properties.
Step 5  Click Go.
Step 6  The following parameters may be edited:
  • Sweep Client Power for Location—Click to enable. You may want to enable this if a high density of access points exists and transmit power is reduced or unknown. The sweeping range of client transmit power may improve accuracy but scalability is negatively affected.
  • HeatMap Binsize—Choose 4, 8, 16, or 32 from the drop-down list.
  • HeatMap Cutoff—Determine the heatmap cutoff. A low heatmap cutoff is recommended especially if the access point density is high and RF propagation conditions are favorable. A higher cutoff value increases scalability but may cause difficulty when locating clients.
Step 7  When any necessary changes have been made or to exit the page, click OK.

Creating New Calibration Models

To create a new calibration model, follow these steps:

Step 1  Choose Monitor > Maps.
Step 2  From the Select a command drop-down list, choose RF Calibration Models.
Step 3  Click Go.
Step 4  From the Select a command drop-down list, choose Create New Model.
Step 5  Click Go.
Step 6  Enter a Model Name, and click OK.
The new model appears along with the other RF calibration models with a status of Not Yet Calibrated.

Starting Calibration Process

To start the calibration process, follow these steps:

Step 1  Click the Model Name to open the Calibration Model > Model Name page.
Step 2  From the Select a command drop-down list, choose Add Data Points.

Step 3  Click GO.

Step 4  Enter the MAC address of the device being used to perform the calibration. Manually-entered MAC addresses must be delimited with colons (such as FF:FF:FF:FF:FF:FF).

Note  If this process is being performed from a mobile device connected to WCS through the Cisco Centralized architecture, the MAC address text box is automatically populated with the device address.

Step 5  Choose the appropriate campus, building, floor or outdoor area where the calibration is performed.

Note  The calibration in outdoor area is supported from 7.0.x release onwards. You can use this option to add the calibration data points to the outdoor area. The data points can be added to the outdoor area using the same procedure for calibration.

Step 6  Click Next.

Step 7  When the chosen floor map and access point locations display, a grid of plus marks (+) indicates the locations where data collection for calibration is performed.

Using these locations as guidelines, you can perform either a point or linear collection of data by appropriate placement of either the Calibration Point pop-up (point) or the Start and Finish pop-ups (linear) that display on the map when the respective options are displayed.

If you want to do a point collection of data for the calibration, do the following:

a. Select Point from the Collection Method drop-down list and select the Show Data points check box if not already selected. A Calibration Point pop-up appears on the map.

b. Position the tip of the Calibration Point pop-up at a data point (+), and click Go. A pane appears showing the progress of the data collection.

Note  Rotate the calibrating client laptop during data collection so that the client is heard evenly by all access points in the vicinity.

c. When the data collection is complete for a selected data point and the coverage area is plotted on the map, move the Calibration Point pop-up to another data point, and click Go.

Note  The coverage area plotted on the map is color-coded and corresponds with the specific wireless LAN standard used to collect that data. Information on color-coding is provided in legend on the left side of the page. Additionally, the progress of the calibration process is indicated by two status bars above the legend, one for 802.11a/n and one for 802.11b/g/n.

Note  To delete data points for locations selected in error, click Delete and move the black square that appears over the appropriate data points. Resize the square as necessary by pressing Ctrl and moving the mouse.

d. Repeat point collection steps a to c until the calibrations status bar of the relevant spectrums (802.11a/n, 802.11b/g/n) display as ‘done.’
The calibration status bar indicates data collection for the calibration as done, after roughly 50 distinct locations and 150 measurements have been gathered. For every location point saved in the calibration process, more than one data point is gathered. The progress of the calibration process is indicated by two status bars above the legend, one for 802.11b/g/n and one for 802.11a/n.

If you want to do a linear collection of data for the calibration, do the following:

a. Select Linear from the Collection Method drop-down list and select the Show Data points check box if not already selected. A line appears on the map with both Start and Finish pop-ups.

b. Position the tip of the Start pop-up at the starting data point.

c. Position the Finish pop-up at the ending data point.

d. Position yourself with your laptop at the starting data point and click Go. Walk steadily towards the end point along the defined path. A pane appears to show that data collection is in process.

Note: Do not stop data collection until you reach the end point even if the data collection bar indicates completion.

Note: Only Intel and Cisco adapters have been tested. Make sure the Enable Cisco Compatible Extensions and Enable Radio Management Support are enabled in the Cisco Compatible Extension Options.

e. Press the space bar (or Done in the data collection pane) when you reach the end point. The collection pane displays the number of samples taken before it closes to reveal the map. The map displays all the coverage areas where data was collected.

Note: To delete data points for locations selected in error, click Delete and move the black square that appears over the appropriate data points. Resize the square as necessary by pressing the Ctrl and moving the mouse.

Note: The coverage area is color-coded and corresponds with the specific wireless LAN standard used to collect that data. Information on color-coding is provided in legend on the left-hand side of the page.

f. Repeat linear collection steps b to e until the status bar for the respective spectrum is filled in (done).

Note: You can augment linear collection with point mode data collection to address missed coverage areas.

Step 8 Click the name of the calibration model at the top of the page to return to the main page for that model to calibrate the data points.

Step 9 Choose Calibrate from the Select a command drop-down list, and click Go.
Step 10  Click the **Inspect Location Quality** link when calibration completes. A map displays showing RSSI readings displays.

Step 11  To use the newly created calibration model, you must apply the model to the floor on which it was created (and on any other floors with similar attenuation characteristics as well). Navigate to **Monitor > Maps** and find the specific floor to which the model is applied. At the floor map interface, choose **Edit Floor Area** from the drop-down list, and click **Go**.

Step 12  From the Floor Type (RF Model) drop-down list, choose the newly created calibration model. Click **OK** to apply the model to the floor.

**Note**  This process can be repeated for as many models and floors as needed. After a model is applied to a floor, all location determination performed on that floor is done using the specific collected attenuation data from the calibration model.

---

**Calibrating**

To compute the collected data points, follow these steps:

**Step 1**  Click the Model Name to open the Calibration Model > Model Name page.

**Step 2**  In the Calibration Model > Model Name page, choose **Calibrate** from the Select a command drop-down list.

**Step 3**  Click **Go**.

---

**Applying to Maps**

To use the newly created calibration model, you must apply the model to the floor on which it was created (along with other floors with similar attenuation characteristics).

To apply the model to the floor, follow these steps:

**Step 1**  Choose **Monitor > Maps**.

**Step 2**  Locate the specific floor to which the model is applied.

**Step 3**  From the Select a command drop-down list, choose **Edit Floor Area**.

**Step 4**  Click **Go**.

**Step 5**  From the Floor Type (RF Model) drop-down list, choose the newly-created calibration model.

**Step 6**  Click **OK** to apply the model to the floor.

This process can be repeated for as many models and floors as needed. After a model is applied to a floor, all location determination performed on that floor is done using the specific collected attenuation data from the calibration model.
Deleting Calibration Models

To delete a calibration model, follow these steps:

**Step 1** Click the Model Name to open the Calibration Model > Model Name page.

**Step 2** From the Select a command drop-down list, choose Delete Model.

**Step 3** Click Go.

Managing Location Presence Information

You can enable location presence by mobility services engine to provide expanded Civic (city, state, postal code, country) and GEO (longitude, latitude) location information beyond the Cisco default setting (campus, building, floor, and X, Y coordinates). This information can then be requested by clients on a demand basis for use by location-based services and applications. See the “Enabling Location Presence for Mobility Services” section on page 12-43 for more information on enabling location presence.

To view or edit current location presence information for a current map, follow these steps:

**Step 1** Choose Monitor > Maps.

**Step 2** Select the check box of the map.

**Step 3** From the Select a command drop-down list, choose Location Presence.

**Step 4** Click Go. The Location Presence page appears.

**Note** The current map location information (Area Type, Campus, Building, and Floor) refer to the map you selected from the Monitor > Maps page. To select a different map, use the Select a Map to Update Presence Information drop-down list to select the new map location.
Step 5  Click either the Civic, GPS Markers, or Advanced tab.

- Civic Address—Identifies the campus, building, or floor by name, street, house number, house number suffix, city (address line2), state, postal code, and country.
- GPS Markers—Identify the campus, building, or floor by longitude and latitude.
- Advanced—Identifies the campus, building, or floor with expanded civic information such as neighborhood, city division, county, and postal community name.

Note  Each selected parameter is inclusive of all of those above it. For example, if you select Advanced, it can also provide GPS and Civic location information upon client demand. The selected setting must match what is set on the mobility services engine level. See the Enabling Location Presence for Mobility Services, page 12-43 for more information.

Note  If a client requests location information such as GPS Markers for a campus, building, floor, or outdoor area that is not configured for that parameter, an error message appears.

Note  By default, the Override Child Element Presence Info check box is selected.
Searching Maps

Use the controls in the left sidebar menu to create and save custom searches:

- **New Search drop-down list**: Opens the Search Maps window. Use the Search Maps window to configure, run, and save searches.
- **Saved Searches drop-down list**: Lists the saved custom searches. To open a saved search, choose it from the Saved Searches list.
- **Edit Link**: Opens the Edit Saved Searches window. You can delete saved searches in the Edit Saved Searches window.
- **Audit Status**: Allows you to search based on audit status of not available (audit status is not available), identical (no configuration differences were found during the last audit), or mismatch (configuration differences were found during the last audit).

You can configure the following parameters in the Search Maps window:

- Search for
- Map Name
- Search in
- Save Search
- Items per page

After you click Go, the map search results window appears (see Table 5-7):

<table>
<thead>
<tr>
<th><strong>Table 5-7 Map Search Results</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Parameter</strong></td>
</tr>
<tr>
<td>Name</td>
</tr>
<tr>
<td>Type</td>
</tr>
<tr>
<td>WCS</td>
</tr>
<tr>
<td>Total APs</td>
</tr>
<tr>
<td>a/n Radios</td>
</tr>
<tr>
<td>b/g/n Radios</td>
</tr>
<tr>
<td>OOS Radios</td>
</tr>
</tbody>
</table>

Using Map Editors

You can use the WCS map editor to define, draw, and enhance floor plan information. This section contains the following topics:

- **Opening the Map Editor, page 5-72**
- **Using the Map Editor to Draw Polygon Areas, page 5-72**
- **Defining an Inclusion Region on a Floor, page 5-75**
- **Defining an Exclusion Region on a Floor, page 5-76**
Opening the Map Editor

To use the map editor, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Choose Monitor &gt; Maps to display the Maps page.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Click the desired campus. WCS displays the Maps &gt; Campus Name page.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Click a campus building.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Click the desired floor area. WCS displays the Maps &gt; Campus Name &gt; Building Name &gt; Floor Area Name page.</td>
</tr>
<tr>
<td>Step 5</td>
<td>From the Select a command drop-down list, choose Map Editor, and click Go. WCS displays the Map Editor page.</td>
</tr>
</tbody>
</table>

**Note** Make sure that the floor plan images are properly scaled so that all white space outside of the external walls is removed. To make sure that floor dimensions are accurate, choose the compass tool from the toolbar.

| Step 6 | Position the reference length. When you do, the Scale menu appears with the line length supplied. Enter the dimensions (width and height) of the reference length, and click OK. |
| Step 7 | Determine the propagation pattern at the Antenna Mode drop-down list. |
| Step 8 | Make antenna adjustments by sliding the antenna orientation bar to the desired degree of direction. |
| Step 9 | Choose the desired access point. |
| Step 10 | Click Save. |

Using the Map Editor to Draw Polygon Areas

If you have a building that is non-rectangular or you want to mark a non-rectangular area within a floor, you can use the map editor to draw a polygon-shaped area. To draw a polygon area in the map, follow these steps:

| Step 1 | Add the floor plan if it is not already represented in WCS (see the “Adding Floor Areas to a Campus Building” section on page 5-42). |
| Step 2 | Choose Monitor > Maps. |
| Step 3 | Click the Map Name that corresponds to the outdoor area, campus, building, or floor you want to edit. |
| Step 4 | From the Select a command drop-down list, choose Map Editor, and click Go. |
| Step 5 | At the Map Editor screen, click the Add Perimeter icon on the toolbar (see Figure 5-33). A pop-up dialog box appears. |
Step 6 Enter the name of the area that you are defining. Click **OK**.

A drawing tool appears.

Step 7 Move the drawing tool to the area you want to outline.

- Click the left mouse button to begin and end drawing a line.
- When you have completely outlined the area, double-click the left mouse button and the area is highlighted on the screen (see **Figure 5-34**).

The outlined area must be a closed object to highlight on the map.
Step 8  Click the disk icon on the toolbar to save the newly drawn area.

Step 9  Choose Command > Exit to close the window. You are returned to the original floor plan.

Note  When you return to the original floor plan view, after exiting the map editor, the newly drawn area is not seen; however, it appears in the Planning Model window when you add elements.

Step 10  Choose Planning Mode from the Select a command drop-down list to begin adding elements to the newly defined polygon-shaped area.

The Table 5-8 explains the color coding of obstacles.

<table>
<thead>
<tr>
<th>Type of obstacle</th>
<th>Color coding</th>
<th>Loss (in dB)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Thick wall</td>
<td></td>
<td>13</td>
</tr>
<tr>
<td>Light wall</td>
<td></td>
<td>2</td>
</tr>
<tr>
<td>Heavy door</td>
<td></td>
<td>15</td>
</tr>
</tbody>
</table>

**Figure 5-34  Polygon Area**

**Table 5-8  Obstacle color coding**
Note
The RF prediction heatmaps for access points approximates of the actual RF signal intensity. It takes into account the attenuation of obstacles drawn using the Map Editor but it does not take into account the attenuation of various building materials, such as drywall or metal objects, nor does it display the effects of RF signals bouncing off obstructions. The thick wall (color-coded orange) with a loss of 13 dB may not be enough to contain the RF signal beyond the walls of the heatmap.

### Defining an Inclusion Region on a Floor

To define an inclusion area, follow these steps:

**Step 1** Choose **Monitor > Maps**.

**Step 2** Click the name of the appropriate floor area.

**Step 3** From the Select a command drop-down list, choose **Map Editor**.

**Step 4** Click **Go**.

**Step 5** At the map, click the aqua box on the toolbar.

**Note** A message box appears reminding you that only one inclusion area can be defined at a time. Defining a new inclusion region automatically removes the previously defined inclusion region. By default, an inclusion region is defined for each floor when it is added to WCS. The inclusion region is indicated by a solid aqua line and generally outlines the region.

**Step 6** Click **OK** in the message box that appears. A drawing icon appears to outline the inclusion area.

**Step 7** To begin defining the inclusion area, move the drawing icon to a starting point on the map and click once.

**Step 8** Move the cursor along the boundary of the area you want to include and click to end a border line. Click again to define the next boundary line.

**Step 9** Repeat **Step 8** until the area is outlined and then double-click the drawing icon. A solid aqua line defines the inclusion area.

**Step 10** Choose **Save** from the Command menu or click the disk icon on the toolbar to save the inclusion region.

---

### Table 5-8 Obstacle color coding (continued)

<table>
<thead>
<tr>
<th>Type of obstacle</th>
<th>Color coding</th>
<th>Loss (in dB)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Light door</td>
<td><img src="image" alt="Light door color" /></td>
<td>4</td>
</tr>
<tr>
<td>Cubicle</td>
<td><img src="image" alt="Cubicle color" /></td>
<td>1</td>
</tr>
<tr>
<td>Glass</td>
<td><img src="image" alt="Glass color" /></td>
<td>1.5</td>
</tr>
</tbody>
</table>

---
Chapter 5  Monitoring Maps

Using Map Editors

Note
If you made an error in defining the inclusion area, click the area. The selected area is outlined by a dashed aqua line. Next, click the X icon on the toolbar. The area is removed from the floor map.

Step 11 To return to the floor map to enable inclusion regions on heatmaps, choose Exit from the Command menu.

Step 12 At the floor map, click the Layers drop-down list.

Step 13 Select the Location Regions check box if it is not already selected. If you want it to apply to all floor maps, click Save settings. Close the Layers configuration pane.

Step 14 To resynchronize the WCS and location databases, click Services > Synchronize Services.

Step 15 At the Synchronize page, select Network Designs from the Synchronize drop-down list and then click Synchronize.

Check the Sync. Status column to ensure that the synchronization is successful (two green arrows).

Note Newly defined inclusion and exclusion regions appear on heatmaps only after the mobility services engine recalculates location.

Defining an Exclusion Region on a Floor

To further refine location calculations on a floor, you can define areas that are excluded (exclusion areas) in the calculations. For example, you might want to exclude areas such as an atrium or stairwell within a building. As a rule, exclusion areas are generally defined within the borders of an inclusion area.

To define an exclusion area, follow these steps:

Step 1 Choose Monitor > Maps.

Step 2 Click the name of the appropriate floor area.

Step 3 From the Select a command drop-down list, choose Map Editor.

Step 4 Click Go.

Step 5 At the map, click the purple box on the toolbar.

Step 6 Click OK in the message box that appears. A drawing icon appears to outline the exclusion area.

Step 7 To begin defining the exclusion area, move the drawing icon to the starting point on the map and click once.

Step 8 Move the drawing icon along the boundary of the area you want to exclude and click once to start a boundary line; click again to end the boundary line.

Step 9 Repeat Step 8 until the area is outlined and then double-click the drawing icon. The defined exclusion area is shaded in purple. when the area is completely defined. The excluded area is shaded in purple.

Step 10 To define additional exclusion regions, repeat Step 5 to Step 9.

Step 11 When all exclusion areas are defined, choose Save from the Command menu or the disk icon on the toolbar to save the exclusion region.
To delete an exclusion area, click the area to be deleted. The selected area is outlined by a dashed purple line. Next, click the X icon on the toolbar. The area is removed from the floor map.

**Step 12**  
To return to the floor map to enable exclusion regions on heatmaps, choose **Exit** from the Command menu.

**Step 13**  
At the floor map, click the Layers drop-down list.

**Step 14**  
Select the Location Regions check box if it is not already selected and then click **Save settings**, close the Layers configuration pane when complete.

**Step 15**  
To resynchronize the WCS and location databases, click **Services > Synchronize Services**.

**Step 16**  
At the Synchronize page, select **Network Designs** from the Synchronize drop-down list and then click **Synchronize**.  
Check the Sync. Status column to ensure that the synchronization is successful (two green arrows).

---

**Defining a Rail Line on a Floor**

You can define a rail line on a floor that represents a conveyor belt. Additionally, you can define an area around the rail area known as the snap-width to further assist location calculations. This represents the area in which you expect clients to appear. Any client located within the snap-width area is plotted on the rail line (majority) or just outside of the snap-width area (minority).

**Note**  
Rail line configurations do not apply to tags.

The snap-width area is defined in feet or meters (user-defined) and represents the distance that is monitored on either side (east and west or north and south) of the rail.

To define a rail with a floor, follow these steps:

**Step 1**  
Choose **Monitor > Maps**.

**Step 2**  
Click the name of the appropriate floor area.

**Step 3**  
Choose **Map Editor** from the Select a command drop-down list.

**Step 4**  
Click **Go**.

**Step 5**  
At the map, click the rail icon (to the right of the purple exclusion icon) on the toolbar.

**Step 6**  
In the message pane that appears, enter a snap-width (feet or meters) for the rail and then click **OK**. A drawing icon appears.

**Note**  
The snap-width is defined in feet or meters (as defined by the user) and represents the distance that is monitored on either side (left and right) of the rail.

**Step 7**  
Click the drawing icon at the starting point of the rail line. Click again when you want to stop drawing the line or change the direction of the line.

**Step 8**  
Click the drawing icon twice when the rail line is completely drawn on the floor map. The rail line appears on the map and is bordered on either side by the defined snap-width region.
Inspecting Location Readiness and Quality

You can configure WCS to verify the ability of the existing access point deployment to estimate the true location of a client, rogue client, rogue access point, or tag within 10 meters at least 90% of the time. The location readiness calculation is based on the number and placement of access points.

You can also check the location quality and the ability of a given location to meet the location specification (10 m, 90%) based on data points gathered during a physical inspection and calibration.

Inspecting Location Readiness

The Inspect Location Readiness feature is a distance-based predictive tool that can point out problem areas with access point placement.

To access the Inspect Location Readiness tool, follow these steps:

Step 1 Choose Monitor > Maps.
Step 2 Select the applicable floor area name to view the map.

Note If RSSI is not displayed, you can enable AP Heatmaps under the Layer menu (top-left).

Note If clients, tags, and access points are not displayed, verify that their respective check boxes are selected in the Layers menu. Licenses for both clients and tags must also be purchased for each to be tracked.

Step 3 From the Select a command drop-down list, choose Inspect Location Readiness.
Step 4 Click Go.
Inspecting Location Readiness and Quality

A color-coded map appears showing those areas that meet (indicated by Yes) and do not meet (indicated by No) the ten meter, 90% location specification.

Inspecting Location Quality Using Calibration Data

After completing a calibration model based on data points generated during a physical tour of the area, you can inspect the location quality of the access points.

To inspect location quality based on calibration, follow these steps:

**Step 1** Choose **Monitor > Maps**.
**Step 2** Choose **RF Calibration Model** from the Select a command list. Click **Go**.

A list of calibration models appears.

**Step 3** Click the appropriate calibration model.

Details on the calibration including date of last calibration, number of data points by signal type (802.11a, 802.11 b/g) used in the calibration, location, and coverage are displayed.

**Step 4** At the same page, click the **Inspect Location Quality** link found under the Calibration Floors heading.

A color-coded map noting percentage of location errors appears.

*Note* You can modify the distance selected to see the effect on the location errors.

Inspecting VoWLAN Readiness

Voice readiness tool (the VoWLAN Readiness tool) allows you to check the RF coverage to see if it is sufficient for your voice needs. This tool verifies RSSI levels after access points have been installed.

To access the VoWLAN Readiness Tool (VRT), follow these steps:

**Step 1** Choose **Monitor > Maps**.
**Step 2** Select the applicable floor area name.
**Step 3** From the Select a command drop-down list, choose **Inspect VoWLAN Readiness**.
**Step 4** Select the applicable **Band**, **AP Transmit Power**, and **Client** parameters from the drop-down lists.

*Note* By default the region map displays the region map for b/g/n band for Cisco Phone based RSSI threshold. The new settings cannot be saved.

**Step 5** Depending on the selected client, the RSSI values may not be editable.
- Cisco Phone—RSSI values are not editable.
- Custom—RSSI values are editable with the following ranges:
  - Low threshold between -95dBm to -45dBm
Monitoring Mesh Networks Using Maps

Monitoring Mesh Networks Using Maps

You can access and view details for the following elements from a mesh network map in Cisco WCS:

- Mesh Link Statistics
- Mesh Access Points
- Mesh Access Point Neighbors

This section describes how information is accessed and displayed for each of these items and contains the following sections:

- Monitoring Mesh Link Statistics Using Maps, page 5-80
- Monitoring Mesh Access Points Using Maps, page 5-83
- Monitoring Mesh Access Point Neighbors Using Maps, page 5-85
- Monitoring Mesh Health, page 5-88
- Mesh Statistics for an Access Point, page 5-92
- Using Mesh Filters to Modify Map Display of Maps and Mesh Links, page 5-98

Monitoring Mesh Link Statistics Using Maps

You can view the SNR for a specific mesh network link, view the number of packets transmitted and received on that link, and initiate a link test from the Monitor > Maps display.
To view details on a specific mesh link between two mesh access points or a mesh access point and a root access point, follow these steps:

**Step 1** Choose **Monitor > Maps**.

**Step 2** Click the **Map Name** that corresponds to the outdoor area, campus, building, or floor you want to monitor.

**Step 3** From the left sidebar menu, Click the arrow to the right of AP Mesh Info (see Figure 5-35). A Mesh Filter dialog box appears.

![Mesh Filter Page](image)

**Step 4** Move the cursor over the colored dot next to each mesh access point child to view details on the link between it and its parent. Table 5-9 summarizes the parameters that display.

The color of the dot also provides a quick reference point of the SNR strength.
- A green dot represents a high SNR (above 25 dB).
- An amber dot represents an acceptable SNR (20-25 dB).
- A red dot represents a low SNR (below 20 dB).
- A black dot indicates a root access point.

The Bridging Link information appears.
Table 5-9  Bridging Link Information

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Information fetched on</td>
<td>Date and time that information was compiled.</td>
</tr>
<tr>
<td>Link SNR</td>
<td>Link signal-to-noise ratio (SNR).</td>
</tr>
<tr>
<td>Link Type</td>
<td>Hierarchical link relationship.</td>
</tr>
<tr>
<td>SNR Up</td>
<td>Signal-to-noise radio for the uplink (dB).</td>
</tr>
<tr>
<td>SNR Down</td>
<td>Signal-to-noise radio for the downlink (dB).</td>
</tr>
<tr>
<td>PER</td>
<td>The packet error rate for the link.</td>
</tr>
<tr>
<td>Tx Parent Packets</td>
<td>The TX packets to a node while acting as a parent.</td>
</tr>
<tr>
<td>Rx Parent Packets</td>
<td>The RX packets to a node while acting as a parent.</td>
</tr>
<tr>
<td>Time of Last Hello</td>
<td>Date and time of last hello.</td>
</tr>
</tbody>
</table>

**Step 5**  Click either **Link Test, Child to Parent** or **Link Test, Parent to Child**. After the link test is complete, a results page appears.

**Note**  A link test runs for 30 seconds.

**Note**  You cannot run link tests for both links (child-to-parent and parent-to-child) at the same time.

**Step 6**  To view a graphical representation of SNR statistics over a period of time, click the arrow on the link. A page with multiple SNR graphs appears (see Figure 5-36).

The following graphs are displayed for the link:

- **SNR Up**—Plots the RSSI values of the neighbor from the perspective of the access point.
- **SNR Down**—Plots the RSSI values that the neighbor reports to the access point.
- **Link SNR**—Plots a weighed and filtered measurement based on the SNR Up value.
- **The Adjusted Link Metric**—Plots the value used to determine the least cost path to the root access point. This value is the ease to get to the rooftop access point and accounts for the number of hops. The lower the ease value, the less likely the path is used.
- **The Unadjusted Link Metric**—Plots the least cost path to get to the root access point unadjusted by the number of hops. The higher the value for the unadjusted link, the better the path.
Monitoring Mesh Access Points Using Maps

You can view the following summary information for a mesh access point from a mesh network map:

- Parent
- Number of children
- Hop count
- Role
- Group name
- Backhaul interface
- Data Rate
- Channel

Note: This information is in addition to the information shown for all access points (MAC address, access point model, controller IP address, location, height of access point, access point up time, and LWAPP up time).
You can also view detailed configuration and access alarm and event information from the map. For detailed information on the Alarms and Events displayed, see the “Alarm and Event Dictionary” section on page 14-1.

To view summary and detailed configuration information for a mesh access point from a mesh network map, follow these steps:

**Step 1** In Cisco WCS, choose **Monitor > Maps**.

**Step 2** Click the **Map Name** that corresponds to the outdoor area, campus, building, or floor location of the access point you want to monitor.

**Step 3** To view summary configuration information for an access point, move the cursor over the access point that you want to monitor. A dialog box page with configuration information for the selected access point appears (see **Figure 5-37**).

**Step 4** To view detailed configuration information for an access point, double-click the access point appearing on the map. The configuration details for the access point appears (see **Figure 5-38**).
Step 5  In the Access Point configuration page, follow these steps to view configuration details for the mesh access point.

a. Click the General tab to view the overall configuration of the mesh access point such as AP name, MAC address, AP Up time, associated controllers (registered and primary) operational status, and software version.

   Note  The software version for mesh access points is appended the letter \textit{m} and the word \textit{mesh} in parentheses.

b. Click the Interface tab to view configuration details for the interfaces supported on the mesh access point. Interface options are radio and Ethernet.

c. Click the Mesh Links tab to view parent and neighbor details (name, MAC address, packet error rate, and link details) for the mesh access point. You can also initiate link tests from this page.

d. Click the Mesh Statistics tab to view details on the bridging, queue, and security statistics for the mesh access point. For more details on mesh statistics, see the “Mesh Statistics for an Access Point” section on page 5-92.

Monitoring Mesh Access Point Neighbors Using Maps

To view details on neighbors of a mesh access point from a mesh network map, follow these steps:
Step 1  Choose Monitor > Maps.

Step 2  Click the Map Name that corresponds to the outdoor area, campus, building, or floor you want to monitor.

Step 3  To view detailed information on mesh links for a mesh access point, click the arrow portion of the access point label. The Access Points page appears.

Step 4  Click the Mesh Links tab (see Figure 5-39).

**Figure 5-39** Access Points > Mesh Links Page

---

**Note**

You can also view mesh link details for neighbors of a selected access point by clicking the View Mesh Neighbors link on the Mesh tab of the access point configuration summary page, which appears when you hover your mouse cursor over an access point on a map (see Figure 5-40).
Figure 5-40  Access Point Configuration Summary Dialog Box

Note  Signal-to-noise (SNR) appears on the View Mesh Neighbors page (see Figure 5-41).
In addition to listing the current and past neighbors in the page that appears, labels are added to the mesh access points map icons to identify the selected access point, the neighbor access point, and the child access point. Click the `clear` link of the selected access point to remove the relationship labels from the map.

The drop-down lists at the top of the mesh neighbors page indicate the resolution of the map (100%) displayed and how often the information displayed is updated (5 mins). You can modify these default values.

**Monitoring Mesh Health**

Mesh Health monitors the overall health of Cisco Aironet 1500 and 1520 series outdoor access points as well as Cisco Aironet 1130 and 1240 series indoor access points when configured as mesh access points, except as noted. Tracking this environmental information is particularly critical for access points that are deployed outdoors. The following factors are monitored:

- **Temperature**: Displays the internal temperature of the access point in Fahrenheit and Celsius (Cisco Aironet 1510 and 1520 outdoor access points only).
- **Heater status**: Displays the heater as on or off (Cisco Aironet 1510 and 1520 outdoor access points only)
- **AP Up time**: Displays how long the access point has been active to receive and transmit.
- **LWAPP Join Taken Time**: Displays how long it took to establish the LWAPP connection (excluding Cisco Aironet 1505 access points).
Mesh Health information is displayed in the General Properties page for mesh access points. To view the mesh health details for a specific mesh access point, follow these steps:

**Step 1**

Choose **Monitor > Access Points**. A listing of radios belonging to access points appears (see Figure 5-42).

**Note**

The radio status (not an access point status) is displayed when you choose Monitor > Access Points. The given status is updated frequently from traps and wireless status polling and takes several minutes to reflect actual radio status. The overall status of an access point can be found by viewing the access point on a map.

**Note**

You can also use the New Search button to display the mesh access point summary shown Figure 5-42. With the New Search option, you can further define the criteria of the access points that display. Search criteria include AP Type, AP Mode, Radio Type, and 802.11n Support.

**Figure 5-42 Monitor > Access Points**

```
<table>
<thead>
<tr>
<th>AP Name</th>
<th>Radio</th>
<th>Status</th>
<th>Mesh Status</th>
<th>Radio Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>AP1</td>
<td>Radio1</td>
<td>Enabled</td>
<td>Mesh Up</td>
<td>Radio Up</td>
</tr>
<tr>
<td>AP2</td>
<td>Radio2</td>
<td>Enabled</td>
<td>Mesh Up</td>
<td>Radio Up</td>
</tr>
</tbody>
</table>
```

**Step 2**

Click the AP Name link to display details for that mesh access point. The General tab for that mesh access point appears (see Figure 5-43).

**Note**

You can also access the General tab for a mesh access point from a Cisco WCS map page. To display the page, double-click the mesh access point label. A tabbed page appears and displays the General tab for the selected access point.
Monitoring Mesh Networks Using Maps

Chapter 5      Monitoring Maps

Monitoring Mesh Networks Using Maps

Figure 5-43    AP Name > General Properties Tab

To add, remove, or reorder columns in the table, click the **Edit View** link in the Monitor > Access Points page. Table 5-10 displays optional access point parameters available from the Edit View page.

Table 5-10    Monitor Access Points Additional Search Results Parameters

<table>
<thead>
<tr>
<th>Column</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>AP Model</td>
<td>Indicates the model of the access point.</td>
</tr>
<tr>
<td>AP Type</td>
<td>Indicates the type of access point (unified or autonomous).</td>
</tr>
<tr>
<td>Antenna Azim. Angle</td>
<td>Indicates the horizontal angle of the antenna.</td>
</tr>
<tr>
<td>Antenna Diversity</td>
<td>Indicates if antenna diversity is enabled or disabled. Antenna diversity refers to the access point sampling the radio signal from two integrated antenna ports to choose the preferred antenna.</td>
</tr>
<tr>
<td>Antenna Elev. Angle</td>
<td>Indicates the elevation angle of the antenna.</td>
</tr>
<tr>
<td>Antenna Gain</td>
<td>The peak gain of the dBi of the antenna for directional antennas and the average gain in dBi for omni-directional antennas connected to the wireless network adapter. The gain is in multiples of 0.5 dBm. An integer value 4 means $4 \times 0.5 = 2$ dBm of gain.</td>
</tr>
<tr>
<td>Antenna Mode</td>
<td>Indicates the antenna mode such as omni, directional, or non-applicable.</td>
</tr>
<tr>
<td>Antenna Name</td>
<td>Indicates the antenna name or type.</td>
</tr>
<tr>
<td>Antenna Type</td>
<td>Indicates whether the antenna is internal or external.</td>
</tr>
</tbody>
</table>
### Table 5-10  Monitor Access Points Additional Search Results Parameters (continued)

<table>
<thead>
<tr>
<th>Column</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Audit Status</td>
<td>Indicates one of the following audit statuses:</td>
</tr>
<tr>
<td></td>
<td>• Mismatch—Config differences were found between WCS and controller during the last audit.</td>
</tr>
<tr>
<td></td>
<td>• Identical—No config differences were found during the last audit.</td>
</tr>
<tr>
<td></td>
<td>• Not Available—Audit status is unavailable.</td>
</tr>
<tr>
<td>Base Radio MAC</td>
<td>Indicates the MAC address of a radio.</td>
</tr>
<tr>
<td>Bridge Group Name</td>
<td>Indicates the name of the bridge group used to group the access points, if applicable.</td>
</tr>
<tr>
<td>CDP Neighbors</td>
<td>Indicates all directly connected Cisco devices.</td>
</tr>
<tr>
<td>Channel Control</td>
<td>Indicates whether the channel control is automatic or custom.</td>
</tr>
<tr>
<td>Channel Number</td>
<td>Indicates the channel on which the Cisco radio is broadcasting.</td>
</tr>
<tr>
<td>Controller Port</td>
<td>Indicates the number of controller ports.</td>
</tr>
<tr>
<td>Earth Location</td>
<td>Indicates whether a Google Earth location is assigned.</td>
</tr>
<tr>
<td>Location</td>
<td>The physical location of the access point.</td>
</tr>
<tr>
<td>Node Hops</td>
<td>Indicates the number of hops between access points.</td>
</tr>
<tr>
<td>OfficeExtend AP</td>
<td>Specifies if OfficeExtend AP is enabled or disabled. If it is disabled, the access point is</td>
</tr>
<tr>
<td></td>
<td>remotely deployed, which increases the security risk.</td>
</tr>
<tr>
<td>POE Status</td>
<td>Indicates the Power-over-Ethernet status of the access point. The possible values include:</td>
</tr>
<tr>
<td></td>
<td>• Low—The access point draws low power from the Ethernet.</td>
</tr>
<tr>
<td></td>
<td>• Lower than 15.4 volts—The access point draws lower than 15.4 volts from the Ethernet.</td>
</tr>
<tr>
<td></td>
<td>• Lower than 16.8 volts—The access point draws lower than 16.8 volts from the Ethernet.</td>
</tr>
<tr>
<td></td>
<td>• Normal—The power is high enough for the operation of the access point.</td>
</tr>
<tr>
<td></td>
<td>• Not Applicable—The power source is not from the Ethernet.</td>
</tr>
<tr>
<td>Primary Controller</td>
<td>Indicates the name of the primary controller for this access point.</td>
</tr>
<tr>
<td>Reg. Domain Supported</td>
<td>Indicates whether or not the regulatory domain is supported.</td>
</tr>
<tr>
<td>Serial Number</td>
<td>Indicates the serial number of an access point.</td>
</tr>
<tr>
<td>Slot</td>
<td>Indicates the slot number.</td>
</tr>
<tr>
<td>Tx Power Control</td>
<td>Indicates whether the transmission power control is automatic or custom.</td>
</tr>
<tr>
<td>Tx Power Level</td>
<td>Indicates the transmission power level.</td>
</tr>
<tr>
<td>Up Time</td>
<td>Indicates how long the access point has been up in days, hours, minutes, and seconds.</td>
</tr>
</tbody>
</table>
Mesh Statistics for an Access Point

Mesh Statistics are reported when a child mesh access point authenticates or associates with a parent mesh access point.

Security entries are removed and no longer displayed when the child mesh access point disassociates from the controller.

The following mesh security statistics are displayed for mesh access points:

- Bridging
- Queue
- Security

To view the mesh statistics for a specific mesh access point, follow these steps:

### Step 1
Choose Monitor > Access Points. A listing of radios belonging to access points appears (see Figure 5-42).

**Note**
The radio status (not an access point status) is displayed when you choose Monitor > Access Points. The given status is updated frequently from traps and wireless status polling and takes several minutes to reflect actual radio status. The overall status of an access point can be found by viewing the access point on a map.

**Note**
You can also use the New Search button to display the access point summary. With the New Search option, you can further define the criteria of the access points that display. Search criteria include AP Name, IP address, MAC address, Controller IP or Name, Radio type, and Outdoor area.

### Step 2
Click the AP Name link of the target mesh access point.

The General Properties tab appears for the selected access point.

### Step 3
Click the Mesh Statistics tab (see Figure 5-44). A bridging tab appears.

---

**Table 5-10 Monitor Access Points Additional Search Results Parameters (continued)**

<table>
<thead>
<tr>
<th>Column</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>WLAN Override Names</td>
<td>Indicates the WLAN override profile names.</td>
</tr>
<tr>
<td>WLAN Override</td>
<td>Indicates whether WLAN Override is enabled or disabled. Each access point is limited to sixteen WLAN profiles. Each access point broadcasts all WLAN profiles unless the WLAN override feature is enabled. The WLAN override feature allows you to disable any of the 16 WLAN profiles per access point.</td>
</tr>
</tbody>
</table>
The Mesh Statistics tab and its subordinate tabs (Bridging, Queue and Security) only appear for mesh access points. The Mesh Link Alarms and Mesh Link Events links are accessible from each of the three tabs.

You can also access the Mesh Securities page for a mesh access point from a Cisco WCS map. To display the page, double-click the mesh access point label.

Summaries of the Bridging, Queue and Security Statistics and their definitions are provided in Table 5-11, Table 5-12 and Table 5-13 respectively.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Role</td>
<td>The role of the mesh access point. Options are mesh access point (MAP) and root access point (RAP).</td>
</tr>
<tr>
<td>Bridge Group Name</td>
<td>The name of the bridge group to which the MAP or RAP is a member. Assigning membership in a bridge group name is recommended. If one is not assigned, a MAP is by default assigned to a default bridge group name.</td>
</tr>
<tr>
<td>Backhaul Interface</td>
<td>The radio backhaul for the mesh access point.</td>
</tr>
<tr>
<td>Routing State</td>
<td>The state of parent selection. Values that display are seek, scan, and maint. maint appears when parent selection is complete.</td>
</tr>
</tbody>
</table>
### Table 5-11  Bridging Mesh Statistics (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Malformed Neighbor Packets</td>
<td>The number of malformed packets received from the neighbor. Examples of malformed packets include malicious floods of traffic such as malformed or short DNS packets and malformed DNS replies.</td>
</tr>
<tr>
<td>Poor Neighbor SNR</td>
<td>The number of times the signal-to-noise ratio falls below 12 dB on the backhaul link.</td>
</tr>
<tr>
<td>Excluded Packets</td>
<td>The number of packets received from excluded neighbor mesh access points.</td>
</tr>
<tr>
<td>Insufficient Memory</td>
<td>The number of insufficient memory conditions.</td>
</tr>
<tr>
<td>RX Neighbor Requests</td>
<td>The number of broadcast and unicast requests received from the neighbor mesh access points.</td>
</tr>
<tr>
<td>RX Neighbor Responses</td>
<td>The number of responses received from the neighbor mesh access points.</td>
</tr>
<tr>
<td>TX Neighbor Requests</td>
<td>The number of unicast and broadcast requests sent to the neighbor mesh access points.</td>
</tr>
<tr>
<td>TX Neighbor Responses</td>
<td>The number of responses sent to the neighbor mesh access points.</td>
</tr>
<tr>
<td>Parent Changes</td>
<td>The number of times a mesh access point (child) moves to another parent.</td>
</tr>
<tr>
<td>Neighbor Timeouts</td>
<td>The number of neighbor timeouts.</td>
</tr>
<tr>
<td>Node Hops</td>
<td>The number of hops between the MAP and the RAP. Click the value link to display a pane which enables you to configure details of what is reported, how often the node hop value is updated, and view a graphical representation of the report.</td>
</tr>
</tbody>
</table>

### Table 5-12  Queue Mesh Statistics

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Silver Queue</td>
<td>The average and peak number of packets waiting in the silver (best effort) queue during the defined statistics time interval. Packets dropped and queue size is also summarized.</td>
</tr>
<tr>
<td>Gold Queue</td>
<td>The average and peak number of packets waiting in the gold (video) queue during the defined statistics time interval. Packets dropped and queue size is also summarized.</td>
</tr>
<tr>
<td>Platinum Queue</td>
<td>The average and peak number of packets waiting in the platinum (voice) queue during the defined statistics time interval. Packets dropped and queue size is also summarized.</td>
</tr>
</tbody>
</table>
### Table 5-12 Queue Mesh Statistics (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bronze Queue</td>
<td>The average and peak number of packets waiting in the bronze (background) queue during the defined statistics time interval. Packets dropped and queue size is also summarized.</td>
</tr>
<tr>
<td>Management Queue</td>
<td>The average and peak number of packets waiting in the management queue during the defined statistics time interval. Packets dropped and queue size is also summarized.</td>
</tr>
</tbody>
</table>

### Table 5-13 Security Mesh Statistics

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Packets Transmitted</td>
<td>Summarizes the total number of packets transmitted during security negotiations by the selected mesh access point.</td>
</tr>
<tr>
<td>Packets Received</td>
<td>Summarizes the total number of packets received during security negotiations by the selected mesh access point.</td>
</tr>
<tr>
<td>Association Request Failures</td>
<td>Summarizes the total number of association request failures that occur between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Association Request Timeouts</td>
<td>Summarizes the total number of association request time outs that occur between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Association Request Success</td>
<td>Summaries the total number of successful association requests that occur between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Authentication Request Failures</td>
<td>Summarizes the total number of failed authentication requests that occur between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Authentication Request Timeouts</td>
<td>Summarizes the total number of authentication request timeouts that occur between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Authentication Request Success</td>
<td>Summarizes the total number of successful authentication requests between the selected mesh access point and its parent mesh node.</td>
</tr>
<tr>
<td>Reassociation Request Failures</td>
<td>Summarizes the total number of failed reassociation requests between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Reassociation Request Timeouts</td>
<td>Summarizes the total number of reassociation request timeouts between the selected mesh access point and its parent.</td>
</tr>
</tbody>
</table>
Viewing the Mesh Network Hierarchy

You can view the parent-child relationship of mesh access points within a mesh network in an easily navigable display. You can also filter which access points display on the Map view, by selecting only access points of interest.

To view the mesh network hierarchy for a selected network, follow these steps:

**Step 1** Choose Monitor > Maps.

**Step 2** Select the map you want to display.

**Step 3** Select the AP Mesh Info check box in the left sidebar menu if it is not already selected.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reassociation Request Success</td>
<td>Summarizes the total number of successful reassociation requests between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Reauthentication Request Failures</td>
<td>Summarizes the total number of failed reauthentication requests between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Reauthentication Request Timeouts</td>
<td>Summarizes the total number of reauthentication request timeouts that occurred between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Reauthentication Request Success</td>
<td>Summarizes the total number of successful reauthentication requests that occurred between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Invalid Association Request</td>
<td>Summarizes the total number of invalid association requests received by the parent mesh access point from the selected child mesh access point. This state might occur when the selected child is a valid neighbor but is not in a state that allows association.</td>
</tr>
<tr>
<td>Unknown Association Requests</td>
<td>Summarizes the total number of unknown association requests received by the parent mesh access point from its child. The unknown association requests often occur when a child is an unknown neighbor mesh access point.</td>
</tr>
<tr>
<td>Invalid Reassociation Request</td>
<td>Summarizes the total number of invalid reassociation requests received by the parent mesh access point from a child. This might happen when a child is a valid neighbor but is not in a proper state for reassociation.</td>
</tr>
<tr>
<td>Unknown Reassociation Request</td>
<td>Summarizes the total number of unknown reassociation requests received by the parent mesh access point from a child. This might happen when a child mesh access point is an unknown neighbor.</td>
</tr>
</tbody>
</table>
Note The AP Mesh Info check box is only selectable if mesh access points are present on the map. It must be selected to view the mesh hierarchy.

Step 4 Click the AP Mesh Info arrow to display the mesh parent-child hierarchy (see Figure 5-45).

Figure 5-45  Mesh Parent-Child Hierarchical View

---

Step 5 Click the plus (+) sign next to a mesh access point to display its children.

All subordinate mesh access points are displayed when a negative (-) sign appears next to the parent mesh access point entry. For example, in Figure 5-45, the access point, indoor-mesh-45-rap2, has only one child, indoor-mesh-44-map2.

Step 6 Move the cursor over the colored dot next to each mesh access point child to view details on the link between it and its parent. Table 5-14 summarizes the parameters that appears.

The color of the dot also provides a quick reference point of the SNR strength.

- A green dot represents a high SNR (above 25 dB).
- An amber dot represents an acceptable SNR (20-25 dB).
- A red dot represents a low SNR (below 20 dB).
- A black dot indicates a root access point.
Viewing the Mesh Network Hierarchy

Using Mesh Filters to Modify Map Display of Maps and Mesh Links

In the mesh hierarchical page, you can also define mesh filters to determine which mesh access points display on the map based on hop values as well as what labels display for mesh links.

Mesh access points are filtered by the number of hops between them and their root access point.

To use mesh filtering, follow these steps:

**Step 1**
To modify what label and color displays for a mesh link, follow these steps:

a. In the Mesh Parent-Child Hierarchical View, select an option from the Link Label drop-down list. The options are None, Link SNR, and Packet Error Rate.

b. In the Mesh Parent-Child Hierarchical View, select an option from the Link Color drop-down list to define which parameter (Link SNR or Packet Error Rate) determines the color of the mesh link on the map.

**Note**
The color of the link provides a quick reference point of the SNR strength or Packet Error Rate. Table 5-15 defines the different link colors.

---

**Table 5-14  Bridging Link Information**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Information fetched on</td>
<td>Date and time that information was compiled.</td>
</tr>
<tr>
<td>Link SNR</td>
<td>Link signal-to-noise ratio (SNR).</td>
</tr>
<tr>
<td>Link Type</td>
<td>Hierarchical link relationship.</td>
</tr>
<tr>
<td>SNR Up</td>
<td>Signal-to-noise radio for the uplink (dB).</td>
</tr>
<tr>
<td>SNR Down</td>
<td>Signal-to-noise radio for the downlink (dB).</td>
</tr>
<tr>
<td>PER</td>
<td>The packet error rate for the link.</td>
</tr>
<tr>
<td>Tx Parent Packets</td>
<td>The TX packets to a node while acting as a parent.</td>
</tr>
<tr>
<td>Rx Parent Packets</td>
<td>The RX packets to a node while acting as a parent.</td>
</tr>
<tr>
<td>Time of Last Hello</td>
<td>Date and time of last hello.</td>
</tr>
</tbody>
</table>

---

**Table 5-15  Definition for SNR and Packet Error Rate Link Color**

<table>
<thead>
<tr>
<th>Link Color</th>
<th>Link SNR</th>
<th>Packet Error Rate (PER)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green</td>
<td>Represents a SNR above 25 dB (high value)</td>
<td>Represents a PER of one percent (1%) or lower</td>
</tr>
<tr>
<td>Amber</td>
<td>Represents a SNR between 20 and 25 dB (acceptable value)</td>
<td>Represents a PER that is less than ten percent (10%) and greater than one percent (1%)</td>
</tr>
<tr>
<td>Red</td>
<td>Represents a SNR below 20 dB (low value)</td>
<td>Represents a PER that is greater than ten percent (10%)</td>
</tr>
</tbody>
</table>
Note: The Link label and color settings are reflected on the map immediately (see Figure 5-46). You can display both SNR and PER values simultaneously.

Step 2: To modify which mesh access points display based on the number of hops between them and their parents, choose the appropriate option from the Quick selection drop-down list (see Table 5-16 for the list of available options):

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select only Root APs</td>
<td>Choose this setting if you want the map view to display root access points only.</td>
</tr>
<tr>
<td>Select up to 1st hops</td>
<td>Choose this setting if you want the map view to display 1st hops only.</td>
</tr>
<tr>
<td>Select up to 2nd hops</td>
<td>Choose this setting if you want the map view to display 2nd hops only.</td>
</tr>
<tr>
<td>Select up to 3rd hops</td>
<td>Choose this setting if you want the map view to display 3rd hops only.</td>
</tr>
<tr>
<td>Select up to 4th hops</td>
<td>Choose this setting if you want the map view to display 4th hops only.</td>
</tr>
<tr>
<td>Select All</td>
<td>Select this setting if you want the map view to display all access points.</td>
</tr>
</tbody>
</table>

c. Click **Update Map View** to refresh the screen and redisplay the map view with the selected options.

Note: Map view information is retrieved from the WCS database and is updated every 15 minutes.

Note: You can also select or unselect the check boxes of access points in the mesh hierarchical view to modify which mesh access points are displayed. For a child access point to be visible, the parent access point to root access point must be selected.

Note: If you want to have the MAC address appear with the client logo in the Monitor > Maps page, follow these steps:
   a) Go to the Maps Tree View.
   b) Click the > beside Clients.
   c) Unselect the **Small Icons** check box.
Monitoring Tags Using Maps

On a WCS map, you can review the name of the access point that generated the signal for a tagged asset, its strength of signal and when the location information was last updated for the asset. This information is display by simply passing the cursor over the asset tag icon on the map.

To enable tag location status on a map, follow these steps:

Step 1  Choose Monitor > Maps.

Step 2  Choose Building > Floor for the applicable mobility services engine and tag.

Step 3  Select the 802.11 Tags check box in the Floor Settings pane (left), if not already selected.

Note  Do not click Save Settings unless you want to save changes made to the Floor Settings across all maps.

Step 4  Move the cursor over a tag icon (yellow tag) and a summary of its configuration appears in a dialog box.

Step 5  Click the tag icon to see tag details.
Using Planning Mode

You can calculate the recommended number and location of access points based on whether data and/or voice traffic and/or location are active.

Note

Based on the throughput specified for each protocol (802.11a or 802.11 b/g), planning mode calculates the total number of access points required that would provide optimum coverage in your network.

Accessing Planning Mode

To access the Planning Mode feature, follow these steps:

Step 1  Choose Monitor > Maps.
Step 2  Select the desired campus or building from the Name list.
Step 3  Click the desired floor area in the Building.
Step 4  From the Select a command drop-down list, choose Planning Mode.
Step 5  Click Go.

Note

Planning mode does not use AP type or Antenna pattern information for calculating the number of access points required. The calculation is based on the access point coverage area or the number of users per access point.

Planning Mode options:

- Add APs—Enables you to add access points on a map. See the “Adding Access Points to a Floor Area” section on page 5-48 for details.
- Delete APs—Deletes the selected access points.
- Map Editor—Opens the Map Editor window. See the “Using Map Editors” section on page 5-71 for more details.
- Synchronize with Deployment—Synchronizes your planning mode access points with the current deployment scenario.
- Generate Proposal—View a planning summary of the current access points deployment.
- Planned AP Association Tool—Allows you to perform add, delete or import an AP Association from an excel or CSV file. Once an access point is defined, it can be associated to a base radio MAC address using the Planned AP Association Tool. If the AP is not discovered they get pushed into a standby bucket and get associated when discovered.

Note

AP association is subjected to a limitation that AP should not belong to any floor or outdoor area. If the AP is already assigned to a floor or outdoor area, then the standby bucket will hold the AP and when removed from the floor or outdoor, get positioned to the given floor. One Mac address cannot be put into bucket for multiple floor or outdoor areas.
Using Planning Mode

The WCS planning mode enables you to calculate the number of access points required to cover an area by placing fictitious access points on a map and allowing you to view the coverage area. Based on the throughput specified for each protocol (802.11a/n or 802.11b/g/n), planning mode calculates the total number of access points required to provide optimum coverage in your network. You can calculate the recommended number and location of access points based on the following criteria:

- traffic type active on the network: data or voice traffic or both
- location accuracy requirements
- number of active users
- number of users per square footage

To calculate the recommended number and placement of access points for a given deployment, follow these steps:

**Step 1** Choose Monitor > Maps.

The map pane appears (see Figure 5-47).

**Figure 5-47 Monitor > Maps Page**

**Step 2** Click the appropriate location link from the list that appears.

A color-coded map appears showing placement of all installed elements (access points, clients, tags) and their relative signal strength (see Figure 5-48).
Step 3  Choose **Planning Mode** from the Select a command drop-down list (top-right) and click **Go**. A blank floor map appears.

Step 4  Click **Add APs**.

Step 5  In the page that appears, drag the dashed-line rectangle over the map location for which you want to calculate the recommended access points (see Figure 5-49).

**Note** Adjust the size or placement of the rectangle by selecting the edge of the rectangle and holding down the **Ctrl** key. Move the mouse as necessary to outline the targeted location.
**Step 6** Select *Automatic* from the Add APs drop-down list.

**Step 7** Select the AP Type and the appropriate antenna and protocol for that access point.

**Step 8** Select the target throughput for the access point.

**Step 9** Select the box(es) next to the service(s) that will be used on the floor. Options are Data/Coverage (default), Voice, Location, and Location with Monitor Mode APs. (see Table 5-17).

---

**Note** You must select at least one service or an error occurs.

**Note** If you select the Advanced Options box, two additional access point planning options appear: Demand and Override Coverage per AP. Additionally, a Safety Margin parameter appears for the Data/Coverage and Voice safety margin options.

---

**Table 5-17** Definition of Services Options

<table>
<thead>
<tr>
<th>Service Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data/Coverage</td>
<td>Select if data traffic is transmitted on the wireless LAN. The following densities are used depending on the band and data rates:</td>
</tr>
<tr>
<td></td>
<td>Band</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Table 5-17  Definition of Services Options (continued)

<table>
<thead>
<tr>
<th>Service Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>802.11a</td>
<td>–3.3</td>
</tr>
<tr>
<td>802.11a</td>
<td>–3.3</td>
</tr>
<tr>
<td>802.11a</td>
<td>–3.5</td>
</tr>
<tr>
<td>802.11a</td>
<td>–3.5</td>
</tr>
<tr>
<td>802.11bg</td>
<td>–3.3</td>
</tr>
<tr>
<td>802.11bg</td>
<td>–3.3</td>
</tr>
<tr>
<td>802.11bg</td>
<td>–3.5</td>
</tr>
<tr>
<td>802.11bg</td>
<td>–3.5</td>
</tr>
</tbody>
</table>

If you select the Advanced Options (check box), you can select the desired safety margin (aggressive, safe, or very safe) of the signal strength threshold for data.

- Aggressive = Minimum (–3 dBm)
- Safe = Medium (0 dBm)
- Very Safe = Maximum (+3 dBm)

Voice

Select if voice traffic is transmitted on the wireless LAN.

If you select the Advanced Options (check box), you can select the desired safety margin (aggressive, safe, very safe or 7920-enabled) of the signal strength threshold for voice.

- Aggressive = Minimum [–78 dBm (802.11a/b/g)]
- Safe = Medium [–75 dBm (802.11a/b/g)]
- Very Safe = Maximum [(–72 dBm (802.11a/b/g)]
- 7920_enabled = [(–72 dBm (802.11a)); (–67 dBm (802.11b/g)]

Location

Select to ensure that the recommended access point calculation provides the true location of an element within 10 meters at least 90% of the time.

To meet the criteria, access points are collocated within 70 feet of each other in a hexagonal pattern employing staggered and perimeter placement.

Note  Each service option includes all services that are listed above it. For example, if you select the Location check box, the calculation considers data/coverage, voice, and location in determining the optimum number of access points required.
Table 5-18  Definition of Advanced Services

<table>
<thead>
<tr>
<th>Service Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data/Coverage</td>
<td>Select if data traffic is transmitted on the wireless LAN. The following densities are used depending on the band and data rates:</td>
</tr>
<tr>
<td></td>
<td>Band</td>
</tr>
<tr>
<td>802.11a</td>
<td></td>
</tr>
<tr>
<td>802.11a</td>
<td></td>
</tr>
<tr>
<td>802.11a</td>
<td></td>
</tr>
<tr>
<td>802.11a</td>
<td></td>
</tr>
<tr>
<td>802.11bg</td>
<td></td>
</tr>
<tr>
<td>802.11bg</td>
<td></td>
</tr>
<tr>
<td>802.11bg</td>
<td></td>
</tr>
<tr>
<td>802.11bg</td>
<td></td>
</tr>
</tbody>
</table>

If you select the Advanced Options (check box), you can select the desired safety margin (aggressive, safe, or very safe) of the signal strength threshold for data.

- Aggressive = Minimum (–3 dBm)
- Safe = Medium (0 dBm)
- Very Safe = Maximum (+3 dBm)

Voice

Select if voice traffic is transmitted on the wireless LAN.

If you select the Advanced Options (check box), you can select the desired safety margin (aggressive, safe, very safe or 7920-enabled) of the signal strength threshold for voice.

- Aggressive = Minimum [–78 dBm (802.11a/b/g)]
- Safe = Medium [–75 dBm (802.11a/b/g)]
- Very Safe = Maximum [{–72 dBm (802.11a/b/g)]

7920_enabled = [{–72 dBm (802.11a); –67 dBm (802.11b/g)]

Location

Select to ensure that the recommended access point calculation provides the true location of an element within 10 meters at least 90% of the time.

To meet the criteria, access points are collocated within 70 feet of each other in a hexagonal pattern employing staggered and perimeter placement.

Note  Each service option includes all services that are listed above it. For example, if you select the Location check box, the calculation considers data/coverage, voice, and location in determining the optimum number of access points required.

Demand

Select if you want to use the total number of users or user ratio per access point as a basis for the access point calculation.
Table 5-18 Definition of Advanced Services (continued)

<table>
<thead>
<tr>
<th>Service Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Override Coverage per AP</td>
<td>Select if you want to specify square foot coverage as the basis for access point coverage.</td>
</tr>
<tr>
<td>Safety Margin</td>
<td>Select option to qualify relative signal strength requirements for data and voice service in the access point calculation. The available options are: Aggressive, Safe, Very Safe, and 7920-enabled (voice only). Select Aggressive to require minimal signal strength requirements in the calculation and Very Safe to request the highest signal strength.</td>
</tr>
</tbody>
</table>

Step 10 Click Calculate.

The recommended number of access points given the selected services appears (see Figure 5-50).

Figure 5-50 Recommended Number of Access Points Given Selected Services and Parameters

Note Recommended calculations assume the need for consistently strong signals unless adjusted downward by the safety margin advanced option. In some cases, the recommended number of access points is higher than what is required.
Step 11 Click **Apply** to generate a map that shows proposed deployment of the recommended access points in the selected area based on the selected services and parameters (see Figure 5-51).

**Figure 5-51**  **Recommended Access Point Deployment Given Selected Services and Parameters**

Step 12 Choose **Generate Proposal** to display a textual and graphical report of the recommended access point number and deployment based on the given input.

**Refresh Options**

To prepare for monitoring your wireless LANs, become familiar with the various refresh options for a map.

- **Load**—The Load option in the left sidebar menu refreshes map data from the WCS database on demand (see callout 1 in Figure 5-52).
- **Auto Refresh**—The Auto Refresh option (see callout 2 in Figure 5-52) provides an interval drop-down list to set how often to refresh the map data from the database.
- **Refresh from network**—By clicking the **Refresh from network** icon to the right of the Auto Refresh drop-down list (see callout 2 in Figure 5-52), you can refresh the map status and statistics directly from the controller through an SNMP fetch rather than polled data from the WCS database that is five to fifteen minutes older.
Creating a Network Design

After access points have been installed and have joined a controller, and WCS has been configured to manage the controllers, set up a network design. A *network design* is a representation within WCS of the physical placement of access points throughout facilities. A hierarchy of a single campus, the buildings that comprise that campus, and the floors of each building constitute a single network design. These steps assume that the location appliance is set to poll the controllers in that network, as well as be configured to synchronize with that specific network design, to track devices in that environment. The concept and steps to perform synchronization between WCS and the mobility service engine are explained in the *Cisco 3350 Mobility Services Engine Configuration Guide*.

Designing a Network

To design a network, follow these steps:

**Step 1** Open the WCS web interface and log in.

**Note** To create or edit a network design, you must log into WCS and have SuperUser, Admin, or ConfigManager access privileges.

**Step 2** Choose Monitor > Maps.
Creating a Network Design

**Step 3**
From the drop-down list on the right-hand side, choose either **New Campus** or **New Building**, depending on the size of the network design and the organization of maps. If you chose New Campus, continue to Step 4. To create a building without a campus, skip to **Step 14**.

**Step 4**
Click **Go**.

**Step 5**
Enter a name for the campus network design, a contact name, and the file path to the campus image file. .bmps and .jpgs are importable.

**Note**
You can use the Browse button to navigate to the location.

**Step 6**
Click **Next**.

**Step 7**
Select the **Maintain Aspect Ratio** check box. Enabling this check box causes the horizontal span of the campus to be 5000 feet and adjusts the vertical span according to the aspect ratio of the image file. Adjusting either the horizontal or vertical span changes the other field in accordance with the image ratio.

You should unselect the Maintain Aspect Ratio check box if you want to override this automatic adjustment. You could then adjust both span values to match the real world campus dimensions.

**Step 8**
Click **OK**.

**Step 9**
In the Monitor > Maps page, click the hyperlink associated with the above-made campus map. A window showing the new campus image is displayed.

**Step 10**
From the drop-down list on the upper right of the window, select **New Building**, and click **Go**.

**Step 11**
Enter the name of the building, the contact person, the number of floors and basements in the building, and the dimensions. Click **OK**.

**Step 12**
Indicate which building on the campus map is the correct building by clicking the blue box in the upper left of the campus image and dragging it to the intended location (see **Figure 5-53**). To resize the blue box, hold down the **Ctrl** key and click and drag to adjust its horizontal size. You can also enter dimensions of the building by entering numerical values in the Horizontal Span and Vertical Span fields and click **Place**. After resizing, reposition the blue box if necessary by clicking on it and dragging it to the desired location. Click **Save**.

**Figure 5-53 Repositioning Building Highlighted in Blue**
Step 13  WCS is then returned to the campus image with the newly created building highlighted in a green box. Click the green box (see Figure 5-54).

Figure 5-54  Newly Created Building Highlighted in Green

Step 14  To create a building without a campus, choose New Building, and click Go.

Step 15  Enter the name of the building, contact information, number of floors and basements, and dimension information. Click Save. WCS is returned to the Monitor > Maps page.

Step 16  Click the hyperlink associated with the newly created building.
Step 17 On the Monitor > Maps > [Campus Name] > [Building Name] window, go to the drop-down list and choose New Floor Area. Click Go.

Step 18 Enter a name for the floor, a contact, a floor number, floor type, and height at which the access points are installed and the path of the floor image. Click Next.

Note The Floor Type (RF Model) field specifies the type of environment on that specific floor. This RF Model indicates the amount of RF signal attenuation likely to be present on that floor. If the available models do not properly characterize a floor's makeup, details on how to create RF models specific to a floor's attenuation characteristics are available in the Cisco 3350 Mobility Services Engine Configuration Guide.

Step 19 If the floor area is a different dimension than the building, adjust floor dimensions by either making numerical changes to the text fields under the Dimensions heading or by holding the Ctrl key and clicking and dragging the blue box around the floor image. If the floor's location is offset from the upper left corner of the building, change the placement of the floor within the building by either clicking and dragging the blue box to the desired location or by altering the numerical values under the Coordinates of top left corner heading (see Figure 5-55). After making changes to any numerical values, click Place.

Figure 5-55 Repositioning Using Numerical Value Fields
Step 20 Adjust the floor’s characteristics with the WCS map editor by selecting the Launch Map Editor after floor creation check box. For an explanation of the map editor feature, see the “Using Map Editors” section on page 5-71.

Step 21 In the new floor’s image page (Monitor > Maps > [CampusName] > [BuildingName] > [FloorName]), choose Add Access Points from the drop-down list. Click Go.

Step 22 All access points that are connected to controllers are displayed. Even controllers that WCS is configured to manage but which have not yet been added to another floor map are displayed. Select the access points to be placed on the specific floor map by selecting the check boxes to the left of the access point entries. Select the check box to the left of the Name column to select all access points. Click OK.

Step 23 Each access point you have chosen to add to the floor map is represented by a gray circle (differentiated by access point name or MAC address) and is lined up in the upper-left part of the floor map. Drag each access point to the appropriate location. (Access points turn blue when you click them to relocate.) The small black arrow at the side of each access point represents Side A of each access point, and each access point’s arrow must correspond with the direction in which the access points were installed. (Side A is clearly noted on each 1000 series access point and has no relevance to the 802.11a/n radio.)
Importing or Exporting WLSE Map Data

When you convert an access point from autonomous to CAPWAP and from WLSE to WCS, one of the conversion steps is to manually re-enter the access point information into WCS. This can be a time-consuming step. To speed up the process, you can export the information about access points from WLSE and import it into WCS.

**Note**
WCS expects a .tar file and checks for a .tar extension before importing the file. If the file you are trying to import is not a .tar file, WCS displays an error message and prompts you to import a different file.

To map properties and import a tar file containing WLSE data using the WCS web interface, follow these steps. For more information on the WLSE data export functionality (WLSE version 2.15), see [http://<WLSE_IP_ADDRESS>:1741/debug/export/exportSite.jsp](http://<WLSE_IP_ADDRESS>:1741/debug/export/exportSite.jsp).

**Step 1**  Choose **Monitor > Maps**.

**Step 2**  Choose **Properties** from the Select a command drop-down list, and click **Go**.

**Step 3**  In the Export/Import AP/LS/SP Placement section, click **Browse** to select the file to import.

**Step 4**  Find and select the .tar file to import, and click **Open**.

WCS displays the name of the file in the Import From field.

**Step 5**  Click **Import**.

WCS uploads the file and temporarily saves it into a local directory while it is being processed. If the file contains data that cannot be processed, WCS prompts you to correct the problem and retry. After the file has been loaded, WCS displays a report of what will be added to WCS. The report also specifies what cannot be added and why.

If some of the data to be imported already exists, WCS either uses the existing data in the case of campuses or overwrites the existing data using the imported data in the cases of buildings and floors.

If there are duplicate names between a WLSE site and building combination and a WCS campus (or top-level building) and building combination, WCS displays a message in the Pre Execute Import Report indicating that it will delete the existing building.

**Step 6**  Click **Import** to import the WLSE data.

WCS displays a report indicating what was imported.
Device Details

Access Point Details

Hold your mouse cursor over an access point icon to view access point details (Figure 5-56). Click the appropriate tab to view access point and radio information.

Note: Monitor mode access points are shown with gray labels to distinguish them from other access points.

The AP Info tab includes the following access point information:

- MAC address
- Access point model
- Controller
- Location
- Access point height
- Access point uptime
- LWAPP uptime

Note: From the AP Info tab, you can run a ping test by clicking the Run Ping Test link.
The 802.11 tabs (Figure 5-57) includes the following radio information:

- Channel number
- Extension channel
- Channel width
- Transmit power level
- Client count

**Note** The number of clients associated to access points may not match the total number of clients.

- Receiving and transmitting utilization percentages
- Channel utilization percentage

**Note** Total utilization = (Rx + Tx + Channel utilization) scaled to 100%.

- Antenna name and angle
- Elevation angle

**Note** From either of the 802.11 tabs, you can view Rx neighbors and radio details for this access point by clicking the appropriate link (View Rx Neighbors or View Radio Details).

- Dot11n Enabled
- CleanAir Status—Displays the CleanAir status of the access point, whether or not CleanAir is enabled on the access point.
- Average Air Quality—Displays the average air quality on this access point.
- Minimum Air Quality—Displays the minimum air quality on this access point.
Client Details

Hold your mouse cursor over a client icon to view client details (Figure 5-58).

Client details information includes the following:

- Username
- IP address
- Asset name, group, and category
- Status
- Auth
Tag Details

Hold your mouse cursor over a tag icon to view tag details (Figure 5-59).

Tag details includes the following:
- Asset name, group, and category
- Type
- Battery life
- Last located

Rogue Access Point Details

Hold your mouse cursor over an access point icon to view rogue access point details (Figure 5-60).
Rogue access point details includes the following:

- Classification type—Friendly, malicious, or unknown.
- State
- Detecting access points
- Type
- Rogue clients
- First seen
- Last seen
- On network
- Last located

**Rogue Adhoc Details**

Hold your mouse cursor over an access point icon to view rogue ad hoc details.

**Rogue Client Details**

Hold your mouse cursor over an access point icon to view rogue client details (Figure 5-61).

**Interferer Details**

Hold your mouse cursor over an interferer icon to view its details. Interferer details includes the following:

- Interferer Name—The name of the interfering device.
- Affected Channels—The channel the interfering device is affecting.
- Detected Time—The time at which the interference was detected.
- Severity—The severity index of the interfering device.
- Duty Cycle—The duty cycle (in percentage) of the interfering device.
- RSSI (dBm)—The Received Signal Strength Indicator of the interfering device.

**Figure 5-61 Rogue Client Details Page**

Rogue client details include:
- State
- Associated rogue access point
- Detecting access points
- First seen
- Last seen
- Last located

**Floor View Navigation**

The main Floor View navigation page (Figure 5-62) provides access to multiple map functions.

**Figure 5-62 Floor View Navigation Page**

This navigation page includes the following functionality:
Chapter 5      Monitoring Maps

- **Zoom In/Zoom Out**—Click the magnifying glass icon with the plus sign (+) to enlarge the map view. Click the magnifying glass icon with the minus sign (-) to decrease the size of the map view.

- **Map Size**—Use the map size drop-down list to manually select the map view size (ranging from 50% to 800%).

- **Show Grid**—Click to show or hide the grid that displays distance in feet on the map.

- **RSSI Legend**—Hold your mouse cursor over the RSSI Legend icon to display the RSSI color scheme (ranging from red/-35 dBm to dark blue/-90 dBm).

- **Add Access Points**—Click to open the Add Access Points window. See the “Adding Access Points to a Floor Area” section on page 5-48 for more information.

- **Remove Access Points**—Click to open the Remove Access Points window. Select the access points that you want to remove, and click **OK**.

- **Position Access Points**—Click to open the Position Access Points window. See the “Placing Access Points” section on page 5-54 for more information.

- **Add Chokepoints**—Click to open the Add Chokepoints window. Refer to the Cisco Context-Aware Services Configuration Guide for more information.

- **Add WiFi TDOA Receivers**—Click to open the Add Wi-Fi TDOA Receivers window. Refer to the Cisco Context-Aware Services Configuration Guide for more information.

- **Auto Refresh**—From the drop-down list, select the length of time between each system refresh.

- **Refresh from Network**—Click to initiate an immediate refresh of the current data.

- **Planning Mode**—Click to open the Planning Mode window. See the “Using Planning Mode” section on page 5-101 for more information.

- **Map Editor**—Click to open the Map Editor.

**Full Screen**—Click to increase the size of the map to full screen. Once there, click **Exit Full Screen** to return to the normal view.
Monitoring Wireless Devices

Information About Monitoring

This chapter describes how to use WCS to monitor Cisco WLAN Solution device configurations. It contains the following sections:

- Monitoring Controllers, page 6-1
- Monitoring Access Points, page 6-23
- Monitoring Channel Width, page 6-55
- Viewing Clients Identified as WGBs, page 6-58
- Retrieving the Unique Device Identifier on Controllers and Access Points, page 6-59
- Monitoring Coverage Hole, page 6-62
- Monitoring Tags, page 6-64
- Monitoring Chokepoints, page 6-67
- Monitoring Interferers, page 6-67
- Monitoring WiFi TDOA Receivers, page 6-71
- Monitoring Spectrum Experts, page 6-71
- Monitoring Media Streams, page 6-73
- Monitoring Interactive Graphs, page 6-75
- Monitoring Radio Resource Management (RRM), page 6-77
- Monitoring Alarms, page 6-80
- Monitoring Rogue Access Points, page 6-88
- Monitoring Adhoc Rogues, page 6-103
- Monitoring Rogue Access Point Location, Tagging, and Containment, page 6-110
- Monitoring Events, page 6-124

Monitoring Controllers

Choose Monitor > Controllers to access the controller summary page. Click a controller IP address to view its details.

This section contains the following topics:
Searching Controllers

This section describes how to use the WCS Search feature to find specific controllers or to create and save custom searches. This section contains the following topics:

- Using the Search Feature, page 2-34
- Quick Search, page 2-34
- Advanced Search, page 2-35
- Saved Searches, page 2-46

For a controller search, you can search using the following parameters:

- Search for controller by—Choose All Controllers, IP Address, Controller Name, or Network.

  Note: Search parameters may change depending on the selected category. When applicable, enter the additional parameter or filter information to help identify the Search By category.

- Enter Controller IP Address—This field only appears if you select IP Address from the Search for controller by field.
- Enter Controller Name—This field only appears if you select Controller Name from the Search for controller by field.
- Select a Network
- Audit Status—Choose one of the following from the drop-down list:
  - All Status
  - Mismatch—Config differences were found between WCS and controller during the last audit.
  - Identical—No config differences were found during the last audit.
  - Not Available—Audit status is unavailable.

Viewing Controller Search Results

Choose Monitor > Controllers or perform a controller search to access this page.
Note
See the “Advanced Search” section on page 2-35 for more information on performing an advanced search.

The data area of this page contains a table with the following columns:
- **IP Address**—Local network IP address of the controller. Click the title to toggle from ascending to descending order. Click an IP address in the list to display Monitoring System Summary.
- **Controller Name**—Click the title to toggle from ascending to descending order.
- **Location**—The geographical location (such as a campus or building). Click the title to toggle from ascending to descending order.
- **Mobility Group Name**—Name of the controller mobility or WPS group.
- **Reachability Status**—Reachable or Unreachable. Click the title to toggle from ascending to descending order.

To add, remove, or reorder columns in the table, click the **Edit View** link to go to the Edit View page.

### Configuring the Search Results Display

The **Edit View** page allows you to add, remove, or reorder columns in the Controllers table.

To edit the available columns in the controllers table, follow these steps:

**Step 1** Choose **Monitor > Controllers**.

**Step 2** Click the **Edit View** link.

**Step 3** To add an additional column to the controllers table, click to highlight the column heading in the left list. Click **Show** to move the heading to the right list. All items in the right list are displayed in the controllers table.

**Step 4** To remove a column from the controllers table, click to highlight the list heading in the right list. Click **Hide** to move the heading to the left list. All items in the left list are not displayed in the controllers table.

**Step 5** Use the **Up/Down** buttons to specify the order in which the information appears in the table. Highlight the desired list heading and click **Up or Down** to move it higher or lower in the current list.

**Step 6** Click **Reset** to restore the default view.

**Step 7** Click **Submit** to confirm the changes.

### Monitoring System Parameters

This section provides detailed information regarding monitoring controller system parameters and contains the following topics:
- Monitoring System Summary, page 6-4
- Monitoring Spanning Tree Protocol, page 6-5
- Monitoring CLI Sessions, page 6-6
- Monitoring DHCP Statistics, page 6-7
Monitoring System Summary

This page displays a summary of the controller parameters with a graphic displaying the status of the controller. The graphic of the front of the controller shows front-panel ports (click a port to go to Monitor Controllers > IPaddr > Ports > General for information about that port).

To access this page:

- Choose Monitor > Controllers and click the applicable IP address.
- Choose Monitor > Access Points, click a list item under AP Name, and then click Registered Controller.
- Choose Configure > Access Points, choose a list item under AP Name, then click Registered Controller.

Click Controllers in the page title to view a list of all the controllers. See the “Viewing Controller Search Results” section on page 6-2.

The following parameters display:

**General**

- IP Address—Local network IP address of the controller.
- Name—User-defined name of the controller.
- Type
- UP Time—Time in days, hours and minutes since the last reboot.
- System Time—Time used by the controller.
- Internal Temperature
- Location—User-defined physical location of the controller.
- Contact

**Inventory**

- Total Client Count—Total number of clients currently associated with the controller.
- Current LWAPP Transport Mode—Lightweight Access Point Protocol transport mode. Communications between controllers and access points. Selections are Layer 2 or Layer 3.
- Power Supply One
- Power Supply Two

- Software Version—The operating system release.version.dot.maintenance number of the code currently running on the controller.
- Emergency Image Version.
- Description—Description of the inventory item.
- Model No.—Specifies the machine model as defined by the Vital Product Data.
- Serial No.—Unique serial number for this controller.
- Burned-in MAC Address—The burned-in MAC address for this controller.
- Number of APs Supported—The maximum number of access points supported by the controller.
- Gig Ethernet/Fiber Card—Displays the presence or absence of the optional 1000BASE-T/1000BASE-SX GigE card.
- Crypto Card One—Displays the presence or absence of an enhanced security module which enables IPsec security and provides enhanced processing power.
Chapter 6  Monitoring Wireless Devices

Monitoring Controllers

Note  By default, enhanced security module is not installed on a controller.

Maximum number of crypto cards that can be installed on a Cisco Wireless LAN controller:
- Cisco 2000 Series—None
- Cisco 4100 Series—One
- Cisco 4400 Series—Two

- Crypto Card Two—Displays the presence or absence of a second enhanced security module.
- GIGE Port(s) Status—Up or Down. Click to review the status of the port.

Unique Device Identifier (UDI)
- Name—Product type. Chassis for controller and Cisco AP for access points.
- Description—Description of controller and may include number of access points.
- Product ID—Orderable product identifier.
- Version ID—Version of product identifier.
- Serial Number—Unique product serial number.

Access Points
- Access Points—Name of the access point. Click to access the Monitor > Access Point Details page. See the “Monitoring Access Points Details” section on page 6-34 for more information.
- MAC Address
- Port—Controller port number connected or assigned to the access point.
- Status—Status of the access point. Colored icon: Red (down), Yellow (alarm) or Green (up).

WIPS Profile—Displays the current Cisco Adaptive Wireless IPS profiles for this controller. Click the profile name to view profile details. See the “Configuring wIPS Profiles” section on page 9-211 for more information.

Alarms—Click to go to the Monitor > Alarms page. See the “Monitoring Alarms” section on page 6-80 for more information.

Events—Click to go to the Monitor > Events page. See the “Monitoring Events” section on page 6-124 for more information.

Monitoring Spanning Tree Protocol

The Spanning Tree Protocol (STP) is a link management protocol. Cisco WLAN Solution implements the IEEE 802.1D standard for media access control bridges.

Spanning tree algorithm provides redundancy while preventing undesirable loops in a network that are created by multiple active paths between stations. STP allows only one active path at a time between any two network devices (this prevents the loops) but establishes the redundant links as a backup if the initial link should fail.

You can access this page in the following ways:
- Choose Monitor > Controllers, select an IP address, and choose System > Spanning Tree Protocol from the left sidebar menu.
- Choose Monitor > Clients, click a list item under AP Name, click Registered Controller, then choose System > Spanning Tree Protocol from the left sidebar menu.
This page enables you to view the following Spanning Tree Algorithm parameters:

**General**

- **Spanning Tree Specification**—An indication of what version of the Spanning Tree Protocol is being run. IEEE 802.1D implementations will return 'IEEE 802.1D'. If future versions of the IEEE Spanning Tree Protocol are released that are incompatible with the current version a new value will be defined.

- **Spanning Tree Algorithm**—Specifies if this controller will participate in the Spanning Tree Protocol. May be enabled or disabled by selecting the corresponding line on the drop-down list entry field. The factory default is disabled.

- **Priority**—The value of the writable portion of the Bridge ID, that is, the first two octets of the (8 octet long) Bridge ID. The other (last) 6 octets of the Bridge ID are given by the value of Bridge MAC Address. The value may be specified as a number between 0 and 65535. The factory default is 32768.

**STP Statistics**

- **Topology Change Count**—The total number of topology changes detected by this bridge since the management entity was last reset or initialized.

- **Time Since Topology Changed**—The total number of topology changes detected by this bridge since the management entity was last reset or initialized.

- **Designated Root**—The bridge identifier of the root of the spanning tree as determined by the Spanning Tree Protocol as executed by this node. This value is used as the Root Identifier parameter in all Configuration Bridge PDUs originated by this node.

- **Root Cost**—The cost of the path to the root as seen from this bridge.

- **Root Port**—The port number of the port which offers the lowest cost path from this bridge to the root bridge.

- **Maximum Age (seconds)**—The value that all bridges use for MaxAge when this bridge is acting as the root.

  **Note**  
  The 802.1D-1990 specifies that the range for this parameter is related to the value of Stp Bridge Hello Time. The granularity of this timer is specified by 802.1D-1990 to be 1 second. Valid values are 6 through 40 seconds. The factory default is 20.

- **Hello Time (seconds)**—The value that all bridges use for HelloTime when this bridge is acting as the root. The granularity of this timer is specified by 802.1D-1990 to be 1 second. Valid values are 1 through 10 seconds. The factory default is 2.

- **Forward Delay (seconds)**—The value that all bridges use for ForwardDelay when this bridge is acting as the root. Note that 802.1D-1990 specifies that the range for this parameter is related to the value of Stp Bridge Maximum Age. The granularity of this timer is specified by 802.1D-1990 to be 1 second. An agent may return a badValue error if a set is attempted to a value which is not a whole number of seconds. Valid values are 4 through 30 seconds. The factory default is 15.

- **Hold Time (seconds)**—The minimum time period to elapse between the transmission of Configuration BPDUs through a given LAN Port: at most one Configuration BPDU shall be transmitted in any Hold Time period.

**Monitoring CLI Sessions**

The CLI Sessions page for a controller can be accessed in the following ways:
Choose **Monitor > Controllers**, click the applicable IP address, then choose **System > CLI Sessions** from the left sidebar menu.

Choose **Monitor > Clients**, click a list item under AP Name, click **Registered Controller**, then select **System > CLI Sessions** from the left sidebar menu.

This page provides a list of open command-line interface sessions. It details the following information:

<table>
<thead>
<tr>
<th>CLI Session Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Session Index—Session identification.</td>
</tr>
<tr>
<td>Username—Login username.</td>
</tr>
<tr>
<td>Connection Type—Telnet or serial session.</td>
</tr>
<tr>
<td>Connection From—IP address of the client computer system.</td>
</tr>
<tr>
<td>Session Time—Elapsed active session time.</td>
</tr>
<tr>
<td>Idle Time—Elapsed inactive session time.</td>
</tr>
</tbody>
</table>

### Monitoring DHCP Statistics

WCS provides DHCP server statistics for version 5.0.6.0 controllers or later. These statistics include information on the packets sent and received, DHCP server response information, last request timestamp.

To access this page, choose **Monitor > Controllers**, click the applicable IP address, then select **System > DHCP Statistics** from the left sidebar menu.

The DHCP Statistics page provides the following information:

<table>
<thead>
<tr>
<th>DHCP Statistics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server IP—Identifies the IP address of the server.</td>
</tr>
<tr>
<td>Is Proxy—Identifies whether or not this server is proxy.</td>
</tr>
<tr>
<td>Discover Packets Sent—Identifies the total number of packets sent intended to locate available servers.</td>
</tr>
<tr>
<td>Request Packets Sent—Identifies the total number of packets sent from the client requesting parameters from the server or confirming the correctness of an address.</td>
</tr>
<tr>
<td>Decline Packets—Identifies the number of packets indicating that the network address is already in use.</td>
</tr>
<tr>
<td>Inform Packets—Identifies the number of client requests to the DHCP server for local configuration parameters because the client already has an externally configured network address.</td>
</tr>
<tr>
<td>Release Packets—Identifies the number of packets that release the network address and cancel the remaining lease.</td>
</tr>
<tr>
<td>Reply Packets—Identifies the number of reply packets.</td>
</tr>
<tr>
<td>Offer Packets—Identifies the number of packets that respond to the discover packets with an offer of configuration parameters.</td>
</tr>
<tr>
<td>Ack Packets—Identifies the number of packets that acknowledge successful transmission.</td>
</tr>
<tr>
<td>Nak—Identifies the number of packets that indicate that the transmission occurred with errors.</td>
</tr>
<tr>
<td>Tx Failures—Identifies the number of transfer failures that occurred.</td>
</tr>
<tr>
<td>Last Response Received—Provides a timestamp of the last response received.</td>
</tr>
</tbody>
</table>
• Last Request Sent—Provides a timestamp of the last request sent.

Monitoring WLANs

This page enables you to view a summary of the wireless local access networks (WLANs) that you have configured on this controller:

• WLAN ID—Identification number of the WLAN.
• Profile Name—User-defined profile name specified when initially creating the WLAN. Profile Name is the WLAN name.
• SSID—User-defined SSID name.
• Security Policies—Security policies enabled on the WLAN.
• Admin Status—Status of the WLAN is either enabled or disabled.
• No. of Clients—Current number of clients currently associated with this WLAN.

To access this page, choose Monitor > Controllers, click a controller IP address, and choose WLANs from the left sidebar menu.

Monitoring Ports

Select one of the following for detailed information regarding monitoring controller port parameters:

• Monitoring General Ports, page 6-8
• Monitoring CDP Interface Neighbors, page 6-11

Monitoring General Ports

The Ports > General page provides information regarding physical ports on the selected controller. Click a port number to view details for that port. See the “Port Details” section on page 6-9 for more information.

General port information includes the following:

• Port—Click the port number to view port details. See the “Port Details” section on page 6-9 for more information.
• Physical Mode—Displays the physical mode of all ports. Selections include:
  - 100 Mbps Full Duplex
  - 100 Mbps Half Duplex
  - 10 Mbps Full Duplex
  - 10 Mbps Half Duplex
• Admin Status—Displays the state of the port of either Enable or Disable.
• STP State—Displays the STP state of the port of either Forwarding or Disabled.
• Physical Status—Displays the actual port physical interface:
  - Auto Negotiate
Chapter 6  Monitoring Wireless Devices

- Half Duplex 10 Mbps
- Full Duplex 10 Mbps
- Half Duplex 100 Mbps
- Full Duplex 100 Mbps
- Full Duplex 1 Gbps

- Link Status—Red (down/failure), Yellow (alarm), Green (up/normal).

To access the Monitor > Ports > General page, do one of the following:

- Choose Configure > Controllers, click the applicable IP address. From the left sidebar menu, click General under Ports.
- Choose Monitor > Controllers, click the applicable, and click a port to access this page.
- Choose Monitor > Access Points and click a list item under AP Name, click Registered Controller, then click a port to access this page.
- Choose Monitor > Clients and click a list item under AP Name, click Registered Controller, then click a port to access this page.

Port Details

Note

Click Alarms to open the Monitor Alarms page. See the “Monitoring Alarms” section on page 6-80 for more information.
Click Events to open the Monitor Events page. See the “Monitoring Events” section on page 6-124 for more information.

The Port Detail page includes the following information:

Interface

- Operational Status—Displays the operational status of the controller: Options are UP or DOWN.
- Unknown Protocol Packets—The number of packets of unknown type which were received from this server on this port.

Traffic (Received and Transmitted)

- Total Bytes—The total number of packets received.
- Packets—The total number of packets (including bad packets) received that were within the indicated octet range in length (excluding framing bits but including FCS octets).

Ranges include:
- 64 Octets
- 65-127 Octets
- 128-255 Octets
- 256-511 Octets
- 512-1023 Octets
- 1024-1518 Octets

Packets (Received and Transmitted)

- Total—Total number of packets received/transmitted.
• **Unicast Packets**—The number of subnet-unicast packets delivered/sent to a higher-layer protocol.

• **Broadcast Packets**—The total number of packets received/sent that were directed to the broadcast address.

• **Packets Discarded**—Packets Discarded (Received/Transmitted): The number of inbound/outbound packets which were chosen to be discarded even though no errors had been detected to prevent their being deliverable to a higher-layer protocol. A possible reason for discarding a packet could be to free up buffer space.

• **Errors in Packets**—The total number of packets received that were with errors.

**Received packets with MAC errors**

• **Jabbers**—The total number of packets received that were longer than 1518 octets (excluding framing bits, but including FCS octets), and had either a bad Frame Check Sequence (FCS) with an integral number of octets (FCS Error) or a bad FCS with a non-integral number of octets (Alignment Error).

**Note**
This definition of jabber is different than the definition in IEEE-802.3 section 8.2.1.5 (10Base-5) and section 10.3.1.4 (10Base-2). These documents define jabber as the condition where any packet exceeds 20 ms. The allowed range to detect jabber is between 20 and 150 ms.

• **Fragments/Undersize**—The total number of packets received that were less than 64 octets in length (excluding framing bits but including FCS octets).

• **Alignment Errors**—The total number of packets received that had a length (excluding framing bits, but including FCS octets) of between 64 and 1518 octets, inclusive, but had a bad Frame Check Sequence (FCS) with a non-integral number of octets.

• **FCS Errors**—The total number of packets received that had a length (excluding framing bits, but including FCS octets) of between 64 and 1518 octets, inclusive, but had a bad Frame Check Sequence (FCS) with an integral number of octets.

**Transmit discards**

• **Single Collision Frames**—A count of the number of successfully transmitted frames on a particular interface for which transmission is inhibited by exactly one collision.

• **Multiple Collision Frames**—A count of the number of successfully transmitted frames on a particular interface for which transmission is inhibited by more than one collision.

• **Deferred Transmissions**—A count of frames for which transmission on a particular interface fails due to deferred transmissions.

• **Late Collisions**—A count of frames for which transmission on a particular interface fails due to late collisions.

• **Excessive Collisions**—A count of frames for which transmission on a particular interface fails due to excessive collisions.

**Ether Stats**

• **CRC Align Errors**—The number of incoming packets with the Checksum (FCS) alignment error. This represents a count of frames received on a particular interface that are not an integral number of octets in length and do not pass the FCS check. Received frames for which multiple error conditions obtain are, according to the conventions of IEEE 802.3 Layer Management, counted exclusively according to the error status presented to the LLC.
Monitoring Controllers

- **Undersize Packets**—The total number of packets received that were less than 64 octets in length (excluding framing bits but including FCS octets).
- **Oversize Packets**—The total number of frames that exceeded the maximum permitted frame size. This counter has a maximum increment rate of 815 counts per second at 10 Mbps.
- **Ether Stats Collisions**—The number of packets with collision errors.
- **SQE Test Errors**—Signal Quality Error Test errors (that is, Heartbeat) during transmission. This tests the important collision detection electronics of the transceiver, and lets the Ethernet interface in the computer know that the collision detection circuits and signal paths are working correctly. The errors indicate a count of times that the SQE TEST ERROR message is generated by the PLS sublayer for a particular interface. The SQE TEST ERROR message is defined in section 7.2.2.2.4 of ANSI/IEEE 802.3-1985 and its generation is described in section 7.2.4.6 of the same document.
- **Internal MAC Receive Errors**—A count of frames for which reception on a particular interface fails due to an internal MAC sublayer receive error. A frame is only counted by an instance of this object if it is not counted by the corresponding instance of either the FrameTooLong property, the AlignmentErrors property, or the FCSErrors property. The precise meaning of the count represented by an instance of this object is implementation-specific. In particular, an instance of this object may represent a count of receive errors on a particular interface that are not otherwise counted.
- **Internal MAC Transmit Errors**—A count of frames for which transmission on a particular interface fails due to an internal MAC sublayer transmit error. A frame is only counted by an instance of this object if it is not counted by the corresponding instance of either the LateCollisions property, the ExcessiveCollisions property, or the CarrierSenseErrors property. The precise meaning of the count represented by an instance of this object is implementation-specific. In particular, an instance of this object may represent a count of transmission errors on a particular interface that are not otherwise counted.
- **Carrier Sense Errors**—The Carrier Sense detects the presence of a carrier. The number of times that the carrier sense condition was lost or never asserted when attempting to transmit a frame on a particular interface.
- **Too Long Frames**—A count of frames received on a particular interface that exceed the maximum permitted frame size. The count represented by an instance of this object is incremented when the FrameTooLong status is returned by the MAC layer to the LLC (or other MAC user). Received frames for which multiple error conditions obtain are, according to the conventions of IEEE 802.3 Layer Management, counted exclusively according to the error status presented to the LLC.

**Monitoring CDP Interface Neighbors**

To access the Monitor CDP Interface Neighbors page, follow these steps:

1. **Step 1** Choose Monitor > Controllers.
2. **Step 2** Click the IP address of the applicable controller.
3. **Step 3** From the left sidebar menu, click CDP Interface Neighbors (under the Port heading).
4. **Step 4** The CDP Interface Neighbors page provides the following information:
   - **Local Interface**
   - **Neighbor Name**—The name of each CDP neighbor.
   - **Neighbor Address**—The IP address of each CDP neighbor.
   - **Neighbor Port**—The port used by each CDP neighbor for transmitting CDP packets.
   - **Capability**—The functional capability of each CDP neighbor.
Monitoring Controller Security

This section describes detailed information regarding monitoring controller security and contains the following topics:

- Monitoring RADIUS Authentication, page 6-12
- Monitoring RADIUS Accounting, page 6-13
- Monitoring Management Frame Protection Summary, page 6-14
- Monitoring Rogue AP Rules, page 6-15
- Monitoring Guest Users, page 6-16

Monitoring RADIUS Authentication

The RADIUS authentication page displays RADIUS authentication server information and enables you to add or delete a RADIUS authentication server.

To access this page, do one of the following:

- Choose Monitor > Controllers, click the applicable IP address, choose Radius Authentication from the Security section of the left sidebar menu.
- Choose Monitor > Access Points, click a list item under AP Name, click Registered Controller, choose Radius Authentication from the Security section of the left sidebar menu.
- Choose Monitor > Clients, click a list item under AP Name, click Registered Controller, choose Radius Authentication from the Security section of the left sidebar menu.

The following information is displayed:

- RADIUS Authentication Servers
  - Server Index—Access priority number for RADIUS servers. Up to four servers can be configured, and controller polling of the servers starts with Index 1, Index 2 second, and so forth. Index number is based on when the RADIUS server is added to the controller.
  - IP Address—The IP address of the RADIUS server.
  - Ping—Click to icon to ping the RADIUS Server from the controller to verify the link.
  - Port—Controller port number for the interface protocols.
  - Admin Status—Indicates whether the server is enabled or disabled.

- Authentication Server Statistics
  - Msg Round Trip Time—The time interval (in milliseconds) between the most recent Access-Reply/Access-Challenge and the Access-Request that matched it from this RADIUS authentication server.
  - First Requests—The number of RADIUS Access-Request packets sent to this server. This does not include retransmissions.
- Retry Requests—The number of RADIUS Authentication-Request packets retransmitted to this RADIUS authentication server.
- Accept Responses—The number of RADIUS Access-Accept packets (valid or invalid) received from this server.
- Reject Responses—The number of RADIUS Access-Reject packets (valid or invalid) received from this server.
- Challenge Responses—The number of RADIUS Access-Challenge packets (valid or invalid) received from this server.
- MalformedMsgs—The number of malformed RADIUS Access-Response packets received from this server. Malformed packets include packets with an invalid length. Bad authenticators or Signature attributes or unknown types are not included as malformed access responses.
- PendingRequests—The number of RADIUS Access-Request packets destined for this server that have not yet timed out or received a response. This variable is incremented when an Access-Request is sent and decremented due to receipt of an Access-Accept, Access-Reject or Access-Challenge, a timeout, or retransmission.
- BadAuthenticationMsgs—The number of RADIUS Access-Response packets containing invalid authenticators or Signature attributes received from this server.
- TimeoutsRequests—The number of authentication timeouts to this server. After a timeout the client may retry to the same server, send to a different server, or give up. A retry to the same server is counted as a retransmit as well as a timeout. A send to a different server is counted as a Request as well as a timeout.
- UnknownTypeMsgs—The number of RADIUS packets of unknown type which were received from this server on the authentication port.
- OtherDrops—The number of RADIUS packets received from this server on the authentication port and dropped for some other reason.

**Monitoring RADIUS Accounting**

You can access this page by any of the following ways:

- Choose Monitor > Controllers and click the applicable IP address, choose **Radius Accounting** from the Security section of the left sidebar menu.
- Choose Monitor > Clients and click a list item under AP Name, click **Registered Controller**, choose **Radius Accounting** from the Security section of the left sidebar menu.
- Choose Monitor > Maps, click an item in the **Name** column, click an access point icon, click **Controller**, choose **Radius Accounting** from the Security section of the left sidebar menu.
- Choose Configure > Access Points and select a list item under AP Name, click **Registered Controller**, choose **Radius Accounting** from the Security section of the left sidebar menu.

This page displays RADIUS accounting server information and statistics:

- **RADIUS Accounting Server**
  - Server Index—Access priority number for RADIUS servers. Up to four servers can be configured, and controller polling of the servers starts with Index 1, Index 2 second, and so forth. Index number is based on when the RADIUS server is added to the controller.
  - IP Address—The IP address of the RADIUS server.
  - Ping—Click to icon to ping the RADIUS Server from the controller to verify the link.
- Admin Status—Indicates whether the server is enabled or disabled.

- Accounting Statistics
  - Msg Round Trip Time—The time interval (in milliseconds) between the most recent Accounting-Response and the Accounting-Request that matched it from this RADIUS accounting server.
  - First Requests—The number of RADIUS Accounting-Request packets sent. This does not include retransmissions.
  - Retry Requests—The number of RADIUS Accounting-Request packets retransmitted to this RADIUS accounting server. Retransmissions include retries where the Identifier and Acct-Delay have been updated, as well as those in which they remain the same.
  - Accounting Responses—The number of RADIUS packets received on the accounting port from this server.
  - Malformed Msgs—The number of malformed RADIUS Accounting-Response packets received from this server. Malformed packets include packets with an invalid length. Bad authenticators and unknown types are not included as malformed accounting responses.
  - Bad Authentication Msgs—The number of RADIUS Accounting-Response packets which contained invalid authenticators received from this server.
  - Pending Requests—The number of RADIUS Accounting-Request packets sent to this server that have not yet timed out or received a response. This variable is incremented when an Accounting-Request is sent and decremented due to receipt of an Accounting-Response, a timeout or a retransmission.
  - Timeouts Requests—The number of accounting timeouts to this server. After a timeout the client may retry to the same server, send to a different server, or give up. A retry to the same server is counted as a retransmit as well as a timeout. A send to a different server is counted as an Accounting-Request as well as a timeout.
  - Unknown Type Msgs—The number of RADIUS packets of unknown type which were received from this server on the accounting port.
  - Other Drops—The number of RADIUS packets which were received from this server on the accounting port and dropped for some other reason.

Monitoring Management Frame Protection Summary

This page displays the Management Frame Protection (MFP) summary information. MFP provides for the authentication of 802.11 management frames. Management frames can be protected to detect adversaries who are invoking denial of service attacks, flooding the network with probes, interjecting as rogue access points, and affecting the network performance by attacking the QoS and radio measurement frames.

If one or more of the WLANs for the controller has MFP enabled, the controller sends each registered access point a unique key for each BSSID the access point uses for those WLANs. Management frames sent by the access point over the MFP enabled WLANs will be signed with a Frame Protection Information Element (IE). Any attempt to alter the frame invalidates the message causing the receiving access point configured to detect MFP frames to report the discrepancy to the WLAN controller.

Access this page in one of the following ways:

- Choose **Monitor > Controllers**. From the Controllers > Search Results page, click the applicable IP Address, choose **Management Frame Protection** from the Security section of the left sidebar menu.
• Choose **Monitor** > **Access Points**, click a list item under AP Name, click **Registered Controller**, choose **Management Frame Protection** from the Security section of the left sidebar menu.

• Choose **Monitor** > **Clients**, click a list item under AP Name, click **Registered Controller**, choose **Management Frame Protection** from the Security section of the left sidebar menu.

The following parameters is displayed:

**General**

• Management Frame Protection—Indicates if infrastructure MFP is enabled globally for the controller.

• Controller Time Source Valid—The Controller Time Source Valid field indicates whether the controller time is set locally (by manually entering the time) or through an external source (such as NTP server). If the time is set by an external source, the value of this field is "True." If the time is set locally, the value is "False." The time source is used for validating the timestamp on management frames between access points of different controllers within a mobility group.

**WLAN Details**

• WLAN ID—The WLAN ID, 1 through 17.

• WLAN Name—User-defined profile name when initially creating the WLAN. Both the SSID name and profile name are user-defined. The WLAN name is same as the profile name.

• MFP Protection—Management Frame Protection is either enabled or disabled.

• Status—Status of the WLAN is either enabled or disabled.

**AP Details**

• AP Name—Operator defined name of access point.

• MFP Validation—Management Frame Protection is enabled or disabled.

• Radio—802.11a or 802.11b/g.

• Operation Status—Displays the operational status of the: either UP or DOWN.

• Protection—Full (All Frames).

• Validation—Full (All Frames).

### Monitoring Rogue AP Rules

Rogue AP rules automatically classify rogue access points based on criteria such as authentication type, matching configured SSIDs, client count, and RSSI values. WCS applies the rogue access point classification rules to the controllers and respective access points.

These rules can limit a rogue appearance on maps based on RSSI level (weaker rogue access points are ignored) and time limit (a rogue access point is not flagged unless it is seen for the indicated period of time).

Rogue AP Rules also help reduce false alarms.

---

**Note**

Rogue classes include the following types:

- **Malicious Rogue**—A detected access point that matches the user-defined malicious rules or has been manually moved from the Friendly AP category.
- **Friendly Rogue**—Known, acknowledged, or trusted access point or a detected access point that matches user-defined friendly rules.
- **Unclassified Rogue**—A detected access point that does not match the malicious or friendly rules.
The Monitor > Controllers > Security > Rogue AP Rules page provides a list of all rogue access point rules currently applied to this controller.

The following information is displayed for rogue access point rules:

- **Rogue AP Rule name**—Click the link to view Rogue AP Rule details. See for more information.
- **Rule Type**—Malicious or Friendly.
  - Malicious Rogue—A detected access point that matches the user-defined Malicious rules or has been manually moved from the Friendly AP category.
  - Friendly Rogue—Known, acknowledged, or trusted access point or a detected access point that matches user-defined Friendly rules.
- **Priority**—Indicates the priority level for this rogue AP rule.

### Note
See the “Configuring a Rogue AP Rules Template” section on page 11-90 for more information on Rogue AP Rules.

## Rogue AP Rules Details

The Rogue AP Rules Details page displays the following information:

- **Rule Name**
- **Rule Type**—Malicious or Friendly.
  - Malicious Rogue—A detected access point that matches the user-defined Malicious rules or has been manually moved from the Friendly AP category.
  - Friendly Rogue—Known, acknowledged, or trusted access point or a detected access point that matches user-defined Friendly rules.
- **Match Type**—Match any or match all conditions.
- **Enabled Rule Conditions**—Indicates all enabled rule conditions including:
  - Open Authentication
  - Match Managed AP SSID
  - Match User Configured SSID
  - Minimum RSSI
  - Time Duration
  - Minimum Number Rogue Clients

### Note
See the “Configuring a Rogue AP Rules Template” section on page 11-90 for more information on Rogue AP Rules.

## Monitoring Guest Users

WCS allows you to monitor guest users from the Monitor > Controllers > Guest Users page as well as from the WCS home page.

The Monitor > Controllers > Guest Users page provides a summary of the guest access deployment and network use.
The following information is displayed for guest users currently associates on the network:

- **Guest User Name**—Indicates the guest user login name.
- **Profile**—Indicates the profile to which the guest user is connected.
- **Lifetime**—Indicates the length of time that the guest user account is active. Length of time displays in days, hours, and minutes or as Never Expires.
- **Start Time**—Indicates when the guest user account was activated.
- **Remaining Lifetime**—Indicates the remaining time for the guest user account.
- **Role**—Indicates the designated user role.
- **First Logged in at**—Indicates the date and time of the user first log in.
- **Number of logins**—Indicates the total number of log ins for this guest user.
- **Description**—User-defined description of the guest user account for identification purposes.

### Monitoring Controller Mobility

#### Monitoring Mobility Stats

The Mobility Stats page displays the statistics for mobility group events.

Access this page in one of the following ways:

- Choose **Monitor > Controllers** and click the applicable IP address, then select **Mobility Stats** from the Mobility section of the left sidebar menu.
- Choose **Monitor > Access Points**, click a list item under AP Name, click **Registered Controller**, then select **Mobility Stats** from the Mobility section of the left sidebar menu.
- Choose **Monitor > Clients**, click a list item under AP Name, click **Registered Controller**, then select **Mobility Stats** from the Mobility section of the left sidebar menu.

The following parameters is displayed:

**Global Mobility Statistics**

- **Rx Errors**—Generic protocol packet receive errors, such as packet too short or format incorrect.
- Tx Errors—Generic protocol packet transmit errors, such as packet transmission fail.
- Responses Retransmitted—The Mobility protocol uses UDP and it resends requests several times if it does not receive a response. Because of network or processing delays, the responder may receive one or more retry requests after it initially responds to a request. This is a count of the response resends.
- Handoff Requests Received—Total number of handoff requests received, ignored or responded to.
- Handoff End Requests—Total number of handoff end requests received. These are sent by the Anchor or the Foreign to notify the other about the close of a client session.
- State Transitions Disallowed—PEM (policy enforcement module) has denied a client state transition, usually resulting in the handoff being aborted.
- Resource Unavailable—A necessary resource, such as a buffer, was unavailable, resulting in the handoff being aborted.

Mobility Responder Statistics
- Handoff Requests Ignored—Number of handoff requests/client announces that were ignored. The controller simply had no knowledge of that client.
- Ping Pong Handoff Requests Dropped—Number of handoff requests that were denied because the handoff period was too short (3 sec).
- Handoff Requests Dropped—Number of handoff requests that were dropped due to a either an incomplete knowledge of the client or a problem with the packet.
- Handoff Requests Denied—Number of handoff requests that were actively denied.
- Client Handoff as Local—Number of handoffs responses sent while in the local role.
- Client Handoff as Foreign—Number of handoffs responses sent while in the foreign role.
- Anchor Requests Received—Number of anchor requests received.
- Anchor Requests Denied—Number of anchor requests denied.
- Anchor Requests Granted—Number of anchor requests granted.
- Anchor Transferred—Number of anchors transferred because the client has moved from a foreign controller to controller on the same subnet as the current anchor.

Mobility Initiator Statistics
- Handoff Requests Sent—Number of clients that have associated with controller and have been announced to the mobility group.
- Handoff Replies Received—Number of handoff replies that have been received in response to the requests sent.
- Handoff as Local Received—Number of handoffs in which the entire client session has been transferred.
- Handoff as Foreign Received—Number of handoffs in which the client session was anchored elsewhere.
- Handoff Denies Received—Number of handoffs that were denied.
- Anchor Request Sent—Number of anchor requests that were sent for a three party (foreign to foreign) handoff. Handoff was received from another foreign and the new controller is requesting the anchor to move the client.
- Anchor Deny Received—Number of anchor requests that were denied by the current anchor.
- Anchor Grant Received—Number of anchor requests that were approved by the current anchor.
• Anchor Transfer Received—Number of anchor transfers that were received by the current anchor.

Monitoring the 802.11a/n Controller

Select one of the following for detailed information regarding monitoring 802.11a/n parameters:

- Monitoring 802.11a/n Parameters, page 6-19
- Monitoring 802.11a/n RRM Groups, page 6-20

Monitoring 802.11a/n Parameters

Access this parameters page in one of the following ways:

- Choose Monitor > Controllers and click the applicable IP address, then select Parameters from the 802.11a/n section of the left sidebar menu.
- Choose Monitor > Access Points, click a list item under AP Name, click Registered Controller, then select Parameters from the 802.11a/n section of the left sidebar menu.
- Choose Monitor > Clients, click a list item under AP Name, click Registered Controller, then select Parameters from the 802.11a/n section of the left sidebar menu.

This page displays the following 802.11a parameters:

MAC Operation Parameters

- RTS Threshold—Indicates the number of octets in an MPDU, below which an RTS/CTS handshake is not performed.

  Note An RTS/CTS handshake is performed at the beginning of any frame exchange sequence where the MPDU is a data or management type, the MPDU has an individual address in the Address1 field, and the length of the MPDU is greater than this threshold. Setting this attribute higher than the maximum MSDU size turns off the RTS/CTS handshake for data or management type frames transmitted by this STA. Setting this attribute to zero turns on the RTS/CTS handshake for all transmitted data or management type frames.

- Short Retry Limit—The maximum number of transmission attempts of a frame (less than or equal to dot11RTSThreshold) made before a failure condition is indicated. The default value is 7.
- Long Retry Limit—The maximum number of transmission attempts of a frame (greater than dot11RTSThreshold) made before a failure condition is indicated. The default value is 4.
- Max Tx MSDU Lifetime—The elapsed time in TU, after the initial transmission of an MSDU, after which further attempts to transmit the MSDU are terminated. The default value is 512.
- Max Rx Lifetime—The elapsed time in TU, after the initial reception of a fragmented MMPDU or MSDU, after which further attempts to reassemble the MMPDU or MSDU are terminated. The default value is 512.

Physical Channel Parameters

- TI Threshold—The threshold being used to detect a busy medium (frequency). CCA shall report a busy medium upon detecting the RSSI above this threshold.
- Channel Agility Enabled—Physical channel agility functionality is or is not implemented.

Station Configuration Parameters
• Medium Occupancy Limit—Indicates the maximum amount of time, in TU, that a point coordinator may control the usage of the wireless medium without relinquishing control for long enough to allow at least one instance of DCF access to the medium. The default value is 100, and the maximum value is 1000.

• CFP Period—The number of DTIM intervals between the start of CFPs. It is modified by MLME-START.request primitive.

• CFP Max Duration—The maximum duration of the CFP in TU that may be generated by the PCF. It is modified by MLME-START.request primitive.

• CF Pollable—When this attribute is implemented, it indicates that the client is able to respond to a CF-Poll with a data frame within a SIFS time. This attribute is not implemented if the STA is not able to respond to a CF-Poll with a data frame within a SIFS time.

• CF Poll Request—Specifies whether CFP is requested by the client.

• DTIM Period—The number of beacon intervals that shall elapse between transmission of Beacon frames containing a TIM element whose DTIM Count field is 0. This value is transmitted in the DTIM Period field of Beacon frames.

Monitoring 802.11a/n RRM Groups

Access the RRM Grouping page in one of the following ways:

• Choose Monitor > Controllers and click the applicable IP address, choose Grouping or WPS Grouping from the 802.11a/n section of the left sidebar menu.

• Choose Monitor > Access Points, click a list item under AP Name, click Registered Controller, choose RRM Grouping or WPS Grouping from the 802.11a/n section of the left sidebar menu.

• Choose Monitor > Clients, click a list item under AP Name, click Registered Controller, choose RRM Grouping or WPS Grouping from the 802.11a/n section of the left sidebar menu.

This page displays the following 802.11a RRM groups parameters:

802.11a Grouping Control

• Grouping Mode—Dynamic grouping has two modes: on and off. When the grouping is off, no dynamic grouping occurs. Each controller optimizes only its own access point’s parameters. When grouping is on, the controller forms groups and elects leaders to perform better dynamic parameter optimization.

• Grouping Role—There are five grouping roles:
  - None—This grouping role appears when the RF Group Mode is configured as Off.
  - Auto-Leader—This grouping role appears when the RF Group Mode is configured as Automatic and the controller is elected as a leader by the automatic grouping algorithm.
  - Auto-Member—This grouping role appears when the RF Group Mode is configured as Automatic and the controller is selected as a member by the automatic grouping algorithm.
  - Static-Leader—This grouping role appears when the RF Group Mode is configured as Leader.
  - Static-member—This grouping role appears when the RF Group Mode is configured as automatic and the controller joins the leader as a result of the join request from the leader.

• Group Leader IP Address—This is the IP address of the group leader.

• Group Leader MAC Address—This is the MAC address of the group leader for the group containing this controller.
- Last Update Time (secs)—The elapsed time since the last group update in seconds. This is only valid if this controller is a group leader.
- Group Update Interval (secs)—When grouping is on, this interval (in seconds) represents the period with which the grouping algorithm is run by the Group Leader. Grouping algorithm will also run when the group contents changes and the automatic grouping is enabled. A dynamic grouping can be started upon request from the system administrator. Default value is 3600 seconds.

Group Members
- Group Member Name—Name of group member(s).
- Group Member IP Address—IP address of group member(s).
- Member Join Reason—Current state of the member(s).

Monitoring the 802.11b/g/n Controller

Select one of the following for detailed information regarding monitoring 802.11b/g/n parameters:
- Monitoring 802.11b/g/n Parameters, page 6-21
- Monitoring 802.11b/g/n RRM Groups, page 6-22

Monitoring 802.11b/g/n Parameters

Access this parameters page in one of the following ways:
- Choose Monitor > Controllers and click the applicable IP Address, then select Parameters from the 802.11b/g/n section of the left sidebar menu.
- Choose Monitor > Access Points, click a list item under AP Name, click Registered Controller, then select Parameters from the 802.11b/g/n section of the left sidebar menu.
- Choose Monitor > Clients, click a list item under AP Name, click Registered Controller, then select Parameters from the 802.11b/g/n section of the left sidebar menu.

This page displays the following 802.11b/g parameters:

MAC Operation Parameters
- RTS Threshold—Indicates the number of octets in an MPDU, below which an RTS/CTS handshake is not performed.

Note
An RTS/CTS handshake is performed at the beginning of any frame exchange sequence where the MPDU is a data or management type, the MPDU has an individual address in the Address1 field, and the length of the MPDU is greater than this threshold. Setting this attribute higher than the maximum MSDU size turns off the RTS/CTS handshake for data or management type frames transmitted by this STA. Setting this attribute to zero turns on the RTS/CTS handshake for all transmitted data or management type frames.

- Short Retry Limit—The maximum number of transmission attempts of a frame (less than or equal to dot11RTSThreshold) made before a failure condition is indicated. The default value is 7.
- Long Retry Limit—The maximum number of transmission attempts of a frame (greater than dot11RTSThreshold) made before a failure condition is indicated. The default value is 4.
- Max Tx MSDU Lifetime—The elapsed time in TU, after the initial transmission of an MSDU, after which further attempts to transmit the MSDU are terminated. The default value is 512.
Monitoring Controllers

Chapter 6      Monitoring Wireless Devices

Physical Channel Parameters

- Max Rx Lifetime—The elapsed time in TU, after the initial reception of a fragmented MMPDU or MSDU, after which further attempts to reassemble the MMPDU or MSDU are terminated. The default value is 512.

- TI Threshold—The threshold being used to detect a busy medium (frequency). CCA shall report a busy medium upon detecting the RSSI above this threshold.

- Channel Agility Enabled—Physical channel agility functionality is or is not implemented.

Station Configuration Parameters

- Medium Occupancy Limit—Indicates the maximum amount of time, in TU, that a point coordinator may control the usage of the wireless medium without relinquishing control for long enough to allow at least one instance of DCF access to the medium. The default value is 100, and the maximum value is 1000.

- CFP Period—The number of DTIM intervals between the start of CFPs. It is modified by MLME-START.request primitive.

- CFP Max Duration—The maximum duration of the CFP in TU that may be generated by the PCF. It is modified by MLME-START.request primitive.

- CF Pollable—When this attribute is implemented, it indicates that the client is able to respond to a CF-Poll with a data frame within a SIFS time. This attribute is not implemented if the STA is not able to respond to a CF-Poll with a data frame within a SIFS time.

- CF Poll Request—Specifies whether CFP is requested by the client.

- DTIM Period—The number of beacon intervals that shall elapse between transmission of Beacon frames containing a TIM element whose DTIM Count field is 0. This value is transmitted in the DTIM Period field of Beacon frames.

Monitoring 802.11b/g/n RRM Groups

Access the RRM Group page in one of the following ways:

- Choose Monitor > Controllers and click the applicable IP address, then select RRM Grouping or WPS Grouping from the 802.11b/g/n section of the left sidebar menu.

- Choose Monitor > Access Points, click a list item under AP Name, click Registered Controller, then select RRM Grouping or WPS Grouping from the 802.11b/g/n section of the left sidebar menu.

- Choose Monitor > Clients, click a list item under AP Name, click Registered Controller, then select RRM Grouping or WPS Grouping from the 802.11b/g/n section of the left sidebar menu.

This page displays the following 802.11b/g RRM groups parameters:

802.11b/g Grouping Control

- Grouping Mode—Dynamic grouping has two modes: on and off. When the grouping is off, no dynamic grouping occurs. Each controller optimizes only its own access point parameters. When grouping is on, the controller forms groups and elects leaders to perform better dynamic parameter optimization.

- Grouping Role—There are five grouping roles:
  - None—This grouping role appears when the RF Group Mode is configured as Off.
  - Auto-Leader—This grouping role appears when the RF Group Mode is configured as Automatic and the controller is elected as a leader by the automatic grouping algorithm.
– Auto-Member—This grouping role appears when the RF Group Mode is configured as Automatic and the controller is selected as a member by the automatic grouping algorithm.

– Static-Leader—This grouping role appears when the RF Group Mode is configured as Leader.

– Static-member—This grouping role appears when the RF Group Mode is configured as automatic and the controller joins the leader as a result of the join request from the leader.

- Group Leader IP Address—This is the IP address of the group leader.
- Group Leader MAC Address—This is the MAC address of the group leader for the group containing this controller.
- Time Since Last Group Update (secs)—The elapsed time since the last group update in seconds. This is only valid if this controller is a group leader.
- Group Update Interval Time (secs)—When grouping is on, this interval (in seconds) represents the period with which the grouping algorithm is run by the Group Leader. Grouping algorithm will also run when the group contents changes and the automatic grouping is enabled. A dynamic grouping can be started upon request from the system administrator. Default value is 3600 seconds.

Group Members

- Group Member Name—Name of group member(s).
- Group Member IP Address—IP address of group member(s).
- Member Join Reason—Current state of the member(s).

### Monitoring Access Points

This section provides access to the controller access points summary details. Use the main data area to access the respective access point details.

Choose **Monitor > Access Points** to access this page. The following provide more detailed information regarding monitoring access points:

- Searching Access Points, page 6-23
- Viewing Access Points Search Results, page 6-24
- Configuring the Search Results Display, page 6-25
- Generating a Report for Access Points, page 6-26
- Monitoring Access Points Details, page 6-34
- Monitoring Access Point Radio Details, page 6-41
- Monitoring Mesh Access Points, page 6-50

### Searching Access Points

Use the WCS Search feature to find specific access points or to create and save custom searches. See one of the following topics for additional information:

- Using the Search Feature, page 2-34
- Quick Search, page 2-34
- Advanced Search, page 2-35
- Saved Searches, page 2-46
Viewing Access Points Search Results

Choose Monitor > Access Points or perform an access point search to access this page.

This page enables you to view a summary of access points including the following default information:

- AP Name—The name assigned to the access point. Click a list item to view access point details. See the “Monitoring Access Points Details” section on page 6-34 for more information.
- Ethernet MAC
- IP Address
- Radio—Protocol of the rogue access point is 802.11a, 802.11b or 802.11g. Click a list item to view access point radio details. See the “Monitoring Access Point Radio Details” section on page 6-41 for more information.
- Map Location—Click a list item to go to the location indicated on the list.
- Controller—Click a list item to display a graphic and information about the controller. See the “Monitoring System Summary” section on page 6-4 for more information.
- Client Count—Displays the total number of clients currently associated with the controller.
- Admin Status—Displays the administration state of the access point as either enabled or disabled.
- AP Mode—Displays the operational mode of the access point.
- Oper Status—Displays the operational status of the Cisco WLAN Solution device, either Up or Down.
- Alarm Status—Alarms are color coded as follows:
  - Clear—No Alarm
  - Red—Critical Alarm
  - Orange—Major Alarm
  - Yellow—Minor Alarm

To add, remove, or reorder columns in the table, click the Edit View link to go to the Edit View page.

The following are optional access point parameters available for the search results:

- AP Type—Indicates the type of access point (unified or autonomous).
- Antenna Azim. Angle—Indicates the horizontal angle of the antenna.
- Antenna Diversity—Indicates if antenna diversity is enabled or disabled. Antenna diversity refers to the access point sampling the radio signal from two integrated antenna ports to choose the preferred antenna.
- Antenna Elev. Angle—Indicates the elevation angle of the antenna.
- Antenna Gain—The peak gain of the dBi of the antenna for directional antennas and the average gain in dBi for omni-directional antennas connected to the wireless network adapter. The gain is in multiples of 0.5 dBm. An integer value 4 means 4 x 0.5 = 2 dBm of gain.
- Antenna Mode—Indicates the antenna mode such as omni, directional, or non-applicable.
- Antenna Name—Indicates the antenna name or type.
- Antenna Type—Indicates whether the antenna is internal or external.
- Audit Status—Indicates one of the following audit statuses:
  - Mismatch—Config differences were found between WCS and controller during the last audit.
Identical—No config differences were found during the last audit.
Not Available—Audit status is unavailable.

- Base Radio MAC—Indicates the MAC address of the base radio.
- Bridge Group Name—Indicates the name of the bridge group used to group the access points, if applicable.
- CDP Neighbors—Indicates all directly connected Cisco devices.
- Channel Control—Indicates whether the channel control is automatic or custom.
- Channel Number—Indicates the channel on which the Cisco Radio is broadcasting.
- Controller Port—Indicates the number of controller ports.
- Google Earth Location—Indicates whether or not a Google Earth location is assigned and indicates the location.
- Location—Indicates the physical location of the access point.
- Node Hops—Indicates the number of hops between access points.
- OfficeExtend AP—Specifies whether or not OfficeExtend access is enabled. If it is disabled, the access point is remotely deployed which increases the security risk.
- PoE Status—Indicates the power over ethernet status of the access point. The possible values include:
  - Low—The access point draws low power from the Ethernet.
  - Lower than 15.4 volts—The access point draws lower than 15.4 volts from the Ethernet.
  - Lower than 16.8 volts—The access point draws lower than 16.8 volts from the Ethernet.
  - Normal—The power is high enough for the operation of the access point.
  - Not Applicable—The power source is not from the Ethernet.
- Primary Controller—Indicates the name of the primary controller for this access point.
- Radio MAC—Indicates the radio MAC address.
- Reg. Domain Supported—Indicates whether or not the regulatory domain is supported.
- Serial Number—Indicates the access point serial number.
- Slot—Indicates the slot number.
- Tx Power Control—Indicates whether the transmission power control is automatic or custom.
- Tx Power Level—Indicates the transmission power level.
- Up Time—Indicates how long the access point has been up in days, hours, minutes and seconds.
- WLAN Override Names—Indicates the WLAN override profile names.
- WLAN Override—Indicates whether WLAN Override is enabled or disabled.

### Configuring the Search Results Display

The **Edit View** page allows you to add, remove, or reorder columns in the Access Points table.

To edit the available columns in the alarms table, follow these steps:

**Step 1** Choose **Monitor > Access Points**.
Step 2  Click the Edit View link.

Step 3  To add an additional column to the access points table, click to highlight the column heading in the left column. Click Show to move the heading to the right column. All items in the right column are displayed in the table.

Step 4  To remove a column from the access points table, click to highlight the column heading in the right column. Click Hide to move the heading to the left column. All items in the left column are not displayed in the table.

Step 5  Use the Up/Down buttons to specify the order in which the information appears in the table. Highlight the desired column heading and click Up or Down to move it higher or lower in the current list.

Step 6  Click Reset to restore the default view.

Step 7  Click Submit to confirm the changes.

Note  See the “Viewing Access Points Search Results” section on page 6-24 for additional access point parameters than can be added through Edit View.

Generating a Report for Access Points

To generate a report for access points, follow these steps:

Step 1  Choose Monitor > Access Points.
Step 2  Click to select the access point(s) for which you want to run a report.
Step 3  Select the applicable report from the Select a report drop-down list.
Step 4  Click Go.

The following reports are available:

- Load—Generates a report with load information. See the “Monitoring the Traffic Load” section on page 6-27 for more information.
- Dynamic Power Control—Generates a report with Dynamic Power Control information. See the “Monitoring Dynamic Power Control” section on page 6-28 for more information.
- Noise—Generates a report with Noise information. See the “Monitoring Access Points Noise” section on page 6-29 for more information.
- Interference—Generates a report with Interference information. See the “Monitoring Access Points Interference” section on page 6-29 for more information.
- Coverage (RSSI)—Generates a report with Coverage (RSSI) information. See the “Monitoring Access Points Coverage (RSSI)” section on page 6-30 for more information.
- Coverage (SNR)—Generates a report with Coverage (SNR) information. See the “Monitoring Access Points Coverage (SNR)” section on page 6-30 for more information.
- Up/Down Statistics—Time in days, hours and minutes since the last reboot. Generates a report with Up Time information. See the “Monitoring Access Points Up/Down Statistics” section on page 6-30 for more information.
- Voice Statistics—Generates a report for selected access points showing radio utilization by voice traffic. The report includes the number of current calls. See the “Monitoring Access Points Voice Statistics” section on page 6-31 for more information.

- Voice TSM Table—Generates a report for selected access points and radio, organized by client device showing QoS status, PLR, and latency of its voice traffic stream. See the “Monitoring Access Points Voice TSM Table” section on page 6-31 for more information.

- Voice TSM Reports—Graphical representation of the TSM table except that metrics from the clients are averaged together on the graphs. See the “Monitoring Access Points Voice TSM Reports” section on page 6-32 for more information.

- 802.11 Counters—Displays counters for access points at the MAC layer. Statistics such as error frames, fragment counts, RTS/CTS frame count, and retried frames are generated based on the filtering criteria and can help interpret performance (and problems, if any) at the MAC layer. See the “802.11 Counters” section on page 15-119 for more information.

- AP Profile Status—Displays access point load, noise, interference, and coverage profile status. See the “AP Profile Status” section on page 15-71 for more information.

- Air Quality vs Time—Displays the air quality index of the wireless network during the configured time duration.

- Traffic Stream Metrics—Useful in determining the current and historical quality of service (QoS) for given clients at the radio level. It also displays uplink and downlink statistics such as packet loss rate, average queuing delay, distribution of delayed packets, and roaming delays. See the “Traffic Stream Metrics” section on page 15-126 for more information.

- Tx Power and Channel—Displays the channel plan assignment and transmit power level trends of devices based on the filtering criteria used when the report was generated. It could help identify unexpected behavior or issues with network performance. See the “Tx Power and Channel” section on page 15-129 for more information.

- VoIP Calls Graph—Helps analyze wireless network usage from a voice perspective by providing details such as the number and duration of VoIP calls (per radio) on the network over time. To be able to gather useful data from this report, VoIP snooping must be enabled on the WLAN. This report displays information in a graph. See the “VoIP Calls Graph” section on page 15-131 for more information.

- Calls Table—Provides the same information as the VoIP Calls Graph report but in table form. See the “VoIP Calls Table” section on page 15-133 for more information.

- Voice Statistics—Helps analyze wireless network usage from a voice perspective by providing details such as percentage of bandwidth used by voice clients, voice calls, roaming calls, and rejected calls (per radio) on the network. To be able to gather useful data from this report, make sure call admission control (CAC) is supported on voice clients. See the “Voice Statistics” section on page 15-135 for more information.

- Worst Air Quality APs—Displays the access points with the lowest air quality index.

**Monitoring the Traffic Load**

Traffic Load is the total amount of bandwidth used for transmitting and receiving traffic. This enables WLAN managers to track network growth and plan network growth ahead of client demand.

To access the access point Load report, follow these steps:

**Step 1** Choose Monitor > Access Points.
Chapter 6      Monitoring Wireless Devices

Monitoring Access Points

Step 2  Select the check box(es) of the applicable access point(s).

Step 3  From the Generate a report for selected APs drop-down list, choose Load.

Step 4  Click Go. The Load report displays for the selected access points.

This page displays the following load data:

- **AP Name**—Click the access point name to view access point details. See the “Monitoring Access Points Details” section on page 6-34 for more information.
- **Radio**—Protocol of the rogue access point is either 802.11a, 802.11b or 802.11g. Click the radio to view On-Demand Statistics for this access point. See the “Monitoring Access Point Radio Details” section on page 6-41 for more information.
- **Attached Client Count**—Number of clients attached (Actual and Threshold.)
- **Channel Utilization**—802.11a RF utilization threshold between 0 and 100 percent (Actual and Threshold).
- **Receive Utilization**—802.11a or 802.11b/g RF receive utilization threshold between 0 and 100 percent.
- **Transmit Utilization**—802.11a or 802.11b/g RF transmit utilization threshold between 0 and 100 percent.
- **Status**—Status of the client connection.

### Monitoring Dynamic Power Control

To access the access point Load report, follow these steps:

**Step 1**  Choose Monitor > Access Points.

**Step 2**  Select the check box(es) of the applicable access point(s).

**Step 3**  From the Generate a report for selected APs drop-down list, choose Dynamic Power Control.

**Step 4**  Click Go. The Dynamic Power Control report displays for the selected access points.

This page displays dynamic control parameters for access points as follows:

- **AP Name**—This is the name assigned to the access point. Choose an access point name from the list to access its parameters. See the “Monitoring Access Points Details” section on page 6-34 for more information.

- **Radio**—Protocol of the rogue access point is either 802.11a, or 802.11b/g. Choose a Cisco Radio from the list to access its parameters. See the “Monitoring Access Point Radio Details” section on page 6-41 for more information.

- **Current Power Level**—Displays the operating transmit power level from the transmit power table. Access point transmit power level: 1 = Maximum power allowed per Country Code setting, 2 = 50% power, 3 = 25% power, 4 = 6.25 to 12.5% power, and 5 = 0.195 to 6.25% power.

**Note**  The power levels and available channels are defined by the Country Code Setting, and are regulated on a country by country basis.

- **Power Assignment Mode**—Dynamic transmit power assignment has three modes:
Monitoring Access Points

To access the access point Noise report, follow these steps:

Step 1 Choose Monitor > Access Points.
Step 2 Select the check box(es) of the applicable access point(s).

Note If multiple access points are selected, they must have the same radio type.

Step 3 From the Generate a report for selected APs drop-down list, choose Noise.
Step 4 Click Go. The Noise report displays for the selected access points.
This page displays a bar graph of noise (RSSI in dBm) for each channel.

Monitoring Access Points Interference

To access the access point Interference report, follow these steps:

Step 1 Choose Monitor > Access Points.
Step 2 Select the check box(es) of the applicable access point(s).

Note If multiple access points are selected, they must have the same radio type.

Step 3 From the Generate a report for selected APs drop-down list, choose Interference.
Step 4 Click Go. The Interference report displays for the selected access points.
This page displays a bar graph of interference (RSSI in dBm) for each channel:
- High interference -40 to 0 dBm.
- Marginal interference -100 to -40 dBm.
- Low interference -110 to -100 dBm.
Monitoring Access Points Coverage (RSSI)

To access the access point Coverage (RSSI) report, follow these steps:

Step 1  Choose Monitor > Access Points.
Step 2  Select the check box(es) of the applicable access point(s).
Step 3  From the Generate a report for selected APs drop-down list, choose Coverage (RSSI).
Step 4  Click Go. The Coverage (RSSI) report displays for the selected access points.

This page displays a bar graph of client distribution by received signal strength showing the number of clients versus RSSI in dBm.

Monitoring Access Points Coverage (SNR)

To access the access point Coverage (SNR) report, follow these steps:

Step 1  Choose Monitor > Access Points.
Step 2  Select the check box(es) of the applicable access point(s).
Step 3  From the Generate a report for selected APs drop-down list, choose Coverage (SNR).
Step 4  Click Go. The Coverage (SNR) report displays for the selected access points.

This page displays a bar graph of client distribution by signal-to-noise ratio showing the number of clients versus SNR.

Monitoring Access Points Up/Down Statistics

To access the access point Up/Down Statistics report, follow these steps:

Step 1  Choose Monitor > Access Points.
Step 2  Select the check box of the applicable access point.
Step 3  From the Generate a report for selected APs drop-down list, choose Up/Down Statistics.
Step 4  Click Go. The Up/Down Statistics report displays for the selected access points.

Note  Up Time is time in days, hours, and minutes since the last reboot.

This page displays a line graph of access point up time graphed against time.
If you select more than one access point, the following message appears:
Please select only one AP for the Up Time Report.
Monitoring Access Points Voice Statistics

This generates a report for selected access points showing radio utilization by voice traffic. The report includes the number of current calls.

Note

Voice Statistics reports are only applicable for CAC/WMM clients.

To access the access point Voice Statistics report, follow these steps:

Step 1 Choose Monitor > Access Points.
Step 2 Select the check box(es) of the applicable access point(s).
Step 3 From the Generate a report for selected APs drop-down list, choose Voice Statistics.

Click Go. The Voice Statistics report displays for the selected access points.

The page displays the following access point voice statistics:

- AP Name—Select an item under AP Name. For more information, see the “Monitoring Access Points Details” section on page 6-34.
- Radio—Select an item under Radio. For more information, see the “Monitoring Access Point Radio Details” section on page 6-41.
- Calls in Progress—Number of calls in progress.
- Roaming Calls in Progress—Number of roaming calls in progress.
- Bandwidth in Use—Percentage of bandwidth in use.

Monitoring Access Points Voice TSM Table

This generates a report for selected access points and radio, organized by client device showing QoS status, PLR, and latency of its voice traffic stream.

To access the access point Voice TSM Table report, follow these steps:

Step 1 Choose Monitor > Access Points.
Step 2 Select the check box of the applicable access point.
Step 3 From the Generate a report for selected APs drop-down list, choose Voice TSM Table.
Step 4 Click Go. The Voice TSM Table report displays for the selected access point.

The page displays the following voice TSM data:

- Time—Time that the statistics were gathered from the access point(s).
- Client MAC—MAC address of the client. This shows a list of the clients evaluated during the most recent 90 second interval. The client could be a VoIP phone, laptop, PDA and refers to any client attached to the access point collecting measurements.
- QoS—QoS values (packet latency, packet jitter, packet loss, roaming time) which can affect the WLAN are monitored. Access points and clients measure the metrics, access points collect the measurements and send them to the controller. The access points update the controller with traffic stream metric information every 90 seconds and 10 minutes of data is stored at one time.
Monitoring Access Points

Monitoring Access Points Voice TSM Reports

This report provides a graphical representation of the TSM table except that metrics from the clients are averaged together on the graphs.

To access the access point Voice TSM report, follow these steps:

**Step 1** Choose **Monitor > Access Points**.

**Step 2** Select the check box of the applicable access point.

**Step 3** From the Generate a report for selected APs drop-down list, choose **Voice TSM Reports**.

Click **Go**. The Voice TSM Table report displays for the selected access point.

This page displays line graphs of the following downlink and uplink metric information, including times and dates:

- **Average Queuing Delay (ms)**—Average queuing delay in milliseconds. Average packet queuing delay is the average delay of voice packets traversing the voice queue. Packet queue delay is measured beginning when a packet is queued for transmission and ending when the packet is successfully transmitted. It includes time for re-tries, if needed.
- **% Packet with less than 10 ms delay**—Percentage of packets with less than 10 milliseconds delay.
- **% Packet with more than 10 < 20 ms delay**—Percentage of packets with more than 10 milliseconds delay but less than 20 milliseconds delay.
- **% Packet with more than 20 < 40 ms delay**—Percentage of packets with more than 20 milliseconds delay but less than 40 milliseconds delay.
- **% Packet with more than 40 ms delay**—Percentage of packets with more than 40 milliseconds delay.
- **Packet Loss Ratio**—Ratio of lost packets.
- **Total Packet Count**—Number of total packets.
- Roaming Count—Number of packets exchanged for roaming negotiations in this 90 seconds metrics page.
- Roaming Delay—Roaming delay in milliseconds.

**Monitoring Access Points 802.11 Counters**

Displays counters for access points at the MAC layer. Statistics such as error frames, fragment counts, RTS/CTS frame count, and retried frames are generated based on the filtering criteria and can help interpret performance (and problems, if any) at the MAC layer.

See the “802.11 Counters” section on page 15-119 for more information on 802.11 Counters reports.

**Monitoring Access Points AP Profile Status**

Displays access point load, noise, interference, and coverage profile status.

See the “AP Profile Status” section on page 15-71 for more information on AP Profile Status reports.

**Monitoring Access Points Radio Utilization**

See the “Network Utilization” section on page 15-124 for more information on Radio Utilization reports.

**Monitoring Access Points Traffic Stream Metrics**

Useful in determining the current and historical quality of service (QoS) for given clients at the radio level. It also displays uplink and downlink statistics such as packet loss rate, average queuing delay, distribution of delayed packets, and roaming delays.

See the “Traffic Stream Metrics” section on page 15-126 for more information on Traffic Stream Metrics reports.

**Monitoring Access Points Tx Power and Channel**

See the “Tx Power and Channel” section on page 15-129 for more information on Tx Power and Channel reports.

The Current Tx Power Level setting controls the maximum conducted transmit power. The maximum available transmit power varies according to the configured channel, individual country regulation, and access point capability. See the Product Guide or data sheet at www.cisco.com for each specific model to determine the access point capability.

The Current Tx Power Level setting of 1 represents the maximum conducted power setting for the access point. Each subsequent power level (for example, 2, 3, 4, and so on.) represents approximately a 50% (or 3dBm) reduction in transmit power from the previous power level.

**Note**

The actual power reduction may vary slightly for different models of access points.

Based on the configured antenna gain, the configured channel, and the configured power level, the actual transmit power at the access point can be reduced so that the specific country regulations are not exceeded.
Monitoring Access Points

Note
Irrespective of whether you choose Global or Custom assignment method, the actual conducted transmit power at the access point is verified such that country specific regulations are not exceeded.

Command Buttons

- Save—Save the current settings.
- Audit—Discover the present status of this access point.

Monitoring Access Points Details

Access Points Details page enables you to view access point information for a single AP. Depending on the type of access point, the following tabs may be displayed. See the following topics for detailed information regarding each Access Points Details tab:

- General Tab, page 6-34
- Interfaces Tab, page 6-39
- CDP Neighbors Tab, page 6-40
- Current Associated Clients Tab, page 6-40

Choose Monitor > Access Points and click a list item under AP Name to access this page.
Choose Monitor > Clients and click a list item under AP Name to access this page.
Choose Monitor > Controllers and click an item under IP Address, then click an item under Access Points to access this page.

General Tab

This section contains the following topics:

Note
The General tab parameters differ between lightweight and autonomous access points.

- General Parameters—Lightweight Access Points
- General Parameters—Autonomous

General Parameters—Lightweight Access Points

General:
- AP Name—User-defined
- AP IP address, Ethernet MAC address, and Base Radio MAC address.
- Country Code—The codes of the supported countries. Up to 20 countries can be supported per controller.

Note
Access points may not operate properly if they are not designed for use in your country of operation. For a complete list of country codes supported per product, refer to .
• Link Latency Settings—You can configure link latency on the controller to measure the link between an access point and the controller. See the “Configuring Link Latency Settings for Access Points” section on page 9-195 for more information.
  - Current Link Latency (in msec)—The current round-trip time (in milliseconds) of heartbeat packets from the access point to the controller and back.
  - Minimum Link Latency (in msec)—Because link latency has been enabled or reset, the minimum round-trip time (in milliseconds) of heartbeat packets from the access point to the controller and back.
  - Maximum Link Latency (in msec)—Because link latency has been enabled or reset, the maximum round-trip time (in milliseconds) of heartbeat packets from the access point to the controller and back.

• LWAPP Uptime

• LWAPP Join Taken Time

• Admin Status—The administration state of the access point as either enabled or disabled.

• AP Mode—Access point modes (or roles) include:
  - Local—Default mode. Data clients are serviced while configured channels are scanned for noise and rogues. The access point goes off-channel for 50 ms and listens for rogues. It cycles through each channel for the period specified under the Auto RF configuration.

  **Note** To configure Local or HREAP access points for Cisco Adaptive wIPS feature, choose Local or HREAP and select the Enhanced wIPS Engine Enabled check box.

  **Note** Enhanced wIPS Engine is not supported for 1130 and 1240 non-monitor mode access points.

  - Monitor—Radio receive only mode. The access point scans all configured channels every 12 seconds. Only deauthentication packets are sent in the air with an access point configured this way. A monitor mode access point detects rogues, but it cannot connect to a suspicious rogue as a client to prepare for the sending of RLDP packets.

  To configure access points for Cisco Adaptive wIPS feature, select Monitor. Select the Enhanced wIPS Engine Enabled check box and select wIPS from the Monitor Mode Optimization drop-down list.

  - Rogue Detector—The access point radio is turned off and the access point listens to wired traffic only. The controllers that operate in this mode monitor the rogue access points. The controller sends all the rogue access point and client MAC address lists to the rogue detector, and the rogue detector forwards this information to the WLC. The MAC address list is compared to what the WLC access points heard over the network. If the MAC addresses match, you can determine which rogue access points are connected on the wired network.

  - Sniffer—The access point captures and forwards all the packets on a particular channel to a remote machine that runs AiroPeek. These packets contain information such as timestamp, signal strength, packet size, and so on. This feature can only be enabled if you run AiroPeek, which is a third-party network analyzer software that supports the decoding of data packets. For more information see the AiroPeek website.

  - H-REAP—Enables hybrid REAP for up to six access points. The HREAP access points can switch client data traffic locally and perform client authentication locally when their connection to the controller is lost.


**Note**

H-REAP must be selected to configure an OfficeExtend access point. When the AP mode is H-REAP, H-REAP configuration options display including the option to enable OfficeExtend AP and to enable Least Latency Controller Join.

- Bridge—This is a special mode where an autonomous access point functions as a wireless client and connects to a lightweight access point. The bridge and its wired clients are listed as client in WCS if the AP mode is set to Bridge, and the access point is bridge capable.

- Spectrum Expert—This mode allows a CleanAir-enabled access point to be used extensively for interference detection on all monitored channels. All other functions such as IDS scanning and Wi-Fi are suspended.

- Enhanced wIPS Engine—Enabled or Disabled, to enable the monitoring of the security attacks using Cisco Adaptive wIPS feature.

- Operational Status—Registered or Not Registered, as determined by the controller.

- Registered Controller—The controller to which the access point is registered. Click to display the registered controller details. See the “Monitoring System Summary” section on page 6-4 for more information.

- Primary Controller—The SNMP name of the access point primary controller. The access point attempts to associate with this controller first for all network operations and in the event of a hardware reset.

- Port Number

- AP Uptime

- Map Location—Customer-definable location name for the access point. Click to look at the actual location on a map. See Monitor > Access Points > <name> > Map Location for more information.

- Google Earth Location

- Location—The physical location where the access point is placed (or Unassigned).

- Statistics Timer—This counter sets the time in seconds that the access point sends its DOT11 statistics to the controller.

- PoE Status—The power over ethernet status of the access point. The possible values include:
  - Low—The access point draws low power from the Ethernet.
  - Lower than 15.4 volts—The access point draws lower than 15.4 volts from the Ethernet.
  - Lower than 16.8 volts—The access point draws lower than 16.8 volts from the Ethernet.
  - Normal—The power is high enough for the operation of the access point.
  - Not Applicable—The power source is not from the Ethernet.

- Rogue Detection—Indicates whether or not Rogue Detection is enabled. See the “Monitoring Rogue Access Point Location, Tagging, and Containment” section on page 6-110 for more information on rogue detection.

**Note**

Rogue detection is disabled automatically for OfficeExtend access points because these access points, which are deployed in a home environment, are likely to detect a large number of rogue devices. For more information regarding OfficeExtend access points, see the *Cisco Wireless LAN Controller Configuration Guide*. 
- OfficeExtend AP—Indicates whether or not the access point is enabled as an OfficeExtend access point. The default is Enabled.
- Encryption—Indicates whether or not encryption is enabled.

**Note** Enabling or disabling encryption functionality causes the access point to reboot which then causes a loss of connectivity for clients.

**Note** DTLS data encryption is enabled automatically for OfficeExtend access points to maintain security. Encryption is only available if the access point is connected to a 5500 series controller with a Plus license.

- Least Latency Join
- Telnet Access—Indicates whether or not Telnet Access is enabled.
- SSH Access—Indicates whether or not SSH is enabled.

**Note** An OfficeExtend access point may be connected directly to the WAN which could allow external access if the default password is used by the access point. Because of this, Telnet and SSH access are disabled automatically for OfficeExtend access points.

Versions:
- Software Version—The operating system release.version.dot.maintenance number of the code currently running on the controller.
- Boot Version—The operating system bootloader version number.

Inventory Information:
- AP Model—Access point model number.
- Cisco IOS Version
- AP Certificate Type—Either Self Signed or Manufacture Installed.
- AP Serial Number

wIPS Profile (when applicable):
- Profile Name—Click the user-assigned profile name to view wIPS profile details.
- Profile Version

Unique Device Identifier (UDI)
- Name
- Description
- Product ID—Orderable product identifier.
- Version ID
- Serial Number—Unique product serial number.

Run Ping Test—Click to ping the access point. The results are displayed in a pop-up dialog box.
Alarms—Click to display alarms associated with this access point.
Events—Click to display events associated with this access point.
For autonomous clients, WCS only collects client counts. The client counts in the Monitor page and reports have autonomous clients included. Client search, client traffic graphs, or other client reports (such as Unique Clients, Busiest Clients, Client Association) do not include clients from autonomous access points.

General:
- AP Name—User-defined
- AP IP address and Ethernet MAC address
- AP UpTime—Indicates how long the access point has been up in number of days, hours, minutes, and seconds.
- Map Location—Customer-definable location name for the access point. Click to look at the actual location on a map. See the “Monitoring Maps” section on page 5-22 for more information.
- WGB Mode—Indicates whether or not the access point is in work group bridge mode. See the “Viewing Clients Identified as WGBs” section on page 6-58 for more information.

SNMP Info:
- SysObjectId—System Object ID.
- SysDescription—The system device type and current version of firmware.
- SysLocation—The physical location of the device, such as a building name or room in which it is installed.
- SysContact—The name of the system administrator responsible for the device.

Versions:
- Software Version—The operating system release.version.dot.maintenance number of the code currently running on the controller.

Inventory Information:
- AP Type—Autonomous or lightweight.
- AP Model—The Access Point model number.
- AP Serial Number—Unique serial number for this access point.

Unique Device Identifier (UDI):
- Name
- Description
- Product ID
- Version ID
- Serial Number

Click Alarms to display the alarms associated with the access point. Click Events to display events associated with the access point.
Interfaces Tab

The Interfaces tab displays the following parameters:

Interface:
- Admin Status—Indicates whether the Ethernet interface is enabled.
- Operational Status—Indicates whether the Ethernet interface is operational.
- Rx Unicast Packets—Indicates the number of unicast packets received.
- Tx Unicast Packets—Indicates the number of unicast packets sent.
- Rx Non-Unicast Packets—Indicates the number of non-unicast packets received.
- Tx Non-Unicast Packets—Indicates the number of non-unicast packets sent.

Radio Interfaces:
- Interface—802.11a/n or 802.11b/g/n.
- Protocol—802.11a/n or 802.11b/g/n.
- Admin Status—Indicates whether the access point is enabled or disabled.
- CleanAir Capable—Indicates whether the access point is able to use CleanAir.
- CleanAir Status—Indicates the status of CleanAir.
- Channel Number—Indicates the channel on which the Cisco Radio is broadcasting.
- Extension Channel—Indicates the secondary channel on which Cisco radio is broadcasting.
- Power Level—Access Point transmit power level: 1 = Maximum power allowed per Country Code setting, 2 = 50% power, 3 = 25% power, 4 = 6.25 to 12.5% power, and 5 = 0.195 to 6.25% power.
- Channel Width—Indicates the channel bandwidth for this radio interface. See the “Configuring 802.11a/n RRM Dynamic Channel Allocation” section on page 9-121 for more information on configuring channel bandwidth.

Note: Minimum (default) setting is 20 MHz. Maximum setting is the maximum channel width supported by this radio.

- Antenna Name—Identifies the type of antenna.

Click an interface name to view its properties.
- AP Name—Name of the Access Point.
- Link speed—Indicates the speed of the interface in Mbps.
- RX Bytes—Indicates the total number of bytes in the error-free packets received on the interface.
- RX Unicast Packets—Indicates the total number of unicast packets received on the interface.
- RX Non-Unicast Packets—Indicates the total number of non-unicast or multicast packets received on the interface.
- Input CRC—Indicates the total number of CRC error in packets received on the interface.
- Input Errors—Indicates the sum of all errors in the packets while receiving on the interface.
- Input Overrun—Indicates the number of times the receiver hardware was incapable of handing received data to a hardware buffer because the input rate exceeded the receiver capability to handle the data.
- Input Resource—Indicates the total number of resource errors in packets received on the interface.
• Runts—Indicates the number of packets that are discarded because they are smaller than the medium minimum packet size.
• Throttle—Indicates the total number of times the interface advised a sending NIC that it was overwhelmed by packets being sent and to slow the pace of delivery.
• Output Collision—Indicates the total number of packet retransmitted due to an Ethernet collision.
• Output Resource—Indicates the total number of resource errors in packets transmitted on the interface.
• Output Errors—Indicates the sum of all errors that prevented the final transmission of packets out of the interface.
• Operational Status—Indicates the operational state of the physical Ethernet interface on the AP.

**CDP Neighbors Tab**

The CDP Neighbors tab displays the following parameters:
• AP Name—The name assigned to the access point.
• AP IP Address—IP address of the access point.
• Local Interface—Identifies the local interface.
• Neighbor Name—Name of the neighboring Cisco device.
• Neighbor Address—Network address of the neighboring Cisco device.
• Neighbor Port—Port of the neighboring Cisco device.

**Current Associated Clients Tab**

The Current Associated Clients tab displays the following parameters (when the access point is associated with the controller):
• Username—Click the username to view the Monitor Client Details page for this client. See the “Monitoring Clients” section on page 10-8 for more information.
• IP Address—IP address of the associated client.
• Client MAC Address—Click the client MAC address to view the Monitor Client Details page for this client. See the “Monitoring Clients” section on page 10-8 for more information.
• Association Time—Date and time of the association.
• UpTime—Time duration of the association.
• SSID
• Protocol
• SNR (dB)—Signal to Noise Ratio in dB of the associated client.
• RSSI
• Bytes Tx
• Bytes Rx

When the access point is not associated with the controller, then the database is used to retrieve the data (rather than the controller itself). If the access point is not associated, the following parameters display:
• User Name
• IP Address
• Client MAC Address
• Association Time
• Session Length
• SSID
• Protocol
• Avg. Session Throughput
• Traffic (MB) as before

Note
Click the Edit View link to add, remove or reorder columns in the Current Associated Clients table. See the “Configuring the Search Results Display” section on page 6-25 for adding a new parameter using the Edit View.

Monitoring Access Point Radio Details

Choose Monitor > Access Points and click a list item under Radio to access this page.

Choose Monitor > Maps, then click an item in the Name column, then click an access point icon to access this page.

Choose Monitor > Access Points and click a list item under AP Name, click 802.11a or 802.11b under AP Interfaces to access this page. This page enables you to view access point information for a single 802.11a or 802.11b/g Cisco Radio.

The default is to show On Demand Statistics. Use the View drop-down list to select a different view:

• Select On Demand Statistics, and click Go to display “Monitoring On Demand Statistics”.
• Select Operational Parameters, and click Go to display “Monitoring Operational Parameters”.
• Select 802.11 MAC Counters, and click Go to display “Monitoring 802.11 MAC Counters”.
• Select View Alarms, and click Go to display “Monitoring View Alarms”.
• Select View Events, and click Go to display “Monitor View Events”.

Monitoring On Demand Statistics

To view On Demand Statistics for an access point, click the Radio of the applicable access point from the Monitor > Access Points page. The Radio Details page defaults to On Demand Statistics. See the “Monitoring Access Point Radio Details” section on page 6-41 for more information on radio details.

Note
You can also select On Demand Statistics from the View drop-down list located on the Radio Details page.

This page enables you to view the following access point 802.11a or 802.11b Cisco Radio statistics for a single access point:
General

- AP Name—Click to view the access point details. See the “Monitoring Access Points Details” section on page 6-34 for more information.
- AP MAC Address
- Radio
- CleanAir Capable—Indicates if the access point is CleanAir Capable.
- Spectrum Expert Connection—Yes or No. Indicates if the access point is connected in SE-Connect mode.
- CleanAir Management Admin State—Indicates if CleanAir is enabled on this access point.
- CleanAir Management Operation State—Indicates the operational status of the CleanAir sensor (Up or Down).
- Admin Status—Enabled or disabled.
- Operational Status—Displays the operational status of the Cisco Radios (Up or Down).
- Controller—Click to display controller system details. See the “Monitoring System Summary” section on page 6-4 for more information.
- Channel—The channel upon which the Cisco Radio is broadcasting.
- Extension Channel—Indicates the secondary channel on which Cisco radio is broadcasting.
- Channel Width—Indicates the channel bandwidth for this radio interface. See the “Configuring 802.11a/n RRM Dynamic Channel Allocation” section on page 9-121 for more information on configuring channel bandwidth.
- Power Level—Access Point transmit power level: 1 = Maximum power allowed per Country Code setting, 2 = 50% power, 3 = 25% power, 4 = 6.25 to 12.5% power, and 5 = 0.195 to 6.25% power.
  The power levels and available channels are defined by the Country Code setting, and are regulated on a country by country basis.
- Port—(1 to 24) Port to which the access point is connected.
- Map Location—Click to display the floor map showing the access point location.

Management Frame Protection

- Protection Capability—All Frames
- Validation Capability—All Frames
- MFP Version Supported—Management Frame Protection version supported and configured.

Profile Information

- Noise Profile—Notification sent when Noise Profile state changes between Success and Failure.
- Interference Profile—Notification sent when Interference Profile state changes between Success and Failure.
- Load Profile—Notification sent when Load Profile state changes between Success and Failure.
- Coverage Profile—Notification sent when Coverage Profile state changes between Success and Failure.
Note: Click Success or Failure to view associated alarms.

**Noise by Channel (dBm)**

Graph showing channel and noise.

**Interference by Channel (dBm%)**

Graph showing the percentage of interference per channel.

Note: Channel Utilization is a combination of Receive Power (RX) + Transmit Power (TX) + Interference. Interference—Access points report on the percentage of the medium taken up by interfering 802.11 transmissions (this can be from overlapping signals from foreign APs, as well as non-neighbors).

Note: The channel list (as configured from the RRM page) is scanned completely using the "channel scan duration" parameter under monitor intervals. For example, if scanning all 11 channels in 2.4 GHz, and using the default duration (180 seconds), you get: 180/11 = 16.36 seconds approximately between each channel that is being scanned.

**Load Statistics**

- RX Utilization—802.11a or 802.11b/g RF receive utilization threshold between 0 and 100 percent.
- TX Utilization—802.11a or 802.11b/g RF transmit utilization threshold between 0 and 100 percent.
- Channel Utilization—802.11a RF utilization threshold between 0 and 100 percent (Subcolumns for Actual and Threshold).
- Attached Client Count—The number of clients attached.

**General Tab**

The General tab displays the following information.

**% Client Count by RSSI**

Graph with % and Received Signal Strength Indicator.

**% Client Count by SNR**

Graph with % and Signal-to-Noise Ratio.

**Channel Utilization (% Busy)**

Graph displaying the channel number on the x-axis and channel utilization on the y-axis.

**Noise by Channel (dBm)**

Graph displaying the channel on the x-axis and power in dBm on the y-axis.
Rx Neighbors

- Radio MAC Address
- AP Name—Click to view access point details.
- Map—Click to view the map.
- Mobility Group-Leader IP Address
- Neighbor Channel
- Channel Bandwidth
- RSSI (dBm)

Channel Utilization Statistics

- Time
- Picc—Percentage of time consumed by received frames from co-channel APs and clients.
- Pib—Percentage of time consumed by interference on the channel which cannot be correctly demodulated.

**Note** Picc and Pib values should give a good indication of the percentage of time the access point is busy because of co-channel interference.

CleanAir Tab

The CleanAir tab provides the following information.

Air Quality

This graph displays the air quality index of the wireless network. A value of 100 indicates the air quality is best and a value of 1 indicates maximum interference.

Interference Power

This graph displays the interference power of the interfering devices on the channel number.

Non-WiFi Channel Utilization

This graph displays the non-WiFi channel utilization of the wireless network.

Active Interferers

This section displays the details of the active interferers on the wireless network. The following details are available:

- Interferer Name—The name of the interfering device.
- Affected Channels—The channel the interfering device is affecting.
- Detected Time—The time at which the interference was detected.
- Severity—The severity index of the interfering device.
- Duty Cycle(%)—The duty cycle (in percentage) of the interfering device.
• RSSI(dBm)—The Received Signal Strength Indicator of the interfering device.

**View Drop-Down List**

- Select On Demand Statistics, and click **Go** to display On Demand Statistics for this access point radio. See the “Monitoring On Demand Statistics” section on page 6-41 for more information.
- Select Operational Parameters, and click **Go** to display Operational parameters for this access point radio. See the “Monitoring Operational Parameters” section on page 6-45 for more information.
- Select 802.11 MAC Counters, and click **Go** to display 802.11 MAC Counters for this access point radio. See the “Monitoring 802.11 MAC Counters” section on page 6-48 for more information.
- Select View Alarms, and click **Go** to display alarms for this access point radio. See the “Monitoring View Alarms” section on page 6-49 for more information.
- Select View Events, and click **Go** to display events for this access point radio. See the “Monitoring View Events” section on page 6-49 for more information.

**Monitoring Operational Parameters**

To view Operational Parameters for an access point radio, follow these steps:

**Step 1** Choose **Monitor > Access Points**, and click the radio for the applicable access point.

**Step 2** From the View drop-down list, select Operational Parameters.

**Step 3** Click **Go**.

This page enables you to view configuration information for a single 802.11a or 802.11b Cisco radio.

**General**

- AP Name—Click to view the access point details. See the “Monitoring Access Points Details” section on page 6-34 for more information.
- AP MAC Address
- Radio
- Admin Status—Enabled or disabled.
- Operational Status—Displays the operational status of the Cisco Radios (Up or Down).
- Controller—Click to display controller system details. See the “Monitoring System Summary” section on page 6-4 for more information.
- Channel—The channel upon which the Cisco Radio is broadcasting.
- Extension Channel—Indicates the secondary channel on which Cisco radio is broadcasting.
- Channel Width—Indicates the channel bandwidth for this radio interface. See the “Configuring 802.11a/n RRM Dynamic Channel Allocation” section on page 9-121 for more information on configuring channel bandwidth.
- Power Level—Access Point transmit power level: 1 = Maximum power allowed per Country Code setting, 2 = 50% power, 3 = 25% power, 4 = 6.25 to 12.5% power, and 5 = 0.195 to 6.25% power. The power levels and available channels are defined by the Country Code setting, and are regulated on a country by country basis.
• Port—(1 to 24) Port to which the access point is connected.
• Map Location—Click to display the floor map showing the access point location.

**Station Configuration Parameters**

• Configuration Type—Automatic or Custom.
• Number of WLANs—1 (one) is the default.
• Medium Occupancy Limit—Indicates the maximum amount of time, in TU, that a point coordinator may control the usage of the wireless medium without relinquishing control for long enough to allow at least one instance of DCF access to the medium. The default value is 100, and the maximum value is 1000.
• CFP Period—The number of DTIM intervals between the start of CFPs.
• CFP Max. Duration—The maximum duration of the CFP in TU that may be generated by the PCF.
• BSSID—MAC address of the access point.
• Beacon Period—The rate at which the SSID is broadcast by the access point, from 100 to 600 milliseconds.
• DTIM Period—The number of beacon intervals that shall elapse between transmission of Beacon frames containing a TIM element whose DTIM Count field is 0. This value is transmitted in the DTIM Period field of Beacon frames.
• Country String—Identifies the country in which the station is operating. The first two octets of this string are the two character country code.

**Physical Channel Parameters**

• Current Channel—Current operating frequency channel.
• Configuration—Locally customized or globally controlled.
• Current CCA Mode—CCA method in operation. Valid values are:
  - Energy detect only (edonly) = 01.
  - Carrier sense only (csonly) = 02.
  - Carrier sense and energy detect (edandcs)= 04.
  - Carrier sense with timer (cswithtimer)= 08.
  - High rate carrier sense and energy detect (hrcsanded)=16.
• ED/TI Threshold—The Energy Detect and Threshold being used to detect a busy medium (frequency). CCA shall report a busy medium upon detecting the RSSI above this threshold.

**Physical Antenna Parameters**

• Antenna Type—Internal or External.
• Diversity—Enabled via the internal antennas or via either Connector A or Connector B. (Enabled or Disabled).

**RF Recommendation Parameters**

• Channel—802.11a Low Band, Medium Band, and High Band; 802.11b/g.
• Tx Power Level—Zero (0) if Radio Resource Management (RRM) disabled, 1 - 5 if Radio Resource Management (RRM) enabled.

• RTS/CTS Threshold—Zero (0) if Radio Resource Management (RRM) disabled, 1 - 5 if Radio Resource Management (RRM) enabled. See RTS Threshold in MAC Operation Parameters above.

• Fragmentation Threshold—Zero (0) if Radio Resource Management (RRM) disabled, or as Radio Resource Management (RRM) recommends.

**MAC Operation Parameters**

• Configuration Type—Automatic or Custom.

• RTS Threshold—This attribute indicates the number of octets in an MPDU, below which an RTS/CTS handshake is not performed.

An RTS/CTS handshake is performed at the beginning of any frame exchange sequence where the MPDU is a Data or Management type, the MPDU has an individual address in the Address1 field, and the length of the MPDU is greater than this threshold. Setting this attribute to be larger than the maximum MSDU size turns off the RTS/CTS handshake for Data or Management type frames transmitted by this STA. Setting this attribute to zero turns on the RTS/CTS handshake for all frames of Data or Management type transmitted by this STA. The default value of this attribute shall be 2347.

• Short Retry Limit—The maximum number of transmission attempts of a frame, the length of which is less than or equal to dot11RTSThreshold, that shall be made before a failure condition is indicated. The default value of this attribute is 7.

• Long Retry Limit—The maximum number of transmission attempts of a frame, the length of which is greater than dot11RTSThreshold, that shall be made before a failure condition is indicated. The default value of this attribute shall be 4.

• Fragmentation Threshold—The current maximum size, in octets, of the MPDU that may be delivered to the PHY. An MSDU shall be broken into fragments if its size exceeds the value of this attribute after adding MAC headers and trailers. An MSDU or MMPDU shall be fragmented when the resulting frame has an individual address in the Address1 field, and the length of the frame is larger than this threshold. The default value for this attribute shall be the lesser of 2346 or the aMPDUMaxLength of the attached PHY and shall never exceed the lesser of 2346 or the aMPDUMaxLength of the attached PHY. The value of this attribute shall never be less than 256.

• Max Tx MSDU Lifetime—The elapsed time in TU, after the initial transmission of an MSDU, after which further attempts to transmit the MSDU shall be terminated. The default value of this attribute is 512.

• Max Rx Lifetime—The MaxReceiveLifetime shall be the elapsed time in TU, after the initial reception of a fragmented MMPDU or MSDU, after which further attempts to reassemble the MMPDU or MSDU shall be terminated. The default value is 512.

**Tx Power**

• # Supported Power Levels—Five or fewer power levels, depending on operator preference.

• Tx Power Level x—Access point transmit power level: 1 = Maximum power allowed per Country Code setting, 2 = 50% power, 3 = 25% power, 4 = 6.25 to 12.5% power, and 5 = 0.195 to 6.25% power.

*Note* The power levels and available channels are defined by the Country Code setting, and are regulated on a country by country basis.
Monitoring Access Points

- Tx Power Configuration—Globally controlled or customized for this access point (Custom or Global).
- Current Tx Power Level—Displays the operating transmit power level from the transmit power table.

Monitoring 802.11 MAC Counters

To view Operational Parameters for an access point radio, follow these steps:

Step 1 Choose Monitor > Access Points, click the radio for the applicable access point.
Step 2 From the View drop-down list, choose 802.11 MAC Counters.
Step 3 Click Go.

This page enables you to view 802.11 MAC Counter information for a single 802.11a or 802.11b Cisco Radio.

General

- AP Name—Click to view the access point details. See the “Monitoring Access Points Details” section on page 6-34 for more information.
- AP MAC Address
- Radio
- Admin Status—Enabled or disabled.
- Operational Status—Displays the operational status of the Cisco Radios (Up or Down).
- Controller—Click to display controller system details. See the “Monitoring System Summary” section on page 6-4 for more information.
- Channel—The channel upon which the Cisco Radio is broadcasting.
- Extension Channel—Indicates the secondary channel on which Cisco radio is broadcasting.
- Channel Width—Indicates the channel bandwidth for this radio interface. See the “Configuring 802.11a/n RRM Dynamic Channel Allocation” section on page 9-121 for more information on configuring channel bandwidth.

Note Minimum (default) setting is 20 MHz. Maximum setting is the maximum channel width supported by this radio.

- Power Level—Access Point transmit power level: 1 = Maximum power allowed per Country Code setting, 2 = 50% power, 3 = 25% power, 4 = 6.25 to 12.5% power, and 5 = 0.195 to 6.25% power. The power levels and available channels are defined by the Country Code setting, and are regulated on a country by country basis.
- Port—(1 to 24) Port to which the access point is connected.
- Map Location—Click to display the floor map showing the access point location.
RF Counters

- **Tx Fragment Count**—This counter is incremented for each successfully received MPDU Data or Management type.
- **Multicast Tx Frame Count**—This counter increments only when the multicast bit is set in the destination MAC address of a successfully transmitted MSDU. When operating as a STA in an ESS, where these frames are directed to the access point, this implies having received an acknowledgment to all associated MPDUs.
- **Tx Failed Count**—This counter increments when an MSDU is successfully transmitted after one or more retransmissions.
- **Retry Count**—This counter increments when an MSDU is successfully transmitted after one or more retransmissions.
- **Multiple Retry Count**—This counter increments when an MSDU is successfully transmitted after more than one retransmission.
- **Frame Duplicate Count**—This counter increments when a frame is received that the Sequence Control field indicates is a duplicate.
- **RTS Success Count**—This counter increments when a CTS is received in response to an RTS.
- **RTS Failure Count**—This counter increments when a CTS is not received in response to an RTS.
- **ACK Failure Count**—This counter increments when an ACK is not received when expected.
- **Rx Fragment Count**—The total number of packets received that were less than 64 octets in length (excluding framing bits but including FCS octets).
- **Multicast Rx Framed Count**—This counter increments when a MSDU is received with the multicast bit set in the destination MAC address.
- **FCS Error Count**—This counter increments when an FCS error is detected in a received MPDU.
- **Tx Frame Count**—This counter increments for each successfully transmitted MSDU.
- **WEP Undecryptable Count**—This counter increments when a frame is received with the WEP subfield of the Frame Control field set to one and the WEP On value for the key mapped to the AT MAC address indicates that the frame should not have been encrypted or that frame is discarded due to the receiving STA not implementing the privacy option.

**Monitoring View Alarms**

To access the **View Alarms** page from the Monitor Access Points page, follow these steps:

**Step 1** Choose **Monitor > Access Points**.
**Step 2** Select the Radio Type in the Radio Type column of the applicable access point.
**Step 3** From the View drop-down list, choose **View Alarms**.
**Step 4** Click **Go**.

For more information on Viewing Alarms, see the “Monitoring Alarms” section on page 6-80.

**Monitor View Events**

To access the **View Events** page from the Monitor Access Points page, follow these steps:
Step 1 Choose **Monitor > Access Points**.

Step 2 Select the Radio Type in the Radio Type column of the applicable access point.

Step 3 From the View drop-down list, choose **View Events**.

Step 4 Click **Go**.

For more information on viewing events, see the “Monitoring Events” section on page 6-124.

---

**Monitoring Mesh Access Points**

Mesh Health monitors the overall health of Cisco Aironet 1500 and 1520 series outdoor access points as well as Cisco Aironet 1130 and 1240 series indoor access points when configured as mesh access points, except as noted. Tracking this environmental information is particularly critical for access points that are deployed outdoors. The following factors are monitored:

- **Temperature**: Displays the internal temperature of the access point in Fahrenheit and Celsius (Cisco Aironet 1510 and 1520 outdoor access points only).
- **Heater status**: Displays the heater as on or off (Cisco Aironet 1510 and 1520 outdoor access points only)
- **AP Up time**: Displays how long the access point has been active to receive and transmit.
- **LWAPP Join Taken Time**: Displays how long it took to establish the LWAPP connection (excluding Cisco Aironet 1505 access points).
- **LWAPP Up Time**: Displays how long the LWAPP connection has been active (excluding Cisco Aironet 1505 access points).

Mesh Health information is displayed in the General Properties page for mesh access points.

To view the mesh health details for a specific mesh access point, follow these steps:

Step 1 Choose **Monitor > Access Points**. A listing of radios belonging to access points appears.

**Note** The radio status (not an access point status) is displayed when you choose **Monitor > Access Points**. The given status is updated frequently from traps and wireless status polling and takes several minutes to reflect actual radio status. The overall status of an access point can be found by viewing the access point on a map.

**Note** You can also use the New Search button to display the mesh access point summary. With the New Search option, you can further define the criteria of the access points that appear. Search criteria include AP Type, AP Mode, Radio Type, and 802.11n Support.

Step 2 Click the AP Name link to display details for that mesh access point. The General tab for that mesh access point appears.
Mesh Statistics for an Access Point

Mesh Statistics are reported when a child mesh access point authenticates or associates with a parent mesh access point.

Security entries are removed and no longer displayed when the child mesh access point disassociates from the controller.

The following mesh security statistics are displayed for mesh access points:

- Bridging
- Queue
- Security

To view the mesh statistics for a specific mesh access point, follow these steps.

**Step 1** Choose Monitor > Access Points. A listing of radios belonging to access points appears.

**Note** The radio status (not an access point status) is displayed when you choose Monitor > Access Points. The given status is updated frequently from traps and wireless status polling and takes several minutes to reflect actual radio status. The overall status of an access point can be found by viewing the access point on a map.

**Note** You can also use the New Search button to display the access point summary. With the New Search option, you can further define the criteria of the access points that display. Search criteria include AP Name, IP address, MAC address, Controller IP or Name, Radio type, and Outdoor area.

**Step 2** Click the AP Name link of the target mesh access point.

A tabbed page appears and displays the General Properties page for the selected access point.

**Step 3** Click the Mesh Statistics tab. A three-tabbed Mesh Statistics page appears.

**Note** The Mesh Statistics tab and its subordinate tabs (Bridging, Queue and Security) only appear for mesh access points. The Mesh Link Alarms and Mesh Link Events links are accessible from each of the three tabbed panels.
Chapter 6  Monitoring Wireless Devices

Monitoring Access Points

Note  You can also access the Mesh Securities page for a mesh access point from a Cisco WCS map. To display the page, double-click the mesh access point label.

Summaries of the Bridging, Queue and Security Statistics and their definitions are provided in Table 6-1, Table 6-2 and Table 6-3 respectively.

Table 6-1  Bridging Mesh Statistics

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Role</td>
<td>The role of the mesh access point. Options are mesh access point (MAP) and root access point (RAP).</td>
</tr>
<tr>
<td>Bridge Group Name</td>
<td>The name of the bridge group to which the MAP or RAP is a member. We recommend assigning membership in a bridge group name. If one is not assigned, a MAP is by default assigned to a default bridge group name.</td>
</tr>
<tr>
<td>Backhaul Interface</td>
<td>The radio backhaul for the mesh access point.</td>
</tr>
<tr>
<td>Routing State</td>
<td>The state of parent selection. Values that display are seek, scan and maint. Maint appears when parent selection is complete.</td>
</tr>
<tr>
<td>Malformed Neighbor Packets</td>
<td>The number of malformed packets received from the neighbor. Examples of malformed packets include malicious floods of traffic such as malformed or short DNS packets and malformed DNS replies.</td>
</tr>
<tr>
<td>Poor Neighbor SNR</td>
<td>The number of times the signal-to-noise ratio falls below 12 dB on the backhaul link.</td>
</tr>
<tr>
<td>Excluded Packets</td>
<td>The number of packets received from excluded neighbor mesh access points.</td>
</tr>
<tr>
<td>Insufficient Memory</td>
<td>The number of insufficient memory conditions.</td>
</tr>
<tr>
<td>RX Neighbor Requests</td>
<td>The number of broadcast and unicast requests received from the neighbor mesh access points.</td>
</tr>
<tr>
<td>RX Neighbor Responses</td>
<td>The number of responses received from the neighbor mesh access points.</td>
</tr>
<tr>
<td>TX Neighbor Requests</td>
<td>The number of unicast and broadcast requests sent to the neighbor mesh access points.</td>
</tr>
<tr>
<td>TX Neighbor Responses</td>
<td>The number of responses sent to the neighbor mesh access points.</td>
</tr>
<tr>
<td>Parent Changes</td>
<td>The number of times a mesh access point (child) moves to another parent.</td>
</tr>
</tbody>
</table>
### Table 6-1  Bridging Mesh Statistics (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Neighbor Timeouts</td>
<td>The number of neighbor timeouts.</td>
</tr>
<tr>
<td>Node Hops</td>
<td>The number of hops between the MAP and the RAP. Click the value link to display a dialog box which enables you to configure details of what is reported, how often the node hop value is updated, and view a graphical representation of the report.</td>
</tr>
</tbody>
</table>

### Table 6-2  Queue Mesh Statistics

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Silver Queue</td>
<td>The average and peak number of packets waiting in the silver (best effort) queue during the defined statistics time interval. Packets dropped and queue size is also summarized.</td>
</tr>
<tr>
<td>Gold Queue</td>
<td>The average and peak number of packets waiting in the gold (video) queue during the defined statistics time interval. Packets dropped and queue size is also summarized.</td>
</tr>
<tr>
<td>Platinum Queue</td>
<td>The average and peak number of packets waiting in the platinum (voice) queue during the defined statistics time interval. Packets dropped and queue size is also summarized.</td>
</tr>
<tr>
<td>Bronze Queue</td>
<td>The average and peak number of packets waiting in the bronze (background) queue during the defined statistics time interval. Packets dropped and queue size is also summarized.</td>
</tr>
<tr>
<td>Management Queue</td>
<td>The average and peak number of packets waiting in the management queue during the defined statistics time interval. Packets dropped and queue size is also summarized.</td>
</tr>
</tbody>
</table>

### Table 6-3  Security Mesh Statistics

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Packets Transmitted</td>
<td>Summarizes the total number of packets transmitted during security negotiations by the selected mesh access point.</td>
</tr>
<tr>
<td>Packets Received</td>
<td>Summarizes the total number of packets received during security negotiations by the selected mesh access point.</td>
</tr>
</tbody>
</table>
### Table 6-3 Security Mesh Statistics (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Association Request Failures</td>
<td>Summarizes the total number of association request failures that occur between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Association Request Timeouts</td>
<td>Summarizes the total number of association request timeouts that occur between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Association Request Success</td>
<td>Summaries the total number of successful association requests that occur between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Authentication Request Failures</td>
<td>Summarizes the total number of failed authentication requests that occur between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Authentication Request Timeouts</td>
<td>Summarizes the total number of authentication request timeouts that occur between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Authentication Request Success</td>
<td>Summarizes the total number of successful authentication requests between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Reassociation Request Failures</td>
<td>Summarizes the total number of failed reassociation requests between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Reassociation Request Timeouts</td>
<td>Summarizes the total number of reassociation request timeouts between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Reassociation Request Success</td>
<td>Summarizes the total number of successful reassociation requests between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Reauthentication Request Failures</td>
<td>Summarizes the total number of failed reauthentication requests between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Reauthentication Request Timeouts</td>
<td>Summarizes the total number of reauthentication request timeouts that occurred between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Reauthentication Request Success</td>
<td>Summarizes the total number of successful reauthentication requests that occurred between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Invalid Association Request</td>
<td>Summarizes the total number of invalid association requests received by the parent mesh access point from the selected child mesh access point. This state might occur when the selected child is a valid neighbor but is not in a state that allows association.</td>
</tr>
</tbody>
</table>
Follow these steps to view the channel width.

**Step 1**  
Choose **Monitor > Access Points**.

**Note**  
The radio status (not an access point status) is displayed when you choose Monitor > Access Points. The given status is updated frequently from traps and wireless status polling and takes several minutes to reflect actual radio status. The overall status of an access point can be found by viewing the access point on a map. Click an access point in the AP Name column.

**Step 2**  
Click the **Interfaces** tab (see **Figure 6-1**).

### Table 6-3 Security Mesh Statistics (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unknown Association Requests</td>
<td>Summarizes the total number of unknown association requests received by the parent mesh access point from its child. The unknown association requests often occur when a child is an unknown neighbor mesh access point.</td>
</tr>
<tr>
<td>Invalid Reassociation Request</td>
<td>Summarizes the total number of invalid reassociation requests received by the parent mesh access point from a child. This might happen when a child is a valid neighbor but is not in a proper state for reassociation.</td>
</tr>
<tr>
<td>Unknown Reassociation Request</td>
<td>Summarizes the total number of unknown reassociation requests received by the parent mesh access point from a child. This might happen when a child mesh access point is an unknown neighbor.</td>
</tr>
</tbody>
</table>

### Monitoring Channel Width

Follow these steps to view the channel width.

**Step 1**  
Choose **Monitor > Access Points**.

**Note**  
The radio status (not an access point status) is displayed when you choose Monitor > Access Points. The given status is updated frequently from traps and wireless status polling and takes several minutes to reflect actual radio status. The overall status of an access point can be found by viewing the access point on a map. Click an access point in the AP Name column.

**Step 2**  
Click the **Interfaces** tab (see **Figure 6-1**).
Table 6-4 lists the parameter details that appear on the interfaces tab.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interface</td>
<td></td>
</tr>
<tr>
<td>Admin Status</td>
<td>Indicates whether the Ethernet interface is enabled.</td>
</tr>
<tr>
<td>Operational Status</td>
<td>Indicates whether the Ethernet interface is operational.</td>
</tr>
<tr>
<td>Rx Unicast Packets</td>
<td>Indicates the number of unicast packets received.</td>
</tr>
<tr>
<td>Tx Unicast Packets</td>
<td>Indicates the number of unicast packets sent.</td>
</tr>
<tr>
<td>Rx Non-Unicast Packets</td>
<td>Indicates the number of non-unicast packets received.</td>
</tr>
<tr>
<td>Tx Non-Unicast Packets</td>
<td>Indicates the number of non-unicast packets sent.</td>
</tr>
<tr>
<td>Radio Interfaces</td>
<td></td>
</tr>
<tr>
<td>Protocol</td>
<td>802.11a or 802.11b/g.</td>
</tr>
<tr>
<td>Admin Status</td>
<td>Indicates whether the access point is enabled or disabled.</td>
</tr>
<tr>
<td>Channel Number</td>
<td>Indicates the channel on which the Cisco Radio is broadcasting.</td>
</tr>
<tr>
<td>Extension Channel</td>
<td>Indicates the secondary channel on which the Cisco radio is broadcasting.</td>
</tr>
<tr>
<td>Power Level</td>
<td>Access Point transmit power level: 1 = Maximum power allowed per Country Code setting, 2 = 50% power, 3 = 25% power, 4 = 6.25 to 12.5% power, and 5 = 0.195 to 6.25% power.</td>
</tr>
<tr>
<td>Channel Width</td>
<td>Indicates the channel width for this radio interface. See &quot;Configuring 40-MHz Channel Bonding&quot; section on page 9-122 for more information on configuring channel bandwidth.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Minimum (default) setting is 20 MHz. Maximum setting is the maximum channel width supported by this radio.</td>
</tr>
<tr>
<td>Antenna</td>
<td>Identifies the type of antenna.</td>
</tr>
</tbody>
</table>

**Step 3** Click an interface name to view its properties (see Figure 6-2).
Table 6-5 lists the properties that appear on the Interface Properties page.

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AP Name</td>
<td>Name of the Access Point.</td>
</tr>
<tr>
<td>Link speed</td>
<td>Indicates the speed of the interface in Mbps.</td>
</tr>
<tr>
<td>RX Bytes</td>
<td>Indicates the total number of bytes in the error-free packets received on the interface.</td>
</tr>
<tr>
<td>RX Unicast Packets</td>
<td>Indicates the total number of unicast packets received on the interface.</td>
</tr>
<tr>
<td>RX Non-Unicast Packets</td>
<td>Indicates the total number of non-unicast or multicast packets received on the interface.</td>
</tr>
<tr>
<td>Input CRC</td>
<td>Indicates the total number of CRC error in packets received on the interface.</td>
</tr>
<tr>
<td>Input Errors</td>
<td>Indicates the sum of all errors in the packets while receiving on the interface.</td>
</tr>
<tr>
<td>Input Overrun</td>
<td>Indicates the number of times the receiver hardware was incapable of handing received data to a hardware buffer because the input rate exceeded the capability of a receiver to handle the data.</td>
</tr>
<tr>
<td>Input Resource</td>
<td>Indicates the total number of resource errors in packets received on the interface.</td>
</tr>
<tr>
<td>Runts</td>
<td>Indicates the number of packets that are discarded because they are smaller than the minimum packet size of the medium.</td>
</tr>
<tr>
<td>Throttle</td>
<td>Indicates the total number of times the interface advised a sending NIC that it was overwhelmed by packets being sent and to slow the pace of delivery.</td>
</tr>
<tr>
<td>Output Collision</td>
<td>Indicates the total number of packet retransmitted due to an Ethernet collision.</td>
</tr>
<tr>
<td>Output Resource</td>
<td>Indicates the total number of resource errors in packets transmitted on the interface.</td>
</tr>
</tbody>
</table>
Viewing Clients Identified as WGBs

If an access point is bridge capable, and the AP mode was set to Bridge, you can view clients identified as WGBs. WGB clients bridge wireless to wired. Any Cisco IOS access point can take on the role of a WGB, acting as a wireless client with a wired client connected to it. The information about this WGB is propagated to the controller and appears as a client in both WCS and WLC. To see a list of all clients identified as a workgroup bridges, follow these steps:

**Step 1** Choose **Monitor > Clients**.

**Step 2** From the drop-down list, choose **WGB Clients**. The Clients (detected as WGBs) page appears (see Figure 6-3).

---

**Table 6-5 Interface Properties (continued)**

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Errors</td>
<td>Indicates the sum of all errors that prevented the final transmission of packets out of the interface.</td>
</tr>
<tr>
<td>Operational Status</td>
<td>Indicates the operational state of the physical Ethernet interface on the AP.</td>
</tr>
<tr>
<td>Duplex</td>
<td>Indicates the duplex mode of an interface.</td>
</tr>
<tr>
<td>TX Bytes</td>
<td>Indicates the total number of bytes in the error-free packets transmitted on the interface.</td>
</tr>
<tr>
<td>TX Unicast Packets</td>
<td>Indicates the total number of unicast packets transmitted on the interface.</td>
</tr>
<tr>
<td>TX Non-Unicast Packets</td>
<td>Indicates the total number of non-unicast or multicast packets transmitted on the interface.</td>
</tr>
<tr>
<td>Input Aborts</td>
<td>Indicates the total number of packet aborted while receiving on the interface.</td>
</tr>
<tr>
<td>Input Frames</td>
<td>Indicates the total number of packet received incorrectly having a CRC error and a non-integer number of octets on the interface.</td>
</tr>
<tr>
<td>Input Drops</td>
<td>Indicates the total number of packets dropped while receiving on the interface because the queue was full.</td>
</tr>
<tr>
<td>Unknown Protocol</td>
<td>Indicates the total number of packet discarded on the interface due to an unknown protocol.</td>
</tr>
<tr>
<td>Giants</td>
<td>Indicates the number of packets that are discarded because they exceed the medium's maximum packet size.</td>
</tr>
<tr>
<td>Interface Resets</td>
<td>Indicates the number of times that an interface has been completely reset.</td>
</tr>
<tr>
<td>Output No Buffer</td>
<td>Indicates the total number of packets discarded because there was no buffer space.</td>
</tr>
<tr>
<td>Output Underrun</td>
<td>Indicates the number of times the transmitter has been running faster than the router can handle.</td>
</tr>
<tr>
<td>Output Total Drops</td>
<td>Indicates the total number of packets dropped while transmitting from the interface because the queue was full.</td>
</tr>
</tbody>
</table>
Retrieving the Unique Device Identifier on Controllers and Access Points

The unique device identifier (UDI) standard uniquely identifies products across all Cisco hardware product families, enabling customers to identify and track Cisco products throughout their business and network operations and to automate their asset management systems. The standard is consistent across all electronic, physical, and standard business communications. The UDI consists of five data elements:

- The orderable product identifier (PID)
- The version of the product identifier (VID)
- The serial number (SN)
- The entity name
- The product description

The UDI is burned into the EEPROM of controllers and lightweight access points at the factory and can be retrieved through the GUI.

To retrieve the UDI on controllers and access points, follow these steps:

**Step 1**  Choose **Monitor > Controllers**. The Monitor > Controllers page appears (see Figure 6-4).
Chapter 6  Monitoring Wireless Devices

Retrieving the Unique Device Identifier on Controllers and Access Points

Figure 6-4  Monitor > Controllers Page

Step 2  (Optional) If you want to change how the controller search results are displayed, click Edit View. The Edit View page appears (see Figure 6-5). In the left-hand page, highlight the areas you want to view and click Show to move them to the right-hand page. You can then highlight the areas in the right-hand menu and click Up or Down to rearrange the order.

Figure 6-5  Edit View Page

Step 3  Click the IP address of the controller (seen in Figure 6-4) whose UDI information you want to retrieve. Data elements of the controller UDI display. These elements are described in Table 6-6 and Table 6-7:

Table 6-6  Controllers Summary

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General Portion</strong></td>
<td></td>
</tr>
<tr>
<td>IP Address</td>
<td>Local network IP address of the controller management interface.</td>
</tr>
<tr>
<td>Name</td>
<td>User-defined name of the controller.</td>
</tr>
<tr>
<td>Type</td>
<td>The type of controller.</td>
</tr>
<tr>
<td>Note</td>
<td>For WiSM, the slot and port numbers are also given.</td>
</tr>
<tr>
<td>UP Time</td>
<td>Time in days, hours, and minutes since the last reboot.</td>
</tr>
<tr>
<td>System Time</td>
<td>Time used by the controller.</td>
</tr>
</tbody>
</table>
Table 6-6 Controllers Summary (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Internal Temperature</td>
<td>The current internal temperature of the unit (in Centigrade).</td>
</tr>
<tr>
<td>Location</td>
<td>User-defined physical location of the controller.</td>
</tr>
<tr>
<td>Contact</td>
<td>The contact person for this controller, their textual identification, and ways to contact them. If no contact information is known, this is an empty string.</td>
</tr>
<tr>
<td>Total Client Count</td>
<td>Total number of clients currently associated with the controller.</td>
</tr>
<tr>
<td>Current LWAPP Transport Mode</td>
<td>Lightweight Access Point Protocol transport mode. Communications between controllers and access points. Selections are Layer 2 or Layer 3.</td>
</tr>
<tr>
<td>Power Supply One</td>
<td>Indicates the presence or absence of a power supply and its operations state.</td>
</tr>
<tr>
<td>Power Supply Two</td>
<td>Indicates the presence or absence of a power supply and its operations state.</td>
</tr>
<tr>
<td><strong>Inventory Portion</strong></td>
<td></td>
</tr>
<tr>
<td>Software Version</td>
<td>The operating system release, version.dot.maintenance number of the code currently running on the controller.</td>
</tr>
<tr>
<td>Emergency Image Version</td>
<td></td>
</tr>
<tr>
<td>Description</td>
<td>Description of the inventory item.</td>
</tr>
<tr>
<td>Model No.</td>
<td>Specifies the machine model as defined by the Vital Product Data.</td>
</tr>
<tr>
<td>Serial No.</td>
<td>Unique serial number for this controller.</td>
</tr>
<tr>
<td>Burned-in MAC Address</td>
<td>The burned-in MAC address for this controller.</td>
</tr>
<tr>
<td>Number of APs supported</td>
<td>The maximum number of access points supported by the controller.</td>
</tr>
<tr>
<td>Gig Ethernet/Fiber Card</td>
<td>Displays the presence or absence of the optional 1000BASE-T/1000BASE-SX GigE card.</td>
</tr>
<tr>
<td>Crypto Card One</td>
<td>Displays the presence or absence of an enhanced security module which enables IPsec security and provides enhanced processing power. See Table 6-7 for information on the maximum number of crypto cards that can be installed on a controller.</td>
</tr>
<tr>
<td>Crypto Card Two</td>
<td>Displays the presence or absence of a second enhanced security module.</td>
</tr>
<tr>
<td><strong>GIGE Port(s) Status</strong></td>
<td></td>
</tr>
<tr>
<td>Port 1</td>
<td>Up or Down.</td>
</tr>
<tr>
<td>Port 2</td>
<td>Up or Down.</td>
</tr>
<tr>
<td><strong>Unique Device Identifier (UDI)</strong></td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Product type. Chassis for controller and Cisco AP for access points.</td>
</tr>
</tbody>
</table>
Monitoring Coverage Hole

Coverage holes are areas where clients cannot receive a signal from the wireless network. The Cisco Unified Wireless Network Solution Radio Resource Management (RRM) identifies these coverage hole areas and reports them to the WCS, enabling the IT manager to fill holes based on user demand.

WCS is informed about the reliability-detected coverage holes by the controllers. WCS alerts the user about these coverage holes. For more information on finding coverage holes, refer to Cisco Context-Aware Services documentation at this location:


Coverage holes are displayed as alarms. Pre-coverage holes are displayed as events.

Monitoring Pre-Coverage Holes

While coverage holes are displayed as alarms, pre-coverage holes are displayed as events.

To view pre-coverage hole events, follow these steps:

1. Choose **Monitor > Events** to display all current events.
2. To view pre-coverage hole events only, click the **Advanced Search** link.
3. In the New Search page, change the Search Category drop-down to **Events**.
4. From the Event Category drop-down list, choose **Pre Coverage Hole**, and click **Go**.

The Pre-Coverage Hole Events page provides the information described in the following table (see Table 6-8):

---

**Table 6-6 Controllers Summary (continued)**

<table>
<thead>
<tr>
<th>Description</th>
<th>Description of controller and may include number of access points.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product Id</td>
<td>Orderable product identifier.</td>
</tr>
<tr>
<td>Version Id</td>
<td>Version of product identifier.</td>
</tr>
<tr>
<td>Serial Number</td>
<td>Unique product serial number.</td>
</tr>
</tbody>
</table>

**Table 6-7 Maximum Number of Crypto Cards That Can Be Installed on a Cisco Wireless LAN Controller**

<table>
<thead>
<tr>
<th>Type of Controller</th>
<th>Maximum Number of Crypto Cards</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco 2000 Series</td>
<td>None</td>
</tr>
<tr>
<td>Cisco 4100 Series</td>
<td>One</td>
</tr>
<tr>
<td>Cisco 4400 Series</td>
<td>Two</td>
</tr>
</tbody>
</table>

---
Step 5  Choose a Client MAC Address to view pre-coverage hole details.
- General—Provides the following information:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Severity</td>
<td>Pre-coverage hole events are always considered informational (Info).</td>
</tr>
<tr>
<td>Client MAC Address</td>
<td>MAC address of the client affected by the pre-coverage hole.</td>
</tr>
<tr>
<td>AP MAC Address</td>
<td>MAC address of the applicable access point.</td>
</tr>
<tr>
<td>AP Name</td>
<td>The name of the applicable access point.</td>
</tr>
<tr>
<td>Radio Type</td>
<td>The radio type (802.11b/g or 802.11a) of the applicable access point.</td>
</tr>
<tr>
<td>Power Level</td>
<td>Access point transmit power level: 1 = Maximum power allowed per country code setting, 2 = 50% power, 3 = 25% power, 4 = 6.25 to 12.5% power, and 5 = 0.195 to 6.25% power.</td>
</tr>
<tr>
<td>Client Type</td>
<td>Client type can be any of the following: laptop(0), pc(1), pda(2), dot11mobilephone(3), dualmodephone(4), wgb(5), scanner(6), tabletpc(7), printer(8), projector(9), videoconfsystem(10), camera(11), gamingsystem(12), dot11deskphone(13), cashregister(14), radiotag(15), rfidSensor(16), server(17)</td>
</tr>
<tr>
<td>WLAN Coverage Hole Status</td>
<td>Determines if the current coverage hole state is enabled or disabled.</td>
</tr>
<tr>
<td>WLAN</td>
<td>The name for this WLAN.</td>
</tr>
<tr>
<td>Date/Time</td>
<td>The date and time the event occurred. Click the title to toggle between ascending and descending order.</td>
</tr>
</tbody>
</table>
Monitoring Tags

The Monitor > Tags page allows you to monitor tag status and location on WCS maps as well as review tag details.

Note
This page is only available in the Location version of WCS.

Choose Monitor > Tags to access this section. By default, Tag Summary page is displayed. This section provides information on the tags detected by the location appliance and contains the following topics:

- Tag Summary
- Searching Tags
- Viewing Search Results
- Viewing Tag List

Tag Summary

Choose Monitor > Tags to access this page.

This page provides information on the number of tags that are detected by the location appliance. The following parameters are displayed on the main data area:

- Device Name
- Device Address
- Total Tags—Click the number to view tag details.
Searching Tags

Use the WCS Advanced Search feature to find specific or all tags.

To search for tags in WCS, follow these steps:

**Step 1**  
Click **Advanced Search**.

**Step 2**  
Select **Tags** from the Search Category drop-down list.

**Step 3**  
Identify the applicable tag search parameters including:

- Search By—Choose All Tags, Asset Name, Asset Category, Asset Group, MAC Address, Controller, MSE, Floor Area, or Outdoor Area.

**Note**  
Search parameters may change depending on the selected category. When applicable, enter the additional parameter or filter information to help identify the Search By category.

- Search In—Choose MSEs or WCS Controllers.
- Last detected within—Choose a time increment from 5 minutes to 24 hours. The default is 15 minutes.
- Tag Vendor—Select the check box and choose Aeroscout, G2, PanGo, or WhereNet.
- Telemetry Tags only—Check the Telemetry Tags only to search tags accordingly.

**Step 4**  
Click **Go**.

Viewing Search Results

Use the WCS Advanced Search feature located at the top right of the WCS window to search for tags by asset type (name, category and group), by MAC address, by system (controller or location appliance), and by area (floor area and outdoor area).

**Note**  
Search parameters may change depending on the selected category. When applicable, enter the additional parameter or filter information to help identify the Search By category.

You can further refine your search using the Advanced search parameters and save the search criteria for future use. Saved search criteria can be retrieved from the Saved Searches located in the navigation bar.

See “Advanced Search” section on page 2-35 or “Saved Searches” section on page 2-46 for additional information.

When you click the MAC address of a tag location in a search results page, the following details appear for the tag:

- Tag vendor

**Note**  
This option does not appear when Asset Name, Asset Category, Asset Group, or MAC Address are the search criteria for tags.
• Controller to which tag is associated
• Telemetry data (CCX v1 compliant tags only)
  – Telemetry data displayed is vendor-specific; however, some commonly reported details are GPS location, battery extended information, pressure, temperature, humidity, motion, status, and emergency code.

  **Note**  The Telemetry data option only appears when MSE (select for location servers), Floor Area, or Outdoor Area are selected as the Search for tags by option.

  **Note**  Only those vendor tags that support telemetry appear.

• Asset Information (Name, Category, Group)
• Statistics (bytes and packets received)
• Location (Floor, Last Located, MSE, map)
• Location Notification (Absence, Containment, Distance, All)

  **Note**  Telemetry data displayed is vendor-specific; however, some commonly reported details are GPS location, battery extended information, pressure, temperature, humidity, motion, status, and emergency code.

• Emergency Data (CCX v1 compliant tags only)

**Viewing Tag List**

Click the **Total Tags** number link to view the Tags list for the applicable device name. The Tag list includes the following information:

• MAC Address
• Asset Name
• Asset Group
• Asset Category
• Vendor Name
• Mobility Services Engine
• Controller
• Battery Status
• Map Location
Monitoring Chokepoints

Chokepoints are installed and configured as recommended by the Chokepoint vendor. After the chokepoint installation is complete and operational, the chokepoint can be added to WCS and placed on Floor Maps. They are pushed to the Location Server during synchronization.

Choose Monitor > Chokepoints to access this section. A page appears displaying a list of found chokepoints. Clicking the link under Map Location for a particular chokepoint displays a map that shows the location of the chokepoint.

The following parameters are displayed:

- **MAC Address**—The MAC address of the chokepoint.
- **Chokepoint Name**—The user-defined name of the chokepoint.
- **Entry/Exit Chokepoint**—Indicates whether or not the chokepoint is an entry/exit chokepoint.
- **Range**—The range of the chokepoint in feet.
- **Static IP**—The static IP address of the chokepoint.
- **Map Location**—A link to a map showing the location of the chokepoint.

Performing a Chokepoint Search

An advanced search allows you to search for chokepoints.

To perform an advanced search for a chokepoint in WCS, follow these steps:

1. Click Advanced Search located in the top right corner of WCS.
2. From the New Search page, select Chokepoint from the Search Category drop-down list.
3. Select the method by which you want to search (by MAC address or chokepoint name) from the Search for Chokepoint by drop-down list.
4. Enter the MAC address or chokepoint name, depending on the search method selected.
5. Click Search.

Monitoring Interferers

The Monitor > Interferer page allows you to monitor interference devices detected by the CleanAir enabled access points.

This section provides information on the interferers detected by the CleanAir enabled access points and contains the following topics:

- **Monitoring AP Detected Interferers**, page 6-68
- **Monitoring AP Detected Interferer Details**, page 6-69
- **Configuring the Search Results Display**, page 6-70

By default, the “Monitoring AP Detected Interferers” section on page 6-68 page is displayed.
Monitoring AP Detected Interferers

Choose Monitor > Interferers to view all the interfering devices detected by the CleanAir enabled access points on your wireless network. This page enables you to view a summary of the interfering devices including the following default information:

- Interferer ID—A unique identifier for the interferer. Click this link to know more about the interferer.
- Type—Indicates the category of the interferer. Click to read more about the type of device. A page appears displaying more details. The categories includes the following:
  - Bluetooth link—A Bluetooth link (802.11b/g/n only)
  - Microwave Oven—A microwave oven (802.11b/g/n only)
  - 802.11 FH—An 802.11 frequency-hopping device (802.11b/g/n only)
  - Bluetooth Discovery—A Bluetooth discovery (802.11b/g/n only)
  - TDD Transmitter—A time division duplex (TDD) transmitter
  - Jammer—A jamming device
  - Continuous Transmitter—A continuous transmitter
  - DECT-like Phone—A digital enhanced cordless communication (DECT)-compatible phone
  - Video Camera—A video camera
  - 802.15.4—An 802.15.4 device (802.11b/g/n only)
  - WiFi Standard—A device using standard Wi-Fi channels
  - WiFi Inverted—A device using spectrally inverted Wi-Fi signals
  - WiFi Invalid Channel—A device using non-standard Wi-Fi channels
  - SuperAG—An 802.11 SuperAG device
  - Canopy—A Motorola Canopy device
  - Radar—A radar device (802.11a/n only)
  - XBox—A Microsoft Xbox (802.11b/g/n only)
  - WiMAX Mobile—A WiMAX mobile device (802.11a/n only)
  - WiMAX Fixed—A WiMAX fixed device (802.11a/n only)
  - WiFi AOCI—A WiFi device with AOCI
  - Unclassified
- Status—Indicates the status of the interfering device.
  - Active—Indicates that the interferer is currently being detected by the CleanAir capable access point.
  - Inactive—Indicates that the interferer is no longer being detected by the CleanAir capable access point or no longer reachable by WCS.
- Severity—Displays the severity ranking of the interfering device.
- Affected Band—Displays the band in which this device is interfering.
- Affected Channels—Displays the affected channels.
- Duty Cycle (%)—The duty cycle of interfering device in percentage.
- Discovered—Displays the time at which it was discovered.
• Last Updated—The last time the interference was detected.
• Floor—The location where the interfering device is present.

**Monitoring AP Detected Interferer Details**

Choose **Monitor > Interferers > Interferer ID** to view this page. This page enables you to view the details of the interfering devices detected by the access points. This page provides the following details about the interfering device.

- **Interferer Properties**
  - **Type**—Displays the type of the interfering device detected by the AP.
  - **Status**—The status of the interfering device. Indicates the status of the interfering device.
    - **Active**—Indicates that the interferer is currently being detected by the CleanAir capable access point.
    - **Inactive**—Indicates that the interferer is no longer being detected by the CleanAir capable access point or no longer reachable by WCS.
  - **Severity**—Displays the severity ranking of the interfering device.
  - **Duty Cycle (%)**—The duty cycle of interfering device in percentage.
  - **Affected Band**—Displays the band in which this device is interfering.
  - **Affected Channels**—Displays the affected channels.
  - **Discovered**—Displays the time at which it was discovered.
  - **Last Updated**—The last time the interference was detected.

- **Location**
  - **Floor**—The location where this interfering device was detected.
  - **Last Located At**—The last time where the interfering device was located.
  - **On MSE**—The Mobility Server Engine on which this interference device was located.

- **Clustering Information**
  - **Clustered By**—Displays the IP address of the controller or the MSE that clustered the interferer information from the access point.
  - **Detecting APs**—Displays the details of the access point that has detected the interfering device. The details include: Acces Point Name (Mac), Severity, and Duty Cycle(%).

- **Details**—Displays a short description about the interfering type.

**Select a command**

The Select a command drop-down list provides access to the location history of the interfering device detected by the access point. See “**Monitoring AP Detected Interferer Details Location History**” section on page 6-69.

**Monitoring AP Detected Interferer Details Location History**

Choose **Monitor > Interferers > Interference Device ID**, choose **Location History** from the Select a command drop-down list, and click **Go** to view this page.
• Interferer Information—Displays the basic information about the interfering device.
  – Data Collected At—The time stamp at which the data was collected.
  – Type—The type of the interfering device.
  – Severity—The severity index of the interfering device.
  – Duty Cycle—The duty cycle (in percentage) of the interfering device.
  – Affected Channels—A comma separated list of the channels affected.

• Interferer Location History—Displays the location history of the interfering devices.
  – Time Stamp
  – Floor

• Clustering Information
  – Clustered By

• Detecting APs
  – AP Name—The access point that detected the interfering device.
  – Severity—The severity index of the interfering device.
  – Duty Cycle(%)—The duty cycle (in percentage) of the interfering device.

• Location
  – Location Calculated At—Displays the time stamp at which this information was generated.
  – Floor—Displays location information of the interfering device.
  – A graphical view of the location of the interfering device is displayed in a map. Click the Enlarge link to view an enlarged image.

Configuring the Search Results Display

The Edit View page allows you to add, remove, or reorder columns in the AP Detected Interferers Summary page.

To edit the columns in the AP Detected Interferers page, follow these steps:

**Step 1** Choose Monitor > Interferers. The AP Detected Interferers page appears showing details of the interferers detected by the CleanAir enabled access points.

**Step 2** Click the Edit View link.

**Step 3** To add an additional column to the access points table, click to highlight the column heading in the left column. Click Show to move the heading to the right column. All items in the right column are displayed in the table.

**Step 4** To remove a column from the access points table, click to highlight the column heading in the right column. Click Hide to move the heading to the left column. All items in the left column are not displayed in the table.

**Step 5** Use the Up/Down buttons to specify the order in which the information appears in the table. Highlight the desired column heading and click Up or Down to move it higher or lower in the current list.

**Step 6** Click Reset to restore the default view.

**Step 7** Click Submit to confirm the changes.
Monitoring WiFi TDOA Receivers

To monitor Wi-Fi TDOA receivers, follow these steps:

**Step 1** Choose Monitor > WiFi TDOA Receivers. The WiFi TDOA Receiver summary page appears showing all mapped WiFi TDOA receivers.

**Step 2** To refine the search criteria when an extensive lists appears, you can search by MAC address or location sensor name.

- a. To initiate a search for a TDOA receiver by its MAC address, click the Advanced Search link in the WCS window. Select WiFi TDOA Receiver from the Search Category drop-down list and MAC Address from the Search by drop-down list. Enter the MAC address of the TDOA receiver in the available text box, and click Search.

- b. To initiate a search for a TDOA receiver by its name, click Advanced Search link in the WCS window. Select WiFi TDOA Receiver from the Search Category drop-down list and WiFi TDOA Receivers from the Search by drop-down list. Enter the name of the TDOA receiver in the available text box, and click Search.

If no match exists, then a message indicating that appears in the page. Otherwise the search result displays.

---

**Note** See “Using the Search Feature” section on page 2-34 or “Advanced Search” section on page 2-35 for more information on the WCS Search feature.

The WiFi TDOA Receivers page displays the following information:

- MAC Address
- WiFi TDOA Receiver Name
- Static IP—Static IP address of the WiFi TDOA receiver.
- Oper Status—Up or down.
- Map Location—Click the Map Location link to view the floor map for this WiFi TDOA receiver. See “Floor Area” section on page 5-4 for more information on WCS floor maps.

---

**Note** See “Configuring WiFi TDOA Receivers” section on page 5-61 for more information on adding, configuring, and editing WiFi TDOA receivers.

---

Monitoring Spectrum Experts

A Spectrum Expert client acts as a remote interference sensor and sends dynamic interference data to WCS. This feature allows the WCS to collect and archive and monitor detailed interferer and air quality data from Spectrum Experts in the network.

This section contains the following topics:

- Spectrum Experts Summary, page 6-72
- Interferers Summary, page 6-72
To access the Monitor Spectrum Experts page, follow these steps:

**Step 1** Choose **Monitor > Spectrum Experts**.

**Step 2** From the left sidebar menu, you can access the “Spectrum Experts Summary” section on page 6-72 and the “Interferers Summary” section on page 6-72.

### Spectrum Experts Summary

The **Spectrum Experts > Summary** page is the default page and provides a table of the Spectrum Experts added to the system. The table provides the following Spectrum Expert information:

- **Hostname**—Displays the hostname or IP Address depending on how it was added. Click the hostname to access the “Spectrum Experts Details” section on page 6-73 page.
- **Active Interferers**—Indicates the current number of interferes being detected by the Spectrum Experts.
- **Affected APs**—The number of access points seen by the Spectrum Expert that are potentially affected by detected interferers.
- **Alarms**—The number of active interference traps sent by the Spectrum Expert. Click to access the Alarm page that is filtered to the active alarms for this Spectrum Expert.
- **Reachability Status**—Indicates “Reachable” in green if the Spectrum Expert is running and sending data to WCS; otherwise indicates “Unreachable” in red.
- **Location**—When the Spectrum is a wireless client, a link is available that displays the location of the Spectrum Expert. A red box around the Spectrum Expert indicates the effective range. Click to access the nearest mapped access point.

### Interferers Summary

The **Interferers > Summary** page displays a list of all the Interferers detected over a 30 day interval. The table provides the following Interferers information:

- **Interferer ID**—An identifier that is unique across different spectrum experts.
- **Category**—Indicates the category of the interferer. Categories include: Bluetooth, Cordless Phones, Microwave Ovens, 802.11 FH, Generic - Fixed-Frequency, Jammers, Generic - Frequency-Hopped, Generic - Continuous.
- **Type**—Indicates the type of Interferer. Click to access a pop-up description of the type.
- **Status**—Indicates Active or Inactive.
  - **Active**—Indicates that the interferer is currently being detected by a spectrum expert.
  - **Inactive**—Indicates that the interferer is no longer detected by a spectrum expert or the spectrum expert that saw the interferer is no longer reachable by WCS.
- **Discover Time**—Indicates the time of discovery.
- **Affected Channels**—Identifies affected channels.
- **Number of APs Affected**—An access point is listed as Affected if the following conditions are met:
  - The access point is managed by WCS.
– The spectrum expert detects the access point.
– The spectrum expert detects an interferer on the serving channel of the access point.

- Power—Indicated in dBm.
- Duty Cycle—Indicated in percentage.

**Note** 100% indicates the worst value.

- Severity—Indicates the severity ranking of the Interferer.

**Note** 100% indicates the worst value where 0 indicates no interference.

**Interferers Search**

Use the WCS Search feature to find specific Interferers or to create and save custom searches. See one of the following topics for additional information:

- Using the Search Feature, page 2-34
- Quick Search, page 2-34
- Advanced Search, page 2-35
- Saved Searches, page 2-46

**Spectrum Experts Details**

The Spectrum Expert Details page provides all interference details from a single Spectrum Expert. This page updates every 20 seconds providing a real-time look at what is happening on the remote Spectrum Expert and includes the following items:

- Total Interferer Count—As seen by the specific Spectrum Expert.
- Active Interferers Count Chart—Displays a pie chart that groups interferes by category.
- Active Interferer Count Per Channel—Displays the number of interferes grouped by category on different channels.
- AP List—Provides a list of access points detected by the Spectrum Expert that are on channels that have active interferers detected by the Spectrum Expert on those channels.
- Affected Clients List—Provides a list of clients that are currently authenticated/associated to the radio of one of the access points listed in the access point list.

**Monitoring Media Streams**

To monitor Media Streams, choose **Monitor > Media Streams**. The Media Streams listing page appears showing a list of media streams configured across all controllers. The page provides the following information in a tabular format:

- Stream Name
- Start IP
Media Stream Details

In the Media Stream listing page, click a media stream name to get detailed information about the media stream. The media stream details consists of the following information:

- Media Stream Details
  - Media Stream Name
  - Multicast Destination Start IP—Start IP address of the media stream to be multicast.
  - Multicast Destination End IP—End IP address of the media stream to be multicast.
  - Maximum Expected Bandwidth—Maximum bandwidth that a media stream can use.
  - Operational Status
  - Average Packet Size—Average packet size that a media stream can use.
  - RRC Periodical Update—Resource Reservation Control calculations that are updated periodically; if disabled, RRC calculations are done only once when a client joins a media stream.
  - RRC Priority—Priority of RRC with the highest at 1 and the lowest at 8.
  - Traffic Profile Violation—Displays if the stream is dropped or put in the best effort queue if the stream violates the QoS video profile.
  - Policy—Displays if the media stream is admitted or denied.

- Statistics
  - Number of Controllers—Number of Controllers using this media stream
  - Number of Clients—Number of Clients using this media stream

Note: Clicking the Controller Count takes you to the Controller monitoring page, where the controllers using this media stream are displayed. Similarly, clicking the Client count takes you to the Client monitoring page, where the clients using this media stream are displayed.

- Client Counts—A graphical representation of the number of clients
- Failed Client Counts—A graphical representation of the number of failed clients
Media Stream Search

Use the WCS Search box to find specific media streams or to create and save custom searches. See one of the following topics for additional information:

- Using the Search Feature, page 2-34
- Quick Search, page 2-34
- Advanced Search, page 2-35
- Saved Searches, page 2-46

Monitoring Interactive Graphs

This section contains the following topics:

- Interactive Graphs Overview, page 6-75
- Interactive Graph Features, page 6-75
- Time-Based Graphs, page 6-76

Interactive Graphs Overview

Interactive graph features are based upon Adobe Flex technology that uses flash to render the graphs on the browser and provide interactivity to the user.

Minimum Requirements include:

- Windows—Flash Player version 9.0.47.0.
- Linux—Flash Player version 9.0.48.0.

**Note** If you do not have a flash player or your version is not recent enough, an error page prompts you with this information. Click the **Get Latest Flash Player** link to access Adobe website. From this site, you can download the latest version of the flash player. You only need to download the flash player once. Remember to restart the browser following the download.

WCS Interactive Graphs include line, area, pie, and stacked bar graphs.

Interactive Graph Features

Interactive graph features include:

- Two distinct types of graphs:
  - Time-Based Graphs
  - Non-Time based
- Support for automatic refresh—The graphs refresh automatically within a predetermined interval of time.
- Two graph views:
  - Graph (Chart) view (default)
Table (Grid) view

**Note** Use the two toggle buttons located at the bottom left side of the graph page to switch between the two graph views. To view the button type, hold your mouse over the applicable button for a tool tip identifying **View in Chart** or **View in Grid**. Click **View in Chart** to view the data in a graph. Click **View in Grid** to view the data in a table.

- Enlarged View—Click the button located at the bottom right side of the graph to enlarge the graph in a separate page. The Chart View and Grid View buttons are available in the new page to change the type of graph displayed.

### Time-Based Graphs

For graphs that are time-based, there is a link bar at the top of the graph page that displays 6h, 1d, 1w, 2w, 4w, 3m, 6m, 1y, and Custom. When selected, the data for that time frame is retrieved and the corresponding graph is displayed. The time-frame options include the following:

- **6h**—Denotes the last six hours of data from the current time. The data is gathered from the current database table.
- **1d**—Denotes the last day (24 hours) of data from the current time. The data is gathered from the current database table.
- **1w**—Denotes the last week (seven days) of data from the current time. The data is gathered from the hourly aggregated table.
- **2w**—Denotes the last two weeks of data from the current time. The data is gathered from the hourly aggregated table.
- **4w**—Denotes the last four weeks of data from the current time. The data is gathered from the hourly aggregated table.
- **3m**—Denotes the last three months of data from the current time. The data is gathered from the daily aggregated table.
- **6m**—Denotes the last six months of data from the current time. The data is gathered from the weekly aggregated table.
- **1y**—Denotes the past year (12 months) of data from the current time. The data is gathered from the weekly aggregated table.
- **Custom**—User-selected time period. Both days and hours can be set for the start and end dates. The use of a current or hourly, daily, or weekly aggregated source for data depends upon the selected start date.

**Note** The data management settings for aggregated tables are located in “Configuring Data Management” section on page 16-69 under the Administration menu. The default settings have a value of 31 days for Daily Aggregated Data and ten weeks for Weekly Aggregated Data.
Monitoring Radio Resource Management (RRM)

The operating system security solution uses the Radio Resource Management (RRM) function to continuously monitor all nearby access points, automatically discover rogue access points, and locate them as described in the “Monitoring Rogue Access Point Location, Tagging, and Containment” section on page 6-110.

Radio Resource Management (RRM) built into the Cisco Unified Wireless Network monitors and dynamically corrects performance issues found in the RF environment.

Prior to WCS software release 5.1, WCS would receive traps whenever a change in the transmit power of the access point or channel occurred. These trap events or similar events such as RF regrouping were logged into WCS events as informational and were maintained by the event dispatcher. The reason behind the transmit power or channel changes (such as signals from neighboring access points, interference, noise, load, and the like) were not evident. You could not view these events and statistics to then perform troubleshooting practices.

WCS software release 5.1 introduces a snapshot of the Radio Resource Management (RRM) statistics. It helps to identify trouble spots and provides possible reasons for channel or power level changes. The dashboard provides network-wide RRM performance statistics and predicts reasons for channel changes based on grouping the events together (worst performing access points, configuration mismatch between controllers in the same RF group, coverage holes that were detected by access points based on threshold, pre-coverage holes that were detected by controllers, ratios of access points operating at maximum power, and so on).

Note

The RRM dashboard information is only available for lightweight access points.

- Channel Change Notifications
- Transmission Power Change Notifications
- RF Grouping Notifications
- Viewing the RRM Dashboard

Channel Change Notifications

Notifications are sent to the WCS RRM dashboard when a channel change occurs. Channel changes depend on the Dynamic Channel Assignment (DCA) configuration where the mode can be set to auto or on demand. When the mode is auto, channel assignment is periodically updated for all lightweight access points which permit this operation. When the mode is set to on demand, channel assignments are updated based upon request. If the DCA is static, no dynamic channel assignments occur, and values are set to their global default.

When a channel change trap is received and a channel change had occurred earlier, the event is marked as Channel Revised; otherwise, the event is marked as Channel Changed. Each event for channel change can be caused by multiple reasons. The reason code is factored and equated to one irrespective of the number of reasons for the event to occur. For example, suppose a channel change is caused by signal, interference, or noise. When the reason code is received in the notification, the reason code is refactored across the reasons. If three reasons caused the event to occur, the reason code is refactored to 1/3 or 0.33 per reason. If ten channel change events are received with the same reason code, all of the three reasons are equally factored to determine the cause of the channel change.
Monitoring Radio Resource Management (RRM)

Transmission Power Change Notifications

Notifications are sent to the WCS RRM dashboard when transmission power changes occur. Each event for transmit power changes is caused by multiple reasons. The reason code is factored and equated to one irrespective of the number of reasons for the event to occur.

RF Grouping Notifications

When RRM is run on the controller, dynamic grouping is done, and a new group leader is chosen. Dynamic grouping has three modes: Automatic, Off and Leader. When the grouping is Off, no dynamic grouping occurs, and each switch optimizes only its own lightweight access point parameters. When the grouping is Automatic, switches form groups and elect leaders to perform better dynamic parameter optimization. With grouping automatic, configured intervals (in seconds) represent the period with which the grouping algorithm is run. (Grouping algorithms also run when the group contents change and automatic grouping is enabled.)

Viewing the RRM Dashboard

The RRM dashboard is accessed by choosing Monitor > RRM.

The dashboard is made up of the following parts:

- The RRM RF Group Summary shows the number of different RF groups.

  Note
  To get the latest number of RF Groups, you must run the configuration sync background task.

- The RRM Statistics portion shows network-wide statistics.

- The Channel Change Reason portion shows why channels changed for all 802.11a/b/g/n radios.

  - Signal—The channel changed because it improved the channel quality for some other neighbor radio(s). Improving the channel quality for some other neighbor radio(s) improved the channel plan of the system as evaluated by the algorithm.
  - Wifi Interference
  - Load
  - Radar
  - Noise
  - Persistent Non-Wifi Interference
  - Major Air Quality Event
  - Other

- The Channel Change shows all events complete with causes and reasons.

- The Configuration Mismatch portion shows comparisons between leaders and members.

- The Coverage Hole portion rates how severe the coverage holes are and gives their location.

- The Percent Time at Maximum Power shows what percent of time the access points were at maximum power and gives the location of those access points.

The following statistics are displayed:
• Total Channel Changes—The sum total of channel changes across 802.11a/b/g/n radios, irrespective of whether the channel was updated or revised. The count is split over a 24-hour and 7-day period. If you click the percentages link or the link under the 24-hour column, a page with details for that access point only appears.

• Total Configuration Mismatches—The total number of configuration mismatches detected over a 24-hour period.

• Total Coverage Hole Events—The total number of coverage hole events over a 24-hour and 7-day period.

• Number of RF Groups—The total number of RF groups (derived from all the controllers which are currently managed by WCS).

• Configuration Mismatch—The configuration mismatch over a 24-hour period by RF group with details on the group leader.

• APs at MAX Power—The percentage of access points with 802.11a/n radios as a total percentage across all access points which are at maximum power. The maximum power levels are preset and are derived with reference to the preset value.

Note: Maximum power is shown in three areas of the RRM dashboard. This maximum power portion shows the current value and is poll driven.

• Channel Change Causes—A graphical bar chart for 802.11a/n radios. The chart is factored based on the reason for channel change. The chart is divided into two parts, each depicting the percentage of weighted reasons causing the event to occur over a 24-hour and 7-day period. Each event for channel change can be caused by multiple reasons, and the weight is equally divided across these reasons. The net reason code is factored and equated to one irrespective of the number of reasons for the event to occur.

• Channel Change - APs with channel changes—Each event for channel change includes the MAC address of the lightweight access point. For each reason code, you are given the most channel changes that occurred for the 802.11a/n access point based on the weighted reason for channel events. This count is split over a 24-hour and 7-day period.

• Coverage Hole - APs reporting coverage holes—The top five access points filtered by IF Type 11a/n which triggered a coverage hole event (threshold based) are displayed.

• Aggregated Percent Max Power APs—A graphical progressive chart of the total percentage of 802.11a/n lightweight access points which are operating at maximum power to accommodate coverage holes events. The count is split over a 24-hour and 7-day period.

Note: This maximum power portion shows the values from the last 24 hours and is poll driven. This occurs every 15 minutes or as configured for radio performance.

• Percent Time at Maximum Power—A list of the top five 802.11a/n lightweight access points which have been operating at maximum power.

Note: This maximum power portion shows the value from the last 24 hours and is only event driven.
Monitoring Alarms

This section contains the following topics:

- Alarms and Events Overview, page 6-80
- Using the Alarm Summary, page 6-80
- Customizing Alarm Summary Results, page 6-83
- Configuring Alarm Severity, page 6-84
- Viewing Alarms, page 6-85
- Configuring the Search Results Display, page 6-85
- Viewing Alarm Details, page 6-87

Alarms and Events Overview

An event is an occurrence or detection of some condition in and around the network. For example, it can be a report about radio interference crossing a threshold, the detection of a new rogue access point, or a controller rebooting.

Events are not generated by a controller for each and every occurrence of a pattern match. Some pattern matches must occur a certain number of times per reporting interval before they are considered a potential attack. The threshold of these pattern matches is set in the signature file. Events can then generate alarms which further can generate e-mail notifications if configured as such.

An alarm is a Cisco WCS response to one or more related events. If an event is considered of high enough severity (critical, major, minor, or warning), the WCS raises an alarm until the resulting condition no longer occurs. For example, an alarm may be raised while a rogue access point is detected, but the alarm terminates after the rogue has not been detected for several hours.

One or more events can result in a single alarm being raised. The mapping of events to alarms is their correlation function. For example, some IDS events are considered to be network wide so all events of that type (regardless of which access point the event is reported from) map to a single alarm. On the other hand, other IDS events are client-specific. For these, all events of that type for a specific client MAC address map to an alarm which is also specific for that client MAC address, regardless of whether multiple access points report the same IDS violation. If the same kind of IDS violation takes place for a different client, then a different alarm is raised.

A WCS administrator currently has no control over which events generate alarms or when they time out. On the controller, individual types of events can be enabled or disabled (such as management, SNMP, trap controls, and so on).

Using the Alarm Summary

When WCS receives an alarm message from a controller, it displays an alarm indicator at the top of the WCS page (see Figure 6-6).

Note: The Administration > Settings > Alarms page has a Hide Acknowledged Alarms check box. You must unselect the preference of hiding acknowledged alarms if you want acknowledged alarms to show on the WCS Alarm Summary and alarms lists page. By default, acknowledged alarms are not shown.
Critical (red), Major (orange) and Minor (yellow) alarms are shown in the alarm dashboard, left-to-right.

**Figure 6-6  WCS Alarm Summary**

Alarms indicate the current fault or state of an element that requires attention, and they are usually generated by one or more events. The alarm can be cleared but the event remains.

**Note**
Alarm counts refresh every 15 seconds.

**Note**
If an alarm is acknowledged, it does not appear on the alarm summary page by default. To change this setting, choose Administration > Settings > Alarms and unselect the Hide acknowledged alarms check box.

Alarms are color coded as follows:
- Red—Critical Alarm
- Orange—Major Alarm
- Yellow—Minor Alarm

The Alarm Summary displays the number of current critical, major, and minor alarms (see Figure 6-7).
Click the alarm count number link in the Alarm Summary page to view the Monitor > Alarms page for these alarms.

Click the blue down arrow in the Alarm Summary page to expand the alarm summary (see Figure 6-8).
The expanded summary includes alarm counts for the following:

- **Access Points**—Displays counts for AP alarms such as AP Disassociated from controller, Thresholds violation for Load, Noise or Interference, AP Contained as Rogue, AP Authorization Failure, AP regulatory domain mismatch, or Radio card Failure. See the “Configuring Alarm Severity” section on page 6-84 for more information.

- **Controllers**—Displays counts for controller alarms, such as reachability problems from WCS and other controller failures (fan failure, POE controller failure, AP license expired, link down, temperature sensor failure, and low temperature sensed). See the “Configuring Alarm Severity” section on page 6-84 for more information.

- **Coverage Hole**—Displays counts for coverage hole alarms generated for access points whose clients are not having enough coverage set by thresholds. See the “Monitoring Maps” for more information.

- **Malicious AP**—Displays counts for malicious rogue access points alarms. See the “Configuring Alarm Severity” section on page 6-84 for more information.

- **Mesh Links**—Displays counts for mesh link alarms, such as poor SNR, console login, excessive parent change, authorization failure, or excessive association failure. See the “Configuring Alarm Severity” section on page 6-84 for more information.

- **Mobility**—Displays counts for location alarms such as reachability problems from WCS and location notifications (In/Out Area, Movement from Marker, or Battery Level). See the “Configuring Alarm Severity” section on page 6-84 for more information.

- **Security**—Displays counts for security alarms such as Signature Attacks, AP Threats/Attacks, and Client Security Events. See the “Configuring Alarm Severity” section on page 6-84 for more information.

- **Unclassified AP**—Displays counts for unclassified rogue access point alarms. See the “Configuring Alarm Severity” section on page 6-84 for more information.

- **WCS**—Displays counts for WCS alarms such as e-mail failures and license violation alarms.

### Customizing Alarm Summary Results

If you click **Edit View** from the Alarm Summary page (shown in Figure 6-7), you can customize which results you want to appear in the Alarm Summary page.

Column names appear in one of the following lists:

- **Hide Information**—Lists columns that do not appear in the table. The Hide button points to this list.

- **View Information**—Lists columns that do appear in the table. The Show button points to this list.
To display a column in a table, click it in the Hide Information list, then click Show. To remove a column from a table, click it in the View Information list, then click Hide. You can select more than one column by holding down the Shift or Control key.

To change the position of a column in the View Information list, click it, then click Up or Down. The higher a column is in the list, the farther left it appears in the table.

The Alarm Summary items to choose from are as follows:
- Owner
- Date/Time
- Message
- Acknowledged
- Category
- Condition

**Configuring Alarm Severity**

The Settings > Severity Configuration page allows you to change the severity level for newly generated alarms.

**Note**

Existing alarms remain unchanged.

To reconfigure the severity level for a newly generated alarm, follow these steps:

**Step 1** Choose Administration > Settings.

**Step 2** From the left sidebar menu, select Severity Configuration.

**Step 3** Select the check box of the alarm condition whose severity level you want to change.

**Step 4** From the Configure Security Level drop-down list, select from the following severity levels:
- Critical
- Major
- Minor
- Warning
- Informational
- Reset to Default

**Step 5** Click Go.

**Step 6** Click OK to confirm the change or Cancel to leave the security level unchanged.
Chapter 6  Monitoring Wireless Devices

Monitoring Alarms

You can view alarm details from the Monitor > Alarms page by doing either of the following:

- Clicking the arrow to the left of the Name column for the alarm for which you want to see details. See “Viewing Alarm Details” section on page 6-87.
- Hovering your mouse cursor over an alarm severity in the Severity column and clicking the arrow that appears. See “Using the Alarm Summary” section on page 6-80.

Select a command

Using the Select a command drop-down list, you can perform the following actions on the selected alarms:

- Assign to me—Assign the selected alarm(s) to the current user.
- Unassign—Unassign the selected alarm(s).
- Delete—Delete the selected alarm(s).
- Clear—Clear the selected alarm(s). Indicates that the alarm is no longer detected by any access point.

Note Once the severity is Clear, the alarm is deleted from WCS after 30 days.

- Acknowledge—You can acknowledge the alarm to prevent it from showing up in the Alarm Summary page. The alarm remains in WCS and you can search for all Acknowledged alarms using the alarm search functionality. See “Acknowledging Alarms” section on page 6-121 for more information.
- Unacknowledge—You can choose to unacknowledge an already acknowledged alarm.
- Email Notification—Takes you to the All Alarms > Email Notification page to view and configure email notifications. See “Monitoring Email Notifications” section on page 6-116 for more information.

To perform an action on the selected alarm, follow these steps:

1. Select an alarm by selecting the check box.
2. From the Select a command drop-down list, choose a command.
3. Click Go.

For more information on MSE Alarms, see “Viewing the MSE Alarm Details” section on page 12-69.

Configuring the Search Results Display

The Edit View page allows you to add, remove, or reorder columns in the alarms table (see Figure 6-9).
The following alarm parameters are available in the Edit View page:

- **Owner**—Displays the name of the person to whom this alarm is assigned, if one was entered.
- **Date/Time**—Displays the date and time that the alarm occurred.
- **Message**—Indicates the reason for the alarm.
- **Acknowledged**—Displays whether or not the alarm is acknowledged by the user.

You can acknowledge the alarm to prevent it from showing up in the Alarm Summary page. The alarm remains in WCS and you can search for all Acknowledged alarms using the alarm search functionality. See “Acknowledging Alarms” section on page 6-121 for more information.

- **Category**—Displays the alarm assigned category such as rogue AP, controller, switch, and security.
- **Condition**—Displays the current condition that caused the alarm.

To edit the available columns in the alarms table, follow these steps:

**Step 1** Choose **Monitor > Alarms**.

**Step 2** Click the **Edit View** link.

**Step 3** To add an additional column to the alarms table, click to highlight the column heading in the left column. Click **Show** to move the heading to the right column. All items in the right column are displayed in the alarms table.

**Step 4** To remove a column from the alarms table, click to highlight the column heading in the right column. Click **Hide** to move the heading to the left column. All items in the left column are not displayed in the alarms table.

**Step 5** Use the Up/Down buttons to specify the order in which the information appears in the table. Highlight the desired column heading and click **Up** or **Down** to move it higher or lower in the current list.

**Step 6** Click **Reset** to restore the default view.

**Step 7** Click **Submit** to confirm the changes.
Viewing Alarm Details

In the Monitor > Alarms page, click an item under Failure Source to access the alarms details page (see Figure 6-10).

Figure 6-10 Alarm Details Page

This page provides the following information (Table 6-9):

Table 6-9 General Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Failure Source</td>
<td>Device that generated the alarm.</td>
</tr>
<tr>
<td>Owner</td>
<td>Name of person to which this alarm is assigned, or blank.</td>
</tr>
<tr>
<td>Acknowledged</td>
<td>Displays whether or not the alarm is acknowledged by the user.</td>
</tr>
<tr>
<td>Category</td>
<td>The category of the alarm (for example, AP, Rogue AP, or Security).</td>
</tr>
<tr>
<td>Created</td>
<td>Month, day, year, hour, minute, second, AM or PM alarm created.</td>
</tr>
<tr>
<td>Modified</td>
<td>Month, day, year, hour, minute, second, AM or PM alarm last modified.</td>
</tr>
<tr>
<td>Generated By</td>
<td>Device that generated the alarm.</td>
</tr>
<tr>
<td>Severity</td>
<td>Level of security: Critical, Major, Minor, Warning, Clear, Info, Color coded.</td>
</tr>
<tr>
<td>Previous Severity</td>
<td>Critical, Major, Minor, Warning, Clear, Info, Color coded.</td>
</tr>
</tbody>
</table>

The General information may vary depending on the type of alarm. For example, some alarm details may include location and switch port tracing information.
Monitoring Rogue Access Points

This section describes security solutions for rogue devices. A rogue device is an unknown access point or client that is detected by managed access points in your network.
Challenges

Rogue access points can disrupt wireless LAN operations by hijacking legitimate clients and using plain-text or other denial of service or man-in-the-middle attacks. That is, a hacker can use a rogue access point to capture sensitive information, such as usernames and passwords. The hacker can then transmit a series of clear-to-send (CTS) frames. This action mimics an access point informing a particular client to transmit and instructing all others to wait, which results in legitimate clients being unable to access network resources. Therefore, wireless LAN service providers have a strong interest in banning rogue access points from the air space.

Because rogue access points are inexpensive and readily available, employees sometimes plug unauthorized rogue access points into existing LANs and build ad-hoc wireless networks without IT department knowledge or consent. These rogue access points can be a serious breach of network security as they can be plugged into a network port behind the corporate firewall. Because employees generally do not enable any security settings on the rogue access point, it is easy for unauthorized users to use the access point to intercept network traffic and hijack client sessions. Even more alarming, wireless users frequently publish insecure access point locations, increasing the odds of having enterprise security breached.

Detecting Rogue Devices

The controllers continuously monitor all nearby access points and automatically discover and collect information on rogue access points and clients. When a controller discovers a rogue access point, it uses the Rogue Location Discovery Protocol (RLDP) to determine if the rogue is attached to your network.

Note

WCS consolidates all of the controllers' rogue access point data.

You can configure controllers to use RLDP on all access points or only on access points configured for monitor (listen-only) mode. The latter option facilitates automated rogue access point detection in a crowded RF space, allowing monitoring without creating unnecessary interference and without affecting regular data access point functionality. If you configure a controller to use RLDP on all access points, the controller always chooses the monitor access point for RLDP operation if a monitor access point and a local (data) access point are both nearby. If RLDP determines that the rogue is on your network, you can choose to either manually or automatically contain the detected rogue. See “Configuring Rogue Policies” section on page 9-103 for information on enabling RLDP.

Note

Rogue access point partitions are associated with one of the detecting access points (the one with the latest or strongest RSSI value). If there is detecting access point information, WCS uses the detecting controller. If the rogue access point is detected by two controllers which are in different partitions, the rogue access point partition may be changed at any time.

Monitoring Rogue AP Alarms

Rogue access point radios are unauthorized access points detected by one or more access points.
To open the Rogue AP Alarms page, do one of the following:

- Search for rogue APs. See “Using the Search Feature” section on page 2-34 for more information about the search feature.
- From the WCS home page, click the Security tab. This page displays all the rogue access points detected in the past hour and the past 24 hours. Click the rogue access point number to view the rogue access point alarms.
- Click the Malicious AP number link in the Alarm Summary box. See “Using the Alarm Summary” section on page 6-80 for more information.

If there are multiple alarm pages, the page numbers are displayed at the top of the page with a scroll arrow on each side. Use it to view additional alarms.

Rogue access point partitions are associated with one of the detecting access points (the one with the latest or strongest RSSI value). If there is detecting access point information, WCS uses the detecting controller.

If the rogue access point is detected by two controllers which are in different partitions, the rogue access point partition may be changed at any time.

The Rogue AP Alarms page contains the following parameters:

- Severity—Indicates the severity of the alarm including the following:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Critical</td>
</tr>
<tr>
<td></td>
<td>Major</td>
</tr>
<tr>
<td></td>
<td>Minor</td>
</tr>
<tr>
<td></td>
<td>Warning</td>
</tr>
</tbody>
</table>

When WCS polls, some data may change or get updated. Because of this, some of the displayed rogue data (including Strongest AP RSSI, No. of Rogue Clients, Channel, SSID, and Radio Types) can change during the life of the rogue.
Chapter 6  Monitoring Wireless Devices

Monitoring Rogue Access Points

You can use the Severity Configuration feature to determine the level of severity for the following rogue access point alarm types:

- Rogue detected
- Rogue detected contained
- Rogue detected on network

See “Severity Configurations” section on page 16-80 for more information.

- Rogue MAC Address—Indicates the MAC address of the rogue access points. See “Viewing Rogue AP Alarm Details” section on page 6-96.
- Vendor—Rogue access point vendor name or Unknown.
- Classification Type—Pending, Malicious, Friendly, or Unclassified.
- Radio Type—Lists all radio types applicable to this rogue access point.
- Strongest AP RSSI—Displays the strongest AP RSSI for this rogue access point across the life of the rogue. The strongest AP RSSI over the life of the rogue displays to indicate the nearest distance that existed between the rogue access point and your building or location. The higher the RSSI, the closer the location.
- No. of Rogue Clients—Indicates the number of rogue clients associated to this rogue access point.

Note
This number comes from the WCS database and is updated every two hours. In the Monitor > Alarms > Alarm Details page, this number is a real-time number. It is updated each time you open the Alarm Details page for this rogue access point.

- Owner—Name of person to which this alarm is assigned, or (blank).
- Last Seen Time—Indicates the date and time that the rogue access point was last seen.
- State—Indicates the state of the alarm. Possible states vary depending on the classification type of rogue access point. See “Rogue Access Point Classification Types” section on page 6-95 for additional information.
  - Malicious rogue states include: Alert, Contained, Threat, Contained Pending, and Removed. See “Malicious Rogue APs” section on page 6-95 for more information.
  - Friendly rogue states include: Internal, External, and Alert. See “Friendly Rogue APs” section on page 6-95 for more information.
  - Unclassified rogue states include: Pending, Alert, Contained, and Contained Pending. See “Unclassified Rogue APs” section on page 6-96 for more information.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>🔄</td>
<td>Info</td>
</tr>
<tr>
<td>🔄</td>
<td>Clear—Displays if the rogue is no longer detected by any access point.</td>
</tr>
<tr>
<td>Note</td>
<td>Rogues can be detected by multiple access points. If one access point no longer detects the rogue but the other access point does, Clear is not sent.</td>
</tr>
<tr>
<td>Note</td>
<td>Once the severity of a rogue is Clear, the alarm is deleted from WCS after 30 days.</td>
</tr>
</tbody>
</table>
- SSID—Indicates the service set identifier being broadcast by the rogue access point radio. It is blank if the SSID is not being broadcast.
- Map Location—Indicates the map location for this rogue access point.
- Acknowledged—Displays whether or not the alarm is acknowledged by the user.

You can acknowledge the alarm to prevent it from showing up in the Alarm Summary page. The alarm remains in WCS and you can search for allAcknowledged alarms using the alarm search functionality. See “Acknowledging Alarms” section on page 6-121 for more information.

### Select a command

Select one or more alarms by selecting their respective check boxes, select one of the following commands from the Select a command drop-down list, and click **Go**.

- **Assign to me**—Assign the selected alarm(s) to the current user.
- **Unassign**—Unassign the selected alarm(s).
- **Delete**—Delete the selected alarm(s).
- **Clear**—Clear the selected alarm(s). Indicates that the alarm is no longer detected by any access point.

**Note**  
Once the severity is Clear, the alarm is deleted from WCS after 30 days.

- **Acknowledge Alarm**—Acknowledge the alarm to prevent it from showing up in the Alarm Summary page. See “Acknowledging Alarms” section on page 6-121 for more information.

**Note**  
The alarm remains in WCS and you can search for all Acknowledged alarms using the alarm search functionality.

- **Unacknowledge Alarm**—Unacknowledge an already acknowledged alarm.
- **Email Notification**—Takes you to the All Alarms > Email Notification page to view and configure email notifications. See “Monitoring Email Notifications” section on page 6-116 for more information.
- **Severity Configuration**—Allows you to change the severity level for newly-generated alarms. See “Severity Configurations” section on page 16-80 for more information.
- **Detecting APs**—View the access points that are currently detecting the rogue access point. See “Detecting Access Points” section on page 6-110 for more information.
- **Map (High Resolution)**—Click to display a high-resolution map of the rogue access point location.
- **Rogue Clients**—Click to view a list of rogue clients associated with this rogue access point. The Rogue Clients page displays the Client MAC Address, when it was last heard, its current status, its controller, and the Rogue access point. See “Viewing Rogue Client Details” section on page 6-101 for more information. This information can also be accessed by using the WCS Search feature. See “Using the Search Feature” section on page 2-34 or “Advanced Search” section on page 2-35 for more information.
- **Set State to ‘Unclassified - Alert’**—Choose this command to tag the rogue access point as the lowest threat, continue monitoring the rogue access point, and to turn off Containment. See “Unclassified Rogue APs” section on page 6-96 for more information on Unclassified rogues.
• Set State to ‘Malicious - Alert’—Choose this command to tag the rogue access point as ‘Malicious’. See “Malicious Rogue APs” section on page 6-95 for more information on Malicious rogues.

• Set State to ‘Friendly - Internal’—Choose this command to tag the rogue access point as internal, add it to the Known Rogue APs list, and to turn off Containment. See “Friendly Rogue APs” section on page 6-95 for more information on Friendly rogues.

• Set State to ‘Friendly - External’—Choose this command to tag the rogue access point as external, add it to the Known Rogue APs list, and to turn off Containment. See “Friendly Rogue APs” section on page 6-95 for more information on Friendly rogues.

• 1 AP Containment—Target the rogue access point for containment by one access point. (Lowest containment level.)

• 2 AP Containment—Target the rogue access point for containment by two access points.

• 3 AP Containment—Target the rogue access point for containment by three access points.

• 4 AP Containment—Target the rogue access point for containment by four access points. (Highest containment level.)

Note The higher the threat of the rogue access point, the higher the containment required.

Caution Attempting to contain a rogue access point may lead to legal consequences. When you select any of the AP Containment commands and click Go, a message “Containing a Rogue AP may have legal consequences. Do you want to continue?” appears. Click OK if you are sure, or click Cancel if you do not wish to contain any access points.

Classifying Rogue Access Points

Classification and reporting of rogue access points occurs through the use of rogue states and user-defined classification rules that enable rogues to automatically move between states. You can create rules that enable the controller to organize and display rogue access points as Friendly, Malicious, or Unclassified.

Note WCS consolidates all of the controllers rogue access point data.

By default, none of the classification rules are enabled. Therefore, all unknown access points are categorized as Unclassified. When you create a rule, configure conditions for it, and enable the rule, the unclassified access points are reclassified. Whenever you change a rule, it is applied to all access points (friendly, malicious, and unclassified) in the Alert state only.

Note Rule-based rogue classification does not apply to ad-hoc rogues and rogue clients.
Note

The 5500 series controllers support up to 2000 rogues (including acknowledged rogues); the 4400 series controllers, Cisco WiSM, and Catalyst 3750G Integrated Wireless LAN Controller Switch support up to 625 rogues; and the 2100 series controllers and Controller Network Module for Integrated Services Routers support up to 125 rogues. Each controller limits the number of rogue containments to three per radio (or six per radio for access points in monitor mode).

When the controller receives a rogue report from one of its managed access points, it responds as follows:

1. The controller verifies that the unknown access point is in the friendly MAC address list. If it is, the controller classifies the access point as Friendly.
2. If the unknown access point is not in the friendly MAC address list, the controller starts applying rogue classification rules.
3. If the rogue is already classified as Malicious, Alert or Friendly, Internal or External, the controller does not reclassify it automatically. If the rogue is classified differently, the controller reclassifies it automatically only if the rogue is in the Alert state.
4. The controller applies the first rule based on priority. If the rogue access point matches the criteria specified by the rule, the controller classifies the rogue according to the classification type configured for the rule.
5. If the rogue access point does not match any of the configured rules, the controller classifies the rogue as Unclassified.
6. The controller repeats the previous steps for all rogue access points.
7. If RLDP determines that the rogue access point is on the network, the controller marks the rogue state as Threat and classifies it as Malicious automatically, even if no rules are configured. You can then manually contain the rogue (unless you have configured RLDP to automatically contain the rogue), which would change the rogue state to Contained. If the rogue access point is not on the network, the controller marks the rogue state as Alert, and you can manually contain the rogue.
8. If desired, you can manually move the access point to a different classification type and rogue state.

As mentioned previously, the controller can automatically change the classification type and rogue state of an unknown access point based on user-defined rules, or you can manually move the unknown access point to a different classification type and rogue state. Table 6-10 shows the allowable classification types and rogue states from and to which an unknown access point can be configured.

Table 6-10  Allowable Classification Type and Rogue State Transitions

<table>
<thead>
<tr>
<th>From</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Friendly (Internal, External, Alert)</td>
<td>Malicious (Alert)</td>
</tr>
<tr>
<td>Friendly (Internal, External, Alert)</td>
<td>Unclassified (Alert)</td>
</tr>
<tr>
<td>Friendly (Alert)</td>
<td>Friendly (Internal, External)</td>
</tr>
<tr>
<td>Malicious (Alert, Threat)</td>
<td>Friendly (Internal, External)</td>
</tr>
<tr>
<td>Malicious (Contained, Contained Pending)</td>
<td>Malicious (Alert)</td>
</tr>
<tr>
<td>Unclassified (Alert, Threat)</td>
<td>Friendly (Internal, External)</td>
</tr>
<tr>
<td>Unclassified (Contained, Contained Pending)</td>
<td>Unclassified (Alert)</td>
</tr>
<tr>
<td>Unclassified (Alert)</td>
<td>Malicious (Alert)</td>
</tr>
</tbody>
</table>
If the rogue state is Contained, you have to uncontain the rogue access point before you can change the classification type. If you want to move a rogue access point from Malicious to Unclassified, you must delete the access point and allow the controller to reclassify it.

**Rogue Access Point Classification Types**

Rogue access points classification types include:

- **Malicious**—Detected but untrusted or unknown access points with a malicious intent within the system. They also refer to access points that fit the user-defined malicious rules or have been manually moved from the friendly access point classification. See the “Malicious Rogue APs” section on page 6-95 for more information.

- **Friendly**—Known, acknowledged, or trusted access points. They also refer to access points that fit the user-defined friendly rogue access point rules. Friendly rogue access points cannot be contained. See the “Friendly Rogue APs” section on page 6-95 for more information. For more information on configuring friendly access point rules, see the “Configuring a Friendly Access Point Template” section on page 11-94.

- **Unclassified**—Rogue access point that are not classified as either malicious or friendly. These access points can be contained and can be moved manually to the friendly rogue access point list. See for more information. See the “Unclassified Rogue APs” section on page 6-96 for more information.

**Malicious Rogue APs**

Malicious rogue access points are detected but untrusted or unknown access points with a malicious intent within the system. They also refer to access points that fit the user-defined malicious rules or have been manually moved from the friendly access point classification.

The Security tab of the WCS home page displays the number of malicious rogue access points for each applicable state for the past hour, the past 24 hours, and the total number of active malicious rogue access points.

Malicious rogue access point states include:

- **Alert**—Indicates that the access point is not on the neighbor list or part of the user-configured Friendly AP list.

- **Contained**—The unknown access point is contained.

- **Threat**—The unknown access point is found to be on the network and poses a threat to WLAN security.

- **Contained Pending**—Indicates that the containment action is delayed due to unavailable resources.

- **Removed**—This unknown access point was seen earlier but is not seen now.

Click an underlined number in any of the time period categories for detailed information regarding the malicious rogue access points. See the “Viewing Alarm Details” section on page 6-87 for more information.

**Friendly Rogue APs**

Friendly rogue access points are known, acknowledged or trusted access points. They also refer to access points that fit the user-defined friendly rogue access point rules. Friendly rogue access points cannot be contained.
Monitoring Rogue Access Points

Only WCS users can add a rogue access point MAC address to the Friendly AP list. The WCS does not apply the Friendly AP MAC address to controllers.

The Security tab of the WCS home page displays the number of friendly rogue access points for each applicable state for the past hour, the past 24 hours, and the total number of active friendly rogue access points.

Friendly rogue access point states include:

- **Internal**—If the unknown access point is inside the network and poses no threat to WLAN security, you would manually configure it as Friendly, Internal. For example, the access points in your lab network.
- **External**—If the unknown access point is outside the network and poses no threat to WLAN security, you would manually configure it as Friendly, External. For example, the access points belonging to a neighboring coffee shop.
- **Alert**—The unknown access point is not on the neighbor list or part of the user-configured Friendly AP list.

Click an underlined number in any of the time period categories for detailed information regarding the friendly rogue access points. See the “Viewing Alarm Details” section on page 6-87 for more information.

To delete a rogue access point from the Friendly AP list, ensure that both the WCS and controller remove the rogue access point from the Friendly AP list. Change the rogue access point from Friendly AP Internal or External to Unclassified or Malicious Alert.

**Unclassified Rogue APs**

An unclassified rogue access point refers to a rogue access point that is not classified as either malicious or friendly. These access points can be contained and can be moved manually to the friendly rogue access point list.

The Security tab of the WCS home page displays the number of unclassified rogue access points for each applicable state for the past hour, the past 24 hours, and the total number of active unclassified rogue access points.

Unclassified rogue access point states include the following:

- **Pending**—On first detection, the unknown access point is put in the Pending state for 3 minutes. During this time, the managed access points determine if the unknown access point is a neighbor access point.
- **Alert**—The unknown access point is not on the neighbor list or part of the user-configured Friendly AP list.
- **Contained**—The unknown access point is contained.
- **Contained Pending**—The unknown access point is marked Contained, but the action is delayed due to unavailable resources.

Click an underlined number in any of the time period categories for further information. See the “Viewing Alarm Details” section on page 6-87.

**Viewing Rogue AP Alarm Details**

Rogue access point radios are unauthorized access points detected by access points. Alarm event details for each rogue access point are available from the Rogue AP Alarms list page.
To view alarm events for a rogue access point radio, click the rogue MAC address for the applicable alarm from the Monitor > Alarms list page for rogue access point alarms.

**Note** All Alarm Details page fields (except No. of Rogue Clients) are populated through polling and are updated every two hours. The number of rogue clients is a real-time number and is updated each time you access the Alarm Details page for a rogue access point alarm.

**Note** When the WCS polls, some data may change or get updated. Therefore, some of the displayed rogue data (including Strongest AP RSSI, No. of Rogue Clients, Channel, SSID, and Radio Types) can change during the life of the rogue.

The Alarm Details page displays the following information:

- **General**
  - Rogue MAC Address—MAC address of the rogue access points.
  - Vendor—Rogue access point vendor name or Unknown.
    **Note** When a rogue access point alarm displays for Airlink, the vendor displays as Alpha instead of Airlink.
  - Rogue Type—Indicates the rogue type such as AP.
  - On Network—Indicates how the rogue detection occurred. Controller—The controller detected the rogue (Yes or No). Switch Port Trace—The rogue was detected by a switch port trace. Indicated by one of the following: Traced but not found, Traced and found, Not traced.
  - Owner—Indicates the owner or is left blank.
  - Acknowledged—Indicates whether or not the alarm is acknowledged by the user. You can acknowledge the alarm to prevent it from showing up in the Alarm Summary page. The alarm remains in WCS and you can search for all Acknowledged alarms using the alarm search functionality. See the “Acknowledging Alarms” section on page 6-121 for more information.
  - Classification Type—Malicious, Friendly, or Unclassified. See the “Rogue Access Point Classification Types” section on page 6-95 for more information.
  - State—Indicates the state of the alarm. Possible states vary depending on the classification type of rogue access point. See the “Rogue Access Point Classification Types” section on page 6-95 for additional information.
  - SSID—Service Set Identifier being broadcast by the rogue access point radio. (Blank if SSID is not broadcast.)
  - Channel Number—Indicates the channel of the rogue access point.
  - Containment Level—Indicates the containment level of the rogue access point or Unassigned (not contained).
  - Radio Type—Lists all radio types applicable to this rogue access point.
- Strongest AP RSSI—Displays the strongest AP RSSI for this rogue access point across the life of the rogue. The strongest AP RSSI over the life of the rogue displays to indicate the nearest distance that existed between the rogue access point and your building or location. The higher the RSSI, the closer the location.

- No. of Rogue Clients—Indicates the number of rogue clients associated to this rogue access point.

**Note**
The number of rogue clients is the only real-time field in the Monitor > Alarm > Alarm Details page. It updates each time you open the Alarm Details page for this rogue access point. All other fields on the Alarm Details page are populated through polling and are updated every two hours.

- First Seen Time—Indicates the date and time when the rogue access point was first detected. This information is populated from the controller.

- Last Seen Time—Indicates the date and time when the rogue access point was last detected. This information is populated from the controller.

- Modified—Indicates when the alarm event was modified.

- Generated By—Indicates how the alarm event was generated (either NMS or from a trap).
  - NMS (Network Management System - WCS)—Generated through polling. WCS periodically polls the controllers and generates events. WCS generates events when the traps are disabled or when the traps are lost for those events. In this case “Generated by” will be NMS.
  - Trap—Generated by the controller. WCS process these traps and raises corresponding events for them. In this case "Generated by" will be Controller.

- Severity—The severity of the alarm including:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Critical" /></td>
<td>Critical</td>
</tr>
<tr>
<td><img src="image" alt="Major" /></td>
<td>Major</td>
</tr>
<tr>
<td><img src="image" alt="Minor" /></td>
<td>Minor</td>
</tr>
<tr>
<td><img src="image" alt="Warning" /></td>
<td>Warning</td>
</tr>
<tr>
<td><img src="image" alt="Info" /></td>
<td>Info</td>
</tr>
<tr>
<td><img src="image" alt="Clear" /></td>
<td>Clear—Displays if the rogue is no longer detected by any access point.</td>
</tr>
</tbody>
</table>

**Note**
Rogues can be detected by multiple access points. If one access point no longer detects the rogue but the other access point does, Clear is not sent.

**Note**
Once the severity of a rogue is Clear, the alarm is deleted from WCS after 30 days.
You can use the Severity Configuration feature to determine the level of severity for rogue access points. See the “Severity Configurations” section on page 16-80 for more information.

- Previous Severity—The previous severity of the alarm: Critical, Major, Minor, Clear.
- Event Details—Click the Event History link to view the event details.
- Rogue AP History—Click the Rogue AP History link to view the Rogue Alarm details.
- Switch Port Trace Status—Indicates the switch port trace status. Switch port trace status may include: Traced, but not found, Traced and found, Not traced, Failed. See the “Switch Port Tracing” section on page 16-88 for more information.
- Switch Port Tracing Details—Provides the most recent switch port tracing details. To view additional trace details, use the Click here for more details link. See the “Switch Port Tracing” section on page 16-88 for more information.
- Rogue Clients—Lists rogue clients for this access point including the client MAC address, the last date and time the client was heard, and the current client status. See the “Viewing Rogue Client Details” section on page 6-101 for more information.

Note

The number of rogue clients is the only real-time field in the Monitor > Alarm > Alarm Details page. It updates each time you open the Alarm Details page for this rogue access point. All other fields on the Alarm Details page are populated through polling and are updated every two hours.

- Message—Displays the most recent message regarding this rogue access point. A message is sent for the following: When the rogue access point is first detected, for any trap sent, and for any changed state.
- Annotations—Lists current notes regarding this rogue access point. To add a new note, click New Annotation. Type the note and click Post to save and display the note or Cancel to close the page without saving the note.
- Location Notifications—Displays the number of location notifications logged against the client. Clicking a link displays the notifications.
- Location—Provides location information, if available.

Select a command

The Select a command drop-down list located on the Rogue AP Alarm Details page provides the following options. Select an option from the drop-down list, and click Go.

- Assign to me—Assign the selected alarm(s) to the current user.
- Unassign—Unassign the selected alarm(s).
- Delete—Delete the selected alarm(s).
- Clear—Clear the selected alarm(s).
- Acknowledge Alarm—Acknowledge the alarm to prevent it from showing up in the Alarm Summary page. See the “Acknowledging Alarms” section on page 6-121 for more information.

Note

The alarm remains in WCS and you can search for all Acknowledged alarms using the alarm search functionality.
Monitoring Rogue Access Points

- **Unacknowledge**—Unacknowledge an already acknowledged alarm.
- **Trace Switch Port**—Click to run a switch port trace for this rogue access point. See the “Switch Port Tracing” section on page 16-88 for more information.
- **Event History**—Click to view a list of events for this rogue access point. See the “Monitoring Rogue Alarm Events” section on page 6-111 for more information.
- **Refresh from Network**—Click to sync up the rogue APs from the network.
- **View Detecting AP on Network**—View the access points that are currently detecting the rogue access point. See the “Detecting Access Points” section on page 6-110 for more information.

**Note**
Detecting AP Name, Radio, SSID information might be empty as the information is not available on controller. Refresh the page after the rogue AP task is completed to see the AP details.

- **View Details by Controller**—View the classification type and state of the rogue APs reported by the controller.

**Note**
For more information about rogue AP Background Task Performance Tuning, see the “Rogue AP Background Task Performance Tuning” section on page A-9.

- **Map (High Resolution)**—Click to display a high-resolution map of the rogue access point location.
- **Rogue Clients**—Click to view a list of rogue clients associated with this rogue access point. The Rogue Clients page displays the Client MAC Address, when it was last heard, its current status, its controller, and the Rogue access point. See the “Viewing Rogue Client Details” section on page 6-101 for more information. This information can also be accessed by using the WCS Search feature. See the “Using the Search Feature” section on page 2-34 or “Advanced Search” section on page 2-35 for more information.
- **Set State to ‘Unclassified - Alert’**—Choose this command to tag the rogue access point as the lowest threat, continue monitoring the rogue access point, and to turn off Containment. See the “Unclassified Rogue APs” section on page 6-96 for more information on Unclassified rogues.
- **Set State to ‘Malicious - Alert’**—Choose this command to tag the rogue access point as ‘Malicious’. See the “Malicious Rogue APs” section on page 6-95 for more information on Malicious rogues.
- **Set State to ‘Friendly - Internal’**—Choose this command to tag the rogue access point as internal, add it to the Known Rogue APs list, and to turn off Containment. See the “Friendly Rogue APs” section on page 6-95 for more information on Friendly rogues.
- **Set State to ‘Friendly - External’**—Choose this command to tag the rogue access point as external, add it to the Known Rogue APs list, and to turn off Containment. See the “Friendly Rogue APs” section on page 6-95 for more information on Friendly rogues.
- **1 AP Containment**—Target the rogue access point for containment by one access point. (Lowest containment level.)
- **2 AP Containment**—Target the rogue access point for containment by two access points.
- **3 AP Containment**—Target the rogue access point for containment by three access points.
- **4 AP Containment**—Target the rogue access point for containment by four access points. (Highest containment level.)
Viewing Rogue Client Details

You can view a list of rogue clients in several ways:

- Perform a search for rogue clients using the WCS Search feature. See the “Advanced Search” section on page 2-35 for more information.
- View the list of rogue clients for a specific rogue access point from the Alarm Details page for the applicable rogue access point.
- From the Alarms Details page of a rogue access point, choose Rogue Clients from the Select a command drop-down list.

The Rogue Clients page displays the Client MAC Address, when it was last heard, its current status, its controller, and the associated rogue access point.

Click the Client MAC Address for the rogue client to view the Rogue Client details page. The Rogue Client details page displays the following information:

- General—Information includes: client MAC address, number of access points that detected this client, when the client was first and last heard, the rogue access point MAC address, and the client current status.
- Location Notifications—Indicates the number of notifications for this rogue client including: absence, containment, distance, and all. Click the notification number to open the applicable Monitor > Alarms page.
- APs that detected the rogue client—Provides the following information for all access points that detected this rogue client: base radio MAC address, access point name, channel number, radio type, RSSI, SNR, and the date/time that the rogue client was last heard.
- Location—Provides location information, if available.

Select a command

The Select a command drop-down list on the Rogue Client details page includes the following options:

- Set State to ‘Unknown - Alert’—Choose this command to tag the rogue client as the lowest threat, continue monitoring the rogue client, and to turn off Containment.
- 1 AP Containment—Target the rogue client for containment by one access point. (Lowest containment level.)
- 2 AP Containment—Target the rogue client for containment by two access points.
- 3 AP Containment—Target the rogue client for containment by three access points.
- 4 AP Containment—Target the rogue client for containment by four access points. (Highest containment level.)
- Map (High Resolution)—Click to display a high-resolution map of the rogue client location.
- Location History—Click to display the history of the rogue client location based on RF fingerprinting.
Viewing Rogue AP History Details

To view the history of a rogue AP alarms, click the Rogue AP History link in the Rogue AP Alarm page. The Rogue AP History page displays the following information:

- **Severity**—The severity of the alarm.
- **Rogue MAC Address**—MAC address of the rogue access points.
- **Classification Type**—Malicious, Friendly, or Unclassified. See the “Rogue Access Point Classification Types” section on page 6-95 for more information.
- **Radio Type**—Lists all radio types applicable to this rogue access point.
- **Strongest AP RSSI**—Displays the strongest AP RSSI for this rogue access point across the life of the rogue. The strongest AP RSSI over the life of the rogue displays to indicate the nearest distance that existed between the rogue access point and your building or location. The higher the RSSI, the closer the location.
- **No. of Rogue Clients**—Indicates the number of rogue clients associated to this rogue access point.

**Note** The number of rogue clients is the only real-time field in the Monitor > Alarm > Alarm Details page. It updates each time you open the Alarm Details page for this rogue access point.

- All other fields on the Alarm Details page are populated through polling and are updated every two hours.
- **First Seen Time**—Indicates the date and time when the rogue access point was first detected. This information is populated from the controller.
- **Last Seen Time**—Indicates the date and time when the rogue access point was last detected. This information is populated from the controller.
- **State**—Indicates the state of the alarm. Possible states vary depending on the classification type of rogue access point. See the “Rogue Access Point Classification Types” section on page 6-95 for additional information.
- **SSID**—Service Set Identifier being broadcast by the rogue access point radio. (Blank if SSID is not broadcast.)
- **Category**—Indicates the category of this alarm such as Security or WCS.
- **On Network**—Indicates how the rogue detection occurred.
  - **Controller**—The controller detected the rogue (Yes or No).
  - **Switch Port Trace**—The rogue was detected by a switch port trace. Indicated by one of the following: Traced but not found, Traced and found, Not traced.
- **Channel Number**—Indicates the channel of the adhoc rogue.
- **Containment Level**—Indicates the containment level of the adhoc rogue or Unassigned.
- **Switch Port Trace Status**—Indicates the switch port trace status. Switch port trace status may include: Traced, but not found, Traced and found, Not traced, Failed.

Viewing Rogue AP Event History Details

To view the event details of a rogue AP, click the Event History link in the Rogue AP Alarm page.
Monitoring Adhoc Rogues

If the MAC address of a mobile client operating in an adhoc network is not in the authorized MAC address list, then it is identified as an adhoc rogue. This section contains the following topics:

- Monitoring Adhoc Rogue Alarms, page 6-103
- Viewing Adhoc Rogue Alarm Details, page 6-108

Monitoring Adhoc Rogue Alarms

The Adhoc Rogue Alarms page displays alarm events for adhoc rogues.

To access the Adhoc Rogue Alarms page, do one of the following:

- Perform a search for adhoc rogue alarms. See the “Using the Search Feature” section on page 2-34 for more information.
- From the WCS home page, click the Security tab. This page displays all the adhoc rogues detected in the past hour and the past 24 hours. Click the adhoc rogue number to view the adhoc rogue alarms.

If there are multiple alarm pages, the page numbers are displayed at the top of the page with a scroll arrow on each side. Use this to view additional alarms.

The Adhoc Rogue Alarms page contains the following parameters:

Note: When WCS polls, some data may change or get updated. Because of this, some of the displayed rogue data (including Strongest AP RSSI, No. of Rogue Clients, Channel, SSID, and Radio Types) can change during the life of the rogue.

- Severity—Indicates the severity of the alarm including:
Chapter 6  Monitoring Wireless Devices

Monitoring Adhoc Rogues

You can use the Severity Configuration feature to determine the level of severity for the following adhoc rogue alarm types:

- Adhoc Rogue auto contained
- Adhoc Rogue detected
- Adhoc Rogue detected on network
- Adhoc Rogue detected on network

See the “Severity Configurations” section on page 16-80 for more information.

- Rogue MAC Address—Indicates the MAC address of the rogue. See the “Viewing Adhoc Rogue Alarm Details” section on page 6-108 for more information.
- Vendor—Indicates the adhoc rogue vendor name, or Unknown.
- Radio Type—Lists all radio types applicable to this rogue access point.
- Strongest AP RSSI—Displays the strongest AP RSSI for this rogue across the life of the rogue. The strongest AP RSSI over the life of the rogue displays to indicate the nearest distance that existed between the rogue and your building or location. The higher the RSSI, the closer the location.

No. of Rogue Clients—Indicates the number of rogue clients associated to this rogue access point.

Note: The number of rogue clients is the only real-time field on the Monitor > Alarm > Alarm Details page. It updates each time you open the Alarm Details page for this rogue access point. All other fields on the Alarm Details page are populated through polling and are updated every two hours.

- Owner—Indicates the owner or is left blank.
- Last Seen Time—Indicates the date and time that the alarm was last viewed.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Critical Icon]</td>
<td>Critical</td>
</tr>
<tr>
<td>![Major Icon]</td>
<td>Major</td>
</tr>
<tr>
<td>![Minor Icon]</td>
<td>Minor</td>
</tr>
<tr>
<td>![Warning Icon]</td>
<td>Warning</td>
</tr>
<tr>
<td>![Info Icon]</td>
<td>Info</td>
</tr>
<tr>
<td>![Clear Icon]</td>
<td>Clear—Displays if the rogue is no longer detected by any access point.</td>
</tr>
</tbody>
</table>

Note: Rogues can be detected by multiple access points. If one access point no longer detects the rogue but the other access point does, Clear is not sent.

Note: Once the severity of a rogue is Clear, the alarm is deleted from WCS after 30 days.
- **State**—Indicates the state of the alarm. Possible states for adhoc rogues include Threat, Alert, Internal, External, Contained, Contained Pending, and Removed.
- **SSID**—The Service Set Identifier that is being broadcast by the rogue adhoc radio. It is blank if there is no broadcast.
- **Map Location**—Indicates the map location for this adhoc rogue.
- **Acknowledged**—Displays whether or not the alarm is acknowledged by the user.
  
  You can acknowledge the alarm to prevent it from showing up in the Alarm Summary page. The alarm remains in WCS and you can search for all Acknowledged alarms using the alarm search functionality. See the "Acknowledging Alarms" section on page 6-121 for more information.

**Select a command**

Select one or more alarms by selecting their respective check boxes, select one of the following commands from the Select a command drop-down list, and click **Go**.

- **Assign to me**—Assign the selected alarm(s) to the current user.
- **Unassign**—Unassign the selected alarm(s).
- **Delete**—Delete the selected alarm(s).
- **Clear**—Clear the selected alarm(s).
- **Acknowledge**—Acknowledge the alarm to prevent it from showing up in the Alarm Summary page. See the "Acknowledging Alarms" section on page 6-121 for more information.
  
  **Note**  
  The alarm remains in WCS and you can search for all Acknowledged alarms using the alarm search functionality.

- **Unacknowledge**—Unacknowledge an already acknowledged alarm.
- **Email Notification**—Takes you to the All Alarms > Email Notification page to view and configure email notifications. See the "Monitoring Email Notifications" section on page 6-116 for more information.
- **Detecting APs**—View the access points that are currently detecting the rogue adhoc. See the "Detecting Access Points" section on page 6-110 for more information.
- **Map (High Resolution)**—Click to display a high-resolution map of the adhoc rogue location.
- **Rogue Clients**—Click to view a list of rogue clients associated with this adhoc rogue. The Rogue Clients page displays the Client MAC Address, when it was last heard, its current status, its controller, and the adhoc rogue.
- **Set State to ‘Alert’**—Choose this command to tag the adhoc rogue as the lowest threat, continue monitoring the rogue access point, and to turn off Containment.
- **Set State to ‘Internal’**—Choose this command to tag the adhoc rogue as internal, add it to the Known Rogue APs list, and to turn off Containment.
- **Set State to ‘External’**—Choose this command to tag the adhoc rogue as external, add it to the Known Rogue APs list, and to turn off Containment.
- **1 AP Containment**—Target the adhoc rogue for containment by one access point. (Lowest containment level.)
- **2 AP Containment**—Target the adhoc rogue for containment by two access points.
Monitoring Adhoc Rogues

- 3 AP Containment—Target the adhoc rogue for containment by three access points.
- 4 AP Containment—Target the adhoc rogue for containment by four access points. (Highest containment level.)

Caution

Attempting to contain an adhoc rogue may lead to legal consequences. When you select any of the AP Containment commands and click Go, a message “Containing a Rogue AP may have legal consequences. Do you want to continue?” appears. Click OK if you are sure, or click Cancel if you do not wish to contain any access points.

Using Advanced Search

When the access points on your wireless LAN are powered up and associated with controllers, WCS immediately starts listening for rogue access points. When a controller detects a rogue access point, it immediately notifies WCS, which creates a rogue access point alarm.

To find rogue access point alarms using Advanced Search, follow these steps:

Step 1 Click Advanced Search in the top right-hand corner of the WCS main page.
Step 2 Choose Rogue Client from the Search Category drop-down list.
Step 3 (optional) You can filter the search even further with the other search criteria if desired.
Step 4 Click Search.
Step 5 The list of rogue clients appears (see Figure 6-11).

Figure 6-11 Rogue Clients Page

Step 6 Choose a rogue client by clicking a client MAC address. The Rogue Client detail page appears (see Figure 6-12).
### Rogue Client Detail Page

#### General
- **Client MAC Address**: 00:13:02:85:e4:92
- **Number of Detecting APs**: 16
- **First Heard**: Wed Apr 8 07:13:09 2009
- **Last Heard**: Wed Apr 8 11:00:48 2009
- **Rogue AP MAC Address**:
  - **Status**
    - **Location**: No Location Information
    - **Client is not detected by any MSE**

#### Location Notifications
- Absence
- Containment
- Distance
- All

#### APs that detected the Rogue Client

<table>
<thead>
<tr>
<th>AP Name</th>
<th>Channel Number</th>
<th>Radio Type</th>
<th>RSSI</th>
<th>SNR</th>
<th>Last Heard</th>
</tr>
</thead>
<tbody>
<tr>
<td>eap17 : 01-01-01</td>
<td>36</td>
<td>802.11a</td>
<td>-82</td>
<td>17</td>
<td>Wed Apr 8 10:51:38 2009</td>
</tr>
<tr>
<td>eap17 : 01-01-01</td>
<td>6</td>
<td>802.11b/g</td>
<td>-120</td>
<td>-1</td>
<td>Wed Apr 8 09:59:22 2009</td>
</tr>
<tr>
<td>eap17 : 01-01-01</td>
<td>36</td>
<td>802.11a</td>
<td>-120</td>
<td>-1</td>
<td>Wed Apr 8 08:58:17 2009</td>
</tr>
<tr>
<td>eap17 : 01-01-01</td>
<td>36</td>
<td>802.11a</td>
<td>-63</td>
<td>30</td>
<td>Wed Apr 8 10:57:45 2009</td>
</tr>
<tr>
<td>eap17 : 01-01-01</td>
<td>36</td>
<td>802.11a</td>
<td>-120</td>
<td>-1</td>
<td>Wed Apr 8 08:58:16 2009</td>
</tr>
<tr>
<td>eap17 : 01-01-01</td>
<td>36</td>
<td>802.11a</td>
<td>-120</td>
<td>-1</td>
<td>Wed Apr 8 08:58:16 2009</td>
</tr>
<tr>
<td>eap17 : 01-01-01</td>
<td>36</td>
<td>802.11a</td>
<td>-120</td>
<td>-1</td>
<td>Wed Apr 8 08:58:16 2009</td>
</tr>
<tr>
<td>eap17 : 01-01-01</td>
<td>36</td>
<td>802.11a</td>
<td>-120</td>
<td>-1</td>
<td>Wed Apr 8 08:58:16 2009</td>
</tr>
</tbody>
</table>
Step 7   To modify the alarm, choose one of these commands from the Select a command drop-down list, and click Go.

- Set State to ‘Unknown-Alert’—Tags the ad hoc rogue as the lowest threat, continues to monitor the ad hoc rogue, and turns off containment.
- 1 AP Containment through 4 AP Containment—Indicates the number of access points (1-4) in the vicinity of the rogue unit that send dauthenticate and disassociate messages to the client devices that are associated to the rogue unit.
- Map (High Resolution)—Displays the current calculated rogue location on the Maps > Building Name > Floor Name page.
- Location History—Displays the history of the rogue client location based on RF fingerprinting.

Note   The client must be detected by an MSE for the location history to appear.

Viewing Adhoc Rogue Alarm Details

Alarm event details for each adhoc rogue are available from the Adhoc Rogue Alarms page.

To view alarm events for a adhoc rogue radio, click the applicable Rogue MAC Address from the Adhoc Rogue Alarms page.

This page displays alarm events for a rogue access point radio. Rogue access point radios are unauthorized access points detected by access points.

Note   When WCS polls, some data may change or get updated. Because of this, some of the displayed rogue data (including Strongest AP RSSI, No. of Rogue Clients, Channel, SSID, and Radio Types) can change during the life of the rogue. The following information is available:

- General
  - Rogue MAC Address—Media Access Control address of the adhoc rogue.
  - Vendor—Adhoc rogue vendor name or Unknown.
  - On Network—Indicates how the rogue detection occurred.
    Controller—The controller detected the rogue (Yes or No).
    Switch Port Trace—The rogue was detected by a switch port trace. Indicated by one of the following: Traced but not found, Traced and found, Not traced.
  - Owner—Indicates the owner or left blank.
  - Acknowledged—Indicates whether or not the alarm is acknowledged by the user.
    You can acknowledge the alarm to prevent it from showing up in the Alarm Summary page. The alarm remains in WCS and you can search for all Acknowledged alarms using the alarm search functionality. See the “Acknowledging Alarms” section on page 6-121 for more information.
  - State—Indicates the state of the alarm. Possible states for adhoc rogues include Threat, Alert, Internal, External, Contained, Contained Pending, and Removed.
  - SSID—Service Set Identifier being broadcast by the adhoc rogue radio. (Blank if SSID is not broadcast.)
- Channel Number—Indicates the channel of the adhoc rogue.
- Containment Level—Indicates the containment level of the adhoc rogue or Unassigned.
- Radio Type—Lists all radio types applicable to this adhoc rogue.
- Strongest AP RSSI—Indicates the strongest received signal strength indicator for this WCS (including all detecting access points for all controllers and across all detection times).
- No. of Rogue Clients—Indicates the number of rogue clients associated to this adhoc.

**Note**
This number comes from the WCS database. It is updated every two hours. From the Monitor > Alarms > Alarm Details page, this number is a real-time number. It is updated each time you open the Alarm Details page for this rogue access point.

- Created—Indicates when the alarm event was created.
- Modified—Indicates when the alarm event was modified.
- Generated By—Indicates how the alarm event was generated (either NMS or from a trap).
  - NMS (Network Management System - WCS)—Generated through polling. WCS periodically polls the controllers and generates events. WCS generates events when the traps are disabled or when the traps are lost for those events. In this case "Generated by" will be NMS.
  - Trap—Generated by the controller. WCS process these traps and raises corresponding events for them. In this case "Generated by" will be Controller.
- Severity—Indicates the severity of the alarm including the following:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="triangle-red.png" alt="Critical" /></td>
<td>Critical</td>
</tr>
<tr>
<td><img src="triangle-orange.png" alt="Major" /></td>
<td>Major</td>
</tr>
<tr>
<td><img src="triangle-yellow.png" alt="Minor" /></td>
<td>Minor</td>
</tr>
<tr>
<td><img src="triangle-green.png" alt="Warning" /></td>
<td>Warning</td>
</tr>
<tr>
<td><img src="info-circle.png" alt="Info" /></td>
<td>Info</td>
</tr>
<tr>
<td><img src="circle-grey.png" alt="Clear" /></td>
<td>Clear—Displays if the rogue is no longer detected by any access point.</td>
</tr>
</tbody>
</table>

**Note**
Rogues can be detected by multiple access points. If one access point no longer detects the rogue but the other access point does, Clear is not sent.

**Note**
Once the severity of a rogue is Clear, the alarm is deleted from WCS after 30 days.

- Previous Severity—The previous severity of the alarm: Critical, Major, Minor, Clear. Color coded.
  - Annotations—Enter any new notes in this box and click **Add** to update the alarm.
  - Message—Displays descriptive information about the alarm.
Monitoring Rogue Access Point Location, Tagging, and Containment

When the Cisco Unified Wireless Network Solution is monitored using WCS, WCS generates the flags as rogue access point traps and displays the known rogue access points by MAC address. The operator can then display a map showing the location of the access points closest to each rogue access point. The next step is to mark them as Known or Acknowledged rogue access points (no further action), Alert rogue access points (watch for and notify when active), or Contained rogue access points (have between one and four access points discourage rogue access point clients by sending the clients deauthenticate and disassociate messages whenever they associate with the rogue access point).

This built-in detection, tagging, monitoring, and containment capability enables system administrators to take appropriate action:

- Locate rogue access points
- Receive new rogue access point notifications, eliminating hallway scans
- Monitor unknown rogue access points until they are eliminated or acknowledged
- Determine the closest authorized access point, making directed scans faster and more effective
- Contain rogue access points by sending their clients deauthenticate and disassociate messages from one to four access points. This containment can be done for individual rogue access points by MAC address or can be mandated for all rogue access points connected to the enterprise subnet.
- Tag rogue access points:
  - Acknowledge rogue access points when they are outside of the LAN and do not compromise the LAN or wireless LAN security
  - Accept rogue access points when they do not compromise the LAN or wireless LAN security
  - Tag rogue access points as unknown until they are eliminated or acknowledged
- Tag rogue access points as contained and discourage clients from associating with the rogue access points by having between one and four access points transmit deauthenticate and disassociate messages to all rogue access point clients. This function applies to all active channels on the same rogue access point.

Detecting Access Points

Use the Detecting Access Points feature to view information about the Cisco lightweight access points that are detecting a rogue access point.

To access the Rogue AP Alarms details page, follow these steps:

---

**Step 1** To display the Rogue AP Alarms page, do one of the following:
• Perform a search for rogue APs. See the “Using the Search Feature” section on page 2-34 for more information about the search feature.

• From the WCS home page, click the Security tab. This tab displays all the rogue access points detected in the past hour and the past 24 hours. Click the rogue access point number to view the rogue access point alarms.

• Click the Malicious AP number link in the Alarm Summary box. See the “Using the Alarm Summary” section on page 6-80 for more information.

Step 2 From the Rogue AP Alarms page, click the Rogue MAC Address for the applicable rogue access point. The Rogue AP Alarms details page appears.

Step 3 From the Select a command drop-down list, choose Detecting APs.

Step 4 Click Go. Click a list item to display data about that item:

• AP Name
• Radio
• Map Location
• SSID—Service Set Identifier being broadcast by the rogue access point radio.
• Channel Number—Which channel the rogue access point is broadcasting on.
• WEP—Enabled or disabled.
• WPA—Enabled or disabled.
• Pre-Amble—Long or short.
• RSSI—Received signal strength indicator in dBm.
• SNR—Signal-to-noise ratio.
• Containment Type—Type of containment applied from this access point.
• Containment Channels—Channels that this access point is currently containing.

Monitoring Rogue Alarm Events

The Events page enables you to review information about rogue alarm events. WCS generates an event when a rogue access point is detected or if you make manual changes to a rogue access point (such as changing its state). The Rogue AP Events list page displays all rogue access point events.

To access the Rogue AP Events list page, follow these steps:

Step 1 Do one of the following:

• Perform a search for rogue access point events using the Advanced Search feature of WCS. See the “Advanced Search” section on page 2-35 for more information.

• From the Rogue AP Alarms details page, choose Event History from the Select a command drop-down list. See the “Viewing Rogue AP Alarm Details” section on page 6-96 for more information.

Step 2 The Rogue AP Events list page displays the following event information:

• Severity—Indicates the severity of the alarm including:
Monitoring Rogue Access Point Location, Tagging, and Containment

Chapter 6  Monitoring Wireless Devices

Rogue MAC Address—Click the rogue MAC address to view the Rogue AP Event Details page. See the “Viewing Rogue AP Event Details” section on page 6-112 for more information.

Vendor—Rogue access point vendor name or Unknown.

Classification Type—Malicious, Friendly, or Unclassified. See the “Rogue Access Point Classification Types” section on page 6-95 for more information.

On Network—Indicates how the rogue detection occurred.

– Controller—The controller detected the rogue (Yes or No).

– Switch Port Trace—The rogue was detected by a switch port trace. Indicated by one of the following: Traced but not found, Traced and found, Not traced.

Radio Type—Lists all radio types applicable to this rogue access point.

Date/Time—The date and time that the event was generated.

State—Indicates the state of the alarm. Possible states vary depending on the classification type of rogue access point. See the “Rogue Access Point Classification Types” section on page 6-95 for additional information.

SSID—Service Set Identifier being broadcast by the rogue access point radio. (Blank if SSID is not broadcast.)

---

Viewing Rogue AP Event Details

To view rogue access point event details, follow these steps:

---

**Step 1**
From the Rogue AP Events list page, click the Rogue MAC Address link.

**Step 2**
The Rogue AP Events Details page displays the following information:

- Rogue MAC Address
- Vendor—Rogue access point vendor name or Unknown.
- On Network—Indicates how the rogue detection occurred.
  - Controller—The controller detected the rogue (Yes or No).
– Switch Port Trace—The rogue was detected by a switch port trace. Indicated by one of the following: Traced but not found, Traced and found, Not traced.

• Classification Type—Malicious, Friendly, or Unclassified. See the “Rogue Access Point Classification Types” section on page 6-95 for more information.

• State—Indicates the state of the alarm. Possible states vary depending on the classification type of rogue access point. See the “Rogue Access Point Classification Types” section on page 6-95 for additional information.

• SSID—Service Set Identifier being broadcast by the rogue access point radio. (Blank if SSID is not broadcast.)

• Channel Number—The channel on which the rogue access point is broadcasting.

• Containment Level—Indicates the containment level of the rogue access point or Unassigned.

• Radio Type—Lists all radio types applicable to this rogue access point.

• Created—The date and time that the event was generated.

• Generated By—Indicates how the alarm event was generated (either NMS or from a trap).
  – NMS (Network Management System - WCS)—Generated through polling. WCS periodically polls the controllers and generates events. WCS generates events when the traps are disabled or when the traps are lost for those events. In this case "Generated by" will be NMS.
  – Trap—Generated by the controller. WCS process these traps and raises corresponding events for them. In this case "Generated by" will be Controller.

• Device IP Address

• Severity—Indicates the severity of the alarm including the following:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="icon" alt="Critical" /></td>
<td>Critical</td>
</tr>
<tr>
<td><img src="icon" alt="Major" /></td>
<td>Major</td>
</tr>
<tr>
<td><img src="icon" alt="Minor" /></td>
<td>Minor</td>
</tr>
<tr>
<td><img src="icon" alt="Warning" /></td>
<td>Warning</td>
</tr>
<tr>
<td><img src="icon" alt="Info" /></td>
<td>Info</td>
</tr>
<tr>
<td><img src="icon" alt="Clear" /></td>
<td>Clear—Displays if the rogue is no longer detected by any access point.</td>
</tr>
</tbody>
</table>

**Note** Rogues can be detected by multiple access points. If one access point no longer detects the rogue but the other access point does, Clear is not sent.

**Note** Once the severity of a rogue is Clear, the alarm is deleted from WCS after 30 days.

• Message—Provides details of the current event.
Monitoring Adhoc Rogue Events

The Events page enables you to review information about adhoc rogue events. WCS generates an event when an adhoc rogue is detected or if you make manual changes to an adhoc rogue (such as changing its state). The Adhoc Rogue Events list page displays all adhoc rogue events.

To access the Rogue AP Events list page, follow these steps:

Step 1  Do one of the following:
- Perform a search for adhoc rogue events using the Advanced Search feature of WCS. See the “Advanced Search” section on page 2-35 for more information.
- From the Adhoc Rogue Alarms details page, choose Event History from the Select a command drop-down list. See the “Viewing Adhoc Rogue Alarm Details” section on page 6-108 for more information.

Step 2  The Rogue AP Events list page displays the following event information.
- Severity—Indicates the severity of the alarm including:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="critical.png" alt="Critical" /></td>
<td>Critical</td>
</tr>
<tr>
<td><img src="major.png" alt="Major" /></td>
<td>Major</td>
</tr>
<tr>
<td><img src="minor.png" alt="Minor" /></td>
<td>Minor</td>
</tr>
<tr>
<td><img src="warning.png" alt="Warning" /></td>
<td>Warning</td>
</tr>
<tr>
<td><img src="info.png" alt="Info" /></td>
<td>Info</td>
</tr>
</tbody>
</table>

- Rogue MAC Address—Click the rogue MAC address to view the Rogue AP Event Details page. See the “Viewing Adhoc Rogue Event Details” section on page 6-115 for more information.
- Vendor—Rogue access point vendor name or Unknown.
- On Network—Indicates how the rogue detection occurred.
  - Controller—The controller detected the rogue (Yes or No).
  - Switch Port Trace—The rogue was detected by a switch port trace. Indicated by one of the following: Traced but not found, Traced and found, Not traced.
- Radio Type—Lists all radio types applicable to this rogue access point.
- Date/Time—The date and time that the event was generated.
- State—Indicates the state of the alarm. Possible states for adhoc rogues include Threat, Alert, Internal, External, Contained, Contained Pending, and Removed.
- SSID—Service Set Identifier being broadcast by the rogue access point radio. (Blank if SSID is not broadcast.)
Viewing Adhoc Rogue Event Details

To view rogue access point event details, follow these steps:

**Step 1**  From the Rogue AP Events list page, click the Rogue MAC Address link.

**Step 2**  The Rogue AP Events Details page displays the following information:

- Rogue MAC Address
- Vendor—Rogue access point vendor name or Unknown.
- On Network—Indicates how the rogue detection occurred.
  - Controller—The controller detected the rogue (Yes or No).
  - Switch Port Trace—The rogue was detected by a switch port trace. Indicated by one of the following: Traced but not found, Traced and found, Not traced.
- State—Indicates the state of the alarm. Possible states for adhoc rogues include Threat, Alert, Internal, External, Contained, Contained Pending, and Removed.
- SSID—Service Set Identifier being broadcast by the rogue access point radio. (Blank if SSID is not broadcast.)
- Channel Number—The channel on which the rogue access point is broadcasting.
- Containment Level—Indicates the containment level of the rogue access point or Unassigned.
- Radio Type—Lists all radio types applicable to this rogue access point.
- Created—The date and time that the event was generated.
- Generated By—Indicates how the alarm event was generated (either NMS or from a trap).
  - NMS (Network Management System - WCS)—Generated through polling. WCS periodically polls the controllers and generates events. WCS generates events when the traps are disabled or when the traps are lost for those events. In this case "Generated by" will be NMS.
  - Trap—Generated by the controller. WCS process these traps and raises corresponding events for them. In this case "Generated by" will be Controller.
- Device IP Address
- Severity—Indicates the severity of the alarm including the following:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="triangle-red.png" alt="Critical" /></td>
<td>Critical</td>
</tr>
<tr>
<td><img src="triangle-orange.png" alt="Major" /></td>
<td>Major</td>
</tr>
<tr>
<td><img src="triangle-yellow.png" alt="Minor" /></td>
<td>Minor</td>
</tr>
<tr>
<td><img src="triangle-yellow.png" alt="Warning" /></td>
<td>Warning</td>
</tr>
</tbody>
</table>
Monitoring Rogue Access Point Location, Tagging, and Containment

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Info</td>
<td>Clear—Displays if the rogue is no longer detected by any access point.</td>
</tr>
<tr>
<td>Note</td>
<td>Rogues can be detected by multiple access points. If one access point no longer detects the rogue but the other access point does, Clear is not sent.</td>
</tr>
<tr>
<td>Note</td>
<td>Once the severity of a rogue is Clear, the alarm is deleted from WCS after 30 days.</td>
</tr>
</tbody>
</table>

- Message—Provides details of the current event.

Monitoring Email Notifications

The Cisco WCS includes a built-in email notification function which can notify the network operator when critical alarms occur.

The email notification filter page allows you to add a filter for each alert category. Severity level is set to critical by default when the alert category is enabled, but you can choose a different severity level for different categories. Email notifications are generated only for the severity levels that are configured.

To configure e-mail notifications, follow these steps:

**Step 1** Choose Monitor > Alarms.

**Step 2** From the Select a command drop-down list, choose Email Notification.

**Step 3** Click Go.

**Step 4** Click an Alarm Category to edit severity level and e-mail recipients for its e-mail notifications.

**Step 5** Select the severity level check box(es) (Critical, Major, Minor, or Warning) for which you want a notification sent.

**Step 6** Enter the notification recipient e-mail addresses in the To text box.

*Note* Separate multiple e-mail addresses with a comma.

**Step 7** Click OK.

**Step 8** Select the Enabled check box for applicable alarm categories to activate the delivery of e-mail notifications.

**Step 9** Click OK.

Monitoring Severity Configurations

You can change the severity level for newly generated alarms.
Monitoring Rogue Access Point Location, Tagging, and Containment

Note

Existing alarms remain unchanged.

To change the severity level of newly-generated alarms, follow these steps:

Step 1  Choose Administration > Setting.
Step 2  Choose Severity Configuration from the left sidebar menu.
Step 3  Select the check box of the alarm condition for which you want to change the severity level.
Step 4  From the Configure Severity Level drop-down list, choose the new severity level (Critical, Major, Minor, Warning, Informational, Reset to Default).
Step 5  Click Go.
Step 6  Click OK to confirm the change.

Monitoring Cisco Adaptive wIPS Alarms

Alarms from Cisco Adaptive wIPS DoS (denial of service) and security penetration attacks are classified as security alarms. You can view these wIPS alarms and their details in the Monitor > Alarms section of WCS.

To view a list of wIPS DoS and security penetration attack alarms, follow these steps:

Step 1  Perform a search for Security alarms using the Advanced Search feature. See the “Advanced Search” section on page 2-35 for more information on performing an advanced search.

The following information is provided for wIPS alarms:

- Severity—Severity levels include critical, major, info, warning, and clear.
- Failure Object—Displays the name and IP or MAC address of the object for which the alarm was generated. Click the Failure Object to view alarm details. See the “Monitoring Cisco Adaptive wIPS Alarm Details” section on page 6-118 for more information on viewing wIPS alarm details.
- Date/Time—Displays the date and time that the alarm occurred.
- Message—Displays a message explaining why the alarm occurred (such as the applicable wIPS policy).
- Acknowledged—Displays whether or not the alarm is acknowledged by the user.
- Category—Indicates the category of this alarm such as Security.
- Condition—Displays a description of what caused this alarm to be triggered.

When there are multiple alarm pages, the page numbers are displayed at the top of the page with a scroll arrow on each side. Use this to view additional alarms.

To add, remove, or reorder columns in the table, click the Edit View link to go to the Edit View page.
Select a command

Using the **Select a command** drop-down list, you can perform the following actions on the selected alarms:

- Assign to me—Assign the selected alarm(s) to the current user.
- Unassign—Unassign the selected alarm(s).
- Delete—Delete the selected alarm(s).
- Clear—Clear the selected alarm(s).
- Acknowledge—You can acknowledge the alarm to prevent it from showing up in the Alarm Summary page. The alarm remains in WCS and you can search for all Acknowledged alarms using the alarm search functionality.
- Unacknowledge—You can choose to unacknowledge an already acknowledged alarm.
- Email Notification—Takes you to the All Alarms > Email Notification page to view and configure email notifications.

To perform an action on the selected alarm, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Select an alarm by selecting its check box.</td>
</tr>
<tr>
<td>2</td>
<td>From the Select a command drop-down list, choose a the applicable command.</td>
</tr>
<tr>
<td>3</td>
<td>Click Go.</td>
</tr>
</tbody>
</table>

**Monitoring Cisco Adaptive wIPS Alarm Details**

Choose **Monitor > Alarms > \(<failure object>\)** to view details of the selected Cisco wIPS alarm. The following Alarm Details are provided for Cisco Adaptive wIPS alarms:

- **General**
  - Detected By wIPS AP—The access point that detected the alarm.
  - wIPS AP IP Address—The IP address of the wIPS access point.
  - Owner—Name of person to which this alarm is assigned or left blank.
  - Acknowledged—Displays whether or not the alarm is acknowledged by the user.
  - Category—For wIPS, the alarm category is Security.
  - Created—Month, day, year, hour, minute, second, AM or PM that the alarm was created.
  - Modified—Month, day, year, hour, minute, second, AM or PM that the alarm was last modified.
  - Generated By—Indicates how the alarm event was generated (either NMS or from a trap).
    - NMS (Network Management System - WCS)—Generated through polling. WCS periodically polls the controllers and generates events. WCS generates events when the traps are disabled or when the traps are lost for those events. In this case "Generated by” will be NMS.
    - Trap—Generated by the controller. WCS process these traps and raises corresponding events for them. In this case "Generated by” will be Controller.
  - Severity—Level of severity including critical, major, info, warning, and clear.
  - Last Disappeared—The date and time that the potential attack last disappeared.
- Channel—The channel on which the potential attack occurred.
- Attacker Client/AP MAC—The MAC address of the client or access point that initiated the attack.
- Attacker Client/AP IP Address—The IP address of the client or access point that initiated the attack.
- Target Client/AP IP Address—The IP address of the client or access point targeted by the attacker.
- Controller IP Address—The IP address of the controller to which the access point is associated.
- MSE—The IP address of the associated mobility services engine.
- Controller MAC address—The MAC address of the controller to which the access point is associated.
- wIPS access point MAC address
- Forensic File
- Event History—Takes you to the “Monitoring Alarms” section on page 6-80 page to view all events for this alarm.

- Annotations—Enter any new notes in this box and click Add to update the alarm. Notes are displayed in the “Annotations” display area.
- Messages—Displays information about the alarm.
- Audit Report—Click to view config audit alarms details. This report is only available for Config Audit alarms.

Configuration audit alarms are generated when audit discrepancies are enforced on config groups.

**Note**  
If enforcement fails, a critical alarm is generated on the config group. If enforcement succeeds, a minor alarm is generated on the config group. The alarms have links to the audit report where you can view a list of discrepancies for each controller.

- Rogue Clients—If the failure object is a rogue access point, information about rogue clients is displayed.

**Select a command**

Select one or more alarms by selecting their respective check boxes, selecting one of the following commands, and clicking Go.

- Assign to me—Assign the selected alarm(s) to the current user.
- Unassign—Unassign the selected alarm(s).
- Delete—Delete the selected alarm(s).
- Clear—Clear the selected alarm(s).
- Acknowledge—You can acknowledge the alarm to prevent it from showing up in the Alarm Summary page. The alarm remains in WCS and you can search for all Acknowledged alarms using the alarm search functionality.
- Unacknowledge—You can choose to unacknowledge an already acknowledged alarm.
- Email Notification—Takes you to the All Alarms > Email Notification page to view and configure email notifications.
• Event History—Takes you to the Monitor Alarms > Events page to view events for Rogue Alarms.

**Working with Alarms**

You can view, assign, and clear alarms and events on access points and mobility services engine using WCS.

This section also describes on how to have email notifications of alarms sent to you.

- Assigning and Unassigning Alarms, page 6-120
- Deleting and Clearing Alarms, page 6-120
- Acknowledging Alarms, page 6-121

**Assigning and Unassigning Alarms**

To assign and unassign an alarm to yourself, follow these steps:

**Step 1** Perform an advanced search for access point alarms. See the “Advanced Search” section on page 2-35 for more information.

**Step 2** Select the alarms that you want to assign to yourself by selecting their corresponding check boxes.

**Note** To unassign an alarm assigned to you, unslect the box next to the appropriate alarm. You cannot unassign alarms assigned to others.

**Step 3** From the Select a command drop-down list, choose Assign to Me (or Unassign), and click Go.

If you choose Assign to Me, your username appears in the Owner column. If you choose Unassign, the username column becomes empty.

**Deleting and Clearing Alarms**

To delete or clear an alarm from a mobility services engine, follow these steps:

**Step 1** From the Monitor > Alarms page, select the alarms that you want to delete or clear by selecting their corresponding check boxes.

**Note** If you delete an alarm, WCS removes it from its database. If you clear an alarm, it remains in the WCS database, but in the Clear state. You clear an alarm when the condition that caused it no longer exists.

**Step 2** From the Select a command drop-down list, choose Delete or Clear, and click Go.

**Note** To set up cleanup of old alarms and cleared alarms, choose Administration > Settings > Alarms. See the “Configuring Alarms” section on page 16-60 for more information.
Acknowledging Alarms

You may want certain alarms to be removed from the Alarms List. For example, if you are continuously receiving an interference alarm from a certain access point on the 802.11g interface, you may want to stop that access point from being counted as an active alarm on the Alarm Summary page or any alarms list. In this scenario, you can find the alarm for the 802.11g interface in the Alarms list, select the check box, and choose Acknowledge from the Select a command drop-down list.

Now if the access point generates a new violation on the same interface, WCS will not create a new alarm, and the Alarm Summary page shows no new alarms. However, if the interference violation is created on another interface, such as 802.11a, a new alarm is created.

Any alarms, once acknowledged, will not show up on either the Alarm Summary page or any alarm list page. Also, no emails are generated for these alarms after you have marked them as acknowledged. By default, acknowledged alarms are not included for any search criteria. To change this default, choose the Administration > Settings > Alarms page, and disable the Hide Acknowledged Alarms preference.

When you acknowledge an alarm, the following warning appears as a reminder that a recurrence of the problem does not generate another alarm unless this functionality is disabled (see Figure 6-13).

![Figure 6-13 Alarm Warning](image)

When you acknowledge an alarm, a warning displays as a reminder that a recurrence of the problem does not generate another alarm unless this functionality is disabled. Choose Administration > User Preferences page to disable this warning message.

You can also search for all previously acknowledged alarms to reveal the alarms that were acknowledged during the last seven days. WCS automatically deletes cleared alerts that are more than seven days old so your results can only show activity for the last seven days. Until an existing alarm is deleted, a new alarm cannot be generated for any managed entity for which WCS has already generated an alarm.

Monitoring Air Quality Alarms

The Air Quality Alarms page displays air quality alarms on your network.

To access the air quality alarms page, do one of the following:

- Perform a search for Performance alarms. See the “Using the Search Feature” section on page 2-34 for more information.
- Click the Performance number link in the Alarm Summary box. See the “Using the Alarm Summary” section on page 6-80 for more information.

The Monitor Air Quality Alarms page contains the following parameters:
• Severity—Indicates the severity of the alarm including:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Critical</td>
</tr>
<tr>
<td></td>
<td>Major</td>
</tr>
<tr>
<td></td>
<td>Minor</td>
</tr>
<tr>
<td></td>
<td>Warning</td>
</tr>
<tr>
<td></td>
<td>Info</td>
</tr>
<tr>
<td></td>
<td>Clear</td>
</tr>
</tbody>
</table>

Note: Rogues can be detected by multiple access points. If one access point no longer detects the rogue but the other access point does, Clear is not sent.

Note: Once the severity of a rogue is Clear, the alarm is deleted from WCS after 30 days.

• Failure Source—Device that generated the alarm.
• Owner—Name of the person to which this alarm is assigned, or blank.
• Date/Time—The time at which the alarm was generated.
• Message—The associated message displayed in the WCS alarm browser.
• Acknowledged—Displays whether or not the alarm is acknowledged by the user. See the “Acknowledging Alarms” section on page 6-121 for more information.

**Select a command**

Select one or more alarms by selecting their respective check boxes, select one of the following commands from the Select a command drop-down list, and click **Go**.

• Assign to me—Assign the selected alarm(s) to the current user.
• Unassign—Unassign the selected alarm(s).
• Clear—Clear the selected alarm(s).
• Delete—Delete the selected alarm(s).
• Acknowledge—Acknowledge the alarm to prevent it from showing up in the Alarm Summary page. See the “Acknowledging Alarms” section on page 6-121 for more information.

**Note** The alarm remains in WCS and you can search for all Acknowledged alarms using the alarm search functionality.

• Unacknowledge—Unacknowledge an already acknowledged alarm.
• Email Notification—Takes you to the All Alarms > Email Notification page to view and configure email notifications. See the “Monitoring Email Notifications” section on page 6-116 for more information.

Monitoring CleanAir Security Alarms

The CleanAir Security Alarms page displays security alarms on your network.

To access the security alarms page, do one of the following:

• Perform a search for Security alarms. See the “Using the Search Feature” section on page 2-34 for more information.

• Click the Security number link in the Alarm Summary box. See the “Using the Alarm Summary” section on page 6-80 for more information.

The Monitor CleanAir Security Alarms page contains the following parameters:

• Severity—Indicates the severity of the alarm including:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Critical Icon]</td>
<td>Critical</td>
</tr>
<tr>
<td>![Major Icon]</td>
<td>Major</td>
</tr>
<tr>
<td>![Minor Icon]</td>
<td>Minor</td>
</tr>
<tr>
<td>![Warning Icon]</td>
<td>Warning</td>
</tr>
<tr>
<td>![Info Icon]</td>
<td>Info</td>
</tr>
<tr>
<td>![Clear Icon]</td>
<td>Clear—Displays if the rogue is no longer detected by any access point.</td>
</tr>
</tbody>
</table>

**Note**
Rogues can be detected by multiple access points. If one access point no longer detects the rogue but the other access point does, Clear is not sent.

**Note** Onces the severity of a rogue is Clear, the alarm is deleted from WCS after 30 days.

• Failure Source—Device that generated the alarm.

• Owner—Name of the person to which this alarm is assigned, or blank.

• Date/Time—The time at which the alarm was generated.

• Message—The associated message displayed in the WCS alarm browser.

• Acknowledged—Displays whether or not the alarm is acknowledged by the user. See the “Acknowledging Alarms” section on page 6-121 for more information.
Select a command

Select one or more alarms by selecting their respective check boxes, select one of the following commands from the Select a command drop-down list, and click Go.

- Assign to me—Assign the selected alarm(s) to the current user.
- Unassign—Unassign the selected alarm(s).
- Clear—Clear the selected alarm(s).
- Delete—Delete the selected alarm(s).
- Acknowledge—Acknowledge the alarm to prevent it from showing up in the Alarm Summary page. See the “Acknowledging Alarms” section on page 6-121 for more information.

Note

- Unacknowledge—Unacknowledge an already acknowledged alarm.
- Email Notification—Takes you to the All Alarms > Email Notification page to view and configure email notifications. See the “Monitoring Email Notifications” section on page 6-116 for more information.

Monitoring Events

Choose Monitor > Events to access the Events page.

One or more events may generate an abnormal state or alarm. The alarm can be cleared, but the event remains.

The Monitor > Events page displays the following information:

- Severity—Event severities include: Critical, Major, Minor, Warning, Clear, Info. Color coded. Click the title to sort the events list by severity (ascending or descending order).
- Failure Source—Indicates the affected device type (including name and/or MAC address).
- Date/Time—Indicates the date and time the event was generated.
- Message—Indicates event details.

When you filter the table using the Search feature, the Events page may display the additional information. See the “Advanced Search” section on page 2-35 (Advanced Search results for Events) for more information on performing a search. The additional information includes:

- Coverage Hole Events
  - Access Point Name
  - Failed Clients—Number of clients that failed due to the coverage hole.
  - Total Clients—Total number of clients affected by the coverage hole.
  - Radio Type—The radio type (802.11b/g or 802.11a) of the applicable access point.
  - Coverage Threshold
- Rogue AP Events
  - Vendor—Rogue access point vendor name or Unknown.
Classification Type—Indicates the type of rogue access point including Malicious, Friendly, or Unclassified.

On Network—Indicates how the rogue detection occurred.

Controller—The controller detected the rogue (Yes or No).

Switch Port Trace—The rogue was detected by a switch port trace. Indicated by one of the following: Traced but not found, Traced and found, Not traced.

Radio Type—Lists all radio types applicable to this rogue access point.

State—Indicates the state of the alarm. Possible states for adhoc rogues include Threat, Alert, Internal, External, Contained, Contained Pending, and Removed.

SSID—Service Set Identifier being broadcast by the rogue access point radio. (Blank if SSID is not broadcast.)

Note See the “Monitoring Rogue Alarm Events” section on page 6-111 or “Viewing Rogue AP Event Details” section on page 6-112 for more information on rogue access points events.

- Adhoc Rogue Events
  - Vendor—Rogue access point vendor name or Unknown.
  - On Network—Indicates how the rogue detection occurred.
  
  Controller—The controller detected the rogue (Yes or No).
  
  Switch Port Trace—The rogue was detected by a switch port trace. Indicated by one of the following: Traced but not found, Traced and found, Not traced.
  
  Radio Type—Lists all radio types applicable to this rogue access point.
  
  State—Indicates the state of the alarm. Possible states for adhoc rogues include Threat, Alert, Internal, External, Contained, Contained Pending, and Removed.
  
  SSID—Service Set Identifier being broadcast by the rogue access point radio. (Blank if SSID is not broadcast.)

- Interference
  - Detected By—IP address of the device that detected the interference.
  
  ID—ID of the device that detected the interference.

- Mesh Links
- Client
- Context Aware Notification

- Pre Coverage Hole
  - Client MAC Address—MAC address of the client affected by the Pre Coverage Hole.
  
  AP MAC Address—MAC address of the applicable access point.
  
  Radio Type—The radio type (802.11b/g or 802.11a) of the applicable access point.
  
  Power Level—Access Point transmit power level:

  1 = Maximum power allowed per Country Code setting
  
  2 = 50% power
  
  3 = 25% power
4 = 6.25 to 12.5% power
5 = 0.195 to 6.25% power.

- Client Type—Client type can be any of the following:
  - laptop(0),
  - pc(1),
  - pda(2),
  - dot11mobilephone(3),
  - dualmodephone(4),
  - wgb(5),
  - scanner(6),
  - tablet(7),
  - printer(8),
  - projector(9),
  - videoconfsystem(10),
  - camera(11),
  - gamingsystem(12),
  - dot11deskphone(13),
  - cashregister(14),
  - radiotag(15),
  - rfsensor(16),
  - server(17)

- WLAN Coverage Hole Status

If there is more than one page of events, the number of pages is displayed with a scroll arrow on each side. Use this to view additional events.

### Searching Events

Use the WCS Search feature to find specific events or to create and save custom searches. See one of the following topics for additional information:

- Using the Search Feature, page 2-34
- Quick Search, page 2-34
- Advanced Search, page 2-35
- Saved Searches, page 2-46
Monitoring Failure Objects

**Note**
The event categories Location Servers and Location Notifications appear only in the Cisco WCS Location version.

Choose Monitor > Events, and click a list item under Failure Object to access this page. This page displays information for a specific event. It contains the following information:

- **General Parameters**
  - Failure Object—Click the title to toggle between the name and the object in the Message column. Click a list item to display parameter details.
  - Owner—Owner of the event, or (blank).
  - Category—Type of alarm such as Security or Access Point.
  - Created—Date and time that the event occurred.
  - Generated By—Indicates how the alarm event was generated (either NMS or from a trap).
    - NMS (Network Management System - WCS)—Generated through polling. WCS periodically polls the controllers and generates events. WCS generates events when the traps are disabled or when the traps are lost for those events. In this case "Generated by" will be NMS.
    - Trap—Generated by the controller. WCS process these traps and raises corresponding events for them. In this case "Generated by" will be Controller.
  - Device IP Address—IP address of the alarm-generating device.
  - Severity—Level of severity including critical, major, info, warning, and clear.

- **Help**—A short explanation of the event.
- **Message**—Message explaining why the event occurred.

Monitoring Events for Rogue APs

Choose Monitor > Events. From the left sidebar menu Event Category, choose Rogue AP to display the Monitoring Events page page 6-124 page for rogue access points. Click an item under Rogue MAC Address to display this page.

This page displays alarm events for a rogue access point radio. Rogue access point radios are unauthorized access points detected by controllers. The following parameters appear:

General
- Rogue MAC Address
- Vendor
- On Network—Indicates how the rogue detection occurred.
  - Controller—The controller detected the rogue (Yes or No).
  - Switch Port Trace—The rogue was detected by a switch port trace. Indicated by one of the following: Traced but not found, Traced and found, Not traced.
- Owner—Name of person to which this alarm is assigned, or (blank).
Monitoring Events

• **State**—State of this radio relative to the network or Port. Rogue access point radios appear as “Alert” when first scanned by the Port, or as “Pending” when operating system identification is still underway.

• **SSID**—Service Set Identifier being broadcast by the rogue access point radio. (Blank if SSID is not broadcast.)

• **Containment Level**—An access point which is being contained will either not be able to provide service at all, or will provide exceedingly slow service. There is a level associated with the containment activity which indicates how many access points to use in containing the threat. This service must be initiated and halted by the administrator. Containment Type - Contained if the rogue access point clients have been contained at Level 1 through Level 4 under Update Status, otherwise Unassigned.

• **Channel**—Indicates the band at which the adhoc rogue is broadcasting.

• **Radio Type**—Lists all radio types applicable to this rogue access point.

• **Created**—Date and time that the event occurred.

• **Generated By**—Indicates how the alarm event was generated (either NMS or from a trap).
  - NMS (Network Management System - WCS)—Generated through polling. WCS periodically polls the controllers and generates events. WCS generates events when the traps are disabled or when the traps are lost for those events. In this case "Generated by" will be NMS.
  - Trap—Generated by the controller. WCS process these traps and raises corresponding events for them. In this case "Generated by" will be Controller.

• **Device IP Address**—IP address of the alarm-generating device.

• **Severity**—Level of severity, Critical, Major, Minor, Warning, Clear, Info. Color coded.

**Message**—Displays descriptive information about the alarm.

**Help**—Displays information about the alarm.

**Note**

Use the Advance Search feature to find specific events. See the “Advanced Search” section on page 2-35 for more information.

---

**Monitoring Events for Adhoc Rogues**

Choose **Monitor > Events**. From the left sidebar menu Event Category, choose **Adhoc Rogue** to display the “Monitoring Events” section on page 6-124 page for adhoc rogue. Click an item under Rogue MAC Address to display adhoc rogue event details.

**General**

• **Rogue MAC Address**

• **Vendor**

• **On Network**—Indicates how the rogue detection occurred.
  - **Controller**—The controller detected the rogue (Yes or No).
  - **Switch Port Trace**—The rogue was detected by a switch port trace. Indicated by one of the following: Traced but not found, Traced and found, Not traced.
• Owner—Name of person to which this alarm is assigned, or (blank).
• State—State of this radio relative to the network or Port. Rogue access point radios appear as “Alert” when first scanned by the Port, or as “Pending” when operating system identification is still underway.
• SSID—Service Set Identifier being broadcast by the rogue access point radio. (Blank if SSID is not broadcast.)
• Containment Level—An access point which is being contained will either not be able to provide service at all, or will provide exceedingly slow service. There is a level associated with the containment activity which indicates how many access points to use in containing the threat. This service must be initiated and halted by the administrator. Containment Type - Contained if the rogue access point clients have been contained at Level 1 through Level 4 under Update Status, otherwise Unassigned.
• Channel—Indicates the band at which the adhoc rogue is broadcasting.
• Created—Date and time that the event occurred.
• Generated By—Indicates how the alarm event was generated (either NMS or from a trap).
  – NMS (Network Management System - WCS)—Generated through polling. WCS periodically polls the controllers and generates events. WCS generates events when the traps are disabled or when the traps are lost for those events. In this case “Generated by” will be NMS.
  – Trap—Generated by the controller. WCS process these traps and raises corresponding events for them. In this case “Generated by” will be Controller.
• Device IP Address—IP address of the alarm-generating device.
Message—Displays descriptive information about the alarm.
Help—Displays information about the alarm.

Monitoring Cisco Adaptive wIPS Events

Choose Monitor > Events to view wIPS events. One or more events may generate an abnormal state or alarm. The alarm can be cleared, but the event remains. For more information regarding monitoring events, see the “Monitoring Events” section on page 6-124.

The following sections provide additional information regarding Cisco Adaptive wIPS:

• Configuring wIPS Profiles, page 9-211
• Mobility Services, page 12-1
• wIPS Policy Alarm Encyclopedia, page 20-1

Perform an events search to narrow the results to mobility services engine or Security events only. To view mobility services engine or Security events only, follow these steps:

Step 1 Choose Monitor > Events.
Step 2 From the left sidebar menu, choose Mobility Service or Security from the Event Category drop-down list.
Step 3 Click Go.
Note
If there is more than one page of events, the number of pages is displayed with a scroll arrow on each side. Use this to view additional events.

Monitoring CleanAir Air Quality Events

You can use WCS to view the events generated on the air quality of the wireless network.

To view air quality events, follow these steps:

Step 1 Click Advanced Search in the WCS window.

The New Search page appears.

Step 2 In the New Search page, choose Events from the Search Category drop-down list.

Step 3 From the Severity drop-down list, choose the type of severity you want to search the air quality events.

Step 4 From the Event Category drop-down list, choose Performance.

Step 5 Click Go.

The air quality events page displays the following information:

- Severity—Indicates the severity of the alarm including:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Critical" /></td>
<td>Critical</td>
</tr>
<tr>
<td><img src="image2" alt="Major" /></td>
<td>Major</td>
</tr>
<tr>
<td><img src="image3" alt="Minor" /></td>
<td>Minor</td>
</tr>
<tr>
<td><img src="image4" alt="Warning" /></td>
<td>Warning</td>
</tr>
<tr>
<td><img src="image5" alt="Info" /></td>
<td>Info</td>
</tr>
<tr>
<td><img src="image6" alt="Clear" /></td>
<td>Clear—Displays if the rogue is no longer detected by any access point.</td>
</tr>
</tbody>
</table>

Note: Rogues can be detected by multiple access points. If one access point no longer detects the rogue but the other access point does, Clear is not sent.

Note: Once the severity of a rogue is Clear, the alarm is deleted from WCS after 30 days.

- Failure Source—Device that generated the alarm.
- Date/Time—The time at which the alarm was generated.
Viewing Air Quality Event Details

To view air quality event details, follow these steps:

**Step 1**  From the Air Quality Events page, click an item under Failure Source to access the alarm details page. See the “Monitoring CleanAir Air Quality Events” section on page 6-130.

**Step 2**  The air quality event page displays the following information:
- Failure Source—Device that generated the alarm.
- Category—The category this event comes under. In this case, Performance.
- Created—The time stamp at which the event was generated.
- Generated by—The device that generated the event.
- Device IP Address—The IP address of the device that generated the event.
- Severity—The severity of the event.
- Alarm Details—A link to the related alarms associated with this event. Click the link to know more about the alarm details.
- Message—Describes the air quality index on this access point.

Monitoring Interferer Security Risk Events

You can use WCS to view the security events generated on your wireless network.

To view interferer security events, follow these steps:

**Step 1**  Click **Advanced Search** in the WCS window.

The New Search page appears.

**Step 2**  In the New Search page, choose **Events** from the Search Category drop-down list.

**Step 3**  From the Severity drop-down list, choose the type of severity you want to search the air quality events.

**Step 4**  From the Event Category drop-down list, choose **Security**.

**Step 5**  Click **Go**.

The interferer security events page displays the following information:
- Severity—Indicates the severity of the alarm including:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="critical_icon" alt="Critical" /></td>
<td>Critical</td>
</tr>
<tr>
<td><img src="major_icon" alt="Major" /></td>
<td>Major</td>
</tr>
<tr>
<td><img src="minor_icon" alt="Minor" /></td>
<td>Minor</td>
</tr>
<tr>
<td><img src="warning_icon" alt="Warning" /></td>
<td>Warning</td>
</tr>
</tbody>
</table>
Monitoring Events

Chapter 6 Monitoring Wireless Devices

Viewing Interferer Security Risk Event Details

To view interferer security event details, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>In the Interferer Security Event details page, click an item under Failure Source to access the alarm details page. See the “Monitoring Interferer Security Risk Events” section on page 6-131.</td>
</tr>
</tbody>
</table>
| Step 2 | The air quality event page displays the following information:  
- Failure Source—Device that generated the alarm.  
- Category—The category this event comes under. In this case, Security.  
- Created—The time stamp at which the event was generated.  
- Generated by—The device that generated the event.  
- Device IP Address—The IP address of the device that generated the event.  
- Severity—The severity of the event.  
- Alarm Details—A link to the related alarms associated with this event. Click the link to know more about the alarm details.  
- Message—Describes the interferer device affecting the access point. |

Monitoring Health Monitor Events

You can use WCS to view the events generated by the Health Monitor.

To view the health monitor events, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
</table>
| Step 1 | Click Advanced Search in the WCS window.  
The New Search page appears. |
| Step 2 | In the New Search page, choose Events from the Search Category drop-down list. |
| Step 3 | From the Severity drop-down list, choose the type of severity you want to search the health monitor events. |
Step 4  From the Event Category drop-down list, choose WCS.

Step 5  Click Go.

The health monitor events page displays the following information:

- Severity—Indicates the severity of the alarm including the following:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Critical" /></td>
<td>Critical</td>
</tr>
<tr>
<td><img src="image" alt="Major" /></td>
<td>Major</td>
</tr>
<tr>
<td><img src="image" alt="Minor" /></td>
<td>Minor</td>
</tr>
<tr>
<td><img src="image" alt="Warning" /></td>
<td>Warning</td>
</tr>
<tr>
<td><img src="image" alt="Info" /></td>
<td>Info</td>
</tr>
<tr>
<td><img src="image" alt="Clear" /></td>
<td>Clear</td>
</tr>
</tbody>
</table>

- Failure Source—Device that generated the alarm.
- Date/Time—The time at which the alarm was generated.
- Message—Describes the health details.

### Viewing Health Monitor Event Details

To view health monitor event details, follow these steps:

Step 1  From the Health Monitor Events page, click an item under Failure Source to access the alarm details page. See the “Monitoring Health Monitor Events” section on page 6-132.

Step 2  The health monitor event page displays the following information:

- Failure Source—Device that generated the alarm.
- Category—The category this event comes under. In this case, WCS.
- Created—The time stamp at which the event was generated.
- Generated by—The device that generated the event.
- Device IP Address—The IP address of the device that generated the event.
- Severity—The severity of the event.
- Alarm Details—A link to the related alarms associated with this event. Click the link to know more about the alarm details.
- Message—Describes the event through a message.
Working with Events

You can use WCS to view mobility services engine and access point events. You can search and display events based on their severity (critical, major, minor, warning, clear, info) and event category or you can search for a mobility services engine and access point by its IP address, MAC address or name.

A successful event search displays the event severity, failure object, date and time of the event, and any messages for each event.

To display events, follow these steps:

---

**Step 1**  In Cisco WCS, click **Monitor > Events**.

**Step 2**  In the Events page:

- If you want to display the events for a specific element and you know its IP address, MAC address, or Name, enter that value in the Quick Search text box (left pane). Click **Go**.
- To display events by severity and category, select the appropriate options from the Severity and Event Category drop-down lists (left pane). Click **Search**.

**Step 3**  If WCS finds events that match the search criteria, it displays a list of these events.

---

**Note**  For more information about an event, click the failure object associated with the event. Additionally, you can sort the events summary by each of the column headings.
Managing WCS User Accounts

The Administration enables you to schedule tasks, administer accounts, and configure local and external authentication and authorization. Also, set logging options, configure mail servers, and data management related to configuring the data retain periods. Information is available about the types of WCS licenses and how to install a license.

Organizations need an easy and cost-effective method to manage and control wireless network segments using a single management platform. They need a solution that supports limiting an individual administrator to manage or control the wireless LAN.

This chapter describes the administrative tasks to perform with Cisco WCS. It contains the following sections:

- Managing WCS User Accounts, page 7-1
- Viewing the Audit Trail, page 7-10
- Managing WCS Guest User Accounts, page 7-13
- Adding a New User, page 7-15
- Managing Lobby Ambassador Accounts, page 7-19

Managing WCS User Accounts

This section describes how to configure global e-mail parameters and manage WCS user accounts. It contains the following topics:

- Adding WCS User Accounts, page 7-2
- Deleting WCS User Accounts, page 7-4
- Changing Passwords, page 7-5
- Monitoring Active Sessions, page 7-5
- Viewing or Editing User Account Information, page 7-6
- Viewing or Editing Group Information, page 7-9
- Viewing the Audit Trail, page 7-10
- Creating Guest User Accounts, page 7-11
- Logging in to the WCS User Interface as a Lobby Ambassador, page 7-12
Adding WCS User Accounts

This section describes how to configure a WCS user. The accounting portion of the AAA framework is not implemented at this time. Besides complete access, you can give administrative access with differentiated privileges to certain user groups. WCS supports external user authentication using these access restrictions and authenticates the users against the TACACS+ and RADIUS servers.

The username and password supplied by you at install time are always authenticated, but the steps you take here create additional superusers. If the password is lost or forgotten, you must run a utility to reset the password to another user-defined password.

To add a new user account to WCS, follow these steps:

---

**Step 1**
Start WCS by following the instructions in the “Starting WCS” section on page 2-15.

**Step 2**
Log into the WCS user interface as Super1.

**Note**
We recommend that you create a new superuser assigned to the SuperUsers group and delete Super1 to prevent unauthorized access to the system.

**Step 3**
Choose Administration > AAA. The Change Password page appears (see Figure 7-1).

---

**Figure 7-1**
Change Password Page

---

**Step 4**
In the Old Password text box, enter the current password that you want to change.

**Step 5**
Enter the username and password for the new WCS user account. You must enter the password twice.

**Note**
These entries are case sensitive.

**Step 6**
Choose Groups from the left sidebar menu. The All Groups page displays the following group names (see Figure 7-2).
Note: Some usergroups cannot be combined with other usergroups. For instance, you cannot choose both lobby ambassador and monitor lite.

- **System Monitoring**—Allows users to monitor WCS operations.
- **ConfigManagers**—Allows users to monitor and configure WCS operations.
- **Admin**—Allows users to monitor and configure WCS operations and perform all system administration tasks except administering WCS user accounts and passwords.

Note: If you choose admin account and log in as such on the controller, you can also see the guest users under Local Net Admin.

- **SuperUsers**—Allows users to monitor and configure WCS operations and perform all system administration tasks including administering WCS user accounts and passwords. Superusers tasks can be changed.
- **North bound API**—A user group used only with WCS Navigator.
- **Users Assistant**—Allows only local net user administration. User assistants cannot configure or monitor controllers. They must access the Configure > Controller page to configure these local net features.

Note: If you create a user assistant user, log in as that user, and choose Monitor > Controller, you receive a permission denied message as expected behavior.

- **Lobby Ambassador**—Allows guest access for only configuration and managing of user accounts.
- **Monitor lite**—Allows monitoring of assets location.
- **Root**—Allows users to monitor and configure WCS operations and perform all system administration tasks including changing any passwords. Only one user can be assigned to this group and is determined upon installation. It cannot be removed from the system, and no task changes can be made for this user.
Managing WCS User Accounts

Chapter 7      Managing WCS User Accounts

Managing WCS User Accounts

Figure 7-2   All Groups Page

<table>
<thead>
<tr>
<th>Change Password</th>
<th>Local Password Policy</th>
<th>AAA Mode</th>
<th>Users</th>
<th>Groups</th>
<th>Active Sessions</th>
<th>TACACS+</th>
<th>RADIUS</th>
</tr>
</thead>
<tbody>
<tr>
<td>All Groups</td>
<td>Administration &gt; AAA &gt; All Groups</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Group Name</th>
<th>Members</th>
<th>Audit Trail</th>
<th>Export</th>
</tr>
</thead>
<tbody>
<tr>
<td>Admin</td>
<td>temp</td>
<td>...</td>
<td>Task List</td>
</tr>
<tr>
<td>ConfSupports</td>
<td>temp</td>
<td>...</td>
<td>Task List</td>
</tr>
<tr>
<td>System Monitoring</td>
<td>admin</td>
<td>...</td>
<td>Task List</td>
</tr>
<tr>
<td>User Assistant</td>
<td>...</td>
<td>...</td>
<td>Task List</td>
</tr>
<tr>
<td>LobbyAmbassador</td>
<td>lobbyadm</td>
<td>lobbyrt</td>
<td>Task List</td>
</tr>
<tr>
<td>Monitor User</td>
<td>...</td>
<td>...</td>
<td>Task List</td>
</tr>
<tr>
<td>North Bound API</td>
<td>...</td>
<td>...</td>
<td>Task List</td>
</tr>
<tr>
<td>UserDefined</td>
<td>non-test</td>
<td>non-group</td>
<td>Task List</td>
</tr>
<tr>
<td>Logout</td>
<td>...</td>
<td>...</td>
<td>Task List</td>
</tr>
<tr>
<td>UserDefined 1</td>
<td>...</td>
<td>...</td>
<td>Task List</td>
</tr>
<tr>
<td>UserDefined 2</td>
<td>...</td>
<td>...</td>
<td>Task List</td>
</tr>
<tr>
<td>UserDefined 3</td>
<td>...</td>
<td>...</td>
<td>Task List</td>
</tr>
<tr>
<td>UserDefined 4</td>
<td>...</td>
<td>...</td>
<td>Task List</td>
</tr>
</tbody>
</table>

Step 7   Click the name of the user group to which you assigned the new user account. The Group Detail > User Group page shows a list of this group’s permitted operations.

From this page you can also show an audit trail of login and logout patterns or export a task list.

Step 8   Make any desired changes by selecting or unselecting the appropriate check boxes for task permissions and members.

Note   Any changes you make will affect all members of this user group.

Note   To view complete details in the Monitor > Client details page and to perform operations such as Radio Measurement, users in User Defined groups need permission for Monitor Clients, View Alerts & Events, Configure Controllers, and Client Location.

Step 9   Click Submit to save your changes or Cancel to leave the settings unchanged.

Deleting WCS User Accounts

To delete a WCS user account, follow these steps:

Step 1   Start WCS by following the instructions in the “Starting WCS” section on page 2-15.

Step 2   Log into the WCS user interface as a user assigned to the SuperUsers group.

Step 3   Choose Administration > AAA.

Step 4   Choose Users from the left sidebar menu to display the Users page.

Step 5   Select the check box to the left of the user account(s) to be deleted.

Step 6   From the Select a command drop-down list, choose Delete User(s), and click Go.
When prompted, click OK to confirm your decision. The user account is deleted and can no longer be used.

### Changing Passwords

To change the password for a WCS user account, follow these steps:

**Step 1** Start WCS by following the instructions in the “Starting WCS” section on page 2-15.

**Step 2** Log into the WCS user interface as a user assigned to the SuperUsers group.

**Step 3** Choose Administration > AAA to display the Change Password page.

**Step 4** Enter your old password, unless you are the root user. (A root user can change any password without entering the old password.)

**Step 5** Enter the new password in both the New Password and Confirm New Password text boxes.

**Step 6** Click Save to save your changes. The password for this user account has been changed and can be used immediately.

### Monitoring Active Sessions

To view a list of active users, follow the steps:

**Step 1** Choose Administration > AAA.

**Step 2** From the left sidebar menu, choose Active Sessions. The Active Sessions page appears (see Figure 7-3).

![Figure 7-3 Active Sessions Page](image-url)
The user highlighted in red represents your current login. If a column heading is a hyperlink, click the heading to sort the list of active sessions in descending or ascending order along that column. The sort direction is toggled each time the hyperlink is clicked.

The Active Sessions page has the following columns:

- **IP/Host Name**: The IP address or the hostname of the machine on which the browser is running. If the hostname of the user machine is not in DNS, the IP address is displayed.
- **Login Time**: The time at which the user logged in to WCS. All times are based on the WCS server machine time.
- **Last Access Time**: The time at which the user last accessed WCS. All times are based on the WCS server machine time.

Note: The time displayed in this column is usually a few seconds behind the current system time because Last Access Time is updated frequently by the updates to the alarm status pane. However, if a user navigates to a non-WCS Navigator web page in the same browser, the disparity in time is greater upon returning to WCS Navigator. This disparity results because alarm counts are not updated while the browser is visiting non-WCS Navigator web pages.

- **Login Method**:
  - Web Service: Internal session needed by Navigator to manage WCS.
  - Regular: Sessions created for users who log into WCS directly through a browser.
  - Navigator Redirect: Sessions created for Navigator users who are redirected to WCS from Navigator.
- **User Groups**: The list of groups to which the user belongs. (North bound API is a user group used only with WCS Navigator.)
- **Audit trail icon**: Link to page that displays the audit trail (previous login times) for that user.

### Viewing or Editing User Account Information

To see the group the user is assigned to or to adjust a password or group assignment for that user, follow these steps:

**Step 1**  Choose **Administration > AAA**.
**Step 2**  From the left sidebar menu, choose **Users**.
**Step 3**  Click a user in the User Name column. The User Detail: **User Group** page appears (see **Figure 7-4**).
You can see which group is assigned to this user or change a password or group assignment.

**Setting the Lobby Ambassador Defaults**

If you choose a Lobby Ambassador from the User Name column, a Lobby Ambassador Defaults tab appears (see Figure 7-5). All of the guest user accounts created by the lobby ambassador have these credentials by default. If the default values are not specified, the lobby ambassador must provide the required guest user credential fields.

**Note**

If no default profile is chosen on this tab, the defaults do not get applied to this lobby ambassador. The lobby ambassador account does get created, and you can create users with any credentials you choose.
Managing WCS User Accounts

Figure 7-5  Lobby Ambassador Default Tab

Step 1  Use the Profile drop-down list to choose the guest user to connect to.

Wired-guest is an example of a profile that might be defined to indicate traffic that is originating from wired LAN ports. See the “Configuring Wired Guest Access” section on page 9-44.

Step 2  Choose a user role to manage the amount of bandwidth allocated to specific users within the network. They are predefined by the administrator and are associated with the guests’ access (such as contractor, customer, partner, vendor, visitor, and so on).

Step 3  Choose **Limited** or **Unlimited** at the Lifetime radio button.

- For the limited option, you choose the period of time that the guest user account is active using the hours and minutes drop-down lists. The default value for Limited is one day (8 hours).
- When *unlimited* is chosen, no expiration date for the guest account exists.

Step 4  Use the Apply to drop-down list to choose from the following options. What you choose determines what additional parameters appear.

- Indoor area—A campus, building, or floor.
- Outdoor area—A campus or outdoor area.
- Controller list—A list of controller(s) with the selected profile created.
- Config Group—Those config group names configured on WCS.
Step 5 Enter the e-mail ID of the host to whom the guest account credentials are sent.
Step 6 Provide a brief description of the account.
Step 7 If you want to supply disclaimer text, enter it.
   a. Select the **Defaults Editable** check box if you want to allow the lobby ambassador to override these configured defaults. This allows the Lobby Ambassadors to modify Guest User default settings while creating guest account from the Lobby Ambassador portal.

**Note** If no default profile is selected on this tab, the defaults are not applied to this Lobby Ambassador. However, the Lobby Ambassador account is created, and the Lobby Ambassador can create users with credentials as desired.

Step 8 Select the **Max User Creations Allowed** check box to set limits on the number of guest users that can be created by the lobby ambassador in a given time period. The time period is defined in hours, days, or weeks.

Step 9 Click the **Preview Current Logo** link to see what is currently being used as a logo, and then you can click to enable it or browse to another location to update the logo.

Step 10 If you want additional page header text, you can enter it at the Print Page Header Text parameter.

Step 11 Click **Submit**.

### Viewing or Editing Group Information

To see specific tasks the user is permitted to do within the defined group or make changes to the tasks, follow these steps:

**Step 1** Choose **Administration > AAA**.
**Step 2** Choose **Users** from the left sidebar menu.
**Step 3** Click the group link in the **Member Of** column. The Group Detail: **User Group** page appears (see Figure 7-6).

**Note** The detailed page varies based on what group you choose. **Figure 7-6** shows the detailed page of the superuser.
You can see the specific tasks the user is permitted to do within the defined group or make changes to the tasks.

**Editing the Guest User Credentials**

Click the WCS username of the guest user whose credentials you want to edit. The Lobby Ambassador Default tab appears, and you can modify the credentials.

**Note** While editing, if the *Profile* selection is removed (changed to *Select a profile*), the defaults are removed for this Lobby Ambassador. The user must reconfigure the defaults to reinforce them.

**Viewing the Audit Trail**

Click the *Audit Trail* icon in the Users page to view a log of authentication attempts. The Audit Trail page appears (see Figure 7-7).

This page enables you to view the following data:

- **User**: User login name
- **Operation**: Type of operation audited
- **Time**: Time operation was audited
Chapter 7  Managing WCS User Accounts

Viewing the Audit Trail

- Status: Success or failure
- Reason: Reason for the failure

Figure 7-7  Audit Trail

Creating Guest User Accounts

You can use the Cisco Lobby Ambassador to create guest user accounts in WCS. A guest network provided by an enterprise allows access to the Internet for a guest without compromising the host. The web authentication is provided with or without a supplicant or client, so a guest needs to initiate a VPN tunnel to their desired destinations.

Both wired and wireless guest user access is supported. Wired guest access enables guest users to connect to the guest access network from a wired Ethernet connection designated and configured for guest access. Wired guest access ports might be available in a guest office or specific ports in a conference room. Like wireless guest user accounts, wired guest access ports are added to the network using the lobby ambassador feature.

The network administrator must first set up a lobby ambassador account. Guest user accounts are for visitors, temporary workers, and so on, who need network access. A lobby ambassador account has limited configuration privileges and only allows access to the screens used to configure and manage guest user accounts.

The lobby ambassador can create the following types of guest user accounts:

- A guest user account with a limited lifetime. After the specified time period, the guest user account automatically expires.
- A guest user account with an unlimited lifetime. This account never expires.
Chapter 7  Managing WCS User Accounts

Viewing the Audit Trail

- A guest user account that is activated at a predefined time in the future. The lobby ambassador defines the beginning and end of the valid time period.

To create guest user accounts in WCS, follow these steps:

**Note** You should have SuperUser privilege (by default) to create a lobby ambassador account and not administration privileges. Multiple lobby ambassador accounts can be created by the administrator with varying profiles and permissions.

**Note** A root group, which is created during installation, has only one assigned user, and no additional users can be assigned after installation. This root user cannot be changed. Also, unlike a super user, no task changes are allowed.

**Step 1** Log into the WCS user interface as an administrator.

**Step 2** Choose Administration > AAA.

**Step 3** From the left sidebar menu, choose Users.

**Step 4** From the Select a command drop-down list, choose Add User, and click Go. The Users page appears.

**Step 5** Enter the username.

**Step 6** Enter the password. The minimum is six characters. Reenter and confirm the password.

**Note** The password must include at least three of the following four types of elements: lowercase letters, uppercase letters, numbers, and special characters.

**Step 7** In the Groups Assigned to this User section, select the LobbyAmbassador check box to access the Lobby Ambassador Defaults tab.

**Step 8** Follow the steps in the “Setting the Lobby Ambassador Defaults” section on page 7-7.

Logging in to the WCS User Interface as a Lobby Ambassador

When you log in as a lobby ambassador, you have access to the guest user template page in WCS. You can then configure guest user accounts (through templates).

To log into the WCS user interface through a web browser, follow these steps:

**Step 1** Launch Internet Explorer 7.0 or later on your computer.

**Note** Some WCS features may not function properly if you use a web browser other than Internet Explorer 7.0 or later on a Windows workstation.

**Step 2** In the browser’s address line, enter https://wcs-ip-address (such as https://1.1.1.1/login.html), where wcs-ip-address is the IP address of the computer on which WCS is installed. Your administrator can provide this IP address.
Step 3 When the WCS user interface displays the Login page, enter your username and password.

Note All entries are case sensitive.

Note The lobby ambassador can only define guest users templates.

Step 4 Click Submit to log into WCS. The WCS user interface is now active and available for use. The Guest Users page is displayed. This page provides a summary of all created Guest Users.

To exit the WCS user interface, close the browser page or click Logout in the upper right corner of the page. Exiting a WCS user interface session does not shut down WCS on the server.

Note When a system administrator stops the WCS server during a WCS session, the session ends, and the web browser displays this message: “The page cannot be displayed.” Your session does not reassociate to WCS when the server restarts. You must restart the WCS session.

Managing WCS Guest User Accounts

WCS guest user accounts are managed with the use of templates. This section describes how to manage WCS user accounts. It contains the following topics:

- Adding WCS Guest User Accounts (see the “Configuring a Guest User Template” section on page 11-63)
- Scheduling WCS Guest User Accounts, page 7-13
- Printing or E-mailing WCS Guest User Details, page 7-14
- Saving Guest Accounts on a Device, page 7-15

Scheduling WCS Guest User Accounts

A lobby ambassador is able to schedule automatic creation of a guest user account. The validity and recurrence of the account can be defined. The generation of a new password on every schedule is optional and is enabled using a check box. For scheduled users, the password is automatically generated and is automatically sent by e-mail to the host of the guest. The e-mail address for the host is configured on the New User page. After clicking Save, the Guest User Details page displays the password. From this page, you can e-mail or printer the account credentials.

To schedule a recurring guest user account in WCS, follow these steps:

Step 1 Log in to the WCS user interface as lobby ambassador.

Step 2 Choose Schedule Guest User from the Guest User page.

Note You can also schedule guest users from the Configure > Controller Template Launch Pad > Security > Guest User option.

Step 3 On the Guest Users > Scheduling page, enter the guest username. The maximum is 24 characters.
**Step 4** Select the check box to generate a username and password on every schedule. If this is enabled, a different password is supplied for each day (up to the number of days chosen). If this is disabled (unselected), one password is supplied for a span of days. The generation of a new password on every schedule is optional.

**Step 5** Select a Profile ID from the drop-down list. This is the SSID to which this guest user applies and must be a WLAN that has Layer 3 authentication policy configured. Your administrator can advise which Profile ID to use.

**Step 6** Enter a description of the guest user account.

**Step 7** Choose **limited** or **unlimited**.
- **Limited**—From the drop-down list, choose days, hours, or minutes for the lifetime of this guest user account. The maximum is 35 weeks.
  - **Start time**—Date and time when the guest user account begins.
  - **End time**—Date and time when the guest user account expires.
- **Unlimited**—This user account never expires.
- **Days of the week**—Select the check box for the days of the week that apply to this guest user account.

**Step 8** Choose **Apply To** to restrict a guest user to a confined area by selecting a campus, building, or floor so that when applied, only those controllers and associated access points are available. You can use AP grouping to enforce access point level restrictions that determine which SSIDs to broadcast. Those access points are then assigned to the respective floors. You can also restrict the guest user to specific listed controllers or a configuration group, which is a group of controllers that has been preconfigured by the administrator.

From the drop-down lists, choose one of the following:
- **Controller List**—Select the check box for the controller(s) to which the guest user account is associated.
- **Indoor Area**—Choose the applicable campus, building, and floor.
- **Outdoor Area**—Choose the applicable campus and outdoor area.
- **Config group**—Choose the configuration group to which the guest user account belongs.

**Step 9** Enter the e-mail address to send the guest user account credentials. Each time the scheduled time comes up, the guest user account credentials are e-mailed to the specified e-mail address.

**Step 10** Review the disclaimer information. Use the scroll bar to move up and down.

**Step 11** Click **Save** to save your changes or **Cancel** to leave the settings unchanged.

---

**Printing or E-mailing WCS Guest User Details**

The lobby ambassador can print or e-mail the guest user account details to the host or person who welcomes guests.

The e-mail and print copy shows the following details:
- **Username**—Guest user account name.
- **Password**—Password for the guest user account.
- **Start time**—Data and time when the guest user account begins.
Chapter 7  Managing WCS User Accounts

Adding a New User

- End time—Date and time when the guest user account expires.
- Profile ID—Profile assigned to the guest user. Your administrator can advise which Profile ID to use.
- Disclaimer—Disclaimer information for the guest user.

When creating the guest user account and applying the account to a list of controllers, area, or configuration group, a link is provided to e-mail or print the guest user account details. You can also print guest user account details from the Guest Users List page.

To print guest user details from the Guest Users List page, follow these steps:

| Step 1 | Log into the WCS user interface as lobby ambassador. |
| Step 2 | In the Guest User page, select the check box next to User Name, choose Print/E-mail User Details from the Select a command drop-down list, and click Go. |

- If printing, click Print and from the print page, select a printer, and click Print or Cancel.
- If e-mailing, click E-mail and from the e-mail page, enter the subject text and the recipient’s e-mail address. Click Send or Cancel.

Note You can also print or email user details from the Configure > Controller Template Launch Pad > Security > Guest User option.

Saving Guest Accounts on a Device

Select the Save Guest Accounts on Device check box to save guest accounts to a WLC flash so that they are maintained across WLC reboots.

Note In the Configure > Controller Template Launch Pad > Security > Guest page, you choose Save Guest Accounts on device from the Select a command drop-down list.

Editing the Guest User Credentials

Click the WCS username of the guest user whose credentials you want to edit. The Lobby Ambassador Default tab appears, and you can modify the credentials.

While editing, if the Profile selection is removed (changed to Select a profile), the defaults are removed for this Lobby Ambassador. The user must reconfigure the defaults to reinforce them.

Adding a New User

The Add User page allows the administrator to set up a new user login including username, password, groups assigned to the user, and virtual domains for the user.
Adding a New User

You can only assign virtual domains to a newly created user which you own. By assigning virtual domains to a user, the user is restricted to information applicable to those virtual domains.

You must have SuperUser status to access this page.

This section contains the following topics:
- Adding User Names, Passwords, and Groups, page 7-16
- Assigning a Virtual Domain, page 7-17

Adding User Names, Passwords, and Groups

To add a new user, follow these steps:

Step 1
Choose Administration > AAA.

Step 2
From the left sidebar menu, choose Users.

Step 3
From the Select a command drop-down list, choose Add User.

Step 4
Click Go. The Users page appears (see Figure 7-8).

Figure 7-8 Users Page

Step 5
Enter a new Username.

Step 6
Enter and confirm a password for this account.

Step 7
Select the check box(es) of the groups to which this user will be assigned.

Note
If the user belongs to Lobby Ambassador, Monitor Lite, Northbound API, or Users Assistant group, the user cannot belong to any other group.

- Admin—Allows users to monitor and configure WCS operations and perform all system administration tasks except administering WCS user accounts and passwords.
- ConfigManagers—Allows users to monitor and configure WCS operations.
Chapter 7  Managing WCS User Accounts

Adding a New User

- System Monitoring—Allows users to monitor WCS operations.
- Users Assistant—Allows local net user administration only.
- Lobby Ambassador—Allows guest access for configuration and management only of user accounts. If Lobby Ambassador is selected, a Lobby Ambassador Defaults tab appears.
- Monitor Lite—Allows monitoring of assets location.
- North Bound API User—A user group used only with WCS Navigator and WCS Web Service consumers.

Note
North Bound API Users cannot be assigned a Virtual Domain. When a North Bound API group is selected, the Virtual Domains tab is not available.

- SuperUsers—Allows users to monitor and configure WCS operations and perform all system administration tasks including administering WCS user accounts and passwords. Superuser tasks can be changed.
- Root—This group is only assignable to ‘root’ user and that assignment cannot be changed.
- User Defined.

Assigning a Virtual Domain

To assign a virtual domain to this user, follow these steps:

Step 1
Click the Virtual Domains tab. This tab displays all virtual domains available and assigned to this user (see Figure 7-9).
Chapter 7  Managing WCS User Accounts

Adding a New User

Figure 7-9  Users Virtual Domains Tab

<table>
<thead>
<tr>
<th>Available Virtual Domains</th>
<th>Selected Virtual Domains</th>
</tr>
</thead>
<tbody>
<tr>
<td>Root</td>
<td></td>
</tr>
<tr>
<td>Test</td>
<td></td>
</tr>
<tr>
<td>Ash, Inc.</td>
<td></td>
</tr>
<tr>
<td>Sites</td>
<td></td>
</tr>
</tbody>
</table>

Note  The Virtual Domains tab enables the administrator to assign virtual domains for each user. By assigning virtual domains to a user, the user is restricted to information applicable to those virtual domains.

Note  North Bound API Users cannot be assigned a Virtual Domain. When a North Bound API group is selected, the Virtual Domains tab is not available.

Step 2  Click to highlight the virtual domain in the Available Virtual Domains list that you want to assign to this user.

Note  You can select more than one virtual domain by holding down the Shift or Control key.

Step 3  Click Add >. The virtual domain moves from the Available Virtual Domains to the Selected Virtual Domains list.
Managing Lobby Ambassador Accounts

You can use the Cisco Lobby Ambassador to create guest user accounts in WCS. A guest network provided by an enterprise allows access to the Internet for a guest without compromising the host. The web authentication is provided with or without a supplicant or client, so a guest needs to initiate a VPN tunnel to their desired destinations.

Both wired and wireless guest user access is supported. Wired guest access enables guest users to connect to the guest access network from a wired Ethernet connection designated and configured for guest access. Wired guest access ports might be available in a guest office or specific ports in a conference room. Like wireless guest user accounts, wired guest access ports are added to the network using the lobby ambassador feature.

The network administrator must first set up a lobby ambassador account. Guest user accounts are for visitors, temporary workers, and so on, who need network access. A lobby ambassador account has limited configuration privileges and only allows access to the pages used to configure and manage guest user accounts.

The lobby ambassador can create the following types of guest user accounts:

- A guest user account with a limited lifetime. After the specified time period, the guest user account automatically expires.
- A guest user account with an unlimited lifetime. This account never expires.
- A guest user account that is activated at a predefined time in the future. The lobby ambassador defines the beginning and end of the valid time period.

This section contains the following topics:

- Creating a Lobby Ambassador Account, page 7-19
- Editing a Lobby Ambassador Account, page 7-21
- Logging in to the WCS User Interface as a Lobby Ambassador, page 7-21
- Logging the Lobby Ambassador Activities, page 7-22

Creating a Lobby Ambassador Account

Note

You should have SuperUser privileges (by default) to create a lobby ambassador account and not Admin privileges.

To create a lobby ambassador account in WCS, follow these steps:

Step 1
Log into the WCS user interface as an administrator.

Step 2
Choose Administration > AAA.
Step 3  From the left sidebar menu, choose **Users**.
Step 4  From the Select a command drop-down list, choose **Add User**.
Step 5  Click **Go**.
Step 6  Enter the username.
Step 7  Enter the password. Reenter to confirm the password. Password requirements include the following:
  - The password must have a minimum of eight characters.
  - The password must include at least three of the following elements: lowercase letters, uppercase letters, numbers, or special characters.
Step 8  In the Groups Assigned to this User section, select the LobbyAmbassador check box to access the Lobby Ambassador Defaults tab.

The Lobby Ambassador Defaults tab has the following parameters:
  - **Profile**—The default profile to which the guest users would connect.
  - **Lifetime**—Limited or Unlimited.

**Note** By default, the lifetime is limited to eight hours.

  - **Apply to**—From the drop-down list, choose one of the following:
    - Indoor Area—Campus, Building, and Floor.
    - Outdoor Area—Campus, Outdoor Area.
    - Controller List—List of controller(s) on which the selected profile is created.
    - Config Groups—Config group names configured on WCS.
  - **Email ID**—The email ID of the host to whom the guest account credentials are sent.
  - **Description**—A brief description of this account.
  - **Disclaimer**—The default disclaimer text.
  - **Defaults Editable**—Select this check box if you want to allow the lobby ambassador to override these configured defaults. This allows the lobby ambassador to modify these Guest User Account default settings while creating Guest Accounts from the Lobby Ambassador portal.

**Note** If no default profile is selected on this tab, the defaults are not applied to this Lobby Ambassador. However, the Lobby Ambassador account is created and the Lobby Ambassador can create users with credentials as desired.

  - **Max User Creation Allowed**—Select this check box to set limits on the number of guest users that can be created by the Lobby Ambassador in a given time period. The time period is defined in hours, days, or weeks.
  - **Click Submit**. The name of the new lobby ambassador account is listed and the account can be used immediately.
Chapter 7      Managing WCS User Accounts

Managing Lobby Ambassador Accounts

Editing a Lobby Ambassador Account

The Lobby Ambassador default credentials can be edited from the username link on the WCS user list page.

To edit the Lobby Ambassador default credentials, follow these steps:

Step 1 Log into the WCS user interface as an administrator.
Step 2 Choose Administration > AAA.
Step 3 From the left sidebar menu, choose Users.
Step 4 Click the applicable Lobby Ambassador account from the User Name column.
Step 5 From the Lobby Ambassador Defaults page, edit the credentials as necessary.

Note While editing, if the Profile selection is removed (changed to Select a profile), the defaults are removed for this Lobby Ambassador. The user must reconfigure the defaults to reinforce them.

Step 6 Click Submit.

Logging into the WCS User Interface as a Lobby Ambassador

When you log in as a lobby ambassador, you have access to the guest user template page in WCS. You can then configure guest user accounts (through templates).

To log into the WCS user interface through a web browser, follow these steps:

Step 1 Launch Internet Explorer 7.0 or later on your computer.

Note Some WCS features may not function properly if you use a web browser other than Internet Explorer 7.0 or later on a Windows workstation.

Step 2 In the browser address line, enter https://wcs-ip-address (such as https://1.1.1.1/login.html), where wcs-ip-address is the IP address of the computer on which WCS is installed. Your administrator can provide this IP address.

Step 3 When the WCS user interface displays the Login window, enter your username and password.

Note All entries are case sensitive.

Note The lobby ambassador can only define guest users templates.

Step 4 Click Submit to log into WCS. The WCS user interface is now active and available for use. The Guest Users page is displayed. This page provides a summary of all created Guest Users.
To exit the WCS user interface, close the browser window or click **Logout** in the upper right corner of the page. Exiting a WCS user interface session does not shut down WCS on the server.

---

**Note**

When a system administrator stops the WCS server during a WCS session, the session ends, and the web browser displays this message: “The page cannot be displayed.” Your session does not reassociate to WCS when the server restarts. You must restart the WCS session.

---

### Logging the Lobby Ambassador Activities

The following activities are logged for each lobby ambassador account:

- Lobby ambassador login—WCS logs the authentication operation results for all users.
- Guest user creation—When a lobby ambassador creates a guest user account, WCS logs the guest username.
- Guest user deletion—When a lobby ambassador deletes the guest user account, WCS logs the deleted guest username.
- Account updates—WCS logs the details of any updates made to the guest user account. For example, increasing the life time.

Follow these steps to view the lobby ambassador activities.

---

**Note**

You must have superuser status to open this window.

---

**Step 1**
Log into the Navigator or WCS user interface as an administrator.

**Step 2**
Choose **Administration > AAA > Groups** from the left sidebar menu to display the All Groups page.

**Step 3**
On the All Groups page, click the **Audit Trail** icon for the lobby ambassador account you want to view. The Audit Trail page for the lobby ambassador appears.

This page enables you to view a list of lobby ambassador activities over time.

- **User**—User login name
- **Operation**—Type of operation audited
- **Time**—Time operation was audited
- **Status**—Success or failure

**Step 4**
To clear the audit trail, choose **Clear Audit Trail** from the Select a command drop-down list, and click **Go**.
Configuring Mobility Groups

This chapter describes mobility groups and explains how to configure them on Cisco WCS. It contains the following sections:

- Information About Mobility, page 8-1
- Symmetric Tunneling, page 8-5
- Overview of Mobility Groups, page 8-5
- Configuring Mobility Groups, page 8-8
- Mobility Anchors, page 8-13
- Configuring Multiple Country Codes, page 8-16
- Configuring Controller Config Groups, page 8-19
- Reporting Config Groups, page 8-26
- Downloading Software, page 8-26

Information About Mobility

Mobility, or roaming, is a wireless LAN client’s ability to maintain its association seamlessly from one access point to another securely and with as little latency as possible. This section explains how mobility works when controllers are included in a wireless network.

When a wireless client associates and authenticates to an access point, the access point’s controller places an entry for that client in its client database. This entry includes the client’s MAC and IP addresses, security context and associations, quality of service (QoS) contexts, the WLANs, and the associated access point. The controller uses this information to forward frames and manage traffic to and from the wireless client. Figure 8-1 illustrates a wireless client roaming from one access point to another when both access points are joined to the same controller.
Figure 8-1  
**Intra-Controller Roaming**

When the wireless client moves its association from one access point to another, the controller simply updates the client database with the newly associated access point. If necessary, new security context and associations are established as well.

The process becomes more complicated, however, when a client roams from an access point joined to one controller to an access point joined to a different controller. The process also varies based on whether the controllers are operating on the same subnet. **Figure 8-2** illustrates inter-controller roaming, which occurs when the controllers’ wireless LAN interfaces are on the same IP subnet.
When the client associates to an access point joined to a new controller, the new controller exchanges mobility messages with the original controller, and the client database entry is moved to the new controller. New security context and associations are established if necessary, and the client database entry is updated for the new access point. This process remains invisible to the user.

**Note**

All clients configured with 802.1X/Wi-Fi Protected Access (WPA) security complete a full authentication to comply with the IEEE standard.

Figure 8-3 illustrates *inter-subnet roaming*, which occurs when the controllers’ wireless LAN interfaces are on different IP subnets.
Inter-subnet roaming is similar to inter-controller roaming in that the controllers exchange mobility messages on how the client roams. However, instead of moving the client database entry to the new controller, the original controller marks the client with an “Anchor” entry in its own client database. The database entry is copied to the new controller client database and marked with a “Foreign” entry in the new controller. The roam remains invisible to the wireless client, and the client maintains its original IP address.

After an inter-subnet roam, data flows in an asymmetric traffic path to and from the wireless client. Traffic from the client to the network is forwarded directly into the network by the foreign controller. Traffic to the client arrives at the anchor controller, which forwards the traffic to the foreign controller in an EtherIP tunnel. The foreign controller then forwards the data to the client. If a wireless client roams to a new foreign controller, the client database entry is moved from the original foreign controller to the new foreign controller, but the original anchor controller is always maintained. If the client moves back to the original controller, it becomes local again.

In inter-subnet roaming, WLANs on both anchor and foreign controllers need to have the same network access privileges and no source-based routing or source-based firewalls in place. Otherwise, the clients may have network connectivity problems after the handoff.

**Note**
Currently, multicast traffic cannot be passed during inter-subnet roaming. In other words, avoid designing an inter-subnet network for Spectralink phones that need to send multicast traffic while using push to talk.

**Note**
Both inter-controller roaming and inter-subnet roaming require the controllers to be in the same mobility group. See the next two sections for a description of mobility groups and instructions for configuring them.
Symmetric Tunneling

With symmetric mobility tunneling, the controller provides inter-subnet mobility for clients roaming from one access point to another within a wireless LAN. The client traffic on the wired network is directly routed by the foreign controller. If a router has reverse path filtering (RPF) enabled (which provides additional checks on incoming packets), the communication is blocked. Symmetric mobility tunneling allows the client traffic to reach the controller designated as the anchor, even with RPF enabled. You enable or disable symmetric tunneling by choosing Configure > Controller and then System > General from the left sidebar menu.

Note  
All controllers in a mobility group should have the same symmetric tunneling mode.

Note  
For symmetric tunneling to take effect, a reboot is required.

With this guest tunneling N+1 redundancy feature, the time it takes for a client to join another access point following a controller failure is decreased because a failure is quickly identified, the clients are moved away from the problem controller, and the clients are anchored to another controller.

See the “Configuring Controller Templates” section on page 11-3 for instructions on configuring this feature within a template.

Overview of Mobility Groups

A set of controllers can be configured as a mobility group to allow seamless client roaming within a group of controllers. By creating a mobility group, you can enable multiple controllers in a network to dynamically share information and forward data traffic when inter-controller or inter-subnet roaming occurs. Controllers can share the context and state of client devices and controller loading information. With this information, the network can support inter-controller wireless LAN roaming and controller redundancy.

Note  
Clients do not roam across mobility groups.

Figure 8-4 shows an example of a mobility group.
Overview of Mobility Groups

Figure 8-4  A Single Mobility Group

As shown in Figure 8-4, each controller is configured with a list of the other members of the mobility group. Whenever a new client joins a controller, the controller sends out a unicast message to all of the controllers in the mobility group. The controller to which the client was previously connected passes on the status of the client. All mobility exchange traffic between controllers is carried over a CAPWAP tunnel.

Examples:

1. A 4404-100 controller supports up to 100 access points. Therefore, a mobility group consisting of 24 4404-100 controllers supports up to 2400 access points (24 * 100 = 2400 access points).

2. A 4402-25 controller supports up to 25 access points, and a 4402-50 controller supports up to 50 access points. Therefore, a mobility group consisting of 12 4402-25 controllers and 12 4402-50 controllers supports up to 900 access points (12 * 25 + 12 * 50 = 300 + 600 = 900 access points).

Mobility groups enable you to limit roaming between different floors, buildings, or campuses in the same enterprise by assigning different mobility group names to different controllers within the same wireless network. Figure 8-5 shows the results of creating distinct mobility group names for two groups of controllers.
Chapter 8 Configuring Mobility Groups

Overview of Mobility Groups

Figure 8-5 Two Mobility Groups

The controllers in the ABC mobility group recognize and communicate with each other through their access points and through their shared subnets. The controllers in the ABC mobility group do not recognize or communicate with the XYZ controllers, which are in a different mobility group. Likewise, the controllers in the XYZ mobility group do not recognize or communicate with the controllers in the ABC mobility group. This feature ensures mobility group isolation across the network.

Note
Clients may roam between access points in different mobility groups, provided they can detect them. However, their session information is not carried between controllers in different mobility groups.

When to Include Controllers in a Mobility Group

If it is possible for a wireless client in your network to roam from an access point joined to one controller to an access point joined to another controller, both controllers should be in the same mobility group.

Messaging among Mobility Groups

The controller provides inter-subnet mobility for clients by sending mobility messages to other member controllers. There can be up to 72 members in the list with up to 24 in the same mobility group. In WCS and controller software releases 5.0, two improvements have been made to mobility messaging, each of which is especially useful when sending messages to the full list of mobility members:
• Sending Mobile Announce messages within the same group first and then to other groups in the list

The controller sends a Mobile Announce message to members in the mobility list each time a new client associates to it. In WCS and controller software releases prior to 5.0, the controller sends this message to all members in the list irrespective of the group to which they belong. However, in controller software release 5.0, the controller sends the message only to those members that are in the same group as the controller and then includes all of the other members while sending retries.

• Sending Mobile Announce messages using multicast instead of unicast

In WCS and controller software releases prior to 5.0, the controller may be configured to use multicast to send the mobile announce messages, which requires sending a copy of the messages to every mobility member. This behavior is not efficient because many messages (such as Mobile Announce, PMK Update, AP List Update, and IDS Shun) are meant for all members in the group. In WCS and controller software releases 5.0, the controller uses multicast mode to send the Mobile Announce messages. This behavior allows the controller to send only one copy of the message to the network, which destines it to the multicast group containing all the mobility members. To derive the maximum benefit from multicast messaging, we recommend that it be enabled or disabled on all group members.

Configuring Mobility Groups

This section provides instructions for configuring mobility groups.

Note
You can also configure mobility groups using the controller. See the Cisco Wireless LAN Controller Configuration Guide for instructions.

Prerequisites

Before you add controllers to a mobility group, you must verify that the following requirements have been met for all controllers that are to be included in the group:

• All controllers must be configured for the same LWAPP transport mode (Layer 2 or Layer 3).

Note
You can verify and, if necessary, change the LWAPP transport mode in the System > General page.

• IP connectivity must exist between the management interfaces of all devices.

Note
You can verify IP connectivity by pinging the controllers.

• All controllers must be configured with the same mobility group name.

Note
For the Cisco WiSM, both controllers should be configured with the same mobility group name for seamless routing among 300 access points.

• All devices must be configured with the same virtual interface IP address.
If all the controllers within a mobility group are not using the same virtual interface, inter-controller roaming may appear to work, but the hand-off does not complete, and the client loses connectivity for a period of time.

- You must have gathered the MAC address and IP address of every controller that is to be included in the mobility group. This information is necessary because you will be configuring all controllers with the MAC address and IP address of all the other mobility group members.

You can find the MAC and IP addresses of the other controllers to be included in the mobility group in the Configure > Controllers page.

To add each WLC controller into mobility groups and configure them, follow these steps:

**Step 1**
Choose Configure > Controllers (see Figure 8-6).

**Figure 8-6 Configure > Controllers**

This page shows the list of all the controllers you added in Step 1. The mobility group names and the IP address of each controller that is currently a member of the mobility group is listed.

**Step 2**
Choose the first controller by clicking on the WLC IP address. You will then access the controller templates interface for the controller you are managing.

**Step 3**
Choose System > Mobility Groups from the left sidebar menu. The existing Mobility Group members are listed in the page (see Figure 8-7).
Chapter 8  Configuring Mobility Groups

Figure 8-7  Existing Mobility Groups

Step 4  You will see a list of available controllers. From the Select a command drop-down list in the upper right-hand corner, choose Add Group Members and then click Go.

Step 5  If no controllers were found to add to the mobility group, you can add the members manually by clicking the “To add members manually to the Mobility Group click here” message. The Mobility Group Member page appears (see Figure 8-8).
Step 6  In the Member MAC Address text box, enter the MAC address of the controller to be added.

Step 7  In the Member IP Address text box, enter the management interface IP address of the controller to be added.

**Note**  If you are configuring the mobility group in a network where Network Address Translation (NAT) is enabled, enter the IP address sent to the controller from the NAT device rather than the controller’s management interface IP address. Otherwise, mobility will fail among controllers in the mobility group.

Step 8  Enter the multicast group IP address to be used for multicast mobility messages in the Multicast Address text box. The local mobility member’s group address must be the same as the local controller’s group address.

Step 9  In the Group Name text box, enter the name of the mobility group.

Step 10  Click **Save**.

Step 11  Repeat the steps 1 through 9 for the remaining WLC devices.
Setting the Mobility Scalability Parameters

To set the mobility message parameters, follow these steps:

**Note** You must complete the steps in the “Configuring Mobility Groups” section on page 8-8 prior to setting the mobility scalability parameters.

**Step 1** Choose Configure > Controllers.

**Step 2** Choose an IP address of a controller whose software version is 5.0 or later.

**Step 3** Choose System > Multicast from the left sidebar menu. The Multicast page appears (see Figure 8-9).

**Figure 8-9 Multicast Page**

- **Step 4** At the Ethernet Multicast Support parameter, specify if you want to disable the ability for the controller to use multicast mode to send Mobile Announce messages to mobility members. Otherwise, you can choose Multicast or Unicast.

- **Step 5** If you chose multicast in Step 4, you must enter the group IP address at the Multicast Group Address parameter to begin multicast mobility messaging. You must configure this IP address for the local mobility group, but it is optional for other groups within the mobility list. If you do not configure the IP address for other (non-local) groups, the controllers use unicast mode to send mobility messages to those members.

- **Step 6** Select the Enable Global Multicast Mode check box to make the multicast mode available globally.

- **Step 7** Select the Enable IGMP Snooping check box to enable IGMP snooping.
Step 8  Select **Enable** from the Multicast Mobility Mode drop-down list to change the IGMP snooping status or to set the IGMP timeout. When IGMP snooping is enabled, the controller gathers IGMP reports from the clients and then sends each access point a list of the clients listening to any multicast group. The access point then forwards the multicast packets only to those clients.

The timeout interval has a range of 3 to 300 and a default value of 60. When the timeout expires, the controller sends a query to all WLANs. Those clients which are listening in the multicast group then send a packet back to the controller.

Step 9  If you enabled the Multicast Mobility Mode, enter the mobility group multicast address.

Step 10  Select the **Multicast Direct** check box to enable videos to be streamed over a wireless network.

Step 11  Specify the Session Banner information, which is the error information sent to the client if the client is denied or dropped from a Media Stream.

- **State**—Select the check box to activate the Session Banner. If not activated, the Session Banner is not sent to the client.
- **URL**—A web address reported to the client
- **Email**—An email address reported to the client
- **Phone**—A telephone number reported to the client
- **Note**—A note reported to the client

**Note**  All Media Streams on a Controller share this configuration.

Step 12  Click **Save**.

---

### Mobility Anchors

Mobility anchors are a subset of a mobility group specified as the anchor controllers for a WLAN. This feature can be used to restrict a WLAN to a single subnet, regardless of the client’s entry point into the network. In this way, users can access a public or guest WLAN throughout an enterprise but still be restricted to a specific subnet. Guest WLAN can also be used to provide geographic load balancing because WLANs can represent a particular section of a building (such as a lobby, a restaurant, and so on).

When a client first associates to a controller of a mobility group that has been preconfigured as a mobility anchor for a WLAN, the client associates to the controller locally, and a local session is created for the client. Clients can be anchored only to preconfigured anchor controllers of the WLAN. For a given WLAN, you should configure the same set of anchor controllers on all controllers in the mobility group.

When a client first associates to a controller of a mobility group that has not been configured as a mobility anchor for a WLAN, the client associates to the controller locally, a local session is created for the client, and the controller is announced to the other controllers in the same mobility group. If the announcement is not answered, the controller contacts one of the anchor controllers configured for the WLAN and creates a foreign session for the client on the local switch. Packets from the client are encapsulated through a mobility tunnel using EtherIP and sent to the anchor controller, where they are decapsulated and delivered to the wired network. Packets to the client are received by the anchor controller and forwarded to the foreign controller through a mobility tunnel using EtherIP. The foreign controller decapsulates the packets and forwards them to the client.
A 2000 series controller cannot be designated as an anchor for a WLAN. However, a WLAN created on a 2000 series controller can have a 4100 series controller or a 4400 series controller as its anchor.

The L2TP Layer 3 security policies are unavailable for WLANs configured with a mobility anchor.

## Configuring Mobility Anchors

To create a new mobility anchor for a WLAN, follow these steps:

### Step 1
Click **Configure > Controllers**.

### Step 2
Choose a controller by clicking an IP address.

### Step 3
Choose **WLANs > WLAN Configuration** from the left sidebar menu.

### Step 4
Select the check box of the desired WLAN ID URL (see Figure 8-10).

### Step 5
After choosing a WLAN ID, a tabbed page appears (see Figure 8-11). Click the **Advanced** tab.
Step 6  Click the Mobility Anchors link at the bottom of the page. The Mobility Anchors page appears (see Figure 8-12).
Step 7  Select the IP address check box of the controller to be designated a mobility anchor, and click Save.

Step 8  Repeat Step 6 and Step 7 to set any other controllers as anchors for this WLAN.

Step 9  Configure the same set of anchor controllers on every controller in the mobility group.

Configuring Multiple Country Codes

You can configure one or more countries on a controller. After countries are configured on a controller, the corresponding 802.11a/n DCA channels are available for selection. At least one DCA channel must be selected for the 802.11a/n network. When the country codes are changed, the DCA channels are automatically changed in coordination.

Note  802.11a/n and 802.11b/n networks for controllers and access points must be disabled before configuring a country on a controller. To disable 802.11a/n or 802.11b/n networks, choose Configure > Controllers, select the desired controller you want to disable, choose 802.11a/n or 802.11b/g/n from the left sidebar menu, and then choose Parameters. The Network Status is the first check box.

Note  To configure multiple country codes outside of a mobility group, refer to the “Configuring Security Parameters” section on page 9-82.

To add multiple controllers that are defined in a configuration group and then set the DCA channels, follow these steps:

Step 1  Choose Configure > Controller Config Groups.
Step 2  Choose **Add Config Groups** from the Select a command drop-down list, and click **Go**.

Step 3  Create a config group by entering the group name and mobility group name.

Step 4  Click **Save**. The Config Groups page appears (see **Figure 8-13**).

**Figure 8-13  Config Groups Page**

- **Group Name**: sb-lab
- **Mobility Group Name**: sb
- **Last Modified on**: 2/16/00 3:46 PM
- **Last Applied on**: 2/16/00 3:46 PM

**Footnotes:***

1. To enable please set template based audit in Audit settings page under Administration menu.
2. Only when the user invokes apply action, the specified mobility group name will get set on the group controllers and mobility group members will be created on each of the group controllers.
3. All the group templates gets applied to each of the group controllers only when user invokes apply action.
4. After invoking any of the operation Apply, Audit or Reboot, user can leave this screen or even logout of WCS. The process will continue and user can return later to this screen to view the report.
5. A controller cannot be a member of more than one mobility group. Adding a controller to one mobility group will remove the controller from other mobility groups.
6. Enabling the background audit will make sure all the templates part of this group will be audited against the specified controller(s) during network and controller audit. And enable Enforcement selection will allow user to automatically apply the templates during audit.

Step 5  Click the **Controllers** tab. The Controllers page appears (see **Figure 8-14**).
Chapter 8 Configuring Mobility Groups

Configuring Multiple Country Codes

Figure 8-14 Controller Tab

Step 6 Highlight the controllers you want to add, and click the Add button. The controller is added to the Group Controllers page.

Step 7 Click the Country/DCA tab. The Country/DCA page appears (see Figure 8-15). Dynamic Channel Allocation (DCA) automatically selects a reasonably good channel allocation amongst a set of managed devices connected to the controller.
Step 8 Select the **Update Countries/DCA** check box to display a list of countries from which to choose.

Step 9 Those DCA channels that are currently configured on the controller for the same mobility group are displayed in the Select Country Codes page. The corresponding 802.11a/n and 802.11b/n allowable channels for the chosen country is displayed as well. You can add or delete any channels in the list by selecting or deselecting the channel and clicking **Save Selection**.

**Note** A minimum of 1 and a maximum of 20 countries can be configured for a controller.

### Configuring Controller Config Groups

By creating a config group, you can group controllers that should have the same mobility group name and similar configuration. You can assign templates to the group and push templates to all the controllers in a group. You can add, delete, or remove config groups, and download software, IDS signatures, or a customized web authentication page to controllers in the selected config groups. You can also save the current configuration to nonvolatile (flash) memory to controllers in selected config groups.
Chapter 8  Configuring Mobility Groups

Configuring Controller Config Groups

A controller cannot be a member of more than one mobility group. Adding a controller to one mobility group removes that controller from any other mobility group to which it is already a member.

For information about applying templates to either individual controllers or controllers in selected Config Groups, see the “Using Templates” section on page 11-1.

By choosing Configure > Controller Config Groups, you can view a summary of all config groups in the Cisco WCS database. When you choose Add Config Groups from the Select a command drop-down list, the page displays a table with the following columns:

- Group Name: Name of the config group.
- Templates: Number of templates applied to config group.

Adding New Group

To add a config group, follow these steps:

**Step 1** Choose Configure > Controller Config Groups.

**Step 2** From the Select a command drop-down list, choose Add Config Group, and click Go. The Add New Group page appears.

**Step 3** Enter the new config group name. It must be unique across all groups. If Enable Background Audit is selected, the network and controller audits occur for this config group. If Enable Enforcement is selected, the templates are automatically applied during the audit if any discrepancies are found.

**Note** If the Enable Background Audit option is chosen, the network and controller audit is performed on this config group.

**Step 4** Other templates created in WCS can be assigned to a config group. The same WLAN template can be assigned to more than one config group. Choose from the following:

- Select and add later: Click to add template at a later time.
- Copy templates from a controller: Click to copy templates from another controller. Choose a controller from a list of current controllers to copy its applied template to the new config group. Only the templates are copied.

**Note** The order of the templates is important when dealing with radio templates. For example, if the template list includes radio templates that require the radio network to be disabled prior to applying the radio parameters, the template to disable the radio network must be added to the template first.

**Step 5** Click Save. The Config Groups page appears (see Figure 8-16).
To configure a config group, follow these steps:

**Step 1** Choose **Configure > Controller Config Groups**, and click a group name under the Group Name column. The Config Group page shown in **Figure 8-16** appears.

**Step 2** Click the **General** tab. The following options for the config group appear:

- **Group Name**: Name of the config group
  - **Enable Background Audit**—If selected, all the templates that are part of this group are audited against the controller during network and controller audits.
  - **Enable Enforcement**—If selected, the templates are automatically applied during the audit if any discrepancies are found.

**Note**

The audit and enforcement of the config group template happens when the selected audit mode is **Template based audit**.
- Enable Mobility Group—If selected, the mobility group name is pushed to all controllers in the group.

- Mobility Group Name: Mobility Group Name that is pushed to all controllers in the group. The Mobility Group Name can also be modified here.

**Note** A controller can be part of multiple config groups.

- Last Modified On: Date and time config group was last modified.
- Last Applied On: Date and time last changes were applied.

**Step 3** You must click the **Apply/Schedule** tab to distribute the specified mobility group name to the group controllers and to create mobility group members on each of the group controllers.

**Step 4** Click **Save**.

---

### Adding or Removing Controllers from a Config Group

To add or remove controllers from a config group, follow these steps:

**Step 1** Choose **Configure > Controller Config Groups**, and click a group name under the Group Name column.

**Step 2** Click the **Controllers** tab. The columns in the table display the IP address of the controller, the config group name the controller belongs to, and the controller’s mobility group name.

**Step 3** Click to highlight the row of the controller you want to add to the group.

**Step 4** Click **Add**.

**Note** If you want to remove a controller from the group, highlight the controller in the Group Controllers box and click **Remove**.

**Step 5** You must click the **Apply/Schedule** tab, and click **Apply** to add or remove the controllers to the config groups.

**Step 6** Click **Save Selection**.
Adding or Removing Templates from the Config Group

To add or remove templates from the config group, follow these steps:

**Step 1** Choose **Configure > Controller Config Groups**, and click a group name under the Group Name column.

**Step 2** Click the **Templates** tab. The Remaining Templates table displays the item number of all available templates, the template name, and the type and use of the template.

**Step 3** Click to highlight the row of the template you want to add to the group.

**Step 4** Click **Add** to move the highlighted template to the Group Templates column.

*Note* If you want to remove a template from the group, highlight the template in the Remaining Templates box and click the **Remove** button.

**Step 5** You must click the **Apply/Schedule** tab and click **Apply** to add or remove the templates to the config groups.

**Step 6** Click **Save Selection**.

Applying or Scheduling Config Groups

*Note* The scheduling function allows you to schedule a start day and time for provisioning.

To apply the mobility groups, mobility members, and templates to all the controllers in a config group, follow these steps:

**Step 1** Choose **Configure > Controller Config Groups**, and click a group name in the Group Name column.

**Step 2** Click the **Apply/Schedule** tab to access this page.

**Step 3** Click **Apply** to start the provisioning of mobility groups, mobility members, and templates to all the controllers in the config group. After you apply, you can leave this page or log out of Cisco WCS. The process continues, and you can return later to this page to view a report.

*Note* Do not perform any other config group functions during the apply provisioning.

A report is generated and appears in the Recent Apply Report page. It shows which mobility group, mobility member, or template were successfully applied to each of the controllers.

*Note* If you want to print the report as shown on the page, you must choose landscape page orientation.

**Step 4** Enter a starting date in the text box or use the calendar icon to choose a start date.

**Step 5** Choose the starting time using the hours and minutes drop-down lists.
Step 6  Click Schedule to start the provisioning at the scheduled time.

Auditing Config Groups

The Config Groups Audit page allows you to verify if the controller’s configuration complies with the

group templates and mobility group. During the audit, you can leave this screen or logout of Cisco WCS.
The process continues, and you can return to this page later to view a report.

Note  Do not perform any other config group functions during the audit verification.

To perform a config group audit, follow these steps:

Step 1  Choose Configure > Controller Config Groups, and click a group name under the Group Name
column.

Step 2  Click the Audit tab to access this page.

Step 3  Click to highlight a controller from the Controllers tab, choose >> (Add), and Save Selection.

Step 4  Click to highlight a template from the Templates tab, choose >> (Add), and Save Selection.

Step 5  Click Audit to begin the auditing process (see Figure 8-17).

A report is generated and the current configuration on each controller is compared with that in the config
group templates. The report displays the audit status, the number of templates in sync, and the number
of templates out of sync.

Note  This audit does not enforce the WCS configuration to the device. It only identifies the
discrepancies.

Figure 8-17  Config Groups Audit Tab
Step 6  Click Details to view the Controller Audit Report details (see Figure 8-18).

**Figure 8-18  Controller Audit Report Details**

![Controller Audit Report Details](image)

Step 7  Double-click a line item to open the Attribute Differences page. This page displays the attribute, its value in WCS, and its value in the controller.

**Note**  Click Retain WCS Value to push all attributes in the Attribute Differences page to the device.

Step 8  Click Close to return to the Controller Audit Report page.

---

**Rebooting Config Groups**

To reboot a config group, follow these steps:

Step 1  Choose Configure > Controller Config Groups, and click a group name under the Group Name column.

Step 2  Click the Reboot tab.

Step 3  Select the Cascade Reboot check box if you want to reboot one controller at a time, waiting for that controller to come up before rebooting the next controller.

Step 4  Click Reboot to reboot all controllers in the config group at the same time. During the reboot, you can leave this page or logout of Cisco WCS. The process continues, and you can return later to this page and view a report.

The Recent Reboot Report page shows when each controller was rebooted and what the controller status is after the reboot. If WCS is unable to reboot the controller, a failure is shown.
Reporting Config Groups

To display all recently applied reports under a specified group name, follow these steps:

**Step 1** Choose Configure > Controller Config Groups, and click a group name under the Group Name column.

**Step 2** Click the Report tab. The Recent Apply Report page displays all recently applied reports including the apply status, the date and time the apply was initiated, and the number of templates. The following information is provided for each individual IP address:

- Apply Status—Indicates success, partial success, failure, or not initiated.
- Successful Templates—Indicates the number of successful templates associated with the applicable IP address.
- Failures—Indicates the number of failures with the provisioning of mobility group, mobility members, and templates to the applicable controller.
- Details—Click Details to view the individual failures and associated error messages.

**Step 3** If you want to view the scheduled task reports, click the click here link at the bottom of the page. You are then redirected to the Configure > Scheduled Configuration Tasks > Config Group menu where you can view reports of the scheduled config groups.

Downloading Software

To download software to all controllers in the selected groups after you have a config group established, follow these steps:

**Step 1** Choose Configure > Controller Config Groups.

**Step 2** Select the check box to choose one or more config groups names on the Config Groups page.

**Step 3** Choose Download Software from the Select a command drop-down list, and click Go.

**Step 4** The Download Software to Controller page appears. The IP address of the controller to receive the bundle and the current status are displayed. Choose local machine from the File is Located On parameter.

**Step 5** Enter the maximum number of times the controller should attempt to download the signature file in the Maximum Retries parameter.

**Step 6** Enter the maximum amount of time in seconds before the controller times out while attempting to download the signature file in the Timeout parameter.
### Downloading Software

**Step 7** The signature files are uploaded to the c:\tftp directory. Specify the local file name in that directory or use the Browse button to navigate to it. The controller uses this local file name as a base name and then adds _custom.sgi as a suffix.

If the transfer times out for some reason, you can simply choose the TFTP server option in the File Is Located On parameter, and the Server File Name is populated for you and retried.

**Step 8** Click OK.

---

### Downloading IDS Signatures

To download Intrusion Detection System (IDS) signature files from your config group to a local TFTP server, follow these steps:

**Step 1** Choose **Configure > Controller Config Groups**.

**Step 2** Select the check box to choose one or more config groups on the Config Groups page.

**Step 3** Choose **Download IDS Signatures** from the Select a command drop-down list, and click **Go**.

**Step 4** The Download IDS Signatures to Controller page appears. The IP address of the controller to receive the bundle and the current status are displayed. Choose **local machine** from the File is Located On parameter.

**Step 5** Enter the maximum number of times the controller should attempt to download the signature file in the Maximum Retries parameter.

**Step 6** Enter the maximum amount of time in seconds before the controller times out while attempting to download the signature file in the Timeout parameter.

**Step 7** The signature files are uploaded to the c:\tftp directory. Specify the local file name in that directory or use the Browse button to navigate to it. The controller uses this local file name as a base name and then adds _custom.sgi as a suffix.

If the transfer times out for some reason, you can simply choose the TFTP server option in the File Is Located On parameter, and the Server File Name is populated for you and retried.

**Step 8** Click OK.

---

### Downloading Customized WebAuth

To download customized web authentication, follow these steps:

**Step 1** Choose **Configure > Controller Config Groups**.

**Step 2** Select the check box to choose one or more config groups on the Config Groups page.

**Step 3** Choose **Download Customized WebAuth** from the Select a command drop-down list, and click **Go**.

**Step 4** The Download Customized Web Auth Bundle to Controller page appears. The IP address of the controller to receive the bundle and the current status are displayed.
Step 5  Choose **local machine** from the File is Located On parameter.
This chapter describes how to configure wireless devices in the WCS database. It contains the following sections:

- Configuring Controllers, page 9-1
- Configuring Existing Controllers, page 9-21
- Configuring Access Points, page 9-152
- Configuring Ethernet Switches, page 9-189
- Configuring Spectrum Experts, page 9-191
- Configuring Chokepoints, page 9-196
- Configuring WiFi TDOA Receivers, page 9-199
- Configuring Scheduled Configuration Tasks, page 9-202
- Configuring wIPS Profiles, page 9-211
- Configuring ACS View Servers, page 9-220
- Configuring TFTP Servers, page 9-221
- Interactive Graphs, page 9-222

### Configuring Controllers

This section describes how to configure controllers in the WCS database.

Choose **Configure > Controllers** to access the following:

- A summary of all controllers in the WCS database.
- The ability to add, remove, and reboot selected controllers.
- The ability to download software from the WCS server to selected controllers.
- The ability to save the current configuration to nonvolatile (flash) memory on selected controllers.
- The ability to view audit reports for selected controllers.

The controllers data table contains the following columns:

- Check box—Select the applicable controller.
- IP Address—Local network IP address of the controller.
  - Click the title to sort the list items.
- Click a list item to display parameters for that IP address. See the “Viewing Controllers Properties” section on page 9-22.
- Click the icon to the right of the IP address to launch the controller Web user interface in a new browser window.

- Controller Name—Indicates the name of the controller. Click the **Controller Name** link to sort the list by controller name.
- Type—Click to sort by type. Based on the series, controller types are grouped. For example:
  - WLC2100—21xx Series Wireless LAN Controllers
  - 2500—25xx Series Wireless LAN Controllers
  - 4400—44xx Series Wireless LAN Controllers
  - 5500—55xx Series Wireless LAN Controllers
  - 7500—75xx Series Wireless LAN Controllers
  - WiSM—WiSM (slot number, port number)
  - WiSM2—WiSM2 (slot number, port number)
- Location—Indicates the location of the controller.
- Software Version—The operating system release.version.dot.maintenance number of the code currently running on the controller.
- Mobility Group Name—Name of the mobility or WPS group.
- Reachability Status—Reachable or not reachable.

**Note** Reachability status is updated based on the last execution information of the Device Status background task. For updating the current status, choose **Administration > Background Tasks**, and choose **Execute Now** from the Select a command drop-down list.

- Audit Status
  - Not Available—No audit occurred on this switch.
  - Identical—No configuration differences were discovered.
  - Mismatch—Configuration differences were discovered.

Click the **Audit Status** link to access the audit report. In the Audit Report page, choose **Audit Now** from the Select a command drop-down list to run a new audit for this controller. See the “Understanding the Controller Audit Report” section on page 9-3 for more information on audit reports.

**Note** Audit status is updated based on the last execution information of either the Configuration Sync background task or the Audit Now option located in the Controllers page. To get the current status, either choose **Administration > Background Tasks** and choose **Execute Now** or **Audit Now** from the Select a command drop-down list.

**Note** Use the Search feature to search for a specific controller. See the “Using the Search Feature” section on page 2-34 for more information.

This section contains the following topics:
Chapter 9 Configuring Wireless Devices

Configuring Controllers

- Understanding the Controller Audit Report, page 9-3
- Adding Controllers, page 9-4
- Removing Controllers from WCS, page 9-7
- Rebooting Controllers, page 9-7
- Rebooting Controllers and APs by Swapping AP Images, page 9-7
- Rebooting Controllers and APs Without Swapping AP Images, page 9-8
- Downloading Software to Controllers, page 9-8
- Downloading IDS Signatures, page 9-13
- Downloading a Customized WebAuthentication Bundle to a Controller, page 9-14
- Downloading a Vendor Device Certificate, page 9-15
- Downloading a Vendor CA Certificate, page 9-16
- Saving the Configuration to Flash, page 9-17
- Refreshing the Configuration from the Controller, page 9-17
- Discovering Templates from the Controller, page 9-18
- Viewing Templates Applied to a Controller, page 9-18
- Using the Audit Now Feature, page 9-19
- Viewing the Latest Network Audit Report, page 9-20

Understanding the Controller Audit Report

The Controller Audit Report displays the following information depending on the type of audit selected in Administration > Settings > Audit and on which parameters the audit is performed:

- Applied template discrepancies (Template Based Audit only)
- Config group template discrepancies (Template Based Audit only)
- Total enforcements for config groups with background audit enabled (Template Based Audit only)
  - If the total enforcement count is greater than zero, this number appears as a link. Click the link to view a list of the enforcements made from WCS.
- Failed for config groups with background audit enabled (Template Based Audit only)
  - If the failed enforcement count is greater than zero, this number appears as a link. Click the link to view the failures returned from the device.
- Other WCS discrepancies

**Note**
The controller audit report indicates if the audit was performed on all parameters or on a selected set of parameters.

**Note**
See the “Configuring an Audit” section on page 16-62 for more in depth information on the two types of audits and how to manage specific parameters for the audit.
A current Controller Audit Report can be accessed in the Configure > Controllers page by clicking a value in the Audit Status column.

You can audit a controller by choosing Audit Now from the Select a command drop-down list in the Configure > Controllers page (See the “Using the Audit Now Feature” section on page 9-19 for more information) or by clicking Audit Now in the Controller Audit Report.

## Adding Controllers

You can add controllers one at a time or in batches.

To add controllers, follow these steps:

### Step 1
Choose Configure > Controllers.

### Step 2
From the Select a command drop-down list, choose Add Controllers, and click Go. The Add Controller page appears (see Figure 9-1).

![Figure 9-1 Add Controller Page](image)

### Step 3
Choose one of the following:

- If you want to add one controller or use commas to separate multiple controllers, leave the Add Format Type drop-down list at Device Info.
- If you want to add multiple controllers by importing a CSV file, choose File from the Add Format Type drop-down list. The CSV file allows you to generate your own import file and add the devices you want.
When a controller is removed from the system, the associated access points are not removed automatically and therefore remain in the system. These disassociated access points must be removed manually.

If you are adding a controller into WCS across a GRE link using IPsec or a lower MTU link with multiple fragments, you may need to adjust the MaxVar Binds Per SET PDU and MaxVar Binds Per GET PDU. If it is set too high, the controller may fail to be added into WCS. To adjust the MaxVar Binds Per SET PDU or MaxVar Binds Per GET PDU setting, do the following: Stop WCS, go to the location of the Open SnmpParameters.properties file on the server that is running WCS, edit MaxVar Binds Per SET PDU or MaxVar Binds Per GET PDU to 50 or lower, and Restart WCS.

If you reduce the Maximum VarBinds per Get PDU or Maximum VarBinds per Set PDU value, applying the configurations to the device might fail.

If you chose Device Info, enter the IP address of the controller you want to add. If you want to add multiple controllers, use a comma between the string of IP addresses.

If a partial byte boundary is used and the IP address appears to be broadcast (without regard to the partial byte boundary), there is a limitation on adding the controllers into WCS. For example, 10.0.2.255/23 cannot be added but 10.0.2.254/23 can.

If you chose File, click Browse to find the location of the CSV file you want to import.

The first row of the CSV file is used to describe the columns included. The first row of the CSV file is used to describe the columns included. The IP Address column is mandatory. The following example shows a sample CSV file.

```
ip_address,network_mask,snmp_version,snmp_community,snmpv3_user_name,snmpv3_auth_type,snmpv3_auth_password,snmpv3_privacy_type,snmpv3_privacy_password,snmp_retries,snmp_timeout,protocol,telnet_username,telnet_password,enable_password,telnet_timeout
209.165.200.225,255.255.255.224,v2,public,,,,,,3,10,telnet,cisco,cisco,cisco,60
209.165.200.226,255.255.255.224,v2,public,,,,,,3,10,cisco,cisco,cisco,60
209.165.200.227,255.255.255.224,v2,public,,,,,,3,10,telnet,cisco,cisco,cisco,60
```

The CSV files can contain the following fields:

- ip_address
- network_mask
- snmp_version
- snmp_community
- snmpv3_user_name
- snmpv3_auth_type
- snmpv3_auth_password
- snmpv3_privacy_type
- snmpv3_privacy_password
Step 5 Select the **Verify Telnet/SSH Credentials** check box if you want this controller to verify Telnet/SSH credentials. You may want to leave this unselected (or disabled) because of the substantial time it takes for discovery of the devices.

Step 6 Use the Version drop-down list to choose v1, v2c, or v3.

Step 7 In the Retries parameter, enter the number of times that attempts are made to discover the controller.

Step 8 Provide the client session timeout value in seconds. This determines the maximum amount of time allowed for a client before it is forced to reauthenticate.

Step 9 In the Community parameter, enter either public or private (for v1 and v2 only).

**Note** If you go back and later change the community mode, you must perform a refresh config for that controller.

Step 10 Choose None, HMAC-SHA, or HMAC-MD5 (for v3 only) for the authorization type.

Step 11 Enter the authorization password (for v3 only).

Step 12 Enter None, CBC-DES, or CFB-AES-128 (for v3 only) for the privacy type.

Step 13 Enter the privacy password (for v3 only).

Step 14 Enter the Telnet credentials information for the controller. If you chose the File option and added multiple controllers, the information will apply to all specified controllers. If you added controllers from a CSV file, the username and password information is obtained from the CSV file.

**Note** The Telnet/SSH username must have sufficient privileges to execute commands in CLI templates.

The default username and password is admin.

Step 15 Enter the retries and timeout values. The default retries number is 3, and the default retry timeout is 1 minute.

Step 16 Click **OK**.

**Note** If you fail to add a device to WCS, and if the error message ‘Sparse table not supported’ occurs, verify that WCS and WLC versions are compatible and retry. For information on compatible versions, see [http://www.cisco.com/en/US/docs/wireless/controller/4400/tech_notes/Wireless_Software_Compatibility_Matrix.html](http://www.cisco.com/en/US/docs/wireless/controller/4400/tech_notes/Wireless_Software_Compatibility_Matrix.html).
Chapter 9 Configuring Wireless Devices

Configuring Controllers

Note When a controller is added to the WCS, the WCS acts as a TRAP receiver and the following traps are enabled on the controller: 802.11 Disassociation, 802.11 Deauthentication, and 802.11 Authenticated.

Removing Controllers from WCS

To remove a controller, follow these steps:

Step 1 Choose Configure > Controllers.
Step 2 Select the check box(es) of the applicable controller(s).
Step 3 From the Select a command drop-down list, choose Remove Controllers.
Step 4 Click Go.
Step 5 Click OK in the pop-up dialog box to confirm the deletion.

Note When a controller is removed from the system, the associated access points are not removed automatically and, therefore, remain in the system. These disassociated access points must be removed manually.

Rebooting Controllers

To reboot a controller, follow these steps:

Step 1 Choose Configure > Controllers.
Step 2 Select the check box(es) of the applicable controller(s).
Step 3 From the Select a command drop-down list, choose Reboot Controllers.
Step 4 Click Go.

Note Save the current controller configuration prior to rebooting.

Step 5 Click OK in the pop-up dialog box to confirm the reboot.

Rebooting Controllers and APs by Swapping AP Images

To reboot controllers and APs by swapping AP images, follow these steps:

Step 1 Choose Configure > Controllers.
Step 2 Select the check box(es) of the applicable controller(s).
Step 3 From the Select a command drop-down list, choose Reboot Controllers and APs(Swap AP Images).

Step 4 Click Go.

Note When you attempt to use this feature, a warning message appears noting that the selected controllers are going to be rebooted.

Step 5 Click OK in the pop-up dialog box to confirm the reboot.

Note This option is supported only when the selected controllers are using the version 7.0.x.x or later.

Rebooting Controllers and APs Without Swapping AP Images

To reboot controllers and APs without swapping AP images, follow these steps:

Step 1 Choose Configure > Controllers.

Step 2 Select the check box(es) of the applicable controller(s).

Step 3 From the Select a command drop-down list, choose Reboot Controllers and APs(Do Not Swap AP Images).

Step 4 Click Go.

Note When you attempt to use this feature, a warning message appears noting that the selected controllers are going to be rebooted.

Step 5 Click OK in the pop-up dialog box to confirm the reboot.

Note This option is supported only when the selected controllers are using the version 7.0.x.x or later.

Downloading Software to Controllers

Both File Transfer Protocol (FTP) and Trivial File Transfer Protocol (TFTP) are supported for uploading and downloading files to and from WCS. In previous software releases, only TFTP was supported.

This section contains the following topics:

- Download Software (FTP), page 9-9
- Download Software (TFTP), page 9-10
- Configure IPaddr Upload Configuration/Logs from Controller, page 9-12
Download Software (FTP)

To download software to a controller, follow these steps:

**Step 1** Choose Configure > Controllers.

**Step 2** Select the check box(es) of the applicable controller(s).

**Step 3** From the Select a command drop-down list, choose Download Software (FTP).

**Step 4** Click Go.

---

**Note** Software can also be downloaded by choosing Configure > Controllers > IPaddr > System > Commands > Upload/Download Commands > Download Software.

The IP address of the controller and its current status appears in the Download Software to Controller page.

**Step 5** Select the download type.

---

**Note** The pre-download option is displayed only when all selected controllers are using the version 7.0.x.x or later.

- Now—Executes the download software operation immediately. If you select this option, proceed with Step 7.

---

**Note** After the download is successful, reboot the controllers to enable the new software.

- Scheduled—Specify the scheduled download options.
  - Schedule download to controller—Select this check box to schedule download software to controller.
  - Pre-download software to APs—Select this check box to schedule the pre-download software to APs. The APs download the image and then reboot when the controller reboots.

---

**Note** To see Image Predownload status per AP, enable the task in the Administration > Background Task > AP Image Predownload Task page, and run an AP Image Predownload report from the Report Launch Pad.

**Step 6** If you selected the Scheduled option under Download type, enter the Schedule Details.

- Task Name—Enter a Scheduled Task Name to identify this scheduled software download task.
- Reboot Type—Indicates whether the reboot type is manual, automatic, or scheduled.

---

**Note** Reboot Type Automatic can be set when the only Download software to controller option is selected.

- Download date/time—Enter a date in the provided text box or click the calendar icon to open a calendar from which you can choose a date. Choose the time from the hours and minutes drop-down lists.
- Reboot date/time—This option appears only if you select the reboot type as “Scheduled”. Enter a date in the provided text box or click the calendar icon to open a calendar from which you can choose a date to reboot the controller. Choose the time from the hours and minutes drop-down lists.

  **Note** Schedule enough time (at least 30mins) between Download and Reboot so that all APs can complete the software pre-download.

  **Note** If any one of the AP is in pre-download progress state at the time of scheduled reboot, the controller will not reboot. In such a case, wait for the pre-download to finish for all the APs and reboot the controller manually.

- Notification (Optional)—Enter the e-mail address of recipient to send notifications via e-mail.

  **Note** To receive email notifications, configure the WCS mail server in the Administration > Settings > Mail Server Configuration page.

**Step 7** Enter the FTP credentials including username, password, and port.

**Step 8** In the File is located on parameter, click either the Local machine or FTP Server.

  **Note** If you choose FTP Server, choose Default Server or New from the Server Name drop-down list.

  **Note** The software files are uploaded to the FTP directory specified during the install.

**Step 9** Specify the local file name or click Browse to navigate to the appropriate file.

  **Note** If you chose FTP Server previously, specify the server filename.

**Step 10** Click Download.

  **Note** If the transfer times out for some reason, you can choose the FTP server option in the File is located on radio button; the server filename is populated and retried.

---

**Download Software (TFTP)**

To download software to a controller, follow these steps:

**Step 1** Choose Configure > Controllers.

**Step 2** Select the check box(es) of the applicable controller(s).

**Step 3** In the Select a command drop-down list, choose Download Software (TFTP).
**Step 4**  Click **Go**.

*Note* Software can also be downloaded from Configure > Controllers > IPaddr > System > Commands > Upload/Download Commands > Download Software.

The IP address of the controller and its current status are displayed in the Download Software to Controller page.

**Step 5**  Select the download type.

*Note* The pre-download option is displayed only when all selected controllers are using the version 7.0.x.x or later.

- **Now**—Executes the download software operation immediately. If you select this option, proceed with Step 7.

*Note* After the download is successful, reboot the controllers to enable the new software.

- **Scheduled**—Specify the scheduled download options.
  - Download software to controller—Select this option to schedule download software to controller.
  - Pre-download software to APs—Select this option to schedule the pre-download software to APs. The APs download the image and then reboot when the controller reboots.

*Note* To see Image Predownload status per AP, enable the task in the Administration > Background Task > AP Image Predownload Task page, and run an AP Image Predownload report from the Report Launch Pad.

**Step 6**  If you selected the Scheduled option under Download type, enter the Schedule Detail.

- **Task Name**—Enter a Scheduled Task Name to identify this scheduled software download task.
- **Reboot Type**—Indicates whether the reboot type is manual, automatic, or scheduled.

*Note* Reboot Type **Automatic** can be set when only Download software to controller option is selected.

- **Download date/time**—Enter a date in the provided text box or click the calendar icon to open a calendar from which you can choose a date. Choose the time from the hours and minutes drop-down lists.
- **Reboot date/time**—This option appears only if you select the reboot type as “Scheduled”. Enter a date in the provided text box or click the calendar icon to open a calendar from which you can choose a date to reboot the controller. Choose the time from the hours and minutes drop-down lists.

*Note* Schedule enough time (at least 30 minutes) between Download and Reboot so that all APs can complete the software pre-download.
Note: If any one of the AP is in pre-download progress state at the time of scheduled reboot, the controller will not reboot. In such a case, wait for the pre-download to finish for all the APs and reboot the controller manually.

- Notification (Optional)—Enter the e-mail address of recipient to send notifications via e-mail.

Note: To receive email notifications, configure the WCS mail server in the Administration > Settings > Mail Server Configuration page.

Step 7 From the File is located on parameter, choose Local machine or TFTP server.

Note: If you choose TFTP server, select the Default Server or add a New server using the Server Name drop-down list.

Step 8 From the Maximum Retries parameter, enter the maximum number of tries the controller should attempt to download the software.

Step 9 In the Timeout parameter, enter the maximum amount of time (in seconds) before the controller times out while attempting to download the software.

Note: The software files are uploaded to the TFTP directory specified during the install.

Step 10 Specify the local file name or click Browse to navigate to the appropriate file.

Note: If you selected TFTP server previously, specify the Server File Name.

Step 11 Click Download.

Tip: If the transfer times out for some reason, you can choose the TFTP server option in the File is located on parameter; the Server File Name is populated and retried.

Configure IPaddr Upload Configuration/Logs from Controller

To upload files from the controller, follow these steps:

Step 1 Choose Configure > Controllers.

Step 2 Click an IP address under the IP address column.

Step 3 From the left sidebar menu, choose System > Commands.

Step 4 Select the FTP or TFTP radio button.
Configuring Controllers

Chapter 9 Configuring Wireless Devices

Note Both File Transfer Protocol (FTP) and Trivial Transfer Protocol (TFTP) are supported for uploading and downloading files to and from WCS. In previous software releases, only TFTP was supported.

Step 5 From the Upload/Download Commands drop-down list, choose **Upload File from Controller**.

Step 6 Click **Go** to access this page.

- **FTP Credentials Information**—Enter the FTP username, password, and port if you selected the FTP radio button previously.
- **TFTP or FTP Server Information**:
  - **Server Name**—From the drop-down list, choose **Default Server** or **New**.
  - **IP Address**—IP address of the controller. This is automatically populated if the default server is selected.
  - **File Type**—Select from configuration, event log, message log, trap log, crash file, signature files, or PAC.
  - Enter the Upload to File from \(/(root)/wcs-tftp/ or /(root)/wcs-ftp/ filename.
  - Select whether or not Cisco WCS saves before backing up the configuration.

Note The WCS uses an integral TFTP and FTP server. This means that third-party TFTP and FTP servers cannot run on the same workstation as the Cisco WCS, because the Cisco WCS and the third-party servers use the same communication port.

Step 7 Click **OK**. The selected file will be uploaded to your TFTP or FTP server and named what you entered in the File Name text box.

---

**Downloading IDS Signatures**

To download Intrusion Detection System (IDS) signature files to a controller, follow these steps:

Step 1 Choose **Configure > Controllers**.

Step 2 Select the check box(es) of the applicable controller(s).

Step 3 From the Select a command drop-down list, choose **Download IDS Signatures**.

Step 4 Click **Go**.

Note IDS signature files can also be downloaded from **Configure > Controllers > IPaddr > System > Commands > Upload/Download Commands > Download IDS Signatures**.

In the Download IDS Signatures to Controller page, the controller IP address and its current status appears.

Step 5 Copy the signature file (*.sig) to the default directory on your TFTP server.

Step 6 In the **File is located on** parameter, select the **Local machine** radio button.
Note If you know the filename and path relative to the server root directory, you can also select the TFTP server radio button.

Step 7 In the Maximum Retries text box, enter the maximum number of tries the controller should attempt to download the signature file.

Step 8 In the Timeout text box, enter the maximum amount of time (in seconds) before the controller times out while attempting to download the signature file.

Note The signature files are uploaded to the c:\tftp directory.

Step 9 Specify the local file name or click Browse to navigate to the appropriate file. The controller uses this local file name as a base name and adds _custom.sgi as a suffix.

Note If you chose TFTP server previously, specify the server file name.

Step 10 Click Download.

Tip If the transfer times out for some reason, you can choose the TFTP server option in the File is located on parameter; the server file name is populated and retried.

Note The local machine option initiates a two-step operation. First, the local file is copied from the administrator workstation to WCS own built-in TFTP server. Then the controller retrieves that file. For later operations, the file is already in the WCS server TFTP directory, and the downloaded web page now automatically populates the filename.

---

**Downloading a Customized WebAuthentication Bundle to a Controller**

To download customized web authentication bundle to a controller, follow these steps:

Step 1 Choose Configure > Controllers.

Step 2 Select the check box(es) of the applicable controller(s).

Step 3 From the Select a command drop-down list, choose Download Customized WebAuth.

Step 4 Click Go.

Note A customized web authentication bundle can also be downloaded from Configure > Controllers > IPaddr > System > Commands > Upload/Download Commands > Download Customized WebAuth.

In the Download Customized WebAuth bundle to Controller page, the controller IP address and its current status appears.
Step 5  Select the **Local machine** radio button in the File is located on parameter.

Note  If you know the file name and path relative to the server root directory, you can also select the **TFTP server** radio button.

Note  For a local machine download, either .zip or .tar file options exists but the WCS does the conversion of .zip to .tar automatically. If you choose a TFTP server download, only .tar files are specified.

Step 6  In the Maximum Retries text box, enter the maximum number of tries the controller should attempt to download the file.

Step 7  In the Timeout text box, enter the maximum amount of time (in seconds) before the controller times out while attempting to download the file.

Note  The WCS Server Files In parameter specifies where the WCS server files are located.

Step 8  Specify the local file name or click **Browse** to navigate to the appropriate file. The controller uses this local file name as a base name and adds _custom.sgi as a suffix.

Step 9  Click **Download**.

Tip  If the transfer times out for some reason, you can select the TFTP server radio button in the File is located on parameter; the server file name is populated and retried.

Step 10  The local machine option initiates a two-step operation. First, the local file is copied from the administrator workstation to WCS own built-in TFTP server. Then the controller retrieves that file. For later operations, the file is already in the WCS server TFTP directory, and the downloaded web page now automatically populates the filename.

Step 11  After completing the download, you are directed to a new page and are able to authenticate.

### Downloading a Vendor Device Certificate

Each wireless device (controller, access point, and client) has its own device certificate. If you wish to use your own vendor-specific device certificate, it must be downloaded to the controller.

To download a vendor device certificate to a controller, follow these steps:

Step 1  Choose **Configure > Controllers**.

Step 2  You can download the certificate in one of two ways:

- Select the check box(es) of the applicable controller(s).
- From the Select a command drop-down list, choose **Download Vendor Device Certificate**.
- Click **Go**.
Configuring Controllers

- or -

a. Click the IP address of the desired controller.
b. Choose System > Commands from the left sidebar menu.
c. From the Upload/Download Commands drop-down list, choose Download Vendor Device Certificate.
d. Click Go.

Step 3 In the Certificate Password text box, enter the password used to protect the certificate.
Step 4 Re-enter the password in the Confirm Password text box.
Step 5 In the File is located on parameter, select the Local machine or TFTP server radio button.

Note If the certificate is located on the TFTP server, enter the Server File Name. If it is located on the local machine, enter the local file name by clicking Browse.

Step 6 Enter the TFTP server name in the Server Name parameter. The default is the WCS server.
Step 7 Enter the server IP address.
Step 8 In the Maximum Retries text box, enter the maximum number of times that the TFTP server attempts to download the certificate.
Step 9 In the Timeout text box, enter the amount of time (in seconds) that the TFTP server attempts to download the certificate.
Step 10 In the Local File Name text box, enter the directory path of the certificate.
Step 11 In the Server File Name text box, enter the name of the certificate.
Step 12 Click Download.

Downloading a Vendor CA Certificate

Controllers and access points have a certificate authority (CA) certificate that is used to sign and validate device certificates. The controller is shipped with a Cisco-installed CA certificate. This certificate may be used by EAP-TLS and EAP-FAST (when not using PACs) to authenticate wireless clients during local EAP authentication. However, if you wish to use your own vendor-specific CA certificate, it must be downloaded to the controller.

To download a vendor CA certificate to the controller, follow these steps:

Step 1 Choose Configure > Controllers.
Step 2 You can download the certificate in one of two ways:
   a. Select the check box(es) of the applicable controller(s).
   b. From the Select a command drop-down list, choose Download Vendor CA Certificate.
   c. Click Go.
   - or -
   a. Click the IP address of the desired controller.
   b. Choose System > Commands from the left sidebar menu.
c. From the Upload/Download Commands drop-down list, choose **Download Vendor CA Certificate**.
d. Click **Go**.

**Step 3**
In the File is located on parameter, select the **Local machine** or **TFTP server** radio button.

**Note**
- If the certificate is located on the TFTP server, enter the server file name. If it is located on the local machine, enter the local file name by clicking the **Browse** button.

**Step 4**
Enter the TFTP server name in the **Server Name** text box. The default is the WCS server.

**Step 5**
Enter the server IP address.

**Step 6**
In the **Maximum Retries** text box, enter the maximum number of times that the TFTP server attempts to download the certificate.

**Step 7**
In the **Timeout** text box, enter the amount of time (in seconds) that the TFTP server attempts to download the certificate.

**Step 8**
In the **Local File Name** text box, enter the directory path of the certificate.

**Step 9**
In the **Server File Name** text box, enter the name of the certificate.

**Step 10**
Click **OK**.

---

**Saving the Configuration to Flash**

To save the configuration to flash memory, follow these steps:

**Step 1**
Choose **Configure > Controllers**.

**Step 2**
Select the check box(es) for the applicable controller(s).

**Step 3**
From the Select a command drop-down list, choose **Save Config to Flash**.

**Step 4**
Click **Go**.

---

**Refreshing the Configuration from the Controller**

To refresh the configuration from the controller, follow these steps:

**Step 1**
Choose **Configure > Controllers**.

**Step 2**
Select the check box(es) for the applicable controller(s).

**Step 3**
From the Select a command drop-down list, choose **Refresh Config from Controller**.

**Step 4**
Click **Go**.

**Step 5**
At the Configuration Change prompt, select the **Retain** or **Delete** radio button.

**Step 6**
Click **Go**.
Discovering Templates from the Controller

Prior to software release 5.1, templates were detected when a controller was detected, and every configuration found on WCS for a controller had an associated template. Now templates are not automatically detected with controller discovery, and you can specify which WCS configurations you want to have associated templates.

Note: The templates that are discovered do not retrieve management or local user passwords.

The following rules apply for template discovery:

- Template Discovery discovers templates that are not found in WCS.
- Existing templates are not discovered.
- Discovered templates are not associated to the configuration on the device.

To discover current templates, follow these steps:

Step 1 Choose Configure > Controllers.
Step 2 Select the check box of the controller for which you want to discover templates.
Step 3 From the Select a command drop-down list, choose Discover Templates from Controller.
Step 4 Click Go. The Discover Templates page displays the number of discovered templates, each template type and each template name.

Note: Template discovery refreshes configuration from the controller prior to discovering templates. Click OK in the warning dialog box to continue with the discovery.

Viewing Templates Applied to a Controller

You can view all templates currently applied to a specific controller.

Note: Only templates applied in this partition are displayed.

To view applied templates, follow these steps:

Step 1 Choose Configure > Controllers.
Step 2 Select the check box for the applicable controller.
Step 3 From the Select a command drop-down list, choose Templates Applied to a Controller.
Step 4 Click Go. The Templates Applied to a Controller page displays each applied template name, template type, the date the template was last saved, and the date the template was last applied.
Note
Click the template name link to view the template details. See the “Using Templates” section on page 11-1 for more information.

Using the Audit Now Feature

You can audit a controller by choosing Audit Now from the Select a command drop-down list in the Configure > Controllers page or by choosing Audit Now directly from the Select a command drop-down list.

Note
A current Controller Audit Report can be accessed in the Configure > Controllers page by clicking a value in the Audit Status column.

To audit a controller, follow these steps:

**Step 1** Choose Configure > Controllers.

**Step 2** Select the check box for the applicable controller.

**Step 3** From the Select a command drop-down list, choose Audit Now.

**Step 4** Click Go.

**Step 5** Click OK in the pop-up dialog box if you want to remove the template associations from configuration objects in the database as well as template associations for this controller from associated config groups (Template based audit only).

The Audit Report displays:

- Device Name
- Time of Audit
- Audit Status
- Applied and Config Group Template Discrepancies information including the following:
  - Template type (template name)
  - Template application method
  - Audit status (For example, mismatch, identical)
  - Template attribute
  - Value in WCS
  - Value in Controller
- Other WCS Discrepancies including:
  - Configuration type (name)
  - Audit Status (For example, mismatch, identical)
  - Attribute
  - Value in WCS
• Value in Controller

• Total enforcements for config groups with background audit enabled—If discrepancies are found during the audit in regards to the config groups enabled for background audit and if the enforcement is enabled, this section lists the enforcements made during the controller audit. Choose **Config Groups > General** for more information on enabling the background audit.

• Failed Enforcements for Config Groups with background audit enabled—Click the link to view a list of failure details (including the reason for the failure) returned by the device. See the “Configuring Config Groups” section on page 9-204 for more information on enabling the background audit (ConfigAuditSet).

• Restore WCS Values to Controller or Refresh Config from Controller—If there are config differences found as a result of the audit, you can either click **Restore WCS Values to controller** or **Refresh Config from controller** to bring the WCS configuration in sync with the controller.
  - If you choose Restore WCS Values, all of the WCS values are enforced on the controller in an attempt to resolve the discrepancies on the device. All of the applied templates and the templates that are part of the config group are applied to this controller.

  **Note** Template discrepancies can be resolved by enforcing WCS templates on the device. See the “Configuring Config Groups” section on page 9-204 for more information on enforcing configurations.

  - If you choose Refresh Config from Controller, the Refresh Config page prompts you to choose between retaining the configuration or delete the configuration. Click **Go** to confirm your selection or **Cancel** to close the page without taking any action.

  **Note** Templates are not refreshed as a result of clicking Refresh Config from Controller.

---

### Viewing the Latest Network Audit Report

The Network Audit Report shows the time of the audit, the IP address of the selected controller, and the synchronization status.

**Note** This method shows the report from the network audit task and not an on-demand audit per controller.

To view the latest network audit report for the selected controllers, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Select the check box for the applicable controller.

**Step 3** From the Select a command drop-down list, choose **View Latest Network Configuration Audit Report**.

**Step 4** Click **Go**.

The Audit Summary displays the time of the audit, the IP address of the selected controller, and the audit status. The Audit Details display the config differences, if applicable.
Use the General and Schedule tabs to revise Audit Report parameters. See the “Understanding the Controller Audit Report” section on page 9-3 section for more information.

**Command Buttons**

- Save—Click to save changes made to the current parameters.
- Save and Run—Click to save the changes to the current parameters and run the report.
- Run Now—Click to run the audit report based on existing parameters.
- Export Now—Click to export the report results. The supported export formats is PDF and CSV.
- Cancel—Click to cancel any changes made to the existing parameters.

**Note**

From the All Controllers page, click the Audit Status column value to view the latest audit details page for the selected controller. This method has similar information as the Network Audit report on the Reports menu, but this report is interactive and per controller.

**Note**

To run an on-demand audit report, choose which controller you want to run the report on and choose **Audit Now** from the Select a command drop-down list. If you run an on-demand audit report and configuration differences are detected, you are given the option to retain the existing controller or WCS values.

**Configuring Existing Controllers**

This section contains the following topics:

- Viewing Controllers Properties, page 9-22
- Configuring Controller System Parameters, page 9-23
- Configuring Controller WLANs, page 9-63
- Configuring Hybrid REAP Parameters, page 9-79
- Configuring Security Parameters, page 9-82
- Configuring Cisco Access Points, page 9-110
- Configuring 802.11 Parameters, page 9-112
- Configuring 802.11a/n Parameters, page 9-117
- Configuring 802.11b/g/n Parameters, page 9-130
- Configuring Mesh Parameters, page 9-140
- Configuring Port Parameters, page 9-143
- Configuring Controllers Management Parameters, page 9-144
- Configuring Location Configurations, page 9-150
Viewing Controllers Properties

To view the properties for current controllers, follow these steps:

- **Step 1** Choose **Configure > Controllers**.
- **Step 2** Click the IP address of the applicable controller.
- **Step 3** From the left sidebar menu, choose **Properties > Settings**. The following parameters appear:
  - **General Parameters**:
    - **Name**—Name assigned to the controller.
    - **Type**—Controller type.
    - **Restore on Cold Start Trap**—Select to enable a restore on a cold start trap.
    - **Auto Refresh on Save Config Trap**—Select to enable an automatic refresh on a Save Config trap.
    - **Trap Destination Port**—Read-only.
    - **Software Version**—Read-only.
    - **Location**—Location of the controller.
    - **Contact**—The contact person for this controller.
    - **Most Recent Backup**—The date and time of the most recent backup.
    - **Save Before Backup**—Select to enable a save before backup.
  - **SNMP Parameters**:
    - **Note** SNMP write access parameters are needed for modifying controller configuration. With read-only access parameters, configuration can only be displayed.
    - **Version**—Choose from v1, v2c, or v3.
    - **Retries**—Indicates the number of controller discovery attempts.
    - **Timeout (seconds)**—Client Session timeout. Sets the maximum amount of time allowed a client before it is forced to reauthenticate.
    - **Community**—Public or Private.
    - **Access Mode**—Read Write
      - **Note** Community settings only apply to v1 and v2c.
    - **User Name**—Enter a username.
    - **Auth. Type**—Choose an authentication type from the drop-down list or choose **None**.
    - **Auth. Password**—Enter an authentication password.
    - **Privacy Type**—Choose a privacy type from the drop-down list or choose **None**.
    - **Privacy Password**—Enter a privacy password.
Step 4 If you made changes to this controller properties, click OK to confirm the changes, Reset to return to the previous or default settings, or Cancel to return to the Configure > Controllers page without making any changes to these settings.

### Configuring Controller System Parameters

This section describes how to configure the controller system parameters and includes the following topics:

- Managing General System Properties for Controllers, page 9-24
- Configuring Controller System Commands, page 9-30
- Configuring Controller System Interfaces, page 9-36
- Configuring Controller System Interface Groups, page 9-39
- Configuring Controller Network Routes, page 9-48
- Configuring Controller Spanning Tree Protocol Parameters, page 9-49
- Configuring Controller Mobility Groups, page 9-49
- Configuring Controller Network Time Protocol, page 9-52
- Configuring Controller QoS Profiles, page 9-55
- Configuring Controller DHCP Scopes, page 9-56
- Configuring Controller User Roles, page 9-57
- Configuring a Global Access Point Password, page 9-58
- Configuring AP 802.1X Supplicant Credentials
- Configuring Controller DHCP, page 9-60
- Configuring Controller Multicast Mode, page 9-61
Managing General System Properties for Controllers

To view the general system parameters for a current controller, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click the IP address of the applicable controller.

**Step 3** From the left sidebar menu, choose **System > General**. The following parameters appear:

- **802.3x Flow Control Mode**—Disable or enable. See the “802.3x Flow Control” section on page 9-27 for more information.
- **802.3 Bridging**—Disable or enable. See the “Configuring 802.3 Bridging” section on page 9-27 for more information.
- **Web Radius Authentication**—Choose PAP, CHAP, or MD5-CHAP.
  - **PAP**—Password Authentication Protocol. Authentication method where user information (username and password) is transmitted in clear text.
  - **CHAP**—Challenge Handshake Authentication Protocol. Authentication method where user information is encrypted for transmission.
  - **MD5-CHAP**—Message Digest 5 Challenge Handshake Authentication Protocol. With MD5, passwords are hashed using the Message Digest 5 algorithm.
- **AP Primary Discovery Timeout**—Enter a value between 30 and 3600 seconds. The access point maintains a list of backup controllers and periodically sends primary discovery requests to each entry in the list. When configured, the primary discovery request timer specifies the amount of time that a controller has to respond to the discovery request of the access point before the access point assumes that the controller cannot be joined and waits for a discovery response from the next controller in the list.
- **CAPWAP Transport Mode**—Layer 3 or Layer 2. See the “Lightweight Access Point Protocol Transport Mode” section on page 9-28 for more information.
- **Current LWAPP Operating Mode**—Automatically populated.
- **Broadcast Forwarding**—Disable or enable.
- **LAG Mode**—Choose **Disable** if you want to disable LAG.
  Link aggregation (LAG) is a partial implementation of the 802.3ad port aggregation standard. It bundles all of the controller distribution system ports into a single 802.3ad port channel, thereby reducing the number of IP addresses needed to configure the ports on your controller. When LAG is enabled, the system dynamically manages port redundancy and load balances access points transparently to the user.

**Note**
LAG is disabled by default on the Cisco 5500 and 4400 series controllers but enabled by default on the Cisco WiSM and the controller in the Catalyst 3750G Integrated Wireless LAN Controller Switch.

See the “Link Aggregation” section on page 9-29 for more information.

- **Ethernet Multicast Support**
  - **Disable**—Select to disable multicast support on the controller.
– Unicast—Select if the controller, upon receiving a multicast packet, forwards the packets to all the associated access points.

**Note** H-REAP supports only unicast mode.

– Multicast—Select to enable multicast support on the controller.

- Aggressive Load Balancing—Disable or enable. See the “Aggressive Load Balancing” section on page 9-29 for more information on load balancing.

- Peer to Peer Blocking Mode
  - Disable—Same-subnet clients communicate through the controller.
  - Enable—Same-subnet clients communicate through a higher-level router.

- Over Air Provision AP Mode—Disable or enable.
  Over-the-air provisioning (OTAP) is supported by Cisco 5500 and 4400 series controllers. If this feature is enabled on the controller, all associated access points transmit wireless CAPWAP or LWAPP neighbor messages, and new access points receive the controller IP address from these messages. This feature is disabled by default and should remain disabled when all access points are installed.

**Note** Disabling OTAP on the controller does not disable it on the access point. OTAP cannot be disabled on the access point.


- AP Fallback—Disable or enable.

**Note** Enabling AP Fallback causes an access point which lost a primary controller connection to automatically return to service when the primary controller returns.

- AP Failover Priority—Disable or enable.

**Note** To configure failover priority settings for access points, you must first enable the AP Failover Priority feature. See the “AP Failover Priority” section on page 9-26 for more information.

- AppleTalk Bridging—Disable or enable.

- Fast SSID change—Disable or enable.
  When fast SSID changing is enabled, the controller allows clients to move between SSIDs. When the client sends a new association for a different SSID, the client entry in the controller connection table is cleared before the client is added to the new SSID. When fast SSID changing is disabled, the controller enforces a delay before clients are allowed to move to a new SSID.
Chapter 9 Configuring Wireless Devices

### Configuring Existing Controllers

**Note**
If enabled, the client connects instantly to the controller between SSIDs without having appreciable loss of connectivity.

- Master Controller Mode—Disable or enable.

**Note**
Because the master controller is normally not used in a deployed network, the master controller setting is automatically disabled upon reboot or OS code upgrade.

- Wireless Management—Disable or enable. See the “Wireless Management” section on page 9-29 for more information.

- Symmetric Tunneling Mode

- ACL Counters—Disable or enable. The number of hits are displayed in the ACL Rule page. See the “Configuring Access Control Lists” section on page 9-97 or the “Configure IPaddr > Access Control List > listname Rules” section on page 9-98 for more information.

- Multicast Mobility Mode—Disable or enable. See the “Setting the Mobility Scalability Parameters” section on page 9-51 for more information.

- Default Mobility Domain Name—Enter domain name.

- Mobility Anchor Group Keep Alive Interval—Enter the amount of delay time allowed between tries for a client attempting to join another access point. See the “Mobility Anchor Group Keep Alive Interval” section on page 9-30 for more information.

**Tip**
When you hover your mouse cursor over the parameter text box, the valid range for that field appears.

- Mobility Anchor Group Keep Alive Retries—Enter number of allowable retries.

**Tip**
When you hover your mouse cursor over the parameter text box, the valid range for that field appears.

- RF Network Name—Enter network name.
- User Idle Timeout (seconds)—Enter timeout in seconds.
- ARP Timeout (seconds)—Enter timeout in seconds.

#### AP Failover Priority

When a controller fails, the backup controller configured for the access point suddenly receives a number of Discovery and Join requests. If the controller becomes overloaded, it may reject some of the access points.

By assigning failover priority to an access point, you have some control over which access points are rejected. When the backup controller is overloaded, join requests of access points configured with a higher priority levels take precedence over lower-priority access points.

To configure failover priority settings for access points, you must first enable the AP Failover Priority feature.
To enable the AP Failover Priority feature, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click the IP address of the applicable controller.

**Step 3** From the left sidebar menu, choose **System > General**.

**Step 4** From the AP Failover Priority drop-down, select **Enabled**.

To configure an access point failover priority, follow these steps:

**Step 1** Choose **Configure > Access Points > AP Name**.

**Step 2** From the AP Failover Priority drop-down list, choose the applicable priority (**Low**, **Medium**, **High**, **Critical**).

**Note** The default priority is **Low**.

**Configuring 802.3 Bridging**

The controller supports 802.3 frames and applications that use them, such as those typically used for cash registers and cash register servers. However, to make these applications work with the controller, the 802.3 frames must be bridged on the controller.

Support for raw 802.3 frames allows the controller to bridge non-IP frames for applications not running over IP. Only this raw 802.3 frame format is currently supported.

To configure 802.3 bridging using WCS release 4.1 or later, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click the IP address of the applicable controller.

**Step 3** Choose **System > General** to access the General page.

**Step 4** From the 802.3 Bridging drop-down list, choose **Enable** to enable 802.3 bridging on your controller or **Disable** to disable this feature. The default value is Disable.

**Step 5** Click **Save** to confirm your changes.

**802.3x Flow Control**

Flow control is a technique for ensuring that a transmitting entity, such as a modem, does not overwhelm a receiving entity with data. When the buffers on the receiving device are full, a message is sent to the sending device to suspend the transmission until the data in the buffers has been processed.

By default, flow control is disabled. You can only enable a Cisco switch to receive PAUSE frames but not to send them.
Lightweight Access Point Protocol Transport Mode

Lightweight Access Point Protocol transport mode indicates the communications layer between controllers and access points. Selections are Layer 2 or Layer 3.

To convert a Cisco Unified Wireless Network Solution from Layer 3 to Layer 2 lightweight access point transport mode using the WCS user interface, follow these steps:

**Note**
Cisco IOS-based lightweight access points do not support Layer 2 lightweight access point mode. These access points can only be run with Layer 3.

**Note**
This procedure causes your access points to go offline until the controller reboots and the associated access points reassociate to the controller.

**Step 1**
Make sure that all controllers and access points are on the same subnet.

**Note**
You must configure the controllers and associated access points to operate in Layer 2 mode before completing the conversion.

**Step 2**
Log into the WCS user interface. Then follow these steps to change the lightweight access point transport mode from Layer 3 to Layer 2:

a. Choose **Configure > Controllers**.
b. Click the IP address of the applicable controller.
c. Choose **System > General** to access the General page.
d. Change lightweight access point transport mode to Layer2 and click **Save**.
e. If WCS displays the following message, click **OK**:

Please reboot the system for the CAPWAP Mode change to take effect.

**Step 3**
Follow these steps to restart WCS:

a. Choose **System > Commands**.
b. From the Administrative Commands drop-down list, choose **Save Config To Flash**, and click **Go** to save the changed configuration to the controller.
c. Click **OK** to continue.
d. From the Administrative Commands drop-down list, choose **Reboot**, and click **Go** to reboot the controller.
e. Click **OK** to confirm the save and reboot.

**Step 4**
After the controller reboots, follow these steps to verify that the CAPWAP transport mode is now Layer 2:

a. Choose **Configure > Controllers**.
b. Click the IP address of the applicable controller.
c. Verify that the current CAPWAP transport mode is Layer2 from the general drop-down list.
You have completed the CAPWAP transport mode conversion from Layer 3 to Layer 2. The operating system software now controls all communications between controllers and access points on the same subnet.

### Aggressive Load Balancing

In routing, load balancing refers to the capability of a router to distribute traffic over all its network ports that are the same distance from the destination address. Good load-balancing algorithms use both line speed and reliability information. Load balancing increases the use of network segments, thus increasing effective network bandwidth.

Aggressive load balancing actively balances the load between the mobile clients and their associated access points.

### Link Aggregation

Link aggregation allows you to reduce the number of IP addresses needed to configure the ports on your controller by grouping all the physical ports and creating a link aggregation group (LAG). In a 4402 model, two ports are combined to form a LAG whereas in a 4404 model, all four ports are combined to form a LAG.

If LAG is enabled on a controller, the following configuration changes occur:

- Any dynamic interfaces that you have created are deleted. This is done to prevent configuration inconsistencies in the interface database.
- Interfaces cannot be created with the “Dynamic AP Manager” flag set.

**Note** You cannot create more than one LAG on a controller.

The advantages of creating a LAG include:

- Assurance that, if one of the links goes down, the traffic is moved to the other links in the LAG. As long as one of the physical ports is working, the system remains functional.
- No need to configure separate backup ports for each interface.
- Multiple AP-manager interfaces are not required because only one logical port is visible to the application.

**Note** When you make changes to the LAG configuration, the controller has to be rebooted for the changes to take effect.

**Tip** When you hover your mouse cursor over over the parameter text box, the valid range for that field appears.

### Wireless Management

Because of IPsec operation, management via wireless is only available to operators logging in across WPA, Static WEP, or VPN Pass-through WLANs. Wireless management is not available to clients attempting to log in via an IPsec WLAN.
Mobility Anchor Group Keep Alive Interval

Indicate the delay between tries for clients attempting to join another access point. This decreases the time it takes for a client to join another access point following a controller failure because the failure is quickly identified, the clients are moved away from the problem controller, and the clients are anchored to another controller.

Tip

When you hover your mouse cursor over the parameter text box, the valid range for that field appears.

Configuring Controller System Commands

To view the System Command parameters for current controllers, follow these steps:

Step 1  Choose Configure > Controllers.
Step 2  Click the IP address of the applicable controller.
Step 3  From the left sidebar menu, choose System > Commands. The following parameters appear:
- Administrative
  - Reboot—This command enables you to confirm the restart of your controller after saving your configuration changes. Open and confirm a new session and log into the controller to avoid loosing a system connection.
  - Save Config to Flash—Data is saved to the controller in non-volatile RAM (NVRAM) and is preserved in the event of a power cycle. If the controller is rebooted, all applied changes are lost unless the configuration has been saved.
  - Reset to Factory Default—Choose this command to return the controller to its original settings. See the “Restoring Factory Defaults” section on page 9-31 for more information.
  - Ping From Controller—Send a ping to a network element. This pop-up dialog box allows you to tell the controller to send a ping request to a specified IP address. This is useful for determining if there is connectivity between the controller and a particular IP station. If you click OK, three pings are sent and the results of the ping are displayed in the pop-up. If a reply to the ping is not received, it will show No Reply Received from IP xxx.xxx.xxx.xxx, otherwise it shows Reply received from IP xxx.xxx.xxx.xxx: (send count =3, receive count = n).
- Configuration
  - Audit Config—See the “Viewing the Latest Network Audit Report” section on page 9-20.
  - Refresh Config From Controller—See the “Refreshing the Configuration from the Controller” section on page 9-17.
  - Restore Config To Controller—Choose this command to restore the configuration from the WCS database to the controller.
  - Set System Time—See the “Setting Controller Time and Date” section on page 9-32.
- Upload/Download Commands

Note

Select the FTP or TFTP radio button. Both File Transfer Protocol (FTP) and Trivial Transfer Protocol (TFTP) are supported for uploading and downloading files to and from WCS. In previous software releases, only TFTP was supported.
- Upload File from Controller—See the “Uploading Configuration/Logs from Controllers” section on page 9-32.

- Download Config—See the “Downloading Configurations to Controllers” section on page 9-33.

- Download Software—Choose this command to download software to the selected controller or all controllers in the selected groups after you have a configuration group established. See the “Downloading Software to a Controller” section on page 9-34.

- Download Web Auth Cert—Choose this command to access the Download Web Auth Certificate to Controller page. See the “Downloading a Web Admin Certificate to a Controller” section on page 9-34.

- Download Web Admin Cert—Choose this command to access the Download Web Admin Certificate to Controller page. See the “Downloading a Web Admin Certificate to a Controller” section on page 9-34.

- Download IDS Signatures—Choose this command to download customized signatures to the standard signature file currently on the controller. See the “Downloading Signature Files” section on page 9-106 for more information.

- Download Customized Web Auth—Choose this command to download a customized Web authentication page to the controller. A customized web page is created to establish a username and password for user web access. See the “Downloading a Customized Web Authentication Bundle to a Controller” section on page 9-14.

- Download Vendor Device Certificate—Choose this command to download your own vendor-specific device certificate to the controller to replace the current wireless device certificate. See the “Downloading a Vendor Device Certificate” section on page 9-15.

- Download Vendor CA Certificate—Choose this command to download your own vendor-specific certificate authority (CA) to the controller to replace the current CA. See the “Downloading a Vendor CA Certificate” section on page 9-16.

- RRM Commands
  - RRM 802.11a/n Reset—Resets Remote Radio Management for 802.11a/n Cisco Radios.
  - 802.11b/g/n Reset—Resets Remote Radio Management for 802.11b/g/n Cisco Radios.
  - 802.11a/n Channel Update—Updates access point dynamic channel algorithm for 802.11a/n Cisco Radios.
  - 802.11b/g/n Channel Update—Updates access point dynamic channel algorithm for 802.11b/g/n Cisco Radios.
  - 802.11a/n Power Update—Updates access point dynamic transmit power algorithm for 802.11a/n Cisco Radios.
  - 802.11b/g/n Power Update—Updates access point dynamic transmit power algorithm for 802.11b/g/n Cisco Radios.

---

**Restoring Factory Defaults**

Choose **Configure > Controllers**, and click an IP address in the IP Address column. From the left sidebar menu, choose **System > Commands**, and from the Administrative Commands drop-down list, choose **Reset to Factory Default**, and click **Go** to access this page.
Chapter 9  Configuring Wireless Devices

Configuring Existing Controllers

This command enables you to reset the controller configuration to the factory default. This overwrites all applied and saved configuration parameters. You are prompted for confirmation to re-initialize your controller.

All configuration data files are deleted, and upon reboot, the controller is restored to its original non-configured state. This will remove all IP configuration, and you will need a serial connection to restore its base configuration.

**Note**

After confirming configuration removal, you must reboot the controller and select the “Reboot Without Saving” option.

Setting Controller Time and Date

Choose Configure > Controllers, and click an IP address under the IP Address column. From the left sidebar menu, choose System > Commands, and from the Configuration Commands drop-down list choose Set System Time, and click Go to access this page.

Use this command to manually set the current time and date on the controller. To use a Network Time Server to set or refresh the current time, see the “Configuring an NTP Server Template” section on page 11-9 page. The following parameters appear:

- Current Time—Shows the time currently being used by the system.
- Month/Day/Year—Choose the month/day/year from the drop-down list.
- Hour/Minutes/Seconds—Choose the hour/minutes/seconds from the drop-down list.
- Delta (hours)—Enter the positive or negative hour offset from GMT (Greenwich Mean Time).
- Delta (minutes)—Enter the positive or negative minute offset from GMT.
- Daylight Savings—Select to enable Daylight Savings Time.

**Command Buttons**

- Set Date and Time
- Set Time Zone
- Cancel

Uploading Configuration/Logs from Controllers

To upload files from the controller, follow these steps:

**Step 1** Choose Configure > Controllers.

**Step 2** Click an IP address in the IP Address column.

**Step 3** From the left sidebar menu, choose System > Commands.

**Step 4** From the Upload/Download Commands drop-down list, choose Upload File from Controller.

**Step 5** Click Go to access this page.

Use this command to upload files from your controller to a local TFTP (Trivial File Transfer Protocol) server. The following parameter appears:

- IP Address—IP address of the controller.
Chapter 9  Configuring Wireless Devices

Configuring Existing Controllers

- Status—Upload NOT_INITIATED, or other state.
- Enter the TFTP server name, or New and the new TFTP server name.
- Verify and/or enter the IP Address of the TFTP server.
- Select the file type—Configuration file, Event Log, Message Log, Trap Log, Crash File.
- Enter the Upload to File from /(root)/wcs-tftp/ filename.
- Choose whether or not Cisco WCS saves before backing up the configuration.

**Step 6** Click **OK**. The selected file will be uploaded to your TFTP server and named what you entered in the File Name text box.

**Note**
The Cisco WCS uses an integral TFTP server. This means that third-party TFTP servers cannot run on the same workstation as the Cisco WCS, because the Cisco WCS and the third-party TFTP servers use the same communication port.

---

**Downloading Configurations to Controllers**

To download configuration files, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click an IP address in the IP Address column.

**Step 3** From the left sidebar menu, choose **System > Commands**.

**Step 4** From the Upload/Download Commands drop-down list, choose **Download Config**.

**Step 5** Click **Go** to access this page.

Use this command to download and install a configuration file to your controller from a local TFTP (Trivial File Transfer Protocol) server. The following parameters appear:

**Note**
The Cisco WCS uses an integral TFTP server. This means that third-party TFTP servers cannot run on the same workstation as the Cisco WCS, because the Cisco WCS and the third-party TFTP servers use the same communication port.

- IP Address—IP address of the controller.
- Status—Status of the certificate, for example, NOT_INITIATED.

**TFTP Servers**

- Server Name—Choose Default Server or New from the drop-down list. When you choose New, type in the IP address.
- Server Address—IP address of the server.
- Maximum Retries—How many times to retry if the download fails.
- Timeout—How long to allow between retries.
- File Name—Enter or choose the filename to download by clicking the Browse button.
Chapter 9      Configuring Wireless Devices

Configuring Existing Controllers

Downloading Software to a Controller

To download software, follow these steps:

---

**Step 1**  Choose Configure > Controllers.

**Step 2**  Click an IP address in the IP Address column.

**Step 3**  From the left sidebar menu, choose System > Commands.

**Step 4**  From the Upload/Download Commands drop-down list, choose Download Software.

**Step 5**  Click Go to access this page.

Use this command to download and install a new Operating System software to your controller from a local TFTP (Trivial File Transfer Protocol) server.

---

**Note**  The Cisco WCS uses an integral TFTP server. This means that third-party TFTP servers cannot run on the same workstation as the Cisco WCS, because the Cisco WCS and the third-party TFTP servers use the same communication port.

- **IP Address**—IP address of the controller to receive the software.
- **Current Software Version**—The software version currently running on the controller.
- **Status**—Status of the software, for example, NOT_INITIATED.
- **TFTP Server on Cisco WCS System**—Checkmark to enabled the built-in Cisco WCS TFTP server.
- **Server IP Address**—When you have disabled the built-in Cisco WCS TFTP server, IP Address of the TFTP server to send the software to the controller.
- **Maximum Retries**—Maximum number of unsuccessful attempts before the download is abandoned.
- **Timeout**—Maximum number of seconds before the download is abandoned.
- **File Name**—Enter or select the filename to download using the Browse button.

Downloading a Web Admin Certificate to a Controller

To download a Web Admin Certificate, follow these steps:

---

**Step 1**  Choose Configure > Controllers.

**Step 2**  Click an IP address in the IP Address column.

**Step 3**  From the left sidebar menu, choose System > Commands.

**Step 4**  From the Upload/Download Commands drop-down list, choose Download WEB Admin Cert.

**Step 5**  Click Go to access this page.

This page enables you to download a web administration certificate to the controller. The following parameters appear:

---

**Caution**  Each certificate has a variable-length embedded RSA Key. The RSA key length varies from 512 bits, which is relatively insecure, to thousands of bits, which is very secure. When you are obtaining a new certificate from a certificate authority (such as the Microsoft CA), Make sure the RSA key embedded in the certificate is at least 768 Bits.
• IP Address—IP address of the controller to receive the certificate.
• Status—Status of the certificate, for example, NOT_INITIATED.

**TFTP Servers**

• Server Name—Use the drop-down list to choose the Default Server or New. When you select New, type in the IP address.
• Server Address—IP address of the server.
• Maximum Retries—Maximum number of times each download operation can be attempted.
• Timeout (seconds)—The amount of time allowed for each download operation.
• File Name—File name of the certificate.
• Password—Password to access the certificate.

**Downloading IDS Signatures**

To download IDS Signatures, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Choose Configure &gt; Controllers.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Click an IP address in the IP Address column.</td>
</tr>
<tr>
<td>Step 3</td>
<td>From the left sidebar menu, choose System &gt; Commands.</td>
</tr>
<tr>
<td>Step 4</td>
<td>From the Upload/Download Commands drop-down list, choose Download IDS Signatures.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Click Go to access this page.</td>
</tr>
</tbody>
</table>

Use this command to download IDS (Intrusion Detection System) signature files from your controller to a local TFTP (Trivial File Transfer Protocol) server. The following parameters appear:

• IP Address—IP address of the controller.
• Status—Download NOT_INITIATED, TRANSFER_SUCCESSFUL or other state.

**Downloading a Customized Web Auth Bundle to a Controller**

To download a customized web authentication page to the controller, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Choose Configure &gt; Controllers</td>
</tr>
<tr>
<td>Step 2</td>
<td>Click an IP address in the IP Address column.</td>
</tr>
<tr>
<td>Step 3</td>
<td>From the left sidebar menu, choose System &gt; Commands.</td>
</tr>
<tr>
<td>Step 4</td>
<td>From the Upload/Download Commands drop-down list, choose Download Customized Web Auth.</td>
</tr>
</tbody>
</table>

The following parameters appear:

• IP Address—IP address of the controller to receive the bundle.
• Status—State of download: NOT_INITIATED, TRANSFER_SUCCESSFUL, TRANSFER_FAILED, NOT_RESPONDING.

Before downloading the customized Web authentication bundle, follow these steps:
Step 1  Click the indicated link to download the example login.tar bundle file from the server.
The link is the highlighted word “here” near the bottom of the page.

Step 2  Edit the login.html file and save it as a .tar or .zip file.

Step 3  Download the .tar or .zip file to the controller.
The file contains the pages and image files required for the web authentication display.

Note  The controller accepts a .tar or .zip file of up to 1 MB in size. The 1 MB limit includes the total size of uncompressed files in the bundle.

TFTP Servers

To set up one or more TFTP servers, configure the following parameters:

- File is located on—Choose Local machine or TFTP server. The default is local machine (WCS internal server).
- Server Name—Use the drop-down list to choose one of the following:
  - New—Set up a new server. Enter the server name and IP address in the text boxes provided.
  - Default Server—server name (editable) IP address (read-only) are automatically added.
- Server IP Address—IP address of the server.
- Maximum Retries—Maximum number of unsuccessful attempts before the download is abandoned.
- Timeout—Maximum number of seconds before the download is abandoned.
- WCS Server Files In—C:\tftp or other specified file directory on the local machine.
- Local File Name—Filename of the Web authentication bundle on the local machine. Click Browse to locate the file.
- Server File Name—Filename on a remote TFTP server.

When completed, these fields and settings are repopulated in the page and do not need to be entered again.

Command Buttons

- OK—The file is downloaded from the local machine or TFTP server with the name shown in the File Name text box.
- Cancel

Configuring Controller System Interfaces

This section describes how to configure controller system interfaces and contains the following topics:

- Adding an Interface, page 9-37
- Viewing Current Interface Details, page 9-38
- Deleting a Dynamic Interface, page 9-39
- NAC Out-of-Band Integration, page 9-42
- Configuring Wired Guest Access, page 9-44
To view existing interfaces, follow these steps:

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Choose <strong>Configure &gt; Controllers</strong>.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Click the IP address of the applicable controller.</td>
</tr>
</tbody>
</table>
| Step 3 | From the left sidebar menu, choose **System > Interfaces**. The following parameters appear:
- Check box—Select the dynamic interface for deletion. Choose **Delete Dynamic Interfaces** from the Select a command drop-down list.
- Interface Name—User-defined name for this interface (For example, Management, Service-Port, Virtual).
- VLAN Identifier—VLAN identifier between 0 (untagged) and 4096, or N/A.
- Quarantine—Select the check box if the interface has a quarantine VLAN ID configured on it.
- IP Address—IP address of this interface.
- Interface Type—Static (Management, AP-Manager, Service-Port, and Virtual interfaces) or Dynamic (operator-defined interfaces).
- AP Management Status—Displays the status of AP Management interfaces. The parameters include Enabled, Disabled, and N/A.

**Adding an Interface**

To add an interface, follow these steps:

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Choose <strong>Configure &gt; Controllers</strong>.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Click the IP address of the applicable controller.</td>
</tr>
<tr>
<td>Step 3</td>
<td>From the Select a command drop-down list, choose <strong>Add Interface</strong>.</td>
</tr>
</tbody>
</table>
| Step 5 | Enter the necessary parameters:
- Interface Name—User-defined name for this interface (Management, Service-Port, Virtual, and VLAN n).
- Wired Interface—Select the check box to mark the interface as wired.
- Interface Address
  - VLAN Identifier—1 through 4096, or 0 = untagged.
  - Quarantine—Enable/disable to quarantine a VLAN. Select the check box to enable.
  - IP Address—IP address of the interface.
  - Gateway—Gateway address of the interface.
- Physical Information
  - Port Number—The port that is used by the interface.
  - Primary Port Number (active)—The port that is currently used by the interface.
  - Secondary Port Number—The port that is used by the interface when the primary port is down.
Configuring Existing Controllers

Note
Primary and secondary port numbers are only present in Cisco 4400 Series Wireless LAN Controllers.

Note
The secondary port is used when the primary port shuts down. When the primary port is reactivated, the Cisco 4400 Series Wireless LAN Controller transfers the interfaces back to the primary port.

- AP Management—Select to enable access point management.

- DHCP Information
  - Primary DHCP Server—IP address of the primary DHCP server.
  - Secondary DHCP Server—IP address of the secondary DHCP server.

- Access Control List—User-defined ACL name (or none).

Viewing Current Interface Details

To view details for a current interface, follow these steps:

Step 1
Choose Configure > Controllers.

Step 2
Click the IP address of the applicable controller.

Step 3
From the left sidebar menu, choose System > Interfaces.

Step 4
Select the Interface Name for the applicable interface. The Interface Details page opens.

Step 5
View or edit the following interface parameters:

Note
Changing the Interface parameters causes the WLANs to be temporarily disabled and thus may result in loss of connectivity for some clients.

- Interface Address
  - VLAN Identifier—1 through 4096, or 0 = untagged.
  - Guest LAN
  - Quarantine—Enable/disable to quarantine a VLAN. Select the check box to enable.
  - IP Address—IP address of the interface.
  - Gateway—Gateway address of the interface.

- Physical Information
  - Primary Port Number (active)—The port that is currently used by the interface.
  - Secondary Port Number—The port that is used by the interface when the primary port is down.

Note
Primary and secondary port numbers are only present in Cisco 4400 Series Wireless LAN Controllers.
Chapter 9       Configuring Wireless Devices

Configuring Existing Controllers

Note
The secondary port is used when the primary port shuts down. When the primary port is reactivated, the Cisco 4400 Series Wireless LAN Controller transfers the interfaces back to the primary port.

- AP Management—Select to enable access point management.
- DHCP Information
  - Primary DHCP Server—IP address of the primary DHCP server.
  - Secondary DHCP Server—IP address of the secondary DHCP server.
- Access Control List
  - ACL Name—User-defined name of the access control list (or none).

Step 6
Click Save to confirm any changes made. Click Audit to audit the device values.

Deleting a Dynamic Interface

To delete a dynamic interface, follow these steps:

Step 1
Choose Configure > Controllers.

Step 2
Click the IP address of the applicable controller.

Step 3
From the left sidebar menu, choose System > Interfaces.

Step 4
Select the check box of the dynamic interface that you want to delete.

Step 5
From the Select a command drop-down list, choose Delete Dynamic Interfaces.

Step 6
Click OK to confirm the deletion.

Note
The dynamic interface cannot be deleted if it is been assigned to interface group.

Configuring Controller System Interface Groups

This section describes how to configure controller system interface groups and introduces the following topics:

- Adding an Interface Group, page 9-39
- Deleting an Interface Group, page 9-40
- Viewing Interface Groups, page 9-41

Adding an Interface Group

To add an interface group, follow these steps:
Configuring Existing Controllers

Step 1  Choose Configure > Controllers.
Step 2  Click the IP address of the applicable controller.
Step 3  From the left sidebar menu, choose System > Interface Groups.
Step 4  From the Select a command drop-down list, choose Add Interface Group.
Step 5  Enter the necessary parameters:
   • Name—User-defined name for this interface group (group1, group2).
   • Interface Group Type—Select/deselect to quarantine a VLAN.
   • Description—(Optional) Description for the Interface group.
Step 6  Click Add.
   The Interface dialog box appears.
Step 7  Select the interfaces that you want to add to the group, and click OK.
   To remove an Interface from the Interface group, from the Interface Group page, select the Interface and click Remove.
Step 8  Once you are done with adding the interfaces in the Interface Group page, click any of these buttons:
   • Save to confirm any changes made.
   • Audit to audit the device values.
   • Cancel to discard the changes.

Note
   • The number of interfaces that could be added to an interface group depends upon the type of the controller.
   • Guest LAN interfaces cannot be part of interface groups.
   • An Interface group name must be different from the Interface name.

Related Topics
   • Adding an Interface
   • Viewing Current Interface Details
   • Deleting a Dynamic Interface
   • Deleting an Interface Group
   • Viewing Interface Groups
   • Adding an Interface Group

Deleting an Interface Group

To delete an interface group, follow these steps:

Step 1  Choose Configure > Controllers.
Step 2  Click the IP address of the applicable controller.
Step 3  From the left sidebar menu, choose System > Interface Groups.
Step 4  Select the check box of the interface group that you want to delete.

Step 5  From the Select a command drop-down list, choose **Delete Interface Group**, and click **Go**.

Step 6  Click **OK** to confirm the deletion.

**Note**

- The Interface Group cannot be deleted if it has been assigned to WLAN(s).
- The Interface Group cannot be deleted if it has been assigned to AP Group(s).
- The Interface Group cannot be deleted if it has been assigned to Foreign Controller Mapping for the WLAN(s).
- The Interface Group Template cannot be deleted if it has been assigned to WLAN Template(s).
- The Interface Group Template cannot be deleted if it has been assigned to AP Group Template(s).
- You cannot enable/disable quarantine for an interface if it has been assigned to an interface group.

**Related Topics**

- Adding an Interface
- Viewing Current Interface Details
- Deleting a Dynamic Interface
- Configuring Controller System Interface Groups
- Viewing Interface Groups
- Adding an Interface Group

**Viewing Interface Groups**

To view existing interface groups, follow these steps:

**Step 1**  Choose **Configure > Controllers**.

**Step 2**  Click the IP address of the applicable controller.

**Step 3**  From the left sidebar menu, choose **System > Interface Groups**. The following parameters appear:

- **Name**—User-defined name for the interface group (For example, group1, group2).
- **Description**—(Optional) Description for the Interface Group.
- **Interfaces**—Count of the number of interfaces belonging to the group.

**Step 4**  Click the Interface group name link.

The Interface Groups Details page appears with the Interface group details as well as the details of the Interfaces that form part of that particular Interface group.

**Related Topics**

- Adding an Interface
- Viewing Current Interface Details
NAC Out-of-Band Integration

The Cisco NAC appliance, also known as Cisco Clean Access (CCA), is a network admission control (NAC) product that allows network administrators to authenticate, authorize, evaluate, and remediate wired, wireless, and remote users and their machines prior to allowing users onto the network. It identifies whether machines are compliant with security policies and repairs vulnerabilities before permitting access to the network. The NAC appliance is available in two modes: in-band and out-of-band. Customers can deploy both modes if desired, each geared toward certain types of access (in-band for supporting wireless users and out-of-band for supporting wired users, for example).

For more information on NAC Out-of-Band Integration, see the applicable section in the Cisco Wireless Control System Configuration Guide.

Guidelines for Using NAC Out-of-Band Integration

Follow these guidelines when using NAC out-of-band integration:

- The NAC appliance supports up to 3500 users, and the controller supports up to 5000 users. Therefore, multiple NAC appliances might need to be deployed.
- Because the NAC appliance supports static VLAN mapping, you must configure a unique quarantine VLAN for each interface configured on the controller. For example, you might configure a quarantine VLAN of 110 on controller 1 and a quarantine VLAN of 120 on controller 2. However, if two WLANs or guest LANs use the same distribution system interface, they must use the same quarantine VLAN, provided they have one NAC appliance deployed in the network. The NAC appliance supports unique quarantine-to-access VLAN mapping.
- For posture reassessment based on session expiry, you must configure the session timeout on both the NAC appliance and the WLAN, making sure that the session expiry on the WLAN is greater than that on the NAC appliance.
- When a session timeout is configured on an open WLAN, the timing out of clients in the Quarantine state is determined by the timer on the NAC appliance. Once the session timeout expires for WLANs using web authentication, clients deauthenticate from the controller and must perform posture validation again.
- NAC out-of-band integration is supported only on WLANs configured for hybrid-REAP central switching. It is not supported for use on WLANs configured for hybrid-REAP local switching.
- If you want to enable NAC on an access point group VLAN, you must first enable NAC on the WLAN. Then you can enable or disable NAC on the access point group VLAN. If you ever decide to disable NAC on the WLAN, be sure to disable it on the access point group VLAN as well.
- NAC out-of-band integration is not supported for use with the WLAN AAA override feature.
- All Layer 2 and Layer 3 authentication occurs in the quarantine VLAN. To use external web authentication, you must configure the NAC appliance to allow HTTP traffic to and from external web servers and to allow the redirect URL in the quarantine VLAN.
Configuring NAC Out-of-Band Integration

To configure NAC out-of-band integration, follow these steps:

**Step 1** To configure the quarantine VLAN for a dynamic interface, follow these steps:

a. Choose Configure > Controller.

b. Choose which controller you are configuring for out-of-band integration by clicking it in the IP Address column.

c. Choose System > Interfaces from the left sidebar menu.

d. Choose Add Interface from the Select a command drop-down list.

e. In the Interface Name text box, enter a name for this interface, such as “quarantine.”

f. In the VLAN Identifier text box, enter a non-zero value for the access VLAN ID, such as “10.”

g. Select the Quarantine check box if the interface has a quarantine VLAN ID configured on it.

h. Configure any remaining fields for this interface, such as the IP address, netmask, and default gateway.

i. Enter an IP address for the primary and secondary DHCP server.

j. Click Save. You are now ready to create a NAC-enabled WLAN or Guest LAN.

**Step 2** To configure NAC out-of-band support on a WLAN or guest LAN, follow these steps:

a. Choose WLANs > WLAN from the left sidebar menu.

b. Choose Add a WLAN from the Select a command drop-down list and click Go.

c. If you have a template established that you want to apply to this controller, choose the guest LAN template name from the drop-down list. Otherwise, click the click here link to create a new template. For more information on setting up the template, see the “Configuring Wired Guest Access” section on page 9-44 section.

d. Click the Advanced tab.

e. To configure NAC out-of-band support for this WLAN or guest LAN, select the NAC Support check box. To disable NAC out-of-band support, leave the check box unselected, which is the default value.

f. Click Apply to commit your changes.
Step 3 To configure NAC out-of-band support for a specific AP group, follow these steps:

a. Choose **WLANs > AP Groups VLAN** from the left sidebar menu to open the AP Groups page.

| Note | AP Groups (for 5.2 and later controllers) is referred to as **AP Group VLANs** for controllers prior to 5.2. |

b. Click the name of the desired AP group.

c. From the Interface Name drop-down list, choose the quarantine enabled interface.

d. To configure NAC out-of-band support for this AP group, select the **NAC Support** check box. To disable NAC out-of-band support, leave the check box unselected, which is the default value.

e. Click **Apply** to commit your changes.

Step 4 To see the current state of the client (either Quarantine or Access), follow these steps:

a. Choose **Monitor > Clients** to open the Clients. Perform a search for Clients.

b. Click the MAC address of the desired client to open the Clients > Detail page. The NAC state appears as access, invalid, or quarantine in the Security Information section.

---

**Configuring Wired Guest Access**

Wired Guest Access enables guest users to connect to the guest access network from a wired Ethernet connection designated and configured for guest access. Wired guest access ports might be available in a guest office or specific ports in a conference room.

Like wireless guest user accounts, wired guest access ports are added to the network using the Lobby Ambassador feature. See the “Configuring a Guest Account” section on page 16-70.

Wired Guest Access can be configured in a standalone configuration or in a dual controller configuration employing an anchor and foreign controller. This latter configuration is used to further isolate wired guest access traffic but is not required for deployment of wired guest access.

Wired Guest Access ports initially terminate on a Layer 2 access switch or switch port which is configured with VLAN interfaces for wired guest access traffic.

The wired guest traffic is then trunked from the access switch to a wireless LAN controller. This controller is configured with an interface that is mapped to a wired guest access VLAN on the access switch.

If two controllers are being used, the controller (foreign) that receives the wired guest traffic from the switch then forwards the wired guest traffic to an anchor controller that is also configured for wired guest access. After successful hand off of the wired guest traffic to the anchor controller, a bidirectional Ethernet over IP (EoIP) tunnel is established between the foreign and anchor controllers to handle this traffic.

| Note | Although wired guest access is managed by anchor and foreign anchors when two controllers are deployed, mobility is not supported for wired guest access clients. In this case, DHCP and web authentication for the client are handled by the anchor controller. |
Note You can specify how much bandwidth a wired guest user is allocated in the network by configuring and assigning a role and bandwidth contract. For details on configuring these features, see the “Configuring a Guest Account” section on page 16-70.

To configure and enable wired guest user access on the network, follow these steps:

**Step 1** To configure a dynamic interface for wired guest user access, choose Configure > Controllers and after IP address, choose System > Interfaces.

**Step 2** Choose Add Interface from the Select a command drop-down list, and click Go.

**Step 3** Enter a name and VLAN ID for the new interface.

**Step 4** Select the Guest LAN check box.

**Step 5** Enter the primary and secondary port number.

**Step 6** Click Save. You are now ready to create a wired LAN for guest access.

**Step 7** To configure a wired LAN for guest user access, choose WLANs > WLAN configuration from the left sidebar menu.

**Step 8** Choose Add a WLAN from the Select a command drop-down list, and click Go.

**Step 9** If you have a template established that you want to apply to this controller, choose the guest LAN template name from the drop-down list. Otherwise, click the click here link to create a new template.

**Step 10** In the WLAN > New Template general page, enter a name in the Profile Name text box that identifies the guest LAN. Do not use any spaces in the name entered.

**Step 11** Select the Enabled check box for the WLAN Status parameter.

**Step 12** From the Ingress Interface drop-down list, choose the VLAN that you created in Step 3. This VLAN provides a path between the wired guest client and the controller by way of the Layer 2 access switch.

**Step 13** From the Egress Interface drop-down list, choose the name of the interface. This WLAN provides a path out of the controller for wired guest client traffic.

Note If you have only one controller in the configuration, choose management from the Egress Interface drop-down list.

**Step 14** Choose Security > Layer 3 tab to modify the default security policy (web authentication) or to assign WLAN specific web authentication (login, logout, login failure) pages and the server source.

a. To change the security policy to passthrough, select the Web Policy check box and select the Passthrough radio button. This option allows users to access the network without entering a username or password.

An Email Input check box appears. Select this check box if you want users to be prompted for their email address when attempting to connect to the network.

b. To specify custom web authentication pages, unselect the Global WebAuth Configuration Enabled check box.

When the Web Auth Type drop-down list appears, choose one of the following options to define the web login page for the wireless guest users:

Default Internal—Displays the default web login page for the controller. This is the default value.
Customized Web Auth—Displays custom web login, login failure, and logout pages. When the customized option is selected, three separate drop-down lists for login, login failure, and logout page selection appear. You do not need to define a customized page for all three of the options. Choose None from the appropriate drop-down list if you do not want to display a customized page for that option.

These optional login, login failure, and logout pages are downloaded to the controller as webauth.tar files. For specifics on downloading custom pages, see the “Downloading a Customized WebAuthentication Bundle to a Controller” section on page 9-14.

External—Redirects users to an external server for authentication. If you choose this option, you must also enter the URL of the external server in the URL text box.

You can select specific RADIUS or LDAP servers to provide external authentication in the Security > AAA pane. To do so, continue with Step 17.

**Note** The RADIUS and LDAP external servers must be already configured to have selectable options in the Security > AAA pane. You can configure these servers on the RADIUS Authentication Servers, TACACS+ Authentication Servers page, and LDAP Servers page.

**Step 15** If you selected External as the Web Authentication Type in Step 15, choose Security > AAA and choose up to three RADIUS and LDAP servers using the drop-down lists.

**Step 16** Click Save.

**Step 17** Repeat this process if a second (anchor) controller is being used in the network.

---

**Creating an Ingress Interface**

To create an Ingress interface, follow these step:

**Step 1** Choose Add Interface from the Select a command drop-down list, and click Go.

**Step 2** Click an interface name. The Interfaces Details : New Config page appears (see Figure 9-2).
Step 3  In the Interface Name text box, enter a name for this interface, such as guestinterface.

Step 4  Enter a VLAN identifier for the new interface.

Step 5  Select the Guest LAN check box.

Step 6  Enter the primary and secondary port numbers.

Step 7  Click Save.

Creating an Egress Interface

To create an Egress interface, follow these steps:

Step 1  Choose Add Interface from the Select a command drop-down list, and click Go.

Step 2  Click an interface name. The Interfaces Details : New Config page appears (see Figure 9-2).

Step 3  In the Interface Name text box, enter a name for this interface, such as quarantine.

Step 4  In the VLAN Identifier text box, enter a non-zero value for the access VLAN ID, such as 10.

Step 5  Select the Quarantine check box and enter a non-zero value for the quarantine VLAN ID, such as 110.
### Configuring Existing Controllers

**Note**  
You can have NAC-support enabled on the WLAN or guest WLAN template Advanced tab for interfaces with Quarantine enabled.

**Step 6**  
Enter the IP address, netmask, and default gateway.

**Step 7**  
Enter the primary and secondary port numbers.

**Step 8**  
Provide an IP address for the primary and secondary DHCP server.

**Step 9**  
Configure any remaining fields for this interface, and click **Save**.

You are now ready to create a wired LAN for guest access.

### Configuring Controller Network Routes

The Network Route page enables you to add a route to the controller service port. This route allows you to direct all Service Port traffic to the designated management IP address.

- Viewing Existing Network Routes, page 9-48
- Adding a Network Route, page 9-48

### Viewing Existing Network Routes

To view existing network routes, follow these steps:

**Step 1**  
Choose **Configure > Controllers**.

**Step 2**  
Click the IP address of the applicable controller.

**Step 3**  
From the left sidebar menu, choose **System > Network Route**. The following parameters appear:

- **IP Address**—The IP address of the network route.
- **IP Netmask**—Network mask of the route.
- **Gateway IP Address**—Gateway IP address of the network route.

### Adding a Network Route

To add a network route, follow these steps:

**Step 1**  
Choose **Configure > Controllers**.

**Step 2**  
Click the IP address of the applicable controller.

**Step 3**  
From the left sidebar menu, choose **System > Network Route**.

**Step 4**  
From the Select a command drop-down list, choose **Add Network Route**.

**Step 5**  
Click **Go**.

**Step 6**  
Enter the IP address, IP Netmask, and Gateway IP address information.
Step 7 Click Save.

Configuring Controller Spanning Tree Protocol Parameters

Spanning Tree Protocol (STP) is a link management protocol that provides path redundancy while preventing undesirable loops in the network.

To view or manage current STP parameters, follow these steps:

- **Step 1** Choose Configure > Controllers.
- **Step 2** Click the IP address of the applicable controller.
- **Step 3** From the left sidebar menu, choose System > Spanning Tree Protocol. The Spanning Tree Protocol page displays the following parameters:
  - Protocol Spec—The current protocol specification.
  - Admin Status—Select this check box to enable.
  - Priority—The numerical priority number of the ideal switch.
  - Maximum Age (seconds)—The amount of time (in seconds) before the received protocol information recorded for a port is discarded.
  - Hello Time (seconds)—Determines how often (in seconds) the switch broadcasts its hello message to other switches.
  - Forward Delay (seconds)—The time spent (in seconds) by a port in the learning/listening states of the switches.

Configuring Controller Mobility Groups

By creating a mobility group, you can enable multiple network controllers to dynamically share information and forward data traffic when inter-controller or inter-subnet roaming occurs. Controllers can share the context and state of client devices and controller loading information. With this information, the network can support inter-controller wireless LAN roaming and controller redundancy.

**Note**

If it is possible for a wireless client in your network to roam from an access point joined to one controller to an access point joined to another controller, both controllers should be in the same mobility group.

- Messaging Among Mobility Groups, page 9-50
- Mobility Group Prerequisites, page 9-50
- Viewing Current Mobility Group Members, page 9-50
- Adding Mobility Group Members from a List of Controllers, page 9-50
- Manually Adding Mobility Group Members, page 9-51
- Setting the Mobility Scalability Parameters, page 9-51
Messaging Among Mobility Groups

The controller provides inter-subnet mobility for clients by sending mobility messages to other member controllers:

- There can be up to 72 members in the list with up to 24 in the same mobility group.
- The controller sends a Mobile Announce message to members in the mobility list each time a new client associates to it.
- In WCS and controller software release 5.0, the controller uses multicast mode to send the Mobile Announce messages. This allows the controller to send only one copy of the message to the network, which delivers it to the multicast group containing all the mobility members.

For more information regarding mobility groups, see the Cisco Wireless Control System Configuration Guide.

Mobility Group Prerequisites

Before you add controllers to a mobility group, you must verify that the following requirements have been met for all controllers that are to be included in the group:

- All controllers must be configured for the same CAPWAP transport mode (Layer 2 or Layer 3).
- IP connectivity must exist between the management interfaces of all devices.
- All controllers must be configured with the same mobility group name.
- All devices must be configured with the same virtual interface IP address.
- Availability of MAC and IP addresses of each controller to be included in the mobility group (to configure the controllers with the MAC address and IP address of all the other mobility group members).

Viewing Current Mobility Group Members

To view current mobility group members, follow these steps:

Step 1 Choose Configure > Controllers.
Step 2 Click the IP address of the applicable controller.
Step 3 From the left sidebar menu, choose System > Mobility Groups.

To delete a group member, select a check box for the applicable group member, choose Delete Group Members, and click Go.

Adding Mobility Group Members from a List of Controllers

To add a mobility group member from a list of existing controllers, follow these steps:

Step 1 Choose Configure > Controllers.
Step 2 Click the IP address of the applicable controller.
Step 3 From the left sidebar menu, choose **System > Mobility Groups**.

Step 4 From the Select a command drop-down list, choose **Add Group Members**.

Step 5 Click **Go**.

Step 6 Select the check box(es) for the controller to be added to the mobility group.

Step 7 Click **Save**.

---

**Manually Adding Mobility Group Members**

If no controllers were found to add to the mobility group, you can add members manually. To manually add members to the mobility group, follow these steps:

Step 1 Click the **click here** link from the Mobility Group Member details page.

Step 2 In the Member MAC Address text box, enter the MAC address of the controller to be added.

Step 3 In the Member IP Address text box, enter the management interface IP address of the controller to be added.

**Note** If you are configuring the mobility group in a network where Network Address Translation (NAT) is enabled, enter the IP address sent to the controller from the NAT device rather than the controller management interface IP address. Otherwise, mobility fails among controllers in the mobility group.

Step 4 Enter the multicast group IP address to be used for multicast mobility messages in the Multicast Address text box. The local mobility member group address must be the same as the local controller group address.

Step 5 In the Group Name text box, enter the name of the mobility group.

Step 6 Click **Save**.

Step 7 Repeat the Steps 1 through 6 for the remaining WLC devices.

---

**Setting the Mobility Scalability Parameters**

**Note** Mobility Groups must be configured prior to setting the mobility scalability parameters.

To set the mobility message parameters, follow these steps:

Step 1 Choose **Configure > Controllers**.

Step 2 Choose an IP address of a controller whose software version is 5.0 or later.

Step 3 From the left sidebar menu, choose **System > General**.

Step 4 At the Multicast Mobility Mode parameter, specify if you want to enable or disable the ability for the controller to use multicast mode to send Mobile Announce messages to mobility members.
Step 5  If you enabled multicast messaging by setting multicast mobility mode to enabled, you must enter the
group IP address at the Mobility Group Multicast-address parameter to begin multicast mobility
messaging. You must configure this IP address for the local mobility group but it is optional for other
groups within the mobility list. If you do not configure the IP address for other (non-local) groups, the
controllers use unicast mode to send mobility messages to those members.

Step 6  Click Save.

Configuring Controller Network Time Protocol

To add a new NTP Server, follow these steps:

Step 1  Choose Configure > Controllers.
Step 2  Click the IP address of the applicable controller.
Step 3  From the left sidebar menu, choose System > Network Time Protocol.
Step 4  From the Select a command drop-down list, choose Add NTP Server.
Step 5  Click Go.
Step 6  From the Select a template to apply to this controller drop-down list, select the applicable template to
apply to this controller.

Command Buttons

- Apply
- Cancel

To create a New Template for NTP Servers, use the click here link to access the template creation page
(Configure NTP Servers > New Template).

NTP general parameters include:

- Template Name—Enter the new NTP Template name.

  Note  Template Name is the unique key used to identify the template. A template name is
  mandatory to distinguish between two templates that have identical key attributes.

- Server Address—Enter the NTP server IP address.
- No. of Controllers Applied To—Number of controllers to which this template is applied (read-only).

Background Scanning on 1510s in Mesh Networks

Background scanning allows Cisco Aironet 1510 Access Points to actively and continuously monitor
neighboring channels for more optimal paths and parents. Because the access points are searching on
neighboring channels as well as the current channel, the list of optimal alternate paths and parents is
greater.
Identifying this information prior to the loss of a parent results in a faster transfer and the best link possible for the access points. Additionally, access points might switch to a new channel if a link on that channel is found to be better than the current channel in terms of fewer hops, stronger signal-to-noise ratio (SNR), and so on.

Background scanning on other channels and data collection from neighbors on those channels are performed on the primary backhaul between two access points:

The primary backhaul for 1510s operate on the 802.11a link.

Background scanning is enabled on a global basis on the access point’s associated controller.

---

**Note**

Latency might increase for voice calls when they are switched to a new channel.

**Note**

In the EMEA regulatory domain, locating neighbors on other channels might take longer given DFS requirements.

### Background Scanning Scenarios

A few scenarios are provided below to better illustrate how background scanning operates.

In **Figure 9-3**, when the mesh access point (MAP1) initially comes up, it is aware of both root access points (RAP1 and RAP2) as possible parents. It chooses RAP2 as its parent because the route through RAP2 is better in terms of hops, SNR, and so on. After the link is established, background scanning (once enabled) continuously monitors all channels in search of a more optimal path and parent. RAP2 continues to act as parent for MAP1 and communicates on channel 2 until either the link goes down or a more optimal path is located on another channel.

**Figure 9-3  Mesh Access Point (MAP1) Selects a Parent**

In **Figure 9-4**, the link between MAP1 and RAP2 is lost. Data from ongoing background scanning identifies RAP1 and channel 1 as the next best parent and communication path for MAP1 so that link is established immediately without the need for additional scanning after the link to RAP2 goes down.
Enabling Background Scanning

To enable background scanning on an AP1510 RAP or MAP, follow these steps:

---

**Step 1**  Click Configure > Controllers.

**Note**  You can also enable this on the Controllers template. See the “Configuring Mesh Templates” section on page 11-129.

**Step 2**  Choose Mesh > Mesh Settings from the left sidebar menu. The Mesh Settings page appears (see Figure 9-5).

---

*Figure 9-5  Mesh Settings Page*
Step 3 Select the **Background Scanning** check box to enable background scanning or unselect it to disable the feature. The default value is disabled.

Step 4 Click **Save**.

### Configuring Controller QoS Profiles

To make modifications to the quality of service profiles, follow these steps:

Step 1 Choose **Configure > Controllers**.

Step 2 Click the IP address of the applicable controller.

Step 3 From the left sidebar menu, choose **System > QoS Profiles**. The following parameters appear:

- **Bronze**—For Background
- **Gold**—For Video Applications
- **Platinum**—For Voice Applications
- **Silver**—For Best Effort

Step 4 Click the applicable profile to view or edit profile parameters.

Step 5 Set the following values in the Per-User Bandwidth Contracts section (all have a default of 0 or Off):

- **Average Data Rate**—The average data rate for non-UDP traffic.
- **Burst Data Rate**—The peak data rate for non-UDP traffic.
- **Average Real-time Rate**—The average data rate for UDP traffic.
- **Burst Real-time Rate**—The peak data rate for UDP traffic.

Step 6 Set the following values for the Over-the-Air QoS section:

- **Maximum QoS RF Usage Per AP (%)**—The maximum air bandwidth available to clients. The default is 100%.
• QoS Queue Depth—The depth of queue for a class of client. The packets with a greater value are dropped at the access point.

Step 7  Set the following values in the Wired QoS Protocol section:
• Wired QoS Protocol—Choose 802.1P to activate 802.1P priority tags or None to deactivate 802.1P priority tags.

Step 8  Click Save.

## Configuring Controller DHCP Scopes

• Viewing Current DHCP Scopes, page 9-56
• Adding a New DHCP Scope, page 9-56

### Viewing Current DHCP Scopes

To view current DHCP (Dynamic Host Configuration Protocol) scopes, follow these steps:

Step 1  Choose Configure > Controllers.
Step 2  Click the IP address of the applicable controller.
Step 3  From the left sidebar menu, choose System > DHCP Scopes.

The following DHCP Scopes information appears:
• Pool Address
• Lease Time
• Status

### Adding a New DHCP Scope

To add a new DHCP Scope, follow these steps:

Step 1  Choose Configure > Controllers.
Step 2  Click the IP address of the applicable controller.
Step 3  From the left sidebar menu, choose System > DHCP Scopes.
Step 4  From the Select a command drop-down list, choose Add DHCP Scope.
Step 5  Enter the following information:
• Scope Name
• Lease Time (in seconds)
• Network
• Netmask
• Pool Start Address
• Pool End Address
- DNS Domain Name
- Status
- Router Addresses—Enter which IP addresses are already in use and should therefore be excluded. For example, you should enter the IP address of your company router. In doing so, this IP address will be blocked from use by another client.
- DNS Servers—Enter the IP address of the DNS server(s). Each DNS server must be able to update a client DNS entry to match the IP address assigned by this DHCP scope.
- NetBIOS Servers—Enter the IP address of the Microsoft Network Basic Input Output System (NetBIOS) name server(s), such as a Windows Internet Naming Service (WINS) server.

Step 6  Click Save.

Configuring Controller User Roles

- Viewing Current Local Net User Roles, page 9-57
- Adding a New Local Net User Role, page 9-57

Viewing Current Local Net User Roles

To view current local net user roles, follow these steps:

Step 1  Choose Configure > Controllers.

Step 2  Click the IP address of the applicable controller.

Step 3  From the left sidebar menu, choose System > User Roles.

The following Local Net User Role parameters appear:

- Template Name

  Note  Template Name is the unique key used to identify the template. A template name is mandatory to distinguish between two templates that have identical key attributes.

- Role Name
- Average Data Rate—The average data rate for non-UDP traffic.
- Burst Data Rate—The peak data rate for non-UDP traffic.
- Average Real-time Rate—The average data rate for UDP traffic.
- Burst Real-time Rate—The peak data rate for UDP traffic.

Step 4  Click a Template Name to view the User Role details.

Adding a New Local Net User Role

To add a new local net user role, follow these steps:

Step 1  Choose Configure > Controllers.
Configuring Existing Controllers

Chapter 9      Configuring Wireless Devices

Configuring Existing Controllers

Step 2  Click the IP address of the applicable controller.
Step 3  From the left sidebar menu, choose System > User Roles.
Step 4  From the Select a command drop-down list, choose Add User Role.
Step 5  Select a template from the Select a template to apply to this controller drop-down list.
Step 6  Click Apply.

Note  To create a new template for local net user roles, click the click here link to access the template creation page. See the “Configuring User Roles Controller Templates” section on page 11-10 for more information about User Role templates.

Configuring a Global Access Point Password

The AP Username Password page enables you to set a global password that all access points inherit as they join a controller. When you are adding an access point, you can also choose to accept this global username and password or override it on a per-access point basis. See the “Configuring AP Configuration Templates” section on page 11-143 to view where the global password is displayed and how it can be overridden on a per-access point basis.

Also in controller software release 5.0, after an access point joins the controller, the access point enables console port security and you are prompted for your username and password whenever you log into the access point console port. When you log in, you are in non-privileged mode and you must enter the enable password to use the privileged mode.

To establish a global username and password, follow these steps:

Step 1  Choose Configure > Controllers.
Step 2  Click an IP address of a controller with a version of 5.0 or later.
Step 3  From the left sidebar menu, choose System > AP Username Password.
Step 4  Enter the username and password that you want to be inherited by all access points that join the controller.

Note  For Cisco IOS access points, you must also enter and confirm an enable password.
Step 5  Click Save.

Configuring Global CDP

Cisco Discovery Protocol (CDP) is a device-discovery protocol that runs on all Cisco network equipment. Each device sends identifying messages to a multicast address, and each device monitors the messages sent by other devices.

Note  CDP is enabled on the bridge's Ethernet and radio ports by default.
Configuring Existing Controllers

To configure a Global CDP, follow these steps:

**Step 1** Choose Configure > Controllers.

**Step 2** Choose the IP address of the desired controller.

**Step 3** From the left sidebar menu, choose System > Global CDP Configuration from the left sidebar menu. The Global CDP Configuration page appears.

**Step 4** In the Global CDP portion of the page, specify the following parameters:
- CDP on controller—Choose enable or disable CDP on the controller.
  
  **Note** This configuration cannot be applied on WISM2 controllers.

- Global CDP on APs—Choose to enable or disable CDP on the access points.
- Refresh-time Interval (seconds)—At the Refresh Time Interval parameter, enter the time in seconds at which CDP messages are generated. The default is 60.
- Holdtime (seconds)—Enter the time in seconds before the CDP neighbor entry expires. The default is 180.
- CDP Advertisement Version—Enter which version of the CDP protocol to use. The default is v1.

**Step 5** In the CDP for Ethernet Interfaces portion of the page, select the slots of Ethernet interfaces for which you want to enable CDP.

  **Note** CDP for Ethernet Interfaces fields are supported for controller version 7.0.110.2 onwards.

**Step 6** In the CDP for Radio Interfaces portion of the page, select the slots of Radio interfaces for which you want to enable CDP.

  **Note** CDP for Radio Interfaces fields are supported for controller version 7.0.110.2 onwards.

**Step 7** Click Save.

### Configuring AP 802.1X Supplicant Credentials

You can configure 802.1X authentication between lightweight access points and the switch. The access point acts as an 802.1X supplicant and is authenticated by the switch using EAP-FAST with anonymous PAC provisioning. You can set global authentication settings that all access points inherit as they join the controller. This includes all access points that are currently joined to the controller and any that join in the future.

If desired, you can override the global authentication settings and assign unique authentication settings for a specific access point. See the “Configuring Access Point Details” section on page 9-165 for more information.
To enable global supplicant credentials, follow these steps:

Step 1 Choose **Configure > Controllers**.
Step 2 Choose the IP address of the desired controller.
Step 3 From the left sidebar menu, choose **System > AP 802.1X Supplicant Credentials**.
Step 4 Select the **Global Supplicant Credentials** check box.
Step 5 Enter the supplicant username.
Step 6 Enter and confirm the applicable password.
Step 7 Click **Save**.

**Note** Once saved, you can click **Audit** to perform an audit on this controller. See the “Understanding the Controller Audit Report” section on page 9-3 or the “Configuring an Audit” section on page 16-62 for more information.

### Configuring Controller DHCP

To configure DHCP (Dynamic Host Configuration Protocol) information for a controller, follow these steps:

Step 1 Choose **Configure > Controllers**.
Step 2 Choose the IP address of the desired controller.
Step 3 From the left sidebar menu, choose **System > DHCP**.
Step 4 Add or modify the following parameters:
   - DHCP Option 82 Remote Id Field Format—Choose **AP-MAC** or **AP-MAC-SSID** from the drop-down list.
     **Note** To set the format for RemoteID field in DHCP option 82: If ‘Ap-Mac’ is selected, then set the RemoteID format as <AP-Mac>. If ‘Ap-Mac-ssid’ is selected, then set the RemoteID format as <AP-Mac>:<SSID>.
   - DHCP Proxy—Select the check box to enable DHCP by proxy.
     **Note** When DHCP proxy is enabled on the controller, the controller unicasts DHCP requests from the client to the configured servers. Consequently, at least one DHCP server must be configured on either the interface associated with the WLAN or the WLAN itself.
Step 5 Enter the DHCP Timeout in seconds after which the DHCP request will time out. The default setting is 5. Allowed values range from 5 to 120 seconds.

**Note** DHCP Timeout is applicable from the controller version 7.0.114.74 onwards.
Step 6  Click Save.

Note  Once saved, you can click Audit to perform an audit on this controller. See the “Understanding the Controller Audit Report” section on page 9-3 or the “Configuring an Audit” section on page 16-62 for more information.

Configuring Controller Multicast Mode

WCS provides an option to configure IGMP (Internet Group Management Protocol) snooping and timeout values on the controller.

To configure multicast mode and IGMP snooping for a controller, follow these steps:

Step 1  Choose Configure > Controllers.
Step 2  Click the IP address of the desired controller.
Step 3  From the left sidebar menu, choose System > Multicast.
Step 4  Choose Disable, Unicast, or Multicast from the Ethernet Multicast Support drop-down list.

Note  IGMP Snooping and timeout can be set only if Ethernet Multicast mode is Enabled.

Step 5  If Multicast is selected, enter the multicast group IP address.
Step 6  Select the Enable Global Multicast Mode check box to make the multicast mode available globally.
Step 7  Select to enable IGMP Snooping.
Step 8  Choose Enable from the Multicast Mobility Mode drop-down list to change the IGMP snooping status or to set the IGMP timeout. When IGMP snooping is enabled, the controller gathers IGMP reports from the clients and then sends each access point a list of the clients listening to any multicast group. The access point then forwards the multicast packets only to those clients.

The timeout interval has a range of 3 to 300 and a default value of 60. When the timeout expires, the controller sends a query to all WLANs. Those clients which are listening in the multicast group then send a packet back to the controller.

Step 9  If you enabled the Multicast Mobility Mode, enter the mobility group multicast address.
Step 10 Select the Multicast Direct check box to enable videos to be streamed over a wireless network.
Step 11 Specify the Session Banner information, which is the error information sent to the client if the client is denied or dropped from a Media Stream.

a.  State—Select the check box to activate the Session Banner. If not activated, the Session Banner is not sent to the client.
b.  URL—A web address reported to the client
c.  Email—An email address reported to the client
d.  Phone—A telephone number reported to the client
e.  Note—A note reported to the client
Configuring Existing Controllers

Note
All Media Streams on a Controller share this configuration.

Step 12
Click Save.

Note
Once saved, you can click Audit to perform an audit on this controller. See the “Understanding the Controller Audit Report” section on page 9-3 or the “Configuring an Audit” section on page 16-62 for more information.

Configuring Access Point Timer Settings

Advanced timer configuration for HREAP and local mode is available for the controller on WCS.

Note
This feature is only supported on Release 6.0 controllers and later.

- Configuring Advanced Timers, page 9-62
- Access Point Timer Settings for Local Mode, page 9-62
- Access Point Timer Settings for HREAP Mode, page 9-62

Configuring Advanced Timers

To configure the advanced timers, follow these steps:

Step 1 Choose Configure > Controllers.
Step 2 Choose the controller for which you want to set timer configuration.
Step 3 From the left sidebar menu, choose System > AP Timers.
Step 4 Select the applicable access point mode (Local mode or HREAP mode).
Step 5 See the “Access Point Timer Settings for Local Mode” section on page 9-62 or the “Access Point Timer Settings for HREAP Mode” section on page 9-62 for more information on each mode configuration.

Access Point Timer Settings for Local Mode

To reduce the failure detection time, you can configure the fast heartbeat interval (between the controller and the access point) with a smaller timeout value. When the fast heartbeat timer expires (at every heartbeat interval), the access point determines if any data packets have been received from the controller within the last interval. If no packets have been received, the access point sends a fast echo request to the controller. You can then enter a value between 10 and 15 seconds.

Access Point Timer Settings for HREAP Mode

Once selected, you can configure the HREAP timeout value. Select the AP Primary Discovery Timeout check box to enable the timeout value. Enter a value between 30 and 3600 seconds.
5500 series controllers accept access point fast heartbeat timer values in the range of 10-15. All other controller models support a range of 1-10.

Configuring Controller WLANs

Since controllers can support 512 WLAN configurations, WCS provides an effective way to enable or disable multiple WLANs at a specified time for a given controller.

To view a summary of the wireless local access networks (WLANs) that you have configured on your network, follow these steps:

**Step 1** Choose Configure > Controllers.

**Step 2** Click the IP address of the applicable controller.

**Step 3** From the left sidebar menu, choose WLANs > WLAN Configuration. The Configure WLAN Summary page appears (see Figure 9-6). This WLAN Configuration page contains the values found in Table 9-1.

**Figure 9-6 WLAN Configuration Summary Page**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check box</td>
<td>Select the WLAN for deletion. Choose Delete WLANs from the Select a command drop-down list.</td>
</tr>
<tr>
<td>WLAN ID</td>
<td>Identification number of the WLAN.</td>
</tr>
</tbody>
</table>
Chapter 9  Configuring Wireless Devices

Configuring Existing Controllers

Viewing WLAN Details

To view WLAN details, choose WLANs. The WLAN Details page appears (see Figure 9-7).

Use the tabs (General, Security, QoS, and Advanced) to view or edit parameters for the WLAN.

- General Tab, page 9-65
- Security Tab, page 9-65
- QoS Tab, page 9-69
- Advanced Tab, page 9-70
General Tab

The General tab includes the following information:

- Guest LAN—Indicates whether or not this WLAN is a Guest LAN.
- Profile Name
- SSID
- Status—Select the Enabled check box to enable this WLAN.

Note Depending on the WLAN template used for this controller, these parameters may or may not be available.

- Schedule Status
- Security Policies—Identifies the security policies set using the Security tab (includes security policies such as None, 802.1X, Static WEP, Static WEP-802.1X, WPA+WPA2, and CKIP). Changes to the security policies appear in this section after the page is saved.
- Radio Policy—Choose any one of the following from the drop-down list.
  - All, 802.11a only, 802.11g only, 802.11b/g only, 802.11a/g only.
- Interface/Interface Group—Choose from the drop-down list.
- Broadcast SSID—Select the check box to enable.
- Egress Interface—Select the name of the applicable interface. This WLAN provides a path out of the controller for wired guest client traffic.

Note To configure a start time for the WLAN status to be enabled, select the Schedule Status check box. Select the hours and minutes from the drop-down lists. Click the calendar icon to select the applicable date.

- Schedule Status
- Security Policies
- Radio Policy
- Interface/Interface Group
- Broadcast SSID
- Egress Interface

Note If you only have one controller in the configuration, choose Management from the Egress Interface drop-down list.

- Ingress Interface—Choose the applicable VLAN from the drop-down list. This interface provides a path between the wired guest client and the controller by way of the Layer 2 access switch.

Security Tab

The Security tab includes three additional tabs: Layer 2, Layer 3, and AAA Servers.

Layer 2 Security

Use the Layer 2 Security drop-down list to choose between None, 802.1x, Static WEP, Cranite, Static WEP-802.1x, WPA1+WPA2, and CKIP. These parameters are described in the Table 9-2.

MAC Filtering—Select the check box if you want to filter clients by MAC address.
### Table 9-2  Layer 2 Security Options

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>No Layer 2 security selected.</td>
</tr>
<tr>
<td>802.1x</td>
<td>802.11 Data Encryption:</td>
</tr>
<tr>
<td></td>
<td>- Type—WEP</td>
</tr>
<tr>
<td></td>
<td>- Key Size—40, 104, or 128 bits.</td>
</tr>
<tr>
<td>Static WEP</td>
<td>802.11 Data Encryption:</td>
</tr>
<tr>
<td></td>
<td>- Type</td>
</tr>
<tr>
<td></td>
<td>- Key Size—not set, 40, 104, or 128 bits.</td>
</tr>
<tr>
<td></td>
<td>- Key Index—1 to 4.</td>
</tr>
<tr>
<td></td>
<td>- Encryption Key</td>
</tr>
<tr>
<td></td>
<td>- Encryption Key Format—ASCII or HEX.</td>
</tr>
<tr>
<td>Cranite</td>
<td>Configure the WLAN to use the FIPS140-2 compliant Cranite Wireless Wall Software Suite, which uses AES encryption and VPN tunnels to encrypt and verify all data frames carried by the Cisco Wireless LAN Solution.</td>
</tr>
<tr>
<td>Static WEP-802.1X</td>
<td>Use this setting to enable both Static WEP and 802.1X policies. If this option is selected, static WEP and 802.1X parameters are displayed at the bottom of the page.</td>
</tr>
<tr>
<td></td>
<td>Static WEP encryption parameters:</td>
</tr>
<tr>
<td></td>
<td>- 802.11 Data Encryption</td>
</tr>
<tr>
<td></td>
<td>- Type</td>
</tr>
<tr>
<td></td>
<td>- Key Size—not set, 40, 104, or 128 bits.</td>
</tr>
<tr>
<td></td>
<td>- Key Index—1 to 4.</td>
</tr>
<tr>
<td></td>
<td>- Encryption Key</td>
</tr>
<tr>
<td></td>
<td>- Encryption Key Format—ASCII or HEX.</td>
</tr>
<tr>
<td></td>
<td>- Allowed Shared Key Authentication—Select the check box to enable.</td>
</tr>
<tr>
<td></td>
<td>802.1X parameters:</td>
</tr>
<tr>
<td></td>
<td>- 802.11 Data Encryption</td>
</tr>
<tr>
<td></td>
<td>- Type</td>
</tr>
<tr>
<td></td>
<td>- Key Size—40, 104, or 128 bits.</td>
</tr>
</tbody>
</table>
### Table 9-2  Layer 2 Security Options (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
</table>
| **WPA+WPA2**    | Use this setting to enable WPA, WPA2, or both. WPA enables Wi-Fi Protected Access with TKIP-MIC Data Encryption or AES. When WPA+WPA2 is selected, you can use Cisco’s Centralized Key Management (CCKM) authentication key management, which allows fast exchange when a client roams from one access point to another. When WPA+WPA2 is selected as the Layer 2 security policy and Pre-Shared Key is enabled, neither CCKM or 802.1X can be enabled, although, both CCKM and 802.1X can be enabled at the same time. WPA+WPA2 parameters:  
- WPA1—Select the check box to enable.  
- WPA2—Select the check box to enable.  
**Authentication Key Management:**  
- 802.1X—Select the check box to enable.  
- CCKM—Select the check box to enable.  
- PSK—Select the check box to enable. |
| **CKIP**        | Cisco Key Integrity Protocol. A Cisco access point advertises support for CKIP in beacon and probe response packets. CKIP can be configured only when Aironet IE is enabled on the WAN.  
**Note**  
CKIP is not supported on 10xx access points.  
**CKIP parameters:**  
- 802.11 Data Encryption  
  - Type  
  - Key Size—not set, 40, 104, or 128 bits.  
  - Key Index—1 to 4.  
  - Encryption Key  
  - Encryption Key Format—ASCII or HEX.  
- MMH Mode—Select the check box to enable.  
- Key Permutation—Select the check box to enable. |
Layer 3 Security

Use the Layer 3 Security drop-down list to choose between None, VPN Pass Through, and IPsec (Internet Protocol Security). The page parameters change according to the selection you make.

<table>
<thead>
<tr>
<th>Note</th>
<th>Depending on the type of WLAN, the Layer 3 parameters may or may not be available.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Note</td>
<td>If you choose VPN pass through, you must enter the VPN gateway address.</td>
</tr>
<tr>
<td>Note</td>
<td>IPsec is a suite of protocols for securing IP communications by authenticating and/or encrypting each IP packet in a data stream. IPsec also includes protocols for establishing cryptographic keys.</td>
</tr>
</tbody>
</table>

Web Policy—Select the check box to specify policies such as authentication, pass through, or conditional web redirect. This section also allows you to enable guest users to view customized login pages.

| Note | If you choose Pass Through, the Email Input check box appears. Select this check box if you want users to be prompted for their email addresses when attempting to connect to the network. |

To allow guest users to view customized login pages, follow these steps:

**Step 1** Unselect the **Global WebAuth Configuration** check box.

**Step 2** Choose **Web Auth Type** from the drop-down list on the Security > Layer 3 tab.

- Default Internal—The guest user receives the default login page.
- Customized WebAuth—Customized login pages can be downloaded from the Upload/Download Commands page. See the “Downloading a Customized Web Authentication Page” section on page 11-76 for more information.
  - Choose **Web Auth Login Page**, **Web Auth Login Failure Page**, or **Web Auth Logout Page** from the drop-down lists.
  - Choose **None** from any of the drop-down lists if you do not want to display a customized page for that option.
- External—The guest user is redirected to an external login page. Enter the login page URL in the External Web Auth URL text box.

**Note** If External is selected, you can select up to three RADIUS and LDAP servers in the Security > AAA page. See the “AAA Servers” section on page 9-69 for more information.
**AAA Servers**

Select RADIUS and LDAP servers to override use of default servers on the current WLAN.

- **RADIUS Servers**—Use the drop-down lists to choose authentication and accounting servers. With this selection, the default RADIUS server for the specified WLAN overrides the RADIUS server that is configured for the network. If all three RADIUS servers are configured for a particular WLAN, server 1 has the highest priority, and so on.

- **LDAP Servers**—If no LDAP servers are chosen from the drop-down lists, WCS uses the default LDAP server order from the database.

- **Local EAP Authorization**—Allows users and wireless clients to be authenticated locally. It is designed for use in remote offices that want to maintain connectivity to wireless clients when the back-end system becomes disrupted or the external authentication server fails. Select the check box to enable if you have an EAP profile configured. Select the profile from the drop-down list.

- **Allow AAA Override**—When enabled, if a client has conflicting AAA and controller WLAN authentication parameters, client authentication is performed by the AAA server. As part of this authentication, the operating system moves clients from the default Cisco WLAN solution to a VLAN returned by the AAA server and predefined in the controller interface configuration (only when configured for MAC filtering, 802.1X, or WPA operation).

In all cases, the operating system also uses QoS and ACL provided by the AAA server as long as they are predefined in the controller interface configuration. (This VLAN switching by AAA override is also referred to as identity networking.)

When AAA override is disabled, all client authentication defaults to the controller authentication parameter settings, and authentication is only performed by the AAA server if the controller WLANs do not contain any client-specific authentication parameters.

**QoS Tab**

- **Quality of service (QoS)**—From the drop-down list, choose **Platinum (voice)**, **Gold (video)**, **Silver (best effort)**, or **Bronze (background)**.
  - Services such as VoIP should be set to gold. Non-discriminating services such as text messaging can be set to bronze.

- **WMM Parameters**
  - **WMM Policy**—Choose **Disabled**, **Allowed** (to allow clients to communicate with the WLAN), or **Required** (to make it mandatory for clients to have WMM enabled for communication).
  - **7920 AP CAC**—Select the check box to enable support on Cisco 7920 phones.
  - **7920 Client CAC**—Select the check box to enable WLAN support for older versions of the software on 7920 phones. The CAC limit is set on the access point for newer versions of software.

- **Media**
  - **Multicast Direct**—Select the **Multicast Direct** check box to enable the Multicast Direct feature on the WLAN.
Advanced Tab

- **H-REAP Local Switching**—Select the check box to enable Hybrid REAP local switching. When enabled, the H-REAP access point handles client authentication and switches client packets locally. See the “Configuring Hybrid REAP” section on page 13-4 for more information.

---

**Note**

- H-REAP local switching applies only to Cisco 1130/1240/1250 series access points. It is not supported with L2TP, PPTP, CRANITE, and FORTRESS authentications. It does not apply to WLAN IDs 9-16.
- H-REAP Local Authentication is applicable for controller version 7.0.116.0 onwards.
- H-REAP Local Authentication works with Layer2 MAC Filtering.
- The Layer2 security 802.1X+Static WEP is not supported with H-REAP Local Authentication.
- The Layer 3 Web policies are not supported with H-REAP Local Authentication.
- H-REAP Local Auth configuration can be enabled only when H-REAP Local Switching option is selected.

---

- **Enable H-REAP local authentication by selecting the H-REAP Local Auth check box.**

  Local authentication is useful where you cannot maintain the criteria a remote office setup of minimum bandwidth of 128 kbps with the roundtrip latency no greater than 100 ms and the maximum transmission unit (MTU) no smaller than 500 bytes. In local switching, the authentication capabilities are present in the access point itself. Thus local authentication reduces the latency requirements of the branch office.

**Note**

- Local authentication can only be enabled on the WLAN of a HREAP AP that is in local switching mode.

Local authentication is not supported in the following scenarios:
- Guest Authentication cannot be performed on a HREAP local authentication enabled WLAN.
- RRM information is not available at the controller for the hybrid REAP local authentication enabled WLAN.
- Local radius is not supported.
- Once the client has been authenticated, roaming will only be supported after the WLC and the other hybrid REAPs in the group are updated with the client information.

- **Session Timeout (secs)**—Set the maximum time a client session can continue before re-authentication.
- **Aironet IE**—Select the check box to enable support for Aironet information elements (IEs) for this WLAN.
  - If Aironet IE support is enabled, the access point sends an Aironet IE 0x85 (which contains the access point name, load, number of associated clients, and so on) in the beacon and probe responses of this WLAN, and the controller sends Aironet IEs 0x85 and 0x95 (which contains the management IP address of the controller and the IP address of the access point) in the reassociation response if it receives Aironet IE 0x85 in the association request.
- **IPv6**—Select the check box to enable IPv6.
Chapter 9 Configuring Wireless Devices

Configuring Existing Controllers

Note
Layer 3 security must be set to None for IPv6 to be enabled.

- Diagnostic Channel—Click to enable the diagnostics. When enabled, clients can connect to this WLAN for diagnostic purposes.

Note
The results of the diagnostic tests are stored in the SNMP table, and WCS polls these tables to display the results.

- Override Interface ACL—Choose a defined access control list (ACL) from the drop-down list. When the ACL is selected, the WLAN associates the ACL to the WLAN.

Note
Choosing an ACL is optional, and the default is None.

For more information, see the “Configuring an Access Control List Template” section on page 11-80.

- Peer to Peer Blocking—From the drop-down list, choose Disable, Drop, or Forward-Up Stream.
  - This option allows users to configure peer-to-peer blocking for individual clients rather than universally for all WLAN clients.

- Client Exclusion—Select the check box to enable automatic client exclusion. If it is enabled, set the timeout value in seconds for disabled client machines.
  - Client machines are excluded by MAC address, and their status can be observed.
  - A timeout setting of 0 indicates that administrative control is required to re-enable the client.

Note
When session timeout is not set, the excluded client remains and will not time out from the excluded state. It does not imply that the exclusion feature is disabled.

- Media Session Snooping—Click to enable Media Session Snooping. This feature enables access points to detect the establishment, termination, and failure of voice calls and then report them to the controller and WCS. It can be enabled or disabled for each WLAN.

  When media session snooping is enabled, the access point radios advertise this WLAN snoop for Session Initiation Protocol (SIP) voice packets. Any packets destined to or originating from port number 5060 are considered for further inspection. The access point tracks whether Wi-Fi Multimedia (WMM) and non-WMM clients are establishing a call, already on an active call, or in the process of ending a call and then notify the controller of any major call events.

- NAC Support—Select the NAC Support check box to enable it. SIP errors that are discovered generate traps that appear on the client troubleshooting and alarms screens. The controller can integrate with the NAC appliance in out-of-band mode, where the NAC appliance remains in the data path only until clients have been analyzed and cleaned. Out-of-band mode reduces the traffic load on the NAC appliance and enables centralized NAC processing. See the “NAC Out-of-Band Integration” section on page 9-42 for more information.

- Passive Client—If the check box is selected, it enables passive clients on your WLAN.
Passive clients are wireless devices like scales and printers that are configured with a static IP address. These clients do not transmit any IP information such as IP address, subnet mask, and gateway information during association with an access point. As a result, when passive clients are used, the controller will never know the IP address unless they use DHCP.

Wireless LAN controllers currently act as a proxy for ARP requests. On receiving an ARP request, the controller responds with an ARP response instead of passing the request directly to the client. This has two advantages:

- The upstream device that sends out the ARP request to the client cannot know where the client is located.
- Reserves power for battery-operated devices like mobile phones and printers as they do not need to respond to every ARP request.

Because the wireless controller does not have any IP-related information about passive clients, it cannot respond to any ARP requests. The current behavior does not allow the transfer of ARP requests to passive clients. Therefore, any application that tries to access a passive client will fail.

This feature enables ARP requests and responses to be exchanged between wired and wireless clients on a per-VLAN/WLAN basis. This feature enables the user to mark a desired WLAN for presence of proxy ARP thereby enabling the controller to pass the ARP requests until the client gets to RUN state.

Note: This feature is supported only on the 5500 and 2100 series controllers.

- DTIM Period (in beacon intervals)—For 802.11a/n and 802.11b/g/n, specify the frequency of the DTIM packet sent in the wireless medium. This period can be configured for every WLAN (except guest WLAN) on all version 6.0 and above controllers.
- DHCP
  - DHCP Server—Select the check box to override the DHCP server, and enter the IP address of the DHCP server.
    Note: For some WLAN configurations, this setting is required.
  - DHCP Addr. Assignment—If you select the Required check box, clients connected to this WLAN will get an IP address from the default DHCP server.
- Management Frame Protection (MFP)
  - MFP Signature Generation—If the check box is selected, it enables signature generation for the 802.11 management frames transmitted by an access point associated with this WLAN. With signature generation, changes to the transmitted management frames by an intruder are detected and reported.
  - MFP Client Protection—From the drop-down list, choose Optional, Disabled, or Required for individual WLAN configurations.
  - MFP Version—Displays the Management Frame Protection version.
    Note: Client-side MFP is available only for those WLANs configured to support CCXv5 (or later) clients. In addition, WPA1 must first be configured.
Foreign Controller Mapping—Click this link to configure foreign controller mappings. This will take you to the Foreign Controller configuration page. In this configuration page, choose a foreign controller from the Foreign Controller drop-down list and choose an interface or interface group from the Interface/Interface Group drop-down list. After choosing the required options, click Add to complete the adding of a foreign controller.

Adding a WLAN

To add a WLAN, follow these steps:

**Step 1** Choose Configure > Controllers.
**Step 2** Click the IP address of the appropriate controller.
**Step 3** From the left sidebar menu, choose WLANs > WLAN Configuration.
**Step 4** From the Select a command drop-down list, choose Add a WLAN.
**Step 5** Click Go to open the WLAN Details: Add from Template page (see Figure 9-8).
Figure 9-8 WLAN Details: Add From Template Page

Step 6 Choose a template from the Select a template to apply to this controller drop-down list.

Step 7 Click Apply.

Note To create a new template for WLANs, use the click here link in this page, or choose Configure > Controller Template Launch Pad > WLANs > WLAN.

Deleting a WLAN

To delete a WLAN, follow these steps:

Step 1 Choose Configure > Controllers.

Step 2 Click the IP address of the appropriate controller.

Step 3 From the left sidebar menu, choose WLANs > WLAN Configuration.
Chapter 9  Configuring Wireless Devices

Configuring Existing Controllers

Step 4  Select the check boxes of the WLANs that you want to delete.

Step 5  From the Select a command drop-down list, choose **Delete a WLAN**.

Step 6  Click **Go**.

Step 7  Click **OK** to confirm the deletion.

Managing WLAN Status Schedules

WCS enables you to change the status of more than one WLAN at a time on a given controller. You can select multiple WLANs and select the date and time for that status change to take place.

To schedule multiple WLANs for a status change, follow these steps:

Step 1  Choose **Configure > Controllers**.

Step 2  Click the IP address of the appropriate controller.

Step 3  From the left sidebar menu, choose **WLANs > WLAN Configuration**.

Step 4  Select the check boxes of the WLANs that you want to schedule for a status change.

Step 5  From the Select a command drop-down list, choose **Schedule Status** to open the WLAN Schedule Task Detail page (see Figure 9-9).

**Figure 9-9  WLAN Schedule Task Detail Page**

The selected WLANs are listed at the top of the page.

Step 6  Enter a Scheduled Task Name to identify this status change schedule.

Step 7  Choose the new Admin Status (Enabled or Disabled) from the drop-down list.

Step 8  Choose the schedule time using the hours and minutes drop-down lists.

Step 9  Click the calendar icon to choose a schedule date or enter the date in the text box (MM/DD/YYYY).
Step 10 Select the appropriate Recurrence radio button to determine the frequency of the status change (Daily, Weekly, or No Recurrence).

Step 11 Click Submit to initiate the status change schedule.

Note For more information on the WLAN Configuration Scheduled Task results, see the “Viewing WLAN Configuration Scheduled Task Results” section on page 9-206.

Mobility Anchors

Mobility anchors are one or more controllers defined as anchors for the WLAN. Clients (802.11 mobile stations such as a laptop) are always attached to one of the anchors.

This feature can be used to restrict a WLAN to a single subnet, regardless of the client’s entry point into the network. In this way, users can access a public or guest WLAN throughout an enterprise but still be restricted to a specific subnet. Guest WLAN can also be used to provide geographical load balancing because WLANs can represent a particular section of a building (such as a lobby, restaurant, and so on).

When a client first associates to a controller of a mobility group that has been preconfigured as a mobility anchor for a WLAN, the client associates to the controller locally, and a local session is created for the client. Clients can be anchored only to preconfigured anchor controllers of the WLAN. For a given WLAN, you should configure the same set of anchor controllers on all controllers in the mobility group.

When a client first associates to a controller of a mobility group that has not been configured as a mobility anchor for a WLAN, the client associates to the controller locally, a local session is created for the client, and the controller is announced to the other controllers in the same mobility group. If the announcement is not answered, the controller contacts one of the anchor controllers configured for the WLAN and creates a foreign session for the client on the local switch. Packets from the client are encapsulated and delivered to the wired network. Packets to the client are received by the anchor controller and forwarded to the foreign controller through a mobility tunnel using EitherIP. The foreign controller decapsulates the packets and forwards them to the client.

Note A 2000 series controller cannot be designated as an anchor for a WLAN. However, a WLAN created on a 2000 series controllers can have a 4100 series controller or a 4400 series controller as its anchor.

Note The L2TP Layer 3 security policies are unavailable for WLANs configured with a mobility anchor.

To view the real time status of mobility anchors for a specific WLAN, follow these steps:

Step 1 Choose Configure > Controllers.
Step 2 Click the IP address of the appropriate controller.
Step 3 From the left sidebar menu, choose WLANs > WLAN Configuration.
Step 4 Click a WLAN ID to view the parameters for a specific WLAN.
Step 5 Click the Advanced tab.
Step 6 Click the Mobility Anchors link. Table 9-3 describes the parameters that are displayed.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mobility Anchor</td>
<td>The IP address of the anchor.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the anchor. For example, reachable or unreachable.</td>
</tr>
</tbody>
</table>

### Configuring WLANs AP Groups

Site-specific VLANs or AP groups limit the broadcast domains to a minimum by segmenting a WLAN into different broadcast domains. Benefits of this include more effective management of load balancing and bandwidth allocation.

To open this page, follow these steps:

**Step 1** Choose Configure > Controllers.

**Step 2** Click a controller IP address.

**Step 3** From the left sidebar menu, choose WLAN > AP Groups.

This page displays a summary of the AP groups configured on your network. From here you can add, remove, or view details of an AP group. Click the AP group name on the Access Points tab to view or edit its access point(s). Click the WLAN Profiles tab to view, edit, add, or delete WLAN profiles.

### Adding Access Point Groups

To add a new access point group, follow these steps:

**Step 1** Choose Configure > Controllers.

**Step 2** Click a controller IP address.

**Step 3** From the left sidebar menu, choose WLAN > AP Groups.

**Note** AP Groups (for 5.2 and later controllers) is referred to as AP Group VLANs for controllers prior to 5.2.

**Step 4** From the Select a command drop-down list, choose Add AP Groups.

**Step 5** Click Go.

In the AP Groups details page, you can add access points and WLAN profiles to this access point group.

**Step 6** Enter a name and group description for the access point group.
Configuring Existing Controllers

Chapter 9      Configuring Wireless Devices

Note The group description is optional.

Step 7 To add access points to the group, follow these steps:

a. Click the Access Points tab.

b. Click Add. The access point page displays parameters for available access points. Click the access point name to view or edit parameters for one of the available access points.

c. Select the check box(es) of the access point(s) you want to add.

d. Click Select.

Step 8 To add a WLAN profile to this group, follow these steps:

a. Click the WLAN Profiles tab.

Note Each access point is limited to sixteen WLAN profiles. Each access point broadcasts all WLAN profiles unless the WLAN override feature is enabled. The WLAN override feature allows you to disable any of the 16 WLAN profiles per access point.

Note The WLAN override feature applies only to older controllers that do not support the 512 WLAN feature (can support up to 512 WLAN profiles).

Note OfficeExtend access points are limited to fifteen WLAN profiles because one is reserved as the personal or local SSID for the OfficeExtend access point.

Step 9 Enter a WLAN profile name or choose one from the WLAN Profile Name drop-down list.

Step 10 Choose the interface or interface group from the Interface/Interface Group drop-down list.

Note For more information about configuring interfaces, see the “Configuring Controller System Interfaces” section on page 9-36.

Step 11 Select the NAC Override check box, if applicable. NAC override is disabled by default.

Step 12 When access points and WLAN profiles are added, click Save.

Note After saving, use the edit icon from the WLAN Profiles tab to edit WLAN profile information.

Note Changing the WLAN-interface mapping in an AP Group will remove the local VLAN mapping for HREAP APs in this group. These mappings will need to be reconfigured after applying this change.
Deleting Access Point Groups

To delete an access point group, follow these steps:

Step 1  Choose Configure > Controllers.
Step 2  Click a controller IP address.
Step 3  From the left sidebar menu, choose WLAN > AP Groups.
Step 4  Select the check box(es) of the access point group(s) that you want to delete.
Step 5  From the Select a command drop-down list, choose Delete AP Groups.
Step 6  Click OK to confirm the deletion.

Auditing Access Point Groups

You can audit the access point group to determine if the WCS and device values differ.
To audit an access point group, follow these steps:

Step 1  Choose Configure > Controllers.
Step 2  Click a controller IP address.
Step 3  From the left sidebar menu, choose WLAN > AP Groups.
Step 4  Click the name of the access point group that you want to audit.

Note  Click Audit located at the bottom of the page.

Configuring Hybrid REAP Parameters

Hybrid REAP enables customers to configure and control access points in a branch or remote office from the corporate office through a wide area network (WAN) link without deploying a controller in each office. There is no deployment restriction on the number of hybrid-REAP access points per location. The hybrid-REAP access points can switch client data traffic locally and perform client authentication locally when their connection to the controller is lost. When they are connected to the controller, they can also send traffic back to the controller.

- Configuring H-REAP AP Groups, page 9-79
- Auditing an H-REAP Group, page 9-82

Configuring H-REAP AP Groups

To view a list of existing H-REAP AP groups, follow these steps:

Step 1  Choose Configure > Controllers.
Step 2  Click the IP address of the applicable controller.

Step 3  From the left sidebar menu, choose H-REAP > H-REAP AP Groups. The H-REAP AP Groups page opens.
- Group Name—The name of the H-REAP AP group. Click the group name to view its details.

Note  Use the check box to select a group for deletion.

Configuring a H-REAP AP Group

To configure a hybrid-REAP access point group, follow these steps:

Step 1  Choose Configure > Controllers.

Step 2  Click the IP address of the applicable controller.

Step 3  From the left sidebar menu, choose H-REAP > H-REAP AP Groups.

Step 4  From the Select a command drop-down list, choose Add H-REAP AP Group to open the H-REAP AP Group > Add From Template pane.

Step 5  Choose a template from the Select a template to apply to this controller drop-down list.

Step 6  Click Apply.

Note  To make modifications to an existing H-REAP AP Group, click the existing group in the Group Name column of the H-REAP AP Group page. To delete an existing group, select the check box of the group you want to remove, and choose Delete H-REAP AP Group from the Select a command drop-down list.

Step 7  Configure the following H-REAP AP Group parameters:
- General tab
  - Template Name—The name of the template applied to this controller.
  - Primary Radius—From the drop-down list, choose the primary radius authentication server present on the controller.

Note  If a RADIUS authentication server is not present on the controller, the WCS configured RADIUS server does not apply.

Note  You must configure the RADIUS server configuration on the controller before you apply H-REAP RADIUS server configuration from WCS.
- Secondary Radius—From the drop-down list, choose the secondary radius authentication server present on the controller.
If a RADIUS authentication server is not present on the controller, the WCS configured RADIUS server does not apply.

- H-REAP AP tab
  - Ethernet MAC—Select this check box to apply to the H-REAP group.

An AP Ethernet MAC address cannot exist in more than one H-REAP group on the same controller. The controller will not allow you to set an AP Ethernet MAC in a hybrid-REAP group if it is already present in another H-REAP group.

- Add AP—Click to add an additional H-REAP AP (present in the WCS) to an existing H-REAP group.

**Step 8** If you want to enable local authentication for a hybrid-REAP group, click the H-REAP Configuration tab.

Make sure that the Primary RADIUS Server and Secondary RADIUS Server parameters are set to None on the General tab.

**Step 9** Select the H-REAP Local Authentication Enable check box to enable local authentication for this hybrid-REAP group. The default value is unselected.

**Step 10** To allow a hybrid-REAP access point to authenticate clients using LEAP, select the LEAP check box. Otherwise, to allow a hybrid-REAP access point to authenticate clients using EAP-FAST, select the EAP-FAST check box.

**Step 11** Perform one of the following, depending on how you want protected access credentials (PACs) to be provisioned:

- To use manual PAC provisioning, enter the key used to encrypt and decrypt PACs in the EAP=FAST Key text box. The key must be 32 hexadecimal characters.
- To allow PACs to be sent automatically to clients that do not have one during PAC provisioning, select the Ignore Server Key check box.

**Step 12** In the EAP-FAST Authority ID text box, enter the authority identifier of the EAP-FAST server. The identifier must be 32 hexadecimal characters.

**Step 13** In the EAP-FAST Authority Info text box, enter the authority identifier of the EAP-FAST server in text format. You can enter up to 32 hexadecimal characters.

**Step 14** In the EAP-FAST PAC Timeout text box, specify a PAC timeout value by entering the number of seconds for the PAC to remain visible in the edit text box. The valid range is 2 to 4095 seconds.

To see if an individual access point belongs to a hybrid-REAP group, click the Users configured in the group link. It advances you to the H-REAP AP Group page which shows the names of the groups and the access points that belong in it.
Auditing an H-REAP Group

If the H-REAP configuration changes over a period of time either on WCS or the controller, you can audit the configuration. The changes are visible in subsequent pages. You can specify to refresh WCS or the controller to synchronize the configuration.

Configuring Security Parameters

This section contains the following topics:

- Configuring Controller File Encryption, page 9-82
- Configure Controllers > IPaddr > Security > AAA, page 9-83
- Configure Controllers > IPaddr > Security > Local EAP, page 9-93
- Configuring User Login Policies, page 9-97
- Managing Manually Disabled Clients, page 9-97
- Configuring Access Control Lists, page 9-97
- Configuring CPU Access Control Lists, page 9-99
- Configuring the IDS Sensor List, page 9-100
- Configuring CA Certificates, page 9-100
- Configuring ID Certificates, page 9-101
- Configuring Wireless Protection Policies, page 9-102
- Configuring Rogue Policies, page 9-103
- Configuring Rogue AP Rules, page 9-104
- Configuring Client Exclusion Policies, page 9-104
- Configuring Controller Standard Signature Parameters, page 9-105
- Configuring Custom Signatures, page 9-108
- Configuring AP Authentication and MFP, page 9-109

Configuring Controller File Encryption

To configure a controller file encryption, follow these steps:

**Step 1** Choose Configure > Controllers.

**Step 2** Click the IP address of the applicable controller.

**Step 3** From the left sidebar menu, choose Security > File Encryption. File encryption ensures that data is encrypted when you upload or download the controller configuration file from a TFTP server.

File Encryption parameters include:

- File Encryption—If this option is enabled, the data in the controller configuration file is encrypted when it is uploaded or downloaded through the TFTP server.
- Encryption Key—A text string of exactly 16 characters.
- Confirm Encryption Key—Enter the encryption key.
Configure Controllers > IPaddr > Security > AAA

This section describes how to configure controller security AAA parameters and contains the following topics:

- Configuring AAA General Parameters, page 9-83
- Configuring AAA RADIUS Auth Servers, page 9-83
- Configuring AAA RADIUS Acct Servers, page 9-84
- Configuring AAA RADIUS Fallback Parameters, page 9-85
- Configuring AAA LDAP Servers, page 9-86
- Configuring AAA TACACS+ Servers, page 9-88
- Configuring AAA Local Net Users, page 9-88
- Configuring AAA MAC Filtering, page 9-90
- Configuring AAA AP/MSE Authorization, page 9-90
- Configuring AAA Web Auth Configuration, page 9-91

Configuring AAA General Parameters

The General page allows you to configure the local database entries on a controller.

To configure the local database entries, follow these steps:

Step 1 Choose Configure > Controllers.
Step 2 Click the IP address of the applicable controller.
Step 3 From the left sidebar menu, choose Security > AAA > General.
Step 4 Enter the maximum number of allowed database entries. This amount becomes effective on the next reboot. The valid range is 512 - 2048.

Configuring AAA RADIUS Auth Servers

To view a summary of existing RADIUS authentication servers, follow these steps:

Step 1 Choose Configure > Controllers.
Step 2 Click the IP address of the applicable controller.
Step 3 From the left sidebar menu, choose Security > AAA > RADIUS Auth Servers. The following RADIUS Auth Servers parameters appear:

- Server Index—Access priority number for the RADIUS server (display only). Click to go to Configure IPaddr > RADIUS Authentication Server.
- Server Address—IP address of the RADIUS server (read-only).
- Port Number—Controller port number (read-only).
- Admin Status—Enable or Disable.
Configuring Existing Controllers

- Network User—Enable or Disable.
- Management User—Enable or Disable.

Adding an Authentication Server

To add an authentication server, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click the IP address of the applicable controller.

**Step 3** From the left sidebar menu, choose **Security > AAA > RADIUS Auth Servers**.

**Step 4** From the Select a command drop-down list, choose **Add Auth Server** to open the Radius Authentication Server > Add From Template page.

**Step 5** Choose a template from the Select a template to apply to this controller drop-down list.

**Step 6** Click **Apply**.

**Note** To create a new template for Radius authentication servers, choose **Configure > Controller Templates > Security > RADIUS Auth Servers**.

Configuring AAA RADIUS Acct Servers

To view a summary of existing RADIUS accounting servers, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click the IP address of the applicable controller.

**Step 3** From the left sidebar menu, choose **Security > AAA > RADIUS Acct Servers**. RADIUS Acct Server parameters include the following:

- Server Index—Access priority number for the RADIUS server (read-only). Click to open the Radius Acct Servers Details page.

**Note** To edit or audit the current accounting server parameters, click the Server Index for the applicable accounting server.

- Server Address—IP address of the RADIUS server (read-only).
- Port Number—Controller port number (read-only).
- Admin Status—Enable or Disable.
- Network User—Enable or Disable.
Command Buttons

- Save
- Audit

Adding an Accounting Server

To add an accounting server, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Choose Configure &gt; Controllers.</td>
</tr>
<tr>
<td>2</td>
<td>Click the IP address of the applicable controller.</td>
</tr>
<tr>
<td>3</td>
<td>From the left sidebar menu, choose Security &gt; AAA &gt; RADIUS Acct Servers.</td>
</tr>
<tr>
<td>4</td>
<td>From the Select a command drop-down list, choose Add Acct Server to open the Radius Acct Servers Details &gt; Add From Template page.</td>
</tr>
<tr>
<td>5</td>
<td>Choose a template from the Select a template to apply to this controller drop-down list.</td>
</tr>
<tr>
<td>6</td>
<td>From the drop-down list, choose a controller to apply to this template.</td>
</tr>
<tr>
<td>7</td>
<td>Click Apply.</td>
</tr>
</tbody>
</table>

Note: To create a new template for Radius accounting servers, choose Configure > Controller Templates Launch Pad > Security > RADIUS Acct Servers.

Deleting an Accounting Server

To delete an accounting server, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Choose Configure &gt; Controllers.</td>
</tr>
<tr>
<td>2</td>
<td>Click the IP address of the applicable controller.</td>
</tr>
<tr>
<td>3</td>
<td>From the left sidebar menu, choose Security &gt; AAA &gt; RADIUS Acct Servers.</td>
</tr>
<tr>
<td>4</td>
<td>Select the check box(es) for the applicable accounting server(s).</td>
</tr>
<tr>
<td>5</td>
<td>From the Select a command drop-down list, choose Delete Acct Server.</td>
</tr>
<tr>
<td>6</td>
<td>Click Go.</td>
</tr>
<tr>
<td>7</td>
<td>Click OK in the pop-up dialog box to confirm the deletion.</td>
</tr>
</tbody>
</table>

Configuring AAA RADIUS Fallback Parameters

To configure RADIUS fallback parameters, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Choose Configure &gt; Controllers.</td>
</tr>
<tr>
<td>2</td>
<td>Click the IP address of the applicable controller.</td>
</tr>
<tr>
<td>3</td>
<td>From the left sidebar menu, choose Security &gt; AAA &gt; RADIUS Fallback.</td>
</tr>
</tbody>
</table>
Step 4  Add or modify the following parameters:
  • RADIUS FallbackMode
  • Username
  • Time Interval

Step 5  Click Save.

---

### Configuring AAA LDAP Servers

This page enables you to add and delete LDAP servers to this controller.

To access the LDAP Servers page, follow these steps:

---

Step 1  Choose Configure > Controllers.

Step 2  Click the IP address of the applicable controller.

Step 3  From the left sidebar menu, choose Security > AAA > LDAP Servers.

This page displays LDAP servers currently used by this controller and contains the following parameters:
  • Check box—Select the check box to choose an LDAP server for deletion.
  • Server Index—A number assigned to identify the LDAP server.

---

#### Notes
- Click Audit to check the present configuration status of WCS and the controller.

---

- Server Address—The LDAP server IP address.
- Port Number—The port number used to communicate with the LDAP server.
- Admin Status—Server template status.
  Indicates if use of the LDAP server template is enabled or disabled.

---

Note  If the title of a column is a link, click it to toggle between ascending and descending order.

---

Note  WCS now supports LDAP configuration for both an anonymous or authenticated bind. For more information, see the “Configuring New LDAP Bind Requests” section on page 9-87.
LDAP Servers Select a command Drop-Down List Options

Adding LDAP Server

To add a LDAP Server, follow these steps:

---

**Step 1** Choose **Configure > Controllers**.
**Step 2** Click the **IP address** of the applicable controller.
**Step 3** From the left sidebar menu, choose **Security > AAA > LDAP Servers**.
**Step 4** From the **Select a command drop-down list**, choose **Add LDAP Server**.
**Step 5** Click **Go**.
---

Deleting LDAP Servers

To delete the LDAP Server, follow these steps:

---

**Step 1** Choose **Configure > Controllers**.
**Step 2** Click the **IP address** of the applicable controller.
**Step 3** From the left sidebar menu, choose **Security > AAA > LDAP Servers**.
**Step 4** Select the check box(es) of the LDAP servers that you want to delete.
**Step 5** From the **Select a command drop-down list**, choose **Delete LDAP Servers**.
**Step 6** Click **Go**.
---

Configuring New LDAP Bind Requests

WCS now supports LDAP configuration for both an anonymous or authenticated bind. A bind is a socket opening that performs a lookup.

To configure LDAP bind requests, follow these steps:

---

**Step 1** Choose **Configure > Controller**.
**Step 2** From the left sidebar menu, choose **Security > AAA > LDAP Servers**.
**Step 3** From the **Bind Type drop-down list**, choose **Authenticated** or **Anonymous**. If you choose **Authenticated**, you must enter a bind username and password as well.
**Step 4** In the **Server User Base DN text box**, enter the distinguished name of the subtree in the LDAP server that contains a list of all the users.
**Step 5** In the **Server User Attribute text box**, enter the attribute that contains the username in the LDAP server.
**Step 6** In the **Server User Type text box**, enter the ObjectType attribute that identifies the user.
**Step 7** In the **Retransmit Timeout text box**, enter the number of seconds between retransmissions. The valid range is 2 to 30 seconds, and the default value is 2 seconds.
**Step 8** Select the **Admin Status** check box if you want the LDAP server to have administrative privileges.
Step 9  Click Save.

Configuring AAA TACACS+ Servers

This page enables you to add and delete TACACS+ servers to this controller.
To access the TACACS+ Servers page, follow these steps:

| Step 1 | Choose Configure > Controllers. |
| Step 2 | Click the IP address of the applicable controller. |
| Step 3 | From the left sidebar menu, choose Security > AAA > TACACS+ Servers. |

This page displays TACACS+ servers currently used by this controller and contains the following parameters:
- Check box—Select the check box to choose a TACACS+ server for deletion.
- Server Type—The TACACS+ server type.
- Displays Accounting, Authorization, or Authentication.
- Server Index—A number assigned to identify the TACACS+ server and set its use priority.
- Click the index number to go to the TACACS+ server configuration page.
- Server Address—The TACACS+ server IP address.
- Port Number—The port number used to communicate with the TACACS+ server.
- Admin Status—Server template status.
  Indicates if use of the TACACS+ server template is enabled.

If the title of a column is a link, click it to toggle between ascending and descending order.
The Select a command drop-down list has the following options:
- Add TACACS+ Server—Choose this option, then click Go to add a TACACS+ server to the controller.
- Delete TACACS+ Servers—Choose this option, then click Go to delete all TACACS+ servers with a selected check box from the controller.

Configuring AAA Local Net Users

This page provides a summary of the existing local network user controllers for clients who are allowed to access a specific WLAN. This is an administrative bypass of the RADIUS authentication process. Layer 3 Web Authentication must be enabled. The client information is passed to the RADIUS authentication server first, and if the client information does not match a RADIUS database entry, this local database is polled. Clients located in this database are granted access to network services if the RADIUS authentication fails or does not exist.

- Adding a Local Net User, page 9-89
- Deleting a Local Net User, page 9-89

To view existing local network users, follow these steps:
Step 1  Choose Configure > Controllers.
Step 2  Click the IP address of the applicable controller.
Step 3  From the left sidebar menu, choose Security > AAA > Local Net Users. The Local Net Users page displays the following local net user parameters:
   - Username—User-defined identification.
   - WLAN ID—Any WLAN ID, 1 through 16; 0 for all WLANs; 17 for third-party WLAN that this local net user is allowed to access.
   - Description—Optional user-defined description.

Adding a Local Net User

To add a local net user, follow these steps:

Step 1  Choose Configure > Controllers.
Step 2  Click the IP address of the applicable controller.
Step 3  From the left sidebar menu, choose Security > AAA > Local Net Users.
Step 4  From the Select a command drop-down list, choose Add Local Net User to open the Local Net User > Add From Template page.
Step 5  Choose a template from the Select a template to apply to this controller drop-down list.
Step 6  Click Apply.

Note  To create a new template for local net users, choose Configure > Controller Templates > Security > Local Net Users. See the “Configuring a Local Network Users Template” section on page 11-61 for more information.

Deleting a Local Net User

To delete a local net user, follow these steps:

Step 1  Choose Configure > Controllers.
Step 2  Click the IP address of the applicable controller.
Step 3  From the left sidebar menu, choose Security > AAA > Local Net Users.
Step 4  Select the check box(es) for the applicable local net user(s).
Step 5  From the Select a command drop-down list, choose Delete Local Net Users.
Step 6  Click Go.
Step 7  Click OK in the dialog box to confirm the deletion.
Configuring Existing Controllers

Chapter 9 Configuring Wireless Devices

Configuring AAA MAC Filtering

This page enables you to view MAC Filter parameter information.

To access the MAC Filtering page, follow these steps:

Step 1 Choose Configure > Controllers.
Step 2 Click the IP address of the applicable controller.
Step 3 From the left sidebar menu, choose Security > AAA > MAC Filtering. The MAC Filtering page displays the following parameters:

- MAC Filter Parameters
  - RADIUS Compatibility Mode—User-defined RADIUS server compatibility: Cisco ACS, FreeRADIUS, or Other.
  - MAC Delimiter—The MAC delimiters can be Colon (xx:xx:xx:xx:xx:xx), Hyphen (xx-xx-xx-xx-xx-xx), Single Hyphen (xxxxxx-xxxxxx), or No Delimiter (xxxxxxxxxxxx), as required by the RADIUS server.
- MAC Filters
  - MAC Address—Client MAC address. Click to open Configure IPaddr > MAC Filter.
  - WLAN ID—1 through 16, 17 = Third-party AP WLAN, or 0 = all WLANs.
  - Interface—Displays the associated Interface Name.
  - Description—Displays an optional user-defined description.
Step 4 From the Select a command drop-down list, choose Add MAC Filters to add a MAC Filter, Delete MAC Filters to delete the template(s), or Edit MAC Filter Parameters to edit the MAC Filters.
Step 5 Click Go.

Configuring AAA AP/MSE Authorization

The AP/MSE Authorization page displays the access point policies and the list of authorized access points along with the type of certificate that an access point uses for authorization.

To access the AP/MSE Authorization page, follow these steps:

Step 1 Choose Configure > Controllers.
Step 2 Click the IP address of the applicable controller.
Step 3 From the left sidebar menu, choose Security > AAA > AP/MSE Authorization. The AP/MSE Authorization page displays the following parameters:

- AP Policies
  - Authorize APs—Enabled or Disabled.
  - Accept SSC-APs—Enabled or Disabled.
- AP/MSE Authorization
  - AP/MSE Base Radio MAC Address—The MAC address of the authorized access point.
Chapter 9 Configuring Wireless Devices

Configuring Existing Controllers

---

**Note**
Click the AP/MSE Base Radio MAC Address to view AP/MSE Authorization details.

- **Type**
- **Certificate Type**—MIC or SSC.
- **Key Hash**—The 40-hex long SHA1 key hash.

---

**Note**
The key hash is displayed only if the certificate type is SSC.

---

**Command Buttons**

- Add AP/MSE Auth Entry—Select this command, and click Go. See the “Configuring an Access Point or MSE Authorization Template” section on page 11-68.
- Delete AP/MSE Auth Entries—Select one or more access points, select this command, and click Go to delete the selected access point from the AP authorization list.
- Edit AP Policies—Select this command, and click Go. See the “Editing AP Policies” section on page 9-91.

---

**Editing AP Policies**

To edit AP/MSE Authorization access point policies, follow these steps:

**Step 1** Choose **Configure > Controllers**.
**Step 2** Click the IP address of the applicable controller.
**Step 3** From the left sidebar menu, choose **Security > AAA > AP/MSE Authorization**.
**Step 4** In **Edit AP Policies** page, edit the following parameters, if necessary:
- **Authorize APs**—Select the check box to enable access point authorization.
- **Accept SSC-APs**—Select the check box to enable the acceptance of SSE access points.
**Step 5** Click **Save** to confirm the changes, **Audit** to perform an audit on these device values, or **Cancel** to close this page with no changes.

---

**Configuring AAA Web Auth Configuration**

The Web Auth Configuration page enables the user to configure the Web auth configuration type. If the type is configured as customized, the user downloaded web auth replaces the controller-provided internal web auth page.

To access the Web Auth Configuration page, follow these steps:

**Step 1** Choose **Configure > Controllers**.
Step 2  Click the IP address of the applicable controller.

Step 3  From the left sidebar menu, choose Security > AAA > Web Auth Configuration.

Step 4  In the Web Authentication page, choose the Web Auth Type from the drop-down list. Web auth options include a default internal web page, a customized web authentication page, or an external web page.

Step 5  Configure the web auth parameters depending on the type chosen:

- Default Internal
  - Logo Display—Enable or disable logo display.
  - Web Auth Page Title—Title displayed on web authentication page.
  - Custom Redirect URL—URL where the user is redirected after a successful authentication. For example, if the value entered for this text box is http://www.example.com, the user would be directed to the company home page.

- Customized Web Auth
  You have the option of downloading an example login page and customizing the page. If you are using a customized web authentication page, it is necessary to download the example login.tar bundle file from the server, edit the login.html file and save it as either a .tar or .zip file, then download the .tar or .zip file to the controller.
  
  Click the preview image to download this sample login page as a TAR. After editing the HTML you may click here to redirect to the Download Web Auth page. See the “Downloading a Customized WebAuthentication Bundle to a Controller” section on page 9-14 for more information.

- External
  - External Redirect URL—Location of the login.html on an external server on the network.
  
  If there are not any external web auth servers configured, you have the option of configuring one.

  No external Web Auth server(s) configured.

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>To configure an external web server template, see the “Configuring an External Web Auth Server Template” section on page 11-78.</td>
</tr>
</tbody>
</table>

**Command Buttons**

- Save—Save the current settings to the controller.
- Audit—Check the present configuration status of WCS and the controller.

**Configuring AAA Password Policy**

This page enables you to determine your password policy.
To make modifications to an existing password policy, follow these steps:

**Step 1**  Choose Configure > Controllers.

**Step 2**  Click the IP address of the applicable controller.
**Step 3** From the left sidebar menu, choose **Security > AAA > Password Policy**.

**Step 4** Modify the password policy parameters as appropriate (see **Figure 9-10**).

**Figure 9-10 Password Policy**

![Password Policy](image)

**Step 5** Click **Save**.

---

**Note** If you disable password policy options, you will see a “Disabling the strong password check(s) will be a security risk as it allows weak passwords” message.

---

**Configure Controllers > IPaddr > Security > Local EAP**

Local EAP is an authentication method that allows users and wireless clients to be authenticated locally. It is designed for use in remote offices that want to maintain connectivity to wireless clients when the backend system becomes disrupted or the external authentication server goes down.

When you enable local EAP, the controller serves as the authentication server and the local user database, making it independent of an external authentication server. Local EAP retrieves user credentials from the local user database or the LDAP backend database to authenticate users.

**Configuring Local EAP General Parameters**

This page allows you to specify a timeout value for local EAP. You can then add a template with this timeout value or make changes to an existing template.

---

**Note** If any RADIUS servers are configured on the controller, the controller tries to authenticate the wireless clients using the RADIUS servers first. Local EAP is attempted only if no RADIUS servers are found, either because the RADIUS servers timed out or no RADIUS servers were configured. If four RADIUS servers are configured, the controller attempts to authenticate the client with the first RADIUS server, then the second RADIUS server, and then local EAP. If the client attempts to then reauthenticate manually, the controller tries the third RADIUS server, then the fourth RADIUS server, and then local EAP.
To specify a timeout value for local EAP, follow these steps:

---

**Step 1**  Choose **Configure > Controllers**.

**Step 2**  Click the IP address of the applicable controller.

**Step 3**  From the left sidebar menu, choose **Security > Local EAP > General - Local EAP**.

**Step 4**  Enter the Local Auth Active Timeout in the Local Auth Active Timeout text box (in seconds).

**Note**  Local Auth Active Timeout refers to the timeout period during which Local EAP will always be used after all Radius servers are failed.

**Step 5**  The following values should be adjusted if you are using EAP-FAST, manual password entry, one-time password, or 7920/7921 phones.

**Note**  You must increase the 802.1x timeout values on the controller (default=2 seconds) for the client to obtain the PAC using automatic provisioning. We recommend the default timeout on the Cisco ACS server of 20 seconds.

- Local EAP Identify Request Timeout = 1 (in seconds)
- Local EAP Identity Request Maximum Retries = 20 (in seconds)
- Local EAP Dynamic Wep Key Index = 0
- Local EAP Request Timeout = 20 (in seconds)
- Local EAP Request Maximum Retries = 2
- EAPOL-Key Timeout = 1000 (in milli-seconds)
- EAPOL-Key Max Retries = 2
- Max-Login Ignore Identity Response

**Note**  Roaming fails if these values are not set the same across multiple controllers.

**Step 6**  Click **Save**.

---

**Command Buttons**

- **Save**—Click to save the current template.
- **Apply to Controllers**—Click to apply the current template to controllers. In the Apply to Controllers page, choose the applicable controllers, and click **OK**.
- **Delete**—Click to delete the current template. If the template is currently applied to controllers, click **OK** to confirm that you want to remove the template from the selected controllers to which it is applied.
- **Cancel**—Click to cancel the current template creation or changes to the current template.
Configuring Local EAP Profiles

This page allows you to apply a template for a local EAP profile or make modifications to an existing template.

Note
The LDAP backend database supports only these local EAP methods: EAP-TLS and EAP-FAST with certificates. LEAP and EAP-FAST with PACs are not supported for use with the LDAP backend database.

- Viewing Existing Local EAP Profiles, page 9-95
- Adding a Local Net User, page 9-95

Viewing Existing Local EAP Profiles

To view existing local EAP profiles, follow these steps:

Step 1 Choose Configure > Controllers.
Step 2 Click the IP address of the applicable controller.
Step 3 From the left sidebar menu, choose Security > Local EAP > Local EAP Profiles. The Local EAP Profiles page displays the following parameters:
- EAP Profile Name—User-defined identification.
- LEAP—Authentication type that leverages Cisco Key Integrity Protocol (CKIP) and MMH message integrity check (MIC) for data protection. A username and password are used to perform mutual authentication with the RADIUS server through the access point.
- EAP-FAST—Authentication type (Flexible Authentication via Secure Tunneling) that uses a three-phased tunnel authentication process to provide advanced 802.1x EAP mutual authentication. A username, password, and PAC (protected access credential) are used to perform mutual authentication with the RADIUS server through the access point.
- TLS—Authentication type that uses a dynamic session-based WEP key derived from the client adapter and RADIUS server to encrypt data. It requires a client certificate for authentication.
- PEAP—Protected Extensible Authentication Protocol.

Adding a Local Net User

To add a local EAP profile, follow these steps:

Step 1 Choose Configure > Controllers.
Step 2 Click the IP address of the applicable controller.
Step 3 From the left sidebar menu, choose Security > Local EAP > Local EAP Profile.
Step 4 From the Select a command drop-down list, choose Add Local EAP Profile to open the Local EAP Profile > Add From Template page.
Step 5 Choose a template from the Select a template to apply to this controller drop-down list.
Step 6 Click Apply.
Configuring Local EAP General EAP-FAST Parameters

This authentication type (Flexible Authentication via Secure Tunneling) uses a three-phased tunnel authentication process to provide advanced 802.1x EAP mutual authentication. A username, password, and PAC are used to perform mutual authentication with the RADIUS server through the access point.

To set EAP-FAST Parameters, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click the IP address of the applicable controller.

**Step 3** From the left sidebar menu, choose **Security > Local EAP > EAP-FAST Parameters**.

**Step 4** Enter the following parameters:

- Time to live for the PAC—The number of days for the PAC to remain viable. The valid range is 1 to 1000 days; the default setting is ten days.
- Authority ID—The authority identifier of the local EAP-FAST server in hexadecimal characters. You can enter up to 32 hexadecimal characters but it must be an even number of characters.
- Authority Info—The authority identifier of the local EAP-FAST server in text format.
- Server Key—The key (in hexadecimal characters) used to encrypt and decrypt PACs.
- Confirm Server Key—Verify the correct Server Key by re-typing it.
- Anonymous Provision—Select the check box to enable anonymous provisioning.

**Note** This feature allows PACs to be sent automatically to clients that do not have one during PAC provisioning. If this feature is disabled, PACs must be manually provisioned.

**Step 5** Click **Save**.

### Configuring Local EAP General Network Users Priority

To specify the order that LDAP and local databases use to retrieve user credential information, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click the IP address of the applicable controller.

**Step 3** From the left sidebar menu, choose **Security > Local EAP > Network Users Priority**.

**Step 4** Use the left and right pointing arrows to include or exclude network credentials in the right-most list.

**Step 5** Use the up and down buttons to determine the order credentials are attempted.
Configuring User Login Policies

To configure the user login policies, follow these steps:

**Step 1** Choose Configure > Controllers.

**Step 2** Click the IP address of the applicable controller.

**Step 3** From the left sidebar menu, choose Security > User Login Policies.

**Step 4** Enter the maximum number of concurrent logins allowed for a single username.

**Step 5** Click Save.

Managing Manually Disabled Clients

The Disabled Clients page enables you to view excluded (blacklisted) client information. Clients who fail to authenticate three times when attempting to associate are automatically blocked, or excluded, from further association attempts for an operator-defined timeout. After the Excluded timeout, the client is allowed to retry authentication until it associates or fails authentication and is excluded again.

To access the Manually Disabled Clients page, follow these steps:

**Step 1** Choose Configure > Controllers.

**Step 2** Click the IP address of the applicable controller.

**Step 3** From the left sidebar menu, choose Security > Manually Disabled Clients. The Manually Disabled Clients page displays the following parameters:

- MAC Address—Disabled Client MAC addresses. Click a list item to edit the disabled client description.
- Description—Optional description of disabled client.

**Manually Disabled Clients Select a command Drop-Down List Options**

- Add Manually Disabled Client—Select this command, and click Go. See the “Configuring a Manually Disabled Client Template” section on page 11-69.
- Delete Manually Disabled Clients—Select the applicable controller check box, select this command, and click Go.

Configuring Access Control Lists

The Access Control Lists page displays access control lists (ACLs) available for this controller. It also enables you to add a new rule or edit an existing rule in an applied access control list.
To access the Access Control Lists page, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click the applicable IP address under the IP Address column.

**Step 3** From the left sidebar menu, choose **Security > Access Control Lists**.

- Check box—Use the check box to select one or more ACLs for deletion.
- ACL Name—User-defined name of this template. Click an ACL item to view its parameters. See the “Configure IPaddr > Access Control List > listname Rules” section on page 9-98.

---

**Configure IPaddr > Access Control List > listname Rules**

This page displays current access control list (ACL) rules applied to this access control list.

To access the Access Control Lists Rules page, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click the applicable IP address under the IP address column.

**Step 3** From the left sidebar menu, choose **Security > Access Control Lists**.

**Step 4** Click an ACL name.

- Check box—Select to delete access control list rules.
- Seq#—The operator can define up to 64 Rules for each ACL. The Rules for each ACL are listed in contiguous sequence from 1 to 64. That is, if Rules 1 through 4 are already defined and you add Rule 29, it will be added as Rule 5.
- Note If you add or change a Sequence number, operating system adjusts the other rule sequence numbers to retain the contiguous sequence. For instance, if you have Sequence numbers 1 through 7 defined and change number 7 to 5, operating system automatically reassigns Sequence 6 to 7 and Sequence 5 to 6.
- Action—Permit, Deny.
- Source IP/Mask—Source IP address and mask.
- Destination IP/Mask—Destination IP address and mask.
- Protocol—Protocol to use for this ACL:
  - Any—All protocols
  - TCP—Transmission Control Protocol
  - UDP—User Datagram Protocol
  - ICMP—Internet Control Message Protocol
  - ESP—IP Encapsulating Security Payload
  - AH—Authentication Header
  - GRE—Generic Routing Encapsulation
  - IP—Internet Protocol
If TCP or UDP is selected, Source Port and Dest Port parameters appear:

- Source Port—Source Port. Can be Any, HTTP, HTTPS, Telnet, RADIUS, DHCP Server, DHCP Client, DNS, L2TP, PPTP control, FTP control, SMTP, SNMP, LDAP, Kerberos, NetBIOS NS, NetBIOS DS, NetBIOS SS, MS Dir Server, Other and Port Range.
- Dest Port—Destination port. If TCP or UDP is selected, can be Any, HTTP, HTTPS, Telnet, RADIUS, DHCP Server, DHCP Client, DNS, L2TP, PPTP control, FTP control, SMTP, SNMP, LDAP, Kerberos, NetBIOS NS, NetBIOS DS, NetBIOS SS, MS Dir Server, Other and Port Range.

- DSCP (Differentiated Services Code Point)—Any, or 0 through 255.
- Direction—Any, Inbound (from client) or Outbound (to client).

To add a new ACL rule, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click an applicable IP address.

**Step 3** From the left sidebar menu, choose **Security > Access Control Lists**.

**Step 4** Click an ACL Name.

**Step 5** Click an applicable Seq#, or choose **Add New Rule** to access this page.

### Configuring CPU Access Control Lists

Access control lists (ACL) can be applied to the controller CPU to control traffic to the CPU. The Access Control Lists Rules page displays the name of the CPU access control list template applied to the chosen controller.

To access the Access Control Lists Rules page, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click a controller IP address.

**Step 3** From the left sidebar menu, choose **Security > CPU Access Control Lists**.

**Step 4** Select the **Enable CPU ACL** check box to enable the CPU ACL.

If this check box is selected, the following parameters are available:

- **ACL Name**—Choose the ACL to use from the ACL Name drop-down list.
- **CPU ACL Mode**—Choose which data traffic direction this CPU ACL list controls.

The choices include: The wired side of the data traffic, the wireless side of the data traffic, or both wired and wireless.
Configuring Existing Controllers

Chapter 9      Configuring Wireless Devices

Configuring the IDS Sensor List

When the sensors identify an attack, they alert the controller to shun the offending client. When you add a new IDS (Intrusion Detection System) sensor, you register the controller with that IDS sensor so that the sensor can send shunned client reports to the controller. The controller also polls the sensor periodically.

To view IDS sensors, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Choose <strong>Configure &gt; Controllers</strong>.</td>
</tr>
<tr>
<td>2</td>
<td>Click an applicable IP address.</td>
</tr>
<tr>
<td>3</td>
<td>From the left sidebar menu, choose <strong>Security &gt; IDS Sensor Lists</strong>.</td>
</tr>
</tbody>
</table>

The IDS Sensor page lists all IDS sensors that have been configured for this controller. Click an IP address to view details for a specific IDS sensor.

Configuring CA Certificates

A CA certificate is a digital certificate issued by one certificate authority (CA) for another certification CA.

- Importing a CA Certificate, page 9-100
- Pasting a CA Certificate Directly, page 9-100

Importing a CA Certificate

To import a CA certificate from a file, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Choose <strong>Configure &gt; Controllers</strong>.</td>
</tr>
<tr>
<td>2</td>
<td>Click an applicable IP address.</td>
</tr>
<tr>
<td>3</td>
<td>From the left sidebar menu, choose <strong>Security &gt; IP Sec Certificates &gt; CA Certificate</strong>.</td>
</tr>
<tr>
<td>4</td>
<td>Click <strong>Browse</strong> to navigate to the applicable certificate file.</td>
</tr>
<tr>
<td>5</td>
<td>Click <strong>Open</strong>.</td>
</tr>
<tr>
<td>6</td>
<td>Click <strong>Save</strong>.</td>
</tr>
</tbody>
</table>

Pasting a CA Certificate Directly

To paste a CA certificate directly, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Copy the CA certificate to your computer clipboard.</td>
</tr>
<tr>
<td>2</td>
<td>Choose <strong>Configure &gt; Controllers</strong>.</td>
</tr>
<tr>
<td>3</td>
<td>Click an applicable IP address.</td>
</tr>
<tr>
<td>4</td>
<td>From the left sidebar menu, choose <strong>Security &gt; IP Sec Certificates &gt; CA Certificate</strong>.</td>
</tr>
<tr>
<td>5</td>
<td>Select the <strong>Paste</strong> check box.</td>
</tr>
</tbody>
</table>
Step 6  Paste the certificate directly into the text box.
Step 7  Click Save.

Configuring ID Certificates

This page lists the existing network ID certificates by certificate name. An ID certificate can be used by web server operators to ensure secure server operation. This section contains the following topics:

- Importing a ID Certificate, page 9-101
- Pasting an ID Certificate, page 9-101

Importing a ID Certificate

To import an ID certificate from a file, follow these steps:

Step 1  Choose Configure > Controllers.
Step 2  Click an applicable IP address.
Step 3  From the left sidebar menu, choose Security > IP Sec Certificates > ID Certificate.
Step 4  From the Select a command drop-down list, choose Add Certificate.
Step 5  Click Go.
Step 6  Enter the Name and Password.
Step 7  Click Browse to navigate to the applicable certificate file.
Step 8  Click Open.
Step 9  Click Save.

Pasting an ID Certificate

To paste an ID certificate directly, follow these steps:

Step 1  Copy the ID certificate to your computer clipboard.
Step 2  Choose Configure > Controllers.
Step 3  Click an applicable IP address.
Step 4  From the left sidebar menu, choose Security > IP Sec Certificates > ID Certificate.
Step 5  From the Select a command drop-down list, choose Add Certificate.
Step 6  Click Go.
Step 7  Enter the Name and Password.
Step 8  Select the Paste check box.
Step 9  Paste the certificate directly into the text box.
Step 10  Click Save.
ID certificates are available only if the controller is running Cisco Unified Wireless Network Software Version 3.2 or higher.

To delete a certificate, select it, choose **Delete Certificates** from the Select a command drop-down list, and click **Go**.

### Configure Controllers > IPaddr > Security > Web Auth Certificate

This page enables you to download a web authorization certificate or regenerate the internally-generated web auth certificate.

To access the Web Auth Certificate page, follow these steps:

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Choose <strong>Configure &gt; Controllers</strong>.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Click an applicable IP address.</td>
</tr>
<tr>
<td>Step 3</td>
<td>From the left sidebar menu, choose <strong>Security &gt; Web Auth Certificate</strong>.</td>
</tr>
</tbody>
</table>

**Caution**

Each certificate has a variable-length embedded RSA Key. The RSA key can vary from 512 bits, which is relatively insecure, through thousands of bits, which is very secure. When you are obtaining a new certificate from a certificate authority (such as the Microsoft CA), make sure the RSA key embedded in the certificate is at least 768 Bits.

- Download Web Auth Certificate—Click to access the Download Web Auth Certificate to Controller page. See the “Download Web Auth or Web Admin Certificate to Controller” section on page 9-149 for additional information.

### Command Buttons

- Regenerate Cert—Regenerate the internally-generated web auth certificate.

### Configuring Wireless Protection Policies

This section describes the wireless protection policy configurations and contains the following topics:

- Configuring Rogue Policies, page 9-103
- Configuring Rogue AP Rules, page 9-104
- Configuring Client Exclusion Policies, page 9-104
- Configuring Controller Standard Signature Parameters, page 9-105
- Configuring Custom Signatures, page 9-108
- Configuring AP Authentication and MFP, page 9-109
Configuring Rogue Policies

This page enables you to set up policies for rogue access points.

To access the Rogue Policies page, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click an applicable IP address.

**Step 3** From the left sidebar menu, choose **Security > Wireless Protection Policies > Rogue Policies**. The following parameters appear:

- **Rogue Location Discovery Protocol—RLDP** determines whether or not the rogue is connected to the enterprise wired network. Choose one of the following from the drop-down list:
  - Disable—Disables RLDP on all access points. This is the default value.
  - All APs—Enables RLDP on all access points.
  - Monitor Mode APs—Enables RLDP only on access points in monitor mode.

**Note** Make sure that rogue detection is enabled on the desired access points. Rogue detection is enabled by default for all access points joined to a controller (except for OfficeExtend access points). However, in WCS software Release 6.0 or later, you can enable or disable rogue detection for individual access points by selecting or unselecting the **Rogue Detection** check box in the Access Point Details page. See the “Configuring Access Points” section on page 9-152 for more information.

**Note** Rogue detection is disabled by default for OfficeExtend access points because these access points, which are deployed in a home environment, are likely to detect a large number of rogue devices.

- **Rogue APs**
  - **Expiration Timeout for Rogue AP and Rogue Client Entries (seconds)**—Enter the number of seconds after which the rogue access point and client entries expire and are removed from the list.
    
    The valid range is 240 to 3600 seconds and the default value is 1200 seconds.

  **Note** If a rogue access point or client entry times out, it is removed from the controller only if its rogue state is Alert or Threat for any classification type.

- **Rogue Clients**
  - **Validate rogue clients against AAA**—Select the check box to use the AAA server or local database to validate if rogue clients are valid clients. The default value is unselected.
  - **Detect and report Adhoc networks**—Select the check box to enable ad-hoc rogue detection and reporting. The default value is selected.
Command Buttons

- Save—Save the changes made to the client exclusion policies and return to the previous page.
- Audit—Compare the WCS values with those used on the controller.

Configuring Rogue AP Rules

This page enables you to view and edit current Rogue AP Rules.

To access the Rogue AP Rules page, follow these steps:

1. Choose Configure > Controllers.
2. Click an applicable IP address.
3. From the left sidebar menu, choose Security > Wireless Protection Policies > Rogue AP Rules. The Rogue AP Rules displays the Rogue AP Rules, the rule types (Malicious or Friendly), and the rule sequence.
4. Click a Rogue AP Rule to view or edit its details. See the “Configuring a Rogue AP Rules Template” section on page 11-90 for more information.

Configuring Client Exclusion Policies

This page enables you to set, enable, or disable the client exclusion policies applied to the controller.

To access the Client Exclusion Policies page, follow these steps:

1. Choose Configure > Controllers.
2. Click an applicable IP address.
3. From the left sidebar menu, choose Security > Wireless Protection Policies > Client Exclusion Policies. The following parameters appear:
   - Excessive 802.11a Association Failures—If enabled, clients are excluded on the sixth 802.11 association attempt, after five consecutive failures.
   - Excessive 802.11a Authentication Failures—If enabled, clients are excluded on the sixth 802.11 authentication attempt, after five consecutive failures.
   - Excessive 802.11x Authentication Failures—If enabled, clients are excluded on the fourth 802.1X authentication attempt, after three consecutive failures.
   - Excessive 802.11 Web Authentication Failures—If enabled, clients are excluded on the fourth web authentication attempt, after three consecutive failures.
   - IP Theft Or Reuse—If enabled, clients are excluded if the IP address is already assigned to another device.
4. Click Save to save the changes made to the client exclusion policies and return to the previous page or click Audit to compare the WCS values with those used on the controller.
Configuring IDS Signatures

You can configure IDS Signatures, or bit-pattern matching rules used to identify various types of attacks in incoming 802.11 packets, on the controller. When the signatures are enabled, the access points joined to the controller perform signature analysis on the received 802.11 data or management frames and report any discrepancies to the controller. If an attack is detected, an appropriate mitigation action is initiated.

Cisco supports 17 standard signatures on the controller as shown on the Standard Signatures and Custom Signatures pages. For more information on these IDS Signatures, see the Cisco Wireless Control System Configuration Guide.

- Configuring Controller Standard Signature Parameters, page 9-105
- Configuring Custom Signatures, page 9-108
- Configuring AP Authentication and MFP, page 9-109

Configuring Controller Standard Signature Parameters

The Standard Signature Parameters page shows the list of Cisco-supplied signatures that are currently on the controller. This section contains the following topics:

- Downloading Signature Files, page 9-106
- Uploading Signature Files, page 9-106
- Global Settings for Standard and Custom Signatures, page 9-107

To access the Standard Signatures page, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click an applicable IP address.

**Step 3** From the left sidebar menu, choose **Security > Wireless Protection Policies > Standard Signatures**.

This page displays the following parameters:

- Precedence—The order in which the controller performs the signature checks.
- Name—The type of attack the signature is trying to detect.
- Frame Type—Management or data frame type on which the signature is looking for a security attack.
- Action—What the controller is directed to do when the signature detects an attack. For example:
  - None—No action is taken.
  - Report—Report the detection.
- State—Enabled or Disabled.
- Description—A more detailed description of the type of attack the signature is trying to detect.

**Note** Click a signature Name to view individual parameters and to enable or disable the signature.
Chapter 9  Configuring Wireless Devices

Configuring Existing Controllers

Downloading Signature Files

To download a signature file, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click an applicable IP address.

**Step 3** From the left sidebar menu, choose **Security > Wireless Protection Policies > Standard Signatures** or **Security > Wireless Protection Policies > Custom Signatures**.

**Step 4** From the **Select a command** drop-down list, choose **Download Signature Files**.

*Note* This function can also be accessed by choosing **System > Commands > Upload/Download Commands > Download IDS Signatures**.

**Step 5** Click **Go**.

**Step 6** Copy the signature file (*.sig) to the default directory on your TFTP server.

**Step 7** Choose **Local Machine** from the **File is Located On**. If you know the filename and path relative to the server root directory, you can also choose **TFTP server**.

**Step 8** Enter the maximum number of times the controller should attempt to download the signature file in the **Maximum Retries**.

**Step 9** Enter the maximum amount of time in seconds before the controller times out while attempting to download the signature file in the **Timeout**.

**Step 10** The signature files are uploaded to the c:\tftp directory. Specify the local file name in that directory or click the **Browse** button to navigate to it. A "revision" line in the signature file specifies whether the file is a Cisco-provided standard signature file or a site-tailored custom signature file (custom signature files must always have revision=custom).

*Note* If the transfer times out for some reason, you can simply choose the TFTP server option in the **File Is Located On** parameter, and the server file name will be populated for you and retried. The local machine option initiates a two-step operation. First, the local file is copied from the administrator workstation to WCS own built-in TFTP server. Then the controller retrieves that file. For later operations, the file is already in the WCS server TFTP directory, and the downloaded web page now automatically populates the filename.

**Step 11** Click **OK**.

Uploading Signature Files

To upload a signature file from the controller, follow these steps:

**Step 1** Obtain a signature file from Cisco (hereafter called a standard signature file). You can also create your own signature file (hereafter called a custom signature file) by following the “**Downloading Signature Files**” section on page 9-106.

**Step 2** Make sure you have a Trivial File Transfer Protocol (TFTP) server available for the signature download. Keep these guidelines in mind when setting up a TFTP server:
• If you are downloading through the service port, the TFTP server must be on the same subnet as the service port because the service port cannot be routed.
• If you are downloading through the distribution system network port, the TFTP server can be on the same or a different subnet because the distribution system port cannot be routed.
• A third-party TFTP server cannot run on the same computer as the Cisco WCS because WCS built-in TFTP server and third-party TFTP server use the same communication port.

Step 3  Choose Configure > Controllers.
Step 4  Click an applicable IP address.
Step 6  From the Select a command drop-down list, choose Upload Signature Files from controller.

Note  This function can also be accessed by choosing Security > Custom Signatures > Select a command > Upload Signature Files from controller or System > Commands > Upload/Download Commands > Upload File from Controller.

Step 7  Specify the TFTP server name being used for the transfer.
Step 8  If the TFTP server is new, enter the TFTP IP address in the Server IP Address parameter.
Step 9  Choose Signature Files from the File Type drop-down list.
Step 10  The signature files are uploaded to the root directory which was configured for use by the TFTP server. You can change to a different directory at the Upload to File parameter (this parameter only shows if the Server Name is the default server). The controller uses this local file name as a base name and then adds _std.sig as a suffix for standard signature files and _custom.sig as a suffix for custom signature files.
Step 11  Click OK.

Global Settings for Standard and Custom Signatures

This command enables all signatures that were individually selected as enabled. If this text box remains unselected, all files will be disabled, even those that were previously enabled. When the signatures are enabled, the access points joined to the controller perform signature analysis on the received 802.11 data or management frames and report any discrepancies to the controller.

To enable all standard and custom signatures currently on the controller, follow these steps:

Step 1  From the Select a command drop-down list, choose Edit Signature Parameters.
Step 2  Click Go.
Step 3  Select the Enable Check for All Standard and Custom Signatures check box.
Step 4  Click Save.

To enable or disable an individual signature, follow these steps:

Step 1  Click an applicable Name for the type of attack you want to enable or disable.
The Standard Signature parameters page shows the list of Cisco-supplied signatures that are currently on the controller. The Custom Signatures page shows the list of customer-supplied signatures that are currently on the controller. The following parameters are displayed in both the signature page and the detailed signature page:

- **Precedence**—The order, or precedence, in which the controller performs the signature checks.
- **Name**—The type of attack the signature is trying to detect.
- **Description**—A more detailed description of the type of attack that the signature is trying to detect.
- **Frame Type**—Management or data frame type on which the signature is looking for a security attack.
- **Action**—What the controller is directed to do when the signature detects an attack. One possibility is None, where no action is taken, and another is Report, to report the detection.
- **Frequency**—The signature frequency or the number of matching packets per interval that must be identified at the detecting access point level before an attack is detected. The range is 1 to 32,000 packets per interval and the default value is 50 packets per interval.
- **Quiet Time**—The length of time (in seconds) after which no attacks have been detected at the individual access point level, and the alarm can stop. This time appears only if the MAC information is all or both. The range is 60 to 32,000 seconds and the default value is 300 seconds.
- **MAC Information**—Whether the signature is to be tracked per network or per MAC address or both at the detecting access point level.
- **MAC Frequency**—The signature MAC frequency or the number of matching packets per interval that must be identified at the controller level before an attack is detected. The range is 1 to 32,000 packets per interval and the default value is 30 packets per interval.
- **Interval**—Enter the number of seconds that must elapse before the signature frequency threshold is reached within the configured interval. The range is 1 to 3600 seconds and the default value is 1 second.
- **Enable**—Select this check box to enable this signature to detect security attacks or unselect it to disable this signature.
- **Signature Patterns**—The pattern that is being used to detect a security attack.

**Step 2** From the Enable drop-down list, choose Yes. Because you are downloading a customized signature, you should enable the files named with the _custom.sgi and disable the standard signature with the same name but differing suffix. For example, if you are customizing broadcast probe flood, you want to disable broadcast probe flood in the standard signatures but enable it in custom signatures.

**Step 3** Click Save.

### Configuring Custom Signatures

The Custom Signature page shows the list of customer-supplied signatures that are currently on the controller.

- [Downloading Signature Files, page 9-106](#)
- [Uploading Signature Files, page 9-106](#)
- [Global Settings for Standard and Custom Signatures, page 9-107](#)

To access the Custom Signatures page, follow these steps:
Chapter 9 Configuring Wireless Devices

Configuring Existing Controllers

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click an applicable IP address.

**Step 3** From the left sidebar menu, choose **Security > Wireless Protection Policies > Custom Signatures**. This page displays the following parameters:

- **Precedence**—The order in which the controller performs the signature checks.
- **Name**—The type of attack the signature is trying to detect.
- **Frame Type**—Management or data frame type on which the signature is looking for a security attack.
- **Action**—What the controller is directed to do when the signature detects an attack. For example:
  - None—No action is taken.
  - Report—Report the detection.
- **State**—Enabled or Disabled.
- **Description**—A more detailed description of the type of attack the signature is trying to detect.

**Note**

Click a signature Name to view individual parameters and to enable or disable the signature.

**Configuring AP Authentication and MFP**

This page enables you to set the access point authentication policy.

To access the AP Authentication and MFP (Management Frame Protection) page, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click an applicable IP address.

**Step 3** From the left sidebar menu, choose **Security > Wireless Protection Policies > AP Authentication and MFP**.

- **RF Network Name**—Not an editable text box. The RF Network Name entered in the general parameters page (See Configure IPaddr > General) is displayed here.
- **Protection Type**—From the drop-down list, choose one of the following authentication policies:
  - None—No access point authentication policy.
  - AP Authentication—Apply authentication policy.
  - MFP—Apply Management Frame Protection. See the “Monitoring Management Frame Protection Summary” section on page 6-14 for more information.
- **Alarm Trigger Threshold**—(Appears only when AP Authentication is selected as the Protection Type). Set the number of hits to be ignored from an alien access point before raising an alarm. The valid range is from 1 to 255. The default value is 255.
Command Buttons

- Save
- Audit

Configuring Cisco Access Points

You can use the Configure > Controllers page to view and configure Cisco access points for a specific controller.

To access the Cisco APs page, follow these steps:

**Step 1** Choose Configure > Controllers.
**Step 2** Click an applicable IP address.
**Step 3** From the left sidebar menu, choose Access Points > Cisco APs. The Cisco APs page opens and displays the following parameters:
  - AP Name—Click an access point name to view or configure access point details.
  - Base Radio MAC
  - Admin Status
  - AP Mode
  - Software Version
  - Primary Controller Name

**Step 4** Click an access point name to view or configure the access point details. The displayed information may vary depending on the access point type.

**Note** See the “Configuring Access Points” section on page 9-152 for more detailed information.

Command Buttons

- Save—Save the current settings.
- Audit—Discover the present status of this access point.

Sniffer feature

When the sniffer feature is enabled on an access point, the access point functions as a sniffer and captures and forwards all the packets on a particular channel to a remote machine that runs AiroPeek. The packets contain information on timestamp, signal strength, packet size, and so on.

**Note** The sniffer feature can be enabled only if you are running AiroPeek, which is a third-party network analyzer software that supports decoding of data packets. For more information see the AiroPeek website.
Prerequisites for Using the Sniffer Feature

Before using the sniffer feature, you must have completed the following:

- Configured an access point in sniffer mode at the remote site. For information on how to configure an access point in sniffer mode, see AP mode in Configuring an AP in Sniffer Mode Using the Web User Interface.
- Installed AiroPeek version 2.05 or later on a Windows XP machine.

Note: You must be a WildPackets Maintenance Member to download the following dll files. See the following URL:

https://wpdn.wildpackets.com/view_submission.php?id=30

- Copied the following dll files:
  - socket.dll file to the Plugins folder (Example: C:\ProgramFiles\WildPackets\AiroPeek\Plugins)
  - socketres.dll file to the PluginRes folder (Example: C:\ProgramFiles\WildPackets\AiroPeek\1033\PluginRes)

Configuring AiroPeek on the Remote Machine

To configure AiroPeek on the remote machine, follow these steps:

**Step 1** Start the AiroPeek application and click **Options** on the Tools tab.

**Step 2** Click **Analysis Module** in the Options page.

**Step 3** Right-click inside the page and select **Disable All** option.

**Step 4** Find the Cisco remote module column and enable it. Click **OK** to save the changes.

**Step 5** Click **New capture** to bring up the capture option page.

**Step 6** Choose the remote Cisco adapter and from the list of adapter modules.

**Step 7** Expand it to locate the new remote adapter option. Double-click it to open a new page, enter a name in the text box provided and enter the controller management interface IP in the IP address column.

**Step 8** Click **OK**. The new adapter will be added to the remote Cisco adapter.

**Step 9** Select the new adapter for remote airopeek capture using the access point.

**Step 10** Click **start socket capture** in the capture page to start the remote capture process.

**Step 11** Go to the controller CLI, bring up an access point, and set it to sniffer mode by entering the **config ap mode sniffer ap-name** command.

The access point will reboot and come up in sniffer mode.

Configuring an AP in Sniffer Mode Using the Web User Interface

To configure an AP in Sniffer Mode using the web user interface, follow these steps:

**Step 1** Choose **Configure > Access Points**, then click an item under AP Name list to navigate to this pane.

**Step 2** In General parameters, set the AP mode to Sniffer using the drop-down list, and click **Apply**.
Configuring Existing Controllers

Step 3 Select a Protocol (802.11a/802.11b/g) under Radio Interfaces. This will open the configuration page.

Step 4 Select the Sniff check box to bring up the Sniff parameters. Select the channel to be sniffed and enter the IP address of the server (The remote machine running AiroPeek).

Step 5 Click Save to save the changes.

Configuring 802.11 Parameters

- Configuring General Parameters for an 802.11 Controller, page 9-112
- Configuring Security Parameters, page 9-82
- Configuring Aggressive Load Balancing, page 9-113
- Configuring Band Selection, page 9-114
- Configuring 802.11 Media Parameters, page 9-117

Configuring General Parameters for an 802.11 Controller

This page enables you to edit country selection and timer information on a 802.11 controller. To access this page, follow these steps:

Step 1 Choose Configure > Controllers.

Step 2 Click an applicable IP address.

Step 3 From the left sidebar menu, choose 802.11 > General. The page opens and displays the following parameters:

- Country
  - Country—Countries and the protocols allowed.

  Note: The maximum number of countries that you can select is 20.

  - Selected Countries—Displays countries currently selected.

- Timers
  - Authentication Response Timeout—Configures 802.11 authentication response timeout in seconds.

Setting Multiple Country Codes

To set multiple country support for a single controller(s) that is not part of a mobility group, follow these steps:

Step 1 Choose Configure > Controllers.

Step 2 Click the controller for which you are adding countries.
Configuring Existing Controllers

Step 3  Choose 802.11 > General from the left sidebar menu.

Step 4  Select the check box to choose which country you want to add. Access points are designed for use in many countries with varying regulatory requirements. You can configure a country code to ensure that it complies with your country regulations.

---

**Note**
Access points may not operate properly if they are not designed for use in your country of operation. For example, an access point with part number AIR-AP1030-A-K9 (which is included in the Americas regulatory domain) cannot be used in Australia. Always be sure to purchase access points that match your country regulatory domain. For a complete list of country codes supported per product, see [http://www.cisco.com/warp/public/779/smbiz/wireless/approvals.html](http://www.cisco.com/warp/public/779/smbiz/wireless/approvals.html).

---

Step 5  Enter the time (in seconds) after which the authentication response will timeout.

Step 6  Click Save.

---

Configuring Aggressive Load Balancing

Enabling aggressive load balancing on the controller allows lightweight access points to load balance wireless clients across access points.

---

**Note**
Clients are load balanced between access points on the same controller. Load balancing does not occur between access points on different controllers.

When a wireless client attempts to associate to a lightweight access point, association response packets are sent to the client with an 802.11 response packet including status code 17. This code indicates whether the access point can accept any more associations. If the access point is too busy, the client attempts to associate to a different access point in the area. The system determines if an access point is relatively more busy than its neighbor access points that are also accessible to the client.

For example, if the number of clients on AP1 is more than the number of clients on AP2 plus the load-balancing window, then AP1 is considered to be busier than AP2. When a client attempts to associate to AP1, it receives an 802.11 response packet with status code 17, indicating that the access point is busy, and the client attempts to associate to a different access point.

You can configure the controller to deny client associations up to 10 times (if a client attempted to associate 11 times, it would be allowed to associate on the 11th try). You can also enable or disable load balancing on a particular WLAN, which is useful if you want to disable load balancing for a select group of clients (such as time-sensitive voice clients).

To configure aggressive load balancing, follow these steps:

---

Step 1  Choose Configure > Controllers.

Step 2  Choose the controller that you need to configure.

Step 3  Choose 802.11 > Load Balancing from the left sidebar menu. The load balancing page appears (see Figure 9-11).
Step 4  Enter a value between 1 and 20 for the client window size. The page size becomes part of the algorithm that determines whether an access point is too heavily loaded to accept more client associations:

\[
\text{load-balancing page + client associations on AP with lightest load = load-balancing threshold}
\]

In the group of access points accessible to a client device, each access point has a different number of client associations. The access point with the lowest number of clients has the lightest load. The client page size plus the number of clients on the access point with the lightest load forms the threshold. Access points with more client associations than this threshold is considered busy, and clients can associate only to access points with client counts lower than the threshold.

Step 5  Enter a value between 0 and 10 for the max denial count. The denial count sets the maximum number of association denials during load balancing.

Step 6  Click Save.

Step 7  To enable or disable aggressive load balancing on specific WLANs, browse to the WLAN Configuration page, and click the Advanced tab. For instructions on using the WLAN Configuration page, see the “Configuring Controller WLANs” section on page 9-63.

**Configuring Band Selection**

Band selection enables client radios that are capable of dual-band (2.4- and 5-GHz) operation to move to a less congested 5-GHz access point. The 2.4-GHz band is often congested. Clients on this band typically experience interference from Bluetooth devices, microwave ovens, and cordless phones as well as co-channel interference from other access points because of the 802.11b/g limit of three non-overlapping channels. To combat these sources of interference and improve overall network performance, you can configure band selection on the controller.

Band selection works by regulating probe responses to clients. It makes 5-GHz channels more attractive to clients by delaying probe responses to clients on 2.4-GHz channels.

You can enable band selection globally on a controller, or you can enable or disable band selection for a particular WLAN, which is useful if you want to disable it for a select group of clients (such as time-sensitive voice clients).
Note

Band-selection-enabled WLANs do not support time-sensitive applications like voice and video because of roaming delays.

Guidelines for Using Band Selection

Follow these guidelines when using band selection:

- Band selection can be used only with Cisco Aironet 1140 and 1250 series access points.
- Band selection operates only on access points that are connected to a controller. A hybrid-REAP access point without a controller connection does not perform band selection after a reboot.
- The band-selection algorithm directs dual-band clients only from the 2.4-GHz radio to the 5-GHz radio of the same access point, and it only runs on an access point when both the 2.4-GHz and 5-GHz radios are up and running.
- You can enable both band selection and aggressive load balancing on the controller. They run independently and do not impact one another.

Configuration Steps

To configure band selection, follow these steps:

Step 1 Choose Configure > Controllers.

Step 2 Choose the controller that you need to configure.

Step 3 Choose 802.11 > Band Select from the left sidebar menu. The band select page appears (see Figure 9-12).

Figure 9-12 Band Select

Step 4 Enter a value between 1 and 10 for the probe cycle count. The cycle count sets the number of suppression cycles for a new client. The default cycle count is 2.

Step 5 Enter a value between 1 and 1000 milliseconds for the scan cycle period threshold. This setting determines the time threshold during which new probe requests from a client come from a new scanning cycle. The default cycle threshold is 200 milliseconds.
Chapter 9  Configuring Wireless Devices

Configuring Existing Controllers

Step 6  Enter a value between 10 and 200 seconds for the age out suppression parameter. Age-out suppression sets the expiration time for pruning previously known 802.11b/g clients. The default value is 20 seconds. After this time elapses, clients become new and are subject to probe response suppression.

Step 7  Enter a value between 10 and 300 seconds for the age out dual band parameter. The age-out period sets the expiration time for pruning previously known dual-band clients. The default value is 60 seconds. After this time elapses, clients become new and are subject to probe response suppression.

Step 8  Enter a value between –20 and –90 dBm for the acceptable client RSSI parameter. This parameter sets the minimum RSSI for a client to respond to a probe. The default value is –80 dBm.

Step 9  Click Save.

Step 10  To enable or disable band selection on specific WLANs, browse to the WLAN Configuration page and click the Advanced tab. For instructions on using the WLAN Configuration page, see the “Configuring Controller WLANs” section on page 9-63.

Configuring Preferred Call

The Preferred Call feature enables you to specify highest priority to SIP calls made to some specific numbers. The high priority is achieved by allocating bandwidth to such preferred SIP Calls even when there is no available voice bandwidth in the configured Voice Pool. This feature is supported only for those clients that use SIP based CAC for bandwidth allocation in WCS or WLC.

Note You can configure up to 6 numbers per controller.

To configure the preferred call support, follow these steps:

Step 1  Choose Configure > Controllers.

Step 2  Click the IP address of the applicable controller.

Step 3  From the left sidebar menu, choose 802.11 > Preferred Call. The following parameters appear if there is an existing preferred call:

- Description—Description for the preferred call.
- Number Id—Indicates the unique identifier for the controller and denotes one of the six preferred call numbers assigned to the controller.
- Preferred Number—Indicates the preferred call number.

Step 4  From the Select a command drop-down list, choose Add Number.

Figure 9-13  Preferred Call
Step 5  Select a template to apply to this controller.

**Note**  You need to select a template to apply to the selected controller. To create a New Template for Preferred Call Numbers, see the “Configuring Preferred Call Templates” section on page 11-97.

Step 6  Click **Apply**.

**Note**  To delete a preferred call, select the check box for the applicable preferred call number and choose **Delete** from the Select a command drop-down list. Click **Go** and then click **OK** to confirm the deletion.

### Configuring 802.11 Media Parameters

To configure the media parameters for 802.11, follow these steps:

**Step 1**  Choose **Configure > Controllers**.

**Step 2**  Click the applicable IP address.

**Step 3**  From the left sidebar menu, choose **802.11 > Media Parameters**.

**Step 4**  In the Media Stream Configuration section, specify the following parameters:

- Media Stream Name
- Multicast Destination Start IP—Start IP address of the media stream to be multicast
- Multicast Destination End IP—End IP address of the media stream to be multicast
- Maximum Expected Bandwidth—Maximum bandwidth that a media stream can use

**Step 5**  In the Resource Reservation Control (RRC) Parameters area, specify the following parameters:

- Average Packet Size—Average packet size that a media stream can use.
- RRC Periodical Update—Resource Reservation Control calculations that are updated periodically; if disabled, RRC calculations are done only once when a client joins a media stream.
- RRC Priority—Priority of RRC with the highest at 1 and the lowest at 8.
- Traffic Profile Violation—Appears if the stream is dropped or put in the best effort queue if the stream violates the QoS video profile.
- Policy—Appears if the media stream is admitted or denied.

**Step 6**  Click **Save**.

### Configuring 802.11a/n Parameters

This section contains the following topics:

- Configuring 802.11a/n General Parameters, page 9-118
- Configuring 802.11a/n 802.11h Parameters, page 9-128
Chapter 9      Configuring Wireless Devices

Configuring Existing Controllers

- Configuring 802.11a/n RRM Intervals, page 9-120
- Configuring 802.11a/n RRM Dynamic Channel Allocation, page 9-121
- Configuring 40-MHz Channel Bonding, page 9-122
- Configuring 802.11a/n RRM Radio Grouping, page 9-124
- Configuring 802.11a/n Media Parameters, page 9-124
- Configuring 802.11a/n EDCA Parameters, page 9-127
- Configuring 802.11a/n Roaming Parameters, page 9-127
- Configuring 802.11a/n 802.11h Parameters, page 9-128
- Configuring 802.11a/n High Throughput (802.11n) Parameters, page 9-129
- Configuring 802.11a/n CleanAir Parameters, page 9-129

Configuring 802.11a/n General Parameters

To view 802.11a/n parameters for a specific controller, follow these steps:

---

**Step 1** Choose Configure > Controllers.

**Step 2** Click an applicable IP address.

**Step 3** From the left sidebar menu, choose 802.11a/n Parameters to view the following parameters:

- **General**
  - 802.11a/n Network Status—Select the check box to enable.
  - Beacon Period—The amount of time between beacons. The valid range is from 100 to 600 milliseconds.
  - DTIM Period—The number of beacon intervals that may elapse between transmission of beacon frames containing a traffic indicator message (TIM) element whose delivery count field is 0.
  - Fragmentation Threshold (in bytes)—The size at which packets are fragmented. Use a low setting in areas where communication is poor or where there is a great deal of radio interference.
  - Template Applied

- **802.11a/n Band Status**
  - Low, Medium, and High Bands (read-only).

- **802.11a/n Power Status**
  - Dynamic Assessment—Automatic, On Demand, or Disabled.
  - Current Tx Level—Range includes: 1 (maximum power allowed per country code setting), 2 (50% power), 3 (25% power), 4 (6.25 to 12.5% power), and 5 (0.195 to 6.25% power).

  **Note** The power levels and available channels are defined by the country code setting and are regulated on a country by country basis.

  - Control Interval—in seconds (read-only).
  - Dynamic Treatment Power Control—Select the check box to enable.

- **802.11a/n Channel Status**
Configuring Existing Controllers

- Assignment Mode—Automatic, On Demand, or Disabled.
- Update Interval—in seconds.
- Avoid Foreign AP Interference—Enable to have RRM consider interference from foreign Cisco access points (those non-Cisco access points outside RF/mobility domain) when assigning channels.
- Avoid Cisco AP load—Enable to have controllers consider the traffic bandwidth used by each access point when assigning channels to access points.
- Avoid non 802.11 Noise—Enable to have access points avoid channels that have interference from non-access point sources, such as microwave ovens or Bluetooth devices. Disable this parameter to have RRM ignore this interference.
- Signal Strength Contribution—Not configurable.
- Avoid Persistent Non-WiFi interface

- Data Rates
  - Ranges between 6 Mbps and 54 Mbps—Supported, Mandatory, or Disabled.

- Noise/Interference/Rogue Monitoring Channels.
  - Channel List—All Channels, Country Channels, DCA Channels.

**Note**
Dynamic Channel Allocation (DCA) automatically selects a reasonably good channel allocation from a set of managed devices connected to the controller.

- CCX Location Measurement—When enabled, it enhances the location accuracy of clients.
  - Mode—Select the check box to enable.
  - Interval—in seconds.

**Note**
The CCX Location Measurement Interval can be changed only when measurement mode is enabled.

**Command Buttons**

- Save—Save the changes made.
- Audit—Compare the WCS values with those used on the controller.

**Configuring 802.11a/n RRM Thresholds**

To configure a 802.11a/n RRM threshold controller, follow these steps:

**Step 1** Choose **Configure > Controller**.

**Step 2** Click an applicable IP address.

**Step 3** From the left sidebar menu, choose **802.11a/n > RRM Thresholds**.

**Step 4** Make any necessary changes to Coverage Thresholds, Load Thresholds, Other Thresholds, and Noise/Interference/Rogue Monitoring Channels.
When the Coverage Thresholds Min SNR Level (dB) parameter is adjusted, the value of the Signal Strength (dB) automatically reflects this change. The Signal Strength (dB) parameter provides information regarding what the target range of coverage thresholds will be when adjusting the SNR value.

Step 5  Click Save.

Configuring 802.11a/n RRM Intervals

To configure 802.11a/n or 802.11b/g/n RRM intervals for an individual controller, follow these steps:

Step 1  Choose Configure > Controller.
Step 2  Click an applicable IP address.
Step 3  From the left sidebar menu, choose 802.11a/n > RRM Intervals or 802.11b/g/n > RRM Intervals.

Note  The default for the following four RRM interval parameters is 300 seconds.

Step 4  Enter at which interval you want strength measurements taken for each access point.
Step 5  Enter at which interval you want noise and interference measurements taken for each access point.
Step 6  Enter at which interval you want load measurements taken for each access point.
Step 7  Enter at which interval you want coverage measurements taken for each access point.
Step 8  Click Save.

Configuring 802.11a/n RRM Transmit Power Control

The controller dynamically controls access point transmit power based on real-time wireless LAN conditions. Normally, power can be kept low to gain extra capacity and reduce interference. The controller attempts to balance the access points' transmit power according to how the access points are seen by their third strongest neighbor.

The transmit power control (TPC) algorithm both increases and decreases an access point's power in response to changes in the RF environment. In most instances TPC will seek to lower an access point's power to reduce interference, but in the case of a sudden change in the RF coverage—for example, if an access point fails or becomes disabled—TPC can also increase power on surrounding access points. This feature is different from Coverage Hole Detection, explained below. Coverage hole detection is primarily concerned with clients, while TPC is tasked with providing enough RF power to achieve desired coverage levels while avoiding channel interference between access points.

To configure 802.11a/n or 802.11b/g/n RRM TPC, follow these steps:

Step 1  Choose Configure > Controller.
Step 2  Click an applicable IP address.
Step 3  From the left sidebar menu, choose 802.11a/n-RRM > TPC.
Step 4 Configure the following TPC parameters:

- **Template Applied**—The name of the template applied to this controller.
- **Dynamic Assignment**—From the Dynamic Assignment drop-down list, choose one of three modes:
  - Automatic - The transmit power is periodically updated for all access points that permit this operation.
  - On Demand - Transmit power is updated when the Assign Now button is selected.
  - Disabled - No dynamic transmit power assignments occur, and values are set to their global default.
- **Maximum Power Assignment**—Indicates the maximum power assigned.
  - Range: -10 to 30 dB
  - Default: 30 dB
- **Minimum Power Assignment**—Indicates the minimum power assigned.
  - Range: -10 to 30 dB
  - Default: 30 dB
- **Dynamic Tx Power Control**—Determine if you want to enable Dynamic Tx Power Control.
- **Transmitted Power Threshold**—Enter a transmitted power threshold between -50 and -80.
- **Control Interval**—In seconds (read-only).

Step 5 Click Save.

**Configuring 802.11a/n RRM Dynamic Channel Allocation**

The Radio Resource Management (RRM) Dynamic Channel Allocation (DCA) page allows you to select the DCA channels as well as the channel width for this controller.

RRM DCA supports 802.11n 40 MHz channel width in the 5 GHz band. 40 MHz channelization allows radios to achieve higher instantaneous data rates.

*Note* Selecting a larger bandwidth reduces the non-overlapping channels which could potentially reduce the overall network throughput for certain deployments.

To configure 802.11a/n or 802.11b/g/n RRM DCA channel width for an individual controller, follow these steps:

Step 1 Choose Configure > Controller.

Step 2 Click an applicable IP address.

Step 3 From the left sidebar menu, choose 802.11a/n-RRM > DCA.

Step 4 From the Channel width drop-down list, choose 20 MHz or 40 MHz.

*Note* To view the channel width for an access point radio, choose Monitor > Access Points > name > Interfaces tab.
Configuring Existing Controllers

Note Channel width can also be configured from the Configure Access Point. See the “RF Channel Assignment” section on page 9-182 for more information.

Note The DCA channel width option is only available for the 802.11 a/n protocol.

Step 5 Select the check box(es) for the applicable DCA channel(s). The selected channels are listed in the Selected DCA channels text box.

Step 6 Enable or disable event-driven radio resource management (RRM). Event Driven RRM is used when a CleanAir-enabled access point detects a significant level of interference, follow these steps:
- Event Driven RRM—Enable or Disable spectrum event-driven RRM. By default, Event Driven RRM is enabled.
- Sensitivity Threshold—If Event Driven RRM is enabled, this text box displays the threshold level at which event-driven RRM is triggered. It can have a value of either Low, Medium, or High. When the interference for the access point rises above the threshold level, RRM initiates a local Dynamic Channel Assignment (DCA) run and changes the channel of the affected access point radio if possible to improve network performance. Low represents a decreased sensitivity to changes in the environment while High represents an increased sensitivity.

Step 7 Click Save.

Configuring 40-MHz Channel Bonding

The Radio Resource Management (RRM) Dynamic Channel Assignment (DCA) page allows you to choose the DCA channels as well as the channel width for this controller.

RRM DCA supports 802.11n 40-MHz channel width in the 5-GHz band. The higher bandwidth allows radios to achieve higher instantaneous data rates.

Note Choosing a larger bandwidth reduces the non-overlapping channels which could potentially reduce the overall network throughput for certain deployments.

To configure 802.11 a/n RRM DCA channels for an individual controller, follow these steps:

Step 1 Choose Configure > Controllers.

Step 2 Click the IP address of the appropriate controller.

Step 3 From the left sidebar menu, choose 802.11a/n > RRM DCA. The 802.11a/n RRM DCA page appears (see Figure 9-14).

Note You can also configure the channel width on the access point page by choosing Configure > Access Points, and clicking the 802.11a/n link in the Radio column. The Current RF Channel Assignment. is provided, and you can choose a Global assignment method or choose Custom to specify a channel.
Step 4  From the Channel Width drop-down list, choose **20 MHz** or **40 MHz**. Prior to software release 5.1, 40-MHz channels were only statically configurable. Only radios with 20-MHz channels were supported by DCA. With 40 MHz, radios can achieve higher instantaneous data rates; however, larger bandwidths reduce the number of non-overlapping channels so certain deployments could have reduced overall network throughput.

*Note*  Be cautious about deploying a mix of 20-MHz and 40-MHz devices. The 40-MHz devices have slightly different channel access rules which may negatively impact the 20-MHz devices.

*Note*  To view the channel width for an access point’s radio, go to Monitor > Access Points > *name* > Interfaces tab. You can also view the channel width and antenna selections by choosing Configure > Access Points and clicking on the desired radio in the Radio column.

Step 5  Select the check boxes for the appropriate DCA channels. The selected channels are listed in the Selected DCA channels list.

Step 6  Enable or disable event-driven Radio Resource Management (RRM) using the following parameters. Event Driven RRM is used when a CleanAir-enabled access point detects a significant level of interference.

- Event Driven RRM—Enable or Disable spectrum event-driven RRM. By default, Event Driven RRM is enabled.
• Sensitivity Threshold—If Event Driven RRM is enabled, this field displays the threshold level at which event-driven RRM is triggered. It can have a value of either Low, Medium, or High. When the interference for the access point rises above the threshold level, RRM initiates a local Dynamic Channel Assignment (DCA) run and changes the channel of the affected access point radio if possible to improve network performance. Low represents a decreased sensitivity to changes in the environment while High represents an increased sensitivity.

Step 7 Click Save.

Configuring 802.11a/n RRM Radio Grouping

To configure 802.11a/n or 802.11b/g/n RRM Radio Grouping for an individual controller, follow these steps:

Step 1 Choose Configure > Controller.
Step 2 Click an applicable IP address.
Step 3 From the left sidebar menu, choose 802.11a/n > RRM > RF Grouping.
Step 4 Choose a grouping mode from the drop-down list. The following parameters appear:
  • Automatic—Allows you to activate the automatic RRM Grouping Algorithm. This is the default mode.
  • Off—Allows you to deactivate the automatic grouping.
  • Leader—Allows you to assign members to the group.
Step 5 Choose a group update interval (secs) from the drop-down list. When grouping is on, this interval (in seconds) represents the period with which the grouping algorithm is run by the Group Leader. Grouping algorithm will also run when the group contents changes and the automatic grouping is enabled. A dynamic grouping can be started upon request from the system administrator. Default value is 600 seconds.
Step 6 In the Group Members area, click Add >. The selected controller moves from the Available Controllers to the RF Group Members list.

Note The RF Group Members area appears only when the grouping mode is set to Leader.

Note The maximum number of controllers that can be added to a RF Group is 20.

Step 7 Click Save.

Configuring 802.11a/n Media Parameters

To configure the media parameters for 802.11a/n, follow these steps:

Step 1 Choose Configure > Controllers.
Step 2 Click the applicable IP address.
Step 3  From the left sidebar menu, choose **802.11a/n > Media Parameters**.

Step 4  In the **Voice** tab, specify the following parameters:

- Admission Control (ACM)—Select the check box to enable admission control.
  
  For end users to experience acceptable audio quality during a VoIP phone call, packets must be delivered from one endpoint to another with low latency and low packet loss. To maintain QoS under differing network loads, call admission control (CAC) is required. CAC on an access point allows it to maintain controlled QoS when the network is experiencing congestion and keep the maximum allowed number of calls to an acceptable quantity.

- CAC Method—If Admission Control (ACM) is enabled, specify the CAC method as either load-based or static.
  
  Load-based CAC incorporates a measurement scheme that takes into account the bandwidth consumed by all traffic types from itself, from co-channel access points, and by co-located channel interference. Load-based CAC also covers the additional bandwidth consumption resulting from PHY and channel impairment.

  In load-based CAC, the access point periodically measures and updates the utilization of the RF channel, channel interference, and the additional calls that the access point can admit. The access point admits a new call only if the channel has enough unused bandwidth to support that call. By doing so, load-based CAC prevents over-subscription of the channel and maintains QoS under all conditions of WLAN loading and interference.

- Maximum Bandwidth Allowed—Specify the percentage of maximum bandwidth allowed. This option is only available when CAC is enabled.

- Reserved Roaming Bandwidth—Specify the percentage of reserved roaming bandwidth. This option is only available when CAC is enabled.

- Expedited Bandwidth—Select the check box to enable expedited bandwidth as an extension of CAC for emergency calls.

  You must have an expedited bandwidth that is CCXv5 compliant so that a TSPEC request is given higher priority.

- SIP CAC—Select the check box to enable SIP CAC.

  SIP CAC should be used only for phones that support status code 17 and do not support TSPEC-based admission control.

- SIP Codec—Specify the codec name you want to use on this radio. The available options are G.711, G.729, and User Defined.

- SIP Call Bandwidth—Specify the bandwidth in kilobits per second that you want to assign per SIP call on the network. This parameter can be configured only when the SIP Codec selected is User Defined.

- SIP Sample Interval—Specify the sample interval in milliseconds that the codec must operate in.

- Max Voice Calls per Radio—Specify the maximum number of voice calls that can be made per Radio.

- Max Roaming Reserved Calls per Radio—Specify the maximum number roaming calls that can be reserved per Radio.

---

**Note**  The **Max Voice Calls per Radio** and **Max Roaming Reserved Calls per Radio** options are available only if the CAC Method is specified as Static and SIP CAC is enabled.

- Metric Collection—Select the check box to enable metric collection.
Traffic stream metrics are a series of statistics about VoIP over your wireless LAN which inform you of the QoS of the wireless LAN. For the access point to collect measurement values, traffic stream metrics must be enabled. When this is enabled, the controller begins collecting statistical data every 90 seconds for the 802.11b/g interfaces from all associated access points. If you are using VoIP or video, this feature should be enabled.

**Step 5** On the **Video** tab, specify the following parameters:

- Admission Control (ACM)—Select the check box to enable admission control.
- Maximum Bandwidth Allowed—Specify the percentage of maximum bandwidth allowed. This option is only available when CAC is enabled.
- Reserved Roaming Bandwidth—Specify the percentage of reserved roaming bandwidth. This option is only available when CAC is enabled.
- Unicast Video Redirect—Select the **Unicast Video Redirect** check box to enable all non-media stream packets in video queue are redirected to the best effort queue. If disabled, all packets with video marking are kept in video queue.
- Client Minimum Phy Rate—Specify the physical data rate required for the client to join a media stream from the Client Minimum Phy Rate drop-down list.
- Multicast Direct Enable—Select the **Multicast Direct Enable** check box to set the Media Direct for any WLAN with Media Direct enabled on a WLAN on this radio.
- Maximum Number of Streams per Radio—Specify the maximum number of streams per Radio to be allowed.
- Maximum Number of Streams per Client—Specify the maximum number of streams per Client to be allowed.
- Best Effort QOS Admission—Select the Best Effort QOS Admission check box to redirect new client requests to the best effort queue. This happens only if all the video bandwidth has been used.

**Note** If disabled and maximum video bandwidth has been used, then any new client request is rejected.

**Step 6** In the **General** tab, specify the following parameter:

- Maximum Media Bandwidth (0 to 85%)—Specify the percentage of maximum of bandwidth allowed. This option is only available when CAC is enabled.

**Step 7** Click **Save**.

**Note** SIPs are available only on the following controllers: 4400, 5500 and on for the following access points: 1240, 1130, and 11n.

**Command Buttons**

- **Save**—Save the changes made.
- **Audit**—Compare the WCS values with those used on the controller.

**Related Topics**

- Configuring Media Parameters for Controller Templates
Configuring 802.11a/n EDCA Parameters

The EDCA parameters (EDCA profile and Streaming MAC Enable settings) for 802.11a/n and 802.11b/g/n can be configured either by individual controller or through a controller template to improve voice QoS support.

To configure 802.11a/n or 802.11b/g/n EDCA parameters for an individual controller, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click an applicable IP address.

**Step 3** From the left sidebar menu, choose **802.11a/n > EDCA Parameters** or **802.11b/g/n > EDCA Parameters**.

**Step 4** Choose the EDCA Profile from the drop-down list.

| Note | Profiles include Wi-Fi Multimedia (WMM), Spectralink Voice Priority (SVP), Voice Optimized, and Voice & Video Optimized. WMM is the default EDCA profile. |

| Note | You must shut down radio interface before configuring EDCA Parameters. |

**Step 5** Select the **Enable Streaming MAC** check box to enable this feature.

| Note | Only enable Streaming MAC if all clients on the network are WMM compliant. |

Configuring 802.11a/n Roaming Parameters

To configure 802.11a/n or 802.11b/g/n EDCA parameters for an individual controller, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click an applicable IP address.

**Step 3** From the left sidebar menu, choose **802.11a/n > Roaming Parameters**.

**Step 4** From the Mode drop-down list, choose **Default values** or **Custom values**.

- **Default values**—The default values (read-only) are automatically displayed in the text boxes.
- **Custom values**—Activates the text boxes to enable editing of the roaming parameters.

**Step 5** In the Minimum RSSI text box, enter a value for the minimum Received Signal Strength Indicator (RSSI) required for the client to associate to an access point.

- Range: -80 to -90 dBm
- Default: -85 dBm
Chapter 9  Configuring Wireless Devices

Configuring Existing Controllers

Note If the client average received signal power dips below this threshold, reliable communication is typically impossible; clients must already have found and roamed to another access point with a stronger signal before the minimum RSSI value is reached.

Step 6 In the Hysteresis text box, enter a value to indicate how strong the signal strength of a neighboring access point must for the client to roam to it.

This parameter is intended to reduce the amount of “ping ponging” between access points if the client is physically located on or near the border between two access points.

- Range: 2 to 4 dB
- Default: 3 dB

Step 7 In the Adaptive Scan Threshold text box, enter the RSSI value, from a client associated access point, below which the client must be able to roam to a neighboring access point within the specified transition time.

This parameter provides a power-save method to minimize the time that the client spends in active or passive scanning. For example, the client can scan slowly when the RSSI is above the threshold and scan more rapidly when below the threshold.

- Range: -70 to -77 dB
- Default: -72 dB

Step 8 In the Transition Time text box, enter the maximum time allowed for the client to detect a suitable neighboring access point to roam to and to complete the roam, whenever the RSSI from the client associated access point is below the scan threshold.

The Scan Threshold and Transition Time parameters guarantee a minimum level of client roaming performance. Together with the highest expected client speed and roaming hysteresis, these parameters make it possible to design a wireless LAN network that supports roaming simply by ensuring a certain minimum overlap distance between access points.

- Range: 1 to 10 seconds
- Default: 5 seconds

Step 9 Click Save.

Configuring 802.11a/n 802.11h Parameters

To configure 802.11h parameters for an individual controller, follow these steps:

Step 1 Choose Configure > Controller.

Step 2 Click an applicable IP address.

Step 3 From the left sidebar menu, choose 802.11a/n > 802.11h or 802.11b/g/n > 802.11h.

Step 4 Select the power constraint check box to enable TPC.

Step 5 Select the channel announcement check box to enable channel announcement. Channel announcement is a method in which the access point announces when it is switching to a new channel and the new channel number.
Configuring Existing Controllers

Step 6 Click Save.

Configuring 802.11a/n High Throughput (802.11n) Parameters

To configure 802.11a/n or 802.11b/g/n high throughput parameters, follow these steps:

Step 1 Choose Configure > Controller.
Step 2 Click an applicable IP address.
Step 3 From the left sidebar menu, choose 802.11a/n > High Throughput or 802.11b/g/n > High Throughput.
Step 4 Select the 802.11n Network Status Enabled check box to enable high throughput.
Step 5 In the MCS (Data Rate) Settings, choose which level of data rate you want supported. MCS is modulation coding schemes which are similar to 802.11a data rate. As a default, 20 MHz and short guarded interval is used.

Note When you select the Supported check box, the chosen numbers appear in the Selected MCS Indexes page.

Step 6 Click Save.

Configuring 802.11a/n CleanAir Parameters

To configure 802.11a/n CleanAir parameters, follow these steps:

Step 1 Choose Configure > Controller.
Step 2 Click an applicable IP address.
Step 3 From the left sidebar menu, choose 802.11a/n > CleanAir to view the following information.

- CleanAir—Select the check box to enable CleanAir functionality on the 802.11 a/n network, or unselect to disable CleanAir functionality. The default value is selected.
- Reporting Configuration—Use the parameters in this section to configure the interferer devices you want to include for your reports.
  - Report—Select the report interferers check box to enable CleanAir system to report and detect sources of interference, or unselect it to prevent the controller from reporting interferers. The default value is selected.
  - Make sure that any sources of interference that need to be detected and reported by the CleanAir system appear in the Interferences to Detect text box and any that do not need to be detected appear in the Interferers to Ignore text box. Use the > and < buttons to move interference sources between these two text boxes. By default, all interference sources are detected.
- Alarm Configuration—This section enables you to configure triggering of air quality alarms.
  - Air Quality Alarm—Select the Air Quality Alarm check box to enable the triggering of air quality alarms, or unselect the box to disable this feature. The default value is selected.
Chapter 9 Configuring Wireless Devices

Configuring Existing Controllers

- Air Quality Alarm Threshold—If you selected the Air Quality Alarm check box, enter a value between 1 and 100 (inclusive) in the Air Quality Alarm Threshold text box to specify the threshold at which you want the air quality alarm to be triggered. When the air quality falls below the threshold level, the alarm is triggered. A value of 1 represents the worst air quality, and 100 represents the best. The default value is 35.

- Interferers For Security Alarm—Select the Interferers For Security Alarm check box to trigger interferer alarms when the controller detects specified device types, or unselect it to disable this feature. The default value is selected.

- Make sure that any sources of interference that need to trigger interferer alarms appear in the Interferers Selected for Security Alarms text box and any that do not need to trigger interferer alarms appear in the Interferers Ignored for Security Alarms text box. Use the > and < buttons to move interference sources between these two boxes. By default, all interference sources trigger interferer alarms.

- Event Driven RRM—To trigger spectrum event-driven Radio Resource Management (RRM) to run when a CleanAir-enabled access point detects a significant level of interference, follow these steps:
  - Event Driven RRM—Displays the current status of spectrum event-driven RRM.
  - Sensitivity Threshold—If Event Driven RRM is enabled, this text box displays the threshold level at which event-driven RRM is triggered. It can have a value of either Low, Medium, or High. When the interference for the access point rises above the threshold level, RRM initiates a local Dynamic Channel Assignment (DCA) run and changes the channel of the affected access point radio if possible to improve network performance. Low represents a decreased sensitivity to changes in the environment while High represents an increased sensitivity.

Command Buttons

- Save—Save the changes made.
- Audit—Compare the WCS values with those used on the controller.

Configuring 802.11b/g/n Parameters

This section contains the following topics:

- Configuring 802.11b/g/n General Parameters, page 9-131
- Configuring 802.11b/g/n RRM Thresholds, page 9-132
- Configuring 802.11b/g/n RRM Intervals, page 9-133
- Configuring an 802.11b/g/n RRM DCA, page 9-134
- Configuring 802.11b/g/n RRM Radio Grouping, page 9-134
- Configuring 802.11b/g/n Media Parameters, page 9-135
- Configuring 802.11b/g/n EDCA Parameters, page 9-137
- Configuring 802.11b/g/n Roaming Parameters, page 9-138
- Configuring 802.11b/g/n High Throughput (802.11n) Parameters, page 9-139
- Configuring 802.11b/g/n CleanAir Parameters, page 9-139
Configuring 802.11b/g/n General Parameters

To view 802.11b/g/n parameters for a specific controller, follow these steps:

---

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click an applicable IP address.

**Step 3** From the left sidebar menu, choose **802.11b/g/n Parameters** to view the following parameters:

- **General**
  - 802.11b/g Network Status—Select the check box to enable.
  - 802.11g Support—Select the check box to enable.
  - Beacon Period—In milliseconds.
  - DTIM Period—The number of beacon intervals that may elapse between transmission of beacon frames containing a traffic indicator message (TIM) element whose delivery count field is 0.
  - Fragmentation Threshold—In bytes.
  - Short Preamble—Select the check box to enable.
  - Template Applied

- **802.11a/n Power Status**
  - Dynamic Assessment—Automatic, On Demand, or Disabled.
  - Current Tx Level
  - Control Interval—In seconds (Read-only).
  - Dynamic Treatment Power Control—Select the check box to enable.

- **802.11a/n Channel Status**
  - Assignment Mode—Automatic, On Demand, or Disabled.
  - Update Interval—In seconds.
  - Avoid Foreign AP Interference—Select the check box to enable.
  - Avoid Cisco AP load—Select the check box to enable.
  - Avoid non 802.11 Noise—Select the check box to enable.
  - Signal Strength Contribution—Select the check box to enable.

- **Data Rates**
  - Ranges between 1 Mbps and 54 Mbps—Supported, Mandatory, or Disabled.

- **Noise/Interference/Rogue Monitoring Channels**
  - Channel List—All Channels, Country Channels, DCA Channels.

- **CCX Location Measurement**
  - Mode—Select the check box to enable.
  - Interval—In seconds.
The CCX Location Measurement Interval can be changed only when measurement mode is enabled.

Command Buttons

- Save—Save the changes made.
- Audit—Compare the WCS values with those used on the controller.

Configuring 802.11b/g/n RRM Thresholds

To configure a 802.11b/g/n RRM threshold controller, follow these steps:

Step 1 Choose Configure > Controller.
Step 2 Click an applicable IP address.
Step 3 From the left sidebar menu, choose 802.11b/g/n > RRM Thresholds.
Step 4 Make any necessary changes to Coverage Thresholds, Load Thresholds, Other Thresholds, and Noise/Interference/Rogue Monitoring Channels.

Note When the Coverage Thresholds Min SNR Level (dB) parameter is adjusted, the value of the Signal Strength (dB) automatically reflects this change. The Signal Strength (dB) parameter provides information regarding what the target range of coverage thresholds will be when adjusting the SNR value.

Step 5 Click Save.

Configuring 802.11b/g/n RRM Transmit Power Control

The controller dynamically controls access point transmit power based on real-time wireless LAN conditions. Normally, power can be kept low to gain extra capacity and reduce interference. The controller attempts to balance the access points’ transmit power according to how the access points are seen by their third strongest neighbor.

The transmit power control (TPC) algorithm both increases and decreases an access point’s power in response to changes in the RF environment. In most instances, TPC will seek to lower an access point’s power to reduce interference, but in the case of a sudden change in the RF coverage—for example, if an access point fails or becomes disabled—TPC can also increase power on surrounding access points. This feature is different from Coverage Hole Detection, explained below. Coverage hole detection is primarily concerned with clients, while TPC is tasked with providing enough RF power to achieve desired coverage levels while avoiding channel interference between access points.

To configure 802.11b/g/n RRM TPC, follow these steps:

Step 1 Choose Configure > Controller.
Step 2  Click an applicable IP address.
Step 3  From the left sidebar menu, choose 802.11b/g/n-RRM > TPC.
Step 4  Configure the following TPC parameters:
- Template Applied—The name of the template applied to this controller.
- Dynamic Assignment—At the dynamic Assignment drop-down list, choose one of three modes:
  - Automatic - The transmit power is periodically updated for all access points that permit this operation.
  - On Demand - Transmit power is updated when the Assign Now button is selected.
  - Disabled - No dynamic transmit power assignments occur, and values are set to their global default.
- Maximum Power Assignment—Indicates the maximum power assigned.
  - Range: -10 to 30 dB
  - Default: 30 dB
- Minimum Power Assignment—Indicates the minimum power assigned.
  - Range: -10 to 30 dB
  - Default: 30 dB
- Dynamic Tx Power Control—Determine if you want to enable Dynamic Tx Power Control.
- Transmitted Power Threshold—Enter a transmitted power threshold between -50 and -80.
- Control Interval—In seconds (read-only).
Step 5  Click Save.

**Configuring 802.11b/g/n RRM Intervals**

To configure 802.11a/n or 802.11b/g/n RRM intervals for an individual controller, follow these steps:

Step 1  Choose Configure > Controller.
Step 2  Click an applicable IP address.
Step 3  From the left sidebar menu, choose 802.11a/n > RRM Intervals or 802.11b/g/n > RRM Intervals.

Note  The default for the following four RRM interval parameters is 300 seconds.

Step 4  Enter at which interval you want strength measurements taken for each access point.
Step 5  Enter at which interval you want noise and interference measurements taken for each access point.
Step 6  Enter at which interval you want load measurements taken for each access point.
Step 7  Enter at which interval you want coverage measurements taken for each access point.
Step 8  Click Save.
Configuring an 802.11b/g/n RRM DCA

To configure 802.11a/n or 802.11b/g/n RRM DCA channels for an individual controller, follow these steps:

**Step 1** Choose **Configure > Controller**.

**Step 2** Click an applicable IP address.

**Step 3** From the left sidebar menu, choose **802.11b/g/n-RRM > DCA**.

**Step 4** Select the check box(es) for the applicable DCA channel(s). The selected channels are listed in the Selected DCA channels text box.

**Step 5** Enable or disable event-driven Radio Resource Management (RRM). Event Driven RRM is used when a CleanAir-enabled access point detects a significant level of interference, follow these steps:

- Event Driven RRM—Enable or Disable spectrum event-driven RRM. By default, Event Driven RRM is enabled.
- Sensitivity Threshold—If Event Driven RRM is enabled, this text box displays the threshold level at which event-driven RRM is triggered. It can have a value of either Low, Medium, or High. When the interference for the access point rises above the threshold level, RRM initiates a local Dynamic Channel Assignment (DCA) run and changes the channel of the affected access point radio if possible to improve network performance. Low represents a decreased sensitivity to changes in the environment while High represents an increased sensitivity.

**Step 6** Click **Save**.

Configuring 802.11b/g/n RRM Radio Grouping

To configure 802.11a/n or 802.11b/g/n RRM Radio Grouping for an individual controller, follow these steps:

**Step 1** Choose **Configure > Controller**.

**Step 2** Click an applicable IP address.

**Step 3** From the left sidebar menu, choose **802.11b/g/n > RRM > RF Grouping**.

**Step 4** Choose a grouping mode from the drop-down list. The following parameters appear:

- Automatic—Allows you to activate the automatic RRM Grouping Algorithm. This is the default mode.
- Off—Allows you to deactivate the automatic grouping.
- Leader—Allows you to assign members to the group.

**Step 5** Choose a group update interval (secs) from the drop-down list. When grouping is on, this interval (in seconds) represents the period with which the grouping algorithm is run by the Group Leader. Grouping algorithm will also run when the group contents changes and the automatic grouping is enabled. A dynamic grouping can be started upon request from the system administrator. Default value is 600 seconds.

**Step 6** Under the Group Members area, click **Add >**. The selected controller moves from the Available Controllers to the RF Group Members list.
Configuring Existing Controllers

Note
The RF Group Members area appears only when the grouping mode is set to Leader.

Note
The maximum number of controllers that can be added to a RF Group is 20.

Step 7 Click Save.

Configuring 802.11b/g/n Media Parameters

To configure the media parameters for 802.11b/g/n, follow these steps:

Step 1 Choose Configure > Controllers.
Step 2 Click the applicable IP address.
Step 3 From the left sidebar menu, choose 802.11b/g/n > Media Parameters.
Step 4 In the Voice tab, specify the following parameters:

- Admission Control (ACM)—Select the check box to enable admission control.
  For end users to experience acceptable audio quality during a VoIP phone call, packets must be delivered from one endpoint to another with low latency and low packet loss. To maintain QoS under differing network loads, Call Admission Control (CAC) is required. CAC on an access point allows it to maintain controlled QoS when the network is experiencing congestion and keep the maximum allowed number of calls to an acceptable quantity.

- CAC Method—If Admission Control (ACM) is enabled, specify the CAC method as either load-based or static.
  Load-based CAC incorporates a measurement scheme that takes into account the bandwidth consumed by all traffic types from itself, from co-channel access points, and by co-located channel interference. Load-based CAC also covers the additional bandwidth consumption resulting from PHY and channel impairment.
  In load-based CAC, the access point periodically measures and updates the utilization of the RF channel, channel interference, and the additional calls that the access point can admit. The access point admits a new call only if the channel has enough unused bandwidth to support that call. By doing so, load-based CAC prevents over-subscription of the channel and maintains QoS under all conditions of WLAN loading and interference.

- Maximum Bandwidth Allowed—Specify the percentage of maximum bandwidth allowed. This option is only available when CAC is enabled.

- Reserved Roaming Bandwidth—Specify the percentage of reserved roaming bandwidth. This option is only available when CAC is enabled.

- Expedited Bandwidth—Select the check box to enable expedited bandwidth as an extension of CAC for emergency calls.
  You must have an expedited bandwidth that is CCXv5 compliant so that a TSPEC request is given higher priority.

- SIP CAC—Select the check box to enable SIP CAC.
SIP CAC should be used only for phones that support status code 17 and do not support TSPEC-based admission control.

- **SIP Codec**—Specify the codec name you want to use on this radio. The available options are G.711, G.729, and User Defined.

- **SIP Call Bandwidth**—Specify the bandwidth in kilobits per second that you want to assign per SIP call on the network. This parameter can be configured only when the SIP Codec selected is User Defined.

- **SIP Sample Interval**—Specify the sample interval in milliseconds that the codec must operate in.

- **Max Voice Calls per Radio**—Indicates the maximum number of voice calls that can be made per Radio.

  **Note** You cannot set the value of Max Voice Calls per Radio. This is automatically calculated based on the selected CAC method, Max BW allowed, and Roaming Bandwidth.

- **Max Roaming Reserved Calls per Radio**—Indicates the maximum number roaming calls that can be reserved per Radio.

  **Note** The Max Voice Calls per Radio and Max Roaming Reserved Calls per Radio options are available only if the CAC Method is specified as Static and SIP CAC is enabled.

- **Metric Collection**—Select the check box to enable metric collection. Traffic stream metrics are a series of statistics about VoIP over your wireless LAN which inform you of the QoS of the wireless LAN. For the access point to collect measurement values, traffic stream metrics must be enabled. When this is enabled, the controller begins collecting statistical data every 90 seconds for the 802.11b/g interfaces from all associated access points. If you are using VoIP or video, this feature should be enabled.

**Step 5** In the **Video** tab, specify the following parameters:

- **Admission Control (ACM)**—Select the check box to enable admission control.

- **Maximum Bandwidth**—Specify the percentage of maximum bandwidth allowed. This option is only available when CAC is enabled.

- **Reserved Roaming Bandwidth**—Specify the percentage of reserved roaming bandwidth. This option is only available when CAC is enabled.

- **Unicast Video Redirect**—Select the **Unicast Video Redirect** check box to enable all non-media stream packets in video queue are redirected to the best effort queue. If disabled, all packets with video marking are kept in video queue.

- **Client Minimum Phy Rate**—Specify the physical data rate required for the client to join a media stream from the Client Minimum Phy Rate drop-down list.

- **Multicast Direct Enable**—Select the **Multicast Direct Enable** check box to set the Media Direct for any WLAN with Media Direct enabled on a WLAN on this radio.

- **Maximum Number of Streams per Radio**—Specify the maximum number of streams per Radio to be allowed.

- **Maximum Number of Streams per Client**—Specify the maximum number of streams per Client to be allowed.

- **Best Effort QOS Admission**—Select the **Best Effort QOS Admission** check box to redirect new client requests to the best effort queue. This happens only if all the video bandwidth has been used.
Configuring Existing Controllers

Note
If disabled and maximum video bandwidth has been used, then any new client request is rejected.

Step 6
In the General tab, specify the following parameter:
- Maximum Media Bandwidth (0 to 85%)—Specify the percentage of maximum of bandwidth allowed. This option is only available when CAC is enabled.

Step 7
Click Save.

Note
SIPs are available only on the following controllers: 4400, 5500 and on for the following access points: 1240, 1130, and 11n.

Command Buttons

- Save—Save the changes made.
- Audit—Compare the WCS values with those used on the controller.

Configuring 802.11b/g/n EDCA Parameters

The EDCA parameters (EDCA profile and Streaming MAC Enable settings) for 802.11a/n and 802.11b/g/n can be configured either by individual controller or through a controller template to improve voice QoS support.

To configure 802.11a/n or 802.11b/g/n EDCA parameters for an individual controller, follow these steps:

Step 1
Choose Configure > Controllers.

Step 2
Click an applicable IP address.

Step 3
From the left sidebar menu, choose 802.11a/n > EDCA Parameters or 802.11b/g/n > EDCA Parameters.

Step 4
Choose the EDCA Profile from the drop-down list.

Note
Profiles include Wi-Fi Multimedia (WMM), Spectralink Voice Priority (SVP), Voice Optimized, and Voice & Video Optimized. WMM is the default EDCA profile.

Note
You must shut down radio interface before configuring EDCA Parameters.

Step 5
Select the Enable Streaming MAC check box to enable this feature.

Note
Only enable Streaming MAC if all clients on the network are WMM compliant.
Configuring 802.11b/g/n Roaming Parameters

To configure 802.11a/n or 802.11b/g/n EDCA parameters for an individual controller, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click an applicable IP address.

**Step 3** From the left sidebar menu, choose **802.11a/n > Roaming Parameters** or **802.11b/g/n > Roaming Parameters**.

**Step 4** From the Mode drop-down list, choose **Default values** or **Custom values**.

- **Default values**—The default values (read-only) are automatically displayed in the text boxes.
- **Custom values**—Activates the text boxes to enable editing of the roaming parameters.

**Step 5** In the Minimum RSSI text box, enter a value for the minimum received signal strength indicator (RSSI) required for the client to associate to an access point.

- **Range**: -80 to -90 dBm
- **Default**: -85 dBm

**Note** If the client average received signal power dips below this threshold, reliable communication is typically impossible; clients must already have found and roamed to another access point with a stronger signal before the minimum RSSI value is reached.

**Step 6** In the Hysteresis text box, enter a value to indicate how strong the signal strength of a neighboring access point must be in order for the client to roam to it.

This parameter is intended to reduce the amount of “ping ponging” between access points if the client is physically located on or near the border between two access points.

- **Range**: 2 to 4 dB
- **Default**: 3 dB

**Step 7** In the Adaptive Scan Threshold text box, enter the RSSI value, from a client associated access point, below which the client must be able to roam to a neighboring access point within the specified transition time.

This parameter provides a power-save method to minimize the time that the client spends in active or passive scanning. For example, the client can scan slowly when the RSSI is above the threshold and scan more rapidly when below the threshold.

- **Range**: -70 to -77 dB
- **Default**: -72 dB

**Step 8** In the Transition Time text box, enter the maximum time allowed for the client to detect a suitable neighboring access point to roam to and to complete the roam, whenever the RSSI from the client associated access point is below the scan threshold.

The Scan Threshold and Transition Time parameters guarantee a minimum level of client roaming performance. Together with the highest expected client speed and roaming hysteresis, these parameters make it possible to design a wireless LAN network that supports roaming simply by ensuring a certain minimum overlap distance between access points.

- **Range**: 1 to 10 seconds
- **Default**: 5 seconds
Step 9  Click Save.

Configuring 802.11b/g/n High Throughput (802.11n) Parameters

To configure 802.11a/n or 802.11b/g/n high throughput parameters, follow these steps:

Step 1  Choose Configure > Controller.
Step 2  Click an applicable IP address.
Step 3  From the left sidebar menu, choose 802.11a/n > High Throughput or 802.11b/g/n > High Throughput.
Step 4  Select the **802.11n Network Status Enabled** check box to enable high throughput.
Step 5  In the MCS (Data Rate) Settings, choose which level of data rate you want supported. MCS is modulation coding schemes which are similar to 802.11a data rate. As a default, 20 MHz and short guarded interval is used.

Note  When you select the Supported check box, the chosen numbers appear in the Selected MCS Indexes page.

Step 6  Click Save.

Configuring 802.11b/g/n CleanAir Parameters

To configure 802.11b/g/n CleanAir parameters, follow these steps:

Step 1  Choose Configure > Controller.
Step 2  Click an applicable IP address.
Step 3  From the left sidebar menu, choose 802.11b/g/n > CleanAir to view the following information.

- **CleanAir**—Select the check box to enable CleanAir functionality on the 802.11b/g/n network, or unselect to prevent the controller from detecting spectrum interference. The default value is selected.
- **Reporting Configuration**—Use the parameters in this section to configure the interferer devices you want to include for your reports.
  - **Report**—Select the **report interferers** check box to enable CleanAir system to report and detect sources of interference, or unselect it to prevent the controller from reporting interferers. The default value is selected.
  - Make sure that any sources of interference that need to be detected and reported by the CleanAir system appear in the Interferences to Detect text box and any that do not need to be detected appear in the Interferers to Ignore text box. Use the > and < buttons to move interference sources between these two text boxes. By default, all interference sources are detected.
- **Alarm Configuration**—This section enables you to configure triggering of air quality alarms.
  - **Air Quality Alarm**—Select the **Air Quality Alarm** check box to enable the triggering of air quality alarms, or unselect the text box to disable this feature. The default value is selected.
Configuring Existing Controllers

Chapter 9 Configuring Wireless Devices

Configuring Existing Controllers

- Air Quality Alarm Threshold—If you selected the Air Quality Alarm check box, enter a value between 1 and 100 (inclusive) in the Air Quality Alarm Threshold text box to specify the threshold at which you want the air quality alarm to be triggered. When the air quality falls below the threshold level, the alarm is triggered. A value of 1 represents the worst air quality, and 100 represents the best. The default value is 35.

- Interferers For Security Alarm—Select the Interferers For Security Alarm check box to trigger interferer alarms when the controller detects specified device types, or unselect it to disable this feature. The default value is selected.

- Make sure that any sources of interference that need to trigger interferer alarms appear in the Interferers Selected for Security Alarms text box and any that do not need to trigger interferer alarms appear in the Interferers Ignored for Security Alarms text box. Use the > and < buttons to move interference sources between these two text boxes. By default, all interference sources trigger interferer alarms.

- Event Driven RRM—To trigger spectrum event-driven Radio Resource Management (RRM) to run when a CleanAir-enabled access point detects a significant level of interference, use the following parameters:
  - Event Driven RRM—Displays the current status of spectrum event-driven RRM.
  - Sensitivity Threshold—If Event Driven RRM is enabled, this text box displays the threshold level at which event-driven RRM is triggered. It can have a value of either Low, Medium, or High. When the interference for the access point rises above the threshold level, RRM initiates a local Dynamic Channel Allocation (DCA) run and changes the channel of the affected access point radio if possible to improve network performance. Low represents a decreased sensitivity to changes in the environment while High represents an increased sensitivity.

Command Buttons

- Save—Save the changes made.
- Audit—Compare the WCS values with those used on the controller.

Configuring Mesh Parameters

To configure Mesh parameters for an individual controller, follow these steps:

Step 1 Choose Configure > Controller.
Step 2 Click an applicable IP address.
Step 3 From the left sidebar menu, choose Mesh > Mesh Settings.
Step 4 View or edit the following mesh parameters:
  - RootAP to MeshAP Range (150 - 13200 ft)—By default, this value is 12,000 feet. You can enter a value between 150 and 132,000 feet. Enter the optimum distance (in feet) that should exist between the root access point and the mesh access point. This global parameter applies to all access points when they join the controller and all existing access points in the network.
• Client Access on Backhaul Link—Enabling this feature lets mesh access points associate with 802.11a wireless clients over the 802.11a backhaul. This client association is in addition to the existing communication on the 802.11a backhaul between the root and mesh access points. This feature is only applicable to access points with two radios. For more information, see the “Client Access on 1524SB Dual Backhaul” section on page 9-141.

  Note  Changing Backhaul Client Access reboots all mesh access points.

• Mesh DCA Channels—Enable or disable. This option is disabled by default. Enable this option to enable backhaul channel deselection on the Controller using the DCA channel list. Any change to the channels in the Controller DCA list is pushed to the associated access points. This option is only applicable for 1524SB mesh access points. For more information on this feature, see the “Backhaul Channel Deselection Using WCS” section on page 9-142.

• Background Scanning—Select the Background Scanning check box to enable background scanning or unselect it to disable the feature. The default value is disabled. Background scanning allows Cisco Aironet 1510 Access Points to actively and continuously monitor neighboring channels for more optimal paths and parents.

• Security Mode—Choose EAP (Extensible Authentication Protocol) or PSK (Pre-Shared Key) from the Security Mode drop-down list.

  Note  Changing Security reboots all mesh access points.

Step 5  Click Save.

Client Access on 1524SB Dual Backhaul

The 1524 Serial Backhaul (SB) access point consists of three radio slots. Radio in slot-0 operate in 2.4 GHz frequency band which is used for client access. Radios in slot-1 and slot-2 operate in 5.8 GHz band and are primarily used for backhaul. However, with the Universal Client Access feature, client access is also allowed over slot-1 and slot-2 radios.

The two 802.11a backhaul radios use the same MAC address. There may be instances where the same WLAN maps to the same BSSID in more than one slot.

By default, client access is disabled over both of the backhaul radios.

The following guidelines should be followed for enabling or disabling a radio slot:
• You can enable client access on slot-1 even if client access on slot-2 is disabled.
• You can enable client access on slot-2 only when client access on slot-1 is enabled.
• If you disable client access on slot-1 the client access on slot-2 is automatically disabled.
• All the Mesh Access Points reboot whenever the client access is enabled or disabled.

You can configure client access over backhaul radio from either one of the following:
• The Controller command-line interface (CLI)
• The Controller Graphical User Interface (GUI)
• The WCS GUI. For more information, see the “Configuring Client Access using WCS - GUI” section on page 9-142.
Chapter 9  Configuring Wireless Devices

Configuring Existing Controllers

Note
The procedure for configuring client access using the CLI and GUI is documented in the Controller Configuration Guide.

Configuring Client Access using WCS - GUI

To configure client access on the two backhaul radios, follow these steps:

Step 1  Choose Configure > Controllers > Controller IP > Mesh > Mesh Settings.

Step 2  Select the Client Access on Backhaul Link check box.

Step 3  Select the Extended Backhaul Client Access check box if you want to enable extended backhaul client access.

Step 4  Click Save.

A warning message is displayed:

Enabling client access on both backhaul slots will use same BSSIDs on both the slots. Changing Backhaul Client Access will reboot all Mesh APs.

Step 5  Click OK.

The Universal Client access is configured on both the radios.

Backhaul Channel Deselection Using WCS

To configure backhaul channel deselection, follow these steps:

Step 1  You must first configure the Mesh DCA channels flag on the controllers. See the “Configuring Mesh DCA Channel Flag on Controllers Using WCS” section on page 9-142 for more information.

Step 2  Then change the channel list using config groups. See the “Changing the Channel List Using Config Groups” section on page 9-143 for more information.

Configuring Mesh DCA Channel Flag on Controllers Using WCS

You can configure the Mesh DCA Channel flag to push each channel change on one or more controllers to all the associated 1524SB access points. To configure this feature, follow these steps:

Step 1  Choose Configure > Controllers > ip address of controller > Mesh > Mesh Settings to configure this flag for a specific controller.

Or

Configure > Controller Template Launch Pad > Mesh > Mesh Settings to configure this flag for a list of controllers.

The Mesh Settings page appears.

Step 2  From the general options select the Mesh DCA Channels check box to enable channel selection. This option is unselected by default.
Now the channel changes in the controllers are pushed to the associated 1524SB access points.

Changing the Channel List Using Config Groups

You can use controller config groups to configure backhaul channel deselection. You can create a config group and add the required controllers into the group and use the Country/DCA tab to select or deselect channels for the controllers in that group.

To configure backhaul channel deselection using config groups, follow these steps:

**Step 1** Choose **Configure > Controller Config Groups**.
**Step 2** Select a config group to view its config group details.
**Step 3** From the Config Group detail page, click the Country/DCA tab.
**Step 4** Select or unselect the channels for the config group.

**Note** You can also configure backhaul channel deselection from controllers. For more information, see the Controller Online Help or **Controller User Guide**.

Configuring Port Parameters

To configure Port parameters for an individual controller, follow these steps:

**Step 1** Choose **Configure > Controller**.
**Step 2** Click an applicable IP address.
**Step 3** From the left sidebar menu, choose **Ports > Port Settings**.
**Step 4** Click the applicable Port Number to open the Port Settings Details page. The following parameters display:

- **General Parameters**:
  - Port Number—Read-only.
  - Admin Status—Choose Enabled or Disabled from the drop-down list.
  - Physical Mode—Choose Auto Negotiate or Full Duplex 1 Gbps.
  - STP Mode—Choose 802.1D, Fast, or Off.
  - Mirror Mode—Choose Enabled or Disabled.
  - Link Traps—Choose Enabled or Disabled.
  - Power Over Ethernet
  - Multicast Application Mode—Select Enabled or Disabled.

- **Spanning Tree Protocol Parameters**:
  - Priority—The numerical priority number of the ideal switch.
Path Cost—A value (typically based on hop count, media bandwidth, or other measures) assigned by a network administrator and used to determine the most favorable through an internetwork environment (the lower the cost, the better the path).

**Step 5** Choose **Save** or **Audit** for General or Spanning Tree Protocol settings.

### Configuring Controllers Management Parameters

- Configuring Trap Receivers, page 9-144
- Configuring Trap Control Parameters, page 9-145
- Configuring Telnet SSH Parameters, page 9-147
- Configuring a Syslog for an Individual Controller, page 9-148
- Configuring Multiple Syslog Servers, page 9-148
- Configuring WEB Admin, page 9-148
- Configuring Local Management Users, page 9-150
- Configuring Authentication Priority, page 9-150

### Configuring Trap Receivers

This section contains the following topics:

- Configuring Trap Receivers for an Individual Controller, page 9-144
- Adding a New Receiver, page 9-145

### Configuring Trap Receivers for an Individual Controller

To configure trap receivers for an individual controller, follow these steps:

**Step 1** Choose **Configure > Controller**.

**Step 2** Click an applicable IP address.

**Step 3** From the left sidebar menu, choose **Management > Trap Receivers**.

**Step 4** The following parameters are displayed for current trap receivers:

- Template Name—User-defined name of this template.
- IP Address—The IP address of the server.
- Admin Status—Status must be enabled for the SNMP traps to be sent to the receiver.

**Step 5** Click a receiver Name to access its details.

**Step 6** Select the **Admin Status** check box to enable the trap receiver. Unselect the check box to disable the trap receiver.

**Step 7** Click **Save**.
Adding a New Receiver

To add a new receiver, follow these steps:

**Step 1**  
From the Select a command drop-down list, choose Add Receiver.

**Step 2**  
Click Go.

**Step 3**  
From the Select a template to apply to this controller drop-down list, choose the applicable template to apply to this controller.

**Note**  
To create a new template for Trap Receivers, use the click here link to access the applicable template creation page.

**Step 4**  
Click Apply.

Configuring Trap Control Parameters

To configure trap control parameters for an individual controller, follow these steps:

**Step 1**  
Choose Configure > Controller.

**Step 2**  
Click an applicable IP address.

**Step 3**  
From the left sidebar menu, choose Management > Trap Control.

The applied template is identified (if applicable). See the “Configuring Trap Control Templates” section on page 11-132 for more information.

The following traps can be enabled for this controller:

- **Miscellaneous Traps**
  - SNMP Authentication—The SNMPv2 entity has received a protocol message that is not properly authenticated.

  **Note**  
  When a user who is configured in SNMP V3 mode tries to access the controller with an incorrect password, the authentication fails and a failure message is displayed. However, no trap logs are generated for the authentication failure.

  - Link (Port) Up/Down—Link changes status from up or down.
  - Multiple Users—Two users login with the same login ID.
  - Spanning Tree—Spanning Tree traps. See the STP specifications for descriptions of individual parameters.
  - Rogue AP—Whenever a rogue access point is detected this trap will be sent with its MAC Address; When a rogue access point that was detected earlier and it no longer exists this trap is sent.
  - Config Save—Notification sent when the controller configuration is modified.

- **Client Related Traps**
- 802.11 Association—The associate notification is sent when the client sends an association frame.
- 802.11 Disassociation—The disassociate notification is sent when the client sends a disassociation frame.
- 802.11 Deauthentication—The deauthenticate notification is sent when the client sends a deauthentication frame.
- 802.11 Failed Authentication—The authenticate failure notification is sent when the client sends an authentication frame with a status code other than 'successful'.
- 802.11 Failed Association—The associate failure notification is sent when the client sends an association frame with a status code other than 'successful'.
- Excluded—The associate failure notification is sent when a client is excluded.

- Cisco AP Traps
  - AP Register—Notification sent when an access point associates or disassociates with the controller.
  - AP Interface Up/Down—Notification sent when access point interface (802.11a or 802.11b/g) status goes up or down.

- Auto RF Profile Traps
  - Load Profile—Notification sent when Load Profile state changes between PASS and FAIL.
  - Noise Profile—Notification sent when Noise Profile state changes between PASS and FAIL.
  - Interference Profile—Notification sent when Interference Profile state changes between PASS and FAIL.
  - Coverage Profile—Notification sent when Coverage Profile state changes between PASS and FAIL.

- Auto RF Update Traps
  - Channel Update—Notification sent when access point dynamic channel algorithm is updated.
  - Tx Power Update—Notification sent when access point dynamic transmit power algorithm is updated.

- AAA Traps
  - User Auth Failure—This trap is to inform that a client RADIUS Authentication failure has occurred.
  - RADIUS Server No Response—This trap is to indicate that no RADIUS server(s) are responding to authentication requests sent by the RADIUS client.

- IP Security Traps
  - ESP Authentication Failure—IPsec packets with invalid hashes were found in an inbound ESP SA.
  - ESP Replay Failure—IPsec packets with invalid sequence numbers were found in an inbound ESP SA.
  - Invalid SPI—A packet with an unknown SPI was detected from the specified peer with the specified SPI using the specified protocol.
  - IKE Negotiation Failure—An attempt to negotiate a phase 1 IKE SA failed. The notification counts are also sent as part of the trap, along with the current value of the total negotiation error counters.
- IKE Suite Failure—An attempt to negotiate a phase 2 SA suite for the specified selector failed. The current total failure counts are passed as well as the notification type counts for the notify involved in the failure.

- Invalid Cookie—ISAKMP packets with invalid cookies were detected from the specified source, intended for the specified destination. The initiator and responder cookies are also sent with the trap.

- 802.11 Security Traps
  - WEP Decrypt Error—Notification sent when the controller detects a WEP decrypting error.

- WPS Traps
  - Rogue Auto Containment—Notification sent when a rogue access point is auto-contained.

**Step 4** After selecting the applicable parameters, click **Save**.

---

### Configuring Telnet SSH Parameters

To configure Telnet SSH (Secure Shell) parameters for an individual controller, follow these steps:

**Step 1** Choose **Configure > Controller**.

**Step 2** Click an applicable IP address.

**Step 3** From the left sidebar menu, choose **Management > Telnet SSH**.

The applied template is identified (if applicable). See the “Configuring Telnet SSH Templates” section on page 11-135 for more information.

The following parameters can be configured:

- **Session Timeout**—Indicates the number of minutes a Telnet session is allowed to remain inactive before being logged off. A zero means there will be no timeout. May be specified as a number from 0 to 160. The factory default is 5.

- **Maximum Sessions**—From the drop-down list, choose a value from 0 to 5. This object indicates the number of simultaneous Telnet sessions allowed.

  **Note** New Telnet sessions can be allowed or disallowed on the DS (network) port. New Telnet sessions are always allowed on the Service port.

- **Allow New Telnet Sessions**—Indicates that new Telnet sessions will not be allowed on the DS Port when set to no. The factory default value is no.

  **Note** New Telnet sessions can be allowed or disallowed on the DS (network) port. New Telnet sessions are always allowed on the Service port.

- **Allow New SSH Sessions**—Indicates that new Secure Shell Telnet sessions will not be allowed when set to no. The factory default value is yes.

**Step 4** After configuring the applicable parameters, click **Save**.
Configuring a Syslog for an Individual Controller

To enable a Syslog for an individual controller, follow these steps:

Step 1  Choose Configure > Controller.
Step 2  Click an applicable IP address.
Step 3  From the left sidebar menu, choose Management > Syslog.
        The applied template is identified (if applicable). See the “Configuring Legacy Syslog Templates” section on page 11-136 for more information.
        • Syslog Enabled—Select the check box to enable the syslog.
Step 4  Click Save.

Configuring Multiple Syslog Servers

For version 5.0.148.0 controllers or later, you can configure multiple (up to three) syslog servers on the WLAN controller. With each message logged, the controller sends a copy of the message to each configured syslog host, provided the message has severity greater than or equal to the configured syslog filter severity level.

To enable syslogs for an individual controller, follow these steps:

Step 1  Choose Configure > Controller.
Step 2  Click an applicable IP address.
Step 3  From the left sidebar menu, choose Management > Multiple Syslog.
        The applied template is identified:
        • Syslog Server Address—Indicates the server address of the applicable syslog.
Step 4  Click Save.

Configuring WEB Admin

This section provides instructions for enabling the distribution system port as a web port (using HTTP) or as a secure web port (using HTTPS). You can protect communication with the GUI by enabling HTTPS. HTTPS protects HTTP browser sessions by using the Secure Sockets Layer (SSL) protocol. When you enable HTTPS, the controller generates its own local web administration SSL certificate and automatically applies it to the GUI. You also have the option of downloading an externally generated certificate.

To enable WEB admin parameters for an individual controller, follow these steps:

Step 1  Choose Configure > Controller.
Step 2  Click an applicable IP address.
Step 3  From the left sidebar menu, choose Management > Web Admin.
        The following parameters can be configured:
• Web Mode—Choose Enable or Disable from the drop-down list. When enabled, users can access the controller GUI using http://ip-address. The default is Disabled.

\[
\text{Note} \quad \text{Web mode is not a secure connection.}
\]

• Secure Web Mode—Choose Enable or Disable from the drop-down list. When enabled, users can access the controller GUI using https://ip-address. The default is Enabled.

\[
\text{Note} \quad \text{Secure web mode is a secure connection.}
\]

• Certificate Type
  • Download Web Admin Certificate—Click to access the Download Web Admin Certificate to Controller page. See the “Download Web Auth or Web Admin Certificate to Controller” section on page 9-149 for additional information.

\[
\text{Note} \quad \text{The controller must be rebooted for the new Web Admin certificate to take effect.}
\]

Command Buttons

• Save
• Audit
• Regenerate Cert

Download Web Auth or Web Admin Certificate to Controller

To download a Web Auth or Web Admin Certificate to the controller, follow these steps:

Step 1 Click the Download Web Admin Certificate or Download Web Auth Certificate link.
Step 2 In the File is located on parameter, specify Local machine or TFTP server.

\[
\text{Note} \quad \text{If the certificate is located on the TFTP server, enter the Server File Name. If it is located on the local machine, enter the Local File Name using the Browse button.}
\]

Step 3 Enter the TFTP server name in the Server Name parameter. The default is the WCS server.
Step 4 Enter the server IP address.
Step 5 In the Maximum Retries text box, enter the maximum number of times that the TFTP server attempts to download the certificate.
Step 6 In the Timeout text box, enter the amount of time (in seconds) that the TFTP server attempts to download the certificate.
Step 7 In the Local File Name text box, enter the directory path of the certificate.
Step 8 In the Server File Name text box, enter the name of the certificate.
Step 9  Enter the password in the Password text box.
Step 10 Click OK.

Configuring Local Management Users

This page lists the names and access privileges of the local management users.
To access the Local Management Users page, follow these steps:

Step 1  Choose Configure > Controllers.
Step 2  Click an applicable IP address.
Step 3  From the left sidebar menu, choose Management > Local Management Users.
Step 4  Click a user name.
  •  User Name (read-only)—Name of the user.
  •  Access Level (read-only)—Read Write or Read Only.

Configuring Authentication Priority

In this page, you can control the order in which authentication servers are used to authenticate a controller management users.
To access the Authentication Priority page, follow these steps:

Step 1  Choose Configure > Controllers.
Step 2  Click an applicable IP address.
Step 3  From the left sidebar menu, choose Management > Authentication Priority.
Step 4  The local database is searched first. Choose either RADIUS or TACACS+ for the next search. If authentication using the local database fails, the controller uses the next type of server.
Step 5  Click Save.

Command Buttons

•  Save—Save the changes made to the management user authentication order and return to the previous page.
•  Audit—Compare the WCS values with those used on the controller.

Configuring Location Configurations

In the Location Configuration page, you can configure location parameters such as expiration times, notification interval, and other advanced configuration options.
You can set the following general and advanced parameters on the location template:
• General parameters—Enable RFID tag collection, set the location path loss for calibrating or normal (non-calibrating) clients, measurement notification for clients, tags, and rogue access points, set the RSSI expiry timeout value for clients, tags, and rogue access points.

• Advanced parameters—Set the RFID tag data timeout value and enable the location path loss configuration for calibrating client multi-band.

To configure location configurations for an individual controller, follow these steps:

Step 1  Choose Configure > Controller.

Step 2  Click an applicable IP address.

Step 3  From the left sidebar menu, choose Location Configuration > Location Configuration.

The Location Configuration page displays two tabs: General and Advanced.

Step 4  Add or modify the General parameters:

• RFID Tag Data Collection—Select the check box to enable the collection of data on tags.
  Before the location server can collect asset tag data from controllers, you must enable the detection of active RFID tags using the CLI command config rfid status enable on the controllers.

• Location Path Loss Configuration
  – Calibrating Client—Select the Enabled check box to enable calibration for the client.
    Controllers send regular S36 or S60 requests (depending on the client capability) by way of the access point to calibrate clients. Packets are transmitted on all channels. All access points gather RSSI data from the client at each location. These additional transmissions and channel changes might degrade contemporaneous voice or video traffic.

  Note To use all radios (802.11a/b/g/n) available, you must enable multiband in the Advanced page.

  – Normal Client—Select the Enabled check box to have a non-calibrating client. No S36 or S60 requests are transmitted to the client.

• Measurement Notification Interval (in secs)
  – Tags, Clients, and Rogue APs/Clients—Allows you to set the NMSP measurement notification interval for clients, tags, and rogues. Specify how many seconds should elapse before notification of the found element (tags, clients, and rogue access points/clients).
  Setting this value on the controller generates an out-of-sync notification which you can view in the Synchronize Servers page. When different measurement intervals exist between a controller and the mobility services engine, the largest interval setting of the two is adopted by the mobility services engine.
  Once this controller is synchronized with the mobility services engine, the new value is set on the mobility services engine.

  Note Synchronization to the mobility services engine is required if changes are made to measurement notification interval.

• RSS Expiry Timeout (in secs)
  – For Clients—Enter the number of seconds after which RSSI measurements for normal (non-calibrating) clients should be discarded.
For Calibrating Clients—Enter the number of seconds after which RSSI measurements for calibrating clients should be discarded.

- For Tags—Enter the number of seconds after which RSSI measurements for tags should be discarded.

- For Rogue APs—Enter the number of seconds after which RSSI measurements for rogue access points should be discarded.

**Step 5** Add or modify the Advanced parameters:

- **RFID Tag Data Timeout (in secs)**—Enter a value (in seconds) to set the RFID tag data timeout setting.

- **Location Path Loss Configuration**
  
  - **Calibrating Client Multiband**—Select the Enabled check box to send S36 and S60 packets (where applicable) on all channels. Calibrating clients must be enable in the general page.

- **Note** To use all radios (802.11a/b/g/n) available, you must enable multiband.

**Step 6** Click **Save**.

---

**Command Buttons**

- **Save**—Save the changes made to the management user authentication order and return to the previous page.

- **Audit**—Compare the WCS values with those used on the controller.

---

**Configuring Access Points**

This section describes how to configure access points in the Cisco WCS database. This section contains the following topics:

- **Setting AP Failover Priority**, page 9-153
- **Configuring Global Credentials for Access Points**, page 9-153
- **Configuring Ethernet Bridging and Ethernet VLAN Tagging**, page 9-155
- **Autonomous to Lightweight Migration Support**, page 9-160
- **Configuring Access Point Details**, page 9-165
- **Configuring CDP**, page 9-183
- **Configuring Access Point Radios for Tracking Optimized Monitor Mode**, page 9-184
- **Copying and Replacing Access Points**, page 9-184
- **Removing Access Points**, page 9-185
- **Scheduling Radio Status**, page 9-186
- **Viewing Audit Status (for Access Points)**, page 9-186
- **Searching Access Points**, page 9-187
- **Viewing Mesh Link Details**, page 9-188
• Viewing or Editing Rogue Access Point Rules, page 9-188
• Configuring Spectrum Experts, page 9-191
• OfficeExtend Access Point, page 9-194
• Configuring Link Latency Settings for Access Points, page 9-195

Setting AP Failover Priority

When a controller fails, the backup controller configured for the access point suddenly receives a number of discovery and join requests. This may cause the controller to reach a saturation point and reject some of the access points.

By assigning priority to an access point, you have some control over which access points are rejected. In a failover situation when the backup controller is saturated, the higher priority access points are allowed to join the backup controller by disjoining the lower priority access points.

To configure priority settings for access points, you must first enable the AP Priority feature. To enable the AP Priority feature, follow these steps:

Step 1  Choose Configure > Controllers.
Step 2  Click the IP address of the applicable controller.
Step 3  From the left sidebar menu, choose System > General.
Step 4  From the AP Failover Priority drop-down list, choose Enable.

To configure an access point’s priority, see the “Configuring Access Point Details” section on page 9-165.

Configuring Global Credentials for Access Points

Cisco autonomous access points are shipped from the factory with Cisco as the default enable password. This password allows users to log into the non-privileged mode and execute show and debug commands, posing a security threat. The default enable password must be changed to prevent unauthorized access and to enable users to execute configuration commands from the access point’s console port.

In WCS and controller software releases prior to 5.0, you can set the access point enable password only for access points that are currently connected to the controller. In WCS and controller software release 5.0, you can set a global username, password, and enable password that all access points inherit as they join a controller. This includes all access points that are currently joined to the controller and any that join in the future. When you are adding an access point, you can also choose to accept this global username and password or override it on a per-access point basis and assign a unique username, password, and enable password. See the “Configuring AP Configuration Templates” section on page 11-143 to see where the global password is displayed and how it can be overridden on a per-access point basis.

Also in controller software release 5.0, after an access point joins the controller, the access point enables console port security, and you are prompted for your username and password whenever you log into the access point’s console port. When you log in, you are in non-privileged mode, and you must enter the enable password to use the privileged mode.
These controller software release 5.0 features are supported on all access points that have been converted to lightweight mode, except the 1100 series. VxWorks access points are not supported.

The global credentials that you configure on the controller are retained across controller and access point reboots. They are overwritten only if the access point joins a new controller that is configured with a global username and password. If the new controller is not configured with global credentials, the access point retains the global username and password configured for the first controller.

You need to keep careful track of the credentials used by the access points. Otherwise, you might not be able to log into an access point’s console port. If necessary, you can clear the access point configuration to return the access point username and password to the default setting.

To establish a global username and password, follow these steps:

**Step 1** Choose **Configure > Controllers** or **Configure > Access Points**.

**Step 2** Choose an IP address of a controller with software release 5.0 or later or choose an access point associated with software release 5.0 or later.

**Step 3** Choose **System > AP Username Password** from the left sidebar menu. The AP Username Password page appears (see **Figure 9-15**).

**Figure 9-15  AP Username Password Page**
Step 4 In the AP Username text box, enter the username that is to be inherited by all access points that join the controller.

Step 5 In the AP Password text box, enter the password that is to be inherited by all access points that join the controller. Re-enter in the Confirm AP Password text box.

Step 6 For Cisco autonomous access points, you must also enter and confirm an enable password. In the AP Enable Password text box, enter the enable password that is to be inherited by all access points that join the controller. Re-enter in the Confirm Enable Password text box.

Step 7 Click Save.

Configuring Ethernet Bridging and Ethernet VLAN Tagging

Ethernet bridging is used in two mesh network scenarios:

1. Point-to-point and point-to-multipoint bridging between MAPs (untagged packets). A typical trunking application might be bridging traffic between buildings within a campus (see Figure 9-16).

Note You do not need to configure VLAN tagging to use Ethernet bridging for point-to-point and point-to-multipoint bridging deployments.

Figure 9-16 Point-to-Multipoint Bridging

2. Ethernet VLAN tagging allows specific application traffic to be segmented within a wireless mesh network and then forwarded (bridged) to a wired LAN (access mode) or bridged to another wireless mesh network (trunk mode).

A typical public safety access application using Ethernet VLAN tagging is placement of video surveillance cameras at various outdoor locations within a city. Each of these video cameras has a wired connection to a MAP. The video of all these cameras is then streamed across the wireless backhaul to a central command station on a wired network (see Figure 9-17).
Ethernet VLAN Tagging Guidelines

- For security reasons, the Ethernet port on a mesh access point (RAP and MAP) is disabled by default. It is enabled by configuring Ethernet Bridging on the mesh access point port.
- You must enable Ethernet bridging on all the access points in the mesh network to allow Ethernet VLAN Tagging to operate.
- You must set VLAN Mode as non-VLAN transparent (global mesh parameter). See the “Configuring Ethernet Bridging and Ethernet VLAN Tagging” section on page 9-155.
  - VLAN transparent is enabled by default. To set as non-VLAN transparent, you must unselect the VLAN transparent option in the Global Mesh Parameters page.
- VLAN configuration on a mesh access point is only applied if all the uplink mesh access points are able to support that VLAN.
- If uplink access points are not able to support the VLAN, then the configuration is stored rather than applied.

- VLAN tagging can only be configured on Ethernet interfaces.
  - On 152x mesh access points, use three of the four ports as secondary Ethernet interfaces: port 0-PoE in, port 1-PoE out, and port 3-fiber. You cannot configure Port 2-cable as a secondary Ethernet interface.
  - In Ethernet VLAN tagging, port 0-PoE in on the RAP connects the trunk port of the switch of the wired network. Port 1-PoE out on the MAP connects external devices such as video cameras.

- Backhaul interfaces (802.11a radios) act as primary Ethernet interfaces. Backhauls function as trunks in the network and carry all VLAN traffic between the wireless and wired network. You are not required to configure the primary Ethernet interface.

- You must configure the switch port in the wired network that is attached to the RAP (port 0-PoE in) to accept tagged packets on its trunk port. The RAP forwards all tagged packets received from the mesh network to the wired network.

- Configuration to support VLAN tagging on the 802.11a backhaul Ethernet interface is not required within the mesh network.
  - This includes the RAP uplink Ethernet port. The required configuration happens automatically using a registration mechanism.
  - Any configuration changes to an 802.11a Ethernet link acting as a backhaul are ignored, and a warning results. When the Ethernet link no longer functions as a backhaul, the modified configuration is applied.

- You cannot configure VLANs on port-02-cable modem port of a 152x access point. Configure VLANs on ports 0 (PoE-in), 1 (PoE-out), and 3 (fiber).

- If bridging between two MAPs, enter the distance (mesh range) between the two access points that are bridging. (Not applicable to applications in which you are forwarding traffic connected to the MAP to the RAP, access mode.)

- Each sector supports up to 16 VLANs; therefore, the cumulative number of VLANs supported by a RAP’s children (MAPs) cannot exceed 16.

- Ethernet ports on access points function as normal, access, or trunk ports in an Ethernet tagging deployment.
  - Normal mode—In this mode, the Ethernet interface is VLAN-transparent by default and does not accept or send any tagged packets. Tagged frames from clients are dropped. Untagged frames are forwarded to the native VLAN on the RAP trunk port.
  - Access mode—In this mode only untagged packets are accepted. You must tag all packets with a user-configured VLAN called access-VLAN. For this mode to take effect, the global VLAN mode should be non-VLAN transparent.

  Use this option for applications in which information is collected from devices connected to the MAP such as cameras or PCs and then forwarded to the RAP. The RAP then applies tags and forwards traffic to a switch on the wired network.

  - Trunk mode—This mode requires the user to configure a native VLAN and an allowed VLAN list (no defaults). In this mode, both tagged and untagged packets are accepted. You can accept untagged packets and tag them with the user-specified native VLAN. You can accept tagged packets if they are tagged with a VLAN in the allowed VLAN list. For this mode to take effect, the global VLAN mode should be non-VLAN transparent.

  Use this option for bridging applications such as forwarding traffic between two MAPs resident on separate buildings within a campus.
The switch port connected to the RAP must be a trunk.
- The trunk port on the switch and the RAP trunk port must match.

- A configured VLAN on a MAP Ethernet port cannot function as a Management VLAN.
- The RAP must always connect to the native VLAN (ID 1) on a switch.
  - The RAP’s primary Ethernet interface is by default the native VLAN of 1.

### Enabling Ethernet Bridging and VLAN Tagging

To enable Ethernet Bridging and VLAN tagging on a RAP or MAP, follow these steps:

**Step 1** Choose **Configure > Access Points**.

**Step 2** Click the name of the mesh access point for which you want to enable Ethernet bridging. A configuration page for the access point appears.

**Step 3** In the Bridging Information section, choose the appropriate backhaul rate from the Data Rate drop-down list. The default value is 24 Mbps for the 802.11a backhaul interface.

**Step 4** In the Bridging Information section, choose Enable from the Ethernet Bridging drop-down list.

**Step 5** Click the appropriate Ethernet interface link (such as FastEthernet or gigabitEthernet1). (See **Figure 9-18**.)

**Figure 9-18** **Configure > Access Points > AP Name Page**

<table>
<thead>
<tr>
<th>Interface</th>
<th>Operational Status</th>
<th>VLAN Mode</th>
<th>VLAN Id</th>
</tr>
</thead>
<tbody>
<tr>
<td>FastEthernet0</td>
<td>Up</td>
<td>Normal</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Protocol</th>
<th>Admin Status</th>
<th>Channel Number</th>
<th>Power Level</th>
<th>Antenna Diversity</th>
<th>Antenna Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>802.11a</td>
<td>Enable</td>
<td>140</td>
<td>1</td>
<td>Enabled</td>
<td>External</td>
</tr>
<tr>
<td>802.11b/g</td>
<td>Enable</td>
<td>1*</td>
<td>8*</td>
<td>Enabled</td>
<td>External</td>
</tr>
</tbody>
</table>

**Step 6** Within the Ethernet interface page, perform one of the following (see **Figure 9-19**):
The configuration options vary for each of the VLAN modes (normal, access, and trunk).

a. If you are configuring a MAP and RAP normal ports and chose FastEthernet0, choose Normal from the VLAN Mode drop-down list.

In this mode, the Ethernet interface is VLAN-transparent by default and does not accept or send any tagged packets. Tagged frames from clients are dropped. Untagged frames are forwarded to the native VLAN on the RAP trunk port.

b. If you are configuring a MAP access port and chose gigabitEthernet1 (port 1-PoE out):

1. Choose Access from the VLAN Mode drop-down list.
2. Enter a VLAN ID. The VLAN ID can be any value between 1 and 4095.
3. Click Save.

Note: VLAN ID 1 is not reserved as the default VLAN.

Note: A maximum of 16 VLANs in total are supported across all of a RAP’s subordinate MAPs.

c. If you are configuring a RAP or MAP trunk port and chose gigabitEthernet0 (or FastEthernet0) (port 0-PoE in),

1. Choose trunk from the VLAN Mode drop-down list.
2. Enter a native VLAN ID for incoming traffic. The native VLAN ID can be any value between 1 and 4095. Do not assign any value assigned to a user-VLAN (access).
3. Enter a trunk VLAN ID for outgoing traffic, and click Add.

The added trunk appears in the summary column of allowed VLAN IDs.

If forwarding untagged packets, do not change the default trunk VLAN ID value of zero (such as MAP-to-MAP bridging, campus environment).

If forwarding tagged packets, enter a VLAN ID (1 to 4095) that is not already assigned (such as RAP to switch on wired network).
4. Click **Save**.

**Note**  At least one mesh access point must be set to RootAP in the mesh network.

---

**Autonomous to Lightweight Migration Support**

The autonomous to lightweight migration support feature provides a common application (WCS) from which you can perform basic monitoring of autonomous access points along with current lightweight access points. The following autonomous access points are supported:

- Cisco Aironet 1130 Access Point
- Cisco Aironet 1200 Access Point
- Cisco Aironet 1240 Access Point
- Cisco Aironet 1310 Bridge
- Cisco Aironet 1410 Bridge

You may also choose to convert autonomous access points to lightweight. Once an access point is converted to lightweight, the previous status or configuration of the access point is not retained.

From WCS, the following functions are available when managing autonomous access points:

- **Adding Autonomous Access Points to WCS**, page 9-160
- **Viewing Autonomous Access Points in WCS**, page 9-162
- **Adding and viewing autonomous access points from the Monitor > Maps page** (see the “Monitoring Maps” section on page 5-1 for more information)
- Monitoring associated alarms
- Performing an autonomous access point background task
  - Checks the status of autonomous access points managed by WCS.
  - Generates a critical alarm when an unreachable autonomous access point is detected.
- Running reports on autonomous access points
  - See **Reports > Inventory Reports** and **Reports > Client Reports > Client Count** for more information
- **Supporting Autonomous Access Points in Work Group Bridge (WGB) mode**, page 9-163
- **Migrating an Autonomous Access Point to a Lightweight Access Point**, page 11-154

---

**Adding Autonomous Access Points to WCS**

From WCS, the following methods are available for adding autonomous access points:

- **Adding Autonomous Access Points by Device Information**, page 9-161 (IP addresses and credentials).
Adding Autonomous Access Points by Device Information

Autonomous access points can be added to WCS by device information using comma-separated IP addresses and credentials.

To add autonomous access points using device information, follow these steps:

**Step 1** Choose Configure > Access Points.

**Step 2** From the Select a command drop-down list, choose Add Autonomous APs.

**Step 3** Click Go.

**Step 4** Choose Device Info from the Add Format Type drop-down list.

**Step 5** Enter comma-separated IP addresses of autonomous access points.

**Step 6** Select the Verify Telnet/SSH Credentials check box if you want this controller to verify Telnet/SSH credentials.

**Note** If you select the Verify Telnet/SSH checkbox, the migration analysis is run during the autonomous access point discovery process.

**Step 7** Enter the SNMP parameters including version number, number of retries, and timeout in seconds.

**Step 8** (Optional) Enter Telnet credentials for migration.

**Note** The Telnet credentials are required to convert the access points from autonomous to unified and for access point CLI templates.

**Note** If the autonomous access point already exists, WCS updates the credentials (SNMP and Telnet) to the existing device.

**Step 9** Click OK.

Adding Autonomous Access Points by CSV File

Autonomous access points can be added to WCS using a CSV file exported from WLSE.

To add autonomous access points using a CSV file, follow these steps:

**Step 1** Choose Configure > Access Points.

**Step 2** From the Select a command drop-down list, choose Add Autonomous APs.

**Step 3** Click Go.

**Step 4** Choose File from the Add Format Type drop-down list.

**Step 5** Enter or browse to the applicable CSV file.

The sample CSV files for V2 devices are as follows:
Configuring Access Points

The sample CSV files for V3 devices are as follows:

```
ip_address, network_mask, snmp_version, snmpv3_user_name, snmpv3_auth_type, snmpv3_auth_password, snmpv3_privacy_type, snmpv3_privacy_password, snmp_retries, snmp_timeout, telnet_username, telnet_password, telnet_retries, telnet_timeout
209.165.200.224, 255.255.255.224, v2, public, , , , , 3, 4
209.165.201.0, 255.255.255.224, v2, public, , , , , 3, 4
209.165.200.224, 255.255.255.224, v3, default, HMAC-MD5, default, None, , 3, 4
209.165.201.0, 255.255.255.224, v3, default, HMAC-MD5, default1, DES, default, 3, 4
```

The CSV files can contain the following fields:
- ip_address
- network_mask
- snmp_version
- snmp_community
- snmpv3_user_name
- snmpv3_auth_type
- snmpv3_auth_password
- snmpv3_privacy_type
- snmpv3_privacy_password
- snmp_retries
- snmp_timeout
- telnet_username
- telnet_password
- telnet_retries
- telnet_timeout

**Step 6**  
Click **OK**.

To remove an autonomous access point from WCS, follow these steps:

**Step 1**  
Select the check boxes of the access points you want to remove.

**Step 2**  
Choose **Remove APs** from the Select a command drop-down list.

### Viewing Autonomous Access Points in WCS

Once added, the autonomous access points can be viewed on the Monitor > Access Points page. Click the autonomous access point to view more detailed information such as the following:
Configuring Access Points

- Operational status of the access points
- Key attributes including radio information, channel, power, and number of clients on the radio
- CDP neighbored information

The autonomous access points can also be viewed in Monitor > Maps.

They can be added to a floor area by choosing Monitor Maps > floor area and choosing Add Access Points from the Select a command drop-down list.

Downloading Images to Autonomous Access Points

Lightweight access point images are bundled with controller images and managed by the controller. Autonomous access point images must be handled by a NMS system such as WLSE, CiscoWorks, or WCS.

To download images to autonomous access points, follow these steps:

Step 1: Choose Configure > Access Points.
Step 2: Select the check box of the autonomous access point to which you want to download an image. The AP Type column displays whether the access point is autonomous or lightweight.
Step 3: From the Select a command drop-down list, choose Download Autonomous AP Image. The image download page appears.

To ensure that no more than ten access points are selected for download, a check is made. The image must be compatible with all of the selected access points. Scheduling an immediate task initiates the image download. It is periodically refreshed.

Supporting Autonomous Access Points in Work Group Bridge (WGB) mode

Workgroup Bridge (WGB) mode is a special mode where an autonomous access point functions as a wireless client and connects to a lightweight access point. The WGB and its wired clients are listed as client in WCS if the AP mode is set to Bridge, and the access point is bridge capable.

To view a list of all WCS clients that are WGBs, choose Monitor > Clients. From the Show drop-down list, choose WGB Clients, and click Go. The Clients (detected as WGBs) page appears. Click a User to view detailed information regarding a specific WGB and its wired clients.

Note

The WCS provides WGB client information for the autonomous access point whether or not it is managed by the WCS. If the WGB access point is also managed by the WCS, WCS provides basic monitoring functions for the access point similar to other autonomous access points.

Upgrading Autonomous Access Points

You can choose to upgrade the autonomous access points manually or automatically. From the Migration Analysis page, you can choose the access point with the software version listed as failed and choose Upgrade Firmware (Manual or Automatic) from the Select a command drop-down list. This process upgrades the autonomous firmware image of the Cisco IOS access point to a supported version.
WCS uses a Telnet-based connection to upgrade the access point firmware. If you choose the automatic option, the internal TFTP server is used with the default images present in WCS. The default images as per device type are as follows:

- ap801-k9w7-tar.124-10b.JA3.tar
- ap802-k9w7-tar
- c1100-k9w7-tar.123-7.JA5.tar
- c1130-k9w7-tar.123-7.JA5.tar
- c1200-k9w7-tar.123-7.JA5.tar
- c1240-k9w7-tar.12307.JA5.tar
- c1250-k9w7-tar.124-10b.JA3.tar
- c1310-k9w7-tar.123-7.JA5.tar

If you choose the manual option, an additional screen with TFTP server IP, file path, and file path name appears. The final page is the report page.

**Changing Station Role to Root Mode**

Because a wired connection between the access point and controller is required to send the association request, the autonomous access point must be assigned the appropriate role. If the role shows as ineligible, you can choose **Change Station Role to Root Mode** from the Select a command drop-down list.

**Running Migration Analysis**

You can choose **Run Migration Analysis** from the Select a command drop-down list of the Migration Analysis Summary page. The resulting migration analysis summary shows the current status of different criteria. Initially, migration analysis is run automatically when the access point is discovered.

**Generating the Migration Analysis Report**

You can choose **View Migration Analysis Report** from the Select a command drop-down list of the Migration Analysis Summary page to generate a report. The report includes the following:

- Access point address
- Status
- Timestamp
- Access point logs

**Viewing Current Status of Cisco IOS Access Points**

Select **View Current Status** from the Select a command drop-down list of the Autonomous AP Migration Templates to view the status of Cisco IOS access point migration.

The following information is displayed:

- IP Address—IP address of the access point.
- Status—Current status of the migration.
- Progress—Summary of the migration progress.
Disabling Access Points that are Ineligible

If an autonomous access point is labelled as ineligible for conversion, you can disable it.

Configuring Access Point Details

Choose Configure > Access Points to see a summary of all access points in the Cisco WCS database. The summary information includes the following:

- Ethernet MAC
- IP Address
- Radio
- Map Location
- AP Type
- Controller
- Operation Status
- Alarm Status
- Audit Status

Note: If you hover your mouse cursor over the Audit Status value, the time of the last audit is displayed.

Note: You cannot configure the Cisco 600 Series Access Points from this page. It can be configured from the AP Configuration Templates page only. For details on configuring AP Configuration Templates, see “Configuring AP Configuration Templates” section on page 11-143.

Step 1: Click the link under AP Name to see detailed information about that access point name. The Access Point Detail page appears (see Figure 9-20).
Note

The operating system software automatically detects and adds an access point to the Cisco WCS database as it associates with existing controllers in the Cisco WCS database.

Note

Access point parameters may vary depending on the access point type.

Some of the parameters on the page are automatically populated.

- The General portion displays the Ethernet MAC, the Base Radio MAC, IP Address, and status.
- The Versions portion of the page displays the software and boot version.
• The Inventory Information portion displays the model, AP type, AP certificate type, serial number, and REAP mode support.

• The Ethernet Interfaces portion provides information such as interface name, slot ID, admin status, and CDP state.

• The Radio Interfaces portion provides the current status of the 802.11a/n and 802.11b/g/n radios such as admin status, channel number, power level, antenna mode, antenna diversity, and antenna type.

To set the configurable parameters, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Enter the name assigned to the access point.</td>
</tr>
<tr>
<td>3</td>
<td>Use the drop-down list to choose a country code to establish multiple country support. Access points are designed for use in many countries with varying regulatory requirements. You can configure a country code to ensure that the access point complies with your country’s regulations. Consider the following when setting the country code:</td>
</tr>
<tr>
<td></td>
<td>• You can configure up to 20 countries per controller.</td>
</tr>
<tr>
<td></td>
<td>• Because only one auto-RF engine and one list of available channels exist, configuring multiple countries limits the channels available to auto-RF in the common channels. A common channel is one that is legal in each and every configured country.</td>
</tr>
<tr>
<td></td>
<td>• When you configure access points for multiple countries, the auto-RF channels are limited to the highest power level available in every configured country. A particular access point may be set to exceed these limitations (or you may manually set the levels in excess of these limitations), but auto-RF does not automatically choose a non-common channel or raise the power level beyond that available in all countries.</td>
</tr>
<tr>
<td></td>
<td>Note: Access points may not operate properly if they are not designed for use in your country of operation. For example, an (-A) access point with part number AIR-AP1030-A-K9 (which is included in the Americas regulatory domain) cannot be used in Europe (-E). Always be sure to purchase access points that match your country’s regulatory domain. For a complete list of country codes supported per product, refer to this location: <a href="http://www.cisco.com/en/US/prod/collateral/wireless/ps5679/ps5861/product_data_sheet0900aecd80537b6a_ps430_Products_Data_Sheet.html">http://www.cisco.com/en/US/prod/collateral/wireless/ps5679/ps5861/product_data_sheet0900aecd80537b6a_ps430_Products_Data_Sheet.html</a>.</td>
</tr>
<tr>
<td>4</td>
<td>If you want to enable the access point for administrative purposes, select the Enable check box.</td>
</tr>
<tr>
<td>5</td>
<td>If you select Enable at the AP Static IP check box, a static IP address is always assigned to the access point rather than getting an IP address dynamically upon reboot.</td>
</tr>
<tr>
<td>6</td>
<td>Choose the role of the access point from the AP Mode drop-down list. No reboot is required after the mode is changed except when monitor mode is selected. You are notified of the reboot when you click Save. The available modes are as follows:</td>
</tr>
<tr>
<td></td>
<td>• Local—This is the normal operation of the access point and the default AP Mode choice. With this mode, data clients are serviced while configured channels are scanned for noise and rogues. The access point goes off-channel for 50 ms and listens for rogues. It cycles through each channel for the period specified under the Auto RF configuration.</td>
</tr>
</tbody>
</table>
• **H-REAP**—Choose **HREAP** from the AP Mode drop-down list to enable Hybrid REAP for up to six access points. The H-REAP access points can switch client data traffic locally and perform client authentication locally when their connection to the controller is lost.

**Note** To configure Local or HREAP access points for Cisco Adaptive wIPS feature, choose Local or HREAP, and select the **Enhanced wIPS Engine Enabled** check box.

• **Monitor**—This is radio receive only mode and allows the access point to scan all configured channels every 12 seconds. Only deauthentication packets are sent in the air with an access point configured this way. A monitor mode access point detects rogues, but it cannot connect to a suspicious rogue as a client to prepare for the sending of RLDP packets.

**Note** You can expand the monitor mode for tags to include location calculation by enabling the tracking optimized monitor mode (TOMM) feature. When TOMM is enabled, you can specify which four channels within the 2.4 GHz band (802.11b/g radio) of an access point to use to monitor tags. This allows you to focus channel scans on only those channels for which tags are traditionally found (such as channels 1, 6, and 11) in your network. To enable TOMM, you must also make additional edits on the 802.11b/g radio of the access point. See the “Configuring Access Point Radios for Tracking Optimized Monitor Mode” section on page 9-184 for configuration details.

**Note** You cannot enable both TOMM and wIPS at the same time. TOMM can be enabled only when wIPS is disabled.

**Note** To configure access points for Cisco Adaptive wIPS feature, choose **Monitor** and select the **Enhanced wIPS Engine Enabled** check box, and select **wIPS** from the Monitor Mode Optimization drop-down list.

• **Rogue Detector**—In this mode, the access point radio is turned off, and the access point listens to wired traffic only. The controllers that operate in this mode monitor the rogue access points. The controller sends all the rogue access point and client MAC address lists to the rogue detector, and the rogue detector forwards this information to the WLC. The MAC address list is compared to what the WLC access points expected. If the MAC addresses match, you can determine which rogue access points are connected on the wired network.

• **Sniffer**—Operating in sniffer mode, the access point captures and forwards all the packets on a particular channel to a remote machine that runs AiroPeek. These packets contain information such as timestamp, signal strength, packet size, and so on. This feature can only be enabled if you run AiroPeek, which is a third-party network analyzer software that supports the decoding of data packets. For more information on AiroPeek, see [http://www.wildpackets.com/products](http://www.wildpackets.com/products).

• **Bridge**—Bridge mode is a special mode where an autonomous access point functions as a wireless client and connects to a lightweight access point. The bridge and its wired clients are listed as clients in WCS if the AP mode is set to Bridge, and the access point is bridge capable.

• **SE-Connect**—This mode allows a CleanAir-enabled access point to be used extensively for interference detection on all monitored channels. All other functions such as IDS scanning and Wi-Fi are suspended.
Note: This option is displayed only if the access point is CleanAir-capable.

Note: Changing the AP mode reboots the access point.

Step 7  Disable any access point radios.

Step 8  From the AP Failover Priority drop-down list, choose Low, Medium, High, or Critical to indicate the access point’s failover priority. The default priority is low. See the “Setting AP Failover Priority” section on page 9-153 for more information.

Step 9  In the Primary, Secondary, and Tertiary Controller fields, you can define the order in which controllers are accessed.

Step 10 The AP Group Name drop-down shows all access point group names that have been defined using WLANs > AP Group VLANs, and you can specify whether this access point is tied to any group.

An access point group name to 31 characters for WLC versions earlier than 4.2.132.0 and 5.0.159.0.

Step 11  Enter a description of the physical location where the access point was placed.

Step 12  In the Stats Collection Period parameter, enter the time in which the access point sends .11 statistics to the controller. The valid range is 0 to 65535 seconds. A value of 0 means statistics should not be sent.

Step 13  Choose Enable for Mirror Mode if you want to duplicate (to another port) all of the traffic originating from or terminating at a single client device or access point. Mirror mode is useful in diagnosing specific network problems but should only be enabled on an unused port since any connections to this port become unresponsive.

Step 14  You can globally configure MFP on a controller. When you do, management frame protection and validation are enabled by default for each joined access point, and access point authentication is automatically disabled. After MFP is globally enabled on a controller, you can disable and re-enable it for individual WLANs and access points.

If you click to enable MFP Frame Validation, three main functions are performed:

- Management frame protection—When management frame protection is enabled, the access point protects the management frames it transmits by adding a message integrity check information element (MIC IE) to each frame. Any attempt to copy, alter, or replay the frame invalidates the MIC, causing those receiving access points which were configured to detect MFP frames to report the discrepancy.

- Management frame validation—When management frame validation is enabled, the access point validates every management frame it receives from other access points in the network. When the originator is configured to transmit MFP frames, the access point ensures that the MIC IE is present and matches the content of the management frame. If it receives any frame that does not contain a valid MIC IE, it reports the discrepancy to the network management system. To report this discrepancy, the access point must have been configured to transmit MFP frames. Likewise, for the timestamps to operate properly, all controllers must be Network Transfer Protocol (NTP) synchronized.

- Event reporting—The access point notifies the controller when it detects an anomaly, and the controller aggregates the received anomaly events and reports the results through SNMP traps to alert the network manager.
Step 15 Select the **Cisco Discovery Protocol** check box if you want to enable it. CDP is a device discovery protocol that runs on all Cisco-manufactured equipment, such as routers, bridges, and communication servers. Each device sends periodic messages to a multicast address and listens to the messages that others send to learn about neighboring devices. When the device boots, it sends a CDP packet specifying whether the device is inline power enabled so that the requested power can be supplied.

**Note** Changing access point parameters temporarily disables an access point and might result in loss of connectivity to some clients.

Step 16 Select the check box to enable rogue detection. See the “Rogue Access Point Location, Tagging, and Containment” section on page 3-21 for more information on rogue detection.

**Note** Rogue detection is disabled automatically for OfficeExtend access points because these access points, which are deployed in a home environment, are likely to detect a large number of rogue devices. For more information regarding OfficeExtend access points, refer to the *Cisco Wireless LAN Controller Configuration Guide*.

Step 17 Select the **Encryption** check box to enable encryption.

**Note** Enabling or disabling encryption functionality causes the access point to reboot, which then causes clients to lose connectivity.

**Note** DTLS data encryption is enabled automatically for OfficeExtend access points to maintain security, but disabled by default for all other access points.

**Note** Cisco 5500 controllers can be loaded with one of the two types of images, AS_5500_LDPE_x_x_x_x.aes or AS_5500_x_x_x_x.aes. For the 5500 controller loaded with former image, you need to have DTLS License to show encryption.

**Note** For WiSM2 and 2500 controllers, it is mandatory to have DTLS license to show encryption.

Step 18 If rogue detection is enabled, the access point radio is turned off, and the access point listens to wired traffic only. The controllers that operate in this mode monitor the rogue access points. The controller sends all the rogue access point and client MAC address lists to the rogue detector, and the rogue detector forwards this information to the WLC. The MAC address list is compared to what the WLC access points expected. If the MAC addresses match, you can determine which rogue access points are connected on the wired network.

Step 19 Select the **SSH Access** check box to enable SSH access.

Step 20 Select the **Telnet Access** check box to enable Telnet access.

**Note** An OfficeExtend access point may be connected directly to the WAN which could allow external access if the default password is used by the access point. Therefore, Telnet and SSH access are disabled automatically for OfficeExtend access points.
Step 21 If you want to override credentials for this access point, select the **Override Global Username** and **Password** check box. You can then enter a new supplicant AP username, AP password, and Enable password that you want to assign for this access point.

---

**Note**

In the System > AP Username Password page, you can set global credentials for all access points to inherit as they join a controller. These established credentials appear in the lower right of the AP Parameters tab page.

The information that you enter is retained across controller and access point reboots and if the access point joins a new controller.

---

Step 22 Select the **Enable Link Latency** check box to enable link latency for this access point or unselect it to prevent the access point from sending the round-trip time to the controller after every echo response is received. See the "Configuring Link Latency Settings for Access Points" section on page 9-195 for more information on link latency.

---

Step 23 You can now manipulate power injector settings through WCS without having to go directly to the controllers. In the Power Over Ethernet Settings section, select the check box to enable pre-standard or power injector state.

Pre-standard is chosen if the access point is powered by a high power Cisco switch; otherwise, it is disabled. If power injector state is selected, power injector options appear. The possible values are installed or override. If you choose override, you can either enter a MAC address or leave it empty so that it is supplied by WLC.

---

**Note**

To determine which source of power is running WCS, choose **Monitor > Access Points**, click **Edit View**, and then choose and move POE Status to the View Information box. After you click **Submit**, the POE status appears in the last column. If the device is powered by an injector, the POE status appears as Not Applicable.

---

Step 24 Select the **Enable** check box to enable the following H-REAP configurations:

---

**Note**

H-REAP settings cannot be changed when the access point is enabled.

- **OfficeExtend AP**—The default is Enabled.

  **Note**

  Unselecting the check box simply disables OfficeExtend mode for this access point. It does not undo all of the configuration settings on the access point, but it does put the access point at risk since it becomes remotely deployed. If you want to clear the access point’s configuration and return it to factory default settings, click **Clear Config** at the bottom of the access point details page. If you want to clear only the access point’s personal SSID, click **Reset Personal SSID** at the bottom of the access point details page.

When you select Enabled for the OfficeExtend AP, a warning message provides the following information:

- Configuration changes that automatically occur. Encryption and Link Latency are enabled. Rogue Detection, SSH Access, and Telnet Access are disabled.
- A reminder to configure at least one primary, secondary, and tertiary controller (including name and IP address).
Typically, an access point first looks for the primary controller to join. After that, the controller tries the secondary and then the tertiary controller. If none of these controllers are configured, the access point switches to a default discovery mode in an attempt to join whatever controller it may find.

An OfficeExtend access point searches only for a primary, secondary, or tertiary controller to join. It does not look any further for a configured controller. Because of this, it is important that you configure at least one primary, secondary, or tertiary controller name and IP address.

- A warning the enabling encryption causes the access point to reboot and causes clients to lose connectivity.
- Least Latency Controller Join—When enabled, the access point switches from a priority order search (primary, secondary, and then tertiary controller) to a search for the controller with the best latency measurement (least latency). The controller with the least latency provides the best performance.

Note: The access point only performs this search once when it initially joins the controller. It does not recalculate the primary, secondary, and tertiary controllers’ latency measurements once joined to see if the measurements have changed.

- Enable VLAN—When selected, enter the Native VLAN identifier. When Enable VLAN is selected, WCS displays locally switched VLANs.

Step 25 Select the role of the mesh access point from the Role drop-down list. The default setting is MAP.

Note: An access point in a mesh network functions as either a root access point (RAP) or mesh access point (MAP).

Step 26 Enter the name of the bridge group to which the access point belongs. The name can have up to 10 characters.

Note: Bridge groups are used to logically group the mesh access points to avoid two networks on the same channel from communicating with each other.

Note: For mesh access points to communicate, they must have the same bridge group name.

Note: For configurations with multiple RAPs, make sure that all RAPs have the same bridge group name to allow failover from one RAP to another.

Note: For configurations where separate sectors are required, make sure that each RAP and its associated MAPs have separate bridge group names.
The Type parameter appears whether the mesh access point is an indoor or outdoor access point, and the Backhaul Interface parameter displays the access point radio that is being used as the backhaul for the access point.

**Step 27** Choose the data rate for the backhaul interface from the drop-down list. Data rates available are dictated by the backhaul interface. The default rate is 18 Mbps.

**Note** This data rate is shared between the mesh access points and is fixed for the whole mesh network.

**Note** Do NOT change the data rate for a deployed mesh networking solution.

**Step 28** Choose **Enable** from the Ethernet Bridging drop-down list to enable Ethernet bridging for the mesh access point.

**Step 29** Click **Save** to save the configuration.

**Step 30** Re-enable the access point radios.

**Step 31** If you need to reset this access point, click **Reset AP Now**.

**Step 32** Click **Reset Personal SSID** to reset the OfficeExtend access point personal SSID to the factory default.

**Step 33** If you need to clear the access point configuration and reset all values to the factory default, click **Clear Config**.

---

**Configuring an Ethernet Interface**

**Note** The 152x mesh access points are configured on any one of these four ports: port 0-PoE in, port 1-PoE out, Port 2 - cable, and port 3- fiber. Other APs (such as 1130,1140,1240,1250) are configured on Port 2 - cable.

To configure an Ethernet interface, follow these steps:

**Step 1** Choose **Configure > Access Points**.

**Step 2** Click the link under AP Name to see detailed information about that access point name. The Access Point Detail page appears.

**Note** The Access Point Details page displays the list of Ethernet interfaces.

**Step 3** Click the link under Interface to see detailed information about that interface. The Ethernet Interface page appears.

This page displays the following parameters:

- AP Name—The name of the access point.
- Slot Id—Indicates the slot number.
- Admin Status—Indicates the administration state of the access point.
- CDP State—Select the **CDP State** check box to enable the CDP state.
Configuring Access Points

Chapter 9  Configuring Wireless Devices

Configuring Access Points

Step 4  Click Save.

Downloading Autonomous AP Images

From the Select a command drop-down list in the Configure > Access Points page, you can choose Download Autonomous AP Image. TFTP is used for the download. WCS verifies that no more than ten access points are selected for download. An appropriate warning also appears if another download is in progress. The image must be compatible with all of the selected access points prior to image download. The image download starts immediately and cannot be scheduled for a future time. An image download status screen is displayed and refreshed periodically.

Importing AP Configuration

To import a current access point configuration file, follow these steps:

Step 1  Choose Configure > Access Points.

Step 2  From the Select a command drop-down list, choose Import AP Config.

A pop-up alert box appears stating All Unified AP(s) are imported from CSV file only. Unified AP(s) from Excel and XML file are not imported.

Step 3  Click OK to close the pop-up alert box.

Step 4  Click Go.

Step 5  Enter the CSV file path in the text box or use the Browse button to navigate to the CSV file on your computer.

The first row of the CSV file is used to describe the columns included. The AP Ethernet Mac Address column is mandatory. The parameters on the page will be used for columns not defined in the CSV file.

Sample File Header:

```
ethernetMac,apName,location,primaryController,secondaryController,tertiaryController
```

- ethernetMac—Access point ethernet MacAddress
- apName—Access point name
- location—Access point location
- primaryController—Primary Controller
- secondaryController—Secondary Controller
- tertiaryController—Tertiary Controller

The CSV file can contain the following fields:

- AP Ethernet MacAddress—Mandatory
- AP Name—Optional
- Location—Optional
- Primary Controller—Optional
- Secondary Controller—Optional
Configuring Access Points

- Tertiary Controller—Optional

**Note**
Optional fields can remain empty. The AP Config Import ignores empty optional field values. However, if primaryMwar and secondaryMwar entries are empty then a unified access point update is not complete.

**Step 6**
When the appropriate CSV file path appears in the Select CSV File text box, click **OK**.

---

### Exporting AP Configuration

To export current access point configuration files, follow these steps:

**Step 1**
Choose **Configure > Access Points**.

**Step 2**
From the Select a command drop-down list, choose **Export AP Config**.

A pop-up alert box appears stating All Unified AP(s) are exported to CSV/EXCEL/XML file.

**Step 3**
Click **OK** to close the pop-up alert box.

**Step 4**
Click **Go** to view the current AP configurations including:
- apName
- ethernetMac
- location
- primaryController
- secondaryController
- tertiaryController

**Step 5**
Select the file option (CSV, Excel, XML) to export the access point configurations.

**Step 6**
In the File Download window, click **Save** to save the file.

---

### Configuring Access Points 802.11n Antenna

WCS provides the ability to enable or disable the use of specific antennas. All antennas are enabled by default.

**Note**
At least one transmitting and one receiving antenna must be enabled. You cannot disable all transmitting or all receiving antennas at once.

If you choose **Configure > Access Points** and select an **802.11n** item from the Radio column, the following page appears (see Figure 9-21).
Figure 9-21  Access Point > 802.11a/n

<table>
<thead>
<tr>
<th>General</th>
<th>RF Channel Assignment</th>
<th>Tx Power Level Assignment</th>
</tr>
</thead>
<tbody>
<tr>
<td>AP Name</td>
<td>Rogue_Detector</td>
<td>Current Channel</td>
</tr>
<tr>
<td>AP Base Radio MAC</td>
<td>00:14:18:ae:03:60</td>
<td>Assignment Method</td>
</tr>
<tr>
<td>Admin Status</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Controller</td>
<td>10.1.10.200.200.200</td>
<td></td>
</tr>
<tr>
<td>Site Config ID</td>
<td>6</td>
<td></td>
</tr>
</tbody>
</table>

| Antenna          | Internal              | Current Tx Power Level    | 1*                         |
|------------------|                       | Assignment Method         | Global                     |
| Antenna Diversity| Enabled               |                           | Custom                     |
| External Antenna | Optional              |                           |                            |
| Antenna Gain     | 0 dB                  |                           |                            |
| Current Gain (dBm)| 4.0                   |                           |                            |

Performance Profile:
To view/edit Performance Profile parameters for this AP Interface: click here

Footnotes:
1. Changing any of the parameters causes the radio to be temporarily disabled and thus may result in loss of connectivity for some clients.
The following 11n Parameters appear and can be modified:

**General**

- AP Name—The operator-defined name of the access point.
- AP Base Radio MAC—MAC address of the access point’s base radio.
- Admin Status—Select the box to enable the administration state of the access point.
- CDP State—Select the CDP State check box to enable CDP.
- Controller—IP address of the controller. Click the controller’s IP address for more details.
- Site Config ID—Site identification number.
- CleanAir Capable—Displays if the access point is CleanAir capable.
- CleanAir—Select the check box to enable CleanAir.

**Antenna**

- Antenna Type—Indicates an external or internal antenna.
- Antenna Diversity—Select Right, Left, or Enabled.

**Note** Antenna diversity refers to the Cisco Aironet access point feature where an access point samples the radio signal from two integrated antenna ports and chooses the preferred antenna. This diversity option is designed to create robustness in areas with multi-path distortion.

For external antennas, select one of the following:
- Enabled—Use this setting to enable diversity on both the left and right connectors of the access point.
- Left—Use this setting if your access point has removable antennas and you install a high-gain antenna on the access point’s left connector.
- Right—Use this setting if your access point has removable antennas and you install a high-gain antenna on the access point’s right connector.

For internal antennas, select one of the following:
- Enabled—Use this setting to enable diversity on both Side A and Side B.
- Side A—Use this setting to enable diversity on Side A (front antenna) only.
- Side B—Use this setting to enable diversity on Side B (rear antenna) only.

- External Antenna—Choose the external antenna or Other from the drop-down list.
- Antenna Gain—Enter the desired antenna gain in the text box.

**Note** The peak gain of the dBi of the antenna for directional antennas and the average gain in dBi for omni-directional antennas connected to the wireless network adapter. The gain is in multiples of 0.5 dBm. An integer value 4 means $4 \times 0.5 = 2$ dBm of gain.
- Current Gain (dBm)—Indicates the current gain in dBm.

Table 9-4 lists the antenna names, gain, and descriptions.

<table>
<thead>
<tr>
<th>Antenna Name</th>
<th>Gain (dBi)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AIR-ANT1000</td>
<td>0.00</td>
<td>AP 1000 Integrated antenna</td>
</tr>
<tr>
<td>CUSH-S5157WP</td>
<td>3.00</td>
<td>5.15-5.87 GHz diversity wideband panel antenna (side gain and back attenuation)</td>
</tr>
<tr>
<td>KODIAK-DIRECTIONAL</td>
<td>8.00</td>
<td>Integrated Kodiak directional antenna</td>
</tr>
<tr>
<td>KODIAK-OMNI</td>
<td>5.00</td>
<td>Kodiak omni antenna</td>
</tr>
<tr>
<td>AIR-ANT1728</td>
<td>5.20</td>
<td>Omni ceiling mount antenna</td>
</tr>
<tr>
<td>AIR-ANT1729</td>
<td>6.00</td>
<td>Patch wall mount antenna</td>
</tr>
<tr>
<td>AIR-ANT2012</td>
<td>6.50</td>
<td>Diversity patch wall mount antenna</td>
</tr>
<tr>
<td>AIR-ANT2410Y-R</td>
<td>10.00</td>
<td>Yagi master or wall mount antenna</td>
</tr>
<tr>
<td>AIR-ANT5959</td>
<td>2.00</td>
<td>Omni diversity ceiling mount antenna</td>
</tr>
<tr>
<td>AJAX-OMNI</td>
<td>5.00</td>
<td>Integrated Ajax omni antenna</td>
</tr>
<tr>
<td>AIR-ANT5135D-R</td>
<td>3.50</td>
<td>Omni dipole antenna</td>
</tr>
<tr>
<td>AIR-ANT5135DW-R</td>
<td>3.50</td>
<td>3.5-dBi white dipole antenna</td>
</tr>
<tr>
<td>AIR-ANT5135DG-R</td>
<td>3.50</td>
<td>3.5 dB5 gray non-articulating dipole antenna</td>
</tr>
<tr>
<td>AIR-ANT2422DW-R</td>
<td>2.20</td>
<td>2.2-dBi white dipole antenna</td>
</tr>
<tr>
<td>AIR-ANT2422DB-R</td>
<td>2.20</td>
<td>Omni dipole antenna</td>
</tr>
<tr>
<td>AIR-ANT2422DG-R</td>
<td>2.20</td>
<td>2.2 dBi gray non-articulating dipole antenna</td>
</tr>
<tr>
<td>AIR-ANT5145V-R</td>
<td>4.50</td>
<td>Omni diversity antenna</td>
</tr>
<tr>
<td>AIR-ANT5160V-R</td>
<td>6.00</td>
<td>Omni antenna</td>
</tr>
<tr>
<td>AIR-ANT3549</td>
<td>9.00</td>
<td>Patch wall mount antenna</td>
</tr>
<tr>
<td>AIR-ANT4941</td>
<td>2.20</td>
<td>Omni dipole antenna</td>
</tr>
<tr>
<td>AIR-ANT2506</td>
<td>0.00</td>
<td>Omni mass mount antenna</td>
</tr>
<tr>
<td>AIR-ANT3213</td>
<td>5.20</td>
<td>Omni diversity pillar antenna</td>
</tr>
<tr>
<td>CUSH-S24516DBP</td>
<td>3.00</td>
<td>Integrated 2.4/5 GHz hemispheric pattern</td>
</tr>
<tr>
<td>CUSH-S5153WBPX</td>
<td>6.00</td>
<td>Ceiling mount 6-dBi omni</td>
</tr>
<tr>
<td>AIR-ANT5170V-R</td>
<td>7.00</td>
<td>Wall mount diversity patch antenna</td>
</tr>
<tr>
<td>AIR-ANT5175V</td>
<td>7.50</td>
<td>Omni antenna for Wireless Bridge</td>
</tr>
<tr>
<td>AIR-ANT5195V-R</td>
<td>9.50</td>
<td>Wall mount patch antenna</td>
</tr>
<tr>
<td>AIR-ANT58G10SSA</td>
<td>9.50</td>
<td>Sector antenna for Wireless Bridge</td>
</tr>
<tr>
<td>AIR-ANT2455V</td>
<td>5.50</td>
<td>Omni antenna for Wireless Bridge</td>
</tr>
<tr>
<td>CUSH-S54717P</td>
<td>17.00</td>
<td>Patch array antenna for Wireless Bridge</td>
</tr>
<tr>
<td>CUSH-S49014WP</td>
<td>14.00</td>
<td>Patch array antenna for Wireless Bridge</td>
</tr>
<tr>
<td>CUSH-S2406BP</td>
<td>8.00</td>
<td>Omni antenna for Wireless Bridge</td>
</tr>
<tr>
<td>AIR-ANT1100</td>
<td>2.20</td>
<td>Default antenna for AP1100</td>
</tr>
</tbody>
</table>
The following table lists the default values of some of the attributes of an access point when it is added to the WCS for the first time.

<table>
<thead>
<tr>
<th>Antenna Name</th>
<th>Gain (dBi)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BR1310</td>
<td>13.00</td>
<td>Integrated patch directional antenna</td>
</tr>
<tr>
<td>AIR-ANT2460</td>
<td>6.00</td>
<td>Patch wall mount antenna</td>
</tr>
<tr>
<td>AIR-ANT2465</td>
<td>6.50</td>
<td>Diversity patch wall mount antenna</td>
</tr>
<tr>
<td>AIR-ANT2485</td>
<td>9.00</td>
<td>Patch wall mount antenna</td>
</tr>
<tr>
<td>AIR-ANT2480V-N</td>
<td>8.00</td>
<td>2.4 GHz omni antenna for mesh</td>
</tr>
<tr>
<td>AIR-ANT5114P-N</td>
<td>14.00</td>
<td>5 GHz patch for mesh</td>
</tr>
<tr>
<td>AIR-ANT5117S-N</td>
<td>17.00</td>
<td>5 GHz sector for mesh</td>
</tr>
<tr>
<td>AIR-ANT2450V-N</td>
<td>5.00</td>
<td>2.4 GHz omni antenna</td>
</tr>
<tr>
<td>AIR-ANT5180V-N</td>
<td>8.00</td>
<td>5 GHz omni antenna</td>
</tr>
<tr>
<td>AIR-ANT2450S-R</td>
<td>5.50</td>
<td>2.4 GHz 135-degree sector antenna</td>
</tr>
<tr>
<td>AIR-ANT2451V-R</td>
<td>2.4 GHz—2.0</td>
<td>2.4 GHz and 5 GHz four-element dual band antenna.</td>
</tr>
<tr>
<td>AIR-ANT2460NP-R</td>
<td>6.00</td>
<td>2.4 GHz MIMO (3-Element) Patch Antenna</td>
</tr>
<tr>
<td>AIR-ANT5160NP-R</td>
<td>6.00</td>
<td>5 GHz MIMO (3-Element) Patch Antenna</td>
</tr>
<tr>
<td>AIR-ANT2422SDW-R</td>
<td>2.20</td>
<td>2.4 GHz “Stubby” white monopole antenna</td>
</tr>
<tr>
<td>AIR-ANT5135SDW-R</td>
<td>3.50</td>
<td>5 GHz &quot;Stubby&quot; white monopole antenna</td>
</tr>
<tr>
<td>AIR-ANT2451NV-R</td>
<td>2.4 GHz—2.5 5 GHz—3.5</td>
<td>2.4 GHz and 5 GHz “6-pack” ceiling mount omni antenna</td>
</tr>
<tr>
<td>AIR-ANT2452V-R</td>
<td>5.2</td>
<td>2.4 GHz Diversity Wall Mount Omni-directional Antenna</td>
</tr>
<tr>
<td>AIR-ANT24020V-R</td>
<td>2.0</td>
<td>External omni diversity ceiling mount antenna</td>
</tr>
<tr>
<td>AIR-ANT2547V-N</td>
<td>2.4 GHz—4.0 5 GHz—7.0</td>
<td>2.4 GHz and 5 GHz dual band Omni-directional Antenna.</td>
</tr>
</tbody>
</table>
# Chapter 9  Configuring Wireless Devices

## Configuring Access Points

<table>
<thead>
<tr>
<th>AP Type</th>
<th>Radio Type</th>
<th>Supported Antennas</th>
</tr>
</thead>
<tbody>
<tr>
<td>AP 1131</td>
<td>802.11a</td>
<td>AJAX-OMNI</td>
</tr>
<tr>
<td></td>
<td>802.11b/g</td>
<td>AJAX-OMNI</td>
</tr>
<tr>
<td>AP 1100</td>
<td>802.11b/g</td>
<td>AIR-ANT1100</td>
</tr>
<tr>
<td></td>
<td>(only b/g)</td>
<td>AIR-ANT1100</td>
</tr>
<tr>
<td></td>
<td>802.11b/g</td>
<td>AIR-ANT1000, AIR-ANT4941, AIR-ANT1728, AIR-ANT2012, AIR-ANT1729, AIR-ANT5959, AIR-ANT2506, AIR-ANT3213, AIR-ANT2460, AIR-ANT2465, AIR-ANT2485, CUSH-S24516DBP, AIR-ANT2452V-R, AIR-ANT24020V-R</td>
</tr>
<tr>
<td>AP Type</td>
<td>Radio Type</td>
<td>Supported Antennas</td>
</tr>
<tr>
<td>---------</td>
<td>------------</td>
<td>--------------------</td>
</tr>
<tr>
<td>802.11b/g</td>
<td>AIR-ANT1000, AIR-ANT1728, AIR-ANT2012, AIR-ANT1729, AIR-ANT5959, AIR-ANT2506, AIR-ANT3213, AIR-ANT2460, AIR-ANT2465, AIR-ANT2485, CUSH-S24516DBP, AIR-ANT2452V-R, AIR-ANT24020V-R</td>
<td></td>
</tr>
<tr>
<td>AP 1500</td>
<td>802.11a</td>
<td>AIR-ANT5175V, AIR-ANT58G10SSA, CUSH-S54717P, CUSH-S49014WP</td>
</tr>
<tr>
<td></td>
<td>802.11b/g</td>
<td>AIR-ANT2455V, CUSH-S2406BP</td>
</tr>
<tr>
<td>AP 1505</td>
<td>802.11a</td>
<td>AIR-ANT5175V, AIR-ANT58G10SSA, CUSH-S54717P, CUSH-S49014WP</td>
</tr>
<tr>
<td></td>
<td>802.11b/g</td>
<td>AIR-ANT2455V, CUSH-S2406BP</td>
</tr>
<tr>
<td>AP 1040</td>
<td>802.11a</td>
<td>Internal-1040-5.0 GHz</td>
</tr>
<tr>
<td></td>
<td>802.11b/g</td>
<td>Internal-1040-2.4 GHz</td>
</tr>
<tr>
<td>AP 1140</td>
<td>802.11a</td>
<td>Internal-1140-5.0 GHz</td>
</tr>
<tr>
<td></td>
<td>802.11b/g</td>
<td>Internal-1140-2.4 GHz</td>
</tr>
<tr>
<td>AP 3500i</td>
<td>802.11a</td>
<td>Internal-3500i-5 GHz</td>
</tr>
<tr>
<td>AP 3500i</td>
<td>802.11b/g</td>
<td>Internal-3500i-2.4 GHz</td>
</tr>
</tbody>
</table>
WLAN Override

The following 802.11a WLAN Override parameter appears:

- WLAN Override—Choose **Enable** or **Disable** from the drop-down list.

**Note**

When you enable WLAN Override, operating system displays a table showing all current Cisco WLAN Solution WLANs. In the table, select WLANs to enable WLAN operation, and deselect WLANs to disallow WLAN operation for this 802.11a Cisco Radio.

**Note**

WLAN override does not apply to access points that support the 512 WLAN feature.

Performance Profile

Click the URL to view or edit performance profile parameters for this access point interface.

- **ClientLink**—Enable or disable client link for the access point radios per interface. This feature is only supported for legacy (orthogonal frequency-division multiplexing) OFDM rates. The interface must support ClientLink, and OFDM rates must be enabled. Also, two or more antennas must be enabled for transmission, and all three antennas must be enabled for reception.

**Note**

The maximum number of clients supported is 15. If the antenna configuration restricts operation to a single transmit antenna or OFDM rates are disabled, ClientLink cannot be used.

RF Channel Assignment

The following 802.11n RF Channel Assignment parameters appear:

- **Current Channel**—Channel number of the access point.
- **Assignment Method**—Select one of the following:
  - **Global**—Use this setting if your access point’s channel is set globally by the controller.
  - **Custom**—Use this setting if your access point’s channel is set locally. Select a channel from the drop-down list.
    
    For example, if you select 2(17 dBm) as the custom power, 2 corresponds to the Power Level and 17 is the Absolute Power (dBm).
  
- **Channel width**—Select the channel width from the drop-down list. The selections include 20, above 40, and below 40.

RF Channel assignment supports 802.11n 40 MHz channel width in the 5-GHz band. 40-MHz channelization allows radios to achieve higher instantaneous data rates.

The 40-MHz channel width is not applicable for the following APs on the 2.4-GHz band:

- 1260
- 3500e
- 3500i
Note: Selecting a larger bandwidth reduces the non-overlapping channels which could potentially reduce the overall network throughput for certain deployments.

**Tx Power Level Assignment**

- Current Tx Power Level—Indicates the current transmit power level.
- Assignment Method—Select one of the following:
  - Global—Use this setting if your access point’s power level is set globally by the controller.
  - Custom—Use this setting if your access point’s power level is set locally. Choose a power level from the drop-down list.

**11n Antenna Selection**

WCS provides the ability to enable or disable the use of specific antennas. All antennas are enabled by default.

Note: At least one transmitting and one receiving antenna must be enabled. You cannot disable all transmitting or all receiving antennas at once.

The following 11n Antenna Selection parameters appear:

- Transmit Antenna—Select the check box beside Antenna A or Antenna B to enable it.
- Receive Antenna—Select the check box beside Antenna A, B, or C to enable it.

**11n Parameters**

The following 11n parameter appears:

- 11n Supported—Indicates whether or not 802.11n radios are supported.

---

**Configuring CDP**

Cisco Discovery Protocol (CDP) is a device-discovery protocol that runs on all Cisco network equipment. Each device sends identifying messages to a multicast address, and each device monitors the messages sent by other devices.

Note: CDP is enabled on the bridge's Ethernet and radio ports by default.

**Configuring CDP on Access Point**

To configure CDP on Radio or Ethernet interfaces, follow these steps:

**Step 1** Choose **Configure > Access Points**.

**Step 2** Choose an access point associated with software release 5.0 or later.
Step 3  Choose the slots of radio or an Ethernet interface for which you want to enable CDP.

Step 4  Select the **CDP State** check box to enable CDP on the interface.

Step 5  Click **Save**.

---

**Configuring Access Point Radios for Tracking Optimized Monitor Mode**

To optimize monitoring and location calculation of tags, you can enable tracking optimized monitor mode (TOMM) on up to four channels within the 2.4-GHz band (802.11b/g radio) of an access point. This allows you to focus channel scans only on those channels on which tags are usually programmed to operate (such as channels 1, 6, and 11).

After enabling Monitor Mode at the access point level, you must then enable TOMM and assign monitoring channels on the 802.11b/g radio of the access point.

**Note**  For details on enabling Monitor Mode on an access point, refer to **Step 6** in the “Configuring Access Point Details” section on page 9-165.

To set enable TOMM and assign monitoring channels on the access point radio, follow these steps:

**Step 1**  After enabling Monitor Mode at the access point level, choose **Configure > Access Points**.

**Step 2**  In the Access Points page, click the **802.11 b/g Radio** link for the appropriate access point.

**Step 3**  In the General portion, disable **Admin Status** by unselecting the check box. This disables the radio.

**Step 4**  Select the **TOMM** check box. This check box only appears for Monitor Mode APs. drop-down lists for each of the four configurable channels display.

**Step 5**  Select the four channels on which you want the access point to monitor tags.

**Note**  You can configure fewer than four channels for monitoring. To eliminate a monitoring channel, select **None** from the channel drop-down list.

**Step 6**  Click **Save**. Channel selection is saved.

**Step 7**  In the Radio parameters page, re-enable the radio by selecting the **Admin Status** check box.

**Step 8**  Click **Save**. The access point is now configured as a TOMM access point.

The AP Mode displays as Monitor/TOMM in the Monitor > Access Points page.

---

**Copying and Replacing Access Points**

The Copy and Replace AP feature is useful if you need to remove an access point from the network and replace it with a new access point. All of the access point information, such as AP mode, name, and map location needs to be copied from the old access point to the new access point.

To access the **Copy and Replace AP** function, follow these steps:
Chapter 9  Configuring Wireless Devices

Configuring Access Points

**Step 1** Choose Configure > Access Points.

**Step 2** Select the check box for the applicable access point.

**Step 3** From the Select a command drop-down list, choose Copy and Replace AP.

**Step 4** Click Go.

The old access point needs to be removed from the network first. This access point then becomes unassociated to any controller. When you plug in the new access point, it is associated with the controller and WCS refreshes the information. At that point, select the old unassociated access point and choose to copy and replace the configuration to the new access point.

**Note**

If a different access point type is used to replace an older access point, only the configuration parameters that apply will be copied.

- Check box
- MAC Address
- Name—Name of the access point.
- Controller IP Address—IP address of controller to which the access point is associated.
- Map Location—Map location of the access point.
- Copy Location information

**Command Buttons**

- Copy to AP
- Cancel

**Removing Access Points**

To remove access points that are not associated, follow these steps:

**Step 1** Choose Configure > Access Points.

**Step 2** From the Select a command drop-down list, choose Remove APs.

**Step 3** Click Go.

**Step 4** Click OK to confirm the removal.

**Scheduling and Viewing Radio Status**

- Scheduling Radio Status, page 9-186
- Viewing Scheduled Tasks, page 9-186
Scheduling Radio Status

To schedule a radio status change (enable or disable), follow these steps:

Step 1 Choose Configure > Access Points.
Step 2 Select the check box for the applicable access point(s).
Step 3 From the Select a command drop-down list, choose Schedule Radio Status.
Step 4 Click Go.
Step 5 Choose Enable or Disable from the Admin Status drop-down list.
Step 6 Use the Hours and Minutes drop-down lists to determine the scheduled time.
Step 7 Click the calendar icon to select the scheduled date for the status change.
Step 8 If the scheduled task is recurring, choose Daily or Weekly, as applicable. If the scheduled task is a one-time event, choose No Recurrence.
Step 9 Choose Save to confirm the scheduled task.

Viewing Scheduled Tasks

To view currently scheduled radio status tasks, follow these steps:

Step 1 Choose Configure > Access Points.
Step 2 Select the check box for the applicable access point(s).
Step 3 From the Select a command drop-down list, choose View Scheduled Radio Task(s).
Step 4 Click Go.

The Scheduled Task(s) information includes:

- Scheduled Task(s)—Choose the task to view its access points and access point radios.
- Scheduled Radio adminStatus—Indicates the status change (Enable or Disable).
- Schedule Time—Indicates the time the schedule task occurs.
- Execution status—Indicates whether or not the task is scheduled.
- Recurrence—Indicates Daily or Weekly if the scheduled task is recurring.
- Next Execution—Indicates the time and date of the next task occurrence.
- Last Execution—Indicates the time and date of the last task occurrence.
- Unschedule—Click Unschedule to cancel the scheduled task. Click OK to confirm the cancellation.

Viewing Audit Status (for Access Points)

An Audit Status column in the Configure > Access Points page shows an audit status for each of the access points. You can also view the audit report for the selected access points. The report shows the time of the audit, the IP address of the selected access point, and the synchronization status.
To view the audit status, follow these steps:

**Step 1** Choose **Configure > Access Points**.

**Step 2** Click the **Audit Status** column value to go to the latest audit details page for the selected access point. This report is interactive and per access point.

| Note | If you hover your mouse cursor over the Audit Status column value, the time of the last audit is displayed. |

To run an access point on-demand audit report, select the desired access point for which you want to run the report and choose **Audit Now** from the Select a command drop-down list. In versions prior to 4.1, the audit only spanned the parameters present in the AP Details and AP Interface Details page. In release 4.1, this audit report covers complete access point level auditing. The audit results are stored in the database so that you can view the latest audit reports without having to run another audit.

| Note | The audit can only be run on an access point that is associated to a controller. |

### Searching Access Points

Use the search options in the uppermost right corner of the page to create and save custom searches:

- New Search: Enter an IP address, name, SSID, or MAC, and click Search.
- Saved Searches: Click **Saved Search** to choose a category, a saved custom search, or choose other criteria for a search from the drop-down lists.
- Advanced Search: An advanced search allows you to search for a device based on a variety of categories and filters.

See the “Using the Search Feature” section on page 2-34 for further information.

After you click **Go**, the access point search results appear (see Table 9-5).

<table>
<thead>
<tr>
<th>Table 9-5</th>
<th>Access Point Search Results</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Parameter</strong></td>
<td><strong>Options</strong></td>
</tr>
<tr>
<td>IP Address</td>
<td>IP address of the access point.</td>
</tr>
<tr>
<td>Ethernet MAC</td>
<td>MAC address of the access point.</td>
</tr>
<tr>
<td>AP Name</td>
<td>Name assigned to the access point. Click the access point name item to display details.</td>
</tr>
<tr>
<td>Radio</td>
<td>Protocol of the access point is either 802.11a/n or 802.11b/g/n.</td>
</tr>
<tr>
<td>Map Location</td>
<td>Campus, building, and floor location.</td>
</tr>
<tr>
<td>Controller</td>
<td>IP address of the controller.</td>
</tr>
<tr>
<td>AP Type</td>
<td>Access point radio frequency type.</td>
</tr>
</tbody>
</table>
Configuring Access Points

Viewing Mesh Link Details

You can access mesh link details in several ways:

- Click the **Mesh** tab on the WCS home page
- Choose **Monitor > Access Points**, click the **Mesh Links** tab and then click the **Details** link
- After you import a KML file from Google Earth, click the **AP Mesh** link

The current statistics are displayed at the top of the page followed by diagrams for certain statistics.

- **SNR Graph**—SNR Up and Down graphs are combined into one graph. Each set of data is represented by different colors.
- **Link Metrics Graph**—The Adjusted Link Metric and Unadjusted Link Metric is combined into one graph. Each set of data is represented by different colors.
- **Packet Error Rate Graph**—Displays the packet error rates in a graph.
- **Link Events**—The last five events for the link are displayed.
- **Mesh Worst SNR Links**—Displays the worst signal-to-noise ratio (SNR) links.
- **AP Uptime**—These statistics help determine if an access point is rebooting frequently.
- **LWAPP Join Taken Time**—These statistics determine how long it takes an access point to join.
- **Location Links**—Allows you to navigate to the WCS map or the Google Earth location.

Viewing or Editing Rogue Access Point Rules

You can view or edit current rogue access point rules on a single WLC. See the “Configuring a Rogue AP Rules Template” section on page 11-90 for more information.

To access the rogue access point rules, follow these steps:

**Step 1**  Choose **Configure > Controllers**.
Chapter 9      Configuring Wireless Devices

Configuring Ethernet Switches

The Configure Ethernet Switches feature allows you to add SNMP switch credentials to be used for tracing rogue access point switch ports.

Note
From the Configure > Ethernet Switches page, you can also add a location-capable switch for tracking wired clients by mobility services engine and WCS.

- Configuring Ethernet Switches, page 9-189
- Removing Ethernet Switch Credentials, page 9-191

Note
The following switches are supported: 3750, 3560, 3750E, 3560E, and 2960.

Configuring Ethernet Switch Credentials

To configure ethernet switch credentials, follow these steps:

Step 1 Choose Configure > Ethernet Switches.
Step 2 From the Select a command drop-down list, choose Add Ethernet Switches.

Note
To edit a current switch configuration, select the applicable switch from the list.

Step 3 Choose between Device and File format types.

Note
Select Device Info to manually enter a single or multiple switch IP addresses. Select File to import a file with multiple Catalyst switches IP addresses defined. When File is selected, a pop up page appears that defines the accepted format for the imported file.

Step 4 Enter the following information depending on the format selection (Device Info or File):
Device Info:
- IP Addresses—Separate multiple IP addresses with a comma.
- Network Mask
- Location Capable—Select the check box to enable.
Chapter 9      Configuring Wireless Devices

### Configuring Ethernet Switches

- **SNMP Parameters:**
  - **Version**—Select from v2c, v1, and v3.

  **Note** For switch port tracing to be successful in switches configured with SNMP v3, the context for the corresponding VLAN must be configured in the switch.

  The following is an example for configuring SNMPv3 on the switch:

  ```
  snmp-server view v3default iso included
  snmp-server group v3group v3 auth write v3default snmp-server user
  <username> <v3group> v3 auth <md5 or sha> <authentication password>
  ```

  If the switch has VLANs, you must configure each VLAN, otherwise switch porting tracing will fail. The following is an example if the switch has VLANs 1 and 20.

  ```
  snmp-server group v3group v3 auth context vlan-1  write v3default
  snmp-server group v3group v3 auth context vlan-20 write v3default
  ```

  **Note** When you create SNMP v3 view, make sure you include all of the OIDs.

  - **Retries**—Enter the number of controller retries allowed.
  - **Timeout (seconds)**—Enter the number of seconds allowed before the process stops without success.
  - **Community**

  **Note** Enter SNMP parameters for the write access, if available. If you enter read-only access parameters, the switch is added but WCS is unable to modify the configuration.

### File:

- **Select CSV File**—Enter the CSV file path in the text box or use the Browse button to navigate to the CSV file on your computer.

  **Note** Enter SNMP parameters for the write access, if available. If you enter read-only access parameters, the switch is added but WCS is unable to modify the configuration.

  The first row of the CSV file is used to describe the columns included. The IP Address column is mandatory.

  **Sample File One:**

  ```
  ip_address, snmp_version, snmp_community, network_mask
  1.1.1.1, v1, public, 255.255.255.0
  2.2.2.2, v2, public, 255.255.255.0
  3.3.3.3, v2, private, 255.255.255.0
  4.4.4.4, v2, private, 255.255.255.0
  5.5.5.5, v2, public, 255.255.255.0
  ```
Sample File Two:

```
ip_address,snmp_version,snmpv3_user_name,snmpv3_auth_type,snmpv3_auth_password,snmpv3_privacy_type,snmpv3_privacy_password,network_mask
1.1.1.1,v3,user1,HMAC-MD5,12345,DES,12345,255.255.255.0
2.2.2.2,v3,user1,HMAC-MD5,password3,DES,password4,255.255.255.0
10.77.246.19,v3,user1,HMAC-MD5,12345,DES,12345,255.255.255.0
```

The CSV file can contain following fields:

- ip_address—IP address
- network_mask—Network mask
- snmp_version—SNMP credentials version. Can be v1, v2, or v3.
- snmpv1_community—SNMP V1 community
- snmpv2_community—SNMP V2 community
- snmpv3_user_name—SNMP V3 username
- snmpv3_auth_type—SNMP V3 authorization type. Can be None or HMAC-MD5 or HMAC-SHA
- snmpv3_auth_password—SNMP V3 authorization password
- snmpv3_privacy_type—SNMP V3 privacy type. Can be None or DES or CFB-AES-128
- snmpv3_privacy_password—SNMP V3 privacy password
- snmp_retries—SNMP retries
- snmp_timeout—SNMP timeout

**Step 5** Click **OK** to confirm the device information or the CSV file path.

---

### Removing Ethernet Switch Credentials

To remove SNMP switch credentials, follow these steps:

**Step 1** Choose **Configure > Ethernet Switches**.
**Step 2** Select the check box(es) of the switch(es) you want to remove.
**Step 3** From the Select a command drop-down list, choose **Remove Switches**.
**Step 4** Click **Go**.
**Step 5** Click **OK** to confirm the deletion.

---

### Configuring Spectrum Experts

A Spectrum Expert client acts as a remote interference sensor and sends dynamic interference data to WCS. This feature allows the WCS to collect, monitor, and archive detailed interferer data from Spectrum Experts in the network.
To configure spectrum experts, choose **Configure > Spectrum Experts**. This page provides a list of all Spectrum Experts including:

- Hostname—The hostname or IP address of the Spectrum Expert laptop.
- MAC Address—The MAC address of the spectrum sensor card in the laptop.
- Reachability Status—Specifies whether the Spectrum Expert is successfully running and sending information to WCS. The status appears as reachable or unreachable.

### Adding a Spectrum Expert

To add a Spectrum Expert, follow these steps:

**Step 1** Choose **Configure > Spectrum Experts**.

**Step 2** From the Select a command drop-down list, choose **Add a Spectrum Expert**.

**Note** This link only appears when no spectrum experts are added. You can also access the Add a Spectrum Expert page by choosing **Add a Spectrum Expert** from the Select a command drop-down list.

**Step 3** Enter the Spectrum Expert’s Hostname or IP address. If you use hostname, your spectrum expert must be registered with DNS to be added to WCS.

**Note** To be correctly added as a spectrum expert, the spectrum expert client must be running and configured to communicate to WCS.

### Monitoring Spectrum Experts

You also have the option to monitor spectrum experts.

To monitor spectrum experts, follow these steps:

**Step 1** Choose **Monitor > Spectrum Experts**.

**Step 2** From the left sidebar menu, you can access the Spectrum Experts > Summary page and the Interferers > Summary page.

### Viewing Spectrum Experts Summary

The Spectrum Experts Summary page provides a table of the Spectrum Experts added to the system. The table provides the following Spectrum Expert information:

- Hostname—Displays the host name or IP address.
- Active Interferers—Indicates the current number of interferes being detected by the Spectrum Experts.
Alarms APs—The number of access points seen by the Spectrum Experts that are potentially affected by detected interferers.

Alarms—The number of active interference traps sent by the Spectrum Expert. Click to access the Alarm page that is filtered to the active alarms for this Spectrum Expert.

Reachability Status—Indicates “Reachable” in green if the Spectrum Expert is running and sending data to WCS. Otherwise, indicates “unreachable” in red.

Location—When the Spectrum Expert is a wireless client, a link for location is available. It shows the location of the Spectrum Expert with a red box that shows the effective range.

### Viewing Interferers Summary

The Interferers Summary page displays a list of all the interferers detected over a 30-day interval. The table provides the following interferers’ information:

- **Interferer ID**—An identifier that is unique across different spectrum experts.
- **Category**—Indicates the category of the interferer. Categories include: Bluetooth, cordless phones, microwave ovens, 802.11 FH, generic: fixed-frequency, jammers, generic: frequency-hopped, generic: continuous, and analog video.
- **Type**—Active indicates that the interferer is currently being detected by a spectrum expert. Inactive indicates that the interferer is no longer detected by a spectrum expert or the spectrum expert saw that the interferer is no longer reachable by WCS.
- **Discover Time**—Indicates when the interferer was discovered.
- **Affected Channels**—Identifies affected channels.
- **Number of APs Affected**—The number of access points managed by WCS that the spectrum expert detects or the interferers that the spectrum expert detected on the channels of the access point. Only active interferers are shown. If all of the following conditions are met, the access point is labelled as affected:
  - If the access point is managed by WCS.
  - If the spectrum expects detects the access point.
  - If the spectrum expert detects an interferer on the serving channel of the access point.
- **Power**—Indicated in dBm.
- **Duty Cycle**—Indicated in percentage. 100% is the worst value.
- **Severity**—Indicates the severity ranking of the interferer. 100 is the worst case whereas 0 is no interference.

### Viewing Spectrum Experts Details

The Spectrum Expert Details page provides all interference details from a single Spectrum Expert. This page updates every 20 seconds and gives a real-time look at the remote spectrum expert. This page includes the following items:

- **Total Interferer Count**—Given from the specific spectrum expert.
- **Active Interferers Count Chart**—Displays a pie chart that groups interferers by category.
- **Active Interferer Count Per Channel**—Displays the number of interferers grouped by category on different channels.
• **AP List**—Provides a list of access points detected by the spectrum expert. These access points are on channels that have active interferers detected.

• **Affected Clients List**—Provides a list of clients that are currently authenticated to an access point. You can select specific RADIUS or LDAP servers to provide external authentication on the Security > AAA page.

### OfficeExtend Access Point

An OfficeExtend access point provides secure communications from a controller to an access point at a remote location, seamlessly extending the corporate WLAN over the Internet to an employee’s residence. The teleworker’s experience at the home office is exactly the same as it would be at the corporate office. Datagram Transport Layer Security (DTLS) encryption between the access point and the controller ensures that all communications have the highest level of security.

Figure 9-22 illustrates a typical OfficeExtend access point setup.

![Figure 9-22 Typical OfficeExtend Access Point Setup](image)

**Note**

OfficeExtend access points are designed to work behind a router or other gateway device that is using network address translation (NAT). NAT allows a device, such as a router, to act as an agent between the Internet (public) and a personal network (private), thereby enabling an entire group of computers to be represented by a single IP address. In controller release 6.0, only one OfficeExtend access point can be deployed behind a single NAT device.

Currently, only Cisco Aironet 1130 series and 1140 series access points that are joined to a Cisco 5500 series controller with a WPlus license can be configured to operate as OfficeExtend access points.

**Note**

Your firewall must be configured to allow traffic from access points using CAPWAP. Make sure that UDP ports 5246 and 5247 are enabled and are not blocked by an intermediate device that could prevent an access point from joining the controller.

### Licensing for an OfficeExtend Access Point

Make sure that the WPlus license is installed on the 5500 series controller. After the license is installed, you can enable the OfficeExtend mode on an 1130 series or 1140 series access point.
The operating system software automatically detects and adds an access point to the Cisco WCS database as it associates with existing controllers in the Cisco WCS database.

### Configuring Link Latency Settings for Access Points

You can configure link latency on the controller to measure the link between an access point and the controller. This feature can be used with all access points joined to a controller but is especially useful for hybrid-REAP access points, for which the link could be a slow or unreliable WAN connection.

Link latency is supported for use only with hybrid-REAP access points in connected mode. Hybrid-REAP access points in standalone mode are not supported.

Link latency monitors the round-trip time of the CAPWAP heartbeat packets (echo request and response) from the access point to the controller and back. This time can vary due to network link speed and controller processing loads. The access point timestamps the outgoing echo requests to the controller and the echo requests received from the controller. The access point sends this delta time to the controller as the system round-trip time. The access point sends heartbeat packets to the controller at a default interval of 30 seconds.

Link latency calculates the CAPWAP response time between the access point and the controller. It does not measure network latency or ping responses.

The controller displays the current round-trip time as well as a running minimum and maximum round-trip time. The minimum and maximum times continue to run as long as the controller is up or can be cleared and allowed to restart.

To configure link latency, follow these steps:

**Step 1** In the Configure > Access Point details page, select the **Enable Link Latency** check box to enable link latency for this access point or unselect it to prevent the access point from sending the round-trip time to the controller after every echo response is received. The default value is unselected.

**Step 2** Click **Save** to save your changes.

The link latency results appear below the Enable Link Latency check box:

- **Current**—The current round-trip time (in milliseconds) of CAPWAP heartbeat packets from the access point to the controller and back.
- **Minimum**—Since link latency has been enabled or reset, the minimum round-trip time (in milliseconds) of CAPWAP heartbeat packets from the access point to the controller and back.
- **Maximum**—Since the link latency has been enabled or reset, the maximum round-trip time (in milliseconds) of CAPWAP heartbeat packets from the access point to the controller and back.

**Step 3** To clear the current, minimum, and maximum link latency statistics on the controller for this access point, click **Reset Link Latency**. The updated statistics appear in the Minimum and Maximum fields.
Configuring Chokepoints

Chokepoints are low frequency transmitting devices. When a tag passes within range of placed chokepoint, the low-frequency field awakens the tag that in turn sends a message over the Cisco Unified Wireless Network including the chokepoint device ID. The transmitted message includes sensor information (such as temperature and pressure). A chokepoint location system provides room level accuracy (ranging from few inches to 2 feet depending on the vendor).

Chokepoints are installed and configured as recommended by the Chokepoint vendor. After the chokepoint installation is complete and operational, the chokepoint can be entered into the location database and plotted on a WCS map.

- Configure New Chokepoints, page 9-196
- Editing Current Chokepoints, page 9-198

Configure New Chokepoints

- Adding a Chokepoint to WCS Database, page 9-196
- Adding a Chokepoint to a WCS Map, page 9-197
- Removing a Chokepoint from a WCS Map, page 9-198
- Removing a Chokepoint from WCS, page 9-198

Adding a Chokepoint to WCS Database

To add a chokepoint to the WCS database, follow these steps:

Step 1  Choose Configure > Chokepoints.
Step 2  From the Select a command drop-down list, choose Add Chokepoints.
Step 3  Click Go.
Step 4  Enter the MAC address and name for the chokepoint.
Step 5  Select the check box to indicate that it is an Entry/Exit Chokepoint.
Step 6  Enter the coverage range for the chokepoint.

Note  Chokepoint range is a visual representation only. It is product-specific. The actual range must be configured separately using the applicable chokepoint vendor software.

Step 7  Click OK.

Note  After the chokepoint is added to the database, it can be placed on the appropriate WCS floor map.
## Adding a Chokepoint to a WCS Map

To add the chokepoint to a map, follow these steps:

### Step 1
Choose **Monitor > Maps**.

### Step 2
In the Maps page, click the link that corresponds to the floor location of the chokepoint.

### Step 3
From the Select a command drop-down list, choose **Add Chokepoints**.

### Step 4
Click **Go**.

**Note** The Add Chokepoints summary page lists all recently-added chokepoints that are in the database but not yet mapped.

### Step 5
Select the check box next to the chokepoint that you want to place on the map.

### Step 6
Click **OK**.

A map appears with a chokepoint icon located in the top-left hand corner. You are now ready to place the chokepoint on the map.

### Step 7
Left-click the chokepoint icon and drag and place it in the proper location.

**Note** The MAC address, name, and coverage range of the chokepoint appear in the selected chokepoints detail page when you click the chokepoint icon for placement.

### Step 8
Click **Save**.

You are returned to the floor map and the added chokepoint appears on the map.

**Note** The newly created chokepoint icon may or may not appear on the map depending on the display settings for that floor.

**Note** The rings around the chokepoint icon indicate the coverage area. When a CCX tag and its asset passes within the coverage area, location details are broadcast, and the tag is automatically mapped on the chokepoint coverage circle. When the tag moves out of the chokepoint range, its location is calculated as before and is no longer mapped on the chokepoint rings.

**Note** MAC address, name, entry/exit chokepoint, static IP address, and range of the chokepoint display when you hover your mouse cursor over its map icon.

### Step 9
If the chokepoint does not appear on the map, select the **Chokepoints** check box located in the Floor Settings menu.

**Note** Do not select the **Save Settings** check box unless you want to save this display criteria for all maps.
Chapter 9      Configuring Wireless Devices

Configuring Chokepoints

Note
You must synchronize network design to the mobility services engine or location server to push chokepoint information.

Removing a Chokepoint from a WCS Map

To remove an chokepoint from the map, follow these steps:

Step 1  Choose Monitor > Maps.
Step 2  In the Maps page, choose the link that corresponds to the floor location of the chokepoint.
Step 3  From the Select a command drop-down list, choose Remove Chokepoints.
Step 4  Click Go.
Step 5  Click OK to confirm the deletion.

Removing a Chokepoint from WCS

To remove an chokepoint from WCS, follow these steps:

Step 1  Choose Configure > Chokepoints.
Step 2  Select the check box of the chokepoint that you want to delete.
Step 3  From the Select a command drop-down list, choose Remove Chokepoints.
Step 4  Click Go.
Step 5  Click OK to confirm the deletion.

Editing Current Chokepoints

To edit a current chokepoint in the WCS database and appropriate map, follow these steps:

Step 1  Choose Configure > Chokepoints. The Configure > Chokepoints page displays the following information for each current chokepoint: MAC address, chokepoint name, entry/exit chokepoint, range, static IP address, and map location for the chokepoint.
Step 2  Click the chokepoint you want to edit in the MAC Address column.
Step 3  Edit the following parameters, as necessary:
   - Name
   - Entry/Exit Chokepoint—Click to enable.
   - Range—Coverage range for the chokepoint.
Configuring WiFi TDOA Receivers

- Using WiFi TDOA Receivers to Enhance Tag Location Reporting, page 9-199
- Adding Wi-Fi TDOA Receivers to Cisco WCS and Maps, page 9-200
- Viewing or Editing Current Wi-Fi TDOA Receivers, page 9-201
- Removing Wi-Fi TDOA Receivers from Cisco WCS and Maps, page 9-202

Using WiFi TDOA Receivers to Enhance Tag Location Reporting

The Wi-Fi TDOA receiver is an external system designed to receive signals transmitted from a tagged, tracked asset. These signals are then forwarded to the mobility services engine to aid in the location calculation of the asset. TDOA receivers use the method of Time Difference of Arrival (TDOA) to calculate tag location. This method uses data from a minimum of three TDOA receivers to generate a tagged asset location.

- If a TDOA receiver is not in use and the partner engine software is resident on the mobility service engine, then the location calculations for tags are generated using RSSI readings from access points.
- If the partner software engine is not installed and no TDOA receiver is in use, no tag location calculations are done.

Before using a TDOA receiver within the Cisco Unified Wireless Network, you must perform the following tasks.

1. Have a mobility services engine active in the network.
   See the “Adding a Mobility Services Engine” section on page 12-5 for details on adding a mobility services engine.
2. Add the TDOA receiver to the WCS database and map.
   See the “Adding Wi-Fi TDOA Receivers to Cisco WCS and Maps” section on page 9-200 for details on adding the TDOA receiver to WCS.
3. Download the partner engine software to the mobility services engine using WCS.
4. Synchronize WCS and mobility services engines.
   See the “Synchronizing Services” section on page 12-10 for details on synchronization.
5. Set up the TDOA receiver using the AeroScout System Manager.
Chapter 9  Configuring Wireless Devices

Adding Wi-Fi TDOA Receivers to Cisco WCS and Maps

After the Wi-Fi TDOA receiver is installed and configured by the AeroScout System Manager and the partner software is downloaded on the mobility services engine, you are ready to add the TDOA receiver to the mobility services engine database and position it on a WCS map.

After adding TDOA receivers to WCS maps, you continue to make configuration changes to the TDOA receivers using the AeroScout System Manager application rather than WCS.

To add a TDOA receiver to the WCS database and appropriate map, follow these steps:

Step 1  In WCS, choose Configure > WiFi TDOA Receivers to open the All WiFi TDOA Receivers summary page.

To view or edit current WiFi TDOA receiver details, click the MAC Address link to open the details page.

Step 2  From the Select a command drop-down list, choose Add WiFi TDOA Receivers.

Step 3  Click Go.

Step 4  Enter the MAC address, name and static IP address of the TDOA receiver.

Step 5  Click OK to save the TDOA receiver entry to the database.

After you add the TDOA receiver to the database, you can place the TDOA receiver on the appropriate WCS floor map. To do so, continue with Step 6.

A WiFi TDOA Receiver must be configured separately using the receiver vendor software.

Step 6  To add the TDOA receiver to a map, choose Monitor > Maps.

Step 7  In the Maps page, select the link that corresponds to the floor location of the TDOA receiver.

Step 8  From the Select a command drop-down list, choose Add WiFi TDOA receivers.

Step 9  Click Go.
**Note** The All WiFi TDOA Receivers summary page lists all recently-added TDOA receivers that are in the database but not yet mapped.

**Step 10** Select the check box next to each TDOA receiver to add it to the map.

**Step 11** Click OK. A map appears with a TDOA receiver icon located in the top-left hand corner. You are now ready to place the TDOA receiver on the map.

**Step 12** Left-click the TDOA receiver icon and drag and place it in the proper location on the floor map.

**Note** The MAC address and name of the TDOA receiver appear in the left pane when you click the TDOA receiver icon for placement.

**Step 13** Click **Save** when the icon is placed correctly on the map. The added TDOA receiver appears on the floor heat map.

**Note** The icon for the newly added TDOA receiver may or may not appear on the map depending on the display settings for that floor. If the icon did not appear, proceed with **Step 14**.

**Step 14** If the TDOA receiver does not appear on the map, click **Layers** to collapse a selection menu of possible elements to display on the map.

**Step 15** Select the **WiFi TDOA Receivers** check box. The TDOA receiver appears on the map.

**Note** When you place your cursor over a TDOA receiver on a map, configuration details display for that receiver.

**Step 16** Click **X** to close the Layers page.

**Note** Do not choose **Save Settings** from the Layers menu unless you want to save this display criteria for all maps.

**Step 17** You can now download the partner engine software to the mobility services engine.

---

**Viewing or Editing Current Wi-Fi TDOA Receivers**

To view a current TDOA receiver to the WCS database, follow these steps:

**Step 1** In WCS, choose **Configure > WiFi TDOA Receivers** to open the All WiFi TDOA Receivers summary page.

**Step 2** Click the MAC Address link to view the TDOA receiver details including MAC address, name, and static IP address.

**Step 3** If you make any changes to the receiver name or IP address, click **Save** to confirm these changes.
Removing Wi-Fi TDOA Receivers from Cisco WCS and Maps

You can remove one or multiple WiFi TDOA receivers at a time. If you remove a TDOA receiver from a map it remains in the WCS database but is labeled as unassigned.

To delete a TDOA receiver from WCS, follow these steps:

**Step 1** In WCS, choose Configure > WiFi TDOA Receivers to open the All WiFi TDOA Receivers summary page.

**Step 2** Select the check box next to each TDOA receiver to be deleted.

**Step 3** From the Select a command drop-down list, choose Remove WiFi TDOA Receivers.

**Step 4** Click Go.

**Step 5** To confirm TDOA receiver deletion, click OK in the dialog box.

In the All WiFi TDOA Receivers page, a message confirms the deletion. The deleted TDOA receiver is no longer listed in the page.

Configuring Scheduled Configuration Tasks

The Scheduled Configuration Tasks feature allows you to view, modify, and delete scheduled access point template and configuration group tasks. To access the Scheduled Configuration Tasks page, choose Configure > Scheduled Configuration Tasks.

This section contains the following topics:

- AP Template Tasks, page 9-202
- Configuring Config Groups, page 9-204
- Viewing WLAN Configuration Scheduled Task Results, page 9-206
- Downloading Software, page 9-207

AP Template Tasks

The AP Template Tasks page allows you to view, modify, delete, enable, or disable current access point template tasks. To access the AP Template Tasks page and view current access point template tasks, choose Configure > Scheduled Configuration Tasks.

- Modifying a Current AP Template Task, page 9-203
- Viewing AP Status Report for the Scheduled Task, page 9-203
- Enabling or Disabling a Current AP Template Task, page 9-203
Modifying a Current AP Template Task

To modify a current access point template task, follow these steps:

- **Step 1** Choose Configure > Scheduled Configuration Tasks.
- **Step 2** Select the template name of the applicable task.
- **Step 3** In the AP Radio/Template page, click the Apply/Schedule tab.
- **Step 4** Make any necessary changes to the current schedule or access point template, and click Schedule.

Viewing AP Status Report for the Scheduled Task

The AP Status Report for the scheduled task includes the following information:

- **AP Name**—Lists all of the access points included in the scheduled access point template task.
- **Ethernet MAC**—Indicates the Ethernet MAC addresses for the applicable access points.
- **Controller**—Indicates the associated controller for each of the applicable access points.
- **Map**—Displays the map location for the applicable access points.
- **Status**—Indicates whether the access point template has been successfully applied. Possible states include Not Initiated, Success, Failure, Partial Failure, and Not Reachable.
- **Task Execution Time**—Indicates the execution time of the scheduled task for the applicable access point.

To view the status report for the access points included in the scheduled task, follow these steps:

- **Step 1** Choose Configure > Scheduled Configuration Tasks.
- **Step 2** Select the AP Status Report for the applicable task.

Enabling or Disabling a Current AP Template Task

To enable or disable a current access point template task, follow these steps:

- **Step 1** Choose Configure > Scheduled Configuration Tasks.
- **Step 2** Select the check box of the scheduled task to be enabled or disabled.
- **Step 3** From the Select a command drop-down list, choose Enable Schedule or Disable Schedule, as applicable.
- **Step 4** Click Go.
Viewing AP Template Task History

To view previous scheduled task reports, follow these steps:

**Step 1** Choose **Configure > Scheduled Configuration Tasks**.
**Step 2** Select the check box of the applicable scheduled task.
**Step 3** From the Select a command drop-down list, choose **View History**.
**Step 4** Click **Go**.

Deleting a Current AP Template Task

To delete a scheduled access point template task, follow these steps:

**Step 1** Choose **Configure > Scheduled Configuration Tasks**.
**Step 2** Select the check box of the applicable scheduled task.
**Step 3** From the Select a command drop-down list, choose **Delete Task(s)**.
**Step 4** Click **Go**.
**Step 5** Click **OK** to confirm the deletion.

Configuring Config Groups

The Config Group Tasks page allows you to view, modify, delete, enable, or disable current configuration group tasks. To access the Config Group Tasks page and view current config group tasks, choose **Configure > Scheduled Configuration Tasks > ConfigGroup**.

- Modifying a Current Config Group Task, page 9-204
- Viewing Controller Status Report for the Scheduled Task, page 9-205
- Enabling or Disabling a Current Config Group Task, page 9-205
- Viewing Config Group Task History, page 9-205
- Deleting a Current Config Group Task, page 9-206

Modifying a Current Config Group Task

To modify a current configuration group task, follow these steps:

**Step 1** Choose **Configure > Scheduled Configuration Tasks**.
**Step 2** From the left sidebar menu, choose **ConfigGroup**.
**Step 3** Select the group name of the applicable task.
**Step 4** From the Config Groups page, click the **Apply/Schedule** tab.
Chapter 9      Configuring Wireless Devices

Viewing Controller Status Report for the Scheduled Task

The Controller Status Report for the scheduled task includes the following information:

- **Group Name**—Name of the config group.
- **Schedule**—Indicates whether the task is enabled, disabled, or expired.
- **Last Run Time**—Indicates the date and time of the most recent scheduled task.
- **Next Scheduled Run**—Indicates the date and time of the next scheduled task.
- **Controller Status Report**—Indicates the number of status reports for this config group. Click the number link to view the status reports.

To view the controller status report, follow these steps:

**Step 1** Choose **Configure > Scheduled Configuration Tasks**.

**Step 2** From the left sidebar menu, choose **ConfigGroup**.

**Step 3** Select the Controller Status Report for the applicable task. The Controller Status Report provides the following information:

- **Controller**
- **Status of task** (such as Not Initiated, Success, Failure, Partial Failure, Partial Success, Not Reachable)
- **Number of templates applied**
- **Number of templates failed**
- **Time and date of the task execution**

Enabling or Disabling a Current Config Group Task

To enable or disable a current configuration group task, follow these steps:

**Step 1** Choose **Configure > Scheduled Configuration Tasks**.

**Step 2** From the left sidebar menu, choose **ConfigGroup**.

**Step 3** Select the check box of the scheduled task to be enabled or disabled.

**Step 4** From the Select a command drop-down list, choose **Enable Schedule** or **Disable Schedule**, as applicable.

**Step 5** Click **Go**.

Viewing Config Group Task History

To view previous scheduled task reports, follow these steps:
Step 1  Choose **Configure > Scheduled Configuration Tasks**.

Step 2  From the left sidebar menu, choose **ConfigGroup**.

Step 3  Select the check box of the applicable scheduled task.

Step 4  From the Select a command drop-down list, choose **View History**.

Step 5  Click **Go**.

---

### Deleting a Current Config Group Task

To delete a scheduled configuration group task, follow these steps:

Step 1  Choose **Configure > Scheduled Configuration Tasks**.

Step 2  From the left sidebar menu, choose **ConfigGroup**.

Step 3  Select the check box of the applicable scheduled task.

Step 4  From the Select a command drop-down list, choose **Delete Task(s)**.

Step 5  Click **Go**.

Step 6  Click **OK** to confirm the deletion.

---

### Viewing WLAN Configuration Scheduled Task Results

**Note**  There is no drop-down command list provided for WLAN Configuration.

To view and manage all scheduled WLAN tasks in WCS, follow these steps:

Step 1  Choose **Configure > Scheduled Configuration Tasks**.

Step 2  From the left sidebar menu, choose **WLAN Configuration** to open the WLAN Configuration Task List page.

Step 3  If scheduled configuration tasks are available, the WLAN Configuration Task List page contains the following parameters:

- Schedule Task Name—The user-defined name of the new scheduled task.
- Schedule—Indicates the status of the scheduled task.
- WLAN Status—Indicates the status of the WLAN.
- Controller IP Address—Indicates the IP address of the controller.
- Last Run Time—Indicates the date and time of the most recent scheduled task.
- Next Scheduled Run—Indicates the date and time of the next scheduled task.
- Recurrence—Indicates Daily or Weekly if the scheduled task is recurring.
Chapter 9  Configuring Wireless Devices

Configuring Scheduled Configuration Tasks

Step 4  Select the Task Name link to open the WLAN Schedule Detail page. In this page, you can modify the date and time of the scheduled task. See the “Managing WLAN Status Schedules” section on page 9-75 for more information.

Step 5  Select the check box of the scheduled task and use the Select a command drop-down list located in the WLAN Configuration Task List page to enable, disable, or delete selected tasks.

- Enable Schedule—Enable the task if its schedule is disabled on the server.
- Disable Schedule—Disable the running scheduled task on the server. Once disabled, the task will not run at the scheduled time. You can re-enable the task at a later time.
- View History—View the execution results for individual WLAN tasks including reasons for any failures.
- Delete Task(s)—Delete the selected task from the WCS server.

Downloading Software

By using this feature you can schedule tasks for downloading software to controllers. The Download Software Tasks page allows you to add, delete, view, enable, or disable scheduled download software tasks. To access the Download Software Tasks page and view current download software tasks, choose Configure > Scheduled Configuration Tasks > Download Software.

- Adding a Download Software Task, page 9-207
- Modifying a Download Software Task, page 9-209
- Selecting Controllers for the Download Software Task, page 9-209
- Viewing Download Software Results, page 9-210
- Deleting a Download Software Task, page 9-210
- Enabling or Disabling a Download Software Task, page 9-211

Adding a Download Software Task

To add a download software task, follow these steps:

Step 1  Choose Configure > Scheduled Configuration Tasks.
Step 2  From the left sidebar menu, choose Download Software to open the Download Software Task List page.
Step 3  From the Select a command drop-down list, choose Add Download Software Task.
Step 4  Click Go. The New Download Software Task page appears.
Step 5  Configure the following information:

- General
  - Task Name—Enter a Scheduled Task Name to identify this scheduled software download task.
- Schedule Details
  - Download Type—Select the download type. Select the Download software to controller check box to schedule download software to controller or select the Pre-download software APs check box to schedule the pre-download software APs. If you select Download software to controller, specify the image details.
Chapter 9 Configuring Wireless Devices

Configuring Scheduled Configuration Tasks

Note The pre-download option is displayed only when all selected controllers are using the version 7.0.x.x or later.

Note To see Image Predownload status per AP, enable the task in the Administration > Background Task > AP Image Predownload Task page, and run an AP Image Predownload report from the Report Launch Pad.

- Reboot Type—Indicates whether the reboot type is manual, automatic, or scheduled.

  Note Reboot Type Automatic can be set only when the Download software to controller option is selected.

- Download date/time—Enter a date in the provided text box or click the calendar icon to open a calendar from which you can choose a date. Select the time from the hours and minutes drop-down lists.

- Reboot date/time—This option appears only if select the reboot type “Scheduled”. Enter a date in the provided text box or click the calendar icon to open a calendar from which you can choose a date to reboot the controller. Select the time from the hours and minutes drop-down lists.

  Note Schedule enough time (at least 30mins) between Download and Reboot so that all APs can complete the software pre-download.

  Note If any one of the AP is in pre-download progress state at the time of scheduled reboot, the controller will not reboot. In such a case, wait for the pre-download to finish for all the APs and reboot the controller manually.

- Notification (Optional)—Enter the e-mail address of recipient to send notifications via e-mail.

  Note To receive email notifications, configure the WCS mail server in the Administration > Settings > Mail Server Configuration page.

- Image Details—Specify the TFTP or FTP Server Information:

  Note Complete these details if you selected the Download software to controller option under Schedule Details.

  TFTP—Specify the TFTP Server Information:

  - From the File is Located on drop-down list, choose Local machine or TFTP server.

    Note If you choose TFTP server, select the Default Server or add a New server using the Server Name drop-down list.
Specifying IP addresses:

- Specify the IP address of the TFTP server. This is automatically populated if the default server is selected.
- Specify the local file name or click Browse to navigate to the appropriate file.
- If you selected TFTP server previously, specify the File Name.

FTP—Specify the FTP Server Information:

- FTP Credentials Information—Enter the FTP username, password, and port if you selected the FTP radio button.
- From the File is Located on parameter, choose Local machine or FTP server.

**Note**

If you choose FTP server, select the Default Server or add a New server using the Server Name drop-down list.

- Specify the IP address of the FTP server. This is automatically populated if the default server is selected.
- Specify the local file name or click the Browse button to navigate to the appropriate file.
- If you selected FTP server previously, specify the File Name.

**Step 6** Click Save.

---

**Modifying a Download Software Task**

To modify a download software task, follow these steps:

**Step 1** Choose Configure > Scheduled Configuration Tasks.
**Step 2** From the left sidebar menu, choose Download Software.
**Step 3** Select the Task Name link to open the Download Software Task page.
**Step 4** Make any necessary changes.

**Note**

Any changes in Download Type (Download/Pre-download) or Server Type (FTP/TFTP) for the task in 'Enabled' state will set the task to 'Disabled' state and all the existing controllers will be disassociated from the task.

**Step 5** Click Save.

---

**Selecting Controllers for the Download Software Task**

This page lists all the supported controllers that can be selected for the scheduled image download/pre-download task.

To select a controller for scheduled image download, follow these steps:

**Step 1** Choose Configure > Scheduled Configuration Tasks.
Configuring Scheduled Configuration Tasks

Chapter 9  Configuring Wireless Devices

Viewing Download Software Results

To view the Schedule Run Results report, follow these steps:

Step 1  Choose Configure > Scheduled Configuration Tasks.
Step 2  From the left sidebar menu, choose Download Software.
Step 3  Select the Task Name check box.
Step 4  From the Select a command drop-down list, choose Schedule Run Results.
Step 5  Click Go. The Schedule Run Results page provides the information:

- IP Address—The IP address of the controller to which the software to be downloaded.
- Controller Name—Name of the controller.
- Scheduled Run Time—Scheduled time of the download process.
- Last Updated Time—Last update time of the schedule download status (or result).
- Transfer Status—Current download status of the image in controller. For example, Not Initiated, Wrong file Type, Writing the code into flash, Transfer Successful.
- Reboot Status—Reboot status of the controller. For example, NA (if the reboot type is “Manual”), Reboot failed, Reboot Successful.
- Details—Detailed status about the download and reboot process.

Deleting a Download Software Task

To delete a scheduled download software task, follow these steps:

Step 2  From the left sidebar menu, choose Download Software.
Step 3  Click the Controller to open the Download Software Task details page.
Step 4  In the Download Software Task details page, Click Select Controller to view the controller list.

Note  The Select Controllers page can also be accessed from Configure > Scheduled Configuration Tasks > Download Software > click hyperlink in the Select Controller column for any download task which is in Enabled, Disabled or in Expired state.

Note  If the pre-download option is chosen for the task, then the controllers with software version 7.0.x.x or later only will be listed.

Note  Controllers with Reachability Status 'Unreachable' cannot be selected for Download Software Task.

Step 5  Make any necessary changes.
Step 6  Click Save.
Configuring wIPS Profiles

WCS provides several pre-defined profiles from which to choose. These profiles (based on customer types, building types, industry types, and so on) allow you to quickly activate the additional wireless threat protection available through Cisco Adaptive wIPS. You can use a profile ‘as is’ or customize it to better meet your needs.

Tip
To learn more about Cisco Adaptive wIPS features and functionality, go to Cisco.com to watch a multimedia presentation. Here you will find learning modules for a variety of WCS topics. Over future releases, we will add more overview and technical presentations to enhance your learning.

Pre-defined profiles include:

- Education
- EnterpriseBest
- EnterpriseRogue
- Financial
- HealthCare
- HotSpotOpen
- Hotspot8021x
- Military

Enabling or Disabling a Download Software Task

To enable or disable a download software task, follow these steps:

Step 1  Choose Configure > Scheduled Configuration Tasks.
Step 2  From the left sidebar menu, choose Download Software.
Step 3  Select the check box of the scheduled task to be enabled or disabled.
Step 4  From the Select a command drop-down list, choose Enable Schedule or Disable Schedule, as applicable.
Step 5  Click Go.

Configuring wIPS Profiles

WCS provides several pre-defined profiles from which to choose. These profiles (based on customer types, building types, industry types, and so on) allow you to quickly activate the additional wireless threat protection available through Cisco Adaptive wIPS. You can use a profile ‘as is’ or customize it to better meet your needs.

Tip
To learn more about Cisco Adaptive wIPS features and functionality, go to Cisco.com to watch a multimedia presentation. Here you will find learning modules for a variety of WCS topics. Over future releases, we will add more overview and technical presentations to enhance your learning.

Pre-defined profiles include:

- Education
- EnterpriseBest
- EnterpriseRogue
- Financial
- HealthCare
- HotSpotOpen
- Hotspot8021x
- Military

Enabling or Disabling a Download Software Task

To enable or disable a download software task, follow these steps:

Step 1  Choose Configure > Scheduled Configuration Tasks.
Step 2  From the left sidebar menu, choose Download Software.
Step 3  Select the check box of the applicable scheduled task.
Step 4  From the Select a command drop-down list, choose Delete Download Software Task.
Step 5  Click Go.
Step 6  Click OK to confirm the deletion.
Configuring wIPS Profiles

Chapter 9      Configuring Wireless Devices

• Retail
• Tradeshow
• Warehouse

The wIPS Profiles page provides access to the wIPS profile list and the SSID group list. To access the wIPS Profile page, choose Configure > wIPS Profiles.

The current wIPS profile list and the SSID group list can be accessed from the left sidebar menu.

The wIPS Profiles page defaults to the Profile List. The SSID Group List page is accessible from the left sidebar menu.

Note
Adaptive wIPS does not support the WCS partitioning feature.

Profile List

The wIPS Profiles > Profile List page allows you to view, edit, apply, or delete current wIPS profiles and to add new profiles.

Tip
To learn more about Cisco Adaptive wIPS features and functionality, go to Cisco.com to watch a multimedia presentation. Here you will also find learning modules for a variety of WCS topics. Over future releases, we will add more overview and technical presentations to enhance your learning.

To access the wIPS profile list for WCS, choose Configure > wIPS Profiles. The page defaults to the wIPS Profiles > Profile List. If the Profile List is not currently displayed, choose Profile List from the wIPS Profiles left sidebar menu.

The Profile List provides the following information for each profile:

• Profile Name—Indicates the user-defined name for the current profile. Click the profile name to view or edit profile details.

Note
When you hover your mouse cursor over the profile name, the Profile ID and version display.

• MSE(s) Applied To—Indicates the number of mobility services engines (MSEs) to which this profile is applied. Click the MSE number to view profile assignment details.

• Controller(s) Applied To—Indicates the number of controllers to which this profile is applied. Click the controller number to view profile assignment details.

This section contains the following topics:

• Adding a Profile, page 9-213
• Deleting a Profile, page 9-216
• Applying a Current Profile, page 9-216

The profile editor allows you to create new or modify current profiles. See the “Profile Editor” section on page 9-213 for more information.
Adding a Profile

A new wIPS profile can be created using the default or a pre-configured profile.

Tip
To learn more about Cisco Adaptive wIPS features and functionality, go to Cisco.com to watch a multimedia presentation. Here you will also find learning modules for a variety of WCS topics. Over future releases, we will add more overview and technical presentations to enhance your learning.

To add a wIPS profile, follow these steps:

Step 1 Select Configure > wIPS Profiles. The page defaults to the wIPS Profiles > Profile List.
Step 2 From the Select a command drop-down list, choose Add Profile.
Step 3 Click Go.
Step 4 Type a profile name in the Profile Name text box of the Profile Parameters page.
Step 5 Select the applicable pre-defined profile, or choose Default from the drop-down list. Pre-defined profiles include the following:
- Education
- EnterpriseBest
- EnterpriseRogue
- Financial
- HealthCare
- HotSpotOpen
- Hotspot8021x
- Military
- Retail
- Tradeshow
- Warehouse
Step 6 Select one of the following:
- Save—Saves the profiles to the WCS database with no changes and no mobility services engine or controller assignments. The profile appears in the profile list. Click the profile name to access the “Profile Editor” section on page 9-213 to edit the profile at a later time.
- Save and Edit—Saves the profile and launches the “Profile Editor” section on page 9-213.
- Cancel—Closes the Profile Parameters page without creating a profile.

Profile Editor

Tip
To learn more about Cisco Adaptive wIPS features and functionality, Cisco.com to watch a multimedia presentation. Here you will also find learning modules for a variety of WCS topics. Over future releases, we will add more overview and technical presentations to enhance your learning.
Chapter 9  Configuring Wireless Devices

Configuring wIPS Profiles

The profile editor allows you to configure profile details including the following:

- **SSID groups**—Add, edit, or delete SSID groups.
- **Policy inclusion**—Determine which policies are included in the profile.
- **Policy level settings**—Configure settings for each policy such as threshold, severity, notification type, and ACL/SSID groups.
- **MSE/controller applications**—Select the mobility services engine(s) or controller(s) to which you want to apply the profile.

To configure profile details, follow these steps:

**Step 1**
Access the profile editor. This can be done in two ways:

- When creating a new profile, click **Save and Edit** in the Profile Parameters page.
- Click the profile name from the Profile List page.

**Step 2**
From the SSID Groups page, you can edit and delete current groups or add a new group. For more information on adding, editing, or deleting SSID groups, see the “Configure > wIPS > SSID Group List” section on page 9-217 for more information.

**Step 3**
When SSID groups have been added or edited as needed, select one of the following:

- **Save**—Saves the changes made to the SSID groups.
- **Cancel**—Returns to the profile list with no changes made.
- **Next**—Proceeds to the Profile Configuration page.

**Step 4**
From the Profile Configuration page, you can determine which policies are included in the current profile. The check boxes in the policy tree (located in the left Select Policy pane) indicate which policies are enabled or disabled in the current profile. You can enable or disable an entire branch or an individual policy as needed by selecting the check box for the applicable branch or policy.

**Note**
By default, all policies are selected.

**Note**
For detailed information regarding each of the wIPS policies, see the “wIPS Policy Alarm Encyclopedia” section on page 20-1.

**Step 5**
In the Profile Configuration page, click an individual policy to display the policy description and to view or modify current policy rule settings.

The following options are available for each policy:

- **Add**—Click **Add** to access the Policy Rule Configuration page to create a new rule for this policy.
- **Edit**—Select the check box of the applicable rule, and click **Edit** to access the Policy Rule Configuration page to edit the settings for this rule.
- **Delete**—Select the check box of the rule you want to delete, and click **Delete**. Click **OK** to confirm the deletion.

**Note**
There must be at least one policy rule in place. You cannot delete a policy rule if it is the only one in the list.

- **Move Up**—Select the check box of the rule you want to move up in the list. Click **Move Up**.
Chapter 9 Configuring Wireless Devices

Configuring wIPS Profiles

- Move Down—Select the check box of the rule you want to move down in the list. Click Move Down.
The following settings can be configured at the policy level:
- Threshold (not applicable to all policies)—Indicates the threshold or upper limit associated with the selected policy. When the threshold is reached for a policy, an alarm is triggered.

**Note** Since every policy must contain at least one threshold, default thresholds are defined for each based on standard wireless network issues.

**Note** Threshold options vary based on the selected policy.

**Note** Alarms from Cisco Adaptive wIPS DoS and security penetration attacks are classified as security alarms. A summary of these attacks is located in the Security Summary page. Choose Monitor > Security to access this page. The wIPS attacks are located in the Threats and Attacks section.

- Severity—Indicates the level of severity of the selected policy. Parameters include critical, major, info, and warning. The value of this parameter may vary depending on the wireless network.
- Notification—Indicates the type of notification associated with the threshold.
- ACL/SSID Group—Indicates the ACL or SSID Group(s) to which this threshold is be applied.

**Note** Only selected groups trigger the policy.

**Step 6** When the profile configuration is complete, select one of the following:
- Save—Saves the changes made to the current profile.
- Cancel—Returns to the profile list with no changes made.
- Back—Returns to the SSID Groups page.
- Next—Proceeds to the MSE/Controller(s) page.

**Step 7** In the Apply Profile page, select the check box(es) of the mobility services engine and controller(s) to which you want to apply the current profile.

**Step 8** When the applicable mobility services engine(s) and controller(s) are selected, choose one of the following:
- Apply—Applies the current profile to the selected mobility services engine/controller(s).
- Cancel—Returns to the profile list with no changes made.

**Note** A created profile can also be applied directly from the profile list. From the Profile List page, select the check box of the profile you want to apply and click **Apply Profile** from the Select a command drop-down list. Click **Go** to access the Apply Profile page.
Deleting a Profile

To delete a wIPS profile, follow these steps:

---

**Step 1** Choose **Configure > wIPS Profiles**. The page defaults to the wIPS Profiles > Profile List.

**Step 2** Select the check box of the wIPS profile(s) you want to delete.

**Step 3** From the Select a command drop-down list, choose **Delete Profile**.

**Step 4** Click **Go**.

**Step 5** Click **OK** to confirm the deletion.

---

**Note** If the profile is already applied to a controller, it cannot be deleted.

---

Applying a Current Profile

---

**Tip** To learn more about Cisco Adaptive wIPS features and functionality, [Cisco.com](http://Cisco.com) to watch a multimedia presentation. Here you will also find learning modules for a variety of WCS topics. Over future releases, we will add more overview and technical presentations to enhance your learning.

To apply a wIPS profile, follow these steps:

---

**Step 1** Choose **Configure > wIPS Profiles**. The page defaults to the wIPS Profiles > Profile List.

**Step 2** Select the check box of the wIPS profile(s) you want to apply.

**Step 3** From the Select a command drop-down list, choose **Apply Profile**.

**Step 4** Click **Go**.

**Step 5** Select the mobility services engine(s) and controller(s) to which the profile will be applied.

---

**Note** If the new assignment is different than the current assignment, you are prompted to save the profile with a different name.

**Step 6** When the applicable mobility services engine(s) and controller(s) are selected, choose one of the following:

- **Apply**—Applies the current profile to the selected mobility services engine/controller(s).
- **Cancel**—Returns to the profile list with no changes made.

---
Configure > wIPS > SSID Group List

The SSID (Service Set IDentifier) is a token or key which identifies an 802.11 (Wi-Fi) network. You must know the SSID to join an 802.11 network. SSIDs can be associated with a wIPS profile as a group using the SSID group list feature.

An SSID group can be added to a profile by importing it from the Global SSID Group List page (Configure > wIPS Profiles > SSID Group List) or by adding one directly from the SSID Groups page located in the “Profile Editor” section on page 9-213.

- Global SSID Group List—A global SSID group can be set up separately and added to multiple profiles as needed.
- SSID Groups

Tip
To learn more about Cisco Adaptive wIPS features and functionality, Cisco.com to watch a multimedia presentation. Here you will also find learning modules for a variety of WCS topics. Over future releases, we will add more overview and technical presentations to enhance your learning.

Global SSID Group List

The SSID Group List page allows you to add or configure global SSID groups that you may later import into an applicable wIPS profile.

Tip
To learn more about Cisco Adaptive wIPS features and functionality, Cisco.com to watch a multimedia presentation. Here you will also find learning modules for a variety of WCS topics. Over future releases, we will add more overview and technical presentations to enhance your learning.

To access the SSID Group List page, choose Configure > wIPS Profiles. From the left sidebar menu, choose SSID Group List. The SSID Group List page display current SSID groups and their associated SSIDs.

This section contains the following topics:

- Adding a Group, page 9-217
- Editing a Group, page 9-218
- Deleting Group, page 9-218

Adding a Group

To add an SSID Group, follow these steps:

Step 1 Choose Configure > wIPS Profiles.
Step 2 From the left sidebar menu, choose SSID Group List.
Step 3 From the Select a command drop-down list, choose Add Group.
Step 4 Click Go.
Step 5 In the SSID configuration page, type an SSID group name in the available text box.
Step 6 Enter the SSIDs in the SSID List text box. Separate multiple SSIDs with a space.
Step 7 When finished, select one of the following:
• Save—Saves the SSID group and adds it to the SSID Group List.
• Cancel—Closes the SSID configuration page without saving the new SSID group.

**Note**

To import the SSID groups to a profile, choose **Configure > wIPS Profile**. Click the profile name for the applicable profile to open the SSID Groups page. From the Select a command drop-down list, choose **Add Groups from Global List**. Select the check box(es) for the SSID group(s) you want to import and click **Save**.

---

**Editing a Group**

To edit a current SSID Group, follow these steps:

**Step 1** Choose **Configure > wIPS Profiles**.
**Step 2** From the left sidebar menu, choose **SSID Group List**.
**Step 3** Select the check box of the SSID group that you want to edit.
**Step 4** From the Select a command drop-down list, choose **Edit Group**.
**Step 5** Click **Go**.
**Step 6** In the SSID configuration page, make the necessary changes to the SSID group name or the SSID list.
**Step 7** When finished, select one of the following:
  • Save—Saves the current changes and closes the SSID configuration page.
  • Cancel—Closes the SSID configuration page without saving the changes.

---

**Deleting Group**

To delete a current SSID Group, follow these steps:

**Step 1** Choose **Configure > wIPS Profiles**.
**Step 2** From the left sidebar menu, choose **SSID Group List**.
**Step 3** Select the check box of the SSID group(s) that you want to delete.
**Step 4** From the Select a command drop-down list, choose **Delete Group**.
**Step 5** Click **Go**.
**Step 6** Click **OK** to confirm the deletion.

---

**SSID Groups**

The SSID Groups page is the first page displayed when you access the “Profile Editor” section on page 9-213. This page displays SSID groups that are included for the current wIPS profile. From this page, you can add, import, edit, or delete an SSID group for the current profile.
This section contains the following topics:

- Adding a Group, page 9-219
- Adding Groups from Your Global List, page 9-219
- Editing a Group, page 9-220
- Deleting Group, page 9-220

Adding a Group

To add an SSID Group to the current wIPS profile, follow these steps:

1. Choose Configure > wIPS Profiles.
2. From the left sidebar menu, choose Profile List.
3. Click the profile name of the applicable wIPS profile.
4. From the Select a command drop-down list, choose Add Group.
5. Click Go.
6. In the SSID configuration page, type an SSID group name in the available text box.
7. Enter the SSIDs in the SSID List text box. Separate multiple SSIDs with a comma.
8. When finished, select one of the following:
   - Save—Saves the SSID group and adds it to the SSID Group List.
   - Cancel—Closes the SSID configuration page without saving the new SSID group.

Adding Groups from Your Global List

SSID groups can also be added by importing them from your Global SSID Groups list. See the “Global SSID Group List” section on page 9-217 for more information on creating a global SSID groups list.

To import SSID groups into a profile, follow these steps:

1. Select Configure > wIPS Profile.
2. Click the profile name for the applicable profile to open the SSID Groups page.
3. From the Select a command drop-down list, choose Add Groups from Global List.
4. Select the check box(es) for the SSID group(s) you want to import.
5. Click Save.
Editing a Group

To edit a current SSID Group, follow these steps:

Step 1  Choose Configure > wIPS Profiles.
Step 2  From the left sidebar menu, choose Profile List.
Step 3  Click the profile name of the applicable wIPS profile.
Step 4  Select the check box of the SSID group that you want to edit.
Step 5  From the Select a command drop-down list, choose Edit Group.
Step 6  Click Go.
Step 7  In the SSID configuration page, make the necessary changes to the SSID group name or the SSID list.
Step 8  When finished, select one of the following:
   •  Save—Saves the current changes and closes the SSID configuration page.
   •  Cancel—Closes the SSID configuration page without saving the changes.

Deleting Group

To delete a current SSID Group, follow these steps:

Step 1  Choose Configure > wIPS Profiles.
Step 2  From the left sidebar menu, choose Profile List.
Step 3  Click the profile name of the applicable wIPS profile.
Step 4  Select the check box of the SSID group that you want to delete.
Step 5  From the Select a command drop-down list, choose Delete Group.
Step 6  Click Go.
Step 7  Click OK to confirm the deletion.

Configuring ACS View Servers

To facilitate communication between WCS and the ACS View Server and to access the ACS View Server tab, you must add a view server with credentials.

Note

WCS only supports ACS 5.1 or above. ACS 5.x supports the functionality of ACS View Server. Ensure that you enable the ACS View web interface.

To configure the ACS View Server Credentials, follow these steps:

Step 1  Choose Configure > ACS View Server.
Step 2 Enter the port number of the ACS View Server you are adding. (Some ACS View Servers do not allow you to change the port on which HTTPS runs.)

Step 3 Enter the password that was established on the ACS View Server. Confirm the password.

Step 4 Specify the time in seconds after which the authentication request times out and a retransmission is attempted by the controller.

Step 5 Specify the number of retries that will be attempted.

Step 6 Click Submit.

---

### Configuring ACS View Server Credentials

To facilitate communication between WCS and the ACS View Server and to access the ACS View Server tab, you must add a view server with credentials.

**Note** WCS only supports ACS 5.1 or above. ACS 5.x supports the functionality of the ACS View Server. Ensure that you enable the ACS View web interface.

To configure the ACS View Server Credentials, follow these steps:

**Step 1** Choose Configure > ACS View Server.

**Step 2** Enter the port number of the ACS View Server you are adding. (Some ACS View Servers do not allow you to change the port on which HTTPS runs.)

**Step 3** Enter the password that was established on the ACS View Server. Confirm the password.

**Step 4** Specify the number of retries that will be attempted.

**Step 5** Click Submit.

---

### Configuring TFTP Servers

Use the Configure > TFTP Servers page to add or delete TFTP servers from WCS.

**Note** The WCS uses an integral TFTP server. This means that third-party TFTP servers cannot run on the same workstation as the WCS, because the WCS and the third-party TFTP servers use the same communication port.

This section contains the following topics:

- Adding a TFTP Server, page 9-222
- Deleting TFTP Servers, page 9-222
Adding a TFTP Server

To add a TFTP server, follow these steps:

Step 1 Choose Configure > TFTP Servers.
Step 2 From the Select a command drop-down list, choose Add TFTP Server.
Step 3 Enter a TFTP server name. This is a user-defined name for the server.
Step 4 Enter the IP address of the TFTP server.
Step 5 Click Save.

Deleting TFTP Servers

To delete a TFTP server, select the check box for the applicable server, and choose Delete TFTP Servers from the Select a command drop-down list. Click Go and then click OK to confirm the deletion.

Interactive Graphs

This section contains the following topics:
- Interactive Graphs Overview, page 9-222
- Interactive Graph Features, page 9-222

Interactive Graphs Overview

Interactive graph features are based upon Adobe Flex technology that uses flash to render the graphs on the browser and provide interactivity to the user.

Minimum Requirements include:
- Windows—Flash Player version 9.0.115.0.
- Linux—Flash Player version 9.0.115.0.

Note If you do not have a flash player or your version is not recent enough, an error page prompts you with this information. Click the Get Latest Flash Player link to access Adobe website. From this site, you can download the latest version of the flash player. You only need to download the flash player once. Remember to restart the browser following the download.

WCS Interactive Graphs include line, area, pie, and stacked bar graphs.

Interactive Graph Features

Interactive graph features include the following:
- Two distinct types of graphs:
Interactive Graphs

- Time-based Graphs
- Non-Time based

- Support for automatic refresh—The graphs refresh automatically within a predetermined interval of time.
- Two graph views:
  - Graph (Chart) view (default)
  - Table (Grid) view

**Note** Use the two toggle buttons located at the bottom left side of the graph page to switch between the two graph views. To view the button type, hover your mouse cursor over the applicable button for a tool tip identifying View in Chart or View in Grid. Click **View in Chart** to view the data in a graph. Click **View in Grid** to view the data in a table.

- Enlarged View—Click the button located at the bottom right side of the graph to enlarge the graph in a separate page. The Chart View and Grid View buttons are available in the new page to change the type of graph displayed.

### Time-based Graphs

For graphs that are time-based, there is a link bar at the top of the graph page that displays 6h, 1d, 1w, 2w, 4w, 3m, 6m, 1y, and Custom. When selected, the data for that time frame is retrieved and the corresponding graph is displayed. The time-frame options include the following:

- 6h—Denotes the last six hours of data from the current time. The data is gathered from the current database table.
- 1d—Denotes the last day (24 hours) of data from the current time. The data is gathered from the current database table.
- 1w—Denotes the last week (seven days) of data from the current time. The data is gathered from the hourly aggregated table.
- 2w—Denotes the last two weeks of data from the current time. The data is gathered from the hourly aggregated table.
- 4w—Denotes the last four weeks of data from the current time. The data is gathered from the hourly aggregated table.
- 3m—Denotes the last three months of data from the current time. The data is gathered from the daily aggregated table.
- 6m—Denotes the last six months of data from the current time. The data is gathered from the weekly aggregated table.
- 1y—Denotes the past year (12 months) of data from the current time. The data is gathered from the weekly aggregated table.
- Custom—User-selected time period. Both days and hours can be set for the start and end dates. The use of a current or hourly, daily, or weekly aggregated source for data depends upon the selected start date.
Note

The data management settings for aggregated tables are located in the “Data Management Tasks (Settings)” section on page 16-3 under the Administration menu. The default settings have a value of 31 days for Daily Aggregated Data and ten weeks for Weekly Aggregated Data.

For more information on Interactive Graphs, see the “Interactive Graphs” section on page 9-222.
Managing Clients

You can look at the client’s association history and statistical information in several ways on the Cisco WCS GUI. With WCS 7.0, you can view client session related information and determine client presence, usage patterns, and historical session data. You can also use these tools to analyze and troubleshoot client issues. The information can be used in addition to maps to assess which areas experience inconsistent coverage and which areas have the potential to drop coverage.

This chapter contains the following sections:

- Client Tab, page 10-2
- Monitoring Clients, page 10-8
- Enabling Automatic Client Troubleshooting, page 10-21
- Viewing Client Details in the Access Point Page, page 10-21
- Running Client Reports, page 10-21
- Client Troubleshooting, page 10-21
- Receiving Radio Measurements for a Client, page 10-32
- Viewing Client V5 Statistics, page 10-33
- Viewing Client Operational Parameters, page 10-34
- Viewing Client Profiles, page 10-36
-Disabling a Current Client, page 10-36
- Removing a Current Client, page 10-37
- Enabling Mirror Mode, page 10-37
- Viewing a Map (High Resolution) of a Client Recent Location, page 10-37
- Viewing a Map (High Resolution) of a Client Current Location, page 10-38
- Viewing a Client Sessions Report for the Client, page 10-38
- Viewing a Roam Reason Report for the Client, page 10-38
- Viewing Detecting Access Point Details, page 10-39
- Viewing Client Location History, page 10-39
- Viewing Voice Metrics for a Client, page 10-39
Client Tab

Use the Client tab (see Figure 10-1) on the WCS home page as the main client health monitor. Unlike the historical data retrieved from the device periodically and stored in the WCS Client Detail page, this trend data can be collected whenever you chose to refresh the dashboard with the current network status. It can be customized and acts as a main client health monitor where you can get overall client information. You can see how many client devices are connected to your network as well as where and how these devices have accessed your network. You can also see which clients are authenticated or excluded.

Note When you click the Client tab from the WCS home page, it takes longer than average to load the data.

Click the Edit Content link to choose the panes you want to have appear on the Client tab. You can choose the pane from the Available Components list and then click to add it to the left or right column. For more information on using the Edit Content link, see the “Editing Content” section on page 2-26. For example, if you wanted to see the client count in both the General and Client dashboards, you could add the same pane to both.

To return to the original client tab before customization, click Edit Tabs and click Reset to Factory Default.
Client Distribution

This pane (see Figure 10-2) shows how many clients are on your network presently. You can see how clients are distributed by protocol, EAP type, and authentication type.

- Protocol—Represents radio bands such as 802.11a/n, 802.11b/g/n, and so on
- EAP-Type—Represents Extensible Authentication Protocol (EAP) types such as EAP-FAST, PEAP, and so on
- Authentication Type—Represents types such as WPA (TKIP), WPA2 (AES), open, and so on

You can choose to display this information in table form or in a pie chart. The pie charts are clickable. If you hover your mouse cursor over a particular portion of the pie chart, a heading and percentage appears, and you can then click the pie chart piece to open a filtered list. When you click the number represented by Client Distribution, you get a list of clients represented by this number (the same page that you see when you choose Monitor > Clients). You can filter the data that is displayed in client distribution by clicking the Component Options icon and choosing either controller IP, SSID, or floor area.

![Client Distribution](image)

**Note**  The asterisk next to the Client Distribution count indicates that the component has been customized. If you reset to the default page, the asterisk is cleared.

Client Protocol Distribution

This pane (see Figure 10-3) shows the current client count distribution by protocols. It shows the subtotal of each radio band (802.11a/n and 802.11b/g/n) distribution and the total client count. You can choose to display this information in table form or in a pie chart. When you click the number represented by Total Clients, you get a list of clients represented by this number (the same page that you see when you choose Monitor > Clients). You can filter the data that is displayed in client count by clicking the Component Options icon and choosing either controller IP, SSID, or floor area.
Client Count

This pane (see Figure 10-4) shows the trend of associated and authenticated client counts in a given period of time. You can choose to display the information in table form or in a pie chart. It shows the minimum, average, and maximum number of clients. You can filter the data that is displayed in client count by clicking the Component Options icon and choosing either controller IP, SSID, or floor area.

If you click View History, the Client Count Historical Charts pane appears for the various time frames (see Figure 10-5). The Client Count Historical Charts pane shows the client count over the last hour, last 6 hours, last day, last week, last month, and last year. The blue line shows the authenticated client count and the orange line shows the associated client count. The upper right-hand corner shows when the chart was last updated.
Client Tab

Figure 10-5   View History

This pane (see Figure 10-6) shows the five most recent client alarms providing the following data:

- Client Association Failure
- Client Authentication Failure
- Client WEP Key Decryption Error
- Client WPA MIC Error Counter Activated
- Client Excluded

Click the number in the Total column to open the Events page (the same page that you see when you choose Monitor > Events).
Client Traffic

Controllers keep counters for the number of bytes transferred and received for each client. WCS reads the number every 15 minutes and then calculates the difference, comparing the prior polling. This client traffic data is then aggregated every hour, every day, and every week (see Figure 10-7). It shows the average and maximum values in megabytes per second for both downstream and upstream traffic. You can display the information in table form or in a pie chart. When generating the chart based on the floor, WCS adds up all client traffic on this floor. You can filter the data that is displayed in client traffic by clicking the Component Options icon and choosing either controller IP, SSID, or floor area.

If you click View History, the Client Traffic Historical Charts pane appears for the various time frames (see Figure 10-5). The Client Traffic Historical Charts pane shows the client traffic over the last 6 hours, last day, last week, last month, and last year. The blue line shows the authenticated client count and the orange line shows the associated client count. The upper right-hand corner shows when the chart was last updated.
**Client Authentication Type Distribution**

This pane (see Figure 10-8) shows the number of clients for each authentication type. You can choose to display this information in table form or in a pie chart. When you click the number represented by Total Clients, you get a list of clients represented by this number (the same page that you see when you choose Monitor > Clients). You can filter the data that is displayed in client authentication type distribution by clicking the Component Options icon and choosing either controller IP, SSID, or floor area.

*Note* Only the current authentication types are shown. Obsolete types are not displayed.

![Figure 10-8 Client Authentication Type Distribution](image)

**AP Join Taken Time**

This pane (see Figure 10-9) shows how long it took each access point to join the controller. You can restrict the number of access points to display by clicking the Component Options icon and choosing the items per page.

![Figure 10-9 AP Join Taken Time](image)

**AP Threats/Attacks**

This pane (see Figure 10-10) shows the type and number of attacks and threats that have occurred in the last hour, last 24 hours, and the total active.
Monitoring Clients

The Monitor Client information assists in identifying, diagnosing, and resolving client issues.

Using the Monitor Clients feature, you can view a client association history and statistical information. You can also troubleshoot client historical issues. These tools are useful when users complain of network performance as they move throughout a building with their laptops. The information may help you assess what areas experience inconsistent coverage and which areas have the potential to drop coverage.

This section contains the following topics:

- Client Detail Page, page 10-10
- Configuring the Search Results Display, page 10-11
- Configuring the Search Results Display, page 10-11
- Filtering the Client Summary, page 10-11
- Client Association History, page 10-18
- Client Statistics, page 10-18
- Client Event Information, page 10-19
- Client Location Information, page 10-19
- Client CCXv5 Information, page 10-19

Monitoring Clients Summary

Choose Monitor > Clients to view access point client information.

You can use the advanced search feature to narrow the client list based on specific categories and filters. See the “Using the Search Feature” section on page 2-34 or the “Advanced Search” section on page 2-35 for more information.

You can also filter the current list using the Show drop-down list. See the “Filtering the Client Summary” section on page 10-11 for more information.

The following default information is displayed on the Monitor > Clients page:
Client Username—User-defined client username, or <none>. Click a username to view client details. See the "Client Detail Page" section on page 10-10 for more information.

Client IP Address—Client access point address, or 0.0.0.0 if unknown.

Client MAC Address—Click the icon to the right of the client MAC address to launch the Client Troubleshooting page. See the "Client Troubleshooting" section on page 10-21 for more information.

Vendor Name—Client manufacturer.

AP Name—Current or most recent access point to which this client was associated. Click the access point name to view access point details.

Controller Name—Click to view the Controller > Summary page.

Map Location—Campus, building, and floor location.

SSID—Current WLAN SSID or WLAN SSID where previously seen.

Profile Name—Indicates the name of the profile to which the client is associated.

VLAN—Indicates the access VLAN ID for this client.

Protocol—802.11a, 802.11b/g, or 802.11n.

Note: If an 802.11n client associates to an 802.11a radio that has 802.11n enabled, then the client type shows as 802.11n(5GHz). If the 802.11n client associates to an 802.11b/g radio with 802.11n enabled, then the client type shows as 802.11n(2.4GHz).

EAP Type—Type of Extensible Authentication Protocol (EAP) used. For example, TLS, TTLS, LEAP, EAP-FAST, or PEAP.

Association
- Idle—Normal operation; no rejections of client association requests.
- AAAPending—Completing an AAA transaction.
- Authenticated—802.11 authentication complete.
- Associated—802.11 association complete.
- Power Save—Client is in power save mode.
- Disassociated—802.11 disassociation complete.
- To Be Deleted—The client will deleted after disassociation.
- Probing—Client is not currently associated or authorized.
- Blacklisted—Automatically disabled by system due to perceived security threat.

Association Time—Date and time the client began association.

Session Length—Amount of time of the association.

Authentication Type—Which 802.11 authentication algorithm is in use.

Traffic (MB)—The amount of inbound and outbound client traffic in MB.

Avg. Session Throughput (kbps)—The average statistics of throughput across a session.

Link Test—Click this option to have WCS test the link from the AP to the client.

Automated Test Ran—The Automated Test Ran column is populated with Yes if the test is ran for this client. Otherwise, the column has the value No.
Client Detail Page

This section describes how to view client properties, client association history, client statistics, client session information, and so on. The Client Detail page shows the association history graph to represent the time-based data. The information will help you identify, diagnose, and resolve client issues.

To open the Client Detail page, follow these steps:

**Note**
To view complete details in the Monitor > Client details page and to perform operations such as Radio Measurement, users in User Defined groups need permission for Monitor Clients, View Alerts & Events, Configure Controllers, and Client Location.

**Step 1**
Choose Monitor > Clients.

**Step 2**
Choose a hyperlink from the Client Username column to view client details. The Monitor > Client > Client Details page appears (see Figure 10-11). This data is displayed in both table and chart form.

The Client Details page includes the following information:

- **Client Identity and Device Information**—Username, Client MAC address, Client IP address, Client host name, Vendor, H-REAP Local Authentication, CCX Version, and power save.
- **Association Information**—Protocol, SSID, Profile, VLAN ID, Interface, Associated AP name, Associated AP MAC address, Associated AP IP address, Associated controller name, Associated controller IP, First seen time, Last seen time, and Current associated status.
- **Security Information**—Security policy, 802.11 authentication, Cipher, and EAP type.
- **Statistic Information**—RF quality, SNR, RSSI, Throughput, Data rate, Bytes sent and received, Packets sent and received, and retries.
- **Historical Charts**—Client association chart and RF quality, SNR and RSSI, Bytes sent and received, Packets sent and received.
- **Events**—Client association failure, Client authentication failure, Client WEP key decryption error, client WPA MIC error counter activated, Client decrypt error occurred, Client excluded, AP disassociated from controller, and AP crash.
- **Client Location**—A small map showing the current client location.
- **CCXv5**—Basic CCXv5 client information if appropriate.
• Client Sessions—The details of the client session stated during the selected time range.

## Configuring the Search Results Display

The Edit View page allows you to add, remove, or reorder columns in the clients table. To edit the available columns in the clients table, follow these steps:

**Step 1** Choose Monitor > Clients.

**Step 2** Click the Edit View link.

**Step 3** To add an additional column to the clients table, click to highlight the column heading in the left column. Click Show to move the heading to the right column. All items in the right column are displayed in the clients table.

**Step 4** To remove a column from the clients table, click to highlight the column heading in the right column. Click Hide to move the heading to the left column. All items in the left column are not displayed in the clients table.

**Step 5** Use the Up/Down buttons to specify the order in which the information appears in the table. Highlight the desired column heading and click Up or Down to move it higher or lower in the current list.

**Step 6** Click Reset to restore the default view.

**Step 7** Click Submit to confirm the changes.

**Note** Additional client parameters include: AP MAC Address, Anchor Controller, Authenticated, CCX, Client Host Name, Controller IP Address, Controller Port, E2E, Encryption Cipher, MSE, RSSI, SNR, and H-REAP Local Authentication.

## Filtering the Client Summary

You can filter the Monitor Clients list page according to client type. From the Monitor > Clients page, use the Show drop-down list to filter the current client list. Choose a client type, then click Go.

Client type filters include:

- 2.4 GHz Clients
- 5 GHz Clients
- All Clients
- Associated Clients
- Authenticated Clients
- Clients Detected by MSE
- Clients Detected in last 24 hours
- Excluded Clients
• H-REAP Locally Authenticated
• New Clients Detected in last 24 hours
• Probing Clients
• Unauthenticated Clients
• Workgroup Bridge (WGB) Clients

**Note**
See the “Monitoring Clients” section on page 10-8 or the “Client Detail Page” section on page 10-10 for more information.

### 2.4 GHz Clients

From the Show drop-down list on the Monitor Clients list page, choose **2.4 GHz Clients**, then click Go. When filtered, the Monitor Clients page displays all 2.4 GHz clients.

### 5 GHz Clients

From the Show drop-down list on the Monitor Clients list page, choose **5 GHz Clients**, then click Go. When filtered, the Monitor Clients page displays all 5 GHz clients.

### All Clients

From the Show drop-down list on the Monitor Clients list page, choose **All Clients**, then click Go. When filtered, the Monitor Clients page displays all clients.

### Associated Clients

From the Show drop-down list on the Monitor Clients list page, choose **Associated Clients**, then click Go. When filtered, the Monitor Clients page displays all associated clients.

### Authenticated Clients

From the Show drop-down list on the Monitor Clients list page, choose **Authenticated Clients**, then click Go. When filtered, the Monitor Clients page displays all authenticated clients.

### Clients Detected by MSE

From the Show drop-down list on the Monitor Clients list page, choose **Clients Detected by MSE**, then click Go. When filtered, the Monitor Clients page displays all clients stored on the mobility services engine that were detected by the mobility services engine through controller polling.

### Clients Detected in last 24 hours

From the Show drop-down list on the Monitor Clients list page, choose **Clients Detected in last 24 hours**, then click Go. When filtered, the Monitor Clients page displays all clients that were detected in the last 24 hours.

### Excluded Clients

From the Show drop-down list on the Monitor Clients list page, choose **Excluded Clients**, then click Go. When filtered, the Monitor Clients page displays all excluded clients.
Chapter 10      Managing Clients

Monitoring Clients

H-REAP Locally Authenticated

From the Show drop-down list on the Monitor Clients list page, choose **H-REAP Locally Authenticated**, then click **Go**. When filtered, the Monitor Clients page displays all locally authenticated clients.

New Clients Detected in last 24 hours

From the Show drop-down list on the Monitor Clients list page, choose **New Clients Detected in last 24 hours**, then click **Go**. When filtered, the Monitor Clients page displays all new clients that were detected in the last 24 hours.

Probing Clients

From the Show drop-down list on the Monitor Clients list page, choose **Probing Clients**, then click **Go**. When filtered, the Monitor Clients page displays all probing clients.

Note

Probing clients are clients that are associated to another controller but whose probing activity causes them to be seen by another controller and counted as an element by the “probed” controller as well as its primary controller.

Unauthenticated Clients

From the Show drop-down list on the Monitor Clients list page, choose **Unauthenticated Clients**, then click **Go**. When filtered, the Monitor Clients page displays all unauthenticated clients.

Workgroup Bridge (WGB) Clients

From the Show drop-down list on the Monitor Clients list page, choose **WGB Clients**, then click **Go**. When filtered, the Monitor Clients page displays all wired clients detected as WGB clients.

A workgroup bridge (WGB) is a mode that can be configured on an autonomous IOS access point to provide wireless connectivity to a lightweight access point on behalf of clients that are connected by Ethernet to the WGB access point. A WGB connects a wired network over a single wireless segment by learning the MAC addresses of its wired clients on the Ethernet interface and reporting them to the lightweight access point using Internet Access Point Protocol (IAPP) messaging. The WGB provides wireless access connectivity to wired clients by establishing a single wireless connection to the lightweight access point. The lightweight access point treats the WGB as a wireless client.

Note

The WCS provides WGB client information for the autonomous access point whether or not it is managed by the WCS. If the WGB access point is also managed by the WCS, WCS provides basic monitoring functions for the access point similar to other autonomous access points.

See the “Guidelines for Using WGBs” section on page 10-13 for more information on work group bridges.

Guidelines for Using WGBs

Follow these guidelines for using WGBs on your network:
The WGB can be any autonomous access point that supports the workgroup bridge mode and is running Cisco IOS Release 12.4(3g)JA or later (on 32-MB access points) or Cisco IOS Release 12.3(8)JEB or later (on 16-MB access points). These access points include the AP1120, AP1121, AP1130, AP1231, AP1240, and AP1310. Cisco IOS Releases prior to 12.4(3g)JA and 12.3(8)JEB are not supported.

Note
If your access point has two radios, you can configure only one for workgroup bridge mode. This radio is used to connect to the lightweight access point. We recommend that you disable the second radio.

The WGB can associate only to lightweight access points.

Only WGBs in client mode (which is the default value) are supported. Those in infrastructure mode are not supported. Perform one of the following to enable client mode on the WGB:

- On the WGB access point GUI, choose Disabled for the Reliable Multicast to WGB parameter.
- On the WGB access point CLI, enter this command: no infrastructure client.

Note
VLANs are not supported for use with WGBs.

These features are supported for use with a WGB:

- Guest N+1 redundancy
- Local EAP
- Open, WEP 40, WEP 128, CKIP, WPA+TKIP, WPA2+AES, LEAP, EAP-FAST, and EAP-TLS authentication modes

These features are not supported for use with a WGB:

- Cisco Centralized Key Management (CCKM)
- Hybrid REAP
- Idle timeout
- Web authentication

Note
If a WGB associates to a web-authentication WLAN, the WGB is added to the exclusion list, and all of the WGB wired clients are deleted.

The WGB supports a maximum of 20 wired clients. If you have more than 20 wired clients, use a bridge or another device.

Wired clients connected to the WGB are not authenticated for security. Instead, the WGB is authenticated against the access point to which it associates. Therefore, we recommend that you physically secure the wired side of the WGB.

With Layer 3 roaming, if you plug a wired client into the WGB network after the WGB has roamed to another controller (for example, to a foreign controller), the wired client's IP address appears only on the anchor controller, not on the foreign controller.
• If a wired client does not send traffic for an extended period of time, the WGB removes the client from its bridge table, even if traffic is continuously being sent to the wired client. As a result, the traffic flow to the wired client fails. To avoid the traffic loss, prevent the wired client from being removed from the bridge table by configuring the aging-out timer on the WGB to a large value using the following Cisco IOS commands on the WGB:

```
configure terminal
bridge bridge-group-number aging-time seconds
exit
end
```

where bridge-group-number is a value between 1 and 255, and seconds is a value between 10 and 1,000,000 seconds. We recommend configuring the seconds parameter to a value greater than the wired client's idle period.

• When you delete a WGB record from the controller, all of the WGB wired clients records are also deleted.

• Wired clients connected to a WGB inherit the WGB QoS and AAA override attributes.

• These features are not supported for wired clients connected to a WGB:
  – MAC filtering
  – Link tests
  – Idle timeout

• To enable the WGB to communicate with the lightweight access point, create a WLAN and make sure that Aironet IE is enabled.

**Client Properties**

The Properties section displays client details and properties of the access point with which the client is associated.

**Note**

At the bottom of the Properties area, click More to view additional client properties. Once clicked, you can click Less to hide these additional properties.

These details include the following:

• Client Identity and Device Information including: Username, client MAC address, client IP address, client host name, vendor, H-REAP Local Authentication information, CCX version (or not supported), and power save status.

• Controller—Client controller. Click to view controller parameters. See the “Monitoring System Summary” section on page 6-4 for more information.

• Port—Controller port to which the client is attached.

• Protocol—802.11a, 802.11b/g, or 802.11n. Click to view On Demand Statistics for the radio. See the “Monitoring On Demand Statistics” section on page 6-41 for more information.

**Note**

If an 802.11n client associates to an 802.11a radio that has 802.11n enabled, then the client type shows as 802.11n(5 GHz). If the 802.11n client associates to an 802.11b/g radio with 802.11n enabled, then the client type shows as 802.11n(2.4 GHz).
- SSID—WLAN Service Set ID.
- Profile Name
- Access point information including:
  - AP Name—Click the AP name to view details regarding the associated access point. See the “Monitoring Access Points Details” section on page 6-34 for more information.
  - AP IP Address—Click the AP IP address to view details regarding the associated access point. See the “Monitoring Access Points Details” section on page 6-34 for more information.
  - AP Type
  - AP Base Radio MAC address
- Interface—The name of the interface to which the client is connected.
- VLAN ID—The client has successfully joined an access point for the given SSID. VLAN ID is the reverse lookup of the interface used by the WLAN on the controller side.
- 802.11 State—802.11 state may be one of the following:
  - Idle (0) -- normal operation: no rejections of client association requests.
  - AAAPending (1) -- completing an aaa transaction.
  - Authenticated (2) -- 802.11 authentication completed.
  - Associated (3) -- 802.11 association completed.
  - Power Save (4) -- client in power save mode.
  - Disassociated (5) -- 802.11 disassociation completed.
  - To Be Deleted (6) -- to be deleted after disassociation.
  - Probing (7) -- client not associated or authorized yet.
  - Blacklisted (8) -- automatically disabled by system due to perceived security threats.
- Security information including:
  - Security Policy—The security policy used by the client.
  - 802.11 Authentication—Which 802.11 authentication algorithm is in force.
  - Encryption Cipher—Encryption settings.
  - EAP Type—Type of Extensible Authentication Protocol (EAP) used.
- Statistical information including:
  - RSSI
  - SNR (dB)—Signal to noise ratio of the client RF session as detected by the access point with which the client is associated.
  - Retries
  - Packets Tx/Rx
  - Bytes Tx/Rx
- Policy Errors
- Uptime (Sec)—Time duration (in seconds) of the association.
- Current TxRateSet
- Data RateSet
Note

Click **More** to view the following parameters.

- Mobility Role—Local, Anchor, Foreign, Export Anchor, Export Foreign.
- Policy Manager State—Internal state of the client WLAN. Client is working properly when the state is RUN.
- Mobility Peer IP Address
- Mirror Mode—Disable or enable.
- E2E—Indicates if E2E is supported.
- Client Type
- AP Mode—The access point operational mode (Local, Monitor, H-REAP, Rogue Detector, Sniffer, or Bridge).
- Association ID—Client access point association identification number.
- NAC State—Network Access Control state (Quarantine, Access, Invalid, or Not Applicable).
- Reason Code—The client reason code may be one of the following:
  - Normal (0)—Normal operation.
  - Unspecified reason (1)—Client associated but no longer authorized.
  - PreviousAuthNotValid (2)—Client associated but not authorized.
  - DeauthenticationLeaving (3)—The access point went offline, deauthenticating the client.
  - DisassociationDueToInactivity (4)—Client session timeout exceeded.
  - DisassociationAPBusy (5)—The access point is busy, performing load balancing, for example.
  - Class2FrameFromNonAuthStation (6)—Client attempted to transfer data before it was authenticated.
  - Class2FrameFromNonAssStation (7)—Client attempted to transfer data before it was associated.
  - DisassociationStnHasLeft (8)—Controller moved the client to another access point using non-aggressive load balancing.
  - StaReqAssociationWithoutAuth (9)—Client not authorized yet, still attempting to associate with an Cisco WLAN Solution WLAN.
  - Missing Reason Code (99)—Client momentarily in an unknown state.
- Authenticated—Yes or No.
- Anchor Address
  - N/A when the client is Local (has not roamed from its original subnet).
  - Anchor IP Address (the IP address of the original controller) when the client is Foreign (has roamed to another controller on a different subnet).
  - Foreign IP Address (the IP address of the original controller) when the client is Anchor (has roamed back to another controller on a different subnet).
Client Association History

The Association History section displays information regarding the last ten association times for the selected client. This information can help in troubleshooting the client.

Client Association History includes the following information:

- Date and time of association
- Duration of association
- Username
- IP address
- Access point and controller name
- Map location
- SSID
- Protocol
- Amount of traffic (MB)
- Hostname
- Roam reason (such as *No longer seen from controller* or *New association detected*)

**Note**

Click the *Edit View* link to add, remove or reorder columns in the Current Associated Clients table. See the “Configuring the Search Results Display” section on page 6-25 for adding a new parameters than can be added through Edit View.

Client Statistics

The Statistics includes the following information for the selected client:

- Client AP Association History
- Client RSSI History (dBm)—History of RSSI (Received Signal Strength Indicator) as detected by the access point with which the client is associated.
- Client SNR History—History of SNR (signal-to-noise ratio of the client RF session) as detected by the access point with which the client is associated
- Bytes Sent and Received (Kbps)—Bytes sent and received with the associated access point.
- Packets Sent and Received (per second)—Packets sent and received with the associated access point.

**Note**

Hover your mouse cursor over points on the graph for additional statistical information.

This information is presented in interactive graphs. See the “Interactive Graphs” section on page 9-222 for more information.
Client Event Information

The Event section of the Client Details page displays all events for this client including the event type as well as the date and time of the event.

Click an event type to view its details. See the “Monitoring Failure Objects” section on page 6-127 for more information.

Client Location Information

The following location parameters display (if available) for the selected client.

- Map
- Asset Information
  - Name
  - Group
  - Category
  - Location Debug

  **Note**  This displays access point RSSI information on the map.

- Location Notifications—Displays the number of location notifications logged against the client.
  - Absence—The location server generates absence events when the location server cannot see the asset in the WLAN for the specified time.
  - Containment—The location server generates containment events when an asset is moved inside or outside of a designated area.
  - Distance—The location server generates movement events when an asset is moved beyond a specified distance from a designated marker you define on a map.
  - All—The total of absence, containment, and distance notifications.

  **Note**  Click the number to view applicable notification details.

Client CCXv5 Information

CCXv5 clients are client devices that support Cisco Compatible Extensions version 5 (CCXv5). Reports specific to CCXv5 clients provide client details that enhance client diagnostics and troubleshooting.

**Note**  The CCXv5 manufacturing information is displayed for CCXv5 clients only.

To view specific client details, perform a client search using the applicable search parameters. For more information on performing a client search, see the “Monitoring Clients” section on page 10-8 or the “Advanced Search” section on page 2-35.

CCXv5 information displays in the Monitor Clients > Client Details page. CCXv5 information includes the following:
CCXv5 Manufacturing Information:
- **Organizationally Unique Identifier**—The IEEE assigned organizational unique identifier, for example the first 3 bytes of the MAC address of the wireless network connected device.
- **ID**—The manufacturer identifier of the wireless network adapter.
- **Model**—Model of the wireless network adapter.
- **Serial Number**—Serial number of the wireless network adapter.
- **Radio**—Radio type of the client.
- **MAC Address**—MAC address assigned to the client.
- **Antenna Type**—Type of antenna connected to the wireless network adapter.
- **Antenna Gain**—The peak gain of the dBi of the antenna for directional antennas and the average gain in dBi for omni-directional antennas connected to the wireless network adapter. The gain is in multiples of 0.5 dBm. An integer value 4 means $4 \times 0.5 = 2$ dBm of gain.

**Note**  
Click **More** to view the following additional CCXv5 parameters.

Automated Troubleshooting Report—If the automated test runs, this pane displays the location of automated troubleshooting log AUTO_TS_LOG<ClientMac>.txt. If no automated test runs, **Not Exists** appears.
- **Click Export** to save the .zip file. The file contains three logs: automated troubleshoot report, frame log, and watch list log.

**Note**  
The Settings > Client page allows you to enable automatic client troubleshooting on a diagnostic channel. This feature is only available for Cisco Compatible Extension clients version 5. See the “Processing Diagnostic Trap” section on page 16-65 for more information.

Radio Receiver Sensitivity—Displays receiver sensitivity of the wireless network adapter including:
- **Radio**
- **Data Rate**
- **Minimum and Maximum RSSI**

CCXV5 Capability Information—Displays the Capability Information parameters for CCXv5 clients only.
- **Radio**
- **Client Status**—Success or failure.
- **Service Capability**—Service capabilities such as voice, streaming (uni-directional) video, interactive (bi-directional) video.

Radio Channels—Identifies the channels for each applicable radio.

Transmit Data Rates—Identifies the transmission data rates (Mbps) for each radio.

Transmit Power Values—Identifies the transmission power values including:
- **Power mode**
- **Radio**
- **Power (dBm)**
Enabling Automatic Client Troubleshooting

In the Settings > Client page, you can enable automatic client troubleshooting on a diagnostic channel. This feature is available only for Cisco Compatible Extension clients version 5.

To enable automatic client troubleshooting, follow these steps:

Step 1  Choose Administration > Settings.
Step 2  From the left sidebar menu, choose Client.
Step 3  Select the Automatically troubleshoot client on diagnostic channel check box.

Note When the check box is selected, WCS processes the diagnostic association trap. When it is not selected, WCS raises the trap, but automated troubleshooting is not initiated.

Step 4  Click Save.

Viewing Client Details in the Access Point Page

You can also view the client information from the access point page. Choose Monitor > Access Points. Click an access point URL from the column to see details about that access point. Click the Current Associated Clients tab.

Running Client Reports

You can run client reports such as busiest clients, client count, client sessions, client summary, throughput, unique clients and v5 clients statistics from the Report Launch pad. See the “Creating and Running a New Report” section on page 15-3.

Client Troubleshooting

You can begin troubleshooting several ways: by entering a MAC address in the Client tab dashboard, by using the search function, or by clicking the Troubleshooting icon within the Client MAC Address column in the Monitor > Clients page. Any method provides all the information necessary to troubleshoot historical client issues. You can monitor the status of the connection, verify the user’s current and past locations, and troubleshoot client connectivity problems. You may want to use the client troubleshooting option if a user experiences repeated connectivity issues. The Client Details page shows SNR over time, RSSI over time, client reassociations, client reauthentications, and any RRM events. An administrator can correlate reassociations and reauthentications and determine if the problem was with the network or client.
Troubleshooting from the Client Tab Dashboard

If you enter a client MAC address and click **Troubleshoot** (see Figure 10-12), the same Client Details page as shown in Figure 10-1 appears.

*Figure 10-12  Client Tab Troubleshooting*

If the client is not currently associated, most of the information will not appear.

Troubleshooting Using the Search Feature

Client search is the primary method for you to locate clients. For a detailed description of the search feature, refer to the “Using the Search Feature” section on page 2-34.

To troubleshoot a client using the search feature, follow these steps:

**Step 1** Choose **Monitor > Clients**.

**Step 2** In the Quick Search area, type the MAC address of the client, and click **Search**. The Search Results page appears (see Figure 10-13).
Chapter 10  Managing Clients

Client Troubleshooting

Figure 10-13  Search Results Page

Step 3  Click View List to see the clients that matched the search criteria in the Clients page. The Monitor > Clients page appears (see Figure 10-14).

Figure 10-14  Clients Page

The Monitor > Clients Page displays the following information (see Table 10-1).

Table 10-1  Clients Page Information

<table>
<thead>
<tr>
<th>Table Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client Username</td>
<td>The username of the client used for authentication. Clicking the client username displays detailed information about the client such as client properties, association history, and client status and performance statistics.</td>
</tr>
<tr>
<td>Client IP Address</td>
<td>The IP address of the client.</td>
</tr>
<tr>
<td>Client MAC Address</td>
<td>The MAC address of the client.</td>
</tr>
</tbody>
</table>
### Table 10-1 Clients Page Information (continued)

<table>
<thead>
<tr>
<th>Table Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vendor Name</td>
<td>The client’s vendor information.</td>
</tr>
<tr>
<td>AP Name</td>
<td>The name of the access point to which the client is associated. Clicking the AP name displays information in the Monitor &gt; Access Points page.</td>
</tr>
<tr>
<td>Controller Name</td>
<td>The IP address of the controller to which the client is registered. Clicking the controller name displays information in the Monitor &gt; Controllers &gt; System &gt; Summary page.</td>
</tr>
<tr>
<td>Map Location</td>
<td>The physical location of the client (such as building, floor, and so on). Clicking the map location displays information in the Monitor &gt; Maps page.</td>
</tr>
<tr>
<td>SSID</td>
<td>The SSID assigned to this WLAN. The access points broadcast the SSID on this WLAN. Different WLANs can use the same SSID as long as the Layer 2 security has a different value.</td>
</tr>
<tr>
<td>Profile Name</td>
<td>The profile name of the WLAN that the client is associated to or is trying to associate to.</td>
</tr>
<tr>
<td>VLAN</td>
<td>The client has successfully joined an access point for the given SSID. VLAN is the reverse lookup of the interface used by the WLAN on the controller side.</td>
</tr>
<tr>
<td>Protocol</td>
<td>Indicates whether the 802.11a/n or 802.11b/g/n protocol is being used.</td>
</tr>
<tr>
<td>Association</td>
<td>The state of the client. May be one of the following:</td>
</tr>
<tr>
<td></td>
<td>- Idle—completing an AAA transaction</td>
</tr>
<tr>
<td></td>
<td>- AAA Pending—completing an AAA transaction</td>
</tr>
<tr>
<td></td>
<td>- Authenticated—802.11 authentication completed</td>
</tr>
<tr>
<td></td>
<td>- Associated—802.11 association completed</td>
</tr>
<tr>
<td></td>
<td>- Power Save—client in power save mode</td>
</tr>
<tr>
<td></td>
<td>- Disassociated—802.11 disassociation completed</td>
</tr>
<tr>
<td></td>
<td>- To Be Deleted—to be deleted after disassociation</td>
</tr>
<tr>
<td></td>
<td>- Probing—client not associated or authorized yet</td>
</tr>
<tr>
<td>Association Time</td>
<td>The date and time that the status of the client last changed.</td>
</tr>
<tr>
<td>Session Length</td>
<td>The length of time the client has been in the current state.</td>
</tr>
<tr>
<td>Authentication Type</td>
<td>The 802.11 authentication algorithm that is in use.</td>
</tr>
<tr>
<td>Traffic (MB)</td>
<td>The amount of client traffic (in MBs) for both inbound and outbound.</td>
</tr>
<tr>
<td>Avg Session Throughput (kbps)</td>
<td>The throughput averages across a session.</td>
</tr>
<tr>
<td>Automated Test Ran</td>
<td>Indicates whether or not an automated test has been run.</td>
</tr>
<tr>
<td>Authenticated</td>
<td>Indicates whether the client has been authenticated.</td>
</tr>
<tr>
<td>CCX</td>
<td>Indicates the Cisco Compatible Extension version, if the client supports it.</td>
</tr>
<tr>
<td>Client Host Name</td>
<td>Specifies the client host name.</td>
</tr>
</tbody>
</table>
Step 4 Click the icon to the right of the Client MAC Address that you want to troubleshoot. The Troubleshooting Client page appears (see Figure 10-15). If you are troubleshooting a Cisco Compatible Extension v5 client, your Troubleshooting Client page has additional tabs like the page referenced in Figure 10-19.

Note If you receive a message that the client does not seem to be connected to any access point, you must reconnect the client and click Refresh.

Table 10-1 Clients Page Information (continued)

<table>
<thead>
<tr>
<th>Table Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controller IP Address</td>
<td>Clicking a controller IP address displays information from the Monitor &gt; Controllers &gt; System &gt; Summary page.</td>
</tr>
<tr>
<td>Port</td>
<td>The port on the controller to which the client is connected.</td>
</tr>
<tr>
<td>E2E</td>
<td>Indicates whether E2E is supported.</td>
</tr>
<tr>
<td>Encryption Cipher</td>
<td>Encryption settings.</td>
</tr>
<tr>
<td>Client IP Address</td>
<td>The IP address of the client.</td>
</tr>
</tbody>
</table>

Figure 10-15 Troubleshooting Client Page

The summary page briefly describes the problem and recommends a course of action.
Note Some Cisco Compatible Extension features do not function properly when you use a web browser other than Mozilla Firefox 3.0 or later or Internet Explorer 7.0 or later on a Windows workstation.

Step 5 To view log messages logged against the client, click the Log Analysis tab (see Figure 10-16).

Step 6 To begin capturing log messages about the client from the controller, click Start. To stop log message capture, click Stop. To clear all log messages, click Clear.

Note Log messages are captured for ten minutes and then stopped automatically. You must click Start to continue.

Step 7 To select log messages to display, click one of the links under Select Log Messages (the number between parentheses indicates the number of messages). The messages appear in the box. The message includes the following information:

- A status message
- The controller time
- A severity level of info or error (errors are displayed in red)
- The controller to which the client is connected
Step 8  To display a summary of the client’s event history, click the **Event History** tab (see Figure 10-17).

*Note*  If an access point that the client is associated to has Media Session Snooping enabled within the WLAN configuration, any Session Initiation Protocol (SIP) errors that are detected appear in the AP Events list.

This page displays client and access point events that occurred within the last 24 hours.
Step 9 If you click the ACS View Server tab, you can interact with the Cisco Access Control (ACS) System View Server (see Figure 10-18). You must have View Server credentials established before you can access this tab. (The tab will show the server list as empty if no view servers are configured.) See the “Configuring ACS View Server Credentials” section on page 9-221 for steps on establishing credentials.

This server provides WCS with aggregated client status information from multiple ACS servers. The client status information allows you to further troubleshoot client issues and determine whether they are related to authentication or authorization. Enter the date and time ranges to retrieve the historical authentication and authorization information, and click Submit. The results of the query are displayed in the Authentication Records portion of the page and is used as a filter for the userid logged into the client.
Step 10  You can click the CleanAir tab to view information about the air quality parameters and the active interferers for the CleanAir enabled access point. This tab provides the following information about the air quality detected by the CleanAir enabled access point.

- **AP Name**—Click to view the access point details. See the “Monitoring Access Points Details” section on page 6-34 for more information.
- **AP MAC Address**
- **Radio**
- **CleanAir Capable**—Indicates if the access point is CleanAir Capable.
- **CleanAir Enabled**—Indicates if CleanAir is enabled on this access point.
- **Admin Status**—Enabled or disabled.
- **Operational Status**—Displays the operational status of the Cisco Radios (Up or Down).
- **Channel**—The channel upon which the Cisco Radio is broadcasting.
- **Extension Channel**—Indicates the secondary channel on which Cisco radio is broadcasting.
- **Channel Width**—Indicates the channel bandwidth for this radio interface. See the “Configuring 802.11a/n RRM Dynamic Channel Allocation” section on page 9-121 for more information on configuring channel bandwidth.
- **Power Level**—Access Point transmit power level: 1 = Maximum power allowed per Country Code setting, 2 = 50% power, 3 = 25% power, 4 = 6.25 to 12.5% power, and 5 = 0.195 to 6.25% power.
The power levels and available channels are defined by the Country Code setting, and are regulated on a country by country basis.

- Average AQ Index—Average air quality index.
- Minimum AQ Index—Minimum air quality index.

The following information about the active interferers is displayed:

- Interferer Name—The name of the interfering device.
- Affected Channels—The channel the interfering device is affecting.
- Detected Time—The time at which the interference was detected.
- Severity—The severity index of the interfering device.
- Duty Cycle(%)—The duty cycle (in percentage) of the interfering device.
- RSSI(dBm)—The Received Signal Strength Indicator of the interfering device.

Click **CleanAir Details** to know more about the air quality index.

**Step 11** (Optional) If Cisco Compatible Extension Version 5 clients are available, you can click a Test Analysis tab as shown in Figure 10-19.

**Figure 10-19   Test Analysis Tab**

The Test Analysis tab allows you to run a variety of diagnostic tests on the client. Select the check box for the applicable diagnostic test, enter any appropriate input information, and click **Start**. The following diagnostic tests are available:

- DHCP—Executes a complete DHCP Discover/Offer/Request/ACK exchange to determine that the DHCP is operating properly between the controller and the client.
- IP Connectivity—Causes the client to execute a ping test of the default gateway obtained in the DHCP test to verify that IP connectivity exists on the local subnet.
Client Troubleshooting

- **DNS Ping**—Causes the client to execute a ping test of the DNS server obtained in the DHCP test to verify that IP connectivity exists to the DNS server.
- **DNS Resolution**—Causes the DNS client to attempt to resolve a network name known to be resolvable to verify that name resolution is functioning correctly.
- **802.11 Association**—Directs an association to be completed with a specific access point to verify that the client is able to associate properly with a designated WLAN.
- **802.1X Authentication**—Directs an association and 802.1X authentication to be completed with a specific access point to verify that the client is able to properly complete an 802.1x authentication.
- **Profile Redirect**—At any time, the diagnostic system may direct the client to activate one of the client’s configured WLAN profiles and to continue operation under that profile.

**Note**

To run the profile diagnostic test, the client must be on the diagnostic channel. This test uses the profile number as an input. To indicate a wildcard redirect, enter 0. With this redirect, the client is asked to disassociate from the diagnostic channel and to associate with any profile. You can also enter a valid profile ID. Because the client is on the diagnostic channel when the test is run, only one profile is returned in the profile list. You should use this profile ID in the profile redirect test (when wildcard redirecting is not desired).

**Step 12** (Optional) If Cisco Compatible Extension Version 5 clients are available, a Messaging tab as shown in Figure 10-20 appears. Use this tab to send an instant text message to the user of this client. From the Message Category drop-down list, choose a message, and click **Send**.

**Figure 10-20 Messaging Tab**

**Step 13** Close the Troubleshooting Client page.
Receiving Radio Measurements for a Client

In the client page, you can receive radio measurements only if the client is Cisco Compatible Extensions v2 (or higher) and is in the associated state (with a valid IP address). If the client is busy when asked to do the measurement, it determines whether to honor the measurement or not. If it declines to make the measurement, it shows no data from the client.

To receive radio measurements, follow these steps:

**Step 1** Choose **Monitor > Clients**.

**Step 2** Choose a client from the Client Username column.

*Note* You can also perform a search for a specific client using the WCS Search feature. See the “Using the Search Feature” section on page 2-34 or the “Advanced Search” section on page 2-35 for more information.

**Step 3** From the Select a command drop-down list, choose **Radio Measurement**.

*Note* The Radio Measurement option only appears if the client is Cisco Compatible Extensions v2 (or higher) and is in the associated state (with a valid IP address).

**Step 4** Select the check box to indicate if you want to specify beacon measurement, frame measurement, channel load, or noise histogram.

**Step 5** Click **Initiate**. The different measurements produce differing results. See the “Radio Measurement Results for a Client” section on page 10-32 for more information.

*Note* The measurements take about 5 msec to perform. A message from WCS indicates the progress. If the client chooses not to perform the measurement, that will also be communicated.

Radio Measurement Results for a Client

Depending on the measurement type requested, the following information may appear:

- **Beacon Response**
  - Channel—The channel number for this measurement
  - BSSID—6-byte BSSID of the station that sent the beacon or probe response
  - PHY—Physical Medium Type (FH, DSS, OFDM, high rate DSS or ERP)
  - Received Signal Power—The strength of the beacon or probe response frame in dBm
  - Parent TSF—The lower 4 bytes of serving access point TSF value
  - Target TSF—The 8-byte TSF value contained in the beacon or probe response
  - Beacon Interval—The 2-byte beacon interval in the received beacon or probe response
  - Capability information—As present in the beacon or probe response
Viewing Client V5 Statistics

To access the Statistics request page, follow these steps:

**Step 1** Choose Monitor > Clients.

**Step 2** Choose a client from the Client Username column.

**Step 3** From the Select a command drop-down list, choose V5 Statistics.

**Note** This menu will be shown only for CCX v5 and later clients.

**Step 4** Click Go.

**Step 5** Select the desired type of stats (Dot11 Measurement or Security Measurement).

**Step 6** Click Initiate to initiate the measurements.

**Note** The duration of measurement is five seconds.

**Step 7** Depending on the V5 Statistics request type, the following counters are displayed in the results page:

- **Dot11 Measurement**
  - Transmitted Fragment Count
  - Multicast Transmitted Frame Count
  - Failed Count
  - Retry Count
  - Multiple Retry Count
  - Frame Duplicate Count
  - Rts Success Count
Viewing Client Operational Parameters

To view specific client operational parameters, follow these steps:

**Step 1** Choose Monitor > Clients.

**Step 2** Choose a client from the Client Username column.

**Step 3** From the Select a command drop-down list, choose Operational Parameters.

**Step 4** Click Go.

The following information is displayed:

Operational Parameters:

- Device Name—User-defined name for device.
- Client Type—Client type can be any of the following:
  - laptop(0)
- pc(1)
- pda(2)
- dot11mobilephone(3)
- dualmodephone(4)
- wgb(5)
- scanner(6)
- tabletpc(7)
- printer(8)
- projector(9)
- videoconfsystem(10)
- camera(11)
- gamingsystem(12)
- dot11deskphone(13)
- cashregister(14)
- radiotag(15)
- rfidsensor(16)
- server(17)

- Transmit Power Mode—Power mode of the client.
- Data Rate—Data rates that the client will use for transmissions.
- SSID—SSID being used by the client.
- IP Address—IP address assigned to the client.
- Subnet Mask—The mask for the IP address assigned to the client.
- Default Gateway—The default gateway chosen for the client.
- Operating System—Identifies the operating system that is using the wireless network adaptor.
- Operating System Version—Identifies the version of the operating system that is using the wireless
  network adaptor.
- WNA Firmware Version—Version of the firmware currently installed on the client.
- Enterprise Phone Number—Enterprise phone number for the client.
- Cell Phone Number—Cell phone number for the client.
- Power Save Mode—Will display any of the following power save modes: awake, normal, or
  maxPower.

Radio Information:
- Radio Type—The following radio types are available:
  - unused(0)
  - fhss(1)
  - dsss(2)
  - irbaseband(3)
  - ofdm(4)
Viewing Client Profiles

To view specific client profile information, follow these steps:

Step 1 Choose Monitor > Clients.
Step 2 Choose a client from the Client Username column.
Step 3 From the Select a command drop-down list, choose Profiles.
Step 4 Click Go.

The following information is displayed:

- Profile Name—List of profile names as hyperlinks. Click to display the profile details.
- SSID—SSID of the WLAN to which the client is associated.

Disabling a Current Client

To disable a current client, follow these steps:

Step 1 Choose Monitor > Clients.
Step 2 Choose a client from the Client Username column.
Step 3 From the Select a command drop-down list, choose Disable.
Step 4 Click Go.
Step 5 Enter a description in the Description text box.
Removing a Current Client

To remove a current client, follow these steps:

1. Choose Monitor > Clients.
2. Choose a client from the Client Username column.
3. From the Select a command drop-down list, choose Remove.
4. Click Go.
5. Click OK to confirm the deletion.

Enabling Mirror Mode

When enabled, mirror mode enables you to duplicate (to another port) all of the traffic originating from or terminating at a single client device or access point.

Note: Mirror mode is useful in diagnosing specific network problems but should only be enabled on an unused port as any connections to this port become unresponsive.

To enable mirror mode, follow these steps:

1. Choose Monitor > Clients.
2. Choose a client from the Client Username column.
3. From the Select a command drop-down list, choose Enable Mirror Mode.
4. Click Go.

Viewing a Map (High Resolution) of a Client Recent Location

To display a high-resolution map of the client recent location, follow these steps:

1. Choose Monitor > Clients.
2. Choose a client from the Client Username column.
3. From the Select a command drop-down list, choose Recent Map (High Resolution).
Step 4 Click Go.

Viewing a Map (High Resolution) of a Client Current Location

To display a high-resolution map of the client present location, follow these steps:

Step 1 Choose Monitor > Clients.
Step 2 Choose a client from the Client Username column.
Step 3 From the Select a command drop-down list, choose Present Map (High Resolution).
Step 4 Click Go.

Viewing a Client Sessions Report for the Client

To view the most recent client session report results for this client, follow these steps:

Step 1 Choose Monitor > Clients.
Step 2 Choose a client from the Client Username column.
Step 3 From the Select a command drop-down list, choose Client Sessions Report.
Step 4 Click Go. The Client Session report details display. See the “Client Sessions” section on page 15-29 for more information.

Viewing a Roam Reason Report for the Client

To view the most recent roam report for this client, follow these steps:

Step 1 Choose Monitor > Clients.
Step 2 Choose a client from the Client Username column.
Step 3 From the Select a command drop-down list, choose Roam Reason.
Step 4 Click Go.

This page displays the most recent roam report for the client. Each roam report has the following information:

- New AP MAC address
- Old (previous) AP MAC address
- Previous AP SSID
- Previous AP channel
Viewing Client Location History

To display the history of the client location based on RF fingerprinting, follow these steps:

Step 1 Choose Monitor > Clients.
Step 2 Choose a client from the Client Username column.
Step 3 From the Select a command drop-down list, choose Location History.
Step 4 Click Go.

Viewing Voice Metrics for a Client

To view traffic stream metrics for this client, follow these steps:

Step 1 Choose Monitor > Clients.
Step 2 Choose a client from the Client Username column.
Step 3 From the Select a command drop-down list, choose Voice Metrics.
Step 4 Click Go.

The following information appears:

- Time—Time that the statistics were gathered from the access point(s).
- QoS
- AP Ethernet MAC
- Radio

Transition time—Time that it took the client to associate to a new access point.
Roam reason—Reason for the client roam.
• % PLR (Downlink)—Percentage of packets lost on the downlink (access point to client) during the 90 second interval.

• % PLR (Uplink)—Percentage of packets lost on the uplink (client to access point) during the 90 second interval.

• Avg Queuing Delay (ms) (Uplink)—Average queuing delay in milliseconds for the uplink. Average packet queuing delay is the average delay of voice packets traversing the voice queue. Packet queue delay is measured beginning when a packet is queued for transmission and ending when the packet is successfully transmitted. It includes time for re-tries, if needed.

• % Packets > 40 ms Queuing Delay (Downlink)—Percentage of queuing delay packets greater than 40 ms.

• % Packets 20ms—40ms Queuing Delay (Downlink)—Percentage of queuing delay packets greater than 20 ms.

• Roaming Delay—Roaming delay in milliseconds. Roaming delay, which is measured by clients, is measured beginning when the last packet is received from the old access point and ending when the first packet is received from the new access point after a successful roam.
CHAPTER 11

Using Templates

This chapter describes how to add and apply templates. Templates allow you to set parameters that you can then apply to multiple devices without having to re-enter the common information. This chapter contains the following sections:

- Information About Templates, page 11-1
- Accessing Controller Template Launch Pad, page 11-1
- Adding Controller Templates, page 11-2
- Deleting Controller Templates, page 11-2
- Applying Controller Templates, page 11-2
- Configuring Controller Templates, page 11-3
- Configuring AP Configuration Templates, page 11-143
- Configuring Autonomous AP Migration Templates, page 11-153

Information About Templates

The Controller Template Launch Pad is a hub for all controller templates. From this Template Launch Pad you can add and apply controller templates, view templates, or make modifications to existing templates. This chapter also includes steps for applying and deleting controller templates and creating or changing access point templates.

Note
Template information can be overridden on individual devices.

Accessing Controller Template Launch Pad

To access the Controller Template Launch Pad, choose Configure > Controller Template Launch Pad. The controller template launch pad provides access to all WCS templates from a single page. From this page, you can view current controller templates or create and save new templates.

Tip
Hover your mouse cursor over the tool tip next to the template type to view more details regarding the template.
Adding Controller Templates

To add a new controller template, follow these steps:

**Step 1** Choose **Configure > Controller Template Launch Pad**.

**Step 2** Click **New** beside the template you want to add.

**Step 3** Enter the template name.

*Note* Template Name is the unique key used to identify the template. A template name is mandatory to distinguish between two templates that have identical key attributes.

**Step 4** Provide a description of the template.

**Step 5** Click **Save**.

Deleting Controller Templates

To delete a controller template, follow these steps:

**Step 1** Choose **Configure > Controller Template Launch Pad**.

**Step 2** Click the template type to open its template list page.

**Step 3** Select the check box(es) of the template(s) you want to delete.

**Step 4** From the Select a command drop-down list, choose **Delete Templates**.

**Step 5** Click **Go**.

**Step 6** Click **OK** to confirm the deletion. If this template is applied to controllers, the Remove Template Confirmation page opens and lists all controllers to which this template is currently applied.

**Step 7** Select the check box of each controller from which you want to remove the template.

**Step 8** Click **OK** to confirm the deletion or **Cancel** to close this page without deleting the template.

Applying Controller Templates

You can apply a controller template directly to a controller or to controllers in a selected configuration group.

To apply a controller template, follow these steps:

**Step 1** Choose **Configure > Controller Template Launch Pad**.

**Step 2** From the left sidebar menu, choose the category of templates to apply.

**Step 3** Click the template name for the template that you want to apply to the controller.
Step 4  Click **Apply to Controllers** to open the Apply to Controllers page.

Step 5  Choose between applying the template directly to a controller or to all controllers in a selected configuration group.

To apply the template directly to a controller (or controllers), follow these steps:

a. Select the **Apply to controllers selected directly** radio button. The Apply to Controllers page lists the IP address for each available controller along with the controller name and the configuration group name (if applicable).

b. Select the check box for each controller to which you want to apply the template.

**Note**  Select the “Ignore errors on Apply template to Controllers” check box to ignore errors and apply all commands in the template to the controller. If this check box is not selected, any errors encountered while applying a command in the template to a controller causes the rest of the commands to be not applied.

To apply the template to all controllers in a selected configuration group, follow these steps:

a. Select the **Apply to controllers in the selected Config Groups** radio button. The Apply to Controllers page lists the name of each configuration group along with the mobility group name and the number of controllers included.

b. Select the check box for each configuration group to which you want to apply the template.

**Note**  Configuration groups which have no controllers cannot be selected to apply the templates.

Step 6  Click **OK**.

**Note**  You can apply some templates directly from the Template List page. Select the check box(es) of the template(s) that you want to apply, choose **Apply Templates** from the Select a command drop-down list, and click **Go** to open the Apply to Controllers page. Select the check box(es) of the controllers to which you want to apply this template, and click **OK**.

## Configuring Controller Templates

This section contains the following topics:

- Configuring System Templates, page 11-4
- Configuring WLAN Templates, page 11-22
- Configuring H-REAP Templates, page 11-41
- Configuring Security Templates, page 11-44
- Configuring Security - Access Control Templates, page 11-79
- Configuring Security - CPU Access Control List Templates, page 11-87
- Configuring Security - Rogue Templates, page 11-88
- Configuring 802.11 Templates, page 11-96
Configuring System Templates

This section contains the following topics:

- Configuring General Templates, page 11-4
- Configuring SNMP Community Controller Templates, page 11-8
- Configuring an NTP Server Template, page 11-9
- Configuring User Roles Controller Templates, page 11-10
- Configuring AP Username Password Controller Templates, page 11-10
- Configuring AP 802.1X Supplicant Credentials, page 11-11
- Configuring a Global CDP Configuration Template, page 11-12
- Configuring DHCP Templates, page 11-13
- Configuring Dynamic Interface Templates, page 11-14
- Configuring Controller System Interface Groups, page 9-39
- Configuring QoS Templates, page 11-16
- Configuring AP Timers Templates, page 11-18
- Configuring a Traffic Stream Metrics QoS Template, page 11-20

Configuring General Templates

To add a general template or make changes to an existing general template, follow these steps:

Step 1 Choose Configure > Controller Template Launch Pad.

Click General or choose System > General from the left sidebar menu. The System > General Template page appears, and the number of controllers and virtual domains the template is applied to automatically populates. The last column shows when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page that displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 2 If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The General template page appears (see Figure 11-1).
### Chapter 11      Using Templates

#### Configuring Controller Templates

**Figure 11-1   System > General Page**

**New Controller Template**

Configure > Controller Template > System > General > New Controller Template

<table>
<thead>
<tr>
<th>General</th>
</tr>
</thead>
<tbody>
<tr>
<td>Template Name</td>
</tr>
<tr>
<td>802.3x Flow Control Mode</td>
</tr>
<tr>
<td>802.3 Bridging</td>
</tr>
<tr>
<td>Web Radius Authentication</td>
</tr>
<tr>
<td>AP Primary Discovery Timeout</td>
</tr>
<tr>
<td>Back-up Primary Controller IP Address</td>
</tr>
<tr>
<td>Back-up Primary Controller Name</td>
</tr>
<tr>
<td>Back-up Secondary Controller IP Address</td>
</tr>
<tr>
<td>Back-up Secondary Controller Name</td>
</tr>
<tr>
<td>CAPWAP Transport Mode</td>
</tr>
<tr>
<td>Broadcast Forwarding</td>
</tr>
<tr>
<td>LAG Mode</td>
</tr>
<tr>
<td>Peer to Peer Blocking Mode</td>
</tr>
<tr>
<td>Over-the-Air Provisioning AP Mode</td>
</tr>
<tr>
<td>AP Fallback</td>
</tr>
<tr>
<td>AP Failover Priority</td>
</tr>
<tr>
<td>Apple Talk Bridging</td>
</tr>
<tr>
<td>Fast SSID change</td>
</tr>
<tr>
<td>Master Controller Mode</td>
</tr>
<tr>
<td>Wireless Management</td>
</tr>
<tr>
<td>Symmetric Tunneling Mode</td>
</tr>
<tr>
<td>ACL Counters</td>
</tr>
<tr>
<td>Default Mobility Domain Name</td>
</tr>
<tr>
<td>Mobility Anchor Group Keep Alive Interval</td>
</tr>
<tr>
<td>Mobility Anchor Group Keep Alive Retries</td>
</tr>
<tr>
<td>RF Network Name</td>
</tr>
<tr>
<td>User Idle Timeout</td>
</tr>
<tr>
<td>ARP Timeout</td>
</tr>
<tr>
<td>Global TCP Adjust MSS</td>
</tr>
<tr>
<td>Web Auth Proxy Redirect Mode</td>
</tr>
<tr>
<td>Web Auth Proxy Redirect Port</td>
</tr>
<tr>
<td>AP Retransmit Count</td>
</tr>
<tr>
<td>AP Retransmit Interval</td>
</tr>
</tbody>
</table>

**Footnotes:**
1. Software-based forwarding architecture for 2100-series-based controllers is being replaced with a new forwarding plane architecture. As a result, 2100 series controllers and the Cisco Wireless LAN Controller Network Module for Cisco Integrated Services Routers bridge 802.3 packets by default. Therefore 802.3 bridging cannot be disabled on these devices from 5.2.24.6 version.
2. SNMP support for Web Radius Authentication is available only from 6.0 version of controller.
3. SNMP support for AP Primary Discovery Timeout is available only from 6.0 version of controller.
4. Global Primary/Secondary Controller IP and name is applicable from 6.0 version of controller. Setting the Global Primary/Secondary Controller IP to 0.0.0.0 or blank will unset the Primary/Secondary Controller Setting.
5. From 5.2 onwards, Asymmetric Tunneling mode is not supported. So by default Symmetric Tunneling mode will be enabled.
6. AP Retransmit Configuration is supported from controller version 7.0.114.8

**Step 3** Use the drop-down list to enable or disable flow control mode.

**Step 4** Use the drop-down list to enable or disable 802.3 bridging.
Chapter 11      Using Templates

Configuring Controller Templates

Note  This 802.3 bridging option is not available for 5500 and 2106 series controllers.

Step 5  Use the drop-down list to choose the desired Web RADIUS authentication. You can choose to use PAP, CHAP, or MD5-CHAP for authentication between the controller and the client during the user credential exchange.

Step 6  Specify the number of seconds for the AP Primary Discovery Timeout. The default is 120 seconds, and the valid range is 30 to 3600.

Step 7  Specify the Back-up Primary and Secondary Controller details (Controller IP Address and Controller Name)

Step 8  Specify Layer 2 or Layer 3 transport mode. When set to Layer 3, the lightweight access point uses IP addresses to communicate with the access points; these IP addresses are collected from a mandatory DHCP server. When set to Layer 2, the lightweight access point uses proprietary code to communicate with the access points.

Note  The older version of controllers until 5.2 will use LWAPP and the new controller version uses CAPWAPP.

Step 9  Choose to enable or disable broadcast forwarding. The default is disabled.

Step 10  Choose Enable or Disable from the LAG Mode drop-down list. Link aggregation allows you to reduce the number of IP addresses needed to configure the ports on your controller by grouping all the physical ports and creating a link aggregation group (LAG).

If LAG is enabled on a controller, any dynamic interfaces that you have created are deleted to prevent configuration inconsistencies in the interface database. When you make changes to the LAG configuration, the controller has to be rebooted for the changes to take effect.

Note  Interfaces cannot be created with the Dynamic AP Manager flag set. Also, you cannot create more than one LAG on a controller.

Step 11  Choose to enable or disable peer-to-peer blocking mode. If you choose Disable, any same-subnet clients communicate through the controller. If you choose Enable, any same-subnet clients communicate through a higher-level router.

Step 12  From the Over Air AP Provision Mode drop-down list, choose enable or disable.

Step 13  From the AP Fallback drop-down list, choose enable or disable. Enabling fallback causes an access point that lost a primary controller connection to automatically return to service when the primary controller returns.

Step 14  When a controller fails, the backup controller configured for the access point suddenly receives a number of discovery and join requests. This may cause the controller to reach a saturation point and reject some of the access points. By assigning priority to an access point, you have some control over which access points are rejected. In a failover situation when the backup controller is saturated, the higher priority access points can join the backup controller if the lower priority access points are disjoined. Choose Enable at the AP Failover Priority drop-down list if you want to allow this capability.

Step 15  Choose to enable or disable Apple Talk bridging.

Note  This Apple Talk bridging option is not available on 5500 series controllers.
Step 16 Choose to enable or disable the Fast SSID Change option. If the option is enabled, the client connects instantly to the controller between SSIDs without having much loss of connectivity. Normally, each client is connected to a particular WLAN identified by the SSID. If the client moves out of reach of the connected access point, the client has to reconnect to the controller using a different access point. This normal process consumes some time as the DHCP (Dynamic Host Configuration Protocol) server has to assign an IP address to the client.

Step 17 Because the master controller is normally not used in a deployed network, the master controller setting is automatically disabled upon reboot or operating system code upgrade. You may enable the controller as the master controller from the Master Controller Mode drop-down list.

Step 18 Choose to enable or disable access to the controller management interface from wireless clients. Because of IPsec operation, management via wireless is only available to operators logging in across WPA or Static WEP. Wireless management is not available to clients attempting to log in via an IPsec WLAN.

Step 19 Choose to enable or disable symmetric tunneling mode. With symmetric mobility tunneling, the controller provides inter-subnet mobility for clients roaming from one access point to another within a wireless LAN. The client traffic on the wired network is directly routed by the foreign controller. If a router has Reverse Path Forwarding (RPF) enabled (which provides additional checks on incoming packets), the communication is blocked. Symmetric mobility tunneling allows the client traffic to reach the controller designated as the anchor, even with RPF enabled.

Note All controllers in a mobility group should have the same symmetric tunneling mode.

Note For symmetric tunneling to take effect, you must reboot.

Step 20 Use the drop-down list to enable or disable ACL counters. The values per ACL rule can be viewed for each controller.

Step 21 Enter the operator-defined RF mobility group name in the Default Mobility Domain Name text box.

Step 22 At the Mobility Anchor Group Keep Alive Interval, determine the delay between tries for clients attempting to join another access point. With this guest tunneling N+1 redundancy feature, the time it takes for a client to join another access point following a controller failure is decreased because a failure is quickly identified, the clients are moved away from the problem controller, and the clients are anchored to another controller.

Note When you hover your mouse cursor over the parameter field, the valid range for that field appears.

Step 23 At the Mobility Anchor Group Keep Alive Retries, specify the number of queries to anchor before the client declares it unreachable.

Step 24 Enter the RF network group name between 8 and 19 characters. Radio Resource Management (RRM) neighbor packets are distributed among access points within an RF network group. The Cisco access points only accept RRM neighbor packets sent with this RF network name. The RRM neighbor packets sent with different RF network names are dropped.

Step 25 Specify the time out for idle clients. The factory default is 300 seconds. When the timeout expires, the client loses authentication, briefly disassociates from the access point, reassociates, and re-authenticates.

Step 26 Specify the timeout in seconds for the address resolution protocol. The factory default is 300 seconds.
Step 27  Select the **Global TCP Adjust MMS** check box to start checking the TCP packets originating from the client, for the TCP SYN/ TCP ACK packets and MSS value and reset it to the configured value on the upstream and downstream side.

Step 28  Choose **enable** or **disable** Web Auth Proxy Redirect Mode, if a manual proxy configuration is configured on the client’s browser, all web traffic going out from the client will be destined to the PROXY IP and PORT configured on the browser.

Step 29  Enter the Web Auth Proxy Redirect Port. The default ports are 8080 and 3128. The range is 0 to 65535.

Step 30  Enter the AP Retransmit Count and Intervals. The AP Retransmit Count default value is 5 and the range is from 3 to 8. The AP Retransmit Interval default value is 3. The range is 2 to 5.

Step 31  Click **Save**.

### Configuring SNMP Community Controller Templates

Create or modify a template for configuring SNMP communities on controllers. Communities can have read-only or read-write privileges using SNMP v1, v2, or v3.

To add a new template with SNMP community information for a controller, follow these steps:

---

**Step 1**  Choose **Configure > Controller Template Launch Pad**.

**Step 2**  Click **New** beside the template you want to add.

**Step 3**  Add or modify the following parameters:

- **Template Name**
  
  **Note**  Template Name is the unique key used to identify the template. A template name is mandatory to distinguish between two templates that have identical key attributes.

- Community Name
- Confirm Community Name—Retype the community name.
- IP Address—The IP address of the server.
- Netmask
- Access Mode—Choose **Read Only** or **Read Write** from the drop-down list.
  - Read Only—Cannot be edited.
  - Read Write—Can be edited.
- Admin Status—Select the check box to enable this template.

**Step 4**  Click **Save**. Once saved, the template displays in the Template List page. In the Template List page, you can apply this template to controllers. See the **“Applying Controller Templates”** section on page 11-2 for more information.
Configuring an NTP Server Template

Note  
NTP is used to synchronize computer clocks on the Internet.

To add an NTP template or make modifications to an existing NTP template, follow these steps:

Step 1  Choose Configure > Controller Template Launch Pad.

Step 2  Click Network Time Protocol or choose System > Network Time Protocol from the left sidebar menu. The System > NTP Server Template page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens the Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens to an Applied to Virtual Domains page that shows all partition names.

Step 3  If you want to add a new template, click Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The Network Time Protocol template page appears (see Figure 11-2).

Figure 11-2  NTP Servers Template

Step 4  Enter the NTP server IP address.

Step 5  Click Save.
Configuring User Roles Controller Templates

This section describes how to create or modify a template for configuring user roles. User roles determine how much bandwidth the network can use. Four QoS levels (Platinum, Bronze, Gold, and Silver) are available for the bandwidth distribution to Guest Users. Guest Users are associated with predefined roles (Contractor, Customer, Partner, Vendor, Visitor, Other) with respective bandwidth configured by the Admin. These roles can be applied when adding a new Guest User. See the “Configuring a Guest User Template” section on page 11-63 for more information on adding Guest Users.

To add a new template with User Roles information for a controller, follow these steps:

1. Choose Configure > Controller Template Launch Pad.
2. Click New beside the template you want to add.
3. Add or modify the following parameters:
   - Role Name
   - Average Data Rate—The average data rate for non-UDP (User Datagram Protocol) traffic.
   - Burst Data Rate—The peak data rate for non-UDP traffic.
   - Average Real-time Rate—The average data rate for UDP traffic.
   - Burst Real-time Rate—The peak data rate for UDP traffic.
4. Click Save. Once saved, the template displays in the Template List page. From the Template List page, you can apply this template to controllers. See the “Applying Controller Templates” section on page 11-2 for more information.

Configuring AP Username Password Controller Templates

Create or modify a template for setting an access point username and password. All access points inherit the password as they join the controller and these credentials are used to log into the access point via the console or Telnet/SSH.

Note
See the “Configuring a Global Access Point Password” section on page 9-58 for more information regarding global passwords.

The AP Username Password page enables you to set a global password that all access points inherit as they join a controller. When you are adding an access point, you can also choose to accept this global username and password or override it on a per-access point basis. See the “Configuring AP Configuration Templates” section on page 11-143 to see where the global password is displayed and how it can be overridden on a per-access point basis.

Also in controller software release 5.0, after an access point joins the controller, the access point enables console port security and you are prompted for your username and password whenever you log into the access point console port. When you log in, you are in non-privileged mode and you must enter the enable password to use the privileged mode.

To add a new template with AP Username Password information for a controller, follow these steps:

1. Choose Configure > Controller Template Launch Pad.
Step 2 Click New beside the template you want to add.

Step 3 Add or modify the following parameters:

- AP Username—Type the username that you want to be inherited by all access point that join the controller.
- AP Password—Type the password that you want to be inherited by all access point that join the controller.
- Confirm Password—Retype the access point password.
- Enable Password

Note For Cisco IOS access points, you must also enter and confirm an enable password.

- Confirm Enable Password

Step 4 Click Save. Once saved, the template displays in the Template List page. In the Template List page, you can apply this template to controllers. See the “Applying Controller Templates” section on page 11-2 for more information.

Note See the “Configuring a Global Access Point Password” section on page 9-58 for more information regarding global passwords.

Configuring AP 802.1X Supplicant Credentials

You can configure 802.1X authentication between lightweight access points and the switch. The access point acts as an 802.1X supplicant and is authenticated by the switch using EAP-FAST with anonymous PAC provisioning. You can set global authentication settings that all access points inherit as they join the controller. All access points that are currently joined to the controller and any that join in the future are included. Follow these steps to add or modify an existing AP 802.1X Supplicant Credentials template.

Note If desired, you can override the global authentication settings and assign unique authentication settings for a specific access point. See the “Configuring Access Points” section on page 9-152 for more information.

Step 1 Choose Configure > Controller Templates Launch Pad.

Step 2 Click AP 802.1X Supplicant Credentials or choose System > AP 802.1X Supplicant Credentials from the left sidebar menu. The AP 802.1X Supplicant Credentials Templates page displays all currently saved AP 802.1X Supplicant Credentials templates. It also displays the number of controllers and virtual domains to which each template is applied.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 3 Click a template name to open the Controller Template list page. From there, you can edit the current template parameters.
Step 4  Click Save.

Configuring a Global CDP Configuration Template

Cisco Discovery Protocol (CDP) is a device-discovery protocol that runs on all Cisco network equipment. Each device sends identifying messages to a multicast address, and each device monitors the messages sent by other devices.

Note  CDP is enabled on the bridge's Ethernet and radio ports by default.

To configure a Global CDP configuration template, follow these steps:

Step 1  Choose Configure > Controller Template Launch Pad.

Step 2  Click Global CDP Configuration or choose System > Global CDP Configuration from the left sidebar menu. The Global CDP Configuration Templates page displays all currently saved Global CDP Configuration templates.

Step 3  If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The Global CDP Configuration template page appears.

Step 4  Enter the new CDP template name.

Step 5  In the Global CDP portion of the page, enter the following parameters:

- CDP on controller—Choose enable or disable CDP on the controller.

  Note  This configuration cannot be applied on WISM2 controllers.

- Global CDP on APs—Choose to enable or disable CDP on the access points.

- Refresh-time Interval (seconds)—At the Refresh Time Interval parameter, enter the time in seconds at which CDP messages are generated. The default is 60.

- Holdtime (seconds)—Enter the time in seconds before the CDP neighbor entry expires. The default is 180.

- CDP Advertisement Version—Enter which version of the CDP protocol to use. The default is v1.

Step 6  In the CDP for Ethernet Interfaces portion of the page, select the slots of Ethernet interfaces for which you want to enable CDP.

  Note  CDP for Ethernet Interfaces fields are supported for controller version 7.0.110.2 onwards.

Step 7  In the CDP for Radio Interfaces portion of the page, select the slots of Radio interfaces for which you want to enable CDP.

  Note  CDP for Radio Interfaces fields are supported for controller version 7.0.110.2 onwards.

Step 8  Click Save.
Configuring Controller Templates

Note
The Global Interface CDP configuration will be applied only to the APs for which the CDP is enabled at AP level.

Configuring DHCP Templates

To add a DHCP template or make modifications to an existing DHCP template, follow these steps:

**Step 1** Choose Configure > Controller Template Launch Pad.

**Step 2** Click DHCP or choose System > DHCP from the left sidebar menu. The System > DHCP Template page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3** If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The DHCP template page appears (see Figure 11-3).

![Figure 11-3 DHCP Template Page](image)

**Step 4** You can enable or disable DHCP proxy on a global basis rather than on a WLAN basis. When DHCP proxy is enabled on the controller, the controller unicasts DHCP requests from the client to the configured servers. At least one DHCP server must be configured on either the interface associated with the WLAN or on the WLAN itself. DHCP proxy is enabled by default.

**Step 5** Enter the DHCP Timeout in seconds after which the DHCP request will time out. The default setting is 5. Allowed values range from 5 to 120 seconds.

Note
DHCP Timeout is applicable from the controller version 7.0.114.74 onwards.
Step 6  Click Save.

Configuring Dynamic Interface Templates

To add a dynamic interface template or make modifications to an existing interface configuration, follow these steps:

Step 1  Choose Configure > Controller Template Launch Pad.

Step 2  Click Dynamic Interface or choose System > Dynamic Interface from the left sidebar menu. The System > Dynamic Interface Template page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 3  If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The Dynamic Interface template page appears (see Figure 11-4).

Figure 11-4  Dynamic Interface Template

Step 4  Select the Guest LAN check box to mark the interface as wired.

Step 5  Enter the net mask address of the interface.

Step 6  Enter which port is currently used by the interface.

Step 7  Enter a secondary port to be used by the interface when the primary port is down. When the primary port is reactivated, the Cisco 4400 Series Wireless LAN Controller transfers the interfaces back to the primary port.
Note: Primary and secondary port numbers are present only in the Cisco 4400 Series Wireless LAN Controllers.

Step 8 Enter the IP address of the primary DHCP server.

Step 9 Enter the IP address of the secondary DHCP server.

Step 10 From the ACL Name drop-down list, choose a name from the list of defined names.

Step 11 From the Add Format Type drop-down list in the Add Interface Format Type section, choose either Device Info or File. If you choose device info, you must configure the device specific parameters for each controller. If you choose File, you must configure CSV device specific parameters (Interface Name, VLAN Identifier, Quarantine VLAN Identifier, IP Address, and Gateway) for all the managed controllers specified in the CSV file (see Table 11-1). If you choose Device Info, continue to Step 12.

The sample CSV files are as follows.

**Table 11-1 Sample CSV Files**

<table>
<thead>
<tr>
<th>ip_address</th>
<th>interface_name</th>
<th>vlan_id</th>
<th>quarantine_vlan_id</th>
<th>interface_ip_address</th>
<th>gateway</th>
</tr>
</thead>
<tbody>
<tr>
<td>209.165.200.224</td>
<td>dyn-1</td>
<td>1</td>
<td>2</td>
<td>209.165.200.228</td>
<td>209.165.200.229</td>
</tr>
<tr>
<td>209.165.200.225</td>
<td>interface-1</td>
<td>4</td>
<td>2</td>
<td>209.165.200.230</td>
<td>209.165.200.231</td>
</tr>
<tr>
<td>209.165.200.227</td>
<td>dyna-2</td>
<td>2</td>
<td>3</td>
<td>209.165.200.234</td>
<td>209.165.200.235</td>
</tr>
</tbody>
</table>

The first row of the CSV file is used to describe the columns included. The CSV files can contain the following fields:

- ip_address
- interface_name
- vlan_id
- quarantine_vlan_id
- interface_ip_address
- gateway

Step 12 If you choose Apply to Controllers, you advance to the Apply To page where you can configure device-specific parameters for each controller (see Figure 11-5).

**Figure 11-5 Apply To Page**

Use the Add and Remove options to configure device specific parameters for each controllers. If you click Edit, a dialog box appears with the current parameter input.

Step 14 Make the necessary changes in the dialog box, and click OK.
Chapter 11      Using Templates

Configuring Controller Templates

Configuring QoS Templates

Applying a Dynamic Interface Template to Controllers

Note
If you change the interface parameters, the WLANs are temporarily disabled, so, you may lose connectivity for some clients. Any changes to the interface parameters are saved only after you successfully apply them to the controller(s).

Note
If you remove an interface here, it is removed only from this template and NOT from the controllers.

Applying a Dynamic Interface Template to Controllers

To apply a Dynamic Interface template to a controller, follow these steps:

Step 1
In the Dynamic Interface controller template page, click Apply to Controllers.

Step 2
Use the Manage Interfaces options to configure device-specific parameters:
- Add—Click Add to open the Add Interface dialog box. Enter an interface name, VLAN identifier, IP address, and gateway. When all parameters are entered, click Done.
- Edit—Click Edit to make changes to current interfaces.
- Remove—Click Remove to delete a current interface.

Step 3
Select a check box for each controller to which you want to apply this template.

Step 4
Click Apply.

Note
Changing the Interface parameters causes the WLANs to be temporarily disabled and may result in loss of connectivity for some clients.

Note
Interface parameter changes or configurations made on this page are saved only when applied successfully to the controller(s).

Note
Interfaces removed from this page are removed only from this template and not from controllers.

Note
See the “Configuring Dynamic Interface Templates” section on page 11-14 for more information on Dynamic Interface controller templates.

Configuring QoS Templates

To modify the quality of service (QoS) profiles, follow these steps:
### Chapter 11: Using Templates

#### Configuring Controller Templates

**Step 1** Choose Configure > Controller Template Launch Pad.

**Step 2** Click QoS Profiles or choose System > QoS Profiles from the left sidebar menu. The System > QoS Profiles page appears. The number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3** If you want to edit the bronze, gold, platinum, or silver QoS profile, click in the Name column for the profile you want to edit. The Edit QoS Profile Template page appears (see Figure 11-6).

**Figure 11-6 Edit QoS Profile Template Page**

![Edit QoS Profile Template Page](image)

**Step 4** Set the following values in the Per-User Bandwidth Contracts portion of the page. All have a default of 0 or Off.

- **Average Data Rate** - The average data rate for non-UDP traffic.
- **Burst Data Rate** - The peak data rate for non-UDP traffic.
- **Average Real-time Rate** - The average data rate for UDP traffic.
- **Burst Real-time Rate** - The peak data rate for UDP traffic.

**Step 5** Set the following values for the Over-the-Air QoS portion of the page.

- **Maximum QoS RF Usage per AP** - The maximum air bandwidth available to clients. The default is 100%.
- **QoS Queue Depth** - The depth of queue for a class of client. The packets with a greater value are dropped at the access point.
Step 6  Set the following values in the Wired QoS Protocol portion of the page.

- Wired QoS Protocol - Choose 802.1P to activate 802.1P priority tags or None to deactivate 802.1P priority flags.
- 802.1P Tag - Choose 802.1P priority tag for a wired connection from 0 to 7. This tag is used for traffic and CAPWAP packets.

Step 7  Click Save.

Configuring AP Timers Templates

Some advanced timer configuration for HREAP and local mode is available for the controller on WCS. To configure a template for advanced timers, follow these steps:

Step 1  Choose Configure > Controller Template Launch Pad.

Step 2  Click AP Timers or choose System > AP Timers from the left sidebar menu. The System > AP Timers page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The values in the Access Point Mode column are links. When you click a link, the Controller Template <access point mode> page appears. The Access Point Mode is automatically populated (see Figure 11-7).

Step 3  Select the AP Fast Heartbeat Timer State check box to enable AP Fast Heartbeat Timeout.

Step 4  Enter an AP Fast Heartbeat Timeout value. The valid range is 1 to 15 seconds. The default is 10 seconds. The recommended timeout values are:

- 10 to 15 seconds for 7500 series controllers.
- 10 to 15 seconds for 5500 series of controllers with version 7.0.98.0 or lower.
- 1 to 10 seconds for 5500 series of controllers with version above 7.0.98.0.
- 1 to 10 seconds for other controllers.
Configuring an Interface Group Template

The interface group template page allows you to select list of interfaces and form a group.

**Note** You cannot create interfaces using this page.

To configure an interface group template, follow these steps:

**Step 1** Choose Configure > Controller Template Launch Pad.

**Step 2** Click Interface Groups or choose System > Interface Groups from the left sidebar menu. The System > Interface Groups page appears.

**Step 3** If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The New Controller Template page appears.

**Step 4** Specify the following details:

- **Name**—Interface Group name.
- **Description (optional)**—A more detailed description of the interface group.
- **Quarantine**—Indicates the type of interfaces that can be added to an interface group. If this option is enabled, you can add interfaces with quarantine VLAN ID set. If this option is disabled, you can add interfaces with quarantine VLAN ID not set.
Step 5  Selected Controllers/Interfaces that you want to add to the group.

Step 6  Click Save.

Configuring a Traffic Stream Metrics QoS Template

Traffic stream metrics are a series of statistics about VoIP over your wireless LAN and informs you of the QoS of the wireless LAN. These statistics are different than the end-to-end statistics provided by VoIP systems. End-to-end statistics provide information on packet loss and latency covering all the links comprising the call path. However, traffic stream metrics are statistics for only the WLAN segment of the call. Because of this, system administrators can quickly determine whether audio problems are being caused by the WLAN or by other network elements participating in a call. By observing which access points have impaired QoS, system administrators can quickly determine the physical area where the problem is occurring. This is important when lack of radio coverage or excessive interference is the root problem.

Four QoS values (packet latency, packet jitter, packet loss, and roaming time), which can affect the audio quality of voice calls, are monitored. All the wireless LAN components participate in this process. Access points and clients measure the metrics, access points collect the measurements and then send them to the controller. The access points update the controller with traffic stream metric information every 90 seconds, and 10 minutes of data is stored at one time. Cisco WCS queries the controller for the metrics and displays them in the Traffic Stream Metrics QoS Status. These metrics are compared to threshold values to determine their status level and if any of the statistics are displaying a status level of fair (yellow) or degraded (red), the administrator investigates the QoS of the wireless LAN.

For the access points to collect measurement values, traffic stream metrics must be enabled on the controller.

To configure a Traffic Stream Metrics QoS template, follow these steps:

Step 1  Choose Configure > Controller Template Launch Pad.

Step 2  Click Traffic Stream Metrics QoS or choose System > Traffic Stream Metrics QoS from the left sidebar menu. The System > Traffic Stream Metrics QoS Status page appears (see Figure 11-8).
The Traffic Stream Metrics QoS Status Configuration page shows several QoS values. An administrator can monitor voice and video quality of the following:

- Upstream delay
- Upstream packet loss rate
- Roaming time
- Downstream packet loss rate
- Downstream delay

Packet Loss Rate (PLR) affects the intelligibility of voice. Packet delay can affect both the intelligibility and conversational quality of the connection. Excessive roaming time produces undesired gaps in audio.

There are three levels of measurement:

- Normal: Normal QoS (green)
- Fair: Fair QoS (yellow)
- Degraded: Degraded QoS (red)

System administrators should employ some judgement when setting the green, yellow, and red alarm levels. Some factors to consider are:

- Environmental factors including interference and radio coverage which can affect PLR.
- End-user expectations and system administrator requirements for audio quality on mobile devices (lower audio quality can permit greater PLR).
- Different codec types used by the phones have different tolerance for packet loss.
Not all calls will be mobile-to-mobile; therefore, some have less stringent PLR requirements for the wireless LAN.

## Configuring WLAN Templates

This section contains the following topics:

- Configuring WLAN Templates, page 11-22
- Configuring WLAN AP Groups Templates, page 11-38

### Configuring WLAN Templates

WLAN templates allow you to define various WLAN profiles for application to different controllers. In WCS software release 4.0.96.0 and later releases, you can configure multiple WLANs with the same SSID. This feature enables you to assign different Layer 2 security policies within the same wireless LAN. Unlike previous release where profile name was used as the unique identifier, the template name is now the unique identifier with software release 5.1.

These restrictions apply when configuring multiple WLANs with the same SSID:

- WLANs with the same SSID must have unique Layer 2 security policies so that clients can make a WLAN selection based on information advertised in the beacons and probes. These are the available Layer 2 security policies:
  - None (open WLAN)
  - Static WEP or 802.1
  - CKIP
  - WPA/WPA2
- Broadcast SSID must be enabled on the WLANs that share an SSID so that the access points can generate probe responses for these WLANs.
- Hybrid-REAP access points do not support multiple SSIDs.

To add a WLAN template or make modifications to an existing WLAN template, follow these steps:

---

**Step 1** Choose **Configure > Controller Template Launch Pad**.

**Step 2** Click **WLAN** or choose **WLANs > WLAN** from the left sidebar menu. The WLAN Template page appears with a summary of all existing defined WLANs. The following information headings are used to define the WLANs listed on the WLAN Template General page:

- **Template Name**—The user-defined name of the template. Clicking the name displays parameters for this template.
- **Profile Name**—User-defined profile name used to distinguish WLANs with the same SSID.
- **SSID**—Displays the name of the WLAN.
- **WLAN/Guest LAN**—Determines if guest LAN or WLAN.
- **Security Policies**—Indicates what security policy is chosen. None indicates no 802.1X.
- **WLAN Status**—Determines whether the WLAN is enabled or not.
• Applied to Controllers—The number of controllers the WLAN template is applied to. The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status.

• Applied to Virtual Domains—The number of virtual domains the WLAN template is applied to. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

• Last Saved At—Indicates when the template was last saved.

**Step 3** If you want to add a new template, choose **Add Template** from the Select a command drop-down list, and click **Go**. To modify an existing template, click the template name. The WLAN template page appears (see **Figure 11-9**).

![WLAN Template](image)

**Step 4** Select the **Wired LAN** check box to indicate whether or not this WLAN is a wired LAN.
Chapter 11      Using Templates

Configuring Controller Templates

Configure the Controller Template to define the WLANs it will manage. The settings defined in the template apply to all WLANs created from this template. When creating a WLAN, use the Controller Template name to identify the Controller Template.

Figure 11-10    WLAN Template

![WLAN Template](image)

**Note** Specify if you want guest users to have wired guest access from an Ethernet connection designated and configured for guest access. Wired guest access ports might be available in a guest office or specific ports in a conference room and accounts are added to the network using the Lobby Ambassador portal. (See the “Creating Guest User Accounts” section on page 7-11).

**Note** The Egress or Ingress interface configurations are applicable for Wired LAN only.

**Step 5** Use the **Type** drop-down list to select the type of the wired LAN.
- Guest LAN—Indicates that this wired LAN is a Guest LAN.

**Note** If you selected the Guest LAN option, you need to select an Ingress interface which has not already been assigned to any Guest LAN.

- Remote LAN—Indicates that this wired LAN is a Remote LAN.

**Step 6** Enter a name in the Profile Name text box that identifies the WLAN or the guest LAN. Do not use any spaces in the name entered.

**Step 7** Enter the name of the WLAN SSID. An SSID is not required for a guest LAN.
WLANs with the same SSID must have unique Layer 2 security policies so that clients can make a WLAN selection based on information advertised in the beacons and probes.

**Step 8** Select the **Enable** check box for the Status parameter.

**Step 9** Use the Radio Policy drop-down list to set the WLAN policy to apply to All (802.11a/b/g/n), 802.11a only, 802.11g only, 802.11b/g only, or 802.11a/g only.

**Step 10** Use the Interface/Interface Group drop-down list to choose the available names of interfaces created by the Controller > Interfaces module.
Step 11 From the Egress Interface drop-down list, choose the Egress interface that you created in the “Creating an Egress Interface” section on page 9-47. This provides a path out of the controller for wired guest client traffic.

Step 12 From the Ingress Interface drop-down list, choose the Ingress interface that you created in the “Creating an Ingress Interface” section on page 9-46. The provides a path between the wired guest client and the controller by way of the Layer 2 access switch.

Step 13 Select the Enable check box to enable the multicast VLAN feature.

Step 14 From the Multicast VLAN Interface drop-down list, choose the appropriate interface name. This list is automatically populated when you enable the multicast VLAN feature.

Step 15 Click Broadcast SSID to activate SSID broadcasts for this WLAN.

Step 16 Click Save.

Step 17 To further configure the WLAN template, choose from the following:

- Click the Security tab to establish which AAA can override the default servers on this WLAN and to establish the security mode for Layer 2 and 3. Continue to the “Security” section on page 11-25.
- Click the QoS tab to establish which quality of service is expected for this WLAN. Continue to the “QoS” section on page 11-33.
- Click the Advanced tab to configure any other details about the WLAN, such as DHCP assignments and management frame protection. Continue to the “Advanced” section on page 11-34.

Security

After choosing Security, you have an additional three tabs: Layer 2, Layer 3, and AAA Servers.

Layer 2

When you click the Layer 2 tab, the Layer 2 tab appears (see Figure 11-11).

Note The tab contains different views depending on what option is chosen in the Layer 2 Security drop-down list.
To configure the Layer 2 tab, follow these steps:

**Step 1**
Use the Layer 2 Security drop-down list to choose None, 802.1X, Static WEP, Static WEP-802.1X, WPA + WPA2, or CKIP as described in Table 11-2.

**Table 11-2 Layer 2 Security Options**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>No Layer 2 security selected.</td>
</tr>
</tbody>
</table>
| 802.1X    | WEP 802.1X data encryption type (Note 1):
  | 40/64 bit key. |
  | 104 bit key. |
  | 152 bit key. |
### Table 11-2  Layer 2 Security Options (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
</table>
| Static WEP           | Static WEP encryption parameters:  
|                      | Key sizes: Not set, 40/64, 104, and 152 bit key sizes.  
|                      | Key Index: 1 to 4 (Note 2).  
|                      | Encryption Key: Encryption key required.  
|                      | Key Format: ASCII or HEX.  
|                      | Allowed Shared Key Authentication—Select the check box to enable.  
| Note                 | Regardless of the format you choose, for security reasons, only ASCII is visible on the WLC (and WCS). For this reason, you cannot use a template to replicate the configuration on a second controller during auto provisioning. You should set the key format again in the template in case a discovered template is applied to another device. |
| Static WEP-802.1X    | Use this setting to enable both Static WEP and 802.1X policies. If this option is selected, static WEP and 802.1X parameters are displayed at the bottom of the page.  
|                      | Static WEP encryption parameters:  
|                      | Key sizes: Not set, 40/64, 104, and 152 bit key sizes.  
|                      | Key Index: 1 to 4 (Note 2).  
|                      | Encryption Key: Enter encryption key.  
|                      | Key Format: ASCII or HEX.  
|                      | Allowed Shared Key Authentication—Select the check box to enable.  
|                      | 802.1 Data Encryption: 40/64 bit key, 104 bit key, 152 bit key. |
Configuring Controller Templates

Chapter 11      Using Templates

Table 11-2   Layer 2 Security Options (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>WPA+WPA2</td>
<td>Use this setting to enable WPA, WPA2, or both. See the WPA1 and WPA2 parameters displayed in the page when WPA+WPA2 is selected. WPA enables Wi-Fi Protected Access with TKIP-MIC Data Encryption or AES. When WPA+WPA2 is selected, you can use Cisco Centralized Key Management (CCKM) authentication key management, which allows fast exchange when a client roams from one access point to another. When WPA+WPA2 is selected as the Layer 2 security policy, and Pre-shared Key is enabled, then neither CCKM or 802.1X can be enabled; although, both CCKM and 802.1X can be enabled at the same time.</td>
</tr>
<tr>
<td>CKIP</td>
<td>Cisco Key Integrity Protocol (CKIP). A Cisco access point advertises support for CKIP in beacon and probe response packets. CKIP can be configured only when Aironet IE is enabled on the WLAN. <strong>Note</strong> CKIP is not supported on 10xx APs. When selected, these CKIP parameters are displayed. Key size: Not set, 40, or 104. Key Index: 1 to 4 Encryption Key: Specify encryption key. Key Format: ASCII or HEX. <strong>Note</strong> Regardless of the format you choose, for security reasons, only ASCII is visible on the WLC (and WCS). For this reason, you cannot use a template to replicate the configuration on a second controller during auto provisioning. You should set the key format again in the template in case a discovered template is applied to another device. MMH Mode: Select the check box to enable. Key Permutation: Select the check box to enable.</td>
</tr>
</tbody>
</table>

**Step 2** Select the **MAC Filtering** check box if you want to filter clients by MAC address.

---

**Note** The ability to join a controller without specification within a MAC filter list is only supported on mesh access points.

---

**Note** For releases prior to 4.1.82.0, mesh access points do not join the controller unless they are defined in the MAC filter list.
You may want to disable the MAC filter list to allow newly added access points to join the controller. Before enabling the MAC filter list again, you should enter the MAC addresses of the new access points.

**Step 3** Choose the desired type of authentication key management. The choices are 802.1X, CCKM, or PSK.

---

**Note** If you choose PSK, you must enter the shared key and type (ASCII or hexadecimal).

---

**Note** Regardless of the format you choose, for security reasons, only ASCII is visible on the WLC (and WCS). For this reason, you cannot use a template to replicate the configuration on a second controller during auto provisioning. You should set the key format again in the template in case a discovered template is applied to another device.

**Step 4** Click **Save**.

---

**Layer 3**

When you click the Layer 3 tab, the Layer 3 tab appears (see Figure 11-12).

---

**Note** The tab contains different views depending on what option is chosen in the Layer 3 Security drop-down list.
To configure the Layer 3 tab, follow these steps:

**Step 1**
Use the Layer 3 security drop-down list to choose between None and VPN Pass Through. The page parameters change according to the selection you make. If you choose VPN pass through, you must enter the VPN gateway address.

**Note**
The VPN passthrough option is not available for the 2106 or 5500 series controllers.

**Step 2**
You can modify the default static WEP (web authentication) or assign specific web authentication (login, logout, login failure) pages and the server source.

a. To change the static WEP to passthrough, select the **Web Policy** check box and choose the Passthrough option. This option allows users to access the network without entering a username or password.

An **Email Input** check box appears. Select this check box if you want users to be prompted for their email address when attempting to connect to the network.

b. Choose the **WebAuth on MAC Filter Failure** option so that when clients fail on MAC filter, they get automatically switched to webAuth.
c. To specify custom web authentication pages, unselect the Global WebAuth Configuration Enable check box.

1. When the Web Auth Type drop-down list appears, choose one of the following options to define the web login page for the wireless guest users:

   - Default Internal—Displays the default web login page for the controller. This is the default value.
   - Customized Web Auth—Displays custom web login, login failure, and logout pages. When the customized option is selected, three separate drop-down lists for login, login failure, and logout page selection appear. You do not need to define a customized page for all three of the options. Choose None from the appropriate drop-down list if you do not want to display a customized page for that option.

   These optional login, login failure, and logout pages are downloaded to the controller as webauth.tar files. For specifics on downloading custom pages, see the “Downloading Customized Web Authentication” section on page 3-50.

   - External—Redirects users to an external server for authentication. If you choose this option, you must also enter the URL of the external server in the URL text box.

   **Note** External web auth is not supported for 2106 and 5500 series controllers.

You can select specific RADIUS or LDAP servers to provide external authentication in the Security > AAA page. To do so, continue with Step 4.

**Note** The RADIUS and LDAP servers must be already configured to have selectable options in the Security > AAA page. You can configure these servers in the RADIUS Authentication Servers page and TACACS+ Authentication Servers page.

- **Step 3** If you selected External as the Web Authentication Type in Step 2, choose Security > AAA, and choose up to three RADIUS and LDAP servers using the drop-down lists.
- **Step 4** Click Save.
- **Step 5** Repeat this process if a second (anchor) controller is being used in the network.

### AAA Servers

When you click the AAA Servers tab, the AAA Servers tab appears (see Figure 11-13).
To configure the AAA Servers tab, follow these steps:

**Step 1** Select the **Radius Server Overwrite Interface** check box to send the client authentication request through the dynamic interface which is set on the WLAN. When you enable the Radius Server Overwrite Interface option, the WLC will source all radius traffic for a WLAN using the dynamic interface configured on that WLAN.

**Note** You cannot enable Radius Server Overwrite Interface when Diagnostic Channel is enabled.

**Note** The Radius Server Overwrite Interface option is supported since controller version 7.0.x.

**Step 2** Select the **Enable** check boxes, then use the drop-down lists in the RADIUS and LDAP servers section to choose authentication and accounting servers. This selects the default RADIUS server for the specified WLAN and overrides the RADIUS server that is configured for the network. If all three RADIUS servers are configured for a particular WLAN, server 1 has the highest priority and so on.

If no LDAP servers are chosen here, WCS uses the default LDAP server order from the database.

**Step 3** Select the **Local EAP Authentication** check box if you have an EAP profile already configured that you want to enable. Local EAP is an authentication method that allows users and wireless clients to locally authenticate. It is designed for use in remote offices that want to maintain connectivity to wireless clients when the backend system becomes disrupted or the external authentication server goes down.

**Step 4** When AAA Override is enabled, and a client has conflicting AAA and controller WLAN authentication parameters, client authentication is performed by the AAA server. As part of this authentication, the operating system moves clients from the default Cisco WLAN Solution to a VLAN returned by the AAA server and predefined in the controller interface configuration (only when configured for MAC filtering, 802.1X, and/or WPA operation). In all cases, the operating system also uses QoS and ACL provided by the AAA server, as long as they are predefined in the controller interface configuration. (This VLAN switching by AAA override is also referred to as identity networking.)
For instance, if the corporate WLAN primarily uses a management interface assigned to VLAN 2, and if AAA override returns a redirect to VLAN 100, the operating system redirects all client transmissions to VLAN 100, regardless of the physical port to which VLAN 100 is assigned.

When AAA override is disabled, all client authentication defaults to the controller authentication parameter settings, and authentication is only performed by the AAA server if the controller WLANs do not contain any client-specific authentication parameters.

The AAA override values may come from a RADIUS server, for example.

**Step 5**

Click **Save.**

---

### QoS

When you click the QoS tab in the WLAN Template page, the QoS tab appears (see **Figure 11-14**).

**Figure 11-14    QoS Tab**

---

1. When enabled, a excluded timeout value of zero means infinity (will require administrative override to reset excluded clients.)
2. Layer 3 and/or Layer 2 security must be set to 'none' if IPv6 and Global WPA authentication are enabled at same time.
3. Web Authentication cannot be used in combination with IPsec and L2TP.
4. IEEE 802.11i is not supported on 802.11a.
5. IEEE 802.11i is not supported with IPSEC, L2TP, PPTP, CRANITE and CASTLE authentication. It is not applicable to WLAN ID 9-16.
6. Client MPP is not active unless MPP2 is configured.
7. Select valid BAP profile name when local BAP authentication is enabled.
8. Select an ingress interface which has not already been assigned to any Guest LAN.
9. DTD configuration is supported only from 6.0.X.X version of controllers.
To configure the QoS tab, follow these steps:

**Step 1** Use the QoS drop-down list to choose Platinum (voice), Gold (video), Silver (best effort), or Bronze (background). Services such as VoIP should be set to gold while non-discriminating services such as text messaging can be set to bronze.

**Step 2** Use the WMM Policy drop-down list to choose Disabled, Allowed (so clients can communicate with the WLAN), or Required to make it mandatory for clients to have WMM enabled for communication.

**Step 3** Select the **7920 AP CAC** check box if you want to enable support on Cisco 7920 phones.

**Step 4** If you want WLAN to support older versions of the software on 7920 phones, select the **7920 Client CAC** check box. The CAC limit is set on the access point for newer versions of software.

**Step 5** The IEEE 802.11 wireless multicast delivery mechanism does not provide a reliable way to acknowledge lost or corrupted packets. As a result, if any multicast packet is lost in the air, it is not sent again which may cause an IP multicast stream unviewable.

For Platinum (voice) and Gold (video) services, the Multicast Direct feature makes the IP multicast stream delivery reliable over the air, by converting the broadcast frame over the air to a unicast frame. Each VideoStream client acknowledges receiving a video IP multicast stream.

Select the **Multicast Direct** check box to enable this feature. By default it is disabled.

**Step 6** Click **Save**.

---

**Advanced**

When you click the Advanced tab in the WLAN Template page, the Advanced tab appears (see Figure 11-15).

*Figure 11-15  Advanced Tab*
Chapter 11      Using Templates

Configuring Controller Templates

Step 1  Select the **Hybrid REAP local switching** check box if you want to enable Hybrid REAP local switching. For more information on Hybrid REAP, see the “Configuring Hybrid REAP” section on page 13-4. If you enable it, the hybrid-REAP access point handles client authentication and switches client data packets locally.

H-REAP local switching is only applicable to the Cisco 1130/1240/1250 series access points. It is not supported with L2TP or PPTP authentications, and it is not applicable to WLAN IDs 9-16.

Step 2  Select the **H-REAP Local Auth** check box if you want to enable H-REAP local authentication.

Local authentication is useful where you cannot maintain the criteria a remote office setup of minimum bandwidth of 128 kbps with the roundtrip latency no greater than 100 ms and the maximum transmission unit (MTU) no smaller than 500 bytes. In local switching, the authentication capabilities are present in the access point itself. Thus local authentication reduces the latency requirements of the branch office.

Note  Local authentication can only be enabled on the WLAN of a HREAP AP that is in local switching mode.

Local authentication is not supported in the following scenarios:

- Guest Authentication cannot be performed on a HREAP local authentication enabled WLAN.
- RRM information is not available at the controller for the hybrid REAP local authentication enabled WLAN.
- Local radius is not supported.
- Once the client has been authenticated, roaming will only be supported after the WLC and the other hybrid REAPs in the group are updated with the client information.

Step 3  Choose to enable the diagnostic channel feature or leave it disabled. The diagnostic channel feature allows you to troubleshoot problems regarding client communication with a WLAN. When initiated by a client having difficulties, the diagnostic channel provides the most robust communication methods with the fewest obstacles to communication.

Step 4  Select the **Aironet IE** check box if you want to enable support for Aironet information elements (IEs) for this WLAN. If Aironet IE support is enabled, the access point sends an Aironet IE 0x85 (which contains the access point name, load, number of associated clients, and so on) in the beacon and probe responses of this WLAN, and the controller sends Aironet IEs 0x85 and 0x95 (which contains the management IP address of the controller and the IP address of the access point) in the reassociation response if it receives Aironet IE 0x85 in the reassociation request.

Step 5  Select the **IPv6** check box. You can configure IPv6 bridging and IPv4 web auth on the same WLAN.

Step 6  At the Session Timeout parameter, set the maximum time a client session can continue before requiring reauthorization.

Step 7  Choose to enable or disable coverage hold detection (CHD) on this WLAN. By default, CHD is enabled on all WLANs on the controller. If you disable CHD on a WLAN, a coverage hole alert is still sent to the controller, but no other processing is done to mitigate the coverage hole. This feature is useful for guest WLANs where highly mobile guests are connected to your network for short periods of time.

Step 8  The **Override Interface drop-down lists** provide a list of defined access control lists (ACLs). (See the “Configuring an Access Control List Template” section on page 11-80 for steps on defining ACLs.) Upon choosing an ACL from the list, the WLAN associates the ACL to the WLAN. Selecting an ACL is optional, and the default for this parameter is None.

Step 9  You can configure peer-to-peer blocking per WLAN rather than applying the status to all WLANs. From the Peer to Peer Blocking drop-down list, choose one of the following:
• Disable—Peer-to-peer blocking is disabled, and traffic is bridged locally whenever possible.
• Drop—The packet is discarded.
• Forward Up Stream—The packet is forwarded on the upstream VLAN, and the decision is made about what to do with the packet.

If H-REAP local switching is enabled for the WLAN, which prevents traffic from passing through the controller, this drop-down list is dimmed.

Note  Peer-to-peer blocking does not apply to multicast traffic.

Step 10  Select the check box if you want to enable automatic client exclusion.

Step 11  If you enable client exclusion, you must also set the Timeout Value in seconds for disabled client machines. Client machines are excluded by MAC address, and their status can be observed. A timeout setting of 0 indicates that administrative control is required to re-enable the client.

Note  When session timeout is not set, it implies that an excluded client remains and will not timeout from the excluded state. It does not imply that the exclusion feature is disabled.

Step 12  Enter the maximum number of clients to be associated in a WLAN in the Maximum Clients text box.

Step 13  Enable dynamic anchoring of static IP clients by selecting the Static IP Tunneling check box.

Step 14  Select the Media Session Snooping check box. This feature enables access points to detect the establishment, termination, and failure of voice calls and then report them to the controller and WCS. It can be enabled or disabled per WLAN.

When media session snooping is enabled, the access point radios that advertise this WLAN snoop for Session Initiation Protocol (SIP) voice packets. Any packets destined to or originating from port number 5060 are considered for further inspection. The access point tracks whether Wi-Fi Multimedia (WMM) and non-WMM clients are establishing a call, already on an active call, or in the process of ending a call and then notify the controller of any major call events.

Step 15  Select the NAC Support check box if you want to enable NAC support. The controller can integrate with the NAC appliance in out-of-band mode, where the NAC appliance remains in the data path only until clients have been analyzed and cleaned. Out-of-band mode reduces the traffic load on the NAC appliance and enables centralized NAC processing. See the “NAC Out-of-Band Integration” section on page 9-42 for more information.

Step 16  Off-Channel Scanning Defer is essential to the operation of RRM, which gathers information about alternate channel choices such as noise and interference. Additionally, Off-Channel Scanning Defer is responsible for rogue detection. Devices that need to defer Off-Channel Scanning Defer should use the same WLAN as often as possible. If there are many of these devices (and the possibility exists that Off-Channel Defer scanning could be completely disabled by the use of this feature), you should implement an alternative to local AP Off-Channel Scanning Defer, such as monitor access points, or other access points in the same location that do not have this WLAN assigned.

Assignment of a QoS policy (bronze, silver, gold, and platinum) to a WLAN affects how packets are marked on the downlink connection from the access point regardless of how they were received on the uplink from the client. UP=1,2 is the lowest priority, and UP=0,3 is the next higher priority. The marking results of each QoS policy are as follows:

• Bronze marks all downlink traffic to UP= 1.
• Silver marks all downlink traffic to UP= 0.
- Gold marks all downlink traffic to UP=4.
- Platinum marks all downlink traffic to UP=6.

Set the Scan Defer Priority by clicking the priority argument and set the time in milliseconds in the Scan Defer Interval text box. Valid values are 100 through 60000. The default value is 100 milliseconds.

**Step 17**
In 802.11a/n and 802.11b/g/n networks, lightweight access points broadcast a beacon at regular intervals, which coincides with the Delivery Traffic Indication Map (DTIM). After the access point broadcasts the beacon, it transmits any buffered broadcast and multicast frames based on the value set for the DTIM period. This feature allows power-saving clients to wake up at the appropriate time if they are expecting broadcast or multicast data.

Normally, the DTIM value is set to 1 (transmit broadcast and multicast frames after every beacon) or 2 (transmit after every other beacon). For instance, if the beacon period of the 802.11a/n or 802.11b/g/n network is 100 ms and the DTIM value is set to 1, the access point transmits buffered broadcast and multicast frames 10 times per second. If the beacon period is 100 ms and the DTIM value is set to 2, the access point transmits buffered broadcast and multicast frames 5 times per second. Either of these settings may be suitable for applications, including VoIP, that expect frequent broadcast and multicast frames.

However, the DTIM value can be set as high as 255 (transmit broadcast and multicast frames after every 255th beacon) if all 802.11a/n or 802.11b/g/n clients have power save enabled. Because the clients have to listen only when the DTIM period is reached, they can be set to listen for broadcasts and multicasts less frequently, resulting in longer battery life. For instance, if the beacon period is 100 ms and the DTIM value is set to 100, the access point transmits buffered broadcast and multicast frames once every 10 seconds, allowing the power-saving clients to sleep longer before they have to wake up and listen for broadcasts and multicasts, resulting in longer battery life.

Many applications cannot tolerate a long time between broadcast and multicast messages, resulting in poor protocol and application performance. We recommend a low DTIM value for 802.11a/n and 802.11b/g/n networks that support such clients.

Under DTIM Period, enter a value between 1 and 255 (inclusive) in the 802.11a/n and 802.11b/g/n fields. The default value is 1 (transmit broadcast and multicast frames after every beacon).

---

**Note**
A DTIM interval (data beacon rate) is the frequency at which an access point's beacon includes a DTIM. This frequency is usually measured in milliseconds (ms).

**Note**
DTIM configuration is not appropriate for guest LANs.

**Step 18**
When you select the check box to override DHCP server, another parameter appears where you can enter the IP address of your DHCP server. For some WLAN configurations, this is required. Three valid configurations are as follows:

- DHCP Required and a valid DHCP server IP address - All WLAN clients obtain an IP address from the DHCP server.
- DHCP is not required and a valid DHCP server IP address - All WLAN clients obtain an IP address from the DHCP server or use a static IP address.
- DHCP not required and DHCP server IP address 0.0.0.0 - All WLAN clients are forced to use a static IP address. All DHCP requests are dropped.

You cannot choose to require a DHCP address assignment and then enter a DHCP server IP address.
Step 19 If the MFP Signature Generation check box is selected, it enables signature generation for the 802.11 management frames transmitted by an access point associated with this WLAN. Signature generation makes sure that changes to the transmitted management frames by an intruder are detected and reported.

Step 20 From the MFP Client Protection drop-down list, choose Optional, Disabled, or Required for configuration of individual WLANs of a controller. If infrastructure MFP is not enabled, this drop-down list is unavailable.

Note: Client-side MFP is only available for those WLANs configured to support Cisco Compatible Extensions (version 5 or later) clients, and WPA2 must first be configured.

Step 21 Click Save.

Configuring WLAN AP Groups Templates

Site-specific VLANs or AP groups limit the broadcast domains to a minimum by segmenting a WLAN into different broadcast domains. Benefits include more effective management of load balancing and bandwidth allocation.

To configure WLAN AP Groups, follow these steps:

Step 1 Choose Configure > Controller Template Launch Pad.

Step 2 Click AP Groups or choose WLAN > AP Groups from the left sidebar menu. The WLAN > AP Groups page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 3 If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The AP Groups template page appears (see Figure 11-16).
This page displays a summary of the AP groups configured on your network. From here you can add, remove, edit, or view details of an AP group. Click in the Edit column to edit its access point(s). Select the check box in the WLAN Profile Name column, and click **Remove** to delete WLAN profiles.

**Note**  
The maximum characters that you can enter in the Description text box is 256.

### Adding Access Point Groups

To add a new access point group, follow these steps:

**Step 1**  
Choose **Configure > Controller Template Launch Pad**.

**Step 2**  
Click **AP Group VLANs** or choose **WLAN > AP Group VLANs** from the left sidebar menu.

**Note**  
AP Groups (for 5.2 and above controllers) are referred to as AP Group VLANs for controllers prior to 5.2.
Step 3 Choose **Add Template** from the Select a command drop-down list, and click **Go**.

Step 4 Enter a name and group description for the access point group.

*Note* The group description is optional.

Step 5 Select the **WLAN Profile** check box.

*Note* To display all available WLAN profile names, delete the current WLAN profile name from the text box. When the current WLAN profile name is deleted from the text box, all available WLAN profiles appear in the drop-down list.

*Note* Each access point is limited to sixteen WLAN profiles. Each access point broadcasts all WLAN profiles unless the WLAN override feature is enabled. The WLAN override feature allows you to disable any of the 16 WLAN profiles per access point.

*Note* The WLAN override feature applies only to older controllers that do not support the 512 WLAN feature (can support up to 512 WLAN profiles).

Step 6 Type a WLAN profile name or choose one from the WLAN Profile Name drop-down list.

Step 7 Enter an interface/interface group or choose one from the Interface/Interface Group drop-down list.

*Note* To display all available interfaces, delete the current interface from the Interface text box. When the current interface is deleted from the Interface text box, all available interfaces appear in the drop-down list.

Step 8 Select the **NAC Override** check box, if applicable. NAC override is disabled by default.

Step 9 When access points and WLAN profiles are added, click **Add**.

*Note* After saving, click the edit icon on the WLAN Profiles tab to edit the WLAN profile information.

### Deleting Access Point Groups

To delete an access point group, follow these steps:

Step 1 Choose **Configure > Controller Template Launch Pad**.

Step 2 Click **AP Groups** or choose **WLAN > AP Groups** from the left sidebar menu.

Step 3 Click **Remove**.
Configuring H-REAP Templates

This section contains the following topics:

- Configuring H-REAP AP Groups Templates, page 11-41
- Configuring H-REAP Users, page 11-43

Configuring H-REAP AP Groups Templates

Hybrid REAP enables you to configure and control access points in a branch or remote office from the corporate office through a wide area network (WAN) link without deploying a controller in each office. There is no deployment restriction on the number of hybrid-REAP access points per location, but you can organize and group the access points per floor and limit them to 25 or so per building, since it is likely the branch offices share the same configuration.

To set up an H-REAP AP group, follow these steps:

---

**Step 1** Choose **Configure > Controller Template Launch Pad**.

**Step 2** Click **H-REAP AP Groups** or choose **H-REAP > H-REAP AP Groups** from the left sidebar menu. The H-REAP > H-REAP AP Groups page appears. It displays the primary and secondary RADIUS, as well as the number of controllers and virtual domains that the template is applied to, which automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3** If you want to add a new template, choose **Add Template** from the Select a command drop-down list, and click **Go**. To modify an existing template, click the template name. The General tab of the H-REAP AP Groups page appears (see **Figure 11-17**).
The Template Name parameter shows the group name assigned to the H-REAP access point group.

Choose the primary RADIUS authentication servers for each group. If a RADIUS authentication server is not present on the controller, the WCS configured RADIUS server does not apply. A value of 10 indicates that the primary RADIUS server is not configured for this group.

Choose the secondary RADIUS authentication servers for each group. If a RADIUS authentication server is not present on the controller, the WCS configured RADIUS server does not apply. A value of 0 indicates that the primary RADIUS server is not configured for this group.

If you want to add an access point to the group, click the H-REAP AP tab.

An access point Ethernet MAC address cannot exist in more than one H-REAP group on the same controller. If more than one group is applied to the same controller, select the Ethernet MAC check box to unselect an access point from one of the groups. You should save this change or apply it to controllers.

Click Add AP. The H-REAP AP Group page appears.

Click the H-REAP Configuration tab to enable local authentication for a hybrid REAP group.

Make sure that the Primary RADIUS Server and Secondary RADIUS Server parameters are set to None on the General tab.

Select the H-REAP Local Authentication check box to enable local authentication for this hybrid-REAP group. The default value is unselected.
Configuring Controller Templates

Note When you attempt to use this feature, a warning message indicates that it is a licensed feature.

Note You can click the Users configured in the group link that appears at the bottom of the page to view the list of H-REAP users. You can create H-REAP users only after you save the H-REAP AP Group.

Step 12 To allow a hybrid-REAP access point to authenticate clients using LEAP, select the LEAP check box. Otherwise, to allow a hybrid-REAP access point to authenticate clients using EAP-FAST, select the EAP-FAST check box.

Step 13 Perform one of the following, depending on how you want protected access credentials (PACs) to be provisioned:
   - To use manual PAC provisioning, enter the key used to encrypt and decrypt PACs in the EAP-FAST Key and Confirm EAP-FAST Key text box. The key must be 32 hexadecimal characters.
   - To allow PACs to be sent automatically to clients that do not have one during PAC provisioning, select the Auto key generation check box.

Step 14 In the EAP-FAST Key text box, enter the authority identifier of the EAP-FAST server. The identifier must be 32 hexadecimal characters.

Step 15 In the EAP-FAST Authority ID text box, enter the authority identifier of the EAP-FAST server in text format. You can enter up to 32 hexadecimal characters.

Step 16 In the EAP-FAST Pac Timeout text box, specify a PAC timeout value by entering the number of seconds for the PAC to remain viable in the edit box. The valid range is 2 to 4095 seconds.

Step 17 Click Save.

Configuring H-REAP Users

Note You can create H-REAP users only after you save the H-REAP AP Group.

Note Maximum 100 H-REAP users are supported from 5.2.x.x controller version. If controller version is less than 5.2.0.0, only 20 H-REAP users are supported.

To configure a H-REAP user, follow these steps:

Step 1 Choose Configure > Controller Template Launch Pad.

Step 2 Click H-REAP AP Groups or choose H-REAP > H-REAP AP Groups from the left sidebar menu. The H-REAP > H-REAP AP Groups page appears.

Step 3 Click the H-REAP Configuration tab to enable local authentication for a hybrid REAP group.

Step 4 Select the H-REAP Local Authentication check box to enable local authentication for this hybrid-REAP group.

Step 5 Click the Users configured in the group link. The H-REAP Users page appears.
Configuring Controller Templates

Chapter 11      Using Templates

Step 6     If you want to add a new user, choose **Add User** from the Select a command drop-down list, and click **Go**. The **Add User** page appears.

Step 7     In the **User Name** text box, enter the H-REAP username.

Step 8     In the **Password** text box, enter the password.

Step 9     Re-enter the password in the **Confirm Password** text box.

Step 10    Click **Save**.

---

**Note**
To delete a H-REAP User, choose a user from the H-REAP Users list, and then click **Delete**.

---

Configuring Security Templates

This section contains the following topics:

- Configuring a General Security Controller Template, page 11-44
- Configuring a File Encryption Template, page 11-45
- Configuring a RADIUS Authentication Template, page 11-46
- Configuring a RADIUS Accounting Template, page 11-49
- Configuring a RADIUS Fallback Template, page 11-50
- Configuring an LDAP Server Template, page 11-52
- Configuring a TACACS+ Server Template, page 11-54
- Configuring a Local EAP General Template, page 11-55
- Configuring a Local EAP Profile Template, page 11-56
- Configuring an EAP-FAST Template, page 11-58
- Configuring a Network User Credential Retrieval Priority Template, page 11-60
- Configuring a Local Network Users Template, page 11-61
- Configuring a Guest User Template, page 11-63
- Configuring a User Login Policies Template, page 11-65
- Configuring a MAC Filter Template, page 11-66
- Configuring an Access Point or MSE Authorization Template, page 11-68
- Configuring a Manually Disabled Client Template, page 11-69
- Configuring a Client Exclusion Policies Template, page 11-70
- Configuring an Access Point Authentication and MFP Template, page 11-72
- Configuring a Web Authentication Template, page 11-73
- Configuring an External Web Auth Server Template, page 11-78

Configuring a General Security Controller Template

To add a new template with general security information for a controller, follow these steps:
Chapter 11 Using Templates

Configuring Controller Templates

Step 1  Choose Configure > Controller Template Launch Pad.

Step 2  Click New beside the template you want to add.

Step 3  Add or modify the following parameters:

- Template Name

  Note  Template Name is the unique key used to identify the template. A template name is mandatory to distinguish between two templates that have identical key attributes.

- Maximum Local Database Entries (on next reboot)—Enter the maximum number of allowed database entries. This amount becomes effective on the next reboot.

Step 4  Click Save. Once saved, the template appears in the Template List page. In the Template List page, you can apply this template to controllers. See the “Applying Controller Templates” section on page 11-2 for more information.

Configuring a File Encryption Template

This page enables you to add a file encryption template or make modifications to an existing file encryption template.

To configure a File Encryption template, follow these steps:

Step 1  Choose Configure > Controller Template Launch Pad.

Step 2  Click File Encryption or choose Security > File Encryption from the left sidebar menu. The Security > File Encryption page appears. The number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 3  If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The File Encryption template page appears (see Figure 11-18).
**Figure 11-18  File Encryption Template**

**Step 4** Check if you want to enable file encryption.

**Step 5** Enter an encryption key text string of exactly 16 ASCII characters.

**Step 6** Retype the encryption key.

**Step 7** Click **Save**.

---

**Configuring a RADIUS Authentication Template**

This page allows you to add a RADIUS authentication template or make modifications to an existing template. After these server templates are configured, controller users who log into the controller through the CLI or GUI are authenticated.

To configure a RADIUS Authentication template, follow these steps:

**Step 1** Choose **Configure > Controller Template Launch Pad**.
Step 2  Click **RADIUS Auth Servers** or choose **Security > RADIUS Auth Servers** from the left sidebar menu. The Security > RADIUS Auth Servers page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The IP address of the RADIUS server and the port number and admin status for the interface protocol is also displayed. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 3  If you want to add a new template, choose **Add Template** from the Select a command drop-down list, and click **Go**. To modify an existing template, click the template name. The RADIUS Auth Servers template page appears (see Figure 11-19).

![Figure 11-19 RADIUS Authentication Server Template](image)

**Figure 11-19  RADIUS Authentication Server Template**

Step 4  Use the Shared Secret Format drop-down list to choose either ASCII or hex shared secret format.
Step 5 Enter the RADIUS shared secret used by your specified server.

Step 6 If you select the key wrap check box, the authentication request is sent to RADIUS servers that have key encryption key (KEK) and message authenticator code keys (MACK) configured. When enabled, the following parameters appear:

- **Shared Secret Format**: Determine whether ASCII or hexadecimal.
- **KEK Shared Secret**: Enter KEK shared secret.
- **MACK Shared Secret**: Enter MACK shared secret.

**Note** Regardless of the format you choose, for security reasons, only ASCII is visible on the WLC (and WCS). For this reason, you cannot use a template to replicate the configuration on a second controller during auto provisioning. You should set the key format again in the template in case a discovered template is applied to another device.

Step 7 If you want to enable administration privileges, select the **Admin Status** check box.

Step 8 If you want to enable support for RFC 3576, select the **Support for RFC 3576** check box. RFC 3576 is an extension to the Remote Authentication Dial In User Service (RADIUS) protocol. It allows dynamic changes to a user session and includes support for disconnecting users and changing authorizations applicable to a user session. With these authorizations, support is provided for Disconnect and Change-of-Authorization (CoA) messages. Disconnect messages immediately terminate a user session, whereas CoA messages modify session authorization attributes such as data filters.

Step 9 If you want to enable network user authentication, select the **Network User** check box. If this option is enabled, this entry is considered as the RADIUS authenticating server for the network user.

Step 10 If you want to enable management authentication, select the **Management User** check box. If this option is enabled, this entry is considered as the RADIUS authenticating server for the management user.

Step 11 Specify the time in seconds after which the RADIUS authentication request times out and a retransmission is attempted by the controller. You can specify a value between 2 and 30 seconds.

Step 12 Select the **IPsec** check box to enable the IP security mechanism. If this option is enabled, additional IP security parameters are added to the page, and Steps 13 to 19 are required. If you disable it, click **Save** and skip Steps 13 to 19.

Step 13 Use the drop-down list to choose which IP security authentication protocol to use. The options are HMAC-SHA1, HMAC-MD5, and None.

**Note** Each time the controller is notified with the shared secret, the existing shared secret is overwritten with the new shared secret.

Message Authentication Codes (MAC) are used between two parties that share a secret key to validate information transmitted between them. HMAC (Hash MAC) is a mechanism based on cryptographic hash functions and can be used in combination with any iterated cryptographic hash function.
HMAC-MD5 and HMAC-SHA1 are two constructs of the HMAC using the MD5 hash function and the SHA1 hash function. HMAC also uses a secret key for calculation and verification of the message authentication values.

**Step 14** Set the IP security encryption mechanism to use. The options are as follows:
- DES—Data Encryption Standard is a method of data encryption using a private (secret) key. DES applies a 56-bit key to each 64-bit block of data.
- Triple DES—Data Encryption Standard that applies three keys in succession.
- AES 128 CBC—Advanced Encryption Standard uses keys with a length of 128, 192, or 256 bits to encrypt blocks with a length of 128, 192, or 256 bits. AES 128 CBC uses a 128-bit data path in Cipher Clock Chaining (CBC) mode.
- None—No IP security encryption mechanism.

**Step 15** The Internet Key Exchange (IKE) authentication is not an editable text box. Internet Key Exchange protocol (IKE) is used as a method of distributing the session keys (encryption and authentication), as well as providing a way for the VPN endpoints to agree on how data should be protected. IKE keeps track of connections by assigning a bundle of security associations (SAs) to each connection.

**Step 16** Use the IKE phase 1 drop-down list to choose either aggressive or main. This sets the IKE protocol. IKE phase 1 is used to negotiate how IKE is protected. Aggressive mode passes more information in fewer packets, with the benefit of a slightly faster connection, at the cost of transmitting the identities of the security gateways in the clear.

**Step 17** At the Lifetime parameter, set the timeout interval (in seconds) when the session expires.

**Step 18** Set the IKE Diffie Hellman group. The options are group 1 (768 bits), group 2 (1024 bits), or group 5 (1536 bits). Diffie-Hellman techniques are used by two devices to generate a symmetric key where you can publicly exchange values and generate the same symmetric key.

Although all three groups provide security from conventional attacks, Group 5 is considered more secure because of its larger key size. However, computations involving Group 1 and Group 2 based keys might occur slightly faster because of their smaller prime number size.

**Step 19** Click Save.

---

**Configuring a RADIUS Accounting Template**

This page allows you to add a RADIUS accounting template or make modifications to an existing RADIUS accounting template.

To configure a RADIUS Accounting template, follow these steps:

**Step 1** Choose **Configure > Controller Template Launch Pad**.

**Step 2** Click **RADIUS Acct Servers** or choose **Security > RADIUS Acct Servers** from the left sidebar menu. The Security > RADIUS Acct Servers page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The IP address of the RADIUS server and the port number and admin status for the interface protocols are also displayed. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.
Configuring Controller Templates

**Step 3** If you want to add a new template, choose **Add Template** from the Select a command drop-down list, and click **Go**. To modify an existing template, click the template name. The RADIUS Accounting Server template page appears (see Figure 11-20).

![Figure 11-20 RADIUS Accounting Server Templates](image)

**Step 4** Use the Shared Secret Format drop-down list to choose either ASCII or hexadecimal.

**Note** Regardless of the format you choose, for security reasons, only ASCII is visible on the WLC (and WCS). For this reason, you cannot use a template to replicate the configuration on a second controller during auto provisioning. You should set the key format again in the template in case a discovered template is applied to another device.

**Step 5** Enter the RADIUS shared secret used by your specified server.

**Step 6** Retype the shared secret.

**Step 7** If you want to establish administrative privileges for the server, select the **Admin Status** check box.

**Step 8** If you want to enable the network user authentication, select the **Network User** check box. If this option is enabled, this entry is considered as the RADIUS authenticating server for the network user.

**Step 9** Specify the time in seconds after which the RADIUS authentication request will timeout and a retransmission by the controller will occur. You can specify a value between 2 and 30 seconds.

**Step 10** Select the **IPsec** check box to enable the IP security mechanism.

**Step 11** Click **Save**.

---

**Configuring a RADIUS Fallback Template**

This page allows you to add a RADIUS fallback template or make modifications to an existing RADIUS fallback template.
To configuring a RADIUS Fallback template, follow these steps:

**Step 1** Choose Configure > Controller Template Launch Pad.

**Step 2** Click RADIUS Fallback or choose Security > RADIUS Fallback from the left sidebar menu. The Security > RADIUS Fallback page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3** If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The RADIUS Fallback template page appears (see Figure 11-21).

**Figure 11-21  RADIUS Fallback Page**

**Step 4** From the RADIUS Fallback Mode drop-down list, choose Off, Passive, or Active.
Step 5  
Click Save.

Configuring an LDAP Server Template

This section explains how to configure a Lightweight Directory Access Protocol (LDAP) server as a backend database, similar to a RADIUS or local user database. An LDAP backend database allows the controller to query an LDAP server for the credentials (username and password) of a particular user. These credentials are then used to authenticate the user. For example, local EAP may use an LDAP server as its backend database to retrieve user credentials.

To add an LDAP server template or make modifications to an existing LDAP server template, follow these steps:

Step 1  
Choose Configure > Controller Template Launch Pad.

Step 2  
Click LDAP Servers or choose Security > LDAP Servers from the left sidebar menu. The Security > LDAP Servers page appear. The IP address of the LDAP server and the port number for the interface protocols are displayed. Also, the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 3  
If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The LDAP Server template page appears (see Figure 11-22).
Step 4  The port number of the controller to which the access point is connected. The range is 1 to 65535.

Step 5  From the Bind Type drop-down list, choose Authenticated or Anonymous. If you choose Authenticated, you must enter a bind username and password as well. A bind is a socket opening that performs a lookup. Anonymous bind requests are rejected.

Step 6  In the Server User Base DN text box, enter the distinguished name of the subtree in the LDAP server that contains a list of all the users.

Step 7  In the Server User Attribute text box, enter the attribute that contains the username in the LDAP server.

Step 8  In the Server User Type text box, enter the ObjectType attribute that identifies the user.

Step 9  In the Retransmit Timeout text box, enter the number of seconds between retransmissions. The valid range is 2 to 30 seconds, and the default value is 2 seconds.

Step 10  Select the Admin Status check box if you want the LDAP server to have administrative privileges.

Step 11  Click Save.
Configuring TACACS+ Server Template

This page allows you to add a TACACS+ server or make modifications to an existing TACACS+ server template. After these server templates are configured, controller users who log into the controller through the CLI or GUI are authenticated.

To configure a TACACS+ Server template, follow these steps:

**Step 1** Choose Configure > Controller Template Launch Pad.

**Step 2** Click TACACS+ Server or choose Security > TACACS+ Server from the left sidebar menu. The Security > TACACS+ Servers page appears. The IP address and the port number and admin of the TACACS+ template are displayed. Also, the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3** If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The TACACS+ Servers template page appears (see Figure 11-23).

**Figure 11-23 TACACS+ Server Template**

**Step 4** Select the server type. The choices are authentication, authorization, or accounting.

**Step 5** Use the drop-down list to choose either ASCII or hex shared secret format.
Configuring Controller Templates

Note Regardless of which format you choose, for security reasons, only ASCII is visible on the WLC (and WCS). For this reason, you cannot use a template to replicate the configuration on a second controller during auto provisioning. Set the key format again in the template in the event a discovered template is applied to another device.

Step 6 Enter the TACACS+ shared secret used by your specified server.

Step 7 Re-enter the shared secret in the Confirm Shared Secret text box.

Step 8 Select the Admin Status check box if you want the TACACS+ server to have administrative privileges.

Step 9 Specify the time in seconds after which the TACACS+ authentication request times out and a retransmission is attempted by the controller.

Step 10 Click Save.

Configuring a Local EAP General Template

This page allows you to specify a timeout value for local EAP. You can then add or make changes to an existing local EAP general template.

Note If any RADIUS servers are configured on the controller, the controller tries to authenticate the wireless clients using the RADIUS servers first. Local EAP is attempted only if no RADIUS servers are found, either because the RADIUS servers timed out or no RADIUS servers were configured. If four RADIUS servers are configured, the controller attempts to authenticate the client with the first RADIUS server, then the second RADIUS server, and then local EAP. If the client attempts to then reauthenticate manually, the controller tries the third RADIUS server, then the fourth RADIUS server, and then local EAP.

Step 1 Choose Configure > Controller Template Launch Pad.

Step 2 Click Local EAP General or choose Security > Local EAP General from the left sidebar menu. The Security > Local EAP General page appears. The number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 3 If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The Local EAP General controller template page appears (see Figure 11-24).
Step 4  In the Local Auth Active Timeout text box, enter the amount of time (in seconds) that the controller attempts to authenticate wireless clients using local EAP after any pair of configured RADIUS servers fail. The valid range is 1 to 3600 seconds, and the default setting is 1000 seconds.

Step 5  The following values should be adjusted if you are using EAP-FAST, manual password entry, one-time password, or 7920/7921 phones. You must increase the 802.1x timeout values on the controller (default=2 seconds) for the client to obtain the PAC using automatic provisioning. The recommended and default timeout on the Cisco ACS server is 20 seconds.

Note  Roaming fails if these values are not set the same across multiple controllers.

- Local EAP Identify Request Timeout =1
- Local EAP Identity Request Maximum Retries=20
- Local EAP Dynamic WEP Key Index=0
- Local EAP Request Timeout=20
- Local EAP Request Maximum Retries=2

Step 6  Click Save.

Configuring a Local EAP Profile Template

This page allows you to add a local EAP profile template or make modifications to an existing template. Local EAP is an authentication method that allows users and wireless clients to be authenticated locally. It is designed for use in remote offices that want to maintain connectivity to wireless clients when the backend system becomes disrupted or the external authentication server goes down. When you enable
local EAP, the controller serves as the authentication server and the local user database, thereby removing dependence on an external authentication server. Local EAP retrieves user credentials from the local user database or the LDAP backend database to authenticate users.

**Note**
The LDAP backend database supports only these local EAP methods: EAP-TLS and EAP-FAST with certificates. LEAP and EAP-FAST with PACs are not supported for use with the LDAP backend database.

**Step 1** Choose Configure > Controller Template Launch Pad.

**Step 2** Click Local EAP Profiles or choose Security > Local EAP Profiles from the left sidebar menu. The Security > Local EAP Profiles page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. It also shows the EAP profile name and indicates whether LEAP, EAP-FAST, TLS, or PEAP is used. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3** If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The Local EAP Profiles template page appears (see Figure 11-25).

**Figure 11-25 Local EAP Profiles Template**
Step 4 Each EAP profile must be associated with an authentication type(s). Choose the desired authentication type:

- LEAP—This authentication type leverages Cisco Key Integrity Protocol (CKIP) and MMH message integrity check (MIC) for data protection. A username and password are used to perform mutual authentication with the RADIUS server through the access point.

- EAP-FAST—This authentication type (Flexible Authentication via Secure Tunneling) uses a three-phased tunnel authentication process to provide advanced 802.1X EAP mutual authentication. A username, password, and PAC (protected access credential) are used to perform mutual authentication with the RADIUS server through the access point.

- TLS—This authentication type uses a dynamic session-based WEP key derived from the client adapter and RADIUS server to encrypt data. It requires a client certificate for authentication.

- PEAP—This authentication type is based on EAP-TLS authentication but uses a password instead of a client certificate for authentication. PEAP uses a dynamic session-based WEP key derived from the client adapter and RADIUS server to encrypt data.

Step 5 Use the Certificate Issuer drop-down list to determine whether Cisco or another vendor issued the certificate for authentication. Only EAP-FAST and TLS require a certificate.

Step 6 If you want the incoming certificate from the client to be validated against the certificate authority (CA) certificates on the controller, select the Check Against CA Certificates check box.

Step 7 If you want the common name (CN) in the incoming certificate to be validated against the CA certificates’ CN on the controller, select the Verify Certificate CN Identity check box.

Step 8 If you want the controller to verify that the incoming device certificate is still valid and has not expired, select the Check Against Date Validity check box.

Step 9 If a local certificate is required, select the check box.

Step 10 If a client certificate is required, select the check box.

Step 11 Click Save.

Step 12 To enable local EAP, follow these steps:

a. Choose WLAN > WLAN Configuration from the left sidebar menu.

b. Click the profile name of the desired WLAN.

c. Click the Security > AAA Servers tab to access the AAA Servers page.

d. Select the Local EAP Authentication check box to enable local EAP for this WLAN.

Step 13 Click Save.

---

Configuring an EAP-FAST Template

This authentication type (Flexible Authentication via Secure Tunneling) uses a three-phased tunnel authentication process to provide advanced 802.1X EAP mutual authentication. A username, password, and PAC are used to perform mutual authentication with the RADIUS server through the access point. This page allows you to add an EAP-FAST template or make modifications to an existing EAP-FAST template.

Step 1 Choose Configure > Controller Template Launch Pad.
Step 2 Click EAP-FAST Parameters or choose Security > EAP-FAST Parameters from the left sidebar menu. The Security > EAP-FAST Parameters page appears. The number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 3 If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The EAP-FAST Parameters template page appears (see Figure 11-26).

Figure 11-26 EAP-FAST Parameters Template

Step 4 In the Time to Live for the PAC text box, enter the number of days for the PAC to remain viable. The valid range is 1 to 1000 days, and the default setting is 10 days.

Step 5 In the Authority ID text box, enter the authority identifier of the local EAP-FAST server in hexadecimal characters. You can enter up to 32 hexadecimal characters, but you must enter an even number of characters.
Step 6 In the Authority ID text box, enter the ID for the authority identifier of the local EAP-FAST server.

Step 7 In the Authority Info text box, enter the authority identifier of the local EAP-FAST server in text format.

Step 8 In the Server Key and Confirm Server Key fields, enter the key (in hexadecimal characters) used to encrypt and decrypt PACs.

Step 9 If you want to enable anonymous provisioning, select the **Anonymous Provision** check box. This feature allows PACs to be sent automatically to clients that do not have one during PAC provisioning. If you disable this feature, PACs must be manually provisioned.

Step 10 Click **Save**.

---

### Configuring a Network User Credential Retrieval Priority Template

You can specify the order that LDAP and local databases use to retrieve user credential information. This page allows you to add or make modifications to an existing network user credential retrieval priority template.

Step 1 Choose **Configure > Controller Template Launch Pad**.

Step 2 Click **Network Users Priority** or choose **Security > Network Users Priority** from the left sidebar menu. The Security > Network User Credential Retrieval Priority page appears. The network retrieval order and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 3 If you want to add a new template, choose **Add Template** from the Select a command drop-down list, and click **Go**. To modify an existing template, click the template name. The Network Users Priority template page appears (see **Figure 11-27**).
Step 4 Use the left and right pointing arrows to include or disclude network user credentials in the right page.

Step 5 Use the up and down buttons to determine the order credentials are tried.

Step 6 Click Save.

Configuring a Local Network Users Template

With this template, you can store the credentials (username and password) of all the local network users. These credentials are then used to authenticate the users. For example, local EAP may use the local user database as its backend database to retrieve user credentials. This page allows you to add or make modifications to an existing local network user template. You must create a local net user and define a password when logging in as a web authentication client.

To configure a Local Network Users template, follow these steps:

Step 1 Choose Configure > Controller Template Launch Pad.
Step 2  Click **Local Net Users** or choose **Security > Local Net Users** from the left sidebar menu. The Security > Local Net Users page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 3  If you want to add a new template, choose **Add Template** from the Select a command drop-down list, and click **Go**. To modify an existing template, click the template name. The Local Net Users template page appears (see Figure 11-28).

**Figure 11-28  Local Net Users Template**

Step 4  If you keep Import from File enabled, you need to enter a file path or click the Browse button to navigate to the file path. Then continue to Step 11. If you disable the import, continue to Step 5.

**Note**  You can only import a .csv file. Any other file formats are not supported.

The first row in the file is the header. The data in the header is not read by WCS. The header can either be blank or filled. The Cisco WCS reads data from the second row onwards.

Step 5  Enter a username and password. It is mandatory to fill the Username and Password fields in all the rows.

Step 6  Enter a profile. The Profile column if left blank (or filled in with *any profile*) means a client on any profile can use this account.

Step 7  Enter a description of the profile.

Step 8  Use the drop-down list to choose the SSID which this local user is applied to or choose the *any SSID* option.

Step 9  Enter a user-defined description of this interface. Skip to Step 11.

Step 10  If you want to override the existing template parameter, click the **Override existing templates** check box.
Step 11 Click Save.

Configuring a Guest User Template

This page allows you to add a guest user template or make modifications to an existing guest user template. The purpose of a guest user account is to provide a user account for a limited amount of time. A Lobby Ambassador is able to configure a specific time frame for the guest user account to be active. After the specified time period, the guest user account automatically expires. See the “Creating Guest User Accounts” section on page 7-11 for further information on guest access.

Step 1 Choose Configure > Controller Template Launch Pad.
Step 2 Click Guest Users or choose Security > Guest Users from the left sidebar menu. The Security > Guest User page appears.

Note To reduce clutter, WCS does not show expired templates by default. You can specify which guest users to filter based on their status (active, scheduled, expired, not active, or none). Use the Select a Status Filter drop-down list to determine the filter criteria.

Step 3 If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The Guest Users template page appears (see Figure 11-29).
Figure 11-29 Guest User Template

Step 4 Enter a guest name. Maximum size is 24 characters.
Step 5 Enter a password for this username.
Step 6 Click the Advanced tab.
Step 7 Use the Profile drop-down list to choose the guest user to connect to.
Step 8 Choose a user role for the guest user from the drop-down list. User roles are predefined by the administrator and are associated with the guests’ access (such as contractor, customer, partner, vendor, visitor, and so on).

User Role is used to manage the amount of bandwidth allocated to specific users within the network.

Step 9 Define how long the guest user account will be active by choosing either the Limited or Unlimited Lifetime option.

- For the limited option, you choose the period of time that the guest user account is active using the hours and minutes drop-down lists. The default value for Limited is one day (8 hours).
- When Unlimited is chosen, there is no expiration date for the guest account.

Step 10 Choose the area (indoor, outdoor), controller list, or config group to which the guest user traffic is limited from the Apply to drop-down list.
If you choose the controller list option, a list of controller IP addresses appears.

**Step 11** (Optionally) Modify the default guest user description on the General tab if necessary.

**Step 12** (Optionally) Modify the Disclaimer text on the General tab, if necessary. If you want the supplied text to be the default, select the **Make this Disclaimer default** check box.

**Step 13** Click **Save**.

---

### Configuring a User Login Policies Template

This page allows you to add a user login template or make modifications to an existing user login policies template. On this template you set the maximum number of concurrent logins that each single user can have.

**Step 1** Choose **Configure > Controller Template Launch Pad**.

**Step 2** Click **User Login Policies** or choose **Security > User Login Policies** from the left sidebar menu. The Security > User Login Policies page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3** If you want to add a new template, choose **Add Template** from the Select a command drop-down list, and click **Go**. To modify an existing template, click the template name. The User Login Policies template page appears (see **Figure 11-30**).
Step 4 You can adjust the maximum number of concurrent logins each single user can have.

Step 5 Click Save to keep this template.

Configuring a MAC Filter Template

This page allows you to add a MAC filter template or make modifications to an existing MAC filter template.

Step 1 Choose Configure > Controller Template Launch Pad.

Step 2 Click MAC Filtering or choose Security > MAC Filtering from the left sidebar menu. The Security > MAC Filtering page appears.

Step 3 If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The MAC Filtering template page appears (see Figure 11-31).
Figure 11-31  MAC Filter Templates

Step 4  If you keep Import From File enabled, you need to enter a file path or click the Browse button to navigate to the file path. The import file must be a CSV file with MAC address, profile name, interface, and description (such as 00:11:22:33:44:55,Profile1,management,test filter). If you disable Import from File, continue to Step 5. Otherwise, skip to Step 8.

The client MAC address appears.

Step 5  Choose the profile name to which this MAC filter is applied or choose the any Profile option.

Step 6  Use the drop-down list to choose from the available interface names.

Step 7  Enter a user-defined description of this interface. Skip to Step 9.

Step 8  If you want to override the existing template parameter, click to enable this parameter.

Step 9  Click Save.
Configuring an Access Point or MSE Authorization Template

Follow these steps to add an MSE authorization or make changes to an existing access point or MSE authorization template. These templates are devised for Cisco 11xx/12xx series access points converted from Cisco IOS to lightweight access points or for 1030 access points connecting in bridge mode. See the Cisco Location Appliance Configuration Guide for further information.

**Step 1** Choose **Configure > Controller Template Launch Pad.**

**Step 2** Click **AP/MSE Authorization** or choose **Security > AP/MSE Authorization** from the left sidebar menu. The Security > AP/LBS Authorization Template appears, and the number of controllers and virtual domains that the template is applied to automatically populates. This initial page also shows the Base Radio MAC and the certificate type and key. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3** If you want to add a new template, choose **Add Template** from the Select a command drop-down list, and click **Go.** To modify an existing template, click the template name. The AP/MSE Authorization template page appears (see **Figure 11-32**).

**Figure 11-32  AP/MSE Authorization Templates**
Step 4 Select the Import from File check box if you want to import a file containing access point MAC addresses.

Note You can only import a .csv file. The .csv file format parallels the fields in the GUI and therefore includes access point base radio MAC, Type, Certificate Type (MIC or SSC), and key hash (such as 00:00:00:00:00:00, AP, SSC, xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx). Any other file formats are not supported.

Step 5 Enter the file path from where you want to import the file.

Step 6 Click Save.

Configuring a Manually Disabled Client Template

This page allows you to add a manually disable client template or make modifications to an existing disabled client template.

Step 1 Choose Configure > Controller Template Launch Pad.

Step 2 Click Disable Clients or choose Security > Disabled Clients from the left sidebar menu. The Security > Disabled Clients page appears.

Step 3 If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The Manually Disabled template page appears (see Figure 11-33).
Configuring Controller Templates

Follow these steps to add a client exclusion policies template or modify an existing client exclusion policies template.

**Step 1** Choose **Configure > Controller Template Launch Pad**.

**Step 2** Click **Client Exclusion Policies** or choose **Security > Client Exclusion Policies** from the left sidebar menu. The Security > Client Exclusion Policies page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.
The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3** If you want to add a new template, choose **Add Template** from the Select a command drop-down list, and click **Go**. To modify an existing template, click the template name. The Client Exclusion Policies template page appears (see Figure 11-34).

![Figure 11-34  Policies Template](image)

**Step 4** Edit a client exclusion policies template by configuring its parameters. (see Table 11-3)

<table>
<thead>
<tr>
<th><strong>Table 11-3  Policies Template Parameters</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Parameter</strong></td>
</tr>
<tr>
<td>Template Name</td>
</tr>
<tr>
<td>Excessive 802.11 Association Failures</td>
</tr>
<tr>
<td>Excessive 802.11 Authentication Failures</td>
</tr>
<tr>
<td>Excessive 802.1X Authentication Failures</td>
</tr>
</tbody>
</table>
### Configuring Controller Templates

**Step 5** Click **Save**.

### Configuring an Access Point Authentication and MFP Template

Management Frame Protection (MFP) provides for the authentication of 802.11 management frames by the wireless network infrastructure. Management frames can be protected to detect adversaries who are invoking denial of service attacks, flooding the network with associations and probes, interjecting as rogue access points, and affecting the network performance by attacking the QoS and radio measurement frames.

When enabled, the access point protects the management frames it transmits by adding a message integrity check information element (MIC IE) to each frame. Any attempt to copy, alter, or replay the frame invalidates the MIC, causing any receiving access point configured to detect MFP frames to report the discrepancy. An access point must be a member of a WDS to transmit MFP frames.

When MFP detection is enabled, the access point validates every management frame that it receives from other access points in the network. It ensures that the MIC IE is present (when the originator is configured to transmit MFP frames) and matches the content of the management frame. If it receives any frame that does not contain a valid MIC IE from a BSSID belonging to an access point that is configured to transmit MFP frames, it reports the discrepancy to the network management system.

To add or make modifications for the access point authentication and management frame protection (MFP) template, follow these steps:

**Step 1** Choose **Configure > Controller Template Launch Pad**.

**Step 2** Click **AP Authentication and MFP** or choose **Security > AP Authentication and MFP** from the left sidebar menu. The Security > AP Authentication Policy Template appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3** If you want to add a new template, choose **Add Template** from the Select a command drop-down list, and click **Go**. To modify an existing template, click the template name. The AP Authentication and MFP template page appears (see Figure 11-35).
Step 4 From the Protection Type drop-down list, choose one of the following authentication policies:

- None: No access point authentication policy.
- AP Authentication: Apply authentication policy.
- MFP: Apply management frame protection.

Alarm trigger threshold appears only when AP authentication is selected as a protection type. Set the number of hits from an alien access point to ignore before raising an alarm. The valid range is from 1 to 255. The default value is 255.

Step 5 Click Save.

Configuring a Web Authentication Template

With web authentication, guests are automatically redirected to a web authentication page when they launch their browsers. Guests gain access to the WLAN through this web portal. Wireless LAN administrators using this authentication mechanism should have the option of providing unencrypted or encrypted guest access. Guest users can then log into the wireless network using a valid username and
password, which is encrypted with SSL. Web authentication accounts may be created locally or managed by a RADIUS server. The Cisco Wireless LAN controllers can be configured to support a web authentication client. You can use this template to replace the Web authentication page provided on the controller.

To add or make modifications to an existing web authentication template, follow these steps:

---

**Step 1** Choose *Configure > Controller Template Launch Pad*.

**Step 2** Click *Web Auth Configuration* or choose *Security > Web Auth Configuration* from the left sidebar menu. The Security > Web Authentication page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3** If you want to add a new template, choose *Add Template* from the Select a command drop-down list, and click *Go*. To modify an existing template, click the template name. The Web Authentication template page appears (see *Figure 11-36*).
Configuring Controller Templates

Figure 11-36  Web Authentication Configuration Template

Step 4  Choose the appropriate web authentication type from the drop-down list. The choices are default internal, customized web authentication, or external.

- If you choose default internal, you can still alter the page title, message, and redirect URL, as well as whether the logo appears. Continue to Step 5.

- If you choose customized web authentication, click Save and apply this template to the controller. You are prompted to download the web authentication bundle.

Note  Before you can choose customized web authentication, you must first download the bundle by going to Config > Controller and choose Download Customized Web Authentication from the Select a command drop-down list, and click Go.

- If you choose external, you need to enter the URL you want to redirect to after a successful authentication. For example, if the value entered for this text box is http://www.example.com, the user is directed to the company home page.

Step 5  If you want your company logo displayed, select the Logo Display check box.

Step 6  Enter the title you want displayed on the Web authentication page.
Configuring Controller Templates

Chapter 11 Using Templates

Step 7 Enter the message you want displayed on the Web authentication page.

Step 8 Provide the URL where the user is redirected after a successful authentication. For example, if the value entered for this text box is http://www.example.com, the user would be directed to the company home page.

Step 9 Click Save.

Downloading a Customized Web Authentication Page

You can download a customized Web authentication page to the controller. With a customized web page, you can establish a username and password for user web access.

When downloading customized web authentication, you must follow these strict guidelines:

- Provide a username.
- Provide a password.
- Retain a redirect URL as a hidden input item after extracting from the original URL.
- Extract the action URL and set aside from the original URL.
- Include scripts to decode the return status code.

Before downloading, follow these steps:

Step 1 Download the sample login.html bundle file from the server. The .html file is shown in Figure 11-37. The login page is presented to web users the first time they access the WLAN if web authentication is turned on.

Figure 11-37 Login.html

Web Authentication

User Name
Password
Submit

Step 2 Edit the login.html file and save it as a .tar or .zip file.

Note You can change the text of the Submit button to read Accept terms and conditions and Submit.

Step 3 Make sure you have a Trivial File Transfer Protocol (TFTP) server available for the download. Keep these guidelines in mind when setting up a TFTP server:
If you are downloading through the service port, the TFTP server must be on the same subnet as the service port because the service port is not routable. However, if you want to put the TFTP server on a different network while the management port is down, add a static route if the subnet where the service port resides has a gateway (config route add IP address of TFTP server).

If you are downloading through the distribution system network port, the TFTP server can be on the same or a different subnet because the distribution system port is routable.

A third-party TFTP server cannot run on the same computer as the WCS because WCS’s built-in TFTP server and third-party TFTP server use the same communication port.

Step 4 Download the .tar or .zip file to the controller(s).

Note The controller allows you to download up to 1 MB of a .tar file containing the pages and image files required for the Web authentication display. The 1 MB limit includes the total size of uncompressed files in the bundle.

You can now continue with the download.

Step 5 Copy the file to the default directory on your TFTP server.

Step 6 Choose Configure > Controllers.

Step 7 Choose a controller by clicking the URL for the corresponding IP address. If you select more than one IP address, the customized Web authentication page is downloaded to multiple controllers.

Step 8 From the left sidebar menu, choose System > Commands.

Step 9 From the Upload/Download Commands drop-down list, choose Download Customized Web Auth, and click Go.

Step 10 The IP address of the controller to receive the bundle and the current status are displayed.

Step 11 Choose local machine from the File is Located On parameter. If you know the filename and path relative to the server’s root directory, you can also select TFTP server.

Note For a local machine download, either .zip or .tar file options exists, but the WCS does the conversion of .zip to .tar automatically. If you chose a TFTP server download, only .tar files would be specified.

Step 12 Enter the maximum number of times the controller should attempt to download the file in the Maximum Retries parameter.

Step 13 Enter the maximum amount of time in seconds before the controller times out while attempting to download the file in the Timeout parameter.

Step 14 The files are uploaded to the c:\tftp directory. Specify the local file name in that directory or use the Browse button to navigate to it.

Step 15 Click OK.

If the transfer times out, you can simply choose the TFTP server option in the File Is Located On parameter, and the Server File Name is populated for you. The local machine option initiates a two-step operation. First, the local file is copied from the administrator’s workstation to WCS’s own built-in TFTP server. Then the controller retrieves that file. For later operations, the file is already in the WCS server’s TFTP directory, and the download web page now automatically populates the filename.

Step 16 Click the Click here to download a sample tar file link to get an option to open or save the login.tar file.
Step 17  After completing the download, you are directed to the new page and able to authenticate.

---

**Configuring an External Web Auth Server Template**

To create or modify an External Web Auth Server template, follow these steps:

**Step 1** Choose Configure > Controller Templates Launch Pad.

**Step 2** Click External Web Auth Server or choose Security > External Web Auth Server from the left sidebar menu. The External Web Auth Server Controller Templates page displays all currently saved External Web Auth Server templates. It also displays the number of controllers and virtual domains to which each template is applied.

**Step 3** Click a template name to open the Controller Template list page. From here, you can edit the current template parameters.

---

**Configuring a Security Password Policy Template**

This page enables you to determine your security password policy.

To add or make modifications to an existing password policy template, follow these steps:

**Step 1** Choose Configure > Controller Template Launch Pad.

**Step 2** Click Password Policy or choose Security > Password Policy from the left sidebar menu. The Security > Password Policy page appears.

**Step 3** If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The Password Policy template page appears (see Figure 11-42).
Figure 11-38  Password Policy Template

Step 4  Enter the template name.

Step 5  You can enable or disable the following settings:

- Password must contain characters from at least 3 different classes such as upper case letters, lower case letters, digits, and special characters.
- No character can be repeated more than 3 times consecutively.
- Password cannot be the default words like cisco, admin.
- Password cannot contain username or reverse of username.

Note  Password cannot be “cisco”, “ocsic”, “admin”, “nimda” or any variant obtained by changing the capitalization of letters, or by substituting ‘1” “l” or “!” for i, or substituting “0” for “o”, or substituting “$” for “s”.

Step 6  Click Save.

Configuring Security - Access Control Templates

This section contains the following topics:

- Configuring an Access Control List Template, page 11-80
- Configuring an ACL IP Groups Template, page 11-85
- Configuring an ACL Protocol Groups Template, page 11-85
Configuring an Access Control List Template

You can create or modify an ACL template for configuring the type of traffic that is allowed, by protocol, direction, and the source or destination of the traffic.

An access control list (ACL) is a set of rules used to limit access to a particular interface (for example, if you want to restrict a wireless client from pinging the management interface of the controller). ACLs can be applied to data traffic to and from wireless clients or to all traffic destined for the controller Central Processing Unit (CPU) and can now support reusable grouped IP addresses and reusable protocols. After ACLs are configured in the template, they can be applied to the management interface, the AP-manager interface, or any of the dynamic interfaces for client data traffic; to the Network Processing Unit (NPU) interface for traffic to the controller CPU; or to a WAN.

To add or modify an existing ACL template, follow these steps:

#### Step 1
Choose **Configure > Controller Template Launch Pad**.

#### Step 2
Click **Access Control Lists** or choose **Security > Access Control > Access Control Lists** in the left sidebar menu. The Security > Access Control List page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

#### Step 3
To create reusable grouped IP addresses and protocols, choose **Access Control > IP Groups** from the left sidebar menu.

#### Step 4
All the IP address groups are listed. One IP address group can have a maximum of 128 IP address and netmask combinations. To define a new IP address group, choose **Add IP Group** from the Select a command drop-down list, and click **Go**. To view or modify an existing IP address group, click the URL of the IP address group. The IP address group page opens (see Figure 11-39).

Note For the IP address of any, an *any* group is predefined.

---

**Figure 11-39  IP Groups Controller Template**
Step 5  In the ACL IP Groups details page you can edit the current IP group parameters.

- IP Group Name
- IP Address
- Netmask OR CIDR Notation—Enter the Netmask or CIDR Notation and then click Add. The list of IP addresses or Netmasks appears in the List of IP Address/Netmasks text box.

  CIDR notation allows you to add a large number of clients that exist in a subnet range by configuring a single client object.

  Netmask allows you to set the subnet mask in dotted-decimal notation rather than the CIDR notation for the IP address property.
  - Netmask—A range of IP addresses defined so that only machines with IP addresses within the range are allowed to access an Internet service.
  - CIDR—Classless InterDomain Routing. A protocol which allows the assignment of Class C IP addresses in multiple contiguous blocks.

- Broadcast/Network
- List of IP Addresses/Netmasks—Use the Move Up and Move Down buttons to rearrange the order of the list items. Use the Delete button to delete any IP address or Netmask.

Step 6  To define an additional protocol that is not a standard predefined one, choose Access Control > Protocol Groups from the left sidebar menu. The protocol groups with their source and destination port and DSCP are displayed.

Step 7  To create a new protocol group, choose Add Protocol Group from the Select a command drop-down list, and click Go. To view or modify an existing protocol group, click the URL of the group. The Protocol Groups page appears (see Figure 11-40).
Step 8 The rule name is provided for the existing rules, or you can now enter a name for a new rule. ACLs are not required to have rules defined. When a packet matches all the parameters of a rule, the action for this rule is exercised.

Step 9 Choose a protocol from the drop-down list:

- **Any**—All protocols
- **TCP**—Transmission Control Protocol
- **UDP**—User Datagram Protocol
- **ICMP**—Internet Control Message Protocol
- **ESP**—IP Encapsulating Security Payload
- **AH**—Authentication Header
- **GRE**—Generic Routing Encapsulation
- **IP**—Internet Protocol
- Eth Over IP—Ethernet over Internet Protocol
- Other Port OSPF—Open Shortest Path First
- Other—Any other IANA protocol (http://www.iana.org/)

**Step 10** Some protocol choices (such as TCP or UDP) cause additional Source Port and Dest Port GUI elements to appear.

- Source Port—Specify the source of the packets to which this ACL applies. The choices are Any, HTTP, HTTPS, Telnet, RADIUS, DHCP Server, DHCP Client, DNS, L2TP, PPTP control, FTP control, SMTP, SNMP, LDAP, Kerberos, NetBIOS NS, NetBIOS DS, NetBIOS SS, MS Dir Server, Other, and Port Range.

- Dest Port—Specify the destination of the packets to which this ACL applies. The choices are Any, HTTP, HTTPS, Telnet, RADIUS, DHCP Server, DHCP Client, DNS, L2TP, PPTP control, FTP control, SMTP, SNMP, LDAP, Kerberos, NetBIOS NS, NetBIOS DS, NetBIOS SS, MS Dir Server, Other, and Port Range.

**Step 11** From the DSCP (Differentiated Services Code Point) drop-down list, choose **any** or **specific**. If you choose specific, enter the DSCP (range of 0 to 255).

**Note** DSCP is a packet header code that can be used to define the quality of service across the Internet.

**Step 12** Click **Save**.

**Step 13** You can now create new mappings from the defined IP address groups and protocol groups. To define a new mapping, choose the ACL template to which you want to map the new groups. All ACL mappings appear on the top of the page, and all ACL rules appear on the bottom (see Figure 11-41).
Figure 11-41     Access Control List Rule Mapping

Step 14  To define a new mapping, choose **Add Rule Mappings** from the Select a command drop-down list. The Add Rule Mapping page appears.

Step 15  Choose the desired IP address groups, protocol groups, direction, and action, and click **Add**. The new mappings will populate the bottom table.

Step 16  Click **Save**.

Step 17  You can now automatically generate rules from the rule mappings you created. Choose the mappings for which you want to generate rules, and click **Generate**. This automatically creates the rules. These rules are generated with contiguous sequence. That is, if rules 1 through 4 are already defined and you add rule 29, it is added as rule 5.

Existing ACL templates are duplicated into a new ACL template. This duplication clones all the ACL rules and mappings defined in the source ACL template.
Configuring an ACL IP Groups Template

To create reusable grouped IP addresses, follow these steps:

**Step 1** Choose Configure > Controller Template Launch Pad.

**Step 2** Choose Access Control > IP Groups from the left sidebar menu.

**Step 3** All the IP address groups are listed. One IP address group can have a maximum of 128 IP address and netmask combinations. To define a new IP address group, choose Add IP Group from the Select a command drop-down list, and click Go.

**Note** For the IP address of any, an any group is predefined.

**Step 4** Add or modify the following parameters:
- IP Group Name
- IP Address
- Netmask OR CIDR Notation—Enter the Netmask or CIDR Notation and then click Add. The list of IP addresses or Netmasks appears in the List of IP Addresses/Netmasks text box.
  - Netmask—A range of IP addresses defined so that only machines with IP addresses within the range are allowed to access an Internet service.
  - CIDR—Classless InterDomain Routing. A protocol which allows the assignment of Class C IP addresses in multiple contiguous blocks.
- Broadcast/Network
- List of IP Addresses/Netmasks—Use the Move Up and Move Down buttons to rearrange the order of the list items. Use the Delete button to delete an IP address or Netmask.

**Step 5** Click Save. Once saved, the IP Group appears in the Template List page.

You can create new mappings from the defined IP address groups and protocol groups. To define a new mapping, choose the ACL template to which you want to map the new groups. All ACL mappings appear in the top of the page, and all ACL rules appear in the bottom. See the “Configuring an Access Control List Template” section on page 11-80 for more information.

See the “Configuring an ACL Protocol Groups Template” section on page 11-85 for information on defining Protocol Groups.

Configuring an ACL Protocol Groups Template

To define an additional protocol that is not a standard predefined one, follow these steps:

**Step 1** Choose Configure > Controller Template Launch Pad.

**Step 2** Choose Access Control > Protocol Groups from the left sidebar menu.
Chapter 11      Using Templates

**Configuring Controller Templates**

**Step 3** Add or modify the following parameters:

- **Rule Name**—The rule name is provided for the existing rules, or you can now enter a name for a new rule. ACLs are not required to have rules defined. When a packet matches all the parameters of a rule, the action for this rule is exercised.

  **Note** See the “Configuring an Access Control List Template” section on page 11-80 for more information on ACLs.

  - **Protocol**—Choose a protocol from the drop-down list:
    - Any—All protocols
    - TCP—Transmission Control Protocol
    - UDP—User Datagram Protocol
    - ICMP—Internet Control Message Protocol
    - ESP—IP Encapsulating Security Payload
    - AH—Authentication Header
    - GRE—Generic Routing Encapsulation
    - IP—Internet Protocol
    - Eth Over IP—Ethernet over Internet Protocol
    - Other Port OSPF—Open Shortest Path First
    - Other—Any other IANA protocol (http://www.iana.org/)

  - **Source Port**—Can be Any, HTTP, HTTPS, Telnet, RADIUS, DHCP Server, DHCP Client, DNS, L2TP, PPTP control, FTP control, SMTP, SNMP, LDAP, Kerberos, NetBIOS NS, NetBIOS DS, NetBIOS SS, MS Dir Server, Other and Port Range.

  - **Dest Port**—Destination port. If TCP or UDP is selected, can be Any, HTTP, HTTPS, Telnet, RADIUS, DHCP Server, DHCP Client, DNS, L2TP, PPTP control, FTP control, SMTP, SNMP, LDAP, Kerberos, NetBIOS NS, NetBIOS DS, NetBIOS SS, MS Dir Server, Other and Port Range.

  - **DSCP (Differentiated Services Code Point)**—Choose Any or Specific from the drop-down list. If Specific is selected, enter the DSCP (range of 0 through 255).

    **Note** DSCP is a packet header code that can be used to define the quality of service across the Internet.

**Step 4** Click **Save**. Once saved, the IP Group displays in the Template List page.

You can create new mappings from the defined IP address groups and protocol groups. To define a new mapping, choose the ACL template to which you want to map the new groups. All ACL mappings appear in the top of the page, and all ACL rules appear in the bottom. See the “Configuring an Access Control List Template” section on page 11-80 for more information.

See the “Configuring an ACL IP Groups Template” section on page 11-85 for information on defining IP Groups.
Configuring Security - CPU Access Control List Templates

This section contains the following topics:

- Configuring a CPU Access Control List (ACL) Template, page 11-87

Configuring a CPU Access Control List (ACL) Template

The existing ACLs established in the “Configuring an Access Control List Template” section on page 11-80 is used to set traffic controls between the Central Processing Unit (CPU) and Network Processing Unit (NPU).

To add or modify an existing CPU ACL template, follow these steps:

---

**Step 1** Choose Configure > Controller Template Launch Pad.

**Step 2** Click CPU Access Control Lists or choose Security > CPU Access Control > CPU Access Control List from the left sidebar menu. The Security > CPU Access Control List page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3** If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The CPU Access Control List template page appears (see Figure 11-42).
Step 4 If you select the CPU ACL check box, two more parameters appear. When CPU ACL is enabled and applied on the controller, WCS displays the details of the CPU ACL against that controller.

Step 5 From the ACL Name drop-down list, choose a name from the list of defined names.

Step 6 From the CPU ACL Mode drop-down list, choose which data traffic direction this CPU ACL list controls. The choices are the wired side of the data traffic, the wireless side of the data traffic, or both wired and wireless.

Step 7 Click Save.

Configuring Security - Rogue Templates

This section contains the following topics:

- Configuring a Rogue Policies Template, page 11-89
- Configuring a Rogue AP Rules Template, page 11-90
• Configuring a Rogue AP Rule Groups Template, page 11-92
• Configuring a Friendly Access Point Template, page 11-94

Configuring a Rogue Policies Template

This page enables you to configure the rogue policy (for access points and clients) applied to the controller.

To add or modify an existing template, follow these steps:

**Step 1** Choose Configure > Controller Template Launch Pad.

**Step 2** Click Rogue Policies or choose Security > Rogue > Rogue Policies from the left sidebar menu. The Security > Rogue Policy Setup page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3** If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The Rogue Policies template page appears (see Figure 11-43).

**Figure 11-43 Rogue Policy Setup Template**

**Step 4** Determine whether or not the Rogue Location Discovery Protocol (RLDP) is connected to the enterprise wired network. Choose one of the following from the drop-down list:

• Disable—Disables RLDP on all access points.
• All APs—Enables RLDP on all access points.
• Monitor Mode APs—Enables RLDP only on access points in monitor mode.
With RLDP, the controller instructs a managed access point to associate with the rogue access point and sends a special packet to the controller. If the controller receives the packet, the rogue access point is connected to the enterprise network. This method works for rogue access points that do not have encryption enabled.

**Step 5** Set the expiration timeout (in seconds) for rogue access point entries.

**Step 6** Select the Validate rogue clients against AAA check box to enable the AAA validation of rogue clients.

**Step 7** Select the Detect and report Adhoc networks check box to enable detection and reporting of rogue clients participating in ad hoc networking.

**Step 8** Click Save.

---

### Configuring a Rogue AP Rules Template

Rogue access point rules allow you to define rules to automatically classify rogue access points. WCS applies the rogue access point classification rules to the controllers. These rules can limit a rogue’s appearance on maps based on RSSI level (weaker rogue access points are ignored) and time limit (a rogue access point is not flagged unless it is seen for the indicated period of time).

**Note** Rogue access point rules also help reduce false alarms.

To view current classification rule templates, rule type, and the number of controllers to which they are applied, choose Configure > Controller Template Launch Pad > Security > Rogue > Rogue AP Rules. If you want to view rogue access point rules, refer to the “Viewing or Editing Rogue Access Point Rules” section on page 9-188.

**Note** Rogue classes include the following types:
- Malicious Rogue—A detected access point that matches the user-defined malicious rules or has been manually moved from the Friendly AP category.
- Friendly Rogue—Known, acknowledged, or trusted access point or a detected access point that matches user-defined friendly rules.
- Unclassified Rogue—A detected access point that does not match the malicious or friendly rules.

To add or create a new classification rule template for rogue access points, follow these steps:

**Step 1** Choose Configure > Controller Template Launch Pad.

**Step 2** From the left sidebar menu, choose Security > Rogue > Rogue AP Rules. The Rogue AP Rules Controller Template page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.
Step 3  From the Select a command drop-down list, choose Add Classification Rule, and click Go. The Rogue AP Rules > New Template page appears (see Figure 11-44). To modify an existing rogue access point rules template or to apply a current template to the controllers, choose Configure > Controller Template Launch Pad > Security > Rogue > Rogue AP Rules, and click a template name.

![Figure 11-44 Rogue AP Rules > New Template Page](image)

**Step 4**  In the General portion of the page, enter the following parameters:

- **Rule Name**—Enter a name for the rule in the text box.

- **Rule Type**—Choose Malicious or Friendly from the drop-down list. A rogue is considered malicious if a detected access point matches the user-defined malicious rules or has been manually moved from the Friendly AP category. A rogue is considered friendly if it is a known, acknowledged, or trusted access point or a detected access point that matches the user-defined Friendly rules.

- **Match Type**—Choose Match All Conditions or Match Any Condition from the drop-down list.
**Step 5** In the Malicious Rogue Classification Rule portion of the page, enter the following parameters.

- **Open Authentication**—Select the check box to enable open authentication.
- **Match Managed AP SSID**—Select the check box to enable the matching of a Managed AP SSID.

  **Note** Managed SSIDs are the SSIDs configured for the WLAN and known to the system.

- **Match User Configured SSID**—Select the check box to enable the matching of User Configured SSIDs.

  **Note** User Configured SSIDs are the SSIDs that are manually added. Enter the User Configured SSIDs (one per line) in the Match User Configured SSID text box.

- **Minimum RSSI**—Select the check box to enable the Minimum RSSI threshold limit.

  **Note** Enter the minimum RSSI threshold level (dB) in the text box. The detected access point is classified as malicious if it is detected above the indicated RSSI threshold.

- **Time Duration**—Select the check box to enable the Time Duration limit.

  **Note** Enter the time duration limit (in seconds) in the text box. The detected access point is classified as malicious if it is viewed for a longer period of time than the indicated time limit.

- **Minimum Number Rogue Clients**—Select the check box to enable the Minimum Number Rogue Clients limit. Enter the minimum number of rogue clients allowed. The detected access point is classified as malicious if the number of clients associated to the detected access point is greater than or equal to the indicated value.

**Step 6** Click **Save**.

---

**Configuring a Rogue AP Rule Groups Template**

A rogue access point rule group template allows you to combine more than one rogue access point rule to controllers. To view current rogue access point rule group templates or create a new rule group, follow these steps:

**Step 1** Choose **Configure > Controller Template Launch Pad**.

**Step 2** Click **Rogue AP Rule Groups** or choose **Security > Rogue > Rogue AP Rule Groups** from the left sidebar menu.

**Step 3** From the Select a command drop-down list, choose **Add Rogue Rule Group**.

**Step 4** Click **Go**. The Rogue AP Rule Groups > New Template page appears (see Figure 11-45).
Figure 11-45 Rogue AP Rule Groups > New Template

**Step 5** Enter a name for the rule group in the General portion of the page.

**Step 6** To add a Rogue AP rule, click to highlight the rule in the left column. Click **Add** to move the rule to the right column.

**Note**

Rogue access point rules can be added from the Rogue Access Point Rules section. See the “Configuring a Rogue AP Rules Template” section on page 11-90 for more information.

---

**Note**

To modify an existing rogue policy template or to apply a current template to controllers, choose **Configure > Controller Template Launch Pad > Security > Rogue > Rogue AP Rule Groups** and click a template name. Make the necessary changes to the template, and click **Save** or **Apply to Controllers**.

---

To modify an existing rogue policy template or to apply a current template to controllers, choose **Configure > Controller Template Launch Pad > Security > Rogue > Rogue AP Rule Groups** and click a template name. Make the necessary changes to the template, and click **Save** or **Apply to Controllers**.

**Step 5** Enter a name for the rule group in the General portion of the page.

**Step 6** To add a Rogue AP rule, click to highlight the rule in the left column. Click **Add** to move the rule to the right column.

---

**Note**

Rogue access point rules can be added from the Rogue Access Point Rules section. See the “Configuring a Rogue AP Rules Template” section on page 11-90 for more information.
Configuring Controller Templates

Chapter 11    Using Templates

Step 7  To remove a rogue access point rule, click to highlight the rule in the right column. Click Remove to move the rule to the left column.

Step 8  Use the Move Up/Move Down buttons to specify the order in which the rules apply. Highlight the desired rule and click Move Up or Move Down to move it higher or lower in the current list.

Step 9  Click Save to confirm the rogue access point rule list.

Step 10 Click Cancel to close the page without making any changes to the current list.

Note  To view and edit the rules applied to a controller, choose Configure > Controller and click the controller name.

Configuring a Friendly Access Point Template

This template allows you to import friendly internal access points. Importing these friendly access points prevents non-lightweight access points from being falsely identified as rogues.

Note Friendly Internal access points were previously referred to as Known APs.

Follow these steps to view or edit the current list of friendly access points. The friendly access point screen identifies the access point’s MAC address, status, any comments, and whether or not the alarm is suppressed for this access point.

Step 1  Choose Configure > Controller Template Launch Pad.

Step 2  Click Friendly AP or choose Security > Rogue > Friendly AP from the left sidebar menu.

Step 3  From the Select a command drop-down list, choose Add Friendly.

Step 4  Click Go. The Friendly AP page appears (see Figure 11-46).

Note To modify an existing friendly access point, choose Configure > Controller Template Launch Pad > Security > Rogue > Friendly Internal and click the access point’s MAC address. Make the necessary changes to the access point, and click Save.
Step 5  Friendly access points can be added by either importing the access point or manually entering the access point information:

- To import an access point using the Import feature:
  - Select the Import from File check box.
  - Enter the file path or use the Browse button to navigate to the correct file.

- To manually add an access point:
  - Unselect the Import from File check box.
  - Enter the MAC address for the access point.
Configuring Controller Templates

Note
Use a line break to separate MAC addresses. For example, enter the MAC addresses as follows:

00:00:11:22:33:44
00:00:11:22:33:45
00:00:11:22:33:46

- Choose Internal access point from the Status drop-down list.
- Enter a comment regarding this access point, if necessary.
- Select the Suppress Alarms check box to suppress all alarms for this access point.
- Click Save to confirm this access point or Cancel to close the page without adding the access point to the list.

Configuring 802.11 Templates

This section contains the following topics:

- Configuring Load Balancing Templates, page 11-96
- Configuring Band Selection Templates, page 11-97
- Configuring Preferred Call Templates, page 11-97
- Configuring Media Parameters for Controller Templates, page 11-98

Configuring Load Balancing Templates

To configure load balancing templates, follow these steps:

Step 1 Choose Configure > Controller Template Launch Pad.

Step 2 Click Load Balancing or choose 802.11 > Load Balancing from the left sidebar menu. The Load Balancing page appears.

Step 3 Enter a value between 1 and 20 for the client window size. The page size becomes part of the algorithm that determines whether an access point is too heavily loaded to accept more client associations:

\[
\text{load-balancing page} + \text{client associations on AP with lightest load} = \text{load-balancing threshold}
\]

In the group of access points accessible to a client device, each access point has a different number of client associations. The access point with the lowest number of clients has the lightest load. The client page size plus the number of clients on the access point with the lightest load forms the threshold. Access points with more client associations than this threshold is considered busy, and clients can associate only to access points with client counts lower than the threshold.

Step 4 Enter a value between 0 and 10 for the max denial count. The denial count sets the maximum number of association denials during load balancing.

Step 5 Click Save.
Configuring Band Selection Templates

To configure band selection templates, follow these steps:

**Step 1**  Choose **Configure > Controller Template Launch Pad**.

**Step 2**  Click **Band Select** or choose **802.11 > Band Select** from the left sidebar menu. The Band Select page appears.

**Step 3**  Enter a value between 1 and 10 for the probe cycle count. The cycle count sets the number of suppression cycles for a new client. The default cycle count is 2.

**Step 4**  Enter a value between 1 and 1000 milliseconds for the scan cycle period threshold. This setting determines the time threshold during which new probe requests from a client come from a new scanning cycle. The default cycle threshold is 200 milliseconds.

**Step 5**  Enter a value between 10 and 200 seconds for the age out suppression parameter. Age-out suppression sets the expiration time for pruning previously known 802.11b/g clients. The default value is 20 seconds. After this time elapses, clients become new and are subject to probe response suppression.

**Step 6**  Enter a value between 10 and 300 seconds for the age out dual band parameter. The age-out period sets the expiration time for pruning previously known dual-band clients. The default value is 60 seconds. After this time elapses, clients become new and are subject to probe response suppression.

**Step 7**  Enter a value between –20 and –90 dBm for the acceptable client RSSI parameter. This parameter sets the minimum RSSI for a client to respond to a probe. The default value is –80 dBm.

**Step 8**  Click **Save**.

Configuring Preferred Call Templates

This page enables you to create or modify a template for configuring Preferred Call.

To add or modify preferred call templates, follow these steps:

**Step 1**  Choose **Configure > Controller Template Launch Pad**.

**Step 2**  Click **Preferred Call** or choose **802.11 > Preferred Call** from the left sidebar menu. The Preferred Call Controller Templates page appears.

**Step 3**  If you want to add a new template, choose **Add Template** from the Select a command drop-down list, and click **Go**. To modify an existing template, click the template name. The New Controller Template page appears.

**Step 4**  Add or modify the following Preferred Call parameters:

- **Template Name**

  **Note**: Template Name is the unique key used to identify the template. A template name is mandatory to distinguish between two templates that have identical key attributes.

  - **Number Id**—Enter a value to identify the preferred number. You can have a maximum of six preferred call numbers. The valid range is from 1 to 6. The default value is 1.
  - **Preferred Number**—Enter the preferred call number.
**Step 5** Click **Save**.

## Configuring Media Parameters for Controller Templates

To configure the media parameters for a Controller template for 802.11 Radio, follow these steps:

**Step 1** Choose **Configure > Controller Template Launch Pad**.

**Step 2** Scroll down, and under the **802.11** section, click **New** beside Media Parameters. The **New Controller Template** page appears.

**Step 3** In the General section, specify an appropriate name for the template.

**Note** Template Name is the unique key used to identify the template. A template name is mandatory to distinguish between two templates that have identical key attributes.

**Step 4** In the Media Stream Configuration section, specify the following parameters:

- Media Stream Name
- Multicast Destination Start IP—Start IP address of the media stream to be multicast
- Multicast Destination End IP—End IP address of the media stream to be multicast
- Maximum Expected Bandwidth—Maximum bandwidth that a media stream can use

**Step 5** In the Resource Reservation Control (RRC) Parameters section, specify the following parameters:

- Average Packet Size—Average packet size that a media stream can use
- RRC Periodical Update—Resource Reservation Control calculations that are updated periodically; if disabled, RRC calculations are done only once when a client joins a media stream
- RRC Priority—Priority of RRC with the highest at 1 and the lowest at 8
- Traffic Profile Violation—Appears if the stream is dropped or put in the best effort queue if the stream violates the QoS video profile
- Policy—Appears if the media stream is admitted or denied

**Step 6** Click **Save**.

Once saved, the template appears in the Template List page. In the Template List page, you can apply this template to controllers. See the “Applying Controller Templates” section on page 11-2 for more information.

### Related Topics

- Accessing Controller Template Launch Pad
- Adding Controller Templates
- Deleting Controller Templates
- Applying Controller Templates
Configuring Radio Templates (802.11a/n)

This section contains the following topics:

- Configuring 802.11a/n Parameters Templates, page 11-99
- Configuring Media Parameters for Controller Templates, page 11-98
- Configuring EDCA Parameters Through a Controller Template (802.11a/n), page 11-104
- Configuring a Roaming Parameters Template (802.11a/n), page 11-105
- Configuring an 802.11h Template, page 11-107
- Configuring a High Throughput Template (802.11a/n), page 11-108
- Configuring CleanAir Controller Templates (802.11a/n), page 11-109

Configuring 802.11a/n Parameters Templates

To add or modify radio templates, follow these steps:

**Step 1** Choose Configure > Controller Template Launch Pad.

**Step 2** Click Parameters or choose either 802.11a/n > Parameters from the left sidebar menu. The 802.11a/n Parameters Template page appears and the number of controllers and virtual domains that the template is applied to automatically populates. This initial page also displays the 802.11 network status and the channel and power mode. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3** If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The 802.11a/n Parameters template page appears (see Figure 11-47).

**Step 4** If you want to enable 802.11a/n network status, select the 802.11a/n Network Status check box.
Step 5 Use the ClientLink drop-down list to enable ClientLink on all access point 802.11a/n radios that support ClientLink. Otherwise, choose **Disable**.

Step 6 Enter a transmitted power threshold between -50 and -80.

Step 7 Enter the amount of time between beacons in kilomicroseconds. The valid range is from 20 to 1000 milliseconds.

Step 8 Enter the number of beacon intervals that may elapse between transmission of beacon frames containing a traffic indicator message (TIM) element whose delivery count text box is 0. This value is transmitted in the DTIM period field of beacon frames. When client devices receive a beacon that contains a DTIM, they normally wake up to check for pending packets. Longer intervals between DTIMS let clients sleep longer and preserve power. Conversely, shorter DTIM periods reduce the delay in receiving packets but use more battery power because clients wake up more often.

Step 9 At the Fragmentation Threshold parameter, determine the size at which packets are fragmented (sent as several pieces instead of as one block). Use a low setting in areas where communication is poor or where there is a great deal of radio interference.

Step 10 Enter the percentage for 802.11e maximum bandwidth.

Step 11 Click if you want short preamble enabled.

Step 12 From the Dynamic Assignment drop-down list, choose one of three modes:
   - **Automatic** - The transmit power is periodically updated for all access points that permit this operation.
   - **On Demand** - Transmit power is updated when the Assign Now button is selected.
   - **Disabled** - No dynamic transmit power assignments occur, and values are set to their global default.

Step 13 Determine if you want to enable Dynamic Tx Power Control. The power levels and available channels are defined by the country code setting and are regulated on a country by country basis.
Step 14 The Assignment Mode drop-down list has three dynamic channel modes:

- **Automatic** - The channel assignment is periodically updated for all access points that permit this operation. This is also the default mode.
- **On Demand** - Channel assignments are updated when desired.
- **OFF** - No dynamic channel assignments occur, and values are set to their global default.

Step 15 Select the **Avoid Foreign AP Interference** check box. Enable this parameter to have RRM consider interference from foreign Cisco access points (those non-Cisco access points outside RF/mobility domain) when assigning channels. This foreign 802.11 interference. Disable this parameter to have RRM ignore this interference.

In certain circumstances with significant interference energy (dB) and load (utilization) from foreign access points, RRM may adjust the channel assignment to avoid these channels (and sometimes adjacent channels) in access points close to the foreign access points. This increases capacity and reduces variability for the Cisco WLAN Solution.

Step 16 Select the **Avoid Cisco AP Load** check box if you want it enabled. Enable this bandwidth-sensing parameter to have controllers consider the traffic bandwidth used by each access point when assigning channels to access points. Disable this parameter to have RRM ignore this value.

In certain circumstances and with denser deployments, there may not be enough channels to properly create perfect channel re-use. In these circumstances, RRM can assign better re-use patterns to those access points that carry more traffic load.

Step 17 Select the **Avoid non 802.11 Noise** check box if you want to enable it. Enable this noise-monitoring parameter to have access points avoid channels that have interference from non-access point sources, such as microwave ovens or Bluetooth devices. Disable this parameter to have RRM ignore this interference.

In certain circumstances with significant interference energy (dB) from non-802.11 noise sources, RRM may adjust the channel assignment to avoid these channels (and sometimes adjacent channels) in access points close to the noise sources. This increases capacity and reduces variability for the Cisco WLAN Solution.

Step 18 The Signal Strength Contribution check box is always enabled (not configurable), constantly monitors the relative location of all access points within the RF/mobility domain to ensure near-optimal channel re-use. The net effect is an increase in Cisco WLAN Solution capacity and a reduction in co-channel and adjacent channel interference.

Step 19 The client and controller negotiate data rates between them. If the data rate is set to Mandatory, the client must support it to use the network. If a data rate is set as Supported by the controller, any associated client that also supports that same rate may communicate with the access point using that rate. However, it is not required that a client uses all the rates marked supported to associate. For each rate, a drop-down list of Mandatory or Supported is available. Each data rate can also be set to Disabled to match client settings.

Step 20 From the Channel List drop-down list in the Noise/Interference/Rogue Monitoring Channels group box, choose between all channels, country channels, or DCA channels based on the level of monitoring you want. Dynamic Channel Allocation (DCA) automatically selects a reasonably good channel allocation amongst a set of managed devices connected to the controller.

Step 21 The Cisco Compatible Extension’s location measurement interval can only be changed when measurement mode is enabled to broadcast radio measurement requests. When enabled, this enhances the location accuracy of clients.

Step 22 Click **Save**.
Configuring Media Parameters Controller Templates (802.11a/n)

This page enables you to create or modify a template for configuring 802.11a/n voice parameters such as call admission control and traffic stream metrics.

To add a new template with 802.11a/n voice parameters information (such as call admission control and traffic stream metrics) for a controller, follow these steps:

**Step 1** Choose Configure > Controller Template Launch Pad.

**Step 2** Click New beside the template you want to add.

**Step 3** Specify an appropriate name for the template.

**Note** Template Name is the unique key used to identify the template. A template name is mandatory to distinguish between two templates that have identical key attributes.

**Step 4** On the Voice tab, add or modify the following parameters:

- **Admission Control (ACM)** — Select the check box to enable admission control.
  For end users to experience acceptable audio quality during a VoIP phone call, packets must be delivered from one endpoint to another with low latency and low packet loss. To maintain QoS under differing network loads, call admission control (CAC) is required. CAC on an access point allows it to maintain controlled QoS when the network is experiencing congestion and keep the maximum allowed number of calls to an acceptable quantity.

- **CAC Method** — If Admission Control (ACM) is enabled, specify the CAC method as either load-based or static.
  Load-based CAC incorporates a measurement scheme that takes into account the bandwidth consumed by all traffic types from itself, from co-channel access points, and by co-located channel interference. Load-based CAC also covers the additional bandwidth consumption resulting from PHY and channel impairment.

- **Maximum Bandwidth Allowed** — Specify the percentage of maximum bandwidth allowed. This option is only available when CAC is enabled.

- **Reserved Roaming Bandwidth** — Specify the percentage of reserved roaming bandwidth. This option is only available when CAC is enabled.

- **Expedited Bandwidth** — Select the check box to enable expedited bandwidth as an extension of CAC for emergency calls.
  You must have an expedited bandwidth IE that is CCXv5 compliant so that a TSPEC request is given higher priority.

- **SIP CAC** — Select the check box to enable SIP CAC.
  SIP CAC should be used only for phones that support status code 17 and do not support TSPEC-based admission control.

- **SIP Codec** — Specify the codec name you want to use on this radio. The available options are G.711, G.729, and User Defined.

- **SIP Call Bandwidth** — Specify the bandwidth in kilobits per second that you want to assign per SIP call on the network. This parameter can be configured only when the SIP Codec selected is User Defined.

- **SIP Sample Interval** — Specify the sample interval in milliseconds that the codec must operate in.
• Max Number of Calls per Radio—Specify the maximum number of calls per Radio.
• Metric Collection—Select the check box to enable metric collection.

Traffic stream metrics are a series of statistics about VoIP over your wireless LAN which inform you of the QoS of the wireless LAN. For the access point to collect measurement values, traffic stream metrics must be enabled. When this is enabled, the controller begins collecting statistical data every 90 seconds for the 802.11b/g interfaces from all associated access points. If you are using VoIP or video, this feature should be enabled.

Step 5  In the Video tab, add or modify the following parameters:
• Admission Control (ACM)—Select the check box to enable admission control.
• Maximum Bandwidth—Specify the percentage of maximum bandwidth allowed. This option is only available when CAC is enabled.
• Reserved Roaming Bandwidth—Specify the percentage of reserved roaming bandwidth. This option is only available when CAC is enabled.
• Unicast Video Redirect—Select the Unicast Video Redirect check box to enable all non-media stream packets in video queue are redirected to the best effort queue. If disabled, all packets with video marking are kept in video queue.
• Client Minimum Phy Rate—Specify the physical data rate required for the client to join a media stream from the Client Minimum Phy Rate drop-down list.
• Multicast Direct Enable—Select the Multicast Direct Enable check box to set the Media Direct for any WLAN with Media Direct enabled on a WLAN on this radio.
• Maximum Number of Streams per Radio—Specify the maximum number of streams per Radio to be allowed.
• Maximum Number of Streams per Client—Specify the maximum number of streams per Client to be allowed.
• Best Effort QOS Admission—Select the Best Effort QOS Admission check box to redirect new client requests to the best effort queue. This happens only if all the video bandwidth has been used.

Note  If disabled and maximum video bandwidth has been used, then any new client request is rejected.

Step 6  On the General tab, specify the following parameter:
• Maximum Media Bandwidth (0 to 85%)—Specify the percentage of maximum of bandwidth allowed. This option is only available when CAC is enabled.

Step 7  Click Save.

Once saved, the template appears in the Template List page. In the Template List page, you can apply this template to controllers. See the “Applying Controller Templates” section on page 11-2 for more information.

Related Topics
• Configuring Media Parameters for Controller Templates
• Accessing Controller Template Launch Pad
• Adding Controller Templates
• Deleting Controller Templates
• Applying Controller Templates

Configuring EDCA Parameters Through a Controller Template (802.11a/n)

Enhanced distributed channel access (EDCA) parameters are designed to provide preferential wireless channel access for voice, video, and other quality of service (QoS) traffic.

To add or configure 802.11a/n EDCA parameters through a controller template, follow these steps:

**Step 1** Choose Configure > Controller Template Launch Pad.

**Step 2** Click EDCA Parameters or choose 802.11a/n > EDCA Parameters from the left sidebar menu. The EDCA Parameters Template page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. This initial page also displays the EDCP profile and the low latency MAC. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3** If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The 802.11a/n EDCA Parameters template page appears (see Figure 11-48).

**Figure 11-48 802.11a EDCA Parameters**

**Step 4** Choose one of the following options from the EDCA Profile drop-down list:

• WMM—Enables the Wi-Fi Multimedia (WMM) default parameters. This is the default value. Choose this option when voice or video services are not deployed on your network.
Chapter 11      Using Templates

Configuring Controller Templates

- **Spectralink Voice Priority**—Enables Spectralink voice priority parameters. Choose this option if Spectralink phones are deployed on your network to improve the quality of calls.

- **Voice Optimized**—Enables EDCA voice-optimized profile parameters. Choose this option when voice services other than Spectralink are deployed on your network.

- **Voice & Video Optimized**—Enables EDCA voice- and video-optimized profile parameters. Choose this option when both voice and video services are deployed on your network.

  **Note** Video services must be deployed with admission control (ACM). Video services without ACM are not supported.

  **Note** You must shut down radio interface before configuring EDCA Parameters.

**Step 5** Select the **Low Latency MAC** check box to enable this feature.

  **Note** Enable low latency MAC only if all clients on the network are WMM compliant.

**Configuring a Roaming Parameters Template (802.11a/n)**

To add or modify an existing roaming parameter template, follow these steps:

**Step 1** Choose **Configure > Controller Template Launch Pad**.

**Step 2** Click **Roaming Parameters** or choose **802.11a/n > Roaming Parameters** from the left sidebar menu. The Roaming Parameters Template appears, and the number of controllers and virtual domains that the template is applied to automatically populates. This initial page also displays the minimum RSSI, roaming hysteresis, adaptive scan threshold, and transition time. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3** If you want to add a new template, choose **Add Template** from the Select a command drop-down list, and click **Go**. To modify an existing template, click the template name. The 802.11a/n Roaming Parameters template page appears (see **Figure 11-49**).
Step 4  Use the Mode drop-down list to choose one of the configurable modes: default values and custom values. When the default values option is chosen, the roaming parameters are unavailable with the default values displayed in the text boxes. When the custom values option is selected, the roaming parameters can be edited in the text boxes. To edit the parameters, continue to Step 5.

Step 5  In the Minimum RSSI field, enter a value for the minimum Received Signal Strength Indicator (RSSI) required for the client to associate to an access point. If the client’s average received signal power dips below this threshold, reliable communication is usually impossible. Therefore, clients must already have found and roamed to another access point with a stronger signal before the minimum RSSI value is reached.

Range: -80 to -90 dBm
Default: -85 dBm

Step 6  In the Roaming Hysteresis field, enter a value to indicate how strong the signal strength of a neighboring access point must be for the client to roam to it. This parameter is intended to reduce the amount of “ping ponging” between access points if the client is physically located on or near the border between two access points.

Range: 2 to 4 dB
Default: 2 dB

Step 7  In the Adaptive Scan Threshold field, enter the RSSI value from a client’s associated access point, below which the client must be able to roam to a neighboring access point within the specified transition time. This parameter also provides a power-save method to minimize the time that the client spends in active or passive scanning. For example, the client can scan slowly when the RSSI is above the threshold and scan more rapidly when below the threshold.

Range: -70 to -77 dB
Default: -72 dB
Step 8 In the Transition Time field, enter the maximum time allowed for the client to detect a suitable neighboring access point to roam to and to complete the roam, whenever the RSSI from the client’s associated access point is below the scan threshold.

The Scan Threshold and Transition Time parameters guarantee a minimum level of client roaming performance. Together with the highest expected client speed and roaming hysteresis, these parameters make it possible to design a wireless LAN network that supports roaming simply by ensuring a certain minimum overlap distance between access points.

Range: 1 to 10 seconds
Default: 5 seconds

Step 9 Click Save.

---

Configuring an 802.11h Template

802.11h informs client devices about channel changes and can limit the client device’s transmit power. Create or modify a template for configuration 802.11h parameters (such as power constraint and channel controller announcement) and applying these settings to multiple controllers.

To add or modify an 802.11h template, follow these steps:

Step 1 Choose Configure > Controller Template Launch Pad.

Step 2 Click 802.11h or choose 802.11a/n > 802.11h from the left sidebar menu. The 802.11h Template appears, and the number of controllers and virtual domains that the template is applied to automatically populates. This initial page also displays the local power constraint and channel announcement quiet mode. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 3 If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The 802.11h template page appears (see Figure 11-50).
Configuring Controller Templates

To add or modify to an 802.11a/n high throughput template, follow these steps:

Step 1 Choose Configure > Controller Template Launch Pad.

Step 2 Click High Throughput (802.11n) or choose 802.11a/n > High Throughput from the left sidebar menu. The 802.11n Parameters for 2.4 GHz or 802.11n Parameters for 5 GHz template appears, and the number of controllers and virtual domains that the template is applied to automatically populates. This initial page also displays the 802.11n network status. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 3 If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The 802.11a/n High Throughput template page appears (see Figure 11-51).
Figure 11-51  802.11n Parameters for 2.4GHz Template

<table>
<thead>
<tr>
<th>Controller Template 'Dot11anConfigTemplate_53732'</th>
<th>Wireless Control System</th>
<th>Access Points</th>
<th>Config</th>
<th>Services</th>
<th>Administration</th>
<th>Tools</th>
<th>Help</th>
<th>User: root  • Virtual Domain: root</th>
</tr>
</thead>
</table>

**Step 4**  
Click the **802.11n Network Status Enable** check box to enable high throughput.

**Step 5**  
In the MCS (Data Rate) Settings column, choose which level of data rate you want supported. Modulation coding schemes (MCS) are similar to 802.11a data rate. As a default, 20 MHz and short guarded interval is used.

**Note**  
When you select the **Supported** check box, the chosen numbers appear in the Selected MCS Indexes page.

**Step 6**  
Click **Save**.

---

**Configuring CleanAir Controller Templates (802.11a/n)**

Create or modify a template for configuring CleanAir parameters for the 802.11a/n radio. You can configure the template to enable or disable CleanAir, reporting and alarms for the controllers. You can also configure the type of interfering devices to include for reporting and alarms.

To add a new template with 802.11a/n CleanAir information for a controller, follow these steps:

**Step 1**  
Choose **Configure > Controller Template Launch Pad**.

**Step 2**  
From the left sidebar menu, choose **802.11a/n > CleanAir**. The 802.11a/n CleanAir Controller Templates page displays all currently saved 802.11a/n CleanAir templates. It also displays and the number of controllers and virtual domains to which each template is applied.
Step 3  From the **Select a command** drop-down list, choose **Add a Template**, and click **Go**.

The **New Controller Template** page appears.

Step 4  Add or modify the following parameters:

- **Template Name**—Enter the template name.
- **CleanAir**—Select the check box to enable CleanAir functionality on the 802.11 b/g/n network, or unselect to prevent the controller from detecting spectrum interference.

**Note** If CleanAir is enabled, the Reporting Configuration and Alarm Configuration sections appear.

- **Reporting Configuration**—Use the parameters in this section to configure the interferer devices you want to include for your reports.

  Report Interferers—Select the **report interferers** check box to enable CleanAir system to report and detect sources of interference, or unselect it to prevent the controller from reporting interferers. The default value is selected.

  Make sure that any sources of interference that need to be detected and reported by the CleanAir system appear in the Interferences to Detect box and any that do not need to be detected appear in the Interferers to Ignore box. Use the > and < buttons to move interference sources between these two boxes. By default, all interference sources are ignored.

- **Alarm Configuration**—This section enables you to configure triggering of air quality alarms.

  - **Air Quality Alarm**—Select the **Air Quality Alarm** check box to enable the triggering of air quality alarms, or unselect the box to disable this feature.

  - **Air Quality Alarm Threshold**—If you selected the Air Quality Alarm check box, enter a value between 1 and 100 (inclusive) in the Air Quality Alarm Threshold field to specify the threshold at which you want the air quality alarm to be triggered. When the air quality falls below the threshold level, the alarm is triggered. A value of 1 represents the worst air quality, and 100 represents the best. The default value is 1.

  - **Interferers For Security Alarm**—Select the **Interferers For Security Alarm** check box to trigger interferer alarms when the controller detects specified device types, or unselect it to disable this feature. The default value is unselected.

  Make sure that any sources of interference that need to trigger interferer alarms appear in the Interferers Selected for Security Alarms box and any that do not need to trigger interferer alarms appear in the Interferers Ignored for Security Alarms box. Use the > and < buttons to move interference sources between these two boxes. By default, all interferer sources for security alarms are ignored.

Step 5  Click **Save**. Once saved, the template displays in the Template List page. In the Template List page, you can apply this template to controllers. See the “**Configuring Controller Templates**” section on page 11-3 for more information.

---

**Configuring 802.11a/n RRM Templates**

This section contains the following topics:

- **Configuring an RRM Threshold Template (802.11a/n)**, page 11-111
- **Configuring an RRM Interval Template (802.11a/n)**, page 11-112
Configuring an RRM Threshold Template (802.11a/n)

To add or make modifications to an 802.11a/n or 802.11b/g/n RRM threshold template, follow these steps:

**Step 1** Choose Configure > Controller Template Launch Pad.

**Step 2** Click RRM Thresholds or choose 802.11a/n > RRM Thresholds. The 802.11a/n RRM Thresholds Template appears, and the number of controllers and virtual domains that the template is applied to automatically populates. This initial page also displays the interference and noise threshold, maximum clients, and RF utilization. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3** If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The 802.11a/n RRM Threshold template page appears (see Figure 11-52).

**Figure 11-52  802.11a/n RRM Thresholds Template**

**Step 4** Enter the minimum number of failed clients currently associated with the controller.

**Step 5** Enter the target range of coverage threshold.

**Step 6** Enter the Data RSSI (−60 to −90 dBm). This number indicates the value for the minimum Received Signal Strength Indicator (RSSI) for data required for the client to associate to an access point.

**Note** You must disable the 802.11a/n network before applying these RRM threshold parameters.
Step 7 Enter the Voice RSSI (–60 to –90 dBM). This number indicates the value for the minimum received signal strength indicator (RSSI) required for voice for the client to associate to an access point.

Step 8 Enter the maximum number of failed clients that are currently associated with the controller.

Step 9 At the RF Utilization parameter, enter the percentage of threshold for either 802.11a/n.

Step 10 Enter an interference threshold percentage.

Step 11 Enter a noise threshold between -127 and 0 dBm. When the controller is outside of this threshold, it sends an alarm to WCS.

Step 12 Enter the coverage exception level percentage. When the coverage drops by this percentage from the configured coverage for the minimum number of clients, a coverage hole is generated.

Step 13 Click Save.

Configuring an RRM Interval Template (802.11a/n)

To add or make modifications to an 802.11a/n RRM interval template, follow these steps:

Step 1 Choose Configure > Controller Template Launch Pad.

Step 2 Click RRM Intervals or choose 802.11a/n > RRM Intervals from the left sidebar menu. The 802.11a/n or 802.11b/g/n RRM Threshold Template appears, and the number of controllers and virtual domains that the template is applied to automatically populates. This initial page also displays the neighbor packet frequency, noise measurement interval, and load measurement interval. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 3 If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The 802.11a/n or 802.11b/g/n RRM Intervals template page appears (see Figure 11-53).
Configuring Controller Templates

Figure 11-53  802.11a/n RRM Intervals Template

Step 4  At the Neighbor Packet Frequency parameter, enter the interval at which you want strength measurements taken for each access point. The default is 300 seconds.

Step 5  Enter the interval at which you want noise and interference measurements taken for each access point. The default is 300 seconds.

Step 6  Enter the interval at which you want load measurements taken for each access point. The default is 300 seconds.

Step 7  At the Coverage Measurement Interval parameter, enter at which interval you want coverage measurements taken for each access point. The default is 300 seconds.

Step 8  Click Save.

Configuring an RRM Dynamic Channel Allocation Template (802.11a/n)

The Radio Resource Management (RRM) Dynamic Channel Assignment (DCA) page allows you to choose the DCA channels as well as the channel width for this controller.

RRM DCA supports 802.11n 40-MHz channel width in the 5-GHz band. The higher bandwidth allows radios to achieve higher instantaneous data rates.

Note  Choosing a larger bandwidth reduces the non-overlapping channels which could potentially reduce the overall network throughput for certain deployments.

To configure 802.11 a/n RRM DCA template, follow these steps:

Step 1  Choose Configure > Controller Template Launch Pad.
Step 2  Click DCA or choose 802.11a/n > DCA. The 802.11a/n DCS Template appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 3  If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The 802.11a/n TPC template page appears.

Step 4  Add or modify the following parameters:

- Template Name—Enter the template name.
- Assignment Mode—From the Dynamic Assignment drop-down list, choose one of three modes:
  - Automatic - The transmit power is periodically updated for all access points that permit this operation.
  - On Demand - Transmit power is updated when the Assign Now button is selected.
  - Disabled - No dynamic transmit power assignments occur, and values are set to their global default.
- Select the Avoid Foreign AP Interference check box to enable it. Enable this parameter to have RRM consider interference from foreign Cisco access points (those non-Cisco access points outside RF/mobility domain) when assigning channels. This foreign 802.11 interference. Disable this parameter to have RRM ignore this interference.
  In certain circumstances with significant interference energy (dB) and load (utilization) from foreign access points, RRM may adjust the channel assignment to avoid these channels (and sometimes adjacent channels) in access points close to the foreign access points. This increases capacity and reduces variability for the Cisco WLAN Solution.
- Select the Avoid Cisco AP Load check box if you want it enabled. Enable this bandwidth-sensing parameter to have controllers consider the traffic bandwidth used by each access point when assigning channels to access points. Disable this parameter to have RRM ignore this value.
  In certain circumstances and with denser deployments, there may not be enough channels to properly create perfect channel re-use. In these circumstances, RRM can assign better re-use patterns to those access points that carry more traffic load.
- Select the Avoid non 802.11 Noise check box if you want to enable it. Enable this noise-monitoring parameter to have access points avoid channels that have interference from non-access point sources, such as microwave ovens or Bluetooth devices. Disable this parameter to have RRM ignore this interference.
  In certain circumstances with significant interference energy (dB) from non-802.11 noise sources, RRM may adjust the channel assignment to avoid these channels (and sometimes adjacent channels) in access points close to the noise sources. This increases capacity and reduces variability for the Cisco WLAN Solution.
- The Signal Strength Contribution check box is always enabled (not configurable). RRM constantly monitors the relative location of all access points within the RF/mobility domain to ensure near-optimal channel re-use. The net effect is an increase in Cisco WLAN Solution capacity and a reduction in co-channel and adjacent channel interference.
Enable or disable event-driven Radio Resource Management (RRM) using the following parameters. Event Driven RRM is used when a CleanAir-enabled access point detects a significant level of interference.

- Event Driven RRM—Enable or Disable spectrum event-driven RRM. By default, Event Driven RRM is enabled.
- Sensitivity Threshold—If Event Driven RRM is enabled, this field displays the threshold level at which event-driven RRM is triggered. It can have a value of either Low, Medium, or High. When the interference for the access point rises above the threshold level, RRM initiates a local Dynamic Channel Assignment (DCA) run and changes the channel of the affected access point radio if possible to improve network performance. Low represents a decreased sensitivity to changes in the environment while High represents an increased sensitivity.

Step 5 Click Save.

Configuring an RRM Transmit Power Control Template (802.11a/n)

The controller dynamically controls access point transmit power based on real-time wireless LAN conditions. Normally, power can be kept low to gain extra capacity and reduce interference. The controller attempts to balance the access points’ transmit power according to how the access points are seen by their third strongest neighbor.

The transmit power control (TPC) algorithm both increases and decreases an access point's power in response to changes in the RF environment. In most instances TPC will seek to lower an access point's power to reduce interference, but in the case of a sudden change in the RF coverage—for example, if an access point fails or becomes disabled—TPC can also increase power on surrounding access points. This feature is different from Coverage Hole Detection. Coverage hole detection is primarily concerned with clients, while TPC is tasked with providing enough RF power to achieve desired coverage levels while avoiding channel interference between access points.

To configure 802.11a/n RRM TPC template, follow these steps:

Step 1 Choose Configure > Controller Template Launch Pad.
Step 2 Click TPC or choose 802.11a/n > TPC. The 802.11a/n TPC Template appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 3 If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The 802.11a/n TPC template page appears.

Step 4 Add or modify the following parameters:
- Template Name—Enter the template name.
- Dynamic Assignment—From the Dynamic Assignment drop-down list, choose one of three modes:
  - Automatic—The transmit power is periodically updated for all access points that permit this operation.
  - On Demand—Transmit power is updated when the Assign Now button is selected.
Configuring Controller Templates

- Disabled—No dynamic transmit power assignments occur, and values are set to their global default.
- Maximum Power Assignment—Indicates the maximum power assigned.
  - Range: -10 to 30 dB
  - Default: 30 dB
- Minimum Power Assignment—Indicates the minimum power assigned.
  - Range: -10 to 30 dB
  - Default: 30 dB
- Dynamic Tx Power Control—Determine if you want to enable Dynamic Tx Power Control.
- Transmitted Power Threshold—Enter a transmitted power threshold between -50 and -80.
- Control Interval—in seconds (read-only).

Step 5 Click Save.

Configuring Radio Templates (802.11b/g/n)

This section contains the following topics:

- Configuring 802.11b/g/n Parameters Templates, page 11-116
- Configuring Media Parameters Controller Templates (802.11b/g/n), page 11-119
- Configuring EDCA Parameters Controller Templates (802.11b/g/n), page 11-121
- Configuring Roaming Parameters Controller Templates (802.11b/g/n), page 11-121
- Configuring High Throughput (802.11n) Controller Templates (802.11b/g/n), page 11-123
- Configuring CleanAir Controller Templates (802.11 b/g/n), page 11-123
- Configuring 802.11b/g/n RRM Templates, page 11-124

Configuring 802.11b/g/n Parameters Templates

Create or modify a template for configuring 802.11b/g/n parameters (such as power and channel status, data rates, channel list, and CCX location measurement) and/or applying these settings to controller(s).

To add a new template with 802.11b/g/n parameters information for a controller, follow these steps:

Step 1 Choose Configure > Controller Template Launch Pad.
Step 2 Click New beside the template you want to add.
Step 3 Add or modify the following General parameters:
  - Policy Name—Security policy in force.
  - 802.11b/g Network Status
  - Beam Forming—Choose Enable or Disable from the drop-down list.
Beam forming refers to a general signal processing technique used to control the directionality of the reception or transmission of a signal.

- Transmitted Power Threshold—The valid range is from -50 to -80.
- Beacon Period—The rate at which the SSID is broadcast by the access point (the amount of time between beacons). The valid range is from 100 to 600 milliseconds.
- DTIM Period—The number of beacon intervals that may elapse between transmission of beacon frames containing a traffic indicator message (TIM) element whose delivery count field is 0. This value is transmitted in the DTIM period field of beacon frames. When client devices receive a beacon that contains a DTIM, they normally “wake up” to check for pending packets. Longer intervals between DTIMs let clients sleep longer and preserve power. Conversely, shorter DTIM periods reduce the delay in receiving packets but use more battery power because clients wake up more often.

Note DTIM period is not applicable from 5.0.0.0 version of controller.

- Fragmentation Threshold—Determine the size at which packets are fragmented (sent as several pieces instead of as one block). Use a low setting in areas where communication is poor or where there is a great deal of radio interference. The default value is 2346.
- 802.11e Max Bandwidth—Percentage for 802.11e max bandwidth. The default value is 100.

Step 4
Add or modify the following 802.11b/g Power Status parameters:

- Dynamic Assignment—Dynamic transmit power assignment has three modes:
  - Automatic—The transmit power will be periodically updated for all access points that permit this operation.
  - On Demand—Transmit power is updated when the Assign Now button is selected.
  - Disabled—No dynamic transmit power assignments occur and value are set to their global default. The default is Automatic.

Note The power levels and available channels are defined by the country code setting and are regulated on a country by country basis.

- Dynamic Tx Power Control—Select this check box to enable DTPC support. If this option is enabled, the transmit power level of the radio is advertised in the beacons and the probe responses.

Step 5
Add or modify the following 802.11b/g Channel Status parameters:

- Assignment Mode—Dynamic channel assignment has three modes:
  - Automatic—The channel assignment will be periodically updated for all access points that permit this operation.
  - On Demand—Channel assignments are updated when desired.
  - Disabled—No dynamic channel assignments occur and value are set to their global default.

Note The default is Automatic.
- Avoid Foreign AP Interference—Enable this foreign 802.11 interference-monitoring parameter to have Radio Resource Management consider interference from foreign (non-Cisco access points outside the RF/mobility domain) access points when assigning channels to Cisco access points. Disable this parameter to have Radio Resource Management ignore this interference.

  Note: In certain circumstances with significant interference energy (dB) and load (utilization) from Foreign access points, Radio Resource Management may adjust the channel assignment to avoid these channels (and sometimes adjacent channels) in Cisco access points close to the Foreign access points to increase capacity and reduce variability for the Cisco WLAN Solution.

- Avoid Cisco AP Load—Enable this bandwidth-sensing parameter to have controllers consider the traffic bandwidth used by each access point when assigning channels to access points. Disable this parameter to have Radio Resource Management ignore this value.

  Note: In certain circumstances and with denser deployments, there may not be enough channels to properly create perfect channel re-use. In these circumstances, Radio Resource Management can assign better re-use patterns to those APs that carry more traffic load.

- Avoid non 802.11 Noise—Enable this noise-monitoring parameter to have access points avoid channels that have interference from non-Access Point sources, such as microwave ovens or Bluetooth devices. Disable this parameter to have Radio Resource Management ignore this interference.

  Note: In certain circumstances with significant interference energy (dB) from non-802.11 noise sources, Radio Resource Management may adjust the channel assignment to avoid these channels (and sometimes adjacent channels) in access points close to the noise sources to increase capacity and reduce variability for the Cisco WLAN Solution.

- Signal Strength Contribution—Check box, always enabled (not configurable). Constantly monitors the relative location of all access points within the RF/mobility domain to ensure near-optimal channel re-use. The net effect is an increase in Cisco WLAN Solution capacity and a reduction in co-channel and adjacent channel interference.

Step 6 Add or modify the Data Rate parameters.

The data rates set are negotiated between the client and the controller. If the data rate is set to Mandatory, the client must support it to use the network. If a data rate is set as Supported by the controller, any associated client that also supports that same rate may communicate with the access point using that rate. But it is not required that a client be able to use all the rates marked Supported to associate. 6, 9, 12, 18, 24, 36, 48, 54 Mbps For each rate, a drop-down list selection of Mandatory or Supported is available. Each data rate can also be set to Disabled to match Client settings.

Step 7 Add or modify the Noise/Interference/Rogue Monitoring Channels parameters.

Choose between all channels, country channels, or DCA channels based on the level of monitoring you want. Dynamic Channel Allocation (DCA) automatically selects a reasonably good channel allocation among a set of managed devices connected to the controller.

Step 8 Add or modify the CCX Location Measurement parameters:
### Configuring Controller Templates

- **Mode**—Enable or disable the broadcast radio measurement request. When enabled, this enhances the location accuracy of clients.
- **Interval**—Interval in seconds between requests.

<table>
<thead>
<tr>
<th>Note</th>
<th>Cisco Compatible Extension location measurement interval can be changed only when measurement mode is enabled.</th>
</tr>
</thead>
</table>

**Step 9** Click **Save**. Once saved, the template displays in the Template List page. In the Template List page, you can apply this template to controllers. See the “Applying Controller Templates” section on page 11-2 for more information.

### Configuring Media Parameters Controller Templates (802.11b/g/n)

Create or modify a template for configuring 802.11b/g/n voice parameters such as call admission control and traffic stream metrics.

To add a new template with 802.11b/g/n voice parameters information (such as call admission control and traffic stream metrics) for a controller, follow these steps:

**Step 1** Choose **Configure > Controller Template Launch Pad**.

**Step 2** Click **New** beside the template you want to add.

**Step 3** Specify an appropriate name for the template.

<table>
<thead>
<tr>
<th>Note</th>
<th>Template Name is the unique key used to identify the template. A template name is mandatory to distinguish between two templates that have identical key attributes.</th>
</tr>
</thead>
</table>

**Step 4** On the **Voice** tab, add or modify the following parameters:

- **Admission Control (ACM)**—Select the check box to enable admission control.

  For end users to experience acceptable audio quality during a VoIP phone call, packets must be delivered from one endpoint to another with low latency and low packet loss. To maintain QoS under differing network loads, call admission control (CAC) is required. CAC on an access point allows it to maintain controlled QoS when the network is experiencing congestion and keep the maximum allowed number of calls to an acceptable quantity.

- **CAC Method**—If Admission Control (ACM) is enabled, specify the CAC method as either load-based or static.

  Load-based CAC incorporates a measurement scheme that takes into account the bandwidth consumed by all traffic types from itself, from co-channel access points, and by co-located channel interference. Load-based CAC also covers the additional bandwidth consumption resulting from PHY and channel impairment.

- **Maximum Bandwidth Allowed**—Specify the percentage of maximum bandwidth allowed. This option is only available when CAC is enabled.

- **Reserved Roaming Bandwidth**—Specify the percentage of reserved roaming bandwidth. This option is only available when CAC is enabled.

- **Expedited Bandwidth**—Select the check box to enable expedited bandwidth as an extension of CAC for emergency calls.
You must have an expedited bandwidth IE that is CCXv5 compliant so that a TSPEC request is given higher priority.

- **SIP CAC**—Select the check box to enable SIP CAC. SIP CAC should be used only for phones that support status code 17 and do not support TSPEC-based admission control.

- **SIP Codec**—Specify the codec name you want to use on this radio. The available options are G.711, G.729, and User Defined.

- **SIP Call Bandwidth**—Specify the bandwidth in kilobits per second that you want to assign per SIP call on the network. This parameter can be configured only when the SIP Codec selected is User Defined.

- **SIP Sample Interval**—Specify the sample interval in milliseconds that the codec must operate in.

- **Max Number of Calls per Radio**—Specify the maximum number of calls per Radio.

- **Metric Collection**—Select the check box to enable metric collection.

  Traffic stream metrics are a series of statistics about VoIP over your wireless LAN which inform you of the QoS of the wireless LAN. For the access point to collect measurement values, traffic stream metrics must be enabled. When this is enabled, the controller begins collecting statistical data every 90 seconds for the 802.11b/g interfaces from all associated access points. If you are using VoIP or video, this feature should be enabled.

**Step 5** On the Video tab, add or modify the following parameters:

- **Admission Control (ACM)**—Select the check box to enable admission control.

- **Maximum Bandwidth**—Specify the percentage of maximum bandwidth allowed. This option is only available when CAC is enabled.

- **Reserved Roaming Bandwidth**—Specify the percentage of reserved roaming bandwidth. This option is only available when CAC is enabled.

- **Unicast Video Redirect**—Select the **Unicast Video Redirect** check box to enable all non-media stream packets in video queue are redirected to the best effort queue. If disabled, all packets with video marking are kept in video queue.

- **Client Minimum Phy Rate**—Specify the physical data rate required for the client to join a media stream from the Client Minimum Phy Rate drop-down list.

- **Multicast Direct Enable**—Select the **Multicast Direct Enable** check box to set the Media Direct for any WLAN with Media Direct enabled on a WLAN on this radio.

- **Maximum Number of Streams per Radio**—Specify the maximum number of streams per Radio to be allowed.

- **Maximum Number of Streams per Client**—Specify the maximum number of streams per Client to be allowed.

- **Best Effort QOS Admission**—Select the **Best Effort QOS Admission** check box to redirect new client requests to the best effort queue. This happens only if all the video bandwidth has been used.

  **Note** If disabled and maximum video bandwidth has been used, then any new client request is rejected.

**Step 6** On the General tab, specify the following parameter:

- **Maximum Media Bandwidth (0 to 85%)**—Specify the percentage of maximum of bandwidth allowed. This option is only available when CAC is enabled.

**Step 7** Click **Save**.
Once saved, the template displays in the Template List page. In the Template List page, you can apply this template to controllers. See the “Applying Controller Templates” section on page 11-2 for more information.

Related Topics

- Configuring Media Parameters for Controller Templates
- Accessing Controller Template Launch Pad
- Adding Controller Templates
- Deleting Controller Templates
- Applying Controller Templates

Configuring EDCA Parameters Controller Templates (802.11b/g/n)

Create or modify a template for configuring 802.11b/g/n EDCA parameters. EDCA parameters designate pre-configured profiles at the MAC layer for voice and video.

To add a new template with 802.11b/g/n EDCA parameters information for a controller, follow these steps:

**Step 1** Choose **Configure > Controller Template Launch Pad**.

**Step 2** Click **New** beside the template you want to add.

**Step 3** Add or modify the following parameters:

- **Template Name**

  **Note** Template Name is the unique key used to identify the template. A template name is mandatory to distinguish between two templates that have identical key attributes.

- **EDCA Profile**—Profiles include Wi-Fi Multimedia (WMM), Spectralink Voice Priority (SVP), Voice Optimized, and Voice & Video Optimized. WMM is the default EDCA profile.

  **Note** You must shut down radio interface before configuring EDCA Parameters.

- **Streaming MAC**—Only enable streaming MAC if all clients on the network are WMM compliant.

**Step 4** Click **Save**. Once saved, the template displays in the Template List page. In the Template List page, you can apply this template to controllers. See the “Applying Controller Templates” section on page 11-2 for more information.

Configuring Roaming Parameters Controller Templates (802.11b/g/n)

Create or modify a template for configuring roaming parameters for 802.11b/g/n radios.

To add a new template with 802.11b/g/n Roaming parameters information for a controller, follow these steps:
Step 1 Choose Configure > Controller Template Launch Pad.

Step 2 Click New beside the template you want to add.

Step 3 Add or modify the following parameters:

- **Template Name**

  **Note** Template Name is the unique key used to identify the template. A template name is mandatory to distinguish between two templates that have identical key attributes.

- **Mode**—Choose Default Values or Custom Values from the drop-down list.
  - Default Values—The roaming parameters are unavailable and the default values are displayed.
  - Custom Values—The following roaming parameters can be edited.

- **Minimum RSSI**—Enter a value for the minimum Received Signal Strength Indicator (RSSI) required for the client to associate to an access point.
  - Range: -80 to -90 dBm
  - Default: -85 dBm

- **Roaming Hysteresis**—Enter a value to indicate how strong the signal strength of a neighboring access point must be in order for the client to roam to it. This parameter is intended to reduce the amount of “ping ponging” between access points if the client is physically located on or near the border between two access points.
  - Range: 2 to 4 dB
  - Default: 2 dB

- **Adaptive Scan Threshold**—Enter the RSSI value, from a client associated access point, below which the client must be able to roam to a neighboring access point within the specified transition time. This parameter also provides a power-save method to minimize the time that the client spends in active or passive scanning. For example, the client can scan slowly when the RSSI is above the threshold and scan more rapidly when below the threshold.
  - Range: -70 to -77 dB
  - Default: -72 dB

- **Transition Time**—Enter the maximum time allowed for the client to detect a suitable neighboring access point to roam to and to complete the roam, whenever the RSSI from the client associated access point is below the scan threshold.
  - Range: 1 to 10 seconds
  - Default: 5 seconds

**Note** The Scan Threshold and Transition Time parameters guarantee a minimum level of client roaming performance. Together with the highest expected client speed and roaming hysteresis, these parameters make it possible to design a wireless LAN network that supports roaming simply by ensuring a certain minimum overlap distance between access points.
Step 4 Click **Save**. Once saved, the template displays in the Template List page. In the Template List page, you can apply this template to controllers. See the “Applying Controller Templates” section on page 11-2 for more information.

### Configuring High Throughput (802.11n) Controller Templates (802.11b/g/n)

Create or modify a template for configuring high-throughput parameters such as MCS (data rate) settings and indexes and for applying these 802.11n settings to multiple controllers.

To add a new template with High Throughput (802.11n) information for a controller, follow these steps:

**Step 1** Choose **Configure > Controller Template Launch Pad**.

**Step 2** Click **New** beside the template you want to add.

**Step 3** Add or modify the following parameters:
- **Template Name**
  - **Note**: Template Name is the unique key used to identify the template. A template name is mandatory to distinguish between two templates that have identical key attributes.
- **802.11n Network Status**—Select the check box to enable high throughput.
- **MCS (Data Rate) Settings**—Choose which level of data rate you want supported. MCS is modulation coding schemes which are similar to 802.11a data rate.
  - **Note**: As a default, 20 MHz and short guarded interval are used.
  - **Note**: When you select the Supported check box, the chosen numbers appear in the Selected MCS Indexes page.

**Step 4** Click **Save**. Once saved, the template displays in the Template List page. In the Template List page, you can apply this template to controllers. See the “Applying Controller Templates” section on page 11-2 for more information.

### Configuring CleanAir Controller Templates (802.11 b/g/n)

Create or modify a template for configuring CleanAir parameters for the 802.11 b/g/n radio. You can configure the template to enable or disable CleanAir, reporting and alarms for the controllers. You can also configure the type of interfering devices to include for reporting and alarms.

To add a new template with 802.11b/g/n CleanAir information for a controller, follow these steps:

**Step 1** Choose **Configure > Controller Template Launch Pad**.
Step 2 From the left sidebar menu, choose **802.11b/g/n > CleanAir**. The 802.11b/g/n CleanAir Controller Templates page displays all currently saved 802.11b/g/n CleanAir templates. It also displays the number of controllers and virtual domains to which each template is applied.

Step 3 From the Select a command drop-down list, choose **Add a Template**, and click **Go**. The **New Controller Template** page appears.

Step 4 Add or modify the following parameters:

- **Template Name**—Enter the template name.
- **CleanAir**—Select the check box to enable CleanAir functionality on the 802.11 b/g/n network, or unselect to prevent the controller from detecting spectrum interference. The default value is selected.

  **Note** If CleanAir is enabled, the Reporting Configuration and Alarm Configuration sections appear.

- **Reporting Configuration**—Use the parameters in this section to configure the interferer devices you want to include for your reports.
  - **Report Interferers**—Select the **report interferers** check box to enable CleanAir system to report and detect sources of interference, or unselect it to prevent the controller from reporting interferers. The default value is selected.
  - Make sure that any sources of interference that need to be detected and reported by the CleanAir system appear in the Interferences to Detect box and any that do not need to be detected appear in the Interferers to Ignore box. Use the > and < buttons to move interference sources between these two boxes. By default, all interference sources are ignored.

- **Alarm Configuration**—This section enables you to configure triggering of air quality alarms.
  - **Air Quality Alarm**—Select the **Air Quality Alarm** check box to enable the triggering of air quality alarms, or unselect the box to disable this feature.
  - **Air Quality Alarm Threshold**—If you selected the Air Quality Alarm check box, enter a value between 1 and 100 (inclusive) in the Air Quality Alarm Threshold text box to specify the threshold at which you want the air quality alarm to be triggered. When the air quality falls below the threshold level, the alarm is triggered. A value of 1 represents the worst air quality, and 100 represents the best. The default value is 1.
  - **Interferers For Security Alarm**—Select the **Interferers For Security Alarm** check box to trigger interferer alarms when the controller detects specified device types, or unselected it to disable this feature. The default value is unselected.
  - Make sure that any sources of interference that need to trigger interferer alarms appear in the Interferers Selected for Security Alarms box and any that do not need to trigger interferer alarms appear in the Interferers Ignored for Security Alarms box. Use the > and < buttons to move interference sources between these two boxes. By default, all interferer sources for security alarms are ignored.

Step 5 Click **Save**. Once saved, the template displays in the Template List page. In the Template List page, you can apply this template to controllers. See the “Adding Controller Templates” section on page 11-2 for more information.

### Configuring 802.11b/g/n RRM Templates

This section contains the following topics:
Configuring RRM Thresholds Controller Templates (802.11b/g/n)

Create or modify a template for setting various RRM thresholds such as load, interference, noise, and coverage.

To add a new template with 802.11b/g/n RRM thresholds information for a controller, follow these steps:

**Step 1** Choose **Configure > Controller Template Launch Pad**.

**Step 2** Click **New** beside the template you want to add.

**Step 3** Add or modify the following General parameter:
- **Template Name**

  **Note** Template Name is the unique key used to identify the template. A template name is mandatory to distinguish between two templates that have identical key attributes.

**Step 4** Add or modify the following Coverage Hole Algorithm parameters:
- **Min. Failed Clients (#)**—Enter the minimum number of failed clients currently associated with the controller.
- **Coverage Level**—Enter the target range of coverage threshold (dB).
- **Signal Strength**—When the Coverage Level parameter is adjusted, the value of the Signal Strength (dBm) automatically reflects this change. The Signal Strength parameter provides information regarding what the signal strength will be when adjusting the coverage level.
- **Data RSSI**—Enter the Data RSSI (-60 to -90 dBm). This number indicates the value for the minimum received signal strength indicator (RSSI) for data required for the client to associate to an access point.
- **Voice RSSI**—Enter the Voice RSSI (-60 to -90 dBm). This number indicates the value for the minimum received signal strength indicator (RSSI) required for voice for the client to associate to an access point.

**Step 5** Add or modify the following Load Thresholds parameters:
- **Max. Clients**—Enter the maximum number of clients able to be associated with the controller.
- **RF Utilization**—Enter the percentage of threshold for this radio type.

**Step 6** Add or modify the following Threshold for Traps parameters:
- **Interference Threshold**—Enter an interference threshold between 0 and 100 percent.
- **Noise Threshold**—Enter a noise threshold between -127 and 0 dBm. When outside of this threshold, the controller sends an alarm to WCS.
- **Coverage Exception Level**—Enter the coverage exception level percentage. When the coverage drops by this percentage from the configured coverage for the minimum number of clients, a coverage hole is generated.
Configuring Controller Templates

Configuring RRM Intervals Controller Templates (802.11b/g/n)

Create or modify a template for configuring RRM intervals for 802.11b/g/n radios.

To add a new template with 802.11b/g/n RRM intervals information for a controller, follow these steps:

**Step 1** Choose Configure > Controller Template Launch Pad.

**Step 2** Click New beside the template you want to add.

**Step 3** Add or modify the following parameters:

- **Template Name**
  - Note: Template Name is the unique key used to identify the template. A template name is mandatory to distinguish between two templates that have identical key attributes.

- **Neighbor Packet Frequency**—Enter at which interval you want strength measurements taken for each access point. The default is 300 seconds.

- **Noise Measurement Interval**—Enter at which interval you want noise and interference measurements taken for each access point. The default is 180 seconds.

- **Load Measurement Interval**—Enter at which interval you want load measurements taken for each access point. The default is 300 seconds.

- **Channel Scan Duration**—Enter at which interval you want coverage measurements taken for each access point. The default is 300 seconds.

**Step 4** Click Save. Once saved, the template displays in the Template List page. In the Template List page, you can apply this template to controllers. See the “Applying Controller Templates” section on page 11-2 for more information.

Configuring an RRM Dynamic Channel Allocation Template (802.11b/g/n)

The Radio Resource Management (RRM) Dynamic Channel Assignment (DCA) page allows you to choose the DCA channels as well as the channel width for this controller.

RRM DCA supports 802.11n 40-MHz channel width in the 5-GHz band. The higher bandwidth allows radios to achieve higher instantaneous data rates.

- **Note:** Choosing a larger bandwidth reduces the non-overlapping channels which could potentially reduce the overall network throughput for certain deployments.

To configure 802.11b/g/n RRM DCA template, follow these steps:

**Step 1** Choose Configure > Controller Template Launch Pad.
Step 2  Click DCA or choose 802.11b/g/n > DCA. The 802.11b/g/n DCS Template appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 3  If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The 802.11b/g/n TPC template page appears.

Step 4  Add or modify the following parameters:

- Template Name—Enter the template name.
- Assignment Mode—From the Dynamic Assignment drop-down list, choose one of three modes:
  - Automatic - The transmit power is periodically updated for all access points that permit this operation.
  - On Demand - Transmit power is updated when the Assign Now button is selected.
  - Disabled - No dynamic transmit power assignments occur, and values are set to their global default.
- Select the Avoid Foreign AP Interference check box to enable it. Enable this parameter to have RRM consider interference from foreign Cisco access points (those non-Cisco access points outside RF/mobility domain) when assigning channels. This foreign 802.11 interference. Disable this parameter to have RRM ignore this interference.
  
  In certain circumstances with significant interference energy (dB) and load (utilization) from foreign access points, RRM may adjust the channel assignment to avoid these channels (and sometimes adjacent channels) in access points close to the foreign access points. This increases capacity and reduces variability for the Cisco WLAN Solution.

- Select the Avoid Cisco AP Load check box if you want it enabled. Enable this bandwidth-sensing parameter to have controllers consider the traffic bandwidth used by each access point when assigning channels to access points. Disable this parameter to have RRM ignore this value.
  
  In certain circumstances and with denser deployments, there may not be enough channels to properly create perfect channel re-use. In these circumstances, RRM can assign better re-use patterns to those access points that carry more traffic load.

- Select the Avoid non 802.11 Noise check box if you want to enable it. Enable this noise-monitoring parameter to have access points avoid channels that have interference from non-access point sources, such as microwave ovens or Bluetooth devices. Disable this parameter to have RRM ignore this interference.
  
  In certain circumstances with significant interference energy (dB) from non-802.11 noise sources, RRM may adjust the channel assignment to avoid these channels (and sometimes adjacent channels) in access points close to the noise sources. This increases capacity and reduces variability for the Cisco WLAN Solution.

- The Signal Strength Contribution check box is always enabled (not configurable). constantly monitors the relative location of all access points within the RF/mobility domain to ensure near-optimal channel re-use. The net effect is an increase in Cisco WLAN Solution capacity and a reduction in co-channel and adjacent channel interference.
• Enable or disable event-driven Radio Resource Management (RRM) using the following parameters. Event Driven RRM is used when a CleanAir-enabled access point detects a significant level of interference.
  - Event Driven RRM—Enable or Disable spectrum event-driven RRM. By default, Event Driven RRM is enabled.
  - Sensitivity Threshold—If Event Driven RRM is enabled, this field displays the threshold level at which event-driven RRM is triggered. It can have a value of either Low, Medium, or High. When the interference for the access point rises above the threshold level, RRM initiates a local Dynamic Channel Assignment (DCA) run and changes the channel of the affected access point radio if possible to improve network performance. Low represents a decreased sensitivity to changes in the environment while High represents an increased sensitivity.

**Step 5**  Click **Save**.

---

**Configuring an RRM Transmit Power Control Template (802.11b/g/n)**

The controller dynamically controls access point transmit power based on real-time wireless LAN conditions. Normally, power can be kept low to gain extra capacity and reduce interference. The controller attempts to balance the access points’ transmit power according to how the access points are seen by their third strongest neighbor.

The transmit power control (TPC) algorithm both increases and decreases an access point’s power in response to changes in the RF environment. In most instances TPC will seek to lower an access point’s power to reduce interference, but in the case of a sudden change in the RF coverage—for example, if an access point fails or becomes disabled—TPC can also increase power on surrounding access points. This feature is different from Coverage Hole Detection, explained below. Coverage hole detection is primarily concerned with clients, while TPC is tasked with providing enough RF power to achieve desired coverage levels while avoiding channel interference between access points.

To configure 802.11b/g/n RRM TPC template, follow these steps:

**Step 1**  Choose **Configure > Controller Template Launch Pad**.

**Step 2**  Click **TPC** or choose **802.11b/g/n > TPC**. The 802.11b/g/n TPC Template appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3**  If you want to add a new template, choose **Add Template** from the Select a command drop-down list, and click **Go**. To modify an existing template, click the template name. The 802.11b/g/n TPC template page appears.

**Step 4**  Add or modify the following parameters:
  - **Template Name**—Enter the template name.
  - **Dynamic Assignment**—From the Dynamic Assignment drop-down list, choose one of three modes:
    - **Automatic** - The transmit power is periodically updated for all access points that permit this operation.
    - **On Demand** - Transmit power is updated when the Assign Now button is selected.


Configuring Controller Templates

- Disabled - No dynamic transmit power assignments occur, and values are set to their global default.
- Maximum Power Assignment—Indicates the maximum power assigned.
  - Range: -10 to 30 dB
  - Default: 30 dB
- Minimum Power Assignment—Indicates the minimum power assigned.
  - Range: -10 to 30 dB
  - Default: 30 dB
- Dynamic Tx Power Control—Determine if you want to enable Dynamic Tx Power Control.
- Transmitted Power Threshold—Enter a transmitted power threshold between -50 and -80.
- Control Interval—In seconds (read-only).

Step 5  Click Save.

Configuring Mesh Templates

This section contains the following topics:

- Configuring Mesh Setting Templates, page 11-129

Configuring Mesh Setting Templates

You can configure an access point to establish a connection with the controller.

To add or modify a mesh template, follow these steps:

Step 1  Choose Configure > Controller Template Launch Pad.

Step 2  Click Mesh Configuration or choose Mesh > Mesh Configuration from the left sidebar menu. The Mesh Configuration Template page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. This initial page also displays the rootAP to MeshAP range, the client access on backhaul link, and security mode. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 3  If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The Mesh Configuration template page appears (see Figure 11-54).
Step 4 The Root AP to Mesh AP Range is 12,000 feet by default. Enter the optimum distance (in feet) that should exist between the root access point and the mesh access point. This global parameter applies to all access points when they join the controller and all existing access points in the network.

Step 5 The Client Access on Backhaul Link check box is not selected by default. When this option is enabled, mesh access points can associate with 802.11a/n wireless clients over the 802.11a/n backhaul. This client association is in addition to the existing communication on the 802.11a/n backhaul between the root and mesh access points.

Note This feature applies only to access points with two radios.

Step 6 The Mesh DCA Channels check box is not selected by default. Select this option to enable backhaul channel deselection on the Controller using the DCA channel list configured in the Controller. Any change to the channels in the Controller DCA list is pushed to the associated access points. This feature applies only to the 1524SB mesh access points. For more information on this feature, see the Controller Configuration Guide.

Step 7 Select the Background Scanning check box to enable background scanning or unselect it to disable the feature. The default value is disabled. Background scanning allows Cisco Aironet 1510 Access Points to actively and continuously monitor neighboring channels for more optimal paths and parents. See the “Background Scanning on 1510s in Mesh Networks” section on page 9-52 for further information.

Step 8 From the Security Mode drop-down list, choose EAP (Extensible Authentication Protocol) or PSK (Pre-Shared Key).

Step 9 Click Save.

Configuring Management Templates

This section contains the following topics:
Configuring Trap Receiver Templates

If you have monitoring devices on your network that receive SNMP traps, you may want to add a trap receiver template.

To add or modify a trap receiver template, follow these steps:

Step 1  Choose Configure > Controller Template Launch Pad.

Step 2  Click Trap Receivers or choose Management > Trap Receivers from the left sidebar menu.

Step 3  The Management > Trap Receiver page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. This initial page also displays the IP address and admin status. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 4  If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The Trap Receivers template page appears (see Figure 11-55).
Figure 11-55  Trap Receiver Template

Step 5  If you are creating a new template, enter the new Trap Receiver Template name.

**Note** Template name will be used as Trap Receiver Community Name when applying to the Controller.

Step 6  Enter the IP address of the server.

Step 7  If you want SNMP traps to be sent to the receiver, select the **Admin Status** check box.

Step 8  Click **Save**.

**Configuring Trap Control Templates**

To add or modify a trap control template, follow these steps:

**Step 1** Choose **Configure > Controller Template Launch Pad**.

**Step 2** Click **Trap Control** or choose **Management > Trap Control** from the left sidebar menu. The Management > Trap Control page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. This initial page also displays the link port up or down and rogue AP. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.
Step 3
If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The Trap Control template page appears (see Figure 11-56).

Figure 11-56 Trap Controls Template

Step 4
Select the appropriate check box to enable any of the following miscellaneous traps:

- SNMP Authentication—The SNMPv2 entity has received a protocol message that is not properly authenticated. When a user who is configured in SNMP V3 mode tries to access the controller with an incorrect password, the authentication fails and a failure message is displayed. However, no trap logs are generated for the authentication failure.

- Link (Port) Up/Down—Link changes states from up or down.

- Multiple Users—Two users log in with the same login ID.

- Spanning Tree—Spanning Tree traps. See the STP specification for descriptions of individual parameters.

- Rogue AP—Whenever a rogue access point is detected or when a rogue access point was detected earlier and no longer exists, this trap is sent with its MAC address.

- Controller Config Save—Notification sent when the configuration is modified.

Step 5
Select the appropriate check box to enable any of the following client-related traps:

- 802.11 Association—A trap is sent when a client is associated to a WLAN. This trap does not guarantee that the client is authenticated.
• 802.11 Disassociation—The disassociate notification is sent when the client sends a disassociation frame.
• 802.11 Deauthentication—The deauthenticate notification is sent when the client sends a deauthentication frame.
• 802.11 Failed Authentication—The authenticate failure notification is sent when the client sends an authentication frame with a status code other than successful.
• 802.11 Failed Association—The associate failure notification is sent when the client sends an association frame with a status code other than successful.
• Excluded—The associate failure notification is sent when a client is excluded.

Step 6
Select the appropriate check box to enable any of the following access point traps:
• AP Register—Notification sent when an access point associates or disassociates with the controller.
• AP Interface Up/Down—Notification sent when access point interface (802.11a/n or 802.11b/g/n) status goes up or down.

Step 7
Select the appropriate check box to enable any of the following auto RF profile traps:
• Load Profile—Notification sent when Load Profile state changes between PASS and FAIL.
• Noise Profile—Notification sent when Noise Profile state changes between PASS and FAIL.
• Interference Profile—Notification sent when Interference Profile state changes between PASS and FAIL.
• Coverage Profile—Notification sent when Coverage Profile state changes between PASS and FAIL.

Step 8
Select the appropriate check box to enable any of the following auto RF update traps:
• Channel Update—Notification sent when access point’s dynamic channel algorithm is updated.
• Tx Power Update—Notification sent when access point’s dynamic transmit power algorithm is updated.

Step 9
Select the appropriate check box to enable any of the following AAA traps:
• User Auth Failure—This trap is to inform you that a client RADIUS authentication failure has occurred.
• RADIUS Server No Response—This trap is to indicate that no RADIUS server(s) are responding to authentication requests sent by the RADIUS client.

Step 10
Select the appropriate check box to enable the following IP security traps:
• ESP Authentication Failure
• ESP Replay Failure
• Invalid SPI
• IKE Negotiation Failure
• IKE Suite Failure
• Invalid Cookie

Step 11
Select the appropriate check box to enable the following 802.11 security trap:
• WEP Decrypt Error—Notification sent when the controller detects a WEP decrypting error.
• Signature Attack

Step 12
Click Save.
Configuring Telnet SSH Templates

To add or modify a Telnet SSH configuration template, follow these steps:

**Step 1** Choose **Configure > Controller Template Launch Pad**.

**Step 2** Click **Telnet SSH** or choose **Management > Telnet SSH** from the left sidebar menu. The Management > Telnet SSH Configuration page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. This initial page also displays the session timeout, maximum sessions, and whether Telnet or SSH sessions are allowed. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3** If you want to add a new template, choose **Add Template** from the Select a command drop-down list, and click **Go**. To modify an existing template, click the template name. The Telnet SSH template page appears (see **Figure 11-57**).

**Figure 11-57  Telnet SSH Configuration Template**

![Telnet SSH Configuration Template](image)

**Step 4** Enter the number of minutes a Telnet session is allowed to remain inactive before being logged off. A zero means there is no timeout. The valid range is 0 to 160, and the default is 5.

**Step 5** At the Maximum Sessions parameter, enter the number of simultaneous Telnet sessions allowed. The valid range is 0 to 5, and the default is 5. New Telnet sessions can be allowed or disallowed on the DS (network) port. New Telnet sessions are always allowed on the service port.

**Step 6** Use the Allow New Telnet Session drop-down list to determine if you want new Telnet sessions allowed on the DS port. New Telnet sessions can be allowed or disallowed on the DS (network) port. New Telnet sessions are always allowed on the service port. The default is no.
Configuring Controller Templates

Step 7 Use the Allow New SSH Session drop-down list to determine if you want Secure Shell Telnet sessions allowed. The default is yes.

Step 8 Click Save.

Configuring Legacy Syslog Templates

To add or modify a legacy syslog configuration template, follow these steps:

Note Legacy Syslog applies to controllers earlier than version 5.0.6.0

Step 1 Choose Configure > Controller Template Launch Pad.

Step 2 Click Legacy Syslog or choose Management > Legacy Syslog from the left sidebar menu. The Management > Legacy Syslog page appears, and the number of controllers and virtual domains that the template is applied to automatically populates. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 3 If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The Legacy Syslog template page appears (see Figure 11-58).

Figure 11-58 Syslog Configuration Template

Step 4 Enter a template name. The number of controllers to which this template is applied is displayed.
Chapter 11      Using Templates

Configuring Controller Templates

Step 5  Select the Syslog check box. When you do, a Syslog Host IP Address parameter appears.

Step 6  Click Save.

Configuring Multiple Syslog Templates

To add or modify a multiple syslog configuration template, follow these steps:

Note  You can enter up to three syslog server templates.

Step 1  Choose Configure > Controller Template Launch Pad.

Step 2  Click Multiple Syslog or choose Management > Multiple Syslog from the left sidebar menu. The
Management > Multiple Syslog page appears, and the number of controllers and virtual domains that the
template is applied to automatically populates. This initial page also displays the syslog server address.
The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page,
which displays the controller name and IP address to which that template is applied, as well as the time
it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link
opens an Applied to Virtual Domains page that shows all partition names.

Step 3  If you want to add a new template, choose Add Template from the Select a command drop-down list,
and click Go. To modify an existing template, click the template name. The Multiple Syslog template
page appears (see Figure 11-59).

Figure 11-59  Syslog Server Template Page

Step 4  Enter a template name and a syslog server IP address.
Configuring Local Management User Templates

To add or modify a local management user template, follow these steps:

**Step 1** Choose **Configure > Controller Template Launch Pad**.

**Step 2** Click **Local Management Users** or choose **Management > Local Management Users** from the left sidebar menu. The Management > Local Management Users Template appears, and the number of controllers and virtual domains that the template is applied to automatically populates. This initial page also displays the username and access level. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3** If you want to add a new template, choose **Add Template** from the Select a command drop-down list, and click **Go**. To modify an existing template, click the template name. The Local Management Users template page appears (see Figure 11-60).

**Step 4** Enter a template name.

**Step 5** Enter a template username.

**Step 6** Enter a password for this local management user template.

**Step 7** Re-enter the password.

**Step 8** Use the Access Level drop-down list to choose either **Read Only** or **Read Write**.
Step 9 Click Save.

Configuring User Authentication Priority Templates

Management user authentication priority templates control the order in which authentication servers are used to authenticate a controller’s management users.

To add a user authentication priority template or make modifications to an existing template, follow these steps:

Step 1 Choose Configure > Controller Template Launch Pad.

Step 2 Click Authentication Priority or choose Management > Authentication Priority from the left sidebar menu. The Management > Local Management Users Template appears, and the number of controllers and virtual domains that the template is applied to automatically populates. This initial page also displays the authentication priority list. The last column indicates when the template was last saved.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

Step 3 If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The Local Management Users template page appears (see Figure 11-61).

Figure 11-61 User Authentication Priority Template

Step 4 Enter a template name.

Step 5 The local server is tried first. Choose either RADIUS or TACACS+ to try if local authentication fails.

Step 6 Click Save.
Applying a Set of CLI Commands

You can create templates containing a set of CLI commands and apply them to one or more controllers from WCS. These templates are meant for provisioning features in multiple controllers for which there is no SNMP support or custom WCS user interface. The template contents are simply a command array of strings. No support for substitution variables, conditionals, and the like exist.

The CLI sessions to the device are established based on user preferences. The default protocol is SSH. See the “Configuring Protocols for CLI Sessions” section on page 16-67 for information on setting protocol user preferences.

To add or modify a CLI template, follow these steps:

**Step 1** Choose **Configure > Controller Template Launch Pad**.

**Step 2** Click **CLI > General** or choose **CLI > General** from the left sidebar menu. The CLI > General page appears, and the number of controllers that the template is applied to automatically populates.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3** If you want to add a new template, choose **Add Template** from the Select a command drop-down list, and click **Go**. To modify an existing template, click the template name. The Command-Line Interface General template page appears (see **Figure 11-62**).

**Figure 11-62 Command-Line Interface Template**

**Step 4** If you are adding a new template, provide a name that you are giving to this string of commands. If you are making modifications to an existing template, the Template Name field cannot be modified.

**Step 5** In the Commands page, enter the series of CLI commands.
Step 6  Click Save to save the CLI commands to the WCS database without applying to the selected controllers or Apply to Controllers to save the commands to the WCS database as well as apply to the selected controllers. If you click Apply to Controllers, choose the IP address of the controller to which you want to apply the template.

**Note**  When the template is applied to the selected controllers, a status screen appears. If an error occurred while you applied the template, an error message is displayed. You can click the icon in the Session Output column to get the entire session output.

**Note**  If the Controller Telnet credentials check fails or the Controller CLI template fails with invalid username and password even though the correct username and password are configured on the controller, check whether the controller has exceeded the number of CLI connections it can accept. If the connections have exceeded the maximum limit, then either increase the maximum allowed CLI sessions or terminate any pre-existing CLI sessions on the controller, and then retry the operation.

---

### Configuring Location Configuration Templates

To add or modify a location setting template, follow these steps:

**Step 1**  Choose Configure > Controller Template Launch Pad.

**Step 2**  Click Location > Location Configuration or choose Location > Location Configuration from the left sidebar menu. The Location > Location Configuration page appears, and the number of controllers that the template is applied to automatically populates.

The Applied to Controllers number is a link. Clicking the number opens an Applied to Controllers page, which displays the controller name and IP address to which that template is applied, as well as the time it was applied and its status. The Applied to Virtual Domains number is also a link. Clicking this link opens an Applied to Virtual Domains page that shows all partition names.

**Step 3**  If you want to add a new template, choose Add Template from the Select a command drop-down list, and click Go. To modify an existing template, click the template name. The template page appears (see Figure 11-63).
Step 4  Select the **RFID Tag Data Collection** check box to enable tag collection. Before the location server can collect asset tag data from controllers, you must enable the detection of active RFID tags using the CLI `config rfid status enable` command on the controllers.

Step 5  Select the **Calibrating Client** check box to enable calibration for the client. Controllers send regular S36 or S60 requests (depending on the client capability) by way of the access point to calibrating clients. Packets are transmitted on all channels. All access points irrespective of channel (and without a channel change) gather RSSI data from the client at each location. These additional transmissions and channel changes might degrade contemporaneous voice or video traffic.

**Note**  To use all radios (802.11a/b/g/n) available, you must enable multiband in the Advanced page.

Step 6  Select the **Normal Client** check box to have a non-calibrating client. No S36 or S60 requests are transmitted to the client.

Step 7  Specify how many seconds should elapse before notification of the found element (tags, clients, and rogue APs/clients).

Step 8  Enter the number of seconds after which RSSI measurements for clients should be discarded.

Step 9  Enter the number of seconds after which RSSI measurements for calibrating clients should be discarded.

Step 10 Enter the number of seconds after which RSSI measurements for tags should be discarded.

Step 11 Enter the number of seconds after which RSSI measurement for rogue access points should be discarded.

Step 12 Click the **Advanced** tab.

Step 13 Enter a value in seconds to set the RFID tag data timeout setting.

Step 14 Select the **Calibrating Client Multiband** check box to send S36 and S60 packets (where applicable) on all channels. Calibrating clients must be enabled in the General pane.
Configuring AP Configuration Templates

This menu provides access to the access point templates summary details. Use the selector area to access and configure the respective templates details.

Note
Select the template name to view or edit parameters for current access point templates. View the applicable steps in Configuring a New Lightweight Access Point Template, page 11-143 for more information on access point template parameters.

This section contains the following topics:

- Configuring Lightweight Access Point Templates, page 11-143
- Configuring Autonomous Access Point Templates, page 11-152

Configuring Lightweight Access Point Templates

This section contains the following topics:

- Configuring a New Lightweight Access Point Template, page 11-143
- Editing a Current Lightweight Access Point Template, page 11-151

Configuring a New Lightweight Access Point Template

To configure a new lightweight access point template, follow these steps:

Step 1 Choose Configure > AP Configuration Templates > Lightweight AP.
Step 2 From the Select a command drop-down list, choose Add Template.
Step 3 Click Go.
Step 4 Enter a template name.
Step 5 Enter a template description.
Step 6 Click Save.
Step 7 Once loaded, the access point template detail page appears.
Step 8 The following tabs include the access point template information:
  - AP Parameters
  - Mesh
  - 802.11a/n Parameters
  - 802.11a SubBand Parameters
  - 802.11b/g/n Parameters
  - CDP
• Select APs
• Apply/Schedule
• Report

**AP Parameters**

Select the check box of the access point parameters that must be applied.

• Location—Enter the location in the Location text box.
• Admin Status—Select the **Admin and Enabled** check box to enable administrative status.

**Note**  
To conserve energy, access points can be turned off at specified times during non-working hours. Select the **Enabled** check box to allow access points to be turned on or off.

• AP Mode—From the drop-down list, choose one of the following:
  - **Local**—Default
  - **Monitor**—Monitor mode only.

**Note**  
Choose **Monitor** to enable this access point template for Cisco Adaptive wIPS. Once Monitor is selected, select the **Enhanced WIPS Engine** check box and the **Enabled** check box. Then select the **AP Monitor Mode Optimization** check box and choose WIPS from the AP Monitor Mode Optimization drop-down list. For more information on Cisco Adaptive wIPS, see the “Configuring wIPS Profiles” section on page 9-211, or the “wIPS Policy Alarm Encyclopedia” section on page 20-1, and the “Mobility Services” section on page 12-1.

  - **H-REAP/REAP**—Cisco 1030 remote edge lightweight access point (REAP) used for Cisco 1030 IEEE 802.11a/b/g/n remote edge lightweight access points.

**Note**  
H-REAP must be selected to configure an OfficeExtend access point. When the AP mode is H-REAP, H-REAP configuration options display including the option to enable OfficeExtend AP and to enable Least Latency Controller Join. See the “Configuring Hybrid REAP” section on page 13-4 for more information.

  - Rogue Detector—Monitors the rogue access points but does not transmit or contain rogue access points.
  - Bridge
  - Sniffer—The access point “sniffs” the air on a given channel. It captures and forwards all the packets from the client on that channel to a remote machine that runs airopeek (a packet analyzer for IEEE 802.11 wireless LANs). It includes information on timestamp, signal strength, packet size, and so on. If you choose Sniffer as an operation mode, you are required to enter a channel and server IP address on the AP/Radio Templates 802.11b/g/n or 802.11a/n parameters tab.
The sniffer feature can be enabled only if you are running AiroPeek, which is a third-party network analyzer software that supports decoding of data packets. For more information, see the AiroPeek website.

SE-Connect—This mode allows a CleanAir-enabled access point to be used extensively for interference detection on all monitored channels. All other functions such as IDS scanning and Wi-Fi are suspended.

This option is displayed only if the access point is CleanAir-capable.

Changing the AP mode reboots the access point.

- Enhanced wIPS Engine—Select the Enhanced wIPS engine and the Enabled check box to enable.
- AP Monitor Mode Optimization—Choose None or wIPS from the drop-down list.
- AP Height (feet)—Enter the height of the access point (in feet) in the text box.
- Mirror Mode—Select the Enabled check box to enable mirror mode.
- Country Code—Choose the appropriate country code from the drop-down list.

Changing the country code may cause the access point to reboot.

- Stats Collection Interval—Enter the stats collection interval in the text box.
- Cisco Discovery Protocol—Select the Enabled check box to enable Cisco Discovery Protocol.
- AP Failover Priority—Choose Low, Medium, High, or Critical from the drop-down list to indicate the access point failover priority. The default priority is low. See the “Setting AP Failover Priority” section on page 9-153 for more information.
- Pre-Standard State
- Power Injector State—When enabled, this allows you to manipulate power injector settings through WCS without having to go directly to the controllers. If the Enable Power Injector State is selected, power injector options appear.
- Power Injector Selection—Choose installed or override from the drop-down list.
- Injector Switch MAC Address—Enter the MAC address of the injector switch.
- Primary, Secondary, and Tertiary Controller IP—The Primary/Secondary/Tertiary Controller IP is the Management IP of the controller.
- Domain Name
- Domain Name Server IP Address—Domain Name Server IP and Domain Name can be configured only on APs which have static IP.
- Rogue Detection—Select the check box to enable rogue detection. See the “Rogue Access Point Location, Tagging, and Containment” section on page 3-21 for more information on rogue detection.
Chapter 11 Using Templates

Configuring AP Configuration Templates

Note Rogue detection is disabled automatically for OfficeExtend access points because these access points, which are deployed in a home environment, are likely to detect a large number of rogue devices. For more information regarding OfficeExtend access points, see Cisco Wireless LAN Controller Configuration Guide.

- Encryption—Select the Encryption check box to enable encryption.

  Note Enabling or disabling encryption functionality causes the access point to reboot which then causes a loss of connectivity for clients.

  Note DTLS data encryption is enabled automatically for OfficeExtend access points to maintain security. Encryption is only available if the access point is connected to a 5500 series controller with a Plus license. Encryption is not available for all access point models.

  Note Enabling encryption may impair performance.

- SSH Access—Select the SSH Access check box to enable SSH access.
- Telnet Access—Select the Telnet Access check box to enable Telnet access.

  Note An OfficeExtend access point may be connected directly to the WAN which could allow external access if the default password is used by the access point. Because of this, Telnet and SSH access are disabled automatically for OfficeExtend access points.

- Link Latency—You can configure link latency on the controller to measure the link between an access point and the controller. This feature can be used with all access points joined to the controller but is especially useful for hybrid-REAP access points, for which the link could be a slow or unreliable WAN connection. See the “Configuring Link Latency Settings for Access Points” section on page 9-195 for more information.

  Note Link latency is supported for use only with hybrid-REAP access points in connected mode. Hybrid-REAP access points in standalone mode are not supported.

- Reboot AP—Select the check box to enable a reboot of the access point after making any other updates.
- AP Failover Priority—Choose Low, Medium, High, or Critical from the drop-down list to indicate the access point failover priority. The default priority is low. See the “Setting AP Failover Priority” section on page 9-153 for more information.
- Controllers—Select the Controllers check box to enable the drop-down lists for the primary, secondary, and tertiary controller names.
- Group VLAN name—Choose the appropriate group VLAN name from the drop-down list.
- H-REAP Configuration—Select the check box to enable H-REAP configuration (including VLAN support, native VLAN ID, and profile name VLAN mappings).
• Override Global Username Password—Select the check box to enable an override for the global username/password. Enter and confirm the new access point username and password in the appropriate text boxes. See the “Configuring a Global Access Point Password” section on page 9-58 for more information on a global username and password.

  Note In the System > AP Username Password page, you can set global credentials for all access points to inherit as they join a controller. These established credentials are displayed in the lower right of the AP Parameter tab page.
• Override Supplicant Credentials

Mesh

Use the Mesh tab to set the following parameters for mesh access points:

• Bridge Group Name—Enter a bridge group name (up to 10 characters).

<table>
<thead>
<tr>
<th>Note</th>
<th>Bridge groups are used to logically group the mesh access points to avoid two networks on the same channel from communicating with each other.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Note</th>
<th>For mesh access points to communicate, they must have the same bridge group name.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Note</th>
<th>For configurations with multiple RAPs, make sure that all RAPs have the same bridge group name to allow failover from one RAP to another.</th>
</tr>
</thead>
</table>

• Data Rate (Mbps)—Select the data rate for the backhaul interface from the drop-down list. Data rates available are dictated by the backhaul interface. The default rate is 18 Mbps.

<table>
<thead>
<tr>
<th>Note</th>
<th>This data rate is shared between the mesh access points and is fixed for the whole mesh network.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Note</th>
<th>Do not change the data rate for a deployed mesh networking solution.</th>
</tr>
</thead>
</table>

• Ethernet Bridging—Choose the Enable option from the Ethernet Bridging drop-down list to enable Ethernet bridging for the mesh access point.

• Role—Choose the role of the mesh access point from the drop-down list (MAP or RAP). The default setting is MAP.

<table>
<thead>
<tr>
<th>Note</th>
<th>An access point in a mesh network functions as either a root access point (RAP) or mesh access point (MAP).</th>
</tr>
</thead>
</table>

802.11a/n Parameters

Select the check box of the 802.11a/n parameters that must be applied:

• Channel Assignment
• Admin Status
• Antenna Mode
• Antenna Diversity
• Antenna Name
• Power Assignment
• WLAN Override
• 11n Antenna Selection
• CleanAir

**802.11a SubBand Parameters**

Select the 802.11a Sub Band options (for either 4.9 or 5.8 parameters) that must be applied.

**Note** Options are disabled unless the check box to the left of the parameter is selected.

• Admin Status
• Channel Assignment—Select the check box and then select the appropriate channel from the drop-down list.

**Note** The channel number is validated against the radio list of supported channels.

• Power Assignment—Select the check box and then select the appropriate power level from the drop-down list.

**Note** The power level is validated against the radio list of supported power levels.

• WLAN Override—Select the check box and then choose **Disable** or **Enable** from the drop-down list.

**Note** The access point must be reset for the WLAN override change to take effect.

• Antenna Type—Select the check box and then choose the antenna type from the drop-down list.
• Antenna Name—Select the **Antenna Type** check box and then choose the applicable antenna name from the drop-down list.

**Note** Not all antenna models are supported by radios of different access point types.

**802.11b/g/n Parameters**

Select the check box of the 802.11b/g/n parameters that must be applied.

• Channel Assignment
• Admin Status
• Antenna Mode
• Antenna Diversity
• Antenna Name
• Power Assignment
• WLAN Override
• Tracking Optimized Monitor Mode
• 11n Antenna Selection
• CleanAir

CDP

• In the Cisco Discovery Protocol on Ethernet Interfaces group box, select the slots of Ethernet interfaces for which you want to enable CDP.
• In the Cisco Discovery Protocol on Radio Interfaces group box, select the slots of Radio interfaces for which you want to enable CDP.

Select APs

Use the Search APs drop-down list to search for Last Applied AP(s), Scheduled AP(s), All, All Mesh MAP AP(s), All Mesh RAP AP(s), By Controller (choose the controller from the drop-down list), By Controller Name (choose the controller name from the drop-down list), By Floor Area (choose the campus, building, and floor area from the drop-down lists), By Outdoor Area (choose the campus and the outdoor area from the drop-down lists), By Model (choose the model from the drop-down list), By AP MAC Address (enter the MAC address), By AP Name (enter the complete AP name or starting characters of the AP name), and By AP IP Address Range (enter the IP address).

Note
The input text for IP address search can be of two formats X.X.X.* or X.X.X.[0-255]. For example, 10.10.10.* or 10.10.10.[20-50] will search the APs in 10.10.10.10 to 10.10.10.50 IP address range.

Note
The search filter "All Applied AP's" and "Scheduled AP's", lists the last 24 hours AP data.

Note
The search filter “AP(s) unassigned to Map(s)” lists the APs that have not yet been assigned to any maps.

• Click Save to save the parameters selections.
• Click Apply to save and apply the AP/Radio parameters to the selected access points from the search.

Apply/Schedule

Allows you to save the current template, apply the current template immediately, or schedule the current template to start the provisioning at the applicable time.

• Save—Click Save to save the current template configuration.
• Apply—Click Apply to save the template and start the provisioning of the template to selected access points.

Note
This provisioning process continues until completed even if you leave the page and log out of WCS.

• Schedule—Allows you to configure and start the provisioning at a scheduled time.
  – Enable schedule—Select the Enable schedule check box to activate the scheduling function.
Chapter 11  Using Templates

Configuring AP Configuration Templates

– Start Date—Enter a starting date in the text box or use the calendar icon to select a start date.
– Start Time—Select the starting time using the hours and minutes drop-down lists.
– Recurrence—Select from no recurrence, hourly, daily, or weekly to determine how often this provisioning occurs. Enter how often (in days) the provisioning is to occur.
– Schedule—Click Schedule to start the provisioning at the scheduled time.

Report

Displays all recently applied reports including the apply status and the date and time the apply was initiated. The following information is provided for each individual access point:

• Status—Indicates success, partial failure, failure, or not initiated. For failed or partially failed provisioning, click Details to view the failure details (including what failed and why it failed).
• Ethernet MAC—Indicates the ethernet MAC address for the applicable access point.
• Controller—Indicates the controller IP address for the applicable access point.
• Map—Identifies a map location for the access point.

Note  Click the click here link at the bottom of the Report page to view scheduled task reports.

Editing a Current Lightweight Access Point Template

To edit a current lightweight access point template, follow these steps:

Step 1  Choose Configure > AP Configuration Templates > Lightweight AP.
Step 2  Click the applicable template in the Template Name column.
Step 3  Edit the necessary parameters under the following tabs:
• AP Parameters—Select the check box of the access point parameters that must be applied.
• Mesh
• 802.11a/n Parameters—Select the check box of the 802.11a/n parameters that must be applied.
• 802.11b/g/n Parameters—Select the check box of the 802.11b/g/n parameters that must be applied.
• Select APs
  – Use the Search APs drop-down list to search for Last Applied APs, All APs, All MAP(s), or All RAP(s).
  – Click Save to save the parameters selections.
  – Click Apply to save and apply the AP/Radio parameters to the selected access points from the search.
  – Apply Report—Displays the reports from the applied template.
Configuring Autonomous Access Point Templates

The Configuring > Autonomous Access Point Templates page allows you to configure CLI templates for autonomous access points.

This section contains the following topics:

- Configuring a New Autonomous Access Point Template, page 11-152
- Applying an AP Configuration Template to an Autonomous Access Point, page 11-152

Configuring a New Autonomous Access Point Template

To configure a new autonomous access point template, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Choose Configure &gt; AP Configuration Templates &gt; Autonomous AP.</td>
</tr>
<tr>
<td>2</td>
<td>From the Select a command drop-down list, choose Add Template.</td>
</tr>
<tr>
<td>3</td>
<td>Click Go.</td>
</tr>
<tr>
<td>4</td>
<td>Enter a Template Name.</td>
</tr>
<tr>
<td>5</td>
<td>Enter the applicable CLI commands.</td>
</tr>
<tr>
<td>6</td>
<td>Click Save.</td>
</tr>
</tbody>
</table>

Applying an AP Configuration Template to an Autonomous Access Point

To apply an AP configuration template to an autonomous access point, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Choose Configure &gt; AP Configuration Templates &gt; Autonomous AP.</td>
</tr>
<tr>
<td>2</td>
<td>Click the template name link to select a template and apply it to the autonomous access point. The Autonomous AP Template page appears.</td>
</tr>
<tr>
<td>3</td>
<td>Enter a Template Name.</td>
</tr>
<tr>
<td>4</td>
<td>Enter the applicable CLI commands.</td>
</tr>
<tr>
<td>5</td>
<td>Click Save.</td>
</tr>
<tr>
<td>6</td>
<td>Click Apply to Autonomous Access Points. The Apply to Autonomous Access Points page appears.</td>
</tr>
<tr>
<td>7</td>
<td>Select the desired autonomous access point.</td>
</tr>
<tr>
<td>8</td>
<td>Click OK.</td>
</tr>
</tbody>
</table>

Note

Select the Ignore errors on Apply template to Controllers check box to ignore errors and apply all commands in the template to the Autonomous AP. If this check box is not selected, any errors encountered while applying a command in the template to a Autonomous AP causes the rest of the commands to be not applied.
Related Topics

- Configuring AP Configuration Templates
- Configuring Lightweight Access Point Templates
- Configuring Autonomous Access Point Templates
- Viewing Template Results

Viewing Template Results

To view the results when you apply an AP configuration template to an access point, follow these steps:

1. Choose Configure > AP Configuration Templates > Autonomous AP.
2. Click the template name link to select a template and apply it to the an autonomous access point. The Autonomous AP Template page appears.
3. Enter a Template Name.
4. Enter the applicable CLI commands.
5. Click Save.
6. Click Apply to Autonomous Access Points. The Apply to Autonomous Access Points page appears.
7. Select the desired autonomous access point.
8. Click OK. The Template Results page appears. The following parameters appear:
   - IP Address — IP address of the access point.
   - AP Name — The name of the access point.
   - Apply Status — Indicates success, failure, initiated or not initiated.
   - Operation Status — Displays the operational status: Success or Failure.
   - Reason — Indicates the reasons for failure.
   - Session Output

Configuring Autonomous AP Migration Templates

To make a transition from an Autonomous solution to a Unified architecture, autonomous access points must be converted to either CAPWAP or lightweight access points. The migration utility is available from the Configure > Migration Templates page where existing templates are listed.

This section contains the following topics:

- Migrating an Autonomous Access Point to a Lightweight Access Point, page 11-154
- Editing Current Autonomous AP Migration Templates, page 11-155
- Viewing the Migration Analysis Summary, page 11-156
- Adding/Modifying a Migration Template, page 11-156
- Copying a Migration Template, page 11-158
- Deleting Migration Templates, page 11-158
Migrating an Autonomous Access Point to a Lightweight Access Point

The Autonomous AP Migration Templates list page displays the following information:

- **Name**—The template name.
- **Description**—The description of template.
- **AP Count**—The number of autonomous access points selected for migration.
- **Schedule Run**—The time at which the task is scheduled to run.
- **Status**—Indicates one of the following task statuses:
  - Not initiated—The template is yet to start the migration and will start at the scheduled time. When the template is in this state, you can click the Name link to edit the template.
  - Disabled—The template is disabled and will not run at the scheduled time. This is the default state for a template when it is created without selecting any autonomous access points. When the template is in this state, you can click the Name link to edit the template.
  - Expired—The template did not run at the scheduled time (this may be due to the WCS server being down). When the template is in this state, you can click the Name link to edit the template.
  - Enabled—The template is yet to start the migration and will start at the scheduled time. When the template is in this state, you can click the Name link to edit the template.
  - In progress—The template is currently converting the selected autonomous access points to CAPWAP. When the template is in this state, you cannot edit the template by clicking the Name link.
  - Success—The template has completed the migration of autonomous access point to CAPWAP successfully. When the template is in this state, you cannot edit the template by clicking the Name link.
  - Failure—The template failed to migrate all the selected autonomous access point to CAPWAP. You can check the detailed status about the failures by using the View Migration Status page. When the template is in this state, you cannot edit the template by clicking the Name link.
  - Partial Success—The template failed to migrate a subset of the selected autonomous access point to CAPWAP. You can check the detailed status about the failures by using the View Migration Status page. When the template is in this state, you cannot edit the template by clicking the Name link.

**Note**

Once an access point is converted to lightweight, the previous status or configuration of the access point is not retained.

From the Select a command drop-down list, the following functions can be performed:

- **Add Template**—Allows you to provide necessary information for migration.
- **Delete Templates**—Allows you to delete a current template.
- **View Migration Report**—Allows you to view information such as AP address, migration status (in progress or fail), timestamp, and a link to detailed logs.
- **View Current Status**—Allows you to view the progress of the current migration (updated every three seconds).
Chapter 11 Using Templates

Configuring Autonomous AP Migration Templates

Note
When you migrate an already-managed autonomous access point to lightweight, its location and antenna information is migrated as well. You do not need to re-enter the information. WCS automatically removes the autonomous access point after migration.

- View Migration Analysis Summary—Lists the pass or fail status as required for an access point conversion. Only those access points with all criteria as pass are eligible for conversion.

Editing Current Autonomous AP Migration Templates

To edit a current migration template, follow these steps:

Step 1
Choose Configure > Autonomous AP Migration Templates.

Step 2
Click the migration template from the Name column.

Step 3
Edit the necessary parameters:

- General
  - Name—Enter a user-defined name of this migration template.
  - Description—Enter a brief description to help you identify the migration template.

- Upgrade Options
  - DHCP Support—Click to enable Dynamic Host Configuration Protocol support. This ensures that after the conversion every access point gets an IP from the DHCP server.
  - Retain AP HostName—Click to enable retention of the same hostname for this access point.

Note
Hostname will be retained in the LWAPP, only when you are migrating the AP to CAPWAP for the first time. It may not be retained if you are upgrading an AP for several times. CAPWAP access points hostname will be set to default, if autonomous access points hostname has more than 32 characters.

Note
If you upgrade the access points to LWAPP from 12.3(11)JA, 12.3(11)JA1, 12.3(11)JA2, 12.3(11)JA3 autonomous images, the converted access points may not retain their Static IP Address, Netmask, Hostname and Default Gateway.

- Migrate over WANLink—Click to enable. This increases the default timeouts for the CLI commands executed on the access point.
- DNS Address—Enter the DNS address.
- Domain Name—Enter the domain name.

- Controller Details

Note
Ensures that the access point authorization information (SSC) can be configured on this controller and the converted access points can join.

- Controller IP
Chapter 11      Using Templates

Configuring Autonomous AP Migration Templates

Step 4  Click **Save**.

Viewing the Migration Analysis Summary

To view the Migration Analysis Summary, follow these steps:

*Note*  You can also view the migration analysis summary by choosing **Tools > Migration Analysis**.

Step 1  Choose **Configure > Autonomous AP Migration Templates**.

Step 2  Choose **View Migration Analysis Summary** from the Select a command drop-down list, and click **Go**. The Migration Analysis Summary page appears.

The autonomous access points are eligible for migration only if all the criteria have a pass status. A red X designates ineligibility, and a green checkmark designates eligibility. These columns represent the following:

- Privilege 15 Criteria—The Telnet credential provided as part of the autonomous access point discovery must be privilege 15.
- Software Version Criteria—Conversion is supported only from Cisco IOS 12.3(7)JA releases excluding 12.3(11)JA, 12.3(11)JA1, 12.3(11)JA2, and 12.3(11)JA3.
- Role Criteria—A wired connection between the access point and controller is required to send the association request; therefore, the following autonomous access point roles are required:
  - root
  - root access point
  - root fallback repeater
  - root fallback shutdown
  - root access point only
- Radio Criteria—In dual-radio access points, the conversion can happen even if only one radio is of the supported type.

Adding/Modifying a Migration Template

If you want to add a migration template, choose **Add Template** from the Select a command drop-down page on the **Configure > Autonomous AP Migration Templates** page.

To modify an existing template, click the template name from the summary list.

Enter or modify the following migration parameters:
Chapter 11      Using Templates

Configuring Autonomous AP Migration Templates

General

- Name—User-defined name of this migration template.
- Description—Brief description to help you identify the migration template.

Upgrade Options

- DHCP Support—Ensures that after the conversion every access point gets an IP from the DHCP server.
- Retain AP HostName—Allows you to retain the same hostname for this access point.
- Migrate over WANLink—Increases the default timeouts for the CLI commands executed on the access point.
- DNS Address
- Domain Name

Controller Details

Note
Ensure that the access point authorization information (SSC) can be configured on this controller and the converted access points can join.

- Controller IP—Enter the IP address of the WLAN controller you are wanting to add to the newly migrated access point.
- AP Manager IP—Specify the controller the access point should join by entering the access point manager IP address.

Note
For SSC-enabled access points, this IP address must be the same as the controller IP field. For MIC-enabled access points, the IP addresses need not match.

- User Name—Enter a valid username for login of the WLAN controller.
- Password—Enter a valid password for this username used during WLAN controller login.

TFTP Details

When you installed and set up WCS, it provided its own TFTP and FTP server.

- TFTP Server IP—Enter the IP address of the WCS server.
- File Path—Enter the TFTP directory which was defined during WCS setup.
- File Name—Enter the CAPWAP conversion file defined in the TFTP directory during WCS setup (for example, c1240-rcvk9w8.tar.123-11JX1.tar).

Schedule Details

This area enables you to specify scheduling options for migration templates.

- Apply Template—Choose an option by which you want to apply the template for migration.
  - Now—Choose this option to run the migration task immediately.
- Schedule for later date/time—If you plan to schedule the migration at a later time, enter the Schedule parameters. Enter a date in the text box, or click the calendar icon to open a calendar from which you can choose a date. Choose the time from the hours and minutes drop-down lists. The report will begin running on this date and at this time.

- (Optional) Notification—Enter the e-mail address of recipient to send notifications via e-mail.

**Note**

To receive email notifications, configure the WCS mail server in the Administration > Settings > Mail Server Configuration page.

- Click **Save**.

Once a template is added in WCS, the following additional buttons appear:

- Select APs—Selecting this option provides a list of autonomous access points in WCS from which to choose the access points for conversion. Only those access points with migration eligibility as pass can be chosen for conversion.

- Select File—To provide CSV information for access points intended for conversion.

### Copying a Migration Template

To copy a migration template, follow these steps:

**Step 1** Choose **Configure > Autonomous AP Migration Templates**.

**Step 2** Select the check box of the template you want to copy, and then choose **Copy Template** from the Select a command drop-down list.

**Step 3** Click **Go**.

**Step 4** Enter the name for the new template to which you want to copy the current template.

### Deleting Migration Templates

To delete migration templates, follow these steps:

**Step 1** Choose **Configure > Autonomous AP Migration Templates**.

**Step 2** Select the check box(es) of the template(s) you want to delete, and then choose **Delete Templates** from the Select a command drop-down list.

**Step 3** Click **Go**.

**Step 4** Click **OK** to confirm the deletion or **Cancel** to close this page without deleting the template.
Mobility Services

Information About Mobility Services

This chapter briefly describes the CAS or wIPS services that Cisco WCS supports and gives steps for mobility procedures that are common across all services. You can refer to the Cisco Context-Aware Services documentation with the provided links for additional CAS and wIPS configuration and management details.

CAS

Context Aware Software (CAS) allows a mobility services engine to simultaneously track thousands of mobile assets and clients by retrieving contextual information such as location, temperature, and availability from Cisco access points.

Note

You must purchase licenses from Cisco to retrieve contextual information on tags and clients from access points. Licenses for tags and clients are offered independently. For details on tag and client licenses, refer to the Cisco 3350 Mobility Services Engine Release Note at:


wIPS

The Cisco Adaptive Wireless IPS (wIPS) is an advanced approach to wireless threat detection and performance management. Cisco Adaptive wIPS combines network traffic analysis, network device and topology information, signature-based techniques and anomaly detection to deliver highly accurate and complete wireless threat prevention.

Note

wIPS functionality is not supported for non-root partition users.

This section contains the following topics:

- Accessing Services Installation Guides, page 12-2
- MSE Services Co-Existence, page 12-2
- Viewing Current Mobility Services, page 12-4
- Adding a Mobility Services Engine, page 12-5
- Deleting a Mobility Services Engine from the Cisco WCS, page 12-6
Information About Mobility Services

- Registering Product Authorization Keys, page 12-7
- Adding a Location Server, page 12-9
- Synchronizing Services, page 12-10
- Viewing Synchronization History, page 12-18
- Viewing Notification Statistics, page 12-19
- Managing System Properties for a Mobility Services Engine, page 12-20
- Managing Cisco Adaptive wIPS Service Parameters, page 12-37
- Managing Context Aware Service Parameters, page 12-38
- Managing Maintenance for Mobility Services, page 12-35
- Monitoring Status Information for a Mobility Services Engine, page 12-32
- Working with Logs, page 12-27
- Viewing Notification Information for Mobility Services, page 12-58
- About Event Groups, page 12-60
- Upgrading from 5.x to 6.0 or 7.0, page 12-68
- Viewing the MSE Alarm Details, page 12-69
- Overview of MSE License, page 12-71
- Location Assisted Client Troubleshooting from the ContextAware Dashboard, page 12-73
- MSE Reports, page 12-74
- Planning for and Configuring Context-Aware Software, page 12-74
- wIPS Planning and Configuring, page 12-76

Accessing Services Installation Guides

The MSE and Location Server installation guides are available at the following URLs:

MSE 3350 Installation Guide:

MSE 3310 Installation Guide:

Location Server 2710 Installation Guide:

MSE Services Co-Existence

With MSE 6.0 and later, you can enable multiple services (Context Aware and wIPS) to run concurrently. Prior to version 6.0, mobility services engines could only support one active service at a time.

The following must be considered with co-existence of multiple services:

- Co-existence of services may be impacted by license enforcement. As long as the license is not expired, you can enable multiple services.
• Expired evaluation licenses prevent the service from coming up.
• If a CAS license is added or removed, this process restarts all services on the mobility services engine including wIPS. If a wIPS license is added or removed, the process does not impact CAS; only wIPS restarts.
• Other services can be enabled in evaluation mode even if a permanent license for the maximum number of elements has been applied.

Whenever one of the services has been enabled to run with its maximum license, another service cannot be enabled to run concurrently because the capacity of the MSE would not be sufficient to support both services concurrently. For example, on MSE-3310, if you install a wIPS license of 2000, then you cannot enable CAS to run concurrently. However, evaluation licenses are not subject to this limitation.

Note  See the “Mobility Services Engine (MSE) License Information” section on page 16-12 for more information on mobility services engine licensing.
Viewing Current Mobility Services

To view a list of current Mobility Services, choose Services > Mobility Services.

The Mobility Services page provides the following information and features for each device:

- **Device Name**—User-assigned name for the mobility services engine. Click the device name to view and manage mobility services engine details. See the “Managing System Properties for a Mobility Services Engine” section on page 12-20 for more information.
- **Device Type**—Indicates the type of mobility services engine (for example, Cisco 3310 Mobility Services Engine).
- **IP Address**—Indicates the IP address for the mobility services engine.
- **Version**—Indicates the version number of the mobility services engine.
- **Reachability Status**—Indicates whether or not the mobility services engine is reachable.
- **Mobility Service information:**
  - **Name**—Indicates the name of the mobility service.
  - **Admin Status**—Indicates whether the mobility service is enabled or disabled.
  - **Version**—Indicates the version number of the mobility service.
  - **Service Status**—Indicates whether the mobility service is currently up or down.
- **Select a command drop-down list:**
  - **Add Location Server**
  - **Add Mobility Services Engine**—Includes Context Aware service and Cisco Adaptive Wireless IPS (wIPS) service.
  - **Delete Service(s)**
  - **Synchronize Servers**
  - **Synchronization History**

---

**Note**
Location and mobility services engine features of WCS do not support partitioning.
Adding a Mobility Services Engine

Tip
To learn more about Cisco Adaptive wIPS features and functionality, go to Cisco.com to watch a multimedia presentation. Here you will also find the learning modules for a variety of WCS topics. Over future releases, we will add more overview and technical presentations to enhance your learning.

Note
The 7.0 release of WCS will recognize and support MSE 3355 appropriately. However, prior releases of WCS will not be able to identify an MSE 3355. The WCS 6.0 release can manage MSE 3355. However, to leverage the full features and capabilities of MSE 3355, we recommend you install WCS 7.0 or above.

To add a Cisco 3300 Series Mobility Services Engine to WCS, follow these steps:

Step 1
Verify that you can ping the mobility service engine that you want to add from WCS.

Step 2
Choose Services > Mobility Services to display the Mobility Services page.

Step 3
From the Select a command drop-down list, choose Add Mobility Services Engine, and click Go.

Step 4
Enter the following information:

- Device Name—User-assigned name for the mobility services engine.
- IP Address—The IP address of the mobility service engine.
- Contact Name (optional)—The mobility service engine administrator.
- User Name—The default username is admin.
- Password—The default password is admin.

Note
A mobility services engine is added only if a valid IP address is entered. The Device Name helps you distinguish between devices if you have multiple WCSs with multiple mobility services engines, but it is not considered when validating a mobility services engine.

- HTTP—When enabled, HTTP is used for communication between the WCS and mobility services engine.

Note
For HTTP communication with a mobility services engine, HTTP must be enabled explicitly on the mobility services engine.

- Select the Delete synchronized service assignments check box if you want to permanently remove all service assignments from the mobility services engine.

This option is applicable for network designs, wired switches, controllers and event definitions. The existing location history data is retained, however you must use manual service assignments to do any future location calculations.
Step 5  Click Next. The Select Mobility Service page opens.

\[\text{Note}\]  If you click Cancel, the mobility services engine is added.

Step 6  To enable a service on the mobility services engine, select the check box next to the service. Services include Context Aware and wIPS.

If you select Context Aware Service then you would have to select a Location engine to perform location calculation.

You can choose CAS to track clients, rogues, interferers, wired clients and tags.

Choose either of the following engine to track tags:
- Cisco Tag Engine
  or
- Partner Tag Engine

\[\text{Note}\]  With MSE 6.0 and later, you can enable multiple services (CAS and wIPS) simultaneously. Prior to version 6.0, mobility services engines could only support one active service at a time. See the “MSE Services Co-Existence” section on page 12-2 for more information.

Step 7  Click Save. The Mobility Services Engine Added page displays. See the “Mobility Services Engine Added Page” section on page 12-6 for more information.

The mobility service engine is now added to WCS.

\[\text{Note}\]  After adding a mobility services engine, it must be synchronized with WCS. You can synchronize network designs (campus, building, floor and outdoor maps), event groups, or wired switches on the local mobility services engine. You can also choose to synchronize the mobility services engine with a specific controller. You can do this synchronization immediately after adding a new mobility services engine or at a later time. See the “Synchronizing Services” section on page 12-10 for more information.

Mobility Services Engine Added Page

The Mobility Services Engine Added page displays all controllers, network designs, and event groups that must be synchronized.

Click Go to Synchronize to synchronize these devices. See the “Synchronizing Services” section on page 12-10 for more information.

Deleting a Mobility Services Engine from the Cisco WCS

To delete a mobility services engine from the WCS database, follow these steps:

Step 1  Choose Services > Mobility Services to display the Mobility Services page.

Step 2  Select the mobility services engine(s) to be deleted by selecting the corresponding check box(es).
Information About Mobility Services

Step 3 From the Select a command drop-down list, choose Delete Service(s).

Step 4 Click Go.

Step 5 Click OK to confirm that you want to delete the selected mobility services engine from the WCS database.

Step 6 Click Cancel to stop the deletion.

Registering Product Authorization Keys

You receive a product authorization key (PAK) when you order a client, wIPs, or tag license from Cisco. You must register the PAK to receive the license file for install on the mobility services engine. License files are emailed to you after successfully registering a PAK.

Client and wIPs PAKs are registered with Cisco.

Tag PAKs are registered with AeroScout.

Note If you do not have PAK, you can use the sales order number to retrieve the PAK. See the “Retrieving a PAK” section on page 12-8 for more information.

To register a product authoritative key (PAK) to obtain a license file for install, follow these steps:

Step 1 Open a browser page and enter https://tools.cisco.com/SWIFT/Licensing/PrivateRegistrationServlet.

Step 2 Enter the PAK, and click SUBMIT.

Step 3 Verify the license purchase. Click Continue if correct. The licensee entry page appears.

Note If the license is incorrect, click the TAC Service Request Tool link to report the problem.

Step 4 At the Designate Licensee page, enter the UDI of the mobility service engine in the host ID text box. This is the mobility services engine on which the license will be installed.

Note UDI information for a mobility services engine is found on the General Properties pane at Services > Mobility Services Engine > Device Name > System.

Step 5 Select the Agreement check box. Registrant information appears beneath the Agreement check box. Modify information as necessary.

Note Ensure that the phone number does not include any characters in the string for the registrant and end user. For example, enter 408 555 1212 rather than 408.555.1212 or 408-555-1212.

Step 6 If registrant and end user are not the same person, select the Licensee (End-User) check box beneath registrant information and enter the end user information.

Step 7 Click Continue. A summary of entered data appears.
Step 8  At the Finish and Submit page, review registrant and end user data. Click Edit Details to correct information, if necessary.
Step 9  Click Submit. A confirmation page appears.

Retrieving a PAK

If you do not have PAK, you can use the sales order number to retrieve the PAK.

To retrieve the PAK follow these steps:

Step 1  Go to the Sales Order Status Tool at the following URL: http://tools.cisco.com/qtc/status/tool/action/LoadOrderQueryScreen.
Step 2  After logging in, select Sales Order (SO) from the Type of Query drop-down list.
Step 3  Enter the sales order number in Value text box.

Note  The Date Submitted fields are not required for this inquiry.

Step 4  Select the Show Serial Number check box.
Step 5  Select the Orders radio button, if not already selected.
Step 6  Choose Screen from the Deliver Via drop-down list.
Step 7  Click Search. Detailed information on the mobility services engine order displays.
Step 8  Click Line 1. 1 in the table.
Step 9  Under Product column (second line), copy the PAK number (starts with 3201J) that you want to register to obtain the license.

Installing Device and wIPS License Files

You can install client and wIPS licenses from WCS.

Note  The tag license installation is separate only if Aero scout engine was selected for tag calculation while adding the MSE.

Tag licenses are installed using the AeroScout System Manager.

To add a client or wIPS license to WCS after registering the PAK, follow these steps:

Step 1  Choose Administration > License Center.
Step 2  Choose Files > MSE Files from the left sidebar menu.
Step 3  Click Add.

The Add a License File dialog box appears.
Step 4  Choose the applicable MSE name from the MSE Name drop-down list.
Note Verify that the UDI of the selected mobility services engine matches the one you entered when registering the PAK.

Step 5 Click Choose File to browse and to select the license file.
Step 6 Click Upload. The newly added license appears in the MSE license file list.

Adding a Location Server

To add a location server, follow these steps:

Step 1 Choose Services > Mobility Services.
Step 2 From the Select a command drop-down list, choose Add Location Server.
Step 3 Click Go.
Step 4 Enter the required information including:
   • Server Name
   • IP Address
   • Contact Name
   • User Name
   • Password
   • Port
   • HTTPS—When enabled, HTTPS is used for communication between the WCS and location server.
Step 5 Select the Delete synchronized service assignments check box if you want to permanently remove all service assignments from the mobility services engine.
   This option is applicable for network designs, wired switches, controllers and event definitions. The existing location history data is retained, however you must use manual service assignments to do any future location calculations.
Step 6 Click Save.

Note After adding a Location Server, it must be synchronized with WCS. See the “Synchronizing Services” section on page 12-10 for more information.

Note Location and mobility services engine features of WCS do not support partitioning.
Synchronizing Services

This section describes how to synchronize Cisco wireless LAN controllers and WCS with mobility services engines and includes the following topics:

- Keeping Mobility Services Engines Synchronized, page 12-10
- Synchronizing WCS and a Mobility Services Engine or Location Server, page 12-10
- Synchronizing Controllers with Mobility Services Engine, page 12-12
- Working with Third-Party Elements, page 12-13
- Setting and Verifying the Timezone on a Controller, page 12-14
- Configuring Smart Mobility Services Engine Database Synchronization, page 12-15
- Out-of-Sync Alarms, page 12-17
- Viewing Mobility Services Engine Synchronization Status, page 12-18

Keeping Mobility Services Engines Synchronized

This section describes how to synchronize WCS and mobility services engines manually and automatically.

After adding a mobility service engine to WCS, you can push (synchronize) network designs (campus, building, floor and outdoor maps), event groups, controller information (name and IP address), or wired switches to the mobility services engine.

**Note**

Be sure to verify software compatibility between the controller, WCS, and the mobility services engine before performing synchronization. Refer to the latest mobility services engine release note at the following URL:


**Note**

Communication between the mobility services engine and Cisco WCS and the controller is in Coordinated Universal Time (UTC). Configuring NTP on each system provides devices with the UTC time. The mobility services engine and its associated controllers must be mapped to the same NTP server and the same Cisco WCS server. An NTP server is required to automatically synchronize time between the controller, Cisco WCS, and the mobility services engine.

Synchronizing WCS and a Mobility Services Engine or Location Server

This section describes how to synchronize Cisco WCS and mobility services engines manually and smartly.

After adding a mobility services engine to Cisco WCS, you can synchronize network designs (campus, building, floor, and outdoor maps), controllers (name and IP address), specific Catalyst Series 3000 and 4000 switches, and event groups with the mobility services engine.

- Network Design—Is a logical mapping of the physical placement of access points throughout facilities. A hierarchy of a single campus, the buildings that comprise that campus, and the floors of each building constitute a single network design.
- Controller—A selected controller that is associated and regularly exchanges location information with a mobility services engine. Regular synchronization ensures location accuracy.
• Switches (wired)—Wired Catalyst switches that provide an interface to wired clients on the network. Regular synchronization ensures that location tracking of wired clients in the network is accurate.
  – The mobility services engine can be synchronized with Catalyst stackable switches (3750, 3750-E, 3560, 2960, IE-3000 switches), switch blades (3110, 3120, 3130, 3040, 3030, 3020), and switch ports.

• Event Groups—A group of predefined events that define triggers that generate an event. Regular synchronization ensures that the latest defined events are tracked.

Note
Be sure to verify software compatibility between the controller, Cisco WCS, and the mobility services engine before synchronizing. See the latest mobility services engine release note at the following URL: http://www.cisco.com/en/US/products/ps9742/tsd_products_support_series_home.html.

Note
Communication between the mobility services engine and Cisco WCS and the controller is in Coordinated Universal Time (UTC). Configuring NTP on each system provides devices with the UTC time. The mobility services engine and its associated controllers must be mapped to the same NTP server and the same Cisco WCS server. An NTP server is required to automatically synchronize time between the controller, Cisco WCS, and the mobility services engine.

To synchronize WCS network designs, controllers, wired switches, or event groups with the mobility services engine or location server, follow these steps:

Step 1 Choose Services > Synchronize Services.
Step 2 Choose the appropriate menu option (network designs, controllers, wired switches, or event groups).
Step 3 To assign a network design to a mobility services engine, From the left sidebar menu, choose Network Designs.
Step 4 Choose all the maps to be synchronized with the mobility services engine.

Note Through 6.0, you can assign only up to a campus level to a mobility services engine. Beginning with 7.0 this option is granular to a floor level. For example, you can choose to assign floor1 to MSE 1, floor2 to MSE 2, and floor3 to MSE 3.

Step 5 Click Change MSE Assignment.
Step 6 Select the mobility services engine to which the maps are to be synchronized.
Step 7 Click either of the following in the dialog box:
  • Save—Saves the mobility services engine assignment. The following message appears in the Messages column of the Network Designs page with yellow arrows icon:

    To be assigned - Please synchronize.

  • Cancel—Discards the changes to mobility services engine assignment and returns to the Network Designs page.
You can also click Reset to undo the mobility services engine assignments.

**Note** A network design may include a floor in a campus or a large campus with several buildings, each monitored by a different mobility services engine. Because of this, you may need to assign a single network design to multiple mobility services engines.

**Step 8** Click Synchronize to update the mobility services engine(s) database(s).

When items are synchronized, a green two-arrow icon appears in the Sync. Status column for each synchronized entry.

You can use the same procedure to assign wired switches or event groups to a mobility services engine. To assign a controller to a mobility services engine, see the “Synchronizing Controllers with Mobility Services Engine” section on page 12-12 for more information.

**Note** Event groups can also be created by third party applications. For more information on Third party application created event groups, see the “Working with Third-Party Elements” section on page 12-13.

To unassign a network design, controller, wired switch, or event group from a mobility services engine, follow these steps:

**Step 1** On the respective tabs, select one or more elements, and click Change MSE Assignment. The choose mobility services engine dialog box appears.

**Step 2** Deselect the mobility services engine if you do not want the elements to be associated with that mobility services engine.

**Step 3** Click Save to save the changes to the assignments.

**Step 4** Click Synchronize. The Sync Status column appears blank.

---

**Synchronizing Controllers with Mobility Services Engine**

You can assign an MSE to any wireless controller on a per-Service (CAS or wIPS) basis.

**Note** Starting from MSE Release 7.0.116.0, you cannot synchronize a Controller of version 5.0 or before to MSE.

To assign an MSE Service to wireless controllers, follow these steps:

**Step 1** In the synchronization page, choose Controllers.

**Step 2** Choose the controllers to be assigned to the mobility services engine.

**Step 3** Click Change MSE Assignment.

**Step 4** Choose the mobility services engine to which the controllers have to be synchronized.

**Step 5** Click either of the following in the dialog box:
• Save—saves the mobility services engine assignment. The following message appears in the Messages column of the Controllers page with yellow arrows icon:

To be assigned - Please synchronize.

• Cancel—discards the changes to mobility services engine assignment and returns to the Controllers page.

You can also click Reset to undo the yellow button assignments.

Step 6 Click Synchronize to complete the synchronization process.

Step 7 Check if the mobility services engine is communicating with each of the controller for only the chosen service. This can be done by clicking the NMSP status link on the status page.

Note

• After Synchronizing a controller, verify that the timezone is set on the associated controller. See the “Setting and Verifying the Timezone on a Controller” section on page 12-14.

• Controller names must be unique for synchronizing with a mobility services engine. If you have two controllers with the same name, only one will be synchronized.

To unassign a network design, controller, wired switch, or event group from a mobility services engine, follow these steps:

Step 1 On the respective tabs, select one or more elements, and click Change MSE Assignment. The choose mobility services engine dialog box appears.

Step 2 Deselect the mobility services engine if you do not want the elements to be associated with that mobility services engine.

Step 3 Click Save to save the changes to the assignments.

Step 4 Click Synchronize. A two-arrow icon appears in the Sync Status column.

Working with Third-Party Elements

When you synchronize elements with MSE, there might be event groups on the MSE that have been created by third-party applications. You can either delete the unused elements or mark them as third-party elements.

To delete the elements or mark them as third-party elements, follow these steps:

Step 1 In the synchronization page, choose Third Party Elements from the left sidebar menu.

The Third Party Elements page appears.

Step 2 Select one or more elements.

Step 3 Click one of these buttons:

• Delete Event Groups—Deletes the selected event groups.

• Mark as 3rd Party Event Group(s)—Marks the selected event groups as third-party event groups.
Setting and Verifying the Timezone on a Controller

For controller releases 4.2 and later, if a mobility services engine (release 5.1 or greater) is installed in your network, it is mandatory that the time zone be set on the controller to ensure proper synchronization between the two systems.

Greenwich Mean Time (GMT) is used as the standard for setting the time zone system time of the controller.

You can automatically set the time zone during initial system setup of the controller or manually set it on a controller already installed in your network.

To manually set the time and time zone on an existing controller in your network using the CLI, follow these steps:

**Step 1** Configure the current local time in GMT on the controller by entering the following commands:

```
(Cisco Controller) >config time manual 09/07/07 16:00:00
(Cisco Controller) >config end
```

**Note** When setting the time, the current local time is entered in terms of GMT and as a value between 00:00 and 24:00. For example, if it is 8 AM Pacific Standard Time (PST) in the US, you enter 16:00 (4 PM PST) as the PST time zone is 8 hours behind GMT.

**Step 2** Verify that the current local time is set in terms of GMT by entering the following command:

```
(Cisco Controller) >show time
Time............................................. Fri Sep 7 16:00:02 2007
Timezone delta.............................. 0:0
```

**Step 3** Set the local time zone for the system by entering the following commands:

```
(Cisco Controller) >config time timezone -8
(Cisco Controller) >config end
```

**Note** When setting the time zone, you enter the time difference of the local current time zone with respect to GMT (+/-). For example, Pacific Standard Time (PST) in the United States (US) is 8 hours behind GMT (UTC) time. Therefore, it is entered as -8.

**Step 4** Verify that the controller displays the current local time with respect to the local time zone rather than in GMT by entering the following command:

```
(Cisco Controller) >show time
Time............................................. Fri Sep 7 08:00:26 2007
Timezone delta.............................. -8:0
```

**Note** The time zone delta parameter in the `show time` command displays the difference in time between the local time zone and GMT (8 hours). Prior to configuration, the parameter setting is 0:0.
Configuring Smart Mobility Services Engine Database Synchronization

Manual synchronization of WCS and mobility services engine databases provides immediate synchronization. However, future deployment changes (such as making changes to maps and access point positions), can yield incorrect location calculations and asset tracking until resynchronization reoccurs.

To prevent out-of-sync conditions, use WCS to carry out synchronization. This policy ensures that synchronization between WCS and mobility services engine databases is triggered periodically and any related alarms are cleared.

Any change to one or more of any synchronized component will be automatically synchronized with the mobility services engine. For example, if a floor with access points is synchronized with a particular mobility services engine and then one access point is moved to a new location on the same floor or another floor which is also synchronized with the mobility services engine, then the changed location of the access point will be automatically communicated.

To further ensure that WCS and MSE are in sync, Smart Synchronization happens in the background.

To configure smart synchronization, follow these steps:

**Step 1** Choose Administration > Background Tasks.

The Background Tasks summary page appears (see Figure 12-1).
Information About Mobility Services

Figure 12-1 Administration > Background Tasks

Step 2 Select the Mobility Service Synchronization check box.

Step 3 Click the Mobility Service Synchronization link.

The Task > Mobility Service Synchronization page appears.

Step 4 To set the mobility services engine to send out-of-sync alerts, select the Enabled check box in the Out of Sync Alerts section or area.

Step 5 To enable smart synchronization, select the Smart Synchronization Enabled check box.

Note Smart synchronization does not apply to elements (network designs, controllers, or event groups) that have not yet been assigned to a mobility services engine. However, out-of-sync alarms will still be generated for these unassigned elements. For smart synchronization to apply to these elements, you need to manually assign them to a mobility services engine.
Note: When a mobility services engine is added to a WCS, the data in the WCS is always treated as the primary copy that is synchronized with the mobility services engine. All synchronized network designs, controllers, event groups and wired switches that are present in the mobility services engine and not in the WCS are removed automatically from mobility services engine.

Step 6 Enter the time interval in minutes that the smart synchronization is to be performed.

By default, smart-sync is disabled.

Step 7 Click Submit.

For Smart controller assignment and selection scenarios, see the “Smart Controller Assignment and Selection Scenarios” section on page 12-17.

Smart Controller Assignment and Selection Scenarios

Scenario 1
If a floor having at least one access point from a controller is chosen to be synchronized with the mobility services engine from the Network Designs section of the Synchronization page, then the controller to which that access point is connected is automatically selected to be assigned to the mobility services engine for CAS service.

Scenario 2
When at least one access point from a controller is placed on a floor that is synchronized with mobility services engine, the controller to which the access point is connected is automatically assigned to the same mobility services engine for CAS service.

Scenario 3
An access point is added to a floor and is assigned to a mobility services engine. If that access point is moved from controller A to controller B, then controller B is automatically synchronized to the mobility services engine.

Scenario 4
If all access points placed on a floor which is synchronized to the mobility services engine are deleted then that controller is automatically removed from mobility services engine assignment or unsynchronized.

Out-of-Sync Alarms

Out-of-sync alarms are of Minor severity (yellow) and are raised in response to the following conditions:

- Elements have been modified in WCS (the auto-sync policy will push these elements).
- Elements have been modified in mobility services engine.
- Elements except controllers exist in the mobility services engine database but not in WCS.
- Elements have not been assigned to any mobility services engine (the auto-sync policy does not apply)

Out-of-sync alarms are cleared when the following occurs:

- Mobility services engine is deleted
### Information About Mobility Services

**Note**
When you delete a mobility services engine, the out-of-sync alarms for that system are also deleted. In addition, if you delete the last available mobility services engine, the alarms for “elements not assigned to any server” will also be deleted.

- Elements are synchronized manually or automatically
- User manually clears the alarms (although the alarms may reappear in the future when the scheduled task is next executed)

**Note**
By default, out-of-sync alarms are enabled. You can disable them in WCS by clicking **Administration > Scheduled Tasks**, clicking **Mobility Service Synchronization**, unselecting the **Auto Synchronization** check box, and clicking **Submit**.

### Viewing Mobility Services Engine Synchronization Status

You can use the Synchronize Servers command in WCS to view the status of network design, controller, and event group synchronization with a mobility services engine.

To view synchronization status, follow these steps:

**Step 1** Choose **Services > Synchronize Services**.

**Step 2** Select the applicable menu option (Network Designs, Controllers, or Event Groups).

For each of the elements, the Sync. Status column shows the synchronization status. A green two-arrow icon indicates that its corresponding element is synchronized with the specified server such as a mobility services engine. A gray two-arrow icon with a red circle indicates that its corresponding item is not synchronized with a given server.

You can also view the synchronization status and assign or unassign from campus view and building view along with floor view.

To access this page, choose **Monitor > Maps > System Campus > Building > Floor** where **Building** is the building within the Campus and **Floor** is a specific floor in that campus building.

On the left side there is a menu option called MSE Assignment. This shows which mobility services engine the floor is currently assigned to. You can also change mobility services engine assignment from this page.

### Viewing Synchronization History

You can use the Synchronization History command in WCS to view the synchronization history for the last 30 days for a mobility services engine. This is especially useful when automatic synchronization is enabled as alarms are automatically cleared. Synchronization History provides a summary of those cleared alarms.

To view synchronization history, follow these steps:
Step 1  Choose Services > Synchronization History.

Step 2  Table 12-1 describes the Synchronization History fields.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timestamp</td>
<td>The date and time at which the synchronization has happened.</td>
</tr>
<tr>
<td>Server</td>
<td>The mobility services engine server.</td>
</tr>
<tr>
<td>Element Name</td>
<td>The name of the element that was synchronized.</td>
</tr>
<tr>
<td>Type</td>
<td>The type of the element that was synchronized.</td>
</tr>
<tr>
<td>Sync Operation</td>
<td>The sync operation that was performed. It could either be an Update or an Add.</td>
</tr>
<tr>
<td>Generated By</td>
<td>The method of synchronization. It could either be Manual or Automatic.</td>
</tr>
<tr>
<td>Status</td>
<td>The status of the synchronization. It could be either Success or Failed.</td>
</tr>
<tr>
<td>Message</td>
<td>Any additional message about the synchronization.</td>
</tr>
</tbody>
</table>

You can click the column headers to sort the entries.

**Viewing Notification Statistics**

You can view the notification statistics for a specific mobility services engine. To view the Notification Statistics for a specific mobility services engine choose Services > Mobility Services > MSE-name > Context Aware Service > Notification Statistics.

where MSE-name is the name of a mobility services engine.

Table 12-2 describes the fields in the Notification statistics page.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Destinations</td>
<td></td>
</tr>
<tr>
<td>Total</td>
<td>Total count of the destinations.</td>
</tr>
<tr>
<td>Unreachable</td>
<td>Count of unreachable destinations.</td>
</tr>
<tr>
<td>Notification Statistics Summary</td>
<td></td>
</tr>
<tr>
<td>Track Definition Status</td>
<td>Status of the track definition. Track notification status could be either Enabled or Disabled.</td>
</tr>
</tbody>
</table>
Managing System Properties for a Mobility Services Engine

You can manage the system properties of a mobility services engine using the WCS. This section describes the various system properties of a mobility services engine and contains the following topics.

- Editing General Properties for a Mobility Services Engine, page 12-20
- Editing NMSP Parameters for a Mobility Services Engine, page 12-22
- Viewing Active Session Details for a Mobility Services Engine, page 12-24
- Viewing and Adding Trap Destinations for a Mobility Services Engine, page 12-24
- Editing Advanced Parameters for a Mobility Services Engine, page 12-25
- Working with Logs, page 12-27
- Managing User and Group Accounts for a Mobility Services Engine, page 12-29
- Monitoring Status Information for a Mobility Services Engine, page 12-32
- Managing Maintenance for Mobility Services, page 12-35

Editing General Properties for a Mobility Services Engine

You can use WCS to edit the general properties of a mobility services engine registered in the WCS database. General properties include contact name, username, password, and HTTP.

To edit the general properties of a mobility services engine, follow these steps:
Chapter 12  Mobility Services

Information About Mobility Services

---

**Step 1** Choose Services > Mobility Services to display the Mobility Services page.

**Step 2** Click the name of the mobility services engine that you want to edit. The General Properties page (with a General tab and Performance tab) opens.

The General tab displays the following read-only Server Details:

- Device Name
- Device Type
- Device UDI

*Note* For licensing, the Device UID is the string between double quote characters (including spaces in the end if any). Exclude the double quote characters during copy-paste.

- Version
- Start Time
- IP Address

**Step 3** From the General Properties page, modify the following Server Details as necessary:

- Contact Name—Enter a contact name for the mobility service.
- Username—Enter the login username for the WCS server that manages the mobility service.
- Password—Enter the login password for the WCS server that manages the mobility service.
- HTTP—Select the **HTTP enable** check box to enable HTTP.

*Note* When you have a non-default port or HTTPS turned on, you must pass the correct information along with the command. For example, `getserverinfo` must include `-port port -protocol HTTP/HTTPS`. Similarly, for stopping the server, `stoplocserver - port port -protocol HTTP/HTTPS`.

- Legacy Port—8001
- Legacy HTTPS—Select the check box to enable the legacy HTTPS.
- Delete synchronized service assignments and enable synchronization—Select the **Delete synchronized service assignments** check box if you want to permanently remove all service assignments from the mobility services engine. This option will show up only when the delete synchronized service assignments check box was unselected while adding an mobility services engine.

*Note* WCS always uses HTTPS to communicate with a mobility services engine.

*Note* The following tcp ports are in use on a mobility services engine (MSE) in Release 6.0: tcp 22: MSE SSH port, tcp 80: MSE HTTP port, tcp 443: MSE HTTPS port, tcp 1411: AeroScout, tcp 1999: AeroScout internal port, tcp 4096: AeroScout notifications port, tcp 5900X: AeroScout (X could vary from 1 to 10), and tcp 8001: Legacy port. Used for location APIs.
The following udp ports are in use on a mobility services engine (MSE) in release 6.0: udp 123: NTPD port (open after NTP configuration), udp 162: AeroScout SNMP, udp/tcp 4000X: AeroScout proxy (X could vary from 1 to 5), udp 12091: AeroScout devices (TDOA Wi-Fi Receivers, chokepoints), udp 12092: AeroScout devices (TDOA Wi-Fi Receivers, chokepoints), udp 32768: Location internal port, udp 32769: AeroScout internal port, and udp 37008: AeroScout internal port.

In the Mobility Services pane, select the Admin Status check box to enable the applicable (Context Aware Service or wIPS).

If you select Context Aware Service, then you must select a Location engine to perform location calculation.

You can choose CAS to track clients, rogues, interferers, wired clients and tags.

Choose either:

- Cisco Tag Engine
- Partner Tag Engine

With MSE 6.0, you can enable multiple services (CAS and wIPS) simultaneously. Prior to version 6.0, mobility services engines could only support one active service at a time.

The Mobility Services section also displays the following:

- Service Name
- Service Version
- Service Status
- License Type

Use the Click here link to view mobility services engine licensing details. See the “Mobility Services Engine (MSE) License Information” section on page 16-12 for more information.

Click Save to update the Cisco WCS and mobility service databases.

Click the Performance tab to view a graph of CPU and memory utilization percentages. See the “Monitoring Interactive Graphs” section on page 6-75 for more information on reading WCS interactive graphs.

Editing NMSP Parameters for a Mobility Services Engine

Network Mobility Services Protocol (NMSP) is the protocol that manages communication between the mobility service and the controller. Transport of telemetry, emergency and chokepoint information between the mobility service and the controller is managed by this protocol.
Note

- The NMSP parameter is supported in mobility services installed with release 3.0 till 7.0.105.0. It is not supported on releases beyond 7.0.105.0.
- NMSP replaces the LOCP term introduced in release 3.0.
- Telemetry, emergency and chokepoint information is only seen on controllers and WCS installed with release 4.1 software or greater and on mobility services running release 3.0 or greater software.
- The TCP port (16113) that the controller and mobility service communicate over MUST be open (not blocked) on any firewall that exists between the controller and mobility service for NMSP to function.

The NMSP Parameters section of WCS enables you to modify NMSP parameters such as echo and neighbor dead intervals as well as response and retransmit periods.

To configure NMSP parameters, follow these steps:

**Step 1** Choose Services > Mobility Services.
**Step 2** Click the name of the mobility services engine whose properties you want to edit.
**Step 3** From the left sidebar menu, choose System > NMSP Parameters.
**Step 4** Modify the NMSP parameters as appropriate.

Note No change in the default parameter values is recommended unless network is experiencing slow response or excessive latency.

NMSP parameters include:

- **Echo Interval**—Defines how frequently an echo request is sent from a mobility service to a controller. The default value is 15 seconds. Allowed values range from 1 to 120 seconds.

  Note If a network is experiencing slow response, you can increase the values of the echo interval, neighbor dead interval and the response timeout values to limit the number of failed echo acknowledgements.

- **Neighbor Dead Interval**—The number of seconds that the mobility service waits for a successful echo response from the controller before declaring the neighbor dead. This timer begins when the echo request is sent.
  The default values is 30 seconds. Allowed values range from 1 to 240 seconds.

  Note This value must be at least two times the echo interval value.

- **Response Timeout**—Indicates how long the mobility service waits before considering the pending request as timed out. The default value is one second. Minimum value is one (1). There is no maximum value.

- **Retransmit Interval**—Interval of time that the mobility service waits between notification of a response time out and initiation of a request retransmission. The default setting is 3 seconds. Allowed values range from 1 to 120 seconds.
Information About Mobility Services

- Maximum Retransmits—Defines the maximum number of retransmits that are done in the absence of a response to any request. The default setting is 5. Allowed minimum value is zero (0). There is no maximum value.

**Step 5**  Click **Save** to update the WCS and mobility service databases.

### Viewing Active Session Details for a Mobility Services Engine

The Active Sessions section of WCS enables you to view active user sessions on the mobility services engine.

To view active user sessions, follow these steps:

**Step 1**  Choose **Services > Mobility Services**.

**Step 2**  Click the name of the mobility service.

**Step 3**  From the left sidebar menu, choose **System > Active Sessions**.

WCS displays a list of active mobility service sessions. For every session, WCS displays the following information:

- Session identifier
- IP address from which the mobility service is accessed
- Username of the connected user
- Date and time when the session started
- Date and time when the mobility service was last accessed
- How long the session was idle for since the last access

### Viewing and Adding Trap Destinations for a Mobility Services Engine

The Trap Destinations section of WCS enables you to specify which WCS or Cisco Security Monitoring, Analysis and Response System (CS-MARS) network management platform is the recipient of SNMP traps generated by the mobility services engine.

To view or manage trap destination for a mobility services engine, follow these steps:

**Step 1**  Choose **Services > Mobility Services**.

**Step 2**  Click the name of the mobility service.

**Step 3**  From the left sidebar menu, choose **System > Trap Destinations**.

WCS displays a list of current trap destinations including the following information:

- IP address
- Port number
- Community
- Destination type
- SNMP Version
Use the Select a command drop-down list to add or delete a trap destination.

To add a trap destination, follow these steps:

**Step 1** Choose Services > Mobility Services.

**Step 2** Click the name of the mobility service.

**Step 3** From the left sidebar menu, choose System > Trap Destinations.

**Step 4** Choose Add Trap Destination from the the command drop-down list.

The New Trap Destination page appears.

**Step 5** Enter the following details (see Table 12-3).

**Step 6** Click Save to save the changes or Cancel to discard the changes.

### Table 12-3 Add Trap Destination

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IP Address</td>
<td>IP address for the trap destination</td>
</tr>
<tr>
<td>Port Number</td>
<td>Port number for the trap destination. Default port number is 162.</td>
</tr>
<tr>
<td>Destination Type</td>
<td>This field is not editable and has a value Other.</td>
</tr>
</tbody>
</table>

**Editing Advanced Parameters for a Mobility Services Engine**

The Advanced Parameters section of WCS enables you can view general system level settings of the mobility services engine and configure monitoring parameters.

**Note**

You can use WCS to modify troubleshooting parameters for a mobility services engine or a location appliance.

To edit advanced parameters for a mobility services engine, follow these steps:

**Step 1** Choose Services > Mobility Services.

**Step 2** Click the name of the mobility service whose properties you want to edit.

**Step 3** From the left sidebar menu, choose System > Advanced Parameters.

**Step 4** View or modify the advanced parameters as necessary.

- General Information
- Advanced Parameters
  - Number of Days to keep Events—Enter the number of days to keep logs. Change this value as required for monitoring and troubleshooting.
Information About Mobility Services

- Session Timeout—Enter the number of minutes before a session times out. Change this value as required for monitoring and troubleshooting. Currently this option appears greyed out.

- Cisco UDI
  - Product Identifier (PID)-The Product ID of the mobility services engine.
  - Version Identifier (VID)-The version number of the mobility services engine.
  - Serial Number (SN)-Serial number of the mobility services engine.

- Advanced Commands
  - Reboot Hardware—Click to reboot the mobility service hardware. See the “Rebooting the Mobility Services Engine Hardware” section on page 12-26 for more information.
  - Shutdown Hardware—Click to turn off the mobility service hardware. See the “Shutting Down the Mobility Services Engine Hardware” section on page 12-26 for more information.
  - Clear Database—Click to clear the mobility services database. See the “Clearing Mobility Services Engine Database” section on page 12-27 for more information. Unselect the Retain current service assignments in WCS check box to remove all existing service assignments from WCS and MSE. The resources have to be reassigned from Services > Synchronize Services page. By default this option is selected.

Step 5 Click Save to update the WCS and mobility service databases.

Rebooting the Mobility Services Engine Hardware

If you need to restart a mobility services engine, follow these steps:

Step 1 Choose Services > Mobility Services.
Step 2 Click the name of the mobility services engine that you want to reboot.
Step 3 Click System.
Step 4 Click Advanced Parameters.
Step 5 In the Advanced Commands section, click Reboot Hardware.
Step 6 Click OK to confirm that you want to reboot the mobility services engine hardware.

The rebooting process takes a few minutes to complete.

Shutting Down the Mobility Services Engine Hardware

If you need to shut down a mobility services engine, follow these steps:

Step 1 Choose Services > Mobility Services.
Step 2 Click the name of the mobility services engine that you want to shut down.
Step 3 Click System.
Step 4 Click Advanced Parameters.
Step 5 In the Advanced Commands section, click Shutdown Hardware.
**Step 6**  
Click **OK** to confirm that you want to shut down the mobility services engine.

---

**Clearing Mobility Services Engine Database**

To clear a mobility services engine configuration and restore its factory defaults, follow these steps:

**Step 1**  
Choose **Services > Mobility Services**.

**Step 2**  
Click the name of the mobility services engine you want to configure.

**Step 3**  
Click **System**.

**Step 4**  
Click **Advanced Parameters**.

**Step 5**  
In the Advanced Commands section, unselect the **Retain current service assignments in WCS** check box to remove all existing service assignments from WCS and MSE.  
The resources have to be reassigned in the Services > Synchronize Services page. By default, this option is selected.

**Step 6**  
In the Advanced Commands section, click **Clear Database**.

**Step 7**  
Click **OK** to clear the mobility services engine database.

---

**Working with Logs**

This section describes how to configure logging options and how to download log files and includes the following topics:

- Configuring Logging Options, page 12-27
- Downloading Mobility Services Engine Log Files, page 12-28

**Configuring Logging Options**

You can use WCS to specify the logging level and types of messages to log.

To configure logging options, follow these steps:

**Step 1**  
Choose **Services > Mobility Services**.

**Step 2**  
Click the name of the mobility services engine that you want to configure.

**Step 3**  
Choose **System > Logs**. The advanced parameters for the selected mobility services engine appears.

**Step 4**  
Choose the appropriate options from the Logging Level drop-down list.

There are four logging options: Off, Error, Information, and Trace.

All log records with a log level of Error or above are logged to a new error log file locserver-error-%u-%g.log. This is an additional log file maintained along with the location server locserver-%u-%g.log log file. The error log file consists of logs of Error level along with their context information. The contextual information consists of 25 log records prior to the error. You can maintain up to 10 error log files. The maximum size allowed for each log file is 10 MB.
### Information About Mobility Services

**Caution**

Use Error and Trace only when directed to do so by Cisco Technical Assistance Center (TAC) personnel.

**Step 5**
Select the **Enabled** check box next to each element listed in that section to begin logging of its events.

**Step 6**
Select the **Enable** check box under Advanced Parameters to enable advanced debugging. By default, this option is disabled.

**Step 7**
To download log files from the server, click **Download Logs**. For more information, see the “Downloading Mobility Services Engine Log Files” section on page 12-28.

**Step 8**
In the Log File Parameters section, enter the following:

- The number of log files to be maintained in the mobility services engine. You can maintain a minimum of 5 log files and a maximum of 20 log files in the mobility services engine.
- The maximum log file size in MB. The minimum log file size is 10 MB and the maximum is 50 MB.

**Step 9**
In the MAC Address Based Logging Parameters section, do the following:

- Select the **Enable** check box to enable MAC address logging. By default, this option is disabled.
- Add one or more MAC addresses for which you want to enable logging. You can also remove MAC addresses that you have already added by selecting the MAC address from the list and clicking **Remove**.

For more information on MAC Address-based logging, see the “MAC Address Based Logging” section on page 12-28.

**Step 10**
Click **Save** to apply your changes.

---

### MAC Address Based Logging

This feature allows you to create log files that are specific to an entity whose MAC address is specified. The log files are created in the locserver directory under the following path:

```
/opt/mse/logs/locserver
```

A maximum of 5 MAC addresses can be logged at a time. The Log file format for MAC address `aa:bb:cc:dd:ee:ff` is:

```
macaddress-debug-aa-bb-cc-dd-ee-ff.log
```

You can create a maximum of two log files for a MAC Address. The two log files may consist of one main and one backup or rollover log file.

The minimum size of a MAC log file is 10 MB. The maximum size allowed is 20 MB per MAC Address. The MAC log files which are not updated for more than 24 hours are pruned.

### Downloading Mobility Services Engine Log Files

If you need to analyze mobility services engine log files, you can use WCS to download them to your system. WCS downloads a zip file containing the log files.

To download a zip file containing the log files, follow these steps:

**Step 1**
Choose **Services > Mobility Services**.

**Step 2**
Click the name of the mobility services engine to view its status.

**Step 3**
From the left sidebar menu, click **Logs**.
Managing User and Group Accounts for a Mobility Services Engine

This section describes how to configure and manage users and groups on the mobility services engine. This section describes how to add, delete, and edit users for a mobility services engine and includes the following topics:

- Adding Users for a Mobility Services Engine, page 12-29
- Deleting Users, page 12-30
- Editing User Properties, page 12-30

Note
See the “Viewing Active Session Details for a Mobility Services Engine” section on page 12-24 for information on viewing active sessions for each user.

- Managing Group Accounts—This section describes how to add, delete, and edit user groups for a mobility services engine and includes the following topics:
  - Adding User Groups, page 12-30
  - Deleting User Groups, page 12-31
  - Editing Group User Permissions, page 12-31

Adding Users for a Mobility Services Engine

To add a users to a mobility services engine, follow these steps:

Step 1  Choose Services > Mobility Services.
Step 2  Click the device name of the mobility services engine that you want to edit.
Step 3  From the left sidebar menu, choose Systems > Accounts > Users.
Step 4  From the Select a command drop-down list, choose Add User.
Step 5  Click Go.
Step 6  Enter the username in the Username text box.
Step 7  Enter a password in the Password text box.
Step 8  Enter the name of the group to which the user belongs in the Group Name text box.
Step 9  Select a permission level from the Permission drop-down list.

There are three permission levels to select from: Read Access, Write Access, and Full Access (required for WCS to access a mobility services engine).

Caution
Group permissions override individual user permissions. For example, if you give a user full access and add that user to a group with read access, that user will not be able to configure mobility services engine settings.
Deleting Users

To delete a user from a mobility services engine, follow these steps:

**Step 1** Choose Services > Mobility Services.

**Step 2** Click the device name of the mobility services engine that you want to edit.

**Step 3** From the left sidebar menu, choose Systems > Accounts > Users.

**Step 4** Select the check box(es) of the user(s) that you want to delete.

**Step 5** From the Select a command drop-down list, select Delete User.

**Step 6** Click Go.

**Step 7** Click OK to confirm that you want to delete the selected users.

Editing User Properties

To change user properties, follow these steps:

**Step 1** Choose Services > Mobility Services.

**Step 2** Click the device name of the mobility services engine that you want to edit.

**Step 3** From the left sidebar menu, choose Systems > Accounts > Users.

**Step 4** Click the username of the user that you want to edit.

**Step 5** Make the required changes to the Password, Group Name, and Permission text boxes.

**Step 6** Click Save to apply your change.

Adding User Groups

To add a user group to a mobility services engine, follow these steps:

**Step 1** Choose Services > Mobility Services.

**Step 2** Click the device name of the mobility services engine that you want to edit.

**Step 3** From the left sidebar menu, choose Systems > Accounts > Groups.

**Step 4** From the Select a command drop-down list, select Add Group.

**Step 5** Click Go.

**Step 6** Enter the name of the group in the Group Name text box.

**Step 7** Select a permission level from the Permission drop-down list.

There are three permissions levels to select from:

- Read Access
• Write Access
• Full Access (required for WCS to access mobility services engines)

Step 8 Click **Save** to add the new group to the mobility services engine.

**Caution**
Group permissions override individual user permissions. For example, if you give a user full access and add that user to a group with read access permission, that user will not be able to configure mobility services engine settings.

### Deleting User Groups

To delete user groups from a mobility services engine, follow these steps:

- **Step 1** Choose **Services > Mobility Services**.
- **Step 2** Click the device name of the mobility services engine that you want to edit.
- **Step 3** From the left sidebar menu, choose **Systems > Accounts > Groups**.
- **Step 4** Select the check box(es) of the group(s) that you want to delete.
- **Step 5** From the Select a command drop-down list, choose **Delete Group**.
- **Step 6** Click **Go**.
- **Step 7** Click **OK** to confirm that you want to delete the selected users.

### Editing Group User Permissions

To change user group permissions, follow these steps:

- **Step 1** Choose **Services > Mobility Services**.
- **Step 2** Click the device name of the mobility services engine that you want to edit.
- **Step 3** From the left sidebar menu, choose **Systems > Accounts > Groups**.
- **Step 4** Click the group name of the group that you want to edit.
- **Step 5** Select a permission level from the Permission drop-down list.
- **Step 6** Click **Save** to apply your change.

**Caution**
Group permissions override individual user permissions. For example, if you give a user permission for full access and add that user to a group with read access, that user will not be able to configure mobility services engine settings.
Monitoring Status Information for a Mobility Services Engine

The System > Status page enables you to monitor server events, WCS alarms and events, and NMSP connection status for the mobility services engine.

This section provides additional information and contains the following topics:

- Viewing Server Events for a Mobility Services Engine, page 12-32
- Viewing WCS Alarms for a Mobility Services Engine, page 12-33
- Viewing WCS Events for a Mobility Services Engine, page 12-33
- Viewing NMSP Connection Status for a Mobility Services Engine, page 12-33

Viewing Server Events for a Mobility Services Engine

To view a list of server events, follow these steps:

**Step 1** Choose Services > Mobility Services.

**Step 2** Click the name of the applicable mobility service.

**Step 3** From the left sidebar menu, choose System > Status > Server Events.

The Status > Server Events page provides the following information:

- Timestamp—Time of the server event.
- Severity—Severity of the server event.
- Event—Detailed description of the event.
- Facility—The facility in which the event took place.

Viewing Audit Logs from a Mobility Services Engine

You can view the audit logs for User-triggered operations using the Audit Logs option available in a Mobility Services Engine. To view the audit logs, follow these steps:

**Step 1** Choose Services > Mobility Services.

**Step 2** Click the name of the applicable mobility services engine.

**Step 3** From the left sidebar menu, choose System > Status > Audit Logs.

The Status > Audit Logs page provides the following information:

- Username—The Username which has triggered the audit log.
- Operation—The operation that has been performed by the User.
- Operation Status—The status of the operation. It could be either SUCCESSFUL or FAILED.
- Invocation Time—The date and time at which the audit log was recorded for the specified operation.
Viewing WCS Alarms for a Mobility Services Engine

To view a list of WCS alarms, follow these steps:

**Step 1** Choose Services > Mobility Services.

**Step 2** Click the name of the applicable mobility service.

**Step 3** From the left sidebar menu, choose System > Status > WCS Alarms. See the “Monitoring Alarms” section on page 6-80 for more information.

Viewing WCS Events for a Mobility Services Engine

To view a list of WCS events, follow these steps:

**Step 1** Choose Services > Mobility Services.

**Step 2** Click the name of the applicable mobility service.

**Step 3** From the left sidebar menu, choose System > Status > WCS Events. See the “Monitoring Events” section on page 6-124 for more information.

Viewing NMSP Connection Status for a Mobility Services Engine

The NMSP Connection Status page allows you to verify the NMSP connection between the mobility services engine and the Cisco controller to which the mobility services engine is assigned.

**Note**
Network Mobility Services Protocol (NMSP) is the protocol that manages communication between the mobility service and the controller.

To verify the NMSP connection between the controller and the mobility services engine, follow these steps:

**Step 1** Choose Services > Mobility Services.

**Step 2** Click the name of the applicable mobility service.

**Step 3** From the left sidebar menu, choose System > Status > NMSP Connection Status.

The NMSP Connection Status page displays the following information:

- **Summary**—The Summary section displays each device type, the total number of connections, and the number of inactive connections.
- **NMSP Connection Status**—This section displays the following:
  - **IP address**—Click the device IP address to view NMSP connection status details for this device. See the “Viewing NMSP Connection Status Details” section on page 12-34 for additional information.
  - **Target Type**—Indicates the device to which the NMSP connection is intended.
  - **Version**—Indicates the current software version for the device.
Information About Mobility Services

- NMSP Status—Indicates whether the connection is active or inactive.
- Echo Request Count—Indicates the number of echo requests that were sent.
- Echo Response Count—Indicates the number of echo responses that were received.
- Last Message Received—Indicates the date and time of the most recent message received.

**Step 4** Verify that the NMSP Status is ACTIVE.
- If active, you can view details on wired switches and wired clients.
- If not active, resynchronize the WCS device and the mobility services engine.

Viewing NMSP Connection Status Details

To view NMSP Connection Status details, follow these steps:

**Step 1** Choose Services > Mobility Services.
**Step 2** Click the name of the applicable mobility service.
**Step 3** From the left sidebar menu, choose System > Status > NMSP Connection Status.
**Step 4** Click the device IP address to open the NMSP Connection Status Details page. The Details page displays the following information:

- **Summary**
  - IP Address
  - Version—The current software version for the device.
  - Target Type—The device to which the NMSP connection is intended.
  - NMSP Status—Indicates whether the connection is active or inactive.
  - Echo Request Count—The number of echo requests that were sent.
  - Echo Response Count—The number of echo responses that were received.
  - Last Activity Time—The date and time of the most recent message activity between the device and the mobility services engine.
  - Last Echo Request Message Received At—The date and time the last echo request was received.
  - Last Echo Response Message Received At—The date and time the last echo response was received.
  - Model—The device model.
  - MAC Address—The MAC address of the device, if applicable.
  - Capable NMSP Services—Indicates the NMSP-capable services for this device such as ATTACHMENT or LOCATION.
- **Subscribed Services**—Indicates subservices for each subscribed NMSP service. For example, MOBILE_STATION_ATTACHMENT is a subservice of ATTACHMENT.
- **Messages**
Information About Mobility Services

- Message Type—Message types may include: ATTACHMENT_NOTIFICATION, ATTACHMENT_REQUEST, ATTACHMENT_RESPONSE, CAPABILITY_NOTIFICATION, ECHO_REQUEST, ECHO_RESPONSE, LOCATION_NOTIFICATION, LOCATION_REQUEST, SERVICE_SUBSCRIBE_REQUEST, SERVICE_SUBSCRIBE_RESPONSE.
- In/Out—Indicates whether the message was an incoming or outgoing message.
- Count—Indicates the number of incoming or outgoing messages.
- Last Activity Time—The date and time of the most recent activity or message.
- Bytes—Size of the message in Bytes.

Managing Maintenance for Mobility Services

This section contains the following topics:

- Viewing or Editing Mobility Services Backup Parameters, page 12-35
- Backing Up Mobility Services Engine Historical Data, page 12-35
- Restoring Mobility Services Engine Historical Data, page 12-36
- Enabling Automatic Location Data Backup, page 12-36
- Downloading Software to a Mobility Services Engine Using Cisco WCS, page 12-37

Viewing or Editing Mobility Services Backup Parameters

To view or edit mobility service backup parameters, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Choose Services &gt; Mobility Services.</td>
</tr>
<tr>
<td>2</td>
<td>Click the name of the mobility service whose properties you want to edit.</td>
</tr>
<tr>
<td>3</td>
<td>From the left sidebar menu, choose Maintenance &gt; Backup.</td>
</tr>
</tbody>
</table>

- Backups located at—Indicates the location of the backup file.
- Enter a name for the Backup—Enter or edit the name of the backup file.
- Timeout (in secs)—Indicate the length of time (in seconds) before attempts to back up files will time out.

Back Up Mobility Services Engine Historical Data

WCS includes functionality for backing up mobility services engine data.

To back up mobility services engine data, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>In Cisco WCS, click Services &gt; Mobility Services.</td>
</tr>
<tr>
<td>2</td>
<td>Click the name of the mobility services engine that you want to back up.</td>
</tr>
<tr>
<td>3</td>
<td>From the left sidebar menu, choose Maintenance &gt; Backup.</td>
</tr>
</tbody>
</table>
Information About Mobility Services

Step 4  Enter the name of the backup.
Step 5  Enter the time in seconds after which the backup times out.
Step 6  Click Submit to back up the historical data to the hard drive of the server running WCS.

Status of the backup can be seen on the screen while the backup is in process. Three items will display on the screen during the backup process: (1) Last Status field provides messages noting the status of the backup; (2) Progress field shows what percentage of the backup is complete; and (3) Started at field shows when the backup began noting date and time.

Note You can run the backup process in the background while working on other mobility services engine operations in other WCS pages.

Note Backups are stored in the FTP directory you specify during the WCS installation.

Restoring Mobility Services Engine Historical Data

To restore a file back into the mobility service, follow these steps:

Step 1  Choose Services > Mobility Services.
Step 2  Click the name of the mobility service whose properties you want to edit.
Step 3  From the left sidebar menu, choose Maintenance > Restore.
Step 4  Choose the file to restore from the drop-down list.
Step 5  Select the Delete synchronized service assignments check box if you want to permanently remove all service assignments from the mobility services engine.

This option is applicable for network designs, wired switches, controllers and event definitions. The existing location history data is retained, however you must use manual service assignments to do any future location calculations.

Step 6  Click Submit to start the restoration process.
Step 7  Click OK to confirm that you want to restore the data from the Cisco WCS Server hard drive.

When restoration is completed, WCS displays a message to that effect.

Note You can run the restore process in the background while working on other mobility service engine operations in other WCS pages.

Enabling Automatic Location Data Backup

You can configure WCS to perform automatic backups of location data on a regular basis.

To enable automatic location service data backup on a mobility services engine, follow these steps:
Step 1 Choose Administration > Background Tasks.
Step 2 Select the Location Service Backup check box.
Step 3 Select Enable Task from the Select a command drop-down list. Click Go.
The backups are stored in the FTP directory you specified during the Cisco WCS installation.

### Downloading Software to a Mobility Services Engine Using Cisco WCS

To download software to a mobility services engine using WCS, follow these steps:

Step 1 Verify that you can ping the location appliance from WCS or an external FTP server, whichever you are going to use for the application code download.
Step 2 Choose Services > Mobility Services.
Step 3 Click the name of the mobility services engine to which you want to download software.
Step 4 On the left sidebar menu, choose Maintenance.
Step 5 Click Download Software.
To download software, do one of the following:
- To download software listed in the WCS directory, select Select from uploaded images to transfer into the Server. Then, choose a binary image from the drop-down list.
  WCS downloads the binary images listed in the drop-down list into the FTP server directory you have specified during the WCS installation.
- To use downloaded software available locally or over the network, select the Browse a new software image to transfer into the Server check box and click Browse. Locate the file, and click Open.
Step 6 Enter the time in seconds (between 1 and 1800) after which software download times out.
Step 7 Click Download to send the software to the /opt/installers directory on the mobility services engine.

### Managing Cisco Adaptive wIPS Service Parameters

The wIPS Service page allows you to view or manage wIPS service administrative settings.

Note Cisco Adaptive wIPS functionality is not supported for non-root partition users.

### Managing wIPS Service Administration Settings

To view or manage wIPS service administration settings, follow these steps:

Step 1 Choose Services > Mobility Services.
Step 2 Select the device name of the applicable mobility services engine.
Step 3 From the left sidebar menu, choose wIPS Service.
Step 4  View or edit the following parameters:
   • Log level—Select the applicable log level from the drop-down list. Log levels include debug, error, important event, major debug, none, and warning.
   • Forensic size limit (GB)—Enter the maximum allowable size of forensic files.
   • Alarm ageout (hours)—Enter the age limit in hours for each alarm.
   • Device ageout (days)—Enter the age limit in days for the device to send alarms.

Step 5  Click Save to confirm the changes or Cancel to close the page with no changes applied.

Managing Context Aware Service Parameters

Context-Aware Software (CAS) allows a mobility services engine to simultaneously track thousands of mobile assets and clients by retrieving contextual information such as location, temperature and asset availability about a client or tag (Cisco CX version or later) from Cisco access points.

CAS relies on two engines for processing the contextual information it receives. The Context-Aware Engine for Clients processes data received from Wi-Fi clients and the Context-Aware Engine for Tags processes data received from Wi-Fi tags; these engines can be deployed together or separately depending on the business need.

Note  Mobility services engines do not track or map non-Cisco CX tags.

Note  CAS was previously referred to as Cisco location-based services.

You can modify Context-Aware Software properties as to the type and number of clients or tags that are tracked and whether or not locations are calculated for those clients or tags.

You can also modify parameters that affect the location calculation of clients and tags such as Receiver Signal Strength Indicator (RSSI) measurements.

Viewing Contextual Information

Before you can use WCS to view contextual information, initial configuration for the mobility services engine is required using a command-line (CLI) console session. Refer to Cisco 3350 Mobility Services Engine Getting Started Guide and the Cisco 3100 Mobility Services Engine Getting Started Guide at the following link: http://www.cisco.com/en/US/products/ps9742/tsd_products_support_series_home.html.

After its installation and initial configuration are complete, the mobility services engine can communicate with multiple Cisco wireless LAN controllers to collect operator-defined contextual information. You can then use the associated WCS to communicate with each mobility services engine to transfer and display selected data.

You can configure the mobility services engine to collect data for clients, rogue access points, rogue clients, mobile stations, interferes and active RFID asset tags.

Licensing for Clients and Tags

You must purchase licenses from Cisco to retrieve contextual information on tags and clients from access points.
• Licenses for tags and clients are offered separately.
• The clients license also includes tracking of rogue clients and rogue access points, and interferers (if enabled).
• Licenses for tags and clients are offered in a variety of quantities, ranging from 1,000 to 12,000 units.

The AeroScout Context-Aware Engine for Tags support 100 permanent tag licenses. So Context-Aware Services will consist of permanent tag licenses.

Note
For more information on tags and client licenses, refer to the Release Notes for Cisco 3300 Series Mobility Services Engine for Software Release 6.0 at the following link:

This section describes information on Context-Aware parameters and contains the following parameters:

• Context-Aware General Parameters, page 12-39
• Context-Aware Administration Parameters, page 12-40
• Context Aware Advanced Parameters, page 12-53

Context-Aware General Parameters

To access the Context Aware Service > General page, choose Services > Mobility Services > General from the left sidebar menu. This page provides the following information:

• Number of tracked clients
• Number of traced tags
• Number of tracked rogues
• Number of tracked interferers
• Number of tracked wired clients
• Limit for total elements tracked
• Limit for number of tracked tags
• Interactive graph of the mobility services engine client and tag count

Note
See the “Monitoring Interactive Graphs” section on page 6-75 for more information on interactive graphs.

Note
• For MSEs with version higher than 7.0.200.116, the tag/client count chart shows four parameters: Client Count, Tag Count, Peak Client Count and Peak Tag Count in the line chart, the data grid and the legend.
• For MSEs with version lower 7.0.200.116, only the client and tag count parameters are shown in the line graph, data grid and the legend.
• The peak values of the clients and the tags are the peak counts reached during the MSE polling period window set on the WCS. The default polling period is 15 minutes.
Context-Aware Administration Parameters

This section contains the following topics:

- Modifying Tracking Parameters for Mobility Services Engines, page 12-40
- Modifying Filtering Parameters for Mobility Services, page 12-41
- Modifying History Parameters for Mobility Services, page 12-43
- Enabling Location Presence for Mobility Services, page 12-43
- Importing Asset Information for Mobility Services, page 12-44
- Exporting Asset Information for Mobility Services, page 12-45
- Importing Civic Information for Mobility Services, page 12-45

Modifying Tracking Parameters for Mobility Services Engines

The mobility services engine can track up to 18,000 clients and up to 18,000 tags (with the proper license purchase). Updates on the locations of elements being tracked are provided to the mobility services engine from the Cisco wireless LAN controller.

Only those elements designated for tracking by the controller are viewable in WCS maps, queries and reports. No events and alarms are collected for non-tracked elements and none are used in calculating the 18,000 element limit for clients or tags.

You can modify the following tracking parameters using WCS:

- Enable and disable element locations (client stations, active asset tags, and rogue clients and access points) you actively track.
  - Wired client location tracking enables servers in a data center to more easily find wired clients in the network. Servers are associated with wired switch ports in the network.
- Set limits on how many of a specific element you want to track.
  - For example, given a client license of 12,000 trackable units, you could set a limit to track only 8,000 client stations (leaving 4,000 units available to track rogue clients and rogue access points). Once the tracking limit is met for a given element, the number of elements not being tracked is summarized on the Tracking Parameters page.
- Disable tracking and reporting of ad hoc rogue clients and access points.

To configure tracking parameters for a mobility services engine, follow these steps:

Step 1 Choose Services > Mobility Services to open the Mobility Services page.
Step 2 Click the name of the mobility services engine whose properties you want to edit. The General Properties page opens.
Step 3 In the Context-Aware Software menu located on the left sidebar menu, select Tracking Parameters from the Administration sub-heading to display the configuration options.
Step 4 Modify the following tracking parameters as appropriate (see Table 12-4).
Step 5 Click Save to store the new settings in the mobility services engine database.
Modifying Filtering Parameters for Mobility Services

In WCS, you can limit the number of asset tags, wired clients, rogue clients, interferers and access points whose location is tracked by filtering on the following:

- **MAC addresses**

  Specific MAC addresses can be entered and labeled as allowed or disallowed from location tracking. You can import a file with the MAC addresses that are to be allowed or disallowed, or you can enter them individually from the WCS GUI page.

  The format for entering MAC addresses is xx:xx:xx:xx:xx:xx. If a file of MAC addresses is imported, the file must follow a specific format as noted below:

  - Each MAC address should be listed on a single line.
  - Allowed MAC addresses must be listed first and preceded by an “[Allowed]” line item. Disallowed MAC addresses must be preceded by “[Disallowed].”
  - Wildcard listings can be used to represent a range of MAC addresses. For example, the first entry “00:11:22:33:*” in the Allowed listing below is a wildcard.

  **Note**
  
  Allowed MAC address formats are viewable from the Filtering Parameters configuration page. See Table 12-4 for details.

  EXAMPLE file listing:

  ```
  [Allowed]
  00:11:22:33:*
  22:cd:34:ae:56:45
  02:23:23:34:*
  [Disallowed]
  00:10:*
  ae:bc:de:ea:45:23
  ```

- **Probing clients**

  Probing clients are clients that are associated to another controller but whose probing activity causes them to be seen by another controller and counted as an element by the “probed” controller as well as its primary controller.

To configure filtering parameters for a mobility services engine, follow these steps:

**Step 1**  Choose **Services > Mobility Services**. The Mobility Services page appears.

**Step 2**  Click the name of the mobility services engine whose properties you want to edit. The General Properties page appears.

**Step 3**  From the Context-Aware Software menu, select **Filtering Parameters** from the Administration sub-heading to display the configuration options.

**Step 4**  Modify the following filtering parameters as appropriate (see Table 12-4).
### Table 12-4 Filtering Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Configuration Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exclude Probing Clients</td>
<td>Select the check box to prevent location calculation of probing clients.</td>
</tr>
<tr>
<td>Enable Location MAC Filtering</td>
<td>1. Select the check box to enable MAC filtering of specific elements by their MAC address.</td>
</tr>
<tr>
<td></td>
<td>2. To import a file of MAC addresses (Upload a file for Location MAC Filtering field), browse for the file name and click <strong>Save</strong> to load the file. The imported list of MAC addresses auto-populates the Allowed List and Disallowed List based on their designation in the file.</td>
</tr>
<tr>
<td>Note</td>
<td>To view allowed MAC address formats, click the red question mark next to the Upload a file for Location MAC Filtering field.</td>
</tr>
<tr>
<td></td>
<td>3. To add an individual MAC address, enter the MAC addresses (format is xx:xx:xx:xx:xx:xx) and click either <strong>Allow</strong> or <strong>Disallow</strong>. The address appears in the appropriate column.</td>
</tr>
<tr>
<td>Note</td>
<td>To move an address between the Allow and Disallow columns, highlight the MAC address entry and click the button under the appropriate column.</td>
</tr>
<tr>
<td>Note</td>
<td>To move multiple addresses, click the first MAC address and press <strong>Ctrl</strong> to highlight additional MAC addresses. Click <strong>Allow</strong> or <strong>Disallow</strong> based on its desired destination.</td>
</tr>
<tr>
<td>Note</td>
<td>If a MAC address is not listed in the Allow or Disallow column, by default, it appears in the Blocked MACs column. If you click the <strong>Unblock</strong> button, the MAC address automatically moves to the Allow column. You can move it to the Disallow column by selecting the Disallow button under the Allow column.</td>
</tr>
</tbody>
</table>

### Step 5
Click **Save** to store the new settings in the mobility services engine database.
Modifying History Parameters for Mobility Services

You can use WCS to specify how long to store (archive) histories on client stations, rogue clients, and asset tags. These histories are received from those controllers that are associated with the mobility service.

You can also program the mobility service to periodically remove (prune) duplicate data from its historical files to reduce the amount of data stored on its hard drive.

To configure mobility service history settings, follow these steps:

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Choose Services &gt; Mobility Services.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Click the name of the mobility service whose properties you want to edit.</td>
</tr>
<tr>
<td>Step 3</td>
<td>From the left sidebar menu, choose Context Aware Service &gt; History Parameters.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Modify the following history parameters as appropriate (see Table 12-5).</td>
</tr>
</tbody>
</table>

### Table 12-5 History Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Archive for</td>
<td>Enter the number of days for the location appliance to retain a history of each enabled category. Default value is 30. Allowed values are from 1 to 99999.</td>
</tr>
<tr>
<td>Prune data starting at</td>
<td>Enter the number of hours and minutes at which the location appliance starts data pruning (between 0 and 23 hours, and between 1 and 59 minutes). Enter the interval in minutes after which data pruning starts again (between 0, which means never, and 99900000). Default start time is 23 hours and 50 minutes, and the default interval is 1440 minutes.</td>
</tr>
</tbody>
</table>

| Step 5 | Click Save to store your selections in the location appliance database. |

Enabling Location Presence for Mobility Services

You can enable location presence by mobility services engine to provide expanded Civic (city, state, postal code, country) and GEO (longitude, latitude) location information beyond the Cisco default setting (campus, building, floor, and X, Y coordinates). This information can then be requested by wireless and wired clients on a demand basis for use by location-based services and applications.

You can also import advanced location information such as the MAC address of a wired client and the wired switch slot and port to which the wired client is attached.

Location Presence can be configured when a new Campus, Building, Floor or Outdoor Area is being added or configured at a later date.

Once enabled, the mobility services engine is capable of providing any requesting Cisco CX v5 client its location.

**Note** Before enabling this feature, synchronize the mobility services engine.

To enable and configure location presence on a mobility services engine, follow these steps:
Step 1  Choose Services > Mobility Services > Device Name. Select the mobility services engine to which the campus or building or floor is assigned.

Step 2  From the left sidebar menu, choose Context Aware Services > Administration > Presence Parameters.

Step 3  Select the Service Type On Demand check box to enable location presence for Cisco CX clients v5.

Step 4  Select one of the following Location Resolution options:
   a. When Building is selected, the mobility services engine can provide any requesting client, its location by building.
      - For example, if a client requests its location and the client is located in Building A, the mobility services engine returns the client address as Building A.
   b. When AP is selected, the mobility services engine can provide any requesting client, its location by its associated access point. The MAC address of the access point displays.
      - For example, if a client requests its location and the client is associated with an access point with a MAC address of 3034:00hh:0adg, the mobility services engine returns the client address of 3034:00hh:0adg.
   c. When X,Y is selected, the mobility services engine can provide any requesting client, its location by its X and Y coordinates.
      - For example, if a client requests its location and the client is located at (50, 200) the mobility services engine returns the client address of 50, 200.

Step 5  Select any or all of the location formats:
   a. Select the Cisco check box to provide location by campus, building and floor and X and Y coordinates. Default setting.
   b. Select the Civic check box to provide the name and address (street, city, state, postal code, country) of a campus, building, floor or outdoor area.
      - Note To import a file with multiple Civic listings, see the “Importing Civic Information for Mobility Services” section on page 12-45.
   c. Select the GEO check box to provide the longitude and latitude coordinates.

Step 6  By default the Text check box for Location Response Encoding is selected. It indicates the format of the information when received by the client. There is no need to change this setting.

Step 7  Select the Retransmission Rule Enable check box to allow the receiving client to retransmit the received information to another party.

Step 8  Enter a Retention Expiration value in minutes. This determines how long the received information is stored by the client before it is overwritten. Default value is 24 hours (1440 minutes).

Step 9  Click Save.

Importing Asset Information for Mobility Services

To import asset, chokepoint, and TDOA receiver information for the mobility services engine using WCS, follow these steps:
Information About Mobility Services

Step 1 Choose Services > Mobility Services.
Step 2 Click the name of the mobility services engine for which you want to import information.
Step 3 Choose Context Aware Service > Administration > Import Asset Information.
Step 4 Enter the name of the text file or browse for the filename.
Specify information in the imported file in the following formats:
- tag format: #tag, 00:00:00:00:00:00, categoryname, groupname, assetname
- station format: #station, 00:00:00:00:00:00, categoryname, groupname, assetname
Step 5 When the import file name is located in the Browse text box, click Import.

Exporting Asset Information for Mobility Services

To export asset, chokepoint, and TDOA receiver information from the mobility services engine to a file using WCS, follow these steps:

Step 1 Choose Services > Mobility Services.
Step 2 Click the name of the mobility services engine from which you want the export information.
Step 3 Choose Context Aware Service > Administration > Export Asset Information.
Information in the exported file is in the the following formats:
- tag format: #tag, 00:00:00:00:00:00, categoryname, groupname, assetname
- station format: #station, 00:00:00:00:00:00, categoryname, groupname, assetname
Step 4 Click Export.
Click Open (display to screen), Save (to external PC or server), or Cancel (to cancel the request).

Note If you select Save, you are asked to select the asset file destination and name. The file is named assets.out by default. Click Close from the dialog box when download is complete.

Importing Civic Information for Mobility Services

To import civic information for the mobility services engine using WCS, follow these steps:

Step 1 Choose Services > Mobility Services.
Step 2 Click the name of the mobility services engine for which you want to import asset information.
Step 3 Click Context Aware Software located in the left sidebar menu.
Step 4 Click Import Civic Information from under the Administration sub-menu heading.
Step 5 Enter the name of the text file or browse for the file name.
Information in the imported file should be one of the following formats:
Switch IP Address, Slot Number, Port Number, Extended Parent Civic Address, X, Y, Floor ID, Building ID, Network Design ID, ELIN:“ELIN”, PIDF-Lo-Tag:“Civic Address Element Value”

Note: Each entry must appear on a separate line.

Step 6: Click Import.

Context Aware Wired Parameters

This section describes the Context Aware Service > Wired drop-down list parameters and includes the following topics:

- Monitoring Wired Switches, page 12-46
- Wired Switch Details, page 12-46
- Monitoring Wired Clients, page 12-47
- Wired Client Details, page 12-48

Monitoring Wired Switches

You can review details on the wired switch (IP address, MAC address, serial number, software version, and ELIN), its port, its wired clients (count and status), and its civic information.

Wired switch data is downloaded to the mobility services engine through WCS when the ethernet switch and the mobility services engine are synchronized (Services > Synchronize Services > Switches). Communications between a location-capable switch and the mobility services engine is over NMSP. WCS and the mobility services engine communicate over XML.

To view details on wired switches, follow these steps:

Step 1 Choose Services > Mobility Services.
Step 2 In the Mobility Services page, click the device name link of the appropriate wired location switch.
Step 3 Choose Context Aware Service > Wired > Wired Switches. A summary of wired switches that are synchronized with the mobility services engine appears.
Step 4 To see more details on the switch, its port, its wired clients (count and status), and its civic information click the IP address link. See the “Wired Switch Details” section on page 12-46 for information on wired switch details.

Wired Switch Details

To view wired switch details, follow these steps:

Step 1 Choose Services > Mobility Services.
Step 2 At the Mobility Services page, click the device name link of the appropriate mobility services engine.
Step 3 Choose Context Aware Service > Wired > Wired Switches. A summary of wired switches that are synchronized with the mobility services engine appears.
Click the IP address link for the applicable wired switch. The Wired Switch Details page opens. 

The Wired Switch Details page has four tabs: Switch Information, Switch Ports, Civic, and Advanced.

Note You can export civic information from the switch by selecting that option from the Select a command drop-down list. This option is available in all four panes of the Wired Switches page.

The Wired Switch Details tabs display the following information:

- **Switch Information**—Displays a total count summary of wired clients connected to the switch along with the state of the client (connected, disconnected, and unknown).
  - Connected clients—Clients that are connected to the wired switch.
  - Disconnected clients—Clients that are disconnected from the wired switch.
  - Unknown clients—Clients are marked as unknown when the NMSP connection to the wired switch is lost.

Note You can view detailed wired client information by clicking on one of the client count links (total clients, connected, disconnected, and unknown). See the “Monitoring Wired Clients” section on page 12-47 section for more information.

- **Switch Ports**—Displays a detailed list of the ports on the switch.

Note You can change the listing order (ascending, descending) of port IP addresses, slot numbers, module number, port type, and port number by clicking on the respective column heading.

- **Civic**—Displays a detailed list of the civic information for the wired switch.
- **Advanced**—Displays a detailed list of the additional civic information for the wired switch.

### Monitoring Wired Clients

You can view details on a wired client (MAC address, IP address, username, serial number, UDI, model no., software version, VLAN ID, and VLAN ID), port association, and its civic information.

Wired client data is downloaded to the mobility services engine through WCS when the switch and the mobility services engine are synchronized (Services > Synchronize Services > Switches).

WCS and the mobility services engine communicate over XML.

You can view the details of the wired client on either the wired switches page (Context Aware Service > Wired > Wired Switches) or wired clients page (Context Aware Service > Wired > Wired Clients).

- If you know the IP address, MAC address, VLAN ID, serial number, or username, you can use the search field on the wired clients page.
- If you want to examine wired clients as they relates to a specific switch, you can view that information on the wired switches page. See the “Monitoring Wired Switches” section on page 12-46 section for more information.

To view details on a wired client, follow these steps:

**Step 1** Choose **Services > Mobility Services**. The Mobility Services page opens.
Step 2 Click the device name link of the appropriate wired location switch.

Step 3 Choose Context Aware Service > Wired > Wired Clients.

At the Wired Clients summary page, clients are grouped by their switch. A client status is noted as connected, disconnected, or unknown:

- Connected clients—Clients that are active and connected to a wired switch.
- Disconnected clients—Clients that are disconnected from the wired switch.
- Unknown clients—Clients that are marked as unknown when the NMSP connection to the wired switch is lost. See the “Viewing NMSP Connection Status for a Mobility Services Engine” section on page 12-33 for more information about NMSP connections.

If you know the MAC address of the wired client, you can click that link to reach the detail page of the client or use the search field. See the “Wired Client Details” section on page 12-48 for more information on wired client details.

- You can also search for a wired client by its IP address, username, or VLAN ID.

If you click the IP address of the switch, you are forwarded to the detail page of the switch. See the “Monitoring Wired Switches” section on page 12-46 for more information.

Step 4 Click the MAC Address for the applicable client to view wired client details. See the “Wired Client Details” section on page 12-48 for more information on wired client details.

---

Wired Client Details

To view wired client details, follow these steps:

Step 1 Choose Services > Mobility Services.

Step 2 At the Mobility Services page, click the device name link of the appropriate mobility services engine.

Step 3 Choose Context Aware Service > Wired > Wired Clients. A summary of wired clients that are synchronized with the mobility services engine appears.

Step 4 Click the MAC address link for the applicable wired client. The Wired Client Details page opens.

The Wired Client Details page has four tabs: Device Information, Port Association, Civic Address, and Advanced.

The Wired Switch Details tabs display the following information:

- Device Information—Display MAC and IP address, username, serial and model number, UDI, software version, VLAN ID, and VLAN name.
- Port Association—Displays the physical location of the switch port/slot/module on which the wired client terminates, the client status (connected, disconnected, unknown), and the switch IP address.
- Civic Address—Displays any civic address information.
- Advanced—Displays extended physical address details for the wired clients, if applicable.
Information About Mobility Services

Note
A client takes on the civic address and advanced location information that is configured for the port on which the client terminates. If no civic and advanced information is defined for the its port (port/slot/module) then no location data is displayed.

Monitoring Interferers

The Monitor > Interferers page allows you to monitor interference devices detected by the CleanAir enabled access points.

This section provides information on the interferers detected by the CleanAir enabled access points. By default, the Monitor > Interferers > AP Detected Interferers, page 12-49 page is displayed.

- Monitor > Interferers > AP Detected Interferers, page 12-49
- Monitor > Interferers > AP Detected Interferers > Interferer Details, page 12-50
- Monitor > Interferers > Edit View, page 12-52
- Monitor > Interferers > Edit View > Edit Search, page 12-52

Monitor > Interferers > AP Detected Interferers

Choose Monitor > Interferers to view all the interfering devices detected by the CleanAir enabled access points on your wireless network. This page enables you to view a summary of the interferring devices including the following default information:

- Interferer ID—A unique identifier for the interferer. Click this link to know more about the interferer.
- Type—Indicates the category of the interferer. Click to read more about the type of device. The categories include:
  - Bluetooth link—A Bluetooth link (802.11b/g/n only)
  - Microwave Oven—A microwave oven (802.11b/g/n only)
  - 802.11 FH—An 802.11 frequency-hopping device (802.11b/g/n only)
  - Bluetooth Discovery—A Bluetooth discovery (802.11b/g/n only)
  - TDD Transmitter—A time division duplex (TDD) transmitter
  - Jammer—A jamming device
  - Continuous Transmitter—A continuous transmitter
  - DECT-like Phone—A digital enhanced cordless communication (DECT)-compatible phone
  - Video—A video camera
  - 802.15.4—An 802.15.4 device (802.11b/g/n only)
  - WiFi Inverted—A device using spectrally inverted Wi-Fi signals
  - WiFi Invalid—A device using non-standard Wi-Fi channels
  - SuperAG—An 802.11 SuperAG device
  - Canopy—A Motorola Canopy device
  - Radar—A radar device (802.11a/n only)
Information About Mobility Services

- **XBox**—A Microsoft Xbox (802.11b/g/n only)
- **WiMAX Mobile**—A WiMAX mobile device (802.11a/n only)
- **WiMAX Fixed**—A WiMAX fixed device (802.11a/n only)

  - **Status**—Indicates the status of the interfering device.
    - **Active**—Indicates that the interferer is currently being detected by the CleanAir enabled access point.
    - **Inactive**—Indicates that the interferer is no longer being detected by the CleanAir enabled access point or the CleanAir enabled access point saw the interferer no longer reachable by WCS.

  - **Severity**—Displays the severity ranking of the interfering device.

  - **Affected Band**—Displays the band in which this device is interfering.

  - **Affected Channels**—Displays the affected channels.

  - **Duty Cycle (%)**—The duty cycle of interfering device in percentage.

  - **Discovered**—Displays the time at which it was discovered.

  - **Last Updated**—The last time the interference was detected.

  - **Floor**—The location where the interfering device is present.

  **Note**
  These devices appear only if the option to track Interferers is enabled in the Tracking Parameters page. This option is disabled by default. For more information on tracking parameters, see the “Modifying Tracking Parameters for Mobility Services Engines” section on page 12-40.

**Monitor > Interferers > AP Detected Interferers > Interferer Details**

Choose **Monitor > Interferers > Interferer ID** to view this page. This page enables you to view the details of the interfering devices detected by the access points. This page provides the following details about the interfering device.

- **Interferer Properties**
  - **Type**—Displays the type of the interfering device detected by the AP.

- **Status**—The status of the interfering device. Indicates the status of the interfering device.
  - **Active**—Indicates that the interferer is currently being detected by the CleanAir enabled access point.
  - **Inactive**—Indicates that the interferer is no longer being detected by the CleanAir enabled access point or the CleanAir enabled access point saw the interferer no longer reachable by WCS.

  - **Severity**—Displays the severity ranking of the interfering device.

  - **Duty Cycle (%)**—The duty cycle of interfering device in percentage.

  - **Affected Band**—Displays the band in which this device is interfering.

  - **Affected Channels**—Displays the affected channels.

  - **Discovered**—Displays the time at which it was discovered.

  - **Last Updated**—The last time the interference was detected.

- **Location**
- Floor—The location where this interfering device was detected.
- Last Located At—The last time where the interfering device was located.
- On MSE—The Mobility Server Engine on which this interference device was located.

- Clustering Information
  - Clustered By—Displays the following:
    IP address of the controller if clustered by a controller.
    IP address of the mobility services engine if clustered by a mobility services engine.
  - Detecting APs—Displays the details of the access point that has detected the interfering device.
    The details include: Access Point Name (Mac), Severity, and Duty Cycle(%).

**Note**

The detecting access point information is available only for active devices. And even for some active devices, this information may not be available. This is because, those interferers are in the process of being marked inactive and in the next refresh of Monitor > Interferers page, those will appear inactive.

- Details—Displays a short description about the interfering type.

Select a command

The Select a command drop-down list provides access to the location history of the interfering device detected by the access point. See the “Monitor > Interferers > AP Detected Interferer Details > Interference Device ID > Location History” section on page 12-51.

**Monitor > Interferers > AP Detected Interferer Details > Interference Device ID > Location History**

Choose Monitor > Interferers > Interference Device ID and select Location History from the Select a command drop-down list, and click Go to view this page.

- Interferer Information—Displays the basic information about the interfering device.
  - Data Collected At—The time stamp at which the data was collected.
  - Type—The type of the interfering device.
  - Severity—The severity index of the interfering device.
  - Duty Cycle—The duty cycle (in percentage) of the interfering device.
  - Affected Channels—A comma separated list of the channels affected.

- Interferer Location History—Displays the location history of the interfering devices.
  - Time Stamp
  - Floor

- Clustering Information
  - Clustered By

- Detecting APs
  - AP Name—The access point that detected the interfering device.
  - Severity—The severity index of the interfering device.
  - Duty Cycle(%)—The duty cycle (in percentage) of the interfering device.

- Location
Information About Mobility Services

- Location Calculated At—Displays the time stamp at which this information was generated.
- Floor—Displays location information of the interfering device.
- A graphical view of the location of the interfering device is displayed in a map. Click the Enlarge link to view an enlarged image.

Monitor > Interferers > Edit View

The Edit View page allows you to add, remove, or reorder columns in the AP Detected Interferers Summary page. It also allows you to search for Interferers. By default only those interferers that are in Active state and with severity greater than or equal to 5 are displayed in the AP Detected Interferers page. For more information on editing search criteria, see the “Monitor > Interferers > Edit View > Edit Search” section on page 12-52.

To edit the columns in the AP Detected Interferers page, follow these steps:

Step 1 Choose Monitor > Interferers. The AP Detected Interferers page appears showing details of the interferers detected by the CleanAir enabled access points.

Step 2 Click the Edit View link in the AP Detected Interferers page.

Step 3 To add an additional column to the access points table, click to highlight the column heading in the left column. Click Show to move the heading to the right column. All items in the right column are displayed in the table.

Step 4 To remove a column from the access points table, click to highlight the column heading in the right column. Click Hide to move the heading to the left column. All items in the left column are not displayed in the table.

Step 5 Use the Up/Down buttons to specify the order in which the information appears in the table. Highlight the desired column heading and click Up or Down to move it higher or lower in the current list.

Step 6 Click Reset to restore the default view.

Step 7 Click Submit to confirm the changes.

Monitor > Interferers > Edit View > Edit Search

You can search for interferers based on certain criteria. By default only those interferers that are in Active state and with severity greater than or equal to 5 are displayed in the AP Detected Interferers page. Use the Edit Search option to customize the interferer search.

To edit the search criteria, follow these steps:

Step 1 Choose Monitor > Interferers. The AP Detected Interferers page appears.

Step 2 Click Edit Search and select the appropriate criteria. This option allows you to specify the following search criteria:

- Search Category—For interferer search, the search category is Interferers.
- Detected By—Select from the drop down box if the interferer is detected by access points or interferer.
- Search By—Select any one of the option from the list box:
  - All Interferers
  - Interferer ID
Information About Mobility Services

- Interferer Type
- Severity
- Duty Cycle
- Location

- Severity greater than—Enter the severity level in the text box.
- Detected within the last—Select any one of the option from the list box:
  - 5 Minutes
  - 15 Minutes
  - 30 Minutes
  - 1 Hour
  - 3 Hours
  - 6 Hours
  - 12 Hours
  - 24 Hours
  - All History

- Interferer status—Select any of the following options from the list box:
  - Active
  - Inactive
  - All

- Restrict By Radio Band/Channels—Select this check box if you want to restrict certain radio frequencies or channels from the search. By default this check box is unselected. On selected this check box, a list box appears with 2.4 GHz, 5 GHz and Individual Channel options. If you select Individual Channel, an Affected Channels text box appears. Specify the channel and select either the Match All or Match Any radio button.

**Step 3** Select the number of items per page that you want to view in the search results.

**Step 4** Select the Save Search check box if you want to save the search.

**Step 5** After specifying the search criteria. Click Go to view the search results.

Context Aware Advanced Parameters

This section contains the following topics:

- Modifying Location Parameters for Mobility Services, page 12-53
- Modifying Notification Parameters for Mobility Services, page 12-56

Modifying Location Parameters for Mobility Services

You can use WCS to specify whether the mobility service retains its calculation times and how soon the mobility service deletes its collected Receiver Signal Strength Indicator (RSSI) measurement times. You can also apply varying smoothing rates to manage location movement of an element.
To configure location parameters, follow these steps:

**Step 1** Choose Services > Mobility Services.

**Step 2** Click the name of the mobility service whose properties you want to edit.

**Step 3** From the left sidebar menu, choose Context Aware Service > Location Parameters.

**Step 4** Modify the location parameters as appropriate (see Table 12-6).

### Table 12-6 Location Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General</strong></td>
<td></td>
</tr>
<tr>
<td>Enable Calculation Time</td>
<td>Select the check box to enable the calculation of the time required to compute location.</td>
</tr>
<tr>
<td>![Caution]</td>
<td>Enable only under Cisco TAC personnel guidance because enabling this parameter slows down overall location calculations.</td>
</tr>
<tr>
<td>Enable OW Location</td>
<td>Select the check box to enable Outer Wall (OW) calculation as part of location calculation.</td>
</tr>
<tr>
<td>![Note]</td>
<td>The OW Location parameter is ignored by the location server.</td>
</tr>
<tr>
<td>Relative discard RSSI time</td>
<td>Enter the number of minutes since the most recent RSSI sample after which RSSI measurement should be considered stale and discarded. Default value is 3. Allowed values range from 0 to 99999. A value of less than 3 is not recommended.</td>
</tr>
<tr>
<td>Absolute discard RSSI time</td>
<td>Enter the number of minutes after which RSSI measurement should be considered stale and discarded, regardless of the most recent sample. Default value is 60. Allowed values range from 0 to 99999. A value of less than 60 is not recommended.</td>
</tr>
</tbody>
</table>
### Table 12-6 Location Parameters (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RSSI Cutoff</td>
<td>Enter the RSSI cutoff value, in decibels (dBs) with respect to one (1) mW (dBm), above which the mobility service will always use the access point measurement. Default value is -75.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>When 3 or more measurements are available above the RSSI cutoff value, the mobility service will discard any weaker values and use the 3 (or more) strongest measurements for calculation; however, when only weak measurements below the RSSI cutoff value are available, those values are used for calculation.</td>
</tr>
<tr>
<td><strong>Caution</strong></td>
<td>Modify only under Cisco TAC personnel guidance. Modifying this value can reduce the accuracy of location calculation.</td>
</tr>
<tr>
<td>Enable Location Filtering</td>
<td>If enabled, the location filter is applied only for client location calculation. Enabling location filter allows previous location estimates to be used in estimating current location. This reduces location jitter for stationary clients and improve tracking for mobile clients.</td>
</tr>
<tr>
<td>Chokepoint Usage</td>
<td>Select the check box to enable the usage of chokepoint proximity to determine location. Applies to Cisco compatible Tags capable of reporting chokepoint proximity.</td>
</tr>
<tr>
<td>Use Chokepoints for Interfloor conflicts</td>
<td>Allows the use of chokepoints to determine the correct floor during Interfloor conflicts. Select Never, Always, or Floor Ambiguity.</td>
</tr>
<tr>
<td>Chokepoint Out of Range Timeout</td>
<td>After a Cisco compatible Tag leaves a chokepoint proximity range, this is the timeout (in seconds) after which RSSI information will be used again to determine location.</td>
</tr>
<tr>
<td>Absent Data Cleanup Interval</td>
<td>Enter the interval period (in minutes) for removing inactive elements from the database.</td>
</tr>
</tbody>
</table>
Modifying Notification Parameters for Mobility Services

You can use WCS to configure mobility services engine event notification parameters that define such items as how often the notifications are generated or resent by the mobility services engine.

**Note** Modify notification parameters only if you expect the mobility services engine to send a large number of notifications or if notifications are not being received.

You can also enable forwarding of northbound notifications for tags to be sent to third-party applications. The format of northbound notifications sent by the mobility services engine is available on the Cisco developers support portal at:


To configure notification parameters, follow these steps:

**Step 1** Choose **Services > Mobility Services**.

**Step 2** Click the name of the mobility services engine you want to configure.

**Step 3** From the Context Aware Software left sidebar menu, select **Notification Parameters** from the Advanced sub-heading to display the configuration options.

**Step 4** Select the **Enable Northbound Notifications** check box to enable the function.

**Step 5** Select the **Notification Contents** check box to send notifications to third-party applications (northbound).

**Step 6** Select one or more of the following Notification content options:

- Chokepoints
- Telemetry
- Emergency
- Battery Level
- Vendor Data
- Location

### Table 12-6  Location Parameters (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Default Heatmaps for Non Cisco Antennas</td>
<td>Select this check box to enable the usage of default heatmaps for non-Cisco antennas during the Location Calculation. This option is disabled by default.</td>
</tr>
</tbody>
</table>

**Movement Detection**

**Step 5** Click **Save** to store your selections in the WCS and mobility service databases.
Step 7  Select the Notification Triggers check box.

Step 8  Select one or more of the following Notification trigger options:
- Chokepoints
- Telemetry
- Emergency
- Battery Level
- Vendor Data
- Location Recalculation

Step 9  Enter the IP address and port for the system that is to receive the northbound notifications.

Step 10 Select the transport type from the drop-down list.

Step 11 Select HTTPS if you want to use HTTPS protocol for secure access to the destination system.

Step 12 To modify the notification parameter settings, enter the new value in the appropriate text box in the Advanced section of the page. Table 12-7 describes each parameter.

Table 12-7  User-Configurable Conditional and Northbound Notifications Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Configuration Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rate Limit</td>
<td>Enter the rate in milliseconds at which the mobility services engine generates notifications. A value of 0 (default) means that the mobility services engine generates notifications as fast as possible (Northbound notifications only).</td>
</tr>
<tr>
<td>Queue Limit</td>
<td>Enter the event queue limit for sending notifications. The mobility services engine drops any event above this limit. Default values: Cisco 3350 (30000), Cisco 3310 (5,000), and Cisco 2710 (10,000).</td>
</tr>
<tr>
<td>Retry Count</td>
<td>Enter the number of times to generate an event notification before the refresh time expires. This parameter can be used for asynchronous transport types which do not acknowledge the receipt of the notification and there is a possibility that the notification may be lost in transit. Default value is 1.</td>
</tr>
<tr>
<td>Note</td>
<td>The mobility services engine does not store events in its database.</td>
</tr>
<tr>
<td>Refresh Time</td>
<td>Enter the wait time in minutes that must pass before a notification is resent. For example if a device is configured for In Coverage Area notification and it is constantly being detected within the Coverage Area. The notification will be sent once every refresh time.</td>
</tr>
<tr>
<td>Drop Oldest Entry on Queue Overflow</td>
<td>(Read only). The number of event notifications dropped from the queue since startup.</td>
</tr>
<tr>
<td>Serialize Events per Mac address per Destination</td>
<td>Select this option if you want the successive events for the same MAC address to be sent to a single destination in a serial manner.</td>
</tr>
</tbody>
</table>

Step 13  Click Save.
Information About Mobility Services

Viewing Tag Engine Status

To access the Tag Engine Status page, choose Services > Mobility Services > MSE Name > Context Aware Service > Tag Engine > Status.

If tag licenses are available, then Aeroscout Tag Engine is enabled. Else, Cisco Tag Engine is enabled by default.

If only evaluation license is available then Cisco Tag Engine is enabled by default. The Tag Engine status page shows status based on whether it is Aeroscout Tag Engine or Cisco Tag Engine.

If you have selected Aeroscout Tag Engine for Context Aware Service, the Tag Engine Status page displays the following information:

Table 12-9 describes the fields in the Tag Engine Status page for Aeroscout Tag Engine.

If you selected Cisco Tag Engine for Context Aware Service, the Tag Engine Status page displays the following information:

Table 12-10 describes the fields in the Tag Engine Status page for Cisco Tag Engine.

Viewing Notification Information for Mobility Services

The Services > Context Aware Notifications page provides the ability to define events. This section contains the following topics:

- Viewing the Notifications Summary for Mobility Services, page 12-58
- Viewing and Managing Notifications Settings for Mobility Services, page 12-59
- Viewing Notification Statistics, page 12-60

Viewing the Notifications Summary for Mobility Services

To view the Notification Summary, choose Services > Context Aware Notifications > Summary.

The mobility service sends event notifications and does not store them (fire and forget). However, if WCS is a destination of notification events, it stores the notifications it receives and groups them into the following seven categories:

- Absence (Missing)—Generated when the mobility service cannot see the asset in the WLAN for the specified time.
- Location Changes—Generated when client stations, asset tags, rogue clients, and rogue access points move from their previous location.
- Chokepoint Notifications—Generated when a tag is seen (stimulated) by a chokepoint. This information is only reported and displayed for CCX v.1 compliant tags.
- In/Out Area—Generated when an asset is moved inside or outside a designated area.

Note

You define a containment area (campus, building, or floor) in the Maps section of WCS (Monitor > Maps). You can define a coverage area using the Map Editor.

- Battery Level—Generated when a tracked asset tag hits the designated battery level.
Movement from Marker—Generated when an asset is moved beyond a specified distance from a designated marker you define on a map.

Emergency—Generated for a CCX v.1 compliant asset tag when the panic button of the tag is triggered or the tag becomes detached, tampered with, goes inactive or reports an unknown state. This information is only reported and displayed for CCX v.1 compliant tags.

The summary details include the following:
- All Notifications
- Client Stations
- Asset Tags
- Rogue Clients
- Rogue Access Points

Note
To view details for each of the notifications, click the number under the Last Hour, Last 24 Hours, or Total Active column to open the details page for the applicable notification.

Notifications Cleared
A mobility service sends event notifications when it clears an event condition in one of the following scenarios:
- Missing (Absence)—Elements reappear.
- In/Out Area (Containment)—Elements move back in or out of the containment area.
- Distance—Elements move back within the specified distance from a marker.
- Location Changes—Clear state is not applicable to this condition.
- Battery Level—Tags are detected again operating with Normal battery level.

Note
In WCS, the Notifications Summary page reflects whether notifications for cleared event conditions have been received.

Viewing and Managing Notifications Settings for Mobility Services

Note
An Event Group must be created which contains the rules that trigger a notification.

To view the Notifications Settings, follow these steps:

Step 1
Choose Services > Context Aware Notifications.

Step 2
From the left sidebar menu, select Settings.
Viewing Notification Statistics

You can view the notification statistics for a specific mobility services engine. To view the Notification Statistics for a specific mobility services engine:

Go to Services > Mobility Services > MSE-name > Context Aware Service > Notification Statistics.

Table 12-2 describes the fields in the Notification statistics page.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Destinations</td>
<td></td>
</tr>
<tr>
<td>Total</td>
<td>Total count of the destinations.</td>
</tr>
<tr>
<td>Unreachable</td>
<td>Count of unreachable destinations.</td>
</tr>
<tr>
<td>Notification Statistics Summary</td>
<td></td>
</tr>
<tr>
<td>Track Definition Status</td>
<td>Status of the track definition. Track notification status could be either Enabled or Disabled.</td>
</tr>
<tr>
<td>Track Definition</td>
<td>Track definition can be either Notrhbound or CAS event notification.</td>
</tr>
<tr>
<td>Destination IP Address</td>
<td>The destination IP Address to which the notifications are sent.</td>
</tr>
<tr>
<td>Destination Port</td>
<td>The destination port to which the notifications are sent.</td>
</tr>
<tr>
<td>Destination Type</td>
<td>The type of the destination. Example: SOAP_XML</td>
</tr>
<tr>
<td>Destination Status</td>
<td>Status of the destination device. The status is either Up or Down.</td>
</tr>
<tr>
<td>Last Sent</td>
<td>The date and time at which the last notification was sent to the destination device.</td>
</tr>
<tr>
<td>Last Failed</td>
<td>The date and time at which the notification had failed.</td>
</tr>
<tr>
<td>Total Count</td>
<td>The total count of notifications sent to the destination. Click the count link to view the notification statistics details of the destination device.</td>
</tr>
</tbody>
</table>

About Event Groups

To manage events more efficiently, you can use WCS to create event groups. Event groups help you organize your event definitions.

This section consists of the following topics:

- Adding Event Groups, page 12-61
- Deleting Event Groups, page 12-61
• Working with Event Definitions, page 12-61
• Deleting an Event Definition, page 12-68

Adding Event Groups

To add an event group, follow these steps:

Step 1 Choose Services > Context Aware Notifications.
Step 2 Click Notification Definitions from the left sidebar menu.
Step 3 From the Select a command drop-down list, choose Add Event Group.
Step 4 Click Go.
Step 5 Enter the name of the group in the Group Name text box.
Step 6 Click Save.

The new event group appears in the Event Settings page.

Deleting Event Groups

To delete an event group, follow these steps:

Step 1 Choose Services > Context Aware Notifications.
Step 2 Choose Notification Definitions from the left sidebar menu.
Step 3 Select the check box of the event group you want to delete.
Step 4 From the Select a command drop-down list, choose Delete Event Group(s).
Step 5 Click Go.
Step 6 Click OK to confirm the deletion.
Step 7 Click Save.

Working with Event Definitions

An event definition contains information about the condition that caused the event, the assets to which the event applies, and the event notification destinations. This section describes how to add, delete, and test event definitions.

Note WCS enables you to add definitions on a per-group basis. Any new event definition must belong to a particular group.

To add an event definition, follow these steps:

Step 1 Choose Services > Context Aware Notifications.
Step 2 From the left sidebar menu, choose Notification Definitions.
Step 3  Click the name of the group to which you want to add the event. An event definition summary page appears for the selected event group.

Step 4  From the Select a command drop-down list, choose **Add Event Definition**.

Step 5  Click **Go**.

Step 6  Enter the name of the event definition in the Event Definition Name text box.

**Note**  The event definition name must be unique within the event group.

Step 7  Click **Save**.

Step 8  On the General tab, manage the following parameters:

- **Admin Status**—Enable event generation by selecting the **Enabled** check box (disabled by default).
- **Priority**—Set the event priority by choosing a number from the drop-down list. Zero is highest.

**Note**  An event definition with higher priority is serviced before event definitions with lower priority.

- **Activate**—To continuously report events, select the **All the Time** option. To indicate specific days and times for activation, deselect the **All the Time** option and choose the applicable days and From/Until times. Click **Save**.

Step 9  On the Conditions tab, add one or more conditions. For each condition, specify the rules for triggering events notifications. To add a condition, follow these steps:

a. Click **Add** to open the Add/Edit Condition page.

b. Choose a condition type from the **Condition Type** drop-down list and configure its associated **Trigger If** parameters (**Table 12-9**).

**Table 12-9**  **Condition Type/Trigger If Parameters**

<table>
<thead>
<tr>
<th>Condition Type</th>
<th>Trigger If</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Missing</strong></td>
<td>Missing for Time (mins)—Enter the number of minutes after which a missing asset event is generated.</td>
</tr>
<tr>
<td></td>
<td>For example, if you enter 10 in this text box, the mobility services engine generates a missing asset event if the mobility services engine has not located the asset for more than 10 minutes.</td>
</tr>
<tr>
<td><strong>In/Out</strong></td>
<td>Inside of or Outside of—Click <strong>Select Area</strong> and choose the area parameters from the Select page. Click <strong>Select</strong>. The area to monitor could be an entire campus, building within a campus, a floor in a building, or a coverage area (you can define a coverage area using the map editor).</td>
</tr>
</tbody>
</table>
In the Apply To drop-down list, choose the type of asset (Any, Clients, Tags, Rogue APs, Rogue Clients or Interferers) for which an event is generated if the trigger condition is met.

**Note** Emergency and chokepoint events are only applicable to tags (CCXv.1 compliant).

d. From the Match By drop-down list, choose the matching criteria (MAC Address, Asset Name, Asset Group, or Asset Category), the operator (Equals or Like), and enter the relevant text for the selected Match By element.

e. Click **Add**.

**Step 10** In the Destination and Transport tab, follow these steps to add one or more destinations to receive event notifications and configure the transport settings:

a. Click **Add** to open the Add/Edit Destination and Transport page.

b. To add one or more new destinations, click **Add New**, enter the applicable IP address, and click **OK**.

**Note** The recipient system must have an event listener running to process notifications. By default, when you create an event definition, WCS adds its IP address as the destination.

c. To select a destination to receive notifications, click to highlight one or more IP addresses in the box on the right and click **Select** to add the IP address(es) to the box on the left.

d. In the Message Format field, select **XML** or **Plain Text**.

**Note** If you select WCS as the destination, you must select XML format.

e. Choose one of the following transport types from the Transport Type drop-down list:

<table>
<thead>
<tr>
<th>Condition Type</th>
<th>Trigger If</th>
</tr>
</thead>
<tbody>
<tr>
<td>Distance</td>
<td>At the distance of ( x ) (feet) from Marker—Enter the the distance in feet that will trigger an event notification if the monitored asset moves beyond the specified distance from a designated marker. Click <strong>Select Marker</strong> and choose the marker parameters in the Select page. Click <strong>Select</strong>.</td>
</tr>
<tr>
<td>Battery Level</td>
<td>Battery Level Is—Low, Medium, Normal. Select the appropriate battery level that will trigger an event.</td>
</tr>
<tr>
<td>Location Change</td>
<td>An event is triggered if the location of the asset changes.</td>
</tr>
<tr>
<td>Emergency</td>
<td>Select <strong>Any</strong>, <strong>Panic Button</strong>, <strong>Tampered</strong>, or <strong>Detached</strong></td>
</tr>
<tr>
<td>Chokepoint</td>
<td>In the range of Chokepoints—Click <strong>Select Chokepoint</strong> and choose the chokepoint parameters in the Select page. Click <strong>Select</strong>.</td>
</tr>
</tbody>
</table>
- **SOAP**—Simple Object Access Protocol. Use SOAP to send notifications over HTTP/HTTPS and to be processed by web services on the destination.

  Specify whether to send notifications over HTTPS by selecting its corresponding check box. Enter the destination port number in the Port Number text box.

- **Mail**—Use this option to send notifications via email.

  Choose the protocol for sending the mail from the Mail Type drop-down list. Enter the following: username and password (if Authentication is enabled), name of the sender, prefix to add to the subject line, email address of recipient, and a port number if necessary.

- **SNMP**—Simple Network Management Protocol. Use this option to send notifications to SNMP-capable devices.

  If you have selected SNMP version v2c then you would be prompted to enter the SNMP community string in the SNMP Community text box and the applicable port number in the Port Number textbox.

  If you have selected SNMP version v3 then you would be prompted to enter the username, security name, select the authentication type from the drop-down list, enter the authentication password, select the privacy type from the drop-down list and enter the privacy password.

- **SysLog**—Specifies the system log on the destination system as the recipient of event notifications.

  Enter the notification priority in the Priority text box, the name of the facility, and the port number on the destination system.

1. Click **Add**.

   **Step 11** Verify that the new event definition is listed for the event group (Context Aware Service > Notifications > Event > Settings > Event Group Name).

---

### Adding Event Definitions

An event definition contains information about the condition that caused the event, the assets to which the event applies, and the event notification destination.

Cisco WCS enables you to add definitions for each group. An event definition must belong to a group. See the *Cisco Content-Aware Software Configuration Guide* for information on deleting or testing event definitions.

To add an event definition, follow these steps:

**Step 1** Choose **Services > Context Aware Notifications**.

**Step 2** Click **Notification Definitions** from the left sidebar menu.

**Step 3** Click the name of the group to which you want to add to the event. An event definition summary page appears for the selected event group.

**Step 4** From the Select a command drop-down list, choose **Add Event Definition**, and click **Go**.

**Step 5** At the Conditions tab, add one or more conditions. For each condition you add, specify the rules for triggering event notifications.
For example, to keep track of heart monitors in a hospital, you could add rules to generate event notifications when a heart monitor is missing for one hour, a heart monitor moves off its assigned floor, or a heart monitor enters a specific coverage area within a floor.

To add a condition, follow these steps:

1. Click **Add** to add a condition that triggers this event.
2. In the Add/Edit Condition dialog box, follow these steps:
   - **Choose a condition type from the Condition Type drop-down list.**
     - If you chose Missing from the Condition Type drop-down list, enter the number of minutes after which a missing asset generates a notification. For example, if you enter 10 in this text box, the mobility services engine generates a missing asset notification if the mobility services engine has not located the asset for more than 10 minutes after the devices have become inactive or is no longer in the system. This condition occurs when the controller detects its absence and informs mobility services engine about it or if the mobility services engine does not hear anything about this device from the controller for 60 minutes by default. This value is only configurable from the MSE CLI (accessible using cmdshell on the console) using command `config mobile-node-inactive-in-minutes` for clients and `config tag-inactive-time-in-minutes` for tags. Proceed to Step e.
     - If you chose In/Out from the Condition Type drop-down list, select **Inside of** or **Outside of**, then select **Select Area** to select the area to monitor for assets going into it or out of it. In the Select dialog box, choose the area to monitor, then click **Select**. The area to monitor could be an entire campus, building within a campus, a floor in a building, or a coverage area (you can define a coverage area using the map editor). For example, to monitor part of a floor in a building, choose a campus from the Campus drop-down list, choose a building from the Building drop-down list, and choose the area to monitor from the Floor Area drop-down list. Then click **Select**. Proceed to Step e.
     - If you chose Distance from the Condition Type drop-down list, enter the distance in feet that will trigger an event notification if the monitored asset moves beyond the specified distance from a designated marker, then click **Select Marker**. In the Select dialog box, select the campus, building, floor, and marker from the corresponding drop-down list and click **Select**. For example, if you add a marker to a floor plan and set the distance in the Trigger If text box to 60 feet, an event notification will be generated if the monitored asset moves more than 60 feet away from the marker. Proceed to Step e.
     - If you chose Battery Level from the Condition Type drop-down list, select the check box next to the battery level (low, medium, normal) that will trigger an event. Proceed to Step e.
     - If you chose Location Change from the Condition Type drop-down list, proceed to Step e.
     - If you chose Emergency from the Condition Type drop-down list, click the button next to the emergency (any, panic button, tampered, detached) that will trigger an event. Proceed to Step e.
     - If you chose Chokepoint from the Condition Type drop-down list, proceed to Step e. There is only one trigger condition, and it is displayed by default. No configuration is required.
   - In the **Trigger If** text box, specify the time in minutes to trigger the notification. Default is 60 minutes.

---

Tip
---

For example, to keep track of heart monitors in a hospital, you could add rules to generate event notifications when a heart monitor is missing for one hour, a heart monitor moves off its assigned floor, or a heart monitor enters a specific coverage area within a floor.

To add a condition, follow these steps:

1. Click **Add** to add a condition that triggers this event.
2. In the Add/Edit Condition dialog box, follow these steps:
   - **Choose a condition type from the Condition Type drop-down list.**
     - If you chose Missing from the Condition Type drop-down list, enter the number of minutes after which a missing asset generates a notification. For example, if you enter 10 in this text box, the mobility services engine generates a missing asset notification if the mobility services engine has not located the asset for more than 10 minutes after the devices have become inactive or is no longer in the system. This condition occurs when the controller detects its absence and informs mobility services engine about it or if the mobility services engine does not hear anything about this device from the controller for 60 minutes by default. This value is only configurable from the MSE CLI (accessible using cmdshell on the console) using command `config mobile-node-inactive-in-minutes` for clients and `config tag-inactive-time-in-minutes` for tags. Proceed to Step e.
     - If you chose In/Out from the Condition Type drop-down list, select **Inside of** or **Outside of**, then select **Select Area** to select the area to monitor for assets going into it or out of it. In the Select dialog box, choose the area to monitor, then click **Select**. The area to monitor could be an entire campus, building within a campus, a floor in a building, or a coverage area (you can define a coverage area using the map editor). For example, to monitor part of a floor in a building, choose a campus from the Campus drop-down list, choose a building from the Building drop-down list, and choose the area to monitor from the Floor Area drop-down list. Then click **Select**. Proceed to Step e.
     - If you chose Distance from the Condition Type drop-down list, enter the distance in feet that will trigger an event notification if the monitored asset moves beyond the specified distance from a designated marker, then click **Select Marker**. In the Select dialog box, select the campus, building, floor, and marker from the corresponding drop-down list and click **Select**. For example, if you add a marker to a floor plan and set the distance in the Trigger If text box to 60 feet, an event notification will be generated if the monitored asset moves more than 60 feet away from the marker. Proceed to Step e.
     - If you chose Battery Level from the Condition Type drop-down list, select the check box next to the battery level (low, medium, normal) that will trigger an event. Proceed to Step e.
     - If you chose Location Change from the Condition Type drop-down list, proceed to Step e.
     - If you chose Emergency from the Condition Type drop-down list, click the button next to the emergency (any, panic button, tampered, detached) that will trigger an event. Proceed to Step e.
     - If you chose Chokepoint from the Condition Type drop-down list, proceed to Step e. There is only one trigger condition, and it is displayed by default. No configuration is required.
   - In the **Trigger If** text box, specify the time in minutes to trigger the notification. Default is 60 minutes.
d. In the Notification frequency radio option, select either Recurring or Non-recurring. If the frequency is non-recurring the MSE will send absence notification only once. For recurring frequency the MSE sends an absence notification periodically till the device becomes present again. Here period refers to the configured value in the absence definition.

e. From the Apply To drop-down list, choose the type of asset (Any, Clients, Tags, Rogue APs, Rogue Clients, or Interferers) for which an event will be generated if the trigger condition is met.

---

**Note** If you select the any option from the Apply to drop-down list, the battery condition is applied to all tags, clients, and rogue access points and rogue clients.

**Note** Emergency and chokepoint events apply only to Cisco compatible extension tags version 1 (or later).

f. From the Match By drop-down list, choose the matching criteria (MAC Address, Asset Name, Asset Group, or Asset Category), the operator (Equals or Like) from the drop-down list, and enter the relevant text for the selected Match By element.

Some examples of asset matching criteria that you can specify:

- If you choose MAC Address from the Match By drop-down list, choose Equals from the Operator drop-down list, and enter a MAC address (for example 12:12:12:12:12:12), the event condition applies to the element whose MAC address is 12:12:12:12:12:12 (exact match).

- If you choose MAC Address from the Match By drop-down, choose Like from the Operator drop-down list, and enter 12:12, the event condition applies to elements whose MAC address starts with 12:12.

g. Click Add to add the condition you have just defined.

---

**Note** If you are defining a chokepoint, you must select the chokepoint after you add the condition.

To select a chokepoint, do the following:

1. Click Select Chokepoint. An entry page appears.

2. Select Campus, Building, and Floor from the appropriate drop-down lists.

3. Select a Chokepoint from the menu that appears.

You are returned to the Add/Edit Condition page, and the location path (Campus > Building > Floor) for the chokepoint auto-populates the field next to the Select Checkpoint button.

---

**Step 6** At the Destination and Transport tab, follow these steps to add one or more destinations to receive event notifications and to configure the transport settings:

a. To add a new destination, click Add. The Add/Edit Destination configuration page appears.

b. Click Add New.

c. Enter the IP address of the system that will receive event notifications, and click OK.

   The recipient system must have an event listener running to process notifications. By default, when you create an event definition, Cisco WCS adds its IP address as the destination.

d. To select a destination to send event notifications to, highlight one or more IP addresses in the box on the right, and click Select to add the IP addresses to the box on the left.

e. Select XML or Plain Text to specify the message format.
f. Choose one of the following transport types from the Transport Type drop-down list:
   - SOAP—Simple Object Access Protocol. Use SOAP to send notifications over HTTP/HTTPS and to be processed by web services on the destination.
     Specify whether to send notifications over HTTPS by selecting its corresponding check box. Enter the destination port number in the Port Number text box.
   - Mail—Use this option to send notifications via email.
     Choose the protocol for sending the mail from the Mail Type drop-down list. Enter the following: username and password (if Authentication is enabled), name of the sender, prefix to add to the subject line, email address of recipient, and a port number if necessary.
   - SNMP—Simple Network Management Protocol. Use this option to send notifications to SNMP-capable devices.
     If you have selected SNMP version v2c then you would be prompted to enter the SNMP community string in the SNMP Community text box and the applicable port number in the Port Number textbox.
     If you have selected SNMP version v3 then you would be prompted to enter the username, security name, select the authentication type from the drop-down list, enter the authentication password, select the privacy type from the drop-down list and enter the privacy password.
   - SysLog—Specifies the system log on the destination system as the recipient of event notifications.
     - Enter the notification priority in the Priority text box, the name of the facility, and the port number on the destination system.

   g. Click **Save**.

**Step 7**

At the General tab, follow these steps:

a. Select the **Enabled** check box for Admin Status to enable event generation (disabled by default).

b. Set the event priority by choosing a number from the Priority drop-down list. Zero is the highest priority.

   **Note**

   An event notification with high priority is serviced before event definitions with lower priority.

c. To select how often the event notifications are sent:
   1. Select the **All the Time** check box to continuously report events. Proceed to Step g.
   2. Unselect the **All the Time** check box to select the day and time of the week that you want event notifications sent. Days of the week and time fields appear for the selection. Proceed to Step d.

d. Select the check box next to each day you want the event notifications sent.

e. Select the time for starting the event notification by selecting the appropriate hour, minute, and AM/PM options from the Apply From heading.

f. Select the time for ending the event notification by selecting the appropriate hour, minute, and AM/PM options from the Apply Until heading.

g. Click **Save**.

**Step 8**

Verify that the new event notification is listed for the event group (Mobility > Notifications > Settings > Event Group Name).
Deleting an Event Definition

To delete one or more event definitions from WCS, follow these steps:

Step 1 Choose Services > Context Aware Notifications.
Step 2 From the left sidebar menu, choose Settings.
Step 3 Click the name of the group from which you want to delete the event definitions.
Step 4 Select the event definition that you want to delete by selecting its corresponding check box.
Step 5 From the Select a command drop-down list, choose Delete Event Definition(s).
Step 6 Click Go.
Step 7 Click OK to confirm that you want to delete the selected event definitions.

Upgrading from 5.x to 6.0 or 7.0

⚠️ Caution
The number of supported clients, tags, and access points (wIPS) is reset to 100 clients, 100 tags, and 20 access points when you upgrade to release 6.0 or above. All tracking beyond these limits is lost. These limits correspond to the 60 day evaluation licenses that are standard.

⚠️ Caution
When upgrading mobility services engine from 6.0 to 7.0, if any limits have been set on wireless clients or rogues, they will get reset because of the wired client limit change in 7.0.

⚠️ Caution
You must backup the mobility services engine database before upgrading from release 5.x1 or 6.0 to 7.0 to preserve client, tag, and access point configurations. You can restore the database after the software upgrade.

>Note
Release 5.1 did not support licenses. You must order, register, and install licenses to track client and tag locations (CA) or access points (wIPS) beyond the limits of the 60-day evaluation licenses.

To upgrade to release 7.0, follow these steps:

Step 1 Register the Product Authorization Key (PAK).

>Note
You receive a PAK when you order a license. If you have lost your PAK, you can use your sales order or the UDI number of the mobility services engine to register.

- Client and wIPS licenses are registered at:
  https://tools.cisco.com/SWIFT/Licensing/PrivateRegistrationServlet
- Tag licenses are registered at the Aeroscout website:
Step 2  Backup the mobility services engine database:
   a. Choose Services > Mobility Services.
   b. Click the name of the mobility services engine on which you want to backup the database.
   c. Choose Maintenance > Backup from under the System menu (left).
   d. Enter a name for the backup file. Click Submit.

Step 3  Download release 7.0:
   a. Choose Services > Mobility Services.
   b. Click the name of the mobility services engine on which you want to upgrade the software.
   c. Choose Maintenance > Download Software from under the System menu.
   d. Select either an uploaded image or browse and upload an image. Click Download.

Step 4  Install release 7.0 using the MSE CLI:
   a. To overwrite existing software, enter:
      /etc/init.d/msed stop
      cd opt/installers
      ./<mse software file name>
   b. To do a fresh install, enter:
      /etc/init.d/msed stop
      cd /opt/mes/uninstall
      ./uninstall (enter this once in directory)
      (Enter no when prompted to keep old database)
      cd /opt/installers
      ./<mse software file name>

Step 5  Restore mobility services engine database (For Step 4 b.):
   a. Choose Services > Mobility Services.
   b. Click the name of the mobility services engine on which you upgraded the software.
   c. Choose Maintenance > Restore from under the System menu.
   d. Select file name to restore from the drop-down list. Click Submit.

Step 6  Install licenses:
Refer to Chapter 2 of the ContextAware Services Configuration Guide Release 7.0 at

Viewing the MSE Alarm Details

In the Monitor > Alarms page, click an MSE item under Failure Source to access the alarms details for a particular MSE.
Alternatively, you can access the Services > Mobility Services > MSE Name > System > Status > WCS Alarms page and click a particular MSE item under Failure Source to access the alarms details for a particular MSE.

Figure 12-2 shows a WCS alarm for MSE.

![Figure 12-2 MSE Alarm](image)

Table 12-10 lists and displays the various fields in the Alarm Detail page for a MSE.

**Table 12-10 General Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Failure Source</td>
<td>The MSE that generated the alarm.</td>
</tr>
<tr>
<td>Owner</td>
<td>Name of person to which this alarm is assigned, or blank.</td>
</tr>
<tr>
<td>Acknowledged</td>
<td>Displays whether or not the alarm is acknowledged by the user.</td>
</tr>
<tr>
<td>Category</td>
<td>The category of the alarm. The Alarm category is Mobility Services for MSEs.</td>
</tr>
<tr>
<td>Created</td>
<td>Month, day, year, hour, minute, second, AM or PM alarm created.</td>
</tr>
<tr>
<td>Modified</td>
<td>Month, day, year, hour, minute, second, AM or PM alarm last modified.</td>
</tr>
<tr>
<td>Generated By</td>
<td>This field will display MSE.</td>
</tr>
<tr>
<td>Severity</td>
<td>Level of security: Critical, Major, Minor, Warning, Clear, Info, Color coded.</td>
</tr>
</tbody>
</table>

**Note**

The General information may vary depending on the type of alarm. For example, some alarm details may include location and switch port tracing information.

- Annotations—Enter any new notes in this text box and click **Add** to update the alarm. Notes appear in the “Annotations” display area.
• Messages—Displays information about the alarm.

• Audit Report—Click to view config audit alarm details. This report is only available for Config Audit alarms.

Configuration audit alarms are generated when audit discrepancies are enforced on config groups.

Note: If enforcement fails, a critical alarm is generated on the config group. If enforcement succeeds, a minor alarm is generated on the config group.

The alarms have links to the audit report where you can view a list of discrepancies for each controller.

• Event History—Opens you to the MSE Alarm Events page to view events for this alarm. When there are multiple alarm pages, the page numbers appear at the top of the page with a scroll arrow on each side. Use these scroll arrows to view additional alarms.

Select a Command

The Select a command drop-down list provides access to the following functions:

• Assign to me—Assign the selected alarm(s) to the current user.

• Unassign—Unassign the selected alarm(s).

• Delete—Delete the selected alarm(s).

• Clear—Clear the selected alarm(s). Indicates that the alarm is no longer detected by any access point.

Note: Once the severity is Clear, the alarm is deleted from WCS after 30 days.

• Acknowledge—You can acknowledge the alarm to prevent it from showing up in the Alarm Summary page. The alarm remains in WCS and you can search for all Acknowledged alarms using the alarm search functionality. See the “Acknowledging Alarms” section on page 6-121 for more information.

• Unacknowledge—You can choose to unacknowledge an already acknowledged alarm.

• Email Notification—Takes you to the All Alarms > Email Notification page to view and configure email notifications. See the “Monitoring Email Notifications” section on page 6-116 for more information.

• Event History—Takes you to the Monitor > Events page to view events for this alarm. See the “Monitoring Events” section on page 6-124 for more information.

For more information on Alarms, see the “Monitoring Alarms” section on page 6-80.

Overview of MSE License

The MSE packages together multiple product features related to network topology, design such as NMSP, Network Repository along with related Service Engines and application processes, such as:

• Location Service

• Wireless Intrusion Prevention Service (wIPS)
To enable smooth management of MSE and its services, various licenses are offered. This section contains the following topics:

- **MSE License Structure Matrix, page 12-72**
- **Sample MSE License File, page 12-72**
- **Revoking and Reusing an MSE License, page 12-72**

### MSE License Structure Matrix

Table 12-14 lists the breakup of the licenses between the High end, Low end and Evaluation licenses for MSE, Location services, and wIPS.

### Sample MSE License File

The following is a sample MSE license file:

```plaintext
FEATURE MSE cisco 1.0 permanent uncounted \ 
   VENDOR_STRING=UDI=udi,COUNT=1 \ 
   HOSTID=ANY \ 
   NOTICE="<LicFileID>MSELicense</LicFileID><LicLineID>0</LicLineID> \ 
       <PAK>dummyPak</PAK>" \ 
   SIGN="0C04 1EBA BE34 F208 404F 98ED 43EC \ 
       45D7 F881 08F6 7FA5 4DED 43BC AF5C C359 0444 36B2 45CF 6EA6 \ 
       1DB1 899F 413F F543 F426 B055 4C7A D95D 2139 191F 04DE"
```

This sample file has 5 license entries. The first word of the first line of any license entry tells you what type of license it is. It could either be a Feature or Increment. A feature license is a static, lone-item license. There can be multiple Service Engines running in MSE. An Increment license is an additive license. In MSE, the individual Service Engines are treated as increment licenses.

The second word of the first line defines the specific component to be licensed. Example: MSE, LOCATION_TAG. The third word depicts the vendor of the license, example: Cisco. The fourth word denotes the version of the license, example 1.0. The fifth word denotes the expiration date, this could be permanent for licenses that never expire or a date in the format dd-mmm-yyyy. The last word defines whether this license is counted.

For more information on the license types, see the “Mobility Services Engine (MSE) License Information” section on page 16-12.

### Revoking and Reusing an MSE License

You can revoke an MSE appliance license from one system and reuse it on another system. When you revoke a license, the license file is deleted from the system. If you want to reuse the license on another system, then the license needs to be rehosted.

If you want to reuse a license with an upgrade SKU on another system, then you need to have the corresponding base license SKU installed in the system to which you want to reuse the upgrade SKU. You cannot reuse the upgrade license SKU in a system if the corresponding base license SKU is deleted from it.

When you revoke a license, MSE restarts the individual service engines to reflect the changes to the licenses. Then the service engines receives the updated capacity from MSE during startup.
Information About Mobility Services

For more information on Licensing, see the following sections:

- WCS License Information, page 16-8
- Mobility Services Engine (MSE) License Information, page 16-12
- Mobility Services Engine (MSE) License Summary, page 16-14

Location Assisted Client Troubleshooting from the ContextAware Dashboard

You can use the ContextAware tab in the WCS Home Page to troubleshoot a client. You can specify a MAC address or Username or IP address as the search criteria, and click Troubleshoot.

Note

Username, IP Address, and partial MAC address-based troubleshooting is supported only on MSEs with version 7.0.200.0 and above.

The Troubleshoot Client page appears.

You can view the Context Aware History report in the Context Aware History tab. You can filter this report based on MSE Name. You can further filter the report based on Timezone, State or All. The states can be either associated or dissociated.

If you select timezone then you could select any of the following:

- Date and Time

Or

- Any one of these values from the drop-down list:
  - Last 1 Hour
  - Last 6 Hours
  - Last 1 Day
  - Last 2 Days
  - Last 3 Days
  - Last 4 Days
  - Last 5 Days
  - Last 6 Days
  - Last 7 Days
  - Last 2 Weeks
  - Last 4 Weeks
Alternately, you can use the Generate Report link to generate a Client Location History report. You could also opt to export to CSV or PDF format or email the report using the icons available in the report page. For more information on the ContextAware tab of the WCS Home Page, see the “ContextAware Tab” section on page 2-22.

**MSE Reports**

You can generate many ContextAware reports using the Report Launch Pad. For more information on ContextAware reports, see the “ContextAware Reports” section on page 15-57.

**Planning for and Configuring Context-Aware Software**

Context-Aware Software (CAS) resides on the mobility services engine. For more information on the CAS service, refer to the *Cisco Context-Aware Software Configuration Guide*.

---

**Note**

If you have a location server, you can track or map non-Cisco CX tags.

**Note**

Context-Aware Software was previously referred to as *Cisco location-based services*.

---

Chapter 4 of the *Cisco Context-Aware Software Configuration Guide* contains the following information on configuring and viewing system properties on the mobility services engine:

- Configuring general properties
- Modifying NMSP parameters
- Viewing active sessions on a system
- Adding and deleting trap destinations
- Viewing and configuring advanced parameters

Chapter 5 of the *Cisco Context-Aware Software Configuration Guide* contains information on configuring and managing users and groups on the mobility services engine.

Chapter 6 of the *Cisco Context-Aware Software Configuration Guide* contains the following information on event notifications:

- Adding and deleting event groups
- Adding, deleting, and testing event definitions
- Viewing event notification summary
- Notifications cleared
- Notification message formats

Chapter 7 of the *Cisco Context-Aware Software Configuration Guide* contains the following information on the tools and configurations that can be used to enhance the location accuracy of elements (clients, tags, rogue clients, interferers and rogue access points):

- Planning for data, voice, and location deployment
- Creating and applying calibration models
- Inspecting location readiness and quality
• Inspecting location quality using calibration data
• Verifying location accuracy
• Using chokepoints to enhance tag location reporting
• Using Wi-Fi TDOA receiver to enhance tag location reporting
• Using tracking optimized monitor mode to enhance tag location reporting
• Defining inclusion and exclusion regions on a floor
• Defining a rail line on a floor
• Modifying context aware software parameters
• Enabling Location Services on Wired Switches and Wired Clients.
• Assigning a Catalyst Switch to Mobility Services Engine and Synchronizing

Chapter 8 of the *Cisco Context-Aware Software Configuration Guide* contains the following information on how to monitor the mobility services engine by configuring and viewing alarms, events, and logs and how to generate reports on system utilization and element counts:

• Working with alarms
• Working with events
• Working with logs
• Generating reports
• Monitoring wireless clients
• Monitoring tagged assets
• Monitoring chokepoints
• Monitoring Wi-Fi TDOA receivers
• Monitoring Wired Switches
• Monitoring Wired Clients
• Monitoring Interferers

Chapter 9 of the *Cisco Context-Aware Software Configuration Guide* contains the following information on backing up and restoring mobility services engine data and updating the mobility services engine software:

• Recovering a lost password
• Recovering a lost root password
• Backing up and restoring mobility services engine data
• Downloading software to mobility services engines
• Configuring the NTP server
• Rebooting the mobility services engine hardware
• Shutting down the mobility services engine hardware
• Clearing mobility services engine configurations
**wIPS Planning and Configuring**

With a fully integrated solution, Cisco can continually monitor wireless traffic on both the wired and wireless networks and can use that network intelligence to analyze attacks from many different sources of information to more accurately pinpoint and proactively prevent attacks versus waiting until damage or exposure has occurred. See *Cisco Adaptive Wireless IPS* documentation for the following information:

- WCS and wIPS integration overview
- Mobility services engines
- wIPS profiles
- Configuring SSID group list
- Viewing wIPS alarms
- Viewing wIPS events
- Configuring access points and access point templates
- Policy alarm encyclopedia
- WCS security vulnerability assessment
- Rogue management
- Radio resource management
Configuring Hybrid REAP

This chapter describes hybrid REAP and explains how to configure this feature on controllers and access points. It contains the following sections:

- Information About Hybrid REAP, page 13-1
- Configuring Hybrid REAP, page 13-4
- Hybrid REAP Access Point Groups, page 13-12

Information About Hybrid REAP

*Hybrid REAP* is a solution for branch office and remote office deployments. It enables customers to configure and control access points in a branch or remote office from the corporate office through a wide area network (WAN) link without deploying a controller in each office. There is no deployment restriction on the number of hybrid-REAP access points per location. The hybrid-REAP access points can switch client data traffic locally and perform client authentication locally when their connection to the controller is lost. When they are connected to the controller, they can also send traffic back to the controller.

Hybrid REAP is supported only on the 1130AG, 1240AG, 1142 and 1252 access points and on the 2000 and 4400 series controllers, the Catalyst 3750G Integrated Wireless LAN Controller Switch, the Cisco WiSM, and the Controller Network Module for Integrated Services Routers, and the controller within the Catalyst 3750G Integrated Wireless LAN Controller Switch. Figure 13-1 illustrates a typical hybrid-REAP deployment.
Hybrid-REAP Authentication Process

When a hybrid-REAP access point boots up, it looks for a controller. If it finds one, it joins the controller, downloads the latest software image from the controller and configuration information, and initializes the radio. It saves the downloaded configuration in non-volatile memory for use in standalone mode.

A hybrid-REAP access point can learn the controller IP address in one of these ways:

- If the access point has been assigned an IP address from a DHCP server, it discovers a controller through the regular CAPWAP discovery process [Layer 3 broadcast, over-the-air provisioning (OTAP), DNS, or DHCP option 43.]

  **Note** OTAP does not work on the first boot out of the box.

- If the access point has been assigned a static IP address, it can discover a controller through any of the CAPWAP discovery process methods except DHCP option 43. If the access point cannot discover a controller through Layer 3 broadcast or OTAP, we recommend DNS resolution. With DNS, any access point with a static IP address that knows of a DNS server can find at least one controller.

- If you want the access point to discover a controller from a remote network where CAPWAP discovery mechanisms are not available, you can use priming. This method enables you to specify (through the access point CLI) the controller to which the access point is to connect.

When a hybrid-REAP access point can reach the controller (referred to as **connected mode**), the controller assists in client authentication. When a hybrid-REAP access point cannot access the controller, the access point enters standalone mode and authenticates clients by itself.

**Note** The LEDs on the access point change as the device enters different hybrid-REAP modes. See the Hardware Installation Guide for your access point for information on LED patterns.
When a client associates to a hybrid-REAP access point, the access point sends all authentication messages to the controller and either switches the client data packets locally (locally switched) or sends them to the controller (centrally switched), depending on the WLAN configuration. With respect to client authentication (open, shared, EAP, web authentication, and NAC) and data packets, the WLAN can be in any one of the following states depending on the configuration and state of controller connectivity:

- **central authentication, central switching**—In this state, the controller handles client authentication, and all client data tunnels back to the controller. This state is valid only in connected mode.

- **central authentication, local switching**—In this state, the controller handles client authentication, and the hybrid-REAP access point switches data packets locally. After the client authenticates successfully, the controller sends a configuration command with a new payload to instruct the hybrid-REAP access point to start switching data packets locally. This message is sent per client. This state is applicable only in connected mode.

- **local authentication, local switching**—In this state, the hybrid-REAP access point handles client authentication and switches client data packets locally. This state is valid in standalone mode and connected mode.

  Local authentication is useful where you cannot maintain the criteria a remote office setup of minimum bandwidth of 128 kbps with the roundtrip latency no greater than 100 ms and the maximum transmission unit (MTU) no smaller than 500 bytes. In local switching, the authentication capabilities are present in the access point itself. Thus local authentication reduces the latency requirements of the branch office.

**Note**

Local authentication can only be enabled on the WLAN of a HREAP AP that is in local switching mode.

Local authentication is not supported in the following scenarios:
- Guest Authentication cannot be done on a HREAP local authentication enabled WLAN.
- RRM information is not available at the controller for the hybrid REAP local authentication enabled WLAN.
- Local radius is not supported.
- Once the client has been authenticated, roaming will only be supported after the WLC and the other hybrid REAPs in the group are updated with the client information.

- **authentication down, switching down**—In this state, the WLAN disassociates existing clients and stops sending beacon and probe responses. This state is valid only in standalone mode.

- **authentication down, local switching**—In this state, the WLAN rejects any new clients trying to authenticate, but it continues sending beacon and probe responses to keep existing clients alive. This state is valid only in standalone mode.

When a hybrid-REAP access point enters standalone mode, WLANs that are configured for open, shared, WPA-PSK, or WPA2-PSK authentication enter the “local authentication, local switching” state and continue new client authentications. Other WLANs enter either the “authentication down, switching down” state (if the WLAN was configured to central switching) or the “authentication down, local switching” state (if the WLAN was configured to local-switch).

When a hybrid-REAP access point enters standalone mode, it disassociates all clients that are on centrally switched WLANs. For 802.1X or web-authentication WLANs, existing clients are not disassociated, but the hybrid-REAP access point stops sending beacons when the number of associated clients reaches zero (0). It also sends disassociation messages to new clients associating to 802.1X or
web-authentication WLANs. Controller-dependent activities such as 802.1X authentication, NAC, and web authentication (guest access) are disabled, and the access point does not send any Intrusion Detection System (IDS) reports to the controller. Furthermore, most radio resource management (RRM) features (such as neighbor discovery; noise, interference, load, and coverage measurements; use of the neighbor list; and rogue containment and detection) are disabled. However, a hybrid-REAP access point supports dynamic frequency selection in standalone modes.

Note

If your controller is configured for Network Access Control (NAC), clients can associate only when the access point is in connected mode. When NAC is enabled, you need to create an unhealthy (or quarantined) VLAN so that the data traffic of any client that is assigned to this VLAN passes through the controller, even if the WLAN is configured for local switching. After a client is assigned to a quarantined VLAN, all of its data packets are centrally switched.

The hybrid-REAP access point maintains client connectivity even after entering standalone mode. However, once the access point re-establishes a connection with the controller, it disassociates all clients, applies new configuration information from the controller, and reallows client connectivity.

Hybrid REAP Guidelines

Keep these guidelines in mind when using hybrid REAP:

- A hybrid-REAP access point can be deployed with either a static IP address or a DHCP address. In the case of DHCP, a DHCP server must be available locally and must be able to provide the IP address for the access point at bootup.
- Hybrid REAP supports a 500-byte maximum transmission unit (MTU) WAN link at minimum.
- Roundtrip latency must not exceed 300 milliseconds (ms) between the access point and the controller, and CAPWAP control packets must be prioritized over all other traffic. In cases where you cannot achieve this, you can configure the access point to perform local authentication. See the “Hybrid-REAP Authentication Process” section on page 13-2 to know more about hybrid REAP local authentication using local authentication and local switching.
- The controller can send multicast packets in the form of unicast or multicast packets to the access point. In hybrid-REAP mode, the access point receives multicast packets only in unicast form.
- Hybrid REAP supports CCKM full authentication but not CCKM fast roaming.
- Hybrid REAP supports a 1-1 network address translation (NAT) configuration. It also supports port address translation (PAT) for all features except true multicast. Multicast is supported across NAT boundaries when configured using the Unicast option.
- VPN, IPSec, L2TP, PPTP, Fortress authentication, and Cranite authentication are supported for locally switched traffic, provided that these security types are accessible locally at the access point.

Configuring Hybrid REAP

To configure hybrid REAP, you must follow the instructions in these sections in the order provided:

- Configuring the Switch at the Remote Site, page 13-5
- Configuring the Controller for Hybrid REAP, page 13-6
- Configuring an Access Point for Hybrid REAP, page 13-9
Configuring the Switch at the Remote Site

To prepare the switch at the remote site, follow these steps:

- **Step 1** Attach the access point that will be enabled for hybrid REAP to a trunk or access port on the switch.

  Note: The sample configuration below shows the hybrid-REAP access point connected to a trunk port on the switch.

- **Step 2** See the sample configuration below to configure the switch to support the hybrid-REAP access point.

  In this sample configuration, the hybrid-REAP access point is connected to trunk interface FastEthernet 1/0/2 with native VLAN 100. The access point needs IP connectivity on the native VLAN. The remote site has local servers/resources on VLAN 101. A DHCP pool is created in the local switch for both VLANs in the switch. The first DHCP pool (NATIVE) is used by the hybrid-REAP access point, and the second DHCP pool (LOCAL-SWITCH) is used by the clients when they associate to a WLAN that is locally switched. The bolded text in the sample configuration illustrates these settings.

  Note: The addresses in this sample configuration are for illustration purposes only. The addresses that you use must fit into your upstream network.

```plaintext
ip dhcp pool NATIVE
   network 10.10.100.0 255.255.255.0
   default-router 10.10.100.1
!
ip dhcp pool LOCAL-SWITCH
   network 10.10.101.0 255.255.255.0
   default-router 10.10.101.1
!
interface FastEthernet1/0/1
   description Uplink port
   no switchport
   ip address 10.10.98.2 255.255.255.0
   spanning-tree portfast
!
interface FastEthernet1/0/2
   description the Access Point port
   switchport trunk encapsulation dot1q
   switchport trunk native vlan 100
   switchport trunk allowed vlan 100,101
   switchport mode trunk
   spanning-tree portfast
!
interface Vlan100
   ip address 10.10.100.1 255.255.255.0
   ip helper-address 10.10.100.1
!
interface Vlan101
   ip address 10.10.101.1 255.255.255.0
   ip helper-address 10.10.101.1
end
```
Configuring the Controller for Hybrid REAP

This section provides instructions for configuring the controller for hybrid REAP. The controller configuration for hybrid REAP consists of creating centrally switched and locally switched WLANs. This procedure uses these three WLANs as examples:

<table>
<thead>
<tr>
<th>WLAN</th>
<th>Security</th>
<th>Switching</th>
<th>Interface Mapping (VLAN)</th>
</tr>
</thead>
<tbody>
<tr>
<td>employee</td>
<td>WPA1+WPA2</td>
<td>Central</td>
<td>management (centrally switched VLAN)</td>
</tr>
<tr>
<td>employee-local</td>
<td>WPA1+WPA2</td>
<td>Local</td>
<td>101 (local switched VLAN)</td>
</tr>
<tr>
<td>guest-central</td>
<td>Web authentication</td>
<td>Central</td>
<td>management (centrally switched VLAN)</td>
</tr>
</tbody>
</table>

**Step 1** to create a centrally switched WLAN, follow these steps. In our example, this is the first WLAN (employee).

a. Choose **Configure > Controllers**.

b. Click in the IP Address column for a particular controller.

c. Click **WLANs > WLAN Configuration** to access the WLAN Configuration page.

d. Choose **Add a WLAN** from the Select a command drop-down list, and click **Go** (see Figure 13-2).

**Note** Cisco access points can support up to 16 WLANs per controller. However, some Cisco access points do not support WLANs that have a WLAN ID greater than 8. In such cases, when you attempt to create a WLAN, you get a message that says “Not all types of AP support WLAN ID greater than 8, do you wish to continue?”. Clicking OK creates a WLAN with the next available WLAN ID. However, if you delete a WLAN that has a WLAN ID less than 8, then the WLAN ID of the deleted WLAN is applied to the next created WLAN.
Figure 13-2  WLANs > New Page

If you want to apply a template to this controller, choose a template name from the drop-down list. The parameters populate according to how the template is set. If you want to create a new WLAN template, use the click here link to be redirected to the template creation page (see the “Configuring WLAN Templates” section on page 11-22).

Modify the configuration parameters for this WLAN. In our employee WLAN example, you would need to choose **WPA1+WPA2** from the Layer 2 Security drop-down list.

Be sure to enable this WLAN by selecting the **Status** check box under General Policies.

**Note**  
If NAC is enabled and you created a quarantined VLAN for use with this, make sure to select it from the Interface drop-down list under General Policies. Also, select the **Allow AAA Override** check box to ensure that the controller validates a quarantine VLAN assignment.

Click **Save** to commit your changes.
Step 2  Follow these steps to create a locally switched WLAN. In our example, this is the second WLAN (employee-local).

a. Follow the substeps in Step 1 to create a new WLAN. In our example, this WLAN is named “employee-local.”

b. Click a WLAN ID from the original WLAN page to move to a WLANs edit page. Modify the configuration parameters for this WLAN. In our employee WLAN example, you would need to choose WPA1+WPA2 from the Layer 2 Security drop-down box. Make sure to choose PSK authentication key management and enter a pre-shared key.

Note  Make sure to enable this WLAN by selecting the Admin Status check box under General Policies. Also, make sure to enable local switching by selecting the H-REAP Local Switching check box. When you enable local switching, any hybrid-REAP access point that advertises this WLAN is able to locally switch data packets (instead of tunneling them to the controller).

Note  For hybrid-REAP access points, the interface mapping at the controller for WLANs configured for H-REAP Local Switching is inherited at the access point as the default VLAN tagging. This can be easily changed per SSID and per hybrid-REAP access point. Non-hybrid-REAP access points tunnel all traffic back to the controller, and VLAN tagging is dictated by each WLAN’s interface mapping.

c. Click Save to commit your changes.

Step 3  Follow these steps if you also want to create a centrally switched WLAN that is used for guest access. In our example, this is the third WLAN (guest-central). You might want to tunnel guest traffic to the controller so you can exercise your corporate data policies for unprotected guest traffic from a central site.

a. Follow the substeps in Step 1 to create a new WLAN. In our example, this WLAN is named “guest-central.”

b. In the WLANs Edit page, modify the configuration parameters for this WLAN. In our employee WLAN example, you would need to choose None from both the Layer 2 Security and Layer 3 Security drop-down boxes from the Security tab, select the Web Policy check box, and make sure Authentication is selected.

Note  If you are using an external web server, you must configure a preauthentication access control list (ACL) on the WLAN for the server and then choose this ACL as the WLAN preauthentication ACL.

c. Make sure to enable this by selecting the Status check box under General Policies.

d. Click Save to commit your changes.

e. If you want to customize the content and appearance of the login page that guest users see the first time they access this, follow the instructions in the “Configuring a Web Authentication Template” section on page 11-73.

f. To add a local user to this WLAN, choose Configure > Controller Template Launch Pad.

g. Choose Security > Local Net Users from the left sidebar menu.

h. When the Local Net Users page appears, choose Add Template from the Select a command drop-down list, and click Go.
i. Unselect the Import from File check box.

j. Enter a username and password for the local user.

k. From the Profile drop-down list, choose the appropriate SSID.

l. Enter a description of the guest user account.

m. Click Save.

**Step 4** Go to the “Configuring an Access Point for Hybrid REAP” section on page 13-9 to configure two or three access points for hybrid REAP.

---

### Configuring an Access Point for Hybrid REAP

This section provides instructions for configuring an access point for hybrid REAP.

Follow these steps to configure an access point for hybrid REAP.

**Step 1** Make sure that the access point has been physically added to your network.

**Step 2** Choose **Configure > Access Points**.

**Step 3** Choose which access point you want to configure for hybrid REAP by clicking one from the AP Name list. The detailed access point page appears (see Figure 13-3).
Chapter 13 Configuring Hybrid REAP

Configuring Hybrid REAP

The last parameter under Inventory Information indicates whether this access point can be configured for hybrid REAP. Only the 1130AG and 1240AG access points support hybrid REAP.

Step 4 Verify that the AP Mode parameter displays H-REAP. If it does not, continue to Step 5. If H-REAP is showing as supported, skip to Step 9.

Step 5 Choose Configure > AP Configuration Templates > Lightweight AP or Autonomous AP.

Step 6 Choose which access point you want to configure for hybrid REAP by clicking one from the AP Name list. The AP Template Detail page appears (see Figure 13-4).
Step 7 Select the **H-REAP/REAP Config** check box. Enabling this configuration allows you to view all profile mappings.

**Note** If you are changing the mode to H-REAP/REAP and if the access point is not already in H-REAP/REAP mode, all other H-REAP/REAP parameters will not be applied on the access point.

Step 8 Select the **VLAN Support** check box and enter the number of the native VLAN on the remote network (such as 100) in the **Native VLAN ID** text box.
By default, a VLAN is not enabled on the hybrid-REAP access point. When hybrid REAP is enabled, the access point inherits the VLAN ID associated to the WLAN. This configuration is saved in the access point and received after the successful join response. By default, the native VLAN is 1. One native VLAN must be configured per hybrid-REAP access point in a VLAN-enabled domain. Otherwise, the access point cannot send and receive packets to and from the controller. When the client is assigned a VLAN from the RADIUS server, that VLAN is associated to the locally switched WLAN.

**Step 9** Click the **Apply/Schedule** tab to save your changes.

**Step 10** The Locally Switched VLANs section shows which WLANs are locally switched and provides their VLAN identifier. Click the **Edit** link to change the number of VLANs from which a client IP address is obtained. You are then redirected to a page where you can save the VLAN identifier changes.

**Step 11** Click **Save** to save your changes.

**Step 12** Repeat this procedure for any additional access points that need to be configured for hybrid REAP at the remote site.

## Connecting Client Devices to the WLANs

Follow the instructions for your client device to create profiles that connect to the WLANs you created in the “Configuring the Controller for Hybrid REAP” section on page 13-6.

In our example, you would create three profiles on the client:

1. To connect to the “employee” WLAN, you would create a client profile that uses WPA/WPA2 with PEAP-MSCHAPV2 authentication. When the client becomes authenticated, it gets an IP address from the management VLAN of the controller.

2. To connect to the “local-employee” WLAN, you would create a client profile that uses WPA/WPA2 authentication. When the client becomes authenticated, it gets an IP address from VLAN 101 on the local switch.

3. To connect to the “guest-central” WLAN, you would create a profile that uses open authentication. When the client becomes authenticated, it gets an IP address from VLAN 101 on the network local to the access point. After the client connects, the local user types any HTTP address in the web browser. The user is automatically directed to the controller to complete the web-authentication process. When the web login page appears, the user enters his or her username and password.

To see if a client’s data traffic is being locally or centrally switched, choose **Monitor > Devices > Clients**.

## Hybrid REAP Access Point Groups

Hybrid REAP enables you to configure and control access points in a branch or remote office from the corporate office through a wide area network (WAN) link without deploying a controller in each office. There is no deployment restriction on the number of hybrid-REAP access points per location, but you can organize and group the access points per floor and limit them per building, since it is likely the branch offices share the same configuration.
By forming access point groups with similar configurations, a procedure such as CCKM fast roaming can be processed more quickly than going through the controller individually. For example, to activate CCKM fast roaming, the HREAP access points must know the CCKM cache for all clients that could associate. If you have a controller with 300 access points and 1000 clients that can potentially connect, it is quicker and more practical to process and send the CCKM cache for the HREAP group rather than for all 1000 clients. One particular HREAP group could focus on a branch office with a small number of access points so that clients in the branch office could only connect to and roam between those few access points. With the established group, features such as CCKM cache and backup RADIUS are configured for the entire HREAP group rather than being configured in each access point.

All of the hybrid-REAP access points in a group share the same WLAN, backup RADIUS server, CCKM, and local authentication configuration information. This feature is helpful if you have multiple hybrid-REAP access points in a remote office or on the floor of a building and you want to configure them all at once. For example, you can configure a backup RADIUS server for a hybrid-REAP group rather than having to configure the same server on each access point. Figure 13-5 illustrates a typical hybrid-REAP group deployment with a backup RADIUS server in the branch office.

**Figure 13-5 Hybrid-REAP Group Deployment**

**Hybrid-REAP Groups and Backup RADIUS Servers**

You can configure the controller to allow a hybrid-REAP access point in standalone mode to perform full 802.1x authentication to a backup RADIUS server. You can configure a primary RADIUS server or both a primary and secondary RADIUS server.

**Hybrid-REAP Groups and CCKM**

Hybrid-REAP groups are required for CCKM fast roaming to work with hybrid-REAP access points. CCKM fast roaming is achieved by caching a derivative of the master key from a full EAP authentication so that a simple and secure key exchange can occur when a wireless client roams to a different access point. This feature prevents the need to perform a full RADIUS EAP authentication as the client roams from one access point to another. The hybrid-REAP access points need to obtain the CCKM cache information for all the clients that might associate so they can process it quickly instead of sending it back to the controller. If, for example, you have a controller with 300 access points and 100 clients that...
Hybrid REAP Access Point Groups

might associate, sending the CCKM cache for all 100 clients is not practical. If you create a hybrid-REAP group comprising a limited number of access points (for example, you create a group for four access points in a remote office), the clients roam only among those four access points, and the CCKM cache is distributed among those four access points only when the clients associate to one of them.

Note CCKM fast roaming among hybrid-REAP and non-hybrid-REAP access points is not supported.

Hybrid-REAP Groups and Local Authentication

You can configure the controller to allow a hybrid-REAP access point in standalone mode to perform LEAP or EAP-FAST authentication for up to 20 statically configured users. The controller sends the static list of usernames and passwords to each hybrid-REAP access point when it joins the controller. Each access point in the group authenticates only its own associated clients. This feature is ideal for customers who are migrating from an autonomous access point network to a lightweight hybrid-REAP access point network and are not interested in maintaining a large user database nor adding another hardware device to replace the RADIUS server functionality available in the autonomous access point.

Note This feature can be used in conjunction with the hybrid-REAP backup RADIUS server feature. If a hybrid-REAP group is configured with both a backup RADIUS server and local authentication, the hybrid-REAP access point always attempts to authenticate clients using the primary backup RADIUS server first, followed by the secondary backup RADIUS server (if the primary is not reachable), and finally the hybrid-REAP access point itself (if the primary and secondary are not reachable).

Configuring Hybrid-REAP Groups

To configure HREAP groups, follow these steps. If you want to apply an H-REAP template to multiple controllers, refer to the template instructions in the “Configuring H-REAP AP Groups Templates” section.

1. Choose Configure > Controllers.
2. Choose a specific controller by clicking on the desired IP address.
3. From the left sidebar menu choose H-REAP > H-REAP AP Groups. The established HREAP AP groups appear.
4. The Group Name column shows the group names assigned to the HREAP access point groups. If you want to add an additional group, choose Add H-REAP AP Group from the Select a command drop-down list.
   or
   To make modifications to an existing template, click a template in the Template Name column. The General tab of the H-REAP AP Groups template appears (see Figure 13-6).
Chapter 13  Configuring Hybrid REAP

Hybrid REAP Access Point Groups

Figure 13-6  H-REAP AP Groups

<table>
<thead>
<tr>
<th>General</th>
<th>H-REAP AP</th>
<th>H-REAP Configuration</th>
</tr>
</thead>
<tbody>
<tr>
<td>Template Name:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Primary Radius 1:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Secondary Radius 2:</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Notes:
1. Delete radius authentication server present on Controller. If not present on Controller, WCS configured radius authentication server will not apply.
2. Warning: AP Ethernet MAC address cannot exist in more than one H-REAP group on same Controller. Please Use the AP Ethernet MAC from one of the groups if applied to same Controller. Controller will not allow setting AP Ethernet MAC in a H-REAP AP Group if it is already present in another H-REAP Group. You can still apply same AP Ethernet MAC list to different Controller.
3. H-REAP users can be created only after saving the H-REAP AP Group.

Note: Maximum 100 H-REAP users are supported from 5.2.x.x controller version. If controller version is less than 5.2.6.0, only 20 H-REAP users are supported.

To delete a group name, click the group name you want to remove and choose Delete H-REAP AP Group from the Select a command drop-down list.

The Template Name parameter shows the group name assigned to the H-REAP access point group.

Step 5 Choose the primary RADIUS authentication servers for each group. If a RADIUS authentication server is not present on the controller, the WCS configured RADIUS server does not apply.

Note You must configure the RADIUS server configuration on the controller before you apply H-REAP RADIUS server configuration from WCS.

Step 6 Choose the secondary RADIUS authentication servers for each group. If a RADIUS authentication server is not present on the controller, the WCS configured RADIUS server does not apply.

Step 7 If you want to add an access point to the group, click the H-REAP AP tab.

Step 8 An access point Ethernet MAC address cannot exist in more than one H-REAP group on the same controller. If more than one group is applied to the same controller, click the Ethernet MAC check box to unselect an access point from one of the groups. You should save this change or apply it to controllers.
Hybrid REAP Access Point Groups

Step 9 If you want to enable local authentication for a hybrid-REAP group, click the H-REAP Configuration tab. The H-REAP Configuration tab appears.

Note Make sure that the Primary RADIUS Server and Secondary RADIUS Server parameters are set to None on the General tab.

Step 10 Select the H-REAP Local Authentication check box to enable local authentication for this hybrid-REAP group. The default value is unselected.

Note When you attempt to use this feature, a warning message indicates that it is a licensed feature.

Step 11 To allow a hybrid-REAP access point to authenticate clients using LEAP, select the LEAP check box. Otherwise, to allow a hybrid-REAP access point to authenticate clients using EAP-FAST, select the EAP-FAST check box.

Step 12 Perform one of the following, depending on how you want protected access credentials (PACs) to be provisioned:

- To use manual PAC provisioning, enter the key used to encrypt and decrypt PACs in the EAP-FAST Key text box. The key must be 32 hexadecimal characters.
- To allow PACs to be sent automatically to clients that do not have one during PAC provisioning, select the Auto Key Generation check box.

Step 13 In the EAP-FAST Authority ID text box, enter the authority identifier of the EAP-FAST server. The identifier must be 32 hexadecimal characters.

Step 14 In the EAP-FAST Authority Info text box, enter the authority identifier of the EAP-FAST server in text format. You can enter up to 32 hexadecimal characters.

Step 15 In the EAP-FAST Pac Timeout text box, specify a PAC timeout value by entering the number of seconds for the PAC to remain viable in the edit box. The valid range is 2 to 4095 seconds.

Note To verify that an individual access point belongs to a hybrid-REAP group, click the Users configured in the group link. It advances you to the H-REAP AP Group screen which shows the names of the groups and the access points that belong in it.

Auditing an H-REAP Group

If the H-REAP configuration changes over a period of time either on WCS or the controller, you can audit the configuration. The changes are visible on subsequent screens. You can choose to synchronize the configuration by refreshing WCS or the controller.
CHAPTER 14

Alarm and Event Dictionary

This chapter describes the event and alarm notifications that the wireless LAN controller, access points, and location appliances can receive. It also identifies specific actions the administrator can take to address these alarms and events.

It describes the event and alarm notifications that the wireless LAN controller, access points, and location appliances can receive. In addition, specific actions an administrator can do to address these alarms and events are described.

Note

Not all traps which are seen on the WLC GUI are supported by WCS.

This chapter contains the following sections:

- Notification Format, page 14-2
- Traps Added in Release 2.0, page 14-3
- Traps Added in Release 2.1, page 14-22
- Traps Added in Release 2.2, page 14-26
- Traps Added in Release 3.0, page 14-29
- Traps Added in Release 3.1, page 14-31
- Traps Added in Release 3.2, page 14-35
- Traps Added In Release 4.0, page 14-36
- Traps Added or Updated in Release 4.0.96.0, page 14-42
- Traps Added or Updated in Release 4.1, page 14-44
- Traps Added or Updated in Release 4.2, page 14-51
- Traps Added or Updated in Release 5.0, page 14-55
- Traps Added or Updated in Release 5.1, page 14-59
- Traps Added or Updated in Release 6.0, page 14-59
- Traps Added or Updated in Release 7.0, page 14-61
- Unsupported Traps, page 14-63
Notification Format

For each alarm and event notification, the following information is provided (see Table 14-1).

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>The notification title is generally picked up from an event property file defined in the NMS.</td>
</tr>
<tr>
<td>MIB Name</td>
<td>The MIB Name is the name of the notification as defined in the management information base (MIB). In some cases, if the event is specific only to the NMS, this field is not relevant. You can define multiple events in WCS from the same trap based on the values of the variables present in the trap. In such cases, multiple subentries appear with the same MIB Name. In addition, this field displays the value of the variable that caused WCS to generate this event.</td>
</tr>
<tr>
<td>WCS Message</td>
<td>The WCS Message is a text string that reflects the message displayed in the WCS alarm or event browser associated with this event. Numbers such as &quot;{0}&quot; reflect internal WCS variables that typically are retrieved from variables in the trap. However, the order of the variables as they appear in the trap cannot be derived from the numbers.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This field displays the symptoms associated with this event.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>This field displays the severity assigned to this event in WCS.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>This field lists the probable causes of the notification.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>This field lists any actions recommended for the administrator managing the wireless network.</td>
</tr>
</tbody>
</table>
### Traps Added in Release 2.0

#### AP_BIG_NAV_DOS_ATTACK

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnApBigNavDosAttack.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>The AP &quot;{0}&quot; with protocol &quot;{1}&quot; receives a message with a large NAV field and all traffic on the channel is suspended. This is most likely a malicious denial of service attack.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system detected a possible denial of service attack and suspended all traffic to the affected channel.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A malicious denial of service attack is underway.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Identify the source of the attack in the network and take the appropriate action immediately.</td>
</tr>
</tbody>
</table>

#### AP_CONTAINED_AS_ROGUE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPContainedAsARogue.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0}&quot; with protocol &quot;{1}&quot; on Switch &quot;{2}&quot; is contained as a Rogue preventing service.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>An access point is reporting that it is being contained as a rogue.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Another system is containing this access point.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Identify the system containing this access point. You may need to use a wireless sniffer.</td>
</tr>
</tbody>
</table>

#### AP_DETECTED_DUPLICATE_IP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnDuplicateIpAddressReported.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0}&quot; on Switch &quot;{3}&quot; detected duplicate IP address &quot;{2}&quot; being used by machine with mac address &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system detects a duplicate IP address in the network that matches that assigned to an access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Another device in the network is configured with the same IP address as an access point.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Correct the misconfiguration of IP addresses in the network.</td>
</tr>
</tbody>
</table>
**AP_HAS_NO_RADIOS**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnApHasNoRadioCards.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Not supported in WCS yet.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>An access point is reporting that it has no radio cards.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>N/A.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Manufacturing fault or damage to the system during shipping.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Call customer support.</td>
</tr>
</tbody>
</table>

**AP_MAX_ROGUE_COUNT_CLEAR**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnApMaxRogueCountClear.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Fake AP or other attack on AP with MAC address &quot;{0}&quot; associated with Switch &quot;{2}&quot; is cleared now. Rogue AP count is within the threshold of &quot;}{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The number of rogues detected by a switch (controller) is within acceptable limits.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>N/A.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

**AP_MAX_ROGUE_COUNT_EXCEEDED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnApMaxRogueCountExceeded.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Fake AP or other attack may be in progress. Rogue AP count on AP with MAC address &quot;{0}&quot; associated with Switch &quot;{2}&quot; has exceeded the severity warning threshold of &quot;}{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The number of rogues detected by a switch (controller) exceeds the internal threshold.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
</tbody>
</table>
| Probable Causes   | • There may be too many rogue access points in the network.  
                      • A fake access point attack may be in progress. |
| Recommended Actions | Identify the source of the rogue access points. |

**AUTHENTICATION_FAILURE (From MIB-II standard)**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>AuthenticationFailure.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Switch &quot;{0}&quot;. Authentication failure reported.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>There was an SNMP authentication failure on the switch (controller).</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
</tbody>
</table>
Chapter 14      Alarm and Event Dictionary

BSN_AUTHENTICATION_FAILURE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAuthenticationFailure.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Switch &quot;{0}.&quot; User authentication from Switch &quot;{0}&quot; failed for user name &quot;{1}&quot; and user type &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A user authentication failure is reported for a local management user or a MAC filter is configured on the controller.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Incorrect login attempt by an admin user from the controller CLI or controller GUI, or a client accessing the WLAN system.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>If the user has forgotten the password, the superuser may need to reset it.</td>
</tr>
</tbody>
</table>
### COLD_START (FROM MIB-II STANDARD)

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>coldStart.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Switch &quot;[0].&quot; Cold start.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The switch (controller) went through a reboot.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>• The switch (controller) has power-cycled.</td>
</tr>
<tr>
<td></td>
<td>• The switch (controller) went through a hard reset.</td>
</tr>
<tr>
<td></td>
<td>• The switch (controller) went through a software restart.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### CONFIG_SAVED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnConfigSaved.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Switch &quot;[0].&quot; Configuration saved in flash.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A configuration save to flash is performed on the switch (controller).</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The switch (controller) saves the configuration to the flash via a CLI command or entry via the controller GUI or WCS.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>If you change the configuration using the controller CLI or controller GUI, you may need to refresh the configuration.</td>
</tr>
</tbody>
</table>

### IPSEC_IKE_NEG_FAILURE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnIpsecIkeNegFailure.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>IPsec IKE Negotiation failure from remote IP address &quot;[0].&quot;</td>
</tr>
<tr>
<td>Symptoms</td>
<td>Unable to establish an IPsec tunnel between a client and a WLAN appliance.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Configuration mismatch.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Validate configuration, verify that authentication credentials match (preshared keys or certificates); and verify that encryption algorithms and strengths match.</td>
</tr>
</tbody>
</table>
**IPSEC_INVALID_COOKIE**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnIpsecInvalidCookieTrap.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>IPsec Invalid cookie from remote IP address '{0}'.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>Cannot successfully negotiate an IPsec session.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Synchronization problem. The client believes a tunnel exists while the WLAN appliance does not. This problem often happens when the IPsec client does not detect a disassociation event.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Reset the IPsec client and then restart tunnel establishment.</td>
</tr>
</tbody>
</table>

**LINK_DOWN (FROM MIB-II STANDARD)**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>linkDown.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Port '{0}' is down on Switch '{1}'.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The physical link on one of the switch (controller) ports is down.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
</tbody>
</table>
| Probable Causes           | • An access point or a port was manually disconnected from the network.  
                           | • A port failure. |
| Recommended Actions       | Troubleshoot physical network connectivity to the affected port. |

**LINK_UP (FROM MIB-II STANDARD)**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>linkUp.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Port '{0}' is up on Switch '{1}'.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The physical link is up on a switch (controller) port.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A physical link to the switch (controller) is restored.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

**LRAD_ASSOCIATED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPAssociated.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP '{0}' associated with Switch '{2}' on Port number '{1}'.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>An access point has associated with a switch (controller).</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
</tbody>
</table>
| Probable Causes           | • A new access point has joined the network.  
                           | • An access point has associated with a standby switch (controller) due to a failover.  
                           | • An access point rebooted and reassociated with a switch (controller). |
| Recommended Actions       | None. |
## LRAD_DISASSOCIATED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPDisassociated.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0}&quot; disassociated from Switch &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The switch (controller) is no longer detecting an access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
</tbody>
</table>
| Probable Causes   | • A failure in the access point.  
                     • An access point is no longer on the network. |
| Recommended Actions | Check if the access point is powered up and has network connectivity to the switch (controller). |

## LRADIF_COVERAGE_PROFILE_FAILED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPCoverageProfileFailed.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0}&quot;. interface &quot;{1}&quot;. Coverage threshold of &quot;{3}&quot; is violated. Total no. of clients is &quot;{5}&quot; and no. failed clients is &quot;{4}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>Number of clients experiencing suboptimal performance has crossed the configured threshold.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Many clients are wandering to the remote parts of the coverage area of this radio interface with no handoff alternative.</td>
</tr>
</tbody>
</table>
| Recommended Actions | • If the configured threshold is too low, you may need to readjust it to a more optimal value.  
                           • If the coverage profile occurs on a more frequent basis, you may need to provide additional radio coverage.  
                           • If the power level of this radio can be manually controlled, you may need to boost it to increase the coverage area. |

## LRADIF_COVERAGE_PROFILE_PASSED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPCoverageProfileUpdatedToPass.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0}&quot;. interface &quot;{1}&quot;. Coverage changed to acceptable.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio interface that was reporting coverage profile failure has reverted to an acceptable level.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The number of clients on this radio interface with suboptimal performance has dropped below the configured threshold.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### LRADIF_CURRENT_CHANNEL_CHANGED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPCurrentChannelChanged.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0}&quot; interface &quot;{1}&quot;. Channel changed to &quot;{2}&quot;. Interference Energy before update was &quot;{3}&quot; and after update is &quot;{4}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The current channel assigned to a radio interface has automatically changed.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Possible interference on a channel has caused the radio management software on the controller to change the channel.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### LRADIF_CURRENT_TXPOWER_CHANGED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPCurrentTxPowerChanged.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0}&quot; interface &quot;{1}&quot;. Transmit Power Level changed to &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The power level has automatically changed on a radio interface.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The radio management software on the controller has modified the power level for optimal performance.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### LRADIF_DOWN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPIfDown.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0}&quot; interface &quot;{1}&quot; is down.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio interface is out of service.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical if not disabled, otherwise Informational.</td>
</tr>
</tbody>
</table>
| Probable Causes              | • A radio interface has failed.  
                                 • An administrator has disabled a radio interface.  
                                 • An access point has failed and is no longer detected by the controller. |
| Recommended Actions          | If the access point is not administratively disabled, call customer support. |
LRADF_INTERFERENCE_PROFILE_FAILED

MIB Name | bsnAPInterferenceProfileFailed.
---|---
WCS Message | AP "\{0\}," interface "\{1\}" Interference threshold violated.
Symptoms | The interference detected on one or more channels is violated.
WCS Severity | Minor.
Probable Causes | There are other 802.11 devices in the same band that are causing interference on channels used by this system.
Recommended Actions | • If the interference threshold is configured to be too low, you may need to readjust it to a more optimum value.
• Investigate interference sources such as other 802.11 devices in the vicinity of this radio interface.
A possible workaround is adding one or more access points to distribute the current load or slightly increasing the threshold of the access point which is displaying this message. To perform this workaround, follow the steps below:
1. Choose Configure > Controllers.
2. Click any IP address in that column of the All Controllers page.
3. From the left sidebar menu, choose 802.11a/n or 802.11b/g/n and then RRM Thresholds.
4. Adjust the Interference Threshold (%) in the Other Thresholds section.

LRADIF_INTERFERENCE_PROFILE_PASSED

MIB Name | bsnAPInterferenceProfileUpdatedToPass.
---|---
WCS Message | AP "\{0\}," interface "\{1\}" Interference changed to acceptable.
Symptoms | A radio interface reporting interference profile failure has reverted to an acceptable level.
WCS Severity | Informational.
Probable Causes | The interference on this radio interface has dropped below the configured threshold.
Recommended Actions | None.
## LRADIF_LOAD_PROFILE_FAILED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPLoadProfileFailed.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>WCS Message</strong></td>
<td>AP &quot;{0},&quot; interface &quot;{1}&quot;. Load threshold violated.</td>
</tr>
<tr>
<td><strong>Symptoms</strong></td>
<td>A radio interface of an access point is reporting that the client load has crossed a configured threshold.</td>
</tr>
<tr>
<td><strong>WCS Severity</strong></td>
<td>Minor.</td>
</tr>
<tr>
<td><strong>Probable Causes</strong></td>
<td>There are too many clients associated with this radio interface.</td>
</tr>
</tbody>
</table>
| **Recommended Actions**   | • Verify the client count on this radio interface. If the threshold for this trap is too low, you may need to readjust it.  
                              • Add new capacity to the physical location if the client count is a frequent issue on this radio. |

## LRADIF_LOAD_PROFILE_PASSED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPLoadProfileUpdatedToPass.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>WCS Message</strong></td>
<td>AP &quot;{0},&quot; interface &quot;{1}&quot;. Load changed to acceptable.</td>
</tr>
<tr>
<td><strong>Symptoms</strong></td>
<td>A radio interface that was reporting load profile failure has reverted to an acceptable level.</td>
</tr>
<tr>
<td><strong>WCS Severity</strong></td>
<td>Informational.</td>
</tr>
<tr>
<td><strong>Probable Causes</strong></td>
<td>The load on this radio interface has dropped below the configured threshold.</td>
</tr>
<tr>
<td><strong>Recommended Actions</strong></td>
<td>None.</td>
</tr>
</tbody>
</table>

## LRADIF_NOISE_PROFILE_FAILED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPNoiseProfileFailed.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>WCS Message</strong></td>
<td>AP &quot;{0},&quot; interface &quot;{1}&quot;. Noise threshold violated.</td>
</tr>
<tr>
<td><strong>Symptoms</strong></td>
<td>The monitored noise level on this radio has crossed the configured threshold.</td>
</tr>
<tr>
<td><strong>WCS Severity</strong></td>
<td>Minor.</td>
</tr>
<tr>
<td><strong>Probable Causes</strong></td>
<td>Noise sources that adversely affect the frequencies on which the radio interface operates.</td>
</tr>
</tbody>
</table>
| **Recommended Actions**   | • If the noise threshold is too low, you may need to readjust it to a more optimal value.  
                              • Investigate noise sources in the vicinity of the radio interface (for example, a microwave oven). |
### LRADIF_NOISE_PROFILE_PASSED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPNoiseProfileUpdatedToPass.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0},&quot; interface &quot;{1}&quot; Noise changed to acceptable.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio interface that was reporting noise profile failure has reverted to an acceptable level.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The noise on this radio interface has dropped below the configured threshold.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### LRADIF_UP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPIfUp.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0},&quot; interface &quot;{1}&quot; is up.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio interface is back up.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>• An administrator has enabled a radio interface.</td>
</tr>
<tr>
<td></td>
<td>• An access point has turned on.</td>
</tr>
<tr>
<td></td>
<td>• A new access point has joined the network.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### MAX_ROGUE_COUNT_CLEAR

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnMaxRogueCountClear.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Fake AP or other attack is cleared now. Rogue AP count on system &quot;{0}&quot; is within the threshold of &quot;{1}&quot;</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The number of rogues detected by a controller is within acceptable limits.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>N/A.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### MAX_ROGUE_COUNT_EXCEEDED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnMaxRogueCountExceeded.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Fake AP or other attack may be in progress. Rogue AP count on system &quot;{0}&quot; has exceeded the severity warning threshold of &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The number of rogues detected by a controller exceeds the internal threshold.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
</tbody>
</table>
| Probable Causes           | • There are too many rogue access points in the network.  
                            | • A fake access point attack is in progress. |
| Recommended Actions       | Identify the source of the rogue access points. |

### MULTIPLE_USERS

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>multipleUsersTrap.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Switch &quot;{0}&quot;. Multiple users logged in.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>Multiple users with the same login ID are logged in through the CLI.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The same user has logged in multiple times through the CLI interface.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Verify that the expected login sessions for the same user are valid.</td>
</tr>
</tbody>
</table>

### NETWORK_DISABLED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnNetworkStateChanged (bsnNetworkState set to disabled).</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Global &quot;{1}&quot; network status disabled on Switch with IP Address &quot;{0}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>An administrator has disabled the global network for 802.11a/n and 802.11b/g/n.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Administrative command.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### NO_ACTIVITY_FOR_ROGUE_AP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>This is a WCS-only event generated when no rogue activity is seen for a specific duration.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Rogue AP &quot;{0}&quot; is cleared explicitly. It is not detected anymore.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A rogue access point is cleared from the management system due to inactivity.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A rogue access point is not located on any managed controller for a specified duration.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
## POE_CONTROLLER_FAILURE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnPOEControllerFailure.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>The POE controller has failed on the Switch &quot;[0].&quot;</td>
</tr>
<tr>
<td>SYMPTOMS</td>
<td>A failure in the Power Over Ethernet (POE) unit is detected.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The power of the Ethernet unit has failed.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Call customer support. The unit may need to be repaired.</td>
</tr>
</tbody>
</table>

## RADIOS_EXCEEDED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRadiosExceedLicenseCount.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>The Radios associated with Switch &quot;[0]&quot; exceeded license count &quot;[1].&quot; The current number of radios on this switch is &quot;[2].&quot;</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The number of supported radios for a switch (controller) has exceeded the licensing limit.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The number of access points associated with the switch (controller) has exceeded the licensing limits.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Upgrade the license for the switch (controller) to support a higher number of access points.</td>
</tr>
</tbody>
</table>

## RADIUS_SERVERS_FAILED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRADIUSServerNotResponding.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Switch &quot;[0].&quot; RADIUS server(s) are not responding to authentication requests.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The switch (controller) is unable to reach any RADIUS server for authentication.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Network connectivity to the RADIUS server is lost or the RADIUS server is down.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Verify the status of all configured RADIUS servers and their network connectivity.</td>
</tr>
</tbody>
</table>
**ROGUE_AP_DETECTED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRogueAPDetected.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Rogue AP or ad hoc rogue &quot;(0)&quot; with SSID &quot;(3)&quot; and channel number &quot;(4)&quot; is detected by AP &quot;(1)&quot; Radio type &quot;(2)&quot; with RSSI &quot;(5)&quot; and SNR &quot;(6).&quot;</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system has detected a rogue access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor if not on a wired network; Critical if on a wired network.</td>
</tr>
</tbody>
</table>
| Probable Causes  | • An illegal access point is connected to the network.  
                   • A known internal or external access point unknown to this system is detected as rogue. |
| Recommended Actions | • Verify the nature of the rogue access point by tracing it using its MAC address or the SSID, or by using location features to locate it physically.  
                   • If the access point is a known internal or external access point, acknowledge it or mark it as a known access point. Consider adding it to the known access point template within WCS.  
                   • If the access point is deemed to be a severity threat, contain it using the management interface. |

**ROGUE_AP_ON_NETWORK**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRogueAPDetectedOnWiredNetwork</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Rogue AP or ad hoc rogue &quot;(0)&quot; is on the wired network.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A rogue access point is found reachable through the wired network.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>An illegal access point was detected as reachable through the wired network.</td>
</tr>
</tbody>
</table>
| Recommended Actions                     | • Determine if this is a known or valid access point in the system. If it is valid, place it in the known access point list.  
                                           • Contain the rogue. Prevent anyone from accessing it until the access point has been traced down using location or other features. |
## ROGUE_AP_REMOVED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRogueAPRemoved.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Rogue AP or ad hoc rogue &quot;[0]&quot; is removed; it was detected as Rogue AP by AP &quot;[1]&quot; Radio type &quot;[2].&quot;</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system is no longer detecting a rogue access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A rogue access point has powered off or moved away and therefore the system no longer detects it.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## RRM_DOT11_A_GROUPING_DONE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRrmDot11aGroupingDone.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RRM 802.11a/n grouping done; the new group leader’s MAC address is &quot;[0].&quot;</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The radio resource module is finished grouping for the A band, and a new group leader is chosen.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The older RRM group leader may have gone down.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## RRM_DOT11_B_GROUPING_DONE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRrmDot11bGroupingDone.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RRM 802.11b/g/n grouping done; the new group leader’s MAC address is &quot;[0].&quot;</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The radio resource module finished its grouping for the B band and chose a new group leader.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The older RRM group leader may have gone down.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### SENSED_TEMPERATURE_HIGH

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnSensedTemperatureTooHigh.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>The sensed temperature on the Switch &quot;{0}&quot; is too high. The current sensed temperature is &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system's internal temperature has crossed the configured thresholds.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>• Fan failure.</td>
</tr>
<tr>
<td></td>
<td>• Fault in the device.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>• Verify the configured thresholds and increase the value if it is too low.</td>
</tr>
<tr>
<td></td>
<td>• Call customer support.</td>
</tr>
</tbody>
</table>

### SENSED_TEMPERATURE_LOW

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnSensedTemperatureTooLow.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>The sensed temperature on the Switch &quot;{0}&quot; is too low. The current sensed temperature is &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The internal temperature of the device is below the configured limit in the system.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>• Operating environment.</td>
</tr>
<tr>
<td></td>
<td>• Hardware fault.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>• Verify the configured thresholds and ensure that the limit is appropriate.</td>
</tr>
<tr>
<td></td>
<td>• Call customer support.</td>
</tr>
</tbody>
</table>

### STATION_ASSOCIATE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnDot11StationAssociate.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Client &quot;{0}&quot; is associated with AP &quot;{1}&quot;. interface &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A client has associated with an access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A client has associated with an access point.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
## STATION_ASSOCIATE_FAIL

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnDot11StationAssociateFail.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Client &quot;{0}&quot; failed to associate with AP &quot;{1},&quot; interface &quot;{2}&quot;. The reason code is &quot;{3}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A client station failed to associate with the system.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The access point was busy.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Check whether the access point is busy and reporting load profile failures.</td>
</tr>
</tbody>
</table>

## STATION_AUTHENTICATE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnDot11StationAssociate (bsnStationUserName is set).</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Client &quot;{0}&quot; with user name &quot;{3}&quot; is authenticated with AP &quot;{1},&quot; interface &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A client has successfully authenticated with the system.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A client has successfully authenticated with the system.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## STATION_AUTHENTICATION_FAIL

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnDot11StationAuthenticateFail.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Client &quot;{0}&quot; has failed authenticating with AP &quot;{1},&quot; interface &quot;{2}&quot;. The reason code is &quot;{3}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system failed to authenticate a client.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Failed client authentication.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Check client configuration and configured keys or passwords in the system.</td>
</tr>
</tbody>
</table>
### STATION_BLACKLISTED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnpDot11StationBlacklisted.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Client &quot;{0}&quot; which was associated with AP &quot;{1}&quot; interface &quot;{2}&quot; is excluded. The reason code is &quot;{3}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A client is in the exclusion list and is not allowed to authenticate for a configured interval.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
</tbody>
</table>
| Probable Causes          | • Repeated authentication or association failures from the client station.  
                          | • A client is attempting to use an IP address assigned to another device. |
| Recommended Actions      | • Verify the configuration or the client along with its credentials.  
                          | • Remove the client from the exclusion list by using the management interface if the client needs to be allowed back into the network. |

### STATION_DEAUTHENTICATE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnpDot11StationDeauthenticate.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Client &quot;{0}&quot; is deauthenticated from AP &quot;{1}&quot; interface &quot;{2}&quot; with reason code &quot;{3}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A client is no longer authenticated by the system.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A client is no longer authenticated by the system.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### STATION_DISASSOCIATE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnpDot11StationDisassociate.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Client &quot;{0}&quot; is disassociated from AP &quot;{1}&quot; interface &quot;{2}&quot; with reason code &quot;{3}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A client has disassociated with an access point in the system.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A station may disassociate due to various reasons such as inactivity timeout or a forced action from the management interface.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### STATION_WEP_KEY_DECRYPT_ERROR

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnWepKeyDecryptError.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>WCS Message</strong></td>
<td>The WEP Key configured at the station may be wrong. Station MAC Address is &quot;{0}&quot; AP MAC is &quot;{1}&quot; and Slot ID is &quot;{2}&quot;.</td>
</tr>
<tr>
<td><strong>Symptoms</strong></td>
<td>A client station seems to have the wrong WEP key.</td>
</tr>
<tr>
<td><strong>WCS Severity</strong></td>
<td>Minor.</td>
</tr>
<tr>
<td><strong>Probable Causes</strong></td>
<td>A client has an incorrectly configured WEP key.</td>
</tr>
<tr>
<td><strong>Recommended Actions</strong></td>
<td>Identify the client and correct the WEP key configuration.</td>
</tr>
</tbody>
</table>

### STATION_WPA_MIC_ERROR_COUNTER_ACTIVATED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnWpaMicErrorCounterActivated.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>WCS Message</strong></td>
<td>The AP &quot;{1}&quot; received a WPA MIC error on protocol &quot;{2}&quot; from Station &quot;{0}&quot;. Counter measures have been activated and traffic has been suspended for 60 seconds.</td>
</tr>
<tr>
<td><strong>Symptoms</strong></td>
<td>A client station has detected a WPA MIC error.</td>
</tr>
<tr>
<td><strong>WCS Severity</strong></td>
<td>Critical.</td>
</tr>
<tr>
<td><strong>Probable Causes</strong></td>
<td>A possible hacking attempt is underway.</td>
</tr>
<tr>
<td><strong>Recommended Actions</strong></td>
<td>Identify the station that is the source of this threat.</td>
</tr>
</tbody>
</table>

### SWITCH_DETECTED_DUPLICATE_IP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnDuplicateIpAddressReported.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>WCS Message</strong></td>
<td>Switch &quot;{0}&quot; detected duplicate IP address &quot;{0}&quot; being used by machine with mac address &quot;{1}&quot;.</td>
</tr>
<tr>
<td><strong>Symptoms</strong></td>
<td>The system has detected a duplicate IP address in the network that is assigned to the switch (controller).</td>
</tr>
<tr>
<td><strong>WCS Severity</strong></td>
<td>Critical.</td>
</tr>
<tr>
<td><strong>Probable Causes</strong></td>
<td>Another device in the network is configured with the same IP address as that of the switch (controller).</td>
</tr>
<tr>
<td><strong>Recommended Actions</strong></td>
<td>Correct the misconfiguration of IP addresses in the network.</td>
</tr>
</tbody>
</table>
### SWITCH_DOWN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>This is a WCS-only event.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Switch &quot;{0}&quot; is unreachable.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A switch (controller) is unreachable from the management system.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
</tbody>
</table>
| Probable Causes | 1. The switch (controller) has encountered hardware or software failure.  
2. There are network connectivity issues between the management station and the switch (controller).  
3. The configured SNMP community strings on the management station or the switch (controller) are incorrect. |
| Recommended Actions | 1. Check if the switch (controller) is powered up and reachable through the web interface.  
2. Ping the switch (controller) from the management station to verify if there is IP connectivity.  
3. Check the community strings configured on the management station. |

### SWITCH_UP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>This is a WCS-only event.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Switch &quot;{0}&quot; is reachable.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A switch (controller) is now reachable from the management station.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A switch (controller) is reachable from the management station.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### TEMPERATURE_SENSOR_CLEAR

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTemperatureSensorClear.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>The temperature sensor is working now on the switch &quot;{0}&quot;. The sensed temperature is &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The temperature sensor is operational.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The system is detecting the temperature sensor to be operational now.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
## TEMPERATURE_SENSOR_FAILURE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTemperatureSensorFailure.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>The temperature sensor failed on the Switch &quot;{0}&quot;. Temperature is unknown.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system is reporting that a temperature sensor has failed and the system is unable to report accurate temperature.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The temperature sensor has failed due to hardware failure.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Call customer support.</td>
</tr>
</tbody>
</table>

## TOO_MANY_USER_UNSUCCESSFUL_LOGINS

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTooManyUnsuccessLoginAttempts.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>User &quot;{1}&quot; with IP Address &quot;{0}&quot; has made too many unsuccessful login attempts.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A management user has made too many login attempts.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
</tbody>
</table>
| Probable Causes           | • An admin user has made too many login attempts.  
                            | • A user attempted to break into the administration account of the management system. |
| Recommended Actions       | • Identify the source of the login attempts and take the appropriate action.  
                            | • Increase the value of the login attempt threshold if it is too low. |

## Traps Added in Release 2.1

### ADHOC_ROGUE_AUTO_CONTAINED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAdhocRogueAutoContained.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Adhoc Rogue &quot;{0}&quot; was found and is auto contained as per WPS policy.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system detected an ad hoc rogue and automatically contained it.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The system detected an ad hoc rogue and automatically contained it as configured in the system’s wireless prevention policy.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Identify the ad hoc rogue through the location application and take the appropriate action.</td>
</tr>
</tbody>
</table>
### ADHOC_ROGUE_AUTO_CONTAINED_CLEAR

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAdhocRogueAutoContained (bsnClearTrapVariable set to true).</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Adhoc Rogue &quot;{0}&quot; found and was auto contained. The alert state is clear now.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>An ad hoc rogue that the system has detected earlier is now clear.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The system no longer detects an ad hoc rogue.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### NETWORK_ENABLED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnNetworkStateChanged (bsnNetworkState set to enabled).</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Global &quot;{1}&quot; network status enabled on Switch with IP Address &quot;{0}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>An administrator has enabled the global network for 802.11a/n or 802.11b/g/n.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Administrative command.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### ROGUE_AP_AUTO_CONTAINED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRogueApAutoContained.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Rogue AP &quot;{0}&quot; is advertising our SSID and is auto contained as per WPS policy.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system has automatically contained a rogue access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The system detected an ad hoc rogue and automatically contained it as configured in the system’s wireless prevention policy.</td>
</tr>
</tbody>
</table>
| Recommended Actions       |  - Track the location of the rogue and take the appropriate action.  
                           |  - If this is a known valid access point, clear the rogue from containment. |

### ROGUE_AP_AUTO_CONTAINED_CLEAR

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRogueApAutoContained (bsnClearTrapVariable set to true).</th>
</tr>
</thead>
<tbody>
<tr>
<td>Message</td>
<td>Rogue AP &quot;{0}&quot; was advertising our SSID and was auto contained. The alert state is clear now.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system has cleared a previously contained rogue.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The system has cleared a previously contained rogue.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
## TRUSTED_AP_INVALID_ENCRYPTION

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTrustedApHasInvalidEncryption.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Trusted AP &quot;{0}&quot; is invalid encryption. It is using &quot;{1}&quot; instead of &quot;{2}&quot;. It is auto contained as per WPS policy.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system automatically contained a trusted access point that has invalid encryption.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The system automatically contained a trusted access point that violated the configured encryption policy.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Identify the trusted access point and take the appropriate action.</td>
</tr>
</tbody>
</table>

## TRUSTED_AP_INVALID_ENCRYPTION_CLEAR

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTrustedApHasInvalidEncryption (bsnClearTrapVariable set to true).</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Trusted AP &quot;{0}&quot; had invalid encryption. The alert state is clear now.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system has cleared a previous alert about a trusted access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The trusted access point has now conformed to the configured encryption policy.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## TRUSTED_AP_INVALID_RADIO_POLICY

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTrustedApHasInvalidRadioPolicy.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Trusted AP &quot;{0}&quot; has invalid radio policy. It is using &quot;{1}&quot; instead of &quot;{2}&quot;. It has been auto contained as per WPS policy.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system has contained a trusted access point with an invalid radio policy.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The system has contained a trusted access point connected to the wireless system for violating the configured radio policy.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Identify the trusted access point and take the appropriate action.</td>
</tr>
</tbody>
</table>

## TRUSTED_AP_INVALID_RADIO_POLICY_CLEAR

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTrustedApHasInvalidRadioPolicy (bsnClearTrapVariable set to true).</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Trusted AP &quot;{0}&quot; had invalid radio policy. The alert state is clear now.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system has cleared a previous alert about a trusted access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The trusted access point has now conformed to the configured encryption policy.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
**TRUSTED_AP_INVALID_SSID**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTrustedApHasInvalidSsid.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Trusted AP &quot;{0}&quot; has invalid SSID. It was auto contained as per WPS policy.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system has automatically contained a trusted access point for advertising an invalid SSID.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The system has automatically contained a trusted access point for violating the configured SSID policy.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Identify the trusted access point and take the appropriate action.</td>
</tr>
</tbody>
</table>

**TRUSTED_AP_INVALID_SSID_CLEAR**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTrustedApHasInvalidSsid (bsnClearTrapVariable set to true).</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Trusted AP &quot;{0}&quot; had invalid SSID. The alert state is clear now.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system has cleared a previous alert about a trusted access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The trusted access point has now conformed to the configured policy.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

**TRUSTED_AP_MISSING**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTrustedApIsMissing.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Trusted AP &quot;{0}&quot; is missing or has failed.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The wireless system no longer detects a trusted access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A trusted access point has left the network or has failed.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Track down the trusted access point and take the appropriate action.</td>
</tr>
</tbody>
</table>

**TRUSTED_AP_MISSING_CLEAR**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTrustedApIsMissing (bsnClearTrapVariable set to true).</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Trusted AP &quot;{0}&quot; is missing or has failed. The alert state is clear now.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system has found a trusted access point again.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The system has detected a previously missing trusted access point.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### Traps Added in Release 2.2

**AP_IMPERSONATION_DETECTED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPImpersonationDetected.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP Impersonation with MAC &quot;{0}&quot; is detected by authenticated AP &quot;{1}&quot; on &quot;{2}&quot; radio and Slot ID &quot;{3}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio of an authenticated access point has heard from another access point whose MAC address neither matches that of a rogue nor is it an authenticated neighbor of the detecting access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A severity breach related to access point impersonation may be under way.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Track down the MAC address of the impersonating access point in the network and contain it.</td>
</tr>
</tbody>
</table>

**AP_RADIO_CARD_RX_FAILURE**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPRadioCardRxFailure.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Receiver failure detected on the &quot;{0}&quot; radio of AP &quot;{1}&quot; on Switch &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio card is unable to receive data.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
</tbody>
</table>
| Probable Causes           | • A radio card is experiencing reception failure.  
• The antenna of the radio is disconnected. |
| Recommended Actions       | • Check the access point’s antenna connection.  
• Call customer support. |

**AP_RADIO_CARD_RX_FAILURE_CLEAR**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPRadioCardRxFailureClear.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Receiver failure cleared on the &quot;{0}&quot; radio of AP &quot;{1}&quot; on Switch &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio is no longer experiencing reception failure.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A malfunction in the access point has been corrected.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### AP_RADIO_CARD_TX_FAILURE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPRadioCardTxFailure.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Transmitter failure detected on the &quot;{0}&quot; radio of AP &quot;{1}&quot; on Switch &quot;.{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio card is unable to transmit.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
</tbody>
</table>
| Probable Causes           | • A radio card is experiencing transmission failure.  
                            • The antenna of the radio may be disconnected. |
| Recommended Actions       | • Check the antenna of the access point.  
                            • Call customer support. |

### AP_RADIO_CARD_TX_FAILURE_CLEAR

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPRadioCardTxFailureClear.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Transmitter failure cleared on the &quot;{0}&quot; radio of AP &quot;{1}&quot; on Switch &quot;.{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio is no longer experiencing transmission failure.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A malfunction in the access point has been corrected.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### SIGNATURE_ATTACK_CLEARED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnSignatureAttackDetected (bsnClearTrapVariable is set to True).</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Switch &quot;{0}&quot; is cleared from IDS signature attack. The wireless system is no longer detecting the intrusion.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The switch (controller) no longer detects a signature attack.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The signature attack that the system previously detected has stopped.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
**SIGNATURE_ATTACK_DETECTED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnSignatureAttackDetected</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>IDS Signature attack detected on Switch &quot;{0}&quot;. The Signature Type is &quot;{1}&quot;, Signature Name is &quot;{2}&quot;, and Signature description is &quot;{3}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The switch (controller) is detecting a signature attack. The switch (controller) has a list of signatures that it monitors. When it detects a signature, it provides the name of the signature attack in the alert it generates.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Someone is mounting a malevolent signature attack.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Track down the source of the signature attack in the wireless network and take the appropriate action.</td>
</tr>
</tbody>
</table>

**TRUSTED_AP_HAS_INVALID_PREAMBLE**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTrustedApHasInvalidPreamble</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Trusted AP &quot;{0}&quot; on Switch &quot;{3}&quot; has invalid preamble. It is using &quot;{1}&quot; instead of &quot;{2}&quot;. It has been auto contained as per WPS policy.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system has contained a trusted rogue access point for using an invalid preamble.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The system has detected a possible severity breach because a rogue is transmitting an invalid preamble.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Locate the rogue access point using location features or the access point detecting it and take the appropriate actions.</td>
</tr>
</tbody>
</table>

**TRUSTED_HAS_INVALID_PREAMBLE_CLEARED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTrustedApHasInvalidPreamble (bsnClearTrapVariable is set to true).</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Trusted AP &quot;{0}&quot; on Switch &quot;{3}&quot; had invalid preamble. The alert state is clear now.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system has cleared a previous alert about a trusted access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The system has cleared a previous alert about a trusted access point.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
Traps Added in Release 3.0

**AP_FUNCTIONALITY_DISABLED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPFunctionalityDisabled.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP functionality has been disabled for key &quot;{0},&quot; reason being &quot;{1}&quot; for feature-set &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system sends this trap out when the controller disables access point functionality because the license key has expired.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>When the controller boots up, it checks whether the feature license key matches the controller’s software image. If it does not, the controller disables access point functionality.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Configure the correct license key on the controller and reboot it to restore access point functionality.</td>
</tr>
</tbody>
</table>

**AP_IP_ADDRESS_FALLBACK**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPIPAddressFallback.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0}&quot; with static-ip configured as &quot;{2}&quot; has fallen back to the working DHCP address &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This trap is sent out when an access point, with the configured static ip-address, fails to establish connection with the outside world and starts using DHCP as a fallback option.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>If the configured IP address on the access point is incorrect or obsolete, and if the AP Fallback option is enabled on the switch (controller), the access point starts using DHCP.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Reconfigure the access point’s static IP to the correct IP address if desired.</td>
</tr>
</tbody>
</table>
### AP_REGULATORY_DOMAIN_MISMATCH

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPRegulatoryDomainMismatch.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{1}&quot; is unable to associate. The Regulatory Domain configured on it &quot;{3}&quot; does not match the Controller &quot;{0}&quot; country code &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system generates this trap when an access point’s regulatory domain does not match the country code configured on the controller. Due to the country code mismatch, the access point will fail to associate with the controller.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
</tbody>
</table>
| Probable Causes               | • If someone changes the controller’s country code configuration and some of the existing access points support a different country code, these access points fail to associate.  
• An access point on the controller’s network sends join requests to the controller, but the regulatory domain is outside the domain in which the controller is operating. |
| Recommended Actions           | Either remove the access points that are not meant for inclusion in the controller’s domain or correct the controller’s country code setting. |

### RX_MULTICAST_QUEUE_FULL

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRxMulticastQueueFull.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>CPU Receive Multicast Queue is full on Controller &quot;{0}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This trap indicates that the CPU’s Receive Multicast queue is full.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>An ARP storm.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
# Traps Added in Release 3.1

## AP_AUTHORIZATION_FAILURE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPAuthorizationFailure</th>
</tr>
</thead>
</table>
| WCS Message    | - Failed to authorize AP “{0}.” Authorization entry does not exist in Controllers “{1}” AP Authorization List.  
- Failed to authorize AP “{0}.” AP’s authorization key does not match with SHA1 key in Controllers “{1}” AP Authorization List.  
- Failed to authorize AP “{0}.” Controller “{1}” could not verify the Self Signed Certificate from the AP.  
- Failed to authorize AP “{0}.” AP has a self signed certificate where as the Controllers “{1}” AP authorization list has Manufactured Installed Certificate for this AP. |
| Symptoms       | An alert is generated when an access point fails to associate with a controller due to authorization issues. |
| WCS Severity   | Critical                  |
| Probable Causes| - The access point is not on the controller’s access point authorization list.  
- The key entry in the controller's access point authorization list does not match the SHA1 key received from the access point.  
- The access point self-signed certificate is not valid.  
- The access point has a self-signed certificate and the controller’s access point authorization list (for the given access point) references a manufactured installed certificate. |
| Recommended Actions | - Add the access point to the controller’s authorization list.  
- Update the access point’s authorization key to match the controller’s access point key.  
- Check the accuracy of the access point’s self-signed certificate.  
- Check the certificate type of the access point in the controller’s access point authorization list. |

## HEARTBEAT_LOSS_TRAP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>heartbeatLossTrap.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Keepalive messages are lost between Master and Controller“{0}.”</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This trap is generated when the controller loses connection with the Supervisor Switch (in which it is physically embedded) and the controller cannot hear the heartbeat (keepalives) from the Supervisor.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
</tbody>
</table>
| Probable Causes| - Port on the WiSM controller could be down.  
- Loss of connection with the Supervisor Switch. |
| Recommended Actions | None.               |
### INVALID_RADIO_INTERFACE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>invalidRadioTrap.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Radio with MAC address “{0}” and protocol “{1}” that has joined controller “{2}” has invalid interface. The reason is “{3}.”</td>
</tr>
<tr>
<td>Symptoms</td>
<td>If a Cisco access point joins the network but has unsupported radios, the controller detects this and generates a trap. This symptom propogates an alert in WCS.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The radio hardware is not supported by the controller.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### RADAR_CLEARED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRadarChannelCleared</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Radar has been cleared on channel ”{1}” which was detected by AP base radio MAC ”{0}” on radio 802.11a/n.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>Trap is generated after the expiry of a non-occupancy period for a channel that previously generated a radar trap.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Trap is cleared on a channel.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### RADAR_DETECTED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRadarChannelDetected</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Radar has been detected on channel ”{1}” by AP base radio MAC ”{0}” on radio 802.11a/n.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This trap is generated when radar is detected on the channel on which an access point is currently operating.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Radar is detected on a channel.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### RADIO_CORE_DUMP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>radioCoreDumpTrap</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Radio with MAC address “{0}” and protocol “{1}” has core dump on controller “{2}.”</td>
</tr>
<tr>
<td>Symptoms</td>
<td>When a Cisco radio fails and a core dump occurs, the controller generates a trap and WCS generates an event for this trap.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Radio failure.</td>
</tr>
<tr>
<td>------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Capture the core dump file using the controller’s command-line interface and send to TAC support.</td>
</tr>
</tbody>
</table>
## RADIO_INTERFACE_DOWN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPIfDown.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Radio with MAC address “{0}” and protocol “{1}” is down. The reason is “{2}.”</td>
</tr>
<tr>
<td>Symptoms</td>
<td>When a radio interface is down, WCS generates an alert. Reason for the radio outage is also noted.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical if not manually disabled. Informational if radio interface was manually disabled.</td>
</tr>
</tbody>
</table>
| Probable Causes    | • The radio interface has failed.  
                      • The access point cannot draw enough power.  
                      • The maximum number of transmissions for the access point is reached.  
                      • The access point has lost connection with the controller heart beat.  
                      • The admin status of the access point admin is disabled.  
                      • The admin status of the radio is disabled. |
| Recommended Actions| None.                                            |

## RADIO_INTERFACE_UP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPIfUp.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Radio with MAC address “{0}” and protocol “{1}” is up. The reason is “{2}.”</td>
</tr>
<tr>
<td>Symptoms</td>
<td>When a radio interface is operational again, WCS clears the previous alert. Reason for the radio being up again is also noted.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
</tbody>
</table>
| Probable Causes    | • Admin status of access point is enabled.  
                      • Admin status of radio is enabled.  
                      • Global network admin status is enabled. |
| Recommended Actions| None.                                            |

## UNSUPPORTED_AP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>unsupportedAPTrap.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP “{0}” tried to join controller “{1}” and failed. The controller does not support this kind of AP.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>When unsupported access points try to join 40xx/410x controllers or 3500 controller with 64 MB flash, these controllers generate a trap, and the trap is propagated as an event in WCS.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Access point is not supported by the controller.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
## Traps Added in Release 3.2

### LOCATION_NOTIFY_TRAP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>locationNotifyTrap.</th>
</tr>
</thead>
</table>
| WCS Message | Depending on the notification condition reported, the trap is sent out in an XML format and is reflected in WCS with the following alert messages:  
- Absence of `<Element>` with MAC `<macAddress>`, last seen at `<timestamp>`.  
- `<Element>` with MAC `<macAddress>` is `<In | Out> the Area `<campus | building | floor | coverageArea>`.  
- `<Element>` with MAC `<macAddress>` has moved beyond `<specifiedDistance> ft. of marker `<MarkerName>`, located at a range of `<foundDistance> ft.  
For detailed info on the XML format for the trap content, consult the 2700 Location Appliance Configuration Guide. |

### Symptoms

A 2700 location appliance sends this trap out when the defined location notification conditions are met (such as element outside area, elements missing, and elements exceeded specified distance). WCS uses this trap to display alarms about location notification conditions.

### WCS Severity

Minor (under the Location Notification dashboard).

### Probable Causes

The location notification conditions configured for a 2700 location appliance are met for certain elements on the network.

### Recommended Actions

None.
Traps Added In Release 4.0

**CISCO_LWAPP_MESH_POOR_SNR**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CiscoLwappMeshPoorSNR</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Poor SNR.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>SNR (signal-to-noise) ratio is important because high signal strength is not enough to ensure good receiver performance. The incoming signal must be stronger than any noise or interference that is present. For example, you can have high signal strength and still have poor wireless performance if there is strong interference or a high noise level.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The link SNR fell below 12 db. The threshold level cannot be changed. If poor SNR is detected on the backhaul link for a child or parent, the trap is generated and contains SNR values and MAC addresses.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

**CISCO_LWAPP_MESH_PARENT_CHANGE**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CiscoLwappMeshParentChange</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Parent changed.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>When the parent is lost, the child joins with another parent, and the child sends traps containing both old and new parent’s MAC addresses.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The child moved to another parent.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

**CISCO_LWAPP_MESH_CHILD_MOVED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CiscoLwappMeshChildMoved</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Child moved.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>When the parent access point detects a child being lost and communication is halted, the child lost trap is sent to WCS, along with the child MAC address.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The child moved from the parent.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### CISCO_LWAPP_MESH_CONSOLE_LOGIN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappMeshConsoleLogin</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Console login successful or failed.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The console port provides the ability for the customer to change the user name and password to recover the stranded outdoor access point. To prevent any unauthorized user access to the access point, WCS sends an alarm when someone tries to log in. This alarm is required to provide protection because the access point is physically vulnerable being located outdoors.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>A login is of critical severity.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>You have successfully logged in to the access point console port or failed on three consecutive tries.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### CISCO_LWAPP_MESH_AUTHORIZATION_FAILURE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappMeshAuthorizationFailure</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Fails to authenticate with controller.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>WCS receives a trap from the controller. The trap contains the MAC addresses of those access points that failed authorization.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The access point tried to join the MESH but failed to authenticate because the MESH node MAC address was not on the MAC filter list.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### EXCESSIVE_ASSOCIATION

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappMeshExcessiveAssociationFailure</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Excessive association failures.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This trap is raised after a failed-association-attempt exceeds the threshold (which is not user configurable). Association failures are cumulative of the total failures from different MAPs. The trap sent by the controller contains the MAC address of the access point on which the association failed and the number of association failures.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The controller encountered excessive association failures.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### CISCO_LWAPP_MESH_PARENT_EXCLUDED_CHILD

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappMeshParentExcludedChild</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Excluded by parent AP due to failed authentication.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>When a child keeps failing authentication at the controller, the parent can mark that child for exclusion. The child cannot associate with the parent during this exclusion period. The trap contains the excluded child MAC address.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A parent marked a child for exclusion.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### CISCO_LWAPP_MESH_CHILD_EXCLUDED_PARENT

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappMeshChildExcludedParent</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Parent AP being excluded by child AP.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>When a child fails authentication at the controller after a fixed number of attempts, the child can exclude that parent. The child remembers the excluded parent so that when it joins the network, it sends the trap which contains the excluded parent MAC address and the duration of the exclusion period.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A child marked a parent for exclusion.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### CISCO_LWAPP_MESH_EXCESSIVE_PARENT_CHANGE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappMeshExcessiveParentChange</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Parent changed frequently.</td>
</tr>
</tbody>
</table>
### IDS_SHUN_CLIENT_TRAP

<table>
<thead>
<tr>
<th>Symptoms</th>
<th>When MAP parent-change-counter exceeds the threshold within a given duration, it sends a trap to WCS. The trap contains the number of times the MAP changes and the duration of the time. The threshold is user configurable.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The MESH access point changed its parent frequently.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

#### MIB Name
CISCO-LWAPP-IDS-MIB. CLIdsNewShunClient.

#### WCS Message
The Cisco Intrusion Detection System "{0}" has detected a possible intrusion attack by the wireless client "{1}".

#### Symptoms
This trap is generated in response to a shun client clear alert originated from a Cisco IDS/IPs appliance ("{0}") installed in the data path between the wireless client ("{1}") and the site's intranet.

#### WCS Severity
Critical.

#### Probable Causes
The designated client is generating a packet-traffic pattern which shares properties with a well-known form of attack on the customer's network.

#### Recommended Actions
Investigate the designated client and determine if it is an intruder, a virus, or a false alarm.
IDS_SHUN_CLIENT_CLEAR_TRAP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-IDS-MIB. cLIdsNewShunClientClear.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>The Cisco Intrusion Detection System &quot;{0}&quot; has cleared the wireless client &quot;{1}&quot; from possibly having generated an intrusion attack.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This trap is generated is response to one of two things: 1) a shun client clear alert originated from a Cisco IDS/IPS appliance (&quot;{0}&quot;) installed in the data path between the wireless client (&quot;{1}&quot;) and the site’s intranet, or 2) a scheduled timeout of the original IDS_SHUN_CLIENT_TRAP for the wireless client.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The designated client is no longer generating a suspicious packet-traffic pattern.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

MFP_TIMEBASE_STATUS_TRAP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MFP-MIB. ciscoLwappMfpTimebaseStatus.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Controller &quot;{0}&quot; is &quot;{1}&quot; with the Central time server.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is sent by the agent to indicate when the synchronization of the controller’s time base with the Central time base last occurred.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical (not in sync trap) and clear (sync trap).</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The controller’s time base is not in sync with the Central time base.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### MFP_ANOMALY_DETECTED_TRAP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MFP-MIB. ciscoLwappMfpAnomalyDetected.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>MFP configuration of the WLAN was violated by the radio interface &quot;{0}&quot; and detected by the radio interface &quot;{1}&quot; of the access point with MAC address &quot;{2}&quot;. The violation is &quot;{3}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is sent by the agent when the MFP configuration of the WLAN was violated by the radio interface cLApIfSmtDot11Bssid and detected by the radio interface cLApDot11IfSlotId of the access point cLApSysMacAddress. This violation is indicated by cLMfpEventType. When observing the management frame(s) given by cLMfpEventFrames for the last cLMfpEventPeriod time units, the controller reports the occurrence of a total of cLMfpEventTotal violation events of type cLMfpEventType. When the cLMfpEventTotal is 0, no further anomalies have recently been detected, and the NMS should clear any alarm raised about the MFP errors.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The MFP configuration of the WLAN was violated. Various types of violations are invalidMic, invalidSeq, noMic, and unexpectedMic.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### GUEST_USER_REMOVED_TRAP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-WEBAUTH-MIB. cLWAGuestUserRemoved.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Guest user &quot;{1}&quot; deleted on controller &quot;{0}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated when the lifetime of the guest user {1} expires and the guest user’s accounts are removed from the controller &quot;{0}&quot;.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>GuestUserAccountLifetime expired.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
Traps Added or Updated in Release 4.0.96.0

**AP_IMPERSONATION_DETECTED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPImpersonationDetected.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP Impersonation with MAC &quot;{}&quot; using source MAC &quot;{}&quot; is detected by authenticated AP &quot;{}&quot; on &quot;{}&quot; radio and slot ID &quot;{}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio of an authenticated access point had communication with another access point whose MAC address neither matches that of a rogue nor is an authenticated neighbor of the detecting access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A security breach related to access point impersonation may be occurring.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Track down the MAC address of the impersonating access point and contain it.</td>
</tr>
</tbody>
</table>

**RADIUS_SERVER_DEACTIVATED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappAAARadiusServerGlobalDeactivated.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RADIUS server &quot;{}&quot; (port {}) is deactivated.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The controller detects that the RADIUS server is deactivated in the global list.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>RADIUS server is deactivated in the global list.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

**RADIUS_SERVER_ACTIVATED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappAAARadiusServerGlobalDeactivated.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RADIUS server &quot;{}&quot; (port {}) is activated.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The controller detects that the RADIUS server is deactivated in the global list.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>RADIUS server is deactivated in the global list.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
**RADIUS_SERVER_WLAN_DEACTIVATED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-AAA-MIB. ciscoLwappAAARadiusServerWlanDeactivated.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RADIUS server &quot;{0}&quot; (port {1}) is deactivated on WLAN &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The controller detects that the RADIUS server is deactivated on the WLAN.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>RADIUS server is deactivated on the WLAN.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

**RADIUS_SERVER_WLAN_ACTIVATED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-AAA-MIB. ciscoLwappAAARadiusServerWlanActivated.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RADIUS server &quot;{0}&quot; (port {1}) is activated on WLAN &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The controller detects that the RADIUS server is activated on the WLAN.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>RADIUS server is activated on the WLAN.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

**RADIUS_SERVER_TIMEOUT**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-AAA-MIB. ciscoLwappAAARadiusReqTimedOut.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RADIUS server &quot;{0}&quot; (port {1}) failed to respond to request from client &quot;{2}&quot; with MAC &quot;{3}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The controller detects that the RADIUS server failed to respond to a request from a client or user.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>RADIUS server fails to process the request from the client or user.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

**DECRYPT_ERROR_FOR_WRONG_WPA_WPA2**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-DOT11-CLIENT-MIB. CiscoLwappDot11ClientKeyDecryptError.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Decrypt error occurred at AP with MAC &quot;{0}&quot; running TKIP with wrong WPA/WPA2 by client with MAC &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The controller detects that a user is trying to connect with an invalid security policy for WPA/WPA2 types.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The user failed to authenticate and join the controller.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### Traps Added or Updated in Release 4.1

**AP_IMPERSONATION_DETECTED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPImpersonationDetected.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP impersonation of MAC &quot;{0}&quot; using source MAC &quot;{1}&quot; is detected by an authenticated AP &quot;{2}&quot; on &quot;{3}&quot; radio and slot ID &quot;{4}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio of an authenticated access point received signals from another access point whose MAC address neither matches that of a rogue nor is an authenticated neighbor of the detecting access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A security breach related to access point impersonation has occurred.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Track down the MAC address of the impersonating access point and contain it.</td>
</tr>
</tbody>
</table>

**INTERFERENCE_DETECTED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>COGNIO-TRAPS-MIB.cognioInterferenceDetected.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Interference detected by type {0} with power {1}.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A Cognio spectrum agent detected interference over its configured thresholds.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Excessive wireless interference or noise.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

**INTERFERENCE_CLEAR**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>COGNIO-TRAPS-MIB.cognioInterferenceClear</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Interference cleared.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The Cognio spectrum expert agent no longer detects an interference source over its configured threshold.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Previous excessive wireless interference or noise is gone.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### ONE_ANCHOR_ON_WLAN_UP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MOBILITY-MIB. ciscoLwappMobilityOneAnchorOnWlanUp.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Controller &quot;{0}&quot;. An anchor of WLAN &quot;{1}&quot; is up.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>Successive EoIP and UDP ping to at least one anchor on the WLAN is up.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>At least one anchor is reachable from an EoIP/UDP ping.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### RADIUS_SERVER_DEACTIVATED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-AAA-MIB. ciscoLwappAAARadiusServerGlobalDeactivated.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RADIUS server &quot;{0}&quot; (port {1}) is deactivated.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The controller detects that the RADIUS server is deactivated in the global list.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>RADIUS server is deactivated in the global list.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### RADIUS_SERVER_ACTIVATED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-AAA-MIB. ciscoLwappAAARadiusServerGlobalActivated.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RADIUS server &quot;{0}&quot; (port {1}) is activated.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The controller detects that the RADIUS server is activated in the global list.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>RADIUS server is activated in the global list.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### RADIUS_SERVER_WLAN_DEACTIVATED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-AAA-MIB. ciscoLwappAAARadiusServerWlanDeactivated.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RADIUS server &quot;{0}&quot; (port {1}) is deactivated on WLAN &quot;{2}&quot;</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The controller detects that the RADIUS server is deactivated on the WLAN.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>RADIUS server is deactivated on the WLAN.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
## RADIUS_SERVER_WLAN_ACTIVATED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-AAA-MIB. ciscoLwappAAARadiusServerGlobalWlanActivated.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RADIUS server &quot;{0}&quot; (port {1}) is activated on WLAN &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The controller detects that the RADIUS server is activated on the WLAN.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>RADIUS server is activated on the WLAN.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## RADIUS_SERVER_TIMEOUT

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-AAA-MIB. ciscoLwappAAARadiusReqTimedOut.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RADIUS server &quot;{0}&quot; (port {1}) failed to respond to request from client &quot;{2}&quot; with MAC &quot;{3}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The controller detects that the RADIUS server failed to respond to a request from the client or user.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The RADIUS server fails to process the request from a client or user.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## MOBILITY_ANCHOR_CTRL_PATH_DOWN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MOBILITY-MIB. ciscoLwappMobilityAnchorControlPathDown.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Controller &quot;{0}&quot;. Control path on anchor &quot;{1}&quot; is down.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>When successive ICMP ping attempts to the anchor fails, the anchor is conclusively down.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Anchor not reachable by ICMP ping.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## MOBILITY_ANCHOR_CTRL_PATH_UP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MOBILITY-MIB. ciscoLwappMobilityAnchorControlUp.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Controller &quot;{0}&quot;. Control path on anchor &quot;{1}&quot; is up.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The ICMP ping to the anchor is restored, and the anchor is conclusively up.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The anchor is reachable by an ICMP ping.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
## MOBILITY_ANCHOR_DATA_PATH_DOWN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MOBILITY-MIB. ciscoLwappMobilityAnchorDataPathDown.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Controller &quot;{0}&quot;. Data path on anchor &quot;{1}&quot; is down.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>Successive EoIP ping attempts to the anchor fails, and the anchor is conclusively down.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The anchor is not reachable by an EoIP ping.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## MOBILITY_ANCHOR_DATA_PATH_UP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MOBILITY-MIB. ciscoLwappMobilityAnchorDataPathUp.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Controller &quot;{0}&quot;. Data path on anchor &quot;{1}&quot; is up.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The EoIP ping to the anchor is restored, and the anchor is conclusively up.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Anchor is reachable by the EoIP ping.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## WLAN_ALL_ANCHORS_TRAP_DOWN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MOBILITY-MIB. ciscoLwappMobilityAllAnchorsOnWlanDown.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Controller &quot;{0}&quot;. All anchors of WLAN &quot;{1}&quot; are down.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>Successive EoIP ping attempts to all the anchors on WLAN is occurring.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Anchors are not reachable by the EoIP ping.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### MESH_AUTHORIZATIONFAILURE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MESH-MIB. ciscoLwappMeshAuthorizationFailure.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>MESH &quot;{0}&quot; fails to authenticate with controller because &quot;{1}&quot;</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A mesh access point failed to join the mesh network because its MAC address is not listed in the MAC filter list. The alarm includes the MAC address of the mesh access point that failed to join.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The mesh node MAC address is not in the MAC filter list, or a security failure from the authorization server occurred.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### MESH_CHILDEXCLUDEDPARENT

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MESH-MIB. ciscoLwappMeshChildExcludedParent.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Parent AP being excluded by child AP due to failed authentication, AP current parent MAC address &quot;{0},&quot; previous parent MAC address &quot;{1}&quot;</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is sent by the agent when the child access point marks a parent access point for exclusion. When the child fails to authenticate at the controller after a fixed number of times, the child marks the parent for exclusion. The child remembers the excluded MAC address and informs the controller when it joins the network. The child access point marks the MAC address and excludes it for the time determined by MAP node so that it does not try to join this excluded node. The child MAC address is sent as part of the index.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The child access point failed to authenticate to the controller after a fixed number of times.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### MESH_PARENTCHANGE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MESH-MIB. ciscoLwappMeshParentChange.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>MESH &quot;{0}&quot; changed its parent. AP current parent MAC address &quot;{1},&quot; previous parent MAC address &quot;{2}&quot;</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is sent by the agent when a child moves to another parent. The alarm includes the MAC addresses of the former and current parents.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The child access point has changed its parent.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### MESH_CHILDMOVED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MESH-MIB. ciscoLwappMeshChildMoved.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Parent AP lost connection to this AP. AP neighbor type is &quot;{0}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is sent by the agent when the parent access point loses connection with its child.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The parent access point lost connection with its child.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### MESH_EXCESSIVEPARENTCHANGE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MESH-MIB. ciscoLwappMeshExcessiveParentChange.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>MESH &quot;{0}&quot; changes parent frequently.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is sent by the agent if the number of parent changes for a given mesh access point exceeds the threshold. Each access point keeps count of the number of parent changes within a fixed time. If the count exceeds the threshold defined by c1MeshExcessiveParentChangeThreshold, then the child access point informs the controller.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The child access point has frequently changed its parent.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### MESH_POORSNR

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MESH-MIB. ciscoLwappMeshPoorSNR.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>MESH &quot;{0}&quot; has SNR on backhaul link as &quot;{1}&quot; which is lower then predefined threshold.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is sent by the agent when the child access point detects a signal-to-noise ratio below 12dB the backhaul link. The alarm includes the SNR value and the MAC addresses of the parent and child.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>SNR is lower then the threshold defined by c1MeshSNRThreshold.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### MESH_POORSNRCLEAR

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MESH-MIB. ciscoLwappMeshPoorSNRClear.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>MESH &quot;{0}&quot; has SNR on backhaul link as &quot;{1}&quot; which is normal now.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is sent by the agent to clear ciscoLwappMeshPoorSNR when the child access point detects SNR on the backhaul link that is higher than the threshold defined by c1MeshSNRThreshold.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>SNR on the backhaul link is higher than the threshold defined by c1MeshSNRThreshold.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### MESH_CONSOLELOGIN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MESH-MIB. ciscoLwappMeshConsoleLogin.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>MESH &quot;{0}&quot; has console logged in with status &quot;{1}&quot;</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is sent by the agent when login on the MAP console is successful or when a failure occurred after three attempts.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Login on the MAP console was successful, or a failure occurred after three attempts.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### LRADIF_REGULATORY_DOMAIN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappApIfRegulatoryDomainMismatchNotif</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Access Point &quot;{0}&quot; is unable to associate. The Regulatory Domain &quot;{1}&quot; configured on interface &quot;{2}&quot; does not match the controller &quot;{3}&quot; regulatory domain &quot;{4}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system generates this trap when the regulatory domain configured on the access point radios does not match the country code configured on the controller.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>If the controller’s country code configuration is changed, and some access points support a different country code, then these access points fail to associate. An access point on the controller’s network sends join requests to the controller, but the regulatory domain is outside the domain in which the controller is operating.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Either remove the access points that are not meant for inclusion in the controller’s domain or correct the controller’s country code setting.</td>
</tr>
</tbody>
</table>
### LRAD_CRASH

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappApCrash</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Access Point &quot;{0}&quot; crashed and has a core dump on controller &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>An access point has crashed.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Access point failure.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Capture the core dump file using the controller’s CLI and send it to TAC support.</td>
</tr>
</tbody>
</table>

### LRAD_UNSUPPORTED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappApUnsupported</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Access Point &quot;{0}&quot; tried to join controller &quot;{1}&quot; and failed. Associate failure reason &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>An access point tried to associate to a controller to which it is not supported.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The access point is not supported by the controller.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### Traps Added or Updated in Release 4.2

#### GUEST_USER_ADDED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-WEBAUTH-MIB. cLWAGuestUserAdded</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Guest user &quot;{0}&quot; created on the controller &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is sent by the agent when the GuestUser account is created successfully.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The guest user account was created on the agent by either CLI, Web UI, or WCS.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
## GUEST_USER_AUTHENTICATED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-WEBAUTH-MIB. cLWAGuestUserLogged</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Guest user &quot;{0}&quot; logged into controller &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is sent by the agent when the GuestUser logged into the network through webauth successfully.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The guest user was successful with webauth authentication.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## IOSAP_LINK_UP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>linkUp</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Autonomous AP &quot;{0},&quot; Interface &quot;{1}&quot; is {2} up.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The physical link is up on an autonomous access point radio port.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A physical link has been restored to the autonomous access point.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## IOSAP_LINK_DOWN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>linkDown</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Autonomous AP &quot;{0},&quot; Interface &quot;{1}&quot; is {2} down.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The physical link is down on an autonomous access point radio port.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The radio port of an autonomous access point was disabled manually or a port failure occurred.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Check the administrative status of the port. If the port administrative status is not down, check other port settings.</td>
</tr>
</tbody>
</table>
### IOSAP_UP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>The autonomous AP &quot;{0}&quot; is reachable.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The autonomous AP is SNMP reachable.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The autonomous access point starts to respond to SNMP queries.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### IOSAP_DOWN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Autonomous AP &quot;{0}&quot; is unreachable.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The autonomous AP is SNMP unreachable.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
</tbody>
</table>
| Probable Causes | • Network connectivity to the autonomous access point is broken.  
                  • Ethernet port of the autonomous access point is down.  
                  • SNMP agent is not running in the autonomous access point.  
                  • SNMP credentials on the WCS do not match the SNMP credentials configured on the autonomous access point.  
                  • SNMP version on the WCS does not match the SNMP version configured on the autonomous access point. |
| Recommended Actions | First, check the IP connectivity to the access point. Next, check the port status of the access point. Finally, check SNMP credentials on both the WCS and the access point. |

### WCS_EMAIL_FAILURE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>WCS with IP Address &quot;{0}&quot; failed to send e-mail.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS when it fails to send e-mails.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The SNMP server is either not configured or not reachable from WCS.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Check Administration &gt; Settings &gt; Mail Server settings. Send a test e-mail from the mail server settings to see if it is successful.</td>
</tr>
</tbody>
</table>
### AUDIT_STATUS_DIFFERENCE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Switch {0} Audit done at {1}. Config differences found between WCS and controller.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS when audit differences are detected while auditing a controller during a network audit background task or per controller audit.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The WCS and controller configuration are not synchronized.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Refresh the configuration from the controller so that it synchronizes with the controller configuration on WCS.</td>
</tr>
</tbody>
</table>

### LRAD_POE_STATUS

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappApPower</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Access point {0} draws low power from Ethernet. Failure reason: {1}</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated when the access point draws low power from the Ethernet connection.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The access point receives low power from the Ethernet connection.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Check the power status of the access point and the device connected to the access point.</td>
</tr>
</tbody>
</table>

### ROGUE_AP_NOT_ON_NETWORK

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRogueAPDetectedOnWiredNetwork (bsnRogueAPOnWiredNetwork is set to false).</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Rogue AP or ad hoc rogue {0} is not able to connect to the wired network.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A rogue access point is no longer on the wired network.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The rogue access point is no longer reachable on the wired network.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
Traps Added or Updated in Release 5.0

**GUEST_USER_LOGOFF**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-WEBAUTH-MIB. cLWAGuestUserLoggedOut</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Guest user “{1}” logged out from the controller “{0}.”</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is sent by the agent when a GuestUser who was previously logged into the network logs out.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The GuestUser logs off from the network.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

**WCS_NOTIFICATION_FAILURE**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>WCS with IP Address “{0}” failed to send notification.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS when a notification sent to a northbound receiver fails. Currently only guest user related notifications (such as creation, deletion, log in, and log off) can be sent to a northbound receiver.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The notification receiver is either not configured or not reachable from WCS.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Check Administration &gt; Settings &gt; Notification Receiver settings. Make sure the server IP is correct, and the server is reachable from WCS.</td>
</tr>
</tbody>
</table>

**WCS_LOW_DISK_SPACE**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>WCS “{0}” does not meet the minimum hardware requirements for disk space. Available: “{3}.” Minimum requirement: “{4}” Mb.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS when the free disk space where WCS is installed does not meet minimum hardware requirements. This event is of major severity if minimum requirements are not met. This event is of critical severity when the available disk space is less than half of the minimum requirement.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major/Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The disk is out of free space.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Free up disk space.</td>
</tr>
</tbody>
</table>
### WCS_OK_DISK_SPACE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>WCS &quot;{0}&quot; meets the minimum hardware requirements for disk space. Available: &quot;{3}&quot;. Minimum requirement: &quot;{4}&quot; Mb.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS when the free disk space where WCS is installed has met the minimum hardware requirements.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A low disk space condition has been cleared.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### WCS_LOW_DISK_SPACE_BACKUP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>WCS &quot;{0}&quot; does not have sufficient disk space in directory &quot;{1}&quot; for backup. Space needed: &quot;{2}&quot;. space free: &quot;{3}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS when a previously created WCS_LOW_DISK_SPACE_BACKUP event is cleared or when the disk contains enough space for a backup.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A low disk space condition has been cleared.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### STATION_ASSOCIATE_DIAG_WLAN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-DOT11-CCX-CLIENT-MIB.cldccDiagClientAssociatedToDiagWlan</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Client &quot;{0}&quot; is associated to diagnostic WLAN with reason &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is sent by the agent when a v5 client associates to a diagnostic channel.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>When a CCXv5 client gets associated to the diagnostic channel WLAN on WLC, this trap is raised.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>If you wish to automatically perform client troubleshooting, you must enable Client Troubleshooting in Administration &gt; Settings &gt; client. After it is enabled, the series of V5 tests are carried out on the client upon trap arrival, and the client is updated with the test status via pop-up messages. The report is placed in the logs directory. The log filename is shown in the Client Details page in the Automated Troubleshooting Report section. You can export all automated troubleshooting logs.</td>
</tr>
</tbody>
</table>
## WLAN_SHUT_FAILED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Wlan “[0]” shutdown failed on controller “[1].”</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS during scheduled operations for a given WLAN Config object. It notifies the user that the WLAN status did not change at the scheduled time.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The controller for the selected WLAN is not reachable, or the WLAN object does not exist.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Check the WCS logs at the time of event generation and verify if the WLAN exists on the controller.</td>
</tr>
</tbody>
</table>

## WLAN_SHUT_SUCCESS

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Wlan “[0]” successfully shutdown on controller “[1].”</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS during scheduled operation for each given WLAN configuration object. It notifies the user that the admin status has been successfully completed.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Verify the admin status for the displayed WLAN on the controller.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Remove the event from the event list page.</td>
</tr>
</tbody>
</table>
### RADIO_SHUT_FAILED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Radio shutdown failed for AP “{0}” connected to controller “{1}.”</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS during a scheduled operation for a given list of access point radios. It notifies the user that the status for certain radios has failed to change.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The controllers for the selected access point are not reachable, or the radio configurations are changed on the controller.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Check the WCS logs at the time of event generation and verify that the access point is associated with the controller.</td>
</tr>
</tbody>
</table>

### RADIO_SHUT_SUCCESS

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Radio successfully shutdown for AP “{0}” connected to controller “{1}.”</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS during scheduled operation for a given list of access point radios. It notifies the user that the admin status has been successfully changed.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>None.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Verify the status of the specified radio on the controller.</td>
</tr>
</tbody>
</table>
Traps Added or Updated in Release 5.1

**CONFIGAUDITSET_ENFORCEMENT_SUCCESS**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Successfully enforced Config Group “0” on controllers “1.”</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS during network audit when all the templates from the config group (which are opted to be enforced) are successfully enforced.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The config group (which are opted to be enforced) templates are not in sync with the device values.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Look at the controller audit report for the list of enforced values. An alarm is cleared when no enforcements are found during the next network audit cycle.</td>
</tr>
</tbody>
</table>

**CONFIGAUDITSET_ENFORCEMENT_FAIL**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Failed to enforce Config Group “0” on controllers “1.”</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS during network audit when some failures are encountered during enforcement of the templates from the config groups (which as opted to be enforced).</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The config group (which are opted to be enforced) templates are not in sync with the device values.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Look at the controller audit report for the list of enforced values and for the failed enforcements. An alarm is cleared upon successful enforcements during the next network audit cycle.</td>
</tr>
</tbody>
</table>

Traps Added or Updated in Release 6.0

**STATION_AUTHENTICATED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappDot11ClientMovedToRunState</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Client “[0]” is authenticated with interface “[2]” of AP “[1].”</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A client has completed a security policy and has moved to Run state. It can start to send or receive data.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A client has completed security policy and moved to Run state.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### WCS_CLIENT_TRAP_DISABLED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Client traps are disabled on controller(s) {0}.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS when required client traps are disabled in one or more controllers. These traps are needed for WCS to detect client sessions in a timely and efficient manner. The required traps are:</td>
</tr>
<tr>
<td></td>
<td>- 802.11 Association</td>
</tr>
<tr>
<td></td>
<td>- 802.11 Disassociation</td>
</tr>
<tr>
<td></td>
<td>- 802.11 Authentication</td>
</tr>
<tr>
<td></td>
<td>- 802.11 Deauthentication</td>
</tr>
<tr>
<td></td>
<td>- 802.11 Failed Association</td>
</tr>
<tr>
<td></td>
<td>- 802.11 Failed Authentication</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>When a controller is added to WCS, WCS enables the required client traps. If WCS does not have the correct SNMP read-write community, it could fail. The trap controls can also be changed by pushing the SNMP trap control template or using controller GUI/CLI.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Use the WCS template to enable the required client traps on the controller list.</td>
</tr>
</tbody>
</table>

### WLC_LICENSE_NOT_ENFORCED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>clmgmtLicenseNotEnforced</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Controller {0} has AP with unlicensed feature {1} version {2} attempting to join.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>An access point with a licensed feature is trying to join a controller without the proper license.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>An access point with a WPLUS feature like indoor mesh or OfficeExtend AP is trying to join a controller without a WPLUS license.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>You must add a WPLUS license to the controller or fix the primary, secondary, or tertiary controller configuration to have controllers with WPLUS licenses.</td>
</tr>
</tbody>
</table>

### WLC_LICENSE_COUNT_EXCEEDED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>clmgmtLicenseUsageCountExceeded</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Controller {0} with license {1} version {2} and counted feature {4} with limit {3} has been exceeded {5}.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The access point cannot join a controller.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
</tbody>
</table>
###VOIP_CALL_FAILURE

<table>
<thead>
<tr>
<th>Probable Causes</th>
<th>The controller has reached the maximum licensed access point capacity.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recommended Actions</td>
<td>Add a license capacity to the controller or move the access point to a controller with more capacity.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappVoipCallFailureNotif</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>VoIP Call failure of {4} (Error Code {3}) occurred on Client {0} with phone number {5} calling {6} which was associated with AP {1} on interface {2}.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>VoIP snooping is enabled on a WLAN.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A SIP error is detected by an access point.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>The actions depend on the type of error that is being reported. Errors can range from “dialed number does not exist,” “busy,” “service unavailable,” to “service timeout.”</td>
</tr>
</tbody>
</table>

###MSE_EVAL_LICENSE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Evaluation license for {0} is expired.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The tracking for clients or tags stops, or service does not start.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The evaluation period for the service has expired.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Add a permanent license for the service using License Center or the appropriate third-party vendor application.</td>
</tr>
</tbody>
</table>

###MSE_LICENSING_ELEMENT_LIMIT

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>{0} limit for {1} is reached or exceeded.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>Elements are not tracked beyond a certain limit.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Limit for the specified service has been reached.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Add a license with higher licensed capacity to the particular service.</td>
</tr>
</tbody>
</table>

##Traps Added or Updated in Release 7.0

- SI_AQ_TRAPS, page 14-62
- SI_SECURITY_TRAPS, page 14-62
- SI_SENSOR_CRASH_TRAPS, page 14-62
### SI_AQ_TRAPS

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-SI-MIB.my</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Air Quality Index on Channel {0} is {1} (Threshold: {2}).</td>
</tr>
<tr>
<td>Symptoms</td>
<td>Too Many interferers (Wi-Fi / non-Wi-Fi).</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Air Quality Index has gone below the threshold.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Reduce interference.</td>
</tr>
</tbody>
</table>

### SI_SECURITY_TRAPS

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-SI-MIB.my</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Security-Risk Interferer {0} is detected by {3}.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>Interferers detected which are defined as threat to the network.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Interference detected by SI chip.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Reduce interference.</td>
</tr>
</tbody>
</table>

### SI_SENSOR_CRASH_TRAPS

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-SI-MIB.my</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>CleanAir Sensor Status: {0} Error Code: {1}.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>CleanAir Sensor Software stopped working.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>CleanAir sensor is not operational due to crash.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Reset AP to resolve the problem.</td>
</tr>
</tbody>
</table>

### Traps Added or Updated in Release 7.01

#### SI_AQ_BUFFER_UNAVAILABLE_TRAPS

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappSiAqBufferUnavailable</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AQ data for AP &quot;{0}&quot; interface &quot;{1}&quot; is not available as AQ buffer allocation limit &quot;{2}&quot; on controller has reached or AQ data allocation failed. Allocation for AQ buffer successful, AQ data is now available for AP &quot;{0}&quot; interface &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated if Air Quality buffer is unavailable.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Warning.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Controller Resource limitation.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### WCS_NOTIFICATION_ALARM

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoWirelessMOStatusNotification</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>WCS message varies depending on the different HM sub category of the trap.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>Health Monitor uses this trap to send notification to WCS to indicate the Health Monitor alarm during various operation phases.</td>
</tr>
<tr>
<td></td>
<td>• HM_DATABASE</td>
</tr>
<tr>
<td></td>
<td>• HM_DATABASE_CRITICAL</td>
</tr>
<tr>
<td></td>
<td>• HM_FAILBACK</td>
</tr>
<tr>
<td></td>
<td>• HM_REACHABILITY</td>
</tr>
<tr>
<td></td>
<td>• HM_REGISTRATION</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>• HM_DATABASE—Major</td>
</tr>
<tr>
<td></td>
<td>• HM_DATABASE_CRITICAL—Critical</td>
</tr>
<tr>
<td></td>
<td>• HM_FAILBACK—Major</td>
</tr>
<tr>
<td></td>
<td>• HM_REACHABILITY—Major</td>
</tr>
<tr>
<td></td>
<td>• HM_REGISTRATION—Major</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>• HM_DATABASE_CRITICAL—The database is down and cannot be started by HM.</td>
</tr>
<tr>
<td></td>
<td>• HM_DATABASE—At the Database level, the connection between primary and secondary is lost.</td>
</tr>
<tr>
<td></td>
<td>• HM_FAILBACK—Failback attempt failed.</td>
</tr>
<tr>
<td></td>
<td>• HM_REACHABILITY—Primary and Secondary cannot reach each other.</td>
</tr>
<tr>
<td></td>
<td>• HM_REGISTRATION—Failed HA registration due to invalid authentication parameters.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>• HM_DATABASE_CRITICAL—Check the database and WCS log files for more information.</td>
</tr>
<tr>
<td></td>
<td>• HM_DATABASE—Check the database and WCS log files for more information.</td>
</tr>
<tr>
<td></td>
<td>• HM_FAILBACK—Check the WCS log file for more information.</td>
</tr>
<tr>
<td></td>
<td>• HM_REACHABILITY—Ensure that network connectivity is functioning.</td>
</tr>
<tr>
<td></td>
<td>• HM_REGISTRATION—Ensure that the authentication key, version number, OS platform are all correct.</td>
</tr>
</tbody>
</table>

### Unsupported Traps

- BROADCAST_STORM_START: broadcastStormStartTrap
- FAN_FAILURE: fanFailureTrap
- POWER_SUPPLY_STATUS_CHANGE: powerSupplyStatusChangeTrap
- BROADCAST_STORM_END: broadcastStormEndTrap
- VLAN_REQUEST_FAILURE: vlanRequestFailureTrap
- VLAN_DELETE_LAST: vlanDeleteLastTrap
- VLAN_DEFAULT_CFG_FAILURE: vlanDefaultCfgFailureTrap
- VLAN_RESTORE_FAILURE_TRAP: vlanRestoreFailureTrap
- IPSEC_ESP_AUTH_FAILURE: bsnIpsecEspAuthFailureTrap
- IPSEC_ESP_REPLAY_FAILURE: bsnIpsecEspReplayFailureTrap
- IPSEC_ESP_INVALID_SPI: bsnIpsecEspInvalidSpiTrap
- LRAD_UP: bsnAPUp
- LRAD_DOWN: bsnAPDown
- STP_NEWROOT: stpInstanceNewRootTrap
- STP_TOPOLOGY_CHANGE: stpInstanceTopologyChangeTrap
- IPSEC_SUITE_NEG_FAILURE: bsnIpsecSuiteNegFailure
- BSN_DOT11_ESS_CREATED: bsnDot11EssCreated
- BSN_DOT11_ESS_DELETED: bsnDot11EssDeleted
- LRADIF_RTS_THRESHOLD_CHANGED
- LRADIF_ED_THRESHOLD_CHANGED
- LRADIF_FRAGMENTATION_THRESHOLD_CHANGED
- WARM_START: warmStart
- LINK_FAILURE: linkFailureTrap
Reports

Cisco WCS reporting is necessary to monitor the system and network health as well as troubleshoot problems. A number of reports can be generated to run on an immediate and scheduled basis. Each report type has a number of user-defined criteria to aid in the defining of the reports. The reports are formatted as a summary, tabular, or combined (tabular and graphical) layout. Once defined, the reports can be saved for future diagnostic use or scheduled to run and report on a regular basis.

Reports are saved in either CSV or PDF format and are either saved to a file on WCS for later download or e-mailed to a specific e-mail address.

This chapter contains the following sections:

- Report Launch Pad, page 15-2
- CleanAir Reports, page 15-15
- Client Reports, page 15-23
- Compliance Reports, page 15-48
- ContextAware Reports, page 15-57
- Device Reports, page 15-69
- Guest Reports, page 15-89
- Mesh Reports, page 15-96
- Network Summary, page 15-113
- Performance Reports, page 15-118
- Security Reports, page 15-137

The reporting types include the following:

- Current, which provides a snap shot of the data from the last polling cycle without continuously polling
- Historical, which retrieves data from the device periodically and stores it in the WCS database
- Trend, which generates a report using aggregated data. Data can be periodically collected based from devices on user-defined intervals, and a schedule can be established for report generation.

With WCS, you also have the ability to export any report that you can view, sort reports into logical groups, and archive for long-term storage.

Note: The number of rows visible in a report depends on the size of the html file, the number of database records, the size of the exported page, the size of the scheduled report, and the WCS server memory size. If you want the report to print as it appears on the page display, you must choose landscape mode.
detailed limitations are as follows:

Maximum number of graphs for a single report—500
Maximum size of an HTTP report (displayed in the Results parameter)—65 Mbs
Maximum number of records for a non-scheduled report—100,000 records
Maximum number of records for a scheduled report—Up to 200,000 records (when physical memory is greater than 1 GB)

The Reports menu provides access to all WCS reports as well as currently saved and scheduled reports.

- Report Launch Pad—The hub for all WCS reports. From this page, you can access specific types of reports and create new reports. See the “Report Launch Pad” section on page 15-2 for more information.
- Scheduled Run Results—Allows you to access and manage all currently scheduled runs in WCS. See the “Managing Scheduled Run Results” section on page 15-9 for more information.
- Saved Reports—Allows you to access and manage all currently saved reports in WCS. See the “Managing Saved Reports” section on page 15-11 for more information.

Report Launch Pad

The report launch pad provides access to all WCS reports from a single page. From this page, you can view current reports, open specific types of reports, create and save new reports, and manage scheduled runs (see Figure 15-1).

Tip

Hover your mouse cursor over the tool tip next to the report type to view more report details.

This section contains the following topics:

- Creating and Running a New Report, page 15-3
- Managing Current Reports, page 15-9
Creating and Running a New Report

To create and run a new report, follow these steps:

**Step 1**  Choose **Reports > Report Launch Pad**.

The reports are listed by category in the main section of the page and on the left sidebar menu (see **Figure 15-2**).

**Figure 15-2 Report Launch Pad**

To create and run a new report, follow these steps:

**Step 2**  Find the appropriate report in the main section of the Report Launch Pad.

**Note**  Click the report name from the Report Launch Pad or use the navigation on the left side of the Report Launch Pad page to view any currently saved reports for that report type.

**Step 3**  Click **New** to the right of the report. The Report Details page appears (see **Figure 15-3**).
Step 4  In the Report Details page, enter the following Settings parameters:

**Note** Certain parameters may or may not appear depending on the report type.

- Report Title—If you plan to use this as a saved report, enter a report name.
- Report By—Choose the appropriate Report By category from the drop-down list.
- Report Criteria—The parameter allows you to sort your results depending on the previous Report By selection made. Click **Edit** to open the Filter Criteria page.

**Note** Click **Select** to confirm your filter criteria or **Close** to return to the previous page.

- Protocol—Choose **802.11a/n**, **802.11b/g/n**, or both.
- Report Period
  - Last—Select the **Last** radio button and period of time from the drop-down list.
  - From—Select the **From** radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.
- Show—Enter the number of records that you want displayed on each page.

**Note** Leave the text box blank to display all records.

Step 5  If you plan to run this report at a later time or as a recurring report, enter the Schedule parameters. The Schedule parameters allow you to control when and how often the report runs.

- Enable Schedule—Select the check box to run the report on the set schedule.
• Export Format—Choose your format for exported files (CSV or PDF).
• Destination—Select your destination type (File or Email). Enter the applicable file location or the email address.

Note The default file locations for CSV and PDF files are:

/wcs-ftp/reports/Inventory/ReportTitleName_yyyymmdd_HHmmSS.csv
/wcs-ftp/reports/Inventory/ReportTitleName_yyyymmdd_HHmmSS.pdf

Note To set the mail server setup for emails, choose Administration > Settings, then click Mail Server in the sidebar menu to open the Mail Server Configuration page. Enter the SMTP and other required information.

• Start Date/Time—Enter a date in the provided text box or click the calendar icon to open a calendar from which you can choose a date. Choose the time from the hours and minutes drop-down lists. The report will begin running on this data and at this time.
• Recurrence—Enter the frequency of this report.
  – No Recurrence—The report runs only once (at the time indicated for the Start Date/Time).
  – Hourly—The report runs on the interval indicated by the number of hours you enter in the Entry text box.
  – Daily—The report runs on the interval indicated by the number of days you enter in the Every text box.
  – Weekly—The report runs on the interval indicated by the number of weeks you enter in the Every text box and on the days specified by the selected check boxes.

The Create Custom Report page allows you to customize the report results. Table 15-1 specifies which reports are customizable, which have multiple sub-reports, and which report views are available. In future releases, all reports will be customizable.

Table 15-1  Report Customization

<table>
<thead>
<tr>
<th>Report</th>
<th>Customizable?</th>
<th>Multiple Sub-Reports?</th>
<th>Report Views</th>
<th>Data Field Sorting?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Air Quality vs Time</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Security Risk Interferers</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Worst Air Quality APs</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Worst Interferers</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Busiest Clients</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Client Count</td>
<td>Yes</td>
<td>No</td>
<td>Graphical</td>
<td>No</td>
</tr>
<tr>
<td>Client Session</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Client Summary</td>
<td>Yes</td>
<td>Yes</td>
<td>Various</td>
<td>Yes</td>
</tr>
<tr>
<td>Client Traffic</td>
<td>No</td>
<td>No</td>
<td>Graphical</td>
<td>No</td>
</tr>
</tbody>
</table>
### Table 15-1 Report Customization (continued)

<table>
<thead>
<tr>
<th>Report</th>
<th>Customizable?</th>
<th>Multiple Sub-Reports?</th>
<th>Report Views</th>
<th>Data Field Sorting?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client Traffic Stream Metrics</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Throughput</td>
<td>No</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Unique Clients</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>v5 Client Statistics</td>
<td>No</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Configuration Audit</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>PCI DSS Detailed</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>PCI DSS Summary</td>
<td>Yes</td>
<td>No</td>
<td>Graphical</td>
<td>No</td>
</tr>
<tr>
<td>AP Profile Status</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Device Summary</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Busiest APs</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Inventory - Combined Inventory</td>
<td>Yes</td>
<td>Yes</td>
<td>Various²</td>
<td>Yes</td>
</tr>
<tr>
<td>Inventory - APs</td>
<td>Yes</td>
<td>Yes</td>
<td>Various</td>
<td>Yes</td>
</tr>
<tr>
<td>Inventory - Controllers</td>
<td>Yes</td>
<td>Yes</td>
<td>Various</td>
<td>Yes</td>
</tr>
<tr>
<td>Inventory - MSEs</td>
<td>Yes</td>
<td>Yes</td>
<td>Various</td>
<td>Yes</td>
</tr>
<tr>
<td>Up Time</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Utilization - Controllers</td>
<td>No</td>
<td>No</td>
<td>Graphical</td>
<td>No</td>
</tr>
<tr>
<td>Utilization - MSEs</td>
<td>No</td>
<td>No</td>
<td>Graphical</td>
<td>No</td>
</tr>
<tr>
<td>Utilization - Radios</td>
<td>No</td>
<td>No</td>
<td>Graphical</td>
<td>No</td>
</tr>
<tr>
<td>Guest Account Status</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Guest Association</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Guest Count</td>
<td>No</td>
<td>No</td>
<td>Graphical</td>
<td>No</td>
</tr>
<tr>
<td>Guest User Sessions</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>WCS Guest Operations</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Alternate Parent</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Link Stats - Link Stats</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Link Stats - Node Hops</td>
<td>Yes</td>
<td>No</td>
<td>Graphical</td>
<td>No</td>
</tr>
<tr>
<td>Nodes</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Packet Stats - Packet Stats</td>
<td>No</td>
<td>No</td>
<td>Graphical</td>
<td>No</td>
</tr>
<tr>
<td>Packet Stats - Packet Error Stats</td>
<td>No</td>
<td>No</td>
<td>Graphical</td>
<td>No</td>
</tr>
<tr>
<td>Packet Stats - Packet Queue Stats</td>
<td>No</td>
<td>No</td>
<td>Graphical</td>
<td>No</td>
</tr>
<tr>
<td>Stranded APs</td>
<td>No</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
</tbody>
</table>
### Table 15-1 Report Customization (continued)

<table>
<thead>
<tr>
<th>Report</th>
<th>Customizable?</th>
<th>Multiple Sub-Reports?</th>
<th>Report Views</th>
<th>Data Field Sorting?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Worst Node Hops - Worst Node Hop</td>
<td>Yes</td>
<td>Yes</td>
<td>Various</td>
<td>No</td>
</tr>
<tr>
<td>Worst Node Hops - Worst SNR Link</td>
<td>Yes</td>
<td>Yes</td>
<td>Various</td>
<td>No</td>
</tr>
<tr>
<td>802.11n Summary</td>
<td>No</td>
<td>Yes</td>
<td>Graphical</td>
<td>No</td>
</tr>
<tr>
<td>Executive Summary</td>
<td>No</td>
<td>Yes</td>
<td>Various</td>
<td>No</td>
</tr>
<tr>
<td>802.11 Counters</td>
<td>Yes</td>
<td>No</td>
<td>Both</td>
<td>Yes</td>
</tr>
<tr>
<td>Coverage Holes</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Network Utilization</td>
<td>Yes</td>
<td>Yes</td>
<td>Both</td>
<td>Yes</td>
</tr>
<tr>
<td>Traffic Stream Metrics</td>
<td>Yes</td>
<td>Yes</td>
<td>Both</td>
<td>Yes</td>
</tr>
<tr>
<td>Tx Power and Channel</td>
<td>No</td>
<td>No</td>
<td>Graphical</td>
<td>No</td>
</tr>
<tr>
<td>VoIP Calls Graph</td>
<td>No</td>
<td>No</td>
<td>Graphical</td>
<td>No</td>
</tr>
<tr>
<td>VoIP Calls Table</td>
<td>No</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Voice Statistics</td>
<td>No</td>
<td>No</td>
<td>Graphical</td>
<td>No</td>
</tr>
<tr>
<td>Adaptive wIPS Alarm</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Adaptive wIPS Alarm Summary</td>
<td>Yes</td>
<td>No</td>
<td>Both</td>
<td>No</td>
</tr>
<tr>
<td>Adaptive wIPS Top 10 APs</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Adhoc Rogue Count Summary</td>
<td>Yes</td>
<td>No</td>
<td>Both</td>
<td>No</td>
</tr>
<tr>
<td>Adhoc Rogues</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>New Rogue AP Count Summary</td>
<td>Yes</td>
<td>No</td>
<td>Both</td>
<td>No</td>
</tr>
<tr>
<td>New Rogue APs</td>
<td>No</td>
<td>No</td>
<td>Graphical</td>
<td>No</td>
</tr>
<tr>
<td>Rogue AP Count Summary</td>
<td>Yes</td>
<td>No</td>
<td>Both</td>
<td>No</td>
</tr>
<tr>
<td>Rogue APs</td>
<td>Yes</td>
<td>No</td>
<td>Tabular</td>
<td>No</td>
</tr>
<tr>
<td>Security Alarm Trending Summary</td>
<td>Yes</td>
<td>No</td>
<td>Graphical</td>
<td>No</td>
</tr>
</tbody>
</table>

1. Sub-report Client Summary view is tabular only. The rest of the sub-reports such as Client Summary by Protocol have both report views and are customizable to show either tabular, graphical, or both.

2. Combined inventory (similar to other inventory reports: APs/Controllers/MSEs) consists of multiple sub-reports. Reports that are by model or version have both views. These views are customizable with setting such as Count of Controllers by Model. Other reports, such as Controller Inventory, are tabular only.

**Step 6** Click **Customize** to open a separate Create Custom Report page (see **Figure 15-4**).
a. From the Custom Report Name drop-down list, choose the report you intend to run. The Available and Selected column heading selections may change depending on the report selected.

b. From the Report View drop-down list, specify if the report will appear in tabular, graphical, or combined form (both). This option is not available on every report.

c. Use the Add > and < Remove buttons to move highlighted column headings between the two panels (Available data fields and Data fields to include).

Note Column headings in blue are mandatory in the current subreport. They cannot be removed from the Selected Columns area.

d. Use the Change Order buttons (Move Up or Move Down) to determine the order of the columns in the results table. The higher the column heading appears in the Selected Columns list, the farther left it appears in the results table.

e. In the Data field Sorting section, indicate your sorting preference (Ascending or Descending). Determine how the report data is sorted.

- You can select four data fields for which you can specify sorting order. Use the Sort by and Then by drop-down lists to choose each data field for sorting.
- For each sorted data field, choose whether you want it sorted in Ascending or Descending order.

Note Only reports in table form (rather than graphs or combined) can be sorted. Only fields that can be sorted appear in the Data field sorting drop-down lists.

f. Click Apply to confirm the changes, Reset to return columns to the default, or Cancel to close this page with no changes made.
Note: The changes made in the Create Custom Report page are not saved until you click Save from the Report Details page.

**Step 7**
When all report parameters have been set, choose one of the following:
- **Save**—Click to save this report setup without immediately running the report. The report will automatically run at the scheduled time.
- **Save and Run**—Click to save this report setup and to immediately run the report.
- **Run Now**—Click to run the report without saving the report setup.
- **Cancel**—Click to return to the previous page without running nor saving this report.

---

**Managing Current Reports**

If a report has been saved for a specific report type, you can access the current reports from the Report Launch Pad.

To access current or saved reports from the Report Launch Pad, follow these steps:

**Step 1** Choose **Reports > Report Launch Pad**.

**Step 2** Choose the specific report from the left sidebar menu or from the main section of the Report Launch Pad. The page displays a list of current reports for this report type (see Figure 15-5).

Note: To view a list of saved reports, choose **Reports > Saved Reports**. See the “Managing Saved Reports” section on page 15-11 for more information.

**Figure 15-5  Current Reports Page**

---

**Managing Scheduled Run Results**

To view all currently scheduled runs in WCS, choose **Report > Scheduled Run Results** (see Figure 15-6).
Note: The list of scheduled runs can be sorted by report category, report type, and time frame.

Figure 15-6  Scheduled Run Results Page

The Scheduled Run Results page displays the following information:

- **Report Title**—Identifies the user-assigned report name.

  \note{Click the report title to view the details for this report.}

- **Report Type**—Identifies the specific report type.

- **Status**—Indicates whether or not the report ran successfully.

- **Message**—Indicates whether or not this report was saved and the file name for this report (if saved).

- **Run Date/Time**—Indicates the date and time that the report is scheduled to run.

- **History**—Click the History icon to view all scheduled runs and their details for this report.

- **Download**—Click the Download icon to open or save a .csv/.pdf file of the report results.

For more information about scheduled run results, see the following:

- **Sorting Scheduled Run Results**, page 15-10
- **Viewing or Editing Scheduled Run Details**, page 15-11

### Sorting Scheduled Run Results

You can use the Show drop-down lists to sort the Scheduled Run Results by category, type, and time frame (see Figure 15-7):

- **Report Category**—Choose the appropriate report category from the drop-down list, or select All.

- **Report Type**—Choose the appropriate report type from the drop-down list, or select All. The report Type selections change depending on the selected report category.

- **From/To**—Type the report start (From) and end (To) dates in the text boxes, or click the calendar icons to select the start and end dates.

Click Go to sort this list. Only reports that match your criteria appear.
Chapter 15  Reports

Viewing or Editing Scheduled Run Details

To view or edit a saved report, follow these steps:

Step 1  Choose Report > Scheduled Run Results.
Step 2  Click the Report Title link for the appropriate report to open the Report Details page.
Step 3  From this page, you can view or edit the details for the scheduled run.
Step 4  When all scheduled run parameters have been edited (if necessary), select from the following:
   •  Save—Click to save this schedule run without immediately running the report. The report will automatically run at the scheduled time.
   •  Save and Run—Click to save this scheduled run and to immediately run the report.
   •  Cancel—Click to return to the previous page without running nor saving this report.
   •  Delete—Click to delete the current saved report.

Managing Saved Reports

In the Saved Reports page, you can create and manage saved reports (see Figure 15-8). To open this page in WCS, choose Reports > Saved Reports.

Note  The list of saved reports can be sorted by report category, report type, and scheduled status (enabled, disabled, or expired).
The Saved Reports page displays the following information:

- **Report Title**—Identifies the user-assigned report name.

  **Note**  
  Click the report title to view the details for this report.

- **Report Type**—Identifies the specific report type.

- **Scheduled**—Indicates whether this report is enabled or disabled.

- **Next Schedule On**—Indicates the date and time of the next scheduled run for this report.

- **Last Run**—Indicates the date and time of the most recent scheduled run for this report.

- **Download**—Click the Download icon to open, or save a .csv file of the report results.

- **Run Now**—Click the Run Now icon to immediately run the current report.

For additional information on saved reports, see:

- Sorting Saved Reports, page 15-12
- Viewing or Editing Saved Report Details, page 15-13
- Running a Saved Report, page 15-13

### Sorting Saved Reports

You can use the Show drop-down lists to sort the Saved Reports list by category, type, and scheduled status (see Figure 15-9).

- **Report Category**—Choose the appropriate report category from the drop-down list, or select All.

- **Report Type**—Choose the appropriate report type from the drop-down list, or select All. The Report Type selections change depending on the selected report category.

- **Scheduled**—Choose All, Enabled, Disabled, or Expired to sort the Saved Reports list by scheduled status.
Figure 15-9  Sorting Saved Reports

Saved Reports

<table>
<thead>
<tr>
<th>Report Category</th>
<th>Report Type</th>
<th>Scheduled Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>Security</td>
<td>All</td>
<td></td>
</tr>
</tbody>
</table>

Click **Go** to sort this list. Only reports that match your criteria appear.

Viewing or Editing Saved Report Details

To view or edit a saved report, follow these steps:

**Step 1**  Choose **Report > Saved Reports**.

**Step 2**  Click the Report Title link for the appropriate report to open the Report Details page.

**Step 3**  From this page, you can view or edit the details for the saved report.

**Step 4**  When all report parameters have been edited, choose one of the following:

- Save—Click to save this report setup without immediately running the report. The report will automatically run at the scheduled time.
- Save and Run—Click to save this report setup and to immediately run the report.
- Run Now—Click to run the report without saving the report setup.
- Cancel—Click to return to the previous page without running nor saving this report.
- Delete—Click to delete the current saved report.

Running a Saved Report

On the Reports > Saved Reports page, click **Run Now** for the appropriate report. Following is a list of reports specific to WCS.

- CleanAir Reports
  - Air Quality vs Time
  - Security Risk Interferers
  - Worst Air Quality APs
  - Worst Interferers
- Client Reports
  - Busiest Clients
- Client Count
- Client Sessions
- Client Summary
- Client Traffic
- Client Traffic Stream Metrics
- Throughput
- Unique Clients
- V5 Client Statistics

• Compliance Reports
  - Configuration Audit Report
  - PCI DSS Detailed
  - PCI DSS Summary

• ContextAware Reports
  - Client Location History
  - Client Location Tracking
  - Guest Location Tracking
  - Location Notifications
  - Rogue AP Location Tracking
  - Rogue Client Location Tracking
  - Tag Location History
  - Tag Location Tracking

• Device Reports
  - AP Image Predownload
  - AP Profile Status
  - Busiest APs
  - AP Summary
  - Inventory Reports
  - Uptime
  - Utilization

• Guest Reports
  - Guest Accounts Status
  - Guest Association
  - Guest Count
  - Guest User Sessions
  - WCS Guest Operations

• Mesh Reports
  - Alternate Parent Report
  - Link Stats
CleanAir Reports

Click **New** for CleanAir report type to create a new report. See the “Creating and Running a New Report” section on page 15-3 for more information.

Click a report type to view currently saved reports. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.
The CleanAir reports are available:

- Air Quality vs Time
- Security Risk Interferers
- Worst Air Quality APs
- Worst Interferers

**Air Quality vs Time**

This report displays the air quality index distributions over a period of time for access points on your wireless networks.

Click Air Quality vs Time from the Report Launch Pad to open the Air Quality vs Time page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the Air Quality vs Time page. See the “Configuring an AirQuality vs Time Report” section on page 15-16 and the “Air Quality vs Time Report Results” section on page 15-17 for more information.

**Configuring an AirQuality vs Time Report**

This section describes how to configure an AirQuality vs Time report.

**Settings**

The following settings can be configured for a Air Quality vs Time report:

- Report Title—If you plan to use this as a saved report, type an appropriate name.
- Report By
  - AP By Controller—Choose All Controllers > All Access Points, or click Edit to select specific access points.
  - AP By Floor Area—Choose System Campus > All Access Points, or click Edit to select specific access points.
  - AP by Outdoor Area—Choose All Campuses > All Outdoor Areas > All Access Points, or click Edit to select specific locations or access points.
- Protocol—Select the radio type by selecting the check box specific to a radio frequency.
- Reporting Period—You can configure the reporting period in two ways:
  - Last—Select the first radio button to generate reports for a period of time from the drop-down list.
  - From—Click From and enter the From and To dates and times. You can type a date in the text box, or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.
- Show—Enter the number of records you want displayed in each page.

**Note**

Leave the text box blank to display all records.
Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Create a Custom Report

The Create Custom Report page allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Command Buttons

Once all report parameters have been set, select from the following:

- Save—Click to save this report setup without immediately running the report. The report will automatically run at the scheduled time.
- Save and Run—Click to save this report setup and to immediately run the report.
- Run Now—Click to run the report without saving the report setup.
- Cancel—Click to return to the previous page without running nor saving this report.

Note: See the “Creating and Running a New Report” section on page 15-3 for additional information on running or scheduling a report.

Air Quality vs Time Report Results

Use the Create Custom Report page to customize the displayed results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

The following are potential results for an Air Quality vs Time report, depending on how the report is customized:

- AP Name
- Basic Radio MAC
- Radio Type
- Time
- AQ Minimum Index
- AQ Average Index

Security Risk Interferers

This report displays the security risk interferers on your wireless network.

Click Security Risk Interferers from the Report Launch Pad to open the Security Risks Interferers page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

**Configuring a Security Risk Interferers Report**

This section describes how to configure a Security Risk Interferers report.

**Settings**

The following settings can be configured for a Security Risk Interferers report:

- **Report Title**—If you plan to use this as a saved report, type an appropriate name.
- **Report By**
  - **AP By Controller**—Choose **All Campuses** > **All Buildings** > **All Floors** > **All Access Points**, or click **Edit** to select specific access points.
  - **AP By Floor Area**—Choose **All Campuses** > **All Buildings** > **All Floors** > **All Access Points**, or click **Edit** to select specific access points.
  - **AP by Outdoor Area**—Choose **All Campuses** > **All Outdoor Areas** > **All Access Points**, or click **Edit** to select specific locations or access devices.
- **Protocol**—Select the radio type by selecting the check box specific to a radio frequency.
- **Reporting Period**—You can configure the reporting period in two ways:
  - **Last**—Select the **first** radio button to generate reports for a period of time from the drop-down list.
  - **From**—Click **From** and enter the From and To dates and times. You can type a date in the text box, or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.
- **Show**—Enter the number of records you want displayed on each page.

| Note | Leave the text box blank to display all records. |

| Note | The information in this report will be available only if you set a security alarm on the interferer. |

**Schedule**

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

**Create a Custom Report**

The Create Custom Report page allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

**Command Buttons**

Once all report parameters have been set, select from the following:
- Save—Click to save this report setup without immediately running the report. The report will automatically run at the scheduled time.
- Save and Run—Click to save this report setup and to immediately run the report.
- Run Now—Click to run the report without saving the report setup.
- Cancel—Click to return to the previous page without running nor saving this report.

**Note**

See the “Creating and Running a New Report” section on page 15-3 for additional information on running or scheduling a report.

**Security Risks Interferers Report Results**

**Note**

Use the Create Custom Report page to customize the displayed results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

The following are potential results for a Security Risks Interferers report, depending on how the report is customized:

- Interferer Type
- Affected Channels
- Discovered
- Last Updated
- Detected AP Name
- Affected Band
Worst Air Quality APs

This report displays the access points with the lowest air quality index.

Click Worst Air Quality APs from the Report Launch Pad to open the Worst Air Quality APs page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the Worst Air Quality APs page. See the “Configuring a Worst Air Quality APs Report” section on page 15-20 and the “Worst Air Quality APs Report Results” section on page 15-21 for more information.

Configuring a Worst Air Quality APs Report

This section describes how to configure a Worst Air Quality APs report.

Settings

The following settings can be configured for a Worst Air Quality APs report:

• Report Title—If you plan to use this as a saved report, type an appropriate name.

• Report By
  - AP By Controller—Choose All Campuses>All Buildings > All Floors > All Access Points, or click Edit to select specific access points.
  - AP By Floor Area—Choose All Campuses>All Buildings > All Floors > All Access Points, or click Edit to select specific access points.
  - AP by Outdoor Area—Choose All Campuses > All Outdoor Areas > All Access Points, or click Edit to select specific locations or access devices.

• Protocol—Select the radio type by selecting the check box specific to a radio frequency.

• Reporting Period—You can configure the reporting period in two ways:
  - Last—Select the first radio button to generate reports for a period of time from the drop-down list.
  - From—Click From and enter the From and To dates and times. You can type a date in the text box, or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

• Show—Enter the number of records you want displayed on each page.

  Note Leave the text box blank to display all records.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Create a Custom Report

The Create Custom Report page allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.
Command Buttons

Once all report parameters have been set, select from the following:

- **Save**—Click to save this report setup without immediately running the report. The report will automatically run at the scheduled time.
- **Save and Run**—Click to save this report setup and to immediately run the report.
- **Run Now**—Click to run the report without saving the report setup.
- **Cancel**—Click to return to the previous page without running nor saving this report.

**Note**

See the “Creating and Running a New Report” section on page 15-3 for additional information on running or scheduling a report.

### Worst Air Quality APs Report Results

**Note**

Use the Create Custom Report page to customize the displayed results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

The following are potential results for a Worst Air Quality APs report, depending on how the report is customized:

- AP Name
- Radio Type
- Worst Air Quality Value
- Channel Number
- Most Recent Reported Time
- Interferer Count

### Worst Interferers

This report displays the worst interferers on your wireless network.

Click **Worst Interferers** from the Report Launch Pad to open the Worst Air Quality APs page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click **New** from the Report Launch Pad or from the Worst Interferers page.

### Configuring a Worst Interferers Report

This section describes how to configure a Worst Interferers report.

**Settings**

The following settings can be configured for a Worst Interferers report:

- **Report Title**—If you plan to use this as a saved report, type an appropriate name.
• Report By
  - Cluster Center AP
  - Floor Area—Choose All Campuses > All Buildings > All Floors > All Access Points from the report criteria area, or click Edit to select specific locations.
  - Outdoor Area—Choose All Campuses > All Outdoor Area from the report criteria area, or click Edit to select specific locations.
• Protocol—Select the radio type by selecting the check box specific to a radio frequency.
• Reporting Period—You can configure the reporting period in two ways:
  - Last—Select the first radio button to generate reports for a period of time from the drop-down list.
  - From—Click From and enter the From and To dates and times. You can type a date in the text box, or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.
• Show—Enter the number of records you want displayed on each page.

  Note Leave the text box blank to display all records.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Create a Custom Report

The Create Custom Report page allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Command Buttons

Once all report parameters have been set, select from the following:

• Save—Click to save this report setup without immediately running the report. The report will automatically run at the scheduled time.
• Save and Run—Click to save this report setup and to immediately run the report.
• Run Now—Click to run the report without saving the report setup.
• Cancel—Click to return to the previous page without running nor saving this report.

  Note See the “Creating and Running a New Report” section on page 15-3 for additional information on running or scheduling a report.
Worst Interferers Report Results

Note Use the Create Custom Report page to customize the displayed results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

The following are potential results for a Worst Interferers report, depending on how the report is customized:

- Device Type
- Severity
- Worst Severity Time
- Duty Cycle (%)
- Affected Channels
- Cluster Center APs
- Map Location
- Discovered

Note Severity value N/A means that the severity value for this device is not available. A value of 1 means that the severity is minimal and a value of 100 means very severe.

Note Interferers with unknown location are not listed if the Report By criteria is Floor Area or Outdoor Area.

Client Reports

The report structure has changed in Release 6.0 or later:

- The Client Association and Detailed Client Report are replaced by the Client Session report.
- Any saved Detailed Client reports are migrated to the Client Session report.
- Client Association data from 5.1 or earlier is not migrated.

Note After migration to 6.0 or later releases, you cannot see previous Client Association information that was presented in the Client Association report.

- The Client Count report that was under 802.11 Scaling in release 5.2 is now consolidated into one Client Count report.

The following types of client reports are available:

- Busiest Clients
- Client Count
- Client Sessions
- Client Summary
- Client Traffic Stream Metrics
Client Reports

- Throughput
- Unique Clients
- V5 Client Statistics

Busiest Clients

This report displays the busiest and least busy clients on the wireless network by throughput, utilization, and other statistics. You can sort this report by location, by band, or by other parameters.

Note

Busiest Clients reports do not include autonomous clients.

Click Busiest Clients from the Report Launch Pad to open the Busiest Clients Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

Configuring a Busiest Client Report

This section describes how to configure a Busiest Client report.

Settings

- **Report Title**—If you plan to used this as a saved report, enter a report name.
- **Report by**
  - Controller—Choose All Controllers from the Report Criteria page, or click Edit to select specific devices.
  - Floor Area—Choose All Campuses > All Buildings > All Floors from the Report Criteria page, or click Edit to select specific locations.
  - Outdoor Area—Choose All Campuses > All Outdoor Areas from the Report Criteria page, or click Edit to select specific locations.
  - AP by Floor Area—Choose All Campuses > All Buildings > All Floors > All APs from the Report Criteria page, or click Edit to select specific locations or devices.
  - AP by Outdoor Area—Choose All Campuses > All Outdoor Areas > All APs from the Report Criteria page, or click Edit to select specific locations or devices.
  - SSID—Choose All SSIDs from the Report Criteria page, or click Edit to select a specific or multiple SSIDs.
  - AP by RAP Mesh Role—Choose All RAP APs from the Report Criteria page, or click Edit to select a specific RAP access point.

Note

In the Report Criteria page, click Select to confirm your filter criteria, or Close to return to the previous page.

- **Protocol**—Choose All Clients, Wired Clients, or a specific radio type from the drop-down list.
- **Reporting Period**
  - Last—Select the Last radio button and a period of time from the drop-down list.
Chapter 15      Reports

Client Reports

Chapter 15

Reports

From—Click From and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

Note The reporting period is based on the clients last seen time. The times are in the UTC time zone.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Customize Report Format allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note Fixed columns appear in blue font and cannot be moved to Available Columns.

Available information for the Busiest Client report results includes the following:

- Client MAC Address—The MAC address of the client.
- Client IP Address—The IP address of the client.
- Username
- Protocol—802.11a, 802.11b, 802.11g, 802.11n_5 GHz, or 802.11n_2.4 GHz
- Throughput (Mbps)—The average throughput (in Mbps) for the client.
- Utilization (%)—The average percentage of use for this client.
- On Controller—The controller on which the client is located.
- Bytes Sent—The number of bytes sent.
- Bytes Received—The number of bytes received.
- Packets Sent—The number of packets sent.
- Packets Received—The number of packets received.

Busiest Client Report Results

Note Use the Customize Report Format to customize the displayed results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

The following potential results occur, depending on how the report is customized (see Figure 15-10):

- Client MAC address, IP address, and username
- Protocol—802.11a/n or 802.11b/g/n
- Throughput—Either Mbps or kbps
Note: If throughput is less than 0.1 kbps, you see <0.1 kbps.

- Utilization (%)
- On Controller—The controller on which the client is located.
- Bytes sent and received

Note: If the value is greater than 1,000,000,000, a G is appended at the end of the value (such as 3.45 G). If the value is greater than 1,000,000 but less than 1,000,000,000, an M is appended at the end of the value (such as 456.8 M).

- Packets sent and received

Note: If the value is greater than 1,000,000,000, a G is appended at the end of the value (such as 3.45 G). If the value is greater than 1,000,000 but less than 1,000,000,000, an M is appended at the end of the value (such as 456.8 M).

Figure 15-10  Busiest Client Report Results

Client Count

This trending report displays the total number of active clients on your wireless network. The Client Count report displays data on the numbers of clients that connected to the network through a specific device, in a specific geographical area, or through a specific or multiple SSIDs.
Chapter 15  Reports

Client Reports

Client Count reports include clients connected to autonomous Cisco IOS access points.

Configuring a Client Count Report

This section describes how to configure a Client Count report.

Settings

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report by**
  - Controller—Choose All Controllers from the Report Criteria page, or click Edit to select specific devices.
  - Floor Area—Choose All Campuses > All Buildings > All Floors from the Report Criteria page, or click Edit to select specific locations.
  - Outdoor Area—Choose All Campuses > All Outdoor Areas from the Report Criteria page, or click Edit to select specific locations.
  - AP by Floor Area—Choose All Campuses > All Buildings > All Floors > All APs from the Report Criteria page, or click Edit to select specific locations or devices.
  - AP by Outdoor Area—Choose All Campuses > All Outdoor Areas > All APs from the Report Criteria page, or click Edit to select specific locations or devices.
  - SSID—Choose All SSIDs from the Report Criteria page, or click Edit to select a specific or multiple SSIDs.
  - AP by RAP Mesh Role—Choose All RAP APs from the Report Criteria page, or click Edit to select a specific RAP access point.

Note
In the Report Criteria page, click Select to confirm your sort criteria or Close to return to the previous page.

- **Protocol**—Choose All Clients or a specific radio type from the drop-down list.

Note
Wired clients and clients associated to Cisco IOS access points are not included as part of this report.

- **Reporting Period**
  - Last—Select the Last radio button and a period of time from the drop-down list.
  - From—Select the From radio button and enter the From and To dates and times. You can type a date in the text box, or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

Note
The reporting period is based on the alarm last seen time. The times are in the UTC time zone.
Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Customize Report Format allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note

Fixed columns appear in blue font and cannot be moved to Available Columns.

Available information for Client Count report results includes the following:

- Controller IP—The IP address of the controller.
- Time—The time the client count occurred.
- Associated Client Count—The number of associated clients for the specified period of time.
- Authenticated Client Count—The number of authenticated clients for the specified period of time.

Client Count Report Results

Use the Customize Report Format to customize the displayed results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

The following are potential results for a Client Count report, depending on how the report is customized (see Figure 15-11):

- Client IP address
- AP Name
- Key
- SSID
- Date and time the count was taken
- Associated client count
- Authenticated client count
Client Sessions

This report provides client sessions for the given period of time. It displays the history of client sessions, statistics, and the duration at which clients are connected to an access point at any given period of time.

Click **Client Sessions** from the Report Launch Pad to open the Client Sessions Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

Configuring a Client Sessions Report

This section describes how to configure a Client Sessions report.

**Settings**

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report by**
  - **Controller**—Choose **All Controllers** from the Report Criteria page, or click **Edit** to select specific devices.
  - **Floor Area**—Choose **All Campuses > All Buildings > All Floors** from the Report Criteria page, or click **Edit** to select specific locations.
  - **Outdoor Area**—Choose **All Campuses > All Outdoor Areas** from the Report Criteria page, or click **Edit** to select specific locations.
  - **AP by Floor Area**—Choose **All Campuses > All Buildings > All Floors > All APs** from the Report Criteria page, or click **Edit** to select specific locations or devices.
Client Reports

Chapter 15 Reports

– AP by Outdoor Area—Choose All Campuses > All Outdoor Areas > All APs from the Report Criteria page, or click Edit to select specific locations or devices.

– SSID—Choose All SSIDs from the Report Criteria page, or click Edit to select a specific or multiple SSIDs.

– AP by RAP Mesh Role—Choose All RAP APs from the Report Criteria page, or click Edit to select a specific RAP access point.

Note: In the Report Criteria page, click Select to confirm your filter criteria or Close to return to the previous page.

– VLAN
– Client MAC Address
– Client Username

• Reporting Period
  – Last—Select the Last radio button and a period of time from the drop-down list.
  – From—Select the From radio button and enter the From and To dates and times. You can type a date in the text box, or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

Note: The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Customize Report Format allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note: Fixed columns appear in blue font and cannot be moved to Available Columns.

Available information for Client Sessions report results includes the following:

• Client Username
• Client IP Address—The IP address of the client.
• Client MAC Address—The MAC address of the client.
• Association Time —The date and time the client associated.
• Vendor—The vendor name for this client.
• AP Name—The access point to which this client is associated.
• Controller Name—The name of the controller to which this client is associated.
Chapter 15 Reports

Client Reports

- Map Location—The building, floor area, or outdoor area (as applicable) where the client is located.
- SSID—The SSID to which this client is associated.
- Profile—The name of the profile to which this client is associated.
- VLAN ID—The VLAN Identifier. The range is 1 to 4096.
- Protocol—802.11a, 802.11b, 802.11g, 802.11n_5 GHz, or 802.11b_2.4 GHz.
- Session Duration—The length of time of the client session in hours, minutes, and seconds.
- Policy Type—The type of security policy for this client session.
- Average Session Throughput (kbps)—The average throughput in kbps for this client session.
- Host Name—The DNS host name of the device the client is on. WCS does a DNS lookup to resolve the host name from the client’s IP address. The IP address to host name mapping must be defined in a DNS server. By default, the host name lookup is disabled. Use Administration > Settings > Clients to enable host name lookup.
- CCX—The Cisco Client Extension version number.
- AP MAC Address
- IP address
- AP Radio—The radio type of the access point.
- Controller IP Address—The IP address of the controller to which this client is associated.
- Controller Port—The port number for the controller to which this client is associated.
- Anchor Controller—The IP address of the anchor or foreign controller for the mobility client.
- Association ID
- Disassociation Time—The date and time this client disassociated.
- Authentication—The authentication method for this client.
- Encryption Cipher
- EAP Type
- Authentication Algorithm
- Web Security
- Tx and Rx (bytes)—The approximate number of bytes transmitted or received during the session.

Client Sessions Report Results

Use the Customize Report Format to customize the displayed results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

The following are potential results for a Client Sessions report, depending on how the report is customized (see Figure 15-12):

- Client username, IP address, and MAC address (mandatory columns)
- Association time (mandatory column)
- Vendor
- Access point name—The access point name to which this client is assigned.
Chapter 15      Reports

Client Reports

- Controller names
- Map Location—The building, floor area, or outdoor area (as applicable) where the client is located.
- SSID—The SSID to which this client is associated.
- Profile—The name of the profile to which this client is associated.
- VLAN ID—The VLAN Identifier. The range is 1 to 4096.
- Protocol—802.11a, 802.11b, 802.11g, 802.11n_5GHz, or 802.11b_2.4GHz.
- Session Duration
- Policy Type—The type of security policy for this client session.
- Average Session Throughput (kbps)
- Host Name—The DNS host name of the machine on which this client is located.
  WCS performs a DNS lookup to resolve the host name from the client IP address. The IP address to host name mapping must be defined in a DNS server. By default, the host name lookup is disabled. You can enable it from the Administration > Settings > Clients page.
- CCX—The Cisco Client Extension version number.
- AP MAC address
- IP address
- AP Radio—The radio type of the access point.
- Controller IP address
- Controller Port—The port number for the controller to which this client is associated.
- Anchor Controller—The IP address of the anchor or foreign controller for the mobility client, if applicable.
- Association ID—Association ID used in this client session.
- Disassociation Time—The date and time this client disassociated.
- Authentication—The authentication method for this client.
- Encryption Cypher—Encryption cypher used in this client session.
- EAP Type—EAP type used in this client session.
- Authentication Algorithm—Authentication algorithm used in this client session.
- Web Security—Web security used in this client session.
- Tx and Rx (bytes)—The approximate number of bytes transmitted or received during the client session.
- Packets sent and received
- SNR—Signal-to-noise ratio for this client session.
- RSSI—The received signal strength indicator in dBm.
- Status—Associated or disassociated.
- Reason—Reason for disassociation.
- E2E—Version number or Not Supported.
Chapter 15  Reports

Client Summary

The Client Summary is a detailed report that displays various client statistics. Click Client Summary from the Report Launch Pad to open the Client Summary Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

Configuring a Client Summary Report

This section describes how to configure a Client Summary report.

Settings

- **Report Title**—If you plan to used this as a saved report, enter a report name.
- **Reporting Period**
  - **Last**—Select the Last radio button and a period of time from the drop-down list.
  - **From**—Select the From radio button and enter the From and To dates and times. You can type a date in the text box, or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

**Note**  
The reporting period is based on the alarm last seen time. The times are in the UTC time zone.
Schedule

If you plan to run this report at a later time, or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Customize Report Format allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note

Fixed columns appear in blue font and cannot be moved to Available Columns.

Note

A Client Summary report includes summary results sorted by protocol, SSID, VLAN, and vendor. To customize report results for a particular section, select the applicable section from the Customizable Report drop-down list.

The Client Summary report contains four sub reports. Each of them can be independently customized. The following is default information available from a Client Summary report depending on the customizable report selected:

- Number of Sessions
- Number of Total Users
- Number of Unique Users
- Number of New Users
- Number of Unique APs
- Number of Users per AP
- Total Traffic (MB)
- Average Traffic per Session (KB) and per user (in KB)
- Total Throughput (Mbps)
- Average Throughput per Session and per user (Mbps)

Note

When WCS does not receive client traps, it relies on client status polling to discover client associations (The task runs every 5 minutes by default.). However, WCS cannot accurately determine when the client was actually associated. WCS assumes the association started at the polling time which may be later than the actual association time. Therefore the calculation of the average client throughput can give inaccurate results, especially for short client sessions.

- Protocol—802.11a/n or 802.11b/g/n.
- SSID—The user-defined Service Set Identifier name
- VLAN
- Vendor
- User Count
Client Summary Report Results

Use the Customize Report Format to customize the displayed results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

The following are potential results for a Client Summary report, depending on how the report is customized (see Figure 15-13):

- **Client Summary**
  - Number of Sessions (mandatory column)
  - Number of Total Users (mandatory column)—Number of unique endpoints, or MAC addresses.
  - Number of Unique Users—Number of unique user names that are authenticated.
  - Number of New Users
  - Number of Unique Access Points
  - Number of Users per Access Point
  - Total session time in minutes
  - Total traffic (MB)
  - Average traffic per session (KB) and per user (in KB)
  - Total throughput (MBPS)
  - Average throughput per session and per user (MBPS)

**Note**
When WCS does not receive client traps, it relies on client status polling to discover client associations (The task runs every 5 minutes by default). However, WCS cannot accurately determine when the client was actually associated. WCS assumes the association started at the polling time which may be later than the actual association time. Therefore the calculation of the average client throughput can give inaccurate results, especially for short client sessions.

**Note**
WCS only counts authenticated sessions. If a user fails on DHCP or authentication, WCS will not have a session for it. Also, WCS considers every detected AP association as a session. For instance, if a client roams from one access point to another, WCS can have two association sessions.
Client Summary by Protocol, SSID, VLAN, and Vendor

- Protocol (mandatory column)
- SSID (mandatory column)
- VLAN (mandatory column)
- Vendor (mandatory column)
- User Count (mandatory column)
- Time Used (mandatory column)
- Traffic (mandatory column)
- Session Count (mandatory column)
- % of users, time, traffic, and sessions

**Figure 15-13  Client Summary Report Results**
**Client Traffic**

This report displays the traffic by the wireless clients on your network. Click **Client Traffic** from the Report Launch Pad to open the Client Traffic Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

**Configuring a Client Traffic Report**

This section describes how to configure a Client Traffic report.

**Settings**

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report by**
  - **Controller**—Choose **All Controllers** from the Report Criteria page, or click **Edit** to select specific devices.
  - **Floor Area**—Choose **All Campuses > All Buildings > All Floors** from the Report Criteria page, or click **Edit** to select specific locations.
  - **Outdoor Area**—Choose **All Campuses > All Outdoor Areas** from the Report Criteria page, or click **Edit** to select specific locations.
  - **SSID**—Choose **All SSIDs** from the Report Criteria page, or click **Edit** to select specific, or multiple SSIDs.
- **Reporting Period**—Specify the time period for which the report needs to be generated. You can select from a list of choices defined such as Last 1 hour, Last 6 hours, and so on, or specify a custom period by selecting the From and To date and time.

  **Note** The reporting period is based on the time that the alarm was last seen. The times are shown in the local time of the WCS server.

**Schedule**

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

**Customize Report Form**

The Customize Report Format allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

**Note** Fixed columns appear in blue font and cannot be moved to Available Columns.
Client Traffic Report Results

Note
Use the Customize Report Format to customize the displayed results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Figure 15-14 shows the potential results for a Client Traffic report, depending on how the report is customized.

Figure 15-14 Client Traffic Report Results

Client Traffic Stream Metrics

This report displays Traffic Stream Metrics for clients. You can select from the following:

- All clients of a given set of SSIDs
- All clients
- One specific client

Click Client Traffic Stream Metrics from the Report Launch Pad to open the Client Traffic Stream Metrics Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the Client Traffic Stream Metrics Reports page.
Note  The traffic stream metrics and radio performance background tasks must be running prior to generating this report.

Configuring a Client Traffic Stream Metrics Report

This section describes how to configure a Client Traffic Stream Metrics report.

Settings

The following settings can be configured for a Client Traffic Stream Metrics report:

- Report Title—If you plan to use this as a saved report, enter a report name.
- Report by
  - SSID—Choose All SSIDs from the Report Criteria page, or click Edit to select a specific or multiple SSIDs.
  - Client MAC Address—Choose All Clients from the Report Criteria page, or click Edit to select specific clients.

Note  In the Report Criteria page, click Select to confirm your filter criteria or Close to return to the previous page.

- Reporting Period
  - Last—Select the Last radio button and a period of time from the drop-down list.
  - From—Select the From radio button and enter the From and To dates and times. You can type a date in the text box, or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Create Custom Report page allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note  Mandatory columns are displayed in blue font and cannot be moved to Available Columns. Time, Client MAC address, and QoS are mandatory columns for the Client Traffic Stream Metrics report.

Note  Use the Create Custom Report page to customize the displayed results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.
The following are potential results for a Client Traffic Stream Metrics report, depending on how the report is customized:

- Time (mandatory column)
- Client MAC (mandatory column)
- QoS (mandatory column)—QoS values (packet latency, packet jitter, packet loss, roaming time) which can affect how the WLAN are monitored. Access points and clients measure the metrics, access points collect the measurements and send them to the controller. The access points update the controller with traffic stream metric information every 90 seconds and 10 minutes of data is stored at one time.
- AP Name (mandatory column)
- Radio Type (mandatory column)
- Avg Queuing Delay (ms) (Downlink) (mandatory column)—Average queuing delay in milliseconds for the downlink. Average packet queuing delay is the average delay of voice packets traversing the voice queue. Packet queue delay is measured beginning when a packet is queued for transmission and ending when the packet is successfully transmitted. It includes the time for re-tries, if needed.
- Avg Queuing Delay (ms) (Uplink) (mandatory column)—Average queuing delay in milliseconds for the uplink. Average packet queuing delay is the average delay of voice packets traversing the voice queue. Packet queue delay is measured beginning when a packet is queued for transmission and ending when the packet is successfully transmitted. It includes time for re-tries, if needed.
- % PLR (Downlink)—Percentage of packets lost on the downlink (access point to client) during the 90 second interval.
- % PLR (Uplink)—Percentage of packets lost on the uplink (client to access point) during the 90 second interval.
- % Packets > 40ms Queuing Delay (Uplink)—Percentage of queuing delay packets greater than 40 ms.
- % Packets 20ms-40ms Queuing Delay (Uplink)—Percentage of queuing delay packets between 20 ms and 40 ms.
- Roaming Delay—Roaming delay in milliseconds. Roaming delay, which is measured by clients, is measured beginning when the last packet is received from the old access point and ending when the first packet is received from the new access point after a successful roam.
- Time—Time that the statistics were gathered from the access point(s).
- Client MAC—MAC address of the client. This shows a list of the clients evaluated during the most recent 90 second interval. The client could be a VoIP phone, laptop, or PDA and refers to any client attached to the access point collecting measurements.

**Client Traffic Stream Metrics Report Results**

---

**Note**

Use the Create Custom Report page to customize the displayed results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

The following are potential results for a Client Traffic Stream Metrics report, depending on how the report is customized (see Figure 15-15):

- Time (mandatory column)
- Client MAC (mandatory column)
- **QoS (mandatory column)—**QoS values (packet latency, packet jitter, packet loss, roaming time) which can affect the WLAN are monitored. Access points and clients measure the metrics, access points collect the measurements and send them to the controller. The access points update the controller with traffic stream metric information every 90 seconds and 10 minutes of data per client is stored in the WLC. WCS polls this data and stores it for the last seven days.
- **AP Name (mandatory column)**
- **Radio Type (mandatory column)**
- **Avg Queuing Delay (ms) (Downlink) (mandatory column)—**Average queuing delay in milliseconds for the downlink. Average packet queuing delay is the average delay of voice packets traversing the voice queue. Packet queue delay is measured beginning when a packet is queued for transmission and ending when the packet is successfully transmitted. It includes time for re-tries, if needed.
- **Avg Queuing Delay (ms) (Uplink) (mandatory column)—**Average queuing delay in milliseconds for the uplink. Average packet queuing delay is the average delay of voice packets traversing the voice queue. Packet queue delay is measured beginning when a packet is queued for transmission and ending when the packet is successfully transmitted. It includes time for re-tries, if needed.
- **% PLR (Downlink)—**Percentage of packets lost on the downlink (access point to client) during the 90 second interval.
- **% PLR (Uplink)—**Percentage of packets lost on the uplink (client to access point) during the 90 second interval.
- **% Packets > 40ms Queuing Delay (Uplink)—**Percentage of queuing delay packets greater than 40 ms.
- **% Packets 20ms-40ms Queuing Delay (Uplink)—**Percentage of queuing delay packets between 20ms-40 ms.
- **Roaming Delay—**Roaming delay in milliseconds. Roaming delay, which is measured by clients, is measured beginning when the last packet is received from the old access point and ending when the first packet is received from the new access point after a successful roam.
- **Time—**Time that the statistics were gathered from the access point(s).

Client MAC—MAC address of the client. This shows a list of the clients evaluated during the most recent 90 second interval. The client could be a VoIP phone, laptop, PDA and refers to any client attached to the access point collecting measurements.
Throughput

This report displays the ongoing bandwidth used by the wireless clients on your network.

Note

The **Throughput** report does not include wired clients or clients connected to Autonomous Cisco IOS access points.

Click **Throughput** from the Report Launch Pad to open the Throughput Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

Configuring a Throughput Report

This section describes how to configure a Throughput report.

Settings

- Report Title—If you plan to used this as a saved report, enter a report name.
- Report by
  - Controller—Choose **All Controllers** from the Report Criteria page, or click **Edit** to select specific devices.
- Floor Area—Choose All Campuses > All Buildings > All Floors from the Report Criteria page, or click Edit to select specific locations.
- Outdoor Area—Choose All Campuses > All Outdoor Areas from the Report Criteria page, or click Edit to select specific locations.
- AP by Controller—Choose All Controllers > All Access Points, or click Edit to select specific devices.
- AP by Floor Area—Choose All Campuses > All Buildings > All Floors > All APs from the Report Criteria page, or click Edit to select specific locations or devices.
- AP by Outdoor Area—Choose All Campuses > All Outdoor Areas > All APs from the Report Criteria page, or click Edit to select specific locations or devices.

**Note**
In the Report Criteria page, click Select to confirm your filter criteria or Close to return to the previous page.

- Protocol—Choose All Clients or a specific radio type from the drop-down list.

**Note**
Wired clients and clients associated to Cisco IOS access points are not included as part of this report.

- Reporting Period
  - Last—Select the Last radio button and a period of time from the drop-down list.
  - From—Select the From radio button and enter the From and To dates and times. You can type a date in the text box, or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

**Note**
The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

**Schedule**
If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

**Throughput Report Results**
The Throughput report graph displays the following (see Figure 15-16):
- Total throughput (mbps)
- Throughput for the selected protocol
- Date and time for each indicated throughput level
Figure 15-16 Throughput Report Results

Throughput
Generated: 2011-May-18, 05:10:31 UTC
Report By: All
All, All
Connection Protocol: All Clients
Reporting Period: Last 1 day
Client Throughput

Unique Clients

This report displays all unique clients by the time, protocol, and controller filters that you select. A unique client is determined by the MAC address of the client device. These clients are sorted by controller in this report.

Click Unique Clients from the Report Launch Pad to open the Unique Clients Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

A new First Seen column is added in release 6.0. It is the time that WCS first learned of the client MAC address. For existing clients, WCS sets the First Seen column with the timestamp currently in the database, which is the time the record was last updated.

Note

Unique Clients reports do not include autonomous clients.

Configuring a Unique Clients Report

This section describes how to configure a Unique Clients report.

Settings

- Report Title—If you plan to use this as a saved report, enter a report name.
- Report by
  - Controller—Choose All Controllers from the Report Criteria page, or click Edit to select specific devices.
  - Floor Area—Choose All Campuses > All Buildings > All Floors from the Report Criteria page, or click Edit to select specific locations.
- Outdoor Area—Choose All Campuses > All Outdoor Areas from the Report Criteria page, or click Edit to select specific locations.
- AP by Floor Area—Choose All Campuses > All Buildings > All Floors > All APs from the Report Criteria page, or click Edit to select specific locations or devices.
- AP by Outdoor Area—Choose All Campuses > All Outdoor Areas > All APs from the Report Criteria page, or click Edit to select specific locations or devices.
- SSID—Choose All SSIDs from the Report Criteria page, or click Edit to select a specific or multiple SSIDs.
- AP by RAP Mesh Role—Choose All RAP APs from the Report Criteria page, or click Edit to select a specific RAP access point.
- Choose a specific RAP access point.

Note In the Report Criteria page, click Select to confirm your filter criteria or Close to return to the previous page.

- Protocol—Choose All Clients, Wired Clients, or a specific radio type from the drop-down list.
- Reporting Period
  - Last—Select the Last radio button and a period of time from the drop-down list.
  - From—Select the From radio button and enter the From and To dates and times. You can type a date in the text box, or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

Note The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Create Custom Report page allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Mandatory columns are displayed in blue font and cannot be moved to Available data fields Column. Last Seen, User, and MAC address are mandatory columns for the Unique Client report.

The following information is available on the unique client report:
- Host Name
- AP MAC Address
- IP Address—The IP address of the controller to which this client is associated.
- Controller IP Address
- Port
- Last Session Length
Client Reports

Chapter 15      Reports

Client Reports

- VLAN ID—The VLAN Identifier. The range is 1 to 4096.
- CCX—The Cisco Client Extension version number.
- E2E
- Vendor—The vendor name for this client.
- IP Address
- AP Name—The access point to which this client is associated.
- Controller—The name of the controller to which this client is associated.
- 802.11 State—Client association status.
- SSID—The SSID to which this client is associated.
- Profile—The name of the profile to which this client is associated.
- Authenticated
- Protocol—802.11a, 802.11b, 802.11g, 802.11n_5GHz, or 802.11b_2.4GHz.
- Map Location

Unique Client Report Results

The following information is displayed for a Unique Client report (see Figure 15-17):
- First/Last Seen—Date and time the unique client was first and last viewed
- User—Client username
- Vendor—The vendor name or Unknown
- Client IP Address and MAC Address
- AP Name
- Controller—The controller to which the client was associated
- Port
- 802.11 State—Associated, Disassociated, or Idle
- SSID

Note: N/A may display in the SSID field if the client is probing.

- Authenticated—Indicates whether or not the client is authenticated (Yes or No)
- Protocol—802.11a, 802.11b, 802.11g, 802.11n_5GHz, or 802.11b_2.4GHz.
- VLAN ID
- CCX—Indicates whether or not CCX (Cisco Client Extensions) is supported.
- E2E—Indicates whether or not E2E (End to End) is supported.
- Map Location
Figure 15-17  Unique Client Report Results

V5 Client Statistics

This report displays the 802.11 and security statistics for Cisco Compatible Extensions v5 clients. Click V5 Client Statistics from the Report Launch Pad to open the V5 Client Statistics Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

Configuring a V5 Client Statistics Report

This section describes how to configure a V5 Client Statistics report.

Settings

- Report Title—If you plan to use this as a saved report, enter a report name.
- Reporting Period
  - Last—Select the Last radio button and a period of time from the drop-down list.
  - From—Select the From radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

Note  The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.
Chapter 15      Reports

Compliance Reports

V5 Client Statistics Report Results

The following information is displayed for the v5 Client Statistics report.

- Client MAC Address
- Transmitted Fragment Count—This counter is incremented for each successfully received MPDU Data or Management type.
- Multicast Transmitted Frame Count—This counter increments only when the multicast bit is set in the destination MAC address of a successfully transmitted MSDU. When operating as a STA in an ESS, where these frames are directed to the access point, this implies having received an acknowledgment to all associated MPDUs.
- Failed Count—This counter increments when an MSDU is unsuccessfully transmitted.
- Retry Count—This counter increments when an MSDU is successfully transmitted after one or more retransmissions.
- Multicast Retry Count—This counter increments when an MSDU is successfully transmitted after more than one retransmission.
- Frame Duplicate Count—This counter increments when a frame is received that the Sequence Control field indicates is a duplicate.
- RTS Success Count—This counter increments when a CTS (clear-to-send) is received in response to an RTS (ready-to-send).
- RTS Fail Count—This counter increments when a clear-to-send is not received in response to a ready-to-send.
- ACK Fail Count—This counter increments when an ACK is not received when expected.
- Received Fragment Count—The total number of packets received that were less than 64 octets in length (excluding framing bits but including FCS octets).
- Multicast Received Frame Count—This counter increments when a MSDU is received with the multicast bit set in the destination MAC address.
- FCS Error Count—This counter increments when a Frame Check Sequence error is detected in a received MPDU.
- Transmitted Frame Count—This counter increments for each successfully transmitted MSDU.

Compliance Reports

The Configuration Audit report displays the differences between WCS and its controllers. The PCI DSS Compliance report summarizes your Wireless LAN Security components with reference to the Payment Card Industry (PCI) Data Security Standard (DSS) requirements. PCI DSS compliance is required for all merchants and service providers that store, process, or transmit cardholder data. You can find PCI DSS standards at https://www.pcisecuritystandards.org.

The section contains the following topics:

- Configuration Audit Report
- PCI DSS Detailed
- PCI DSS Summary
Chapter 15      Reports
Compliance Reports

Configuration Audit Report

This report displays the configuration differences between WCS and its controllers. You must configure audit mode in the Administration > Settings page. In audit mode, you can perform an audit based on templates or the stored configuration. The report shows the last time an audit was performed using the Configuration Sync background task.

Click Configuration Audit from the Report Launch Pad to open the Configuration Audit Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the Configuration Reports page. See the “Configuring a Configuration Audit Report” section on page 15-49 and the “Configuration Audit Report Results” section on page 15-50 for more information.

Configuring a Configuration Audit Report

This section describes how to configure a Configuration Audit report.

Settings

- Report Title—If you plan to used this as a saved report, enter a report name.
- Controller—Choose All Controllers or a specific controller from the available list.
- Audit Time—Choose Latest or a specific date and time from the available list.

Note The available audit times are based on when the Configuration Sync background task was run.

- Reporting Period
  - Last—Select the Last radio button and a period of time from the drop-down list.
  - From—Select the From radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

Note The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Customize Report Format allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.
A Configuration Audit report includes the following sections: Audit Summary, Applied Templates and Config Group Template Discrepancies, Enforced Values, Failed Enforcements, and WCS Config Discrepancies. Choose the applicable report from the Customizable Report drop-down list. To customize report results for a particular section, select the applicable section from the Customizable Report drop-down list.

A Configuration Audit report contains the following default information, depending on which customized report is selected:

- Controller Name
- Audit Status
- Audit Time
- Name
- Audit Object Display Name
- Device Sync State
- Time
- Client MAC Address
- IP Address
- Message
- Description
- Attribute
- Attribute Value in WCS
- Attribute Value in Device
- Enforced Value
- Instance Name
- Description
- Error Message
- Attribute Value in DB

Configuration Audit Report Results

The following are potential results for a Configuration Audit report, depending on how the report is customized (see Figure 15-18):

- Audit Summary results
  - Controller Name (mandatory column)
  - Audit Status (mandatory column)—Not Available (no audit occurred on this switch), Identical (no configuration differences were discovered), Mismatch (configuration differences were discovered).
- Audit Time (mandatory column)—The time when the network audit background task was run via Configuration Sync task.
- IP Address—The IP address of the audited controller.
- Message—It reports “Device unreachable” if the device is unreachable. Also, if any exceptions are found during the audit, it reports “Internal Exception, check the log files”.

- Applied Templates and Config Group Template Discrepancies results
  - Name (mandatory column)
  - Template Name (mandatory column)
  - Audit Status (mandatory column)—(Mismatch, Identical, Not Available)
  - Template Applied Via—Template description.
  - Attribute
  - WCS Value
  - Controller Device

- Enforced Values results
  - Name (mandatory column)
  - Template Name (mandatory column)
  - Audit Status (mandatory column)
  - Template Applied Via
  - Attribute
  - Enforced Value
  - Controller Value

- Failed Enforcements results
  - Name (mandatory column)
  - Object Name
  - Description
  - Error Message

- WCS Config Discrepancies results
  - Controller Name (mandatory column)
  - Object Name (mandatory column)
  - Audit Status (mandatory column)
  - Attribute (mandatory column)
  - WCS Value
  - Controller Value
Figure 15-18  Configuration Audit Report Results

Config Audit
Generated: 2011-May-18, 05:35:57 UTC

Audit Summary

<table>
<thead>
<tr>
<th>Controller Name</th>
<th>Audit Status</th>
<th>Audit Time</th>
<th>Controller IP Address</th>
<th>Message</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco_07:21:43</td>
<td>Identical</td>
<td>2011-May-18, 04:30:03 UTC</td>
<td>10.33.126.2</td>
<td></td>
</tr>
<tr>
<td>Cisco_20:5b:00</td>
<td>Identical</td>
<td>2011-May-19, 04:30:03 UTC</td>
<td>10.32.100.64</td>
<td></td>
</tr>
<tr>
<td>Cisco_32:1b:25</td>
<td>Identical</td>
<td>2011-May-18, 04:30:03 UTC</td>
<td>10.32.57.4</td>
<td></td>
</tr>
<tr>
<td>Cisco_63:e3:03</td>
<td>Mismatch</td>
<td>2011-May-19, 04:30:03 UTC</td>
<td>10.32.52.5</td>
<td></td>
</tr>
<tr>
<td>Cisco_65:51:00</td>
<td>Mismatch</td>
<td>2011-May-19, 04:30:03 UTC</td>
<td>10.32.56.10</td>
<td></td>
</tr>
<tr>
<td>Cisco_72:16:03</td>
<td>Mismatch</td>
<td>2011-May-18, 04:30:03 UTC</td>
<td>10.32.55.5</td>
<td></td>
</tr>
<tr>
<td>Cisco_78:58:00</td>
<td>Mismatch</td>
<td>2011-May-18, 04:30:03 UTC</td>
<td>171.70.35.231</td>
<td></td>
</tr>
<tr>
<td>Cisco_1e:0e:40</td>
<td>Identical</td>
<td>2011-May-19, 04:30:03 UTC</td>
<td>10.134.145.10</td>
<td></td>
</tr>
<tr>
<td>Cisco_7e:0c:23</td>
<td>Identical</td>
<td>2011-May-18, 04:30:03 UTC</td>
<td>10.32.160.160</td>
<td></td>
</tr>
<tr>
<td>Cisco_91:26:03</td>
<td>Identical</td>
<td>2011-May-19, 04:30:03 UTC</td>
<td>10.34.145.84</td>
<td></td>
</tr>
<tr>
<td>Cisco_51:29:00</td>
<td>Identical</td>
<td>2011-May-19, 04:30:03 UTC</td>
<td>10.34.145.86</td>
<td></td>
</tr>
</tbody>
</table>

PCI DSS Detailed

This report displays the PCI Data Security Standard (DSS) version 2.0 requirements in detail that are relevant to your wireless network security.

Click **PCI DSS Detailed** from the Report Launch Pad to open the PCI DSS Detailed Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click **New** from the Report Launch Pad or from the PCI DSS Detailed Reports page. See the “Configuring a PCI DSS Detailed Report” section on page 15-52 and the “PCI DSS Detailed Report Results” section on page 15-53 for more information.

Configuring a PCI DSS Detailed Report

This section describes how to configure a PCI DSS Detailed report.

**Settings**

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report By**
  - **Controller**—Choose **All Controllers** from the Report Criteria box, or click **Edit** to select specific devices.
  - **MSE**—Choose **All MSEs** from the Report Criteria box, or click **Edit** to select a specific MSE.
  - **Floor Area**—Choose **All Campuses > All Buildings > All Floors** from the Report Criteria box, or click **Edit** to select specific locations.
Note: In the Filter Criteria box, select the appropriate filter criteria.

- Reporting Period—Specify the time period for which the report needs to be generated. You can select from a list of choices defined such as Last 1 hour, Last 6 hours, and so on, or specify a custom period by choosing the From and To date and time.

Note: The times are shown in the local time of the WCS server.

**Schedule**

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

**Customize Report Form**

Click **Customize** to open the Create Custom Report form, which you can use to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note: Fixed columns appear in blue font and cannot be moved to Available Columns.

**PCI DSS Detailed Report Results**

The following are the results for a PCI DSS Detailed Report (see Figure 15-19):
Chapter 15  Reports

Compliance Reports

Figure 15-19  PCI DSS Detailed Report

PCI DSS Detailed

Generated: Wed Oct 20 19:34:29 PDT 2010
Reporting Period: Last 84 days

Introduction

This detailed report covers sections of the Payment Card Industry (PCI) Data Security Standard (DSS) version 2.0 requirements that are relevant to your Cisco Unified Wireless network security. PCI DSS standard requirements are available at https://www.pcisecuritystandards.org

Disclaimer

The report and related information provided in the following pages was generated based upon network information gathered by Cisco’s Wireless Control System (WCS). This report may be helpful in assessing various aspects of the Payment Card Industry (PCI) Data Security Standard (DSS) version 1.2 (October 2008) requirements applicable to a Cisco Unified Wireless network. This report and information set forth herein should not be used as a substitute for a formal PCI compliance audit. THIS REPORT AND THE INFORMATION AND RESULTS RELECTED IN THE RAPPORT THAT FOLLOW ARE PROVIDED WITHOUT WARRANTY. RESULTS SHOULD NOT BE RELIED UPON IN COMPLIANCE WITH THE PCI DSS REQUIREMENTS. IN THE EVENT OF DISPUTE, THE DSS RULES AND GUIDELINES APPLY.

PCI DSS Requirement 2.1.1

For wireless environments connected to the cardholder data environment or transmitting cardholder data, change wireless vendor defaults, including but not limited to default wireless encryption keys, passwords, and WMM community string, frame wireless devices security settings are enabled for strong encryption technology for authentication and transmission.

Mandatory individuals (external and internal to the company) often use default passwords, WMM community strings, DSS settings to compromise cardholder data environment.

List of Violations for PCI DSS Requirement 2.1.1

<table>
<thead>
<tr>
<th>Device Name</th>
<th>Violation Description</th>
<th>Device Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>client-controller-1</td>
<td>Controller is configured with default community string for SHFP v1/v2</td>
<td>Controller</td>
</tr>
<tr>
<td>client-controller-1</td>
<td>WMAP client-controller-1 is configured with weak authentication/encryption method</td>
<td>Controller</td>
</tr>
<tr>
<td>client-controller-1</td>
<td>WMAP guest is configured with weak authentication/encryption method</td>
<td>Controller</td>
</tr>
<tr>
<td>client-controller-1</td>
<td>WMAP 'hmeet' is configured with weak authentication/encryption method</td>
<td>Controller</td>
</tr>
<tr>
<td>client-controller-1</td>
<td>WMAP p2 is configured with weak authentication/encryption method</td>
<td>Controller</td>
</tr>
<tr>
<td>client-controller-1</td>
<td>WMAP 'xmeet' is configured with weak authentication/encryption method</td>
<td>Controller</td>
</tr>
<tr>
<td>client-controller-1</td>
<td>WMAP 'xmeet' is configured with weak authentication/encryption method</td>
<td>Controller</td>
</tr>
<tr>
<td>client-controller-2</td>
<td>Controller is configured with default community string for SHFP v1/v2</td>
<td>Controller</td>
</tr>
<tr>
<td>client-controller-2</td>
<td>WMAP client-controller-2 is configured with weak authentication/encryption method</td>
<td>Controller</td>
</tr>
<tr>
<td>client-controller-2</td>
<td>WMAP 'hmeet' is configured with weak authentication/encryption method</td>
<td>Controller</td>
</tr>
<tr>
<td>client-controller-2</td>
<td>WMAP 'gmeet' is configured with weak authentication/encryption method</td>
<td>Controller</td>
</tr>
</tbody>
</table>

PCI DSS Summary

This report displays a summarized PCI Data Security Standard (DSS) version 2.0 requirements that are relevant to your wireless network security.

Click **PCI DSS Summary** from the Report Security Standard (DSS) Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click **New** from the Report Launch Pad or from the **PCI DSS Summary Reports** page. See the “Configuring a PCI DSS Summary Report” section on page 15-55 and the “PCI DSS Summary Report Results” section on page 15-55 for more information.
Configuring a PCI DSS Summary Report

This section describes how to configure a PCI DSS Summary report.

Settings

- Report Title—If you plan to use this as a saved report, enter a report name.
- Reporting Period—Specify the time period for which the report needs to be generated. You can select from a list of choices defined such as Last 1 hour, Last 6 hours, and so on, or specify a custom period by selecting the From and To date and time.

  Note The times are shown in the local time of the WCS server.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

Click Customize to open the Create Custom Report form, which you can use to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

  Note Fixed columns appear in blue font and cannot be moved to Available Columns.

PCI DSS Summary Report Results

The results of PCI DSS Summary Report contains the following information (see Figure 15-20):

- Number of Violations By PCI DSS Requirement
- Number of Devices Violated By PCI DSS Requirement
- Summary By PCI DSS Requirement
- Summary By Devices
- List of Violations
Figure 15-20  PCI DSS Summary Report

PCI DSS Summary

Generated: Wed Oct 20 05:17:33 PDT 2010

Reporting Period: Last 94 days

Introduction

This summary report covers sections of the Payment Card Industry (PCI) Data Security Standard (DSS) Version 1.2 (October 2008) requirements that are relevant to your Cisco Unified Wireless Network security. PCI DSS standard requirements are available at https://www.pcisecuritystandards.org.

Disclaimer

This report and related information provided in the following pages was generated based upon network information gathered by Cisco’s Wireless Control System (“WCS”). This report may be helpful in assessing various aspects of the Payment Card Industry (PCI) Data Security Standard (DSS) version 1.2 (October 2008) requirements applicable to a Cisco Unified Wireless Network. This report and information set forth herein should not be used as a substitute for a formal PCI compliance audit. THIS REPORT AND THE INFORMATION AND RESULTS REFLECTED IN THE PAGES THAT FOLLOW ARE PROVIDED WITHOUT WARRANTY. RESULTS SHOULDN’T BE RELIED UPON IN CONFIRMING COMPLIANCE WITH THE PCI DSS STANDARD OR ANY OTHER SECURITY STANDARD. CISCO’S END USER LICENSE AGREEMENT, INCLUDING WITHOUT LIMITATION LIMITED WARRANTY AND DISCLAIMER OF LIABILITIES PROVISIONS APPLY.
ContextAware Reports

This section describes the various ContextAware reports that you can generate through the WCS Reports Launch Pad.

To generate a ContextAware report, under the ContextAware section, click New to create a new report. See the “Creating and Running a New Report” section on page 15-3 for more information.

Click a report type to view currently saved reports. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

You can create the following ContextAware Reports. This section contains the following topics:

- Client Location History, page 15-57
- Client Location Tracking, page 15-58
- Guest Location Tracking, page 15-60
- Location Notifications, page 15-61
- Rogue AP Location Tracking, page 15-63
- Rogue Client Location Tracking, page 15-65
- Tag Location History, page 15-66
- Tag Location Tracking, page 15-67

Client Location History

This report displays Location history of a wireless client detected by an MSE.

This section contains the following topics:

- Configuring a Client Location History, page 15-57
- Client Location History Results, page 15-58

Configuring a Client Location History

This section describes how to configure a Client Location History report.

Settings

- Report Title—If you plan to used this as a saved report, enter a report name.
- Report by
  - Client MAC address.
- Report Criteria—Click Edit and enter a valid MAC address as the filter criteria.

Note

In the Report Criteria page, click Select to confirm your filter criteria or Close to return to the previous page.

- Reporting Period
  - Select the radio button and a period of time from the drop-down list.
Or

- Select the **From** radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

---

**Note**
The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

---

**Schedule**

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

---

**Customize Report Form**

The Customize Report Form allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

---

**Note**
Fixed columns appear in blue font and cannot be moved to Available Columns.

---

**Client Location History Results**

The Client Location History Report results contain the following information:

- Last Located—The time when the client was located.
- Client Location—Position of the client at the located time.
- MSE—Name of the MSE which located this client.
- User—The username of the client.
- Detecting Controllers—The IP address of the detecting controller.
- 802.11 State—The state of 802.11. It could be either Probing or Associated.
- IP Address—The IP address of the client.
- AP MAC Address—The MAC address of the associated access point.
- Authenticated—Whether authenticated or not. This could be either Yes or No.
- SSID—The SSID used by the client.
- Protocol—The protocol used to retrieve the information from the client.

---

**Client Location Tracking**

This report displays wireless clients and their locations detected by the MSEs based on your filtering criteria.

This section contains the following topics:

- Configuring a Client Location Tracking, page 15-59
- Client Location Tracking Results, page 15-59
Configuring a Client Location Tracking

This section describes how to configure a Client Location Tracking report.

Settings

- **Report Title**—If you plan to used this as a saved report, enter a report name.
- **Report by**
  - MSE By Floor Area.
  - MSE By Outdoor Area
  - MSE
- **Report Criteria**—The report criteria differs based on the Report By option selected. Click **Edit** and select the required filter criteria.

  **Note** In the Report Criteria page, click **Select** to confirm your filter criteria or **Close** to return to the previous page.

- **Reporting Period**
  - Select the radio button and a period of time from the drop-down list.
  - Or
  - Select the **From** radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

  **Note** The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Customize Report Form allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

  **Note** Fixed columns appear in blue font and cannot be moved to Available Columns.

Client Location Tracking Results

The Client Location Tracking Report results contain the following information:

- **Last Located**—The time when the client was last located during the selected Report Time criteria.
- **MAC Address**—The MAC address of the client.
• Client Location—Position of the client at the located time.
• MSE—Name of the MSE which located this client.
• User—The username of the client.
• Detecting Controllers—The IP address of the detecting controller.
• 802.11 State—The state of 802.11. It could be either Probing or Associated.
• IP Address—The IP address of the client.
• SSID—The SSID used by the client
• Protocol—The protocol used to retrieve the information from the client.

Note
The location field in this report is a hyperlink and clicking on that hyperlink would show the location of the client in the floor map at the located time.

Guest Location Tracking

This report displays Guest clients and their locations detected by the MSEs based on your filtering criteria.

This section contains the following topics:

• Configuring Guest Location Tracking, page 15-60
• Guest Location Tracking Results, page 15-61

Configuring Guest Location Tracking

This section describes how to configure a Guest Location Tracking report.

Settings

• Report Title—If you plan to used this as a saved report, enter a report name.
• Report by
  – MSE By Floor Area.
  – MSE By Outdoor Area
  – MSE
• Report Criteria—The report criteria differs based on the Report By option selected. Click Edit and select the required filter criteria.

Note
In the Report Criteria page, click Select to confirm your filter criteria or Close to return to the previous page.

• Reporting Period
  – Select the radio button and a period of time from the drop-down list.
  Or
– Select the From radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

**Note**
The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

### Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

### Customize Report Form

The Customize Report Form allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

**Note**
Fixed columns appear in blue font and cannot be moved to Available Columns.

### Guest Location Tracking Results

The Guest Location Tracking Report results contain the following information:

- Last Located—The time when the Guest client was last located during the selected Report Time criteria.
- Guest Username—The login name of the guest client user.
- MAC Address—The MAC address of the guest client.
- Guest Location—Position of the guest client at the located time.
- MSE—Name of the MSE which located this guest client.
- Detecting Controllers—The IP address of the detecting controller.
- IP Address—The IP address of the guest client.
- AP MAC Address—The MAC address of the access point to which the guest client is associated with.
- SSID—The SSID used by the guest client.
- Protocol—The protocol used to retrieve the information from the guest client.

**Note**
The location field in this report is a hyperlink and clicking on that hyperlink would show the location of the guest in the floor map at the located time.

### Location Notifications

This report displays Context Aware Notifications generated by MSEs.

This section contains the following topics:
Configuring Location Notification

This section describes how to configure a Location Notification report.

Settings

- Report Title—If you plan to used this as a saved report, enter a report name.
- Report by
  - Missing Device Notifications by MSE
  - Missing Device Notifications by Floor Area
  - Missing Device Notifications by Outdoor Area
  - Device In/Out Notifications by MSE
  - Device In/Out Notifications by Floor Area
  - Device In/Out Notifications by Outdoor Area
- Report Criteria—The report criteria differs based on the Report By option selected. Click Edit and select the required filter criteria.

  Note
  In the Report Criteria page, click Select to confirm your filter criteria or Close to return to the previous page.

- Device Type
  - All
  - Client
  - Tag
  - Rogue Client
  - Rogue AP
  - Interferer
- Reporting Period
  - Select the radio button and a period of time from the drop-down list.
  Or
  - Select the From radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

  Note
  The reporting period is based on the alarm last seen time. The times are in the UTC time zone.
Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Customize Report Form allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note

Fixed columns appear in blue font and cannot be moved to Available Columns.

Location Notification Report Results

The results of Location Notification Report contains the following information:

- Last Seen—The date and time when the device was last located.
- MAC Address—The MAC address of the device.
- Device Type—The type of the device.
- Asset Name—The name of the asset.
- Asset Group—The name of the asset group.
- Asset Category—The name of the asset category.
- Map Location—The map location where the device was located.
- serverName—The name of the server that sends the ContextAware notifications.

Rogue AP Location Tracking

This report displays Rogue APs and their locations detected by the MSEs based on your filtering criteria. This section contains the following topics:

- Configuring Rogue AP Location Tracking, page 15-63
- Rogue AP Location Tracking Results, page 15-64

Configuring Rogue AP Location Tracking

This section describes how to configure a Rogue AP Location Tracking report.

Settings

- Report Title—If you plan to used this as a saved report, enter a report name.
- Report by
  - MSE By Floor Area.
  - MSE By Outdoor Area
  - MSE
• Report Criteria—The report criteria differs based on the Report By option selected. Click **Edit** and select the required filter criteria.

| Note | In the Report Criteria page, click **Select** to confirm your filter criteria or **Close** to return to the previous page. |

• Reporting Period
  - Select the radio button and a period of time from the drop-down list.
  
  Or
  - Select the **From** radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

| Note | The reporting period is based on the alarm last seen time. The times are in the UTC time zone. |

**Schedule**

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

**Customize Report Form**

The Customize Report Form allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

| Note | Fixed columns appear in blue font and cannot be moved to Available Columns. |

**Rogue AP Location Tracking Results**

The Rogue AP Location Tracking Report results contain the following information:

- **Last Located**—The time when the Rogue AP was last located during the selected Report Time criteria.
- **MAC Address**—The MAC address of the rogue access point.
- **Rogue AP Location**—Position of the Rogue AP at the located time.
- **MSE**—Name of the MSE which located this Rogue AP.
- **State**—The state of the Rogue AP.

| Note | The location field in this report is a hyperlink and clicking on that hyperlink would show the location of the rogue AP in the floor map at the located time. |
Rogue Client Location Tracking

This report displays Rogue Client APs and their locations detected by the MSEs based on your filtering criteria.

This section contains the following topics:

- Configuring Rogue Client Location Tracking, page 15-65
- Rogue Client Location Tracking Results, page 15-66

Configuring Rogue Client Location Tracking

This section describes how to configure a Rogue Client Location Tracking report.

Settings

- Report Title—If you plan to use this as a saved report, enter a report name.
- Report by
  - MSE By Floor Area.
  - MSE By Outdoor Area
  - MSE
- Report Criteria—The report criteria differs based on the Report By option selected. Click Edit and select the required filter criteria.

  **Note**  
  In the Report Criteria page, click Select to confirm your filter criteria or Close to return to the previous page.

- Reporting Period
  - Select the radio button and a period of time from the drop-down list.  
  Or
  - Select the From radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

  **Note**  
  The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Customize Report Form allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.
Rogue Client Location Tracking Results

The results of Rogue Client Location Tracking Report contains the following information:

- Last Located—The time when the rogue client was last located during the selected Report Time criteria.
- MAC Address—The MAC address of the rogue client.
- Rogue Client Location—Position of the rogue client at the located time.
- MSE—Name of the MSE which located this rogue client.
- Rogue AP—The rogue access point to which the rogue client is associated with.
- Detecting Controllers—The IP address of the detecting controller.
- State—State of the Rogue Client.

Note

The location field in this report is a hyperlink and clicking on that hyperlink would show the location of the rogue client in the floor map at the located time.

Tag Location History

This report displays Location history of a tag detected by an MSE.

This section contains the following topics:

- Configuring Tag Location Tracking, page 15-68
- Tag Location Tracking Results, page 15-68

Configuring Tag Location History

This section describes how to configure a Tag Location History report.

Settings

- Report Title—If you plan to used this as a saved report, enter a report name.
- Report by
  - Tag MAC address.
- Report Criteria—Click Edit and enter a valid Tag MAC address as the filter criteria.

Note

In the Report Criteria page, click Select to confirm your filter criteria or Close to return to the previous page.

- Reporting Period
  - Select the radio button and a period of time from the drop-down list.
Or

- Select the **From** radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

**Note**
The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

**Schedule**

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

**Customize Report Form**

The Customize Report Form allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

**Note**
Fixed columns appear in blue font and cannot be moved to Available Columns.

**Tag Location History Results**

The results of Tag Location History Report contains the following information:

- **Last Located**—The time when the tag was last located during the selected Report Time criteria.
- **Tag Location**—Position of the tag at the located time.
- **MSE**—Name of the MSE which located this tag.
- **Detecting Controller**—The IP address of the detecting controller.
- **Vendor**—The name of the vendor for the client.
- **Battery Status**—The battery status of the client.

**Note**
The location field in this report is a hyperlink and clicking on that hyperlink would show the location of the tag in the floor map at the located time.

**Tag Location Tracking**

This report displays tags and their locations detected by the MSEs based on your filtering criteria.

This section contains the following topics:

- Configuring Tag Location Tracking, page 15-68
- Tag Location Tracking Results, page 15-68
Configuring Tag Location Tracking

This section describes how to configure a Tag Location Tracking report.

Settings

- Report Title—If you plan to used this as a saved report, enter a report name.
- Report by
  - MSE By Floor Area
  - MSE By Outdoor Area
  - MSE
- Report Criteria—The report criteria differs based on the Report By option selected. Click Edit and select the required filter criteria.

Note: In the Report Criteria page, click Select to confirm your filter criteria or Close to return to the previous page.

- Reporting Period
  - Select the radio button and a period of time from the drop-down list.
  Or
  - Select the From radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

Note: The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Customize Report Form allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note: Fixed columns appear in blue font and cannot be moved to Available Columns.

Tag Location Tracking Results

The Tag Location Tracking Report report results contain the following information:

- Last Located—The time when the tag was last located during the selected Report Time criteria.
- Tag Location—Position of the tag at the located time.
- MSE—Name of the MSE which located this tag.
- Detecting Controller—The IP address of the detecting controller.
- Vendor—The name of the tag vendor.
- Battery Status—The status of the battery of that tag.

**Note**
The location field in this report is a hyperlink and clicking on that hyperlink would show the location of the tag in the floor map at the located time.

---

**Device Reports**

Click New for a Device Report type to create a new report. See the “Creating and Running a New Report” section on page 15-3 for more information.

Click a report type to view currently saved reports. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

This section contains the following topics:
- AP Image Predownload
- AP Profile Status
- Busiest APs
- AP Summary
- Inventory Reports
- Uptime
- Utilization

---

**AP Image Predownload**

This report displays scheduled download software task status.

Click AP Image Predownload from the Report Launch Pad to open the AP Image Predownload page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.


---

**Configuring an AP Image Predownload Report**

This section describes how to configure a AP Image Predownload report.

**Settings**

The following settings can be configured for a AP Image Predownload report:
- Report Title—If you plan to use this as a saved report, enter a report name.
Device Reports

Chapter 15      Reports

- Report by
  - AP by Controller—Choose All Controllers > All Access Points from the Report Criteria page, or click Edit to select specific devices.
  - AP by Floor Area—Choose All Campuses > All Buildings > All Floors > All Access Points from the Report Criteria page, or click Edit to select specific locations or devices.
  - AP by Outdoor Area—Choose All Campuses > All Outdoor Areas > All Access Points from the Report Criteria page, or click Edit to select specific locations or devices.

Note
In the Report Criteria page, you can select All Access Points or All OfficeExtend Access Points.

Note
In the Report Criteria page, click Select to confirm your filter criteria or Close to return to the previous page.

- Show—Enter a number between 10 and 50, or leave blank to show all records.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Creating a Custom Report

The Create Custom Report page allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note
Mandatory columns are displayed in blue font and cannot be moved to Available Columns. AP Name, Primary Image, Backup Image, Predownload Version, and Predownload Status are mandatory columns for the AP Image Predownload report.

Command Buttons

Once all report parameters have been set, select from the following:
- Save—Click to save this report setup without immediately running the report. The report will automatically run at the scheduled time.
- Save and Run—Click to save this report setup and to immediately run the report.
- Run Now—Click to run the report without saving the report setup.
- Export Now—Click to export the report results. The supported export formats is PDF and CSV.
- Cancel—Click to return to the previous page without running nor saving this report.

Note
See the “Creating and Running a New Report” section on page 15-3 for additional information on running or scheduling a report.
AP Image Predownload Report Results

The following are potential results for an AP Image Predownload report, depending on how the report is customized:

- AP Name—Access point name.
- Primary Image—Current Primary Image present in the AP.
- Backup Image—Current Backup Image present in the AP.
- Predownload Version—The image version that is currently downloading to the AP from the controller as part of the predownload process.
- Predownload Status—The current status of the image download as part of the predownload process.
- MAC Address—MAC Address of the AP.
- Controller IP Address—IP address of the controller to which the access point is associated.

AP Profile Status

This report displays access point load, noise, interference, and coverage profile status.

Click AP Profile Status from the Report Launch Pad to open the AP Profile Status Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the AP Profile Status Reports page. See the “Configuring an AP Profile Report” section on page 15-71 and the “AP Profile Status Report Results” section on page 15-72 for more information.

Configuring an AP Profile Report

This section describes how to configure a AP Profile report.

Settings

- Report Title—If you plan to used this as a saved report, enter a report name.
- Report by
  - AP by Controller—Choose All Controllers > All Access Points from the Report Criteria page, or click Edit to select specific devices.
  - AP by Floor Area—Choose All Campuses > All Buildings > All Floors > All Access Points from the Report Criteria page, or click Edit to select specific locations or devices.
  - AP by Outdoor Area—Choose All Campuses > All Outdoor Areas > All Access Points from the Report Criteria page, or click Edit to select specific locations or devices.

Note: In the Reports Criteria page, you can select All Access Points or All OfficeExtend Access Points.

Note: In the Report Criteria page, click Select to confirm your filter criteria or Close to return to the previous page.
Chapter 15 Reports

Device Reports

- Protocol—Choose **802.11 a/n, 802.11 b/g/n**, or both.
- Reporting Period
  - Last—Select the Last radio button and a period of time from the drop-down list.
  - From—Select the From radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

**Note**
The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

**Schedule**

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

**Customize Report Form**

The Customize Report Format allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

**Note**
Fixed columns appear in blue font and cannot be moved to Available Columns.

AP Profile Status report results include:
- Time—The date and time at which AP Profile Status is collected.
- AP Name—The access point name.
- AP MAC address—The MAC address of the access point.
- Radio Type—**802.11a/n** or **802.11b/g/n**.
- Load—*True* if the load level exceeds a threshold level, otherwise *false*.
- Noise—*True* if the noise level exceeds a threshold level, otherwise *false*.
- Controller Name—The controller to which the access point is associated.
- Interference—*True* if the interference level exceeds a threshold level, otherwise *false*.
- Coverage—*True* if the coverage level exceeds a threshold level, otherwise *false*.
- Controller IP Address—The IP address of the controller to which the access point is associated.

**AP Profile Status Report Results**

The following are potential results for an AP Profile Status report, depending on how the report is customized (see Figure 15-21):
- Time (mandatory column)—The date and time at which AP Profile Status is collected.
- AP Name (mandatory column)—Access point name.
- AP MAC address—MAC address of the access point.
- Radio Type—**802.11a/n** or **802.11b/g/n**.
• Load—Pass or Fail. Indicates whether or not the load level exceeds a threshold level.
• Noise—Pass or Fail. Indicates whether or not the noise level exceeds a threshold level.
• Interference—Pass or Fail. Indicates whether or not the interference level exceeds a threshold level.
• Coverage—Pass or Fail. Indicates whether or not the coverage level exceeds a threshold level.
• Controller Name—Name of the controller to which the access point is associated.
• Controller IP Address—IP address of the controller to which the access point is associated.

Figure 15-21  AP Profile Status Report Results

Busiest APs

This report displays the access points with the highest total usage (transmitting, receiving, and channel utilization) on your wireless network.

Click Busiest APs from the Report Launch Pad to open the Busiest APs Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the Busiest APs Reports page. See the “Configuring a Busiest APs Report” section on page 15-73 and the “Configuring a Busiest APs Report” section on page 15-73 for more information.

Configuring a Busiest APs Report

This section describes how to configure a Busiest APs report.

Settings

• Report Title—If you plan to used this as a saved report, enter a report name.
• Protocol—Choose 802.11 a/n or 802.11 b/g/n from the drop-down list.

• Reporting Period
  - Last—Select the Last radio button and a period of time from the drop-down list.
  - From—Select the From radio button and enter the From and To dates and times. You can type a date in the text box, or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

**Note** The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

• Show—Enter the number of records that you want displayed on each page.

**Note** Leave the text box blank to display all records.

**Schedule**

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

**Customize Report Form**

The Customize Report Format allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

**Note** Fixed columns appear in blue font and cannot be moved to Available Columns.

Busiest APs report results include:

• AP Name—The access point name.

• Radio Type

• Rx Utilization (%)—The percentage of time that the access point receiver is busy operating on packets. The percentage (0 to 100%) represents a load from 0 to 1.

• Tx Utilization (%)—The percentage of time that the access point transmitter is busy operating on packets. The percentage (0 to 100%) represents a load from 0 to 1.

• Channel Utilization (%)—The percentage of time that an access point channel is busy operating on packets. The percentage (0 to 100%) represents a load from 0 to 1.

• Controller Name

• Map Location—The building, floor area, or outdoor area (as applicable) where the access point is located.

• Controller IP Address

**Busiest APs Report Results**

The following are potential results for a Busiest APs report, depending on how the report is customized (see Figure 15-22):
**Figure 15-22  Busiest APs Report Results**

### Busiest APs

**Generated:** 2011-May-18, 09:15:32 UTC  
**Report By:** AP By Controller  
**Protocol:** 802.11a/n  
**Reporting Period:** Last 7 days  
**Show:** Up to 5 records

<table>
<thead>
<tr>
<th>AP Name</th>
<th>Radio Type</th>
<th>Rx Utilization (%)</th>
<th>Rx Utilization (%)</th>
<th>Channel Utilization (%)</th>
<th>Controller Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>radio-a1</td>
<td>802.11a/n</td>
<td>6.93</td>
<td>0.11</td>
<td>45.69</td>
<td>Cisco_7f08:80:60</td>
</tr>
<tr>
<td>hide-a2</td>
<td>802.11a/n</td>
<td>0.11</td>
<td>0.11</td>
<td>20.54</td>
<td>Cisco_5602:af</td>
</tr>
<tr>
<td>SJC14-22A-A16</td>
<td>802.11a/n</td>
<td>0.11</td>
<td>0.11</td>
<td>20.54</td>
<td>Cisco_5602:af</td>
</tr>
<tr>
<td>SJC14-22A-A17</td>
<td>802.11a/n</td>
<td>0.11</td>
<td>0.11</td>
<td>20.54</td>
<td>Cisco_5602:af</td>
</tr>
<tr>
<td>SJC14-22A-A18</td>
<td>802.11a/n</td>
<td>0.11</td>
<td>0.11</td>
<td>20.54</td>
<td>Cisco_5602:af</td>
</tr>
<tr>
<td>SJC14-22A-A19</td>
<td>802.11a/n</td>
<td>0.11</td>
<td>0.11</td>
<td>20.54</td>
<td>Cisco_5602:af</td>
</tr>
<tr>
<td>SJC14-22A-A20</td>
<td>802.11a/n</td>
<td>0.11</td>
<td>0.11</td>
<td>20.54</td>
<td>Cisco_5602:af</td>
</tr>
</tbody>
</table>

**AP Summary**

This report displays a list of access points which are broadcasting SSID(s). This report allows you to filter the devices by RF group name, mobility group name, access point group name, SSID, location, and other statistics.

**Note**

This report, by default, displays a list of access points that are broadcasting one or more SSIDs; the *All SSIDs* filter is chosen by default. Access points that are broadcasting no SSID are not displayed.

Click **AP Summary** from the Report Launch Pad to open the AP Summary Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the AP Summary Reports page. See the “Configuring an AP Summary Report” section on page 15-76 and the “AP Summary Report Results” section on page 15-77 for more information.
Configuring an AP Summary Report

This section describes how to configure an AP Summary report.

Settings

- **Report Title**—If you plan to used this as a saved report, enter a report name.
- **Report by**
  - **Floor Area**—Choose **All Campuses > All Builders > All Floors** from the Report Criteria page, or click **Edit** to select specific locations.
  - **Outdoor Area**—Choose **All Campuses > All Outdoor Areas** from the Report Criteria page, or click **Edit** to select specific locations.
  - **OfficeExtend AP**—Choose **Enable** from the Report Criteria page, or click **Edit** to select **Enable** or **Disable**.
  - **AP by Controller**—Choose **All Controllers > All APs** from the Report Criteria page, or click **Edit** to select specific devices.
  - **AP Group**—Choose **All AP Groups** from the Report Criteria page, or click **Edit** to select a specific access point group.
  - **RF Group**—Choose **All RF Groups** from the Report Criteria page, or click **Edit** to select a specific radio frequency group.
  - **AP Mode**—Choose **All AP Modes** from the Report Criteria page, or click **Edit** to select a specific access point mode.

**Note**

This report only returns monitor mode access points if Report by AP Mode is selected. Reports run by any other Report by selection drop all monitor mode access points from the results.

**Note**

In the Report Criteria page, click **Select** to confirm your filter criteria or **Close** to return to the previous page.

- **SSID**—Choose the appropriate SSID from the list. You can choose **None** to show all access points with no SSIDs configured.

**Note**

The SSID filter is tied to all the criteria in the Report By category. This limits the scope for getting a report of access points by any scope listed in the Report By criteria. For this report to be able to retrieve access points by any Report By criteria, the default selection of All SSIDs should be used.

**Note**

Access points must be broadcasting SSID(s) to satisfy the “All SSID” default filter of the report.
Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Customize Report Format allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note

Fixed columns appear in blue font and cannot be moved to Available Columns.

AP Summary report results include the following:

- AP Name—The access point name.
- Ethernet MAC Address
- Base radio MAC Address
- Model
- Location
- Primary Controller
- Admin Status—Enable/Disable.
- AP group Name
- RF group Name
- Software Version
- Controller Version
- AP Mode—Local, Bridge, Rogue Detector, or H-REAP.
- Associated WLANs—Associated SSIDs.
- 802.11a/n and 802.11b/g/n Status—Up/Down.
- Serial Number
- AP Type—Indicates the type of access point (unified or autonomous).

AP Summary Report Results

The following are potential results for an AP Summary report, depending on how the report is customized (see Figure 15-23):

- AP Name (mandatory column)
- Ethernet MAC Address
- Base Radio MAC Address
- Model
- Location
- Primary Controller
- Admin Status—Enabled or disabled.
Inventory Reports

This report allows you to generate inventory-related information for controllers, access points, and MSEs managed by WCS. This information includes hardware type and distribution, software distribution, CDP information, and other statistics.

Click Inventory from the Report Launch Pad to open the Inventory Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the Inventory Reports page. See the “Configuring an Inventory Report” section on page 15-78 and the “Inventory Report Results” section on page 15-82 for more information.

Configuring an Inventory Report

This section describes how to configure an Inventory report.
Settings

- Report Title—If you plan to use this as a saved report, enter a report name.
- Report Type—Choose Combined Inventory, APs, Controllers, or MSEs from the drop-down list.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Customize Report Format allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note

Fixed columns appear in blue font and cannot be moved to Available Columns.

Note

An Inventory report includes the following sections: Count of Controllers by Model, Count of Controllers by Software Version, Controller Inventory, Disassociated AP(s), Count of APs by Model, Count of APs by Software Version.
To customize report results for a particular section, select the appropriate section from the Customizable Report drop-down list.

Available information for Count of Controllers by Model results includes the following:
- Model Name—The name of the model of the controller.
- Number of Controllers—The controller count for each model name.

Available information for Count of Controllers by Software Version results includes the following:
- Software Version—The software version of the controller.
- Number of Controllers—The controller count for each software version.

Available information for Controller Inventory results includes the following:
- Controller Name
- IP Address—The IP address of the controller.
- Location—The user-specified physical location of the controller.
- Interfaces—The names of the interfaces of the controller combined together by commas.
- Reachability Status—Reachable if the controller is currently manageable.
- Serial Number—The serial number of the controller.
- Model—The model name of the controller.
- Software Version—The software version of the controller.
- Mobility Group—The name of the mobility group to which the controller is assigned.
- RF Group—The name of the RF group to which the controller is assigned.
- Neighbor Name, Port, and Address—CDP neighbor information including the name, port, and IP address of the neighbor.
- Duplex—The CDP neighbor interface’s duplex mode.

Available information for Count of APs by Model results includes the following:
- Model Name—The name of the model of the access point.
- Number of APs—The access point count for each model name.

Available information for Count of APs by Software Version results includes the following:
- Software Version—The software version of the access point.
- Number of APs—The access point count for each software version.

Available information for AP Inventory results includes the following:
- AP Name—The access point name.
- Ethernet MAC Address—The Ethernet MAC address of the access point.
- IP Address—The IP address of the access point.
- Model—The name of the model of the access point.
- Map Location—The building, floor area, or outdoor area (as applicable) where the access point is located.
- Controller Name—The name of the controller to which the access point is associated.
- Base radio MAC Address—The MAC address of an access point.
- Software Version—The software version of an access point.
- Location—The user-specified physical location of an access point.
- Primary Controller—The name of the primary controller to which the access point should associate. When the access point is not directly connected to a controller, it tries to find the primary controller and associates with it. If this attribute is empty or an access point is unable to find the controller with this name, it associates with the secondary controller.
- Secondary Controller—The name of the secondary controller to which the access point should associate if the primary controller is unavailable. If the primary and secondary controllers are not available, the access point associates with the tertiary controller.
- Tertiary Controller—The name of the tertiary controller to which the access point should associate if the primary and secondary controller is unavailable. If the primary, secondary, and tertiary switch are unavailable, it associates with the master controller.
- Admin Status—The admin status of the access point.
- AP Mode—The monitor only mode setting of the access point. The options are local, monitor, H-REAP, rogue detector, sniffer, and bridge.
- 802.11 a/n and 802.11 b/g/n Status—The operation state of the respective radio. The options are down, up, not associated, and unknown.
- Gateway—The gateway for the access point.
- Netmask—The netmask of the access point’s IP address.
- IOS and Boot Versions—The version of the IOS Cisco access point, and the major/minor boot version of the access point.
- Certificate Type—The access point certification type options are unknown, manufacture installed, self signed, or local significance.
- Serial Number—The serial number of the access point.
• Neighbor Name, Address, Port, and Advertised Version—The access point’s CDP neighbor’s name, IP address, port, and advertised version information.

Available information for Disassociated AP(s) results includes the following:

• AP Name—The access point name.
• Ethernet MAC Address—The Ethernet MAC address of the access point.
• IP Address—The IP address of the access point.
• Model—The name of the model of the access point.
• Map Location—The building, floor area, or outdoor area (as applicable) where the access point is located.
• Controller Name—The name of the controller to which the access point is associated.
• Base radio MAC Address—The MAC address of an access point.
• Software Version—The software version of an access point.
• Location—The user-specified physical location of an access point.
• Primary Controller—The name of the primary controller to which the access point should associate. When the access point is not directly connected to a controller, it tries to find the primary controller and associates with it. If this attribute is empty or an access point is unable to find the controller with this name, it associates with the secondary controller.
• Secondary Controller—The name of the secondary controller to which the access point should associate if the primary controller is unavailable. If the primary and secondary controllers are not available, the access point associates with the tertiary controller.
• Tertiary Controller—The name of the tertiary controller to which the access point should associate if the primary and secondary controller is unavailable. If the primary, secondary, and tertiary switch are unavailable, it associates with the master controller.
• Admin Status—The admin status of the access point.
• AP Mode—The monitor only mode setting of the access point. The options are local, monitor, H-REAP, rogue detector, sniffer, and bridge.
• 802.11 a/n and 802.11 b/g/n Status—The operation state of the respective radio. The options are down, up, not associated, and unknown.
• Gateway—The gateway for the access point.
• Netmask—The netmask of the access point’s IP address.
• IOS and Boot Versions—The version of the IOS Cisco access point, and the major/minor boot version of the access point.
• Certificate Type—The access point certification type options are unknown, manufacture installed, self signed, or local significance.
• Serial Number—The serial number of the access point.
• Neighbor Name, Address, and Port—The access point’s CDP neighbor’s name, IP address, and port information.
• Duplex—CDP Neighbor interface duplex mode.
• AP Type—Indicates the type of access point (unified or autonomous).

Note: The AP Inventory report displays only associated APs in the network.
Available information for Count of MSEs by Version results includes the following:

- Version—The MSE version.
- Number of MSEs—The count of both MSE and Location Servers.

Available information for MSEs results includes the following:

- Device Name—The name of the MSE or Location Server.
- IP Address
- Device Type
- HTTP/HTTPS Port
- HTTPS
- Version
- Start Time

**Inventory Report Results**

The following are potential results for an Inventory report, depending on how the report is customized (see Figure 15-24):

- Count of Controllers by Model results
  - Model Name (mandatory column)—Name of the model of the controller.
  - Number of Controllers (mandatory column)—Controller count for each model name.

- Count of Controllers by Model results
  - Software Version (mandatory column)—Software version of the controller.
  - Number of Controllers (mandatory column)—Controller count for each software version.

- Controller Inventory results
  - Controller Name (mandatory column)
  - IP Address—IP address of the controller.
  - Location—User specified physical location of the controller.
  - Interfaces—The names of the interfaces of the controller combined together by commas.
  - Reachability Status—Reachable if the controller is currently manageable.
  - Serial Number—Serial number of the controller.
  - Model—Model name of the controller.
  - Software Version—Software version of the controller.
  - Mobility Group—The name of the mobility group to which the controller is assigned.
  - RF Group—The name of the RF group to which the controller is assigned.
  - Neighbor Name, Port, and Address—CDP Neighbor information including the name, port and IP address of the neighbor.
  - Duplex—CDP Neighbor interface duplex mode.

- Count of APs by Model results
  - Model Name (mandatory column)—Name of the model of the access point.
  - Number of APs (mandatory column)—Access point count for each model name.
• Count of APs by Software Version results
  – Software Version (mandatory column)—Software version of the access point.
  – Number of APs (mandatory column)—Access point count for each software version.

• AP Inventory results
  – AP Name (mandatory column)
  – Ethernet MAC Address—Ethernet MAC address of the access point.
  – IP Address—IP address of the access point.
  – Model—Name of the model of the access point.
  – Map Location—The building, floor area, or outdoor area (as applicable) where the access point is located.
  – Controller Name—Name of the controller to which the access point is associated.
  – Base Radio MAC Address—The MAC address of an access point base radio.
  – Software Version—The software version of an access point.
  – Location—User specified physical location of the access point.
  – Primary Controller—Name of the controller identified as the primary controller of the access point with which the access point should associate. When the access point is not directly connected to a controller, it tries to find the primary controller and associates with it. If this attribute is empty or if the access point is not able to find the controller with this name, then it associates with the secondary controller.
  – Secondary Controller—Name of the controller identified as the secondary controller of the access point with which access point should associate if the primary controller is not available.
  – Tertiary Controllers—Name of the controller identified as the tertiary controller of the access point with which access point should associate if the primary or secondary controllers are not available.
  – Admin Status—Administrative state of the access point.
  – AP Mode—Mode setting of the access point. Possible modes include: Local, Monitor, H-REAP, Rogue Detector, Sniffer, and Bridge.
  – 802.11 a/n and 802.11 b/g/n Status—Operation state of the respective radio. Possible statuses include Down, Up, Not Associated, and Unknown.
  – Gateway—The gateway for the access point.
  – Netmask—The netmask of the access point IP address.
  – IOS Version—IOS Version of the Cisco IOS access point.
  – Boot Version—Major and Minor boot version of the access point.
  – Certificate Type—Access point certification type. Possible types include: Unknown, Manufacture Installed, Self Signed, and Local Significance.
  – Serial Number—Serial number of the access point.
  – Neighbor Name, Address, Port, and Advertised Version—The access point CDP neighbor name, IP address, port, and advertised version information.
- Inventory results
  - AP Name (mandatory column)
  - Ethernet MAC Address
  - IP Address
  - Model
  - Map Location—The building, floor area, or outdoor area (as applicable) where the access point is located.
  - 802.11 a/n and 802.11 b/g/n MAC Addresses
  - Software Version
  - Location
  - Reachability Status
  - 802.11 a/n and 802.11 b/g/n Status
  - Serial Number

**Figure 15-24  Inventory Report Results**

<table>
<thead>
<tr>
<th>Model Name</th>
<th>Number of Controllers</th>
</tr>
</thead>
<tbody>
<tr>
<td>AIR-CT2504-K9</td>
<td>1</td>
</tr>
<tr>
<td>AIR-CT5508-K9</td>
<td>9</td>
</tr>
<tr>
<td>AIR-CT7751-K9</td>
<td>1</td>
</tr>
<tr>
<td>AIR-WLC2126-K9</td>
<td>2</td>
</tr>
<tr>
<td>AIR-WLC4402-25-K9</td>
<td>1</td>
</tr>
<tr>
<td>AIR-WLC4402-50-K9</td>
<td>6</td>
</tr>
<tr>
<td>AIR-WLC4444-100-K9</td>
<td>7</td>
</tr>
<tr>
<td>NMEWLC12</td>
<td>1</td>
</tr>
<tr>
<td>NMEWLC0</td>
<td>1</td>
</tr>
<tr>
<td>SVC-WISM</td>
<td>4</td>
</tr>
<tr>
<td>WLC4404-1/00</td>
<td>2</td>
</tr>
<tr>
<td>WS-SVC-WISM3-K9</td>
<td>1</td>
</tr>
</tbody>
</table>

**Count of Controllers by Model**

![](image)
Uptime

This report displays the access point uptime, the LWAPP uptime, and the LWAPP join time. Click **Uptime** from the Report Launch Pad to open the Uptime Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click **New** from the Report Launch Pad or from the Uptime Reports page. See the “Configuring an Uptime Report” section on page 15-85 and the “Configuring an Uptime Report” section on page 15-85 for more information.

Configuring an Uptime Report

This section describes how to configure an AP Image Predownload report.

**Settings**

- **Report Title**—If you plan to used this as a saved report, enter a report name.
- **Show**—Enter the number of records that you want displayed on each page.

**Note** Leave the text box blank to display all records.

**Schedule**

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

**Customize Report Form**

The Customize Report Format allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

**Note** Fixed columns appear in blue font and cannot be moved to Available Columns.

Available information for Uptime report results includes the following:

- **AP Name**—The access point name.
- **Map Location**—The building, floor area, or outdoor area (as applicable) where the access point is located.
- **AP Uptime**—The time duration since the last access point reboot.
- **LWAPP Uptime**—The time duration since the last access point joined the controller.
- **LWAPP Join Taken Time**—The time it took for the access point to join the controller. This value could be significant in Mesh environments.
Uptime Report Results

The following are potential results for an Uptime report, depending on how the report is customized (see Figure 15-25):

- AP Name
- Map Location—The building, floor area, or outdoor area (as applicable) where the access point is located.
- AP Uptime—The length of time since the access point last rebooted.
- LWAPP Uptime—The length of time since the access point last joined the controller.
- LWAPP Join Taken Time—The amount of time the access point took to join the controller.

Note

This could be a significant value in mesh environments.

Figure 15-25 Uptime Report Results

Utilization

This report displays the controller, AP, and MSE usage on your wireless network. These statistics (such as CPU usage, memory usage, link utilization, and radio utilization) can help identify current network performance and help with capacity planning for future scalability needs.

Click Utilization from the Report Launch Pad to open the Utilization Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the Utilization Reports page. See the “Configuring a Utilization Report” section on page 15-87 and the “Utilization Report Results” section on page 15-88 for more information.
Configuring a Utilization Report

This section describes how to configure a Utilization report.

Settings

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report Type**—Choose **Controllers**, **MSEs**, or **Radios** from the drop-down list.
- **Report by** (Report by options change depending on the report type selected)
  - **Controller**—If the report type is Controllers, select **All Controllers** from the Report Criteria page or click **Edit** to select specific devices. Depending on the report type selected, you receive either radio or controller utilization results. See the “Radio, Controller, and MSE Utilization Results” section on page 15-87.
  - **MSEs**—If the report type is MSEs, select **All MSEs** from the Report Criteria page or click **Edit** to select specific devices. Depending on the report type selected, you receive either radio or controller utilization results. See the “Radio, Controller, and MSE Utilization Results” section on page 15-87.
  - **Radios**—If the report type is Radio, select **AP by Controller**, **AP by Floor Area**, or **AP by Outdoor Area** from the Report by drop-down list and the appropriate selection from the Report Criteria page (or click **Edit** to select specific devices). Depending on the report type selected, you receive either radio or controller utilization results. See the “Radio, Controller, and MSE Utilization Results” section on page 15-87.

**Note**

In the Radios Report Criteria page, you can select **All Access Points** or **All OfficeExtend Access Points**.

**Note**

In the Report Criteria page, click **Select** to confirm your filter criteria or **Close** to return to the previous page.

- **Protocol**—Choose **802.11 a/n**, **802.11 b/g/n**, or both. This parameter only appears if the report type is Radios.
- **Reporting Period**
  - **Last**—Select the **Last** radio button and a period of time from the drop-down list.
  - **From**—Select the **From** radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

**Note**

The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

Radio, Controller, and MSE Utilization Results

Depending on the report type selected, you receive either radio, controller, or MSE utilization results.

- **Radio Utilization**
Device Reports

Chapter 15 Reports

Loading Report

Loading parameters differ for each report. Parameters that are common across reports include:

- **Device Name**—The name of the device to be included in the report.
- **Device ID**—The unique identifier for the device.

Other parameters may include:

- **Range**—The range of devices to be included in the report.
- **Number of Devices**—The number of devices to be included in the report.

Utilization Report Results

The following are potential results for a Utilization report (see Figure 15-26):

- **Controller Utilization**
  - CPU Utilization—The percentage of CPU utilization.
  - Memory Utilization—The percentage of memory utilization.
  - Port Utilization—The percentage of \((\text{totalDeltaBits/bandwidth})\) on a port.

- **MSE Utilization**
  - CPU Utilization—The percentage of CPU utilization.
  - Memory Utilization—The percentage of memory utilization.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.
Guest Reports

You can create the following guest reports. This section contains the following topics:

- Guest Accounts Status
- Guest Association
- Guest Count
- Guest User Sessions
- WCS Guest Operations

Guest Accounts Status

This report displays guest account status changes in chronological order. The report filters guest accounts by the guest user who created them. One example of a status change is Scheduled to Active to Expired.

Click Guest Accounts Status from the Report Launch Pad to open the Guest Accounts Status Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.
To create a new report, click **New** from the Report Launch Pad or from the Guest Accounts Status Reports page. See the “Configuring a Guest Accounts Status Report” section on page 15-90 and the “Configuring a Guest Accounts Status Report” section on page 15-90 for more information.

### Configuring a Guest Accounts Status Report

This section describes how to configure a Guest Accounts Status report.

**Settings**

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report by**
  - **WCS User**—Choose **All WCS Users** from the Report Criteria page, or click **Edit** to select a specific WCS user.

**Note**

In the Report Criteria page, click **Select** to confirm your filter criteria or **Close** to return to the previous page.

- **Reporting Period**
  - **Last**—Select the **Last** radio button and a period of time from the drop-down list.
  - **From**—Select the **From** radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

**Note**

The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

**Schedule**

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

**Customize Report Form**

The Customize Report Format allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

**Note**

Fixed columns appear in blue font and cannot be moved to Available Columns.

Available information for Guest Account Status report results includes the following:

- Time
- Guest username
- Created by
- Status
Guest Account Status Report Results

The following are potential results for a Guest Account Status report, depending on how the report is customized:

- Time
- Guest Username
- Created by
- Status

Guest Association

This report is displayed when a guest client associated to and disassociated from a guest profile/SSID over a customizable period of time.

Click Guest Association from the Report Launch Pad to open the Guest Association Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the Guest Association Reports page. See the “Configuring a Guest Accounts Status Report” section on page 15-90 and the “Configuring a Guest Accounts Status Report” section on page 15-90 for more information.

Configuring a Guest Association Report

This section describes how to configure a Guest Association report.

Settings

- Report Title—If you plan to used this as a saved report, enter a report name.
- Report by
  - Guest Profile—Choose All Profiles from the Report Criteria page, or click Edit to select a specific profile.

Note: In the Report Criteria page, click Select to confirm your filter criteria or Close to return to the previous page.

- Reporting Period
  - Last—Select the Last radio button and a period of time from the drop-down list.
  - From—Select the From radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

Note: The reporting period is based on the alarm last seen time. The times are in the UTC time zone.
Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Customize Report Format allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note

Fixed columns appear in blue font and cannot be moved to Available Columns.

Available information for Guest Association report results includes the following:

- Time
- Guest user
- Guest MAC address
- Controller IP Address
- AP MAC Address
- Login and Logout Times
- Guest IP address
- Bytes Received
- Bytes Sent

Guest Association Report Results

The following are potential results for a Guest Association report, depending on how the report is customized:

- Time
- Guest MAC address and username
- Device IP address
- Guest profile
- Status
- AP Name
- Guest IP address
- Session Duration
- Reason—Reason for the disassociation

Guest Count

This report displays the number of guest clients logged into the network per guest profile/SSID over a customizable period of time.
Click **Guest Count** from the Report Launch Pad to open the Guest Count Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click **New** from the Report Launch Pad or from the Guest Count Reports page. See the “Configuring a Guest Count Report” section on page 15-93 and the “Guest Count Report Results” section on page 15-93 for more information.

**Configuring a Guest Count Report**

This section describes how to configure a Guest Count report.

**Settings**

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report by**
  - **Guest Profile**—Choose **All Profiles** from the Report Criteria page, or click **Edit** to select a specific profile.

  **Note** In the Report Criteria page, click **Select** to confirm your filter criteria or **Close** to return to the previous page.

- **Protocol**—Select **802.11 a/n**, **802.11 b/g/n**, or both.
- **Reporting Period**
  - **Last**—Select the **Last** radio button and a period of time from the drop-down list.
  - **From**—Select the **From** radio button and enter the From and To dates and times. You can type a date in the text box, or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

  **Note** The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

**Schedule**

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

**Guest Count Report Results**

The Guest Count results contain the following information:

- **Authenticated Guest Count**—Indicates the number of authenticated guests for each specified guest profile and protocol during the specified period of time.
**Guest User Sessions**

This report displays historic session data for a guest user. The session data such as amount of data passed, login and logout time, guest IP address, and guest MAC address is available for one month by default. The data retention period can be configured from the Administration > Background Tasks page. This report can be generated for guest users who are associated to controllers running software version 5.2 or above.

Click **Guest User Sessions** from the Report Launch Pad to open the Guest User Sessions Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click **New** from the Report Launch Pad or from the Guest User Sessions Reports page. See the “Configuring a Guest User Sessions Report” section on page 15-94 and the “Guest User Sessions Report Results” section on page 15-94 for more information.

**Configuring a Guest User Sessions Report**

This section describes how to configure a Guest User Sessions report.

**Settings**

- **Report Title**—If you plan to used this as a saved report, enter a report name.
- **Report by**
  - **Guest User**—Choose **All Guest Users** from the Report Criteria page or click **Edit** to select a specific guest user.

  ![Note] In the Report Criteria page, click **Select** to confirm your filter criteria or **Close** to return to the previous page.

**Schedule**

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

**Guest User Sessions Report Results**

The following are potential results for a Guest User Sessions report, depending on how the report is customized (see Figure 15-27):

- Time (mandatory column)
- Guest User (mandatory column)
- Guest User MAC Address (mandatory column)
- Controller IP Address
- Login Time
- Logout Time
- Guest IP Address
• Bytes Received
• Bytes Sent

Figure 15-27  Guest User Sessions Report Results

### WCS Guest Operations

This report displays all activities performed by one or all guests, such as creating, deleting, or updating guest user accounts. If a guest user is deleted from WCS, the report still shows an activity performed by the deleted guest user for up to one week after the activity occurred.

Click **WCS Guest Operations** from the Report Launch Pad to open the WCS Guest Operations Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click **New** from the Report Launch Pad or from the WCS Guest Operations Reports page. See the “Configuring a WCS Guest Operations Report” section on page 15-95 and the “WCS Guest Operation Report Results” section on page 15-96 for more information.

### Configuring a WCS Guest Operations Report

This section describes how to configure a WCS Guest Operations report.

**Settings**

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report by**
  - **WCS User**—Choose **All WCS Users** from the Report Criteria page, or click **Edit** to select a specific user.

**Note**

In the Report Criteria page, click **Select** to confirm your filter criteria or **Close** to return to the previous page.

- **Reporting Period**
  - **Last**—Select the **Last** radio button and a period of time from the drop-down list.
From—Select the From radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

Note: The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Customize Report Format allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note: Fixed columns appear in blue font and cannot be moved to Available Columns.

Available information for Guest Operation report results includes the following:
- Time
- Reason
- WCS User
- Guest User
- Operation
- Status

WCS Guest Operation Report Results

The following are potential results for a WCS Guest Operations report, depending on how the report is customized:
- Time
- WCS User
- Guest User
- Operation
- Status
- Reason

Mesh Reports

You can create the following mesh reports. This section contains the following topics:
- Alternate Parent Report, page 15-97
Alternate Parent Report

This report displays the number of alternate parents with the same configured mesh group for each mesh access point. This report can be used to determine an access point capability to handle failures in the mesh path.

Click **Alternate Parent** from the Report Launch Pad to open the Alternate Parent Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click **New** from the Report Launch Pad or from the Alternate Parent Reports page. See the “Configuring an Alternate Parent Report” section on page 15-97 and the “Alternate Parent Report Results” section on page 15-98 for more information.

Configuring an Alternate Parent Report

This section describes how to configure an Alternate Parent report.

**Settings**

- **Report Title**—If you plan to use this as a saved report, enter a report name.

**Schedule**

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

**Customize Report Form**

The Customize Report Format allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

- **Note**
  
  Fixed columns appear in blue font and cannot be moved to Available Columns.

Available information for Alternate Parent report results includes the following:

- **AP Name**—The access point name.
- **MAC address**
- **Parent AP name**
Mesh Reports

- Number Alternate parents
- Parent MAC address

Alternate Parent Report Results

The following are potential results for an Alternate Parent report, depending on how the report is customized (see Figure 15-28):

- AP Name (mandatory column)
- MAC Address—The MAC address of the alternate parent.
- Parent AP Name and MAC Address
- Number of Alternate Parents

![Figure 15-28 Alternate Parent Report Results](image)

Link Stats

This report displays mesh link and node statistics such as parent access point, link SNR, packet error rate, parent changes, node hops, total transmit packets, mesh path, connected access points, mesh group, data rate, and channel. The mesh link and mesh node statistics can be run individually or combined.

Click **Link Stats** from the Report Launch Pad to open the Link Stats Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click **New** from the Report Launch Pad or from the Link Stats Reports page. See the “Configuring a Link Stats Report” section on page 15-99 and the “Link Stats Report Results” section on page 15-100 for more information.
Configuring a Link Stats Report

This section describes how to configure a Link Stats report.

Settings

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report Type**—Choose **Link Stats** or **Node Hops** from the drop-down list.
- **Report by**—Choose **AP by Controller**, **AP by Floor Area**, or **AP by Outdoor Area** from the Report by drop-down list and the appropriate selection from the Report Criteria page (or click **Edit** to select specific devices).

  Note
  
  In the Report Criteria page, click **Select** to confirm your filter criteria or **Close** to return to the previous page.

- **Reporting Period**
  - **Last**—Select the **Last** radio button and a period of time from the drop-down list.
  - **From**—Select the **From** radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

  Note
  
  The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Customize Report Format allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note

Fixed columns appear in blue font and cannot be moved to Available Columns.

Available information for Link Stats report results includes the following:

- Time
- MAC address
- Parent MAC address
- AP Name—The access point name.
- Parent AP name
- Link SNR
- Packet Error Rate
Mesh Reports

- Parent changes
- Parent changes per minute
- Node hops
- Total Tx Packets
- Total Tx Packets per minute

Link Stats Report Results

The following are potential results for a Link Stats report, depending on how the report is customized (see Figure 15-29):

- Time (mandatory column)
- MAC Address (mandatory column)
- Parent MAC Address (mandatory column)
- AP Name
- Parent AP Name
- Link SNR
- Packet Error Rate—Packet error rate percentage = 1- (number of successfully transmitted packets/number of total packets transmitted)
- Parent Changes and Parent Changes per Minute
- Node hops—The number of hops between access points
- Total Tx Packets and Total Tx Packets per Minute

Figure 15-29  Link Stats Report Results

<table>
<thead>
<tr>
<th>Time</th>
<th>MAC Address</th>
<th>Parent MAC Address</th>
<th>AP Name</th>
<th>Parent AP Name</th>
<th>Link SNR</th>
<th>Packet Error Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>2011-May-16 05:59:59 UTC 58:bc:27:04:23:00</td>
<td>58:bc:27:06:e9:00</td>
<td>franklinMAP05</td>
<td>Frankenberg01</td>
<td>26</td>
<td>0.04</td>
<td></td>
</tr>
<tr>
<td>2011-May-16 05:59:59 UTC 58:bc:27:04:23:00</td>
<td>58:bc:27:06:e9:00</td>
<td>franklinMAP05</td>
<td>Frankenberg01</td>
<td>25</td>
<td>0.04</td>
<td></td>
</tr>
<tr>
<td>2011-May-16 05:59:59 UTC 58:bc:27:04:23:00</td>
<td>58:bc:27:06:e9:00</td>
<td>franklinMAP05</td>
<td>Frankenberg01</td>
<td>26</td>
<td>0.04</td>
<td></td>
</tr>
<tr>
<td>2011-May-16 05:59:59 UTC 58:bc:27:04:23:00</td>
<td>58:bc:27:06:e9:00</td>
<td>franklinMAP05</td>
<td>Frankenberg01</td>
<td>25</td>
<td>0.04</td>
<td></td>
</tr>
<tr>
<td>2011-May-16 05:59:59 UTC 58:bc:27:04:23:00</td>
<td>58:bc:27:06:e9:00</td>
<td>franklinMAP05</td>
<td>Frankenberg01</td>
<td>26</td>
<td>0.04</td>
<td></td>
</tr>
<tr>
<td>2011-May-16 05:59:59 UTC 58:bc:27:04:23:00</td>
<td>58:bc:27:06:e9:00</td>
<td>franklinMAP05</td>
<td>Frankenberg01</td>
<td>25</td>
<td>0.04</td>
<td></td>
</tr>
</tbody>
</table>
Nodes

This report displays mesh tree information for each mesh access point such as hop count, number of directly connected children, number of connected access points, and mesh path.

Click Nodes from the Report Launch Pad to open the Mesh Nodes Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the Mesh Nodes Reports page. See the “Configuring a Nodes Report” section on page 15-101 and the “Configuring a Nodes Report” section on page 15-101 for more information.

Configuring a Nodes Report

This section describes how to configure a Nodes report.

Settings

- Report Title—If you plan to used this as a saved report, enter a report name.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Customize Report Format allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note

Fixed columns appear in blue font and cannot be moved to Available Columns.

Available information for Node report results includes the following:

- MAC Address—The MAC address of the mesh access point.
- AP Name—The name of the mesh access point.
- Node Hops—The number of node hops for this mesh group.
- Children—The number of children for this access point.
- Connected APs—The number of access points connected to this access point.
- Mesh Path—The path of the mesh access point.
- Controller—The controller to which the mesh access point is associated.
- Mesh Role—Mesh access point (MAP) or Root access point (RAP).
- Mesh Group—The name of the mesh group to which this access point belongs.
- Data Rate—The data rate for this access point.
- Channel—The channel on which this access point is located.
Nodes Report Results

The following are potential results for a Nodes report, depending on how the report is customized (see Figure 15-30):

- AP Name (mandatory column).
- AP MAC Address (mandatory column).
- Node Hops—The number of hops between access points.
- Children—The number of children for this access point.
- Connected APs—The number of access points connected to this access point.
- Mesh Path—The path of the mesh access point.
- Controller—The controller to which the mesh access point is associated.
- Mesh Role—Mesh access point (MAP) or Root access point (RAP).
- Mesh Group—The name of the mesh group to which this access point belongs.
- Data Rate—The data rate for this access point.
- Channel—The channel on which this access point is located.

Figure 15-30   Node Report Results

Packet Stats

This report displays the total number of packets transmitted, packets transmitted per minute, packet queue average, packet dropped count, packets dropped per minute, and errors for packets transmitted by neighbor access points. A report type can be selected for each data type.

Click Packet Stats from the Report Launch Pad to open the Packet Stats Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.
To create a new report, click **New** from the Report Launch Pad or from the Packet Stats Reports page. See the “Configuring a Packet Stats Report” section on page 15-103 and the “Packet Stats Report Results” section on page 15-103 for more information.

**Configuring a Packet Stats Report**

This section describes how to configure a Packet Stats report.

**Settings**

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report Type**—Choose **Packet Stats** from the drop-down list.
- **Report by**—Choose **AP by Controller**, **AP by Floor Area**, or **AP by Outdoor Area** from the Report by drop-down list and the appropriate selection from the Report Criteria page (or click **Edit** to select specific devices).

  ![Note](Image)

  In the Report Criteria page, click **Select** to confirm your filter criteria or **Close** to return to the previous page.

- **Graph Type**—Select the type of graph you want displayed for these report results (Packet Counts or Packets Per Minute).
- **Reporting Period**
  - **Last**—Select the **Last** radio button and a period of time from the drop-down list.
  - **From**—Select the **From** radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

  ![Note](Image)

  The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

**Schedule**

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

**Packet Stats Report Results**

The Packet Stats report generates a graph of packet queue statistics for each access point selected and for each report type selected. The graph types are Packet Queue Average, Packets Dropped Per Minute, and Packet Dropped Count.

The following are potential results for a Packet Stats report, depending on how the report is customized (see Figure 15-31):

- **Packet Stats**
  - **Packet Count**—Total packets transmitted and total packets received.
Mesh Reports

Chapter 15      Reports

- Packets per Minute—Total packets transmitted per minute and total packets received per minute.

- Packet Error Stats
  - Packet error rate percentages for all neighbor access points or for parent/children neighbor access points only.

- Packet Queue Stats
  - Packet Queue Average—Shows the average number of packets for each queue when the MIB was polled. Silver, gold, platinum, bronze, and management.
  - Packets Dropped Count—Contains the counter for the number of packets dropped.
  - Packets Dropped per Minute—Shows the number of packets dropped since the last sample divided by the number of minutes since the sample.

Figure 15-31   Packet Stats Report Results

Packet Stats
Generated: 2011-May-18, 17:03:44 UTC
Report By: AP By Controller
Graph Type: Packet Count
Reporting Period: Last 7 days

Packet Error Statistics

This report notes the percentages of packet errors for packets transmitted by the neighbor mesh access point. The packet error rate percentage is 1 minus the number of successfully transmitted packets/numbers of total packets transmitted.

Configuring a Packet Error Statistics Report

This section describes how to configure a Packet Error Statistics report.
Settings

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report Type**—Choose **Packet Error Stats** from the drop-down list.
- **Report by**—Choose **AP by Controller**, **AP by Floor Area**, or **AP by Outdoor Area** from the Report by drop-down list and the appropriate selection from the Report Criteria page (or click **Edit** to select specific devices).

  **Note** In the Report Criteria page, click **Select** to confirm your filter criteria or **Close** to return to the previous page.

- **Neighbor Type**—Choose All Neighbors or Parent/Children Only.

- **Reporting Period**
  - **Last**—Select the **Last** radio button and a period of time from the drop-down list.
  - **From**—Select the **From** radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

  **Note** The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Packet Error Statistics Report Results

The Packet Error Statistics report contains the following results (Figure 15-32):
Packet Queue Statistics

This report generates a graph of the total number of packets transmitted and the total number of packets successfully transmitted by the neighbor mesh access point.

Configuring a Packet Queue Statistics Report

This section describes how to configure a Packet Queue Statistics report.
Settings

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report Type**—Choose *Packet Queue Stats* from the drop-down list.
- **Report by**—Choose *AP by Controller, AP by Floor Area, or AP by Outdoor Area* from the Report by drop-down list and the appropriate selection from the Report Criteria page (or click *Edit* to select specific devices).

  ![Note](image)

  In the Report Criteria page, click *Select* to confirm your filter criteria or *Close* to return to the previous page.

- **Graph Type**—Choose the type of graph you want displayed for these report results (*Packet Queue Average, Packets Dropped Count, Packets Dropped Per Minute*).
- **Reporting Period**
  - **Last**—Select the *Last* radio button and a period of time from the drop-down list.
  - **From**—Select the *From* radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

  ![Note](image)

  The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

**Packet Queue Statistics Report Results**

The Packet Queue Statistics report contains the following results (Figure 15-33):
Stranded APs

This report displays access points that appear to be stranded. These access points might have joined a controller at one time and are no longer joined to a controller managed by WCS, or they might have never joined a controller managed by WCS.

Click **Stranded APs** from the Report Launch Pad to open the Stranded APs Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click **New** from the Report Launch Pad or from the Stranded APs Reports page. See the “Configuring a Stranded APs Report” section on page 15-108 and the “Stranded APs Report Results” section on page 15-109 for more information.

Configuring a Stranded APs Report

This section describes how to configure a Stranded APs report.
Chapter 15 Reports

Mesh Reports

Settings

- Report Title—If you plan to use this as a saved report, enter a report name.
- Stranded States—Choose APs Managed by WCS or All.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Customize Report Form allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note

Fixed columns appear in blue font and cannot be moved to Available Columns.

Available information for Link Stats report results includes the following:

- MAC Address—The MAC address of the stranded access point.
- State—The state of the stranded access point (such as Not Detected and Not Previously Associated).
- First Seen—The date and time this access point was first detected.
- Last Seen—The date and time this access point was last seen.
- Detecting APs (Link SNR)—The access point(s) that detected this stranded access point.

Stranded APs Report Results

The following are potential results for a Stranded APs report, depending on how the report is customized (see Figure 15-34):

- MAC Address (mandatory column)—The MAC address of the stranded access point.
- State (mandatory column)—The state of the stranded access point (such as Not Detected and Not Previously Associated).
- First Seen—The date and time this access point was first detected.
- Last Seen—The date and time this access point was last seen.
- Detecting APs (Link SNR)—The access point(s) that detected this stranded access point.
Mesh Reports

Figure 15-34 Stranded APs Report Results

Worst Node Hops

This report displays the worst node hops or backhaul SNR links for the specified reporting period. The information is displayed in both table and graph form. Report types include worst node hops, worst SNR links for all neighbors, and worst SNR links for parent/children only.

Click Worst Node Hops from the Report Launch Pad to open the Worst Node Hops Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the Worst Node Hops Reports page. See the “Configuring a Worst Node Hops Report” section on page 15-110 and the “Worst Node Hops Report Results” section on page 15-112 for more information.

Configuring a Worst Node Hops Report

This section describes how to configure a Worst Node Hops report.

Settings

- Report Title—If you plan to used this as a saved report, enter a report name.
- Report Type—Choose Worst Node Hops or Worst SNR Links from the drop-down list.
- Report Type—When Worst Node Hops is selected from the Report Type above, select Table Only or Table and Graph to determine how the report results display.
- Neighbor Type—When Worst SNR Links is selected from the Report Type, select All Neighbors (Table Only), Parent/Children Only (Table Only), All Neighbors (Table and Graph), or Parent/Children Only (Table and Graph) to determine how the report results display.
- Reporting Period.
Mesh Reports

Chapter 15      Reports

– Last—Select the Last radio button and a period of time from the drop-down list.
– From—Select the From radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

Note The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

• Show—Enter the number of records that you want displayed on each page.

Note Leave the text box blank to display all records.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Customize Report Form allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note Fixed columns appear in blue font and cannot be moved to Available Columns.

Note Worst Node Hops and Worst SNR Links reports are available in both table and graph reports.
To customize report results for a particular section, select the applicable section from the Customizable Report drop-down list.

Available information for Worst Node Hops report results includes the following:
• AP Name—The access point name.
• Node Hops—The number of node hops.
• MAC Address—The MAC address of the access point.
• Parent AP Name—The name of the parent access point.
• Parent MAC Address—The MAC address of the parent access point.
• Time (graph only)—The time of the node hop count.

Available information for Worst SNR Links report results includes the following:
• AP Name—The access point name.
• MAC Address—The MAC address of the access point.
• Neigh SNR—The neighbor signal-to-noise ratio.
• Neigh AP Name—The name of the neighbor access point.
• Neigh MAC Address—The MAC address of the neighbor access point.
- Neigh Type—The neighbor type.
- Time (graph only)—The time of the current report statistics.

**Worst Node Hops Report Results**

The following are potential results for a Worst Node Hops report, depending on how the report is customized (see Figure 15-35):

- Worst Node Hops report results (table)
  - AP Name (mandatory column).
  - Node Hops (mandatory column)—The number of hops between access points.
  - MAC Address (mandatory column)—The MAC address of the access point.
  - Parent AP Name and MAC Address

- Worst Node Hops report results (graph)
  - Time (mandatory column)—The time of the node hop count.
  - MAC Address (mandatory column)—The MAC address of the access point.
  - Node Hops (mandatory column)—The number of hops between access points.
  - AP Name (mandatory column).
  - Parent AP Name and MAC Address.

- Worst SNR Links report results
  - AP Name (mandatory column).
  - MAC Address (mandatory column in graph report)—The MAC address of the access point.
  - Neighbor SNR (mandatory column).
  - Neighbor AP Name (mandatory column in graph report).
  - Neighbor MAC Address and Type.
  - Time (graph only)(mandatory column)—The time of the current report statistics.
Network Summary

Click New for a Network Summary Report type to create a new report. See the “Creating and Running a New Report” section on page 15-3 for more information.

Click a report type to view currently saved reports. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

The section contains the following Network Summary Reports:

- 802.11n Summary, page 15-113
- Executive Summary, page 15-115
- Preferred Calls, page 15-117

802.11n Summary

This report displays a summary of 802.11n clients and client bandwidth usage for a customizable period of time.

Click 802.11n Summary from the Report Launch Pad to open the 802.11n Summary Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the 802.11n Summary Reports page. See the “Configuring an 802.11n Summary Report” section on page 15-113 and the “802.11n Summary Report Results” section on page 15-114 for more information.

Configuring an 802.11n Summary Report

This section describes how to configure an 802.11n Summary report.
Settings

- Report Title—If you plan to used this as a saved report, enter a report name.
- Reporting Period
  - Last—Select the Last radio button and a period of time from the drop-down list.
  - From—Select the From radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

Note: The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

802.11n Summary Report Results

The following information is displayed for the 802.11n Summary report (see Figure 15-36):

- Number of access points per 802.11n band (pie graph)
- Utilization for 802.11n clients during the specified period of time (line graph)
- Number of associated clients for each protocols during the specified period of time (line graph)
Executive Summary

This report displays a quick view of your wireless network.

Click Executive Summary from the Report Launch Pad to open the Executive Summary Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the Executive Summary Reports page. See the “Configuring an Executive Summary Report” section on page 15-115 and the “Executive Summary Report Results” section on page 15-116 for more information.

Configuring an Executive Summary Report

This section describes how to configure an Executive Summary report.
Network Summary

Chapter 15 Reports

Settings

- Report Title—If you plan to used this as a saved report, enter a report name.
- Reporting Period
  - Last—Select the Last radio button and a period of time from the drop-down list.
  - From—Select the From radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

  Note: The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Executive Summary Report Results

The following information is displayed in the Executive Summary report (see Figure 15-37):

- Number of network devices including access points, controllers, and MSEs.
- Number of LWAPP versus autonomous access points (pie graph).
- Number of associated client in the network during the specified period of time (line graph).
- Number of guest client in the network during the specified period of time (line graph).
- Throughput (Kbps) of clients by protocol during the specified period of time.
- Number of associated clients for each protocol during the specified period of time.
- Network utilization (%) during the specified period of time.
Figure 15-37  Executive Summary Report Results

Executive Summary

Count of Devices in the Network

<table>
<thead>
<tr>
<th>Number of APs</th>
<th>Number of Controllers</th>
<th>Number of MSs</th>
</tr>
</thead>
<tbody>
<tr>
<td>1,283</td>
<td>27</td>
<td>2</td>
</tr>
</tbody>
</table>

LWAPP Vs Autonomous

Associated Client Count in the Network

Preferred Calls

This report displays the access points with preferred calls made on the wireless network.

Click Executive Summary from the Report Launch Pad to open the Executive Summary Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.
To create a new report, click **New** from the Report Launch Pad or from the Executive Summary Reports page. See the “Configuring a Preferred Calls Report” section on page 15-118 and the “Performance Reports” section on page 15-118 for more information.

### Configuring a Preferred Calls Report

This section describes how to configure a Preferred Calls report.

#### Settings

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report by**
  - **AP by Controller**—Choose **All Controllers > All Access Points** from the Report Criteria page, or click **Edit** to select a specific device.
  - **AP by Floor Area**—Choose **All Campuses > All Buildings > All Floors > All Access Points** from the Report Criteria page, or click **Edit** to select a specific device.
  - **AP by Outdoor Area**—Choose **All Campuses > All Outdoor Areas > All Access Points** from the Report Criteria page, or click **Edit** to select a specific device.

*Note* In the Report Criteria page, click **Select** to confirm your filter criteria or **Close** to return to the previous page.

- **Protocol**—Choose **802.11 a/n, 802.11 b/g/n**, or both.
- **Reporting Period**
  - Select the radio button and a period of time from the drop-down list.
  - Or
  - Select the **From** radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

*Note* The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

#### Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

### Performance Reports

Click **New** for a Performance Report type to create a new report. See the “Creating and Running a New Report” section on page 15-3 for more information.
15-119
Cisco Wireless Control System Configuration Guide
OL-21743-02
Chapter 15      Reports

Performance Reports

Click a report type to view currently saved reports. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

This section contains the following topics:
- 802.11 Counters, page 15-119
- Coverage Hole, page 15-122
- Network Utilization, page 15-124
- Traffic Stream Metrics, page 15-126
- Tx Power and Channel, page 15-129
- VoIP Calls Graph, page 15-131
- VoIP Calls Table, page 15-133
- Voice Statistics, page 15-135

802.11 Counters

This report displays counters for access points at the MAC layer. Statistics such as error frames, fragment counts, RTS/CTS frame count, and retried frames are generated based on the filtering criteria and can help interpret performance (and problems, if any) at the MAC layer.

Click 802.11 Counters from the Report Launch Pad to open the 802.11 Counters Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the 802.11 Counters Reports page. See the “Configuring an 802.11 Counters Report” section on page 15-119 and the “802.11 Counters Report Results” section on page 15-121 for more information.

Configuring an 802.11 Counters Report

This section describes how to configure an 802.11 Counters report.

Settings

- Report Title—If you plan to used this as a saved report, enter a report name.
- Report by
  - AP by Controller—Choose All Controllers > All Access Points from the Report Criteria page, or click Edit to select a specific device.
  - AP by Floor Area—Choose All Campuses > All Buildings > All Floors > All Access Points from the Report Criteria page, or click Edit to select a specific device.
  - AP by Outdoor Area—Choose All Campuses > All Outdoor Areas > All Access Points from the Report Criteria page, or click Edit to select a specific device.

Note: In the Report Criteria page, click Select to confirm your filter criteria or Close to return to the previous page.

- Protocol—Choose 802.11 a/n, 802.11 b/g/n, or both.
• Reporting Period
  – Last—Select the Last radio button and a period of time from the drop-down list.
  – From—Select the From radio button and enter the From and To dates and times. You can type a date in the text box, or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

Note: The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Customize Report Form allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note: Fixed columns appear in blue font and cannot be moved to Available Columns.

Available information for 802.11 Counters report results includes the following:

• Time—The date and time of the count.
• AP Name—The name of the applicable access point.
• Slot—The slot number.
• Radio Type—802.11a/n or 802.11b/g/n.
• Tx Fragment Count—The number of successfully received MPDUs of type Data or Management.
• Rx Fragment Count—The total number of packets received that were less than 64 octets in length (excluding framing bits but including FCS octets).
• FCS Error Count—The number of FCS errors detected in a received MPDU.
• Retry Count—The number of MSDUs successfully transmitted after one or more retransmissions.
• Multicast Rx Frame Count—The number of MSDUs received with the multicast bit set in the destination MAC address.
• Multicast Tx Frame Count—The number of times a multicast bit is set in the destination MAC address of a successfully transmitted MSDU. Operating as an STA in an ESS, where these frames are directed to the access point, implies having received an acknowledgment to all associated MPDUs.
• Tx Failed Count—The number of MSDUs successfully transmitted after one or more retransmissions.
• Multiple Retry Count—The number of MSDUs successfully transmitted after more than one retransmission.
• Frame Duplicate Count—The number of times a frame is received that the Sequence Control field indicates is a duplicate.
• Tx Frame Count—The number of successfully transmitted MSDUs.
• RTS Success Count—The number of times a CTS is received in response to an RTS.
• RTS Failure Count—The number of times a CTS is not received in response to an RTS.
• ACK Failure Count—The number of times an ACK is not received when expected.
• WEP Undecryptable Count—The number of times a frame is received with the WEP subfield of the Frame Control field set to one and the WEPOn value for the key mapped to the AT’s MAC address indicates that the frame should not have been encrypted or that frame is discarded due to the receiving STA not implementing the privacy option.

802.11 Counters Report Results

The following are potential results for an 802.11 Counters report, depending on how the report is customized (see Figure 15-38):

• Time (mandatory column)
• AP Name (mandatory column)
• Slot (mandatory column)
• AP MAC Address (mandatory column)
• Radio Type—802.11a/n or 802.11b/g/n.
• Tx Fragment Count—The number of successfully received MPDUs of type Data or Management.
• Rx Fragment Count—The total number of packets received that were less than 64 octets in length (excluding framing bits but including FCS octets).
• FCS Error Count—The number of FCS errors detected in a received MPDU.
• Retry Count—The number of MSDUs successfully transmitted after one or more retransmissions.
• Multicast Rx Frame Count—The number of MSDUs received with the multicast bit set in the destination MAC address.
• Multicast Tx Frame Count—The number of time a multicast bit is set in the destination MAC address of a successfully transmitted MSDU. When operating as a STA in an ESS, where these frames are directed to the access point, this implies having received an acknowledgment to all associated MPDUs.
• Tx Failed Count—The number of unsuccessful MSDUs transmissions.
• Multiple Retry Count—The number of MSDUs successfully transmitted after more than one retransmission.
• Frame Duplicate Count—The number of times a frame is received that the Sequence Control field indicates is a duplicate.
• Tx Frame Count—The number of successfully transmitted MSDUs.
• RTS Success Count—The number of times a CTS is received in response to an RTS.
• RTS Failure Count—The number of times a CTS is not received in response to an RTS.
• ACK Failure Count—The number of times an ACK is not received when expected.
• WEP Undecryptable Count—The number of times a frame is received with the WEP subfield of the Frame Control field set to one and the WEPOn value for the key mapped to the AT MAC address indicates that the frame should not have been encrypted or that frame is discarded due to the receiving STA not implementing the privacy option.
**Coverage Hole**

This report identifies the location of potential coverage holes in your network and whether they occur more frequently at a given spot. This report can help you modify RRM settings or determine if additional access points are needed to provide coverage in sparsely deployed areas. It runs on the alarm table and shows both the alarm generation time, the cleared time (if cleared), and the state of the alarm (active or cleared).

Click **Coverage Hole** from the Report Launch Pad to open the Coverage Hole Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click **New** from the Report Launch Pad or from the Coverage Hole Reports page. See the “Configuring a Coverage Hole Report” section on page 15-122 and the “Coverage Hole Report Results” section on page 15-123 for more information.

**Configuring a Coverage Hole Report**

This section describes how to configure a Coverage Hole report.

**Settings**

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report by**
  - **AP by Controller**—Choose **All Controllers > All Access Points** from the Report Criteria page or click **Edit** to select a specific device.
  - **AP by Floor Area**—Choose **All Campuses > All Buildings > All Floors > All Access Points** from the Report Criteria page, or click **Edit** to select a specific device.
  - **AP by Outdoor Area**—Choose **All Campuses > All Outdoor Areas > All Access Points** from the Report Criteria page, or click **Edit** to select a specific device.
Chapter 15  Reports

Performance Reports

Note

In the Report Criteria page, click Select to confirm your filter criteria or Close to return to the previous page.

- Reporting Period
  - Last—Select the Last radio button and a period of time from the drop-down list.
  - From—Select the From radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

Note

The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Customize Report Form allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note

Fixed columns appear in blue font and cannot be moved to Available Columns.

Available information for Coverage Hole report results includes the following:
- Time—The date and time the coverage hole was detected.
- State—Clear or Active.
- AP Base Radio MAC Address—The MAC address of the access point base radio.
- AP Name—The name of the access point on which the coverage hole was detected.
- Radio Type—802.11a/n or 802.11b/g/n.
- Failed Clients.
- Total Clients.
- Threshold RSSI.
- Worst Client MAC.
- Worst Client RSSI.

Coverage Hole Report Results

The following are potential results for a Coverage Hole report, depending on how the report is customized (see Figure 15-39):
- Time (mandatory column)—Indicates the date and time that the alarm was generated or cleared (depending on the current state).
Performance Reports

Chapter 15      Reports

Network Utilization

This report shows the overall network utilization based on the aggregated port utilization of all controllers on your network. These statistics can help identify current network performance and help with capacity planning for future scalability needs.

*Note*

Average utilization (%) is the percentage of utilization where utilization is calculated as \((Tx+Rx)/\text{Bandwidth})\).

Click **Network Utilization** from the Report Launch Pad to open the Network Utilization Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.
To create a new report, click **New** from the Report Launch Pad or from the Network Utilization Reports page. See the “Configuring a Network Utilization Report” section on page 15-125 and the “Network Utilization Report Results” section on page 15-125 for more information.

**Configuring a Network Utilization Report**

This section describes how to configure a Network Utilization report.

**Settings**

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Reporting Period**
  - **Last**—Select the **Last** radio button and a period of time from the drop-down list.
  - **From**—Select the **From** radio button and enter the From and To dates and times. You can type a date in the text box, or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

**Note** The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

**Schedule**

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

**Customize Report Form**

The Customize Report Form allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

**Note** Fixed columns appear in blue font and cannot be moved to Available data fields column.

Available information for the Network Utilization report results includes the following:

- **Time**
- **Average Utilization (%)**—The average aggregated (totalDeltaBits/bandwidth) on all controllers.
- **Average Tx (Mbps)**—The average aggregated received Mbs of all ports on all controllers.
- **Average Rx (Mbps)**—The average aggregated (totalDeltaBits/bandwidth) on all controllers.

**Network Utilization Report Results**

Network utilization is based on the average utilization of all the controllers in the network.

The following information is displayed for a Network Utilization report (see **Figure 15-40**):

- **Time** (mandatory column)
- **Average Utilization (%)** (mandatory column)—Average aggregated (totalDeltaBits/bandwidth) on all controllers.
Note

Average utilization (%) is the percentage of utilization where utilization is calculated as
\((\text{Tx} + \text{Rx}) / \text{Bandwidth})\).

- Average Transmitting (in Mbps)—Average aggregated transmitted Megabytes of all ports on all
  controllers.
- Average Receiving (in Mbps)—Average aggregated received Megabytes of all ports on all
  controllers.

**Figure 15-40 Network Utilization Report Results**

Network Utilization

Generated: 2011-May-18, 18:08:30 UTC

Reporting Period: Last 2 days

**Network Utilization**

Network utilization is based on the average utilization of all the controllers in the network.

<table>
<thead>
<tr>
<th>Time</th>
<th>Average Utilization (%)</th>
<th>Average Tx (Mbps)</th>
<th>Average Rx (Mbps)</th>
</tr>
</thead>
<tbody>
<tr>
<td>2011-May-16, 18:59:59 UTC</td>
<td>0.09</td>
<td>0.46</td>
<td>0.46</td>
</tr>
<tr>
<td>2011-May-16, 19:59:59 UTC</td>
<td>0.10</td>
<td>0.45</td>
<td>0.48</td>
</tr>
<tr>
<td>2011-May-16, 20:59:59 UTC</td>
<td>0.10</td>
<td>0.49</td>
<td>0.59</td>
</tr>
<tr>
<td>2011-May-16, 21:59:59 UTC</td>
<td>0.11</td>
<td>0.50</td>
<td>0.51</td>
</tr>
<tr>
<td>2011-May-16, 22:59:59 UTC</td>
<td>0.09</td>
<td>0.44</td>
<td>0.47</td>
</tr>
<tr>
<td>2011-May-16, 23:59:59 UTC</td>
<td>0.12</td>
<td>0.58</td>
<td>0.66</td>
</tr>
<tr>
<td>2011-May-17, 00:59:59 UTC</td>
<td>0.08</td>
<td>0.44</td>
<td>0.48</td>
</tr>
<tr>
<td>2011-May-17, 01:59:59 UTC</td>
<td>0.08</td>
<td>0.44</td>
<td>0.42</td>
</tr>
<tr>
<td>2011-May-17, 02:59:59 UTC</td>
<td>0.00</td>
<td>0.44</td>
<td>0.43</td>
</tr>
</tbody>
</table>

**Traffic Stream Metrics**

This report can be useful in determining the current and historical quality of service (QoS) for given clients at the radio level. It also displays uplink and downlink statistics such as packet loss rate, average queuing delay, distribution of delayed packets, and roaming delays.

Click **Traffic Stream Metrics** from the Report Launch Pad to open the Traffic Stream Metrics Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.


**Configuring a Traffic Stream Metrics Report**

This section describes how to configure a Traffic Stream Metrics report.

**Settings**

- Report Title—If you plan to used this as a saved report, enter a report name.
Chapter 15  Reports

Performance Reports

- Report by
  - AP by Controller—Choose All Controllers > All Access Points from the Report Criteria page or click Edit to select a specific device.
  - AP by Floor Area—Choose All Campuses > All Buildings > All Floors > All Access Points from the Report Criteria page or click Edit to select a specific device.
  - AP by Outdoor Area—Choose All Campuses > All Outdoor Areas > All Access Points from the Report Criteria page or click Edit to select a specific device.

  Note
  In the Report Criteria page, click Select to confirm your filter criteria or Close to return to the previous page.

- Protocol—Choose 802.11 a/n, 802.11 b/g/n, or both.

- Reporting Period
  - Last—Select the Last radio button and a period of time from the drop-down list.
  - From—Select the From radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

  Note
  The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

The Customize Report Form allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note
Fixed columns appear in blue font and cannot be moved to Available Columns.

Available information for Traffic Stream Metrics report results includes the following:
- Time—Date and time the statistics were recorded.
- MAC address—The MAC address of the access point.
- AP Name—The access point name.
- Radio Type—802.11a/n or 802.11b/g/n.
- Average Queuing Delay (Downlink)—The average queuing delay for downlinks.
- Average Queuing Delay (Uplink)—The average queuing delay for uplinks.
- % Packet with less than 10 ms delay (downlink)—The percentage of packets that have a queuing delay of less than 10 milliseconds for a downlink.
Performance Reports

Chapter 15

Reports

- % Packet with less than 10 ms delay (uplink)—The percentage of packets that have a queuing delay of less than 10 milliseconds for an uplink.
- % Packet with more than 10 < 20 ms delay (downlink)—The percentage of packets that have a queuing delay of more than 10 but less than 20 milliseconds for a downlink.
- % Packet with more than 10 < 20 ms delay (uplink)—The percentage of packets that have a queuing delay of more than 10 but less than 20 milliseconds for an uplink.
- % Packet with more than 20 < 40 ms delay (downlink)—The percentage of packets that have a queuing delay of more than 20 but less than 40 milliseconds for a downlink.
- % Packet with more than 20 < 40 ms delay (uplink)—The percentage of packets that have a queuing delay of more than 20 but less than 40 milliseconds for an uplink.
- % Packet with more than 40 ms delay (downlink)—The percentage of packets that have a queuing delay of more than 40 milliseconds for a downlink.
- % Packet with more than 40 ms delay (uplink)—The percentage of packets that have a queuing delay of more than 40 milliseconds for an uplink.
- Packet Loss Ratio (Downlink)—The ratio of lost packets for downlinks.
- Packet Loss Ratio (Uplink)—The ratio of lost packets for uplinks.
- Total Packet Count (Downlink)—The total number of downlink packets.
- Total Packet Count (Uplink)—The total number of uplink packets.
- Roaming Count—Number of packets exchanged for roaming negotiations in this 90-second metrics page.
- Roaming Delay—Roaming delay in milliseconds.

Traffic Stream Metrics Report Results

The following are potential results for a Traffic Stream Metrics report, depending on how the report is customized (see Figure 15-41):

- Time (mandatory column).
- MAC Address (mandatory column).
- AP Name (mandatory column).
- Radio Type (mandatory column).
- Average Queuing Delay (Downlink) (mandatory column).
- Average Queuing Delay (Uplink) (mandatory column).
- % Packet with less than 10 ms delay (downlink)—The percentage of packets that have a queuing delay of less than 10 milliseconds for a downlink.
- % Packet with less than 10 ms delay (uplink)—The percentage of packets that have a queuing delay of less than 10 milliseconds for an uplink.
- % Packet with more than 10 < 20 ms delay (downlink)—The percentage of packets that have a queuing delay of more than 10 but less than 20 milliseconds for a downlink.
- % Packet with more than 10 < 20 ms delay (uplink)—The percentage of packets that have a queuing delay of more than 10 but less than 20 milliseconds for an uplink.
- % Packet with more than 20 < 40 ms delay (downlink)—The percentage of packets that have a queuing delay of more than 20 but less than 40 milliseconds for a downlink.
- % Packet with more than 20 < 40 ms delay (uplink)—The percentage of packets that have a queuing delay of more than 20 but less than 40 milliseconds for an uplink.
• % Packet with more than 20 < 40 ms delay (uplink)—The percentage of packets that have a queuing delay of more than 20 but less than 40 milliseconds for an uplink.
• % Packet with more than 40 ms delay (downlink)—The percentage of packets that have a queuing delay of more than 40 milliseconds for a downlink.
• % Packet with more than 40 ms delay (uplink)—The percentage of packets that have a queuing delay of more than 40 milliseconds for an uplink.
• Packet Loss Ratio (Downlink)—The ratio of lost packets for downlinks.
• Packet Loss Ratio (Uplink)—The ratio of lost packets for uplinks.
• Total Packet Count (Downlink)—The total number of downlink packets.
• Total Packet Count (Uplink)—The total number of uplink packets.
• Roaming Count—Number of packets exchanged for roaming negotiations in this 90 seconds metrics page.
• Roaming Delay—Roaming delay in milliseconds.

Figure 15-41 Traffic Stream Metrics Report Results

Tx Power and Channel

This report displays the channel plan assignment and transmit power level trends of devices based on the filtering criteria used when the report was generated. It helps to identify unexpected behavior or issues with network performance.

Click **Tx Power and Channel** from the Report Launch Pad to open the Tx Power and Channel Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click **New** from the Report Launch Pad or from the Tx Power and Channel Reports page. See the “Configuring a Tx Power and Channel Report” section on page 15-129 and the “Tx Power and Channel Report Results” section on page 15-130 for more information.

Configuring a Tx Power and Channel Report

This section describes how to configure a Tx Power and Channel report.
Settings

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report by**
  - **AP by Controller**—Choose **All Controllers > All Access Points** from the Report Criteria page, or click **Edit** to select a specific device.
  - **AP by Floor Area**—Choose **All Campuses > All Buildings > All Floors > All Access Points** from the Report Criteria page, or click **Edit** to select a specific device.
  - **AP by Outdoor Area**—Choose **All Campuses > All Outdoor Areas > All Access Points** from the Report Criteria page, or click **Edit** to select a specific device.

  **Note**
  In the Report Criteria page, click **Select** to confirm your filter criteria or **Close** to return to the previous page.

- **Protocol**—Choose **802.11 a/n, 802.11 b/g/n**, or both.
- **Reporting Period**
  - **Last**—Select the **Last** radio button and a period of time from the drop-down list.
  - **From**—Select the **From** radio button and enter the From and To dates and times. You can type a date in the text box, or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

  **Note**
  The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Tx Power and Channel Report Results

The following information is displayed for a Tx Power and Channel report (see **Figure 15-42**):

- Transmit power level for each access point during the specified period of time.
- Channel number for each access point during the specified period of time.
VoIP Calls Graph

This report helps analyze wireless network usage from a voice perspective by providing details such as the number and duration of VoIP calls (per radio) on the network over time. To be able to gather useful data from this report, VoIP snooping must be enabled on the WLAN. This report displays information in a graph.

Click **VoIP Calls Graph** from the Report Launch Pad to open the VoIP Calls Graph Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click **New** from the Report Launch Pad or from the VoIP Calls Graph Reports page. See the “Configuring a VoIP Calls Graph Report” section on page 15-131 and the “VoIP Calls Report Results” section on page 15-132 for more information.

Configuring a VoIP Calls Graph Report

This section describes how to configure a VoIP Calls Graph report.

**Settings**

- Report Title—If you plan to used this as a saved report, enter a report name.
- Report by
- AP by Controller—Choose **All Controllers > All Access Points** from the Report Criteria page, or click **Edit** to select a specific device.

- AP by Floor Area—Choose **All Campuses > All Buildings > All Floors > All Access Points** from the Report Criteria page, or click **Edit** to select a specific device.

- AP by Outdoor Area—Choose **All Campuses > All Outdoor Areas > All Access Points** from the Report Criteria page, or click **Edit** to select a specific device.

**Note**

In the Report Criteria page, click **Select** to confirm your filter criteria or **Close** to return to the previous page.

- Protocol—Choose **802.11 a/n, 802.11 b/g/n**, or both.

- Reporting Period
  - Last—Select the **Last** radio button and a period of time from the drop-down list.
  - From—Select the **From** radio button and enter the From and To dates and times. You can type a date in the text box, or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

**Note**

The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

**Schedule**

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

**VoIP Calls Report Results**

The following information is displayed for a VoIP Calls Graph report (see Figure 15-43):

- Number of attempted VoIP calls per radio during the specified period of time.
- Duration (in seconds) of VoIP calls.
VoIP Calls Table

This report helps analyze wireless network usage from a voice perspective by providing details such as the number and duration of VoIP calls (per radio) on the network over time. To be able to gather useful data from this report, VoIP snooping must be enabled on the WLAN. This report displays information in a table.

Click **VoIP Calls Table** from the Report Launch Pad to open the VoIP Calls Table Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click **New** from the Report Launch Pad or from the VoIP Calls Table Reports page. See the “Configuring a VoIP Calls Table Report” section on page 15-133 and the “VoIP Calls Table Results” section on page 15-134 for more information.

Configuring a VoIP Calls Table Report

This section describes how to configure a VoIP Calls Table report.

**Settings**

- Report Title—If you plan to use this as a saved report, enter a report name.
- Report by
- AP by Controller—Choose All Controllers > All Access Points from the Report Criteria page, or click Edit to select a specific device.

- AP by Floor Area—Choose All Campuses > All Buildings > All Floors > All Access Points from the Report Criteria page, or click Edit to select a specific device.

- AP by Outdoor Area—Choose All Campuses > All Outdoor Areas > All Access Points from the Report Criteria page, or click Edit to select a specific device.

Note In the Report Criteria page, click Select to confirm your filter criteria or Close to return to the previous page.

- Protocol—Choose 802.11 a/n, 802.11 b/g/n, or both.

- Reporting Period
  - Last—Select the Last radio button and a period of time from the drop-down list.
  - From—Select the From radio button and enter the From and To dates and times. You can type a date in the text box, or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

Note The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

VoIP Calls Table Results

This report displays the same information as the VoIP Calls Graph report but the information is displayed in a table instead of a graph.

The following information is displayed for a VoIP Calls Table report (see Figure 15-44):

- Number of attempted VoIP calls per radio during the specified period of time.
- Duration (in seconds) of VoIP calls.
Voice Statistics

This report helps analyze wireless network usage from a voice perspective by providing details such as percentage of bandwidth used by voice clients, voice calls, roaming calls, and rejected calls (per radio) on the network. To be able to gather useful data from this report, make sure Call Admission Control (CAC) is supported on voice clients.

Note

Voice Statistics reports only apply to clients that support Call Admission Control (CAC) and have CAC enabled.

Click Voice Statistics from the Report Launch Pad to open the Voice Statistics Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.


Configuring a Voice Statistics Report

This section describes how to configure a Voice Statistics report.

Settings

- Report Title—If you plan to used this as a saved report, enter a report name.
- Report by
  - AP by Controller—Choose All Controllers > All Access Points from the Report Criteria page, or click Edit to select a specific device.
- AP by Floor Area—Choose All Campuses > All Buildings > All Floors > All Access Points from the Report Criteria page, or click Edit to select a specific device.
- AP by Outdoor Area—Choose All Campuses > All Outdoor Areas > All Access Points from the Report Criteria page, or click Edit to select a specific device.

**Note**
In the Report Criteria page, click Select to confirm your filter criteria or Close to return to the previous page.

- Protocol—Choose 802.11 a/n, 802.11 b/g/n, or both.
- Reporting Period
  - Last—Select the Last radio button and a period of time from the drop-down list.
  - From—Select the From radio button and enter the From and To dates and times. You can type a date in the text box, or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

**Note**
The reporting period is based on the alarm last seen time. The times are in the UTC time zone.

**Schedule**

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

**Voice Statistics Results**

**Note**
Voice Statistics reports only apply to clients that support Call Admission Control (CAC) and have CAC enabled.

The following information is displayed for a Voice Statistics report (see Figure 15-45):
- Percentage of bandwidth in use during the specified period of time.
- Total number of non-roaming and roaming calls during the specified period of time.
- Number of rejected calls during the specified period of time. Statistics include:
  - Total number of rejected calls.
  - Number of rejected roaming and non-roaming calls.
  - Number of rejected calls due to insufficient bandwidth, bad parameters, physical rate, and QoS policy.
Figure 15-45  Voice Statistics Results

Voice Statistics
Generated: 2011-May-18, 18:21:14 UTC
Report By: AP By Controller
Protocol: 802.11a/n
Graph Type: Number Of Calls
Reporting Period: Last 2 days

Voice statistics reports are applicable only to clients that support call admission control (CAC) and have CAC enabled.

Security Reports

Click New for a Security Report type to create a new report. See the “Creating and Running a New Report” section on page 15-3 for more information.

Click a report type to view currently saved reports. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

The section contains the following Security Reports:

- Adaptive wIPS Alarm, page 15-138
- Adaptive wIPS Alarm Summary, page 15-140
- Adaptive wIPS Top 10 AP, page 15-142
- Adhoc Rogue Count Summary, page 15-145
- Adhoc Rogues, page 15-148
- New Rogue AP Count Summary, page 15-150
- New Rogue APs, page 15-152
- Rogue AP Count Summary, page 15-154
Adaptive wIPS Alarm

This report displays wIPS alarms by selected MSEs, controllers, and access points for each alarm type. Click Adaptive wIPS Alarms from the Report Launch Pad to open the Adaptive wIPS Alarms Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the Adaptive wIPS Alarms Reports page. See the “Configuring an Adaptive wIPS Alarm Report” section on page 15-138 and the “Adaptive wIPS Alarm Report Results” section on page 15-139 for more information.

Configuring an Adaptive wIPS Alarm Report

This section describes how to configure an Adaptive wIPS Alarms report.

Settings

- Report Title—If you plan to use this as a saved report, enter a report name.
- Report by
  - MSE with Adaptive wIPS Service—Choose All MSEs with Adaptive wIPS Service from the Report Criteria drop-down list, or click Edit to select a specific MSE.
  - Controller by MSE—Choose All MSEs > All Controllers from the Report Criteria drop-down list, or click Edit to select a specific controller.
  - AP by MSE—Choose All MSEs > All Controllers > All APs from the Report Criteria box, or click Edit to select a specific access point.
  
    Note
    In the Filter Criteria drop-down list, choose the appropriate filter criteria.

- Alarm Category—Choose All Types, Denial of Service (DoS), or Security Penetration to determine the types of wIPS alarms to display in the results.
- Reporting Period—Specify the time period for which the report needs to be generated. You can select from a list of choices defined such as Last 1 hour, Last 6 hours, and so on, or specify a custom period by selecting the From and To date and time.
  
    Note
    The reporting period is based on the time that the alarm was last seen. The times are shown in the local time of the WCS server.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.
Customize Report Form

Click Customized to open the Create Custom Report form, which you can use to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note

Fixed columns appear in blue font and cannot be moved to Available Columns.

Adaptive wIPS Alarm Report Results

An Adaptive wIPS Alarm Report potentially contains the following information, depending on how the report is customized (see Figure 15-46):

- Alarm Name (mandatory column).
- AP Name—The name of the device that detected the alarm.
- Source Device—Identifies the device that initiated the potential attack.
- Target Device—Identifies the device targeted by the potential attack.
- Severity—Indicates the severity of the attack (Critical, Urgent, Warning, Information).
- Channel—The channel on which the alarm occurred.
- Status—The current status of the alarm (Active or Inactive).
- First Seen—The date and time the alarm was first detected.
- Last Seen—The date and time the alarm was last detected.
- AP MAC Address—The MAC address of this access point.
- Target SSID—The Service Set Identifier of the targeted device.
- Alarm Category.
- MSE Name—The name of the MSE to which this device is associated.
Adaptive wIPS Alarm Summary

This report displays a summary of all the Adaptive wIPS Alarms on your network.

Click Adaptive wIPS Alarm Summary from the Report Launch Pad to open the Adaptive wIPS Alarm Summary Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the Adaptive wIPS Alarm Summary Reports page. See the “Configuring an Adaptive wIPS Alarm Summary Report” section on page 15-140 and the “Adaptive wIPS Alarm Summary Report Results” section on page 15-141 for more information.

Configuring an Adaptive wIPS Alarm Summary Report

This section describes how to configure an Adaptive wIPS Alarm Summary report.
Settings

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report By**
  - MSE with Adaptive wIPS Service—Choose *All MSEs with Adaptive wIPS Service* from the Report Criteria drop-down list, or click *Edit* to select a specific MSE.
  - Controller by MSE—Choose *All MSEs > All Controllers* from the Report Criteria drop-down list, or click *Edit* to select a specific controller.
  - AP by MSE—Choose *All MSEs > All Controllers > All APs* from the Report Criteria drop-down list, or click *Edit* to select a specific access point.

**Note**

In the Filter Criteria box, select the appropriate filter criteria.

- **Alarm Category**—Choose *All Types*, *Denial of Service (DoS)*, or *Security Penetration* to determine the types of wIPS alarms to be displayed in the results.
- **Reporting Period**—Specify the time period for which the report needs to be generated. You can select from a list of choices defined such as Last 1 hour, Last 6 hours, and so on, or specify a custom period by selecting the From and To date and time.

**Note**

The reporting period is based on the time that the alarm was last seen. The times are shown in the local time of the WCS server.

- **Show**—Specify the number of records to be displayed. You can specify a number between 10 and 100. If the field is left blank, then all the records are displayed.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

Click **Customize** to open the Create Custom Report form, which you can use to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information about customizing report results.

**Note**

Data fields that appear in blue font cannot be removed from the list of fields to be included.

Adaptive wIPS Alarm Summary Report Results

An Adaptive wIPS Alarm Summary Report potentially contains the following information, depending on how the report is customized (see Figure 15-47):

- **Alarm Name** (mandatory column)
- **Category**—Alarm category
- **Severity Information**
Security Reports

- Critical—The number of critical alarms for this access point.
- Major—The number of major alarms for this access point.
- Minor—The number of minor alarms for this access point.
- Warning—The number of warning alarms for this access point.

- Total—The number of total alarms for this access point.

Figure 15-47 Adaptive wIPS Alarm Summary Report

Adaptive wIPS Top 10 AP

This report displays the top ten access points with the highest number of generated Adaptive wIPS alarms.
Click Adaptive wIPS Top 10 APs from the Report Launch Pad to open the Adaptive wIPS Top 10 APs Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the Adaptive wIPS Top 10 APs Reports page. See the “Configuring an Adaptive wIPS Top 10 AP Report” section on page 15-143 and the “Adaptive wIPS Top 10 AP Report Results” section on page 15-144 for more information.

Configuring an Adaptive wIPS Top 10 AP Report

This section describes how to configure a wIPS Top 10 AP report.

Settings

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report By**
  - MSE with Adaptive wIPS Service—Choose All MSEs with Adaptive wIPS Service from the Report Criteria drop-down list, or click Edit to select a specific MSE.
  - Controller by MSE—Choose All MSEs > All Controllers from the Report Criteria drop-down list, or click Edit to select a specific controller.

  **Note** In the Filter Criteria drop-down list, choose the appropriate filter criteria.

- **Alarm Category**—Choose All Types, Denial of Service (DoS), or Security Penetration to determine the types of wIPS alarms to display in the results.

  **Note** See the wIPS Policy Alarm Encyclopedia for more information regarding wIPS alarm types.

- **Reporting Period**—Specify the time period for which the report needs to be generated. You can select from a list of choices defined such as Last 1 hour, Last 6 hours, and so on, or specify a custom period by selecting the From and To date and time.

  **Note** The reporting period is based on the time that the alarm was last seen. The times are shown in the local time of the WCS server.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

Click Customize to open the Create Custom Report form, which you can use to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.
Adaptive wIPS Top 10 AP Report Results

An Adaptive wIPS Top 10 AP Report potentially contains the following information, depending on how the report is customized (see Figure 15-48):

- AP Name (mandatory column)
- Critical—The number of critical alarms for this access point.
- Major—The number of major alarms for this access point.
- Minor—The number of minor alarms for this access point.
- Warning—The number of warning alarms for this access point.
- Total—The number of total alarms for this access point.
- AP MAC Address—The MAC address of this access point.
- MSE Name—The name of the MSE to which this access point is associated.

Figure 15-48 Adaptive wIPS Top 10 APs Report

Adaptive wIPS Top 10 AP
Generated: 2011-May-19, 18:41:23 UTC

Report By: MSE with Adaptive wIPS service
MSE with Adaptive wIPS Service: All MSEs with Adaptive wIPS Service
Alarm Category: All Types
Reporting Period: Last 3 days

Adaptive wIPS Top 10 AP Report
This report provides a list of the top 10 wIPS monitoring APs that have detected the most security alarms that have occurred in the WLAN environment. These alarms are stored on the Mobility Services Engine(s) installed on your network running Adaptive wIPS. A high number of alarms on a monitoring AP is indicative of “security hot spots” in the network that warrant closer investigation. Please refer to the threat knowledgebase in WCS for remediation and mitigation techniques for these events. A closely monitored WLAN system with latest security standards implemented is protected against many common WLAN security threats. Cisco ensures WLAN security by monitoring the WLAN and alerting the wireless administrator of early warning signs of security threats. With the comprehensive suite of security monitoring technologies, Cisco allows the user to more than 120 different threat conditions. This report includes the different types of potential security threats, the number of alarms they have occurred, and also breaks it down to the severity level (Critical, Major, Minor, and Warning) for each of the Top 10 APs. Please refer to “wIPS Profiles” under the “Configuration” menu to view all detected alarms and their respective category.

<table>
<thead>
<tr>
<th>AP Name</th>
<th>Critical</th>
<th>Major</th>
<th>Minor</th>
<th>Warning</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>SJC14-11A-AP-ID51</td>
<td>270</td>
<td>5</td>
<td>36</td>
<td>11</td>
<td>322</td>
</tr>
</tbody>
</table>
Adhoc Rogue Count Summary

This report displays a summarized count of all adhoc rogue access points.

Click Adhoc Rogue Count Summary from the Report Launch Pad to open the Adhoc Rogue Count Summary Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the Adhoc Rogue Count Summary Reports page. See the “Configuring an Adhoc Rogue Count Summary Report” section on page 15-145 and the “Adhoc Rogue Count Summary Report Results” section on page 15-146 for more information.

Configuring an Adhoc Rogue Count Summary Report

This section describes how to configure an Adhoc Rogue Count Summary report.

Settings

- Report Title—If you plan to use this as a saved report, enter a report name.
- Report By
  - AP by Controller—Choose All Controllers > All Access Points from the Report Criteria drop-down list, or click Edit to select a specific device.
  - AP by Floor Area—Choose All Campuses > All Buildings > All Floors > All Access Points from the Report Criteria drop-down list, or click Edit to select a specific device.
  - AP by Outdoor Area—Choose All Campuses > All Outdoor Areas > All Access Points from the Report Criteria drop-down list, or click Edit to select a specific device.

  Note: In the Filter Criteria drop-down list, choose the appropriate filter criteria.

- Classification Type—Choose All Types, Malicious, Friendly, or Unclassified to determine the type of rogue access point to be displayed in the report results.
- Reporting Period—Specify the time period for which the report needs to be generated. You can select from a list of choices defined such as Last 1 hour, Last 6 hours, and so on, or specify a custom period by selecting the From and To date and time.

  Note: The reporting period is based on the time that the alarm was last seen. The times are shown in the local time of the WCS server.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

Click Customize to open the Create Custom Report form, which you can use to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information about customizing report results.
Adhoc Rogue Count Summary Report Results

The following are potential results for an Adhoc Rogue Count Summary report, depending on how the report is customized (see Figure 15-49):

Figure 15-49 Adhoc Rogue Count Summary Report

Adhoc Rogue Events

This report displays all adhoc rogue events received by WCS.

The following settings and scheduling parameters are available for this report:

Click Adhoc Rogue Events from the Report Launch Pad to open the Adhoc Rogue Events Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the Adhoc Rogue Events Reports page. See the “Configuring an Adhoc Rogue Events Report” section on page 15-147 and the “Adhoc Rogue Events Report Results” section on page 15-148 for more information.
Configuring an Adhoc Rogue Events Report

Settings

The following settings can be configured for an Adhoc Rogue Events report:

- Report Title—If you plan to use this as a saved report, enter a report name.
- Report by
  - AP by Controller—Choose All Controllers > All Access Points from the Report Criteria page or click Edit to select a specific device.
  - AP by Floor Area—Choose All Campuses > All Buildings > All Floors > All Access Points from the Report Criteria page or click Edit to select a specific device.
  - AP by Outdoor Area—Choose All Campuses > All Outdoor Areas > All Access Points from the Report Criteria page or click Edit to select a specific device.

Note: From the Report Criteria page, click Select to confirm your filter criteria or Close to return to the previous page.

- Reporting Period

  Note: Reporting period is based on the alarm Last Seen time.

  - Last—Select the Last radio button and a period of time from the drop-down list.
  - From—Select the From radio button and enter the From and To dates and times. You can type a date in the text box or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Creating a Custom Report

The Create Custom Report page allows you to customize the report results. See the “Creating and Running a New Report” for more information on customizing report results.

Note: Mandatory columns are displayed in blue font and cannot be moved to Available Columns. Last Seen Time, Rogue MAC Address, and Detecting AP Name are mandatory columns for the Adhoc Rogue Events report.

Command Buttons

Once all report parameters have been set, select from the following:

- Save—Click to save this report setup without immediately running the report. The report will automatically run at the scheduled time.
• Save and Run—Click to save this report setup and to immediately run the report.
• Run Now—Click to run the report without saving the report setup.
• Export Now—Click to export the report results. The supported export formats is PDF and CSV.
• Cancel—Click to return to the previous page without running nor saving this report.

See the “Creating and Running a New Report” section on page 15-3 for additional information on running or scheduling a report.

Adhoc Rogue Events Report Results

The following are potential results for an Adhoc Rogue Events report, depending on how the report is customized:

• Last Seen Time (mandatory column)
• Rogue MAC Address (mandatory column)
• Detecting AP Name (mandatory column)
• Radio Type—802.11a or 802.11b/g.
• Controller IP Address—The IP address of the controller on which the adhoc rogue is located.
• Map Location—The building, floor area, or outdoor area (as applicable) where the adhoc rogue was detected.
• SSID—The user-defined Service Set Identifier name.
• State—The radio state relative to the network or port. Adhoc rogue radios appear as “Alert” when first scanned by the port, or as “Pending” when operating system identification is still underway.
• Channel Number—The channel number of the adhoc rogue.
• RSSI (dBm)—The received signal strength indicator in dBm.

Adhoc Rogues

This report displays details for all adhoc rogue devices detected by your network access points based on the time they were last seen.

WCS receives updates about adhoc rogues from controllers by using traps or by polling. Last Seen Time is updated anytime a trap for the adhoc rogue is received or the adhoc rogue was seen during the last polling cycle of WCS.

Note

This report includes rogue access point alarms with clear severity.

Click Adhoc Rogues from the Report Launch Pad to open the Adhoc Rogues Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click New from the Report Launch Pad or from the Adhoc Rogues Reports page. See the “Configuring an Adhoc Rogues Report” section on page 15-149 and the “Adhoc Rogues Report Results” section on page 15-149 for more information.
Configuring an Adhoc Rogues Report

This section describes how to configure an Adhoc Rogues report.

Settings

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report By**
  - AP by Controller—Choose All Controllers > All Access Points from the Report Criteria drop-down list, or click **Edit** to select a specific device.
  - AP by Floor Area—Choose All Campuses > All Buildings > All Floors > All Access Points from the Report Criteria drop-down list, or click **Edit** to select a specific device.
  - AP by Outdoor Area—Choose All Campuses > All Outdoor Areas > All Access Points from the Report Criteria drop-down list, or click **Edit** to select a specific device.

  **Note**
  From the Filter Criteria drop-down list, choose the appropriate filter criteria.

- **Reporting Period**—Specify the time period for which the report needs to be generated. You can select from a list of choices defined such as Last 1 hour, Last 6 hours, and so on, or specify a custom period by selecting the From and To date and time.

  **Note**
  The reporting period is based on the time that the alarm was last seen. The times are shown in the local time of the WCS server.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

Click **Customize** to open the Create Custom Report form, which you can use to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

  **Note**
  Fixed columns appear in blue font and cannot be moved to Available Columns.

Adhoc Rogues Report Results

The following are potential results for an Adhoc Rogues report, depending on how the report is customized (see Figure 15-50):

- **Last Seen Time**—Date and time the ad hoc rogue was last seen.
- **Detecting AP Name**—The access point that last detected the rogue, when a rogue is detected by multiple access points on one controller. This last detected access point name comes from the controller that supports maximum RSSI.
- Radio Type—**802.11a/n** or **802.11b/g/n**.
- Controller IP Address—The IP address of the controller on which the ad hoc rogue is located.
- Map Location—The building, floor area, or outdoor area (as applicable) where the ad hoc rogue was detected.
- SSID—The user-defined Service Set Identifier name.
- State—The radio state relative to the network or port. Ad hoc rogue radios appear as “Alert” when first scanned by the port, or as “Pending” when operating system identification is still underway.
- Rogue MAC Address—The MAC address of the ad hoc rogue.
- Channel Number—The channel number of the ad hoc rogue.
- RSSI (dBm)—The maximum received signal strength indicator ever reported by any controller for this rogue.

**Figure 15-50  Adhoc Rogues Results**

### Adhoc Rogues

**Generated:** 2011-May-18, 18:53:02 UTC

**Report By:** AP By Controller

**Reporting Period:** Last 2 days

<table>
<thead>
<tr>
<th>Last Seen Time</th>
<th>Rogue MAC Address</th>
<th>Detecting AP Name</th>
<th>Radio Type</th>
<th>Controller IP Address</th>
<th>Detecting AP Map Location</th>
<th>SSID</th>
<th>State</th>
<th>Severity</th>
</tr>
</thead>
<tbody>
<tr>
<td>2011-May-18, 21:00:43 UTC</td>
<td>1e:2a:96:67:ea:29</td>
<td>EDC26-21A-AP27</td>
<td>802.11b/g/n</td>
<td>10.32.34.2</td>
<td>System Campus &gt; SJC-24 &gt; 3rd Floor</td>
<td>Bnent Maker's Guest Removed Network</td>
<td>Clear</td>
<td></td>
</tr>
<tr>
<td>2011-May-18, 18:16:10 UTC</td>
<td>09:61:00:60:42:09</td>
<td>EDC14-61A-ID68</td>
<td>802.11b/g/n</td>
<td>10.32.34.2</td>
<td>Alert</td>
<td>Minor</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2011-May-18, 17:15:17 UTC</td>
<td>08:57:00:60:45:08</td>
<td>EDC14-61A-ROBBERT-Moses</td>
<td>802.11b/g/n</td>
<td>10.32.34.2</td>
<td>Alert</td>
<td>Minor</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2011-May-18, 17:16:00 UTC</td>
<td>08:55:30:69:1a:0e</td>
<td>EDC19-42A-AP207</td>
<td>802.11b/g/n</td>
<td>10.32.34.2</td>
<td>System Campus &gt; SJC-19 &gt; 4th Floor</td>
<td>bb-voice</td>
<td>Alert</td>
<td>Minor</td>
</tr>
</tbody>
</table>

### New Rogue AP Count Summary

This report displays a summarized count of all the new rogue access points.

Click **New Rogue AP Count Summary** from the Report Launch Pad to open the New Rogue AP Count Summary Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click **New** from the Report Launch Pad or from the New Rogue AP Count Summary Reports page. See the “Configuring a New Rogue AP Count Summary Report” section on page 15-151 and the “New Rogue AP Count Summary Report Results” section on page 15-151 for more information.
Configuring a New Rogue AP Count Summary Report

This section describes how to configure a New Rogue AP Count Summary report.

Settings

- Report Title—If you plan to use this as a saved report, enter a report name.
- Report By
  - AP by Controller—Choose All Controllers > All Access Points from the Report Criteria drop-down list, or click Edit to select a specific device.
  - AP by Floor Area—Choose All Campuses > All Buildings > All Floors > All Access Points from the Report Criteria drop-down list, or click Edit to select a specific device.
  - AP by Outdoor Area—Choose All Campuses > All Outdoor Areas > All Access Points from the Report Criteria drop-down list, or click Edit to select a specific device.

Note From the Filter Criteria drop-down list, choose the appropriate filter criteria.

- Classification Type—Choose All Types, Malicious, Friendly, or Unclassified to determine the type of rogue access point to be displayed in the report results.
- Reporting Period—Specify the time period for which the report needs to be generated. You can select from a list of choices defined such as Last 1 hour, Last 6 hours, and so on, or specify a custom period by selecting the From and To date and time.

Note The times are shown in the local time of the WCS server.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

Click Customize to open the Create Custom Report form, which you can use to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information about customizing report results.

Note Data fields that appear in blue font cannot be removed from the list of fields to be included.

New Rogue AP Count Summary Report Results

The following are potential results for a New Rogue AP Count Summary report, depending on how the report is customized (see Figure 15-51):
**New Rogue APs**

This report displays all the new rogues detected for the first time on your network within the selected timeframe for this report. The value in the Created Time column indicates the time at which the rogue was first detected.

*Note*

This report includes rogue access point alarms with clear severity.

Click **New Rogue AP** from the Report Launch Pad to open the New Rogue APs Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click **New** from the Report Launch Pad or from the New Rogue APs Reports page. See the “Configuring a New Rogue AP Report” section on page 15-152 and the “New Rogue AP Report Results” section on page 15-153 for more information.

### Configuring a New Rogue AP Report

This section describes how to configure a New Rogue Access Points report.

#### Settings

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report by**
Chapter 15  Reports

Security Reports

- AP by Controller—Choose All Controllers > All Access Points from the Report Criteria drop-down list, or click Edit to select a specific device.
- AP by Floor Area—Choose All Campuses > All Buildings > All Floors > All Access Points from the Report Criteria drop-down list, or click Edit to select a specific device.
- AP by Outdoor Area—Choose All Campuses > All Outdoor Areas > All Access Points from the Report Criteria drop-down list, or click Edit to select a specific device.

Note

From the Filter Criteria drop-down list, choose the appropriate filter criteria.

- Classification Type—Choose All Types, Malicious, Friendly, or Unclassified to determine the type of rogue access point to display in the report results.
- Reporting Period—Specify the time period for which the report needs to be generated. You can select from a list of choices defined such as Last 1 hour, Last 6 hours, and so on, or specify a custom period by selecting the From and To date and time.

Note

The times are shown in the local time of the WCS server.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

Click Customize to open the Create Custom Report form, which you can use to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

Note

Fixed columns appear in blue font and cannot be moved to Available Columns.

New Rogue AP Report Results

The following are potential results for a New Rogue APs report, depending on how the report is customized (see Figure 15-52):

Note

The results for this report are sorted based on First Time Seen.

- First Seen Time—The date and time the rogue access point was first seen.
- Rogue MAC Address—The MAC address of the rogue access point. Click the MAC address link to view the alarm details of the access point.
- Detecting AP Name—The access point that last detected the rogue, when a rogue is detected by multiple access points on one controller. This last detected access point name comes from the controller that supports maximum RSSI.
- Radio Type—802.11a/n or 802.11b/g/n.
- Controller IP Address—The IP address of the controller on which the rogue access point is located.
- Map Location—The building, floor area, or outdoor area (as applicable) where the rogue access point was detected.
- SSID—The user-defined Service Set Identifier name.
- State—The radio state relative to the network or port. Rogue access point radios appear as “Alert” when first scanned by the port, or as “Pending” when operating system identification is still underway.
- Channel Number—The channel number of the rogue access point.
- RSSI (dBm)—The received signal strength indicator in dBm.
- Classification Type—The type of rogue access point (malicious, friendly, or unclassified).
- Switch Port Trace Status—Indicates whether or not the switch port was traced.
- Switch Port Trace Summary—Provides a summary of the switch port trace or remains blank if no switch port was traced.

**Figure 15-52 New Rogue Access Points Report**

### Rogue AP Count Summary

This report displays a summarized count of all the rogue access points on your network.

Click **Rogue AP Count Summary** from the Report Launch Pad to open the Rogue AP Count Summary Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click **New** from the Report Launch Pad or from the Rogue AP Count Summary Reports page. See the “Configuring a Rogue AP Count Summary Report” section on page 15-154 and the “Rogue AP Count Summary Report Results” section on page 15-155 for more information.

### Configuring a Rogue AP Count Summary Report

This section describes how to configure a Rogue AP Count Summary report.

<table>
<thead>
<tr>
<th>Last Seen Time</th>
<th>Rogue MAC Address</th>
<th>Detecting AP Name</th>
<th>Radio Type</th>
<th>Controller IP Address</th>
<th>Detecting AP Map Location</th>
<th>SSID</th>
<th>State</th>
<th>Classification Type</th>
<th>On Network</th>
</tr>
</thead>
<tbody>
<tr>
<td>2011-11-10, 17:15:52 UTC</td>
<td>01:23:45:67:89:AB</td>
<td>SEC14-42A</td>
<td>802.11b/g/n</td>
<td>192.0.2.1</td>
<td>192.0.2.19</td>
<td>Removed</td>
<td>Unclassified</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>2011-11-10, 17:15:52 UTC</td>
<td>01:23:45:67:89:AB</td>
<td>SEC14-42A</td>
<td>802.11b/g/n</td>
<td>192.0.2.1</td>
<td>192.0.2.19</td>
<td>Removed</td>
<td>Unclassified</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>2011-11-10, 17:15:52 UTC</td>
<td>01:23:45:67:89:AB</td>
<td>SEC14-42A</td>
<td>802.11b/g/n</td>
<td>192.0.2.1</td>
<td>192.0.2.19</td>
<td>Removed</td>
<td>Unclassified</td>
<td>No</td>
<td></td>
</tr>
</tbody>
</table>

- **Figure 15-52 New Rogue Access Points Report**

### Rogue AP Count Summary

This report displays a summarized count of all the rogue access points on your network.

Click **Rogue AP Count Summary** from the Report Launch Pad to open the Rogue AP Count Summary Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click **New** from the Report Launch Pad or from the Rogue AP Count Summary Reports page. See the “Configuring a Rogue AP Count Summary Report” section on page 15-154 and the “Rogue AP Count Summary Report Results” section on page 15-155 for more information.

### Configuring a Rogue AP Count Summary Report

This section describes how to configure a Rogue AP Count Summary report.
Settings

- Report Title—If you plan to use this as a saved report, enter a report name.
- Report by
  - AP by Controller—Choose All Controllers > All Access Points from the Report Criteria drop-down list, or click Edit to select a specific device.
  - AP by Floor Area—Choose All Campuses > All Buildings > All Floors > All Access Points from the Report Criteria drop-down list, or click Edit to select a specific device.
  - AP by Outdoor Area—Choose All Campuses > All Outdoor Areas > All Access Points from the Report Criteria drop-down list, or click Edit to select a specific device.

  **Note** From the Filter Criteria drop-down list, choose the appropriate filter criteria.

- Classification Type—Choose All Types, Malicious, Friendly, or Unclassified to determine the type of rogue access point to be displayed in the report results.
- Reporting Period—Specify the time period for which the report needs to be generated. You can select from a list of choices defined such as Last 1 hour, Last 6 hours, and so on, or specify a custom period by selecting the From and To date and time.

  **Note** The times are shown in the local time of the WCS server.

Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Customize Report Form

Click Customize to open the Create Custom Report form, which you can use to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information about customizing report results.

  **Note** Data fields that appear in blue font cannot be removed from the list of fields to be included.

Rogue AP Count Summary Report Results

The following are potential results for a New Rogue AP Count Summary report, depending on how the report is customized (see Figure 15-53):
Rogue Access Point Events

This report displays all rogue access point events received by WCS and based on the event time. Any rogue-related trap received by WCS is logged as a rogue event in WCS. A new rogue access point event is created by WCS based on polled data when there is a newly detected rogue access point. In addition, an event is also created by WCS when the user changes the state and classification of the rogue access point through the WCS user interface.

Note

One rogue can have multiple events. This report is based on the timestamp of the event.

Click Rogue AP Events from the Report Launch Pad to open the Rogue AP Events Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.
To create a new report, click **New** from the Report Launch Pad or from the Rogue AP Events Reports page. See the “Configuring a Rogue Access Point Events Report” section on page 15-157 and the “Rogue AP Events Report Results” section on page 15-158 for more information.

### Configuring a Rogue Access Point Events Report

#### Settings

The following settings can be configured for a Rogue Access Point Events report:

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report by**
  - **AP by Controller**—Choose *All Controllers > All Access Points* from the Report Criteria page, or click **Edit** to select a specific device.
  - **AP by Floor Area**—Choose *All Campuses > All Buildings > All Floors > All Access Points* from the Report Criteria page, or click **Edit** to select a specific device.
  - **AP by Outdoor Area**—Choose *All Campuses > All Outdoor Areas > All Access Points* from the Report Criteria page, or click **Edit** to select a specific device.

<table>
<thead>
<tr>
<th>Note</th>
<th>From the Report Criteria page, click <strong>Select</strong> to confirm your filter criteria or <strong>Close</strong> to return to the previous page.</th>
</tr>
</thead>
</table>

- **Classification Type**—Choose *All Types*, *Malicious*, *Friendly*, or *Unclassified* to determine the type of rogue access point to display in the report results.
- **Reporting Period**
  - **Last**—Select the **Last** radio button and a period of time from the drop-down list.
  - **From**—Select the **From** radio button and enter the From and To dates and times. You can type a date in the text box, or click the calendar icon to choose a date. Choose the hours and minutes from the drop-down lists.

#### Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

#### Creating a Custom Report

The Create Custom Report page allows you to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

<table>
<thead>
<tr>
<th>Note</th>
<th>Mandatory columns are displayed in blue font and cannot be moved to Available Columns. Last Seen Time, Rogue MAC Address, and Detecting AP Name are mandatory columns for the Rogue Access Point Events report.</th>
</tr>
</thead>
</table>

#### Command Buttons

Once all report parameters have been set, select from the following:
• Save—Click to save this report setup without immediately running the report. The report will automatically run at the scheduled time.

• Save and Run—Click to save this report setup and to immediately run the report.

• Run Now—Click to run the report without saving the report setup.

• Export Now—Click to export the report results. The supported export formats is PDF and CSV.

• Cancel—Click to return to the previous page without running nor saving this report.

Note
See the “Creating and Running a New Report” section on page 15-3 for additional information on running or scheduling a report.

Rogue AP Events Report Results

The following are potential results for a Rogue AP Events report, depending on how the report is customized:

• Last Seen Time (mandatory column)

• Rogue MAC Address (mandatory column)

• Detecting AP Name (mandatory column)

• Radio Type—802.11a/n or 802.11b/g/n.

• Controller IP Address—The IP address of the controller on which the rogue is located.

• Map Location—The building, floor area, or outdoor area (as applicable) where the rogue access point was detected.

• SSID—The user-defined Service Set Identifier name.

• State—The radio state relative to the network or port. Rogue access point radios appear as “Alert” when first scanned by the port, or as “Pending” when operating system identification is still underway.

• Channel Number—The channel number of the rogue access point.

• RSSI (dBm)—The received signal strength indicator in dBm.

• SNR—The Signal-to-Noise Ratio.

• Classification Type—The type of rogue access point (malicious, friendly, or unclassified).

Rogue APs

WCS gets updates about rogues from controllers by using traps or by polling. The Last Seen Time is updated anytime a trap for the rogue is received or rogue was seen during the last polling cycles of WCS. This report displays all rogues detected by the access points in your network based on the “last seen time” of the rogue access points and the selected filtering criteria. It orders rogue access points based on the time they were last heard.

Note
The report includes rogue access point alarms with clear severity.
Click **Rogue APs** from the Report Launch Pad to open the Rogue APs Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.

To create a new report, click **New** from the Report Launch Pad or from the Rogue APs Reports page. See the “Configuring a Rogue APs Report” section on page 15-159 and the “Rogue APs Report Results” section on page 15-160 for more information.

### Configuring a Rogue APs Report

This section describes how to configure a Rogue APs report.

#### Settings

- **Report Title**—If you plan to use this as a saved report, enter a report name.
- **Report By**
  - **AP by Controller**—Choose **All Controllers > All Access Points** from the Report Criteria drop-down list, or click **Edit** to select a specific device.
  - **AP by Floor Area**—Choose **All Campuses > All Buildings > All Floors > All Access Points** from the Report Criteria drop-down list, or click **Edit** to select a specific device.
  - **AP by Outdoor Area**—Choose **All Campuses > All Outdoor Areas > All Access Points** from the Report Criteria drop-down list, or click **Edit** to select a specific device.

  **Note** From the Filter Criteria drop-down list, choose the appropriate filter criteria.

- **Classification Type**—Choose **All Types**, **Malicious**, **Friendly**, or **Unclassified** to determine the type of rogue access point to display in the report results.
- **Reporting Period**—Specify the time period for which the report needs to be generated. You can select from a list of choices defined such as Last 1 hour, Last 6 hours, and so on, or specify a custom period by selecting the From and To date and time.

  **Note** The times are shown in the local time of the WCS server.

#### Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

#### Customize Report Form

Click **Customize** to open the Create Custom Report form, which you can use to customize the report results. See the “Creating and Running a New Report” section on page 15-3 for more information on customizing report results.

**Note** Fixed columns appear in blue font and cannot be moved to Available Columns.
Rogue APs Report Results

The following are potential results for a Rogue APs report, depending on how the report is customized (see Figure 15-54):

- **Note** The results for this report are sorted by “Last Seen” time.

- Last Seen Time—The date and time the rogue access point was last detected.
- Rogue MAC Address—The MAC address of the rogue access point. Click an item under MAC Address to view Rogue AP details.
- Detecting AP Name—The access point that last detected the rogue, when a rogue is detected by multiple access points on one controller. This last detected access point name comes from the controller which supports maximum RSSI.
- Radio Type—802.11a or 802.11b/g.
- Controller IP Address—The IP address of the controller on which the rogue is located.
- Map Location—The building, floor area, or outdoor area (as applicable) where the rogue access point is located.
- SSID—The user-defined Service Set Identifier name.
- State—The radio state relative to the network or port. Rogue access point radios appear as “Alert” when first scanned by the port, or as “Pending” when operating system identification is still underway.
- Channel Number—The channel number of the rogue access point.
- RSSI (dBm)—The maximum received signal strength indicator ever reported by any controller for this rogue.
- Classification Type—The type of rogue access point (malicious, friendly, or unclassified).
- Switch Port Trace Status—Indicates whether or not the switch port was traced.
- Switch Port Trace Summary—Provides a summary of the switch port trace or remains blank if no switch port was traced.
- On Network—Indicates whether the access point is on the network or not.
Security Alarm Trending Summary

This report displays a summary of trends of security alarms over a period of time.

Click Security Alarm Trending Summary from the Report Launch Pad to open the Security Summary Reports page. From this page, you can enable, disable, delete, or run currently saved reports. See the “Managing Current Reports” section on page 15-9 for more information.


Configuring a Security Alarm Trending Summary Report

This section describes how to configure a Security Alarm Trending Summary report.

Settings

- Report Title—If you plan to use this as a saved report, enter a report name.
- Reporting Period—Specify the time period for which the report needs to be generated. You can select from a list of choices defined such as Last 1 hour, Last 6 hours, and so on, or specify a custom period by selecting the From and To date and time.

Note: The times are shown in the local time of the WCS server.
Schedule

If you plan to run this report at a later time or as a recurring report, enter the scheduling parameters. See the “Creating and Running a New Report” section on page 15-3 for more information on scheduling a report.

Security Alarm Trending Summary Report Results

The following are potential results for a Security Alarm Trending Summary report, depending on how the report is customized (see Figure 15-55):

Figure 15-55   Security Alarm Trending Summary Report
Performing Administrative Tasks

The Administration enables you to schedule tasks, administer accounts, and configure local and external authentication and authorization. Also, set logging options, configure mail servers, and data management related to configuring the data retain periods. Information is available about the types of WCS licenses and how to install a license.

This chapter describes the administrative tasks to perform with Cisco WCS. It contains the following sections:

- Information About Administrative Tasks, page 16-1
- Performing Background Tasks, page 16-15
- Importing Tasks Into ACS, page 16-40
- Configuring Auto Provisioning, page 16-48
- Configuring Administrative Settings, page 16-60
- Establishing Logging Options, page 16-55
- Configuring High Availability, page 16-92
- Setting User Preferences, page 16-97
- Managing Individual Licenses, page 16-99
- Configuring ACS 5.x, page 16-101
- Managing Licenses, page 16-109
- Configuring AAA, page 16-114

Information About Administrative Tasks

Organizations need an easy and cost-effective method to manage and control wireless network segments using a single management platform. They need a solution that supports limiting an individual administrator to manage or control the wireless LAN.

This section contains the following topics:

- Background Tasks, page 16-2
- Data Management Tasks (Settings), page 16-3
- Other Background Tasks, page 16-4
- Authentication, Authorization, and Accounting (AAA), page 16-4
- Auto Provisioning, page 16-5
Background Tasks

A background task is a scheduled program running in the background with no visible pages or other user interfaces. In WCS background tasks can be anything from data collection to taking backups of the configurations.

Note

Choose Administration > Background Tasks to view several scheduled tasks. The Background Tasks page appears (see Figure 16-1).

You can view the administrative and operating status, task interval, and time of day in which the task occurs. To execute a particular task, select the check box of the desired task and choose Execute Now from the Select a command drop-down list. The task executes based on what you have configured for the specific task.

The tasks are listed in tables with the following columns:

- **Check box**—Select to choose the desired task. Chosen tasks are targets for operations initiated from the Select a command drop-down list including:
  - **Execute Now**—Run all of the data sets with a selected check box.
  - **Enable Collection**—Enable the data set to run on its scheduled interval.
  - **Disable Collection**—Prevent the data set from running on its scheduled interval.
- **Task**—Task name that serves as a link to a configuration page. Click a task name to go to that task configuration page.
Chapter 16  Performing Administrative Tasks

Information About Administrative Tasks

- Enabled—Indicates that the task is enabled or disabled.
- Interval—Time period between executions of task.
- Status—Indicates that the task is idle, disabled, or executing.
- Data Aggregation (Data Collections only)—If set to Yes, the data set will aggregate data.
- Non-Aggregation Data Retain Period (Days) (Data Collections only)—The number of days that non-aggregated data will be retained.

**Note**  See the “WCS Historical Data” section on page 16-69 for more information on aggregated and non-aggregated data in WCS.

- Last Execution Time—The date and time the task was executed.
- Last Execution Status—Indicates if the task executed successfully or failed.

This page enables you to view the status of scheduled WCS tasks. Scheduled tasks are divided into two types: “Data Management Tasks (Settings)” section on page 16-3 and the “Other Background Tasks” section on page 16-4.

**Data Management Tasks (Settings)**

Within the Settings page, you can indicate the data that you want to generate for reports and e-mails.

- See the “Configuring Alarms” section on page 16-60 to specify how to handle old alarms and how to display assigned and acknowledged alarms in the Alarm Summary page.
- See “Configuring an Audit” section on page 16-62 to configure audit information.
- See the “Configuring Clients” section on page 16-64 to enable client troubleshooting on a diagnostic channel.
- See the “Configuring Protocols for CLI Sessions” section on page 16-67 to establish a telnet or SSH session.
- See the “Configuring Controller Upgrade” section on page 16-67 for information on controller upgrade settings.
- See the “Configuring Data Management” section on page 16-69 to establish trends for hourly, daily, and weekly data periods.
- See the “Configuring a Guest Account” section on page 16-70 to designate where the scheduled reports will reside and for how long.
- See the “Configuring Login Disclaimer” section on page 16-71 to enter disclaimer information.
- See the “Configuring the Mail Server” section on page 16-71 to set the primary and secondary SMTP server host and port.
- See the “Configuring the Notification Receiver” section on page 16-73 to configure parameters for notification support of guest access functionality.
- See the “Configuring Server Settings” section on page 16-79 to turn FTP, TFTP, HTTP, or HTTPS on or off.
- See the “Severity Configurations” section on page 16-80 to configure the severity level for newly generated alarms.
- See the “SNMP Credentials” section on page 16-82 to specify which credentials to use for tracing the rogue access points.
Other Background Tasks

- See the “Configuring AAA” section on page 16-114 to view the history and current status of client status polling backups.
- See the “Viewing Controller Configuration Backup Status” section on page 16-21 to view all configuration data from the controllers.
- See the “Viewing Controller Configuration Backup Status” section on page 16-21 to view the history and current status of Cisco WLAN Solution configuration backups.
- See the “Viewing Client Status” section on page 16-22 view the history and current status of Controller License Status polling backups.
- See the “Viewing Data Cleanup Status” section on page 16-25 view the history and current status of Cisco WLAN Solution database cleanups.
- See the “Viewing Device Status” section on page 16-26 view the history and current status of Cisco WLAN Solution device status tasks.
- See the “Performing Guest Accounts Sync” section on page 16-27 view the history and current status of Guest Account Synchronization tasks.
- See the “Performing Mobility Service Backup” section on page 16-29 to schedule a backup of the mobility services engine database.
- See the “Viewing Mobility Service Status” section on page 16-30 to view the status of mobility service engine.
- See the “Performing Mobility Service Synchronization” section on page 16-31 to synchronize mobility services engine(s).
- See the “Performing WCS Server Backup” section on page 16-34 to schedule a backup of the WCS Server.
- See the “Viewing Wireless Status” section on page 16-33 view the history and current status of wireless status polls.

Authentication, Authorization, and Accounting (AAA)

From Administration > AAA, authentication, authorization, and accounting (AAA) can be configured for WCS. The only username that has permissions to configure WCS AAA is root or SuperUser. Any changes to local users accounts will be in effect when configured for local mode. If using external authentication, for example RADIUS or TACACS+, the user changes must be done on the remote server. This section contains the following topics:

- Change Password, page 16-114
- Local Password Policy, page 16-116
- AAA Mode, page 16-114
- Users, page 16-116
- Groups, page 16-120
Auto Provisioning

Auto provisioning allows WCS to automatically configure a new or replace a current wireless LAN controller (WLC). The WCS auto provisioning feature can simplify deployments for customers with a large number of controllers.

**Note**
For Auto Provisioning privileges, you must have Admin, Root, or SuperUser status.

**Note**
To allow or disallow a user Auto Provisioning privileges, edit the permitted tasks using the Administration > AAA > Groups > *group name* > List of Tasks Permitted section of WCS. Select or unselect the check box to allow or disallow these privileges.

**Note**
A controller radio and b/g networks are initially disabled by the WCS downloaded startup configuration file. If desired, you may turn on those radio networks by using a template, which should be included as one of the automated templates.

**Note**
To specify the Auto Provision filter contents, you can directly enter the details in the application or import the details from a CSV file. The auto provisioning feature supports the 5500 and non-5500 series of controllers. The non-5500 series controllers have AP manager interface configuration information defined, whereas 5500 series controllers do not have this information.

To access the Auto Provisioning feature, choose **Configure > Controller Auto Provisioning.**

- **Auto Provisioning Device Management (Auto Provisioning Filter List)**—Allows you to create and edit auto provisioning filters which define the list of allowable devices to be auto provisioned or auto monitored by WCS.
- **Auto Provisioning Primary Search Key Settings**—Provides the ability to set the matching criteria search order.

### Auto Provisioning Device Management (Auto Provisioning Filter List)

This feature allows you to create and edit auto provisioning filters which define the list of allowable devices to be auto provisioned or auto monitored by WCS.

Filter parameters include the following:

- **Filter Name**—Identifies the name of the filter.
- **Filter Enable**—Indicates whether or not the filter is enabled.

**Note**
Only enabled filters can participate in the Auto Provisioning process.
Information About Administrative Tasks

- **Monitor Only**—If selected, the WLC defined in this filter is managed by WCS but not configured by WCS if the WLC contacts WCS during the auto provisioning process.
- **Filter Mode**—Indicates the search mode for this filter (Host Name, MAC Address, or Serial Number).
- **Config Group Name**—Indicates the Configuration Group name.

**Note**
All Config-Groups used by auto provision filters should not have any controller defined in them.

Auto Provisioning Options

The Select a command drop-down list has the following options:

- **Add Filter**—Allows you to add an Auto Provisioning filter. See the “Adding an Auto Provisioning Filter” section on page 16-48 for more information.
- **Delete Filter(s)**—Allows you to delete the selected Auto Provisioning filter. See “Deleting Auto Provisioning Filter(s)” section on page 16-52 for more information.
- **List Filter(s) Device Info**—Allows you to view details for the selected Auto Provisioning filter. See “Listing Auto Provisioning Filter(s) Device Info” section on page 16-53 for more information.
- **List All Filter(s) Device Info**—Allows you to view details for all of the Auto Provisioning filter. See “Listing All Auto Provisioning Filter(s) Device Info” section on page 16-54 for more information.

High Availability

To ensure continued operation in case of failure, WCS now provides a high availability (or failover framework). When an active (primary) WCS fails, a secondary WCS takes over operations (in less than two minutes) for the failed primary WCS and continues to provide service. Upon failover, a peer of the failed primary WCS is activated on the secondary WCS using the local database and files, and the secondary WCS runs a fully functional WCS. While the secondary host is in failover mode, the database and file backups of other primary WCSs continue uninterrupted.

To activate and use high availability, you must buy a high availability license. The license is deployed on each primary WCS that is supported by a secondary WCS. After the license is validated, you must configure parameters on the WCS administration interface (see the “Configuring High Availability” section on page 16-92).

For more High Availability information, refer to one of the following sections:

- Guidelines and Limitations for High Availability, page 16-93
- Failover Scenario, page 16-93
- Performing Background Tasks, page 16-15
- High Availability Status, page 16-94
- Configuring High Availability on Primary WCS, page 16-94
- Deploying High Availability, page 16-96
User Preferences

Choose Administration > User Preferences to open the User Preferences page. The User Preferences page enables you to control certain display options in WCS.

List Pages

- Items Per List—You can set the number of items, such as controllers or access points, to display in pages that list these items. Choose the number of items to display from the Items Per List Page drop-down list.

Home Page

- Refresh Home Page—Select the check box if you want to configure a time for the home page to automatically refresh.
- Refresh Home Page Every—Choose the frequency of the home page refresh from the drop-down list (every 30 seconds, 1 minute, 2 minutes, or 5 minutes).

User Idle Timeout

- Logout idle user—Select the check box if you want to configure the amount of time, in minutes, that a user session can be idle before the server cancels the session.
- Logout idle user after—Choose the maximum number of minutes that a server waits for an idle user. The default value is 60 minutes. The minimum value is 15 minutes. The maximum value is 120 minutes.

**Note** If the Logout idle user check box is unselected, the user session will not be timed out.

Alarms

- Refresh Map/Alarms page on new alarm—Select the check box to refresh map and alarm pages each time a new alarm is generated.
- Refresh Alarm count in the Alarm Summary every—Choose the frequency of the Alarm Summary refresh from the drop-down list (every 5, seconds, 15 seconds, 30 seconds, 1 minute, 2 minutes, or 5 minutes).
- Display Alarm Category in Alarm Summary page—Choose the alarm category that you want to display in the minimized Alarm Summary (Alarm Summary, Malicious AP, Unclassified AP, Coverage Holes, Security, Controllers, Access Points, Mobility Services, Mesh Links, WCS, or Performance).
- Disable Alarm Acknowledge Warning Message—When you acknowledge an alarm, a warning displays as a reminder that a recurrence of the problem does not generate another alarm unless this functionality is disabled. Select this check box to stop the warning message from displaying.
- Select alarms for Alarm Summary Toolbar—To select alarms for the Alarm Summary Toolbar, click Edit Alarm Categories and select the required alarm categories and sub-categories.
License Center

The License Center allows you to manage WCS, wireless LAN controllers, and MSE licenses. The License Center is available from the WCS Administration menu. To view the License Center page, choose Administration > License Center (see Figure 16-2).

Note

Although WCS and MSE licenses can be fully managed from the License Center, WLC licenses can only be viewed. You must use WLC or CLM to manage WLC licenses.

Tip

To learn more about WCS License Center, go to Cisco.com to watch a multimedia presentation. Here you can also find the learning modules for a variety of WCS topics. Over future releases, we will add more overview and technical presentations to enhance your learning.

Figure 16-2   License Center

WCS License Information

The WCS Licenses portion of the License Center page displays the following:

- Feature—The type of license, either Base or PLUS. A Base license supports standard WCS capabilities, which includes wireless client data access, rogue access point containment functions, Cisco WLAN Solution monitoring and control, and client and rogue access point location to the nearest access point. Cisco WCS PLUS license supports Cisco WCS Base license features and the following capabilities: mobility services enablement and high availability.

Note

To upgrade to a PLUS license, you must purchase upgrade licenses with the total count meeting or exceeding your Base license.
Chapter 16      Performing Administrative Tasks

Information About Administrative Tasks

Note
A Cisco WCS Plus license is backward compatible to existing Cisco WCS Location licenses. The process to provision a Cisco WCS Plus license is the same as provisioning a current Cisco WCS license.

- Host—The WCS host name.

Note
The host name provides a link to the WCS License Files section.

- AP Limit—The total number of licensed access points.
- AP Count—The current number of access points using licenses.

Note
AP count includes both associated and unassociated access points. When you are near the AP limit, you can delete any unassociated access points to increase available license capacity. For a demo license, you can click the “If you do not have a Product Authorization Key (PAK), please click here for available licenses” link and choose Wireless Control System Trial License.

- % Used—The percentage of access points licensed across WCS. If the percentage drops to 75%, the value appears in red. At this level, a message also appears indicating that both associated and unassociated access points are part of the AP count.
- Type—Permanent if all licenses are permanent. If any licenses are evaluations (or demos), it shows the number of days remaining on the license that has the fewest number of days until expiration.

Note
To add a new license for WCS, go to the Product License Registration link (https://tools.cisco.com/SWIFT/Licensing/PrivateRegistrationServlet) and provide your Product Authorization Key (PAK) and host name.

Note
If you choose Summary > WCS from the left sidebar menu, only the WCS license information is displayed.


It covers selecting the correct SKU, ordering the SKU, installing the software, registering the PAK certificate, and installing the license file on the server.

See the “WCS Licenses” section on page B-1 for more information on licensing enforcement, PAK certificates, license types, and installing and managing WCS licenses.

WLC Controller License Information

The Controller Licensing portion of the License Center page provides the following information for both WPLUS and Base licenses:
• Controller Count—The current number of licensed controllers.

Note Only 5500 series controllers are included in the count. WCS provides only an inventory view and issues warnings if a license is expiring.

Note Choosing the number in this column is the same as choosing Summary > Controller from the left sidebar menu, except that it is sorted by the feature you click. This page provides a summary of active controllers.

• AP Limit—The total number of licensed access points.

• Type—The four different types of licenses are as follows:

Note For any controllers with a type other than Permanent, the least number of days left to expiration is shown.

– Permanent—Licenses are node-locked and have no usage period associated with them. They are issued by Cisco’s licensing portal and must be installed using management interfaces on the device. Upon installation of these licenses, you have the necessary permissions across different versions.

– Evaluation—Licenses are non-node-locked and are valid only for a limited period. They are used only when no permanent, extension, or grace period licenses exist. Before using an evaluation license, you must accept an End User License Agreement (EULA). Even though they are non-node-locked, their usage is recorded on the device. The number of days remaining on the evaluation license that has the fewest number of days until expiration is shown.

– Extension—Licenses are node-locked and metered. They are issued by Cisco’s licensing portal and must be installed using management interfaces on the device. Before using an extension license, you must accept a EULA during installation.

– Grace Period—Licenses are node-locked and metered. These licenses are issued by Cisco’s licensing portal as part of the permission ticket to rehost a license. They are installed on the device as part of the rehost operation, and you must accept a EULA as part of the rehost operation.

If you need to revoke a license from one controller and install it on another, it is called rehosting. You might want to rehost a license to change the purpose of a controller. See the Chapter 4, “Performing Maintenance Operations,” of the Cisco Wireless LAN Controller Configuration Guide for information on rehosting a license.

Note The licensing status is updated periodically. To initiate an immediate update, choose Administration > Background Tasks and run the Controller License Status task.

If your network contains various Cisco licensed devices, you might want to consider using the Cisco License Manager (CLM) to manage all of the licenses using a single application. CLM is a secure client/server application that manages Cisco software licenses network wide. You can download the CLM software and access user documentation at this URL: http://www.cisco.com/go/clm. You can either register a PAK certificate with CLM or with the licensing portal found at https://tools.cisco.com/SWIFT/Licensing/PrivateRegistrationServlet.
WLC Controller License Summary

If you want to see more details about controller licensing, choose the **Summary > Controller** option from the left sidebar menu. The License Center page appears (see **Figure 16-3**). All currently active licenses on the controller are summarized.

**Figure 16-3 License Center (Edit View) Page**

All licensed controllers and their information in the bulleted list below are displayed. If you want to change how the controller results are displayed, click **Edit View**. In the Edit View page, highlight License Status, and click **Hide** to remove the column from the display.

Above the Controller Summary list is a series of filters that allow you to filter the list by Controller Name, Feature, Type, or Greater Than Percent Used. For example, if you enter 50, the list shows any WLCs that have more than 50% of its licenses used.

---

Note: You can also use the **Advanced Search** link to sort the list of controllers.

- **Controller Name**—Provides a link to the Files > Controller Files page.
- **Controller IP**—The IP address of the controller.
- **Model**—The controller model type.
- **Feature**—The type of license, either Base or WPLUS. The Base license supports the standard software set, and the WPLUS license supports the premium Wireless Plus (WPLUS) software set. The WPLUS software set provides the standard feature set as well as added functionality for OfficeExtend access points, CAPWAP data encryptions, and enterprise wireless mesh.
- **AP Limit**—The maximum capacity of access points allowed to join this controller.
- **AP Count**—The current number of access points using licenses.
- **% Used**—The percentage of licensed access points that are being used. If the percentage is greater than 75%, the bar appears red to indicate that the limit is being approached.
- **Type**—The three different types of licenses are as follows:

---

Note: For any controllers with a type other than Permanent, the least number of days left to expiration is shown.
Information About Administrative Tasks

– Permanent—Licenses are node-locked and have no usage period associated with them. They are issued by Cisco’s licensing portal and must be installed using management interfaces on the device. Upon installation of these licenses, you have the necessary permissions across different versions.

– Evaluation—Licenses are non-node-locked and are valid only for a limited time period. They are used only when no permanent, extension, or grace period licenses exist. Before using an evaluation license, you must accept an End User License Agreement (EULA). Even though they are non-node-locked, their usage is recorded on the device. The number of days remaining on the evaluation license which has the fewest number of days until expiration is shown.

– Extension—Licenses are node-locked and metered. They are issued by Cisco’s licensing portal and must be installed using management interfaces on the device. Before using an extension license, you must accept a EULA during installation.

Note

If a license shows as expired, the controller does not stop functioning. Only upon a reboot will the controller with the expired license become inactive.

• Status—In Use, Not in Use, Inactive, or EULA Not Accepted.
  – Inactive—The license level is being used, but this license is not being used.
  – Not In Use—The license level is not being used and this license is not currently recognized.
  – Expired In Use—The license is being used, but is expired and will not be used upon next reboot.
  – Expired Not In Use—The license has expired and can no longer be used.
  – Count Consumed—The ap-count license is In Use.

Mobility Services Engine (MSE) License Information

There are three types of licenses:

• Permanent—Licenses are node-locked and have no usage period associated with them. They are issued by licensing portal of Cisco and must be installed using management interfaces on the device. Upon installation of these licenses, you have the necessary permissions across different versions.

• Evaluation—Licenses are non-node-locked and are valid only for a limited time period. They are used only when no permanent, extension, or grace period licenses exist. Before using an evaluation license, you must accept an End User License Agreement (EULA). Even though they are non-node-locked, their usage is recorded on the device. The number of days remaining on the evaluation license which has the fewest number of days until expiration is shown.

• Extension—Licenses are node-locked and metered. They are issued by licensing portal of Cisco and must be installed using management interfaces on the device. Before using an extension license, you must accept a EULA during installation.

The MSE Licenses portion of the License Center page provides information for each service. (See Table 16-1).
### Table 16-1  MSE License Information

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>CAS Elements</strong></td>
<td></td>
</tr>
<tr>
<td>Permanent Limit</td>
<td>The total number of CAS elements with permanent licenses.</td>
</tr>
<tr>
<td>Evaluation Limit</td>
<td>The total number of CAS elements with evaluation licenses.</td>
</tr>
<tr>
<td>Count</td>
<td>The number of CAS elements currently licensed across MSEs.</td>
</tr>
<tr>
<td>% Used</td>
<td>The percentage of CAS elements licensed across MSEs.</td>
</tr>
<tr>
<td><strong>wIps Monitor Mode APs</strong></td>
<td></td>
</tr>
<tr>
<td>Permanent Limit</td>
<td>The total number of wIps Monitor Mode APs with permanent licenses.</td>
</tr>
<tr>
<td>Evaluation Limit</td>
<td>The total number of wIps Monitor Mode APs with evaluation licenses.</td>
</tr>
<tr>
<td>Count</td>
<td>The number of wIps Monitor Mode APs currently licensed across MSEs.</td>
</tr>
<tr>
<td>% Used</td>
<td>The percentage of wIps Monitor Mode APs licensed across MSEs.</td>
</tr>
<tr>
<td><strong>wIps Local Mode APs</strong></td>
<td></td>
</tr>
<tr>
<td>Permanent Limit</td>
<td>The total number of wIps Local Mode APs with permanent licenses.</td>
</tr>
<tr>
<td>Evaluation Limit</td>
<td>The total number of wIps Local Mode APs with evaluation licenses.</td>
</tr>
<tr>
<td>Count</td>
<td>The number of wIps Local Mode APs currently licensed across MSEs.</td>
</tr>
<tr>
<td>% Used</td>
<td>The percentage of wIps Local Mode APs licensed across MSEs.</td>
</tr>
</tbody>
</table>

Under wIps Monitor Mode Aps or wIps Local Mode Aps, an active link takes you to a list of licensed access points. You cannot access a list of licensed clients and tags.

When a license is deleted, the mobility services engine automatically restarts to load the new license limits.

For more information on MSE licenses, see the “Overview of MSE License” section on page 12-71.
### Mobility Services Engine (MSE) License Summary

If you want to see more details about MSE licensing, choose **Summary > MSE** from the left sidebar menu. The License Center page appears (see Figure 16-4).

![License Center Page](image)

Figure 16-4  License Center Page

<table>
<thead>
<tr>
<th>MSE Name (UDI)</th>
<th>Type</th>
<th>Limit</th>
<th>Count</th>
<th>Unlicensed Count</th>
<th>% Used</th>
<th>License Type</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>10.10.10.151</td>
<td>AIR-MSE-3310-99</td>
<td>10</td>
<td>0</td>
<td>0</td>
<td>0%</td>
<td>Evaluation (58 days left)</td>
<td>Active</td>
</tr>
<tr>
<td>wIPS Monitor Mode APs</td>
<td>20</td>
<td>0</td>
<td>0</td>
<td>0%</td>
<td>Evaluation (58 days left)</td>
<td>Active</td>
<td></td>
</tr>
<tr>
<td>Tag Elements</td>
<td>100</td>
<td>5</td>
<td>0</td>
<td>3%</td>
<td></td>
<td></td>
<td>Active</td>
</tr>
<tr>
<td>Client Elements</td>
<td>100</td>
<td>20</td>
<td>0</td>
<td>0%</td>
<td></td>
<td></td>
<td>Active</td>
</tr>
</tbody>
</table>

All licensed MSEs are listed in the following columns:

- **MSE Name**—Provides a link to the MSE license file list page.

**Note**

The icon to the left of the MSE Name/UDI indicates whether the mobility services engine is low-end or high-end.

A high-end mobility services engine (3350) has a higher memory capacity and can track up to 18,000 clients and tags. A low-end mobility services engine (3310) can track up to 2000 clients and tags.

- **Type**—Specifies the type of MSE.

  **Note**

  Under wIPS Monitor Mode APs or wIPS Local Mode APs, an active link takes you to a list of licensed access points. You cannot access a list of licensed clients or tags.

- **Limit**—Displays the total number of client elements licensed across MSEs.
- **Count**—Displays the number of client elements that are currently licensed across MSEs.
- **Unlicensed Count**—Displays the number of client elements that are not licensed.

**Note**

wIPS service does not process the alarms generated from these unlicensed access points.
Performing Background Tasks

This section contains procedures for crucial background tasks:

- Performing a Data Collection Task, page 16-15
- Performing Other Background Tasks, page 16-19

For more information on the Data Collection and Other Background Tasks, see “Data Collection Tasks” section on page 16-18 and “Other Background Tasks” section on page 16-36.

Performing a Data Collection Task

Data collection tasks are data-set tasks that collect and organize information that may be useful for creating reports.

Note

All tasks related to collecting data or any other background task would be handled in a similar manner.

Step 1

Choose Administration > Background Tasks to display the Background Tasks page. This page displays the following information:

- Enabled—Whether the tasks have been enabled or disabled.
- Interval—Indicates the time period (in minutes) between task executions. You can set the interval from the data collection configuration page for the task.
- Status—The present state of the task.
• Data Aggregation (Data Collection Tasks only)—If set to Yes, the data set combines data.

• Non-Aggregation Data Retain Period (Days) (Data Collection Tasks only)—The number of days that the non-aggregated data is retained. You can set the retention period from the data collection configuration page of the task.

• Last Execution Time—The time and date when the task was last run.

• Last Execution Status—The status after the last task was run.

**Step 2** On this page, perform one of the following:

• Execute the task now.
  
  Select the check box of the task you want to execute. From the Select a command drop-down list, choose **Execute Now**, and click **Go**.

• Enable the task.
  
  Select the check box of the task you want to enable. From the Select a command drop-down list, choose **Enable Task**, and click **Go**. The task changes from unavailable to active after enabling is complete.

• Disable the task.
  
  Select the check box of the task you want to disable. From the Select a command drop-down list, choose **Disable Task, and click Go**. The task is grayed out after the disabling is complete.

• View details of a task.
  
  Click a URL in the Data Collection Tasks or Other Background Tasks column to view a specific task. The details on that task appear. Data collections are data-set tasks that collect and organize a specific type of information useful for creating reports. For more information on the various Data Collection Tasks, see “Data Collection Tasks” section on page 16-18.

To go to the configuration page of a data set, select the name of the data set in the Data Collection page. Each data set configuration page displays a table of the executions of the data set. The table has following columns:

• Executed task information includes the following:
  
  – Last Execution Start Time—Indicates the date and time that the data-set task began running.
  
  – End Time—Indicates the date and time that the data-set task stopped running.
  
  – Elapsed Time (secs)—Indicates the amount of time (in seconds) it took to complete the task.
  
  – Result—Indicates the success or failure of the task.
  
  – Additional Information—Provides any additional information regarding a specific task.

Each data set configuration page contains the following parameters and information under Collection Set Details:

• Description—Provides a brief read-only description of the data set.

• Data Aggregation—Indicates whether or not data collected by the data set is aggregated.

• Used By Report(s)—Displays names of the reports that use the data set.
  
  – CleanAir Air Quality—This data set is used for Worst Air Quality APs and Air Quality versus Time reports.
  
  – Interferers—This data set is used for Worst Interferers reports.

• Collection Status—Select the **Enabled** check box to enable data collection.

• Interval (min.)—Enter the time (in minutes) for the data set execution interval. Valid value is 1 to 120 minutes.
Each data set configuration page contains the following parameters under Data Management:

- **Non-Aggregation Data Retain Period (Days)**—Enter the number of days to retain non-aggregated data collected by the data set. Valid value is 1 to 31 days.
- **Retain Aggregation Raw Data**—Select the **Enable** check box to enable the retention of aggregated raw data.

  **Note**  
  The Aggregation Raw Data Retain Period setting is for polled raw data. To configure the retention period for aggregated trend data, choose **Administration > Settings**, then choose **Data Management** from the left sidebar menu.

  **Note**  
  See the “Authentication, Authorization, and Accounting (AAA)” section on page 16-4 for more information on aggregated and non-aggregated data.

**Note**  
For this example, performing an WCS server backup was selected as the task. The screens and fields to enter on the detailed screens vary based on the task you choose.

**Step 3**  
Select the **Enabled** check box to enable it.

**Step 4**  
Select the **Report History Backup** check box.

**Step 5**  
In the Max Backups to Keep text box, enter the maximum number of backup files to save on the server.

- **Range:** 7 to 50
- **Default:** 7

  **Note**  
  To prevent the WCS platform from running out of disk space, the server automatically deletes old backup files when the number of files exceeds the value entered for this text box.

**Step 6**  
In the Interval (Days) text box, enter the number of days between each backup. For example, 1 = a daily backup, 2 = a backup every other day, 7 = a weekly backup, and so on.

- **Range:** 1 to 360
- **Default:** 7

**Step 7**  
In the Time of Day text box, enter the back-up start time. It must be in this format: *hh:mm AM/PM* (for example: 03:00 AM). If no AM/PM notation is designated, the entered hour is always AM. If you want to specify 5PM, you can enter 17:00 or 5:00 PM. When the page is revisited after saving, the time is displayed as *hh:mm* (in this case 17:00), without the PM designation.

  **Note**  
  Backing up a large database affects the performance of the WCS server. Therefore, we recommend that you schedule backups to run when the WCS server is idle (such as, in the middle of the night).

**Step 8**  
Click **Submit** to save your settings. The backup file is saved as a .zip file in the *ftp-install-dir*/ftp-server/root/WCSBackup directory using this format: *dd-mmm-yy__hh-mm-ss.zip* (for example, 11-Nov-05_10-30-00.zip).
Data Collection Tasks

Table 16-2 lists and describes the various data collection tasks in WCS.

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Task Status</th>
<th>Default Schedule</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AP Image Pre-Download Status</td>
<td>Disabled</td>
<td>15 minutes</td>
<td>This task is used to see the Image Predownload-status of the associated APs in the Controllers. To see the status of the access points, the Pre-download software to APs option should be selected while downloading software to Controller.</td>
</tr>
<tr>
<td>Autonomous AP CPU and Memory Utilization</td>
<td>Enabled</td>
<td>15 minutes</td>
<td>This task is used to collect information about Memory and CPU Utilization of Autonomous APs.</td>
</tr>
<tr>
<td>CleanAir Air Quality</td>
<td>Enabled</td>
<td>15 minutes</td>
<td>This task is used to collect information about CleanAir Air Quality.</td>
</tr>
<tr>
<td>Client Statistics</td>
<td>Enabled</td>
<td>15 minutes</td>
<td>This task helps you to get the statistical information for the Autonomous and Lightweight clients.</td>
</tr>
<tr>
<td>Controller Performance</td>
<td>Enabled</td>
<td>30 minutes</td>
<td>This task is used to collect performance information for Controllers.</td>
</tr>
<tr>
<td>Guest Sessions</td>
<td>Enabled</td>
<td>15 minutes</td>
<td>This task is used to collect information about the Guest sessions.</td>
</tr>
<tr>
<td>Interferers</td>
<td>Enabled</td>
<td>15 minutes</td>
<td>This task is used to collect information about the Interferers.</td>
</tr>
<tr>
<td>Mesh link Performance</td>
<td>Enabled</td>
<td>10 minutes</td>
<td>This task is used to collect information about the performance of Mesh links.</td>
</tr>
<tr>
<td>Mesh Link Status</td>
<td>Enabled</td>
<td>5 minutes</td>
<td>This task is used to collect status of the Mesh links.</td>
</tr>
<tr>
<td>Mobility Service Performance</td>
<td>Enabled</td>
<td>15 minutes</td>
<td>This task is used to collect information about the performance of mobility service engines.</td>
</tr>
<tr>
<td>Media Stream Clients</td>
<td>Enabled</td>
<td>15 minutes</td>
<td>This task is used to collect information about the media stream clients.</td>
</tr>
<tr>
<td>Radio Performance</td>
<td>Enabled</td>
<td>15 minutes</td>
<td>This task is used to collect statistics from wireless radios.</td>
</tr>
<tr>
<td>Rogue AP</td>
<td>Enabled</td>
<td>120 minutes</td>
<td>This task is used to collect information about the Rogue access points.</td>
</tr>
<tr>
<td>Traffic Stream Metrics</td>
<td>Enabled</td>
<td>8 minutes</td>
<td>This task helps you to get traffic stream metrics for the clients.</td>
</tr>
<tr>
<td>V5 Client Statistics</td>
<td>Disabled</td>
<td>60 minutes</td>
<td>This task is used to collect the Dot11 and Security statistics for CCX clients &gt;= v5.</td>
</tr>
</tbody>
</table>
Performing Other Background Tasks

You can also perform other background tasks using WCS Administration. This section contains the procedures for the other WCS background tasks:

- Performing a Configuration Sync, page 16-19
- Viewing Controller Configuration Backup Status, page 16-21
- Viewing Data Cleanup Status, page 16-25
- Performing Device Data Collection, page 16-25
- Performing Guest Accounts Sync, page 16-27
- Updating Controller License Status, page 16-23
- Performing Mobility Service Backup, page 16-29
- Viewing Mobility Service Status, page 16-30
- Performing Mobility Service Synchronization, page 16-31
- Viewing Wireless Status, page 16-33
- Viewing OSS Server Status, page 16-32

For more information on the Other background tasks, see Other Background Tasks, page 16-36.

Performing a Configuration Sync

To perform a configuration sync, follow these steps:

Step 1  Choose Administration > Background Tasks to display the Background Tasks page (see Figure 16-1).

Step 2  On this page, perform one of the following:

- Execute the task now.
  Choose the Configuration Sync check box. From the Select a command drop-down list, choose Execute Now, and click Go. You see the status change in the Enabled column.

- Enable the task.
  Choose the Configuration Sync check box. From the Select a command drop-down list, choose Enable Task, and click Go. The task converts from dimmed to active in the Enabled column.

- Disable the task.
  Choose the Configuration Sync check box. From the Select a command drop-down list, choose Disable Task, and click Go. The task is dimmed in the Enabled column after the disabling is complete.

Step 3  To modify the task, click the Configuration Sync link in the Background Tasks column. The Task > Configuration Sync page appears (see Figure 16-5).
Performing Background Tasks

Chapter 16  Performing Administrative Tasks

Performing Background Tasks

Figure 16-5  Task > Configuration Sync

Step 4
Click the background task in the Task column to open the task details page.

The Configuration Sync page displays the following information:

- Last Execution Information
  - Start and end times.
  - Elapsed time (in seconds) of the task.
  - Result—Success or error.
  - Message—Text message regarding this task.

Step 5
View or modify the following in the Edit Task pane:

- Description—Read-only. Displays the name of the task.
- Used By Report(s)—Indicates the WCS reports that use these task results.
- Enabled—Select the check box to enable this task.
- Network Audit—Select the check box to enable the secondary network audit.
- Security Index Calculation—Select the check box to enable security index calculation. The Security Index is available on the Monitor > Security page.
- RRM Audit—Select the check box to enable an RRM audit.

Note
The Controller audit will find the discrepancies between the values in WCS Database with the device.
Performing Background Tasks

Note To Query the SNMP Values from the device, you can use the https://<wcs-IP>/webacs/manObjDiagQueryAction.do URL in WCS.

Note The Network Audit audits on all controllers in the network, and also runs RRM audit and Security audit. These options are selectable from the Administration > Background Tasks > Other Background Tasks > Configuration Sync page.

- Time of Day (hh:mm AM|PM)—Indicate the time of day (AM or PM) for the execution of this task.

Note Time of Day (hh:mm AM|PM) must be in this format: hh:mm AM/PM (for example: 03:00 AM). If no AM/PM notation is designated, the entered hour is always AM. If you want to specify 5PM, you could enter 17:00 or 5:00 PM. When the page is revisited after saving, the time is displayed as hh:mm (in this case 17:00), without the PM designation.

Note When WCS is upgraded from 6.0.x to 7.0,x the upgrade script will change the interval for this background task from hours to minutes. The smart sync option is enabled by default with 60 minutes interval. This default setting would override any settings applied in WCS 6.0.x.

Step 6 When finished, click Submit to confirm task changes or Cancel to return to the Administration > Background Tasks page with no changes made.

Viewing Controller Configuration Backup Status

Choose Administration > Background Tasks, then click Controller Configuration Backup to access this page.

This page enables you to view the history and current status of Cisco WLAN Solution configuration backups.

From the Administration > Background Tasks page, you can execute, enable, or disable this task. To execute, enable, or disable this task from the Administration > Background Tasks page, follow these steps:

Step 1 Choose Administration > Background Tasks.

Step 2 Select the check box(es) of the Background Task(s) that you want to execute, enable, or disable.

Step 3 Use the Select a command drop-down list to perform one of the following tasks:

- Execute the task now—Select the check box of the task you want to execute. From the Select a command drop-down list, choose Execute Now, and click Go. The status changes in the Enabled column.

  or

- Enable the task—Select the check box of the task you want to enable. From the Select a command drop-down list, choose Enable Task, and click Go.

  or
Performing Background Tasks

Step 1  Click the background task in the Task column to open the task details page. The Controller Configuration Backup page displays the following information:

- Last Execution Information
  - Start and end times
  - Elapsed time in seconds
  - Result—Success or error.
  - Message—Text message regarding the task execution.

Step 2  View or modify the following in the Edit Task pane:

- Description—Read-only. Displays the name of the task.
- Enabled—Select this check box to enable Cisco WCS execute the task at the specified interval.

  Note  If the Enabled check box is not selected, the task is not executed at the specified time.

- Interval—Indicates the frequency (in days) of the task.
- Time of Day (hh:mm AM|PM)

  Note  Time of Day (hh:mm AM|PM) must be in this format: hh:mm AM/PM (for example: 03:00 AM). If no AM/PM notation is designated, the entered hour is always AM. If you want to specify 5PM, you could enter 17:00 or 5:00 PM. When the page is revisited after saving, the time is displayed as hh:mm (in this case 17:00), without the PM designation.

- TFTP Server—Select the server or Default Server from the drop-down list.

  Note  TFTP must be enabled in Administration > Settings > Server Settings for 'Default Server' options.

Step 3  When finished, click Submit to confirm task changes or Cancel to return to the Administration > Background Tasks page with no changes made.

Viewing Client Status

Choose Administration > Background Tasks, then click Client Status to access this page. This page enables you to view the history and current status of client status polling backups. In the Administration > Background Tasks page, you can execute, enable, or disable this task. To execute, enable, or disable this task from the Administration > Background Tasks page, follow these steps:

- Disable the task—Select the check box of the task you want to disable. From the Select a command drop-down list, choose Disable Task, and click Go.

To modify the task, follow these steps:

Step 1  Click the background task in the Task column to open the task details page.

The Controller Configuration Backup page displays the following information:

- Last Execution Information
  - Start and end times
  - Elapsed time in seconds
  - Result—Success or error.
  - Message—Text message regarding the task execution.

Step 2  View or modify the following in the Edit Task pane:

- Description—Read-only. Displays the name of the task.
- Enabled—Select this check box to enable Cisco WCS execute the task at the specified interval.

  Note  If the Enabled check box is not selected, the task is not executed at the specified time.

- Interval—Indicates the frequency (in days) of the task.
- Time of Day (hh:mm AM|PM)

  Note  Time of Day (hh:mm AM|PM) must be in this format: hh:mm AM/PM (for example: 03:00 AM). If no AM/PM notation is designated, the entered hour is always AM. If you want to specify 5PM, you could enter 17:00 or 5:00 PM. When the page is revisited after saving, the time is displayed as hh:mm (in this case 17:00), without the PM designation.

- TFTP Server—Select the server or Default Server from the drop-down list.

  Note  TFTP must be enabled in Administration > Settings > Server Settings for 'Default Server' options.

Step 3  When finished, click Submit to confirm task changes or Cancel to return to the Administration > Background Tasks page with no changes made.
Performing Background Tasks

Step 1  Choose Administration > Background Tasks.
Step 2  Select the check box(es) of the Background Task(s) that you want to execute, enable, or disable.
Step 3  Use the Select a command drop-down list to perform one of the following tasks:
   • Execute the task now—Select the check box of the task you want to execute. From the Select a command drop-down list, choose Execute Now, and click Go. The status changes in the Enabled column.
   or
   • Enable the task—Select the check box of the task you want to enable. From the Select a command drop-down list, choose Enable Task, and click Go.
   or
   • Disable the task—Select the check box of the task you want to disable. From the Select a command drop-down list, choose Disable Task, and click Go.

To modify the task, follow these steps:

Step 1  Click the background task in the Task column to open the task details page.
The Client Status page displays the following information:
   • Last Execution Information
     – Start and end times
     – Elapsed time in seconds
     – Result—Success or error.
     – Message—Text message regarding the task execution.
Step 2  View or modify the following in the Edit Task pane:
   • Description—Read-only. Displays the name of the task.
   • Enabled—Select this check box to enable WCS to execute the task at the specified interval.
     Note If the Enabled check box is not selected, the task is not executed at the specified time.
   • Interval—Indicates the frequency (in days) of the task.
Step 3  When finished, click Submit to confirm task changes or Cancel to return to the Administration > Background Tasks page with no changes made.

Updating Controller License Status

To update the controller license status, follow these steps:

Step 1  Choose Administration > Background Tasks to display the Background Tasks page (see Figure 16-6).
Step 2  On this page, perform one of the following:
   • Execute the task now.
Performing Background Tasks

Select the **Controller License Status** check box. From the Select a command drop-down list, choose **Execute Now**, and click **Go**. You see the status change in the Enabled column.

- Enable the task.

Select the **Controller License Status** check box. From the Select a command drop-down list, choose **Enable Task**, and click **Go**. The task converts from grayed out to active in the Enabled column.

- Disable the task.

Select the **Controller License Status** check box. From the Select a command drop-down list, choose **Disable Task**, and click **Go**. The task converts from grayed out to active in the Enabled column after the disabling is complete.

**Step 3**
To modify the controller license reset task, click the **Controller License Status** link in the Background Tasks column. The Controller License Status page appears (see **Figure 16-6**).

**Figure 16-6   Controller License Status Page**

This page shows when the latest license resynchronizations occurred. By default, it runs every 4 hours. From this page, you can disable this task or change the interval.

**Step 4**
Click the background task in the Task column to open the task details page.

**Step 5**
The Controller Configuration Backup page displays the following information:

- **Last Execution Information**
  - Start and end times
  - Elapsed time in seconds
  - Result—Success or error.
  - Message—Text message regarding the task execution.

**Step 6**
View or modify the following in the Edit Task pane:
Performing Background Tasks

Description—Read-only. Displays the name of the task.

Enabled—Select this check box to enable Cisco WCS execute the task at the specified interval.

Note If the Enabled check box is not selected, the task is not executed at the specified time.

Interval—Indicates the frequency (in days) of the task.

Step 7 When finished, click Submit to confirm task changes or Cancel to return to the Administration > Background Tasks page with no changes made.

Viewing Data Cleanup Status

Choose Administration > Background Tasks, then click Database Cleanup to access this page.

This page enables you to view the history and current status of Cisco WLAN Solution database cleanups. To modify this task, follow these steps:

Step 1 Choose Administration > Background Tasks.

Step 2 Click the background task in the Task column to open the task details page.

The Data Cleanup page displays the following information:

- Last Execution Information
  - Start and end times
  - Elapsed time in seconds
  - Result—Success or error.
  - Message—Text message regarding the task execution.

Step 3 View or modify the following in the Edit Task pane:

- Description—Read-only. Displays the name of the task.
- Time of Day (hh:mm AM/PM)

Note Time of Day (hh:mm AM/PM) must be in this format: hh:mm AM/PM (for example: 03:00 AM). If no AM/PM notation is designated, the entered hour is always AM. If you want to specify 5PM, you can enter 17:00 or 5:00 PM. When the page is revisited after saving, the time is displayed as hh:mm (in this case 17:00), without the PM designation.

Step 4 When finished, click Submit to confirm task changes or Cancel to return to the Administration > Background Tasks page with no changes made.

Performing Device Data Collection

Follow these steps to perform a device data collection:

Step 1 Choose Administration > Background Tasks to display the Background Tasks page.
Performing Background Tasks

Step 2  On this page, perform one of the following:

• Execute the task now.
  Select the Device Data Collection check box. From the Select a command drop-down list, choose Execute Now, and click Go. You see the status change in the Enabled column.
  or
• Enable the task.
  Select the Device Data Collection check box. From the Select a command drop-down list, choose Enable Task, and click Go. The task converts from grayed out to active in the Enabled column.
  or
• Disable the task.
  Select the Device Data Collection check box. From the Select a command drop-down list, choose Disable Task, and click Go. The task is grayed out in the Enabled column after the disabling is complete.

Step 3  To modify the task, click the Device Data Collection link in the Background Tasks column. The Task > Device Data Collector page appears.

Step 4  Click the background task in the Task column to open the task details page.
  The Device Data Collector page displays the following information:
  • Last Execution Information
    – Start and end times.
    – Elapsed time (in seconds) of the task.
    – Result—Success or error.
    – Message—Text message regarding this task.

Step 5  View or modify the following in the Edit Task group box:
  • Description—Read-only. Displays the name of the task.
  • Enabled—Select the check box to enable this task.
  • Controller IP address—The IP address of the Controller to collect data from.
  • CLI Commands—Enter the CLI commands separated by comma, which you would want to run on the specified Controller.
  • Clean Start—Select or unselect this option to enable or disable a clean start before data collection.
  • Repeat—Enter the number of times you would want the data collection to happen.
  • Interval—Enter the interval in days that you would want the data collection to happen. Valid range: 1 to 360 days.

Step 6  When finished, click Submit to confirm task changes or Cancel to return to the Administration > Background Tasks page with no changes made.

Viewing Device Status

Device status polls controller reachability and WiSM peer information.
Choose Administration > Background Tasks, then click Device Status to access this page.
This page enables you to view the history and current status of Cisco WLAN Solution device status tasks. From the Administration > Background Tasks page, you can execute, enable, or disable this task. To execute, enable, or disable this task from the Administration > Background Tasks page, follow these steps:

### Step 1
Choose Administration > Background Tasks.

### Step 2
Select the check box(es) of the Background Task(s) that you want to execute, enable, or disable.

### Step 3
Use the Select a command drop-down list to perform one of the following tasks:

- **Execute the task now**—Select the check box of the task you want to execute. From the Select a command drop-down list, choose *Execute Now*, and click *Go*. The status changes in the Enabled column.

- **Enable the task**—Select the check box of the task you want to enable. From the Select a command drop-down list, choose *Enable Task*, and click *Go*.

- **Disable the task**—Select the check box of the task you want to disable. From the Select a command drop-down list, choose *Disable Task*, and click *Go*.

To modify the task, follow these steps:

### Step 1
Click the background task in the Task column to open the task details page.

The Device Status page displays the following information:

- **Last Execution Information**
  - Start and end times
  - Elapsed time in seconds
  - Result—Success or error.
  - Message—Text message regarding the task execution.

### Step 2
View or modify the following in the Edit Task pane:

- **Description**—Read-only. Displays the name of the task.
- **Enabled**—Select this check box to enable Cisco WCS execute the task at the specified interval.

**Note**

If the Enabled check box is not selected, the task is not executed at the specified time.

- **Interval**—Indicates the frequency (in days) of the task.

### Step 3
When finished, click *Submit* to confirm task changes or *Cancel* to return to the Administration > Background Tasks page with no changes made.

---

**Performing Guest Accounts Sync**

Choose Administration > Background Tasks, then click *Guest Accounts Sync* to access this page.
This page enables you to view the history and current status of Guest Accounts Synchronization tasks. From the Administration > Background Tasks page, you can execute, enable, or disable this task. To execute, enable, or disable this task from the Administration > Background Tasks page, follow these steps:

### Step 1
Choose **Administration > Background Tasks**.

### Step 2
Select the check box(es) of the Background Task(s) that you want to execute, enable, or disable.

### Step 3
Use the Select a command drop-down list to perform one of the following tasks:

- **Execute the task now**—Select the check box of the task you want to execute. From the Select a command drop-down list, choose **Execute Now**, and click **Go**. The status changes in the Enabled column.

- **Enable the task**—Select the check box of the task you want to enable. From the Select a command drop-down list, choose **Enable Task**, and click **Go**.

- **Disable the task**—Select the check box of the task you want to disable. From the Select a command drop-down list, choose **Disable Task**, and click **Go**.

To modify the task, follow these steps:

### Step 1
Click the background task in the Task column to open the task details page.

The Guest Accounts Synchronization page displays the following information:

- **Last Execution Information**
  - Start and end times
  - Elapsed time in seconds
  - Result—Success or error.
  - Message—Text message regarding the task execution.

### Step 2
View or modify the following in the Edit Task pane:

- **Description**—Read-only. Displays the name of the task.
- **Enabled**—Select this check box to enable Cisco WCS execute the task at the specified interval.

  **Note** If the Enabled check box is not selected, the task is not executed at the specified time.

- **Interval**—Indicates the frequency (in days) of the task.
- **Time of Day (hh:mm AM|PM)**

  **Note** Time of Day (hh:mm AM|PM) must be in this format: hh:mm AM/PM (for example: 03:00 AM). If no AM/PM notation is designated, the entered hour is always AM. If you want to specify 5PM, you can enter 17:00 or 5:00 PM. When the page is revisited after saving, the time is displayed as hh:mm (in this case 17:00), without the PM designation.
Performing Mobility Service Backup

Choose Administration > Background Tasks, then click Mobility Service Backup to access this page. This page enables you to schedule a backup of the mobility services engine database.

From the Administration > Background Tasks page, you can execute, enable, or disable this task. To execute, enable, or disable this task from the Administration > Background Tasks page, follow these steps:

## Step 1
Choose Administration > Background Tasks.

## Step 2
Select the check box(es) of the Background Task(s) that you want to execute, enable, or disable.

## Step 3
Use the Select a command drop-down list to perform one of the following tasks:

- Execute the task now—Select the check box of the task you want to execute. From the Select a command drop-down list, choose Execute Now, and click Go. The status changes in the Enabled column.

- Enable the task—Select the check box of the task you want to enable. From the Select a command drop-down list, choose Enable Task, and click Go.

- Disable the task—Select the check box of the task you want to disable. From the Select a command drop-down list, choose Disable Task, and click Go.

To modify the task, follow these steps:

## Step 1
Click the background task in the Task column to open the task details page.

The Mobility Service Backup page displays the following information:

- Last Execution Information
  - Start and end times
  - Elapsed time in seconds
  - Result—Success or error.
  - Message—Text message regarding the task execution.

## Step 2
View or modify the following in the Edit Task pane:

- Description—Read-only. Displays the name of the task.
- Enabled—Select this check box to enable Cisco WCS execute the task at the specified interval.

Note If the Enabled check box is not selected, the task is not executed at the specified time.
Performing Background Tasks

- Max backups to keep—Enter the maximum number of location backups to be kept on the backup server.
- Interval (days)—Enter the frequency of backup.
- Time of the Day (hh:mm AM/PM)—Enter the time at which the backup starts on the scheduled day.

**Note** Time of Day (hh:mm AM/PM) must be in this format: hh:mm AM/PM (for example: 03:00 AM). If no AM/PM notation is designated, the entered hour is always AM. If you want to specify 5PM, you can enter 17:00 or 5:00 PM. When the page is revisited after saving, the time is displayed as hh:mm (in this case 17:00), without the PM designation.

- When finished, click **Submit** to confirm task changes or **Cancel** to return to the Administration > Background Tasks page with no changes made.

Viewing Mobility Service Status

Choose **Administration** > **Background Tasks**, then click **Mobility Service Status** to access this page. This page displays the status of the mobility services engine.

From the Administration > Background Tasks page, you can execute, enable, or disable this task. To execute, enable, or disable this task from the Administration > Background Tasks page, follow these steps:

**Step 1** Choose **Administration** > **Background Tasks**.

**Step 2** Select the check box(es) of the Background Task(s) that you want to execute, enable, or disable.

**Step 3** Use the Select a command drop-down list to perform one of the following tasks:

- Execute the task now—Select the check box of the task you want to execute. From the Select a command drop-down list, choose **Execute Now**, and click **Go**. The status changes in the Enabled column.
  
  or

- Enable the task—Select the check box of the task you want to enable. From the Select a command drop-down list, choose **Enable Task**, and click **Go**.
  
  or

- Disable the task—Select the check box of the task you want to disable. From the Select a command drop-down list, choose **Disable Task**, and click **Go**.

To modify the task, follow these steps:

**Step 1** Click the background task in the Task column to open the task details page.

The Mobility Service Status page displays the following information:

- Last Execution Information
  
  - Start and end times
  
  - Elapsed time in seconds
Performing Administrative Tasks

Performing Background Tasks

Step 2 View or modify the following in the Edit Task pane:
- Description—Read-only. Displays the name of the task.
- Enabled—Select this check box to enable Cisco WCS execute the task at the specified interval.

Note If the Enabled check box is not selected, the task is not executed at the specified time.
- Interval (days)—Enter the frequency of backup.

Step 3 When finished, click Submit to confirm task changes or Cancel to return to the Administration > Background Tasks page with no changes made.

Performing Mobility Service Synchronization

Choose Administration > Background Tasks, then click Mobility Service Synchronization to access this page.

This page enables you to synchronize mobility services engine(s).

From the Administration > Background Tasks page, you can execute, enable, or disable this task. To execute, enable, or disable this task from the Administration > Background Tasks page, follow these steps:

Step 1 Choose Administration > Background Tasks.
Step 2 Select the check box(es) of the Background Task(s) that you want to execute, enable, or disable.
Step 3 Use the Select a command drop-down list to perform one of the following tasks:
- Execute the task now—Select the check box of the task you want to execute. From the Select a command drop-down list, choose Execute Now, and click Go. The status changes in the Enabled column.
  or
- Enable the task—Select the check box of the task you want to enable. From the Select a command drop-down list, choose Enable Task, and click Go.
  or
- Disable the task—Select the check box of the task you want to disable. From the Select a command drop-down list, choose Disable Task, and click Go.

To modify the task, follow these steps:

Step 1 Click the background task in the Task column to open the task details page.
The Mobility Service Synchronization page displays the following information:
- Last Execution Information
  - Start and end times
Performing Background Tasks

Step 2 View or modify the following in the Edit Task pane:
- Description—Read-only. Displays the name of the task.
- Out of Sync Alerts—When enabled, this generates minor alarms when location server is not synchronized with the WCS changes that you have made.
- Auto Synchronization—Use this setting to enable auto synchronization of the location server. This ensures that when you make changes to WCS, the location server auto synchronizes with the changes.
- Interval (minutes)—Specify the auto synchronization interval.

Step 3 When finished, click Submit to confirm task changes or Cancel to return to the Administration > Background Tasks page with no changes made.

Viewing OSS Server Status

Follow these steps to view the OSS Server status:

Step 1 Choose Administration > Background Tasks to display the Background Tasks page.

Step 2 On this page, perform one of the following:
- Execute the task now.
  Select the OSS Server Status check box. From the Select a command drop-down list, choose Execute Now, and click Go. You see the status change in the Enabled column.
  or
- Enable the task.
  Select the OSS Server Status check box. From the Select a command drop-down list, choose Enable Task, and click Go. The task converts from grayed out to active in the Enabled column.
  or
- Disable the task.
  Select the OSS Server Status check box. From the Select a command drop-down list, choose Disable Task, and click Go. The task converts from grayed out to active in the Enabled column after the disabling is complete.

Step 3 To modify the controller license reset task, click the OSS Server Status link in the Background Tasks column. The OSS Server Status page appears.

Step 4 Click the background task in the Task column to open the task details page.

Step 5 The OSS Server Status page displays the following information:
- Last Execution Information
  - Start and end times
  - Elapsed time in seconds
  - Result—Success or error.
Performing Background Tasks

Step 6View or modify the following in the Edit Task group box:

- Description—Read-only. Displays the name of the task.
- Enabled—Select this check box to enable Cisco WCS execute the task at the specified interval.

**Note** If the Enabled check box is not selected, the task is not executed at the specified time.

- Interval—Indicates the frequency (in days) of the task.

Step 7When finished, click **Submit** to confirm task changes or **Cancel** to return to the Administration > Background Tasks page with no changes made.

Viewing Wireless Status

Wireless status polls:

- Global Dot11 adminStatus on the controller.
- Lightweight access point and radio admin and oper status.
- Radio profile threshold violations.

Choose **Administration > Background Tasks**, then click **Wireless Status** to access this page.

From the Administration > Background Tasks page, you can execute, enable, or disable this task. To execute, enable, or disable this task from the Administration > Background Tasks page, follow these steps:

Step 1 Choose **Administration > Background Tasks**.

Step 2 Select the check box(es) of the Background Task(s) that you want to execute, enable, or disable.

Step 3 Use the Select a command drop-down list to perform one of the following tasks:

- Execute the task now—Select the check box of the task you want to execute. From the Select a command drop-down list, choose **Execute Now**, and click **Go**. The status changes in the Enabled column.

  or

- Enable the task—Select the check box of the task you want to enable. From the Select a command drop-down list, choose **Enable Task**, and click **Go**.

  or

- Disable the task—Select the check box of the task you want to disable. From the Select a command drop-down list, choose **Disable Task**, and click **Go**.

To modify the task, follow these steps:

Step 1 Click the background task in the Task column to open the task details page.

The Wireless Status page displays the following information:

- Last Execution Information
Performing Background Tasks

Step 2 View or modify the following in the Edit Task pane:
- Description—Read-only. Displays the name of the task.
- Enabled—Select this check box to enable Cisco WCS execute the task at the specified interval.

**Note** If the Enabled check box is not selected, the task is not executed at the specified time.
- Interval (days)—Enter the frequency of backup.

Step 3 When finished, click **Submit** to confirm task changes or **Cancel** to return to the Administration > Background Tasks page with no changes made.

Performing WCS Server Backup

Choose **Administration > Background Tasks**, then click **WCS Server Backup** to access this page. This page enables you to schedule a backup of the WCS server.

From the Administration > Background Tasks page, you can execute, enable, or disable this task. To execute, enable, or disable this task from the Administration > Background Tasks page, follow these steps:

**Step 1** Choose **Administration > Background Tasks**.

**Step 2** Select the check box(es) of the Background Task(s) that you want to execute, enable, or disable.

**Step 3** Use the Select a command drop-down list to perform one of the following tasks:
- Execute the task now—Select the check box of the task you want to execute. From the Select a command drop-down list, choose **Execute Now**, and click **Go**. The status changes in the Enabled column.
  or
- Enable the task—Select the check box of the task you want to enable. From the Select a command drop-down list, choose **Enable Task**, and click **Go**.
  or
- Disable the task—Select the check box of the task you want to disable. From the Select a command drop-down list, choose **Disable Task**, and click **Go**.

To modify the task, follow these steps:

**Step 1** Click the background task in the Task column to open the task details page.

The WCS Server Backup page displays the following information:
- Last Execution Information
- Start and end times
- Elapsed time in seconds
- Result—Success or error.
- Message—Text message regarding the task execution.

**Step 2** View or modify the following in the Edit Task pane:

- **Description**—Read-only. Displays the name of the task.
- **Enabled**—Select this check box to enable Cisco WCS execute the task at the specified interval.

**Note** If the Enabled check box is not selected, the task is not executed at the specified time.

- **Report History Backup**—Select the check box to enable WCS to back up report histories.
- **Max Backups to Keep**—Enter the maximum number of WCS server backups to be kept on the backup server.
- **Interval (days)**—Enter a value between 1 and 360. The WCS server data is backed up every $n$ days, where $n$ is the value that you have specified in this field.
- **Time of the Day (hh:mm AM/PM)**—Enter the time at which the backup starts on the scheduled day.

**Note** Time of Day (hh:mm AM/PM) must be in this format: hh:mm AM/PM (for example: 03:00 AM). If no AM/PM notation is designated, the entered hour is always AM. If you want to specify 5PM, you could enter 17:00 or 5:00 PM. When the page is revisited after saving, the time is displayed as hh:mm (in this case 17:00), without the PM designation.
Performing Background Tasks

Table 16-3 lists and describes the other background tasks that are available in WCS:

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Default Schedule</th>
<th>Description</th>
<th>Editable Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuration Sync</td>
<td>Daily at 4 am.</td>
<td>This task is used to view the Configuration Synchronization.</td>
<td>Enable—Select or unselect this option to enable or disable Configuration Synchronization. Default: Enabled. Enable—Select or unselect this option to enable or disable Network Audit. Default: Enabled. Enable—Select or unselect this option to enable or disable Security Index calculation. Default: Enabled. Enable—Select or unselect this option to enable or disable RRM audit. Default: Enabled. Interval—Enter the interval in days that you would want the configuration synchronization to happen. Valid range: 1 to 360 days. Time of Day—Enter the time of the day at which you would want the configuration synchronization to happen. Valid format: hh:mm AM</td>
</tr>
<tr>
<td>Controller Configuration Backup</td>
<td>Daily at 10 pm</td>
<td>This task is used to view the Controller Configuration Backup activities.</td>
<td>Enable—Select or unselect this option to enable or disable Controller Configuration Backup. Default is Disabled. Interval—Enter the interval in days that you would want the configuration synchronization to happen. Valid range: 1 to 360 days. Time of Day—Enter the time of the day at which you would want the configuration synchronization to happen. Valid format: hh:mm AM</td>
</tr>
</tbody>
</table>
Table 16-3 Other Background Tasks (continued)

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Default Schedule</th>
<th>Description</th>
<th>Editable Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client Status</td>
<td>5 minutes.</td>
<td>This task is used to schedule the client status polling backups.</td>
<td>Enable—Select or unselect this option to enable or disable client status polling. Default is Enabled. Interval—Enter the interval in days that you would want the client status polling to happen. Valid range: 1 to 10080 minutes. For more information, see “Viewing Client Status” section on page 16-22.</td>
</tr>
<tr>
<td>Controller License Status</td>
<td>4 hours.</td>
<td>This task is used to schedule the license status polling.</td>
<td>Enable—Select or unselect this option to enable or disable license status polling. Default is Enabled. Interval—Enter the interval in days that you would want the license status polling to happen. Valid range: 1 to 360 days. For more information, see “Updating Controller License Status” section on page 16-23.</td>
</tr>
<tr>
<td>Data Cleanup</td>
<td>Daily at 2 am.</td>
<td>This task is used to schedule a data cleanup</td>
<td>Time of Day—Enter the time of the day at which you would want the data cleanup to happen. Valid format: hh:mm AM/PM. Example: 12:49 AM. Default is Enabled. For more information, see “Viewing Data Cleanup Status” section on page 16-25.</td>
</tr>
<tr>
<td>Device Data Collector</td>
<td>30 minutes</td>
<td>This task is used to schedule a data collection based on the specified CLI commands at a configured time interval.</td>
<td>Enabled—Select or unselect this option to enable or disable data collection for a specified Controller. Default is Disabled. Controller IP address—The IP address of the Controller to collect data from. CLI Commands—Enter the CLI commands separated by comma, which you would want to run on the specified Controller. Clean Start—Select or unselect this option to enable or disable a clean start before data collection. Repeat—Enter the number of times you would want the data collection to happen. Interval—Enter the interval in days that you would want the data collection to happen. Valid range: 1 to 360 days. For more information, see “Performing Device Data Collection” section on page 16-25.</td>
</tr>
</tbody>
</table>
### Table 16-3  
**Other Background Tasks (continued)**

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Default Schedule</th>
<th>Description</th>
<th>Editable Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device Status</td>
<td>5 minutes.</td>
<td>This task is used to view the history and current status of Cisco WLAN Solution device status tasks</td>
<td>Enable—Select or unselect this option to enable or disable Device status polling. Default is Disabled. <strong>Interval</strong>—Enter the interval in minutes that you would want the device polling to happen. Valid range: 1 to 10080 minutes. For more information, see “Viewing Device Status” section on page 16-26.</td>
</tr>
<tr>
<td>Guest Accounts Sync</td>
<td>Daily at 1 am.</td>
<td>This task is used to schedule Guest Account polling and synchronization.</td>
<td>Enable—Select or unselect this option to enable or disable guest account synchronization. Default is Enabled. <strong>Interval</strong>—Enter the interval in days that you would want the guest account synchronization to happen. Valid range: 1 to 360 days. <strong>Time of Day</strong>—Enter the time of the day at which you would want the guest account synchronization to happen. Valid format: hh:mm AM/PM. Example: 12:49 AM. For more information, see “Performing Guest Accounts Sync” section on page 16-27.</td>
</tr>
<tr>
<td>Mobility Service Backup</td>
<td>Every 7 days at 1 am.</td>
<td>This task is used to schedule mobility services backup polling.</td>
<td>Enable—Select or unselect this option to enable or disable mobility service backup. Default is disabled. <strong>Interval</strong>—Enter the interval in days that you would want the mobility services backup to happen. Valid range: 1 to 360 days. <strong>Time of Day</strong>—Enter the time of the day at which you would want the mobility services backup to happen. Valid format: hh:mm AM/PM. Example: 12:49 AM. For more information, see “Performing Mobility Service Backup” section on page 16-29.</td>
</tr>
<tr>
<td>Mobility Service Status</td>
<td>5 minutes.</td>
<td>This task is used to schedule mobility services status polling.</td>
<td>Enable—Select or unselect this option to enable or disable mobility services status polling. Default is Enabled. <strong>Interval</strong>—Enter the interval in days that you would want the mobility services status polling to happen. Valid range: 1 to 360 days. For more information, see “Viewing Mobility Service Status” section on page 16-30.</td>
</tr>
</tbody>
</table>
### Table 16-3 Other Background Tasks (continued)

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Default Schedule</th>
<th>Description</th>
<th>Editable Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mobility Service Synchronization</td>
<td>60 minutes.</td>
<td>This task is used to schedule mobility services synchronization.</td>
<td>Out of Sync Alerts—Select this option if you want to enable out of sync alerts.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Smart Synchronization—Select this option if you want to enable smart synchronization. Default is Enabled.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Interval—Enter the interval in minutes that you would want the mobility services synchronization to happen. Valid range: 1 to 10080 minutes.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>For more information, see “Performing Mobility Service Synchronization” section on page 16-31.</td>
</tr>
<tr>
<td>OSS Server Status</td>
<td>5 minutes.</td>
<td>This task is used to schedule OSS server status polling.</td>
<td>Enable—Select or unselect this option to enable or disable OSS Server polling. Default is Enabled.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Interval—Enter the interval in minutes that you would want the OSS server polling to happen. Valid range: 1 to 10080 minutes.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>For more information, see “Viewing OSS Server Status” section on page 16-32.</td>
</tr>
<tr>
<td>Wireless Status</td>
<td>5 minutes.</td>
<td>This task is used to schedule wireless devices status polling.</td>
<td>Enable—Select or unselect this option to enable or disable OSS Server polling. Default is Enabled.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Interval—Enter the interval in minutes that you would want the OSS server polling to happen. Valid range: 1 to 10080 minutes.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>For more information, see “Viewing OSS Server Status” section on page 16-32.</td>
</tr>
<tr>
<td>WCS Server Backup</td>
<td>Every 7 days at 1 am.</td>
<td>This task is used to schedule the WCS server backup.</td>
<td>Enable—Select or unselect this option to enable or disable WCS server backup. Default is Disabled.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Interval—Enter the interval in days that you would want the WCS server backup to happen. Valid range: 1 to 360 days.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Time of Day—Enter the time of the day at which you would want the WCS server backup to happen. Valid format: hh:mm AM</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>For more information, see “Viewing Wireless Status” section on page 16-33.</td>
</tr>
</tbody>
</table>
Importing Tasks Into ACS

To import tasks into Cisco Secure ACS server, you must add WCS to an ACS server (or non-Cisco ACS server). This section contains the following topics:

- Adding WCS to an ACS Server, page 16-40
- Adding WCS as a TACACS+ Server, page 16-41
- Adding WCS UserGroups into ACS for TACACS+, page 16-41
- Adding WCS to an ACS Server for Use with RADIUS, page 16-43
- Adding WCS UserGroups into ACS for RADIUS, page 16-44
- Adding WCS to a Non-Cisco ACS Server for Use with RADIUS, page 16-47

Adding WCS to an ACS Server

To add WCS to an ACS server, follow these steps:

**Note**
The instructions and illustrations in this section pertain to ACS version 4.1 and may vary slightly for other versions or other vendor types. See the CiscoSecure ACS documentation or the documentation for the vendor you are using.

**Step 1** Click Add Entry on the Network Configuration page of the ACS server (see Figure 16-7).

*Figure 16-7 ACS Server Network Configuration Page*

**Step 2** In the AAA Client Hostname text box, enter the WCS hostname.
Step 3  Enter the WCS IP address in the AAA Client IP Address text box.
Step 4  In the Key text box, enter the shared secret that you wish to configure on both the WCS and ACS servers.
Step 5  Choose TACACS+ from the Authenticate Using drop-down list.
Step 6  Click Submit + Apply.

Adding WCS as a TACACS+ Server

To add WCS to a TACACS+ server, follow these steps:

Step 1  Go to the TACACS+ (Cisco IOS) Interface Configuration page (see Figure 16-7).
Step 2  In the New Services portion of the page, add Wireless-WCS in the Service column heading.
Step 3  Enter HTTP in the Protocol column heading.

Note  HTTP must be in uppercase.

Step 4  Select the check box in front of these entries to enable the new service and protocol.
Step 5  Click Submit.

Adding WCS UserGroups into ACS for TACACS+

To add WCS UserGroups into an ACS Server for use with TACACS+ servers, follow these steps:

Step 1  Log into WCS.
Step 2  Choose Administration > AAA > Groups. The All Groups page appears (see Figure 16-8).
Chapter 16    Performing Administrative Tasks

Importing Tasks Into ACS

Step 3    Click the Task List link (the Export right-most column) of the User Group that you wish to add to ACS. The Export Task List page appears (see Figure 16-9).

Step 4    Highlight the text inside of the TACACS+ Custom Attributes, go to your browser’s menu, and choose Edit > Copy.

Step 5    Log in to ACS.

Step 6    Go to Group Setup. The Group Setup page appears (see Figure 16-10).
Figure 16-10   Group Setup Page on ACS Server

Step 7  Choose which group to use and click Edit Settings. Wireless-WCS HTTP appears in the TACACS+ setting.

Step 8  Use Edit > Paste in your browser to place the TACACS+ custom attributes from WCS into this text box.

Note  When you upgrade WCS, any permissions on the TACACS+ or RADIUS server must be readded.

Step 9  Select the check boxes to enable these attributes.

Step 10  Click Submit + Restart.

You can now associate ACS users with this ACS group.

Note  To enable TACACS+ in WCS, refer to the TACACS+. For information on configuring ACS view server credentials, see the “Configuring ACS View Server Credentials” section on page 9-221. For information on adding WCS Virtual Domains into ACS for TACACS+, see the “Virtual Domain RADIUS and TACACS+ Attributes” section on page 18-10.

Adding WCS to an ACS Server for Use with RADIUS

To add WCS to an ACS server for use with RADIUS servers, follow these steps:

1. If you have a non-Cisco ACS server, see the “Adding WCS to a Non-Cisco ACS Server for Use with RADIUS” section on page 16-47.
Step 1  Go to Network Configuration on the ACS server (see Figure 16-11).

Figure 16-11  Network Configuration Page on ACS Server

Step 2  Click Add Entry.
Step 3  In the AAA Client Hostname text box, enter the WCS hostname.
Step 4  In the AAA Client IP Address text box, enter the WCS IP address.
Step 5  In the Key text box, enter the shared secret that you wish to configure on both the WCS and ACS servers.
Step 6  Choose RADIUS (Cisco IOS/PIX 6.0) from the Authenticate Using drop-down list.
Step 7  Click Submit + Apply.
You can now associate ACS users with this ACS group.

Note  To enable RADIUS in WCS, see the “RADIUS” section on page 16-124. For information on configuring ACS view server credentials, see the “Configuring ACS View Server Credentials” section on page 9-221.

Adding WCS UserGroups into ACS for RADIUS

To add WCS UserGroups into an ACS Server for use with RADIUS servers, follow these steps:

Step 1  Log into WCS.
Step 2  Choose Administration > AAA > Groups. The All Groups page appears (see Figure 16-12).

**Figure 16-12  All Groups Page**

Step 3  Click the Task List link (the Export right-most column) of the User Group that you wish to add to ACS. The Export Task List page appears (see Figure 16-13).

**Figure 16-13  Export Task List Page**

Step 4  Highlight the text inside of the RADIUS Custom Attributes, go to your browser’s menu, and choose Edit > Copy.
When you upgrade WCS, any permissions on the TACACS+ or RADIUS server must be readded.

**Step 5**
Log in to ACS.

**Step 6**
Go to Group Setup. The Group Setup page appears (see Figure 16-14).

### Figure 16-14 Group Setup Page on ACS Server

**Step 7**
Choose which group to use and click **Edit Settings**. Find [009\001]cisco-av-pair under Cisco IOS/PIX 6.x RADIUS Attributes.

**Step 8**
Use Edit > Paste in your browser to place the TACACS+ custom attributes from WCS into this text box.

When you upgrade WCS, any permissions on the TACACS+ or RADIUS server must be readded.

**Step 9**
Click the check boxes to enable these attributes.

**Step 10**
Click **Submit + Restart**.

You can now associate ACS users with this ACS group.

When you upgrade WCS, any permissions on the TACACS+ or RADIUS server must be readded.

**Note** To enable RADIUS in WCS, see the “RADIUS” section on page 16-124. For information on configuring ACS view server credentials, see the “Configuring ACS View Server Credentials” section on page 9-221.
Adding WCS to a Non-Cisco ACS Server for Use with RADIUS

When you use a RADIUS server to log into WCS, the AAA server sends back an access=accept message with a user group and a list of available tasks, after the username and password were verified. The access=accept message comes back as a fragmented packet because of the large number of tasks in some user groups. You can look in the following file to see the tasks associated with a given user group: C:\Program Files\WCS5.0\webnms\webacs\WEB-INF\security\usergroup-map.xml. The tasks are passed back as a vendor specific attribute (VSA), and WCS requires authorization information using the VSA (IETF RADIUS attribute number 26). The VSA contains the WCS RADIUS task list information (see Figure 16-15).

Figure 16-15 Extracting Task List

<table>
<thead>
<tr>
<th>Type</th>
<th>Length</th>
<th>Vendor-Id</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vendor-Id (cont.)</td>
<td>Vendor-type</td>
<td>Vendor-length</td>
</tr>
</tbody>
</table>

The content of the VSA is as follows:
- Type = 26 (IETF VSA number)
- Vendor Id = 9 (Cisco vendor ID)
- Vendor Type = 1 (Custom attributes)
- Vendor Data = The WCS task information (for example Wireless-WCS: task0 = Users and Group)

Each line from the WCS RADIUS task list should be sent in its own RADIUS VSA.

In the data portion of the access=accept packet, the truncated output sometimes shows only one role sent back for an Admin user group login. The tasks associated with the role start with task0 and increment with task1, task2, and so on. Table 16-4 defines what these attributes in the access=accept packet example signify.

```
0000 06 6d 0e 59 07 3d 6a 24 02 47 07 35 d2 12 a4 eb m.Y.=j$G.5...
0010 a2 5a fa 84 38 20 e4 e2 3a 3a bc e5 1a 20 00 00 Z...:
0020 00 09 01 1a 57 69 72 65 6c 65 73 73 2d 57 43 53 ....Wireless-WCS
0030 3a 72 6f 6c 65 30 3d 41 64 69 74 20 54 72 61 69 6c 73 xx task0=Admin.*
0040 00 09 01 25 57 69 72 65 6c 65 73 73 2d 57 43 53 ...%Wireless-WCS
0050 3a 74 61 73 6b 30 3d 55 73 65 72 73 20 61 6e 64 :task0=Users and
0060 20 47 72 6f 75 70 73 1a 27 00 00 00 09 01 21 57 Groups.*...!W
0070 69 72 65 6c 65 73 73 2d 57 43 53 3a 74 61 73 6b Wireless-WCS:task
0080 31 3d 41 75 64 69 74 70 54 72 61 69 6c 73 xx xx 1=Audit Trails.*
```
To troubleshoot, perform the following steps:

- Verify if the RADIUS packet is an access accept.
- Verify the task names for the user group in the access accept.
- Look at the different length fields in the RADIUS packet.

## Configuring Auto Provisioning

This section contains the following topics:

- Adding an Auto Provisioning Filter, page 16-48
- Editing an Auto Provisioning Filter, page 16-52
- Deleting Auto Provisioning Filter(s), page 16-52
- Listing Auto Provisioning Filter(s) Device Info, page 16-53
- Exporting Auto Provisioning Filter(s), page 16-54
- Exporting All Auto Provisioning Filter(s), page 16-55
- Auto Provisioning Primary Search Key Settings, page 16-55

### Adding an Auto Provisioning Filter

To add an Auto Provisioning Filter, follow these steps:

**Step 1** Choose **Configure > Auto Provisioning**. The Auto Provisioning Filter List page appears (see Figure 16-16).
Step 2  From the Select a command drop-down list, choose **Add Filter**.

Step 3  Click **Go**.

Step 4  Click **Go**. The Auto Provisioning Filters > New Filter page appears (see Figure 16-17).

**Figure 16-17  Auto Provisioning Filters > New Filter**

Step 5  Configure the following information:

- General
  - **Enable Filter**—Select the check box to enable the new filter.
Chapter 16  Performing Administrative Tasks

Configuring Auto Provisioning

Note Only enabled filters can participate in the Auto Provisioning process.

- Filter Name—Enter a filter name.

- Filter Properties
  - Monitor Only—If selected, the WLC defined in this Filter is managed by WCS but not configured by WCS if the WLC contacts WCS during the auto provisioning process.
  - Filter Mode—From the drop-down list, choose **Host Name, MAC Address, Serial Number** to indicate the search mode for this filter.
  - Config Group Name—From the drop-down list, choose a config group name.

- Filter Member Management - Add Member
  - Input Type—From the drop-down list, choose **Single Device** or **CSV File**.
    If Single Device is selected, enter the host name, enable LAG configuration (if applicable), and enter the following: management interface IP Address, management interface netmask, management interface gateway, AP manager interface IP address, AP manager interface netmask, AP manager interface gateway, and DHCP IP address.
    If CSV File is selected, enter the CSV file or use the **Browse** button to navigate to the applicable CSV File.

Note You can choose the **Download a sample CSV File** link to download a sample CSV file to your computer and customize the various configurations.

Note Because MS-Excel can insert additional commas when you edit a CSV file, ensure that you edit the CSV file using a normal text editor application.

A CSV file contains the following sections:

**The first part is the General Config section that contains parameters which are used to construct controller's startup config file.**

**The first line in the CSV file must be keyword**

"!!deviceId, LAG, managementIP, managementVlanId, managementNetmask, managementGateway, apManagerIP, apManagerVlanId, apManagerNetmask, apManagerGateway, dhcpServerIP, virtualIPAddress"

devicId—it can be Host name, Mac address, or Serial number.
LAG—controller's LAG configuration (true/false).
managementIP—controller's Management interface IP address.
managementVlanId—controller's Management interface VLAN Id (0=untagged).
managementNetmask—controller's Management interface Network mask.
managementGateway—controller's Management interface Gateway IP.
apManagerIP—controller's AP Manager Interface IP address, optional for 5500 series controller.
apManagerVlanId—controller's AP Manager Interface VLAN Id (0=untagged), optional for 5500 series controller.
apManagerNetmask—controller's AP Manager Interface Netmask, optional for 5500 series controller.
apManagerGateway—controller's AP Manager Interface Gateway, optional for 5500 series controller.
Configuring Auto Provisioning

dhcpServerIP—controller’s DHCP IP address.
virtualIPAddress—controller’s Virtual IP address.

** The second part is the Dynamic Interface section that contains dynamic interface parameters for a controller. This is an optional section.
** To configure a dynamic interface, the first eight parameters are mandatory and the last four parameters are optional.
"!!deviceId, interfaceName, vlanId, quarantineVlanId, interfaceIP, interfaceNetmask, gateway, primaryPort, secondaryPort, primaryDHCP, secondaryDHCP, aclName"
deviceId—this deviceId must be defined previously in section 1.
interfaceName—name of the dynamic interface.
vlanId—vlan ID used by this interface.
quarantineVlanId—quarantine vlan ID used by this interface.
interfaceIP—IP address of the dynamic interface.
gateway—Gateway IP address of the dynamic interface.
primaryPort—physical primary port number used by the dynamic interface.
secondaryPort—physical secondary port number used by the dynamic interface, this is an optional parameter.
primaryDHCP—the IP address of the primary DHCP used by the dynamic interface, this is an optional parameter.
secondaryDHCP—IP address of the secondary DHCP used by the dynamic interface, this is an optional parameter.

** The third part is the Device Specific Config section, contains other device specific configuration parameters which are optional during auto provisioning.
"!!deviceId, countryCode, mobilityGroupName, mobilityGroupMembers"
deviceId—this deviceId must be defined previously in section 1.
countryCode—country code for the controller, this is an optional parameter.
mobilityGroupName—default name of the mobility group this controller belongs to, this is an optional parameter. If this attribute is not specified then the existing default mobility group name will be used.
mobilityGroupMembers—IP addresses, Mac Addresses and mobility group name of the mobility group members of the controller, which are separated by semi colon, this is an optional parameter. Both IP address and Mac Address are required for a mobility group member, they are separated by forward slash. Mobility group name is an optional attribute in this field. If mobility group name is not present then the default mobility group name for this controller will be used.

- If you select the Single Device option, specify the following options:
  - Device Type—From the drop-down list, choose 5500 Controller or non-5500 Controller.
  - Host Name
  - LAG Configuration: Enabled or Disabled.
  - Management Interface IP Address
  - Management Interface Netmask
  - Management Interface Gateway
  - AP Manager Interface IP Address
  - AP Manager Interface Netmask
  - AP Manager Interface Gateway
Configuring Auto Provisioning

- **DHCP IP Address**—When the controller comes up after a reset, it uses this IP address to get a DHCP address, and identifies its TFTP server from where the configuration file needs to be picked.
- **Virtual IP Address**—An address which is not routable and usually configured as 209.165.200.227 as a DHCP server at the virtual IP address to wireless clients.

**Step 6** Click **Submit**.

**Note** You can specify the Dynamic Interface configuration and Device Specific configuration details only when you input a CSV file. These two configurations cannot be performed using the GUI.

Editing an Auto Provisioning Filter

To edit an Auto Provisioning filter, follow these steps:

**Step 1** Choose **Configure > Auto Provisioning**.
**Step 2** Click the Filter Name of the filter you want to edit.
**Step 3** Make the necessary changes to the current filter parameters.

**Note** To view detailed information for a filter member, click the **Device ID** of the member you want to view.
To delete a filter member, select the check box for the member you want to delete in the Filter Member Management - Delete Member section. When you click **Submit**, that member is deleted.

**Step 4** Click **Submit**.

Deleting Auto Provisioning Filter(s)

To delete an Auto Provisioning Filter, follow these steps:

**Step 1** Choose **Configure > Auto Provisioning**.
**Step 2** Select the check box of the filter you want to delete.
**Step 3** From the Select a command drop-down list, choose **Delete Filter(s)**.
**Step 4** Click **Go**.
**Step 5** Click **OK** to confirm the deletion.
Listing Auto Provisioning Filter(s) Device Info

To view details for an individual Auto Provisioning Filter, follow these steps:

**Step 1** Choose Configure > Auto Provisioning.

**Step 2** Select the check box of the filter you want to view.

**Step 3** From the Select a command drop-down list, choose List Filter(s) Device Info.

**Step 4** Click Go. The Detailed Auto Provisioning Device Information page appears (see Figure 16-18).

**Figure 16-18 Detailed Auto Provisioning Device Information**

The following information is provided for the selected filter:

- **Filter Name**—Indicates the filter name.
- **Device ID**—Indicates the device ID.
- **LAG**—Indicates the controller LAG status as true or false.
- **Management IP**—Indicates the management interface IP address of the controller.
- **Management VlanId**—Indicates the management VLAN Id of the controller.
- **Management Netmask**—Indicates the netmask mask of the management interface of the controller.
- **Management Gateway**—Indicates the gateway IP address of the management interface of the controller.
- **AP Mgr IP**—Indicates the IP address of the access point manager.
- **AP Mgr Vlan Id**—Indicates the VLAN identifier of the access point manager.
- **AP Mgr Netmask**—Indicates the netmask mask of the access point manager.
- **AP Mgr Gateway**—Indicates the gateway IP address of the access point manager.
- **Status**—Idle, Trap Received, Failed In Trap Processing, Failed In Applying Templates, Failed In Discovery Switch, Managed, Managed partially applied templates, or Unknown Error.
- **Country**—Indicates the country.
• Mobility Grp—Indicates the name of the mobility group.
• Mobility Grp Members—Indicates the members of the mobility group.
• Timestamp—Indicates the date and time of the information.

Listing All Auto Provisioning Filter(s) Device Info

To view details for all Auto Provisioning Filters, follow these steps:

Step 1  Choose Configure > Auto Provisioning.
Step 2  From the Select a command drop-down list, choose List All Filter(s) Device Info.
Step 3  Click Go.

The following information is provided for the selected filter:
• Filter Name—Indicates the filter name.
• Device ID—Indicates the device ID.
• LAG—Indicates the controller LAG status as true or false.
• Management IP—Indicates the management interface IP address of the controller.
• Management VlanId—Indicates the management Vlan Id of the controller.
• Management Netmask—Indicates the netmask mask of the management interface of the controller.
• Management Gateway—Indicates the netmask gateway of the management interface of the controller.
• AP Mgr IP—Indicates the IP address of the access point manager.
• AP Mgr Vlan Id—Indicates the Vlan identifier of the access point manager.
• AP Mgr Netmask—Indicates the netmask mask of the access point manager.
• AP Mgr Gateway—Indicates the gateway IP address of the access point manager.
• Status—Idle, Trap Received, Failed In Trap Processing, Failed In Applying Templates, Failed In Discovery Switch, Managed, Managed partially applied templates, or Unknown Error.
• Country—Indicates the country.
• Mobility Grp—Indicates the name of the mobility group.
• Mobility Grp Members—Indicates the members of the mobility group.
• Timestamp—Indicates the date and time of the information.

Exporting Auto Provisioning Filter(s)

To export an Auto Provisioning Filter, follow these steps:

Step 1  Choose Configure > Auto Provisioning.
Step 2  Select the check box of the filter(s) you want to export.
Step 3 From the Select a command drop-down list, choose **Export Filter(s) Config (CSV)**.

Step 4 Click **Go**.

Step 5 In the File Download dialog box that appears, click **Save** to save the file to a location on the computer.

---

**Exporting All Auto Provisioning Filter(s)**

To export all Auto Provisioning Filters, follow these steps:

---

Step 1 Choose **Configure > Auto Provisioning**.

Step 2 From the Select a command drop-down list, choose **Export All Filter(s) Config (CSV)**.

Step 3 Click **Go**.

Step 4 In the File Download dialog box that appears, click **Save** to save the file to a location on the computer.

---

**Auto Provisioning Primary Search Key Settings**

The Primary Search Key Setting enables you to set the matching criteria search order.

To indicate the Search Key Order, follow these steps:

---

Step 1 Choose **Configure > Auto Provisioning**.

Step 2 From the left sidebar menu, choose **Auto Provisioning Setting**.

Step 3 Click to highlight the applicable search key.

Step 4 Use the Move Up or Move Down buttons to move the search key to a higher or lower priority.

Step 5 Click **Save** to confirm or **Cancel** to cancel the changes.

---

**Establishing Logging Options**

Choose **Administration > Logging** to access the Administer Logging Options page. The logging for controller syslog information can be done in the **Controller > Management > Syslog page**. The following log settings can be configured:

- General Logging Options, page 16-56
- SNMP Logging Options, page 16-58
- Syslog Options, page 16-58
General Logging Options

To enable e-mail logging, follow these steps. The settings you establish are stored and are used by the e-mail server.

**Step 1** Choose **Administration > Logging**. The General Logging Options page appears (see Figure 16-19).

**Step 2** Choose **General Logging Options** from the left sidebar menu.

**Step 3** Choose a message level option of **Trace**, **Information**, or **Error**.

**Step 4** Select the check boxes within the Enable Log Module portion of the page to enable various administration modules:

- **Message Level**—Choose the minimum level of the messages that will be logged including **Error**, **Information**, or **Trace**.

- **Enable Log Module**—You can enable logging for the following administration modules:
  - **Configuration**—Used to log controller configurations that you make from WCS.
  - **Monitor**—Used for Alarms, Spectrum Intelligence, CCXV5, Clients/Tags, Client Radio Measurements, SSO, and Mesh.
  - **Fault Analysis**—Used by the event and alert subsystem.
  - **General**—Contains logs that do not fall under other log module categories.
  - **Note** To get complete controller configuration logs, also enable the General log module.
  - **Note** To get the configuration values that the WCS sends in logs to controllers, enable Trace Display Values (Administration > Settings > SNMP Settings > Trace Display Value).

- **Log File Settings**
  - **Message level**
    - **Configuration**
    - **Monitor**
    - **Fault Analysis**
    - **General**
    - **Navigator**
    - **Reports**
    - **Database Administration**
    - **Administration**
    - **Telemetry**
    - **Mobility Services Engine**
    - **SOAP Communication**

- **Log File Settings**
  - **Number of files**
  - **File prefix**
  - **Log file size**
  - **Log file rotation**
  - **Log file retention**

- **Download Log File**
  - **Download Log File**

- **Email Log File**
  - **Email server is not configured. Go to Administration > Settings > Mail Server Configuration to configure one.**
Chapter 16      Performing Administrative Tasks

Establishing Logging Options

Note: We recommend that you enable this log module.

- Navigator—Contains logs to debug issues when WCS does not respond to WCS Navigator’s periodic polling through the Northbound Webservice API.
- Reports—Used to log messages related to creating, saving, scheduling, and running reports. This module also contains a list of scheduled and saved reports.
- Database Administration—Contains logs to debug important database-related operations in WCS.

Note: Some functions should be used only for short periods of time during debugging so that the performance is not degraded. For example, trace mode and SNMP mediation should be enabled only during debugging because a lot of log information is generated.

- Communication Protocol—Contains logs related to the protocols used in communication.
- UI General—Contains generic UI validation logs.
- Administration—Contains Administration based logs, where all the configuration changes performed using the administration console is logged.
- Tools—Contains logs related to different plug-in tools.
- MSE—Used for MSE-related operations such as adding or deleting an MSE and changing parameters on the MSE. It also enables logging for MSE synchronization including NW designs and controllers.
- SOAP Communication—Contains logs that contain the SOAP header messages.

Step 5: In the Log File Settings portion, enter the following settings. These settings will be effective after restarting WCS.

- Max. file size—Maximum number of MBs allowed per log file.
- Number of files—Maximum number of log files allowed.
- File prefix—Log file prefix, which can include the characters “%g” to sequentially number of files.

Step 6: Click the Download button to download the Log File to your local machine.

Note: The logs.zip filename includes a prefix with the host name, date, and time so that you can easily identify the stored log file. Included in the zip file is an html file that documents the log files.

Step 7: Enter the Email ID or Email IDs separated by commas to send the Log file.

Note: To send the log file in a mail you must have Email Server Configured.

Step 8: Click Submit.
SNMP Logging Options

To enable SNMP Tracing, follow these steps. The settings you establish are stored and are used by the SNMP server.

**Note**  
SNMP server is nothing but the WCS server which uses these settings for SNMP logging.

**Step 1**  
Choose Administration > Logging. The General Logging Options page appears (see Figure 16-20).

**Step 2**  
Choose SNMP Logging Options from the left sidebar menu.

**Figure 16-20**  
SNMP Logging Options

**Step 3**  
Select the Enable SNMP Trace check box to enable sending SNMP messages (along with traps) between controller and WCS.

**Step 4**  
Select the Display Values check box to see the SNMP Message values.

**Step 5**  
Configure the IP address or IP addresses to trace the SNMP traps. You can add up to a maximum of 10 IP addresses in the text box.

**Step 6**  
You can configure the maximum SNMP file size and the number of SNMP files.

### Syslog Options

The Syslog protocol is simply designed to transport event messages from the generating device to the collector. Various devices generate syslog messages for system information and alerts. To configure Syslog for WCS, follow these steps:

**Step 1**  
Choose Administration > Logging. The General Logging Options page appears (see Figure 16-19).

**Step 2**  
From the left sidebar menu, choose the Syslog Options.
Chapter 16      Performing Administrative Tasks

Establishing Logging Options

Step 3  Select the **Enable Syslog** check box to enable collecting and processing system logs.

Step 4  Configure the Syslog Server IP address of the interface from which the message is to be transmitted.

Step 5  Choose the Syslog Facility. You can choose any of the eight local use facilities for sending syslog messages. The local use facilities are not reserved and are available for general use.

Using Logging Options to Enhance Troubleshooting

The logging screen allows you to customize the amount of data WCS collects to debug an issue. For easily reproduced issues, follow these steps prior to contacting TAC. To create a smoother troubleshooting session, follow these steps:

Step 1  Choose **Administration > Logging**.

Step 2  From the Message Level drop-down list, choose **Trace**.

Step 3  Select each check box to enable all log modules.

Step 4  Reproduce the current problem.

Step 5  Return to the Logging Options page.

Step 6  Click **Download** from the Download Log File section.

**Note**  The logs.zip filename includes a prefix with the host name, date, and time so that you can easily identify the stored log file. Included in the zip file is an html file that documents the log files.

Step 7  After you have retrieved the logs, choose **Information** from the Message Level drop-down list.

**Note**  Leaving the Message Level at **Trace** can adversely affect performance over a long period of time.
Configuring Administrative Settings

The Settings page contains options for managing the WCS data retention functions. This section describes the available settings and contains the following topics:

- Configuring Alarms, page 16-60
- Configuring an Audit, page 16-62
- Configuring Clients, page 16-64
- Configuring Protocols for CLI Sessions, page 16-67
- Configuring Controller Upgrade, page 16-67
- Configuring Data Management, page 16-69
- Configuring a Guest Account, page 16-70
- Configuring Login Disclaimer, page 16-71
- Configuring the Mail Server, page 16-71
- Configuring the Notification Receiver, page 16-73
- Setting Report, page 16-78
- Configuring Server Settings, page 16-79
- Severity Configurations, page 16-80
- SNMP Credentials, page 16-82
- SNMP Settings, page 16-86
- Switch Port Tracing, page 16-88

Configuring Alarms

This Alarms page enables you to handle old alarms and display assigned and acknowledged alarms in the Alarm Summary page.

To open this page, follow these steps:

**Step 1** Choose Administration > Settings.

**Step 2** From the left sidebar menu, choose Alarms. The Administration > Settings > Alarms page appears (see Figure 16-22).
Step 3  Add or modify the following Alarms parameters:

- **Alarm Cleanup Options**
  - Delete active and cleared alarms after—Enter the number of days after which active and cleared alarms are deleted. This option can be disabled by unselecting the check box.
  - Delete cleared security alarms after—Enter the number of days after which Security, Rogue AP, and Adhoc Rogue alarms are deleted.
  - Delete cleared non-security alarms after—Enter the number of days after which non-security alarms are deleted. Non-security alarms include all alarms that do not fall under the Security, Rogue AP, or Adhoc Rogue categories.

**Note** Data cleanup tasks run nightly to delete old alarms. In addition to the data cleanup task, WCS has an hourly task to check alarm table size. When the alarm table size exceeds 300 K, the task deletes the oldest cleared alarms until the alarm table size is within 300 K.
• Alarm Display Options

Note These preferences only apply to the Alarm Summary page. Quick searches or alarms for any entity display all alarms regardless of the acknowledged or assigned state.

- Hide acknowledged alarms—When the check box is selected, Acknowledged alarms do not appear in the Alarm Summary page. This option is enabled by default.

Note E-mails are not generated for acknowledged alarms regardless of severity change.

- Hide assigned alarms—When the check box is selected, assigned alarms do not appear in the Alarm Summary page.

- Add controller name to alarm messages—Select the check box to add the name of the controller to alarm messages.

- Add WCS address to email notifications—Select the check box to add the WCS address to email notifications.

• Alarm Email Options

- Include alarm severity in the email subject line—Select the check box to include alarm severity in the email subject line.

- Include alarm Category in the email subject line—Select the check box to include alarm category in the email subject line.

- Include prior alarm severity in the email subject line—Select the check box to include prior alarm severity in the email subject line.

- Include custom text in the email subject line—Select the check box to add custom text in the email subject line. You can also replace the email subject line with custom text by selecting the Replace the email subject line with custom text check box.

- Include custom text in body of email—Select the check box to add custom text in the body of email.

- Include alarm condition in body of email—Select the check box to include alarm condition in the body of email.

- Add link to Alarm detail page in body of email—Select the check box to add a link to the Alarm detail page in the body of email.

- Enable Secure Message Mode—Select the check box to enable a secure message mode. If you select the Mask IP Address and Mask Controller Name check boxes, the alarm emails are sent in secure mode where all the IP addresses and controller names are masked.

Step 4 Click Save.

Configuring an Audit

The Settings > Audit page allows you to determine the type of audit and on which parameters the audit is performed.

• Audit Mode—Choose between basic auditing and template based auditing.
Audit Mode

The audit mode section allows you to choose between basic auditing and template-based auditing. Basic audit is selected by default.

- **Basic Audit**—Audits the configuration objects in the WCS database against current WLC device values. Prior to the 5.1.0.0 version of WCS, this was the only audit mode available.

  **Note**
  Configuration objects refer to the device configuration stored in the WCS database.

- **Template-based Audit**—Audits on the applied templates, config group templates (which have been selected for the background audit), and configuration audits (for which corresponding templates do not exist) against current WLC device values.

To indicate the type of audit you want to perform, follow these steps:

**Step 1** Choose **Administration > Settings**.

**Step 2** From the left sidebar menu, choose **Audit**. The Audit page appears (see **Figure 16-23**).

**Step 3** Select the **Basic Audit** or **Template based Audit** radio button. A basic audit audits the device configuration in the WCS database against the current WLC configuration. A template-based audit audits the applied templates, config group templates, and configuration objects (for which corresponding templates do not exist) against current WLC configuration.

**Step 4** Choose if you want the audit to run on all parameters or only on selected parameters. If you select the Selected Parameters radio button, you can access the Configure Audit Parameters configuration page. (See the “Configuring Audit Parameters” section on page 16-64). The Select audit parameters URL appears.
The selected audit parameters are used during network and controller audits.

**Step 5**  
Click **Save**.

---

**Note**  
These settings are in effect when the controller audit or network audit is performed.

---

### Audit On

The Audit On option allows you to audit all parameters or to select specific parameters for an audit. When the Selected Parameters radio button is selected, you can access the Select Audit Parameters configuration page.

The selected audit parameters are used during network and controller audits.

### Configuring Audit Parameters

To configure the audit parameters for a global audit, follow these steps:

**Step 1**  
Choose *Administration > Settings*.

**Step 2**  
From the left sidebar menu, choose *Audit*.

**Step 3**  
Select the *Selected Parameters* radio button to display the Select Audit Parameters link.

**Step 4**  
Click **Save**.

**Step 5**  
Click **Select Audit Parameters** to choose the required parameters for the audit in the Audit Configuration > Parameter Selection page.

**Step 6**  
Select the parameters that you want audited from each of the tabs. The tabs include System, WLAN, Security, Wireless, and Selected Attributes.

**Step 7**  
When all desired audit parameters are selected, click **Submit** to confirm the parameters or click **Cancel** to close the page without saving any audit parameters.

Once you click **Submit**, the selected audit parameters display under the Selected Attributes tab.

A current Controller Audit Report can be accessed from the Configure > Controllers page by selecting an object from the Audit Status column.

---

**Note**  
You can audit a controller by choosing **Audit Now** from the Select a command drop-down list in the Configure > Controllers page, or by clicking **Audit Now** directly from the Controller Audit report. See the “Viewing Audit Status (for Access Points)” section on page 9-186.

---

### Configuring Clients

The client processes are configurable to improve WCS performance and scalability. This section contains the following topics:

- Processing Diagnostic Trap, page 16-65
• Host Name Lookup, page 16-66
• Data Retention, page 16-66
• Client Traps, page 16-67

To confirm changes to these client configurations, click Save at the bottom of the page.

Note See the “Client Troubleshooting” section on page 10-21 for further information on client troubleshooting.

Processing Diagnostic Trap

The Settings > Client page allows you to enable automatic client troubleshooting on a diagnostic channel.

Note Automatic client troubleshooting is only available for a CCXV5 client.

To enable this automatic client troubleshooting, follow these steps:

Step 1 Choose Administration > Settings.

Step 2 From the left sidebar menu, choose Client. The Client page appears (see Figure 16-24).

Figure 16-24 Administration > Settings > Client Page

Step 3 Select the Automatically troubleshoot client on diagnostic channel check box.

Note If the check box is selected, WCS processes the diagnostic association trap. If it is not selected, WCS raises the trap, but automated troubleshooting is not initiated.
Note
While processing the diagnostic association trap, the WCS invokes a series of tests on the client. The client is updated on all completed tasks. The automated troubleshooting report is placed in dist/acs/win/webnms/logs. When the test is complete, the location of the log is updated in client details pages:V5 tab:Automated Troubleshooting Report section. An export button allows you to export the logs.

Step 4 Click **Save**.

### Host Name Lookup

DNS lookup can take a considerable amount of time. Because of this, you can enable or disable the DNS lookup for client host name. It is set to Disable by default.

To enable host name lookup, follow these steps:

**Step 1** Choose **Administration > Settings**.

**Step 2** From the left sidebar menu, choose **Client**.

**Step 3** Select the **Lookup client host names from DNS server** check box.

**Step 4** Enter the number of days that you want the host name to remain in the cache.

**Step 5** Click **Save**.

### Data Retention

Client association history can take a lot of database and disk space. This can be an issue for database backup and restore functions. The retaining duration of a client association history can be configured to help manage this potential issue.

To configure data retention parameters, follow these steps:

**Step 1** Choose **Administration > Settings**.

**Step 2** From the left sidebar menu, choose **Client**.

**Step 3** Enter or edit the following data retention parameters:

- **Client (days)**—Enter the number of days that you want WCS to retain the data. The default is 7 days. The valid range is 1 to 365 days.
- **Client (records)**—Enter the number of client records that you want WCS to retain.
- **Client session history (days)**—The default is 31 days. The maximum is 365 days.
- **Client session history (records)**—The default (and maximum recommended) is 1 million records.

**Step 4** Click **Save**.
Client Traps

In some deployments, WCS may receive large amounts of client association and disassociation traps. Saving these traps as events may cause a slight performance issue. In such cases, other events that may be useful may be aged out sooner than expected.

To ensure that WCS does not save client association and disassociation traps as events, unselect the **Save client association and disassociation traps as events** check box. Click **Save** to confirm this configuration change. This option is disabled by default.

If you select the **Poll clients when client traps received** check box, WCS polls clients to quickly identify client sessions. In a busy network, you may want to disable polling while the client traps are received.

Configuring Protocols for CLI Sessions

Many WCS features such as autonomous access point and controller CLI templates, along with migration templates require executing CLI commands on the autonomous access point or controller. These CLI commands can be executed by establishing telnet or SSH sessions. The CLI session page allows you to select the session protocol. SSH is the default.

**Note**  
In CLI templates, you are not required to answer the question responses (such as *Yes* or *No* answer to a command, *Press enter to continue*, and so on). This is automatically performed by WCS.

To configure the protocols for CLI sessions, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Choose <em>Administration &gt; Settings</em>.</td>
</tr>
<tr>
<td>Step 2</td>
<td>From the left sidebar menu, choose <em>CLI Session</em>.</td>
</tr>
<tr>
<td>Step 3</td>
<td>The default controller session protocol SSH is selected. To choose Telnet, select that radio button.</td>
</tr>
<tr>
<td>Step 4</td>
<td>The default autonomous access point session protocol SSH is selected. To choose Telnet, select the radio button.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Click <strong>Save</strong>.</td>
</tr>
</tbody>
</table>

Configuring Controller Upgrade

The Controller Upgrade Settings page allows you to auto-refresh after a controller upgrade. To perform an auto-refresh, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Choose <em>Administration &gt; Settings</em>.</td>
</tr>
<tr>
<td>Step 2</td>
<td>From the left sidebar menu, choose <em>Controller Upgrade Settings</em> (see Figure 16-25).</td>
</tr>
</tbody>
</table>
Configuring Administrative Settings

Step 3  Select the **Auto refresh After Upgrade** check box to automatically restore the configuration whenever there is a change in the WLC image.

Step 4  Determine the action WCS will take when a save config trap is received. When this option is enabled, you can choose to retain or delete the extra configurations present on the device but not on WCS. The setting is applied to all controllers managed by WCS.

**Note**  If you select the Auto Refresh on Save Config Trap check box in the Configure > Controllers > Properties > Settings page, it overrides this global setting.

**Note**  It may take up to three minutes for the automatic refresh to occur.

Step 5  Click **Save**.

Whenever a save config trap is received by WCS this option when enabled will determine the action taken by WCS.

When this option is enabled user can choose to retain or delete the extra configurations present on device and not on WCS.

This setting will be applied to all of the controllers managed by WCS. The setting in the controller > properties page for processing the save config trap will override this global setting.

When there is a change in the WLC image, the configuration from the controller is automatically restored.
Configuring Data Management

To set retention periods for aggregated data used in timed calculations and network audit calculations, follow these steps. You can configure retention periods on an hourly, daily, and weekly basis.

**Step 1** Choose Administration > Settings.

**Step 2** From the left sidebar menu, choose Data Management. The Data Management page appears (see Figure 16-26).

**Figure 16-26 Data Management Page**

**Step 3** Specify the number of days to keep the hourly data. The valid range is 1 to 31. The default is 31 days.

**Step 4** Specify the number of days to keep the daily data. The valid range is 7 to 365. The default is 90 days.

**Step 5** Specify the number of weeks to keep the weekly data. The valid range is 2 to 108. The default is 54 weeks.

**Step 6** Specify the number of days to retain the audit data collected by the Network Audit background task before purging. The limit is 365 days, and the minimum cleanup interval is 7 days. The default is 90 days.

**Note** For the best interactive graph data views, change the default settings to the maximum possible: 90 days for daily aggregated data and 54 weeks for weekly aggregated data. You must also make the appropriate measures to increase RAM and CPU capacity to compensate for these adjustments.

**Step 7** Click Save.

WCS Historical Data

There are two types of historical data in WCS:

- Aggregated historical data—Numeric data that can be gathered as a whole and aggregated to minimum, maximum, or average. Client count is one example of aggregated historical data.

Use the Administration > Settings > Data Management page to define the aggregated data retention period. Aggregation types include hourly, daily, and weekly.
The retention period for these aggregation types are defined as Default, Minimum, and Maximum (see Table 16-5).

### Table 16-5  Aggregated Data Retention Periods

<table>
<thead>
<tr>
<th>Aggregated Data</th>
<th>Default</th>
<th>Minimum</th>
<th>Maximum</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hourly</td>
<td>31 days</td>
<td>1 day</td>
<td>31 days</td>
</tr>
<tr>
<td>Daily</td>
<td>90 days</td>
<td>7 days</td>
<td>365 days</td>
</tr>
<tr>
<td>Weekly</td>
<td>54 weeks</td>
<td>2 weeks</td>
<td>108 weeks</td>
</tr>
</tbody>
</table>

- Non-aggregated historical data—Numeric data that cannot be gathered as a whole (or aggregated). Client association history is one example of non-aggregated historical data.
  
  You can define a non-aggregated retention period in each data collection task and other settings. For example, you define the retention period for client association history in Administration > Settings > Client. By default, the retention period is 31 days or 1 million records. This retention period can be increased to 365 days.

### Configuring a Guest Account

The Guest Account Settings page allows you to globally remove all expired templates. To configure guest account settings, follow these steps:

1. **Step 1** Choose Administration > Settings.
2. **Step 2** From the left sidebar menu, choose Guest Account Settings (see Figure 16-27).

![Guest Account Settings Page](image)

3. **Step 3** When the Automatically remove expired guest accounts option is selected, the guest accounts whose lifetime has ended are not retained, and they are moved to the Expired state. Those accounts in the expired state are deleted from WCS.
4. **Step 4** By default, WCS Lobby Ambassador can access all guest accounts irrespective of who created them. If you select the Search and List only guest accounts created by this lobby ambassador check box, the Lobby Ambassadors can access only the guest accounts that have been created by them.
Configuring Login Disclaimer

The Login Disclaimer page allows you to enter disclaimer text at the top of the Login page for all users. To enter Login Disclaimer text, follow these steps:

Step 1  Choose Administration > Settings.
Step 2  From the left sidebar menu, choose Login Disclaimer. The Login Disclaimer page appears (see Figure 16-28).

Figure 16-28  Login Disclaimer Page

Step 3  Enter your Login Disclaimer text in the available text box.
Step 4  Click Save.

Configuring the Mail Server

You can configure global e-mail parameters for sending e-mails from WCS reports, alarm notifications, and so on. This mail server page enables you to configure e-mail parameters in one place. The Mail Server page enables you to set the primary and secondary SMTP server host and port, the sender's e-mail address, and the recipient’s e-mail addresses. To configure global e-mail parameters, follow these steps.
Cisco Wireless Control System Configuration Guide

Chapter 16      Performing Administrative Tasks

Configuring Administrative Settings

Note
You must configure the global SMTP server before setting global e-mail parameters.

Step 1
Choose Administration > Setting.

Step 2
From the left sidebar menu, choose Mail Server Configuration. The page in Figure 16-29 appears.

Figure 16-29     Mail Server Configuration Page

Step 3
Enter the host name of the primary SMTP server.

Step 4
Provide a password for logging on to the SMTP server and confirm it.

Step 5
Provide the same information for the secondary SMTP server (only if a secondary mail server is available).

Step 6
The From text box in the Sender and Receivers portion of the page is populated with WCS@<WCS server IP address>. You can change it to a different sender.

Step 7
Enter the recipient’s e-mail addresses in the To text box. The e-mail address you provide serves as the default value for other functional areas, such as alarms or reports. Multiple e-mail addresses can be added and should be separated by commas.

Note
Global changes you make to the recipient e-mail addresses in Step 7 are disregarded if e-mail notifications were set.

You must indicate the primary SMTP mail server and fill the From address text boxes.

If you want all alarm categories applied to the provided recipient list, select the Apply recipient list to all alarm categories check box.

Step 8
Enter the text that you want to append to the email subject.

Step 9
If you click the Configure email notification for individual alarm categories link, you can specify the alarm categories and severity levels you want to enable. Email notifications are sent when an alarm occurs that matches categories and the severity levels you select.
Chapter 16  Performing Administrative Tasks

Configuring Administrative Settings

Note
You can set each alarm severity by clicking the alarm category, choosing Critical, Major, Minor, or Warning, and providing an email address.

Step 10
Click the Test button to send a test e-mail using the parameters you configured. The results of the test operation appear on the same screen. The test feature checks the connectivity to both primary and secondary mail servers by sending an e-mail with a "WCS test e-mail" subject line.

If the test results were satisfactory, click Save.

Configuring the Notification Receiver

The Notification Receiver page displays current notification receivers that support guest access. Alerts and events are sent as SNMPv2 notifications to configured notification receivers.

In this page, you can view current or add additional notification receivers.

This section contains the following topics:

- Adding a Notification Receiver to WCS, page 16-74
- Removing a Notification Receiver, page 16-75

To access the Notification Receiver page, follow these steps:

Step 1
Choose Administration > Settings.

Step 2
From the left sidebar menu, choose Notification Receivers. All currently configured servers appear in this page. If you want to add one, choose Add Notification Receiver from the Select a command drop-down list, and click Go (see Figure 16-30).

Figure 16-30  Notification Receiver Page
Adding a Notification Receiver to WCS

To view current or add additional notification receivers, follow these steps:

Step 1 Choose **Administration > Settings**.

Step 2 From the left sidebar menu, choose **Notification Receivers**. All currently configured servers appear on this page.

Step 3 From the Select a command drop-down list, choose **Add Notification Receiver**.

Step 4 Click **Go** (see Figure 16-30).

Figure 16-31 Notification Receiver Page

- **Step 5** Enter the server IP address and name.
- **Step 6** Select either the **North Bound** or **Guest Access** radio button. The Notification Type automatically defaults to UDP.
- **Step 7** Enter the UDP parameters including Port Number and Community.

**Note** The receiver that you configure should be listening to UDP on the same port that is configured.

- **Step 8** If you selected North Bound as the receiver type, specify the criteria and severity.

**Note** Alarms for only the selected category will be processed.

**Note** Alarms with only selected severity matching the selected categories will be processed.

- **Step 9** Click **Save** to confirm the Notification Receiver information.

**Note** By default, only INFO level events will be processed for the selected Category.
Note
Only SNMPV2 traps will be considered for northbound notification.

Removing a Notification Receiver

To delete a notification receiver, follow these steps:

**Step 1** Choose **Administration > Settings**.

**Step 2** From the left sidebar menu, choose **Notification Receivers**. All currently configured servers appear on this page.

**Step 3** Select the check box(es) of the notification receiver(s) that you want to delete.

**Step 4** From the Select a command drop-down list, click **Remove Notification Receiver**.

**Step 5** Click **Go**.

**Step 6** Click **OK** to confirm the deletion.

The following is the sample display from a northbound SNMP receiver that has received event traps from WCS.

*Figure 16-32  Sample Display from a Northbound SNMP Receiver*

The sample output below shows the log file generated by WCS. This log file is located in the log file directory on the WCS server (/opt/WCS7.0.28.0/webnms/logs). The log output helps you troubleshoot when alarms are not being received by the northbound SNMP receiver.

```
06/04/10 08:30:58.559 INFO[com.cisco.wcslogger.services] : [NNotificationServiceSNbOrderQueue][addNbAlarm]Adding into queue
06/04/10 08:30:58.560 INFO[com.cisco.wcslogger.services] : [NNotificationServiceSNbOrderQueue][addNbAlarm]incrTotalNotifications2
06/04/10 08:30:58.560 INFO[com.cisco.wcslogger.services] : [NNotificationServiceSNbOrderQueue][addNbAlarm]incrHandledInNotification2
06/04/10 08:30:58.560 INFO[com.cisco.wcslogger.services] : [NNotificationServiceSNbOrderQueue][addNbAlarm]incrNonCongestedIn2
06/04/10 08:30:58.560 INFO[com.cisco.wcslogger.services] : [NNotificationServiceSNbOrderQueue][getNbAlarm]incrHandledOutNotification2
06/04/10 08:30:58.559 INFO[com.cisco.wcslogger.services] : [NNotificationServiceSNbOrderQueue][addNbAlarm]incrNonCongestedIn
```
Table 16-6 summarizes the Cisco-WCS-Notification-MIB to WCS alert/event mapping.
### Table 16-6  Cisco-WCS-Notification-MIB to WCS Alert/Event Mapping

<table>
<thead>
<tr>
<th>Field Name and Object ID</th>
<th>Data Type</th>
<th>WCS Event/Alert field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>cWcsNotificationTimestamp</td>
<td>DateAndTime</td>
<td>createTime - NmsAlert</td>
<td>Creation time for alarm/event.</td>
</tr>
<tr>
<td>cWcsNotificationUpdatedTimestamp</td>
<td>DateAndTime</td>
<td>modTime - NmsAlert</td>
<td>Modification time for Alarm. Events do not have modification time.</td>
</tr>
<tr>
<td>cWNotificationKey</td>
<td>SnmpAdminString</td>
<td>objectId - NmsEvent entityString - NmsAlert</td>
<td>Unique alarm/event ID in string form.</td>
</tr>
<tr>
<td>cWcsNotificationSubCategory</td>
<td>OCTET STRING</td>
<td>eventType in event</td>
<td>This object represents the subcategory of the alert.</td>
</tr>
<tr>
<td>cWcsNotificationServerAddress</td>
<td>InetAddress</td>
<td>N/A</td>
<td>WCS IP address.</td>
</tr>
<tr>
<td>cWcsNotificationManagedObjectAddressType</td>
<td>InetAddressType</td>
<td>N/A</td>
<td>The type of Internet address by which the managed object is reachable.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Possible values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>0 - unknown</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>1 - IPv4</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>2 - IPv6</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3 - IPv4z</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>4 - IPv6z</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>16 - DNS</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Always set to “1” because WCS only supports ipv4 addresses.</td>
</tr>
<tr>
<td>cWcsNotificationManagedObjectAddress</td>
<td>InetAddress</td>
<td>getNode() value is used if present</td>
<td>getNode is populated for events and some alerts. If it is not null, then it will be used for this field.</td>
</tr>
<tr>
<td>cWcsNotificationSourceDisplayName</td>
<td>OCTET STRING</td>
<td>sourceDisplayName field in alert/event.</td>
<td>This object represents the display name of the source of the notification.</td>
</tr>
<tr>
<td>cWcsNotificationDescription</td>
<td>OCTET STRING</td>
<td>Text - NmsEvent Message - NmsAlert</td>
<td>Alarm description string.</td>
</tr>
</tbody>
</table>
Table 16-6  Cisco-WCS-Notification-MIB to WCS Alert/Event Mapping (continued)

<table>
<thead>
<tr>
<th>Field Name and Object ID</th>
<th>Data Type</th>
<th>WCS Event/Alert field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>cWcsNotificationSeverity</td>
<td>INTEGER</td>
<td>severity - NmsEvent, NmsAlert</td>
<td>Severity of the alert/event critical(1), major(2), minor(3), warning(4), clear(5), info(6), unknown(7).</td>
</tr>
<tr>
<td>cWcsNotificationSpecialAttributes</td>
<td>OCTET STRING</td>
<td>All the attributes in alerts/events apart from the base alert/event class.</td>
<td>This object represents the specialized attributes in alerts like APAssociated, APDisassociated, RogueAPAlert, CoverageHoleAlert, and so on. The string is formatted in ‘property=value’ pairs in CSV format.</td>
</tr>
<tr>
<td>cWNotificationVirtualDomains</td>
<td>OCTET STRING</td>
<td>N/A</td>
<td>Virtual Domain of the object that caused the alarm. This field is not populated for running release and this will be populated with empty string.</td>
</tr>
</tbody>
</table>

Setting Report

To indicate where the scheduled reports will reside and for how many days, follow these steps:

Step 1  Choose Administration > Setting.

Step 2  From the left sidebar menu, choose Report. The Report page appears (see Figure 16-33).
Configuring Administrative Settings

Chapter 16      Performing Administrative Tasks

Figure 16-33      Report Page

Step 3 Enter the path for saving report data files on a local PC. You can edit the existing default path.
Step 4 Specify the number of days to retain report data files.
Step 5 Click Save.

Configuring Server Settings

To turn TFTP, FTP, HTTP, or HTTPS on or off, follow these steps:

Step 1 Choose Administration > Settings.
Step 2 From the left sidebar menu, choose Server Settings. The Server Settings page appears (see Figure 16-34).
Configuring Administrative Settings

Chapter 16 Performing Administrative Tasks

Figure 16-34 Server Settings Page

Step 3 If you want to modify the FTP and TFTP directories or the HTTP and HTTPS ports that were established during installation, enter the port number (or port number and root where required) that you want to modify and click Enable or Disable.

The changes are reflected after a restart.

Severity Configurations

You can change the severity level for newly generated alarms.

Note

Existing alarms remain unchanged.

To change the severity level of newly generated alarms, follow these steps:

Step 1 Choose Administration > Settings.

Step 2 Choose Severity Configuration from the left sidebar menu. The Severity Configuration page appears (see Figure 16-35).
### Severity Configuration

#### Administration > Settings > Severity Configuration

Severity levels change will only apply to the newly generated alerts. Existing alarms will remain unchanged.

<table>
<thead>
<tr>
<th>Alarm Condition</th>
<th>Alarm Category</th>
<th>Configured Severity</th>
</tr>
</thead>
<tbody>
<tr>
<td>AP Authorization Failure</td>
<td>Access Points</td>
<td></td>
</tr>
<tr>
<td>AP Detected Duplicate IP</td>
<td>Security</td>
<td></td>
</tr>
<tr>
<td>AP Reboot</td>
<td>Access Points</td>
<td></td>
</tr>
<tr>
<td>AP associated with controller</td>
<td>Access Points</td>
<td></td>
</tr>
<tr>
<td>AP attempted to join Controller with licensed AP count exceeded</td>
<td>Controllers</td>
<td></td>
</tr>
<tr>
<td>AP big new DOS attack</td>
<td>Security</td>
<td></td>
</tr>
<tr>
<td>AP contained as rogue</td>
<td>Access Points</td>
<td></td>
</tr>
<tr>
<td>AP disconnected from controller</td>
<td>Access Points</td>
<td></td>
</tr>
<tr>
<td>AP functionality license expired</td>
<td>Controllers</td>
<td></td>
</tr>
<tr>
<td>AP has no radios</td>
<td>Access Points</td>
<td></td>
</tr>
<tr>
<td>AP impersonation detected</td>
<td>Security</td>
<td></td>
</tr>
<tr>
<td>AP maximum rogue count exceeded</td>
<td>Access Points</td>
<td></td>
</tr>
<tr>
<td>AP reboot reason</td>
<td>Access Points</td>
<td></td>
</tr>
<tr>
<td>AP regulatory domain mismatch</td>
<td>Access Points</td>
<td></td>
</tr>
<tr>
<td>Access point crash</td>
<td>Access Points</td>
<td></td>
</tr>
<tr>
<td>Access point not supported</td>
<td>Controllers</td>
<td></td>
</tr>
<tr>
<td>Adhoc Rogue auto contained</td>
<td>Security</td>
<td></td>
</tr>
<tr>
<td>Adhoc Rogue detected</td>
<td>Adhoc Rogue</td>
<td></td>
</tr>
<tr>
<td>Adhoc Rogue detected contained</td>
<td>Adhoc Rogue</td>
<td></td>
</tr>
<tr>
<td>Adhoc Rogue detected on network</td>
<td>Adhoc Rogue</td>
<td></td>
</tr>
<tr>
<td>Air Quality Traps</td>
<td>Performance</td>
<td></td>
</tr>
<tr>
<td>Alert status allowing denied</td>
<td>WCS</td>
<td></td>
</tr>
<tr>
<td>Attempt to use an unlicensed Controller feature</td>
<td>Controllers</td>
<td></td>
</tr>
<tr>
<td>Authentication failure reported by controller</td>
<td>Security</td>
<td></td>
</tr>
<tr>
<td>Autonomous AP Admin Status Down</td>
<td>Access Points</td>
<td></td>
</tr>
<tr>
<td>Autonomous AP Link Down</td>
<td>Access Points</td>
<td></td>
</tr>
<tr>
<td>Autonomous AP Open Status Down</td>
<td>Access Points</td>
<td></td>
</tr>
<tr>
<td>CPU BV Multicast queue full</td>
<td>Controllers</td>
<td></td>
</tr>
<tr>
<td>Client Associated to Diagnostic Channel</td>
<td>Clients</td>
<td></td>
</tr>
<tr>
<td>Client Traps are disabled on controllers</td>
<td>WCS</td>
<td></td>
</tr>
<tr>
<td>Client WAP key decryption error</td>
<td>Security</td>
<td></td>
</tr>
<tr>
<td>Client WPA MIC error counter activated</td>
<td>Security</td>
<td></td>
</tr>
<tr>
<td>Client associated failure with AP</td>
<td>Clients</td>
<td></td>
</tr>
<tr>
<td>Client associated to AP</td>
<td>Clients</td>
<td></td>
</tr>
<tr>
<td>Client authenticated</td>
<td>Clients</td>
<td></td>
</tr>
<tr>
<td>Client authentication failure</td>
<td>Clients</td>
<td></td>
</tr>
<tr>
<td>Client deauthenticated from AP</td>
<td>Clients</td>
<td></td>
</tr>
<tr>
<td>Client decrypt error occurred</td>
<td>Security</td>
<td></td>
</tr>
<tr>
<td>Client disassociated from AP</td>
<td>Clients</td>
<td></td>
</tr>
<tr>
<td>Client excluded</td>
<td>Security</td>
<td></td>
</tr>
<tr>
<td>Cold start trap from controller</td>
<td>Controllers</td>
<td></td>
</tr>
<tr>
<td>Configuration backup failed</td>
<td>Controllers</td>
<td></td>
</tr>
<tr>
<td>Configuration backup succeeded</td>
<td>Controllers</td>
<td></td>
</tr>
<tr>
<td>Configuration saved</td>
<td>Controllers</td>
<td></td>
</tr>
<tr>
<td>Controller Detected Duplicate IP</td>
<td>Security</td>
<td></td>
</tr>
<tr>
<td>Controller Down</td>
<td>Controllers</td>
<td></td>
</tr>
<tr>
<td>Country code changes</td>
<td>Controllers</td>
<td></td>
</tr>
<tr>
<td>Enforcement on config group failed</td>
<td>WCS</td>
<td></td>
</tr>
<tr>
<td>Enforcement on config group succeeded</td>
<td>WCS</td>
<td></td>
</tr>
</tbody>
</table>
Step 3  Select the check box of the alarm condition whose severity level you want to change.

Step 4  From the Configure Severity Level drop-down list, choose the new severity level (Critical, Major, Minor, Warning, Informational, or Reset to Default).

Step 5  Click Go.

Step 6  Click OK to confirm the change.

SNMP Credentials

The SNMP Credentials page allows you to specify credentials to use for tracing the rogue access points. Use this option when you cannot find a specific entry using a number-based entry. When a switch credential is not added to WCS, you can use SNMP credentials on this page to connect to the switch.

To configure SNMP credentials, follow these steps:

Step 1  Choose Administration > Settings.

Step 2  From the left sidebar menu, choose SNMP Credentials. The SNMP Credential Details page appears (see Figure 16-36).

Step 3  To view or edit details about a current SNMP entry, click the Network Address link. See the “Viewing Current SNMP Credential Details” section on page 16-83 for more information.

Note  The default network address is 0.0.0.0 which indicates the entire network. An SNMP credential is defined per network so only network addresses are allowed. 0.0.0.0 is the SNMP credential default and is used when no specific SNMP credential is defined. The default community string is private for both read and write. You should update the pre-populated SNMP credential with your own SNMP information.
Performing Administrative Tasks

Configuring Administrative Settings

Chapter 16

Performing Administrative Tasks

Configuring Administrative Settings

Figure 16-36   SNMP Credential Details Page

To add a new SNMP entry, select Add SNMP Entries from the Select a command drop-down list and click Go. See the “Adding a New SNMP Credential Entry” section on page 16-84 for more information.

Viewing Current SNMP Credential Details

To view or edit details for current SNMP credentials, follow these steps:

Step 1   Choose Administration > Settings.

Step 2   From the left sidebar menu, choose SNMP Credentials.

Step 3   Click the Network Address link to open the SNMP Credential Details page. The details page displays the following information.

General Parameters

- Add Format Type—Read-only. See the “Adding a New SNMP Credential Entry” section on page 16-84 for more information regarding Add Format Type.
- Network Address
- Network Mask

SNMP Parameters—Select the applicable version(s) for SNMP parameters. The SNMP credentials are validated according to which SNMP version(s) are selected.
Configuring Administrative Settings

Note Enter SNMP parameters for write access, if available. With read-only access parameters, the switch is added but you will not be able to modify its configuration in WCS. Device connectivity tests use the SNMP retries and timeout parameters configured in Administration > Settings > SNMP Settings.

- Retries—The number of times that attempts are made to discover the switch.
- Timeout—The session timeout value in seconds. This determines the maximum amount of time allowed for a client before it is forced to reauthenticate.
- SNMP v1 Parameters or v2 Parameters—If selected, enter the applicable community in the available text box.
- SNMP v3 Parameters—If selected, configure the following parameters:
  - Username
  - Auth. Type
  - Auth. Password
  - Privacy Type
  - Privacy Password

Note If SNMP v1 or v2 with default community is configured, the network is open to easy attacks because default communities are well known. SNMP v1 or v2 with a non-default community is more secure than a default community, but SNMP v3 with Auth and Privacy type and no default user is the most secure SNMP connection.

Step 4 Click OK to save changes or Cancel to return to the SNMP Credential page without making any changes to the SNMP credential details.

Adding a New SNMP Credential Entry

To add a new SNMP credential entry, follow these steps:

Step 1 Choose Administration > Settings.
Step 2 From the left sidebar menu, choose SNMP Credentials.
Step 3 From the Select a command drop-down list, choose Add SNMP Entries.
Step 4 Click Go. The SNMP Credential Details page opens (see Figure 16-36).
Step 5 Choose one of the following:
  - To manually enter SNMP credential information, leave the Add Format Type drop-down list at SNMP Credential Info. To add multiple network addresses, use a comma between each address. Go to Step 7.
  - If you want to add multiple switches by importing a CSV file, choose File from the Add Format Type drop-down list. The CSV file allows you to generate your own import file and add the devices you want. Go to Step 6.
Step 6 If you chose File, click Browse to find the location of the CSV file you want to import. Skip to Step 11.
The first row of the CSV file is used to describe the columns included. The IP Address column is mandatory.

Sample File:

```
ip_address,snmp_version,snmp_community,snmpv3_user_name,snmpv3_auth_type,snmpv3_auth_password,snmpv3_privacy_type,snmpv3_privacy_password,network_mask
1.1.1.0,v2,private,user1,HMAC-MD5,12345,DES,12345,255.255.255.0
2.2.2.0,v2,private,user1,HMAC-MD5,password3,DES,password4,255.255.255.0
10.77.246.0,v2,private,user1,HMAC-MD5,12345,DES,12345,255.255.255.0
```

The CSV file can contain the following fields:

- **ip_address**: IP address
- **snmp_version**: SNMP version
- **network_mask**: Network mask
- **snmp_community**: SNMP V1/V2 community
- **snmpv3_user_name**: SNMP V3 username
- **snmpv3_auth_type**: SNMP V3 authorization type. Can be None or HMAC-MD5 or HMAC-SHA
- **snmpv3_auth_password**: SNMP V3 authorization password
- **snmpv3_privacy_type**: SNMP V3 privacy type. Can be None or DES or CFB-AES-128
- **snmpv3_privacy_password**: SNMP V3 privacy password
- **snmp_retries**: SNMP retries
- **snmp_timeout**: SNMP timeout

**Step 7**  
If you chose SNMP Credential Info, enter the IP address of the switch you want to add. If you want to add multiple switches, use a comma between the string of IP addresses.

**Step 8**  
In the Retries parameter, enter the number of times that attempts are made to discover the switch.

**Step 9**  
Provide the session timeout value in seconds. This determines the maximum amount of time allowed for a client before it is forced to reauthenticate.

**Step 10**  
Select the applicable version(s) for SNMP parameters. The SNMP credentials are validated according to which SNMP version(s) are selected.

- If SNMP v1 Parameters or v2 Parameters is selected, enter the applicable community in the available text box.
- If SNMP v3 Parameters is selected, configure the following parameters:
  - Username
  - Auth. Type
  - Auth. Password
  - Privacy Type
  - Privacy Password

**Note**  
If SNMP v1 or v2 with default community is configured, the network is open to easy attacks because default communities are well known. SNMP v1 or v2 with a non-default community is more secure than a default community, but SNMP v3 with Auth and Privacy type and no default user is the most secure SNMP connection.
Chapter 16      Performing Administrative Tasks

Configuring Administrative Settings

Step 11  Click OK.
If WCS can use the SNMP credential listed to access the switch, the switch is added for later use and will appear on the Configure > Ethernet Switches page.

Note  If you manually added switches through the Configure > Ethernet Switches page, then switch port tracing will use the credentials from that page, not the ones listed on the SNMP Credentials page. If the manually-added switch credentials have changed, you need to update them from the Configure > Ethernet page.

SNMP Settings

The SNMP Settings page allows you to configure global SNMP settings from WCS.

Note  Any changes you make on this screen globally effect WCS. The changes are saved across restarts as well as across backups and restores.

To configure global SNMP settings, follow these steps:

Step 1  Choose Administration > Settings.
Step 2  From the left sidebar menu, choose SNMP Settings. The SNMP Settings page appears (see Figure 16-37).
**Figure 16-37  SNMP Settings Page**

<table>
<thead>
<tr>
<th>Settings</th>
<th>Response</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trace Display Values</td>
<td>Exponential</td>
</tr>
<tr>
<td>Backoff Algorithm</td>
<td></td>
</tr>
<tr>
<td>Use Reachability Parameters</td>
<td></td>
</tr>
<tr>
<td>Reachability Retries</td>
<td></td>
</tr>
<tr>
<td>Reachability Timeout</td>
<td></td>
</tr>
<tr>
<td>Maximum Varbinds per ROU</td>
<td></td>
</tr>
<tr>
<td>Maximum Rows per Table</td>
<td>20000</td>
</tr>
</tbody>
</table>

**Step 3** If Trace Display Values is selected, mediation trace-level logging shows data values fetched from the controller using SNMP. If unselected, the values do not appear.

**Note** The default is unselected for security reasons.

**Step 4** For the Backoff Algorithm, choose either **Exponential** or **Constant Timeout** from the drop-down list. If you choose Exponential (the default value), each SNMP try waits twice as long as the previous try, starting with the specified timeout for the first try. If you choose Constant Timeout, each SNMP try waits the same, specified amount of time.

**Note** Constant Timeout is useful on unreliable networks (such as satellite networks) where the desired number of retries is large. Because it does not double the timeout per try, it does not take as long to timeout with a high number of retries.

**Step 5** Determine if you want to use reachability parameters. If selected, the WCS defaults to the global Reachability Retries and Timeout that you configure. If unselected, WCS always uses the timeout and retries specified per-controller or per-IOS access point. The default is selected.

**Note** Adjust this setting downward if switch port tracing is taking a long time to complete.

**Step 6** For the Reachability Retries parameter, enter the number of global retries used for determining device reachability. The default number is 2. This parameter is only available if the Use Reachability Parameters check box is selected.
Chapter 16  Performing Administrative Tasks

Configuring Administrative Settings

**Note**  Adjust this setting downward if switch port tracing is taking a long time to complete.

**Step 7**  For the Reachability Timeout parameter, enter a global timeout used for determining device reachability. The default number is 2. This parameter is only available if the Use Reachability Parameters check box is selected.

**Step 8**  At the Maximum VarBinds per PDU parameter, enter a number to indicate the largest number of SNMP variable bindings allowed in a request or response PDU. The default is 100.

**Note**  For customers who have issues with PDU fragmentation in their network, this number can be reduced to 50, which typically eliminates the fragmentation.

**Step 9**  The maximum rows per table parameter is configurable and the default value is 50000 rows. The configured value is retained even if you upgrade the WCS version.

**Step 10**  Click *Save* to confirm these settings.

---

**Switch Port Tracing**

Currently, WCS provides rogue access point detection by retrieving information from the controller. The rogue access point table is populated with any detected BSSID addresses from any frames that are not present in the neighbor list. At the end of a specified interval, the contents of the rogue table are sent to the controller in a CAPWAP Rogue AP Report message. With this method, WCS would simply gather the information received from the controllers; but with software release 5.1, you can now incorporate switch port tracing of Wired Rogue Access Point Switch Ports. This enhancement allows you to react to found wired rogue access points and prevent future attacks. The trace information is available only in the WCS log and only for rogue access points, not rogue clients.

**Note**  Rogue Client connected to the Rogue Access point information is used to track the switch port to which the Rogue Access point is connected in the network.

**Note**  If you try to set tracing for a friendly or deleted rogue, a warning message appears.

**Note**  For Switch Port Tracing to successfully trace the switch ports using and v3, all of the OIDs should be included in the SNMP v3 view and VLAN content should be created for each VLAN in the SNMP v3 group.

**Note**  See the “Switch Port Tracing” section on page 16-88 for information on configuring Switch Port Tracing settings.

The Switch Port Trace page allows you to run a trace on detected rogue access points on the wire. To correctly trace and contain rogue access points, you must correctly provide the following information.
Reporting APs—A rogue access point has to be reported by one or more managed access points.

AP CDP Neighbor—Access point CDP neighbor information is required to determine the seed switches.

Switch IP address and SNMP credentials—All switches to be traced must have a management IP address and SNMP management enabled. You can add network address based entries instead of only adding individual switches. The correct write community string must be specified to enable/disable switch ports. For tracing, read community strings are sufficient.

Switch port configuration—Trunking switch ports must be correctly configured. Switch port security must be turned off.

Only Cisco Ethernet switches are supported.

Switch VLAN settings must be properly configured.

CDP protocol must be enabled on all switches.

An Ethernet connection must exist between the rogue access point and the Cisco switch.

You should have some traffic between rogue access points and the Ethernet switch.

The rogue access point must be connected to a switch within the max hop limit. The default hop count is 2, and the maximum is 10.

If SNMPv3 is chosen, use the context option and create one for each VLAN, in addition to the one for the main group (which is required for non-VLAN-based MIBs).

To specify options for switch port tracing, follow these steps:

**Step 1** Choose Administration > Settings.

**Step 2** From the left sidebar menu, choose Switch Port Trace (see Figure 16-38).

**Figure 16-38 Switch Port Trace Page**

**Step 3** Configure the following basic settings as needed:
• MAC address +1/-1 search—Select the check box to enable.
  This search involves the MAC address +1/-1 convention where the wired-side MAC address of the
go rogue access point is obtained by adding or subtracting the radio MAC address by one.

• Rogue client MAC address search—Select the check box to enable.
  When a rogue access point client exists, the MAC address of the client is added to the searchable
MAC address list.

• Vendor (OUI) search—Select the check box to enable. OUI refers to Organizational Unique
Identifier search which searches the first 3 bytes in a MAC address.

• Exclude switch trunk ports—Select the check box to exclude switch trunk ports from the switch port
trace.

  Note When more than one port is traced for a given MAC address, additional checks are
  performed to improve accuracy. These checks include: trunk port, non-AP CDP neighbors
  present on the port, and whether or not the MAC address is the only one on this port.

• Exclude device list—Select the check box to exclude additional devices from the trace. Enter into
  the device list text box each device that you want to exclude from the switch port trace. Separate
  each device names with commas.

• Max hop count—Enter the maximum number of hops for this trace. Keep in mind that the greater
  the hop count, the longer the switch port trace will take to perform.

• Exclude vendor list—Enter in the vendor list text box any vendors that you want to exclude from the
  switch port trace. Separate vendor names with commas. The vendor list is not case sensitive.

Step 4 Configure the following advanced settings as needed:

• TraceRogueAP task max thread—Switch port tracing uses multiple threads to trace rogue access
  points. This field indicates the maximum number of rogue access points that can be traced on
  parallel threads.

• TraceRogueAP max queue size—Switch port tracing maintains a queue to trace rogue access points.
  Whenever you select a rogue access point for tracing, it is queued for processing. This field indicates
  the maximum number of entries that you can store in the queue.

• SwitchTask max thread—Switch port tracing uses multiple threads to query switch devices. This
  field indicates the maximum number of switch devices that you can query on parallel threads.

  Note The default value for these parameters should be good for normal operations. These parameters
directly impact the performance of switch port tracing and WCS. Unless required, We do not
recommend that you alter these parameters.

• Select CDP device capabilities—Select the check box to enable.

  Note WCS uses CDP to discover neighbors during tracing. When the neighbors are verified, WCS
uses the CDP capabilities field to determine whether or not the neighbor device is a valid
switch. If the neighbor device is not a valid switch, it is not traced.
Configuring Administrative Settings

Chapter 16  Performing Administrative Tasks

Establishing Switch Port Tracing

To establish switch port tracing, follow these steps:

Step 1 In the WCS home page, click the Security tab.

Step 2 In the Rogue APs and Adhoc Rogues section, click the number URL which specifies the number of rogues in the last hour, last 24 hours, or total active.

Step 3 Choose for which rogue you are setting switch port tracking by clicking the URL in the MAC Address column. The Alarms > Rogue AP details page opens.

Step 4 From the Select a command drop-down list, choose Trace Switch Port. The Trace Switch Port page opens and WCS runs a switch port trace.

When one or more searchable MAC addresses are available, the WCS uses CDP to discover any switches connected up to two hops away from the detecting access point. The MIBs of each CDP discovered switch is examined to see if it contains any of the target MAC addresses. If any of the MAC addresses are found, the corresponding port number is returned and reported as the rogue switch port.

The SNMP communities for the switches are provided in the “Configuring Ethernet Switches” section on page 9-189.

See the “Switch Port Tracing Details” section on page 16-91 for additional information on the Switch Port Tracing Details dialog box.

Switch Port Tracing Details

In the Switch Port Tracing Details dialog box, you can enable or disable switch ports, trace switch ports, and view detail status of the access point switch trace. For more information on Switch Port Tracing, see the following topics:

- Switch Port Tracing—Provides information on configuring switch port trace settings.
- Configuring Ethernet Switches—Provides information on configuring SNMP switches.
- SNMP Credentials—Provides information on configuring SNMP switch credentials.

In the Switch Port tracing Details dialog box, do one of the following:

- Click Enable/Disable Switch Port(s)—Enables or disables any selected ports.
- Click Trace Switch Port(s)—Runs another switch port trace.
- Click Show Detail Status—Displays details regarding the switch port traces for this access point.
- Click Close.

Switch Port Tracing Troubleshooting

Switch Port Tracing (SPT) works on a best-effort-basis. SPT depends on the following information to correctly trace and contain rogue APs:
• Reporting access points—A rogue access point must be reported by one or more managed access points.
• Access point CDP neighbor—Access point CDP neighbor information is required to determine the seed switches.
• Switch IP address and SNMP credentials
  – All the switches that needs to be traced should have a management IP address and SNMP management enabled.
  – With the new SNMP credential changes, instead of adding the individual switches to WCS, network address based entries can be added.
  – The new SNMP credential feature will have a default entry 0.0.0.0 with default community string as 'private' for both read/write.
  – Correct write community string has to be specified to enable/disable switch ports. For tracing, read community string should be sufficient.
• Switch port configuration
  – Switch ports that are trunking should be correctly configured as trunk ports.
  – Switch port security should be turned off.
• Only Cisco Ethernet switches are supported.

Note The following switches are supported: 3750, 3560, 3750E, 3560E, and 2960.

• Switch VLAN settings should be properly configured.
• CDP protocol should be enabled all the switches.
• An Ethernet connection should exist between the rogue access point and the Cisco switch.
• There should be some traffic between the rogue access point and the Ethernet switch.
• The rogue access point should be connected to a switch within the max hop limit. Default hop is 2. Max hop is 10.
• If SNMPv3 is used, then make sure you use the context option and create one for each VLAN in addition to the one for the main group (which is required for non-VLAN based MIBs).

Configuring High Availability

This section contains the following topics:
• Guidelines and Limitations for High Availability, page 16-93
• Failover Scenario, page 16-93
• High Availability Status, page 16-94
• Configuring High Availability on Primary WCS, page 16-94
• Deploying High Availability, page 16-96
• Adding a New Primary WCS, page 16-97
• Removing a Primary WCS, page 16-97
Guidelines and Limitations for High Availability

Before initiating failover, you must consider the following prerequisites and limitations:

- You must have the extra hardware identical to the primary WCS to run a stand-by instance of WCS.
- This design is based on the software-based WCS and does not accommodate appliance-based WCS.
- The presence of Navigator is considered so that multi-WCS deployments are accommodated.
- A reliable high-speed wired network must exist between the primary WCS and its backup WCS.
- The primary and secondary WCS must be running the same WCS software release.
- WCS supports both Windows- or Linux-based platforms. However, for this failover design, all WCSs in the primary-secondary group must run on the same operating system (either Windows or Linux).
- Failover should be considered temporary. The failed primary WCS should be restored to normal as soon as possible, and failback will be re-initiated. The longer it takes to restore the failed primary WCS, the longer the other WCSs sharing that secondary WCS must run without failover support.
- The latest controller software must be used.
- The primary and secondary host are not required to share the same subnet. They can be geographically separated.
- If a secondary host fails for any reason, all the primary instances are affected, and they run in stand-alone mode without any failover support.
- The ports over which the primary and secondary WCSs communicate must be open (not blocked with network firewalls, application firewalls, gateways, and so on). The tomcat port is configurable during installation, and its default port is 8082. You should reserve solid database ports from 1315 to 1319.
- Any access control lists imposed between the primary and secondary WCS must allow traffic to go between the primary and secondary WCSs.
- In a 2:1 high availability scenario, the secondary WCS must be a high-end PC with more memory than the two primary PCs.

Failover Scenario

When a failure of a primary WCS is automatically detected, the following events take place:

1. The primary WCS is confirmed as non-functioning (hardware crash, network crash, or the like) by the health monitor on the secondary WCS.
2. If automatic failover has been enabled, WCS is started on the secondary as described in Step 3. If automatic failover is disabled, an email is sent to the administrator asking if they want to manually start failover.
3. The secondary WCS instance is started immediately (using the configuration already in place) and uses the corresponding database of the primary. After a successful failover, the client should point to the newly activated WCS (the secondary WCS). The secondary WCS updates all controllers with its own address as the trap destination.

Note: One physical secondary WCS can back many primary devices (WCS).
The redirecting of web traffic to the secondary WCS does not occur automatically. You must use your infrastructure tools to properly configure this redirection.

Location Servers that were served from the primary WCS are now served by the secondary WCS. Any Navigators in the network start monitoring the secondary WCS.

4. The result of the failover operation is indicated as an event in the Health Monitor UI, or a critical alarm is sent to the administrator and to other WCS instances.

**High Availability Status**

To view High Availability details, follow these steps:

- **Step 1** Choose Administration > High Availability.
- **Step 2** Choose HA Status from the left sidebar menu. The following information is displayed:
  - Current status
  - Time, state, and description of each event

**Configuring High Availability on Primary WCS**

When database transaction logs grow to 1/3 of the database partition disk space, set the database to "Standalone" mode to prevent transaction logs from keep growing. But it requires a complete netcopy next time when the database synchronization occurs.

Follow these steps to configure high availability on the primary WCS. You must specify the WCS role (either standalone, primary, or secondary) during installation. See the “Installing WCS for Windows” section on page 2-6 to see the installation steps.

- **Step 1** Choose Administration > High Availability.
- **Step 2** Choose HA Configuration from the left sidebar menu. The High Availability Configuration page appears (see Figure 16-39).

**Note** Before you configure high availability, you must configure a mail server. See the “Configuring the Mail Server” section on page 16-71 for steps on configuring a mail server.
Figure 16-39  High Availability Configuration Page

The current status of high availability is shown in the upper portion of the page.

**Step 3**  Enter the IP address or hostname of the secondary WCS.

**Step 4**  Enter the authentication key specified during the installation of the secondary WCS.

**Step 5**  The default admin email address that you configured in Administration > Settings > Email Server is automatically supplied. You can make any necessary changes. Any changes you make to these email addresses must also be entered in the Secondary SMTP Server section of the Administration > Settings > Mail Server page.

**Note**  You must enter an email address when configuring high availability. WCS tests the email server configuration, and if the test fails (because the mail server cannot connect), WCS does not allow the high availability configuration.

**Step 6**  Choose either a manual or automatic failover option. If you choose manual, you can trigger the failover operation with a button in the secondary HealthMonitor GUI or with the URL specified in the email which the administrator receives upon failure of the primary WCS. If you choose automatic, the secondary WCS initiates a failover on its own when a failure is detected on the primary.

**Step 7**  Click **Save Only** to retain the configuration but not enable high availability at the current time, or click **Save & Enable** to enable high availability.

**Note**  You can configure the high availability feature now but enable it at a later time.

At this point, the secondary is either reachable with the database, and files are synchronized between health monitors, or the secondary is unreachable, and an error is returned because secondary installation did not occur.

From the WCS GUI (Administration > High Availability) after high availability has been enabled, you can perform the following functions:
• Update—Use the Update function to make changes to the Report Repository path (Administration > Settings > Report) or FTP/TFTP root directory (Administration > Settings > Server Settings) and to appropriately synchronize the files.

• Disable—Use the Disable function to break the connection between the primary and secondary WCSs. The database and files stop synchronizing.

• Delete—Use the Delete operation to decommission the primary WCS from the secondary WCS.

• Cancel—Use the Cancel operation to cancel any modifications you made to the high availability configuration. You are returned to the High Availability Status page after you choose Cancel.

**Deploying High Availability**

To deploy high availability on an existing WCS installation, follow these steps:

**Step 1** Identify and prepare the hardware to run the secondary WCS.

**Step 2** Ensure that network connectivity between the primary and secondary WCS is functioning, and all necessary ports are open.

**Step 3** Install the secondary WCS with the same version of WCS that is installed on the primary. See the “Installing WCS for Windows” section on page 2-6.

**Step 4** Start the secondary WCS as a standby server. In this mode, the WCS application does not start. At the same time, the Health Monitor is started on the secondary WCS.

**Step 5** On every primary WCS that needs to use this secondary WCS, stop the WCS.

**Step 6** On the primary host, install the new version of WCS and perform all necessary upgrade steps.

**Step 7** Start the primary WCS (as a primary). The Health Monitor also starts.

**Step 8** Configure the high availability parameters described in the “Configuring High Availability on Primary WCS” section on page 16-94.

**Step 9** Click **Activate** to activate high availability on the primary. WCS primary first copies its database to the secondary WCS and then connects to the secondary. The following files are copied over from the primary to the secondary WCS:

- DB password file
- all auto provisioning startup config files
- all domain maps
- all history reports which are generated by scheduled report tasks

High availability deployment is complete. Use **https://<wcsip>:8082** to access the HealthMonitor UI. Within the HealthMonitor UI, use the root password to login.

To modify the health monitor authentication key, enter **hmadmin [-options] authKey [pass]**.

To view the current status of the health monitor, enter **hmadmin [-options] status**.
Adding a New Primary WCS

To add a new primary WCS to an existing setup, follow these steps. This new primary WCS uses the existing secondary as the failover server.

**Step 1** Ensure that network connectivity between the new primary and secondary is functioning and that all necessary ports are open.

**Step 2** Make sure that the same WCS release that is loaded on the other primary WCS and secondary WCS is loaded on the new primary WCS.

**Step 3** Install the correct version of WCS on the primary WCS.

**Step 4** Upgrade the primary WCS. The Health Monitor also starts.

**Step 5** Follow the steps in the “Configuring High Availability” section on page 16-92.

**Step 6** After the primary WCS connects to the secondary, the Health Monitor on the primary connects to the secondary Health Monitor. They mutually acknowledge each other and start the monitoring.

High availability deployment is now complete.

Removing a Primary WCS

When a primary WCS instance is removed from a group, you must disable the peer database instance on the secondary WCS and remove the Health Monitor for that primary. (To remove the primary WCS from high availability, use the Remove button on the High Availability configuration page.) The secondary WCS disables the database instance and removes the uninstalled primary WCS from its Health Monitor.

Setting User Preferences

This page contains user-specific settings you may want to adjust:

**Step 1** Choose Administration > User Preferences. The User Preferences Page appears (see Figure 16-40).
**Chapter 16      Performing Administrative Tasks**

**Setting User Preferences**

**Figure 16-40 User Preferences Page**

- **List Pages**
  - Items Per List Page

- **Alarms**
  - Refresh Map/Alarms page on new alarm
  - Refresh Alarm count in the Alarm Summary every
  - Alarm Category to display in Alarm Summary
  - Disable Alarm Acknowledge Warning Message

- **Home Page**
  - Refresh home page
  - Refresh home page every

**Step 2** Use the Items Per List Page drop-down list to configure the number of entries shown on a given list page (such as alarms, events, AP list, and so on.).

**Step 3** Specify how often you want the home page refreshed by clicking the **Refresh home page** check box and choosing a time interval from the **Refresh home page every** drop-down list.

**Step 4** Select the **Logout idle user** check box and configure the **Logout idle user after** text box, in minutes, that a user session can be idle before the server cancels the session.

**Step 5** If you want the maps and alarms page to automatically refresh when a new alarm is raised by WCS, select the **Refresh Map/Alarms page on new alarm** check box in the Alarms portion of the page.

**Step 6** Use the **Refresh Alarm count in the Alarm Summary every** drop-down list to choose a time interval to specify how often to reset, use the drop-down list to choose a time interval.

**Step 7** If you do not want the alarm acknowledge warning message to appear, select the **Disable Alarm Acknowledge Warning Message** check box.

**Step 8** Use the **Edit Alarm Categories** to select the alarm categories to display in the Alarm Summary page.

**Step 9** In the **Select Alarms** page, choose the default category to display from the drop-down list, and select the alarm categories and sub categories to display in the alarm toolbar. Click the Save button to save the alarm category list. The selected alarm category and sub categories appears on the User Preferences page.

**Step 10** Click **Save** to save the User Preference settings.
Managing Individual Licenses

This section provides information on the following:

- Managing Controller Licenses, page 16-99
- Managing WCS Licenses, page 16-100
- Managing MSE Licenses, page 16-101

Managing Controller Licenses

Choose Files > Controller Files from the left sidebar menu to monitor the controller licenses.

**Note**
WCS does not directly manage controller licenses. It simply monitors the licenses. You can manage the licenses using CLI, WebUI, or Cisco License Manager (CM) at:

https://tools.cisco.com/SWIFT/Licensing/PrivateRegistrationServlet.

The page displays the following information:

- Controller Name
- Controller IP
- Feature—The feature options are wplus-ap-count, wplus, base-ap-count, and base. Two are active at any one time for an enable feature level of WPLUS or Base and the AP count (base-ap-count or wplus-ap-count), which determines the number of access points that the controller supports (12, 25, 50, 100, or 250). For every physical license installed, two license files show up in the controller as a feature level license and an ap-count license. For example, if you install a WPlus 500 license on the controller, you see a wplus or wplus-ap-count feature.

**Note**
You can have both a WPLUS and Base license, but only one can be active at a time.

- AP Limit—The number of access points that the controller supports.
- EULA Status—Whether the End User License Agreement has been accepted or not.
- Comments—Any user-entered comments about the license when it is installed.
- Type—Permanent, evaluation, or extension.

**Note**
For any controllers with a type other than Permanent, the number of days left to expiration is shown. A license is not in use does not incur the reduction in count until it is in use.

- Status —The status can be described as follows:
  - Inactive—The license level is being used, but this license is not in use.
  - Not In Use—The license level is not being used, and this license is currently unrecognized.
  - Expired in Use—The license is being used, but it is expired and will not be used upon next reboot.
  - Expired Not in Use—The license has expired and can no longer be used.
Managing Individual Licenses

- Count Consumed—The ap-count license is In Use.

All licensed controllers and their information are displayed. If you want to change how the controller results are displayed, click Edit View. In the Edit View page, use the Show and Hide buttons to determine how the columns appear.

Above the Controller Summary list is a series of filters that allow you to sort the list by Controller Name, Feature, or Type.

Managing WCS Licenses

Follow these steps to manage WCS licenses. For information on deciding on a license, types of licenses, installing a license, and backing up and restoring WCS licenses, see the “WCS Licenses” section on page B-1.

**Step 1** Choose Administration > License Center to access the License Center page. It provides information about the WCS licenses, the controller license, and elements of MSE licenses.

For WCS licenses, the following is displayed:

- Feature
- Host name
- AP Limit
- AP Count (for specified number of access points)
- Capacity of licenses currently used
- Type

For controller licensing, the following is displayed:

- Feature
- Controller Count
- AP Limit
- Type

For tag elements, client elements, wIPS Local Mode APs and wIPS Monitor Mode APs within MSE, the following is displayed:

- Limit
- Count
- % Used

**Step 2** Choose Files > WCS Files from the left sidebar menu to see the following:

- Product Activation Key (PAK)
- the feature
- the access point limit
- type

You can click the check box of the desired license and either add or delete it.
Managing MSE Licenses

To manage MSE license, choose Files > MSE Files from the left sidebar menu. The page displays the MSE licenses found and includes the following information:

- MSE License File
- MSE Name
- Element Type
- Limit
- License Type

*Note* Evaluation extension and tag licenses are not displayed on this page.

With full WCS support, the complete functionality of CLM is embedded within WCS. You therefore have a single point of management for devices and their licenses.

If you need to search for a particular license file, you can choose an element type from the drop-down box, and click Go. For example, if you choose Client, and click Go, all license files with client licenses are returned.

Configuring ACS 5.x

This section provides instructions for configuring ACS 5.x to work with WCS.

This section contains the following topics:

- Creating Network Devices and AAA Clients, page 16-101
- Adding Groups, page 16-102
- Adding Users, page 16-102
- Creating Policy Elements or Authorization Profiles, page 16-103
- Creating Authorization Rules, page 16-105
- Configuring Access Services, page 16-107

Creating Network Devices and AAA Clients

To create Network Devices and AAA Clients, follow these steps:

**Step 1** Choose Network Resources > Network Devices and AAA Clients.
Adding Groups

To add groups, follow these steps:

**Step 1** Choose Users and Identity Stores > Identity Groups.

**Step 2** Create a Group.

Adding Users

To add users, follow these steps:
**Step 1** Choose Users and Identity Stores > Internal Identity Stores > Users.

*Figure 16-43  Internal Users Page*

**Step 2** Add a user, and then map to group to that user.

---

**Creating Policy Elements or Authorization Profiles**

**Creating Policy Elements or Authorization Profiles for RADIUS**

To create policy elements or authorization profiles for RADIUS, follow these steps:

**Step 1** Choose Policy Elements > Authorization and Permissions > Network Access > Authorization Profiles.

**Step 2** Click Create.

**Step 3** Enter a Name and Description.

**Step 4** Click the RADIUS Attributes tab.

**Step 5** Add RADIUS Attributes one by one (see Figure 16-44).
Creating Policy Elements or Authorization Profiles For TACACS

To create policy elements or authorization profiles for RADIUS, follow these steps:

**Step 1** Choose Policy Elements > Authorization and Permissions > Device Administration > Shell Profiles.

**Step 2** Click Create.

**Step 3** Enter a Name and Description.

**Step 4** Click the Custom Attributes tab.

**Step 5** Add the TACACS Attributes one by one (see Figure 16-45).
Step 6 Click Submit.

Creating Authorization Rules

This section provides instructions for configuring authorization for RADIUS and TACACS.

Creating Service Selection Rules for RADIUS

To create service selection rules for RADIUS, follow these steps:

Step 1 Choose Access Policies > Access Services > Service Selection Rules.
Step 2 Click Create.
Step 3 Select the protocol as Radius and service as Default Network Access (see Figure 16-46).
**Creating Service Selection Rules for TACACS**

To create service selection rules for TACACS, follow these steps:

**Step 1**  Choose **Access Policies > Access Services > Service Selection Rules**.

**Step 2**  Click **Create**.

**Step 3**  Select the protocol as TACACS and Service as Default Device Admin (see Figure 16-47).

*Figure 16-47  Service Selection Page*
Configuring Access Services

This section provides instructions for configuring access services for RADIUS and TACACS.

Configuring Access Services for RADIUS

To configure access services for RADIUS, follow these steps:

Step 1  Choose Access Policies > Access Services > Default Network Access.

Step 2  In the General tab, select the Policy Structure you want to use. By default all the three will be selected. Similarly, in Allowed Protocols, select the protocols you want to use.

Note  You can retain the defaults for identity and group mapping.

Step 3  To create an authorization rule for RADIUS, choose Access Policies > Access Services > Default Network Access > Authorization.

Step 4  Click Create.

Step 5  In Location, select All Locations or you can create a rule based on the location.

Step 6  In Group, select the group that you created earlier.

Step 7  In Device Type, select All Device Types or you can create a rule based on the Device Type.

Step 8  In Authorization Profile, select the authorization profile created for RADIUS.
Step 9  Click OK.
Step 10 Click Save.

**Configuring Access Services for TACACS**

To configure access services for TACACS, follow these steps:

**Step 1** Choose **Access Policies > Access Services > Default Device Admin**.

**Step 2** In the General tab, select the Policy Structure you want to use. By default all the three will be selected. Similarly, in Allowed Protocols, select the protocols you want to use.

**Note** You can retain the defaults for identity and group mapping.

**Step 3** To create an authorization rule for TACACS, choose **Access Policies > Access Services > Default Device Admin > Authorization**.

**Step 4** Click **Create**.

**Step 5** In Location, select All Locations or you can create a rule based on the location.

**Step 6** In Group, select the group that you created earlier.

**Step 7** In Device Type, select All Device Types or you can create a rule based on the Device Type.

**Step 8** In Shell Profile, select the shell profile created for TACACS.
Managing Licenses

This section contains the following topics:

- Managing WCS Licenses, page 16-109
- Monitoring Controller Licenses, page 16-110
- Managing Mobility Services Engine (MSE) Licenses, page 16-111

Managing WCS Licenses

If you choose Files > WCS Files from the left sidebar menu, you can manage the WCS licenses. This page displays the following information:

- Product Activation Key (PAK)
- Feature
- Access point limit
- Type

Adding a New WCS License File

To add a new WCS license file, follow these steps:

Step 1  From the License Center > Files > WCS Files page, click Add.
Managing Licenses

Step 2  In the Add a License File dialog box, enter or browse to the applicable license file.

Step 3  Once displayed in the License File text box, click Upload.

Deleting a WCS License File

To delete a WCS license file, follow these steps:

Step 1  From the License Center > Files > WCS Files page, select the check box of the WCS license file that you want to delete.

Step 2  Click Delete.

Step 3  Click OK to confirm the deletion.

Monitoring Controller Licenses

If you choose Files > Controller Files from the left sidebar menu, you can monitor the controller licenses.

WCS does not directly manage controller licenses, rather it simply monitors the licenses. To manage the licenses you can use CLI, WebUI or Cisco License Manager (CLM) [Link to product page.

This page displays the following parameters:

- Controller Name
- Controller IP—The IP address of the controller.
- Feature—License features include wplus-ap-count, wplus, base-ap-count, and base.

For every physical license installed, two license files display in the controller: a feature level license and an ap-count license. For example if you install a “WPlus 500” license on the controller, “wplus” and “wplus-ap-count” features display. There are always two of these features active at any one time that combine to enable the feature level (WPlus or Base) and the AP count.

Note  You can have both a WPlus and Base license, but only one can be active at any given time.

- AP Limit—The maximum capacity of access points allowed to join this controller.
- EULA status—Displays the status of the End User License Agreement and is either Accepted or Not Accepted.
- Comments—User entered comments when the license is installed.
- Type—The four different types of licenses are as follows:
  - Permanent—Licenses are node locked and have no usage period associated with them. They are issued by Cisco licensing portal and must be installed using management interfaces on the device. Upon installation of these licenses, you have the necessary permissions across different versions.
Managing Licenses

- Evaluation—Licenses are non-node locked and are valid only for a limited time period. They are used only when no permanent, extension, or grace period licenses exist. Before using an evaluation license, you must accept an End User License Agreement (EULA). Even though they are non-node locked, their usage is recorded on the device. The number of days left displays for the evaluation license with the fewest number of remaining active license days.

- Extension—Licenses are node locked and metered. They are issued by Cisco licensing portal and must be installed using management interfaces on the device. Before using an extension license, you must accept a EULA during installation.

- Grace Period—Licenses are node locked and metered. These licenses are issued by Cisco licensing portal as part of the permission ticket to rehost a license. They are installed on the device as part of the rehost operation, and you must accept a EULA as part of the rehost operation.

Note

Types other than Permanent display the number of days left until the license expires. Licenses not currently in use do not have their counts reduced until they become “In Use”.

- Status
  - In Use—The license level and the license are in use.
  - Inactive—The license level is being used, but this license is not being used.
  - Not In Use—The license level is not being used and this license is not currently recognized.
  - Expired In Use—The license is being used, but is expired and will not be used upon next reboot.
  - Expired Not In Use—The license has expired and can no longer be used.
  - Count Consumed—The ap-count license is In Use.

Note

If you need to filter the list of license files, you can enter a controller name, feature, or type and click Go.

Managing Mobility Services Engine (MSE) Licenses

If you choose Files > MSE Files from the left sidebar menu, you can manage the mobility services engine licenses.

This section contains the following topics:

- Registering Product Authorization Keys, page 16-112
- Installing Client and wIPS License Files, page 16-113
- Deleting a Mobility Services Engine License File, page 16-113

The page displays the mobility services engine licenses found and includes the following information:

Note

Because tag licenses are added and managed using appropriate vendor applications, tag licenses are not displayed in this page. Evaluation (demo) licenses are also not displayed.

Tag licenses are installed using the AeroScout System Manager.

- MSE License File—Indicates the MSE License.
Managing Licenses

- MSE—Indicates the MSE name.
- Type—Indicates the type of mobility services engine (client elements, wIPS local mode or wIPS monitor mode access points).
- Limit—Displays the total number of client elements or wIPS monitor mode access points licensed across the mobility services engine.
- License Type—Permanent licenses are the only license types displayed on this page.
  - Permanent—Licenses are node locked and have no usage period associated with them. They are issued by Cisco licensing portal and must be installed using management interfaces on the device. Upon installation of these licenses, you have the necessary permissions across different versions.

Registering Product Authorization Keys

You receive a product authorization key (PAK) when you order a client, wIPS, or tag license from Cisco. You must register the PAK to receive the license file for install on the mobility services engine. License files are emailed to you after successfully registering a PAK.

Client and wIPS PAKs are registered with Cisco.

Note
Tag PAKs are registered with AeroScout. To register your tag PAK, go to the AeroScout website.

To register a product authoritative key (PAK) to obtain a license file for install, follow these steps:

Step 1
Open a browser page and goto www.cisco.com/go/license.

Note
You can also access this site by clicking the Product License Registration link located on the License Center page of WCS.

Step 2
Enter the PAK and click SUBMIT.

Step 3
Verify the license purchase. Click Continue if correct. The licensee entry page appears.

Note
If the license is incorrect, click the TAC Service Request Tool link to report the problem.

Step 4
At the Designate Licensee page, enter the mobility service engine UDI in the host ID text box. This is the mobility services engine on which the license will be installed.

Note
UDI information for a mobility services engine is found on the General Properties pane at Services > Mobility Services Engine > Device Name > System.

Step 5
Select the Agreement check box. Registrant information appears beneath the Agreement check box. Modify information as necessary.

Note
Ensure that the phone number does not include any characters in the string for the registrant and end user. For example, enter 408 555 1212 rather than 408.555.1212 or 408-555-1212.
Step 6 If registrant and end user are not the same person, select **Licensee (End-User)** check box beneath registrant information and enter the end user information.

Step 7 Click **Continue**. A summary of entered data appears.

Step 8 At the Finish and Submit page, review registrant and end user data. Click **Edit Details** to correct information, if necessary.

Step 9 Click **Submit**. A confirmation page appears.

---

**Installing Client and wIPS License Files**

You can install client and wIPS licenses from WCS.

**Note** Tag licenses are installed using the AeroScout System Manager.

To add a client or wIPS license to WCS after registering the PAK, follow these steps:

Step 1 Choose **Administration > License Center**.

Step 2 From the left sidebar menu, choose **Files > MSE Files**.

Step 3 From the **License Center > Files > MSE Files** page, click **Add** to open the Add a License File dialog box.

Step 4 From the MSE Name drop-down list, select the mobility services engine to which you want to add the license file.

**Note** Verify that the UDI of the selected mobility services engine matches the one you entered when registering the PAK.

Step 5 Enter the license file in the License File text box or browse to the applicable license file.

Step 6 Once displayed in the License File text box, click **Upload**. Newly added license appears in mobility services engine license file list.

**Note** A Context Aware Service (CAS) restarts if a client or tag license is installed; a wIPS service restarts if a wIPS license is installed.

**Note** Services must come up before attempting to add or delete another license.

---

**Deleting a Mobility Services Engine License File**

To delete a mobility services engine license file, follow these steps:

Step 1 From the **License Center > Files > MSE Files** page, select the check box of the mobility services engine license file that you want to delete.
Configuring AAA

From Administration > AAA, authentication, authorization, and accounting (AAA) can be configured for WCS. The only username that has permissions to configure WCS AAA is root or SuperUser. Any changes to local users accounts will be in effect when configured for local mode. If using external authentication, for example RADIUS or TACACS+, the user changes must be done on the remote server. This section contains the following topics:

- Change Password, page 16-114
- Local Password Policy, page 16-116
- AAA Mode, page 16-114
- Users, page 16-116
- Groups, page 16-120
- Active Sessions, page 16-122
- TACACS+, page 16-122
- RADIUS, page 16-124

Change Password

Choose Administration > AAA > Change Password from the left sidebar menu to access this page. This page enables you to change the root password.

- User—Applies to login username root.
- Old Password—Current password.
- New Password—Enter the new password using ASCII characters.
- Confirm password—Reenter the new password.
- Submit—Click Submit to confirm password change.

AAA Mode

Choose Administration > AAA > AAA Mode from the left sidebar menu to access this page. This page enables you to configure the authentication mode for all users.

- AAA Mode Settings
  - Local—Authenticate users to a local database.
  - RADIUS—Authenticate users to an external RADIUS server.
  - TACACS+—Authenticate users to an external TACACS+ server.
- Enable fallback to Local—If an external authentication server is down, this provides the option to authenticate users locally. This option is only available for RADIUS and TACACS+.
--- Select **ONLY on no server response** or **on auth failure or no server response** from the drop-down list.

See also the “TACACS+” section on page 16-122 and the “RADIUS” section on page 16-124.

## Setting AAA Mode

To choose a AAA mode, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Choose Administration &gt; AAA.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Choose <strong>AAA Mode</strong> from the left sidebar menu. The AAA Mode Setting page appears (see Figure 16-50).</td>
</tr>
</tbody>
</table>

### Figure 16-50 AAA Mode Settings Page

![AAA Mode Settings Page](image)

**Step 3** Choose which AAA mode you want to use. Only one can be selected at a time.

Any changes to local user accounts are effective only when you are configured for local mode (the default). If you use remote authentication, changes to the credentials are made on a remote server. The two remote authentication types are RADIUS and TACACS+. RADIUS requires separate credentials for different locations (East and West Coast). TACACS+ is an effective and secure management framework with a built-in failover mechanism.

**Step 4** Select the **Enable Fallback to Local** check box if you want the administrator to use the local database when the external AAA server is down.

**Note** This option is unavailable if **Local** was selected as a AAA mode type.

**Step 5** Click **OK**.
Local Password Policy

Choose **Administration > AAA > Local Password Policy** from the left sidebar menu to access this page. This page enables you to determine your local password policy.

You can enable or disable the following policies for your local password:

- Set the minimum length of your password. By default it is set as 8.
- Password cannot be the username or the reverse of the username.
- Password cannot be the word cisco or ocsic (cisco reversed) or any special characters replaced for the same.
- Root password cannot be the word public.
- No character can be repeated more than three time consecutively in the password.
- Password must contain character from three of the character classes: upper case, lower case, digits, and special characters.
- Set that the password cannot be reused within n number of the previous passwords used. By default it is 10 times.
- Password cannot be changed at an interval of less than 24 hours from last change.
- Set the account to be lockout after x number of failed login attempts. By default it is 5 attempts.
- Set if the account should be disabled after 30 days of inactivity.
- Set the number of days after when the password should expire. By default it is 60 days.
- Enforce password change on first login.

Click **Save** to confirm the Local Password Policy changes.

Users

This section describes how to configure a WCS user. Besides complete access, you can give administrative access with differentiated privileges to certain user groups.

Choose **Administration > AAA > Users** from the left sidebar menu to access this page including:

- Current User Names
- Member Of—Groups with which the user is associated. Click an item under the **Member Of** column to view permitted tasks for this user.
- Audit Trail—Click the Audit Trail icon for a specific user to view or clear current audit trails. See the “Audit User Operations” section on page 16-120.
- Edit Current Users
  - **Edit Current Users - Passwords and Assigned Groups**, page 16-117
  - **Edit Current Users - Permitted Tasks**, page 16-117
  - **Edit Current Users - Groups Assigned to this User**, page 16-117
- Adding a New User, page 16-118

**Note** You must have SuperUser status to create user accounts and groups.

- Virtual Domain
Edit Current Users - Passwords and Assigned Groups

To edit current user account passwords and assigned groups, follow these steps:

Step 1  Choose Administration > AAA.
Step 2  From the left sidebar menu, choose Users.
Step 3  Select a specific user from the User Name column.
Step 4  Enter and confirm a new password, if necessary (optional).
Step 5  If necessary, make changes to the Groups Assigned to this User check box selections.

Note  If the user belongs to Lobby Ambassador, Monitor Lite, Northbound API, or Users Assistant group, the user cannot belong to any other group.

Step 6  Select Submit to confirm the changes or Cancel to close the page without activating any changes.

Edit Current Users - Permitted Tasks

To edit the permitted tasks for this user account, follow these steps:

Step 1  Choose Administration > AAA.
Step 2  From the left sidebar menu, choose Users.
Step 3  Select the applicable group(s) from the Member Of column.
Step 4  From the List of Tasks Permitted column, select or deselect the applicable tasks to permit or disallow them.

Note  The list of available tasks changes depending on the type of group.

Step 5  Select Submit to confirm the changes or Cancel to close the page without activating any changes.

Edit Current Users - Groups Assigned to this User

To edit the groups assigned to this user, follow these steps:

Step 1  Choose Administration > AAA.
Step 2 From the left sidebar menu, choose Users.

Step 3 Select a specific user from the User Name column.

Step 4 Select the check box(es) of the groups to which this user will be assigned.

Note If the user belongs to Lobby Ambassador, Monitor Lite, Northbound API, or Users Assistant group, the user cannot belong to any other group. Root is only assignable to 'root' user and that assignment cannot be changed.

Note For more information on assigned groups, see Step 7 in the “Adding a New User” section on page 16-118 section.

Step 5 Select Submit to confirm the changes or Cancel to close the page without activating any changes.

Adding a New User

The Add User page allows the administrator to set up a new user login including username, password, groups assigned to the user, and virtual domains for the user.

Note By assigning virtual domains to a user, the user is restricted to information applicable to those virtual domains.

Note You must have SuperUser status to access this page.

This section contains the following topics:

- Add User Name, Password, and Groups, page 16-118
- Assign a Virtual Domain, page 16-119

Add User Name, Password, and Groups

To add a new user, follow these steps:

Step 1 Choose Administration > AAA.

Step 2 From the left sidebar menu, choose Users.

Step 3 From the Select a command drop-down list, choose Add User.

Step 4 Click Go.

Step 5 Enter a new Username.

Step 6 Enter and confirm a password for this account.

Step 7 Select the check box(es) of the groups to which this user will be assigned.
If the user belongs to Lobby Ambassador, Monitor Lite, Northbound API, or Users Assistant group, the user cannot belong to any other group.

- **Admin**—Allows users to monitor and configure WCS operations and perform all system administration tasks except administering WCS user accounts and passwords.
- **ConfigManagers**—Allows users to monitor and configure WCS operations.
- **System Monitoring**—Allows users to monitor WCS operations.
- **Users Assistant**—Allows local net user administration only.
- **Lobby Ambassador**—Allows guest access for configuration and management only of user accounts. If Lobby Ambassador is selected, a Lobby Ambassador Defaults tab appears. See the “Managing Lobby Ambassador Accounts” section on page 7-19 for more information on setting up a Lobby Ambassador account.
- **Monitor Lite**—Allows monitoring of assets location.
- **North Bound API User**—Group used only with WCS Navigator and WCS Web Service consumers.

**Note**  
North Bound API Users cannot be assigned a Virtual Domain. When a North Bound API group is selected, the Virtual Domains tab is not available.

- **SuperUsers**—Allows users to monitor and configure WCS operations and perform all system administration tasks including administering WCS user accounts and passwords. Superuser tasks can be changed.
- **Root**—This group is only assignable to ‘root’ user and that assignment cannot be changed.
- **User Defined.**

**Assign a Virtual Domain**

To assign a virtual domain to this user, follow these steps:

**Step 1**  
Click the **Virtual Domains** tab. This page displays all virtual domains available and assigned to this user.

**Note**  
The Virtual Domains tab enables the administrator to assign virtual domains for each user. By assigning virtual domains to a user, the user is restricted to information applicable to those virtual domains.

**Note**  
North Bound API Users cannot be assigned a Virtual Domain. When a North Bound API group is selected, the Virtual Domains tab is not available.

**Step 2**  
Click to highlight the virtual domain in the Available Virtual Domains list that you want to assign to this user.

**Note**  
You can select more than one virtual domain by pressing the Shift or Control key.
**Configuring AAA**

**Step 3** Click **Add**. The virtual domain moves from the Available Virtual Domains to the Selected Virtual Domains list.

To remove a virtual domain from the Selected Virtual Domains list, click to highlight the domain in the Selected Virtual Domains list and click **Remove**. The virtual domain moves from the Selected Virtual Domains list to the Available Virtual Domains list.

**Step 4** Select **Submit** to or **Cancel** to close the page without adding or editing the current user.

---

**Audit User Operations**

To view or clear audit information for this account, follow these steps:

**Step 1** Choose **Administration > AAA**.

**Step 2** From the left sidebar menu, choose **Users**.

**Step 3** Click the **Audit Trail** icon for the applicable account.

**Note** You must have SuperUser status to access this page.

This page enables you to view a list of user operations over time.

- **User**—User login name.
- **Operation**—Type of operation audited.
- **Time**—Time operation was audited.
- **Status**—Success or Failure.

**Step 4** To clear an audit trail, select the check box for the applicable audit, select Clear Audit Trail from the Select a command drop-down list, click **Go**, and click **OK** to confirm.

---

**Groups**

This page provides you with a list of all current groups and their associated members.

- **Group Name**—Click a specific group to view or edit the permitted tasks for this group. The available tasks change depending on the type of group. See the “Edit Current Users - Permitted Tasks” section on page 16-117 for more information.

- **Members**—Click a specific user under the Member column to view or edit that user. See the “Edit Current Users - Passwords and Assigned Groups” section on page 16-117 for more information.

- **Audit Trail**—Click the Audit Trail icon to view or clear audit for this group. See the “Audit User Operations” section on page 16-120 for more information.

- **Export**—Click to export the task list associated with this group.

To access the Groups page, follow these steps:

**Step 1** Choose **Administration > AAA**.

**Step 2** From the left sidebar menu, choose **Groups**.
Note You must have SuperUser status to access this page.

Viewing or Editing Group Information

Follow these steps to see specific tasks the user is permitted to do within the defined group or make changes to the tasks.

Step 1 Choose Administration > AAA.
Step 2 Choose Groups from the left sidebar menu.
Step 3 Click in the Group Name column. The Group Detail: User Group page appears (see Figure 16-51).

Note The detailed page varies based on what group you choose. Figure 16-51 shows the detailed page of the superuser.

You can see the specific tasks the user is permitted to do within the defined group.

Step 4 Make any necessary changes to the tasks.
Step 5  Click Submit.

### Active Sessions

Choose Administration > AAA > Active Sessions from the left sidebar menu to open this page. This page displays a list of users currently logged in. The user highlighted in red represents your current login.

- **Note** You must be logged into a user account with SuperUsers privileges to see active sessions.

If a column heading is a hyperlink, click the heading to sort the list of active sessions in descending or ascending order along that column. The sort direction is toggled each time the hyperlink is clicked.

The Active Sessions page has the following columns:

- **IP/Host Name**—The IP address or the hostname of the machine on which the browser is running. If the hostname of the user machine is not in DNS, the IP address is displayed.
- **Login Time**—The time at which the user logged in to WCS. All times are based on the WCS server machine time.
- **Last Access Time**—The time at which the user browser accessed WCS. All times are based on the WCS server machine time.

- **Login Method:**
  - Web Service—Internal session needed by Navigator to manage WCS.
  - Regular—Sessions created for users who log into WCS directly through a browser.
  - Navigator Redirect—Sessions created for Navigator users who are redirected to WCS from Navigator.
- **User Groups**—The list of groups the user belongs to.
- **Audit trail icon**—Link to page that displays the audit trail (previous login times) for that user.

- **Note** The time displayed in this column is usually a few seconds behind the current system time because Last Access Time is updated frequently by the updates to the alarm status panel. However, if a user navigates to a non WCS web page in the same browser, the disparity in time will be greater. Alarm counts are not updated when the browser is not displaying WCS web pages.

### TACACS+

This section describes how to add and delete TACACS+ servers. TACACS+ servers provide an effective and secure management framework with built-in failover mechanisms. If you want to make configuration changes, you must be authenticated.

The TACACS+ page shows the TACACS+ server’s IP address, port, retransmit rate, and authentication type (Password Authentication Protocol (PAP)) or Challenge Handshake Authentication Protocol (CHAP). The TACACS+ servers are tried based on how they were configured.
To activate TACACS+ servers, you must enable them as described in the “Importing Tasks Into ACS” section on page 16-40.

**Step 1** Choose Administration > AAA.

**Step 2** From the left sidebar menu, choose TACACS+. The TACACS+ page appears (see Figure 16-52).

**Figure 16-52 TACACS+ Page**

Step 3 The TACACS+ page shows the TACACS+ server’s IP address, port, retransmit rate, and authentication type (Password Authentication Protocol (PAP)) or Challenge Handshake Authentication Protocol (CHAP). The TACACS+ servers are tried based on how they were configured.

**Note** If you need to change the order of how TACACS+ servers are tried, delete any irrelevant TACACS+ servers and re-add the desired ones in the preferred order.

**Step 4** Use the drop-down list in the upper right-hand corner to add or delete TACACS+ servers. You can click an IP address if you want to make changes to the information.

**Step 5** The current server address and port are displayed. Use the drop-down list to choose either ASCII or hex shared secret format.

**Step 6** Enter the TACACS+ shared secret used by your specified server.

**Step 7** Re-enter the shared secret in the Confirm Shared Secret text box.

**Step 8** Specify the time in seconds after which the TACACS+ authentication request times out and a retransmission is attempted by the controller.

**Step 9** Specify the number of retries that will be attempted.

**Step 10** In the Authentication Type drop-down list, choose a protocol: PAP or CHAP.

**Step 11** Click Submit.
Chapter 16  Performing Administrative Tasks

Configuring AAA

Note

See the “Configuring ACS 5.x” section on page 16-101 for more information on Configuring ACS 5.x.

Select a command

- Delete TACACS+ Server—Select a server or servers to be deleted, select this command and click Go to delete the server(s) from the database.

Add TACACS+ Server

Choose Administration > AAA > TACACS+ from the left sidebar menu to access this page. From the Select a command drop-down list choose Add TACACS+ Server and click Go to access this page.

This page allows you to add a new TACACS+ server to WCS.

- Server Address—IP address of the TACACS+ server being added.
- Port—Controller port.
- Shared Secret Format—ASCII or Hex.
- Shared Secret—The shared secret that acts as a password to log in to the TACACS+ server.
- Confirm Shared Secret—Reenter TACACS+ server shared secret.
- Retransmit Timeout—Specify the time in seconds after which the TACACS+ authentication request will time out and the controller will retransmit.
- Retries—Number of retries allowed for authentication request. You can specify a value between 1 and 9.
- Authentication Type—Two authentication protocols are provided. Password Authentication Protocol (PAP) and Challenge Handshake Authentication Protocol (CHAP).

Command Buttons

- Submit
- Cancel

Note

Enable the TACACS+ server with the AAA Mode Settings. See the “AAA Mode” section on page 16-114.

RADIUS

This section describes how to add and delete RADIUS servers. You must enable RADIUS servers and have a template set up for them to make configuration changes.

RADIUS provides authentication of users accessing the network. Authentication requests are sent to a RADIUS server that contains all user authentication and network access information. Passwords are encrypted using RADIUS.

In the event the configured RADIUS server(s) is down, WCS will fall back to local authentication and authorization if the fallback to local option is configured. See the “AAA Mode” section on page 16-114.
Note: To activate RADIUS servers, you must enable them as described in the “Importing Tasks Into ACS” section on page 16-40.

Step 1: Choose Administration > AAA.

Step 2: From the left sidebar menu, choose RADIUS. The RADIUS page appears (see Figure 16-53).

Figure 16-53  RADIUS Page

Step 3: The RADIUS page shows the server address, authentication port, retransmit timeout value, and authentication type for each RADIUS server that is configured. The RADIUS servers are tried based on how they were configured.

Note: If you need to change the order of how RADIUS servers are tried, delete any irrelevant RADIUS servers, and re-add the desired ones in the preferred order.

Step 4: Use the drop-down list in the upper right-hand corner to add or delete RADIUS servers. You can click an IP address if you want to make changes to the information.

Step 5: The current authentication port appears. Use the drop-down list to choose either ASCII or hex shared secret format.

Step 6: Enter the RADIUS shared secret used by your specified server.

Step 7: Re-enter the shared secret in the Confirm Shared Secret text box.

Step 8: Specify the time in seconds after which the RADIUS authentication request times out and a retransmission is attempted by the controller.

Step 9: Specify the number of retries that will be attempted.

Step 10: From the Authentication Type drop-down list, choose a protocol: PAP or CHAP.
Select a command

- Add RADIUS Server—See the “Adding RADIUS Server” section on page 16-126.
- Delete RADIUS Server—Select a server or servers to be deleted, select this command, and click Go to delete the server(s) from the database.

Adding RADIUS Server

Choose Administration > AAA > RADIUS from the left sidebar menu to access this page. From the Select a command drop-down list choose Add RADIUS Server, and click Go to access this page.

This page allows you to add a new RADIUS server to WCS.

- Server Address—IP Address of the RADIUS server being added.
- Port—Controller port.
- Shared Secret Format—ASCII or Hex.
- Shared Secret—The shared secret that acts as a password to log in to the RADIUS server.
- Confirm Shared Secret—Reenter RADIUS server shared secret.
- Retransmit Timeout—Specify the time in seconds after which the RADIUS authentication request will time out and the controller will retransmit.
- Retries—Number of retries allowed for authentication request. You can specify a value between 1 to 9.

Command Buttons

- Submit
- Cancel

Note: Enable the RADIUS server with the AAA Mode Settings. See the “AAA Mode” section on page 16-114.
The Tools menu provides access to the Voice Audit, Location Accuracy Tool, Configuration Audit Summary, and Migration Analysis features of Cisco WCS. This chapter contains the following sections:

- Information About Tools, page 17-1
- Running Voice Audits, page 17-2
- Configuring Location Accuracy Tool, page 17-7
- Running Voice Diagnostic, page 17-11
- Configuring Audit Summary, page 17-20
- Configuring Migration Analysis, page 17-21
- Configuring TAC Case Attachments, page 17-23

Information About Tools

The Tools menu provides access to the Voice Audit, Location Accuracy Tool, Configuration Audit Summary, and Migration Analysis features of WCS.

Voice Audit

WCS provides an auditing mechanism to check the controller configuration and to ensure that any deviations from the deployment guidelines are highlighted as an Audit Violation.

To access the Voice Audit feature, choose Tools > Voice Audit.

The WCS Voice Audit has three tabs: Controllers, Rules, Reports.

- The Controllers tab allows you to choose the controller(s) on which to run the voice audit.
- The Rules tab allows you to indicate the applicable VoWLAN SSID and the applicable rules for this voice audit.
- The Voice Audit Report provides a summary of the voice audit details and report results.
  - Voice Audit Report Details, page 17-6
  - Voice Audit Report Results, page 17-6

This section contain the following topics:

- Location Accuracy Tool, page 17-2
Location Accuracy Tool

By verifying for location accuracy, you are ensuring that the existing access point deployment can estimate the true location of an element within 10 meters at least 90% of the time.

You can analyze the location accuracy of non-rogue and rogue clients and asset tags by using the Accuracy Tool.

There are two methods of conducting location accuracy testing:

- **Scheduled Accuracy Testing**—Employed when clients, tags and interferers are already deployed and associated to the wireless LAN infrastructure. Scheduled tests can be configured and saved when clients, tags and interferers are already pre-positioned so that the test can be run on a regularly scheduled basis.

- **On demand Accuracy Testing**—Employed when elements are associated but not pre-positioned. On demand testing allows you to test the location accuracy of clients, tags and interferers at a number of different locations. It is generally used to test the location accuracy for a small number of clients, tags and interferers.

The Accuracy Tool enables you to run either a scheduled or on-demand location accuracy test. Both tests are configured and executed through a single page.

Voice Diagnostics

The Voice diagnostic tool is an interactive tool to diagnose the voice calls in real time. This tool reports call control related errors, roaming history of the clients and the total active calls accepted and rejected by an associated AP. This tool enables you to start or stop the voice diagnostic.

The Voice diagnostic test is provisioned for multiple controllers, that is if the AP is associated to more than one controller during roaming, the Voice diagnostics tests all the associated controllers. WCS supports testing on controllers whose APs are placed on +/- 3 floors. For example, wcs map has floors 1 to 4 and all APs are associated to controllers(wlc1, wlc2, wlc3, wlc4) and are placed on the wcs map, if a client is associated on any AP with WLC1 on first floor and if voice diagnostic test is started for this client, test will also be provisioned on wlc2 to wlc3 also). This is done for roaming reason.

Running Voice Audits

To access the Voice Audit feature, choose **Tools > Voice Audit**.

This section provides the following information:

- **Running Voice Audits on Controllers**, page 17-2
- **Choosing Voice Audit Rules**, page 17-3

Running Voice Audits on Controllers

The Controllers tab allows you to choose the controller(s) on which to run the voice audit.
You can run the voice audit on a maximum of 50 controllers in a single operation.

To select the controller(s) for the voice audit, follow these steps:

**Step 1** Choose **Tools > Voice Audit**.

**Step 2** Click the **Controllers** tab.

**Step 3** From the Run audit on drop-down list, select from All Controllers, a Floor Area, or a Single Controller.
- All Controllers—No additional Controller information necessary.
- A Floor Area—From the drop-down lists, select the applicable Campus, Building, Floor, and Controller.
- A Single Controller—Select the applicable controller from the drop-down list.

**Step 4** Click the **Rules** tab to determine the rules for this voice audit. See the “Choosing Voice Audit Rules” section on page 17-3 for more information.

### Choosing Voice Audit Rules

The Rules tab allows you to indicate the applicable VoWLAN SSID and the applicable rules for this voice audit.

To indicate the rules for the voice audit, follow these steps:

**Step 1** In the Tools > Voice Audit page, click the Rules tab.

**Step 2** Type the applicable VoWLAN SSID in the VoWLAN SSID text box.

**Step 3** From the Rules List, select the check boxes of the applicable rules for this voice audit (see Table 17-1).

**Note** The red circle indicates an invalid rule (due to insufficient data). The green circle indicates a valid rule.

<table>
<thead>
<tr>
<th>Rule</th>
<th>Rule Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>VoWLAN SSID</td>
<td>Description—Checks whether or not the VoWLAN SSID exists. Rule validity—User defined VoWLAN SSID.</td>
</tr>
<tr>
<td>CAC: 7920</td>
<td>Description—Checks whether or not 7920 AP CAC is enabled for VoWLAN. Rule validity—User defined VoWLAN SSID.</td>
</tr>
</tbody>
</table>
### Table 17-1  Rules List for Voice Audit (continued)

<table>
<thead>
<tr>
<th>Rule</th>
<th>Rule Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>CAC: 7920 Clients</td>
<td>Description—Checks whether or not the 7920 Client CAC is disabled for VoWLAN.</td>
</tr>
<tr>
<td></td>
<td>Rule validity—User defined VoWLAN SSID.</td>
</tr>
<tr>
<td>DHCP Assignment</td>
<td>Description—Checks whether or not DHCP assignment is disabled for VoWLAN.</td>
</tr>
<tr>
<td></td>
<td>Rule validity—User defined VoWLAN SSID.</td>
</tr>
<tr>
<td>MFP Client</td>
<td>Description—Checks whether or not MFP Client protection is not set to Required for VoWLAN.</td>
</tr>
<tr>
<td></td>
<td>Rule validity—User defined VoWLAN SSID.</td>
</tr>
<tr>
<td>Platinum QoS</td>
<td>Description—Checks whether or not QoS is set to Platinum (Voice) for VoWLAN.</td>
</tr>
<tr>
<td></td>
<td>Rule validity—User defined VoWLAN SSID.</td>
</tr>
<tr>
<td>Non Platinum QoS</td>
<td>Description—Checks that QoS is not set to Platinum for non-VoWLAN.</td>
</tr>
<tr>
<td></td>
<td>Rule validity—User defined VoWLAN SSID.</td>
</tr>
<tr>
<td>WMM</td>
<td>Description—Checks whether or not WMM is enabled for VoWLAN.</td>
</tr>
<tr>
<td></td>
<td>Rule data—Select Allowed or Required from the drop-down list.</td>
</tr>
<tr>
<td></td>
<td>Rule validity—User defined VoWLAN SSID.</td>
</tr>
<tr>
<td>ACM</td>
<td>Description—Checks whether or not Admission Control is enabled.</td>
</tr>
<tr>
<td></td>
<td>Rule data—Select the check box for 802.11a/n ACM, 802.11b/g/n ACM, or both.</td>
</tr>
<tr>
<td></td>
<td>Rule validity—At least one band must be selected.</td>
</tr>
<tr>
<td>DTPC</td>
<td>Description—Checks whether or not Dynamic Transmit Power Control is enabled.</td>
</tr>
<tr>
<td></td>
<td>Rule data—Select the check box for 802.11a/n DTPC, 802.11b/g/n DTPC, or both.</td>
</tr>
<tr>
<td></td>
<td>Rule validity—At least one band must be selected.</td>
</tr>
<tr>
<td>Expedited Bandwidth</td>
<td>Description—Checks whether or not Expedited Bandwidth is enabled.</td>
</tr>
<tr>
<td></td>
<td>Rule data—Select the check box for 802.11a/n Expedited Bandwidth, 802.11b/g/n Expedited Bandwidth, or both.</td>
</tr>
<tr>
<td></td>
<td>Rule validity—At least one band must be selected.</td>
</tr>
<tr>
<td>Load Based CAC</td>
<td>Description—Checks whether or not Load Based Admission Control (CAC) is enabled.</td>
</tr>
<tr>
<td></td>
<td>Rule data—Select the check box for 802.11a/n Load Based CAC, 802.11b/g/n Load Based CAC, or both.</td>
</tr>
<tr>
<td></td>
<td>Rule validity—At least one band must be selected.</td>
</tr>
</tbody>
</table>
### Table 17-1  
**Rules List for Voice Audit (continued)**

<table>
<thead>
<tr>
<th>Rule</th>
<th>Rule Details</th>
</tr>
</thead>
</table>
| CAC: Max Bandwidth                | **Description**—Checks whether or not Maximum RF Bandwidth for Call Admission Control is configured properly.  
**Rule data**—Enter percentages in the text boxes for Maximum Allowed Bandwidth for 802.11a/n and 802.11b/g/n.  
**Rule validity**—Data for at least one band must be provided. Valid range is 0—100%. |
| CAC: Reserved Roaming Bandwidth   | **Description**—Checks whether or not Reserved Roaming Bandwidth for Call Admission Control is configured properly.  
**Rule data**—Enter percentages in the text boxes for Maximum Reserved Roaming Bandwidth for 802.11a/n and 802.11b/g/n.  
**Rule validity**—Data for at least one band must be provided. Valid range is 0—100%. |
| Pico Cell mode                    | **Description**—Checks whether or not Pico Cell mode is disabled.  
**Rule data**—Select the check boxes for 802.11a/n Pico Cell mode, 802.11b/g/n Pico Cell mode, or both.  
**Rule validity**—At least one band must be selected. |
| Beacon Period                     | **Description**—Checks whether or not Beacon Period is configured properly.  
**Rule data**—Enter the time (ms) in the text boxes for Beacon Period for 11a/n and 11b/g/n.  
**Rule validity**—Data for at least one band must be provided. Valid range is 20—1000. Enter 0 or keep it empty if a band should not be checked. |
| Short Preamble                    | **Description**—Checks whether or not Short Preamble is enabled for 11b/g. |
| Fragmentation Threshold           | **Description**—Checks whether or not Fragmentation Threshold is configured properly.  
**Rule data**—Enter the threshold amount (bytes) in the text boxes for Fragmentation Threshold for 11a/n and 11b/g/n.  
**Rule validity**—Data for at least one band must be provided. Valid range is 256—2346. Enter 0 or keep it empty if a band should not be checked. |
| Data Rate                         | **Description**—Checks whether or not Data Rates are configured properly.  
**Data Rate configuration for 11b/g**—Select **Disabled**, **Supported**, or **Mandatory** for each Mbps category.  
**Data Rate configuration for 11a**—Select **Disabled**, **Supported**, or **Mandatory** for each Mbps category. |
| Aggressive Load Balancing         | **Description**—Checks whether or not Aggressive Load Balancing is disabled. |
## Table 17-1  Rules List for Voice Audit (continued)

<table>
<thead>
<tr>
<th>Rule</th>
<th>Rule Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>QoS Profile</td>
<td>Description—Checks that QoS Profiles are not altered from default values.</td>
</tr>
<tr>
<td>EAP Request Timeout</td>
<td>Description—Checks whether or not EAP Request Timeout is configured properly.</td>
</tr>
<tr>
<td></td>
<td>Rule data—Enter the time limit (sec) for the EAP Request Timeout</td>
</tr>
<tr>
<td></td>
<td>Rule validity—Data cannot be left blank or as zero. Valid range is 1—120.</td>
</tr>
<tr>
<td>ARP Unicast</td>
<td>Description—Checks whether or not ARP Unicast is disabled.</td>
</tr>
</tbody>
</table>

### Step 4
When the rules are configured for this voice audit, click **Save** to save the current configuration or **Save and Run** to save the configuration and run the report.

### Step 5
Click the **Report** tab to view the Report results. See the “Voice Audit Report Details” section on page 17-6 for more information.

### Voice Audit Report Details

The Voice Audit details provides the following information:

- Audit Status—Indicates whether or not the audit is complete.
- Start Time and End Times—Indicates the time at which the voice audit began and ended.
- # Total Devices—Indicates the number of devices involved in the voice audit.
- # Completed Devices—Indicates the number of devices the tool attempted to audit.

**Note** If a controller is unreachable, the audit skips it. The Voice Audit will not complete any rule checks for that controllers.

- # Rules—Indicates the number of rules selected for the voice audit.

### Voice Audit Report Results

The Voice Audit Report results include the following information:

- IP Address—Indicates the IP Address for the controller involved in the voice audit.
- Rule—Indicates the rule that was applied for this controller.
- Result—Indicates the result (Skipped, Violation, Unreachable) of the applied rule.
Chapter 17 Tools

Configuring Location Accuracy Tool

You can analyze the location accuracy of non-rogue and rogue clients and asset tags by using the Accuracy Tool.

There are two ways to test location accuracy:

- **Scheduled Accuracy Testing**—Employed when clients, tags and interferers are already deployed and associated to the wireless LAN infrastructure. Scheduled tests can be configured and saved when clients, tags and interferers are already pre-positioned so that the test can be run on a regularly scheduled basis.

- **On-Demand Accuracy Testing**—Employed when elements are associated but not pre-positioned. On demand testing allows you to test the location accuracy of clients, tags and interferers at a number of different locations. It is generally used to test the location accuracy for a small number of clients, tags and interferers.

Both are configured and executed through a single page.

This section contains the following topics:

- Enabling the Location Accuracy Tool, page 17-7
- Viewing Currently Scheduled Accuracy Tests, page 17-8
- Viewing Accuracy Test Details, page 17-8
- Using Scheduled Accuracy Testing to Verify Accuracy of Current Location, page 17-9
- Using On-demand Accuracy Testing to Test Location Accuracy, page 17-10

### Enabling the Location Accuracy Tool

**Note**

You must enable the **Advanced Debug** option in Cisco WCS to use the Scheduled and On-demand location accuracy testing features. The Location Accuracy Tool does not appear as an option under the Tools menu when the Advanced Debug option is not enabled.

To enable the advanced debug option in Cisco WCS, follow these steps:
Chapter 17  Tools

Configuring Location Accuracy Tool

Step 1  In Cisco WCS, choose Monitor > Maps.

Step 2  Select Properties from the Select a command drop-down list, and click Go.

Step 3  In the page that appears, select Enabled for the Advanced Debug Mode option. Click OK.

Note  If Advanced Debug is already enabled, you do not need to do anything further. Click Cancel.

You can now run location accuracy tests on the mobility services engine using the Location Accuracy Tool.

Proceed to either the “Using Scheduled Accuracy Testing to Verify Accuracy of Current Location” section on page 17-9 or “Using On-demand Accuracy Testing to Test Location Accuracy” section on page 17-10 section.

Viewing Currently Scheduled Accuracy Tests

To view currently scheduled accuracy tests, follow these steps:

Step 1  Select Tools > Location Accuracy Tool.

Step 2  The Accuracy Tests page displays all currently scheduled accuracy tests. The page displays the following information:

- Test Name—Click the Name to view details regarding this accuracy test.
- Test Type
- Floor or Outdoor Area—Displays the location of this test.
- Status
- Accuracy %

Use the Select a command drop-down list to create a new scheduled or on-demand accuracy test, to download logs for last run, to download all logs, or to delete a current accuracy test.

Note  You can download logs for accuracy tests from the Accuracy Tests summary page. To do so, check the listed test check box and select either Download Logs or Download Logs for Last Run from the Select a command drop-down list. Click Go.

- The Download Logs option downloads the logs for all accuracy tests for the selected test(s).
- The Download Logs for Last Run option downloads logs for only the most recent test run for the selected test(s).

Viewing Accuracy Test Details

To view details regarding a current accuracy test, follow these steps:
Configuring Location Accuracy Tool

Step 1 Select Tools > Location Accuracy Tool.

Step 2 Click the name of the accuracy test for which you want to access details.
From the Accuracy Test Details page, you can position test points or delete the accuracy test.

Step 3 Click Cancel to return to the Accuracy Test overview page.

Using Scheduled Accuracy Testing to Verify Accuracy of Current Location

To configure a scheduled accuracy test, follow these steps:

Step 1 Click Tools > Location Accuracy Tool.

Step 2 Select New Scheduled Accuracy Test from the Select a command drop-down list.

Step 3 Enter a Test Name.

Step 4 Select the Area Type from the drop-down list.

Campus is configured as Root Area, by default. There is no need to change this setting.

Step 5 Select the Building from the drop-down list.

Step 6 Select the Floor from the drop-down list.

Step 7 Select the begin and end time of the test by entering the days, hours and minutes. Hours are entered using a 24-hour clock.

Note When entering the test start time, be sure to allow enough time prior to the test start to position testpoints on the map.

Step 8 Test results are viewed at the Accuracy Tests > Results page. Reports are in PDF format.

Note If you select the email option, a SMTP Mail Server must first be defined for the target email address. Click Administrator > Settings > Mail Server to enter the appropriate information.

Step 10 Click Position Testpoints. The floor map appears with a list of all clients, tags and interferers on that floor with their MAC addresses.

Step 11 Click the check box next to each client and tag for which you want to check the location accuracy.

When you check a MAC address check box, two icons appear on the map. One icon represents the actual location and the other represents the reported location.

Note To enter a MAC address for a client or tag or interferer that is not listed, check the Add New MAC check box, enter the MAC address, and click Go. An icon for the element appears on the map. If the newly added element is on the location server but on a different floor, the icon is displayed in the left-most corner (0,0 position).

Step 12 If the actual location for an element is not the same as the reported location, drag the actual location icon for that element to the correct position on the map. Only the actual location icon can be dragged.
Configuring Location Accuracy Tool

**Step 13** Click **Save** when all elements are positioned. A pane appears confirming successful accuracy testing.

**Step 14** Click **OK** to close the confirmation pane. You are returned to the Accuracy Tests summary page.

| Note | The accuracy test status displays as Scheduled when the test is about to execute. A status of Running displays when the test is in process and Idle when the test is complete. A Failure status appears when the test is not successful. |

**Step 15** To view the results of the location accuracy test, click the test name and then select the Results tab on the page that displays.

**Step 16** At the Results pane, click the Download link under the Saved Report heading to view the report.

The Scheduled Location Accuracy Report includes the following information:

- A summary location accuracy report that details the percentage of elements that fell within various error ranges.
- An error distance histogram.
- A cumulative error distribution graph.
- An error distance over time graph.
- A summary by each MAC address whose location accuracy was tested noting its actual location, error distance and a map showing its spatial accuracy (actual vs. calculated location) and error distance over time for each MAC.

### Using On-demand Accuracy Testing to Test Location Accuracy

An On-demand Accuracy Test is run when elements are associated but not pre-positioned. On-demand testing allows you to test the location accuracy of clients, tags and interferers at a number of different locations. It is generally used to test the location accuracy for a small number of clients, tags and interferers.

To run an On-demand Accuracy Test, follow these steps:

**Step 1** Click **Tools > Location Accuracy Tool**.

**Step 2** From the Select a command drop-down list, choose **New On demand Accuracy Test**.

**Step 3** Enter a Test Name.

**Step 4** Select the Area Type from the drop-down list.

**Step 5** Campus is configured as Root Area, by default. There is no need to change this setting.

**Step 6** Select the Building from the drop-down list.

**Step 7** Select the Floor from the drop-down list.

**Step 8** Select the Destination point for the test results. Test results are viewed at the Accuracy Tests > Results page. Reports are in a PDF.

**Step 9** Click **Position Testpoints**. The floor map appears with a red crosshair at the (0,0) coordinate.

**Step 10** To test the location accuracy and RSSI of a particular location, select either client or tag or interferer from the drop-down list on the left. A list of all MAC addresses for the selected option (client or tag or interferer) displays in a drop-down list to its right.
Step 11 Select a MAC address from the drop-down list and move the red cross hair to a map location and click the mouse to place it.

Step 12 From the Zoom percentage drop-down list, choose the zoom percentage for the map. The X and Y text boxes are populated with the coordinates based on the position of the red cross hair in the map.

Step 13 Click Start to begin collection of accuracy data.

Step 14 Click Stop to finish collection. You should allow the test to run for at least two minutes before clicking Stop.

Step 15 Repeat Step 11 to Step 14 for each testpoint that you want to plot on the map.

Step 16 Click Analyze Results when you are finished mapping the testpoints.

Step 17 Click the Results tab on the pane that appears.

The On-demand Accuracy Report includes the following information:

- A summary location accuracy report that details the percentage of elements that fell within various error ranges.
- An error distance histogram
- A cumulative error distribution graph

Running Voice Diagnostic

The Voice diagnostic page lists the prior test runs, if any. The Voice diagnostic page shows the following details:

- Test Name—Name of the test.
- First Client—Mac address of the primary phone to be tested.
- Second Client—Mac address of the second phone to be tested.
- Start Time—The time when the test was started.
- Remaining Time—The time remaining for the test.
• State—The state of the test. It can be one of the four states, Running, Completed, Stopped or Aborted.

• Problem—The status of the test. Red indicates a problem was discovered in the test. Green indicates the voice diagnostic test that no problems were discovered during the call.

You can either start a new test or view the existing test results or delete a test from the Select a command from the drop-down list.

To view the test details, click the Test Name link. The test detail page shows the following details (see Figure 17-2):

![Test Details Page](image)

Figure 17-2  Test Details Page

- Test Name—Name of the test.
- State—The state of the test. It can be one of the four states, Running, Completed, Stopped or Aborted.
- Problem—The status of the test. Red indicates a problem was discovered in the test. Green indicates the voice diagnostic test was successful without any problems.
- Duration—The duration for which the test is performed. The duration can be either 10, 20, 30, 40, 50, or 60 minutes. The default selection is 10 minutes.
- Starting Time—The time when the test was started.
- Remaining/Stopped Time—The time remaining for the test.
- First Client Details—Displays the First Client details such as the Client MAC address and all the controllers provisioned for the client and if the controllers are not reachable then the failed provisioned controllers are also listed.
- Second Client Details—Displays the Second Client details (if any) such as the Client MAC address and all the controllers provisioned for the client and if the controllers are not reachable then the failed provisioned controllers are also listed.

Note
To support roaming, the tool figures out controllers in the same building as of client’s associated AP building and adds to all controller’s watchlist. The tool looks for controllers in +/-5 floors from client’s current association AP’s location to configure on controllers. Configuration on controller’s watchlist is done for 10 minutes. After 10 minutes controller will remove the entry from the watchlist.

Starting the Voice Diagnostic Test

To start a Voice Diagnostic test, follow these steps:

**Step 1**
Click **Tools > Voice Diagnostics**.

**Step 2**
From the Select a command drop-down list, click the New test and click Go. It takes you to the configuration page (See Figure 17-3).

**Figure 17-3** New Test Configuration

On this page, you can configure maximum of two clients for voice call diagnosis. Both clients can be on the same call or can be in a different call.
Step 3  Enter the Test name and the time duration to monitor the voice call. You can do a voice diagnosis test for 10, 20, 30, 40, 50 or 60 minutes. 10 minutes is the default duration selected by WCS.

Step 4  Enter the MAC address of the device for which you want to do the voice diagnosis test.

Step 5  Select the device type. It could be either a cisco based phone or custom phones. If it is a custom phone you have to enter the RSSI range for the custom phone. For Cisco phones the RSSI range is preselected.

Step 6  Click StartTest to start the test or if the test is completed you can restart the test.

Note  If the test is not completed the state is Running and if test is completed then the state is Completed. To stop the test in between, you can use the Stop button, the state is then stopped.

Viewing Voice Diagnostic Test Reports

The Test Reports is shown using tabular data. There are four main tabs. This section contains the following topics:

- Summary Tab, page 17-14
- Charts Tab, page 17-16
- Roam History Tab, page 17-18
- Events Tab, page 17-19

Summary Tab

This tab is divided into three areas where top area displays the test and client details, the middle area displays the problems, and the bottom area displays the corresponding log messages. Figure 17-4 represents the Summary

Figure 17-4  Summary Tab - Test Status
Test and Client Details

The test status displays the test details like the Test Name, First Client MAC address, Second Client MAC address, device type, test status, start time, remaining time and the duration of the test. Restart if the test was stopped or completed the test. A stop button is provided to Stop the running test. The Refresh Status Tab and Refresh Client Tab buttons is used to refresh the status and client details. Figure 17-5 represents the Client details Summary tab.

**Figure 17-5  Summary Tab - Client Details**

![Image of Client details Summary tab]

The client details such as the client user name, IP address, MAC address, Vendor, CCX Version, 802.11 state, protocol, SSID, profile-name, and AP details are displayed. You can click the Client MAC address for more client details.

Problems

The Problems pane appears below the test and client status details pane. This pane displays all the problems regarding the current diagnosis. This pane is updated every 5 seconds independently. There is no need to refresh the whole page. You can sort the information in this pane by clicking on any of the pane columns. A pop-up dialog box appears with the Problem detailed description and Suggested action when you click any row of the Problems pane. (See Figure 17-6)

**Figure 17-6  Problem Description**

![Image of Problem Description]

Note In some cases of inter controller roaming failure, the MAC address in the From AP information is incorrect and may appear as “00:00:00:00:00:00”.
Logs

The Logs pane appears below the Problems pane. This pane displays all the messages exchanged between the controller and the WCS during this diagnosis. You can sort the information in this pane by clicking on any of the pane columns. This pane is updated every 5 sec independently without refreshing the whole page. (See Figure 17-7).

Figure 17-7 Logs

<table>
<thead>
<tr>
<th>Time</th>
<th>Client-IP</th>
<th>AP Name</th>
<th>Radio</th>
<th>Controller</th>
<th>Mobile</th>
<th>Security</th>
<th>Message</th>
</tr>
</thead>
</table>

Charts Tab

This tab displays the charts for each client’s uplink and downlink traffic. The charts will be updated every 10 secs.

Client Uplink and DownLink TSM Chart with Roaming

The Client Uplink Traffic Stream Metric (TSM) chart shows the clients which support CCX V4 and above. The TSM data is plotted for every 10 sec. The TSM Chart displays the metrics for a set of series, that can be enabled or disabled using the Select Series button in the chart. Figure 17-8 represents the Client Uplink TSM Chart with Roaming.

Figure 17-8 Client Uplink TSM Chart with Roaming
Client Uplink and DownLink QoS Chart

For each interval, QoS will be calculated and shown on the chart. Figure 17-9 represents the Client Uplink QoS chart.

**Figure 17-9  Client Uplink QoS Chart**

This pie chart provides the total Qos Chart counts and its distribution in three categories. These categories generally indicate the quality of a voice call.

Average Uplink and Downlink AC Queue

The AC Queue displays the type of packets and the number of packets for a series. You can enable or disable the series using the Select Series button.
Roam History Tab

This tab shows the roaming history information in the Roaming Table. This Roaming table displays both the successful and the failed roaming history. The roaming table provides the following information (see Figure 17-11):

- Time at which the roaming of the client happened
- The name of the AP from which the client moved
- The type of Radio from which the client moved
- The IP address of the controller from which the client moved
- The name of the AP to which the client moved
- The IP address of the controller to which the client moved
- The type of radio to which the client moved
- The roaming result, whether it was successful or a failure
- If it was a failure it also provides the reason to the failure
Events Tab

The Event tab shows the event history related to client and AP during a voice call in a list. It will show last 10 events. There is two Event tables available, Client Events and AP Events. Client Specific events during the voice call is shown in the Client Events table and AP Specific events in shown in the AP Event table. See Figure 17-12 and Figure 17-13).

Figure 17-12  Client Events

![Client Events Table]

Figure 17-13  AP Events

![AP Events Table]

For more information on events, see the “Monitoring Events” section on page 6-124.
Configuring Audit Summary

Choose **Tools > Config Audit** to launch the Configuration Audit Summary page (see **Figure 17-14**).

**Figure 17-14  Tools > Config Audit Summary Page**

<table>
<thead>
<tr>
<th>Summary</th>
<th>Count</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total Enforced Config Groups</td>
<td>0</td>
</tr>
<tr>
<td>Total Mismatched Controllers</td>
<td>5</td>
</tr>
<tr>
<td>Total Config Audit Alarms</td>
<td>7</td>
</tr>
</tbody>
</table>

*Next recent 5 Audit Alarms (View All)*

<table>
<thead>
<tr>
<th>Object</th>
<th>Event Type</th>
<th>Date/Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controller TA20...</td>
<td>Config Audit</td>
<td>Apr 10, 2009 11:00:07 PM</td>
</tr>
<tr>
<td>Controller 172.16.20.101</td>
<td>Config Audit</td>
<td>Apr 10, 2009 11:00:07 AM</td>
</tr>
<tr>
<td>Controller 172.16.20.101</td>
<td>Config Audit</td>
<td>Apr 10, 2009 11:00:07 AM</td>
</tr>
<tr>
<td>Controller 172.16.20.101</td>
<td>Config Audit</td>
<td>Apr 10, 2009 11:00:05 AM</td>
</tr>
<tr>
<td>Controller 172.16.20.101</td>
<td>Config Audit</td>
<td>Apr 10, 2009 11:00:03 AM</td>
</tr>
</tbody>
</table>

Choose **Tools > Config Audit** to launch the Configuration Audit Summary page (see **Figure 17-14**).
This page provides a summary of the following:

- **Total Enforced Config Groups**—Identifies the count of config group templates which are configured for Background Audit and enforcement enabled.

  Click the link to launch the Config Group page to view config groups with Enforce Configuration enabled.

- **Total Mismatched Controllers**—Identifies the number of mismatched controllers. Mismatched controllers indicate that there were configuration differences found between the WCS and the controller during the last audit.

  Click the link to launch the controller list sorted on the mismatched audit status column. Click an item in the Audit Status column to view the audit report for this controller.

- **Total Config Audit Alarms**—Identifies the number of alarms generated when audit discrepancies are enforced on config groups.

  Click the link to view all config audit alarm details.

  **Note**

  If enforcement fails, a critical alarm is generated on the config group. If enforcement succeeds, a minor alarm is generated on the config group. The alarms have links to the audit report where you can view list of discrepancies for each controller.

- **Most recent 5 audit alarms**—Lists the most recent configuration audit alarms including the object name, event type, and date and time for the audit alarm.

  Click View All to view the applicable Alarm page which includes all configuration audit alarms.

---

**Configuring Migration Analysis**

Choose **Tools > Migration Analysis** to launch the Configuration Migration Analysis Summary page.

**Note**

You can also access the migration analysis summary by choosing **Configure > Migration Templates** and selecting **View Migration Analysis Summary** from the Select a command drop-down list.

The autonomous access points are eligible for migration only if all the criteria has a pass status. A red X designates ineligibility, and a green check mark designates eligibility. These columns represent the following:

- **Privilege 15 Criteria**—The Telnet credential provided as part of the autonomous access point discovery must be privilege 15.

- **Software Version**—Conversion is supported only from 12.3(7)JA releases excluding 12.3(11)JA, 12.3(11)JA1, 12.3(11)JA2, and 12.3(11)JA3.

- **Role Criteria**—A wired connection between the access point and controller is required to send the association request; therefore, the following autonomous access point roles are required:
  - root
  - root access point
  - root fallback repeater
  - root fallback shutdown
  - root access point only
Radio Criteria—In dual-radio access points, the conversion can happen even if only one radio is of the supported type.

**Upgrading Autonomous Access Points**

You can choose to upgrade the autonomous access points manually or automatically. In the Migration Analysis page, you can select the access point with the software version listed as failed and choose **Upgrade Firmware** from the Select a command drop-down list. This process upgrades the autonomous firmware image of the Cisco IOS access point to a supported version.

WCS uses a Telnet-based connection to upgrade the access point firmware. If you choose the automatic option, the internal TFTP server is used with the default images present in WCS. The default images as per device type are as follows:

- `ap801-k9w7-tar.124-10b.JA3.tar`
- `ap802-k9w7-tar`
- `c1100-k9w7-tar.123-7.JA5.tar`
- `c1130-k9w7-tar.123-7.JA5.tar`
- `c1200-k9w7-tar.123-7.JA5.tar`
- `c1240-k9w7-tar.12307.JA5.tar`
- `c1250-k9w7-tar.124-10b.JA3.tar`
- `c1310-k9w7-tar.123-7.JA5.tar`

If you choose the manual option, you are presented with an additional screen where TFTP server IP, file path, and file path name must be entered. The final page is the report page.

**Viewing a Firmware Upgrade Report**

Choose **View Firmware Upgrade Report** from the Select a command drop-down list to view a current report of the upgrade status for the selected access point.

The following information displays:

- **AP Address**—IP address of the access point.
- **Status**—Current status of the firmware upgrade.
- **TimeStamp**—Indicates the date and time of the upgrade.
- **AP Logs**

Click **OK** to return to the Migration Analysis Summary page.

See the “**Upgrading Autonomous Access Points**” section on page 17-22 for more information.

**Changing Station Role to Root Mode**

Because a wired connection between the access point and controller is required to send the association request, the autonomous access point must be assigned the appropriate role. If the role shows as ineligible, you can choose **Change Station Role to Root Mode** from the Select a command drop-down list.
Viewing a Role Change Report

Because a wired connection between the access point and controller is required to send the association request, the autonomous access point must be assigned the appropriate role.

To view a report of these role changes, choose View Role Change Report from the Select a command drop-down list. The following information displays:

- AP Address—IP address of the access point.
- Status—Current status of the role change.
- TimeStamp—Indicates the date and time of the upgrade.
- AP Logs

Click OK to return to the Migration Analysis Summary page.

Running Migration Analysis

You can choose Run Migration Analysis from the Select a command drop-down list of the Migration Analysis Summary page. The resulting migration analysis summary shows the current status of different criteria. Initially, migration analysis is run automatically when the access point is discovered.

Viewing a Migration Analysis Report

You can choose View Migration Analysis Report from the Select a command drop-down list of the Migration Analysis Summary page to generate a report. The report includes the following:

- Access point address
- Status
- Timestamp
- Access point logs

Configuring TAC Case Attachments

Note: You must configure a valid mail server before configuring TAC case attachments.

TAC Case Attachment tool helps you easily attach all the relevant controller TAC cases information in one shot. This tool provides two options:

- Send—Sends an email to attach@cisco.com.
- Download—Downloads the information to a local computer. You have to manually email the data to attach@cisco.com. This option will be handy if there are no email connectivity between WCS server and Cisco system or if the information is too big to be attached through email.

This tool sends the following information:

- Network Information—Sends device inventory details and the client types.
• Controller Information—Sends running configuration details, tech-support, message logs, trap logs, controller crash files.

• Access Point Information—Sends crash files and radio core-dumps.

To Send or Download information, you have to enter the following details:

• Enter a Valid TAC Case Number.

• Select a controller if you want to send the controller or AP information.

Note: You can also send additional information using the additional comments text box. After sending the information you can verify whether the data has reached Cisco by looking at the attachment section in Case tool.

Note: This tool requires read-write access on the controller to collect and upload Controller or Access Point information.
Configuring Virtual Domains

This chapter describes how to perform basic operations like uploading or downloading a file on a controller, scheduling administrative tasks through Cisco WCS, and creating user accounts and groups.

This chapter contains the following sections:

- Information About Virtual Domains, page 18-1
- Configuring a Virtual Domain, page 18-2
- Understanding Virtual Domain Hierarchy, page 18-4
- Managing a Virtual Domain, page 18-7
- Virtual Domain RADIUS and TACACS+ Attributes, page 18-10

Information About Virtual Domains

A WCS Virtual Domain consists of a set of WCS devices and/or maps and restricts a user view to information relevant to these managed objects.

Through a virtual domain, an administrator can ensure that users are only able to view the devices and maps for which they are responsible. In addition, because of the virtual domain filters, users are able to configure, view alarms, generate reports for only their assigned part of the network.

The following elements can be partitioned in a virtual domain: maps, controllers, access points, templates, and config groups.

The following cannot be partitioned in a virtual domain (and are only available from the root partition: Google Earth Maps, Auto Provisioning, and Mobility Services).

The administrator specifies for each user a set of allowed virtual domains. Only one of these can be active for that user at login. The user can change the current virtual domain by selecting a different allowed virtual domain from the Virtual Domain drop-down list at the top of the page. All reports, alarms, and other functionality are now filtered by that virtual domain.

If there is only one virtual domain defined ("root") in the system AND the user does not have any virtual domains in the custom attributes fields in the TACACS+/RADIUS server, the user is assigned the "root" virtual domain by default.

If there is more than one virtual domain, and the user does not have any specified attributes, then the user is blocked from logging in.
**Configuring a Virtual Domain**

Use the Administration > Virtual Domain page to create, edit, or delete virtual domains. Each virtual domain may contain a subset of the elements included with its parent virtual domain. You can assign additional maps, controllers, and access points to the new virtual domain. See the “Managing a Virtual Domain” section on page 18-7 for more information on managing virtual domains.

- **New**—Click to create a new virtual domain. See the “Creating a New Virtual Domain” section on page 18-2 for more information.
- **Delete**—Click to delete the selected virtual domain from the hierarchy.
- **Export**—Click to configure custom attributes for the selected virtual domain. See the “Virtual Domain RADIUS and TACACS+ Attributes” section on page 18-10 for more information.

**Note**
WCS supports up to 252 virtual domain in version 5.2 and later. For versions prior to 5.2, WCS supports up to 124 virtual domains.

---

**Creating a New Virtual Domain**

See the “Managing a Virtual Domain” section on page 18-7 for more information.

To create a new virtual domain, follow these steps:

**Step 1** Choose Administration > Virtual Domains.

**Step 2** From the left Virtual Domain Hierarchy sidebar menu, select to highlight the virtual domain to which you want to add a sub (child) virtual domain.

**Note** The selected virtual domain becomes the parent virtual domain of the newly-created sub-virtual domain.

**Step 3** Click New (see Figure 18-1).
Step 4  Enter the virtual domain name in the text box.

Step 5  Click **Submit** to create the virtual domain or **Cancel** to close the page with no changes.

**Note**  Each virtual domain may contain a subset of the elements included with its parent virtual domain. When a user is assigned a virtual domain, that user may view the same maps, controllers, and access points that are assigned to its parent virtual domain.

**Note**  To modify or update a current virtual domain name or description, choose **Administration > Virtual Domains**. From the left Virtual Domain Hierarchy sidebar menu, click the virtual domain you want to edit.
Understanding Virtual Domain Hierarchy

Virtual domains are organized hierarchically. Sub-sets of an existing virtual domain contain the network elements that are contained in the parent virtual domain.

| Note | The default or "root" domain includes all virtual domains. |

Because network elements are managed hierarchically, some features and components such as report generation, searches, templates, config groups, and alarms are affected.

| Note | If you create a virtual domain with only access points and no controllers assigned, you lose some ability to choose controller-based features. For example, some options require you to drill down from controller to access points. Because controllers are not in the virtual domain, you are not able to generate associated reports. If you create a partition with only a few controllers and then go to Configure > Access Points and click an individual link in the AP Name column, the complete list of WCS-assigned controllers is displayed for primary, secondary and tertiary controllers rather than the limited number specified in the partition. |

| Note | If a controller’s configuration is modified by multiple Virtual Domains, complications may arise. To avoid this, manage each controller from only one Virtual Domain at a time. |

This section helps you to better understand the effects of partitioning and contains the following topics.

- Reports, page 18-4
- Search, page 18-5
- Alarms, page 18-5
- Templates, page 18-5
- Config Groups, page 18-6
- Maps, page 18-6
- Access Points, page 18-6
- Controllers, page 18-7
- Email Notification, page 18-7

Reports

Reports only include components assigned to the current virtual domain. For example, if you create a virtual domain with only access points and no controllers assigned, all controllers do not display when you generate a controller inventory report.

If you create a virtual domain with only access points and no controllers assigned, you lose some ability to choose controller-based features. For example, some options require you to drill down from controller to access points. Because controllers are not in the virtual domain, you are not able to generate associated reports.
Note
Reports are only visible in the current virtual domain. The parent virtual domain cannot view the reports from its sub-virtual domain.

Client reports such as Client Count only include clients that belong to the current virtual domain.

Note
If new clients are assigned to this partition by the administrator, the previous reports do not reflect these additions. Only new reports will reflect the new clients.

Search

Search results only include components that are assigned to the virtual domain in which the search is performed. Search results do not display floor areas when the campus is not assigned to the virtual domain.

Note
The saved searches are only visible in the current virtual domain. The parent virtual domain cannot view these search results.

Note
WCS does not partition network lists. If you search a controller by network list, all controllers will be returned.

Note
Search results do not display floor areas when the campus is not assigned to the virtual domain.

Alarms

When a component is added to a virtual domain, no previous alarms for that component are visible to that virtual domain. Only newly-generated alarms are visible. For example, when a new controller is added to a virtual domain, any alarms generated for that controller prior to its addition do not appear in the current virtual domain.

Alarms are not deleted from a virtual domain when the associated controllers or access points are deleted from the same virtual domain.

Note
Alarm Email Notifications—Only the root virtual domain can enable Location Notifications, Location Servers, and WCS email notifications.

Templates

When you create or discover a template in a virtual domain, it is only available in that virtual domain unless it is applied to a controller. If it is applied to a controller and that controller is assigned to a sub-virtual domain, the template stays with the controller in the new virtual domain.

Note
If you create a sub virtual domain and then apply a template to both network elements in the virtual domain, WCS may incorrectly reflect the number of partitions to which the template was applied.
Config Groups

Config groups in a virtual domain can also be viewed by the parent virtual domain. A parent virtual domain can modify config groups for a sub (child) virtual domain. For example, the parent virtual domain can add or delete controllers from a sub virtual domain.

Maps

You can only view the maps that your administrator assigned to your current virtual domain.

- When a campus is assigned to a virtual domain, all buildings in that campus are automatically assigned to the same virtual domain.
- When a building is assigned to a virtual domain, it automatically includes all of the floors associated with that building.
- When a floor is assigned, it automatically includes all of the access points associated with that floor.

Note: If only floors are assigned to a virtual domain, you lose some ability to choose map-based features. For example, some reports and searches require you to drill down from campus to building to floor. Because campus and buildings are not in the virtual domain, you are not able to generate these kinds of reports or searches.

Note: Coverage areas shown in WCS are only applied to campus and buildings. In a floor-only virtual domain, WCS does not display coverage areas.

Note: If a floor is directly assigned to a virtual domain, it cannot be deleted from the virtual domain which has the building to which the floor belongs.

Note: Search results do not display floor areas when the campus is not assigned to the virtual domain.

Access Points

When a controller or map is assigned to a virtual domain, the access points associated with the controller or map are automatically assigned as well. Access points can also be assigned manually (separate from the controller or map) to a virtual domain.

Note: If the controller is removed from the virtual domain, all of its associated access points are also removed. If an access point is manually assigned, it remains assigned even if its associated controller is removed from the current virtual domain.

Note: If you create a virtual domain with only access points and no controllers assigned, you lose some ability to choose controller-based features. For example, some options require you to drill down from controller to access points. Because controllers are not in the virtual domain, you are not able to generate associated reports.
Chapter 18  Configuring Virtual Domains

Managing a Virtual Domain

Note

If a manually-added access point is removed from a virtual domain but is still associated with a controller or map that is assigned to the same virtual domain, the access point remains visible in the virtual domain. Any alarms associated with this access point are not deleted with the deletion of the access point.

Note

When maps are removed from a virtual domain, the access points on the maps can be removed from the virtual domain.

Note

If you later move an access point to another partition, some events (such as generated alarms) may reside in the original partition location.

Note

Rogue access point partitions are associated with one of the detecting access points (the one with the latest or strongest RSSI value). If there is detecting access point information, WCS uses the detecting controller. If the rogue access point is detected by two controllers which are in different partitions, the rogue access point partition may be changed at any time.

Controllers

Because network elements are managed hierarchically, controllers may be affected by partitioning. If you create a virtual domain with only access points and no controllers assigned, you lose some ability to choose controller-based features. For example, some options require you to drill down from controller to access points. Because controllers are not in the virtual domain, you are not able to generate associated reports.

If you create a partition with only a few controllers and then choose Configure > Access Points and click an individual link in the AP Name column, the complete list of WCS-assigned controllers is displayed for primary, secondary and tertiary controllers rather than the limited number specified in the partition.

Note

If a controller configuration is modified by multiple Virtual Domains, complications may arise. To avoid this, manage each controller from only one Virtual Domain at a time.

Email Notification

Email notification can be configured per virtual domain. An email is sent only when alarms occur in that virtual domain.

Managing a Virtual Domain

Select a Virtual Domain from the Virtual Domain Hierarchy on the left side to view or edit its assigned maps, controllers, and access points. The Summary page displays with links to view the current logged in virtual domain available maps, controllers, and access points.
Managing a Virtual Domain

Note Because all maps, controllers, and access points are included in the partition tree, you should expect this page to take several seconds to load.

The Maps, Controllers, and Access Points tabs are used to add or remove components assigned to this virtual domain.

To assign a map, controller, or access point to this domain, follow these steps:

**Step 1** Choose Administration > Virtual Domains.

**Step 2** Choose Virtual Domain Hierarchy from the left sidebar menu.

Note Because all maps, controllers, and access points are included in the partition tree, you should expect it to take several minutes to load. This increases if you have a system with a significant number of controllers and access points.

**Step 3** Click the applicable Maps, Controller, or Access Points tab.

**Step 4** In the Available (Maps, Controllers, or Access Points) column, click to highlight the new component(s) you want to assign to the virtual domain.

**Step 5** Click Add to move the component(s) to the Selected (Maps, Controllers, or Access Points) column (see Figure 18-2).
### Configuring Virtual Domains

#### Chapter 18

**Managing a Virtual Domain**

**Figure 18-2**  
Virtual Domains Maps Tab

Note: To remove a component from the virtual domain, click to highlight the component in the Selected (Maps, Controllers, or Access Points) column and click Remove. The component returns to the Available column.

**Step 6**  
Click **Submit** to confirm the changes.

**Note**  
After assigning elements to a virtual domain and submitting the changes, WCS may take a long time to process depending on how many elements are added.
Virtual Domain RADIUS and TACACS+ Attributes

The Virtual Domain Custom Attributes page allows you to indicate the appropriate protocol-specific data for each virtual domain. The Export button on the Virtual Domain Hierarchy sidebar menu pre-formats the virtual domain RADIUS and TACACS+ attributes. You can copy and paste these attributes into the ACS server. This allows you to copy only the applicable virtual domains into the ACS server page and ensures that the users only have access to these virtual domains.

To apply the pre-formatted RADIUS and TACACS+ attributes to the ACS server, follow these steps:

1. Choose Administration > Virtual Domains.
2. From the left Virtual Domain Hierarchy sidebar menu, select to highlight the virtual domain for which you want to apply the RADIUS and TACACS+ attributes.
3. Click Export.
4. Highlight the text inside of the RADIUS or TACACS+ Custom Attributes (depending on which one you are currently configuring), go to your browser's menu, and choose Edit > Copy.
5. Log in to ACS.
6. Go to User or Group Setup.
7. For the applicable user or group, click Edit Settings.
8. Use your browser Edit > Paste feature to place the RADIUS or TACACS+ custom attributes into the applicable field.
9. Select the check boxes to enable these attributes.
10. Click Submit + Restart.

If you want to specify virtual domains on a per user basis, then you need to make sure you add ALL the custom attributes (for example, tasks, roles, virtual domains) information into the User custom attribute page.

Understanding Virtual Domains as a User

When you log in, you can access any of the virtual domains that the administrator assigned to you.

Only one virtual domain can be active at login. You can change the current virtual domain by using the Virtual Domain drop-down list at the top of the page. Only virtual domains that have been assigned to you are available in the drop-down list.

When you select a different virtual domain from the drop-down list, all reports, alarms, and other functionality are filtered by the conditions of the new virtual domain.
Viewing Assigned Virtual Domain Components

To view all components (including maps, controllers, and access points) assigned to the current virtual domain, choose Administration > Virtual Domains (see Figure 18-3). Click a link on the Summary tab to view the assigned components for your virtual domain.

Limited Menu Access

Non-root virtual domain users do not have access to the following WCS menus:

- Monitor > RRM
- Configure > Auto Provisioning
- Configure > ACS View Servers
- Mobility > Mobility Services
- Mobility > Synchronize Servers
- Administration > Background Tasks
- Administration > Settings
- Administration > User Preferences
- Tools > Voice Audit
- Tools > Config Audit
Monitoring Google Earth Maps

Within Monitor > Google Earth Maps, you can create an outdoor location, import a file, view Google Earth maps, and specify Google Earth settings.

This chapter contains the following sections:
- Creating an Outdoor Location Using Google Earth, page 19-1
- Importing a File into WCS, page 19-5
- Viewing Google Earth Maps, page 19-6
- Adding Google Earth Location Launch Points to Access Point Pages, page 19-7

Creating an Outdoor Location Using Google Earth

To group the access points together into outdoor locations, use the Latitude/Longitude geographical coordinates for each access point. These coordinates are provided in two ways:
- Importing a KML (Google Keyhole Markup Language) File
- Importing a CSV File (Spreadsheet format with comma-separated values)

Understanding Geographical Coordinates for Google Earth

The following geographical information is required for each access point:

Note: Before you can add coordinates for an access point, you must add the access point to a standard map. Positions will not show up on access points without heatmaps.

- Longitude (East or West)—Angular distance in degrees relative to Prime Meridian. Values west of Meridian range from −180 to 0 degrees. Values east of Meridian range from 0 to 180 degrees. The default is 0.
  - Coordinates in degrees, minutes, seconds, direction:
    - Degrees (−180 to 180)
    - Minutes (0 to 59)
    - Seconds (00.00 to 59.99)
    - Direction—East or West (E, W)
Creating an Outdoor Location Using Google Earth

Decimal format (converted from degrees, minutes, and seconds):
- Longitude can range from –179.59.59.99 W to 179.59.59.99 E
- Latitude (North or South)—Angular distance in degrees relative to the Equator. Values south of the Equator range from –90 to 0 degrees. Values north of the Equator range from 0 to 90 degrees. The default is 0.

Coordinates in degrees, minutes, seconds, direction:
- Degrees (–90 to 90)
- Minutes (0 to 59)
- Seconds (00.00 to 59.99)
- Direction—North or South (N, S)

Decimal format (converted from degrees, minutes, and seconds):
- Latitude can range from –89.59.59.99 S to 89.59.59.99 N

- Altitude—Height or distance of the access point from the earth’s surface in meters. If not provided, value defaults to 0. Values range from 0 to 99999.
- Tilt—Values range from 0 to 90 degrees (cannot be negative). A tilt value of 0 degrees indicates viewing from directly above the access point. A tilt value of 90 degrees indicates viewing along the horizon. Values range from 0 to 90. The default azimuth angle is 0.
- Range—Distance in meters from the point specified by longitude and latitude to the point where the access point is being viewed (the Look At position)(camera range above sea level). Values range from 0 to 999999.
- Heading—Compass direction in degrees. The default is 0 (North). Values range from 0 to ±180 degrees.
- Altitude Mode—Indicates how the <altitude> specified for the Look At point is interpreted.
  - Clamped to ground—Ignores the <altitude> specification and places the Look At position on the ground. This is the default.
  - Relative to ground—Interprets the <altitude> as a value in meters above the ground.
  - Absolute—Interprets the <altitude> as a value in meters above sea level.
- Extend to ground—Indicates whether or not the access point is attached to a mast.

Creating and Importing Coordinates in Google Earth (KML File)

The geographical coordinates can be created in Google Earth and imported. Either a folder or individual placemarks can be created. Creating a folder helps group all the Placemarks into a single folder and allows you to save the folder as a single KML (a.k.a. XML) file. If individual Placemarks are created, each Placemark must be individually saved.

To create a folder in Google Earth, follow these steps:

**Step 1** Launch Google Earth.

**Step 2** In the Places page on the left sidebar menu, choose My Places or Temporary Places.

**Step 3** Right-click Temporary Places and select Add > Folder from the drop-down lists.
Chapter 19  Monitoring Google Earth Maps

Creating an Outdoor Location Using Google Earth

Note
By using a KML file, folders can be created hierarchically to any depth. For example, you can create folders and placemarks organized by country, city, state, zip. This is not applicable for CSV. In CSV there can be only one level of hierarchy.

Step 4 Enter the following information (optional):
- Name—Folder name
- Description—Folder description
- View—Includes latitude, longitude, range, heading, and tilt

Note
If the View coordinates (latitude, longitude, range, heading, and tilt) are specified, this information is used to “fly” or advance to the correct location when Google Earth is first loaded. If no coordinates are specified, the latitude and longitude information is derived using the minimum and maximum latitude and longitude of all access points within this group or folder.

Step 5 Click OK to save the folder. After the folder is created, it can be selected from the Places page to create Placemarks.

To create Placemarks, follow these steps:

Step 1 Launch Google Earth.
Step 2 In the Places page on the left sidebar, select My Places or Temporary Places.
Step 3 Select the folder that you previously created.
Step 4 Right-click your created folder and select Add > Placemark from the drop-down lists.
Step 5 Configure the following parameters, if applicable:
- Name—The Placemark name must contain the name, MAC address, or IP address of the appropriate access point.

Note
The MAC address refers to base radio MAC not Ethernet MAC.

- Latitude—Provides the current coordinate for the folder if the placemark is created inside the folder or the coordinate for the placemark (if not created inside a folder). This parameter is automatically filled depending on where the yellow Placemark icon is located on the map. Use your mouse to move the Placemark to the correct location or enter the correct coordinate in the Latitude text box.
- Longitude—Provides the current coordinate for the folder if the placemark is created inside the folder or the coordinate for the placemark (if not created inside a folder). This parameter is automatically filled depending on where the yellow Placemark icon is located on the map. Use your mouse to move the Placemark to the correct location or enter the correct coordinate in the Longitude text box.
- Description (optional)—Parameter is ignored by WCS.
- Style, Color (optional)—Parameter is ignored by WCS.
Creating an Outdoor Location Using Google Earth

- **View**—Allows you to configure the Latitude, Longitude, Range, Heading and Tilt coordinates. See the “Understanding Geographical Coordinates for Google Earth” section on page 19-1” for more information on these geographical coordinates.
  - Longitude and latitude are automatically filled depending on where the yellow Placemark icon is located on the map. Use your mouse to click and move the Placemark to the correct location.
  - All of the coordinates can be entered manually.
- **Altitude**—Enter the altitude in meters in the text box or use the Ground to Space slide bar to indicate the altitude.
  - Clamped to ground—Indicates that the Look At position is on the ground. This is the default.
  - Relative to ground—Interprets the <altitude> as a value in meters above the ground.
  - Absolute—Interprets the <altitude> as a value in meters above sea level.
  - Extend to ground—for Relative to ground or Absolute settings, indicates whether or not the access point is attached to a mast.

**Step 6** When all coordinates are entered, click **Snapshot current view** or click **Reset** to return the coordinates to the original settings.

---

**Note** For more information regarding Google Earth, refer to the Google Earth online help.

**Step 7** Click **OK**.

**Step 8** Repeat these steps for all placemarks you want to add.

**Step 9** When all placemarks are created, save the folder as a .kmz file (KML Zip file) or as a .kml file.

---

**Note** A .kmz file should contain only one .kml file.

---

**Note** To save the folder, right-click the folder, select **Save as** from the drop-down list, navigate to the correct location on your computer, and click **Save**. Both .kmz and .kml files can be imported into WCS.

---

**Creating and Importing Coordinates as a CSV File**

To create a CSV file to import into WCS, follow these steps:

**Step 1** Open a flat file and provide the necessary information as a comma-separated list. The Table 19-1 lists the potential data, whether the data is optional or required, and the parameters of the data.

---

**Note** For more information regarding the geographical coordinates listed, see the “Understanding Geographical Coordinates for Google Earth” section on page 19-1.
Chapter 19  Monitoring Google Earth Maps

Creating an Outdoor Location Using Google Earth

Step 2  Save the .csv file. The file is now ready to import into WCS.

### Importing a File into WCS

To import a Google KML or a CSV into the Google Earth Maps feature of WCS, follow these steps:

**Step 1**  Log in to WCS.

**Step 2**  Choose **Monitor > Google Earth Maps**.

**Step 3**  From the Select a command drop-down list, choose **Import Google KML** or **Import CSV**.

**Step 4**  Click **Go**.

**Step 5**  Use the Browse button to navigate to the .kml, .kmz, or .csv file on your computer.

**Step 6**  When the file name path is displayed in the text box, click **Next**.

The input file is parsed and validated for the following:

- Access points specified in the uploaded file are validated (the specified access points must be available within WCS).
- Range validations are performed for tilt, heading, range, and other geographical coordinates fields. If longitude and latitude are provided, range validations are performed; if not, the value is defaulted to 0.
Creating an Outdoor Location Using Google Earth

Note
In KML, the longitude and latitude ranges can only be entered in decimal format. In CSV, different formats are supported (refer to the CSV sample under Google Maps > Import CSV).

Note
If the input file does not validate for completeness, an error page appears. The uploaded information cannot be saved until all errors are corrected.

Step 7
After the files pass all validation checks, review the file details, and click Save.
If the uploaded information was saved previously, the information is overwritten accordingly:
• If the folder was uploaded previously, the coordinates are updated for the folder.
• If access points were uploaded previously, the coordinates are updated for the access points.
• Existing access points in the folder are not removed.
• New folders, as needed, are created and access points are placed accordingly.

Viewing Google Earth Maps
To view Google Earth maps, follow these steps:

Step 1
Log in to WCS.

Step 2
Choose Monitor > Google Earth Maps. The Google Earth Maps page displays all folders and the number of access points included within each folder.

Step 3
Click Launch for the map you want to view. Google Earth opens in a separate page and displays the location and its access points.

Note
To use this feature, you must have Google Earth installed on your computer and configured to auto-launch when data is sent from the server. You can download Google Earth from Google’s website.

Viewing Google Earth Map Details
To view details for a Google Earth Map folder, follow these steps:

Step 1
In the Google Earth Map page, click the folder name to open the details page for this folder. The Google Earth Details provide the access point names and MAC or IP addresses.

Note
To delete an access point, select the applicable check box, and click Delete. To delete the entire folder, select the check box next to Folder Name, and click Delete. Deleting a folder also deletes all subfolders and access points inside the folder.
**Step 2** Click **Cancel** to close the details page.

---

**Adding Google Earth Location Launch Points to Access Point Pages**

You can expand the number of Google Earth Location launch points within Cisco WCS by adding it to the Access Point summary and detail pages.

Follow these steps to add a Google Earth Location launch point to the Access Point summary and details page:

**Step 1** Click **Monitor > Access Points** (see Figure 19-1).

**Step 2** At Access Point summary page, click the **Edit View** link next to page heading.

**Figure 19-1  Monitor > Access Points Page**

---

**Step 3** In the Edit View page, highlight **Google Earth Location** in the left-hand column. Click **Show** (see Figure 19-2).

The Google Earth Location column heading moves into the View Information column.
Google Earth Settings

Access point related settings can be defined from the Google Earth Settings page. To configure access point settings for the Google Earth Maps feature, follow these steps:

**Step 1**  
Choose Monitor > Google Earth Maps.

**Step 2**  
Configure the following parameters:

- **Refresh Settings**—Select the **Refresh from Network** check box to enable this on-demand refresh. This option is applied only once and then disabled.

**Caution**  
Because this refresh occurs directly from the network, it could take a long period of time to collect data according to the number of access points.
- Layers—Layer filters for access points, access point heat maps, and access point mesh information can be selected and saved. Select the check box to activate the applicable layer and click > to open the filter page.

**Note** These settings apply when Google Earth sends the request for the next refresh.

- Access Points—From the AP Filter drop-down list, choose to display channels, Tx power level, coverage holes, MAC addresses, names, controller IP, utilization, profiles, or clients.

**Note** If the access point layer is not checked, no data is returned, and an error message is returned to Google Earth as a Placemark without an icon.

- AP Heatmap—From the Protocol drop-down list, choose 802.11a/n, 802.11b/g/n, 802.11a/n & 802.11b/g/n, or None. Select the cutoff from the RSSI Cutoff drop-down list (-60 to -90 dBm).

**Note** If the protocol chosen is both 802.11a/n and 802.11b/g/n, the heat maps are generated for both and overlaid on top of each other. The order cannot be defined. To prevent this overlay, you must turn off individual overlay in Google Earth or change it in the Google Earth Settings on WCS.

- AP Mesh Info—Choose Link SNR, Packet Error Rate, or none from the Link Label drop-down list. Choose Link SNR or Packet Error Rate from the Link Color drop-down list.

**Note** When the AP Mesh Info check box is selected, Mesh Links are also automatically shown.

**Step 3** Click Save Settings to confirm these changes or Cancel to close the page without saving the changes.
Security IDS/IPS Overview

The addition of WLANs in the corporate environment introduces a new class of threats for network security. RF signals that penetrate walls and extend beyond intended boundaries can expose the network to unauthorized users. Rogue access points installed by employees for their personal use usually do not adhere to the corporate security policy. A rogue access point can put the entire corporate network at risk for outside penetration and attack. Not to underestimate the threat of the rogue access point, there are many other wireless security risks and intrusions such as mis-configured and unconfigured access points and DoS (denial of service) attacks.

The Cisco Adaptive Wireless IPS is designed to help manage against security threats by validating proper security configurations and detecting possible intrusions. With the comprehensive suite of security monitoring technologies, the Cisco Adaptive Wireless IPS alerts the user on more than 100 different threat conditions in the following categories:

- User authentication and traffic encryption
- Rogue and ad-hoc mode devices.
- Configuration vulnerabilities
- Intrusion detection on security penetration
- Intrusion detection on DoS attacks

To maximize the power of the Cisco Adaptive Wireless IPS, security alarms can be customized to best match your security deployment policy. For example, if your WLAN deployment includes access points made by a specific vendor, the product can be customized to generate the rogue access point alarm when an access point made by another vendor is detected by the access point or sensor.

Note

The wIPS Local Mode or HREAP Mode Access points does not support all security alarms. The magnifying glass icon indicates that this alarm is not supported by the wIPS Local Mode or HREAP Mode Access points.

Pre-configured profiles for various WLAN environments

During installation, the user can select an appropriate profile based on the WLAN network implemented. The Cisco Adaptive Wireless IPS provides separate profiles for the following:

- Enterprise best practice
- Enterprise rogue detection only
Financial (Gramm-Leach-Bliley Act compliant)
Healthcare (Health Insurance Portability and Accountability Act compliant)
Hotspot implementing 802.1x security
Hotspot implementing NO security
Tradeshow environment
Warehouse/manufacturing environment
Government/Military (8100.2 directive compliant)
Retail environment

When the administrator selects the appropriate profile, the Cisco Adaptive Wireless IPS will enable or disable alarms from the policy profile that are appropriate for that WLAN environment. For example, health care institutions can select the Healthcare profile and all alarms that are necessary to be HIPAA compliant will be enabled. The administrator still has the option after installation to enable or disable any alarm or change the threshold values as per individual preferences.

The Cisco Adaptive Wireless IPS system not only is an IDS (Intrusion Detection System), but also is an IPS (Intrusion Prevention System).

To learn more about Cisco Adaptive wIPS features and functionality, go to Cisco.com to watch a multimedia presentation. Here you will also find the learning modules for a variety of WCS topics. Over future releases, we will add more overview and technical presentations to enhance your learning.

Cisco Adaptive Wireless IPS policies are included in two security subcategories: wIPS—Denial of Service (DoS) Attacks and wIPS—Security Penetration.

This chapter contains the following sections:
- Intrusion Detection—Denial of Service Attack, page 20-2
- Intrusion Detection—Security Penetration, page 20-24

### Intrusion Detection—Denial of Service Attack

Wireless DoS (denial of service) attacks aim to disrupt wireless services by taking advantage of various vulnerabilities of WLANs at layer one and two. DoS attacks may target the physical RF environment, access points, client stations, or the back-end authentication RADIUS servers. For example, RF jamming attacks with a high-power directional antenna from a distance can be carried out from the outside of your office building. Attack tools used by intruders leverage hacking techniques such as spoofed 802.11 management frames, spoofed 802.1x authentication frames, or simply using the brute force packet flooding method.

The nature and protocol standards for wireless are subject to some of these attacks. Cisco has developed Management Frame Protection, the basis of 802.11i, to proactively prevent many of these attacks. (For more information on MFP, refer to the Cisco WCS online help.) The Cisco Adaptive Wireless IPS contributes to this solution by an early detection system where the attack signatures are matched. The Cisco Adaptive Wireless IPS DoS detection focuses on WLAN layer one (physical layer) and two (data link layer, 802.11, 802.1x). When strong WLAN authentication and encryption mechanisms are used, higher layer (IP layer and above) DoS attacks are difficult to execute. The wIPS server tightens your WLAN defense by validating strong authentication and encryption policies. In addition, the Cisco Adaptive Wireless IPS Intrusion Detection on denial of service attacks and security penetration provides 24 X 7 air tight monitoring on potential wireless attacks.
Denial of service attacks include the following three subcategories. This section contains the following topics:

- Denial of Service Attack Against Access Points, page 20-3
- Denial of Service Attack Against Infrastructure, page 20-8
- Denial of Service Attack Against Client Station, page 20-13

**Denial of Service Attack Against Access Points**

DoS attacks against access points are typically carried out on the basis of the following assumptions:

- Access points have limited resources. For example, the per-client association state table.
- WLAN management frames and authentication protocols 802.11 and 802.1x have no encryption mechanisms.

Wireless intruders can exhaust access point resources, most importantly the client association table, by emulating large number of wireless clients with spoofed MAC addresses. Each one of these emulated clients attempts association and authentication with the target access point but leaves the protocol transaction mid-way. When the access point resources and the client association table is filled up with these emulated clients and their incomplete authentication states, legitimate clients can no longer be serviced by the attacked access point. This creates a denial of service attack.

The Cisco Adaptive Wireless IPS tracks the client authentication process and identifies DoS attack signatures against the access point. Incomplete authentication and association transactions trigger the attack detection and statistical signature matching process. Detected DoS attacks result in setting off wIPS alarms which include the usual alarm detail description and target device information.

Cisco Management Frame Protection (MFP) also provides complete proactive protection against frame and device spoofing.

This section describes the DoS attacks against access points and includes the following topics:

- Denial of Service Attack: Association Flood
- Denial of Service Attack: Association Table Overflow
- Denial of Service Attack: Authentication Flood
- Denial of Service Attack: EAPOL-Start Attack
- Denial of Service Attack: PS Poll Flood
- Denial of Service Attack: Unauthenticated Association

**Denial of Service Attack: Association Flood**

**Alarm Description and Possible Causes**

This DoS attack exhausts the access point resources, particularly the client association table, by flooding the access point with a large number of spoofed client associations. At the 802.11 layer, shared-key authentication is flawed and rarely used. The other alternative is open authentication (null authentication) that relies on higher level authentication such as 802.1x or VPN. Open authentication allows any client to authenticate and then associate. An attacker using such a vulnerability can emulate a large number of clients to flood a target access point client association table by creating many clients reaching State 3. When the client association table overflows, legitimate clients cannot get associated; therefore, a DoS attack is committed. (See Figure 20-1)
Intrusion Detection—Denial of Service Attack

Figure 20-1  DoS Attack: Association Flood

**wIPS Solution**

The Cisco Adaptive Wireless IPS detects spoofed MAC addresses and tracks the 802.1x actions and data communication after a successful client association to detect this form of DoS attack. After this attack is reported by the Cisco Adaptive Wireless IPS, you may log onto this access point to inspect its association table for the number of client associations.

Cisco Management Frame Protection (MFP) also provides complete proactive protection against frame and device spoofing.

**Denial of Service Attack: Association Table Overflow**

**Alarm Description and Possible Causes**

Wireless intruders can exhaust access point resources, most importantly the client association table, by imitating a large number of wireless clients with spoofed MAC addresses. Each one of these imitated clients attempts association and authentication with the target access point. The 802.11 authentication typically completes because most deployments use 802.11 open system authentication, which is a null authentication process. Association with these imitated clients follows the authentication process. These imitated clients do not, however, follow up with higher level authentication such as 802.1x or VPN, which leaves the protocol transaction half-finished. At this point, the attacked access point maintains a state in the client association table for each imitated client. When the access point resources and client association table is filled with these imitated clients and their state information, legitimate clients can no longer be serviced by the attacked access point. This creates a DoS attack.
The Cisco Adaptive Wireless IPS tracks the client authentication process and identifies a DoS attack signature against an access point. Incomplete authentication and association transactions trigger the Cisco Adaptive Wireless IPS attack detection and statistical signature matching process.

**Denial of Service Attack: Authentication Flood**

**Attack tool:** Void11

**Alarm Description and Possible Causes**

IEEE 802.11 defines a client state machine for tracking station authentication and association status. Wireless clients and access points implement such a state machine according to the IEEE standard (see Figure 20-2). On the access point, each client has a state recorded in the access point client table (association table). This recorded state has a size limit that can either be a hard-coded number or a number based on the physical memory constraint.

**Figure 20-2  Client State Machine**

A form of DoS attack floods the access point client state table (association table) by imitating many client stations (MAC address spoofing) sending authentication requests to the access point. Upon receipt of each individual authentication request, the target access point creates a client entry in State 1 of the association table. If open system authentication is used for the access point, the access point returns an authentication success frame and moves the client to State 2. If shared-key authentication is used for the access point, the access point sends an authentication challenge to the attacker imitated client, which does not respond. In this case, the access point keeps the client in State 1. In either case, the access point contains multiple clients hanging in either State 1 or State 2 which fills up the access point association table. When the table reaches its limit, legitimate clients cannot authenticate and associate with this access point. This results in a DoS attack.
Intrusion Detection—Denial of Service Attack

wIPS Solution

The Cisco Adaptive Wireless IPS detects this form of DoS attack by tracking client authentication and association states. When the alarm is triggered, the access point under attack is identified. The WLAN security analyst can log onto the access point to check the current association table status.

Denial of Service Attack: EAPOL-Start Attack

Alarm Description and Possible Causes

The IEEE 802.1x standard defines the authentication protocol using EAP over LANs (EAPOL). The 802.1x protocol starts with an EAPOL-Start frame sent by the client station to begin the authentication transaction. The access point responds to an EAPOL-start frame with a EAP-identity-request and some internal resource allocation.

Figure 20-3  EAPOL-Start Protocol and EAPOL-Start Attack

An attacker attempts to disrupt an access point by flooding it with EAPOL-start frames to exhaust the access point internal resources.

wIPS Solution

The Cisco Adaptive Wireless IPS detects this form of DoS attack by tracking the 802.1x authentication state transition and particular attack signature.

Denial of Service Attack: PS Poll Flood

Alarm Description and Possible Causes

Power management is probably one of the most critical features of wireless LAN devices. Power management helps to conserve power by enabling stations to remain in power saving state mode for longer periods of time and to receive data from the access point only at specified intervals.
The wireless client device must inform the access point of the length of time that it will be in the sleep mode (power save mode). At the end of the time period, the client wakes up and checks for waiting data frames. After it completes a handshake with the access point, it receives the data frames. The beacons from the access point also include the Delivery Traffic Indication Map (DTIM) to inform the client when it needs to wake up to accept multicast traffic.

The access point continues to buffer data frames for the sleeping wireless clients. Using the Traffic Indication Map (TIM), the access point notifies the wireless client that it has buffered data buffered. Multicast frames are sent after the beacon that announces the DTIM.

The client requests the delivery of the buffered frames using PS-Poll frames to the access point. For every PS-Poll frame, the access point responds with a data frame. If there are more frames buffered for the wireless client, the access point sets the data bit in the frame response. The client then sends another PS-Poll frame to get the next data frame. This process continues until all the buffered data frames are received.

A potential hacker could spoof the MAC address of the wireless client and send out a flood of PS-Poll frames. The access point then sends out the buffered data frames to the wireless client. In reality, the client could be in the power safe mode and would miss the data frames.

**wIPS Solution**

The Cisco Adaptive Wireless IPS can detect this DoS attack that can cause the wireless client to lose legitimate data. Locate and remove the device from the wireless environment.

Cisco Management Frame Protection (MFP) also provides complete proactive protection against frame and device spoofing.

**Denial of Service Attack: Unauthenticated Association**

**Alarm Description and Possible Causes**

A form of DoS attack is to exhaust the access point resources, particularly the client association table, by flooding the access point with a large number of spoofed client associations. At the 802.11 layer, shared-key authentication is flawed and rarely used. The other alternative is open authentication (null authentication) which relies on higher level authentication such as 802.1x or VPN. Open authentication allows any client to authenticate and then associate. An attacker using such a vulnerability can imitate a large number of clients to flood a target access point client association table by creating many clients reaching State 3. When the client association table overflows, legitimate clients cannot get associated causing a DoS attack.
The Cisco Adaptive Wireless IPS detects spoofed MAC addresses and tracks 802.1x actions and data communication after a successful client association to detect this form of DoS attack. After this attack is reported by the Cisco Adaptive Wireless IPS, you may log onto this access point to inspect its association table for the number of client associations.

Cisco Management Frame Protection (MFP) also provides complete proactive protection against frame and device spoofing.

### Denial of Service Attack Against Infrastructure

In addition to attacking access points or client stations, the wireless intruder may target the RF spectrum or the back-end authentication RADIUS server for DoS attacks. The RF spectrum can be easily disrupted by injecting RF noise generated by a high power antenna from a distance. Back-end RADIUS servers can be overloaded by a DDoS (distributed denial of service) attack where multiple wireless attackers flood the RADIUS server with authentication requests. This attack does not require a successful authentication to perform the attack.

This section describes the DoS attacks against infrastructure and includes the following topics:

- Denial of Service Attack: CTS Flood
- Denial of Service Attack: Queensland University of Technology Exploit
- Denial of Service attack: RF Jamming
- Denial of Service: RTS Flood
- Denial of Service Attack: Virtual Carrier Attack
Denial of Service Attack: CTS Flood

Attack tool: CTS Jack

Alarm Description and Possible Causes

As an optional feature, the IEEE 802.11 standard includes the RTS/CTS (request-to-send/clear-to-send) functionality to control the station access to the RF medium. The wireless device ready for transmission sends a RTS frame to acquire the right to the RF medium for a specified time duration. The receiver grants the right to the RF medium to the transmitter by sending a CTS frame of the same time duration. All wireless devices observing the CTS frame should yield the media to the transmitter for transmission without contention.

![Figure 20-5 Standard RTS/CTS Functionality Compared to the CTS DoS Attack](image)

A wireless DoS attacker may take advantage of the privilege granted to the CTS frame to reserve the RF medium for transmission. By transmitting back-to-back CTS frames, an attacker can force other wireless devices sharing the RF medium to hold back their transmission until the attacker stops transmitting the CTS frames.

wIPS Solution

The Cisco Adaptive Wireless IPS detects the abuse of CTS frames for a DoS attack.

Denial of Service Attack: Queensland University of Technology Exploit

Intrusion Detection—Denial of Service Attack

Chapter 20      wIPS Policy Alarm Encyclopedia

Alarm Description and Possible Causes

802.11 WLAN devices use Carrier Sense Multiple Access with Collision Avoidance (CSMA/CA) as the basic access mechanism in which the WLAN device listens to the medium before starting any transmission and backs-off when it detects any existing transmission taking place. Collision avoidance combines the physical sensing mechanism and the virtual sense mechanism that includes the Network Allocation Vector (NAV), the time before which the medium is available for transmission. Clear Channel Assessment (CCA) in the DSSS protocol determines whether a WLAN channel is clear so an 802.11b device can transmit on it.

Mark Looi, Christian Wullems, Kevin Tham and Jason Smith from the Information Security Research Centre, Queensland University of Technology, Brisbane, Australia, have recently discovered a flaw in the 802.11b protocol standard that could potentially make it vulnerable to DoS radio frequency jamming attacks.

This attack specifically attacks the CCA functionality. According to the AusCERT bulletin, "an attack against this vulnerability exploits the CCA function at the physical layer and causes all WLAN nodes within range, both clients and access points, to defer transmission of data for the duration of the attack. When under attack, the device behaves as if the channel is always busy, preventing the transmission of any data over the wireless network."

This DoS attack affects DSSS WLAN devices including IEEE 802.11, 802.11b, and low-speed (below 20 Mbps) 802.11g wireless devices. IEEE 802.11a (using OFDM), high-speed (above 20 Mbps using OFDM) 802.11g wireless devices are not affected by this attack. Devices that use FHSS are also not affected.

Any attacker using a PDA or a laptop equipped with a WLAN card can launch this attack on SOHO and enterprise WLANs. Switching to the 802.11a protocol is the only solution or known protection against this DoS attack.

For more information on this DoS attack, refer to:
- www.isrc.qut.edu.au
- www.isrc.qut.edu.au/wireless
- http://www.kb.cert.org/vuls/id/106678

wIPS Solution

The Cisco Adaptive Wireless IPS detects this DoS attack and sets off the alarm. Locate and remove the responsible device from the wireless environment.

Denial of Service attack: RF Jamming

Alarm Description and Possible Causes

WLAN reliability and efficiency depend on the quality of the radio frequency (RF) media. Each RF is susceptible to RF noise impact. An attacker using this WLAN vulnerability can perform two types of DoS attacks:

- Disrupt WLAN service—At the 2.4 GHz unlicensed spectrum, the attack may be unintentional. A cordless phone, Bluetooth devices, microwave, wireless surveillance video camera, or baby monitor can all emit RF energy to disrupt WLAN service. Malicious attacks can manipulate the RF power at 2.4 GHz or 5 GHz spectrum with a high-gain directional antenna to amplify the attack impact from a distance.
With free-space and indoor attenuation, a 1-kW jammer 300 feet away from a building can jam 50 to 100 feet into the office area. The same 1-kW jammer located inside a building can jam 180 feet into the office area. During the attack, WLAN devices in the target area are out of wireless service.

- Physically damage AP hardware—An attacker using a high-output transmitter with directional high gain antenna 30 yards away from an access point can pulse enough RF power to damage electronics in the access point putting it being permanently out of service. Such High Energy RF (HERF) guns are effective and are inexpensive to build.

**wIPS Solution**

The Cisco Adaptive Wireless IPS detects continuous RF noise over a certain threshold for a potential RF jamming attack.

Cisco Spectrum Intelligence also provides specific detection of non-802.11 jamming devices. For more information on Cisco Spectrum Intelligence, refer to the *Cisco Wireless Control System Configuration Guide*.

**Denial of Service: RTS Flood**

**Alarm Description and Possible Causes**

As an optional feature, the IEEE 802.11 standard includes the RTS/CTS (Request-To-Send/Clear-To-Send) functionality to control access to the RF medium by stations. The wireless device ready for transmission sends an RTS frame to acquire the right to the RF medium for a specified duration. The receiver grants the right to the RF medium to the transmitter by sending a CTS frame of the same duration. All wireless devices observing the CTS frame should yield the RF medium to the transmitter for transmission without contention. See Figure 20-6.
A wireless denial of service attacker may take advantage of the privilege granted to the CTS frame to reserve the RF medium for transmission. By transmitting back-to-back RTS frames with a large transmission duration field, an attacker reserves the wireless medium and force other wireless devices sharing the RF medium to hold back their transmissions.

**wIPS Solution**

The Cisco Adaptive Wireless IPS detects the abuse of RTS frames for denial of service attacks.

**Denial of Service Attack: Virtual Carrier Attack**

**Alarm Description and Possible Causes**

The virtual carrier-sense attack is implemented by modifying the 802.11 MAC layer implementation to allow random duration values to be sent periodically. This attack can be carried out on the ACK, data, RTS, and CTS frame types by using large duration values. By doing this the attacker can prevent channel access to legitimate users.

Under normal circumstances, the only time a ACK frame carries a large duration value is when the ACK is part of a fragmented packet sequence. A data frame legitimately carries a large duration value only when it is a subframe in a fragmented packet exchange.

One approach to deal with this attack is to place a limit on the duration values accepted by nodes. Any packet containing a larger duration value is truncated to the maximum allowed value. Low cap and high cap values can be used. The low cap has a value equal to the amount of time required to send an ACK frame, plus media access backoffs for that frame. The low cap is used when the only packet that can follow the observed packet is an ACK or CTS. This includes RTS and all management (association, and so on) frames. The high cap is used when it is valid for a data packet to follow the observed frame.
limit in this case needs to include the time required to send the largest data frame, plus the media access
backoffs for that frame. The high cap must be used in two places: when observing an ACK (because the
ACK may be part of a MAC level fragmented packet) and when observing a CTS.

A station that receives an RTS frame also receives the data frame. The IEEE 802.11 standard specifies
the exact times for the subsequent CTS and data frames. The duration value of RTS is respected until the
following data frame is received or not received. Either the observed CTS is unsolicited or the observing
node is a hidden terminal. If this CTS is addressed to a valid in-range station, the valid station can nullify
this by sending a zero duration null function frame. If this CTS is addressed to an out-of-range station,
one method of defense is to introduce authenticated CTS frames containing cryptographically signed
copies of the preceding RTS. With this method, there is a possibility of overhead and feasibility issues.

wIPS Solution

The Cisco Adaptive Wireless IPS detects this DoS attack. Locate the device and take appropriate steps
to remove it from the wireless environment.

Denial of Service Attack Against Client Station

DoS (denial of service) attacks against wireless client station are typically carried out based upon the
fact that 802.11 management frames and 802.1x authentication protocols have no encryption mechanism
and thus can be spoofed. For example, wireless intruders can disrupt the service to a client station by
continuously spoofing a 802.11 dis-association or deauthentication frame from the access point to the
client station. The 802.11 association state machine as specified by the IEEE standard is illustrated in
Figure 20-7 to show how an associated station can be tricked out of the authenticated and associated state
by various types of spoofed frames.

Besides the 802.11 authentication and association state attack, there are similar attack scenarios for
802.1x authentication. For example, 802.1x EAP-Failure or EAP-logoff messages are not encrypted and
can be spoofed to disrupt the 802.1x authenticated state to disrupt wireless service. See Figure 20-8 for
802.1x authentication and key exchange state change.
Figure 20-8  802.1x User Authentication Process

The Cisco Adaptive Wireless IPS tracks the client authentication process and identifies DoS attack signatures. Incomplete authentication and association transactions trigger the attack detection and statistical signature matching process. Detected DoS attack results in setting off wIPS alarms that include the usual alarm detail description and target device information.

This section describes the DoS attacks against client station and includes the following topics:

- Denial of Service Attack: Authentication-Failure Attack, page 20-14
- Denial of Service Attack: Block ACK, page 20-15
- Denial of Service Attack: Deauthentication Broadcast Flood, page 20-16
- Denial of Service Attack: Deauthentication Flood, page 20-17
- Denial of Service Attack: Disassociation Broadcast Flood, page 20-19
- Denial of Service Attack: Disassociation Flood, page 20-20
- Denial of Service Attack: EAPOL-Logoff Attack, page 20-21
- Denial of Service Attack: FATA-Jack Tool, page 20-21
- Denial of Service Attack: Premature EAP-Failure, page 20-23
- Denial of Service Attack: Premature EAP-Success, page 20-23

**Denial of Service Attack: Authentication-Failure Attack**

**Alarm Description and Possible Causes**

IEEE 802.11 defines a client state machine for tracking station authentication and association status. Wireless clients and access points implement this client state machine based on the IEEE standard (see Figure 20-9). A successfully associated client remains in State 3 to continue wireless communication. A client in State 1 and in State 2 cannot participate in the WLAN data communication process until it is authenticated and associated to State 3. IEEE 802.11 defines two authentication services: open system authentication and shared key authentication. Wireless clients go through one of these authentication processes to associate with an access point.
A denial of service (DoS) attack spoofs invalid authentication request frames (with bad authentication service and status codes) being sent from an associated client in State 3 to an access point. Upon receipt of the invalid authentication requests, the access point updates the client to State 1, which disconnects client wireless service.

**wIPS Solution**

The Cisco Adaptive Wireless IPS detects this form of a DoS attack by monitoring for spoofed MAC addresses and authentication failures. This alarm may also indicate an intrusion attempt. When a wireless client fails too many times in authenticating with an access point, the server raises this alarm to indicate a potential intruder attempt to breach security.

**Note**

This alarm focuses on IEEE 802.11 authentication methods, such as open system and shared key. EAP and 802.1x based authentications are monitored by other alarms.

**Denial of Service Attack: Block ACK**

**Alarm Description & Possible Causes**

A form of denial of service attack allows an attacker to prevent an 802.11n AP from receiving frames from a specific valid corporate client. With the introduction of the 802.11n standard, a transaction mechanism was introduced which allows a client to transmit a large block of frames at once, rather than dividing them up into segments. To initiate this exchange, the client will send an Add Block Acknowledgement (ADDBA) to the AP, which contains sequence numbers to inform the AP of the size of the block being transmitted. The AP will then accept all frames that fall within the specified sequence (consequently dropping any frames that fall outside of the range) and transmit a BlockACK message back to the client when the transaction has been completed.
To exploit this process, an attacker can transmit an invalid ADDBA frame while spoofing the valid client MAC address. This process will cause the AP to ignore any valid traffic transmitted from the client until the invalid frame range has been reached.

**wIPS Solution**

The wIPS server monitors ADDBA transactions for signs of spoofed client information. When an attacker is detected attempting to initiate a Block ACK attack, an alarm is triggered. We recommend that users locate the offending device and eliminate it from the wireless environment as soon as possible.

**Denial of Service Attack: Deauthentication Broadcast Flood**

**Alarm Description and Possible Causes**

IEEE 802.11 defines a client state machine for tracking the station authentication and association status. Wireless clients and access points implement this state machine according to the IEEE standard. A successfully associated client remains in State 3 to continue wireless communication. A client in State 1 and State 2 cannot participate in WLAN data communication until it is authenticated and associated to State 3.
A form of DoS attack sends all clients of an access point to the unassociated or unauthenticated State 1 by spoofing deauthentication frames from the access point to the broadcast address. With current client adapter implementation, this form of attack is very effective and immediate in disrupting wireless services against multiple clients. Typically, client stations reassociate and reauthenticate to regain service until the attacker sends another deauthentication frame.

**wIPS Solution**

The Cisco Adaptive Wireless IPS detects this form of DoS attack by detecting spoofed deauthentication frames and tracking client authentication and association states. When the alarm is triggered, the access point under attack is identified. The WLAN security analyst can log onto the access point to verify the current association table status.

Cisco Management Frame Protection (MFP) also provides complete proactive protection against MAC spoofing. For more information on MFP, refer to the *Cisco Wireless Control System Configuration Guide*.

**Denial of Service Attack: Deauthentication Flood**

Attack tool: WLAN Jack, Void11
Intrusion Detection—Denial of Service Attack

Alarm Description and Possible Causes

IEEE 802.11 defines a client state machine for tracking station authentication and association status. Wireless clients and access points implement this state machine according to the IEEE standard. A successfully associated client stays in State 3 to continue wireless communication. A client in State 1 and State 2 cannot participate in WLAN data communication until it is authenticated and associated to State 3.

Figure 20-11 Client State Machine and Deauthentication Flood Attack

A form of DoS attack aims to send an access point client to the unassociated or unauthenticated State 1 by spoofing deauthentication frames from the access point to the client unicast address. With current client adapter implementations, this form of attack is very effective and immediate for disrupting wireless services against the client. Typically, client stations reassociate and reauthenticate to regain service until the attacker sends another deauthentication frame. An attacker repeatedly spoofs the deauthentication frames to keep all clients out of service.

wIPS Solution

The Cisco Adaptive Wireless IPS detects this form of DoS attack by detecting spoofed deauthentication frames and tracking client authentication and association states. When the alarm is triggered, the access point and client under attack are identified. The WLAN security officer can log onto the access point to check the current association table status.

Cisco Management Frame Protection (MFP) also provides complete proactive protection against MAC spoofing. For more information on MFP, refer to the Cisco Wireless Control System Configuration Guide.
Denial of Service Attack: Disassociation Broadcast Flood

Attack tool: ESSID Jack

Alarm Description and Possible Causes

IEEE 802.11 defines a client state machine for tracking the station authentication and association status. Wireless clients and access points implement this state machine according to the IEEE standard. A successfully associated client station stays in State 3 to continue wireless communication. A client station in State 1 and State 2 can not participate in WLAN data communication until it is authenticated and associated to State 3.

Figure 20-12  Client State Machine and Disassociation Broadcast Attack

A form of DoS attack aims to send an access point client to the unassociated or unauthenticated State 2 by spoofing disassociation frames from the access point to the broadcast address (all clients). With current client adapter implementations, this form of attack is effective and immediate for disrupting wireless services against multiple clients. Typically, client stations reassociate to regain service until the attacker sends another disassociation frame. An attacker repeatedly spoofs the disassociation frames to keep all clients out of service.

wIPS Solution

The Cisco Adaptive Wireless IPS detects this form of DoS attack by detecting spoofed disassociation frames and tracking client authentication and association states. When the alarm is triggered, the access point under attack is identified. The WLAN security officer can log onto the access point to check the current association table status.
Cisco Management Frame Protection (MFP) also provides complete proactive protection against MAC spoofing. For more information on MFP, refer to the Cisco Wireless Control System Configuration Guide.

**Denial of Service Attack: Disassociation Flood**

Attack tool: ESSID Jack

**Alarm Description and Possible Causes**

IEEE 802.11 defines a client state machine for tracking the station authentication and association status. Wireless clients and access points implement this state machine according to the IEEE standard. A successfully associated client stays in State 3 to continue wireless communication. A client in State 1 and State 2 cannot participate in WLAN data communication until it is authenticated and associated to State 3.

![Client State Machine and Disassociation Flood Attack](image)

A form of DoS attack aims to send an access point to the unassociated or unauthenticated State 2 by spoofing disassociation frames from the access point to a client. With client adapter implementations, this form of attack is effective and immediate for disrupting wireless services against this client. Typically, client stations reassociate to regain service until the attacker sends another disassociation frame. An attacker repeatedly spoofs the disassociation frames to keep the client out of service.

**wIPS Solution**

The Cisco Adaptive Wireless IPS detects this form of DoS attack by detecting spoofed disassociation frames and tracking client authentication and association states. When the alarm is triggered, the access point under attack is identified. The WLAN security officer can log onto the access point to check the current association table status.
Denial of Service Attack: EAPOL-Logoff Attack

Alarm Description and Possible Causes

The IEEE 802.1x standard defines the authentication protocol using Extensible Authentication Protocol (EAP) over LANs or EAPOL. The 802.1x protocol starts with a EAPOL-start frame to begin the authentication transaction. At the end of an authenticated session when a client station logs off, the client station sends an 802.1x EAPOL-logoff frame to terminate the session with the access point.

Because the EAPOL-logoff frame is not authenticated, an attacker can potentially spoof this frame and log the user off the access point, thus committing a DoS attack. The fact that the client is logged off from the access point is not obvious until it attempts communication through the WLAN. Typically, the disruption is discovered and the client re-associates and authenticates automatically to regain the wireless connection. The attacker can continuously transmit the spoofed EAPOL-logoff frames to be effective on this attack.

wIPS Solution

The Cisco Adaptive Wireless IPS detects this form of DoS attack by tracking 802.1x authentication states. When the alarm is triggered, the client and access point under attack are identified. The WLAN security officer logs onto the access point to check the current association table status.

Denial of Service Attack: FATA-Jack Tool

Alarm Description and Possible Causes

IEEE 802.11 defines a client state machine for tracking station authentication and association status. Wireless clients and access points implement this state machine based on the IEEE standard. A successfully associated client station stays in State 3 to continue wireless communication. A client station in State 1 and in State 2 cannot participate in the WLAN data communication process until it is
authenticating and associated to State 3. IEEE 802.11 defines two authentication services: open system and shared key. Wireless clients go through one of these authentication processes to associate with an access point.

**Figure 20-15  Client State Machine and DoS Attack**

A form of DoS attack spoofs invalid authentication request frames (with bad authentication service and status codes) from an associated client in State 3 to an access point. Upon reception of the invalid authentication requests, the access point updates the client to State 1, which disconnects its wireless service.

FATA-jack is one of the commonly used tools to run a similar attack. It is a modified version of WLAN-jack and it sends authentication-failed packets along with the reason code of the previous authentication failure to the wireless station. This occurs after it spoofs the MAC address of the access point. FATA-jack closes most active connections and at times forces the user to reboot the station to continue normal activities.

**wIPS Solution**

The Cisco Adaptive Wireless IPS detects the use of FATA-jack by monitoring on spoofed MAC addresses and authentication failures. This alarm may also indicate an intrusion attempt. When a wireless client fails too many times in authenticating with an access point, the Cisco Adaptive Wireless IPS raises this alarm to indicate a potential intruder’s attempt to breach security.

**Note**

This alarm focuses on 802.11 authentication methods (open system, shared key, and so on). EAP and 802.1x based authentications are monitored by other alarms.

Cisco Management Frame Protection also provides complete proactive protection against frame and device spoofing.
Denial of Service Attack: Premature EAP-Failure

Alarm Description and Possible Causes

The IEEE 802.1x standard defines the authentication protocol using Extensible Authentication Protocol over LANs or EAPOL. The 802.1x protocol starts with an EAPOL-Start frame to begin the authentication transaction. When the 802.1x authentication packet exchange is complete with the back-end RADIUS server, the access point sends an EAP-success or EAP-failure frame to the client to indicate authentication success or failure.

Figure 20-16  EAP-Failure Protocol and Premature EAP-Failure Attack

The IEEE 802.1X specification prohibits a client from displaying its interface when the required mutual authentication is not complete. This enables a well-implemented 802.1x client station to avoid being fooled by a fake access point sending premature EAP-success packets.

An attacker keeps the client interface from appearing by continuously spoofing pre-mature EAP-failure frames from the access point to the client to disrupt the authentication state on the client.

wIPS Solution

The Cisco Adaptive Wireless IPS detects this form of DoS attack by tracking the spoofed premature EAP-failure frames and the 802.1x authentication states for each client station and access point. Find the device and remove it from the wireless environment.

Denial of Service Attack: Premature EAP-Success

Alarm Description and Possible Causes

The IEEE 802.1x standard defines the authentication protocol using Extensible Authentication Protocol over LANs or EAPOL. The 802.1x protocol starts with an EAPOL-start frame to begin the authentication transaction. When the 802.1x authentication packet exchange is completed with the back-end RADIUS server, the access point sends an EAP-success frame to the client to indicate a successful authentication.
The IEEE 802.1X specification prohibits a client from displaying its interface when the required mutual authentication has not been completed. This enables a well-implemented 802.1x client station to avoid being fooled by a fake access point sending premature EAP-success packets to bypass the mutual authentication process.

An attacker keeps the client interface from appearing by continuously spoofing premature EAP-success frames from the access point to the client to disrupt the authentication state.

**wIPS Solution**

The Cisco Adaptive Wireless IPS detects this form of DoS attack by tracking spoofed premature EAP-success frames and the 802.1x authentication states for each client station and access point. Find the device and remove it from the wireless environment.

**Intrusion Detection—Security Penetration**

A form of wireless intrusion is to breach the WLAN authentication mechanism to gain access to the wired network or the wireless devices. Dictionary attacks on the authentication method is a common attack against an access point. The intruder can also attack the wireless client station during its association process with an access point. For example, a faked access point attack on an unsuspicous wireless client may fool the client into associating with faked access point. This attack allows the intruder to gain network access to the wireless station and potentially hack into its file system. The intruder can then use the station to access the wired enterprise network.

These security threats can be prevented if mutual authentication and strong encryption techniques are used. The Cisco Adaptive Wireless IPS looks for weak security deployment practices as well as any penetration attack attempts. The Cisco Adaptive Wireless IPS ensures a strong wireless security umbrella by validating the best security policy implementation as well as detecting intrusion attempts. If such vulnerabilities or attack attempts are detected, the Cisco Adaptive Wireless IPS generates alarms to bring these intrusion attempts to the administrator notice.

This section describes the security penetration attacks and includes the following topics:

- Airsnarf Attack, page 20-25
Airsnarf Attack

Alarm Description and Possible Causes

A hotspot is any location where Wi-Fi network access is made available for the general public. Hotspots are found in airports, hotels, coffee shops, and other places where business people tend to congregate. They are important network access services for business travelers.

Customers are able to connect to the legitimate access point and receive service using a wireless-enabled laptop or handheld. Most hotspots do not require the user to have any advanced authentication mechanism to connect to the access point other than popping up a web page for the user to log in. The criterion for entry is dependent only on whether or not the subscriber has paid the subscription fees. In a wireless hotspot environment, no one should be trusted. Due to current security concerns, some WLAN hotspot vendors are using 802.1x or higher authentication mechanisms to validate the identity of the user.
The 4 components of a basic hotspot network include:

- Hotspot Subscribers—Valid users with a wireless-enabled laptop or handheld and valid login for accessing the hotspot network.
- WLAN Access Points—Can be SOHO gateways or enterprise level access points depending upon the hotspot implementation.
- Hotspot Controllers—Deals with user authentication, gathering billing information, tracking usage time, filtering functions, and so on. This can be an independent machine or incorporated in the access point itself.
- Authentication Server—Contains the login credentials for the subscribers. Most hotspot controllers verify subscribers credentials with the authentication server.

Airsnarf is a wireless access point setup utility that shows how a hacker can steal username and password credentials from public wireless hotspots.

Airsnarf, a shell script-based tool, creates a hotspot complete with a captive portal where the users enter their login information. Important values such as local network information, gateway IP address, and SSID can be configured within the airsnarf configuration file. This tool initially broadcasts a very strong signal that disassociates the hotspot wireless clients from the authorized access point connected to the Internet. The wireless clients assume that they are temporarily disconnected from the Internet due to some unknown issue and they try to log in again. Wireless clients that associate to the Airsnarf access point receive the IP address, DNS address, and gateway IP address from the rogue Airsnarf access point instead of the legitimate access point installed by the hotspot operator. A web page requests a username and password and the DNS queries are resolved by the rogue Airsnarf access point. The username and password entered are collected by the hacker.

The username and password can be used in any other hotspot location of the same provider anywhere in the nation without the user realizing the misuse. The only case where it could have lesser impact is if the hotspot user is connected using a pay-per-minute usage scheme.

The Airsnarf tool can also penetrate the laptop clients that are unknowingly connected to the Airsnarf access point. The AirSnarf tool can be downloaded by hackers from the AirSnarf website.
wIPS Solution

The Cisco Adaptive Wireless IPS detects the wireless device running the AirSnarf tool. Appropriate action must be taken by the administrator to remove the AirSnarf tool from the WLAN environment.

Chopchop Attack

Alarm Description and Possible Causes

It is well publicized that a WLAN device using a static WEP key for encryption is vulnerable to various WEP cracking attacks. Refer to Weaknesses in the Key Scheduling Algorithm of RC4 - I by Scott Fluhrer, Itsik Mantin, and Adi Shamir for more information.

Figure 20-19  WEP Encipher Process Block Diagram

A cracked WEP secret key offers no encryption protection for data to be transmitted, leading to compromised data privacy. The WEP key, which is in most cases 64-bit or 128-bit (some vendors also offer 152-bit encryption), is a secret key specified by the user, linked with the 24-bit IV (Initialization Vector). The chopchop tool was written for the Linux operating system by Korek to exploit a weakness in WEP and decrypt the WEP data packet. However, the chopchop tool only reveals the plaintext. The attacker uses the packet capture file of a previously injected packet during the initial phase and decrypts the packet by retransmitting modified packets to the attacked network. When the attack is completed, the chopchop tool produces an unencrypted packet capture file and another file with PRGA (Pseudo Random Generation Algorithm) information determined during the decryption process. The PGRA is then XORed with the cyphertext to obtain the plaintext.
Commands for Initiating a Chopchop Attack

Figure 20-20

```
```
Where:
- `-4` means the chopchop attack
- `-h XX:XX:XX:XX:XX:XX` is the MAC address of an associated client or your card’s MAC if you did fake authentication
- `-b YY:YY:YY:YY:YY:YY` is the access point MAC address; `ath0` is the wireless interface name

Access points that drop data packets shorter than 60 bytes may not be vulnerable to this kind of attack. If an access point drops packets shorter than 42 bytes, aireplay will try to guess the rest of the missing data, as far as the headers are predictable. If an IP packet is captured, it additionally checks if the checksum of the header is correct after guessing the missing parts of it. This attack requires at least one WEP data packet. A chopchop attack also works against dynamic WEP configurations. The Cisco Adaptive Wireless IPS is able to detect potential attacks using the chopchop tool.

**wlIPS Solution**

The Cisco Adaptive Wireless IPS activates an alert when a potential chopchop attack is in progress. WEP should not be used in the corporate environment and appropriate measures should be taken to avoid any security holes in the network and upgrade the wireless network infrastructure and devices to use the more secure IEEE 802.11i standard.

**Day-0 Attack by WLAN Performance Anomaly**

**Alarm Description and Possible Causes**

WLAN performance efficiency is constantly challenged by the dynamics of the RF environment and the mobility of client devices. A closely monitored and well tuned WLAN system can achieve a higher throughput than a poorly managed one. Radio Resource Management (RRM) built into the Cisco Unified Wireless Network monitors and dynamically corrects performance issues found in the RF environment. Further performance anomaly monitoring may be done via the Wireless IPS system. For more information on RRM, refer to the Cisco WCS online help.

The Cisco Adaptive Wireless IPS ensures WLAN performance and efficiency by monitoring the WLAN on a continued basis and alerting the wireless administrator on early warning signs for trouble. Performance alarms are generated and classified in the following categories in the event of any performance degradation:

- **RF Management**—The Cisco Adaptive Wireless IPS monitors the physical RF environment that is dynamic and very often the source of WLAN performance problems. While monitoring on the RF environment, the server characterizes the following WLAN fundamentals and reports problems accordingly:
  - Channel interference and channel allocation problems
  - Channel noise and non-802.11 signals
  - WLAN RF service under-coverage area
  - Classic RF hidden-node syndrome
• Problematic traffic pattern—Many WLAN performance problems including the RF multipath problem manifest themselves in the MAC layer protocol transactions and statistics. By tracking and analyzing the wireless traffic, the Cisco Adaptive Wireless IPS is able to spot performance inefficiencies and degradations early on. In many cases, the Cisco Adaptive Wireless IPS can determine the cause of the detected performance problem and suggest counter measures. The Cisco Adaptive Wireless IPS tracks MAC layer protocol characteristics including the following:
  - Frame CRC error
  - Frame re-transmission
  - Frame speed (1, 2, 5.5, 11, ... Mbps) usage and distribution
  - Layer 2 frame fragmentation
  - Access point and station association/re-association/dis-association relationship
  - Roaming hand-off

• Channel or device overloaded—The Cisco Adaptive Wireless IPS monitors and tracks the load to ensure smooth operation with both channel bandwidth limitation or the WLAN device resource capacity. In the event of unsatisfactory performance by the WLAN due to under-provisioning or over-growth, the Cisco Adaptive Wireless IPS raises alarms and offers specific details. RF has no boundaries that could lead to your WLAN channel utilization to increase significantly even when your neighbor installs new WLAN devices in an adjoining channel. The Cisco Adaptive Wireless IPS monitors your WLAN to ensure proper bandwidth and resource provisioning.

• Deployment and operation error—The Cisco Adaptive Wireless IPS scans the airwaves for configuration and operation errors. The following specific areas are continuously monitored:
  - Inconsistent configuration among access points servicing the same SSID
  - Configuration against the principles of best practice
  - Connection problems caused by client/access point mismatch configuration
  - WLAN infrastructure device down or reset
  - Flaws in WLAN device implementation

• IEEE 802.11e and VoWLAN issues—The IEEE 802.11e standard adds QoS (quality of service) features and multimedia support to the existing 802.11 a/b/g wireless standard. This is done while maintaining full backward compatibility with these standards. The QoS feature is critical to voice and video applications. Wireless LAN has limited bandwidth and high overheads as compared to the traditional wired Ethernet. The throughput is reduced for a variety of reasons including the RTS/CTS mechanism, packet fragmentation, packet retransmission, acknowledgements, and collisions.

wIPS Solution

The Cisco Adaptive Wireless IPS has detected a single Performance Intrusion policy violation on a large number of devices in the wireless network. Either the number of devices violating the specific policy in the time period specified are observed or there is a sudden percentage increase in the number of devices as specified in the threshold settings for the alarm. Depending on the Performance Intrusion violation, it is suggested that the devices be monitored and located to carry out further analysis.

For example:
• If the AP overloaded by stations alarm is generated by a large number of devices, it may indicate that a hacker has generated thousands of stations and forcing them to associate to the corporate access point. If this occurs, legitimate corporate clients cannot connect to the access point.
• Excessive frame retries on the wireless devices may indicate such things as noise, interference, packet collisions, multipath, and hidden node syndrome.
Day-0 Attack by WLAN Security Anomaly

Alarm Description and Possible Causes

The addition of WLANs in the corporate environment introduces a whole new class of threats for network security. RF signals that penetrate walls and extend beyond intended boundaries can expose the network to unauthorized users. Rogue access points installed by employees for their personal use usually do not adhere to the corporate security policy. A rogue access point can put the entire corporate network at risk of outside penetration and attack. Besides rogue access points, there are many other wireless security vulnerabilities which compromise the wireless network such as misconfigured and unconfigured access points. There can also be DoS (denial of service) attacks from various sources against the corporate network.

WCS provides automated security vulnerability assessment within the wireless infrastructure that proactively reports any security vulnerabilities or mis-configurations. Further assessment may be done over-the-air via the Wireless IPS system. With the comprehensive suite of security monitoring technologies, the Cisco Adaptive Wireless IPS alerts the user on more than 100 different threat conditions in the following categories:

- User authentication and traffic encryption (Static WEP encryption, VPN, Fortress, Cranite, 802.11i and 802.1x)—Common security violations in this category (authentication and encryption) include mis-configurations, out-of-date software or firmware, and suboptimal choice of corporate security policy.
- Rogue, monitored, and ad-hoc mode devices—Rogue devices must be detected and removed immediately to protect the integrity of the wireless and wired enterprise network.
- Configuration vulnerabilities—Implementing a strong deployment policy is fundamental to a secure WLAN. However, enforcing the policy requires constant monitoring to catch violations caused by mis-configuration or equipment vendor implementation errors. With the increased trend on laptops with built-in Wi-Fi capabilities, the complexity of WLAN configuration extends beyond access points to the user laptops. WLAN device configuration management products can make the configuration process easier, but the need for validation persists especially in laptops with built-in but unused and unconfigured Wi-Fi.
- Intrusion detection on security penetration—A form of wireless intrusion includes breaching the WLAN authentication mechanism to gain access to the wired network or the wireless devices. A Dictionary attack on the authentication method is a very common attack against an access point. The intruder can also attack the wireless client station during its association process with an access point. For example, a faked AP attack on a unsuspicous wireless client may fool the client into associating with a fake access point. This attack allows the intruder to gain network access to the wireless station and potentially hack into its file system. The intruder can then use the station to access the wired enterprise network.
- Intrusion detection on denial of service attacks—Wireless DoS (denial of service) attacks aim to disrupt wireless services by taking advantage of various vulnerabilities of WLAN at layer one and two. DoS attacks may target the physical RF environment, access points, client stations, or the back-end authentication RADIUS servers. For example, RF jamming attack with high power directional antenna from a distance can be carried out from the outside of your office building. Attack tools used by intruders leverage hacking techniques such as spoofed 802.11 management frames, spoofed 802.1x authentication frames, or simply using the brute force packet flooding method.

wIPS Solution

The Cisco Adaptive Wireless IPS has detected a single Security IDS/IPS policy violation on a large number of devices in the wireless network. Either the number of devices violating the specific policy in the time period specified are observed or there is a sudden percentage increase in the number of devices as specified in the threshold settings for the alarm. Depending on the Security IDS/IPS violation, it is
suggested that the devices are monitored and located to carry out further analysis to check if they are compromising the Enterprise wireless network in any way (attack or vulnerability). If this is an increase in the number of rogue devices, it may indicate an attack against the network. The WLAN administrator may use the integrated over-the-air physical location capabilities, or trace device on the wired network using rogue location discovery protocol (RLDP) or switchport tracing to find it.

If there is a sudden increase in the number of client devices with encryption disabled, it may be necessary to revisit the Corporate Security Policy and enforce users to use the highest level of encryption and authentication according to the policy rules.

Day-0 Attack by Device Performance Anomaly

Alarm Description and Possible Causes

WLAN performance efficiency is constantly challenged by the dynamics of the RF environment and the mobility of client devices. A closely monitored and well-tuned WLAN system can achieve a higher throughput than a poorly managed one. Radio Resource Management built into the Cisco Unified Wireless Network monitors and dynamically corrects performance issues found in the RF environment. Further performance anomaly monitoring may be done via the Wireless IPS system. For more information on RRM, refer to the Cisco WCS online help.

The Cisco Adaptive Wireless IPS ensures WLAN performance and efficiency by monitoring the WLAN on a continued basis and alerting the wireless administrator on early warning signs for trouble. Performance alarms are generated and classified in the following categories in the event of any performance degradation:

- **RF Management**—The Cisco Adaptive Wireless IPS monitors the physical RF environment that is dynamic and very often the source of WLAN performance problems. While monitoring on the RF environment, the server characterizes the following WLAN fundamentals and reports problems accordingly:
  - Channel interference and channel allocation problems
  - Channel noise and non-802.11 signals
  - WLAN RF service under-coverage area
  - Classic RF hidden-node syndrome

- **Problematic traffic pattern**—Many WLAN performance problems including the RF multipath problem manifest themselves in the MAC layer protocol transactions and statistics. By tracking and analyzing the wireless traffic, the Cisco Adaptive Wireless IPS is able to spot performance inefficiencies and degradations early on. In many cases, the Cisco Adaptive Wireless IPS can determine the cause of the detected performance problem and suggest counter measures. The Cisco Adaptive Wireless IPS tracks MAC layer protocol characteristics including the following:
  - Frame CRC error
  - Frame re-transmission
  - Frame speed (1, 2, 5.5, 11, ... Mbps) usage and distribution
  - Layer 2 frame fragmentation
  - Access point and station association/re-association/dis-association relationship
  - Roaming hand-off

- **Channel or device overloaded**—The Cisco Adaptive Wireless IPS monitors and tracks the load to ensure smooth operation with both channel bandwidth limitation or the WLAN device resource capacity. In the event of unsatisfactory performance by the WLAN due to under-provisioning or over-growth, the Cisco
Adaptive Wireless IPS raises alarms and offers specific details. RF has no boundaries that could lead to your WLAN channel utilization to increase significantly even when your neighbor installs new WLAN devices in an adjoining channel. The Cisco Adaptive Wireless IPS monitors your WLAN to ensure proper bandwidth and resource provisioning.

- **Deployment and operation error**—The Cisco Adaptive Wireless IPS scans the airwaves for configuration and operation errors. The following specific areas are continuously monitored:
  - Inconsistent configuration among access points servicing the same SSID
  - Configuration against the principles of best practice
  - Connection problems caused by client/access point mismatch configuration
  - WLAN infrastructure device down or reset
  - Flaws in WLAN device implementation

- **IEEE 802.11e and VoWLAN issues**—The IEEE 802.11e standard adds QoS (quality of service) features and multimedia support to the existing 802.11 a/b/g wireless standard. This is done while maintaining full backward compatibility with these standards. The QoS feature is critical to voice and video applications. Wireless LAN has limited bandwidth and high overheads as compared to the traditional wired Ethernet. The throughput is reduced for a variety of reasons including the RTS/CTS mechanism, packet fragmentation, packet retransmission, acknowledgements, and collisions.

To maximize the power of the Cisco Adaptive Wireless IPS, performance alarms can be customized to best match your WLAN deployment specification. For example, if your WLAN is designed for all users to use 5.5 and 11 mbps speed only, customize the threshold for performance alarm 'Low speed tx rate exceeded' to reflect such an expectation.

### wIPS Solution

The Cisco Adaptive Wireless IPS detects a device violating a large number of performance intrusion policies. This device has either generated a large number of performance intrusion violations in the time period specified or there is a sudden percentage increase as specified in the threshold settings for the various alarms. It is suggested that the device is monitored and located to carry out further analysis to check if this device is causing any issues in the overall performance of the network.

For example, if there is a device which has caused an increase in the number of "access points overloaded by stations" and "access points overloaded by utilization" alarms, this could indicate that the access point cannot handle the stations. The administrator may need to reconsider re-deployment of the access points.

### Day-0 Attack by Device Security Anomaly

#### Alarm Description and Possible Causes

The addition of WLANs in the corporate environment introduces a new class of threats for network security. RF signals that penetrate walls and extend beyond intended boundaries can expose the network to unauthorized users. Rogue access points installed by employees for their personal use usually do not adhere to the corporate security policy. Rogue access points can put the entire corporate network at risk for outside penetration and attack. Besides rogue access points, there are many other wireless security vulnerabilities which compromise the wireless network such as misconfigured and unconfigured access points. There can also be DoS attacks from various sources against the corporate network.
WCS provides automated security vulnerability assessment within the wireless infrastructure that proactively reports any security vulnerabilities or mis-configurations. Further assessment may be done over-the-air via the Wireless IPS system. With the comprehensive suite of security monitoring technologies, the Cisco Adaptive Wireless IPS alerts the user on more than 100 different threat conditions in the following categories:

- User authentication and traffic encryption (Static WEP encryption, VPN, Fortress, Cranite, 802.11i and 802.1x)—Common security violations in this category (authentication and encryption) include mis-configurations, out-of-date software or firmware, and suboptimal choice of corporate security policy.
- Rogue, monitored, and ad-hoc mode devices—Rogue devices must be detected and removed immediately to protect the integrity of the wireless and wired enterprise network.
- Configuration vulnerabilities—Implementing a strong deployment policy is fundamental to a secure WLAN. However, enforcing the policy requires constant monitoring to catch violations caused by mis-configuration or equipment vendor implementation errors. With the increased trend on laptops with built-in Wi-Fi capabilities, the complexity of WLAN configuration extends beyond access points to the user laptops. WLAN device configuration management products can make the configuration process easier, but the need for validation persists especially in laptops with built-in but unused and unconfigured Wi-Fi.
- Intrusion detection on security penetration—A form of wireless intrusion includes breaching the WLAN authentication mechanism to gain access to the wired network or the wireless devices. A Dictionary attack on the authentication method is a very common attack against an access point. The intruder can also attack the wireless client station during its association process with an access point. For example, a faked AP attack on a unsuspicous wireless client may fool the client into associating with a fake access point. This attack allows the intruder to gain network access to the wireless station and potentially hack into its file system. The intruder can then use the station to access the wired enterprise network.
- Intrusion detection on DoS attacks—Wireless DoS (denial of service) attacks aim to disrupt wireless services by taking advantage of various vulnerabilities of WLAN at layer one and two. DoS attacks may target the physical RF environment, access points, client stations, or the back-end authentication RADIUS servers. For example, RF jamming attack with high power directional antenna from a distance can be carried out from the outside of your office building. Attack tools used by intruders leverage hacking techniques such as spoofed 802.11 management frames, spoofed 802.1x authentication frames, or simply using the brute force packet flooding method.

**wIPS Solution**

The Cisco Adaptive Wireless IPS detects a device violating a large number of Security IDS/IPS policies. This device has either generated a number of Security IDS/IPS violations in the time period specified or there is a sudden percentage increase as specified in the threshold settings for the various alarms. The device should be monitored and located to carry out further analysis to check if this device is compromising the Enterprise Wireless Network in any way (attack or vulnerability). If this is a rogue device, the WLAN administrator may use the integrated over-the-air physical location capabilities, or trace device on the wired network using rogue location discovery protocol (RLDP) or switchport tracing to find it.

**Device Probing for APs**

Some commonly used scan tools include: NetStumbler (newer versions), MiniStumbler (newer versions), MACStumbler, WaveStumbler, PrismStumbler, dStumbler, iStumbler, Aerosol, Boingo Scans, WiNc, AP Hopper, NetChaser, Microsoft Windows XP scans.
Alarm Description and Possible Causes

The Cisco Adaptive Wireless IPS detects wireless devices probing the WLAN and attempting association (such as association request for an access point with any SSID).

Such devices could pose potential security threats in one of the following ways:

- War-driving, WiLDing (Wireless LAN Discovery), war-chalking, war-walking, war cycling, war-lightrailing, war-busing, and war-flying.
- Legitimate wireless client attempting risky promiscuous association.

War-driving, war-chalking, war-walking, and war-flying activities include:

- War-driving—A wireless hacker uses war-driving tools to discover access points and publishes information such as MAC address, SSID, and security implemented on the Internet with the access points geographical location information.

Figure 20-21  802.11 Access Point Locations Posted on the Internet

- War-chalking—War-chalkers discover WLAN access points and mark the WLAN configuration at public locations with universal symbols (Figure 20-22).

Figure 20-22  War-Chalker Universal Symbols

- War-walking—War-walking is similar to war-driving, but the hacker is on foot instead of a car.
• War-flying—War-flying refers to sniffing for wireless networks from the air. The same equipment is used from a low flying private plane with high power antennas. It has been reported that a Perth, Australia-based war-flier picked up e-mail and Internet relay chat sessions from an altitude of 1,500 feet on a war-flying trip.

Figure 20-23 802.11 AP Location Posted on the Internet by War-driving Groups

Legitimate Wireless Client Attempting Risky Association

The second potential security threat for this alarm may be more damaging. Some of these alarms could be from legitimate and authorized wireless clients on your WLAN who are attempting to associate with any available access point including your neighbor access point or the more damage-causing rogue access point. This potential security threat can be from a Microsoft Windows XP laptop with a built-in Wi-Fi card or laptops using wireless connectivity tools such as the Boingo client utility and the WiNe client utility. When associated, this client station can be accessed by an intruder leading to a major security breach. Even worse, the client station may bridge the unintended access point with your company wired LAN. Typically, laptops are equipped with built-in Wi-Fi cards and, at the same, are physically attached to your company WLAN for network connectivity. Your wired network is exposed if the Windows bridging service is enabled on that Windows laptop. To be secure, configure all client stations with specific SSIDs to avoid associating with an unintended access point. Also consider mutual authentication such as 802.1x and various EAP methods.

The Cisco Adaptive Wireless IPS also detects a wireless client station probing the WLAN for an anonymous association such as an association request for an access point with any SSID) using the NetStumbler tool. The device probing for access point alarm is generated when hackers use the latest versions of the NetStumbler tool. For older versions, the NetStumbler detected alarm is triggered.

NetStumbler is the most widely used tool for war-driving and war-chalking. The NetStumbler website offers MiniStumbler software for use on Pocket PC hardware, saving war-walkers from carrying heavy laptops. It can run on a machine running Windows 2000, Windows XP, or more recent operating systems. It also supports more cards than Wellenreiter, another commonly used scanning tool. War-walkers like to use MiniStumbler and similar products to search shopping malls and retail stores.

wIPS Solution

To prevent your access points from being discovered by these hacking tools, configure the access points to not broadcast SSIDs. Use the Cisco Adaptive Wireless IPS to determine which access points are broadcasting (announcing) their SSID in the beacons.
Dictionary Attack on EAP Methods

Alarm Description and Possible Causes

EEE 802.1x provides an EAP framework for wired or wireless LAN authentication. An EAP framework allows flexible authentication protocol implementation. Some implementations of 802.1x or WPA use authentication protocols such as LEAP, MD5, OTP (one-time-password), TLS, and TTLS. Some of these authentication protocols are based upon the username and password mechanism in which the username is transmitted without encryption and the password is used to answer authentication challenges.

Most password-based authentication algorithms are susceptible to dictionary attacks. During a dictionary attack, an attacker gains the username from the unencrypted 802.1x identifier protocol exchange. The attacker then tries to guess a user password to gain network access by using every word in a dictionary of common passwords or possible combinations of passwords. A dictionary attack relies on a password being a common word, name, or combination of both with a minor modification such as a trailing digit or two.

A dictionary attack can take place actively online, where an attacker repeatedly tries all the possible password combinations. Online dictionary attacks can be prevented using lock-out mechanisms available on the authentication server (RADIUS servers) to lock out the user after a certain number of invalid login attempts. A dictionary attack can also take place offline, where an attacker captures a successful authentication challenge protocol exchange and then tries to match the challenge response with all possible password combinations. Unlike online attacks, offline attacks are not easily detected. Using a strong password policy and periodically expiring user passwords significantly reduces an offline attack tool’s success.

wIPS Solution

The Cisco Adaptive Wireless IPS detects online dictionary attacks by tracking 802.1x authentication protocol exchange and the user identifier usages. When a dictionary attack is detected, the alarm message identifies the username and attacking station MAC address.

The Cisco Adaptive Wireless IPS advises switching username and password based authentication methods to encrypted tunnel based authentication methods such as PEAP and EAP-FAST, which are supported by many vendors including Cisco.

EAP Attack Against 802.1x Authentication

Alarm Description and Possible Causes

IEEE 802.1x provides an Extensible Authentication Protocol (EAP) framework for wired or wireless LAN authentication. An EAP framework allows flexible authentication protocol implementation. Some implementations of 802.1x or WPA use authentication protocols such as LEAP, MD5, OTP (one-time-password), TLS, TTLS, and EAP-FAST. Some of these authentication protocols are based upon the username and password mechanism, where the username is transmitted clear without encryption and the password is used to answer authentication challenges.

Most password-based authentication algorithms are susceptible to dictionary attacks. During a dictionary attack, an attacker gains the username from the unencrypted 802.1x identifier protocol exchange. The attacker attempts to guess a user password and gain network access by using every "word" in a dictionary of common passwords or possible combinations of passwords. A dictionary attack relies on the fact that a password is often a common word, name, or combination of words or names with a minor modification such as a trailing digit or two.
Intruders with the legitimate 802.1x user identity and password combination (or valid certificate) can penetrate the 802.1x authentication process without the proper knowledge of the exact EAP-type. The intruder tries different EAP-types such as TLS, TTLS, LEAP, EAP-FAST, or PEAP to successfully log onto the network. This is a trial and error effort because there are only a handful of EAP-types for the intruder to try and manage to get authenticated to the network.

wIPS Solution

The Cisco Adaptive Wireless IPS detects an attempt by an intruder to gain access to the network using different 802.1x authentication types. Take appropriate steps to locate the device and remove it from the wireless environment.

Fake Access Points Detected

Alarm Description and Possible Causes

The Fake AP tool is meant to protect your WLAN acting as a decoy to confuse war-drivers using NetStumbler, Wellenreiter, MiniStumbler, Kismet, and so on. The tool generates beacon frames imitating thousands of counterfeit 802.11b access points. War-drivers encountering a large number of access points cannot identify the real access points deployed by the user. This tool, although very effective in fending off war-drivers, poses other disadvantages such as bandwidth consumption, misleading legitimate client stations, and interference with the WLAN management tools. Running the Fake AP tool in your WLAN is not recommended.

wIPS Solution

The administrator should locate the device running the Fake AP tool and remove it from the wireless environment.

Fake DHCP Server Detected

Alarm Description and Possible Causes

Dynamic Host Configuration Protocol (DHCP) is used for assigning dynamic IP addresses to devices on a network.

DHCP address assignment takes place as follows:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>The client NIC sends out a DHCP discover packet, indicating that it requires a IP address from a DHCP server.</td>
</tr>
<tr>
<td>2</td>
<td>The server sends a DHCP offer packet with the IP address.</td>
</tr>
<tr>
<td>3</td>
<td>The client NIC sends a DHCP request, informing the DHCP server that it wants to be assigned the IP address sent by the servers offer.</td>
</tr>
<tr>
<td>4</td>
<td>The server returns a DHCP ACK, acknowledging that the NIC has sent a request for a specific IP address.</td>
</tr>
<tr>
<td>5</td>
<td>The client interface assigns or binds the initially offered IP address from the DHCP server.</td>
</tr>
</tbody>
</table>

The DHCP server should be a dedicated machine and part of the enterprise wired network or it could be a wireless/wired gateway. Other wireless devices can have the DHCP service running innocently or maliciously so as to disrupt the WLAN IP service. Wireless clients that are requesting an IP address from the DHCP server may then connect to these fake DHCP servers to get their IP address because the clients do not have any means to authenticate the server. These fake DHCP servers may give the clients
non-functional network configurations or divert all the client's traffic through them. The hackers can then eavesdrop on every packet sent by the client. With the aid of rogue DNS servers, the hacker could also send the users to fake web page logins to get username and password credentials. It could also give out non-functional and non-routable IP addresses to achieve a DoS attack. This sort of attack is generally against a WLAN without encryption such as hotspots or trade show networks.

**wIPS Solution**

The Cisco Adaptive Wireless IPS detects such wireless STAs running the DHCP service and providing IP addresses to unaware users.

When the client is identified and reported, the WLAN administrator may use the integrated over-the-air physical location capabilities, or trace device on the wired network using rogue location discovery protocol (RLDP) or switchport tracing to find the device.

**Fast WEP Crack Tool Detected**

**Alarm Description and Possible Causes**

It is well publicized that WLAN devices using static WEP key for encryption are vulnerable to WEP key cracking attack (Refer to Weaknesses in the Key Scheduling Algorithm of RC4 - I by Scott Fluhrer, Itsik Mantin, and Adi Shamir).

*Figure 20-24 WEP Encipherment Block Diagram*

The WEP secret key that has been cracked by any intruder results in no encryption protection, thus leading to compromised data privacy. The WEP key that is in most cases 64-bit or 128-bit (few vendors also offer 152-bit encryption) consists of the secret key specified by the user linked with the 24-bit IV (Initialization Vector). The IV that is determined by the transmitting station can be reused frequently or in consecutive frames, thus increasing the possibility of the secret key to be recovered by wireless intruders.

The most important factor in any attack against the WEP key is the key size. For 64-bit WEP keys, around 150 K unique IVs and for 128-bit WEP keys around 500 k to a million unique IVs should be enough. With insufficient traffic, hackers have created a unique way of generating sufficient traffic to perform such an attack. This is called the replay attack based on arp-request packets. Such packets have a fixed length and can be spotted easily. By capturing one legitimate arp-request packet and resending them repeatedly, the other host responds with encrypted replies, providing new and possibly weak IVs.
The Cisco Adaptive Wireless IPS alerts on weak WEP implementations and recommends a device firmware upgrade if available from the device vendor to correct the IV usage problem. Ideally, enterprise WLAN networks can protect against WEP vulnerability by using the TKIP (Temporal Key Integrity Protocol) encryption mechanism, which is now supported by most enterprise level wireless equipment. TKIP enabled devices are not subject to any such WEP key attacks.

WCS also provides automated security vulnerability scanning that proactively reports any access points configured to utilize weak encryption or authentication. For more information on automated security vulnerability scanning, refer to the Cisco WCS online help.

**Fragmentation Attack**

**Alarm Description and Possible Causes**

It is well publicized that a WLAN device using a static WEP key for encryption is vulnerable to various WEP cracking attacks. Refer to *Weaknesses in the Key Scheduling Algorithm of RC4 - I* by Scott Fluhrer, Itsik Mantin, and Adi Shamir for more information.

![Figure 20-25 WEP Encipher Process Block Diagram](image)

A cracked WEP secret key offers no encryption protection for data to be transmitted which lead to compromised data privacy. The WEP key, which is in most cases 64-bit or 128-bit (few vendors also offer 152-bit encryption), is the secret key specified by the user and linked with the 24-bit IV (Initialization Vector).

According to [http://www.aircrack-ng.org/doku.php?id=fragmentation&s=fragmentation](http://www.aircrack-ng.org/doku.php?id=fragmentation&s=fragmentation), the aircrack program obtains a small amount of keying material from the packet and then attempts to send ARP and/or LLC packets with known information to an access point. If the packet gets successfully echoed back by the access point, then a larger amount of keying information can be obtained from the returned packet. This cycle is repeated several times until 1500 bytes (less in some cases) of PRGA are obtained.

This attack does not recover the WEP key itself, but merely obtains the PRGA. The PRGA can then be used to generate packets with “packetforge-ng” which can be used for various injection attacks.
Intrusion Detection—Security Penetration

Chapter 20  wiIPS Policy Alarm Encyclopedia

Figure 20-26  Commands to Run the Fragmentation Attack

```
Where:
- 5 means the fragmentation attack
- h XX:XX:XX:XX:XX is the MAC address of an associated client
   or your card’s MAC if you did fake authentication
- b YY:YY:YY:YY:YY is the access point MAC address
   ath0 is the wireless interface name
```

The Cisco Adaptive Wireless IPS detects potential fragmentation attacks in progress against the Wi-Fi network.

wiIPS Solution

The Cisco Adaptive Wireless IPS alerts on detecting a potential fragmentation attack in progress, and recommends that WEP not be used in the corporate environment and that appropriate measures be taken to avoid any security holes in the network and upgrade the wireless network infrastructure and devices to use the more secure IEEE 802.11i standard.

Hot-Spotter Tool Detected

Alarm Description and Possible Causes

A hotspot is any location where Wi-Fi network access available for the general public. Hotspots are often found in airports, hotels, coffee shops, and other places where business people tend to congregate. It is currently one of the most important network access service for business travelers. The customer requires a wireless-enabled laptop or handheld to connect to the legitimate access point and to receive service. Most hotspots do not require the user to have an advanced authentication mechanism to connect to the access point, other than using a web page to log in. The criterion for entry is only dependent on whether or not the subscriber has paid subscription fees. In a wireless hotspot environment, no one should trust anyone else. Due to current security concerns, some WLAN hotspot vendors are using 802.1x or higher authentication mechanisms to validate the identity of the user.
The four components of a basic hotspot network are:

- **Hotspot Subscribers**—Valid users with a wireless enabled laptop or handheld and valid login for accessing the hotspot network.
- **WLAN Access Points**—SOHO gateways or enterprise level access points depending upon the hotspot implementation.
- **Hotspot Controllers**—Deals with user authentication, gathering billing information, tracking usage time, filtering functions, and so on. This can be an independent machine or can be incorporated in the access point itself.
- **Authentication Server**—Contains the login credentials for the subscribers. In most cases, hotspot controllers verify subscriber credentials with the authentication server.

"Hotspotter" automates a method of penetration against wireless clients, independent of the encryption mechanism used. Using the Hotspotter tool, the intruder can passively monitor the wireless network for probe request frames to identify the SSIDs of the networks of the Windows XP clients.

After it acquires the preferred network information, the intruder compares the network name (SSID) to a supplied list of commonly used hotspot network names. When a match is found, the Hotspotter client acts as an access point. The clients then authenticate and associate unknowingly to this fake access point.

When the client gets associated, the Hotspotter tool can be configured to run a command such as a script to kick off a DHCP daemon and other scanning against the new victim.

Clients are also susceptible to this kind of attack when they are operating in different environments (home and office) while they are still configured to include the hotspot SSID in the Windows XP wireless connection settings. The clients send out probe requests using that SSID and make themselves vulnerable to the tool.
Intrusion Detection—Security Penetration

Chapter 20      wIPS Policy Alarm Encyclopedia

When the rogue access point is identified and reported by the Cisco Adaptive Wireless IPS, the WLAN administrator may use the integrated over-the-air physical location capabilities, or trace device on the wired network using rogue location discovery protocol (RLDP) or switchport tracing to find the rogue device.

**Malformed 802.11 Packets Detected**

**Alarm Description and Possible Causes**

Hackers using illegal packets (malformed non-standard 802.11 frames) can force wireless devices to behave in an unusual manner. Illegal packets can cause the firmware of a few vendor wireless NICs to crash.

Examples of such vulnerability includes NULL probe response frame (null SSID in the probe response frame) and oversized information elements in the management frames. These ill-formed frames can be broadcasted to cause multiple wireless clients to crash.

**wIPS Solution**

The Cisco Adaptive Wireless IPS can detect these illegal packets that may cause some NICs to lock up and crash. Also, wireless clients experiencing blue screen or lock-up problem during the attack period should consider upgrading the WLAN NIC driver or the firmware.

When the client is identified and reported by the Cisco Adaptive Wireless IPS, the WLAN administrator may use the device locator to locate it.

**Man-in-the-Middle Attack**

**Alarm Description and Possible Causes**

A Man-in-the-middle (MITM) attack is one of the most common 802.11 attacks that can lead to confidential corporate and private information being leaked to hackers. In a MITM attack, the hacker can use a 802.11 wireless analyzer and monitor 802.11 frames sent over the WLAN. By capturing the wireless frames during the association phase, the hacker gets IP and MAC address information about the wireless client card and access point, association ID for the client, and the SSID of the wireless network.
A common MITM attack involves the hacker sending spoofed disassociation or deauthentication frames. The hacker station then spoofs the MAC address of the client to continue an association with the access point. At the same time, the hacker sets up a spoofed access point in another channel to keep the client associated. All traffic between the valid client and access point then passes through the hacker station.

One of the most commonly used MITM attack tools is Monkey-Jack.

**wIPS Solution**

The Cisco Adaptive Wireless IPS recommends the use of strong encryption and authentication mechanisms to thwart any MITM attacks by hackers. One way to avoid such an attack is to prevent MAC address spoofing by using MAC address exclusion lists and monitoring the RF channel environment. Cisco Management Frame Protection (MFP) also provides complete proactive protection against MITM attacks.

**Monitored Device Detected**

**Alarm Description and Possible Causes**

There are some cases in which the access points and STAs activity must be continuously monitored:

- Malicious intruders attempting to hack into the enterprise wired network must be monitored. It is important to keep track of these access points and STAs to help avoid repeated rogue-related and intrusion attempt problems.
Intrusion Detection—Security Penetration

Chapter 20  wIPS Policy Alarm Encyclopedia

- Lost enterprise wireless equipment must be located.
- Vulnerable devices with previous security violations must be monitored.
- Devices used by ex-employees who may have not returned all their wireless equipment must be monitored.

These nodes may be added to the monitor list to alert the wireless administrator the next time the access point or STA shows up in the RF environment.

wIPS Solution

The wireless administrator can add the access point or STA to the monitor list by identifying it as a monitored device on the Cisco Adaptive Wireless IPS.

NetStumbler Detected

Alarm Description and Possible Causes

The Cisco Adaptive Wireless IPS detects a wireless client station probing the WLAN for an anonymous association (such as an association request for an access point with any SSID) using the NetStumbler tool. The Device probing for Access Point alarm is generated when hackers use recent versions of the NetStumbler tool. For older versions, the Cisco Adaptive Wireless IPS generates the NetStumbler detected alarm.

Figure 20-29  War-Chalker Universal Symbols

NetStumbler is the most widely used tool for war-driving and war-chalking. A wireless hacker uses war-driving tools to discover access points and to publish their information (MAC address, SSID, security implemented, and so on.) on the Internet with the access points' geographical location information. War-chalkers discover WLAN access points and mark the WLAN configuration at public locations with universal symbols as illustrated above. War-walking is similar to war-driving, but the hacker is on foot instead of a car. The NetStumbler website offers MiniStumbler software for use on Pocket PC hardware, saving war-walkers from carrying heavy laptops. It can run on a machine running Windows 2000, Windows XP, or later versions. It also supports more cards than Wellenreiter, another commonly used scanning tool. War-walkers like to use MiniStumbler and similar products to sniff shopping malls and big-box retail stores. War-flying is sniffing for wireless networks from the air. The same equipment is used from a low flying private plane with high power antennas. It has been reported that a Perth, Australia-based war-flier picked up email and Internet Relay Chat sessions from an altitude of 1,500 feet on a war-flying trip.
To prevent your access points from being discovered by these hacking tools, configure your access points to not broadcast its SSID. You can use the Cisco Adaptive Wireless IPS to see which of your access points is broadcasting an SSID in the beacons.

WCS also provides automated security vulnerability scanning that reports any access points configured to broadcast their SSIDs. For more information on automated security vulnerability scanning, refer to the Cisco WCS online help.

**NetStumbler Victim Detected**

**Alarm Description and Possible Causes**

The Cisco Adaptive Wireless IPS detects a wireless client station probing the WLAN for an anonymous association (such as association request for an access point with any SSID) using the NetStumbler tool. The Device probing for access point alarm is generated when hackers more recent versions of the NetStumbler tool. For older versions, the Cisco Adaptive Wireless IPS generates the NetStumbler detected alarm.

NetStumbler is the most widely used tool for war-driving, war-walking, and war-chalking. A wireless hacker uses war-driving tools to discover access points and publish their information (MAC address, SSID, security implemented, and so on.) on the Internet with the access point geographical location information. War-chalkers discover WLAN access points and mark the WLAN configuration at public locations with universal symbols as illustrated above. War-walking is similar to war-driving, but the hacker conducts the illegal operation on foot instead of by car. The NetStumbler website offers MiniStumbler software for use on Pocket PC hardware, saving war-walkers from carrying heavy laptops. It can run on a machine running Windows 2000, Windows XP, or later. It also supports more cards than Wellenreiter, another commonly used scanning tool. War-walkers typically use MiniStumbler and similar products to sniff shopping malls and big-box retail stores. War-flying is sniffing for wireless networks from the air. The same equipment is used, but from a low-flying private plane with high-power antennas. It has been reported that a Perth, Australia-based war-flier picked up e-mail and Internet Relay Chat sessions from an altitude of 1,500 feet on a war-flying trip.
The Cisco Adaptive Wireless IPS alerts the user when it observes that a station running Netstumbler is associated to a corporate access point.

wIPS Solution

To prevent your access points from being discovered by these hacking tools, configure your access points to not broadcast its SSID. You can use the Cisco Adaptive Wireless IPS to see which access point is broadcasting its SSID in the beacons.

Publicly Secure Packet Forwarding (PSPF) Violation Detected

Alarm Description and Possible Causes

PSPF is a feature implemented on WLAN access points to block wireless clients from communicating with other wireless clients. With PSPF enabled, client devices cannot communicate with other client devices on the wireless network.
For most WLAN environments, wireless clients communicate only with devices such as web servers on the wired network. By enabling PSPF it protects wireless clients from being hacked by a wireless intruder. PSPF is effective in protecting wireless clients especially at wireless public networks (hotspots) such as airports, hotels, coffee shops, and college campuses where authentication is null and anyone can associate with the access points. The PSPF feature prevents client devices from inadvertently sharing files with other client devices on the wireless network.

**wIPS Solution**

The Cisco Adaptive Wireless IPS detects PSPF violations. If a wireless client attempts to communicate with another wireless client, the Cisco Adaptive Wireless IPS raises an alarm for a potential intrusion attack. This alarm does not apply if your WLAN deploys wireless printers or VoWLAN applications because these applications rely on wireless client-to-client communication.

**ASLEAP Tool Detected**

**Alarm Description and Possible Causes**

WLAN devices using static WEP key for encryption are vulnerable to the WEP key cracking attack (See *Weaknesses in the Key Scheduling Algorithm of RC4-I* by Scott Fluhrer, Itsik Mantin, and Adi Shamir for more information).

Cisco Systems introduced LEAP (Lightweight Extensible Authentication Protocol) to leverage the existing 802.1x framework to avoid such WEP key attacks. The Cisco LEAP solution provides mutual authentication, dynamic per session and per user keys, and configurable WEP session key time out. The LEAP solution was considered a stable security solution and is easy to configure.

There are hacking tools that compromise wireless LAN networks running LEAP by using off-line dictionary attacks to break LEAP passwords. After detecting WLAN networks that use LEAP, this tool de-authenticates users which forces them to reconnect and provide their username and password credentials. The hacker captures packets of legitimate users trying to re-access the network. The attacker can then analyze the traffic off-line and guess the password by testing values from a dictionary.
The main features of the ASLEAP tool include:

- Reading live from any wireless interface in RFMON mode with libpcap.
- Monitoring a single channel or performing channel hopping to look for target networks running LEAP.
- Actively deauthenticating users on LEAP networks, forcing them to reauthenticate. This allows quick LEAP password captures.
- Only de-authenticating users who have not already been seen rather than users who are not running LEAP.
- Reading from stored libpcap files.
- Using a dynamic database table and index to allow quick lookups on large files. This reduces the worst-case search time to .0015% as opposed to lookups in a flat file.
- Writing only the LEAP exchange information to a libpcap file.

This could be used to capture LEAP credentials with a device short on disk space (like an iPaq); the LEAP credentials are then stored in the libpcap file on a system with more storage resources to mount the dictionary attack.

The source and Win32 binary distribution for the tool are available at http://asleap.sourceforge.net.

Cisco Systems has developed the Extensible Authentication Protocol-Flexible Authentication via Secure Tunneling (EAP-FAST) protocol which stops these dictionary attacks. EAP-FAST helps prevent man-in-the-middle attacks, dictionary attacks, and packet and authentication forgery attacks. In EAP-FAST, a tunnel is created between the client and the server using a PAC (Protected Access Credential) to authenticate each other. After the tunnel establishment process, the client is then authenticated using the user-name and password credentials.

Some advantages of EAP-FAST include:

- It is not proprietary.
- It is compliant with the IEEE 802.11i standard.
- It supports TKIP and WPA.
- It does not use certificates and avoids complex PKI infrastructures.
- It supports multiple Operating Systems on PCs and Pocket PCs.

**wIPS Solution**

The Cisco Adaptive Wireless IPS detects the deauthentication signature of the ASLEAP tool. When detected, the server alerts the wireless administrator. The user of the attacked station should reset the password. The best solution to counter the ASLEAP tool is to replace LEAP with EAP-FAST in the corporate WLAN environment.

WCS also provides automated security vulnerability scanning that proactively reports any access points configured to utilize weak encryption or authentication. For more information on automated security vulnerability scanning, refer to Cisco WCS online help.

**Honey Pot AP Detected**

**Alarm Description and Possible Causes**

The addition of WLANs in the corporate environment introduces a whole new class of threats for network security. RF signals that penetrate walls and extend beyond intended boundaries can expose the network to unauthorized users. A rogue access point can put the entire corporate network at risk for
outside penetration and attack. Not to understate the threat of the rogue access point, there are many other wireless security risks and intrusions such as mis-configured access points, unconfigured access points, and DoS (denial of service) attacks.

One of the most effective attacks facing enterprise networks implementing wireless is the use of a "honey pot" access point. An intruder uses tools such as NetStumbler, Wellenreiter, and MiniStumbler to discover the SSID of the corporate access point. Then the intruder sets up an access point outside the building premises or, if possible, within the premises and broadcasts the discovered corporate SSID. An unsuspecting client then connects to this "honey pot" access point with a higher signal strength. When associated, the intruder performs attacks against the client station because traffic is diverted through the "honey pot" access point.

**wIPS Solution**

When a "honey pot" access point is identified and reported by the Cisco Adaptive Wireless IPS, the WLAN administrator may use the integrated over-the-air physical location capabilities, or trace device on the wired network using rogue location discovery protocol (RLDP) or switchport tracing to find the rogue device.

**Soft AP or Host AP Detected**

Host AP tools: Cqure AP

**Alarm Description and Possible Causes**

A host-based access point (desktop or a laptop computer serving as a wireless access point) represents two potential threats to enterprise security. First, host based access points are not typically part of the enterprise wireless infrastructure and are likely to be rogue devices which do not conform to the corporate security policy. Second, host-based access points are used by wireless attackers as a convenient platform to implement various known intrusions such as man-in-the-middle, honey-pot access point, access point impersonation, and DoS (denial of service) attacks. Since software tools for turning a desktop or laptop into an access point can be easily downloaded from the Internet, host-based access points are more than just a theoretical threat.

Some laptops are shipped with the HostAP software pre-loaded and activated. When the laptops connect to the enterprise wireless network, they expose the wireless network to the hackers.

**wIPS Solution**

The Cisco Adaptive Wireless IPS detected soft access point should be treated as a rogue access point as well as a potential intrusion attempt. When the soft access point is identified and reported by the Cisco Adaptive Wireless IPS, the WLAN administrator may use integrated over-the-air physical location capabilities, or trace device on the wired network using rogue location discovery protocol (RLDP) or switchport tracing to find the rogue device.

**Spoofed MAC Address Detected**

Spoofing tools may include the following: SMAC, macchanger, and SirMACsAlot.
Alarm Description and Possible Causes

A wireless intruder can disrupt a wireless network using a wide range of available attack tools, many of which are available as free downloads from the Internet. Most of these tools rely on a spoofed MAC address which masquerades as an authorized wireless access point or as an authorized client. By using these tools, an attacker can launch various denial of service (DoS) attacks, bypass access control mechanisms, or falsely advertise services to wireless clients.

wIPS Solution

The Cisco Adaptive Wireless IPS detects a spoofed MAC address by following the IEEE authorized OUI (vendor ID) and 802.11 frame sequence number signature.

Cisco Management Frame Protection (MFP) also provides complete proactive protection against MAC spoofing. For more information on MFP, refer to the Cisco Wireless Control System Configuration Guide.

Suspicious After-Hours Traffic Detected

Alarm Description and Possible Causes

One way to detect a wireless security penetration attempt is to match wireless usage against the time when there is not supposed to be any wireless traffic. The wIPS server monitors traffic patterns against the office-hours configured for this alarm to generate alerts when an abnormality is found. Specific suspicious wireless usage sought after by the wIPS server during after-office hours includes the following:

- Client station initiating authentication or association requests to the office WLAN that may indicate security breach attempts.
- Wireless data traffic that may indicate suspicious download or upload over the wireless network.

wIPS Solution

For global wIPS deployment, the configurable office-hour range is defined in local time. The access point or sensor can be configured with a time zone to facilitate management. For the office and manufacturing floor mixed WLAN, one can define one set of office hours for the office WLAN SSID and another set for the manufacturing floor WLAN SSID. If this alarm is triggered, the administrator should look for the devices responsible for the suspicious traffic and remove them from the wireless environment.

Unauthorized Association by Vendor List

Alarm Description and Possible Causes

The Cisco Adaptive Wireless IPS enables network administrators to include vendor information in a policy profile to allow the system to effectively detect stations on the WLAN that are not made by approved vendors. When such a policy profile is created, the system generates an alarm whenever an access point is associating with a station by an unapproved vendor. See Figure 20-33.
As the diagram shows, the access points in ACL-1 should only associate with stations made by Cisco and the access points in ACL-2 can only associate with stations manufactured by Intel. This information is entered in the wIPS system policy profile. Any association between the access points and non-Cisco or non-Intel stations is unauthorized and triggers an alarm.

In the enterprise WLAN environment, rogue stations cause security concerns and undermine network performance. They take up air space and compete for network bandwidth. Since an access point can only accommodate a limited number of stations, it rejects association requests from stations when its capacity is reached. An access point laden with rogue stations denies legitimate stations the access to the network. Common problems caused by rogue stations include connectivity problems and degraded performance.

wIPS Solution

The Cisco Adaptive Wireless IPS automatically alerts network administrators to any unauthorized access point-station association involving non-conforming stations using this alarm. When the alarm has been triggered, the unauthorized station must be identified and actions must be taken to resolve the issue. One way is to block it using the rogue containment.

Unauthorized Association Detected

Alarm Description and Possible Causes

In an enterprise network environment, rogue access points installed by employees do not usually follow the network standard deployment practice and therefore compromise the integrity of the network. They are loopholes in network security and make it easy for intruders to hack into the enterprise wired
network. One of the major concerns that most wireless network administrators face is unauthorized associations between stations in an ACL and a rogue access point. Since data to and from the stations flows through the rogue access point, it leaves the door open for hackers to obtain sensitive information. Rogue stations cause security concerns and undermine network performance. They take up air space and compete for bandwidths on the network. Since an access point can only serve a certain number of stations, it rejects association requests from stations once its capacity is reached. An access point laden with rogue stations denies legitimate stations access to the network. Common problems caused by rogue stations include disrupted connections and degraded performance.

**wIPS Solution**

The Cisco Adaptive Wireless IPS can automatically alert network administrators to any unauthorized access point-station association it has detected on the network through this alarm. When the alarm is triggered, the rogue or unauthorized device must be identified and actions must be taken to resolve the reported issue.

**Wellenreiter Detected**

**Alarm Description and Possible Causes**

The Cisco Adaptive Wireless IPS detects a wireless client station probing the WLAN for an anonymous association (such as association request for an access point with any SSID) using the Wellenreiter tool.

![War-Chalker Universal Symbols](image)

Wellenreiter is a commonly used tool for war-driving and war-chalking. A wireless hacker uses war-driving tools to discover access points and to publish their information (MAC address, SSID, security implemented, and so on.) on the Internet with the access point geographical location information. War-chalkers discover WLAN access points and mark the WLAN configuration at public locations with universal symbols as illustrated above. War-walking is similar to war-driving, but the hacker is on foot instead of a car. War-walkers like to use Wellenreiter and similar products to sniff shopping malls and big-box retail stores. War-flying is sniffing for wireless networks from the air. The same equipment is used, but from a low flying private plane with high power antennas. It has been reported that a Perth, Australia-based war-flier picked up email and Internet Relay Chat sessions from an altitude of 1,500 feet on a war-flying trip.
The tool supports Prism2, Lucent, and Cisco-based cards. The tool can discover infrastructure and ad-hoc networks that are broadcasting SSIDs, their WEP capabilities, and can provide vendor information automatically. It also creates an ethereal/tcpdump-compatible dump file and an Application savefile. It also has GPS support. Users can download the tool from http://www.wellenreiter.net/index.html

**wIPS Solution**

To prevent your access points from being discovered by these hacking tools, configure your access points to not broadcast its SSID. You can use the Cisco Adaptive Wireless IPS to see which of your access points is broadcasting an SSID in the beacons.

WCS also provides automated security vulnerability scanning that reports any access points configured to broadcast their SSIDs. For more information on automated security vulnerability scanning, refer to the WCS online help.
Troubleshooting and Best Practices

This appendix identifies and explains any additional troubleshooting or best practices you may find necessary as you implement a particular function.

This appendix contains the following sections:

- Troubleshooting Cisco Compatible Extensions Version 5 Client Devices, page A-1
- Web Auth Security on WLANs, page A-3
- Rogue AP Background Task Performance Tuning, page A-9

Troubleshooting Cisco Compatible Extensions Version 5 Client Devices

Two features are designed to troubleshoot communication problems with Cisco Compatible Extensions Version 5 Client Devices: diagnostic channel and client reporting.

Note: These features are supported only on Cisco Compatible Extensions Version 5 Client Devices. They are not supported for use with non-Cisco Compatible Extensions Version 5 Client Devices or with clients running an earlier version.

Diagnostic Channel

The diagnostic channel feature enables you to troubleshoot problems regarding client communication with a WLAN. When initiated by a client having difficulties, the diagnostic channel is a WLAN configured to provide the most robust communication methods with the fewest obstacles to communication placed in the path of the client. The client and access points can be put through a defined set of tests in an attempt to identify the cause of communication difficulties experienced by the client.

Note: Only one WLAN per controller can have the diagnostic channel enabled, and all of the security on this WLAN is disabled.
Configuring the Diagnostic Channel

To configure the diagnostic channel, follow these steps:

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click an IP address to choose a specific controller.

**Step 3** Choose **WLAN> WLAN Configuration** from the left sidebar menu.

**Step 4** Choose **Add a WLAN** from the Select a command drop-down list to create a new or click the profile name of an existing.

**Note** We recommend that you create a new WLAN on which to run the diagnostic tests.

**Step 5** When the WLANs page appears, click the **Advanced** tab (see **Figure A-1**).

**Figure A-1 WLANs Advanced Tab**

<table>
<thead>
<tr>
<th>General</th>
<th>Security</th>
<th>QoS</th>
<th>Advanced</th>
</tr>
</thead>
<tbody>
<tr>
<td>Session Timeout(s):</td>
<td>Enable</td>
<td>DHCP</td>
<td>DHCP Server</td>
</tr>
<tr>
<td>Override Interface ACL</td>
<td>Choose</td>
<td></td>
<td>DHCP Addr. Assign.</td>
</tr>
<tr>
<td>Peer to Peer Blocking</td>
<td>Enable</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Client Exclusion</td>
<td>Enable</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Veto Blocking</td>
<td>Enable</td>
<td></td>
<td></td>
</tr>
<tr>
<td>NAC Support</td>
<td>Enable</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Footnotes:**
1. When enabled, a excluded time-out value of zero means infinity (will require administrative override to reset excluded clients.)
2. Layer 3 and/or Layer 2 security must be set to "None" if IPv6 and Global WebAuth configuration are enabled at same time.
3. Web Authentication cannot be used in combination with IPsec and LLDP.
4. CKIP is not supported on 104 APs.
5. P-RAP Local Switching is not supported with IPSec, LLDP, FTP, CRANITE and FORTRESS authentications. It is not net to WLAN IDs 9-16.
6. Client RPD is not active unless WPA2 is configured.
7. Select valid EAP profile name when local EAP authentication is enabled.
8. Select an EAP Authentication which has not already been assigned to any Guest LAN.
9. RPD configuration is supported only from 6.9.x.x.x versions of controllers.
10. Admin Status needs to be enabled for associating with a WLAN.

**Step 6** If you want to enable diagnostic channel troubleshooting on this WLAN, select the **Diagnostic Channel** check box. Otherwise, leave this check box unselected, which is the default value.
Web Auth Security on WLANs

This section describes the troubleshooting and best practices procedures that are useful when implementing web auth security on WLANs.

Web-auth is a Layer 3 security feature which allows web-based authentication to users on a WLAN. It is used mainly in guest networking scenarios, although not restricted to that usage.

When a WLAN is configured with web-auth security, you are redirected to the login page after passing Layer 2 authentications (static WEP, WPA+PSK, MAC filtering, and so on). The login page is stored on the local device or an external web server, and the page can be modified to allow a customized logo, title, and so on.

After the WLAN is configured with a web-auth WLAN, the HTTP get request is sent by the wireless client to the requested website. The controller firewall allows the DNS resolution of the specified URL. After the resolution, the controller interrupts the HTTP packets from the wireless client and redirects to the login page. When the credentials are entered on the login page and submitted, they are authenticated against the local database. If the user is not found in the local database, the configured RADIUS servers are contacted.

Note
PAP and CHAP authentication are used between the client and authentication agent. Make sure your RADIUS server supports both of these protocols so web-auth login is allowed.

Upon successful authentication, you are allowed to pass traffic. After three unsuccessful authentication attempts, the client is excluded. This excluded client cannot associate until the exclusion timeout limit is surpassed. The exclusion timeout limit is configured with aggressive load balancing, which actively balances the load between the mobile clients and their associated access points.

Web-auth WLAN is also configured with a pre-authentication access control list (ACL). This ACL is configured the same as a normal ACL but permits access to resources that the client needs prior to authentication. An administrator must use the interface section to apply an ACL to the client after authentication.

A web-auth WLAN can be configured with a session timeout value. This value defines the time the client needs to re-authenticate with the device. If the value is set to zero, which means infinity, the client never re-authenticates unless the logged out option is used. You can access the logout URL at http://<VirtualIP>/logout.html.

Note
Disable all pop-up blockers on the client to see the logout page.

Web-auth can be configured in different modes under Layer 3 security. The most commonly used modes of web-auth are as follows:

- Internal Web—Redirection to an internal page using http://<virtual IP /DNS name >/login.html. Customization is available.
- External Web—Redirection to an external URL.
Debug Commands

The following debug commands are allowed:

- `debug client <client-mac-address>`
- `debug pm ssh-tcp enable`
- `debug pm ssh-appgw enable`
- `debug pm rules enable`
- `debug pm config enable`
- `show client detail <client-mac-address>`
- `debug pem event enable`

Debug Strategy

To strategize for web-auth configured on a WLAN without guest tunneling, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Identify a mobile client to work with and write down its wireless MAC address. Use the command <code>prompt &gt; ipconfig /all</code> for all MS Windows-based systems.</td>
</tr>
<tr>
<td>2</td>
<td>Disable the mobile client’s radio.</td>
</tr>
<tr>
<td>3</td>
<td>Enter the following debug commands via a serial console set for high speed (115200) or SSH session to the controller’s management port: <code>debug client &lt;client-mac-address&gt;</code> <code>debug pm ssh-tcp enable</code> <code>debug pm ssh-appgw enable</code> <code>debug pm rules enable</code> <code>debug pm config enable</code> <code>show client detail &lt;client-mac-address&gt;</code> <code>debug pem event enable</code> <code>debug pem state enable</code>.</td>
</tr>
<tr>
<td>4</td>
<td>Enable the radio and let the client associate. After the client is associated, enter the <code>show client detail &lt;client-mac-address&gt;</code> command.</td>
</tr>
</tbody>
</table>

$Router1> show client detail 00:0b:85:09:96:10
Client Username........................................ N/A
AP MAC Address........................................ 00:0b:85:09:96:10:10
Client State........................................... Associated
Wireless LAN Id....................................... 1
BSSID................................................ 00:0b:85:09:96:1f
Channel.............................................. 11
IP Address.......................................... 10.50.234.3
Association Id....................................... 1
Authentication Algorithm............................ Open System
Reason Code.......................................... 0
Status Code......................................... 0
Session Timeout..................................... 0
Client CCX version................................. 3
Mirroring............................................ Disabled
QoS Level.......................................... Silver
A-5

Cisco Wireless Control System Configuration Guide

Appendix A      Troubleshooting and Best Practices

Web Auth Security on WLANs

Diff Serv Code Point (DSCP)...................... disabled
802.1P Priority Tag.............................. disabled
WMM Support...................................... Disabled
Mobility State..................................... Local
Internal Mobility State......................... apfMmInitial
Mobility Move Count............................ 0
--More-- or (q)uit
Security Policy Completed...................... No
Policy Manager State............................. WEBAUTH_REQD ========**
Policy Manager Rule Created..................... Yes
NPU Fast Fail Notified............................ Yes
Last Policy Manager State....................... WEBAUTH_REQD
Client Entry Create Time......................... 67733 seconds
Policy Type...................................... N/A
Encryption Cipher................................ None
Management Frame Protection..................... No
EAP Type......................................... Unknown
Interface......................................... management
VLAN.............................................. 0

Client Capabilities:
  CF Pollable...................................... Not implemented
  CF Poll Request............................... Not implemented
  Short Preamble................................ Implemented
  PBCC........................................... Not implemented
  Channel Agility............................... Not implemented
  Listen Interval............................... 0

Client Statistics:
  Number of Bytes Received.................... 188595
  Number of Bytes Sent........................ 19229
  Number of Packets Received................... 3074

--More-- or (q)uit
  Number of Packets Sent....................... 76
  Number of Policy Errors...................... 0
  Radio Signal Strength Indicator............. -41 dBm
  Signal to Noise Ratio........................ 59 dB

Nearby AP Statistics:
  TxExcessiveRetries: 0
  TxRetries: 0
  RtsSuccessCnt: 0
  RtsFailCnt: 0
  TxFiltered: 0
  TxRateProfile: [0, 0, 0, 0, 0, 0, 0, 0, 0, 0]
  ap:09:96:10(slot 1) .......................
  antenna0: 48 seconds ago -45 dBm......... antenna1: 123 seconds ago -128 dBm

Step 5  Make sure the client’s pemstate is WEBAUTH_REQD. Open the browser page on the client and look for the following messages:

Wed Mar  7 17:59:15 2007: sshpmAddWebRedirectRules: mobile station addr is 10.50.234.3
Wed Mar  7 17:59:15 2007: sshpmAddWebRedirectRules: RuleID for ms 10.50.234.3 is 44
Wed Mar  7 17:59:15 2007: sshpmRuleIndexInsert: adding rule for RuleID 44
Wed Mar  7 17:59:15 2007: sshpmRuleIndexInsert: computed raw hash index 02ad3271 for rule id 0000002c
Wed Mar  7 17:59:15 2007: sshpmRuleIndexInsert: computed adjusted index 000000c32 for rule id 0000002c
Web Auth Security on WLANs

Appendix A  Troubleshooting and Best Practices

Cisco Wireless Control System Configuration Guide

Wed Mar  7 17:59:15 2007: sshpmPolicyCommitCallback: called; ContextPtr: 0x2c; Success: 1
Web Auth Security on WLANs

Wed Mar 7 18:02:36 2007: SshAppgwHttp/appgw_http.c:136/ssh_appgw_http_st_wait_input: read -1 bytes (offset 0 data 0)
Wed Mar 7 18:02:41 2007: 00000000: 4745 5420 2f20 4854 5450 2f31 2e31 0d0a  GET / HTTP/1.1..n
Wed Mar 7 18:02:41 2007: 00000010: 4163 6365 7074 3a20 696d 6167 652f 6769  Accept: image/gif
Wed Mar 7 18:02:41 2007: 00000020: 662c 2069 6d61 6765 2f78 2d78 6269 746d  f,, image/x-xbitmap
Wed Mar 7 18:02:41 2007: 00000030: 6170 2c20 696d 6167 652f 706a 7065 672c  ap,, image/jpeg,
Wed Mar 7 18:02:41 2007: 00000040: 696d 6167 652f 706a 7065 672c 2061 7070  image/pjpeg,
Wed Mar 7 18:02:41 2007: 00000050: 6c69 6361 7469 6f6e 2f78 2d73 686f 636b  application/x-shockwave-flash,
Wed Mar 7 18:02:41 2007: 00000060: 7761 7665 2d66 6c61 7368 2c20 2a2f 2a0d  wave-flash, */*
Wed Mar 7 18:02:41 2007: 00000070: 0a41 6363 6570 742d 4c61 6e67 7561 6765 .Accept-Language
Wed Mar 7 18:02:41 2007: 00000080: 3a20 4d6f 7a69 6c6c 612f 34 2e30  : en-us,.Accept-
Wed Mar 7 18:02:41 2007: 00000090: 456e 636f 6469 6e67 3a20 4d6f 7a69 6c6c  Encoding:
Wed Mar 7 18:02:41 2007: 000000a0: 6465 666c 6174 650d 0a55 7365 722d 4167 deflate,.User-Agent
Wed Mar 7 18:02:41 2007: 000000b0: 656e 743a 2028 636f 6d70 6174 6962 3b20 5769 6e64 6f77 7320  Windows
Wed Mar 7 18:02:41 2007: 000000c0: 2028 636f 6d70 6174 6962 3b20 5769 6e64 6f77 7320  IE 6.0;
Wed Mar 7 18:02:41 2007: 000000d0: 4945 5420 2f20 4d6f 7a69 6c6c 612f 34 2e30  GET / HTTP/1.1,
Wed Mar 7 18:02:41 2007: 000000e0: 4e54 2035 2e31 3b20 5374 3a20 3a20 3130 2e30 34 511;Ho
Wed Mar 7 18:02:41 2007: 00000100: 0a43 6f66 6e65 6374 696f 6e6a 3a20 20 6a 0.3.Connection: Kee
Wed Mar 7 18:02:41 2007: 00000110: 702d 416c 6976 656d 0a0d 0a  p-Alive....
Step 6 If you do not see the HTTP GET message, the HTTP packet has not reached the controller. After the client completes the redirection, enter your login and submit it.

Step 7 Look at the client’s entry in NPUdevshell hapiMmcDebugScbInfoShow (‘client mac address’). If the PEM state is not moved from WEBAUTH_REQD to RUN, a credential problem exists. Check the credentials in the local or RADIUS database (where ever they were configured).

Step 8 When the RUN state appears on the client, perform a check from the client to the gateway and see if traffic is being passed.

Best Practices

If the client is not redirected to the login page and you want to avoid DNS resolution in the network, enter http://controller-mgmt-ip. If a redirection occur, the issue is not network related.

Enter `config network web-auth-port Port` to define the ports on the controller other than the standard HTTP port (80). The controller does not interrupt secure HTTP or HTTPS (443) even if the port is configured for interrupt.
Rogue AP Background Task Performance Tuning

Cisco WCS provides a configuration file to tune the performance of rogue AP background task. The configuration file is RogueAP.properties and is present under the webnms/classes/com/cisco/server/faultmanagement directory.

The default content in the file is as follows:

```plaintext
# Enable/disable rogue ap detecting detail data collecting, true is for enable, false is to disable.
RogueAPTask.SaveDetectingInfo=true

# Update rogue AP data batch size. Use this parameter to tune DB batch update performance.
RogueAPTask.BatchSize=1000
```

You can choose to disable the `SaveDetectingInfo` setting by changing the value to `false`. This setting will be effective after restarting WCS.

As the result, the rogue AP background task will not save rogue AP by controllers information into WCS and only saves a consolidated rogue AP information. This helps when you have lots of rogue AP detected and see a performance concern. Also, you could not see any entries when going to the Rogue AP alarm details page and select the View details by Controller command.
WCS and End-User Licenses

This appendix provides the end-user license and warranty information that apply to the Cisco WCS. It contains these sections:

- WCS Licenses, page B-1
- Notices and Disclaimers, page B-5
- End-User License Agreement, page B-7

WCS Licenses

Before you purchase a Cisco Wireless Control System (WCS) license, decide whether if you will need a Base or PLUS license and how many access points will need to be supported and licensed.

The two types of licenses for Cisco WCS support different feature levels:

- Cisco WCS Base supports standard WCS capabilities, which includes wireless client data access, rogue access point containment functions, Cisco WLAN Solution monitoring and control, and client and rogue access point location to the nearest access point.

- Cisco WCS PLUS license supports Cisco WCS base license features and the following capabilities: mobility services enablement and high availability. An older Cisco WCS Location license is forward compatible and equivalent to a PLUS license. When upgrading to this release, older Location licenses will appear as PLUS licenses. Older Enterprise licenses are also forward compatible and become PLUS licenses when loaded. The process to provision a Cisco WCS PLUS license is the same as provisioning a current Cisco WCS license.

See the “Managing Licenses” section on page 16-109 for information on managing WCS licenses on the GUI.

Types of Licenses

The licensing information for existing Cisco WCS deployments are being upgraded to support Cisco Unified Wireless Network Software Release 4.1.82.0. (While previous Cisco WCS SKUs will be available until September 2006, We recommend that you purchase the new Cisco WCS SKUs outlined in the WCS Ordering Guide (http://www.cisco.com/en/US/prod/collateral/wireless/ps5755/ps6301/ps6305/product_data_sheet0900aecd804b4646.html) for a more seamless migration to licensing. This chapter includes information on new or expansion Cisco WCS licenses, migrating from CiscoWorks Wireless LAN Solution Engine
WCS Licenses

(WLSE) to Cisco WCS, upgrading to the Cisco WCS Location option, and deploying the free Cisco WCS demonstration license. The versions of Cisco Wireless Control System (WCS) licenses are as follows:

- **WCS-ENT-PLUS-K9**—Cisco WCS Enterprise PLUS License with Mobility Services Enablement, High availability, and Windows or Linux on multiple Cisco WCS servers.

- **WCS-STANDARD-K9** — For customer buying new or expansion Cisco WCS licenses running Cisco Unified Wireless Network Software. It is available as Cisco WCS Base or Cisco WCS PLUS option in increments of 50, 100, or 500 lightweight access points.

  **Note** When the number of access points exceeds the limit of those licensed, WCS generates an alarm. Also, when the user logs into WCS, they are alerted if the licensed access point count has been exceeded.

- **WCS-WLSE-UPG-K9** — For CiscoWorks WLSE customers migrating from CiscoWorks WLSE (Model 1130) to Cisco WCS. See Appendix B for steps to migrate from CiscoWorks WLSE to the Cisco Unified Wireless Network architecture. It is available as a WCS-WLSE Base option or a WCS-WLSE PLUS option in increments of 50, 100, 500, or 1000 lightweight access points.

  **Note** Dell platforms are not supported.

  **Note** CiscoWorks WLSE Express (Model 1030) and CiscoWorks WLSE (Model 1105 or 1133) are NOT supported with this SKU. DO NOT install the CiscoWorks WLSE CDs on the CiscoWorks WLSE Express (Model 1030) appliance or CiscoWorks WLSE (Model 1105 or 1133) because this conversion does not work and is not supported by Cisco Systems.

- **WCS-PLUS-UPG-K9** — For customers upgrading from their existing Cisco WCS Base licenses to equivalent Cisco WCS PLUS licenses. It is available as Cisco WCS PLUS in increments of 50, 100, or 500 lightweight access points.

- **WCS-ADV-SI-SE-10**—An incremental license that enables the integration of up to 10 Spectrum Experts. This license requires a valid Base or PLUS license.

- **AIR-WCS-DEMO-K9** — For customers wishing to download the new full featured, PLUS Cisco WCS with Spectrum Integration demonstration license that supports ten access points for up to 30 days. Demo licenses are available at [http://www.cisco.com/go/license](http://www.cisco.com/go/license).

  **Note** The free 30-day trial license is NOT supported by the Cisco Technical Assistance Center (TAC).

---

**Licensing Enforcement**

Cisco Unified Wireless Network Releases enforces software based licensing. Customers are prompted to enter license files by all new Cisco WCS SKU families. Existing customers migrating to a later release are also impacted by licensing and should contact their Cisco Sales Representative or TAC to obtain Product Authorization Key (PAK) certificate if they have not already received PAK certificate from Cisco. For more information, refer to the WCS Ordering Guide ([http://www.cisco.com/en/US/products/ps6305/products_data_sheet0900aecd804b4646.html](http://www.cisco.com/en/US/products/ps6305/products_data_sheet0900aecd804b4646.html)).
All Cisco WCS licenses can be purchased or acquired directly from Cisco.com via the normal Cisco ordering processes. Cisco Unified Wireless Network Software Releases can be downloaded from Cisco.com or, for a nominal charge, a CD (WCS-CD-K9) can be purchased from the WCS-STANDARD-K9 or WCS-PLUS-UPG-K9 SKU families. The WCS-CD-K9 contains one software image of Cisco WCS version 4.0 on a CD. Customers can select the appropriate Cisco WCS installer to designate whether they would like to install a Windows or Linux version. The Cisco WCS Base or PLUS features and access point quantity are activated after installation by inserting the license file that is tied to the original purchased Cisco WCS SKU. This CD is shipped via U.S. mail to the purchaser’s address.

For the WCS-WLSE-UPG-K9 SKU family, two CDs are automatically shipped with any order in this specific SKU family. These CDs are special purpose CDs that are used specifically to convert the Cisco Works WLSE platform to Cisco WCS.

The Cisco WCS free demonstration license, AIR-WCS-DEMO-K9 is only available as a software download from Cisco.com. Within the 30 day trial period, this free license can be upgraded to one of the non-expiring Cisco WCS SKUs by applying license files generated through the purchase of one of the non-expiring Cisco WCS SKU families.

### Product Authorization Key Certificate

All Cisco WCS SKUs require a PAK certificate to register the Cisco WCS license. The PAK is a paper certificate sent via U.S. mail from Cisco Systems upon purchase of the Cisco WCS license. The PAK certificate allows customers to receive a Cisco WCS license. It is used to register the Cisco WCS and generate license files. All customers must go to the PAK registration site listed on their PAK certificate to complete their Cisco WCS registration. The PAK certificate provides clear instructions on how to complete the Cisco WCS licensing process.

---

**Note**

All customers that purchase Cisco WCS from Cisco.com via download or CD must activate their Cisco WCS license by registering at the PAK site. Customers receive the PAK via U.S. mail. Cisco WCS will not be activated until the PAK registration process is completed.

### Determining Which License To Use

You should select the correct license based on your deployment situation, the number of access points to be supported, and Cisco WCS options (base or location). All SKUs within a SKU family can be combined with equivalent option levels such as Base to Base or PLUS to PLUS. Unequal option levels (Base and PLUS) cannot be mixed. Only one type of license can be used on the WCS at one time. For example, if your computer has a PLUS license, you cannot add a Base license. You can add to the current license by purchasing a license to increase the access point count. For example, if you have a PLUS license with an access point count of 50 and in a year you need to add more access points, you can buy another PLUS license with an access point count of 100, apply it to the WCS, and have a WCS with PLUS license for 150 access points. You can add a license to increase the number of access points in increments of 50, 100, 500, 1000, or 2500.

---

**Note**

If you have a Base license and want to upgrade to a PLUS, you will need to purchase a PLUS upgrade license. You need to purchase a PLUS upgrade license equivalent to the total number of access points with a Base license. For example, if you have three Base licenses with support for 50, 100, and 200 access points (for a total of 350 access points), you must purchase enough upgrade licenses with support for 350 access points.
Installing a License

You need to have the Wireless Control System license key file to install your license. The key file is distributed to you in an e-mail from Cisco Systems. This file activates the features that you have purchased for your Cisco Wireless Control System (WCS). Do not edit the contents of the .lic file in any way or you will render the file useless.

**Note**

If you upgrade to a WCS version without a license, you receive a critical alarm once a day and a notification regarding lack of a license each time you log in to WCS. Without a license, you have access to all WCS functionality except adding new controllers.

We strongly recommend that you print the e-mail, save the attachment to a removable media, and store both in a safe place for future use, if needed by either yourself or anyone in your organization.

Before you proceed, make sure that the WCS server software has been installed and configured on the server.

To install the WCS license, follow these steps:

---

**Step 1** Save the license file (.lic) to a temporary directory on your hard drive.

**Step 2** Open a supported browser.

**Step 3** In the Location or Address text box, enter the following URL, replacing IP address or host name of the WCS server: https://<IP address>.

**Step 4** Log in to the WCS server as system administrator. User names and passwords are case-sensitive.

**Step 5** Choose **Administration > License Center**.

**Step 6** Choose **Files > WCS** from the left sidebar menu.

**Step 7** Click **Add**. The Add a License File page appears.

**Step 8** In the Add a License File page, click **Browse** to navigate to the location where you saved the .lic file.

**Step 9** Click **Upload**.

The WCS server imports the license.

During the upload the following items are checked:

- Validity of the license file.
- Matching host names on the license and WCS system.
- The license file being installed must have a PLUS Feature. For example, Base or PLUS.
- The PLUS Feature (Base or PLUS) of the file being installed must match that of the system.

If you encounter a problem with the license file, please contact the Cisco Licensing team at 800-553-2447 or licensing@cisco.com.

---

Backup and Restore License

The license files are saved as part of the backup and restore process, so upgrading WCS will not require reentering of the license files. However, the restore must be on a system with the same host name for the restored licenses to work. If you have installed an upgraded license on your system, you must reinstall...
the original license, followed by the upgrade license. For example, if you have upgraded a license from Base license to PLUS license, during the reinstall, you need to first install the Base license, then install the PLUS license. To backup the WCS database, see the “Backing Up the WCS Database” section on page 4-9.

Notices and Disclaimers

This chapter/appendix contains notices and disclaimers that pertain to Cisco WCS/Cisco WLAN Controller/whatever other product.

Notices

The following notices pertain to this software license.

OpenSSL/Open SSL Project

This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/).

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com).

This product includes software written by Tim Hudson (tjh@cryptsoft.com).

License Issues

The OpenSSL toolkit stays under a dual license, for example, both the conditions of the OpenSSL License and the original SSLeay license apply to the toolkit. See below for the actual license texts. Actually both licenses are BSD-style Open Source licenses. In case of any license issues related to OpenSSL please contact openssl-core@openssl.org.

OpenSSL License:
Copyright © 1998-2007 The OpenSSL Project. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions, and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the following acknowledgment: “This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/)”.

4. The names “OpenSSL Toolkit” and “OpenSSL Project” must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact openssl-core@openssl.org.

5. Products derived from this software may not be called “OpenSSL” nor may “OpenSSL” appear in their names without prior written permission of the OpenSSL Project.
6. Redistributions of any form whatsoever must retain the following acknowledgment:

“This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org)/”.

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT “AS IS” AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com). This product includes software written by Tim Hudson (tjh@cryptsoft.com).

**Original SSLeay License:**

Copyright © 1995-1998 Eric Young (eay@cryptsoft.com). All rights reserved.

This package is an SSL implementation written by Eric Young (eay@cryptsoft.com).

The implementation was written so as to conform with Netscape’s SSL.

This library is free for commercial and non-commercial use as long as the following conditions are adhered to. The following conditions apply to all code found in this distribution, be it the RC4, RSA, SHHash, DES, etc., code; not just the SSL code. The SSL documentation included with this distribution is covered by the same copyright terms except that the holder is Tim Hudson (tjh@cryptsoft.com).

Copyright remains Eric Young’s, and as such any Copyright notices in the code are not to be removed. If this package is used in a product, Eric Young should be given attribution as the author of the parts of the library used. This can be in the form of a textual message at program startup or in documentation (online or textual) provided with the package.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the following acknowledgement:

   “This product includes cryptographic software written by Eric Young (eay@cryptsoft.com)”.

   The word ‘cryptographic’ can be left out if the routines from the library being used are not cryptography-related.

4. If you include any Windows specific code (or a derivative thereof) from the apps directory (application code) you must include an acknowledgement: “This product includes software written by Tim Hudson (tjh@cryptsoft.com)”.

THIS SOFTWARE IS PROVIDED BY ERIC YOUNG “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The license and distribution terms for any publicly available version or derivative of this code cannot be changed. i.e. this code cannot simply be copied and put under another distribution license [including the GNU Public License].

Disclaimers

All third party trademarks are the property of their respective owners.

End-User License Agreement

IMPORTANT: PLEASE READ THIS END USER LICENSE AGREEMENT CAREFULLY. DOWNLOADING, INSTALLING OR USING CISCO OR CISCO-SUPPLIED SOFTWARE CONSTITUTES ACCEPTANCE OF THIS AGREEMENT.

CISCO IS WILLING TO LICENSE THE SOFTWARE TO YOU ONLY UPON THE CONDITION THAT YOU ACCEPT ALL OF THE TERMS CONTAINED IN THIS LICENSE AGREEMENT. BY DOWNLOADING OR INSTALLING THE SOFTWARE, OR USING THE EQUIPMENT THAT CONTAINS THIS SOFTWARE, YOU ARE BINDING YOURSELF AND THE BUSINESS ENTITY THAT YOU REPRESENT (COLLECTIVELY, "CUSTOMER") TO THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS AGREEMENT, THEN CISCO IS UNWILLING TO LICENSE THE SOFTWARE TO YOU AND (A) DO NOT DOWNLOAD, INSTALL OR USE THE SOFTWARE, AND (B) YOU MAY RETURN THE SOFTWARE FOR A FULL REFUND, OR, IF THE SOFTWARE IS SUPPLIED AS PART OF ANOTHER PRODUCT, YOU MAY RETURN THE ENTIRE PRODUCT FOR A FULL REFUND. YOUR RIGHT TO RETURN AND REFUND EXPIRES 30 DAYS AFTER PURCHASE FROM CISCO OR AN AUTHORIZED CISCO RESELLER, AND APPLIES ONLY IF YOU ARE THE ORIGINAL END USER PURCHASER.

The following terms of this End User License Agreement ("Agreement") govern Customer's access and use of the Software, except to the extent (a) there is a separate signed agreement between Customer and Cisco governing Customer's use of the Software or (b) the Software includes a separate "click-accept" license agreement as part of the installation and/or download process. To the extent of a conflict between the provisions of the foregoing documents, the order of precedence shall be (1) the signed agreement, (2) the click-accept agreement, and (3) this End User License Agreement.

License. Conditioned upon compliance with the terms and conditions of this Agreement, Cisco Systems, Inc. or its subsidiary licensing the Software instead of Cisco Systems, Inc. ("Cisco"), grants to Customer a nonexclusive and nontransferable license to use for Customer's internal business purposes the Software...
and the Documentation for which Customer has paid the required license fees. "Documentation" means written information (whether contained in user or technical manuals, training materials, specifications or otherwise) specifically pertaining to the Software and made available by Cisco with the Software in any manner (including on CD-Rom, or on-line).

Customer's license to use the Software shall be limited to, and Customer shall not use the Software in excess of, a single hardware chassis or card or such number and types of agent(s), concurrent users, sessions, IP addresses, port(s), seat(s), server(s), site(s), features and feature sets as are set forth in the applicable Purchase Order which has been accepted by Cisco and for which Customer has paid to Cisco the required license fee.

Unless otherwise expressly provided in the Documentation, Customer shall use the Software solely as embedded in, for execution on, or (where the applicable documentation permits installation on non-Cisco equipment) for communication with Cisco equipment owned or leased by Customer and used for Customer's internal business purposes. NOTE: For evaluation or beta copies for which Cisco does not charge a license fee, the above requirement to pay license fees does not apply.

**General Limitations.** This is a license, not a transfer of title, to the Software and Documentation, and Cisco retains ownership of all copies of the Software and Documentation. Customer acknowledges that the Software and Documentation contain trade secrets of Cisco, its suppliers or licensors, including but not limited to the specific internal design and structure of individual programs and associated interface information. Accordingly, except as otherwise expressly provided under this Agreement, Customer shall have no right, and Customer specifically agrees not to:

(i) transfer, assign or sublicense its license rights to any other person or entity, or use the Software on unauthorized or secondhand Cisco equipment, and Customer acknowledges that any attempted transfer, assignment, sublicense or use shall be void;

(ii) make error corrections to or otherwise modify or adapt the Software or create derivative works based upon the Software, or permit third parties to do the same;

(iii) reverse engineer or decompile, decrypt, disassemble or otherwise reduce the Software to human-readable form, except to the extent otherwise expressly permitted under applicable law notwithstanding this restriction;

(iv) use or permit the Software to be used to perform services for third parties, whether on a service bureau or time sharing basis or otherwise, without the express written authorization of Cisco; or

(v) disclose, provide, or otherwise make available trade secrets contained within the Software and Documentation in any form to any third party without the prior written consent of Cisco. Customer shall implement reasonable security measures to protect such trade secrets.

To the extent required by law, and at Customer's written request, Cisco shall provide Customer with the interface information needed to achieve interoperability between the Software and another independently created program, on payment of Cisco's applicable fee, if any. Customer shall observe
strict obligations of confidentiality with respect to such information and shall use such information in compliance with any applicable terms and conditions upon which Cisco makes such information available.

**Software, Upgrades and Additional Copies.** For purposes of this Agreement, "Software" shall include (and the terms and conditions of this Agreement shall apply to) computer programs, including firmware, as provided to Customer by Cisco or an authorized Cisco reseller, and any upgrades, updates, bug fixes or modified versions thereto (collectively, "Upgrades") or backup copies of the Software licensed or provided to Customer by Cisco or an authorized Cisco reseller. NOTWITHSTANDING ANY OTHER PROVISION OF THIS AGREEMENT: (1) CUSTOMER HAS NO LICENSE OR RIGHT TO USE ANY ADDITIONAL COPIES OR UPGRADES UNLESS CUSTOMER, AT THE TIME OF ACQUIRING SUCH COPY OR UPGRADE, ALREADY HOLDS A VALID LICENSE TO THE ORIGINAL SOFTWARE AND HAS PAID THE APPLICABLE FEE FOR THE UPGRADE OR ADDITIONAL COPIES; (2) USE OF UPGRADES IS LIMITED TO CISCO EQUIPMENT FOR WHICH CUSTOMER IS THE ORIGINAL END USER PURCHASER OR LESSEE OR WHO OTHERWISE HOLDS A VALID LICENSE TO USE THE SOFTWARE WHICH IS BEING UPGRADED; AND (3) THE MAKING AND USE OF ADDITIONAL COPIES IS LIMITED TO NECESSARY BACKUP PURPOSES ONLY.

**Proprietary Notices.** Customer agrees to maintain and reproduce all copyright and other proprietary notices on all copies, in any form, of the Software in the same form and manner that such copyright and other proprietary notices are included on the Software. Except as expressly authorized in this Agreement, Customer shall not make any copies or duplicates of any Software without the prior written permission of Cisco.

**Term and Termination.** This Agreement and the license granted herein shall remain effective until terminated. Customer may terminate this Agreement and the license at any time by destroying all copies of Software and any Documentation. Customer's rights under this Agreement will terminate immediately without notice from Cisco if Customer fails to comply with any provision of this Agreement. Upon termination, Customer shall destroy all copies of Software and Documentation in its possession or control. All confidentiality obligations of Customer and all limitations of liability and disclaimers and restrictions of warranty shall survive termination of this Agreement. In addition, the provisions of the sections titled "U.S. Government End User Purchasers" and "General Terms Applicable to the Limited Warranty Statement and End User License" shall survive termination of this Agreement.

**Customer Records.** Customer grants to Cisco and its independent accountants the right to examine Customer's books, records and accounts during Customer's normal business hours to verify compliance with this Agreement. In the event such audit discloses non-compliance with this Agreement, Customer shall promptly pay to Cisco the appropriate license fees, plus the reasonable cost of conducting the audit.

**Export.** Software and Documentation, including technical data, may be subject to U.S. export control laws, including the U.S. Export Administration Act and its associated regulations, and may be subject to export or import regulations in other countries. Customer agrees to comply strictly with all such regulations and acknowledges that it has the responsibility to obtain licenses to export, re-export, or import Software and Documentation.

**U.S. Government End User Purchasers.** The Software and Documentation qualify as "commercial items," as that term is defined at Federal Acquisition Regulation ("FAR") (48 C.F.R.) 2.101, consisting of "commercial computer software" and "commercial computer software documentation" as such terms
End-User License Agreement

are used in FAR 12.212. Consistent with FAR 12.212 and DoD FAR Supp. 227.7202-1 through 227.7202-4, and notwithstanding any other FAR or other contractual clause to the contrary in any agreement into which this End User License Agreement may be incorporated, Customer may provide to Government end user or, if this Agreement is direct, Government end user will acquire, the Software and Documentation with only those rights set forth in this End User License Agreement. Use of either the Software or Documentation or both constitutes agreement by the Government that the Software and Documentation are "commercial computer software" and "commercial computer software documentation," and constitutes acceptance of the rights and restrictions herein.

Limited Warranty

Subject to the limitations and conditions set forth herein, Cisco warrants that commencing from the date of shipment to Customer (but in case of resale by an authorized Cisco reseller, commencing not more than ninety (90) days after original shipment by Cisco), and continuing for a period of the longer of (a) ninety (90) days or (b) the warranty period (if any) expressly set forth as applicable specifically to software in the warranty card accompanying the product of which the Software is a part (the "Product") (if any): (a) the media on which the Software is furnished will be free of defects in materials and workmanship under normal use; and (b) the Software substantially conforms to the Documentation. The date of shipment of a Product by Cisco is set forth on the packaging material in which the Product is shipped. Except for the foregoing, the Software is provided AS IS. This limited warranty extends only to the Customer who is the original licensee. Customer's sole and exclusive remedy and the entire liability of Cisco and its suppliers and licensors under this limited warranty will be (i) replacement of defective media and/or (ii) at Cisco's option, repair, replacement, or refund of the purchase price of the Software, in both cases subject to the condition that any error or defect constituting a breach of this limited warranty is reported to Cisco or the party supplying the Software to Customer, if different than Cisco, within the warranty period. Cisco or the party supplying the Software to Customer may, at its option, require return of the Software as a condition to the remedy. In no event does Cisco warrant that the Software is error free or that Customer will be able to operate the Software without problems or interruptions. In addition, due to the continual development of new techniques for intruding upon and attacking networks, Cisco does not warrant that the Software or any equipment, system or network on which the Software is used will be free of vulnerability to intrusion or attack.

Restrictions. This warranty does not apply if the Software, Product or any other equipment upon which the Software is authorized to be used (a) has been altered, except by Cisco or its authorized representative, (b) has not been installed, operated, repaired, or maintained in accordance with instructions supplied by Cisco, (c) has been subjected to abnormal physical or electrical stress, misuse, negligence, or accident; or (d) is licensed, for beta, evaluation, testing or demonstration purposes for which Cisco does not charge a purchase price or license fee.

DISCLAIMER OF WARRANTY. EXCEPT AS SPECIFIED IN THIS WARRANTY, ALL EXPRESS OR IMPLIED CONDITIONS, REPRESENTATIONS, AND WARRANTIES INCLUDING, WITHOUT LIMITATION, ANY IMPLIED WARRANTY OR CONDITION OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, NON-INFRINGEMENT, SATISFACTORY QUALITY, NON-INTERFERENCE, ACCURACY OF INFORMATIONAL CONTENT, OR ARISING FROM A COURSE OF DEALING, LAW, USAGE, OR TRADE PRACTICE, ARE HEREBY EXCLUDED TO THE EXTENT ALLOWED BY APPLICABLE LAW AND ARE EXPRESSLY DISCLAIMED BY CISCO, ITS SUPPLIERS AND LICENSORS. TO THE EXTENT AN IMPLIED WARRANTY CANNOT BE EXCLUDED, SUCH WARRANTY IS LIMITED IN DURATION TO THE EXPRESS WARRANTY PERIOD. BECAUSE SOME STATES OR JURISDICTIONS DO NOT ALLOW LIMITATIONS ON HOW LONG AN IMPLIED WARRANTY LASTS, THE ABOVE LIMITATION MAY NOT APPLY. THIS WARRANTY GIVES CUSTOMER SPECIFIC LEGAL RIGHTS, AND CUSTOMER MAY ALSO HAVE OTHER RIGHTS WHICH VARY FROM JURISDICTION TO JURISDICTION. This disclaimer and exclusion shall apply even if the express warranty set forth above fails of its essential purpose.

General Terms Applicable to the Limited Warranty Statement and End User License Agreement
Disclaimer of Liabilities. REGARDLESS WHETHER ANY REMEDY SET FORTH HEREIN FAILS OF ITS ESSENTIAL PURPOSE OR OTHERWISE, IN NO EVENT WILL CISCO OR ITS SUPPLIERS BE LIABLE FOR ANY LOST REVENUE, PROFIT, OR LOST OR DAMAGED DATA, BUSINESS INTERRUPTION, LOSS OF CAPITAL, OR FOR SPECIAL, INDIRECT, CONSEQUENTIAL, INCIDENTAL, OR PUNITIVE DAMAGES HOWEVER CAUSED AND REGARDLESS OF THE THEORY OF LIABILITY OR WHETHER ARISING OUT OF THE USE OF OR INABILITY TO USE SOFTWARE OR OTHERWISE AND EVEN IF CISCO OR ITS SUPPLIERS OR LICENSORS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. In no event shall Cisco's or its suppliers' or licensors' liability to Customer, whether in contract, tort (including negligence), breach of warranty, or otherwise, exceed the price paid by Customer for the Software that gave rise to the claim or if the Software is part of another Product, the price paid for such other Product. BECAUSE SOME STATES OR JURISDICTIONS DO NOT ALLOW LIMITATION OR EXCLUSION OF CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO YOU.

Customer agrees that the limitations of liability and disclaimers set forth herein will apply regardless of whether Customer has accepted the Software or any other product or service delivered by Cisco. Customer acknowledges and agrees that Cisco has set its prices and entered into this Agreement in reliance upon the disclaimers of warranty and the limitations of liability set forth herein, that the same reflect an allocation of risk between the parties (including the risk that a contract remedy may fail of its essential purpose and cause consequential loss), and that the same form an essential basis of the bargain between the parties.

The validity, interpretation, and performance of this Warranty and End User License shall be controlled by and construed under the laws of the State of California, United States of America, as if performed wholly within the state and without giving effect to the principles of conflict of laws, and the State and federal courts of California shall have jurisdiction over any claim arising under this Agreement. The parties specifically disclaim the UN Convention on Contracts for the International Sale of Goods. Notwithstanding the foregoing, either party may seek interim injunctive relief in any court of appropriate jurisdiction with respect to any alleged breach of such party's intellectual property or proprietary rights. If any portion hereof is found to be void or unenforceable, the remaining provisions of the Agreement shall remain in full force and effect. Except as expressly provided herein, this Agreement constitutes the entire agreement between the parties with respect to the license of the Software and Documentation and supersedes any conflicting or additional terms contained in any purchase order or elsewhere, all of which terms are excluded. This Agreement has been written in the English language, and the parties agree that the English version will govern.

Supplemental License Agreement

Cisco Wireless Control System (WCS)

IMPORTANT-READ CAREFULLY

You have agreed to the Cisco System, Inc. End User License Agreement (“EULA”) that governs your access and use of the Cisco Wireless Control System (“WCS”). This supplemental license agreement (this "supplement") contains additional terms and conditions.

Capitalized terms used and not defined in this supplement have the meanings as defined in the EULA. To the extent of a conflict between the provisions of this supplement and the EULA, this supplement takes precedence.

By installing, downloading, accessing or otherwise using the Software, Customer agrees to be bound by the terms of this supplement. If Customer does not agree to the terms of this supplement, Customer may not install, download, or otherwise use the Software.

Restrictions on Managed Access Point and Devices

Customer may not use the Software unless:
End-User License Agreement

- Customer obtains a WCS limited license by placing a Purchase Order for a WCS license for a specific number of access points, having the Purchase Order accepted by Cisco, and paying to Cisco the required license fee; or
- Customer obtains a WCS demonstration license by registering and downloading the Software for demonstration purposes in accordance with the Cisco Data Sheet for the Cisco Wireless Control System (the "WCS Data Sheet").

If Customer obtains a WCS limited license, Customer may not use the Software to manage more access points than those identified in the Software's Cisco SKU or the product description on Customer's accepted, paid Purchase Order plus those identified in the Software's Cisco SKUs or the product descriptions on Customer's prior accepted, paid Purchase Orders.

If Customer obtains a WCS demonstration license, Customer may not use the Software to manage more than the number of access points identified for the Cisco WCS demonstration license in the WCS Data Sheet.

Customer may use the Software only to manage those devices identified as managed devices in the product specifications section of WCS Data Sheet.

Server Restrictions
Customer may install and run the Software on multiple servers if the Software's Cisco SKU or product description on Customer's accepted, paid Purchase Order identifies the product as an enterprise or "ent" license. Otherwise, Customer may install and run the Software on only a single server.

Third-Party Proprietary Software
The Software includes proprietary software and technology from Cisco's suppliers. Some suppliers are intended third-party beneficiaries of the EULA and this supplement. Third-party-beneficiary suppliers include: (a) Hifn, Inc.; (b) Wind River Systems, Inc. and its suppliers; and (c) any other supplier Cisco identifies as a third-party beneficiary in the Documentation or additional supplements. These suppliers may enforce, and are express beneficiaries of, the EULA and this supplement. However, they are not in any contractual relationship with Customer.

The limited warranty in the EULA is made only by Cisco and is disclaimed by all Cisco suppliers. Cisco and any Cisco supplier may obtain injunctive relief if Customer's use of the Software is in violation of any license restrictions.

Open-Source Software
The Software includes certain open-source software. Despite anything to the contrary in the EULA or this supplement, the open-source software is governed by the terms and conditions of the applicable open-source license. The open-source software, the applicable open-source licenses and other open-source notices may be identified in the Documentation or in a README file accompanying the Software. Customer agrees to comply with all such licenses and other notices.

Other Terms and Conditions
The terms of the EULA and this supplement may be enforced by license registration and other software tools.
Conversion of a WLSE Autonomous Deployment to a WCS Controller Deployment

This appendix describes how to convert a Cisco Wireless LAN Solution Engine (WLSE) network management appliance to a Cisco Wireless Control System (WCS) network management station. After converting a WLSE appliance to WCS, you must re-create configuration templates and manually add access points (or import them). For information on how to migrate the data, see the “Importing or Exporting WLSE Map Data” section on page 5-114.

After WLSE is converted to WCS, it can no longer be used as a WLSE or converted back into a WLSE. This is a one-way conversion only.

- WLSE Autonomous: A WLSE network management appliance is deployed with autonomous access points from the Aironet products. Some access points act as domain controllers (WDS) for sets of access points in a SWAN architecture, and the access points communicate over the wired network using the WLCCP protocol.

  The WLSE network management station is a Cisco appliance with the WLSE software installed.

- WCS Controller: A WCS network management station is deployed on customer selected hardware running Red Hat Enterprise Linux. The network management station manages controller switches that control access points. The controllers communicate over the wired network with access points using the LWAPP protocol.

  - WCS maintains the Cisco wireless LAN solution configuration, which includes controllers, access points, and location appliances.
  
  - It enables Cisco WCS system administrators to assign logins, passwords, and privileges for all Cisco WCS operators and to set times for periodic system tasks.
  
  - It allows Cisco WCS operators to use a web browser on any connected workstation to access Cisco WCS configuration, monitoring, and administrative functions. The Cisco WCS operators can also add, change, and delete Wireless LAN Solution components and configurations in the Cisco WCS database, depending on privilege level.

This appendix contains these sections:

- Supported Hardware, page C-2
- Installation and Configuration, page C-2
- Minor Upgrades to WCS, page C-3
- Licensing, page C-7
Supported Hardware

Cisco WLSE Management Stations

The conversion from WLSE management station to WCS management station is supported on the Cisco 1130-19 and 1133 hardware platforms.

Note

The conversion from WLSE management station to WCS management station is not supported on the Cisco WLSE 1030 Express platform.

Autonomous Access Points Convertible to LWAPP

The following autonomous AP models can be converted to a WCS controller deployment:

- Cisco Aironet 1230AG Series Access Point (AP 1232AG)
- Cisco Aironet 1200 Series Access Point (AP 1200)
- Cisco Aironet 1130AG Series Access Point (AP 1131AG)

Installation and Configuration

To convert a WLSE network management appliance to a WCS network management station, you need three CDs:

- A conversion CD for the Wireless Control System version 4.0 release. This CD installs the WCS software and Red Hat Enterprise Linux 3 on the WLSE network management appliance.
- An upgrade CD to upgrade the WCS network management station to Red Hat Enterprise Linux 4. It is necessary to complete the installation of WCS software and Red Hat Enterprise Linux 3 prior to performing the Red Hat Enterprise Linux 4 upgrade due to the partitioning of the WLSE network station.

Note

After you have converted the WLSE network management appliance to a WCS network management station, it is irreversible and you cannot convert back to a WLSE network management appliance.

- An upgrade CD to upgrade the WCS network management station to Red Hat Enterprise Linux 5. It is necessary to complete the installation of WCS software and Red Hat Enterprise Linux 4 prior to performing the Red Hat Enterprise Linux 5 upgrade due to the partitioning of the WLSE network station.

Installing Cisco WCS

Follow these steps to install the Cisco WCS software. You need to have physical access to the WLSE network management appliance. Console access is necessary to the WLSE appliance because the setup and install scripts require console interaction. The complete installation process takes approximately 45 seconds.
Before installing the WCS software, back up any data on your WLSE appliance that you would like for record keeping. To back up the data, refer to Backing Up and Restoring Data in the User Guide for the CiscoWorks WLSE and WLSE Express.

Step 1 Insert the installation CD with the WCS software and the Red Hat Linux Enterprise 3 software into the CD drive of the WLSE network management appliance.

Step 2 Using the command-line interface (CLI) prompt, log in the WLSE as administrator.

Step 3 Enter the reload command to reboot. The WLSE reboots, loads, and then installs from the CD. After the install, the CD automatically ejects and reboots again.

Step 4 Log in using root as the username and setup as the password. You are guided through the WCS wizard setup scripts as you would in a regular WCS install. Answer the prompts with the applicable values for your network setup. See the “Installing WCS for Linux” procedure on page 2-11 if you need further assistance.

Note If you cannot execute the installation file, enter the chmod +x WCS-install-file.bin command.

Step 5 When you are prompted to reboot, type Y or Yes. After the reboot continue to the “Upgrading to Red Hat Enterprise Linux 4 or 5” section on page C-3.

Upgrading to Red Hat Enterprise Linux 4 or 5

Follow these steps to upgrade the WLSE network management station to Red Hat Enterprise Linux 4 or 5.

Note Before upgrading the Red Hat Enterprise Linux, you should have already converted WLSE to the Cisco WCS software and Red Hat Linux Enterprise 3 software.

Step 1 Insert the upgrade CD with the Red Hat Enterprise Linux upgrade software (either version 4 or 5 as needed) into the CD drive of the WLSE network management appliance.

Step 2 Log in using root as the username and the password you were supplied in the wizard.

Step 3 Enter the reboot command to reboot the WLSE network management appliance.

Minor Upgrades to WCS

If you need to perform a minor upgrade that does not require an upgrade of Red Hat, you can download the upgrade from cisco.com and burn a CD yourself. If you burn a CD yourself, you cannot access the CD drive from the Linux CLI so you must mount the CD drive using mount /dev/cdrom /media.
Configuring the Converted Appliance

If you have installed Red Hat Linux 3 with the CD and performed the upgrade to 4.0, you are ready to configure the appliance. After the Linux installation, the machine reboots. You must have a connection to the appliance console, and then you are prompted to log in. After you log in, you are presented with the following prompts over the console connection.

### Caution

After WLSE is converted to WCS, it can no longer be used as a WLSE or converted back into a WLSE. This is a one-way conversion only.

### Note

The WCS server will not start until you have configured the appliance.

localhost.localdomain login:

Enter the login root.

Password:

Enter the setup password.

Setup parameters via Setup Wizard (yes/no) [yes]:

Enter yes if you want to use the setup wizard or No if you want to manually set the parameters. Only experienced Linux system administrators should opt to configure the system using the setup script. The option in square brackets is the default. You can press Enter to choose that default.

Current hostname=[localhost]
Configure hostname? (Y)es/(S)kip/(U)se default [Yes]:

The host name is a unique name that can identify the device on the network.

Enter a host name [localhost]:

The host name should start with a letter, end with a letter or number, and contain only letters, numbers, and dashes.

Current domain=[localdomain]
Configure domain name? (Y)es/(S)kip/(U)se default [Yes]:

A domain name specifies the network domain this device belongs to.

Enter a domain name [localdomain]:

The domain name should start with a letter, end with a valid domain name suffix (such as .com), and contain only letters, numbers, dashes, and dots.

Configure root password? (Y)es/(S)kip/(U)se default [Yes]:

Press Enter to choose Yes.

Enter root password:

Confirm root password:

Enter a password for the superuser and confirm it by typing it again. Your typing is not visible.

Remote root login is currently disabled.
Configure remote root access? (Y)es/(S)kip/(U)se default [Yes]:


To enable root login over secure shell for this machine, choose **Yes**. This allows a root login both from the console and using SSH. Otherwise, choose **Skip**. If you choose to leave remote root login disabled, then a root login can only occur from the console.

Enable remote root login (yes/no) [no]

Choose **yes** to allow remote login through SSH in addition to console login. Choose **no** to allow root login only from the console.

Choose **Yes** to begin setup for the main ethernet interface. A network administrator can provide the information for the following prompts.

Enter eth0 IP address:

Enter network mask [255.255.0.0]:

Enter the network mask for the IP address you provided.

Enter default gateway address:

Provide the default gateway that must be reachable from the main Ethernet interface.

The second Ethernet interface is currently disabled for this machine.

Choose **Yes** if you want to provide information for a second Ethernet interface. If you choose to configure eth1, you must manually edit the WCS property file (/opt/WCS4.0/webnms/classes/com/aes/common/net/LocalHostUtils.properties) to specify which of the eth1 or eth0 are used to communicate with controllers and which are used to communicate with location servers. (Changing the ManagementInterface= line to either ManagementInterface=eth0 or ManagementInterface=eth1 specifies the controller interface. Changing the PeerServerInterface= line to either PeerServerInterface=eth0 or PeerServerInterface=eth1 specifies the location server interface. This can be skipped, and the next prompt you would see would be DNS.

Enter eth1 IP address [none]:

Enter an IP address for the second Ethernet interface on this machine.

Because you entered an IP address for the second interface of this machine, you are given the opportunity to define up to two static routing entries for that interface. Each entry requires a network address, network mask, and a gateway address.

Enter network mask [255.0.0.0]:

Enter the network mask for the IP address you specified.

Enter network [none]:

Enter the network address.

Enter network mask [255.0.0.0]:

Enter the network mask for the IP address you provided.

Enter gateway address:

Enter a gateway address for the network and network mask you provided.
Domain Name Service (DNS) Setup
DNS is currently enabled.
No DNS servers currently defined
Configure DNS related parameters? (Y)es/(S)kip/(U)se default [Yes]:

You can enter up to three DNSs, but you can also leave it disabled. No servers have been defined.

Enable DNS (yes/no) [yes]:

Choose Yes to enable DNS.

Enter primary DNS server IP address:

Enter the IP address for this DNS server.

Enter backup DNS server IP address (or none) [none]:

Enter the backup IP address. If you enter a second DNS server, you are prompted for an optional third server.

Configure timezone? (Y)es/(S)kip/(U)se default [Yes]:

Choose Yes to configure the timezone.

Please identify a location so that time zone rules can be set correctly.
Please select a continent or ocean.
1) Africa
2) Americas
3) Antarctica
4) Arctic Ocean
5) Asia
6) Atlantic Ocean
7) Australia
8) Europe
9) Indian Ocean
10) Pacific Ocean
11) UTC - I want to use Coordinated Universal Time.
12) Return to previous setup step (^).

You need to select a location so that time zone rules can be set correctly. Choose the number for the appropriate continent or ocean.

Please select a country.

You are given a choice of countries based on the continent or ocean you selected. Choose the appropriate number.

Please select one of the following time zone regions.

Enter the number for the desired time zone region based on the country you selected.

The timezone information you chose is given.

Is the above information OK?
1) Yes
2) No

Choose Yes to verify if the information is correct. If No, you will be taken through the series of prompts again.

NTP is currently disabled.
Configure NTP related parameters? (Y)es/(S)kip/(U)se default [Yes]:

If you choose to enable network time protocol (NTP), the system is configured from the NTP servers you select. If you choose Skip, you are prompted to enter the current date and time.
Enable NTP (yes/no) [no]:

If you choose Yes, you will be required to enter an NTP server name or address.

Enter NTP server name or address:
Enter another NTP server IP address (or none) [none]:

All of your selections are shown. You are then asked to verify all the setup information you provided.
You can enter Yes to proceed with the configuration, No to make more changes, or ^ to go back to the previous step.

Is the above information correct (yes, no, or ^):

If yes, the configuration information will be applied. We recommend that you reboot the system when prompted to ensure that changes occur. The WCS server starts automatically after the reboot.
The next time you log in using root, you will only get the Linux shell prompt and not the setup script.
You can rerun the setup script at any time to change settings by logging in using root and running /opt/setup-appliance/setup.sh.

Licensing

You will need a license to access the complete WCS user interface on the WLSE network management appliance. A discounted WCS WLSE Upgrade License is available for these appliances. When you purchase the license, you receive the WCS-WLSEU-K9-4.1.xx.0.iso conversion file you need and the WCS-WLSEU-K9-4.0.xx.0.upgrade.iso upgrade file you need.

Note In the filename xx represents the version number.

WLSE Upgrade License

The WLSE Upgrade license can only be used on a converted WLSE appliance. It cannot be transferred to a different machine at a later time.
The WLSE Upgrade license must be specific to the hostname of the network station that you are converting from WLSE to WCS. The installation and startup will proceed without the license but you cannot access the WCS user interface without the license.
To install the license, see the Appendix B, “WCS and End User Licenses.”
Cisco WCS Server Hardening

This appendix provides an instructional checklist for hardening a WCS server. Ideally, the goal of a hardened server is to leave it exposed on the Internet without any other form of protection. This appendix describes the hardening of WCS, which requires some services and processes exposed to function properly. Think of it as WCS Best Practices. Hardening of WCS will involve disabling unnecessary services, removing and modifying registry key entries, and applying appropriate restrictive permissions to files, services, and end points.

This appendix contains the following sections:

- Running WCS as Non-Privileged Account, page D-1
- Tomcat Shutdown Prevention, page D-10
- WCS Password Handling, page D-10
- Setting Up SSL Certification, page D-11

Running WCS as Non-Privileged Account

Web servers provide data through an externally or publicly exposed interface, this is a well-known target for exploitation. Unprotected web servers provide an avenue for malicious activity, such as theft or the denial of service to an organization's resources.

A Non-Privileged account allows you to work as a normal account and launching applications or tools using the credentials of a different account (most likely your administrator account).

Note

In Linux, you need not run WCS as a Non-Privileged Account as Linux starts as root to port 80 and then switches effective userid to nobody.

Creating a Non-Privileged User

To create a Non-Privileged User, follow these steps:

Step 1
Create a new user by choosing Administrator Tools > Computer Management or right-click My Computer > Manage from the drop-down list. You will see the Computer Management window. (See Figure D-1)
Step 2  Click **Local users and Groups** and click the Users folder. Right-click in the right pane and click "**New User**". (See Figure D-2)
Step 3  In the New User dialog box, type in your preferences for a new user name and password (this will be your secondary Administrator account). For example, use wcsuser is the username and wcsuser is the password. Click Create. (See Figure D-3)
Step 4  You need to add the new user to a group. Expand the Local Users and Groups option, right-click the groups and select the **New Group** option. Use wcsgroup as the groupname, and click **Add**, and select **wcsuser**. (See **Figure D-4**)

**Figure D-4**  **New Group**

![New Group](image)

Step 5  To provide permission for wcs group, you need to go to specific WCS installation path, add wcsgroup on the Security tab, and select permissions for wcsgroup.
Figure D-5  Adding a group into security

Step 6  Add Log on service rights for wcsgroup by running secpol.msc from start run command-line. That is, In the Local Security Settings window, select Local Policies > User Rights Assignment and double-click the Log on as as service policy. Add wcsgroup to this policy. (See Figure D-6)
Appendix D      Cisco WCS Server Hardening

Running WCS as Non-Privileged Account

Figure D-6      Local Security Settings

Step 7  Edit the wrapper.conf file located at C:\Program Files\WCSx.xx.x\webnms\conf in your machine or appropriate directory in your setup:

wrapper.ntservice.account=wcs-nms-1\wcsuser
wrapper.ntservice.password=wcsuser

Step 8  Execute the below scripts for install services with new wcsuser account settings. (See Figure D-7):

C:\Program Files\WCS7.0.129.0\bin\UninstallService.bat
C:\Program Files\WCS7.0.129.0\bin\InstallService.bat
Step 9  Change the Properties of WCS Installation directories and files under it to wcsgroup on the Security tab for read, execute, and modify (See Figure D-8):

Figure D-8  Security Tab for WCS Installation Folder
Running WCS as Non-Privileged Account

Step 10  Open the registry editor from the run command-line and provide the permission for Javasoft directory to wcsgroup users to the read execute and write Javasoft directory (See Figure D-9):

**Figure D-9  Registry Editor**

![Registry Editor](image)

Step 11  Open PackagingResources.properties file in <WCS_HOME>\websms\classes\com\cisco\packaging directory, search for "NonPrivUser" attribute, and change it to true (See Figure D-11):
Step 12  Restart the WCS server again from the services window (See Figure D-11):

Figure D-11    Starting WCS Service
Tomcat Shutdown Prevention

On Windows, the file which controls the web service is the Server.xml file. Read and Write or Full Control access to this file is to be limited to the SA, Web Manager or Web Manager's designees.

Tomcat can be shut down maliciously by any user with a browser. Tomcat uses port 8005 for its remote shutdown sequence command. So, the line

```
Server port="8005" shutdown="SHUTDOWN" debug="0"
```

in server.xml should be modified to have some other string than "SHUTDOWN". This string must be modified to "C15C0WC5".

Note: The File permissions for server.xml is the full control, read/write access is given to Administrator only. Others have only read and read/execute permissions.

WCS Password Handling

You can configure additional authentication by configuring the Local Password Policy parameters. Select the check boxes if you want the configurations to be enabled.

Figure D-12 Local PAssword Policy
The following configurations are added for additional authentication:

- You can configure that the password cannot be reused until N number of new passwords are used. This figure is configurable.
- You can configure that the password cannot be changed for a minimum interval of 24 hours from last change.
- You can configure locking of an account if X number of attempts failed. The X figure is configurable.
- You can configure whether you want the account to be disabled or not if it is unused for 30 days.
- You can configure the expiry time of the password. This is configurable and the unit is in days.
- You can configure to enforce a user to change the password on first login.

**Setting Up SSL Certification**

The Secure Sockets Layer (SSL) Certification is to ensure secure transactions between a web server and the browsers. Installing the DoD Certificates will allow your Web browser to trust the identity and provide secure communications which are authenticated by Department of Defense (DoD).

These certificates are used to validate the identity of the server or web site and are used to generate the encryption key used in the SSL. This encryption protects the information being passed between the server and the client.

This section describes the SSL Certification and contains the following topics:

- Setting Up SSL Client Certification, page D-11
- Setting Up SSL Server Certification, page D-12

**Setting Up SSL Client Certification**

To setup the SSL Client Certificate Authentication using DoD certificates, follow these steps:

**Note**

As a prerequisite, to create the SSL Certificates, you would require “KeyTool” available in JDK. KeyTool is a command line tool to manage keystores and the certificates.

**Step 1**

Create SSL Client Certificate using the following command:

```
% keytool -genkey -keystore nmsclientkeystore -storetype pkcs12 -keyalg RSA -keysize 2048 -alias nmsclient -dname "CN=nmsclient, OU=WNBU, O=Cisco, L=San Jose, ST=CA, C=US" -storepass nmskeystore
```

**Note**

Provide the Key Algorithm as RSA and KeySize as 1024 or 2048.

**Step 2**

Generate the Certificate Signing Request (CSR) using the following command:

```
% keytool -certreq -keyalg RSA -keysize 2048 -alias nmsclient -keystore nmsclientkeystore -storetype pkcs12 -file <csrfilename>
```

**Note**

Provide the Key Algorithm as RSA and KeySize as 1024 or 2048 and provide a certificate file name.
Step 3  Send the generated CSR file to DoD. The DoD will issue the corresponding signed certificates.

Note  The CSR reply is through dod.p7b file. In addition you should also receive the root CA certificates.

Note  Please makes sure to retrieve the PKCS7 encoded certificates; Certificate Authorities provide an option to get the PKCS7 encoded certificates.

Step 4  Import the CSR reply in the Keystore using the command:

% keytool -import dod.p7b -keystore nmsclientkeystore -storetype pkcs12 -storepass nmskeystore

Step 5  Check the formats of root CA certificates received, they must be base 64 encoded. If they are not base 64 encoded, use the OpenSSL command to convert them to base 64 encoded format.

% openssl x509 -in rootCA.cer -inform DER -outform PEM -outfile rootCA.crt
% openssl x509 -in DoD-sub.cer -inform DER -outform PEM -outfile rootCA.crt

Note  Convert both root CA certificate and sub-ordinate certificates received.

In case you received both root CA certificate and the sub-ordinate certificate, you must bundle them together using the below command:

% cat DoD-sub.crt > ca-bundle.crt
% cat DoD-rootCA.crt >> ca-bundle.crt

Step 6  To setup SSL Client Authentication using these certificates, enable SSL Client Authentication in Apache in the ssl.conf file located in <WCS_Home>/webms/apache/ssl/backup/ folder.

SSLCACertificationPath conf/ssl.crt
SSLCACertificationFile conf/ssl.crt/ca-bundle.crt
SSLVerifyClient require
SSLVerifyDepth 2

Note  SSLVerifyDepth will depend of the level of Certificate Chain. In case you have only 1 root CA certificate, this should be set to 1. In case you have a certificate chain (root CA and subordinate CA), this should be set to 2.

Step 7  Install the DoD root CA certificates in WCS.

Step 8  Import the nmsclientkeystore in your browser.

Setting Up SSL Server Certification

To setup the SSL Server Certificate using DoD certificates, follow these steps:

Step 1  Generate the Certificate Signing Request (CSR).

% keyadmin -newdn genkey <csrfilename>


**Step 2**  
Send the generated CSR file to DoD. The DoD will issue the corresponding signed certificates.

| Note | The CSR reply is through dod.p7b file. In addition you should also receive the root CA certificates. |

| Note | Please makes sure to retrieve the PKCS7 encoded certificates; Certificate Authorities provide an option to get the PKCS7 encoded certificates. |

**Step 3**  
Import the Signed Certificate using the below command in the Keytool:

```
% keyadmin -importsignedcert <dod.p7>
```

| Note | The certificate and the key are stored at <WCS_Home>/webnms/apache/conf/ssl.crt. |
INDEX

Numerics

40 MHz channel bonding 9-122
802.11a/n
  Parameters
    monitor 6-19
  RRM Grouping
    monitor 6-20
  RRM Groups
    monitor 6-22
802.11a/n Parameters 9-117
  802.11h 9-128
  DCA 9-121
  EDCA 9-127
  General 9-118
  High Throughput 9-129
  Media 9-124, 9-135
  Roaming 9-127
  RRM Intervals 9-120
  RRM Radio Grouping 9-124
  RRM Thresholds 9-128
802.11 association diagnostic test 10-31
802.11b/g/n
  Parameters
    monitor 6-21
  802.11b/g/n Parameters 9-130
    EDCA 9-137
    General 9-131
    High Throughput 9-139
    Roaming 9-138
    RRM Intervals 9-133
    RRM Thresholds 9-132
  802.11b/g/n Parameters Controller Templates 11-116
  802.11b/g RRM interval template 11-108, 11-112
  802.11b/g RRM threshold templates 11-111
  802.11 Counters
    access points 6-33
  802.11 counters report 15-119
  802.11 General Parameters
    configuring 9-112
  802.11h
    802.11a/n 9-128
  802.11h template 11-107
    configuring 11-107
  802.11 MAC Counters
    access points 6-48
  802.11n summary reports 15-113
  802.11 Parameters
    configuring 9-82, 9-112
  802.11 security trap 11-134
  802.1x scaling reports 15-3
  802.1x authentication diagnostic test 10-31
  802.1x supplicant credentials 11-11
  802.3 Bridging
    configuring 9-27
  802.3x Flow Control 9-27
  880 series ISRs 1-7

A

AAA

  AAA mode 16-114
  active sessions 16-122
  AP/MSE Authorization 9-90
  General 9-83
  LDAP Servers 9-86
local password policy  16-116
MAC Filtering          9-90
RADIUS                  16-124
TACACS+                  16-122
TACACS+ Servers        9-88
users                   16-116
Web Auth Configuration  9-91
AAA Local Net Users      9-88
AAA Mode                  16-114
AAA override           11-32
AAA RADIUS
    Acct Servers    9-84
    Fallback Parameters  9-85
AAA servers            11-31
AAA traps               11-134
absolute                 19-2
Access Control List
    Rules          9-98
Access Control Lists
    configuring      9-97
access control list template 11-87
access control list templates 11-80
access mode              9-157
access point
    configuring     11-68
    configuring for hybrid REAP 13-9
    credentials      9-153
    friendly         11-94
access point authentication and MFP templates  11-72
access point authorization template 11-68
access point icons      5-16
access point load
    avoiding        11-101
Access Point Password
    Global          9-58
access point positions
    changing with import or export of file 5-56, 5-57
Access Points
    Cisco APs
    configuring      9-110
    detecting        6-110
    disabling
    ineligible      9-165
Monitoring
    overview        6-23
    radio utilization 6-33
    Tx power and channel 6-33
access points
    configuring      9-165
    configuring for LOMM 9-184
    converting to LWAPP C-2
    embedded         1-7
    positioning      5-56
    searching 2-38, 9-187
access points, adding to maps 5-48 to 5-53
access point threats       3-9
access point threats or attacks 3-9
Access Point Timer Settings 9-62
access point traps         11-134
Account
    creating          7-19
ACL
    configuring      9-97
    Rules          9-98
    template       11-80
ACL IP group details 11-81
ACL Protocol Groups
    configuring      11-85
ACL template           11-87
    configuring      11-87
ACS server
    adding WCS to   16-40
ACS View Server credentials 9-221
ACS View Servers
    configure      9-220
ACS view server tab  10-28
active interferer count per channel 9-193
active interferers       9-192
active interferers count chart 9-193
Active Sessions 16-122
location server 12-24
active sessions
monitoring 7-5
adaptive scan threshold 11-106
adaptive wIPS top 10 APs report 15-142
add config groups 8-20
add group members 8-10
Adding
location server 12-9
MSE 12-5
adding a spectrum expert 9-192
adding autonomous access points
by CSV file 9-161
by device information 9-161
adding autonomous access points to WCS 9-160
adding IOS access points 9-160
by device information 9-161
adding launch points
for Google Earth 19-7
Adding System Interfaces 9-37
adding templates from config group 8-23
adding WCS as TACACS+ server 16-41
Adhoc Rogue
alarm details 6-108
Alarms
overview 6-103
Events
details 6-115
overview 6-114
monitoring alarms 6-103
Adhoc Rogues
overview 6-88
adhoc rogues 2-26, 3-7
adhoc rogues report 15-148
adjusted link metric 5-82
Administration 18-1
location server 12-20
administration menu 2-30
Administrative Tools
overview 1-14
advanced debug 17-7
advanced options 5-104
Advanced Parameters
location server 12-25
advanced search 2-35, 6-106
Advanced tab
on WLAN template 11-34
age out dual band 9-116
age out suppression 9-116
aggregated historical data 16-69
Aggressive Load Balancing 9-29
aggressive load balancing 9-113
Aironet IE 9-70, 11-35
Airopeek
configuring 9-111
Alarm
details 6-87
alarm 6-80
alarm cleanup options 16-61
alarm counts
for access points 6-83
for controllers 6-83
for coverage hole 6-83
for malicious APs 6-83
for mesh links 6-83
for mobility 6-83
for security 6-83
for unclassified APs 6-83
for WCS failures 6-83
alarm dashboard 6-80
alarm display options 16-62
alarm indicator 6-80
Alarms
acknowledging 6-121
Adhoc Rogue
lightweight access point template 11-143
monitor
  overview 6-23
Noise 6-29
Radio
details 6-41
radio 9-175
remove unassociated 9-185
TSM 6-33
UpTime 6-30
Voice Statistics 6-31
Voice TSM Reports 6-32
Voice TSM Table 6-31
APs not assigned to maps 2-19
AP Status Report
  Scheduled Task 9-203
AP Template
tasks 9-202
AP Template Task
delete 9-204
  enable, disable 9-203
  history 9-204
  modify 9-203
AP threats and attacks 10-7
AP Timer Settings 9-62
AP up time 5-88, 6-50
AP uptime 2-26
AP Username Password Controller Templates 11-10
  asset matching criteria 12-66
  assigning location presence 5-31
  assigning virtual domains 7-17, 16-119
  association request failures 5-95, 6-54
  association request success 5-95, 6-54
  association request timeouts 5-95, 6-54
attacks
  access points 3-9
  attacks detected 3-9
AUDIT_STATUS_DIFFERENCE 14-54
auditing config groups 8-24
auditing H-REAP groups 13-16
Audit Mode
  basic audit 16-63
  template based audit 16-63
Audit Now 9-19
audit report
  for alarms 6-88, 12-71
audit reports
  configuring 9-186
audit status 5-91
  viewing for access points 9-186
audit trail
  viewing 7-10
Authentication Priority
  configuring 9-150
authentication priority
  template 11-139
authentication process
  Hybrid REAP 13-2
  authentication request failures 5-95, 6-54
  authentication request success 5-95, 6-54
  authentication request timeout 5-95, 6-54
auto key generation 11-43
automated upgrade 4-15
automatic backups, scheduling 4-9
automatic client exclusion 11-36
automatic client troubleshooting 10-21, 16-64
autonomous access points
  adding 9-160
  adding by CSV file 9-161
  downloading images 9-163
  upgrading 9-163
  viewing 9-162
Autonomous AP
  Migration Templates
    edit 11-155
autonomous AP images
  downloading 9-174
Autonomous APs
template
  new 11-152
  templates 11-152
 autonomous to lightweight migration 9-160
 autonomous to LWAPP migration support 9-160
 auto provisioning filter
  editing 16-52
 auto refresh 5-108, 5-121
 avoid access point load 11-101
 avoid Cisco AP load 11-101
 avoid foreign AP interference 11-101
 avoid non-802.11 noise 11-101

background scanning 9-54
  on mesh configuration 11-130
  on templates 11-130
 background scanning in mesh networks
  described 9-52 to 9-54
  scenarios 9-53
 Background Scan parameter 9-55
 backhaul interface 5-93, 6-52
 backing up the WCS database
  on Linux 4-11
  on Windows 4-10
 Backup
  location server 12-35
 backup and restore license B-4
 band selection 9-114
 battery level
  condition type 12-65
 best practices A-1
 bridge group name 5-93, 6-52
 Bridging link information 5-82, 5-98
 bridging link information 5-82, 5-98
 bridging mesh statistics 5-93, 6-52
 broadcast deauthentication frame signatures 3-42
 bronze 11-34
 bronze queue 5-95, 6-53
 buildings
  adding to WCS database 5-33
 busiest APs report 15-73
 busiest client report 15-24

C
CA Certificate
  configuring 9-100
 CA certificates 4-5
 calculating access point requirements 5-102
 calibrating client 11-142
 CAS 12-1
 cascade reboot 8-25
 CDP Interface Neighbors
  controller ports
    monitor 6-11
 certificate signing request 3-52
 change order buttons 15-8
 changing station role
  root mode 9-164
 channel bonding
  configuring 9-122
 channel width
  monitoring 6-55
 checking the status of WCS
  on Linux 4-7
  on Windows 4-6
 Chokepoint
  adding to WCS database 9-196
  adding to WCS map 9-197
  removing from WCS 9-198
  removing from WCS map 9-198
 chokepoint
  condition type 12-65
 Chokepoints 6-67
  new 9-196
 chokepoints
positioning 5-56
CIDR notation 11-81
Cisco Access Points configuring 9-110
Cisco Adaptive wIPS alarms 6-117
Cisco Aironet 1510 Access Points in Mesh network 9-52
Cisco AP load avoiding 11-101
Cisco Discovery Protocol 9-170
Cisco WCS base B-1
Cisco wired IPS events 2-27
Cisco Wireless LAN Solution overview 1-1 to 1-2
security solutions 3-1 to 3-37
civic address 5-32
CKIP 9-67
collapsed to ground 19-2
classification rule 11-91
Classifying Rogue APs 6-93
clear config 9-173
CLI
template 11-139
CLI commands
applying to template 11-140
Client
disable 10-36
remove 10-37
Sessions Report 10-38
client 10-37
calibrating 11-142
managing 10-1
client alarm summary 10-5
client association failure 10-5
client authentication failure 10-5
client authentication provision 11-60
client authentication type distribution 10-7
client count 2-19, 10-4
client count report 15-26
client detail page 10-10
Client Details
Association History 10-18
CCXv5 Information 10-19
Event Information 10-19
Location Information 10-19
Statistics 10-18
client details
retrieving from access point page 10-21
client devices
connecting to WLANs 13-12
client distribution 10-3
client excluded 10-5
client exclusion 9-71, 11-36
happening automatically 11-36
Client Exclusion Policies configuring 9-104
client exclusion policies 11-70
template 11-70
client exclusion policies template 11-70
Client Location
current map 10-38
recent map 10-37
client MFP 3-39
client protocol distribution 10-3
client related traps 11-133
client reports 15-23
clients
searching 2-40
clients detected by location server 2-27
client security events 2-27
client sessions report 15-29
Client Summary
filtering 10-11
client summary report 15-33
client tab 2-20, 10-2
client tab dashboard 10-22
client traffic 10-6
client troubleshooting
  automatic 16-64
  enabling 10-21
client WEP key decryption error 10-5
client WPA MIC error counter activated 10-5
CLI Sessions
  monitor 6-6
CLI sessions 16-70, 16-88
color coding
  of obstacles 5-74
command buttons 2-32
compliance reports 15-48
component options icon 2-29
condition type
  for event definitions 12-65
config audit 17-20
config audit alarms 17-21
config group
  adding controllers 8-22
  adding templates 8-23
  configuring 8-21
  downloading IDS signatures 8-27
  downloading sw to controllers 8-26
  removing controllers 8-22
  removing templates 8-23
config group audits 8-24
config groups
  applying 8-23
  auditing 8-24
  creating 8-19
  downloading customized webauth 8-27
  rebooting 8-25
  reporting 8-26
Config Group Task
  delete 9-206
  enable, disable 9-205
  history 9-205
Config Group Tasks 9-204
  modify 9-204
Configuration
  scheduled 9-202
configuration audit report 15-49
Configuration Backup 16-21
Configure Access Points
  Radio 9-175
Configure APs
  copy and replace 9-184
Configure Controllers
  802.11
    General Parameters 9-112
    802.11a/n Parameters 9-117
      802.11h 9-128
      Dynamic Channel Assignment 9-121
      EDCA 9-127
      General 9-118
      High Throughput 9-129
      Media 9-124, 9-135
      Roaming 9-127
      RRM Intervals 9-120
      RRM Radio Grouping 9-124
      RRM Thresholds 9-128
    802.11b/g/n Parameters 9-130
      EDCA 9-137
      General 9-131
      High Throughput 9-139
      Roaming 9-138
      RRM DCA List 9-134
      RRM Radio Grouping 9-134
      RRM Thresholds 9-132
    802.11 Parameters 9-82, 9-112
Access Control List
  Rules 9-98
Access Points
  Cisco APs 9-110
  Download Customized Web Auth Bundle 9-35
  Download IDS signatures 9-35
  Downloading Configuration 9-33
  Downloading Software 9-34
Download Web Admin Certificate 9-34
H-REAP 9-79
H-REAP AP Groups 9-79
Management 9-144
  Authentication Priority 9-150
  Local Management Users 9-150
Syslog 9-148
Syslog Servers 9-148
Telnet SSH 9-147
Trap Receivers 9-144
Web Admin 9-148
Mesh 9-140
Ports 9-143
Rebooting Controllers 9-7
Removing Controllers 9-7
Security
  AAA 9-83
    AAA AP authorization 9-90
    AAA Local Net Users 9-88
    AAA RADIUS Acct Servers 9-84
    AAA RADIUS Auth Servers 9-83
    Access Control Lists 9-97
    AP Authentication and MFP 9-109
    CA Certificate 9-100
    Client Exclusion Policies 9-104
    CPU Access Control List 9-99
    Custom Signatures 9-108
    Disabled Clients 9-97
    file encryption 9-82
    ID Certificate 9-101
    IDS Sensor List 9-100
    Local EAP 9-93
    Local EAP General 9-93
    Local EAP general EAP-FAST parameters 9-96
    Local EAP General Network Users Priority 9-96
    Local EAP Profiles 9-95
    Rogue Policies 9-103
    Standard Signatures 9-105
    User Login Policies 9-97
  Web Auth Certificate 9-102
  Wireless Protection 9-102
System
  DHCP Scopes 9-56
  Mobility Groups 9-49
  Network Route 9-48
  Network Time Protocol 9-52
  QoS Profiles 9-55
  Spanning Tree Protocol 9-49
  System Commands 9-30
  System Interfaces 9-36
  Uploading Files from Controllers 9-32
configure menu 2-30
Configuring
  ACL Protocol Groups 11-85
  Wired Guest Access 9-44
Configuring 802.3 Bridging 9-27
configuring access points 9-165
configuring a client exclusion policy template 11-92
configuring a CPU ACL template 11-87
configuring a high throughput template 11-108
configuring alarm severity 6-84, 14-64
configuring a local EAP general template 11-55
configuring a local EAP profile template 11-56
configuring a manually disabled client template 11-69
configuring a mesh template 11-108, 11-129
configuring an 802.11b template 11-107
configuring an access point 11-68
configuring an access point for hybrid REAP 13-9
configuring an EAP-FAST template 11-58
configuring an RRM interval template 11-112
configuring an RRM threshold template 11-107
configuring a policy name template 11-99
configuring a roaming parameters template 11-104
configuring a TACACS+ server template 11-50
configuring a trusted AP policies template 11-90
configuring a user authentication priority template 11-139
configuring a user login policies template 11-65
configuring config group 8-20
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>configuring controller WLANs</td>
<td>9-63</td>
</tr>
<tr>
<td>configuring EDCA parameters</td>
<td></td>
</tr>
<tr>
<td>through a template</td>
<td>11-104</td>
</tr>
<tr>
<td>Configuring Existing Controllers</td>
<td>9-21</td>
</tr>
<tr>
<td>configuring firewall for WCS</td>
<td>3-38</td>
</tr>
<tr>
<td>configuring global credentials</td>
<td>9-153</td>
</tr>
<tr>
<td>configuring global email parameters</td>
<td>16-72</td>
</tr>
<tr>
<td>configuring H-REAP AP groups</td>
<td>11-38</td>
</tr>
<tr>
<td>configuring Hybrid REAP</td>
<td>13-1</td>
</tr>
<tr>
<td>configuring hybrid REAP access point groups</td>
<td>13-12</td>
</tr>
<tr>
<td>configuring Hybrid-REAP groups</td>
<td>13-14</td>
</tr>
<tr>
<td>Configuring IDS</td>
<td>3-41</td>
</tr>
<tr>
<td>Configuring IDS signatures</td>
<td>3-41</td>
</tr>
<tr>
<td>configuring intrusion detection systems</td>
<td>3-41</td>
</tr>
<tr>
<td>configuring multiple country codes</td>
<td>8-16</td>
</tr>
<tr>
<td>configuring search results</td>
<td>2-47</td>
</tr>
<tr>
<td>configuring spectrum experts</td>
<td>9-191</td>
</tr>
<tr>
<td>configuring template</td>
<td></td>
</tr>
<tr>
<td>ACL</td>
<td>11-69</td>
</tr>
<tr>
<td>for rogue AP rule groups</td>
<td>11-92</td>
</tr>
<tr>
<td>configuring templates</td>
<td></td>
</tr>
<tr>
<td>802.11b/g RRM interval</td>
<td>11-112</td>
</tr>
<tr>
<td>access point authentication and MFP</td>
<td>11-90</td>
</tr>
<tr>
<td>access point authorization</td>
<td>11-68</td>
</tr>
<tr>
<td>file encryption</td>
<td>11-45</td>
</tr>
<tr>
<td>guest users</td>
<td>11-63</td>
</tr>
<tr>
<td>known rogue access point</td>
<td>11-107</td>
</tr>
<tr>
<td>local management user</td>
<td>11-137</td>
</tr>
<tr>
<td>MAC filter</td>
<td>11-66</td>
</tr>
<tr>
<td>QoS</td>
<td>11-16</td>
</tr>
<tr>
<td>RADIUS accounting</td>
<td>11-49</td>
</tr>
<tr>
<td>RADIUS authentication</td>
<td>11-46</td>
</tr>
<tr>
<td>syslog</td>
<td>11-136</td>
</tr>
<tr>
<td>Telnet SSH</td>
<td>11-135</td>
</tr>
<tr>
<td>traffic stream metrics QoS</td>
<td>11-20</td>
</tr>
<tr>
<td>trap control</td>
<td>11-132</td>
</tr>
<tr>
<td>WLAN</td>
<td>11-22</td>
</tr>
<tr>
<td>configuring the switch</td>
<td></td>
</tr>
<tr>
<td>for hybrid REAP</td>
<td>13-5</td>
</tr>
<tr>
<td>Configuring User Roles</td>
<td>9-57</td>
</tr>
<tr>
<td>connecting client devices</td>
<td></td>
</tr>
<tr>
<td>to WLANs</td>
<td>13-12</td>
</tr>
<tr>
<td>Connecting to the Guest WLAN</td>
<td>3-52</td>
</tr>
<tr>
<td>content</td>
<td></td>
</tr>
<tr>
<td>customizing</td>
<td>2-25</td>
</tr>
<tr>
<td>context aware configuring</td>
<td>12-74</td>
</tr>
<tr>
<td>context aware planning</td>
<td>12-69</td>
</tr>
<tr>
<td>context-aware software</td>
<td>12-1</td>
</tr>
<tr>
<td>Controller</td>
<td></td>
</tr>
<tr>
<td>General System Parameters</td>
<td>9-24</td>
</tr>
<tr>
<td>Multicast Mode</td>
<td>9-61</td>
</tr>
<tr>
<td>Template Launch Pad</td>
<td>11-1</td>
</tr>
<tr>
<td>Uploading configuration/logs</td>
<td>9-32</td>
</tr>
<tr>
<td>controller</td>
<td></td>
</tr>
<tr>
<td>configuring for hybrid REAP</td>
<td>13-6</td>
</tr>
<tr>
<td>controller CPU utilization</td>
<td>2-27</td>
</tr>
<tr>
<td>controller details</td>
<td>11-157</td>
</tr>
<tr>
<td>Controller DHCP</td>
<td>9-60</td>
</tr>
<tr>
<td>configuring</td>
<td>9-60</td>
</tr>
<tr>
<td>controller license information</td>
<td>16-9</td>
</tr>
<tr>
<td>controller licenses</td>
<td></td>
</tr>
<tr>
<td>managing</td>
<td>16-99</td>
</tr>
<tr>
<td>searching</td>
<td>2-46</td>
</tr>
<tr>
<td>controller memory utilization</td>
<td>2-27</td>
</tr>
<tr>
<td>Controllers</td>
<td></td>
</tr>
<tr>
<td>Adding an Interface</td>
<td>9-37</td>
</tr>
<tr>
<td>configuring existing</td>
<td>9-21</td>
</tr>
<tr>
<td>DHCP Stats</td>
<td></td>
</tr>
<tr>
<td>monitor</td>
<td>6-7</td>
</tr>
<tr>
<td>Edit View</td>
<td>6-3</td>
</tr>
<tr>
<td>monitor</td>
<td></td>
</tr>
<tr>
<td>Summary</td>
<td>6-4</td>
</tr>
<tr>
<td>monitoring</td>
<td>6-1</td>
</tr>
<tr>
<td>search</td>
<td>6-2</td>
</tr>
<tr>
<td>System Parameters</td>
<td></td>
</tr>
<tr>
<td>monitor</td>
<td>6-3</td>
</tr>
</tbody>
</table>
controllers
  adding 9-4
  adding to WCS database 4-2
  searching 2-39
  specified 1-1
Controller Security
  monitor 6-12
Controller Templates
  802.11b/g/n Parameters 11-116
  Adding 11-2
  applying 11-2
  AP Username Password 11-10
  delete 11-2
  managing, creating 11-3
  SNMP Community 11-8
  Viewing 9-18
  Voice
    802.11b/g/n 9-117, 11-98, 11-102, 11-119
Controller Time and Date 9-32
controller upgrade settings 16-67, 16-70, 16-89
Controller User Roles
  configuring 9-63
  converting WLSE autonomous to WCS controller C-1
Country Codes
  setting multiple 9-112
  country codes
    multiple 8-16
Coverage (RSSI)
  access points 6-30
Coverage (SNR)
  access points 6-30
  coverage hole 6-62
  coverage hole reports 15-122
  coverage holes 2-19
CPU access control
  template 11-87
CPU Access Control Lists
  configuring 9-99
CPU ACL
  configuring 9-99
Cranite 9-66
Creating Account 7-19
Creating a Lobby Ambassador Account 7-19
Creating guest user accounts 7-11
creating guest user accounts 7-11
creating placemarks 19-3
creating virtual domains 18-2
CSR 3-52
CSV file 9-161
  method for adding autonomous access points 9-161
CSV files 19-4
Current building
  delete 5-35
  edit map 5-35
currently logged guest users 2-28
Custom and Standard Signatures
  Global Settings 9-107
customized webauth
  downloading 8-27
Customized Web Auth Bundle
  download 9-35
Customized WebAuth Bundles
  downloads 9-14
Customized Web authentication 3-50
customized web authentication
  downloading 11-76
customize report 15-7
customizing content on WCS Home page 2-25
customizing tabs on WCS Home page 2-23
Custom signature 3-47
Custom Signatures
  configuring 9-108

D

data collection
  for RFID tag 11-142
DCA 11-114, 11-127
802.11a/n 9-121
debug commands A-4
debug strategy A-4, D-11
default lobby ambassador credentials editing 7-10, 7-15
Deleting
MSE 12-6
deleting a license B-4
deleting a WLAN 9-74
deleting guest user templates 7-13
deleting WCS user accounts 7-4
designing a network 5-109
destination type for report 15-5
Detecting APs 6-110
details
clients 10-39
device certificates 4-4
device information 9-161
method for adding autonomous access points 9-161
device reports 15-69
DHCP
configuring 9-60
DHCP diagnostic test 10-30
DHCP Scopes
configuring 9-56
DHCP server
overriding 11-37
DHCP Stats
controllers
monitor 6-7
diagnostic channel A-1, D-1
diagnostic test
802.11 association 10-31
802.1X authentication 10-31
DHCP 10-30
DNS ping 10-31
DNS resolution 10-31
IP connectivity 10-30
profile redirect 10-31
Disable
client 10-36
Disabled Clients
manual 9-97
disabled clients
template 11-69
disabling IDS signatures 3-46
Discovering Templates from Controllers 9-18
Distance
condition type 12-65
DNS ping diagnostic test 10-31
DNS resolution diagnostic test 10-31
Download
Web Admin Certificate 9-149
Web Auth Certificate 9-149
downloading a customized web authentication page 11-76
downloading autonomous AP images 9-174
Downloading Configurations to Controllers 9-33
downloading customized webauth 8-27
Downloading customized web authentication 3-50
Downloading IDS signatures 3-45
downloading IDS signatures 3-45
from your config group 8-27
downloading images
to autonomous access points 9-163
Downloading Signature Files 9-106
Downloading Software
controllers 9-34
downloading sw to controllers
after adding config group 8-26
downloading vendor CA certificates 4-5
downloading vendor device certificates 4-4
Downloads
Customized WebAuth Bundles 9-14
Vendor CA Certificates 9-16
Vendor Device Certificate 9-15
downstream delay 11-21
downstream packet loss rate 11-21

drawing polygon areas 5-72

downstream packet loss rate 11-21
drawing polygon areas 5-72

DTIM 11-100

Dynamic Channel Assignment

802.11a/n 9-121
dynamic interface 11-14

Alarms

alarms 6-116
embedded access points 1-7
easy emergency

template 12-65
enable background audit 8-20
enable enforcement 8-20
enable log module 16-56
enabling 10-37

enabling audit trails

for guest user activities 7-11
enabling IDS signatures 3-46
Enabling Web login 3-49
enabling Web login 3-49

end user license agreement 8-7 to 8-12
Ethernet bridging 9-155

Ethernet Switch

credentials 9-189
remove 9-191

Ethernet Switches

configure 9-211

Ethernet VLAN tagging guidelines 9-156
evaluation license

for controller 16-10
for MSE 16-12

event history 6-88, 10-27, 12-71
event notification 1-5

Events

Adhoc Rogue 6-128
details 6-115
overview 6-114

monitoring 6-124
overview 6-124

Pre Coverage Holes 6-129
Rogue Alarms 6-111
Rogue AP
details 6-112
Rogue APs 6-127
wIPS 6-129

working with 6-134
events
  searching  2-42
exclude device list  16-90
excluded packets  5-94, 6-52
exclude switch trunk ports  16-90
exclude vendor list  16-90
executive summary report  15-115
Export Asset Information
  location server  12-45
exporting a file  5-56
  to change access point position  5-56, 5-57
export task list  16-42
extend to ground  19-2
extension license
  for controller  16-10
  for MSE  16-12
extracting task list  16-47

F
Factory Defaults
  restoring  9-31
Failover mechanism  16-6
Failover Priority  9-26
feature
  of WCS license  16-8
feature license  B-2
File Encryption
  controller  9-82
file encryption template  11-45
filter
  editing current auto provisioning  16-52
filtering
  using to modify maps  5-98
filtering saved reports  15-12
filtering scheduled run results  15-10
firewall, configuring for WCS  3-38
Floor Areas
  delete  5-53
  edit  5-53
Floor Plan Editor  1-14
foreign access point interference
  avoiding  11-101
foreign AP interference
  avoiding  11-101
Frame type  3-47
friendly access point template  11-94
friendly AP
  template  11-94
friendly rogue  11-90
friendly rogue access points  3-8
friendly rogue APs  2-27
FTP
  turning on and off  16-80

G
General Properties
  Location Server  12-20
general tab
  home page  2-19
general templates
  configuring  11-4
generating migration analysis report  9-164
geographical coordinates  19-1
Global AP Password
  configuring  9-58
global credentials
  configuring  9-153
Global Settings
  Standard and Custom Signatures  9-107
Global settings
  for standard and custom signatures  3-49
Global SSID Group
  add  9-217
  delete  9-218
  edit  9-218
gold  11-34
gold queue 5-94, 6-53

Google Earth
  adding launch points 19-7
Google Earth coordinates 19-2
Google Earth maps 19-1
Google KML or CSV
  importing into WCS 19-5
GPS markers 5-32
grace period license
  for controller 16-10
groups
  for hybrid-REAP 13-14
  for rogue access point rules 11-92
group setup window on ACS server 16-43
GUEST_USER_ADDED 14-51
GUEST_USER_AUTHENTICATED 14-52
guest account settings 16-70
guest accounts status report 15-89
guest association report 15-91
guest count report 15-92
guest reports 15-89
guest user
  template 11-63
guest user account
  scheduling 7-13
Guest user accounts
  creating 7-11
guest user accounts
  creating 7-11
  managing 7-13
guest user details
  emailing 7-14
  print 7-14
Guest Users
  monitoring 6-16
guest users
  currently logged 2-28
guest user sessions report 15-94
guest user templates 11-63

Guest WLAN
  connecting 3-52
guidelines
  for Ethernet VLAN tagging 9-156
guidelines for using the map editor 5-19

H

heater status 5-88, 6-50
heat map
described 5-50
Help Menu 1-13
help menu 2-30
hierarchy
  of mesh network 5-96
Hierarchy of Mesh parent to child 5-99
hierarchy of mesh parent to child 5-99
High Throughput
  802.11a/n 9-129
  802.11b/g/n Parameters 9-139
high throughput
  template 11-108
high throughput template
  configuring 11-108
historical report type 15-1
History Parameters
  location server 12-43
Home Page 2-18
  customizing tabs 2-19
Home page
  customizing content 2-25
  customizing tabs 2-23
H-REAP AP Groups
  configuring 9-79
H-REAP AP groups
  configuring 11-41
  configuring template 11-41
H-REAP configuration tab 11-42
H-REAP Group
Index

Index

auditing 9-82
H-REAP groups
    auditing 13-16
H-REAP local switching 9-70
H-REAP Parameters 9-79
H-REAP Users 11-43
HTTP
    turning on and off 16-80
Hybrid REAP
    configuring 13-1
hybrid REAP
    bandwidth restriction 9-70, 11-35, 13-3
hybrid REAP access point groups 13-12
hybrid-REAP groups 13-13
Hybrid REAP local switching 11-35
hysteresis 11-106

ID Certificate
    configuring 9-101
identical audit status 5-91
IDS 3-41
    configuring 3-41
IDS Sensor List
    configuring 9-100
IDS sensors 3-41
IDS Signatures
    configuring 9-105
download 9-35
IDS signatures 3-41
    disabling 3-46
downloading 3-45
downloading from config group 8-27
enabling 3-46
uploading 3-44
images
    downloading to autonomous access points 9-163
Import Asset Information

location server 12-44
importing a file 5-56
to change access point position 5-56, 5-57
importing coordinates
    as CSV file 19-4
    into Google Earth 19-2
importing Google KML or CSV into WCS 19-5
Import map 5-54
In/Out
    condition type 12-65
information elements
    Aironet 11-35
infrastructure MFP 3-39
ingress interface 9-65
Inspect Location Readiness 5-78
Inspect VoWLAN Readiness 5-79
installer
    using to upgrade 4-16
installing a license B-4
installing WCS
    for WLSE conversion C-2
insufficient memory 5-94, 6-52
interface group 11-19
Interferers
    summary 6-72, 6-74
interferers
    summary 9-193
inter-subnet roaming 8-4
Intrusion Detection Systems 3-41
intrusion detection systems 3-41
invalid association request 5-96, 6-54
invalid reassociation request 5-96, 6-55
inventory detail status 2-19
inventory reports 15-48, 15-78
inventory status 2-27
IOS access points
    adding 9-160
    adding by device information 9-161
IOSAP_DOWN 14-53
IOSAP_LINK_DOWN  14-52
IOSAP_LINK_UP   14-52
IOSAP_UP  14-53
IP connectivity diagnostic test  10-30

K
KEK
    key encryption key  11-48
key wrap  11-48
KML file  19-2

L
LAG mode  11-6
Latest Network Audit Report  9-20
latitude  19-2
Layer 1 security solutions  3-2
Layer 2  11-25
Layer 2 security solutions  3-2
Layer 3  11-29
Layer 3 security solutions  3-2
Layer 3 to Layer 2 mode, converting Cisco Wireless LAN Solution  3-37
LBS authorization  11-68
    template  11-68
LDAP Servers  9-86
LDAP servers  9-69
    template  11-52
LEAP authentication
    requirements  8-8
legacy syslog
    template  11-136
legacy syslog template  11-136
license
    backup and restore  B-4
license agreement  B-7 to B-12
license installation  B-4
license management  16-100
licenses  B-1
license types  B-1
licensing
    on WLSE network management  C-4
Lightweight AP Protocol Transport Mode  9-28
limitations for high reliability  16-93
Link Aggregation  9-29
link aggregation (LAG)
    guidelines  13-4
link metric
    adjusted  5-82
    unadjusted  5-82
link SNR  5-82
link stats report  15-98
Load
    access points  6-27
load  5-108
load balancing  9-113
Lobby Ambassador
    account  7-19
    creating account  7-19
Lobby ambassador  7-11
Lobby Ambassador Account
    creating  7-19
    editing  7-21
lobby ambassador defaults
    setting  7-7
local authentication
    for hybrid-REAP groups  13-14
Local EAP  9-93
    General EAP-FAST Parameters  9-96
    General Network Users Priority  9-96
    General Parameters  9-93
    Profiles  9-95
local EAP authorization  9-69
Local EAP check box  11-32
local EAP general
    template  11-55
local EAP general template  11-55
local EAP profile template 11-56
Local Management Users
  configuring 9-150
local management users
  template 11-138
local management user template 11-138, 11-139
Local Net Users
  configuring 9-88
local net users
  template 11-62
local net users template 11-61
Local Password Policy 16-116
local switching
  Hybrid REAP 11-35
Location
  calibration 1-15
  location servers 9-222
  notifications 12-58
  notification settings 12-59
  notifications summary 12-58
  synchronize servers 12-10
location appliance functionality 4-2
Location Appliances 1-15
location appliances
  relationship with WCS Location 1-5
location change
  condition type 12-65
location configuration
  template 11-141
Location History
  clients 10-39
location menu 2-30
location optimized monitor mode 9-168
Location Parameters
  location server 12-53
location presence
  assigning 5-31
Location Readiness 5-78
Location Server
  active sessions 12-24
  administration 12-20
  advanced parameters 12-25
  backup 12-35
  export asset information 12-45
  general properties 12-20
  history parameters 12-43
  import asset information 12-44
  location parameters 12-53
  logs 12-27
  maintenance 12-35
  NMSP parameters 12-22
  notification parameters 12-56
  restore 12-36
  server events 12-32
  WCS alarms 12-33
  WCS events 12-33
Location server
  adding 12-9
location server
  automatic backup 12-36
  backup historical data 12-35
  configuration clearing 12-27
  reboot hardware 12-26
Location Servers 9-222
location upgrade 8-2
log analysis 10-26
logging 16-17
logging into the WCS user interface 2-16 to 2-18
logging options 16-55
logging the lobby ambassador activities 7-10
login.html 3-50
login disclaimer 16-71
login policies
  template 11-65
log message levels 16-56
log modules
  enabling 16-56
Logs
location server 12-27

LOMM 9-168
    configuring access point radios 9-184
longitude 19-3
long preambles, enabling for SpectraLink NetLink phones 4-5
LWAPP
    template
        edit 11-151
        templates 11-143
        Transport Mode 9-28
LWAPP migration 9-160
LWAPP template
    new 11-143
LWAPP uptime 2-27

M

MAC Filtering
    configuring 9-90
MAC filtering 11-28
    template 11-66
MAC filter template 11-66
MAC frequency 3-48
MAC information 3-48
MACK
    message authenticator code keys 11-48
mail server configuration 16-71
Maintenance
    location server 12-35
malformed neighbor packets 5-94, 6-52
malicious rogue 11-90
malicious rogue access points 3-5, 3-6
managed network
    security index 3-5
management frame flood signatures 3-43
Management Frame Protection 3-39
management frame protection 9-72, 11-72
Management Frame Protection Summary
    controllers
        monitor 6-14
management interface 11-7
Management Parameters
    configuring 9-144
management queue 5-95, 6-53
managing clients 10-1
managing controller licenses 16-99
managing current reports 15-9
managing MSE licenses 16-101
managing multiple WCSs 1-10
managing saved reports 15-11
managing virtual domains 18-7
managing WLAN schedules 9-75
mandatory data rates 11-101
manually disabled client
    template for 11-69
Manually Disabled Clients
    managing 9-97
manually disabled clients 2-20
Map Editor
    general notes and guidelines 5-19
map editor
        guidelines 5-19
        guidelines for using 5-19
        using to draw polygon areas 5-72
map editor functions 5-4
map properties
    editing 5-28
maps
    searching 2-44
    using to monitor link stats 5-80
    using to monitor mesh AP neighbors 5-85
map size 5-121
map view
    updating 5-99
Menu Bar 1-11
menu bar 2-29
Mesh
monitoring health 5-88
statistics for AP 5-92, 6-51
mesh access point neighbors
monitoring 5-85
mesh access points
monitoring 5-83
mesh alarms
most recent 2-21
mesh configuration
template 11-129
mesh link statistics 5-80
monitoring 5-80
mesh neighbors 5-86
mesh network
monitoring using maps 5-80
mesh network hierarchy 5-96
mesh networks
background scanning 9-52
monitoring 5-80
Mesh Parameters 9-140
mesh parent changing AP 2-27
mesh parent-child hierarchical view 5-11
mesh reports 15-96
mesh tab
home page 2-21
mesh template
configuring 11-129
Mesh tree
viewing 5-96
mesh tree
viewing 5-96
message integrity check information element 11-72
metrics
in QoS 11-20
MFP 3-39, 9-72
for clients 3-40
MFP attacks 3-9
MFP client protection 11-38
MFP signature generation 11-38
MFP Summary
controllers
monitor 6-14
MFP templates 11-72
MIC IE 11-72
migration analysis
running 9-164
migration analysis report
generating 9-164
migration analysis summary
viewing 11-156
Migration Templates
Autonomous APs
edit 11-155
minimum RSSI 11-106
Mirror Mode 10-37
mirror mode 9-169
mismatched audit status 5-91
mobile announce messages 8-8
Mobility 12-1
Mobility Stats
monitor 6-17
service 12-1
mobility 8-1
Mobility Anchor Group Keep Alive Interval 9-30
mobility anchors 8-13, 9-76
Mobility Group
Prerequisites 9-50
Mobility Groups
configuring 9-49
Messaging 9-50
mobility groups 8-7
prerequisites 8-8 to 8-9
mobility groups, configuring 8-8
mobility scalability 8-12
Mobility Services 12-1
viewing 12-4
mobility services engine
deleting 12-6
Mobility Stats
  monitor 6-17
modifying a migration template 11-156
modifying map displays 5-98
  using filters 5-98
Monitor
  Alarms 6-1
  Events 6-124
  Ports
    overview 6-8
Rogue AP Rules 6-15
Monitor Access Points
  details 6-34
  edit view 6-25
load 6-27
radio type
  802.11 MAC counters 6-48
  on demand statistics 6-41
  operational parameters 6-45
  view alarms 6-49
  view events 6-49
radio utilization 6-33
search 6-23
search results 6-24
Tx power and channel 6-33
Monitor Alarms
  details 6-87
  edit view 6-85
Rogue 3-20
Monitor APs
  802.11 Counters 6-33
  AP Profile Status 6-33
  Coverage (RSSI) 6-30
  Coverage (SNR) 6-30
details
  CDP Neighbors 6-40
  Current Associated Clients 6-40
general 6-34
  interfaces 6-39
Dynamic Power Control 6-28
Interference 6-29
Noise 6-29
Radio
details 6-41
TSM 6-33
UpTime 6-30
Voice Statistics 6-31
Voice TSM Reports 6-32
Voice TSM Table 6-31
Monitor Chokepoints 6-67
Monitor Client
detecting APs
details 10-39
  disable 10-36
  location history 10-39
  present map 10-38
  recent map 10-37
  remove 10-37
  roam reason 10-38
  v5 statistics 10-33
  voice metrics 10-39
Monitor Controllers 6-1
  802.11a/n parameters 6-19
  802.11a/n RRM Grouping 6-20
  802.11a/n RRM Groups 6-22
  802.11b/g/n parameters 6-21
CLI Sessions 6-6
  ports
    general 6-8
    spanning tree protocol 6-5
System
  summary 6-4
  WLANs 6-8
Monitor Events
  Details 6-127
  search 6-126
Monitoring
  Guest Users 6-16
monitoring active sessions 7-6
monitoring channel width 6-55
monitoring mesh access point neighbors 5-85
    using maps 5-85
monitoring mesh health 5-88, 6-55
monitoring mesh link statistics
    using maps 5-80
monitoring mesh networks
    using maps 5-80
monitoring neighboring channels 9-52
monitoring pre-coverage holes 6-62
monitoring rogue access point alarms 6-84
monitoring spectrum experts 9-192
monitor menu 2-29
monitor mode
    location optimized 9-168
Monitor Spectrum Experts 6-71
Monitor Tags 6-64
most recent AP alarms 2-27
most recent audit alarms 17-21
most recent client alarms 10-6
most recent mesh alarms 2-21
most recent rogue adhocs 3-7
most recent security alarms 2-20, 2-28
MSE
    adding 12-5
    deleting 12-6
MSE authorization
    template 11-68
MSE license information 16-12
MSE licenses
    managing 16-101
multicast mobility mode 8-12
Multicast Mode
    controller 9-61
Multiple Country Codes
    setting 9-112
multiple country codes
    configuring 8-16
multiple syslog
    template 11-137
multiple syslog template 11-137

N

N+1 redundancy 8-5
NAC Out-of-Band Integration 9-42
NAC support 9-71
NAT 8-11
Navigator 1-10
netmask 11-81
NetStumbler signature 3-43
network address translation 8-11
Network Audit Report
    latest 9-20
    network design 5-109
    network designs 12-10
    network protection 3-41
Network Routes
    configuring 9-48
    network summary reports 15-113
Network Time Protocol
    configuring 9-52
    network users priority
        template 11-60
    network utilization reports 15-124
new rogue access points report 15-152
new search 5-71
NMSP Parameters
    location server 12-22
    node hop count
        worst 2-21
    node hops 5-94, 6-53
    nodes report 15-101
noise
    avoiding non-802.11 types 11-101
    avoid non-802.11 11-101
non-802.11 noise
   avoiding  11-101
non-aggregated historical data  16-70
non-Cisco ACS server
   for use with RADIUS  16-47
normal mode
   for Ethernet port  9-157
Notification Parameters
   location server  12-56
Notifications
   location  12-58
Notification Settings
   location  12-59
Notifications Summary
   location  12-58
NTP configuration  9-52
NTP server template  11-9, 11-13
null probe response signatures  3-43

O

On Demand Statistics
   access points  6-41
onstacle color coding  5-74
Operational Parameters
   access points  6-45
OUI search  16-90
outdoor location
   creating with Google Earth  19-1
overview
   Cisco Wireless LAN Solution  1-1 to 1-2
   WCS  1-2

P

packet error rate
   worse  2-21
packet error rate link color  5-98
packet error statistics report  15-104
packet jitter  11-20
packet latency  11-20
packet loss  11-20
packet loss rate  11-21
packet queue statistics report  15-106
packet stats report  15-102
parent changes  5-94, 6-52
Passive Client  9-71
passthrough  11-30
PCI report  15-52
PEAP  11-58
peer-to-peer blocking  11-35
performance reports  15-118
permanent license
   for controller  16-10
   for MSE  16-12
placemarks
   creating  19-3
placement of access points  5-54
planning mode  5-103
   to calculate access point requirements  5-102
planning mode, calculating access point requirements  5-102
platinum  11-34
platinum queue  5-94, 6-53
PLR  11-21
POE status  5-91
policy manager solutions  3-2
polygon areas
   drawing with map editor  5-72
poor neighbor SNR  5-94, 6-52
Port Parameters
   configuring  9-143
Ports
   Monitor
      overview  6-8
      monitor controllers  6-8
positioning access points  5-56
Index

positioning chokepoints 5-56
positioning Wi-Fi TDOA receivers 5-56
power injector settings 9-171
power-over-ethernet status 5-91
pre-coverage holes
  monitoring 6-62
Preferred Call 9-116
Prerequisites 2-1
Present Map
  clients 10-38
print guest user details 7-14
probe cycle count 9-115
Profile
  List 9-212
Profile editor 9-213
profile redirect diagnostic test 10-31
protection type 11-73

Radio Utilization
  access points 6-33
RADIUS
  16-124
RADIUS Accounting
  controllers
    monitor 6-13
RADIUS accounting servers
  template 11-49
RADIUS accounting template 11-49
RADIUS and TACACS+ attributes
  virtual domains 7-19, 18-10
RADIUS Authentication
  controllers
    monitor 6-12
RADIUS authentication template 11-46, 11-47
RADIUS Auth Servers
  AAA RADIUS
    Auth Servers 9-83
RADIUS fallback
  template 11-51
RADIUS fallback mode 11-51
RADIUS servers 9-69
  configuring 16-124
reachability status 9-192
Readiness
  location 5-78
VoWLAN 5-79
reassociation request failures 5-95, 6-54
reassociation request success 5-96, 6-54
reassociation request timeouts 5-95, 6-54
reauthentication request failures 5-96, 6-54
reauthentication request success 5-96, 6-54
reauthentication request timeout 5-96, 6-54
rebooting config groups 8-25
Rebooting Controllers 9-7
recent adhoc rogue alarms 3-9
recent alarms 2-27, 2-28
recent coverage holes 2-19

Q
QoS 11-33
QoS Profiles
  configuring 9-55
QoS templates 11-16
queues
  silver, gold, platinum, bronze, management 5-94, 6-53
quick search 2-34
Quiet time 3-48

R
Radio
  access points
    configuring 9-175
radio resource management 11-101
Radio Status
  scheduling and viewing 9-185
radio status
Recent Map
   clients  10-37
recent rogue adhoc alarm  2-20
recent rogue alarms  2-27
recent rogue AP alarms  2-20, 3-9
recovering the WCS password  4-22
recurrence
   for report  15-5
refresh browser  5-109
refresh component icon  2-29
Refresh Config  9-17
refresh from network  5-108, 5-121
relative to ground  19-2
Remove APs  9-185
Remove Controllers  9-7
removing controllers from config group  8-22
removing templates from config group  8-23
report
   running new  15-3
report launch pad  15-2
Reports
   Rogue AP Events  15-156
reports
   scheduled runs  15-9
reset AP now  9-173
Restore
   location server  12-36
Restoring Factory Defaults  9-31
restoring WCS database
   in high availability environment  4-14
restoring WCS database on Linux  4-13
retain WCS value  8-25
Retrieving UDI  6-59
RF calibration model, creating  4-6
RF Calibration Models
   apply to maps  5-68
delete  5-69
RFID data collection  11-142
RF profile traps  11-134
RF update traps  11-134
Roaming
   802.11b/g/n Parameters  9-138
roaming  8-1
roaming parameter
   template  11-105
roaming parameters template
   configuring  11-105
roaming time  11-20, 11-21
Roam Reason
   clients  10-38
rogue access point events report  15-158
rogue access point rule groups  11-92
rogue access point rules
   configuring a template  11-90
   viewing or editing  9-188
rogue access points
   friendly  3-8
   malicious  3-6
   monitoring  3-10
   solutions for  3-3
   unclassified  3-7
rogue access points report  15-158
rogue adhoc alarm  2-20
rogue adhocs
   most recent  3-7
Rogue Alarm Events  6-111
Rogue AP
   alarm details  6-96, 6-112
   alarms  6-89
   containment  6-110
   location  6-110
   malicious  6-95
   Rules
      monitor  6-15
tagging  6-110
rogue AP alarms  2-20
rogue AP detail summary  2-27
Rogue AP Events
report  15-156
rogue AP rule groups  
template  11-92
Rogue AP Rules  
configuring  9-104
details  6-16
rogue AP rules  
template  11-90
Rogue APs  
classification types  6-95
classifying  6-93
friendly  6-95
overview  6-88
unclassified  6-96
Rogue Client  
details  6-101
rogue clients  
searching  2-44
rogue detector  9-168
Rogue Devices  
detecting  6-89
rogue location discovery protocol  11-89
Rogue Policies  
configuring  9-103
rogue policies  
template  11-89
template for  11-89
role criteria  11-156
root access points  
selecting  9-160
root mode  
changing from station role  9-164
routing state  5-93, 6-52
RRM  
DCA  
802.11b/g/n Parameters  9-134
Radio Grouping  
802.11b/g/n Parameters  9-134
RRM DCA  9-122
RRM Intervals  
802.11a/n  9-120
802.11b/g/n Parameters  9-133
RRM intervals  11-107
template  11-112
RRM interval template  
configuring  11-108, 11-112
RRM Radio Grouping  
802.11a/n  9-124
RRM threshold  
template  11-111
RRM Thresholds  
802.11b/g/n Parameters  9-132
RRM threshold template  
configuring  11-111
RSSI legend  5-121
rules  
for rogue access point  11-90
viewing or editing for rogue access points  9-188
Running a link test  6-58
running a new report  15-3
running a saved report  15-13
running migration analysis  9-164
RX neighbor requests  5-94, 6-52
RX neighbor responses  5-94, 6-52
S
Save Config to Flash  9-17
saved report  
running  15-13
saved reports  
editing  15-13
filtering  15-12
managing  15-11
saved searches  2-46, 5-71
scalability parameters  8-12
scan cycle period threshold  9-115
scan threshold  11-106
Scheduled Configuration 9-202
Schedule details 9-165
scheduled run details
   editing 15-11
scheduled run results 15-9
   filtering 15-10
Scheduled Task
   AP status report 9-203
schedules
   managing for WLANs 9-75
scheduling guest user account 7-13
scheduling radio status 9-186
Search
   access points 6-23
   controller results 6-2
   Events 6-126
   overview 1-14
search feature 2-34
   using for troubleshooting 10-22
searching clients 2-40
searching controller licenses 2-46
searching events 2-42
searching maps 2-44
searching rogue clients 2-44
searching SE-detected interferers 2-42
searching shunned clients 2-45
searching tags 2-45
searching Wi-Fi TDOA receivers 2-43
search results
   configuring 2-47
secondary WCS operation 16-6
Security
   AAA
      LDAP servers 9-86
      TACACS+ Servers 9-88
      Web Auth Configuration 9-91
   AAA MAC Filtering 9-90
   Local EAP 9-93
security alarms
   most recent 2-20
security color range 3-5
security configurations
   monitoring 6-116
security index 3-5
security mesh statistics 5-95, 6-53
Security Reports
   Rogue AP Events 15-156
security solutions 3-1 to 3-37
security summary 15-161
security tab
   home tab 2-20
   interpreting 3-4
security thermometer 3-5
SE-detected interferers
   searching 2-42
sending mobile announce messages 8-8
sensors
   viewing IDS types 3-41
Server Events
   location servers 12-32
   status 12-32
set sorting buttons 15-8
Set Time
   controller 9-32
setting AP failover 9-153
Setting Controller Time and Date 9-32
setting multiple country codes 9-82
shunned clients
   searching 2-44
sidebar area 2-32
signature attacks summary 2-20
silver 11-34
silver queue 5-94, 6-53
Sniffer 11-144
Sniffer Feature 9-110
sniffer mode 9-168
SNMP authentication 11-133
SNMP Community
controller templates 11-8
SNR definition 5-98
SNR down 5-82
SNR link
  worst 2-21
SNR UP 5-82
SNR up 5-82
software
  downloading config groups to controllers 8-26
software, updating 4-3
Spanning Tree Protocol
  configuring 9-49
  monitor controllers 6-5
SpectraLink NetLink phones, enabling long preambles 4-5
spectrum expert
  adding 9-192
spectrum expert details 9-193
Spectrum Experts 6-71
details 6-73
Interferers 6-72, 6-74
summary 6-72
spectrum experts
  configuring 9-191
  monitoring 9-192
  summary 9-192
SSID Group
  add 9-219
  add from global list 9-219
  add global 9-217
  delete 9-220
  delete global 9-218
  edit 9-220
  edit global 9-218
SSID Group List
  wIPS 9-217
SSID group list
  global 9-217
SSID groups
  wIPS 9-218
Standalone Building
  adding floor plan 5-46
Standard and Custom Signatures
  Global Settings 9-107
  Standard signature 3-47
  Standard Signature Parameters
    configuring 9-105
  standard signatures 3-42
starting WCS
  on Linux 2-16
  on Windows 2-15
static WEP 9-66
Static WEP-802.1X 9-66
station role
  changing to root mode 9-164
status, checking 4-7
Status Report
  scheduled task 9-205
status schedules
  managing for WLANs 9-75
stopping WCS
  on Linux 4-9
  on Windows 4-7
stranded APs report 15-108
supplicant credentials
  for AP 802.1X 11-11
  supported Cisco WLSE management stations C-2
  supported data rates 11-101
Switch
  credentials 9-189
    remove 9-191
  switch
    configuring for hybrid REAP 13-5
Switches
  ethernet 9-211
Switch Port Tracing
  Details 16-91
  Troubleshooting 16-91
symmetric mobility tunneling 11-7
symmetric tunneling 8-5
Synchronize servers
  location 12-10
Syslog
  configuring individual controller 9-148
  Individual controller 9-148
  multiple servers 9-148
syslog templates 11-136, 11-137
System
  General Properties 9-24
System Commands
  controller 9-30
System Interfaces
  Controllers 9-36
System parameters
  controllers
    monitor 6-3
System requirements 2-2

T

TACACS+ 16-122
TACACS+ server
  configuring a template for 11-54
    template 11-54
tagged packets 9-159
Tags 6-64
tags
  searching 2-45
Task
  configuration backup 16-21
telnet SSH
  template 11-132
telnet SSH Parameters
  configuring 9-147
telnet SSH templates 11-135
temperature 5-88, 6-50
  template
configuring for rogue AP rules 11-90
template for configuring network user credentials 11-60
Template Launch Pad
  overview 11-1
Templates
  AP Configuration 11-143
    delete 11-2
test analysis tab 10-30
telnet SSH template 11-132
telnet SSH Parameters
  configuring 9-147
telnet SSH Servers
    configure 9-221
    delete 9-222
thermometer color range 3-5
threats
  access points 3-9
throughput report 15-38
tilt 19-2
Timer Setting
  AP 9-62
tools menu 2-30
top APs by client count 10-3
total APs not assigned to maps 2-19
total interferer count 9-193
total mismatched controllers 17-21
TPC 11-115, 11-128
trace 16-59
traffic indicator message 11-100
Traffic Stream Metrics
  access points 6-33
traffic stream metrics QoS status 11-21
traffic stream metrics QoS template 11-20
traffic stream metrics report 15-126
transition time 11-107
Transport Mode
LWAPP 9-28
transport types 12-67
trap 802.11 security 11-134
Trap Control configuring 9-145
trap control template 11-132
trap control templates 11-132
trap receiver template 11-131
Trap Receivers configuring 9-144
trap receiver template 11-131
traps AAA 11-134
access point 11-134
client related 11-133
RF profile 11-134
RF update 11-134
unsupported 14-63
traps added in 2.1 14-22
traps added in 2.2 14-26
traps added in 3.0 14-29
traps added in 3.1 14-31
traps added in 3.2 14-35
traps added in 4.0 14-36
traps added in 4.0.96.0 14-42
traps added in 4.1 14-44, 14-51
traps added in release 6.0 14-59
traps added in release 7.0 14-64
trend report type 15-1
Troubleshooting Switch Port Tracing 16-91
troubleshooting A-1, D-1
using logging options 16-59
troubleshooting voice RF coverage 5-108
trunk mode 9-157
trusted AP policies template for 11-90
trusted AP policies template 11-90
TSM access points 6-33
tunneling 8-5
TX neighbor requests 5-94, 6-52
TX neighbor responses 5-94, 6-52
Tx Power and Channel access points 6-33
Tx power and channel report 15-129
type of WCS license 16-9

UDI
retrieving on controllers and access points 6-59
unadjusted link metric 5-82
unclassified rogue 11-90
unclassified rogue access points 3-7
unclassified rogue APs 2-28
understanding virtual domains 18-10
uninstalling WCS on Linux 4-15
on Windows 4-14
unique clients report 15-44
unique device identifier 6-59
unknown association requests 5-96, 6-55
unknown reassociation request 5-96, 6-55
untagged packets 9-159
Update map view 5-99
update map view 5-99
upgrading system software 4-3
upgrade settings for controller 16-67
upgrading autonomous access points 9-163
upgrading the network 4-21
upgrading to Linux 4
during WLSE conversion C-3
upgrading WCS
  in high availability environment 4-21
  on Linux  4-20
  on Windows 4-20
Uploading IDS signatures 3-44
uploading IDS signatures 3-44
Uploading Signature Files 9-106
upstream delay 11-21
upstream packet loss rate 11-21
UpTime
  access points 6-30
uptime reports 15-85
User accounts
  for guest 7-11
user accounts
  for guest 7-11
user authentication priority template configuring 11-139
user credential retrieval priority 11-60
user details
  emailing 7-14
  printing 7-14
User Interface 2-29
  Menu Bar 1-11
User Login Policies
  configuring 9-97
user login policies
  configuring a template 11-65
  template 11-65
User Preferences 7-1, 16-7
user preferences 16-97
User Roles
  configuring 9-57
Users 16-116
using Edit View
  for alarms 6-84
using filtering 5-82, 5-98
using logging
  for troubleshooting 16-59
using maps
  to monitor mesh AP neighbors 5-85
  to monitor mesh link statistics 5-80
using maps to monitor mesh networks 5-80
using planning mode 5-72
using search 6-85
using template
  ACL 11-87
  for friendly access point 11-94
using templates
  802.11b/g RRM interval 11-108, 11-112
  802.11b/g RRM threshold 11-111
  access point authentication & MFP 11-72
  access point authorization 11-68
  file encryption 11-45
  for legacy syslog 11-136
  for multiple syslog 11-137
  guest users 11-63
  local management user 11-138, 11-139
  local net users 11-61
  MAC filter 11-66
  NTP server 11-9, 11-13
  password policy 11-78
  QoS 11-16
  RADIUS accounting 11-49
  RADIUS authentication 11-46
  syslog 11-136, 11-137
  Telnet SSH 11-135
  traffic stream metrics QoS 11-20
  trap control 11-132
  trap receiver 11-131
  web authentication 11-73
  WLAN 11-22
using the installer to upgrade 4-16
utilization reports 15-86

V
V5 client statistics 15-47
V5 Statistics
  client 10-33
Vendor CA Certificates
  downloads 9-16
vendor CA certificates
  downloading 4-5
Vendor Device Certificate
  downloads 9-15
vendor device certificates
  downloading 4-4
vendor search 16-90
View 2-29
View Alarms
  access points 6-49
View Events
  access points 6-49
view history 10-4
view in chart icon 2-29
Viewing
  Mobility Services 12-4
  viewing alarm details 6-84
  viewing audit status
    for access points 9-186
viewing autonomous access points 9-162
viewing clients
  identified as WGBs 6-58
viewing Google Earth maps 6-55, 19-6
Viewing Mesh tree 5-89, 6-50
view in grid icon 2-29
Viewing shunned clients 3-41
viewing shunned clients 3-41
Viewing Templates Applied to a Controller 9-18
viewing the audit trail 7-10
viewing the migration analysis 11-156
view list 10-23
virtual domains 18-1
  assigning 7-17, 16-119
  attributes 7-19, 18-10
  creating 18-2

  hierarchy 18-4
  managing 18-7
  understanding 18-10
VLAN tagging 9-155
Voice
  802.11b/g/n Controller Templates 9-117, 11-98, 11-102, 11-119
Voice Metrics
  clients 10-39
Voice-over-Internet Protocol
  snooping 9-71
Voice RF Coverage issues 5-80
Voice Statistics
  access points 6-31
voice statistics 15-135
Voice TSM Reports
  access points 6-32
Voice TSM Table
  access points 6-31
VoIP calls graph 15-131
VoIP calls table 15-133
VoIP snooping 9-71
VoWLAN Readiness 5-79

W
WCS
  checking status
    on Linux 4-7
    on Windows 4-6
installing 2-6
overview 1-2
servers supported 1-3
starting
  on Linux 2-16
  on Windows 2-15
stopping
  on Linux 4-9
  on Windows 4-7
uninstalling
  on Linux  4-15
  on Windows  4-14
upgrading
  on Linux  4-20
  on Windows  4-20
versions  1-3 to 1-7
WCS_EMAIL_FAILURE  14-53
WCS-ADV-SI-SE-10  B-2
WCS Alarm
  status  12-33
WCS Alarms
  location servers  12-33
WCS Base, described  1-4, 1-7
WCS controller deployment
  from WLSE autonomous  C-1
WCS database
  backing up
    on Linux  4-11
    on Windows  4-10
  restoring
    on Linux  4-13
    on Windows  4-11
  restoring in high availability environment  4-14
  scheduling automatic backups  4-9
WCS Events
  location servers  12-33
  status  12-33
WCS guest operations report  15-95
WCS home  2-17
WCS Home Page  2-18
WCS Home page
  customizing content  2-25
  customizing tabs  2-23
WCS licenses  B-1
WCS Location
  described  1-4 to 1-7
  relationship with Cisco location appliances  1-5
WCS Location Calibration  1-15
WCS Navigator  1-10
WCS on WLSE
  licensing  C-7
WCS password
  recovering  4-22
WCS user accounts
  adding  7-2
  changing passwords  7-5
  deleting  7-4
WCS user interface  7-12
  described  1-3, 1-11
  logging into  2-16 to 2-18
Web Admin
  configuring  9-148
Web Admin Certificate
  downloading  9-34
Web Auth Certificate
  configuring  9-102
Web Auth Configuration  9-91
web authentication
  template  11-73
  web authentication template  11-73
  web authentication type  11-75
Web authentication types  3-50
web auth security  A-3
web login
  enabling  3-49
web policy  9-68
Wellenreiter signature  3-44
WGB mode  10-13
WGBs
  viewing those clients  6-58
WiFi TDOA Receivers
  adding  9-200
  configure  9-199
  edit  9-201
  remove  9-202
  tag location  9-199
Wi-Fi TDOA receivers
Index

positioning 5-56
searching 2-43
wIPS 12-1
   planning and configuring 12-76
   Profile
      add 9-213
      Profile Editor 9-213
      Profile List 9-212
      SSID Group List 9-217
wIPS Alarms
   details 6-118
   monitoring 6-117
wIPS Profile
   apply 9-216
   delete 9-216
wIPS Profiles
   add 9-213
   configure 9-211
Wired Guest Access
   configuring 9-44
Wireless Management 9-29
Wireless Protection Policies
   configuring 9-102
WLAN
   adding 9-73
   deleting 9-74
WLAN AP groups 11-38
WLAN details
   viewing 9-64
WLANs
   configuring 9-63
   monitor 6-8
   web auth security A-3
WLAN status schedules
   managing 9-75
WLAN templates 11-22
WLSE autonomous deployment conversion C-1
WLSE management stations C-2
WLSE upgrade B-2

WLSE upgrade license C-7
WMM parameters 9-69
WMM policy 11-34
Work Group Bridge mode 10-13
work group bridge mode 9-163
worst node hop count 2-21
worst node hops report 15-110
worst packet error rate 2-21
worst SNR link 2-21
WPA+WPA2 9-67

Z

zoom in or out 5-121