Cisco Wireless Control System Configuration Guide

Software Release 5.0
February 2008

Americas Headquarters
Cisco Systems, Inc.
170 West Tasman Drive
San Jose, CA 95134-1706
USA
http://www.cisco.com
Tel: 408 526-4000
800 553-NETS (6387)
Fax: 408 527-0883

Customer Order Number:
Text Part Number: OL-15478-01
THE SPECIFICATIONS AND INFORMATION REGARDING THE PRODUCTS IN THIS MANUAL ARE SUBJECT TO CHANGE WITHOUT NOTICE. ALL STATEMENTS, INFORMATION, AND RECOMMENDATIONS IN THIS MANUAL ARE BELIEVED TO BE ACCURATE BUT ARE PRESENTED WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED. USERS MUST TAKE FULL RESPONSIBILITY FOR THEIR APPLICATION OF ANY PRODUCTS.

THE SOFTWARE LICENSE AND LIMITED WARRANTY FOR THE ACCOMPANYING PRODUCT ARE SET FORTH IN THE INFORMATION PACKET THAT SHIPPED WITH THE PRODUCT AND ARE INCORPORATED HEREIN BY THIS REFERENCE. IF YOU ARE UNABLE TO LOCATE THE SOFTWARE LICENSE OR LIMITED WARRANTY, CONTACT YOUR CISCO REPRESENTATIVE FOR A COPY.

The Cisco implementation of TCP header compression is an adaptation of a program developed by the University of California, Berkeley (UCB) as part of UCB’s public domain version of the UNIX operating system. All rights reserved. Copyright © 1981, Regents of the University of California.

NOTWITHSTANDING ANY OTHER WARRANTY HEREIN, ALL DOCUMENT FILES AND SOFTWARE OF THESE SUPPLIERS ARE PROVIDED “AS IS” WITH ALL FAULTS. CISCO AND THE ABOVE-NAMED SUPPLIERS DISCLAIM ALL WARRANTIES, EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THOSE OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OR ARISING FROM A COURSE OF DEALING, USAGE, OR TRADE PRACTICE.

IN NO EVENT SHALL CISCO OR ITS SUPPLIERS BE LIABLE FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL, OR INCIDENTAL DAMAGES, INCLUDING, WITHOUT LIMITATION, LOST PROFITS OR LOSS OR DAMAGE TO DATA ARISING OUT OF THE USE OR INABILITY TO USE THIS MANUAL, EVEN IF CISCO OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

CCVP, the Cisco logo, and Welcome to the Human Network are trademarks of Cisco Systems, Inc.; Changing the Way We Work, Live, Play, and Learn is a service mark of Cisco Systems, Inc.; and Access Registrar, Aironet, Catalyst, CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, CCSP, Cisco, the Cisco Certified Internetwork Expert logo, Cisco IOS, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity, Enterprise/Solver, EtherChannel, EtherFast, EtherSwitch, Fast Step, Follow Me Browsing, FormShare, GigaDrive, HomeLink, Internet Quotient, IOS, iPhone, IP/TV, iQ Expertise, the iQ logo, iQ Net Readiness Scorecard, iQuick Study, LightStream, Linksys, MeetingPlace, MGX, Networkers, Networking Academy, Network Registrar, PIX, ProConnect, ScriptShare, SMARTnet, StackWise, The Fastest Way to Increase Your Internet Quotient, and TransPath are registered trademarks of Cisco Systems, Inc. and/or its affiliates in the United States and certain other countries.

All other trademarks mentioned in this document or Website are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (0711R)
Preface xxii

Audience xxii

Purpose xxii

Organization xxii

Conventions xxiii

Related Publications xxiii

Obtaining Documentation, Obtaining Support, and Security Guidelines xxiv

CHAPTER 1

Overview 1-1

Overview of the Cisco Unified Wireless Network Solution 1-2

Overview of WCS 1-3

WCS Versions 1-4

WCS Base 1-4

WCS Base + Location 1-5

Relationship with Cisco Location Appliances 1-5

Comparison of WCS Base and WCS Location 1-6

WCS User Interface 1-7

Cisco WCS Navigator 1-7

CHAPTER 2

Getting Started 2-1

Prerequisites 2-2

System Requirements 2-2

Installing WCS for Windows 2-4

Installing WCS for Linux 2-10

Starting WCS 2-12

Starting WCS on Windows 2-12

Starting WCS on Linux 2-12

Logging into the WCS User Interface 2-13

General Tab 2-14

Client Tab 2-15

Security Tab 2-16

Customizing Tabs on the WCS Home Page 2-17

Customizing Content on the WCS Home Page 2-18

Using the Cisco WCS User Interface 2-20

Menu Bar 2-21

Monitor Menu 2-21

Configure Menu 2-21
CHAPTER 3

Configuring Security Solutions 3-1

Cisco Unified Wireless Network Solution Security 3-2
Layer 1 Solutions 3-2
Layer 2 Solutions 3-2
Layer 3 Solutions 3-2
Single Point of Configuration Policy Manager Solutions 3-3
Rogue Access Point Solutions 3-3
Rogue Access Point Challenges 3-3
Tagging and Containing Rogue Access Points 3-3
Rogue Management 3-3
Integrated Security Solutions 3-4

Using WCS to Convert a Cisco Unified Wireless Network Solution from Layer 3 to Layer 2 Mode 3-5

Configuring a Firewall for WCS 3-6
Access Point Authorization 3-6
Management Frame Protection (MFP) 3-7
Guidelines for Using MFP 3-8
Configuring Intrusion Detection Systems (IDS) 3-9
Viewing IDS Sensors 3-9
Configuring IDS Signatures 3-9
Uploading IDS Signatures 3-12
Downloading IDS Signatures 3-13
Enabling or Disabling IDS Signatures 3-14
Viewing IDS Signature Events 3-17

Enabling Web Login 3-17
Downloading Customized Web Authentication 3-18
Connecting to the Guest WLAN 3-21
Deleting a Guest User 3-21
Certificate Signing Request (CSR) Generation 3-22
CHAPTER 4
Performing System Tasks 4-1
Adding System Components to the WCS Database 4-2
  Adding a Controller to the WCS Database 4-2
  Adding a Location Appliance to the WCS Database 4-2
    Additional Functionality with Location Appliance 4-3
Using WCS to Update System Software 4-4
Downloading Vendor Device Certificates 4-5
Downloading Vendor CA Certificates 4-5
Using WCS to Enable Long Preambles for SpectraLink NetLink Phones 4-6
Creating an RF Calibration Model 4-7

CHAPTER 5
Adding and Using Maps 5-1
Creating Maps 5-2
  Adding a Campus 5-2
  Adding Buildings 5-3
    Adding a Building to a Campus Map 5-3
    Adding a Standalone Building 5-4
  Adding Outdoor Areas 5-6
  Enabling Location Presence on a Location Server 5-7
Searching Maps 5-9
Finding Coverage Holes 5-10
Adding and Enhancing Floor Plans 5-10
  Adding Floor Plans to a Campus Building 5-11
  Adding Floor Plans to a Standalone Building 5-12
    Using the Map Editor to Enhance Floor Plans 5-13
    Using the Map Editor to Draw Polygon Areas 5-14
    Using Planning Mode to Calculate Access Point Requirements 5-17
  Adding Access Points 5-24
Placing Access Points 5-26
Creating a Network Design 5-28
  Designing a Network 5-28
  Changing Access Point Positions by Importing and Exporting a File 5-34
Using Chokepoints to Enhance Tag Location Reporting 5-35
  Adding Chokepoints to the WCS Database and Map 5-35
  Removing Chokepoints from the WCS Database and Map 5-42
  Monitoring Chokepoints 5-43
Monitoring Maps 5-43
  Monitoring Predicted Coverage 5-44
Contents

Access Point Layer  5-45
AP Mesh Info Layer  5-46
Clients Layer  5-47
802.11 Tags Layer  5-48
Rogue APs Layer  5-49
Rogue Clients Layer  5-50
Monitoring Channels on a Floor Map  5-51
Monitoring Transmit Power Levels on a Floor Map  5-51
Monitoring Coverage Holes on a Floor Map  5-52
Monitoring Clients on a Floor Map  5-53
Monitoring Outdoor Areas  5-54
Importing or Exporting WLSE Map Data  5-55
Creating and Applying Calibration Models  5-58
Analyzing Element Location Accuracy Using Testpoints  5-64
Assigning Testpoints to a Selected Area  5-65
Using the Accuracy Tool to Conduct Accuracy Testing  5-68
Using Scheduled Accuracy Testing to Verify Accuracy of Current Location  5-69
Using On-Demand Accuracy Testing to Test Location Accuracy  5-70

CHAPTER 6  Monitoring Wireless Devices  6-1

Monitoring Rogue Access Points, Adhocs, and Clients  6-2
Interpreting Security Summary Window  6-2
Malicious Rogue Access Points  6-4
Friendly Rogue Access Points  6-4
Unclassified Rogue Access Points  6-5
Rogue Adhocs  6-6
Most Recent Security Alerts  6-7
Most Recent Malicious Rogue Access Points  6-7
Most Recent Rogue Adhocs  6-7
Signature Attacks  6-7
Access Point Threats / Attacks  6-8
Client Security Related  6-8
IPSEC Failures  6-8
Monitoring Rogue Access Point  6-8
Monitoring Rogue Adhoc  6-10
Monitoring Rogue Clients  6-10
Monitoring Shunned Clients  6-11
Rogue Access Point Location, Tagging, and Containment  6-12
Detecting and Locating Rogue Access Points  6-13
Contents

Monitoring Clients 6-15
WLAN Client Troubleshooting 6-16
   Enabling Automatic Client Troubleshooting 6-30
Finding Clients 6-30
Receiving Radio Measurements 6-34
Monitoring Mesh Networks Using Maps 6-35
   Monitoring Mesh Link Statistics Using Maps 6-35
   Monitoring Mesh Access Points Using Maps 6-38
   Monitoring Mesh Access Point Neighbors Using Maps 6-40
   Monitoring Mesh Health 6-42
Mesh Statistics for an Access Point 6-44
Viewing the Mesh Network Hierarchy 6-49
   Using Mesh Filters to Modify Map Display of Maps and Mesh Links 6-50
Viewing Google Earth Maps 6-52
   Google Earth Settings 6-53
Viewing Clients Identified as WGBs 6-54
Running a Link Test 6-55
Retrieving the Unique Device Identifier on Controllers and Access Points 6-57
Coverage Hole 6-60
   Monitoring Pre-Coverage Holes 6-60
Viewing DHCP Statistics 6-62

CHAPTER 7
Managing WCS User Accounts 7-1
Adding WCS User Accounts 7-2
   Deleting WCS User Accounts 7-4
   Changing Passwords 7-4
   Monitoring Active Sessions 7-5
Viewing or Editing User Information 7-6
Viewing or Editing Group Information 7-7
Setting Lobby Ambassador Defaults 7-9
   Editing the Default Lobby Ambassador Credentials 7-10
Viewing the Audit Trail 7-10
Enabling Audit Trails for Guest User Activities 7-12
Creating Guest User Accounts 7-12
   Creating a Lobby Ambassador Account 7-14
   Editing a Lobby Ambassador Account 7-15
   Logging in to the WCS User Interface as a Lobby Ambassador 7-16
### Configuring Mobility Groups  8-1

- Overview of Mobility  8-2
- Symmetric Tunneling  8-5

Overview of Mobility Groups  8-5
  - When to Include Controllers in a Mobility Group  8-7
  - Messaging among Mobility Groups  8-7

Configuring Mobility Groups  8-8
  - Prerequisites  8-8
  
  Setting the Mobility Scalability Parameters  8-11

Mobility Anchors  8-13
  - Configuring Mobility Anchors  8-13

Configuring Multiple Country Codes  8-15

Creating Config Groups  8-18
  - Adding New Group  8-19
  - Configuring Config Groups  8-20
  
  Adding or Removing Controllers from Config Group  8-20
  
  Adding or Removing Templates from the Config Group  8-21

Applying Config Groups  8-21
  - Auditing Config Groups  8-22
  - Rebooting Config Groups  8-22

Downloading Software  8-23
  - Downloading IDS Signatures  8-24
  - Downloading Customized WebAuth  8-25

### Configuring Controllers and Access Points  9-1

- Adding Controllers  9-2
- Setting Multiple Country Codes  9-3
- Searching Controllers  9-4

Managing User Authentication Order  9-5
Viewing Audit Status (for Controllers) 9-5
Viewing Latest Network Audit Report 9-6
Pinging a Network Device from a Controller 9-7
Enabling Load-Based CAC for Controllers 9-7
Enabling High Density 9-9
Requirements 9-9
Optimizing the Controller to Support High Density 9-10
Configuring 802.3 Bridging 9-12
Configuring an RRM Threshold Controller (for 802.11a/n or 802.11b/g/n) 9-12
Configuring EDCA Parameters for Individual Controller 9-13
Configuring SNMPv3 9-13
Configuring Global Credentials for Access Points 9-14
Autonomous to LWAPP Migration Support 9-15
Adding IOS Access Points to WCS 9-16
Adding IOS Access Points by Device Information 9-16
Adding Autonomous Access Points by CSV File 9-17
Viewing Autonomous Access Points in WCS 9-17
Work Group Bridge (WGB) Mode 9-18
Autonomous Access Point to LWAPP Access Point Migration 9-18
Adding/Modifying a Migration Template 9-18
Configuring Access Points 9-19
Configuring Access Point Radios for Location Optimized Monitor Mode 9-24
Scheduling Radio Status 9-25
Viewing Scheduled Tasks 9-25
Viewing Audit Status (for Access Points) 9-26
Searching Access Points 9-26
Viewing or Editing Rogue Access Point Rules 9-27
Configuring Spectrum Experts 9-28
Adding a Spectrum Expert 9-28
Monitoring Spectrum Experts 9-28
Spectrum Experts > Summary 9-29
Interferers > Summary 9-29
Spectrum Experts Details 9-30
Configuring Wired Guest Access 9-30

CHAPTER 10  Using Templates 10-1
Adding Controller Templates 10-1
Configuring an NTP Server Template 10-3
Configuring General Templates 10-4
Configuring QoS Templates 10-7
Configuring a Traffic Stream Metrics QoS Template 10-8
Configuring WLAN Templates 10-9
  Security 10-12
  QoS 10-17
  Advanced 10-18
Configuring H-REAP AP Groups 10-21
Configuring a File Encryption Template 10-22
Configuring a RADIUS Authentication Template 10-23
Configuring a RADIUS Accounting Template 10-25
Configuring a LDAP Server Template 10-26
Configuring a TACACS+ Server Template 10-27
Configuring a Network Access Control Template 10-28
Configuring a Local EAP General Template 10-29
Configuring a Local EAP Profile Template 10-31
Configuring an EAP-FAST Template 10-32
Configuring Network User Credential Retrieval Priority Templates 10-34
Configuring a Local Network Users Template 10-34
Configuring Guest User Templates 10-36
Configuring a User Login Policies Template 10-37
Configuring a MAC Filter Template 10-38
Configuring an Access Point or LBS Authorization 10-39
Configuring a Manually Disabled Client Template 10-40
Configuring a CPU Access Control List (ACL) Template 10-41
Configuring a Rogue Policies Template 10-42
Configuring a Rogue AP Rules Template 10-43
Configuring a Rogue AP Rule Groups Template 10-45
Configuring a Friendly Access Point Template 10-47
Configuring a Client Exclusion Policies Template 10-48
Configuring an Access Point Authentication and MFP Template 10-50
Configuring a Web Authentication Template 10-51
  Downloading a Customized Web Authentication Page 10-53
Configuring Access Control List Templates 10-55
Configuring a Policy Name Template (for 802.11a/n or 802.11b/g/n) 10-56
Configuring High Density Templates 10-59
Configuring a Voice Parameter Template (for 802.11a/n or 802.11b/g/n) 10-61
Configuring a Video Parameter Template (for 802.11a/n or 802.11b/g/n) 10-62
Configuring EDCA Parameters through a Controller Template 10-63
Configuring a Roaming Parameters Template (for 802.11a/n or 802.11b/g/n) 10-64
<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuring an RRM Threshold Template (for 802.11a/n or 802.11b/g/n)</td>
<td>10-65</td>
</tr>
<tr>
<td>Configuring an RRM Interval Template (for 802.11a/n or 802.11b/g/n)</td>
<td>10-66</td>
</tr>
<tr>
<td>Configuring an 802.11h Template</td>
<td>10-67</td>
</tr>
<tr>
<td>Configuring a High Throughput Template (for 802.11a/n or 802.11b/g/n)</td>
<td>10-68</td>
</tr>
<tr>
<td>Configuring a Mesh Template</td>
<td>10-69</td>
</tr>
<tr>
<td>Configuring a TFTP Server Template</td>
<td>10-71</td>
</tr>
<tr>
<td>Configuring a Trap Receiver Template</td>
<td>10-71</td>
</tr>
<tr>
<td>Configuring a Trap Control Template</td>
<td>10-72</td>
</tr>
<tr>
<td>Configuring a Telnet SSH Template</td>
<td>10-74</td>
</tr>
<tr>
<td>Configuring a Legacy Syslog Template</td>
<td>10-75</td>
</tr>
<tr>
<td>Configuring a Multiple Syslog Template</td>
<td>10-76</td>
</tr>
<tr>
<td>Configuring a Local Management User Template</td>
<td>10-77</td>
</tr>
<tr>
<td>Configuring a User Authentication Priority Template</td>
<td>10-78</td>
</tr>
<tr>
<td>Applying Controller Templates</td>
<td>10-79</td>
</tr>
<tr>
<td>Adding Access Point Templates</td>
<td>10-79</td>
</tr>
<tr>
<td>Configuring Access Point Templates</td>
<td>10-80</td>
</tr>
<tr>
<td>Configuring Radio Templates</td>
<td>10-82</td>
</tr>
<tr>
<td>Selecting Access Points</td>
<td>10-84</td>
</tr>
<tr>
<td>Applying the Report</td>
<td>10-84</td>
</tr>
</tbody>
</table>

**CHAPTER 11**

Performing Maintenance Operations 11-1

- Checking the Status of WCS 11-2
  - Checking the Status of WCS on Windows 11-2
  - Checking the Status of WCS on Linux 11-2
- Stopping WCS 11-3
  - Stopping WCS on Windows 11-3
  - Stopping WCS on Linux 11-3
- Backing Up the WCS Database 11-4
  - Scheduling Automatic Backups 11-4
  - Performing a Manual Backup 11-5
    - Backing Up the WCS Database (for Windows) 11-5
    - Backing Up the WCS Database (for Linux) 11-5
- Restoring the WCS Database 11-6
  - Restoring the WCS Database (for Windows) 11-6
  - Restoring the WCS Database (for Linux) 11-7
- Importing the Location Appliance into WCS 11-8
- Importing and Exporting Asset Information 11-10
  - Importing Asset Information 11-10
  - Exporting Asset Information 11-10
Contents

Auto-Synchronizing Location Appliances 11-11
Backing Up Location Appliance Data 11-12
Uninstalling WCS 11-15
  Uninstalling WCS on Windows 11-15
  Uninstalling WCS on Linux 11-15
Upgrading WCS 11-16
  Using the Installer to Upgrade WCS for Windows 11-16
  Using the Installer to Upgrade WCS for Linux 11-19
  Manually Upgrading WCS on Windows 11-20
  Manually Upgrading WCS on Linux 11-20
Upgrading the Network 11-21
Reinitializing the Database 11-21
Recovering the WCS Password 11-21

Chapter 12

Configuring Hybrid REAP 12-1
Overview of Hybrid REAP 12-2
  Hybrid-REAP Authentication Process 12-2
  Hybrid REAP Guidelines 12-4
Configuring Hybrid REAP 12-4
  Configuring the Switch at the Remote Site 12-4
  Configuring the Controller for Hybrid REAP 12-6
  Configuring an Access Point for Hybrid REAP 12-9
  Connecting Client Devices to the WLANs 12-11
Hybrid REAP Access Point Groups 12-12
  Hybrid-REAP Groups and Backup RADIUS Servers 12-13
  Hybrid-REAP Groups and Local Authentication 12-13
  Configuring Hybrid-REAP Groups 12-13
  Auditing an H-REAP Group 12-16

Chapter 13

Alarms and Events 13-1
Using the Alarm Dashboard 13-1
Monitoring Alarms 13-4
  Using Edit View 13-5
  Using Search 13-6
  Monitoring Failed Objects 13-7
  Monitoring Rogue Access Point Alarms 13-7
  Monitoring Rogue Access Point Details 13-9
  Monitoring Rogue Adhoc Alarms 13-10
Monitoring Rogue Adhoc Details  13-11
Detecting Access Points  13-12
Monitoring Events  13-12
Monitoring Rogue Clients  13-13
Monitoring E-mail Notifications  13-13
Monitoring Security Configurations  13-14

Alarm and Event Dictionary  13-14
Notification Format  13-15
Traps Added in Release 2.0  13-15
Traps Added in Release 2.1  13-33
Traps Added in Release 2.2  13-37
Traps Added in Release 3.0  13-39
Traps Added in Release 3.1  13-41
Traps Added in Release 3.2  13-44
Traps Added In Release 4.0  13-45
Traps Added/Updated in Release 4.0.96.0  13-49
Traps Added or Updated in Release 4.1  13-51
Traps Added or Updated in Release 4.2  13-58
Traps Added or Updated in Release 5.0  13-62
Unsupported Traps  13-63

CHAPTER 14

Running Reports  14-1
Choosing a Report  14-2
Enabling or Disabling a Schedule  14-2
Deleting a Report  14-3
Accessing the Schedule Panel  14-3
Access Point Reports  14-4
Viewing or Modifying Access Point Reports  14-4
Creating a New Access Point Report  14-5
Audit Reports  14-5
Viewing or Modifying Audit Reports  14-6
Creating a New Network Configuration Audit Report  14-6
Client Reports  14-7
Viewing or Modifying Client Reports  14-7
Creating a New Client Report  14-8
Inventory Reports  14-8
Viewing or Modifying Inventory Reports  14-9
Creating a New Inventory Report  14-9
Mesh Reports  14-10
CHAPTER 15

Administrative Tasks 15-1

Running Background Tasks 15-2
Performing a Task 15-2
Importing Tasks Into ACS 15-4
  Adding WCS to an ACS Server 15-4
  Adding WCS as a TACACS+ Server 15-5
  Adding WCS UserGroups into ACS for TACACS+ 15-6
  Adding WCS to ACS server for Use with RADIUS 15-9
  Adding WCS UserGroups into ACS for RADIUS 15-10
  Adding WCS to a Non-Cisco ACS Server for Use with RADIUS 15-13
Setting AAA Mode 15-15
Auto Provisioning 15-16
  Viewing Detailed Auto Provisioning Device Information 15-19
  Editing a Current Auto Provisioning Filter 15-19
  Deleting an Auto Provisioning Filter 15-20
  Viewing Details of an Auto Provisioned Filter 15-20
  Setting Auto Provisioning 15-21
Turning Password Rules On or Off 15-21
Configuring TACACS+ Servers 15-22
Configuring RADIUS Servers 15-23
Establishing Logging Options 15-24
Performing Data Management Tasks 15-25
  Data Management 15-26
  Report 15-27
  Mail Server 15-27
  Login Disclaimer 15-29
  Alarms 15-29
  Enabling Automatic Client Troubleshooting 15-29
  Notification Receiver 15-30

Viewing or Modifying Mesh Reports 14-11
Creating a New Mesh Report 14-11
Performance Reports 14-12
  Viewing or Modifying Performance Reports 14-12
  Creating a New Performance Report 14-12
Security Reports 14-13
  Viewing or Modifying Security Reports 14-14
  Creating a New Security Report 14-14
<table>
<thead>
<tr>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>SNMP Settings</strong> 15-30</td>
</tr>
<tr>
<td>Setting User Preferences 15-31</td>
</tr>
<tr>
<td><strong>CHAPTER 16</strong> 16-1</td>
</tr>
<tr>
<td>Google Earth Maps</td>
</tr>
<tr>
<td>Creating an Outdoor Location Using Google Earth 16-1</td>
</tr>
<tr>
<td>Understanding Geographical Coordinates for Google Earth 16-1</td>
</tr>
<tr>
<td>Creating and Importing Coordinates in Google Earth (KML File) 16-2</td>
</tr>
<tr>
<td>Creating and Importing Coordinates as a CSV File 16-4</td>
</tr>
<tr>
<td>Importing a File into WCS 16-6</td>
</tr>
<tr>
<td>Viewing Google Earth Maps 16-6</td>
</tr>
<tr>
<td>Google Earth Settings 16-8</td>
</tr>
<tr>
<td><strong>APPENDIX A</strong> A-1</td>
</tr>
<tr>
<td>Appendix A: Troubleshooting and Best Practices A-1</td>
</tr>
<tr>
<td>Troubleshooting Cisco Compatible Extensions Version 5 Client Devices A-2</td>
</tr>
<tr>
<td>Diagnostic Channel A-2</td>
</tr>
<tr>
<td>Configuring the Diagnostic Channel A-2</td>
</tr>
<tr>
<td>Web Auth Security on WLANs A-3</td>
</tr>
<tr>
<td>Debug Commands A-4</td>
</tr>
<tr>
<td>Debug Strategy A-4</td>
</tr>
<tr>
<td>Best Practices A-9</td>
</tr>
<tr>
<td><strong>APPENDIX B</strong> B-1</td>
</tr>
<tr>
<td>Appendix B: WCS and End User Licenses B-1</td>
</tr>
<tr>
<td>WCS Licenses B-2</td>
</tr>
<tr>
<td>Types of Licenses B-2</td>
</tr>
<tr>
<td>Licensing Enforcement B-3</td>
</tr>
<tr>
<td>Product Authorization Key Certificate B-3</td>
</tr>
<tr>
<td>Determining Which License To Use B-4</td>
</tr>
<tr>
<td>Installing a License B-4</td>
</tr>
<tr>
<td>Managing Licenses B-5</td>
</tr>
<tr>
<td>Adding a License B-5</td>
</tr>
<tr>
<td>Deleting a License B-6</td>
</tr>
<tr>
<td>Backup and Restore License B-6</td>
</tr>
<tr>
<td>Open Source License Acknowledgements B-6</td>
</tr>
<tr>
<td>OpenSSL/Open SSL Project B-6</td>
</tr>
<tr>
<td>End User License Agreement B-7</td>
</tr>
<tr>
<td><strong>APPENDIX C</strong> C-1</td>
</tr>
<tr>
<td>Appendix C: Supported Hardware C-1</td>
</tr>
<tr>
<td>Supported Cisco WLSE Management Stations C-2</td>
</tr>
</tbody>
</table>
Preface

Obtaining Documentation and Submitting a Service Request

For information on obtaining documentation, submitting a service request, and gathering additional information, see the monthly What’s New in Cisco Product Documentation, which also lists all new and revised Cisco technical documentation, at:


Subscribe to the What’s New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free service and Cisco currently supports RSS version 2.0. The preface provides an overview of the Cisco Wireless Control System Configuration Guide, references related publications, and explains how to obtain other documentation and technical assistance, if necessary. It contains these sections:

• Audience, page xviii
• Purpose, page xviii
• Organization, page xviii
• Conventions, page xix
• Related Publications, page xix
• Obtaining Documentation, Obtaining Support, and Security Guidelines, page xx
Audience

This guide describes the Cisco Wireless Control System (WCS). It is meant for networking professionals who use WCS to manage a Cisco Unified Wireless Network Solution. To use this guide, you should be familiar with the concepts and terminology associated with wireless LANs.

Purpose

This guide provides the information you need to manage a Cisco Unified Wireless Network Solution using WCS.

Note

This document pertains specifically to WCS 4.2. Earlier versions of WCS software may look and operate somewhat differently.

Organization

This guide contains the following chapters:


Chapter 2, “Getting Started,” describes how to prepare WCS for operation.


Chapter 4, “Performing System Tasks,” describes how to use WCS to add a controller and location appliance to the WCS database, update system software, enable long preambles for SpectraLink NetLink phones, and create an RF calibration model.

Chapter 5, “Adding and Using Maps,” describes how to add maps to the Cisco WCS database and use them to monitor your wireless LAN.

Chapter 6, “Monitoring Wireless Devices,” describes how to use WCS to monitor your wireless LANs.

Chapter 7, “Managing WCS User Accounts,” describes how to add, delete, and change the passwords of WCS user accounts. It also describes creating a guest user account on WCS and how to configure it for limited activity.

Chapter 8, “Configuring Mobility Groups” provides an overview of mobility and mobility groups and describes how to configure them.

Chapter 9, “Configuring Controllers and Access Points,” describes how to configure controllers and access points for specific tasks within the Cisco WCS database.

Chapter 10, “Using Templates” describes how to set parameters for multiple devices without having to re-enter the common information.

Chapter 11, “Performing Maintenance Operations,” describes how to check the status of, stop, uninstall, and upgrade WCS. It also provides instructions for backing up and restoring the WCS database.

Chapter 12, “Configuring Hybrid REAP,” describes hybrid REAP and explains how to configure this feature on controllers and access points.

Chapter 13, “Alarms and Events” defines alarms and events and what constitutes each.
Chapter 14, “Running Reports,” describes the various reports that can be generated to run on an immediate and scheduled basis for use with diagnosing system and network health.

Chapter 15, “Administrative Tasks,” describes certain administrative tasks you can perform with WCS.

Appendix A, “Troubleshooting and Best Practices,” provides some troubleshooting and best practices tips for a few of the more complicated features.

Appendix B, “WCS and End User Licenses,” provides the end user license and warranty that apply to WCS.


**Conventions**

This publication uses the following conventions to convey instructions and information:

- Commands and keywords are in **boldface** text.
- Variables are in *italicized* text.

<table>
<thead>
<tr>
<th><strong>Note</strong></th>
<th>Means <em>reader take note</em>. Notes contain helpful suggestions or references to material not contained in this manual.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th><strong>Caution</strong></th>
<th>Means <em>reader be careful</em>. In this situation, you might do something that could result in equipment damage or loss of data.</th>
</tr>
</thead>
</table>

**Related Publications**

For more information about WCS and related products, refer to the following documents:


<table>
<thead>
<tr>
<th><strong>Note</strong></th>
<th>Click this link to browse to these documents:</th>
</tr>
</thead>
</table>
Obtaining Documentation, Obtaining Support, and Security Guidelines

For information on obtaining documentation, obtaining support, providing documentation feedback, security guidelines, and also recommended aliases and general Cisco documents, see the monthly What’s New in Cisco Product Documentation, which also lists all new and revised Cisco technical documentation, at:

Overview

This chapter describes the Cisco Unified Wireless Network Solution and the Cisco Wireless Control System (WCS). It contains these sections:

- Overview of the Cisco Unified Wireless Network Solution, page 1-2
- Overview of WCS, page 1-3
- WCS Versions, page 1-4
- WCS User Interface, page 1-7
- Cisco WCS Navigator, page 1-7
Overview of the Cisco Unified Wireless Network Solution

The Cisco Unified Wireless Network solution is designed to provide 802.11 wireless networking solutions for enterprises and service providers. It simplifies the deployment and management of large-scale wireless LANs and enables a unique best-in-class security infrastructure. The operating system manages all data client, communications, and system administration functions, performs radio resource management (RRM) functions, manages system-wide mobility policies using the operating system security solution, and coordinates all security functions using the operating system security framework.

The Cisco Unified Wireless Network Solution consists of Cisco Unified Wireless Network Controllers (hereafter called controllers) and their associated lightweight access points controlled by the operating system, all concurrently managed by any or all of the operating system user interfaces:

- An HTTPS full-featured web user interface hosted by Cisco controllers can be used to configure and monitor individual controllers.
- A full-featured command line interface (CLI) can be used to configure and monitor individual controllers.
- The Cisco Wireless Control System (WCS) can be used to configure and monitor one or more controllers and associated access points. WCS has tools to facilitate large-system monitoring and control. It runs on Windows 2003 and Red Hat Enterprise Linux ES/AS 4 servers.
- An industry-standard SNMP V1, V2c, and V3 interface can be used with any SNMP-compliant third-party network management system.

The Cisco Unified Wireless Network Solution supports client data services, client monitoring and control, and all rogue access point detection, monitoring, and containment functions. It uses lightweight access points, controllers, and the optional WCS to provide wireless services to enterprises and service providers.

Note

This document refers to controllers throughout. Unless specified otherwise, the descriptions herein apply to all Cisco Unified Wireless Network Controllers, including but not limited to Cisco 2000 and 2100 Series Unified Wireless Network Controllers, Cisco 4100 Series Unified Wireless Network Controllers, Cisco 4400 Series Unified Wireless Network Controllers, and controllers within the Cisco Wireless Services Module (WiSM) and Cisco 26/28/37/38xx Series Integrated Services Routers.

Figure 1-1 shows the Cisco Unified Wireless Network Solution components, which can be simultaneously deployed across multiple floors and buildings.
Overview of WCS

The Cisco Wireless Control System (WCS) is a Cisco Unified Wireless Network Solution management tool that adds to the capabilities of the web user interface and command line interface (CLI), moving from individual controllers to a network of controllers. WCS includes the same configuration, performance monitoring, security, fault management, and accounting options used at the controller level and adds a graphical view of multiple controllers and managed access points.

WCS runs on Windows 2003 and Red Hat Enterprise Linux ES 4.0 and AS 4.0 servers. On both Windows and Linux, WCS can run as a normal application or as a service, which runs continuously and resumes running after a reboot.

The WCS user interface enables operators to control all permitted Cisco Unified Wireless Network Solution configuration, monitoring, and control functions through Internet Explorer 6.0 or later. Operator permissions are defined by the administrator using the WCS user interface Administration menu, which enables the administrator to manage user accounts and schedule periodic maintenance tasks.

WCS simplifies controller configuration and monitoring while reducing data entry errors. WCS uses the industry-standard SNMP protocol to communicate with the controllers.
WCS Versions

You can install WCS with one of two capabilities: WCS Base or WCS Location. Regardless of whether you choose WCS Base or WCS Location, a license is required.

WCS Base

The WCS Base supports wireless client data access, rogue access point, and rogue ad hoc detection and containment functions (such as on-demand location of rogue access points that are mapped next to the detecting access point), and Cisco UWN Solution monitoring and control.

It also includes graphical views of the following:

- Autodiscovery of access points as they associate with controllers
- Autodiscovery and containment or notification of rogue access points
- Map-based organization of access point coverage areas, which is helpful when the enterprise spans more than one geographical area
- Rogue adhoc
- User-supplied campus, building, and floor plan graphics, which show the following:
  - Locations and status of managed access points
  - Locations of rogue access points based on the signal strength received by the nearest managed Cisco access points
  - Coverage hole alarm information for access points based on the received signal strength from clients. This information appears in a tabular rather than map format.
  - RF coverage maps

The WCS Base also provides system-wide control of the following:

- Streamlined network, controller, and managed access point configuration using customer-defined templates
- Network, controller, and managed access point status and alarm monitoring
- Automated and manual data client monitoring and control functions
- Automated monitoring of rogue access points, rogue adhocs, coverage holes, security violations, controllers, and access points
- Full event logs for data clients, rogue access points, coverage holes, security violations, controllers, and access points
- Automatic channel and power level assignment by radio resource management (RRM)
- User-defined automatic controller status audits, missed trap polling, configuration backups, and policy cleanups
- Real-time location of rogue access points and rogue adhocs to the nearest Cisco access point
- Real-time and historical location of clients to the nearest Cisco access point
WCS Base + Location

The WCS Location includes all the features of the WCS Base as well as these enhancements:

- On-demand location of rogue access points and rogue ad hocs to within 33 feet (10 meters)
- On-demand location of clients to within 33 feet (10 meters)
- Ability to use location appliances to collect and return historical location data viewable in the WCS Location user interface

Relationship with Cisco Location Appliances

When WCS Location is used, end users can also deploy Cisco 2700 Series Location Appliances. The location appliance enhances the high-accuracy built-in WCS Location capabilities by computing, collecting, and storing historical location data, which can be displayed in WCS. In this role, the location appliance acts as a server to a WCS server by collecting, storing, and passing on data from its associated controllers.

After a quick command line interface (CLI) configuration, the remaining location appliance configuration can be completed using the WCS user interface. After each location appliance is configured, it communicates directly with its associated controllers to collect operator-defined location data. The associated WCS server operators can then communicate with each location appliance to transfer and display selected data.

The location appliance can be backed up to any WCS server into an operator-defined FTP folder, and the location appliance can be restored from that server at any time and at defined intervals. Also, the location appliance database can be synchronized with the WCS server database at any time. Operators can use the location appliance features and download new application code to all associated appliances from any WCS server.

When WCS is enhanced with a location appliance, it can display historical location data for up to 2,500 laptop clients, palmtop clients, VoIP telephone clients, radio frequency identifier (RFID) asset tags, rogue access points, rogue ad hocs, and rogue clients for each location appliance in the Cisco Unified Wireless Network Solution. Operators can configure location appliances to collect this data and statistics at defined intervals.

You can also use WCS to configure location appliance event notification parameters. Event notification is a feature that enables you to define conditions that cause the location appliance to send notifications to the listeners whom you have specified in WCS.

In this way, WCS acts as a notification listener. It receives notifications from the location appliance in the form of the locationNotifyTrap trap as part of the bsnwras.my MIB file. WCS translates the traps into user interface alerts and displays the alerts in the following format:

Absence:
- Absence of Tag with MAC 00:0c:cc:5b:e4:1b, last seen at 16:19:45 13 Oct 2005.

Containment:
- Tag with MAC 00:0c:cc:5b:fa:44 is In the Area 'WNBU > WNBU > 4th Floor > wcsDevArea'

Distance:
- Tag with MAC 00:0c:cc:5b:fa:47 has moved beyond the distance configured for the marker 'marker2'.
- Tag with MAC 00:0c:cc:5b:f9:b9 has moved beyond 46.0 ft. of marker 'marker2', located at a range of 136.74526528595058 ft.
Comparison of WCS Base and WCS Location

Table 1-1 compares the WCS Base and WCS Location features.

<table>
<thead>
<tr>
<th>Features</th>
<th>WCS Base</th>
<th>WCS Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Location and tracking</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Low-resolution client location</td>
<td>Yes</td>
<td>—</td>
</tr>
<tr>
<td>High-resolution client location</td>
<td>—</td>
<td>Yes</td>
</tr>
<tr>
<td>Integration with location appliance</td>
<td>—</td>
<td>Yes</td>
</tr>
<tr>
<td>Low-resolution rogue access point location</td>
<td>Yes</td>
<td>—</td>
</tr>
<tr>
<td>High-resolution rogue access point location</td>
<td>—</td>
<td>Yes</td>
</tr>
<tr>
<td>Client data services, security, and monitoring</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Client access via access points</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Multiple wireless LANs (individual SSIDs and policies)</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Rogue access point detection and containment using access points</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>802.11a/b/g/n bands</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Radio resource management</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Real-time channel assignment and rogue access point detection and containment</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Real-time interference detection and avoidance, transmit power control, channel assignment, client mobility management, client load distribution, and coverage hole detection</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Automated software and configuration updates</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Wireless intrusion protection</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Global and individual AP security policies</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Controls Cisco Unified Wireless Network Controllers</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Supported workstations</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows 2003</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Red Hat Enterprise Linux ES 4.0 or AS 4.0 server</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>
WCS User Interface

The WCS user interface enables the network operator to create and configure Cisco Unified Wireless Network Solution coverage area layouts, configure system operating parameters, monitor real-time Cisco Unified Wireless Network Solution operation, and perform troubleshooting tasks using an HTTPS web browser window. The WCS user interface also enables the WCS administrator to create, modify, and delete user accounts; change passwords; assign permissions; and schedule periodic maintenance tasks. The administrator creates new usernames and passwords and assigns them to predefined permissions groups.

Note
Cisco recommends Internet Explorer 6.0 or later on a Windows workstation for full access to WCS functionality.

Cisco WCS Navigator

The Cisco Wireless Control System Navigator (Cisco WCS Navigator) manages multiple Cisco WCSs (running the same version as Navigator) and provides a unified view of the network. It uses SOAP/XML over HTTPS to communicate with individual WCSs. With WCS Navigator, there is monitoring functionality and reporting capability across all WCSs. In addition, network wide searches are available. In Windows and Linux, Cisco WCS Navigator runs as a service, which runs continuously and resumes running after a reboot.

In order for the WCS Navigator to detect the regional WCSs, you must manually add them to the system using either the IP address or hostname and specify the login credentials for each of the regional WCSs. After being added, WCS Navigator provides summary information and links to the regional WCS systems.
Getting Started

This chapter describes how to prepare WCS for operation. It contains these sections:

- Prerequisites, page 2-2
- System Requirements, page 2-2
- Installing WCS for Windows, page 2-4
- Installing WCS for Linux, page 2-11
- Starting WCS, page 2-12
- Logging into the WCS User Interface, page 2-13
- Customizing Content on the WCS Home Page, page 2-18
- Using the Cisco WCS User Interface, page 2-20
Prerequisites

Before installing the Cisco WCS, ensure that you have completed the following:

- Met the necessary hardware and software requirements as listed in the “System Requirements” section on page 2-2 for Cisco WCS.
- Updated your system with the necessary critical updates and service packs.

Note

Refer to the latest release notes for information on the service packs and patches required for correct operation of Cisco WCS.

- Verified that the following ports are open during installation and startup:
  - HTTP: configurable during install (80 by default)
  - HTTPS: configurable during install (443 by default)
  - 1315
  - 1299
  - 6789
  - 8009
  - 8456
  - 8005
  - 69
  - 21
  - 162
  - 8457

System Requirements

Cisco WCS can be run on a workstation/server class system and access points can be distributed unevenly across controllers. The following requirements must be met for the different components.

High End Server

- Up to 3000 Cisco Aironet lightweight access points, 1250 standalone access points, and 750 Cisco wireless LAN controllers.
- 3.16-GHz Intel Xeon Quad processor with 8-GB RAM.
- 80-GB minimum free disk space on your hard drive.

Note

The free disk space listed is a minimum requirement but may be different for your system, depending on the number of backups.
Standard Server

- Up to 2000 Cisco Aironet lightweight access points, 1000 standalone access points, and 150 Cisco wireless LAN controllers and 1000 autonomous access points.
- 3.2-GHz Intel Dual Core processor with 4-GB RAM.
- 40-GB minimum of free disk space on your hard drive.

Low End Server

- Up to 500 Cisco Aironet lightweight access points, 200 standalone access points, and 125 Cisco wireless LAN controllers.
- 3.06-GHz Intel processor with 2-GB RAM.
- 30-GB minimum free disk space on your hard drive.

Operating Systems Requirements

The following operating systems are supported:

- Windows 2003/SP2 or later with all critical and security Windows updates installed. 64-bit installations are not supported.
- Red Hat Linux Enterprise Server 4.0 Update 5 or Advanced Server 4.0 Update 5. Only 32-bit operating system installations are supported. 64-bit operating system installations are not supported.
- Windows 2003 and Redhat Linux version support on VmWare ESX 3.0.1 version and above.

**Note**
VmWare must be installed on a system with these minimum requirements:
- Quad CPU running at 3.16 GHz
- 8 GBs RAM
- 200 GB hard drive

**Note**
Individual operating systems running WCS in VmWare must follow the specifications for the size of WCS you intend to use.

**Note**
Cisco WCS can be installed on Red Hat Linux Enterprise Server 4.0, but version 4.0 will not be supported in future releases. Please plan on migrating to Red Hat Linux Enterprise Server 5.0.

WCS on WLSE

- Up to 1500 Cisco Aironet lightweight access points and 100/375 Cisco wireless LAN controllers.
- 3-GHz Intel Pentium4 processor with 3 GB RAM
- 38-GB of free space on your hard drive.

WCS Portal

- 20 WCSs
Cisco WCS User Interface

The Cisco WCS user interface requires Internet Explorer 6.0/SP1 or later, with the Flash plug-in version 9.0.47.0. The Cisco WCS user interface has been tested and verified using Internet Explorer 6.0 on a Windows workstation.

Note: The screen resolution should be set to 1024 x 768 pixels for both WCS and Navigator.

Client Requirements

In order for clients to access WCS, they must have a minimum of 1-GB RAM and a 2-GHz processor. The client device should not be running any CPU or memory intensive applications.

Installing WCS for Windows

This section describes how to install Cisco WCS for Windows operating systems. Before installing Cisco WCS, refer to the “Prerequisites” section on page 2-2 and the “System Requirements” section on page 2-2. These sections give an overview of the system requirements and measures that you should take prior to the installation. You must have administrator privileges on Windows. If you receive a message that a previous version of WCS was detected, you must continue with one of two upgrade options. Refer to the “Upgrading WCS” section on page 11-15.

If installing WCS for Linux, see the “Installing WCS for Linux” section on page 2-11.

Guidelines Before Installing WCS

Note: You cannot install the WCS software if the username used to log into the server contains special characters such as exclamation marks (!). To ensure successful installation, log into the server using a username with no special characters before installing the software.

Cisco WCS does not support the underscore character (_) in the name of the Windows server running the WCS software. If the server name contains an underscore, you can install the WCS software, but WCS fails to start.

You must install WCS on a dedicated Windows server with no other services running (including those running as primary or secondary domain controllers) to avoid conflict with WCS.

To install Cisco WCS, follow these steps:

Step 1: Insert the Windows Cisco WCS CD into the CD-ROM drive and double click the WCS-STANDARD-K9-5.0.XX.Y.exe file where 5.0.XX.Y is the software build. If you received the installer from Cisco.com, double click the WCS-STANDARD-WB-K9-5-0-XX-Y.exe file that you downloaded to your local drive.

Step 2: The Install Anywhere window appears and prepares the system for installation. After a few seconds, the Introduction window appears, followed by the license agreement window (see Figure 2-1). You must click the “I accept the terms of the License Agreement” option to continue.
Step 3  If the install wizard detects a previous version of WCS, you see a window similar to Figure 2-2 or Figure 2-3. If a previous version is detected, you must proceed as an upgrade and refer to the “Upgrading WCS” section on page 11-15. For a first-time install, continue to Step 4.
Figure 2-2  Ineligible for Automated Upgrade

Wireless Control System

Radius
- Server Address
- Authentication Port: 1645
- Shared Secret Format: ASCII
- Shared Secret
- Confirm Shared Secret
- Retransmit Timeout: 5 seconds
- Retries: 3
- Authentication Type: EAP

Submit  Cancel
Step 4  The Check Ports window appears (see Figure 2-4). In the Check Ports window, change the default HTTP and HTTPS ports if necessary and click Next to open the Choose Install Type window. The default ports for HTTP and HTTPS are 80 and 443, respectively.
Step 5 Enter and re-enter the root password. The rules for a strong password are as follows:

- The minimum password length is 8.
- The password cannot contain the username or the reverse of the username.
- The password cannot be Cisco or ocsic (Cisco reversed).
- The root password cannot be public.
- No character can be repeated more than three times consecutively in the password.
- The password must contain three of the four following character classes: uppercase, lowercase, numbers, and special characters.

Step 6 Enter the root FTP password.

Step 7 From the FTP Server File window, choose a folder in which to store the FTP server files and click Next to bring up the TFTP File Server window.

Note Store the FTP server files in a folder outside the main installation folder. This ensures that the FTP server files are not deleted if Cisco WCS is uninstalled.

Step 8 From the TFTP Server File window, choose a folder in which to store the TFTP server files and click Next.

Note Store the TFTP server files in a folder outside the main installation folder. This ensures that the TFTP server files are not deleted if Cisco WCS is uninstalled.
Step 9  If you are installing Cisco WCS on a multi-homed server (a server having multiple interfaces), the installer automatically detects the presence of multiple interfaces. The Select Local Interfaces window appears (see Figure 2-5). Choose the interfaces to be used by the server for communicating with controllers, location appliances and remote FTP servers, and clients. Click **Next**.

**Figure 2-5  Select Local Interfaces Window**

![Select Local Interfaces Window](image)

Step 10  Choose a folder in which to install the Cisco WCS at the Choose Install Folder window (see Figure 2-6). Click **Next** to continue.
Step 11 Follow the prompts that appear on the screen to complete the installation. After the installation is complete, the Install Complete window appears. Click Done to complete the installation.

**Note** You can check the install log to determine if anything went wrong during the installation. The install log is located in the installation root directory if the installation completes. If the installation did not complete, the install log resides in the directory from which the installer was run or the install root directory.
Installing WCS for Linux

You must have root privileges on Linux. This section describes how to install Cisco WCS for Linux operating systems.

**Step 1** If not already done, log in as root, and open an X terminal session.

**Step 2** Using the command line, perform one of the following:

a. If you are installing from a CD, switch to the /media/cdrom directory.

b. If you are installing from Cisco.com, switch to the directory that the install file was downloaded to. For example, if the install file was placed in /root/Desktop, enter `cd /root/Desktop`.

**Step 3** Enter `/WCS-STANDARD-K9-5.0.XX.Y.bin` (for CD users) or `/WCS-STANDARD-LB-K9-5-0-XX-Y.bin` (for Cisco.com users) to start the install script. The install script prepares the install environment and displays the license agreement. You are asked to accept the terms of the license agreement.

**Step 4** If the install wizard detects a previous version of WCS, you see a message states whether the detected version is eligible for an automated upgrade or not. If a previous version is detected, you must proceed as an upgrade and refer to the “Upgrading WCS” section on page 11-15. For a first-time installation, continue to Step 5.

**Step 5** The Check Ports prompt appears. In the Check Ports window, change the default HTTP and HTTPS ports if necessary. The default ports for HTTP and HTTPS are 80 and 443, respectively.

**Step 6** Enter and re-enter the root password. The rules for a strong password are as follows:

- The minimum password length is 8.
- The password cannot contain the username or the reverse of the username.
- The password cannot be Cisco or ocsic (Cisco reversed).
- The root password cannot be public.
- No character can be repeated more than three times consecutively in the password.
- The password must contain three of the four character classes: uppercase, lowercase, numbers, and special characters.

**Step 7** Enter the root FTP password.

**Step 8** Choose a folder in which to store the FTP server files.

Note If the folder does not already exist, you must enter `mkdir` and create it.

**Step 9** Choose a folder in which to store the TFTP server files.

Note Store the TFTP server files in a folder outside the main installation folder. This ensures that the TFTP server files are not deleted if Cisco WCS is uninstalled.

**Step 10** If you are installing Cisco WCS on a multi-homed server (a server having multiple interfaces), the installer automatically detects the presence of multiple interfaces. Choose the interfaces to be used by the server for communicating with controllers, location appliances and remote FTP servers, and clients.

**Step 11** Choose a folder in which to install the Cisco WCS.
Starting WCS

This section provides instructions for starting WCS on either a Windows or Linux server.

In Windows and Linux, Cisco WCS is installed as a service. The service runs continuously and resumes after a reboot.

Note: You can check the status of WCS at any time. To do so, follow the instructions in the “Checking the Status of WCS” section on page 11-2.

Starting WCS on Windows

Follow these steps to start WCS when it is installed on Windows.

Note: When WCS is installed as a Windows service, WCS runs automatically upon system bootup.

Step 1
Log into the system as administrator.

Step 2
Perform one of the following:

- From the Windows Start menu, click Programs > Wireless Control System > StartWCS.
- From the command prompt, navigate to the WCS installation directory (C:\Program Files\WCS32\bin) and enter WCS Admin start.

The WCS Admin window appears and displays messages indicating that WCS is starting.

Note: If you are starting WCS after a restore from release 4.0.66.0 or earlier, the startup may take longer than expected. The WCS Admin window may even indicate that starting WCS has failed. Refer to the task viewer to see whether Java is progressively taking CPU space. If so, WCS is running.

Note: If WCS is installed as a service, messages also appear to indicate that the Nms_Server service is starting.

Step 3
Close the WCS Admin window when the Close button becomes active.
Starting WCS on Linux

Follow these steps to start WCS when it is installed on Linux.

**Note**
To see the version of WCS you currently have installed, enter `nmsadmin.sh version`.

**Note**
When WCS is installed as a Linux service, WCS runs automatically upon system bootup.

**Step 1**
Log into the system as root.

**Step 2**
Using the Linux command line interface (CLI), perform one of the following:
- Navigate to the `/opt/WCS32` directory (or the directory chosen during installation) and enter `/StartWCS`.
- Navigate to the `opt/WCS32/bin` directory and enter `WCSAdmin start`.

The CLI displays messages indicate that WCS is starting.

**Step 3**
WCS is ready to host WCS user interfaces (clients). Go to the “Logging into the WCS User Interface” section on page 2-13 to use a web browser to connect to the WCS user interface.

Logging into the WCS User Interface

Follow these steps to log into the WCS user interface through a web browser.

**Step 1**
Launch Internet Explorer 6.0 or later on a different computer than the one on which you installed and started WCS.

**Note**
Some WCS features may not function properly if you use a web browser other than Internet Explorer 6.0 on a Windows workstation.

**Step 2**
In the browser’s address line, enter `https://wcs-ip-address`, where `wcs-ip-address` is the IP address of the computer on which you installed and started WCS.

**Step 3**
When the WCS user interface displays the Login window, enter the root password which was created during installation.

Click Submit to log into WCS. The WCS user interface is now active and available for use. The WCS Home page appears. You can predefine what appears on the home page by choosing the monitoring components that are critical for your network. For example, you may want different monitoring components for a mesh network so that you can create a customized tab for a mesh dashboard.
Note

If the database or Apache web server does not start, check the launchout.txt file in Linux or the wrapper.log file in Windows. You will see a generic “failed to start database” or “failed to start the Apache web server” message.

This page allows you to choose the information that you want to see. You can organize the information in user-defined tabs. The default view comes with default tabs and pre-selected components for each, and you can arrange them as you like.

This page provides a summary of the Cisco Unified Wireless Network Solution, including coverage areas, the most recently detected rogue access points, access point operational data, reported coverage holes, and client distribution over time. Figure 2-7 shows a typical WCS Home page.

You should see 4 tabs on the WCS home page: General, Client, Security, and Mesh.

Note

When you use WCS for the first time, the network summary pages show that the Controllers, Coverage Areas, Most Recent Rogue APs, Top 5 APs, and Most Recent Coverage Holes databases are empty. It also shows that no client devices are connected to the system. After you configure the WCS database with one or more controllers, the WCS Home page provides updated information.

Figure 2-7  WCS Home

Note

To exit the WCS user interface, close the browser window or click Logout in the upper right corner of the page. Exiting a WCS user interface session does not shut down WCS on the server.
When a system administrator stops the WCS server during your WCS session, your session ends, and the web browser displays this message: “The page cannot be displayed.” Your session does not reassociate to WCS when the server restarts. You must restart the WCS session.

**General Tab**

The following are factory default components for the General Tab:

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inventory Detail Status</td>
<td>Displays the following:</td>
</tr>
<tr>
<td></td>
<td>• Controllers—Lists the number of controllers that are managed in WCS.</td>
</tr>
<tr>
<td></td>
<td>Graphically depicts reachable and unreachable controllers.</td>
</tr>
<tr>
<td></td>
<td>• Radios—Lists the number of radios managed in WCS.</td>
</tr>
<tr>
<td></td>
<td>Graphically depicts the number of radios in out-of-service (critical),</td>
</tr>
<tr>
<td></td>
<td>minor, and ok conditions.</td>
</tr>
<tr>
<td></td>
<td>• Location Servers—Lists the number of location servers that are managed</td>
</tr>
<tr>
<td></td>
<td>in WCS. Graphically depicts reachable and unreachable location servers.</td>
</tr>
<tr>
<td></td>
<td>Check the WCS logs to see if anything went wrong while manually adding</td>
</tr>
<tr>
<td></td>
<td>the location servers to WCS. (The trace for location servers must be</td>
</tr>
<tr>
<td></td>
<td>turned on.)</td>
</tr>
<tr>
<td>Coverage Areas</td>
<td>Displays a graphical representation of client count over time with the</td>
</tr>
<tr>
<td></td>
<td>default option of one day. The time options vary from one day to one year.</td>
</tr>
<tr>
<td></td>
<td>Custom dates can also be specified.</td>
</tr>
<tr>
<td>Client Count</td>
<td>Displays the total number of clients in WCS over the selected period of</td>
</tr>
<tr>
<td></td>
<td>time.</td>
</tr>
<tr>
<td>Recent Coverage Holes</td>
<td>Displays the most five recent coverage alarms.</td>
</tr>
<tr>
<td>Total APs not yet assigned to Maps</td>
<td>Indicates the number of unassigned access points. Click the number link to</td>
</tr>
<tr>
<td></td>
<td>view the list of these access points.</td>
</tr>
</tbody>
</table>

**Client Tab**

This client tab assists in identifying, diagnosing, and resolving client issues. The following are factory default components for the Client tab:

**Top APs By Client Count**

Displays the five access points with the highest client count showing the following data:

- **AP Name**—This is the name assigned to the access point. Click an item in the list to see the details of that access point.
- **Map Location**—The name of the map where the client is located.
- a/n Clients—The number of 802.11a clients currently associated with the controller.
- b/g/n Clients—The number of 802.11b clients and 802.11g clients currently associated with the controller.
- Total Client—Total number of clients currently associated with the controller.

**Most Recent Client Alarms**

Displays the five most recent client alarms by default showing the following data:
- Client—IP address, MAC address, or user-defined name of client.
- Date/Time—Date and time of client notification.
- Event Type—Reason for client notification. For example, disassociated, WEP decrypt error, or authentication failure.

Click the number in parentheses to access the Alarms page.

**Manually Disabled Clients**

Provides a link to view a list of manually disabled clients. Click **Manually Disabled Clients** to access this page.

This page enables you to view manually disabled client template information.
- MAC Address—Client MAC address.
- Description—Optional user-defined description.

**Client Traffic**

A graphic shows the associated clients during a given time frame. The client traffic (bps Out and bps In) appears in time increments of six hours, one day, one week, two weeks, four weeks, three months, six months, one year, or a custom time frame.

**Security Tab**

If you click the Security tab from the WCS Home page, you see the following factory default components:

<table>
<thead>
<tr>
<th>Table 2-2 Security Tab Components</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Component</strong></td>
</tr>
<tr>
<td>AP Attack Details</td>
</tr>
<tr>
<td>Signature Attacks Summary</td>
</tr>
<tr>
<td>Recent Rogue AP Alarms</td>
</tr>
</tbody>
</table>
Chapter 2  Getting Started

Logging into the WCS User Interface

Table 2-2  Security Tab Components

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recent Rogue Adhoc Alarm</td>
<td>Displays the five most recent rogue adhoc alarms. Click the number in parentheses to access the Alarms page. Click an item under MAC address to view adhoc details.</td>
</tr>
<tr>
<td>Most Recent Security Alarms</td>
<td>Displays the five most recent security alarms. Click the number in parentheses to access the Alarms page.</td>
</tr>
</tbody>
</table>

Mesh Tab

If you click the Mesh tab from the WCS Home page, you see the following factory default components:

Table 2-3  Mesh Tab Components

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Most Recent Mesh Alarms</td>
<td>Displays the five most recent mesh alarms. Click the number in parentheses to access the Alarms page.</td>
</tr>
<tr>
<td>Worst SNR Link</td>
<td>Displays the worst signal-to-noise ratio (SNR) links. Data includes the Parent AP Name, the Child AP Name, and the Link SNR.</td>
</tr>
<tr>
<td>Worst Node Hop Count</td>
<td>Displays the worst node hop counts. Data includes the AP Name, the Hop Count, and the Parent AP Name.</td>
</tr>
<tr>
<td>Worst Packet Error Rate</td>
<td>Displays the worst packet error rates. Data includes the Parent AP Name, the Child AP Name, and the Packet Error Rate.</td>
</tr>
</tbody>
</table>

Customizing Tabs on the WCS Home Page

You can customize the home page from the default four tabs and personalize its look. When you click the Edit Tabs link on the WCS Home page, you move to a screen in which customization can begin (see Figure 2-8). Follow these steps to create a new tab.
Chapter 2  Getting Started

Logging into the WCS User Interface

Figure 2-8  WCS Home > Edit Tab

Step 1  Enter the name of the new tab you are creating and click **Add**. The tab name you add appears in the Tab Order window.

Note  Add is the only function that does not require a Save after its operation. If you click **Delete**, **Rename**, **Move Up**, or **Move Down**, you must click **Save** for the changes to be applied.

Step 2  Click on the tab names in the Tab Order window and assign placement by clicking **Move Up** or **Move Down**.

Note  If you want to return to the restored factory defaults as shown in Figure 2-7, click **Reset**.

Customizing Content on the WCS Home Page

You can customize the home page components and personalize its look. When you click the Edit Contents link on the WCS Home page, you move to a screen in which customization can begin (see Figure 2-8). You can add or delete components by selecting from the predefined list.

Also part of the customizable home page are time-based or non-time-based interactive graphs which you can display in graphical or chart form (by clicking the appropriate icon). (Interactive graphs also appear in Monitor > Clients, Location > Location Servers, and Configure > Spectrum Experts.) These graphs
refresh automatically within a predetermined time based on the default polling cycles of dependent tasks. When a graph is time based, an additional link bar at the top of the graph window displays the options as follows:

- 6h—the last six hours of data from the current time and current database table
- 1d—the last day of data from the current time and current database table
- 1w—the last week of data from the current time and the hourly aggregated table
- 2w—the last two weeks of data from the current time and hourly aggregated table
- 4w—the last four weeks of data from the current time and hourly aggregated table
- 3m—the last three months of data from the current time and daily aggregated table
- 6m—the last six months of data from the current time and the weekly aggregated table
- 1y—the last year of data from the current time and weekly aggregated table
- custom—the user can set both the days and hours for the start and end date. The appropriate aggregated source (either current, hourly, or daily) is chosen based on the starting date.

After you specify the timeframe, the data for that timeframe is retrieved and the corresponding graph is displayed. The link for which the graph is drawn is shown in a different color (orange) than the other links. The interactive graphs that are available within WCS include line graphs, area graphs, pie graphs, and stacked bar graphs.

You can click **Enlarge Chart** to enlarge the graph in a separate window.

---

**Note**

Hold your mouse over the applicable button for a tool tip identifying the View in Chart or View in Grid. Click the View in Chart button to view the data in a graph. Click the **View in Grid** button to view the data in a table.

There are several components listed in the Available Contents on the WCS Home > Edit Content window. These options and their explanations are as follows:

- **Client Security Component**—This component displays client security details within the last 24 hours. The contents include excluded client events, WEP decrypt errors, WPA MIC errors, shunned clients, and IPSEC failures in the last hour, last 24 hours, and total.
- **Controller CPU Utilization**—This component displays in graphical form the average maximum and minimum CPU utilizations.
- **Most Recent AP Alarms**—This component displays the five most recent access point alarms by default. You can change the number of alarms to display. The All Alarm link goes to the alarm page in which all alarms are visible.
- **Recent Alarms**—This component displays the five most recent alarms by default. You can change the number of alarms to display. The All Alarm link goes to the alarm page in which all alarms are visible.
- **Rogue AP Detail Summary**—This component displays the five most recent rogue alarms. You can change the number of alarms to display. The summary provides the MAC address, SSID, type, state, and date and time stamp.
- **Rogue Adhoc Detail Summary**—This component displays the count for rogue adhoc alarms for on network and off network.
- **Controller Memory Utilization**—This component displays in graphical form the average maximum and minimum memory utilizations.
• Clients Detected by Location Server—This component shows the client count detected by the location server within the last 15 minutes. You can change the number of minutes to 30 or 60.
• Client Count—This component displays a graphical representation of the client count over time with the default option as one day. The time options vary from one day to one year, or you can enter custom dates.
• Inventory Status—The inventory status shows the following:
  – Controllers: Lists the number of controllers that are managed in WCS and graphically depicts the number of reachable and unreachable controllers.
  – Radios: Lists the number of radios managed in WCS and graphically depicts the number of radios in out-of-service (critical), minor, or ok conditions.
  – Location Servers: Lists the number of location servers that are managed in WCS and graphically depicts the number of reachable and unreachable location servers.
• Recent Coverage Holes—This component displays the most five recent coverage alarms. You can change the number of alarms to display.
• Client Traffic—This component displays in graphical form the average traffic in and out for all clients located in WCS.
• Coverage Areas—This component shows the different coverage areas on the map, lists the number of access points, radios, and clients within them, and provides a status. You can change the number of maps to display.

Follow these steps to create new content for the WCS home page.

---

**Step 1**
The home page is divided into two parts. From the Available Contents window, highlight the desired component and choose to add it to the left column or right column. The component moves to the appropriate column.

**Step 2**
Click the component from the Left Column or Right Column window and designate to move it up, down, to the right, or to remove.

---

**Using the Cisco WCS User Interface**

A typical Cisco WCS user interface page consists of the areas illustrated in Figure 2-9.
The following sections describe the Cisco WCS user interface page areas and how to use them:

- **Menu Bar**, page 2-21
- **Sidebar Area**, page 2-22
- **Alarm Dashboard**, page 2-22
- **Command Buttons**, page 2-22
- **Main Data Page**, page 2-23
- **Administrative Tools**, page 2-23

**Menu Bar**

There are five menus on each window: Monitor, Reports, Configure, Location, Administration, and Help. When you move the mouse over any of the menus, a drop-down menu appears.

**Note**

The Location menu is displayed only in Cisco WCS Location version.

**Monitor Menu**

The Monitor menu provides you with a top level description of the devices on your network. You can monitor your network, maps, various devices, security, alarms, events, or reports.

**Configure Menu**

The Configure menu allows you to configure templates, controllers, and access points on your network.
Administration Menu

The Administration menu allows you to schedule tasks like making a backup, checking a device status, auditing your network, synchronizing the location server, and so on. You can also choose Logging to enable various logging modules and specify restart requirements. You can also choose AAA for user administration such as changing passwords, establishing groups, setting application security settings, and so on.

Location Menu

The Location menu allows you to configure location appliances. A location appliance is a Cisco server that collects and stores up to 30 days of historical location data for up to 2,500 laptop clients, palmtop clients, VoIP telephone clients, active RFID (Radio Frequency Identifier) asset tags, rogue access points, and rogue access point clients.

Note

The Location menu is displayed only in Cisco WCS location version.

For more information on location appliances, refer to the Cisco 2700 Series Location Appliance Installation and Configuration Guide.

Note

Read/Write permissions are used by the location function of the location appliance. Write permissions allow a client application or location appliance operator to modify location data only (such as asset information), while Read permissions only allow a client to read location data.

Note

Full permissions are required for administration. All functions under the Locate menu in Cisco WCS are administrative functions. An administrator must always have full permissions.

Help Menu

The Help menu allows you to access online help and check the version of Cisco WCS.

To check the version of WCS, click About the Software. The product name, version number, copyright statement, and Apache Software Foundation statement is displayed.

Sidebar Area

The sidebar area allows you to choose a new configuration panel under the currently selected menu area. You may choose to display or configure any of the available data. The selector area options vary based on which menu you have chosen.

Some windows contain a group of menus in this area. Click the menu item to reveal a submenu and then click the item to chose it.
Alarm Dashboard

When Cisco WCS receives alarm messages from a controller, the Cisco WCS user interface displays an alarm indicator in the lower left corner in an alarm summary panel known as the alarm dashboard. The alarm dashboard only appears when the Macromedia flash is installed.

Alarms indicate the current fault or state of an element that needs attention. These are usually generated by one or more events. The alarm can be cleared, but the event remains. An example of an alarm is AP down, which means that the current status of the access point is down.

Alarms are color coded as follows:
- Clear = No alarm
- Red = Critical alarm
- Orange = Major alarm
- Yellow = Minor alarm

You can click any of the various types of alarms (such as rogues, coverage, security, controllers, access points, location, mesh links, and WCS) to display details.

Command Buttons

The Cisco WCS user interface uses a number of command buttons throughout its windows. The most common of these are as follows:
- Apply to Controllers: Applies the selected information to the controllers
- Delete: Deletes the selected information
- Cancel: Cancels new information entered on the current window and returns to the previous window
- Save: Saves the current settings
- Audit: Discovers the present status of this access point
- Place AP: Audits the configuration of the selected entity by flagging the differences between WCS database device configurations

Main Data Page

The main data page is determined by the required parameter information. Active areas on the data pages include the following:
- Text fields into which data may be entered using the keyboard
- Pull-downs from which one of several options may be chosen
- Check boxes in lists allow you to choose one or more items from the displayed list
- Radio buttons allow you to turn a parameter on or off
- Hyperlinks take you to other pages in the Cisco WCS user interface

Input fields are black text on a white background. When data is entered or selected, it is not sent to the controller, but it is saved in the field until the GO button is selected.
Administrative Tools

This area provides shortcuts to administration functions (such as logged in as, logout, refresh, and help) that are used on a regular basis when configuring a controller through the web user interface.
Configuring Security Solutions

This chapter describes security solutions for wireless LANs. It contains these sections:

- Using WCS to Convert a Cisco Unified Wireless Network Solution from Layer 3 to Layer 2 Mode, page 3-5
- Configuring a Firewall for WCS, page 3-6
- Access Point Authorization, page 3-6
- Management Frame Protection (MFP), page 3-7
- Configuring Intrusion Detection Systems (IDS), page 3-9
- Configuring IDS Signatures, page 3-9
- Enabling Web Login, page 3-17
- Certificate Signing Request (CSR) Generation, page 3-22
Cisco Unified Wireless Network Solution Security

The Cisco Unified Wireless Network Solution bundles potentially complicated Layer 1, Layer 2, and Layer 3 802.11 access point security components into a simple policy manager that customizes system-wide security policies on a per wireless LAN basis. It provides simple, unified, and systematic security management tools.

One of the challenges to wireless LAN deployment in the enterprise is wired equivalent privacy (WEP) encryption, which is a weak standalone encryption method. A more recent problem is the availability of low-cost access points that can be connected to the enterprise network and used to mount man-in-the-middle and denial-of-service attacks. Also, the complexity of add-on security solutions has prevented many IT managers from embracing the benefits of the latest advances in wireless LAN security.

Layer 1 Solutions

The Cisco Unified Wireless Network Solution operating system security solution ensures that all clients gain access within an operator-set number of attempts. Should a client fail to gain access within that limit, it is automatically excluded (blocked from access) until the operator-set timer expires. The operating system can also disable SSID broadcasts on a per wireless LAN basis.

Layer 2 Solutions

If a higher level of security and encryption is required, the network administrator can also implement industry-standard security solutions such as 802.1X dynamic keys with Extensible Authentication Protocol (EAP) or Wi-Fi Protected Access (WPA) dynamic keys. The Cisco Unified Wireless Network Solution WPA implementation includes Advanced Encryption Standard (AES), Temporal Key Integrity Protocol + message integrity code checksum (TKIP + Michael MIC) dynamic keys, or static WEP keys. Disabling is also used to automatically block Layer 2 access after an operator-set number of failed authentication attempts.

Regardless of the wireless security solution selected, all Layer 2 wired communications between controllers and access points are secured by passing data through Lightweight Access Point Protocol (LWAPP) tunnels.

Layer 3 Solutions

The WEP problem can be further solved using industry-standard Layer 3 security solutions such as virtual private networks (VPNs).

The Cisco Unified Wireless Network Solution supports local and RADIUS media access control (MAC) filtering. This filtering is best suited to smaller client groups with a known list of 802.11 access card MAC addresses. The Cisco Unified Wireless Network Solution also supports local and RADIUS user/password authentication. This authentication is best suited to small to medium client groups.
Single Point of Configuration Policy Manager Solutions

When the Cisco Unified Wireless Network Solution is equipped with WCS, you can configure system-wide security policies on a per wireless LAN basis. Small-office, home-office (SOHO) access points force you to individually configure security policies on each access point or use a third-party appliance to configure security policies across multiple access points. Because the Cisco Unified Wireless Network Solution security policies can be applied across the whole system from WCS, errors can be eliminated, and the overall effort is greatly reduced.

Rogue Access Point Solutions

This section describes security solutions for rogue access points.

Rogue Access Point Challenges

Rogue access points can disrupt wireless LAN operations by hijacking legitimate clients and using plain text or other denial-of-service or man-in-the-middle attacks. That is, a hacker can use a rogue access point to capture sensitive information, such as passwords and usernames. The hacker can then transmit a series of clear-to-send (CTS) frames, which mimics an access point informing a particular wireless LAN client adapter to transmit and instructing all others to wait. This scenario results in legitimate clients being unable to access the wireless LAN resources. Thus, wireless LAN service providers have a strong interest in banning rogue access points from the air space.

The operating system security solution uses the radio resource management (RRM) function to continuously monitor all nearby access points, automatically discover rogue access points, and locate them as described in the “Tagging and Containing Rogue Access Points” section.

Tagging and Containing Rogue Access Points

When the Cisco Unified Wireless Network Solution is monitored using WCS, WCS generates the flags as rogue access point traps and displays the known rogue access points by MAC address. The operator can then display a map showing the location of the access points closest to each rogue access point. The next step is to mark them as Known or Acknowledged rogue access points (no further action), Alert rogue access points (watch for and notify when active), or Contained rogue access points (have between one and four access points discourage rogue access point clients by sending the clients deauthenticate and disassociate messages whenever they associate with the rogue access point).

Rogue Management

WCS rogue management includes rogue access points and rogue adhocs. You can click the Security tab from the WCS Home window to see the most recent rogue adhocs.

Most Recent Rogue Adhocs

The Most Recent Rogue Adhocs section displays the rogue adhoc MAC address, SSID, state, and date and time of initial detection.
Note

The Rogue Adhoc state displays as *Alert* when first scanned by the controller or as *Pending* when operating system identification is underway.

---

### Step 1
Click the **MAC Address** of a specific rogue adhoc to view its associated alarm details.

### Step 2
To modify the alarm, choose one of the following commands from the Select a command drop-down menu and click **GO**.

- **Assign to me**—Assigns the selected alarm to the current user.
- **Unassign**—Unassigns the selected alarm.
- **Delete**—Deletes the selected alarm.
- **Clear**—Clears the selected alarm.
- **Acknowledge**—Allows you to designate the alarm as acknowledged.

**Note**
If you mark the alarm as acknowledged, it does not show in the Alarm Summary window.

- **Unacknowledge**—Changes the acknowledged alarm back to unacknowledged.
- **Event History**—Enables you to view events for the rogue adhoc alarm.

**Note**
Event History for this adhoc can also be accessed from the Most Recent Rogue Adhocs details page.

- **Detecting APs**—Enables you to view the access points that are currently detecting the rogue adhoc.
- **Map (High Resolution)**—Displays the current calculated rogue adhoc location on the Maps > **Building Name** > **Floor Name** page.
- **Rogue Clients**—Enables you to view the clients associated with this rogue adhoc.
- **Set State to ‘Unknown - Alert’**—Tags the rogue adhoc as the lowest threat, continues to monitor the rogue adhoc, and turns off containment.
- **Set State to ‘Known - Internal’**—Tags the rogue adhoc as internal, adds it to the known rogue adhoc list, and turns off containment.
- **Set State to ‘Known - External’**—Tags the rogue adhoc as external, adds it to the known rogue adhoc list, and turns off containment.
- **1 AP Containment through 4 AP Containment**—Indicates the number of access points (1-4) in the vicinity of the rogue unit that send deauthenticate and disassociate messages to the client devices that are associated to the rogue unit.

---

### Integrated Security Solutions

The Cisco Unified Wireless Network Solution also provides these integrated security solutions:

- **Cisco Unified Wireless Network Solution operating system security** is built around a robust 802.1X authorization, authentication, and accounting (AAA) engine, which enables operators to rapidly configure and enforce a variety of security policies across the Cisco Unified Wireless Network Solution.
Follow these steps to convert a Cisco Unified Wireless Network Solution from Layer 3 to Layer 2 LWAPP transport mode using the WCS user interface.

**Note**
IOS-based lightweight access points do not support Layer 2 LWAPP mode. These access points can only be run with Layer 3.

**Note**
This procedure causes your access points to go offline until the controller reboots and the associated access points reassociate to the controller.

**Step 1**
Make sure that all controllers and access points are on the same subnet.

**Note**
You must configure the controllers and associated access points to operate in Layer 2 mode before completing the conversion.

**Step 2**
Log into the WCS user interface. Then follow these steps to change the LWAPP transport mode from Layer 3 to Layer 2:

a. Click **Configure > Controllers** to navigate to the All Controllers page.

b. Click the desired controller’s IP address to display the **IP Address > Controller Properties** page.

c. In the sidebar, click **System > General** to display the **IP Address > General** page.

d. Change LWAPP transport mode to **Layer2** and click **Save**.

e. If WCS displays the following message, click **OK**:  

Please reboot the system for the LWAPP Mode change to take effect.

**Step 3**
Follow these steps to restart your Cisco Unified Wireless Network Solution:

a. Return to the *IP Address* > Controller Properties page.

b. Click **System > Commands** to display the *IP Address* > Controller Commands page.

c. Under Administrative Commands, choose **Save Config To Flash** and click **GO** to save the changed configuration to the controller.

d. Click **OK** to continue.

e. Under Administrative Commands, choose **Reboot** and click **GO** to reboot the controller.

f. Click **OK** to confirm the save and reboot.

**Step 4**
After the controller reboots, follow these steps to verify that the LWAPP transport mode is now Layer 2:

a. Click **Monitor > Devices > Controllers** to navigate to the Controllers > Search Results page.

b. Click the desired controller’s IP address to display the Controllers > *IP Address* > Summary page.

c. Under General, verify that the current LWAPP transport mode is Layer2.

You have completed the LWAPP transport mode conversion from Layer 3 to Layer 2. The operating system software now controls all communications between controllers and access points on the same subnet.

---

**Configuring a Firewall for WCS**

When a WCS server and a WCS user interface are on different sides of a firewall, they cannot communicate unless the following ports on the firewall are open to two-way traffic:

- 80 (for initial http)
- 69 (tftp)
- 162 (trap port)
- 443 (https)

Open these ports to configure your firewall to allow communications between a WCS server and a WCS user interface.

---

**Access Point Authorization**

You can view a list of authorized access points along with the type of certificate that an access point uses for authorization.

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click one of the URLs in the IP address column.

**Step 3** From the left sidebar menu, choose **Security > AP Authorization**.
Step 4  The AP Policies portion of the window indicates whether the authorization of access points is enabled or disabled. It also indicates whether the acceptance of self-signed certificates (SSC APs) is enabled or disabled. Normally, access points can be authorized either by AAA or certificates. (SSC is only available for 4400 and 200 controllers.)

To change these values, choose **Edit AP Policies** from the Select a command drop-down menu and click **GO**.

Step 5  The AP Authorization List portion shows the radio MAC address of the access point, certificate type, and key hash. To add a different authorization entry, choose **Add AP Auth Entry** from the Select a command drop-down menu and click **GO**.

Step 6  From the drop-down menu, choose a template to apply to this controller and click **Apply**. To create a new template for access point authorization, click the **click here** to get redirected to the template creation page. Refer to the “Configuring an Access Point or LBS Authorization” section on page 10-39 for steps on creating a new template.

---

### Management Frame Protection (MFP)

Management Frame Protection (MFP) provides security for the otherwise unprotected and unencrypted 802.11 management messages passed between access points and clients. MFP provides both infrastructure and client support. WCS software release 4.1 and later supports both infrastructure and client MFP while WCS software release 4.0 supports only infrastructure MFP.

- **Infrastructure MFP**—Protects management frames by detecting adversaries who are invoking denial of service attacks, flooding the network with associations and probes, interjecting as rogue access points, and affecting network performance by attacking the QoS and radio measurement frames. It also provides a quick and effective means to detect and report phishing incidents.

Specifically, infrastructure MFP protects 802.11 session management functions by adding message integrity check information elements (MIC IEs) to the management frame emitted by access points (and not those emitted by clients), which are then validated by other access points in the network. Infrastructure MFP is passive. It can detect and report intrusions but has no means to stop them.

- **Client MFP**—Shields authenticated clients from spoofed frames, preventing many of the common attacks against wireless LANs from becoming effective. Most attacks, such as deauthentication attacks, revert to simply degrading performance by contending with valid clients.

Specifically, client MFP encrypts management frames sent between access points and Cisco Compatible Extension clients so that both access points and clients can take preventive action by dropping spoofed class 3 management frames (that is, management frames passed between an access point and a client that is authenticated and associated). Client MFP leverages the security mechanisms defined by IEEE 802.11i to protect the following types of class 3 unicast management frames: disassociation, deauthentication, and QoS (WMM) action. Client MFP is active. It can protect a client-access point session from the most common type of denial-of-service attack. It protects class 3 management frames by using the same encryption method used for the session’s data frames. If a frame received by the access point or client fails decryption, it is dropped, and the event is reported to the controller.

To use client MFP, clients must support Cisco Compatible Extensions (version 5) MFP and must negotiate WPA2 using either TKIP or AES-CCMP. EAP or PSK may be used to obtain the PMK. CCKM and controller mobility management are used to distribute session keys between access points or Layer 2 and Layer 3 fast roaming.
To prevent attacks against broadcast frames, access points supporting Cisco Compatible Extensions (version 5) do not emit any broadcast class 3 management frames (such as disassociation, deauthentication, or action). Compatible extensions clients (version 5) and access points must discard broadcast class 3 management frames.

Client MFP supplements infrastructure MFP rather than replacing it because infrastructure MFP continues to detect and report invalid unicast frames sent to clients that are not client-MFP capable, as well as invalid class 1 and 2 management frames. Infrastructure MFP is applied only to management frames that are not protected by client MFP.

Infrastructure MFP consists of three main components:

- **Management frame protection**—The access point protects the management frames it transmits by adding a MIC IE to each frame. Any attempt to copy, alter, or replay the frame invalidates the MIC, causing any receiving access point configured to detect MFP frames to report the discrepancy.

- **Management frame validation**—In infrastructure MFP, the access point validates every management frame it receives from other access points in the network. It ensures that the MC IE is present (when the originator is configured to transmit MFP frames) and matches the content of the management frame. If it receives any frame that does not contain a valid MIC IE from a BSSID belonging to an access point that is configured to transmit MFP frames, it reports the discrepancy to the network management system. In order for the timestamps to operate properly, all controllers must be Network Transfer Protocol (NTP) synchronized.

- **Event reporting**—The access point notifies the controller when it detects an anomaly, and the controller aggregates the received anomaly events and reports the results through SNMP traps to the network management system.

**Guidelines for Using MFP**

Follow these guidelines for using MFP:

- MFP is supported for use with Cisco Aironet lightweight access points, except for the 1500 series mesh access points.

- Lightweight access points support infrastructure MFP in local and monitor modes and in REAP and hybrid-REAP modes when the access point is connected to a controller. They support client MFP in local, hybrid-REAP, and bridge modes.

- Client MFP is supported for use only with Cisco Compatible Extensions (version 5) clients using WPA2 with TKIP or AES-CCMP.

- Non-Cisco Compatible Extensions (version 5) clients may associate to a WLAN if client MFP is disabled or optional.
Configuring Intrusion Detection Systems (IDS)

The Cisco intrusion detection system/intrusion protection system (CIDS/IPS) instructs controllers to block certain clients from accessing the wireless network when attacks involving these clients are detected. This system offers significant network protection by helping to detect, classify, and stop threats including worms, spyware/adware, network viruses, and application abuse. Two methods are available to detect IDS attacks:

- IDS sensors (for Layer 3)
- IDS signatures (for Layer 2)

Viewing IDS Sensors

When the sensors identify an attack, they alert the controller to shun the offending client. When you add a new IDS sensor, you register the controller with that IDS sensor so that the sensor can send shunned client reports to the controller. The controller also polls the sensor periodically.

Follow these steps to view IDS sensors.

**Step 1** Choose Configure > Controllers.
**Step 2** Choose a controller by clicking on an IP address.
**Step 3** From the left sidebar menu, choose Security > IDS Sensor Lists. The IDS Sensor window appears. This page lists all of the IDS sensors that have been configured for this controller.

Configuring IDS Signatures

You can configure *IDS signatures*, or bit-pattern matching rules used to identify various types of attacks in incoming 802.11 packets, on the controller. When the signatures are enabled, the access points joined to the controller perform signature analysis on the received 802.11 data or management frames and report any discrepancies to the controller. If an attack is detected, an appropriate mitigation action is initiated.

Cisco supports 17 standard signatures on the controller as shown on the Standard Signatures and Custom Signatures page (see Figure 3-1).
These signatures are divided into six main groups. The first four groups contain management signatures, and the last two groups contain data signatures:

- **Broadcast deauthentication frame signatures**—During a broadcast deauthentication frame attack, a hacker sends an 802.11 deauthentication frame to the broadcast MAC destination address of another client. This attack causes the destination client to disassociate from the access point and lose its connection. If this action is repeated, the client experiences a denial of service. When the broadcast deauthentication frame signature (precedence 1) is used to detect such an attack, the access point listens for clients transmitting broadcast deauthentication frames that match the characteristics of the signature. If the access point detects such an attack, it alerts the controller. Depending on how your system is configured, the offending device is contained so that its signals no longer interfere with authorized clients, or the controller forwards an immediate alert to the system administrator for further action, or both.

- **NULL probe response signatures**—During a NULL probe response attack, a hacker sends a NULL probe response to a wireless client adapter. As a result, the client adapter locks up. When a NULL probe response signature is used to detect such an attack, the access point identifies the wireless client and alerts the controller. The NULL probe response signatures include:
  - NULL probe resp 1 (precedence 2)
  - NULL probe resp 2 (precedence 3)

- **Management frame flood signatures**—During a management frame flood attack, a hacker floods an access point with 802.11 management frames. The result is a denial of service to all clients associated or attempting to associate to the access point. This attack can be implemented with different types of management frames: association requests, authentication requests, reassociation requests, probe requests, disassociation requests, deauthentication requests, and reserved management subtypes.

  When a management frame flood signature is used to detect such an attack, the access point identifies management frames matching the entire characteristics of the signature. If the frequency of these frames is greater than the value of the frequency set in the signature, an access point that hears these frames triggers an alarm. The controller generates a trap and forwards it to WCS.
The management frame flood signatures include:

- Assoc flood (precedence 4)
- Auth flood (precedence 5)
- Reassoc flood (precedence 6)
- Broadcast probe flood (precedence 7)
- Disassoc flood (precedence 8)
- Deauth flood (precedence 9)
- Reserved mgmt 7 (precedence 10)
- Reserved mgmt F (precedence 11)

The reserved management frame signatures 7 and F are reserved for future use.

- Wellenreiter signature—Wellenreiter is a wireless LAN scanning and discovery utility that can reveal access point and client information. When the Wellenreiter signature (precedence 17) is used to detect such an attack, the access point identifies the offending device and alerts the controller.

- EAPOL flood signature—During an EAPOL flood attack, a hacker floods the air with EAPOL frames containing 802.1X authentication requests. As a result, the 802.1X authentication server cannot respond to all of the requests and fails to send successful authentication responses to valid clients. The result is a denial of service to all affected clients. When the EAPOL flood signature (precedence 12) is used to detect such an attack, the access point waits until the maximum number of allowed EAPOL packets is exceeded. It then alerts the controller and proceeds with the appropriate mitigation.

- NetStumbler signatures—NetStumbler is a wireless LAN scanning utility that reports access point broadcast information (such as operating channel, RSSI information, adapter manufacturer name, SSID, WEP status, and the latitude and longitude of the device running NetStumbler when a GPS is attached). If NetStumbler succeeds in authenticating and associating to an access point, it sends a data frame with the following strings, depending on the NetStumbler version:

  
  | Table 3-1 NetStumbler Versions |
  | --- | --- |
  | Version | String |
  | 3.2.0 | “Flurbler gronk bloopt, bnip Frundletrune” |
  | 3.2.3 | “All your 802.11b are belong to us” |
  | 3.3.0 | Sends white spaces |

When a NetStumbler signature is used to detect such an attack, the access point identifies the offending device and alerts the controller. The NetStumbler signatures include:

- NetStumbler 3.2.0 (precedence 13)
- NetStumbler 3.2.3 (precedence 14)
- NetStumbler 3.3.0 (precedence 15)
- NetStumbler generic (precedence 16)

Follow these instructions to configure signatures:

- **Uploading IDS Signatures, page 3-12**
- **Downloading IDS Signatures, page 3-13**
Follow these steps to upload IDS signatures from the controller.

**Step 1** Obtain a signature file from Cisco (hereafter called a *standard signature file*). You can also create your own signature file (hereafter called a *custom signature file*) by following the “Downloading IDS Signatures” section on page 3-13.

**Step 2** Make sure you have a Trivial File Transfer Protocol (TFTP) server available for the signature download. Keep these guidelines in mind when setting up a TFTP server:
- If you are downloading through the service port, the TFTP server must be on the same subnet as the service port because the service port is not routable.
- If you are downloading through the distribution system network port, the TFTP server can be on the same or a different subnet because the distribution system port is routable.
- A third-party TFTP server cannot run on the same computer as the Cisco WCS because WCS’s built-in TFTP server and third-party TFTP server use the same communication port.

**Step 3** Choose *Configure > Controllers*.

**Step 4** Choose a controller by clicking on an IP address.

**Step 5** From the left sidebar menu, choose *Security* and then *Standard Signatures* or *Custom Signatures*.

**Step 6** From the Select a command drop-down menu, choose *Upload Signature Files from Controller*. Figure 3-2 shows the window that appears.
Figure 3-2  Uploading Signature File

Step 7  Specify the TFTP server name being used for the transfer.

Step 8  If the TFTP server is new, enter the TFTP IP address at the Server IP Address parameter.

Step 9  Choose Signature Files from the File Type drop-down menu.

Step 10  The signature files are uploaded to the root directory which was configured for use by the TFTP server. You can change to a different directory at the Upload to File parameter (this parameter only shows if the Server Name is the default server). The controller uses this local file name as a base name and then adds _std.sig as a suffix for standard signature files and _custom.sig as a suffix for custom signature files.

Step 11  Click OK.

Downloading IDS Signatures

If the standard signature file is already on the controller but you want to download customized signatures to it, follow these steps.

Step 1  Choose Configure > Controllers.

Step 2  Choose a controller by clicking on an IP address.

Step 3  Choose System > Commands.

Step 4  From the Upload/Download Commands drop-down menu, choose Download IDS Signatures and click GO.

Step 5  Copy the signature file (*.sig) to the default directory on your TFTP server.

Step 6  Choose local machine from the File is Located On parameter. If you know the filename and path relative to the server’s root directory, you can also choose TFTP server.
Step 7  Enter the maximum number of times the controller should attempt to download the signature file in the Maximum Retries parameter.

Step 8  Enter the maximum amount of time in seconds before the controller times out while attempting to download the signature file in the Timeout parameter.

Step 9  The signature files are uploaded to the c:tftp directory. Specify the local file name in that directory or use the Browse button to navigate to it. A "revision" line in the signature file specifies whether the file is a Cisco-provided standard signature file or a site-tailored custom signature file (custom signature files must always have revision=custom).

Step 10  If the transfer times out for some reason, you can simply choose the TFTP server option in the File Is Located On parameter, and the Server File Name will be populated for you and retried. The local machine option initiates a two-step operation. First, the local file is copied from the administrator’s workstation to WCS’s own built-in TFTP server. Then the controller retrieves that file. For later operations, the file is already in the WCS server’s TFTP directory, and the download web page now automatically populates the filename.

Step 11  Click OK.

---

**Enabling or Disabling IDS Signatures**

Follow these steps to enable or disable IDS signature.

---

Step 1  Choose **Configure > Controllers**.

Step 2  Choose a controller by clicking on an IP address.

Step 3  From the left sidebar menu, choose **Security** and then **Standard Signatures** or **Custom Signatures**. **Figure 3-3** shows a sample of the screen that appears.
To enable or disable an individual signature, click in the Name column for the type of attack you want to enable or disable. Figure 3-4 shows a sample of a detailed signature screen.

The Standard Signature Parameters window shows the list of Cisco-supplied signatures that are currently on the controller. The Custom Signatures window shows the list of customer-supplied signatures that are currently on the controller. The following information is displayed either on the signature window or the detailed signature window:

- **Precedence** - The order, or precedence, in which the controller performs the signature checks.
- **Name** - The type of attack the signature is trying to detect.
- **Description** - A more detailed description of the type of attack that the signature is trying to detect.
- **Frame Type** - Management or data frame type on which the signature is looking for a security attack.
- **Action** - What the controller is directed to do when the signature detects an attack. One possibility is None, where no action is taken, and another is Report, to report the detection.
- **Frequency** - The signature frequency, or the number of matching packets per interval that must be identified at the detecting access point level before an attack is detected. The range is 1 to 32,000 packets per interval, and the default value is 50 packets per interval.
- **Quiet Time** - The length of time (in seconds) after which no attacks have been detected at the individual access point level, and the alarm can stop. This time appears only if the MAC information is all or both. The range is 60 to 32,000 seconds, and the default value is 300 seconds.
- **MAC Information** - Whether the signature is to be tracked per network or per MAC address or both at the detecting access point level.
- **MAC Frequency** - The signature MAC frequency, or the number of matching packets per interval that must be identified at the controller level before an attack is detected. The range is 1 to 32,000 packets per interval, and the default value is 30 packets per interval.
- Interval - Enter the number of seconds that must elapse before the signature frequency threshold is reached within the configured interval. The range is 1 to 3600 seconds, and the default value is 1 second.
- Enable - Check this to enable this signature to detect security attacks or uncheck it to disable this signature.
- Signature Patterns - The pattern that is being used to detect a security attack.

**Figure 3-4 Standard Signature**

<table>
<thead>
<tr>
<th>Wireless Control System</th>
<th>172.19.20.30 &gt; Standard Signature</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Precedence: 4</td>
</tr>
<tr>
<td></td>
<td>Name: Assoc Flood</td>
</tr>
<tr>
<td></td>
<td>Description: Association Request Flood</td>
</tr>
<tr>
<td></td>
<td>Frame Type: Management</td>
</tr>
<tr>
<td></td>
<td>Action: Report</td>
</tr>
<tr>
<td></td>
<td>Frequency (pkts/sec): 10</td>
</tr>
<tr>
<td></td>
<td>Quiet Time (sec): 90</td>
</tr>
<tr>
<td></td>
<td>MAC Information: Eth</td>
</tr>
<tr>
<td></td>
<td>MAC Frequency (pkts/sec): 10</td>
</tr>
<tr>
<td></td>
<td>Interval: 0</td>
</tr>
<tr>
<td></td>
<td>Enable: Yes</td>
</tr>
</tbody>
</table>

**Step 5** In the Enable yes or no drop-down menu, choose **yes**. Because you are downloading a customized signature, you should enable the files named with the _custom.sgi and disable the standard signature with the same name but differing suffix. (For example, if you are customizing broadcast probe flood, you want to disable broadcast probe flood in the standard signatures but enable it in custom signatures.)

**Step 6** To enable all standard and custom signatures currently on the controller, choose **Edit Signature Parameters** (from the screen in **Figure 3-3**) from the Select a command drop-down list and click **GO**. The Global Settings for Standard and Custom Signature window appears (see **Figure 3-5**).
Enabling Web Login

With web authentication, guests are automatically redirected to web authentication pages when they launch their browsers. Guests gain access to the WLAN through this web portal. Wireless LAN administrators using this authentication mechanism should have the option of providing unencrypted or encrypted guest access. Guest users can then log into the wireless network using a valid username and password, which is encrypted with SSL. Web authentication accounts may be created locally or managed...
Enabling Web Login

by a RADIUS server. The Cisco Wireless LAN controllers can be configured to support a web authentication client. See the “Configuring a Web Authentication Template” section on page 10-51 to create a template that replaces the Web authentication page provided on the controller.

Step 1  Choose Configure > Controller.
Step 2  Choose the controller on which to enable web authentication by clicking an IP address URL in the IP Address column.
Step 3  From the left sidebar menu, choose Security > Web Auth Configuration.
Step 4  Choose the appropriate web authentication type from the drop-down menu. The choices are default internal, customized web authentication, or external.
   • If you choose default internal, you can still alter the page title, message, and redirect URL, as well as choose whether the logo appears. Continue to Step 5.
   • If you choose customized web authentication, skip to the “Downloading Customized Web Authentication” section on page 3-18.
   • If you choose external, you need to enter the URL you want to redirect to after a successful authentication. For example, if the value entered for this field is http://www.company.com, the user is directed to the company home page.
Step 5  Click the Logo Display check box if you want your company logo to display.
Step 6  Enter the title you want displayed on the Web authentication page.
Step 7  Enter the message you want displayed on the Web authentication page.
Step 8  Provide the URL where the user is redirected after a successful authentication. For example, if the value entered for this field is http://www.company.com, the user is directed to the company home page.
Step 9  Click Save.

Downloading Customized Web Authentication

Follow these steps if you chose the customized web authentication option in Step 4 of the previous section. You can download a customized Web authentication page to the controller. A customized web page is created to establish a username and password for user web access.

When downloading customized web authentication, these strict guidelines must be followed:
   • A username must be provided.
   • A password must be provided.
   • A redirect URL must be retained as a hidden input item after extracting from the original URL.
   • The action URL must be extracted and set from the original URL.
   • Scripts to decode the return status code must be included.
   • All paths used in the main page should be of relative type.

Before downloading, the following steps are required:

Step 1  Click on the preview image to download the sample login.html bundle file from the server. See Figure 3-6 for an example of the login.html file. The downloaded bundle is a .TAR file.
Enabling Web Login

**Step 2**
Open and edit the login.html file and save it as a .tar or .zip file.

**Note**
You can edit the text of the Submit button with any text or HTML editor to read “Accept terms and conditions and Submit.”

**Step 3**
Make sure you have a Trivial File Transfer Protocol (TFTP) server available for the download. Keep these guidelines in mind when setting up a TFTP server:

- If you are downloading through the service port, the TFTP server must be on the same subnet as the service port because the service port is not routable.
- If you are downloading through the distribution system network port, the TFTP server can be on the same or a different subnet because the distribution system port is routable.
- A third-party TFTP server cannot run on the same computer as the Cisco WCS because WCS’s built-in TFTP server and third-party TFTP server use the same communication port.

**Step 4**
Click here in the “After editing the HTML you may click here to redirect to the Download Web Auth Page” link to download the .tar or .zip file to the controller(s). The Download Customized Web Auth Bundle to Controller window appears (see Figure 3-7).
**Enabling Web Login**

**Figure 3-7** *Download Customized Web Auth Bundle to Controller*

![Diagram of Wireless Control System with options for configuring security solutions.](image)

---

**Note**

The IP address of the controller to receive the bundle and the current status are displayed.

**Step 5**

Choose *local machine* from the File is Located On parameter. If you know the filename and path relative to the server’s root directory, you can also choose TFTP server.

**Note**

For a local machine download, either .zip or .tar file options exists, but the WCS does the conversion of .zip to .tar automatically. If you chose a TFTP server download, only .tar files are specified.

**Step 6**

Enter the maximum amount of time in seconds before the controller times out while attempting to download the file in the Timeout parameter.

**Step 7**

The WCS Server Files In parameter specifies where the WCS server files are located. Specify the local file name in that directory or use the Browse button to navigate to it. A “revision” line in the signature file specifies whether the file is a Cisco-provided standard signature file or a site-tailored custom signature file (custom signature files must always have revision=custom).

**Step 8**

If the transfer times out for some reason, you can simply choose the TFTP server option in the File Is Located On parameter, and the Server File Name is populated. The local machine option initiates a two-step operation. First, the local file is copied from the administrator’s workstation to the WCS’s own built-in TFTP server. Then the controller retrieves that file. For later operations, the file is already in the WCS server’s TFTP directory, and the download web page now automatically populates the filename.

**Step 9**

Click **OK**.

If the transfer times out for some reason, you can simply choose the TFTP server option in the File Is Located On parameter, and the Server File Name is populated for you.
Step 10  After completing the download, you are directed to the new page and able to authenticate.

Connecting to the Guest WLAN

Follow these steps to connect to the guest central WLAN to complete the web authentication process. See the “Creating Guest User Accounts” section on page 7-12 for more explanation of a guest user account.

Step 1  When you are set for open authentication and are connected, browse to the virtual interface IP address (such as /1.1.1.1/login.html).

Step 2  When the WCS user interface displays the Login window, enter your username and password.

Note  All entries are case sensitive.

The lobby ambassador has access to the templates only to add guest users.

Step 3  Click Submit to log into WCS. The WCS user interface is now active and available for use. The Guest Users Templates page is displayed. This page provides a summary of all created Guest User templates.

Note  To exit the WCS user interface, close the browser window or click Logout in the upper right corner of the page. Exiting a WCS user interface session does not shut down WCS on the server.

Note  When a system administrator stops the WCS server during your WCS session, your session ends, and the web browser displays this message: “The page cannot be displayed.” Your session does not reassociate to WCS when the server restarts. You must restart the WCS session.

Deleting a Guest User

Follow these steps to delete all clients stations that are logged in and using the guest WLAN and its account’s username.

Step 1  Choose Configure > Controller Templates.

Step 2  From the left sidebar menu, choose Security > Guest Users.

Step 3  Click the check box before the username you want to delete. WCS gives you a warning message before deletion.

Step 4  From the Select a command drop-down menu, choose Delete Templates. The window displays remove results if the deletion was successful.
Certificate Signing Request (CSR) Generation

To generate a Certificate Signing Request (CSR) for a third-party certificate using WCS, refer to the following document for instructions on uploading the certificate:

Note

The controller can also send notification when a guest account has expired by invoking a trap. WCS processes this trap and deletes the guest user account from the configuration of that controller.
Performing System Tasks

This chapter describes how to use WCS to perform system-level tasks. It contains these sections:

- Adding System Components to the WCS Database, page 4-2
- Using WCS to Update System Software, page 4-4
- Downloading Vendor Device Certificates, page 4-5
- Downloading Vendor CA Certificates, page 4-5
- Using WCS to Enable Long Preambles for SpectraLink NetLink Phones, page 4-6
- Creating an RF Calibration Model, page 4-7
Adding System Components to the WCS Database

This section describes how to add a controller and a location appliance to the WCS database.

Adding a Controller to the WCS Database

Follow these steps to add a controller to the WCS database.

Note Cisco recommends that you manage controllers through the controller dedicated service port for improved security. However, when you manage controllers that do not have a service port (such as 2000 series controllers) or for which the service port is disabled, you must manage those controllers through the controller management interface.

Step 1 Log into the WCS user interface.
Step 2 Click Configure > Controllers to display the All Controllers page.
Step 3 From the Select a command drop-down menu, choose Add Controller and click GO.
Step 4 On the Add Controller page, enter the controller IP address, network mask, and required SNMP settings.
Step 5 Click OK. WCS displays a Please Wait dialog box while it contacts the controller and adds the current controller configuration to the WCS database. It then returns you to the Add Controller page.
Step 6 If WCS does not find a controller at the IP address that you entered for the controller, the Discovery Status dialog displays this message:

No response from device, check SNMP.

Check these settings to correct the problem:

- The controller service port IP address might be set incorrectly. Check the service port setting on the controller.
- WCS might not have been able to contact the controller. Make sure that you can ping the controller from the WCS server.
- The SNMP settings on the controller might not match the SNMP settings that you entered in WCS. Make sure that the SNMP settings configured on the controller match the settings that you entered in WCS.

Step 7 Add additional controllers if desired.

Adding a Location Appliance to the WCS Database

To add a location appliance to the WCS database, follow the instructions in the Cisco Location Appliance Configuration Guide. It provides documentation on the Location > Location Server option within WCS and all of its capabilities (such as editing general properties, tracking, filtering, history, advanced, and NMSP parameters). WCS without the use of the location appliance supports on-demand or query-based location. This version visually displays a single device's location at a time, placing each single device on the floor map associated with the floor it is on. Location determination using this version of WCS with location is captured in Figure 4-1 where the blue icon is the only visual presented of a Wi-Fi client device.
**Additional Functionality with Location Appliance**

Cisco 2700 series location appliances operate within the Cisco Wireless LAN Solution infrastructure. Location appliances compute, collect, and store historical location data using Cisco wireless LAN controllers and access points to track the physical location of wireless devices.

The location appliance can track up to 2,500 elements. You can track the following elements: client stations, active asset tags, rogue clients and access points. Updates on the locations of elements being tracked are provided to the location server from the Cisco wireless LAN controller.

Only those elements designated for tracking by the controller are viewable in Cisco WCS maps, queries, and reports. No events and alarms are collected for non-tracked elements, and they are not used in calculating the 2,500 element limit.

You can modify the following tracking parameters using Cisco WCS:

- Enable and disable which element locations (client stations, active asset tags, and rogue clients and access points) you actively track
- Set limits on how many of a specific element you want to track
You can set limits on how many of a specific element you wish to track. For example, given a limit of 2,500 trackable units, you could set a limit to track only 1,500 client stations. Once the tracking limit is met, the number of elements not being tracked is summarized on the Tracking Parameters page.

- Disable tracking and reporting of ad hoc rogue clients and access points

**Note**  Even though all clients are loaded in the map, the display has a limit of 250 clients per floor to prevent overcrowding. You can do an advanced search of the map to see the items of interest.

Selectable filters enable you to search collected data and display specific elements on a map. For example, a biomedical user may want to display only active RFID tags that are tracking key medical equipment rather than access points or clients for a given floor.

### Using WCS to Update System Software

Follow these steps to update controller (and access point) software using WCS.

**Step 1** Enter `ping ip-address` to be sure that the WCS server can contact the controller. If you use an external TFTP server, enter `ping ip-address` to be sure that the WCS server can contact the TFTP server.

**Note** When you are downloading through a controller distribution system (DS) network port, the TFTP server can be on the same or a different subnet because the DS port is routable.

**Step 2** Click the **Configure > Controllers** to navigate to the All Controllers page.

**Step 3** Check the check box of the desired controller, choose **Download Software** from the Select a Command drop-down menu, and click **GO**. WCS displays the Download Software to Controller page.

**Step 4** If you use the built-in WCS TFTP server, check the **TFTP Server on WCS System** check box. If you use an external TFTP server, uncheck this check box and add the external TFTP server IP address.

**Step 5** Click **Browse** and navigate to the software update file (for example, AS_2000_release.aes for 2000 series controllers). The files are uploaded to the root directory which was configured for use by the TFTP server. You can change to a different directory.

**Note** Be sure that you have the correct software file for your controller.

**Step 6** Click **Download**. WCS downloads the software to the controller, and the controller writes the code to flash RAM. As WCS performs this function, it displays its progress in the Status field.
Downloading Vendor Device Certificates

Each wireless device (controller, access point, and client) has its own device certificates. For example, the controller is shipped with a Cisco-installed device certificate. This certificate is used by EAP-TLS and EAP-FAST (when not using PACs) to authenticate wireless clients during local EAP authentication. However, if you wish to use your own vendor-specific device certificate, it must be downloaded to the controller.

Follow the instructions below to download a vendor-specific device certificate to the controller.

---

**Step 1** Choose Configure > Controller.

**Step 2** You can download the certificates in one of two ways:

- a. Click the check box of the controller you choose.
- b. Choose Download Vendor Device Certificate from the Select a command drop-down menu and click GO.

or

- a. Click the URL of the desired controller in the IP Address column.
- b. Choose System > Commands from the left sidebar menu.
- c. Choose Download Vendor Device Certificate from the Upload/Download Commands drop-down menu and click GO.

**Step 3** In the Certificate Password field, enter the password which was used to protect the certificate.

**Step 4** Specify if the certificate to download is on the TFTP server or on the local machine. If it is on the TFTP server, the name must be supplied in the Server File Name parameter in Step 10. If the certificate is on the local machine, you must specify the file path in the Local File Name parameter in Step 9 using the Browse button.

**Step 5** Enter the TFTP server name in the Server Name parameter. The default is for the WCS server to act as the TFTP server.

**Step 6** Enter the server IP address.

**Step 7** In the Maximum Retries field, enter the maximum number of times that the TFTP server attempts to download the certificate.

**Step 8** In the Timeout field, enter the amount of time (in seconds) that the TFTP server attempts to download the certificate.

**Step 9** In the Local File Name field, enter the directory path of the certificate.

**Step 10** In the Server File Name field, enter the name of the certificate.

**Step 11** Click OK.

---

Downloading Vendor CA Certificates

Controllers and access points have a Certificate Authority (CA) certificate that is used to sign and validate device certificates. The controller is shipped with a Cisco-installed CA certificate. This certificate may be used by EAP-TLS and EAP-FAST (when not using PACs) to authenticate wireless
clients during local EAP authentication. However, if you wish to use your own vendor-specific CA certificate, it must be downloaded to the controller. Follow the instructions in this section to download vendor CA certificate to the controller.

**Step 1** Click **Configure > Controllers**.

**Step 2** You can download the certificates in one of two ways:

a. Click the check box of the controller you choose.

b. Choose **Download Vendor CA Certificate** from the Select a command drop-down menu and click **GO**.

or

a. Click the URL of the desired controller in the IP Address column.

b. Choose **System > Commands** from the left sidebar menu.

c. Choose **Download Vendor CA Certificate** from the Upload/Download Commands drop-down menu and click **GO**.

**Step 3** Specify if the certificate to download is on the TFTP server or on the local machine. If it is on the TFTP server, the name must be supplied in the Server File Name parameter in Step 9. If the certificate is on the local machine, you must specify the file path in the Local File Name parameter in Step 8 using the Browse button.

**Step 4** Enter the TFTP server name in the Server Name parameter. The default is for the WCS server to act as the TFTP server.

**Step 5** Enter the server IP address.

**Step 6** In the Maximum Retries field, enter the maximum number of times that the TFTP server attempts to download the certificate.

**Step 7** In the Timeout field, enter the amount of time (in seconds) that the TFTP server attempts to download the certificate.

**Step 8** In the Local File Name field, enter the directory path of the certificate.

**Step 9** In the Server File Name field, enter the name of the certificate.

**Step 10** Click **OK**.

---

**Using WCS to Enable Long Preambles for SpectraLink NetLink Phones**

A radio preamble (sometimes called a *header*) is a section of data at the head of a packet. It contains information that wireless devices need when sending and receiving packets. Short preambles improve throughput performance, so they are enabled by default. However, some wireless devices, such as SpectraLink NetLink phones, require long preambles.

To optimize the operation of SpectraLink NetLink phones on your wireless LAN, follow these steps to use WCS to enable long preambles.

**Step 1** Log into the WCS user interface.

**Step 2** Click **Configure > Controllers** to navigate to the All Controllers page.
Step 3 Click the IP address of the desired controller.

Step 4 In the sidebar, click 802.11b/g/n > Parameters.

Step 5 If the IP Address > 802.11b/g/n Parameters page shows that short preambles are enabled, continue to the next step. However, if short preambles are disabled, which means that long preambles are enabled, the controller is already optimized for SpectraLink NetLink phones, and you do not need to continue this procedure.

Step 6 Enable long preambles by unchecking the Short Preamble check box.

Step 7 Click Save to update the controller configuration.

Step 8 To save the controller configuration, click System > Commands in the sidebar, Save Config To Flash from the Administrative Commands drop-down menu, and GO.

Step 9 To reboot the controller, click Reboot from the Administrative Commands drop-down menu and GO.

Step 10 Click OK when the following message appears:

Please save configuration by clicking “Save Config to flash”. Do you want to continue rebooting anyways?

The controller reboots. This process may take some time, during which WCS loses its connection to the controller.

Note You can view the controller reboot process with a CLI session.

Creating an RF Calibration Model

If you would like to further refine WCS Location tracking of client and rogue access points across one or more floors of a building, you have the option of creating an RF calibration model that uses physically collected RF measurements to fine-tune the location algorithm. When you have multiple floors in a building with the same physical layout as the calibrated floor, you can save time calibrating the remaining floors by using the same RF calibration model for the remaining floors.

The calibration models are used as RF overlays with measured RF signal characteristics that can be applied to different floor areas. This allows the Cisco Unified Wireless Network Solution installation team to lay out one floor in a multi-floor area, use the RF calibration tool to measure and save the RF characteristics of that floor as a new calibration model, and apply that calibration model to all the other floors with the same physical layout. See Chapter 5 for calibration instructions.
Adding and Using Maps

This chapter describes how to add maps to the Cisco WCS database and use them to monitor your wireless LAN. It contains these sections:

- Creating Maps, page 5-2
- Placing Access Points, page 5-26
- Creating a Network Design, page 5-28
- Using Chokepoints to Enhance Tag Location Reporting, page 5-35
- Monitoring Maps, page 5-43
- Importing or Exporting WLSE Map Data, page 5-55
- Creating and Applying Calibration Models, page 5-58
- Analyzing Element Location Accuracy Using Testpoints, page 5-64
- Using the Accuracy Tool to Conduct Accuracy Testing, page 5-68
Creating Maps

With the Cisco WCS database, you can add maps and view your managed system on realistic campus, building, and floor map maps. Follow the instructions in the sections below to add a campus, buildings, outdoor areas, floor plans, and access points to maps in the Cisco WCS database:

- Adding a Campus, page 5-2
- Adding Buildings, page 5-3
- Adding Outdoor Areas, page 5-6
- Searching Maps, page 5-9

Adding a Campus

Follow these steps to add a single campus map to the Cisco WCS database.

**Step 1**  
Save the map in .PNG, .JPG, .JPEG, or .GIF format.

*Note*  
The map can be any size because WCS automatically resizes the map to fit its working areas.

**Step 2**  
Browse to and import the map from anywhere in your file system.

**Step 3**  
Click Monitor > Maps to display the Maps page.

**Step 4**  
From the Select a command drop-down menu, choose New Campus and click GO.

**Step 5**  
On the Maps > New Campus page, enter the campus name and campus contact name.

**Step 6**  
Browse to and choose the image filename or CAD file containing the map of the campus and click Open.

*Note*  
Only DXF and DWG CAD file images are supported.

**Step 7**  
Check the Maintain Aspect Ratio check box to prevent length and width distortion when WCS resizes the map.

**Step 8**  
Enter the horizontal and vertical span of the map in feet.

*Note*  
The horizontal and vertical span should be larger than any building or floor plan to be added to the campus.

**Step 9**  
Click OK to add this campus map to the Cisco WCS database. WCS displays the Maps page, which lists maps in the database, map types, and campus status.
# Adding Buildings

You can add buildings to the Cisco WCS database regardless of whether you have added campus maps to the database. This section explains how to add a building to a campus map or a standalone building to the Cisco WCS database.

## Adding a Building to a Campus Map

Follow these steps to add a building to a campus map in the Cisco WCS database.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td><strong>Click</strong> Monitor &gt; Maps <strong>to display the Maps page.</strong></td>
</tr>
<tr>
<td>2</td>
<td><strong>Click</strong> the desired campus. WCS displays the Maps &gt; Campus Name page.</td>
</tr>
<tr>
<td>3</td>
<td>From the Select a command drop-down menu, choose <strong>New Building</strong> and click <strong>GO</strong>.</td>
</tr>
</tbody>
</table>
| 4    | On the Campus Name > New Building page, follow these steps to create a virtual building in which to organize related floor plan maps:  
  a. Enter the building name.  
  b. Enter the building contact name.  
  c. Enter the number of floors and basements.  
  d. Enter an approximate building horizontal span and vertical span (width and depth on the map) in feet.  
  ![Tip](https://via.placeholder.com/150) The horizontal and vertical span should be larger than or the same size as any floors that you might add later. You can also use Ctrl-click to resize the bounding area in the upper left corner of the campus map. As you change the size of the bounding area, the Horizontal Span and Vertical Span parameters of the building change to match your actions.  
  e. **Click** Place **to put the building on the campus map.** WCS creates a building rectangle scaled to the size of the campus map.  
  f. **Click** on the building rectangle and drag it to the desired position on the campus map.  
  ![Note](https://via.placeholder.com/150) **Note** After adding a new building, you can move it from one campus to another without having to recreate it.  
  g. **Click** Save **to save this building and its campus location to the database.** WCS saves the building name in the building rectangle on the campus map.  
  ![Note](https://via.placeholder.com/150) **Note** A hyperlink associated with the building takes you to the corresponding Map page. |
| 5    | *(Optional)* To assign location presence information for the new outdoor area, do the following:  
  a. **Choose** Edit Location Presence Info **from the Select a command drop-down menu.** Click **GO**. The Location Presence window appears (see Figure 5-1). |
b. Choose either the **Civic**, **GPS markers**, or **Advanced** tab.

- Civic Address identifies the campus by name, street, house number, house number suffix, city (address line2), state, postal code, and country.
- GPS Markers identify the campus by longitude and latitude.
- Advanced identifies the campus with expanded civic information such as neighborhood, city division, country, and postal community name.

**Note** Each selected parameter is inclusive of all of those above it. For example, if you choose Advanced, it can also provide GPS and Civic location information upon client demand. The selected setting must match what is set on the location server level (Administration > Location Presence).

**Note** If a client requests location information such as GPS Markers for a campus, building, floor, or outdoor area that is not configured for that parameter, an error message is returned.

c. By default, the Override Child Element’s Presence Info check box is checked. There is no need to alter this setting for standalone buildings.

### Step 6
Click **Save**.

---

### Adding a Standalone Building

Follow these steps to add a standalone building to the Cisco WCS database.

**Step 1** Click **Monitor > Maps** to display the Maps page.
Step 2  From the Select a command drop-down menu, choose \textbf{New Building} and click \textbf{GO}.

Step 3  On the Maps > New Building page, follow these steps to create a virtual building in which to organize related floor plan maps:

a. Enter the building name.

b. Enter the building contact name.

\begin{itemize}
  \item \textbf{Note} After adding a new building, you can move it from one campus to another without having to recreate it.
\end{itemize}

c. Enter the number of floors and basements.

d. Enter an approximate building horizontal span and vertical span (width and depth on the map) in feet.

\begin{itemize}
  \item \textbf{Note} The horizontal and vertical span should be larger than or the same size as any floors that you might add later.
\end{itemize}

e. Click \textbf{OK} to save this building to the database.

\begin{itemize}
  \item \textbf{Note} Since a WLSE file has no floor number information, the structure of the floor index calculation after WLSE is imported into WCS is in descending order. You can click on the floor image to go directly to the appropriate floor screen.
\end{itemize}

Step 4 \textit{(Optional)} To assign location presence information for the new building, do the following:

a. Choose \textbf{Edit Location Presence Info} from the Select a command drop-down menu. Click \textbf{GO}. The Location Presence window appears (see \textbf{Figure 5-1}).

b. Choose either the Civic, GPS markers, or Advanced tab.

- Civic Address identifies the campus by name, street, house number, house number suffix, city (address line2), state, postal code, and country.
- GPS Markers identify the campus by longitude and latitude.
- Advanced identifies the campus with expanded civic information such as neighborhood, city division, county, and postal community name.

\begin{itemize}
  \item \textbf{Note} Each selected parameter is inclusive of all of those above it. For example, if you select Advanced, it can also provide GPS and Civic location information upon client demand. The selected setting must match what is set on the location server level (Administration > Location Presence).
\end{itemize}

\begin{itemize}
  \item \textbf{Note} If a client requests location information such as GPS Markers for a campus, building, floor, or outdoor area that is not configured for that parameter, an error message is returned.
\end{itemize}

c. By default, the Override Child Element’s Presence Info check box is checked. There is no need to alter this setting for standalone buildings.
Creating Maps

Chapter 5      Adding and Using Maps

Step 5  Click **Save**.

Adding Outdoor Areas

Follow these steps to add an outdoor area to a campus map.

**Note**  You can add outdoor areas to a campus map in the Cisco WCS database regardless of whether you have added outdoor area maps to the database.

**Step 1**  If you want to add a map of the outdoor area to the database, save the map in .PNG, .JPG, .JPEG, or .GIF format. Then browse to and import the map from anywhere in your file system.

**Note**  You do not need a map to add an outdoor area. You can simply define the dimensions of the area to add it to the database. The map can be any size because WCS automatically resizes the map to fit the workspace.

**Step 2**  Click **Monitor > Maps** to display the Maps page.

**Step 3**  Click the desired campus. WCS displays the Maps > **Campus Name** page.

**Step 4**  From the Select a command drop-down menu, choose **New Outdoor Area** and click **GO**.

**Step 5**  On the **Campus Name** > New Outdoor Area page, follow these steps to create a manageable outdoor area:

- Enter the outdoor area name.
- Enter the outdoor area contact name.
- If desired, enter or browse to the filename of the outdoor area map.
- Enter an approximate outdoor horizontal span and vertical span (width and depth on the map) in feet.

**Tip**  You can also use Ctrl-click to resize the bounding area in the upper left corner of the campus map. As you change the size of the bounding area, the Horizontal Span and Vertical Span parameters of the outdoor area change to match your actions.

- Click **Place** to put the outdoor area on the campus map. WCS creates an outdoor area rectangle scaled to the size of the campus map.
- Click on the outdoor area rectangle and drag it to the desired position on the campus map.
- Click **Save** to save this outdoor area and its campus location to the database. WCS saves the outdoor area name in the outdoor area rectangle on the campus map.

**Note**  A hyperlink associated with the outdoor area takes you to the corresponding Map page.

**Step 6**  *(Optional)* To assign location presence information for the new outdoor area, do the following:

- Choose **Edit Location Presence Info** from the Select a command drop-down menu. Click **GO**. The Location Presence window appears (see **Figure 5-1**).
b. Choose either the Civic, GPS markers, or Advanced tab.

- Civic Address identifies the campus by name, street, house number, house number suffix, city (address line2), state, postal code, and country.
- GPS Markers identify the campus by longitude and latitude.
- Advanced identifies the campus with expanded civic information such as neighborhood, city division, county, and postal community name.

Note Each selected parameter is inclusive of all of those above it. For example, if you select Advanced, it can also provide GPS and Civic location information upon client demand. The selected setting must match what is set on the location server level (Administration > Location Presence).

Note If a client requests location information such as GPS markers for a campus, building, floor, or outdoor area that is not configured for that parameter, an error message is returned.

c. By default, the Override Child Element’s Presence Info check box is checked. There is no need to alter this setting for outdoor areas.

Step 7 Click Save.

### Enabling Location Presence on a Location Server

Follow these steps to enable and configure location presence on a location server. When enabled, the location server is capable of providing any requesting Cisco Compatible Extension v5 client with its location.

Before enabling this feature, synchronize the location server.

**Step 1** Click Location > Location Servers > Server Name. Choose the location server to which the campus or building is assigned.

**Step 2** Choose Presence Parameters from the Administration menu. The Location Presence window appears (see Figure 5-2).
Step 3  Check the **On Demand** check box to enable location presence for Cisco Compatible Extension v5 clients.

Step 4  Choose one of the Location Resolution options.

a.  When **building** is selected, the location server can provide, to any requesting client, its location by building.
   –  For example, if a client requests its location and the client is located in Building A, the location server returns the client address as **Building A**.

b.  When **ap** is selected, the location server can provide, to any requesting client, its location by its associated access point. The MAC address of the access point appears.
   –  For example, if a client requests its location and the client is associated with an access point with a MAC address of 3034:00hh:0adg, the location server returns the client address of **3034:00hh:0adg**.

c.  When **X,Y** is selected, the location server can provide, to any requesting clients, its location by its X and Y coordinates.
   –  For example, if a client requests its location and the client is located at (50, 200), the location server returns the client address of **50, 200**.

Step 5  Check any or all of the location formats.

a.  Check the **Cisco** check box to provide location by campus, building, and floor with X and Y coordinates. This is the default setting.

b.  Check the **Civic** check box to provide the name and address (street, city, state, postal code, country) of a campus, building, floor, or outdoor area. Expanded location details can also be entered in the Advanced panel.

c.  Check the **GEO** check box to provide the longitude and latitude coordinates.

Step 6  By default the **Text** check box for Location Response Encoding is checked. It indicates the format of the information when received by the client. There is no need to change this setting.

Step 7  Check the **Retransmission Rule Enable** check box to allow the receiving client to retransmit the received information to another party.
Step 8  Enter a **Retention Expiration** value in minutes. This determines how long the received information is stored by the client before it is overwritten. The default value is 24 hours (1440 minutes).

Step 9  Click **Save**.

---

**Searching Maps**

Use the controls in the left sidebar to create and save custom searches:

- **New Search** drop-down menu: Opens the Search Maps window. Use the Search Maps window to configure, run, and save searches.

- **Saved Searches** drop-down menu: Lists the saved custom searches. To open a saved search, choose it from the Saved Searches list.

- **Edit Link**: Opens the Edit Saved Searches window. You can delete saved searches in the Edit Saved Searches window.

- **Audit Status**: Allows you to search based on audit status of not available (audit status is not available), identical (no configuration differences were found during the last audit), or mismatch (configuration differences were found during the last audit).

You can configure the following parameters in the Search Maps window:

- Search for
- Map Name
- Search in
- Save Search
- Items per page
After you click GO, the map search results window appears:

<table>
<thead>
<tr>
<th>Table 5-1</th>
<th>Map Search Results</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Parameter</strong></td>
<td><strong>Options</strong></td>
</tr>
<tr>
<td>Name</td>
<td>Clicking an item in the Name list gives a map of an existing building with individual floor area maps for each floor.</td>
</tr>
<tr>
<td>Type</td>
<td>Campus, building, or floor area.</td>
</tr>
<tr>
<td>WCS</td>
<td>WCS name.</td>
</tr>
<tr>
<td>Total APs</td>
<td>Displays the total number of Cisco radios detected.</td>
</tr>
<tr>
<td>a/n Radios</td>
<td>Displays the number of 802.11a/n Cisco radios.</td>
</tr>
<tr>
<td>b/g/n Radios</td>
<td>Displays the number of 802.11b/g/n Cisco radios.</td>
</tr>
<tr>
<td>OOS Radios</td>
<td>Displays the number of Out of Service access points associated with this controller.</td>
</tr>
<tr>
<td>Clients</td>
<td>Displays the number of clients currently associated with the controller.</td>
</tr>
<tr>
<td>Status</td>
<td>A colored icon indicating the campus or building status (green for Up, yellow for Warning, or red for Down).</td>
</tr>
</tbody>
</table>

## Finding Coverage Holes

Coverage holes are areas where clients cannot receive a signal from the wireless network. The Cisco Unified Wireless Network Solution radio resource management (RRM) identifies these coverage hole areas and reports them to WCS, enabling the IT manager to fill holes based on user demand. Follow these steps to find coverage holes on your wireless LAN.

**Step 1** Click the Coverage indicator on the bottom left of the WCS user interface page (or click Monitor > Alarms and search for Coverage under Alarm Category) to display the Coverage Hole Alarms page.

**Step 2** Click Monitor > Maps and search for access points by name (this search tool is case sensitive). WCS displays the Maps > Search Results page, which lists the floor or outdoor area where the access point is located.

**Step 3** Click the floor or outdoor area link to display the related Maps > Building Name > Floor Name page.

**Step 4** Look for areas of low signal strength near the access point that reported the coverage hole. These areas are the most likely locations of coverage holes. If areas of weak signal strength are detected, make sure that the floor plan map is accurate.

## Adding and Enhancing Floor Plans

This section explains how to add floor plans to either a campus building or a standalone building in the Cisco WCS database. It also provides instructions on using the WCS map editor to enhance floor plans that you have created and the WCS planning mode to calculate the number of access points required to cover an area.
Adding Floor Plans to a Campus Building

After you add a building to a campus map, you can add individual floor plan and basement maps to the building. Follow these steps to add floor plans to a campus building.

**Step 1** Save your floor plan maps in .PNG, .JPG, or .GIF format.

*Note* The maps can be any size because WCS automatically resizes the maps to fit the workspace.

**Step 2** Browse to and import the floor plan maps from anywhere in your file system. You can also import CAD image files DXF and DWG.

**Step 3** Click Monitor > Maps to display the Maps page.

**Step 4** Click the desired campus. WCS displays the Maps > Campus Name page.

**Step 5** Move your cursor over the name within an existing building rectangle to highlight it.

*Note* When you highlight the name within a building rectangle, the building description appears in the sidebar.

**Step 6** Click on the building name to display the Maps > Campus Name > Building Name page.

**Step 7** From the Select a command drop-down menu, choose New Floor Area and click GO.

**Step 8** On the Building Name > New Floor Area page, follow these steps to add floors to a building in which to organize related floor plan maps:

a. Enter the floor or basement name.
b. Enter the floor or basement contact name.
c. Choose the floor or basement number.
d. Choose the floor or basement type.
e. Enter the floor-to-floor height in feet.
f. Check the Image File check box; then browse to and choose the desired floor or basement image filename and click Open.

g. Click Next. At this point, if a CAD file was specified, a default image preview is generated and loaded. The names of the CAD file layers are listed, with check boxes to the right side of the image indicating which are enabled.

*Note* When you choose the floor or basement image filename, WCS displays the image in the building-sized grid.

h. If you have CAD file layers, you can select or deselect as many as you want and click Preview to view an updated image. Click Next when you are ready to proceed with the selected layers.
i. Either leave the Maintain Aspect Ratio check box checked to preserve the original image aspect ratio or uncheck the check box to change the image aspect ratio.
j. Enter an approximate floor or basement horizontal span and vertical span (width and depth on the map) in feet.
Adding and Enhancing Floor Plans

Adding Floor Plans to a Standalone Building

After you have added a standalone building to the Cisco WCS database, you can add individual floor plan maps to the building. Follow these steps to add floor plans to a standalone building.

**Step 1** Save your floor plan maps in .PNG, .JPG, or .GIF format.

**Note** The maps can be any size because WCS automatically resizes the maps to fit the workspace.

**Step 2** Browse to and import the floor plan maps from anywhere in your file system. You can import CAD files in DXF or DWG formats or any of the formats you created in Step 1.

**Step 3** Click **Monitor > Maps** to display the Maps page.

**Step 4** Click the desired building. WCS displays the Maps > **Building Name** page.

**Step 5** From the Select a command drop-down menu, choose **New Floor Area** and click **GO**.

**Step 6** On the **Building Name** > New Floor Area page, follow these steps to add floors to a building in which to organize related floor plan maps:

- **a.** Enter the floor or basement name.
- **b.** Enter the floor or basement contact name.
- **c.** Choose the floor or basement number.
- **d.** Choose the floor or basement type.
e. Enter the floor-to-floor height in feet.

f. Check the Image File check box; then browse to and choose the desired floor or basement image filename and click Open.

g. Click Next.

Note: When you choose the floor or basement image filename, WCS displays the image in the building-sized grid.

h. If you imported a CAD file, you are directed to the image conversion page.

Note: The length of time for the conversion varies and depends on the file size, file detail, and number of layers in the file.

i. Either leave the Maintain Aspect Ratio check box checked to preserve the original image aspect ratio or uncheck the check box to change the image aspect ratio.

j. Enter an approximate floor or basement horizontal span and vertical span (width and depth on the map) in feet.

Note: The horizontal and vertical span should be smaller than or the same size as the building horizontal span and vertical span in the Cisco WCS database.

k. If desired, click Place to locate the floor or basement image on the building grid.

Tip: You can use Ctrl-click to resize the image within the building-sized grid.

l. Click OK to save this floor plan to the database. WCS displays the floor plan image on the Maps > Building Name page.

Step 7: Click any of the floor or basement images to view the floor plan or basement map.

Note: You can zoom in and out to view the map at different sizes, and you can add access points. See the “Inspect VoWLAN Readiness” section on page 5-23 for instructions.

Using the Map Editor to Enhance Floor Plans

You can use the WCS map editor to define, draw, and enhance floor plan information. The map editor enables you to create obstacles so that they can be taken into consideration when computing RF prediction heat maps for access points. You can also add coverage areas for location appliances that locate clients and tags in that particular area. Follow these general guidelines to use the map editor.

General Notes and Guidelines for Using the Map Editor

Consider the following when modifying a building or floor map using the map editor.
Cisco recommends that you use the map editor to draw walls and other obstacles rather than importing an .FPE file from the legacy floor plan editor.

- If necessary, you can still import .FPE files. To do so, navigate to the desired floor area, choose Edit Floor Area from the Select a command drop-down menu, click GO, check the FPE File check box, and browse to and choose the .FPE file.

- You can add any number of walls to a floor plan with the map editor; however, the processing power and memory of a client workstation may limit the refresh and rendering aspects of WCS.
  - Cisco recommends a practical limit of 400 walls per floor for machines with 1-GB RAM or less.

- All walls are used by WCS when generating RF coverage heatmaps.
  - However, the location appliance uses no more than 50 heavy walls in its calculations, and the location appliance does not use light walls in its calculations because those attenuations are already accounted for during the calibration process.

- If you have a high resolution image (near 12 megapixels), you may need to scale down the image resolution with an image editing software prior to using map editor.

Follow these steps to use the map editor:

1. Click Monitor > Maps to display the Maps page.
2. Click the desired campus. WCS displays the Maps > Campus Name page.
3. Click on a campus building.
4. Click on the desired floor area. WCS displays the Maps > Campus Name > Building Name > Floor Area Name page.
5. From the Select a command drop-down menu, choose Map Editor and click GO. WCS displays the Map Editor page.
6. Make sure that the floor plan images are properly scaled so that all white space outside of the external walls is removed. To make sure that floor dimensions are accurate, choose the compass tool from the toolbar.
7. Position the reference length. When you do, the Scale menu appears with the line length supplied. Enter the dimensions (width and height) of the reference length and click OK.
8. Choose the desired 802.11 standard from the Radio Type drop-down menu.
9. Choose the antenna model from the Antenna drop-down menu.
10. Determine the propagation pattern at the Antenna Mode drop-down menu.
11. Make antenna adjustments by sliding the antenna orientation bar to the desired degree of direction.
12. Choose the desired access point.
13. Click Save.

Using the Map Editor to Draw Polygon Areas

If you have a building that is non-rectangular or you want to mark a non-rectangular area within a floor, you can use the map editor to draw a polygon-shaped area.

1. In Cisco WCS, add the floor plan if it is not already represented in WCS (refer to the """" section on page 5-10).
Step 2  Choose **Monitor > Maps**.

Step 3  Click on the Map Name that corresponds to the outdoor area, campus, building, or floor you want to edit.

Step 4  From the Select a command drop-down menu, choose **Map Editor** and click **GO**.

Step 5  At the Map Editor screen, click the **Add Perimeter** icon on the tool bar (see Figure 5-3).

Note  An example of a polygon-shaped area is seen in **Figure 5-3**.

**Figure 5-3  Map Editor Page**

![Map Editor Screen]

Step 6  Enter the name of the area that you are defining. Click **OK**.

Step 7  Move the drawing tool to the area you want to outline.

- Click the left mouse button to begin and end drawing a line.
- When you have completely outlined the area, double click the left mouse button and the area is highlighted on the screen (see **Figure 5-4**).
The outlined area must be a closed object to highlight on the map.

**Figure 5-4  Polygon Area**

---

**Step 8**  Click the disk icon in the tool bar to save the newly drawn area.

**Step 9**  Choose **Command > Exit** to close the window. You are returned to the original floor plan.

**Note**  When you return to the original floor plan view, after exiting the map editor, the newly drawn area is not seen; however, it appears in the Planning Model window when you add elements.

**Step 10**  Select **Planning Model** from the Select a command drop-down menu to begin adding elements to the newly defined polygon-shaped area.
Using Planning Mode to Calculate Access Point Requirements

The WCS planning mode enables you to calculate the number of access points required to cover an area by placing fictitious access points on a map and allowing you to view the coverage area. Based on the throughput specified for each protocol (802.11a/n or 802.11b/g/n), planning mode calculates the total number of access points required to provide optimum coverage in your network. You can calculate the recommended number and location of access points based on the following criteria:

- traffic type active on the network: data or voice traffic or both
- location accuracy requirements
- number of active users
- number of users per square footage

To calculate the recommended number and placement of access points for a given deployment, follow these steps:

**Step 1** Choose Monitor > Maps.

The window appears (see Figure 5-5).

**Figure 5-5 Monitor > Maps Page**

![Figure 5-5 Monitor > Maps Page](image)

**Step 2** Click the appropriate location link from the list that appears.

A color-coded map appears showing placement of all installed elements (access points, clients, tags) and their relative signal strength (see Figure 5-6).
**Step 3**  Choose **Planning Mode** from the Select a command drop-down menu (top-right) and click **GO**. A blank floor map appears.

**Step 4**  Click **Add APs**.

**Step 5**  In the page that appears, drag the dashed-line rectangle over the map location for which you want to calculate the recommended access points (see **Figure 5-7**).

---

**Note**  Adjust the size or placement of the rectangle by selecting the edge of the rectangle and holding down the **Ctrl** key. Move the mouse as necessary to outline the targeted location.
**Figure 5-7   Add APs Page**

**Planning Mode:** Maps > WNBU > 3rd Floor

**Add APs**

- **Name Prefix:** AP
- **Add APs:** Automatic
- **AP Type:** AP-1200
- 802.11a Antennas: 100+10 Ku
- 802.11b/g Antennas: 100+10 Ku
- **Protocol:** 802.11a/b/g
- **Throughput (Mbps):** 802.11a: 18-12, 802.11b/g: 5

**Services:**

- **Advanced Options**
- Data/Coverage
  - Safety Margin: Aggressive
- Voice
  - Safety Margin: Aggressive
- Location
- Demand

**Override Coverage per AP:** Per AP Area (sq feet)

- **Total Coverage Area:** 10109.8 (sq feet)

**Calculate**

**Recommended AP Count:**

- Data/Coverage: 12
- Voice: 2
- Location: 2

---

**Step 6**  Select **Automatic** from the Add APs drop-down menu.

**Step 7**  Select the **AP Type** and the appropriate antenna and protocol for that access point.

**Step 8**  Select the target throughput for the access point.

**Step 9**  Check the box(es) next to the service(s) that will be used on the floor. Options are Data/Coverage (default), Voice, and Location (Table 5-2).

---

**Note**  You must select at least one service or an error occurs.

---

**Note**  If you check the **Advanced Options** box, two additional access point planning options appear: Demand and Override Coverage per AP. Additionally, a Safety Margin parameter appears for the Data/Coverage and Voice service options (Table 5-3).
Table 5-2  Definition of Service Options

<table>
<thead>
<tr>
<th>Service Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Data/Coverage</strong></td>
<td>Select if data traffic is transmitted on the wireless LAN. The following densities are used depending on the band and data rates:</td>
</tr>
<tr>
<td><strong>Band</strong></td>
<td><strong>Path Loss Model (dBm)</strong></td>
</tr>
<tr>
<td>802.11a/n</td>
<td>–3.3</td>
</tr>
<tr>
<td>802.11a/n</td>
<td>–3.3</td>
</tr>
<tr>
<td>802.11a/n</td>
<td>–3.5</td>
</tr>
<tr>
<td>802.11a/n</td>
<td>–3.5</td>
</tr>
<tr>
<td>802.11b/g/n</td>
<td>–3.3</td>
</tr>
<tr>
<td>802.11b/g/n</td>
<td>–3.3</td>
</tr>
<tr>
<td>802.11b/g/n</td>
<td>–3.5</td>
</tr>
<tr>
<td>802.11b/g/n</td>
<td>–3.5</td>
</tr>
</tbody>
</table>

If you enable **Advanced Options** (click check box), you can select the desired safety margin (aggressive, safe, very safe) of the signal strength threshold for data.

* Aggressive = Minimum (–3 dBm)
* Safe = Medium (0 dBm)
* Very Safe = Maximum (+3 dBm)

<table>
<thead>
<tr>
<th><strong>Voice</strong></th>
<th>Select if voice traffic is transmitted on the wireless LAN.</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you enable <strong>Advanced Options</strong> (click check box), you can select the desired safety margin (aggressive, safe, very safe or 7920-enabled) of the signal strength threshold for voice.</td>
<td></td>
</tr>
<tr>
<td>* Aggressive = Minimum [–78 dBm (802.11a/b/g/n)]</td>
<td></td>
</tr>
<tr>
<td>* Safe = Medium [–75 dBm (802.11a/b/g/n)]</td>
<td></td>
</tr>
<tr>
<td>* Very Safe = Maximum [–72 dBm (802.11a/b/g/n)]</td>
<td></td>
</tr>
<tr>
<td>* 7920_enabled = [–72 dBm (802.11a/n); –67 dBm (802.11b/g/n)]</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Location</strong></th>
<th>Select to ensure that the recommended access point calculation provides the true location of an element within 10 meters at least 90% of the time.</th>
</tr>
</thead>
<tbody>
<tr>
<td>To meet the criteria, access points are collocated within 70 feet of each other in a hexagonal pattern employing staggered and perimeter placement.</td>
<td></td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>Each service option includes all services that are listed above it. For example, if you check the Location box, the calculation considers data/coverage, voice, and location in determining the optimum number of access points required.</td>
</tr>
</tbody>
</table>
Table 5-3  Definition of Advanced Options

<table>
<thead>
<tr>
<th>Advanced Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Demand</td>
<td>Select if you want to use the total number of users or user ratio per access point as a basis for the access point calculation.</td>
</tr>
<tr>
<td>Override Coverage per AP</td>
<td>Select if you want to specify square foot coverage as the basis for access point coverage.</td>
</tr>
<tr>
<td>Safety Margin</td>
<td>Select option to qualify relative signal strength requirements for data and voice service in the access point calculation. Options are: Aggressive, Safe, Very Safe, and 7920-enabled (voice only). Select Aggressive to require minimal signal strength requirements in the calculation and Very Safe to request the highest signal strength.</td>
</tr>
</tbody>
</table>

Step 10  Click Calculate.

The recommended number of access points given the selected services appears (see Figure 5-8).

Figure 5-8  Recommended Number of Access Points Given Selected Services and Parameters

![Figure 5-8](image-url)
Note: Recommended calculations assume the need for consistently strong signals unless adjusted downward by the safety margin advanced option. In some cases, the recommended number of access points is higher than what is required.

Note: Walls are not used or accounted for in planning mode calculations.

Step 11 Click Apply to generate a map that shows proposed deployment of the recommended access points in the selected area based on the selected services and parameters.

Figure 5-9 Recommended Access Point Deployment Given Selected Services and Parameters

Step 12 Choose Generate Proposal to display a textual and graphical report of the recommended access point number and deployment based on the given input.

Inspect VoWLAN Location Readiness

The Inspect Location Readiness feature is a distance-based predictive tool that can point out problem areas with access point placement.

The Inspect Location Readiness tool:

- Displays areas that have the required access point coverage and will provide accurate location results.
- Takes into consideration the placement of each access point along with the inter-access point spacing.
- Assumes that access points and controllers are known to WCS.
A point is defined as “location-ready” if the following is true:

- At least four access points are deployed on the floor.
- At least three access points are within 70 feet of the point-in-question.
- At least one access point is found to be resident in each quadrant surrounding the point-in-question.

To access the Inspect Location Readiness tool, follow these steps:

---

Step 1  Choose Monitor > Maps.
Step 2  Choose the applicable floor area name.
Step 3  From the Select a command drop-down menu, click Inspect Location Readiness.

---

**Inspect VoWLAN Readiness**

Voice readiness tool (the VoWLAN Readiness tool) allows you to verify that the RF coverage is sufficient for your voice needs. This tool verifies RSSI levels after access points have been installed.

To access the VoWLAN Readiness Tool (VRT), follow these steps:

---

Step 1  Choose Monitor > Maps.
Step 2  Choose the applicable floor area name.
Step 3  From the Select a command drop-down menu, click Inspect VoWLAN Readiness.
Step 4  Choose the applicable Band, AP Transmit Power, and Client parameters from the drop-down menus.

**Note**  By default, the region map displays the region map for the b/g/n band for Cisco phone based RSSI threshold. The new settings cannot be saved.

Step 5  Depending on the selected client, the RSSI values may not be editable.
- Cisco Phone—RSSI values are not editable.
- Custom—RSSI values are editable with the following ranges:
  - Low threshold between –95dBm to –45dBm
  - High threshold between –90dBm to –40dBm

Step 6  The following color schemes indicate whether or not the area is Voice Ready:
- Green—Yes
- Yellow—Marginal
- Red—No

---

**Troubleshooting Voice RF Coverage Issues**

Perform the following to troubleshoot voice RF coverage issues:

- Set the AP Transmit parameter to Max (the maximum downlink power setting). If the map still shows some yellow or red regions, more access points are required to cover the floor.
- Increase the power level of the access points if a calibrated model shows red or yellow regions (where voice is expected to be deployed) while the AP Transmit parameter is set to Current.
- Verify the green, yellow, and red regions of the RF environment. These indicators are accurate whether the floor is calibrated or not, but floor calibration improves the accuracy.

Adding Access Points

After you add the .PNG, .JPG, .JPEG, or .GIF format floor plan and outdoor area maps to the Cisco WCS database, you can position lightweight access point icons on the maps to show where they are installed in the buildings. Follow these steps to add access points to floor plan and outdoor area maps.

---

**Step 1**
Click the desired floor plan or outdoor area map in the Coverage Areas component of the General tab. WCS displays the associated coverage area map.

**Step 2**
From the Select a command drop-down menu, choose **Add Access Points** and click **GO**.

**Step 3**
On the Add Access Points page, choose the access points to add to the map.

**Step 4**
Click **OK** to add the access points to the map and display the Position Access Points map.

---

**Note**
The access point icons appear in the upper left area of the map.

**Step 5**
Click and drag the icons to indicate their physical locations.

**Step 6**
Click each icon and choose the antenna orientation in the sidebar (see Figure 5-10).

---

**Figure 5-10  Antenna Sidebar**
Note

- The antenna angle is relative to the map’s X axis. Because the origin of the X (horizontal) and Y (vertical) axes is in the upper left corner of the map, 0 degrees points side A of the access point to the right, 90 degrees points side A down, 180 degrees points side A to the left, and so on.
- The antenna elevation is used to move the antenna vertically, up or down, to a maximum of 90 degrees.
- Make sure each access point is in the correct location on the map and has the correct antenna orientation. Accurate access point positioning is critical when you use the maps to find coverage holes and rogue access points.

Step 7

Click **Save** to store the access point locations and orientations. WCS computes the RF prediction for the coverage area. These RF predictions are popularly known as *heat maps* because they show the relative intensity of the RF signals on the coverage area map. **Figure 5-11** shows an RF prediction heat map.

Note

This display is only an approximation of the actual RF signal intensity because it does not take into account the attenuation of various building materials, such as drywall or metal objects, nor does it display the effects of RF signals bouncing off obstructions.

**Figure 5-11**  
*RF Prediction Heat Map*
Placing Access Points

To determine the optimum location of all devices in the wireless LAN coverage areas, you need to consider the access point density and location.

Ensure that no fewer than 3 access points, and preferably 4 or 5, provide coverage to every area where device location is required. The more access points that detect a device, the better. This high level guideline translates into the following best practices, ordered by priority:

1. Most importantly, access points should surround the desired location.
2. One access point should be placed roughly every 50 to 70 linear feet (about 17 to 20 meters). This translates into one access point every 2,500 to 5000 square feet (about 230 to 450 square meters).

Note

The access point must be mounted so that it is under 20 feet high. For best performance, a mounting at 10 feet would be ideal.

Following these guidelines makes it more likely that access points will detect tracked devices. Rarely do two physical environments have the same RF characteristics. Users may need to adjust those parameters to their specific environment and requirements.

Note

Devices must be detected at signals greater than –75 dBm for the controllers to forward information to the location appliance. No fewer than three access points should be able to detect any device at signals below –75 dBm.

Guidelines for Placing Access Points

Follow these rules for placing access points accurately:

1. Place access points along the periphery of coverage areas in order to keep devices close to the exterior of rooms and buildings (see Figure 5-12). Access points placed in the center of these coverage areas provide good data on devices that would otherwise appear equidistant from all other access points.

Figure 5-12 Access Points Clustered Together

By increasing overall access point density and moving access points towards the perimeter of the coverage area, location accuracy is greatly improved (see Figure 5-13).
3. In long and narrow coverage areas, avoid placing access points in a straight line (see Figure 5-14). Stagger them so that each access point is more likely to provide a unique snapshot of a device’s location.

Figure 5-14  Refrain From Straight Line Placement

![Figure 5-14](image)

Although the design in Figure 5-14 may provide enough access point density for high bandwidth applications, location suffers because each access point’s view of a single device is not varied enough; therefore, location is difficult to determine.

4. Move the access points to the perimeter of the coverage area and stagger them. Each has a greater likelihood of offering a distinctly different view of the device, resulting in higher location accuracy (see Figure 5-15).

Figure 5-15  Improved Location Accuracy by Staggering Around Perimeter

![Figure 5-15](image)

5. Designing a location-aware wireless LAN, while planning for voice as well, is better done with a few things in mind. Most current wireless handsets support only 802.11b/n, which offers only three non-overlapping channels. Therefore, wireless LANs designed for telephony tend to be less dense than those planned to carry data. Also, when traffic is queued in the Platinum QoS bucket (typically reserved for voice and other latency-sensitive traffic), lightweight access points postpone their scanning functions that allow them to peak at other channels and collect, among other things, device location information. The user has the option to supplement the wireless LAN deployment with
access points set to monitor-only mode. Access points that perform only monitoring functions do not provide service to clients and do not create any interference. They simply scan the airwaves for device information.

Less dense wireless LAN installations, such as voice networks, find their location accuracy greatly increased by the addition and proper placement of monitor access points (see Figure 5-16).

Figure 5-16  Less Dense Wireless LAN Installations

6. Verify coverage using a wireless laptop, handheld, or phone to ensure that no fewer than three access points are detected by the device. To verify client and asset tag location, ensure that WCS reports client devices and tags within the specified accuracy range (10 m, 90%).

Creating a Network Design

After access points have been installed and have joined a controller, and WCS has been configured to manage the controllers, set up a network design. A network design is a representation within WCS of the physical placement of access points throughout facilities. A hierarchy of a single campus, the buildings that comprise that campus, and the floors of each building constitute a single network design. These steps assume that the location appliance is set to poll the controllers in that network, as well as be configured to synchronize with that specific network design, in order to track devices in that environment. The concept and steps to perform synchronization between WCS and the location appliance are explained in the “Importing the Location Appliance into WCS” section on page 11-8.

Designing a Network

Follow these steps to design a network.

Step 1  Open the WCS web interface and log in.

Note  To create or edit a network design, you must log into WCS and have SuperUser, Admin, or ConfigManager access privileges.
Step 2  Click the Monitor tab and choose the Maps subtab (see Figure 5-17).

Step 3  From the drop-down menu on the right-hand side, choose either New Campus or New Building, depending on the size of the network design and the organization of maps. If you chose New Campus, continue to Step 4. To create a building without a campus, skip to Step 13.

**Figure 5-17  Creating a New Network Design**

**Step 4**  Click GO.

**Step 5**  Enter a name for the campus network design, a contact name, and the file path to the campus image file. .bmps and .jgps are importable.

**Step 6**  Check the Maintain Aspect Ratio check box. Enabling this check box causes the horizontal span of the campus to be 5000 feet and adjusts the vertical span according to the image file’s aspect ratio. Adjusting either the horizontal or vertical span changes the other field in accordance with the image ratio.

You should uncheck the Maintain Aspect Ratio check box if you want to override this automatic adjustment. You could then adjust both span values to match the real world campus dimensions.

**Step 7**  Click OK.

**Step 8**  On the Monitor > Maps subtab, click the hyperlink associated with the above-made campus map. A window showing the new campus image is displayed.

**Step 9**  From the drop-down menu on the upper right of the window, select New Building and click GO (see Figure 5-18).
Step 10  Enter the name of the building, the contact person, and the number of floors and basements in the building.

Step 11  Indicate which building on the campus map is the correct building by clicking the blue box in the upper left of the campus image and dragging it to the intended location (see Figure 5-19). To resize the blue box, hold down the Ctrl key and click and drag to adjust its horizontal size. You can also enter dimensions of the building by entering numerical values in the Horizontal Span and Vertical Span fields and click Place. After resizing, reposition the blue box if necessary by clicking on it and dragging it to the desired location. Click Save.
Step 12  WCS is then returned to the campus image with the newly created building highlighted in a green box. Click the green box (see Figure 5-20).

Step 13  To create a building without a campus, choose New Building and click GO.
Step 14 Enter the building’s name, contact information, number of floors and basements, and dimension information. Click **Save**. WCS is returned to the Monitor > Maps window.

Step 15 Click the hyperlink associated with the newly created building.

Step 16 On the Monitor > Maps > [Campus Name] > [Building Name] window, go to the drop-down menu and choose **New Floor Area**. Click **GO**.

Step 17 Enter a name for the floor, a contact, a floor number, floor type, and height at which the access points are installed and the path of the floor image. Click **Next**.

---

**Note**

The Floor Type (RF Model) field specifies the type of environment on that specific floor. This RF Model indicates the amount of RF signal attenuation likely to be present on that floor. If the available models do not properly characterize a floor's makeup, details on how to create RF models specific to a floor's attenuation characteristics are available in the “Creating and Applying Calibration Models” section on page 5-58.

---

Step 18 If the floor area is a different dimension than the building, adjust floor dimensions by either making numerical changes to the text fields under the Dimensions heading or by holding the **Ctrl** key and clicking and dragging the blue box around the floor image. If the floor's location is offset from the upper left corner of the building, change the placement of the floor within the building by either clicking and dragging the blue box to the desired location or by altering the numerical values under the **Coordinates of top left corner** heading (see Figure 5-21). After making changes to any numerical values, click **Place**.
Step 19 Adjust the floor’s characteristics with the WCS map editor by choosing the check box next to Launch Map Editor. For an explanation of the map editor feature, see the “Using the Map Editor to Enhance Floor Plans” section on page 5-13.

Step 20 At the new floor’s image window (Monitor > Maps > [ CampusName ] > [ BuildingName ] > [ FloorName ]), go to the drop-down menu on the upper right and choose Add Access Points. Click GO.

Step 21 All access points that are connected to controllers are displayed. Even controllers that WCS is configured to manage but which have not yet been added to another floor map are displayed. Select the access points to be placed on the specific floor map by checking the boxes to the left of the access point entries. Check the box to the left of the Name column to select all access points. Click OK.

Step 22 Each access point you have chosen to add to the floor map is represented by a gray circle (differentiated by access point name or MAC address) and is lined up in the upper left part of the floor map. Drag each access point to the appropriate location. (Access points turn blue when you click on them to relocate them.) The small black arrow at the side of each access point represents Side A of each access point, and
each access point’s arrow must correspond with the direction in which the access points were installed. (Side A is clearly noted on each 1000 series access point and has no relevance to the 802.11a/n radio.)

**Step 23**
To adjust the directional arrow, choose the appropriate orientation in the Antenna Angle drop-down menu. Click **Save** when you are finished placing and adjusting each access point’s direction.

**Note**
Access point placement and direction must directly reflect the actual access point deployment or the system cannot pinpoint the device location.

**Step 24**
Repeat the above processes to create campuses, buildings, and floors until each device location is properly detailed in a network design.

### Changing Access Point Positions by Importing and Exporting a File

You can change an access point position by importing or exporting a file. The file contains only the lines describing the access point you want to move. This option takes less time than manually changing multiple access point positions. Follow these steps to change access point positions using the importing or exporting of a file.

**Step 1**
Choose **Monitor > Maps**.

**Step 2**
From the Select a command drop-down menu, choose **Properties**.

**Step 3**
At the Unit of Dimension drop-down menu, choose feet or meters.

**Step 4**
The **Advanced Debug** option must be enabled on both the location appliance and WCS so the location accuracy testpoint is correct.

**Step 5**
In the Import/Export AP Placement portion of the window, click **Browse** to find the file you want to import. The file in the [BuildingName], [FloorName], [APName], (aAngle), (bAngle), [X], [Y], ([aAngleElevation, bAngleElevation, Z]), (aAntennaType, aAntennaMode, (aAntennaPattern, (aAntennaGain)), bAntennaType, bAntennaDiversity, (bAntennaPattern, bAntennaGain))) format must have already been created and added to WCS. (Refer to the “Inspect VoWLAN Readiness” section on page 5-23.)

**Note**
The parameters in square brackets are mandatory, and those in parentheses are optional.

**Note**
Angles must be entered in radians (X,Y), and the height is entered in feet. The aAngle and bAngle range is from –2Pi (-6.28...) to 2Pi (6.28...), and the elevation ranges from –Pi (-3.14..) to Pi (3.14..).

**Step 6**
Click **Import**. The RF calculation takes approximately two seconds per access point.
Using Chokepoints to Enhance Tag Location Reporting

Installation of chokepoints provides enhanced location information for RFID tags. When an active Cisco Compatible Extensions version 1 compliant RFID tag enters the range of a chokepoint, it is stimulated by the chokepoint. The MAC address of this chokepoint is then included in the next beacon sent by the stimulated tag. All access points that detect this tag beacon then forward the information to the controller and location appliance.

Using chokepoints in conjunction with active compatible extensions compliant tags provides immediate location information on a tag and its asset. When a Cisco Compatible Extension’s tag moves out of the range of a chokepoint, its subsequent beacon frames do not contain any identifying chokepoint information. Location determination of the tag defaults to the standard calculation methods based on RSSIs reported by the access point associated with the tag.

Adding Chokepoints to the WCS Database and Map

Chokepoints are installed and configured as recommended by the Chokepoint vendor. After the chokepoint installation is complete and operational, the chokepoint is added to WCS and placed on floor maps. They are forwarded to the location server during synchronization.

Follow these steps to add a chokepoint to the WCS database and appropriate map:

**Step 1** Choose **Configure > Chokepoints** from the main menu.

The All Chokepoints summary window appears (see Figure 5-22).

*Figure 5-22 Configure > Chokepoints*

**Step 2** Select **Add Chokepoints** from the Select a command menu (Figure 5-22). Click **GO**.

The Add Chokepoint entry window appears (see Figure 5-23).
Chapter 5      Adding and Using Maps

Using Chokepoints to Enhance Tag Location Reporting

Figure 5-23  Add Chokepoint Configuration Page

Step 3  Enter the MAC address, name, and coverage range for the chokepoint.

**Note**  The chokepoint range is product-specific and is supplied by the chokepoint vendor.

Step 4  Specify whether the chokepoint is an entry or exit chokepoint.

Step 5  Click **OK** to save the chokepoint entry to the database.

The All Chokepoints summary page appears with the new chokepoint entry listed (Figure 5-24).
After the chokepoint is added to the database, place it on the appropriate WCS floor map.

**Step 6** To add the chokepoint to a map, choose Monitor > Maps (Figure 5-25).

**Step 7** On the Maps page, choose the link that corresponds to the floor location of the chokepoint. The floor map appears (Figure 5-26).
Step 8  Select **Add Chokepoints** from the Select a command menu. Click **GO**.

The Add Chokepoints summary page appears (see Figure 5-27).

**Note**  The Add Chokepoints summary page lists all recently-added chokepoints that are in the database but not yet mapped.
Step 9

Check the box next to the chokepoint to be added to the map. Click **OK**.

A map appears with a chokepoint icon located in the top-left hand corner (Figure 5-28). You are now ready to place the chokepoint on the map.

**Figure 5-27**  
Add Chokepoints Summary Page

**Figure 5-28**  
Map for Positioning Chokepoint
Step 10  Left click on the chokepoint icon and drag and place it in the proper location (see Figure 5-29).

Figure 5-29  Chokepoint Icon Positioned on the Floor Map

Note  The MAC address, name, and coverage range of the chokepoint appear in the left panel when you click on the chokepoint icon for placement.

Step 11  Click Save when the icon is correctly placed on the map.

You are returned to the floor map and the added chokepoint appears on the map.

Note  The newly created chokepoint icon may or may not appear on the map depending on the display settings for that floor. If the icon did not appear, proceed with Step 12.
Note  The rings around the chokepoint icon indicate the coverage area. When a Cisco Compatible Extensions tag and its asset passes within the coverage area, location details are broadcast, and the tag is automatically mapped on the chokepoint coverage circle. The chokepoint range is given as a visual only, but chokepoint vendor software is required to actually configure the range. When the tag moves out of the chokepoint range, its location is calculated as before and is no longer mapped on the chokepoint rings. In Figure 5-30, the tag is currently out of range of the chokepoint.

Note  MAC address, name, and range of a chokepoint display when you pass a mouse over its map icon.

Step 12  If the chokepoint does not appear on the map, click Layers to collapse a selection menu of possible elements to display on the map. Click the Chokepoints box.

The chokepoint appears on the map (Figure 5-31).
Step 13  Click X to close the Layers window.

Note  Do not select Save Settings unless you want to save this display criteria for all maps.

Removing Chokepoints from the WCS Database and Map

You can remove one or multiple chokepoints at a time.

Follow these steps to delete a chokepoint.

Step 1  Choose Configure > Chokepoints. The All Chokepoints page appears.

Step 2  Check the box(es) next to the chokepoint(s) to be deleted.

Step 3  Choose Remove Chokepoints from the Select a command drop-down menu. Click GO.

Step 4  To confirm chokepoint deletion, click OK in the pop-up window that appears.

You are returned to the All Chokepoints page. A message confirming deletion of the chokepoint appears. The deleted chokepoint(s) is no longer listed on the page.
Monitoring Chokepoints

Chokepoints are installed and configured as recommended by the chokepoint vendor. Chokepoints are added to WCS and placed on floor maps, and then they are pushed to the location server during synchronization. Choose Monitor > Chokepoints to display a list of found chokepoints. Clicking the link under Map Location for a particular chokepoint displays a map that shows the location of the chokepoint. The following parameters are displayed:

- MAC Address—The MAC address of the chokepoint.
- Chokepoint Name—The user-defined name of the chokepoint.
- Entry/Exit Chokepoint—Specifies whether the chokepoint is an entry or exit chokepoint.
- Range—The range of the chokepoint in feet.
- Map Location—A link to a map showing the location of the chokepoint.

Monitoring Maps

This section describes how to use maps to monitor your wireless LANs and predict coverage. You can use maps to do the following:

- Monitoring Predicted Coverage, page 5-44
- Monitoring Transmit Power Levels on a Floor Map, page 5-51
- Monitoring Coverage Holes on a Floor Map, page 5-52
- Monitoring Clients on a Floor Map, page 5-53
- Monitoring Outdoor Areas, page 5-54

In preparation for monitoring your wireless LANs, familiar yourself with the various refresh options for a map.

- Refresh from network—By clicking Refresh Heatmap in the left sidebar menu (see callout 1 in Figure 5-32), you can refresh the map status and statistics directly from the controller through an SNMP fetch rather than polled data from the WCS database that is five to fifteen minutes older.

  Note If you have monitor mode access points on the floor plan, you have a choice between IDS or coverage heatmap types. A coverage heatmap excludes monitor mode access points, and an IDS heatmap includes them.

- Refresh browser—Above the map next to the Logout and Print option is another refresh option (see callout 3 in Figure 5-32). Clicking this refreshes the complete page, or the map and its status and statistics if you are on a map page.

- Load—The Load option in the left sidebar menu refreshes map data from the WCS database on demand (see callout 2 in Figure 5-32). Otherwise, the Refresh option (by the Zoom option on the upper right of the map) provides an interval drop-down menu to set how often to refresh the map data from the database.
Monitoring Maps

All three options refresh the data based on the layer selection.

Monitoring Predicted Coverage

Follow these steps to monitor the predicted wireless LAN coverage on a map.

Step 1  Click Monitor > Maps to display the Maps page.
Step 2  Click an item in the Name column.
Step 3  Click Layers to see a check list of the available layers to view. Choosing some layers results in a popup window to further choose what content gets shown in the map. Those layers with popups are described in the next sections. The layer options are as follows:

- Access Points
- AP Heatmaps
- AP Mesh Info — Displays only if mesh access points are present in outdoor areas.
- Clients — Displays data only if a location server was added in WCS.
- 802.11 Tags
- Rogue APs — Displays data only if a location server was added in WCS.
- Rogue Adhocs — Displays data only if a location server was added in WCS.
- Rogue Clients — Displays only if a location server was added in WCS.
- Grid
• Coverage Areas
• Markers
• Chokepoints — Displays only if chokepoints are added in WCS.

Note
If you click the arrow to the right of these layers, more filter options are provided.

The enabled layers are checked, and the disabled ones are unavailable.

Note
When you mouse over the various locations, a popup with general, 802.11a/n, and 802.11b/g/n data appears. It provides the channel, transmit power level, user count, utilization count, antenna name, antenna angle, and elevation angle (for the 802.11a/n and 802.11b/g/n windows), and access point MAC address, model, controller IP address, location, and height in the General tab.

Access Point Layer

If you enable the Access Point layer and then click on the arrow to the right of these layers, an access point filter window appears with further menu options (see Figure 5-33).

**Figure 5-33 Access Point Layer**

Step 1
From the Protocol drop-down menu, choose one of the following 802.11 protocols to display on the coverage map:

• **802.11a/n & b/g/n**—Displays all the access points in the area.
• **802.11a/n**—Displays a colored overlay depicting the coverage patterns for the 802.11a/n radios. The colors show the received signal strength from red (–35 dBm) through dark blue (–85 dBm).
- **802.11b/g/n**—Displays a colored overlay depicting the coverage patterns for the 802.11b/g/n radios. The colors show the received signal strength from red (–35 dBm) through dark blue (–85 dBm). This is the default value.

**Step 2** From the Display drop-down menu, choose one of the following options to specify the information that appears in the flag next to each access point on the map:

- **Channels**—Shows the Cisco Radio channel number as Ch#{nn}, where nn is the channel number, or shows *Unavailable* for unconnected access points.

- **TX Power Level**—Shows the current Cisco Radio transmit power level as Tx Power n, where n is power level 1 (high) through 5 (low) or shows *Unavailable* for unconnected access points.

- **Coverage Holes**—Shows the percentage of clients whose signal has become weaker until the client lost its connection, shows *Unavailable* for unconnected access points, or shows *MonitorOnly* for access points in Monitor-Only mode.

- **MAC Addresses**—Displays the MAC address of the access point, regardless of whether the access point is associated to a controller.

- **Names**—Displays the access point name. This is the default value.

- **Controller IP**—Displays the IP address of the controller to which the access point is associated or “Not Associated” for disassociated access points.

- **Utilization**—Displays the percentage of bandwidth used by the associated client devices, “Unavailable” for disassociated access points, or “MonitorOnly” for access points in monitor-only mode.

- **Profiles**—Shows the Load, Noise, Interference and Coverage components of the corresponding operator-defined thresholds: *Okay* for thresholds not exceeded, *Issue* for exceeded thresholds, or *Unavailable* for unconnected access points. You must also then specify the profile type as load, noise, interference, or coverage.

- **Users**—Shows the number of Cisco WLAN Solution clients, shows *Unavailable* for unconnected access points, or shows *MonitorOnly* for access points in Monitor-Only mode.

**Step 3** Click OK.

### AP Mesh Info Layer

If you enable the AP Mesh Info layer and then click on the arrow to the right of these layers, a Mesh Parent-Child Hierarchical View window appears with further menu options (see Figure 5-34).
You can update the map view by choosing the access points you want to see on the map. From the Quick Selections drop-down menu, choose to select only root access point, various hops between the first and the fourth, or select all access points.

**Note**  
For a child access point to be visible, its parent must also be selected.

### Clients Layer

If you enable the Clients layer and then click on the arrow to the right of these layers, a Client Filter window appears with further menu options (see Figure 5-35).
If you click the **Show All Clients** check box and **Small Icons** check box, all other drop-down menu options are grayed out.

If you uncheck the **Small Icons** check box, you can choose if the want the label to display MAC address, IP address, user name, asset name, asset group, or asset category.

If you uncheck the **Show All Clients** check box, you can specify how you want the clients filtered and enter a particular SSID.

The Protocol drop-down menu options are as follows:

- **All**—Displays all the access points in the area.
- **802.11a/n**—Displays a colored overlay depicting the coverage patterns for the clients with 802.11a/n radios. The colors show the received signal strength from red (–35 dBm) through dark blue (–85 dBm).
- **802.11b/g/n**—Displays a colored overlay depicting the coverage patterns for the clients with 802.11b/g/n radios. The colors show the received signal strength from red (–35 dBm) through dark blue (–85 dBm). This is the default value.

You can further choose to show clients in all states or specifically idle, authenticated, probing, or associated clients.

### 802.11 Tags Layer

If you enable the 802.11 Tags layer and then click on the arrow to the right of these layers, a Tag Filter window appears with further menu options (see Figure 5-36).
If you click the **Show All Tags** check box and **Small Icons** check box, all other drop-down menu options are grayed out.

If you uncheck the **Small Icons** check box, you can choose if the want the label to display MAC address, asset name, asset group, or asset category.

If you uncheck the **Show All Clients** check box, you can specify how you want the clients filtered.

**Rogue APs Layer**

If you enable the Rogue APs layer and then click on the arrow to the right of these layers, a Rogue AP Filter window appears with further menu options (see **Figure 5-37**).
If you click the Show All Rogue APs check box and Small Icons check box, all other drop-down menu options are grayed out.

If you uncheck the Show All Rogue APs check box, you can specify how you want the rogue access points filtered. Follow these steps to define the filter.

---

**Step 1**
If you want to view a particular MAC address, enter it in the MAC Address field.

**Step 2**
From the State drop-down menu, choose if you want to display rogues in the alert, known, acknowledged, contained, threat, or unknown contained state.

**Step 3**
Specify if you want to display all rogues, access point rogues, or ad hoc rogues.

**Step 4**
Specify whether or not you want to display rogue access points on the network.

**Step 5**
Click OK.

---

**Rogue Clients Layer**

If you enable the Rogue Clients layer and then click on the arrow to the right of these layers, a Rogue Client Filter window appears with further menu options (see Figure 5-38).

---

If you click the Show All Rogue Clients check box and Small Icons check box, all other drop-down menu options are grayed out.

If you uncheck the Show All Rogue Clients check box, you can specify how you want the rogue clients filtered. Follow these steps to define the filter.

---

**Step 1**
Provide the MAC address of an associated rogue access point.
Step 2 Specify if you want to display all rogue clients or those in the alert, contained, or threat state.

Monitoring Channels on a Floor Map

Follow these steps to monitor channels on a floor map.

Step 1 Click Monitor > Maps to display the Maps page.
Step 2 Click an item in the Name column.
Step 3 Click > Layers.

Note When you mouse over the various locations, a popup with general, 802.11a/n, and 802.11b/g/n data appears. It provides the channel, transmit power level, user count, utilization count, antenna name, antenna angle, and elevation angle (for the 802.11a/n and 802.11b/g/n windows), and access point MAC address, model, controller IP address, location, and height in the General tab.

Step 4 Click the Access Points check box.
Step 5 Click the > beside Access Point.
Step 6 From the Display drop-down menu, choose Channels.

The number of the channel being used by each radio appears in the flag next to each access point. “Unavailable” appears for disassociated access points.


Monitoring Transmit Power Levels on a Floor Map

Follow these steps to monitor transmit power levels on a floor map.

Step 1 Click Monitor > Maps to display the Maps page.
Step 2 Click an item in the Name column.
Step 3 Click Layers.

Note When you mouse over the various locations, a popup with general, 802.11a/n, and 802.11b/g/n data appears. It provides the channel, transmit power level, user count, utilization count, antenna name, antenna angle, and elevation angle (for the 802.11a/n and 802.11b/g/n windows), and access point MAC address, model, controller IP address, location, and height in the General tab.
Step 4  Click the Access Point check box.
Step 5  Click the arrow beside Access Point.
Step 6  Choose Tx Power Level from the Display drop-down menu.
Step 7  The number of the transmit power level being used by each radio appears in the flag next to each access point. “Unavailable” appears for disassociated access points.

Table 5-4 lists the transmit power level numbers and their corresponding power settings:

<table>
<thead>
<tr>
<th>Transmit Power Level Number</th>
<th>Power Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Maximum power allowed per country code setting</td>
</tr>
<tr>
<td>2</td>
<td>50% power</td>
</tr>
<tr>
<td>3</td>
<td>25% power</td>
</tr>
<tr>
<td>4</td>
<td>12.5 to 6.25% power</td>
</tr>
<tr>
<td>5</td>
<td>6.25 to 0.195% power</td>
</tr>
</tbody>
</table>


Monitoring Coverage Holes on a Floor Map

*Coverage holes* are areas in which clients cannot receive a signal from the wireless network. When you deploy a wireless network, you must consider the cost of the initial network deployment and the percentage of coverage hole areas. A reasonable coverage hole criterion for launch is between 2 and 10 percent. This means that between two and ten test locations out of 100 random test locations might receive marginal service. After launch, Cisco Unified Wireless Network Solution radio resource management (RRM) identifies these coverage hole areas and reports them to the IT manager, who can fill holes based on user demand.

Follow these steps to monitor coverage holes on a floor map.

Step 1  Click Monitor > Maps to display the Maps page.
Step 2  Click an item in the Name column.
Step 3  Click Layers.

Note  When you mouse over the various locations, a popup with general, 802.11a/n, and 802.11b/g/n data appears. It provides the channel, transmit power level, user count, utilization count, antenna name, antenna angle, and elevation angle (for the 802.11a/n and 802.11b/g/n windows), and access point MAC address, model, controller IP address, location, and height in the General tab.

Step 4  Click the Access Points check box.
Step 5 Click the arrow beside Access Point.
Step 6 Choose Coverage Holes from the Display drop-down menu.

The percentage of clients that have lost their connection to the wireless network appears in the flag next to each access point. “Unavailable” appears for disassociated access points, and “MonitorOnly” appears for access points in monitor-only mode.

---

**Monitoring Clients on a Floor Map**

Follow these steps to monitor client devices on a floor map.

---

**Step 1** Click Monitor > Maps to display the Maps page.

**Step 2** Click an item in the Name column.

**Step 3** Click Layers.

---

**Note** When you mouse over the various locations, a popup with general, 802.11a/n, and 802.11b/g/n data appears. It provides the channel, transmit power level, user count, utilization count, antenna name, antenna angle, and elevation angle (for the 802.11a/n and 802.11b/g/n windows), and access point MAC address, model, controller IP address, location, and height in the General tab.

---

**Step 4** Click the Access Points check box.

**Step 5** Click the arrow beside Access Point.

**Step 6** Choose Users from the Display drop-down menu.

The number of client devices associated to each radio appears in the flag next to each access point. “Unavailable” appears for disassociated access points, and “MonitorOnly” appears for access points in monitor-only mode.

**Step 7** Click the number of clients to display a list of specific client devices and parameters. Table 5-5 lists the parameters that appear.
### Monitoring Maps

#### Monitoring Outdoor Areas

Follow these steps to add outdoor areas to a campus.

**Step 1** Choose Monitor > Maps.

**Step 2** Click a campus name in the Name column. Verify in the Type column that it is a campus and not a building, floor area, or outdoor area.

**Step 3** From the Select a command drop-down menu, choose **New Outdoor Area** and click GO.

**Step 4** Enter the user-defined name of the new outdoor area.

**Step 5** Provide a contact name.

**Step 6** Use the drop-down menu to choose what type of structures exist in this area. You can choose cubes and walled offices, drywall office only, or outdoor open space.

**Step 7** Enter the height in feet where the access point is mounted.

**Step 8** Enter the name of the file containing the outdoor area map or use the Browse button to locate the file. Click Next to continue with the new outdoor area process.

**Step 9** A blue rectangle appears in the upper right-hand corner, superimposed on the map of the campus. Using the mouse, drag this rectangle to the desired outdoor location. To resize the blue rectangle, use Ctrl+Left+Click.

**Step 10** The name and contact information carries over to this window. Use the zoom to get a different view of the map.

**Step 11** Click the Maintain Image Aspect Ratio check box if you want to maintain the ratio of horizontal and vertical pixels of the map image. Maintaining the aspect ratio prevents visual distortion of the map.

### Table 5-5 Client Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User</td>
<td>The username of the client</td>
</tr>
<tr>
<td>Vendor</td>
<td>The manufacturer of the client</td>
</tr>
<tr>
<td>IP Address</td>
<td>The IP address of the client</td>
</tr>
<tr>
<td>MAC Address</td>
<td>The MAC address of the client</td>
</tr>
<tr>
<td>Access Point</td>
<td>The name of the access point to which the client is associated</td>
</tr>
<tr>
<td>Controller</td>
<td>The IP address of the controller to which the access point is connected</td>
</tr>
<tr>
<td>Port</td>
<td>The port number of the controller to which the access point is connected</td>
</tr>
<tr>
<td>802.11 State</td>
<td>Indicates whether the client is associated or disassociated</td>
</tr>
<tr>
<td>SSID</td>
<td>The service set identifier (SSID) being broadcast by the access point</td>
</tr>
<tr>
<td>Authenticated</td>
<td>Indicates whether authentication is enabled or disabled</td>
</tr>
<tr>
<td>Protocol</td>
<td>Indicates whether the 802.11a/n or 802.11b/g/n protocol is being used</td>
</tr>
</tbody>
</table>
Step 12  Enter the horizontal distance from the corner of the outdoor area rectangle to the left edge of the campus map in feet or meters.

Step 13  Enter the vertical distance from the corner of the outdoor area rectangle to the top edge of the campus map in feet or meters.

Step 14  Enter the left to right horizontal span of the outdoor area rectangle in feet or meters.

Step 15  Enter the up and down vertical span of the outdoor area rectangle in feet or meters.

Note  To change the unit of measurement (feet or meters), choose Monitor > Maps and then choose Properties from the Select a command drop-down menu and click GO. The first drop-down menu on the Maps > Properties window allows you to choose between feet or meters as a unit of dimension.

Step 16  Choose Place to fix the changes on the display or Save to add them to the database.

Importing or Exporting WLSE Map Data

When converting from autonomous to LWAPP and from WLSE to WCS, one of the conversion steps is to manually re-enter the access point-related information into WCS. This can be a time-consuming step. To speed up the process, you can export the information about access points from WLSE and import it into WCS.

Note  WCS expects a .tar file and checks for a .tar extension before importing the file. If the file you are trying to import is not a .tar file, WCS displays an error message and prompts you to import a different file.

To map properties and import a tar file containing WLSE data using the WCS web interface, follow these steps. For more information on the WLSE data export functionality (WLSE version 2.15), see http://<WLSE_IP_ADDRESS>:1741/debug/export/exportSite.jsp.

Step 1  Choose Monitor > Maps.

Step 2  Choose Properties from the Select a command drop-down menu and click GO.

Step 3  In the Import Map and AP Location section, click Browse to select the file to import.

Step 4  Find and select the .tar file to import and click Open.

WCS displays the name of the file in the Import From field (see Figure 5-39).
Step 5  Click **Import**.

WCS uploads the file and temporarily saves it into a local directory while it is being processed. If the file contains data that cannot be processed, WCS prompts you to correct the problem and retry. After the file has been loaded, WCS displays a report of what will be added to WCS (see Figure 5-40). The report also specifies what cannot be added and why.
If some of the data to be imported already exists, WCS either uses the existing data in the case of campuses or overwrites the existing data using the imported data in the cases of buildings and floors (see Figure 5-41).

Figure 5-41       Pre Execute Import Report — Duplicate Data Handling
Creating and Applying Calibration Models

If the provided RF models do not sufficiently characterize the floor layout, you can create a calibration model that is applied to the floor and better represents the attenuation characteristics of that floor. In environments in which many floors share common attenuation characteristics (such as in a library), one calibration model can be created and then applied to floors with the same physical layout and same deployment.
The calibration models are used as RF overlays with measured RF signal characteristics that can be applied to different floor areas. This enables the Cisco WLAN solution installation team to lay out one floor in a multi-floor area, use the RF calibration tool to measure, save the RF characteristics of that floor as a new calibration model, and apply that calibration model to all the other floors with the same physical layout.

You can collect data for a calibration using one of two methods:

- **Data point collection**—Calibration points are chosen and their coverage area is calculated one location at a time.
- **Linear point collection**—A series of linear paths are chosen and then calculated as you traverse the path. This approach is generally faster than the data point collection. You can also employ data point collection to augment data collection for locations missed by the linear paths.

**Note**
A client device that supports both 802.11a/n and 802.11b/g/n radios is recommended to expedite the calibration process for both spectrums.

Use a laptop or other wireless device to open a browser to the WCS server and perform the calibration process.

**Step 1** Navigate to **Monitor > Maps** and choose **RF Calibration Models** from the Select a command drop-down menu. Click **GO**.

**Step 2** Choose **Create New Model** from the Select a command drop-down menu. Click **GO**.

**Step 3** Assign a name to the model and click **OK**.

**Step 4** The new model appears along with the other RF calibration models, but its status is listed as Not Yet Calibrated. To start the calibration process, click on the hyperlink associated with the new model name. A new window appears which indicates the details of the new model. In the upper right-hand corner, choose **Add Data Points** from the Select a command drop-down menu and click **GO**.

**Step 5** If this process is being performed from a mobile device connected to WCS through the Cisco Centralized architecture, the MAC address field is automatically populated with the device’s address. Otherwise, you can manually enter the MAC address of the device being used to perform the calibration. MAC addresses that are manually entered must be delimited with colons (such as FF:FF:FF:FF:FF:FF).

**Step 6** Choose the appropriate campus, building, and floor where the calibration is performed (see **Figure 5-43**). Click **Next**.
Step 7  When the chosen floor map and access point locations display, a grid of plus marks (+) indicates the locations where data collection for calibration is performed.

Using these locations as guidelines, you can perform either a point or linear collection of data by appropriate placement of either the Calibration Point pop-up (point) or the Start and Finish pop-ups (linear) that display on the map when the respective options are displayed. Figure 5-44 shows the starting window for a point calibration.
a. If you want to do a point collection of data for the calibration, do the following:

1. Choose **Point** from the Collection method drop-down menu and check the **Show Data points** check box if not already checked. A calibration point pop-up displays on the map.

2. Position the tip of the calibration point pop-up at a data point (+) and click **GO**. A panel appears showing the progress of the data collection.

   **Note**  
   Rotate the calibrating client laptop during data collection so that the client is heard evenly by all access points in the vicinity.

3. When the data collection is complete for a selected data point and the coverage area is plotted on the map, move the calibration point pop-up to another data point and click **GO**.

   **Note**  
   The coverage area plotted on the map is color-coded and corresponds with the specific wireless LAN standard used to collect that data. Information on color-coding is provided in the legend on the left-hand side of the window. Additionally, the progress of the calibration process is indicated by two status bars above the legend, one for 802.11a/n and one for 802.11b/g/n.

   **Note**  
   To delete data points for locations selected in error, click **Delete** and move the black square that appears over the appropriate data points. Resize the square as necessary by pressing **Ctrl** and moving the mouse.

4. Repeat steps a1 to a3 until the calibrations status bar of the relevant spectrums (802.11a/n, 802.11b/g/n) display as **done**.
b. If you want to do a linear collection of data for the calibration, do the following:

1. Choose **Linear** from the Collection Method drop-down menu and check the **Show Data** points checkbox if not already checked. A line appears on the map with both Start and Finish pop-ups.
2. Position the tip of the Start pop-up at the starting data point.
3. Position the Finish pop-up at the ending data point.
4. Position yourself with your laptop at the starting data point and click **GO**. Walk steadily towards the end point along the defined path. A panel displays to show that data collection is in process.

   **Note**
   Do not stop data collection until you reach the end point even if the data collection bar indicates completion.

5. Press the space bar (or **Done** on the data collection panel) when you reach the end point. The collection panel displays the number of samples taken before it closes to reveal the map. The map displays all the coverage areas where data was collected (see Figure 5-45).

   **Note**
   To delete data points for locations selected in error, click **Delete** and move the black square that appears over the appropriate data points. Resize the square as necessary by pressing **Ctrl** and moving the mouse.
Figure 5-45  Linear Data Collection

The coverage area is color-coded and corresponds with the specific wireless LAN standard used to collect that data. Information on color-coding is provided in the legend on the left-hand side of the window.

6. Repeat Steps b2 to b5 until the status bar for the respective spectrum is filled in (done).

Note You can augment linear collection with data point collection to address missed coverage areas.

Step 8 Click on the name of the calibration model at the top of the window to return to the main screen for that model. You can then calibrate the data points.

Step 9 Choose Calibrate from the Select a command drop-down menu and click GO.

Step 10 Click the Inspect Location Quality link when calibration completes. A map displays showing RSSI readings.

Step 11 To use the newly created calibration model, you must apply the model to the floor on which it was created (and on any other floors with similar attenuation characteristics as well). Navigate to Monitor > Maps and find the specific floor to which the model is applied. At the floor map interface, choose Edit Floor Area from the drop-down menu and click GO.

Step 12 From the Floor Type (RF Model) drop-down menu, choose the newly created calibration model. Click OK to apply the model to the floor.
Analyzing Element Location Accuracy Using Testpoints

You can analyze the location accuracy of rogue and non-rogue clients and asset tags by entering testpoints on an area or floor map. You can use this feature to validate location information generated either automatically by access points or manually by calibration.

Note
By checking for location accuracy, you are checking the ability of the existing access point deployment to estimate the true location of an element within 10 meters at least 90% of the time.

Note
Before starting this process, record the MAC addresses and locations for all elements within the area or floor to be analyzed. You need this information when placing the testpoints on the map. If analyzing location after calibration, you should analyze the location accuracy of at least as many elements entered during calibration.

Note
The Advanced Debug option must be enabled on both the location appliance and WCS to allow use of the location accuracy testpoint feature.

Follow these steps to enable the advanced debug option and assign testpoints to a floor map to check location accuracy.

Step 1
Choose Location > Location Servers.

Step 2
Select a server from the All Location Servers page that appears.

Step 3
Select Advanced Parameters from the Administration menu of the Location Server General Properties page (see Figure 5-46).
Step 4  On the page that appears, scroll down to the Advanced Parameters section. Check the **Advanced Debug** box to enable the feature. Click **Save**.

**Note**  If the **Advanced Debug** check box is already checked, you do not need to do anything further. Click **Cancel**.

### Assigning Testpoints to a Selected Area

You now must enable the Advanced debug level at the Maps level and begin assigning testpoints to a selected area or map.

**Step 1**  Choose **Monitor > Maps**.

**Step 2**  Select **Properties** from the Select a command drop-down menu.
Step 3  On the Maps > Properties page (see Figure 5-47), select Enable from the Advanced Debug drop-down menu. Click OK.

Figure 5-47  Map > Properties Page

You are returned to the Maps summary window. You are now ready to assign testpoints to a selected area or map.

Step 4  Choose Monitor > Maps. Select the area or floor you want to analyze from the map summary that appears.

The page seen in Figure 5-48 appears.
Step 5  Select **Position TestPoint** from the Select a command drop-down menu (top-right). Click **GO**.

A blank map of the selected area or floor appears for testpoint assignment (see Figure 5-49).

**Figure 5-49  Position TestPoint Assignment Page**

Step 6  On the Position Test Point page, select the location server from the drop-down menu and choose a MAC address from the list of MAC addresses (for clients, tags, rogue access point, rogue clients, and so on).
Using the Accuracy Tool to Conduct Accuracy Testing

There are two methods of conducting location accuracy testing:

- Scheduled Accuracy Testing—Employed when clients and tags are already deployed and associated to the wireless LAN infrastructure. Scheduled tests can be configured and saved when clients and tags are already pre-positioned so that the test can be run on a regularly scheduled basis.

- On demand Accuracy Testing—Employed when elements are associated but not pre-positioned. On demand testing allows you to test the location accuracy of clients and tags at a number of different locations. It is generally used to test the location accuracy for a small number of clients and tags.

Both are configured and executed through a single window.

Note

The Advanced Debug option must be enabled in Cisco WCS to allow use of both the Scheduled and On-demand location accuracy testing features.

Follow these steps to enable the advanced debug option in Cisco WCS.

Step 1

In Cisco WCS, click Monitor > Maps.

Step 2

Choose Properties from the Select a command drop-down menu and click GO.
Using the Accuracy Tool to Conduct Accuracy Testing

Step 3 Choose Enabled from the Advanced Debug drop-down menu. Click OK.

- **Note** If Advanced Debug is already enabled, you do not need to do anything further. Click Cancel.

You can now run location accuracy tests on the location appliance using the Accuracy Tool.

Using Scheduled Accuracy Testing to Verify Accuracy of Current Location

To configure a scheduled accuracy test, do the following:

**Step 1** Click Tools > Accuracy Tool.

**Step 2** Choose New Scheduled Accuracy Test from the Select a command drop-down menu.

**Step 3** Enter a test name.

**Step 4** Choose the area type from the drop-down menu.

- **Note** Campus is configured as root area, by default. There is no need to change this setting.

**Step 5** Choose the building from the drop-down menu.

**Step 6** Choose the floor from the drop-down menu.

**Step 7** Choose the begin and end time of the test by entering the days, hours, and minutes. Hours are entered using a 24-hour clock.

- **Note** When entering the test start time, be sure to allow enough time prior to the test start to position testpoints on the map.

**Step 8** You should e-mail the report or download the test results from the Accuracy Tests > Results window because the data in the Results tab is only stored for seven days. Reports are in PDF format.

- **Note** Only the entries for the last seven days appear in the Results window. After seven days, the Results tab disappears.

- **Note** If you select the e-mail option, a SMTP Mail Server must first be defined for the target e-mail address. Click Administrator > Settings > Mail Server to enter the appropriate information.

**Step 9** Click Position Testpoints. The floor map appears with a list of all clients and tags on that floor with their MAC addresses.

**Step 10** Click the check box next to each client and tag for which you want to check the location accuracy.

- When you check a MAC address check box, two icons overlaying each other appear on the map. One icon represents the actual location and the other the reported location.
Using the Accuracy Tool to Conduct Accuracy Testing

Note To enter a MAC address for a client or tag that is not listed, check the Add New MAC check box and enter the MAC address and click GO. An icon for the element appears on the map. If the newly added element is on the location server but on a different floor, the icon appears in the left-most corner (0, 0 position).

Step 11 If the actual location for an element is not the same as the reported location, drag the actual location icon for that element to the correct position on the map. Only the actual location icon can be dragged.

Step 12 Click Save when all elements are positioned. A panel appears confirming successful accuracy testing.

Step 13 Click OK to close the confirmation panel. You are returned to the Accuracy Tests summary window.

Note The accuracy test status displays as Scheduled when the test is about to execute. A status of Running appears when the test is in process and Idle when the test is complete. A Failure status appears when the test is not successful.

Step 14 To view the results of the location accuracy test, click the test name and then choose the Results tab on the page that appears.

Step 15 At the Results panel, click the Download link under the Saved Report heading to view the report.

The Scheduled Location Accuracy Report includes the following information:

- A summary location accuracy report that details the percentage of elements that fall within various error ranges.
- An error distance histogram
- A cumulative error distribution graph
- An error distance over time graph
- A summary of each MAC address whose location accuracy was tested noting its actual location and error distance, and a map showing its spatial accuracy (actual vs. calculated location) and error distance over time for each MAC.

Using On-Demand Accuracy Testing to Test Location Accuracy

An on-demand accuracy test is run when elements are associated but not pre-positioned. On-demand testing allows you to test the location accuracy of clients and tags at a number of different locations. It is generally used to test the location accuracy for a small number of clients and tags.

Follow these steps to run an on-demand accuracy test.

Step 1 Click Tools > Accuracy Tool.
Step 2 Choose New On demand Accuracy Test from the Select a command drop-down menu.
Step 3 Enter a test name.
Step 4 Choose the area type from the drop-down menu.
   Campus is configured as root area, by default. There is no need to change this setting.
Step 5 Choose the building from the drop-down menu.
Step 6 Choose the floor from the drop-down menu.

Step 7 Tests results are viewed at the Accuracy Tests > Results window. Reports are in .pdf format.

Step 8 Click Position Testpoints. The floor map appears with a red cross hair at the (0,0) coordinate.

Step 9 To test the location accuracy and RSSI of a particular location, choose either client or tag from the drop-down menu on the left. A list of all MAC addresses for the selected option (client or tag) appears in a drop-down menu to its right.

Step 10 Choose a MAC address from the drop-down menu and move the red cross hair to a map location and click the mouse to place it.

Step 11 Click Start to begin collection of accuracy data.

Step 12 Click Stop to finish collection. You should allow the test to run for at least two minutes before clicking Stop.

Step 13 Repeat Step 9 to Step 12 for each testpoint that you want to plot on the map.

Step 14 Click Analyze when you are finished mapping the testpoints.

Step 15 Choose the Results tab on the panel that appears.

The On-demand Accuracy Report includes the following information:
- A summary location accuracy report that details the percentage of elements that fell within various error ranges.
- An error distance histogram
- A cumulative error distribution graph

Note
You can download logs for accuracy tests from the Accuracy Tests summary page.

To do so, check the listed test check box and select either Download Logs or Download Logs for Last Run from the Select a command drop-down menu and click GO.

The Download Logs option downloads the logs for all accuracy tests for the selected test(s).

The Download Logs for Last Run option downloads logs for only the most recent test run for the selected test(s).
Chapter 5  Adding and Using Maps

Using the Accuracy Tool to Conduct Accuracy Testing
Monitoring Wireless Devices

This chapter describes how to use WCS to monitor your wireless LANs. It contains these sections:

- Monitoring Rogue Access Points, Adhocs, and Clients, page 6-2
- Rogue Access Point Location, Tagging, and Containment, page 6-12
- Monitoring Clients, page 6-15
- WLAN Client Troubleshooting, page 6-16
- Finding Clients, page 6-30
- Receiving Radio Measurements, page 6-34
- Monitoring Mesh Networks Using Maps, page 6-35
- Mesh Statistics for an Access Point, page 6-44
- Viewing the Mesh Network Hierarchy, page 6-49
- Viewing Google Earth Maps, page 6-52
- Viewing Clients Identified as WGBs, page 6-54
- Running a Link Test, page 6-55
- Retrieving the Unique Device Identifier on Controllers and Access Points, page 6-57
- Coverage Hole, page 6-60
- Viewing DHCP Statistics, page 6-62
Monitoring Rogue Access Points, Adhocs, and Clients

Because unauthorized rogue access points are inexpensive and readily available, employees sometimes plug them into existing LANs and build ad hoc wireless networks without IT department knowledge or consent. These rogue access points can be a serious breach of network security because they can be plugged into a network port behind the corporate firewall. Because employees generally do not enable any security settings on the rogue access point, it is easy for unauthorized users to use the access point to intercept network traffic and hijack client sessions. Even more alarming, wireless users frequently publish unsecure access point locations, increasing the odds of having the enterprise security breached.

 Rather than having a person with a scanner manually detect rogue access points, the Cisco Unified Wireless Network Solution automatically collects information on rogue access points detected by its managed access points (by MAC and IP address) and allows the system operator to locate, tag, and contain them. It can also be used to discourage rogue access point clients by sending them deauthenticate and disassociate messages from one to four access points.

Interpreting Security Summary Window

You can see a summary of existing events and the security state of the network by choosing Monitor > Security. The Security Summary window appears (see Figure 6-1).
Figure 6-1 Security Summary Window

The Security Summary window provides rogue access point information in the following sections:

- **Malicious Rogue Access Points**
- **Friendly Rogue Access Points**
- **Unclassified Rogue Access Points**
- **Rogue Adhocs**
Malicious Rogue Access Points

This section provides information on rogue access points that are classified as *Malicious*.

**Note** Malicious access points are detected but untrusted or unknown access points with a malicious intent within the system. They also refer to access points that fit the user-defined malicious rules or have been manually moved from the friendly access point classification.

Table 6-1 describes the various parameters. For each of these parameters, a value is provided for last hour, last 24 hours, and all. If you click an underlined number in any of the time period categories, a window with further information appears.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alert</td>
<td>Indicates the number of rogues in an alert state.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> An access point is moved to Alert if it is not on the neighbor list or part of the user-configured Friendly AP list.</td>
</tr>
<tr>
<td>Contained</td>
<td>Indicates the number of contained rogues.</td>
</tr>
<tr>
<td>Threat</td>
<td>Indicates the number of threat rogues.</td>
</tr>
<tr>
<td>Contained Pending</td>
<td>Indicates the number of contained rogues pending.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Contained Pending indicates that the containment action is delayed due to unavailable resources.</td>
</tr>
<tr>
<td>802.11a/n5.0</td>
<td>Indicates the number of rogue access points broadcasting on 802.11a.</td>
</tr>
<tr>
<td>802.11b/g/n2.4</td>
<td>Indicates the number of rogue access points broadcasting one or both of the 802.11b and 802.11g protocols.</td>
</tr>
<tr>
<td>On Network</td>
<td>Indicates the number of rogue access points on the same subnet as the detecting port.</td>
</tr>
<tr>
<td>Off Network</td>
<td>Indicates the number of rogue access points NOT on the same subnet as the detecting port.</td>
</tr>
</tbody>
</table>

Friendly Rogue Access Points

This section provides information on rogue access points that are classified as *friendly*. 
Note
Friendly rogue access points are known, acknowledged, or trusted access points. They also refer to access points that fit the user-defined friendly rogue access point rules. Friendly rogue access points cannot be contained.

Table 6-2 describes the various parameters. For each of these parameters, a value is provided for last hour, last 24 hours, and all. If you click an underlined number in any of the time period categories, a window with further information appears.

<table>
<thead>
<tr>
<th>Table 6-2</th>
<th>Friendly Rogue AP Details</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Parameter</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>Alert</td>
<td>Indicates the number of rogues in an alert state.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>An access point is moved to Alert if it is not on the neighbor list or part of the user-configured Friendly AP list.</td>
</tr>
<tr>
<td>Internal</td>
<td>Indicates the number of internal access points.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>Internal indicates that the detected access point is inside the network and has been manually configured as Friendly - Internal.</td>
</tr>
<tr>
<td>External</td>
<td>Indicates the number of external access points.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>External indicates that the detected access point is outside of the network and has been manually configured as Friendly - External.</td>
</tr>
<tr>
<td>802.11a/n5.0</td>
<td>Number of rogue access points broadcasting on 802.11a.</td>
</tr>
<tr>
<td>802.11b/g/n2.4</td>
<td>Number of rogue access points broadcasting one or both of the 802.11b and 802.11g protocols.</td>
</tr>
</tbody>
</table>

Unclassified Rogue Access Points

This section provides information on rogue access points that are not classified.

Note
An unclassified rogue access point refers to a rogue access point that is not classified as either malicious or friendly. These access points can be contained and can be moved manually to the friendly rogue access point list.

Table 6-3 describes the various parameters. For each of these parameters, a value is provided for last hour, last 24 hours, and all. If you click an underlined number in any of the time period categories, a window with further information appears.
Monitoring Rogue Access Points, Adhocs, and Clients

Table 6-3  Unclassified Rogue

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alert</td>
<td>Number of unclassified rogues in alert state. Rogue access point radios appear as Alert when first scanned by the controller or as Pending when operating system identification is underway.</td>
</tr>
<tr>
<td>Contained</td>
<td>Number of contained unclassified rogues.</td>
</tr>
<tr>
<td>Contained Pending</td>
<td>Number of contained unclassified rogues pending.</td>
</tr>
<tr>
<td>802.11a/n5.0</td>
<td>Number of unclassified rogue access points broadcasting on 802.11a/n.</td>
</tr>
<tr>
<td>802.11b/g/n2.4</td>
<td>Number of unclassified rogue access points broadcasting on 802.11b/n and/or 802.11g/n.</td>
</tr>
</tbody>
</table>

Rogue Adhocs

This section provides information on rogue adhocs. Table 6-4 describes the various parameters. For each of these parameters, a value is provided for last hour, last 24 hours, and all. If you click an underlined number in any of the time period categories, a window with further information appears.

Table 6-4  Rogue Adhocs

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alert</td>
<td>Indicates the number of rogue adhocs in an alert state.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> An access point is moved to Alert if it is not on the neighbor list or part of the user-configured Friendly AP list.</td>
</tr>
<tr>
<td>Contained</td>
<td>Indicates the number of contained rogues.</td>
</tr>
<tr>
<td>Threat</td>
<td>Indicates the number of threat rogues.</td>
</tr>
<tr>
<td>Contained Pending</td>
<td>Indicates the number of contained rogues pending.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Contained pending indicates that the containment action is delayed due to unavailable resources.</td>
</tr>
<tr>
<td>802.11a/n5.0</td>
<td>Indicates the number of rogue access points broadcasting on 802.11a.</td>
</tr>
<tr>
<td>802.11b/g/n2.4</td>
<td>Indicates the number or rogue access points broadcasting one or both of the 802.11b and 802.11g protocols.</td>
</tr>
<tr>
<td>On Network</td>
<td>Indicates the number of rogue access points on the same subnet as the detecting port.</td>
</tr>
<tr>
<td>Off Network</td>
<td>Indicates the number of rogue access points NOT on the same subnet as the detecting port.</td>
</tr>
</tbody>
</table>
Most Recent Security Alerts

This section displays information about the most recent security alerts.

- **Failure Object**—Affected device type, name and MAC address. Click the title to toggle between ascending and descending order. Click a list item to display parameter details.
- **Date/Time**—Time of the day when the event occurred.
- **Message**—Informational message explaining why the event occurred.

Most Recent Malicious Rogue Access Points

This section provides information on the most recently reported malicious rogue access points.

- **MAC Address**—Media Access Control address of the rogue access point.

**Tip**

Hold your mouse cursor over the MAC address of a rogue access point to view a summary of the access point. Click the MAC address of a rogue access point to view complete details.

- **SSID**—Service Set Identifier being broadcast by the rogue access point radio.
- **State**—Radio state relative to the network or port. Rogue access point radios appear as *Alert* when first scanned by the port or as *Pending* when operating system identification is still underway.
- **Date/Time**—The date and time the rogue access point appeared.

Most Recent Rogue Adhocs

This section provides information on the most recently reported rogue adhocs.

**Tip**

Hold your mouse cursor over the MAC address of a rogue adhoc to view a summary of the access point. Click the MAC address of a rogue adhoc to view complete details.

- **SSID**—Service Set Identifier being broadcast by the rogue adhoc radio.
- **State**—Radio state relative to the network or port. Rogue adhoc radios appear as *Alert* when first scanned by the port or as *Pending* when the operating system identification is still underway.
- **Date/Time**—The date and time the rogue adhoc appeared.

Signature Attacks

Signature attacks reflect network patterns that indicate a possible virus or hacker attack. When an attack occurs, the signature attack table is updated immediately. The table displays information on attack type, number of attacks during the last one hour, number of attacks during the last 24 hours, and the total active attacks. You can use this information to assess the security state or security threats to the network.

Click an underlined number in a time period category to display the *Alarms* page. This page displays the list of critical alarms related to signature attacks.
Access Point Threats / Attacks

Table 6-5 describes the AP Threats/Attacks parameters. For each of these parameters, a value is provided for last hour, last 24 hours, and all. If you click an underlined number in any of the time period categories, a window with further information appears.

Table 6-5  AP Threats/Attacks

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fake Attacks</td>
<td>Number of fake attacks</td>
</tr>
<tr>
<td>AP Missing</td>
<td>Number of missing access points</td>
</tr>
<tr>
<td>AP Impersonation</td>
<td>Number of access point impersonations</td>
</tr>
<tr>
<td>AP Invalid SSID</td>
<td>Number of invalid access point SSIDs</td>
</tr>
<tr>
<td>AP Invalid Preamble</td>
<td>Number of invalid access point preambles</td>
</tr>
<tr>
<td>AP Invalid Encryption</td>
<td>Number of invalid access point encryption</td>
</tr>
<tr>
<td>AP Invalid Radio Policy</td>
<td>Number of invalid access point radio policies</td>
</tr>
<tr>
<td>Denial of Service (NAV related)</td>
<td>Number of Denial of Service (NAV related) request</td>
</tr>
<tr>
<td>AP Detected Duplicate IP</td>
<td>Number of detected duplicate access point IPs</td>
</tr>
</tbody>
</table>

Client Security Related

For each of these parameters, a value is provided for last hour, last 24 hours, and all. If you click an underlined number in any of the time period categories, a window with further information appears.

- Excluded Client Events
- WEP Decrypt Errors
- WPA MIC Errors
- Shunned Clients

IPSEC Failures

A value is provided for last hour, last 24 hours, and all. If you click an underlined number in any of the time period categories, a window with further information appears.

Monitoring Rogue Access Point

If you choose Rogue APs from the left sidebar menu (of the Monitor > Security page), the Rogue AP Alarms window appears (see Figure 6-2). This window allows you to view alarm details and messages regarding any anomalies with the controllers and access points.
## Chapter 6  Monitoring Wireless Devices

### Monitoring Rogue Access Points, Adhocs, and Clients

![Figure 6-2  Rogue AP Alarms](image)

<table>
<thead>
<tr>
<th>Device ID</th>
<th>MAC Address</th>
<th>Description</th>
<th>Location</th>
<th>Status</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>01:00:11:22:33:44</td>
<td>00:11:22:33:44:55</td>
<td>Rogue AP</td>
<td>Central Lobby</td>
<td>Active</td>
<td>None</td>
</tr>
</tbody>
</table>

**Note:** The table above lists the rogue APs, adhocs, and clients detected by the Wireless Control System. Each entry includes the device ID, MAC address, description, location, status, and action. The status can be either active or inactive, and the action can be left as none or specified as necessary.
Monitoring Rogue Adhoc

If you choose Rogue Adhocs from the left sidebar menu (of the Monitor > Security page), the Rogue Adhoc Alarms window appears (see Figure 6-3). On this window you can view details of rogue adhoc alarms.

**Figure 6-3  Rogue Adhoc Alarms Window**

Monitoring Rogue Clients

If you choose Rogue Clients from the left sidebar menu (of the Monitor > Security page), the Rogue Clients window appears (see Figure 6-4). You can select search criteria in the left sidebar menu and then details about the rogue clients that are found is displayed.
Monitoring Rogue Access Points, Adhocs, and Clients

Monitoring Shunned Clients

When a Cisco IPS sensor on the wired network detects a suspicious or threatening client, it alerts the controller to shun this client. If the client to be shunned is currently associated to an access point and controller in a mobility group:

1. The shun entry is distributed to all controllers within the same mobility group.
2. The anchor controller adds this client to the dynamic exclusion list.
3. The foreign controller removes the client.

The next time the client tries to connect to a controller, the anchor controller rejects the handcuff and informs the foreign controller that the client is being excluded.

Choose Monitor > Security from the left sidebar menu and select Shunned Clients to access this window (see Figure 6-5).
Rogue Access Point Location, Tagging, and Containment

This built-in detection, tagging, monitoring, and containment capability enables system administrators to take appropriate action:

- Locate rogue access points
- Receive new rogue access point notifications, eliminating hallway scans
- Monitor unknown rogue access points until they are eliminated or acknowledged
- Determine the closest authorized access point, making directed scans faster and more effective
- Contain rogue access points by sending their clients deauthenticate and disassociate messages from one to four access points. This containment can be done for individual rogue access points by MAC address or can be mandated for all rogue access points connected to the enterprise subnet.
- Tag rogue access points:
  - Acknowledge rogue access points when they are outside of the LAN and do not compromise the LAN or wireless LAN security
  - Accept rogue access points when they do not compromise the LAN or wireless LAN security
  - Tag rogue access points as unknown until they are eliminated or acknowledged
- Tag rogue access points as contained and discourage clients from associating with the rogue access points by having between one and four access points transmit deauthenticate and disassociate messages to all rogue access point clients. This function applies to all active channels on the same rogue access point.

Detecting and Locating Rogue Access Points

When the access points on your wireless LAN are powered up and associated with controllers, WCS immediately starts listening for rogue access points. When a controller detects a rogue access point, it immediately notifies WCS, which creates a rogue access point alarm.

When WCS receives a rogue access point message from a controller, an alarm monitor appears in the lower left corner of all WCS user interface pages. The alarm monitor in Figure 6-6 shows 199 rogue access point alarms.

Follow these steps to detect and locate rogue access points.

Step 1 Click the Rogues indicator to display the Rogue AP Alarms page. This page lists the severity of the alarms, the rogue access point MAC addresses, the rogue access point types, the date and time when the rogue access points were first detected, and their SSIDs.

Step 2 Click any Rogue MAC Address link to display the associated Alarms > Rogue - AP MAC Address page. This page shows detailed information about the rogue access point alarm.

Step 3 To modify the alarm, choose one of these commands from the Select a Command drop-down menu and click GO.

- **Assign to me**—Assigns the selected alarm to the current user.
- **Unassign**—Unassigns the selected alarm.
- **Delete**—Deletes the selected alarm.
- **Clear**—Clears the selected alarm.
- **Event History**—Enables you to view events for rogue alarms.
- **Detecting APs** (with radio band, location, SSID, channel number, WEP state, short or long preamble, RSSI, and SNR)—Enables you to view the access points that are currently detecting the rogue access point.
- **Rogue Clients**—Enables you to view the clients associated with this rogue access point.
- **Set State to ‘Unknown - Alert’**—Tags the rogue access point as the lowest threat, continues to monitor the rogue access point, and turns off containment.
Set State to ‘Known - Internal’—Tags the rogue access point as internal, adds it to the known rogue access points list, and turns off containment.

Set State to ‘Known - External’—Tags the rogue access point as external, adds it to the known rogue access points list, and turns off containment.

- 1 AP Containment through 4 AP Containment—When you select level 1 containment, one access point in the vicinity of the rogue unit sends deauthenticate and disassociate messages to the client devices that are associated to the rogue unit. When you select level 2 containment, two access points in the vicinity of the rogue unit send deauthenticate and disassociate messages to the rogue’s clients and so on up to level 4.

Step 4 From the Select a Command drop-down menu, choose Map (High Resolution) and click GO to display the current calculated rogue access point location on the Maps > Building Name > Floor Name page. If you are using WCS Location, WCS compares RSSI signal strength from two or more access points to find the most probable location of the rogue access point and places a small skull-and-crossbones indicator at its most likely location. In the case of an underdeployed network for location with only one access point and an omni antenna, the most likely location is somewhere on a ring around the access point, but the center of likelihood is at the access point. If you are using WCS Base, WCS relies on RSSI signal strength from the rogue access point and places a small skull-and-crossbones indicator next to the access point receiving the strongest RSSI signal from the rogue unit. Figure 6-7 shows a map that indicates that location of a rogue unit.

Figure 6-7 Map Indicating Location of Rogue Unit
Monitoring Clients

This section provides access to the controller clients summary details. The information assists in identifying, diagnosing, and resolving client issues. To monitor clients, choose Monitor > Clients. The Client Summaries window appears (see Figure 6-8).

Figure 6-8  Clients Summary

The Client Summaries window contains the following portions:

**Most Recent Client Notification**

- **Client**—IP address, MAC address, or user-defined name of client.
- **Event Type**—Reason for client notification. For example, disassociated, WEP decrypt error, or authentication failure.
- **Date/Time**—Date and time of client notification.

**Manually Disabled Clients**

Choose Monitor > Clients and then click Manually Disabled Clients to access this page. This page enables you to view manually disabled client template information.

- **MAC Address**—Client MAC address.
- **Description**—Optional user-defined description.

**Top 5 APs**

The Top 5 APs section includes the following:
• AP Name—This is the name assigned to the access point. Click an item in the list to see the details of that access point.
• Map Location —The name of the map where the client is located.
• a/n Clients—The number of 802.11a clients currently associated with the controller.
• b/g/n Clients—The number of 802.11b clients and 802.11g clients currently associated with the controller.
• Total Client—Total number of clients currently associated with the controller.

Clients Detected by Location Servers

Displays clients detected by location servers within the last 15 minutes.
• Server Name—User-defined location server name.
• Server Address—IP address of location server.
• Total Clients—Total number of clients currently associated with the location server.

Client Count

A graphic shows the associated clients during a given time frame.

Client Troubleshooting

Client—Enter the IP address, MAC address, or user-defined client name and click Troubleshoot to continue to the client details.
Diagnostic Notification Received—Indicates the number of diagnostic notifications received. Click the number to view the list of the diagnostic events.

WLAN Client Troubleshooting

The client reporting protocol is used by the client and the access point to exchange client information. Client reports are collected automatically when the client associates. Follow these steps to run diagnostic tests and reports and to view available logs:

Step 1
Choose Monitor > Clients.

Step 2
To troubleshoot a client, enter the MAC address of the client in the Client field and click Troubleshoot. The troubleshooting client options appear (see Figure 6-9). The number of tabs that appear depends on whether the client is a Cisco Compatible Extensions version 5 client or not. The Cisco Compatible Extensions Version 5 clients contain additional tabs like Test Analysis, Messaging, Event Log, and so on. If the MAC address is unknown, enter search criteria of the client (such as user name, floor, and so on) in the Quick Search of the left-hand menu.
The summary page displays a brief description of the problem and recommends a course of action to resolve the issue.

**Note** Some Cisco Compatible Extension features do not function properly if you use a web browser other than Internet Explorer 6.0 on a Windows workstation.

**Step 3** To view log messages logged against the client, click the **Log Analysis** tab (see Figure 6-10).

**Step 4** To begin capturing log messages about the client from the controller, click **Start**. To stop log message capture, click **Stop**. To clear all log messages, click **Clear**.

**Note** Log messages are captured for ten minutes and then stopped automatically. A user must click **Start** to continue.

**Step 5** To select which log messages to display, click one of the links under Select Log Messages (the number between parentheses indicates the number of messages). The messages appear in the box. It includes the following information:

- A status message
- The controller time
WLAN Client Troubleshooting

- A severity level of info or error (errors are displayed in red)
- The controller to which the client is connected

**Figure 6-10 Log Analysis Tab**

![Log Analysis Tab](image)

**Step 6** To display a summary of the client’s events history, click the Event History tab (see Figure 6-11). This page displays client and access point events that occurred within the last 24 hours.
Step 7  (Optional) If Cisco Compatible Extension Version 5 clients are available, a Test Analysis tab as shown in Figure 6-12 appears.
Step 8 The Test Analysis tab allows you to run a variety of diagnostic tests on the client. Click the check box for the applicable diagnostic test, enter any input information (if applicable), and click **Start**. The following diagnostic tests are available:

- **DHCP**—Executes a complete DHCP Discover/Offer/Request/ACK exchange to determine that the DHCP is operating properly between the controller and the client.
- **IP Connectivity**—Causes the client to execute a ping test of the default gateway obtained in the DHCP test to determine that IP connectivity exists on the local subnet.
- **DNS Ping**—Causes the client to execute a ping test of the DNS server obtained in the DHCP test to determine that IP connectivity exists to the DNS server.
- **DNS Resolution**—Causes the DNS client to attempt to resolve a network name known to be resolvable to determine that name resolution is functioning correctly.
- **802.11 Association**—Directs an association to be completed with a specific access point to determine that the client is able to associate properly with a designated WLAN.
- **802.1X Authentication**—Directs an association and 802.1X authentication to be completed with a specific access point to determine that the client is able to properly complete an 802.1x authentication with a designated .
- **Profile Redirect**—At any time, the diagnostic system may direct the client to activate one of the client’s configured WLAN profiles and to continue operation under that profile.

Step 9 (Optional) If Cisco Compatible Extension Version 5 clients are available, a Messaging tab as shown in **Figure 6-13** appears. Use this tab to send an instant text message to the user of this client. From the Message Category drop-down menu, choose a message and click **Send**.
Step 10 Close the Troubleshooting Client window. The General tab displays the client details and properties of the access point with which the client is associated. Table 6-6, Table 6-7, and Table 6-8 describe the fields displayed on this General tab.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client User Name</td>
<td>The username the client used for authentication.</td>
</tr>
<tr>
<td>Client IP Address</td>
<td>The IP address of the client.</td>
</tr>
<tr>
<td>Client MAC Address</td>
<td>The MAC address of the client.</td>
</tr>
<tr>
<td>Client Vendor</td>
<td>The client’s vendor information.</td>
</tr>
<tr>
<td>Controller</td>
<td>The IP address of the controller to which the client is registered. Clicking the controller’s IP address displays information about the controller.</td>
</tr>
<tr>
<td>Port</td>
<td>The port on the controller to which the client is connected.</td>
</tr>
</tbody>
</table>
### Table 6-6: General Tab / Client Properties (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>802.11 State</td>
<td>802.11 state may be one of the following:</td>
</tr>
<tr>
<td><img src="Idle" alt="" /> (0)— normal operation: no rejections of client association requests</td>
<td></td>
</tr>
<tr>
<td>![](AAA Pending) (1)— completing an AAA transaction</td>
<td></td>
</tr>
<tr>
<td><img src="Authenticated" alt="" /> (2)— 802.11 authentication completed</td>
<td></td>
</tr>
<tr>
<td><img src="Associated" alt="" /> (3)— 802.11 association completed</td>
<td></td>
</tr>
<tr>
<td>![](Power Save) (4)— client in power save mode</td>
<td></td>
</tr>
<tr>
<td><img src="Disassociated" alt="" /> (5)— 802.11 disassociation completed</td>
<td></td>
</tr>
<tr>
<td>![](To Be Deleted) (6)— to be deleted after disassociation</td>
<td></td>
</tr>
<tr>
<td><img src="Probing" alt="" /> (7)— client not associated or authorized yet</td>
<td></td>
</tr>
<tr>
<td>Interface</td>
<td>The name of the interface to which the client is connected.</td>
</tr>
<tr>
<td>VLAN ID</td>
<td>The client has successfully joined an access point for the given SSID. VLAN ID is the reverse lookup of the interface used by the WLAN on the controller side.</td>
</tr>
<tr>
<td>802.11 State</td>
<td>The client’s state:</td>
</tr>
<tr>
<td><img src="Idle" alt="" /> — Normal operation; no rejections of client association requests</td>
<td></td>
</tr>
<tr>
<td>![](AAA Pending) — Completing an AAA transaction</td>
<td></td>
</tr>
<tr>
<td><img src="Authenticated" alt="" /> — 802.11 association completed</td>
<td></td>
</tr>
<tr>
<td><img src="Associated" alt="" /> — 802.11 association completed</td>
<td></td>
</tr>
<tr>
<td>![](Power Save) — Client in power save mode</td>
<td></td>
</tr>
<tr>
<td><img src="Disassociated" alt="" /> — Disassociation completed</td>
<td></td>
</tr>
<tr>
<td>![](To Be Deleted) — To be deleted after disassociated</td>
<td></td>
</tr>
<tr>
<td><img src="Probing" alt="" /> — Client not associated or authorized yet</td>
<td></td>
</tr>
<tr>
<td>Blacklisted — Automatically disabled by the system due to perceived security threats</td>
<td></td>
</tr>
<tr>
<td>Mobility Role</td>
<td>Local, Anchor, Foreign, Export Anchor, Export Foreign.</td>
</tr>
<tr>
<td>Policy Manager State</td>
<td>Internal state of the client’s WLAN. Client is working properly when the state is RUN.</td>
</tr>
<tr>
<td>Anchor Address</td>
<td>N/A when the client is Local (has not roamed from its original subnet). Anchor IP Address (the IP Address of the original controller) when the client is Foreign (has roamed to another controller on a different subnet).</td>
</tr>
<tr>
<td>Foreign IP Address</td>
<td>Foreign IP Address (the IP Address of the original controller) when the client is Anchor (has roamed back to another controller on a different subnet).</td>
</tr>
<tr>
<td>Mirror Mode</td>
<td>Disable or enable.</td>
</tr>
</tbody>
</table>
### Table 6-6  General Tab / Client Properties (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco Compatible Extension</td>
<td>Indicates the Cisco Compatible Extension version, if client supports it.</td>
</tr>
<tr>
<td>E2E</td>
<td>Indicates if E2E is supported.</td>
</tr>
<tr>
<td>WGB Status</td>
<td>Indicates the workgroup bridge status as regular client, WGB client, or WGB.</td>
</tr>
</tbody>
</table>

A WGB is a mode that can be configured on an autonomous IOS access point to provide wireless connectivity to a lightweight access point on behalf of clients that are connected by Ethernet to the WGB access point. A WGB connects a wired network over a single wireless segment by learning the MAC addresses of its wired clients on the Ethernet interface and reporting them to the lightweight access point using Internet Access Point Protocol (IAPP) messaging.

### Table 6-7  General Tab / RF Properties (read only)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AP Name</td>
<td>The name of the access point to which the client is associated. Clicking the link displays information about the access point.</td>
</tr>
<tr>
<td>AP Type</td>
<td>The type of access point.</td>
</tr>
<tr>
<td>AP Base Radio MAC</td>
<td>The MAC address of the access point’s base radio.</td>
</tr>
<tr>
<td>Protocol</td>
<td>The protocol used by the radio (802.11a/n or 802.11b/g/n).</td>
</tr>
<tr>
<td>AP Mode</td>
<td>The access point mode.</td>
</tr>
<tr>
<td>Profile Name</td>
<td>The profile name of the WLAN that the client is associated to or is trying to associate to.</td>
</tr>
<tr>
<td>SSID</td>
<td>The SSID assigned to this WLAN. The access points broadcast the SSID on this WLAN. Different WLANs can use the same SSID as long as the Layer 2 security is different.</td>
</tr>
<tr>
<td>Security Policy</td>
<td>The WLAN security policy that is used.</td>
</tr>
<tr>
<td>Association Id</td>
<td>Client’s access point association identification number.</td>
</tr>
</tbody>
</table>
WLAN Client Troubleshooting

Step 11
To obtain additional troubleshooting information and perform additional diagnostics tests, choose a command from the drop-down menu and click GO.

a. To test the link between the client and the access point to which it is associated, choose Link Test from the drop-down menu and click GO.

b. To disable XYZ, choose Disable from the drop-down menu and click GO.

c. To remove XYZ, choose Remove from the drop-down menu and click GO.

Table 6-7 General Tab / RF Properties (read only) (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
</table>
| Reason Code | The client reason code may be one of the following:  
• Normal (0) — Normal operation.  
• Unspecified reason (1) — Client associated but no longer authorized.  
• PreviousAuthNotValid(2) — Client associated but not authorized.  
• DeauthenticationLeaving (3) — The access point went offline, deauthenticating the client.  
• DisassociationDueToInactivity (4) — Client session timeout exceeded.  
• DisassociationAPBusy(5) — The access point is busy, performing load balancing, for example.  
• Class2FrameFromNonAuthStation (6) — Client attempted to transfer data before it was authenticated.  
• Class2FrameFromNonAssStation (7) — Client attempted to transfer data before it was associated.  
• DisassociationStnHasLeft (8) — Controller moved the client to another access point using non-aggressive load balancing.  
• StaReqAssociationWithoutAuth (9) — Client not authorized yet, still attempting to associate with a Cisco WLAN Solution.  
• Missing Reason Code (99) — Client momentarily in an unknown state. |

802.11 Authentication | Which 802.11 authentication algorithm is in force. |

Table 6-8 General Tab / Security

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Authenticated</td>
<td>Indicates whether the client has been authenticated.</td>
</tr>
<tr>
<td>Policy Type</td>
<td>The type of security policy used by the client.</td>
</tr>
<tr>
<td>Encryption Cipher</td>
<td>Encryption settings.</td>
</tr>
<tr>
<td>EAP Type</td>
<td>Type of Extensible Authentication Protocol (EAP) used.</td>
</tr>
</tbody>
</table>
d. To enable the Mirror mode, choose **Enable Mirror Mode** from the drop-down menu and click **GO**.

e. To display a high-resolution map of the client’s recent location, choose **Recent Map (High Resolution)** from the drop-down menu and click **GO**.

f. To display a high-resolution map of the client’s present location, choose **Present Map (High Resolution)** from the drop-down menu and click **GO**.

g. To display a graph showing a history of the client-to-access point associations, choose **AP Association History Graph** from the drop-down menu and click **GO**.

h. To display a table showing a history of the client-to-access-point associations, choose **AP Association History Table** from the drop-down menu and click **GO**.

i. To display information about the reasons for client roaming, choose **Roam Reason** from the drop-down menu and click **GO**.

j. To display details of access points that can hear the client, including at which signal strength/SNR, choose **Detecting APs** from the drop-down menu and click **GO**.

k. To display the history of the client location based on RF fingerprinting, choose **Location History** from the drop-down menu and click **GO**.

l. To display client voice matrix, choose **Voice Metrics** from the drop-down menu and click **GO**.

**Step 12**

To display client statistics, click the **Statistics** tab (see Figure 6-14).

This page displays four graphs:

- Client RSSI History (dBm)— History of RSSI as detected by the access point to which the client is associated
- Client SNR History— History of SNR as detected by the access point to which the client is associated
- Bytes Sent and Received (Kbps)— The bytes sent and received by the client from the access point to which it is associated
- Packets Sent and Received (per sec.)—The packets sent and received by the client from the access point to which it is associated

**Table 6-9** describes the fields displayed on this Statistics tab.
### Figure 6-14  Statistics Tab

**Wireless Control System**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RSSI</td>
<td>Receive signal strength indicator of the client RF session.</td>
</tr>
<tr>
<td>SNR</td>
<td>Signal to noise ratio of the client RF session.</td>
</tr>
<tr>
<td>Bytes Sent and Received</td>
<td>Total number of bytes sent to the client and received by the controller from the client.</td>
</tr>
<tr>
<td>Packets Sent and Received</td>
<td>Total number of packets sent to the client and received by the controller from the client.</td>
</tr>
</tbody>
</table>
Table 6-9  Statistics Tab / Client Statistics (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client RSSI History (dBm)</td>
<td>History of RSSI as detected by the access point with which the client is associated.</td>
</tr>
<tr>
<td>Client SNR History</td>
<td>History of SNR as detected by the access point with which the client is associated.</td>
</tr>
</tbody>
</table>

Step 13  To display the client’s location information, click the **Location** tab (see Figure 6-15). Table 6-10 describes the fields displayed on this Location tab.

Figure 6-15  Location Tab

Table 6-10  Location Tab

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client Location</td>
<td>Describes the location of the client in the map based on RF fingerprinting.</td>
</tr>
<tr>
<td>Asset Information</td>
<td>Describes the asset file destination and name.</td>
</tr>
<tr>
<td>Location Notifications</td>
<td>Displays the number of location notifications logged against the client. Clicking a link displays the notifications.</td>
</tr>
<tr>
<td>Absence</td>
<td>The location server generates absence events when the monitored assets go missing. In other words, the location server cannot see the asset in the WLAN for the specified time.</td>
</tr>
</tbody>
</table>
Step 14 Click the **Cisco Compatible Extension (version 5) Info** tab. Reports specific to compatible clients provide client details that enhance client diagnostics and troubleshooting. Table **Table 6-11** describes the parameters on the Manufacturer Information portion of the Cisco Compatible Extension (version 5) Info tab.

**Note** The Cisco Compatible Extensions (version 5) manufacturing information displays for compatible clients only.

- Automated Troubleshooting Report—Displays the automated troubleshooting file.

**Note** You must click **Export** to save the .zip file. The file contains three logs: automated troubleshooting report, frame log, and watch list log.

<table>
<thead>
<tr>
<th>Table 6-11 Manufacturer Information</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Parameter</strong></td>
</tr>
<tr>
<td>Organizationally Unique Identifier</td>
</tr>
<tr>
<td>ID</td>
</tr>
<tr>
<td>Model</td>
</tr>
<tr>
<td>Serial Number</td>
</tr>
<tr>
<td>Radio</td>
</tr>
<tr>
<td>MAC Address</td>
</tr>
<tr>
<td>Antenna Type</td>
</tr>
</tbody>
</table>
Table 6-11  Manufacturer Information

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Antenna Gain</td>
<td>The peak gain of the dBi of the antenna for directional antennas and the average gain in dBi for omni-directional antennas connected to the wireless network adapter. The gain is in multiples of 0.5 dBm. An integer value 4 means $4 \times 0.5 = 2$ dBm of gain.</td>
</tr>
</tbody>
</table>

Radio Receiver Sensitivity

Provides the receiver sensitivity of the each wireless network adapter. It shows the minimum and maximum RSSI for each radio type as well as the data rate.

CCXV5 Capability Information

Lists the client status and service capability of the Cisco Compatible Extensions version 5 clients.

Radio Channels

Lists all channels used by each radio.

Transmit Data Rates

Lists all data rates used by each radio.

Table 6-12 describes the parameters displayed in the Cisco Compatibility Extensions (version 5) Capability Information portion of the tab.

Note   The Cisco Compatible Extensions (version 5) capability information displays for compatible extension clients only.

Table 6-12  Client Statistics

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bytes Sent and Received (Kbps)</td>
<td>Bytes sent and received with the associated access point.</td>
</tr>
<tr>
<td>Packets Sent and Received (per second)</td>
<td>Packets sent and received with the associated access point.</td>
</tr>
</tbody>
</table>

Step 15   To display the client’s workgroup bridge information, click the WGB Clients tab. Table 6-13 describes the fields that display on this WGB tab.

Table 6-13  WGB Clients Tab

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User</td>
<td>The user name assigned to the work group bridge.</td>
</tr>
<tr>
<td>IP Addr</td>
<td>The IP address of the workgroup bridge.</td>
</tr>
<tr>
<td>MAC Addr</td>
<td>The MAC address of the workgroup bridge.</td>
</tr>
<tr>
<td>802.11 State</td>
<td>Specifies whether the workgroup bridge is associated or not.</td>
</tr>
</tbody>
</table>
Enabling Automatic Client Troubleshooting

The Settings > Client page allows you to enable automatic client troubleshooting on a diagnostic channel. This feature is only available for Cisco Compatible Extension clients version 5.

Follow these steps to enable automatic client troubleshooting.

**Step 1** Choose Administration > Settings.

**Step 2** From the left sidebar menu, choose Client.

**Step 3** Choose the Automatically troubleshoot client on diagnostic channel check box.

**Note** If the check box is selected, WCS processes the diagnostic association trap. If it is not selected, WCS raises the trap, but automated troubleshooting is not initiated.

**Step 4** Click Save.

Finding Clients

Follow these steps to use WCS to find clients on your wireless LAN.

**Step 1** Click Monitor > Clients to navigate to the Clients Summary page.

**Step 2** The sidebar area enables you to select a new configuration panel under the menu area that you have selected. You can make only one choice. The selector area options vary based on the menu that you select.

- **New Search** drop-down menu: Opens the Search Clients window. Use the Search Clients window to configure, run, and save searches.
- **Saved Searches** drop-down menu: Lists the saved custom searches. To open a saved search, choose it from the Saved Searches list.
- **Edit link**: Opens the Edit Saved Searches window. You can delete saved searches in the Edit Saved Searches window.

**Step 3** In the sidebar, click **New Search**. The Search Clients window appears (see Figure 6-16).
You can configure the following parameters in the Search clients window:

- **Search By**
- **Clients Detected By** — Choose WCS for clients stored in WCS that were detected through polling of the controllers from WCS. Choose Location Servers for clients stored on the location server that were detected by the location server through controller polling.
- **Last detected within** — A time increment from 5 minutes to 24 hours.
- **Client States** — Specify if you want to view clients only in a specific state such as idle, authenticated, associated, probing, or excluded.
- **Include Disassociated** — To include clients that are no longer on the network but for which WCS has historical records.
- **Restrict By Protocol** — To restrict the search by protocol. Then from the drop-down menu choose 802.11a/n, 802.11b/n, and 802.11g/n.
- **Restrict by SSID** — To restrict the search by SSID. Then enter the SSID in the text field.
- **Cisco Compatible Extensions** — To search for Cisco Compatible Extension compatible clients.
- **E2E Compatible** — To search for E2E compatible clients.
- **Save Search** — To save the search in the Saved Searches drop-down menu.
- **Items per page** — The number of found items to display on the search results page.

**Step 4** Choose **All Clients** in the Search By drop-down menu and click **GO**. The related search results window appears. The search results are listed.

**Note** You can search for clients under WCS Controllers or Location Servers.

**Step 5** Click the username of the client that you want to locate. WCS displays the corresponding Clients **Client Name** page.
Finding Clients

Note The Client RSSI History, Client SNR History, Bytes Sent and Received, and Packets Sent and Received reports are displayed. You can specify graph view or table view by clicking the appropriate icon. If it is a report where you can specify time period, enter both the start and end time or a specific time period.

Step 6 To find the client, choose one of these options from the Select a Command drop-down menu and click GO:

- **Recent Map (High Resolution)**—Finds the client without disassociating it.
- **Present Map (High Resolution)**—Disassociates the client and then finds it after reassociation.

When you choose this method, WCS displays a warning message and asks you to confirm that you want to continue.

If you are using WCS Location, WCS compares the RSSI signal strength from two or more access points to find the most probable location of the client and places a small laptop icon at its most likely location. If you are using WCS Base, WCS relies on the RSSI signal strength from the client and places a small laptop icon next to the access point that receives the strongest RSSI signal from the client. Figure 6-17 shows a heat map that includes a client location.

**Figure 6-17 Map with Client Location**

Step 7 To view statistics for the selected client, click the **Statistics** tab.
Step 8  To generate a roam reason report, click **Roam Reason**. This reporting does not require any configuration.

Step 9  To generate a voice TSM report, click **Voice Metrics**.

Step 10 To generate a troubleshooting report, click **Troubleshoot**. You can choose a summary tab, a log analysis tab, or an event history tab.

Step 11 A test analysis generates the following results:

- **DHCP**—Verifies that DHCP is operating correctly between the controller and the client.
- **IP Connectivity**—Determines that IP connectivity exists on the local subnet. The IP connectivity test causes the client to execute a ping test to the default gateway.
- **DNS Ping**—Verifies that IP connectivity exists to the DNS server by having the client perform a ping test to the DNS server.
- **DNS Resolution**—Verifies that name resolution is functioning correctly. To test, the client tests a network name known to be resolvable, such as www.cisco.com.
- **802.1X Association**—Determines that the client is able to associate properly with a designated WLAN and with a specific access point.
- **802.1X Authentication**—Determines that the client is able to complete an 802.1X authentication with a designated WLAN and with a specific access point.

### Table 6-14  **Client Statistics**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bytes received</td>
<td>Total number of bytes received by the controller from the client.</td>
</tr>
<tr>
<td>Bytes sent</td>
<td>Total number of bytes sent to the client from the controller.</td>
</tr>
<tr>
<td>Packets received</td>
<td>Total number of packets received by the controller from the client.</td>
</tr>
<tr>
<td>Packets sent</td>
<td>Total number of packets sent to the client from the controller.</td>
</tr>
<tr>
<td>Policy errors</td>
<td>Number of policy errors for the client.</td>
</tr>
<tr>
<td>RSSI</td>
<td>Receive signal strength indicator of the client RF session.</td>
</tr>
<tr>
<td>SNR</td>
<td>Signal-to-noise ratio of the client RF session.</td>
</tr>
<tr>
<td>Client RSSI History (dBm)</td>
<td>History of RSSI as detected by the access point with which the client is associated.</td>
</tr>
<tr>
<td>Client SNR History</td>
<td>History of SNR as detected by the access point with which the client is associated.</td>
</tr>
<tr>
<td>Bytes Sent and Received (Kbps)</td>
<td>Bytes sent and received with the associated access point.</td>
</tr>
<tr>
<td>Packets Sent and Received (per second)</td>
<td>Packets sent and received with the associated access point.</td>
</tr>
</tbody>
</table>
# Receiving Radio Measurements

On the client window, you can receive radio measurements only if the client is Cisco Compatible Extensions v2 (or higher) and is in the associated state (with a valid IP address). If the client is busy when asked to do the measurement, it determines whether to honor the measurement or not. If it declines to make the measurement, it shows no data from the client.

---

**Step 1** Choose **Monitor > Clients**.

**Step 2** Choose a client from the Clients column or enter a client in the Client Troubleshooting section on the bottom right and click **Troubleshoot**.

**Step 3** From the Select a command drop-down menu, choose **Radio Measurement**.

**Step 4** Click the check box to indicate if you want to specify beacon measurement, frame measurement, channel load, or noise histogram. The different measurements produce differing results:

- **Beacon Response**
  - Channel—The channel number for this measurement
  - BSSID— 6-byte BSSID of the station that sent the beacon or probe response
  - PHY— Physical Medium Type (FH, DSS, OFDM, high rate DSS or ERP)
  - Received Signal Power— The strength of the beacon or probe response frame in dBm
  - Parent TSF— The lower 4 bytes of the serving access point’s TSF value
  - Target TSF— The 8-byte TSF value contained in the beacon or probe response
  - Beacon Interval— The 2-byte beacon interval in the received beacon or probe response
  - Capability information— As present in the beacon or probe response

- **Frame Measurement**
  - Channel— Channel number for this measurement
  - BSSID— BSSID contained in the MAC header of the data frames received
  - Number of frames— Number of frames received from the transmit address
  - Received Signal Power— The signal strength of 802.11 frames in dBm

- **Channel Load**
  - Channel—The channel number for this measurement
  - CCA busy fraction— The fractional duration over which CCA indicated the channel was busy during the measurement duration defined as ceiling (255 times the duration the CCA indicated channel was busy divided by measurement duration)

- **Noise Histogram**
  - Channel— The channel number for this measurement
  - RPI density in each of the eight power ranges

**Step 5** Click **Perform Measurement** to initiate the measurement.

The measurements take about 5 msec to perform. A message from WCS indicates the progress. If the client chooses not to perform the measurement, that is also communicated.
Monitoring Mesh Networks Using Maps

You can access and view details for the following elements from a mesh network map in Cisco WCS:

- Mesh Link Statistics
- Mesh Access Points
- Mesh Access Point Neighbors

Details on how this information is accessed and the information displayed for each of these items is detailed in the following sections.

Monitoring Mesh Link Statistics Using Maps

You can view the SNR for a specific mesh network link, view the number of packets transmitted and received on that link, and initiate a link test from the Monitor > Maps display.

To view details on a specific mesh link between two mesh access points or a mesh access point and a root access point, do the following:

**Step 1**
In Cisco WCS, choose **Monitor > Maps**.

**Step 2**
Click the **Map Name** that corresponds to the outdoor area, campus, building, or floor you want to monitor.

**Step 3**
Move the cursor over the link arrow for the target link (see Figure 6-18). A Mesh Link window appears.

**Note**
The AP Mesh Info check box under the Layers drop-down menu must be checked for links to appear on the map.
Step 4 Click either **Link Test, Child to Parent** or **Link Test, Parent to Child**. After the link test is complete, a results page appears (see Figure 6-19).

**Note** A link test runs for 30 seconds.

**Note** You cannot run link tests for both links (child-to-parent and parent-to-child) at the same time.
**Step 5**  
To view a graphical representation of SNR statistics over a period of time, click the arrow on the link. A window with multiple SNR graphs appears (see Figure 6-20).

The following graphs are displayed for the link:

- **SNR Up**—Plots the RSSI values of the neighbor from the perspective of the access point.
- **SNR Down**—Plots the RSSI values that the neighbor reports to the access point.
- **Link SNR**—Plots a weighed and filtered measurement based on the SNR Up value.
- **The Adjusted Link Metric**—Plots the value used to determine the least cost path to the root access point. This value is the ease to get to the rooftop access point and accounts for the number of hops. The lower the ease value, the less likely the path is used.
- **The Unadjusted Link Metric**—Plots the least cost path to get to the root access point unadjusted by the number of hops. The higher the value for the unadjusted link, the better the path.
Monitoring Mesh Access Points Using Maps

You can view the following summary information for a mesh access point from a mesh network map:

- Parent
- Number of children
- Hop count
- Role
- Group name
- Backhaul interface
- Data Rate
- Channel

**Note** This information is in addition to the information shown for all access points (MAC address, access point model, controller IP address, location, height of access point, access point up time, and LWAPP up time).
You can also view detailed configuration and access alarm and event information from the map. For detailed information on the Alarms and Events displayed, refer to the “Alarm and Event Dictionary” section on page 13-14.

To view summary and detailed configuration information for a mesh access point from a mesh network map, do the following:

**Step 1**
In Cisco WCS, choose **Monitor > Maps**.

**Step 2**
Click the **Map Name** that corresponds to the outdoor area, campus, building, or floor location of the access point you want to monitor.

**Step 3**
To view summary configuration information for an access point, move the cursor over the access point that you want to monitor. A window with configuration information for the selected access point appears (see Figure 6-21).

**Figure 6-21  Mesh AP Summary Panel**

![Mesh AP Summary Panel](image)

**Step 4**
To view detailed configuration information for an access point, click the arrow portion of the mesh access point label. The configuration details for the access point appears (see Figure 6-22).

**Note**
For more details on the View Mesh Neighbors link in the access point panel above, see the “Monitoring Mesh Access Point Neighbors Using Maps” section on page 6-40. If the access point has an IP address, a Run Ping Test link is also visible at the bottom of the mesh access point panel.
Monitoring Mesh Access Point Neighbors Using Maps

To view details on neighbors of a mesh access point from a mesh network map, do the following:

**Step 1** In Cisco WCS, choose Monitor > Maps.
Step 2 Click the **Map Name** that corresponds to the outdoor area, campus, building, or floor you want to monitor.

Step 3 To view detailed information on mesh links for a mesh access point, click the arrow portion of the access point label. The Access Points screen appears.

Step 4 Click the Mesh Links tab (see Figure 6-23).

**Figure 6-23 Access Points > Mesh Links Panel**

You can also mesh link details for neighbors of a selected access point by clicking on the View Mesh Neighbors link on the access point configuration summary panel that displays when you mouse over an access point on a map (see Figure 6-22).

**Note** Signal-to-noise (SNR) only appears on the View Mesh Neighbors panel (see Figure 6-23).
Monitoring Mesh Networks Using Maps

Figure 6-24 View Mesh Neighbors Panel

In addition to listing the current and past neighbors in the panel that displays, labels are added to the mesh access points map icons to identify the selected access point, the neighbor access point, and the child access point. Select the clear link of the selected access point to remove the relationship labels from the map.

The drop-down menus at the top of the mesh neighbors window indicate the resolution of the map (100%) displayed and how often the information displayed is updated (5 mins). You can modify these default values.

Monitoring Mesh Health

Mesh Health monitors the overall health of Cisco Aironet 1500 and 1520 series outdoor access points as well as Cisco Aironet 1130 and 1240 series indoor access points when configured as mesh access points, except as noted. Tracking this environmental information is particularly critical for access points that are deployed outdoors. The following factors are monitored:

- Temperature: Displays the internal temperature of the access point in Fahrenheit and Celsius (Cisco Aironet 1510 and 1520 outdoor access points only).
- Heater status: Displays the heater as on or off (Cisco Aironet 1510 and 1520 outdoor access points only)
- AP Up time: Displays how long the access point has been active to receive and transmit.
- LWAPP Join Taken Time: Displays how long it took to establish the LWAPP connection (excluding Cisco Aironet 1505 access points).
- LWAPP Up Time: Displays how long the LWAPP connection has been active (excluding Cisco Aironet 1505 access points).

Mesh Health information is displayed in the General Properties panel for mesh access points. To view the mesh health details for a specific mesh access point, follow these steps.

**Step 1** Choose **Monitor > Access Points**. A listing of access points appears (see **Figure 6-25**).

**Note** You can also use the New Search button to display the mesh access point summary shown below. With the New Search option, you can further define the criteria of the access points that display. Search criteria include AP Name, IP address, MAC address, Controller IP or Name, Radio type, and Outdoor area.

**Figure 6-25**  **Monitor > Access Points**

![Cisco Wireless Control System](image)

**Step 2** Click the AP Name link to display details for that mesh access point. The General Properties panel for that mesh access point appears (see **Figure 6-26**).

**Note** You can also access the General properties panel for a mesh access point from a Cisco WCS map window. To display the panel, click the arrow portion of the mesh access point label. A tabbed panel appears and displays the General properties panel for the selected access point.
Mesh Statistics for an Access Point

Mesh Statistics are reported when a child mesh access point authenticates or associates with a parent mesh access point.

Security entries are removed and no longer displayed when the child mesh access point disassociates from the controller.

The following mesh security statistics are displayed for mesh access points:

- Bridging
- Queue
- Security

To view the mesh statistics for a specific mesh access point, follow these steps.

**Step 1**

In Cisco WCS, choose **Monitor > Access Points**. A listing of access points appears (see Figure 6-27).

**Note**

You can also use the New Search button to display the access point summary. With the New Search option, you can further define the criteria of the access points that display. Search criteria include AP Name, IP address, MAC address, Controller IP or Name, Radio type, and Outdoor area.

**Step 2**

Click the **AP Name** link of the target mesh access point.
A tabbed panel appears and displays the General Properties page for the selected access point.

**Step 3**

Click the **Mesh Statistics** tab (see Figure 6-27). A three-tabbed Mesh Statistics panel appears.

---

**Note**
The Mesh Statistics tab and its subordinate tabs (Bridging, Queue and Security) only appear for mesh access points. The Mesh Link Alarms and Mesh Link Events links are accessible from each of the three tabbed panels.

---

**Note**
You can also access the Mesh Securities panel for a mesh access point from a Cisco WCS map. To display the panel, click the arrow portion of the mesh access point label.

---

**Figure 6-27** Monitor > Access Points > AP Name > Mesh Statistics
Summaries of the Bridging, Queue and Security Statistics and their definitions are provided in Table 6-15, Table 6-16 and Table 6-17 respectively.

**Table 6-15 Bridging Mesh Statistics**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Role</td>
<td>The role of the mesh access point. Options are mesh access point (MAP) and root access point (RAP).</td>
</tr>
<tr>
<td>Bridge Group Name (BGN)</td>
<td>The name of the bridge group to which the MAP or RAP is a member. Assigning membership in a BGN is recommended. If one is not assigned, a MAP is by default assigned to a default BGN.</td>
</tr>
<tr>
<td>Backhaul Interface</td>
<td>The radio backhaul for the mesh access point.</td>
</tr>
<tr>
<td>Routing State</td>
<td>The state of parent selection. Values that display are seek, scan and maint. Maint displays when parent selection is complete.</td>
</tr>
<tr>
<td>Malformed Neighbor Packets</td>
<td>The number of malformed packets received from the neighbor. Examples of malformed packets include malicious floods of traffic such as malformed or short DNS packets and malformed DNS replies.</td>
</tr>
<tr>
<td>Poor Neighbor SNR</td>
<td>The number of times the signal-to-noise ratio falls below 12 dB on the backhaul link.</td>
</tr>
<tr>
<td>Excluded Packets</td>
<td>The number of packets received from excluded neighbor mesh access points.</td>
</tr>
<tr>
<td>Insufficient Memory</td>
<td>The number of insufficient memory conditions.</td>
</tr>
<tr>
<td>RX Neighbor Requests</td>
<td>The number of broadcast and unicast requests received from the neighbor mesh access points.</td>
</tr>
<tr>
<td>RX Neighbor Responses</td>
<td>The number of responses received from the neighbor mesh access points.</td>
</tr>
<tr>
<td>TX Neighbor Requests</td>
<td>The number of unicast and broadcast requests sent to the neighbor mesh access points.</td>
</tr>
<tr>
<td>TX Neighbor Responses</td>
<td>The number of responses sent to the neighbor mesh access points.</td>
</tr>
<tr>
<td>Parent Changes</td>
<td>The number of times a mesh access point (child) moves to another parent.</td>
</tr>
<tr>
<td>Neighbor Timeouts</td>
<td>The number of neighbor timeouts.</td>
</tr>
<tr>
<td>Node Hops</td>
<td>The number of hops between the MAP and the RAP. Click the value link to display a sub-panel which enables you to configure details of what is reported, how often the node hop value is updated, and view a graphical representation of the report.</td>
</tr>
</tbody>
</table>
### Table 6-16  Queue Mesh Statistics

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Silver Queue</td>
<td>The average and peak number of packets waiting in the silver (best effort) queue during the defined statistics time interval. Packets dropped and queue size is also summarized.</td>
</tr>
<tr>
<td>Gold Queue</td>
<td>The average and peak number of packets waiting in the gold (video) queue during the defined statistics time interval. Packets dropped and queue size is also summarized.</td>
</tr>
<tr>
<td>Platinum Queue</td>
<td>The average and peak number of packets waiting in the platinum (voice) queue during the defined statistics time interval. Packets dropped and queue size is also summarized.</td>
</tr>
<tr>
<td>Bronze Queue</td>
<td>The average and peak number of packets waiting in the bronze (background) queue during the defined statistics time interval. Packets dropped and queue size is also summarized.</td>
</tr>
<tr>
<td>Management Queue</td>
<td>The average and peak number of packets waiting in the management queue during the defined statistics time interval. Packets dropped and queue size is also summarized.</td>
</tr>
</tbody>
</table>

### Table 6-17  Security Mesh Statistics

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Association Request Failures</td>
<td>Summarizes the total number of association request failures that occur between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Association Request Success</td>
<td>Summarizes the total number of successful association requests that occur between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Association Request Timeouts</td>
<td>Summarizes the total number of association request timeouts that occur between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Authentication Request Failures</td>
<td>Summarizes the total number of failed authentication requests that occur between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Authentication Request Success</td>
<td>Summarizes the total number of successful authentication requests between the selected mesh access point and its parent mesh node.</td>
</tr>
<tr>
<td>Authentication Request Timeouts</td>
<td>Summarizes the total number of authentication request timeouts that occur between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Invalid Association Request</td>
<td>Summarizes the total number of invalid association requests received by the parent mesh access point from the selected child mesh access point. This state might occur when the selected child is a valid neighbor but is not in a state that allows association.</td>
</tr>
<tr>
<td>Invalid Reassociation Request</td>
<td>Summarizes the total number of invalid reassociation requests received by the parent mesh access point from a child. This might happen when a child is a valid neighbor but is not in a proper state for reassociation.</td>
</tr>
<tr>
<td>Invalid Reauthentication Request</td>
<td>Summarizes the total number of invalid reauthentication requests received by the parent mesh access point from a child. This may happen when a child is a valid neighbor but is not in a proper state for reauthentication.</td>
</tr>
<tr>
<td>Packets Received</td>
<td>Summarizes the total number of packets received during security negotiations by the selected mesh access point.</td>
</tr>
<tr>
<td>Packets Transmitted</td>
<td>Summarizes the total number of packets transmitted during security negotiations by the selected mesh access point.</td>
</tr>
<tr>
<td>Reassociation Request Failures</td>
<td>Summarizes the total number of failed reassociation requests between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Reassociation Request Success</td>
<td>Summarizes the total number of successful reassociation requests between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Reassociation Request Timeouts</td>
<td>Summarizes the total number of reassociation request timeouts between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Reauthentication Request Failures</td>
<td>Summarizes the total number of failed reauthentication requests between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Reauthentication Request Success</td>
<td>Summarizes the total number of successful reauthentication requests that occurred between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Reauthentication Request Timeouts</td>
<td>Summarizes the total number of reauthentication request timeouts that occurred between the selected mesh access point and its parent.</td>
</tr>
<tr>
<td>Unknown Association Requests</td>
<td>Summarizes the total number of unknown association requests received by the parent mesh access point from its child. The unknown association requests often occur when a child is an unknown neighbor mesh access point.</td>
</tr>
</tbody>
</table>
Viewing the Mesh Network Hierarchy

You can view the parent-child relationship of mesh access points within a mesh network in an easily navigable display. You can also filter which access points display on the Map view, by selecting only access points of interest.

To view the mesh network hierarchy for a selected network, do the following:

Step 1 In Cisco WCS, choose Monitor > Maps.
Step 2 Select the map you want to display.
Step 3 Click the Layers arrow to expand that menu (see Figure 6-28).

**Figure 6-28 Monitor > Maps > Selected Map**

Step 4 Check the AP Mesh Info check box if it is not already checked.
Chapter 6  Monitoring Wireless Devices

Viewing the Mesh Network Hierarchy

Note The AP Mesh Info check box is only selectable if mesh access points are present on the map. It must be checked to view the mesh hierarchy.

Step 5 Click the AP Mesh Info arrow to display the mesh parent-child hierarchy.

Step 6 Click the plus (+) sign next to a mesh access point to display its children.

All subordinate mesh access points are displayed when a negative (-) sign displays next to the parent mesh access point entry. For example, in Figure 6-28, the access point, indoor-mesh-45-rap2, has only one child, indoor-mesh-44-map2.

Step 7 Move the cursor over the colored dot next to each mesh access point child to view details on the link between it and its parent. Table 6-18 summarizes the parameters that display.

The color of the dot also provides a quick reference point of the SNR strength.

- A green dot represents a high SNR (above 25 dB).
- An amber dot represents an acceptable SNR (20-25 dB).
- A red dot represents a low SNR (below 20 dB).
- A black dot indicates a root access point.

Table 6-18  Bridging Link Information

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Information fetched on</td>
<td>Date and time that information was compiled.</td>
</tr>
<tr>
<td>Link SNR</td>
<td>Link signal-to-noise ratio (SNR).</td>
</tr>
<tr>
<td>Link Type</td>
<td>Hierarchical link relationship.</td>
</tr>
<tr>
<td>SNR Up</td>
<td>Signal-to-noise radio for the uplink (dB).</td>
</tr>
<tr>
<td>SNR Down</td>
<td>Signal-to-noise radio for the downlink (dB).</td>
</tr>
<tr>
<td>PER</td>
<td>The packet error rate for the link.</td>
</tr>
<tr>
<td>Tx Parent Packets</td>
<td>The TX packets to a node while acting as a parent.</td>
</tr>
<tr>
<td>Rx Parent Packets</td>
<td>The RX packets to a node while acting as a parent.</td>
</tr>
<tr>
<td>Time of Last Hello</td>
<td>Date and time of last hello.</td>
</tr>
</tbody>
</table>

Using Mesh Filters to Modify Map Display of Maps and Mesh Links

In the mesh hierarchical window, you can also define mesh filters to determine which mesh access points display on the map based on hop values as well as what labels display for mesh links.

Mesh access points are filtered by the number of hops between them and their root access point.

To use mesh filtering, follow these steps:

Step 1 To modify what label and color displays for a mesh link, follow these steps:

   a. In the Mesh Parent-Child Hierarchical View, select an option from the Link Label drop-down menu. Options are None, Link SNR, and Packet Error Rate.
b. In the Mesh Parent-Child Hierarchical View, select an option from the Link Color drop-down menu to define which parameter (Link SNR or Packet Error Rate) determines the color of the mesh link on the map.

**Note**
The color of the link provides a quick reference point of the SNR strength or Packet Error Rate.

<table>
<thead>
<tr>
<th>Table 6-19</th>
<th>Definition for SNR and Packet Error Rate Link Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link Color</td>
<td>Link SNR</td>
</tr>
<tr>
<td>Green</td>
<td>Represents a SNR above 25 dB (high value)</td>
</tr>
<tr>
<td>Amber</td>
<td>Represents a SNR between 20 and 25 dB (acceptable value)</td>
</tr>
<tr>
<td>Red</td>
<td>Represents a SNR below 20 dB (low value)</td>
</tr>
</tbody>
</table>

**Note**
The Link label and color settings are reflected on the map immediately (see Figure 6-29). You can display both SNR and PER values simultaneously.

Step 2
To modify which mesh access points display based on the number of hops between them and their parents, do the following:

a. In the Mesh Parent-Child Hierarchical View, click the Quick Selections drop-down menu.

b. Select the appropriate option from the menu. A description of the options is provided in Table 6-20.

<table>
<thead>
<tr>
<th>Table 6-20</th>
<th>Quick Selection Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameter</td>
<td>Description</td>
</tr>
<tr>
<td>Select only Root APs</td>
<td>Choose this setting if you want the map view to display root access points only.</td>
</tr>
<tr>
<td>Select up to 1st hops</td>
<td>Choose this setting if you want the map view to display 1st hops only.</td>
</tr>
<tr>
<td>Select up to 2nd hops</td>
<td>Choose this setting if you want the map view to display 2nd hops only.</td>
</tr>
<tr>
<td>Select up to 3rd hops</td>
<td>Choose this setting if you want the map view to display 3rd hops only.</td>
</tr>
<tr>
<td>Select up to 4th hops</td>
<td>Choose this setting if you want the map view to display 4th hops only.</td>
</tr>
<tr>
<td>Select All</td>
<td>Select this setting if you want the map view to display all access points.</td>
</tr>
</tbody>
</table>

c. Click Update Map View to refresh the screen and redisplay the map view with the selected options.
Viewing Google Earth Maps

Follow these steps to view Google Earth maps. Refer to the Chapter 16, “Google Earth Maps” for further information.

Step 1  Log in to WCS.
Step 2  Choose Monitor > Google Earth Maps. The Google Earth Maps window displays all folders and the number of access points included within each folder.
Step 3  Click Launch for the map you want to view. Google Earth opens in a separate window and displays the location and its access points.
To use this feature, you must have Google Earth installed on your computer and configured to auto-launch when data is sent from the server. You can download Google Earth from Google’s web site.

To view details for a Google Earth Map folder, follow these steps:

Step 1
From the Google Earth Map window, click the folder name to open the details window for this folder. The Google Earth Details window provide the access point names and MAC or IP addresses.

Step 2
Click Cancel to close the details window.

### Google Earth Settings

Access point related settings can be defined from the Google Earth Settings window. To configure access point settings for the Google Earth Maps feature, follow these steps:

Step 1
Choose Monitor > Google Earth Maps.

Step 2
From the Select a command drop-down menu, choose Settings.

Step 3
Click GO.

Step 4
Configure the following parameters:

- Refresh Settings—Choose the Refresh from Network check box to enable this on-demand refresh. This option is applied only once and then disabled.

Caution
Because this refresh occurs directly from the network, the length of time it takes to collect data depends on the number of access points.

- Layers—Layer filters for access points, access point heat maps, and access point mesh information can be selected and saved. Select the check box to activate the applicable layer and click the > to open the filter window.

Note
These settings apply when Google Earth sends the request for the next refresh.

- Access Points—From the drop-down menu, select to display channels, Tx power level, coverage holes, MAC addresses, names, controller IP, utilization, profiles, or clients.
### Viewing Clients Identified as WGBs

When you click Monitor > WGB, you get a list of all clients identified as a workgroup bridges (see Figure 6-30). WGB clients bridge wireless to wired. Any IOS access point can take on the role of a WGB, acting as a wireless client with a wired client connected to it. The information about this WGB is propagated to the controller and appears as a client in both WCS and WLC.

**Figure 6-30    Monitor > WGBs**

Clients(detected as WGBs) (See next page)

This page lists the Clients identified as Work Group Bridge.

<table>
<thead>
<tr>
<th>User</th>
<th>Vendor</th>
<th>IP Addr</th>
<th>MAC Addr</th>
<th>AP</th>
<th>Controller Part</th>
<th>Loc Server</th>
<th>State</th>
<th>802.11 Profile</th>
<th>Authenticated</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;snip&gt;</td>
<td>Cisco</td>
<td>10.32.33.139</td>
<td>00:17:94:56:09:10</td>
<td>802.11a/n &amp; 802.11b/g/n</td>
<td>10.32.32.0</td>
<td>(unknown)</td>
<td>Associated</td>
<td>wgbme</td>
<td>wgbme Yes</td>
</tr>
<tr>
<td>&lt;snip&gt;</td>
<td>Cisco</td>
<td>10.32.33.130</td>
<td>00:19:30:fo:39:66</td>
<td>802.11a/n &amp; 802.11b/g/n</td>
<td>10.32.32.0</td>
<td>(unknown)</td>
<td>Associated</td>
<td>wgbme</td>
<td>wgbme Yes</td>
</tr>
</tbody>
</table>
Running a Link Test

A link test uses a ping from parent-to-child or child-to-parent to test the link quality. The RF parameters of the ping reply packets received by the access point are polled by the controller to find the link quality. Because radio link quality can differ depending on the direction (client to access point versus access point to client), it is critical to have Cisco Compatible Extensions linktest support so that link quality is tested in both directions. It polls the controller every so many seconds until the row status indicates success or failure. During the link test, the table is populated. If the link test fails, the controller reverts to a ping test.

You can access the link test in one of two ways. The first option is described below.

---

**Step 1** Choose **Monitor > Clients**.

**Step 2** From the left sidebar menu, choose **All Clients** in the Search for Clients By drop-down menu.

**Step 3** In the Client States drop-down menu, choose **All States**. The client list page appears.

**Step 4** Click the **Link Test** link in the last column. The link test begins. Figure 6-32 shows a sample link test result. The results show on the same page if the client is associated. Unsuccessful link tests show a failure message.

Another method for accessing the link test is as follows:

---

**Step 1** Choose **Monitor > Clients**. The Clients Summary window appears (see Figure 6-31).

Figure 6-31  Clients Summary

---

**Step 2** Click the URL under the Total Clients column of the Clients Detected by Location Servers portion of the window.

---

Click the URL under the Total Clients column of the Clients Detected by Location Servers portion of the window.
Step 3  Click a link in the User column to advance to the detail page.

Step 4  From the Select a command drop-down menu, choose **Link Test**.

*Figure 6-32* shows a sample Cisco Compatible Extensions link test result and *Figure 6-33* shows a sample ping test result.

*Figure 6-32*  **Cisco Compatible Extensions Link Test Result**

<table>
<thead>
<tr>
<th>Clients</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Total number of clients found: 9</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>User</th>
<th>Vendor</th>
<th>IP Addr</th>
<th>MAC Addr</th>
<th>AP</th>
<th>Controller</th>
<th>Port 802.11 State</th>
<th>SSID</th>
<th>Authen</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;none&gt;</td>
<td>Intel</td>
<td>0.0.0</td>
<td>00:0f:2:1b:0f:69</td>
<td>9f41408f50</td>
<td>10.76.139.113</td>
<td>Probing</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>&lt;none&gt;</td>
<td>Actiontec</td>
<td>0.0.0</td>
<td>00:20:06:37:44:bd</td>
<td>9f41408f50</td>
<td>10.76.139.113</td>
<td>Probing</td>
<td>No</td>
<td></td>
</tr>
</tbody>
</table>

**Link Test from controller 10.76.139.113 to Client MAC 00:48:96:ad:67:45**

**Link Test Statistics**

<table>
<thead>
<tr>
<th>Frame Type</th>
<th>Uplink</th>
<th>Downlink</th>
<th>Data Rate (Mbps)</th>
<th>Uplink</th>
<th>Downlink</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimum RSSI (dBm)</td>
<td>-66</td>
<td>-66</td>
<td>1</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Maximum RSSI (dBm)</td>
<td>-64</td>
<td>-64</td>
<td>2</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Average RSSI (dBm)</td>
<td>-64</td>
<td>-62</td>
<td>5.5</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Minimum SNR (dB)</td>
<td>29</td>
<td>11</td>
<td>6</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Maximum SNR (dB)</td>
<td>31</td>
<td>11</td>
<td>9</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Average SNR (dB)</td>
<td>30</td>
<td>11</td>
<td>11</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Packets Sent Count</td>
<td>20</td>
<td>20</td>
<td>12</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Rearts Packet Count</td>
<td>1</td>
<td>1</td>
<td>18</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Max. Retx of One Packet</td>
<td>1</td>
<td>1</td>
<td>24</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Lost Packet Count</td>
<td>0</td>
<td>0</td>
<td>36</td>
<td>0</td>
<td>18</td>
</tr>
<tr>
<td>Global Statistics</td>
<td>48</td>
<td>20</td>
<td>2</td>
<td>54</td>
<td>0</td>
</tr>
<tr>
<td>Total Packets Lost</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>108</td>
<td>0</td>
</tr>
<tr>
<td>RTTI (Max/Min/Avg)</td>
<td>1/0/0</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Figure 6-33*  **Ping Test Result**

<table>
<thead>
<tr>
<th>Link Test from Controller 10.76.139.121 to Client MAC 00:20:06:37:44:bd</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Link Test Packets Sent</td>
<td>0</td>
</tr>
<tr>
<td>Link Test Packets Received</td>
<td>20</td>
</tr>
<tr>
<td>Local Signal Strength (dBm)</td>
<td>-262</td>
</tr>
<tr>
<td>Local Signal to Noise Ratio (dB)</td>
<td>-31</td>
</tr>
</tbody>
</table>
Retrieving the Unique Device Identifier on Controllers and Access Points

The unique device identifier (UDI) standard uniquely identifies products across all Cisco hardware product families, enabling customers to identify and track Cisco products throughout their business and network operations and to automate their asset management systems. The standard is consistent across all electronic, physical, and standard business communications. The UDI consists of five data elements:

- The orderable product identifier (PID)
- The version of the product identifier (VID)
- The serial number (SN)
- The entity name
- The product description

The UDI is burned into the EEPROM of controllers and lightweight access points at the factory and can be retrieved through the GUI.

Follow these steps to retrieve the UDI on controllers and access points.

**Step 1**
Click Monitor > Controllers. The Controller > Search Results window displays (see Figure 6-34).

**Figure 6-34 Controllers > Search Results**

<table>
<thead>
<tr>
<th>IP Address</th>
<th>Controller Name</th>
<th>Type</th>
<th>Location</th>
<th>Probability Group Name</th>
<th>Reachability Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>172.13.15.26</td>
<td>C3-6002</td>
<td>4406</td>
<td>WLS Lab Rack</td>
<td>Internal</td>
<td>Reachable</td>
</tr>
<tr>
<td>172.13.15.27</td>
<td>WCS-Beijing-Dev</td>
<td>4406</td>
<td></td>
<td>Internal</td>
<td>Reachable</td>
</tr>
<tr>
<td>10.52.52.17</td>
<td>Cisco-ff77:60</td>
<td>WISM (Slot 0, Port 0)</td>
<td>IDF 2.0</td>
<td>Aleta</td>
<td>Reachable</td>
</tr>
</tbody>
</table>

**Step 2**
(Optional) If you want to change how the controller search results are displayed, click Edit View. The Edit View window appears (see Figure 6-35). In the left-hand window, highlight the areas you want to view and click Show to move them to the right-hand window. You can then highlight the areas in the right-hand menu and click Up or Down to rearrange the order.
Retrieving the Unique Device Identifier on Controllers and Access Points

Figure 6-35  Edit View Window

Step 3  Click the IP address of the controller (seen in Figure 6-34) whose UDI information you want to retrieve. Data elements of the controller UDI display on this window:

Table 6-21  Controllers Summary

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General Portion</strong></td>
<td></td>
</tr>
<tr>
<td>IP Address</td>
<td>Local network IP address of the controller management interface.</td>
</tr>
<tr>
<td>Name</td>
<td>User-defined name of the controller.</td>
</tr>
<tr>
<td>Type</td>
<td>The type of controller.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>For WiSM, the slot and port numbers are also given.</td>
</tr>
<tr>
<td>UP Time</td>
<td>Time in days, hours, and minutes since the last reboot.</td>
</tr>
<tr>
<td>System Time</td>
<td>Time used by the controller.</td>
</tr>
<tr>
<td>Internal Temperature</td>
<td>The current internal temperature of the unit (in Centigrade).</td>
</tr>
<tr>
<td>Location</td>
<td>User-defined physical location of the controller.</td>
</tr>
<tr>
<td>Contact</td>
<td>The contact person for this controller, their textual identification, and ways to contact them. If no contact information is known, this is an empty string.</td>
</tr>
<tr>
<td>Total Client Count</td>
<td>Total number of clients currently associated with the controller.</td>
</tr>
<tr>
<td>Current LWAPP Transport</td>
<td>Lightweight Access Point Protocol transport mode. Communications between controllers and access points. Selections are Layer 2 or Layer 3.</td>
</tr>
<tr>
<td>Mode</td>
<td></td>
</tr>
</tbody>
</table>
Retrieving the Unique Device Identifier on Controllers and Access Points

**Inventory Portion**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power Supply One</td>
<td>Indicates the presence or absence of a power supply and its operations state.</td>
</tr>
<tr>
<td>Power Supply Two</td>
<td>Indicates the presence or absence of a power supply and its operation state.</td>
</tr>
<tr>
<td>Software Version</td>
<td>The operating system release, version.dot.maintenance number of the code currently running on the controller.</td>
</tr>
<tr>
<td>Description</td>
<td>Description of the inventory item.</td>
</tr>
<tr>
<td>Model No.</td>
<td>Specifies the machine model as defined by the Vital Product Data.</td>
</tr>
<tr>
<td>Serial No.</td>
<td>Unique serial number for this controller.</td>
</tr>
<tr>
<td>Burned-in MAC Address</td>
<td>The burned-in MAC address for this controller.</td>
</tr>
<tr>
<td>Number of APs supported</td>
<td>The maximum number of access points supported by the controller.</td>
</tr>
<tr>
<td>GigE Card Present</td>
<td>Displays the presence or absence of the optional 1000BASE-T/1000BASE-SX GigE card.</td>
</tr>
<tr>
<td>Crypto Card One</td>
<td>Displays the presence or absence of an enhanced security module which enables IPSec security and provides enhanced processing power. See Table 6-22 for information on the maximum number of crypto cards that can be installed on a controller.</td>
</tr>
<tr>
<td>Note</td>
<td>By default, enhanced security module is not installed on a controller.</td>
</tr>
<tr>
<td>Crypto Card Two</td>
<td>Displays the presence or absence of a second enhanced security module.</td>
</tr>
<tr>
<td>GIGE Port(s) Status</td>
<td></td>
</tr>
<tr>
<td>Port 1</td>
<td>Up or Down</td>
</tr>
<tr>
<td>Port 2</td>
<td>Up or Down</td>
</tr>
<tr>
<td>Unique Device Identifier (UDI)</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Product type. Chassis for controller and Cisco AP for access points.</td>
</tr>
<tr>
<td>Description</td>
<td>Description of controller and may include number of access points.</td>
</tr>
<tr>
<td>Product Id</td>
<td>Orderable product identifier.</td>
</tr>
<tr>
<td>Version Id</td>
<td>Version of product identifier.</td>
</tr>
<tr>
<td>Serial Number</td>
<td>Unique product serial number.</td>
</tr>
</tbody>
</table>
Coverage Hole

Coverage holes are areas where clients cannot receive a signal from the wireless network. The Cisco Unified Wireless Network Solution radio resource management (RRM) identifies these coverage hole areas and reports them to the WCS, enabling the IT manager to fill holes based on user demand.

WCS is informed about the reliability-detected coverage holes by the controllers. WCS alerts the user about these coverage holes. For more information on finding coverage holes, refer to the “Finding Coverage Holes” section on page 5-10.

Note: Coverage holes are displayed as alarms. Pre-coverage holes are displayed as events.

Monitoring Pre-Coverage Holes

While coverage holes are displayed as alarms, pre-coverage holes are displayed as events.

Follow these steps to view pre-coverage hole events.

Step 1: Choose Monitor > Events to display all current events.

Step 2: To view pre-coverage hole events only, choose Pre-coverage Hole from the Event Category drop-down menu on the left sidebar and click Search.

The Pre-Coverage Hole Events window provides the information described in the following table:

Table 6-23 Pre-Coverage Hole Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Severity</td>
<td>Pre-coverage hole events are always considered informational (Info).</td>
</tr>
<tr>
<td>Client MAC Address</td>
<td>MAC address of the client affected by the pre-coverage hole.</td>
</tr>
<tr>
<td>AP MAC Address</td>
<td>MAC address of the applicable access point.</td>
</tr>
<tr>
<td>AP Name</td>
<td>The name of the applicable access point.</td>
</tr>
<tr>
<td>Radio Type</td>
<td>The radio type (802.11b/g or 802.11a) of the applicable access point.</td>
</tr>
</tbody>
</table>

coverage hole

coverage holes are areas where clients cannot receive a signal from the wireless network. the cisco unified wireless network solution radio resource management (rrm) identifies these coverage hole areas and reports them to the wcs, enabling the it manager to fill holes based on user demand.

wcs is informed about the reliability-detected coverage holes by the controllers. wcs alerts the user about these coverage holes. for more information on finding coverage holes, refer to the “finding coverage holes” section on page 5-10.

note: coverage holes are displayed as alarms. pre-coverage holes are displayed as events.

monitoring pre-coverage holes

while coverage holes are displayed as alarms, pre-coverage holes are displayed as events.

follow these steps to view pre-coverage hole events.

step 1: choose monitor > events to display all current events.

step 2: to view pre-coverage hole events only, choose pre-coverage hole from the event category drop-down menu on the left sidebar and click search.

the pre-coverage hole events window provides the information described in the following table:

table 6-23 pre-coverage hole parameters

<table>
<thead>
<tr>
<th>parameter</th>
<th>description</th>
</tr>
</thead>
<tbody>
<tr>
<td>severity</td>
<td>pre-coverage hole events are always considered informational (info).</td>
</tr>
<tr>
<td>client mac address</td>
<td>mac address of the client affected by the pre-coverage hole.</td>
</tr>
<tr>
<td>ap mac address</td>
<td>mac address of the applicable access point.</td>
</tr>
<tr>
<td>ap name</td>
<td>the name of the applicable access point.</td>
</tr>
<tr>
<td>radio type</td>
<td>the radio type (802.11b/g or 802.11a) of the applicable access point.</td>
</tr>
</tbody>
</table>
### Table 6-23 Pre-Coverage Hole Parameters (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power Level</td>
<td>Access point transmit power level: 1 = Maximum power allowed per country code setting, 2 = 50% power, 3 = 25% power, 4 = 6.25 to 12.5% power, and 5 = 0.195 to 6.25% power.</td>
</tr>
<tr>
<td>Client Type</td>
<td>Client type can be any of the following: laptop(0), pc(1), pda(2), dot11mobilephone(3), dualmodephone(4), wgb(5), scanner(6), tabletpc(7), printer(8), projector(9), videoconfsystem(10), camera(11), gamingsystem(12), dot11deskphone(13), cashregister(14), radiotag(15), rfidsensor(16), server(17)</td>
</tr>
<tr>
<td>Date/Time</td>
<td>The date and time the event occurred. Click the title to toggle between ascending and descending order.</td>
</tr>
</tbody>
</table>

**Step 3** Choose a Client MAC Address to view pre-coverage hole details

- General—Provides the following information:
  - Client MAC Address
  - AP MAC Address
  - AP Name
  - Radio Type
  - Power Level
  - Client Type
  - Category
  - Created
  - Generated By
Viewing DHCP Statistics

WCS provides DHCP server statistics for version 5.0.6.0 controllers or later. These statistics include information on the packets sent and received, DHCP server response information, and last request timestamp.

Follow these steps to view DHCP statistics.

**Step 1** Choose Monitor > Controllers.

**Step 2** Click one of the IP addresses in the IP Address column.

**Step 3** From the left sidebar menu, choose System > DHCP Statistics. The DHCP Statistics window appears (see Figure 6-36).

---

The DHCP Statistics screen provides the following information:
### Table 6-24  DHCP Statistics

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server IP</td>
<td>Identifies the IP address of the server.</td>
</tr>
<tr>
<td>Is Proxy</td>
<td>Identifies whether or not this server is proxy.</td>
</tr>
<tr>
<td>Discover Packets Sent</td>
<td>Identifies the total number of packets sent with the intent to locate available servers.</td>
</tr>
<tr>
<td>Request Packets Sent</td>
<td>Identifies the total number of packets sent from the client requesting parameters from the server or confirming the correctness of an address.</td>
</tr>
<tr>
<td>Decline Packets</td>
<td>Identifies the number of packets indicating that the network address is already in use.</td>
</tr>
<tr>
<td>Inform Packets</td>
<td>Identifies the number of client requests to the DHCP server for local configuration parameters because the client already has an externally configured network address.</td>
</tr>
<tr>
<td>Release Packets</td>
<td>Identifies the number of packets that release the network address and cancel the remaining lease.</td>
</tr>
<tr>
<td>Reply Packets</td>
<td>Identifies the number of reply packets.</td>
</tr>
<tr>
<td>Offer Packets</td>
<td>Identifies the number of packets that respond to the discover packets with an offer of configuration parameters.</td>
</tr>
<tr>
<td>Ack Packets</td>
<td>Identifies the number of packets that acknowledge successful transmission.</td>
</tr>
<tr>
<td>Nak Packets</td>
<td>Identifies the number of packets that indicate that the transmission occurred with errors.</td>
</tr>
<tr>
<td>Tx Failures</td>
<td>Identifies the number of transfer failures that occurred.</td>
</tr>
<tr>
<td>Last Response Received</td>
<td>Provides a timestamp of the last response received.</td>
</tr>
<tr>
<td>Last Request Sent</td>
<td>Provides a timestamp of the last request sent.</td>
</tr>
</tbody>
</table>
Managing WCS User Accounts

This chapter describes how to configure global e-mail parameters and manage WCS user accounts. It contains these sections:

- Adding WCS User Accounts, page 7-2
- Viewing or Editing User Information, page 7-6
- Viewing or Editing Group Information, page 7-7
- Setting Lobby Ambassador Defaults, page 7-9
- Viewing the Audit Trail, page 7-10
- Enabling Audit Trails for Guest User Activities, page 7-12
- Creating Guest User Accounts, page 7-12
- Managing WCS Guest User Accounts, page 7-16
Adding WCS User Accounts

This section describes how to configure a WCS user. The accounting portion of the AAA framework is not implemented at this time. Besides complete access, you can give administrative access with differentiated privileges to certain user groups. WCS supports external user authentication using these access restrictions and authenticates the users against the TACACS+ and RADIUS servers.

The username and password supplied by you at install time are always authenticated, but the steps you take here create additional superusers. If the password is lost or forgotten, the user must run a utility to reset the password to another user-defined password.

Follow these steps to add a new user account to WCS.

**Step 1** Start WCS by following the instructions in the “Starting WCS” section on page 2-12.

**Step 2** Log into the WCS user interface as Super1.

**Note** Cisco recommends that you create a new superuser assigned to the SuperUsers group and delete Super1 to prevent unauthorized access to the system.

**Step 3** Click Administration > AAA and the Change Password window appears (see Figure 7-1).

**Figure 7-1 Change Password Window**

**Step 4** From the Select a command drop-down menu, choose Add User and click GO to display the User administration page.

**Step 5** In the Old Password field, enter the current password that you want to change.

**Step 6** Enter the username and password for the new WCS user account. You must enter the password twice.

**Note** These entries are case sensitive.
Step 7  Under Groups Assigned to this User, check the appropriate check box to assign the new user account to one of the user groups supported by WCS:

- **System Monitoring**—Allows users to monitor WCS operations.
- **ConfigManagers**—Allows users to monitor and configure WCS operations.
- **Admin**—Allows users to monitor and configure WCS operations and perform all system administration tasks except administering WCS user accounts and passwords.

*Note* Some user groups cannot be combined with other user groups. For instance, you cannot choose both lobby ambassador and monitor lite.

- **SuperUsers**—Allows users to monitor and configure WCS operations and perform all system administration tasks including administering WCS user accounts and passwords. Superusers tasks can be changed.
- **North bound API**—A user group used only with WCS Navigator.
- **Users Assistant**—Allows only local net user administration. User assistants cannot configure or monitor controllers. They must access the Configure > Controller path to configure these local net features.

*Note* If you choose admin account and log in as such on the controller, you can also see the guest users under Local Net Admin.

- **Lobby Ambassador**—Allows guest access for only configuration and managing of user accounts.
- **Monitor lite**—Allows monitoring of assets location.
- **Root**—Allows users to monitor and configure WCS operations and perform all system administration tasks including changing any passwords. Only one user can be assigned to this group and is determined upon installation. It cannot be removed from the system, and no task changes can be made for this user.

Step 8  Click Submit. The name of the new user account appears on the All Users page and can be used immediately.

Step 9  In the sidebar, click Groups to display the All Groups page (see Figure 7-2).
Adding WCS User Accounts

Figure 7-2  All Groups Window

Step 10  Click the name of the user group to which you assigned the new user account. The Group > User Group page shows a list of this group’s permitted operations.

Step 11  Make any desired changes by checking or unchecking the appropriate check boxes.

Note  Any changes you make will affect all members of this user group.

Step 12  Click Submit to save your changes or Cancel to leave the settings unchanged.

Deleting WCS User Accounts

Follow these steps to delete a WCS user account.

Step 1  Start WCS by following the instructions in the “Starting WCS” section on page 2-12.

Step 2  Log into the WCS user interface as a user assigned to the SuperUsers group.

Step 3  Click Administration > Accounts to display the All Users page.

Step 4  Check the check box to the left of the user account(s) to be deleted.

Step 5  From the Select a command drop-down menu, choose Delete User(s) and click GO.

When prompted, click OK to confirm your decision. The user account is deleted and can no longer be used.

Changing Passwords

Follow these steps to change the password for a WCS user account.
Chapter 7  Managing WCS User Accounts

Adding WCS User Accounts

Step 1  Start WCS by following the instructions in the “Starting WCS” section on page 2-12.

Step 2  Log into the WCS user interface as a user assigned to the SuperUsers group.

Step 3  Click Administration > Accounts to display the Change Password page.

Step 4  Click the name of the user account for which you want to change the password. You can change the password here or through the User > Edit window.

Step 5  Enter your old password, unless you are the root user. (A root user can change any password without entering the old password.)

Step 6  On the User > Username page, enter the new password in both the New Password and Confirm New Password fields.

Step 7  Click Submit to save your changes. The password for this user account has been changed and can be used immediately.

Monitoring Active Sessions

Follow the steps below to view a list of active users.

Step 1  Choose Administration > AAA.

Step 2  From the left sidebar menu, choose Active Sessions. The Active Sessions window appears (see Figure 7-3).

FIGURE 7-3  Active Sessions Window

The user highlighted in red represents your current login. If a column heading is a hyperlink, click the heading to sort the list of active sessions in descending or ascending order along that column. The sort direction is toggled each time the hyperlink is clicked.

The Active sessions window has the following columns:

<table>
<thead>
<tr>
<th>User Name</th>
<th>IP/Host Name</th>
<th>Login Time</th>
<th>Last Access Time</th>
<th>Login Method</th>
<th>User Groups</th>
<th>Severity</th>
<th>Location</th>
<th>Status</th>
<th>Posture</th>
<th>Controller</th>
<th>Access Point</th>
<th>NetLink Status</th>
<th>NetLink Location</th>
<th>Security</th>
<th>Access Count</th>
<th>Coverage Count</th>
<th>Controller Count</th>
<th>Access Point Count</th>
<th>NetLink Status Count</th>
<th>NetLink Location Count</th>
</tr>
</thead>
</table>
Viewing or Editing User Information

Click in the User Name column of the Users window to see the group the user is assigned to or to adjust a password or group assignment. The detailed users window appears (see Figure 7-4).

- **IP/Host Name:** The IP address or the hostname of the machine on which the browser is running. If the hostname of the user machine is not in DNS, the IP address is displayed.
- **Login Time:** The time at which the user logged in to WCS. All times are based on the WCS server machine time.
- **Last Access Time:** The time at which the user’s browser accessed WCS. All times are based on the WCS server machine time.

**Note**
The time displayed in this column is usually a few seconds behind the current system time because Last Access Time is updated frequently by the updates to the alarm status panel. However, if a user navigates to a non-WCS Navigator web page in the same browser, the disparity in time is greater upon returning to WCS Navigator. This disparity results because alarm counts are not updated while the browser is visiting non-WCS Navigator web pages.

- **Login Method:**
  - **Web Service:** Internal session needed by Navigator to manage WCS.
  - **Regular:** Sessions created for users who log into WCS directly through a browser.
  - **Navigator Redirect:** Sessions created for Navigator users who are redirected to WCS from Navigator.
- **User Groups:** The list of groups to which the user belongs. (North bound API is a user group used only with WCS Navigator.)
- **Audit trail icon:** Link to window that displays the audit trail (previous login times) for that user.
Viewing or Editing Group Information

Click in the Member Of column of the User window to see specific tasks the user is permitted to do within the defined group or to make changes and submit them. The detailed group window appears (see Figure 7-5).

Note The detailed window varies based on what group you choose. Figure 7-5 shows the detailed window of the root group.
Figure 7-5  Detailed Group Window

Wireless Control System

- Group > Root
  - Group for root user. Group is not editable.

List of Tasks Permitted

- User Administration
- Users and Groups
- Audit Trails
- TACACS+ Servers
- RADIUS Servers

Administrative Operations
- Logging
- Licensing
- Scheduled Tasks and Data Collection
- User Preferences
- System Settings
- Auto Provisioning
- Diagnostic Information

Alerts and Events
- View Alerts and Events
- Email Notification
- Delete and Clear Alerts
- Pick and Unpick Alerts
- Set and Unset Alerts

Severities Configuration

Network Configuration
- Configure Controllers
- Configure Templates
- Configure Config Groups
- Configure Access Points
- Configure Access Point Templates
- Migration Templates
- Configure Choice Points
- Configure Spectrum Experts

Network Monitoring
- Monitor Controllers
- Monitor Access Points
- Monitor Clients
- Monitor Tags
- Monitor Security
- Monitor Chlokspoints
- Monitor Spectrum Experts
- Interferers Search

Reports
- Access Point Reports
- Mesh Reports
- Client Reports
- Inventory Reports
- Performance Reports
- Security Reports
- Audit Reports
- Voice Audit Report

Location Server
- Location Server Management
- View Location Notifications

Maps
- Maps Read Only
- Maps Read Write
- Client Location
- Roam Location
- Planning Mode
Setting Lobby Ambassador Defaults

If you click the Lobby Ambassador check box when creating a user group, a Lobby Ambassador Defaults tab appears (see Figure 7-6). All of the guest user accounts created by the lobby ambassador have these credentials by default. If the default values are not specified, the lobby ambassador must provide the required guest user credential fields.

Note If no default profile is chosen on this tab, the defaults do not get applied to this lobby ambassador. The lobby ambassador account does get created, and you can create users with any credentials you choose.

Figure 7-6 Lobby Ambassador Defaults

Step 1 Use the Profile drop-down menu to choose the guest user to connect to.

Step 2 Choose Limited or Unlimited at the Lifetime parameter. If you choose limited, you can specify the number of hours and minutes. By default the lifetime is limited to 8 hours.

Step 3 Use the Apply to drop-down menu to choose from the following options. What you choose determines what additional parameters appear.

- Indoor area — A campus, building, or floor.
- Outdoor area — A campus or outdoor area.
- Controller list — A list of controller(s) with the selected profile created.
- Config Group — Those config group names configured on WCS.

Step 4 Enter the e-mail ID of the host to whom the guest account credentials are sent.
Step 5  Provide a brief description of the account.

Step 6  If you want to supply disclaimer text, enter it.

Step 7  Check the Defaults Editable Enable check box if you want to allow the lobby ambassador to override these configured defaults.

Step 8  Check the Max User Creations Allowed Enable check box to allow the lobby ambassador to set limits on the number of guest users that can be on the network in a given time period. The time period is defined in hours, days, or weeks.

---

**Editing the Default Lobby Ambassador Credentials**

Click the WCS username in the Users window to edit the lobby ambassador default credentials. The Lobby Ambassador Default tab appears, and you can modify the credentials.  

---

**Note**  If you remove the profile selection, the defaults for this lobby ambassador are removed.

---

**Viewing the Audit Trail**

Click the Audit Trail icon in the Users window to view a log of authentication attempts. The Audit Trail window appears (see Figure 7-7).
## Viewing the Audit Trail

### Figure 7-7 Audit Trail

The Audit Trail displays a list of user actions along with their status. Each entry includes the user name, operation type, date and time, and status. The status 'Success' indicates successful actions, while 'Failure' indicates unsuccessful ones.

<table>
<thead>
<tr>
<th>User</th>
<th>Operation</th>
<th>Time</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 6, 2016 12:03:54 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 6, 2016 2:54:28 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 6, 2016 4:10:00 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 10:24:05 AM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 1:06:05 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 6:51:00 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 1:52:08 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 1:52:08 PM</td>
<td>Failure</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 1:51:23 PM</td>
<td>Failure</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 1:51:00 PM</td>
<td>Failure</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 1:30:49 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 2:05:04 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 2:17:54 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 2:21:42 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 2:22:19 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 2:31:54 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 2:36:00 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 2:40:05 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 2:41:02 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 2:50:11 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 2:50:36 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:03:54 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:04:50 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:05:22 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:33:33 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:33:41 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:35:49 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:37:19 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:37:25 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:39:33 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:41:50 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:41:10 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:41:10 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:41:10 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:41:10 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:41:16 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:44:23 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:49:00 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:49:12 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:49:13 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:49:13 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 3:49:41 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:01:40 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:17:58 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:19:14 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:19:14 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:21:30 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:21:30 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:28:19 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:28:19 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:28:19 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:28:19 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:29:29 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:30:04 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:30:04 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:30:04 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:30:04 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:30:04 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:32:36 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:35:18 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:41:57 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:50:39 PM</td>
<td>Success</td>
</tr>
<tr>
<td>root</td>
<td>Authentication</td>
<td>Nov 7, 2016 4:50:39 PM</td>
<td>Success</td>
</tr>
</tbody>
</table>
Enabling Audit Trails for Guest User Activities

Follow these steps to enable audit trails for guest user activities.

Step 1  Log into the Navigator or WCS user interface as an administrator.

Step 2  Click Administration > AAA, then click Users in the left sidebar menu to display the Users window.

Step 3  At the Users window, click the Audit Trail icon for the lobby ambassador account that you want to view. The Audit Trail window for the lobby ambassador appears.

The window enables you to view a list of lobby ambassador activities over time. Each entry displays the following information:

- User: User login name (for example, lobby)
- Operation: Type of operation audited (such as, creation and deletion of guest users reported by name)
- Time: Time operation was audited
- Status: Success or failure of activity

Note  WCS keeps all Audit Trail records for up to 7 days. The nightly data cleanup task cleans all records which are older than 7 days.

Step 4  To clear a specific entry from the audit trail listing, check the check box next to that entry and choose Clear Audit Trail from the Select a command drop-down menu and click GO.

You can select multiple entries for deletion at one time.

Creating Guest User Accounts

You can use the Cisco Lobby Ambassador to create guest user accounts in WCS. A guest network provided by an enterprise allows access to the internet for a guest without compromising the host. The web authentication is provided with or without a supplicant or client, so a guest needs to initiate a VPN tunnel to their desired destinations.

Both wired and wireless guest user access is supported. Wired guest access enables guest users to connect to the guest access network from a wired Ethernet connection designated and configured for guest access. Wired guest access ports might be available in a guest office or specific ports in a conference room. Like wireless guest user accounts, wired guest access ports are added to the network using the lobby ambassador feature.

The network administrator must first set up a lobby administrator account. Guest user accounts are for visitors, temporary workers, etc. who need network access. A lobby ambassador account has limited configuration privileges and only allows access to the screens used to configure and manage guest user accounts. The lobby administrator has no access to online help.

The lobby ambassador can create the following types of guest user accounts:

- A guest user account with a limited lifetime. After the specified time period, the guest user account automatically expires.
- A guest user account with an unlimited lifetime. This account never expires.
• A guest user account that is activated at a predefined time in the future. The lobby ambassador defines the beginning and end of the valid time period.
Creating Guest User Accounts

This section describes how to perform the following procedures:

- Creating a Lobby Ambassador Account, page 7-14
- Managing WCS Guest User Accounts, page 7-16
- Logging the Lobby Ambassador Activities, page 7-21

Creating a Lobby Ambassador Account

Follow these steps to create a lobby ambassador account in WCS.

**Note**

You should have SuperUser privilege (by default) to create a lobby ambassador account and not administration privileges. Multiple lobby ambassador accounts can be created by the administrator with varying profiles and permissions.

**Note**

A root group, which is created during installation, has only one assigned user, and no additional users can be assigned after installation. This root user cannot be changed. Also, unlike a super user, no task changes are allowed.

**Step 1**

Log into the WCS user interface as an administrator.

**Step 2**

Click **Administration > AAA**.

**Step 3**

From the left sidebar menu, choose **Users**.

**Step 4**

From the Select a Command drop-down menu, choose **Add User** and click **GO**. The Users window appears.

**Step 5**

Enter the username.

**Step 6**

Enter the password. The minimum is six characters. Reenter and confirm the password.

**Note**

The password must include at least three of the following four types of elements: lowercase letters, uppercase letters, numbers, and special characters.

**Step 7**

In the Groups Assigned to this User section, check the **LobbyAmbassador** check box to access the Lobby Ambassador Defaults tab.

**Step 8**

At the Lobby Ambassador Default tab, follow these steps to set the defaults for a guest user account:

a. Choose a Profile for the guest user from the drop-down menu.

Wired-guest is an example of a profile that might be defined to indicate traffic that is originating from wired LAN ports. Refer to the “Configuring Wired Guest Access” section on page 9-30.

b. Choose a user role for the guest user from the drop-down menu. User roles are predefined by the administrator and are associated with the guests’ access (such as contractor, customer, partner, vendor, visitor, and so on).

User Role is used to manage the amount of bandwidth allocated to specific users within the network. User roles are defined in Cisco WCS on the Local Net User Role Template Window. Refer to the “Configuring Guest User Templates” section on page 10-36.
c. Define how long the guest user account will be active by choosing either the Limited or Unlimited Lifetime option.
   - For the limited option, you choose the period of time that the guest user account is active using the hours and minutes drop-down menus. The default value for Limited is one day (8 hours).
   - When unlimited is chosen, no expiration date for the guest account exists.

d. Choose the area (indoor or outdoor), controller list, or config group to which the guest user traffic is limited from the Apply to drop-down menu.
   - If you choose the controller list option, a list of controller IP addresses appears. Check the check box next to all controller networks on which guest traffic is allowed.

e. (Optionally) Enter the e-mail ID of the host to whom the guest account credentials are sent.

f. (Optionally) Modify the default guest user description if necessary.

g. (Optionally) Modify the Disclaimer text, if necessary.

h. Check the Defaults Editable check box. This allows the Lobby Ambassadors to modify Guest User default settings on the Lobby Ambassador Default setting window.

**Note**
If no default profile is selected on this tab, the defaults are not applied to this Lobby Ambassador. However, the Lobby Ambassador account is created, and the Lobby Ambassador can create users with credentials as desired.

---

**Step 9** Click Submit.

When the lobby ambassador is added, it is part of the lobby ambassador group. The name of the new lobby ambassador account is listed and can be used immediately.

---

**Editing a Lobby Ambassador Account**

The Lobby Ambassador default credentials can be edited from the username link on the WCS user list page.

To edit the Lobby Ambassador default credentials, follow these steps:

---

**Step 1** Log into the WCS user interface as an administrator.

**Step 2** Choose Administration > AAA.

**Step 3** From the left sidebar menu, click Users.

**Step 4** Click the applicable Lobby Ambassador account from the User Name column.

**Step 5** From the Lobby Ambassador Defaults page, edit the credentials as necessary.

**Note** While editing, if the Profile selection is removed (changed to Select a profile), the defaults are removed for this Lobby Ambassador. The user must reconfigure the defaults to reinforce them.

---

**Step 6** Click Submit.
Loggin into the WCS User Interface as a Lobby Ambassador

When you log in as a lobby ambassador, you have access to the guest user template page in WCS. You can then configure guest user accounts (through templates).

Follow these steps to log into the WCS user interface through a web browser.

**Step 1** Launch Internet Explorer 6.0 or later on your computer.

*Note* Some WCS features may not function properly if you use a web browser other than Internet Explorer 6.0 on a Windows workstation.

**Step 2** In the browser’s address line, enter `https://wcs-ip-address` (such as `https://1.1.1.1/login.html`), where `wcs-ip-address` is the IP address of the computer on which WCS is installed. Your administrator can provide this IP address.

**Step 3** When the WCS user interface displays the Login window, enter your username and password.

*Note* All entries are case sensitive.

*Note* The lobby administrator can only define guest users templates.

**Step 4** Click **Submit** to log into WCS. The WCS user interface is now active and available for use. The Guest Users window is displayed. This window provides a summary of all created Guest Users.

To exit the WCS user interface, close the browser window or click **Logout** in the upper right corner of the window. Exiting a WCS user interface session does not shut down WCS on the server.

*Note* When a system administrator stops the WCS server during a WCS session, the session ends, and the web browser displays this message: “The page cannot be displayed.” Your session does not reassociate to WCS when the server restarts. You must restart the WCS session.

Managing WCS Guest User Accounts

WCS guest user accounts are managed with the use of templates. This section describes how to manage WCS user accounts. It includes the following:

- Adding Guest User Accounts, page 7-17
- Deleting Guest User Templates, page 7-19
- Scheduling WCS Guest User Accounts, page 7-20
- Printing or E-mailing WCS Guest User Details, page 7-21
Adding Guest User Accounts

Templates are used to create guest user accounts in WCS. After the template is created, it is applied to all controllers that the guest users can access. Follow these steps to add a new guest user account to WCS.

**Step 1**
Log into the WCS user interface as lobby ambassador to open the Guest user window.

**Step 2**
From the Select a command drop-down menu, choose Add Guest User.

**Step 3**
Click GO. The Guest User > New User window has two tabs: General and Advanced. The lobby ambassador can either manually enter the username and password for an individual or can import a file with user names and passwords defined for multiple users by selecting the Generate Password option.

- If the username and password are entered manually, the password is entered twice for confirmation.
- If the Generate Password option is chosen, the Import From File option should be selected on the Advanced tab. The following fields can be imported for a guest user: username, password, lifetime setting, description, and disclaimer. Format for the fields in the CSV file is noted at the bottom of the Advanced panel.
- If the Import From File check box is checked, no username and password fields appear on the General tab.

**Note**
Passwords are case sensitive and must be a minimum of 8 characters. The password must include at least three of the following elements: lowercase letters, uppercase letters, numbers, and special characters. Reenter and confirm the password.

**Step 4**
At the Advanced tab, check the Import From File option to upload the following information for multiple guest users: username, password, lifetime setting, description, and disclaimer. Format for the fields in the CSV file is noted at the bottom of the Advanced panel.

**Step 5**
If Import From file is selected, browse to or enter the file name from which to upload the file.

**Step 6**
Choose a Profile from the drop-down menu.

The selectable profiles are predefined by a system administrator and define the length of time, user role (allocated bandwidth), and areas of the network (indoor, outdoor, controllers, and config groups) to which a guest user has access. Your administrator can advise which profile to use.

**Step 7**
Choose a user role from the drop-down menu. (This option is not seen if the Import From File check box is selected.)

**Step 8**
Choose the lifetime of the guest user account. The options are limited or unlimited. (This option is not seen if the Import From File check box is selected.)

- Limited—From the drop-down menus, choose days, hours, or minutes for the lifetime of this guest user account. The maximum is 30 days.
- Unlimited—This user account never expires.

**Step 9**
Click Apply To to restrict a guest user to a confined area by selecting a campus, building, or floor so that when applied, only those controllers and associated access points are available. You can also restrict the guest user (wired or wireless) to a specific listed controller or a configuration group, which is a group of controllers that has been preconfigured by the administrator.
From the Apply To drop-down menu, choose one of the following:

- Controller List: Check the check box for the controller(s) to which the guest user account applies. Only those controllers configured for guest access (wired or wireless) display.
- Indoor Area: Choose the applicable campus, building, and floor.
- Outdoor Area: Choose the applicable campus and outdoor area.
- Config Group: Choose the config group to which the guest user account applies.

**Step 10** Review and modify, if necessary, the description field. (This option is not seen if the Import From File check box was selected.)

**Step 11** Review and modify, if necessary, the disclaimer information. Use the scroll bar to move up and down. (This option is not seen if the Import From File check box was selected.)

**Step 12** Click the **Make this Disclaimer Default** to use the disclaimer text as the default for all guest user accounts. Click the check box if you want to set new default disclaimer text for all future guest user accounts. (This option is not seen if the Import From File check box was selected.)

**Step 13** Click **Save** to save your changes or **Cancel** to leave the settings unchanged. The Guest User Credentials window appears. See the “Guest User Credentials” section on page 7-18.

### Guest User Credentials

The Guest User Credentials window displays the following information:

- **IP Address**: IP address of controller to which the guest user account applies.
- **Controller Name**: Name of controller.
- **Operation Status**: Indicates successful or unsuccessful creation of guest user account.
- **Reason**: Indicates why the creation of the guest user account was unsuccessful.
- **Guest User Credentials**:
  - **Guest User Name**: Guest user account login name.
  - **Password**: Guest user account password.
  - **Start time**: Date and time that the guest user account begins.
  - **End time**: Date and time that the guest user account expires.
  - **Disclaimer**: Disclaimer information for the guest user.
- **Print/E-mail Guest User Credentials**: Link to print or e-mail guest user information. See the “Printing or E-mailing WCS Guest User Details” section on page 7-21.

### Viewing and Editing Guest Users

Follow these steps to view the current WCS guest users.

**Step 1** Log into the WCS user interface as described in the “Logging into the WCS User Interface” section on page 2-13.

**Step 2** On the Guest User window, click which item number under the User Name column you want to view or edit.
Step 3 On the Guest Users > Users window, you can edit the following items:

- Profile ID: The selectable profiles are predefined by the system administrator and define the length of time, user role (allocated bandwidth), and areas of the network (indoor, outdoor, controllers, config groups) to which a guest user has access. Your administrator can advise which profile to use.
- Description: Enter a description of the guest user account.
- Limited or Unlimited:
  - Limited: From the drop-down menus, choose days, hours, or minutes for the lifetime of this guest user account. The maximum is 30 days.
  - Unlimited: This user account never expires.
- Choose Apply To to restrict a guest user to a confined area by selecting a campus, building, or floor so that when applied, only those controllers and associated access points are available. You can also restrict the guest user (wired or wireless) to a specific listed controller or a config group, which is a group of controllers that has been preconfigured by the administrator.

  From the Apply To drop-down menus, choose one of the following:
  - Controller List: Check the check box for the controller(s) to which the guest user account applies.
  - Indoor Area: Choose the applicable campus, building, and floor.
  - Outdoor Area: Choose the applicable campus and outdoor area.
  - Config Group: Choose the Config Group to which the guest user account applies.

Step 4 Click Save to save your changes or Cancel to leave the settings unchanged. When you click Save, the screen refreshes.

---

Deleting Guest User Templates

During deletion of the guest account, all client stations logged in and using the guest WLAN username are deleted. Follow these steps to delete a WCS guest user template.

Step 1 Log into the WCS user interface as described in the “Logging into the WCS User Interface” section on page 2-13.

Step 2 On the Guest Users window, check the check box to the left of the guest user account(s) to be deleted.

Step 3 From the Select a Command drop-down menu, choose Delete Guest User and click GO.

Step 4 When prompted, click OK to confirm your decision.

---

Note The IP address and controller name to which the guest user account was applied appears, and you are prompted to confirm the removal of the template from the controller.
The controller sends a notification of a guest account expiry and deletion by invoking a trap. WCS processes the trap and deletes the user account expired from the configuration of that controller. If that guest account is not applied to other controllers, it can be deleted from the templates as well. A notice appears in the event logs also.

**Step 5** Click **OK** to delete the guest user template from the controller or **Cancel** to leave the settings unchanged. When you delete the guest user template from the controller, you delete the specified guest user account.

---

**Scheduling WCS Guest User Accounts**

A lobby ambassador is able to schedule automatic creation of a guest user account. The validity and recurrence of the account can be defined. The generation of a new username on every schedule is optional and is enabled using a check box. For scheduled users, the password is automatically generated and is automatically sent by e-mail to the host of the guest. The e-mail address for the host is configured on the New User window. After clicking Save, the Guest User Details window displays the password. From this window, you can e-mail or printer the account credentials.

Follow these steps to schedule a recurring guest user account in WCS.

**Step 1** Log in to the WCS user interface as lobby ambassador.

**Step 2** On the Guest User window, choose **Schedule Guest User** and click **GO** from the Select a command drop-down menu.

**Step 3** On the Guest Users > Scheduling window, enter the guest user name. The maximum is 24 characters.

**Step 4** Check the check box to generate a username and password on every schedule. If this is enabled, a different password is supplied for each day (up to the number of days chosen). If this is disabled (unchecked), one password is supplied for a span of days. The generation of a new username and password on every schedule is optional.

**Step 5** Select a Profile ID from the drop-down menu. This is the SSID to which this guest user applies and must be a WLAN that has Layer 3 authentication policy configured. Your administrator can advise which Profile ID to use.

**Step 6** Enter a description of the guest user account.

**Step 7** Choose **limited** or **unlimited**.

- **Limited**: From the drop-down menu, choose days, hours, or minutes for the lifetime of this guest user account. The maximum is 30 days.
  - Start time: Date and time when the guest user account begins.
  - End time: Date and time when the guest user account expires.
- **Unlimited**: This user account never expires.

**Step 8** Choose **Apply To** to restrict a guest user to a confined area by selecting a campus, building, or floor so that when applied, only those controllers and associated access points are available. You can also restrict the guest user to specific listed controllers or a configuration group, which is a group of controllers that has been preconfigured by the administrator.

From the drop-down menus, choose one of the following:

- **Controller List**: check the check box for the controller(s) to which the guest user account is associated.
Chapter 7      Managing WCS User Accounts

Managing WCS Guest User Accounts

- Indoor Area: choose the applicable campus, building, and floor.
- Outdoor Area: choose the applicable campus and outdoor area.
- Config group: choose the configuration group to which the guest user account belongs.

**Step 9** Enter the e-mail address to send the guest user account credentials. Each time the scheduled time comes up, the guest user account credentials are e-mailed to the specified e-mail address.

**Step 10** Review the disclaimer information. Use the scroll bar to move up and down.

**Step 11** Click **Save** to save your changes or **Cancel** to leave the settings unchanged.

---

### Printing or E-mailing WCS Guest User Details

The lobby ambassador can print or e-mail the guest user account details to the host or person who welcomes guests.

The e-mail and print copy shows the following details:
- **Username**: Guest user account name.
- **Password**: Password for the guest user account.
- **Start time**: Date and time when the guest user account begins.
- **End time**: Date and time when the guest user account expires.
- **Profile ID**: Profile assigned to the guest user. Your administrator can advise which Profile ID to use.
- **Disclaimer**: Disclaimer information for the guest user.

When creating the guest user account and applying the account to a list of controllers, area, or configuration group, a link is provided to e-mail or print the guest user account details. You can also print guest user account details from the Guest Users List window.

Follow these steps to print guest user details from the Guest Users List window.

**Step 1** Log into the WCS user interface as lobby ambassador.

**Step 2** On the Guest User window, check the check box next to User Name and choose **Print/E-mail User Details** from the Select a command drop-down menu and click **GO**.

- If printing, click **Print** and from the print window, select a printer and click **Print** or **Cancel**.
- If e-mailing, click **E-mail** and from the e-mail window, enter the subject text and the recipient’s e-mail address. Click **Send** or **Cancel**.

---

### Logging the Lobby Ambassador Activities

The following activities are logged for each lobby ambassador account:
- **Lobby ambassador login**: WCS logs the authentication operation results for all users.
- **Guest user creation**: When a lobby ambassador creates a guest user account, WCS logs the guest user name.
Chapter 7      Managing WCS User Accounts

Managing WCS Guest User Accounts

- Guest user deletion: When a lobby ambassador deletes the guest user account, WCS logs the deleted guest user name.
- Account updates: WCS logs the details of any updates made to the guest user account. For example, increasing the life time.

Follow these steps to view the lobby ambassador activities.

Note

You must have superuser status to open this window.

Step 1
Log into the Navigator or WCS user interface as an administrator.

Step 2
Click Administration > AAA, then click Groups in the left sidebar menu to display the All Groups window.

Step 3
On the All Groups windows, click the Audit Trail icon for the lobby ambassador account you want to view. The Audit Trail window for the lobby ambassador appears.

This window enables you to view a list of lobby ambassador activities over time.
- User: User login name
- Operation: Type of operation audited
- Time: Time operation was audited
- Status: Success or failure

Step 4
To clear the audit trail, choose Clear Audit Trail from the Select a command drop-down menu and click GO.
Configuring Mobility Groups

This chapter describes mobility groups and explains how to configure them on WCS. It contains these sections:

- Overview of Mobility, page 8-2
- Symmetric Tunneling, page 8-5
- Overview of Mobility Groups, page 8-5
- Messaging among Mobility Groups, page 8-7
- Mobility Anchors, page 8-13
- Configuring Multiple Country Codes, page 8-15
- Creating Config Groups, page 8-18
- Downloading Software, page 8-23
Overview of Mobility

.mobility, or roaming, is a wireless LAN client's ability to maintain its association seamlessly from one access point to another securely and with as little latency as possible. This section explains how mobility works when controllers are included in a wireless network.

When a wireless client associates and authenticates to an access point, the access point’s controller places an entry for that client in its client database. This entry includes the client’s MAC and IP addresses, security context and associations, quality of service (QoS) contexts, the WLANs, and the associated access point. The controller uses this information to forward frames and manage traffic to and from the wireless client. Figure 8-1 illustrates a wireless client roaming from one access point to another when both access points are joined to the same controller.

Figure 8-1 Intra-Controller Roaming

When the wireless client moves its association from one access point to another, the controller simply updates the client database with the newly associated access point. If necessary, new security context and associations are established as well.
The process becomes more complicated, however, when a client roams from an access point joined to one controller to an access point joined to a different controller. The process also varies based on whether the controllers are operating on the same subnet. Figure 8-2 illustrates inter-controller roaming, which occurs when the controllers’ wireless LAN interfaces are on the same IP subnet.

**Figure 8-2 Inter-Controller Roaming**

When the client associates to an access point joined to a new controller, the new controller exchanges mobility messages with the original controller, and the client database entry is moved to the new controller. New security context and associations are established if necessary, and the client database entry is updated for the new access point. This process remains invisible to the user.

---

**Note**

All clients configured with 802.1X/Wi-Fi Protected Access (WPA) security complete a full authentication in order to comply with the IEEE standard.

Figure 8-3 illustrates inter-subnet roaming, which occurs when the controllers’ wireless LAN interfaces are on different IP subnets.
Inter-subnet roaming is similar to inter-controller roaming in that the controllers exchange mobility messages on how the client roams. However, instead of moving the client database entry to the new controller, the original controller marks the client with an “Anchor” entry in its own client database. The database entry is copied to the new controller client database and marked with a “Foreign” entry in the new controller. The roam remains invisible to the wireless client, and the client maintains its original IP address.

After an inter-subnet roam, data flows in an asymmetric traffic path to and from the wireless client. Traffic from the client to the network is forwarded directly into the network by the foreign controller. Traffic to the client arrives at the anchor controller, which forwards the traffic to the foreign controller in an EtherIP tunnel. The foreign controller then forwards the data to the client. If a wireless client roams to a new foreign controller, the client database entry is moved from the original foreign controller to the new foreign controller, but the original anchor controller is always maintained. If the client moves back to the original controller, it becomes local again.

In inter-subnet roaming, WLANs on both anchor and foreign controllers need to have the same network access privileges and no source-based routing or source-based firewalls in place. Otherwise, the clients may have network connectivity problems after the handoff.

**Note**
Currently, multicast traffic cannot be passed during inter-subnet roaming. In other words, avoid designing an inter-subnet network for Spectralink phones that need to send multicast traffic while using push to talk.

**Note**
Both inter-controller roaming and inter-subnet roaming require the controllers to be in the same mobility group. See the next two sections for a description of mobility groups and instructions for configuring them.
Symmetric Tunneling

With symmetric mobility tunneling, the controller provides inter-subnet mobility for clients roaming from one access point to another within a wireless LAN. The client traffic on the wired network is directly routed by the foreign controller. If a router has reverse path filtering (RPF) enabled (which provides additional checks on incoming packets), the communication is blocked. Symmetric mobility tunneling allows the client traffic to reach the controller designated as the anchor, even with RPF enabled. You enable or disable symmetric tunneling by choosing Configure > Controller and then System > General from the left sidebar menu.

Note
All controllers in a mobility group should have the same symmetric tunneling mode.

Note
For symmetric tunneling to take effect, a reboot is required.

With this guest tunneling N+1 redundancy feature, the time it takes for a client to join another access point following a controller failure is decreased because a failure is quickly identified, the clients are moved away from the problem controller, and the clients are anchored to another controller.

Refer to the “Configuring General Templates” section on page 10-4 for instructions on configuring this feature within a template.

Overview of Mobility Groups

A set of controllers can be configured as a mobility group to allow seamless client roaming within a group of controllers. By creating a mobility group, you can enable multiple controllers in a network to dynamically share information and forward data traffic when inter-controller or inter-subnet roaming occurs. Controllers can share the context and state of client devices and controller loading information. With this information, the network can support inter-controller wireless LAN roaming and controller redundancy.

Note
Clients do not roam across mobility groups.

Figure 8-4 shows an example of a mobility group.
Overview of Mobility Groups

Figure 8-4  A Single Mobility Group

As shown above, each controller is configured with a list of the other members of the mobility group. Whenever a new client joins a controller, the controller sends out a unicast message to all of the controllers in the mobility group. The controller to which the client was previously connected passes on the status of the client. All mobility exchange traffic between controllers is carried over an LWAPP tunnel.

Examples:

1. A 4404-100 controller supports up to 100 access points. Therefore, a mobility group consisting of 24 4404-100 controllers supports up to 2400 access points (24 * 100 = 2400 access points).

2. A 4402-25 controller supports up to 25 access points, and a 4402-50 controller supports up to 50 access points. Therefore, a mobility group consisting of 12 4402-25 controllers and 12 4402-50 controllers supports up to 900 access points (12 * 25 + 12 * 50 = 300 + 600 = 900 access points).

Mobility groups enable you to limit roaming between different floors, buildings, or campuses in the same enterprise by assigning different mobility group names to different controllers within the same wireless network. Figure 8-5 shows the results of creating distinct mobility group names for two groups of controllers.
The controllers in the ABC mobility group recognize and communicate with each other through their access points and through their shared subnets. The controllers in the ABC mobility group do not recognize or communicate with the XYZ controllers, which are in a different mobility group. Likewise, the controllers in the XYZ mobility group do not recognize or communicate with the controllers in the ABC mobility group. This feature ensures mobility group isolation across the network.

**Note**

Clients may roam between access points in different mobility groups, provided they can detect them. However, their session information is not carried between controllers in different mobility groups.

### When to Include Controllers in a Mobility Group

If it is possible for a wireless client in your network to roam from an access point joined to one controller to an access point joined to another controller, both controllers should be in the same mobility group.

### Messaging among Mobility Groups

The controller provides inter-subnet mobility for clients by sending mobility messages to other member controllers. There can be up to 72 members in the list with up to 24 in the same mobility group. In WCS and controller software releases 5.0, two improvements have been made to mobility messaging, each of which is especially useful when sending messages to the full list of mobility members:
Sending Mobile Announce messages within the same group first and then to other groups in the list

The controller sends a Mobile Announce message to members in the mobility list each time a new client associates to it. In WCS and controller software releases prior to 5.0, the controller sends this message to all members in the list irrespective of the group to which they belong. However, in controller software release 5.0, the controller sends the message only to those members that are in the same group as the controller and then includes all of the other members while sending retries.

Sending Mobile Announce messages using multicast instead of unicast

In WCS and controller software releases prior to 5.0, the controller may be configured to use multicast to send the mobile announce messages, which requires sending a copy of the messages to every mobility member. This behavior is not efficient because many messages (such as Mobile Announce, PMK Update, AP List Update, and IDS Shun) are meant for all members in the group. In WCS and controller software releases 5.0, the controller uses multicast mode to send the Mobile Announce messages. This behavior allows the controller to send only one copy of the message to the network, which destines it to the multicast group containing all the mobility members. To derive the maximum benefit from multicast messaging, Cisco recommends that it be enabled or disabled on all group members.

**Configuring Mobility Groups**

This section provides instructions for configuring mobility groups.

**Note**
You can also configure mobility groups using the controller. Refer to the *Cisco Wireless LAN Controller Configuration Guide* for instructions.

**Prerequisites**

Before you add controllers to a mobility group, you must verify that the following requirements have been met for all controllers that are to be included in the group:

- All controllers must be configured for the same LWAPP transport mode (Layer 2 or Layer 3).

**Note**
You can verify and, if necessary, change the LWAPP transport mode on the System > General page.

- IP connectivity must exist between the management interfaces of all devices.

**Note**
You can verify IP connectivity by pinging the controllers.

- All controllers must be configured with the same mobility group name.

**Note**
For the Cisco WiSM, both controllers should be configured with the same mobility group name for seamless routing among 300 access points.

- All devices must be configured with the same virtual interface IP address.
Chapter 8 Configuring Mobility Groups

Configuring Mobility Groups

Note
If all the controllers within a mobility group are not using the same virtual interface, inter-controller roaming may appear to work, but the hand-off does not complete, and the client loses connectivity for a period of time.

- You must have gathered the MAC address and IP address of every controller that is to be included in the mobility group. This information is necessary because you will be configuring all controllers with the MAC address and IP address of all the other mobility group members.

Note
You can find the MAC and IP addresses of the other controllers to be included in the mobility group on the Configure > Controllers page.

Follow these steps to add each WLC controller into mobility groups and configure them.

Step 1
Navigate to Configure > Controllers (see Figure 8-6).

Figure 8-6 Configure > Controllers

This page shows the list of all the controllers you added in Step 1. The mobility group names and the IP address of each controller that is currently a member of the mobility group is listed.

Step 2
Choose the first controller by clicking on the WLC IP address. You will then access the controller templates interface for the controller you are managing.

Step 3
Choose System > Mobility Groups on the left-hand side. The existing Mobility Group members are listed in the window (see Figure 8-7).
**Figure 8-7  Existing Mobility Groups**

Step 4  You will see a list of available controllers. From the Select a command drop-down menu in the upper right-hand corner, choose Add Group Members and then click GO.

Step 5  If no controllers were found to add to the mobility group, you can add the members manually by clicking the “To add members manually to the Mobility Group click here” message. The Mobility Group Member window appears.
Chapter 8 Configuring Mobility Groups

Configuring Mobility Groups

Figure 8-8 Mobility Group Member Window

Step 6 In the Member MAC Address field, enter the MAC address of the controller to be added.

Step 7 In the Member IP Address field, enter the management interface IP address of the controller to be added.

Note If you are configuring the mobility group in a network where network address translation (NAT) is enabled, enter the IP address sent to the controller from the NAT device rather than the controller’s management interface IP address. Otherwise, mobility will fail among controllers in the mobility group.

Step 8 Enter the multicast group IP address to be used for multicast mobility messages in the Multicast Address field. The local mobility member’s group address must be the same as the local controller’s group address.

Step 9 In the Group Name field, enter the name of the mobility group.

Step 10 Click Save.

Step 11 Repeat the above steps for the remaining WLC devices.

Setting the Mobility Scalability Parameters

Follow these steps to set the mobility message parameters.

Note You must complete the steps in the “Configuring Mobility Groups” section on page 8-8 prior to setting the mobility scalability parameters.
Step 1  Choose **Configure > Controllers**.

Step 2  Choose an IP address of a controller whose software version is 5.0 or later.

Step 3  Choose **System > General** from the left sidebar menu. The General window as shown in **Figure 8-9** appears.

**Figure 8-9  System > General Window**

![System > General Window](image)

Step 4  At the Multicast Mobility Mode parameter, specify if you want to enable or disable the ability for the controller to use multicast mode to send Mobile Announce messages to mobility members.

Step 5  If you enabled multicast messaging by setting multicast mobility mode to enabled, you must enter the group IP address at the Mobility Group Multicast-address parameter to begin multicast mobility messaging. You must configure this IP address for the local mobility group, but it is optional for other groups within the mobility list. If you do not configure the IP address for other (non-local) groups, the controllers use unicast mode to send mobility messages to those members.

Step 6  Click **Save**.
Mobility Anchors

Mobility anchors are a subset of a mobility group specified as the anchor controllers for a WLAN. This feature can be used to restrict a WLAN to a single subnet, regardless of the client’s entry point into the network. In this way, users can access a public or guest WLAN throughout an enterprise but still be restricted to a specific subnet. Guest WLAN can also be used to provide geographic load balancing because WLANs can represent a particular section of a building (such as, a lobby, a restaurant, and so on).

When a client first associates to a controller of a mobility group that has been preconfigured as a mobility anchor for a WLAN, the client associates to the controller locally, and a local session is created for the client. Clients can be anchored only to preconfigured anchor controllers of the WLAN. For a given WLAN, you should configure the same set of anchor controllers on all controllers in the mobility group.

When a client first associates to a controller of a mobility group that has not been configured as a mobility anchor for a WLAN, the client associates to the controller locally, a local session is created for the client, and the controller is announced to the other controllers in the same mobility group. If the announcement is not answered, the controller contacts one of the anchor controllers configured for the WLAN and creates a foreign session for the client on the local switch. Packets from the client are encapsulated through a mobility tunnel using EtherIP and sent to the anchor controller, where they are decapsulated and delivered to the wired network. Packets to the client are received by the anchor controller and forwarded to the foreign controller through a mobility tunnel using EtherIP. The foreign controller decapsulates the packets and forwards them to the client.

Note
A 2000 series controller cannot be designated as an anchor for a WLAN. However, a WLAN created on a 2000 series controller can have a 4100 series controller or a 4400 series controller as its anchor.

Note
The L2TP Layer 3 security policies are unavailable for WLANs configured with a mobility anchor.

Configuring Mobility Anchors

Follow these steps to create a new mobility anchor for a WLAN.

Step 1  Click Configure > Controllers.
Step 2  Choose a controller by clicking an IP address.
Step 3  Choose WLANs > WLANs from the left sidebar menu.
Step 4  Click the desired WLAN ID URL (see Figure 8-10).
Step 5  After choosing a WLAN ID, a tabbed window appears (see Figure 8-11). Click the Advanced tab.

Step 6  Click the Mobility Anchors link at the bottom of the page. The Mobility Anchors window appears (see Figure 8-12).
Configuring Multiple Country Codes

You can configure one or more countries on a controller. After countries are configured on a controller, the corresponding 802.11a/n DCA channels are available for selection. At least one DCA channel must be selected for the 802.11a/n network. When the country codes are changed, the DCA channels are automatically changed in coordination.

Note

802.11a/n and 802.11b/n networks for controllers and access points must be disabled before configuring a country on a controller. To disable 802.11a/n or 802.11b/n networks, 1) choose Configure > Controllers, 2) select the desired controller you want to disable, 3) choose 802.11a/n or 802.11b/g/n from the left sidebar menu, and then 4) choose Parameters. The Network Status is the first check box.

Follow these steps to add multiple controllers that are defined in a configuration group and then set the DCA channels. To configure multiple country codes outside of a mobility group, refer to the “Setting Multiple Country Codes” section on page 9-3.

Step 1 Choose Configure > Config Groups.
Step 2 Choose Add Config Groups from the Select a command drop-down menu.
Step 3 Create a config group by entering the group name and mobility group name.
Step 4 Click Save. The Config Groups window appears (see Figure 8-13).
**Step 5** Click the **Controllers** tab. The Controllers window appears (see *Figure 8-14*).
Step 6  Highlight the controllers you want to add and click the >> Add button. The controller is added to the Group Controllers window.

Step 7  Click the Country/DCA tab. The Country/DCA window appears (see Figure 8-15). Dynamic Channel Allocation (DCA) automatically selects a reasonably good channel allocation amongst a set of managed devices connected to the controller.
Creating Config Groups

By creating a config group, you can group controllers that should have the same mobility group name and similar configuration. You can assign templates to the group and push templates to all the controllers in a group. You can add, delete, or remove config groups, and download software, IDS signatures, or a customized web authentication page to controllers in the selected config groups. You can also save the current configuration to nonvolatile (Flash) memory to controllers in selected config groups.

For information about applying templates to either individual controllers or controllers in selected Config Groups, refer to Chapter 10, “Using Templates.”

By choosing Configure > Config Groups, you can view a summary of all config groups in the Cisco WCS database. When you choose Add Config Groups from the Select a command drop-down menu, the page displays a table with the following columns:

Step 8 Check the Update Countries check box to display a list of countries from which to choose.

Step 9 Those DCA channels that are currently configured on the controller for the same mobility group are displayed in the Select Country Codes window. The corresponding 802.11a/n and 802.11b/n allowable channels for the chosen country is displayed as well. You can add or delete any channels in the list by selecting or deselecting the channel and clicking Save Selection.

Note A minimum of 1 and a maximum of 20 countries can be configured for a controller.
Chapter 8 Configuring Mobility Groups

Creating Config Groups

- Check box: Check to select the config group.
- Group Name: Name of the config group.
- Mobility Group Name: Name of Mobility or WPS Group.
- Controllers: Number of controllers added to Config Group.
- Templates: Number of templates applied to config group.
- Last Modified: Date and time config group was last modified.
- Last Applied: Date and time last changes were applied.

Adding New Group

Follow these steps to add a config group.

**Step 1** Choose Configure > Config Groups.

**Step 2** From the Select a command drop-down list, choose Add Config Group and click GO. The Add New Group window appears (see Figure 8-16).

![Figure 8-16 Add New Config Group](image)

**Step 3** Enter the new config group name. It must be unique across all groups.

**Step 4** Enter the mobility group name. Group controllers should have the same mobility group name and similar configuration. This name gets populated to all controllers in the group. Two different config groups can have the same mobility group.

**Step 5** Other templates created in WCS can be assigned to a config group. The same WLAN template can be assigned to more than one config group. Choose from the following:
- Select and add later: Click to add template at a later time.
• Copy templates from a controller: Click to copy templates from another controller. Choose a controller from a list of current controllers to copy its applied template to the new config group. Only the templates are copied.

• Check the check box to add the selected controller to the new config group, if you want to add the controller.

**Step 6** Click **Save**.

### Configuring Config Groups

Follow these steps to configure a config group.

**Step 1** Choose **Configure > Config Groups**, and click a group name under the Group Name column.

**Step 2** Click the **General** tab. The following options for the config group appear:

- **Group Name**: Name of the config group
- **Mobility Group Name**: Mobility Group Name that is pushed to all controllers in the group. The Mobility Group Name can also be modified here.
- **Last Modified On**: Date and time config group was last modified.
- **Last Applied On**: Date and time last changes were applied.

**Step 3** You must choose the **Apply** tab to distribute the specified mobility group name to the group controllers and to create mobility group members on each of the group controllers.

**Step 4** Click **Save**.

### Adding or Removing Controllers from Config Group

Follow these steps to add or remove controllers from a config group.

**Step 1** Choose **Configure > Config Groups**, and click a group name under the Group Name column.

**Step 2** Click the **Controllers** tab. The columns in the table display the IP address of the controller, the config group name the controller belongs to, and the controller’s mobility group name.

**Step 3** Click to highlight the row of the controller you want to add to the group.

**Step 4** Click the **>>Add** button.

**Note** If you want to remove a controller from the group, highlight the controller in the Group Controllers box and click the **<< Remove** button.

**Step 5** You must choose the **Apply** tab and click the **Apply** button to add or remove the controllers to the config groups.

**Step 6** Click the **Save Selection** button.
Adding or Removing Templates from the Config Group

Follow these steps to add or remove templates from the config group.

Step 1 Choose **Configure > Config Groups**, and click a group name under the Group Name column.
Step 2 Click the **Templates** tab. The Remaining Templates table displays the item number of all available templates, the template name, and the type and use of the template.
Step 3 Click to highlight the row of the template you want to add to the group.
Step 4 Click the **>> Add** button.

**Note** If you want to remove a template from the group, highlight the template in the Remaining Templates box and click the **<< Remove** button.

Step 5 You must choose the **Apply** tab and click the **Apply** button to add or remove the templates to the config groups.
Step 6 Click the **Save Selection** button.

Applying Config Groups

Follow these steps to apply the mobility groups, mobility members, and templates to all the controllers in a config group.

Step 1 Choose **Configure > Config Groups**, and click a group name under the Group Name column.
Step 2 Click the **Apply** tab to access this page.
Step 3 Click **Apply** to start the provisioning of mobility groups, mobility members, and templates to all the controllers in the config group. After you apply, you can leave this window or log out of Cisco WCS. The process continues, and you can return later to this page and view a report.

**Note** Do not perform any other config group functions during the apply provisioning.

A report is generated and appears in the Recent Apply Report window. It shows which mobility group, mobility member, or template were successfully applied to each of the controllers.

**Note** If you want to print the report as shown on the window, you must choose landscape page orientation.
Auditing Config Groups

Follow these steps to verify if the controller’s configuration complies with the group templates and mobility group.

**Step 1** Choose **Configure > Config Groups**, and click a group name under the Group Name column.

**Step 2** Click the **Audit** tab to access this page.

**Step 3** Click **Audit** to verify if the controller’s configuration complies with the group templates and the mobility group. During the audit, you can leave this window or logout of Cisco WCS. The process will continue and you can return later to this page and view a report.

---
**Note** Do not perform any other config group functions during the audit verification.

A report is generated and the current configuration on each controller is compared with that in the config group templates. An audit report for each controller is displayed and includes an option to correct each controller configuration, if needed.

---
**Note** If you want to print the report as shown on the window, you must choose landscape page orientation.

Rebooting Config Groups

Follow these steps to reboot a config group.

**Step 1** Choose **Configure > Config Groups**, and click a group name under the Group Name column.

**Step 2** Click the **Reboot** tab.

**Step 3** Click the **Cascade Reboot** check box if you want to reboot one controller at a time, waiting for that controller to come up before rebooting the next controller.

**Step 4** Click **Reboot** to reboot all controllers in the config group at the same time. During the reboot, you can leave this window or logout of Cisco WCS. The process continues, and you can return later to this page and view a report.

The Recent Reboot Report window shows when each controller was rebooted and what the controller status is after the reboot. If WCS is unable to reboot the controller, a failure is shown.

---
**Note** If you want to print the report as shown on the window, you must choose landscape page orientation.
**Downloading Software**

Follow these steps to download software to all controllers in the selected groups after you have a config group established.

**Step 1**  
From Configure > Config Groups, click the check box to choose one or more config groups names on the Config Groups window.

**Step 2**  
Choose **Download Software** from the Select a command drop-down menu and click **GO** (see Figure 8-17).

**Figure 8-17 Download Software Option**

**Step 3**  
The Download Software to Controller window appears. The IP address of the controller to receive the bundle and the current status are displayed. Choose **local machine** from the File is Located On parameter.

**Step 4**  
Enter the maximum number of times the controller should attempt to download the signature file in the **Maximum Retries** parameter.

**Step 5**  
Enter the maximum amount of time in seconds before the controller times out while attempting to download the signature file in the **Timeout** parameter.

**Step 6**  
The signature files are uploaded to the c:\tftp directory. Specify the local file name in that directory or use the **Browse** button to navigate to it. The controller uses this local file name as a base name and then adds _custom.sgi as a suffix.

If the transfer times out for some reason, you can simply choose the TFTP server option in the File Is Located On parameter, and the Server File Name is populated for you and retried.

**Step 7**  
Click **OK**.
**Downloading IDS Signatures**

Follow these steps to download intrusion detection system (IDS) signature files from your config group to a local TFTP server.

**Step 1** From Configure > Config Groups, click the check box to choose one or more config groups on the Config Groups window.

**Step 2** Choose **Download IDS Signatures** from the Select a command drop-down menu and click **GO** (see Figure 8-18).

**Step 3** The Download IDS Signatures to Controller window appears. The IP address of the controller to receive the bundle and the current status are displayed. Choose **local machine** from the File is Located On parameter.

**Step 4** Enter the maximum number of times the controller should attempt to download the signature file in the Maximum Retries parameter.

**Step 5** Enter the maximum amount of time in seconds before the controller times out while attempting to download the signature file in the Timeout parameter.

**Step 6** The signature files are uploaded to the `c:\tftp` directory. Specify the local file name in that directory or use the Browse button to navigate to it. The controller uses this local file name as a base name and then adds _custom.sgi as a suffix.

If the transfer times out for some reason, you can simply choose the TFTP server option in the File Is Located On parameter, and the Server File Name is populated for you and retried.

**Step 7** Click **OK**.
**Downloading Customized WebAuth**

Follow these steps to download customized web authentication.

---

**Step 1**
From Configure > Config Groups, click the check box to choose one or more config groups on the Config Groups window.

**Step 2**
Choose **Download Customized WebAuth** from the Select command drop-down menu and click **GO** (see **Figure 8-19**).

![Figure 8-19 Download Customized Web Auth](image)

**Step 3**
The Download Customized Web Auth Bundle to Controller window appears. The IP address of the controller to receive the bundle and the current status are displayed (see **Figure 8-20**).
Figure 8-20  Download Customized Web Auth Bundle to Controller

Step 4  Choose local machine from the File is Located On parameter.

Step 5  Enter the amount of times the controller should attempt to download the file in the Maximum Retries field.

Step 6  Enter the amount of time in seconds before the controller times out while attempting to download the file in the Timeout field.

Step 7  The WCS Server Files In parameter specifies where the WCS server files are located. Specify the local file name in that directory or use the Browse button to navigate to it.

Step 8  Click OK.

If the transfer times out for some reason, you can simply choose the TFTP server option in the File Is Located On parameter, and the Server File Name is populated for you and retried.
Configuring Controllers and Access Points

This chapter describes how to configure controllers and access points in the Cisco WCS database. This chapter contains the following sections:

- Adding Controllers, page 9-2
- Setting Multiple Country Codes, page 9-3
- Searching Controllers, page 9-4
- Managing User Authentication Order, page 9-5
- Viewing Audit Status (for Controllers), page 9-5
- Viewing Latest Network Audit Report, page 9-6
- Enabling Load-Based CAC for Controllers, page 9-7
- Enabling High Density, page 9-9
- Configuring 802.3 Bridging, page 9-12
- Configuring an RRM Threshold Controller (for 802.11a/n or 802.11b/g/n), page 9-12
- Configuring EDCA Parameters for Individual Controller, page 9-13
- Configuring SNMPv3, page 9-13
- Configuring Global Credentials for Access Points, page 9-14
- Autonomous to LWAPP Migration Support, page 9-15
- Configuring Access Points, page 9-19
- Configuring Access Point Radios for Location Optimized Monitor Mode, page 9-24
- Searching Access Points, page 9-26
- Viewing or Editing Rogue Access Point Rules, page 9-27
- Configuring Spectrum Experts, page 9-28
- Configuring Wired Guest Access, page 9-30
Adding Controllers

You can add controllers one at a time or in batches. Follow these steps to add controllers.

**Step 1** Choose **Configure > Controllers**.

**Step 2** From the Select a command drop-down menu choose **Add Controllers** and click **GO**. The Add Controller window appears (see **Figure 9-1**).

**Figure 9-1** **Add Controller Window**

![Add Controller Window](image)

**Step 3** Choose one of the following:

If you want to add one controller or use commas to separate multiple controllers, leave the Add Format Type drop-down menu at **Device Info**.

If you want to add multiple controllers by importing a CSV file, choose **File** from the Add Format Type drop-down menu. The CSV file allows you to generate your own import file and add the devices you want.

**Note** If you are adding a controller into WCS across a GRE link using IPsec or a lower MTU link with multiple fragments, you may need to adjust the MaxVar Binds PerPDU. If it is set too high, the controller may fail to be added into WCS. To adjust the MaxVarBindsPerPDU setting, do the following: 1) Stop WCS. 2) Go to the location of the the Open SnmpParameters.properties file on the server that is running WCS. 3) Edit MaxVarBindsPerPDU to 50 or lower. 4) Restart WCS.

**Step 4** If you chose Device Info, enter the IP address of the controller you want to add. If you want to add multiple controllers, use a comma between the string of IP addresses.
Setting Multiple Country Codes

To set multiple country support for a single controller(s) that is not part of a mobility group, follow the steps below.

Step 1 Choose Configure > Controllers.
Step 2 Choose the controller for which you are adding countries.
Step 3 Select 802.11 > General from the left sidebar menu. The Controller 802.11 window appears (see Figure 9-2).

Figure 9-2 Controller 802.11

Step 4 Click the check box to choose which country you want to add. Access points are designed for use in many countries with varying regulatory requirements. You can configure a country code to ensure that it complies with your country’s regulations.
Note
Access points may not operate properly if they are not designed for use in your country of operation. For example, an access point with part number AIR-AP1030-A-K9 (which is included in the Americas regulatory domain) cannot be used in Australia. Always be sure to purchase access points that match your country’s regulatory domain. For a complete list of country codes supported per product, refer to http://www.cisco.com/warp/public/779/smbiz/wireless/approvals.html.

Step 5
Enter the time (in seconds) after which the authentication response will timeout.

Step 6
Click Save.

Searching Controllers

Use the controls in the left sidebar to create and save custom searches:

- **New Search** drop-down menu: Opens the Search Controllers window. Use the Search Controllers window to configure, run, and save searches.

- **Saved Searches** drop-down menu: Lists the saved custom searches. To open a saved search, choose it from the Saved Searches list.

- **Edit Link**: Opens the Edit Saved Searches window. You can delete saved searches in the Edit Saved Searches window.

You can configure the following parameters in the Search Controllers window:

- Search for controller by— Choose all controllers, IP address, or controller name.

- Select a Network— Choose all networks or an individual network.

- Save Search— Check the Save Search check box and enter a name in the Save Search text field to save the search in the Saved Searches drop-down list.

- Search by Audit Status— Search by audit status of the following:
  - Not Available: Audit status is not available.
  - Identical: No configuration differences found during last audit.
  - Mismatch: Configuration differences were found between WCS and controller during last audit.

- Items per page—Choose the number of found items to display on the search results window. The range is 10 to 100 items per window. The default is 20.

After you click GO, the controller search results appear:

<table>
<thead>
<tr>
<th><strong>Table 9-1 Search Results</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Parameter</strong></td>
</tr>
<tr>
<td>IP Address</td>
</tr>
<tr>
<td>WCS</td>
</tr>
</tbody>
</table>
Managing User Authentication Order

You can control the order in which authentication servers are used to authenticate a controller’s management users.

**Step 1** Choose Configure > Controllers.
**Step 2** Click an IP address.
**Step 3** From the left sidebar menu, choose Management > Authentication Priority.
**Step 4** The local database is searched first. Choose either RADIUS or TACACS+ for the next search. If authentication using the local database fails, the controller uses the next type of server.
**Step 5** Click Save.

Viewing Audit Status (for Controllers)

An Audit Status column on the Configure > Controllers window shows audit status for each of the controllers based on the last audit. You can also view the network audit report for the selected controllers. The report shows the time of the audit, the IP address of the selected controller, and the synchronization status.

**Step 1** Choose Configure > Controllers.
**Step 2** You can view the latest audit report in one of two ways:
Check the check boxes of the controllers for which you want audit reports. Choose Audit Now from the Select a command drop-down list and click GO. This method shows the report from the network audit task and not an on-demand audit per controller.
or
Click the Audit Status column value to go to the latest audit details page for the selected controller. This method has similar information as the Network Audit report in the Reports menu, but this report is interactive and per controller.
Viewing Latest Network Audit Report

The Network Audit Report shows the time of the audit, the IP address of the selected controller, and the synchronization status.

Note    This method shows the report from the network audit task and not an on-demand audit per controller.

To view the latest network audit report for the selected controllers, follow these steps:

Step 1 Choose Configure > Controllers.
Step 2 Select the check box for the applicable controller.
Step 3 From the Select a command drop-down menu, choose View Latest Network Audit Report.
Step 4 Click GO.

The Audit Summary displays the time of the audit, the IP address of the selected controller, and the audit status. If any configuration differences exist, they are shown in the details.

You can use the General and Schedule tabs to revise the Audit Report parameters.

Note From the All Controllers page, click the Audit Status column value to view the latest audit details page for the selected controller. This method has similar information as the Network Audit report in the Reports menu, but this report is interactive and per controller.

Note To run an on-demand audit report, select which controller you want to run the report on and choose Audit Now from the Select a command drop-down menu. If you run an on-demand audit report and configuration differences are detected, you are given the option to retain the existing controller or WCS values.

Pinging a Network Device from a Controller

Follow these steps to ping network devices from a controller.

Step 1 Click Configure > Controllers to navigate to the All Controllers page.
Step 2 Click the desired IP address to display the IP Address > Controller Properties page.
Step 3 In the sidebar, choose System > Commands to display the IP Address > Controller Commands page.
Step 4 Choose Ping From Controller from the Administrative Commands drop-down menu and click GO.
Step 5 In the Enter an IP Address (x.x.x.x) to Ping window, enter the IP address of the network device that you want the controller to ping and click OK.

WCS displays the Ping Results window, which shows the packets that have been sent and received. Click Restart to ping the network device again or click Close to stop pinging the network device and exit the Ping Results window.

Enabling Load-Based CAC for Controllers

Load-based CAC incorporates a measurement scheme that takes into account the bandwidth consumed by all traffic types from itself, from co-channel access points, and by co-located channel interference. Load-based CAC also covers the additional bandwidth consumption resulting from PHY and channel impairment.

In load-based CAC, the access point periodically measures and updates the utilization of the RF channel, channel interference, and the additional calls that the access point can admit. The access point admits a new call only if the channel has enough unused bandwidth to support that call. By doing so, load-based CAC prevents over-subscription of the channel and maintains QoS under all conditions of WLAN loading and interference.
To enable load-based CAC for a controller template, refer to the “Configuring a Voice Parameter Template (for 802.11a/n or 802.11b/g/n)” section on page 10-61.

To enable load-based CAC for a controller using the WCS web interface, follow these steps.

**Step 1**  
Click **Configure > Controllers**.

**Step 2**  
Click the IP address link of the controller.

**Step 3**  
Click **Voice Parameters** under 802.11a/n or 802.11b/g/n.

The 802.11a/n (or 802.11b/g/n) Voice Parameters page appears (see **Figure 9-3**).

**Figure 9-3  802.11a/n Voice Parameters Page**

**Step 4**  
Click the check box to enable bandwidth CAC. For end users to experience acceptable audio quality during a VoIP phone call, packets must be delivered from one endpoint to another with low latency and low packet loss. To maintain QoS under differing network loads, call admission control (CAC) is required. CAC on an access point allows it to maintain controlled QoS when the network is experiencing congestion and keep the maximum allowed number of calls to an acceptable quantity.

**Step 5**  
Determine if you want to enable load-based CAC for this radio band. Doing so incorporates a measurement scheme that considers the bandwidth consumed by all traffic types from itself, from co-channel access points, and by co-located channel interference.

**Step 6**  
Enter the percentage of maximum bandwidth allowed.

**Step 7**  
Enter the percentage of reserved roaming bandwidth.

**Step 8**  
Click the check box if you want to enable expedited bandwidth as an extension of CAC for emergency calls. You must have an expedited bandwidth IE that is Cisco Compatible Extensions (version 5) compliant so that a TSPEC request is given higher priority.
Step 9 Click the check box if you want to enable metric collection. Traffic stream metrics are a series of statistics about VoIP over your wireless LAN, and they inform you of the QoS of the wireless LAN. For the access point to collect measurement values, traffic stream metrics must be enabled. When this is enabled, the controller begins collecting statistical data every 90 seconds for the 802.11b/g/n interfaces from all associated access points. If you are using VoIP or video, enable this feature.

Step 10 Click Save.

Enabling High Density

The high density deployments are enabled with Cisco Unified Wireless Network software release 4.1 in conjunction with the Cisco and Intel Business Class Suite Version 2 initiative.

The high density networking feature is designed for large, multi-cell high density wireless networks in which it can be challenging to populate a site with a large number of lightweight access points to manage the cumulative bandwidth load while diminishing the contention between access points and still maintaining quality of service. To optimize RF channel capacity and improve network performance, the high density (or pico cell) mode parameters are introduced.

With this feature you can manually configure the transmit power, receiver sensitivity thresholds, and clear channel assessment sensitivity threshold of Intel client devices and Cisco Aironet lightweight access points in order to create optimal high-density deployments. When a client that supports high density associates to an access point with high-density enabled, they exchange specific 802.11 information elements (IEs) that instruct the client to adhere to the access point’s advertised received sensitivity threshold, CCA sensitivity threshold, and transmit power levels. These three parameters reduce the effective cell size by adjusting the received signal strength before an access point and client consider the channel accessible for the transfer of packets. When all access points and clients raise the signal standard in this way throughout a high density area, access points can be deployed closer together, minimizing interference with each other and managing environmental and distant rogue signals.

Note

High density is off by default. There are deployment risks involved if you change from the predetermined values. Do not attempt to configure pico cell functionality within your wireless LAN without the advice of Cisco technical support. Non-standard installation is not supported.

Along with these configuration changes, you can further optimize the pico cell deployment as follows:

Requirements

High density has the following restrictions:

- Only Cisco lightweight access points (except the AP1030 and 1500 series mesh access points) and the Intel PRO/Wireless 3945ABG and Intel Wireless WiFi Link 4965AGN clients are supported.
- Only 802.11a/n networks with high density deployments are supported.

Note Cisco recommends the use of high density only in new WLAN deployments in which all clients and lightweight access points support the high-density feature.
Optimizing the Controller to Support High Density

To optimize a controller to support high density, you need to enable pico cell mode v2. A method to mitigate the inter-cell contention problem in high-density networks is to adjust the access point and client receiver sensitivity, CCA sensitivity, and transmit power parameters in a relatively cooperative manner. By adjusting these variables, the effective cell size can be reduced, not by lowering the transmit power but by increasing the necessary received power before an access point and client consider the channel sufficiently clear for packet transfer. These similar values can be set in the Controller Templates portion of the GUI. Refer to Adding Controller Templates, page 10-1. Follow these steps to configure high density.

If you enable pico cell, the default values for auto RF adjust according to the values suggested for Intel 3945ABG clients. The transmit power is set to 10 dBm, CCA sensitivity threshold to –65 dBm, and receiver sensitivity threshold to –65 dBm.

**Step 1** Choose Configure > Controllers.

**Step 2** From the left sidebar menu, choose 802.11a/n > Parameters or 802.11b/g/n > Parameters. The window as shown in Figure 9-4 appears. Ensure that the 802.11a/n (or 802.11b/g/n) Network Status check box is not enabled.

**Figure 9-4 Pico Cell Parameter**

**Step 3** In the General portion of this window, you see a Pico Cell Mode parameter. Click Enable.
Step 4  Click **Save**.

Step 5  Choose **802.11a/n > Pico Cell** or **802.11b/g/n > Pico Cell** from the left sidebar menu. The Pico Cell Parameters screen appears (see Figure 9-5).

**Figure 9-5  Pico Cell Parameters Window**

Note  Pico cell mode cannot be enabled while Aggressive Load Balancing is enabled on the controller.

Step 6  From the Pico Cell Mode drop-down menu, choose **V2**. By choosing V2, the high-density parameters for the access point and clients share the same values and make communication symmetrical. This selection also allows you to enter values for Rx sensitivity, CCA sensitivity, and transmit power, although the defaulted minimum and maximum values represent the Cisco recommended values for most networks.

Note  If the Pico Cell Mode parameter is set to Disabled or V1, the Pico Cell V2 parameters are grayed out.

Note  Choose V1 only if you are using a legacy Airespace branded product acquired prior to their acquisition by Cisco. Cisco recommends that you choose V2 if you want to enable pico cell mode.

Step 7  Set the Rx sensitivity threshold based on the desired receiver sensitivity for 802.11a/n radios. The Current column shows what is currently set on the access point and clients, and the Min and Max columns show the range to which the access points and clients should adapt. The valid ranges for Current, Min, and Max columns are -127 to 127 dBm. The defaults are -65 dBm (current), -127 dBm (Min), and 127 dBm (Max). Receiver signal strength values outside of this range are blocked.
Step 8 Set the CCA sensitivity threshold based on when the access point or client considers the channel clear enough for activity. The Current column shows what is currently set on the access point and clients, and the Min and Max columns show the range to which the access points and clients should adapt. The valid ranges for Current, Min, and Max columns are -127 to 127 dBm. The defaults are -65 dBm (current), -127 dBm (Min), and 127 dBm (Max). CCA values outside of this range are blocked.

Step 9 Specify the transmit power of the radio that will be used by the client. The valid ranges for Current, Min, and Max columns are -127 to 127 dBm. The defaults are 10 dBm (current), 0 dBm (Min), and 17 dBm (Max).

Step 10 Click Save to save these values. Click Audit to see a comparison of how WCS configuration matches up with controller configurations. Before choosing Reset to Defaults, you must turn off the 802.11a/n network.

Step 11 Return to 802.11a/n > Parameters and check the 802.11a /n Network Status check box to turn the network back on.

---

**Configuring 802.3 Bridging**

The controller supports 802.3 frames and applications that use them, such as those typically used for cash registers and cash register servers. However, to make these applications work with the controller, the 802.3 frames must be bridged on the controller.

Support for raw 802.3 frames allows the controller to bridge non-IP frames for applications not running over IP. Only this raw 802.3 frame format is currently supported.

You can configure 802.3 bridging using WCS release 4.1 or later. Follow these steps.

**Step 1** Click Configure > Controllers.

**Step 2** Click System > General to access the General page.

**Step 3** From the 802.3 Bridging drop-down menu, choose Enable to enable 802.3 bridging on your controller or Disable to disable this feature. The default value is Disable.

**Step 4** Click Save to commit your changes.

---

**Configuring an RRM Threshold Controller (for 802.11a/n or 802.11b/g/n)**

Follow these steps to configure an 802.11a/n or 802.11b/g/n RRM threshold controller.

**Step 1** Choose Configure > Controller.

**Step 2** Click the IP address of the appropriate controller to open the Controller Properties page.

**Step 3** From the left sidebar menu, choose 802.11a/n > RRM Thresholds or 802.11b/g/n > RRM Thresholds.

**Step 4** Make any necessary changes to Coverage Thresholds, Load Thresholds, Other Thresholds, and Noise/Interference/Rogue Monitoring Channels.
Chapter 9   Configuring Controllers and Access Points

Configuring EDCA Parameters for Individual Controller

The EDCA parameters (EDCA profile and Streaming MAC Enable settings) for 802.11a/n and 802.11b/g/n can be configured either by individual controller or through a controller template to improve voice QoS support. Refer to the “Configuring EDCA Parameters through a Controller Template” section on page 10-63 for steps to configure a controller template.

To configure 802.11a/n or 802.11b/g/n EDCA parameters for an individual controller, do the following:

**Step 1** Choose Configure > Controllers.

**Step 2** Click the IP Address of the applicable controller.

**Step 3** From the left sidebar menu, select 802.11a/n > EDCA Parameters or 802.11b/g/n > EDCA Parameters.

**Step 4** Choose the EDCA Profile from the drop-down menu.

- **Note** Profiles include Wi-Fi Multimedia (WMM), Spectralink Voice Priority (SVP), Voice Optimized, and Voice & Video Optimized. WMM is the default EDCA profile.

- **Note** You must shut down radio interface before configuring EDCA Parameters.

**Step 5** Click the Enable Streaming MAC check box to enable this feature.

- **Note** Only enable Streaming MAC if all clients on the network are WMM compliant.

Configuring SNMPv3

When you are configuring a controller, you can add SNMPv3 settings or change the setting (and any other settings) established from the previously added controller. Follow these steps to set the SNMPv3 settings.

**Step 1** Choose Configure > Controllers.
Configuring Global Credentials for Access Points

Cisco IOS access points are shipped from the factory with “Cisco” as the default enable password. This password allows users to log into the non-privileged mode and execute show and debug commands, posing a security threat. The default enable password must be changed to prevent unauthorized access and to enable users to execute configuration commands from the access point’s console port.

In WCS and controller software releases prior to 5.0, you can set the access point enable password only for access points that are currently connected to the controller. In WCS and controller software release 5.0, you can set a global username, password, and enable password that all access points inherit as they join a controller. This includes all access points that are currently joined to the controller and any that join in the future. When you are adding an access point, you can also choose to accept this global username and password or override it on a per-access point basis and assign a unique username, password, and enable password. Refer to the “Configuring Access Point Templates” section on page 10-80 to see where the global password is displayed and how it can be overridden on a per-access point basis.

Also in controller software release 5.0, after an access point joins the controller, the access point enables console port security, and you are prompted for your username and password whenever you log into the access point’s console port. When you log in, you are in non-privileged mode, and you must enter the enable password in order to use the privileged mode.

Note

These controller software release 5.0 features are supported on all access points that have been converted to lightweight mode, except the 1100 series. VxWorks access points are not supported.

The global credentials that you configure on the controller are retained across controller and access point reboots. They are overwritten only if the access point joins a new controller that is configured with a global username and password. If the new controller is not configured with global credentials, the access point retains the global username and password configured for the first controller.

Note

You need to keep careful track of the credentials used by the access points. Otherwise, you might not be able to log into an access point’s console port. If necessary, you can clear the access point configuration to return the access point username and password to the default setting.

Follow these steps to establish a global username and password:

Step 2 Click the IP Address of the applicable controller or choose Add Controller from the Select a command drop-down menu.

Step 3 On the SNMP Parameters portion of the window, choose v3 from the Version drop-down menu.

Step 4 You can change the retries and timeout values that were established for this controller if desired.

Step 5 In the Privacy Type drop-down menu, choose None, CBC-DES, or CFB-AES-128. AES refers to the Advanced Encryption Standard algorithm established by the National Institute of Standards and Technology (NIST). It is more secure than older DES algorithms. CFB (Cipher Feedback) refers to the method AES uses to encrypt the packets, and 128 refers to the key length (128 bits).

Step 6 Any passwords used to derive encryption keys for algorithms using 128 but must contain a minimum of 12 characters. Enter a privacy password that fits this criteria.

Step 7 Click OK.
Autonomous to LWAPP Migration Support

Step 1  Choose **Configure > Controllers** or **Configure > Access Points**.

Step 2  Choose an IP address of a controller with software release 5.0 or later or choose an access point associated with software release 5.0 or later.

Step 3  Choose **System > AP Username Password** from the left sidebar menu. The AP Username Password window appears (see Figure 9-6).

**Figure 9-6  AP Username Password Window**

Step 4  In the AP Username field, enter the username that is to be inherited by all access points that join the controller.

Step 5  In the AP Password field, enter the password that is to be inherited by all access points that join the controller. Re-enter in the Confirm AP Password field.

Step 6  For Cisco IOS access points, you must also enter and confirm an enable password. In the AP Enable Password field, enter the enable password that is to be inherited by all access points that join the controller. Re-enter in the Confirm Enable Password field.

Step 7  Click **Save**.

Autonomous to LWAPP Migration Support

The autonomous to LWAPP migration support feature provides a common application (WCS) from which you can perform basic monitoring of IOS access points along with current LWAPP access points. The following autonomous access points are supported:

- Cisco Aironet 1100 Access Point
- Cisco Aironet 1130 Access Point
You may also choose to convert IOS access points to LWAPP.

From WCS, the following functions are available when managing IOS access points:

- Adding IOS access points
- Configuring IOS access points
- Viewing current IOS access points from the Monitor > Access Points page (see Monitoring Access Points for more information)
- Adding and viewing IOS access points from the Monitor > Maps page (see Maps for more information)
- Monitoring associated alarms
- Performing an autonomous access point background task
  - Checks the status of IOS access points managed by WCS.
  - Generates a critical alarm when an unreachable IOS access point is detected.
  - See Background Task for more information
- Running reports on IOS access points
  - See Reports > Inventory Reports and Reports > Client Reports > Client Count for more information
- Supporting IOS access points in Work Group Bridge (WGB) mode
- Migrating IOS access points to LWAPP access points

### Adding IOS Access Points to WCS

From WCS, the following methods are available for adding IOS access points:

- Add IOS access points by Device information (IP addresses and credentials).
- Add IOS access points by CSV file.

### Adding IOS Access Points by Device Information

IOS access points can be added to WCS by device information using comma-separated IP addresses and credentials.

To add IOS access points using device information, follow these steps:

**Step 1** Choose Configure > Access Points.

**Step 2** From the Select a command drop-down menu, choose Add Autonomous APs.

**Step 3** Click GO.

**Step 4** Select Device Info from the Add Format Type drop-down list.

**Step 5** Enter comma-separated IP addresses of IOS access points.
Chapter 9  Configuring Controllers and Access Points

Autonomous to LWAPP Migration Support

Step 6  Enter the SNMP parameters including version number, number of retries, and timeout in seconds.

Step 7  Enter Telnet credentials for migration (optional).

Note  The Telnet credentials are required to convert the access points from autonomous to unified.

Note  If the autonomous access point already exists, WCS updates the credentials (SNMP and Telnet) to the existing device.

Step 8  Click OK.

Adding Autonomous Access Points by CSV File

Autonomous access points can be added to WCS using a CSV file exported from WLSE. To add autonomous access points using a CSV file, follow these steps:

Step 1  Choose Configure > Access Points.

Step 2  From the Select a Command drop-down menu, choose Add Autonomous APs.

Step 3  Click GO.

Step 4  Select File from the Add Format Type drop-down list.

Step 5  Enter or browse to the applicable CSV file.

Note  The CSV file has the same format as Adding Controllers but includes additional (optional) columns such as telnet_username, telnet_password, and enable_password.

Step 6  Click OK.

To remove an autonomous access point from WCS:

Step 1  Select the check box(es) of the appropriate access point(s).

Step 2  Select Remove APs from the Select a Command drop-down list.

Viewing Autonomous Access Points in WCS

Once added, the autonomous access points can be viewed on the Monitor > Access Points page. Click the autonomous access point to view more detailed information such as:

- Operational status of the access points
- Key attributes including radio information, channel, power, and number of clients on the radio
Autonomous to LWAPP Migration Support

Chapter 9 Configuring Controllers and Access Points

Autonomous to LWAPP Migration Support

-- CDP neighbored information

The autonomous access points can also be viewed in Monitor > Maps.

They can be added to a floor area by choosing Monitor Maps > <floor area> and selecting Add Access Points from the Select a Command drop-down list.

Work Group Bridge (WGB) Mode

Wireless Group Bridge (WGB) mode is a special mode where an autonomous access point functions as a wireless client and connects to an LWAPP access point. The WGB and its wired clients are listed as client in WCS.

Choose Monitor > WGBs to view a list of all WCS clients that are in WGBs. Click a User to view detailed information regarding a specific WGB and its wired clients.

Note

The WCS provides WGB client information for the autonomous access point whether or not it is managed by the WCS. If the WGB access point is also managed by the WCS, WCS provides basic monitoring functions for the access point similar to other autonomous access points.

Autonomous Access Point to LWAPP Access Point Migration

To make a transition from an Autonomous solution to a Unified architecture, autonomous access points must be converted to LWAPP access points. The migration utility is available from the Configure > Migration Templates page where existing templates are listed.

From the Select a command drop-down list, the following functions can be performed:

- Add Template—Allows you to provide necessary information for migration.
- Delete Templates—Allows you to delete a current template.
- View Migration Report—Allows you to view information such as AP address, migration status, timestamp, and a link to detailed logs.
- View Current Status—Allows you to view the progress of the current migration (updated every three seconds).

Note

When migrating an already-managed autonomous access point to LWAPP, its location and antenna information is migrated as well. You do not need to re-input the information. WCS automatically removes the autonomous access point after migration.

Adding/Modifying a Migration Template

To add a new template, select Add Template from the Select a command drop-down list.

To modify an existing template, click the template name from the summary list.

Enter or modify the following migration parameters:

General

- Template Name—User-defined name of this migration template.
• Description—Brief description to help you identify the migration template.

Upgrade Options

• DHCP Support—Ensures that after the conversion every access point gets an IP from the DHCP server.
• Retain AP HostName—Allows you to retain the same hostname for this access point.
• Migrate over WAN Link—Increases the default timeouts for the CLI commands executed on the access point.
• DNS Address
• Domain Name

Controller Details

Note

Ensures that the access point authorization information (SSC) can be configured on this controller and the converted access points can join.

• Controller IP
• User Name
• Password

TFTP Details

• TFTP Server IP
• File Path
• File Name

Once a template is added in WCS, the following additional buttons appear:

• Select APs—Selecting this option provides a list of autonomous access points in WCS from which to choose the access points for conversion.
• Select File—To provide CSV information for access points intended for conversion.

Configuring Access Points

Choose Configure > Access Points to see a summary of all access points in the Cisco WCS database. The summary information includes the following:

• Ethernet MAC
• IP Address
• Radio
• Map Location
• AP Type
• Controller
• Operation Status
Chapter 9  Configuring Controllers and Access Points

Configuring Access Points

- Alarm Status
- Audit Status

**Note** If you hover over the Audit Status value, the time of the last audit is displayed.

**Step 1** Click the link under AP Name to see detailed information about that access point name. The following window appears (see Figure 9-7).

**Figure 9-7  Detailed Access Point Information**

There is no need to add access points to the Cisco WCS database. The operating system software automatically detects and adds an access point to the Cisco WCS database as it associates with existing controllers in the Cisco WCS database.

Some of the parameters on the window are supplied.
- The General portion displays the Ethernet MAC, the Base Radio MAC, and IP Address.
- The Versions portion of the window displays the software and boot version.
- The Inventory Information portion displays the model, IOS version, and serial number and type of the access point, provides which certificate type is required, and determines whether H-REAP mode is supported or not.
- The Radio Interfaces portion provides the current status of the 802.11a/n and 802.11b/g/n radios such as admin status, channel number, power level, antenna mode, antenna diversity, and antenna type.

Follow the steps below to set the configurable parameters.

**Step 2** Enter the name assigned to the access point.
Step 3 Use the drop-down menu to choose a country code to establish multiple country support. Access points are designed for use in many countries with varying regulatory requirements. You can configure a country code to ensure that the access point complies with your country’s regulations. Consider the following when setting the country code:

- You can configure up to 20 countries per controller.
- Because only one auto-RF engine and one list of available channels exist, configuring multiple countries limits the channels available to auto-RF in the common channels. A common channel is one that is legal in each and every configured country.
- When you configure access points for multiple countries, the auto-RF channels are limited to the highest power level available in every configured country. A particular access point may be set to exceed these limitations (or you may manually set the levels in excess of these limitations), but auto-RF does not automatically choose a non-common channel or raise the power level beyond that available in all countries.

Note Access points may not operate properly if they are not designed for use in your country of operation. For example, an (-A) access point with part number AIR-AP1030-A-K9 (which is included in the Americas regulatory domain) cannot be used in Europe (-E). Always be sure to purchase access points that match your country’s regulatory domain. For a complete list of country codes supported per product, refer to http://www.cisco.com/warp/public/779/smbiz/wireless/approvals.html.

Step 4 If you want to enable the access point for administrative purposes, check the Enabled check box.

Step 5 If you click Enabled at the AP Static IP check box, a static IP address is always assigned to the access point rather than getting an IP address dynamically upon reboot.

Step 6 Choose the role of the access point from the AP Mode drop-down menu. No reboot is required after the mode is changed except when monitor mode is selected. You are notified of the reboot when you click Save. The available modes are as follows:

- Local — This is the normal operation of the access point and the default AP Mode choice. With this mode, data clients are serviced while configured channels are scanned for noise and rogues. The access point goes off-channel for 50 ms and listens for rogues. It cycles through each channel for the period specified under the Auto RF configuration.
- Monitor — This is radio receive only mode and allows the access point to scan all configured channels every 12 seconds. Only deauthentication packets are sent in the air with an access point configured this way. A monitor mode access point detects rogues, but it cannot connect to a suspicious rogue as a client to prepare for the sending of RLDP packets.

Note You can expand the monitor mode for tags to include location calculation by enabling the location optimized monitor mode (LOMM) feature. When LOMM is enabled, you can specify which four channels within the 2.4GHz band (802.11b/g radio) of an access point to use to monitor tags. This allows you to focus channel scans on only those channels for which tags are traditionally found (such as channels 1, 6, and 11) in your network. To enable LOMM, you must also make additional edits on the 802.11b/g radio of the access point. Refer to the “Configuring Access Point Radios for Location Optimized Monitor Mode” section on page 9-24 for configuration details.
Rogue Detector — In this mode, the access point radio is turned off, and the access point listens to wired traffic only. The controller sends all the rogue access point and client MAC address lists to the rogue detector, and the rogue detector forwards this information to the WLC. The MAC address list is compared to what the WLC access points expected. If the MAC addresses match, you can determine which rogue access points are connected on the wired network.

Sniffer Mode — Operating in sniffer mode, the access point captures and forwards all the packets on a particular channel to a remote machine that runs Airopeek. These packets contain information such as timestamp, signal strength, packet size, and so on. This feature can only be enabled if you run Airopeek, which is a third-party network analyzer software that supports the decoding of data packets. For more information on Airopeek, see www.wildpackets.com/products/airopeek/overview.

HREAP — Choose HREAP from the AP Mode drop-down menu to enable hybrid REAP for up to six access points. The HREAP access points can switch client data traffic locally and perform client authentication locally when their connection to the controller is lost.

Step 7 In the Primary, Secondary, and Tertiary Controller fields, you can define the order in which controllers are accessed.

Step 8 The AP Group Name drop-down shows all access point group names that have been defined using WLANs > AP Group VLANs, and you can specify whether this access point is tied to any group.

Step 9 Enter a description of the physical location where the access point was placed.

Step 10 In the Stats Collection Period parameter, enter the time in which the access point sends .11 statistics to the controller. The valid range is 0 to 65535 seconds. A value of 0 means statistics should not be sent.

Step 11 Choose Enabled for Mirror Mode if you want to duplicate (to another port) all of the traffic originating from or terminating at a single client device or access point. Mirror mode is useful in diagnosing specific network problems but should only be enabled on an unused port since any connections to this port become unresponsive.

Step 12 You can globally configure MFP on a controller. When you do, management frame protection and validation are enabled by default for each joined access point, and access point authentication is automatically disabled. After MFP is globally enabled on a controller, you can disable and re-enable it for individual WLANs and access points.

If you click to enable MFP Frame Validation, three main functions are performed:

- Management frame protection — When management frame protection is enabled, the access point protects the management frames it transmits by adding a message integrity check information element (MIC IE) to each frame. Any attempt to copy, alter, or replay the frame invalidates the MIC, and the receiving access points which were configured to detect MFP frames report the discrepancy.
- Management frame validation — When management frame validation is enabled, the access point validates every management frame it receives from other access points in the network. When the originator is configured to transmit MFP frames, the access point ensures that the MIC IE is present and matches the content of the management frame. If it receives any frame that does not contain a valid MIC IE, it reports the discrepancy to the network management system. In order to report this discrepancy, the access point must have been configured to transmit MFP frames. Likewise, for the timestamps to operate properly, all controllers must be Network Transfer Protocol (NTP) synchronized.
- Event reporting — The access point notifies the controller when it detects an anomaly, and the controller aggregates the received anomaly events and reports the results through SNMP traps to alert the network manager.
Click the **Cisco Discovery Protocol** check box if you want to enable it. CDP is a device discovery protocol that runs on all Cisco-manufactured equipment, such as routers, bridges, and communication servers. Each device sends periodic messages to a multicast address and listens to the messages that others send in order to learn about neighboring devices. When the device boots, it sends a CDP packet specifying whether the device is inline power enabled so that the requested power can be supplied.

### Note
Changing access point parameters temporarily disables an access point and might result in loss of connectivity to some clients.

On the System > AP Username Password window, you can set global credentials for all access points to inherit as they join a controller. These established credentials are displayed in the lower right of the AP Parameters tab window. If you want to override the global credentials for this particular access point, click the **Override Global Username Password** check box. You can then enter a unique username, password, and enable password that you want to assign to this access point.

Select the role of the mesh access point from the AP Role drop-down menu. The default setting is MAP.

### Note
An access point in a mesh network functions as either a root access point (RAP) or mesh access point (MAP).

Enter the name of the bridge group to which the access point belongs. The name can have up to 10 characters.

### Note
Bridge groups are used to logically group the mesh access points to avoid two networks on the same channel from communicating with each other.

### Note
For mesh access points to communicate, they must have the same bridge group name.

### Note
For configurations with multiple RAPs, make sure that all RAPs have the same bridge group name to allow failover from one RAP to another.

### Note
For configurations where separate sectors are required, make sure that each RAP and its associated MAPs have separate bridge group names.

The Type parameter appears whether the mesh access point is an indoor or outdoor access point, and the Backhaul Interface parameter displays the access point radio that is being used as the backhaul for the access point.

Select the data rate for the backhaul interface from the drop-down menu. Data rates available are dictated by the backhaul interface. The default rate is 18 Mbps.

### Note
This data rate is shared between the mesh access points and is fixed for the whole mesh network.
Configuring Access Point Radios for Location Optimized Monitor Mode

To optimize monitoring and location calculation of tags, you can enable LOMM on up to four channels within the 2.4 GHz band (802.11b/g radio) of an access point. This allows you to focus channel scans only on those channels on which tags are usually programmed to operate (such as channels 1, 6, and 11). After enabling Monitor Mode at the access point level, you must then enable LOMM and assign monitoring channels on the 802.11b/g radio of the access point.

Follow the steps below to set enable LOMM and assign monitoring channels on the access point radio.

**Step 1**
After enabling Monitor Mode at the access point level, choose **Configure > Access Points**.

**Step 2**
At the All Access Points Summary window, choose the **802.11 b/g Radio** link for the appropriate access point.

**Step 3**
At the Radio parameters window, disable **Admin Status** by unchecking the check box. This disables the radio.

**Step 4**
Check the **Location Optimized Channel Assignment** checkbox. Drop-down menus for each of the four configurable channels display.

**Step 5**
Select the four channels on which you want the access point to monitor tags.

**Note**
You can configure fewer than four channels for monitoring. To eliminate a monitoring channel, select **None** from the channel drop-down menu.

**Step 6**
Click **Save**. Channel selection is saved.

**Step 7**
At the Radio parameters window, re-enable the radio by checking the **Admin Status** check box.

**Step 8**
Click **Save**. The access point is now configured as a LOMM access point.
The AP Mode displays as Monitor/LOMM on the Monitor > Access Points window.

Scheduling Radio Status

To schedule a radio status change (enable or disable), follow these steps:

**Step 1** Choose Configure > Access Points.
**Step 2** Choose the check box for the applicable access point(s).
**Step 3** From the Select a command drop-down menu, choose Schedule Radio status.
**Step 4** Click GO.
**Step 5** Choose Enable or Disable from the Admin Status drop-down menu.
**Step 6** Use the Hours and Minutes drop-down menus to determine the scheduled time.
**Step 7** Click the calendar icon to select the scheduled date for the status change.
**Step 8** If the scheduled task is recurring, choose Daily or Weekly, as applicable. If the scheduled task is a one-time event, choose No Recurrence.
**Step 9** Choose Submit to confirm the scheduled task.

Viewing Scheduled Tasks

To view currently scheduled radio status tasks, follow these steps:

**Step 1** Choose Configure > Access Points.
**Step 2** Choose the check box for the applicable access point(s).
**Step 3** From the Select a command drop-down menu, choose View Scheduled Task(s).
**Step 4** Click GO.

The Scheduled Task(s) information includes:
- Scheduled Task(s)—Choose the task to view its access points and access point radios.
- Scheduled Radio adminStatus—Indicates the status change (Enable or Disable).
- Schedule Time—Indicates the time the schedule task occurs.
- Execution status—Indicates whether or not the task is scheduled.
- Recurrence—Indicates Daily or Weekly if the scheduled task is recurring.
- Next Execution—Indicates the time and date of the next task occurrence.
- Last Execution—Indicates the time and date of the last task occurrence.
- Unschedule—Click Unschedule to cancel the scheduled task. Click OK to confirm the cancellation.
Viewing Audit Status (for Access Points)

An Audit Status column on the Configure > Access Points window shows an audit status for each of the access points. You can also view the audit report for the selected access points. The report shows the time of the audit, the IP address of the selected access point, and the synchronization status.

**Step 1** Choose Configure > Access Points.

**Step 2** Click the Audit Status column value to go to the latest audit details page for the selected access point. This report is interactive and per access point.

**Note** If you hover over the Audit Status column value, the time of the last audit is displayed.

To run an access point on-demand audit report, select the desired access point for which you want to run the report and choose Audit Now from the Select a command drop-down menu. In versions prior to 4.1, the audit only spanned the parameters present on the AP Details and AP Interface Details page. In release 4.1, this audit report covers complete access point level auditing. The audit results are stored in the database so that you can view the latest audit reports without having to run another audit.

**Note** The audit can only be run on an access point that is associated to a controller.

Searching Access Points

Use the controls in the left sidebar to create and save custom searches:

- **New Search** drop-down menu: Opens the Search Access Points window. Use the Search Access Points window to configure, run, and save searches.

- **Saved Searches** drop-down menu: Lists the saved custom searches. To open a saved search, choose it from the Saved Searches list.

- **Edit Link**: Opens the Edit Saved Searches window. You can delete saved searches in the Edit Saved Searches window.

You can configure the following parameters in the Search Access Points window:

- Search By
- Radio Type
- Search in
- Save Search
- Items per page

After you click GO, the access point search results appear:
Chapter 9      Configuring Controllers and Access Points

Viewing or Editing Rogue Access Point Rules

You can view or edit current rogue access point rules on a single WLC. Follow these steps to access the rogue access point rules. Refer to the “Configuring a Rogue AP Rules Template” section on page 10-43 for more information.

**Step 1** Choose **Configure > Controllers**.

**Step 2** Click an IP address under the IP Address column.

**Step 3** From the left sidebar menu, choose **Security > Rogue AP Rules**. The Rogue AP Rules displays the rogue access point rules, the rule types (malicious or friendly), and the rule sequence.

**Step 4** Choose a **Rogue AP Rule** to view or edit its details.

---

**Table 9-2   Access Point Search Results**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>AP Name</td>
<td>Name assigned to the access point. Click the access point name item to display details.</td>
</tr>
<tr>
<td>WCS</td>
<td>WCS name where access point was detected.</td>
</tr>
<tr>
<td>Ethernet MAC</td>
<td>MAC address of the access point.</td>
</tr>
<tr>
<td>IP Address</td>
<td>IP address of the access point.</td>
</tr>
<tr>
<td>Radio</td>
<td>Protocol of the access point is either 802.11a/n or 802.11b/g/n.</td>
</tr>
<tr>
<td>Map Location</td>
<td>Campus, building, and floor location.</td>
</tr>
<tr>
<td>Controller</td>
<td>IP address of the controller.</td>
</tr>
<tr>
<td>Admin Status</td>
<td>Administration site of the access point (Enabled or Disabled).</td>
</tr>
<tr>
<td>AP Type</td>
<td>Access point radio frequency type.</td>
</tr>
<tr>
<td>Operational Status</td>
<td>Displays the operational status of the Cisco radios (Up or Down).</td>
</tr>
<tr>
<td>Alarm Status</td>
<td>Alarms are color coded as follows:</td>
</tr>
<tr>
<td></td>
<td>• Clear = No Alarm</td>
</tr>
<tr>
<td></td>
<td>• Red = Critical Alarm</td>
</tr>
<tr>
<td></td>
<td>• Orange = Major Alarm</td>
</tr>
<tr>
<td></td>
<td>• Yellow = Minor Alarm</td>
</tr>
</tbody>
</table>
Configuring Spectrum Experts

A Spectrum Expert client acts as a remote interference sensor and sends dynamic interference data to WCS. This feature allows the WCS to collect, monitor, and archive detailed interferer data from Spectrum Experts in the network.

To configure spectrum experts, choose Configure > Spectrum Experts. This page provides a list of all Spectrum Experts including:
- Hostname—The hostname or IP address of the Spectrum Expert laptop.
- MAC Address—The MAC address of the spectrum sensor card in the laptop.
- Reachability Status—Specifies whether the Spectrum Expert is successfully running and sending information to WCS. The status appears as reachable or unreachable.

Adding a Spectrum Expert

To add a Spectrum Expert, follow these steps:

2. Click Add a Spectrum Expert.
   - **Note** This link only appears when no spectrum experts are added. You can also access the Add a Spectrum Expert page by choosing Add a Spectrum Expert from the Select a command drop-down menu.
3. Enter the Spectrum Expert’s Hostname or IP address. If you use hostname, your spectrum expert must be registered with DNS in order to be added to WCS.
   - **Note** To be correctly added as a spectrum expert, the spectrum expert client must be running and configured to communicate to WCS.

Monitoring Spectrum Experts

You also have the option to monitor spectrum experts. Follow these steps to monitor spectrum experts:

2. From the left sidebar menu, you can access the Spectrum Experts > Summary page and the Interferers > Summary page.
Spectrum Experts > Summary

The Spectrum Experts Summary page provides a table of the Spectrum Experts added to the system. The table provides the following Spectrum Expert information:

Hostname—Displays the host name or IP address.

Active Interferers—Indicates the current number of interferers being detected by the Spectrum Experts.

Alarms APs—The number of access points seen by the Spectrum Experts that are potentially affected by detected interferers.

Alarms—The number of active interference traps sent by the Spectrum Expert. Click to access the Alarm page that is filtered to the active alarms for this Spectrum Expert.

Reachability Status—Indicates “Reachable” in green if the Spectrum Expert is running and sending data to WCS. Otherwise, indicates “unreachable” in red.

Location—When the Spectrum Expert is a wireless client, a link for location is available. It shows the location of the Spectrum Expert with a red box that shows the effective range.

Interferers > Summary

The Interferers Summary page displays a list of all the interferers detected over a 30-day interval. The table provides the following interferers’ information:

- Interferer ID—An identifier that is unique across different spectrum experts.
- Category—Indicates the category of the interferer. Categories include: Bluetooth, cordless phones, microwave ovens, 802.11 FH, generic: fixed-frequency, jammers, generic: frequency-hopped, generic:continuous, and analog video.
- Type—Active indicates that the interferer is currently being detected by a spectrum expert. Inactive indicates that the interferer is no longer detected by a spectrum expert or the spectrum expert saw that the interferer is no longer reachable by WCS.
- Discover Time—Indicates when the interferer was discovered.
- Affected Channels—Identifies affected channels.
- Number of APs Affected—The number of access points managed by WCS that the spectrum expert detects or the interferers that the spectrum expert detected on the channels of the access point. Only active interferers are shown. If all of the following conditions are met, the access point is labelled as affected:
  - If the access point is managed by WCS.
  - If the spectrum expects detects the access point.
  - If the spectrum expert detects an interferer on the serving channel of the access point.
- Power—Indicated in dBm.
- Duty Cycle—Indicated in percentage. 100% is the worst value.
- Severity—Indicates the severity ranking of the interferer. 100 is the worst case whereas 0 is no interference.
Spectrum Experts Details

The Spectrum Expert Details page provides all interference details from a single Spectrum Expert. This page updates every 20 seconds and gives a real-time look at the remote spectrum expert. This page includes the following items:

- **Total Interferer Count**—Given from the specific spectrum expert.
- **Active Interferers Count Chart**—Displays a pie chart that groups interferers by category.
- **Active Interferer Count Per Channel**—Displays the number of interferers grouped by category on different channels.
- **AP List**—Provides a list of access points detected by the spectrum expert. These access points are on channels that have active interferers detected.
- **Affected Clients List**—Provides a list of clients that are currently authenticated to an access point in the access point list.

Configuring Wired Guest Access

Wired Guest Access enables guest users to connect to the guest access network from a wired Ethernet connection designated and configured for guest access. Wired guest access ports might be available in a guest office or specific ports in a conference room.

Like wireless guest user accounts, wired guest access ports are added to the network using the Lobby Ambassador feature. Refer to the “Creating Guest User Accounts” section on page 7-12.

Wired Guest Access can be configured in a standalone configuration or in a dual controller configuration employing an anchor and foreign controller. This latter configuration is used to further isolate wired guest access traffic but is not required for deployment of wired guest access.

Wired Guest Access ports initially terminate on a Layer 2 access switch or switch port which is configured with VLAN interfaces for wired guest access traffic.

The wired guest traffic is then trunked from the access switch to a wireless LAN controller. This controller is configured with an interface that is mapped to a wired guest access VLAN on the access switch.

If two controllers are being used, the controller (foreign) that receives the wired guest traffic from the switch then forwards the wired guest traffic to an anchor controller that is also configured for wired guest access. After successful hand off of the wired guest traffic to the anchor controller, a bidirectional Ethernet over IP (EoIP) tunnel is established between the foreign and anchor controllers to handle this traffic.

---

**Note**

Although wired guest access is managed by anchor and foreign anchors when two controllers are deployed, mobility is not supported for wired guest access clients. In this case, DHCP and web authentication for the client are handled by the anchor controller.

---

**Note**

You can specify how much bandwidth a wired guest user is allocated in the network by configuring and assigning a role and bandwidth contract. For details on configuring these features, refer to the “Creating Guest User Accounts” section on page 7-12.

---

Follow these steps to configure and enable wired guest user access on the network.
Step 1  To configure a dynamic interface for wired guest user access, click Configure > Controllers and after choosing a particular IP address, choose System > Interfaces. The Interfaces summary window appears.

Step 2  Choose Add Interface from the Select a command drop-down menu and click GO.

Step 3  Enter a name and VLAN ID for the new interface.

Step 4  Check the Guest LAN check box.

Step 5  Enter the IP address, netmask, and gateway address for the interface.

Step 6  Enter an IP address address for the primary and secondary DHCP server.

Step 7  Click Save. You are now ready to create a wired LAN for guest access.

Step 8  To configure a wired LAN for guest user access, click WLANs > WLAN from the left sidebar menu.

Step 9  Choose Add WLAN from the Select a command drop-down menu and click GO.

Step 10  If you have a template established that you want to apply to this controller, choose the guest LAN template name from the drop-down menu. Otherwise, click the click here link to create a new template.

Step 11  At the > New Template general panel, enter a name in the Profile Name field that identifies the guest LAN. Do not use any spaces in the name entered.

Step 12  Check the Enabled check box for the WLAN Status parameter.

Step 13  From the Ingress Interface drop-down menu, choose the VLAN that you created in Step 3. This VLAN provides a path between the wired guest client and the controller by way of the Layer 2 access switch.

Step 14  From the Egress Interface drop-down menu, choose the name of the interface. This provides a path out of the controller for wired guest client traffic.

Note  If you have only one controller in the configuration, choose management from the Egress Interface drop-down menu.

Step 15  Click Security > Layer 3 to modify the default security policy (web authentication) or to assign specific web authentication (login, logout, login failure) pages and the server source.

a.  To change the security policy to passthrough, check the Web Policy check box and the Passthrough option. This option allows users to access the network without entering a username or password.

   An Email Input check box appears. Check this check box if you want users to be prompted for their e-mail address when attempting to connect to the network.

b.  To specify custom web authentication windows, uncheck the Global WebAuth Configuration Enabled check box.

   1.  When the Web Auth Type drop-down menu appears, choose one of the following options to define the web login page for the wireless guest users:

      Internal—Displays the default web login page for the controller. This is the default value.

      Customized—Displays custom web login, login failure, and logout pages. When the customized option is selected, three separate drop-down menus for login, login failure, and logout page selection appear. You do not need to define a customized page for all three of the options. Choose None from the appropriate drop-down menu if you do not want to display a customized page for that option.

      These optional login, login failure, and logout pages are downloaded to the controller as webauth.tar files. For specifics on downloading custom pages, refer to the “Downloading Customized Web Authentication” section on page 3-18.
External—Redirects users to an external server for authentication. If you choose this option, you must also enter the URL of the external server in the URL field.

You can select specific RADIUS or LDAP servers to provide external authentication on the Security > AAA panel. To do so, continue with Step 16.

Note

The RADIUS and LDAP external servers must be already configured to have selectable options on the Security > AAA panel. You can configure these servers on the RADIUS Authentication Servers page, TACACS+ Authentication Servers page, and LDAP Servers page.

**Step 16**
If you selected External as the Web Authentication Type in Step 15, click Security > AAA and select up to three RADIUS and LDAP servers using the drop-down menus.

**Step 17**
Click Save.

**Step 18**
Repeat this process if a second (anchor) controller is being used in the network.
Using Templates

This chapter describes how to add and apply controller templates. Information on creating (adding) access point templates is also provided.

Templates allow you to set parameters that you can then apply to multiple devices without having to re-enter the common information.

Note

Template information can be overridden on individual devices.

This chapter contains these sections:

- Adding Controller Templates, page 10-1
- Applying Controller Templates, page 10-79
- Adding Access Point Templates, page 10-79
- Configuring Access Point Templates, page 10-80

Adding Controller Templates

Follow these steps to add a new controller template.

Step 1 Choose Configure > Controller Templates.
Step 2 Choose Add Template from the Select a command drop-down menu and click GO.
Step 3 Enter the template name.
Step 4 Provide a description of the template.
Step 5 Click Save.

A summary of the templates that can be added is highlighted below:

- Configuring an NTP Server Template, page 10-3
- Configuring General Templates, page 10-4
- Configuring QoS Templates, page 10-7
- Configuring a Traffic Stream Metrics QoS Template, page 10-8
- Configuring WLAN Templates, page 10-9
• Configuring H-REAP AP Groups, page 10-21
• Configuring a File Encryption Template, page 10-22
• Configuring a RADIUS Authentication Template, page 10-23
• Configuring a RADIUS Accounting Template, page 10-25
• Configuring a LDAP Server Template, page 10-26
• Configuring a TACACS+ Server Template, page 10-27
• Configuring a Network Access Control Template, page 10-28
• Configuring a Local EAP General Template, page 10-29
• Configuring a Local EAP Profile Template, page 10-31
• Configuring an EAP-FAST Template, page 10-32
• Configuring Network User Credential Retrieval Priority Templates, page 10-34
• Configuring a Local Network Users Template, page 10-34
• Configuring Guest User Templates, page 10-36
• Configuring a User Login Policies Template, page 10-37
• Configuring a MAC Filter Template, page 10-38
• Configuring an Access Point or LBS Authorization, page 10-39
• Configuring a Manually Disabled Client Template, page 10-40
• Configuring a CPU Access Control List (ACL) Template, page 10-41
• Configuring a Rogue Policies Template, page 10-42
• Configuring a Rogue AP Rules Template, page 10-43
• Configuring a Rogue AP Rule Groups Template, page 10-45
• Configuring a Friendly Access Point Template, page 10-47
• Configuring a Client Exclusion Policies Template, page 10-48
• Configuring an Access Point Authentication and MFP Template, page 10-50
• Configuring a Web Authentication Template, page 10-51
• Configuring Access Control List Templates, page 10-55
• Configuring a Policy Name Template (for 802.11a/n or 802.11b/g/n), page 10-56
• Configuring High Density Templates, page 10-59
• Configuring a Voice Parameter Template (for 802.11a/n or 802.11b/g/n), page 10-61
• Configuring EDCA Parameters through a Controller Template, page 10-63
• Configuring EDCA Parameters through a Controller Template, page 10-63
• Configuring an RRM Threshold Template (for 802.11a/n or 802.11b/g/n), page 10-65
• Configuring an RRM Interval Template (for 802.11a/n or 802.11b/g/n), page 10-66
• Configuring an 802.11h Template, page 10-67
• Configuring a High Throughput Template (for 802.11a/n or 802.11b/g/n), page 10-68
• Configuring a Mesh Template, page 10-69
• Configuring a TFTP Server Template, page 10-71
• Configuring a Trap Receiver Template, page 10-71
Chapter 10  Using Templates

Adding Controller Templates

- Configuring a Trap Control Template, page 10-72
- Configuring a Telnet SSH Template, page 10-74
- Configuring a Legacy Syslog Template, page 10-75
- Configuring a Multiple Syslog Template, page 10-76
- Configuring a Local Management User Template, page 10-77
- Configuring a User Authentication Priority Template, page 10-78
- Configuring Radio Templates, page 10-82

Configuring an NTP Server Template

Follow these steps to add a new network time protocol (NTP) server template to the controller configuration or make modifications to an existing NTP template. NTP is used to synchronize computer clocks on the internet.

Step 1 Choose Configure > Controller Templates.
Step 2 Choose System > Network Time Protocol from the left sidebar menu.
Step 3 To add a new template, choose Add Template from the Select a command drop-down menu and click GO. To modify an existing template, click to select a template in the Template Name column. The NTP Server Template window appears (see Figure 10-1), and the number of controllers the template is applied to automatically populates.

Figure 10-1  NTP Servers Template

Step 4 Enter the NTP server IP address.
Step 5 Click Save.
Configuring General Templates

Follow these steps to add a new template with general information for a controller or make a change to an existing template.

**Step 1** Choose **Configure > Controller Templates**.

**Step 2** From the left sidebar menu, choose **System > General**.

**Step 3** To add a new template, choose **Add Template** from the Select a command drop-down menu and click GO. To modify an existing template, click to select a template in the Template Name column. The General Template window appears (see **Figure 10-2**).

**Figure 10-2** General Template

<table>
<thead>
<tr>
<th>Wireless Control System</th>
<th>General Template &gt; Template &quot;Switching_3177&quot;</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General</strong></td>
<td></td>
</tr>
<tr>
<td>Template Name</td>
<td>Switching_3177</td>
</tr>
<tr>
<td>Enable/Disable</td>
<td></td>
</tr>
<tr>
<td>BGU in Non-Clear Mode</td>
<td>Disable</td>
</tr>
<tr>
<td>802.3 Bridging</td>
<td>Enable</td>
</tr>
<tr>
<td>LWAPP Transport Mode</td>
<td>Layer3</td>
</tr>
<tr>
<td>Ethernet Multicast Support</td>
<td>Enable</td>
</tr>
<tr>
<td>Aggressive Load Balancing</td>
<td>Disable</td>
</tr>
<tr>
<td>Peer to Peer Bridging Mode</td>
<td>Enable</td>
</tr>
<tr>
<td>Over Air Provision AP Mode</td>
<td>Disable</td>
</tr>
<tr>
<td>AP Failover</td>
<td>Enable</td>
</tr>
<tr>
<td>Apple Talk Bridging</td>
<td>Disable</td>
</tr>
<tr>
<td>Port CTS Change</td>
<td>Enable</td>
</tr>
<tr>
<td>Master Controller Mode</td>
<td>Disable</td>
</tr>
<tr>
<td>Wireless Management</td>
<td>Enable</td>
</tr>
<tr>
<td>Link Aggregation</td>
<td>Disable</td>
</tr>
<tr>
<td>Symmetric Tunneling Mode</td>
<td>Enable</td>
</tr>
<tr>
<td>Default Mobility Domain Name</td>
<td>Default</td>
</tr>
<tr>
<td>Mobile Anchor Group Keep Alive Interval</td>
<td>10</td>
</tr>
<tr>
<td>Mobility Anchor Group Keep Alive Minutes</td>
<td>3</td>
</tr>
<tr>
<td>AP Network Name</td>
<td>Default</td>
</tr>
<tr>
<td>User Idle Timeout (seconds)</td>
<td>300</td>
</tr>
<tr>
<td>CDP Version (seconds)</td>
<td>300</td>
</tr>
<tr>
<td>CDP Advertisement Version</td>
<td>1v1</td>
</tr>
</tbody>
</table>

**Step 4** Use the drop-down menu to enable or disable flow control mode.

**Step 5** Use the drop-down menu to enable or disable 802.3 bridging.

**Step 6** Specify Layer 2 or Layer 3 transport mode. When set to Layer 3, the LWAPP uses IP addresses to communicate with the access points; these IP addresses are collected from a mandatory DHCP server. When set to Layer 2, the LWAPP uses proprietary code to communicate with the access points.

**Step 7** At the Ethernet Multicast Support drop-down menu, choose **Disable** to disable multicast support on the controller or **Multicast** to enable multicast support on the controller. Choose **Unicast** if the controller, upon receiving a multicast packet, forwards the packets to all the associated access points. H-REAP supports only unicast mode.

**Step 8** Choose if you want to enable or disable aggressive load balancing.
Step 9  Choose to enable or disable peer-to-peer blocking mode. If you choose Disable, any same-subnet clients communicate through the controller. If you choose Enable, any same-subnet clients communicate through a higher-level router.

Step 10  At the Over Air AP Provision Mode drop-down menu, choose enable or disable.

Step 11  At the AP Fallback drop-down menu, choose enable or disable. Enabling fallback causes an access point which lost a primary controller connection to automatically return to service when the primary controller returns.

Step 12  Choose to enable or disable Apple talk bridging.

Step 13  Choose to enable or disable the fast SSID option. If enabled, the client connects instantly to the controller between SSIDs without having appreciable loss of connectivity. Normally, each client is connected to a particular WLAN identified by the SSID. If the client moves out of reach of the connected access point, the client has to reconnect to the controller using a different access point. This normal process consumes some time as the DHCP (Dynamic Host Configuration Protocol) server has to assign an IP address to the client.

Step 14  Because the master controller is normally not used in a deployed network, the master controller setting is automatically disabled upon reboot or OS code upgrade. You may enable the controller as the master controller from the Master Controller Mode drop-down menu.

Step 15  Choose to enable or disable access to the controller management interface from wireless clients. Because of IPSec operation, management via wireless is only available to operators logging in across WPA, Static WEP, or VPN Pass Through WLANs. Wireless management is not available to clients attempting to log in via an IPSec WLAN.

Step 16  Choose to enable or disable link aggregation. Link aggregation allows you to reduce the number of IP addresses needed to configure the ports on your controller by grouping all the physical ports and creating a link aggregation group (LAG). In a 4402 model, two ports are combined to form a LAG whereas in a 4404 model, all four ports are combined to form a LAG.

If LAG is enabled on a controller, the following configuration changes occur:

- Any dynamic interfaces that you have created are deleted. This is done to prevent configuration inconsistencies in the interface database.
- Interfaces cannot be created with the “Dynamic AP Manager” flag set.

**Note**  You cannot create more than one LAG on a controller.

The advantages of creating a LAG are as follows:

- It ensures that if one of the links goes down, the traffic is moved to the other links in the LAG. Hence, as long as one of the physical ports is working, the system remains functional.
- It eliminates the need to configure separate backup ports for each interface.
- Multiple AP-manager interfaces are not required since only one logical port is visible to the application.

**Note**  When you make changes to the LAG configuration, the controller has to be rebooted for the changes to take effect.

Step 17  Choose to enable or disable symmetric mobility tunneling. With symmetric mobility tunneling, the controller provides inter-subnet mobility for clients roaming from one access point to another within a wireless LAN. The client traffic on the wired network is directly routed by the foreign controller. If a
router has reverse path filtering (RPF) enabled (which provides additional checks on incoming packets), the communication is blocked. Symmetric mobility tunneling allows the client traffic to reach the controller designated as the anchor, even with RPF enabled.

Note

All controllers in a mobility group should have the same symmetric tunneling mode.

Note

For symmetric tunneling to take effect, you must reboot.

Step 18 Enter the operator-defined RF mobility group name in the Default Mobility Domain Name field.

Step 19 At the Mobility Anchor Group Keep Alive Interval, determine the delay between tries for clients attempting to join another access point. With this guest tunneling N+1 redundancy feature, the time it takes for a client to join another access point following a controller failure is decreased because a failure is quickly identified, the clients are moved away from the problem controller, and the clients are anchored to another controller.

Note When you hover over the parameter field with the mouse, the valid range for that field appears.

Step 20 At the Mobility Anchor Group Keep Alive Retries, specify the number of queries to anchor before the client declares it unreachable.

Note When you hover over the parameter field with the mouse, the valid range for that field appears.

Step 21 Enter the RF network group name between 8 and 19 characters. Radio Resource Management (RRM) neighbor packets are distributed among access points within an RF network group. The Cisco access points only accept RRM neighbor packets sent with this RF network name. The RRM neighbor packets sent with different RF network names are dropped.

Step 22 Specify the time out for idle clients. The factory default is 300 seconds. When the timeout expires, the client loses authentication, briefly disassociates from the access point, reassociates, and re-authenticates.

Step 23 Specify the timeout in seconds for the address resolution protocol. The factory default is 300 seconds.

Step 24 At the CDP on controller drop-down menu, choose if you want to enable CDP on the controller. CDP is a device discovery protocol that runs on all Cisco manufactured equipment (such as routers, bridges, communication servers, and so on).

Step 25 At the Global CDP on APs drop-down menu, choose if you want to enable CDP on the access point.

Step 26 At the Refresh Time Interval parameter, enter the interval at which CDP messages are generated. With the regeneration, the neighbor entries are refreshed.

Step 27 At the Holdtime parameter, enter the time in seconds before the CDP neighbor entry expires.

Step 28 At the CDP Advertisement Version parameter, enter which version of the CDP protocol to use.

Step 29 Click Save.
Configuring QoS Templates

Follow these steps to make modifications to the quality of service profiles.

**Step 1** Choose **Configure > Controller Templates**.

**Step 2** On the left sidebar menu, choose **System > QoS Profiles**. The QoS Template window appears (see Figure 10-3), and the number of controllers the template is applied to automatically populates.

**Figure 10-3 QoS Profile Template**

![Figure 10-3 QoS Profile Template](image)

**Step 3** Set the following values in the Per-User Bandwidth Contracts portion of the window. All have a default of 0 or Off.

- **Average Data Rate** - The average data rate for non-UDP traffic.
- **Burst Data Rate** - The peak data rate for non-UDP traffic.
- **Average Real-time Rate** - The average data rate for UDP traffic.
- **Burst Real-time Rate** - The peak data rate for UDP traffic.

**Step 4** Set the following values for the Over-the-Air QoS portion of the window.

- **Maximum QoS RF Usage per AP** - The maximum air bandwidth available to clients. The default is 100%.
- **QoS Queue Depth** - The depth of queue for a class of client. The packets with a greater value are dropped at the access point.

**Step 5** Set the following values in the Wired QoS Protocol portion of the window.

- **Wired QoS Protocol** - Choose 802.1P to activate 802.1P priority tags or None to deactivate 802.1P priority flags.
- **802.1P Tag** - Choose 802.1P priority tag for a wired connection from 0 to 7. This tag is used for traffic and LWAPP packets.
Configuring a Traffic Stream Metrics QoS Template

Traffic stream metrics are a series of statistics about VoIP over your wireless LAN and informs you of the QoS of the wireless LAN. These statistics are different than the end-to-end statistics provided by VoIP systems. End-to-end statistics provide information on packet loss and latency covering all the links comprising the call path. However, traffic stream metrics are statistics for only the WLAN segment of the call. Because of this, system administrators can quickly determine whether audio problems are being caused by the WLAN or by other network elements participating in a call. By observing which access points have impaired QoS, system administrators can quickly determine the physical area where the problem is occurring. This is important when lack of radio coverage or excessive interference is the root problem.

Four QoS values (packet latency, packet jitter, packet loss, and roaming time), which can affect the audio quality of voice calls, are monitored. All the wireless LAN components participate in this process. Access points and clients measure the metrics, access points collect the measurements and then send them to the controller. The access points update the controller with traffic stream metric information every 90 seconds, and 10 minutes of data is stored at one time. Cisco WCS queries the controller for the metrics and displays them in the Traffic Stream Metrics QoS Status. These metrics are compared to threshold values to determine their status level and if any of the statistics are displaying a status level of fair (yellow) or degraded (red), the administrator investigates the QoS of the wireless LAN.

For the access points to collect measurement values, traffic stream metrics must be enabled on the controller.

**Step 1** Choose **Configure > Controller Templates**.

**Step 2** On the left sidebar menu, choose **System > Traffic Stream Metrics QoS**. The Traffic Stream Metrics QoS Status Configuration window appears (see Figure 10-4).

---

**Figure 10-4 Traffic Stream Metrics QoS Status Template**

---

### Wireless Control System

<table>
<thead>
<tr>
<th>Traffic Stream Metrics QoS Status Configuration</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Upstream Delay</strong></td>
</tr>
<tr>
<td>Normal QoS is</td>
</tr>
<tr>
<td>Fair QoS is</td>
</tr>
<tr>
<td>Degraded QoS is</td>
</tr>
<tr>
<td><strong>Downstream Packet Loss Rate</strong></td>
</tr>
<tr>
<td>Normal QoS is</td>
</tr>
<tr>
<td>Fair QoS is</td>
</tr>
<tr>
<td>Degraded QoS is</td>
</tr>
</tbody>
</table>

### Roaming Time

| Normal QoS is | less than \( > 127 \) ms. |
| Fair QoS is | less than \( > 510 \) ms. |
| Degraded QoS is | equal or greater than \( > 1,000 \) ms. |

---

### Downstream Packet Loss Rate

| Normal QoS is | less than \( > 2 \) percent. |
| Fair QoS is | less than \( > 2 \) percent. |
| Degraded QoS is | equal or greater than \( > 2 \) percent. |
Chapter 10  Using Templates

Adding Controller Templates

The Traffic Stream Metrics QoS Status Configuration window shows several QoS values. An administrator can monitor voice and video quality of the following:

- Upstream delay
- Upstream packet loss rate
- Roaming time
- Downstream packet loss rate
- Downstream delay

Packet Loss Rate (PLR) affects the intelligibility of voice. Packet delay can affect both the intelligibility and conversational quality of the connection. Excessive roaming time produces undesired gaps in audio.

There are three levels of measurement:

- Normal: Normal QoS (green)
- Fair: Fair QoS (yellow)
- Degraded: Degraded QoS (red)

System administrators should employ some judgement when setting the green, yellow, and red alarm levels. Some factors to consider are:

- Environmental factors including interference and radio coverage which can affect PLR.
- End-user expectations and system administrator requirements for audio quality on mobile devices (lower audio quality can permit greater PLR).
- Different codec types used by the phones have different tolerance for packet loss.
- Not all calls will be mobile-to-mobile; therefore, some have less stringent PLR requirements for the wireless LAN.

Configuring WLAN Templates

WLAN templates allow you to define various WLAN profiles for application to different controllers. In WCS software release 4.0.96.0 and later releases, you can configure multiple WLANs with the same SSID. This feature enables you to assign different Layer 2 security policies within the same wireless LAN. To distinguish among WLANs with the same SSID, you need to create a unique profile name for each WLAN.

These restrictions apply when configuring multiple WLANs with the same SSID:

- WLANs with the same SSID must have unique Layer 2 security policies so that clients can make a WLAN selection based on information advertised in the beacons and probes. These are the available Layer 2 security policies:
  - None (open WLAN)
  - Static WEP or 802.1
  - CKIP
  - WPA/WPA2
- Broadcast SSID must be enabled on the WLANs that share an SSID so that the access points can generate probe responses for these WLANs.
- Hybrid-REAP access points do not support multiple SSIDs.
Follow these steps to add a new WLAN template or make modifications to an existing WLAN template.

**Step 1** Choose Configure > Controller Templates.

**Step 2** Choose WLANs > WLAN from the left sidebar menu.

The WLAN Template window appears with a summary of all existing defined WLANs. The following information headings are used to define the WLANs listed on the WLAN Template General window (see Figure 10-5).

- **Template Name** - The user-defined name of the template. Clicking the name displays parameters for this template.
- **Profile Name** - User-defined profile name used to distinguish WLANs with the same SSID.

**Note** This heading is not present in software release prior to 4.0.96.0.

- **SSID** - Displays the name of the WLAN.
- **WLAN Status** - Sets the status of the WLAN to enabled when checked.
- **Security Policies** - Determines whether 802.1X is enabled. None indicates no 802.1X.

**Step 3** To add a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click a URL in the Template Name column. The WLAN Template window appears (see Figure 10-5).

![WLAN Template](image)

Figure 10-5 WLAN Template
**Step 4** Wired guest access enables guest users to connect to the guest access network from a wired Ethernet connection designated and configured for guest access. Wired guest access ports might be available in a guest office or specific ports in a conference room. Wired guest access accounts are added to the network using the Lobby Ambassador portal. (Refer to the “Creating Guest User Accounts” section on page 7-11).

**Step 5** Enter a name in the Profile Name field that identifies the guest LAN. Do not use any spaces in the name entered.

**Step 6** Check the **Enabled** check box for the Status parameter.

**Step 7** Use the Radio Policy drop-down menu to set the WLAN policy to apply to All (802.11a/b/g/n), 802.11a only, 802.11g only, 802.11b/g/n only, or 802.11a/g/n only.

**Step 8** Use the Interface drop-down menu to choose the available names of interfaces created by the Controller Interfaces module.

**Step 9** Click **Broadcast SSID** to activate SSID broadcasts for this WLAN.

**Step 10** Click **Save**.

**Step 11** To further configure the WLAN template, choose from the following:

- Click the **Security** tab to establish which AAA can override the default servers on this WLAN and to establish the security mode for Layer 2 and 3. Continue to the “Security” section on page 10-11.
- Click the **QoS** tab to establish which quality of service is expected for this WLAN. Continue to the “QoS” section on page 10-17.
- Click the **Advanced** tab to configure any other details about the WLAN, such as DHCP assignments and management frame protection. Continue to the “Advanced” section on page 10-18.

### Security

After choosing Security, you have an additional three tabs: Layer 2, Layer 3, and AAA Servers.

### Layer 2

When you choose the Layer 2 tab, the window as shown in Figure 10-6 appears.

**Note** The screen contains different views depending on what option is chosen in the Layer 2 Security drop-down menu.
Step 1

Use the Layer 2 Security drop-down menu to choose between None, WPA, WPA-2, Static WEP, 802.1X, Cranite, Fortress, Static WEP-802.1X, CKIP, and WPA1 + WPA2 as described in the table below.

Table 10-1  Layer 2 Security Options

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>No Layer 2 security selected.</td>
</tr>
<tr>
<td>802.1X</td>
<td>WEP 802.1X data encryption type (Note 1):</td>
</tr>
<tr>
<td></td>
<td>40/64 bit key.</td>
</tr>
<tr>
<td></td>
<td>104/128 bit key.</td>
</tr>
<tr>
<td></td>
<td>128/152 bit key.</td>
</tr>
<tr>
<td>WPA</td>
<td>This is a 3.2 controller code option and is not supported in 4.0 or later versions.</td>
</tr>
<tr>
<td>WPA-2</td>
<td>This is a 3.2 controller code option is not supported in 4.0 or later versions.</td>
</tr>
</tbody>
</table>
### Table 10-1  Layer 2 Security Options (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
</table>
| Static WEP        | Static WEP encryption parameters:  
|                   | Key sizes: 40/64, 104/128, and 128/152 bit key sizes.  
|                   | Key Index: 1 to 4 (Note 2).  
|                   | Encryption Key: Encryption key required.  
|                   | Key Format: Select encryption key format in ASCII or HEX.  |
| Cranite           | Configure the WLAN to use the FIPS140-2 compliant Cranite Wireless Wall Software Suite, which uses AES encryption andVPN tunnels to encrypt and verify all data frames carried by the Cisco Wireless LAN Solution.
| Fortress          | FIPS 40-2 compliant Layer 2 security feature.  |
| Static WEP-802.1X | Use this setting to enable both Static WEP and 802.1X policies. If this option is selected, static WEP and 802.1X parameters are displayed at the bottom of the page.  
|                   | Static WEP encryption parameters:  
|                   | Key sizes: 40/64, 104/128, and 128/152 bit key sizes.  
|                   | Key index: 1 to 4 (Note 2).  
|                   | Encryption Key: Enter encryption key.  
|                   | Key Format: Select encryption key format in ASCII or HEX.  
|                   | WEP 802.1X data encryption type (Note 1):  
|                   | 40/64 bit key.  
|                   | 104-128 bit key.  
|                   | 128/152 bit key.  |
Table 10-1  Layer 2 Security Options (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>WPA1+WPA2</td>
<td>Use this setting to enable WPA1, WPA2, or both. See the WPA1 and WPA2 parameters displayed on the window when WPA1+WPA2 is selected. WPA1 enables Wi-Fi Protected Access with TKIP-MIC Data Encryption. When WPA1+WPA2 is selected, you can use Cisco’s Centralized Key Management (CCKM) authentication key management, which allows fast exchange when a client roams from one access point to another. When WPA1+WPA2 is selected as the Layer 2 security policy, and Pre-shared Key is enabled, then neither CCKM or 802.1X can be enabled. Although, both CCKM and 802.1X can be enabled at the same time.</td>
</tr>
<tr>
<td>CKIP</td>
<td>Cisco Key Integrity Protocol (CKIP). A Cisco access point advertises support for CKIP in beacon and probe response packets. CKIP can be configured only when Aironet IE is enabled on the WLAN. When selected, these CKIP parameters are displayed. Key size: Specify key length. Encryption Key: Specify encryption key. Key Format: ASCII or HEX. MMH Mode: Enabled or disabled (check box). Key Permutation: Enabled or disabled (check box).</td>
</tr>
</tbody>
</table>

Step 2  Check the MAC Filtering check box if you want to filter clients by MAC address.

Step 3  If you selected either WPA1 or WPA2 in Step 1, you must specify the type of WPA encryption: either TKIP or AES.

Step 4  Choose the desired type of authentication key management. The choices are 802.1X, CCKM, PSK, or CCKM+802.1X.

Note  If you choose PSK, you must enter the password and type (ASCII or hexadecimal).

Step 5  Click Save.

Layer 3

When you choose the Layer 3 tab, the window shown in Figure 10-7 appears.

Note  The screen contains different views depending on what option is chosen in the Layer 3 Security drop-down menu.
Figure 10-7  Layer 3 Window

Follow these steps to configure the Layer 3 tab.

**Step 1**
Use the Layer 3 security drop-down menu to choose between None and VPN Pass Through. The window parameters change according to the selection you make. If you choose VPN pass through, you must enter the VPN gateway address.

**Step 2**
You can modify the default security policy (web authentication) or assign specific web authentication (login, logout, login failure) pages and the server source.

a. To change the security policy to passthrough, check the **Web Policy** check box and the **Passthrough** option. This option allows users to access the network without entering a username or password. An **Email Input** check box appears. Check this check box if you want users to be prompted for their email address when attempting to connect to the network.

b. To specify custom web authentication windows, uncheck the **Global WebAuth Configuration Enabled** check box.

1. When the Web Auth Type drop-down menu appears, choose one of the following options to define the web login page for the wireless guest users:

   - **Internal**—Displays the default web login page for the controller. This is the default value.
   - **Customized**—Displays custom web login, login failure, and logout pages. When the customized option is selected, three separate drop-down menus for login, login failure, and logout page selection appear. You do not need to define a customized page for all three of the options. Choose **None** from the appropriate drop-down menu if you do not want to display a customized page for that option.
These optional login, login failure, and logout pages are downloaded to the controller as webauth.tar files. For specifics on downloading custom pages, refer to the “Downloading Customized Web Authentication” section on page 3-18.

**External**—Redirects users to an external server for authentication. If you choose this option, you must also enter the URL of the external server in the URL field.

You can select specific RADIUS or LDAP servers to provide external authentication on the Security > AAA panel. To do so, continue with Step 4.

**Note** The RADIUS and LDAP external servers must be already configured to have selectable options on the Security > AAA panel. You can configure these servers on the RADIUS Authentication Servers page, TACACS+ Authentication Servers page, and LDAP Servers page.

**Step 3** If you selected External as the Web Authentication Type in Step 2, click Security > AAA and choose up to three RADIUS and LDAP servers using the drop-down menus.

**Step 4** Click Save.

**Step 5** Repeat this process if a second (anchor) controller is being used in the network.

### AAA Servers

When you choose the AAA Servers tab, the window shown in Figure 10-8 appears.

**Figure 10-8 AAA Servers Window**
Follow these steps to configure the AAA Servers tab.

---

**Step 1**
Use the drop-down menus in the RADIUS and LDAP servers section to choose authentication and accounting servers. This selects the default RADIUS server for the specified WLAN and overrides the RADIUS server that is configured for the network. If all three RADIUS servers are configured for a particular WLAN, server 1 has the highest priority and so on. If no LDAP servers are chosen here, WCS uses the default LDAP server order from the database.

**Step 2**
Click the Local EAP Authentication check box if you have an EAP profile already configured that you want to enable. Local EAP is an authentication method that allows users and wireless clients to locally authenticate. It is designed for use in remote offices that want to maintain connectivity to wireless clients when the backend system becomes disrupted or the external authentication server goes down.

**Step 3**
When AAA Override is enabled, and a client has conflicting AAA and controller WLAN authentication parameters, client authentication is performed by the AAA server. As part of this authentication, the operating system moves clients from the default Cisco WLAN Solution to a VLAN returned by the AAA server and predefined in the controller interface configuration (only when configured for MAC filtering, 802.1X, and/or WPA operation). In all cases, the operating system also uses QoS and ACL provided by the AAA server, as long as they are predefined in the controller interface configuration. (This VLAN switching by AAA override is also referred to as identity networking.)

For instance, if the corporate WLAN primarily uses a management interface assigned to VLAN 2, and if AAA override returns a redirect to VLAN 100, the operating system redirects all client transmissions to VLAN 100, regardless of the physical port to which VLAN 100 is assigned.

When AAA override is disabled, all client authentication defaults to the controller authentication parameter settings, and authentication is only performed by the AAA server if the controller WLANs do not contain any client-specific authentication parameters.

The AAA override values may come from a RADIUS server, for example.

**Step 4**
Click **Save**.

---

**QoS**

When you select the QoS tab from the WLAN Template window, the window as shown in Figure 10-9 appears.
Adding Controller Templates

Chapter 10  Using Templates

Figure 10-9  QoS Window

Follow these steps to configure the QoS tab.

**Step 1** Use the QoS drop-down menu to choose Platinum (voice), Gold (video), Silver (best effort), or Bronze (background). Services such as VoIP should be set to gold while non-discriminating services such as text messaging can be set to bronze.

**Step 2** Use the WMM Policy drop-down menu to choose Disabled, Allowed (so clients can communicate with the WLAN), or Required to make it mandatory for clients to have WMM enabled for communication.

**Step 3** Click the 7920 AP CAC check box if you want to enable support on Cisco 7920 phones.

**Step 4** If you want WLAN to support older versions of the software on 7920 phones, click to enable the 7920 Client CAC check box. The CAC limit is set on the access point for newer versions of software.

**Step 5** Click Save.

**Advanced**

When you click the Advanced tab on the WLAN Template window, the window shown in Figure 10-10 appears.
Step 1  Click the check box if you want to enable Hybrid REAP local switching. For more information on Hybrid REAP, see the “Configuring Hybrid REAP” section on page 12-4. If you enable it, the hybrid-REAP access point handles client authentication and switches client data packets locally.

H-REAP local switching is only applicable to the Cisco 1130/1240/1250 series access points. It is not supported with L2TP, PPTP, CRANITE, and FORTRESS authentications, and it is not applicable to WLAN IDs 9-16.

Step 2  At the Session Timeout parameter, set the maximum time a client session can continue before requiring reauthorization.

Step 3  Check the Aironet IE check box if you want to enable support for Aironet information elements (IEs) for this WLAN. If Aironet IE support is enabled, the access point sends an Aironet IE 0x85 (which contains the access point name, load, number of associated clients, and so on) in the beacon and probe responses of this WLAN, and the controller sends Aironet IEs 0x85 and 0x95 (which contains the management IP address of the controller and the IP address of the access point) in the reassociation response if it receives Aironet IE 0x85 in the reassociation request.

Step 4  Click if you want to enable IPv6. You can configure IPv6 bridging and IPv4 web auth on the same WLAN. WCS disallows Layer 2 security with IPv6 bridging.

Note  Layer 3 security must be set to None for this to be enabled.
Adding Controller Templates

Chapter 10      Using Templates

Step 5  A list of defined access control lists (ACLs) is provided at the Override Interface ACL drop-down menu. (Refer to the “Configuring Access Control List Templates” section on page 10-55 for steps on defining ACLs.) Upon choosing an ACL from the list, the WLAN associates the ACL to the WLAN. Selecting an ACL is optional, and the default for this parameter is None.

Step 6  You can configure peer-to-peer blocking per WLAN rather than applying the status to all WLANs. At the Peer to Peer Blocking drop-down menu, choose one of the following:

- Disable—Peer-to-peer blocking is disabled, and traffic is bridged locally whenever possible.
- Drop—The packet is discarded.
- Forward Up—The packet is forwarded on the upstream VLAN, and the decision is made about what to do with the packet.

If HREAP local switching is enabled for the WLAN, which prevents traffic from passing through the controller, this drop-down menu is grayed out.

Note  Peer-to-peer blocking does not apply to multicast traffic.

Step 7  Click the check box if you want to enable automatic client exclusion. If you enable client exclusion, you must also set the Timeout Value in seconds for disabled client machines. Client machines are excluded by MAC address, and their status can be observed. A timeout setting of 0 indicates that administrative control is required to re-enable the client.

Note  When session timeout is not set, it implies that an excluded client remains and will not timeout from the excluded state. It does not imply that the exclusion feature is disabled.

Step 8  When you click the check box to override DHCP server, another parameter appears where you can enter the IP address of your DHCP server. For some WLAN configurations, this is required. Three valid configurations are as follows:

- DHCP Required and a valid DHCP server IP address - All WLAN clients obtain an IP address from the DHCP server.
- DHCP is not required and a valid DHCP server IP address - All WLAN clients obtain an IP address from the DHCP server or use a static IP address.
- DHCP not required and DHCP server IP address 0.0.0.0 - All WLAN clients are forced to use a static IP address. All DHCP requests are dropped.

You cannot choose to require a DHCP address assignment and then enter a DHCP server IP address.

Step 9  If the MFP Signature Generation check box is checked, it enables signature generation for the 802.11 management frames transmitted by an access point associated with this WLAN. Signature generation makes sure that changes to the transmitted management frames by an intruder are detected and reported.

Step 10  At the MFP Client Protection drop-down menu, choose Optional, Disabled, or Required for configuration of individual WLANs of a controller. If infrastructure MFP is not enabled, this drop-down menu is unavailable.

Note  Client-side MFP is only available for those WLANs configured to support Cisco Compatible Extensions (version 5 or later) clients, and WPA2 must first be configured.
Configuring H-REAP AP Groups

Hybrid REAP enables you to configure and control access points in a branch or remote office from the corporate office through a wide area network (WAN) link without deploying a controller in each office. There is no deployment restriction on the number of hybrid-REAP access points per location, but you can organize and group the access points per floor and limit them to 25 or so per building, since it is likely the branch offices share the same configuration.

Follow these steps to set up an H-REAP AP group.

Step 1  Choose Configure > Controller Templates.

Step 2  From the left sidebar menu, choose HREAP > HREAP AP Groups.

Step 3  The Template Name column shows the group names assigned to the HREAP access point groups. If you want to add an additional group, choose Add HREAP AP Group from the Select a command drop-down menu.

- or -

To make modifications to an existing template, click to select a template in the Template Name column. The General tab of the HREAP AP Groups template appears (see Figure 10-11).

Figure 10-11  AP Groups HREAP Template

Step 4  The Template Name parameter shows the group name assigned to the HREAP access point group.

Step 11  Click Save.
Step 5  Choose the primary RADIUS authentication servers for each group. If a RADIUS authentication server is not present on the controller, the WCS configured RADIUS server does not apply. A value of 10 indicates that the primary RADIUS server is not configured for this group.

Step 6  Choose the secondary RADIUS authentication servers for each group. If a RADIUS authentication server is not present on the controller, the WCS configured RADIUS server does not apply. A value of 0 indicates that the primary RADIUS server is not configured for this group.

Step 7  If you want to add an access point to the group, click the H-REAP AP tab.

Step 8  An access point Ethernet MAC address cannot exist in more than one H-REAP group on the same controller. If more than one group is applied to the same controller, click the Ethernet MAC check box to unselect an access point from one of the groups. You should save this change or apply it to controllers.

Step 9  Click Add AP. The H-REAP AP Group window appears.

Step 10  Click the H-REAP Configuration tab to enable local authentication for a hybrid REAP group.

Note  Make sure that the Primary RADIUS Server and Secondary RADIUS Server parameters are set to None on the General tab.

Step 11  Check the H-REAP Local Authentication Enabled check box to enable local authentication for this hybrid-REAP group. The default value is unchecked.

Note  When you attempt to use this feature, a warning message indicates that it is a licensed feature.

Step 12  To allow a hybrid-REAP access point to authenticate clients using LEAP, check the LEAP check box. Otherwise, to allow a hybrid-REAP access point to authenticate clients using EAP-FAST, check the EAP-FAST check box.

Step 13  Perform one of the following, depending on how you want protected access credentials (PACs) to be provisioned:

- To use manual PAC provisioning, enter the key used to encrypt and decrypt PACs in the EAP-FAST Key and Confirm EAP-FAST Key field. The key must be 32 hexadecimal characters.
- To allow PACs to be sent automatically to clients that do not have one during PAC provisioning, check the Auto key generation check box.

Step 14  In the EAP-FAST Authority ID field, enter the authority identifier of the EAP-FAST server. The identifier must be 32 hexadecimal characters.

Step 15  In the EAP-FAST Authority Info field, enter the authority identifier of the EAP-FAST server in text format. You can enter up to 32 hexadecimal characters.

Step 16  In the EAP-FAST Pac Timeout field, specify a PAC timeout value by entering the number of seconds for the PAC to remain viable in the edit box. The valid range is 2 to 4095 seconds.

Step 17  Click Submit.

Configuring a File Encryption Template

This page enables you to add a new file encryption template or make modifications to an existing file encryption template.
Adding Controller Templates

**Step 1**  Choose Configure > Controller Templates.

**Step 2**  From the left sidebar menu, choose Security > File Encryption.

**Step 3**  To add a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click to select a template in the Template Name column. The File Encryption Template appears (see Figure 10-12).

![Figure 10-12 File Encryption Template](image)

**Step 4**  Check if you want to enable file encryption.

**Step 5**  Enter an encryption key text string of exactly 16 ASCII characters.

**Step 6**  Retype the encryption key.

**Step 7**  Click Save.

**Configuring a RADIUS Authentication Template**

This page allows you to add a template for RADIUS authentication server information or make modifications to an existing template. After these server templates are configured, controller users who log into the controller through the CLI or GUI are authenticated.

**Step 1**  Choose Configure > Controller Templates.

**Step 2**  On the left sidebar menu, choose Security > RADIUS Authentication Servers.

**Step 3**  To add a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click to select the template in the Template Name column. The RADIUS Authentication Server Template window appears (see Figure 10-13), and the number of controllers the template is applied to automatically populates.

The IP address of the RADIUS server and the port number for the interface protocol is also displayed.
### Adding Controller Templates

#### Figure 10-13 RADIUS Authentication Server Template

**Step 4** Use the drop-down menu to choose either ASCII or hex shared secret format.

**Step 5** Enter the RADIUS shared secret used by your specified server.

**Step 6** Click if you want to enable key wrap. If this option is enabled, the authentication request is sent to RADIUS servers that have key encryption key (KEK) and message authenticator code keys (MACK) configured. Also, when enabled, the parameters below appear:

- **Shared Secret Format**: Determine whether ASCII or hexadecimal.
- **KEK Shared Secret**: Enter KEK shared secret.
- **MACK Shared Secret**: Enter MACK shared secret.

**Note** Each time the controller is notified with the shared secret, the existing shared secret is overwritten with the new shared secret.

**Step 7** Click if you want to enable administration privileges.

**Step 8** Click if you want to enable support for RFC 3576. RFC 3576 is an extension to the Remote Authentication Dial In User Service (RADIUS) protocol. It allows dynamic changes to a user session and includes support for disconnecting users and changing authorizations applicable to a user session. With these authorizations, support is provided for Disconnect and Change-of-Authorization (CoA) messages. Disconnect messages immediately terminate a user session, whereas CoA messages modify session authorization attributes such as data filters.

**Step 9** Click if you want to enable network user authentication. If this option is enabled, this entry is considered as the RADIUS authenticating server for the network user.

**Step 10** Click if you want to enable management authentication. If this option is enabled, this entry is considered as the RADIUS authenticating server for the management user.

**Step 11** Specify the time in seconds after which the RADIUS authentication request times out and a retransmission is attempted by the controller. You can specify a value between 2 and 30 seconds.

**Step 12** If you click to enable the IP security mechanism, additional IP security parameters are added to the window, and Steps 13 to 19 are required. If you disable it, click **Save** and skip Steps 13 to 19.
Step 13 Use the drop-down menu to choose which IP security authentication protocol to use. The options are HMAC-SHA1, HMAC-MD5, and None.
Message Authentication Codes (MAC) are used between two parties that share a secret key to validate information transmitted between them. HMAC (Hash MAC) is a mechanism based on cryptographic hash functions and can be used in combination with any iterated cryptographic hash function. HMAC-MD5 and HMAC-SHA1 are two constructs of the HMAC using the MD5 hash function and the SHA1 hash function. HMAC also uses a secret key for calculation and verification of the message authentication values.

Step 14 Set the IP security encryption mechanism to use. Options are as follows:
- DES—Data Encryption Standard is a method of data encryption using a private (secret) key. DES applies a 56-bit key to each 64-bit block of data.
- Triple DES—Data Encryption Standard that applies three keys in succession.
- AES 128 CBC—Advanced Encryption Standard uses keys with a length of 128, 192, or 256 bits to encrypt blocks with a length of 128, 192, or 256 bits. AES 128 CBC uses a 128-bit data path in Cipher Clock Chaining (CBC) mode.
- None—No IP security encryption mechanism.

Step 15 The Internet Key Exchange (IKE) authentication is not an editable field. Internet Key Exchange protocol (IKE) is used as a method of distributing the session keys (encryption and authentication), as well as providing a way for the VPN endpoints to agree on how data should be protected. IKE keeps track of connections by assigning a bundle of security associations (SAs) to each connection.

Step 16 Use the IKE phase 1 drop-down menu to choose either aggressive or main. This sets the IKE protocol. IKE phase 1 is used to negotiate how IKE is protected. Aggressive mode passes more information in fewer packets, with the benefit of a slightly faster connection, at the cost of transmitting the identities of the security gateways in the clear.

Step 17 At the Lifetime parameter, set the timeout interval (in seconds) when the session expires.

Step 18 Set the IKE Diffie-Hellman group. The options are group 1 (768 bits), group 2 (1024 bits), or group 5 (1536 bits). Diffie-Hellman techniques are used by two devices to generate a symmetric key where you can publicly exchange values and generate the same symmetric key.
Although all three groups provide security from conventional attacks, Group 5 is considered more secure because of its larger key size. However, computations involving Group 1 and Group 2 based keys might occur slightly faster because of their smaller prime number size.

Step 19 Click Save.

---

**Configuring a RADIUS Accounting Template**

This page allows you to add a new template for RADIUS accounting server information or make modifications to an existing template.

Step 1 Choose Configure > Controller Templates.
Step 2 From the left sidebar menu, choose Security > RADIUS Acct Servers.
**Step 3**  
To add a new template, choose **Add Template** from the Select a command drop-down menu and click **GO**. To make modifications to an existing template, click to select a template in the Template Name column. The RADIUS Accounting Template appears (see **Figure 10-14**), and the number of controllers the template is applied to automatically populates. The IP address of the RADIUS server and the port number for the interface protocols are also displayed.

**Figure 10-14  RADIUS Accounting Server Templates**

---

**Step 4**  
Use the Shared Secret Format drop-down menu to choose either ASCII or hexadecimal.

**Step 5**  
Enter the RADIUS shared secret used by your specified server.

**Step 6**  
Retype the shared secret.

**Step 7**  
Click if you want to establish administrative privileges for the server.

**Step 8**  
Click if you want to enable the network user authentication. If this option is enabled, this entry is considered as the RADIUS authenticating server for the network user.

**Step 9**  
Specify the time in seconds after which the RADIUS authentication request will timeout and a retransmission by the controller will occur. You can specify a value between 2 and 30 seconds.

**Step 10**  
Click **Save**.

---

**Configuring a LDAP Server Template**

This section explains how to configure a Lightweight Directory Access Protocol (LDAP) server as a backend database, similar to a RADIUS or local user database. An LDAP backend database allows the controller to query an LDAP server for the credentials (username and password) of a particular user. These credentials are then used to authenticate the user. For example, local EAP may use an LDAP server as its backend database to retrieve user credentials. This page allows you to add a new template for an LDAP server or make modifications to an existing template.

**Step 1**  
Choose **Configure > Controller Templates**.
**Step 2** From the left sidebar menu, choose **Security > LDAP Servers**.

**Step 3** To add a new template, choose **Add Template** from the Select a command drop-down menu and click **GO**. To make modifications to an existing template, click to select a template in the Template Name column. The LDAP Server Template appears (see **Figure 10-15**). The IP address of the LDAP server and the port number for the interface protocols are displayed.

**Figure 10-15 LDAP Server Template**

![LDAP Server Template](image)

**Step 4** In the Server User Base DN field, enter the distinguished name of the subtree in the LDAP server that contains a list of all the users.

**Step 5** In the Server User Attribute field, enter the attribute that contains the username in the LDAP server.

**Step 6** In the Server User Type field, enter the ObjectType attribute that identifies the user.

**Step 7** If you are adding a new server, choose **Secure** from the Use TLS for Sessions to Server drop-down menu if you want all LDAP transaction to use a secure TLS tunnel. Otherwise, choose **none**.

**Step 8** In the Retransmit Timeout field, enter the number of seconds between retransmissions. The valid range is 2 to 30 seconds, and the default value is 2 seconds.

**Step 9** Check the Admin Status check box if you want the LDAP server to have administrative privileges.

**Step 10** Click **Save**.

---

**Configuring a TACACS+ Server Template**

This page allows you to add a new TACACS+ server template or make modifications to an existing template. After these server templates are configured, controller users who log into the controller through the CLI or GUI are authenticated.
Adding Controller Templates

Step 1 Choose Configure > Controller Templates.

Step 2 On the left sidebar menu, choose Security > TACACS+ Server.

Step 3 To add a new template, choose Add Template from the Select a command drop-down menu and click Go. To make modifications to an existing template, click to select a user in the Template Name column. The TACACS+ Server Template appears (see Figure 10-16). The IP address and the port number of the TACACS+ template are displayed.

Figure 10-16 TACACS+ Server Template

Step 4 Select the server type. The choices are authentication, authorization, or accounting.

Step 5 Use the drop-down menu to choose either ASCII or hex shared secret format.

Step 6 Enter the TACACS+ shared secret used by your specified server.

Step 7 Re-enter the shared secret in the Confirm Shared Secret field.

Step 8 Check the Admin Status check box if you want the TACACS+ server to have administrative privileges.

Step 9 Specify the time in seconds after which the TACACS+ authentication request times out and a retransmission is attempted by the controller.

Step 10 Click Save.

Configuring a Network Access Control Template

This page allows you to add a new template for network access control or make modifications to an existing template.

Step 1 Choose Configure > Controller Templates.

Step 2 From the left sidebar menu, choose Security > Network Access Control.
**Step 3**

To add a new template, choose **Add Template** from the Select a command drop-down menu and click **GO**. To make modifications to an existing template, click to select a template in the Template Name column. The Network Access Control Template appears (see **Figure 10-17**). The IP address and port number for the interface protocols are displayed.

**Figure 10-17**  Network Access Control Template

![Network Access Control Template](image)

**Step 4**

Enter the shared secret used by your specified server.

**Step 5**

Re-enter the shared secret in the Confirm Shared Secret field.

**Step 6**

Check the Admin Status check box if you want the server to have administrative privileges.

**Step 7**

Click **Save**.

---

**Configuring a Local EAP General Template**

This page allows you to specify a timeout value for local EAP. You can then add a template with this timeout value or make changes to an existing template.

---

**Note**

If any RADIUS servers are configured on the controller, the controller tries to authenticate the wireless clients using the RADIUS servers first. Local EAP is attempted only if no RADIUS servers are found, either because the RADIUS servers timed out or no RADIUS servers were configured. If four RADIUS servers are configured, the controller attempts to authenticate the client with the first RADIUS server, then the second RADIUS server, and then local EAP. If the client attempts to then reauthenticate manually, the controller tries the third RADIUS server, then the fourth RADIUS server, and then local EAP.
Step 1  Choose Configure > Controller Templates.

Step 2  From the left sidebar menu, choose Security > Local EAP General.

Step 3  To add a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click to select a template in the Template Name column. The Local EAP General Template appears (see Figure 10-18).

Figure 10-18  Local EAP General Template

Step 4  In the Local Auth Active Timeout field, enter the amount of time (in seconds) that the controller attempts to authenticate wireless clients using local EAP after any pair of configured RADIUS servers fail. The valid range is 1 to 3600 seconds, and the default setting is 1000 seconds.

Step 5  The following values should be adjusted if you are using EAP-FAST, manual password entry, one-time password, or 7920/7921 phones. You must increase the 802.1x timeout values on the controller (default=2 seconds) for the client to obtain the PAC using automatic provisioning. The recommended and default timeout on the Cisco ACS server is 20 seconds.

Note  Roaming fails if these values are not set the same across multiple controllers.

- Local EAP Identify Request Timeout =1
- Local EAP Identity Request Maximum Retries=20
- Local EAP Dynamic WEP Key Index=0
- Local EAP Request Timeout=20
- Local EAP Request Maximum Retries=2

Step 6  Click Save.
Configuring a Local EAP Profile Template

This page allows you to add a new template for the local EAP profile or make modifications to an existing template. Local EAP is an authentication method that allows users and wireless clients to be authenticated locally. It is designed for use in remote offices that want to maintain connectivity to wireless clients when the backend system becomes disrupted or the external authentication server goes down. When you enable local EAP, the controller serves as the authentication server and the local user database, thereby removing dependence on an external authentication server. Local EAP retrieves user credentials from the local user database or the LDAP backend database to authenticate users.

**Note**
The LDAP backend database supports only these local EAP methods: EAP-TLS and EAP-FAST with certificates. LEAP and EAP-FAST with PACs are not supported for use with the LDAP backend database.

**Step 1** Choose **Configure > Controller Templates**.

**Step 2** From the left sidebar menu, choose **Security > Local EAP Profiles**.

**Step 3** To add a new template, choose **Add Template** from the Select a command drop-down menu and click **GO**. To make modifications to an existing template, click to select a template in the Template Name column. The Local EAP Profiles Template appears (see **Figure 10-19**).

**Figure 10-19  Local EAP Profiles Template**

**Step 4** Each EAP profile must be associated with an authentication type(s). Choose the desired authentication type from the choices below:

- **LEAP** — This authentication type leverages Cisco Key Integrity Protocol (CKIP) and MMH message integrity check (MIC) for data protection. A username and password are used to perform mutual authentication with the RADIUS server through the access point.
• EAP-FAST — This authentication type (Flexible Authentication via Secure Tunneling) uses a three-phased tunnel authentication process to provide advanced 802.1X EAP mutual authentication. A username, password, and PAC (protected access credential) are used to perform mutual authentication with the RADIUS server through the access point.

• TLS — This authentication type uses a dynamic session-based WEP key derived from the client adapter and RADIUS server to encrypt data. It requires a client certificate for authentication.

• PEAP — This authentication type is based on EAP-TLS authentication but uses a password instead of a client certificate for authentication. PEAP uses a dynamic session-based WEP key derived from the client adapter and RADIUS server to encrypt data.

**Step 5**
Use the Certificate Issues drop-down menu to determine whether Cisco or another vendor issued the certificate for authentication. Only EAP-FAST and TLS require a certificate.

**Step 6**
If you want the incoming certificate from the client to be validated against the certificate authority (CA) certificates on the controller, check the **Check Against CA Certificates** check box.

**Step 7**
If you want the common name (CN) in the incoming certificate to be validated against the CA certificates’ CN on the controller, check the **Verify Certificate CN Identity** check box.

**Step 8**
If you want the controller to verify that the incoming device certificate is still valid and has not expired, check the **Check Against Date Validity** check box.

**Step 9**
If you want the device certificate on the controller to be used for authentication, check the **Local Certificate Required** check box. This certification is applicable only to EAP-FAST.

**Step 10**
If you want the wireless clients to send their device certificates to the controller in order to authenticate, check the **Client Certificate Required** check box. This certification is only applicable to EAP-FAST.

**Step 11**
Click **Save**.

**Step 12**
Follow these steps to enable local EAP on a:

a. Choose **WLAN > WLANs** from the left sidebar menu.
b. Click the profile name of the desired WLAN.
c. Click the **Security > AAA Servers** tab to access the AAA Servers page.
d. Check the **Local EAP Authentication** check box to enable local EAP for this WLAN.

**Step 13**
Click **Save**.

**Configuring an EAP-FAST Template**

This authentication type (Flexible Authentication via Secure Tunneling) uses a three-phased tunnel authentication process to provide advanced 802.1X EAP mutual authentication. A username, password, and PAC are used to perform mutual authentication with the RADIUS server through the access point. This page allows you to add a new template for the EAP-FAST profile or make modifications to an existing template.

**Step 1**
Choose **Configure > Controller Templates**.

**Step 2**
From the left sidebar menu, choose **Security > EAP-FAST Parameters**.

**Step 3**
To add a new template, choose **Add Template** from the Select a command drop-down menu and click **GO**. To make modifications to an existing template, click to select a template in the Template Name column. The EAP-FAST Parameters Template appears (see **Figure 10-19**).
Step 4 In the Time to Live for the PAC field, enter the number of days for the PAC to remain viable. The valid range is 1 to 1000 days, and the default setting is 10 days.

Step 5 In the Authority ID field, enter the authority identifier of the local EAP-FAST server in hexadecimal characters. You can enter up to 32 hexadecimal characters, but you must enter an even number of characters.

Step 6 In the Authority ID field, enter the ID for the authority identifier of the local EAP-FAST server.

Step 7 In the Authority Info field, enter the authority identifier of the local EAP-FAST server in text format.

Step 8 In the Server Key and Confirm Server Key fields, enter the key (in hexadecimal characters) used to encrypt and decrypt PACs.

Step 9 If a local certificate is required, click the check box.

Step 10 If a client certificate is required, click the check box.

Step 11 If an anonymous provision is required, click the check box.

Step 12 If you want to enable anonymous provisioning, check the Client Authentication Provision check box. This feature allows PACs to be sent automatically to clients that do not have one during PAC provisioning. If you disable this feature, PACs must be manually provisioned.

Step 13 Click Save.
Configuring Network User Credential Retrieval Priority Templates

You can specify the order that LDAP and local databases use to retrieve user credential information. This page allows you to add a new template for the network user credential retrieval priority or make modifications to an existing template.

**Step 1** Choose **Configure > Controller Templates**.

**Step 2** From the left sidebar menu, choose **Security > Network Users Priority**.

To add a new template, choose **Add Template** from the Select a command drop-down menu and click **GO**. To make modifications to an existing template, click to select a template in the Template Name column. The Network User Credential Retrieval Priority Template appears (see Figure 10-21).

**Figure 10-21 Network User Credential Retrieval Priority Order Template**

**Step 3** Use the left and right pointing arrows to include or disclude network user credentials in the right-most window.

**Step 4** Use the up and down buttons to determine the order credentials are tried.

**Step 5** Click **Save**.

Configuring a Local Network Users Template

With this template, you can store the credentials (username and password) of all the local network users. These credentials are then used to authenticate the users. For example, local EAP may use the local user database as its backend database to retrieve user credentials. This page allows you to add a new local authentication template or make modifications to an existing template. You must create a local net user and define a password when logging in as a web authentication client.

**Step 1** Choose **Configure > Controller Templates**.
Step 2  On the left sidebar menu, choose Security > Local Net Users.

Step 3  To add a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click to select a user in the User Name column. The Local Net Users Template appears (see Figure 10-22).

![Figure 10-22 Local Net Users Template](image)

Step 4  If you keep Import from File enabled, you need to enter a file path or click the Browse button to navigate to the file path. Then continue to Step 8. If you disable the import, continue to Step 5.

**Note** You can only import a .csv file. Any other file formats are not supported. See Figure Figure 10-23 for CSV file format examples.

The first row in the file is the header. The data in the header is not read by the Cisco WCS. The header can either be blank or filled. The Cisco WCS reads data from the second row onwards. It is mandatory to fill the Username and Password fields in all the rows.

![Figure 10-23 CSV File Format](image)

Step 5  Enter a username and password.

Step 6  Use the drop-down menu to choose the SSID which this local user is applied to or choose the any SSID option.

Step 7  Enter a user-defined description of this interface. Skip to Step 9.
### Adding Controller Templates

**Step 8**  
If you want to override the existing template parameter, click to enable this parameter.

**Step 9**  
Click **Save**.

---

### Configuring Guest User Templates

This page allows you to create a new template for guest user information or make modifications to an existing template. The purpose of a guest user account is to provide a user account for a limited amount of time. A Lobby Ambassador is able to configure a specific time frame for the guest user account to be active. After the specified time period, the guest user account automatically expires. Refer to the “Creating Guest User Accounts” section on page 7-12 for further information on guest access.

**Step 1**  
Choose **Configure > Controller Templates**.

**Step 2**  
From the left sidebar menu, choose **Security > Guest Users**.

**Step 3**  
To add a new template, choose **Add Template** from the Select a command drop-down menu and click **GO**. To make modifications to an existing template, click to select a user in the User Name column. The General Guest User Template window appears (see Figure 10-24).

**Step 4**  
Enter a guest name. Maximum size is 24 characters.

**Step 5**  
Click the **Generate Password** check box if you want a password automatically generated. The Password and Confirm Password parameters are automatically populated. If automatic generation is not enabled, you must supply a password twice.
### Chapter 10      Using Templates

#### Adding Controller Templates

**Note**  
If this is enabled, a different password is supplied for each day (up to the number of days chosen). If this is disabled (unchecked), one password is supplied for a span of days.

**Step 6**  
Click the **Advanced** tab.

**Step 7**  
If you want to import multiple users, click the **Import From File** check box.

**Step 8**  
Click **Browse** to go to the file path where the CSV is located. The Sample CSV file is as follows:

<table>
<thead>
<tr>
<th>User Name</th>
<th>Password</th>
<th>Life Time</th>
<th>Description</th>
<th>Disclaimer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Guest-1</td>
<td>pwd1</td>
<td>864000</td>
<td>Description-1</td>
<td>Disclaimer-1</td>
</tr>
<tr>
<td>Guest-2</td>
<td>pwd2</td>
<td>864000</td>
<td>Description-2</td>
<td>Disclaimer-2</td>
</tr>
</tbody>
</table>

**Note**  
Table headings are not required, and description and disclaimer are not mandatory.

**Step 9**  
Choose a user role for the guest user from the drop-down menu. User roles are predefined by the administrator and are associated with the guests’ access (such as contractor, customer, partner, vendor, visitor, and so on).

User Role is used to manage the amount of bandwidth allocated to specific users within the network.

**Step 10**  
Define how long the guest user account will be active by choosing either the Limited or Unlimited Lifetime option.

- For the limited option, you choose the period of time that the guest user account is active using the hours and minutes drop-down menus. The default value for Limited is one day (8 hours).
- When Unlimited is chosen, there is no expiration date for the guest account.

**Step 11**  
Choose the area (indoor, outdoor), controller list, or config group to which the guest user traffic is limited from the Apply to drop-down menu.

If you choose the controller list option, a list of controller IP addresses appears. Check the check box next to all controller networks on which guest traffic is allowed.

**Step 12**  
(Optionally) Modify the default guest user description if necessary.

**Step 13**  
(Optionally) Modify the Disclaimer text, if necessary. If you want the supplied text to be the default, click the **Make this Disclaimer default** check box.

**Step 14**  
Click **Save**.

---

### Configuring a User Login Policies Template

This page allows you to add a new user login policies template or make modifications to an existing template. On this template you set the maximum number of concurrent logins that each single user can have.

**Step 1**  
Choose **Configure > Controller Templates**.

**Step 2**  
From the left sidebar menu, choose **Security > User Login Policies**.

**Step 3**  
To add a new template, choose **Add Template** from the Select a command drop-down menu and click **GO**. To make modifications to an existing template, click to select a user login policy in the Template Name column. The User Login Policies Template window appears (see Figure 10-25).
Step 4 You can adjust the maximum number of concurrent logins each single user can have.

Step 5 Click **Save** to keep this template.

### Configuring a MAC Filter Template

This page allows you to add a new MAC filter template or make modifications to an existing template.

**Step 1** Choose **Configure > Controller Templates**.

**Step 2** From the left sidebar menu, choose **Security > MAC Filtering**.

**Step 3** To add a new template, choose **Add Template** from the Select a command drop-down menu and click **GO**. To make modifications to an existing template, click to select a MAC address in the MAC Address column. The MAC Filter Templates window appears (see Figure 10-26).
Step 4 If you keep Import From File enabled, you need to enter a file path or click the Browse button to navigate to the file path. Skip to Step 9. If you disable Import from File, continue to Step 5.

The client MAC address appears.

Step 5 Choose the SSID which this MAC filter is applied to or choose the any SSID option.

Step 6 Use the drop-down menu to choose from the available interface names.

Step 7 Enter a user-defined description of this interface. Skip to Step 9.

Step 8 If you want to override the existing template parameter, click to enable this parameter.

Step 9 Click Save.

## Configuring an Access Point or LBS Authorization

Follow these steps to add an access point or LBS authorization template or make changes to an existing template. These templates are devised for Cisco 11xx/12xx series access points converted from IOS to LWAPP or for 1030 access points connecting in bridge mode. Refer to the *Cisco Location Appliance Configuration Guide* for further information.

### Step 1
Choose Configure > Controller Templates

### Step 2
From the Security selections in the left sidebar menu, choose AP/LBS authorization.

### Step 3
To add a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click a MAC address in the AP Base Radio MAC column. The AP/LBS Authorization Template appears (see Figure 10-27), and the number of controllers the template is applied to automatically populates.
Adding Controller Templates

Chapter 10 Using Templates

Figure 10-27 AP/LBS Authorization Templates

Step 4 Select the Import from File check box if you want to import a file containing access point MAC addresses.

Note You can only import a .csv file. Any other file formats are not supported.

Step 5 Enter the file path from where you want to import the file.

Step 6 Click Save.

Configuring a Manually Disabled Client Template

This page allows you to add a new manually disabled client template or make modifications to an existing template.

Step 1 Choose Configure > Controller Templates.

Step 2 From the left sidebar menu, choose Security > Disabled Clients.

To add a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click to select a disabled client in the Template Name column. The Manually Disabled Clients Template window appears (see Figure 10-28).
Figure 10-28  Manually Disabled Clients Template

Step 3  Enter the MAC address of the client you want to disable.

Step 4  Enter a description of the client you are setting to disabled.

Step 5  Click Save.

Configuring a CPU Access Control List (ACL) Template

The existing ACLs established in the “Configuring Access Control List Templates” section on page 10-55 is used to set traffic controls between the central processing unit (CPU) and network processing unit (NPU). Follow these steps to add a CPU ACL template or make modifications to an existing template.

Step 1  Choose Configure > Controller Templates.

Step 2  Choose Security > CPU Access Control List in the left sidebar menu.

Step 3  If you want to create a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click to select a template name in the ACL Name column. The CPU Access Control List Template appears (see Figure 10-29).
Adding Controller Templates

Figure 10-29  CPU Access Control List Template

Step 4 If you click the check box to enable CPU ACL, two more parameters appear. When CPU ACL is enabled and applied on the controller, WCS displays the details of the CPU ACL against that controller.

Step 5 From the ACL Name drop-down menu, choose a name from the list of defined names.

Step 6 From the CPU ACL Mode drop-down menu, choose which data traffic direction this CPU ACL list controls. The choices are the wired side of the data traffic, the wireless side of the data traffic, or both wired and wireless.

Step 7 Click Save.

Configuring a Rogue Policies Template

This window enables you to configure the rogue policy (for access points and clients) applied to the controller. Follow these steps to add a rogue policy template or modify an existing template.

Step 1 Choose Configure > Controller Templates.

Step 2 From the left sidebar menu, choose Security > Rogue Policies.

Step 3 If you want to create a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click to select a template name in the Template Name column. The Rogue Policy Setup Template appears (see Figure 10-30).
Figure 10-30 Rogue Policy Setup Template

**Step 4** Check the **Rogue Location Discovery Protocol** to enable the discovery of rogue access points. Rogue Location Discovery Protocol (RLDP) determines whether or not the rogue is connected to the enterprise wired network.

*Note* With RLDP, the controller instructs a managed access point to associate with the rogue access point and sends a special packet to the controller. If the controller receives the packet, the rogue access point is connected to the enterprise network. This method works for rogue access points that do not have encryption enabled.

**Step 5** Set the expiration timeout (in seconds) for rogue access point entries.

**Step 6** Check the **Validate rogue clients against AAA** check box to enable the AAA validation of rogue clients.

**Step 7** Check the **Detect and report Adhoc networks** check box to enable detection and reporting of rogue clients participating in adhoc networking.

**Step 8** Click **Save**.

---

**Configuring a Rogue AP Rules Template**

Rogue access point rules allow you to define rules to automatically classify rogue access points. WCS applies the rogue access point classification rules to the controllers. These rules can limit a rogue’s appearance on maps based on RSSI level (weaker rogue access points are ignored) and time limit (a rogue access point is not flagged unless it is seen for the indicated period of time).

*Note* Rogue access point rules also help reduce false alarms.
To view current classification rule templates, rule type, and the number of controllers to which they are applied, choose **Configure > Controller Templates > Security > Rogue AP Rules**. If you want to view rogue access point rules, refer to the “Viewing or Editing Rogue Access Point Rules” section on page 9-27.

**Note**

Rogue classes include the following types:
- Malicious Rogue—A detected access point that matches the user-defined malicious rules or has been manually moved from the Friendly AP category.
- Friendly Rogue—Known, acknowledged, or trusted access point or a detected access point that matches user-defined friendly rules.
- Unclassified Rogue—A detected access point that does not match the malicious or friendly rules.

Follow these steps to create a new classification rule template for rogue access points.

**Step 1** Choose **Configure > Controller Templates**.

**Step 2** From the left sidebar menu, choose **Security > Rogue AP Rules**.

**Step 3** From the Select a command drop-down menu, choose **Add Classification Rule** and click GO. The Rogue AP Rules > New Template window appears (see Figure 10-31). To make modifications to an existing rogue access point rules template or to apply a current template to the controllers, choose **Configure > Controller Templates > Security > Rogue AP Rules** and click a template name in the Template Name column.

**Figure 10-31  Rogue AP Rules > New Template Window**

**Step 4** In the General portion of the window, enter the following parameters:
- Rule Name—Enter a name for the rule in the text box.
Chapter 10 Using Templates

Adding Controller Templates

- **Rule Type**—Choose **Malicious** or **Friendly** from the drop-down menu. A rogue is considered malicious if a detected access point matches the user-defined malicious rules or has been manually moved from the Friendly AP category. A rogue is considered friendly if it is a known, acknowledged, or trusted access point or a detected access point that matches the user-defined Friendly rules.

- **Match Type**—Choose **Match All Conditions** or **Match Any Condition** from the drop-down menu.

**Step 5**

In the Malicious Rogue Classification Rule portion of the window, enter the following parameters.

- **Open Authentication**—Choose the check box to enable open authentication.
- **Match Managed AP SSID**—Choose the check box to enable the matching of a Managed AP SSID.

**Note** Managed SSIDs are the SSIDs configured for the WLAN and known to the system

- **Match User Configured SSID**—Choose the check box to enable the matching of User Configured SSIDs.

**Note** User Configured SSIDs are the SSIDs that are manually added. Enter the User Configured SSIDs (one per line) in the text box below **Match User Configured SSID**.

- **Minimum RSSI**—Choose the check box to enable the Minimum RSSI threshold limit.

**Note** Enter the minimum RSSI threshold level (dB) in the text box. The detected access point is classified as malicious if it is detected above the indicated RSSI threshold.

- **Time Duration**—Choose the check box to enable the Time Duration limit.

**Note** Enter the time duration limit (in seconds) in the text box. The detected access point is classified as malicious if it is viewed for a longer period of time than the indicated time limit.

- **Minimum Number Rogue Clients**—Choose the check box to enable the Minimum Number Rogue Clients limit. Enter the minimum number of rogue clients allowed. The detected access point is classified as malicious if the number of clients associated to the detected access point is greater than or equal to the indicated value.

**Step 6**

Click **Save**.

Configuring a Rogue AP Rule Groups Template

A rogue access point rule group template allows you to combine more than one rogue access point rule to controllers.

To view current rogue access point rule groups templates, choose **Configure > Controller Templates > Security > Rogue AP Rule Groups**.

Follow these steps to create a new Rogue AP Rule Groups template.
**Step 1** Choose **Configure > Controller Templates**.

**Step 2** From the left sidebar menu, choose **Security > Rogue AP Rule Groups**.

**Step 3** From the Select a command drop-down menu, click **Add Rogue Rule Group**.

**Step 4** Click **GO**. The Rogue AP Rule Groups > New Template window appears (see **Figure 10-32**).

**Figure 10-32** Rogue AP Rule Groups > New Template

---

**Note** To make modifications to an existing rogue policy template or to apply a current template to controllers, choose **Configure > Controller Templates > Security > Rogue AP Rule Groups** and click a template name in the Template Name column. Make the necessary changes to the template and click **Save** or **Apply to Controllers**.

**Step 5** Enter a name for the rule group in the General portion of the window.

**Step 6** To add a Rogue AP rule, click to highlight the rule in the left column. Click **Add** to move the rule to the right column.

---

**Note** Rogue access point rules can be added from the Rogue Access Point Rules section. Refer to the “Configuring a Rogue AP Rules Template” section on page 10-43 for more information.

**Step 7** To remove a rogue access point rule, click to highlight the rule in the right column. Click **Remove** to move the rule to the left column.

**Step 8** Use the **Move Up/Move Down** buttons to specify the order in which the rules apply. Highlight the desired rule and click **Move Up** or **Move Down** to move it higher or lower in the current list.

**Step 9** Click **Save** to confirm the rogue access point rule list.

**Step 10** Click **Cancel** to close the window without making any changes to the current list.
Configuring a Friendly Access Point Template

This template allows you to import friendly internal access points. Importing these friendly access points prevents non-LWAPP access points from being falsely identified as rogues.

**Note**

*Friendly Internal* access points were previously referred to as *Known APs*.

To view or edit the current list of friendly access points, choose **Configure > Controller Templates > Security > Friendly AP**. The friendly access point screen identifies the access point’s MAC address, status, any comments, and whether or not the alarm is suppressed for this access point.

To add a new friendly access point, follow these steps:

**Step 1**
Choose **Configure > Controller Templates**.

**Step 2**
From the left sidebar menu, choose **Security > Friendly AP**.

**Step 3**
From the Select a command drop-down menu, choose **Add Friendly**.

**Step 4**
Click **GO**. The Friendly AP window appears (see Figure 10-33).

**Note**
To make modifications to an existing friendly access point, choose **Configure > Controller Templates > Security > Friendly Internal** and click the access point’s MAC address. Make the necessary changes to the access point and click **Save**.
Step 5  Friendly access points can be added by either importing the access point or manually entering the access point information:

- To import an access point using the Import feature,
  - Choose the **Import from File** check box.
  - Enter the file path or use the **Browse** button to navigate to the correct file.
- To manually add an access point,
  - Deselect the **Import from File** check box.
  - Enter the MAC address for the access point.

  **Note**  Use a line break to separate MAC addresses. For example, you could enter the MAC addresses as follows:
  
  00:00:11:22:33:44  
  00:00:11:22:33:45  
  00:00:11:22:33:46  

  - Choose **Internal** access point from the Status drop-down menu.
  - Enter a comment regarding this access point, if necessary.
  - Check the **Suppress Alarms** check box to suppress all alarms for this access point.
- Click **Save** to confirm this access point or **Cancel** to close the window without adding the access point to the list.

**Configuring a Client Exclusion Policies Template**

Follow these steps to add a client exclusion policies template or modify an existing template.
Step 1  Choose Configure > Controller Templates.

Step 2  Choose Security > Client Exclusion Policies in the left sidebar menu.

If you want to create a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click to select a template name in the Template Name column. The Client Exclusion Policies Template appears (see Figure 10-34).

Figure 10-34  Client Exclusion Policies Template

---

Step 3  To edit an existing client exclusion policies template, click its name in the Template Name column to go the Client Exclusion Policies Template window. Create or edit a client exclusion policies template by configuring its parameters.

Table 10-2  Client Exclusion Policies Template Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Template Name</td>
<td>Enter a name for the client exclusion policy.</td>
</tr>
<tr>
<td>Excessive 802.11 Association Failures</td>
<td>Enable to exclude clients with excessive 802.11 association failures.</td>
</tr>
<tr>
<td>Excessive 802.11 Authentication Failures</td>
<td>Enable to exclude clients with excessive 802.11 authentication failures.</td>
</tr>
<tr>
<td>Excessive 802.1X Authentication Failures</td>
<td>Enable to exclude clients with excessive 802.1X authentication failures.</td>
</tr>
<tr>
<td>External Policy Server Failures</td>
<td>Enable to exclude clients with excessive external policy server failures.</td>
</tr>
</tbody>
</table>
Adding Controller Templates

Step 4  Click Save.

Configuring an Access Point Authentication and MFP Template

Management frame protection (MFP) provides for the authentication of 802.11 management frames by the wireless network infrastructure. Management frames can be protected in order to detect adversaries who are invoking denial of service attacks, flooding the network with associations and probes, interjecting as rogue access points, and affecting the network performance by attacking the QoS and radio measurement frames.

When enabled, the access point protects the management frames it transmits by adding a message integrity check information element (MIC IE) to each frame. Any attempt to copy, alter, or replay the frame invalidates the MIC, causing any receiving access point configured to detect MFP frames to report the discrepancy. An access point must be a member of a WDS to transmit MFP frames.

When MFP detection is enabled, the access point validates every management frame that it receives from other access points in the network. It ensures that the MIC IE is present (when the originator is configured to transmit MFP frames) and matches the content of the management frame. If it receives any frame that does not contain a valid MIC IE from a BSSID belonging to an access point that is configured to transmit MFP frames, it reports the discrepancy to the network management system.

Follow these steps to add a new template for the access point authentication and management frame protection (MFP) or make modifications to an existing template.

Step 1  Choose Configure > Controller Templates.

Step 2  From the left sidebar menu, select Security > AP Authentication and MFP.

Step 3  To add a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click to select a MAC address in the AP Base Radio MAC column. The AP Authentication Policy Template appears (see Figure 10-35), and the number of controllers the template is applied to automatically populates.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Excessive 802.11 Web Authentication Failures</td>
<td>Enable to exclude clients with excessive 802.11 web authentication failures.</td>
</tr>
<tr>
<td>IP Theft or Reuse</td>
<td>Enable to exclude clients exhibiting IP theft or reuse symptoms.</td>
</tr>
</tbody>
</table>
Figure 10-35  AP Authentication Policy Template

Step 4  From the Protection Type drop-down menu, choose one of the following authentication policies:
- None: No access point authentication policy.
- AP Authentication: Apply authentication policy.
- MFP: Apply management frame protection.

Step 5  Check to enable AP neighbor authentication. With this feature enabled, the access points sending RRM neighbor packets with different RF network names are reported as rogues.

Step 6  Alarm trigger threshold appears only when AP authentication is selected as a protection type. Set the number of hits from an alien access point to ignore before raising an alarm.

The valid range is from 1 to 255. The default value is 255.

Step 7  Click Save.

Configuring a Web Authentication Template

With web authentication, guests are automatically redirected to a web authentication page when they launch their browsers. Guests gain access to the WLAN through this web portal. Wireless LAN administrators using this authentication mechanism should have the option of providing unencrypted or encrypted guest access. Guest users can then log into the wireless network using a valid username and password, which is encrypted with SSL. Web authentication accounts may be created locally or managed by a RADIUS server. The Cisco Wireless LAN controllers can be configured to support a web authentication client. You can use this template to replace the Web authentication page provided on the controller.

Follow these steps to add a web authentication template or make modifications to an existing template.

Step 1  Choose Configure > Controller Templates.

Step 2  From the left sidebar menu, choose Security > Web Auth Configuration.
Adding Controller Templates

Step 3  To add a new template, choose **Add Template** from the Select a command drop-down menu and click **GO**. To make modifications to an existing template, click to select a template in the Template Name column. The Web Authentication Configuration Template window appears (see Figure 10-36), and the number of controllers the template is applied to automatically populates.

![Figure 10-36 Web Authentication Configuration Template](image)

**Step 4** Choose the appropriate web authentication type from the drop-down menu. The choices are default internal, customized web authentication, or external.

- If you choose default internal, you can still alter the page title, message, and redirect URL, as well as whether the logo appears. Continue to Step 5.

- If you choose customized web authentication, click **Save** and apply this template to the controller. You are prompted to download the web authentication bundle.

**Note** Before you can choose customized web authentication, you must first download the bundle by going to **Config > Controller** and choose **Download Customized Web Authentication** from the Select a command drop-down menu and click **GO**.

- If you choose external, you need to enter the URL you want to redirect to after a successful authentication. For example, if the value entered for this field is `http://www.company.com`, the user would be directed to the company home page.

**Step 5** Click to enable Logo Display if you want your company logo displayed.

**Step 6** Enter the title you want displayed on the Web authentication page.

**Step 7** Enter the message you want displayed on the Web authentication page.

**Step 8** Provide the URL where the user is redirected after a successful authentication. For example, if the value entered for this field is `http://www.company.com`, the user would be directed to the company home page.

**Step 9** Click **Save**.
**Downloading a Customized Web Authentication Page**

You can download a customized Web authentication page to the controller. A customized web page is created to establish a username and password for user web access.

When downloading customized web authentication, these strict guidelines must be followed:

- A username must be provided.
- A password must be provided.
- A redirect URL must be retained as a hidden input item after extracting from the original URL.
- The action URL must be extracted and set from the original URL.
- Scripts to decode the return status code must be included.
- All paths used in the main page should be of relative type.

Before downloading, the following steps are required:

**Step 1** Download the sample login.html bundle file from the server. The .html file is shown in Figure 10-37. The login page is presented to web users the first time they access the WLAN if web authentication is turned on.

*Figure 10-37 Login.html*

**Step 2** Edit the login.html file and save it as a .tar or .zip file.

*Note* You can change the text of the Submit button to read Accept terms and conditions and Submit.

**Step 3** Make sure you have a Trivial File Transfer Protocol (TFTP) server available for the download. Keep these guidelines in mind when setting up a TFTP server:

- If you are downloading through the service port, the TFTP server must be on the same subnet as the service port because the service port is not routable. However, if you want to put the TFTP server on a different network while the management port is down, add a static route if the subnet where the service port resides has a gateway (config route add IP address of TFTP server).
- If you are downloading through the distribution system network port, the TFTP server can be on the same or a different subnet because the distribution system port is routable.
- A third-party TFTP server cannot run on the same computer as the Cisco WCS because WCS’s built-in TFTP server and third-party TFTP server use the same communication port.

**Step 4** Download the .tar or .zip file to the controller(s).
Adding Controller Templates

Chapter 10  Using Templates

Note
The controller allows you to download up to 1 MB of a tar file containing the pages and image files required for the Web authentication display. The 1 MB limit includes the total size of uncompressed files in the bundle.

You can now continue with the download.

Step 5  Copy the file to the default directory on your TFTP server.

Step 6  Choose Configure > Controllers.

Step 7  Choose a controller by clicking the URL for the corresponding IP address. If you select more than one IP address, the customized Web authentication page is downloaded to multiple controllers.

Step 8  From the left sidebar menu, choose System > Commands.

Step 9  From the Upload/Download Commands drop-down menu, choose Download Customized Web Auth and click GO.

Step 10  The IP address of the controller to receive the bundle and the current status are displayed (see Figure 10-38).

Figure 10-38  Download Customized Web Auth Bundle to Controller

Step 11  Choose local machine from the File is Located On parameter. If you know the filename and path relative to the server’s root directory, you can also select TFTP server.

Note  For a local machine download, either .zip or .tar file options exists, but the WCS does the conversion of .zip to .tar automatically. If you chose a TFTP server download, only .tar files would be specified.

Step 12  Enter the maximum number of times the controller should attempt to download the file in the Maximum Retries parameter.

Step 13  Enter the maximum amount of time in seconds before the controller times out while attempting to download the file in the Timeout parameter.
**Adding Controller Templates**

**Step 14** The files are uploaded to the c:\tftp directory. Specify the local file name in that directory or use the Browse button to navigate to it.

**Step 15** Click OK.

If the transfer times out for some reason, you can simply choose the TFTP server option in the File Is Located On parameter, and the Server File Name is populated for you. The local machine option initiates a two-step operation. First, the local file is copied from the administrator’s workstation to WCS’s own built-in TFTP server. Then the controller retrieves that file. For later operations, the file is already in the WCS server’s TFTP directory, and the download web page now automatically populates the filename.

**Step 16** Click the “Click here to download a sample tar file” to get an option to open or save the login.tar file.

**Step 17** After completing the download, you are directed to the new page and able to authenticate.

---

**Configuring Access Control List Templates**

An access control list (ACL) is a set of rules used to limit access to a particular interface (for example, if you want to restrict a wireless client from pinging the management interface of the controller). ACLs can be applied to data traffic to and from wireless clients or to all traffic destined for the controller central processing unit (CPU) and can now support reusable grouped IP addresses and reusable protocols. After ACLs are configured in the template, they can be applied to the management interface, the AP-manager interface, or any of the dynamic interfaces for client data traffic; to the network processing unit (NPU) interface for traffic to the controller CPU; or to a WAN. Follow these steps to add an ACL template or make modifications to an existing template.

**Step 1** Choose Configure > Controller Templates.

**Step 2** Choose Access Control > Access Control Lists in the left sidebar menu.

**Step 3** If you want to create a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click to select a template name in the ACL Name column. The Access Control List name appears in the window.

**Step 4** To create reusable grouped IP addresses and protocols, choose Access Control > IP Groups from the left sidebar menu.

**Step 5** All the IP address groups are listed. One IP address group can have a maximum of 128 IP address and netmask combinations. To define a new IP address group, choose Add IP Group from the Select a command drop-down menu and click GO. To view or modify an existing IP address group, click the URL of the IP address group. The IP address group window opens.

**Note** For the IP address of any, an any group is predefined.

**Step 6** To define an additional protocol that is not a standard predefined one, choose Access Control > Protocol Groups from the left sidebar menu. The protocol groups with their source and destination port and DSCP are displayed.

**Step 7** To create a new protocol group, choose Add Protocol Group from the Select a command drop-down menu and click GO. To view or modify an existing protocol group, click the URL of the group. The Protocol Groups window appears.
Adding Controller Templates

Step 8  The rule name is provided for the existing rules, or you can now enter a name for a new rule. ACLs are not required to have rules defined. When a packet matches all the parameters of a rule, the action for this rule is exercised.

Step 9  In the Start Port parameter, enter a value (between 1 and 64) to determine the order of this rule in relation to any other rules defined for this ACL. The rules for each ACL are listed in contiguous sequence from 1 to 64. That is, if rules 1 through 4 are already defined and you add rule 29, it is added as rule 5.

**Note**  If you add or change a sequence number, the operating system adjusts the other rule sequence numbers to retain the contiguous sequence. For instance, if you have sequence numbers 1 through 7 defined and change number 7 to 5, the operating system automatically reassigns sequence 5 to 6 and sequence 6 to 7. Any rules generated can be edited individually and resequenced in the desired order.

Step 10  From the Source Port drop-down menu, specify the source of the packets to which this ACL applies.

Step 11  For the Destination drop-down menu, specify the destination of the packets to which this ACL applies.

Step 12  In the DSCP drop-down menu, choose any or a specific IP address. DSCP is a packet header code that can be used to define the quality of service across the Internet.

Step 13  Click **Save**.

Step 14  You can now create new mappings from the defined IP address groups and protocol groups. To define a new mapping, choose the ACL template to which you want to map the new groups. All ACL mappings appear on the top of the window, and all ACL rules appear on the bottom.

Step 15  To define a new mapping, choose **Add Rule Mappings** from the Select a command drop-down menu. The Add Rule Mapping windows appears.

Step 16  Choose the desired IP address groups, protocol groups, and action and click **Add**. The new mappings will populate the bottom table.

Step 17  Click **Save**.

Step 18  You can now automatically generate rules from the rule mappings you created. Choose the mappings for which you want to generate rules and click **Generate**. This automatically creates the rules. These rules are generated with contiguous sequence. That is, if rules 1 through 4 are already defined and you add rule 29, it is added as rule 5.

Existing ACL templates are duplicated into a new ACL template. This duplication clones all the ACL rules and mappings defined in the source ACL template.

Configuring a Policy Name Template (for 802.11a/n or 802.11b/g/n)

Follow these steps to add a new policy name template for 802.11a/n or 802.11b/g/n or make modifications to an existing template.

Step 1  Choose **Configure > Controller Templates**.

Step 2  From the left sidebar menu, choose either **802.11a/n > Parameters** or **802.11b/g/n > Parameters**.
Step 3  
To add a new template, choose **Add Template** from the Select a command drop-down menu. To make modifications to an existing template, click to select a policy name in the Policy Name column. The 802.11a/n or b/g/n Parameters Template window appears (see **Figure 10-39**), and the number of controllers the template is applied to automatically populates.

**Figure 10-39  802.11a/n Parameters Template**

![802.11a/n Parameters Template](image)

**Step 4**  
Click the check box if you want to enable 802.11a/n or b/g/n network status.

**Step 5**  
Enter the amount of time between beacons in kilomicroseconds. The valid range is from 100 to 600 milliseconds.

**Step 6**  
Enter the number of beacon intervals that may elapse between transmission of beacon frames containing a traffic indicator message (TIM) element whose delivery count field is 0. This value is transmitted in the DTIM period field of beacon frames. When client devices receive a beacon that contains a DTIM, they normally wake up to check for pending packets. Longer intervals between DTIMS let clients sleep longer and preserve power. Conversely, shorter DTIM periods reduce the delay in receiving packets but use more battery power because clients wake up more often.

**Step 7**  
At the Fragmentation Threshold parameter, determine the size at which packets are fragmented (sent as several pieces instead of as one block). Use a low setting in areas where communication is poor or where there is a great deal of radio interference.

**Step 8**  
Enter the percentage for 802.11e maximum bandwidth.

**Step 9**  
Click if you want short preamble enabled.

**Step 10**  
Click the **Pico Cell Mode** check box if you want it enabled. This feature enables automatic operating system parameter reconfiguration, allowing the operating system to function efficiently in pico cell deployments.

**Step 11**  
Click the **Fast Roaming Mode** check box if you want to enable it. Enabling Cisco’s Centralized Key Management (CCKM) authentication key management allows fast exchange when a client roams from one access point to another.

**Step 12**  
At the Dynamic Assignment drop-down menu, choose one of three modes:
- Automatic - The transmit power is periodically updated for all access points that permit this operation.
- On Demand - Transmit power is updated when the Assign Now button is selected.
- Disabled - No dynamic transmit power assignments occur, and values are set to their global default.

**Step 13**
Use the Tx Level drop-down menu to determine the access point’s transmit power level. The available options are as follows:

- 1 - Maximum power allowed per country code setting
- 2 - 50% power
- 3 - 25% power
- 4 - 6.25 to 12.5% power
- 5 - 0.195 to 6.25% power

**Note** The power levels and available channels are defined by the country code setting and are regulated on a country by country basis.

**Step 14**
The Assignment Mode drop-down menu has three dynamic channel modes:

- Automatic - The channel assignment is periodically updated for all access points that permit this operation. This is also the default mode.
- On Demand - Channel assignments are updated when desired.
- OFF - No dynamic channel assignments occur, and values are set to their global default.

**Step 15**
At the Avoid Foreign AP Interference check box, click if you want to enable it. Enable this parameter to have RRM consider interference from foreign Cisco access points (those non-Cisco access points outside RF/mobility domain) when assigning channels. This foreign 802.11 interference. Disable this parameter to have RRM ignore this interference.

In certain circumstances with significant interference energy (dB) and load (utilization) from foreign access points, RRM may adjust the channel assignment to avoid these channels (and sometimes adjacent channels) in access points close to the foreign access points. This increases capacity and reduces variability for the Cisco WLAN Solution.

**Step 16**
Click the Avoid Cisco AP Load check box if you want it enabled. Enable this bandwidth-sensing parameter to have controllers consider the traffic bandwidth used by each access point when assigning channels to access points. Disable this parameter to have RRM ignore this value.

In certain circumstances and with denser deployments, there may not be enough channels to properly create perfect channel re-use. In these circumstances, RRM can assign better re-use patterns to those access points that carry more traffic load.

**Step 17**
Click the Avoid non 802.11 Noise check box if you want to enable it. Enable this noise-monitoring parameter to have access points avoid channels that have interference from non-access point sources, such as microwave ovens or Bluetooth devices. Disable this parameter to have RRM ignore this interference.

In certain circumstances with significant interference energy (dB) from non-802.11 noise sources, RRM may adjust the channel assignment to avoid these channels (and sometimes adjacent channels) in access points close to the noise sources. This increases capacity and reduces variability for the Cisco WLAN Solution.
Chapter 10      Using Templates

Adding Controller Templates

Step 18 The Signal Strength Contribution check box is always enabled (not configurable). constantly monitors the relative location of all access points within the RF/mobility domain to ensure near-optimal channel re-use. The net effect is an increase in Cisco WLAN Solution capacity and a reduction in co-channel and adjacent channel interference.

Step 19 Data rates are negotiated between the client and the controller. If the data rate is set to Mandatory, the client must support it in order to use the network. If a data rate is set as Supported by the controller, any associated client that also supports that same rate may communicate with the access point using that rate. However, it is not required that a client uses all the rates marked supported in order to associate. For each rate, a pull-down selection of Mandatory or Supported is available. Each data rate can also be set to Disabled to match client settings.

Step 20 At the Channel List drop-down menu in the Noise/Interference/Rogue Monitoring Channels section, choose between all channels, country channels, or DCA channels based on the level of monitoring you want. Dynamic Channel Allocation (DCA) automatically selects a reasonably good channel allocation amongst a set of managed devices connected to the controller.

Step 21 The Cisco Compatible Extension’s location measurement interval can only be changed when measurement mode is enabled to broadcast radio measurement requests. When enabled, this enhances the location accuracy of clients.

Step 22 Click Save.

Configuring High Density Templates

A method to mitigate the inter-cell contention problem in high-density networks is to adjust the access point and client station receiver sensitivity, CCA sensitivity, and transmit power parameters in a relatively cooperative manner. By adjusting these variables, the effective cell size can be reduced, not by lowering the transmit power but by increasing the necessary received power before an access point and client consider the channel sufficiently clear for packet transfer. Follow these steps to add high density on a template or make modifications to an existing template.

Step 1 Choose Configure > Controller Templates.

Step 2 From the left sidebar menu, choose either 802.11a/n > Parameters.

Step 3 In the General portion of this window, you see a Pico Cell Mode parameter. Click the check box to enable pico cell.

**Note** In order for this check box to have validity, you must have software version 4.1 or later. If you have an earlier version, this check box value is ignored.

Step 4 Choose 802.11a/n > Pico Cell from the left sidebar menu. Click which template in the Template Name column you want to modify or choose Add Template from the Select a command drop-down menu and click GO. The window as shown in Figure 10-40 appears.
**Adding Controller Templates**

**Chapter 10  Using Templates**

**Figure 10-40  Pico Cell Parameters Window**

If the Pico Cell Mode parameter is set to Disabled or V1, the Pico Cell V2 parameters are grayed out.

For pico cell V2 to work with Intel 3945 clients, the QBSS feature also has to be enabled (i.e., WMM clients must be set to allowed), and fast roaming cannot be enabled.

**Step 5**  
Go to **802.11a/n > Parameters** and ensure that the 802.11a/n Network Status check box is not enabled.

**Step 6**  
From the Pico Cell Mode drop-down menu, choose **V2**. By choosing V2, the parameters for access point and clients share the same values and make communication symmetrical. This selection also allows you to put in values for Rx sensitivity, CCA sensitivity, and transmit power although the defaulted minimum and maximum values represent the Cisco recommended values for most networks.

You can only choose V2 if you have software version 4.1 or later.

**Step 7**  
Set the Rx sensitivity based on the desired receiver sensitivity for 802.11a/n radios. The Current column shows what is currently set on the access point and clients, and the Min and Max columns show the range to which the access points and clients should adapt. Receiver signal strength values falling outside of this range are normally disregarded.

**Step 8**  
Set the CCA sensitivity based on when the access point or client considers the channel clear enough for activity. The current column shows what is currently set on the access point and clients, and Min and Max columns show the range to which the access points and clients should adapt. CCA values falling outside of this range are normally disregarded.
Step 9 Click **Save** to save these values. Before choosing **Reset to Defaults** you must turn off the 802.11 network.

---

**Configuring a Voice Parameter Template (for 802.11a/n or 802.11b/g/n)**

Follow these steps to add a template for either 802.11a/n or 802.11b/g/n voice parameters, such as call admission control and traffic stream metrics or make modifications to an existing template.

**Step 1** Choose **Configure > Controller Templates**.

**Step 2** From the left sidebar menu, choose either **802.11a/n > Voice Parameters** or **802.11b/g/n > Voice Parameters**.

**Step 3** To add a new template, choose **Add Template** from the Select a command drop-down menu and click **GO**. To make modifications to an existing template, click to select a template in the Template Name column. The 802.11a/n or 802.11b/g/n Voice Parameters window appears (see Figure 10-41), and the number of controllers the template is applied to automatically populates.

**Figure 10-41 802.11b/g/n Voice Parameters Template**

**Step 4** For end users to experience acceptable audio quality during a VoIP phone call, packets must be delivered from one endpoint to another with low latency and low packet loss. To maintain QoS under differing network loads, call admission control (CAC) is required. CAC on an access point allows it to maintain controlled QoS when the network is experiencing congestion and keep the maximum allowed number of calls to an acceptable quantity. Click the check box to enable CAC.
Step 5  Load-based CAC incorporates a measurement scheme that takes into account the bandwidth consumed by all traffic types from itself, from co-channel access points, and by co-located channel interference. Load-based CAC also covers the additional bandwidth consumption resulting from PHY and channel impairment. To enable load-based CAC for this radio band, check the Use Load-based AC check box.

Step 6  Enter the percentage of maximum bandwidth allowed.

Step 7  Enter the percentage of reserved roaming bandwidth.

Step 8  Click if you want to enable expedited bandwidth as an extension of CAC for emergency calls. You must have an expedited bandwidth IE that is Cisco Compatible Extensions (version 5) compliant so that a TSPEC request is given higher priority.

Step 9  Click the check box if you want to enable metric collection. Traffic stream metrics are a series of statistics about VoIP over your wireless LAN and informs you of the QoS of the wireless LAN. For the access point to collect measurement values, traffic stream metrics must be enabled. When this is enabled, the controller begins collecting statistical data every 90 seconds for the 802.11b/g/n interfaces from all associated access points. If you are using VoIP or video, this feature should be enabled.

Step 10  Click \textit{Save}.

Configuring a Video Parameter Template (for 802.11a/n or 802.11b/g/n)

Follow these steps to add a template for either 802.11a/n or 802.11b/g/n video parameters or make modifications to an existing template.

Step 1  Choose \textit{Configure} > Controller Templates.

Step 2  From the left sidebar menu, choose either \textit{802.11a/n > Video Parameters} or \textit{802.11b/g/n > Video Parameters}.

Step 3  To add a new template, choose Add Template from the Select a command drop-down menu and click \textit{GO}. To make modifications to an existing template, click to select a template in the Template Name column. The 802.11a/n or 802.11b/g/n Video Parameters window appears (see \textit{Figure 10-42}), and the number of controllers the template is applied to automatically populates.

\textit{Figure 10-42  802.11a/n Video Parameters Template}
For end users to experience acceptable audio quality during a VoIP phone call, packets must be delivered from one endpoint to another with low latency and low packet loss. To maintain QoS under differing network loads, call admission control (CAC) is required. CAC on an access point allows it to maintain controlled QoS when the network is experiencing congestion and keeps the maximum allowed number of calls to an acceptable quantity. Click the check box to enable CAC.

Enter the percentage of maximum bandwidth allowed.

Enter the percentage of reserved roaming bandwidth.

Click Save.

**Configuring EDCA Parameters through a Controller Template**

Enhanced distributed channel access (EDCA) parameters are designed to provide preferential wireless channel access for voice, video, and other quality-of-service (QoS) traffic. Follow the instructions in this section to configure 802.11a/n or 802.11b/g/n EDCA parameters through a controller template:

Choose Configure > Controller Templates.

From the left sidebar menu, select 802.11a/n > EDCA Parameters or 802.11b/g/n > EDCA Parameters to open the EDCA Parameters summary page.

Modify or view a current template by selecting the Template Name

-or-

Create a new template by selecting Add Template from the Select a command drop-down menu.

Choose one of the following options from the EDCA Profile drop-down menu:

- WMM—Enables the Wi-Fi Multimedia (WMM) default parameters. This is the default value. Choose this option when voice or video services are not deployed on your network.

- Spectralink Voice Priority—Enables Spectralink voice priority parameters. Choose this option if Spectralink phones are deployed on your network to improve the quality of calls.

- Voice Optimized—Enables EDCA voice-optimized profile parameters. Choose this option when voice services other than Spectralink are deployed on your network.

- Voice & Video Optimized —Enables EDCA voice- and video-optimized profile parameters. Choose this option when both voice and video services are deployed on your network.

Video services must be deployed with admission control (ACM). Video services without ACM are not supported.

You must shut down radio interface before configuring EDCA Parameters.

Click the Enable Streaming MAC checkbox to enable this feature.

Only enable Streaming MAC if all clients on the network are WMM compliant.
Adding Controller Templates

Chapter 10      Using Templates

Configuring a Roaming Parameters Template (for 802.11a/n or 802.11b/g/n)

Follow these steps to add a roaming parameters template or make modifications to an existing template.

**Step 1** Choose Configure > Controller Templates.

**Step 2** From the left sidebar menu, choose 802.11a/n > RRM Thresholds or 802.11b/g/n > RRM Thresholds.

**Step 3** To add a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click to select a template name in the Template Name column. The Roaming Parameters Template appears (see Figure 10-43), and the number of controllers the template is applied to automatically populates.

**Figure 10-43** 802.11 Roaming Parameters Template

**Step 4** Use the Mode drop-down menu to choose one of the configurable modes: default values and custom values. When the default values option is chosen, the roaming parameters are unavailable with the default values displayed in the text boxes. When the custom values option is selected, the roaming parameters can be edited in the text boxes. To edit the parameters, continue to Step 5.

**Step 5** In the Minimum RSSI field, enter a value for the minimum received signal strength indicator (RSSI) required for the client to associate to an access point. If the client’s average received signal power dips below this threshold, reliable communication is usually impossible. Therefore, clients must already have found and roamed to another access point with a stronger signal before the minimum RSSI value is reached.

- **Range:** -80 to -90 dBm
- **Default:** -85 dBm
Step 6  In the Hysteresis field, enter a value to indicate how strong the signal strength of a neighboring access point must be for the client to roam to it. This parameter is intended to reduce the amount of “ping ponging” between access points if the client is physically located on or near the border between two access points.

Range: 2 to 4 dB
Default: 2 dB

Step 7  In the Adaptive Scan Threshold field, enter the RSSI value from a client’s associated access point, below which the client must be able to roam to a neighboring access point within the specified transition time. This parameter also provides a power-save method to minimize the time that the client spends in active or passive scanning. For example, the client can scan slowly when the RSSI is above the threshold and scan more rapidly when below the threshold.

Range: -70 to -77 dB
Default: -72 dB

Step 8  In the Transition Time field, enter the maximum time allowed for the client to detect a suitable neighboring access point to roam to and to complete the roam, whenever the RSSI from the client’s associated access point is below the scan threshold.

The Scan Threshold and Transition Time parameters guarantee a minimum level of client roaming performance. Together with the highest expected client speed and roaming hysteresis, these parameters make it possible to design a wireless LAN network that supports roaming simply by ensuring a certain minimum overlap distance between access points.

Range: 1 to 10 seconds
Default: 5 seconds

Step 9  Click Save.

---

**Configuring an RRM Threshold Template (for 802.11a/n or 802.11b/g/n)**

Follow these steps to add a new 802.11a/n or 802.11b/g/n RRM threshold template or make modifications to an existing template.

---

Step 1  Choose Configure > Controller Templates.

Step 2  From the left sidebar menu, choose 802.11a/n > RRM Thresholds or 802.11b/g/n > RRM Thresholds.

Step 3  To add a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click to select a template name in the Template Name column. The 802.11a/n or 802.11b/g/n RRM Thresholds Template appears (see Figure 10-44), and the number of controllers the template is applied to automatically populates.
Chapter 10      Using Templates

Adding Controller Templates

Step 4  Enter the minimum percentage of failed clients that are currently associated with the controller.

Step 5  Enter the minimum number of failed clients that are currently associated with the controller.

Step 6  At the Min SNR Level parameter, enter the minimum signal-to-noise ratio of the client RF session.

Note  When the Min SNR Level (dB) parameter is adjusted, the value of the Signal Strength (dB) automatically reflects this change. The Signal Strength (dB) parameter provides information regarding what the target range of coverage thresholds will be when adjusting the SNR value.

Step 7  Enter the maximum number of clients currently associated with the controller.

Step 8  At the RF Utilization parameter, enter the percentage of threshold for either 802.11a/n or 802.11b/g/n.

Step 9  Enter an interference threshold.

Step 10  Enter a noise threshold between -127 and 0 dBm. When outside of this threshold, the controller sends an alarm to WCS.

Step 11  At the Channel List drop-down menu in the Noise/Interference/Rogue Monitoring Channels section, choose between all channels, country channels, or DCA channels based on the level of monitoring you want. Dynamic Channel Allocation (DCA) automatically selects a reasonably good channel allocation amongst a set of managed devices connected to the controller.

Step 12  Click Save.

Configuring an RRM Interval Template (for 802.11a/n or 802.11b/g/n)

Follow these steps to add an 802.11a/n or 802.11b/g/n RRM interval template or make modifications to an existing template.

Step 1  Choose Configure > Controller Templates.
Step 2 From the left sidebar menu, choose **802.11a/n > RRM Intervals** or **802.11b/g/n > RRM Intervals**.

Step 3 To add a new template, choose **Add Template** from the Select a command drop-down menu and click **GO**. To make modifications to an existing template, click to select a template name from the Template Name column. The 802.11a/n or 802.11b/g/n RRM Threshold Template appears (see **Figure 10-45**), and the number of controllers the template is applied to automatically populates.

**Figure 10-45  802.11a/n RRM Intervals Template**

Step 4 Enter at which interval you want strength measurements taken for each access point. The default is 300 seconds.

Step 5 Enter at which interval you want noise and interference measurements taken for each access point. The default is 300 seconds.

Step 6 Enter at which interval you want load measurements taken for each access point. The default is 300 seconds.

Step 7 Enter at which interval you want coverage measurements taken for each access point. The default is 300 seconds.

Step 8 Click **Save**.

### Configuring an 802.11h Template

Follow these steps to add an 802.11h template or make modifications to an existing template.

**Step 1** Choose **Configure > Controller Templates**.

**Step 2** From the left sidebar menu, choose **802.11a/n > 802.11h**.

**Step 3** To add a new template, choose **Add Template** from the Select a command drop-down menu and click **GO**. To make modifications to an existing template, click to select a template name from the Template Name column. The 802.11h Template appears (see **Figure 10-46**), and the number of controllers the template is applied to automatically populates.
Adding Controller Templates

Chapter 10      Using Templates

Figure 10-46  802.11h Template

Step 4  Check the power constraint check box to enable TPC.
Step 5  Check the channel announcement check box to enable channel announcement. Channel announcement is a method in which the access point announces when it is switching to a new channel and the new channel number.
Step 6  Click Save.

Configuring a High Throughput Template (for 802.11a/n or 802.11b/g/n)

Follow these steps to add an 802.11a/n or 802.11b/g/n high throughput template or make modifications to an existing template.

Step 1  Choose Configure > Controller Templates.
Step 2  From the left sidebar menu, choose 802.11a/n > High Throughput or 802.11b/g/n > High Throughput.
Step 3  To add a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click to select a template name from the Template Name column. The 802.11n Parameters for 2.4 GHz or 802.11n Parameters for 5 GHz template appears (see Figure 10-47), and the number of controllers the template is applied to automatically populates.
Chapter 10      Using Templates

Adding Controller Templates

Figure 10-47  802.11n Parameters for 2.4GHz Template

Step 4  Click the 802.11n Network Status Enabled check box to enable high throughput.

Step 5  In the MCS (Data Rate) Settings column, choose which level of data rate you want supported. Modulation coding schemes (MCS) are similar to 802.11a data rate. As a default, 20 MHz and short guarded interval is used.

Note  When you click the Supported check box, the chosen numbers appear in the Selected MCS Indexes window.

Step 6  Click Save.

Configuring a Mesh Template

You can configure an access point to establish a connection with the controller. Follow these steps to add a mesh template or make modifications to an existing template.

Step 1  Choose Configure > Controller Templates.

Step 2  From the left sidebar menu, choose Mesh.

Step 3  To add a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click a specific template name. The Mesh Configuration Template window appears (see Figure 10-48).
### Step 4

The Root AP to Mesh AP Range is 12,000 feet by default. Enter the optimum distance (in feet) that should exist between the root access point and the mesh access point. This global parameter applies to all access points when they join the controller and all existing access points in the network.

### Step 5

The Mesh Mac Filter is enabled by default. When enabled, this feature secures your network against any rogue access points and does not allow access points to attach if they are not defined in the MAC filter list.

However, if you disable this feature, mesh access points can join the controller.

#### Note

The ability to join a controller without specification within a MAC filter list is only supported on mesh access points.

#### Note

For releases prior to 4.1.82.0, mesh access points do not join the controller unless they are defined in the MAC filter list.

You may want to disable the MAC filter list to allow newly added access points to join the controller. Before enabling the MAC filter list again, you should enter the MAC addresses of the new access points.

After you check the Enable Mesh MAC Filter check box, the access points reboot and then rejoin the controller if defined in the MAC filter list. Access points that are not defined in the MAC list cannot join the controller.

### Step 6

The Enable Client Access on Backhaul Link check box is not checked by default. When this option is enabled, mesh access points are able to associate with 802.11a/n wireless clients over the 802.11a/n backhaul. This client association is in addition to the existing communication on the 802.11a/n backhaul between the root and mesh access points.
Chapter 10  Using Templates

Adding Controller Templates

Note
This feature is only applicable to access points with two radios.

Step 7
Click Save.

Configuring a TFTP Server Template

A Trivial File Transfer Protocol (TFTP) server is often available for the download. Keep these guidelines in mind when setting up a TFTP server:

- If you are downloading through the service port, the TFTP server must be on the same subnet as the service port because the service port is not routable. However, if you want to put the TFTP server on a different network while the management port is down, add a static route if the subnet where the service port resides has a gateway (config route add IP address of TFTP server).

- If you are downloading through the distribution system network port, the TFTP server can be on the same or a different subnet because the distribution system port is routable.

- A third-party TFTP server cannot run on the same computer as the Cisco WCS because WCS’s built-in TFTP server and third-party TFTP server use the same communication port.

Follow these steps to add a new TFTP server template or make modifications to an existing template.

- **Step 1** Choose Configure > Controller Templates.
- **Step 2** From the left sidebar menu, choose TFTP Servers.
- **Step 3** To add a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click a specific template in the TFTP Server Name column. The TFTP Server window appears.
- **Step 4** Enter the IP address for the TFTP server.
- **Step 5** Click Save.

Configuring a Trap Receiver Template

Follow these steps to add a new trap receiver template or make modifications to an existing template. If you have monitoring devices on your network that receive SNMP traps, you may want to add a trap receiver template.

- **Step 1** Choose Configure > Controller Templates.
- **Step 2** From the left sidebar menu, choose Management > Trap Receivers.
- **Step 3** To add a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click a specific template in the Template Name column. The Trap Receiver Template window appears (see Figure 10-49), and the number of controllers the template is applied to automatically populates.
**Figure 10-49  Trap Receiver Template**

<table>
<thead>
<tr>
<th>Wireless Control System</th>
</tr>
</thead>
<tbody>
<tr>
<td>Template Name: 172.32.104</td>
</tr>
<tr>
<td>No of Controllers Applied To: 0</td>
</tr>
<tr>
<td>IP Address: 172.32.32.104</td>
</tr>
<tr>
<td>Admin Status: enabled</td>
</tr>
</tbody>
</table>

**Step 4** Enter the IP address of the server.

**Step 5** Click to enable the admin status if you want SNMP traps to be sent to the receiver.

**Step 6** Click **Save**.

---

**Configuring a Trap Control Template**

Follow these steps to add a trap control template or make modifications to an existing template.

**Step 1** Choose **Configure > Controller Templates**.

**Step 2** From the left sidebar menu, choose **Management > Trap Control**.

**Step 3** To add a new template, choose **Add Template** from the Select a command drop-down menu and click **GO**. To make modifications to an existing template, click to select a template in the Template Name column. The Trap Controls Template window appears (see **Figure 10-50**), and the number of controllers the template is applied to automatically populates.
Figure 10-50  Trap Controls Template

Step 4  Check the appropriate check box to enable any of the following miscellaneous traps:

- **SNMP Authentication** - The SNMPv2 entity has received a protocol message that is not properly authenticated. When a user who is configured in SNMP V3 mode tries to access the controller with an incorrect password, the authentication fails and a failure message is displayed. However, no trap logs are generated for the authentication failure.

- **Link (Port) Up/Down** - Link changes states from up or down.

- **Multiple Users** - Two users log in with the same login ID.

- **Spanning Tree** - Spanning Tree traps. Refer to the STP specification for descriptions of individual parameters.

- **Rogue AP** - Whenever a rogue access point is detected or when a rogue access point was detected earlier and no longer exists, this trap is sent with its MAC address.

- **Controller Config Save** - Notification sent when the configuration is modified.

Step 5  Check the appropriate check box to enable any of the following client-related traps:

- **802.11 Disassociation** - The disassociate notification is sent when the client sends a disassociation frame.

- **802.11 Deauthentication** - The deauthenticate notification is sent when the client sends a deauthentication frame.

- **802.11 Failed Authentication** - The authenticate failure notification is sent when the client sends an authentication frame with a status code other than successful.

- **802.11 Failed Association** - The associate failure notification is sent when the client sends an association frame with a status code other than successful.
• Excluded - The associate failure notification is sent when a client is excluded.

**Step 6** Check the appropriate check box to enable any of the following access point traps:

• AP Register - Notification sent when an access point associates or disassociates with the controller.
• AP Interface Up/Down - Notification sent when access point interface (802.11a/n or 802.11b/g/n) status goes up or down.

**Step 7** Check the appropriate check box to enable any of the following auto RF profile traps:

• Load Profile - Notification sent when Load Profile state changes between PASS and FAIL.
• Noise Profile - Notification sent when Noise Profile state changes between PASS and FAIL.
• Interference Profile - Notification sent when Interference Profile state changes between PASS and FAIL.
• Coverage Profile - Notification sent when Coverage Profile state changes between PASS and FAIL.

**Step 8** Check the appropriate check box to enable any of the following auto RF update traps:

• Channel Update - Notification sent when access point’s dynamic channel algorithm is updated.
• Tx Power Update - Notification sent when access point’s dynamic transmit power algorithm is updated.

**Step 9** Check the appropriate check box to enable any of the following AAA traps:

• User Auth Failure - This trap is to inform you that a client RADIUS authentication failure has occurred.
• RADIUS Server No Response - This trap is to indicate that no RADIUS server(s) are responding to authentication requests sent by the RADIUS client.

**Step 10** Check the appropriate check box to enable the following 802.11 security trap:

• WEP Decrypt Error - Notification sent when the controller detects a WEP decrypting error.

**Step 11** Check the appropriate check box to enable the following WPS trap:

• Rogue Auto Containment - Notification sent when a rogue access point is auto-contained.

**Step 12** Click **Save**.

---

**Configuring a Telnet SSH Template**

Follow these steps to add a Telnet SSH configuration template or make changes to an existing template.

**Step 1** Choose **Configure > Controller Templates**.

**Step 2** From the left sidebar menu, choose **Management > Telnet SSH**.

**Step 3** To add a new template, choose **Add Template** from the Select a command drop-down menu and click **GO**. To make modifications to an existing template, click to select a template in the Template Name column. The Telnet SSH Configuration Template window appears (see **Figure 10-51**), and the number of controllers the template is applied to automatically populates.
Step 4  Enter the number of minutes a Telnet session is allowed to remain inactive before being logged off. A zero means there is no timeout. The valid range is 0 to 160, and the default is 5.

Step 5  At the Maximum Sessions parameter, enter the number of simultaneous Telnet sessions allowed. The valid range is 0 to 5, and the default is 5. New Telnet sessions can be allowed or disallowed on the DS (network) port. New Telnet sessions are always allowed on the service port.

Step 6  Use the Allow New Telnet Session drop-down menu to determine if you want new Telnet sessions allowed on the DS port. New Telnet sessions can be allowed or disallowed on the DS (network) port. New Telnet sessions are always allowed on the service port. The default is no.

Step 7  Use the Allow New SSH Session drop-down menu to determine if you want Secure Shell Telnet sessions allowed. The default is yes.

Step 8  Click Save.

Configuring a Legacy Syslog Template

Follow these steps to add a legacy syslog configuration template or make modifications to an existing template.

Note  Legacy Syslog applies to controllers earlier than version 5.0.6.0

Step 1  Choose Configure > Controller Templates.

Step 2  From the left sidebar menu, choose Management > Legacy Syslog.

Step 3  To add a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click to select a template in the Template Name column. The Legacy Syslog Configuration Template window appears (see Figure 10-52), and the number of controllers the template is applied to automatically populates.
Adding Controller Templates

Chapter 10 Using Templates

Figure 10-52 Syslog Configuration Template

Configuring a Multiple Syslog Template

Follow these steps to add a multiple syslog configuration template or make modifications to an existing template.

Note You can enter up to three syslog server templates.

Step 1 Choose Configure > Controller Templates.

Step 2 From the left sidebar menu, choose Management > Multiple Syslog.

Step 3 To add a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click to select a template in the Template Name column. The Multiple Syslog Configuration Template window appears (see Figure 10-52), and the number of controllers the template is applied to automatically populates.
Chapter 10  Using Templates

Adding Controller Templates

**Figure 10-53  Syslog Server Template Window**

Step 4  Enter a template name and a syslog server IP address.

Step 5  Click Save.

---

**Configuring a Local Management User Template**

Follow these steps to add a local management user template or make modifications to an existing template.

**Step 1**  Choose **Configure > Controller Templates**.

**Step 2**  From the left sidebar menu, choose **Management > Local Management Users**.

**Step 3**  To add a new template, choose **Add Template** from the Select a command drop-down menu and click **GO**. To make modifications to an existing template, click to select a username in the User Name column. The Local Management Users Template appears (see **Figure 10-54**).
Adding Controller Templates

Chapter 10      Using Templates

Figure 10-54   Local Management Users Template

Step 4 Enter a template username.
Step 5 Enter a password for this local management user template.
Step 6 Re-enter the password.
Step 7 Use the Access Level drop-down menu to choose either Read Only or Read Write.
Step 8 Click Save.

Configuring a User Authentication Priority Template

Management user authentication priority templates control the order in which authentication servers are used to authenticate a controller’s management users. Follow these steps to add a user authentication priority template or make modifications to an existing template.

Step 1 Choose Configure > Controller Templates.
Step 2 From the left sidebar menu, choose Management > Authentication Priority.
Step 3 To add a new template, choose Add Template from the Select a command drop-down menu and click GO. To make modifications to an existing template, click to select a username in the Template Name column. The Local Management Users Template appears (Figure 10-55).
### Applying Controller Templates

You can apply a controller template to a controller.

**Step 1** Go to Configure > Controller Templates.

**Step 2** Using the left sidebar menu, choose the category of templates to apply.

**Step 3** Click the URL from the Template Name column that you want to apply to the controller.

**Step 4** Click the Apply to Controllers button.

### Adding Access Point Templates

This page allows you to add a new access point template.

**Step 1** Choose Configure > Access Point Templates.

**Step 2** Choose Add Template from the Select a command drop-down menu and click GO.

**Step 3** Enter the template name.

**Step 4** Provide a description of the template.

**Step 5** Click Save.
Configuring Access Point Templates

This page allows you to configure a template of access point information that you can apply to one or more access points.

**Step 1** Choose Configure > Access Point Templates.

**Step 2** From the Template Name column, click on the template name you want to configure.

**Step 3** Choose the AP Parameters tab. The AP/Radio Templates window appears (see Figure 10-56).

**Figure 10-56 AP/Radio Templates**

**Step 4** Click the Location check box and enter the access point location.

**Step 5** Click both the Admin Status and Enabled check box to enable access point administrative status.

**Step 6** Click the AP Mode check box and use the drop-down menu to set the operational mode of the access point as follows:

- Local - Default
- Monitor - Monitor mode only
- REAP - Cisco 1030 remote edge lightweight access point (REAP) used for Cisco 1030 IEEE 802.11a/b/g/n remote edge lightweight access points.
- Rogue Detected - Monitors the rogue access points but does not transmit or contain rogue access points.
• Sniffer - The access point “sniffs” the air on a given channel. It captures and forwards all the packets from the client on that channel to a remote machine that runs airopeek (a packet analyzer for IEEE 802.11 wireless LANs). It includes information on timestamp, signal strength, packet size, and so on. If you choose Sniffer as an operation mode, you are required to enter a channel and server IP address on the AP/Radio Templates 802.11b/g/n or 802.11a/n parameters tab.

**Note**  The sniffer feature can be enabled only if you are running Airopeek, which is a third-party network analyzer software that supports decoding of data packets. For more information on Airopeek, see www.wildpackets.com/products/airopeek/overview.

**Step 7** Enter the access point height in feet. The height defaults to the floor height. The height must be greater than 3 feet and must not exceed the floor height. The specified height is applied to all selected access points in the template.

**Note**  To change the height for a specific access point, go to Monitor > Maps > Floor > Position Access Points.

**Step 8** You must click both the **Mirror Mode** and **Enabled** check box to enable access point mirroring mode.

**Step 9** Click the check box to enable the country code drop-down menu. A list of country codes is returned. For this access point, choose which country code selection to allow. Access points are designed for use in many countries with varying regulatory requirements. You can configure a country code to ensure that it complies with your country’s regulations.

**Note**  Access points may not operate properly if they are not designed for use in your country of operation. For example, an access point with part number AIR-AP1030-A-K9 (which is included in the Americas regulatory domain) cannot be used in Australia. Always be sure to purchase access points that match your country’s regulatory domain. For a complete list of country codes supported per product, refer to http://www.cisco.com/warp/public/779/smbiz/wireless/approvals.html.

**Step 10** Click to enable **Stats Collection Interval** and then enter the collection period (in seconds) for access point statistics.

**Step 11** Choose the bridging option if you want the access point to act as a bridging access point. This feature applies only to Mesh access points.

**Step 12** Use the Data Rate drop-down menu to choose a data rate of 6, 9, 12, 18, 24, 36, 48, or 54 Mbps.

**Step 13** Use the Ethernet Bridging drop-down menu to choose to enabled or disabled.

**Step 14** Click the **Cisco Discovery Protocol check box** and click **Enabled** to allow CDP on a single access point or all access points. CDP is a device discovery protocol that runs on all Cisco manufactured equipment (such as routers, bridges, communication servers, and so on).

**Step 15** Click the **Controllers** check box, and then you are required to enter the Primary, Secondary, and Tertiary Controller names.

**Step 16** Click the **Group VLAN Name** check box and then use the drop-down menu to select an established Group VLAN name.

**Step 17** Enable local switching by checking the **H-REAP Configuration** check box. When you enable local switching, any remote access point that advertises this WLAN is able to locally switch data packets (instead of tunneling to the controller).
Configuring Access Point Templates

Step 18 Check the VLAN Support check box to enable it and enter the number of the native VLAN on the remote network (such as 100) in the Native VLAN ID field. This value cannot be zero.

Note: By default, a VLAN is not enabled on the hybrid-REAP access point. Once hybrid REAP is enabled, the access point inherits the VLAN name (interface name) and the VLAN ID associated to the WLAN. This configuration is saved in the access point and received after the successful join response. By default, the native VLAN is 1. One native VLAN must be configured per hybrid-REAP access point in a VLAN-enabled domain. Otherwise, the access point cannot send and receive packets to and from the controller. When the client is assigned a VLAN from the RADIUS server, that VLAN is associated to the locally switched WLAN.

Step 19 The SSID-VLAN Mappings section lists all the SSIDs of the controllers which are currently enabled for HREAP local switching. You can edit the number of VLANs from which the clients will get an IP address by clicking the check box and adjusting the value.

Step 20 On the System > AP Username Password window, you can set global credentials for all access points to inherit as they join a controller. These established credentials are displayed in the lower right of the AP Parameters tab window. If you want to override the global credentials for this particular access point, click the Override Global Username Password check box. You can then enter a unique username, password, and enable password that you want to assign to this access point.

Step 21 Save the template.

Step 22 If the updates require a reboot to be reflected, click to check the Reboot AP check box.

Step 23 Choose the Select APs tab. Use the drop-down menu to apply the parameters by controller, floor area, outdoor area, or all. Click Apply.

Note: When you apply the template to the access point, WCS checks to see if the access point supports REAP mode and displays the application status accordingly. Clicking Apply saves and applies the template parameters to the selected access points. After applying a report, it appears in the Apply Report tab.

Configuring Radio Templates

This page allows you to configure a template of radio information that you can apply to one or more access points.

Step 1 Choose Configure > Access Point Templates.

Step 2 From the Template Name column, click on the template name you want to configure.

Step 3 Choose the 802.11a/n Parameters or 802.11b/g/n Parameter tab. The AP/Radio Templates window appears (see Figure 10-57).
Step 4 Click the Channel Assignment checkbox to enable it. To choose a specific channel, click Custom and use the drop-down to designate the channel. Otherwise, click Global.

**Note** The channel assignment is validated against the radio’s list of supported channels.

Step 5 Click both the Admin Status and Enabled check box to enable access point administrative status.

Step 6 Use the Antenna Mode drop-down menu to choose the antenna model. The choices are omni, sector A, and sector B.

**Note** Not all antenna models are supported by radios of different access point types.

Step 7 For external antennas, choose one of the following:

- **Enabled**—Use this setting to enable diversity on both the left and right connectors of the access point.
- **Left/Side B**—Use this setting if your access point has removable antennas and you install a high-gain antenna on the access point’s left connector.
- **Right/Side A**—Use this setting if your access point has removable antennas and you install a high-gain antenna on the access point’s right connector.

For internal antennas, choose one of the following:

- **Enabled**—Use this setting to enable diversity on both Side A and Side B.
- **Left/Side B**—Use this setting to enable diversity on Side B (rear antenna) only.
- **Right/Side A**—Use this setting to enable diversity on Side A (front antenna) only.
Configuring Access Point Templates

Chapter 10      Using Templates

Step 8 Click to enable Antenna Type and use the drop-down menu to specify if the antenna is external or internal.

Step 9 Use the Antenna Name drop-down menu to determine whether the antenna is a Kodiak directional, AIR-ANT1000, CUSH-S5157WP, etc.

Step 10 Check the Power Assignment check box and choose the power level currently being used to transmit data. (Some PHYs also use this value to determine the receiver sensitivity requirements.) If you choose Global, the power level is assigned by dynamic algorithm. If you choose Custom, you can select a value using the drop-down menu. Power level 1 is the maximum.

Step 11 Enable or disable WLAN override for this access point. When you enable WLAN override, the operating system displays a table showing all current Cisco WLAN Solution WLANs. In the table, choose WLANs to enable WLAN operation and deselect WLANs to disallow WLAN operation for this access point 802.11b/g Cisco Radio.

Note The access point must be reset for the WLAN override change to take effect.

Selecting Access Points

After you have completed the radio template configuration, you must pick the access point to which these attributes are applied. Follow these steps to select access points.

Step 1 Click the Select APs tab.

Step 2 Use one of the search criterias to choose the access points and click Search. For example, you can search for access points that this template was last applied to or search by controller name, by floor area, etc. The search criterias change based on the selection you choose.

The AP name, ethernet MAC, controller and map information appears.

Step 3 Click the checkbox in the AP Name column and select to which access points you want the access point and radio parameters applied. You can also click the Select All or Unselect All options.

Step 4 Click Save to save the parameter selection or click Apply to save and apply the access point and radio parameters to the selected access points.

Applying the Report

After access points are selected and applied, click the Apply Report tab.
Performing Maintenance Operations

This chapter provides routine procedures for maintaining WCS. It contains these sections:

- Checking the Status of WCS, page 11-2
- Stopping WCS, page 11-3
- Backing Up the WCS Database, page 11-4
- Restoring the WCS Database, page 11-6
- Importing and Exporting Asset Information, page 11-10
- Auto-Synchronizing Location Appliances, page 11-11
- Backing Up Location Appliance Data, page 11-12
- Importing and Exporting Asset Information, page 11-10
- Upgrading WCS, page 11-15
- Reinitializing the Database, page 11-21
- Recovering the WCS Password, page 11-21
Checking the Status of WCS

This section provides instructions for checking the status of WCS on either a Windows or Linux server.

Checking the Status of WCS on Windows

Follow these steps to check the status of WCS when it is installed as a Windows application or Windows service. You can check the status at any time.

**Step 1** Log into the system as administrator.

**Step 2** Perform one of the following:

- From the Windows Start menu, click Programs > Wireless Control System > WCSStatus.
- From the command prompt, navigate to the WCS installation directory (such as C:\Program Files\WCS4.2.47.0) and enter WCSAdmin status.

The WCSAdmin window appears and displays messages indicating the status of WCS.

**Step 3** Close the WCSAdmin window when the Close button becomes active.

Checking the Status of WCS on Linux

Follow these steps to check the status of WCS when it is installed as a Linux application or Linux service. You can check the status at any time.

**Step 1** Log into the system as root.

**Step 2** Using the Linux CLI, perform one of the following:

- Navigate to the installation directory (such as /opt/WCS4.2.47.0) and enter ./WCSSStatus.
- Navigate to the installation directory (such as /opt/WCS4.2.47.0) and enter WCSAdmin status.

The CLI displays messages indicating the status of WCS.
Stopping WCS

This section provides instructions for stopping WCS on either a Windows or Linux server.

Stopping WCS on Windows

Follow these steps to stop WCS when it is installed as a Windows application or Windows service. You can stop WCS at any time.

Note
If any users are logged in when you stop WCS, their WCS sessions stop functioning.

Step 1
Log into the system as administrator.

Step 2
Perform one of the following:

- From the Windows Start menu, click Programs > Wireless Control System > StopWCS.
- From the command prompt, navigate to the WCS installation directory (such as C:\Program Files\WCS4.2.47.0\bin) and enter WCSAdmin stop.

The WCSAdmin window appears and displays messages indicating that WCS is stopping.

Note
If WCS is installed as a service, messages also appear to indicate that the Nms_Server service is stopping.

Step 3
Close the WCSAdmin window when the Close button becomes active.

Stopping WCS on Linux

Follow these steps to stop WCS when it is installed as a Linux application or Linux service. You can stop WCS at any time.

Note
If any users are logged in when you stop WCS, their WCS sessions stop functioning.

Step 1
Log into the system as root.

Note
To see which version of WCS you currently have installed, enter nmsadmin.sh version.

Step 2
Using the Linux CLI, perform one of the following:

- Navigate to the /opt/WCS4.2.47.0 directory (or the directory chosen during installation) and enter ./StopWCS.
- Navigate to the /opt/WCS4.2.47.0/bin directory and enter WCSAdmin stop.
Backing Up the WCS Database

This section provides instructions for backing up the WCS database. You can schedule regular backups through the WCS user interface or manually initiate a backup on either a Windows or Linux server.

Scheduling Automatic Backups

Follow these steps to schedule automatic backups of the WCS database.

**Step 1** Log into the WCS user interface.

**Step 2** Click Administration > Scheduled Tasks to display the Scheduled Tasks page.

**Step 3** Click WCS Server Backup to display the Task > WCS Server Backup page.

**Step 4** Check the Admin Status: Enabled check box.

**Step 5** In the Max Backups to Keep field, enter the maximum number of backup files to save on the server.

- **Range:** 7 to 50
- **Default:** 7

**Note** To prevent the WCS platform from running out of disk space, the server automatically deletes old backup files when the number of files exceeds the value entered for this field.

**Step 6** In the Interval (Days) field, enter a number representing the number of days between each backup. For example, 1 = a daily backup, 2 = a backup every other day, 7 = a weekly backup, and so on.

- **Range:** 1 to 360
- **Default:** 7

**Step 7** In the Time of Day field, enter the time when you want the backup to start. It must be in this format: hh:mm AM/PM (for example: 03:00 AM).

**Note** Backing up a large database affects the performance of the WCS server. Therefore, Cisco recommends that you schedule backups to run when the WCS server is idle (for example, in the middle of the night).

**Step 8** Click Submit to save your settings. The backup file is saved as a .zip file in the ftp-install-dir/ftp-server/root/WCSBackup directory using this format: dd-mmm-yy_hh-mm-ss.zip (for example, 11-Nov-05_10-30-00.zip).

The CLI displays messages indicating that WCS is stopping.
Performing a Manual Backup

This section provides instructions for backing up the WCS database on either a Windows or Linux server.

Backing Up the WCS Database (for Windows)

Follow these steps to back up the WCS database on a Windows server.

Step 1  Log into the system as administrator.
Step 2  Create a backup directory for the WCS database with no spaces in the name, such as C:\WCS4.2.47.0_Backup.

Note  Make sure that the directory name does not contain spaces. Spaces can generate errors.

Step 3  Perform one of the following:
   • Follow these steps from the Windows Start menu:
     a. Click Programs > Wireless Control System > Backup. The Enter Information window appears.
     b. Browse to the backup directory that you created and choose the filename or enter the full path of the backup directory that you created and a name for the backup file (such as C:\WCS4.2.47.0_Backup\Nov11) and click OK.
   • Follow these steps from the command prompt:
     a. Navigate to the WCS installation directory (C:\Program Files\WCS4.2.47.0\bin).
     b. Enter DBAdmin backup backup-filename, where backup-filename is the full path of the backup directory that you created plus a name for the backup file (such as C:\WCS4.2.47.0_Backup\Nov11).

The DBAdmin window appears and displays messages indicating the status of the backup.

Step 4  Close the DBAdmin window when the Close button becomes active.

Note  In the example above, the backup file would appear in the C:\WCS4.2.47.0_Backup directory as Nov11.nmsbackup.

Backing Up the WCS Database (for Linux)

Follow these steps to back up the WCS database on a Linux server.

Step 1  Log into the system as root.
Step 2  Using the Linux CLI, navigate to the /opt/WCS4.2 directory (or any other directory).
Step 3  Create a backup directory for the WCS database with no spaces in the name (for example, mkdir WCS4.2.47.0_Backup).
Note: Make sure that the directory name does not contain spaces. Spaces can generate errors.

Step 4 Perform one of the following:

- Navigate to the /opt/WCS4.2.47.0 directory (or the directory chosen during installation) and enter ./Backup. Enter a name for the backup file when prompted (such as WCS4.2.47.0_Backup/Nov11).

- Navigate to the /opt/WCS4.2.47.0/bin directory (or the directory chosen during installation) and enter DBAdmin backup backup-filename, where backup-filename is the full path of the backup directory that you created plus a name for the backup file (such as WCS4.2.47.0_Backup/Nov11).

- Using KDE or X-Windows, enter DBAdmin - gui backup, browse to the backup directory, and choose the file.

The CLI displays messages indicating the status of the backup.

Note: In the example above, the backup file would appear in the WCS4.2.47.0_Backup directory as Nov11.nmsbackup.

---

Restoring the WCS Database

This section provides instructions for restoring the WCS database on either a Windows or Linux server.

Restoring the WCS Database (for Windows)

Follow these steps to restore the WCS database from a backup file on a Windows server.

Step 1 Log into the system as administrator.

Step 2 Perform one of the following:

- Follow these steps from the Windows Start menu:
  a. Click Start > Programs > Wireless Control System> Restore. The DBAdmin and Enter Information window appears.
  b. Browse to the backup directory that you created and choose the filename or enter the full path and filename of the backup file (such as C:\WCS4.2.47.0_Backup\Nov11.nmsbackup) and click OK.
- Follow these steps from the command prompt:
  a. Navigate to the WCS installation directory (C:\Program Files\WCS4.2.47.0\bin).
  b. Enter DBAdmin restore backup-filename, where backup-filename is the full path and filename of the backup file (for example, C:\WCS4.2.47.0_Backup\Nov11.nmsbackup).

Note: If you are restoring data larger than 8-GB unzipped from a WCS version prior to 4.1, you must instead enter dbadmin.bat -gui -largedb restore.
Chapter 11  Performing Maintenance Operations

Restoring the WCS Database

Step 3  Click Yes if a message appears indicating that WCS is running and needs to be shut down.

Step 4  The DBAdmin window appears and displays messages indicating that WCS is shutting down (if applicable) and the WCS database is being restored. Close the DBAdmin window when the Close button becomes active.

Note  If the restore process shuts down WCS, a restart is attempted after a successful restore.

Restoring the WCS Database (for Linux)

Follow these steps to restore the WCS database from a backup file on a Linux server.

Step 1  If possible, stop all WCS user interfaces to stabilize the database.

Step 2  Log into the system as root.

Step 3  Using the Linux CLI, perform one of the following:

- Navigate to the /opt/WCS4.2.47.0 directory (or the directory chosen during installation) and enter ./Restore to start the restoration process. Enter the backup filename when prompted (such as WCS4.2.47.0_Backup/Nov11.nmsbackup).

- Navigate to the /opt/WCS4.2.47.0/bin directory (or the directory chosen during installation) and enter DBAdmin restore backup-filename, where backup-filename is the full path and filename of the backup file (such as WCS4.2.47.0_Backup/Nov11.nmsbackup).

Note  If you are restoring from a WCS version prior to 3.2, you must enter a directory rather than a backup file because tar/gzip did not exist prior to 3.2. Enter DBAdmin restore directory, where directory is the backup directory that you created.

Step 4  Click Yes if a message appears indicating that WCS is running and needs to be shut down.

Step 5  The DBAdmin window appears and displays messages indicating that WCS is shutting down (if applicable) and the WCS database is being restored. Close the DBAdmin window when the Close button becomes active.

Note  If the restore process shuts down WCS, a restart is attempted after a successful restore.
The CLI displays messages indicating that the WCS database is being restored.

## Importing the Location Appliance into WCS

Cisco 2700 series location appliances operate within the Cisco Wireless LAN Solution infrastructure. Location appliances compute, collect, and store historical location data using Cisco wireless LAN controllers and access points to track the physical location of wireless devices.

Up to 2,500 laptop clients, palmtop clients, VoIP telephone clients, active Radio Frequency Identifier (RFID) asset tags, rogue access points, and clients can be tracked.

### Note

Even though all clients are loaded in the map, the display has a limit of 250 clients per floor to prevent overcrowding. You can do an advanced search of the map to see the items of interest.

To import a location appliance into WCS, follow the steps below.

**Step 1** Navigate to Location > Location Servers. Choose Add Server from the drop-down menu and click GO.

**Step 2** Enter any name for the appliance, its IP address, and a contact name on the Import window (see Figure 11-1). Keep the username, password, port, and HTTPS fields unaltered and click Save.

### Figure 11-1 General Properties

[Figure showing the General Properties window]
Step 3 After you import the new location appliance, a pop-up window reminds you that WCS contains data that needs to be transported to the location appliance. Those controllers and network diagrams that are available to be synchronized are listed. From the Select a command drop-down menu, choose **Synchronize Servers**.

The Synchronize WCS and Location Servers window appears (see **Figure 11-2**).

**Note** Existing network diagrams, controllers, and event groups must be synchronized with the appropriate location appliance to provide accurate location information. Synchronization is generally recommended after any network design change. You can limit areas that the location appliance tracks by synchronizing only areas that you want to actively track. Limiting synchronization to specific areas provides optimal performance of the location appliance.

**Figure 11-2**  **Synchronizing WCS and Location Servers**

- **Step 4** Select the **Network Designs** option from the Synchronize drop-down menu. Click the **Assign** hyperlink (far-right) of the appropriate network.

- **Step 5** In the **Assign to Servers** pop up window that appears, check the box next to the appropriate server (location appliance). Click **OK**.

- **Step 6** Click the check box next to the new location appliance and click **OK**.

- **Step 7** Click **Synchronize**.

- **Step 8** If the network diagram is properly synchronized, two green arrows appear under the Sync. Status column for each diagram. After synchronizing with the network diagram, all floor maps and access point placements associated with that diagram are copied to the location appliance; therefore, when the location appliance is set to synchronize with the diagram’s controllers, it can find them.

- **Step 9** To set up controller synchronization, choose **Controllers** from the Synchronize drop-down menu.

- **Step 10** Each controller managed by WCS appears in a drop-down menu. Assign each controller to a specific location appliance by choosing the name of the location appliance with which the controllers will synchronize and click **Synchronize**.

- **Step 11** After the location appliance is properly synchronized with controllers, green arrows appear next to each controller under the Sync. Status column.
After synchronizing network designs and controllers, ensure that the location appliance polling parameters (Location Server > Administration > Polling Parameters) are enabled so that the location of the elements gets calculated.

After all relevant network designs and controllers are assigned to a new location appliance and initial synchronization is complete, you can configure the location appliance to automatically synchronize with WCS. For more details, see the “Importing and Exporting Asset Information” section on page 11-10.

Importing and Exporting Asset Information

This section describes how to import and export asset information stored in a flat text file to minimize manual entry.

Importing Asset Information

To import asset information for the location server using Cisco WCS, follow these steps:

1. In Cisco WCS, choose Location > Location Servers. The All Location Servers summary window appears.
2. Click the name of the server for which you want to import asset information.
3. Click Administration (left) to display the administrative configuration options.
4. Click Import Asset Information.
5. Enter the name of the text file or browse for the file name. Information stored in the imported file should be in the following format:
   - tag format: #tag, 00:00:00:00:00:00, categoryname, groupname, assetname
   - station format: #station, 00:00:00:00:00:00, categoryname, groupname, assetname
6. Click Import.

Exporting Asset Information

To export asset information from the location server to a file using Cisco WCS, follow these steps:

1. In Cisco WCS, choose Location > Location Servers. The All Location Servers summary window appears.
2. Click the name of the server from which you want export asset information.
Step 3  Click **Administration** (left) to display the administrative configuration options.

Step 4  Click **Export Asset Information**.

Step 5  Click **Export**.

You are prompted to **Open** (display to screen) or **Save** (to external PC or server) the asset file or to **Cancel** the request.

**Note** If you select **Save**, you are asked to select the asset file destination and name. The file is named “assets.out” by default. Click **Close** from the dialog box when download is complete.

---

**Auto-Synchronizing Location Appliances**

After all relevant network designs and controllers are assigned to a new location appliance and initial synchronization is complete, you can configure the location appliance to automatically synchronize with WCS by enabling the **Location Server Auto-Synchronization** feature.

Enabling auto-synchronization ensures that all future map modifications such as adding access points, changing access point positions or orientations, and any resizings are accurately reflected in the map in case a manual synchronization (Location > Synchronize Servers) is not performed after element changes. You can configure the frequency (minimum of 24 hours) and time of day that the automatic synchronization occurs.

**Step 1** Choose **Administration > Background Tasks**.

The Background Tasks summary window appears (see Figure 11-3).

**Figure 11-3  Administration > Background Tasks**
Step 2  Select the **Location Server Synchronization** link.

Step 3  In the window that appears (Figure 11-4), check the **Enabled** box next to the **Auto Synchronization** option.

![Figure 11-4 Location Server Synchronization Page](image)

**Step 4**  Enter the frequency of the automatic synchronization in the **Interval (days)** field.
The value entered represents number of days. One day is the minimum value.

**Step 5**  Enter the Time of Day (hh:mm AM | PM) for the synchronization to occur.

**Step 6**  Click **Submit**.
You are returned to the Scheduled Tasks Summary window.

**Note**  To disable the Auto-Synchronization, uncheck the **Enabled** box for that feature.

**Note**  You may also want to enable the **Out of Sync Alerts** option if it is not already active. When enabled, this option generates alerts for the location appliance when elements such as network designs or controllers are not assigned to a location appliance. Modifications to elements without subsequent synchronization generate location appliance alerts as well.

## Backing Up Location Appliance Data

You can configure the Cisco WCS to regularly back up the data stored on the location appliance. You can specify the frequency and the time-of-day of the backups and the number of previous backups you want to save.
Back-up data is saved on the FTP server specified during WCS installation.

To back up the data stored on a location appliance, follow the steps below.

**Step 1** Choose **Administration > Background Tasks**.

The window shown in **Figure 11-5** appears.

**Figure 11-5  Administration > Background Tasks**

![Figure 11-5](image)

**Step 2** Check the box next to the **Location Server Backup** link and then select the link. The Location Server Backup configuration window appears (see **Figure 11-6**).
Uninstalling WCS

This section provides instructions for uninstalling WCS on either a Windows or Linux server. You can uninstall WCS at any time, even while WCS is running.

Uninstalling WCS on Windows

Follow these steps to uninstall WCS on a Windows server.

Step 1 Log into the system as administrator.

Step 2 From the Windows Start menu, click Programs > Wireless Control System > Uninstall WCS.

Step 3 When the Uninstall Wireless Control System window appears, click Uninstall.

Step 4 Follow the instructions on the window to continue the uninstall process.

Step 5 When the WCS Uninstaller window indicates that the program is uninstalled, click Finish to close the window.
Note: If any part of the C:\Program Files\WCS4.2.27.0 folder remains on the hard drive, manually delete the folder and all of its contents. If you fail to delete the previous WCS installation, this error message appears when you attempt to reinstall WCS: “Cisco WCS already installed. Please uninstall the older version before installing this version.”

### Uninstalling WCS on Linux

Follow these steps to uninstall WCS on a Linux server.

**Step 1** Stop WCS.

**Step 2** Log into the system as root through an X terminal session.

**Step 3** Using the Linux CLI, navigate to the /opt/WCS4.2.47.0 directory (or the directory chosen during installation).

**Step 4** Enter ./UninstallWCS.

**Step 5** Click Yes to continue the uninstall process.

**Step 6** Click Finish when the uninstall process is complete.

Note: If any part of the /opt/WCS4.2.47.0 directory remains on the hard drive, manually delete the directory and all of its contents. If you fail to delete the previous WCS installation, this error message appears when you attempt to reinstall WCS: “Cisco WCS already installed. Please uninstall the older version before installing this version.”

### Upgrading WCS

This section provides instructions for upgrading WCS on either a Windows or Linux server. An automated upgrade is available in software release 4.2 and later. It handles the steps you would normally follow to accomplish an upgrade (shut down WCS, perform a backup, install new version, restore the backup, remove the old WCS version, and start WCS). If you choose to use the installer, it searches for any previous WCS versions.

**Note**: You must have software release 4.1.91.0 before you can automatically upgrade to 4.2.

If you choose to use the easy upgrade process, it provides error checking at each step and gives an informative message if an error causing an exit occurs. An upgrade-version.log is also produced and provides corrective measures.
Chapter 11 Performing Maintenance Operations

Using the Installer to Upgrade WCS for Windows

Follow these steps to upgrade WCS (on a Windows platform) using the automated upgrade:

**Step 1** Insert the Windows Cisco WCS CD into the CD-ROM drive and double click the WCS-STANDARD-K9-4.2.X.Y.exe file where 4.2.X.Y is the software build. If you downloaded the installer from Cisco.com, double click the WCS-STANDARD-WB-K9-4-2-X-Y.exe file that you downloaded to your local drive.

**Step 2** The Install Anywhere window appears and prepares the system for installation. After a few seconds, the Introduction window appears, followed by the license agreement window. You must click the “I accept the terms of the License Agreement” option to continue.

**Step 3** At this point, the install wizard detects whether a previous version of WCS is installed and specifies whether the current version is eligible for an automated upgrade. If your most recent WCS version cannot participate in the automated upgrade, you receive a notification as shown in Figure 11-7. If your WCS version is eligible for an automated upgrade, you receive a notification as shown in Figure 11-8.
Figure 11-7  Ineligible for Automated Upgrade

![Image of the Install/Upgrade dialog box showing an error message about an ineligible version for automated upgrade.]

The installed version does not support automated upgrade.

Automated upgrade support begins in 4.1.61.0. Manual upgrade will have to be used; see documentation for details. Installing multiple versions is not recommended.

Would you like to install this version along with the one already installed (not recommended)?

Options: Install, Exit.
Step 4 If you see a window similar to the one in Figure 11-7 and choose Install because you cannot perform the automated upgrade, continue to the “Manually Upgrading WCS on Windows” section on page 11-20. If you see a window similar to the one in Figure 11-8 and choose Install, continue to the “Manually Upgrading WCS on Windows” section on page 11-20. If you see a window similar to the one in Figure 11-8 because a previous qualifying version of WCS is detected, choose Upgrade and continue to Step 5. This method is preferred.

Step 5 Several of the values from the previous install are retained and carried over as part of the upgrade. These include the following:

- the ports
- the root password
- the root FTP password
- the TFTP server file location
- the FTP server file location
- the multi-homed server interfaces

Step 6 Choose a folder in which to install the Cisco WCS at the Choose Install Folder window. It must be a different location than the previous install. Click Next to continue.

Step 7 Choose a folder location to store the shortcuts. It must be a different location than the previous install.

Step 8 Continue to follow the prompts that appear. You are notified of checking for required space, uninstalling of previous versions, backing up files, restoring, and so on. You then see a prompt asking if you are now ready to start WCS as a service. Click Yes.
Using the Installer to Upgrade WCS for Linux

Follow these steps to upgrade WCS (on a Linux platform) using the automated upgrade:

**Step 1** Using the command line, perform one of the following:

a. If you are installing from a CD, switch to the /media/cdrom directory.

b. If you are installing from Cisco.com, switch to the directory in which the install file was downloaded. For example, if the install file was placed in /root/Desktop, enter `cd /root/Desktop`.

**Step 2** Enter `/WCS-STANDARD-K9-4.2.X.Y.bin` (for CD users) or `/WCS-STANDARD-LB-K9-4-2-X-Y.bin` (for Cisco.com users) to start the install script.

**Step 3** The Install Anywhere message appears and prepares the system for installation. After a few seconds, the Introduction appears, followed by the license agreement statement. You must accept the license agreement to continue.

**Step 4** At this point, the install wizard detects whether a previous version of WCS is installed and specifies whether the current version is eligible for an automated upgrade. You receive a notification whether or not your most recent WCS version is eligible for the automated upgrade.

**Step 5** If you cannot continue to the automated upgrade because your current WCS version is not eligible, choose Install and continue to the “Manually Upgrading WCS on Linux” section on page 11-20. If you choose to do a manual upgrade rather than the recommended automated upgrade, choose Install and continue to the “Manually Upgrading WCS on Linux” section on page 11-20. If your current WCS version is eligible for the recommended automated upgrade, choose Upgrade and continue to Step 6.

**Step 6** Several of the values from the previous install are retained and carried over as part of the upgrade. These include the following:

- the ports
- the root password
- the root FTP password
- the TFTP server file location
- the FTP server file location
- the multi-homed server interfaces

**Step 7** Choose a folder in which to install the Cisco WCS. It must be a different location than the previous install. Click Next to continue.

**Step 8** Choose a folder location to store the shortcuts. It must be a different location than the previous install.

**Step 9** Continue to follow the prompts that appear. You are notified of checking for required space, uninstalling of previous versions, backing up files, restoring, and so on. You then see a prompt asking if you are now ready to start WCS as a service. Click Yes.
Chapter 11    Performing Maintenance Operations

**Upgrading WCS**

**Note**  The upgrade log is located in the standard log directory (\webnms\logs) if the automated upgrade completes. For an incomplete automated upgrade, the upgrade log is located in the user home directory.

---

### Manually Upgrading WCS on Windows

Follow these steps to manually upgrade WCS on a Windows server. This type of upgrade is not recommended.

**Note**  When upgrading from software release 4.096.0 to 4.1.82.0, only one “from” e-mail address is restored for the alarm e-mail filters. If you have multiple “from” e-mail addresses defined in the alarm e-mail filters, they are lost. The single “from” e-mail address is configured in Administration > Settings > Mail Server (refer to the “Mail Server” section on page 15-27).

**Step 1**  If possible, stop all WCS user interfaces to stabilize the database.

**Step 2**  Back up the WCS database by following the instructions in the “Backing Up the WCS Database (for Windows)” section on page 11-5.

**Step 3**  Uninstall the WCS application by following the instructions in the “Uninstalling WCS on Windows” section on page 11-14.

**Step 4**  Install the new version of WCS by following the instructions in the “Installing WCS for Windows” section on page 2-4.

**Step 5**  Restore the WCS database by following the instructions in the “Restoring the WCS Database (for Windows)” section on page 11-6.

---

### Manually Upgrading WCS on Linux

Follow these steps to upgrade WCS on a Linux server. This type of upgrade is not recommended.

**Step 1**  If possible, stop all WCS user interfaces to stabilize the database.

**Step 2**  Back up the WCS database by following the instructions in the “Backing Up the WCS Database (for Linux)” section on page 11-5.

**Step 3**  Uninstall the WCS application by following the instructions in the “Uninstalling WCS on Linux” section on page 11-15.

**Step 4**  Install the new version of WCS by following the instructions in the “Installing WCS for Linux” section on page 2-11.

**Step 5**  Restore the WCS database by following the instructions in the “Restoring the WCS Database (for Linux)” section on page 11-7.
Upgrading the Network

Network upgrades must follow a recommended procedure so that databases can remain synchronized with each other. You cannot for instance upgrade the controller portion of the network to a newer release but maintain the current WCS version and not upgrade it. The supported order of upgrade is WCS first, followed by the controller, and then any additional devices.

Reinitializing the Database

If you need to reset the database because of a synchronization problem or a corruption of some type, enter `{install directory}/bin/dbadmin.(sh|bat) reinitdb` to reinitialize the database.

Recovering the WCS Password

You can change the WCS application root user or FTP user password. This option provides a safeguard if you lose the root password. An executable was added to the installer /bin directory (passwd.bat for Windows and passwd.sh for Linux). Follow these steps to recover the passwords and regain access to WCS. For password recovery on a wireless location device, refer to chapters 8 or 9 of the Cisco 2700 Series Location Appliance Configuration Guide.

---

**Note**

If you are a Linux user, you must be the root user to run the command.

**Step 1**
Change to the WCS bin folder.

**Step 2**
Perform one of the following:

Enter `passwd root-user <newpassword>` to change the WCS root password. The `newpassword` is the root login password you choose.

or

Enter `passwd location-ftp-user <newuser> <newpassword>` to change the FTP user and password. The `newuser` and `newpassword` are the FTP user and password you choose.

**Step 3**
The following options are available with these commands:

- `-q` — to quiet the output
- `-pause` — to pause before exiting
- `-gui` — to switch to the graphical user interface
- `-force` — to skip prompting for configuration

**Step 4**
Start WCS.
Configuring Hybrid REAP

This chapter describes hybrid REAP and explains how to configure this feature on controllers and access points. It contains these sections:

- Overview of Hybrid REAP, page 12-2
- Configuring Hybrid REAP, page 12-4
- Hybrid REAP Access Point Groups, page 12-12
Overview of Hybrid REAP

Hybrid REAP is a solution for branch office and remote office deployments. It enables customers to configure and control access points in a branch or remote office from the corporate office through a wide area network (WAN) link without deploying a controller in each office. There is no deployment restriction on the number of hybrid-REAP access points per location. The hybrid-REAP access points can switch client data traffic locally and perform client authentication locally when their connection to the controller is lost. When they are connected to the controller, they can also send traffic back to the controller.

Hybrid REAP is supported only on the 1130AG and 1240AG access points and on the 2000 and 4400 series controllers, the Catalyst 3750G Integrated Wireless LAN Controller Switch, the Cisco WiSM, and the Controller Network Module for Integrated Services Routers, and the controller within the Catalyst 3750G Integrated Wireless LAN Controller Switch. Figure 12-1 illustrates a typical hybrid-REAP deployment.

**Figure 12-1 Hybrid REAP Deployment**

Hybrid-REAP Authentication Process

When a hybrid-REAP access point boots up, it looks for a controller. If it finds one, it joins the controller, downloads the latest software image from the controller and configuration information, and initializes the radio. It saves the downloaded configuration in non-volatile memory for use in standalone mode.

A hybrid-REAP access point can learn the controller IP address in one of these ways:

- If the access point has been assigned an IP address from a DHCP server, it discovers a controller through the regular LWAPP discovery process [Layer 3 broadcast, over-the-air provisioning (OTAP), DNS, or DHCP option 43.]

**Note** OTAP does not work on the first boot out of the box.
- If the access point has been assigned a static IP address, it can discover a controller through any of the LWAPP discovery process methods except DHCP option 43. If the access point cannot discover a controller through Layer 3 broadcast or OTAP, Cisco recommends DNS resolution. With DNS, any access point with a static IP address that knows of a DNS server can find at least one controller.

- If you want the access point to discover a controller from a remote network where LWAPP discovery mechanisms are not available, you can use priming. This method enables you to specify (through the access point CLI) the controller to which the access point is to connect.

When a hybrid-REAP access point can reach the controller (referred to as connected mode), the controller assists in client authentication. When a hybrid-REAP access point cannot access the controller, the access point enters standalone mode and authenticates clients by itself.

**Note**

The LEDs on the access point change as the device enters different hybrid-REAP modes. Refer to the Hardware Installation Guide for your access point for information on LED patterns.

When a client associates to a hybrid-REAP access point, the access point sends all authentication messages to the controller and either switches the client data packets locally (locally switched) or sends them to the controller (centrally switched), depending on the WLAN configuration. With respect to client authentication (open, shared, EAP, web authentication, and NAC) and data packets, the WLAN can be in any one of the following states depending on the configuration and state of controller connectivity:

- **central authentication, central switching**—In this state, the controller handles client authentication, and all client data tunnels back to the controller. This state is valid only in connected mode.

- **central authentication, local switching**—In this state, the controller handles client authentication, and the hybrid-REAP access point switches data packets locally. After the client authenticates successfully, the controller sends a configuration command with a new payload to instruct the hybrid-REAP access point to start switching data packets locally. This message is sent per client. This state is applicable only in connected mode.

- **local authentication, local switching**—In this state, the hybrid-REAP access point handles client authentication and switches client data packets locally. This state is valid only in standalone mode.

- **authentication down, switching down**—In this state, the WLAN disassociates existing clients and stops sending beacon and probe responses. This state is valid only in standalone mode.

- **authentication down, local switching**—In this state, the WLAN rejects any new clients trying to authenticate, but it continues sending beacon and probe responses to keep existing clients alive. This state is valid only in standalone mode.

When a hybrid-REAP access point enters standalone mode, WLANs that are configured for open, shared, WPA-PSK, or WPA2-PSK authentication enter the “local authentication, local switching” state and continue new client authentications. Other WLANs enter either the “authentication down, switching down” state (if the WLAN was configured to central switching) or the “authentication down, local switching” state (if the WLAN was configured to local-switch).

When a hybrid-REAP access point enters standalone mode, it disassociates all clients that are on centrally switched WLANs. For 802.1X or web-authentication WLANs, existing clients are not disassociated, but the hybrid-REAP access point stops sending beacons when the number of associated clients reaches zero (0). It also sends disassociation messages to new clients associating to 802.1X or web-authentication WLANs. Controller-dependent activities such as 802.1X authentication, NAC, and web authentication (guest access) are disabled, and the access point does not send any intrusion detection system (IDS) reports to the controller. Furthermore, most radio resource management (RRM) features
Configuring Hybrid REAP

Chapter 12

Configuring Hybrid REAP

(such as neighbor discovery; noise, interference, load, and coverage measurements; use of the neighbor list; and rogue containment and detection) are disabled. However, a hybrid-REAP access point supports dynamic frequency selection in standalone modes.

**Note**

If your controller is configured for network access control (NAC), clients can associate only when the access point is in connected mode. When NAC is enabled, you need to create an unhealthy (or quarantined) VLAN so that the data traffic of any client that is assigned to this VLAN passes through the controller, even if the WLAN is configured for local switching. After a client is assigned to a quarantined VLAN, all of its data packets are centrally switched.

The hybrid-REAP access point maintains client connectivity even after entering standalone mode. However, once the access point re-establishes a connection with the controller, it disassociates all clients, applies new configuration information from the controller, and reallo ws client connectivity.

**Hybrid REAP Guidelines**

Keep these guidelines in mind when using hybrid REAP:

- A hybrid-REAP access point can be deployed with either a static IP address or a DHCP address. In the case of DHCP, a DHCP server must be available locally and must be able to provide the IP address for the access point at bootup.

- Hybrid REAP supports a 500-byte maximum transmission unit (MTU) WAN link at minimum.

- Roundtrip latency must not exceed 100 milliseconds (ms) between the access point and the controller, and LWAPP control packets must be prioritized over all other traffic.

- The controller can send multicast packets in the form of unicast or multicast packets to the access point. In hybrid-REAP mode, the access point receives multicast packets only in unicast form.

- Hybrid REAP supports CCKM full authentication but not CCKM fast roaming.

- Hybrid REAP supports a 1-1 network address translation (NAT) configuration. It also supports port address translation (PAT) for all features except true multicast. Multicast is supported across NAT boundaries when configured using the Unicast option.

- VPN, IPSec, L2TP, PPTP, Fortress authentication, and Cranite authentication are supported for locally switched traffic, provided that these security types are accessible locally at the access point.

**Configuring Hybrid REAP**

To configure hybrid REAP, you must follow the instructions in these sections in the order provided:

- Configuring the Switch at the Remote Site, page 12-4
- Configuring the Controller for Hybrid REAP, page 12-6
- Configuring an Access Point for Hybrid REAP, page 12-9
- Connecting Client Devices to the WLANs, page 12-11

**Configuring the Switch at the Remote Site**

Follow these steps to prepare the switch at the remote site.
Configuring Hybrid REAP

Chapter 12      Configuring Hybrid REAP

Step 1
Attach the access point that will be enabled for hybrid REAP to a trunk or access port on the switch.

Note: The sample configuration below shows the hybrid-REAP access point connected to a trunk port on the switch.

Step 2
Refer to the sample configuration below to configure the switch to support the hybrid-REAP access point.

In this sample configuration, the hybrid-REAP access point is connected to trunk interface FastEthernet 1/0/2 with native VLAN 100. The access point needs IP connectivity on the native VLAN. The remote site has local servers/resources on VLAN 101. A DHCP pool is created in the local switch for both VLANs in the switch. The first DHCP pool (NATIVE) is used by the hybrid-REAP access point, and the second DHCP pool (LOCAL-SWITCH) is used by the clients when they associate to a WLAN that is locally switched. The bolded text in the sample configuration illustrates these settings.

Note: The addresses in this sample configuration are for illustration purposes only. The addresses that you use must fit into your upstream network.

```
ip dhcp pool NATIVE
    network 10.10.100.0 255.255.255.0
    default-router 10.10.100.1
!
ip dhcp pool LOCAL-SWITCH
    network 10.10.101.0 255.255.255.0
    default-router 10.10.101.1
!
interface FastEthernet1/0/1
    description Uplink port
    no switchport
    ip address 10.10.98.2 255.255.255.0
    spanning-tree portfast
!
interface FastEthernet1/0/2
    description the Access Point port
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 100
    switchport trunk allowed vlan 100,101
    switchport mode trunk
    spanning-tree portfast
!
interface Vlan100
    ip address 10.10.100.1 255.255.255.0
    ip helper-address 10.10.100.1
!
interface Vlan101
    ip address 10.10.101.1 255.255.255.0
    ip helper-address 10.10.101.1
end
```
Configuring the Controller for Hybrid REAP

This section provides instructions for configuring the controller for hybrid REAP. The controller configuration for hybrid REAP consists of creating centrally switched and locally switched WLANs. This procedure uses these three WLANs as examples:

<table>
<thead>
<tr>
<th>WLAN</th>
<th>Security</th>
<th>Switching</th>
<th>Interface Mapping (VLAN)</th>
</tr>
</thead>
<tbody>
<tr>
<td>employee</td>
<td>WPA1+WPA2</td>
<td>Central</td>
<td>management (centrally switched VLAN)</td>
</tr>
<tr>
<td>employee-local</td>
<td>WPA1+WPA2</td>
<td>Local</td>
<td>101 (local switched VLAN)</td>
</tr>
<tr>
<td>guest-central</td>
<td>Web authentication</td>
<td>Central</td>
<td>management (centrally switched VLAN)</td>
</tr>
</tbody>
</table>

**Step 1**

Follow these steps to create a centrally switched WLAN. In our example, this is the first WLAN (employee).

a. Choose **Configure > Controllers**.
b. Click in the IP Address column for a particular controller.
c. Click **WLANs > WLANs** to access the WLAN page.
d. Choose **Add** from the Select a command drop-down menu and click **GO** (see Figure 12-2).

**Note**

Cisco access points can support up to 16 WLANs per controller. However, some Cisco access points do not support WLANs that have a WLAN ID greater than 8. In such cases, when you attempt to create a WLAN, you get a message that says “Not all types of AP support WLAN ID greater than 8, do you wish to continue?”. Clicking OK creates a WLAN with the next available WLAN ID. However, if you delete a WLAN that has a WLAN ID less than 8, then the WLAN ID of the deleted WLAN is applied to the next created WLAN.
e. If you want to apply a template to this controller, choose a template name from the drop-down menu. The parameters populate according to how the template is set. If you want to create a new WLAN template, use the click here link to be redirected to the template creation page (see the “Configuring WLAN Templates” section on page 10-9).

f. Modify the configuration parameters for this WLAN. In our employee WLAN example, you would need to choose WPA1+WPA2 from the Layer 2 Security drop-down box.

g. Be sure to enable this WLAN by checking the Admin Status check box under General Policies.

---

### Note

If NAC is enabled and you created a quarantined VLAN for use with this, make sure to select it from the Interface drop-down box under General Policies. Also, check the Allow AAA Override check box to ensure that the controller validates a quarantine VLAN assignment.

h. Click Apply to commit your changes.

---

**Step 2**

Follow these steps to create a locally switched WLAN. In our example, this is the second WLAN (employee-local).

a. Follow the substeps in Step 1 to create a new WLAN. In our example, this WLAN is named “employee-local.”
b. Click a WLAN ID from the original WLAN window to move to a WLANs edit page. Modify the configuration parameters for this WLAN. In our employee WLAN example, you would need to choose **WPA1+WPA2** from the Layer 2 Security drop-down box. Make sure to choose **PSK** authentication key management and enter a pre-shared key.

**Note** Make sure to enable this WLAN by checking the **Admin Status** check box under General Policies. Also, make sure to enable local switching by checking the **H-REAP Local Switching** check box. When you enable local switching, any hybrid-REAP access point that advertises this WLAN is able to locally switch data packets (instead of tunneling them to the controller).

**Note** For hybrid-REAP access points, the interface mapping at the controller for WLANs configured for H-REAP Local Switching is inherited at the access point as the default VLAN tagging. This can be easily changed per SSID and per hybrid-REAP access point. Non-hybrid-REAP access points tunnel all traffic back to the controller, and VLAN tagging is dictated by each WLAN’s interface mapping.

c. Click **Apply** to commit your changes.

**Step 3** Follow these steps if you also want to create a centrally switched WLAN that is used for guest access. In our example, this is the third WLAN (guest-central). You might want to tunnel guest traffic to the controller so you can exercise your corporate data policies for unprotected guest traffic from a central site.

a. Follow the substeps in **Step 1** to create a new WLAN. In our example, this WLAN is named “guest-central.”

b. In the WLANs Edit page, modify the configuration parameters for this WLAN. In our employee WLAN example, you would need to choose **None** from both the Layer 2 Security and Layer 3 Security drop-down boxes, check the **Web Policy** check box, and make sure **Authentication** is selected.

**Note** If you are using an external web server, you must configure a preauthentication access control list (ACL) on the for the server and then choose this ACL as the WLAN preauthentication ACL.

c. Make sure to enable this by checking the **Admin Status** check box under General Policies.

d. Click **Apply** to commit your changes.

e. If you want to customize the content and appearance of the login page that guest users see the first time they access this , follow the instructions in the “Configuring a Web Authentication Template” section on page 10-51.

f. To add a local user to thisWLAN, click **Security** and then click **Local Net Users**.

g. When the Local Net Users page appears, choose **Add Local Net User** from the Select a command drop-down menu.

h. In the User Name and Password fields, enter a username and password for the local user. Click the **Generate Password** check box if you want a password automatically generated. The Password and Confirm Password parameters is automatically populated. If automatic generation is not enabled, you must supply a password twice.
i. From the SSID drop-down list, choose the SSID to which this guest user applies. Only those SSIDs for which web security is enabled are listed. The SSID must be a WLAN that has Layer 3 web authentication policy configured.

j. Enter a description of the guest user account.

k. From the Lifetime drop-down list, choose the number of days, hours, or minutes for this user account to remain active.

l. Click **Save**.

**Step 4**  
Go to the “Configuring an Access Point for Hybrid REAP” section on page 12-9 to configure two or three access points for hybrid REAP.

---

**Configuring an Access Point for Hybrid REAP**

This section provides instructions for configuring an access point for hybrid REAP.

Follow these steps to configure an access point for hybrid REAP:

---

**Step 1**  
Make sure that the access point has been physically added to your network.

**Step 2**  
Choose **Configure > Access Points**.

**Step 3**  
Choose which access point you want to configure for hybrid REAP by clicking one from the AP Name list. The detailed access point window appears (see **Figure 12-3**).
Configuring Hybrid REAP

The last parameter under Inventory Information indicates whether this access point can be configured for hybrid REAP. Only the 1130AG and 1240AG access points support hybrid REAP.

**Step 4** Verify that the H-REAP Mode Supported parameter displays Yes. If it does not, continue to Step 5. If H-REAP is showing as supported, skip to Step 7.

**Step 5** Choose **Configure > Access Point Templates**.

**Step 6** Choose which access point you want to configure for hybrid REAP by clicking one from the AP Name list. The AP/Radio Templates window appears (see **Figure 12-4**).
Step 7 Check the Enable VLAN check box and enter the number of the native VLAN on the remote network (such as 100) in the Native VLAN Identifier field.

Note By default, a VLAN is not enabled on the hybrid-REAP access point. When hybrid REAP is enabled, the access point inherits the VLAN ID associated to the WLAN. This configuration is saved in the access point and received after the successful join response. By default, the native VLAN is 1. One native VLAN must be configured per hybrid-REAP access point in a VLAN-enabled domain. Otherwise, the access point cannot send and receive packets to and from the controller. When the client is assigned a VLAN from the RADIUS server, that VLAN is associated to the locally switched WLAN.

Step 8 Click Save to save your changes.

Step 9 The Locally Switched VLANs section shows which WLANs are locally switched and provides their VLAN identifier. Click the Edit link to change the number of VLANs from which a client IP address is obtained. You are then redirected to a page where you can save the VLAN identifier changes.

Step 10 Click Save to save your changes.

Step 11 Repeat this procedure for any additional access points that need to be configured for hybrid REAP at the remote site.

Connecting Client Devices to the WLANs

Follow the instructions for your client device to create profiles that connect to the WLANs you created in the “Configuring the Controller for Hybrid REAP” section on page 12-6.
In our example, you would create three profiles on the client:

1. To connect to the “employee” WLAN, you would create a client profile that uses WPA/WPA2 with PEAP-MSCHAPV2 authentication. When the client becomes authenticated, it gets an IP address from the management VLAN of the controller.

2. To connect to the “local-employee” WLAN, you would create a client profile that uses WPA/WPA2 authentication. When the client becomes authenticated, it gets an IP address from VLAN 101 on the local switch.

3. To connect to the “guest-central” WLAN, you would create a profile that uses open authentication. When the client becomes authenticated, it gets an IP address from VLAN 101 on the network local to the access point. After the client connects, the local user types any HTTP address in the web browser. The user is automatically directed to the controller to complete the web-authentication process. When the web login page appears, the user enters his or her username and password.

To see if a client’s data traffic is being locally or centrally switched, click Monitor > Devices > Clients.

### Hybrid REAP Access Point Groups

Hybrid REAP enables you to configure and control access points in a branch or remote office from the corporate office through a wide area network (WAN) link without deploying a controller in each office. There is no deployment restriction on the number of hybrid-REAP access points per location, but you can organize and group the access points per floor and limit them per building, since it is likely the branch offices share the same configuration.

By forming access point groups with similar configurations, a procedure such as CCKM fast roaming can be processed more quickly than going through the controller individually. For example, to activate CCKM fast roaming, the HREAP access points must know the CCKM cache for all clients that could associate. If you have a controller with 300 access points and 1000 clients that can potentially connect, it is quicker and more practical to process and send the CCKM cache for the HREAP group rather than for all 1000 clients. One particular HREAP group could focus on a branch office with a small number of access points so that clients in the branch office could only connect to and roam between those few access points. With the established group, features such as CCKM cache and backup RADIUS are configured for the entire HREAP group rather than being configured in each access point.

All of the hybrid-REAP access points in a group share the same, backup RADIUS server, CCKM, and local authentication configuration information. This feature is helpful if you have multiple hybrid-REAP access points in a remote office or on the floor of a building and you want to configure them all at once. For example, you can configure a backup RADIUS server for a hybrid-REAP group rather than having to configure the same server on each access point. Figure 12-6 illustrates a typical hybrid-REAP group deployment with a backup RADIUS server in the branch office.
Hybrid-REAP Groups and Backup RADIUS Servers

You can configure the controller to allow a hybrid-REAP access point in standalone mode to perform full 802.1x authentication to a backup RADIUS server. You can configure a primary RADIUS server or both a primary and secondary RADIUS server.

Hybrid-REAP Groups and Local Authentication

You can configure the controller to allow a hybrid-REAP access point in standalone mode to perform LEAP or EAP-FAST authentication for up to 20 statically configured users. The controller sends the static list of usernames and passwords to each hybrid-REAP access point when it joins the controller. Each access point in the group authenticates only its own associated clients.

This feature is ideal for customers who are migrating from an autonomous access point network to an LWAPP hybrid-REAP access point network and are not interested in maintaining a large user database nor adding another hardware device to replace the RADIUS server functionality available in the autonomous access point.

This feature can be used in conjunction with the hybrid-REAP backup RADIUS server feature. If a hybrid-REAP group is configured with both a backup RADIUS server and local authentication, the hybrid-REAP access point always attempts to authenticate clients using the primary backup RADIUS server first, followed by the secondary backup RADIUS server (if the primary is not reachable), and finally the hybrid-REAP access point itself (if the primary and secondary are not reachable).

Configuring Hybrid-REAP Groups

Follow these steps to configure HREAP groups. If you want to apply an H-REAP template to multiple controllers, refer to the template instructions in the “Configuring H-REAP AP Groups” section on page 10-21.

**Step 1** Choose Configure > Controllers.

**Step 2** Choose a specific controller by clicking on the desired IP address.
Step 3  From the left sidebar menu choose **H-REAP > H-REAP AP Groups**. The established HREAP AP groups appear.

Step 4  The Group Name column shows the group names assigned to the HREAP access point groups. If you want to add an additional group, choose **Add H-REAP AP Group** from the Select a command drop-down menu.

- or -
To make modifications to an existing template, click to select a template in the Template Name column. The General tab of the HREAP AP Groups template appears (see **Figure 12-6**).

**Figure 12-6  H-REAP AP Groups**

Note  To delete a group name, click the group name you want to remove and choose **Delete H-REAP AP Group** from the Select a command drop-down menu.

Step 5  The Group Name parameter shows the group name assigned to the HREAP access point group.

Step 6  Choose the primary RADIUS authentication servers for each group. If a RADIUS authentication server is not present on the controller, the WCS configured RADIUS server does not apply.

Note  You must configure the RADIUS server configuration on the controller before you apply H-REAP RADIUS server configuration from WCS.

Step 7  Choose the secondary RADIUS authentication servers for each group. If a RADIUS authentication server is not present on the controller, the WCS configured RADIUS server does not apply.

Step 8  Click **Save**.
Step 9  If you want to add an access point to the group, click the **H-REAP AP** tab.

Step 10  An access point Ethernet MAC address cannot exist in more than one H-REAP group on the same controller. If more than one group is applied to the same controller, click the **Ethernet MAC** check box to unselect an access point from one of the groups. You should save this change or apply it to controllers.

Step 11  Click **Add AP**. The H-REAP AP Group window appears. Choose the access point Ethernet MAC from the WCS list of H-REAP MAC addresses and apply it.

Step 12  Click **Save**.

Step 13  If you want to enable local authentication for a hybrid-REAP group, click the **H-REAP Configuration** tab. The H-REAP Configuration tab appears.

**Note**  Make sure that the Primary RADIUS Server and Secondary RADIUS Server parameters are set to **None** on the General tab.

Step 14  Check the **H-REAP Local Authentication Enabled** check box to enable local authentication for this hybrid-REAP group. The default value is unchecked.

**Note**  When you attempt to use this feature, a warning message indicates that it is a licensed feature.

Step 15  To allow a hybrid-REAP access point to authenticate clients using LEAP, check the **LEAP** check box. Otherwise, to allow a hybrid-REAP access point to authenticate clients using EAP-FAST, check the **EAP-FAST** check box.

Step 16  Perform one of the following, depending on how you want protected access credentials (PACs) to be provisioned:

- To use manual PAC provisioning, enter the key used to encrypt and decrypt PACs in the EAP-FAST Key field. The key must be 32 hexadecimal characters.
- To allow PACs to be sent automatically to clients that do not have one during PAC provisioning, check the **Ignore Server Key** check box.

Step 17  In the EAP-FAST Authority ID field, enter the authority identifier of the EAP-FAST server. The identifier must be 32 hexadecimal characters.

Step 18  In the EAP-FAST Authority Info field, enter the authority identifier of the EAP-FAST server in text format. You can enter up to 32 hexadecimal characters.

Step 19  In the EAP-FAST Pac Timeout field, specify a PAC timeout value by entering the number of seconds for the PAC to remain viable in the edit box. The valid range is 2 to 4095 seconds.

**Note**  To verify that an individual access point belongs to a hybrid-REAP group, click the **Users configured in the group** link. It advances you to the H-REAP AP Group screen which shows the names of the groups and the access points that belong in it.
Auditing an H-REAP Group

If the H-REAP configuration changes over a period of time either on WCS or the controller, you can audit the configuration. The changes are visible on subsequent screens. You can choose to synchronize the configuration by refreshing WCS or the controller.
This chapter describes the type of events and alarms reported, how to view alarms and events by product or entity and severity, and how to view IDS signature attacks. It contains these sections:

- Using the Alarm Dashboard, page 13-1
- Monitoring Alarms, page 13-4
- Alarm and Event Dictionary, page 13-14

An event is an occurrence or detection of some condition in and around the network. For example, it can be a report about radio interference crossing a threshold, the detection of a new rogue access point, or a controller rebooting.

Events are not generated by a controller for each and every occurrence of a pattern match. Some pattern matches must occur a certain number of times per reporting interval before they are considered a potential attack. The threshold of these pattern matches is set in the signature file. Events can then generate alarms which further can generate e-mail notifications if configured as such.

An alarm is a WCS response to one or more related events. If an event is considered of high enough severity (critical, major, minor, or warning), the WCS raises an alarm until the resulting condition no longer occurs. For example, an alarm may be raised while a rogue access point is detected, but the alarm terminates after the rogue has not been detected for several hours.

One or more events can result in a single alarm being raised. The mapping of events to alarms is their correlation function. For example, some IDS events are considered to be network wide so all events of that type (regardless of which access point the event is reported from) map to a single alarm. On the other hand, other IDS events are client-specific. For these, all events of that type for a specific client MAC address map to an alarm which is also specific for that client MAC address, regardless of whether multiple access points report the same IDS violation. If the same kind of IDS violation takes place for a different client, then a different alarm is raised.

A WCS administrator currently has no control over which events generate alarms or when they time out. On the controller, individual types of events can be enabled or disabled (such as management, SNMP, trap controls, etc.).

**Using the Alarm Dashboard**

The number of active alarms for controllers, access points, location, and rogue elements as well as alarms associated with entities such as coverage, mesh, and severity are actively displayed on the left-side of most WCS windows (see Figure 13-1).
Chapter 13  Alarms and Events

Using the Alarm Dashboard

Note

The Administration > Settings > Alarms page has a Do Not Show Acknowledged Alarms in Alarm Summary Window check box. You must uncheck the preference of hiding acknowledged alarms if you want them to show in the Alarm Summary window.

Critical (red), Major (orange) and Minor (yellow) alarms are shown in the alarm dashboard, left-to-right.

Figure 13-1  Alarm Summary Block

To view a listing of a specific type of alarm (critical, major, or minor) for a specific product or entity (such as coverage), click on the appropriate box within the alarm dashboard and a window displaying details for that alarm type and product or entity appears (see Figure 13-2).

Note

You can also view alarm details for a specific product or entity by choosing Monitor > Alarms and then selecting the desired alarm level from the Severity drop-down menu and the product or entity type from the Alarm Category drop-down menu.

Note

To search for additional alarms, click New Search... on the left panel of the page.

Note

You can also configure a username and password login for access points from the controller.
**Note**
You can click a box in the alarm dashboard to display alarm events for the entity and alarm type selected. For example, if you click on the minor alarms box for location, the Alarms page for that specific item appears (see Figure 13-2). For more details on a specific alarm listed on the Alarms page, click on the **Failure Object** link (see Figure 13-3).
The most recent 802.11 channel where a rogue access point was observed is provided by clicking the Rogue Clients link on the bottom right or choosing Rogue Clients from the Select a command drop-down menu.

Note: You can use the drop-down menu at the upper-right of the Alarms page to assign, unassign, delete, or clear the alarm. The event history of the alarm is also accessible from this menu.

Monitoring Alarms

Choose Monitor > Alarms to access the Alarms window. This window provides a summary of the controller alarms.

This section provides information on the following information.

- Using Edit View, page 13-5
- Using Search, page 13-6
- Monitoring Failed Objects, page 13-7
- Monitoring Rogue Access Point Alarms, page 13-7
- Monitoring Rogue Access Point Details, page 13-9
- Monitoring Rogue Adhoc Alarms, page 13-10
When there are multiple alarm pages, the page numbers are displayed at the top of the page with a scroll arrow on each side. Use these scroll arrows to view additional alarms.

To add, remove, or reorder columns in the table, click the Edit View link to go to the Edit View window.

**Using Edit View**

The Edit View window allows you to add, remove, or reorder columns in the Alarms table.

To edit the available columns in the alarms table, follow these steps:

**Step 1** Choose **Monitor > Alarms**.

**Step 2** Click the **Edit View** link.

**Step 3** To add an additional column to the alarms table, click to highlight the column heading in the left column. Click **Show** to move the heading to the right column. All items in the right column are displayed in the alarms table.

**Step 4** To remove a column from the alarms table, click to highlight the column heading in the right column. Click **Hide** to move the heading to the left column. All items in the left column are not displayed in the alarms table.

**Step 5** Use the **Up/Down** buttons to specify the order in which the information appears in the table. Highlight the desired column heading and click **Up** or **Down** to move it higher or lower in the current list.

**Step 6** Click **Reset** to restore the default view.
Step 7  Click **Submit** to confirm the changes.

---

**Using Search**

Use the controls in the left sidebar to create and save custom searches. To use a saved search, choose it from the Saved Searches drop-down list to open the Search Alarms window.

---

**Note**  You can change the saved search criteria before initiating the search.

---

To delete a saved search, click Edit to open the Edit Saved Searches window. Check the check box for the saved search that you want to cancel, then click Submit.

To create a new search, click **New Search...** to open a Search Alarms window and set search criteria.

Search criteria windows have the following commands:

- **New Search** drop-down menu—Opens the Search Alarms window. Use the Search Alarms window to configure, run, and save searches.
  - **Severity** (drop-down list)—All Severities, Critical, Major, Minor, Warning, Clear, Info.
  - **Alarm Category**—All Types, AP, Controller, Mesh Links, Security, Coverage, Rogue AP, Rogue Adhoc, Location Servers, Location Notifications.
  - **Rogue State** (only shown when Rogue AP Alarm Category is selected)—All States, Alert, Known, Acknowledged, Contained, Threat, Contained Pending, Removed.
  - **Search for Rogue APs by** (only shown when Rogue AP Alarm Category is selected)—All APs, AP Name, Floor Area, Outdoor Area.
  - **Enter AP Name** (only shown when Rogue AP Alarm Category and Search for Rogue APs by AP Name are selected)—Enter the desired rogue access point name.
  - **Select Radio Type** (only shown when Floor Area Alarm Category, or Rogue AP Alarm Category and Search for Rogue APs by AP Name are selected)—All Radios, 802.11a, 802.11b/g.
  - **Campus** (only shown when Rogue AP Alarm Category and Search for Rogue APs by Floor Area/Outdoor Area are selected)—Root Area, <Campus Name>.
  - **Outdoor Area** (only shown when Rogue AP Alarm Category and Search for Rogue APs by Outdoor Area are selected)—Outdoor Area, <Outdoor Area Name>.
  - **Building** (only shown when Rogue AP Alarm Category and Search for Rogue APs by Floor Area are is selected)—All Buildings, <Building Name>.
  - **Floor Area** (only shown when Rogue AP Alarm Category and Search for Rogue APs by Floor Area are selected)—All Floors, <Floor Area Name>.
  - **Access Point** (only shown when Rogue AP Alarm Category and Search for Rogue APs by Floor Area/Outdoor Area are selected)—All Access Points, <Access Point Name>.
  - **Save Search**—To save a search, check the check box and enter the name of the search. The new search can later be accessed from the Saved Searches drop-down list on the left sidebar menu.
  - **Items per page**—The number of alarms to list per page.

- **Saved Searches** drop-down menu—Lists the saved custom searches. To open a saved search, choose it from the Saved Searches list.
Monitoring Failed Objects

Choose Monitor > Alarms to access the Alarms page. Click an item under Failure Object to access this page. The General Parameters descriptions are shown in Table 13-2.

This page provides the alarm details and messages regarding any anomalies with the controllers and access points.

Table 13-2  General Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Failure Object</td>
<td>Device that generated the alarm.</td>
</tr>
<tr>
<td>Owner</td>
<td>Name of person to which this alarm is assigned or (blank).</td>
</tr>
<tr>
<td>Acknowledged</td>
<td>Displays whether or not the alarm is acknowledged by the user.</td>
</tr>
<tr>
<td>Category</td>
<td>The category of the alarm (for example, AP, Rogue AP, or Security).</td>
</tr>
<tr>
<td>Created</td>
<td>Month, day, hour, minute, second, AM, or PM alarm created.</td>
</tr>
<tr>
<td>Modified</td>
<td>Month, day, hour, minute, second, AM, or PM alarm last modified.</td>
</tr>
<tr>
<td>Generated By</td>
<td>Device that generated the alarm.</td>
</tr>
</tbody>
</table>

Monitoring Rogue Access Point Alarms

Rogue access point radios are unauthorized access points detected by one or more Cisco lightweight access points. This page displays rogue access point alarms based on the severity you clicked in the Alarm Monitor.

To access the Rogue AP Alarms page, do one of the following:

- Choose Monitor > Alarms. From the left sidebar, click New Search and choose Rogue AP from the Alarm Category drop-down menu. Click GO to display the matching alarms.
- Choose Monitor > Security. From the left sidebar, click Rogue APs.
- Click the Malicious AP number link in the Alarm Summary box at the bottom of the left sidebar.

Note: If there are multiple alarm pages, the page numbers are displayed at the top of the page with a scroll arrow on each side. Use the scroll arrows to view additional alarms.
The Rogue AP Alarms page contains the following parameters:

### Table 13-3 Rogue Access Point Alarms

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check box</td>
<td>Select the alarms on which you want to take action.</td>
</tr>
<tr>
<td>Severity</td>
<td>The severity of the alarm: Critical, Major, Minor, Clear. Color coded.</td>
</tr>
<tr>
<td>Rogue MAC Address</td>
<td>Media Access Control address of the rogue access points. See Monitor Alarms &gt; Rogue AP Details.</td>
</tr>
<tr>
<td>Vendor</td>
<td>Rogue access point vendor name, or Unknown.</td>
</tr>
<tr>
<td>Classification Type</td>
<td>Malicious, Friendly, or Unclassified.</td>
</tr>
<tr>
<td>Radio Type</td>
<td>Indicates the radio type for this rogue access point.</td>
</tr>
<tr>
<td>Strongest AP RSSI</td>
<td>Indicates the strongest received signal strength indicator in dBm.</td>
</tr>
<tr>
<td>No. of Rogue Clients</td>
<td>Indicates the number of rogue clients associated to this access point.</td>
</tr>
<tr>
<td>Owner</td>
<td>Indicates the ‘owner’ of the rogue access point.</td>
</tr>
<tr>
<td>Date/Time</td>
<td>Date and time the alarm occurred.</td>
</tr>
<tr>
<td>State</td>
<td>State of the alarm: Alert, Known or Removed.</td>
</tr>
<tr>
<td>SSID</td>
<td>Service Set Identifier being broadcast by the rogue access point radio. (Blank if SSID is not broadcast.)</td>
</tr>
<tr>
<td>Map Location</td>
<td>Indicates the map location for this rogue access point.</td>
</tr>
<tr>
<td>Acknowledged</td>
<td>Displays whether or not the alarm is acknowledged by the user.</td>
</tr>
</tbody>
</table>

The alarm remains in WCS, and you can search for all Acknowledged alarms using the alarm search functionality.

The other sections on the Rogue AP Alarms page include the following:

- Unacknowledge—Unacknowledge an already acknowledged alarm.
- E-mail Notification—Takes you to the All Alarms > E-mail Notification page to view and configure e-mail notifications. See Monitor Alarms > E-mail Notification for more information.
- Severity Configuration—Change the severity level for newly-generated alarms. See Monitor Alarms > Severity Configuration for more information.
- Detecting APs—View the Cisco lightweight access points that are currently detecting the rogue access point.
- Map (High Resolution)—Click to display a high-resolution map of the rogue access point location.
- Rogue Clients—Click to view a list of rogue clients associated with this rogue access point. The Rogue Clients page displays the Client MAC Address, when it was last heard, its current status, its controller, and the rogue access point.
- Set State to ‘Unclassified - Alert’—Choose this command to tag the rogue access point as the lowest threat, continue monitoring the rogue access point, and to turn off containment.
- Set State to ‘Malicious - Alert’—Choose this command to tag the rogue access point as Malicious.
• Set State to ‘Friendly - Internal’—Choose this command to tag the rogue access point as internal, add it to the Known Rogue APs list, and to turn off containment.

• 1 AP Containment—Target the rogue access point for containment by one access point. (Lowest containment level.)

• 2 AP Containment—Target the rogue access point for containment by two Cisco lightweight access points.

• 3 AP Containment—Target the rogue access point for containment by three Cisco lightweight access points.

• 4 AP Containment—Target the rogue access point for containment by four Cisco lightweight access points. (Highest containment level.)

Caution

Attempting to contain a rogue access point may lead to legal consequences. When you select any of the AP Containment commands and click GO, a message “Containing a Rogue AP may have legal consequences. Do you want to continue?” appears. Click OK if you are sure or click Cancel if you do not wish to contain any access points.

Monitoring Rogue Access Point Details

Alarm event details for each rogue access point are available from the Rogue AP Alarms page. Follow these steps to view alarm events for a rogue access point radio.

Step 1

From the Rogue AP Alarms page, click an item under Rogue MAC Address.

This page displays alarm events for a rogue access point radio. Rogue access point radios are unauthorized access points detected by Cisco lightweight access points. The following information is available:

• General—
  • Rogue MAC Address—Media Access Control address of the rogue access points.
  • Vendor—Rogue access point vendor name or Unknown.
  • On Network—Indicates whether or not the rogue access point is located on the network.
  • Owner—Indicates the owner or left blank.
  • Acknowledged—Indicates whether or not the alarm is acknowledged by the user.
  • Classification Type—Malicious, Friendly, or Unclassified.
  • State—Indicates the state of the alarm: Alert, Known, or Removed.
  • SSID—Service Set Identifier being broadcast by the rogue access point radio. (Blank if SSID is not broadcast.)
  • Channel Number—Indicates the channel of the rogue access point.
  • Containment Level—Indicates the containment level of the rogue access point or Unassigned.
  • Radio Type—Indicates the radio type for this rogue access point.
  • Strongest AP RSSI—Indicates the strongest received signal strength indicator in dBm.
  • No. of Rogue Clients—Indicates the number of rogue clients associated to this access point.
  • Created—Indicates when the alarm event was created.
Monitoring Alarms

- Modified—Indicates when the alarm event was modified.
- Generated By—Indicates how the alarm event was generated.
- Previous Severity—The previous severity of the alarm: Critical, Major, Minor, Clear. Color coded.

- Annotations—Enter any new notes in this box and click Add to update the alarm.
- Message—Displays descriptive information about the alarm.
- Help—Displays the latest information about the alarm.
- Event History—Click to access the Monitor Alarms > Events page.
- Annotations—Lists existing notes for this alarm.

Monitoring Rogue Adhoc Alarms

The Rogue Adhoc Alarms page displays alarm events for rogue adhocs.

To access the Rogue Adhoc Alarms page, do one of the following:

- Choose Monitor > Alarms. From the left sidebar, click New Search and choose Rogue Adhoc from the Alarm Category drop-down menu. Click GO to display the matching alarms.
- Choose Monitor > Security. From the left sidebar, click Rogue Adhocs.

Note

If there are multiple alarm pages, the page numbers are displayed at the top of the page with a scroll arrow on each side. Use this to view additional alarms.

The Rogue Adhoc Alarms page contains the following parameters:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check box</td>
<td>Choose the alarms on which you want to take action.</td>
</tr>
<tr>
<td>Severity</td>
<td>The severity of the alarm: Critical, Major, Minor, Clear. Color coded.</td>
</tr>
<tr>
<td>Rogue Adhoc MAC Address</td>
<td>Media Access Control address of the rogue adhoc.</td>
</tr>
<tr>
<td>Vendor</td>
<td>Rogue adhoc vendor name or Unknown.</td>
</tr>
<tr>
<td>Classification Type</td>
<td>Malicious, Friendly, or Unclassified.</td>
</tr>
<tr>
<td>Radio Type</td>
<td>Indicates the radio type for this rogue adhoc.</td>
</tr>
<tr>
<td>Strongest AP RSSI</td>
<td>Indicates the strongest received signal strength indicator in dBm.</td>
</tr>
<tr>
<td>No. of Rogue Clients</td>
<td>Indicates the number of rogue clients associated to this rogue adhoc.</td>
</tr>
<tr>
<td>Owner</td>
<td>Indicates the owner of the rogue adhoc.</td>
</tr>
<tr>
<td>Date/Time</td>
<td>Date and time the alarm occurred.</td>
</tr>
<tr>
<td>State</td>
<td>State of the alarm: Alert, Known, or Removed.</td>
</tr>
</tbody>
</table>
Chapter 13 Alarms and Events

Monitoring Alarms

Monitoring Rogue Adhoc Details

Alarm event details for each rogue adhoc are available from the Rogue Adhoc Alarms page. Follow these steps to view the alarm events for a rogue adhoc radio.

Step 1
From the Rogue Adhoc Alarms page, click an item under Rogue MAC Address.
This page displays alarm events for a rogue access point radio. Rogue access point radios are unauthorized access points detected by Cisco lightweight access points. The following information is available:

- General—
  - Rogue MAC Address—Media Access Control address of the rogue adhoc.
  - Vendor—Rogue adhoc vendor name or Unknown.
  - On Network—Indicates whether or not the rogue adhoc is located on the network.
  - Owner—Indicates the owner or left blank.
  - Acknowledged—Indicates whether or not the alarm is acknowledged by the user.
  - Classification Type—Malicious, Friendly, or Unclassified.
  - State—Indicates the state of the alarm: Alert, Known, or Removed.
  - SSID—Service Set Identifier being broadcast by the rogue adhoc radio. (Blank if SSID is not broadcast.)
  - Channel Number—Indicates the channel of the rogue adhoc.
  - Containment Level—Indicates the containment level of the rogue adhoc or Unassigned.
  - Radio Type—Indicates the radio type for this rogue adhoc.
  - Strongest AP RSSI—Indicates the strongest received signal strength indicator in dBm.
  - No. of Rogue Clients—Indicates the number of rogue clients associated to this adhoc.
  - Created—Indicates when the alarm event was created.
  - Modified—Indicates when the alarm event was modified.
  - Generated By—Indicates how the alarm event was generated.
  - Previous Severity—The previous severity of the alarm: Critical, Major, Minor, Clear. Color coded.

- Annotations—Enter any new notes in this box and click Add to update the alarm.
- Message—Displays descriptive information about the alarm.

Table 13-4 (continued) Rogue Adhoc Alarms

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SSID</td>
<td>Service Set Identifier being broadcast by the rogue adhoc radio. (Blank if SSID is not broadcast.)</td>
</tr>
<tr>
<td>Map Location</td>
<td>Indicates the map location for this rogue adhoc.</td>
</tr>
<tr>
<td>Acknowledged</td>
<td>Displays whether or not the alarm is acknowledged by the user.</td>
</tr>
</tbody>
</table>
Monitoring Alarms

- **Help**—Displays the latest information about the alarm.
- **Event History**—Click to access the Monitor Alarms > Events page.
- **Annotations**—Lists existing notes for this alarm.

Detecting Access Points

Click a Rogues alarm square in the Alarm Monitor (lower left-hand side of the screen) to access the Monitor Alarms > <failure object> page. In the Monitor Rogue AP Alarms page, click an item under Rogue MAC Address to access the Monitor Alarms > Rogue AP Details page, from the Select a command drop-down list choose **Detecting APs**, and click **GO** to access this page.

Choose **Monitor > Alarms**, then click **New Search** in the left sidebar. Choose **Severity > All Severities** and **Alarm Category > Rogue AP**, and click **Go** to access Monitor Alarms > <Failure Objects>.

In the Monitor Rogue AP Alarms page, click an item under Rogue MAC Address to access Monitor Alarms > Rogue AP Details. In the Monitor Alarms > Rogue - <vendor:MACaddr> page, from the Select a command drop-down list, choose **Detecting APs** to access this page.

This page enables you to view information about the Cisco lightweight access points that are detecting a rogue access point.

Click a list item to display data about that item:
- **AP Name**
- **Radio**
- **Map Location**
- **SSID**—Service Set Identifier being broadcast by the rogue access point radio.
- **Channel Number**—Which channel the rogue access point is broadcasting on.
- **WEP**—Enabled or disabled.
- **WPA**—Enabled or disabled.
- **Pre-Amble**—Long or short.
- **RSSI**—Received signal strength indicator in dBm.
- **SNR**—Signal-to-noise ratio.
- **Containment Type**—Type of containment applied from this access point.
- **Containment Channels**—Channels that this access point is currently containing.

Monitoring Events

Click a **Rogues** alarm square in the **Alarm Monitor** (lower left-hand side of the screen), click a list item under **Rogue MAC Addresses**, from the Select a command drop-down list choose **Event History**, and click **GO** to access this page.

Choose **Monitor > Alarms** and then click **New Search** in the left sidebar. Choose **Severity > All Severities** and **Alarm Category > Rogue AP**, and click **Go** to access the Monitor Alarms > <failure object> page. Click an item under the Rogue MAC Address to display the Monitor Alarms > Rogue AP Details page. From the Select a command drop-down list choose **Event History**, and click **GO** to access this page.
This page enables you to review information about rogue alarm events. Events list the sequence of occurrences for an element(s) over a period of time.

Click the title of each column to reorder the listings:

- **Severity**—Color coded display of the severity of the event.
- **Rogue MAC Address**—Click a list item to display information about the entry.
- **Vendor**—Name of rogue access point manufacturer.
- **Type**—AP or AD-HOC.
- **On Network**—Whether or not the rogue access point is on the same subnet as the associated Port.
- **On 802.11a**—Whether or not the rogue access point is broadcasting on the 802.11a band.
- **On 802.11b**—Whether or not the rogue access point is broadcasting on the 802.11b/802.11g band.
- **Date/Time**—Date and time of the alarm.
- **Classification Type**—Malicious, Friendly, or Unclassified.
- **State**—State of the alarm, such as Alert and Removed.
- **SSID**—Service Set Identifier being broadcast by the rogue access point radio.

### Monitoring Rogue Clients

Choose **Monitor > Alarms** and then click **New Search** in the left sidebar. Choose **Severity > All Severities** and **Alarm Category > Rogue AP**, and click **GO** to access the Monitor Alarms > <failure object> page. Click an item under the Rogue MAC Address to display the Monitor Alarms > Rogue AP Details page. From the Select a command drop-down list, choose **Rogue Clients** to access this page.

This page enables you to view information about clients that have associated with the rogue access point.

- **Client MAC Address**—Media Access Control address of the rogue access point client.
- **Last Heard**—The last time a Cisco access point detected the rogue access point client.
- **Status**—Status of the rogue access point client.

### Monitoring E-mail Notifications

You can configure the delivery of e-mail notifications for specific alarm categories and severity levels. To configure e-mail notifications, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Choose <strong>Monitor &gt; Alarms</strong>.</td>
</tr>
<tr>
<td>Step 2</td>
<td>From the Select a command drop-down menu, choose <strong>E-mail Notification</strong>.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Click an <strong>Alarm Category</strong> to edit severity level and e-mail recipients for its e-mail notifications.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Choose the severity level check box(es) (Critical, Major, Minor, Warning) for which you want a notification sent.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Enter the notification recipient e-mail addresses in the <strong>To</strong> text box.</td>
</tr>
</tbody>
</table>

**Note** Separate multiple e-mail addresses with a comma.
Monitoring Security Configurations

You can change the severity level for newly-generated alarms.

Note

Existing alarms remain unchanged.

To change the severity level of newly-generated alarms, follow these steps:

Step 1  Choose Monitor > Alarms.
Step 2  From the Select a command drop-down menu, choose Severity Configuration.
Step 3  Choose the check box of the alarm condition for which you want to change the severity level.
Step 4  From the Configure Severity Level drop-down menu, choose the new severity level (Critical, Major, Minor, Warning, Informational, Reset to Default).
Step 5  Click GO.
Step 6  Click OK to confirm the change.

Alarm and Event Dictionary

This section describes the event and alarm notifications that the wireless LAN controller, access points, and location appliances can receive. In addition, specific actions an administrator can do to address these alarms and events are described.
Notification Format

For each alarm and event notification, the following information is provided:

Table 13-5  Notification Format

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>The notification title is generally picked up from an event property file defined in the NMS.</td>
</tr>
<tr>
<td>MIB Name</td>
<td>The MIB Name is the name of the notification as defined in the management information base (MIB). In some cases, if the event is specific only to the NMS, this field is not relevant. You can define multiple events in WCS from the same trap based on the values of the variables present in the trap. In such cases, multiple subentries appear with the same MIB Name. In addition, this field displays the value of the variable that caused WCS to generate this event.</td>
</tr>
<tr>
<td>WCS Message</td>
<td>The WCS Message is a text string that reflects the message displayed in the WCS alarm or event browser associated with this event. Numbers such as &quot;{0}&quot; reflect internal WCS variables that typically are retrieved from variables in the trap. However, the order of the variables as they appear in the trap cannot be derived from the numbers.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This field displays the symptoms associated with this event.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>This field displays the severity assigned to this event in WCS.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>This field lists the probable causes of the notification.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>This field lists any actions recommended for the administrator managing the wireless network.</td>
</tr>
</tbody>
</table>

Traps Added in Release 2.0

AP_BIG_NAV_DOS_ATTACK

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnApBigNavDosAttack.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>The AP &quot;{0}&quot; with protocol &quot;{1}&quot; receives a message with a large NAV field and all traffic on the channel is suspended. This is most likely a malicious denial of service attack.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system detected a possible denial of service attack and suspended all traffic to the affected channel.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A malicious denial of service attack is underway.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Identify the source of the attack in the network and take the appropriate action immediately.</td>
</tr>
</tbody>
</table>
### AP_CONTAINED_AS_ROGUE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPContainedAsARogue.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0}&quot; with protocol &quot;{1}&quot; on Switch &quot;{2}&quot; is contained as a Rogue preventing service.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>An access point is reporting that it is being contained as a rogue.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Another system is containing this access point.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Identify the system containing this access point. You may need to use a wireless sniffer.</td>
</tr>
</tbody>
</table>

### AP_DETECTED_DUPLICATE_IP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnDuplicateIpAddressReported.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0}&quot; on Switch &quot;{3}&quot; detected duplicate IP address &quot;{2}&quot; being used by machine with mac address &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system detects a duplicate IP address in the network that matches that assigned to an access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Another device in the network is configured with the same IP address as an access point.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Correct the misconfiguration of IP addresses in the network.</td>
</tr>
</tbody>
</table>

### AP_HAS_NO_RADIOS

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnApHasNoRadioCards.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Not supported in WCS yet.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>An access point is reporting that it has no radio cards.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>N/A.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Manufacturing fault or damage to the system during shipping.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Call customer support.</td>
</tr>
</tbody>
</table>
## AP_MAX_ROGUE_COUNT_CLEAR

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnApMaxRogueCountClear.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Fake AP or other attack on AP with MAC address &quot;{0}&quot; associated with Switch &quot;{2}&quot; is cleared now. Rogue AP count is within the threshold of &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The number of rogues detected by a switch (controller) is within acceptable limits.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>N/A.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## AP_MAX_ROGUE_COUNT_EXCEEDED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnApMaxRogueCountExceeded.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Fake AP or other attack may be in progress. Rogue AP count on AP with MAC address &quot;{0}&quot; associated with Switch &quot;{2}&quot; has exceeded the severity warning threshold of &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The number of rogues detected by a switch (controller) exceeds the internal threshold.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
</tbody>
</table>
| Probable Causes     | • There may be too many rogue access points in the network.  
                       • A fake access point attack may be in progress. |
| Recommended Actions | Identify the source of the rogue access points. |
**AUTHENTICATION_FAILURE (From MIB-II standard)**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>AuthenticationFailure.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Switch &quot;{0}&quot;. Authentication failure reported.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>There was an SNMP authentication failure on the switch (controller).</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>An incorrect community string is in use by a management application.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Identify the source of the incorrect community string and correct the string within the management application.</td>
</tr>
</tbody>
</table>

**BSN_AUTHENTICATION_FAILURE**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAuthenticationFailure.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Switch &quot;{0}&quot;. User authentication from Switch &quot;{0}&quot; failed for user name &quot;{1}&quot; and user type &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A user authentication failure is reported for a local management user or a MAC filter is configured on the controller.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Incorrect login attempt by an admin user from the controller CLI or controller GUI, or a client accessing the WLAN system.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>If the user has forgotten the password, the superuser may need to reset it.</td>
</tr>
</tbody>
</table>

**COLD_START (FROM MIB-II STANDARD)**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>coldStart.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Switch &quot;{0}&quot;. Cold start.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The switch (controller) went through a reboot.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
</tbody>
</table>
| Probable Causes  | - The switch (controller) has power-cycled.  
|                  | - The switch (controller) went through a hard reset.  
|                  | - The switch (controller) went through a software restart. |
| Recommended Actions | None. |

**CONFIG_SAVED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnConfigSaved.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Switch &quot;{0}&quot;. Configuration saved in flash.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A configuration save to flash is performed on the switch (controller).</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
</tbody>
</table>
### Chapter 13      Alarms and Events

### Alarm and Event Dictionary

<table>
<thead>
<tr>
<th>Event</th>
<th>Description</th>
<th>Probable Causes</th>
<th>Recommended Actions</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>IPSEC_IKE_NEG_FAILURE</strong></td>
<td>IPsec IKE Negotiation failure from remote IP address &quot;{0}&quot;</td>
<td>Configuration mismatch.</td>
<td>Validate configuration, verify that authentication credentials match (preshared keys or certificates); and verify that encryption algorithms and strengths match.</td>
</tr>
<tr>
<td><strong>IPSEC_INVALID_COOKIE</strong></td>
<td>IPsec Invalid cookie from remote IP address &quot;{0}&quot;</td>
<td>Synchronization problem. The client believes a tunnel exists while the WLAN appliance does not. This problem often happens when the IPsec client does not detect a disassociation event.</td>
<td>Reset the IPsec client and then restart tunnel establishment.</td>
</tr>
<tr>
<td><strong>LINK_DOWN (FROM MIB-II STANDARD)</strong></td>
<td>Port &quot;{0}&quot; is down on Switch &quot;{1}&quot;</td>
<td>An access point or a port was manually disconnected from the network.</td>
<td>Troubleshoot physical network connectivity to the affected port.</td>
</tr>
<tr>
<td><strong>LINK_UP (FROM MIB-II STANDARD)</strong></td>
<td>Port &quot;{0}&quot; is up on Switch &quot;{1}&quot;</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Alarm and Event Dictionary

### LRAD_ASSOCIATED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPAssociated.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0}&quot; associated with Switch &quot;{2}&quot; on Port number &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>An access point has associated with a switch (controller).</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>- A new access point has joined the network.</td>
</tr>
<tr>
<td></td>
<td>- An access point has associated with a standby switch (controller) due to a failover.</td>
</tr>
<tr>
<td></td>
<td>- An access point rebooted and reassociated with a switch (controller).</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### LRAD_DISASSOCIATED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPDisassociated.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0}&quot; disassociated from Switch &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The switch (controller) is no longer detecting an access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>- A failure in the access point.</td>
</tr>
<tr>
<td></td>
<td>- An access point is no longer on the network.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Check if the access point is powered up and has network connectivity to the switch (controller).</td>
</tr>
</tbody>
</table>

### LRADIF_COVERAGE_PROFILE_FAILED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPCoverageProfileFailed.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0},&quot; interface &quot;{1}&quot;. Coverage threshold of &quot;{3}&quot; is violated. Total no. of clients is &quot;{5}&quot; and no. failed clients is &quot;{4}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>Number of clients experiencing suboptimal performance has crossed the configured threshold.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Recommended Actions</td>
</tr>
<tr>
<td>--------------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Many clients are wandering to the remote parts of the coverage area of this</td>
<td>• If the configured threshold is too low, you may need to readjust it to a more</td>
</tr>
<tr>
<td>radio interface with no handoff alternative.</td>
<td>optimal value.</td>
</tr>
<tr>
<td></td>
<td>• If the coverage profile occurs on a more frequent basis, you may need to provide</td>
</tr>
<tr>
<td></td>
<td>additional radio coverage.</td>
</tr>
<tr>
<td></td>
<td>• If the power level of this radio can be manually controlled, you may need to</td>
</tr>
<tr>
<td></td>
<td>boost it to increase the coverage area.</td>
</tr>
</tbody>
</table>

**LRADIF_COVERAGE_PROFILE_PASSED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPCoverageProfileUpdatedToPass.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0},&quot; interface &quot;{1}&quot;. Coverage changed to acceptable.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio interface that was reporting coverage profile failure has reverted to an</td>
</tr>
<tr>
<td></td>
<td>acceptable level.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The number of clients on this radio interface with suboptimal performance has</td>
</tr>
<tr>
<td></td>
<td>dropped below the configured threshold.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

**LRADIF_CURRENT_CHANNEL_CHANGED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPCurrentChannelChanged.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0},&quot; interface &quot;{1}&quot;. Channel changed to &quot;{2}&quot;. Interference Energy before</td>
</tr>
<tr>
<td></td>
<td>update was &quot;{3}&quot; and after update is &quot;{4}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The current channel assigned to a radio interface has automatically changed.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Possible interference on a channel has caused the radio management software on the</td>
</tr>
<tr>
<td></td>
<td>controller to change the channel.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

**LRADIF_CURRENT_TXPOWER_CHANGED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPCurrentTxPowerChanged.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0},&quot; interface &quot;{1}&quot;. Transmit Power Level changed to &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The power level has automatically changed on a radio interface.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The radio management software on the controller has modified the power level for</td>
</tr>
<tr>
<td></td>
<td>optimal performance.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### LRADIF_DOWN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPfDown.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0},&quot; interface &quot;{1}&quot; is down.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio interface is out of service.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical if not disabled, otherwise Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>• A radio interface has failed.</td>
</tr>
<tr>
<td></td>
<td>• An administrator has disabled a radio interface.</td>
</tr>
<tr>
<td></td>
<td>• An access point has failed and is no longer detected by the controller.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>If the access point is not administratively disabled, call customer support.</td>
</tr>
</tbody>
</table>

### LRADF_INTERFERENCE_PROFILE_FAILED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPInterferenceProfileFailed.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0},&quot; interface &quot;{1}&quot;. Interference threshold violated.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The interference detected on one or more channels is violated.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>There are other 802.11 devices in the same band that are causing interference on channels used by this system.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>• If the interference threshold is configured to be too low, you may need to readjust it to a more optimum value.</td>
</tr>
<tr>
<td></td>
<td>• Investigate interference sources such as other 802.11 devices in the vicinity of this radio interface.</td>
</tr>
</tbody>
</table>

A possible workaround is adding one or more access points to distribute the current load or slightly increasing the threshold of the access point which is displaying this message. To perform this workaround, follow the steps below:

1. Choose **Configure > Controllers**.
2. Click on any IP address in that column of the All Controllers page.
3. From the left sidebar menu, choose **802.11a/n** or **802.11b/g/n** and then **RRM Thresholds**.
4. Adjust the Interference Threshold (%) in the Other Thresholds section.

### LRADIF_INTERFERENCE_PROFILE_PASSED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPInterferenceProfileUpdatedToPass.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0},&quot; interface &quot;{1}&quot;. Interference changed to acceptable.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio interface reporting interference profile failure has reverted to an acceptable level.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
</tbody>
</table>
### LRADIF_LOAD_PROFILE_FAILED

<table>
<thead>
<tr>
<th>Probable Causes</th>
<th>The interference on this radio interface has dropped below the configured threshold.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPLoadProfileFailed.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0},&quot; interface &quot;{1}&quot;. Load threshold violated.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio interface of an access point is reporting that the client load has crossed a configured threshold.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
</tbody>
</table>

### LRADIF_LOAD_PROFILE_PASSED

<table>
<thead>
<tr>
<th>Probable Causes</th>
<th>There are too many clients associated with this radio interface.</th>
</tr>
</thead>
</table>
| Recommended Actions | • Verify the client count on this radio interface. If the threshold for this trap is too low, you may need to readjust it.  
• Add new capacity to the physical location if the client count is a frequent issue on this radio. |

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPLoadProfileUpdatedToPass.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0},&quot; interface &quot;{1}&quot;. Load changed to acceptable.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio interface that was reporting load profile failure has reverted to an acceptable level.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
</tbody>
</table>

### LRADIF_NOISE_PROFILE_FAILED

<table>
<thead>
<tr>
<th>Probable Causes</th>
<th>Noise sources that adversely affect the frequencies on which the radio interface operates.</th>
</tr>
</thead>
</table>
| Recommended Actions | • If the noise threshold is too low, you may need to readjust it to a more optimal value.  
• Investigate noise sources in the vicinity of the radio interface (for example, a microwave oven). |

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPNoiseProfileFailed.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0},&quot; interface &quot;{1}&quot;. Noise threshold violated.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The monitored noise level on this radio has crossed the configured threshold.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
</tbody>
</table>

Probable Causes: The interference on this radio interface has dropped below the configured threshold.

Recommended Actions: None.

MIB Name: bsnAPLoadProfileFailed.
WCS Message: AP "{0}," interface "{1}". Load threshold violated.
Symptoms: A radio interface of an access point is reporting that the client load has crossed a configured threshold.
WCS Severity: Minor.
Probable Causes: There are too many clients associated with this radio interface.
Recommended Actions: Verify the client count on this radio interface. If the threshold for this trap is too low, you may need to readjust it. Add new capacity to the physical location if the client count is a frequent issue on this radio.

MIB Name: bsnAPLoadProfileUpdatedToPass.
WCS Message: AP "{0}," interface "{1}". Load changed to acceptable.
Symptoms: A radio interface that was reporting load profile failure has reverted to an acceptable level.
WCS Severity: Informational.
Probable Causes: The load on this radio interface has dropped below the configured threshold.
Recommended Actions: None.

MIB Name: bsnAPNoiseProfileFailed.
WCS Message: AP "{0}," interface "{1}". Noise threshold violated.
Symptoms: The monitored noise level on this radio has crossed the configured threshold.
WCS Severity: Minor.
Probable Causes: Noise sources that adversely affect the frequencies on which the radio interface operates.
Recommended Actions: If the noise threshold is too low, you may need to readjust it to a more optimal value. Investigate noise sources in the vicinity of the radio interface (for example, a microwave oven).
## LRADIF_NOISE_PROFILE_PASSED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPNoiseProfileUpdatedToPass.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0},&quot; interface &quot;{1}.&quot; Noise changed to acceptable.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio interface that was reporting noise profile failure has reverted to an acceptable level.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The noise on this radio interface has dropped below the configured threshold.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## LRADIF_UP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPIfUp.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0},&quot; interface &quot;{1}&quot; is up.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio interface is back up.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
</tbody>
</table>
| Probable Causes           | • An administrator has enabled a radio interface.  
                          | • An access point has turned on.  
                          | • A new access point has joined the network. |
| Recommended Actions       | None.      |

## MAX_ROGUE_COUNT_CLEAR

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnMaxRogueCountClear.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Fake AP or other attack is cleared now. Rogue AP count on system &quot;{0}&quot; is within the threshold of &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The number of rogues detected by a controller is within acceptable limits.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>N/A.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### MAX_ROGUE_COUNT_EXCEEDED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnMaxRogueCountExceeded.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Fake AP or other attack may be in progress. Rogue AP count on system &quot;{0}&quot; has exceeded the severity warning threshold of &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The number of rogues detected by a controller exceeds the internal threshold.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
</tbody>
</table>
| Probable Causes        | • There are too many rogue access points in the network.  
                        | • A fake access point attack is in progress. |
| Recommended Actions    | Identify the source of the rogue access points. |

### MULTIPLE_USERS

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>multipleUsersTrap.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Switch &quot;{0}&quot;. Multiple users logged in.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>Multiple users with the same login ID are logged in through the CLI.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The same user has logged in multiple times through the CLI interface.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Verify that the expected login sessions for the same user are valid.</td>
</tr>
</tbody>
</table>

### NETWORK_DISABLED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnNetworkStateChanged (bsnNetworkState set to disabled).</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Global &quot;{1}&quot; network status disabled on Switch with IP Address &quot;{0}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>An administrator has disabled the global network for 802.11a/n and 802.11b/g/n.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Administrative command.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### NO_ACTIVITY_FOR_ROGUE_AP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>This is a WCS-only event generated when no rogue activity is seen for a specific duration.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Rogue AP &quot;{0}&quot; is cleared explicitly. It is not detected anymore.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A rogue access point is cleared from the management system due to inactivity.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A rogue access point is not located on any managed controller for a specified duration.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
## POE_CONTROLLER_FAILURE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnPOEControllerFailure.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>The POE controller has failed on the Switch &quot;{0}&quot;.</td>
</tr>
<tr>
<td>SYMPTOMS</td>
<td>A failure in the Power Over Ethernet (POE) unit is detected.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The power of the Ethernet unit has failed.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Call customer support. The unit may need to be repaired.</td>
</tr>
</tbody>
</table>

## RADIOS_EXCEEDED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRadiosExceedLicenseCount.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>The Radios associated with Switch &quot;{0}&quot; exceeded license count &quot;{1}&quot;. The current number of radios on this switch is &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The number of supported radios for a switch (controller) has exceeded the licensing limit.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The number of access points associated with the switch (controller) has exceeded the licensing limits.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Upgrade the license for the switch (controller) to support a higher number of access points.</td>
</tr>
</tbody>
</table>

## RADIUS_SERVERS_FAILED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRADIUSServerNotResponding.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Switch &quot;{0}&quot;. RADIUS server(s) are not responding to authentication requests.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The switch (controller) is unable to reach any RADIUS server for authentication.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Network connectivity to the RADIUS server is lost or the RADIUS server is down.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Verify the status of all configured RADIUS servers and their network connectivity.</td>
</tr>
</tbody>
</table>
### ROGUE_AP_DETECTED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRogueAPDetected.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Rogue AP or rogue adhoc &quot;{0}&quot; with SSID &quot;{3}&quot; and channel number &quot;{4}&quot; is detected by AP &quot;{1}&quot; Radio type &quot;{2}&quot; with RSSI &quot;{5}&quot; and SNR &quot;{6}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system has detected a rogue access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor if not on a wired network; Critical if on a wired network.</td>
</tr>
</tbody>
</table>
| Probable Causes   | • An illegal access point is connected to the network.  
|                   | • A known internal or external access point unknown to this system is detected as rogue. |
| Recommended Actions| • Verify the nature of the rogue access point by tracing it using its MAC address or the SSID, or by using location features to locate it physically.  
|                   | • If the access point is a known internal or external access point, acknowledge it or mark it as a known access point. Consider adding it to the known access point template within WCS.  
|                   | • If the access point is deemed to be a severity threat, contain it using the management interface. |

### ROGUE_AP_ON_NETWORK

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRogueAPDetectedOnWiredNetwork</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Rogue AP or rogue adhoc &quot;{0}&quot; is on the wired network.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A rogue access point is found reachable through the wired network.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>An illegal access point was detected as reachable through the wired network.</td>
</tr>
</tbody>
</table>
| Recommended Actions             | • Determine if this is a known or valid access point in the system. If it is valid, place it in the known access point list.  
|                                 | • Contain the rogue. Prevent anyone from accessing it until the access point has been traced down using location or other features. |

### ROGUE_AP_REMOVED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRogueAPRemoved.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Rogue AP or rogue adhoc &quot;{0}&quot; is removed; it was detected as Rogue AP by AP &quot;{1}&quot; Radio type &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system is no longer detecting a rogue access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A rogue access point has powered off or moved away and therefore the system no longer detects it.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
## RRM_DOT11_A_GROUPING_DONE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRrmDot11aGroupingDone.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RRM 802.11a/n grouping done; the new group leader’s MAC address is '{0}.'</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The radio resource module is finished grouping for the A band, and a new group leader is chosen.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The older RRM group leader may have gone down.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## RRM_DOT11_B_GROUPING_DONE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRrmDot11bGroupingDone.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RRM 802.11b/g/n grouping done; the new group leader’s MAC address is '{0}.'</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The radio resource module finished its grouping for the B band and chose a new group leader.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The older RRM group leader may have gone down.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## SENSED_TEMPERATURE_HIGH

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnSensedTemperatureTooHigh.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>The sensed temperature on the Switch '{0}' is too high. The current sensed temperature is '{1}'.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system’s internal temperature has crossed the configured thresholds.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>• Fan failure.</td>
</tr>
<tr>
<td></td>
<td>• Fault in the device.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>• Verify the configured thresholds and increase the value if it is too low.</td>
</tr>
<tr>
<td></td>
<td>• Call customer support.</td>
</tr>
</tbody>
</table>

## SENSED_TEMPERATURE_LOW

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnSensedTemperatureTooLow.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>The sensed temperature on the Switch '{0}' is too low. The current sensed temperature is '{1}'.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The internal temperature of the device is below the configured limit in the system.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
</tbody>
</table>
| Probable Causes | • Operating environment.  
• Hardware fault. |
|-----------------|---------------------------------------------------|
| Recommended Actions | • Verify the configured thresholds and ensure that the limit is appropriate.  
• Call customer support. |

### STATION_ASSOCIATE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnDot11StationAssociate.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Client &quot;{0}&quot; is associated with AP &quot;{1},&quot; interface &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A client has associated with an access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A client has associated with an access point.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### STATION_ASSOCIATE_FAIL

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnDot11StationAssociateFail.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Client &quot;{0}&quot; failed to associate with AP &quot;{1},&quot; interface &quot;{2}&quot;. The reason code is &quot;{3}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A client station failed to associate with the system.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The access point was busy.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Check whether the access point is busy and reporting load profile failures.</td>
</tr>
</tbody>
</table>

### STATION_AUTHENTICATE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnDot11StationAuthenticate (bsnStationUserName is set).</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Client &quot;{0}&quot; with user name &quot;{3}&quot; is authenticated with AP &quot;{1},&quot; interface &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A client has successfully authenticated with the system.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A client has successfully authenticated with the system.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### STATION_AUTHENTICATION_FAIL

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnDot11StationAuthenticateFail.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Client &quot;{0}&quot; has failed authenticating with AP &quot;{1},&quot; interface &quot;{2}&quot;. The reason code is &quot;{3}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system failed to authenticate a client.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
</tbody>
</table>
### STATION_BLACKLISTED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnDot11StationBlacklisted.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Client &quot;{0}&quot; which was associated with AP &quot;{1},&quot; interface &quot;{2}&quot; is excluded. The reason code is &quot;{3}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A client is in the exclusion list and is not allowed to authenticate for a configured interval.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>• Repeated authentication or association failures from the client station.</td>
</tr>
<tr>
<td></td>
<td>• A client is attempting to use an IP address assigned to another device.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>• Verify the configuration or the client along with its credentials.</td>
</tr>
<tr>
<td></td>
<td>• Remove the client from the exclusion list by using the management interface if the client needs to be allowed back into the network.</td>
</tr>
</tbody>
</table>

### STATION_DEAUTHENTICATE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnDot11StationDeauthenticate.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Client &quot;{0}&quot; is deauthenticated from AP &quot;{1},&quot; interface &quot;{2}&quot; with reason code &quot;{3}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A client is no longer authenticated by the system.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A client is no longer authenticated by the system.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### STATION_DISASSOCIATE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnDot11StationDisassociate.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Client &quot;{0}&quot; is disassociated from AP &quot;{1},&quot; interface &quot;{2}&quot; with reason code &quot;{3}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A client has disassociated with an access point in the system.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A station may disassociate due to various reasons such as inactivity timeout or a forced action from the management interface.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### STATION_WEP_KEY_DECRYPT_ERROR

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnWepKeyDecryptError.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>WCS Message</strong></td>
<td>The WEP Key configured at the station may be wrong. Station MAC Address is &quot;{0},&quot; AP MAC is &quot;{1}&quot; and Slot ID is &quot;{2}&quot;.</td>
</tr>
<tr>
<td><strong>Symptoms</strong></td>
<td>A client station seems to have the wrong WEP key.</td>
</tr>
<tr>
<td><strong>WCS Severity</strong></td>
<td>Minor.</td>
</tr>
<tr>
<td><strong>Probable Causes</strong></td>
<td>A client has an incorrectly configured WEP key.</td>
</tr>
<tr>
<td><strong>Recommended Actions</strong></td>
<td>Identify the client and correct the WEP key configuration.</td>
</tr>
</tbody>
</table>

### STATION_WPA_MIC_ERROR_COUNTER_ACTIVATED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnWpaMicErrorCounterActivated.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>WCS Message</strong></td>
<td>The AP &quot;{1}&quot; received a WPA MIC error on protocol &quot;{2}&quot; from Station &quot;{0}&quot;. Counter measures have been activated and traffic has been suspended for 60 seconds.</td>
</tr>
<tr>
<td><strong>Symptoms</strong></td>
<td>A client station has detected a WPA MIC error.</td>
</tr>
<tr>
<td><strong>WCS Severity</strong></td>
<td>Critical.</td>
</tr>
<tr>
<td><strong>Probable Causes</strong></td>
<td>A possible hacking attempt is underway.</td>
</tr>
<tr>
<td><strong>Recommended Actions</strong></td>
<td>Identify the station that is the source of this threat.</td>
</tr>
</tbody>
</table>

### SWITCH_DETECTED_DUPLICATE_IP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnDuplicateIpAddressReported.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>WCS Message</strong></td>
<td>Switch &quot;{0}&quot; detected duplicate IP address &quot;{0}&quot; being used by machine with mac address &quot;{1}&quot;.</td>
</tr>
<tr>
<td><strong>Symptoms</strong></td>
<td>The system has detected a duplicate IP address in the network that is assigned to the switch (controller).</td>
</tr>
<tr>
<td><strong>WCS Severity</strong></td>
<td>Critical.</td>
</tr>
<tr>
<td><strong>Probable Causes</strong></td>
<td>Another device in the network is configured with the same IP address as that of the switch (controller).</td>
</tr>
<tr>
<td><strong>Recommended Actions</strong></td>
<td>Correct the misconfiguration of IP addresses in the network.</td>
</tr>
</tbody>
</table>
### SWITCH_DOWN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>This is a WCS-only event.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Switch &quot;[0]&quot; is unreachable.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A switch (controller) is unreachable from the management system.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>• The switch (controller) has encountered hardware or software failure.</td>
</tr>
<tr>
<td></td>
<td>• There are network connectivity issues between the management station and the switch (controller).</td>
</tr>
<tr>
<td></td>
<td>• The configured SNMP community strings on the management station or the switch (controller) are incorrect.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>• Check if the switch (controller) is powered up and reachable through the web interface.</td>
</tr>
<tr>
<td></td>
<td>• Ping the switch (controller) from the management station to verify if there is IP connectivity.</td>
</tr>
<tr>
<td></td>
<td>• Check the community strings configured on the management station.</td>
</tr>
</tbody>
</table>

### SWITCH_UP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>This is a WCS-only event.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Switch &quot;[0]&quot; is reachable.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A switch (controller) is now reachable from the management station.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A switch (controller) is reachable from the management station.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### TEMPERATURE_SENSOR_CLEAR

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTemperatureSensorClear.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>The temperature sensor is working now on the switch &quot;{0}&quot;. The sensed temperature is &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The temperature sensor is operational.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The system is detecting the temperature sensor to be operational now.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
**TEMPERATURE_SENSOR_FAILURE**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTemperatureSensorFailure.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>The temperature sensor failed on the Switch &quot;{0}&quot;. Temperature is unknown.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system is reporting that a temperature sensor has failed and the system is unable to report accurate temperature.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The temperature sensor has failed due to hardware failure.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Call customer support.</td>
</tr>
</tbody>
</table>

**TOO_MANY_USER_UNSUCCESSFUL_LOGINS**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTooManyUnsuccessLoginAttempts.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>User &quot;{1}&quot; with IP Address &quot;{0}&quot; has made too many unsuccessful login attempts.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A management user has made too many login attempts.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
</tbody>
</table>
| Probable Causes         | • An admin user has made too many login attempts.  
                          | • A user attempted to break into the administration account of the management system. |
| Recommended Actions     | • Identify the source of the login attempts and take the appropriate action.  
                          | • Increase the value of the login attempt threshold if it is too low. |

**Traps Added in Release 2.1**

**ADHOC_ROGUE_AUTO_CONTAINED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAdhocRogueAutoContained.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Adhoc Rogue &quot;{0}&quot; was found and is auto contained as per WPS policy.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system detected an adhoc rogue and automatically contained it.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The system detected an adhoc rogue and automatically contained it as configured in the system’s wireless prevention policy.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Identify the adhoc rogue through the location application and take the appropriate action.</td>
</tr>
</tbody>
</table>

**ADHOC_ROGUE_AUTO_CONTAINED_CLEAR**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAdhocRogueAutoContained (bsnClearTrapVariable set to true).</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Adhoc Rogue &quot;{0}&quot; was found and was auto contained. The alert state is clear now.</td>
</tr>
</tbody>
</table>
### Alarm and Event Dictionary

<table>
<thead>
<tr>
<th><strong>Symptoms</strong></th>
<th>An adhoc rogue that the system has detected earlier is now clear.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>WCS Severity</strong></td>
<td>Informational.</td>
</tr>
<tr>
<td><strong>Probable Causes</strong></td>
<td>The system no longer detects an adhoc rogue.</td>
</tr>
<tr>
<td><strong>Recommended Actions</strong></td>
<td>None.</td>
</tr>
</tbody>
</table>

**NETWORK_ENABLED**

<table>
<thead>
<tr>
<th><strong>MIB Name</strong></th>
<th>bsnNetworkStateChanged (bsnNetworkState set to enabled).</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>WCS Message</strong></td>
<td>Global &quot;{1}&quot; network status enabled on Switch with IP Address &quot;{0}&quot;.</td>
</tr>
<tr>
<td><strong>Symptoms</strong></td>
<td>An administrator has enabled the global network for 802.11a/n or 802.11b/g/n.</td>
</tr>
<tr>
<td><strong>WCS Severity</strong></td>
<td>Informational.</td>
</tr>
<tr>
<td><strong>Probable Causes</strong></td>
<td>Administrative command.</td>
</tr>
<tr>
<td><strong>Recommended Actions</strong></td>
<td>None.</td>
</tr>
</tbody>
</table>

**ROGUE_AP_AUTO_CONTAINED**

<table>
<thead>
<tr>
<th><strong>MIB Name</strong></th>
<th>bsnRogueApAutoContained.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>WCS Message</strong></td>
<td>Rogue AP &quot;{0}&quot; is advertising our SSID and is auto contained as per WPS policy.</td>
</tr>
<tr>
<td><strong>Symptoms</strong></td>
<td>The system has automatically contained a rogue access point.</td>
</tr>
<tr>
<td><strong>WCS Severity</strong></td>
<td>Major.</td>
</tr>
<tr>
<td><strong>Probable Causes</strong></td>
<td>The system detected an adhoc rogue and automatically contained it as configured in the system’s wireless prevention policy.</td>
</tr>
</tbody>
</table>
| **Recommended Actions** | • Track the location of the rogue and take the appropriate action.  
• If this is a known valid access point, clear the rogue from containment. |

**ROGUE_AP_AUTO_CONTAINED_CLEAR**

<table>
<thead>
<tr>
<th><strong>MIB Name</strong></th>
<th>bsnRogueApAutoContained (bsnClearTrapVariable set to true).</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Message</strong></td>
<td>Rogue AP &quot;{0}&quot; was advertising our SSID and was auto contained. The alert state is clear now.</td>
</tr>
<tr>
<td><strong>Symptoms</strong></td>
<td>The system has cleared a previously contained rogue.</td>
</tr>
<tr>
<td><strong>WCS Severity</strong></td>
<td>Informational.</td>
</tr>
<tr>
<td><strong>Probable Causes</strong></td>
<td>The system has cleared a previously contained rogue.</td>
</tr>
<tr>
<td><strong>Recommended Actions</strong></td>
<td>None.</td>
</tr>
</tbody>
</table>
### TRUSTED_AP_INVALID_ENCRYPTION

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTrustedApHasInvalidEncryption.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Trusted AP &quot;[0]&quot; is invalid encryption. It is using &quot;[1]&quot; instead of &quot;[2].&quot; It is auto contained as per WPS policy.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system automatically contained a trusted access point that has invalid encryption.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The system automatically contained a trusted access point that violated the configured encryption policy.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Identify the trusted access point and take the appropriate action.</td>
</tr>
</tbody>
</table>

### TRUSTED_AP_INVALID_ENCRYPTION_CLEAR

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTrustedApHasInvalidEncryption (bsnClearTrapVariable set to true).</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Trusted AP &quot;[0]&quot; had invalid encryption. The alert state is clear now.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system has cleared a previous alert about a trusted access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The trusted access point has now conformed to the configured encryption policy.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### TRUSTED_AP_INVALID_RADIO_POLICY

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTrustedApHasInvalidRadioPolicy.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Trusted AP &quot;[0]&quot; has invalid radio policy. It is using &quot;[1]&quot; instead of &quot;[2].&quot; It has been auto contained as per WPS policy.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system has contained a trusted access point with an invalid radio policy.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The system has contained a trusted access point connected to the wireless system for violating the configured radio policy.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Identify the trusted access point and take the appropriate action.</td>
</tr>
</tbody>
</table>

### TRUSTED_AP_INVALID_RADIO_POLICY_CLEAR

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTrustedApHasInvalidRadioPolicy (bsnClearTrapVariable set to true).</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Trusted AP &quot;[0]&quot; had invalid radio policy. The alert state is clear now.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system has cleared a previous alert about a trusted access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The trusted access point has now conformed to the configured encryption policy.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### TRUSTED_AP_INVALID_SSID

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTrustedApHasInvalidSsid.</th>
</tr>
</thead>
</table>
| WCS Message                  | Trusted AP 

| Symptoms                     | The system has automatically contained a trusted access point for advertising an invalid SSID. |
| WCS Severity                 | Major. |
| Probable Causes              | The system has automatically contained a trusted access point for violating the configured SSID policy. |
| Recommended Actions          | Identify the trusted access point and take the appropriate action. |

### TRUSTED_AP_INVALID_SSID_CLEAR

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTrustedApHasInvalidSsid (bsnClearTrapVariable set to true).</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Trusted AP &quot;{0}&quot; had invalid SSID. The alert state is clear now.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system has cleared a previous alert about a trusted access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The trusted access point has now conformed to the configured policy.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### TRUSTED_AP_MISSING

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTrustedApIsMissing.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Trusted AP &quot;{0}&quot; is missing or has failed.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The wireless system no longer detects a trusted access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A trusted access point has left the network or has failed.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Track down the trusted access point and take the appropriate action.</td>
</tr>
</tbody>
</table>

### TRUSTED_AP_MISSING_CLEAR

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnTrustedApIsMissing (bsnClearTrapVariable set to true).</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Trusted AP &quot;{0}&quot; is missing or has failed. The alert state is clear now.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system has found a trusted access point again.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The system has detected a previously missing trusted access point.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### Chapter 13  Alarms and Events

#### Alarm and Event Dictionary

**Traps Added in Release 2.2**

**AP_IMPERSONATION_DETECTED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPImpersonationDetected.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP Impersonation with MAC &quot;{0}&quot; is detected by authenticated AP &quot;{1}&quot; on &quot;{2}&quot; radio and Slot ID &quot;{3}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio of an authenticated access point has heard from another access point whose MAC address neither matches that of a rogue nor is it an authenticated neighbor of the detecting access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A severity breach related to access point impersonation may be under way.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Track down the MAC address of the impersonating access point in the network and contain it.</td>
</tr>
</tbody>
</table>

**AP_RADIO_CARD_RX_FAILURE**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPRadioCardRxFailure.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Receiver failure detected on the &quot;{0}&quot; radio of AP &quot;{1}&quot; on Switch &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio card is unable to receive data.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
</tbody>
</table>
| Probable Causes | • A radio card is experiencing reception failure.  
• The antenna of the radio is disconnected. |
| Recommended Actions | • Check the access point’s antenna connection.  
• Call customer support. |

**AP_RADIO_CARD_RX_FAILURE_CLEAR**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPRadioCardRxFailureClear.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Receiver failure cleared on the &quot;{0}&quot; radio of AP &quot;{1}&quot; on Switch &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio is no longer experiencing reception failure.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A malfunction in the access point has been corrected.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

**AP_RADIO_CARD_TX_FAILURE**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPRadioCardTxFailure.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Transmitter failure detected on the &quot;{0}&quot; radio of AP &quot;{1}&quot; on Switch &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio card is unable to transmit.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
</tbody>
</table>
### Alarm and Event Dictionary

#### AP_RADIO_CARD_TX_FAILURE_CLEAR

| Probable Causes | • A radio card is experiencing transmission failure.  
• The antenna of the radio may be disconnected. |
|-----------------|--------------------------------------------------|
| Recommended Actions | • Check the antenna of the access point.  
• Call customer support. |

#### MIB Name
bsnAPRadioCardTxFailureClear

#### WCS Message
Transmitter failure cleared on the "{0}" radio of AP "{1}" on Switch "{2}".

#### Symptoms
A radio is no longer experiencing transmission failure.

#### WCS Severity
Informational.

#### Probable Causes
A malfunction in the access point has been corrected.

#### Recommended Actions
None.

#### SIGNATURE_ATTACK_CLEARED

<table>
<thead>
<tr>
<th>Probable Causes</th>
<th>A signature attack that the system previously detected has stopped.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

#### MIB Name
bsnSignatureAttackDetected (bsnClearTrapVariable is set to True).

#### WCS Message
Switch "{0}" is cleared from IDS signature attack. The wireless system is no longer detecting the intrusion.

#### Symptoms
The switch (controller) no longer detects a signature attack.

#### WCS Severity
Informational.

#### Probable Causes
The signature attack that the system previously detected has stopped.

#### Recommended Actions
None.

#### SIGNATURE_ATTACK_DETECTED

<table>
<thead>
<tr>
<th>Probable Causes</th>
<th>Someone is mounting a malevolent signature attack.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recommended Actions</td>
<td>Track down the source of the signature attack in the wireless network and take the appropriate action.</td>
</tr>
</tbody>
</table>

#### MIB Name
bsnSignatureAttackDetected

#### WCS Message
IDS Signature attack detected on Switch "{0}". The Signature Type is "{1}". Signature Name is "{2}" and Signature description is "{3}".

#### Symptoms
The switch (controller) is detecting a signature attack. The switch (controller) has a list of signatures that it monitors. When it detects a signature, it provides the name of the signature attack in the alert it generates.

#### WCS Severity
Critical.
TRUSTED_AP_HAS_INVALID_PREAMBLE

MIB Name | 
<table>
<thead>
<tr>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>bsnTrustedApHasInvalidPreamble.</td>
</tr>
</tbody>
</table>

WCS Message | Trusted AP "(0)" on Switch "(3)" has invalid preamble. It is using "(1)" instead of "(2)." It has been auto contained as per WPS policy. |

Symptoms | The system has contained a trusted rogue access point for using an invalid preamble. |

WCS Severity | Major. |

Probable Causes | The system has detected a possible severity breach because a rogue is transmitting an invalid preamble. |

Recommended Actions | Locate the rogue access point using location features or the access point detecting it and take the appropriate actions. |

TRUSTED_HAS_INVALID_PREAMBLE/CLEARED

MIB Name | bsnTrustedApHasInvalidPreamble (bsnClearTrapVariable is set to true). |

WCS Message | Trusted AP "(0)" on Switch "(3)" had invalid preamble. The alert state is clear now. |

Symptoms | The system has cleared a previous alert about a trusted access point. |

WCS Severity | Informational. |

Probable Causes | The system has cleared a previous alert about a trusted access point. |

Recommended Actions | None. |

Traps Added in Release 3.0

AP_FUNCTIONALITY_DISABLED

MIB Name | bsnAPFunctionalityDisabled. |

WCS Message | AP functionality has been disabled for key "(0)," reason being "(1)" for feature-set "(2)." |

Symptoms | The system sends this trap out when the controller disables access point functionality because the license key has expired. |

WCS Severity | Critical. |

Probable Causes | When the controller boots up, it checks whether the feature license key matches the controller’s software image. If it does not, the controller disables access point functionality. |

Recommended Actions | Configure the correct license key on the controller and reboot it to restore access point functionality. |
### AP_IP_ADDRESS_FALLBACK

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPIPAddressFallback.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{0}&quot; with static-ip configured as &quot;{2}&quot; has fallen back to the working DHCP address &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This trap is sent out when an access point, with the configured static ip-address, fails to establish connection with the outside world and starts using DHCP as a fallback option.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>If the configured IP address on the access point is incorrect or obsolete, and if the AP Fallback option is enabled on the switch (controller), the access point starts using DHCP.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Reconfigure the access point’s static IP to the correct IP address if desired.</td>
</tr>
</tbody>
</table>

### AP_REGULATORY_DOMAIN_MISMATCH

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPRegulatoryDomainMismatch.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;{1}&quot; is unable to associate. The Regulatory Domain configured on it &quot;{3}&quot; does not match the Controller &quot;{0}&quot; country code &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system generates this trap when an access point’s regulatory domain does not match the country code configured on the controller. Due to the country code mismatch, the access point will fail to associate with the controller.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
</tbody>
</table>
| Probable Causes           | • If someone changes the controller’s country code configuration and some of the existing access points support a different country code, these access points fail to associate.  
                          | • An access point on the controller’s network sends join requests to the controller, but the regulatory domain is outside the domain in which the controller is operating. |
| Recommended Actions       | Either remove the access points that are not meant for inclusion in the controller’s domain or correct the controller’s country code setting. |

### RX_MULTICAST_QUEUE_FULL

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRxMulticastQueueFull.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>CPU Receive Multicast Queue is full on Controller &quot;{0}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This trap indicates that the CPU’s Receive Multicast queue is full.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>An ARP storm.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
Traps Added in Release 3.1

**AP_AUTHORIZATION_FAILURE**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPAuthorizationFailure</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Failed to authorize AP “{0}.” Authorization entry does not exist in Controllers “{1}” AP Authorization List.</td>
</tr>
<tr>
<td></td>
<td>• Failed to authorize AP “{0}.” AP’s authorization key does not match with SHA1 key in Controllers “{1}” AP Authorization List.</td>
</tr>
<tr>
<td></td>
<td>• Failed to authorize AP “{0}.” Controller “{1}” could not verify the Self Signed Certificate from the AP.</td>
</tr>
<tr>
<td></td>
<td>• Failed to authorize AP “{0}.” AP has a self signed certificate where as the Controllers “{1}” AP authorization list has Manufactured Installed Certificate for this AP.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>An alert is generated when an access point fails to associate with a controller due to authorization issues.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>• The access point is not on the controller’s access point authorization list.</td>
</tr>
<tr>
<td></td>
<td>• The key entry in the controller's access point authorization list does not match the SHA1 key received from the access point.</td>
</tr>
<tr>
<td></td>
<td>• The access point self-signed certificate is not valid.</td>
</tr>
<tr>
<td></td>
<td>• The access point has a self-signed certificate and the controller’s access point authorization list (for the given access point) references a manufactured installed certificate.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>• Add the access point to the controller’s authorization list.</td>
</tr>
<tr>
<td></td>
<td>• Update the access point’s authorization key to match the controller’s access point key.</td>
</tr>
<tr>
<td></td>
<td>• Check the accuracy of the access point’s self-signed certificate.</td>
</tr>
<tr>
<td></td>
<td>• Check the certificate type of the access point in the controller’s access point authorization list.</td>
</tr>
</tbody>
</table>

**HEARTBEAT_LOSS_TRAP**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>heartbeatLossTrap</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Keepalive messages are lost between Master and Controller “{0}.”</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This trap is generated when the controller loses connection with the Supervisor Switch (in which it is physically embedded) and the controller cannot hear the heartbeat (keepalives) from the Supervisor.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>• Port on the WiSM controller could be down.</td>
</tr>
<tr>
<td></td>
<td>• Loss of connection with the Supervisor Switch.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
# INVALID_RADIO_INTERFACE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>invalidRadioTrap.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Radio with MAC address “{0}” and protocol “{1}” that has joined controller “{2}” has invalid interface. The reason is “{3}.”</td>
</tr>
<tr>
<td>Symptoms</td>
<td>If a Cisco access point joins the network but has unsupported radios, the controller detects this and generates a trap. This symptom propagates an alert in WCS.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The radio hardware is not supported by the controller.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

# RADAR_CLEARED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRadarChannelCleared</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Radar has been cleared on channel “{1}” which was detected by AP base radio MAC “{0}” on radio 802.11a/n.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>Trap is generated after the expiry of a non-occupancy period for a channel that previously generated a radar trap.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Trap is cleared on a channel.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

# RADAR_DETECTED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRadarChannelDetected</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Radar has been detected on channel “{1}” by AP base radio MAC “{0}” on radio 802.11a/n.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This trap is generated when radar is detected on the channel on which an access point is currently operating.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Radar is detected on a channel.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
# Radios Core Dump

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>radioCoreDumpTrap</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Radio with MAC address &quot;{0}&quot; and protocol &quot;{1}&quot; has core dump on controller &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>When a Cisco radio fails and a core dump occurs, the controller generates a trap and WCS generates an event for this trap.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Radio failure.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Capture the core dump file using the controller’s command line interface and send to TAC support.</td>
</tr>
</tbody>
</table>

# Radio Interface Down

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPIfDown.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Radio with MAC address &quot;{0}&quot; and protocol &quot;{1}&quot; is down. The reason is &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>When a radio interface is down, WCS generates an alert. Reason for the radio outage is also noted.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical if not manually disabled. Informational if radio interface was manually disabled.</td>
</tr>
</tbody>
</table>
| Probable Causes   | • The radio interface has failed.  
                   • The access point cannot draw enough power.  
                   • The maximum number of transmissions for the access point is reached.  
                   • The access point has lost connection with the controller heartbeat.  
                   • The admin status of the access point admin is disabled.  
                   • The admin status of the radio is disabled. |
| Recommended Actions | None.                      |

# Radio Interface Up

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPIfUp.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Radio with MAC address &quot;{0}&quot; and protocol &quot;{1}&quot; is up. The reason is &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>When a radio interface is operational again, WCS clears the previous alert. Reason for the radio being up again is also noted.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
</tbody>
</table>
| Probable Causes   | • Admin status of access point is enabled.  
                   • Admin status of radio is enabled.  
                   • Global network admin status is enabled. |
| Recommended Actions | None.                      |
**UNSUPPORTED_AP**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>unsupportedAPTrap.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP &quot;[0]&quot; tried to join controller &quot;[1]&quot; and failed. The controller does not support this kind of AP.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>When unsupported access points try to join 40xx/410x controllers or 3500 controller with 64 MB flash, these controllers generate a trap, and the trap is propagated as an event in WCS.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Access point is not supported by the controller.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

**Traps Added in Release 3.2**

**LOCATION_NOTIFY_TRAP**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>locationNotifyTrap.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Depending on the notification condition reported, the trap is sent out in an XML format and is reflected in WCS with the following alert messages:</td>
</tr>
<tr>
<td></td>
<td>• Absence of &lt;Element&gt; with MAC &lt;macAddress&gt;, last seen at &lt;timestamp&gt;.</td>
</tr>
<tr>
<td></td>
<td>• &lt;Element&gt; with MAC &lt;macAddress&gt; is &lt;In</td>
</tr>
<tr>
<td></td>
<td>• &lt;Element&gt; with MAC &lt;macAddress&gt; has moved beyond &lt;specifiedDistance&gt; ft. of marker &lt;MarkerName&gt;, located at a range of &lt;foundDistance&gt; ft.</td>
</tr>
<tr>
<td></td>
<td>For detailed info on the XML format for the trap content, consult the 2700 Location Appliance Configuration Guide.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A 2700 location appliance sends this trap out when the defined location notification conditions are met (such at element outside area, elements missing, and elements exceeded specified distance). WCS uses this trap to display alarms about location notification conditions.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor (under the Location Notification dashboard).</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The location notification conditions configured for a 2700 location appliance are met for certain elements on the network.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
Traps Added In Release 4.0

**CISCO_LWAPP_MESH_POOR_SNR**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappMeshPoorSNR</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Poor SNR.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>SNR (signal-to-noise) ratio is important because high signal strength is not enough to ensure good receiver performance. The incoming signal must be stronger than any noise or interference that is present. For example, you can have high signal strength and still have poor wireless performance if there is strong interference or a high noise level.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The link SNR fell below 12 db. The threshold level cannot be changed. If poor SNR is detected on the backhaul link for a child or parent, the trap is generated and contains SNR values and MAC addresses.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

**CISCO_LWAPP_MESH_PARENT_CHANGE**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappMeshParentChange</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Parent changed.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>When the parent is lost, the child joins with another parent, and the child sends traps containing both old and new parent’s MAC addresses.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The child moved to another parent.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

**CISCO_LWAPP_MESH_CHILD_MOVED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappMeshChildMoved</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Child moved.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>When the parent access point detects a child being lost and communication is halted, the child lost trap is sent to WCS, along with the child MAC address.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The child moved from the parent.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
# Alarm and Event Dictionary

## CISCO_LWAPP_MESH_CONSOLE_LOGIN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappMeshConsoleLogin</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Console login successful or failed.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The console port provides the ability for the customer to change the user name and password to recover the stranded outdoor access point. To prevent any unauthorized user access to the access point, WCS sends an alarm when someone tries to log in. This alarm is required to provide protection because the access point is physically vulnerable being located outdoors.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>A login is of critical severity.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>You have successfully logged in to the access point console port or failed on three consecutive tries.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## CISCO_LWAPP_MESH_AUTHORIZATION_FAILURE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappMeshAuthorizationFailure</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Fails to authenticate with controller.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>WCS receives a trap from the controller. The trap contains the MAC addresses of those access points that failed authorization.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The access point tried to join the MESH but failed to authenticate because the MESH node MAC address was not on the MAC filter list.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## CISCO_LWAPP_MESH_CHILD_EXCLUDED_PARENT

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappMeshChildExcludedParent</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Parent AP being excluded by child AP.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>When a child fails authentication at the controller after a fixed number of attempts, the child can exclude that parent. The child remembers the excluded parent so that when it joins the network, it sends the trap which contains the excluded parent MAC address and the duration of the exclusion period.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A child marked a parent for exclusion.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
Chapter 13  Alarms and Events

Alarm and Event Dictionary

**CISCO_LWAPP_MESH_EXCESSIVE_PARENT_CHANGE**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappMeshExcessiveParentChange</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Parent changed frequently.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>When MAP parent-change-counter exceeds the threshold within a given duration, it sends a trap to WCS. The trap contains the number of times the MAP changes and the duration of the time. The threshold is user configurable.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The MESH access point changed its parent frequently.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

**IDS_SHUN_CLIENT_TRAP**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-IDS-MIB. CLIdsNewShunClient.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>The Cisco Intrusion Detection System &quot;{0}&quot; has detected a possible intrusion attack by the wireless client &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This trap is generated in response to a shun client clear alert originated from a Cisco IDS/IPS appliance (&quot;{0}&quot; installed in the data path between the wireless client (&quot;{1}&quot; and the site’s intranet.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The designated client is generating a packet-traffic pattern which shares properties with a well-known form of attack on the customer’s network.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Investigate the designated client and determine if it is an intruder, a virus, or a false alarm.</td>
</tr>
</tbody>
</table>

**IDS_SHUN_CLIENT_CLEAR_TRAP**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-IDS-MIB. cLIdsNewShunClientClear.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>The Cisco Intrusion Detection System &quot;{0}&quot; has cleared the wireless client &quot;{1}&quot; from possibly having generated an intrusion attack.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This trap is generated in response to one of two things: 1) a shun client clear alert originated from a Cisco IDS/IPS appliance (&quot;{0}&quot; installed in the data path between the wireless client (&quot;{1}&quot; and the site’s intranet, or 2) a scheduled timeout of the original IDS_SHUN_CLIENT_TRAP for the wireless client.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The designated client is no longer generating a suspicious packet-traffic pattern.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
**MFP_TIMEBASE_STATUS_TRAP**

| MIB Name | CISCO-LWAPP-MFP-MIB. ciscoLwappMfpTimebaseStatus. |
| WCS Message | Controller "\{0\}" is "\{1\}" with the Central time server. |
| Symptoms | This notification is sent by the agent to indicate when the synchronization of the controller’s time base with the Central time base last occurred. |
| WCS Severity | Critical (not in sync trap) and clear (sync trap). |
| Probable Causes | The controller’s time base is not in sync with the Central time base. |
| Recommended Actions | None. |

**MFP_ANOMALY_DETECTED_TRAP**

| MIB Name | CISCO-LWAPP-MFP-MIB. ciscoLwappMfpAnomalyDetected. |
| WCS Message | MFP configuration of the WLAN was violated by the radio interface "\{0\}" and detected by the radio interface "\{1\}" of the access point with MAC address "\{2\}". The violation is "\{3\}". |
| Symptoms | This notification is sent by the agent when the MFP configuration of the WLAN was violated by the radio interface cLApIfSmtDot11Bssid and detected by the radio interface cLApDot11IfSlotld of the access point cLApSysMacAddress. This violation is indicated by cLMfpEventType. When observing the management frame(s) given by cLMfpEventFrames for the last cLMfpEventPeriod time units, the controller reports the occurrence of a total of cLMfpEventTotal violation events of type cLMfpEventType. When the cLMfpEventTotal is 0, no further anomalies have recently been detected, and the NMS should clear any alarm raised about the MFP errors. **Note** This notification is generated by the controller only if MFP was configured as the protection mechanism through cLMfpProtectType. |
| WCS Severity | Critical. |
| Probable Causes | The MFP configuration of the WLAN was violated. Various types of violations are invalidMic, invalidSeq, noMic, and unexpectedMic. |
| Recommended Actions | None. |

**GUEST_USER_REMOVED_TRAP**

| MIB Name | CISCO-LWAPP-WEBAUTH-MIB. cLWAGuestUserRemoved. |
| WCS Message | Guest user "\{1\}" deleted on controller "\{0\}". |
| Symptoms | This notification is generated when the lifetime of the guest user \{1\} expires and the guest user's accounts are removed from the controller "\{0\}". |
| WCS Severity | Critical. |
| Probable Causes | GuestUserAccountLifetime expired. |
| Recommended Actions | None. |
Traps Added/Updated in Release 4.0.96.0

**AP_IMPERSONATION_DETECTED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPImpersonationDetected.</th>
</tr>
</thead>
</table>
| WCS Message                   | AP Impersonation with MAC 
{0}" using source MAC 
{1}" is detected by
authenticated AP 
{2}" on 
{3}" radio and slot ID 
{4}". |
| Symptoms                      | A radio of an authenticated access point had communication with another
access point whose MAC address neither matches that of a rogue nor is an
authenticated neighbor of the detecting access point. |
| WCS Severity                  | Critical.                                                        |
| Probable Causes               | A security breach related to access point impersonation may be occurring. |
| Recommended Actions           | Track down the MAC address of the impersonating access point and contain it. |

**RADIUS_SERVER_DEACTIVATED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappAAARadiusServerGlobalDeactivated.</th>
</tr>
</thead>
</table>
| WCS Message                   | RADIUS server 
{0}" (port {1}) is deactivated.                             |
| Symptoms                      | The controller detects that the RADIUS server is deactivated in the global list. |
| WCS Severity                  | Major.                                                          |
| Probable Causes               | RADIUS server is deactivated in the global list.                |
| Recommended Actions           | None.                                                           |

**RADIUS_SERVER_ACTIVATED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappAAARadiusServerGlobalDeactivated.</th>
</tr>
</thead>
</table>
| WCS Message                   | RADIUS server 
{0}" (port {1}) is activated.                             |
| Symptoms                      | The controller detects that the RADIUS server is deactivated in the global list. |
| WCS Severity                  | Major.                                                          |
| Probable Causes               | RADIUS server is deactivated in the global list.                |
| Recommended Actions           | None.                                                           |
### RADIUS_SERVER_WLAN_DEACTIVATED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-AAA-MIB. ciscoLwappAAARadiusServerWlanDeacti-vated.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RADIUS server &quot;[0]&quot; (port {1}) is deactivated on WLAN &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The controller detects that the RADIUS server is deactivated on the WLAN.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>RADIUS server is deactivated on the WLAN.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### RADIUS_SERVER_WLAN_ACTIVATED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-AAA-MIB. ciscoLwappAAARadiusServerWlanActivated.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RADIUS server &quot;[0]&quot; (port {1}) is activated on WLAN &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The controller detects that the RADIUS server is activated on the WLAN.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>RADIUS server is activated on the WLAN.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### RADIUS_SERVER_TIMEOUT

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-AAA-MIB. ciscoLwappAAARadiusReqTimedOut.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RADIUS server &quot;[0]&quot; (port {1}) failed to respond to request from client &quot;{2}&quot; with MAC &quot;{3}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The controller detects that the RADIUS server failed to respond to a request from a client or user.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>RADIUS server fails to process the request from the client or user.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### DECRYPT_ERROR_FOR_WRONG_WPA_WPA2

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-DOT11-CLIENT-MIB. CiscoLwappDot11ClientKeyDecryptError.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Decrypt error occurred at AP with MAC &quot;{0}&quot; running TKIP with wrong WPA/WPA2 by client with MAC &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The controller detects that a user is trying to connect with an invalid security policy for WPA/WPA2 types.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The user failed to authenticate and join the controller.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
Traps Added or Updated in Release 4.1

**AP_IMPERSONATION_DETECTED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnAPImpersonationDetected.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>AP impersonation of MAC &quot;{0}&quot; using source MAC &quot;{1}&quot; is detected by an authenticated AP &quot;{2}&quot; on &quot;{3}&quot; radio and slot ID &quot;{4}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A radio of an authenticated access point received signals from another access point whose MAC address neither matches that of a rogue nor is an authenticated neighbor of the detecting access point.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A security breach related to access point impersonation has occurred.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Track down the MAC address of the impersonating access point and contain it.</td>
</tr>
</tbody>
</table>

**INTERFERENCE_DETECTED**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>COGNIO-TRAPS-MIB.cognioInterferenceDetected.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Interference detected by type {0} with power {1}.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A Cognio spectrum agent detected interference over its configured thresholds.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Excessive wireless interference or noise.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

**INTERFERENCE_CLEAR**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>COGNIO-TRAPS-MIB. cognioInterferenceClear</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Interference cleared.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The Cognio spectrum expert agent no longer detects an interference source over its configured threshold.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Previous excessive wireless interference or noise is gone.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
## ONE_ANCHOR_ON_WLAN_UP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MOBILITY-MIB. ciscoLwappMobilityOneAnchorOnWlanUp.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Controller &quot;{0}&quot;. An anchor of WLAN &quot;{1}&quot; is up.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>Successive EoIP and UDP ping to at least one anchor on the WLAN is up.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>At least one anchor is reachable from an EoIP/UDP ping.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## RADIUS_SERVER_DEACTIVATED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-AAA-MIB. ciscoLwappAAARadiusServerGlobalDeactivated.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RADIUS server &quot;{0}&quot; (port {1}) is deactivated.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The controller detects that the RADIUS server is deactivated in the global list.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>RADIUS server is deactivated in the global list.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## RADIUS_SERVER_ACTIVATED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-AAA-MIB. ciscoLwappAAARadiusServerGlobalActivated.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RADIUS server &quot;{0}&quot; (port {1}) is activated.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The controller detects that the RADIUS server is activated in the global list.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>RADIUS server is activated in the global list.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## RADIUS_SERVER_WLAN_DEACTIVATED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-AAA-MIB. ciscoLwappAAARadiusServerWlanDeactivated.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RADIUS server &quot;{0}&quot; (port {1}) is deactivated on WLAN &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The controller detects that the RADIUS server is deactivated on the WLAN.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>RADIUS server is deactivated on the WLAN.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### RADIUS_SERVER_WLAN_ACTIVATED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-AAA-MIB. ciscoLwappAAARadiusServerGlobalWlanActivated.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RADIUS server &quot;{0}&quot; (port {1}) is activated on WLAN &quot;{2}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The controller detects that the RADIUS server is activated on the WLAN.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>RADIUS server is activated on the WLAN.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### RADIUS_SERVER_TIMEOUT

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-AAA-MIB. ciscoLwappAAARadiusReqTimedOut.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>RADIUS server &quot;{0}&quot; (port {1}) failed to respond to request from client &quot;{2}&quot; with MAC &quot;{3}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The controller detects that the RADIUS server failed to respond to a request from the client or user.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The RADIUS server fails to process the request from a client or user.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### MOBILITY_ANCHOR_CTRL_PATH_DOWN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MOBILITY-MIB. ciscoLwappMobilityAnchorControlPathDown.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Controller &quot;{0}&quot;. Control path on anchor &quot;{1}&quot; is down.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>When successive ICMP ping attempts to the anchor fails, the anchor is conclusively down.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Anchor not reachable by ICMP ping.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### MOBILITY_ANCHOR_CTRL_PATH_UP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MOBILITY-MIB. ciscoLwappMobilityAnchorControlUp.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Controller &quot;{0}&quot;. Control path on anchor &quot;{1}&quot; is up.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The ICMP ping to the anchor is restored, and the anchor is conclusively up.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The anchor is reachable by an ICMP ping.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
### MOBILITY_ANCHOR_DATA_PATH_DOWN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MOBILITY-MIB. ciscoLwappMobilityAnchorDataPath-Down.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Controller &quot;{0}&quot; Data path on anchor &quot;{1}&quot; is down.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>Successive EoIP ping attempts to the anchor fails, and the anchor is conclusively down.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The anchor is not reachable by an EoIP ping.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### MOBILITY_ANCHOR_DATA_PATH_UP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MOBILITY-MIB. ciscoLwappMobilityAnchorDataPath-Up.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Controller &quot;{0}&quot; Data path on anchor &quot;{1}&quot; is up.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The EoIP ping to the anchor is restored, and the anchor is conclusively up.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Anchor is reachable by the EoIP ping.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### WLAN_ALL_ANCHORS_TRAP_DOWN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MOBILITY-MIB. ciscoLwappMobilityAllAnchorsOnWlanDown.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Controller &quot;{0}&quot; All anchors of WLAN &quot;{1}&quot; are down.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>Successive EoIP ping attempts to all the anchors on WLAN is occurring.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Anchors are not reachable by the EoIP ping.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### MESH_AUTHORIZATIONFAILURE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MESH-MIB. ciscoLwappMeshAuthorizationFailure.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>MESH &quot;{0}&quot; fails to authenticate with controller because &quot;{1}&quot;</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A mesh access point failed to join the mesh network because its MAC address is not listed in the MAC filter list. The alarm includes the MAC address of the mesh access point that failed to join.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
</tbody>
</table>
### MESH_CHILDEXCLUDEDPARENT

<table>
<thead>
<tr>
<th>Probable Causes</th>
<th>The mesh node MAC address is not in the MAC filter list, or a security failure from the authorization server occurred.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

#### MIB Name
CISCO-LWAPP-MESH-MIB. ciscoLwappMeshChildExcludedParent.

#### WCS Message
Parent AP being excluded by child AP due to failed authentication, AP current parent MAC address "\{0\}," previous parent MAC address "\{1\}.”

#### Symptoms
This notification is sent by the agent when the child access point marks a parent access point for exclusion. When the child fails to authenticate at the controller after a fixed number of times, the child marks the parent for exclusion. The child remembers the excluded MAC address and informs the controller when it joins the network. The child access point marks the MAC address and excludes it for the time determined by MAP node so that it does not try to join this excluded node. The child MAC address is sent as part of the index.

#### WCS Severity
Info.

#### Probable Causes
The child access point failed to authenticate to the controller after a fixed number of times.

#### Recommended Actions
None.

### MESH_PARENTCHANGE

<table>
<thead>
<tr>
<th>Probable Causes</th>
<th>The child access point has changed its parent.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

#### MIB Name
CISCO-LWAPP-MESH-MIB. ciscoLwappMeshParentChange.

#### WCS Message
MESH "\{0\}” changed its parent. AP current parent MAC address "\{1\}," previous parent MAC address "\{2\}.”

#### Symptoms
This notification is sent by the agent when a child moves to another parent. The alarm includes the MAC addresses of the former and current parents.

#### WCS Severity
Info.

### MESH_CHILDMOVED

<table>
<thead>
<tr>
<th>Probable Causes</th>
<th>Parent AP lost connection to this AP. AP neighbor type is &quot;{0}.”</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

#### MIB Name
CISCO-LWAPP-MESH-MIB. ciscoLwappMeshChildMoved.

#### WCS Message
Parent AP lost connection to this AP. AP neighbor type is "\{0\}.”

#### Symptoms
This notification is sent by the agent when the parent access point loses connection with its child.
**MESH_EXCESSIVEPARENTCHANGE**

<table>
<thead>
<tr>
<th>WCS Severity</th>
<th>Info.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Probable Causes</td>
<td>The parent access point lost connection with its child.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

**MIB Name** CISCO-LWAPP-MESH-MIB. ciscoLwappMeshExcessiveParentChange.

**WCS Message** MESH "{0}" changes parent frequently.

**Symptoms** This notification is sent by the agent if the number of parent changes for a given mesh access point exceeds the threshold. Each access point keeps count of the number of parent changes within a fixed time. If the count exceeds the threshold defined by c1MeshExcessiveParentChangeThreshold, then the child access point informs the controller.

**WCS Severity** Major.

**Probable Causes** The child access point has frequently changed its parent.

**Recommended Actions** None.

**MESH_POORSNR**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MESH-MIB. ciscoLwappMeshPoorSNR.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>MESH &quot;{0}&quot; has SNR on backhaul link as &quot;{1}&quot; which is lower then predefined threshold.</td>
</tr>
<tr>
<td><strong>Symptoms</strong></td>
<td>This notification is sent by the agent when the child access point detects a signal-to-noise ratio below 12dB the backhaul link. The alarm includes the SNR value and the MAC addresses of the parent and child.</td>
</tr>
<tr>
<td><strong>WCS Severity</strong></td>
<td>Major.</td>
</tr>
<tr>
<td><strong>Probable Causes</strong></td>
<td>SNR is lower then the threshold defined by c1MeshSNRThreshold.</td>
</tr>
<tr>
<td><strong>Recommended Actions</strong></td>
<td>None.</td>
</tr>
</tbody>
</table>

**MESH_POORSNRCLEAR**

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MESH-MIB. ciscoLwappMeshPoorSNRClear.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>MESH &quot;{0}&quot; has SNR on backhaul link as &quot;{1}&quot; which is normal now.</td>
</tr>
<tr>
<td><strong>Symptoms</strong></td>
<td>This notification is sent by the agent to clear ciscoLwappMeshPoorSNR when the child access point detects SNR on the backhaul link that is higher than the threshold defined by c1MeshSNRThreshold.</td>
</tr>
<tr>
<td><strong>WCS Severity</strong></td>
<td>Info.</td>
</tr>
</tbody>
</table>
### MESH_CONSOLELOGIN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-MESH-MIB. ciscoLwappMeshConsoleLogin.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>MESH &quot;{0}&quot; has console logged in with status &quot;{1}&quot;</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is sent by the agent when login on the MAP console is successful or when a failure occurred after three attempts.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Login on the MAP console was successful, or a failure occurred after three attempts.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### LRADIF_REGULATORY_DOMAIN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappApIfRegulatoryDomainMismatchNotif</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Access Point &quot;{0}&quot; is unable to associate. The Regulatory Domain &quot;{1}&quot; configured on interface &quot;{2}&quot; does not match the controller &quot;{3}&quot; regulatory domain &quot;{4}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The system generates this trap when the regulatory domain configured on the access point radios does not match the country code configured on the controller.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>If the controller’s country code configuration is changed, and some access points support a different country code, then these access points fail to associate. An access point on the controller’s network sends join requests to the controller, but the regulatory domain is outside the domain in which the controller is operating.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Either remove the access points that are not meant for inclusion in the controller’s domain or correct the controller’s country code setting.</td>
</tr>
</tbody>
</table>

### LRAD_CRASH

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>ciscoLwappApCrash</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Access Point &quot;{0}&quot; crashed and has a core dump on controller &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>An access point has crashed.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
</tbody>
</table>
### Alarm and Event Dictionary

<table>
<thead>
<tr>
<th>Alarm/Event</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>LRAD_UNSUPPORTED</strong></td>
<td>Access point failure.</td>
</tr>
<tr>
<td><strong>Probable Causes</strong></td>
<td>Access point failure.</td>
</tr>
<tr>
<td><strong>Recommended Actions</strong></td>
<td>Capture the core dump file using the controller’s CLI and send it to TAC support.</td>
</tr>
</tbody>
</table>

### Traps Added or Updated in Release 4.2

#### GUEST_USER_ADDED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>CISCO-LWAPP-WEBAUTH-MIB. cLWAGuestUserAdded</strong></td>
<td>Guest user &quot;{0}&quot; created on the controller &quot;{1}&quot;.</td>
</tr>
<tr>
<td><strong>WCS Message</strong></td>
<td>This notification is sent by the agent when the GuestUser account is created successfully.</td>
</tr>
<tr>
<td><strong>Symptoms</strong></td>
<td>The guest user account was created on the agent by either CLI, Web UI, or WCS.</td>
</tr>
<tr>
<td><strong>Recommended Actions</strong></td>
<td>None.</td>
</tr>
</tbody>
</table>

#### GUEST_USER_AUTHENTICATED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>CISCO-LWAPP-WEBAUTH-MIB. cLWAGuestUserLogged</strong></td>
<td>Guest user &quot;{0}&quot; logged into controller &quot;{1}&quot;.</td>
</tr>
<tr>
<td><strong>WCS Message</strong></td>
<td>This notification is sent by the agent when the GuestUser logged into the network through webauth successfully.</td>
</tr>
<tr>
<td><strong>Symptoms</strong></td>
<td>The guest user was successful with webauth authentication.</td>
</tr>
<tr>
<td><strong>Recommended Actions</strong></td>
<td>None.</td>
</tr>
</tbody>
</table>
## IOSAP_LINK_UP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>linkUp</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Autonomous AP “{0},” Interface “{1}” is {2} up.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The physical link is up on an autonomous access point radio port.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A physical link has been restored to the autonomous access point.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## IOSAP_LINK_DOWN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>linkDown</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Autonomous AP “{0},” Interface “{1}” is {2} down.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The physical link is down on an autonomous access point radio port.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The radio port of an autonomous access point was disabled manually or a port failure occurred.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Check the administrative status of the port. If the port administrative status is not down, check other port settings.</td>
</tr>
</tbody>
</table>

## IOSAP_UP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>The autonomous AP “{0}” is reachable.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The autonomous AP is SNMP reachable.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The autonomous access point starts to respond to SNMP queries.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

## IOSAP_DOWN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Autonomous AP “{0}” is unreachable.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>The autonomous AP is SNMP unreachable.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Critical.</td>
</tr>
</tbody>
</table>
### WCS_EMAIL_FAILURE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>WCS with IP Address “{0}” failed to send e-mail.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS when it fails to send e-mails.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The SNMP server is either not configured or not reachable from WCS.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Check Administration &gt; Settings &gt; Mail Server settings. Send a test e-mail from the mail server settings to see if it is successful.</td>
</tr>
</tbody>
</table>

### AUDIT_STATUS_DIFFERENCE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Switch “{0}” Audit done at “{1}.” Config differences found between WCS and controller.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS when audit differences are detected while auditing a controller during a network audit background task or per controller audit.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Minor.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The WCS and controller configuration are not synchronized.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Refresh the configuration from the controller so that it synchronizes with the controller configuration on WCS.</td>
</tr>
</tbody>
</table>
## ROGUE_AP_NOT_ON_NETWORK

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>bsnRogueAPDetectedOnWiredNetwork (bsnRogueAPOnWiredNetwork is set to false).</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Rogue AP or rogue adhoc &quot;{0}&quot; is not able to connect to the wired network.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>A rogue access point is no longer on the wired network.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The rogue access point is no longer reachable on the wired network.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>
## Traps Added or Updated in Release 5.0

### GUEST_USER_LOGOFF

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-WEBAUTH-MIB. cLWAGuestUserLoggedOut</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Guest user “{1}” logged out from the controller “{0}.”</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is sent by the agent when a GuestUser who was previously logged into the network logs out.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Informational.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The GuestUser logs off from the network.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### WCS_NOTIFICATION_FAILURE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>WCS with IP Address “{0}” failed to send notification.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS when a notification sent to a northbound receiver fails. Currently only guest user related notifications (such as creation, deletion, log in, and log off) can be sent to a northbound receiver.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The notification receiver is either not configured or not reachable from WCS.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Check Administration &gt; Settings &gt; Notification Receiver settings. Make sure the server IP is correct, and the server is reachable from WCS.</td>
</tr>
</tbody>
</table>

### WCS_LOW_DISK_SPACE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>WCS “{0}” does not meet the minimum hardware requirements for disk space. Available: “{3}.” Minimum requirement: “{4}” Mb.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS when the free disk space where WCS is installed does not meet minimum hardware requirements. This event is of major severity if minimum requirements are not met. This event is of critical severity when the available disk space is less than half of the minimum requirement.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major/Critical.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The disk is out of free space.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Free up disk space.</td>
</tr>
</tbody>
</table>
### WCS_OK_DISK_SPACE

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>WCS &quot;{0}&quot; meets the minimum hardware requirements for disk space. Available: &quot;{3}&quot;. Minimum requirement: &quot;{4}&quot; Mb.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS when the free disk space where WCS is installed has met the minimum hardware requirements.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A low disk space condition has been cleared.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### WCS_LOW_DISK_SPACE_BACKUP

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>WCS &quot;{0}&quot; does not have sufficient disk space in directory &quot;{1}&quot; for backup. Space needed: &quot;{2}&quot;. space free: &quot;{3}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS when a previously created WCS_LOW_DISK_SPACE_BACKUP event is cleared or when the disk contains enough space for a backup.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Clear.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>A low disk space condition has been cleared.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>None.</td>
</tr>
</tbody>
</table>

### STATION_ASSOCIATE_DIAG_WLAN

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>CISCO-LWAPP-DOT11-CCX-CLIENT-MIB.cldccDiagClientAssociated-ToDiagWlan</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Client &quot;{0}&quot; is associated to diagnostic WLAN with reason &quot;{1}&quot;.</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is sent by the agent when a v5 client associates to a diagnostic channel.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>When a CCXv5 client gets associated to the diagnostic channel WLAN on WLC, this trap is raised.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>If you wish to automatically perform client troubleshooting, you must enable Client Troubleshooting in Administration &gt; Settings &gt; client. After it is enabled, the series of V5 tests are carried out on the client upon trap arrival, and the client is updated with the test status via pop-up messages. The report is placed in the logs directory. The log filename is shown in the Client Details page in the Automated Troubleshooting Report section. You can export all automated troubleshooting logs.</td>
</tr>
</tbody>
</table>
## WLAN_SHUT_FAILED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Wlan “{0}” shutdown failed on controller “{1}.”</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS during scheduled operations for a given WLAN Config object. It notifies the user that the WLAN status did not change at the scheduled time.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The controller for the selected WLAN is not reachable, or the WLAN object does not exist.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Check the WCS logs at the time of event generation and verify if the WLAN exists on the controller.</td>
</tr>
</tbody>
</table>

## WLAN_SHUT_SUCCESS

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Wlan “{0}” successfully shutdown on controller “{1}.”</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS during scheduled operation for each given WLAN configuration object. It notifies the user that the admin status has been successfully completed.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>Verify the admin status for the displayed WLAN on the controller.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Remove the event from the event list page.</td>
</tr>
</tbody>
</table>
### RADIO_SHUT_FAILED

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Radio shutdown failed for AP “{0}” connected to controller “{1}.”</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS during a scheduled operation for a given list of access point radios. It notifies the user that the status for certain radios has failed to change.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Major.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>The controllers for the selected access point are not reachable, or the radio configurations are changed on the controller.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Check the WCS logs at the time of event generation and verify that the access point is associated with the controller.</td>
</tr>
</tbody>
</table>

### RADIO_SHUT_SUCCESS

<table>
<thead>
<tr>
<th>MIB Name</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCS Message</td>
<td>Radio successfully shutdown for AP “{0}” connected to controller “{1}.”</td>
</tr>
<tr>
<td>Symptoms</td>
<td>This notification is generated by WCS during scheduled operation for a given list of access point radios. It notifies the user that the admin status has been successfully changed.</td>
</tr>
<tr>
<td>WCS Severity</td>
<td>Info.</td>
</tr>
<tr>
<td>Probable Causes</td>
<td>None.</td>
</tr>
<tr>
<td>Recommended Actions</td>
<td>Verify the status of the specified radio on the controller.</td>
</tr>
</tbody>
</table>

### Unsupported Traps

- BROADCAST_STORM_START: broadcastStormStartTrap
- FAN_FAILURE: fanFailureTrap
- POWER_SUPPLY_STATUS_CHANGE: powerSupplyStatusChangeTrap
- BROADCAST_STORM_END: broadcastStormEndTrap
- VLAN_REQUEST_FAILURE: vlanRequestFailureTrap
- VLAN_DELETE_LAST: vlanDeleteLastTrap
- VLAN_DEFAULT_CFG_FAILURE: vlanDefaultCgfFailureTrap
- VLAN_RESTORE_FAILURE_TRAP: vlanRestoreFailureTrap
- IPSEC_ESP_AUTH_FAILURE: bsnIpsecEspAuthFailureTrap
- IPSEC_ESP_REPLAY_FAILURE: bsnIpsecEspReplayFailureTrap
- IPSEC_ESP_INVALID_SPI: bsnIpsecEspInvalidSpiTrap
- LRAD_UP: bsnAPUp
- LRAD_DOWN: bsnAPDown
- STP_NEWROOT: stpInstanceNewRootTrap
- STP_TOPOLOGY_CHANGE: stpInstanceTopologyChangeTrap
Running Reports

WCS reporting is necessary to monitor the system and network health as well as troubleshoot problems. A number of reports can be generated to run on an immediate and scheduled basis. Each report type has a number of user-defined criteria to aid in the defining of the reports. The reports are formatted as a summary, tabular, or graphical layout. Once defined, the reports can be saved for future diagnostic use or scheduled to run and report on a regular basis.

Reports are saved in either CSV or PDF format and are either saved to a file on WCS for later download or e-mailed to a specific e-mail address.

The reporting types include the following:

- Current, which provides a snapshot of the data from the last polling cycle without continuously polling
- Historical, which retrieves data from the device periodically and stores it in the WCS database
- Trend, which generates a report using aggregated data. Data can be periodically collected based from devices on user-defined intervals, and a schedule can be established for report generation

With WCS, you also have the ability to export any report that you can view, sort reports into logical groups, and archive for long-term storage.

Note

If you want the report to print as it appears on the window display, you must choose landscape mode.

From the Reports menu, you can access any of the following types:

- Access Point Reports, page 14-4
- Audit Reports, page 14-5
- Client Reports, page 14-7
- Inventory Reports, page 14-8
- Mesh Reports, page 14-10
- Performance Reports, page 14-12
- Security Reports, page 14-13
Choosing a Report

If you choose one of the above options from the Reports menu, a window with a list of created report tasks appears. Perform one of the following operations:

- If you want to enable or disable a report schedule, refer to the “Enabling or Disabling a Schedule” section on page 14-2.
- If you want to delete a report, refer to the “Deleting a Report” section on page 14-3.
- If no reports are defined, you can create a report by selecting New from the Select a command menu. After clicking GO, two new panels appear: General and Schedule. The General panel allows you to configure data gathering parameters. The Schedule panel allows you to control when and how often the report runs, based on what you specify. Refer to the “Accessing the Schedule Panel” section on page 14-3.

After running the report, a Results tab shows the report data (see Figure 14-1).

Figure 14-1  Results Tab

A History Tab appears after some scheduled executions have occurred.

Enabling or Disabling a Schedule

To enable a defined report, check the check box next to the report and select Enable Schedule from the Select a command menu. Click GO. If the scheduled time period for the report has passed, then Expired appears in the Schedule column. To remedy, click the report title and enter new time parameters in the window that appears.

To disable a defined report, check the check box next to the report and select Disable Schedule from the Select a command menu. Click GO. The disabled state appears in the Schedule column.
Deleting a Report

To delete a defined report, check the check box next to the report and select **Delete** from the Select a command menu and click **GO**. The report is deleted from the listing.

Accessing the Schedule Panel

The schedule panel is the same for any report. After choosing the Schedule tab, the Schedule window appears (see **Figure 14-2**).

**Figure 14-2    Schedule Tab**

Follow these steps after choosing the **Schedule** tab within any report type.

**Step 1**  Check the **Enable Schedule** check box.

**Step 2**  Specify if you want the export format to be .csv (a file containing the MAC addresses of access points) or .pdf from the Export Format drop-down menu.

**Step 3**  Choose either the **Save to File** or **E-mail To** option as the destination type.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- If you select the Save to File option, a destination path must first be defined at the **Administration > Settings > Report** page. Enter the destination path for the files in the Repository Path field.
- If you select the E-mail to option, an SMTP Mail Server must be defined prior to entry of the target e-mail address. Choose **Administrator > Settings > Mail Server** to enter the appropriate information.

**Step 4**  Enter a start date (MM:DD:YYYY format) in the provided field or click the calendar icon to select a date. The report begins running on this date.

**Step 5**  Specify a start time using the hour and minute drop-down menus.

**Step 6**  Click on one of the recurrence buttons to select how often the report is run.
Step 7 When entry is complete, do one of the following:

- Click **Save** to save the entry.
- Click **Save and Run** to save the changes and run the report now. The report is run, and the results are either e-mailed or saved to a designated file as defined in the Schedule tab. The report runs again at the scheduled time.
- Click **Run Now** if you want to run the report immediately and review the results in the WCS window. The report runs regardless of any scheduled time associated with the report.

**Note** You can use the Run command to check a report scenario before saving it or to run ad hoc reports as necessary.

### Access Point Reports

In the left sidebar menu, all of the access point report options are listed.

**Note** The access point reports do not show the status of autonomous access points.

The choices are as follows:

- **AP List by Location and SSID Report**—Displays information on access points located in specific physical areas and specific SSIDs.
- **AP Profile Status Report**—Displays information on access points located in specific physical areas and with specific SSIDs.
- **AP Up Times**—This report displays various up time information for access points. You can choose between AP up time, LWAPP up time, and LWAPP join time and then sort the report from lowest-to-highest up times or from highest-to-lowest up times. The generated data that is returned includes which access points have been up for the longest time and which have been up for the shortest time. The report also displays the access point and map location if applicable.
- **Busiest APs Report**—Allows you to view information on the busiest access points in terms of total utilization. The total utilization is the sum of transmitting, receiving, and channel utilization.
- **Traffic Stream Metrics Report**—Shows voice traffic stream metrics and high density related reports. The controller keeps multiple records of the voice metrics data for each client. The access points update the controller with traffic stream metric information every 90 seconds, and 10 minutes of data is stored at one time to generate an on-demand report. WCS polls the data from the controllers and aggregates it as hourly, daily, and weekly. The generated data that is returned includes but is not limited to the following: the level of QoS, the percentage of packet loss ratio on the downlink and uplink, and any queuing delays.
- **Graphical Traffic Stream Metrics Report**—The Traffic Streams Metrics (Graphs) report is equivalent to the Traffic Streams Report, but the information is displayed in graph form.

### Viewing or Modifying Access Point Reports

Follow these steps to view or modify existing access point reports.
Step 1  Choose Reports > Access Point Reports. The Access Point Report page appears.
Step 2  Choose the Access Point Report type from the left panel.
Step 3  Define (or modify) the conditions for the report in the General panel.
Step 4  Refer to the “Accessing the Schedule Panel” section on page 14-3 to complete the scheduling process.
Step 5  Click the History tab if you want to review details of the current and past runs of the report.

Creating a New Access Point Report

Follow these steps to create a new access point report.

Note  Some of these steps or options are not required for every report.

Step 1  Choose Reports > Access Point Reports. The Access Point Reports page appears.
Step 2  Click on one of the report types summarized under Access Points Reports (left-side).
Step 3  Choose New from the Select a command drop-down menu and click GO.
Step 4  Specify a report title.
Step 5  Use the Report By drop-down menu to choose of which physical area to report. The following options are available:
   • AP By Outdoor Area—Generates the report of the outdoor area on a per-access point basis.
   • AP by Floor Area—Generates the report of the floor area on a per-access point basis.
Step 6  Perform one of the following:
   If you chose outdoor, you need to specify in which campus and outdoor area it is located.
   If you chose floor area, you need to choose in which campus, building, and floor the area is located.
Step 7  Determine which access points you want to include in the report.
Step 8  Specify if you want to include 802.11a/n or 802.11b/g/n radios in the report.
Step 9  Click the Schedule tab to complete the scheduling process. Refer to the “Accessing the Schedule Panel” section on page 14-3.

Audit Reports

Network configuration audit reports give information about the audit status of the controllers along with details on the configuration differences between the WCS and controllers. Data for this report is collected by the Network Audit Configuration task which is enabled by default on a newly installed WCS system and is scheduled to run once every 7 days. To change the frequency of the background task, refer to the “Running Background Tasks” section on page 15-2. The report shows the audit status for each controller and shows the attribute differences in the configurations. Even controllers which are not
reachable during the network audit configuration task are listed. The authorization for the audit reports is tied into the security framework so that only certain users can have access. By default, the admin, configManagers, system monitoring, superusers, and root users have access.

**Note**  
The Audit Reports do not show the status of autonomous access points.

### Viewing or Modifying Audit Reports

Follow these steps to view or modify existing audit reports.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Choose <strong>Reports &gt; Audit Reports</strong>. The Audit Report page appears.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Choose the Audit Report type from the left panel.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Define (or modify) the conditions for the report in the General panel.</td>
</tr>
</tbody>
</table>

**Note**  
Even controllers that are not audited or not reachable are listed on the report.

| Step 4 | Refer to the “Accessing the Schedule Panel” section on page 14-3 to complete the scheduling process. |
| Step 5 | Click the **History** tab if you want to review details of the current and past runs of the report. |

### Creating a New Network Configuration Audit Report

Follow these steps to create a new audit report.

| Step 1 | Choose **Reports > Audit Reports**. The Audit Reports page appears. |
| Step 2 | Click on one of the report types summarized under Audit Reports (left-side). Currently only one network configuration audit report is available. |

**Note**  
With a clean install, Background Tasks > Network Audit is enabled.

| Step 3 | Select **New** from the Select a command menu. Click **GO**. The two-tabbed entry panel appears. |
| Step 4 | Specify a report title. |
| Step 5 | Specify if you want the report to include all controllers or a selected controller. |
| Step 6 | From the Audit Time drop-down menu, determine if you want to view the latest report or choose from a network audit time. Audit time is the time when the network audit background task was excluded. **Latest** is the default selection. |
| Step 7 | Click the **Schedule** tab to complete the scheduling process. Refer to the “Accessing the Schedule Panel” section on page 14-3. |
Client Reports

You can run reports of all unique clients that have accessed the network for a specified duration. For example, you may want to show all clients that were on a certain floor in the last three days and see detailed information network activity.

Note
The Client Count report is the only client reports that shows the status of autonomous access points.

The client report options are as follows:

- Busiest Clients Report—Displays information on the busiest clients in terms of total throughput of clients during a given period of time.
- Client Association Report—Shows a detailed association history of the clients as collected from the controller. The generated data that is returned includes but is not limited to the following: the username and MAC address of the client, which access point it is associated with, and a status.
- Client Count Report—Displays data on the numbers of clients that connected to the network through a specific device, in a specific geographical region, or through a specific SSID.
- Traffic Stream Metrics Report—Shows voice traffic stream metrics and high density related reports for clients. The controller keeps multiple records of the voice metrics data for each client. The generated data that is returned includes but is not limited to the following: the level of QoS, the percentage of packet loss ratio on the downlink and uplink, and any queuing delays.
- Unique Client Report—Shows which unique clients have accessed the network within a specified duration. For example, you could show all clients on a particular floor in the last three days and view detailed information about their network activity. The generated data that is returned includes but is not limited to the following: the vendor and MAC address of the client, which access point it is associated to, and the Cisco Compatible Extensions version supported by the client.
- V5 Client Statistics Report—Collects client statistics for V5 clients and above that are in an associated and authenticated state. The report contains counters for a Dot11 statistics measurement and a security statistics measurement. If V5 clients exist, a request is initiated for Dot11 measurement; and if the request is successful, the database is populated with the Dot11 response for the client. Then the security request is initiated and if successful, the database is populated with the security response for the client.

Viewing or Modifying Client Reports

Follow these steps to view or modify existing client reports.

Step 1 Choose Reports > Client Reports. The Client Report page appears.
Step 2 Choose the Client Report type from the left panel.
Step 3 Define (or modify) the conditions for the report in the General panel.
Step 4 Refer to the “Accessing the Schedule Panel” section on page 14-3 to complete the scheduling process.
Step 5 Click the History tab if you want to review details of the current and past runs of the report.

Creating a New Client Report

Follow these steps to create a new client report.

**Note** Some of these steps or options are not required for every report.

Step 1 Choose Reports > Client Reports. The Client Reports page appears.
Step 2 Click on one of the report types summarized under Client Reports (left-side).
Step 3 Choose New from the Select a command drop-down menu and click GO. The two-tabbed entry panel appears.
Step 4 Specify a report title.
Step 5 Enter the number of clients you want displayed in the report.
Step 6 Choose ALL SSIDs or choose a specific SSID to restrict the report to access points using that SSID.
Step 7 Enter a specific client MAC address. If no MAC address is specified, then all the clients per specified SSID would be reviewed.
Step 8 Specify if you want the report listed by controller, floor area, outdoor area, AP by floor, AP by outdoor area, or SSID. The floor area and outdoor area report generates the report on an area basis while the AP by floor or AP by outdoor area generates the report on a per-access point basis.
Step 9 If you chose controller, you need to enter a controller IP address.
If you chose floor area or AP by floor area, you need to enter the campus, building, and floor location. If you chose outdoor area or AP by outdoor area, you need to enter the campus and outdoor area.
Step 10 Determine which access points you want to include in the report.
Step 11 Specify if you want to include 802.11a/n or 802.11b/g/n radios in the report.
Step 12 In the Reporting Period section, choose Last to determine the timeframe the report should encompass or choose Between and use the calendar icon to choose a date and set the hour and minutes.
Step 13 Click the Schedule tab to complete the scheduling process. Refer to the “Accessing the Schedule Panel” section on page 14-3.

Inventory Reports

In the left sidebar menu, all of the inventory report options are listed. These reports are generated based on the data already stored in the WCS database. Because inventory reports are not on-demand reports, some configuration changes may have occurred since the storage and may not duplicate the attributes of the controller that are reflected in the stored data.
### Inventory Reports

The inventory reports do not show the status of autonomous access points.

The choices are as follows:

- **Access Point Inventory Report**—Provides data on deployed access points. The data that is returned includes but is not limited to the following: the access points’ MAC address, model, location, and radio status.

- **Combined Inventory Report**—Provides data on all deployed controllers, access points, and location appliances.

- **Controller Report**—Provides data on deployed controllers. The data that is returned includes but is not limited to the following: the model, IP address, and serial number of the controller, what software version it is running, and where it is located.

- **Location Server Report**—Provides data on deployed location appliances. The data that is returned includes but is not limited to the following: the IP address and version of the location appliance, which port is being used, and the time the appliance starts up.

### Viewing or Modifying Inventory Reports

Follow these steps to view or modify existing inventory reports.

**Step 1** Choose **Reports > Inventory Reports**. The Inventory Reports page appears.

**Step 2** Choose the Inventory Report type from the left panel.

**Step 3** Define (or modify) the conditions for the report in the General panel.

**Step 4** Refer to the “Accessing the Schedule Panel” section on page 14-3 to complete the scheduling process.

**Step 5** Click the **History** tab if you want to review details of the current and past runs of the report.

### Creating a New Inventory Report

Follow these steps to create a new inventory report.

**Note** Some of these steps or options are not required for every report.

**Step 1** Choose **Reports > Inventory Reports**. The Inventory Reports page appears.

**Step 2** Click on one of the report types summarized under Inventory Reports (left-side).

**Step 3** Choose **New** from the Select a command drop-down menu and click **GO**. The two-tabbed entry panel appears.

**Step 4** Specify a report title.

**Step 5** Click the **Schedule** tab to complete the scheduling process. Refer to the “Accessing the Schedule Panel” section on page 14-3.
Mesh Reports

Mesh reports are used to analyze and diagnose mesh networks. In the left sidebar menu, all of the mesh report options are listed.

Note

The mesh reports do not show the status of autonomous access points.

The following reports can be generated for 1510 mesh access points.

- Mesh Alternate Parent—Lists the number of alternate parents available for a mesh access point. A value of zero (0) indicates the mesh access point has no alternate parents.
- Mesh Link Stats—Lists link statistics for a mesh access point such as packets transmitted, packet error rate, parent changes, SNR, and hops from the root access point.
- Mesh Node Hops—Lists the number of hops between a mesh access point and its root access point.
- Mesh Packet Error Statistics—Notes the percentage of packet errors for packets transmitted by the neighbor mesh access point. Packet error rate percentage = 1- (number of successfully transmitted packets/number of total packets transmitted).
- Mesh Packet Queue Statistics—Generates a graph of the total number of packets transmitted and the total number of packets successfully transmitted by the neighbor mesh access point.
- Mesh Packet Statistics—Generates a graph of packet queue statistics for each access point selected and for each report type selected. The report types are Packet Queue Average, Packets Dropped Per Minute, and Packet Dropped Count. The Packet Queue Average report shows the average number of packets for each queue when the MIB was polled. The Packets Dropped Per Minute report shows the number of packets dropped since the last sample divided by the number of minutes since the sample. The Packet Dropped Count contains the counter for the number of packets dropped.
- Mesh Stranded APs—Displays any potentially stranded access points. A stranded access point is one listed as a mesh neighbor but not currently joined with a controller or one joined with a controller known by WCS but no longer seen by a mesh neighbor. The report displays all current access points believed to be stranded and lists the current detecting access points (the last set of access points detecting the device when the access point is not seen by any mesh neighbor). The report also displays the state of the stranded access point. As determined by WCS, the three states are:
  - Detected and Never Associated: An access point which has never joined a controller and is being detected as a neighbor.
  - Not Detected and Previously Associated: An access point which has associated to a controller at one time but is no longer associated. No mesh access points are detecting this access point as a neighbor.
  - Detected and Not Associated: An access point which has associated to a controller at one time but is no longer associated. A neighbor access point is detecting this access point.
- Mesh Worst Node Hops—Lists mesh access points by name and MAC address and notes those that are 10 hops (default) away from the root access point. Number of hops can be modified.
- Mesh Worst SNR Links—Lists the 10 (default) mesh access point-to-neighbor links that exhibit the worst signal-to-noise ratio (SNR). You can change the number of links to display.
Viewing or Modifying Mesh Reports

Follow these steps to view or modify existing inventory reports.

Step 1  Choose Reports > Mesh Reports. The Mesh Reports page appears.
Step 2  Choose the Mesh Report type from the left panel.
Step 3  Define (or modify) the conditions for the report in the General panel.
Step 4  Refer to the “Accessing the Schedule Panel” section on page 14-3 to complete the scheduling process.

Creating a New Mesh Report

Follow these steps to create a new mesh report.

Note  Some of these steps or options are not required for every report.

Step 1  Choose Reports > Mesh Reports. The Mesh Reports page appears.
Step 2  Click on one of the report types summarized under Mesh Reports (left-side).
Step 3  Select New from the Select a command menu. Click GO. The two-tabbed entry panel appears.
Step 4  Specify a report title.
Step 5  If you want to report more items than the default setting, enter a new value. For example, you could enter a new value at the Mesh Worst SNR Links field which is currently configured by default to report the 10 worst links.
Step 6  Specify if you want the report listed by controller, floor area, outdoor area, AP by floor, AP by outdoor area, or SSID. The floor area and outdoor area report generates the report on an area basis while the AP by floor or AP by outdoor area generates the report on a per-access point basis.
Step 7  If you chose controller, you need to enter a controller IP address.
If you chose floor area or AP by floor area, you need to enter the campus, building, and floor location.
If you chose outdoor area or AP by outdoor area, you need to enter the campus and outdoor area.
Step 8  If necessary, enter which access points to include in the report.
Step 9  Select the neighbor type and display option (table or graph).
Step 10  At the Graph Type parameter, choose either packet count or packets per minute.
Step 11  Enter the reporting period for the report. You can define the report to collect data for an hourly or weekly period or select a specific date and time range for reporting.

Note  Hours are defined on a 24-hour basis rather than a 12-hour basis with AM and PM. For example, select hour 13 for 1 PM.

Step 12  Click the Schedule tab to complete the scheduling process. Refer to the “Accessing the Schedule Panel” section on page 14-3.
Performance Reports

In the left sidebar menu, all of the performance report options are listed.

**Note**

Performance reports do not show the status of autonomous access points.

The choices are as follows:

- **802.11 Counters Report**—Shows a graph of data transmission and reception information for access point 802.11 interfaces based on the parameters you selected for the 802.11 counters.
- **Controller Utilization Report**—Shows a report of all controller memory and CPU utilization at configurable intervals.
- **Coverage Hole Summary Report**—Provides a summary of all coverage hole alarms by access point, floor, etc. This report helps troubleshoot where coverage issues occurred with the client. The data that is returned includes but is not limited to the following: the base radio MAC address of the alarming access point, the radio type, and the coverage threshold.
- **Location Server Utilization**—Provides all location appliance memory and CPU utilization at configurable intervals. The data that is returned includes but is not limited to the following: the radio type, channel number, and average RSSI value.
- **Radio Utilization Report**—Shows all utilization of the radio at configurable times.
- **Tx Power Level and Channel Report**—Shows all transmit power level and channel number changes seen by access points, by a given floor, etc. The data that is returned includes but is not limited to the following: the transmit power level for 802.11a/n and 802.11b/g/n interfaces, the channel number used for 802.11a/n and 802.11b/g/n interfaces, and the grouping types.
- **Voice Statistics Report**—Shows radio utilization of voice traffic for selected access points.

### Viewing or Modifying Performance Reports

Follow these steps to view or modify existing performance reports.

**Step 1** Choose **Reports > Performance Reports**. The Performance Reports page appears.

**Step 2** Choose the Performance Report type from the left panel.

**Step 3** Define (or modify) the conditions for the report in the General panel.

**Step 4** Refer to the “Accessing the Schedule Panel” section on page 14-3 to complete the scheduling process.

**Step 5** Click the **History** tab if you want to review details of the current and past runs of the report.

### Creating a New Performance Report

Follow these steps to create a new performance report.

**Note**

Some of these steps or options are not required for every report.
Step 1 Choose Reports > Performance Reports. The Performance Reports page appears.

Step 2 Click on one of the report types summarized under Performance Reports (left-side).

Step 3 Choose New from the Select a command drop-down menu and click GO. The two-tabbed entry panel appears.

Step 4 Specify a report title.

Step 5 Specify if you want the report listed by controller, floor area, outdoor area, AP by floor, AP by outdoor area, or SSID. The floor area and outdoor area report generates the report on an area basis while the AP by floor or AP by outdoor area generates the report on a per-access point basis.

Step 6 If you chose controller, you need to enter a controller IP address.
   If you chose floor area or AP by floor area, you need to enter the campus, building, and floor location.
   If you chose outdoor area or AP by outdoor area, you need to enter the campus and outdoor area.

Step 7 If necessary, enter which access points or location server to include in the report.

Step 8 Specify if you want to include 802.11a/n or 802.11b/g/n radios.

Step 9 Enter the reporting period for the report. You can define the report to collect data for an hourly or weekly period or choose a specific date and time range for reporting.

Step 10 Click the Schedule tab to complete the scheduling process. Refer to the “Accessing the Schedule Panel” section on page 14-3.

Security Reports

In the left sidebar menu, all of the security report options are listed. The security reports display information about the security of the wireless network.

Note: Security reports do not show the status of autonomous access points.

The choices are as follows:

- New Rogue APs—Displays, in tabular form, all rogues detected in a selected timeframe. It provides which new rogues were detected within a selected time. The created time indicates the time at which the rogue was first detected.
- New Rogue AP Count—Displays, in graphical form, all rogues detected in a selected timeframe.
- Rogue APs—Displays all rogues that are active in your network and have been updated in the selected timeframe. WCS receives updated events for rogues that are detected.
- Rogue APs Event—Displays all the events received by WCS. The controller sends updates of detected rogues if any of the attributes change or new rogues are detected.

Note: This report was formally called the Rogue Detected by AP.

- Rogue Adhocs—Displays all adhocs that have been updated in the selected timeframe.
- Rogue Adhocs Event—Displays all adhoc events that WCS has received in the selected timeframe.
- Security Summary Report—Shows the number of association failures, rogues access points, adhocs, and access point connections or disconnections over one month.
Viewing or Modifying Security Reports

Follow these steps to view or modify existing security reports.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Choose Reports &gt; Security Reports. The Security Reports page appears.</td>
</tr>
<tr>
<td>2</td>
<td>Choose the Security Report type from the left panel.</td>
</tr>
<tr>
<td>3</td>
<td>Define (or modify) the conditions for the report in the General panel.</td>
</tr>
<tr>
<td>4</td>
<td>Refer to the “Accessing the Schedule Panel” section on page 14-3 to complete the scheduling process.</td>
</tr>
<tr>
<td>5</td>
<td>Click the History tab if you want to review details of the current and past runs of the report.</td>
</tr>
</tbody>
</table>

Creating a New Security Report

Follow these steps to create a new security report.

Note: Some of these steps or options are not required for every report.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Choose Reports &gt; Security Reports. The Security Reports page appears.</td>
</tr>
<tr>
<td>2</td>
<td>Click on one of the report types summarized under Security Reports (left-side).</td>
</tr>
<tr>
<td>3</td>
<td>Choose New from the Select a command drop-down menu and click GO. The two-tabbed entry panel appears.</td>
</tr>
<tr>
<td>4</td>
<td>Specify a report title.</td>
</tr>
<tr>
<td>5</td>
<td>Specify if you want the report listed by controller, floor area, outdoor area, AP by floor, AP by outdoor area, or SSID. The floor area and outdoor area report generates the report on an area basis while the AP by floor or AP by outdoor area generates the report on a per-access point basis.</td>
</tr>
<tr>
<td>6</td>
<td>If you chose controller, you need to enter a controller IP address. If you chose floor area or AP by floor area, you need to enter the campus, building, and floor location. If you chose outdoor area or AP by outdoor area, you need to enter the campus and outdoor area.</td>
</tr>
<tr>
<td>7</td>
<td>If necessary, enter which access points or location server to include in the report.</td>
</tr>
<tr>
<td>8</td>
<td>Enter the reporting period for the report. You can define the report to collect data for an hourly or weekly period or choose a specific date and time range for reporting.</td>
</tr>
<tr>
<td>9</td>
<td>Click the Schedule tab to complete the scheduling process. Refer to the “Accessing the Schedule Panel” section on page 14-3.</td>
</tr>
</tbody>
</table>
This chapter describes administrative tasks to perform with WCS. These tasks include the following:

- Running Background Tasks, page 15-2 (such as database cleanup, location server synchronization, network audit, server backup)
- Performing a Task, page 15-2
- Importing Tasks Into ACS, page 15-4
- Setting AAA Mode, page 15-15
- Auto Provisioning, page 15-16
- Turning Password Rules On or Off, page 15-21
- Configuring TACACS+ Servers, page 15-22
- Configuring RADIUS Servers, page 15-23
- Establishing Logging Options, page 15-24
- Performing Data Management Tasks, page 15-25
- Establishing Logging Options, page 15-24
Running Background Tasks

Choose Administration > Background Tasks to view several scheduled tasks. The Background Tasks window appears (see Figure 15-1).

Figure 15-1  Background Tasks Window

You can view the administrative and operating status, task interval, and time of day in which the task occurs. To execute a particular task, click the check box of the desired task and choose Execute Now from the Select a command drop-down menu. The task executes based on what you have configured for the specific task.

Performing a Task

Follow these steps to perform a task (such as scheduling an automatic backup of the WCS database).

Note

All tasks related to collecting data or any other background task would be handled in a similar manner.

Step 1 Choose Administration > Background Tasks to display the Background Tasks page (see Figure 15-1).

Step 2 On this window, perform one of the following:

- Execute the task now.
  
  Click the check box of the task you want to execute. From the Select a command drop-down menu, choose Execute Now and click GO.

- Enable the task.
  
  Click the check box of the task you want to enable. From the Select a command drop-down menu, choose Enable Task and click GO. The task converts from grayed out to active after enabling is complete.
• Disable the task.

**Click the check box** of the task you want to disable. From the Select a command drop-down menu, choose **Disable Task** and click **GO**. The task is grayed out after the disabling is complete.

• View details of a task.

Click a URL in the Data Set column to view a specific task. The details on that task appear (see the figure in **Figure 15-2**).

---

**Note**

For this example, performing a WCS server backup was selected as the task. The screens and fields to enter on the detailed screens vary based on what task you choose.

---

**Figure 15-2**  **Detailed Background Task Window**

---

**Step 3**

Check the **Admin Status** check box to enable it.

**Step 4**

In the Max Backups to Keep field, enter the maximum number of backup files to be saved on the server.

- **Range:** 7 to 50
- **Default:** 7

**Note**

To prevent the WCS platform from running out of disk space, the server automatically deletes old backup files when the number of files exceeds the value entered for this field.

**Step 5**

In the Interval (Days) field, enter the number of days between each backup. For example, 1 = a daily backup, 2 = a backup every other day, 7 = a weekly backup, and so on.

- **Range:** 1 to 360
- **Default:** 7
Importing Tasks Into ACS

To import tasks into Cisco Secure ACS server, you must add WCS to an ACS server (or non-Cisco ACS server).

Adding WCS to an ACS Server

Follow these steps to add WCS to an ACS server.

**Note** The instructions and illustrations in this section pertain to ACS version 4.1 and may vary slightly for other versions or other vendor types. Refer to the CiscoSecure ACS documentation or the documentation for the vendor you are using.

**Step 1** Click **Add Entry** on the Network Configuration window of the ACS server (see Figure 15-3).
Figure 15-3  ACS Server Network Configuration Window

Step 2  In the AAA Client Hostname field, enter the WCS hostname.
Step 3  Enter the WCS IP address into the AAA Client IP Address field.
Step 4  In the Key field, enter the shared secret that you wish to configure on both the WCS and ACS servers.
Step 5  Choose TACACS+ in the Authenticate Using drop-down menu.
Step 6  Click Submit + Apply.

Adding WCS as a TACACS+ Server

Follow these steps to add WCS to a TACACS+ server.

Step 1  Go to the TACACS+ (Cisco IOS) Interface Configuration window (see Figure 15-4).
Chapter 15      Administrative Tasks

Figure 15-4   TACACS+ Cisco IOS Interface Configuration Window

Step 2 In the New Services portion of the window, add Wireless-WCS in the Service column heading.

Step 3 Enter HTTP in the Protocol column heading.

Note HTTP must be in uppercase.

Step 4 Click the check box in front of these entries to enable the new service and protocol.

Step 5 Click Submit.

Adding WCS UserGroups into ACS for TACACS+

Follow these steps to add WCS UserGroups into an ACS Server for use with TACACS+ servers.

Step 1 Log into WCS.

Step 2 Navigate to Administration > AAA > Groups. The All Groups window appears (see Figure 15-5).
Step 3 Click on the Task List URL (the Export right-most column) of the User Group that you wish to add to ACS. The Export Task List window appears (see Figure 15-6).
Step 4  Highlight the text inside of the TACACS+ Custom Attributes, go to your browser’s menu, and choose Edit > Copy.

Step 5  Log in to ACS.

Step 6  Go to Group Setup. The Group Setup window appears (see Figure 15-7).
Step 7  Choose which group to use and click **Edit Settings**. Wireless-WCS HTTP appears in the TACACS+ setting.

Step 8  Use your browser’s Edit > Paste sequence to place the TACACS+ custom attributes from WCS into this field.

Step 9  Click the checkboxes to enable these attributes.

Step 10  Click **Submit + Restart**.

You can now associate ACS users with this ACS group.

**Note**  To enable TACACS+ in WCS, refer to the “Configuring TACACS+ Servers” section on page 15-22.

---

**Adding WCS to ACS server for Use with RADIUS**

Follow these steps to add WCS to an ACS server for use with RADIUS servers. If you have a non-Cisco ACS server, refer to the “Adding WCS to a Non-Cisco ACS Server for Use with RADIUS” section on page 15-13.

Step 1  Go to Network Configuration on the ACS server (see Figure 15-8).
Step 2 Click Add Entry.

Step 3 In the AAA Client Hostname field, enter the WCS hostname.

Step 4 In the AAA Client IP Address field, enter the WCS IP address.

Step 5 In the Key field, enter the shared secret that you wish to configure on both the WCS and ACS servers.

Step 6 Choose RADIUS (Cisco IOS/PIX 6.0) from the Authenticate Using drop-down menu.

Step 7 Click Submit + Apply.

You can now associate ACS users with this ACS group.

Note To enable RADIUS in WCS, refer to the “Configuring RADIUS Servers” section on page 15-23.

Adding WCS UserGroups into ACS for RADIUS

Follow these steps to add WCS UserGroups into an ACS Server for use with RADIUS servers.

Step 1 Log into WCS.

Step 2 Navigate to Administration > AAA > Groups. The All Groups window appears (see Figure 15-9).
Step 3 Click on the Task List URL (the Export right-most column) of the User Group that you wish to add to ACS. The Export Task List window appears (see Figure 15-10).
Importing Tasks into ACS

Step 4  Highlight the text inside of the RADIUS Custom Attributes, go to your browser’s menu, and choose Edit > Copy.

Step 5  Log in to ACS.

Step 6  Go to Group Setup. The Group Setup window appears (see Figure 15-11).
Chapter 15     Administrative Tasks
Importing Tasks Into ACS

Figure 15-11     Group Setup Window on ACS Server

Step 7 Choose which group to use and click **Edit Settings**. Find [009]001]cisco-av-pair under Cisco IOS/PIX 6.x RADIUS Attributes.

Step 8 Use your browser’s Edit > Paste sequence to place the RADIUS custom attributes from WCS into this field.

Step 9 Click the checkboxes to enable these attributes.

Step 10 Click **Submit + Restart**.

You can now associate ACS users with this ACS group.

**Note**

To enable RADIUS in WCS, refer to the “Configuring RADIUS Servers” section on page 15-23.

---

**Adding WCS to a Non-Cisco ACS Server for Use with RADIUS**

When you use a RADIUS server to log into WCS, the AAA server sends back an access=accept message with a usergroup and a list of available tasks, after the username and password were verified. The access=accept message comes back as a fragmented packet because of the large number of tasks in some user groups. You can look in the following file to see the tasks associated with a given user group: C:\Program Files\WCS5.0\webnms\webacs\WEB-INF\security\usergroup-map.xml. The tasks are passed back as a vendor specific attribute (VSA), and WCS requires authorization information using the VSA (IETF RADIUS attribute number 26). The VSA contains the WCS RADIUS task list information (refer to Figure 15-12).
The content of the VSA is as follows:

- **Type = 26** (IETF VSA number)
- **Vendor Id = 9** (Cisco vendor ID)
- **Vendor Type = 1** (Custom attributes)
- **Vendor Data = The WCS task information** (for example Wireless-WCS: task0 = Users and Group)

Each line from the WCS RADIUS task list should be sent in its own RADIUS VSA.

In the data portion of the access=access packet, the truncated output sometimes shows only one role sent back for an Admin user group login. The tasks associated with the role start with task0 and increment with task1, task2, and so on. Table 15-1 defines what these attributes in the access=access packet example signify.

<table>
<thead>
<tr>
<th>Attribute Description</th>
<th>Vendor attribute</th>
</tr>
</thead>
<tbody>
<tr>
<td>2b (43 bytes in decimal)</td>
<td>Length as the total number of bytes to skip and still reach the next TLV (for task0, Users and Groups)</td>
</tr>
<tr>
<td>4-byte field</td>
<td>Vendor Cisco 09</td>
</tr>
<tr>
<td>01</td>
<td>Cisco AV pair - a TLV for WCS to read</td>
</tr>
<tr>
<td>25 (37 bytes in decimal)</td>
<td>Length</td>
</tr>
<tr>
<td>hex text string</td>
<td>Wireless-WCS:task0=Users and Groups</td>
</tr>
<tr>
<td>255.255.255.255</td>
<td>TLV: RADIUS type 8 (framed IP address)</td>
</tr>
</tbody>
</table>
To troubleshoot, perform the following steps:

- Verify if the RADIUS packet is an access accept.
- Verify the task names for the user group in the access accept.
- Look at the different length fields in the RADIUS packet.

### Setting AAA Mode

Follow these steps to choose a AAA mode.

**Step 1** Choose Administration > AAA.

**Step 2** Choose AAA Mode from the left sidebar menu. The AAA Mode Setting window appears (see Figure 15-13).

**Figure 15-13  AAA Mode Settings Window**

... (Figure content omitted for brevity)

**Step 3** Choose which AAA mode you want to use. Only one can be selected at a time.

Any changes to local user accounts are effective only when you are configured for local mode (the default). If you use remote authentication, changes to the credentials are made on a remote server. The two remote authentication types are RADIUS and TACACS+. RADIUS requires separate credentials for different locations (East and West Coast). TACACS+ is an effective and secure management framework with a built-in failover mechanism.

**Step 4** Click the Fallback to Local check box if you want the administrator to use the local database when the external AAA server is down.

---

**Table 15-1  Access=Access Packet Example (continued)**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type 35 (0x19)</td>
<td>A class, which is a string</td>
</tr>
<tr>
<td>Type 80 (0x50)</td>
<td>Message authenticator</td>
</tr>
</tbody>
</table>

... (Table content continues for brevity)
Auto Provisioning

Auto provisioning allows WCS to automatically configure a new or replace a current wireless LAN controller. The WCS auto provisioning feature can simplify deployments for customers with a large number of controllers.

Note
For auto provisioning privileges, you must have Admin, Root, or SuperUser status.

Note
To allow or disallow auto provisioning privileges to a user, edit the permitted tasks using the Administration > AAA > Groups > <group name> List of Tasks Permitted section of WCS. Select or deselect the check box to allow or disallow these privileges.

Follow these steps to configure auto provisioning.

Step 1
Choose Configure > Auto Provisioning. The Auto Provisioning Filter List window appears (see Figure 15-14).

Figure 15-14 Auto Provisioning Filter List
Step 2

Choose **Auto Provisioning Device Management** from the left sidebar menu. This allows you to create and edit auto provisioning filters which define the list of allowable devices to be auto provisioned or auto monitored by WCS.

Step 3

The Auto Provisioning Filter List window displays the following information:

- Filter Name: Name of the filter
- Filter Enable: Indicates whether or not the filter is enabled.

**Note**

Only enabled filters can participate in the auto provisioning process.

- Filter Mode: Indicates the search mode for this filter (host name, MAC address, or serial number).
- Config Group Name: Indicates the configuration group name.

Step 4

From the Select a command drop-down menu, you can choose to add or delete a filter or list some or all filter device information. If you choose to add a new filter, continue to Step 5.

Step 5

From the Select a command drop-down menu, choose **Add Filter**.

Step 6

Click GO. The Auto Provisioning Filters > New Filter window appears (see Figure 15-15).

**Figure 15-15  Auto Provisioning Filters > New Filter**

Step 7

Configure the following information:

- **General**
  - Enable Filter: Click the check box to enable the new filter.

**Note**

Only enabled filters can participate in the Auto Provisioning process.

- Filter Name: Enter a filter name.
• Filter Properties
  – Monitor Only: When contacted by WCS during the auto provisioning process, the WLC defined in this filter is managed, but not configured, by WCS.
  – Filter Mode: From the drop-down menu, choose Host Name, MAC Address, and Serial Number to indicate the search mode for this filter.
  – Config Group Name: From the drop-down menu, choose a Config Group Name.

Note
An empty config group with no controllers defined must be created so that all config groups appear in the drop-down list.

• Filter Member Management - Add Member
  – Input Type: From the drop-down menu, choose Single Device or CSV file.

If Single Device is selected, enter the Host Name, Management Interface IP Address, Management Interface Netmask, Management Interface Gateway, LAG, AP manager interface IP address, AP manager interface network mask, AP manager interface gateway IP address, and DHCP information.

If CSV File is chosen, enter the CSV file or use the Browse button to navigate to the applicable CSV File. An example of a valid CSV file (with MAC address filter mode) is as follows:

deviceId, LAG, managementIP, managementNetmask, managementGateway, apManagerIP, apManagerNetmask, apManagerGateway, dhcpServerIP
00:0B:85:46:F2:60, true, 1.9.116.39, 255.255.255.0, 1.9.116.1, 2.9.116.39, 255.255.255.0, 2.9.116.1, 2.9.116.250
00:0B:85:46:F2:61, true, 1.9.116.40, 255.255.255.0, 1.9.116.1, 2.9.116.40, 255.255.255.0, 2.9.116.1, 2.9.116.250
00:0B:85:46:F2:62, false, 1.9.116.41, 255.255.255.0, 1.9.116.1, 2.9.116.41, 255.255.255.0, 2.9.116.1, 2.9.116.250
00:0B:85:46:F2:63, false, 1.9.116.42, 255.255.255.0, 1.9.116.1, 2.9.116.42, 255.255.255.0, 2.9.116.1, 2.9.116.250
00:0B:85:46:F2:64, false, 1.9.116.43, 255.255.255.0, 1.9.116.1, 2.9.116.43, 255.255.255.0, 2.9.116.1, 2.9.116.250

The first line in the CSV file must be keyword “deviceId, LAG, managementIP, managementNetmask, managementGateway, apManagerIP, apManagerNetmask, apManagerGateway, dhcpServerIp.”

Each of the following lines should contain nine tokens as follows, separated by commas:
1st token can be host name, MAC address, or serial number depending on the selected filter mode.
2nd token is the controller’s LAG configuration (true/false).
3rd token is the controller’s management interface IP address.
4th token is the controller’s management interface network mask.
5th token is the controller’s management interface gateway IP.
6th token is the controller’s AP Manager interface IP address.
7th token is the controller’s AP Manager interface network mask.
8th token is the controller’s AP Manager interface Gateway IP.
9th token is the controller’s DHCP IP address.

– Host Name
Chapter 15  Administrative Tasks

Auto Provisioning

- LAG Configuration: Enabled or Disabled.
- Management Interface IP Address
- Management Interface Netmask
- Management Interface Gateway
- AP Manager Interface IP Address
- AP Manager Interface Netmask
- AP Manager Interface Gateway
- DHCP IP Address

Step 8  Click Submit.

Viewing Detailed Auto Provisioning Device Information

To view detailed information about auto provisioning devices, choose List Filters Device Info or List All Filters Device Info from the Select a command drop-down menu. The Detailed Auto Provisioning Device window appears (see Figure 15-16). The filter name, its device ID, and the IP address, netmask, and gateway address are provided.

The status displays as idle, trap received, failed in trap processing, failed in applying templates, failed in discovery switch, managed, managed partially applied templates, or unknown error.

Figure 15-16  Detailed Auto Provisioning Device Information

Editing a Current Auto Provisioning Filter

Follow these steps to edit a current auto provisioning filter.
Auto Provisioning

Step 1  Choose Configure > Auto Provisioning.
Step 2  Click the Filter Name of the filter you want to edit.
Step 3  Make the necessary changes to the current filter parameters.
Step 4  Click Submit.

Deleting an Auto Provisioning Filter

Follow these steps to delete an auto provisioning filter.

Step 1  Choose Configure > Auto Provisioning.
Step 2  Choose the check box of the file you want to delete.
Step 3  From the Select a command drop-down menu, choose Delete Filter(s).
Step 4  Click GO.
Step 5  Click OK to confirm the deletion.

Viewing Details of an Auto Provisioned Filter

To view details for an individual auto provisioning filter, follow these steps:

Step 1  Choose Configure > Auto Provisioning.
Step 2  Choose the check box of the filter you want to view.
Step 3  From the Select a command drop-down menu, choose List Filter(s) Device Info.
Step 4  Click GO.

The following information is provided for the selected filter.

<table>
<thead>
<tr>
<th>Table 15-2 List Filter(s) Device Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameter</td>
</tr>
<tr>
<td>---------------------</td>
</tr>
<tr>
<td>Filter Name</td>
</tr>
<tr>
<td>Device ID</td>
</tr>
<tr>
<td>Interface IP</td>
</tr>
<tr>
<td>Interface Netmask</td>
</tr>
<tr>
<td>Interface Gateway</td>
</tr>
</tbody>
</table>

Cisco Wireless Control System Configuration Guide

OL-15478-01
Chapter 15      Administrative Tasks

Turning Password Rules On or Off

You have the ability to customize the various password rules to meet your criteria. Follow these steps to customize the password rules.

Step 1 Choose Administration > AAA.

Step 2 From the left sidebar menu, choose Local Password Policy. The password rules are displayed individually, and each has a check box in front of it.

Step 3 Click the check boxes to enable the rules you want. The rules are as follows:

Note All rules are on by default.

- Password minimum length is 8 characters (the length configurable).
- Password cannot contain username or the reverse of the username.
- Password cannot be cisco or ocsic (Cisco reversed).
- Root password cannot be public.
- No character can be repeated more than three times consecutively in the password.
- Password must contain characters from three of the character classes: uppercase, lowercase, digits, and special characters.

### Setting Auto Provisioning

The Primary Search Key Setting provides the ability to set the matching criteria search order. To indicate the Search Key Order, follow these steps:

Step 1 Choose Configure > Auto Provisioning.

Step 2 From the left sidebar menu, choose Auto Provisioning Setting. The Auto Provisioning Primary Search Key Setting appears.

Step 3 Click to highlight the applicable search key.

Step 4 Use the Move Up or Move Down buttons to move the Search Key to a higher or lower priority.

Step 5 Click Save to confirm or Cancel to cancel the changes.

<table>
<thead>
<tr>
<th>Table 15-2 List Filter(s) Device Information (continued)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Parameter</strong></td>
</tr>
<tr>
<td>Status</td>
</tr>
<tr>
<td>Timestamp</td>
</tr>
</tbody>
</table>
Configuring TACACS+ Servers

This section describes how to add and delete TACACS+ servers. TACACS+ servers provide an effective and secure management framework with built-in failover mechanisms. If you want to make configuration changes, you must be authenticated.

Note
In order to activate TACACS+ servers, you must enable them as described in the “Importing Tasks Into ACS” section on page 15-4.

Step 1
Choose Administration > AAA.

Step 2
From the left sidebar menu, choose TACACS+. The TACACS+ window appears (see Figure 15-17).

Figure 15-17 TACACS+ Window

Step 3
The TACACS+ window shows the TACACS+ server’s IP address, port, retransmit rate, and authentication type (Password Authentication Protocol (PAP)) or Challenge Handshake Authentication Protocol (CHAP). The TACACS+ servers are tried based on how they were configured.

Note
If you need to change the order of how TACACS+ servers are tried, delete any irrelevant TACACS+ servers and re-add the desired ones in the preferred order.

Step 4
Use the drop-down menu in the upper right-hand corner to add or delete TACACS+ servers. You can click on an IP address if you want to make changes to the information.

Step 5
The current server address and port are displayed. Use the drop-down menu to choose either ASCII or hex shared secret format.

Step 6
Enter the TACACS+ shared secret used by your specified server.

Step 7
Re-enter the shared secret in the Confirm Shared Secret field.

Step 8
Specify the time in seconds after which the TACACS+ authentication request times out and a retransmission is attempted by the controller.

Step 9
Specify the number of retries that will be attempted.
Step 10 In the Authentication Type drop-down menu, choose a protocol: PAP or CHAP.
Step 11 Click Submit.

Configuring RADIUS Servers

This section describes how to add and delete RADIUS servers. You must enable RADIUS servers and have a template set up for them in order to make configuration changes.

![RADIUS Window]

In order to activate RADIUS servers, you must enable them as described in the “Importing Tasks Into ACS” section on page 15-4.

Step 1 Choose Administration > AAA.
Step 2 From the left sidebar menu, choose RADIUS. The RADIUS window appears (see Figure 15-18).

Figure 15-18 RADIUS Window

Step 3 The RADIUS window shows the server address, authentication port, retransmit timeout value, and authentication type for each RADIUS server that is configured. The RADIUS servers are tried based on how they were configured.

Note If you need to change the order of how RADIUS servers are tried, delete any irrelevant RADIUS servers, and re-add the desired ones in the preferred order.

Step 4 Use the drop-down menu in the upper right-hand corner to add or delete RADIUS servers. You can click on an IP address if you want to make changes to the information. When you click on a particular IP address, the window shown in Figure 15-19 appears.
Establishing Logging Options

Use Administration > Logging to access the Administer Logging Options page. This logging function is related only to WCS logging and not syslog information. The logging for controller syslog information can be done on the Controller > Management > Syslog window.

Follow the steps below to enable e-mail logging. The settings you establish are stored and are used by the e-mail server.

**Step 1** Choose Administration > Logging. The Logging Options menu appears (see Figure 15-20).
Performing Data Management Tasks

Within the Settings window, you can determine what data to generate for reports and e-mails. Choose Administration > Settings in the left sidebar menu. Three choices appear.

- Refer to the “Data Management” section on page 15-26 to establish trends for hourly, daily, and weekly data periods.
- Refer to the “Report” section on page 15-27 to designate where the scheduled reports will reside and for how long.
- Refer to the “Mail Server” section on page 15-27 to set the primary and secondary SMTP server host and port.
- Refer to the “Login Disclaimer” section on page 15-29 to enter disclaimer information.
- Refer to the “Alarms” section on page 15-29 to specify how to handle old alarms and how to display assigned and acknowledged alarms in the Alarm Summary window.
- Client
  - Refer to the “Enabling Automatic Client Troubleshooting” section on page 15-29 configure parameters for notification support of Guest Access functionality.
- Refer to the “SNMP Settings” section on page 15-30 to configure global SNMP settings from WCS.

Step 2  Choose a message level option of Trace, Information, or Error in the General portion of the window.

Step 3  Click the check boxes within the Log Modules portion of the window to enable various administration modules (such as performance, status, object, configuration, monitor, fault analysis, SNMP mediation, general, location servers, XML mediation, asynchronous, and portal).

Note  Some functions should be used only for short periods of time during debugging so that the performance is not degraded. For example, trace mode and SNMP mediation should be enabled only during debugging because a lot of log information is generated.
Data Management

Follow the steps below to manage data aggregation on an hourly, daily, and weekly basis.

**Step 1** Choose Administration > Settings.
**Step 2** From the left sidebar menu, choose Data Management. The Data Management window appears (see Figure 15-21).

**Figure 15-21 Data Management Window**

<table>
<thead>
<tr>
<th>Wireless Control System</th>
<th>Data Management</th>
</tr>
</thead>
<tbody>
<tr>
<td>Settings</td>
<td>Data Management</td>
</tr>
<tr>
<td>Data Management</td>
<td>Trend Data Retain Periods</td>
</tr>
<tr>
<td>Report</td>
<td>Hourly Aggregated Data Retain Period (days) 31</td>
</tr>
<tr>
<td>Mail Server</td>
<td>Daily Aggregated Data Retain Period (days) 31</td>
</tr>
<tr>
<td>Login Disclaimer</td>
<td>Weekly Aggregated Data Retain Period (weeks) 13</td>
</tr>
<tr>
<td>Alarms</td>
<td>Network Audit Data Retain Period</td>
</tr>
<tr>
<td></td>
<td>Audit Data Retain Period (days) 31</td>
</tr>
</tbody>
</table>

**Step 3** Specify the number of days to keep the hourly data. The valid range is 1 to 31.
**Step 4** Specify the number of days to keep the daily data. The valid range is 7 to 31.
**Step 5** Specify the number of weeks to keep the weekly data. The valid range is 2 to 10.
**Step 6** Specify the number of days to retain the audit data before purging. The limit is 90 days, and the minimum cleanup interval is 7 days.

**Note** For the best interactive graph data views, change the default settings to the maximum possible: 90 days for daily aggregated data and 54 weeks for weekly aggregated data. You must also make the appropriate measures to increase RAM and CPU capacity to compensate for these adjustments.

**Step 7** Click Save.
Report

Follow the steps below to indicate where the scheduled reports will reside and for how many days.

**Step 1**  Choose Administration > Setting.

**Step 2**  From the left sidebar menu, choose Report. The Report window appears (see Figure 15-22).

**Figure 15-22 Report Window**

![Report Window](image)

**Step 3**  Enter the location on the WCS server where you want the scheduled reports to reside on the server.

**Step 4**  Specify the number of days the file will stay in the repository.

**Step 5**  Click Save.

Mail Server

You can configure global e-mail parameters to use when sending e-mails from WCS reports, alarm notifications, and so on. This mail server page allows you to configure e-mail parameters at a single place to avoid re-entering the information each time you need it. The Mail Server window allows you to set the primary and secondary SMTP server host and port, the sender’s e-mail address, and the recipient’s e-mail address(es). Follow these steps to configure global e-mail parameters.

**Note**

You must configure the global SMTP server before setting global e-mail parameters.

**Step 1**  Choose Administration > Setting.

From the left sidebar menu, choose Mail Server. The window in Figure 15-23 appears.
Performing Data Management Tasks

Chapter 15 Administrative Tasks

Figure 15-23 Mail Server Configuration Window

The Mail Server window allows you to set the primary and secondary SMTP server host and port, the sender’s e-mail address, and the recipient’s e-mail address. From this window, you can configure e-mail parameters without having to visit multiple places.

You must designate the primary mail server, and the secondary one is used only if the primary fails. SMTP authorization is also supported for both primary and secondary mail servers. Follow the steps below to configure the mail server.

Step 1 Enter the host name of the primary SMTP server.

Step 2 The SMTP port is set to 25 by default, but you can change it if your mail server is using a non-default port.

Step 3 Enter the designated username if SMTP authorization is turned on for this mail server.

Step 4 Provide a password for logging on to the SMTP server and enter it for the Password and Confirm Password parameter.

Step 5 Provide the same information for the secondary SMTP server (only if a secondary mail server is available). The secondary server is used only if the primary fails.

Step 6 The From field in the Sender and Receivers portion of the window is populated with WCS@<WCS server IP address>. You can change it to a different sender.

Step 7 Enter the recipient’s e-mail address(es) in the To field. The e-mail address you provide serves as the default values for other functional areas, such as alarms or reports. Multiple e-mail addresses can be added and should be separated by a comma.

Note If you make global changes to the recipient e-mail address(es) in Step 7, they are disregarded if e-mail notifications were set.

You are required to set the primary SMTP mail server and the From address fields.
Step 8  Click the **Test** button to send a test e-mail using the parameters you configured. The results of the test operation are shown on the same screen. The test feature checks the connectivity to both primary and secondary mail servers by sending an e-mail with a "WCS test e-mail" subject line.

Step 9  If the test results were satisfactory, click **Save**.

---

### Login Disclaimer

The Login Disclaimer page allows you to enter disclaimer text at the top of the Login page for all users. To enter Login Disclaimer text, follow these steps:

**Step 1**  Choose **Administration > Settings**.

**Step 2**  From the left sidebar menu, choose **Login Disclaimer**.

**Step 3**  Type your Login Disclaimer text in the available text box.

**Step 4**  Click **Save**.

---

### Alarms

This Alarms page allows you to manage the following:

- The handling of old alarms.
- The display of assigned and acknowledged alarms in the Alarm Summary window.

To access this window, follow these steps:

**Step 1**  Choose **Administration > Settings**.

**Step 2**  From the left sidebar menu, choose **Alarms**.

**Step 3**  In the Cleanup of Old Alarms section, check the check box to enable the deletion of old alarms.

**Step 4**  Enter the number of days after which old alarms are deleted.

**Step 5**  In the Alarm Summary Window section, check the check box to hide acknowledged and assigned alarms on the Alarm Summary window. This preference applies only to the Alarm Summary window. A quick search or alarms for any entity show alarms regardless of the acknowledged or assigned state specified here. The default is to hide acknowledged alarms.

---

### Enabling Automatic Client Troubleshooting

From the Settings > Client window, you can enable automatic client troubleshooting on a diagnostic channel. Refer to the “WLAN Client Troubleshooting” section on page 6-16 for further information on client troubleshooting. Follow these steps:

**Step 1**  Choose **Administration > Settings**.

---
Performing Data Management Tasks

Chapter 15      Administrative Tasks

Step 2 From the left sidebar menu, choose Client.
Step 3 Choose the **Automatically troubleshoot client on diagnostic channel** check box.

**Note** If the check box is selected, WCS processes the diagnostic association trap. If it is not selected, WCS raises the trap, but automated troubleshooting is not initiated.

Step 4 Click **Save**.

---

**Notification Receiver**

The Notification Receiver page allows you to configure parameters for notification support of guest access functionality.

Follow these steps to configure notification receiver parameters:

**Step 1** Choose **Administration > Settings**.
**Step 2** From the left sidebar menu, choose **Notification Receiver**.
**Step 3** Enter the Notification Type parameter including Port Number and Community.

**Note** The Notification Type automatically defaults to SNMP.

**Step 4** Click **Submit** to confirm the Notification Receiver information.

---

**SNMP Settings**

The SNMP Settings window allows you to configure global SNMP settings from WCS.

**Note** Any changes made on this screen take effect globally for WCS and are saved across restarts as well as across backups and restores.

Follow these steps to configure global SNMP settings.

**Step 1** Choose **Administration > Settings**.
**Step 2** From the left sidebar menu, choose **SNMP Settings**.
**Step 3** If Trace Display Values is selected, mediation trace-level logging shows data values fetched from the controller using SNMP. If unchecked, the values do not display.

**Note** The default is unchecked for security reasons.
Step 4  For the Backoff Algorithm, choose either **Exponential** or **Constant Timeout** from the drop-down menu. If you choose Exponential (the default value), each SNMP try waits twice as long as the previous try, starting with the specified timeout for the first try. If you choose Constant Timeout, each SNMP try waits the same, specified amount of time.

---

**Note**  Constant Timeout is useful on unreliable networks (such as satellite networks) where the desired number of retries is large. Because it does not double the timeout per try, it does not take as long to timeout with a high number of retries.

---

Step 5  Determine if you want to use reachability parameters. If selected, the WCS defaults to the global Reachability Retries and Timeout that you configure. If unchecked, WCS always uses the timeout and retries specified per-controller or per-IOS access point. The default is checked.

Step 6  For the Reachability Retries parameter, enter the number of global retries used for determining device reachability. The default number is 2. This parameter is only available if the Use Reachability Parameters check box is selected.

Step 7  For the Reachability Timeout parameter, enter a global timeout used for determining device reachability. The default number is 2. This parameter is only available if the Use Reachability Parameters check box is selected.

Step 8  At the Maximum VarBinds per PDU parameter, enter a number to indicate the largest number of SNMP variable bindings allowed in a request or response PDU. The default is 100.

---

**Note**  For customers who have issues with PDU fragmentation in their network, this number can be reduced to 50, which typically eliminates the fragmentation.

---

Step 9  Click **Save** to confirm these settings.

---

**Setting User Preferences**

This page contains user-specific settings you may want to adjust.

---

**Step 1**  Choose **Administration > User Preferences**. The User Preferences Window appears (see Figure 15-24).
Step 2  Use the Items Per List Page drop-down menu to configure the number of entries shown on a given list window (such as alarms, events, AP list, etc.).

Step 3  If you want the maps and alarms page to automatically refresh when a new alarm is raised by WCS, click the check box in the Alarms portion of the window.

Step 4  Use the drop-down menu to indicate how often you want the alarm count refreshed in the Alarm summary window on the left panel.

Step 5  Click Save.
Google Earth Maps

Within Monitor > Google Earth Maps, you can create an outdoor location, import a file, view Google Earth maps, and specify Google Earth settings.

- Creating an Outdoor Location Using Google Earth
- Importing a File into WCS
- Viewing Google Earth Maps
- Google Earth Settings

Creating an Outdoor Location Using Google Earth

To group the access points together into outdoor locations, use the Latitude/Longitude geographical coordinates for each access point. These coordinates are provided in two ways:

- Importing a KML (Google Keyhole Markup Language) File
- Importing a CSV File (Spreadsheet format with comma-separated values)

Understanding Geographical Coordinates for Google Earth

The following geographical information is required for each access point:

- Longitude (East or West)—Angular distance in degrees relative to Prime Meridian. Values west of Meridian range from −180 to 0 degrees. Values east of Meridian range from 0 to 180 degrees. Default is 0.
  Coordinates in degrees, minutes, seconds, direction:
  - Degrees (−180 to 180)
  - Minutes (0 to 59)
  - Seconds (00.00 to 59.99)
  - Direction—East or West (E, W)
  Decimal format (converted from degrees, minutes, and seconds):
  - Longitude can range from −179.59.99 W to 179.59.99 E

- Latitude (North or South)—Angular distance in degrees relative to the Equator. Values south of the Equator range from −90 to 0 degrees. Values north of the Equator range from 0 to 90 degrees. Default is 0.
Coordinates in degrees, minutes, seconds, direction:
- Degrees (–90 to 90)
- Minutes (0 to 59)
- Seconds (00.00 to 59.99)
- Direction—North or South (N, S)

Decimal format (converted from degrees, minutes, and seconds):
- Latitude can range from –89.59.99 S to 89.59.99 N

- Altitude—Height or distance of the access point from the earth’s surface in meters. If not provided, value defaults to 0. Values range from 0 to 99999.
- Tilt—Values range from 0 to 90 degrees (cannot be negative). A tilt value of 0 degrees indicates viewing from directly above the access point. A tilt value of 90 degrees indicates viewing along the horizon. Values range from 0 to 90. The default azimuth angle is 0.
- Range—Distance in meters from the point specified by longitude and latitude to the point where the access point is being viewed (the Look At position)(camera range above sea level). Values range from 0 to 999999.
- Heading—Compass direction in degrees. Default is 0 (North). Values range from 0 to ±180 degrees.
- Altitude Mode—Indicates how the <altitude> specified for the Look At point is interpreted.
  - Clamped to ground—Ignores the <altitude> specification and places the Look At position on the ground. This is the default.
  - Relative to ground—Interprets the <altitude> as a value in meters above the ground.
  - Absolute—Interprets the <altitude> as a value in meters above sea level.
- Extend to ground—Indicates whether or not the access point is attached to a mast.

Creating and Importing Coordinates in Google Earth (KML File)

The geographical coordinates can be created in Google Earth and imported. Either a folder or individual placemarks can be created. Creating a folder helps group all the Placemarks into a single folder and allows you to save the folder as a single KML (a.k.a. XML) file. If individual Placemarks are created, each Placemark must be individually saved.

Follow these steps to create a folder in Google Earth:

**Step 1**
Launch Google Earth.

**Step 2**
In the Places panel on the left sidebar, select **My Places** or **Temporary Places**.

**Step 3**
Right-click Temporary Places and select **Add > Folder** from the drop-down menus.

**Note**
Folders can be created hierarchically to n level depths. When creating KMLs, you can create placemarks and organize them hierarchically according to the zone, city, state, zip. This is not applicable for CSV. In CSV there can be only one level of hierarchy.

**Step 4**
Enter the following information (optional):
- Name—Folder name
- Description—Folder description
Creating an Outdoor Location Using Google Earth

Step 5
Click OK to save the folder. After the folder is created, it can be selected from the Places panel to create Placemarks.

To create Placemarks, follow these steps:

Step 1
Launch Google Earth.

Step 2
In the Places panel on the left sidebar, select My Places or Temporary Places.

Step 3
Select the folder that you previously created.

Step 4
Right-click your created folder and select Add > Placemark from the drop-down menus.

Step 5
Configure the following parameters, if applicable:

- Name—The Placemark name must contain the name, MAC address, or IP address of the appropriate access point.
- Latitude—Provides the current coordinate for the folder if the placemark is created inside the folder or the coordinate for the placemark (if not created inside a folder). This parameter is automatically filled depending on where the yellow Placemark icon is located on the map. Use your mouse to move the Placemark to the correct location or enter the correct coordinate in the Latitude text box.
- Longitude—Provides the current coordinate for the folder if the placemark is created inside the folder or the coordinate for the placemark (if not created inside a folder). This parameter is automatically filled depending on where the yellow Placemark icon is located on the map. Use your mouse to move the Placemark to the correct location or enter the correct coordinate in the Longitude text box.
- Description (optional)—Parameter is ignored by WCS.
- Style, Color (optional)—Parameter is ignored by WCS.
- View—Allows you to configure the Latitude, Longitude, Range, Heading and Tilt coordinates. See “Understanding Geographical Coordinates for Google Earth” for more information on these geographical coordinates.
  - Longitude and latitude are automatically filled depending on where the yellow Placemark icon is located on the map. Use your mouse to click on and move the Placemark to the correct location.
  - All of the coordinates can be entered manually.
- Altitude—Enter the altitude in meters in the text box or use the Ground to Space slide bar to indicate the altitude.
Creating an Outdoor Location Using Google Earth

- Clamped to ground—Indicates that the Look At position is on the ground. This is the default.
- Relative to ground—Interprets the <altitude> as a value in meters above the ground.
- Absolute—Interprets the <altitude> as a value in meters above sea level.
- Extend to ground—For Relative to ground or Absolute settings, indicates whether or not the access point is attached to a mast.

**Step 6** When all coordinates are entered, click **Snapshot current view** or click **Reset** to return the coordinates to the original settings.

**Note** For more information regarding Google Earth, refer to the Google Earth online help.

**Step 7** Click **OK**.

**Step 8** Repeat these steps for all placemarks you want to add.

**Step 9** When all placemarks are created, save the folder as a .kmz file (KML Zip file) or as a .kml file.

**Note** A .kmz file should contain only one .kml file.

**Note** To save the folder, right-click on the folder, select **Save as** from the drop-down menu, navigate to the correct location on your computer, and click **Save**. Both .kmz and .kml files can be imported into WCS.

Creating and Importing Coordinates as a CSV File

To create a CSV file to import into WCS, follow these steps:

**Step 1** Open a flat file and provide the necessary information as a comma-separated list. The Table 16-1 lists the potential data, whether the data is optional or required, and the parameters of the data.

**Note** For more information regarding the geographical coordinates listed below, see the “Understanding Geographical Coordinates for Google Earth” section on page 16-1.

### Table 16-1 Potential Fields for the CSV File

<table>
<thead>
<tr>
<th>Field</th>
<th>Optional</th>
<th>Max Length</th>
<th>Parameter Range</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;FolderPath&quot;</td>
<td>&quot;Value Optional&quot;</td>
<td>32</td>
<td></td>
</tr>
<tr>
<td>&quot;FolderState&quot;</td>
<td>&quot;Value Optional&quot;</td>
<td></td>
<td>true/false</td>
</tr>
<tr>
<td>&quot;FolderLongitude&quot;</td>
<td>&quot;Value Optional&quot;</td>
<td>Range: 0 to ±180</td>
<td></td>
</tr>
<tr>
<td>&quot;FolderLatitude&quot;</td>
<td>&quot;Value Optional&quot;</td>
<td>Range: 0 to ±90</td>
<td></td>
</tr>
<tr>
<td>&quot;FolderAltitude&quot;</td>
<td>&quot;Value Optional&quot;</td>
<td>Range: 0 to 99999</td>
<td></td>
</tr>
<tr>
<td>&quot;FolderRange&quot;</td>
<td>&quot;Value Optional&quot;</td>
<td>99999</td>
<td></td>
</tr>
<tr>
<td>&quot;FolderTilt&quot;</td>
<td>&quot;Value Optional&quot;</td>
<td>90</td>
<td></td>
</tr>
</tbody>
</table>
### Creating an Outdoor Location Using Google Earth

**Step 2** Save the .csv file. The file is now ready to import into WCS.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Value Required</th>
<th>Range/MAX Length/Permitted Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;FolderHeading&quot;</td>
<td>&quot;Value Optional&quot;</td>
<td></td>
<td>Range: 0 to ±180</td>
</tr>
<tr>
<td>&quot;FolderGeoAddress&quot;</td>
<td>&quot;Value Optional&quot;</td>
<td></td>
<td>Max Length: 128</td>
</tr>
<tr>
<td>&quot;FolderGeoCity&quot;</td>
<td>&quot;Value Optional&quot;</td>
<td></td>
<td>Max Length: 64</td>
</tr>
<tr>
<td>&quot;FolderGeoState&quot;</td>
<td>&quot;Value Optional&quot;</td>
<td></td>
<td>Max Length: 40</td>
</tr>
<tr>
<td>&quot;FolderGeoZip&quot;</td>
<td>&quot;Value Optional&quot;</td>
<td></td>
<td>Max Length: 12</td>
</tr>
<tr>
<td>&quot;FolderGeoCountry&quot;</td>
<td>&quot;Value Optional&quot;</td>
<td></td>
<td>Max Length: 64</td>
</tr>
<tr>
<td>&quot;AP_Name&quot;</td>
<td>&quot;Value Required&quot;</td>
<td></td>
<td>Max Length: 32</td>
</tr>
<tr>
<td>&quot;AP_Longitude&quot;</td>
<td>&quot;Value Required&quot;</td>
<td></td>
<td>Range: 0 to ±180</td>
</tr>
<tr>
<td>&quot;AP_Latitude&quot;</td>
<td>&quot;Value Required&quot;</td>
<td></td>
<td>Range: 0 to ±90</td>
</tr>
<tr>
<td>&quot;AP_Altitude&quot;</td>
<td>&quot;Value Required&quot;</td>
<td></td>
<td>Range: 0 to 99999</td>
</tr>
<tr>
<td>&quot;AP_Range&quot;</td>
<td>&quot;Value Required&quot;</td>
<td></td>
<td>Range: 0 to 99999</td>
</tr>
<tr>
<td>&quot;AP_Tilt&quot;</td>
<td>&quot;Value Required&quot;</td>
<td></td>
<td>Range: 0 to 90</td>
</tr>
<tr>
<td>&quot;AP_Heading&quot;</td>
<td>&quot;Value Required&quot;</td>
<td></td>
<td>Range: 0 to ±180</td>
</tr>
<tr>
<td>&quot;AP_AltitudeMode&quot;</td>
<td>&quot;Value Required&quot;</td>
<td></td>
<td>Permitted Values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• clampToGround OR 1</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• relativeToGround OR 2</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• absolute OR 3</td>
</tr>
<tr>
<td>&quot;AP_Extrude&quot;</td>
<td>&quot;Value Required&quot;</td>
<td></td>
<td>Permitted Values: true/false</td>
</tr>
</tbody>
</table>

**Note** Altitude mode defaults to clampToGround if it does not match any of the above options.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Value Optional</th>
<th>Permitted Values: 0, 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;AP_Tessellate&quot;</td>
<td>&quot;Value Optional&quot;</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### AP Coords

- **AP_Coordinates_Longitude** Required
- **AP_Coordinates_Latitude** Required
- **AP_Coordinates_Altitude** Required (Permitted Range: 0 to 99999)
Importing a File into WCS

To import a Google KML or a CSV into the Google Earth Maps feature of WCS, follow these steps:

Step 1  Log in to WCS.
Step 2  Choose Monitor > Google Earth Maps.
Step 3  From the Select a command drop-down menu, choose Import Google KML or Import CSV.
Step 4  Click GO.
Step 5  Use the Browse button to navigate to the .kml, .kmz, or .csv file on your computer.
Step 6  When the file name path is displayed in the text box, click Next.

The input file is parsed and validated for the following:

• Access points specified in the uploaded file are validated (the specified access points must be available within WCS).
• Range validations are performed for longitude, latitude, tilt, heading, range, and other geographical coordinates fields.
• If provided, longitude and latitude coordinates are validated.

Note  If the input file does not validate for completeness, an error page appears. The uploaded information cannot be saved until all errors are corrected.

Step 7  After the files pass all validation checks, review the file details and click Save.

If the uploaded information was saved previously, the information is overwritten accordingly:

• If the folder was uploaded previously, the coordinates are updated for the folder.
• If access points were uploaded previously, the coordinates are updated for the access points.
• Existing access points in the folder are not removed.
• New folders, as needed, are created and access points are placed accordingly.

Viewing Google Earth Maps

To view Google Earth maps, follow these steps:

Step 1  Log in to WCS.
Step 2  Choose Monitor > Google Earth Maps. The Google Earth Maps window displays all folders and the number of access points included within each folder.
Step 3  Click Launch for the map you want to view. Google Earth opens in a separate window and displays the location and its access points.
Note
To use this feature, you must have Google Earth installed on your computer and configured to auto-launch when data is sent from the server. You can download Google Earth from Google’s web site.
Creating an Outdoor Location Using Google Earth

To view details for a Google Earth Map folder, follow these steps:

**Step 1**
From the Google Earth Map window, click the folder name to open the details window for this folder. The Google Earth Details provide the access point names and MAC or IP addresses.

**Note**
To delete an access point, select the applicable check box and click **Delete**. To delete the entire folder, select the check box next to **Folder Name** and click **Delete**. Deleting a folder also deletes all subfolders and access points inside the folder.

**Step 2**
Click **Cancel** to close the details window.

**Google Earth Settings**

Access point related settings can be defined from the Google Earth Settings window. To configure access point settings for the Google Earth Maps feature, follow these steps:

**Step 1**
Choose **Monitor > Google Earth Maps**.

**Step 2**
From the Select a command drop-down menu, choose **Settings**.

**Step 3**
Click **GO**.

**Step 4**
Configure the following parameters:

- **Refresh Settings**—Select the **Refresh from Network** check box to enable this on-demand refresh. This option is applied only once and then disabled.

**Caution**
Because this refresh occurs directly from the network, it could take a long period of time to collect data according to the number of access points.

- **Layers**—Layer filters for access points, access point heat maps, and access point mesh information can be selected and saved. Choose the check box to activate the applicable layer and click **>** to open the filter window.

**Note**
These settings apply when Google Earth sends the request for the next refresh.

- **Access Points**—From the drop-down menu, choose to display channels, Tx power level, coverage holes, MAC addresses, names, controller IP, utilization, profiles, or clients.

**Note**
If the access point layer is not checked, no data is returned, and an error message is returned to Google Earth as a Placemark without an icon.

- **AP Heatmap**—From the Protocol drop-down menu, choose **802.11a/n**, **802.11b/g/n**, **802.11a/n & 802.11b/g/n**, or **None**. Select the cutoff from the RSSI Cutoff drop-down menu (-60 to -90 dBm).
**Note** If the protocol chosen is both 802.11a/n and 802.11b/g/n, the heat maps are generated for both and overlaid on top of each other. The order cannot be defined. To prevent this overlay, you must turn off individual overlay in Google Earth or change it in the Google Earth Settings on WCS.

- **AP Mesh Info**—Choose **Link SNR**, **Packet Error Rate**, or **none** from the Link Label drop-down menu. Choose **Link SNR** or **Packet Error Rate** from the Link Color drop-down menu.

**Note** When the AP Mesh Info check box is chosen, Mesh Links are also automatically shown.

**Step 5** Click **Save** to confirm these changes or **Cancel** to close the window without saving the changes.
Troubleshooting and Best Practices

This document identifies and explains any additional troubleshooting or best practices you may find necessary as you implement a particular function.

The following features are included in this document:

- Troubleshooting Cisco Compatible Extensions Version 5 Client Devices, page A-2
- Web Auth Security on WLANs, page A-3
Troubleshooting Cisco Compatible Extensions Version 5 Client Devices

Two features are designed to troubleshoot communication problems with Cisco Compatible Extension clients: diagnostic channel and client reporting.

Note
These features are supported only on Cisco Compatible Extensions Version 5 Client Devices. They are not supported for use with non-Cisco Compatible Extensions Version 5 Client Devices or with clients running an earlier version.

Diagnostic Channel

The diagnostic channel feature enables you to troubleshoot problems regarding client communication with a WLAN. When initiated by a client having difficulties, the diagnostic channel is a WLAN configured to provide the most robust communication methods with the fewest obstacles to communication placed in the path of the client. The client and access points can be put through a defined set of tests in an attempt to identify the cause of communication difficulties experienced by the client.

Note
Only one WLAN per controller can have the diagnostic channel enabled, and all of the security on this WLAN is disabled.

Configuring the Diagnostic Channel

Follow these steps to configure the diagnostic channel.

Step 1 Choose Configure > Controllers.
Step 2 Click on an IP address to choose a specific controller.
Step 3 Choose WLAN > WLANs from the left sidebar menu.
Step 4 Choose Add WLAN from the Select a command drop-down menu to create a new or click the profile name of an existing .

Note Cisco recommends that you create a new WLAN on which to run the diagnostic tests.

Step 5 When the WLANs page appears, click the Advanced tab (see Figure A-1).
Web Auth Security on WLANs

This section describes the troubleshooting and best practices procedures that are useful when implementing web auth security on WLANs.

Web-auth is a Layer 3 security feature which allows web-based authentication to users on a WLAN. It is used mainly in guest networking scenarios, although not restricted to that usage.

When a WLAN is configured with web-auth security, you are redirected to the login page after passing Layer 2 authentications (static WEP, WPA+PSK, MAC filtering, and so on). The login page is stored on the local device or an external web server, and the page can be modified to allow a customized logo, title, and so on.

After the WLAN is configured with a web-auth WLAN, the HTTP get request is sent by the wireless client to the requested website. The controller firewall allows the DNS resolution of the specified URL. After the resolution, the controller interrupts the HTTP packets from the wireless client and redirects to the login page. When the credentials are entered on the login page and submitted, they are authenticated against the local database. If the user is not found in the local database, the configured RADIUS servers are contacted.

---

**Figure A-1 WLANs Advanced Tab**

Step 6 If you want to enable diagnostic channel troubleshooting on this WLAN, check the Diagnostic Channel check box. Otherwise, leave this check box unchecked, which is the default value.

Step 7 Click Save to commit your changes.
Note: PAP and CHAP authentication are used between the client and authentication agent. Make sure your RADIUS server supports both of these protocols so web-auth login is allowed.

Upon successful authentication, you are allowed to pass traffic. After three unsuccessful authentication attempts, the client is excluded. This excluded client cannot associate until the exclusion timeout limit is surpassed. The exclusion timeout limit is configured with aggressive load balancing, which actively balances the load between the mobile clients and their associated access points.

Web-auth WLAN is also configured with a pre-authentication access control list (ACL). This ACL is configured the same as a normal ACL but permits access to resources that the client needs prior to authentication. An administrator must use the interface section to apply an ACL to the client after authentication.

A web-auth WLAN can be configured with a session timeout value. This value defines the time the client needs to re-authenticate with the device. If the value is set to zero, which means infinity, the client never re-authenticates unless the logged out option is used. You can access the logout URL at http://<VirtualIP>/logout.html.

Note: Disable all pop-up blockers on the client to see the logout window.

Web-auth can be configured in different modes under Layer 3 security. The most commonly used modes of web-auth are as follows:

- **Internal Web**—Redirection to an internal page using http://<virtual IP/DNS name>/login.html. Customization is available.
- **External Web**—Redirection to an external URL.

### Debug Commands

The following debug commands are allowed:

```
debug client <client-mac-address>
debug pm ssh-tcp enable
debug pm ssh-appgw enable
debug pm rules enable
debug pm config enable

show client detail <client-mac-address>
debug pem event enable
```

### Debug Strategy

Use the following strategy for web-auth configured on a WLAN without guest tunneling.

**Step 1** Identify a mobile client to work with and write down its wireless MAC address. Use the command prompt `> ipconfig /all` for all MS Windows-based systems.

**Step 2** Disable the mobile client’s radio.

**Step 3** Enable the following debug commands via a serial console set for high speed (115200) or SSH session to the controller’s management port.
Step 4

Enable the radio and let the client associate. After the client is associated, enter `show client detail <client-mac-address>`.

Client Username ......................... N/A
AP MAC Address............................ 00:0b:85:09:96:10
Client State................................. Associated
Wireless LAN Id.............................. 1
BSSID........................................ 00:0b:85:09:96:1f
Channel.................................... 11
IP Address.................................. 10.50.234.3
Association Id......................... 1
Authentication Algorithm.................. Open System
Reason Code............................... 0
Session Timeout........................... 0
Client CCX version........................ 3
Restricting.. .............. Disabled
QoS Level.............................. Silver
diff Serv Code Point (DSCP)............. disabled
802.1P Priority Tag....................... disabled
WMM Support............................... Disabled
Mobility State............................ Local
Internal Mobility State.................. apfMsMmInitial
Mobility Move Count..................... 0
--More-- or (q)uit
Security Policy Completed............... No
Policy Manager State....................... WEBAUTH_REQD =========**
Policy Manager Rule Created............. Yes
NPU Fast Fast Notified................... Yes
Last Policy Manager State............... WEBAUTH_REQD
Client Entry Create Time................. 67733 seconds
Policy Type................................ N/A
Encryption Cipher........................ None
Management Frame Protection............ No
EAP Type................................... Unknown
Interface.................................. management
VLAN...................................... 0
Client Capabilities:
  CF Pollable............................ Not implemented
  CF Poll Request.......................... Not implemented
  Short Preamble.......................... Implemented
  PBCC.................................... Not implemented
  Channel Agility.......................... Not implemented
  Listen Interval......................... 0
Client Statistics:
  Number of Bytes Received.............. 188595
  Number of Bytes Sent................... 19229
  Number of Packets Received........... 3074
  Number of Packets Sent................ 76
  Number of Policy Errors............... 0
  Radio Signal Strength Indicator........ -41 dBm
  Signal to Noise Ratio.................. 59 dB
--More-- or (q)uit
Nearby AP Statistics:
- TxExcessiveRetries: 0
- TxRetries: 0
- RtsSuccessCnt: 0
- RtsFailCnt: 0
- TxFiltered: 0
- TxRateProfile: [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0]
- ap:09:96:10(slot 1) ..........................
- antenna0: 48 seconds ago -45 dBm................. antenna1: 123 seconds ago -128 dBm

**Step 5**  
Make sure the client’s pemstate is WEBAUTH_REQD. Open the browser page on the client and look for the following messages.

Wed Mar  7 17:59:15 2007: sshpmAddWebRedirectRules: mobile station addr is 10.50.234.3
Wed Mar  7 17:59:15 2007: sshpmAddWebRedirectRules: RuleID for ms 10.50.234.3 is 44
Wed Mar  7 17:59:15 2007: sshpmRuleIndexInsert: adding rule for RuleID 44
Wed Mar  7 17:59:15 2007: sshpmRuleIndexInsert: computed raw hash index 02ad3271 for rule id 0000002c
Wed Mar  7 17:59:15 2007: sshpmRuleIndexInsert: computed adjusted index 00000c32 for rule id 0000002c
Wed Mar  7 17:59:15 2007: sshpmPolicyCommitCallback: called; ContextPtr: 0x2c; Success: 1
Wed Mar  7 18:02:32 2007: SshPmAppgw/pm_appgw.c:1234/ssh_pm_appgw_request: New application gateway request for 'alg-http@ssh.com': 10.50.234.3.1153 > 10.50.234.1.80 (nat: 10.50.234.1.80) tcp ft=0x00000000 tt=0x00000000
Wed Mar  7 18:02:32 2007: SshPmAppgw/pm_appgw.c:1239/ssh_pm_appgw_request: Packet attributes: trigger_rule=0x4ecb, tunnel_id=0x0, trd_index=0xddffffff, prev_trd_index=0xddffffff, Packet: 00000000: 6e58 0000 0101 6b30 755a 5657 0000 0000 e8.0........uW7..
Wed Mar  7 18:02:32 2007: SshPmAppgw/pm_appgw.c:1240/ssh_pm_appgw_request: Packet: 00000000: 4500 0030 0308 4000 8006 0f57 0a32 ea03 45..0...........pB...
Wed Mar  7 18:02:32 2007: SshPmStAppgw/pm_st_appgw.c:403/ssh_pm_st_appgw_start: Calling redirection callback
Wed Mar  7 18:02:32 2007: SshPmStAppgw/pm_st_appgw.c:493/ssh_pm_st_appgw_mappings_done: NAT on initiator side
Wed Mar  7 18:02:32 2007: SshPmStAppgw/pm_st_appgw.c:583/ssh_pm_st_appgw_tcp_responder_stream_done: ssh_pm_st_appgw_tcp_responder_stream_done: conn->context.responder_stream=0x0
Wed Mar 7 18:02:32 2007: SshPmStAppgw/pm_st_appgw.c:646/ssh_pm_st_appgw_tcp_open_initiator_stream: Initiator stream opened
Wed Mar 7 18:02:36 2007: SshAppgwHttp/appgw_http.c:136/ssh_appgw_http_st_wait_input: read -1 bytes (offset 0 data 0)
Wed Mar 7 18:02:41 2007: 00000000: 4745 5420 2f20 4854 5450 2f31 2e31 0d0a  GET /HTTP/1.1
Wed Mar 7 18:02:41 2007: 00000010: 4163 6365 7074 3a20 696d 6167 652f 6769  Accept: image/gi
Wed Mar 7 18:02:41 2007: 00000020: 662c 2069 6d61 6765 2f78 2d78 6269 746d  f,
Wed Mar 7 18:02:41 2007: 00000030: 6170 2c20 696d 6167 652f 706a 7065 672c  ap,
Wed Mar 7 18:02:41 2007: 00000040: 696d 6167 652f 706a 7065 672c 2061 7070  image/jpeg,
Wed Mar 7 18:02:41 2007: 00000050: 6c69 6361 7469 6f6e 2f78 2d78 6269 746d  application/x-shock
Wed Mar 7 18:02:41 2007: 00000060: 7761 7665 2d66 6c61 7368 2c20 2a2f 2a0d  wave-flash, */*
Wed Mar 7 18:02:41 2007: 00000070: 0a41 6363 6570 724d 4c61 6e67 7561 666f  .Accept-Language
Web Auth Security on WLANs

Appendix A    Troubleshooting and Best Practices

Wed Mar  7 18:02:41 2007: 00000080: 3a20 656e 2d75 730d 0a41 6365 7074 2d  :  en-us..Accept-
Wed Mar  7 18:02:41 2007: 00000090: 456e 636f 6469 6e67 3a20 677a 6970 2c20  Encoding:
Wed Mar  7 18:02:41 2007: 000000a0: 6465 666c 6174 650d 0a55 7365 722d 4167  deflate..User-Ag
Wed Mar  7 18:02:41 2007: 000000b0: 656e 743a 204d 6f7a 696c 6c61 2f34 2e30  ent:
Wed Mar  7 18:02:41 2007: 000000c0: 2028 636f 6d70 6174 6962 6c65 3b20 4d53  (compatible;
Wed Mar  7 18:02:41 2007: 000000d0: 4945 2036 2e30 3b20 5769 6e64 6f77 7320  IE 6.0;
Wed Mar  7 18:02:41 2007: 000000e0: 6465 743a 2031 30 2e35 302e 3233 342e 310d  ent:
Wed Mar  7 18:02:41 2007: SshAppgwHttp/appgw_http.c:207/ssh_appgw_http_is_inject: Connection:
Web Auth Security on WLANs

Wed Mar 7 18:02:45 2007: SshPmStAppgw/pm_st_appgw.c:1094/ssh_pm_st_appgw_terminate: terminating appgw instance

Step 6  If you do not see the HTTP GET message, the HTTP packet has not reached the controller. After the client completes the redirection, enter your login and submit it.

Step 7  Look at the client’s entry in NPUsdevshell hapiMmcDebugSchInfoShow('client mac address'). If the PEM state is not moved from WEBAUTH_REQD to RUN, a credential problem exists. Check the credentials in the local or RADIUS database (wherever they were configured).

Step 8  When the RUN state appears on the client, perform a check from the client to the gateway and see if traffic is being passed.

Best Practices

If the client is not redirected to the login page and you want to avoid DNS resolution in the network, enter http://<controller-mgmt-ip>. If a redirection occurs, the issue is not network related.

Enter config network web-auth-port <Port> to define the ports on the controller other than the standard HTTP port (80). The controller does not interrupt secure HTTP or HTTPS(443) even if the port is configured for interrupt.
WCS and End User Licenses

This appendix provides the end user license and warranty that apply to the Cisco Wireless Control System (WCS). It contains these sections:

- WCS Licenses, page B-2
- Open Source License Acknowledgements, page B-6
- End User License Agreement, page B-7
WCS Licenses

Before you purchase a Cisco Wireless Control System (WCS) license, determine if you will need a Base or Location license and how many access points will need to be supported and licensed.

The two types of Cisco WCS support different feature levels:

- **Cisco WCS Base** supports standard WCS capabilities, which includes wireless client data access, rogue access point containment functions, Cisco WLAN Solution monitoring and control, and client and rogue access point location to the nearest access point.

- **Cisco WCS Location** includes all the features present in the Cisco WCS Base, plus the ability to track a single Wi-Fi device on demand or expand location capabilities by adding a Cisco Wireless Location Appliance to simultaneously track up to 2500 Wi-Fi devices.

Types of Licenses

The licensing information for existing Cisco WCS deployments are being upgraded to support Cisco Unified Wireless Network Software Release 4.1.82.0. (While previous Cisco WCS SKUs will be available until September 2006, Cisco recommends that you purchase the new Cisco WCS SKUs outlined in the WCS Ordering Guide (http://www.cisco.com/en/US/products/ps6305/products_data_sheet0900aecd804b4646.html) for a more seamless migration to licensing. This chapter includes information on new or expansion Cisco WCS licenses, migrating from CiscoWorks Wireless LAN Solution Engine (WLSE) to Cisco WCS, upgrading to the Cisco WCS Location option, and deploying the free Cisco WCS demonstration license. The versions of Cisco Wireless Control System (WCS) licenses are as follows:

- **WCS-STANDARD-K9** — For customer buying new or expansion Cisco WCS licenses running Cisco Unified Wireless Network Software Release 4.1.82.0. It is available as Cisco WCS Base or Cisco WCS Location increments of 50, 100, 500, 1000, or 2500 lightweight access points.

  **Note** When the number of access points exceeds the limit of those licensed, WCS generates an alarm. Also, when the user logs into WCS, they are alerted if the licensed access point count has been exceeded.

- **WCS-WLSE-UPG-K9** — For CiscoWorks WLSE customers migrating from CiscoWorks WLSE (Model 1130) to Cisco WCS. See “Conversion of a WLSE Autonomous Deployment to a WCS Controller Deployment” in Appendix B for steps to migrate from CiscoWorks WLSE to the Cisco Unified Wireless Network architecture.

  **Note** Dell platforms are not supported.

- **WCS-LOC-UPG-K9** — For customers upgrading from their existing Cisco WCS base licenses to equivalent Cisco WCS Location licenses. It is available as Cisco WCS Location in increments of 50, 100, 500, 1000, or 2500 lightweight access points.

  **Note** CiscoWorks WLSE Express (Model 1030) and CiscoWorks WLSE (Model 1105) are NOT supported with this SKU. DO NOT install the CiscoWorks WLSE CDs on the CiscoWorks WLSE Express (Model 1030) appliance or CiscoWorks WLSE (Model 1105) because this conversion does not work and is not supported by Cisco Systems.
WCS Licenses

- WCS-ADV-SI-SE-10—A feature license that enables the integration of up to 10 spectrum experts. This license requires a valid base or location license.
- AIR-WCS-DEMO-K9 — For customers wishing to download the new full featured, location-enabled Cisco WCS demonstration license that supports ten access points for up to 30 days.

Note: The free 30-day trial license is NOT supported by the Cisco Technical Assistance Center (TAC).

Licensing Enforcement

Cisco Unified Wireless Network Releases enforces software based licensing. Customers are prompted to enter license files by all new Cisco WCS SKU families. Existing customers migrating to a later release are also impacted by licensing and should contact their Cisco Sales Representative or TAC to obtain Product Authorization Key (PAK) certificate if they have not already received PAK certificate from Cisco. For more information, refer to the WCS Ordering Guide (http://www.cisco.com/en/US/products/ps6305/products_data_sheet0900aecd804b4646.html).

All Cisco WCS licenses can be purchased or acquired directly from Cisco.com via the normal Cisco ordering processes. Cisco Unified Wireless Network Software Releases can be downloaded from Cisco.com or, for a nominal charge, a CD (WCS-CD-K9) can be purchased from the WCS-STANDARD-K9 or WCS-LOC-UPG-K9 SKU families. The WCS-CD-K9 contains one software image of Cisco WCS version 4.0 on a CD. Customers can select the appropriate Cisco WCS installer to designate whether they would like to install a Windows or Linux version. The Cisco WCS base or location features and access point quantity are activated after installation by inserting the license file that is tied to the original purchased Cisco WCS SKU. This CD is shipped via U.S. mail to the purchaser’s address.

For the WCS-WLSE-UPG-K9 SKU family, two CDs are automatically shipped with any order in this specific SKU family. These CDs are special purpose CDs that are used specifically to convert the Cisco Works WLSE platform to Cisco WCS.

The Cisco WCS free demonstration license, AIR-WCS-DEMO-K9 is only available as a software download from Cisco.com. Within the 30 day trial period, this free license can be upgraded to one of the non-expiring Cisco WCS SKUs by applying license files generated through the purchase of one of the non-expiring Cisco WCS SKU families.

Product Authorization Key Certificate

All Cisco WCS SKUs require a PAK certificate to register the Cisco WCS license. The PAK is a paper certificate sent via U.S. mail from Cisco Systems upon purchase of the Cisco WCS license. The PAK certificate allows customers to receive a Cisco WCS license. It is used to register the Cisco WCS and generate license files. All customers must go to the PAK registration site listed on their PAK certificate to complete their Cisco WCS registration. The PAK certificate provides clear instructions on how to complete the Cisco WCS licensing process.

Note: All customers that purchase Cisco WCS from Cisco.com via download or CD must activate their Cisco WCS license by registering at the PAK site. Customers receive the PAK via U.S. mail. Cisco WCS will not be activated until the PAK registration process is completed.
Determining Which License To Use

You should select the correct license based on your deployment situation, the number of access points to be supported, and Cisco WCS options (base or location). All SKUs within a SKU family can be combined with equivalent option levels such as base to base or location to location. Unequal option levels (base and location) cannot be mixed. Only one type of license can be used on the WCS at one time. For example, if your computer has a location license, you cannot add a base license. You can add to the current license by purchasing a license to increase the access point count. For example, if you have a location license with an access point count of 50 and in a year you need to add more access points, you can buy another location license with an access point count of 100, apply it to the WCS, and have a WCS with location license for 150 access points. You can add a license to increase the number of access points in increments of 50, 100, 500, 1000, or 2500.

**Note**
If you have a base license and want to upgrade to a location, you will need to purchase a location upgrade license. You need to purchase a location upgrade license equivalent to the total number of access points with a base license. For example, if you have three base licenses with support for 50, 100, and 200 access points (for a total of 350 access points), you must purchase a single location upgrade license with support for 350 access points.

Installing a License

You need to have the Wireless Control System license key file to install your license. The key file is distributed to you in an e-mail from Cisco Systems. This file activates the features that you have purchased for your Cisco Wireless Control System (WCS). Do not edit the contents of the .lic file in any way or you will render the file useless.

**Note**
If you upgrade to a WCS version without a license, you receive a critical alarm once a day and a notification regarding lack of a license each time you log in to WCS. Without a license, you have access to all WCS functionality except adding new controllers.

Cisco strongly recommends that you print the e-mail, save the attachment to a removable media, and store both in a safe place for future use, if needed by either yourself or anyone in your organization. Before you proceed, make sure that the WCS server software has been installed and configured on the server.

To install the WCS license, follow these steps:

**Step 1** Save the license file (.lic) to a temporary directory on your hard drive.

**Step 2** Open a supported version of the Internet Explorer browser.

**Step 3** In the Location or Address field, enter the following URL, replacing IP address or host name of the WCS server: https://<IP address>.

**Step 4** Log in to the WCS server as system administrator. User names and passwords are case-sensitive.

**Step 5** From the Help menu, select **Licensing**.

**Step 6** On the Licensing page, from the Select a command drop-down menu, choose **Add License**.

**Step 7** On the Add License page, click **Browse** to navigate to the location where you saved the .lic file.

**Step 8** Click **Upload**.
The WCS server imports the license.

During the upload the following items are checked:
- Validity of the license file
- Matching host names on the license and WCS system
- The license file being installed must have a “Location Feature.” For example, Base or Location.
- The “Location Feature” (Base or Location) of the file being installed must match that of the system.

If you encounter a problem with the license file, please contact the Cisco Licensing team at 800-553-2447 or licensing@cisco.com.

---

### Managing Licenses

Choose **Help > Licensing** to access the Licenses page.

This page enables you to view a list of the current licenses installed, add a license, and delete a license.

The license information displays the following:
- Host name
- Type
- AP count (for specified number of access points)
- Percentage of what is licensed
- Capacity of licenses currently used

The license list displays the following:
- A summary of each individual license.
- ID: Unique identifier for the license.
- Host: License applies to this host machine.
- Type: Location or base.
- AP Count: Number of access points for listed license. Should correspond with AP Count in License Information column.
- Expires: When license expires.

---

### Adding a License

Follow these steps to add a license.

**Step 1**  
From the Select a command drop-down list, choose **Add License** and click **GO**.

**Step 2**  
Click **Browse** to search for the license file you are adding.

**Step 3**  
Click **Upload**.
Deleting a License

Follow these steps to delete a license.

Step 1  From the License List portion of the Licenses window, click the check box of the license you want to delete.

Step 2  From the Select a command drop-down list, choose Delete License and click GO.

Backup and Restore License

The license files are saved as part of the backup and restore process, so upgrading WCS will not require reentering of the license files. However, the restore must be on a system with the same host name for the restored licenses to work. If you have installed an upgraded license on your system, you must reinstall the original license, followed by the upgrade license. For example, if you have upgraded a license from base license to location license, during the reinstall, you need to first install the base license, then install the location license. To backup and restore the WCS database, refer to the “Backing Up the WCS Database” section on page 11-4 and the “Restoring the WCS Database” section on page 11-6.

Open Source License Acknowledgements

The following acknowledgements pertain to this software license.

OpenSSL/Open SSL Project

This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/).

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com).

This product includes software written by Tim Hudson (tjh@cryptsoft.com).

License Issues

The OpenSSL toolkit stays under a dual license, i.e. both the conditions of the OpenSSL License and the original SSLeay license apply to the toolkit. See below for the actual license texts. Actually both licenses are BSD-style Open Source licenses. In case of any license issues related to OpenSSL please contact openssl-core@openssl.org.

**OpenSSL License:**

© 1998-1999 The OpenSSL Project. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the copyright notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions, and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the following acknowledgment: “This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit. (http://www.openssl.org/)”

4. The names “OpenSSL Toolkit” and “OpenSSL Project” must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact openssl-core@openssl.org.

5. Products derived from this software may not be called “OpenSSL” nor may “OpenSSL” appear in their names without prior written permission of the OpenSSL Project.

6. Redistributions of any form whatsoever must retain the following acknowledgment:
   “This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/)”

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT “AS IS” AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com). This product includes software written by Tim Hudson (tjh@cryptsoft.com).

Original SSLeay License:

© 1995-1998 Eric Young (eay@cryptsoft.com). All rights reserved.

This package is an SSL implementation written by Eric Young (eay@cryptsoft.com).

The implementation was written so as to conform with Netscape's SSL.

This library is free for commercial and non-commercial use as long as the following conditions are adhered to. The following conditions apply to all code found in this distribution, be it the RC4, RSA, lhash, DES, etc., code; not just the SSL code. The SSL documentation included with this distribution is covered by the same copyright terms except that the holder is Tim Hudson (tjh@cryptsoft.com).

Copyright remains Eric Young's, and as such any Copyright notices in the code are not to be removed. If this package is used in a product, Eric Young should be given attribution as the author of the parts of the library used. This can be in the form of a textual message at program startup or in documentation (online or textual) provided with the package.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
3. All advertising materials mentioning features or use of this software must display the following acknowledgement:
   “This product includes cryptographic software written by Eric Young (eay@cryptsoft.com)”. The word ‘cryptographic’ can be left out if the routines from the library being used are not cryptography-related.

4. If you include any Windows specific code (or a derivative thereof) from the apps directory (application code) you must include an acknowledgement: “This product includes software written by Tim Hudson (tjh@cryptsoft.com)”. 

THE SOFTWARE IS PROVIDED BY ERIC YOUNG “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The license and distribution terms for any publicly available version or derivative of this code cannot be changed. i.e. this code cannot simply be copied and put under another distribution license [including the GNU Public License].

End User License Agreement

IMPORTANT: PLEASE READ THIS END USER LICENSE AGREEMENT CAREFULLY. DOWNLOADING, INSTALLING OR USING CISCO OR CISCO-SUPPLIED SOFTWARE CONSTITUTES ACCEPTANCE OF THIS AGREEMENT.

CISCO IS WILLING TO LICENSE THE SOFTWARE TO YOU ONLY UPON THE CONDITION THAT YOU ACCEPT ALL OF THE TERMS CONTAINED IN THIS LICENSE AGREEMENT. BY DOWNLOADING OR INSTALLING THE SOFTWARE, OR USING THE EQUIPMENT THAT CONTAINS THIS SOFTWARE, YOU ARE BINDING YOURSELF AND THE BUSINESS ENTITY THAT YOU REPRESENT (COLLECTIVELY, “CUSTOMER”) TO THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS AGREEMENT, THEN CISCO IS UNWILLING TO LICENSE THE SOFTWARE TO YOU AND (A) DO NOT DOWNLOAD, INSTALL OR USE THE SOFTWARE, AND (B) YOU MAY RETURN THE SOFTWARE FOR A FULL REFUND, OR, IF THE SOFTWARE IS SUPPLIED AS PART OF ANOTHER PRODUCT, YOU MAY RETURN THE ENTIRE PRODUCT FOR A FULL REFUND. YOUR RIGHT TO RETURN AND REFUND EXPIRES 30 DAYS AFTER PURCHASE FROM CISCO OR AN AUTHORIZED CISCO RESELLER, AND APPLIES ONLY IF YOU ARE THE ORIGINAL END USER PURCHASER.

The following terms of this End User License Agreement (“Agreement”) govern Customer’s access and use of the Software, except to the extent (a) there is a separate signed agreement between Customer and Cisco governing Customer’s use of the Software or (b) the Software includes a separate “click-accept”
License. Conditioned upon compliance with the terms and conditions of this Agreement, Cisco Systems, Inc. or its subsidiary licensing the Software instead of Cisco Systems, Inc. ("Cisco"), grants to Customer a nonexclusive and nontransferable license to use for Customer's internal business purposes the Software and the Documentation for which Customer has paid the required license fees. "Documentation" means written information (whether contained in user or technical manuals, training materials, specifications or otherwise) specifically pertaining to the Software and made available by Cisco with the Software in any manner (including on CD-Rom, or on-line).

Customer's license to use the Software shall be limited to, and Customer shall not use the Software in excess of, a single hardware chassis or card or such number and types of agent(s), concurrent users, sessions, IP addresses, port(s), seat(s), server(s), site(s), features and feature sets as are set forth in the applicable Purchase Order which has been accepted by Cisco and for which Customer has paid to Cisco the required license fee.

Unless otherwise expressly provided in the Documentation, Customer shall use the Software solely as embedded in, for execution on, or (where the applicable documentation permits installation on non-Cisco equipment) for communication with Cisco equipment owned or leased by Customer and used for Customer's internal business purposes. NOTE: For evaluation or beta copies for which Cisco does not charge a license fee, the above requirement to pay license fees does not apply.

General Limitations. This is a license, not a transfer of title, to the Software and Documentation, and Cisco retains ownership of all copies of the Software and Documentation. Customer acknowledges that the Software and Documentation contain trade secrets of Cisco, its suppliers or licensors, including but not limited to the specific internal design and structure of individual programs and associated interface information. Accordingly, except as otherwise expressly provided under this Agreement, Customer shall have no right, and Customer specifically agrees not to:

(i) transfer, assign or sublicense its license rights to any other person or entity, or use the Software on unauthorized or secondhand Cisco equipment, and Customer acknowledges that any attempted transfer, assignment, sublicense or use shall be void;

(ii) make error corrections to or otherwise modify or adapt the Software or create derivative works based upon the Software, or permit third parties to do the same;

(iii) reverse engineer or decompile, decrypt, disassemble or otherwise reduce the Software to human-readable form, except to the extent otherwise expressly permitted under applicable law notwithstanding this restriction;

(iv) use or permit the Software to be used to perform services for third parties, whether on a service bureau or time sharing basis or otherwise, without the express written authorization of Cisco; or
(v) disclose, provide, or otherwise make available trade secrets contained within the Software and Documentation in any form to any third party without the prior written consent of Cisco. Customer shall implement reasonable security measures to protect such trade secrets.

To the extent required by law, and at Customer's written request, Cisco shall provide Customer with the interface information needed to achieve interoperability between the Software and another independently created program, on payment of Cisco's applicable fee, if any. Customer shall observe strict obligations of confidentiality with respect to such information and shall use such information in compliance with any applicable terms and conditions upon which Cisco makes such information available.

**Software, Upgrades and Additional Copies.** For purposes of this Agreement, "Software" shall include (and the terms and conditions of this Agreement shall apply to) computer programs, including firmware, as provided to Customer by Cisco or an authorized Cisco reseller, and any upgrades, updates, bug fixes or modified versions thereto (collectively, "Upgrades") or backup copies of the Software licensed or provided to Customer by Cisco or an authorized Cisco reseller. NOTWITHSTANDING ANY OTHER PROVISION OF THIS AGREEMENT: (1) CUSTOMER HAS NO LICENSE OR RIGHT TO USE ANY ADDITIONAL COPIES OR UPGRADES UNLESS CUSTOMER, AT THE TIME OF ACQUIRING SUCH COPY OR UPGRADE, ALREADY HOLDS A VALID LICENSE TO THE ORIGINAL SOFTWARE AND HAS PAID THE APPLICABLE FEE FOR THE UPGRADE OR ADDITIONAL COPIES; (2) USE OF UPGRADES IS LIMITED TO CISCO EQUIPMENT FOR WHICH CUSTOMER IS THE ORIGINAL END USER PURCHASER OR LESSEE OR WHO OTHERWISE HOLDS A VALID LICENSE TO USE THE SOFTWARE WHICH IS BEING UPGRADED; AND (3) THE MAKING AND USE OF ADDITIONAL COPIES IS LIMITED TO NECESSARY BACKUP PURPOSES ONLY.

**Proprietary Notices.** Customer agrees to maintain and reproduce all copyright and other proprietary notices on all copies, in any form, of the Software in the same form and manner that such copyright and other proprietary notices are included on the Software. Except as expressly authorized in this Agreement, Customer shall not make any copies or duplicates of any Software without the prior written permission of Cisco.

**Term and Termination.** This Agreement and the license granted herein shall remain effective until terminated. Customer may terminate this Agreement and the license at any time by destroying all copies of Software and any Documentation. Customer's rights under this Agreement will terminate immediately without notice from Cisco if Customer fails to comply with any provision of this Agreement. Upon termination, Customer shall destroy all copies of Software and Documentation in its possession or control. All confidentiality obligations of Customer and all limitations of liability and disclaimers and restrictions of warranty shall survive termination of this Agreement. In addition, the provisions of the sections titled "U.S. Government End User Purchasers" and "General Terms Applicable to the Limited Warranty Statement and End User License" shall survive termination of this Agreement.

**Customer Records.** Customer grants to Cisco and its independent accountants the right to examine Customer's books, records and accounts during Customer's normal business hours to verify compliance with this Agreement. In the event such audit discloses non-compliance with this Agreement, Customer shall promptly pay to Cisco the appropriate license fees, plus the reasonable cost of conducting the audit.
Export. Software and Documentation, including technical data, may be subject to U.S. export control laws, including the U.S. Export Administration Act and its associated regulations, and may be subject to export or import regulations in other countries. Customer agrees to comply strictly with all such regulations and acknowledges that it has the responsibility to obtain licenses to export, re-export, or import Software and Documentation.

U.S. Government End User Purchasers. The Software and Documentation qualify as "commercial items," as that term is defined at Federal Acquisition Regulation ("FAR") (48 C.F.R.) 2.101, consisting of "commercial computer software" and "commercial computer software documentation" as such terms are used in FAR 12.212. Consistent with FAR 12.212 and DoD FAR Supp. 227.7202-1 through 227.7202-4, and notwithstanding any other FAR or other contractual clause to the contrary in any agreement into which this End User License Agreement may be incorporated, Customer may provide to Government end user or, if this Agreement is direct, Government end user will acquire, the Software and Documentation with only those rights set forth in this End User License Agreement. Use of either the Software or Documentation or both constitutes agreement by the Government that the Software and Documentation are "commercial computer software" and "commercial computer software documentation," and constitutes acceptance of the rights and restrictions herein.

Limited Warranty

Subject to the limitations and conditions set forth herein, Cisco warrants that commencing from the date of shipment to Customer (but in case of resale by an authorized Cisco reseller, commencing not more than ninety (90) days after original shipment by Cisco), and continuing for a period of the longer of (a) ninety (90) days or (b) the warranty period (if any) expressly set forth as applicable specifically to software in the warranty card accompanying the product of which the Software is a part (the "Product") (if any): (a) the media on which the Software is furnished will be free of defects in materials and workmanship under normal use; and (b) the Software substantially conforms to the Documentation. The date of shipment of a Product by Cisco is set forth on the packaging material in which the Product is shipped. Except for the foregoing, the Software is provided AS IS. This limited warranty extends only to the Customer who is the original licensee. Customer's sole and exclusive remedy and the entire liability of Cisco and its suppliers and licensors under this limited warranty will be (i) replacement of defective media and/or (ii) at Cisco's option, repair, replacement, or refund of the purchase price of the Software, in both cases subject to the condition that any error or defect constituting a breach of this limited warranty is reported to Cisco or the party supplying the Software to Customer, if different than Cisco, within the warranty period. Cisco or the party supplying the Software to Customer may, at its option, require return of the Software as a condition to the remedy. In no event does Cisco warrant that the Software is error free or that Customer will be able to operate the Software without problems or interruptions. In addition, due to the continual development of new techniques for intruding upon and attacking networks, Cisco does not warrant that the Software or any equipment, system or network on which the Software is used will be free of vulnerability to intrusion or attack.

Restrictions. This warranty does not apply if the Software, Product or any other equipment upon which the Software is authorized to be used (a) has been altered, except by Cisco or its authorized representative, (b) has not been installed, operated, repaired, or maintained in accordance with instructions supplied by Cisco, (c) has been subjected to abnormal physical or electrical stress, misuse, negligence, or accident; or (d) is licensed, for beta, evaluation, testing or demonstration purposes for which Cisco does not charge a purchase price or license fee.

DISCLAIMER OF WARRANTY. EXCEPT AS SPECIFIED IN THIS WARRANTY, ALL EXPRESS OR IMPLIED CONDITIONS, REPRESENTATIONS, AND WARRANTIES INCLUDING, WITHOUT LIMITATION, ANY IMPLIED WARRANTY OR CONDITION OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, NON-INFRINGEMENT, SATISFACTORY QUALITY, NON-INTERFERENCE, ACCURACY OF INFORMATIONAL CONTENT, OR ARISING FROM A COURSE OF DEALING, LAW, USAGE, OR TRADE PRACTICE, ARE HEREBY EXCLUDED TO THE EXTENT ALLOWED BY APPLICABLE LAW AND ARE EXPRESSLY DISCLAIMED BY CISCO, ITS SUPPLIERS AND LICENSORS. TO THE
EXTENT AN IMPLIED WARRANTY CANNOT BE EXCLUDED, SUCH WARRANTY IS LIMITED IN DURATION TO THE EXPRESS WARRANTY PERIOD. BECAUSE SOME STATES OR JURISDICTIONS DO NOT ALLOW LIMITATIONS ON HOW LONG AN IMPLIED WARRANTY LASTS, THE ABOVE LIMITATION MAY NOT APPLY. THIS WARRANTY GIVES CUSTOMER SPECIFIC LEGAL RIGHTS, AND CUSTOMER MAY ALSO HAVE OTHER RIGHTS WHICH VARY FROM JURISDICTION TO JURISDICTION. This disclaimer and exclusion shall apply even if the express warranty set forth above fails of its essential purpose.

General Terms Applicable to the Limited Warranty Statement and End User License Agreement

Disclaimer of Liabilities. REGARDLESS WHETHER ANY REMEDY SET FORTH HEREIN FAILS OF ITS ESSENTIAL PURPOSE OR OTHERWISE, IN NO EVENT WILL CISCO OR ITS SUPPLIERS BE LIABLE FOR ANY LOST REVENUE, PROFIT, OR LOST OR DAMAGED DATA, BUSINESS INTERRUPTION, LOSS OF CAPITAL, OR FOR SPECIAL, INDIRECT, CONSEQUENTIAL, INCIDENTAL, OR PUNITIVE DAMAGES HOWEVER CAUSED AND REGARDLESS OF THE THEORY OF LIABILITY OR WHETHER ARISING OUT OF THE USE OF OR INABILITY TO USE SOFTWARE OR OTHERWISE AND EVEN IF CISCO OR ITS SUPPLIERS OR LICENSORS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. In no event shall Cisco’s or its suppliers’ or licensors’ liability to Customer, whether in contract, tort (including negligence), breach of warranty, or otherwise, exceed the price paid by Customer for the Software that gave rise to the claim or if the Software is part of another Product, the price paid for such other Product. BECAUSE SOME STATES OR JURISDICTIONS DO NOT ALLOW LIMITATION OR EXCLUSION OF CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO YOU.

Customer agrees that the limitations of liability and disclaimers set forth herein will apply regardless of whether Customer has accepted the Software or any other product or service delivered by Cisco. Customer acknowledges and agrees that Cisco has set its prices and entered into this Agreement in reliance upon the disclaimers of warranty and the limitations of liability set forth herein, that the same reflect an allocation of risk between the parties (including the risk that a contract remedy may fail of its essential purpose and cause consequential loss), and that the same form an essential basis of the bargain between the parties.

The validity, interpretation, and performance of this Warranty and End User License shall be controlled by and construed under the laws of the State of California, United States of America, as if performed wholly within the state and without giving effect to the principles of conflict of laws, and the State and federal courts of California shall have jurisdiction over any claim arising under this Agreement. The parties specifically disclaim the UN Convention on Contracts for the International Sale of Goods. Notwithstanding the foregoing, either party may seek interim injunctive relief in any court of appropriate jurisdiction with respect to any alleged breach of such party’s intellectual property or proprietary rights. If any portion hereof is found to be void or unenforceable, the remaining provisions of the Agreement shall remain in full force and effect. Except as expressly provided herein, this Agreement constitutes the entire agreement between the parties with respect to the license of the Software and Documentation and supersedes any conflicting or additional terms contained in any purchase order or elsewhere, all of which terms are excluded. This Agreement has been written in the English language, and the parties agree that the English version will govern.

Supplemental License Agreement

Cisco Wireless Control System (WCS)

IMPORTANT-READ CAREFULLY

You have agreed to the Cisco System, Inc. End User License Agreement ("EULA") that governs your access and use of the Cisco Wireless Control System ("WCS"). This supplemental license agreement (this "supplement") contains additional terms and conditions.
Capitalized terms used and but not defined in this supplement have the meanings as defined in the EULA. To the extent of a conflict between the provisions of this supplement and the EULA, this supplement takes precedence.

By installing, downloading, accessing or otherwise using the Software, Customer agrees to be bound by the terms of this supplement. If Customer does not agree to the terms of this supplement, Customer may not install, download, or otherwise use the Software.

Restrictions on Managed Access Point and Devices

Customer may not use the Software unless:

- Customer obtains a WCS limited license by placing a Purchase Order for a WCS license for a specific number of access points, having the Purchase Order accepted by Cisco, and paying to Cisco the required license fee; or

- Customer obtains a WCS demonstration license by registering and downloading the Software for demonstration purposes in accordance with the Cisco Data Sheet for the Cisco Wireless Control System (the "WCS Data Sheet").

If Customer obtains a WCS limited license, Customer may not use the Software to manage more access points than those identified in the Software's Cisco SKU or the product description on Customer's accepted, paid Purchase Order plus those identified in the Software's Cisco SKUs or the product descriptions on Customer's prior accepted, paid Purchase Orders.

If Customer obtains a WCS demonstration license, Customer may not use the Software to manage more than the number of access points identified for the Cisco WCS demonstration license in the WCS Data Sheet.

Customer may use the Software only to manage those devices identified as managed devices in the product specifications section of WCS Data Sheet.

Server Restrictions

Customer may install and run the Software on multiple servers if the Software's Cisco SKU or product description on Customer's accepted, paid Purchase Order identifies the product as an enterprise or "ent" license. Otherwise, Customer may install and run the Software on only a single server.

Third-Party Proprietary Software

The Software includes proprietary software and technology from Cisco's suppliers. Some suppliers are intended third-party beneficiaries of the EULA and this supplement. Third-party-beneficiary suppliers include: (a) Hifn, Inc.; (b) Wind River Systems, Inc. and its suppliers; and (c) any other supplier Cisco identifies as a third-party beneficiary in the Documentation or additional supplements. These suppliers may enforce, and are express beneficiaries of, the EULA and this supplement. However, they are not in any contractual relationship with Customer.

The limited warranty in the EULA is made only by Cisco and is disclaimed by all Cisco suppliers. Cisco and any Cisco supplier may obtain injunctive relief if Customer's use of the Software is in violation of any license restrictions.

Open-Source Software

The Software includes certain open-source software. Despite anything to the contrary in the EULA or this supplement, the open-source software is governed by the terms and conditions of the applicable open-source license. The open-source software, the applicable open-source licenses and other open-source notices may be identified in the Documentation or in a README file accompanying the Software. Customer agrees to comply with all such licenses and other notices.

Other Terms and Conditions

The terms of the EULA and this supplement may be enforced by license registration and other software tools.
Conversion of a WLSE Autonomous Deployment to a WCS Controller Deployment

This chapter describes how to convert a Cisco Wireless LAN Solution Engine (WLSE) network management appliance to a Cisco Wireless Control System (WCS) network management station.

**Caution**

After WLSE is converted to WCS, it can no longer be used as a WLSE or converted back into a WLSE. This is a one-way conversion only.

- **WLSE Autonomous**: A WLSE network management appliance is deployed with autonomous access points from the Aironet products. Some access points act as domain controllers (WDS) for sets of access points in a SWAN architecture, and the access points communicate over the wired network using the WLCCP protocol.

  The WLSE network management station is a Cisco appliance with the WLSE software installed.

- **WCS Controller**: A WCS network management station is deployed on customer selected hardware running Red Hat Enterprise Linux. The network management station manages controller switches that control access points. The controllers communicate over the wired network with access points using the LWAPP protocol.

  - WCS maintains the Cisco wireless LAN solution configuration, which includes controllers, access points, and location appliances.
  - It enables Cisco WCS system administrators to assign logins, passwords, and privileges for all Cisco WCS operators and to set times for periodic system tasks.
  - It allows Cisco WCS operators to use a web browser on any connected workstation to access Cisco WCS configuration, monitoring, and administrative functions. The Cisco WCS operators can also add, change, and delete Wireless LAN Solution components and configurations in the Cisco WCS database, depending on privilege level.

This chapter contains these sections:

- **Supported Hardware**, page C-2
- **Installation and Configuration**, page C-2
- **Configuring the Converted Appliance**, page C-3
- **Licensing**, page C-6
Supported Hardware

Supported Cisco WLSE Management Stations

The conversion from WLSE management station to WCS management station is supported on the Cisco 1130-19 and 1133 hardware platforms.

Note

The conversion from WLSE management station to WCS management station is not supported on the Cisco WLSE 1030 Express platform.

Autonomous Access Points Convertible to LWAPP

The following autonomous AP models can be converted to a WCS controller deployment.

- Cisco Aironet 1230AG Series Access Point (AP 1232AG)
- Cisco Aironet 1200 Series Access Point (AP 1200)
- Cisco Aironet 1130AG Series Access Point (AP 1131AG)

Installation and Configuration

To convert a WLSE network management appliance to a WCS network management station, you need a three CDs:

- A conversion CD for the Wireless Control System version 4.0 release. This CD installs the WCS software and Red Hat Enterprise Linux 3 on the WLSE network management appliance.
- An upgrade CD to upgrade the WCS network management station to Red Hat Enterprise Linux 4. It is necessary to complete the installation of WCS software and Red Hat Enterprise Linux 3 prior to performing the Red Hat Enterprise Linux 4 upgrade due to the partitioning of the WLSE network station.

Note

After you have converted the WLSE network management appliance to a WCS network management station, it is irreversible and you cannot convert back to a WLSE network management appliance.

- An upgrade CD to upgrade the WCS network management station to Red Hat Enterprise Linux 5. It is necessary to complete the installation of WCS software and Red Hat Enterprise Linux 4 prior to performing the Red Hat Enterprise Linux 5 upgrade due to the partitioning of the WLSE network station.

Installing Cisco WCS

Follow these steps to install the Cisco WCS software. You need to have physical access to the WLSE network management appliance. Console access is necessary to the WLSE appliance because the setup and install scripts require console interaction. The complete installation process takes approximately 30 minutes.
Before installing the WCS software, backup any data on your WLSE appliance that you would like for record keeping. To backup the data, refer to Backing Up and Restoring Data in the User Guide for the CiscoWorks WLSE and WLSE Express.

Step 1
Insert the installation CD with the WCS software and the Red Hat Linux Enterprise 3 software into the CD drive of the WLSE network management appliance.

Step 2
Using the command line interface (CLI) prompt, log in the WLSE as administrator.

Step 3
Enter the reload command to reboot. The WLSE reboots, loads, and then installs from the CD. After the install, the CD automatically ejects and reboots again.

Upgrading to Red Hat Enterprise Linux 4

Follow these steps to upgrade the WLSE network management station to Red Hat Enterprise Linux 4 or 5.

Before upgrading the Red Hat Enterprise Linux, you should have already converted WLSE to the Cisco WCS software and Red Hat Linux Enterprise 3 software.

Step 1
Insert the CD with the Red Hat Enterprise Linux upgrade software (either version 4 or 5 as needed) into the CD drive of the WLSE network management appliance.

Step 2
Log in using root as the username and the password you were supplied in the wizard.

Step 3
Enter the reboot command to reboot the WLSE network management appliance.

Minor Upgrades to WCS

If you need to perform a minor upgrade that does not require an upgrade of Red Hat, you can download the upgrade from cisco.com and burn a CD yourself. If you burn a CD yourself, you cannot access the CD drive from the Linux CLI so you must mount the CD drive using mount /dev/cdrom /media.

Configuring the Converted Appliance

After the Linux installation, the machine reboots. You must have a connection to the appliance console, and then you are prompted to log in. After you log in, you go through a series of prompts over the console connection that are addressed below.

Caution
After WLSE is converted to WCS, it can no longer be used as a WLSE or converted back into a WLSE. This is a one-way conversion only.
Note

The WCS server will not start until you have configured the appliance.

localhost.localdomain login:
Enter the login root.
Password:
Enter the password setup.

Setup parameters via Setup Wizard (yes/no) [yes]:

Note

You are prompted to enter and confirm passwords for the following: the operating system root user, the WCS root user, and the FTP user.

Enter yes if you want to use the setup wizard or No if you want to manually set the parameters. Only experienced Linux system administrators should opt to configure the system using the setup script. The option in square brackets is the default. You can press Enter to choose that default.

Current hostname=[localhost]
Configure hostname? (Y)es/(S)kip/(U)se default [Yes]:
The host name is a unique name that can identify the device on the network.
Enter a host name [localhost]:
The host name should start with a letter, end with a letter or number, and contain only letters, numbers, and dashes.

Current domain=[localdomain]
Configure domain name? (Y)es/(S)kip/(U)se default [Yes]:
A domain name specifies the network domain this device belongs to.
Enter a domain name [localdomain]:
The domain name should start with a letter, end with a valid domain name suffix (such as .com), and contain only letters, numbers, dashes, and dots.

Configure root password? (Y)es/(S)kip/(U)se default [Yes]:
Press Enter to choose Yes.
Enter root password:
Confirm root password:
Enter a password for the superuser and confirm it by typing it again. Your typing is not visible.

Remote root login is currently disabled.
Configure remote root access? (Y)es/(S)kip/(U)se default [Yes]:
To enable root login over secure shell for this machine, choose Yes. This allows a root login both from the console and using SSH. Otherwise, choose Skip. If you choose to leave remote root login disabled, then a root login can only occur from the console.
Enable remote root login (yes/no) [no]
Choose yes to allow remote login through SSH in addition to console login. Choose no to allow root login only from the console.

Current IP address=[]
Current eth0 netmask=[]
Current gateway address=[]
Configure eth0 interface parameters? (Y)es/(S)kip/(U)se default [Yes]:
Choose Yes to begin setup for the main ethernet interface. A network administrator can provide the information for the following prompts.
Enter eth0 IP address:
Enter an IP address for the main ethernet interface of this machine.
Enter network mask [255.255.0.0]:
Appendix C  Conversion of a WLSE Autonomous Deployment to a WCS Controller Deployment

Configuring the Converted Appliance

Enter the network mask for the IP address you provided.

Enter default gateway address:
Provide the default gateway that must be reachable from the main ethernet interface.

The second ethernet interface is currently disabled for this machine.

Configure eth1 interface parameters? (Y)es/(S)kip/(U)se default [Yes]:
Choose Yes if you want to provide information for a second ethernet interface. If you choose to configure eth1, you must manually edit the WCS property file (/opt/WCS4.0/webnms/classes/com/aes/common/net/LocalHostUtils.properties) to specify which of the eth1 or eth0 are used to communicate with controllers and which are used to communicate with location servers. (Changing the ManagementInterface= line to either ManagementInterface=eth0 or ManagementInterface=eth1 specifies the controller interface. Changing the PeerServerInterface= line to either PeerServerInterface=eth0 or PeerServerInterface=eth1 specifies the location server interface. This can be skipped, and the next prompt you would see would be DNS.

Enter eth1 IP address [none]:
Enter an IP address for the second ethernet interface on this machine.

Because you entered an IP address for the second interface of this machine, you are given the opportunity to define up to two static routing entries for that interface. Each entry requires a network address, network mask, and a gateway address.

Enter network mask [255.0.0.0]:
Enter the network mask for the IP address you specified.

Enter network [none]:
Enter the network address.

Enter network mask [255.0.0.0]:
Enter the network mask for the IP address you provided.

Enter gateway address:
Enter a gateway address for the network and network mask you provided.

Domain Name Service (DNS) Setup
DNS is currently enabled.
No DNS servers currently defined

Configure DNS related parameters? (Y)es/(S)kip/(U)se default [Yes]:
You can enter up to three DNSs, but you can also leave it disabled. No servers have been defined.

Enable DNS (yes/no) [yes]:
Choose Yes to enable DNS.

Enter primary DNS server IP address:
Enter the IP address for this DNS server.

Enter backup DNS server IP address (or none) [none]:
Enter the backup IP address. If you enter a second DNS server, you are prompted for an optional third server.

Configure timezone? (Y)es/(S)kip/(U)se default [Yes]:
Choose Yes to configure the timezone.

Please identify a location so that time zone rules can be set correctly.
Please select a continent or ocean.
1) Africa
2) Americas
3) Antarctica
4) Arctic Ocean
5) Asia
6) Atlantic Ocean
7) Australia
8) Europe
9) Indian Ocean
10) Pacific Ocean
11) UTC - I want to use Coordinated Universal Time.
12) Return to previous setup step (^).

You need to select a location so that time zone rules can be set correctly. Choose the number for the appropriate continent or ocean.

Please select a country.
You are given a choice of countries based on the continent or ocean you selected. Choose the appropriate number.

Please select one of the following time zone regions.
Enter the number for the desired time zone region based on the country you selected.

The timezone information you chose is given.

Is the above information OK?
1) Yes
2) No

Choose Yes to verify if the information is correct. If No, you will be taken through the series of prompts again.

NTP is currently disabled.
Configure NTP related parameters? (Y)es/(S)kip/(U)se default [Yes]:

If you choose to enable network time protocol (NTP), the system is configured from the NTP servers you select. If you choose Skip, you are prompted to enter the current date and time.

Enable NTP (yes/no) [no]:

If you choose Yes, you will be required to enter an NTP server name or address.

Enter NTP server name or address:
Enter another NTP server IP address (or none) [none]:

All of your selections are shown. You are then asked to verify all the setup information you provided. You can enter Yes to proceed with the configuration, No to make more changes, or ^ to go back to the previous step.

Is the above information correct (yes, no, or ^):

If yes, the configuration information will be applied. Cisco recommends that you reboot the system when prompted to ensure that changes occur. The WCS server starts automatically after the reboot.

The next time you log in using root, you will only get the Linux shell prompt and not the setup script. You can rerun the setup script at any time to change settings by logging in using root and running /opt/setup-appliance/setup.sh.

Licensing

You will need a license to access the complete WCS user interface on the WLSE network management appliance. A discounted WCS WLSE Upgrade License is available for these appliances. When you purchase the license, you receive the WCS-WLSEU-K9-5.0.xx.0.iso conversion file.

Note
In the filename xx represents the version number.

WLSE Upgrade License

The WLSE Upgrade license can only be used on a converted WLSE appliance. It cannot be transferred to a different machine at a later time.
Numerics

802.11a policy name 10-56
802.11b/g RRM interval template 10-66, 10-68
802.11b/g RRM threshold templates 10-65
802.11b/g voice templates 10-61
802.11 counters report 14-12
802.11h template
  configuring 10-67
802.11 security trap 10-74
802.11 tags layer 5-48
802.1X association 6-33
802.1X authentication 6-33
802.3 bridging
  configuring 9-12
access point positions
  changing with import or export of file 5-34
access point reports 14-4
  modifying 14-4
  viewing 14-4
access points
  adding 5-24
  adding to maps 5-24 to 5-25
  configuring 9-19
  configuring for LOMM 9-24
  converting to LWAPP C-2
  detecting 13-12
  searching 9-26
  selecting 10-84
access point security statistics
  for mesh 6-44
access point templates
  adding 10-79
access point threats 6-8
access point traps 10-74
accuracy tool 5-68
ACL template 10-41
  configuring 10-41
ACS server
  adding WCS to 15-4
active interferer count per channel 9-30
active interferers 9-29
active interferers count chart 9-30
active sessions
  monitoring 7-5
adaptive scan threshold 10-65
add config groups 8-18
add group members 8-10
adding access points 5-23
adding access point templates 10-79
adding a license 8-5
adding a migration template 9-18
adding a spectrum expert 9-28

A

AAA override 10-17
AAA servers 10-16
AAA traps 10-74
absolute 16-2
access control list templates 10-55
  CPU 10-41
accessing the schedule panel 14-3
access point
  configuring 10-39
  configuring for hybrid REAP 12-9
  credentials 9-14
  friendly 10-47
access point/radio templates 10-80
access point authentication and MFP templates 10-50
access point authorization template 10-39
access point inventory report 14-9
access point layer 5-45
access point load
  avoiding 10-58
access point placement 5-25
adding autonomous access points
  by CSV file  9-17
adding auto-provisioning filter  15-17
adding chokepoints  5-35
adding controllers  9-2
adding controllers from config group  8-20
adding guest user account  7-17
adding IOS access points  9-16
  by device information  9-16
adding templates from config group  8-21
adding WCS as TACACS+ server  15-5
adding WCS to ACS server  
  for use with RADIUS  15-9
adding WCS to an ACS server  15-4
adding WCS to a non-Cisco ACS server  15-13
adding WCS usergroups  
  into ACS for RADIUS  15-10
  into ACS for TACACS+  15-6
add known rogue  10-69
adjusted link metric  6-37
administration menu  2-21
advanced debug  5-34, 5-64, 5-69
advanced options  5-19
  definition  5-21
advanced tab  
  on WLAN template  10-18
Aironet IE  10-19
alarm  13-1
alarm dashboard  2-22, 13-1
alarm monitor  2-22, 6-13
alarms  13-1
  monitoring  13-4
  rogue access point  13-8
  rogue adhoc  13-10
alarm trigger threshold  10-51
all groups window  15-7
alternate parent  
  for mesh  14-10
altitude  16-2
altitude mode  16-2
analyzing element location accuracy  5-64
anonymous provisioning  10-33
antenna gain  6-29
antenna type  6-28
AP attack details  2-16
AP list by location  14-4
AP list by location report  14-4
AP list by SSID  14-4
AP mesh layer info  5-46
applying calibration models  5-58
applying config groups  8-21
applying controller templates  10-78
AP policies  3-7
AP policies template  10-43
AP profile status report  14-4
APs not assigned to maps  2-15
AP up time  6-42
assigning location presence  5-3
association request failures  6-47
association request success  6-47
association request timeouts  6-47
attacks  
  access points  6-8
audience of document  -xxii
AUDIT_STATUS_DIFFERENCE  13-60
auditing config groups  8-22
auditing H-REAP groups  12-16
audit reports  14-5
  configuring  9-5, 9-26
audit status  
  viewing  9-5
  viewing for access points  9-26
audit trails  
  enabling for guest user activities  7-12
  viewing  7-10
authentication order  
  managing  9-5
authentication priority  9-5
authentication process
  Hybrid REAP 12-2
authentication request failures 6-47
authentication request success 6-47
authentication request timeout 6-47
auto key generation 10-22
automated upgrade 11-16
automatic backups, scheduling 11-4, 15-2
automatic client exclusion 10-20
automatic client troubleshooting 15-29
autonomous access points
  adding by CSV file 9-17
  viewing 9-17
autonomous to LWAPP migration support 9-15
auto provisioning 15-16
  setting 15-21
auto provisioning device information
  detailed 15-19
auto provisioning filter
  deleting 15-20
  editing 15-19
auto-synchronizing location appliances 11-10
avoid access point load 10-58
avoid Cisco AP load 10-58
avoid foreign AP interference 10-58
avoid non-802.11 noise 10-58

B
background tasks 11-14
  running 15-2
backhaul interface 6-46
backing up location appliance data 11-12
backing up the WCS database
  on Linux 11-5 to 11-6
  on Windows 11-5
backup and restore license B-6
bandwidth
  making expedited 10-62
best practices A-1
bridge group name 6-46
bridging link information 6-50
bridging mesh statistics 6-46
broadcast deauthentication frame signatures 3-10
bronze 10-18
bronze queue 6-47
buildings
  adding to a campus map 5-3
  adding to WCS database 5-4
busiest APs report 14-4
busiest clients report 14-7

C
CAC
  enabling 9-7
CA certificates 4-5
CAD files 5-2
calculating access point requirements 5-17
calibration models 5-58
calibration models, applying 5-58
calibration status bar 5-62
call admission control 10-61
campus map, adding to WCS database 5-2
cascade reboot 8-22
cautions, defined -xxiii
CCA sensitivity 10-60
certificate signing request 3-22
changing access point positions 5-34
  by importing or exporting a file 5-34
channels
  monitoring on a floor map 5-51
checking the status of WCS
  on Linux 11-2
  on Windows 11-2
chokepoints 5-35
  adding 5-35
  monitoring 5-43
removing 5-42
using to enhance tag location 5-35
Cisco AP load
avoiding 10-58
Cisco Discovery Protocol 9-23
Cisco UDI 5-20
Cisco Unified Wireless Network Solution 5-64
Cisco WCS base B-2
Cisco WCS location B-2
Cisco Wireless LAN Solution
overview 1-2
security solutions 3-2 to 3-5
civic address 5-4
classification rule 10-44
clear config 9-24
client alarms
most recent 2-15
client association report 14-7
client authentication provision 10-33
client count 2-15, 2-19
client count report 14-7
client devices
connecting to WLANs 12-11
client exclusion 10-20
happening automatically 10-20
client exclusion policies template 10-48
client MFP 3-7
client properties 6-21
client related traps 10-73
client report
creating new 14-8
modifying 14-6, 14-7
viewing 14-6, 14-7
clients
finding 6-30 to 6-32
manually disabled 2-16
map 6-32
monitoring on a floormap 5-53
parameters 5-53
clients detected by location server 2-19
client security component 2-19
clients layer 5-47
client statistics 6-33
client tab
home page 2-15
client traffic 2-16, 2-19
client troubleshooting
automatic 15-29
combined inventory report 14-9
command buttons 2-22
conducting accuracy testing 5-68
config group
adding controllers 8-20
adding templates 8-21
configuring 8-20
downloading IDS signatures 8-24
downloading sw to controllers 8-23
removing controllers 8-20
removing templates 8-21
config groups
applying 8-21
auditing 8-22
creating 8-18
downloading customized webauth 8-25
rebooting 8-22
configure menu 2-21
configuring an 802.11h template 10-67
configuring 802.3 bridging 9-12
configuring an access point 10-39
configuring an access point for hybrid REAP 12-9
configuring access control lists 10-55
configuring access points 9-12, 9-19
configuring alarm severity 13-63
configuring audit reports 9-5
configuring a client exclusion policy template 10-45
configuring config group 8-18
configuring the controller for hybrid REAP 12-6
configuring a CPU ACL template 10-41
<table>
<thead>
<tr>
<th>Index</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>configuring an EAP-FAST template</td>
<td>10-32</td>
</tr>
<tr>
<td>configuring EDCA parameters</td>
<td>9-13</td>
</tr>
<tr>
<td>for individual controllers</td>
<td>10-63</td>
</tr>
<tr>
<td>through a template</td>
<td></td>
</tr>
<tr>
<td>configuring firewall for WCS</td>
<td>3-6</td>
</tr>
<tr>
<td>configuring general templates</td>
<td>10-4</td>
</tr>
<tr>
<td>configuring global credentials</td>
<td>9-14</td>
</tr>
<tr>
<td>configuring global email parameters</td>
<td>15-28</td>
</tr>
<tr>
<td>configuring high density templates</td>
<td>10-59</td>
</tr>
<tr>
<td>configuring a high throughput template</td>
<td>10-68</td>
</tr>
<tr>
<td>configuring H-REAP AP groups</td>
<td>10-21</td>
</tr>
<tr>
<td>configuring Hybrid REAP</td>
<td>12-1</td>
</tr>
<tr>
<td>configuring hybrid REAP access point groups</td>
<td>12-12</td>
</tr>
<tr>
<td>configuring Hybrid-REAP groups</td>
<td>12-13</td>
</tr>
<tr>
<td>configuring IDS</td>
<td>3-9</td>
</tr>
<tr>
<td>configuring IDS signatures</td>
<td>3-9</td>
</tr>
<tr>
<td>configuring intrusion detection systems</td>
<td>3-9</td>
</tr>
<tr>
<td>configuring a LDAP server template</td>
<td>10-26</td>
</tr>
<tr>
<td>configuring a local EAP general template</td>
<td>10-29</td>
</tr>
<tr>
<td>configuring a local EAP profile template</td>
<td>10-31</td>
</tr>
<tr>
<td>configuring a manually disabled client template</td>
<td>10-40</td>
</tr>
<tr>
<td>configuring a mesh template</td>
<td>10-68, 10-69</td>
</tr>
<tr>
<td>configuring multiple country codes</td>
<td>8-15</td>
</tr>
<tr>
<td>configuring a network access control template</td>
<td>10-28</td>
</tr>
<tr>
<td>configuring a policy name template</td>
<td>10-56</td>
</tr>
<tr>
<td>configuring radio templates</td>
<td>10-82</td>
</tr>
<tr>
<td>configuring RADIUS servers</td>
<td>15-23</td>
</tr>
<tr>
<td>configuring a roaming parameters template</td>
<td>10-63</td>
</tr>
<tr>
<td>configuring a rogue policies template</td>
<td>10-42</td>
</tr>
<tr>
<td>configuring an RRM interval template</td>
<td>10-66</td>
</tr>
<tr>
<td>configuring an RRM threshold template</td>
<td>10-65</td>
</tr>
<tr>
<td>configuring SNMPv3</td>
<td>9-13</td>
</tr>
<tr>
<td>configuring spectrum experts</td>
<td>9-28</td>
</tr>
<tr>
<td>configuring the switch</td>
<td></td>
</tr>
<tr>
<td>for hybrid REAP</td>
<td>12-4</td>
</tr>
<tr>
<td>configuring TACACS+ servers</td>
<td>15-16</td>
</tr>
<tr>
<td>configuring a TACACS+ server template</td>
<td>10-27</td>
</tr>
<tr>
<td>configuring a TFTP server template</td>
<td>10-71</td>
</tr>
<tr>
<td>configuring a trusted AP policies template</td>
<td>10-43</td>
</tr>
<tr>
<td>configuring a user authentication priority template</td>
<td>10-78</td>
</tr>
<tr>
<td>configuring a user login policies template</td>
<td>10-37</td>
</tr>
<tr>
<td>configuring a video parameter template</td>
<td>10-62</td>
</tr>
<tr>
<td>configuring a voice parameter template</td>
<td>10-61</td>
</tr>
<tr>
<td>configuring templates</td>
<td></td>
</tr>
<tr>
<td>802.11a policy name</td>
<td>10-55</td>
</tr>
<tr>
<td>802.11b/g RRM interval</td>
<td>10-66</td>
</tr>
<tr>
<td>802.11b/g RRM threshold</td>
<td>10-62</td>
</tr>
<tr>
<td>802.11b/g voice</td>
<td>10-61</td>
</tr>
<tr>
<td>access point/radio</td>
<td>10-80</td>
</tr>
<tr>
<td>access point authentication and MFP</td>
<td>10-43</td>
</tr>
<tr>
<td>access point authorization</td>
<td>10-39</td>
</tr>
<tr>
<td>ACL</td>
<td>10-40</td>
</tr>
<tr>
<td>file encryption</td>
<td>10-22</td>
</tr>
<tr>
<td>guest users</td>
<td>10-36</td>
</tr>
<tr>
<td>known rogue access point</td>
<td>10-67</td>
</tr>
<tr>
<td>local management user</td>
<td>10-77</td>
</tr>
<tr>
<td>local net users</td>
<td>10-26</td>
</tr>
<tr>
<td>MAC filter</td>
<td>10-38</td>
</tr>
<tr>
<td>QoS</td>
<td>10-7</td>
</tr>
<tr>
<td>RADIUS accounting</td>
<td>10-25</td>
</tr>
<tr>
<td>RADIUS authentication</td>
<td>10-23</td>
</tr>
<tr>
<td>for rogue AP rule groups</td>
<td>10-45</td>
</tr>
<tr>
<td>syslog</td>
<td>10-75</td>
</tr>
<tr>
<td>Telnet SSH</td>
<td>10-74</td>
</tr>
<tr>
<td>traffic stream metrics QoS</td>
<td>10-8</td>
</tr>
<tr>
<td>trap control</td>
<td>10-72</td>
</tr>
<tr>
<td>trap receiver</td>
<td>10-71</td>
</tr>
<tr>
<td>web authentication</td>
<td>10-51</td>
</tr>
<tr>
<td>WLAN</td>
<td>10-9</td>
</tr>
<tr>
<td>configuring wired guest access</td>
<td>9-30</td>
</tr>
<tr>
<td>connecting client devices</td>
<td></td>
</tr>
<tr>
<td>to WLANs</td>
<td>12-11</td>
</tr>
<tr>
<td>connecting to the Guest WLAN</td>
<td>3-21</td>
</tr>
<tr>
<td>containment</td>
<td></td>
</tr>
<tr>
<td>of rogue access points</td>
<td>6-12</td>
</tr>
<tr>
<td>content</td>
<td></td>
</tr>
<tr>
<td>customizing</td>
<td>2-18</td>
</tr>
</tbody>
</table>
controller
  configuring for hybrid REAP  12-6
controller CPU utilization  2-19
controller inventory report  14-9
controller inventory status  2-19
controller memory utilization  2-19
controllers
  adding  9-2
  adding to WCS database  4-2
  pinging network devices  9-7
  searching  9-4
  specified  1-2
controller templates
  applying  10-79
controller utilization report  14-12
controller values
  refreshing  9-6
conventions of document  -xxiii
converting WLSE autonomous to WCS controller  C-1
counters report
  for 802.11  14-12
country codes
  multiple  8-15, 9-3
  setting  9-3
coverage areas  2-19
coverage hole  2-15, 6-60
coverage holes
  finding  5-10
  monitoring on floormap  5-52
  summary report  14-12
creating a lobby ambassador account  7-14
creating a network configuration audit  14-6
creating a network design  5-28
creating a new access point report  14-5
creating a new client report  14-8
creating a new inventory report  14-9
creating a new mesh report  14-6, 14-11
creating a new performance report  14-12
creating a new security report  14-14
creating calibration models  5-46
creating guest user accounts  7-12
creating placemarks  16-3
CSR  3-22
CSV file  9-17, 15-18, 16-4
CSV file format  10-35
customized web auth  3-18, 9-31
  downloading  8-25, 10-53
customizing content on WCS Home page  2-18
customizing tabs on WCS Home page  2-17
custom signature  3-15

d
data/coverage  5-20
data management tasks
  performing  15-25
data point collection  5-59
debug commands  A-4
debug strategy  A-4
default lobby ambassador credentials
  editing  7-10
deleting a guest user  3-21
deleting guest user templates  7-19
deleting a license  B-6
deleting a report  14-3
deleting WCS user accounts  7-4
designing a network  5-28
detailed auto provisioning device information  15-19
detecting access points  13-12
detecting rogue access points  6-13
device certificates  4-5
device information  9-16
DHCP  6-33
DHCP server
  overriding  10-20
DHCP statistics  6-62
diagnostic channel  A-2
disable report schedule  14-2
disabling IDS signatures 3-14
DNS ping 6-33
DNS resolution 6-33
document
  audience xxii
  conventions xxiii
  organization xxii
  purpose xxii
documentation
  obtaining xxiv
downloading a customized web authentication page 10-53
downloading customized webauth 3-18, 8-25
downloading IDS signatures 3-13
  from your config group 8-24
downloading sw to controllers
  after adding config group 8-23
downloading vendor CA certificates 4-5
downloading vendor device certificates 4-5
download logs 5-71
downstream delay 10-9
downstream packet loss rate 10-9
drawing polygon areas
  using map editor 5-14
DTIM 10-57

E
EAP-FAST template 10-32
EAPOL flood signature 3-11
EDCA parameters
  configuring for individual controllers 9-13
  configuring through a template 10-63
editing the default lobby ambassador credentials 7-10
editing guest users 7-18
editing signature parameters 3-16
edit link 5-9
  home page 2-17
edit location presence information 5-3
edit view 13-5
egress interface 9-31
email
  configuring parameters 15-27
email notifications
  monitoring 13-13
enable report schedule 14-2
enabling audit trails
  for guest user activities 7-12
enabling high density 9-9
enabling IDS signatures 3-14
enabling load-based CAC 9-6
enabling location presence 5-7
enabling Web login 3-17
end user license agreement B-7
entry chokepoint 5-43
establishing logging options 15-24
event history 6-18
event notification 1-5
events 13-1
  monitoring 13-12
excluded packets 6-46
exit chokepoint 5-43
expedited 10-62
expedited bandwidth 10-62
exporting a file
  to change access point position 5-34
exporting asset information 11-10
exporting WLSE map data 5-55
export task list 15-7
extend to ground 16-2
external web auth 9-32
extracting task list 15-14

F
failed objects
  monitoring 13-7
failure object 6-7
feature license B-3
file encryption template  10-22
filter
deleing auto provisioning  15-20
editing current auto provisioning  15-19
filtering
using to modify maps  6-50
filter member management  15-18
filter mode  15-17
filter properties  15-18
finding clients  6-30
finding coverage holes  5-10
firewall, configuring for WCS  3-6
floor plans
adding to a campus building  5-11 to 5-12
adding to a standalone building  5-12 to 5-13
enhancing with map editor  5-13
foreign access point interference
avoiding  10-58
foreign AP interference
avoiding  10-58
frame type  3-15
friendly access point template  10-47
friendly rogue  10-44
friendly rogue access points  6-4
global settings
for standard and custom signatures  3-16
global username and password
overriding  9-23
gold  10-18
gold queue  6-47
Google Earth coordinates  16-2
Google Earth maps  16-1
viewing  6-52
Google KML or CSV
importing into WCS  16-6
GPS markers  5-4
grid of plus marks  5-60
groups
for hybrid-REAP  12-13
for rogue access point rules  10-45
group setup window on ACS server  15-9
GUEST_USER_ADDED  13-58
GUEST_USER_AUTHENTICATED  13-58
guest user
deleting  3-21
guest user account
adding  7-17
creating  7-12
managing  7-16
scheduling  7-20
guest user activities  7-12
guest user credentials  7-18
guest user details
emailing  7-21
print  7-21
guest users
viewing and editing  7-18
guest user templates  10-36
deleting  7-19
guest WLAN
connecting  3-21
guidelines for using the map editor  5-13

G
general tab
client properties  6-21
home page  2-14
RF properties  6-23
security  6-24
general templates
configuring  10-4

generate password  10-36
GEO check box  5-8
geographical coordinates  16-1
global credentials
configuring  9-14
heater status 6-42
heat map
described 5-25
graphic 5-25
help menu 2-22
hierarchy
of mesh network 6-49
hierarchy of mesh parent to child 6-51
high density
enabling 9-9
high density requirements 9-9
high density templates 10-59
high throughput template
configuring 10-68
historical report type 14-1
home page
customizing content 2-18
customizing tabs 2-17
H-REAP AP groups
configuring 10-21
H-REAP configuration tab 10-22
H-REAP groups
auditing 12-16
Hybrid REAP
configuring 9-1, 12-1
hybrid REAP access point groups 12-12
hybrid-REAP groups 12-13
Hybrid REAP local switching 10-19
hysteresis 10-65

IDS 3-9
configuring 3-9
IDS sensors 3-9
IDS signature events
viewing 3-17
IDS signatures 3-9
disabling 3-14
downloading 3-13
downloading from config group 8-24
enabling 3-14
uploading 3-12
importing a file
to change access point position 5-34
importing asset information 11-10
importing coordinates
as CSV file 16-4
into Google Earth 16-2
importing Google KML or CSV into WCS 16-6
importing WLSE map data 5-55
indicator of alarms 2-22
information elements
Aironet 10-19
infrastructure MFP 3-7
ingress interface 9-31
input type 15-18
inspect location readiness 5-22
inspect VoWLAN readiness 5-23
installer
using to upgrade 11-16
installing a license B-4
installing WCS
for WLSE conversion C-2
insufficient memory 6-46
interferers
summary 9-29
internal web auth 9-31
inter-subnet roaming 8-4
intrusion detection systems 3-9
invalid association request 6-48
invalid reassociation request 6-48
invalid reauthentication request 6-48
inventory detail status 2-15
inventory reports 14-8
creating 14-9
Index

modifying 14-9
viewing 14-9
inventory status 2-19
IOS access points
  adding 9-16
  adding by device information 9-16
IOSAP_DOWN 13-59
IOSAP_LINK_DOWN 13-59
IOSAP_LINK_UP 13-59
IOSAP_UP 13-59
IP connectivity 6-33
IPSEC failures 6-8

K

KEK
  key encryption key 10-24
key wrap 10-24
KML file 16-2

L

laptop icon 6-32
latitude 16-1
Layer 1 security solutions 3-2
Layer 2 10-12
Layer 2 security solutions 3-2
Layer 3 10-14
Layer 3 security solutions 3-2
Layer 3 to Layer 2 mode, converting Cisco Wireless LAN Solution 3-5
LBS authorization 10-39
LDAP server
  configuring a template for 10-26
LEAP authentication
  requirements 8-8
legacy syslog template 10-75
license
  adding B-5
backup and restore B-6
deleting B-6
license agreement B-7
license installation B-4
license management B-5
licenses B-2
license types B-2
licensing
  on WLSE network management C-3
lifetime 7-19
linear point collection 5-59
link aggregation 10-5
link aggregation (LAG) guidelines 12-4
link metric
  adjusted 6-37
  unadjusted 6-37
link SNR 6-37
link stats
  for mesh 14-10
link test
  running 6-55
link test results 6-37
list all filters 15-19
load 5-43
load-based CAC 10-62
  enabling 9-7
lobby ambassador 7-12
  logging activities 7-21
lobby ambassador account
  creating 7-14
  editing 7-15
lobby ambassador defaults setting 7-9
local authentication
  for hybrid-REAP groups 12-13
local EAP check box 10-17
local EAP general template 10-29
local EAP profile template 10-31
local management user template 10-77, 10-78
local net users template 10-34
local password policy 15-21
local switching
  Hybrid REAP 10-19
locating rogue access points 6-13
  of rogue access points 6-12
location accuracy
  analyzing 5-64
  using testpoints 5-64
location appliance
  importing 11-8
location appliance data
  backing up 11-12
location appliance functionality 4-3
location appliance importing 11-8
location appliances
  adding to WCS database 4-2
  auto-synchronizing 11-11
  relationship with WCS Location 1-5
location inventory status 2-19
location menu 2-21
location optimized monitor mode 9-21
location presence
  assigning 5-3
  on a location server 5-7
location readiness
  inspecting 5-22
location server inventory report 14-9
location server utilization 14-12
location tab 6-27
location upgrade B-2
log analysis 6-17
logging 15-4
logging in
  to the WCS user interface 7-15
logging into the WCS user interface 2-13 to 2-14
logging options 15-24
logging the lobby ambassador activities 7-21
login.html 3-18
LOMM 9-21
  configuring access point radios 9-24
longitude 16-3
long preambles, enabling for SpectraLink NetLink phones 4-6
LWAPP migration 9-15

M
MAC filtering 10-14
MAC filter template 10-38
MAC frequency 3-15
MAC information 3-15
MACK
  message authenticator code keys 10-24
Maintain Image Aspect Ratio 5-54
maintaining WCS 11-1 to 11-20
malformed neighbor packets 6-46
malicious rogue 10-44
malicious rogue access points 6-4
  most recent 6-7
management frame flood signatures 3-10
management frame protection 3-7, 10-50
management queue 6-47
managing guest user accounts 7-16
managing licenses B-5
managing multiple WCSs 1-7
managing user authentication order 9-5
manually disabled client 2-16
  template for 10-40
manufacturer information 6-28
map
  adding chokepoints 5-35
  removing chokepoints 5-42
map editor
  general notes and guidelines 5-13
  using to draw polygon areas 5-14
map editor, enhancing floor plans 5-13
maps
creating 5-2 to 5-25
monitoring 5-43, 5-43 to 5-54
searching 5-9
using to monitor link stats 6-35
using to monitor mesh AP neighbors 6-40
map view
upating 6-51
menu bar 2-21
mesh access point neighbors
monitoring 6-40
mesh access points
monitoring 6-38
mesh alarms
most recent 2-17
mesh alternate parent 14-10
mesh health 6-42
monitoring 6-42
mesh link statistics 6-35
monitoring 6-35
mesh link stats 14-10
mesh neighbors 6-41
mesh network
monitoring using maps 6-35
mesh network hierarchy 6-49
mesh networks
monitoring 6-35
mesh node hops 14-10
mesh packet error statistics 14-10
mesh packet statistics 14-10
mesh parent-child hierarchical view 5-46
mesh report
creating 14-6, 14-11
modifying 14-11
viewing 14-11
mesh security statistics
for an AP 6-42
mesh statistics
for an access point 6-44
mesh stranded APs 14-10
mesh tab
home page 2-17
mesh template
configuring 10-69
mesh tree
viewing 6-49
mesh worst node hops 14-10
mesh worst SNR links 14-10
message integrity check information element 10-50
metrics
in QoS 10-8
MFP 3-7
for clients 3-7
MFP client protection 10-20
MFP signature generation 10-20
MFP templates 10-50
MIC IE 10-50
minimum RSSI 10-64
mirror mode 9-22
mobile announce messages 8-8
mobility 8-2
mobility anchors 8-13
mobility groups 8-7
configuring 8-8
prerequisites 12-4
mobility scalability 8-11
modifying access point reports 14-4
modifying audit reports 14-6
modifying client reports 14-6, 14-7
modifying inventory reports 14-9
modifying map displays 6-50
using filters 6-50
modifying mesh reports 14-11
modifying a migration template 9-18
modifying performance reports 14-12
modifying security reports 14-14
monitoring active sessions  7-5
monitoring alarms  13-4
monitoring channels
  on a floor map  5-51
monitoring chokepoints  5-43
monitoring clients
  on a floormap  5-53
monitoring coverage holes
  on a floormap  5-52
monitoring email notifications  13-13
monitoring events  13-12
monitoring failed objects  13-7
monitoring maps  5-43
monitoring mesh access point neighbors  6-40
  using maps  6-40
monitoring mesh health  6-37, 6-42, 6-52
monitoring mesh link statistics
  using maps  6-35
monitoring mesh networks
  using maps  6-35
monitoring outdoor areas  5-54
monitoring pre-coverage holes  6-60
monitoring predicted coverage  5-44
monitoring rogue access point alarms  13-7
monitoring rogue access point details  13-9
monitoring rogue access points  6-8
monitoring rogue adhoc alarms  13-10
monitoring rogue adhocs  6-10
monitoring rogue clients  6-10, 13-13
monitoring security configurations  13-14
monitoring shunned clients  6-11
monitoring spectrum experts  9-28
monitoring transmit power levels
  on a floormap  5-51
monitor menu  2-21
monitor mode
  location optimized  9-21
most recent AP alarms  2-19
most recent client alarms  2-15
most recent malicious rogue  6-7
most recent mesh alarms  2-17
most recent rogue adhocs  3-3, 6-7
most recent security alarms  2-16
most recent security alerts  6-7
multicast mobility mode  8-12
multiple country codes
  configuring  8-15
  setting  9-3
multiple syslog template  10-76

N
N+1 redundancy  8-5
NAT  8-11
Navigator  1-7
NetStumbler signature  3-11
network access control
  configuring template  10-28
network address translation  8-11
network design  5-28
network protection  3-9
Network Summary page  2-14
new rogue AP count report  14-13
new rogue APs report  14-13
new search  5-9
node hop count
  worst  2-17
node hops  6-46
  for mesh  14-10
noise
  avoiding non-802.11 types  10-58
non-802.11 noise
  avoiding  10-58
non-Cisco ACS server
  for use with RADIUS  15-13
note, defined xxiii
NTP server template  10-3
null probe response signatures  3-10
queue 14-10
queues
  silver, gold, platinum, bronze, management 6-47
quiet time 3-15

R
radio inventory status 2-19
radio measurements
  receiving 6-34
radio receiver sensitivity 6-29
radio resource management 10-58
radio status
  scheduling 9-25
radio templates
  configuring 10-82
radio utilization report 14-12
RADIUS accounting template 10-25
RADIUS authentication template 10-23
RADIUS servers
  configuring 15-23
reachability status 9-28
reassociation request failures 6-48
reassociation request success 6-48
reassociation request timeouts 6-48
reauthentication request failures 6-48
reauthentication request success 6-48
reauthentication request timeout 6-48
rebooting config groups 8-22
receiving radio measurements 6-34
recent alarms 2-19
recent coverage holes 2-15, 2-19
recent map 6-32
recent rogue adhoc alarm 2-16
recent rogue AP alarms 2-16
recovering the WCS password 11-21
refresh browser 5-43
refresh controller values 9-6
refresh from network 5-43
refresh heatmap 5-43
related publications xxiii
relative to ground 16-2
removing chokepoints 5-42
removing controllers from config group 8-20
removing templates from config group 8-21
report
  802.11 counters 14-12
  access point inventory 14-9
  busiest APs 14-4
  busiest clients 14-7
  client association 14-7
  client count 14-7
  combined inventory 14-9
  controller inventory 14-9
  controller utilization 14-12
  coverage hole summary 14-12
  deleting 14-3
  location server inventory 14-9
  location server utilization 14-12
  mesh alternate parent 14-10
  mesh worst node hops 14-10
  radio utilization 14-12
  security summary 14-13
  traffics stream metrics 14-4
  traffic stream metrics 14-7
  Tx power level and channel 14-12
  unique client 14-7
  voice statistics 14-12
reporting tag location 5-35
reports
  access point type 14-4
  disable schedule 14-2
  enable schedule 14-2
  mesh link stats 14-10
  mesh node hops 14-10
  mesh packet error statistics 14-10
  mesh packet statistics 14-10
  mesh worst SNR links 14-10
running  14-1
reset AP now  9-24
restore WCS values  9-6
restoring WCS database on Linux  11-7
restrict by protocol  6-31
retention expiration  5-9
retransmission rule enable  5-8
retrieving UDI  6-56
RF calibration model, creating  4-7
RF calibration tool  1-7
RF prediction heat map  5-25
RF profile traps  10-74
RF properties  6-23
RF update traps  10-74
RLDP  10-43
roaming  8-2
roaming parameters template
  configuring  10-64
roaming time  10-8, 10-9
ROGUE_AP_NOT_ON_NETWORK  13-61
rogue access point alarms
  monitoring  13-7
rogue access point details  13-9
rogue access point location  6-12
rogue access point rule groups  10-45
rogue access point rules
  configuring a template  10-43
  viewing or editing  9-27
rogue access points
  alarm monitor  6-13
  detecting  6-13
  detecting and locating  6-13 to 6-14
  friendly  6-4
  locating  6-13
  malicious  6-4
  monitoring  6-2 to ??, 6-8
  solutions for  3-3
  unclassified  6-5
rogue adhoc alarm  2-16
rogue adhoc alarms
  monitoring  13-10
rogue adhoc detail summary  2-19
rogue adhocs  6-6
  monitoring  6-10
  most recent  3-3, 6-7
rogue adhocs event report  14-13
rogue AP alarms  2-16
rogue AP detail summary  2-19
rogue APs event report  14-13
rogue APs layer  5-49
rogue APs report  14-13
rogue clients
  monitoring  6-10, 13-13
rogue clients layer  5-50
rogue detector  9-22
rogue location discovery protocol  10-43
rogue management  3-3
rogue policies
  template for  10-42
rogues detected by APs  14-13
routing state  6-46
RRM intervals  10-67, 10-68
RRM interval template
  configuring  10-66, 10-68
RRM thresholds  10-65
RRM threshold template
  configuring  10-65
rules
  for rogue access point  10-43
  viewing or editing for rogue access points  9-27
running a link test  6-55
running background tasks  15-2
running reports  14-1
RX neighbor requests  6-46
RX neighbor responses  6-46
Rx sensitivity  10-60
S

saved searches 5-9
scalability parameters 8-11
scan threshold 10-65
scheduled accuracy testing 5-68
scheduled tasks
  viewing 9-25
schedule panel
  accessing 14-3
scheduling guest user account 7-20
scheduling radio status 9-25
search
  using for alarms 13-6
search clients 6-31
searching controllers 9-4
searching maps 5-7
security alarms
  most recent 2-16
security alerts
  most recent 6-7
security configurations
  monitoring 13-14
security mesh statistics 6-47
security reports 14-13
  creating 14-14
  modifying 14-14
  viewing 14-14
security solutions 3-2 to 3-5
security statistics
  for mesh 6-44
security summary report 14-13
security summary window 6-2
security tab
  home page 2-16
selecting access points 10-84
sending mobile announce messages 8-8
sensors
  viewing IDS types 3-9
sequence parameter 10-56
serial number 6-28
servers
  synchronizing WCS and location servers 11-9
service options
  definitions 5-20
setting lobby ambassador defaults 7-9
setting multiple country codes 9-3
shunned clients
  monitoring 6-11
sidebar area 2-22
signature attacks 6-7
signature attacks summary 2-16
silver 10-18
silver queue 6-47
single device 15-18
skull-and-crossbones indicator 6-14
sniffer 10-81
sniffer mode 9-22
SNMP authentication 10-73
SNMPv3
  configuring 9-13
SNR definition 6-51
SNR down 6-37
SNR link
  worst 2-17
SNR UP 6-37
software
  downloading config groups to controllers 8-23
software, updating 4-4
SpectraLink NetLink phones, enabling long preambles 4-6
spectrum expert
  adding 9-28
spectrum expert details 9-30
spectrum experts
  configuring 9-28
  monitoring 9-28
  summary 9-29
standard signatures 3-9, 3-15
starting WCS
  on Linux 2-12
  on Windows 2-12
statistics
  DHCP 6-62
statistics tab 6-25
status, checking 11-2
status report
  AP profile 14-4
stopping WCS
  on Linux 11-3
  on Windows 11-3
supported Cisco WLSE management stations C-2
switch
  configuring for hybrid REAP 12-4
symmetric mobility tunneling 10-5
symmetric tunneling 8-5
synchronize servers 11-9
syslog templates 10-75, 10-76
system requirements 2-2

T

TACACS+ server
  configuring a template for 10-27
TACACS+ servers
  configuring 15-22
tagging
  of rogue access points 6-12
tag location reporting 5-35
target TSF 6-34
tasks
  importing into ACS 15-4
Telnet SSH templates 10-74
temperature 6-42
template
  configuring for rogue AP rules 10-43
template for configuring network user credentials 10-34
templates
  using 10-1
test analysis 6-33
testing
  accuracy 5-68
testpoints 5-64
TFTP server 3-12
TFTP server template
  configuring 10-71
threats
  access points 6-8
tilt 16-2
tool to conduct accuracy testing 5-68
top APs by client count 2-15
total APs not assigned to maps 2-15
total interferer count 9-30
traffic indicator message 10-57
traffic stream metrics 10-62
traffic stream metrics QoS status 10-8
traffic stream metrics QoS template 10-8
traffic stream metrics report 14-4, 14-7
  graphical 14-4
transition time 10-65
transmit power level 10-58
  monitoring on a floor map 5-51
  monitoring on a floor map values 5-52
trap
  802.11 security 10-74
trap control templates 10-72
trap receiver template 10-71
traps
  AAA 10-74
  access point 10-74
  client related 10-73
  RF profile 10-74
  RF update 10-74
  unsupported 13-63
  WPS 10-74
traps added in 2.1  13-33
traps added in 2.2  13-37
traps added in 3.0  13-39
traps added in 3.1  13-41
traps added in 3.2  13-44
traps added in 4.0  13-45
traps added in 4.0.96.0  13-49
traps added in 4.1  13-51, 13-58
traps added in 4.2  13-58
traps added in 5.0  13-62
trend report type  14-1
troubleshooting  A-1
troubleshooting voice RF coverage  5-23
trusted AP policies
  template for  10-43
trusted AP policies template  10-43
tunneling  8-5
turning password rules on or off  15-16
Tx channel report  14-12
Tx neighbor requests  6-46
Tx neighbor responses  6-46
Tx power level report  14-12

U
UDI
  retrieving on controllers and access points  6-57
unadjusted link metric  6-37
unclassified rogue  10-44
unclassified rogue access points  6-5
uninstalling WCS
  on Linux  11-15
  on Windows  11-15
unique client report  14-7
unique device identifier  6-57
unknown association requests  6-48
unknown reassociation request  6-49
unknown reauthentication request  6-49
update map view  6-51

updating system software  4-4
upgrading the network  11-21
upgrading to Linux 4
during WLSE conversion  C-3
upgrading WCS
  on Linux  11-20
  on Windows  11-20
uploading IDS signatures  3-12
upstream delay  10-9
upstream packet loss rate  10-9
user accounts
  for guest  7-12
user authentication order
  managing  9-5
user authentication priority template
  configuring  10-78
user credential retrieval priority  10-34
user details
  emailing  7-21
  printing  7-21
user groups  7-3
user interface  2-20
user login policies
  configuring a template  10-37
user preferences  15-31
using chokepoints  5-34
to enhance tag location reporting  5-34
using edit view  13-5
using filtering  6-50
using maps
  to monitor mesh AP neighbors  6-40
  to monitor mesh link statistics  6-35
using maps to monitor mesh networks  6-35
using planning mode  5-14
using search  13-6
using template
  ACL  10-41
  for friendly access point  10-47
Index

using templates 10-1
  802.11a policy name 10-56
  802.11b/g RRM interval 10-66, 10-68
  802.11b/g RRM threshold 10-65
  802.11b/g voice 10-61
  access point/radio 10-80
  access point authentication & MFP 10-50
  access point authorization 10-39
file encryption 10-22
  for legacy syslog 10-75
  for multiple syslog 10-76
guest users 10-36
  local management user 10-77, 10-78
  local net users 10-34
MAC filter 10-38
NTP server 10-3
QoS 10-7
  RADIUS accounting 10-25
  RADIUS authentication 10-23
syslog 10-75, 10-76
  Telnet SSH 10-74
  traffic stream metrics QoS 10-8
trap control 10-72
trap receiver 10-71
web authentication 10-51
WLAN 10-9
using testpoints
  to analyze element location accuracy 5-64
using the installer to upgrade 11-16
utilization report
  for controllers 14-12

V

V5 Client Statistics Report 14-7
vendor CA certificates
  downloading 4-5
vendor device certificates
  downloading 4-5
video parameter template
  configuring 10-62
view audit reports 9-5
view filters icon 5-45, 5-51, 5-52, 5-53
viewing access point reports 14-4
viewing audit reports 14-6
viewing audit status 9-5
  for access points 9-26
viewing autonomous access points 9-17
viewing client reports 14-7
viewing clients
  identified as WGBs 6-54
viewing DHCP statistics 6-62
viewing Google Earth maps 6-52, 16-6
viewing guest users 7-18
viewing IDS signature events 3-17
viewing inventory reports 14-9
viewing mesh reports 14-11
viewing mesh tree 6-44
viewing MFP events 13-4
viewing performance reports 14-12
view in grid 2-19
viewing security reports 14-14
viewing shunned clients 3-9
viewing the audit trail 7-10
voice parameter template
  configuring 10-61
voice RF coverage
  troubleshooting 5-23
voice statistics report 14-12
voice traffic 5-20
VoWLAN readiness
  inspecting 5-23

W

WCS
  checking status
    on Linux 11-2
on Windows 11-2
installing 2-4
maintaining 11-1 to 11-20
overview 1-3
servers supported 1-3
starting
  on Linux 2-12
  on Windows 2-12
stopping
  on Linux 11-3
  on Windows 11-3
uninstalling
  on Linux 11-15
  on Windows 11-15
upgrading
  on Linux 11-20
  on Windows 11-20
versions 1-4 to 1-6
WCS_EMAIL_FAILURE 13-60
WCS-ADV-SI-SE-10 B-3
WCS Base, described 1-4, 1-6
WCS controller deployment
  from WLSE autonomous C-1
WCS database
  adding chokepoints 5-35
  adding controllers 4-2
  adding location appliances 4-2
backing up
  on Linux 11-5 to 11-6
  on Windows 11-5
removing chokepoints 5-42
restoring
  on Linux 11-7
  on Windows 11-6
scheduling automatic backups 11-4, 15-2
WCS licenses B-2
WCS Location
  described 1-5 to 1-6
  relationship with Cisco location appliances 1-5
WCS Navigator 1-7
WCS on WLSE
  licensing C-6
WCS passwords
  recovering 11-21
WCS user accounts
  adding 7-2
  changing passwords 7-4
  deleting 7-4
WCS user interface 7-16
  described 1-3, 1-7
  logging into 2-13 to 2-14
WCS values
  restoring 9-6
web authentication template 10-51
web authentication types 3-18
web auth security A-3
web auth types 9-31
web login
  enabling 3-17
Wellenreiter signature 3-11
WGB 9-18
WGBs
  viewing those clients 6-54
wired guest access
  configuring 9-30
Wireless Control System (WCS)
  See WCS
WLANs
  web auth security A-3
WLAN templates 10-9
WLSE autonomous deployment conversion C-1
WLSE management stations C-2
WLSE map data
  exporting 5-55
importing 5-55
WLSE upgrade B-2
WLSE upgrade license C-6
WMM policy 10-18
work group bridge mode 9-18
worst node hop count 2-17
worst node hops
  for mesh 14-10
worst packet error rate 2-17
worst SNR link 2-17
worst SNR links
  for mesh 14-10
WPS traps 10-74