THE SPECIFICATIONS AND INFORMATION REGARDING THE PRODUCTS IN THIS MANUAL ARE SUBJECT TO CHANGE WITHOUT NOTICE. ALL STATEMENTS, INFORMATION, AND RECOMMENDATIONS IN THIS MANUAL ARE BELIEVED TO BE ACCURATE BUT ARE PRESENTED WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED. USERS MUST TAKE FULL RESPONSIBILITY FOR THEIR APPLICATION OF ANY PRODUCTS.

THE SOFTWARE LICENSE AND LIMITED WARRANTY FOR THE ACCOMPANYING PRODUCT ARE SET FORTH IN THE INFORMATION PACKET THAT SHIPPED WITH THE PRODUCT AND ARE INCORPORATED HEREIN BY THIS REFERENCE. IF YOU ARE UNABLE TO LOCATE THE SOFTWARE LICENSE OR LIMITED WARRANTY, CONTACT YOUR CISCO REPRESENTATIVE FOR A COPY.

The Cisco implementation of TCP header compression is an adaptation of a program developed by the University of California, Berkeley (UCB) as part of UCB's public domain version of the UNIX operating system. All rights reserved. Copyright © 1981, Regents of the University of California.

NOTWITHSTANDING ANY OTHER WARRANTY HEREIN, ALL DOCUMENT FILES AND SOFTWARE OF THESE SUPPLIERS ARE PROVIDED "AS IS" WITH ALL FAULTS. CISCO AND THE ABOVE-NAMED SUPPLIERS DISCLAIM ALL WARRANTIES, EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THOSE OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OR ARISING FROM A COURSE OF DEALING, USAGE, OR TRADE PRACTICE.

IN NO EVENT SHALL CISCO OR ITS SUPPLIERS BE LIABLE FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL, OR INCIDENTAL DAMAGES, INCLUDING, WITHOUT LIMITATION, LOST PROFITS OR LOSS OR DAMAGE TO DATA ARISING OUT OF THE USE OR INABILITY TO USE THIS MANUAL, EVEN IF CISCO OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: http://www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

© 2003-2013 Cisco Systems, Inc. All rights reserved.
CONTENTS

Preface ix
  Purpose ix
  Audience ix
  Organization ix
  Related Documentation x
  Product Naming Conventions x
  Conventions xi
  Documentation and Service Requests xii
  Documentation Feedback xii

PART I Agent Management and Call Routing 1

CHAPTER 1 Cisco Unified Contact Center Enterprise Agents 3
  Agent Administration 3
    Agents 3
    Database Records for Voice-Only Agents 4
    Database Records for Multichannel Agents 4
    Agent Desk Settings Configuration 4
    Agent Teams and Supervisors 5
    Agent teams and Multichannel Applications 6
    Single-Line Versus Multi-line Behavior 6

CHAPTER 2 CTI OS and Cisco Agent Desktop Feature Configuration 9
  Agent Feature Configuration with Agent Desk Settings List Tool 9
    Agent Wrap-Up 9
    Reason Codes 10
    Agent Desk Settings That Affect Reason Codes 10
Agent Feature Configuration 30
  Configure Unified CCE for Redirection on No Answer on IP IVR 31
  Configure Unified CCE for Redirection on No Answer on Cisco Unified CVP 32
  Configure Automatic Wrap-Up 33
  Configure Supervisor Assist and Emergency Alert 34
Supervisor Feature Configuration 35
  Configure Supervisor Logged-In State for CAD 35
Agent Re-skilling Tool 35
  Access Agent Re-skilling Tool 35
Network Transfer for IVR Configuration 36
  Configure Network Transfer from IP Phone 36
  Configure Network Transfer from CTIOS Desktop 37

CHAPTER 5
Voice Call Routing with Cisco Unified Contact Center Enterprise 39
  Unified CCE Voice Routing Setup 39
    Configure a Device Target 39
    Duplicate Extensions in Multi-site Installations 40
  Routing a Target Device in Unified CCE 40
    Target Device Routing on Unified CM 40
    Route Target Device Using Configuration Manager 40
    Peripherals and Skill Groups 41

CHAPTER 6
Dialed Number Plan 43
  About Dialed Number Plan 43
    Dialed Number Plan Explained 43
    Dialed Number Plan and Routing of Agent Calls 44
    Dialed Number Plan and Basic Dialing Substitutions 44
  Dialed Number Plan Values 44
    Wildcard Pattern 45
    Routing Client 45
    Post Route 45
    Dialed Number 45
    Dial String 46
    Dial String Configuration for Speed Dialing 47
    Dial String Configuration for Alphanumeric Substitutions 47
### Contents

**Dial Number Type Plan** 47  
**Dialed Number Plan Configuration** 48  
  - Use Dialed Number Plan to Ensure Routing of Agent Calls 48  
  - Use Dialed Number Plan to Set Up Basic Dialing Substitutions 49

---

**CHAPTER 7**  
**Precision Queues** 51  
  - **Precision Queue Routing** 51  
  - **Scripting Precision Queues** 52  
    - **Precision Queue Script Node** 52  
    - **Precision Queue Properties Dialog Box - Static Precision Queue** 53  
    - **Precision Queue Properties Dialog Box - Dynamic Precision Queue** 54  
  - **Queuing Behavior of Precision Queue Node** 55  
  - **Queuing Precision Queues** 55  
  - **Precision Queue Reports** 55  
  - **Precision Queue Configuration** 56  
    - **Configure Precision Queues** 56  
    - **Edit Precision Queue** 59  
    - **Delete Precision Queue** 59

---

**CHAPTER 8**  
**Database Administration** 61  
  - **Unified CCE Database Administration** 61  
  - **Historical Data** 62  
  - **Database Administration Tool** 63  
    - **Create Database with Configured Components** 64  
    - **Create Database Without Configured Components** 65  
    - **Delete a Database** 66  
    - **Expand a Database** 66  
    - **Recreate a Database** 67  
    - **View Database Properties** 68  
    - **View Table Properties** 68  
    - **Import and Export Data** 69  
    - **Synchronize Database Data** 69  
    - **Configure a Database Server** 70  
  - **Database Sizing Estimator Tool** 71  
    - **Start Database Sizing Estimator** 72
Estimate Database Size 73
Administration & Data Server with Historical Data Server Setup 74
  Set Up HDS and Add Instance 74
  Set Up HDS from Added Instance 74
Database Size Monitoring 75
System Response When Database Nears Capacity 75
Allocation of More Database Space 76
Initialize Local Database (AWDB) 76
General Database Administration 76
  Built-In Administration 77
Check AWDB Data Integrity 78
Logger Events 79
Database Networking Support 79
Database Backup and Restore 79
Database Comparison 80
Database Resynchronization 81
  Synchronize Database from Command Window 81
Preface

- Purpose, page ix
- Audience, page ix
- Organization, page ix
- Related Documentation, page x
- Product Naming Conventions, page x
- Conventions, page xi
- Documentation and Service Requests, page xii
- Documentation Feedback, page xii

Purpose

This guide describes how to administer components of the Cisco Unified Contact Center Enterprise/Cisco Unified Contact Center Hosted (Unified CCE/Unified CCH) solution. It includes information about administering Unified CCE for voice and multichannel contact centers.

Audience

This document is intended for contact center supervisors and administrators.

Organization

The following table describes the information contained in each section of this guide:

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Part I: Agent Management and Call Routing</td>
<td>Provides conceptual information about Unified CCE agents, agent features, and call routing.</td>
</tr>
</tbody>
</table>
Related Documentation


- For documentation for these Cisco Unified Contact Center products, go to http://www.cisco.com/cisco/web/psa/default.html, click Voice and Unified Communications, then click Customer Collaboration, then click Cisco Unified Contact Center Products or Cisco Unified Voice Self-Service Products, then click the product/option you are interested in.

- For troubleshooting tips for these Cisco Unified Contact Center products, go to http://docwiki.cisco.com/wiki/Category:Troubleshooting, then click the product/option you are interested in.

- You can access documentation for Cisco Unified Communications Manager from: http://www.cisco.com/cisco/web/psa/default.html.


- You can access the Product Alert tool from (login required): http://www.cisco.com/cgi-bin/Support/FieldNoticeTool/field-notice.


Product Naming Conventions

In this release, the product names defined in the following table have changed. The New Name (long version) is reserved for the first instance of that product name and in all headings. The New Name (short version) is used for subsequent instances of the product name.
This document uses the naming conventions provided in each GUI, which means that in some cases the old product name is in use.

<table>
<thead>
<tr>
<th>Old Product Name</th>
<th>New Name (long version)</th>
<th>New Name (short version)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco IPCC Enterprise Edition</td>
<td>Cisco Unified Contact Center Enterprise</td>
<td>Unified CCE</td>
</tr>
<tr>
<td>Cisco IPCC Hosted Edition</td>
<td>Cisco Unified Contact Center Hosted</td>
<td>Unified CCH</td>
</tr>
<tr>
<td>Cisco Intelligent Contact Management (ICM) Enterprise Edition</td>
<td>Cisco Unified Intelligent Contact Management Enterprise</td>
<td>Unified ICME</td>
</tr>
<tr>
<td>Cisco Intelligent Contact Management (ICM) Hosted Edition</td>
<td>Cisco Unified Intelligent Contact Management Hosted</td>
<td>Unified ICMH</td>
</tr>
<tr>
<td>Cisco CallManager/Cisco Unified CallManager</td>
<td>Cisco Unified Communications Manager</td>
<td>Unified CM</td>
</tr>
</tbody>
</table>

**Conventions**

This manual uses the following conventions:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>boldface font</strong></td>
<td>Boldface font is used to indicate commands, such as user entries, keys, buttons, and folder and submenu names. For example:</td>
</tr>
<tr>
<td></td>
<td>• Choose <strong>Edit &gt; Find</strong>.</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Finish</strong>.</td>
</tr>
<tr>
<td><strong>italic font</strong></td>
<td>Italic font is used to indicate the following:</td>
</tr>
<tr>
<td></td>
<td>• To introduce a new term; for example: A <em>skill group</em> is a collection of agents who share similar skills.</td>
</tr>
<tr>
<td></td>
<td>• For emphasis; for example: <em>Do not</em> use the numerical naming convention.</td>
</tr>
<tr>
<td></td>
<td>• A syntax value that the user must replace; for example: IF <em>condition, true-value, false-value</em></td>
</tr>
<tr>
<td></td>
<td>• A book title; for example: Refer to the <em>Cisco CRS Installation Guide</em></td>
</tr>
<tr>
<td>Convention</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>window font</td>
<td>Window font, such as Courier, is used for the following:</td>
</tr>
<tr>
<td></td>
<td>• Text as it appears in code or that the window displays; for example: &lt;html&gt;&lt;title&gt;Cisco Systems, Inc.&lt;/title&gt;&lt;/html&gt;</td>
</tr>
<tr>
<td></td>
<td>• Navigational text when selecting menu options; for example: ICM Configuration Manager &gt; Tools &gt; Explorer Tools &gt; Agent Explorer</td>
</tr>
<tr>
<td>&lt; &gt;</td>
<td>Angle brackets are used to indicate the following:</td>
</tr>
<tr>
<td></td>
<td>• For arguments where the context does not allow italic, such as ASCII output.</td>
</tr>
<tr>
<td></td>
<td>• A character string that the user enters but that does not appear on the window such as a password.</td>
</tr>
</tbody>
</table>

**Documentation and Service Requests**

For more information about obtaining documentation, submitting a service request, and gathering additional information, see the monthly *What's New in Cisco Product Documentation*, which also lists all new and revised Cisco technical documentation, at:


Subscribe to the *What's New in Cisco Product Documentation* as a Really Simple Syndication (RSS) feed and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free service and Cisco currently supports RSS Version 2.0.

**Documentation Feedback**

You can provide comments about this document by sending email to the following address:

contactcenterproducts_docfeedback@cisco.com

We appreciate your comments.
PART

Agent Management and Call Routing

- Cisco Unified Contact Center Enterprise Agents, page 3
- CTI OS and Cisco Agent Desktop Feature Configuration, page 9
- Routing Tasks for Multichannel Options, page 23
CHAPTER 1

Cisco Unified Contact Center Enterprise Agents

This chapter explains the concepts you must be familiar with when setting up agents for your Unified CCE contact center.

- Agent Administration, page 3
- Single-Line Versus Multi-line Behavior, page 6

Agent Administration

This section provides information about the Unified CCE agent, including associating the agent with database records and agent desk settings.

Agents

An agent is an individual who handles customer contact within your contact center. In a Unified CCE configuration, you can create two types of agents:

<table>
<thead>
<tr>
<th>Agent type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Voice-only agents</td>
<td>Agents can receive telephone calls. You can also configure voice-only agents to receive non-voice requests such as chat, blended collaboration, and email.</td>
</tr>
<tr>
<td>Multichannel agents</td>
<td>Agents can receive voice calls and requests from other media. You can also configure multichannel agents to only receive non-voice requests such as chat, blended collaboration, and email.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>You must have Cisco multichannel software installed as part of your Unified CCE configuration to create multichannel agents.</td>
</tr>
</tbody>
</table>
In most cases, the Cisco Unified Communications Manager (Unified CM) peripheral on the Generic CUCM peripheral gateway (PG), which is set up with your initial Unified CCE installation, tracks and records the state and activity of all voice and non-voice agents. You can configure a non-voice PG rather than a Unified CM PG to monitor state and activity of agents configured as non-voice agents. However, this is optional, and is not necessary if you have a Unified CM peripheral on the Generic CUCM PG.

Database Records for Voice-Only Agents

In the Unified ICM database, you must associate each agent with two database records.

<table>
<thead>
<tr>
<th>Unified ICM database record</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Person record</td>
<td>Identifies the individual. Person records must exist for all Unified CCE agents. Every agent in your configuration must have a single Person record. You can then associate this record with one or multiple Agent records, as described below.</td>
</tr>
<tr>
<td>Agent record</td>
<td>Identifies the agent working on a particular peripheral. There must be a one-to-one correspondence between each Agent record and its associated peripheral. However, in Unified CCE, if an agent is going to be working on several peripherals, you can create several Agent records and associate these with the same Person record. In this way, a single agent can work on several different peripherals.</td>
</tr>
</tbody>
</table>

When you create an Agent record, you have the option of associating it with an existing Person record (select Select Person). If you do not associate the Agent record with an existing Person record, a new Person record is automatically created when you create the agent.

Database Records for Multichannel Agents

Unified CCE agents who use multichannel software are associated with three different database records:

- The Person record in the ICM Unified CCE database
- The Agent record in the ICM Unified CCE database
- The Agent record in the database for the multichannel application

Agent Desk Settings Configuration

You must associate each Agent record with an agent desk setting. You use the agent desk settings configuration to associate a set of permissions or characteristics with specific agents. These settings are comparable to Class of Service settings on a PBX or ACD. Desk settings are associated with an agent when the agent is configured in the Unified ICM database. The desk settings are global in scope and you can apply them to any configured agent on any peripheral within a ICM Unified CCE configuration.
If desktop settings are not associated with a configured agent, the agent is assigned the peripheral default settings. The peripheral default settings depend on the default setting for the Generic IPCC PG the agent is logged in to.

Agent Feature Configuration with Agent Desk Settings List Tool, on page 9

Agent Teams and Supervisors

You can organize Unified CCE voice agents into teams. A team is a collection of agents grouped for reporting purposes.

Note

A single agent can belong to only one team.

Unified ICM/CCE software allows you to group individual agents into agent teams that supervisors can manage. Agent teams are assigned to a specific peripheral, so you must assign all agents of a given team to the same Unified CM peripheral.

Unified ICM/CCE software lets you assign both Primary and Secondary supervisors to an individual team. Cisco recommends that you set up your teams with both a Primary and a Secondary supervisor. This setup helps to accommodate Supervisor and Emergency assist scenarios.

Supervisors listed on the agents team list are able to view real-time statistics (using your reporting application). Supervisors can, for example, barge-in, intercept, silently monitor, and log out agents in the associated team using the CTI Toolkit IPCC Supervisor Desktop application.

Note

If you use Cisco Agent Desktop, you must configure the supervisor in Unified ICM/Unified CCE software first, then configure the supervisory features within Cisco Agent Desktop.

For reporting purposes, you can report on agent teams and agents grouped into teams. Also, supervisors can run reports on their teams. (For more information about reposting, see Reporting Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted.)

Each team you set up must have an agent supervisor associated with it. You can then configure supervisory agent features, to allow the supervisor to better monitor agent activity and assist agents on their team. When you create an agent supervisor, you must enter the following information for the supervisor:

- Windows Domain name to which the agent team belongs
- Windows User ID for the supervisor
- Windows password for the supervisor

When configuring agent teams, be aware of the following rules:

- An agent can be a member of only one agent team.
- An agent team can have only one Primary Supervisor.
- A supervisor can be a supervisor of any number of agent teams.
- A supervisor for an agent team can also be a member of that agent team.
- All agents belonging to an agent team and all supervisors for that agent team must be on the same peripheral.
- A supervisor cannot be using the Windows administrator account when logging in as supervisor.

Agent teams and Multichannel Applications

You can group voice agents into teams using the Unified ICM/Unified CCE/Unified CCH Administration User Interface. However, that there is no team feature in Cisco Unified E-Mail Interaction Manager (Unified EIM) and Cisco Unified Web Interaction Manager (Unified WIM); therefore, you cannot group Unified EIM-only agents and Unified WIM-only agents into teams.

For more information about supervisory features, see CTI OS System Manager's Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted and CTI OS Supervisor Desktop User Guide for Cisco Unified Contact Center Enterprise & Hosted.

CTI OS and Cisco Agent Desktop Feature Configuration, on page 9
Supervisor Feature Configuration, on page 14

Single-Line Versus Multi-line Behavior

The following table details single-line behavior versus multi-line behavior.

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-line behavior</th>
<th>Multi-line behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accept a routed call while call is on second line?</td>
<td>Yes</td>
<td>Yes, when Non ACD Line Impact is set no impact for the deployment.</td>
</tr>
<tr>
<td>Supervisor monitor second line using Supervisor Desktop Monitor (CTI OS or Cisco Agent Desktop)?</td>
<td>Yes, but supervisor cannot know agent had calls by looking at desktop</td>
<td>Yes, and supervisor can see second line calls on desktop by default. Yes, depending on the CTI OS Server privacy configuration.</td>
</tr>
<tr>
<td>Supervisor Monitor using Unified CM-based silent monitor</td>
<td>No</td>
<td>Yes, depending on the CTI OS Server privacy configuration.</td>
</tr>
<tr>
<td>Call park</td>
<td>Supported on unmonitored second line</td>
<td>Not supported because all lines are monitored.</td>
</tr>
<tr>
<td>Join Across Lines (JAL)/Direct Transfer across Lines (DTAL)</td>
<td>Not supported</td>
<td>Supported</td>
</tr>
<tr>
<td>Shared line</td>
<td>Supported on unmonitored line; no configuration limitations</td>
<td>Supported, but agent login is not allowed on shared line when Agent Phone Line Control is enabled for the deployment. Login is allowed for only one agent on unique extension when shared line exists between multiple devices.</td>
</tr>
</tbody>
</table>
**Single-Line Versus Multi-line Behavior**

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-line behavior</th>
<th>Multi-line behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>Call Waiting / Busy trigger &gt; 1</td>
<td>No longer supported</td>
<td>No longer supported. Hard-coded to 1 on 69xx series phones (must be configured before enabling multi-line).</td>
</tr>
<tr>
<td>Reporting on second line calls</td>
<td>Use CDRs in Unified CM</td>
<td>Termination Call Detail Records for call to or from an agent's Non ACD line with an unmonitored device or another agent's Non ACD line is reported with a Non ACD Peripheral Call Type. Reporting for all calls on the Non ACD line is captured in the Agent Interval table for that agent.</td>
</tr>
<tr>
<td>Number of configured lines on phone</td>
<td>No limit described (only monitoring one line)</td>
<td>Maximum of four lines. Agent login will be rejected. Config Alert generated.</td>
</tr>
</tbody>
</table>

For more information about enabling the Cisco Round Table phones, see *Installation and Configuration Guide for Cisco Unified Contact Center Enterprise & Hosted*. For more information about configuring the Cisco Round Table phones, see *Installation Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted* and the Cisco Unified Communications Manager documentation.
CTI OS and Cisco Agent Desktop Feature Configuration

- Agent Feature Configuration with Agent Desk Settings List Tool, page 9
- Supervisor Feature Configuration, page 14
- Agent Re-skilling Tool, page 15
- Skill Groups per Agent Limit Modification, page 16
- Network Transfer for IVRs, page 17
- Unified CCE Routing, page 18

Agent Feature Configuration with Agent Desk Settings List Tool

You must associate each voice Agent record with an agent desk setting (not necessary for non-voice agents). You can use the agent desk settings list tool configuration to associate a set of permissions or characteristics with specific agents. You can use the agent desk settings list tool to configure the following agent features:

- Agent Wrap-up
- Reason Codes
- Redirection on No Answer
- Emergency and Supervisor Assist Calls

Agent Wrap-Up

Agents can enter Wrap-up mode after completing a call. Wrap-up mode enables the agent to finish with any tasks that require after-call work before entering a Ready state. When in Wrap-up mode, the agent is not routed any additional tasks.

Agents can manually enter Wrap-up state by activating the wrap-up button on their soft phone. You can also configure agent desk settings so that agents automatically enter Wrap-up mode after finishing each call.

When you create agent desk settings using the Unified ICM/Unified CCE/Unified CCH Administration User Interface, you can specify whether agents enter Wrap-up mode automatically after finishing incoming calls.
The Work Mode Settings allow you to specify whether the agent must enter Wrap-up mode after incoming calls. You can also use these settings to require agents to enter reason codes while in Wrap-up mode (incoming calls only).

**Reason Codes**

Agents select Reason Codes when they:

- Log out of the agent desktop system
- Enter Wrap-up mode after a call
- Change to a Not Ready state

Reason Codes allow you to track the agent's state and logout status as it changes. You configure Reason Codes using the agent desktop application (CTI OS and/or the Cisco Agent Desktop administrator's desktop). If you use the CTI OS desktop, you can also configure Unified ICM/Unified CCE software to control when Reason Codes are required.

**Agent Desk Settings That Affect Reason Codes**

<table>
<thead>
<tr>
<th>Agent desk setting option</th>
<th>Affects this type of reason code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Work mode on Incoming</td>
<td>Wrap-up</td>
</tr>
<tr>
<td>Idle reason required</td>
<td>Not Ready</td>
</tr>
<tr>
<td>Logout reason required</td>
<td>Logout</td>
</tr>
</tbody>
</table>

**Wrap-Up Reason Codes and Work Mode**

If you use the CTI Toolkit Agent Desktop, you can use the Work Mode on Incoming option on the agent desk settings list window to specify when and if agents are required to enter Reason Codes when entering Wrap-up for incoming calls. The following table describes Work Mode on Incoming options and explains how Reason Codes are related to each.

<table>
<thead>
<tr>
<th>Work Mode</th>
<th>Description</th>
<th>Reason Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Required</td>
<td>Ensures that the agent automatically enters Wrap-up state after completing the call.</td>
<td>The agent can choose to enter a Reason Code.</td>
</tr>
<tr>
<td>Optional</td>
<td>Allows agents to choose whether to activate the wrap-up button or the Not Ready button to end the call.</td>
<td>If the agent uses the wrap-up button, the agent can choose to enter a Reason Code.</td>
</tr>
<tr>
<td>Not Allowed</td>
<td>Restricts the agent from entering Wrap-up mode. The agent can go into Not Ready mode.</td>
<td>The agent can decide whether to enter a Not Ready Reason Code.</td>
</tr>
</tbody>
</table>
Reason CodeDescription
---
The agent must enter a Reason Code. Ensures that the agent automatically enters Wrap-up state after completing the call. **Note** This mode is not supported for outgoing calls.

<table>
<thead>
<tr>
<th>Work Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Required with wrap-up data</td>
<td>Indicates that the agent is not ready for the next call. Required</td>
</tr>
<tr>
<td>Optional</td>
<td>Recommended setting when using Cisco Agent Desktop. <strong>Note</strong> Configure Wrap-up options in Cisco Desktop Administrator.</td>
</tr>
<tr>
<td>Not Allowed</td>
<td>Not used with Cisco Agent Desktop.</td>
</tr>
<tr>
<td>Required with Wrap-up data</td>
<td>Not used with Cisco Agent Desktop.</td>
</tr>
</tbody>
</table>

The following table describes the Cisco Agent Desktop configuration for Work Mode on Incoming options.

<table>
<thead>
<tr>
<th>Work Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Required</td>
<td>Not used with Cisco Agent Desktop.</td>
</tr>
<tr>
<td>Optional</td>
<td>Recommended setting when using Cisco Agent Desktop. <strong>Note</strong> Configure Wrap-up options in Cisco Desktop Administrator.</td>
</tr>
<tr>
<td>Not Allowed</td>
<td>Not used with Cisco Agent Desktop.</td>
</tr>
<tr>
<td>Required with Wrap-up data</td>
<td>Not used with Cisco Agent Desktop.</td>
</tr>
</tbody>
</table>

The following table describes the Cisco Agent Desktop configuration for Work Mode on Outgoing options.

<table>
<thead>
<tr>
<th>Work Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Required</td>
<td>When the agent drops an outbound call, the agent goes into a Work Not Ready state for the time specified in the Wrap-up time in the agent desk settings and pops the Wrap-up options, if they are enabled in the Cisco Agent Desktop Administrator application.</td>
</tr>
<tr>
<td>Optional</td>
<td>Recommended setting if not using Wrap-up options for outbound calls.</td>
</tr>
<tr>
<td>Not Allowed</td>
<td>Not used with Cisco Agent Desktop.</td>
</tr>
<tr>
<td>Required with wrap-up data</td>
<td>Not used with Cisco Agent Desktop.</td>
</tr>
</tbody>
</table>

**Predefined Reason Codes**

Unified CCE uses several predefined reason codes to indicate certain system events, described in the following table.

<table>
<thead>
<tr>
<th>Reason Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>32767</td>
<td>Agent state changed because the agent did not answer the call.</td>
</tr>
<tr>
<td>Reason Code</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>-------------</td>
</tr>
<tr>
<td>50001</td>
<td>The CTI OS client disconnected, logging the agent out. <strong>Note</strong> This reason code is converted to a 50002, so 50001 does not display in the agent log out records.</td>
</tr>
<tr>
<td>50002</td>
<td>A CTI OS component disconnected, causing the agent to be logged out or set to the Not Ready state. This could be due to closing the agent desktop application, heart beat time out, or a CTI OS Server failure.</td>
</tr>
<tr>
<td>50003</td>
<td>Agent was logged out because the Unified CM reported the device out of service.</td>
</tr>
<tr>
<td>50004</td>
<td>Agent was logged out due to agent inactivity as configured in agent desk settings.</td>
</tr>
<tr>
<td>50005</td>
<td>For a Unified CCE agent deployment, where the Agent Phone Line Control is enabled in the peripheral and the Non ACD Line Impact is configured to impact agent state, the agent is set to Not Ready while talking on a call on the Non ACD line with this reason code.</td>
</tr>
<tr>
<td>50010</td>
<td>Agent was set to Not Ready state because the agent was routed two consecutive calls that did not arrive.</td>
</tr>
<tr>
<td>50020</td>
<td>Agent was logged out when the agent's skill group dynamically changed on the Administration &amp; Data Server.</td>
</tr>
<tr>
<td>50030</td>
<td>If an agent is logged in to a dynamic device target that is using the same dialed number (DN) as the PG static device target, the agent is logged out.</td>
</tr>
<tr>
<td>50040</td>
<td>Mobile agent was logged out because the call failed.</td>
</tr>
<tr>
<td>50041</td>
<td>Mobile agent state changed to Not Ready because the call fails when the mobile agent's phone line rings busy.</td>
</tr>
<tr>
<td>50042</td>
<td>Mobile agent was logged out because the phone line disconnected while using nailed connection mode.</td>
</tr>
<tr>
<td>-1</td>
<td>Agent reinitialized (used if peripheral restarts).</td>
</tr>
<tr>
<td>-2</td>
<td>PG reset the agent, normally due to a PG failure.</td>
</tr>
<tr>
<td>-3</td>
<td>An administrator modified the agent's extension while the agent was logged in.</td>
</tr>
</tbody>
</table>

These reason codes appear in these reports:
- Agent log out reports if the event caused the agent to log out.
- Agent real time reports if the agent was set to a Not Ready state.
- Agent Not Ready reports.
For reporting on all PGs other than VRU PGs, be sure to select the Agent event detail check box on the Agent Distribution tab in the Unified ICM/Unified CCE/Unified CCH Administration User Interface's PG Explorer tool. You must select this check box to report on Not Ready Reason Codes.

If you are using Cisco Agent Desktop, the Desktop Administrator uses the following predefined reason codes.

<table>
<thead>
<tr>
<th>Reason Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>20001</td>
<td>Places the agent in the Not Ready state first before forcefully logging them off.</td>
</tr>
<tr>
<td>20002</td>
<td>Forces the logout request; for example, when Agent A attempts to log in to Cisco Agent Desktop and Agent B is already logged in under that agent ID, Agent A is asked whether or not to force the login. If Agent A answers yes, Agent B is logged out and Agent A is logged in. Reports then show that Agent B logged out at a certain time with a reason code of 20002 (Agent B was forcibly logged out).</td>
</tr>
<tr>
<td>20003</td>
<td>If not already in the Logout state, request is made to place agent in the Not Ready state. Then logout request is made to log agent out.</td>
</tr>
<tr>
<td>Supervisor Not Ready</td>
<td>This code is reserved.</td>
</tr>
<tr>
<td>Supervisor Logout</td>
<td>This code is reserved.</td>
</tr>
</tbody>
</table>

**Note**

Cisco Unified Mobile Agent is the only exception, where CAD will not allow you to log out a login name/ID that is already in use.

### Redirection on No Answer

You can configure your Unified CCE system to handle and accurately report on situations when the agent does not answer their phone. These situations are referred to as Redirection on No Answer.

Although you can specify some values that control Redirection on No Answer situations, configuring Redirection on No Answer involves additional steps:

- Unified ICM/Unified CCE configuration
- Unified ICM/Unified CCE scripting
- Unified CM configuration

Redirection on No Answer conditions are handled by two routing scripts: the initial routing script and a script specifically set up for these conditions. The initial routing script handles the incoming call; when the call is redirected on no answer from the agent's IP phone, the script branches to another script set up specifically for Ring No Answer conditions.
The Target Requery script feature, implemented using the Label, Queue, Route Select, and Select nodes, is not supported for Unified CCE systems; however, it is supported for Cisco Unified Customer Voice Portal (Unified CVP).

Note

Scripting and Media Routing Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted

Emergency and Supervisor Assist Calls

Agents can activate Supervisor Assist or Emergency Assist buttons on their desktop when they need special assistance from the primary or secondary supervisor assigned to their team.

Agents can use the Supervisor and Emergency assist features, regardless of whether or not they are on a call.

There are two types of Supervisor and Emergency Assist calls:

- Existing call—Consult must be selected as an option on the agent desktop settings for supervisor or emergency assist. If the agent is on a call when they activate either the supervisor or emergency assist feature on their desktop, the CTI software activates the conference key on behalf of the agent's phone and calls the supervisor via the Supervisor or Emergency Assist script. (This example assumes the emergency or supervisor assist script has an Agent-to-Agent node to find a supervisor.) The supervisor answers the call and consult privately with the agent. During the consultation, the supervisor can decide to barge into the call.

- No call—if the agent is not on a call when they activate either the supervisor or emergency assist feature on the agent's desktop, the CTI software activates the make call functionality on behalf of the agent's phone and calls the supervisor via the Supervisor or Emergency Assist script.

Note

Blind Conference is not supported for Emergency and Supervisor Assist.

Supervisor Feature Configuration

Note

If you use Cisco Agent Desktop, you must configure the supervisor in Unified ICM/Unified CCE software first, then configure the supervisory features using Cisco Desktop Administrator.

The CTI Toolkit IPCC Supervisor Desktop includes functions that allow supervisors to monitor and manage their agent team members. A supervisor desktop application has all of the capabilities of an agent desktop application plus supervisor services to monitor and manage agent team members. The desktop application supports the Barge-In and Intercept call monitoring features.

Note

For more information on setting up Unified CCE supervisory features, see Reporting Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted. These instructions help ensure successful use of these features and accurate reporting.
**Barge-In**

When using the CTI OS Desktop to barge in on an agent's call, a supervisor needs to select an agent from the Team State Information grid and select a call from the Monitored Calls section. The supervisor can select a call in this window and then select the **Barge-In** button. The supervisor then becomes party to the call. The supervisor must be in the Not Ready state to use the barge-in function.

When using Cisco Supervisor Desktop, an agent supervisor can use the barge-in function while in the Ready or Not Ready state.

Cisco Supervisor Desktop does not allow barge-in when the agent is:

- On hold
- On two calls
- On a conference call
- Already on another call
- Running Cisco Agent Desktop—Browser Edition

**Intercept**

When using the CTI OS Desktop, you can only use the **Intercept** button after Barge-in. The supervisor can use the **Intercept** button to remove the agent from the call, leaving only the supervisor and the customer on the call.

---

**Note**

The **Intercept** button mentioned above refers to the button located on the CTI OS Desktop (soft phone), not the button on the hard phone.

When using Cisco Supervisor Desktop, an agent supervisor can intercept an agent's call without using Barge-In.

Cisco Supervisor Desktop does not allow intercept when the agent is:

- On hold
- On two calls
- The Cisco Supervisor Desktop self is on another call
- An IP Phone agent

**Agent Re-skilling Tool**

The Unified CCE Agent Re-skilling Tool is an optional, browser-based application designed for use by Unified CCE call center supervisors. It lets you change the skill group designations of agents on your team, and quickly view skill group members and details on individual agents. Changes made to an agent's skill group membership take place immediately without the need for the agent to exit and re-enter the system.
Skill Groups per Agent Limit Modification

Unified ICM and Unified CCE impose a default limit on the number of skill groups that you can assign to a single agent. After this limit is reached, you cannot reassign additional skill groups.

You can also use the Configuration Limit tool to specify your own limit on the number of skill groups that you can assign to an agent. For optimum performance, you can specify a limit far lower than the system default.

For more information, see *Cisco Unified Contact Center Enterprise Design Guide*.

Warning

Setting a default value for skill groups per agent that is higher than the system default can adversely affect system performance. Cisco does not support configurations that exceed the default value.

Caution

The Configuration Limit tool is a command-line tool utility from the bin directory of all Unified ICM and Unified CCE Administration & Data Servers. Access is limited to users with privileges for the Setup or Config Groups in Active Directory for the chosen customer instance. For more information about the Configuration Limit tool, see *Outbound Option Guide for Cisco Unified Contact Center Enterprise & Hosted*.

Change Skill Groups per Agent Limit

To change the skill groups per agent limit using the Configuration Limit tool, complete the following steps:

Procedure

Step 1  From the Windows menu, select **Start > Run**, type `configlimit`, and then click **Enter**.

*Note*  Run the Configuration Limit tool on the same machine as the Distributor for the instance you want to configure. If more than one instance of the Administration & Data Server is installed on the Distributor machine, use the Select Administration Server tool to select the instance you want to configure.

Step 2  To view currently configured parameter limits, run the following command:

```
cl /show
```

Step 3  To change the skill groups per agent limit, enter a command in the following format:

```
cl /id 1 /value [ConfigLimitCurrentValue] [/update]
```

Where:

- id 1 = the ID of the skill groups per agent limit.
• ConfigLimitCurrentValue = the parameter limit. In this case, the parameter limit is the skill groups per agent limit.

For example, to change the skill groups per agent limit to 5, enter the following:

```
cl /id 1 value/5 /update
```

**Note** Using the Configuration Limit tool, you can change the ConfigLimitCurrentValue only. You cannot change the ConfigLimitDefaultValue.

---

**Additional Requirements**

**Lowering the Limit**

If you have modified the skill groups per agent limit to be lower than the system default, no additional changes are necessary. The new, lower limit is enforced immediately. Note that the new limit does not impact agents whose existing skill group membership exceeds the new limit until the next attempt to add a new skill group for those agents. At that time the new limit is enforced, preventing you from adding additional skill groups.

**Exceeding the Default Limit**

If you have modified the skill groups per agent limit to be higher than the system default (in spite of the Warning given above), certain deployments require additional changes (listed in the following sections) to your system to use the new limit and allow you to add additional skill groups.

**Note** If you exceed the default limit and are using CTI OS, do not exceed a maximum of 99 skill groups.

**IPCC Gateway PG**

For IPCC Gateway deployments, modify the following registry keys on your IPCC Gateway PGs to include the new value. A change to the registry requires that you restart the PG service.

**IPCC Enterprise Gateway PIM (Cisco Unified Contact Center Enterprise parent):**

```
HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\< customer_instance >\PG{n}[A|B]\PG\CurrentVersion\PIMS\pim{m}\ACMIData\Config\MaxSkills
```

**IPCC Express Gateway PIM (Cisco Unified Contact Center Express parent):**

```
HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\< customer_instance >\PG{n}[A|B]\PG\CurrentVersion\PIMS\pim{n}\ACMIData\Config\MaxSkills
```

---

**Network Transfer for IVRs**

When a call is transferred from an IVR (for example, IP IVR) to an agent and that agent wants to transfer the call to another agent, the transfer can be made either from the agent's IP phone or the agent desktop. Transfers made from the:
• IP phones are made using CTI route points that point to a Unified ICM/Unified CCE script.
• Agent desktops are made using the Dialed Number Plan.

Note
If the route point is configured using Unified CM, there is no difference between using the hard phone or the desktop phone.

For network transfer from either the IP phone or the CTI Toolkit Agent Desktop, you must queue the call to the skill group in the first Unified ICM/Unified CCE script; for example, “NetXfer1,” to create the call context. In this script you must set the “networkTransferEnabled” flag to “1”.

Note
IP IVR does not support network transfer. Unified CVP supports only network “blind” transfer.

Unified CCE Routing

To understand how Unified CCE routes voice calls, you must understand the concepts of routing operation and routing configuration.

Routing Operations

To understand how Unified CCE routing occurs, you must understand these concepts:

• The Routing Client: The Unified CCE component that submits a route request to the Central Controller.

  In Unified CCE configurations, the routing client can be:
  • The Unified CM PG
  • An interexchange carrier (IXC)
  • A VRU PG
  • A Media Routing Peripheral Gateway

  When a routing client makes a request for a route from the Unified ICM/Unified CCE platform, it receives the response and delivers the call to the specified destination. If an Unified CCE agent is available, Unified ICM/Unified CCE software routes the call to the device target (phone) on the Unified CM (device targets are dynamically associated with the agent when the agent logs in to the system). If an agent is not available, you can configure Unified ICM/Unified CCE software to queue the call to IP IVR or Unified CVP.

• Route and Queuing Requests: Messages sent from the routing client to the Central Controller. Route requests typically pass along call detail information about the incoming call. Unified ICM/Unified CCE software uses information in the route request to determine which routing script is run for the call.

  Call detail information sent with the route request can include:
  • Dialed Number (DN)
  • Calling line ID (CLID)
  • Caller Entered Digits (CED)
Queueing requests are messages sent from the VRU using the Cisco Service Control Interface. The VRU makes a queue request to provide announcements or music when no Unified CCE agents are available to take the call.

- **About Routing to the VRU with Unified CCE:** With Unified CCE you can ensure that voice calls are routed to the VRU when an agent is not immediately available. The call is queued to the VRU and sent to the next available agent via the routing script.

The configurations for routing to a VRU in a Unified CCE environment include:

- Translation Route to the VRU via a route on the PG. The Unified CM uses the DNIS in the translation route to direct the call to the VRU.
- A network route request is issued by the carrier via the NIC. The DNIS and/or Correlation ID is retrieved from the carrier.
- The call is sent directly to the VRU, so that caller entered digits (CED) can be collected.

You do not need a translation route to a Unified CM PG because it is targeting agents and implicitly matches call data.

- **Routing a Call to the VRU:** Translation routing is the preferred method of routing a call to the VRU. The DNIS used in the translation route is not the original number dialed by the customer, but rather, the Dialed Number used to route the call to the VRU.

The scenario is as follows:

- Call comes in to the Unified CM.
- Unified CM identifies the number as a route point for the Unified CM PG.
- The Unified C PG receives a route request from the Unified CM and forwards it to the CallRouter.
- The CallRouter runs the script for the translation route to the VRU.
- A Label is returned to the Unified CM via the Unified CM PG.
- The Unified CM routes the call to the VRU, based on the CTI route point for the translation route.
- VRU sends up a request instruction with the DN as the DNIS.
- VRU PG matches up the call and the Correlation ID, then informs the CallRouter of the call arrival with a "request instruction."
- The CallRouter matches the correlation ID and finds the pending script/call.
- The CallRouter continues with script (for example, run script).

For translation routing, the VRU Type to configure in the Network VRU in the Unified ICM/CCE/CCH Administration User Interface is type 2.

Be sure the Unified CM PG routing client and the VRU PG routing client both have the labels mapped for the peripheral targets in the translation route.

**Routing Configuration**

To set up routing in your Unified CCE system, you must set up the following entities:
• **Dialed Numbers:** The dialed number is the number that the caller dials to contact an agent. It is sent as part of the call detail information in the route request message sent from the routing client.

In the system software, you set up a Dialed Number List. It identifies all of the phone numbers in your contact center that customers can dial to initiate contact.

The Dialed Number plays an integral role in routing calls. Dialed Numbers are required pieces of Unified ICM call types that are used to identify the appropriate routing script for each call.

• **Call Types:** A call type is a category of incoming Unified ICM routable tasks. Each call type has a schedule that determines which routing script or scripts are active for that call type at any time. There are two classes of call types: voice (phone calls) and non-voice (for example, email and text chat). Voice call types are categorized by the dialed number (DN), the caller-entered digits (CED) and the calling line ID (CLID). Non voice call types are categorized by the Script Type Selector, Application String 1, and Application String 2. In either case, the last two categories of the call type can be optional. For voice call types, the caller-entered digits and the calling line ID can be optional, depending on the call. For non voice call types, Application String 1 and Application String 2 can be optional, depending on the application.

Because the call type determines which routing script is run for a call, the call type defines call treatment in a Unified CCE system. Therefore, the call type is the highest level reporting entity. Reporting on call type activity provides insight into end-to-end customer interactions with the system and with agents by providing data such as service level adherence, transfers, average speed of answer, calls handled, and calls abandoned.

In routing scripts, such as scripts for Self-Service VRU applications, you may change the call type at specific points in the script to indicate that a transaction has been completed. For example, if the customer is calling a bank and successfully checks their account balance using a Self-Service script, you may want to change the call type to indicate that the account balance transaction has completed and a new transaction has begun.

You can also change the call type in a script to invoke a new routing script associated with that call type. For example, if a call is not answered at an agent's desktop, you can change the call type in the script to redirect the call to a different script designed for Redirection on No Answer. The Redirection on No Answer script assigns a different agent to handle the call.

• **Routes:** Unified ICM/Unified CCE software uses routes to define the mapping of a target to a specific label for a routing script. Targets include services (service targets), skill groups (skill targets), agents (device targets), and translation routes.

Routes must be defined for VRU Translation Routing and to route calls to agents.

• **Device Targets:** Device targets are deprecated. A device target is a telephony device that can be uniquely addressed (or identified) by a telephone number. A device target is not associated with any one peripheral. Each device target must have one or more labels associated with it, although only one label may exist per routing client. Replace device targets with **Agent Targeting Rules**, which greatly simplifies call routing configuration.

• **Labels:** A label is the value that Unified ICM/Unified CCE software returns to a routing client instructing it where to send the call. The routing client can map the label to an announcement, a trunk group and DNIS, or a device target. Special labels might instruct the routing client to take another action, such as playing a busy signal or an unanswered ring to the caller.

If the label is for a device target, the routing client is responsible for delivering the call to the device target on the Unified CM through the voice gateway.

If the label is for a VRU queue point, the routing client delivers the call to the Route Point on the VRU. The VRU must recognize that the call has arrived and then request queue instructions from Unified
ICM/Unified CCE software. Unified ICM/Unified CCE software returns either a destination for the call or instructions on what script the VRU will run, based on a particular Call Type.

- **Services:** You set up Services in Unified ICM/Unified CCE software to represent the type of processing that a caller requires, and to configure VRU Services to route calls to the VRU. For example, you might define separate services for Sales, Support, or Accounts Payable. A Service is often associated with a peripheral and can be referred to as a Peripheral Service.

For Services that are used to route a call to an agent, you must associate them with skill groups. You associate different Skill Groups with Services by making them members of the Service. Using Services allows you to group agents working in like skill groups.

- **Skill Groups:** Agents must be associated with skill groups to receive Unified ICM-routed calls. You create skill groups using the Unified ICM/Unified CCE/Unified CCH Administration User Interface. A base skill group is the main skill group created using the Unified ICM/Unified CCE/Unified CCH Administration User Interface. Using base skill groups ensures accurate agent reporting and simplifies configuration and scripting for your contact center.

Agents must be associated with skill groups or precision queues.

---

**Note** A sub-skill group is a subdivision of a base skill group. Sub-skill groups are not supported in Unified CCE 9.0(1); the only instance where they are still supported is for Avaya PG and Avaya Aura PG peripherals in Unified ICM deployments. You cannot create a sub-skill group for the System PG, CallManager, and ARS PG peripheral types. You can only remove sub-skill groups from these peripheral types. Sub-skill groups are also not supported for non-voice skill groups. You cannot create sub-skill groups for chat, blended collaboration, and email.

---

- **Precision Queues:** You can create multidimensional precision queues based on predefined business criteria using the Unified CCE Web Administration. Agents automatically become members of these precision queues based on their attributes, dramatically simplifying configuration and scripting.

- **Migrating from Sub-skill Groups to Base or Enterprise Skill Groups**

Follow these steps to migrate from sub-skill groups to base and enterprise skill groups:

- Disable the sub-skill group mask for the peripheral using the PG Explorer tool. All skill groups created after you complete this are base skill groups.
- Define a new base skill group to correspond with each sub-skill group being removed.
- Assign agents to the new base skill groups and remove them from your sub-skill groups.
- Optionally, create enterprise skill groups to group the base skill groups.
- Update all of your routing scripts and routing templates so that they refer to the newly created base or enterprise skill groups.

---

**Routing Scripts**

A routing script, created using the Script Editor, identifies the desired agent based upon skills and customer database profile, determines the call target, and returns a route response to the routing client.
Routing Tasks for Multichannel Options

If you install multichannel features with Unified CCE, it is important that you understand how Unified ICM/Unified CCE software routes contacts and requests made from the Unified EIM Server and the Unified WIM Server.

- Software Configuration for Multichannel Routing, page 23
- Multichannel Software Configuration, page 23

Software Configuration for Multichannel Routing

To route contact requests submitted from the World Wide Web or email, you must configure:

- Media Routing Peripheral Gateway
- Media Routing Domains and Media Classes
- Multichannel agents
- Application instances
- Administration connections
- Multichannel skill groups
- Multichannel routing scripts

For more information about configuring Unified CCE for multichannel routing, see Installation and Configuration Guide for Cisco Unified Contact Center Enterprise & Hosted.

Multichannel Software Configuration

After you complete your Unified ICM/Unified CCE configuration, you must configure your Unified ICM multichannel software and Cisco Media Blender.

The multichannel software you must configure includes:

- Cisco Unified Interaction Manager, which includes Unified EIM and Unified WIM
- Cisco Media Blender

For more information about configuring the Cisco Media Blender component of the Web Collaboration Option, see Cisco Media Blender Installation Guide for Cisco ICM/IPCC Enterprise & Hosted Editions and the Cisco Media Blender Administration Guide for Cisco ICM/IPCC Enterprise & Hosted Editions.
Overview

The following sections describe the configuration required for setting up Unified CCE agents and agent features. These sections also provide information on setting up voice and multichannel routing with Unified CCE.

Note

If you choose to upgrade Unified CM, you need to update the Java Telephony API (JTAPI) client on the Unified CM PG and then restart the PG. If you perform Unified CM maintenance that involves configuration changes only, the Unified CM PG does not require restart. For more information about updating the JTAPI Client, see Cisco Unified Contact Center Express Administration Guide.
Agent Administration

This chapter explains the tasks you must be familiar with when setting up agents for your Unified CCE contact center.

- Administering Agents, page 27
- Configure Not Ready Reason Codes, page 30
- Agent Feature Configuration, page 30
- Supervisor Feature Configuration, page 35
- Agent Re-skilling Tool, page 35
- Network Transfer for IVR Configuration, page 36

Administering Agents

Create Voice-Only Agent

Before You Begin
You must ensure that you have already set up agent desk settings before configuring agents.

Procedure

Step 1
Create an Agent record by selecting ICM Configuration Manager > Tools > Explorer Tools > Agent Explorer. If you want to associate this agent with an existing Person record, select the Select Person button.

Important
Do not change an agent's ID while the agent is logged in to the CTI Toolkit Agent Desktop.
This step creates an Agent record associated with the Person record.

- Agent IDs can be up to nine digits long. The first digit in the ID must be 1 through 9. It cannot be 0. Also, this number cannot be the same as the extensions on the CCM cluster for this agent.
- If you change the Agent ID (Peripheral ID), you must cycle the PG to populate the new agent ID and information in the CTI Toolkit IPCC Supervisor Desktop.

**Step 2**
Enter the agent information and click **Save**.
This step creates the Agent record.

If you did not use the **Select Person** button to associate the agent with an existing Person record, a new Person record is automatically created for the agent.

---

**Note**
You can also add many agents at one time using the Bulk Configuration tool.

---

**Delete Voice-Only Agent**

You logically delete agents using the Agent Explorer tool. You cannot delete agents from the Agent Explorer until you remove them from any teams using the Agent Team List tool. If agents exist in script references, use the Script Reference tool to find any existing references, then use the Script Editor application to delete that script. Agents still exist in the deleted objects databases until permanently deleted.

**Note**
For scripting and reporting purposes, if you configure the script to send a call directly to an agent and that agent is permanently deleted, the call/script fails. Also, you can run historical reports for permanently deleted agents.

---

**Procedure**

**Step 1** Select **ICM Configuration Manager > Tools > Explorer Tools > Agent Explorer**.

- **Note** If this was the last or only Agent record associated with the Person record for this agent, then the associated Person record is also deleted.

**Step 2** Highlight the agent and select **Delete**.
Deletes the agent as well as the associated person.

**Step 3** Select **ICM Configuration Manager > Tools > Miscellaneous Tools > Deleted Objects**.

**Step 4** Highlight the Agent table name in the **Tables with Deleted Records** window, then highlight the agent in the Deleted Records of the "Agent" Table window and select **Delete**.
The agent is permanently deleted from the database.

---

**Create Agent Supervisor**

You create an agent supervisor by simply modifying the Agent record in the Configuration Manager.
Important: You must perform the configuration procedure below so the supervisor can use the Barge-In and Intercept features.

**Procedure**

**Step 1** Select the Supervisor tab in the Agent Explorer tool application when you create or modify an Agent record. Accesses an Agent record.

**Step 2** Select the Supervisor Agent check box. Enter the Windows Domain name. Complete the remaining fields on this tab as described in the Configuration Manager online help. Designates the agent as a supervisor.

---

**Delete Agent Supervisor**

You delete an agent supervisor by simply modifying the Agent record in the Configuration Manager.

**Procedure**

**Step 1** Select the Supervisor tab in the Agent Explorer tool application when you delete an Agent record. This step accesses an Agent record.

**Step 2** Clear the Supervisor Agent check box. The agent is no longer designated as a supervisor.

---

**Create Agent Team**

After adding agents with the Agent Explorer tool, you can create agent teams with the Agent Team List tool.

**Procedure**

**Step 1** Access the Agent Team List tool by selecting ICM Configuration Manager > Tools > List Tools > Agent Team List.

**Step 2** Select Retrieve, and then select Add to add a new agent team. Allows you to begin defining a new agent team. Complete the window, adding desired agents to the team.

**Step 3** Select the Members tab. Allows you to select agents to add to the team.

**Step 4** Select the Supervisor tab. Allows you to designate a supervisor for the team.
With Unified CCE, assign both a primary and a secondary supervisor to each agent team.

Delete Agent Team

You delete agent teams with the Agent Teams List tool. You cannot delete a team until you remove the agent and supervisor from that team.

Procedure

Step 1 Access the Agent Team List tool in the Configuration Manager by selecting ICM Configuration Manager > Tools > List Tools > Agent Team List.
Step 2 Select Retrieve to obtain the current list of teams.
Step 3 Highlight the team you want to delete and select Delete.
Step 4 Select Save to save your changes.

Configure Not Ready Reason Codes

Procedure

Step 1 Select ICM Configuration Manager > Tools > List Tools > Reason Code List.

Example:

Note If you are using the CTI Toolkit Agent Desktop, make sure the Reason Codes match the codes on the desktop. Unified ICM Reason Codes appear in the Agent Not Ready reports, but the agent actually selects the desktop code, so these codes must match to avoid confusion. Configure predefined Not Ready Reason Codes so their text appears in the reports.

Step 2 Enable the Agent event detail option by selecting ICM Configuration Manager > Tools > Explorer Tools > PG Explorer, and then selecting the Unified CM peripheral.
Step 3 Select the Agent event detail check box on the Agent Distribution tab to enable reporting on Not Ready Reason Codes.
Step 4 Configure the Not Ready Reason Codes on the desktop.

For more information about configuring CTI OS Logout and Not Ready Reason Codes, see CTI OS System Manager's Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted.

Agent Feature Configuration

This section describes how to perform the following tasks:
• Configure Unified CCE for Redirection on No Answer situations on IP IVR and Unified CVP
• Configure automatic wrap-up
• Configure supervisor assist and emergency alert situations

Configure Unified CCE for Redirection on No Answer on IP IVR

Important
Unified CM is the Unified ICM Routing Client that ensures the call arrives at the right destination.

The recommended Redirection on No Answer situation configuration is detailed in the procedure below.

Procedure

Step 1 Configure agent desk settings by selecting ICM Configuration Manager > Tools > List Tools > Agent Desk Settings List.
Allows you to define the following:

• A Redirection on No Answer time
• Redirection on No Answer dialed number (to access the Redirection on No Answer script defined in Step 3, below)

Note The Redirection on No Answer timer is not applicable if the Auto answer option is enabled because the Redirection on No Answer feature and Force Answer are mutually exclusive. If both are defined, Auto answer takes precedence over Redirection on No Answer.

Step 2 Set up the call type by selecting ICM Configuration Manager > Tools > List Tools > Call Type List.
This step sets up the call type and associates it with the dialed number and the routing script.

Step 3 Using the Script Editor, create a routing script to handle Redirection on No Answer situations.
This step allows you to define routing logic used for situations when an assigned agent does not answer.

Important This script queues the call at the highest priority in the skill group(s) defined within the call variables; otherwise, the call is no longer the first call to be routed off of the queue, as it was when it was first assigned to the (unavailable) agent. Also, call variables that were set in the original routing script are still present in the ring-no-answer script. Consequently, you might want to set variable values in one script that can be checked and acted upon in the other script.
• If you configure the Redirection on No Answer timer in the Unified ICM agent desk settings, it is not necessary to configure the Unified CM Call Forward No Answer fields for the agent extensions in the Unified CM configuration. If you want to configure them for cases when an agent is not logged in, set the Unified CM system service parameter for the Unified CM Call Forward No Answer timer at least 3 seconds higher than the Unified ICM Redirection on No Answer timer on each of the Unified CM nodes.

• If you want to ensure that Redirection on No Answer calls adversely affect the service level, define the service level threshold to be less than the Redirection on No Answer timer at the call type and service.

Configure Unified CCE for Redirection on No Answer on Cisco Unified CVP

For Unified CCE systems in which Unified CVP is deployed, the Unified CM does not control Unified CVP and cannot send an unanswered call back to Unified CVP for re-queuing. You configure the Re-route on Redirection on No Answer feature to only make the agent state "Not Ready" when the agent does not answer a call; you can use the Unified CVP Target Requery feature to re-queue the call. For more information, see Installation and Configuration Guide for Cisco Unified Contact Center Enterprise & Hosted.

Important

Unified CM does not control the queuing platform (Unified CVP); therefore, Unified CM cannot send the call back to Unified CVP for re-queuing.

Recommended configuration for Redirection on No Answer situations is detailed in the procedure below.

Procedure

Step 1 Configure agent desk setting by selecting ICM Configuration Manager > Tools > List Tools > Agent Desk Settings List.

Allows you to define the following:

• A Redirection on No Answer time: Set this number less than the number set for the No Answer Timeout for the Target Requery that you set in Unified CVP (causes agent to be made unavailable after the Redirection on No Answer timer expires, but cannot invoke the Redirection on No Answer mechanism to re-route the call—see Step 3, below)

• Redirection on No Answer dialed number (to access the Redirection on No Answer script): Leave this field blank

Note

The Redirection on No Answer timer is not applicable if Auto-answer is enabled because the Redirection on No Answer feature and Force Answer are mutually exclusive. If both are defined, Auto-answer takes precedence over Redirection on No Answer.

Step 2 Using the Unified CVP VBAadmin tool, configure the Unified CVP ring-no-answer timeout value.

This step causes Unified CVP to issue a query to the system software, if the assigned agent does not answer. In the VBAadmin tool, use the SetRNTTimeout command to set the ring-no-answer timeout to a duration that is two seconds longer than the Redirection on No Answer time set in Step 1.
Set this timeout to under 30 seconds because the system software waits 30 seconds for Unified CVP to return a routing label and then fails, so Unified CVP needs to requery before this happens.

**Step 3**

Using the Script Editor, account for requeries in the routing script to handle Redirection on No Answer situations.

Use the Target Requery script feature.

**Note** Do not create and schedule a new Routing script for Redirection on No Answer purposes in Unified CVP deployments.

Allows you to report on Redirection on No Answer information. This script enables Requery (selects the Requery check box) on the node in the script that selects and delivers the call to the first agent. Depending on the type of node used, the Requery mechanism selects a new target from the available agents or requires additional scripting.

For information about how Requery works for the different nodes, see *Scripting and Media Routing Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted*.

**Important** This script queues the call at the highest priority in the skill group(s) defined within the call variables. Otherwise, the call is no longer the first in queue, as it was when it was first assigned to the (unavailable) agent.

---

**Note**

- If you configure the Redirection on No Answer timer in the Unified ICM agent desk settings, it is not necessary to configure the Unified CM Call Forward No Answer fields for the agent extensions in the Unified CM configuration. To configure them for cases when an agent is not logged in, set the Unified CM system service parameter for the Unified CM Call Forward No Answer timer at least 3 seconds higher than the Unified ICM Redirection on No Answer timer on each of the Unified CM nodes.

- To ensure that Redirection on No Answer calls adversely affect the service level, define the service level threshold to be less than the Redirection on No Answer timer at the call type and service.

---

**Configure Automatic Wrap-Up**

Automatic wrap-up allows you to force agents into Wrap-up mode when they are finished with inbound or outbound calls.

**Procedure**

**Step 1**

Select **ICM Configuration Manager > Tools > List Tools > Agent Desk Settings List**.

Use these two fields to enable automatic wrap-up:

- Work mode on Incoming
- Work mode on outgoing

Choose either **Required** or **Required with wrap-up data** to indicate automatic wrap-up.

Also, enter the time, in seconds, allocated to an agent to wrap-up a call.

**Step 2**

Configure agent desk settings to require appropriate Reason Codes.
This configuration allows you to determine if and when agents are required to enter a Reason Code when they log out or enter a Not Ready state.

**Configure Supervisor Assist and Emergency Alert**

The recommended supervisor assist and emergency alert situation configuration is detailed in the procedure below.

**Procedure**

**Step 1** Configure agent desk settings by selecting ICM Configuration Manager > Tools > List Tools > Agent Desk Settings List.
This step allows you to define the following:

- Assist call method
- Emergency alert method

**Step 2** Set up the call type by selecting ICM Configuration Manager > Tools > List Tools > Call Type List.
This step allows you to set up the call type and associate it with the dialed number and the routing script.

**Step 3** Configure Dialed Number for supervisor by selecting ICM Configuration Manager > Tools > List Tools > Dialed Number/Script Selector List.
This step allows you to define the following:

- Dialed number string
- Call type

**Step 4** Configure Agent Team by selecting ICM Configuration Manager > Tools > List Tools > Agent Team List.
Allows you to define the Supervisor script dialed number option.

**Step 5** Using the Script Editor, create a routing script to associate the dialed number.
Use the Agent to Agent node to route the call to the primary supervisor by editing the formula with the call preferredagentid. In addition, in case this routing fails, set up a route to the skill group or precision queue where the secondary supervisors are located.

This step allows you to report on blind conference and consultative call information. This script associates the supervisor's dialed number with the script using the Script Editor's Call Type Manager window.

---

For more information about agent desk settings, agent teams, and dialed numbers, see *Installation and Configuration Guide for Cisco Unified Contact Center Enterprise & Hosted* and the Configuration Manager online help.

For more information about Reason Codes, see *CTI OS System Manager's Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted.*
Supervisor Feature Configuration

This section explains how to configure the supervisor logged-in state for CAD.

Configure Supervisor Logged-In State for CAD

Procedure

**Step 1** Configure agent desk settings for the CAD supervisor by selecting ICM Configuration Manager > Tools > List Tools > Agent Desk Settings List.

Example:
This step creates separate desk settings for the CAD supervisor.

**Step 2** Leave the Logout non-activity time option blank. Leaving this option blank keeps a supervisor logged in to Cisco Agent Desktop.

A CAD supervisor uses Cisco Supervisor Desktop to view agent activity, silently monitor, record agent calls, send Team Performance Messages, and chat with agents and other supervisors. A supervisor can only barge in, intercept, or view skill statistics if Cisco Agent Desktop is running on the supervisor's computer.

For more information about agent desk settings, see Installation and Configuration Guide for Cisco Unified Contact Center Enterprise & Hosted and the Configuration Manager online help.

For more information about barge-in and intercept, see CTI OS System Manager's Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted.

Agent Re-skilling Tool

Access Agent Re-skilling Tool

Access to the Agent Re-skilling Tool is limited to individuals with supervisor privileges.

Procedure

**Step 1** To access the Agent Re-skilling Tool using your agent name:

a) In your browser's address bar, enter:
   https://<agent_reskilling_server_ip_or_dns>/reskill
   Your administrator must provide you with this address.

b) Press Enter.
   The Login page appears.

c) Enter your supervisor username and password.
**Note** In a Unified CCE system, the login name to the Agent Re-skilling Tool may or may not be case sensitive. This is determined by the "Login case sensitive" value in the System Information screen under Miscellaneous Tools in the Configuration Manager.

d) Select Login.

**Step 2** In certain deployments, you have the option of logging in to the Agent Re-skilling Tool using your numeric agent ID. To log in using your agent ID:

a) In your browser’s address bar, enter:
   
   `https://<agent_reskilling_server_ip_or_dns>/reskill`

   Your administrator must provide you with this address.

b) Press Enter. The Login page appears.

c) Select the Login By Agent ID link.

   **Note** If this link does not appear on the Login Page you can only log in using your login name.

d) Enter your numeric agent ID and password.

e) Select the correct peripheral for your agent ID. Consult your administrator if you are not sure of your correct peripheral.

f) Select Login.

---

**What to Do Next**

For security purposes, log out when you are finished using the Agent Re-skilling Tool. Select the Log Out link at the top-right of the page. This action returns you to the Login page. Sessions also time-out automatically after 30 minutes of inactivity. If your session ended due to inactivity, you are prompted to login again to resume using the tool.

For more information about using the Unified CCE Agent Re-skilling tool, see the online help.

---

**Network Transfer for IVR Configuration**

**Configure Network Transfer from IP Phone**

To configure network transfer from an IP Phone, complete the following steps.

**Procedure**

**Step 1** Define a CTI Route Point, for example “9999”, in the Unified CM. Associate it with the JTAPI User that is connected to IPCC PIM in the system software.

**Step 2** In the Administration Client or Administration & Data Server, define a Dialed Number for IPCC PIM and a call type for that dialed number. You can then associate this call type with a Unified ICM script; for example, “NetXfer2.”

**Note** Do not define the labels of agents for the Unified CM PG. Instead, define the labels for the VRU PIM so that the route result is returned to VRU instead of a Unified CM PG. If you do define the agent labels for the Unified CM PG, the Router returns the route result to the VRU PIM, if "Network Transfer Preferred” is enabled on the Unified CM PG and VRU PIM and returns the route result to the Unified CM PG if "Network Transfer Preferred” is disabled on the Unified CM PG and VRU PIM.
Step 3  When the call is delivered to Agent 1 using the Unified ICM Script "NetXfer1," the agent can dial the number 9999 to send the call to another script, "NetXfer2."

Configure Network Transfer from CTI OS Desktop

To configure network transfer from a CTI OS Desktop, complete the following steps.

Procedure

Step 1  Define a "Dialed Number Plan" in the system software. The routing client is the IPCC PIM and the dialed number is the one defined before for the IPCC PIM (that is, IPCC_PIM.9999).

Step 2  Set the Post Route to Yes and the Plan to International.

Step 3  In the agent desk settings, select all the Outbound access check boxes.
Voice Call Routing with Cisco Unified Contact Center Enterprise

Unified CCE Voice Routing Setup

Configure a Device Target

Procedure

Step 1 Add/configure an IP Phone on Unified CM.
Step 2 Create/configure a Device Target on the system software by selecting ICM Configuration Manager > Targets > Device Target > Device Target Explorer. Be sure to enter the Dialed Number associated with the IP Phone. Use this string when you enter the dialed number: /devtype ciscophone/dn 9510. This step ensures that Unified ICM can send this string to the Unified CM to initialize the device.
Step 3 Associate the device in Unified CM with the selected Global User. Maps the user and CTI Route Point.

Note
You can use Agent Targeting Rules instead of Device Targets to log into an agent.
Duplicate Extensions in Multi-site Installations

You can use duplicate extensions in different sites in a multi-site Unified CCE configuration. To accomplish this, you must associate the device targets with the appropriate peripheral using the /PID configuration parameter. This ensures that the device target is tied to the peripheral and is not recognized by other peripherals.

To associate a device target with a peripheral:

- Add or modify single device target entries using the Device Target Explorer. (Use the Device Target Bulk (Insert) tool when adding a new device.)
- Set the Configuration Parameter field to /PID <xxxx>, where <xxxx> is the four-digit Peripheral ID (that is, /PID 5000). When you save this change, it takes effect immediately. You do not need to cycle the Unified CM PG Node services for this to take effect.

Routing a Target Device in Unified CCE

The following procedures outline the steps to follow each time you want to route to a new device target in Unified CCE.

Target Device Routing on Unified CM

Procedure

Step 1: Create a CTI Route Point on the Unified CM.
This step configures the Unified CM to make a route request to the system software when the Route Point is dialed.

Step 2: Associate the CTI Route Point with the PG User.
This step makes the Route Point visible to the system software.

Route Target Device Using Configuration Manager

Procedure

Step 1: Create a new Dialed Number using the Configuration Manager.
Defines a new entry point for call routing.

Step 2: Add a new Call Type using the Configuration Manager.
Allows you to categorize calls and route them appropriately.

Step 3: Associate the Dialed Number with the Unified ICM Call Type.
Allows you to map the Dialed Number to a routing script.

Step 4: Create a new routing script using the Script Editor.
Routes the call to the entry point.

**Step 5**

Associate the Call Type with the routing script.

Associates the Call Type with the routing script.

---

**Note**

- In a Unified CM cluster, be aware that two routing clients must not share the same CTI Route Point. Each routing client must use distinct CTI Route Points in a Unified CM cluster.

- When you configure a calling party transformation mask for the translation pattern in Unified CM, the application will have additional connections and disconnections. Therefore, for the components to function properly, Cisco recommends you not have a translation pattern mask for the calling party.

---

**Peripherals and Skill Groups**

Only base skill groups are supported for Unified CCE configurations. A default is set at the peripheral level, ensuring that any new skill group created is base-only.

Agents must be associated with skill groups or precision queues. You can create precision queues using the Unified CCE Web Administration.

For more information about creating routing scripts, see Scripting and Media Routing Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted and the Script Editor online help.

For more information about configuring Unified CCE, see Installation and Configuration Guide for Cisco Unified Contact Center Enterprise & Hosted.
Dialled Number Plan

Note
The Dialled Number Plan is applicable only to the Voice media.

- About Dialled Number Plan, page 43
- Dialled Number Plan Values, page 44
- Dialled Number Plan Configuration, page 48

About Dialled Number Plan

The Dialled Number Plan allows you to manage and track agent-initiated calls.

The Dialled Number Plan applies only to calls initiated by the agent on their soft phone and not on their hard phone. Calls made on the hard phone are not subject to the permission, interpretation, translation, posting routing, and so on, specified in the Dialled Number Plan.

Dialled Number Plan Explained

The Dialled Number Plan consists of a number of entries intended to accommodate the different types of calls agents might make. Each entry contains a wildcard string that is used to match a number that an agent might dial. Each digit of the string is processed until a matching dial plan entry is found. When found, the selected trunk group or resource is used to complete the call.

Each entry contains additional information indicating how to handle the calls matching that wildcard string.

For example, dialing a 9 to receive an outside line on a PBX or ACD is specified in the dial plan. All patterns that reference network trunks might begin with a “9” digit. Subsequent digits might be “1” for long distance patterns, “0” for operator assisted or international calls, “2” through “9” to specify an area code. The dial plan allows a customer to have multiple phone carrier trunks terminated at the PBX or ACD for different outbound call types. A customer might choose MCI as the long distance carrier while AT&T is the international carrier, and Bell Atlantic is the local carrier. The dial plan configuration is used to determine which carrier to use based on the patterns defined within the dial plan.
Do not confuse the Dialed Number Plan Bulk Insert tool with the Dialed Number Bulk Insert tool.

You use the Dialed Number Plan to:

• Ensure agent-initiated calls are routed by a Unified ICM routing script
• Set up basic dialing substitutions

**Dialed Number Plan and Routing of Agent Calls**

The most common and powerful use of the Dialed Number Plan is to ensure that agent-initiated calls are routed through the system software. In this case, you must specify that you want to request a PostRoute for the call and specify a dialed number associated with a routing script designed to handle the type of agent call.

Use this method of configuring the Dialed Number Plan for:

• Agent-to-agent transfers
• Agent-to-agent calling
• Agent-initiated outbound calls

**Dialed Number Plan and Basic Dialing Substitutions**

You can also use the Dialed Number Plan to specify basic dialing substitutions. In this scenario, you identify a wildcard pattern to match the number dialed by an agent. However, you do not request a Post Route and the call is *not* matched to a Dialed Number, and thus not routed by the system software. Instead, you enter the string you want to be dialed in the Dial String field. That string is used to place the agent's call.

Using the Dialed Number Plan in this way is most useful for setting up such things as:

• Speed dial
• Using alphanumeric characters to dial from a soft phone

**Dialed Number Plan Values**

Each field on the Dialed Number Plan dialog box is defined in the Configuration Manager online help. This section provides additional information about these fields and how you can use them to set up agent dialing for your contact center.

The window below illustrates a Dialed Number Plan entry that specifies Unified ICM routing for the agent call.
**Wildcard Pattern**

The wildcard pattern you enter can contain letters, digits, and number signs (#). It can also include the following wildcard characters.

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>?</td>
<td>Represents any single alphanumeric character.</td>
</tr>
<tr>
<td>!</td>
<td>Represents any string of character and can appear only at the end of a pattern.</td>
</tr>
</tbody>
</table>

**Routing Client**

The Routing Client field lets you specify the routing client for the agent call. In Unified CCE configurations, set this field to identify the Unified CM PG.

**Post Route**

Use the Post Route field to specify whether this type of agent call will be sent to a routing script. If you set Post Route to Yes, you must also enter a Dialed Number that is associated with a routing script designed to handle the type of agent call.

**Dialed Number**

Use the Dialed Number field if you have set the Post Route field to Yes, indicating that you want a Unified ICM routing script to handle this agent call.
**Dial String**

Use the Dial String field only when you set the Post Route field to **No**, indicating that you want to use this entry for dialing substitutions. This field cannot be used when PostRoute is selected to send the call to a Unified ICM routing script.

The Dial String field can contain wildcard characters used to translate the dialed number string provided by the agent to the dial string that will be delivered to the switching platform. The following table describes the wildcard characters that might appear in the DialString field.

<table>
<thead>
<tr>
<th>Wildcard Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>!</td>
<td>Matches any group of characters</td>
</tr>
<tr>
<td>?</td>
<td>Matches any single character</td>
</tr>
<tr>
<td>X or x</td>
<td>Excludes the character in the agent supplied dialed number string at the position identified from the offset as defined from the beginning of the DialedNumberPlan DialString field</td>
</tr>
</tbody>
</table>

The following table provides examples of the translation of a DialedNumber string specified by an agent to a resultant DialString as defined by the DialString entry of the matching DialedNumberPlan entry.

<table>
<thead>
<tr>
<th>Agent Dialed Number</th>
<th>DialedNumber Plan Dial String</th>
<th>Dial string result</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>5133</td>
<td>6100</td>
<td>6100</td>
<td>Direct substitution.</td>
</tr>
<tr>
<td>5133</td>
<td>6X???</td>
<td>6133</td>
<td>Partial replacement.</td>
</tr>
<tr>
<td>5133</td>
<td>!</td>
<td>5133</td>
<td>Complete Copy.</td>
</tr>
<tr>
<td>5133</td>
<td>9275!</td>
<td>92755133</td>
<td>Prefix Addition.</td>
</tr>
<tr>
<td>5133</td>
<td>62XX??</td>
<td>6233</td>
<td>First 2 char substitution.</td>
</tr>
<tr>
<td>5133</td>
<td>???.</td>
<td>5133</td>
<td>Complete Copy.</td>
</tr>
<tr>
<td>5133</td>
<td>?XXX000</td>
<td>5000</td>
<td>Retain first character; substitute the remaining characters.</td>
</tr>
<tr>
<td>2755100</td>
<td>???.200</td>
<td>2755200</td>
<td>Replace last three characters.</td>
</tr>
<tr>
<td>2755100</td>
<td>!220</td>
<td>2755100220</td>
<td>Suffix addition.</td>
</tr>
</tbody>
</table>
Dial String Configuration for Speed Dialing

You can configure Static Dial String translations to provide speed dial capabilities. Here, you enter the abbreviated string an agent dials in the wildcard pattern. You enter the actual target number in the Dial String of the entry.

When a dialed number (provided by an agent) matches the wildcard pattern of the Dialed Number Plan entry, the Dial String configured entry is sent in place of the agent supplied Dialed Number string.

The following table provides an example of a speed dial configuration.

<table>
<thead>
<tr>
<th>Agent Dialed Number</th>
<th>Wildcard Pattern</th>
<th>Dial String</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>133</td>
<td>1??</td>
<td>919782755!</td>
<td>919782755133</td>
</tr>
</tbody>
</table>

Dial String Configuration for Alphanumeric Substitutions

You can use the Dialed Number Plan to allow agents to specify an alphanumeric string when dialing. For instance, an agent might dial SALES when calling the sales department rather than a numeric value that might be harder to remember.

To configure an alphanumeric substitution, configure the alphanumeric dial string as the wildcard pattern and the target number as the Dial String of the DialedNumberPlan entry. When a dialed number provided by an agent matches the wildcard pattern of the Dialed Number Plan entry, the configured Dial String is sent in place of the agent supplied string.

You can combine wildcard characters with this feature to allow Alpha prefixes to be added to numbers to identify the location of the number. Examples are shown the following table.

<table>
<thead>
<tr>
<th>Agent Dialed Number</th>
<th>DialedNumberPlan Dial String</th>
<th>Resultant Dial String</th>
</tr>
</thead>
<tbody>
<tr>
<td>SALES</td>
<td>919782755100</td>
<td>919782755100</td>
</tr>
<tr>
<td>BOS5133</td>
<td>9782755133</td>
<td>9782755133</td>
</tr>
<tr>
<td>FL14Office1433</td>
<td>5133</td>
<td>5133</td>
</tr>
</tbody>
</table>

Dial Number Type Plan

The Dial Number Type Plan lets you specify the type of call that will be placed.

<table>
<thead>
<tr>
<th>Dialed Number Plan</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>International</td>
<td>Allows agents to place calls classified as international calls.</td>
</tr>
<tr>
<td>National</td>
<td>Allows agents to place calls classified as national long distance calls.</td>
</tr>
<tr>
<td>Local</td>
<td>Allows agents to place calls classified as national local calls.</td>
</tr>
</tbody>
</table>
The options for this field map exactly with the options on the agent desk settings list window. The system software checks the agent desk settings for the agent placing the outbound call. Agent desk settings define which types of calls agents are permitted to make. If the agent desk settings for an agent prevent them from placing a particular type of call (for instance, international), the call is not placed.

### Dialed Number Plan Configuration

#### Use Dialed Number Plan to Ensure Routing of Agent Calls

Follow these steps to configure a Dialed Number Plan entry to route an agent call through the system software.

**Procedure**

**Step 1** Create a routing script to handle each type of agent-initiated call using the Script Editor. This step ensures agent-initiated calls are routed appropriately by the system software.

The script can target agent, services, or skill groups using Unified ICM script nodes. When a target is chosen, the associated label is sent back to the requesting peripheral. The label value is substituted for the dial string specified by the agent and sent to the switching platform to place the outbound call.

**Step 2** Select ICM Configuration Manager > Tools > List Tools > Call Type List. Allows you to set up the call type and associate it with the dialed number to target to routing scripts.

**Note** You can also use a pre-existing call type and script.

**Step 3** Select ICM Configuration Manager > Tools > Bulk Configuration > Insert > Dialed Number Plan Bulk Insert and insert an entry in the Dialed Number Plan dialog. Using the fields in this window, make sure to:

- Indicate the appropriate wildcard character.
- Set the Post Route text box to Yes.
- Select a valid Dialed Number associated with the routing script used to route the agent call.
- Set the Dial Number Type Plan to indicate the type of call.

This step matches the agent's dialed string to a Dialed Number. This ensures the agent's call will be routed by a Unified ICM routing script.

**Step 4** Select ICM Configuration Manager > Tools > List Tools > Agent Desk Settings List and ensure that Agent Desk Settings are set to identify the types of calls agents can place. Ensures that agents are allowed to or restricted from placing different types of outbound calls.
Use Dialed Number Plan to Set Up Basic Dialing Substitutions

Follow these steps to configure a Dialed Number Plan entry to do basic dialing substitutions.

Procedure

**Step 1** Insert an entry in the Dialed Number Plan dialog box by selecting **ICM Configuration Manager > Tools > Bulk Configuration > Insert > Dialed Number Plan Bulk Insert**.

Using the fields in this window, make sure to:

- Indicate the appropriate wildcard character.
- Set the PostRoute field to **No**.
- Identify a valid Dial String used to place the call.
- Set the Dial Number Type Plan to indicate the type of call.

Matches the agent's dialed string to the Dial String indicated in the entry. This Dial String is used to place the call (the call will not be routed by the system software).

**Step 2** Ensure agent desk settings are set to identify the types of calls agents can place by selecting **ICM Configuration Manager > Tools > List Tools > Agent Desk Settings List**.

Ensures that agents make only the types of outbound calls they are permitted to make.

For more information about Unified ICM Routing Scripts, see *Scripting and Media Routing Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted.*

**Agent Desk Settings Configuration**, on page 4
Precision Queues

Precision Routing is a feature available with Cisco Unified Contact Center Enterprise (Unified CCE), Release 9.0 and later. Precision Routing enhances and can replace traditional routing. Traditional routing looks at all of the skills to which an agent belongs and defines the hierarchy of skills to map business needs. However, traditional routing is restricted by its single dimensional nature. Precision Routing provides multidimensional routing with simple configuration, scripting, and reporting. Agents are represented through multiple attributes with proficiencies so that the capabilities of each agent are accurately exposed, bringing more value to the business.

You can use a combination of attributes to create multidimensional precision queues. Using Unified CCE scripting, you can dynamically map the precision queues to direct a call to the agent that best matches the precise needs of the caller.


Note

Precision Routing is supported only on Unified CCE Communications Manager PG.

Note

Precision Routing is only supported by inbound Unified CCE agents.

- Precision Queue Routing, page 51
- Scripting Precision Queues, page 52
- Queuing Precision Queues, page 55
- Precision Queue Reports, page 55
- Precision Queue Configuration, page 56

Precision Queue Routing

You can create multidimensional precision queues based on predefined business criteria. Agents automatically become members of these precision queues based on their attributes, dramatically simplifying configuration and scripting.
To implement Precision Routing, you create precision queues and implement in your call routing scripts.

A precision queue includes:

- **Terms** - A term compares an attribute against a value. For example, you can create the following term: `English > 6`

- **Expressions** - An expression is a collection of at least one or more terms. For example, if you require an agent who can speak English, is from Dallas and is proficient in sales, you can create the following expression: `English > 6 AND Dallas == TRUE AND Sales > 6`. You can create up to ten terms for each expression.

- **Steps** - A step is a collection of at least one or more expressions. When you create a precision queue, you must configure at least one step. You can configure up to ten steps. A step may also include wait time and a Consider If formula. Use wait time to assign a maximum amount of time for the system to wait for an available agent on a step. Use a Consider If formula to evaluate the step at runtime, for example, if the Caller is a Gold or Bronze level.

To configure Precision Routing, you must complete the following tasks:

1. Create attributes.
2. Assign attributes to agents.
3. Create precision queues.
4. Create routing scripts.

### Scripting Precision Queues

To implement Precision Routing in your contact center, you must create scripts.

You can create and use configured (static) and dynamic precision queue nodes in your scripts. Static precision queue nodes target a single, configured precision queue. When the script utilizes a single precision queue, use static precision queues. Dynamic precision queue nodes are used to target one or more previously configured precision queues. Use dynamic precision queues when you want a single routing script for multiple precision queues (for example, when the overall call treatment does not vary from one precision queue to another).

Dynamic precision queues can simplify and reduce the overall number of routing scripts in the system.

Precision Queues are peripheral gateway (PG) agnostic. Precision queues do not care on which PG an agent resides.

### Precision Queue Script Node

You can use the Precision Queue script node to queue a call based on caller requirements until agents with desired proficiency become available. This node contains multiple agent selection criterion which are separated into steps.

**Figure 1: Precision Queue Script Node**

A single call can be queued on multiple precision queues. If an agent becomes available in one of the precision queues, the call is routed to that resource. You cannot reference multiple precision queues with a single
Precision Queue node. However, you can execute multiple Precision Queue nodes sequentially to achieve this.

The Precision Queue node includes a Priority field, which sets the initial queuing priority for the calls processed through this node versus other calls queued to the other targets using different nodes. The priority is expressed as an integer from 1 (top priority) to 10 (least priority). The default value is 5.

If more than one call is queued to a precision queue when an agent becomes available, the queued call with the lowest priority number is routed to the target first. For example, assume an agent in a precision queue becomes available and two calls are queued to that precision queue. If one call has priority 3 and the other has priority 5, the call with priority 3, the lower value, is routed to the precision queue while the other call continues to wait. If the priorities of the two calls are same, then the call queued first is routed first.

VRU script instructions are not sent to the VRU. If a call enters the Precision Queue node and no resource is available, the call is queued to the precision queue and the node transfers the call to the default VRU, if the call is not already on a VRU. The script flow then exits immediately through the success branch and continues to a Run External Script node to instruct the VRU what to do while holding the call until an agent becomes available. Typically, this invokes a Network VRU script that plays music-on-hold, possibly interrupted on a regular basis with an announcement. The script flow can also use other queuing nodes to queue the same call to other targets, for example, Queue to Skill Group and Queue to Agent.

**Precision Queue Properties Dialog Box - Static Precision Queue**

The following list describes the Precision Queue Properties dialog box for a static precision queue script node.

![Figure 2: Precision Queue Properties Dialog Box—Static Precision Queue](image)

The following property is unique to static precision queues:

- **Drop-down list**—To route calls that enter this node to a static precision queue, you must select a precision queue from the list.

The following properties are common to static and dynamic precision queues:

- **Select Precision Queue radio buttons**—You can select one of the following options for each a precision queue:
  - **Statically**—Select this option to choose a single precision queue to be selected for all the calls that enter this node.
  - **Dynamically**—Select this option to select a precision queue on a call-by-call basis based on a formula.
Dynamic Precision Queue selection is not available when an External Authorization server is used with Internet Script Editor and will be grayed out in the interface.

- **Priority selection**—To select the initial queuing priority for calls processed through this node, you can select from 1 to 10. The default is 5.

- **Enable target requery check box**—To enable the requery feature for calls processed through this node, select this check box. When a requery occurs, for example if a call is presented to an available agent and the agent does not answer, the script continues through the failure terminal. The script can then inspect the call variable RequeryStatus to determine what to do next. The typical action in case of a No Answer is to queue the call again to other precision queues, and increase the priority so that it is taken out of the queue before regular queued calls.

### Precision Queue Properties Dialog Box - Dynamic Precision Queue

The following list describes the Precision Queue Properties dialog box for a dynamic precision queue script node.

Use dynamic precision queues when you want a single routing script for multiple precision queues (for example, when the overall call treatment does not vary from one precision queue to another). Dynamic precision queues can simplify and reduce the overall number of routing scripts in the system.

*Figure 3: Precision Queue Properties Dialog Box—Dynamic Precision Queue*

The following properties are unique to dynamic precision queues:

- **Find By radio buttons**—To dynamically route calls that enter this node to a Precision Queue name or ID, use the Find By radio buttons.
  - Precision Queue Name radio—Select this option to dynamically route calls that enter this node to a Precision Queue name.
**Precision Queue ID**—Select this option to dynamically route calls that enter this node to a Precision Queue ID.

**Formula Editor button**—To determine to which Precision Queue name or ID to route calls that enter this node, click the Formula Editor button to create a formula. The formula is then evaluated at run time to select a precision queue by either name or by database ID. For example, you can use the formula "Call.PeripheralVariable4" to look up the Precision Queue if call variable 4 contained the Precision Queue name, as a result of a database lookup or from IVR call processing.

For properties which are common to static and dynamic precision queues see, Precision Queue Properties Dialog Box - Static Precision Queue, on page 53

**Queuing Behavior of Precision Queue Node**

Precision queues internally are configured with one or more time-based steps, each with a configured wait time. After a call is queued, the first step begins and the timer starts. This occurs although the execution path of the script exited the success node and a new node may be targeted (for example, Run Ext. Script).

If the timer for the first step expires, control moves to the second step (assuming one exists), and so on. As long as the call remains in queue and there are steps left to execute, the call internally continues to move between steps regardless of the path the call takes after it leaves the Precision Queue node. If a call is queued to two or more precision queues, the call internally walks through the steps for each Precision Queue in parallel. After the call reaches the last step on a precision queue, it remains queued on that step until the call is routed, abandoned, or ended.

**Queuing Precision Queues**

Precision Queues internally are configured with one or more time-based steps, each with a configured wait time. After a call is queued, the first step begins and the timer starts. This occurs although the execution path of the script exited the success node and a new node may be targeted (for example, Run Ext. Script).

If the timer for the first step expires, control moves to the second step (assuming one exists), and so on. As long as the call remains in queue and there are steps left to execute, the call internally continues to move between steps regardless of the path the call takes after it leaves the Precision Queue node. If a call is queued to two or more Precision Queues, the call internally walks through the steps for each Precision Queue in parallel. After the call reaches the last step on a Precision Queue, it remains queued on that step until the call is routed, abandoned, or ended.

**Precision Queue Reports**

Reporting provides a complete view of all the queues in the system with both real time and historical metrics. You can use filtering to narrow down the view to specific attributes.

To run real-time or historical reports, you can use CUIC reporting templates. For more information about CUIC template reports, see the CUIC Template Reporting User Guide.

**Updated CUIC Report Templates**

The following existing CUIC Reporting Templates contain updates for Precision Routing:
**Agent Real Time** - This report displays, for each agent, the active skill group or active precision queue, the state, and the call direction within each media routing domain into which the agent is logged.

**Agent Team Real Time** - This report displays the current status for each selected agent team and displays the current state and the active skill group or active precision queue for each agent in the selected agent teams.

**Call Type Queue Historical All Fields** - This report displays the summary statistics for skill groups and precision queues within Call Type ID.

**New CUIC Report Templates**

The following CUIC Reporting templates are new for Precision Routing:

**Agent Precision Queue Membership** - This report displays selected agents, the media routing domain into which the agent is logged, and the active precision queue with up to the maximum supported number of associated attributes.

**Precision Queue Real Time All Fields** - This report displays the current status of selected precision queues.

**Precision Queue Historical All Fields** - This report displays interval data for consolidated call and precision queue statistics.

**Agent Precision Queue Historical All Fields** - This report displays activity for selected agents for a selected interval, sorted by precision queue.

---

**Precision Queue Configuration**

Precision queues are a combination of steps that include attributes, defined terms for the selected attributes, wait times, and Consider If formulas.

Precision queues are configured using the Precision Queue gadget not the Configuration Manager.


---

**Configure Precision Queues**

Precision Queues are configured using the Precision Queue gadget not the Configuration Manager.

**Before You Begin**

Before you create precision queues, ensure that you complete the following prerequisites:

- Create attributes.
- Assign attributes to agents.

**Procedure**

**Step 1**
On the Precision Queue Summary page, click the **New** button. The page refreshes and a new page appears.

**Step 2**
In the **Name** dialog box, type a name for the precision queue.

**Note**
You can enter a combination of up to 32 alphanumeric characters and underscores. Precision queue names are case-sensitive.
Step 3  (Optional) In the **Description** dialog box, type any useful information about the precision queue that you wish to note. You can use the description to note the logic behind your queue criteria or for which call type(s) this queue is designed.

**Note** You can enter a combination of alphanumeric characters and underscores only.

Step 4  From the **Service Level Type** list, select the service level type to use for reporting on your service level agreement. The default value is **Ignore Abandoned Calls**. In the **Service Level Threshold** dialog box, type the time in seconds that calls are to be answered based on your service level agreement.

**Note** The time entered in this box is used to report on service level agreements and does not impact how long a call remains in a precision queue. The length of time a call remains in a step is determined by each individual step wait time.

Step 5  From the **Agent Order** list, select one of the following options to determine which agents receive calls from this queue:

- Longest Available Agent - This represents an agent that has been available the longest.
- Most Skilled Agent - This represents an agent that best matches the terms in a step. This is accomplished by totaling the agent’s proficiency attribute ratings for that step and selecting the agent with the highest value.
- Least Skilled Agent - This represents an agent that least matches the terms in a step. This is accomplished by totaling the agent’s proficiency attribute ratings for that step and selecting the agent with the lowest value.

The default value is **Longest Available Agent**.

Step 6  (Optional) Bucket Intervals. Select the **Bucket Interval** whose bounds are to be used to measure the time slot in which calls are answered. The field defaults to **Use System Default**. To select a different bucket interval: Click the magnifying glass to display the **Select Bucket Interval** list. Click the link to select a bucket interval and close the list. Click the **X** icon to clear the selection and reapply **Use System Default**.

Step 7  Click the numbered step builder link (‘Step 1’, ‘Step 2’, and so on). The Step Builder interface pops up. You must build at least one step before you can save the precision queue. Click the magnifying glass in the **Select Attribute** dialog box and select an attribute. The **Select Attribute** dialog box will open with the list of Attributes on the system. You can sort and search through the Attributes. Click on an Attribute name to select it for that term. Click the **X** icon to clear your selection.

Step 8  If you selected a Boolean attribute, from the value list select == (is equal to) or != (does not equal). OR

If you selected a proficiency attribute, from the operator list, select one of the following operators:

- == (is equal to)
- != (does not equal)
- < (is less than)
- <= (is less than or equal to)
- > (is greater than)
- >= (is greater than or equal to)

Then, for either attribute type, select a value from the values list.

Step 9  To add an additional term, click **Add Attribute** and return to step 7.
OR
To add an additional expression, click the drop down arrow and click **Add Expression** and return to step 7.
OR
Proceed to the next step.

**Note**  
When you add an attribute, you can select **OR** or **AND** to specify the logic between the previous and current attributes. The default value is **AND**.
When you add an expression, you can select **OR** or **AND** to specify the logic between the previous and current expressions. The default value is **OR**.
You can add up to 10 expressions or up to 10 terms to a step.
After you add 10 expressions or 10 terms to a step, the **Add Attribute** button is disabled.

To delete a term, click the X icon.

If you are not on the last step of the Precision Queue, then you can enter a Wait Time (in seconds). A call will queue at a particular step looking for an available agent matching the step criteria up until the time specified in the wait time field for that step. A blank (or zero) wait time indicates that the call will immediately proceed to the next step if there are no available agents matching the step criteria.

If you are not on the last step of the Precision Queue, then you can enter a Consider If formula for that step.

**Consider If expression**
You can use a Consider If expression to evaluate a call (within a step) against additional criteria. Each time a call reaches a step with a Consider If expression, the expression is evaluated. If the value for the expression returns as true, the call is considered for the step. If the value returns as false, the call moves to the next step. If no expression is provided for a step, the step is always considered for calls.

**Note**  
You cannot add a Consider If expression to the last step.
To add a Consider If expression, you can type the expression into the Consider If box. Alternatively, you can use the Script Editor to build the expression and then copy and paste it into the Consider If box. Objects used in consider if expressions are case-sensitive. All Consider If expressions that you add to a precision queue must be valid. If you add an invalid expression, you cannot save the precision queue. To ensure that the expression is valid, it is recommended that you use Script Editor to build and validate the expression.

**Note**  
It is possible that a valid Consider If expression can become invalid. For example, if you delete an object used in the expression after you create or update the precision queue, the expression is no longer valid.

Only the following scripting objects are valid in a Consider If expression:

- Call
- PQ
- Skillgroup
- ECC
- PQ Step
- Call Type
- You can use custom functions in a Consider If expression and you can create custom functions (in Script Editor).
**Example:**
Consider If expression examples
PQ.PQ1.LoggedOn > 1 - Evaluates whether there is more than one agent logged into this queue.
CallType.CallType1.CallsRoutedToday > 100 - Evaluates whether more than 100 calls of this call type were routed today.
PQStep.PQ1.1.RouterAgentsLoggedIn > 1 - Evaluates whether there is more than one router agent logged into this queue for step 1.
CustomFunction(Call.PeripheralVariable1) > 10 - Evaluates whether this expression using a custom function returns a value greater than ten.

**Step 10**  
Click **OK**. The step appears in the precision queue with the agent count. The agent count represents the number of configured agents that match the step criteria.  
*Note*  
As a best practice it is recommended that for a particular step, an equal or greater number of agents are available to select from than in the previous step. If less agents are available to select from, a warning icon appears beside the agent count.

**Step 11**  
To add an additional step, click **Add Step** and then return to step.  
*Note*  
The **Add Step** button is disabled until you add at least one expression to the previous step. You can add up to 10 steps. After you reach 10 steps, the **Add Step** button is disabled. To delete a step, click the **X** icon.

**Step 12**  
Click **Save**.  
A message appears indicating that the precision queue was successfully saved and the summary page reappears.

---

**Edit Precision Queue**

**Procedure**

**Step 1**  
In the summary view, navigate or search for the precision queue to edit.

**Step 2**  
In the list, click the precision queue name. The page refreshes and the edit view appears.

**Step 3**  
Complete required changes and click **Save**.  
The page refreshes and the summary view appears. A message appears at the top of the page indicating whether or not the save was successful.

---

**Delete Precision Queue**

You cannot delete a precision queue that is referenced statically in any version of a saved script. Specifically, before you can delete a precision queue that is referenced statically in a script, you must remove the precision queue from every saved version of the script. If you reference a precision queue dynamically in a script and there are calls queued against the precision queue, you can delete the precision queue. Any calls queued against the deleted precision queue will be default routed.
When deleting a precision queue that is referenced by a dynamic precision queue node, this precision queue's calls will be default routed.

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong></td>
<td>On the Precision Queue Summary page, select the precision queue to delete.</td>
</tr>
<tr>
<td><strong>Step 2</strong></td>
<td>Click the X icon. You receive a prompt to confirm that you want to delete the precision queue.</td>
</tr>
<tr>
<td><strong>Step 3</strong></td>
<td>To delete the queue, click <strong>Yes</strong>. Otherwise, click <strong>No</strong>.</td>
</tr>
</tbody>
</table>
Database Administration

- Unified CCE Database Administration, page 61
- Historical Data, page 62
- Database Administration Tool, page 63
- Database Sizing Estimator Tool, page 71
- Administration & Data Server with Historical Data Server Setup, page 74
- Database Size Monitoring, page 75
- System Response When Database Nears Capacity, page 75
- Allocation of More Database Space, page 76
- Initialize Local Database (AWDB), page 76
- General Database Administration, page 76
- Check AWDB Data Integrity, page 78
- Logger Events, page 79
- Database Networking Support, page 79
- Database Backup and Restore, page 79
- Database Comparison, page 80
- Database Resynchronization, page 81

Unified CCE Database Administration

When you install a new Logger, you create its central database. You must create an HDS database on a real-time Administration & Data Server. When you create a database, you specify the size of its data or log files. The data files must be sufficient for all the data that you expect the database to hold. The size of the central and HDS databases depend on your call center traffic and your data retention requirements.

The local database (awdb) contains configuration and real-time data, if the Administration & Data Server role includes a real-time server. Because the real-time data in the local database (awdb) are constantly overwritten by new data, the database size remains fairly constant.
Over time, the size of your enterprise or your call volumes might change significantly. Therefore, you might need to resize the central and HDS databases to meet new requirements. You normally do not need to resize the local database (awdb). If you do need to resize the local database (awdb), you can do so using the ICM Database Administration (ICMDBA) tool.

The data in the central database and HDS database grow as they accumulate historical data and call detail records. The growth is directly related to the following factors:

- Size of the Unified ICM configuration; for example, how many services, skill groups, routes, and trunk groups are configured.
- Call rate; that is, how many calls per day the system software is handling.
- How long historical data is kept in the database.

The amount of configuration data directly affects the amount of historical data generated. The system software generates a new historical record every half hour for each service, skill group, route, trunk group, and so on, that is configured in the Unified ICM system.

You size and create the central and HDS databases after installing the system software. Use the Database Sizing Estimator applet for estimating the size of these databases, based on the expected usage.

If your configuration expands significantly or if you change the retention times for historical data, you might have to increase the size of the database. This increase might involve adding additional disks to the system.

**Historical Data**

The system software initiates a purge process on the Logger once every day. By default, the purge process runs each night at 12:30 A.M. The purge process deletes records that are older than a specified number of retain days. When you set up the Logger using the Web Setup tool, you can modify the default retention time and purge schedule.

This table lists the *default* settings for retaining historical data.

<table>
<thead>
<tr>
<th>Historical tables</th>
<th>Default retention time</th>
</tr>
</thead>
<tbody>
<tr>
<td>Logger_Admin, Import_Rule_History, Persistent</td>
<td>30 days</td>
</tr>
<tr>
<td>Recovery</td>
<td>100 days</td>
</tr>
<tr>
<td>All other historical tables</td>
<td>14 days</td>
</tr>
</tbody>
</table>

The following large historical tables are not purged by the system software but as a scheduled SQL Server Agent Job:

- Agent_Event_Detail
- Call_Type_SG_Interval
- Dialer_Detail
- Network_Event_Detail
- Route_Call_Detail
- Route_Call_Variable
Termination_Call_Detail
Termination_Call_Variable

Caution
SQL Server Agent Jobs are installed and enabled during the Unified CCE install and upgrade procedure. Do not stop these jobs while the system software is active. If you plan to stop the Logger and Administration & Data Server-hds component services for maintenance for more than a day, manually disable the Microsoft SQL Server jobs using the SQL Server enterprise management tool. Later, after the services are started, re-enable the jobs.

Database Administration Tool

Unified CCE includes the ICMDBA tool (icmdba.exe) in the \icm\bin directory. This tool provides a central utility to administer the Unified ICM databases. Use this tool to:

- Create, edit, and delete central databases, local databases, and historical databases
- Resize database files
- Recreate databases
- Import/export Unified ICM configuration data to/from databases
- View database properties

In addition to these tasks, you can start or stop a server and do some limited SQL Server configuration.

Note
Before using the ICMDBA tool, you must install the Unified CCE software. See the Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, for information on the Unified CCE installation.

Note
The ICMDBA Import/Export feature works on Unified ICM configuration data only. To import or export Unified ICM historical data, use Microsoft’s SQL Server Database Backup and Database Restore utilities.

You start the ICMDBA either by double-clicking ICMDBA in the Unified CCE Tools folder or by selecting Start > Run > ICMDBA.

The main window is a tree hierarchy displaying the Unified ICM database servers in the current domain.

Note
If you cannot find the server you want in the main window, you can select any computer on your local network by choosing File > Add Computer.

Expanding the server name displays the Unified ICM instances that have databases on the server. Expanding the Unified ICM instance displays a specific Unified ICM node or nodes (Administration & Data Server and Logger) on machines that have databases for that instance. Expanding the node displays the databases associated with the node. Expanding the node database displays a list of the individual tables in the node database. Under databases are the table groups, and the final level lists the tables in the group.
You can create databases for instances with or without configured components. When an instance does not have configured components, database creation occurs under the instance within a component placeholder on the ICMDBA main window tree view.

To view the properties of a table, right-click the desired table in the list and select Properties from the context menu, or double-click the table in the list.

There are two ways to access the ICMDBA tool functions:

- From the main window, select a node or database from the tree and then select a function from the menu bar menu.
- Right-click a node or database to display a context menu.

**Create Database with Configured Components**

Use the Create function to create a database for an Administration & Data Server or Logger. You can only create one Logger database per side.

**Procedure**

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>With the Unified CCE running, for the server and instance, select the node (Administration &amp; Data Server or Logger) where you want to create the database.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Select <strong>Database &gt; Create</strong> from the menu bar (or click the right mouse button and select <strong>Create</strong>). The <strong>Create Database</strong> window is displayed.</td>
</tr>
</tbody>
</table>
| Step 3 | Enter the following information for the database:  
  - **DB Type**—Specify the type of database: **Outbound Option** for an outbound dialer, **Administration & Database Server** for a local database (awdb), or **Historical Data Server/Detail Data Server** (HDS/DDS) for Administration & Data Server machines. For a **Logger** device, the default database type is displayed (Logger side must be selected).  
  - **ICM Type**—Specify whether this is a Unified ICM or Unified CCE, Unified ICMH, or CICM (Customer ICM) system.  
  - **Region**—Specify regional information where applicable. |
| Step 4 | Select **Add**. This button invokes the **Add Device** window. Use this window to create a new data file and a new log file for the selected database. Specify the disk drive letter and size in megabytes for each new file.  
  **Note** By default, the newly created data file is set to “Automatically Grow,” if it exceeds the initially specified size. You can modify this setting, as well as the maximum file size, with SQL Server Enterprise Manager. Verify on the **Files** page in SQL Server Enterprise Manager that the **Autogrowth** column shows:  
  - Data files automatically grow in 100 MB increments.  
  - Log files automatically grow in 10% increments. |
| Step 5 | After you complete entering information in the **Create Database** window, select **Create** to close the window and create the database. |
Create Database Without Configured Components

Use the Create function to create a database for an Administration & Data Server or Logger. You can only create one Logger database per side.

Note

When an instance does not have any configured components, database creation occurs under the instance within a component placeholder.

Procedure

Step 1
With Unified CCE running, for the server and instance, select the instance where you want to create the database.

Step 2
Select Database > Create from the menu bar (or click the right mouse button and select Create). The Select Component dialog appears.

Step 3
Select the Administration & Data Server, LoggerA, or LoggerB component and select OK.

Step 4
If you select LoggerA or LoggerB, the Select Logger type dialog appears, allowing you to select Enterprise, CICM, or NAM. Select the logger type and select OK. The Create Database window appears.

Step 5
Enter the following information for the database:

- **DB Type**—Specify the type of database: Outbound Option for an outbound dialer, Administration & Database Server for a local database (awdb), or Historical Data Server/Detail Data Server (HDS/DDS) for Administration & Data Server machines. For a Logger device, the default database type is displayed (Logger side must be selected).

- **ICM Type**—Specify whether this is a Unified ICM or Unified CCE, Unified ICMH, or CICM (Customer ICM) system.

- **Region**—Specify regional information where applicable.

Step 6
Select Add. This button invokes the Add Device window. Use this window to create a new data file and a new log file for the selected database. Specify the disk drive letter and size in megabytes for each new file.

Note

By default, the newly created data file is set to "Automatically Grow," if it exceeds the initially specified size. You can modify this setting, as well as the maximum file size, with SQL Server Enterprise Manager. Verify on the Files page in SQL Server Enterprise Manager that the Autogrowth column shows:

- Data files automatically grow in 100 MB increments.
- Log files automatically grow in 10% increments.

Step 7
After you have completed entering information in the Create Database window, select Create to close the window and create the database.
Delete a Database

Use the Delete function to delete a Administration & Data Server or Logger database.

Note
When an instance does not have any configured components, component placeholders appear under that instance on the application tree view. If you delete the database, the component placeholders no longer appear.

Procedure

Step 1 With Unified CCE running, for the server, instance, and node (Administration & Data Server or Logger), select the database that you want to delete.
Step 2 Select Database > Delete from the menu bar.
Step 3 The Delete Database prompt appears. Select Yes to delete the database.
Step 4 Verify that you want to delete the database in the message box.
Step 5 Select Close to exit. Check the main window to verify that the database was deleted.

Expand a Database

Use this function to add a new storage file.

Note
ICMDBA allows a database to be expanded a maximum of 49 times (resulting in 50 segments). In the event that you reach this limit, you must either recreate the database or use SQL Enterprise Manager to modify the database.

Procedure

Step 1 For the server, instance, and node (Administration & Data Server or Logger), select the database that you want to expand.
Step 2 Select Database > Expand from the menu bar (or click the right mouse button and select Expand). The Expand window appears:
Step 3  Use the window to adjust the size allocation on the database storage device, by completing the following fields:

- **Component**—Specifies whether the file is a data file or log file. Each database must have a file for each type of service.
- **Available Drives**—Specify the drive on which to create the database.
- **Size**—Specifies the size (in MB) of the storage. The field displays a default size, adjust the value as necessary.

Step 4  Select **OK** to expand the file and exit the screen.

---

**Recreate a Database**

Use the Recreate function to recreate a database. The procedure for recreating a database is similar to the procedure for creating a database.

---

**Caution**

When you recreate a database, the information currently stored in the database is deleted.

---

**Note**

When an instance does not have any configured components, database creation occurs under a component placeholder on the application tree view.
### Procedure

**Step 1** For the server, instance, and node (Administration & Data Server or Logger), select the database that you want to recreate.

**Step 2** Select **Database > Recreate** from the menu bar. The **Recreate** window appears.

**Step 3** Enter the database information. See the online help for a description of the fields.

**Step 4** Select **Create** to continue. A message is displayed asking if you are sure you want to recreate the database. Select **Yes** to continue the operation.

**Step 5** The next **Recreate Database** window appears. Select **Start** to recreate the database. After the process completes, a message appears indicating the action was successful. Select **OK** and then select **Close** to exit.

### View Database Properties

The ICMDBA tool allows you to view the properties of specified databases.

**Procedure**

**Step 1** For the server, instance, and node (Administration & Data Server or Logger), select the database that you want to view.

**Step 2** Select **Database > Properties** from the menu bar (or click the right mouse button and select **Properties**). The **Properties** window appears. The screen display includes the following information:

- Instance name
- The database configuration
- The size and percentage used of the files
- Where the data and log files are stored

**Step 3** After you finish viewing the database properties, select **Close** to exit the window.

### View Table Properties

ICMDBA also allows you to view the properties of each table in the database.
**Procedure**

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Select and expand the database to display the tables of a database.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Double-click the table you want to view. The <strong>Table Properties</strong> window appears.</td>
</tr>
<tr>
<td>Step 3</td>
<td>After you finish viewing the table properties, select <strong>Close</strong> to exit the window.</td>
</tr>
</tbody>
</table>

**Import and Export Data**

You can use Import/Export functions to move Unified ICM configuration data from one database to another.

**Note**
The ICMDBA Import/Export feature handles Unified ICM configuration data only. To import or export Unified ICM historical data, use Microsoft’s SQL Server Database Backup and Database Restore utilities.

**Procedure**

<table>
<thead>
<tr>
<th>Step 1</th>
<th>For the server, instance, and node (Administration &amp; Data Server or Logger), select the database from which you want to import or export data.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Select <strong>Data &gt; Import</strong> (or Export) from the menu bar. The <strong>Import data to</strong> (or Export) window appears.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Check <strong>Lockout Changes</strong>, if you want to prevent changes to the database during the import or export operation.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Check <strong>Truncate Config Message Log</strong>, if you want to truncate the Config_Message_Log table in the Logger database.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Truncating deletes the data and does not export the Config_Message_Log table.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Set the <strong>Data type</strong> for the imported data.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Indicate the path for the source/destination of the data.</td>
</tr>
<tr>
<td>Step 7</td>
<td>Select <strong>Import</strong> (or Export) to display the <strong>Import</strong> (or Export) dialog.</td>
</tr>
<tr>
<td>Step 8</td>
<td>Select <strong>Start</strong> to import (or export) the data. After the process completes, a message appears indicating that the action was successful. Select <strong>OK</strong> and then select <strong>Close</strong> to exit. You can select <strong>Cancel</strong> at any time to end the process.</td>
</tr>
</tbody>
</table>

**Synchronize Database Data**

Use the Synchronize function to synchronize the data of two Logger databases.

**Procedure**

<table>
<thead>
<tr>
<th>Step 1</th>
<th>For the server and instance, select the Logger database to synchronize.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Select <strong>Data &gt; Synchronize</strong> from the menu bar. The <strong>Synchronize</strong> window appears:</td>
</tr>
</tbody>
</table>
Step 3  Check **Lockout Changes**, if you want to prevent changes to the database during the synchronize operation.

Step 4  Check **Truncate Config Message Log**, if you want to truncate the Config_Message_Log table in the Logger database.

Step 5  Select the server name and database for both source and target from the drop down lists. To select a server that is not on the drop down list, select **Add** and enter the server name in the **Add Server** box:

Step 6  Select **Synchronize**.

Step 7  A message box appears asking for confirmation. Select **OK** to continue.

Step 8  The next **Synchronize** window appears. Select **Start** to synchronize the data. After the process completes, a message appears indicating that the action was successful. Select **OK** and then select **Close** to exit. You can select **Cancel** at any time to end the process.

---

**Configure a Database Server**

ICMDBA allows you to start or stop a server and to do some limited server configuration.

To start or stop a server, select the node from the list and select **Server > Start/Stop** from the menu bar.
When you use the Configure option, the SQL Server, Administration & Data Server, and Logger restart automatically. However, when you use the Stop option from the Server menu, you must manually restart the Logger and Administration & Data Server from ICM Service Control.

**Procedure**

**Step 1** Select the server and select **Server > Configure** from the menu bar. The **Configure** window appears.

**Step 2** Use this window to modify the following SQL Server parameters:

- **User Connections**—Indicates the maximum number of users that can connect to SQL Server at one time.
- **Locks**—Indicates the maximum number of available locks.
- **Open Objects**—Indicates the maximum number of available open objects.
  
  **Note** User Connections, Locks, and Open Objects are "dynamically allocated" by SQL Server. Unified ICM does not allow you to change these options, so they are grayed out.

- **Open Databases**—Indicates the maximum number of available open databases.
- **Memory**—Indicates the amount of memory (in megabytes) allocated to SQL Server processing.
  
  **Note** You can configure a specific amount of memory instead of the SQL Server default of "Dynamic." Specifying a value of 0 sets the Memory setting to "Dynamic."

- **Recovery Interval**—This setting controls checkpoint frequency.
- **Max Async ID**—Indicates the maximum number of outstanding asynchronous disk input/output (I/O) requests that the entire server can issue against a file.

**Step 3** After you are finished configuring the server, select **OK** to complete the operation or select **Cancel** to end the operation without making any changes.

---

**Database Sizing Estimator Tool**

The Database Sizing Estimator tool enables you to perform database sizing tasks.

The Database Sizing Estimator estimates the storage requirements for a Cisco Unified ICM/CCE logger or HDS database based on information about the configuration of the environment (for example, the number of agents, skill groups, call types, and so on) and database retention days. You can supply initial values by loading values from your local Unified ICM database.

When values are updated in the Database Sizing Estimator, the application recalculates its totals. This update enables you to immediately see the effects of each change as it is made, with the values displayed in a spreadsheet. The tool enables you to engage in what-if scenarios to see the effects that various changes will have on the database sizing requirements.

The Database Sizing Estimator allows you to save the values as an XML file on your local machine. At any time, you can load the saved XML file back into the Database Sizing Estimator, so you can continue revising your estimates.
Cisco Unified ICM/CCE Database Retriever Dialog

The Cisco Unified ICM/CCE Database Retriever dialog, which you access from the Database Sizing Estimator tool, queries the existing database and registry configuration. The Database Sizing Estimator tool then uses this data to provide starting values, which you can modify.

To access the Database Retriever dialog, select Load from DB in the Database Sizing Estimator tool on your local machine.

Note
Cisco Unified ICM/CCE Database Retriever can retrieve the configuration and retention information from any Unified ICM/CCE system containing a Logger or Historical Data Server (HDS) database. The Database Sizing Estimator can calculate a database size for a newer schema other than the deployment to which the Database Sizing Estimator is connected.

Start Database Sizing Estimator

The following steps describe how to start the Database Sizing Estimator.

Note
For Database Sizing Estimator field-level descriptions, see the online help.

Procedure

Step 1 Open the Database Sizing Estimator tool by selecting Database > Estimate in the ICMDBA tool.
Step 2 The Cisco Unified ICM/CCE Database Sizing Estimator window appears:
Step 3  The window displays initial default values for all fields. As you change the field values, the database size requirements update automatically. You can load values from a previous version or from the Cisco Unified ICM/CCE Database Retriever dialog by selecting Load from File to load an external XML data file.

**Estimate Database Size**

[Diagram of the Database Sizing Estimator Tool]

**Note**  Steps 1–3 in this procedure only apply when using existing databases.

**Procedure**

**Step 1**  Use your existing database as the starting point. Select Load from DB in the Database Sizing Estimator main window. The Cisco Unified ICM/CCE Database Retriever dialog appears.

**Step 2**  Select the database you want to use as the starting point for your sizing estimates.

**Step 3**  Select Retrieve.
The fields in the **Database Sizing Estimator** main window auto-populate with the information from the selected database.

**Step 4** Modify the database information depending on your scenario. As changes are made, the **Database Size Required** value changes.

**Step 5** Save your work in progress by selecting **Save to File**.

---

**Administration & Data Server with Historical Data Server Setup**

There are two ways to set up a Historical Data Server (HDS) VM:

- The instance is created in the domain, but not already added.
- The instance is created in the domain and is already added.

**Set Up HDS and Add Instance**

**Procedure**

**Step 1** Run the Cisco Unified ICM/Contact Center Enterprise & Hosted Installer (if you have not run it already) on the local machine.

**Step 2** Run the Web Setup tool for that machine (in a browser, from anywhere). Under **Instance Management**, select **Add** and add the instance.

**Step 3** Run the ICMDBA tool on the local machine. Create the Historical Data Server/Detail Data Server database.

**Step 4** Return to the Web Setup tool. Under **Component Management**, select **Add** on the Administration & Data Server list page, then follow the instructions in the Cisco Unified Contact Center Enterprise Installation and Upgrade Guide. If you did not perform step 3, the Administration & Data Server **Add** wizard does not allow you to finish this procedure until you create an HDS database.

**What to Do Next**

Use the Database Sizing Estimator tool to determine the size of the database and then use the ICMDBA tool to create the database.

**Set Up HDS from Added Instance**

**Procedure**

**Step 1** Run the Cisco Unified ICM/Contact Center Enterprise & Hosted Installer (if you have not run it already) on the local machine.

**Step 2** In the Web Setup tool, under **Component Management**, select **Add** on the Administration & Data Server list page, then follow the instructions in the Cisco Unified Contact Center Enterprise Installation and Upgrade Guide.
Guide. If you did not perform step 1, the Administration & Data Server Add wizard does not allow you to finish this procedure until you create an HDS database.

What to Do Next

Use the Database Sizing Estimator tool to determine the size of the database and then use the ICMDBA tool to create the database.

Database Size Monitoring

You should regularly monitor the space used by the central database and transaction logs. You can monitor database size by viewing the Logger’s per-process log files. The per-process log files contain information on Logger and database activity, as this example log file illustrates:

```
The Logger logs events and trace messages that show the percentage of space used in the database. These files are stored in a \logfiles subdirectory in the Logger's directory (la or lb). You can view the Logger’s per-process log files by using the Unified ICM dumplog utility.

When the database becomes 80 percent full, the Logger logs an EMS warning message to the central database. The "80 percent full" warning message might also immediately be sent to your Unified ICM network management station through SNMP or SYSLOG.

See the Serviceability Best Practices Guide for Cisco Unified ICM/Contact Center Enterprise for more information on using the dumplog utility.

If you decide that you need additional database space, contact your Unified ICM support provider.

System Response When Database Nears Capacity

The system software has automatic checks to prevent the central database from becoming full:

- **Warning message**—When the central database begins to approach its capacity, the system software issues a warning message. By default, this warning occurs when the database is 80% full, but you can
configure this value. Warning messages trigger an event that is registered in AlarmTracker, which the console window displays in an EMS trace message.

• **Automatic purge**—If you select the Automatic Purge Adjustment option when you install the Logger software, the system software automatically deletes the oldest historical data when database usage exceeds 80% threshold or when the central or HDS database nears its capacity. If the data has not exceeded the retention period, it does not get deleted. By default, automatic purge occurs when the database is 80% full, but you can set the percentage when you set up the Logger. You can also set the retention period for data when you set up the Logger.

**Note**  
See the Cisco Unified Contact Center Enterprise Installation and Upgrade Guide for more on purging information from databases.

• **Emergency Purge**—By default, the system automatically deletes the oldest historical data from all historical tables when the database exceeds 90% usage capacity.

The automatic purge ensures that the database can never become completely full. But, the purge means that you can lose older historical data.

## Allocation of More Database Space

If the central database is growing too large, you can allocate additional space. If you require additional space in the central database, you must back up the master database before you add more space. Your Unified ICM support provider might have options for allocating more space.

### Initialize Local Database (AWDB)

Normally, you do not need to initialize the local database (awdb), because initialization happens automatically during its creation. If you ever need to initialize the local database after its creation, you can do so.

**Procedure**

1. **Step 1**  
   Double-click **Initialize Local Database** within the Administration Tools folder. The Initialize Local Database main window appears.

2. **Step 2**  
   Select **Start** to transfer the data. As data is copied, the screen displays the number of rows processed for each table.

3. **Step 3**  
   After the transfer is complete, select **Close** to exit.

### General Database Administration

Because Unified ICM is a mission-critical application that runs 24 hours a day, the system software takes care of many routine administration tasks automatically. In general, the system software retains control of most of the database administration functions in order to keep external interference to a minimum.
As the Unified ICM administrator, you might be responsible for performing several optional Unified ICM administration tasks:

- Setting networking options
- Monitoring Logger activity
- Backing up the central database
- Restoring the central database from backup
- Comparing databases
- Resynchronizing databases

---

**Note**

To conserve system resources, minimize all Unified ICM process windows before configuring your system.

---

**Built-In Administration**

The system software maintains a database on each side of the Central Controller and the local database (awdb). Each database consists of a group of interrelated tables. As you add or update data in the database, you must ensure that logical relationships are maintained. For example, if you delete a trunk group, you must not leave trunks in the database that reference that trunk group. If you do, the integrity of the database is broken.

Configuration Manager prevents you from making certain changes that disrupt the integrity of the data in the database. However, it cannot prevent all such changes. Usually, if data integrity in the local database (awdb) is temporarily disrupted, no major problems occur. However, integrity problems in the central Unified ICM database could cause errors in system processing.

---

**Note**

To protect the integrity of the Unified ICM databases, do not use third-party tools to modify them. These tools do not protect against disruptions of database integrity. (You can use third-party tools to view Unified ICM data.)

---

**Caution**

Manual integrity checks of the central database must involve your Unified ICM support provider. Do not run the DBCC CHECKDB procedure on the central database while the Unified ICM system is running. This procedure stops the Logger.
Check AWDB Data Integrity

You can manually check the integrity of data in the local database (awdb). Configuration Manager provides a Check Integrity option under the Administer menu. Configuration Manager allows you to select which checks you want to execute.

The specific data integrity check procedures are listed in the following table:

**Table 1: Local Database Data Integrity Check Procedures**

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Null</td>
<td>Checks for the value NULL in specific fields in the database that must not be null. It also checks that the value of the RoutingClient.PeripheralID is NULL for routing clients associated with a NIC.</td>
</tr>
<tr>
<td>Targets</td>
<td>Checks for appropriate relationships among peripherals, targets at peripherals (services, skill groups, agents, and translation routes), trunk groups, network targets, announcements and peripheral targets.</td>
</tr>
<tr>
<td>Routes and Numbers</td>
<td>Checks that ID fields cross-referenced from several tables correspond to existing records.</td>
</tr>
<tr>
<td>Scripts</td>
<td>Checks for valid cross-references among scripts, call types, and dialed numbers.</td>
</tr>
<tr>
<td>Enterprise</td>
<td>Checks for valid cross-references among enterprise services and services, and between enterprise skill groups and skill groups. Also performs several other checks on skill groups, trunks, and so on.</td>
</tr>
<tr>
<td>Domain Adherence</td>
<td>Checks for valid relationships between agents and skill groups, between skill groups and services, between labels and routing clients, between dialed numbers and routes, and between peripherals and routing clients.</td>
</tr>
<tr>
<td>Names</td>
<td>Checks for invalid characters in enterprise names (EnterpriseName field) in various database tables. Enterprise names provide unique character-string names for objects in the Unified ICM configuration.</td>
</tr>
<tr>
<td>Miscellaneous</td>
<td>Checks rules for Outbound Option Configuration.</td>
</tr>
</tbody>
</table>

For more information on the specific fields checked by these procedures, see the online help for the Configuration Manager tool.
Procedure

Step 1  Invoke Configuration Manager by double-clicking its icon in the Administration Tools folder.

Step 2  Select Configure ICM > Administration > Integrity Check from the menu bar. The Integrity Check dialog box appears.

Step 3  Select specific checks to execute, or select All to perform all the checks.

Step 4  Select Start to perform the checks. If any integrity problems are found, the Configuration Manager displays a message describing the problems.

Step 5  After you perform all the checks you want, select Done to dismiss the Integrity Check dialog box.

Logger Events

You can view recent Logger activity by viewing the Logger's per-process log files. Per-process log files document events for the specific processes running on a computer. These files are useful in diagnosing problems with processes on the Logger (and on other nodes in the Unified ICM system).

You can also view Logger event data in the central database. The Event Management System (EMS) logs events to the central database. Be especially aware of Error and Warning events generated by the Logger. For example, the system software logs a Warning event when the central database becomes 80% full.

See the Serviceability Best Practices Guide for Cisco Unified ICM/Contact Center Enterprise for more information on viewing the per-process log files and central database event data.

Database Networking Support

You can use the SQL Server Setup program to specify which network protocols the database manager supports. The correct order and states are:

1  Shared Memory—Enabled
2  Named Pipes—Enabled
3  TCP/IP—Enabled
4  VIA—Disabled

See the Staging Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted for detailed information about installing SQL Server. For more information about database networking, see the Microsoft SQL Server System Administrator's Guide.

Database Backup and Restore

A database can be lost or corrupted for several reasons. Because you cannot protect against all these reasons, you must have a backup strategy in place. This backup strategy is especially important if you have a non-redundant central database configuration. However, even for a redundant system, you still need to perform backups to protect against software problems that corrupt both sides of the system.

The commonly-used database backup strategies are:
• Regularly scheduled database backups
• Mirrored disk configurations
• Redundant Array of Inexpensive Disks (RAID) configurations

Although the last two strategies might decrease system performance, they have the advantage of not requiring manual intervention. However, while these configurations protect against disk drive failure and bad media, they might not protect against some software errors.

In a single database configuration, you need to ensure protection against all types of errors. To protect your data, regularly back up the central database with the SQL Administrator tool provided with SQL Server.

Note
The SQL Monitor service must run during a backup. If SQL Server is not configured to start SQL Monitor automatically, start the service manually before beginning the backup.

When you restore a database, you can only restore up to the last backup. Any transactions after that backup are lost. In single database configurations, daily backups are required to ensure maximum data protection.

Note
You must backup the entire database at each backup interval. The system software does not support the use of transaction log dumps as incremental backups.

For general information about developing a backup strategy, including the use of mirrored disks, see Microsoft’s SQL Server System Administrator’s Guide. For specific information about backing up a database using SQL Administrator, see Microsoft’s SQL Administrator User’s Guide.

To backup an Unified ICM database:

1. Stop Unified ICM services for the processes that are using the database that you want to back up.
2. Run the backup.
3. Restart Unified ICM services after the backup is complete.

On a redundant system, calls processing can continue if you backup the two sides at different times.

Database Comparison

For diagnostic purposes, you might want to check that two databases have the same data in a specific table. For example, you might want to check that the ICM_Locks table contains the same data on both sides of a Central Controller. The tool dbdiff.exe performs this type of check. Its syntax is as follows:

dbdiff database1.table@host1 database2.table@host2

For example:

dbdiff cust1_sideA.ICM_Locks@geoxyz1grb cust1_sideB.ICM_Locks@geoxyz2grb

The batch script diffconfig.bat invokes dbdiff for various tables to automatically compare two Unified ICM databases. Its syntax is as follows:

diffconfig database1 host1 database2 host2

For example:

diffconfig cust1_sideA geoxyz1grb cust1_sideB geoxyz2grb
Database Resynchronization

You might occasionally need to repair a corrupt Logger database on one side of a redundant Unified ICM by copying the Logger database from the other side. You can synchronize the databases using either the DOS Command window or the ICM Database Administration (ICMDBA) tool.

The ICMDBA synchronize process involves dropping the targeted side data and copying the data from the source. For example, if you are synchronizing side B data to side A data, the side B data will be replaced with the data stored in side A.

Note
Perform these procedures in a maintenance window.

Synchronize Database from Command Window

The following directions explain how to synchronize the databases.

Procedure

Step 1 Stop the Logger for the target database, if that Logger is running.
Step 2 In a DOS Command window on the VM for that Logger, change to the \icm directory.
Step 3 Run the following command: install\syncloggers <Source_server> <Source_database> <Target_server> <Target_database>.
Step 4 When prompted, verify that the configuration is deleted from the correct database and type Y to continue.

What to Do Next

When the command is complete, restart the Logger on the target server.
INDEX

/PID 40

A
administering agents 3
agent desk settings 4, 10
   about 4
   reason codes 10
Wrap-up 10
Agent desk settings 10
   Idle reason required 10
   Logout reason required 10
   Work mode 10
agent desktop features, configuring 9
Agent Re-skilling tool 15, 35
   about 15
   accessing 35
agent supervisor 28, 29
   creating 28
   deleting 29
agent teams 5, 29, 30
   about 5
   creating 29
   deleting 30
agent types 3
   multichannel 3
   voice-only 3
agent wrap-up 9
agents 3, 4, 5, 6, 9, 10, 15, 28, 29, 30
   about 3
   about supervisors 5
   about teams 5
   administering 3
   changing skill group designations 15
   configuring Not Ready Reason Codes 30
   creating 27
   creating voice-only 27
   deleting voice-only 28
   entering Wrap-up mode 9
   multichannel 3
   reason codes 10
agents (continued)
teams, creating 29
teams, deleting 30
teams, multichannel 6
   voice-only 3, 4
alpha prefixes, adding to numbers 47
alphanumeric substitutions, configuring 47
Assist call method, configuring 34
automatic wrap-up 33
   configuring 33

B
Barge-in option 15
base skill groups 19
   about 19
   migrating from sub-skill groups 19

C
CAD 11, 35
   configuring supervisor logged-in state 35
   predefined reason codes 11
Call forward on Redirection on No Answer 13
Call forward on Ring No Answer 31, 32
   configuring IPCC on IP IVR 31
   configuring Unified CCE on Unified CVP 32
call types 19, 47
   about 19
   identification 47
calls, single-line vs. multi-line behavior 6
Cisco Agent Desktop 10
   configuring Work Mode on Incoming option 10
   configuring Work Mode on Outgoing option 10
Cisco Media Blender 23
classifying call types 47
ConfigLimit tool, using 16
Configuration Manager, using 40
   configuration parameters 40
configuring 9, 10, 14, 19, 23, 29, 30, 33, 34, 35, 36, 37, 39, 47
agent features 30
agent features with Agent Desk Settings List tool 9
agent teams 29
alphanumeric substitutions 47
Assist call and Emergency alert methods 34
automatic wrap-up 33
CAD supervisor logged-in state 35
device target with IPCC Enterprise 39
multichannel routing 23
multichannel software, about 23
network transfer from a CTIOS Agent Desktop 37
network transfer from an IP phone 36
Not Ready Reason Codes 30
routings, about 19
speed dialing 47
Static Dial String translations 47
supervisor features 14
Work Mode on Incoming option for Cisco Agent Desktop 10
Work Mode on Incoming option for CTIOS Agent Desktop 10
Work Mode on Outgoing option for Cisco Agent Desktop 10
creating 27, 28, 29
agent supervisor 28
agent teams 29
agents 27
voice-only agents 27
CTIOS Agent Desktop 10, 37
configuring network transfer 37
configuring Work Mode on Incoming option 10
CTIOS OS features, configuring 9

D
Database 4
Agent record 4
databases 4
Agent record 4
Person record 4
records for IPCC Enterprise agents using multichannel software 4
deleting 28, 29, 30
agent supervisor 29
agent teams 30
voice-only agents 28
desk settings, agent 9
desktop features, configuring 9
device targets 19, 39, 40
about 19
configuring with IPCC Enterprise 39
routing to a new 40
dial string, using for alphanumeric substitutions 47
Dialled Number Plan 43, 44, 45, 46, 47, 48, 49
about 43
alphanumeric substitutions 44
configuring 44
dial number type plan 47
dial string 47
Post Route field 45
Post Route field 45
routings, about 19
speed dialing 47
Wildcard pattern 45
dialled numbers 19
dialing substitutions, Dialled Number Plan 44
duplicate extensions 40

E
E-Mail Interaction Manager (Unified EIM) 23
evacuation alert method, configuring 34
emergency calls 14
enabling peripherals and skill groups 41
Intercept option 15
IPCC Enterprise Web Administration Tool, about ix
IVRs, configuring network transfer 36

L
labels, about 19
limit, skill groups 16

M
Media Blender 23
migrating from sub-skill groups to base skill groups 19
modes, Wrap-up 9
multi-site installations, duplicate extensions 40
multichannel agent database records 4
multichannel agents 3
multichannel routing, about configuring 23
multichannel software 4, 23
  Cisco Media Blender 23
  Cisco Unified E-Mail Interaction Manager 23
  Cisco Unified Web Interaction Manager 23
configuring 23
database records for IPCC Enterprise agents 4

N

network transfer 17, 36, 37
  configuring from a CTI OS Agent Desktop 37
  configuring from an IP Phone 36
  for IVRs, about 17

P

performing administrative tasks 27
Person database record 4
predefined reason codes 11

Q

queue requests 18

R

reason codes 10, 11
  about 10
  predefined 11
  Wrap-Up 10
Reason codes 10
  idle reason required 10
  logout reason required 10
Reason Codes 30
  configuring 30
Redirection on No Answer 13, 31, 32
  about 13
  configuring IPCC on IP IVR 31
  configuring Unified CCE on Unified CVP 32
route requests 18
routes, about 19
routing 18, 19, 21, 23, 39, 40, 44, 48
  about IPCC Enterprise 18
  agent calls using Dialed Number Plan 48
  agent calls with the Dialed Number Plan 44
  and queuing requests 18
call to the VRU 18
call types 19

S

scripts, routing, about 21
services 19
setting up basic dialing substitutions for agent calling 49
skill groups 15, 19
  about 19
  base 19
  changing agent designation 15
  migrating from sub-skills to base skills 19
skill groups, limit 16
speed 47
  dial, configuring 47
  dialing, Dialed Number Plan 47
speed dialing, configuring 47
static dial string translations 47
sub-skill groups 19
  migrating to base skill groups 19
supervisor 14, 15, 28, 29, 34
  assist calls 14, 34
  creating agent 28
  deleting agent 29
  using Barge-In option 15
  using Intercept option 15
supervisor features 14, 35
  configuring, about 14
  configuring, how to 35
  monitoring agent team members 14
supervisors 5, 15
  about 5
  assigning primary and secondary 5
  required information when creating 5
  using the Agent Re-skilling Tool 15
target devices 40
tasks, routing for multichannel options 23
teams 5, 29, 30
    about agent 5
    creating agent 29
deleting agent 30
tools 15, 16
    Agent Re-skilling 15
    ConfigLimit 16

using 48, 49
    Dialed Number Plan to ensure routing of agent calls 48
    Dialed Number Plan to set up basic dialing substitutions for agent calling 49

voice calls, routing 39
voice-only agents 4, 27, 28
    creating 27
    database records 4
deleting 28
VRU routing 18

Web Interaction Manager (Unified WIM) 23
wildcard characters 47
    combining with alphanumeric substitution 47
Work mode, agent wrap-up 10
wrap-up 10, 33
    configuring 33
    reason codes and work mode 10
Wrap-up mode 9
Wrap-up reason codes 10
Wrap-Up reason codes and work mode 10