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Unified CCE Database Administration
When you install a new Logger, you create its central database. You must create an HDS database on a
real-time Administration & Data Server. When you create a database, you specify the size of its data or log
files. The data files must be sufficient for all the data that you expect the database to hold. The size of the
central and HDS databases depend on your call center traffic and your data retention requirements.

The local database (awdb) contains configuration and real-time data, if the Administration & Data Server role
includes a real-time server. Because the real-time data in the local database (awdb) are constantly overwritten
by new data, the database size remains fairly constant.
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Over time, the size of your enterprise or your call volumes might change significantly. Therefore, you might
need to resize the central and HDS databases to meet new requirements. You normally do not need to resize
the local database (awdb). If you do need to resize the local database (awdb), you can do so using the ICM
Database Administration (ICMDBA) tool.

The data in the central database and HDS database grow as they accumulate historical data and call detail
records. The growth is directly related to the following factors:

• Size of the Unified ICM configuration; for example, how many services, skill groups, routes, and trunk
groups are configured.

• Call rate; that is, how many calls per day the system software is handling.

• How long historical data is kept in the database.

The amount of configuration data directly affects the amount of historical data generated. The system software
generates a new historical record every half hour for each service, skill group, route, trunk group, and so on,
that is configured in the Unified ICM system.

You size and create the central and HDS databases after installing the system software. Use the Database
Sizing Estimator applet for estimating the size of these databases, based on the expected usage.

If your configuration expands significantly or if you change the retention times for historical data, you might
have to increase the size of the database. This increase might involve adding additional disks to the system.

Historical Data
The system software initiates a purge process on the Logger once every day. By default, the purge process
runs each night at 12:30 A.M. The purge process deletes records that are older than a specified number of
retain days. When you set up the Logger using the Web Setup tool, you can modify the default retention time
and purge schedule.

This table lists the default settings for retaining historical data.

Default retention timeHistorical tables

30 daysLogger_Admin, Import_Rule_History, Persistent

3650 daysRecovery

14 daysAll other historical tables

The following large historical tables are not purged by the system software but as a scheduled SQL Server
Agent Job:

• Agent_Event_Detail

• Call_Type_SG_Interval

• Dialer_Detail

• Network_Event_Detail

• Route_Call_Detail
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• Route_Call_Variable

• Termination_Call_Detail

• Termination_Call_Variable

SQL Server Agent Jobs are installed and enabled during the Unified CCE install and upgrade procedure.
Do not stop these jobs while the system software is active. If you plan to stop the Logger and Administration
&Data Server-hds component services for maintenance for more than a day, manually disable theMicrosoft
SQL Server jobs using the SQL Server enterprise management tool. Later, after the services are started,
re-enable the jobs.

Caution

Database Administration Tool
Unified CCE includes the ICMDBA tool (icmdba.exe) in the \icm\bin directory. This tool provides a central
utility to administer the Unified ICM databases. Use this tool to:

• Create, edit, and delete central databases, local databases, and historical databases

• Resize database files

• Recreate databases

• Import/export Unified ICM configuration data to/from databases

• View database properties

In addition to these tasks, you can start or stop a server and do some limited SQL Server configuration.

Before using the ICMDBA tool, you must install the Unified CCE software. See the Cisco Unified Contact
Center Enterprise Installation and Upgrade Guide , for information on the Unified CCE installation.

Note

The ICMDBA Import/Export feature works on Unified ICM configuration data only. To import or export
Unified ICM historical data, use Microsoft’s SQL Server Database Backup and Database Restore utilities.

Note

You start the ICMDBA either by double-clicking ICMDBA in the Unified CCE Tools folder or by selecting
Start > Run > ICMDBA.

The main window is a tree hierarchy displaying the Unified ICM database servers in the current domain.

If you cannot find the server you want in the main window, you can select any computer on your local
network by choosing File > Add Computer.

Note

Expanding the server name displays the Unified ICM instances that have databases on the server. Expanding
the Unified ICM instance displays a specific Unified ICM node or nodes (Administration & Data Server and
Logger) onmachines that have databases for that instance. Expanding the node displays the databases associated
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with the node. Expanding the node database displays a list of the individual tables in the node database. Under
databases are the table groups, and the final level lists the tables in the group.

You can create databases for instances with or without configured components. When an instance does not
have configured components, database creation occurs under the instance within a component placeholder on
the ICMDBA main window tree view.

To view the properties of a table, right-click the desired table in the list and select Properties from the context
menu, or double-click the table in the list.

There are two ways to access the ICMDBA tool functions:

• From the main window, select a node or database from the tree and then select a function from the menu
bar menu.

• Right-click a node or database to display a context menu.

Create Database with Configured Components
Use the Create function to create a database for an Administration & Data Server or Logger. You can only
create one Logger database per side.

Procedure

Step 1 With the Unified CCE running, for the server and instance, select the node (Administration & Data Server or
Logger) where you want to create the database.

Step 2 SelectDatabase >Create from the menu bar (or click the right mouse button and selectCreate). TheCreate
Database window is displayed.

Step 3 Enter the following information for the database:

• DB Type—Specify the type of database: Outbound Option for an outbound dialer, Administration
& Database Server for a local database (awdb), or Historical Data Server/Detail Data Server
(HDS/DDS) for Administration & Data Server machines. For a Logger device, the default database
type is displayed (Logger side must be selected).

• ICMType—Specify whether this is a Unified ICM or Unified CCE, Unified ICMH, or CICM (Customer
ICM) system.

• Region—Specify regional information where applicable.

Step 4 Select Add. This button invokes the Add Device window.
Use this window to create a new data file and a new log file for the selected database. Specify the disk drive
letter and size in megabytes for each new file.

By default, the newly created data file is set to “Automatically Grow,” if it exceeds the initially
specified size. You can modify this setting, as well as the maximum file size, with SQL Server
EnterpriseManager. Verify on the Files page in SQL Server EnterpriseManager that theAutogrowth
column shows:

Note

• Data files automatically grow in 100 MB increments.

• Log files automatically grow in 10% increments.
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Step 5 After you complete entering information in the Create Database window, select Create to close the window
and create the database.

Create Database Without Configured Components
Use the Create function to create a database for an Administration & Data Server or Logger. You can only
create one Logger database per side.

When an instance does not have any configured components, database creation occurs under the instance
within a component placeholder.

Note

Procedure

Step 1 With Unified CCE running, for the server and instance, select the instance where you want to create the
database.

Step 2 Select Database > Create from the menu bar (or click the right mouse button and select Create). The Select
Component dialog appears.

Step 3 Select the Administration & Data Server, LoggerA, or LoggerB component and select OK.
Step 4 If you select LoggerA or LoggerB, the Select Logger type dialog appears, allowing you to select Enterprise,

CICM, or NAM. Select the logger type and select OK.
The Create Database window appears.

Step 5 Enter the following information for the database:

• DB Type—Specify the type of database: Outbound Option for an outbound dialer, Administration
& Database Server for a local database (awdb), or Historical Data Server/Detail Data Server
(HDS/DDS) for Administration & Data Server machines. For a Logger device, the default database
type is displayed (Logger side must be selected).

• ICMType—Specify whether this is a Unified ICM or Unified CCE, Unified ICMH, or CICM (Customer
ICM) system.

• Region—Specify regional information where applicable.

Step 6 Select Add. This button invokes the Add Device window.
Use this window to create a new data file and a new log file for the selected database. Specify the disk drive
letter and size in megabytes for each new file.

By default, the newly created data file is set to “Automatically Grow,” if it exceeds the initially
specified size. You can modify this setting, as well as the maximum file size, with SQL Server
EnterpriseManager. Verify on the Files page in SQL Server EnterpriseManager that theAutogrowth
column shows:

Note

• Data files automatically grow in 100 MB increments.

• Log files automatically grow in 10% increments.
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Step 7 After you have completed entering information in the Create Database window, select Create to close the
window and create the database.

Delete a Database
Use the Delete function to delete a Administration & Data Server or Logger database.

When an instance does not have any configured components, component placeholders appear under that
instance on the application tree view. If you delete the database, the component placeholders no longer
appear.

Note

Procedure

Step 1 With Unified CCE running, for the server, instance, and node (Administration & Data Server or Logger),
select the database that you want to delete.

Step 2 Select Database > Delete from the menu bar.
Step 3 The Delete Database prompt appears. Select Yes to delete the database.
Step 4 Verify that you want to delete the database in the message box.
Step 5 Select Close to exit. Check the main window to verify that the database was deleted.

Expand a Database
Use this function to add a new storage file.

ICMDBA allows a database to be expanded a maximum of 49 times (resulting in 50 segments). In the
event that you reach this limit, you must either recreate the database or use SQL Enterprise Manager to
modify the database.

Note

Procedure

Step 1 For the server, instance, and node (Administration & Data Server or Logger), select the database that you
want to expand.

Step 2 Select Database > Expand from the menu bar (or click the right mouse button and select Expand). The
Expand window appears:
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Step 3 Use the window to adjust the size allocation on the database storage device, by completing the following
fields:

• Component—Specifies whether the file is a data file or log file. Each database must have a file for each
type of service.

• Available Drives—Specify the drive on which to create the database.

• Size—Specifies the size (in MB) of the storage. The field displays a default size, adjust the value as
necessary.

Step 4 Select OK to expand the file and exit the screen.

Recreate a Database
Use the Recreate function to recreate a database. The procedure for recreating a database is similar to the
procedure for creating a database.

When you recreate a database, the information currently stored in the database is deleted.Caution

When an instance does not have any configured components, database creation occurs under a component
placeholder on the application tree view.

Note

Administration Guide for Cisco Unified Contact Center Enterprise & Hosted, Release 10.5(1)    
7

Database Administration
Recreate a Database



Procedure

Step 1 For the server, instance, and node (Administration & Data Server or Logger), select the database that you
want to recreate.

Step 2 Select Database > Recreate from the menu bar. The Recreate window appears.
Step 3 Enter the database information. See the online help for a description of the fields.
Step 4 Select Create to continue. A message is displayed asking if you are sure you want to recreate the database.

Select Yes to continue the operation.
Step 5 The nextRecreate Databasewindow appears. Select Start to recreate the database. After the process completes,

a message appears indicating the action was successful. Select OK and then select Close to exit.

View Database Properties
The ICMDBA tool allows you to view the properties of specified databases.

Procedure

Step 1 For the server, instance, and node (Administration & Data Server or Logger), select the database that you
want to view.

Step 2 SelectDatabase > Properties from the menu bar (or click the right mouse button and select Properties). The
Properties window appears.
The screen display includes the following information:

• Instance name

• The database configuration

• The size and percentage used of the files

• Where the data and log files are stored

Step 3 After you finish viewing the database properties, select Close to exit the window.

View Table Properties
ICMDBA also allows you to view the properties of each table in the database.
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Procedure

Step 1 Select and expand the database to display the tables of a database.
Step 2 Double-click the table you want to view. The Table Properties window appears.
Step 3 After you finish viewing the table properties, select Close to exit the window.

Import and Export Data
You can use Import/Export functions to move Unified ICM configuration data from one database to another.

The ICMDBA Import/Export feature handles Unified ICM configuration data only. To import or export
Unified ICM historical data, use Microsoft’s SQL Server Database Backup and Database Restore utilities.

Note

Procedure

Step 1 For the server, instance, and node (Administration & Data Server or Logger), select the database from which
you want to import or export data.

Step 2 Select Data > Import (or Export) from the menu bar. The Import data to (or Export) window appears.
Step 3 CheckLockout Changes, if you want to prevent changes to the database during the import or export operation.
Step 4 Check Truncate Config Message Log, if you want to truncate the Config_Message_Log table in the Logger

database.
Truncating deletes the data and does not export the Config_Message_Log
table.

Note

Step 5 Set the Data type for the imported data.
Step 6 Indicate the path for the source/destination of the data.
Step 7 Select Import (or Export) to display the Import (or Export) dialog.
Step 8 Select Start to import (or export) the data. After the process completes, a message appears indicating that the

action was successful. Select OK and then select Close to exit. You can select Cancel at any time to end the
process.

Synchronize Database Data
Use the Synchronize function to synchronize the data of two Logger databases.
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Procedure

Step 1 For the server and instance, select the Logger database to synchronize.
Step 2 Select Data > Synchronize from the menu bar. The Synchronize window appears:

Step 3 Check Lockout Changes, if you want to prevent changes to the database during the synchronize operation.
Step 4 Check Truncate Config Message Log, if you want to truncate the Config_Message_Log table in the Logger

database.
Step 5 Select the server name and database for both source and target from the drop down lists. To select a server

that is not on the drop down list, select Add and enter the server name in the Add Server box:

Step 6 Select Synchronize.
Step 7 A message box appears asking for confirmation. Select OK to continue.
Step 8 The next Synchronize window appears. Select Start to synchronize the data. After the process completes, a

message appears indicating that the action was successful. Select OK and then select Close to exit. You can
select Cancel at any time to end the process.

Configure a Database Server
ICMDBA allows you to start or stop a server and to do some limited server configuration.
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To start or stop a server, select the node from the list and select Server > Start/Stop from the menu bar.

When you use the Configure option, the SQL Server, Administration & Data Server, and Logger restart
automatically. However, when you use the Stop option from the Server menu, you must manually restart
the Logger and Administration & Data Server from ICM Service Control.

Note

Procedure

Step 1 Select the server and select Server > Configure from the menu bar. The Configure window appears.
Step 2 Use this window to modify the following SQL Server parameters:

• User Connections—Indicates the maximum number of users that can connect to SQL Server at one
time.

• Locks—Indicates the maximum number of available locks.

• Open Objects—Indicates the maximum number of available open objects.
User Connections, Locks, and Open Objects are “dynamically allocated” by SQL Server. Unified
ICM does not allow you to change these options, so they are grayed out.

Note

• Open Databases—Indicates the maximum number of available open databases.

•Memory—Indicates the amount of memory (in megabytes) allocated to SQL Server processing.
You can configure a specific amount of memory instead of the SQL Server default of “Dynamic.”
Specifying a value of 0 sets the Memory setting to “Dynamic.”

Note

• Recovery Interval—This setting controls checkpoint frequency.

•Max Async ID—Indicates the maximum number of outstanding asynchronous disk input/output (I/O)
requests that the entire server can issue against a file.

Step 3 After you are finished configuring the server, select OK to complete the operation or select Cancel to end
the operation without making any changes.

Database Sizing Estimator Tool
The Database Sizing Estimator tool enables you to perform database sizing tasks.

The Database Sizing Estimator estimates the storage requirements for a Cisco Unified ICM/CCE logger or
HDS database based on information about the configuration of the environment (for example, the number of
agents, skill groups, call types, and so on) and database retention days. You can supply initial values by loading
values from your local Unified ICM database.

When values are updated in the Database Sizing Estimator, the application recalculates its totals. This update
enables you to immediately see the affects of each change as it is made, with the values displayed in a
spreadsheet. The tool enables you to engage in what-if scenarios to see the effects that various changes will
have on the database sizing requirements.
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The Database Sizing Estimator allows you to save the values as an XML file on your local machine. At any
time, you can load the saved XML file back into the Database Sizing Estimator, so you can continue revising
your estimates.

Cisco Unified ICM/CCE Database Retriever Dialog

The Cisco Unified ICM/CCEDatabase Retriever dialog, which you access from the Database Sizing Estimator
tool, queries the existing database and registry configuration. The Database Sizing Estimator tool then uses
this data to provide starting values, which you can modify.

To access the Database Retriever dialog, select Load from DB in the Database Sizing Estimator tool on
your local machine.

Cisco Unified ICM/CCEDatabase Retriever can retrieve the configuration and retention information from
anyUnified ICM/CCE system containing a Logger or Historical Data Server (HDS) database. The Database
Sizing Estimator can calculate a database size for a newer schema other than the deployment to which the
Database Sizing Estimator is connected.

Note

Start Database Sizing Estimator
The following steps describe how to start the Database Sizing Estimator.

For Database Sizing Estimator field-level descriptions, see the online help.Note

Procedure

Step 1 Open the Database Sizing Estimator tool by selecting Database > Estimate in the ICMDBA tool.
Step 2 The Cisco Unified ICM/CCE Database Sizing Estimator window appears:
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Step 3 The window displays initial default values for all fields. As you change the field values, the database size
requirements update automatically. You can load values from a previous version or from the Cisco Unified
ICM/CCE Database Retriever dialog by selecting Load from File to load an external XML data file.

Estimate Database Size

Steps 1–3 in this procedure only apply when using existing databases.Note

Procedure

Step 1 Use your existing database as the starting point. Select Load from DB in the Database Sizing Estimator
main window. The Cisco Unified ICM/CCE Database Retriever dialog appears.

Step 2 Select the database you want to use as the starting point for your sizing estimates.
Step 3 Select Retrieve.
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The fields in the Database Sizing Estimator main window auto-populate with the information from the
selected database.

Step 4 Modify the database information depending on your scenario. As changes are made, the Database Size
Required value changes.

Step 5 Save your work in progress by selecting Save to File.

Administration & Data Server with Historical Data Server Setup
There are two ways to set up a Historical Data Server (HDS) VM:

• The instance is created in the domain, but not already added.

• The instance is created in the domain and is already added.

Set Up HDS and Add Instance

Procedure

Step 1 Run the Cisco Unified ICM/Contact Center Enterprise & Hosted Installer (if you have not run it already) on
the local machine.

Step 2 Run theWeb Setup tool for that machine (in a browser, from anywhere). Under InstanceManagement, select
Add and add the instance.

Step 3 Run the ICMDBA tool on the local machine. Create the Historical Data Server/Detail Data Server database.
Step 4 Return to the Web Setup tool. Under Component Management, select Add on the Administration & Data

Server list page, then follow the instructions in the Cisco Unified Contact Center Enterprise Installation and
Upgrade Guide . If you did not perform step 3, the Administration & Data Server Add wizard does not allow
you to finish this procedure until you create an HDS database.

What to Do Next

Use the Database Sizing Estimator tool to determine the size of the database and then use the ICMDBA tool
to create the database.
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Set Up HDS from Added Instance

Procedure

Step 1 Run the Cisco Unified ICM/Contact Center Enterprise & Hosted Installer (if you have not run it already) on
the local machine.

Step 2 In the Web Setup tool, under Component Management, select Add on the Administration & Data Server
list page, then follow the instructions in the Cisco Unified Contact Center Enterprise Installation and Upgrade
Guide . If you did not perform step 1, the Administration & Data Server Add wizard does not allow you to
finish this procedure until you create an HDS database.

What to Do Next

Use the Database Sizing Estimator tool to determine the size of the database and then use the ICMDBA tool
to create the database.

Database Size Monitoring
You should regularly monitor the space used by the central database and transaction logs. You can monitor
database size by viewing the Logger’s per-process log files. The per-process log files contain information on
Logger and database activity, as this example log file illustrates:

The Logger logs events and trace messages that show the percentage of space used in the database. These
files are stored in a \logfiles subdirectory in the Logger’s directory (la or lb). You can view the Logger’s
per-process log files by using the Unified ICM dumplog utility.

When the database becomes 80 percent full, the Logger logs an EMSwarning message to the central database.
The “80 percent full” warning message might also immediately be sent to your Unified ICM network
management station through SNMP or SYSLOG.

Administration Guide for Cisco Unified Contact Center Enterprise & Hosted, Release 10.5(1)    
15

Database Administration
Set Up HDS from Added Instance



See the Serviceability Best Practices Guide for Cisco Unified ICM/Contact Center Enterprise for more
information on using the dumplog utility.

Note

If you decide that you need additional database space, contact your Unified ICM support provider.

System Response When Database Nears Capacity
The system software has automatic checks to prevent the central database from becoming full:

•Warning message—When the central database begins to approach its capacity, the system software
issues a warning message. By default, this warning occurs when the database is 80% full, but you can
configure this value. Warning messages trigger an event that is registered in AlarmTracker, which the
console window displays in an EMS trace message.

• Automatic purge—If you select the Automatic Purge Adjustment option when you install the Logger
software, the system software automatically deletes the oldest historical data when database usage
exceeds 80% threshold or when the central or HDS database nears its capacity. If the data has not
exceeded the retention period, it does not get deleted. By default, automatic purge occurs when the
database is 80% full, but you can set the percentage when you set up the Logger. You can also set the
retention period for data when you set up the Logger.

See the Cisco Unified Contact Center Enterprise Installation and Upgrade Guide for
more on purging information from databases.

Note

• Emergency Purge—By default, the system automatically deletes the oldest historical data from all
historical tables when the database exceeds 90% usage capacity.

The automatic purge ensures that the database can never become completely full. But, the purge means that
you can lose older historical data.

Allocation of More Database Space
If the central database is growing too large, you can allocate additional space. If you require additional space
in the central database, you must back up the master database before you add more space. Your Unified ICM
support provider might have options for allocating more space.

Initialize Local Database (AWDB)
Normally, you do not need to initialize the local database (awdb), because initialization happens automatically
during its creation. If you ever need to initialize the local database after its creation, you can do so.
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Procedure

Step 1 Double-click Initialize Local Databasewithin the Administration Tools folder. The Initialize Local Database
main window appears.

Step 2 Select Start to transfer the data. As data is copied, the screen displays the number of rows processed for each
table.

Step 3 After the transfer is complete, select Close to exit.

General Database Administration
Because Unified ICM is a mission-critical application that runs 24 hours a day, the system software takes care
of many routine administration tasks automatically. In general, the system software retains control of most
of the database administration functions in order to keep external interference to a minimum.

As the Unified ICM administrator, you might be responsible for performing several optional Unified ICM
administration tasks:

• Setting networking options

• Monitoring Logger activity

• Backing up the central database

• Restoring the central database from backup

• Comparing databases

• Resynchronizing databases

To conserve system resources, minimize all Unified ICM process windows before configuring your system.Note

Built-In Administration
The system software maintains a database on each side of the Central Controller and the local database (awdb).
Each database consists of a group of interrelated tables. As you add or update data in the database, you must
ensure that logical relationships are maintained. For example, if you delete a trunk group, you must not leave
trunks in the database that reference that trunk group. If you do, the integrity of the database is broken.

Configuration Manager prevents you from making certain changes that disrupt the integrity of the data in the
database. However, it cannot prevent all such changes. Usually, if data integrity in the local database (awdb)
is temporarily disrupted, no major problems occur. However, integrity problems in the central Unified ICM
database could cause errors in system processing.
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To protect the integrity of the Unified ICM databases, do not use third-party tools to modify them. These
tools do not protect against disruptions of database integrity. (You can use third-party tools to view Unified
ICM data.)

Note

When your Unified ICM support provider installs the Unified ICM system, they perform integrity checks to
make sure that the database is configured correctly. After that, the integrity of the central database is maintained
by the system software. You do not need to manually check the integrity of the Unified ICM central database.
If you ever have a problem with data integrity in the central database, the problem is most likely a software
problem that your Unified ICM support provider needs to address.

Manual integrity checks of the central database must involve your Unified ICM support provider. Do not
run the DBCC CHECKDB procedure on the central database while the Unified ICM system is running.
This procedure stops the Logger.

Caution

Check AWDB Data Integrity
You can manually check the integrity of data in the local database (awdb). Configuration Manager provides
a Check Integrity option under the Administer menu. Configuration Manager allows you to select which
checks you want to execute.

The specific data integrity check procedures are listed in the following table:

Table 1: Local Database Data Integrity Check Procedures

DescriptionProcedure

Checks for the value NULL in specific fields in the database that must not be
null. It also checks that the value of the RoutingClient.PeripheralID is NULL
for routing clients associated with a NIC.

Null

Checks for appropriate relationships among peripherals, targets at peripherals
(services, skill groups, agents, and translation routes), trunk groups, network
targets, announcements and peripheral targets.

Targets

Checks that ID fields cross-referenced from several tables correspond to existing
records.

Routes and Numbers

Checks for valid cross-references among scripts, call types, and dialed numbers.Scripts

Checks for valid cross-references among enterprise services and services, and
between enterprise skill groups and skill groups. Also performs several other
checks on skill groups, trunks, and so on.

Enterprise

Checks for valid relationships between agents and skill groups, between skill
groups and services, between labels and routing clients, between dialed numbers
and routes, and between peripherals and routing clients.

Domain Adherence

   Administration Guide for Cisco Unified Contact Center Enterprise & Hosted, Release 10.5(1)
18

Database Administration
Check AWDB Data Integrity



DescriptionProcedure

Checks for invalid characters in enterprise names (EnterpriseName field) in
various database tables. Enterprise names provide unique character-string names
for objects in the Unified ICM configuration.

Names

Checks rules for Outbound Option Configuration.Miscellaneous

For more information on the specific fields checked by these procedures, see the online help for the
Configuration Manager tool.

Procedure

Step 1 Invoke Configuration Manager by double-clicking its icon in the Administration Tools folder.
Step 2 SelectConfigure ICM >Administration > Integrity Check from the menu bar. The Integrity Check dialog

box appears.
Step 3 Select specific checks to execute, or select All to perform all the checks.
Step 4 Select Start to perform the checks. If any integrity problems are found, the Configuration Manager displays

a message describing the problems.
Step 5 After you perform all the checks you want, select Done to dismiss the Integrity Check dialog box.

Logger Events
You can view recent Logger activity by viewing the Logger’s per-process log files. Per-process log files
document events for the specific processes running on a computer. These files are useful in diagnosing problems
with processes on the Logger (and on other nodes in the Unified ICM system).

You can also view Logger event data in the central database. The Event Management System (EMS) logs
events to the central database. Be especially aware of Error and Warning events generated by the Logger. For
example, the system software logs a Warning event when the central database becomes 80% full.

See the Serviceability Best Practices Guide for Cisco Unified ICM/Contact Center Enterprise for more
information on viewing the per-process log files and central database event data.

Database Networking Support
You can use the SQL Server Setup program to specify which network protocols the database manager supports.

The correct order and states are:

1 Shared Memory—Enabled
2 Named Pipes—Enabled
3 TCP/IP—Enabled
4 VIA—Disabled
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See the Staging Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted for detailed information
about installing SQL Server. For more information about database networking, see theMicrosoft SQL Server
System Administrator’s Guide.

Database Backup and Restore
A database can be lost or corrupted for several reasons. Because you cannot protect against all these reasons,
you must have a backup strategy in place. This backup strategy is especially important if you have a
non-redundant central database configuration. However, even for a redundant system, you still need to perform
backups to protect against software problems that corrupt both sides of the system.

The commonly-used database backup strategies are:

• Regularly scheduled database backups

• Mirrored disk configurations

• Redundant Array of Inexpensive Disks (RAID) configurations

Although the last two strategies might decrease system performance, they have the advantage of not requiring
manual intervention. However, while these configurations protect against disk drive failure and bad media,
they might not protect against some software errors.

In a single database configuration, you need to ensure protection against all types of errors. To protect your
data, regularly back up the central database with the SQL Administrator tool provided with SQL Server.

The SQLMonitor service must run during a backup. If SQL Server is not configured to start SQLMonitor
automatically, start the service manually before beginning the backup.

Note

When you restore a database, you can only restore up to the last backup. Any transactions after that backup
are lost. In single database configurations, daily backups are required to ensure maximum data protection.

You must backup the entire database at each backup interval. The system software does not support the
use of transaction log dumps as incremental backups.

Note

For general information about developing a backup strategy, including the use of mirrored disks, seeMicrosoft’s
SQL Server System Administrator’s Guide. For specific information about backing up a database using SQL
Administrator, seeMicrosoft’s SQL Administrator User’s Guide.
To backup an Unified ICM database:

1 Stop Unified ICM services for the processes that are using the database that you want to back up.
2 Run the backup.
3 Restart Unified ICM services after the backup is complete.

On a redundant system, calls processing can continue if you backup the two sides at different times.
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Database Comparison
For diagnostic purposes, you might want to check that two databases have the same data in a specific table.
For example, you might want to check that the ICM_Locks table contains the same data on both sides of a
Central Controller. The tool dbdiff.exe performs this type of check. Its syntax is as follows:
dbdiff database1.table@host1 database2.table@host2

For example:
dbdiff cust1_sideA.ICM_Locks@geoxyzlgra cust1_sideB.ICM_Locks@geoxyzlgrb

The batch script diffconfig.bat invokes dbdiff for various tables to automatically compare two Unified
ICM databases. Its syntax is as follows:
diffconfig database1 host1 database2 host2

For example:
diffconfig cust1_sideA geoxyzlgra cust1_sideB geoxyzlgrb

Database Resynchronization
You might occasionally need to repair a corrupt Logger database on one side of a redundant Unified ICM by
copying the Logger database from the other side. You can synchronize the databases using either the DOS
Command window or the ICM Database Administration (ICMDBA) tool.

The ICMDBA synchronize process involves dropping the targeted side data and copying the data from the
source. For example, if you are synchronizing side B data to side A data, the side B data will be replaced with
the data stored in side A.

Perform these procedures in a maintenance window.Note

Synchronize Database from Command Window
The following directions explain how to synchronize the databases.

Procedure

Step 1 Stop the Logger for the target database, if that Logger is running.
Step 2 In a DOS Command window on the VM for that Logger, change to the \icm directory.
Step 3 Run the following command: install\syncloggers <Source_server> <Source_database> <Target_server>

<Target_database>.
Step 4 When prompted, verify that the configuration is deleted from the correct database and type Y to continue.

What to Do Next

When the command is complete, restart the Logger on the target server.
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