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Managing Activities
Whether you are using Workflow or non-Workflow mode, all policy configuration is done within an
activity, which is also called a configuration session in non-Workflow mode. In Workflow mode, you
must explicitly create and manage activities, whereas in non-Workflow mode much of the activity
creation and management is done automatically for you. However, in non-Workflow mode, you are in
fact working within an activity whenever you modify policies, and so you should understand the basic
activity concepts.
The following topics provide information about activities:
•

Understanding Activities, page 4-1

•

Working with Activities, page 4-6

Understanding Activities
An activity is a temporary context within which you define policies and assign them to devices. You do
not need to create an activity to import, create, or delete devices (unless you perform policy discovery
as part of the action), or to perform various system management tasks.
The requirements for creating or opening activities differ depending on your Workflow mode:
•

Non-Workflow mode—An activity is created automatically and transparently for you whenever you
define, modify, or assign policies to devices. The same activity is used until you submit your changes
to the database, and is automatically closed and reopened as needed. You cannot actively open or
manage activities in non-Workflow mode. These types of activities are also called configuration
sessions.

•

Workflow mode—If you do not explicitly open an activity, you are prompted to create a new activity
or open an existing one whenever you perform an action that requires an activity. You must actively
open and manage activities in Workflow mode.

When you create an activity, or one is created for you, you open a virtual copy of the Security Manager
policy database. You define and assign policies within this copy. Changes that you made within this copy
are only available within the copy. Other users in different activities cannot see these changes. After the
activity is submitted and, in Workflow mode, approved, the changes within this copy are committed to
the database so that all other users can view the changes. Then, you can create a deployment job to
generate the relevant CLI commands and deploy them to the devices.
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How you submit your activity changes differs depending on Workflow mode:
•

Non-Workflow mode—Select File > Submit to submit your changes to the policy database.

•

Workflow mode—Select Activities > Submit Activity if you are working with an activity approver,
or Activities > Approve Activity if you do not have a separate activity approver.

The following topics describe why activities are important and how they operate in Workflow mode:
•

Benefits of Activities, page 4-2

•

Activity Approval, page 4-2

•

Activities and Locking, page 4-3

•

Activities and Multiple Users, page 4-4

•

Understanding Activity States, page 4-4

Benefits of Activities
You use activities to control changes made to policies and policy assignments. Although how activities
are implemented depends on the workflow settings you choose, all activities provide the following
benefits:
•

Audit trail—Activities track changes that are made in Security Manager. In Workflow mode, you
can use this information to determine what changes were made and who made the changes as
described in Viewing Activity Status and History (Workflow Mode), page 4-18. For both Workflow
and non-Workflow mode, there is also an audit report that provides visibility into activities and other
actions, as described in Working with Audit Reports, page 10-11.

•

Safety mechanism—Activities provide a means for experimenting with changes. Because you are
making the changes to a private database view, if you do not want to implement the changes, you
can easily discard the activity or configuration session. For more information, see Discarding an
Activity (All Modes), page 4-17.

•

Task isolation—The policies that are modified within an activity (or configuration session) are
locked from being modified within other activities. This prevents conflicting changes that could
make a policy unstable. For more information, see Activities and Locking, page 4-3.
In addition, the changes you make within an activity are visible only within the activity. Other users
see only the last approved committed configurations, unless they view your activity before you close
it (in Workflow mode).

Activity Approval
When you enable Workflow mode, you can choose to operate with or without an activity approver.
If your organization requires a different person with higher permissions to approve activities, you can
enable workflow with an approver. When using Workflow mode with an approver, the activity must be
approved by a person with the appropriate permissions so the policies can be committed to the database.
This approval process at the policy definition level helps to ensure that no inappropriate configurations
reach the network devices.
If you choose to operate without an approver, the person defining the policies has the permissions to
approve them.
For information about enabling or disabling activity approval and changing the default activity approver,
see Workflow Page, page 11-40.
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Activities and Locking
To prevent multiple users from making conflicting changes, Security Manager obtains activity-level
locks when a user performs certain actions within an activity or configuration session in Workflow or
non-Workflow mode. This prevents two or more people from making changes to the same feature policy,
policy assignment, or object at the same time.
Security Manager also uses locking to ensure that operations related to the committed configuration
always run exclusive of one another. These operations can be divided into two categories:
Operations that change the committed configuration:
•

Activity approval, which includes configuration session submission in non-Workflow mode.

•

Device deletion.

•

Editing device properties.

Operations that read the committed configuration:
•

Configuration preview.

•

Deployment (in non-Workflow mode).

•

Creation of deployment job (in Workflow mode).

•

Activity or configuration session validation.

If you are performing an operation that changes the committed configuration, no one can perform any
of the operations in either list until this operation is complete. An error message is displayed to the user
who tries, indicating the action and activity (or user, in non-Workflow mode) that has the lock. For
example, if you are approving an activity (which occurs automatically when an activity is submitted in
non-Workflow mode), no one else can delete a device or validate a different activity until the approval
is complete. This type of locking is particularly important in multi-user settings as it prevents multiple
users from simultaneously making changes to the committed configuration.
If you are performing an operation that reads the committed configuration, no one can perform an
operation that changes the committed configuration. For example, if you are validating an activity,
another user cannot approve an activity. However, other users can perform another operation that reads
the configuration. For example, if you are validating an activity, another user can create a deployment
job. Similarly, if you are previewing the configuration before deployment, another user is permitted to
do the same. This is because these two operations are limited to reading the committed configuration;
they do not make any changes to it.

Tip

Activity locking is broader in scope than policy locking, which is described in Understanding Policy
Locking, page 5-7. Policy locking prevents two users from changing the same policy on the same device
simultaneously.
Related Topics
•

Approving or Rejecting an Activity (Workflow Mode), page 4-16

•

Deleting Devices from the Security Manager Inventory, page 3-47

•

Viewing or Changing Device Properties, page 3-34

•

Working with Deployment and the Configuration Archive, page 8-24

•

Validating an Activity (All Modes), page 4-14
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Activities and Multiple Users
Only one user can define or change policies within an individual activity at one time. However, when
Workflow mode is enabled, multiple users can work in the activity in sequence. That is, if an activity is
closed (but not yet approved or submitted for approval), another user can open it and make changes to
it. Multiple users can work in parallel in different activities.

Understanding Activity States
In Workflow mode, an activity can have the states described in the following table. The main activity
states are shown in bold.
Table 4-1

Activity States

State

Description

Edit

The activity was created, but the activity is not currently being edited.
The activity can be opened or discarded while it is in the Edit state.

Edit Open

The activity is open for editing. Changes, such as defining and
assigning policies, can be made in the activity. The policies, policy
assignments (devices being assigned policies), and objects being
configured or modified in the activity are locked. That is, they cannot
be configured or modified within the context of another activity. The
activity can be closed, discarded, submitted, or approved while it is in
the Edit Open state.
The configuration changes can be seen only in the context of the
activity.

Submitted
Submitted Open

The activity was submitted for review and approval. (This state is
available only if you have Workflow mode enabled with activity
approval required. For more information, see Workflow Page,
page 11-40.) No further changes can be made within the activity. The
policies, devices (through policy assignment), or objects affected by the
policy changes remain locked to other activities.
When an activity is submitted, an e-mail is sent to the approver. The
approver can open the activity (in read-only mode, moving to the
Submitted Open state) to review the changes within the activity, then
approve or reject it. An approved activity moves to the approved state.
A rejected activity returns to the Edit state.

Approved

The activity was approved, and the corresponding configuration
elements are now committed policy configurations. The devices
affected by the policy changes are no longer locked to other activities.
The activity can be deployed while it is in the Approved state.

Approve Failed

The activity is placed in the Approve Failed state if errors occur during
approval (for example, due to a power failure). If this happens, try to
approve the activity again or reboot the server.
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Table 4-1

Activity States (Continued)

State

Description

Discarded

Changes made to the activity since the activity was created were
discarded and further changes to the activity are not allowed. Devices
associated with the activity are unlocked and can now be used in a new
activity. The activity remains in the Activity table showing a Discarded
state until it is purged from the system.

Figure 4-1 shows the stages in the activity workflow without an approver. Figure 4-2 shows the stages
in the activity workflow with an approver.
Figure 4-1

Activity Workflow without an Approver
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Figure 4-2

Activity Workflow with an Approver

Create/open
activity

Editable

Close
activity

Define
configurations

Submit
activity

Submitted

Approve
activity

Reject
activity

Approved

Editable

COMMITTED

73772

Open activity
(read-only)

Working with Activities
The following topics provide information to help you use activities and configuration sessions:
•

Accessing Activity Functions in Workflow Mode, page 4-7

•

Creating an Activity (Workflow Mode), page 4-10

•

Opening an Activity (Workflow Mode), page 4-11

•

Closing an Activity (Workflow Mode), page 4-12
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•

Viewing Change Reports (All Modes), page 4-12

•

Validating an Activity (All Modes), page 4-14

•

Submitting an Activity for Approval (Workflow Mode with Activity Approver), page 4-15

•

Approving or Rejecting an Activity (Workflow Mode), page 4-16

•

Discarding an Activity (All Modes), page 4-17

•

Viewing Activity Status and History (Workflow Mode), page 4-18

Accessing Activity Functions in Workflow Mode
In Workflow mode, you can access activity management functions in the following ways:
•

Select Tools > Activity Manager. The Activity Manager window contains a list of existing activities
and their states. From this window, you can create new activities, and open, close, submit, approve,
reject, or discard existing activities. For more information, see Activity Manager Window, page 4-8.

•

Click a button in the Activities portion of the main toolbar or select the equivalent command in the
Activities menu. Whether a button or command is active depends on your user permissions, the state
of the activity, and whether you are using workflow with or without an approver. The following table
explains the buttons and commands and the conditions under which you can them.

Table 4-2

Button

Activities Tool Bar Buttons and Commands When Workflow Mode Is Enabled

Activities Menu
Command

Description

New Activity

Creates an activity.

Open Activity

Opens an activity. You can open an activity when it is in the Edit
or the Submitted state.
To open a submitted activity, you must have user privileges to
approve or reject changes made in that activity. For more
information, see the Installation Guide for Cisco Security
Manager.

Close Activity

Saves all changes made while the activity was open and closes it.
You can close an activity when it is in the Edit Open or the Submit
Open state.

View Changes

Evaluates all changes made in the activity and produces an
Activity Change Report in PDF format in a separate window. For
more information, see Viewing Change Reports (All Modes),
page 4-12

Validate Activity

Validates the integrity of changed policies within the current
activity. By validating an activity, you can check for configuration
errors that you might have introduced by your policy changes.

Submit Activity

In Workflow mode with an activity approver, submits the activity
for approval. You can submit an activity when it is in the Edit or
the Edit Open state.
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Table 4-2

Button

Activities Tool Bar Buttons and Commands When Workflow Mode Is Enabled

Activities Menu
Command

Description

Approve Activity

Approves the changes proposed in an activity.
You can approve an activity when it is in the Submitted state when
using an activity approver, or the Edit or Edit Open state when not
using an approver. You must have user privileges to accept the
changes proposed in an activity. For more information, see the
Installation Guide for Cisco Security Manager.

Reject Activity

In Workflow mode with an activity approver, rejects the changes
proposed in an activity.
You can reject an activity when it is in the Submitted or Submitted
Open state. You must have user privileges to deny changes
proposed in an activity. For more information, see the Installation
Guide for Cisco Security Manager.

Discard Activity

Discards the selected activity. The activity is discarded and later
purged from the system after it exceeds the age for keeping
activities as set under Tools > Security Manager Administration >
Workflow. The activity state is shown as discarded until the
activity is actually purged from the system.

Activity Manager Window
Use the Activity Manager window to create and manage activities and to view activity status and history.
The upper pane lists the activities that have been created. Select an activity to view its details and history
in the lower pane.
The Activity Manager window is available only if you are operating in Workflow mode. In
non-Workflow mode, Security Manager automatically and transparently manages activities.
Navigation Path

Click the Activity Manager button on the Main toolbar, or select Tools > Activity Manager.
Field Reference
Table 4-3

Activities Manager Window

Element

Description

Activity

The name of the activity.

Last Modified

The date and time of the most recent change to the activity.

State

The state of the activity. For a list of states, see Understanding Activity
States, page 4-4.

User

The username of the person who last changed the state of the activity.

Last Action

The most recent action performed on the activity.

Create button

Click this button to create new activity so that you can create or change
policies or assign policies to devices. For more information, see
Creating an Activity (Workflow Mode), page 4-10.
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Table 4-3

Activities Manager Window (Continued)

Element

Description

Open button

Click this button to open the selected activity so that changes, such as
defining and assigning policies, are captured within the activity. You
can open an activity when it is in the Edit or the Submitted state.
Submitted activities are opened read-only.

Validate button

Click this button to validate changes that you have made to the selected
activity from the time you created the activity to the current time.
Validating an activity checks policy integrity and deployability, and
displays detailed error information if errors are detected. For more
information, see Validating an Activity (All Modes), page 4-14.

Submit button

In Workflow mode with an activity approver, click this button to submit
the selected activity. Submitting the activity sends notification that the
activity is ready for review to the specified approver. You can submit an
activity when it is in the Edit or the Edit Open state.
You are prompted for a comment. For more information, see
Submitting an Activity for Approval (Workflow Mode with Activity
Approver), page 4-15.

Approve button

Click this button to approve the selected activity, which saves the
proposed changes to the database. Devices associated with the activity
are unlocked, meaning they can be included in policy definitions and
changes in other activities. You must have appropriate user permissions
to approve the activity.
In Workflow mode without an approver, you can approve your own
activities when they are in the Edit state. In workflow mode with an
approver, you must submit your activity, and the approver can approve
an activity only when it is in the Submitted state.
You are prompted for an approval comment. For more information, see
Approving or Rejecting an Activity (Workflow Mode), page 4-16.

Reject button

In Workflow mode with an activity approver, click this button to reject
the changes proposed in the selected activity. You must have
appropriate user permissions to reject an activity. If the activity is
rejected, the submitter can continue to make changes to the activity.
Devices associated with the activity are not unlocked, meaning that
they cannot be included in policy definitions or changes in another
activity. You can reject an activity only when it is in the Submitted or
the Submitted Open state.
You are prompted for a rejection comment. For more information, see
Approving or Rejecting an Activity (Workflow Mode), page 4-16.
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Table 4-3

Activities Manager Window (Continued)

Element

Description

Discard button

Click this button to discard the selected activity. Devices associated
with the activity are unlocked, meaning they can be used by other
activities.
You are prompted for a comment. For more information, see Discarding
an Activity (All Modes), page 4-17.
Discarded activities are removed from the system according to the
settings defined in the Security Manager settings for Workflow. The
activity state is shown as discarded until the activity is purged from the
system. For more information, see Workflow Page, page 11-40.

View Changes

Click this button to generate a report in PDF format for the selected
activity. If activity is closed, this button is grayed out. For more
information, see Viewing Change Reports (All Modes), page 4-12.

Refresh button

Click this button to refresh the information presented in the window.

Details tab

Displays detailed information for the selected activity. Besides the
information repeated from the activities table, the details include this
information:

History tab

•

Activity ID—The identification number assigned by Security
Manager when you created the activity.

•

Created—The date and time the activity was created.

•

Description—The description of the activity, which was entered
when the activity was created.

Displays a log of the changes that have been made to the selected
activity. The information includes the state changes, the user who made
the change, the date and time of the change (based on the Security
Manager server time), and any comments the user entered to document
the change.

Creating an Activity (Workflow Mode)
In Workflow mode, before you create or change policies or assign policies to devices, you must create
an activity.

Tip

In non-Workflow mode, activities are created automatically when needed.
Related Topics
•

Understanding Activities, page 4-1

•

Opening an Activity (Workflow Mode), page 4-11
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Step 1

Do one of the following:
•

Click the Create Activity button in the activity toolbar.

•

Select Activities > New Activity.

•

Click Create in the Activity Manager window.

The Create Activity dialog box appears.
Step 2

In the Create Activity dialog box, enter a name for the activity or keep the system-generated name. The
default activity name contains the username, date, and time the activity was created. You can also enter
a comment to describe the activity.

Step 3

Click OK.
The activity is listed in the Activity Manager window. For more information, see Activity Manager
Window, page 4-8.

Responding to the Activity Required Dialog Box
When in Workflow mode, you must create or open an activity before you create or modify policies. If
you attempt to perform an action that requires an activity, and you have not created or opened one yet,
you are prompted to do so with the Activity Required dialog box.
You can choose from the following options:
•

Create a new activity—Create a completely new activity, specifying an activity name and
optionally a description of the purpose of the activity. The default activity name contains the
username, date, and time the activity was created.

•

Open an existing activity—To open the activity you select from the Activity list. This option is
displayed only if there are activities available in the Edit state.

Related Topics
•

Creating an Activity (Workflow Mode), page 4-10

•

Understanding Activity States, page 4-4

Opening an Activity (Workflow Mode)
In Workflow mode, you can open an existing activity if no one else has it opened. You might open an
existing activity in the Edit state to make further policy changes, or you might open an existing activity
in the Submitted state to review proposed policy changes before approving or rejecting it (if you have
the appropriate permissions and you are working in Workflow mode with an approver).
You can made changes to activities in the Edit state, but you can only view activities in the Submitted
state.
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To open an activity, do one of the following:

Tip

•

Click the Open button in the activity toolbar or select Activities > Open Activity. The Openable
Activities dialog box lists all activities that can be opened, including the name of the activity, its
state, and the username of the person who created the activity. Select the activity you want to open
and click OK.

•

Select Tools > Activity Manager. From the Activity Manager window, select the activity you want
to open and click Open.

In non-Workflow mode, your previous configuration session is opened whenever needed until you
submit it. A new activity is then created the next time you perform an action that requires an activity.
Related Topics
•

Understanding Activities, page 4-1

Closing an Activity (Workflow Mode)
You can close an activity without approving it (or submitting it for approval) if you or others want to
continue configuring policies at a later time.
A person with administrator privileges can close an activity opened by another user.
To close an open activity, do one of the following:

Tip

•

Click the Close button in the activity toolbar.

•

Select Activities > Close Activity.

•

Select Tools > Activity Manager. From the Activity Manager window, click Close.

In non-Workflow mode, your configuration session is closed whenever you log out. The same session is
reopened the next time you log in.
Related Topics
•

Understanding Activities, page 4-1

Viewing Change Reports (All Modes)
There are many places in the interface where you can open activity change reports. Typically, the button
or command to generate the report is View Changes. These change reports provide detailed information
about the policy and policy object changes, and the devices that were acted on, that have been made in
an activity, whether you are operating in Workflow or non-Workflow mode.
The activity change report is in Adobe Acrobat (PDF) format. You can use all of the Acrobat features,
including the bookmarks tab, to view the report.
If you discover a device or rediscover policies on a device, then subsequent policy changes in the same
activity performed on that device are not listed in the activity change report. This is also true on a device
that you clone from another device.

User Guide for Cisco Security Manager 4.0.1

4-12

OL-23439-01

Chapter 4

Managing Activities
Working with Activities

Following are some of the ways you can view change reports:
Non-Workflow mode:

•

– Select File > View Changes to view the changes made during the current configuration session.
– Select Tools > Change Reports to view the changes made during previous sessions (which are

closed when you submit or discard your changes). Select a configuration session from the
Change Report window and click View Changes. (See Selecting a Change Report in
Non-Workflow Mode, page 4-14.)
Workflow mode:

•

– Select Activities > View Changes, or click the View Changes button in the toolbar, to view the

changes made during the currently open activity.
– Highlight an activity in the Activity Manager window and click View Changes to view the

changes made in that activity.
In both modes, you can view changes from various dialog boxes when creating deployment jobs.

•

Note

You must disable any popup-blocker applications you have running to ensure the activity report will
open.
Figure 4-3 shows a sample activity report.
Figure 4-3

Activity Report
Activity Change Report
User:
Session started on:
Current state:
Report created on:

celia
26-Oct-2006 00:49:16
Edit Open
26-Oct-2006 18:14:22

Devices
router2600
Policy Objects Override
InterfaceRole
Category ID

Operation
Add

None

Name Patterns

Comment

Ethernet1 , Dialer0 , Serial0 , External interfaces
Async1 , Serial0/0 , Outside

Patterns

Name

Ethernet1 , Dialer0 , Serial0 , External
Async1 , Serial0/0 , Outside ,
Ethernet1 , Dialer0 , Serial0 ,
Async1 , Serial0/0 , Outside

Shared Policies
No changes
Ike
Category ID

Operation
Add

None

Dh Group
1

Lifetime
86400

Priority
-1

Hash
SHA

Encryption
aes-128

Authentication
Preshared Key

Name
New IKE Proposal

191242

Policy Objects

The activity report includes these elements:
•

Activity name—The name of the activity (or the user and session start date and time if it is
unnamed).

•

Created by—The username of the person who created the activity, with the date and time.

•

Current state—The current state of the activity.

•

Report created on—The date and time the report was created.

•

Devices section—A summary of the devices that were acted on in the activity (that is, they were
added, modified, or deleted). Changes to local policies are displayed here.
Changes in this section and the other sections of the report are color-coded to help you identify
changes:
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– Green—Indicates a newly inserted item.
– Red—Indicates a deleted item or the old value of a changed item.
– Blue—Indicates the new value of a changed item.
•

Shared Policies section—Changes to all shared policies are displayed here.

•

Policy Objects—Changes to all policy objects are displayed here.

Selecting a Change Report in Non-Workflow Mode
In non-Workflow mode, you can view change reports for closed configuration sessions by selecting
Tools > Change Reports and then selecting the session in the Change Report dialog box.
In non-Workflow mode, a configuration session is considered complete when you either submit or
discard your changes. The Change Report dialog box lists all closed sessions, showing the date and time
the session was closed, the action that closed it (submitted or discarded), and the user name associated
with the session. These sessions are equivalent to activities in Workflow mode. Select a session and click
View Changes to view the report. For information on reading the report, see Viewing Change Reports
(All Modes), page 4-12.

Tip

To view the report for the current configuration session, close this dialog box and select File > View
Changes.

Validating an Activity (All Modes)
In Workflow mode, Security Manager validates activities when you submit them for approval, or you can
validate an activity at any time while you are creating and changing policies in an activity. After an
activity is submitted, the validation report remains static.
In non-Workflow mode, Security Manager validates policies when you submit them to the database,
when you try to deploy them, or when you validate them. The validation process reports on policy
changes that were made up until the changes are saved or deployed.
The validation process checks the following areas. If there are errors, you can display a detailed
summary of the validation results.
•

Policy integrity—There are no unresolvable references (for example, missing objects, unresolved
interface roles, overrides of mandatory settings, and so on).

•

Policy deployability—The platform, operating system, and configured features are supported by the
target devices so that policies can be correctly translated into CLI commands.
If a policy contains options that require specific device types or operation system versions, you will
see validation warnings for non-supported devices, but Security Manager will not generate the
associated commands for unsupported devices. This allows you to create policies that apply to a
wide range of devices without having to create policies that are too device-specific.

•

FlexConfig integrity—There are no corrupted FlexConfig objects. If corrupted objects are found, a
warning with a list of the corrupted FlexConfig objects results.

•

FlexConfig syntax—If syntax errors are found, a warning with a list of affected FlexConfigs and
their syntax errors results.

•

FlexConfig object references—All object references are resolvable. If FlexConfig objects reference
non-existent objects, a warning with a list of the missing objects results.
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Related Topics

Step 1

•

Submitting an Activity for Approval (Workflow Mode with Activity Approver), page 4-15

•

Deploying Configurations in Non-Workflow Mode, page 8-27

Do one of the following:
•

In Workflow mode:
– Open an activity, and then click the Validate button on the activity toolbar or select Activities

> Validate Activity.
– Select Tools > Activity Manager. From the Activity Manager window, select an activity, and

then click Validate.
•

In non-Workflow mode, select File > Validate, or try to preview or deploy policies.

Security Manager performs the validation and opens an informational message dialog box that
summarizes the validation results. If there are no errors, validation passes. If there are errors or warnings,
click Details to open the Validation dialog box, where you can view detailed information about the
errors.
Step 2

Evaluate the errors to determine how to fix them.
The Validation dialog box organizes the errors and warnings in two ways, which are displayed on
separate tabs:
•

Errors tab—The Errors tab organizes validation problems based on the type of error. Each error
indicates the number of devices that are affected and the severity of the error.
Select an error in the upper pane, and a list of devices (with the type of device) that have the error
appears in the lower left pane. The lower right pane describes the error, its cause, and what you
might do to fix it.

•

Devices tab—The Devices tab organizes validation problems based on the device. Each device
indicates the number and types of errors and warnings for the device, and the device type. The device
status indicates the worst problem in the device configuration (error or warning).
Select a device in the upper pane, and a list of the errors for that device appears in the lower left
pane. Select an error and the lower right pane describes the error, its cause, and what you might do
to fix it.

You must correct errors before submitting the activity. Security Manager does not allow an activity to be
submitted with validation errors.

Note

A validation warning (as opposed to an error) will not prevent activity approval or deployment.

Submitting an Activity for Approval (Workflow Mode with Activity Approver)
In Workflow mode with an activity approver, you must submit activities for approval. When you submit
the activity, the integrity and deployability of the activity is validated. For details about the validation
process and report, see Validating an Activity (All Modes), page 4-14.
The activity is also closed so that it can be opened by the user who has the permissions to approve it.
When the activity is approved, its configurations are committed to the Security Manager database, and
they can be deployed to the devices.
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When you submit an activity, Security Manager sends an e-mail to the relevant approvers to notify them
that an activity requires approval.
If you are working in Workflow mode without an activity approver, you do not need to submit activities
(in fact, you cannot submit them). You can approve the activity yourself. For more information about
changing activity approval settings, and configuring the e-mail addresses for notifications, see Workflow
Page, page 11-40.
Related Topics

Step 1

•

Understanding Activities, page 4-1

•

Opening an Activity (Workflow Mode), page 4-11

•

Understanding Activity States, page 4-4

•

Configuring an SMTP Server and Default Addresses for E-Mail Notifications, page 1-19

Do one of the following:
•

Open an activity and click the Submit Activity button on the activity toolbar or select Activities >
Submit Activity.

•

Select Tools > Activity Manager. From the Activity Manager window, select an activity, then click
Submit.

The Submit Activity dialog box opens.
Step 2

In the Submit Activity dialog box, fill in the following fields:
•

Approver—Enter the e-mail address of the person who should approve the activity if the default
address is not the right one. This person receives notification of your submission.
The default e-mail address is set in Tools > Security Manager Administration > Workflow.

•

Comment—Enter comments that will help the approver evaluate the activity.

•

Submitter—Enter the e-mail address of the person submitting the approval request if the default
address is not the right one. The field initially contains the e-mail address associated with the
username you used to log into Security Manager. Notifications of activity state changes are sent to
this address.

If desired, you can click the View Changes button to view a report in PDF format of the changes made
in the activity. For more information, see Viewing Change Reports (All Modes), page 4-12.
Step 3

Click OK. The activity status changes to Submitted in the Activity Manager window and notifications
are sent.

Note

Security Manager warns you if the e-mail cannot be sent and you must contact the approver
directly.

Approving or Rejecting an Activity (Workflow Mode)
Before the changes in an activity are committed to the database, you must approve the activity. If you
have activity approval permissions, you can open an activity, review the policies and policy assignments,
and then either approve or reject the activity.
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If you are operating in Workflow mode without an approver, you can approve your own activities. When
working without an approver, you cannot reject an activity, but you can discard it if you do not want to
save your changes. In non-Workflow mode, you use the Submit and Discard commands on the file menu
to submit (and automatically approve) or discard the configuration session.
In Workflow mode with an activity approver, the activity must be submitted before you can open it and
approve it. In this mode, you can also reject the activity.
If you approve an activity, policies and policy assignments are committed to the database and are ready
to be deployed to devices or files. Devices associated with the activity are unlocked, meaning they can
be included in policy definitions and changes in other activities.
If you reject the activity, it is returned to the Edit state and the submitter can reopen the activity to make
the necessary changes and resubmit it for approval. Devices associated with the activity are not
unlocked, meaning that they cannot be included in policy definitions or changes in another activity.

Note

After an activity is approved, changes cannot be undone. You must create a new activity and manually
change policies and policy assignments to the desired state.
Related Topics

Step 1

•

Understanding Activities, page 4-1

•

Opening an Activity (Workflow Mode), page 4-11

•

Understanding Activity States, page 4-4

Do one of the following:
•

Open an activity and click the Approve Activity or Reject Activity button, as appropriate, on the
activity toolbar.

•

Open an activity and select Activities > Approve Activity or Activities > Reject Activity, as
appropriate.

•

Select Tools > Activity Manager. In the Activity Manager window, select an activity and click
Approve or Reject, as appropriate.

The Approve Activity or Reject Activity dialog box appears.
Step 2

In the Comment field, enter a brief explanation of why you are approving or rejecting the activity. If you
are rejecting the activity, you might want to include suggested revisions.

Step 3

Click OK. The activity status changes to Approved or Edit (if rejected) in the Activity Manager window.
For a description of the elements in the window, see Activity Manager Window, page 4-8.

Discarding an Activity (All Modes)
You can discard an activity (configuration session in non-Workflow mode) if it is no longer required.
When you discard an activity, you delete all the policies and policy assignments that were defined within
the activity. Those policies and policy assignments are not in the database; therefore, they cannot be
deployed.
Discarded activities are removed from the system according to the settings defined in the Security
Manager settings for Workflow and devices associated with the activity are unlocked, meaning they can
be used by other activities. For more information, see Workflow Page, page 11-40.
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To discard an activity:
•

Workflow Mode—Do one of the following:
– Open an activity, then click the Discard button on the activity toolbar or select Activities >

Discard Activity.
– Select Tools > Activity Manager. From the Activity Manager window, select an activity, then

click Discard. Only an activity in the Edit or Edit Open state can be discarded.
Using either method, you are prompted with the Discard Activity dialog box, which allows you to
enter an optional comment to explain why you are discarding the activity. Enter a comment and click
OK to discard it.
•

Non-Workflow Mode—Select File > Discard to discard the changes in the current configuration
session.

Related Topics
•

Understanding Activities, page 4-1

•

Opening an Activity (Workflow Mode), page 4-11

•

Understanding Activity States, page 4-4

Viewing Activity Status and History (Workflow Mode)
In Workflow mode, you can view the status and history of changes for activities in the Activity Manager
window.
To open the window, click the Activity Manager button in the toolbar or select Tools > Activity
Manager.
The upper pane lists all available activities, including the current state of the activity. Select an activity
to see additional information in the tabs in the lower pane:
•

Details tab—Shows the date and time the activity was created, and its description.

•

History tab—Shows the transaction history for the activity. Each time the activity state is changed,
a record of the change is kept, including the user who made the change and any comments about the
change.

Related Topics
•

Understanding Activities, page 4-1

•

Activity Manager Window, page 4-8
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