Upgrading Cisco ONS 15600 Release 1.x to R5.0
This chapter explains how to upgrade the Cisco ONS 15600 Cisco Transport Controller (CTC) software
from Software Release 1.x to Software R5.0 using the Timing and Shelf Controller (TSC) card. The
ONS 15600 supports errorless upgrades.

Before You Begin
Before beginning, write down the following information about your site: date, street address, site phone
number, and dial-up number. This data will be useful during and after the upgrade.

Caution

Read each procedure before you begin the upgrade.

Caution

This document supports upgrades from Release 1.1.x or 1.3.x to 5.0. You cannot upgrade from
Release 1.4 to 5.0.

Caution

Upgrading to Release 5.0 requires replacement of the Core Cross-Connect (CXC) cards in your nodes
with Single Shelf Cross-Connect (SSXC) cards during the upgrade procedure. You must be physically
present during the upgrade to perform this card upgrade task.

Note

Perform the procedures in this chapter in consecutive order unless otherwise noted. In general, you are
not done with a procedure until you have completed it for each node that you are upgrading, and you are
not done with the upgrade until you have completed each procedure that applies to your network. If you
are new to upgrading the ONS 15600, you might want to check off each procedure on your printed copy
of this document as you complete it.
This section lists the document procedures (NTPs). Turn to a procedure for applicable tasks (DLPs).
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Before You Begin

Each non-trouble procedure (NTP) is a list of steps designed to accomplish a specific task. Follow the
steps until the task is complete. For a crafts person requiring more detailed instructions, refer to the
Detailed Level Procedure (DLP) specified in the procedure steps.
The detailed level procedure (DLP) supplies additional task details to support the NTP. The DLP lists
numbered steps that lead the crafts person through completion of a task. Some steps require that
equipment indications be checked for verification. When the proper response is not obtained, a trouble
clearing reference is provided.
The following NTPs are in this document:
1.

NTP-U118 Prepare for the Release 1.x to Release 5.0 Upgrade, page 2—This procedure contains
critical information and tasks that you must read and complete before beginning the upgrade
process.

2.

NTP-U119 Back Up the Software R1.x Database, page 4—Complete the database backup to ensure
that you have preserved your node and network provisioning in the event that you need to restore
them.

3.

NTP-U120 Upgrade Software R1.x to Software R5.0, page 5—You must complete this entire
procedure to complete the upgrade.

4.

NTP-U121 Restore the Previous Software Load and Database, page 17—Complete this procedure if
you need to return to Software R1.x.

NTP-U118 Prepare for the Release 1.x to Release 5.0 Upgrade
Purpose

This procedure steps you through the critical information checks and tasks
you must complete before beginning an upgrade.

Tools/Equipment

PC or UNIX workstation; Cisco ONS 15600 Software Release 5.0 (CD or
soft copy)

Prerequisite Procedures None
Required/As Needed

Required

Onsite/Remote

Onsite or remote

Security Level

Superuser

Step 1

Read the Release Notes for Cisco ONS 15600 Release 5.0.

Step 2

Log into the node that you will upgrade. For detailed instructions, refer to the Cisco ONS 15600
Procedure Guide.

Step 3

Complete the “DLP-U185 Verify CTC Workstation Requirements” task on page 3.

Step 4

Disable all other Ethernet devices (such as a dial-up adapter) on the workstation that runs CTC. For
instructions, contact the Cisco Technical Assistance Center (TAC).
If you have multiple IP addresses on your workstation, you should remove them; you cannot run
Software R5.0 if multiple IP addresses are configured.

Step 5

If you have multiple ONS 15600 nodes configured in the same IP subnet, ensure that only one is
connected to a router. Otherwise, the remaining nodes might be unreachable. Refer to the
Cisco ONS 15600 Reference Manual for LAN-connection suggestions.

Step 6

Verify that TSC cards are installed in Slots 5 and 10 and that the TSC in Slot 10 is active.

Step 7

Complete the “NTP-U119 Back Up the Software R1.x Database” task on page 4.
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Stop. You have completed this procedure.

DLP-U185 Verify CTC Workstation Requirements
Purpose

This task verifies that all PC or UNIX workstation hardware and software
requirements are met.

Tools/Equipment

PC or UNIX workstation

Prerequisite Procedures None

Step 1

Step 2

Step 3

Step 4

Required/As Needed

Required

Onsite/Remote

Onsite or remote (but in the presence of the workstation)

Security Level

Superuser

Ensure that your workstation is either one of the following:
•

IBM-compatible PC with a Pentium or higher processor, CD-ROM drive, and 128 MB RAM running
Windows 95, Windows 98, Windows 2000, or Windows NT

•

UNIX workstation running any Solaris release

Ensure that your web browser software is one of the following:
•

Netscape Navigator 7.0 or higher (Netscape Navigator 7.0 is included on the ONS 15454 software
CD shipped with the node)

•

Internet Explorer 6.x or higher

Verify that the Java Version installed on your computer is Java Runtime Environment (JRE) Release
1.3.1_02.

Tip

You can check the JRE version in your browser window after entering the node IP address in the
URL window under Java Version.

Note

You will upgrade the JRE version to JRE 1.4.2, and Java Plug-in 1.4.2 at the end of the activation
task. Release 5.0 requires JRE 1.4.2, and Java Plug-in 1.4.2, which are supplied on the software
CD.

Verify that the Java Policy file is installed on your computer.

Note

Step 5

For important information on CTC backward compatibility affected by your choice of JRE
versions, see the Readme.txt or Readme.html file on the software CD.

Return to your originating procedure (NTP).

Upgrading Cisco ONS 15600 Release 1.x to R5.0
OL-5484-01

3

DLP- U185 Verify CTC Workstation Requirements

NTP-U119 Back Up the Software R1.x Database
Purpose

This procedure preserves all configuration data for your network before
performing the upgrade.

Tools/Equipment

PC or UNIX workstation

Prerequisite Procedures NTP-U118 Prepare for the Release 1.x to Release 5.0 Upgrade, page 2

Note

Required/As Needed

Required

Onsite/Remote

Onsite or remote (but in the presence of the workstation)

Security Level

Superuser

To restore a software database, a backup file of that database must be available.

Step 1

Log into CTC. For detailed instructions, refer to the Cisco ONS 15600 Procedure Guide. If you are
already logged in, continue with Step 2.

Step 2

In node view, click the Maintenance > Database tabs.

Step 3

Click Backup.

Step 4

In the Database backup dialog box, click Browse.

Step 5

In the Save dialog box, navigate to a local PC directory or network directory and type a database name
(such as database.db) in the File name field.

Step 6

Click Save.

Step 7

If you are overwriting an existing file, click Yes in the confirmation dialog box.

Step 8

In the Database backup dialog box, check the Alarms, Performance, and/or Audit check boxes to
choose these database items in addition to provisioning information.

Note

Provisioning is a default component of the backup file.

Step 9

Click OK.

Step 10

Repeat Steps 1 through 9 for each node in the network.

Step 11

(Optional) Cisco recommends that you manually log critical information by either writing it down or
printing screens where applicable. Use Table 1 to determine the information you should log; complete
the table (or your own version) for every node in the network.
Table 1

Manually Logged Data

Item

Record Data Here (If Applicable)

IP address of the node
Node name
Timing settings
DCC connections; list all optical ports that have DCCs activated
User IDs (List all, including at least one super user)
Inventory; do a print screen from the inventory window
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Table 1

Manually Logged Data (Continued)

Item

Record Data Here (If Applicable)

Active TSC

Slot 5 or Slot 10 (circle one)

Note

The TSC card in Slot 10 must be the active TSC card for
an upgrade.

CXC preferred copy

Slot 6/7 or Slot 8/9 (circle one)

Network information; do a print screen from the Provisioning tab
in the network view.
Current configuration: UPSR, linear, etc. Do print screens as
needed.
List all protection groups in the system; do a print screen from
the Protection Group window.
List alarms; do a print screen from the Alarm window.
List circuits; do a print screen from the Circuit window.
Stop. You have completed this procedure.

NTP-U120 Upgrade Software R1.x to Software R5.0
Purpose

This procedure upgrades your software to Software R5.0.

Tools/Equipment

PC or UNIX workstation; Cisco ONS 15600 Software Release 5.0 (CD or
soft copy)

Prerequisite Procedures NTP-U119 Back Up the Software R1.x Database, page 4
Required/As Needed

Required

Onsite/Remote

Onsite or remote (but in the presence of the workstation)

Security Level

Superuser

Caution

Executing an upgrade with a single TSC card is traffic affecting. Do not start an upgrade unless both
TSC cards are present and alarm free.

Note

To upgrade the software successfully, read and perform each task that applies to your network in the
proper order.

Note

The UPGRADE, SFTWDOWN, and SW-VER alarms are raised during the upgrade process. These
alarms are normal and will clear when the download is complete.

Step 1

Insert the Software R5.0 CD into the workstation CD-ROM (or otherwise acquire access to the software)
to begin the upgrade process.
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Note

Inserting the software CD activates the CTC Setup Wizard. You can use the setup wizard to
install components or click Cancel to continue with the upgrade.

Step 2

Log into the node that you want to upgrade. For detailed instructions, refer to the Cisco ONS 15600
Procedure Guide. If you are already logged in, continue with Step 3.

Step 3

(BLSR nodes only) Complete the “DLP-U187 Perform a Software R1.x BLSR Lockout” task on page 7.

Note

The bidirectional line switched ring (BLSR) lockout must be completed for all nodes in all rings
for which the ONS 15600 is provisioned.

Step 4

Complete the “DLP-U186 Download the Software” task on page 8.

Step 5

Complete the “DLP-U188 Activate the New Load” task on page 10.

Step 6

(As needed) Complete the “DLP-U91 Delete Cached JAR Files” task on page 12.

Note

The “DLP-U91 Delete Cached JAR Files” task on page 12 is provided in case you have trouble
logging back into a node after the activation. This task is not generally necessary.

Step 7

Reconnect to the node using CTC. The new CTC applet for Software R5.0 uploads.

Step 8

During the CTC login, complete the “DLP-U92 Install the Public-Key Security Certificate” task on
page 13.

Note

Step 9

Release 5.0 raises an “EQPT-IMPR-XC” alarm while any CXC cards are installed. This alarm
will clear after you replace the CXC cards with SSXC cards in Step 10.

Complete the “DLP-U189 Accept the New Load” task on page 14.

Note

After you have accepted the Software R5.0 build, you cannot revert to Software R1.x without
downloading Software R1.x again and restoring the R1.x database.

Step 10

Complete the “DLP-U190 Upgrade the CXC Card to the SSXC Card” task on page 15.

Step 11

Repeat Steps 5 through 10 for all nodes in the network that need to be upgraded. Allow each node to
finish. All alarms should be cleared for 10 minutes before activating the next node.

Note

Only activate one node at a time.

Step 12

Complete the “DLP-U127 Remove the BLSR Lockout” task on page 16 for all BLSR nodes in the
network.

Step 13

Complete the “DLP-U94 Set the Date and Time” task on page 17 for any nodes that are not using Simple
Network Time Protocol (SNTP).

Step 14

As needed, upgrade any spare TSC cards by installing the spare in the standby slot of a Software R5.0
node.
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Note

When you insert a spare TSC card in the standby slot, a software mismatch is raised. The
working software on the active TSC card is then copied to the standby TSC, causing the standby
TSC card to reset. When the standby TSC card reset completes, the standby TSC is running the
same software version as the active TSC card.

Stop. You have completed this procedure.

DLP-U187 Perform a Software R1.x BLSR Lockout
Purpose

If you have a BLSR provisioned, before beginning the upgrade you must
perform a span lockout at each node in the ring.

Tools/Equipment

PC or UNIX workstation, Software R5.0 files

Prerequisite Procedures NTP-U119 Back Up the Software R1.x Database, page 4
Required/As Needed

Required for BLSR only

Onsite/Remote

Onsite or remote (but in the presence of the workstation)

Security Level

Superuser

Note

During the lockout, BLSR spans are not protected. You must leave the BLSR in the lockout state until
you have finished activating all nodes in the ring, but you must be sure to remove the lockout after you
have finished activating.

Note

To prevent ring or span switching, perform the lockout on both the east and west spans of each node.

Step 1

In node view, click the Maintenance > BLSR tabs.

Step 2

For each of the BLSR trunk (span) cards (OC-48, OC-192), perform the following steps:

Note

a.

Next to the trunk card row, click the East Switch column to show the drop-down list.

b.

From the menu options, choose Lockout Span.

c.

Click Apply.

d.

In the same row, click the West Switch column to show the drop-down list.

e.

From the menu options, choose Lockout Span.

f.

Click Apply.

Ignore any Default K alarms that occur on the protect STS time slots during this lockout period.
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Note

Step 3

Certain BLSR or Multiservice Switching Platform (MSSP)-related alarms might be raised following
activation of the first node in the ring. The following alarms, if raised, are normal and should not cause
concern. They clear upon completion of the upgrade, after all nodes have been activated.
•

BLSROSYNC (MN)

•

RING-MISMATCH (MJ)

•

APSCDFLTK (MN)

•

BLSR-RESYNC (NA)

Return to your originating procedure (NTP).

DLP-U186 Download the Software
Purpose

This task downloads the software to the ONS 15600 nodes.

Tools/Equipment

PC or UNIX workstation

Prerequisite Procedures NTP-U119 Back Up the Software R1.x Database, page 4

Note

Required/As Needed

Required

Onsite/Remote

Onsite or remote (but in the presence of the workstation)

Security Level

Superuser

The download task does not affect traffic because the active software continues to run at the primary
RAM location; therefore, you can download the software at any time.

Step 1

From the View menu, choose Go To Network View.

Step 2

Verify that the alarm filter is not on:
a.

Click the Alarms tab.

b.

Click the Filter tool at the lower-right side of the bottom toolbar.
Alarm filtering is enabled if the tool is selected and disabled if the tool is raised (not selected).

Step 3

On the Alarms tab, check all nodes for existing alarms. Resolve any outstanding alarms before
proceeding. If necessary, refer to the Cisco ONS 15600 Troubleshooting Guide.

Step 4

From the View menu, choose Go to Home View.

Step 5

Verify that the TSC card in Slot 10 is the active card. If it is not, complete the following:
a.

Right-click the TSC in Slot 5 and choose Soft-reset Card.

b.

Click Yes in the confirmation dialog box.

c.

Click OK in the Connection Lost dialog box.

Note

The TSC card takes several minutes to reboot.
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Step 6

Double-click the node icon to return to node view.

Step 7

Click the Maintenance > Software tabs.

Step 8

Click Download. The Download Selection dialog box appears.

Step 9

Click Browse.

Step 10

In the Open dialog box, navigate to the software package files on the ONS 15600 software CD or on your
hard drive, if you are working from a local copy.

Step 11

Select the file with the .pkg extension and click Open.

Step 12

In the Download Selection dialog box, verify that the node is checked.

Step 13

Click OK. The software begins downloading to the active TSC card. The Download Status column on
the Maintenance > Software tab shows the percentages complete:
1.

Downloading (approximately 7 to 10 minutes)

2.

Qualifying (approximately 1 to 2 minutes)

3.

Copying to stby TSC (approximately 2 to 5 minutes)

When the Download Status column is empty, the software has finished loading.
Step 14

Verify the version:
a.

Click Info.

b.

In the Current Software Info dialog box, verify that the TSC B Working field shows 1.x and the TSC
B Protect field shows 5.0.

c.

Click OK.

Note

Step 15

Repeat Steps 1 through 14 for each node.

Note
Step 16

You can also verify the load information on the Maintenance > Software tab. The Working
Version column shows the original software load and the Protect Version column shows the
software load that you just downloaded.

The software download process can take 15 minutes or more per node.

Return to your originating procedure (NTP).
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DLP-U188 Activate the New Load
Purpose

This task activates Software R5.0 in each node in the network. Activating
the software load downloads the software to the standby TSC.

Tools/Equipment

PC or UNIX workstation

Prerequisite Procedures NTP-U119 Back Up the Software R1.x Database, page 4
DLP-U186 Download the Software, page 8

Note

Caution

Required/As Needed

Required

Onsite/Remote

Onsite or remote (but in the presence of the workstation)

Security Level

Superuser

Although the activate task is not service affecting, Cisco recommends that you activate the new load
during a maintenance window.

Do not perform maintenance or provisioning activities during the activation task.

Note

For BLSRs only, a non-service affecting APS-CHAN-FAILURE alarm is raised on each of the nodes
joined to an activating node in the ring during activation. Once the activation completes for that node,
the alarms will clear.

Note

Cisco recommends that the first node you activate be a LAN-connected node. This ensures that the new
CTC JAR files will download to your workstation as quickly as possible.

Step 1

In node view, click the Maintenance > Software tabs.

Step 2

Verify the version:
a.

Click Info.

b.

In the Current Software Info dialog box, verify that the TSC B Working shows R1.x and the TSC B
Protect shows R5.0.

c.

Click OK.

Step 3

Click Activate. The Activate dialog box appears with a warning message indicating that you should
perform a database backup.

Step 4

Complete one of the following:
•

If you have not backed up the Software R1.x database, click No. Complete the “NTP-U119 Back Up
the Software R1.x Database” procedure on page 4. When you have completed the procedure, return
to Step 3 in this task.

•

If you have backed up the Software R1.x database, click Yes to proceed with the activation. The
Download Status column shows:
– The Qualifying percentage completed (approximately 1 to 2 minutes).
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– The status “Wait” while the standby TSC reboots (approximately 2 to 5 minutes). When the

standby TSC completes the reboot, it is still in standby but is now running Software R5.0. The
active TSC in Slot 10 is still active and is running Software R1.x.
– The Acquiring percentage completed as the standby TSC acquires the active timing reference

(approximately 10 to 15 minutes).
Step 5

Click OK when the Rebooting message appears indicating that the software is successfully activated.
The node reboot could take up to four minutes.

Step 6

Click OK in the Connection Lost dialog box.

Note
Step 7

CTC loses connection to the node while the node reboots and displays the network view.

After activating the node, wait until the software upgrade reboot finishes at that node before continuing.
The node will remain gray for the remainder of this task. The upgrade process can take up to 30 minutes,
depending on how many cards are installed. The following occurs:
•

When the active TSC card in Slot 10 reboots, the TSC card in Slot 5 becomes active, using
Software R5.0 as the working copy. When the TSC card in Slot 10 resets, it is in standby mode and
is still running Software R1.x. All remaining cards in the shelf reset simultaneously.

•

A system reboot (SYSBOOT) alarm is raised briefly while activation is in progress. When all cards
have reset, this alarm clears.

When all of the cards finish rebooting and all of the alarms clear, you can safely proceed to the next step.
Step 8

In CTC, choose File > Exit.

Step 9

In your browser window, click the Delete CTC Cache button.

Note

You must ensure that CTC is closed before clicking the Delete CTC Cache button. CTC behavior
is unreliable if the button is clicked while the software is still running.

Note

It might also be necessary to delete cached files from your browser’s directory, or from the temp
directory on your MS Windows workstation. If you have trouble reconnecting to CTC, complete
the “DLP-U91 Delete Cached JAR Files” task on page 12.

Step 10

Close your browser.

Step 11

Install the new JRE version and (optionally) run the Cache Loader pre-caching utility:

Note

Cisco recommends you run the optional Cache Loader pre-caching utility during this step, prior
to activating the node. This ensures that the new CTC JAR files download to your workstation
as quickly as possible.

a.

In your Windows environment, choose Start > Settings > Control Panel, and click Add/Remove
Programs.

b.

Scroll the list of programs until you see the Java 2 Runtime Environment, then click
Change/Remove.
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c.

Click Yes in the dialog box to proceed with removing the old JRE version.

a.

Load the Release 5.0 CD into your CD-ROM drive. If the directory of the CD does not open
automatically, open it.

b.

Double-click the setup.exe file to run the Installation Wizard. The CTC installation wizard dialog
box opens.

c.

Click Next. The setup options dialog box opens.

d.

Choose Custom, and click Next. The custom options dialog box appears.

e.

Select Cisco Transport Controller, Java Runtime Environment 1.4.2, and (optionally) CTC JAR
files. Deselect any other preselected options.

f.

Click Next. A confirmation box appears.

g.

Click Next again. The (optional) CTC Cache Loader pre-caches the JAR files to your workstation,
displaying a progress status box, and installs the JRE.

h.

When the installation finishes, click OK, and then in the wizard, click Finish.

Step 12

Reopen your browser.

Step 13

Return to your originating procedure (NTP).

DLP-U91 Delete Cached JAR Files
Purpose

This task deletes previously cached files from your browser and hard
drive.

Tools/Equipment

PC or UNIX workstation

Prerequisite Procedures DLP-U188 Activate the New Load, page 10

Step 1

Required/As Needed

Required

Onsite/Remote

Onsite or remote (but in the presence of the workstation)

Security Level

None

Delete cache files from your browser directory.
In Netscape:
a.

Choose Edit > Preferences > Advanced > Cache.

b.

Click Clear Memory Cache.

c.

Click OK.

d.

Click Clear Disk Cache.

e.

Click OK twice.

In Microsoft Internet Explorer:
a.

Choose Tools > Internet Options > General.

b.

Choose Delete Files.

c.

Select the Delete all offline content check box.

d.

Click OK twice.
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Step 2

Close your browser.
You will not be able to delete cached JAR files from your hard drive until you have closed your browser.
If you have other applications open that use JAR files, you must also close them.

Step 3

(Windows systems only) Delete cached files from your workstation.
a.

In your Windows start menu, choose Settings > Control Panel > System > Advanced.

b.

Click Environment Variables. This shows you a list of user variables and a list of system variables.

c.

In the list of user variables, look for the TEMP variable. The value associated with this variable is
the path to your temporary directory where JAR files are stored.

d.

Open the TEMP directory located in the path you just looked up.

e.

Select View > Details.

f.

Select and delete all files with “jar” in the Name or Type field.

Step 4

Reopen your browser. You should now be able to connect to CTC.

Step 5

Return to your originating procedure (NTP).

DLP-U92 Install the Public-Key Security Certificate
Purpose

This task installs the ITU Recommendation X.509 public-key security
certificate. The public-key certificate is required to run Software R5.0 or
later.

Tools/Equipment

None

Prerequisite Procedures DLP-U91 Delete Cached JAR Files, page 12

Caution

Step 1

Required/As Needed

Required

Onsite/Remote

Onsite or remote

Security Level

Provisioning or higher

If you delete the Java policy file, you cannot log into nodes running Software R1.x and earlier. If you
delete the file and want to log into an ONS 15600 running an earlier release, insert the software CD for
the release into your PC CD-ROM and run the CTC setup wizard to reinstall the Java policy file.
If the Java Plug-in Security Warning dialog box appears, choose one of the following options.
•

Grant This Session—Installs the public-key certificate to your PC only for the current session. After
the session is ended, the certificate is deleted. This dialog box will appear the next time you log into
the ONS 15600.

•

Deny—Denies permission to install the certificate. If you choose this option, you cannot log into the
ONS 15600.

•

Grant always—Installs the public-key certificate and does not delete it after the session is over.
Cisco recommends this option.

•

View Certificate—Allows you to view the public-key security certificate.
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Step 2

Step 3

If the Login dialog box appears, continue with Step 3. If the Change Java Policy File dialog box appears,
complete this step. The Change Java Policy File dialog box appears if CTC finds a modified Java policy
file (.java.policy) on your PC. In Software R1.1.x, the Java policy file was modified to allow CTC
software files to be downloaded to your PC. The modified Java policy file is not needed in Software R5.0,
so you can remove it unless you will log into ONS 15600s running Software R1.1.x. Choose one of the
following options:
•

Yes—Removes the modified Java policy file from your PC. Choose this option only if you will log
into ONS 15600s running Software R5.0 or later.

•

No—Does not remove the modified Java policy file from your PC. Choose this option if you will
log into ONS 15600s running Software R1.1.x. If you choose No, this dialog box will appear every
time you log into the ONS 15600. If you do not want it to appear, check the Do not show the
message again check box.

Return to your originating procedure (NTP).

DLP-U189 Accept the New Load
Purpose

This task upgrades the standby TSC.

Tools/Equipment

PC or UNIX workstation

Prerequisite Procedures DLP-U188 Activate the New Load, page 10
Required/As Needed

Required

Onsite/Remote

Onsite or remote (but in the presence of the workstation)

Security Level

Superuser

Step 1

In node view, click the Maintenance > Software tabs.

Step 2

Click Accept. This process takes approximately 2 to 5 minutes.

Step 3

Note

You can reject the new software load by clicking Cancel. The Cancel button resets the active
TSC card in Slot 5. The TSC card in Slot 10 then becomes the active TSC using Software R1.x
as the working copy. After the TSC card in Slot 5 resets, it becomes the standby TSC and begins
using Software R1.x.

Note

If the Cancel button is not active, the standby TSC has not finished acquiring the active timing
reference. The acquire process can take approximately 10 to 15 minutes. When the acquire
process completes, the Cancel button becomes active.

Verify the version:
a.

Click Info.

b.

In the Current Software Info dialog box, verify that the TSC B Working field shows the correct
version. The TSC B Protect field should show the previous version.

c.

If the TSC B Working and TSC B Protect fields show “none,” click OK and click the Info button
again after several minutes. Repeat until the TSC B software versions appear.
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DLP- U190 Upgrade the CXC Card to the SSXC Card

d.
Step 4

Click OK.

Return to your originating procedure (NTP).

DLP-U190 Upgrade the CXC Card to the SSXC Card

Warning

Note

Purpose

This task upgrades the CXC card to the SSXC card. The CXC card
supports Software R1.x. The SSXC card supports Software R5.0.

Tools/Equipment

Two SSXC cards

Prerequisite Procedures

None

Required/As Needed

Required

Onsite/Remote

Onsite

Security Level

Provisioning or higher

Do not reach into a vacant slot or chassis while you install or remove a module or a fan. Exposed
circuitry could constitute an energy hazard.

Card removal raises an improper removal (IMPROPRMVL) alarm, but this clears after the card
replacement is complete.

Step 1

Verify that there are no relevant alarms in the network other than the EQPT-IMPR-XC alarm raised
against any node with CXC cards.

Step 2

In the node view, click the Maintenance > Preferred Copy tabs.

Step 3

View the preferred data copy currently in use (A or B) and verify that all traffic is using that copy (the
“Currently used” data copy field should show the same copy).

Step 4

Physically remove the nonpreferred CXC (for example, if the preferred copy is A, remove CXC B):
a.

Open the card ejectors.

b.

Slide the card out of the slot.

Note
Step 5

Step 6

An UNPROT-SCMTX alarm is reported when you remove the CXC card.

Install a new SSXC card in the shelf:
a.

Open the ejectors on the replacement card.

b.

Slide the replacement card into the slot along the guide rails until it contacts the backplane.

c.

Close the ejectors.

Wait for the new card to boot. (Wait for the service state to change from OOS-AUMA,MT & SWDL to
OOS-MA,MT. The UNPROT-XCMTX alarm will also clear.) This takes approximately one minute.

Note

The MEA (card mismatch) alarm appears because CTC recognizes a mismatch between
cross-connect card types. Disregard this alarm; it clears by the end of the procedure.
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Step 7

On the Maintenance > Preferred Copy tab, select the SSXC you just installed as the new Preferred data
copy and verify that all traffic uses that SSXC copy.

Step 8

Repeat Steps 4 to 7 for the remaining CXC card and new SSXC card.

Step 9

Return to your originating procedure (NTP).

DLP-U127 Remove the BLSR Lockout
Purpose

Release the span lockouts on all BLSR nodes. Complete this task after the
new software load is activated on all nodes.

Tools/Equipment

PC or UNIX workstation

Prerequisite Procedures DLP-U188 Activate the New Load, page 10
Required/As Needed

Required for BLSR

Onsite/Remote

Onsite or remote (but in the presence of the workstation)

Security Level

Superuser

Step 1

In CTC node view, click the Maintenance > BLSR tabs.

Step 2

For each of the BLSR trunk (span) cards (OC-48, or OC-192), perform the following steps:
a.

Next to the trunk card row, click the West Switch column to show the drop-down list.

b.

Choose Clear from the list

c.

Click Apply to activate the command.

Note

When removing a lockout, be sure to apply your changes each time you choose the Clear option.
If you try to select Clear for more than one lockout at a time, you risk traffic loss on the first ring
switch.

d.

In the same row, click the East Switch column to show the drop-down list.

e.

Choose Clear from the list.

f.

Click Apply to activate the command.

Step 3

Repeat this task as many times as necessary to remove all BLSR span lockouts on the upgrade nodes.

Step 4

Return to your originating procedure (NTP).
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DLP-U94 Set the Date and Time
Purpose

This task resets the date and time at each node.

Tools/Equipment

PC or UNIX workstation

Prerequisite Procedures None

Note

Required/As Needed

As needed

Onsite/Remote

Onsite or remote (but in the presence of the workstation)

Security Level

Superuser

If you are not using SNTP, the upgrade procedure can cause the date and time setting to change. If you
are using SNTP, you do not need to perform this task.

Step 1

In node view, click the Provisioning > General tabs.

Step 2

Set the correct date and time, then click Apply.

Step 3

Repeat Steps 1 and 2 for each remaining node.

Step 4

Return to your originating procedure (NTP).

NTP-U121 Restore the Previous Software Load and Database
Purpose

This procedure returns the node to the software and database provisioning
you had before you activated Software R5.0.

Tools/Equipment

PC or UNIX workstation

Prerequisite Procedures NTP-U118 Prepare for the Release 1.x to Release 5.0 Upgrade, page 2
NTP-U119 Back Up the Software R1.x Database, page 4
NTP-U120 Upgrade Software R1.x to Software R5.0, page 5
Required/As Needed

As needed

Onsite/Remote

Onsite or remote (but in the presence of the workstation)

Security Level

Superuser

Note

The tasks to downgrade to a previous load are not a part of the upgrade. They are provided here as a
convenience to those wishing to restore an earlier software load after an upgrade. If you have performed
all necessary procedures up to this point, you have finished the software upgrade.

Note

Before you upgraded to Release 5.0 software, you should have backed up the existing database at all
nodes in the network (using the “NTP-U119 Back Up the Software R1.x Database” procedure on
page 4). Cisco recommends that you record or export all critical information to your hard drive.
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Caution

Note

Step 1

Downgrades are service affecting.

A system-wide soft reset occurs after the database is restored. All line (I/O) and matrix (SSXC) cards
automatically soft reset. Existing traffic can be affected, depending on the circuit provisioning map.
Log into the node. For detailed instructions, refer to the Cisco ONS 15600 Procedure Guide. If you are
already logged in, continue with Step 2.

Note

Step 2

To perform a downgrade from Software R5.0, Software R1.x must have been working at the time
you activated to Software R5.0 on that node. Also, a supported revert restores the node
configuration at the time of the previous activation. Thus, any configuration changes made after
activation will be lost when you revert the software.

(BLSR nodes only) Complete the “DLP-U187 Perform a Software R1.x BLSR Lockout” task on page 7.

Note

The BLSR lockout must be completed for all nodes in all rings for which the ONS 15600 is
provisioned.

Step 3

Complete the “DLP-U191 Downgrade the SSXC Card to the CXC Card” task on page 19.

Step 4

Complete the “DLP-U186 Download the Software” task on page 8.

Step 5

Click Revert. The Database Restore dialog box appears.

Step 6

Click Browse.

Step 7

In the Open dialog box, navigate to a local PC directory or network directory where the database file is
stored and click Open.

Step 8

If alarms and performance were backed up, check the Alarms and Performance check boxes in the
Database Restore dialog box.

Step 9

Click OK.

Step 10

Click Yes in the confirmation dialog box.

Step 11

Wait until the software download finishes. The Download Status column shows:
•

The Qualifying percentage completed (approximately 1 to 2 minutes)

•

The status “Wait” while the standby TSC reboots (approximately 2 to 5 minutes)

•

The Acquiring percentage completed as the standby TSC acquires the active timing reference
(approximately 10 to 15 minutes)

The ONS 15600 then reboots.

Note

When you have upgraded your JRE version to 1.4.2, you will no longer be able to log into nodes
running Releases 1.x until you also downgrade the JRE to 1.3.1. For instructions on uninstalling
one JRE version and installing another, refer to Step 11 of the “DLP-U188 Activate the New
Load” task on page 10.
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Step 12

Complete the “DLP-U127 Remove the BLSR Lockout” task on page 16 for all BLSR nodes in the
network.

Step 13

Complete the “DLP-U189 Accept the New Load” task on page 14.

Step 14

Repeat Steps 1 through 13 for any other nodes you want to downgrade.
Stop. You have completed this procedure.

DLP-U191 Downgrade the SSXC Card to the CXC Card

Warning

Note

Purpose

This task downgrades the SSXC card to the CXC card in the case where
a software revert must be performed from Software R5.0 to
Software R1.x. The SSXC card supports Software R5.0. The CXC card
supports Software R1.x.

Tools/Equipment

Two CXC cards

Prerequisite Procedures

None

Required/As Needed

As needed

Onsite/Remote

Onsite

Security Level

Provisioning or higher

Do not reach into a vacant slot or chassis while you install or remove a module or a fan. Exposed
circuitry could constitute an energy hazard.

Card removal raises an improper removal (IMPROPRMVL) alarm, but this clears after the card
replacement is complete.

Step 1

Verify that there are no relevant alarms in the network.

Step 2

In node view, click the Maintenance > Preferred Copy tabs.

Step 3

View the preferred data copy currently in use (A or B) and verify that all traffic is using that copy (the
“Currently used” data copy field should show the same copy).

Step 4

Physically remove the nonpreferred SSXC (for example, if the preferred copy is A, remove SSXC B):
a.

Open the card ejectors.

b.

Slide the card out of the slot.

Note
Step 5

An UNPROT-SCMTX alarm is reported when you remove the SSXC card.

Install the replacement CXC card in the shelf:
a.

Open the ejectors on the replacement card.

b.

Slide the replacement card into the slot along the guide rails until it contacts the backplane.

c.

Close the ejectors.

Upgrading Cisco ONS 15600 Release 1.x to R5.0
OL-5484-01

19

Related Documentation

Step 6

Wait for the CXC card to boot. (Wait for the service state to change from OOS-AUMA,MT & SWDL to
OOS-MA,MT. The UNPROT-XCMTX alarm will also clear.) This takes approximately one minute.

Note

Step 7

The MEA (card mismatch) alarm appears because CTC recognizes a mismatch between XC card
types. Disregard this alarm; it clears by the end of the procedure.

On the Maintenance > Preferred Copy tab, select the CXC you just installed as the new Preferred data
copy and verify that all traffic uses that CXC copy.

Note

A 2-ms traffic interruption occurs as traffic transfers to the CXC card.

Step 8

Repeat Steps 4 to 7 for the remaining SSXC card and replacement CXC card.

Step 9

Return to your originating procedure (NTP).

Related Documentation
Use this Upgrading Cisco ONS 15600 Release 1.x to R5.0 document in conjunction with the following
publications:
•

Cisco ONS 15600 Procedure Guide
Provides installation, turn up, test, and maintenance procedures

•

Cisco ONS 15600 Reference Manual
Provides technical reference information for SONET/SDH cards, nodes, and networks

•

Cisco ONS 15600 Troubleshooting Guide
Provides a list of alarms and troubleshooting procedures, general troubleshooting information, and
hardware replacement procedures

•

Cisco ONS SONET TL1 Command Guide
Provides a comprehensive list of TL1 commands

•

Release Notes for Cisco ONS 15600 Release 5.0
Provides caveats, closed issues, and new feature and functionality information

Where to Find Safety and Warning Information
For safety and warning information, refer to the Cisco Optical Transport Products Safety and
Compliance Information document that accompanied the product. This publication describes the
international agency compliance and safety information for the Cisco ONS 15600 systems. It also
includes translations of the safety warnings that appear in the ONS 15600 system documentation.

Obtaining Documentation
Cisco documentation and additional literature are available on Cisco.com. Cisco also provides several
ways to obtain technical assistance and other technical resources. These sections explain how to obtain
technical information from Cisco Systems.
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Documentation Feedback

Cisco.com
You can access the most current Cisco documentation at this URL:
http://www.cisco.com/univercd/home/home.htm
You can access the Cisco website at this URL:
http://www.cisco.com
You can access international Cisco websites at this URL:
http://www.cisco.com/public/countries_languages.shtml

Ordering Documentation
You can find instructions for ordering documentation at this URL:
http://www.cisco.com/univercd/cc/td/doc/es_inpck/pdi.htm
You can order Cisco documentation in these ways:
•

Registered Cisco.com users (Cisco direct customers) can order Cisco product documentation from
the Ordering tool:
http://www.cisco.com/en/US/partner/ordering/index.shtml

•

Nonregistered Cisco.com users can order documentation through a local account representative by
calling Cisco Systems Corporate Headquarters (California, USA) at 408 526-7208 or, elsewhere in
North America, by calling 1 800 553-NETS (6387).

Cisco Optical Networking Product Documentation CD-ROM
Optical networking-related documentation, including Cisco ONS 15600 product documentation, is
available in a CD-ROM package that ships with your product. The Optical Networking Product
Documentation CD-ROM is updated periodically and may be more current than printed documentation.

Documentation Feedback
You can send comments about technical documentation to bug-doc@cisco.com.
You can submit comments by using the response card (if present) behind the front cover of your
document or by writing to the following address:
Cisco Systems
Attn: Customer Document Ordering
170 West Tasman Drive
San Jose, CA 95134-9883
We appreciate your comments.
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Obtaining Technical Assistance
For all customers, partners, resellers, and distributors who hold valid Cisco service contracts, Cisco
Technical Support provides 24-hour-a-day, award-winning technical assistance. The Cisco Technical
Support Website on Cisco.com features extensive online support resources. In addition, Cisco Technical
Assistance Center (TAC) engineers provide telephone support. If you do not hold a valid Cisco service
contract, contact your reseller.

Cisco Technical Support Website
The Cisco Technical Support Website provides online documents and tools for troubleshooting and
resolving technical issues with Cisco products and technologies. The website is available 24 hours a day,
365 days a year, at this URL:
http://www.cisco.com/techsupport
Access to all tools on the Cisco Technical Support Website requires a Cisco.com user ID and password.
If you have a valid service contract but do not have a user ID or password, you can register at this URL:
http://tools.cisco.com/RPF/register/register.do

Note

Use the Cisco Product Identification (CPI) tool to locate your product serial number before submitting
a web or phone request for service. You can access the CPI tool from the Cisco Technical Support
Website by clicking the Tools & Resources link under Documentation & Tools. Choose Cisco Product
Identification Tool from the Alphabetical Index drop-down list, or click the Cisco Product
Identification Tool link under Alerts & RMAs. The CPI tool offers three search options: by product ID
or model name; by tree view; or for certain products, by copying and pasting show command output.
Search results show an illustration of your product with the serial number label location highlighted.
Locate the serial number label on your product and record the information before placing a service call.

Submitting a Service Request
Using the online TAC Service Request Tool is the fastest way to open S3 and S4 service requests. (S3
and S4 service requests are those in which your network is minimally impaired or for which you require
product information.) After you describe your situation, the TAC Service Request Tool provides
recommended solutions. If your issue is not resolved using the recommended resources, your service
request is assigned to a Cisco TAC engineer. The TAC Service Request Tool is located at this URL:
http://www.cisco.com/techsupport/servicerequest
For S1 or S2 service requests or if you do not have Internet access, contact the Cisco TAC by telephone.
(S1 or S2 service requests are those in which your production network is down or severely degraded.)
Cisco TAC engineers are assigned immediately to S1 and S2 service requests to help keep your business
operations running smoothly.
To open a service request by telephone, use one of the following numbers:
Asia-Pacific: +61 2 8446 7411 (Australia: 1 800 805 227)
EMEA: +32 2 704 55 55
USA: 1 800 553-2447
For a complete list of Cisco TAC contacts, go to this URL:
http://www.cisco.com/techsupport/contacts
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Definitions of Service Request Severity
To ensure that all service requests are reported in a standard format, Cisco has established severity
definitions.
Severity 1 (S1)—Your network is “down,” or there is a critical impact to your business operations. You
and Cisco will commit all necessary resources around the clock to resolve the situation.
Severity 2 (S2)—Operation of an existing network is severely degraded, or significant aspects of your
business operation are negatively affected by inadequate performance of Cisco products. You and Cisco
will commit full-time resources during normal business hours to resolve the situation.
Severity 3 (S3)—Operational performance of your network is impaired, but most business operations
remain functional. You and Cisco will commit resources during normal business hours to restore service
to satisfactory levels.
Severity 4 (S4)—You require information or assistance with Cisco product capabilities, installation, or
configuration. There is little or no effect on your business operations.

Obtaining Additional Publications and Information
Information about Cisco products, technologies, and network solutions is available from various online
and printed sources.
•

Cisco Marketplace provides a variety of Cisco books, reference guides, and logo merchandise. Visit
Cisco Marketplace, the company store, at this URL:
http://www.cisco.com/go/marketplace/

•

The Cisco Product Catalog describes the networking products offered by Cisco Systems, as well as
ordering and customer support services. Access the Cisco Product Catalog at this URL:
http://cisco.com/univercd/cc/td/doc/pcat/

•

Cisco Press publishes a wide range of general networking, training and certification titles. Both new
and experienced users will benefit from these publications. For current Cisco Press titles and other
information, go to Cisco Press at this URL:
http://www.ciscopress.com

•

Packet magazine is the Cisco Systems technical user magazine for maximizing Internet and
networking investments. Each quarter, Packet delivers coverage of the latest industry trends,
technology breakthroughs, and Cisco products and solutions, as well as network deployment and
troubleshooting tips, configuration examples, customer case studies, certification and training
information, and links to scores of in-depth online resources. You can access Packet magazine at
this URL:
http://www.cisco.com/packet

•

iQ Magazine is the quarterly publication from Cisco Systems designed to help growing companies
learn how they can use technology to increase revenue, streamline their business, and expand
services. The publication identifies the challenges facing these companies and the technologies to
help solve them, using real-world case studies and business strategies to help readers make sound
technology investment decisions. You can access iQ Magazine at this URL:
http://www.cisco.com/go/iqmagazine
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•

Internet Protocol Journal is a quarterly journal published by Cisco Systems for engineering
professionals involved in designing, developing, and operating public and private internets and
intranets. You can access the Internet Protocol Journal at this URL:
http://www.cisco.com/ipj

•

World-class networking training is available from Cisco. You can view current offerings at
this URL:
http://www.cisco.com/en/US/learning/index.html

This document is to be used in conjunction with the documents listed in the “Related Documentation” section.
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