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Manage Alarms
This chapter explains how to view and manage the alarms and conditions on a Cisco ONS 15454 SDH.
Cisco Transport Controller (CTC) detects and reports SDH alarms generated by the Cisco ONS 15454
SDH and the SDH network. You can use CTC to monitor and manage alarms at a card, node (default
login), or network level. You can also view alarm counts on the LCD front panel.

Note

Except where noted, the procedures and tasks in this chapter apply to both DWDM (Software Release
4.5) and non-DWDM (Software R4.1 and earlier) nodes.

Before You Begin
This section lists the chapter procedures (NTPs). Turn to a procedure for applicable tasks (DLPs).
1.

NTP-D195 Document Existing Provisioning, page 9-2—Complete this procedure as needed to print
or export node data.

2.

NTP-D196 View Alarms, History, Events, and Conditions, page 9-5—Complete this procedure as
needed to see alarms and conditions occurring on the node and a complete history of alarm and
condition messages.

3.

NTP-D68 Delete Cleared Alarms from Display, page 9-13—Complete this procedure as needed to
delete cleared alarm information.

4.

NTP-D69 View Alarm-Affected Circuits, page 9-14—Complete this procedure as needed to find
circuits that are affected by a particular alarm or condition.

5.

NTP-D70 View Alarm Counts on the LCD for a Node, Slot, or Port, page 9-16—Complete this
procedure as needed to see a statistical count of alarms that have occurred for a slot or port.

6.

NTP-D71 Create, Download, and Assign Alarm Severity Profiles, page 9-17—Complete this
procedure as needed to change the default severity for certain alarms, assign the new severities to a
port, card, or node, and delete alarm profiles.

7.

NTP-D168 Enable, Modify, or Disable Alarm Severity Filtering, page 9-26—Complete this
procedure as needed to enable, disable, or modify alarm severity filtering in the Conditions, Alarms,
or History screens; you can enable, modify, and disable alarm severity filtering at the node or
network level.

8.

NTP-D72 Suppress and Discontinue Alarm Suppression, page 9-30—As needed, use these tasks to
suppress reported alarms at the port, card, or node level and disable the suppress command to restore
normal alarm reporting.
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NTP-D195 Document Existing Provisioning

NTP-D195 Document Existing Provisioning
Purpose

Use this procedure to print card, node, or network CTC information in
graphical or tabular form on a Windows-provisioned printer, or to export
card, node, or network information as editable delineated text files to
other applications. This procedure is useful for network record keeping
and troubleshooting.

Tools/Equipment

Printer connected to the CTC computer by a direct or network
connection.

Prerequisite Procedures

Chapter 4, “Turn Up Node”

Required/As needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Retrieve

Step 1

Complete the “DLP-D60 Log into CTC” task on page 3-23 at the node where you want to record or save
data. If you are already logged in, go to Step 2.

Step 2

As needed, complete the “DLP-D138 Print CTC Data” task on page 9-2.

Step 3

As needed, complete the “DLP-D139 Export CTC Data” task on page 9-4.
Stop. You have completed this procedure.

DLP-D138 Print CTC Data

Step 1

Purpose

This task prints CTC card, node, or network data in graphical or tabular
form on a Windows-provisioned printer.

Tools/Equipment

Printer connected to the CTC computer by a direct or network
connection.

Prerequisite procedures

DLP-D60 Log into CTC, page 3-23

Required/As needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Retrieve

Click the tab (and subtab, if present) containing the information you want to print. For example, click
the Alarms tab to print Alarms window data.
The print operation is available for all network, node, and card view windows.

Step 2

Click File > Print.

Step 3

In the Print dialog box, click a a printing option (Figure 9-1).
•

Entire Frame—Prints the entire CTC window including the graphical view of the card, node, or
network. This option is available for all windows.
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•

Tabbed View—Prints the lower half of the CTC window containing tabs and data. The printout
includes the selected tab (on top) and the data shown in the tab window. For example, if you print
the History window Tabbed View, you print only history items appearing in the window. This option
is available for all windows.

•

Table Contents—Prints CTC data in table format without graphical representations of shelves,
cards, or tabs. This option is available only for CTC table data, so it does not apply to:
– Provisioning > General, Protection, SNMP, or Timing windows
– Provisioning > Network > General window
– Provisioning > UCP > Node window
– Provisioning > WDM-ANS > Provisioning window (Release 4.5)
– Maintenance > Database, Protection, Diagnostic, or Timing windows
– Maintenance > Cross-Connect > Cards window

The Table Contents option prints all the data contained in a table and the table column headings. For
example, if you print the History window Table Contents view, you print all data included in the
table whether or not items appear in the window.

Tip

When you print using the Tabbed View option, it can be difficult to distinguish whether the
printout applies to the network, node, or card view. To determine the view, compare the tabs on
the printout. The network, node, and card views are identical except that network view does not
contain an Inventory tab or Performance tab.

Figure 9-1

Selecting CTC Data For Print

Step 4

Click OK.

Step 5

In the Windows Print dialog box, click a printer and click OK.

Step 6

Repeat this task for each window that you want to print.

Step 7

Return to your originating procedure (NTP).
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DLP-D139 Export CTC Data
Purpose

This task exports CTC table data as delineated text to view or edit the data
in text editor, word processing, spreadsheet, database management, or web
browser applications.

Tools/Equipment

None

Prerequisite procedures DLP-D60 Log into CTC, page 3-23
Required/As needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Retrieve

Step 1

Click the tab containing the information you want to export (for example, the Alarms tab or the Circuits
tab).

Step 2

Choose Export from the File menu.

Step 3

In the Export dialog box (Figure 9-2), click a data format:
•

As HTML—Saves data as a simple HTML table file without graphics. The file must be viewed or
edited with applications such as Netscape Navigator, Microsoft Internet Explorer, or other
applications capable of opening HTML files.

•

As CSV—Saves the CTC table as comma-separated values (CSV).

•

As TSV—Saves the CTC table as tab-separated values (TSV).

Figure 9-2

Step 4

Selecting CTC Data For Export

If you want to open a file in a text editor or word processor application, procedures may vary; but
typically you can use the File > Open command to display the CTC data, or you can double-click the file
name and choose an application such as Notepad.
Text editor and word processor applications display the data exactly as it is exported, including comma
or tab separators. All applications that open the data files allow you to format the data.

Step 5

If you want to open the file in spreadsheet and database management applications, procedures may vary;
but typically you need to open the application and choose File > Import, then choose a delimited file to
display the data in cells.
Spreadsheet and database management programs also allow you to manage the exported data.

Note

An exported file cannot be opened in CTC.
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The export operation only applies to tabular data, so it is not available for the following CTC tabs and
subtabs:
•

Provisioning > General, Protection, SNMP, or Timing windows

•

Provisioning > Network > General window

•

Provisioning > UCP > Node window

•

Provisioning > WDM-ANS > Provisioning window (Release 4.5)

•

Maintenance > Database, Protection, Diagnostic, or Timing windows

•

Maintenance > Cross-Connect > Cards window

Step 6

Click OK.

Step 7

In the Save dialog box, enter a name in the File name field using one of the following formats:
•

[filename].html—for HTML files

•

[filename].csv—for CSV files

•

[filename].tsv—for TSV files

Step 8

Navigate to a directory where you want to store the file.

Step 9

Click OK.

Step 10

Repeat the task for each window that you want to export.

Step 11

Return to your originating procedure (NTP).

NTP-D196 View Alarms, History, Events, and Conditions
Purpose

Use this procedure to view current or historical alarms and conditions for
a card, a node, or network. This information is useful for monitoring and
troubleshooting hardware and software events.

Tools/Equipment

None

Prerequisite Procedures None
Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Provisioning

Step 1

Complete the “DLP-D60 Log into CTC” task on page 3-23 at the node that contains the alarms you want
to view. If you are already logged in, go to Step 2.

Step 2

In the card, node, or network view, click the Alarms tab to display the alarms for that card, node, or
network (Figure 9-3).
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Figure 9-3

CTC Node View

Table 9-1 lists the columns in the Alarms window and their descriptions.
Table 9-1

Alarm Column Descriptions

Column

Information Recorded

New

Indicates a new alarm; to change this status, click either the Synchronize button or
the Delete Cleared Alarms button

Date

Date and time of the alarm

Node

Node where the alarm occurred (appears only in network view)

Object

The object for an HPmon or LPmon

Eqpt Type

Card type in this slot

Slot

Slot where the alarm occurred (appears only in network and node view)

Port

Port where the alarm is raised. For HPTerm and LPTerm, the port refers to the
upstream card it is partnered with.

Sev

Severity level: CR (critical), MJ (major), MN (minor), NA (not-alarmed), NR
(not-reported)

ST

Status: R (raised), C (clear)

SA

When checked, indicates a service-affecting alarm
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Table 9-1

Alarm Column Descriptions (continued)

Column

Information Recorded

Cond

The error message/alarm name; these names are alphabetically defined in the “Alarm
Troubleshooting” chapter of the Cisco ONS 15454 SDH Troubleshooting Guide

Description

Description of the alarm

Num

An incrementing count of alarm messages

Ref

The reference number assigned to the alarm

Table 9-2 lists the color codes for alarm and condition severities.
Table 9-2

Color Codes for Alarms and Conditions

Color

Description

Red

Raised Critical (CR) alarm

Orange

Raised Major (MJ) alarm

Yellow

Raised Minor (MN) alarm

Magenta (pink) Raised Not-Alarmed (NA) condition
Blue

Raised Not-Reported (NR) condition

White

Cleared (C) alarm or condition

Releases 4.0 and later have additional numbered STM and VC alarm object identifiers based upon the
object IDs.
Table 9-3

Release 4.0 and Later Port-Based Alarm Numbering Scheme

STM and VC Alarm Numbering
MON
object

VC4-<slot>-<port>-<VC within port>

TERM
object

VC4-<slot>-<VC within slot>

Port=1

For example, VC4-6-1-6
Port=1

For example, VC4-6-6

Step 3

If alarms are present, refer to the Cisco ONS 15454 SDH Troubleshooting Guide for information and
troubleshooting procedures.

Step 4

Complete the “DLP-D110 View Alarm History” task on page 9-8, the “DLP-D113 Synchronize Alarms”
task on page 9-11, or the “DLP-D114 View Conditions” task on page 9-11 as needed.
Stop. You have completed this procedure.
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DLP-D110 View Alarm History
Purpose

Use this task to view past cleared and uncleared ONS 15454 SDH alarm
messages at the card, node, or network level. This task is useful for
troubleshooting configuration, traffic, or connectivity issues that are
indicated by alarms.

Tools/Equipment

None

Prerequisite Procedures DLP-D60 Log into CTC, page 3-23
Required/As Needed
Onsite/Remote

As needed

Security Level

Retrieve

Onsite or remote

Step 1

Decide whether you want to view the alarm message history at the node, network, or card level.

Step 2

To view node alarm history:
a.

Click the History > Session tabs to view the alarms and conditions (events) raised during the current
session.

b.

Click the History > Node tabs to retrieve all available alarm messages for the node.

Tip

Step 3

Double-click an alarm in the alarm table or an event (condition) message in the history table to
display the view that corresponds to the alarm message. For example, double-clicking a card
alarm takes you to card view. In network view, double-clicking a node alarm takes you to node
view.

To view network alarm history, from node view:
a.

Click View > Go to Network View.

b.

Click the History tab.

Alarms and conditions (events) raised during the current session appear.
Step 4

To view card alarm history, from network view click View > Go to Previous View to return to the node
view.

Step 5

From node view, double-click a card on the shelf graphic to display the card-level view for the card.

Note

TCC2 and cross-connect cards do not have a card view.

a.

Click the History > Session tabs to view the alarm messages raised during the current session.

b.

Click the History > Card tabs to retrieve all available alarm messages for the card.

Note

Step 6

The ONS 15454 SDH can store up to 640 critical alarm messages, 640 major alarm
messages, 640 minor alarm messages, and 640 condition messages. When any of these limits
is reached, the ONS 15454 SDH discards the oldest events in that category.

To display Not-Alarmed (NA) and transient event (condition) history from the node or card view:
a.

Check the Events check box in the History > Node window or History > Card window.
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b.
Step 7

The window displays raised and cleared alarm messages (and events, if selected).

Tip

Step 8

Click Retrieve.

Double-click an alarm in the alarm table or a condition in the history table to display the view
that corresponds to the alarm message. For example, double-clicking a card alarm takes you to
card view. In network view, double-clicking a node alarm takes you to node view.

Return to your originating procedure (NTP).

DLP-D111 Changing the Maximum Number of Session Entries for Alarm History
Purpose

This task changes the maximum number of session entries included in the
alarm history. Use this task to extend the history list in order to save
information for future reference or troubleshooting.

Tools/Equipment

None

Prerequisite Procedures DLP-D60 Log into CTC, page 3-23

Step 1

Required/As Needed
Onsite/Remote

As needed

Security Level

Provisioning

Onsite or remote

From the Edit menu, choose Preferences.
The CTC Preferences Dialog box appears (Figure 9-4).
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DLP-D112 Display Alarms and Conditions Using Time Zone

CTC Preferences Dialog Box

243477

Figure 9-4

Step 2

Click the up or down arrow buttons next to the Maximum History Entries field to change the entry.

Step 3

Click Apply and OK.

Step 4

Note

Setting the Maximum History Entries value to the high end of the range uses more CTC memory
and could impair CTC performance.

Note

This task changes the maximum history entries recorded for CTC sessions. It does not affect the
maximum number of history entries viewable for a network, node, or card.

Return to your originating procedure (NTP).

DLP-D112 Display Alarms and Conditions Using Time Zone
Purpose

Use this task to change the timestamp for events to the timezone of the
ONS node reporting the alarm. By default, the events timestamp is set to
the timezone for the CTC workstation.

Tools/Equipment

None

Prerequisite Procedures DLP-D60 Log into CTC, page 3-23
Required/As Needed
Onsite/Remote

As needed

Security Level

Provisioning

Onsite or remote
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Step 1

From the Edit menu, choose Preferences.
The CTC Preferences Dialog box appears (Figure 9-4 on page 9-10).

Step 2

Check the Display Events Using Each Node’s Timezone check box. The Apply button is enabled.

Step 3

Click Apply and OK.

Step 4

Return to your originating procedure (NTP).

DLP-D113 Synchronize Alarms
Purpose

Use this task to view ONS 15454 SDH events at the card, node, or network
level and to refresh the alarm listing while troubleshooting so that you can
check for new and cleared alarms and conditions.

Tools/Equipment

None

Prerequisite Procedures DLP-D60 Log into CTC, page 3-23
Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Retrieve

Step 1

At the card, node, or network view, click the Alarms tab.

Step 2

Click Synchronize.
This button causes CTC to retrieve a current alarm summary for the card, node, or network. This step is
optional because CTC updates the Alarms window automatically as raise/clear messages arrive from the
node.

Note

Step 3

Alarms that have been raised during the session will have a check mark in the Alarms window
New column. When you click Synchronize, the check mark disappears.

Return to your originating procedure (NTP).

DLP-D114 View Conditions
Purpose

Use this task to view conditions [events with a Not-Reported (NR)
severity] at the card, node, or network level. Conditions give you a clear
record of changes or events that do not result in alarms.

Tools/Equipment

None

Prerequisite Procedures DLP-D60 Log into CTC, page 3-23
Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Retrieve

Cisco ONS 15454 SDH Procedure Guide, R4.1.1 and R4.5
November 2004

9-11

Chapter 9

Manage Alarms

DLP-D114 View Conditions

Step 1

From the card, node, or network view, click the Conditions tab.

Step 2

Click Retrieve (Figure 9-5).
The Retrieve button requests the current set of fault conditions from the node, card, or network. The
window is not updated when events change on the node. You must click Retrieve to see any changes.
Figure 9-5

Node View Conditions Window

Conditions include all fault conditions raised on the node, whether or not they are reported.

Note

Alarms can be unreported when they are filtered out of the display. See the “DLP-D225 Enable
Alarm Filtering” task on page 9-27 for information.

Events that are reported as Major (MJ), Minor (MN), or Critical (CR) severities are alarms. Events that
are reported as Not-Alarmed (NA) are conditions. Conditions that are not reported at all are marked
Not-Reported (NR) in the Conditions window severity column.
Conditions that have a default severity of Critical (CR), Major (MJ), Minor (MN), or Not-Alarmed (NA)
but are not reported due to exclusion or suppression are shown as NR in the Conditions window.

Note

For more information about alarm suppression, see the “DLP-D119 Suppress Alarm Reporting”
task on page 9-31.
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Current conditions are shown with the severity chosen in the alarm profile, if used. For more information
about alarm profiles, see the “NTP-D71 Create, Download, and Assign Alarm Severity Profiles”
procedure on page 9-17.

Note

Step 3

When ports are placed out of service for maintenance (OOS-MT), they raise an Alarms
Suppressed for Maintenance (AS-MT) condition. For information about alarm and condition
troubleshooting, refer to the Cisco ONS 15454 SDH Troubleshooting Guide.

If you want to apply exclusion rules, check the Exclude Same Root Cause check box at the node or
network view, but do not check the Exclude Same Root Cause check box in card view.
An exclusion rule eliminates all lower-level alarms or conditions that originate from the same cause. For
example, a fiber break may cause an LOS alarm, an AIS condition, and an SF condition. If you check
the Exclude Same Root Cause checkbox, only the LOS alarm will appear. According to IEEE, exclusion
rules apply to a query of “all conditions from a node.”

Step 4

Return to your originating procedure (NTP).

NTP-D68 Delete Cleared Alarms from Display
Purpose

Use this procedure to delete Cleared (C) status alarms from the alarms
window. The procedure can be used to delete transient messages from the
CTC History window.

Tools/Equipment

None

Prerequisite Procedures None
Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Retrieve

Step 1

Log into a node where you want to delete alarms. See the “DLP-D60 Log into CTC” task on page 3-23.
If you are already logged in, go to Step 2.

Step 2

To delete cleared node-level alarms:
a.

In the node view, click the Alarms tab.

b.

Click the Delete Cleared Alarms button, referring to the rules in Step 5.

This action removes any cleared ONS 15454 SDH alarms from the Alarms display. The rows of cleared
alarms turn white and have a C in their status (ST) column (Figure 9-5 on page 9-12).
Step 3

Step 4

To delete cleared card-level alarms:
a.

In the node view, double-click the card graphic for the card you want to open.

b.

Click the Alarms tab and then click the Delete Cleared Alarms button, referring to the rules in
Step 5.

To delete clear network-level alarms:
a.

Choose Go to Network View from the View menu.
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b.
Step 5

Step 6

Click the Alarms tab and then click Delete Cleared Alarms, referring to the rules in
Step 5.

Consult the following rules when deleting cleared alarms from the display:
•

If the Autodelete Cleared Alarms check box is checked, an alarm disappears from the window when
it is cleared.

•

If the Autodelete Cleared Alarms check box is not checked, an alarm remains in the window when
it is cleared. The alarm appears white in the window and has a Clear (CL) severity. The alarm can
be removed by clicking the Delete Cleared Alarms button.

Transient messages are single messages and not raise-and-clear pairs (that is, they do not have
companion messages stating they are cleared). Click the Delete Cleared Alarms button to remove the
transients from the History window.
Stop. You have completed this procedure.

NTP-D69 View Alarm-Affected Circuits
Purpose

Use this procedure to view all circuits, if any, affected by an alarm or
condition

Tools/Equipment

None

Prerequisite Procedures NTP-D196 View Alarms, History, Events, and Conditions, page 9-5
Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Retrieve

Step 1

Complete the “DLP-D60 Log into CTC” task on page 3-23. If you are already logged in, go to Step 2.

Step 2

In the network, node, or card view, click the Alarms tab or Conditions tab and then right-click anywhere
in the row of an active alarm or condition.

Note

The node view is the default, but you can also navigate to the Alarms tab in the network view or
card view to perform Step 2.

Note

The card view is not available for the TCC2 or cross-connect cards.

The Select Affected Circuit option appears on the shortcut menu (Figure 9-6).
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Figure 9-6

Step 3

Select Affected Circuits Option

Left-click or right-click Select Affected Circuits.
The Circuits window appears with the affected circuits highlighted (Figure 9-7).
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Figure 9-7

Step 4

Viewing Alarm-Affected Circuits

If you want to search for particular circuits, see the “DLP-D131 Search for Circuits” task on page 11-6.
Stop. You have completed this procedure.

NTP-D70 View Alarm Counts on the LCD for a Node, Slot, or Port
Purpose

Use this procedure to find out how many alarms have occurred on a node,
slot or port without using CTC.

Tools/Equipment

None

Prerequisite Procedures None
Required/As Needed

As needed

Onsite/Remote

Onsite

Security Level

Retrieve

Step 1

If you want to view the alarm count for the node, press the Slot button on the LCD panel until Node
appears on the LCD.

Step 2

To view the node alarm summary, press the Status button.
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Step 3

To view the node-level alarm summary:
a.

Press the Port button to toggle to Port 0.

b.

Press the Status button.

Step 4

To view the card-level alarm count, press the Slot button.

Step 5

To view the slot alarm summary, wait 8 seconds after pressing Slot and the LCD is automatically updated
with the summary of all alarms for the slot. To toggle to summaries for different slots, press the Slot
button again.

Step 6

To view port-level alarm counts:
a.

Press the Port button to toggle to Port 0.

b.

Press Status to get slot card-level alarm counts.

c.

To toggle to a the alarm count for a different port, press the Port button again.

d.

Press Slot to toggle back to the node summary.

Figure 9-8 shows the LCD panel.
The LCD Panel

Status

Slot

Port

12/19/02
24˚C
04.00-002L-10
FAN FAIL

Note

CRIT

MAJ

MIN

87093

Figure 9-8

A blank LCD results when the fuse on the AIP board is blown. If this occurs, log into
http://www.cisco.com/tac for more information or log into
http://www.cisco.com/warp/public/687/Directory/DirTAC.shtml to obtain a directory of Cisco
TAC toll-free numbers for your country.

Stop. You have completed this procedure.

NTP-D71 Create, Download, and Assign Alarm Severity Profiles
Purpose

Use this procedure to create a customized copy of the default alarm profile
applied to a node, to download a saved custom profile from a network
location to another node, to assign custom severities individually to a port,
card, or node, and to delete alarm profiles.

Tools/Equipment

None

Prerequisite Procedures None
Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Provisioning or higher
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Step 1

Complete the “DLP-D60 Log into CTC” task on page 3-23 at the node where you want to create an alarm
profile. If you are already logged in, go to Step 2 to clone or modify an alarm profile, or go to Step 3 to
download an alarm profile.

Step 2

Complete the “DLP-D115 Create Alarm Severity Profiles” task on page 9-18. This task clones a current
alarm profile, renames the profile, and customizes the new profile. Go to Step 4.

Step 3

Complete the “DLP-D223 Download an Alarm Severity Profile” task on page 9-21. This task downloads
an alarm severity profile from a CD or a node.

Step 4

As necessary, complete the “DLP-D19 Apply Alarm Profiles to Ports” task on page 9-22 or the
“DLP-D117 Apply Alarm Profiles to Cards and Nodes” task on page 9-24.
Stop. You have completed this procedure.

DLP-D115 Create Alarm Severity Profiles
Purpose

Use this task to create a custom severity profile by modifying the default
severity profile.

Tools/Equipment

None

Prerequisite Procedures DLP-D60 Log into CTC, page 3-23
Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Provisioning or higher

Step 1

From the View menu choose Go to Network View.

Step 2

Click the Provisioning > Alarm Profiles tabs (Figure 9-3 on page 9-6).

Step 3

Click Load.

Step 4

In the Select Profile(s) from Node or Filename to Load dialog box, click the From Node radio button.

Step 5

Click the node name you are logged into in the Node Names list.

Step 6

Click Default in the Profile Names list.

Step 7

Click OK.
The default alarm severity profile appears in the Alarm Profiles window (Figure 9-9).

Note

The alarm profile list contains a master list of alarms that is used for a mixed node network.
Some of these alarms may not be used in all ONS nodes.
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Figure 9-9

Network View Alarm Profiles Window

Step 8

Right-click anywhere in the Default profile column to display the profile editing shortcut menu.

Step 9

Click Clone in the shortcut menu.

Tip

Step 10

To find out which profiles are available for loading or cloning, click the Available button. You
cannot clone Inherited profiles.

In the Clone Profile dialog box, enter a name for the copied profile in the New Profile Name field.
Profile names must be unique. If you try to import or name a profile that has the same name as another
profile, CTC adds a suffix to create a new name. Long file names are supported.

Step 11

Click OK.
A new alarm profile (named in Step 10) is created. This profile duplicates the default profile severities
and appears to the right of the default profile in the Alarm Profiles window. You can highlight it and drag
it to a different position.

Step 12

Step 13

Modify (customize) the new alarm profile:
a.

In the new alarm profile column, double-click the alarm severity you want to change.

b.

Click the desired severity in the drop-down menu.

c.

Repeat Steps a and b for each severity you want to customize.

After you have customized the new alarm profile, right-click the profile column to highlight it.

Cisco ONS 15454 SDH Procedure Guide, R4.1.1 and R4.5
November 2004

9-19

Chapter 9

Manage Alarms

DLP-D115 Create Alarm Severity Profiles

Step 14

Click Store in the profile editing shortcut menu.

Step 15

Click the To Node(s) radio button and go to Step a or click the To File radio button and go to Step b.
(Figure 9-10).
Figure 9-10 Store Profile(s) Dialog Box

a.

Choose the node(s) where you want to save the profile:
– If you want to save the profile to only one node, click the node in the Node Names list.
– If you want to save the profile to all nodes, click Select All.
– If you do not want to save the profile to any nodes, click Select None.
– If you want to update alarm profile information, click (Synchronize).

b.

Navigate to the profile save location by clicking Browse.
– Enter a name in the File name field.
– Click Select to choose this name and location.

Note
c.

Step 16

Long file names are supported. CTC supplies a suffix of *.pfl.

Click the OK button to store the profile.

Note

Click the Hide Identical Rows check box to configure the Alarm Profiles window to display rows
with dissimilar severities.

Note

Click the Hide Reference Values Matching Profile Default check box to configure the Alarm
Profiles window to display severities that do not match the Default profile.

Return to your originating procedure (NTP).
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DLP-D223 Download an Alarm Severity Profile
Purpose

Use this task to download a custom alarm severity profile from a
network-drive accessible CD-ROM, floppy disk, or hard disk location.

Tools/Equipment

None

Prerequisite Procedures DLP-D60 Log into CTC, page 3-23
Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Provisioning or higher

Step 1

From the View menu choose Go to Network View (Figure 9-3 on page 9-6).

Step 2

Click the Provisioning > Alarm Profiles tabs.

Step 3

Click Load.

Step 4

If you want to download a file from the local PC hard drive, floppy disk, CD-ROM, or a network drive
(if connected), click the From File radio button in the Select Profile(s) from Node or Filename to Load
dialog box.
a.

Click Browse.
The Open dialog box appears.

b.

In the Look in pull-down menu, click to navigate to the folder where the profile file is located.

c.

Click the name in the window to highlight it.

The file must have the *.pfl extension.

Note
d.

Click Open.

Go to Step 6.
Step 5

Step 6

If you want to download a file from the login node or another connected node, click the From Node radio
button in the Select Profile(s) from Node or Filename to Load dialog box.
a.

Click the node where the profile is located under the Node Names list.

b.

Click the profile under the Profile Names list.

Click OK in the Select Profile(s) from Node or Filename to Load dialog box.
The downloaded profile appears at the right side of the Alarm Profiles window.

Step 7

Right-click anywhere in the downloaded profile column to display the profile editing shortcut menu.

Step 8

Click Store in the shortcut menu.

Step 9

In the Store Profile(s) dialog box, click To Node(s) (Figure 9-10 on page 9-20).
a.

b.

Choose the node(s) where you want to save the profile:
•

If you want to save the profile to only one node, click the node in the Node Names list.

•

If you want to save the profile to all nodes, click Select All.

•

If you do not want to save the profile to any nodes, click Select None.

•

If you want to update alarm profile information, click Synchronize.

Click OK.
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Step 10

Return to your originating procedure (NTP).

DLP-D19 Apply Alarm Profiles to Ports
Purpose

Use this task to apply a custom or default alarm severity profile to a port
or ports.

Tools/Equipment

None

Prerequisite Procedures DLP-D115 Create Alarm Severity Profiles, page 9-18
DLP-D60 Log into CTC, page 3-23

Step 1

Step 2

Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Provisioning or higher

In the node view, double-click a card to display the card view.

Note

You can also apply alarm profiles to cards using the “DLP-D117 Apply Alarm Profiles to Cards
and Nodes” task on page 9-24.

Note

The card view is not available for the TCC2 or cross-connect cards.

Depending on which card you want to apply the profile to, click the following tabs:
•

If the card is an E-Series Ethernet, G-Series Ethernet, MXP, TXP, STM-N, or electrical traffic card,
click the Provisioning > Alarm Behavior tabs.

•

If the card is an ML-Series Ethernet (traffic) card, click the Provisioning > Ether Alarming tabs
or the Provisioning > POS Alarming tabs, depending on whether you want to apply the profile to
the front physical ports (“Ether alarming”) or packet over SDH (“POS alarming”). For more
information about ML-Series card ports and service, see the Cisco ONS 15454 SONET/SDH
ML-Series Multilayer Ethernet Card Software Feature and Configuration Guide.

•

If the card is an OSCM or OSC-CSM DWDM card, click the Provisioning > OC3 Line tab or
Provisioning > Optical Line tab and the Alarm Behavior subtab.

•

If the card is a 32MUX-O or 32DM-X DWDM card, click the Provisioning > Optical Chn or
Provisioning > Line tab and the Alarm Behavior subtab.

•

If the card is an OPT-PRE or OPT-BST DWDM card, click the Provisioning > Optical Line or
Provisioning > Optical Ampli. Line and the Alarm Behavior subtab.

•

If the card is a channel add/drop DWDM card (AD-1C-xx.x, AD-2C-xx.x, AD-4C-xx.x) click the
Provisioning > Optical Line or Provisioning > Optical Chn tab and the Alarm Behavior subtab.

•

If the card is a band add/drop DWDM card (AD-1B-xx.x, AD-2B-xx.x, AD-4B-xx.x) DWDM card,
click the Provisioning > Optical Line or Provisioning > Optical Band tab and the Alarm Behavior
subtab.

Figure 9-11 shows the alarm profile of AD-4C-xx.x card ports. CTC shows Force all ports to Profile:
Inherited.
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Figure 9-11 Card View Port Alarm Profile for an AD-4C-xx.x Card

Go to Step 3 to apply profiles to a port. Go to Step 4 to apply profiles to all ports on a card.
Step 3

Step 4

Step 5

To apply profiles on a port basis:
a.

Click the port row under the Profile column.

b.

Choose the new profile from the drop-down menu.

c.

Click Apply.

To apply profiles to all ports on a card:
a.

Click the Force all ports to profile menu arrow at the bottom of the window.

b.

Choose the new profile from the drop-down menu.

c.

Click Force (still need to “Apply”).

d.

Click Apply.

Return to your originating procedure (NTP).

Tip

Click Reset to return to the previous profile setting unless you have already clicked Apply. To
return to the previous profile if you have already applied it, select the previous profile and click
Apply again.
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DLP-D117 Apply Alarm Profiles to Cards and Nodes
Purpose

This task applies a custom or default alarm profile to cards or nodes.

Tools/Equipment

None

Prerequisite Procedures DLP-D115 Create Alarm Severity Profiles, page 9-18
DLP-D60 Log into CTC, page 3-23

Step 1

Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Provision

In node view, click the Provisioning > Alarm Behavior tabs (Figure 9-12).
Figure 9-12 Node View Alarm Profile

Step 2

Step 3

To apply profiles to a card:
a.

Click the Profile row for the card.

b.

Choose the new profile from the drop-down menu.

c.

Click Apply.

To apply the profile to an entire node:
a.

Click the Node Profile menu arrow at the bottom of the window (Figure 9-12).
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Tip

Step 4

b.

Click the new alarm profile in the drop-down menu.

c.

Click Apply.

Click Reset to return to the previous profile setting unless you have already clicked Apply. To return to
the previous profile if you have already applied it, select the previous profile and click Apply again.
Return to your originating procedure (NTP).

DLP-D118 Delete Alarm Severity Profiles
Purpose

This task deletes a custom or default alarm severity profile.

Tools/Equipment

None

Prerequisite Procedures DLP-D60 Log into CTC, page 3-23
Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Provision

Step 1

From the View menu choose Go to Network View.

Step 2

Click the Provisioning > Alarm Profiles tabs.

Step 3

Click the column heading for the profile column you want to delete.
The selected alarm profile name is displayed in the Description field.

Step 4

Click Delete.
The Select Node/Profile Combination for Delete dialog box appears (Figure 9-13).
Figure 9-13 Select Node/Profile Combination For Delete Dialog Box

Step 5

Click the node name(s) in the Node Names list to highlight the profile location.

Tip

Step 6

If you hold the Shift key down, you can select consecutive node names. If you hold the Ctrl key
down, you can select any combination of nodes.

Click the profile name(s) you want to delete in the Profile Names list.
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Step 7

Click OK.
The Delete Alarm Profile confirmation dialog box appears.

Step 8

Click Yes for each Delete Alarm Profile confirmation dialog box.

Note

Step 9

Step 10

If you delete a profile from a node, it is still displayed in the network view
Provisioning > Alarm Profiles window unless you remove it by choosing Remove.

To remove the alarm profile from the Provisioning > Alarm Profiles window, right-click the column of
the profile you deleted and choose Remove from the shortcut menu.

Note

If a node and profile combination is selected but does not exist, a warning appears: “One or more
of the profile(s) selected do not exist on one or more of the node(s) selected.” For example, if
node A has only profile 1 and the user tries to delete both profile 1 and profile 2 from node A,
this warning appears. However, the operation still removes profile 1 from node A.

Note

The Default and Inherited special profiles cannot be deleted and do not appear in the Select
Node/Profile Combination for Delete Window.

Return to your originating procedure (NTP).

NTP-D168 Enable, Modify, or Disable Alarm Severity Filtering
Purpose

Use this procedure to start, change, or stop alarm filtering for one or more
severities in the Alarms, Conditions, and History windows in all network
nodes.

Tools/Equipment

None

Prerequisite Procedures None
Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Retrieve

Step 1

Complete the “DLP-D60 Log into CTC” task on page 3-23 at the node where you want to enable alarm
severity filtering. If you are already logged in, go to Step 2.

Step 2

As necessary, complete the “DLP-D225 Enable Alarm Filtering” task on page 9-27. This task enables
alarm filtering at the card, node, and network views for all nodes in the network. Alarm filtering can be
enabled for alarms, conditions, or events.

Step 3

As necessary, complete the “DLP-D226 Modify Alarm and Condition Filtering Parameters” task on
page 9-27 to modify the alarm filtering for network nodes to show or hide particular alarms or
conditions.

Step 4

As necessary, complete the “DLP-D227 Disable Alarm Filtering” task on page 9-29 to disable alarm
profile filtering for all network nodes.
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Stop. You have completed this procedure.

DLP-D225 Enable Alarm Filtering
Purpose

Use this task to enable alarm filtering for alarms, conditions, or event
history in all network nodes.

Tools/Equipment

None

Prerequisite Procedures DLP-D60 Log into CTC, page 3-23
Required/As Needed
Onsite/Remote

As needed

Security Level

Retrieve

Onsite or remote

Step 1

At the node, network, or card view, click the Alarms tab.

Step 2

Click the Filter tool at the lower-right side of the bottom toolbar.
Alarm filtering is enabled if the tool is selected and disabled if the tool is raised (not selected).
Alarm filtering will be enabled in the card, node, and network views of the Alarms tab at the node and
for all other nodes in the network. If, for example, the Alarm Filter tool is enabled in the Alarms tab of
the node view at one node, the Alarms tab in the network view and card view of that node will also show
the tool enabled. All other nodes in the network will also have the tool enabled.
If you filter an alarm in card view, the alarm will still be displayed in node view. In this view, the card
will display the color of the highest-level alarm. The alarm is also shown for the node in the network
view.

Step 3

If you want alarm filtering enabled when you view conditions, repeat Steps 1 and 2 using the Conditions
window.

Step 4

If you want alarm filtering enabled when you view alarm history, repeat Steps 1 and 2 using the History
window.

Step 5

Return to your originating procedure (NTP).

DLP-D226 Modify Alarm and Condition Filtering Parameters
Purpose

Use this task change alarm and condition reporting in all network nodes.

Tools/Equipment

None

Prerequisite Procedures DLP-D225 Enable Alarm Filtering, page 9-27
DLP-D60 Log into CTC, page 3-23
Required/As Needed
Onsite/Remote

As needed

Security Level

Retrieve

Onsite or remote
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Step 1

At the node, network, or card view, click the Alarms tab.

Step 2

Click the Filter button at the lower-left of the bottom toolbar.
The Alarm Filter Dialog box appears, showing the General tab (Figure 9-14).
Figure 9-14 Alarm Filter Dialog Box General Tab

In the General tab Show Severity box, you can choose which alarm severities will show through the
alarm filter and provision a time period during which filtered alarms show through the filter. To change
the alarm severities shown in the filter, go to Step 3. To change the time period filter for the alarms go
to Step Step 4.
Step 3

In the Show Severity area, click the check boxes for the severities [Critical (CR), Major (MJ), Minor
(MN), or Not-Alarmed (NA)] you want to be reported at the network level. Leave severity check boxes
deselected (unchecked) to keep them from appearing.
When alarm filtering is disabled, all alarms show.

Step 4

In the Time area, click the Show alarms between time limits check box to enable it. Then click the up
and down arrows in the From Date, To Date, and Time fields to modify what period of alarms are shown.
To modify filter parameters for conditions, go to Step 5. If you do not need to modify them, go to Step 6.

Step 5

Click the Conditions tab (Figure 9-15).
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Figure 9-15 Alarm Filter Dialog Box Conditions Tab

When alarm filtering is enabled, conditions in the Show list are visible and conditions in the Hide list
are invisible.
•

To move conditions individually from the Show list to the Hide list, click the > button.

•

To move conditions individually from the Hide list to the Show list, click the < button.

•

To move conditions collectively from the Show list to the Hide list, click the >> button.

•

To move conditions collectively from the Hide list to the Show list, click the << button.

Note
Step 6

Conditions include alarms.

Click Apply and OK.
Alarm and condition filtering parameters are enforced when alarm filtering is enabled (see the
“DLP-D225 Enable Alarm Filtering” task on page 9-27), and are not enforced when alarm filtering is
disabled (see the “DLP-D227 Disable Alarm Filtering” task on page 9-29).

Step 7

Return to your originating procedure (NTP).

DLP-D227 Disable Alarm Filtering
Purpose

Use this task to turn off specialized alarm filtering in all network nodes so
that all severities are reported in CTC.

Tools/Equipment

None

Prerequisite Procedures DLP-D225 Enable Alarm Filtering, page 9-27
DLP-D60 Log into CTC, page 3-23
Required/As Needed
Onsite/Remote

As needed

Security Level

Retrieve

Onsite or remote
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Step 1

At the node, network, or card view, click the Alarms tab.

Step 2

Click the Filter tool at the lower-right side of the bottom toolbar.
Alarm filtering is enabled if the tool is indented and disabled if the tool is raised (not selected).

Step 3

If you want alarm filtering disabled when you view conditions, click the Conditions tab and repeat
Step 2.

Step 4

If you want alarm filtering disabled when you view alarm history, click the History tab and repeat
Step 2.

Step 5

Return to your originating procedure (NTP).

NTP-D72 Suppress and Discontinue Alarm Suppression
Purpose

Use this procedure to prevent alarms from being reported for a port, card,
or node in circumstances when an alarm or condition is known to exist but
you do not want to include it in the display. Also use this procedure to
resume normal alarm reporting by discontinuing the suppression.

Tools/Equipment

None

Prerequisite Procedures None
Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Provisioning

Step 1

Complete the “DLP-D60 Log into CTC” task on page 3-23. If you are already logged in, go to Step 2.

Step 2

Complete the “DLP-D119 Suppress Alarm Reporting” task on page 9-31 to make the node send out
autonomous messages that clear particular raised alarms and cause the suppressed alarms to appear in
the Conditions window.

Note

Step 3

Suppressing one or more alarms prevents them from appearing in Alarm or History windows or
in any other clients. The suppress command causes CTC to display them in the Conditions
window, where Not-Reported (NR) events are shown. The suppressed alarms appear there with
their severity, their severity color code, and service-affecting status.

Complete the “DLP-D120 Discontinue Alarm Suppression” task on page 9-32 to remove the suppress
command and resume normal alarm reporting.
Stop. You have completed this procedure.
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DLP-D119 Suppress Alarm Reporting
Purpose

This task suppresses the reporting of ONS 15454 SDH alarms at the port,
card, or node level.

Tools/Equipment

None

Prerequisite Procedures DLP-D60 Log into CTC, page 3-23

Caution

Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Provisioning

If multiple CTC sessions are open, suppressing alarms in one session suppresses the alarms in all other
open sessions.

Step 1

At either the node or card view, click the Provisioning > Alarm Behavior tabs.

Step 2

At the node level, you can suppress alarms on a card basis or for the entire node. At the card level, you
can suppress alarms on a port basis.
a.

To suppress alarms at the node level for the entire node, check the Suppress Alarms column check
box located at the bottom-left of the window.

b.

To suppress alarms at the node level for individual cards, check the Suppress Alarms column check
box for the slot row where you want to suppress alarms.

Note
c.

In node view, row numbers correspond to slot numbers.
Click Apply (whether or not you complete the next step).
The node sends out autonomous messages to clear any raised alarms.

Step 3

To suppress alarms at the card level for ports:
a.

Double-click the card.

b.

Click the Provisioning > Alarm Behavior tabs.

c.

Check the Suppress Alarms column check box for the port row where you want to suppress alarms.

Step 4

Click Apply.

Step 5

Return to your originating procedure (NTP).
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DLP-D120 Discontinue Alarm Suppression
Purpose

This task discontinues alarm suppression and reenable alarm reporting on
a port, card, or node.

Tools/Equipment

None

Prerequisite Procedures DLP-D119 Suppress Alarm Reporting, page 9-31
DLP-D60 Log into CTC, page 3-23
Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Provisioning

Step 1

To discontinue alarm suppression for the entire node, uncheck the Suppress Alarms check box at the
lower-left of the Alarm Behavior window.

Step 2

To discontinue alarm suppression for individual cards that you suppressed at the node level:

Step 3

Step 4

a.

Uncheck the check box in the Suppress Alarms column for that card.

b.

Click Apply.

To discontinue alarm suppression for ports that you suppressed at the card level:
a.

Double-click the card to display the card view.

b.

Uncheck the Suppress Alarms check box for the port(s) you no longer want to suppress.

c.

Click Apply.

Return to your originating procedure (NTP).

NTP-D247 Provision External Alarms and Controls on the Alarm
Interface Controller-International
Purpose

Use this procedure to create external (environmental) alarms and external
controls for the Alarm Interface Controller (AIC) or Alarm Interface
Controller-International card.

Tools/Equipment

An AIC-I card must be installed in Slot 9.

Prerequisite Procedures NTP-D24 Verify Card Installation, page 4-2

Note

Required/As Needed

As needed

Onsite/Remote

Onsite or remote

Security Level

Provisioning or higher

For information about the AIC-I external alarms and controls, virtual wire, and orderwire, refer to the
Cisco ONS 15454 SDH Reference Manual.
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Step 1

Verify the alarm contact wiring. See the “NTP-D223 Attach Wires to Alarm, Timing, and LAN
Connections” procedure on page 1-30 for information about the ONS 15454 SDH contacts.
a.

For external alarms, verify that the external device relays are wired to the ENVIR ALARMS IN
connector pins.

b.

For external controls, verify the external device relays are wired to the ENVIR ALARMS OUT
connector pins.

Step 2

In the node view, double-click the AIC-I card shelf graphic. The card view appears.

Step 3

Click the Provisioning > Card tabs.

Step 4

In the Input/Output area, click one of the following options:
•

External Alarm—Select External Alarm if you use external alarms only. Selecting External Alarm
gives you 20 external alarm ports.

•

External Control—Select External Control if you use both external alarms and external controls. If
you select External Control, four of the ports are converted to external control ports, leaving you
with 16 external alarm ports.

Step 5

Click Apply.

Step 6

If you are provisioning external alarms, click the External Alarms tab (Figure 9-16). If you are not
provisioning external alarms, skip Steps 7 through 9 and go to Step 10.
Figure 9-16 Provisioning External Alarms On The AIC-I Card

Step 7

Complete the following fields for each external device wired to the ONS 15454 SDH backplane:
•

Enabled—Check the check box to activate the fields for the alarm input number.

•

Alarm Type—Choose an alarm type from the drop-down menu.

•

Severity—Click a severity from the drop-down menu.
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The severity determines the severity the alarm has in the Alarms and History tabs and determines
whether the LEDs are activated. Critical (CR), Major (MJ), and Minor (MN) alarms activate the
LEDs. Not-Alarmed (NA) and Not-Reported (NR) do not activate LEDs, but do report the
information in CTC.
•

Virtual Wire—Choose the virtual wire number from the drop-down menu to assign the external
device to a virtual wire. Otherwise, do not change the None default. For information about the AIC-I
virtual wire, see the Cisco ONS 15454 SDH Reference Manual.

•

Raised When—From the drop-down menu, choose the contact condition (open or closed) that
triggers the alarm.

•

Description—A default description is provided; enter a different description if needed.

Step 8

To provision additional devices, complete Step 7 for each additional device.

Step 9

Click Apply.

Step 10

If you are provisioning external controls, click the External Controls tab and complete the following
fields for each external control wired to the ONS 15454 SDH connectors:
•

Enabled—Check this check box to activate the fields for the alarm input number.

•

Control Type—Choose the control type from the drop-down menu: air conditioner, engine, fan,
generator, heat, light, sprinkler, or miscellaneous.

•

Trigger Type—Choose a trigger type: a local minor, major, or critical alarm; a remote minor, major,
or critical alarm; or a virtual wire activation.

•

Description—Enter a description.

Step 11

To provision the other external controls, complete Step 10 for each additional device.

Step 12

Click Apply.

Note

When you provision an external alarm, the alarm object is ENV-IN-nn. The variable nn refers to
the external alarm’s number, regardless of the name you assign.

Note

Environmental alarms that you create (and name) should be recorded locally for the NE. Both
the Alarm name and resolution are node-specific.

Stop. You have completed this procedure.
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