Cisco Prime Network Analysis Module
User Guide

Release 6.2
June 2015

Cisco Systems, Inc.
www.cisco.com

Cisco has more than 200 offices worldwide. Addresses, phone numbers, and fax numbers are listed on the Cisco website at www.cisco.com/go/offices.
The Cisco implementation of TCP header compression is an adaptation of a program developed by the University of California, Berkeley (UCB) as part of UCB’s public domain version of the UNIX operating system. All rights reserved. Copyright © 1981, Regents of the University of California.

Notwithstanding any other warranty herein, all document files and software of these suppliers are provided “as is” with all faults. Cisco and the above-named suppliers disclaim all warranties, expressed or implied, including, without limitation, those of merchantability, fitness for a particular purpose and noninfringement or arising from a course of dealing, usage, or trade practice.

In no event shall Cisco or its suppliers be liable for any indirect, special, consequential, or incidental damages, including, without limitation, lost profits or loss or damage to data arising out of the use or inability to use this manual, even if Cisco or its suppliers have been advised of the possibility of such damages.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

Cisco Prime Network Analysis Module User Guide
© 2005-2015 Cisco Systems, Inc. All rights reserved.
# Contents

## Chapter 1

**Overview** 1-1

- Introducing Cisco Prime NAM 1-1
- Overview of the Cisco NAM Platforms 1-3
- How to Use Prime NAM to Analyze Your Traffic 1-3
- Before You Begin 1-4

## Chapter 2

**Getting Started** 2-1

- Before You Begin 2-1
- Quick Start 2-2
- Where to Go to Learn How to Customize Your NAM 2-2

## Chapter 3

**Monitoring and Analyzing Traffic** 3-1

- How To Make Dashboards Work for You 3-2
  - How Do I Solve My Problem? 3-2
- Troubleshooting Application Slowness 3-3
- Using Traffic Summary 3-4
- Using Response Time Summary 3-5
- Using Site Summary 3-6
- Using Alarm Summary 3-7
  - Utilizing Sites to Create a Geographically- or Organizationally-Familiar Deployment 3-8
- Analyzing Traffic 3-9
  - Analyzing Site Traffic 3-10
  - Analyzing Application Traffic 3-10
  - Analyzing Host Traffic 3-11
    - Applications Detail 3-11
  - NetFlow Interface Traffic Analysis 3-11
    - DSCP Detail 3-12
  - DSCP 3-12
  - Encapsulation 3-13
  - URL Hits 3-13
    - Viewing Collected URLs 3-13
    - Filtering a URL Collection List 3-13
<table>
<thead>
<tr>
<th>Detailed Traffic Analysis Views</th>
<th>3-14</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sites Detailed Views</td>
<td>3-14</td>
</tr>
<tr>
<td>Site Conversations Detailed Views</td>
<td>3-14</td>
</tr>
<tr>
<td>Applications Detailed Views</td>
<td>3-14</td>
</tr>
<tr>
<td>Application Groups Detailed Views</td>
<td>3-14</td>
</tr>
<tr>
<td>Application Traffic By Hosts Detailed Views</td>
<td>3-15</td>
</tr>
<tr>
<td>Top Application Traffic Detailed Views</td>
<td>3-15</td>
</tr>
<tr>
<td>Hosts Detailed Views</td>
<td>3-15</td>
</tr>
<tr>
<td>Host Conversations Detailed Views</td>
<td>3-15</td>
</tr>
<tr>
<td>Encapsulations Detailed Views</td>
<td>3-15</td>
</tr>
<tr>
<td>DCSPs Detailed Views</td>
<td>3-16</td>
</tr>
</tbody>
</table>

About Analyze Traffic Charts 3-16

Optimizing WAN 3-16

Ensuring WAN Optimization 3-16

Analyzing Traffic for Optimization Using the Top Talkers Detail 3-17

Analyzing Application Performance after WAAS Optimization 3-18

Comparing Transaction Time (Client Experience) 3-18

Comparing Traffic Volume and Compression Ratio 3-18

Planning Capacity Using Average Concurrent Connections (Optimized vs. Passthru) 3-18

Optimizing Usage Using Multi-Segment Network Time (Client LAN - WAN - Server LAN) 3-18

Monitoring WAAS Traffic Across Multi-Segments 3-18

Monitoring WAAS Single-Segment Traffic 3-19

Measuring Response Time 3-19

Application Response Time 3-21

Network Response Time 3-21

Server Response Time 3-22

Client Response Time 3-22

Client-Server Response Time 3-23

Application Response Time Distribution 3-23

Network Response Time Distribution 3-23

Server Response Time Distribution 3-23

Client Response Time Distribution 3-23

Client-Server Response Time Distribution 3-24

Server Application Responses 3-24

Server Application Transactions 3-24

Server Network Responses 3-24

Client-Server Application Responses 3-25

Client-Server Application Transactions 3-25

Client-Server Network Responses 3-25
Contents

Viewing Capture Sessions 4-20
Understanding Global Capture Settings 4-20

Working with Capture Files 4-21
Analyzing Capture Files 4-21
Drilling Down into Packet Error Details 4-21
Downloading Capture Files 4-22
Deleting a Capture File 4-22
Deleting Multiple Capture Files 4-22
Understanding Capture Sessions 4-23

Utilizing Capture Data Storage 4-24
About Capturing to Data Storage 4-25
Installing and Configuring Local and External Storage 4-25
Configuring the iSCSI Array 4-26
Locating the Prime NAM IQN 4-26
Connecting the Storage Array 4-26
Preparing LUNs for File Storage 4-28
Using LUNs to Store Packets from a Capture Session 4-28
Logging In and Out of External Storage LUNs 4-28
Connecting and Disconnecting External Storage 4-29

Recovering Data Storage 4-29
Inspecting Packet Decode Information for Suspicious Traffic 4-30
Analyzing Packets in the NAM Packet Analyzer 4-31
Filtering Packets Displayed in the NAM Packet Analyzer 4-32
Viewing Detailed Protocol Decode Information 4-33
Understanding the NAM Packet Analyzer 4-33
Customizing Display Filters 4-35
Creating Custom Display Filters 4-35
Editing or Deleting Custom Display Filters 4-38

CHAPTER 5
Performing User and System Administration 5-1
Performing System Administration 5-1
Monitoring Prime NAM Health and Traffic Statistics 5-2
Setting Network Parameters 5-3
Setting the SNMP Agent 5-3
Working with NAM Community Strings 5-4
Synchronizing Your System Time 5-5
Understanding NAM System Time 5-7
Setting Up E-Mail Notifications for Alarms 5-8
Sharing NAM Data by Enabling Web Data Publication 5-8
Monitoring Cisco WAAS and Measuring Its Impact  6-6
Monitoring  6-9
Using NAM to Monitor QoS/DiffServ (DSCP)  6-10
Using NAM for Historical Trends via Interactive Report  6-12
Using NAM to Evaluate Application-Level Performance Monitoring for TCP-Interactive Applications  6-14
Using NAM to Evaluate Application-Level Performance Monitoring for UDP Real-Time Applications  6-14
Monitoring the Nexus 1000V Switch Environment  6-14
Troubleshooting  6-16
Using NAM for Problem Isolation  6-16
Using NAM for SmartGrid Visibility  6-16

CHAPTER 7
Customizing Cisco Prime NAM  7-1
Advanced Configuration Overview  7-2
Setting Up Traffic Configurations  7-3
Configuring Traffic to Monitor  7-3
Creating a SPAN Session for RISE Appliance  7-4
Creating a SPAN Session for Appliances and other Virtual Platforms  7-4
Editing a SPAN Session for RISE Appliance  7-5
Editing a SPAN Session for Appliances and other Virtual Platforms  7-5
Setting Up Prime NAM Data Sources  7-6
Forwarding SPAN Traffic  7-6
Forwarding ERSPAN Traffic  7-7
Forwarding VACL Traffic  7-14
Forwarding NetFlow Traffic  7-16
Forwarding CEF Traffic  7-22
Managing WAAS and WAN Traffic  7-23
Configuring Hardware Deduplication  7-30
Setting Up Alarms and Alarm Thresholds  7-31
Configuring Alarm Actions  7-31
Viewing Alarm Actions  7-33
Understanding Trigger Capture  7-33
Defining Thresholds  7-33
Setting Host Thresholds  7-34
Setting Conversation Thresholds  7-35
Setting Application Thresholds  7-35
Setting Response Time Thresholds  7-36
Setting DSCP Thresholds  7-36
Setting RTP Stream Thresholds 7-37
Setting Voice Signaling Thresholds 7-37
Setting NetFlow Interface Thresholds 7-38
Setting Video Stream Thresholds 7-38
Setting MDI Stream Thresholds 7-39
Editing or Deleting an Alarm Threshold 7-39

Setting Up Data Export 7-40
Configuring NetFlow Export Templates 7-40
Creating NetFlow Export Templates 7-40
Editing NetFlow Export Templates 7-40
Deleting NetFlow Export Templates 7-41

Sharing Files 7-41
Scheduling Data Report Exports 7-41
Creating a Scheduled Report Export 7-42
Editing a Scheduled Export Job 7-43
Deleting a Scheduled Export Job 7-43
Downloading a Scheduled Report 7-43
Renaming a Scheduled Report 7-44
Deleting a Saved Reports 7-44

Accessing Device Interface and Health Details 7-44
Understanding How Platform-Specific NAMs Handle Managed Device Data 7-45
Configuring Managed Device Information 7-45
Configuring Managed Device Information on Blades or Modules 7-46
Configuring Managed Device Information on Appliances and other Virtual Platforms 7-46
Configuring Managed Device Information on RISE Appliances 7-46

Viewing Managed Device Information 7-47
Configuring Network Parameters 7-47
Configuring Sites 7-47
Defining a Site 7-48
Viewing Defined Sites 7-48
Editing a Site 7-48
Configuring Sites Using Subnets 7-49

Setting Interface Speed using NetFlow Interface Capacity 7-51
Creating or Editing a NetFlow Interface 7-51
Configuring DSCP Groups 7-51
Creating a DSCP Group 7-52
Editing a DSCP Group 7-52
Deleting a DSCP Group 7-52

Configuring Application Classification 7-52
Adding More Detail into Dashboard and Application Reports  7-53
  About Deeper Application Classification  7-53
  About Protocol Packs and Application Classification  7-54
  About NAM Classic Deep Packet Application Classification  7-54
Creating Deeper Visibility Into Application Traffic  7-55
  Creating Custom Applications  7-55
  Editing Custom Application Classifications  7-56
  Deleting an Application Rule  7-56
  Understanding Application Traffic  7-57
Configuring Application Groups  7-59
  Creating an Application Group  7-59
  Editing or Deleting an Application Group  7-59
  Deleting an Application Group  7-59
Filtering Encapsulations  7-60
Setting Up Prime NAM Monitoring  7-61
  Setting Aggregation Intervals  7-61
  Configuring Response Time  7-62
  Setting Up Media Monitoring  7-63
  Creating RTP Filters  7-64
  Configuring URL Collections  7-64
    Enabling a URL Collection  7-65
    Changing a URL Collection  7-65
    Disabling a URL Collection  7-66
  Configuring WAAS Monitored Servers  7-66

APPENDIX A

Understanding Prime NAM Traffic Sources  A-1
  Data Source Overview  A-1
  Ports and Hardware Details  A-3
  Understanding How the Prime NAM Uses SPAN  A-3
    A-5
  Understanding How the Prime NAM Uses VACLs in Catalyst Switch  A-5
  Configuring ACL Capture on Nexus 7000 Series  A-6
  Understanding How the Prime NAM Uses NetFlow  A-7
    Understanding NetFlow Interfaces  A-7
    Understanding NetFlow Flow Records  A-8
    Managing NetFlow Data Sources  A-8
  Understanding How the Prime NAM Uses WAAS  A-9
  Understanding How the Prime NAM uses CEF  A-9
  Understanding UCSE Physical Interfaces  A-10
APPENDIX B

Configuring NAM Security  B-1

Idle Timeout  B-1

SSL/TLS Security  B-1
  Configuring a Self-Signed Certificate  B-1
  Configuring a CA-Signed Certificate  B-2
  Configuring SSL/TLS Parameters  B-3
  Configuring SSL/TLS Ciphersuites  B-3
  Configuring SSL/TLS Protocols  B-3

SSH Security  B-4
  Configuring SSH Authorized Keys  B-4
  Configuring SSH Ciphers and MACs  B-4
  Secure File Transfers  B-5
  Protecting Against Man-in-the-Middle Attacks  B-5
  SSH Known Hosts  B-5
  SSL/TLS CA Certificates  B-6
  Software Image Upgrades  B-6

APPENDIX C

Understanding Prime NAM Behavior Reference  C-1

Menu Bar  C-2

Filters  C-2
  Quick Filter  C-2
  Advanced Filter  C-3

Displaying Detailed Views  C-3

Accessing Context Menus  C-3

Performing a Quick Capture  C-4

Determining How to Use Sites to View Data  C-4

Filtering Traffic for Viewing on the Dashboards  C-4

Filtering Data Using Global Search  C-5

Switching Chart Formats Using the Chart View / Table View  C-5

Accessing Other Tasks Using Mouse-Over for Details  C-6

Changing the Time Interval Using Zoom/Pan Charts  C-6

Using Sort Grid to Change Sort Order  C-6

Displaying Bits or Bytes or Packets in Charts  C-7

Statistics  C-7

Context-Sensitive Online Help  C-7

Feedback  C-7
APPENDIX D

GUI Field Descriptions D-1

Setup User Interface Windows D-1
  Create SPAN Session Dialog Box D-2
  Prime NAM Data Sources Dialog Box D-3
  Edit SPAN Session Dialog Box D-3
  SNMP Credential Options in NAM Data Sources Window D-4
  Device System Information Dialog Box D-5
  Alarm Configuration Window D-5
  Threshold Configuration Window D-5
  Host Alarm Thresholds Window D-6
  Conversation Alarm Thresholds Window D-7
  Application Alarm Thresholds Configuration Window D-7
  Response Time Alarm Threshold Configuration Window D-8
  DSCP Alarm Threshold Configuration Window D-8
  RTP Streams Threshold Configuration Window D-9
  Voice Signaling Threshold Configuration Window D-9
  NetFlow Interface Threshold Configuration Window D-10
  Video Stream Threshold Configuration Window D-10
  Video MDI Stream Threshold Configuration Window D-11
  Router System Information Window D-12
  Switch/Managed Device System Information D-12
  NBAR Interfaces Window D-13
  Site Configuration Window D-13
  Subnet Detection Window D-14
  Sites Window D-14
  Add NetFlow Interface Window D-15
  DSCP Group Setup Dialog Box D-15
  DSCP Group Label Formats D-15
  Application Window D-16
  Applications Window D-17
  URL-Based Applications Window D-18
  Response Time Configuration Window D-19
  Media Monitor Setup Window D-19
  URL Collection Configuration Window D-20
  NetFlow Export Template Window D-21

Monitor User Interface Windows D-22
  Applications Detail Window D-28
  Application Groups Detail Window D-28
  Application Response Time (ART) Metrics D-29
  Client Server Application Responses Window D-31
Troubleshooting Login Issues  E-2
Understanding Typical Error Messages  E-3
  Frequently Asked Questions about Prime NAM Behavior  E-3
Troubleshooting WAAS Data Issues  E-4
Troubleshooting Video Streams  E-5
Using the CLI to Troubleshoot Issues  E-5
  Locating Packet Drops  E-5
  Handling an Unresponsive NAM  E-6
  Using the CLI to Troubleshoot Performance Agent (PA)  E-6
Overview

This chapter contains information about the Cisco Prime Network Analysis Module (NAM) software and describes task overviews.

This chapter contains the following sections:

- Introducing Cisco Prime NAM
- Overview of the Cisco NAM Platforms
- How to Use Prime NAM to Analyze Your Traffic
- Before You Begin

Introducing Cisco Prime NAM

The Cisco Prime Network Analysis Module (Prime NAM) software is a network monitoring and analysis tool that combines flow-based and packet-based analysis into a single tool set. Prime NAM software provides network operations and engineering with user, command line, and application programming interfaces that you use for traffic analysis of applications, hosts, and conversations, performance-based measurements on application, server, and network latency, quality of experience metrics. as well as ways to see deeper into your network. The robust graphical user interface makes traffic monitoring and troubleshooting simple and cost-effective.

This chapter contains an overview on ways to use Prime NAM to monitor and analyze your network traffic. See Table 1-1 for details on high-level task areas and how they map to the user interface.

For a list of the key features in this release, see the Cisco Prime Network Analysis Module Release Notes.
### Table 1-1  Prime NAM Task Areas

<table>
<thead>
<tr>
<th>Task Area</th>
<th>Menu Mapping</th>
<th>Task Description</th>
<th>Used By</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plan and Prepare</td>
<td>Setup menu</td>
<td>Create a list of your network performance goals. Set expected goals and limits for response time, expected ranges for MOS values, bandwidth usage per application, and utilization on critical WAN links. Determine on which performance issues you want to concentrate.</td>
<td>Network Engineers, Designers, and Architects</td>
</tr>
<tr>
<td>Monitor and Analyze</td>
<td>Home, Capture, Analyze and Monitor menus</td>
<td>View dashboards which give you a quick view of traffic performance information, and various incidents. Use interactive reports filter data when monitoring specific network traffic and troubleshooting problems. Monitor your network and perform other day-to-day operations related to proactive and reactive traffic analysis and troubleshooting. Analyze QoS policy traffic using alarms, syslogs, traps, and e-mail alerts. See Monitoring and Analyzing Traffic and Capturing and Decoding Packets.</td>
<td>Network Engineers, NOC Operators, and Service Operators</td>
</tr>
<tr>
<td>Administer</td>
<td>Administer menu</td>
<td>Change default system display, notification, and user settings, as well as manage database access control and view system diagnostics. See Performing User and System Administration.</td>
<td>Network Engineers</td>
</tr>
<tr>
<td>Deploy</td>
<td>Setup and Admin menus</td>
<td>Configure devices to share data with NAM. Configure managed devices and data sources. Perform customized setup of NAM including sites, alarms and thresholds, scheduled exports, and so on. Monitor an extended level of your managed device’s data (health and interface information). Determine which locations are ingress or egress points of a logical network boundary (aggregation layer, core, campus edge, and so on) that can offer valuable insights into the network activity within that partition. Create a baseline of current metrics including applications, bandwidth per application, top conversations and hosts, QoS values used in the network, unrecognized protocols, and current server and end-to-end response time measurements. See Customizing Cisco Prime NAM.</td>
<td>Network Engineers, Designers, and Architects</td>
</tr>
<tr>
<td>Troubleshoot</td>
<td>Capture, Analyze and Monitor menus</td>
<td>Resolve common NAM issues including login problems and unresponsiveness, understand error messages, and troubleshoot network issues using Prime NAM. See Troubleshooting Network and NAM Issues.</td>
<td>Network Engineers, NOC Operators, and Service Operators</td>
</tr>
</tbody>
</table>
Overview of the Cisco NAM Platforms

Cisco NAM is supported on a variety of platforms. This guide does not discuss platforms, but focuses on tasks and capabilities.

For a list of Cisco NAM models and their features and capabilities, see the data sheets in Products & Services on Cisco.com.

It is important to note that the portfolio of Cisco NAM models differ in memory, performance, disk size, and other capabilities. Therefore, some allow for more features and capabilities (for example, the amount of memory allocated for capture).

Throughout this guide, there may be notes explaining that some features apply only to specific platforms. If there is no note, then that feature or aspect applies to all Cisco NAM platforms.

For details on memory, performance, disk size, and other capabilities, see the NAM Compatibility Matrix.

How to Use Prime NAM to Analyze Your Traffic

The Cisco Prime NAM software helps you to address the following major areas:

- Network Layer Traffic Analysis. Prime NAM provides comprehensive traffic analysis to identify what applications are running over the network, how much network resources are consumed, and who is using these applications. Prime NAM software offers a rich set of reports with which to view traffic by Hosts, Application, or Conversations. See the discussions about Dashboards, starting with Using Traffic Summary, page 2-4.

- Application Response Time. Prime NAM can provide passive measurement of TCP-based applications for any given server or client, supplying a wide variety of statistics like response time, network flight time, and transaction time. See Using Response Time Summary, page 2-5.

- Voice Quality Analysis. Prime NAM provides application performance for real time applications like Voice and Video. Prime NAM can compute MOS, as well as provide RTP analysis for the media stream. See Analyzing Media, page 2-32.

- Advanced Troubleshooting. Prime NAM provides robust capture and decode capabilities for packet traces that can be triggered or terminated based on user-defined thresholds. See Application Performance Monitoring Using Capture and Decode, page 3-5.

- WAN Optimization insight. Prime NAM provides insight into WAN Optimization offerings that compress and optimize WAN Traffic for pre- and post-deployment scenarios. This is applicable for Optimized and Passthru traffic. See

- Open instrumentation. Prime NAM is a mediation and instrumentation product offering, and provides a robust API that can be used by partner products as well as work with customer-created applications. Contact your account representative for a copy of the Cisco Prime Network Analysis Module API Programmer’s Guide.

To understand which types of monitoring are supported by specific NAM data sources, see Table 1-2.
Before You Begin

Depending on your Cisco NAM, ensure the following list of requirements are complete before you use Prime NAM. For detailed instructions, see your platform installation guide, except where noted:

- Reset your Cisco NAM root password
- Set up a data source to send traffic to the Cisco NAM
- Configure access to the Prime NAM user interface or CLI
- Synchronize your Cisco NAM to the standard time source outside the NAM in addition to the router or switch (depending on your platform). For detailed instructions, see Synchronizing Your System Time, page 4-5.

For optional advanced customizations, such as adding sites or configuring alarms and thresholds, see Advanced Configuration Overview, page 6-2.

---

**Table 1-2 Data Source Monitoring Capabilities**

<table>
<thead>
<tr>
<th>Data Sources</th>
<th>Monitoring Capabilities</th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Capture</td>
<td>Traffic</td>
<td>ART</td>
<td>RTP/Voice</td>
</tr>
<tr>
<td>SPAN/VAACL/ERSPAN</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>WAAS</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>NetFlow</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
</tbody>
</table>

For information on which data sources Prime NAM uses to deliver this functionality, see Understanding Prime NAM Traffic Sources. For information about which traffic sources are supported on each platform, see the NAM Compatibility Matrix.
Getting Started

This chapter contains getting started information for both users that want to use the NAM quickly without customizing the product or that want to customize the NAM. It includes some simple workflows that illustrate how to use Prime NAM to quickly to help troubleshoot performance and optimization issues.

There are many additional workflows for which Prime NAM can be used. These tasks are documented in the following chapters.

This chapter contains the following sections:

- Before You Begin, page 2-1
- Quick Start, page 2-2
- Where to Go to Learn How to Customize Your NAM, page 2-2

Before You Begin

This section contains tasks that must be performed prior to using NAM.

1. Ensure you perform all required tasks in your NAM installation guide. To review your platform’s specific requirements, see http://www.cisco.com/go/nam/docs.

2. Ensure that the NAM system time is configured correctly. If the system time is incorrect, NAM data presentation may be inaccurate due to time ranges, hence providing incorrect interpretations of NAM data. Although some platforms are synchronized automatically, you must also synchronize the standard time source outside the NAM in addition to the NAM and the router or switch in order for the data to be accurate. For details, see Synchronizing Your System Time, page 4-5.
Quick Start

Use the following workflows to get started using your product. These tasks do not require additional configuration or setup. You can see other workflows and tasks within this user guide in the task-specific chapters.

- Troubleshooting Application Slowness, page 2-3
- Using Traffic Summary, page 2-4
- Using Response Time Summary, page 2-5
- Using Site Summary, page 2-6
- Using Alarm Summary, page 2-7
- Filtering Data Using Global Search, page B-5
- Filtering Traffic for Viewing on the Dashboards, page B-4
- Filtering Data Using Global Search, page B-5

Where to Go to Learn How to Customize Your NAM

There are many capabilities beyond the tasks you can perform out-of-the-box. These tasks require some level of customization before you can access some of the additional functionality within NAM.

To review the customization you may need to perform, see Advanced Configuration Overview, page 6-2.
Monitoring and Analyzing Traffic

Cisco Prime Network Analysis Module, or Prime NAM, provides several dashboards and tools to help you to monitor and analyze your network traffic data. Prime NAM starts collecting data once your network device’s IP address is shared with the NAM. You can view the monitor dashboard, analyze traffic using various views, troubleshoot suspicious traffic using the capture tool, and decode capture sessions without any additional configuration on your part.

This chapter provides information about monitoring your network traffic and analyzing the information presented.

This chapter contains the following sections:

- How To Make Dashboards Work for You, page 2-2
- Troubleshooting Application Slowness, page 2-3
- Using Traffic Summary, page 2-4
- Using Response Time Summary, page 2-5
- Using Site Summary, page 2-6
- Using Alarm Summary, page 2-7
- Analyzing Traffic, page 2-9
- Optimizing WAN, page 2-16
- Measuring Response Time, page 2-19
- Analyzing Device Interface and Health Data, page 2-26
- Analyzing Media, page 2-32
- Using the NAM Application Programming Interface, page 2-42
If you want to customize Prime NAM to use more advanced configurations such as sites and filtering, see Customizing Cisco Prime NAM, page 6-1.

How To Make Dashboards Work for You

You can view traffic in a summary view (available from the Monitor menu) which you can then further analyze using the more in-depth analysis view (available from the Analyze menu).

The Monitor dashboards allow you to view graphic depictions of network traffic, application performance, site performance, and alarms at a glance. From there, you can isolate one area, for example an application with response time issues, and then drill down to the Analyze dashboard for further investigation.

The following are some of the configuration tasks that enhance NAM’s ability to provide more traffic details on dashboards:

- Turn on deep application classification to identify applications regardless of the ports on which the applications may be running. To enable deep packet inspection, see Adding More Detail into Dashboard and Application Reports, page 6-53. For example on how to troubleshoot using deep packet inspection, see Troubleshooting Application Slowness, page 2-3.
- To understand how to use filters to easily find information and significantly change what you view in the dashboards, see Filtering Traffic for Viewing on the Dashboards, page B-4 and Filtering Data Using Global Search, page B-5.
- To make your custom application traffic more visible on the dashboards and reports, add HTTP URL or Server IP/Port definitions. See Creating Deeper Visibility Into Application Traffic, page 6-55.

For more details about when or why to use specific dashboards, see How Do I Solve My Problem?, page 2-2.

How Do I Solve My Problem?

This section includes a table that provides various problems you can solve with specific dashboards, as well as what details you might want to know and what dashboards are associated with that data.

<table>
<thead>
<tr>
<th>What Problem Needs Solving</th>
<th>Why Do I Need to Know This</th>
<th>Where to Go</th>
</tr>
</thead>
<tbody>
<tr>
<td>My application is slow</td>
<td>Dashboards provide multiple entry points into data.</td>
<td>Troubleshooting Application Slowness, page 2-3</td>
</tr>
<tr>
<td>My phone quality is poor.</td>
<td>NAM detects and computes Mean Opinion Scores (MOSs) for VoIP calls transported through Real Time Protocol (RTP) streams.</td>
<td>Using Site Summary, page 2-6 see Top N Sites by Average MOS and RTP Streams</td>
</tr>
<tr>
<td>I want more or specific details in my captures</td>
<td>Use various filters to select what gets added in your captures.</td>
<td>Understanding Global Capture Settings, page 3-20 and Configuring Hardware Filters, page 3-9</td>
</tr>
</tbody>
</table>
Chapter 2      Monitoring and Analyzing Traffic

Troubleshooting Application Slowness

This section contains a sample workflow that describes one way to use Prime NAM to help troubleshoot common network slowness.

This example concentrates on how to troubleshoot application performance issues that stem from using common server applications (such as HTTP or Sharepoint).

Tip

This case applies to any instance where an application is suspected of causing network latency.

Before You Begin

NAM assumes that your system time is synchronized. If you do not have the time synchronized between the NAM and the standard time source outside the NAM, then you may see either incorrect data or no data. If you suspect inaccurate timestamps, you need to set up the System Time so that NAM data presentation is accurate. For instructions on how to set system time by choosing Administration > System > System Time, see Synchronizing Your System Time, page 4-5.

To determine what may be causing network slowness for the remote desktop users:

<table>
<thead>
<tr>
<th>What Problem Needs Solving</th>
<th>Why Do I Need to Know This</th>
<th>Where to Go</th>
</tr>
</thead>
<tbody>
<tr>
<td>Is my interface overloaded?</td>
<td>View Analyze &gt; Managed Device &gt; Interface to see list of all interfaces and errors or discards on each interface.</td>
<td>Analyzing Device Interface and Health Data, page 2-26</td>
</tr>
<tr>
<td>I’m seeing a lot of unexpected or excessive applications traffic</td>
<td>This may be tied to the occurrence of multiple Unknown applications (for example, video traffic).</td>
<td>Configuring Application Classification, page 6-52</td>
</tr>
<tr>
<td>I want to identify my homegrown applications</td>
<td>Your traffic visibility into your application can be improved by adding your custom application details so it can be classified.</td>
<td>Creating Deeper Visibility Into Application Traffic, page 6-55</td>
</tr>
<tr>
<td>How do get notified before a problem occurs?</td>
<td>Set up alarms and thresholds to notify you via email.</td>
<td>Setting Up Alarms and Alarm Thresholds, page 6-31</td>
</tr>
</tbody>
</table>

Step 1 To see Layer 7 application details, ensure deep packet inspection is enabled. This is the system default on new installations. To confirm this setting, choose Setup > Classification > Applications Settings and ensure that the Deep Packet Inspection check box is selected. For more information, see Adding More Detail into Dashboard and Application Reports, page 6-53.

Step 2 Choose Analyze > Application Traffic in order to find the network devices that use a specific protocol or application.

   a. In the Interactive Report Filter select the name of your application (for example, Sharepoint) as the Application option in order to collect network traffic details for that application only. If you do not see your application, you may need to download the latest protocol pack.

   b. You can also customize the time range to ensure that your data collection provides enough data or focuses on specific points of time that have heavy traffic.
If you do not see any data, select a different time range in the filter and submit the search again in order to locate the surge traffic.

**Step 3**  
Use the zoom/pan chart slider at the bottom of the Application Traffic chart in order to focus in on those details that are most important to you.  
Focus on the traffic surges in the chart in order to identify the participating servers and the remote clients.

**Step 4**  
Use the Top Hosts Traffic In and Out charts in order to drill down for more bandwidth details.  

a. Select the server with the most traffic and review the maximum and average bandwidth used by your application in order to pinpoint the source of the issue.  
For the select server, assess the amount of traffic in order to view:  
- A breakdown by each site  
- Conversations by individual users

**Step 5**  
Assess if there is enough capacity on the link connecting the site to the data center in order to determine if this might be part of the problem. Since this is out of this product’s scope, we recommend you use other applications to perform this task.

**Step 6**  
If your network capacity is limited, for example, a 256 Kbps link shared across multiple applications and there is a requirement to support multiple clients, consider the following options:

- Apply a control mechanism, for example Quality of Service policies  
- Upgrade the link so that it can handle a higher bandwidth

---

## Using Traffic Summary

The Traffic Summary Dashboard allows you to view the Top N Applications, Top N Application Groups, Top N Hosts (In and Out), IP Distribution, Top N DSCP, and Top N Encapsulations being monitored on your network. It provides automatic monitoring of traffic from all potential data sources (for example, SPAN, NetFlow, and WAAS). You can get to the Traffic Summary Dashboard by going to **Monitor > Overview > Traffic Summary**.

You can use the Interactive Report on the left to filter the information for a particular Site, Data Source, encapsulations, or reporting time distribution. You can specify just one type of criteria and leave the others blank, or specify all of them. You can also choose to view the rate or cumulative data from the Interactive Report. To set a system preference for bytes instead of bits, go to **Administration > System > Preferences**.

When you log into Prime NAM for the first time, the default view will be the Traffic Summary dashboard, and the top data source is selected by default.

**Table 2-1** provides an at-a-glance summary of the Traffic Summary dashboard. For each chart described below, you can left-click on any colored bar to get to a context menu, with which you can get more detailed information about that item. You can also place your cursor over the colored bar to see the number of bits per second collected or the total bits over the last time interval. To toggle your view from chart to table, select the icon under the table.
### Using Response Time Summary

The NAM software provides response time measurements and various user-experience-related metrics, which are computed by monitoring and time-stamping packets sent from the user to the server providing services. These Application Response Time Metrics are available to view under the Response Time Summary Dashboard (Monitor > Overview > Response Time Summary).

After the NAM is started, these metrics will begin to populate automatically. When you first navigate to Response Time Summary dashboard, the top data source is selected by default. This dashboard shows you performance statistics for site, data source, encapsulation, and a specific amount of time.

### Table 2-1 Traffic Summary At-a-Glance

<table>
<thead>
<tr>
<th>Basics</th>
</tr>
</thead>
<tbody>
<tr>
<td>View top application traffic rate or traffic volume, based on the Interactive Report filter selection (data rate or cumulative, respectively)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chart</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Top N Applications</strong></td>
<td>This chart reports application-level (L7 payload) bits. If you left-click on a colored bar and choose Capture from the context menu, you can start a capture on this data (see Capturing and Decoding Packets, page 3-1 for more information). You can also select other options to view various application traffic details. See Analyzing Application Traffic, page 2-10.</td>
</tr>
<tr>
<td><strong>Top N Application Groups</strong></td>
<td>In the Interactive Report, you can select either rate or cumulative, where rate is the bits per second, and cumulative is the total number of bits.</td>
</tr>
<tr>
<td><strong>Top N Hosts (In and Out)</strong></td>
<td>To get more specific details about the host activity, left-click on the colored bar and make a selection. If you left-click on a colored bar, you can select additional options for host activity data. See Analyzing Host Traffic, page 2-11.</td>
</tr>
<tr>
<td><strong>IP Distribution</strong></td>
<td>Shows the percentages of bits being distributed to IP protocols (for example, IPv4 TCP).</td>
</tr>
<tr>
<td><strong>Top N DSCP</strong></td>
<td>For more detail, hover over the colored bar or left-click to select Details option. See DSCP, page 2-12</td>
</tr>
<tr>
<td><strong>Top N Encapsulations</strong></td>
<td>In the Interactive Report, you can select a VLAN and filter specific encapsulation protocols from within this chart (including OTV, VxLAN, LISP, and others). You can also narrow your data by filtering on certain time ranges. The default time range is 15 minutes. See Encapsulation, page 2-13.</td>
</tr>
</tbody>
</table>

---

To change from bits to bytes, choose Administration > System > Preferences and change the Data displayed in selection.

To see a chart in table format, use the Show Chart/Show Table toggle buttons on the bottom left corner of the chart.

When viewing the data as a Grid, the numbers are formatted according to what you have configured in Administration > System > Preferences. On that page, you can also configure the number of Top N entries you would like to display.
Use the Interactive Report window on the left side of the window to change the parameters for the information displayed. To see a chart in table format, use the Show Chart / Show Table toggle button on the bottom right corner of the chart.

The dashboard charts will show you the following information:

- **Top N Applications by Transaction Time**
  This chart displays the server response times for the applications in the site, data traffic source, VLAN, or site clients or servers you selected in the Interactive Report window. For example, a selection `http` would show you the average response time of HTTP servers seen in the traffic category you have selected in the Interactive Report window. The data displays in microseconds (µ), milliseconds, or seconds depending on your preference settings.

- **Top N Site-to-Site Network Time**
  This chart displays the top network time between the client site and the server site in the category you selected. The data displays in microseconds (µ), milliseconds, or seconds depending on your preference settings.

- **TOP N Server-Applications by Server Response Time**
  This chart allows you to see how well servers perform, by showing you the server that has the longest response time (the item appearing at the top). The data displays in microseconds.

- **TOP N Servers by Traffic Rate (In + Out)**
  This chart displays the total bits or rate of traffic for the top servers. You can choose to display NAM data in either Bits or Bytes in the Preferences (accessed by choosing Administration > System > Preferences).

- **TOP N Client-Applications by Transaction Time**
  This chart displays the transaction time per client. The client with the highest response time appears on top. The data displays in microseconds (µ), milliseconds, or seconds depending on your preference settings.

- **Top N Clients by Traffic Rate (In + Out)**
  This chart displays the total bits or rate of traffic for the top clients.

### Using Site Summary

The Site Summary Dashboard (accessed by choosing Monitor > Overview > Site Summary) shows you information about the sites in your network. You can use the Interactive Report on the left side of the window to change the information displayed. For more information about sites, see Configuring Sites, page 6-47.

The charts displayed on the Site Summary dashboard are:

- **Top N Sites by Average Transaction Time**
  This chart shows the average transaction time by site.

- **TOP N Application Traffic by Site to Site**
  This chart shows top site to site traffic.

- **TOP N Worst Site to Site by Average MOS**
  This chart shows sites that have the highest average Mean Opinion Score (MOS).
MOS normally ranges from 1-5, denoting the perceived quality of the transmission, where 1 is the lowest perceived quality, and 5 is the highest perceived quality measurement. The MOS is weighted depending on the duration.

- **Top N Sites by Traffic**
  This chart shows the sites that have the most traffic (which are the most active). It is a total of all the traffic sent or received for hosts that belong to the particular site, which means that this traffic includes intra-site traffic as well.

To see any of the charts in table format, use the Show Chart / Show Table toggle button on the bottom right corner of the chart.

### Using Alarm Summary

The Alarm Summary Dashboard (accessed by choosing Monitor > Overview > Alarm Summary) will show you the top alarms occurring in the network.

To display network traffic information for a particular amount of time, use the Interactive Report on the left side of the window. The Severity Selector in the Interactive Report allows you to choose to view high severity alarms only, low severity alarms only, or both high and low severity alarms (these settings are configured under Setup > Alarms > Thresholds). You can also choose the desired amount of time from the Time Range drop-down menu, or you can customize the time range.

On any chart on the Alarm Summary Dashboard, you can click on a colored bar to see the Context menu, with which you can get more information.

If you do not set any alarms or thresholds, the Alarm Summary Dashboard will not display any data. For information on setting up alarms and thresholds, see Setting Up Alarms and Alarm Thresholds, page 6-31.

You could see a count of two alarms for the same occurrence if:

- both the source and the destination are in the same site in the Top N Site - Host Pair chart.
- both the source and the destination are in the same site in the Top N Site chart.
- both the source and the destination are in the same site using the same application in the Top N Site - Application Pair chart.

**Note**

You will not have any data in Top N Site - Application and Top N Application if there is no threshold configured that involves an application (for example: Response Time threshold or Application threshold).

NetFlow Interface alarms are not related to any site; therefore, they will not appear on the four colored site alarm charts on the Alarm Summary dashboard. Instead, the New Alarms Raised and Last 50 Alarms tables at the bottom of this window will contain NetFlow Interface alarms raised.

The five charts displayed on the Alarm Summary dashboard are:

- **Top N Sites by Alarm Count**
  This chart lists the top sites that have the most alarm triggers during the selected time range. The number of sites displays based on the maximum number you set in preferences. If no thresholds are configured, this chart contains no data. The number on the bottom of the chart is the alarm count.
  You can configure thresholds under Setup > Alarms > Thresholds. You can configure the Top N entries under Administration > System > Preferences.

- **Top N Hosts by Site and Alarm Count**
This chart shows the number of alarm messages during the selected time range that are triggered for Hosts across all sites, by the Site - Host Pair.

- **Top N Applications by Alarm Count**
  This chart shows the number of alarms during the selected time range for Applications across all sites.

- **Top N Applications by Site and Alarm Count**
  This chart shows the most alarm triggers during the selected time range by the application and site pair.

- **New Alarms Raised**
  The New Alarms Raised table shows you all alarms that occurred during the interval selected in the Interactive Report window. Some alarms may have been triggered outside of the time period, but may still be occurring.

- **Last 50 Alarms**
  The Last 50 Alarms table shows you the alarms that occurred during the interval selected in the Interactive Report window. Some alarms may have been triggered outside of the time period, but may still be occurring. See Table D-46.
  Click **All Alarms** to display a separate window, which shows all the alarms from that particular time interval.
  You can also use the Filter button, both in this window and the All Alarms window, to display only alarms that meet the criteria you enter.

---

**Utilizing Sites to Create a Geographically- or Organizationally-Familiar Deployment**

In Prime NAM you can define a site, which enables you to aggregate and organize performance statistics. If you want to limit the view of your network analysis data to a specific city, a specific building, or even a specific floor of a building, you can use the sites function.

Figure 2-1 shows a centralized NAM deployment analyzing multiple data sources from different locations in the network.
For this deployment, multiple sites can be created such as SanJose-Campus, SanJose-Datacenter, NewYork-NetFlow-Bldg1, and NewYork-WAAS-Bldg2. The data that does not match the site configuration will be displayed in the Default site. This helps to isolate the view and information for monitoring and troubleshooting so you can drill down to the specific area of interest.

You can also include multiple types of data sources in the site definition, and you can then get an aggregated view of all network traffic.

The predefined Unassigned Site makes it easy to bring up a NAM without having to configure user-defined sites. Hosts that do not belong to any user-defined site will automatically belong to the Unassigned Site.

You can create, view, or edit your sites by selecting Setup > Network > Sites. Unassigned sites cannot be changed.

The interactive dashboard can be used to drill down into either San Jose or New York sites to see Top applications, hosts, Encapsulations, DSCP, and application response time.

From each of the charts in the dashboard, you can access the context menu to further drill down to analyze data such as detailed application, host, and conversation traffic.

**Analyzing Traffic**

Prime NAM offers many ways to analyze your network traffic data using graphs, charts, and detailed views.

Use the links below to locate information about:

- Analyzing Site Traffic, page 2-10
- Analyzing Application Traffic, page 2-10
- Analyzing Host Traffic, page 2-11
- NetFlow Interface Traffic Analysis, page 2-11
- DSCP, page 2-12
- Encapsulation, page 2-13
- URL Hits, page 2-13
Analyzing Site Traffic

To show you the traffic level for a given site over a selected period of time:

<table>
<thead>
<tr>
<th>Step</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Choose Analyze &gt; Traffic &gt; Site.</td>
</tr>
<tr>
<td>Step 2</td>
<td>To change the data to see the top application traffic coming into a specific site, out of a specific site, or all traffic within, coming in and moving out of that site, use the traffic selector buttons.</td>
</tr>
<tr>
<td>Step 3</td>
<td>To see site conversations about the conversation between sites to pinpoint specific applications or sites, select the Site Conversations button and choose filters from the Interactive Report to further pinpoint an application, data source, or time frame in question.</td>
</tr>
<tr>
<td>Step 4</td>
<td>To view top applications transmitting and receiving traffic for the selected time period and drill down to collect more data utilizing capture data, real-time graphs, and application group detail, left click the Top N Application dashboard.</td>
</tr>
<tr>
<td>Step 5</td>
<td>To see the criteria by which the NAM classifies the amount of application traffic on this site over this period of time, use the view Application Distribution graph. Hover over graph parts to view detailed information on speed and percentages or left-click a graph element for other menu options.</td>
</tr>
</tbody>
</table>

Analyzing Application Traffic

To show you the traffic level for a given application over a selected period of time:

<table>
<thead>
<tr>
<th>Step</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Choose Analyze &gt; Traffic &gt; Application.</td>
</tr>
<tr>
<td>Step 2</td>
<td>To see data for a different time interval (when No data for select time interval displays), click Filter on the Interactive Report, and expand the time range to allow more data to be viewed.</td>
</tr>
<tr>
<td>Step 3</td>
<td>To focus in on a spike or area of interest, use the slider under the Application Traffic graph. Hover over the data points to see specific traffic details.</td>
</tr>
<tr>
<td>Step 4</td>
<td>To see top application traffic details, click Top Application Traffic and choose filters from the Interactive Report to further pinpoint a data source, encapsulation method, or time frame in question.</td>
</tr>
<tr>
<td>Step 5</td>
<td>To view top hosts transmitting and receiving traffic for the selected time period and drill down to collect more data utilizing capture data, real-time graphs, and application group detail, left-click a Top N Hosts graph element and select a specific task.</td>
</tr>
<tr>
<td>Step 6</td>
<td>For example, select Hosts Detail to see the All Hosts window and the detailed information about all hosts. Table D-44 describes the fields in this window.</td>
</tr>
<tr>
<td>Step 7</td>
<td>To show the criteria by which the NAM classifies packets as that application, select one of the options under the Application Configuration. This is typically a list of TCP and/or UDP ports that identify the application. Some applications are identified by heuristic or other state-based algorithms. You can select Configure Application to configure specific applications in your network. For detailed instructions, see Creating Deeper Visibility Into Application Traffic, page 6-55.</td>
</tr>
</tbody>
</table>
Analyzing Host Traffic

The Host Traffic Analysis window will show you at a quick glance the input and output of a particular host over a specified time range. It is available under the menu option Analyze > Traffic > Host. It will show you:

- Input and output traffic for the host
- Top N application activity of the host over the selected interval
- Total application usage distribution for the host
- Host Conversations—Shows detailed lists of all the conversations for a particular host.

Applications Detail

On the Top N Applications chart, you can left-click a colored bar to get the context menu, and choose Applications Detail to see the All Applications window and the detailed information about all applications. You can also choose Analyze Host Traffic from the context menu to see the host dashboard and analyze the host traffic for the selected application using Over Time chart. Table D-37 describes the fields in the Applications Detail window.

NetFlow Interface Traffic Analysis

To view data collected for individual interfaces on a switch or router that is exporting NetFlow packets to the NAM, use the NetFlow Interface Analysis page. The displayed information represents the total data collected since the collection was created, or since the NAM was restarted.

Before You Begin

1. Ensure Auto-create is enabled for the NetFlow Data Export (NDE) data source. Once NDE data is sent to the NAM, an NDE data source is created.

2. Edit the NDE data source to enter SNMP credential information that allows the NAM to properly query the router/switch interface information. Go to Setup > Traffic > NAM Data Sources. For more information, see Creating NetFlow Data Sources Using the Web GUI, page 6-17 or Creating NetFlow Data Sources Using the CLI, page 6-18

3. Go to NetFlow Interface Capacity page (Setup > Network > NDE Interface Capacity) to ensure all information is populated.

To view NetFlow Interface Analysis:

Step 1  Choose Analyze > Traffic > NDE Interface. The default view is Interface View.

Step 2  Select an interface from the Interface Selector to see traffic in the charts. Click the arrow icon to the left of the NetFlow data source name to display all interfaces, and then select an interface to see data for that interface.

When you go to the Group View tab, you see all interfaces and NetFlow data sources grouped into two static groups. You can select combinations of interfaces from each group and click Submit, and the charts on the right will sum up the metrics and display them for each group.
Note
If the charts show no data, and you see a message “Interface needs to be selected,” you have not yet chosen an interface.

NetFlow flow record must include source/destination addresses, source destination ports, protocol, input and output SNMP interface if-indices, octet count, and packet count. NAM discards flow records that do not meet this requirement.

NetFlow only takes into account of IP and its payload. Anything that is before the IP layer will not be counted toward the packet and octet count.

Once you have chosen the interface, you will see the following charts populated:

- Interface Traffic (Ingress % Utilization and Egress % Utilization)
- Top N Applications - Ingress
- Top N Applications - Egress
- Top N Hosts - Ingress
- Top N Hosts - Egress
- Top N DSCP Aggr - Ingress
- Top N DSCP Aggr - Egress

The interface speed can be entered manually through the Interface capacity table, or it can be auto configured if the SNMP settings for the NetFlow device are entered in data source table.

DSCP Detail

On the Top N DSCP Aggr - Ingress and Top N DSCP Aggr - Egress chart, left-click a colored bar to get the context menu. Choose DSCP Detail to see the All DSCP window. You can also get to this window by choosing Analyze > Traffic > DSCP Traffic from the menu and clicking the All DSCPs button on the right.

Table D-43 describes the fields in the All DSCP window.

DSCP

Differentiated services monitoring (DiffServ) is designed to monitor the network traffic usage of differentiated services code point (DSCP) values.

To monitor DSCP groups, you must configure at least one aggregation profile and one or more aggregation groups associated with each profile. For more information on configuring an aggregation profile, see Configuring DSCP Groups, page 6-51.

You can monitor the DSCP information by going to Analyze > Traffic > DSCP. The data provided to you includes:

- Traffic volume over time for DSCP group
- Top N applications and application groups using that DSCP group
- Top N hosts transmitting and receiving traffic on that DSCP group
Encapsulation

You can analyze the encapsulation traffic collected by Prime NAM (for setup, see Filtering Encapsulations, page 6-60). This section contains the following use cases:

- Viewing Collected Encapsulation Data—see Viewing Collected URLs, page 2-13
- Filtering Various Encapsulations—see Filtering a URL Collection List, page 2-13

URL Hits

You can analyze the URLs collected by the NAM (for setup, see Configuring URL Collections, page 6-64).

The URL hits helps you to determine the URLs that are used in the network and then see what applications are affiliated with those URLs.

This section contains the following topics:

- Viewing Collected URLs
- Filtering a URL Collection List

Viewing Collected URLs

To view collected URLs and optionally create URL-based custom applications, follow these steps:

**Step 1** Choose Analyze > Traffic > URL Hits.

The URL Hits Window displays the collected URLs.

**Note** Only one URL collection can be active at one time. The data source is for information only.

**Step 2** To create a URL-based custom application, click Create URL-Based Application.

For details on the URL-Based Applications window, see Table D-29.

Filtering a URL Collection List

To filter a URL collection list:

**Step 1** From the drop-down list in the URLs Window (Analyze > Traffic > URL Hits), choose which part of the URL to filter:

- **URL**—You can filter on any part of the URL
- **Host**—This filter applies only to the host part of collected URLs.
- **Path**—This filter applies only to the path part of the collected URLs
- **Arguments**—This filter applies only to the argument part of the collected URLs

**Step 2** Enter filter string.

**Step 3** Click Filter to apply the filter.
Note
To remove any display filter and show all URLs collected, click Clear.

Detailed Traffic Analysis Views

Prime NAM offers several detailed traffic analysis views which allow you to analyze the following data:

- Sites Detailed Views, page 2-14
- Site Conversations Detailed Views, page 2-14
- Applications Detailed Views, page 2-14
- Application Groups Detailed Views, page 2-14
- Application Traffic By Hosts Detailed Views, page 2-15
- Top Application Traffic Detailed Views, page 2-15
- Hosts Detailed Views, page 2-15
- Host Conversations Detailed Views, page 2-15
- Encapsulations Detailed Views, page 2-15
- DCSPs Detailed Views, page 2-16

Sites Detailed Views

Displays data for each site (including all unassigned sites) and see packet per second and bits per second details. Use the Interactive report filter to pinpoint specific attributes. There are no filter time limits for this data.

Site Conversations Detailed Views

Displays site traffic for all or selected sites. To pinpoint site traffic data between two devices, select the Interactive Report Filter.

Applications Detailed Views

To view the All Applications window and the detailed information about all application and filter on specific applications or other filter attributes, use the Interactive Report filter.

Application Groups Detailed Views

To see the All Application Groups window and the detailed information about all application groups, left-click a colored bar on the Top N Application Groups chart to get the context menu, and choose Applications Groups Detail. Table D-38 describes the fields in the All Applications window.
Chapter 2      Monitoring and Analyzing Traffic

Analyzing Traffic

Application Traffic By Hosts Detailed Views

Shows the traffic for a given application broken out by individual hosts using the application. You may specify the time period to view, as well as the application, site (optional), data source (optional), and VLAN (optional).

The NAM only supports a maximum Time Range of one hour filter for the Host Conversations, RTP Streams, Voice Calls Statistics, Calls Table, and RTP Conversations.

Top Application Traffic Detailed Views

Shows the top applications by traffic rate over a selected time and for the specified site and/or data source.

Top Application Traffic Detailed Views shows you all of the applications that have been running for the time period interval. The color-coded legend shows you what the applications are running.

The Display Other check box (which is underneath the Top Application Traffic heading) corresponds to the data for the applications not in the N list. If you check this check box, the chart will display the Other data in addition to the data for the N number of applications.

If you place your cursor over any of the data points, you will get more details about the exact values for each of the applications that are running.

Hosts Detailed Views

Shows the input and output of a particular host over time. Use the Filter button in the Interactive Report (left side of the window) to change the parameters of the information displayed.

Host Conversations Detailed Views

Shows detailed lists of all the conversations for a particular host.

You can view the following data:

• A table of hosts that sends and receives packets to the selected host, along with application, encapsulation, and traffic rate information.
• A breakout of application usage for the selected host. You can view the application usage table, when you select the required host from the filter only.
• A Top N Application Traffic Stacked Chart for the selected hosts. The application usage table is replaced with this chart, when you select both the required and optional hosts from the filter.

Use the Filter button in the Interactive Report (left side of the window) to change the parameters of the information displayed.

The NAM only supports a maximum time range of one hour filter for the Host Conversations, RTP Streams, Voice Calls Statistics, Calls Table, and RTP Conversations.

Encapsulations Detailed Views

To show a detailed analysis of the various encapsulation layers, bits, and packet data, choose Analyze > Traffic > Detailed Views > Encapsulations.

Use the Filter button in the Interactive Report to change the information displayed and target data.
DCSPs Detailed Views

The DSCP detailed views show a detailed analysis of all the network traffic usage of differentiated services code point (DSCP) values, choose Analyze > Traffic > Detailed Views > DSCPs.

Use the Filter button in the Interactive Report to change the information displayed and target data.

For details about setting your TOS key and the implications of doing so, see Customizing System Preferences, page 4-12.

About Analyze Traffic Charts

The charts available under the Analyze menu show statistics that occur over time. You can use the Zoom/Pan feature, with which you can drag the beginning or end to change the time interval or distribution.

The time interval change on the zoom/pan chart will affect the data presented in the charts in the bottom of the window. The zoom/pan time interval also affects the drill down navigations; if the zoom/pan interval is modified, the context menu drill downs from that dashboard will use the zoom/pan time interval.

Note: In a bar chart which you can zoom/pan, each block represents data collected during the previous interval (the time stamp displayed at the bottom of each block is the end of the time range). Therefore, you may have to drag the zoom/pan one block further than expected to get the desired data to populate in the charts in the bottom of the window.

Optimizing WAN

Prime NAM can provide insight into WAN Optimization offerings that compress and optimize WAN traffic for pre- and post-deployment scenarios. This is applicable for optimized and passthru traffic.

WAN Optimization tasks include:

- Ensuring WAN Optimization, page 2-16
- Analyzing Traffic for Optimization Using the Top Talkers Detail, page 2-17
- Analyzing Application Performance after WAAS Optimization, page 2-18
- Monitoring WAAS Traffic Across Multi-Segments, page 2-18
- Monitoring WAAS Single-Segment Traffic, page 2-19

Note: To monitor the WAAS data, you must select the correct WAAS data source.

Ensuring WAN Optimization

In order to ensure that your applications are performing optimally and your WAN is optimized:

Step 1: To identify sites with application performance challenges, choose Monitor > Site Summary.
If you do not have sites identified, you can use the Unknown site category or to learn about how to create sites, see Configuring Sites, page 6-47.

**Step 2**  
Look for sites with the highest average transaction time and highest traffic rate.

**Step 3**  
To quantify the application performance:


b. Set up a filter that targets key areas such as a specific location and different time ranges (one day and one week). This allows you to focus in on exactly the data you want to analyze.

c. Right-click the application with the highest server response time and choose Analyze Application Response Time.

d. Specify a filter time range using the Interactive Filter. We recommend viewing data over a one day range to allow for possible peak times.

e. Identify applications with poor performance and quantify the response time by network time, server response time, and data transfer time.

**Step 4**  
To validate the impact of WAN optimization:

a. Choose Analyze > WAN optimization > Application Performance Analysis.

b. Minimize WAN Opt Impact analysis filter (on the left pane).

c. View the effect of optimizing one of your applications (for example, to determine if your HTTP browser has lower transaction times and thus better end-client experience, lower compression ratios for better utilization of the WAN, and fewer average concurrent connections for better utilization of server through connection reuse).

**Step 5**  
To perform ongoing monitoring of WAN optimization and troubleshoot WAN optimized traffic:

a. Choose Analyze > Conversation Multi Segment.

b. View a detailed breakdown of latency and bandwidth measures for the server, WAN, and client network segments.

---

**Analyzing Traffic for Optimization Using the Top Talkers Detail**

While you are in the process of deploying WAAS devices, you can get data to assist in the WAAS planning and configuration.

This window allows you to display response time and concurrent connections for the top Application, Network Links, Clients, and Servers from WAN data sources before WAAS optimization.

To analyze traffic for optimization using the Top Talkers Detail:

**Step 1**  
Choose Analyze > WAN Optimization > Top Talkers Detail and filter data using the Interactive Report window to select the traffic you want to analyze for optimization.

If the data source is from SPAN or WAAS, it does not include the packet header; if the data source is NetFlow, it will include the packet header.

**Note**  
You can choose to display NAM data in either Bits or Bytes in Administration > System > Preferences.
Based on the results, you can then configure the WAAS products to optimize your network.

Analyzing Application Performance after WAAS Optimization

WAN optimization allows you to display response time, concurrent connections, traffic volume and compression ratio from WAN data sources after WAAS optimization. To analyze the WAAS traffic, choose **Analyze > WAN Optimization > Application Performance Analysis**.

The tasks associated with this analysis include:

- **Comparing Transaction Time (Client Experience)**, page 2-18
- **Comparing Traffic Volume and Compression Ratio**, page 2-18
- **Planning Capacity Using Average Concurrent Connections (Optimized vs. Passthru)**, page 2-18
- **Optimizing Usage Using Multi-Segment Network Time (Client LAN - WAN - Server LAN)**, page 2-18

Comparing Transaction Time (Client Experience)

To compare client transaction time, choose **Analyze > WAN Optimization > Application Performance Analysis** and using this chart. It displays the average client transaction time. One line represents pass-through traffic (in which optimization is turned off), and the second represents optimized traffic. After setting up optimization for a certain period, you can compare the two lines and see where the vertical drop in the chart occurs. Depending on your Response Time Display unit preference setting, the data may display in microseconds, milliseconds, or seconds.

Comparing Traffic Volume and Compression Ratio

You can compare the bandwidth reduction ratio between the number of bits before compression and the number of bits after compression using this chart.

Planning Capacity Using Average Concurrent Connections (Optimized vs. Passthru)

You can use the number of concurrent connections during a specified time to assist with peak and off-period identification. This information can be used for capacity planning.

Optimizing Usage Using Multi-Segment Network Time (Client LAN - WAN - Server LAN)

You can use the network time between the multiple segments to identify lagging performance issues. The data is shown in microseconds.

Monitoring WAAS Traffic Across Multi-Segments

To monitor WAAS traffic across multiple segments use the Conversation Multiple Segments window. This window provides a correlation of data from different data sources, and allows you to view and compare response time metrics from multiple WAAS segments (data sources). You can access this window from **Analyze > WAN Optimization > Conversation Multi-segments**.
The window shows network time, server response time, and other metrics of the selected server or client-server pair from applicable segments. The relevant metrics from all segments are combined into one row per client-server conversation.

**Monitoring WAAS Single-Segment Traffic**

To monitor WAAS traffic across a single segment use the data in the Conversation Single-Segments window to see data from different data sources, and view and compare response time metrics from different WAAS segments (data sources). You can access this window from **Analyze > WAN Optimization > Conversation Single-Segment**.

The window shows network time, server response time, and other metrics of the selected server or client-server pair (one row per segment).

**Measuring Response Time**

The NAM monitors TCP packet flow between client and server, and measures response time data to provide more visibility into application response times (ART) and network latency. Prime NAM response time monitoring provides end-to-end response times to help you locate possible network and application delays.

- **Note**
  
  Prime NAM software supports IPv6 for response time monitoring.

NAM application response time requires both way TCP connections. In general, it is best to SPAN the physical interface with BOTH direction. If VLAN is desired, use either RX or TX. See the SPAN source product documents for SPAN limitations.

You can set up the NAM to measure network time, client response time, server response time, and the total transaction time to improve application performance. **Figure 2-2** shows the various points in network packet flow where the NAM gathers data and the trip times you can monitor. This is one example that represents only a subset of measurements.
Figure 2-2  
*NAM Application Response Time Measurements*

![Diagram of NAM Application Response Time Measurements]

**Figure 2-3** shows a representation of total transaction time as opposed to application response time.

**Figure 2-3  Transaction Time versus Response Time Measurements**

![Diagram of Transaction Time versus Response Time Measurements]

Table D-39 lists and describes the ART metrics measured by Prime NAM.

Application Response Time Metrics are available on the response Response Time Summary Dashboard (Monitor > Response Time Summary), which allows you to see a summary view of the data.

To analyze Response Time data over time, use the following selections that fall under the Response Time window:

- Application Response Time, page 2-21
- Network Response Time, page 2-21
- Server Response Time, page 2-22
- Client Response Time, page 2-22
- Client-Server Response Time, page 2-23
To view the detailed lists for the response events, choose Analyze > Response Time > Detailed Views. This section covers the following topics:

- Application Response Time Distribution, page 2-23
- Network Response Time Distribution, page 2-23
- Server Response Time Distribution, page 2-23
- Client Response Time Distribution, page 2-23
- Client-Server Response Time Distribution, page 2-24
- Server Application Responses, page 2-24
- Server Application Transactions, page 2-24
- Server Network Responses, page 2-24
- Client-Server Application Responses, page 2-25
- Client-Server Application Transactions, page 2-25
- Client-Server Network Responses, page 2-25

### Application Response Time

The Application Analysis window allows you to view the performance of a particular application over time. The ART can be accessed by choosing Analyze > Response Time > Application.

The Transaction Time chart shows you the average total transaction time for the application you have selected and contains the following three components:

- Network Time
- Server Response Time
- Data Time

The Other Metrics chart allows you to see information over time after you have selected the desired metrics from the Metric Group 1 and Metric Group 2 drop-down.

Next are the Top Clients and Top Servers charts. These show you the clients and servers with the most bits of traffic for the chosen application.

**Note** You can choose to display NAM data in either Bits or Bytes in Administration > System > Preferences.

Application Response Time Distribution bar chart shows the response of the chosen application for various time distribution range. To drill down for further response time distribution analysis, click Application Response Time Distribution from the context menu of the bar chart. The average total transaction time, top clients and servers for the selected distribution range is displayed.

### Network Response Time

After you have selected a client site and a server site, the Network Response Time chart shows you the transaction time of the network link between the client site and server site. You can access the Network Response Time by choosing Analyze > Response Time > Network.
Measuring Response Time

Note

If you do not specify any application, the chart shows the network time instead of transaction time.

The Other Metrics chart allows you to see information about the network link between sites, after you have selected the desired metrics from the Metric Group 1 and Metric Group 2 drop-down.

The Top Clients and Top Servers charts show you the top clients and servers that are communicating through the network link (in bits or bytes).

The Network Response Time Distribution bar chart shows the response of the network link between the chosen client and server sites, for various time distribution range. To drill down for further response time distribution analysis, click Network Response Time Distribution from the context menu of the bar chart. The average total transaction time, top clients and servers for the selected distribution range is displayed.

Server Response Time

You can choose the Client Site and Server Site from the Interactive Report, and enter the IP address for the server that you want to analyze. The Total Transaction Time Composition chart displays the network time, server response time, data time, and the transaction time.

The Other Metrics chart allows you to see information about the server performance after you have selected the desired metrics from the Metric Group 1 and Metric Group 2 drop-down.

Top Client shows you top client talking to the server you have selected; Server Top Clients Sites shows the top client sites (traffic bits).

Note

You can choose to display NAM data in either Bits or Bytes in Administration > System > Preferences.

The Server Response Time Distribution bar chart shows the response of the chosen server for various time distribution range. To drill down for further response time distribution analysis, click Server Response Time Distribution from the context menu of the bar chart. The average total transaction time, server’s top clients and server’s top client sites for the selected distribution range is displayed.

Client Response Time

You can analyze the transaction time of that client in the Total Transaction Time Composition chart, after entering the client IP address and application in the Interactive Report Filter.

The Other Metrics chart allows you to see client performance over time after you have selected the desired metrics from the Metric Group 1 and Metric Group 2 drop-down.

The Clients Top Applications chart show you the applications being used the most by the client selected, and the Top Servers chart show you the servers being used most by the client.

The Client Response Time Distribution bar chart shows the response of the chosen client for various time distribution range. To drill down for further response time distribution analysis, click Client Response Time Distribution from the context menu of the bar chart. The average total transaction time, client’s top applications and client’s top servers for the selected distribution range is displayed.
Client-Server Response Time

You can analyze the transaction times between the client and server you have selected in the chart, after entering the client IP address and application in the Interactive Report Filter.

The Other Metrics chart allows you to see Client-Server transaction information after you have selected the desired metrics from the Metric Group 1 and Metric Group 2 drop-down.

The Client-Server Response Time Distribution bar chart shows the response of the chosen client and server for various time distribution range. To drill down for further response time distribution analysis, click Client-Server Response Time Distribution from the context menu of the bar chart. The average total transaction time for the selected distribution range is displayed.

Application Response Time Distribution

You can choose Analyze > Response Time > Detailed Views > Application Response Time Distribution to display the Application Response Time Distribution window.

From the Interactive Report filter, select the application and the distribution range. The average total transaction time, top clients and servers for the selected distribution range is displayed.

Network Response Time Distribution

You can choose Analyze > Response Time > Detailed Views > Network Response Time Distribution to display the Network Response Time Distribution window.

From the Interactive Report filter, select the client site, server site and the distribution range. The average total transaction time, top clients and servers for the selected distribution range is displayed. This distribution helps you to identify the problematic transactions and the associated client and server.

Server Response Time Distribution

You can choose Analyze > Response Time > Detailed Views > Server Response Time Distribution to display the Server Response Time Distribution window.

In the Interactive Report filter, enter the IP address for the server that you want to analyze, and select the distribution range. The average total transaction time, server’s top clients and server’s top client sites for the selected distribution range is displayed.

Client Response Time Distribution

You can choose Analyze > Response Time > Detailed Views > Client Response Time Distribution to display the Client Response Time Distribution window.

In the Interactive Report filter, enter the IP address for the client that you want to analyze, and select the distribution range. The average total transaction time, client’s top applications and client’s top servers for the selected distribution range is displayed.
Client-Server Response Time Distribution

You can choose Analyze > Response Time > Detailed Views > Client-Server Response Time Distribution to display the Client-Server Response Time Distribution window.

In the Interactive Report filter, enter the IP address of the client and server that you want to analyze, and select the distribution range. The average total transaction time for the selected distribution range is displayed.

Server Application Responses

You can choose Analyze > Response Time > Detailed Views > Server Application Responses to display the Server Application Responses window.

If you click on a row of data, you can then choose Response Time Details to see more information. Table D-47 provides definitions of each field of the Server Application Responses window.

Server Application Transactions

You can choose Analyze > Response Time > Detailed Views > Server Application Transactions to display the Server Application Transactions window.

The Server Application Transactions window provides a summary of the server application transaction response times (ART) per server application displaying the server IP address, application used, and minimum, average, and maximum response times for the following:

- Application Response Time
- Data Transfer Time
- Retransmit Time
- Round Trip Time

Note

NAM uses the TCP three-way handshake to calculate network delay. If there are no new TCP connections during the polling interval, the NAM GUI displays a dash (-) for the delay value indicating there is no delay data for that interval.

Table D-48 provides definitions of each field of the Server Application Transactions window.

Server Network Responses

You can choose Analyze > Response Time > Detailed Views > Server Network Responses to display the Server Network Responses window. The Server Network Responses window shows the network connectivity and responsiveness between the server and the switch.

Note

NAM uses the TCP three-way handshake to calculate network delay. If there are no new TCP connections during the polling interval, the NAM GUI displays a dash (-) for the delay value indicating there is no delay data for that interval.
Table D-49 provides definitions of each field of the Server Network Response Times window.

**Client-Server Application Responses**

To view the Client-Server Application Responses window, choose Analyze > Response Time > Detailed Views > Client-Server Application Responses.

The Client-Server Application Responses window displays. Table D-40 provides definitions of each field of the Client-Server Application Responses window.

---

**Note**

NAM uses the TCP three-way handshake to calculate network delay. If there are no new TCP connections during the polling interval, the NAM GUI displays a dash (-) for the delay value indicating there is no delay data for that interval.

---

**Client-Server Application Transactions**

The Client-Server Application Transactions window provides a summary of the server application transaction response times (ART) per server application displaying the server IP address, application used, and minimum, average, and maximum response times for the following:

- Application Response Time
- Data Transfer Time
- Retransmit Time
- Round Trip Time

---

**Note**

NAM uses the TCP three-way handshake to calculate network delay. If there are no new TCP connections during the polling interval, the NAM GUI displays a dash (-) for the delay value indicating there is no delay data for that interval.

The Client-Server Application Transaction window displays when you click Analyze > Response Time > Detailed Views > Client-Server Application Transactions. You can also view the TopN Chart to view the most active network.

Table D-41 provides definitions of each field of the Client-Server Application Transactions window.

---

**Client-Server Network Responses**

The Client-Server Network Responses window shows information about network connectivity (also known as network flight time) between servers and clients.

To view the Client-Server Network Responses window, choose Analyze > Response Time > Detailed Views > Client-Server Network Responses.

NAM uses the TCP three-way handshake to calculate network delay. If there are no new TCP connections during the polling interval, the NAM GUI displays a dash (-) for the delay value indicating there is no delay data for that interval.

Table D-42 describes the fields of the Server-Client Network Response Time window.
Analyzing Device Interface and Health Data

You can view interface information and system health data using the Analyze > Managed Device window. The menu selections for analyzing Managed Devices are:

- Viewing Interface Information, page 2-26
- Viewing Health Data, page 2-26

Viewing Interface Information

You can view the following interface information:

- Interfaces Stats Table, page 2-26
- Interface Statistics Over Time, page 2-26

Interfaces Stats Table

To view the packet distribution details on the interfaces, choose Analyze > Managed Device > Interface. The Interfaces Stats table displays and shows the total packet distribution on all interfaces. Depending on the interface chosen, the chart below the Interfaces Stats table refreshes with that information.

Use the Interactive Report and the Filter button on the left to change the time range displayed.

The Discards and Errors are measured in packets per second. When you select a VDC below the Interactive Report, the main interface screen will be updated with interfaces that belong to the VDC.

When NAM is not in RISE environment, the VDC selector will not be displayed.

Interface Statistics Over Time

When you select an interface in the Interface Statistics Table, the statistics for that interface updates in the graph below the Interface Statistics Table.

You can check the check boxes for the information you would like to display in the graph:

- Bits: In Bits, Out Bits
- Packets: In Packets (inUcastPkts + inNUcastPkts), Out Packets (outUcastPkts + outNUcastPkts)
- Discards: In Discards, Out Discards
- Errors: In Errors, Out Errors

Note

You can choose to display NAM data in either Bits or Bytes in Administration > System > Preferences.

Viewing Health Data

You can use the NAM to view system health data. To view system health data collected for the switch or router, choose Analyze > Managed Device > Health from the menu.

For more details on the options available in each windows, see:

- Switch Health Options, page 2-27
- Router Health Options, page 2-30
Switch Health Options

For a switch, the Health window is displayed with a drop-down menu that provides the following options:

- Chassis Health, page 2-27
- Chassis Information, page 2-28
- Crossbar Switching Fabric, page 2-29
- Ternary Content Addressable Memory Information, page 2-30

Chassis Health

The Chassis Health window displays two real-time graphs:

- CPU usage
- Backplane Utilization

CPU usage

CPU type

- Usage for last 1 minute (%)
- Usage for last 5 minutes (%)

Backplane Utilization

- Peak %
- Peak Time (For example: Mon October 1 2007, 15:26:55)

The Health window also displays a matrix with the following information:

- Minor Alarm (on, off)
- Major Alarm (on, off)
- Temperature Alarm (on, off)
- Fan Status (other, ok, minorFault, majorFault, unknown)

<table>
<thead>
<tr>
<th>Table 2-2 Chassis Memory Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column</td>
</tr>
<tr>
<td>--------</td>
</tr>
<tr>
<td>Memory Type</td>
</tr>
<tr>
<td>Used</td>
</tr>
<tr>
<td>Free</td>
</tr>
<tr>
<td>Largest Free</td>
</tr>
</tbody>
</table>
## Chassis Information

Table 2-3 describes the Chassis Information window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
<td>Name an administrator assigned to this managed node, this is the node's fully-qualified domain name.</td>
</tr>
<tr>
<td><strong>Hardware</strong></td>
<td>A textual description which should contain the manufacturer's name for the physical entity and be set to a distinct value for each version or model of the physical entity.</td>
</tr>
<tr>
<td><strong>Backplane</strong></td>
<td>The chassis backplane type.</td>
</tr>
<tr>
<td><strong>Supervisor Software Version</strong></td>
<td>The full name and version identification of the system's software operating-system and networking software.</td>
</tr>
<tr>
<td><strong>UpTime</strong></td>
<td>The time (in hundredths of a second) since the network management portion of the system was last re-initialized.</td>
</tr>
<tr>
<td><strong>Location</strong></td>
<td>The physical location of this node.</td>
</tr>
<tr>
<td><strong>Contact</strong></td>
<td>The textual identification of the contact person for this managed node and information on how to contact this person.</td>
</tr>
<tr>
<td><strong>Modem</strong></td>
<td>Indicates whether the RS-232 port modem control lines are enabled.</td>
</tr>
<tr>
<td><strong>Baud rate</strong></td>
<td>The baud rate in bits per second of the RS-232 port.</td>
</tr>
<tr>
<td><strong>Power Supply</strong></td>
<td>Description of the power supply being instrumented.</td>
</tr>
<tr>
<td><strong>Power Supply Type</strong></td>
<td>The power supply source:</td>
</tr>
<tr>
<td></td>
<td>- unknown</td>
</tr>
<tr>
<td></td>
<td>- ac</td>
</tr>
<tr>
<td></td>
<td>- dc</td>
</tr>
<tr>
<td></td>
<td>- externalPowerSupply</td>
</tr>
<tr>
<td></td>
<td>- internalRedundant</td>
</tr>
<tr>
<td><strong>Power Supply Status</strong></td>
<td>The current state of the power supply being instrumented.</td>
</tr>
<tr>
<td></td>
<td>1: normal</td>
</tr>
<tr>
<td></td>
<td>2: warning</td>
</tr>
<tr>
<td></td>
<td>3: critical</td>
</tr>
<tr>
<td></td>
<td>4: shutdown</td>
</tr>
<tr>
<td></td>
<td>5: notPresent</td>
</tr>
<tr>
<td></td>
<td>6: notFunctioning</td>
</tr>
<tr>
<td><strong>Power Redundancy Mode</strong></td>
<td>Power Redundancy Mode:</td>
</tr>
<tr>
<td></td>
<td>The power-supply redundancy mode.</td>
</tr>
<tr>
<td></td>
<td>1: not supported</td>
</tr>
<tr>
<td></td>
<td>2: redundant</td>
</tr>
<tr>
<td></td>
<td>3: combined</td>
</tr>
</tbody>
</table>
Table 2-3  Chassis Information (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power Total</td>
<td>Total current available for FRU usage.</td>
</tr>
<tr>
<td></td>
<td>When Redundancy Mode is redundant, the total current available will be the capability of a power supply with the lesser power capability of the two power supplies.</td>
</tr>
<tr>
<td></td>
<td>When Redundancy Mode is combined, the total current available will be the sum of the capacities of all operating power supplies.</td>
</tr>
<tr>
<td>Power Drawn</td>
<td>Total Current Drawn by powered-on FRUs.</td>
</tr>
</tbody>
</table>

Crossbar Switching Fabric

Table 2-4 describes the Crossbar Switching Fabric information.

Table 2-4  Crossbar Switching Fabric Information

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Crossbar Switching Fabric</td>
<td>Physical and configuration information about the module:</td>
</tr>
<tr>
<td></td>
<td><strong>Active slot</strong>—Indicates the slot number of the active switching fabric module. A value of NONE indicates that the active switching fabric module is either powered down or not present in the chassis.</td>
</tr>
<tr>
<td></td>
<td><strong>Backup slot</strong>—Indicates the slot number of the backup switching fabric module. A value of NONE indicates that the backup switching fabric module is either powered down or not present in the chassis.</td>
</tr>
<tr>
<td></td>
<td><strong>Bus Only Mode Allowed</strong>—Determines the value of each module. If set to True, each and every module is allowed to run in bus-only mode. If set to False, none of the modules are allowed to run in bus-only mode. (All the non-fabric capable modules will be powered off.) Absence of fabric module results in all the fabric capable modules being powered off.</td>
</tr>
<tr>
<td></td>
<td><strong>Truncated Mode Allowed</strong>—Indicates whether truncated mode is administratively enabled on the device or not.</td>
</tr>
<tr>
<td>Module Switching Mode</td>
<td>Indicates switching mode of the module:</td>
</tr>
<tr>
<td></td>
<td><strong>busmode</strong>—Module does not use fabric. Backplane is used for both lookup and data forwarding.</td>
</tr>
<tr>
<td></td>
<td><strong>crossbarmode</strong>—Module uses the backplane for forwarding decision and fabric for data forwarding.</td>
</tr>
<tr>
<td></td>
<td><strong>dcefmode</strong>—Module uses fabric for data forwarding and local forwarding is enabled.</td>
</tr>
<tr>
<td>Module-Channel</td>
<td>Module slot number</td>
</tr>
<tr>
<td>Module-Status</td>
<td>Status of the fabric channel at the module</td>
</tr>
<tr>
<td>Fabric Status</td>
<td>Status of the fabric channel at the slot</td>
</tr>
<tr>
<td>Speed (MB)</td>
<td>Speed (MB/second) of the module</td>
</tr>
<tr>
<td>Module-Channel</td>
<td>Channel for the module</td>
</tr>
<tr>
<td>In Errors</td>
<td>The total number of error packets received since this entry was last initialized.</td>
</tr>
</tbody>
</table>
**Table 2-4** Crossbar Switching Fabric Information (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Our Errors</td>
<td>The total number of error packets transmitted since this entry was last initialized.</td>
</tr>
<tr>
<td>Dropped</td>
<td>The total number of dropped packets transmitted since this entry was last initialized.</td>
</tr>
<tr>
<td>In Utilization (%)</td>
<td>Input utilization of the channel for the module.</td>
</tr>
<tr>
<td>Out Utilization (%)</td>
<td>Output utilization of the channel for the module.</td>
</tr>
</tbody>
</table>

**Ternary Content Addressable Memory Information**

Shows the Ternary Content Addressable Memory (TCAM) usage information. Table 2-5 lists and describes the TCAM information.

**Table 2-5** Ternary Content Addressable Memory Information

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Security Acl Mask</td>
<td>Indicates that TCAM space is allocated to store ACL masks.</td>
</tr>
<tr>
<td>Security Acl Value</td>
<td>Indicates that TCAM space is allocated to store ACL value.</td>
</tr>
<tr>
<td>Dynamic Security Acl Mask</td>
<td>Indicates that TCAM space is allocated to dynamically store ACL masks.</td>
</tr>
<tr>
<td>Dynamic Security Acl Value</td>
<td>Indicates that TCAM space is allocated to dynamically store ACL values.</td>
</tr>
<tr>
<td>Qos Acl Mask</td>
<td>Indicates that TCAM space is allocated to store QoS masks.</td>
</tr>
<tr>
<td>Qos Acl Value</td>
<td>Indicates that TCAM space is allocated to store QoS value.</td>
</tr>
<tr>
<td>Dynamic Qos Acl Mask</td>
<td>Indicates that TCAM space is allocated to dynamically store QoS masks.</td>
</tr>
<tr>
<td>Dynamic Qos Acl Value</td>
<td>Indicates that TCAM space is allocated to dynamically store ACL values.</td>
</tr>
<tr>
<td>Layer 4 Port Operator</td>
<td>Indicates that TCAM space is allocated for layer 4 port operators purpose.</td>
</tr>
<tr>
<td>Interface Mapping Module</td>
<td>Indicates that TCAM space is allocated for interface mapping purpose.</td>
</tr>
</tbody>
</table>

**Router Health Options**

If your device is a router, the Router Health window displays with a drop-down box that provides the following options:

- Router Health, page 2-30
- Router Information, page 2-32

**Router Health**

The Router Health window displays a real-time graph and information about the health of a router. Table 2-6 describes the contents of the Router Health window.
### Table 2-6 Router Health Information

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPU Usage (graph)</td>
<td>Overall CPU busy percentage in the last 5 minute period</td>
</tr>
<tr>
<td>CPU Type</td>
<td>Describes type of CPU being monitored</td>
</tr>
<tr>
<td>Last 1 minute</td>
<td>Overall CPU busy percentage in the last 1 minute period.</td>
</tr>
<tr>
<td>Last 5 minutes</td>
<td>Overall CPU busy percentage in the last 5 minute period.</td>
</tr>
<tr>
<td>Temperature Description</td>
<td>Description of the test point being measured</td>
</tr>
<tr>
<td>Temperature Status</td>
<td>The current state of the test point being instrumented; one of the following are the states:</td>
</tr>
<tr>
<td></td>
<td>• Normal</td>
</tr>
<tr>
<td></td>
<td>• Warning</td>
</tr>
<tr>
<td></td>
<td>• Critical</td>
</tr>
<tr>
<td></td>
<td>• Shutdown</td>
</tr>
<tr>
<td></td>
<td>• Not Present</td>
</tr>
<tr>
<td></td>
<td>• Not Functioning</td>
</tr>
<tr>
<td></td>
<td>• Unknown</td>
</tr>
<tr>
<td>Failures</td>
<td>The failing component of the power supply being measured:</td>
</tr>
<tr>
<td></td>
<td>• None—No failure</td>
</tr>
<tr>
<td></td>
<td>• inputVoltage—Input power lost in one of the power supplies</td>
</tr>
<tr>
<td></td>
<td>• dcOutputVoltage—DC output voltage lost in one of the power supplies</td>
</tr>
<tr>
<td></td>
<td>• Thermal—Power supply thermal failure.</td>
</tr>
<tr>
<td></td>
<td>• Multiple—Multiple failures.</td>
</tr>
<tr>
<td></td>
<td>• Fan—Fan failure</td>
</tr>
<tr>
<td></td>
<td>• Overvoltage—Over voltage.</td>
</tr>
<tr>
<td>Memory Type</td>
<td>Type of memory including processor and I/O.</td>
</tr>
<tr>
<td>Used</td>
<td>Number of used MB for a particular memory type.</td>
</tr>
<tr>
<td>Free</td>
<td>Number of free MB for a particular memory type.</td>
</tr>
<tr>
<td>Largest Free</td>
<td>Number of largest contiguous free MB for a particular memory type.</td>
</tr>
</tbody>
</table>
Router Information

The Router Information window displays router information. Table 2-7 lists and describes the fields of the Router Information window.

Table 2-7 Router Information

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name an administrator assigned to this managed node, this is the node's fully-qualified domain name.</td>
</tr>
<tr>
<td>Hardware</td>
<td>A textual description which should contain the manufacturer's name for the physical entity and be set to a distinct value for each version or model of the physical entity.</td>
</tr>
<tr>
<td>Supervisor Software Version</td>
<td>The full name and version identification of the system's software operating-system and networking software.</td>
</tr>
<tr>
<td>Up Time</td>
<td>The time (in hundredths of a second) since the network management portion of the system was last re-initialized.</td>
</tr>
<tr>
<td>Location</td>
<td>The physical location of this node.</td>
</tr>
<tr>
<td>Contact</td>
<td>The textual identification of the contact person for this managed node and information on how to contact this person.</td>
</tr>
<tr>
<td>Modem</td>
<td>Indicates whether the RS-232 port modem control lines are enabled.</td>
</tr>
<tr>
<td>Baud</td>
<td>The baud rate in bits per second of the RS-232 port.</td>
</tr>
<tr>
<td>Power Supply</td>
<td>Description of the power supply being instrumented.</td>
</tr>
<tr>
<td>Power Supply Type</td>
<td>The power supply source:</td>
</tr>
<tr>
<td></td>
<td>• unknown</td>
</tr>
<tr>
<td></td>
<td>• ac</td>
</tr>
<tr>
<td></td>
<td>• dc</td>
</tr>
<tr>
<td></td>
<td>• externalPowerSupply</td>
</tr>
<tr>
<td></td>
<td>• internalRedundant</td>
</tr>
<tr>
<td>Power Supply Status</td>
<td>The current state of the power supply being instrumented.</td>
</tr>
<tr>
<td></td>
<td>1: normal</td>
</tr>
<tr>
<td></td>
<td>2: warning</td>
</tr>
<tr>
<td></td>
<td>3: critical</td>
</tr>
<tr>
<td></td>
<td>4: shutdown</td>
</tr>
<tr>
<td></td>
<td>5: notPresent</td>
</tr>
<tr>
<td></td>
<td>6: notFunctioning</td>
</tr>
</tbody>
</table>

Analyzing Media

The Analyzing Media contains the following sections:

- RTP Streams, page 2-33
- Voice Call Statistics, page 2-35
- Video Streams, page 2-36
RTP Streams

- Understanding the RTP Stream Data, page 2-33
- Monitoring RTP Streams, page 2-34

Understanding the RTP Stream Data

To view RTP stream information, summary statistics on the stream, and per-interval statistics, use the RTP Streams.

This window shows you three pieces of information:

**RTP Stream Information**
- Source IP Address and Port: IP address and UDP port of the originator of the RTP stream.
- Destination IP Address and Port: IP address and UDP port of the receiver of the RTP stream.
- SSRC: Synchronization source number as it appeared in the RTP header of the RTP stream.
- codec: encoding decoding format of the RTP stream.

**RTP Stream Stats Summary**
The summary includes the information about the RTP stream for the entire duration of RTP stream.

- Duration: duration of the RTP stream. This may not be the entire duration of the stream. It depends on the viewing time interval of the window which launched this RTP stream detail window.
- Worst / Duration Weighted / Max MOS: the lowest score among per-interval reports, the score of all per-interval reports that takes duration into account, and the highest score among per-interval reports of the stream.

Note: Duration-weighted is calculated with the following formula:
\[
\text{SUM (per-minute-mos * duration) / SUM (duration)}
\]

- Worst / Duration Weighted / Min Jitter: the largest jitter among per-interval reports, the jitter that takes into account of the duration of all per-interval reports, and the smallest jitter values among per-interval reports of the stream.

Note: Duration-weighted are used with the following formula:
\[
\text{SUM (per-interval-jitter * duration) / SUM (duration)}
\]
Worst / Overall / Min Actual Packet Loss: Loss percent of RTP packets that are not seen by NAM and RTP packets that arrived beyond the buffer capability of the receiving endpoint. This includes the highest percentile among per-interval reports, the sum of packets loss against total packets of all per-interval reports, and the lowest percentile loss among per-interval reports.

Worst / Overall / Min Actual Packet Loss: Similar to above, but the percent loss only includes RTP packets that were not seen by the NAM.

Worst / Total / Min Concealment Seconds: Number of seconds in which NAM detected packet loss during the duration of the stream. This includes lowest concealment seconds among per-interval reports, total concealment seconds of the entire duration of the stream, and highest concealment seconds among per-minute stream reports.

Severe Concealment Seconds: Similar to above; severe condition is met when the seconds have more than 5 percent loss.

**RTP Stream Stats Details**

This table shows the per-interval stats calculated by NAM at each interval. The columns of the tables are:

- **Report Time**: time when the stats were calculated. This is the end time of the interval.
- **Report Duration**: the stream duration during the report interval.
- **Worst MOS**: the lowest score of the stream among 3-second MOS score. NAM internally evaluates the MOS value of the stream every 3 seconds. This is the lowest score among them.
- **Average MOS**: average score of the 3-second score values during the duration of the stream in the interval. This value is used in deriving the Duration Weighted MOS value in NAM.
- **Jitter**: variation of packet arrival time compare to the expected time.
- **Actual Packet Loss percentile**: percentile of packets that are not seen by NAM.
- **Adjusted Packet Loss percentile**: percentile of packets that include the actual packets lost and packets that had arrived too late to get into buffer prior to paying back at the endpoint.
- **Concealment Seconds**: number of seconds in which the NAM sees packet loss.
- **Severe Concealment Seconds**: number of seconds in which the NAM detected more 5 percent of packet loss.
- **Packets**: total packets NAM have seen for the interval.

**Monitoring RTP Streams**

Use Prime NAM to monitor the network to ensure that call quality is good. If quality issues appear, isolate and troubleshoot the problem rapidly.

**Step 1**

View RTP Streams using the menu selection **Analyze > Media**. You can access this from the RTP Conversation table by clicking on a specific stream or from the Call Detail window by clicking on the stream that is associated with the call.

This chart indicates current voice quality of all RTP streams being monitored. MOS values range from 1 to 5, where 1 is poor and 5 is excellent (see the legend for a breakdown into categories-Poor, Fair, Good and Excellent). Use the Top N RTP Streams source and destination endpoints to view whether there are calls that are in the poor range.

**Step 2**

To isolate calls that have had a poor MOS, scroll down to Top N RTP Streams and click on the chart to drill down into the RTP Stream Details. Note that MOS values for calls below 3.0 might be considered low. You can also look at the other metrics provided in the same row (for example, row one. note the
jitter and packet loss rate scores to see if they also result in a low MOS value. This information can help you determine if jitter is the root cause of the poor calls; or if it is instead packet loss somewhere in the network.

**Step 3**

With the endpoints’ IP addresses, you can look at the network topology to identify where in the network your subnet is located.

Navigate to that NAM and go to the menu selection Analyze > Managed Device > Interface. This page lists all interfaces and errors or discards on each interface. Look up the link that leaves the site in question. That interface is likely the source of the packet loss. Check the interface for faults and fix as needed.

**Understanding RTP Streams**

To monitor the RTP streams, choose Analyze > Media > RTP Streams. You can also arrive at this page by:

- From the RTP Conversation table, clicking on a specific stream
- From the Call Detail window, clicking on the stream that is associated with the call

In this window, at least one of the following is required: Site or data source.

The five charts available in this window are:

- **RTP Streams**: Number of streams that fall in the quality bands of excellent, good, fair, and poor during the selected interval.
- **Top N Source Endpoints**: Endpoints that generated the lowest duration weighted MOS during the selected interval.
- **Top N Destination Endpoints**: Endpoints that experienced the lowest duration weighted MOS during the selected interval.
- **Top N RTP streams**: RTP streams that have the lowest duration weighted MOS during the selected interval.
- **Top N RTP streams by Adjusted Packet Loss**: RTP streams that have the highest overall adjusted packet loss percent during the selected interval.

**Voice Call Statistics**

To monitor voice quality, choose Analyze > Media > Voice Call Statistics. The charts will provide an overview of voice quality.

The charts available are:

- **Voice Call Statistics**: Number of calls per signaling protocol (SCCP, SIP, MGCP, and H.323) at each interval during the selected interval.
- **Top N End Points by Jitter (ms)**: Endpoints that have the largest average of endpoint reported jitter during the selected interval.
- **Top N End Points by Packet Loss (%)**: Endpoints that have the largest average of endpoint reported packet loss during the selected interval.
- **Top N Calls by Jitter (ms)**: Calls that have the longest endpoint-reported jitter during the selected interval.
- **Top N Calls by Packet Loss (%)**: Calls that have the most endpoint reported packet loss percent during the selected interval.
Video Streams

- Understanding the Video Stream Data, page 2-36
- Monitoring Video Stream Data, page 2-38

Understanding the Video Stream Data

The Video Streams window allows you to view video stream information, summary statistics on the stream, and per-interval statistics. Currently, NAM monitors Video streams over RTP only.

The Video Streams window shows the following information depending on whether it is MPEG-TS stream:

- Video Stream Information, page 2-36
- Media Delivery Index Details of Current Stream’s Carrier RTP, page 2-36
- Video Stream of Codec Stats Summary, page 2-37
- Video Stream of Codec Stats Details, page 2-37

Video Stream Information

Table 2-8 describes the Video Stream Information.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source IP Address and Port</td>
<td>IP address and UDP port of the originator of RTP stream.</td>
</tr>
<tr>
<td>Destination IP Address and Port</td>
<td>IP address and UDP port of the RTP stream.</td>
</tr>
<tr>
<td>SSRC</td>
<td>Synchronization source number that appears in the RTP header of the RTP stream.</td>
</tr>
<tr>
<td>Codec</td>
<td>Encoding decoding format of the video stream.</td>
</tr>
<tr>
<td>Program ID</td>
<td>For the MPEG-TS stream.</td>
</tr>
<tr>
<td>Protocol</td>
<td>Transport protocol for the video stream.</td>
</tr>
<tr>
<td></td>
<td>Possible options are:</td>
</tr>
<tr>
<td></td>
<td>• RTP</td>
</tr>
<tr>
<td></td>
<td>• RTP/MPEG-TS</td>
</tr>
</tbody>
</table>

Media Delivery Index Details of Current Stream’s Carrier RTP

The Media Delivery Index (MDI) table displays the details of the MDI statistics at each interval. You can view this MDI table when the video stream is MPEG-TS stream only. Table 2-9 describes the MDI details.
Table 2-9   **MDI Details**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Time</td>
<td>Time when the statistics were calculated. This is the end time of the interval.</td>
</tr>
<tr>
<td>Report Durations</td>
<td>Durations (in seconds) of valid MDI metrics in this interval.</td>
</tr>
<tr>
<td>Min/Max/Average Media Rate</td>
<td>The minimum/maximum/average media rate in this interval. The media rate is the media payload traffic rate for RTP packet and only counts the RTP payload octets.</td>
</tr>
<tr>
<td>Min/Max/Average Delay Factor</td>
<td>Delay factor is defined by RFC-4445 and is valid only when the traffic is CBR and is calculated on a per second basis.</td>
</tr>
<tr>
<td>Media Loss Rate</td>
<td>Media Loss Rate is defined by RFC-4445 and is the average MLR over the period.</td>
</tr>
</tbody>
</table>

**Video Stream of Codec Stats Summary**

Table 2-10 describes the codec stats summary of the video stream for the entire duration of the video stream.

Table 2-10   **Codec Stats Summary**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Intervals monitored</td>
<td>Count of intervals that has been monitored.</td>
</tr>
<tr>
<td>Received Count / Impaired Count / Lost Count I Frame</td>
<td>Received/Impaired/Lost count of I frames in this period.</td>
</tr>
<tr>
<td>Received Count / Impaired Count / Lost Count All (I&amp;B&amp;P) Frame</td>
<td>Received/Impaired/Lost count of I/B/P frames in this period.</td>
</tr>
<tr>
<td>Worst / Min / Average I Frame Loss Rate</td>
<td>Worst/Minimum/Average Loss percent of I frames that are not seen by NAM and is calculated with the formula: SUM (I Frame Loss Count) / SUM (I Frame Received Count + I Frame Loss Count)</td>
</tr>
<tr>
<td>Worst / Min / Average All Frame Loss Rate</td>
<td>Worst/Minimum/Average Loss percent of all frames that are not seen by NAM and is calculated with the formula: SUM (I Frame Loss Count + B Frame Loss Count + P Frame Loss Count) / SUM (I Frame Received Count + B Frame Received Count + P Frame Received Count + I Frame Loss Count + B Frame Loss Count + P Frame Loss Count)</td>
</tr>
</tbody>
</table>

**Video Stream of Codec Stats Details**

The Video Stream of Codec Stats Details show the per-interval stats calculated by NAM at each interval. Table 2-11 describes the Codec Stats Details.
To monitor the Video streams, choose **Analyze > Media > Video Streams**.

The following charts get displayed:

- **Video Frames**—Number of Video Streams that fall in the quality bands of excellent, good, fair and poor during the selected interval.
- **Delay Factor (MDI)**—Number of MDI streams whose DF falls in the corresponding quality bands during the selected interval.
- **Media Loss Rate (MDI)**—Number of MDI streams whose MLR falls in the corresponding quality bands during the selected interval.
- **Top N Source End Points**—Endpoints that generated the largest frame loss rate during the selected interval.
- **Top N Destination End Points**—Endpoints that experienced the largest frame loss rate during the selected interval.
- **Top N MDI Streams by Delay Factor**—MDI streams that have the largest delay factor during the selected interval.
- **Top N MDI Streams by Media Loss Rate**—MDI streams that have the largest MLR during the selected interval.

### Video Channels Statistics

To monitor video quality, choose **Analyze > Media > Video Channels Statistics**. The Video Channels Statistics charts provide an overview of video channels set up by media control signaling protocols.

The Video Channel Statistics chart shows the number of video streams per signaling protocol (SCCP, SIP, MGCP, H.323, RTSP and IGMP) at each selected intervals. The chart also shows the number of streams setup per protocol per state (Active, Paused, New and Terminated).

---

**Table 2-11 Codec Stats Details**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Time</td>
<td>Time when the statistics were calculated. This is the end time of the interval.</td>
</tr>
<tr>
<td>Codec</td>
<td>Encoding decoding format of the video stream. Currently, it supports only MPEG-2 and H.264.</td>
</tr>
<tr>
<td>Frame Rate</td>
<td>Frame rate of the video stream.</td>
</tr>
<tr>
<td>I/B/P Frames Received</td>
<td>Received I/B/P frame count in the interval.</td>
</tr>
<tr>
<td>I/B/P Frames Impaired</td>
<td>Impaired I/B/P frame count in the interval.</td>
</tr>
<tr>
<td>I/B/P Frame Lost</td>
<td>Lost I/B/P frames that are not seen by NAM in the interval (For H.264, it shows only I/None-I Lost).</td>
</tr>
<tr>
<td>Video Resolution</td>
<td>Width multiplied by height resolution of the video.</td>
</tr>
<tr>
<td>I/All Frame Loss Quality</td>
<td>Quality level of the interval and is calculated depending on the set Video Quality Ranges.</td>
</tr>
</tbody>
</table>
 Calls Table

The Calls Table shows you calls that the NAM detected by inspecting voice signaling protocols payload. For this table to have data, the NAM must see:

- SCCP protocol—Call Information message of the call.
- SIP protocol—SIP INVITE message of the call. Note that SIP protocol will be detected as per call leg.
- H.323 protocol—Call SETUP of the call.
- MGCP protocol—Create connection message of the call. Note that MGCP will be detected per call leg.

Note: SIP and MGCP will be detected per call leg. Each call could be two or more parties. Each party has its own call leg from the call party to control entity; for example, Cisco Unified Communications Manager or MGCP gateway. Any information that is not detected by NAM will be displayed as “-” or blank.

To view the active calls, choose Analyze > Media > Detailed Views > Call Table. The Calls Table and RTP Streams for the Selected Call display. These tables show a list of all currently active calls.

Note: Some values in the Calls table are not available until the end of the call, and Cisco Unified Communications Manager must be configured to have the IP phones send out the call status and quality information.

Note: All calculated metrics in Table D-50, Calls Table, are based on a one minute interval.

Table D-50 provides descriptions of the Calls Table fields.

If you click on a call row in the table, in the RTP Streams for the Selected Call display at the bottom of the page you will see all streams that are associated with the call. It will display the RTP streams that:

- have source address and port matched the call’s calling host address and calling port or called host address and called port
- have destination address and port that matched the call’s calling host address and calling port or called address and called port

Note: There is a delay of two minutes of RTP streams statistics. As the result, there may not be any RTP stream information of the call.

The RTP Streams of the Selected Call table shows the overall RTP streams statistics that are calculated by the NAM. You can use this information to compare the views of the call endpoints and the NAM regarding the call quality. The columns of the RTP Stream report are described in Table D-51.

You can see more detailed information about each RTP stream by selecting the RTP stream and clicking on the RTP Stream Details button. A pop up window will show more detailed information of the stream displayed.
RTP Conversation

To get detailed information about RTP conversations, choose Analyze > Media > Detailed Views > RTP Conversations. This table shows you the overview of RTP streams analyzed by NAM during the selected interval. You can drill down to each stream to get stream statistics, which are analyzed by the NAM at each interval. To get more detailed information, you can:

- Click on the RTP stream for which you want to see more information.
- Click on the “RTP Stream Details” context menu. A pop up window will show you the detailed information of the stream.

The columns of the RTP Conversation tables are described in Table D-56.

Site MOS

You can use the Mean Opinion Score (MOS) to quantify the perceived level of quality you are receiving in your network voice traffic. This allows you to assess the work of codecs, or algorithms, which compress audio traffic to save on bandwidth utilization but may result in a drop in quality.

You must first set up the software to monitor voice data, then you can view the collected voice data using Analyze > Media > Detailed Views > Site MOS.

Table D-31 contains details on Site MOS scores.

Video Channels Table

The Video Channels Table shows you video channels that are detected by inspecting media control signaling protocols payload. For this table to have data, the NAM must use the below protocols:

- SCCP protocol—Video channels setup by this protocol for a VoIP call with video channel.
- SIP protocol—Video channels setup by this protocol for a VoIP call with video channel.
- H.323 protocol—Video channels setup by this protocol for a VoIP call with video channel.
- MGCP protocol—Video channels setup by this protocol for a VoIP call with video channel.
- RTSP protocol—Video channels setup by RTSP session.
- IGMP protocol—Video channels joined by IGMP/MLD protocol join message.

The Video Channels table columns are described in Table D-52, Table D-53, Table D-54, and Table D-55.

To view the active video channels setup by media control sessions in network, choose Analyze > Media > Detailed Views > Video Channels Table. You can view the Video Signaling Channel List, Video Stream Conversations, Media Signaling Sessions and RTP Streams for the selected Media Signaling Session. These tables show a list of all currently active videos on the related network.

Note

All calculated metrics including stream state in Video Channels Table are based on one minute interval.

If you click on a video channel row in the Video Signaling Channel List table, you will see the following tables:
- Video Stream Conversation Table—Displays the video streams that have destination address and destination port matching with the video channel’s destination address and destination port, along with video channel start and end time.
- Media Signaling Session Table—Displays the media controlling session to setup related video channel. Signaling protocol to setup this video channel should be supported on NAM.
- RTP Streams Table—Displays the RTP streams that have source address and port matching with the media control session’s calling/client host address and calling/client port or called/server host address and called/server port. Also, displays the destination address and port matching with the media control session’s calling/client host address and calling/client port or called/server address and called/server port.

**Note**
There will be a delay of two minutes to display the RTP streams statistics. As a result, there will not be any RTP stream information for the video call.

The RTP streams of the Selected Call table shows the overall RTP streams statistics that are calculated by the NAM. If it is an VoIP call RTP stream, you can use this information to compare the views of the call endpoints to check the call quality. The columns of the RTP Stream report are described in Table D-50.

You can see more detailed information about each RTP stream by selecting the RTP stream and clicking on the **RTP Stream Details** button.

**Note**
Video channels setup by supported media controlling protocol will have codec which are not supported by NAM. Such video channels will not have any video conversation to display on NAM.

See section Video Stream Conversations, page 2-41 for more details on video conversation.

### Video Stream Conversations

To monitor the Video streams, choose **Analyze > Media > Video Streams**.

The following charts get displayed:

- **Video Frames**—Number of Video Streams that fall in the quality bands of excellent, good, fair and poor during the selected interval.
- **Delay Factor (MDI)**—Number of MDI streams whose DF falls in the corresponding quality bands during the selected interval.
- **Media Loss Rate (MDI)**—Number of MDI streams whose MLR falls in the corresponding quality bands during the selected interval.
- **Top N Source End Points**—Endpoints that generated the largest frame loss rate during the selected interval.
- **Top N Destination End Points**—Endpoints that experienced the largest frame loss rate during the selected interval.
- **Top N MDI Streams by Delay Factor**—MDI streams that have the largest delay factor during the selected interval.
- **Top N MDI Streams by Media Loss Rate**—MDI streams that have the largest MLR during the selected interval.

The columns of the Video Stream Conversations table is described in Table D-53.
Using the NAM Application Programming Interface

NAM provides an Application Programming Interface (API) that allows you to configure and retrieve data from the NAM. The API follows the commonly used Representational State Transfer (REST) style of providing services over HTTP or HTTPS. The NAM REST API is also referred to as the Northbound Interface (NBI).

For application developers who want to use the NAM REST API, ask your Cisco representative about the Cisco Prime Network Analysis Module REST API Guide.
Capturing and Decoding Packets

You can set up multiple sessions to capture, filter, and decode packet data using the Capture feature. You can then manage the data in local or remote storage and display the contents of the packets to collect troubleshooting information.

Note
This software feature may be limited depending on your hardware platform. For details, see the NAM Compatibility Matrix or the Cisco Prime Network Analysis Module Release Notes.

This chapter contains the following sections:

- How Do I Solve My Problem?, page 3-1
- Manually Starting a Capture, page 3-2
- Using Alarm-Triggered Captures, page 3-3
- Scheduling Captures, page 3-3
- Troubleshooting Application Slowness Using Alarms, page 3-4
- Application Performance Monitoring Using Capture and Decode, page 3-5
- Creating and Managing Capture Sessions, page 3-6
- Working with Capture Files, page 3-21
- Utilizing Capture Data Storage, page 3-24
- Inspecting Packet Decode Information for Suspicious Traffic, page 3-30

How Do I Solve My Problem?

This section provides an overview of how to collect and analyze packet data to ensure your network is running well or pinpoint network issues.

There are many ways to collect data and analyze it using Prime NAM. In order to collect data, the prerequisite is to have set up SPAN or ERSPAN through your NAM dataports. For details on data source configuration, see Understanding Prime NAM Traffic Sources, page A-1. Many users want a quick capture to analyze their packet data. See Manually Starting a Capture, page 3-2 for details on how to get a quick capture.

Table 3-1 provides an at-a-glance summary of capture tasks you can perform to ensure your network is optimized and trouble-free.
Manually Starting a Capture

You do not have to perform any configuration and can quickly collect packet data by selecting the context menu option, **Capture**. Figure 3-1 shows an example of a context menu for Top N Applications dashboard.

For details on how to use the decode window to analyze your data, see Inspecting Packet Decode Information for Suspicious Traffic, page 3-30.
Using Alarm-Triggered Captures

You can configure multiple alarm-triggered captures that start and stop automatically by alarm events you define.

To set up an alarm-triggered capture:

---

**Step 1** Choose **Capture > Packet Capture/Decode > Sessions** and create a capture session. For detailed instructions, see *Configuring Capture Sessions*, page 3-6.

**Step 2** Create an alarm event from **Setup > Alarms > Actions** and click **Create** to make a new trigger capture action which uses the session from **Step 1**.

Configure an alarm event for the type of event for which you want to capture data. For detailed instructions, see *Configuring Alarm Actions*, page 6-31.

**Step 3** Create a threshold which uses the alarm event action from **Step 2**. Choose **Setup > Alarms > Thresholds** window.

To configure the threshold of parameters of interest in the associated Alarm Event, see *Defining Thresholds*, page 6-33.

---

Scheduling Captures

You can configure multiple time-based triggered captures that start and stop automatically based on a certain time or period of time that you define. This is also referred to as continuous capture. Continuous capture overwrites itself in memory when the buffer is full. The following is an example of setting a 60 minute window to schedule capture packet data.
To set up a schedule capture:

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Create a new capture from the <strong>Capture &gt; Packet Capture/Decode &gt; Sessions</strong> window.</td>
</tr>
<tr>
<td>2</td>
<td>Check the Auto Capture <strong>Enable</strong> check box.</td>
</tr>
<tr>
<td>3</td>
<td>Set the Start Date and Time and Duration (in minutes) to <strong>60</strong>.</td>
</tr>
<tr>
<td>4</td>
<td>Select an appropriate storage type to store your capture data. For example, select capture to <strong>memory HDD</strong>.</td>
</tr>
<tr>
<td>5</td>
<td>Select appropriate software filters.</td>
</tr>
<tr>
<td>6</td>
<td>Click <strong>Submit</strong>.</td>
</tr>
<tr>
<td>7</td>
<td>To start the capture session, return to the <strong>Capture &gt; Packet Capture/Decode &gt; Sessions</strong> menu and select the capture session you previously created and click <strong>Start</strong>.</td>
</tr>
</tbody>
</table>

**Troubleshooting Application Slowness Using Alarms**

This section describes how to use Prime NAM to use triggered alarms and capture files to help you determine the source of some network problems.

**Before You Begin**

You must already create an alarm that notifies you when there is a surge in application traffic. If you need to create an alarm, thresholds, and set up email notification, see Setting Up Alarms and Alarm Thresholds, page 6-31.

To use existing alarms to help you to create and analyze captured packet files:

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>After receiving an email that was triggered by an alarm notification, view the alarm summary and analyze the details. For example, if your alarm triggers when your application has reached a certain threshold, choose <strong>Monitor &gt; Alarm Summary</strong> to view the Top N Applications by Alarm Count dashboard. If you use sites, you could view the top sites by alarm count dashboard in order to see the alarm details and determine what threshold variable is causing the alarm to trigger.</td>
</tr>
<tr>
<td>2</td>
<td>To view more details (or drill down) from this dashboard, left-click the row you are interested in and select <strong>Application Response Time</strong> in order to analyze the response time during the time interval of the alarm trigger. If your application is not listed in the graph, you can select the table icon to choose your application from the list of all the applications and drill down from there to analyze the response time.</td>
</tr>
<tr>
<td>3</td>
<td>Adjust the Interactive filter to view specific time ranges and severity levels in order to view where the spike in response time occur. This helps to determine if the occurrence is limited to a one-time event, if it occurs more than once in a short period of time, or is an event related to a specific time of the day. For example, by changing the time range filter from 1 hour to 4 hours to 1 day, you can see the latest data trends that help you to determine what to do next. See Filtering Traffic for Viewing on the Dashboards, page B-4.</td>
</tr>
<tr>
<td>4</td>
<td>In the graph that displays, focus in on the time frame when the event occurs by using the slider to pinpoint the event. Look for peak or valleys; these may be critical changes that require investigation. Using the legend you can determine whether the event was caused by the network or server. See Changing the Time Interval Using Zoom/Pan Charts, page B-6.</td>
</tr>
</tbody>
</table>
Step 5  Select any of the metrics provided below the application average response time graph.

a. To view if there are specific clients that have significant transaction time differences, see the Top Clients By Average Transaction Time graph in order to identify data such as Client-Server Application Transactions using an application-specific filter.

- To view a table of response time metrics and add new metrics for additional data (such as average server response time) and use the drop down menu to select which other metric data you want to appear in the graph.

Application Performance Monitoring Using Capture and Decode

This task explains how to proactively monitor your application performance, then use it to help isolate and troubleshoot application latency issues experienced by your end user.

Before You Begin

NAM assumes that your system time is synchronized. If you do not have the time synchronized between the NAM and the standard time source outside the NAM, then you may see either incorrect data or no data. If you suspect inaccurate timestamps, you need to set up the System Time so that NAM data presentation is accurate. For instructions on how to set system time by choosing Administration > System > System Time, see Synchronizing Your System Time, page 4-5.

Step 1  Identify and monitor your business critical applications. To see Layer 7 application details, ensure you enable deep packet inspection. Choose Setup > Classification > Applications Settings and select the Deep Packet Inspection checkbox.

For detailed instructions, see Adding More Detail into Dashboard and Application Reports, page 6-53.

Step 2  Proactively detect performance degradation using threshold violation alerts. First, define your alarm by choosing Setup > Alarms > Actions. Then define the thresholds for your alarm by choosing Setup > Alarms > Thresholds.

For detailed instructions, see Setting Up Alarms and Alarm Thresholds, page 6-31.

Step 3  Validate a reported trouble ticket or network issue. Choose Monitor > Overview > Response Time Summary and use the Top N Applications by Transaction Time dashboard to identify which application may be impacted.

You can select the table view to see more than the top default applications. You can also use the other dashboards to view server or client transaction times. See Using Response Time Summary, page 2-5.

Step 4  Analyze the application performance behavior over time using the Interactive Report filter. Determine if the behavior is transient, persistent, recurring, and so on. For details on using the Interactive Report filters, see Filtering Traffic for Viewing on the Dashboards, page B-4.

Step 5  Zoom in to view specific spikes in the performance, and drill down to isolate whether the cause of the degradation stems from your network, server or application. See Changing the Time Interval Using Zoom/Pan Charts, page B-6.

Step 6  Analyze the server response time and network performance metric in order to eliminate one of them as the cause. See Server Response Time, page 2-22 and Network Response Time, page 2-21.

Step 7  Analyze server activity based on the traffic the server is placing on the network and assess the cause of increase in the server response time. See Analyzing Host Traffic, page 2-11.
Creating and Managing Capture Sessions

You can use capture sessions to capture, filter, and decode packet data, manage the data in a local or remote storage, and display the contents of the packets. The captured packets can be decoded and analyzed using Prime NAM for more efficient problem isolation.

This section contains the following topics:
- Configuring Capture Sessions, page 3-6
- Configuring Software Filters, page 3-7
- Configuring Hardware Filters, page 3-9
- Understanding Hardware and Software Capture Sessions Filters, page 3-19
- Viewing Capture Sessions, page 3-20
- Understanding Global Capture Settings, page 3-20

Configuring Capture Sessions

Because it may be important for you to collect data over time and have various locations for which you want to analyze data, we support multiple sessions per capture location/target. You can collect data using multiple sessions per target, but only one session can be running per target. Prime NAM now supports up to 25 capture sessions. If you have external storage you can save to local disk and some number of LUNs. As part of configuring a capture session, you can also create software filters, if desired (see Creating a Software Capture Filter for a Capture Session, page 3-7).

To configure a new capture session:

Step 1  Choose Capture > Packet/Capture Decode > Sessions.
Step 2  Click Create to set up a new capture. The NAM displays the Configure Capture Session window.
Step 3  Enter information in the Capture Settings Fields (Table D-59) as appropriate.

When capturing to multiple files, a suffix is added to the file name. For example, the first file for a capture named CaptureA would be labeled as CaptureA_1 the second CaptureA_2, and so on.

Step 4  Click Submit to finish configuration for this session, or configure Software Filters for this session (see Understanding Global Capture Settings, page 3-20).
Chapter 3      Capturing and Decoding Packets

Configuring Software Filters

You can create and save specialized filters that will disregard all capture data except the information in which you are interested (see Figure 3-6). You can configure multiple software filters for each session (up to six). This allows you to narrow in on the traffic that you are interested in, and it also saves resources (either memory or disk space).

Use the following topics for help on filtering network traffic using software filters:

- Creating a Software Capture Filter for a Capture Session, page 3-7
- Editing a Software Capture Filter, page 3-7
- Understanding Software Capture Filter Options, page 3-8

Creating a Software Capture Filter for a Capture Session

You can create software capture filter for many variables. This workflow examines how to create a capture session with a software filter.

To create a software capture filter:

---

Step 1 Choose Capture > Packet Capture/Decode > Sessions.
Step 2 Click Create to create a new capture session.
   If you already have a capture session to which you want to add a software filter, see Editing a Software Capture Filter, page 3-7 for detailed instructions.
Step 3 Enter information in each of the fields as appropriate. See Table D-65.
Step 4 Click Submit to create the filter, or click Cancel to close the dialog box without creating a software filter.

Editing a Software Capture Filter

To edit software capture filters:

---

Step 1 Choose Capture > Packet Capture/Decode > Sessions.
Step 2 Choose the session to edit, then click Edit.
   The Software Filter dialog box displays. See Table D-65.
Step 3 Enter information in each of the fields as appropriate.
Step 4 Do one of the following:
   - To apply the changes, click Submit.
   - To cancel the changes, click Cancel.
Important Notes about Software Capture Filters

This section contains important software capture filters details that may be helpful to know.

- For NAM-3 and NAM-NX1 service modules, multiple software filters use the “OR” logic; in other words, if a packet passes any software filter, it is captured.

- If you create a session and then start it, you cannot edit the session or analyze it without stopping it. If you edit a session containing already captured data, you get a warning stating that the session will be cleared and the data removed. If clearing the session and removing the data is acceptable, ignore the warning dialog message, then add a filter to the session and click **Submit** to enable the new filter settings.

- The application filter can be used to filter on the highest layer of the protocol parsing; that is usually a layer 4 protocol (based on port). If you want to filter on the transport protocol (for example, UDP or TCP), you will need to use the IP Protocol selector. Selecting, for example, TCP in the “IP Protocol” selector will filter on all packets using TCP.

**Tip** Be careful when setting capture software filtering for encapsulation. If you set a software capture filter with encapsulation for the top three network traffic layers only, data displays only if the top three layers match the specified encapsulation type.

Understanding Software Capture Filter Options

You can define a software filter to filter based on any of the following options:

- Source host address
- Destination host address
- Network encapsulation
- VLAN or VLAN range
- TCP Flag bits
- Application
- Source port or port range
- Destination port or port range
- IP Protocol

**Note** Software capture filtering is not supported on URL-based applications.

Table D-65 contains descriptions of the Software Filter dialog box fields.
The parameters described in the table above are independently evaluated by the NAM. Therefore, the NAM will allow you to enter parameters that are contradictory, but you will not be able to get meaningful results if they do not match.

For example, the parameters Network Encapsulation and Source/Destination Address are independently evaluated. If a filter is specified with contradicting parameters such as “Network Encapsulation=IP4” and “Source Address=an IPv6 address”, it will never match any traffic, and the result will be 0 packets captured.

Configuring Hardware Filters

You can use hardware filtering to help limit the amount of traffic allowed into the NAM for processing. In service modules, there is a hardware datapath throughput limitation and hardware filtering helps to reduce the traffic into the NAM. The NAM hardware platforms that support hardware filtering include:

- Service Modules—NAM-3 and NAM-NX1
- Specific NAM 2000 Series Appliances—2320, 2420, and 2440

Depending on your NAM, the hardware filter support varies. The following section describes:

- Creating NAM Service Modules Hardware Filters, page 3-9
- Creating NAM Appliance Hardware Filters, page 3-14

Creating NAM Service Modules Hardware Filters

This section is applicable only for NAM-3 and NAM-NX1 service modules.

NAM-3 and NAM-NX1 service modules have specific hardware filter logic. These hardware filters allow you to improve capture performance by eliminating extraneous traffic, since packets excluded from capture processing.

Hardware filters and global packet slicing affect all capture sessions, except for ERSPAN capture sessions. See Figure 3-6, “NAM Capture Sessions Example” for an architectural overview.

NAM-3 and NAM-NX1 support up to four hardware filters. You can disable hardware filters without deleting them.

Within each filter, you can set up conditions with the AND/OR logic. Only the same logic type can be used within the same filter; you cannot mix the AND/OR logic within the same filter. Also, you can combine the filters together with the AND/OR logic. See Figure 3-2 for examples of filter logic you can use.
Creating and Managing Capture Sessions

Chapter 3  Capturing and Decoding Packets

Creating and Managing Capture Sessions

Creating and Managing Capture Sessions

Figure 3-2  Hardware Filter Logic (AND/OR)

The selections are described in the following sections. For information about how you can achieve specific results, see Configuring Hardware Filter Examples, page 3-11.

Tip

Software filters add flexibility to your filtering, but hardware filters are most efficient. The less traffic that requires software filtering, the more efficient the filtering.

See these topics for information about setting up and managing hardware filters:

- Creating or Editing a NAM Services Modules Hardware Filter, page 3-10
- Configuring Hardware Filter Settings, page 3-11
- Configuring Hardware Filter Examples, page 3-11

Choose Capture > Packet Capture/Decode > Sessions to view the status and settings of hardware filters that are configured on the Cisco NAM. The Hardware Filters box appears at the bottom of the Sessions page.

Creating or Editing a NAM Services Modules Hardware Filter

The Hardware Filters window displays the status and settings of the hardware filters if they have been defined. To configure a capture with hardware filters:

Step 1  Choose Capture > Packet Capture/Decode > Sessions. The top half of the window shows Capture Sessions, and the bottom half of the window shows Hardware Filters.

Step 2  In the Hardware Filters section on the bottom of the window, click Create. The Hardware Filter Dialog appears.

Step 3  Enter a name for the hardware filter in the Name field. The name should be less than 40 characters and contain only supported characters.

Step 4  Check the Enable check box to enable the filter. If the filter is created with the Enable check box unchecked, the filter will be saved but inactive. It can be enabled at a later time by editing the filter and checking the Enable check box.

Step 5  Choose either the AND or the OR radio button. This selection will apply to all of the selections you make in the next step (the selections are described in Table 3-3).

Step 6  Check the boxes for the attributes you want to filter on, and then in the corresponding drop-down menu, select the desired option. The Check All check box selects all check boxes. See Table D-63.

Step 7  Click Apply to complete the configuration of the hardware filter.
Configuring Hardware Filter Settings

The Hardware Filter Settings allows you to set global settings for all capture hardware filters. To add settings that apply to all hardware filters:

**Step 1** Choose **Capture > Packet Capture/Decode > Sessions**.

**Step 2** In the Hardware Filters section at the bottom, click **Hardware Filter Settings**.

**Step 3** Choose the **AND** or **OR** Combination Logic, which will be applied to all configured hardware filters. This logic is used to combine the filters; see the green text in **Figure 3-2**.

**Step 4** Choose the **Include in capture** or **Exclude from capture** Packet Match Logic. This selection will apply to all configured hardware filters.

**Exclude from capture** will drop packets that match all of the hardware filters you have configured. Meanwhile, all packets that do not match will be captured.

**Step 5** Click **Apply**.

Configuring Hardware Filter Examples

Use these topics to configure the following network traffic:

- **IP Subnet + L4 Port (L5 Application)**, page 3-11
- **VLAN + L4 Protocol**, page 3-12
- **Multiple Hosts**, page 3-12
- **VLAN Range**, page 3-12
- **Data Port + Frame Length**, page 3-13
- **MPLS**, page 3-13

**IP Subnet + L4 Port (L5 Application)**

To capture all HTTP traffic emanating from the 10.1.1.0/24 subnet:

**Step 1** On the Hardware Filters window, click **Create**.

**Step 2** Enter a name in the Name field.

**Step 3** Choose the Logic **AND** radio button (this will combine the selections you make below).

**Step 4** Check the **Source IP Address** check box and enter the subnet “10.1.1.0/24”.

**Step 5** Check the **L4 Source Port** check box and enter the port “80” for HTTP.

**Step 6** Click **Apply**.

To see the opposite direction of the HTTP conversations:

**Step 1** On the Hardware Filters window, click **Create**.

**Step 2** Enter a name in the Name field.

**Step 3** Choose the Logic **AND** radio button.
Creating and Managing Capture Sessions

Step 4  Select Destination IP Address and enter the same subnet as before, 10.1.1.0/24
Step 5  Select L4 Destination Port and enter the same port, 80.
Step 6  Click Apply.
Step 7  To see the incoming and the outgoing, click Hardware Filter Settings and select the OR logic. This will combine the two hardware filters with the OR logic.

VLAN + L4 Protocol
To see all TCP traffic from VLAN 100:

Step 1  On the Hardware Filters window, click Create.
Step 2  Enter a name in the Name field.
Step 3  Choose the Logic AND radio button.
Step 4  Select VLAN and enter the VLAN, 100.
Step 5  Select L4 Protocol and choose TCP.
Step 6  Click Apply.

Multiple Hosts
To see traffic sent to and from multiple hosts: 1.1.1.1, 2.2.2.2, ...

Step 1  On the Hardware Filters window, click Create.
Step 2  Enter a name in the Name field.
Step 3  Choose the Logic OR radio button.
Step 4  Check the Source IP Address check box and enter the first host: 1.1.1.1.
Step 5  Check the Destination IP Address and enter the same host: 1.1.1.1.
Step 6  Click Apply.
Step 7  Click Create to make a second hardware filter.
Step 8  Enter a name for the hardware filter in the Name field.
Step 9  Choose the Logic OR radio button.
Step 10 Check the Source IP Address check box and enter the second host, “2.2.2.2”.
Step 11 Check the Destination IP Address check box and enter the second host, “2.2.2.2”.
Step 12 Click Apply.
Step 13 Repeat Step 7 through Step 12 for a third and fourth host, if desired.
Step 14 Click Hardware Filter Settings and select the logic OR radio button.

VLAN Range
To see all traffic from VLANS 10 through 20:
Step 1  On the Hardware Filters window, click **Create**.
Step 2  Enter a name in the Name field.
Step 3  Check the check box for **VLAN IDs** and choose **Greater Than** from the drop-down menu.
Step 4  In the empty field, enter the bottom VLAN range boundary, “9.”
Step 5  Click **Apply**.
Step 6  Click **Create** to make a second filter.
Step 7  Enter a name in the Name field.
Step 8  Check the check box for **VLAN IDs** and choose **Less Than** from the drop-down menu.
Step 9  In the empty field, enter the bottom VLAN range boundary, “21.”
Step 10 Click **Apply**.
Step 11 Click **Hardware Filter Settings** and select the **AND** radio button, which will combine the logic of all hardware filters.

**Data Port + Frame Length**
To see all traffic spanned to DATA PORT 1 that is less than 200 bytes:

Step 1  On the Hardware Filters window, click **Create**.
Step 2  Enter a name in the Name field.
Step 3  Choose the Logic **AND** radio button.
Step 4  In the **Data Port** drop-down list, choose **DATA PORT 1**.
Step 5  Check the check box for **Frame Length** and choose **Less Than** from the drop-down menu.
Step 6  In the empty field, enter the frame length ceiling, “200.”
Step 7  Click **Apply**.

**MPLS**
To see traffic in which the first MPLS label is 300:

Step 1  On the Hardware Filters window, click **Create**.
Step 2  Enter a name in the Name field.
Step 3  Check the check box for **MPLS Label**.
Step 4  In the empty field, enter the label, “300.”
Step 5  Click **Apply**.

**Bi-Direction Conversation**
To see both directions of a conversation between hosts 1.1.1.1 and 2.2.2.2:

Step 1  On the Hardware Filters window, click **Create**.
Creating and Managing Capture Sessions

Chapter 3  Capturing and Decoding Packets

Creating NAM Appliance Hardware Filters

This section describes how to create NAM appliance hardware filters.

The Hardware filters allow you to improve capture performance by eliminating extraneous traffic, since packets filtered out are excluded from capture processing.

Note

The hardware filter applies to the NAM 2320, 2420, and 2440 appliances. The NAM 2304 does not support hardware filters.

Software filters add flexibility to your filtering, but a capture session is most efficient when you use hardware filters only. The less traffic requiring software filtering, the more efficient the filtering.
For the NAM appliances that support hardware filtering, you can set up to five hardware filters per appliance. When multiple hardware filters are created on the appliance, the logic among them are OR logic.

Hardware filters and global packet slicing affect all capture sessions, except for ERSPAN capture sessions.

All fields within a single filter are combined with AND logic. The filters are then combined with OR logic. See Figure 3-3 for examples of filter logic you can use.

![Figure 3-3 Hardware Filter Logic (AND/OR)](image)

See Configuring Supported NAM Appliance Hardware Filters, page 3-15 for detailed steps.

**Configuring Supported NAM Appliance Hardware Filters**

The Hardware Filters window appears at the bottom of the Capture > Packet Capture/Decode > Sessions window. To configure a hardware filter:

- **Step 1** Choose Capture > Packet Capture/Decode > Sessions.
- **Step 2** At the bottom of the window, select a data port hardware filter and click Create.
- **Step 3** Enter a name in the Name field.
- **Step 4** Choose any or all of the following types of filters:
  - Frame Length
  - VLAN IDs
  - MPLS Label
  - Source Address/Mask
  - Destination Address/Mask
  - L4 Protocol
  - L4 Source Port
  - L4 Destination Port
  - IP and Payload Data
  - Payload Data
Creating and Managing Capture Sessions

When you use the IP address fields in the hardware filters, tunneled packets will be filtered based on the outer IP address. The NAM will further inspect matching packets to analyze the contents within the tunnel. The NAM Packet Analyzer will always display the inner IP address in the packet list. See Understanding the NAM Packet Analyzer, page 3-33 for details.

Step 5 Data fields will then appear that correspond with the type of hardware filter you select. Fill in the desired fields.

Step 6 Click **Submit** to complete the configuration of the capture session.

**IP and Payload Data**
To configure an IP and Payload Data hardware filter:

**Step 1** Enter a Filter Name and select your options.
**Step 2** Enter a Source Address / Mask (optional).
**Step 3** Enter a Destination Address / Mask (optional).
**Step 4** Choose a Layer 4 Protocol, either TCP or UDP.
**Step 5** Enter the values for Pattern Match:
   - Enter a Value of up to four bytes (eight hex characters).
   - Enter a Mask of up to four bytes (eight hex characters).
   - Enter an Offset from 1-1023. The offset is relative to the beginning of the payload (Layer 5).

**Note** Only one payload segment (one row) is required and provided. This is to guard against overlapping payload segments. If overlapping segments have different values the filter will never match anything due to the inherent AND logic.

**Step 6** Click **Submit**.

**Payload Data**
To configure a Payload Data hardware filter:

**Step 1** Enter a Filter Name.
**Step 2** Choose a Layer 4 Protocol, either TCP or UDP.
**Step 3** Enter the values for Payload Data:
   - Enter a Value of up to four bytes (eight hex characters).
   - Enter a Mask of up to four bytes (eight hex characters).
   - Enter an Offset from 1-1023. The offset is relative to the beginning of the payload (Layer 5).
Only one payload segment (one row) is required and provided. This is to guard against overlapping payload segments. If overlapping segments have different values the filter will never match anything due to the inherent AND logic.

Step 4  
Click Submit.

Configuration Example

Figure 3-4 and Figure 3-5 shows configuration examples on how to calculate the offset value and how to set mask to use the payload feature.

Figure 3-4  Configuration Example

<table>
<thead>
<tr>
<th>No</th>
<th>Time</th>
<th>Source</th>
<th>Destination</th>
<th>Protocol</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.00000</td>
<td>96-19200 1010</td>
<td>66-16000</td>
<td>FTP</td>
<td>107</td>
</tr>
<tr>
<td>5</td>
<td>0.00609</td>
<td>96-19200 1010</td>
<td>66-16000</td>
<td>FTP</td>
<td>107</td>
</tr>
<tr>
<td>11</td>
<td>0.01484</td>
<td>96-19200 1010</td>
<td>66-16000</td>
<td>FTP</td>
<td>107</td>
</tr>
<tr>
<td>12</td>
<td>0.01884</td>
<td>96-19200 1010</td>
<td>66-16000</td>
<td>FTP</td>
<td>107</td>
</tr>
</tbody>
</table>

* Frame 1: 107 bytes on wire (954 bits), 107 bytes captured (954 bits)
* Ethernet II, Src: 00:00:00:00:00:01 (00:00:00:00:00:01), Dst: 00:00:00:00:00:02 (00:00:00:00:00:02)
* IP (version 4), 40 bytes (0x28)
* TCP (6), 60 bytes (0x3c)

Figure 3-5  Configuration Example (Continued)

<table>
<thead>
<tr>
<th>Offset</th>
<th>Value</th>
<th>Mask</th>
<th>Offset</th>
<th>Value</th>
<th>Mask</th>
<th>Offset</th>
<th>Value</th>
<th>Mask</th>
<th>Offset</th>
<th>Value</th>
<th>Mask</th>
</tr>
</thead>
<tbody>
<tr>
<td>23</td>
<td>34</td>
<td>56</td>
<td>80</td>
<td>D1</td>
<td>49</td>
<td>1A</td>
<td>45</td>
<td>34</td>
<td>56</td>
<td>80</td>
<td>D1</td>
</tr>
</tbody>
</table>

Hardware Filter Dialog

* Name: web/ftp/ PAYLOAD
  Type: IP and Payload Data
  Description: 66-19200 1010/126
  Protocol: TCP

Payload Data

<table>
<thead>
<tr>
<th>Offset</th>
<th>Value</th>
<th>Mask</th>
<th>Offset</th>
<th>Value</th>
<th>Mask</th>
<th>Offset</th>
<th>Value</th>
<th>Mask</th>
<th>Offset</th>
<th>Value</th>
<th>Mask</th>
</tr>
</thead>
<tbody>
<tr>
<td>0000</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
</tr>
<tr>
<td>0002</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
</tr>
<tr>
<td>0004</td>
<td>7D</td>
<td>33</td>
<td>FF</td>
<td>F6</td>
<td>FB</td>
<td>FF</td>
<td>F6</td>
<td>FB</td>
<td>FF</td>
<td>F6</td>
<td>FB</td>
</tr>
<tr>
<td>0006</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
</tr>
</tbody>
</table>

Hardware Filter Dialog

* Name: web/ftp/ PAYLOAD
  Type: Payload Data
  Protocol: TCP

Payload Data

<table>
<thead>
<tr>
<th>Offset</th>
<th>Value</th>
<th>Mask</th>
<th>Offset</th>
<th>Value</th>
<th>Mask</th>
<th>Offset</th>
<th>Value</th>
<th>Mask</th>
<th>Offset</th>
<th>Value</th>
<th>Mask</th>
</tr>
</thead>
<tbody>
<tr>
<td>0100</td>
<td>66</td>
<td>66</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
</tr>
<tr>
<td>0102</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
</tr>
<tr>
<td>0104</td>
<td>7C</td>
<td>2D</td>
<td>FF</td>
<td>F6</td>
<td>FB</td>
<td>FF</td>
<td>F6</td>
<td>FB</td>
<td>FF</td>
<td>F6</td>
<td>FB</td>
</tr>
<tr>
<td>0106</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
</tr>
<tr>
<td>0108</td>
<td>06</td>
<td>0A</td>
<td>68</td>
<td>55</td>
<td>BB</td>
<td>FF</td>
<td>F6</td>
<td>FB</td>
<td>FF</td>
<td>F6</td>
<td>FB</td>
</tr>
<tr>
<td>0110</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
<td>00</td>
</tr>
<tr>
<td>0112</td>
<td>60</td>
<td>60</td>
<td>60</td>
<td>60</td>
<td>60</td>
<td>60</td>
<td>60</td>
<td>60</td>
<td>60</td>
<td>60</td>
<td>60</td>
</tr>
</tbody>
</table>
Understanding Hardware and Software Capture Sessions Filters

You can filter specific traffic data and manage that information in local or remote storage. This increases your visibility into network issues and allows you to filter out unnecessary information. You can use either hardware or software filters to target specific packet data to receive.

As shown in Figure 3-6, if network packets coming into the NAM pass through the hardware filters you have configured, the packets go on to the next step. If no hardware filters are configured, all packets pass through.

Note
Hardware filters are supported on specific Prime NAM platforms. See Configuring Hardware Filters, page 3-9 for details.

Packets must then pass at least one software filter in that particular session to be saved by that session. If no software filters are configured for a session, then all packets are captured. For more information about software filters, see Configuring Software Filters, page 3-7.

For better performance for the supported NAM platforms, hardware filters are recommended over software filters, and fewer sessions are recommended over more sessions.

You do not have to configure the items in Figure 3-6 in any particular order. For example, you can set Global Capture Settings first, and then configure Capture Sessions, and then create filters; or, you can create Hardware and Software filters first, and then configure Capture Sessions, and finally apply Global Capture Settings. We recommend that you “Start” the session last; otherwise, you will start capturing before you have configured any filters and before doing any packet slicing.

Global Capture Settings and Hardware Filters can be changed at any time, even when the session is running; they will affect running capture sessions immediately. We recommend that you first stop your capture session to edit it since you may capture some unexpected packets during the filter change. See Understanding Global Capture Settings, page 3-20 for details.

Figure 3-6 NAM Capture Sessions Example
Viewing Capture Sessions

To access the basic operations for capturing, viewing and decoding packet data on the NAM, choose Capture > Packet Capture/Decode > Sessions.

The Capture Sessions window shows the list of capture sessions. If none have been configured, the list will be blank. Table D-58 describes the Capture Sessions fields and operations that you can perform from the Capture Sessions window.

Understanding Global Capture Settings

You can limit the size of the captured packets by using the Global Capture Settings to apply a custom packet slice and error settings for all capture sessions. This setting applies to NAM-3 and NAM-NX1 only. You can change these settings even when a filter is running since they affect the running sessions immediately.

To enable the Global Capture Settings, click Global Capture Settings in the Capture > Packet Capture/Decode > Sessions then click Enable and complete your selections.

To understand these settings see:

- Global Packet Slicing
- Error Packets

Global Packet Slicing

Global packet slicing affects all capture sessions, as opposed to the per-session Packet Slice Size parameter, and is performed in hardware. Use this feature to capture packets more efficiently when only the first N bytes are of interest to you. The capture buffer/file is smaller and the NAM is able to capture more packets per second.

The default setting for Global Packet Slicing is Disabled.

This setting overrides individual capture session software slicing settings if it is shorter. For example, if you have a capture session with the slicing field set to 100, but you also have Global Packet Slicing set to 56, then all packets will be sliced down to 56 bytes.

Hardware filters and global packet slicing affect all capture sessions, except for ERSPAN capture sessions.

In addition to global packet slicing you can set choose to allow error packets in the packet. For details on error packet settings, see Error Packets, page 3-20.

Error Packets

Error packets are packets that would normally be dropped by the network interface card, such as under size and over size packets, as well as packets with CRC errors. Error packets can be very helpful for troubleshooting the network.

If you want to customize how Prime NAM treats error packets use the following options:

- Include in capture (Default)—Includes packets with and without errors.
- Exclude from capture—Omits error packets. The packet capture only includes packets without errors.
• **Only error packets in capture**—Omits packets without errors. The packet capture includes only packets with errors. This option will save disk space but may not be as helpful since you may be unable to see the big picture view of all packet details.

This setting applies to all capture sessions on NAM-3 and NAM-NX1 only.

This setting is applied to all capture sessions. In addition to setting error packets, you can also enable global packet slicing. For details on global packet slicing settings, see Global Packet Slicing, page 3-20.

**Working with Capture Files**

To decode, download, rename, convert/merge, delete, analyze, or error-scan saved packet capture files use the Files option.

This section covers the following topics:

- Analyzing Capture Files, page 3-21
- Downloading Capture Files, page 3-22
- Deleting a Capture File, page 3-22
- Deleting Multiple Capture Files, page 3-22
- Understanding Capture Sessions, page 3-23

**Analyzing Capture Files**

The Capture Files window (available at Capture > Packet Capture/Decode > Files) enables you to obtain various statistics including traffic rate (bytes/second) over a capture period and lists of hosts and protocols associated with network traffic.

This window also enables you to drill down for a more detailed look at a particular set of network traffic. The pane above the Traffic over Time graph displays the time shown in the graph in the From: and To: fields. It also provides fields for Protocol and Host/subnet, and a Drill-Down button.

---

**Note**

After clicking the Drill-Down button, the Host Statistics results table will display both source and destination hosts, if either the source or destination host of the traffic belongs to the Host/Subnet that you had specified.

Each slice in the Traffic over Time graph displays the amount of traffic for the amount of time set in the Granularity of the capture file.

You can view more detail about a specific time frame by entering the time in the From: and To: fields and choosing Drill-Down. You can also drill down on a specific Protocol or Host/subnet address.

Table D-57 describes the different areas of the Capture Analysis window.

**Drilling Down into Packet Error Details**

You can further investigate, or drill down, into packet error details by viewing the decode packet data available on Prime NAM.
The Capture Errors and Warnings Information window shows warnings and errors, and packet irregularities. From here, you can launch the Packet Decode Window, where you can drill down to packet details.

To get to the Capture Errors and Warnings Information window, choose **Capture > Packet Capture/Decode > Files**. Highlight a file and click the **Errors Scan** button. The Error Scan window displays. The fields are described in Table D-60. Then select the packet details by selecting a row and clicking the **Decode Packets** button.

### Downloading Capture Files

You can only download one capture file at a time. To download a capture file to your computer:

**Step 1** Choose **Capture > Packet Capture/Decode > Files**.

**Step 2** Choose a capture file from the list of captures.

**Step 3** Click **Download**. A **File Download** dialog box displays and asks “**Do you want to save this file?**”

**Step 4** Click **Save**. A **Save As** dialog box opens and provides a way for you to rename and save the file at a location of your choice.

### Deleting a Capture File

To delete a capture file:

**Step 1** Choose **Capture > Packet Capture/Decode > Files**.

**Step 2** Check the check box to select a capture file from the list of captures, or select more than one if desired.

**Step 3** Click **Delete**. A dialog box displays and asks “**Delete the following file(s)?**” and displays the file name.

**Step 4** Click **OK** to delete the file(s) or **Cancel** to allow the file(s) to remain.

### Deleting Multiple Capture Files

To delete all capture files at once:

**Step 1** Choose **Capture > Packet Capture/Decode > Files**.

**Step 2** Check at least one check box to select a capture.

**Step 3** Click **Delete All** to delete all captures. A dialog box displays and asks “**Are you sure you want to delete all files?**”
Understanding Capture Sessions

To understand how Prime NAM creates capture files with saved packet data, it is important to learn about how NAM handles capture session triggers.

This section contains the following topics:

- Types of Capture Triggers, page 3-23
- Resolving Session Conflicts, page 3-23
- Manipulating Capture Files, page 3-24

Types of Capture Triggers

Packet capture sessions can be triggered on the Prime NAM in several ways:

- Manually, by starting a capture using the Capture menu option or clicking the Start capture button.
- Scheduled, by specifying a start date/time and maximum duration when you create or edit a capture session.
- Alarmed, by creating an alarm with an associated trigger capture action that starts a particular capture session.

Resolving Session Conflicts

Prime NAM supports multiple capture sessions associated with the same capture storage location, but only one of these sessions can be running at any given time. Since there are several ways for such capture session to be started, it is possible for conflicts to arise among such capture sessions.

For example, suppose one capture session is started manually, but another capture session is scheduled to begin capturing while the first is still running. If these two sessions capture to the same storage location, there is a conflict. In this case, Prime NAM resolves the conflict by automatically stopping the manual session and allowing the scheduled session to begin.

In general, NAM resolves capture session conflicts by prioritizing them in the following (descending) order:

1. High-severity alarm triggered capture
2. Low-severity alarm triggered capture
3. Scheduled capture
4. Manual capture

For example, if a manually started capture session is saving data to the local disk and a scheduled capture is set to begin capturing to the same local disk, Prime NAM stops the manual session before the scheduled session begins.

If there are existing capture sessions already running on the same storage target, this means there is a conflicting alarm trigger. An alarm trigger is created when you configure an alarm threshold to start collecting packet data. Each alarm has a severity option.

Once a capture session is completed, you can manipulate the file. See
Manipulating Capture Files
This section provides an overview of the tasks you can complete with capture files. See Table 3-2.
For information about how to save capture sessions to files, see Creating and Managing Capture Sessions, page 3-6.

Caution
If you have capture files with a state of Full and the NAM is rebooted, the capture is triggered again and these files may be overwritten by the new capture. If you want to retain the file, save the file before you reboot.

Table 3-2 Actions You Can Complete with Capture Files

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decode</td>
<td>Display the packets in a file.</td>
</tr>
<tr>
<td>Download</td>
<td>Download a file to your computer in .pcap file format.</td>
</tr>
<tr>
<td>Rename</td>
<td>Give the file a new name. A dialog box displays and asks you to enter the new name for the selected capture file.</td>
</tr>
<tr>
<td>Merge</td>
<td>Merges capture files that were captured simultaneously in chronological order.</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete selected capture files.</td>
</tr>
<tr>
<td>Analyze</td>
<td>View statistical analysis of the selected capture. See Analyzing Capture Files, page 3-21.</td>
</tr>
<tr>
<td>Errors Scan</td>
<td>View more information about the file (Packed ID, Protocol, Severity, Group, and Description). From here you can also decode the packet. For more information see Drilling Down into Packet Error Details, page 3-21.</td>
</tr>
</tbody>
</table>

Caution

Utilizing Capture Data Storage
Cisco Prime Network Analysis Module platforms offer external storage connectivity for extended capture durations and higher capture bandwidths. All platforms support iSCSI data storage. Some platforms may support other forms of data storage, but this document covers only iSCSI data storage.

This section covers the following topics:

- About Capturing to Data Storage, page 3-25
- Installing and Configuring Local and External Storage, page 3-25
- Recovering Data Storage, page 3-29
Chapter 3 Capturing and Decoding Packets

Utilizing Capture Data Storage

Figure 3-7 External Storage Setup

For instructions on installing and configuring external storage not covered here, see your platform-specific guides on Cisco.com or related documentation in the Cisco NAM Documentation Overview.

About Capturing to Data Storage

To avoid filling up the local server disk on the NAM, you can capture files to external storage. One of the benefits of using external storage is that it can provide larger capacities, higher read/write speeds, and can be moved from one Cisco NAM to another. The capture files are decoded in the same manner as the Capture > Packet Capture/Decode > Files page.

Using Prime NAM, you can perform internal and external storage management using Capture > Packet Capture/Decode > Data Storage. This window lists detected storage devices, including the internal hard drive, if one is available. For details on how to install and configure local and external storage, see Installing and Configuring Local and External Storage, page 3-25.

This release supports 32 external data storage targets, or Logical Unit Numbers (LUNs).

You can create multiple capture sessions per target. Only one capture per storage target (file location) is allowed at a time. Additionally you can have multiple sessions to memory.

Installing and Configuring Local and External Storage

You can use local or external storage as a repository for long term data for performance comparisons.

This topic covers:

- Configuring the iSCSI Array, page 3-26
- Preparing LUNs for File Storage, page 3-28
- Connecting the Storage Array, page 3-26
- Using LUNs to Store Packets from a Capture Session, page 3-28
- Logging In and Out of External Storage LUNs, page 3-28
- Connecting and Disconnecting External Storage, page 3-29
Configuring the iSCSI Array

You may decide that in addition to or instead of local storage that you want to set up an external storage drive using iSCSI. This section contains the required settings for Prime NAM.

Use your vendor’s user documentation to ensure you have properly configured the iSCSI array. The Prime NAM is independent of most array settings, but some are important for accessibility and performance.

Step 1  To configure the disk volumes on the array there is often a Segment Size setting. Larger segment sizes can improve write speeds. Configure the Segment Size setting to use the largest possible segment size (up to 512 KB).

Multiple volumes can be configured on a single array.

Step 2  Assign a Logical Unit Number (LUN) to the disk volume. This number is used for volume identification by the host.

Step 3  Map the LUNs to iSCSI Qualified Names (IQNs) on the array. Each IQN represents a different list of LUNs which hosts (such as the Prime NAM) can access.

Prime NAM supports up to 32 LUNs between all protocols and multiple LUNs mapped to one IQN.

Step 4  Prime NAM also has an IQN, which represents the host side of an iSCSI session. You must give the Prime NAM’s IQN access to the iSCSI array’s LUNs. The array calls this Host Access. Be sure to give the Prime NAM’s IQN read-write access. Most arrays require this for security reasons to ensure that only certain hosts can access the LUNs.

Each Prime NAM has a unique IQN, so perform this required step for each Prime NAM that requires access and for each target LUN that you want to access. For more details about which CLI command to use, see Locating the Prime NAM IQN, page 3-26.

Caution  Only one Prime NAM should connect to a LUN because only one host can have write access at a time. If multiple Prime NAMs connect to the same LUN simultaneously, there will be access conflicts and capture operations may not work properly.

Step 5  Ensure the Prime NAM management port has IP connectivity to the iSCSI array. For details on how to complete this required task, see Connecting the Storage Array, page 3-26.

Locating the Prime NAM IQN

To find the Prime NAM IQN, use the remote-storage iscsi local-iqu CLI command:

root@nam.domain# remote-storage iscsi local-iqu

For details on how to complete the storage array configuration, see Connecting the Storage Array, page 3-26.

Connecting the Storage Array

After you configure the iSCSI storage arrays, ensure that the array has an IP path to the Prime NAM management port. The array can be connected while the Prime NAM is running.
Some arrays come with multiple storage controller modules. As a security feature, module ownership must often be mapped to each LUN or IQN.

The Prime NAM logs into the storage to start an iSCSI session using the IP address and IQN(s) of the storage array.

To connect the storage array using the user interface:

**Step 1** Log into the Prime NAM web interface. To access the Data Storage page, choose **Capture > Packet Capture/Decode > Data Storage**.

**Step 2** Click **iSCSI Login** and enter the iSCSI array IP address. Then click **Search IQN Targets**. A list of IQNs available to the Prime NAMs host IQN appear.

**Step 3** Depending on the outcome, perform one of the following steps:

a. If the IQNs do not appear, check **remote-storage iscsi list** to verify the iSCSI session was properly started.

   The follow example shows how to verify the iSCSI session.

   ```
   root@nam.domain# remote-storage iscsi list
   Storage ID: 16
   Label:
   Status: Ready
   Protocol: ISCSI
   Target IP: 172.20.122.81
   Target IQN: iqn.2011-09:celeros.target11
   Type: LUN
   Model: IET VIRTUAL-DISK
   LUN: 4
   Capacity: 24.98GB
   Available: 24.98GB
   Active iSCSI Sessions:
   ```

   The LUN number (in the above example, **LUN 4**) helps you identify one LUN from others mapped to the same IQN. This number is unique to each IQN, meaning two LUNs from different IQNs can have the same number.

b. If the iSCSI session was properly started, check the storage array configuration to verify that:

   - The LUNs are mapped to the target IQN, and
   - The Prime NAM IQN has been given Read/Write access to the LUNs.

c. If you make any configuration changes, logout of the iSCSI session and login again. To logout, use the CLI **remote-storage iscsi logout** or use the GUI and click **iSCSI Logout**. All LUNs mapped to that target IQN will be disconnected from the Prime NAM.
Preparation of LUNs for File Storage

Some arrays come with multiple storage controller modules, and the module ownership must often be mapped to each LUN (Logical Unit Numbers). This is a common security feature.

To see if the NAM can access the storage array LUNs and prepare them to store files:

**Step 1** Choose **Capture > Packet Capture/Decode > Data Storage**.

New LUNs which have not been used by the NAM show a status of **Unformatted**.

a. Skip to **Step 3** if your LUNs are formatted.

b. If no LUNs appear, see **Installing and Configuring Local and External Storage**, page 3-25 and **Configuring the iSCSI Array**, page 3-26 for detailed instructions on how to set up your storage array.

**Step 2** To prepare these LUNs for capture use, select the LUN and click **Format**. After a few minutes, the status should change to **Ready**.

**Step 3** To apply optional user labels to the LUNs to help differentiate between them, select the LUN and click **Label**.

The Label dialog appears with information about the current label and the last time the LUN was formatted.

You are now ready to use the external storage for capture files.

Using LUNs to Store Packets from a Capture Session

To use a LUN to store packets from a capture session:

**Step 1** Go to **Capture > Packet Capture/Decode > Sessions**.

**Step 2** Under the Capture Sessions table, click **Create**.

**Step 3** Fill in the appropriate fields for creating a session, and for Storage Type choose the **Files** option.

**Step 4** Use the File Location table to select the LUN you wish to use. Each list entry includes the protocol and either the model or the user label if it is set. Note that the list will only include targets which are in the **Ready** state.

**Step 5** Click **Submit** to create the session.

When a session is **STARTED**, the associated LUN state changes to **In Use**. At that point, no other session can use that LUN until the session is deleted. This prevents contention, corrupted data, and write bandwidth degradation.

Logging In and Out of External Storage LUNs

You can use iSCSI to facilitate data transfers over intranets and to manage your remote capture data storage.

Prime NAM provides a more streamlined workflow to log in and out of your data storage targets. You must log into iSCSI in order to save capture sessions to remote storage. If you do not log in, capture sessions are saved to either local disk or memory locations.
Utilizing Capture Data Storage

To log in or out of your available remote data storage LUNs:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Ensure you have configured your target iSCSI system with read/write permission to your NAM for at least one LUN in the storage array. For details, see About Capturing to Data Storage, page 3-25.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Choose Capture &gt; Packet Capture/Decode &gt; Data Storage and click iSCSI Login.</td>
</tr>
<tr>
<td>Step 3</td>
<td>To enable auto discovery of any iSCSI Qualified Name (IQN) target, enter the target IP address of the storage location and click Search IQN Targets. All available IQNs for that location display in the table.</td>
</tr>
<tr>
<td>Step 4</td>
<td>To log out, click iSCSI Logout. The list of IQNs to which you are currently logged into displays in a table.</td>
</tr>
<tr>
<td>Step 5</td>
<td>To view the LUNs which the system will log you out, select one of the IQNs and a popup displays the associated LUNs to select.</td>
</tr>
</tbody>
</table>

Connecting and Disconnecting External Storage

Before physically disconnecting an external storage device, it is highly recommended to use the Unmount button on the Capture > Packet Capture/Decode > Storage window. This notifies the Cisco NAM that the device will be disconnected, so that the Prime NAM can perform important cleanup procedures. After this is done, the storage target displays as Unmounted in the status column, and it is safe to remove the external storage device. External storage is automatically unmounted in this manner when the Cisco NAM is powered down.

Caution

If this step is skipped, it is possible to corrupt the storage data upon physical disconnect.

If a device has been logically disconnected using the Unmount button, but the storage is still physically connected, it can be reactivated using the Mount button. It will restore the storage target’s previous state. This makes it unnecessary to physically disconnect and reconnect the storage, which can be particularly useful if the storage is located far away from you.

Recovering Data Storage

In the event that a previously working target displays as Unformatted, you can use the CLI to determine what happened by running a filesystem check on it. Use the command remote-storage <protocol> fsck <storage ID>, when you know the protocol. You can find the storage ID using remote-storage <protocol> list. The filesystem check can potentially resolve filesystem corruption or state issues. If the command succeeds, it automatically mounts the storage and displays as Ready.

The following shows a iSCSI recovery example:

root@nam.cisco.com# remote-storage iscsi list
Storage ID: 16
    Label:
    Status: Unformatted
    Protocol: ISCSI
    Target IP: 172.20.10.81
    Target IQN: iqn.2011-09:celeros.target11
    Model: IET VIRTUAL-DISK
    LUN: 4
    Capacity: 24.98GB
Inspecting Packet Decode Information for Suspicious Traffic

After you have captured some traffic data packets, you can use the NAM Packet Analyzer to view the packet contents and inspect for suspicious traffic.

This section includes the following sections:

- Analyzing Packets in the NAM Packet Analyzer, page 3-31
- Filtering Packets Displayed in the NAM Packet Analyzer, page 3-32
- Viewing Detailed Protocol Decode Information, page 3-33
- Understanding the NAM Packet Analyzer, page 3-33
Analyzing Packets in the NAM Packet Analyzer

Figure 3-8  NAM Packet Analyzer Window

Note
To use these decode features, you must be capturing to memory with the no rotate option selected. Otherwise, captures must be paused or stopped. For detailed descriptions about the features in this window, see Understanding the NAM Packet Analyzer.

To inspect packet decode information for suspicious traffic:

Step 1  Choose Capture > Packet Capture/Decode > Sessions and create a capture session. If you already have a capture session choose Capture > Packet Capture/Decode > Files.

Step 2  Choose a capture session or file, and then click Decode. The NAM Packet Analyzer window displays. See Figure 3-8. For table descriptions see Table D-63.

Step 3  To quickly filter on a key word or phrase, for example rtp to focus on voice quality, enter the word in the Filter text box (see callout 1 in Figure 3-8). The window refreshes displaying only data that includes the filtered information.

Step 4  To filter packet data based on multiple filters, click Display Filter and enter your options in the window, then click Apply. This action displays only the distribution of the packets that match your filter. For detailed steps, see Filtering Packets Displayed in the NAM Packet Analyzer, page 3-32.

Step 5  To save filters for future use, click Saved Filters on the Display Filter window. You can also edit or remove existing filters as needed.

Step 6  To view the packet capture flow and focus in on a specific time interval or area of interest click on the slider in the Packet Histogram and move the left or right cursors to zoom in (see callout 2 in Figure 3-8). To pan this filtered data, click and hold the slider while moving it inside the histogram. This provides a visual of packet capture flow and enables you to navigate through the packet list.
Step 7  To toggle
    • between a one and two-column layout view, choose Tools > Toggle Layout.
    • between the Packet Histogram and the packet paging controls, choose Tools > Show ...

Step 8  To disable the default colors in the packet window, choose Tools > Disable Protocol Coloring.

Step 9  To review capture file information, choose Tools > Capture Info.

Step 10 To save the current filtered packet info displayed on this page, choose Tools > Save Filtered Packets.
    Only visible when filters are in use. Saves to memory or to the capture file based on the options in your Capture Sessions window. See Configuring Capture Sessions, page 3-6.

Step 11 To make the font size larger or smaller for the hex data pane, hover over the top-right corner of the pane to see the enlarge option. To increase the font, select the A+ or to decrease it select the A-.

Step 12 Use the Tools menu to perform validation tasks—options have limited support. Options include:
    - TCP Checksum Validation check box—filter on TCP in the decode window and use the TCP pane to verify that the checksum has been validated.
    - UDP Checksum Validations check box—filter on UDP in the decode window and use the UDP pane to verify that the checksum has been validated.
    - IP Host Name Resolution—perform global host name resolution for NAM. Synchronizes with the Administration preferences.

Step 13 To view packet details including packet range displayed, data port, and number of filtered packets, see the heading in the upper right corner of the NAM Packet Analyzer window.

Filtering Packets Displayed in the NAM Packet Analyzer

To filter packets based on multiple options for display in the NAM Packet Analyzer:

Step 1  From the NAM Packet Analyzer, click Display Filter. The NAM Packet Analyzer - Display Filter Window displays.

Step 2  Do the following:
    • Choose a Filter Mode:
      - Inclusive displays packets that match the condition(s.)
      - Exclusive displays packets that do not match the condition(s).
    • Choose an Address Filter:
      - IP/Host address filters on IP address.
      - MAC address filters on MAC address.
      - Source allows you to specify the source address, or leave it blank if not applicable.
      - Destination allows you to specify the destination address, or leave it blank if not applicable.
      - Both Directions allows you to match of packets traveling in both directions.
    • Define a Protocol Filter:
      - Click Match any (or) to display packets that match any of the protocols or fields.
    or
- Click **Match all (and)** to display packets that match all of the protocols or fields.
- Choose a protocol from the **Protocols** list.

**Note**
You can enter the first few letters of the protocol name to go directly to the protocol. If you make a typo, press **ESC** or **SPACE** to reset.

- Choose a protocol field from the **Fields** list, then specify the field value if applicable.

**Step 3**
To add more protocol filters, click the + sign.

**Step 4**
To delete a defined Protocol Filter, click the - sign.

**Step 5**
Click **OK** to apply the filter and close the window or **Apply** to apply the filter and keep the window open.

---

**Viewing Detailed Protocol Decode Information**

To view detailed protocol information:

**Step 1**
Highlight the packet number about which you want more information.

Detailed information about that packet is displayed in the Protocol Decode and hexadecimal dump panes at the bottom of the window.

**Note**
If you highlight the details in the Protocol Decode pane, the corresponding bytes are highlighted in the hexadecimal dump pane below it.

**Step 2**
To review the information, use the scrolling bar in the lower panes.

**Note**
When you decode SCCP traffic, Prime NAM lists the protocol as **skinny**, not SCCP.

**Tip**
- Protocols are color coded both in the Packet Browser and the Protocol Decode pane.
- Choose the protocol name in the Protocol Decode pane to collapse and expand protocol information.
- To adjust the size of any of the panes, click and drag the pane frame up or down.

---

**Understanding the NAM Packet Analyzer**

The NAM Packet Analyzer, also known as the packet decoder, uses two levels of packet analysis: basic and full. Because preparing a large capture file for full analysis can take a long time, NAM automatically chooses which level to use based on your filtering complexity. This allows you to browse your captured packet data more quickly without having to wait for analysis.
When you select a capture file to analyze for the first time, NAM limits some of the more complex display filters you can use. For example, you can filter using protocol identifiers such as TCP, UDP, SDP, and SIP which allow the packet decode to display more quickly than an advanced filtering selection.

If you enter more advanced filters (such as those with and/or logic operators on the protocol field), NAM automatically begins the full analysis of the capture file and then applies your complex filter to display the results. For example, if you filter using ‘ip.src==192.168.1.1 && tcp.dstport==80’, the NAM Packet Analyzer starts the full analysis and displays it only after the results have been filtered.

**Understanding the NAM Packet Analyzer Window and Browser Pane**

The NAM Packet Analyzer window shows three views of a packet:

- a summary line briefly describes the packet type
- the protocol field of interest can be shown and analyzed in the portion of the window directly below the summary line
- a hexadecimal dump shows exactly what the packet looks like when it goes across the wire.

There are many unique features in the NAM Packet Analyzer decode window; for example, it can assemble all the packets in a TCP conversation and highlight the ASCII data in that conversation. You can use the expanded display filter functionality to allow you to view more focused data.

Figure 3-8 is an example of the NAM Packet Analyzer window. Table D-64 describes the packet decoder operations on the NAM Packet Analyzer decoder window.

You can perform the following tasks in the NAM Packet Analyzer window:

- Show Packet histogram display the number of packets over a specific time range. This provides a feel of the packet flow for the capture. You can use the histogram selector control to navigate through the packet list as well. You can apply a display filter to make the histogram show the distribution of the packets that match the applied filter. Can set time range and move across histogram. Firefox is faster than IE performance with this feature.
- Toggle to Show Packet Paging Controls displays the buffer divided into pages.
- Toggle layout changes how the three content panes in the decoder are arranged.
- Display Hex data font size by hovering over two buttons in the top right corner of the hex data content pane of the decoder. You can increase or decrease the font size of the contents.
- Display the current range of packets in the packet list by selecting the Packet range button. You can also enter the range of packets to view.
- Use the Display Filter button yo display Saved Display Filters and Manage Display Filters windows.
- Alter Protocol coloring. You can map custom colors to specific protocols in this release. Default colors
- Use the Tools menu—options have limited support. Options include:
  - TCP Checksum Validation check box—filter on TCP in the decode window and use the TCP pane to verify that the checksum has been validated.
  - UDP Checksum Validations check box—filter on UDP in the decode window and use the UDP pane to verify that the checksum has been validated.
  - IP Host Name Resolution—perform global host name resolution for NAM. Synchronizes with the Administration preferences.
- Display Filter input field to manually enter display filters.
Customizing Display Filters

Use custom display filters to create and save customized filters to use in the NAM Packet Analyzer decode window to limit which packets are displayed.

NAM supports most software display filters with the following exceptions:

- Filters using Perl Regular Expressions. For example:
  
  \n  http.request.uri matches "gl=se$"
  
- Filters on a protocol payload (a protocol section in a packet). For example:
  
  udp[8:3]==81:60:03

See these topics for help setting up and managing custom display filters:

- Creating Custom Display Filters, page 3-35
- Editing or Deleting Custom Display Filters, page 3-38

Creating Custom Display Filters

To create custom display filters:

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Choose Capture &gt; Packet Capture/Decode &gt; Sessions. The Hardware Filters box is displayed at the bottom of the page.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Click Create. The Hardware Filters Dialog box displays. See Table D-62.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Enter information in each of the fields as appropriate.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Do one of the following:</td>
</tr>
<tr>
<td></td>
<td>To create the filter, click Submit.</td>
</tr>
<tr>
<td></td>
<td>To cancel filter creation, click Cancel.</td>
</tr>
</tbody>
</table>

Tips for Creating Custom Decode Filter Expressions

You can construct custom decode filter expressions using the following logical and comparison operators listed in Table 3-3.
To group subexpressions within parentheses, use the fields in Table D-61 to help you add filter expressions.

**Examples of Custom Decode Filter Expressions**

Table 3-4 provides some examples of basic NAM display filters you can use to filter on application types.

<table>
<thead>
<tr>
<th>Filter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>tcp</td>
<td>Find all TCP-based applications</td>
</tr>
<tr>
<td>udp</td>
<td>Find all UDP-based applications</td>
</tr>
<tr>
<td>! eth</td>
<td>Find all packets other than Ethernet</td>
</tr>
<tr>
<td>tcp and not vlan</td>
<td>Find all TCP traffic NOT running over vlan</td>
</tr>
<tr>
<td>http</td>
<td>Find all src/dst HTTP application packets (may be not standard port 80 if different application 'decode as' port specified; e.g. 'tcp.port==8080,http')</td>
</tr>
<tr>
<td>ftp</td>
<td></td>
</tr>
<tr>
<td>not tcp</td>
<td>Exclude all TCP packets</td>
</tr>
<tr>
<td>! tcp</td>
<td>Exclude all TCP packets</td>
</tr>
<tr>
<td>! (ftp</td>
<td></td>
</tr>
</tbody>
</table>

Table 3-5 provides some examples of complex NAM display filters.

<table>
<thead>
<tr>
<th>Filter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>tcp.port eq 80</td>
<td>Find all src/dst HTTP packets on standard HTTP port 80</td>
</tr>
<tr>
<td>ip.addr == 192.168.1.0/24</td>
<td>Find all packets in Class C network (subnet)</td>
</tr>
<tr>
<td>tcp.flags.reset == 1</td>
<td>Find all TCP resets</td>
</tr>
</tbody>
</table>
Table 3-5  Compound NAM Display Filters (continued)

<table>
<thead>
<tr>
<th>Filter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>tcp.window_size == 0 &amp; &amp; tcp.flags.reset != 1</td>
<td>Src is instructing dst to stop sending data (TCP buffer full)</td>
</tr>
<tr>
<td>Ipv6.addr == ::1</td>
<td>Correct statement with IPv6 label and IPv6 address.</td>
</tr>
</tbody>
</table>

Table 3-6 provides some examples of protocol field hexbyte filters.

Table 3-6  Protocol Field Hexbyte Filters

<table>
<thead>
<tr>
<th>Filter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>eth.src==00:3c:06:0a:02:68</td>
<td>Find source MAC</td>
</tr>
<tr>
<td>eth.dst==00:3c:06:0a:02:68</td>
<td>Find destination MAC</td>
</tr>
<tr>
<td>eth.addr==00:3c:06:0a:02:68</td>
<td>Find source or dest MAC</td>
</tr>
<tr>
<td>! (eth.addr==00:3c:06:0a:02:68)</td>
<td>Find all MAC except specific address</td>
</tr>
<tr>
<td>eth.addr contains 00:3c</td>
<td>Find bytes in any protocol field subrange</td>
</tr>
</tbody>
</table>

Table 3-7 provides some examples of protocol field hexbyte subrange filters.

Table 3-7  Protocol Field Hexbyte Subrange Filters

<table>
<thead>
<tr>
<th>Filter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>eth.addr[0:2]==00:3c</td>
<td>Find specific subrange in MAC</td>
</tr>
<tr>
<td>eth.addr[1:3]==3c:06:0a</td>
<td>Find specific subrange in MAC</td>
</tr>
</tbody>
</table>

Table 3-8 provides some examples of hexbyte data representations syntax.

Table 3-8  Hexbyte Data Representations (Syntax)

<table>
<thead>
<tr>
<th>Filter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>eth.dst == ff:ff:ff:ff:ff</td>
<td>Hexbyte separators can be colons</td>
</tr>
<tr>
<td>eth.dst == ff-ff-ff-ff-ff</td>
<td>Hexbyte separators can be dashes</td>
</tr>
<tr>
<td>eth.dst == ffff.ffff.ffff</td>
<td>Hexbyte separators can be dots (one or two bytes)</td>
</tr>
</tbody>
</table>

Note You can use a filter expression with other fields in the Custom Decode Filter dialog box. In this case, the filter expression is ANDed with other conditions. Invalid or conflicting filter expressions result in no packet match.
Editing or Deleting Custom Display Filters

To edit custom display filters:

Step 1  From the NAM Packet Analyzer, choose Display Filters.
Step 2  To edit a filter, choose the filter to edit then click Edit.
Step 3  Change the information in each of the fields as appropriate.
Step 4  To delete a filter, choose the filter to delete from the Hardware Filters Data Port 1 or Data Port 2 pane, then click Delete.
Performing User and System Administration

This chapter provides information about what user and system administration tasks are required or optional, how to generate diagnostic information when requesting technical assistance, and provide user access.

This chapter contains the following topics:
- Performing System Administration, page 4-1
- Troubleshooting Using Diagnostics Tools, page 4-13
- Controlling User Access, page 4-15
- Managing System Data, page 4-22

Performing System Administration

You can perform the following system administration tasks:
- Setting Network Parameters, page 4-3
- Setting the SNMP Agent, page 4-3
- Synchronizing Your System Time, page 4-5
- Sharing NAM Data by Enabling Web Data Publication, page 4-8
- Setting Remote Servers to Receive Syslog Messages, page 4-9
- Configuring Hosts to Receive SNMP Traps from Prime NAM, page 4-9
- Licensing, page 4-10
- Customizing System Preferences, page 4-12
- Importing/Exporting Configuration Details, page 4-13
For at-a-glance details on why you may want to perform these system administration tasks, see Table 4-1.

<table>
<thead>
<tr>
<th>Task</th>
<th>Choose...</th>
</tr>
</thead>
<tbody>
<tr>
<td>View system health and traffic details</td>
<td>Administration &gt; System &gt; Overview</td>
</tr>
<tr>
<td>Use IP hostname resolution/DNS lookup</td>
<td>Administration &gt; System &gt; Network Parameters</td>
</tr>
<tr>
<td>Add extra security and allow additional host details to be displayed in NAM traffic information</td>
<td>Administration &gt; System &gt; SNMP Agent</td>
</tr>
<tr>
<td>Ensure that the NAM system time is configured correctly (required)</td>
<td>Administration &gt; System &gt; System Time</td>
</tr>
<tr>
<td>Provide e-mail notification of alarms and reports</td>
<td>Administration &gt; System &gt; E-Mail Setting</td>
</tr>
<tr>
<td>Allow general web users and websites to access selected NAM monitor and report windows without a login session</td>
<td>Administration &gt; System &gt; Web Data Publication</td>
</tr>
<tr>
<td>Specify whether syslog messages should be logged locally on the NAM, on a remote host, or both</td>
<td>Administration &gt; System &gt; Syslog Setting</td>
</tr>
<tr>
<td>Set a host destination to which Prime NAM sends trap</td>
<td>Administration &gt; System &gt; SNMP Trap Setting</td>
</tr>
<tr>
<td>Allow extension of evaluation period and permanent usage of the vNAM without expiration</td>
<td>Administration &gt; System &gt; SMART License</td>
</tr>
<tr>
<td>Change the Prime NAM display or logging characteristics</td>
<td>Administration &gt; System &gt; Preferences</td>
</tr>
<tr>
<td>Import or Export configuration details</td>
<td>Administration &gt; System &gt; Import/Export Configuration</td>
</tr>
</tbody>
</table>

---

**Monitoring Prime NAM Health and Traffic Statistics**

Ensuring that your Cisco NAM processes your traffic efficiently and effectively without becoming overloaded is a critical task.

To view the network traffic coming into the Cisco NAM as well as data about its health (such as server network details and CPU, memory, and data usage) use Administration > System > Overview.

Use the data provided in the Inputs and Resources tabs to determine scalability issues and to assist with troubleshooting.

Table D-66 describes the types of information of the System Overview window.
Setting Network Parameters

If you want to use IP hostname resolution in Prime NAM, you must configure the nameservers first. Prime NAM supports three DNS servers. If this task is not complete, you will be unable to perform DNS lookup. You can also set

Ensure your name server addresses are correct, otherwise some of your Monitor dashboards and Capture Decode windows may seem slow to load.

To view and set your name servers:

Step 1 Choose Administration > System > Network Parameters.
The Network Parameters window displays.
Step 2 Enter or change the IPv4 or IPv6 information.
Step 3 To validate the accuracy of the nameservers, click Validate Nameservers.
Step 4 Do one of the following:
  • To save the changes, click Submit.
  • To cancel the changes, click Reset.
Step 5 Ensure you have turned on IP hostname resolution using Administration > System > Preferences. See Customizing System Preferences, page 4-12.

Setting the SNMP Agent

An SNMP Agent is a network management software module that resides in a managed device. It has local knowledge of management information and translates that information into a form compatible with SNMP.

You can manage devices with SNMPv3 in addition to SNMPv2 and SNMPv1. The NAM polls the managed device to get its basic health and interface statistics. For NAM blades, the managed device is the switch in which the NAM is inserted, and the NAM software negotiates with the switch to use SNMP and a community string to do the polling. This community string is only valid for use with the NAM. For security purposes, the switch associates the community string with the NAM's IP address only, and no other SNMP application can use this community string to communicate with the switch. For more information about community strings, see Working with NAM Community Strings, page 4-4.

Also, to further alleviate any security concerns, the SNMP exchanges between NAM blades and the switch take place on an internal backplane bus. These SNMP packets are not visible on any network, nor any interface outside of the switch. It is a completely secure out-of-band channel inside the switch.

For other platforms, such as Cisco NAM appliances, you can type in any IP address and use it as the managed device. In setting managed devices, virtual NAM platforms managed devices function just like the NAM appliances. On all platforms, NAM can only monitor and display data for one managed device at a time.

In this case, the managed device may only want to use SNMPv3 since it is more secure.
Performing System Administration

**Note**

NAM blades use SNMPv2 to manage the locally managed device.

For RISE appliances, if the managed device is a Nexus switch/VDC, RISE service is configured on the Nexus switch SUP. When RISE service is configured, Nexus device and NAM will automatically sync up the VDC and interfaces information. NAM in this environment is used to manage more than one VDC’s interface statistics, without moving physical data port connections between NAM and switch.

To view and set the NAM SNMP agent, follow these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Choose <strong>Administration &gt; System &gt; SNMP Agent</strong>.</td>
</tr>
<tr>
<td>2</td>
<td>Enter or change the information in the NAM SNMP window. The fields are detailed in Table D-67.</td>
</tr>
<tr>
<td>3</td>
<td>To create community strings, see Creating NAM Community Strings, page 4-4.</td>
</tr>
<tr>
<td>4</td>
<td>To delete community strings, select the entry and click <strong>Delete</strong>.</td>
</tr>
<tr>
<td>5</td>
<td>To save the changes, click <strong>Submit</strong>.</td>
</tr>
</tbody>
</table>

**Working with NAM Community Strings**

You use community strings so that other applications can send SNMP get and set requests to the NAM, set up collections, poll data, and so on.

**Creating NAM Community Strings**

To create the NAM community strings:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Choose <strong>Administration &gt; System &gt; SNMP Agent</strong>.</td>
</tr>
<tr>
<td>2</td>
<td>Click <strong>Create</strong> under NAM Community Strings. The <strong>System SNMP Agent Dialog Box</strong> displays.</td>
</tr>
<tr>
<td>3</td>
<td>Enter the community string (use a meaningful name).</td>
</tr>
<tr>
<td>4</td>
<td>Enter the community string again in the Verify Community field.</td>
</tr>
<tr>
<td>5</td>
<td>Assign read-only or read-write permissions using the following criteria:</td>
</tr>
<tr>
<td></td>
<td>• Read-only allows only read access to SNMP MIB variables (get).</td>
</tr>
<tr>
<td></td>
<td>• Read-write allows full read and write access to SNMP MIB variables (get and set).</td>
</tr>
<tr>
<td>6</td>
<td>To make the changes, click <strong>Submit</strong>.</td>
</tr>
</tbody>
</table>

**Deleting NAM Community Strings**

To delete the NAM community strings:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Choose <strong>Administration &gt; System &gt; SNMP Agent</strong>.</td>
</tr>
<tr>
<td>2</td>
<td>Select an entry, then click <strong>Delete</strong>.</td>
</tr>
</tbody>
</table>
Caution
Deleting the NAM community strings blocks SNMP requests to the NAM from outside SNMP agents.

Testing the Router Community Strings

Before the router can send information to the NAM using SNMP, the router community strings set in the NAM must match the community strings set on the actual router. The Router Parameters dialog box displays the router name, hardware, Supervisor engine software version, system uptime, location, and contact information.

The local router IP address and the SNMP community string must be configured so that the NAM can communicate with the local router.

To set the community strings on the router, use the router CLI. For information on using the CLI, see the documentation that accompanied your device.

Caution
The router community string you enter must match the read-write community strings on the router. Otherwise you cannot communicate with the router.

To test router community strings:

Step 1 Choose Setup > Managed Device > Device Information. The Device Information dialog box displays.
Step 2 Enter the Device’s Community String.
Step 3 Click Test Connectivity.
Step 4 Wait for a while for NAM to communicate with the Device. If it comes back OK, then click on Submit.

Synchronizing Your System Time

Ensure that the NAM system time is configured correctly. If the system time is incorrect, NAM data presentation may be inaccurate due to time ranges, hence providing incorrect interpretations of NAM data.

Some platforms are synchronized automatically, but you must also synchronize the standard time source outside the NAM in addition to the NAM and the router, switch, or in order for the data to be accurate. We recommend you perform the time synchronization for your platform, especially if you see the following message on the dashboard interface: Client or NAM time is incorrect.

You can configure the NAM system time by using one of the following methods:

- Configuring the NAM System Time with an NTP Server, page 4-6
  This is valid for all platforms and is the recommended option.
- Synchronizing the NAM System Time with the Switch or Router, page 4-6
  This option is valid only for NAM-3 and NAM-NX1.
Performing System Administration

- Synchronizing the NAM System Time Locally, page 4-6
  This option is valid for Cisco NAM appliances, Nexus 1000 VSB, and vNAM.
- Configuring the NAM System Time with Precision Time Protocol (IEEE 1588), page 4-7
  This option is valid for NAM-3 and NAM-NX1.

Configuring the NAM System Time with an NTP Server

To configure the NAM system time with an NTP server:

Step 1 Choose Administration > System > System Time.
Step 2 Choose the NTP Server radio button.
Step 3 Enter one or two NTP server names or IP address in the NTP server name/IP Address text boxes.
Step 4 Select the Region and local time zone from the lists.
Step 5 To save the changes, click Submit.

Synchronizing the NAM System Time with the Switch or Router

Note This section is valid only for NAM-3 and NAM-NX1. For additional platform options, see Synchronizing Your System Time, page 4-5.

To configure the NAM system time from the switch or router:

Step 1 Choose Administration > System > System Time.
Step 2 Choose:
  - Local to sync to your switch or router. If you choose this option you must <is there anything on the router side that needs to be done?>
  - NTP Server
Step 3 Select the Region and local time zone from the lists. This should be the region in which your NAM is located.
Step 4 Click Submit.

Synchronizing the NAM System Time Locally

Note This section is valid for Cisco NAM appliances, Nexus 1000V, and vNAM. For additional platform options, see Synchronizing Your System Time, page 4-5.

To configure the NAM system time locally using the NAM command line:

Step 1 Log into the NAM command line interface.
Step 2 Set the clock using the CLI clock set command.
Performing System Administration

Chapter 4: Performing User and System Administration

Performing System Administration

Step 3: On the Prime NAM GUI, choose Administration > System > System Time.

Step 4: Click the Local radio button.

Step 5: Select the Region and local time zone from the lists.

Step 6: Click Submit to save the changes.

Configuring the NAM System Time with Precision Time Protocol (IEEE 1588)

To use Precision Time Protocol (PTP), you will need to have a PTP-aware or multicast-enabled switch connected to the sync port on the front of the NAM-3 or NAM-NX1, as well as a PTP master connected to the switch.

Note: This section is applicable to the NAM-3 and NAM-NX1. For details on any hardware setup requirements related to this feature, see your specific NAM installation guide. For additional platform options, see Synchronizing Your System Time, page 4-5.

To configure the NAM system time using PTP:

Step 1: On the NAM, choose Administration > System > System Time.

Step 2: Choose the PTP radio button.

Step 3: Enter the IP address of the PTP interface in the PTP Interface IP Address field.

Tip: Set the PTP interface IP address so that it is not in the same subnet as the management interface. If they are in the same subnet, there may be routing issues for outbound management traffic (http, for example).

Step 4: Enter the subnet mask in the PTP Interface Subnet Mask field.

Step 5: For NAM Local Time Zone, select the Region and the Zone from the drop-down lists.

Step 6: To save the changes, click Submit.

Understanding NAM System Time

Ensure that the Prime NAM software application’s Linux system time is synchronized with the packet timestamp and the standard time source outside of the NAM platform. Packet timing analysis uses system time to support application response time measurements, voice and video quality metrics, packet decode data, reporting, and many other network statistics.

The NAM gets the UTC (GMT) time from several sources, depending on its NAM platform type. All NAMs can be set up to get their time from an external NTP server. Other NAM platforms may prefer to use an IEEE 1588 Precision Time Protocol (PTP)-based time master due to its high accuracy and precision.
You should also configure any PTP switches that are between the NAM and the master clock to use Edge-to-Edge (E2E) mode. E2E is preferred because it reduces PTP messaging bandwidth and eliminates delay accumulation when daisy chaining many nodes. If the master clock and/or PTP switches are not configured correctly, all of the clocks on the NAM will be synced with each other, but to the wrong time.

**Caution**

Both the client computer and the NAM server must have the time set accurately for their respective time zones. If either the client or the server time is incorrect, then the data shown in the GUI is incorrect.

The clock identity is the first three octets of the MAC address, followed by “ff fe,” and then the last three octets of the MAC address, as shown in the example below.

0xec:44:76:ff:fe:5d:12:0

After the NAM acquires the time, you can set the local time zone using the NAM System Time configuration window.

For details on how to configure the NAM system time for your specific hardware platform, see *Synchronizing Your System Time, page 4-5*.

---

### Setting Up E-Mail Notifications for Alarms

You can configure Prime NAM to provide e-mail notification of alarms and to e-mail reports.

To set up e-mail notifications:

**Step 1**  Choose Administration > System > E-Mail Setting.

**Step 2**  Check the Enable Mail check box and enter the required or optional field information.

Table D-68 describes the Mail Configuration Options.

**Step 3**  Check the optional Advanced Settings check box and enter the details in the fields provided.

**Step 4**  Click Submit to save your modifications, or click Reset to clear the dialog of any characters you entered or restore the previous settings.

---

### Sharing NAM Data by Enabling Web Data Publication

Web Data Publication allows general web users and websites to access (or link to) selected NAM monitor and report windows without a login session.

Web Data Publication can be open or restricted using Access Control List (ACL) and/or publication code. The publication code, if required, must be present in the URL address or cookie to enable access to published data.

To enable Web Data Publishing:

**Step 1**  Choose Administration > System > Web Data Publication.

**Step 2**  Check the Enable Web Data Publication check box.
Step 3  Enter a Publication Code (Optional). This is the pass code required in a URL’s cookie to access the published page. For example, a publication code set to abc123 would be able to access the following published window:

http://<cnam-hostname>/application-analysis/index?publicationcode=abc123

Step 4  Enter an ACL Permit IP Address/Subnets to permit only those IP addresses or subnets access to web publications. No entry provides open access to all.

Step 5  Click Submit to enable web publishing, or click Reset to clear the dialog of any characters you entered.

Note  Before the new iSCSI storage entry takes effect, you must reboot the NAM system.

Setting Remote Servers to Receive Syslog Messages

NAM syslogs are created for alarm threshold events, voice threshold events, or system alerts. You can specify whether syslog messages should be logged locally on the NAM, on a remote host, or both. You can use the NAM to view the local NAM syslogs.

If logging on a remote host, in most Unix-based systems, the syslog collector that handles the incoming syslog messages uses the facility field to determine what file to write the message to, and it will use a facility called local7. Check the syslog collector configuration to ensure that local7 is handled properly.

To set up the NAM syslog:

Step 1  Choose Administration > System > Syslog Setting.

The NAM Syslog Setting window displays.

Step 2  In the Remote Server Names field, enter the IP address or DNS name of up to five remote systems where syslog messages are logged. Each address you enter receives syslog messages from all three alarms (Alarm Thresholds, Voice Signaling Thresholds, and System).

Step 3  Click Submit to save your changes, or click Reset to cancel.

Configuring Hosts to Receive SNMP Traps from Prime NAM

Traps are used to store alarms triggered by threshold crossing events. When an alarm is triggered, you can trap the event and send it to a separate host. Trap-directed notifications can result in substantial savings of network and agent resources by eliminating the need for frivolous SNMP requests.

To configure, edit, or delete a host destination to which Prime NAM will send traps:

Step 1  Choose Administration > System > SNMP Trap Setting.

The SNMP Trap Setting window displays.

Step 2  Click Create.

Step 3  In the Community field, enter the community string set in the NAM Thresholds.
Step 4  In the IP Address field, enter the IP address to which the trap is sent if the alarm and trap community strings match.

Step 5  In the UDP Port field, enter the UDP port number.

Step 6  Click **Submit** to save your changes, or click **Reset** to cancel and leave the configuration unchanged.

---

**Licensing**

Certain software-only NAM platforms require software licenses to run. You can see your NAM platform installation guide for details.

To obtain a NAM license, go to the following URL:

http://www.cisco.com/go/license

Follow the instructions on this page to obtain a NAM license file. You will need your NAM platform’s PID and SN to obtain the license file.

Tip  Use the Prime NAM show inventory command to obtain the PID and SN for licensing.

After you enter the PID and SN or the Product Authorization Key, a license file will be sent by e-mail. Store the license file on an available FTP server. Use the license install command to install the license after the NAM software installation completes.

Several Cisco Prime Network Analysis Module platform requires you to install a product license in the form of a text file.

Note  See your release notes as platform support changes with each release.

An evaluation license allows you to use the software for up to 60 days. The NAM login window indicates how many days remain before the evaluation license expires. After that time, you will be unable to log into the NAM GUI.

For details on licensing install and management CLI commands, see the *Cisco Prime Network Analysis Module Command Reference Guide*.

There is no license required for the protocol pack usage in Prime NAM.

There are two types of license:

- CSL or Node-locked Licensing
- SMART Licensing

When you purchase a license you will be provided with a URL that points you to the Cisco Smart Software Manager portal where you can manage your licenses and monitor their usage. For more details on the portal, see *Cisco Smart Software Manager User Guide*.

**CSL or Node-locked Licensing**

Only specific NAM platforms such as vNAM, and NAM on Nexus VB N1K-1110-X(), support node-locked licensing or CSL.
SMART Licensing

SMART License allows you to extend the evaluation period which is 90 days, and permanently use the vNAM without expiration and also allows you to increase the traffic rate that you can monitor on vNAM, for the purchased license. Smart Licensing introduces licensing by pool or virtual account.

Pooling or Virtual account provides:

- Full visibility to all assets across the company
- Central repository for all licenses
- Licenses that are Enterprise Account specific and can be used with any compatible device in your company

To use SMART License feature you must have access to internet. You can follow the below methods:

- Direct access—You can deploy vNAM on the internet directly.
- Proxy Server—You can use a proxy server to access the internet from your intranet.
- Transport Gateway—You can access the internet using a transport gateway which is set in your DMZ.

The only platform supported for SMART licensing is vNAM and includes both KVM based vNAM and vNAM on the ESX hypervisor.

Setting SMART License

To register with a Smart Licensing token using GUI, follow these steps:

**Step 1** Choose Administration > System > SMART License.

The SMART License Settings page appears.

**Step 2** Enter a token to register the product instance.

For details on creating a registration token, see “Creating a Product Instance Registration Token” section in *Cisco Smart Software Manager User Guide*.

**Step 3** Click Register Token to register the product instance.

**Step 4** Enter the tag details.

**Step 5** Click Request Tag to request a tag based on different rate limits.

To register with a Smart Licensing token using CLI:

**Step 1** Enter the command callhome.

```
root@nam.localdomain# callhome ?
```

**Step 2** (Optional) Enter the command transport http gateway <url> to set the smart licensing back end URL. This is required only when you use a Transport Gateway.

```
root@nam.localdomain# callhome transport http gateway <url>
```

**Step 3** (Optional) Enter the command callhome transport http proxy <url> <port> to set the proxy. This is required only when you use proxy method.

```
root@nam.localdomain# callhome transport http proxy <url> <port>
```
Step 4  Set up a DNS server so NAM can resolve the back end URL.
   a.  Enter the command `ip nameserver` to set the nameserver.
   b.  Enter the command `ip domain` to set the domain.

Step 5  Enter the command `license smart`.
   root@nam.localdomain# license smart ?
   de-register             - de-register smart licensing agent
   disable                - disable smart licensing agent
   enable                 - enable smart licensing
   register               - register smart licensing agent
   release                - release entitlements
   renew                  - renew auth
   request                - request license entitlement

Step 6  Enter the command `enable` to enable SMART license.
   root@nam.localdomain# license smart enable

Step 7  Enter the command `register idtoken <idtoken>`.
   Enter a token to register the product instance.
   root@nam.localdomain# license smart register idtoken <idtoken>
   For details on creating a registration token, see “Creating a Product Instance Registration Token” section in Cisco Smart Software Manager User Guide.

Step 8  Enter the command `request tag <tag>` to request a tag based on different rate limits.
   root@nam.localdomain# license smart request tag <tag>

When all the licenses in a license pool is used up, and when you get an Out Of Compliance (OOC) status from Cisco Smart Software Manager, you can add more licenses to the pool, and enter the command `license smart renew auth` to force the smart licensing agent to renew the license.

Upgrading Your License

To upgrade your license, you must provide only node-locking license information during software installation or after software installation using the NAM CLI. You can upgrade your license if you are using CSL licensing only.

For details on licensing install and management CLI commands, see the Cisco Prime Network Analysis Module Command Reference Guide.

Customizing System Preferences

To change the Prime NAM display or logging characteristics, choose Administration > System > Preferences. Table D-68 describes the fields of the Preferences window and why you may want to change the defaults.
Importing/Exporting Configuration Details

To import/export the configuration details:

Step 1 Choose Administration > System > Import/Export Configuration.
Step 2 Click Import or Export at the top of the window.
Step 3 Choose either FTP, SFTP or SCP from the protocol drop-down list.
Step 4 Enter the IP address of the host.
Step 5 Enter the username and password of the host. This is optional if you select FTP as the protocol.
Step 6 Enter the configuration filename of the application which you want to import or export.
Step 7 Enter the location where you want to import or export the application details.
Step 8 Enter the configuration filename of the DSCP which you want to import or export.
Step 9 Enter the location where you want to import or export the DSCP details.
Step 10 Enter the configuration filename of the Site which you want to import or export.
Step 11 Enter the location where you want to import or export the Site details.
Step 12 Click Import or Export.

While importing, it will replace the existing configuration details with the new details.

Troubleshooting Using Diagnostics Tools

The Diagnostics option of the Administration menu provides tools to aid in troubleshooting. You can use these tools when you have a problem that might require assistance from the Cisco Technical Assistance Center (TAC). There are options for:

- System Alerts
- Audit Trail
- Tech Support

For additional information on troubleshooting NAM, see Troubleshooting Network and NAM Issues.

System Alerts

You can view any failures or problems that the NAM has detected during normal operations. To view System Alerts, choose Administration > Diagnostics > System Alerts.

Each alert includes a date, the time the alert occurred, and a message describing the alert. The NAM displays up to one thousand (1,000) of the most-recent alerts. If more than 1,000 alerts have occurred, you need to use the NAM CLI command show tech-support to see all of the alerts.

If you notice an alert condition and troubleshoot and attempt to solve the condition causing the alert, you might want to click Clear to remove the list of alerts to see if additional alerts occur.
Audit Trail

The Audit Trail option displays a listing of recent critical activities that have been recorded in an internal syslog log file. Syslog messages can also be sent to an external log using Administration > System > Syslog Setting.

The following user activities are logged in the audit trail:

- All CLI commands
- User logins (including failed attempts)
- Unauthorized access attempts
- SPAN changes
- NetFlow data source changes
- Enabling and disabling data collections
- Starting and stopping captures
- Adding and deleting users

Each log entry will contain the following:

- User ID
- Time stamp
- IP address (in case of remote web access)
- Activity description

In Cisco NAM 6.2 release, there are two additional logs, Samba (SMB) and SSH/SFTP which are logged events from the File Sharing feature. These events get logged when the file operations are performed either on a network device through SMB or from SSH/SFTP connections.

To access the audit trail window, choose Administration > Diagnostics > Audit Trail. The Audit Trail window appears and provides a way to view the user access log and filter entries based on time, user, (IP address) from or activity. The internal log files are rotated after reaching certain size limits.

Tech Support

The NAM syslog records NAM system alerts that contain event descriptions and date and timestamps, indicating unexpected or potentially noteworthy conditions. This feature generates a potentially extensive display of the results of various internal system troubleshooting commands and system logs. For a list of user activities logged in the audit trail window, see Audit Trail.

This information is unlikely to be meaningful to the average user. It is intended to be used by your technical support team for debugging purposes. You are not expected to understand this information; instead, you should save the information and attach it to an e-mail message to your support team or, if applicable, Cisco TAC.

Before You Begin

Before you can view the Tech Support page, you must enable the System Config user privilege on the Administration > Users > Local Database page. For more information on editing user privileges, see Establishing TACACS+ Authentication and Authorization.
Controlling User Access

In order to make your Cisco NAM solution more secure, you can take several steps including:

- Enable Secure Sockets Layer (SSL) on the Cisco NAM for secure, encrypted HTTP sessions. See your installation guide for details.
- Enable Secure Shell (SSH) protocol for secure Telnet to the Cisco NAM.
- Enable TACACS+ for authentication and authorization. Cisco NAMs provide support for multiple TACACS+ servers.

This section covers how to control your user’s access using the Administration options:

- **Local Database**
- **Establishing TACACS+ Authentication and Authorization**
- **Configuring a TACACS+ Server to Support NAM Authentication and Authorization**
- **Current User Sessions**

Local Database

When you first install the NAM, use the NAM command-line interface (CLI) to enable the HTTP server and establish a username and password to access the NAM for the first time.

After setting up the initial user accounts (root, admin, and webuser), you can create additional accounts, enabling or disabling different levels of access independently for each user.

Table D-70 provides information about User Privileges and describes each privilege.

For additional information about creating and editing users, see Creating a New User and Establishing TACACS+ Authentication and Authorization.

If you have forgotten your password, use the helper utility to reset your root or user passwords (see Resetting Passwords).
Resetting Passwords

There are several methods you can use to reset your NAM passwords. Use the options documented in Table 4-2 based on your needs.

<table>
<thead>
<tr>
<th>NAM User</th>
<th>Method</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Root, Admin, and webuser</td>
<td>Boot into helper utility</td>
<td>Restart your NAM and choose <code>option 5</code> or enter <code>reboot -helper</code> at the NAM CLI.</td>
</tr>
<tr>
<td>Root and webuser</td>
<td><code>clear system-passwords</code> NAM CLI command</td>
<td>The easiest way to reset NAM passwords. This command resets both the root and guest user passwords to the factory default state. You must have appropriate privileges to reset passwords.</td>
</tr>
<tr>
<td>Root, Admin, and webuser</td>
<td>CLI commands on the switch or router</td>
<td>See your platform installation guide.</td>
</tr>
<tr>
<td>NAM Admin users</td>
<td><code>Admin &gt; Users &gt; Local Database</code></td>
<td>Delete the user for whom you have forgotten the password; then create a new one.</td>
</tr>
<tr>
<td>Webuser</td>
<td><code>rmwebusers</code> NAM CLI command</td>
<td>Use if no other local users are configured other than the user for whom you have forgotten the password. Then enable http or https to prompt for the creation of a NAM user.</td>
</tr>
</tbody>
</table>

Changing Predefined NAM User Accounts on the Switch or Router

The predefined root and guest NAM user accounts (accessible through either a switch or router `session` command or a Telnet login to the NAM CLI) are static and independent of the NAM. You cannot change these static accounts nor can you add other CLI-based users with the NAM.

Creating a New User

To create a new user:

**Step 1** Choose `Administration > Users > Local Database`.

The GUI displays the users in the local database. Checks indicate the privileges each user has for the functions listed.

**Step 2** Click `Create`.

The GUI displays the New User Dialog Box.

**Step 3** Enter the information required to create new user and select each privilege to grant to the user. See Table D-71 for an explanation of user privileges. Table D-69 describes the fields in the New User Dialog Box.

**Note** If you delete user accounts while users are logged in, they remain logged in and retain their privileges. The session remains in effect until they log out. Deleting an account or changing permissions in mid-session affects only future sessions. To force off a user who is logged in, restart the NAM.
Step 4  Select a single or multiple check box to set user privileges. *Table D-71* provides information about each privilege.

Step 5  Click **Submit** to create the user or **Reset** to clear the dialog of any characters you entered.

**Invalid User Name and Password Characters**

For usernames, do not use the following:

- Exclamation point !
- At sign @
- Pound sign #
- Dollar sign $
- Percent %
- Carot ^
- Ampersand &
- Asterisk *
- Left or right parentheses ( )
- Greater than <
- Less than >
- Comma ,
- Period .
- Double quote "
- Single quote ’
- Forward slash /
- Backward slash \ 

For web user passwords, do not use the following:

- Double quote "
- Single quote ’
- Greater than <
- Less than <

For **root** or **guest** user passwords, only the single quote is not allowed.

**Establishing TACACS+ Authentication and Authorization**

Terminal Access Controller Access Control System (TACACS) is an authentication protocol that provides remote access authentication, authorization, and related services such as event logging. With TACACS, user passwords and privileges are administered in a central database instead of an individual switch or router to provide scalability.

TACACS+ is a Cisco Systems enhancement that provides additional support for authentication and authorization.
When a user logs into the NAM, TACACS+ determines if the username and password are valid and what the access privileges are.

To establish TACACS+ authentication and authorization:

**Step 1** Choose Administration > Users > TACACS+. The TACACS+ Authentication and Authorization Dialog Box displays.

**Step 2** Enter or select the appropriate information in Table D-72, TACACS+ Authentication and Authorization Dialog Box.

**Step 3** Do one of the following:

- To save the changes, click **Submit**.
- To cancel, click **Reset**.

**Tip** If you cannot log into the NAM with TACACS+ configured, verify that you entered the correct TACACS+ server name and secret key.

### Configuring a TACACS+ Server to Support NAM Authentication and Authorization

In addition to enabling the TACACS+ option, you must configure your TACACS+ server so that it can authenticate and authorize NAM users. NAM supports ACS versions 5.2, 5.1 (including Patch 1), and 4.2.

**Note** Configuration methods vary depending on the type of TACACS+ server you use. When configuring NAM within ACS 5.x, uncheck the check box for the Single Connect Device option under the TACACS+ settings.

Continue to the section specific to your particular version:

- Configuring a Cisco ACS Server, Version 4.2
- Configuring a Cisco ACS Server, Version 5.x
- Configuring a Generic TACACS+ Server

### Configuring a Cisco ACS Server, Version 4.2

To configure a version 4.2 Cisco ACS server, you must perform two tasks:

- Add a NAM user or user group. See Adding a NAM User or User Group for Version 4.2.
Configuring NAM on ACS for Windows NT and 2000 Systems for Version 4.2

To configure a Cisco ACS TACACS+ server (version 4.2):

---

**Step 1** Log into the ACS server.

**Step 2** Click Network Configuration.

**Step 3** Click Add Entry.

**Step 4** For the Network Access Server, enter the NAM hostname and IP address.

**Step 5** Enter the secret key.

---

| Note | The secret key must be the same as the one configured on the NAM.

**Step 6** In the Authenticate Using field, select TACACS+.

**Step 7** Click Submit+Apply.

**Step 8** Continue to Adding a NAM User or User Group for Version 4.2 to complete the next configuration task.

---

Adding a NAM User or User Group for Version 4.2

To add a NAM user or user group:

---

**Step 1** Click User Setup.

**Step 2** Enter the user login name.

**Step 3** Click Add/Edit.

**Step 4** Enter the user data.

**Step 5** Enter a user password.

**Step 6** If necessary, assign a user group.

**Step 7** In the TACACS+ settings:

a. Select Shell.

b. Select IOS Command.

c. Select Permit.

d. Select Command.

e. Enter web.

f. In the Arguments field, enter:

   - permit capture
   - permit system
   - permit collection
   - permit account
   - permit alarm
   - permit view

**Step 8** In Unlisted Arguments, select Deny.
Configuring a Cisco ACS Server, Version 5.x

To configure a version 5.1 (Patch 1) or 5.2 Cisco ACS server, you must perform these tasks. There is an additional configuration task that enables you to set up policy rules for your users or groups.

Use the following sections to configure your Cisco ACS server:

- Configure the NAM hostname and IP address on the ACS server. See Configuring NAM on ACS For Windows NT and 2000 Systems for Version 5.x.
- Add a NAM user or user group. See Adding a NAM User or User Group for Version 5.x.
- Set up your policy rules. See Configuring Access Policies for ACS and NAM for Version 5.x.

Configuring NAM on ACS For Windows NT and 2000 Systems for Version 5.x

To configure a Cisco ACS TACACS+ server (version 5.1(P1) or 5.2):

Step 1 Log into the ACS server.
Step 2 To set up an optional device type for NAM, click Network Resources > Network Device Groups > Device Type and create a device type. For example, you may choose to name your device type NAM_Module.
Step 3 Click Network Resources > Network Devices and AAA Clients to add NAM devices.
Step 4 For the Network Access Server, enter the NAM hostname and IP address.
Step 5 Under Authentication Options field, select TACACS+.
Step 6 Enter the secret key and deselect the check box for the Single Connect Device option under the TACACS+ settings.

Note The secret key must be the same as the one configured on the NAM.
Step 7 Click Submit.
Step 8 Continue to Adding a NAM User or User Group for Version 5.x to complete the next configuration task.

Adding a NAM User or User Group for Version 5.x

To add a NAM user or user group:

Step 1 Click Users and Identity Stores > Internal Identity Stores > Users.
Step 2 Click Create.
Step 3 Enter the user login name.
Step 4 Enter the user data.
Configuring Access Policies for ACS and NAM for Version 5.x

In versions 5.1(P1), 5.2, and 5.3 you must set up access policies to complete your ACS and NAM configuration.

Step 1
On the ACS server, click Policy Elements > Authorization and Permissions > Device Administration > Command Sets and click Create to create NAM command sets.

For example, if you want to provide full access to the NAM, create a command set called NAMfullAccess and check the check box Permit any command that is not in the table below.

Step 2
Click Submit when you have completed entering the NAM command sets. Ensure you include all of the following commands:

- permit capture
- permit system
- permit collection
- permit account
- permit alarm
- permit view

Step 3
Click Access Policies > Access Services > Create to create a new Service (for example, name = namAdmin; Service Type = Device Administration.)

Step 4
Go to Access Policies > Access Services > namAdmin > Authorization > Customize to set up customized conditions which are needed in later step. For example, you may choose: NDG: Device Type, Device IP Address, and so on). Replace namAdmin with the service you created in this step.

Step 5
Go to Access Policies > Access Services > namAdmin > Authorization > Create to set up the condition to qualify all login requests. NAM devices use these conditions and follow the command set (created in Step 1). For example, your condition may be == NDG: Device Type is All Device Types: NAM device which you set up in Step 2.

Step 6
Click Access Policies > Service Selection Rules to choose a service (for example, the service you created in Step 3).

Step 7
Log into the NAM and click NAM > Administration > Users > TACACS+ to set up the ACS server IP and secret key.

Configuring a Generic TACACS+ Server

To configure a generic TACACS+ server:

Step 1
Specify the NAM IP address as a Remote Access Server.

Step 2
Configure a secret key for the TACACS+ server to communicate with the NAM.

Note
The secret key must be the same as the one configured on the NAM.
Step 3  For each user or group to be allowed access to the NAM, configure the following TACACS+ parameters:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Enter</th>
</tr>
</thead>
<tbody>
<tr>
<td>service</td>
<td>shell</td>
</tr>
<tr>
<td>cmd</td>
<td>web</td>
</tr>
</tbody>
</table>
| cmd-arg        | One or more the following:  
|                | accountmgmt     |
|                | system           |
|                | capture          |
|                | alarm            |
|                | collection       |
|                | view             |
| password       | pap              |
| authentication method—Password Authentication Protocol (PAP) |

Current User Sessions

The Current User Sessions table is a record of the users who are logged into the application. The user session times out after 30 minutes of inactivity. After a user session times out, that row is removed from the table.

To view the current user sessions table:

Step 1  Choose Administration > Users > Current Users.

The Current User Sessions table (Table D-73) displays.

Managing System Data

One of the roles of an administrator is to manage Prime NAM’s network data collection and retention so that it:

- Scales to fit the real needs of the system’s users.
- Minimizes the burden on monitored devices, applications, and network bandwidth.
- Survives hardware failures.

The following sections explain how to achieve these goals, and how to perform other data management tasks.

- Handling Backups
- Shrinking Storage Requirements
Handling Backups

It is critical to have your system backed up so that you can restore your configuration and data if required. Ensure you have sufficient data backups scheduled. Use the `config upload` command to back up your current configuration. For detailed instructions see your installation guide on Cisco.com.

Shrinking Storage Requirements

Network administrators are consistently looking for ways to shrink their network storage requirements and improve bandwidth efficiency on tasks like backup and recovery.

By configuring Prime NAM packet deduplication on supported platforms, packets whose inspected segments match another packet within the specific time window are marked as duplicates and not forwarded.

For configuration guidelines and instructions, see Configuring Hardware Deduplication.

You can also move capture files to an external storage location to save on local disk space. See About Capturing to Data Storage.
NAM Deployment

This chapter describes some usage cases on how to deploy NAM in your networks. It contains details on network performance management as well as usage scenarios for the Cisco Prime Network Analysis Module Software.

To view which release versions run on the supported NAM platforms, see the NAM Compatibility Matrix.

The use cases focus on a specific need to be addressed or a problem to be solved. Each scenario takes into account the deployment considerations discussed in Overview and then uses one or more of NAM’s features to meet the need or solve the problem. The goal of these use cases is to provide real-world examples. These examples discuss best practices and approaches to effective NAM deployment and are grouped into several categories.

This chapter contains the following sections:

- Deploying in the Data Center
- Deploying in a Campus Environment
- Deploying in the Branch
- General Usage Scenarios
- NAM Integrations with Monitoring and Reporting Applications

Note

Some of the graphics represented in this section may be different than what you see on the screen. These illustrations are for examples only.

Deploying in the Data Center

- Monitoring the Nexus 1000V Switch Environment, page 5-14
- Using NAM to Evaluate Application-Level Performance Monitoring for TCP-Interactive Applications, page 5-14
- Using NAM to Evaluate Application-Level Performance Monitoring for UDP Real-Time Applications, page 5-14
- Using NAM to Monitor QoS/DiffServ (DSCP), page 5-10
- Monitoring Cisco WAAS and Measuring Its Impact, page 5-6
Deploying in a Campus Environment

- Using NAM to Evaluate Application-Level Performance Monitoring for TCP-Interactive Applications, page 5-14
- Using NAM to Evaluate Application-Level Performance Monitoring for UDP Real-Time Applications, page 5-14
- Using NAM to Monitor QoS/DiffServ (DSCP), page 5-10
- Using NAMs to Monitor VoIP Quality, page 5-3

Deploying in the Branch

- Using NAM to Evaluate Application-Level Performance Monitoring for TCP-Interactive Applications, page 5-14
- Using NAM to Evaluate Application-Level Performance Monitoring for UDP Real-Time Applications, page 5-14
- Using NAM to Monitor QoS/DiffServ (DSCP), page 5-10
- Monitoring Cisco WAAS and Measuring Its Impact, page 5-6
- Using NAMs to Monitor VoIP Quality, page 5-3

General Usage Scenarios

These use cases are applicable to any part of the network:

- Using NAM for Historical Trends via Interactive Report, page 5-12
- Using NAM for Problem Isolation, page 5-16
- Creating Custom Applications, page 5-5
- Auto-Discovery Capabilities of NAM, page 5-4
- Using NAM for SmartGrid Visibility, page 5-16

NAM Integrations with Monitoring and Reporting Applications

- Integrating NAM with Prime Infrastructure, page 5-5
- Integrating NAM with Third Party Reporting Tools, page 5-6

Deployment Examples

- Using NAMs to Monitor VoIP Quality, page 5-3
- Auto-Discovery Capabilities of NAM, page 5-4
- Creating Custom Applications, page 5-5
- Integrating NAM with Third Party Reporting Tools, page 5-6
- Integrating NAM with Prime Infrastructure, page 5-5
Using NAMs to Monitor VoIP Quality

Voice quality analysis has been significantly enhanced in Cisco NAM. The software is now capable of accurately measuring voice quality by using the industry-standard MOS algorithm. Call quality measurements are computed every 1 minute and made available through the GUI. Note that the voice-related screens on the NAM GUI are significantly different from previous releases. Changes have been made to provide useful information quickly and automatically, while allowing easy navigation to details.

Deployment: NAM deployments for voice quality analysis require that NAM be able to monitor VoIP packets from the calling phone to the called phone. The branch edge location in the network provides visibility into all calls entering and leaving the branch; similarly a campus edge location monitors calls crossing the campus boundary. Often, the distribution layer is a good location to deploy NAMs for this purpose, especially if specific phones or particular portions of the network are to be monitored. For example, a new Multi protocol Label Switching (MPLS) link is being piloted and three buildings that are part of Company X's headquarters are part of the pilot. In order to monitor voice quality for those three buildings, a NAM could be deployed at the distribution Catalyst 6500 that serves those users.

Note

The data center is typically not an appropriate location for RTP stream analysis because calls will seldom go through the data center. However, the data center is a good location to monitor signaling messages between phones and Cisco Unified Communications Manager. NAM decodes signaling messages to track call history, caller names, phone numbers, and other relevant call details.

Use the following steps to monitor the network to make sure that call quality is good. If quality issues appear, isolate and troubleshoot the problem rapidly.

Step 1  View RTP Streams using the menu selection Analyze > Media. This chart indicates current voice quality of all RTP streams being monitored. MOS values range from 1 to 5, where 1 is poor and 5 is excellent (see the legend for a breakdown into categories-Poor, Fair, Good and Excellent). The figure below displays the Top N RTP Source and Destination endpoints. Notice that there are calls that are in the poor range.

Step 2  To isolate calls that had a poor MOS, scroll down to Top N RTP Streams and click on the chart to drill down into the RTP Stream Details. See Figure 5-1.
**Step 3**  
With the endpoints’ IP addresses, you can look at the network topology to identify where in the network the 50.5.10.38 subnet is located. For the purposes of this use case, this subnet is in Building 3 of the main campus. You know that the Building 3 distribution switch has a NAM located in it.

Navigate to that NAM and go to the menu selection **Analyze > Managed Device > Interface**. This page lists all interfaces and errors or discards on each interface. Look up the link that leaves Building 3 and connects to the core. That interface is likely the source of the packet loss. Check the interface for faults and fix as needed.

See **Analyzing Traffic, RTP Streams, page 2-33** and **Setting Voice Signaling Thresholds, page 6-37**.

**Auto-Discovery Capabilities of NAM**

Auto-discovery data source is enabled by default for ERSPAN, NetFlow, and WAAS data that are sent from remote device to NAM management port. NAM user has the option to disable any of the three auto-discovery. When auto-discovery is enabled, NAM automatically creates ERSPAN data source, NetFlow data source, and/or WAAS data source based on the data type being received at the NAM management interface.
Creating Custom Applications

NAM identifies applications/protocols based on the TCP/UDP port number, so if there are applications using custom ports, the NAM can be configured to identify those applications by name instead of the port.


Integrating NAM with Prime Infrastructure

Cisco Prime supports integrated lifecycle management of networks, services, and endpoints for Cisco borderless network, data center, and collaboration architectures with end-to-end assurance. You can use Cisco Prime Infrastructure to centrally manage the Cisco Prime NAM platforms such as the NAM appliance to track inventory, view configurations, and perform image and fault management. Prime Infrastructure also rolls up the performance intelligence from NAMs deployed across the network into a consolidated dashboard.

The following overview describes the steps to complete in Prime Infrastructure to set up NAM to view multiple NAMs on your dashboard. For details steps, see the Prime Infrastructure User Guide on Cisco.com.

Step 1
Ensure you configure NTP and DNS for all the NAMs in your network. You can now configure those without going to the CLI or logging in to the individual NAM web GUI. Use the Cisco Prime Infrastructure Device Work Center to perform this task. For detailed steps, see your Prime Infrastructure product documentation.

Step 2
Add the NAM HTTPS credentials from the Prime Infrastructure’s Device Work Center Edit Device window so that Prime Infrastructure can retrieve data from them. You must add them only after the discovery process is complete or the modules have been added to the Prime Infrastructure inventory.

If you have licensed Assurance features, most Assurance features depend on NAM data to work so this is a required step.

You can repeat this task for all NAMs from which you want Prime Infrastructure to collect data.

Step 3
To ensure that you can collect data from your NAMs using Prime Assurance, you must enable NAM data collection and configure your NetFlow-enabled switches, routers, and other devices (ISR/ASR) to export this data to Prime Infrastructure. You can do this for each discovered or added NAM, or for all NAMs at the same time.

Step 4
To manage and troubleshoot a network problem such as a suspected network attack, you can use multiple NAMs to create packet captures, save them as files, and then decode them to inspect the suspicious traffic.

For other troubleshooting tips on how to use NAM with Prime Infrastructure, see the Prime Infrastructure User Guide. For application developers who want to use the NAM REST API to connect with Prime NAM, ask your Cisco representative about using the Cisco Prime Network Analysis Module REST API.
Integrating NAM with Third Party Reporting Tools

Prime NAM integrates with the CA NetQoS SuperAgent for the purpose of aggregating Application Response Times. Prime NAM also integrates with CompuWare Vantage and InfoVista 5View for Host, Conversation, RTP, and Response Time.

Ask your Cisco representative about the Prime NAM API Programmer’s Guide to find out more about the NAM Northbound Interface, also referred to as the REST API (Application Programming Interface). The API enables you to provision Prime NAM and extract performance data.

You can write your own scripts based on the Prime NAM Northbound API, but you must perform some setup in the GUI.

For details on what data can be collected, see Using Response Time Summary.

Monitoring Cisco WAAS and Measuring Its Impact

Cisco Wide Area Application Services (WAAS) is a comprehensive WAN optimization solution that accelerates applications over the WAN, delivers video to the branch office, and provides local hosting of branch-office IT services. Cisco WAAS allows IT departments to centralize applications and storage in the data center while maintaining LAN-like application performance and provides locally hosted IT services while reducing the branch-office device footprint.

One of the challenges facing IT personnel who deploy WAAS is to measure and report on the benefits provided by their WAN optimization deployment. Accurate measurement provides many benefits: IT can show return on investment; IT can assess whether the improvement gained meets originally advertised expectations from the solution; and finally, IT can use WAAS ongoing for monitoring, troubleshooting, and planning information for expanding the deployment.

The NAM can monitor WAAS-optimized flows by using WAE devices as the data source. Using this capability, the NAM is able to provide visibility into optimization-related metrics for the three distinct segments that are created by WAAS: the branch, the WAN, and the data center segments.

Placing a Cisco NAM appliance at the edge of the data center is recommended for WAAS deployments. From this location in the network, the NAM can measure local metrics using SPAN technology, and for information on the remote branch segment, it relies on flow agent exports from the remote WAE device. See Figure 5-2.
To deploy this solution:

**Step 1** Using a NAM 2x20 deployed at the data center, measure application response time before WAAS is enabled using **Analyze > WAN Optimization > Top Talker Detail**. The Top Talker display includes such data as utilization, concurrent connections, and average transaction time for top applications, network links, clients, and servers that are possible candidates for optimization.

**Step 2** Create a WAAS Client Side and WAAS Server Side for the WAAS flows from the DC and Branch WAEs.

**Step 3** The NAM provides an interactive dashboard to view the analyzed data. **Figure 5-3** displays Client Transaction Time, Traffic Volume and Compression Ratio, Number of Concurrent Connections (Optimized vs. Passthru), and Multi-Segment Network Time (Client LAN - WAN - Server LAN). As you can see in the first graph, all non-optimized traffic is displayed as Passthru.
The screen shot above illustrates the significant improvement experienced by users in the branch when WAAS is turned on. Such reports are very useful to justify an investment in WAN optimization technologies and to show returns on those investments in terms of increase in employee productivity and improved user experience from remote sites.
Step 4  From the perspective of the NAM located in the data center, there are two sources of information for response time measurements. SPAN provides measurement at the data center and exports from the branch; WAAS flow or PA via Prime Infrastructure provides measurements from the branch. Using these two sources of information, the NAM at the data center can continuously monitor current response times for each branch and help IT personnel keep user experience within known bounds. When abnormal response times are detected, the NAM can be configured to send alerts to appropriate personnel with information relevant to troubleshooting the problem.

Note  The NAM 2x20 in the above scenario can be substituted with the NAM Virtual Blade on the WAVE-574 and WAE-674 to obtain the same type of reports.

Monitoring

- Using NAM to Monitor QoS/DiffServ (DSCP), page 5-10
- Using NAM for Historical Trends via Interactive Report, page 5-12
- Using NAM to Evaluate Application-Level Performance Monitoring for TCP-Interactive Applications, page 5-14
- Using NAM to Evaluate Application-Level Performance Monitoring for UDP Real-Time Applications, page 5-14
Using NAM to Monitor QoS/DiffServ (DSCP)

Differentiated Services (DiffServ) provides insight into how traffic is being classified by QoS and detects incorrectly marked or unauthorized traffic. The NAM identifies the application/protocol based on the type of service (ToS) bits setting. The administrator can configure DSCP Groups or use the ones provided. The voice template can be used to monitor whether voice traffic is marked properly. Figure 5-6 displays the DiffServ application statistics for all DSCP value. Looking at this, you will notice that RTP and Session Initiation Protocol (SIP) are listed, which indicates that they are not being correctly marked throughout its path.

In the following scenario, IT has deployed QoS to prioritize VoIP traffic to improve voice quality across the network. The NAMs are deployed in the data center and branches and utilized to monitor the DSCP to validate QoS policies.

Step 1  Choose **Setup > Network > DSCP Groups** to display the default groups.

Step 2  Choose **Administration > System > Preferences** to turn the IP TOS Flow Key on. Use caution since this option affects ART and other flow-based traffic. See Table D-69 for details.

Step 3  Choose **Analyze > Traffic > DSCP** to find any misclassified traffic. In Figure 5-5, the RTP protocol is displayed for ToS0 classification.

Step 4  Click on the **All DSCP** button to view all DSCP and applications.
Step 5  In Figure 5-6, RTP and SIP are highlighted. The protocols are listed for DSCP 0, which is incorrect since the standard classification for voice traffic is DSCP 46 and 24. This means that some of the voice traffic is misclassified on the network. You can also view the branch NAMs to investigate whether voice traffic is being misclassified.

![Figure 5-6 All DSCP Table](image)

Step 6  Left-click on the RTP graph and select Application Traffic by Host to display the clients using those protocols. This helps to troubleshoot why RTP or SIP traffic from these clients is not marked correctly. As shown in Figure 5-7, the NAM displays the IP addresses of the phones using those protocols. This helps you review the QoS policy implemented on the routers and switches between the clients.

![Figure 5-7 RTP Host Table](image)
Using NAM for Historical Trends via Interactive Report

Historical trending is an important component of network performance management. While real-time analysis provides information about events, historical trending provides visibility into event sequences. Such sequences offer valuable information about various aspects of the network such as changes in network traffic behavior, anomalies and unusual activities, and network usage in peak times versus low times. It is also helpful in planning future network upgrades, application roll outs, and hardware builds. Here are some things to note of regarding NAM’s historical trending capabilities:

- Use the Interactive Report > Filter button (located on the left side of the NAM window) to look at short term and long term trends by changing the Time Range. The interactive reports can be exported or the filter setting saved for quick view in the future. The exported data can be sent via e-mail in CSV or PDF format.
- Figure 5-8 displays host traffic for the last day, and using the middle graph you can zoom down to the required time range to view what other application this host is using.

In the following deployment scenario, you will predict the capacity needed for a new branch build out due in six months by studying the usage of an existing branch office of a similar size. To deploy a NAM located in the branch router (ISR) of the existing branch:

**Step 1** Start capturing traffic rates between the branch and the data center. View the traffic for the last month from Interactive Report > Filter > Time Range > Custom (enter a date covering a month).
Step 2  Open a conversation report from today and find a stream that has a mildly increasing trend but is unable to confirm the rate at which it is increasing (see Figure 5-9).

Figure 5-9  A Stream with a Mildly Increasing Trend

Step 3  Change the Time Range dynamically in the Interactive Report to study the trend with a granularity of one month. You may find that the pattern does show periodic increases (see Figure 5-10). You are then able to conclude that the ISP link needed at the new site would be similar, and so a standard T1 line would be more than sufficient for the needs of the new remote office.

Figure 5-10  The Trend Shown with a Granularity of 1 Month

Studying historical trends is a valuable exercise in planning and creating baselines in a network. Monitor and trend on business critical applications and servers. These trends should provide handy information in a variety of day-to-day decisions.
Using NAM to Evaluate Application-Level Performance Monitoring for TCP-Interactive Applications

Application Performance Response Time Analysis provides up to 45 metrics. You can configure thresholds based on many of these metrics, and receive an alert when the thresholds are passed. Thresholds should be set for critical applications or servers using Average Server Response Time, or Average Transaction Time, or Average Network Time and Average Server Network Time. These thresholds will help identify where the problem lies in the application performance, and show whether the problem is a server or network issue. Depending on the alarm, you can access the NAM to see the applications and clients accessing the server, or to check the devices in the traffic path monitoring device and interface utilization.

See Application Response Time, page 2-21.

See Defining Thresholds, page 6-33.

Using NAM to Evaluate Application-Level Performance Monitoring for UDP Real-Time Applications

The NAM monitors and analyzes RTP streams and voice calls statistics by intercepting the data collected by endpoints. So, when a phone call ends, the endpoints calculate the information and send it to the Unified Communications Manager (aka the Call Manager), the NAM collects the data (as long as it is along that path).

NAM uses the voice call statistics from the endpoint with the RTP stream to correlate the phone number with the IP address of the endpoint. Alerts are sent based on analysis of the RTP streams for MOS, Jitter, and Packet Loss.

To use NAM to monitor the application-level performance for UDP real-time applications:

**Step 1** Set up thresholds to focus on which types of performance metrics you want to monitor at Setup > Alarms > Thresholds.

**Step 2** View voice signaling/RTP traffic at Analyze > Media > RTP Streams or Analyze > Media > Voice Call Statistics.


See Table D-31, Media Monitor Setup Window, page D-19.

Monitoring the Nexus 1000V Switch Environment

As networks and applications move into the virtualization environment, the challenge for you is to find tools to gain insight into that environment. The NAM VSB provides that function by integrating with the Cisco Nexus 1010 virtualization appliance. Using the NAM VSB, you can gain operational visibility into the virtual switching layer and is able to see virtual machine (VM) to VM statistics. See Figure 5-11.

The Nexus 1000V switch can also be monitored by other NAM platforms running the Prime NAM software.
You are deploying applications in the ritualized environment and the Nexus 1000V switch is providing the network connectivity. The NAM VSB installed on the Nexus 1010 Virtual Services Appliance is used to monitor the environment.

**Note**

If Nexus 1000V switches and NAMs are already deployed in the network, ERSPAN or NetFlow data source can be directed by any one of those NAMs. You should directly connect the 1000V switch and NAM to the same physical switch.

**Figure 5-11  Cisco Nexus 1000V NAM Virtual Service Blade Deployment**

To monitor the Nexus 1000V environment:

**Step 1** Install and configure either the NAM VSB on the Nexus 1110 Virtual Services Appliance. See the Installation and Configuration Guides for the NAM on Cisco.com.

**Step 2** For the NAM VSB:

1. Verify that ERSPAN or NetFlow are configured on the Cisco 1000V Switch Virtual Supervisor Module (VSM) that is providing data to NAM.

2. Configure the ERSPAN or NetFlow data source, depending on your NAM.

3. Enable all applicable monitoring parameters in NAM for ERSPAN and NetFlow. Use the Traffic Summary window to display Top N information such as applications, hosts, protocol, and server response time. You can view and display details for each of the categories listed.

4. Using the Interactive Report, configure reports for trending on the application response time, hosts, and conversation traffic patterns.
The physical and virtual interfaces table provides VM-to-VM traffic utilization. Because one virtual interface connects to one VM, the data shows which VMS are utilizing the switch resources. You can then view the hosts and conversations tables to identify the culprit utilizing the resources.

**Note**  
NAM VSB provides the same complement of features except that it supports only ERSPAN and NetFlow data sources and performs no voice monitoring and packet capture.

---

**Troubleshooting**

- Using NAM for Problem Isolation, page 5-16
- Using NAM for SmartGrid Visibility, page 5-16

**Using NAM for Problem Isolation**

The alarm details (found in the Cisco Prime Network Analysis Module Software under Monitor > Overview > Alarm Summary) provides information you can use to drill down on the threshold that was violated. You may also receive this alarm in e-mail (Setup > Alarms > E-mail). An example of the alarm is:

```
2013 SEPT 28 9:17:0:Application:Exceeded rising value(1000);packets;60653;Site(San Jose), Application)
```

After receiving this alarm, you can access the NAM GUI to view the application in your specific site to determine why there was a spike. Click on Analyze > Traffic > Application; in the Interactive Report window on the left, change Site to “San Jose,” Application to “HTTP,” and Time Range to the range when the alert was received. This will display all the hosts using this protocol. You can see the Top hosts and verify there are no unauthorized hosts accessing this application. You can also access Analyze > Traffic > Host to view which conversations are chatty, and therefore causing the increase traffic for this application.

If the alarm is for an Application Response Time issue, you can access Monitor > Response Time Summary or Analyze > Response Time > Application to drill down on what hosts are accessing the application. Identify the application server and view what other applications are hosted and all the clients accessing that server.


**Using NAM for SmartGrid Visibility**

The NAM will not recognize the IEC 60870 protocol out of the box (this is one of the main protocols used by power distribution companies). You will have to add a custom protocol, because it is a specific port you will be using. When you choose Setup > Classification > Application Configuration, you will see all hosts using that application. It will be identified as a Telnet application.
Customizing Cisco Prime NAM

This chapter provides set up details for advanced tools and customization. You can use these tools to take your network monitoring to another level. It provides information about functions that will begin automatically, optional tasks, and other setup tasks you will need to perform for advanced feature configuration.

This chapter contains the following sections:

- Advanced Configuration Overview, page 6-2
- Setting Up Traffic Configurations, page 6-3
- Setting Up Alarms and Alarm Thresholds, page 6-31
- Setting Up Data Export, page 6-40
- Accessing Device Interface and Health Details, page 6-44
- Configuring Network Parameters, page 6-47
- Configuring Application Classification, page 6-52
- Setting Up Prime NAM Monitoring, page 6-61

For information about how to install the product, configure it, and log in, see the installation guide for your specific Cisco NAM platform.
Advanced Configuration Overview

Table 6-1 leads you through the advanced configuration steps you can follow for Prime NAM. See the description to understand why or when to perform these tasks.

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
<th>GUI Location</th>
<th>User Guide Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure the Managed Device information</td>
<td>If you want to monitor an extended level of your managed device’s data (health and interface information), you can set up your managed device using Cisco NAM. If you do not set up this feature, your data collection is limited. Depending on your NAM platform, managed device health and interface information will display in Analyze &gt; Managed Device GUI. For service module NAM blades such as NAM-3 and NAM-NX1, the NAM managed device is the switch or router where NAM is located. Managed device SNMP credentials are automatically synchronized to the NAM upon NAM boot up. For other NAM platforms, the NAM managed device IP address, SNMP, and/or NetConf interface credential must be provided for NAM to get managed device health and interface information.</td>
<td>Setup &gt; Managed Device &gt; Device Information</td>
<td>See Accessing Device Interface and Health Details, page 6-44.</td>
</tr>
<tr>
<td>Configure sites</td>
<td>A site is a collection of hosts (network endpoints) partitioned into views that help you monitor traffic and troubleshoot problems. If you want to limit the view of your network data to a specific city, a specific building, or even a specific floor of a building, you can use the sites function. We recommend that sites are configured using prefix-based subnets instead of based on data source.</td>
<td>Setup &gt; Network &gt; Sites</td>
<td>See Configuring Sites, page 6-47.</td>
</tr>
<tr>
<td>Define alarms and thresholds</td>
<td>Alarms are predefined conditions based on a rising data threshold, a falling data threshold, or both. You can choose for what types of events you want the software to notify you, and how you want to be notified. Create alarms that will be used for thresholds, then create the thresholds.</td>
<td>Setup &gt; Alarms &gt; Actions and Setup &gt; Alarms &gt; Thresholds</td>
<td>See Viewing Alarm Actions, page 6-33. See Defining Thresholds, page 6-33.</td>
</tr>
</tbody>
</table>
Table 6-1  Advanced Configuration Overview (continued)

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
<th>GUI Location</th>
<th>User Guide Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure capture</td>
<td>Capture allows you to configure up to ten sessions for capturing, filtering, and decoding packet data, manage the data in local or remote storage, and display the contents of the packets. Per file location, you can have only one capture session. We support up to ten capture sessions.</td>
<td>Capture &gt; Packet Capture/Decode</td>
<td>See Capturing and Decoding Packets, page 3-1.</td>
</tr>
<tr>
<td>Configure scheduled export</td>
<td>You can set up scheduled jobs that generate daily reports at a specified time, in a specified interval, and then e-mail it to a specified e-mail address or addresses. Some windows may not support data export.</td>
<td>In the Interactive Report (left side of the dashboard), click Export. Scheduled Export can only be done from a Monitor or Analyze window.</td>
<td>See Scheduling Data Report Exports, page 6-41.</td>
</tr>
<tr>
<td>Set up TACACS+ server</td>
<td>TACACS+ is a Cisco Systems enhancement that provides additional support for authentication and authorization. When a user logs into Prime NAM, TACACS+ determines if the username and password are valid and what the access privileges are. For TACACS+ to work, both NAM and the TACACS+ server has to be configured.</td>
<td>Administration &gt; Users &gt; TACACS+</td>
<td>See Configuring a TACACS+ Server to Support NAM Authentication and Authorization, page 4-18.</td>
</tr>
<tr>
<td>Change system preferences</td>
<td>You can change many preferences, such as refresh interval, Top N Entries, Data Displayed, and enabling Audit Trail, as needed.</td>
<td>Administration &gt; System &gt; Preferences</td>
<td>See Performing User and System Administration</td>
</tr>
</tbody>
</table>

### Setting Up Traffic Configurations

To set up Prime NAM traffic, you should perform the following:
- Configuring Traffic to Monitor, page 6-3
- (Optional) Setting Up Prime NAM Data Sources, page 6-6
- (Optional) Configuring Hardware Deduplication, page 6-30 (For specific NAM appliances only)

To view which traffic sources are supported on specific NAM platforms, see the NAM Compatibility Matrix.

### Configuring Traffic to Monitor

Prime NAM can monitor your network traffic to perform many tasks including helping you to optimize your network resources and troubleshoot performance issues. Before you can monitor data, you must direct specific traffic flowing through a switch or router to the Prime NAM software for monitoring purposes.
A switched port analyzer (SPAN) session is an association of a destination port with a set of source ports, configured with parameters that specify the monitored network traffic.

NAM allows you to create LOCAL SPAN session only. There are limitations of total number of SPAN sessions per managed device platform. See the managed device document for SPAN limitations.

There are three different ways to configure LOCAL SPAN session on the SUP:

- By using SNMP—NAM supports SNMPv1, SNMPv2c, and SNMPv3. NAM-3 platform will automatically sync SNMP credential with SUP. For the SPAN feature to work under this condition, the managed device must support entity MIB.
- By using NetConf interface—This option is available for NAM appliances. You must provide the SSH credential for NetConf interface. The SUP must have SSH enabled and support NetConf. Cisco Nexus OS devices support this NetConf interface.
- By using RISE—This option is available for NAM appliance with Nexus 7000 devices only. RISE service must be configured on the Nexus device. After RISE is configured, NAM and switch device will sync up automatically.

The following sections describe SPAN sessions on devices running Prime NAM:

- Understanding How the Prime NAM Uses SPAN, page A-3
- Creating a SPAN Session for RISE Appliance, page 6-4
- Creating a SPAN Session for Appliances and other Virtual Platforms, page 6-4
- Editing a SPAN Session for RISE Appliance, page 6-5
- Editing a SPAN Session for Appliances and other Virtual Platforms, page 6-5

Creating a SPAN Session for RISE Appliance

To create a SPAN session for the VDCs of a managed device in RISE environment:

1. Choose Setup > Traffic > SPAN Sessions. The SPAN Session window appears.
2. Select the managed device from the Managed Device Address drop-down list. You can view the VDCs of the managed device, and the SPAN sessions created for each VDC.
3. Click Create.
4. Select a VDC from the Managed Device drop-down list.
5. Fill in the appropriate information on the Create SPAN Session window. Depending on your platform, the System Information may display some or all of the fields shown in Table D-1.
6. Click Create to create the SPAN session for the selected managed device.

Creating a SPAN Session for Appliances and other Virtual Platforms

To create a SPAN session on a switch:

Step 2  Click Create.

The Create SPAN Session Dialog displays. DataPort is the default for the SPAN Type. Contents of this window may be different depending on your NAM platform.

Step 3  Fill in the appropriate information on the Create SPAN Session window. See Table D-1.

Step 4  To create the SPAN session, click Submit. The Active Sessions window displays.

Step 5  To save the current active SPAN session in the running-configuration to the startup-configuration for switches running Cisco IOS software only, click Save in the active SPAN session window.

   Note  For switches running Cisco IOS software, all pending running-configuration changes will be saved to the startup-configuration.

Step 6  To verify the SPAN session was created and to view the data, go to the Top N charts on the Traffic Analysis dashboard (Monitor > Overview > Traffic Summary).

### Editing a SPAN Session for RISE Appliance

To edit a SPAN session for the VDCs of a managed device in RISE environment:

Step 1  Choose Setup > Traffic > SPAN Sessions.

The Active SPAN Sessions dialog box displays.

Step 2  Select a device IP address from the Managed Device Address drop-down list.

Step 3  Select the VDC.

Step 4  Select the SPAN session to edit, then click Edit.

The Edit SPAN Session Dialog Box displays. The fields are described in Table D-2. Depending on your NAM platform, there may be different fields that display.

Step 5  Make the appropriate changes on the Edit SPAN Session window.

### Editing a SPAN Session for Appliances and other Virtual Platforms

You can only edit SPAN sessions that have been directed to the NAM. You can only delete certain SPAN sessions using the user interface. NAM allows you to edit and delete SPAN sessions that are destined to one of its DATAPORT. ERSPAN sessions on the main screen are for information only. You cannot edit or delete ERSPAN sessions even if the ERSPAN sessions are for NAM management interface.

   Note  Editing an existing SPAN session that has multiple SPAN destinations will affect all destinations.

To edit a SPAN session:

Step 1  Choose Setup > Traffic > SPAN Sessions.

The Active SPAN Sessions dialog box displays.
Setting Up Traffic Configurations

Step 2  Select the SPAN session to edit, then click Edit.

The Edit SPAN Session Dialog Box displays. The fields are described in Table D-2. Depending on your NAM platform, there may be different fields that display.

Step 3  Make the appropriate changes on the Edit SPAN Session window.

Setting Up Prime NAM Data Sources

Data sources are where the traffic sent to Prime NAM originates. Some examples of the data sources are:

- Physical dataports of the Prime NAM where you get SPAN data
- A specific router or switch that sends NetFlow to the NAM
- A WAAS device segment that sends data to Prime NAM
- ERSPAN and which goes to NAM management port.

NAM allows you to combine two or more data sources to generate a consolidated report for analyzing the traffic.

Caution

If you have configured sites (see Configuring Sites, page 6-47), you can assign data sources to that particular site. If you do this, and you also configure data sources, the two could overlap since sites can also be a primary “view” into data sources. If there is a mismatch between the two, you will not see any data.

Note

We recommend that you configure a site using subnets instead of selecting a data source. For examples on how to specify a site using subnets, see Configuring Sites Using Subnets, page 6-49.

The following sections contains setup steps and specific information about the types of data sources available:

- Data Source Overview, page A-1
- Forwarding SPAN Traffic, page 6-6
- Forwarding ERSPAN Traffic, page 6-7
- Forwarding VAACL Traffic, page 6-14
- Forwarding NetFlow Traffic, page 6-16
- Forwarding CEF Traffic, page 6-22
- Managing WAAS and WAN Traffic, page 6-23
- Ports and Hardware Details, page A-3

Forwarding SPAN Traffic

A switched port analyzer (SPAN) session is an association of a destination port with a set of source ports, configured with parameters that specify the monitored network traffic. Depending on your platform, you can configure multiple SPAN sessions. For details on what platforms support SPAN, see the NAM Compatibility Matrix.
For more information about SPAN sessions, see Configuring Traffic to Monitor, page 6-3 or your platform operating system documentation.

**Forwarding ERSPAN Traffic**

This section describes how to configure Encapsulated Remote Switched Port Analyzer (ERSPAN) on your remote device as a Prime NAM data source. You configure ERSPAN as a Prime NAM data source from the remote device command line interface, not the Prime NAM GUI.

For details on which NAM platforms support ERSPAN, see the *NAM Compatibility Matrix*.

As an ERSPAN consumer, Prime NAM can receive ERSPAN packets on its management port from devices such as Cisco routers and switches. Those packets are analyzed as if that traffic had appeared on one of the Prime NAM dataports. Prime NAM supports ERSPAN versions 1 and 3. Incoming ERSPAN data is parsed by Prime NAM, stored in its internal database, and presented in the GUI in the same way as traffic from other data sources.

**Before You Begin**

For the Prime NAM to receive ERSPAN from an external switch or router, that device must be configured to send ERSPAN packets to the IP address of the Cisco NAM.

To enable ERSPAN as a data source:

- Enabling Autocreation of ERSPAN Data Sources Using the Web GUI, page 6-7
- Enabling Autocreation of ERSPAN Data Sources Using the CLI, page 6-8
- Aggregating Data Ports Using the Web GUI, page 6-8
- Disabling Autocreation of ERSPAN Data Sources Using the Web GUI, page 6-9
- Disabling Autocreation of ERSPAN Data Sources Using the CLI, page 6-9
- Creating ERSPAN Data Sources Using the Web GUI, page 6-9
- Creating ERSPAN Data Sources Using the CLI, page 6-10
- Deleting ERSPAN Data Sources Using the Web GUI, page 6-11
- Deleting ERSPAN Data Sources Using the CLI, page 6-12
- Configuring ERSPAN on Devices, page 6-13

**Note**

Depending on the Cisco IOS/Nexus OS version on the managed device, the CLI format for configuring an ERSPAN session may be different than what appears in this document. For details on using ERSPAN as a data source, see your specific OS product documentation.

**Enabling Autocreation of ERSPAN Data Sources Using the Web GUI**

There is a convenient autocreate feature for data sources, which is enabled by default. With the autocreate feature, a new data source will automatically be created for each device that sends ERSPAN traffic to the NAM, after the first packet is received. Manual creation of ERSPAN data sources using the Prime NAM GUI or the CLI is typically not necessary. When manually creating a data source, you may specify any name you want for the data source. A data source entry must exist on the Prime NAM in order for it to accept ERSPAN packets from an external device.
Autocreated ERSPAN data sources will be assigned a name in the format ERSPAN-<IP Address>-ID-<Integer>, where IP Address is the IP address of the sending device, and Integer is the Session-ID of the ERSPAN session on that device. For example, device 192.168.0.1 sending ERSPAN packets with the Session ID field set to 12 would be named ERSPAN-192.168.0.1-ID-12. You can edit these autocreated data sources and change the name if desired.

One device can be configured to send multiple separate ERSPAN sessions to the same NAM. Each session will have a unique Session ID. Prime NAM can either group all sessions from the same device into one data source, or have a different data source for each Session ID. When data sources are autocreated, they will be associated with one particular Session ID. When manually created, you can instruct Prime NAM to group all traffic from the same device into one data source. If you check the Session check box, and enter a Session ID in the Value field, the data source will only apply to that specific session. If you leave the check box unchecked, all ERSPAN traffic from the device will be grouped together into this data source, regardless of Session ID.

To configure Prime NAM to automatically create data sources when it receives ERSPAN packets from an external device, use the following steps. Remember however, that the autocreate feature is turned on by default, so these steps are typically not necessary.

**Step 1** Choose Setup > Traffic > NAM Data Sources.

**Step 2** Click Auto Create on the bottom left of the window.

**Step 3** Check the ERSPAN check box to toggle autocreation of ERSPAN data sources to “on”.

**Step 4** Click Submit.

---

### Enabling Autocreation of ERSPAN Data Sources Using the CLI

You can also configure the autocreate feature using the Prime NAM CLI. The autocreate feature is turned on by default, in most cases these steps are not necessary.

To configure Prime NAM to automatically create data sources when it receives ERSPAN packets from an external device, use the `autocreate-data-source` command as follows:

```
root@172-20-104-107.cisco.com# autocreate-data-source erspan
```

ERSPAN data source autocreate successfully ENABLED

Prime NAM will now automatically create a ERSPAN data source for each device that sends ERSPAN packets to it. The data source will have the specific Session ID that is populated by the device in the ERSPAN packets sent to the NAM. If the same device happens to send ERSPAN packets to the Prime NAM with different Session ID values, a separate data source will be created for each unique Session ID sent from the device.

### Aggregating Data Ports Using the Web GUI

To aggregate the datasources:

**Step 1** Choose Setup > Traffic > NAM Data Sources.

**Step 2** Click Aggregation.

A pop up window appears.
Step 3 Click Submit to combine two or more datasources for generating a consolidated report to analyze the traffic.

Disabling Autocreation of ERSPAN Data Sources Using the Web GUI

Step 1 Choose Setup > Traffic > NAM Data Sources.
Step 2 Click Auto Create on the bottom left of the window.
Step 3 Uncheck the ERSPAN check box to toggle autocreation of ERSPAN data sources to “off”.
Step 4 Click Submit.

Disabling Autocreation of ERSPAN Data Sources Using the CLI

To disable autocreation of ERSPAN data sources, use the no autocreate-data-source command as follows:

```
root@172-20-104-107.cisco.com# no autocreate-data-source erspan
ERSPAN data source autocreate successfully DISABLED
root@172-20-104-107.cisco.com#
```

Creating ERSPAN Data Sources Using the Web GUI

To manually configure a ERSPAN data source on the GUI, for example if the autocreation feature is turned off, use the following steps:

Step 1 Choose Setup > Traffic > NAM Data Sources.
Step 2 Click Create along the bottom of the window.
Step 3 From the Type drop-down list, choose ERSPAN.
Step 4 Enter the IP address of the device that will export ERSPAN to the NAM.
Step 5 Give the Data Source a name. This name will appear anywhere there is a Data Source drop-down list.
Step 6 (Optional) Check the Session check box and enter an Session ID into the Value field if the data source should only apply to that specific session. If you leave the check box unchecked, all ERSPAN traffic from the device will be grouped together into this data source, regardless of Session ID. Devices can be configured with multiple ERSPAN Sessions. The packets exported may have the same source IP address, but the Session ID exported will be a different for each session. If you want to include only one Session in the data source, you must check the “Session” box and provide the value of that Session ID.
Step 7 Click Submit.
Creating ERSPAN Data Sources Using the CLI

To manually configure a ERSPAN data source on the Prime NAM using the CLI (for example if the autocreation feature is turned off), use the following steps. Note that when using the CLI, there are two separate phases involved: First, you must create a “device” entry on the Prime NAM and remember the device ID, and then you must create a data source entry using this device ID. In the Prime NAM GUI, these two phases for creating ERSPAN data sources are combined together.

**Step 1** Enter the command `device erspan`. You will now be in erspan device subcommand mode as shown here:

```
root@172-20-104-107.cisco.com# device erspan
```

Entering into subcommand mode for this command.
Type 'exit' to apply changes and come out of this mode.
Type 'cancel' to discard changes and come out of this mode.

```
root@172-20-104-107.cisco.com(sub-device-erspan)#
```

**Step 2** Enter `?` to see all the command options available, as in the example below:

```
root@172-20-104-107.cisco.com(sub-device-netflow)# ?
?                         - display help
address                   - device IP address (*)
cancel                    - discard changes and exit from subcommand mode
exit                      - create device and exit from sub-command mode
help                      - display help
show                      - show current config that will be applied on exit
```

(*) - denotes a mandatory field for this configuration.

```
root@172-20-104-107.cisco.com(sub-device-netflow)#
```

**Step 3** Enter the IP address of the device as shown in this example (required):

```
root@172-20-104-107.cisco.com(sub-device-erspan)# address 192.168.0.1
```

**Step 4** Type `show` to look at the device configuration that will be applied and verify that it is correct:

```
root@172-20-104-107.cisco.com(sub-device-erspan)# show
```

```
DEVICE TYPE         : ERSPAN (Encapsulated Remote SPAN)
DEVICE ADDRESS      : 192.168.0.1
```

```
root@172-20-104-107.cisco.com(sub-device-erspan)#
```

**Step 5** Type `exit` to come out of the subcommand mode and create the device. Remember the ID value that was assigned to the new device (you will need it to create the data source).

```
root@172-20-104-107.cisco.com(sub-device-erspan)# exit
```

```
Device created successfully, ID = 1
```

```
root@172-20-104-107.cisco.com#
```

**Step 6** Enter the command `data-source erspan`. You will now be in erspan data source subcommand mode as shown here:

```
root@172-20-104-107.cisco.com# data-source erspan
```

Entering into subcommand mode for this command.
Type 'exit' to apply changes and come out of this mode.
Type 'cancel' to discard changes and come out of this mode.

```
root@172-20-104-107.cisco.com(sub-data-source-erspan)#
```
**Step 7** Enter `?` to see all the command options available, as in the example below:

```
root@172-20-104-107.cisco.com(sub-data-source-erspan)# ?
?                         - display help
cancel                    - discard changes and exit from subcommand mode
device-id                 - erspan device ID (*)
exit                      - create data-source and exit from sub-command mode
help                      - display help
name                      - data-source name (*)
session-id                - erspan Session ID
show                      - show current config that will be applied on exit
```

(*) - denotes a mandatory field for this configuration.

**Step 8** Enter the device ID from Step 4.
```
root@172-20-104-107.cisco.com(sub-data-source-erspan)# device-id 1
```

**Step 9** Enter the name you would like for the data source (required):
```
root@172-20-104-107.cisco.com(sub-data-source-erspan)# name MyFirstErspanDataSource
```

**Step 10** If desired, supply the specific Session ID for this ERSPAN data source (optional):
```
root@172-20-104-107.cisco.com(sub-data-source-erspan)# session-id 123
```

**Step 11** Enter `show` to look at the data source configuration that will be applied and verify that it is correct:
```
root@172-20-104-107.cisco.com(sub-data-source-netflow)# show
DATA SOURCE NAME : MyFirstErspanDataSource
DATA SOURCE TYPE : ERSPAN (Encapsulated Remote SPAN)
DEVICE ID        : 1
DEVICE ADDRESS   : 192.168.0.1
SESSION ID       : 123
```

**Step 12** Enter `exit` to come out of the subcommand mode and create the data source:
```
root@172-20-104-107.cisco.com(sub-data-source-erspan)# exit
Data source created successfully, ID = 3
```

The data source is now created, and ERSPAN records from the device will be received and accepted by Prime NAM as they arrive.

**Deleting ERSPAN Data Sources Using the Web GUI**

To delete an existing ERSPAN data source, use the following steps. Note that if the autocreation feature is turned on, and the device continues to send ERSPAN packets to the NAM, the data source will be recreated again automatically as soon as the next ERSPAN packet arrives. Therefore, if you wish to delete an existing ERSPAN data source, it is usually advisable to first turn the ERSPAN autocreate feature off, as described earlier.

**Step 1** Choose Setup > Traffic > NAM Data Sources.

**Step 2** Choose the data source you would like to delete.
Deleting ERSPAN Data Sources Using the CLI

To delete an ERSPAN data source using the CLI, follow the steps below. Note that when using the CLI, there are generally two separate phases involved. First, you should delete the data source, then delete the device if you have no other data sources using the same device (for example, with a different Engine ID value). As a shortcut, if you simply delete the device, all data sources using that device will also be deleted.

Step 1  Show all data sources so you can find the ID of the one you want to delete:

```
root@172-20-104-107.cisco.com# show data-source

DATA SOURCE ID : 1
DATA SOURCE NAME : DATA PORT 1
TYPE : Data Port
PORT NUMBER : 1

DATA SOURCE ID : 2
DATA SOURCE NAME : DATA PORT 2
TYPE : Data Port
PORT NUMBER : 2

DATA SOURCE ID : 3
DATA SOURCE NAME : MyFirstErspanDataSource
TYPE : ERSPAN (Encapsulated Remote SPAN)
DEVICE ID : 2
DEVICE ADDRESS : 192.168.0.1
ENGINE ID : 123

root@172-20-104-107.cisco.com#
```

Step 2  Use the `no data-source` command to delete the data source:

```
root@172-20-104-107.cisco.com# no data-source 3
Successfully deleted data source 3
root@172-20-104-107.cisco.com#
```

Step 3  Show all devices so you can find the ID of the one you want to delete:

```
root@172-20-104-107.cisco.com# show device

DEVICE ID : 1
DEVICE TYPE : ERSPAN (Encapsulated Remote SPAN)
IP ADDRESS : 192.168.0.1
INFORMATION : No packets received
STATUS : Inactive

root@172-20-104-107.cisco.com#
```
Step 4: Use the `no device` command to delete the device:

```
root@172-20-104-107.cisco.com# no device 1
Successfully deleted device 1
root@172-20-104-107.cisco.com#
```

Note that if the autocreation mode is on, and the device continues to send ERSPAN packets to the NAM, the data source (and device entry) will be recreated again automatically as soon as the next ERSPAN packet arrives. Therefore, if you wish to delete an existing ERSPAN data source, it is usually advisable to first turn the ERSPAN autocreate feature off, as described earlier.

Configuring ERSPAN on Devices

There are two ways to configure ERSPAN so that the Prime NAM receives the data:

- Sending ERSPAN Data to Layer 3 Interface, page 6-13
- Sending ERSPAN Data Directly to the Cisco NAM Management Interface, page 6-14

**Note**

Depending on the Cisco IOS or NX-OS version on your managed device, the CLI format for configuring an ERSPAN session may be different than what appears in this document. For details on using ERSPAN as a data source, see your specific OS product documentation.

**Sending ERSPAN Data to Layer 3 Interface**

To send the data to a layer 3 interface on the Switch housing the NAM, configure the ERSPAN source session. The ERSPAN destination session then sends the traffic to a Prime NAM data-port. After performing this configuration, you can select the DATA PORT X data source to analyze the ERSPAN traffic.

**Note**

This method causes the ERSPAN traffic to arrive on one of the NAM dataports, which is the most efficient method and will not have any adverse effect on the NAM’s IP connectivity. Therefore, we recommend this method. The configuration below may be different depending on your platform and OS version. See your OS product documentation for additional help.

**Sample Configuration of ERSPAN Source**

```
monitor erspan origin ip-address aa.bb.cc.dd global

monitor session 4 type erspan-source
  erspan-id N
  vrf default
  destination ip aa.bb.cc.ii
  source interface Ethernet12/1
  rate-limit auto
  no shut

Interface that is connected to the NAM appliance data port:

interface Ethernet12/11
  description connect to 2420 ee.ff.gg.hh DP2
  mtu 9216
  ip address aa.bb.cc.dd/24
  no shutdown
```
Setting Up Traffic Configurations

On NAM:

root@appliance-2420-90.cisco.com# data-port 2 ip-address aa.bb.cc.ii
root@appliance-2420-90.cisco.com# show data-port 2 ip-address

Port number: 2
IPv4 address: aa.bb.cc.ii

root@appliance-2420-90.cisco.com#

Where:

- \( N \) matches the ERSPAN ID at the source switch
- \( aa.bb.cc.dd \) is the IP address defined at the destination
- \( aa.bb.cc.ii \) is the IP address of the NAM data port
- \( ee.ff.gg.hh \) is the IP address of the NAM management port

**Sending ERSPAN Data Directly to the Cisco NAM Management Interface**

To send the data directly to the Cisco NAM management IP address (management-port), configure the ERSPAN source session. No ERSPAN destination session configuration is required. After performing this configuration on the Catalyst 6500 switch, when ERSPAN packets are sent to the NAM, it will automatically create a data source for that packet stream. If the autocr eate feature is not enabled, you will have to manually create the data source for this ERSPAN stream of traffic (see Creating ERSPAN Data Sources Using the Web GUI, page 6-9).

Note

This method causes the ERSPAN traffic to arrive on the Cisco NAM management port. If the traffic level is high, this could have negative impact on the NAM’s performance and IP connectivity.

**Sample Configuration**

```
monitor session 1 type erspan-source
no shut
source interface Fa3/47
destination
    erspan-id Y
    ip address aa.bb.cc.dd
origin ip address ee.ff.gg.hh
```

Where:

- Interface fa3/47 is a local interface on the erspan-source switch to be monitored
- \( Y \) is any valid span session number
- \( aa.bb.cc.dd \) is the management IP address of the NAM
- \( ee.ff.gg.hh \) is the source IP address of the ERSPAN traffic

**Forwarding VACL Traffic**

You can use VLAN access control (VACL) lists to filter packet data and expand your device’s capability beyond the two SPAN session limitation. For details on which devices support VACL, see the NAM Compatibility Matrix.

VACL can forward traffic from either a WAN interface or VLANs to a dataport on some of the NAM platforms. A VACL provides an alternative to using SPAN; a VACL can provide access control based on Layer 3 addresses for IP and IPX protocols. The unsupported protocols are access controlled through the MAC addresses. A MAC VACL cannot be used to access control IP or IPX addresses.
Configuring VACL on a WAN Interface

Because WAN interfaces do not support the SPAN function, you must use the switch CLI to manually configure a VACL in order to monitor WAN traffic with the NAM. This feature only works for IP traffic over the WAN interface.

VACL can also be used if there is no available SPAN session to direct traffic to the NAM. In this case, a VACL can be set up in place of a SPAN for monitoring VLAN traffic.

The following example shows how to configure a VACL on an ATM WAN interface and forward both ingress and egress traffic to the NAM. These commands are for switches running Cisco IOS version 12.1(13)E1 or higher. For more information on using these features, see your accompanying switch documentation.

```
Cat6509#config terminal
Cat6509(config)# access-list 100 permit ip any any
Cat6509(config)# vlan access-map wan 100
Cat6509(config-access-map)# match ip address 100
Cat6509(config-access-map)# action forward capture
Cat6509(config-access-map)# exit
Cat6509(config)# vlan filter wan interface AM6/0/0.1
Cat6509(config)# analysis module 3 data-port 1 capture allowed-vlan 1-4094
Cat6509(config)# analysis module 3 data-port 1 capture
Cat6509(config)# exit
```

To monitor egress traffic only, get the VLAN ID that is associated with the WAN interface by using the following command:

```
Cat6509# show cwan vlan
Hidden VLAN swidb->i_number Interface
1017 94 ATM6/0/0.1
```

After you have the VLAN ID, configure the Cisco NAM dataport using the following command:

```
Cat6509(config)# analysis module 3 data-port 1 capture allowed-vlan 1017
```

To monitor ingress traffic only, replace the VLAN number in the capture configuration with the native VLAN ID that carries the ingress traffic. For example, if VLAN 1 carries the ingress traffic, you would use the following command:

```
Cat6509(config)# analysis module 3 data-port 1 capture allowed-vlan 1
```

Configuring VACL on a LAN VLAN

For VLAN Traffic monitoring on a LAN, traffic can be sent to Cisco NAM by using the SPAN feature of the switch. However, in some instances when the traffic being spanned exceeds the monitoring capability of the NAM, you might want to pre-filter the LAN traffic before it is forwarded. This can be done by using VACL.

The following example shows how to configure VACL for LAN VLAN interfaces. In this example, all traffic directed to the server 172.20.10.221 on VLAN 1 is captured and forwarded to the Cisco NAM located in slot 3.

```
Cat6509#config terminal
Cat6509(config)# access-list 100 permit ip any any
Cat6509(config)# access-list 110 permit ip any host 172.20.10.221
Cat6509(config)# vlan access-map lan 100
Cat6509(config-access-map)# match ip address 110
Cat6509(config-access-map)# action forward capture
Cat6509(config-access-map)# exit
Cat6509(config)# vlan access-map lan 200
Cat6509(config-access-map)# match ip address 100
```

Setting Up Traffic Configurations

Cat6509#(config-access-map)#action forward
Cat6509#(config-access-map)#exit
Cat6509#(config)#vlan filter lan vlan-list 1
Cat6509#(config)#analysis module 3 data-port 1 capture allowed-vlan 1
Cat6509#(config)#analysis module 3 data-port 1 capture
Cat6509#(config)#exit

See Configuring ACL Capture on Nexus 7000 Series, page A-6 for details on how to configure VACL capture on Nexus 7000.

Forwarding NetFlow Traffic

NAM functions as a NetFlow consumer. You can configure NetFlow on the device side so that Prime NAM can receive NetFlow packets from devices such as Cisco routers and switches. Those records are stored in its collection database as if that traffic had appeared on one of the Cisco NAM dataports. Prime NAM understands NetFlow version 5 and version 9. Incoming NetFlow data is parsed by Prime NAM, stored in its internal database, and presented in the user interface in the same way as traffic from other data sources.

For Prime NAM to receive NetFlow packets from an external switch or router, you must configure that device to forward export flow records to the NAM’s IP address and the correct UDP port number. The default port number on which Prime NAM listens for NetFlow packets is port 3000. This port can be modified using the Prime NAM CLI, but it is critical that the same port be configured on the Cisco NAM and the exporting device or devices. Depending on the external device, you may need to enable the NetFlow feature on a per-interface basis.

See the following sections about NetFlow as a data source:

- Understanding NetFlow Interfaces, page A-7
- Understanding NetFlow Flow Records, page A-8
- Managing NetFlow Data Sources, page A-8
- Configuring NetFlow on Devices, page 6-16

Configuring NetFlow on Devices

The configuration commands for NetFlow devices to export NetFlow packets to Prime NAM are platform and device specific. The example configuration commands provided here are the ones most commonly found for devices running Cisco IOS. For more detailed NetFlow configuration information, see your device documentation.

Enabling Autocreation of NetFlow Data Sources Using the Web GUI

To configure Prime NAM to automatically create data sources when it receives NetFlow packets from an external device, use the following steps. Remember however, that the autocreate feature is turned on by default, so these steps are typically not necessary.

**Step 1** Choose Setup > Traffic > NAM Data Sources.
**Step 2** Click Auto Create on the bottom left of the window.
**Step 3** Check the Netflow check box to toggle autocreation of NetFlow data sources on.
**Step 4** Click Submit.
Enabling Autocreation of NetFlow Data Sources Using the CLI

Configuration of the autocreate feature is also possible using the Prime NAM CLI. Remember that the autocreate feature is turned ON by default, so in most cases these steps are not necessary.

To configure the Prime NAM to automatically create data sources when it receives NetFlow packets from an external device, use the following steps:

Use the `autocreate-data-source` command as follows:

```
root@172-20-104-107.cisco.com# autocreate-data-source netflow
```

Prime NAM will now automatically create a NetFlow data source for each device that sends NetFlow packets to it. The data source will have the specific Engine ID that is populated by the device in the NetFlow packets sent to the NAM. If the same device happens to send NetFlow packets to the NAM with different Engine ID values, a separate data source will be created for each unique Engine ID sent from the device.

Disabling Autocreation of NetFlow Data Sources Using the Web GUI

1. Choose Setup > Traffic > NAM Data Sources.
2. Click Auto Create on the bottom left of the window.
3. Uncheck the Netflow check box to toggle autocreation of NetFlow data sources off.
4. Click Submit.

Disabling Autocreation of NetFlow Data Sources Using the CLI

To disable autocreation of NetFlow data sources, use the `no autocreate-data-source` command as follows:

```
root@172-20-104-107.cisco.com# no autocreate-data-source netflow
```

Creating NetFlow Data Sources Using the Web GUI

To manually configure a NetFlow data source using the Prime NAM GUI, for example if the autocreation feature is turned OFF, use the following steps:

1. Choose Setup > Traffic > NAM Data Sources.
2. Click Create along the bottom of the window.
3. Give the Data Source a name. This name will appear anywhere there is a Data Source drop-down list.
4. From the Type drop-down list, choose NetFlow.
5. Enter the IP address of the device that will export NetFlow to Prime NAM (required).
6. (Optional) If you know the specific value of the Engine ID on the device you would like to monitor, check the Engine check box, and enter the value of the Engine ID. If the Engine check box is left unchecked, then all NetFlow records exported by the device will be grouped into the same data source, regardless of the Engine ID populated in the NetFlow packets (in most cases the Engine check box can be left blank and you don't have to worry about the Engine ID value).
Some devices have multiple Engines which independently export NetFlow records. For example, on some Cisco routers, NetFlow records can be exported by the Supervisor module as well as individual line cards. The packets exported may have the same source IP address, but the Engine ID exported by the Supervisor will be a different value than the Engine ID(s) exported by the line card(s). If you want to include only one Engine in the data source, you must check the “Engine” box and provide the value of that Engine ID.

**Step 7**  
(Optional) SNMP v1/v2c RO Community String: If SNMP v1 or v2c will be used to communicate with the device, enter the community string that is configured on the device that is going to export NetFlow packets to the NAM.

**Step 8**  
(Optional) “Enable SNMP v3”: If SNMP v3 will be used to communicate with the device, fill in the fields within the v3-specific dialog.

**Step 9**  
(Optional) If desired, fill in the SNMP credentials for the device. If valid SNMP credentials are provided, **Prime NAM** can upload readable text strings from the device to describe the interfaces on that device rather than just displaying the interfaces as numbers. You may specify either SNMPv2c or SNMPv3 credentials. See Table D-3.

**Step 10** Click Test Connectivity to see if the information you provided is accurate.

**Step 11** Click Submit.

---

**Creating NetFlow Data Sources Using the CLI**

To manually configure a NetFlow data source on the Prime NAM using the CLI, for example if the autocreation feature is turned off, use the following steps. Note that when using the CLI, there are two separate phases involved. First you must create a “device” entry on the Prime NAM and remember the device ID. Then you must create a data source entry using this device ID. For convenience, these two phases are combined together when using the GUI to create NetFlow data sources.

**Step 1**  
Enter the command `device netflow`. You will now be in netflow device subcommand mode as shown here:

```
root@172-20-104-107.cisco.com# device netflow
```

Entering into subcommand mode for this command.  
Type ‘exit’ to apply changes and come out of this mode.  
Type ‘cancel’ to discard changes and come out of this mode.

```
root@172-20-104-107.cisco.com(sub-device-netflow)#
```

**Step 2**  
Enter `?` to see all the command options available, as in the example below:

```
root@172-20-104-107.cisco.com(sub-device-netflow)# ?
?
- display help
address  - device IP address (*)
cancel   - discard changes and exit from subcommand mode
community - SNMPv2c community string
exit     - create device and exit from sub-command mode
help     - display help
show     - show current config that will be applied on exit
snmp-version  - SNMP version to use to communicate with device
v3-auth-passphrase  - SNMPv3 authentication passphrase
v3-auth-protocol   - SNMPv3 authentication protocol
v3-priv-passphrase  - SNMPv3 privacy passphrase
v3-priv-protocol   - SNMPv3 privacy protocol
v3-sec-level       - SNMPv3 security level
v3-username        - SNMPv3 username
```
Chapter 6 Customizing Cisco Prime NAM

Setting Up Traffic Configurations

(*) - denotes a mandatory field for this configuration.

root@172-20-104-107.cisco.com(sub-device-netflow)#

Step 3 Enter the IP address of the device as shown in this example (required):

root@172-20-104-107.cisco.com(sub-device-netflow)# address 192.168.0.1

Step 4 If desired, enter the SNMP credentials for the device, as in the example below. If you specify snmp-version v2c, then you should enter the community string for the device. If you specify snmp-version v3, then you should enter the security level, username, authentication protocol, authentication passphrase, privacy protocol, and privacy passphrase.

root@172-20-104-107.cisco.com(sub-device-netflow)# snmp-version v2c
root@172-20-104-107.cisco.com(sub-device-netflow)# community public

Step 5 Enter show to look at the device configuration that will be applied and verify that it is correct:

root@172-20-104-107.cisco.com(sub-device-netflow)# show

DEVICE TYPE : NDE (Netflow Data Export)
DEVICE ADDRESS : 192.168.0.1
SNMP VERSION : SNMPv2c
V2C COMMUNITY : public
V3 USERNAME :
V3 SECURITY LEVEL : No authentication, no privacy
V3 AUTHENTICATION : MD5
V3 PRIV PASSPHRASE :
V3 PRIVACY :
V3 PRIV PASSPHRASE :

root@172-20-104-107.cisco.com(sub-device-netflow)#

Step 6 Enter exit to come out of the subcommand mode and create the device. Remember the ID value that was assigned to the new device, you will need it to create the data source!

root@172-20-104-107.cisco.com(sub-device-netflow)# exit
Device created successfully, ID = 1
root@172-20-104-107.cisco.com#

Step 7 Enter the command data-source netflow. You will now be in netflow data source subcommand mode as shown here:

root@172-20-104-107.cisco.com# data-source netflow

Entering into subcommand mode for this command.
Type 'exit' to apply changes and come out of this mode.
Type 'cancel' to discard changes and come out of this mode.

root@172-20-104-107.cisco.com(sub-data-source-netflow)#

Step 8 Enter ? to see all the command options available, as in the example below:

root@172-20-104-107.cisco.com(sub-data-source-netflow)# ?
? - display help
cancel - discard changes and exit from subcommand mode
device-id - netflow device ID (*)
engine-id - netflow Engine ID
exit - create data-source and exit from sub-command mode
help - display help
name - data-source name (*)
show - show current config that will be applied on exit
Setting Up Traffic Configurations

Chapter 6 Customizing Cisco Prime NAM

(*) - denotes a mandatory field for this configuration.

root@172-20-104-107.cisco.com(sub-data-source-netflow)#

Step 9 Enter the device ID from Step 4 (required):

```
root@172-20-104-107.cisco.com(sub-data-source-netflow)# device-id 1
```

Step 10 Enter the name you would like for the data source (required):

```
root@172-20-104-107.cisco.com(sub-data-source-netflow)# name MyFirstNdeDataSource
```

Step 11 If desired, supply the specific Engine ID for this NetFlow data source (optional):

```
root@172-20-104-107.cisco.com(sub-data-source-netflow)# engine-id 123
```

Step 12 Enter show to look at the data source configuration that will be applied and verify that it is correct:

```
root@172-20-104-107.cisco.com(sub-data-source-netflow)# show
```

```
DATA SOURCE NAME       : MyFirstNdeDataSource
DATA SOURCE TYPE       : NDE (Netflow Data Export)
DEVICE ID              : 1
DEVICE ADDRESS         : 192.168.0.1
ENGINE ID              : 123
```

```
root@172-20-104-107.cisco.com(sub-data-source-netflow)#
```

Step 13 Enter exit to come out of the subcommand mode and create the data source:

```
root@172-20-104-107.cisco.com(sub-data-source-netflow)# exit
```

Data source created successfully, ID = 3

The data source is now created, and NetFlow records from the device will be received and accepted by the Prime NAM as they arrive.

Deleting NetFlow Data Sources Using the Web GUI

To delete an existing NetFlow data source, use the following steps. If the autocreation feature is turned on, and the device continues to send NetFlow packets to the NAM, the data source will be recreated again automatically as soon as the next NetFlow packet arrives. Therefore, if you wish to delete an existing NetFlow data source, it is usually advisable to first turn the NetFlow autocreate feature off, as described earlier.

Step 1 Choose Setup > Traffic > NAM Data Sources.

Step 2 Click on the data source you would like to delete.

Step 3 Click Delete.

Deleting NetFlow Data Sources Using the CLI

To delete a NetFlow data source using the CLI, use the following steps. Note that when using the CLI, there are generally two separate phases involved. First you should delete the data source, then delete the device if you have no other data sources using the same device (for example with a different Engine ID value). As a shortcut, if you simply delete the device, then all data sources using that device will also be deleted.
Step 1 Show all data sources so you can find the ID of the one you want to delete:

```
root@172-20-104-107.cisco.com# show data-source

DATA SOURCE ID   : 1
DATA SOURCE NAME : DATA PORT 1
TYPE             : Data Port
PORT NUMBER      : 1
-----------

DATA SOURCE ID   : 2
DATA SOURCE NAME : DATA PORT 2
TYPE             : Data Port
PORT NUMBER      : 2
-----------

DATA SOURCE ID   : 3
DATA SOURCE NAME : MyFirstNdeDataSource
TYPE             : NDE (Netflow Data Export)
DEVICE ID        : 2
DEVICE ADDRESS   : 192.168.0.1
ENGINE ID        : 123
-----------
```

```
root@172-20-104-107.cisco.com#
```

Step 2 Use the no data-source command to delete the data source:

```
root@172-20-104-107.cisco.com# no data-source 3
Successfully deleted data source 3
root@172-20-104-107.cisco.com#
```

Step 3 Show all devices so you can find the ID of the one you want to delete:

```
root@172-20-104-107.cisco.com# show device

DEVICE ID            : 1
DEVICE TYPE          : NDE (Netflow Data Export)
IP ADDRESS           : 192.168.0.1
SNMP VERSION         : SNMPv2c
V2C COMMUNITY        : public
V3 USERNAME          :
V3 SECURITY LEVEL    : No authentication, no privacy
V3 AUTHENTICATION    : MD5
V3 AUTH PASSPHRASE   :
V3 PRIVACY           : DES
V3 PRIV PASSPHRASE   :
INFORMATION          : No packets received
STATUS               : Inactive
------
```

```
root@172-20-104-107.cisco.com#
```

Step 4 Use the no device command to delete the device:

```
root@172-20-104-107.cisco.com# no device 1
Successfully deleted device 1
root@172-20-104-107.cisco.com#
```
Note that if the autocreation mode is on, and the device continues to send NetFlow packets to the NAM, the data source (and device entry) will be re-created again automatically as soon as the next NetFlow packet arrives. Therefore, if you wish to delete an existing NetFlow data source, it is usually advisable to first turn the NetFlow autocreate feature off, as described earlier.

**Testing NetFlow Devices**

You can test the SNMP community strings for the devices in the Devices table. To test a device, select it from the Devices table, then click Test. The Device System Information Dialog Box displays. See Table D-4 for a description of the fields.

If the device is sending NetFlow Version 9 (V9) and the Prime NAM has received the NetFlow templates, then a V9 Templates button appears below the Device System Information window.

*Note* NetFlow v9 templates do not appear in all NetFlow packets. When there are no templates, the V9 Templates button does not appear.

**Forwarding CEF Traffic**

Cisco Express Forwarding (CEF) is an advanced, layer 3 IP switching technology. CEF optimizes network performance and scalability for networks with large and dynamic traffic patterns, such as Internet, on networks characterized by intensive Web-based applications, or interactive sessions. For more information about CEF and configuring CEF, see the Cisco IOS Switching Services Configuration Guide.

You can configure CEF traffic copy and forward it to NAM session as a Prime NAM data source from the remote device command line interface and not from the Prime NAM GUI.

For details on which NAM platforms support CEF traffic, see the NAM Compatibility Matrix.

As a CEF consumer, Prime NAM can receive CEF packets on its data port from Cisco monitoring interface. Prime NAM supports monitoring and analysis of incoming CEF data to be parsed by Prime NAM, stored in its internal database, and presented in the GUI in the same way as traffic from other data sources.

**Before You Begin**

For the Prime NAM to receive CEF traffic from router, the device must be configured to copy and forward the CEF packets to Cisco Prime NAM.

To enable CEF as a data source:

- Configure CEF and CEF monitoring on devices
- CEF data port will be auto created on physical port receiving CEF traffic on devices
See the *Cisco IOS Switching Services Configuration Guide, Release 12.2* for CEF configuration examples.

**Note**

Depending on the Cisco IOS/Nexus OS version on the managed device, the CLI format for configuring a CEF copy and forward session may be different from what appears in this document. Ensure that your IOS/Nexus OS version supports UCSE platform. Before you create CEF traffic monitoring session on a router, enable NAM feature through UCSE CIMC. For list of router platforms and IOS releases support UCSE, see *Getting Started Guide for Cisco UCS E-Series Servers and the Cisco UCS E-Series Network Compute Engine, Release 2.x*.

See Understanding How the Prime NAM uses CEF, page A-9 for details of how to configure CEF monitoring.

**Managing WAAS and WAN Traffic**

This section contains the following topics about using the **Prime NAM** GUI to manage WAAS data sources:

- Understanding WAAS, page 6-23
- Considering Deployment Scenarios, page 6-24
- Using the WAAS Central Manager, page 6-25
- Monitoring Response Time from WAAS Data Sources, page 6-26
- Monitoring Client Data Sources, page 6-27
- Monitoring WAN Data Sources, page 6-27
- Monitoring Server Data Sources, page 6-27
- Enabling WAAS Flow Agent, page 6-27
- Adding Data Sources for New WAAS Device, page 6-28
- Editing WAAS Data Sources, page 6-28
- Deleting a WAAS Data Source, page 6-29
- Auto Create of New WAAS Devices, page 6-29

**Understanding WAAS**

Cisco Wide Area Application Services (WAAS) software optimizes the performance of TCP-based applications operating in a wide area network (WAN) environment and preserves and strengthens branch security. The WAAS solution consists of a set of devices called Wide Area Application Engines (WAEs) that work together to optimize WAN traffic over your network.

When client and server applications attempt to communicate with each other, the network devices intercept and redirect this traffic to the WAEs to act on behalf of the client application and the destination server.

WAEs provide information about packet streams traversing through both LAN and WAN interfaces of WAAS WAEs. Traffic of interest can include specific servers and types of transaction being exported. **Prime NAM** processes the data exported from the WAAS and performs application response time calculations and enters the data into reports you set up.

The WAEs examine the traffic and use built-in application policies to determine whether to optimize the traffic or allow it to pass through your network not optimized.
You can use the WAAS Top Talkers Detail Dashboard to analyze the traffic for optimization. See Analyzing Traffic for Optimization Using the Top Talkers Detail, page 2-17 for more information.

Cisco WAAS helps enterprises to meet the following objectives:

- Provide branch office employees with LAN-like access to information and applications across a geographically distributed network.
- Migrate application and file servers from branch offices into centrally managed data centers.
- Minimize unnecessary WAN bandwidth consumption through the use of advanced compression algorithms.
- Provide print services to branch office users. WAAS allows you to configure a WAE as a print server so you do not need to deploy a dedicated system to fulfill print requests.
- Improve application performance over the WAN by addressing the following common issues:
  - Low data rates (constrained bandwidth)
  - Slow delivery of frames (high network latency)
  - Higher rates of packet loss (low reliability)

For more information about WAAS and configuring the WAAS components, see the Cisco Wide Area Application Services Configuration Guide.

### Considering Deployment Scenarios

Table 6-2 lists six different deployment scenarios you might consider to monitor the optimized traffic on your WAAS network. Scenario #1 is typical when using NAM-3 blades.

<table>
<thead>
<tr>
<th>Deployment Scenario</th>
<th>Edge WAE Data Source</th>
<th>Core WAE Data Source</th>
</tr>
</thead>
</table>
| 1                   | Clients in the edge (branch)  
                      | Servers in the core (data center)  
                      | NAM in the core  | Client  | Server  |
|                     |                       |                      |             | Server  | Server WAN |
| 2                   | Clients in the edge (branch)  
                      | Servers in the core (data center)  
                      | NAM in the edge  | Client  | Client WAN  | Server  |
| 3                   | Servers in the edge (branch)  
                      | Clients in the core (data center)  
                      | NAM in the core  | Server  | Client  |
|                     |                       |                      |             | Client  | Client WAN  |
| 4                   | Servers in the edge (branch)  
                      | Clients in the core (data center)  
                      | NAM in the edge  | Server  | Server  |
|                     |                       |                      |             | Server  | Server WAN  |
Chapter 6  Customizing Cisco Prime NAM

6-25

Setting Up Traffic Configurations

Table 6-2  WAAS Data Source Configurations (continued)

<table>
<thead>
<tr>
<th>Deployment Scenario</th>
<th>Edge WAE Data Source</th>
<th>Core WAE Data Source</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Clients and servers in the edge (branch) and the core (data center)</td>
<td>Client Server</td>
<td>Client Server</td>
</tr>
<tr>
<td>- NAM in the core</td>
<td></td>
<td>Client WAN Server WAN</td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Clients and servers in the edge (branch) and the core (data center)</td>
<td>Client Server</td>
<td>Client Server</td>
</tr>
<tr>
<td>- NAM in the edge</td>
<td></td>
<td>Client WAN Server WAN</td>
</tr>
</tbody>
</table>

Using the WAAS Central Manager

The Cisco WAAS is centrally managed by a scalable, secure, and simple function called the Cisco WAAS Central Manager, which runs on Cisco WAE Appliances. The Cisco WAAS Central Manager provides a centralized mechanism for configuring features, reporting, and monitoring, and can manage a topology containing thousands of Cisco WAE nodes.

Prime NAM is accessible from within the Central Manager interface. Prime NAM integration with WAAS Central Manager provides for easier viewing of Prime NAM reports that are directly associated with Application Response Time measurements through the WAN, in both WAAS optimized and non-optimized environments.

Below is a standard configuration workflow that you can follow.

Prerequisites are that the WAAS Central Manager is installed and functional, and the Cisco NAM (device or virtual blade) is installed and functional.

**Step 1**  From the WAAS Central Manager, configure the Cisco NAM IP address and login credentials.

**Step 2**  From the router or switch, configure the data source(s) for baseline (SPAN).

**Step 3**  From the WAAS Central Manager, configure the Site definition. See Configuring Sites, page 6-47 for more information.

**Step 4**  In the Monitor section of WAAS Central Manager, one can observe the Top Talkers under the Network Analysis tab. See Analyzing Traffic for Optimization Using the Top Talkers Detail, page 2-17 for more information.

**Step 5**  From the WAAS Central Manager, configure the WAAS Flow Agent and branch/data center WAEs.

**Step 6**  Create Device Groups for the branch and data center on the WAAS Central Manager, and assign a device to the Device Groups.

**Step 7**  Enable the Flow Agent on the WAAS, pointing to the Cisco NAM IP. Segments are automatically selected (enabled only if Cisco NAM is configured). Prime NAM will start to compute baseline ART, protocol distribution, and Top Talkers. See Enabling WAAS Flow Agent, page 6-27.

**Step 8**  Turn on WAAS optimization. See Optimizing WAN, page 2-16 for more information.

**Step 9**  Turn on the Flow Agent and identify the servers to monitor to get ART improvements. See Editing WAAS Data Sources, page 6-28.
Monitoring Response Time from WAAS Data Sources

**Prime NAM** processes the TCP flow data exported from the WAAS and performs application response time (ART) calculations and reports. You use the **Prime NAM** GUI to create a WAAS data source to monitor WAAS traffic statistics. In addition to ART, Prime NAM monitors and reports other traffic statistics of the WAAS data sources including application, host, and conversation information.

**Prime NAM** provides different ART metrics by collecting data at different points as packets flow along their paths. **Prime NAM** provides five different collection points, each represented by a WAAS data source. Figure 6-1, WAAS Data Sources (Data Collection Points), shows an example of the data collection points. The solid line represents data exported from a WAAS device and/or directly monitored traffic like SPAN. The broken line represents data exported from a WAAS device only.

**Figure 6-1**  WAAS Data Sources (Data Collection Points)

You can use the **Prime NAM** GUI to configure data sources at the locations in the network described in Table 6-3.

**Table 6-3**  WAAS Data Collection Points

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client</td>
<td>This setting configures the WAE device to export the original (LAN side) TCP flows originated from its clients to <strong>Prime NAM</strong> for monitoring. To monitor this point, configure a Client data source.</td>
</tr>
<tr>
<td>Client WAN</td>
<td>This setting configures the WAE device to export the optimized (WAN side) TCP flows originated from its clients to <strong>Prime NAM</strong> for monitoring. To monitor this point, configure a Client WAN data source.</td>
</tr>
<tr>
<td>Server WAN</td>
<td>This setting configures the WAE device to export the optimized (WAN side) TCP flows from its servers to <strong>Prime NAM</strong> for monitoring. To monitor this point, configure a Server WAN data source.</td>
</tr>
<tr>
<td>Server</td>
<td>This setting configures the WAE device to export the original (LAN side) TCP flows from its servers to <strong>Prime NAM</strong> for monitoring. To monitor this point, configure a Server data source.</td>
</tr>
<tr>
<td>Passthrough</td>
<td>This setting configures the WAE device to export the TCP flows that are passed through unoptimized.</td>
</tr>
</tbody>
</table>
You can also configure a data source to use Export Passthrough data. For more information about configuring WAAS data sources, see Editing WAAS Data Sources, page 6-28.

Monitoring Client Data Sources

By monitoring the TCP connections between the client and the WAE device (Client segment in Figure 6-1), you can measure the following ART metrics:

- Total Response Time as experienced by the client
- Total Transaction Time as experienced by the client
- Bandwidth usage (bits/packets) before optimization
- Number of transactions and connections.
- Network Time broken down into two segments: client-edge and edge-server

To view detailed views of this data, select the Analyze > Response Time > Detailed Views submenu.

Monitoring WAN Data Sources

By monitoring the TCP connections between the edge and core WAE devices (Client WAN and Server WAN segments in Figure 6-1), you can measure the following:

- Bandwidth usage (bits/packets) after optimization
- Network Time of the WAN segment

Monitoring Server Data Sources

By monitoring the TCP connections between the core WAE devices and the servers (Server segment in Figure 6-1), you can measure the following ART metrics:

- Server Response Time (without proxy acceleration/caching server)
- Network Time between the core WAE device and the servers

Note: Prime NAM measures Network Time by monitoring the TCP three-way handshake between the devices.

Enabling WAAS Flow Agent

Before you can monitor WAAS traffic, you must first configure the WAAS device to export WAAS flow record data to the Prime NAM. Use the following WAAS command-line interface (CLI) flow monitor command to enable the Flow Agent on the WAAS:

```
flow monitor tcpstat-v1 host <nam IP address>
flow monitor tcpstat-v1 enable
```

After you enable flow export to the Prime NAM using WAAS CLI commands like those above, WAAS devices will be detected and automatically added to the NAM’s WAAS device list.

You must then configure the WAAS segments you want to monitor as WAAS data sources: Client, Client WAN, Server WAN, and/or Server. See Editing WAAS Data Sources, page 6-28, for more detailed information.
You can also use the WAAS Central Manager to centrally issue WAAS CLI commands to configure a large number of WAEs at one time. Prime NAM is accessible from within the WAAS Central Manager interface. For more information about WAAS Central Manager, refer to the WAAS technical documentation.

**Note**

In addition to configuring the WAAS devices, you must specify which application servers you want to monitor among the servers being optimized by WAAS devices. See Configuring WAAS Monitored Servers, page 6-66, for more detailed information.

For more information about WAAS and configuring the WAAS components, see the Cisco Wide Area Application Services Configuration Guide.

This section contains the following topics:

- Adding Data Sources for New WAAS Device, page 6-28
- Editing WAAS Data Sources, page 6-28
- Deleting a WAAS Data Source, page 6-29

**Adding Data Sources for New WAAS Device**

Prime NAM uses WAAS data sources to monitor traffic collected from different WAAS segments: Client, Client WAN, Server WAN, and Server. Each WAAS segment is represented by a data source. You can set up Prime NAM to monitor and report other traffic statistics of the WAAS data sources such as application, host, and conversation information in addition to the monitored Response Time metrics.

**Note**

This step is not usually necessary because export-enabled WAAS devices are detected and added automatically. See Enabling WAAS Flow Agent, page 6-27, for more information about how to enable WAAS export to the NAM.

To manually add a WAAS device to the list of devices monitored by Prime NAM:

**Step 1** Choose Setup > Traffic > NAM Data Sources.

**Step 2** Click Create.

The Prime NAM Data Source Configuration Dialog appears.

**Step 3** Choose “WAAS” from the list of Types.

**Step 4** Enter the device IP address in the IP field.

**Step 5** Check the check boxes for the appropriate WAAS Segments. See Table 6-3.

**Step 6** Click Submit to add the new WAAS custom data source.

**Editing WAAS Data Sources**

Prime NAM uses WAAS data sources to monitor traffic collected from different WAAS segments: Client, Client WAN, Server WAN, and Server. Each WAAS segment is represented by a data source. You can set up Prime NAM to monitor and report other traffic statistics of the WAAS data sources such as application, host, and conversation information in addition to the monitored Response Time metrics.
To edit a WAAS device’s custom data source:

Step 1  Choose Setup > Traffic > NAM Data Sources. The data sources are displayed.

Step 2  Choose the WAAS device you want to modify, and then click Edit.

You can configure the WAAS data sources to monitor the following WAAS segments as shown in Figure 6-1, WAAS Data Sources (Data Collection Points):

- **Client**—This setting configures the WAE device to export the original (LAN side) TCP flows originated from its clients to **Prime NAM** for monitoring.
- **Client WAN**—This setting configures the WAE device to export the optimized (WAN side) TCP flows originated from its clients to **Prime NAM** for monitoring.
- **Server WAN**—This setting configures the WAE device to export the optimized (WAN side) TCP flows from its servers to **Prime NAM** for monitoring.
- **Server**—This setting configures the WAE device to export the original (LAN side) TCP flows from its servers to **Prime NAM** for monitoring.

SPAN data sources might take the place of the WAE Server data sources listed in Table 6-2. For example, if you already configure SPAN to monitor the server LAN traffic, it is not necessary to enable the Server data source on the WAE device.

**Note**  The following step is optional and applies only when **Prime NAM** is configured to export data to an External Response Time Reporting Console, such as the NetQos Super Agent.

**Deleting a WAAS Data Source**

To delete a WAAS custom data source:

Step 1  Choose Setup > Traffic > NAM Data Sources. The data sources are displayed.

Step 2  Choose the WAAS custom data source you want to delete, then click Delete.

A dialog box displays the device address and asks if you are sure you want to delete the device.

**Auto Create of New WAAS Devices**

If you have numerous WAE devices, you can set up **Prime NAM** to configure newly discovered WAE devices using a predefined configuration template using the **Prime NAM** auto configuration option.

**Note**  If most of your WAE devices are edge WAE, you might want to set the auto configuration to be that of the edge device, then manually configure the data center WAE. For example, select the Client segment for monitoring.

To configure WAAS autoconfiguration:

Step 1  Choose Setup > Traffic > NAM Data Sources. The data sources are displayed.
Setting Up Traffic Configurations

Chapter 6      Customizing Cisco Prime NAM

Step 2  Click Auto Create.

The Prime NAM Data Source Configuration Dialog displays.

Step 3  Check the WAAS check box.

Step 4  Check the check boxes for the desired Segments. See Editing WAAS Data Sources, page 6-28, for more information.

Configuring Hardware Deduplication

Note  This section applies only to Cisco NAM 2320, 2420, and 2440 appliances.

Prime NAM supports hardware-based detection of duplicate packets and allows you to configure a single deduplication filter that reduces the amount of duplicate traffic across all adapter ports.

You can use deduplication to eliminate redundant data. This can help to significantly shrink storage requirements and improve bandwidth efficiency on tasks like backup and recovery.

After you enable deduplication, the NAM appliance detects and filters the duplicated packets. The packet is identified as duplicated if all inspected segments match another packet within the specific time window.

In addition to the duration-based timeout, there is also a fixed packet-count timeout. There cannot be more than 7 packets between the duplicate packets. If packets 0 and 8 are identical, packet 8 will be dropped. If packets 0 and 9 are identical, packet 9 will not be dropped.

To configure packet deduplication:

Step 1  Choose Setup > Traffic > Hardware Deduplication.

Step 2  Check the Enabled check box to enable packet deduplication.

Enter a value in the Time Window (1-127 in millisecond (ms)) for the search or buffer period.

The value you set in the Time Window indicates the length of time (ms) in which two packets can be considered duplicates. If the Time Window is 100 ms but two identical packets arrive 120 ms apart, the second packet would not be dropped. If the identical packets arrive 80 ms apart, the second packet would be dropped.

Step 3  Click to choose a segment of the packet to inspect for deduplication.

The default inspects the entire packet. The second option inspects all segments except the ISL portion of the packet. The third option inspects all segments except the ISL, MAC, and VLAN portions of the packet. The fourth option inspects all segments except the ISL, MAC, and VLAN portions of the packet. The final (bottom) option inspects only the UDP/TCP and payload segments of the packet.

Note  Regardless of the option you choose, the packet checksum is ignored.

Step 4  Click Submit to enable the settings you have entered, or click Reset to cancel any change.
Setting Up Alarms and Alarm Thresholds

Alarms are predefined conditions based on a rising data threshold, a falling data threshold, or both. You can choose what types of events for which you want Prime NAM to notify you, and how you want to be notified. Monitoring alarms enables you to watch problem areas and collect data on areas such as increased utilization, severe application response delays, and voice quality degradation.

This is the order that you typically follow for setting up alarms and alarm thresholds:

**Step 1** Define the way you would like to be notified when an alarm occurs (by e-mail, trap, trigger capture, or syslog).
- For e-mail server settings: Choose Administration > System > E-Mail Setting
- For trap settings: Choose Administration > System > SNMP Trap Setting
- For capture session settings: Choose Capture > Packet Capture/Decode > Sessions
- For syslog settings: Choose Administration > System > Syslog Setting

**Step 2** Define the Alarm Action at Setup > Alarms > Actions.

**Step 3** Define the Threshold for this alarm at Setup > Alarms > Thresholds.

The tasks for setting up alarms are:
- Configuring Alarm Actions, page 6-31
- Viewing Alarm Actions, page 6-33
- Defining Thresholds, page 6-33

Configuring Alarm Actions

Alarms are predefined conditions based on a rising data threshold, a falling data threshold, or both. When a threshold’s rising water mark is crossed, the alarm condition is met. This triggers the alarm action to take effect.

To configure an alarm action:

**Step 1** Choose Setup > Alarms > Actions.

The Alarm Action page displays any configured actions. If none of the four actions (e-mail, trap, capture, or syslog) are configured, you will see No data available.

**Step 2** Click Create.

**Step 3** Enter a Name for the action (up to 63 characters).

**Step 4** Choose the type of alarm action. Prime NAM supports any combination of these four actions in one alarm condition:
## Alarm Action Description Important Notes

<table>
<thead>
<tr>
<th>Alarm Action</th>
<th>Description</th>
<th>Important Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>E-mail syslog</td>
<td>An alarm action that e-mails the syslog content of the alarm condition. To avoid e-mail flooding the network, <strong>Prime NAM</strong> does not send more than five e-mails in any given hour.</td>
<td>Configure the e-mail address in <strong>Administration &gt; System &gt; E-Mail Setting</strong>. Prime NAM alarm mail is sent as a result of Prime NAM alarms, not router or switch alarms. Prime NAM sends up to five e-mails per hour per function (traffic and NetFlow, voice signaling, RTP, and application response time). Also, in each e-mail, there could be up to five alarm messages. These limits are in place to avoid e-mail overload. If you have configured e-mail alarms and do not receive e-mail, then your Prime NAM does not have any alarms. If Prime NAM sends you many alarm messages, the e-mail may state, for example, “5 of 2,345 alarm messages.”</td>
</tr>
<tr>
<td>Trap</td>
<td>An alarm action that sends Prime NAM trap messages to one or more trap servers. Any trap server that has the same community string will receive the trap message. Prime NAM uses Cisco Syslog MIB in the trap message. To avoid trap flooding, the limit is ten trap messages per interval.</td>
<td>Choose the SNMP community where you would like traps to be sent. Configure the community string in <strong>Administration &gt; System &gt; SNMP Trap Setting</strong>. After the “Community field appears, choose the community string from the drop-down list.</td>
</tr>
<tr>
<td>Trigger capture</td>
<td>An alarm action to start or stop a pre-defined capture session or stop a capture to save it to a file.</td>
<td>From the Session drop-down, choose the session (the list will be empty if there is no capture session configured in <strong>Capture &gt; Packet Capture/Decode &gt; Sessions</strong>). Click the Start Capture, Stop Capture, or Stop Capture and Save to File radio button. For more details, see <strong>Understanding Trigger Capture</strong>, page 6-33.</td>
</tr>
<tr>
<td>Remote syslog</td>
<td>An alarm action that sends syslog messages to remote syslog servers. The limit is ten syslog messages per interval to avoid flooding the network.</td>
<td>This will log syslog messages. The default setting is to log syslog messages locally to Prime NAM. If you want to log syslog messages to remote servers, set up the destination information at <strong>Administration &gt; System &gt; Syslog Setting</strong>.</td>
</tr>
</tbody>
</table>

**Step 5** To edit or delete alarm actions, select the alarm and use the appropriate button.

**Step 6** Click **Submit**.

The Alarm Action table displays the newly configured action in its list.
Viewing Alarm Actions

Alarms are predefined conditions based on a rising data threshold, a falling data threshold, or both. You can set thresholds and alarms on various network parameters such as increased utilization, severe application response delays, and voice quality degradation and be alerted to potential problems.

Prime NAM supports IPv6 for all alarm functionality.

Note
You could see two alarms for the same occurrence if both the source and the destination are in the same site.

To see events that have been created, choose Setup > Alarms > Actions. See Table D-5 for descriptions of the fields on the Alarm Configuration window.

To configure alarm actions, see Configuring Alarm Actions, page 6-31.

Understanding Trigger Capture

This section describes how to use a trigger capture to start a capture session based on the alarm parameters you set. For example, you can set alarm parameters on various thresholds to start a capture session which can be used to investigate some kind of questionable network activity.

You must set your alarm threshold parameters so that Prime NAM has defined rising or falling numbers that will cause an action, or trigger, to start a capture session. You can also use the stop-and-save and Scheduled Capture option. The actions are defined below:

- Trigger Capture Start—An alarm condition occurs based on threshold parameters you have set; the capture session starts automatically.
- Trigger Capture Stop: An alarm condition occurs based on the threshold parameters you have set; the capture session stops automatically.
- Trigger Capture Stop Capture and Save to File—An alarm condition occurs, stopping the capture session. If the captured packet data is in memory, it is saved to a file. The buffer memory is then clear to wait for next alarm event.
- Trigger Capture Scheduled Capture—An alarm condition occurs, starting the capture session on specific date time for certain duration (in minutes).

When an event occurs that you have defined as an alarm threshold, NAM stops any existing capture session and saves the captured packets from memory into a file. The capture session then restarts. NAM can save up to five files, depending on your local hard disk storage.

NAM monitors for threshold parameters every minute. For real-time data, the default is 5 minutes.

Defining Thresholds

Prime NAM can inspect incoming performance records and apply a configured set of thresholds to the most recent interval of data. Using thresholds allows you to target specific network traffic issues and set up notifications that are triggered when certain thresholds are crossed. For example:

- if a server’s CPU load exceeds 90%
- if a device or the whole network uses more bandwidth than usual, or
- if the remaining file size on a disk drive is less than 15% or 100 MB.
In general, you should set thresholds so that only severe traffic problems that impact quality of service generate events. These critical events are intended to provide actionable notification of problems to network operators. When setting thresholds try to identify a traffic level that will have a noticeable effect on network service levels. Set a duration that corresponds to an unacceptable period of poor service. The goal is to generate very few, significant events indicating severe problems that require immediate attention. Thresholds are not intended as a reporting tool to generate statistical information about network traffic.

To set up alarm thresholds for variables with values that trigger alarms, see Viewing Alarm Actions, page 6-33.

**Note**

You could receive two alarms for the same occurrence if both the source and the destination are in the same site.

You can also decide whether you want to be notified if the threshold is being crossed just once, or whether you only want an alarm to be triggered if this state persists for a certain time. This helps you to ensure an effective network monitoring system, which will not bombard you with unnecessary notifications.

Prime NAM Threshold Alarms window (Setup > Alarms > Thresholds) displays thresholds you have configured. If you hover over the arrow next to the threshold Name a detailed view of the selected threshold displays.

For descriptions of the fields on the Threshold window, see Table D-6.

You can set up alarm thresholds by defining threshold conditions for monitored variables on the NAM. You can configure the following thresholds:

- Setting Host Thresholds, page 6-34
- Setting Conversation Thresholds, page 6-35
- Setting Application Thresholds, page 6-35
- Setting Response Time Thresholds, page 6-36
- Setting DSCP Thresholds, page 6-36
- Setting RTP Stream Thresholds, page 6-37
- Setting Voice Signaling Thresholds, page 6-37
- Setting NetFlow Interface Thresholds, page 6-38
- Setting Video Stream Thresholds, page 6-38
- Setting MDI Stream Thresholds, page 6-39

**Related Topics**

- Configuring Alarm Actions, page 6-31
- Viewing Alarm Actions, page 6-33

### Setting Host Thresholds

**Step 1** Choose Setup > Alarms > Thresholds.
Step 2 Click Create and choose the Host tab.

Step 3 The Host Alarm Threshold Configuration window displays. Fill in the fields as appropriate.

Table D-7 describes the fields available on this window.

| Note | If you leave a selection blank, it means that the parameter will not be considered. If you select Any, it will use any of the selections for that parameter, if encountered. |

Step 4 Click Submit to set the thresholds, click Reset to reset the thresholds to their default value, or click Cancel to remove any changes you might have made.

Step 5 When finished, click Submit.

Setting Conversation Thresholds

Step 1 Choose Setup > Alarms > Thresholds.

Step 2 Click Create and choose the Conversation tab.

Step 3 The Conversation Alarm Threshold Configuration window displays. Fill in the fields as appropriate.

Table D-8 describes the fields available in this window.

| Note | If you leave a selection blank, it means that that parameter will not be considered. If you select Any, it will use any of the selections for that parameter, if encountered. |

Step 4 Click Submit to set the thresholds, click Reset to reset the thresholds to their default value, or click Cancel to remove any changes you might have made.

Step 5 When finished, click Submit.

Setting Application Thresholds

Step 1 Choose Setup > Alarms > Thresholds.

Step 2 Click Create and choose the Application tab.

Step 3 The Application Alarm Threshold Configuration window displays. Fill in the fields as appropriate.

Table D-9 describes the fields available in this window.

| Note | If you leave a selection blank, it means that parameter will not be considered. If you select Any, it will use any of the selections for that parameter, if encountered. |
Step 4  Click **Submit** to set the thresholds, click **Reset** to reset the thresholds to their default value, or click **Cancel** to remove any changes you might have made.

Step 5  When finished, click **Submit**.

### Setting Response Time Thresholds

Step 1  Choose **Setup > Alarms > Thresholds**.

Step 2  Click **Create** and choose the **Response Time** tab.

Step 3  The Response Time Alarm Threshold Configuration window displays. Fill in the fields as appropriate. 

Table D-10 describes the fields available in this window.

**Note**  If you leave a selection blank, it means that that parameter will not be considered. If you select **Any**, it will use any of the selections for that parameter, if encountered.

Step 4  Click **Submit** to set the thresholds, click **Reset** to reset the thresholds to their default value, or click **Cancel** to remove any changes you might have made.

Step 5  When finished, click **Submit**.

### Setting DSCP Thresholds

Step 1  Choose **Setup > Alarms > Thresholds**.

Step 2  Click **Create** and choose the **DSCP** tab.

Step 3  The DSCP Alarm Threshold Configuration window displays. Fill in the fields as appropriate.

Table D-11 describes the fields available in this window.

**Note**  If you leave a selection blank, it means that that parameter will not be considered. If you select **Any**, it will use any of the selections for that parameter, if encountered.

Step 4  Click **Submit** to set the thresholds, click **Reset** to reset the thresholds to their default value, or click **Cancel** to remove any changes you might have made.

Step 5  When finished, click **Submit**.
Setting RTP Stream Thresholds

Prime NAM sends syslog, trap, e-mail, and trigger captures for RTP streams that violate stream statistics thresholds on the following metrics:

- Number of Consecutive Packet Loss
  Each RTP packet has an RTP header that contains a sequence number. The sequence number increments by one for each RTP packet received in the same RTP stream. A gap in the sequence numbers identifies a packet loss. If the gap in sequence numbers jump is more than the threshold, the software raises an alarm condition.

- Packet Loss percent
  There are two types of percent packet loss percent: Adjusted Packet Loss and Actual Packet Loss. Actual Packet Loss indicates expected packets that never appear in Prime NAM. Adjusted Packet Loss includes actual packets lost and packets that arrive with large delay beyond the expected buffer capacity of the endpoint.

- Jitter: Packets delay compare to the expected receiving time

- Concealment Seconds: Seconds in which there is one or more packets lost

- Severe Concealment Seconds: Seconds in which there is more than 5% of packet lost

To set thresholds for RTP streams:

**Step 1** Choose **Setup > Alarms > Thresholds**.

**Step 2** Click **Create** and choose the **RTP Streams** tab.

**Step 3** The RTP Stream Alarm Threshold Configuration window displays. Fill in the fields as appropriate. **Table D-12** describes the fields available in this window.

**Note** If you leave a selection blank, it means that that parameter will not be considered. If you select any, it will use any of the selections for that parameter, if encountered.

**Step 4** Click **Submit** to set the thresholds, click **Reset** to reset the thresholds to their default value, or click **Cancel** to remove any changes you might have made.

**Step 5** When finished, click **Submit**.

Setting Voice Signaling Thresholds

You can set up software to monitor voice call quality. When Cisco Unified Communication Manager’s call detail records option is enabled, Cisco IP phones, both SCCP and SIP, will report the call’s jitter and packet loss at the end of the call. Prime NAM intercepts this information and raises an alarm when the alarm condition crosses the rising threshold.
To set up a voice signaling threshold:

**Step 1** Choose **Setup > Alarms > Thresholds**.

**Step 2** Click **Create** and choose **Voice Signaling** tab.

**Step 3** The Voice Signaling Alarm Threshold Configuration window displays. Fill in the fields as appropriate. Table D-13 describes the fields available under the Voice Signaling Metrics drop-down menu.

*Note* If you leave a selection blank, it means that that parameter will not be considered. If you select **Any**, it will use any of the selections for that parameter, if encountered.

**Step 4** Click **Submit** to set the voice signaling thresholds, click **Reset** to reset the thresholds to their default value, or click **Cancel** to remove any changes you might have made.

**Step 5** When finished, click **Submit**.

---

### Setting NetFlow Interface Thresholds

**Step 1** Choose **Setup > Alarms > Thresholds**.

**Step 2** Click **Create** and choose the **NDE Interface** tab.

The NDE Interface Alarm Threshold Configuration window displays. The fields are described in Table D-14.

*Note* If you leave a selection blank, it means that that parameter will not be considered. If you select **Any**, it will use any of the selections for that parameter, if encountered.

**Step 3** Click **Submit** to set the thresholds, click **Reset** to reset the thresholds to their default value, or click **Cancel** to remove any changes you might have made.

---

### Setting Video Stream Thresholds

Prime NAM can monitor the quality of video streams and trigger alarms for video streams that violates stream statistics thresholds. Each video stream contains a series of video frames. The video frames are of different frame type such as I (Intra), P (Predicted) and B (Bi-predictive). I frames are the most important frames in the video. The metrics are given with regard to only I frames or to all frame types. The metrics are as follows:

- Number of Video Frame Loss Count
- I or All frame loss count in the current interval
- Video Frame Loss Percentage
- All frame loss percentage in the current interval

To set thresholds for Video streams:
Setting Up Alarms and Alarm Thresholds

Step 1 Choose Setup > Alarms > Thresholds.
Step 2 Click Create and choose the Video Streams tab.
The Video Stream Alarm Threshold Configuration window displays. Fill the fields as appropriate. Table D-14 describes the fields available in this window.
Step 3 Click Submit to set the thresholds, click Reset to reset the thresholds to their default value, or click Cancel to remove any changes you might have made.
Step 4 Click Submit when finished.

Setting MDI Stream Thresholds

MDI streams are defined as video streams that are carried over MPEG-TS. Prime NAM can monitor the quality of MDI streams and trigger alarms for streams that violate stream statistics thresholds on the following metrics:
• Delay Factor: RFC-4445 delay factor.
• Media Loss Rate: RFC-4445 media loss rate.
To set thresholds for Video streams:

Step 1 Choose Setup > Alarms > Thresholds.
Step 2 Click Create and choose the MDI Streams tab.
The MDI Stream Alarm Threshold Configuration window displays. Fill the fields as appropriate. The following table describes the fields available in this window.
Step 3 Click Submit to set the thresholds, click Reset to reset the thresholds to their default value, or click Cancel to remove any changes you might have made.
Step 4 When finished, click Submit.

Editing or Deleting an Alarm Threshold

You can edit alarm thresholds on an as-needed basis. You can delete thresholds when you no longer need them. Any changes take effect immediately.

To edit or delete an alarm threshold:

Step 1 Choose Setup > Alarms > Thresholds.
The Thresholds table displays.
Step 2 Select the alarm, then click Edit or Delete.
Step 3 Depending on your selection:
• If you selected to edit, the dialog box displays for the type of alarm; for example, Host Threshold. Make the necessary changes. Then
  – click Submit to save your changes
  – click Reset to reset the thresholds to the values set before you edited them, or
Setting Up Data Export

The tasks for setting up data export are:

- Configuring NetFlow Export Templates, page 6-40
- Scheduling Data Report Exports, page 6-41
- Sharing Files, page 6-41

Configuring NetFlow Export Templates

This section contains the following topics:

- Creating NetFlow Export Templates, page 6-40
- Editing NetFlow Export Templates, page 6-40
- Deleting NetFlow Export Templates, page 6-41

Creating NetFlow Export Templates

To create NetFlow Export templates:

Step 1 Choose Setup > Data Export > NetFlow.
The NetFlow Export Template page appears.

Step 2 Click Create.
The Export Configuration page appears.

Step 3 Fill in the fields as described in Table D-33.

Step 4 Click Submit to save your changes.

Editing NetFlow Export Templates

To edit NetFlow Export templates:

Step 1 Choose Setup > Data Export > NetFlow.
Step 2 Click the template that you want to edit.
Step 3 Click Edit.
Step 4 Modify the information as desired.
Step 5  Click **Submit** to submit to save the changes.

### Deleting NetFlow Export Templates

To delete NetFlow Export templates:

**Step 1**  Choose **Setup > Data Export > NetFlow**.

**Step 2**  Click the template that you want to delete.

**Step 3**  Click **Delete**.

**Step 4**  Click **OK** to confirm, or **Cancel** to return to the previous window without deleting.

### Sharing Files

This feature allows you to easily access the NAM data files. You can map the NAM as a network drive and it will appear like any other folder in your machine. You will be able to only read and delete the files for security and stability reasons.

To share the NAM data files:

**Step 1**  Check the **Enable** check boxes to enable the SMB and SFTP file sharing services.

**Step 2**  Enter the port details for SMB and SFTP services.

**Step 3**  Select either **Share** or **Hide** to share or hide the capture files and scheduled reports.

The dataset access behavior varies between SMB and SFTP. If SMB is enabled, and if the dataset is hidden, the directory will not be visible. If SFTP is enabled, and dataset is hidden, the directory will be visible but you will not be able to access or view any files within it.

**Step 4**  Click **Submit** to access the shared files via SMB or SFTP using web-user's username and password.

**Note**  TACACS users cannot use the file sharing feature. You have to use NAM’s local web-users to access the shared files.

### Scheduling Data Report Exports

You can use Prime NAM to schedule data collection over a period of time for trend analysis and troubleshooting activities and then export the reports to be viewed at your convenience. For example, if you see a spike in application response time on a certain day or time you can set up a scheduled report. The report exports collected data from a specific range of time so that you have a snapshot of what might be causing issues.

You can set up scheduled jobs that will generate a daily report at a specified time, in a specified interval, and e-mail it to a specified e-mail address or addresses.
You can also obtain a report immediately by clicking the **Preview** button, rather than wait for the scheduled time. This report can also be sent after you preview it.

**Tip**

Prime NAM displays time in preview report based on the browser that initiated the report. So if your browser is in San Jose, CA, the time zone displayed in the report is based on the time zone of that machine. Scheduled email report shows NAM server timezone. The data is not based on the Cisco NAM server time if the two machines are not synchronized. To synchronize your time, see **Synchronizing Your System Time, page 4-5**.

This section covers the following topics:

- Creating a Scheduled Report Export, page 6-42
- Editing a Scheduled Export Job, page 6-43
- Deleting a Scheduled Export Job, page 6-43
- Downloading a Scheduled Report, page 6-43
- Renaming a Scheduled Report, page 6-44
- Deleting a Saved Reports, page 6-44

**Creating a Scheduled Report Export**

Scheduled export of data reports is a convenient way to collect traffic of interest in Prime NAM. We strongly recommend you to define your data report time range first and then set your export time right after your report end time. This is the most straight-forward way to use this feature.

To set up a scheduled report and export it to an e-mail address or addresses:

**Step 1**
From any Monitor or Analyze window, click **Export** in the Interactive Report pane to select your export preferences. If you want the report to contain filtered data, enter the filters before selecting **Export**.

**Step 2**
Enter the Report Name and Report Description. Report name should be at least four characters long.

**Step 3**
Enter the e-mail address to which you would like the report to be delivered.

**Step 4**
Choose either CSV or PDF as the delivery option.

**Step 5**
Choose **Save** to save the report to your local disk.

**Step 6**
Choose the Report Time by selecting a time range for the interval of time you want data measured. The time range is limited to a 24 hour period. Any time range that includes midnight will have a **from** time larger than **to** time.

**Step 7**
Choose the Export Time (which is the day of the week on which to generate the weekly report and hour that report will be sent). Multiple days are supported. You can also specify what time to start the export.

The actual data time range used to generate the report for export is always the last available and complete time span specified in the Report Time step above. Prime NAM does not generate reports using data in any future time. For example:
Chapter 6      Customizing Cisco Prime NAM

Setting Up Data Export

<table>
<thead>
<tr>
<th>Export Time</th>
<th>Report Time</th>
<th>Data Reported and Exported</th>
</tr>
</thead>
<tbody>
<tr>
<td>If Every Day and Hour is 09:00</td>
<td>07:00 to 08:00</td>
<td>07:00 to 08:00 the same day (recommended use case)</td>
</tr>
<tr>
<td>If Monday and Friday and Hour is 03:00</td>
<td>05:00 to 05:59</td>
<td>Sunday and Thursday 05:00 to 05:59</td>
</tr>
<tr>
<td>If Every Day and Hour is 00:00</td>
<td>18:00 to 01:00</td>
<td>Starts two days before current day from 18.00 to the next day 1.00</td>
</tr>
</tbody>
</table>

Tip

Set your Export Time to occur right after the end of Report Time. This gives you the most recent data and is the easiest way to use this feature.

Step 8

Click Submit to submit the request for the scheduled job, or click Preview to generate the report immediately.

Note

Remember that report results are based on the local time of the browser that initiated the report.

Editing a Scheduled Export Job

Step 1

Choose Setup > Data Export > Scheduled Exports.

Step 2

Click the job you want to edit.

Step 3

Click Edit.

Step 4

Modify the information as desired.

Step 5

Click Submit to submit the request for the scheduled job.

Deleting a Scheduled Export Job

Step 1

Choose Setup > Data Export > Scheduled Exports.

Step 2

Click the job you want to delete.

Step 3

Click Delete to delete the selected job, or click Delete All to delete all the jobs.

Step 4

Click OK to confirm, or click Cancel to return to the previous window without deleting the job.

Downloading a Scheduled Report

To download a scheduled report:
**Accessing Device Interface and Health Details**

You can enable your NAM to access interface and health device details if they are available on the device you identify using the Prime NAM Managed Device feature.

This section contains the following topics:

- Understanding How Platform-Specific NAMs Handle Managed Device Data, page 6-45
- Configuring Managed Device Information, page 6-45
- Viewing Managed Device Information, page 6-47

---

**Renaming a Scheduled Report**

To rename a scheduled report:

1. Choose Setup > Data Export > Scheduled Exports.
2. Click Saved Reports tab.
   You will be able to view the saved reports in a tabular format.
3. Select the reports that you want to rename.
4. Click Rename.

---

**Deleting a Saved Reports**

1. Choose Setup > Data Export > Scheduled Exports.
2. Click Saved Reports tab.
3. Click the reports you want to delete.
4. Click Delete to delete the selected job, or click Delete All to delete all the jobs.
5. Click OK to confirm, or click Cancel to return to the previous window without deleting the job.

---

**Steps for Accessing Device Interface and Health Details**

1. Choose Setup > Data Export > Scheduled Exports.
2. Click Saved Reports tab.
   You will be able to view the saved reports in a tabular format.
3. Select the reports that you want to download.
4. Click Download.

---

**Steps for Configuring Managed Device Information**

1. Choose Setup > Data Export > Scheduled Exports.
2. Click Saved Reports tab.
   You will be able to view the saved reports in a tabular format.
3. Select the reports that you want to download.
4. Click Download.
Understanding How Platform-Specific NAMs Handle Managed Device Data

A managed device can represent a router or switch being monitored by Prime NAM. Depending on your Cisco NAM platform, the managed device is accessed by the NAM differently and may support different MIBs based on the device support.

The following details list how NAM accesses the managed device:

- For a physical or virtual blade or service module, the managed device is the device in which NAM software or hardware is located. The managed device information is automatically updated without user intervention and cannot be modified on the NAM. One of the benefits of having a blade or service module is that there is no configuration required for this feature.

- For a physical appliance, you identify the managed device as a switch or router that shares its traffic using SPAN or user credentials. You must enter the device address and either the SNMP credentials or NetConf credentials to configure the NAM SPAN session on the managed device. On certain platforms, NetConf is an alternative for NAM to configure a NAM SPAN session on a managed device which does not support configuring NAM SPAN sessions using SNMP. If you choose to use NetConf, you must enable NetConf on the managed device interface and enable SSH to support the SPAN session. This enables you to monitor managed device information such as interface statistics.

- All supported NAM platforms, except NAM-NX1 and vNAM, require `if-mib (ifTable)` to provide the managed device interface data. NAM-NX1 gets this data by exchanging messaging with the Supervisor card (SUP) on the EOBC channel. SPAN session configuration from a managed device is not allowed on Cisco Prime vNAMs.

- All supported NAM platforms, except for NAM-NX1, vNAM, and NAM appliance platforms, require `entity-mib` and `if-mib` to get and configure SPAN sessions. NAM-NX1 uses EOBC and proprietary messages with SUP on EOBC to get and configure SPAN sessions. Appliances have two options to get and configure SPAN sessions: SNMP (which use the MIBs required by the other NAM platforms) or NetConf interface (which require no MIBs). SPAN session configuration from a managed device is not allowed on Cisco Prime vNAMs.

- For RISE, the managed devices are Nexus 7000 series switches. The Nexus switches support RISE feature and are directly or indirectly connected to the NAM appliance in RISE mode and configured accordingly. With supported SUP software version, the setup is plug-n-play, and no additional configuration is required on the NAM side. See the RISE NAM configuration section in *Cisco Remote Integrated Services Engine with Cisco Prime NAM and Cisco Nexus 7000 Series Switches Configuration Guide* for more details.

To see a list of the available platforms and supported devices, see the *NAM Compatibility Matrix*. For MIB support, see Table D-73 on page D-55.

Configuring Managed Device Information

The managed device information that is required is dependent on your platform device type. For details, see *Understanding How Platform-Specific NAMs Handle Managed Device Data*, page 6-45.

For details on how to ensure NAM is managing your device interface and other traffic, see:

- Configuring Managed Device Information on Blades or Modules, page 6-46
- Configuring Managed Device Information on Appliances and other Virtual Platforms, page 6-46
- Configuring Managed Device Information on RISE Appliances, page 6-46
Configuring Managed Device Information on Blades or Modules

You are not required to configure NAM blades or modules on the NAM side.

Note
NAM-3 platform requires SNMP MIBS (SNMPv3 is not required). SNMP requests and responses are communicated over an internal interface within the chassis and SNMPv3 is not used. NAM-NX1 requires some SNMP MIBs.

Ensure you follow the configuration instructions in your platform documentation so that your managed device communicates network traffic to NAM.

Once NAM automatically updates your managed device details, you can view that information using Setup > Managed Device > Device Information. For details, see Viewing Managed Device Information, page 6-47.

For details about how NAM treats managed devices, see Accessing Device Interface and Health Details, page 6-44.

Configuring Managed Device Information on Appliances and other Virtual Platforms

For appliances and some virtual NAM platforms, you must set up your managed device using the NAM Setup > Managed Device > Device Information window. Enter your device address and credentials to allow NAM SPAN session configuration. You need to configure SNMP credentials to receive details about managed device interface statistics. You may need to configure NetConf credentials to enable a NAM SPAN session to and from the managed device. To use NetConf, your managed device must support the NetConf interface and have SSH enabled. You can use NetConf as an alternative to configuring a NAM SPAN session on your managed device if your device does not support configuring NAM SPAN sessions via SNMP.

Note
This section applies to all Cisco NAM platforms except the NAM-NX1 and NAM-3 blades. SPAN session configuration via managed device is not allowed on vNAMs.

To set your managed device parameters:

Step 1 Choose Setup > Managed Device > Device Information.

Depending on your managed device, either the Router System Information displays as show in Table D-17 or the Switch System Information displays as shown in Table D-18.

Step 2 Click Test Connectivity to perform an SNMP test. Click Close when finished.

Step 3 Click Submit to submit the information and close the window.

Configuring Managed Device Information on RISE Appliances

For some NAM appliance in RISE mode, you must set up your managed device using the NAM Setup > Managed Device > Device Information window.
To edit your managed device parameters:

---

**Step 1** Choose **Setup > Managed Device > Device Information**.  
The managed devices and the VDC details appear.

**Step 2** Select the short term interval from the **Managed Device Interface Stats** drop-down list and click **Submit**.  
When you modify the interval, the existing data will be removed.

**Step 3** Select the managed device and click **Edit**.

**Step 4** Select the VDC which you want to enable/disable and click **Enable/Disable**. To delete or refresh VDC details, click **Delete** or **Refresh**.

---

### Viewing Managed Device Information

To view the switch information, choose **Setup > Managed Device > Device Information**.  
Depending on your platform, the System Information may display some or all of the fields shown in Table D-17 or Table D-18.

---

### Configuring Network Parameters

This section describes how to set up the network parameters including:

- Configuring Sites, page 6-47
- Setting Interface Speed using NetFlow Interface Capacity, page 6-51
- Configuring DSCP Groups, page 6-51

---

### Configuring Sites

Cisco Prime Network Analysis Module makes it easier to monitor traffic and identify issues across your network by providing a way to manage large campuses using different views of your network, referred to as **sites**.

A **site** is a collection of hosts (network endpoints) partitioned into views. You can limit the view of your network analysis data to a specific city, a specific building, or even a specific floor of a building, and can use sites to focus collection and analysis of data. Sites are optional, but recommended.

See the following sections to set up sites:

- Defining a Site, page 6-48
- Viewing Defined Sites, page 6-48
- Configuring Sites Using Subnets, page 6-49
Defining a Site

A site can be defined as a set of subnets specified by an address prefix and mask, or using other criteria such as a remote device data source (for example, remote WAE device and segment information).

Configuring Sites Using Subnets, page 6-49 gives specific information about various scenarios.

To set up a site or sites:

**Step 1** Choose Setup > Network > Sites and click Create.

**Step 2** The Site Configuration window appears. Enter a Name, Description, Subnet, and Data Source as appropriate.

See Table D-20 for field descriptions.

**Step 3** Enter the subnet and data source, then click Detect to tell the software to look for subnets in the traffic.

See Detecting Site Subnets, page 6-48.

**Step 4** Click Submit.

*Note* The “Unassigned” site (with a description of “Unclassified hosts”) includes any that do not match any of your site configurations. Sites are classified at the time of packet processing.

Detecting Site Subnets

When you click the Detect button at Setup > Network > Sites > Sites Configuration, Prime NAM looks for subnets detected within in the past hour. See Table D-21 for information about the fields.

When you click Detect, Prime NAM finds those subnets that meet the criteria that you entered.

Viewing Defined Sites

To view already-defined sites:

**Step 1** Choose Setup > Network > Sites.

**Step 2** The Sites window appears. Defined sites will be listed in the table.

The fields are described in Table D-22.

Editing a Site

You can edit sites that have been created. The Unassigned site cannot be edited or deleted.

**Step 1** Choose Setup > Network > Sites.

**Step 2** Highlight the site that you have configured.

**Step 3** Click Edit and edit the desired field.
The fields are described in Table D-22.

**Step 4**  
Click **Submit** to save the changes, or click **Reset** and **OK** to reinstate the site’s previous settings, or click **Cancel** to cancel any changes and return to the main Sites page.

## Configuring Sites Using Subnets

The site definition is very flexible and can accommodate various scenarios. Prime NAM uses the site definition not only for viewing of data, but for data export and data retention as well. The same rule cannot be defined in multiple sites. That is why the preferred way is to define a site using its subnets. See Table 6-4 for examples of site definitions.

### Note

VLAN option is removed from the Site definition.

For details on how Prime NAM resolves overlapping IP addresses, see Resolving Ambiguity (Overlapping Site Definitions), page 6-50

<table>
<thead>
<tr>
<th>Site Definition</th>
<th>Example</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Subnet (IP address prefix)</td>
<td><strong>Site Data-Center = subnet 172.20.0.0/16</strong></td>
<td>Preferred. Normally, subnets alone are sufficient to define a site.</td>
</tr>
</tbody>
</table>
| Overlapping IP addresses (subnet from data source) | **Site NewYork = subnet 10.11.0.0/16 from "NetFlow-NewYork" data source.**  
**Site LosAngeles = subnet 10.11.0.0/16 from "NetFlow-LosAngeles" data source.**  
**Site Sale-Dept = subnet 10.11.0.0/16 from "DATA PORT 1" data source.**  
**Site Finance-Dept = subnet 10.11.0.0/16 from "DATA PORT 1" data source.** | In certain scenarios when there are overlapping IP address spaces in the networks (for example, in private networks where hosts from different sites have the same IP addresses), then data sources can be used to differentiate the subnets. |
### Table 6-4 Site Definition Details

<table>
<thead>
<tr>
<th>Site Definition</th>
<th>Example</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>WAE device serving the site</td>
<td>For WAAS traffic, you can define a site associated with a WAE device without specifying the site’s subnets. Simply select all of the WAAS data sources coming from the WAE device(s) serving that site. <em>Site SanJose = WAE-SJ-Client, WAE-SJ-CltWAN, and WAE-SJ-Passthrough data sources.</em></td>
<td>We recommend that you use subnets to specify WAAS-optimized sites. Use this method only if the site’s subnets cannot be determined. If you are configuring a WAAS device, you will need to add WAAS servers to Prime NAM. See Auto Create of New WAAS Devices, page 6-29.</td>
</tr>
<tr>
<td>Multiple Rules</td>
<td>You can define a site using a combination of multiple rules described in this table. For example, if a site has both optimized and non-optimized traffic, it can be defined using a combination of WAAS data sources and a subnet from a NetFlow data source.</td>
<td>When defining a site using multiple data sources, be careful to make sure that those data sources do not have duplicated traffic to avoid double counting the site traffic statistics.</td>
</tr>
<tr>
<td>Unassigned site</td>
<td>The Unassigned site includes hosts that do not match any of your site configurations. Sites are classified at the time of packet processing.</td>
<td>Cannot be edited or deleted.</td>
</tr>
</tbody>
</table>

### Resolving Ambiguity (Overlapping Site Definitions)

Conflicting rules are not allowed in site definitions. Of the following two scenarios, the second one is not allowed.

1.2.3.0/24 from DATASOURCE1 = SiteA

1.2.3.0/24 from DATASOURCE1 = SiteB

Using a prefix is the preferred method. Data source is secondary. In the following two scenarios, the first would receive the higher priority.

1.2.3.0/24 = Site D

WAE1-Client datasrc = Site E

The longest prefix has higher priority (same data source). In the following two scenarios, the first would receive the higher priority.

1.2.3.0/24 from DATASOURCE1 = Site A

1.2.0.0/16 from DATASOURCE1 = Site C

The more refined (specific) rule has higher priority. In the following two scenarios, the first would receive the higher priority.

1.2.3.0/24 from DATASOURCE1 = Site A
1.2.3.0/24 (any datasrc) = Site D

Setting Interface Speed using NetFlow Interface Capacity

After you have set up NetFlow data sources (see Forwarding NetFlow Traffic, page 6-16), you can go to the NDE Interface Capacity window at Setup > Network > NDE Interface Capacity to specify the speed of each interface. This allows the software to calculate interface utilization on the NDE Interface Traffic Analysis window (Analyze > Traffic > NDE Interface). Otherwise, the Prime NAM software can only display the throughput of the interface, but cannot show its utilization.

The interface name and speed will be automatically discovered by the Prime NAM if you configure the device SNMP credentials in Setup > > Create > Type: NETFLOW.

To add a new or edit an existing interface, continue to Creating or Editing a NetFlow Interface, page 6-51.

Creating or Editing a NetFlow Interface

To add a new interface if it has not been automatically discovered, at the NetFlow Data Export (NetFlow) Interface Capacity window (Setup > Network > NDE Interface Capacity), click Add. Then fill in the fields as described in Table D-23.

Note

It is normally not necessary to manually create NetFlow interfaces. They should be discovered automatically when the device sends NetFlow packets to the NAM.

To edit an existing interface, choose the device, then click Edit. Fill in the fields as described in Table D-23.

Configuring DSCP Groups

Differentiated services monitoring (DiffServ) is designed to monitor the network traffic usage of Differentiated Services Code Point (DSCP) values. To monitor DSCP, you must configure at least one aggregation profile, and one aggregation groups associated with each profile. This section describes how to set up the DSCP groups.

You can define two or three different groups of traffic, and assign the various DSCP values to each group. Or you can assign one particular value for the first group and give it a name, and then assign all the rest to the other (or default) group and give that a name.

For detailed information about setting DSCP values, see Implementing Quality of Service Policies with DSCP:

The following tasks help you set up and manage the DSCP groups:

- Creating a DSCP Group, page 6-52
- Editing a DSCP Group, page 6-52
- Deleting a DSCP Group, page 6-52
Creating a DSCP Group

To create a DSCP Group:

Step 1  Choose Setup > Network > DSCP Groups.
The DSCP Groups table displays.
Step 2  Click Create.
The DSCP Group Configuration window displays.
Step 3  Fill in the fields as described in Table D-24. Table D-25 shows the available formats and associated values.
Step 4  Click Submit to save your changes.

Editing a DSCP Group

To edit a DSCP group:

Step 1  Choose Setup > Network > DSCP Groups.
The DSCP groups window displays.
Step 2  Select the profile to edit, then click Edit.
Step 3  Make the necessary changes, then click Submit to save your changes, or click Reset to cancel.

Deleting a DSCP Group

To delete a DSCP group, select the profile from the DSCP Groups table, then click Delete.

Configuring Application Classification

Prime NAM provides two ways of enhancing how your traffic is displayed in the dashboard and reports. Prime NAM uses application classification to:

- Expand the number of application’s for which Prime NAM can provide down to Layer 7 application details. See Adding More Detail into Dashboard and Application Reports.
- Create custom applications using a list of rules based on HTTP URL or Server /Port definition. This is referred to as the classic application classification model. See Creating Deeper Visibility Into Application Traffic, page 6-55.

You can use one or both of these methods to ensure Prime NAM provides the level of traffic detail you need.
Adding More Detail into Dashboard and Application Reports

You can add more detail enable deep packet inspection to see Layer 7 application visibility by using application classification. To understand more about application classification and Layer 7 application visibility, see About Deeper Application Classification.

In order to enable application classification for deep packet inspection in Prime NAM:

Step 1 Choose Setup > Classification > Applications Settings. Then select the Deep Packet Inspection checkbox in order to enable your Prime NAM dashboards to display key critical details, such as hostname and port, in your traffic captures and reports.

Step 2 (Optional). Select New in the Protocol Pack pane to download the latest NBAR2 Protocol Pack (PP). The PP is a single compressed file that contains the rules used for classifying traffic when Deep Packet Inspection is enabled. Prime NAM stores the default plus one additional PP.

Step 3 Enter the PP URL to download the PP files.

This URL supports ftp, http[s], scp, and sftp protocols. The User Name and Password fields are used only if the server requires authentication. Alternatively, the username and password can be specified directly within the following URL:

ftp://username:password@hostname/

You can also download the PP files under the Cisco Prime Network Analysis Module product links at the CCO software download location at following URL:

http://software.cisco.com/download/navigator.html


Step 4 To revert back to the default protocol when a previous protocol pack is no longer needed, choose Restore Default.

About Deeper Application Classification

This release of Prime NAM supports a more comprehensive, or deeper, application classification method. This method allows you to see more details in your monitoring dashboards and packet captures (including application names, interface details, and so on).

To expand the level of application information your Prime NAM can monitor and analyze, enable the deeper level of application classification and download application signature updates when you need them.

In addition to providing the application name, this method also brings attributes to simplify application management for both classification and reporting. Application categorization, for example, allows the grouping of similar applications.

When this method is enabled you can view extracted information from applications such as HTTP URL, HTTP User Agent, and SIP URL, for export or classification.

Note Depending on your installation or upgrade method you may need to enable deep packet inspection.
You can use protocol packs to add new and update existing application signatures. NAM support of protocol packs allows you to see any new and updated application signatures in Prime NAM traffic monitoring. For more details on Protocols Packs, see About Protocol Packs and Application Classification, page 6-54.

You can also use the Prime NAM CLI to change the classification status to use the deeper application classification method and check which classification setting your NAM is using.

For details about what application signatures are in specific protocol pack versions, see Network-Based Application Recognition Q&A on Cisco.com.

For details on enabling deep application classification and updating protocol packs using the CLI, see the Cisco Prime Network Analysis Module Command Reference Guide.

About Protocol Packs and Application Classification

Prime NAM uses Cisco’s Network-Based Application Recognition to recognize and classify a wide variety of protocols and applications, including web-based and other difficult-to-classify applications and protocols that use dynamic TCP/User Datagram Protocol (UDP) port assignments. The support of Protocol Packs (PP) allow you to update your application signatures so that dashboard and traffic data provide the most detailed information available. Prime NAM Protocol Packs can be found in the CCO software download location. These are the only protocol packs you should use with Prime NAM.

You do not need a license to download a protocol pack for Prime NAM. For this release, updating the protocol pack may cause a temporary interruption of operation for several seconds, similar to changing the system time.

To view the Prime NAM Protocol Pack version, choose Setup > Classification > Applications Settings.

To turn on deep application classification in Prime NAM, choose Setup > Classification > Applications Settings and select Deep Packet Inspection. For details, see Adding More Detail into Dashboard and Application Reports, page 6-53.

If you choose not to use the deep application classification method, Prime NAM defaults to a less comprehensive classification method that may not include all applications or protocols.

About NAM Classic Deep Packet Application Classification

This section covers how you can customize your Prime NAM to provide a deeper level of visibility into the application data presented in the dashboard and reports.

Prime NAM uses the application ID classification system. When defining applications, you can view and select from a list of protocols and port numbers, and candidate IP addresses and port numbers for the traffic being analyzed. You can also create URL-based application classifications. For an in depth overview of application types, see Understanding Application Traffic, page 6-57.

You can also configure custom applications using the Application Programming Interface (API), also referred to as the North Bound Interface (NBI). This is needed to ensure uniform application classification across a number of NAMs. See your customer service representative for details on how to get access to the NBI documentation.

To set up classifications use the following tasks:

- Creating Deeper Visibility Into Application Traffic, page 6-55
- Configuring Application Groups, page 6-59
- Filtering Encapsulations, page 6-60
Creating Deeper Visibility Into Application Traffic

This section provides details into the application classification method known as Network Based Application Recognition (NBAR) classic.

You can use Prime NAM to monitor pre-determined or custom applications in your Data Center so that your traffic analysis is more focused and therefore optimal.

Without configuring application classification, applications running on a certain servers or specific ports are classified as *unknown*. This means that you may not have enough insight into the monitoring traffic. After configuring your application or ports, you can gain visibility into those application details on the monitoring screens. Similarly for the URL-based applications, instead of having all web traffic being grouped under the HTTP URL, you can specify a more granular layer of monitoring by using the application and port.

This section describes the following tasks:
- Creating Custom Applications, page 6-55
- Editing Custom Application Classifications, page 6-56
- Adding More Detail into Dashboard and Application Reports, page 6-53
- Deleting an Application Rule, page 6-56
- Understanding Application Traffic, page 6-57

To find out more about Layer 7 visibility and deep packet inspection, see Adding More Detail into Dashboard and Application Reports, page 6-53.

Creating Custom Applications

You can create a custom applications using the list of rules based on HTTP URL, Protocol, or Server IP addresses. If you create a custom application, you can later edit it if you choose. Standard, pre-defined applications cannot be edited.

For details on application types or other options, see Understanding Application Traffic, page 6-57.

To create a new application classification:

**Step 1**  Choose **Setup > Classification > Applications** and select **Create**.
For a description of the Applications window, see Table D-27.

**Step 2**  Enter an application classification name.

**Step 3**  (Optional) Enter an application description that gets displayed in the view table. There is a 75 character limit.

**Step 4**  (Optional) You can skip the Selector value. This is an arbitrary number, unique within an engine-id. It will be automatically assigned if left blank.

**Step 5**  Select the application classification rule type drop-down menu.

  - To choose a Server/Port application rule, select **Server/Port** in the Application Classification Rule drop-down menu.
    Then select the definition drop-down menu to enter the following required information.
    
    - To choose a Server, Protocol, and Port or Port Range, select the drop-down menu then enter the required information.
    
    - To choose a protocol, select **Any**, **TCP**, **UDP**, or **Both TCP & UDP**.
- To choose a port or port range, enter the required information.

b. To choose the URL-based application rule, select HTTP URL in the Application Classification Rule drop-down menu then enter the required information. (See Understanding URL-Based Application Classification, page 6-58 for additional field details.)

Tip
You can also add or remove multiple rule definitions to this application classification by clicking the gear icon and selecting Insert new rule or Delete.

Step 6
Click Submit to create the new application classification signature.
You can now monitor the new applications using the Interactive Report filter with the application dashboards.

Editing Custom Application Classifications
In Prime NAM you can only modify the custom, or user-defined, applications, and not the preconfigured system applications. You can only edit an application for which it states Custom in the Engine ID column.

To edit an application:

Step 1
Choose Setup > Classification > Applications.

Step 2
Select the application to edit, and click Edit.
The Application configuration window displays.

Step 3
Make the desired changes.

Step 4
Do one of the following:
- To accept the changes, click Submit.
- To leave the configuration unchanged, click Cancel.
- To delete the application rule, click Delete.

Deleting an Application Rule
You may want to delete an application rule when you are no longer using it in your network.
To delete an application rule, simply select it from the Application list, then click Delete.
You cannot delete preconfigured system applications, only custom applications.
Understanding Application Traffic

This section contains information on application types, rules, and other details you may find helpful.

There are two types of application classification rules:

1. **Server/Port** rules define a server IP address. For server-based application classification, Prime NAM analyzes traffic for the candidate IP addresses and port number or numbers you specify. You can also define port or protocol-based application (for example, based on a TCP port). You can create additional ports to enable Prime NAM to handle additional traffic for standard applications. Port ranges for IP are 1-255 for IP. TCP and UDP port ranges are 1-65535.

2. **HTTP-based URL** rules define URL-based application extensions to the existing list of supported applications. When the URL in an HTTP request matches the criteria of a URL-based application, the traffic is classified as that protocol. The HTTP request is a URL on any port that is part of the iana-l4:http protocol, or protocol named http under the iana-l4 engine ID.

To create Protocol or Server IP Address applications, you can check the Application Configuration table in **Analyze > Traffic > Application**. To create an HTTP URL-based application, you can analyze the incoming URLs on **Analyze > Traffic > URL Hits**. NBAR is enabled through CLI and GUI.

Prime NAM recognizes an application based on either:

- An application which resides on a specific server IP address—You can filter using an IP address, a protocol, and a port or range of port numbers. After configuring the server information, the monitoring dashboard displays more detailed application information instead of just the unknown grouping.

- A set list of application IDs—the protocol, port number, or port number range, along with the focused inspection of traffic (for example, voice signaling traffic or FTP), heuristics (for example, DCE-RPC or SUN-RPC), or standardized application identifiers exported by Cisco platforms with NetFlow.

If Prime NAM is not able to recognize an application using any of these mechanisms, the application type of the traffic is reported as unknown. You can configure the application reported as unknown to create custom applications.

- A custom application based on a URL-based HTTP request—you can include URL Host, or URL Path and allows you to gain additional visibility instead of grouping all web traffic HTTP. For details, see Understanding URL-Based Application Classification, page 6-58.

To add custom applications and view or edit any user-defined applications, choose **Setup > Classification > Applications**.

**Caution**

There is no limit on the number of URL-based applications that can be created. It is important to consider that these types of applications use large amounts of CPU bandwidth and may impact your performance if too many are defined.

Table D-26 describes the fields on the Applications view page.
Understanding URL-Based Application Classification

URL-based applications are extensions to the list of applications. When the URL in an HTTP request (a URL on any port that is part of the iana-l4:http protocol, or protocol named http under the iana-l4 engine ID) matches the criteria of a URL-based application, the traffic is classified as that protocol. The device interface statistics are collected by regularly (once a minute) polling the ifTable statistics of all interfaces on the managed device.

A URL-based application can be used the same way as any other application. For example, a URL-based application can be used in collections, captures, and reports.

An incoming URL is matched against the criteria of the configured URL-based applications in the order of the selector in ascending order. When a match is found, the remaining URL-based applications are not considered.

A URL consists of the following parts:
- a host (host.domain.com)
- a path (dir_nam/dir_name)
- an argument/content type

Tip
Content-type argument should rarely be used in combination with the other two fields. It can be used alone, for example to identify WAP traffic you could define an application with a content type of *wap.*. In almost all other cases, we recommend you use host and path only.

Example—Creating an URL-Based Application

This example provides steps on how to create a URL to allow you to control the displayed traffic data. For example, the URL `www.cisco.com/go/nam` are broken down when sent to the web server into two fields: a host field (`www.cisco.com`) and a path field (`/go/nam`). By defining different values for the fields in the application, you can control the granularity of URLs that are classified as this new application. If you want to group all traffic to `www.cisco.com` together and only define the host part, then use the host only part. If you have multiple hosts that map to the same end resource and only want to define the path part., then use only the path entry (`go/nam`).

To collect traffic for a particular host and path for the URL `http://cisco.com/go/nam` enter:
- the host part is `host.domain.com`, for example, `Cisco.com`
- the path part is `/go/nam`
- the argument part is `null/empty`

In the configuration of an URL-based application, the path part and the argument path are combined and called the path part. For detailed descriptions, see Table D-31.

Note
The host, path, and argument parts of a URL are matched against the corresponding POSIX regular expressions specified in the application definition. For details on regular expression syntax, refer to the IEEE Std.
Configuring Application Groups

An application group is a set of applications that can be monitored as a whole. The following topics help you set up and manage the application group:

- Creating an Application Group, page 6-59
- Editing or Deleting an Application Group, page 6-59
- Deleting an Application Group, page 6-59

Creating an Application Group

To create an application group:

**Step 1** Choose Setup > Classification > Application Groups.

   The Application Groups window displays.

**Step 2** Click Create and enter the name in the Application Group Name field.

**Step 3** Use the next Application field and the Filter button to narrow the list of selectable applications. For example, if you enter bittorrent, all applications with that name appear in the list below.

**Step 4** Select an application and click Add. Applications appear in the Selected Applications box. You can select multiple applications at once by using the Shift button, and then click Add.

**Step 5** Click Submit to save your changes.

Editing or Deleting an Application Group

To edit or delete an application group:

**Step 1** Choose Setup > Classification > Application Groups.

**Step 2** Select the Application Group by clicking the radio button, then click Edit or Delete.

**Note** You can only delete one application group at a time.

Deleting an Application Group

To delete an application group, simply select the application and then click the Delete button.
Filtering Encapsulations

Using encapsulation gives you increased flexibility when trying to view different types of application traffic (such as counting or grouping). The encapsulation settings affect how traffic of certain IP-based tunneling protocols are treated.

You can use this software to set up the way you want to view different types of encapsulations in network traffic for the following protocols:

- CAPWAP Data—Control And Provisioning of Wireless Access Points
- ERSPAN—Encapsulated Remote Switched Port Analyzer
- FabricPath
- GRE—IP over GRE tunneling (Generic Routing Encapsulation)
- GTP—GPRS (General Packet Radio Service) Tunneling Protocol
- IP.IP4—IP4 over IP4/IP6
- IP.IP6—IP6 over IP6
- IPESP—IP with Encapsulating Security Payload
- L2TP Data—Layer 2 Tunneling Protocol
- LISP Data—Locator/ID Separation Protocol
- LWAP Data—Lightweight Access Point Protocol
- MPLS—Multiprotocol Label Switching
- OTV—Overlay Transport Virtualization
- PPPoE—Point to Point Protocol over Ethernet
- Segment ID—Rule to match one or more fields with a regular expression.
- SGT—Security Group Tag
- VNTAG—Virtual Network Tag
- VxLAN—Virtual Extensible LAN

To filter encapsulations:

**Step 1** Select **Analyze > Traffic > Encapsulation**.

**Step 2** From the Interactive Report pane, click **Filter** to display the filter options.

**Step 3** Use the available options to select filtering for the encapsulation traffic reports. Unavailable options will be grayed out.

**Step 4** Enter whether you want to include filtering on the site and specify the data source.

**Step 5** Select encapsulation options to filter on including the time range.

**Step 6** If you add a filter name, the filter is saved below the Interactive Report pane for reuse.

**Step 7** Click **Submit** to run the filter and update the Encapsulation Traffic graphs and Top N dashboards based on your filter settings.

If you want to revert to the previous settings since your last submission, click **Reset**.
Setting Up Prime NAM Monitoring

This section discusses how to set up monitoring over and above the default monitoring parameters. You can customize these monitoring parameters.

To set up Prime NAM monitoring perform these tasks:

- Setting Aggregation Intervals, page 6-61
- Configuring Response Time, page 6-62
- Setting Up Media Monitoring, page 6-63
- Creating RTP Filters, page 6-64
- Configuring URL Collections, page 6-64
- Configuring WAAS Monitored Servers, page 6-66

Setting Aggregation Intervals

Prime NAM has short-term and long-term aggregation intervals (this was referred to as long-term reporting in earlier NAM releases). Aggregated data is displayed in the dashboards if the query is longer than one day.

The purpose of gathering short term aggregation interval data is for troubleshooting. It has a finer granularity than long term data (by default, the short term aggregation interval for Traffic/Media is one minute, and short term response time interval is five minutes).

The purpose of gathering long term interval data is for trending analysis. The smallest aggregation interval for long term data is one hour (60 minutes).

Caution
If you modify the aggregation intervals, existing collected data that is not in the same aggregation interval will be completely removed. Data will then start being collected from the beginning again at the moment the intervals are modified and applied.

Traffic and Media refer to applications, hosts, RTP streams, and voice calls monitoring. Response Time refers only to application response time. Prime NAM does not support long term aggregations of data for the following media: conversations, RTP streams, and voice signaling calls monitoring.

To set up aggregation intervals:

1. Choose Setup > Monitoring > Aggregation Intervals.
2. Choose the desired durations for Short Term Interval and Long Term Interval.
3. Check the Collect only hosts from user-defined sites (exclude hosts from Unassigned site) check box if you want the Prime NAM long term data to contain information only for hosts classified to the user-defined sites. This check box only applies to the long term data; short term always collects all hosts.

Note
Enabling the “Collect only hosts from user-define sites” option can significantly speed up report queries, because it excludes unclassified hosts’ statistics from the database.
When you first start the NAM, in monitoring windows that show site information, you will see a site named “Unassigned” and with a description of “Unclassified Hosts.” The Unassigned site includes any that do not match the site configurations. By default, long-term storage will include data for all sites, including the Unassigned site. In some cases, you may not want to view long term data of hosts that are not in your network, in which case you would check the check box.

**Step 4** Click Submit.

The aggregation intervals determine how much data can be stored in the Prime NAM database. See Table 6-5 for information about short and long-term data retention. This calculation is based on a worst case scenario where tables are full or almost full. It is based on recommended database sizes.

### Configuring Response Time

To configure the timing parameters for response time data collections:

**Step 1** Choose **Setup > Monitoring > Response Time**.

The Response Time Configuration page displays. The settings you make on this window comprise the time distribution in microseconds for the detailed Response Time data collection.

**Step 2** Check the Enable Response Time Monitor check box.

**Step 3** After Monitored Server Filter, you will see Disabled or Enabled. If a WAAS server has been configured under Setup > Monitoring > WAAS Servers, you will see Enabled. Click Configure Filter to configure a filter if you need to enable your monitor server filter.

**Step 4** Enter the Response Time values as described in Table D-30.

**Step 5** Accept the default settings or change the settings to the values you want to monitor. Click Submit to save your changes.

<table>
<thead>
<tr>
<th></th>
<th>Short-Term Aggregated Data (Normal)</th>
<th>Short-Term Aggregated Data (Minimum)</th>
<th>Long-Term Aggregated Data (Normal)¹</th>
<th>Long-Term Aggregated Data (Minimum)</th>
</tr>
</thead>
<tbody>
<tr>
<td>All supported platforms</td>
<td>72 hours</td>
<td>14 hours</td>
<td>100 days (with default polling interval)</td>
<td>30 days (with default polling interval)</td>
</tr>
</tbody>
</table>

1. Can depend on how the user configures the LT polling interval. The more frequent polling, the shorter the duration.
Setting Up Media Monitoring

This section covers the following topics:

- Setting up Voice Monitoring
- Setting up Video Monitoring

Setting up Voice Monitoring

You can use the Mean Opinion Score (MOS) to quantify the perceived level of quality you are receiving in your network voice traffic. This allows you to assess the work of codes, or algorithms, which compress audio traffic to save on bandwidth utilization but may result in a drop in quality.

After you set up the software to monitor voice data, you will be able to view the collected voice data under **Analyze > Media**. For more information on viewing the voice data, see **Analyzing Media**, page 2-32.

**Note**

Voice monitoring features are supported with Cisco IP telephony devices only.

To set up voice monitoring:

**Step 1** Choose **Setup > Monitoring > Media**.

The Media Monitoring page displays.

**Step 2** Check the **Enable Call Signal Monitoring** check box.

**Step 3** Accept the default MOS Score value range or modify the values as you prefer. See **Table D-30**.

**Note**

To report jitter and packet loss for the SCCP protocol, you must enable CDR on Cisco Unified Communications Manager. For more information on Cisco Unified Communications Manager, see the Cisco Unified Communications Manager documentation.


**Step 4** Click **Submit** to save your changes, or click **Reset** to cancel and revert to the previous settings.

Setting up Video Monitoring

You can use the Media Delivery Index (MDI) to quantify the perceived level of quality you are receiving in your network video traffic. This allows you to assess the work of codecs, or algorithms, which compresses audio traffic to save bandwidth utilization but may result in a drop in quality. After you set up the software to monitor video conversation data, you will be able to view the collected video stream data under **Analyze > Media**.

To set up video monitoring:

**Step 1** Choose **Setup > Monitoring > Media**.

The Media Monitoring page displays.

**Step 2** Check the **Enable Video Signal Monitoring** check box.

**Step 3** Accept the default MDI quality range or modify the values as you prefer. See **Table D-30**.
Step 4  Accept the default codec streams quality range or modify the values as you prefer.

Step 5  Click **Submit** to save your changes, or click **Reset** to cancel and revert to the previous settings.

---

**Note**

You can enable the video signaling monitoring only when voice signaling monitoring is enabled, and when you disable voice signaling monitoring, video signaling monitoring also gets disabled.

---

### Creating RTP Filters

When the software is initially started, RTP stream traffic will automatically start being monitored. Prime NAM enables you to monitor all RTP stream traffic among all SPAN traffic, without having to know the signaling traffic used in negotiating the RTP channels. RTP Stream Monitoring is enabled by default under **Setup > Monitoring > RTP Filter**. To disable it, uncheck the **Enable RTP Stream Monitoring** check box and click **Submit** to apply the change.

To create an RTP filter:

- Step 1  Choose **Setup > Monitoring > RTP Filter**.
- Step 2  Click **Create**.
- Step 3  From the drop-down menu, choose the protocol (IP or IPv6).
- Step 4  Enter the Source Address, Source Mask, Destination Address, and Destination Mask.
- Step 5  Click **OK**.

### Configuring URL Collections

The URL collection listens to traffic on TCP port 80 of a selected data source and collects URLs. Any protocol which has its master port set to TCP port 80 can be used for URL collections. URL collection can be enabled on multiple data sources such as Data Port(s), CEF Data Port(s) and ERSPAN.

A URL, for example: `http://host.domain.com/intro?id=123`, consists of a host part (`host.domain.com`), a path part (`intro`), and an arguments part (`?id=123`).

**Note**

Since the argument is matched against a regular expression, a literal `?id=123` is not a valid regular expression. The `?` needs to be escaped with a backslash character, `\`, so the actual regular expression needed is `\?id=123`.

The collection can be configured to collect all parts or it can configured to collect only some of the parts and ignore others.

This section contains the following procedures:

- **Enabling a URL Collection**
- **Changing a URL Collection**
- **Disabling a URL Collection**
Enabling a URL Collection

To enable a URL collection:

**Step 1**  Choose Setup > Monitoring > URL.

**Step 2**  Provide the information described in Table D-31.

You can enter a partial name of a data source and click Filter to find data sources that match. Choose Clear to return to the entire list of data sources.

**Note**  Depending on which radio button option is collected, the format of the URL varies. For example, the leading http part is only present if the host part is collected. Keep this variable in mind, when configuring a match only expression.

**Step 3**  Check the Recycle Entries check box to recycle entries.

**Step 4**  Select the check box for one of the following:

- Collect complete URL (Host, Path and Arguments)—You might use this if you are a network security engineer and suspect a virus infection may be caused by a website. This information could be used to identify which web page has the virus embedded and how it may have spread. It can also be shared for further analysis to help create a solution to stop the spread.
- Collect Host only (ignore Path and Arguments)—You might use this if your network administrator changed your firewall policies to block certain hosts.
- Collect Host and Path (ignore Arguments)
- Collect Path and Arguments (ignore Host)
- Collect Path only (ignore Host and Arguments)

**Step 5**  Click Submit to save your changes, or click Reset to cancel.

Changing a URL Collection

To change a URL collection:

**Step 1**  Choose Setup > Monitoring > URL.

**Step 2**  Change the URL Collection Configuration field information as described in Table D-31.

**Note**  Changing any parameters and applying the changes flushes the collected URLs and restarts the collection process.

**Step 3**  Click Submit to save your changes, or click Reset to cancel.
Disabling a URL Collection

When you disable URL collection monitoring, all collection stops immediately and any collection that was in progress is deleted.

To disable a URL collection:

1. Choose Setup > Monitoring > URL.
2. Uncheck the Enable check box.
3. Click Submit.

Configuring WAAS Monitored Servers

WAAS monitored servers specify the servers from which WAAS devices export traffic flow data to the Prime NAM monitors. To enable WAAS monitoring, you must list the servers to be monitored by Prime NAM using the WAAS device's flow monitoring.

You must configure WAAS monitored servers to enable Prime NAM to monitor WAAS traffic. Prime NAM displays status of WAAS devices as pending until you set up WAAS monitored servers.

To configure a WAAS monitored server:

2. Check the Filter Response Time for all Data Sources by Monitored Servers check box if you want Prime NAM to compute response time data only for the servers from this list for all data sources, including non-WAAS data sources. All other servers will be ignored in response time monitoring views. This enables you to reduce Prime NAM workload and to improve its overall performance.
3. Click Add and enter the server IP address in the Server Address field. You can paste multiple IP addresses here as well.

Tip

Specify the WAAS monitored servers from which WAAS devices export traffic flow data to the Prime NAM monitors. Do not use the WAE device IP address.

4. Click Submit.
Understanding Prime NAM Traffic Sources

Before you can monitor data using Prime NAM software, you must direct specific traffic flowing through a switch or router to the Prime NAM. This appendix explains the various data sources that you can configure for Prime NAM.

This appendix contains the following topics:

- Data Source Overview, page A-1
- Understanding How the Prime NAM Uses SPAN, page A-3
- Understanding How the Prime NAM Uses VACLs in Catalyst Switch, page A-5
- Configuring ACL Capture on Nexus 7000 Series, page A-6
- Understanding How the Prime NAM Uses NetFlow, page A-7
- Understanding How the Prime NAM Uses WAAS, page A-9
- Understanding How the Prime NAM uses CEF, page A-9

For details on supported data sources, see the NAM Compatibility Matrix.

Data Source Overview

Prime NAM uses various data sources to deliver its performance troubleshooting functionality:

To understand which methods to use to direct specific traffic to the Prime NAM software, see Table A-1.

<table>
<thead>
<tr>
<th>Method</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch SPAN¹</td>
<td>You can direct a set of physical ports, a set of VLANs, or a set of EtherChannels to the NAM.</td>
</tr>
<tr>
<td></td>
<td>Selecting an EtherChannel as a SPAN source is the same as selecting all physical ports comprising the EtherChannel as the SPAN source.</td>
</tr>
<tr>
<td></td>
<td>On some NAM platforms, using SPAN allows for NAM configuration without having to use the switch.</td>
</tr>
<tr>
<td></td>
<td>Forwarding SPAN Traffic, page 6-6.</td>
</tr>
<tr>
<td>Switch Remote SPAN (RSPAN)¹</td>
<td>You can monitor packet streams from remote switches, assuming that all traffic from a remote switch arrives at the local switch on a designated RSPAN VLAN. Use the RSPAN VLAN as the SPAN source for the NAM.</td>
</tr>
</tbody>
</table>
Data Source Overview

The Data Sources page (Setup > Traffic > NAM Data Sources) lists the data sources configured for your NAM. Table D-2 describes the fields in the NAM Data Sources window.

Table A-2 summarizes the traffic sources that are used for Prime NAM monitoring.

### Table A-1 Methods of Directing Traffic (continued)

<table>
<thead>
<tr>
<th>Method</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Encapsulated Remote Switched Port Analyzer (ERSPAN)</strong>&lt;sup&gt;1&lt;/sup&gt;</td>
<td>You can monitor traffic on one or more ports, or one or more VLANs, and send the monitored traffic to one or more destination ports using ERSPAN. ERSPAN sends traffic to a network analyzer such as a SwitchProbe device or other Remote Monitoring (RMON) probe. ERSPAN supports source ports, source VLANs, and destination ports on different routers or switches, which provides remote monitoring of multiple routers or switches across your network. See Forwarding ERSPAN Traffic, page 6-7.</td>
</tr>
<tr>
<td><strong>NetFlow Data Export (NDE)</strong></td>
<td>Prime NAM analyzes NetFlow from Managed Devices (Routers/Switches). You can monitor NetFlow records directly from remote switches or routers. You must configure the NetFlow packet source to the NAM from a local switch or remote router using the device CLI. For received NetFlow traffic, a default site will be created including all interfaces from that device. See Configuring Sites, page 6-47. <strong>Note:</strong> SPAN and NetFlow sources can be in effect simultaneously. See Forwarding NetFlow Traffic, page 6-16.</td>
</tr>
<tr>
<td><strong>WAAS</strong></td>
<td>You can access Prime NAM from within the Central Manager interface. Prime NAM integration with WAAS Central Manager provides for easier viewing of Prime NAM reports that are directly associated with Application Response Time measurements through the WAN, in both WAAS optimized and non-optimized environments. See Configuring WAAS Monitored Servers, page 6-66.</td>
</tr>
<tr>
<td><strong>SNMP</strong></td>
<td>Used as a southbound interface for configuration and data retrieval from switches and routers. Prime NAM uses web services as the northbound interface for data objects. The software continues to support baseline manageability features of SNMP such as MIB-2 and IF-TABLE for the NAM, and the health status and interface statistics that can be used by external products like Fault and Configuration Management offerings (for example, CiscoWorks LMS and Prime Infrastructure).</td>
</tr>
<tr>
<td><strong>Network Tap Device</strong></td>
<td>Applies to NAM appliances only. For details, see your appliance installation guide.</td>
</tr>
<tr>
<td><strong>CEF</strong></td>
<td>You can enable CEF traffic monitoring on one or more ports and send the monitored CEF traffic to an UCSE NAM. See Understanding How the Prime NAM Uses VACLs in Catalyst Switch, page A-5</td>
</tr>
</tbody>
</table>

---

<sup>1</sup>Prime NAM can analyze Ethernet VLAN traffic from the following sources: Ethernet, Fast Ethernet, Gigabit Ethernet, trunk port, or Fast EtherChannel SPAN, RSPAN, or ERSPAN source port.

---

The Data Sources page (Setup > Traffic > NAM Data Sources) lists the data sources configured for your NAM. Table D-2 describes the fields in the NAM Data Sources window.

Table A-2 summarizes the traffic sources that are used for Prime NAM monitoring.
Ports and Hardware Details

NAM-3 and NAM-NX1 each have two dataports. Each dataport can accept one SPAN session. Depending on the managed device operating system (OS) version, the number of SPAN sessions allowed may vary. Most IOS versions support two SPAN sessions. Nexus OS may support more than two SPAN sessions.

Depending on the IOS running on the Supervisor, port names are displayed differently. Newer versions of IOS software display a port name as Gi2/1 to represent a Gigabit port on module 2 port 1. In the VSS, a port name might be displayed as Gi1/2/1 to represent a Gigabit port on switch 1, module2, port 1. On NAM-NX1, a port name might be displayed at Ethernet1/1/1.

On NAM hardware, one of the two interfaces must be selected as the Prime NAM management port for IP traffic (such as HTTP and SNMP). Prime NAM can monitor traffic for analysis on the internal interface, the external interface, or both simultaneously. A typical configuration is to monitor LAN and WAN traffic on the internal interface. However, the external interface can be used to monitor LAN traffic.

Some Cisco switches do not support SNMP MIB objects that are required by NAM when configuring SPAN sessions. On these switches, you can use the switch device CLI command to configure the SPAN session for NAM. Alternatively, for the NAM appliances only, if the NAM managed device supports NetConf interface over SSH, you can configure the NAM to use NetConf to configure SPAN sessions on the managed device.

Understanding How the Prime NAM Uses SPAN

A switched port analyzer (SPAN) session is an association of a destination port with a set of source ports, configured with parameters that specify the monitored network traffic. You can configure up to two SPAN sessions in a Catalyst 6500 chassis. Newer Cisco IOS images may support more than two SPAN sessions. Consult the Cisco IOS document for the number of SPAN sessions supported per switch or router.

Table A-3 describes the types of SPAN sources and the possible ways to configure them.
Understanding How the Prime NAM Uses SPAN

Table A-3  SPAN Sources

<table>
<thead>
<tr>
<th>SPAN Source</th>
<th>Configured with one of the following:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Any set of physical ports</td>
<td>• Prime NAM (the GUI)</td>
</tr>
<tr>
<td></td>
<td>• Switch CLI</td>
</tr>
<tr>
<td>Any EtherChannel</td>
<td>• Prime NAM (the GUI)</td>
</tr>
<tr>
<td></td>
<td>• Switch CLI</td>
</tr>
<tr>
<td>Any set of VLANs configured on the local switch</td>
<td>• Prime NAM (the GUI)</td>
</tr>
<tr>
<td></td>
<td>• Switch CLI</td>
</tr>
</tbody>
</table>

1. See the NAM Compatibility Matrix for detailed list of NAM devices that can be configured using the GUI.

See Table D-3 for a description of the fields on the SPAN Sessions window.

Table A-4 lists the possible SPAN states. The SPAN state displays in parenthesis in the Source - Direction column.

Table A-4  Possible SPAN States

<table>
<thead>
<tr>
<th>State</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Active</td>
<td>SPAN source is valid and packet traffic from the source is copied to the SPAN destination (NAM Dataport).</td>
</tr>
<tr>
<td>Inactive</td>
<td>Packet traffic from the source is not copied to the SPAN destination (NAM Dataport).</td>
</tr>
<tr>
<td>Up</td>
<td>For NAM-NX1 only, the Supervisor displays this when packets are forwarded to the NAM.</td>
</tr>
<tr>
<td>Down</td>
<td>For NAM-NX1 only, the Supervisor displays this when packets are not forwarding to the NAM.</td>
</tr>
</tbody>
</table>

The NAM-3 platform provides two possible destination ports for SPAN and VLAN access control list (VACL) sessions. Multiple SPAN sessions to the Prime NAM are supported, but they must be destined for different ports. The Prime NAM destination ports for use by the SPAN graphical user interface (GUI) are named DATA PORT 1 and DATA PORT 2 by default. In the CLI, NAM-3 SPAN port is named dataport1 and dataport2.

For more information about SPAN and how to configure it on the various NAM platforms, see your device documentation on Cisco.com.

Note

Due to potentially very high volume of ERSPAN traffic from the source, we recommend that you do not terminate the ERSPAN session on the NAM management port. Instead, you should terminate ERSPAN on the switch, and use the switch’s SPAN feature to SPAN the traffic to NAM dataports.
A VLAN access control list can forward traffic from either a WAN interface or VLANs to a dataport on the NAM. A VACL provides an alternative to using SPAN; a VACL can provide access control based on Layer 3 addresses for IP and IPX protocols. The unsupported protocols are access controlled through the MAC addresses. A MAC VACL cannot be used to access control IP or IPX addresses.

There are two types of VACLs: one that captures all bridged or routed VLAN packets and another that captures a selected subset of all bridged or routed VLAN packets. Catalyst operating system VACLs can only be used to capture VLAN packets because they are initially routed or bridged into the VLAN on the switch.

A VACL can provide access control for all packets that are bridged within a VLAN or that are routed into or out of a VLAN or, with Release 12.1(13)E or later releases, a WAN interface. Unlike regular Cisco IOS standard or extended ACLs that are configured on router interfaces only and are applied on routed packets only, the VACLs apply to all packets and can be applied to any VLAN or WAN interface. The VACLs are processed in the hardware.

A VACL uses Cisco IOS access control lists (ACLs). A VACL ignores any Cisco IOS ACL fields that are not supported in the hardware. Standard and extended Cisco IOS ACLs are used to classify packets. Classified packets can be subject to a number of features, such as access control (security), encryption, and policy-based routing. Standard and extended Cisco IOS ACLs are only configured on router interfaces and applied on routed packets.

After a VACL is configured on a VLAN, all packets (routed or bridged) entering the VLAN are checked against the VACL. Packets can either enter the VLAN through a switch port or through a router port after being routed. Unlike Cisco IOS ACLs, the VACLs are not defined by direction (input or output).

A VACL contains an ordered list of access control entries (ACEs). Each ACE contains a number of fields that are matched against the contents of a packet. Each field can have an associated bit mask to indicate which bits are relevant. Each ACE is associated with an action that describes what the system should do with the packet when a match occurs. The action is feature dependent. Catalyst 6500 series switches and Cisco 7600 series routers support three types of ACEs in the hardware: IP, IPX, and MAC-Layer traffic. The VACLs that are applied to WAN interfaces support only IP traffic.

When you configure a VACL and apply it to a VLAN, all packets entering the VLAN are checked against the VACL. If you apply a VACL to the VLAN and an ACL to a routed interface in the VLAN, a packet coming into the VLAN is first checked against the VACL and, if permitted, is then checked against the input ACL before it is handled by the routed interface. When the packet is routed to another VLAN, it is first checked against the output ACL applied to the routed interface and, if permitted, the VACL configured for the destination VLAN is applied. If a VACL is configured for a packet type and a packet of that type does not match the VACL, the default action is deny.

When configuring VACLs, note the following:

- VACLs and context-based access control (CBAC) cannot be configured on the same interface.
- TCP Intercepts and Reflexive ACLs take precedence over a VACL action on the same interface.
- Internet Group Management Protocol (IGMP) packets are not checked against VACLs.

**Note**

You cannot set up VACL using the Prime NAM interface.
For details on how to configure a VACL with Cisco IOS software, see Cisco.com. For details on how to configure a VACL on a WAN interface and on a LAN VLAN, see Forwarding VACL Traffic, page 6-14.

## Configuring ACL Capture on Nexus 7000 Series

Nexus ACL capture allows you to capture IP ACL, PORT ACL, MAC ACL and VLAN ACL. You can configure an ACL capture in order to selectively monitor traffic on an interface or VLAN. When you enable the capture option for an ACL rule, packets that match this rule are either forwarded or dropped based on the specified permit or deny action and will also be copied to an alternate destination port for further analysis.

To configure VACL capture to NAM-NX1 port-channel, all configurations are done on Nexus 7000 switches, and configuration is not required on NAM.

For detailed configuration, refer section Configuring VLAN ACLs in Cisco Nexus 7000 Series NX-OS Configuration Guide.

A simple configuration example on Nexus 7000 device is given below:

```plaintext
----
enable acl capture in default vdc, this CLI disable acl logging automatically
hardware access-list capture

ip access-list tcpany
  10 permit tcp any any capture session 1

ip access-list udpany
  20 permit udp any any capture session 3

vlan access-map tcp-map 10
  match ip address tcpany
  action forward
  statistics per-entry

vlan access-map udp-map 20
  match ip address acl-02
  action forward
  statistics per-entry

---- apply access-map to appropriate vlans
vlan filter tcp-map vlan-list 55-65
vlan filter udp-map vlan-list 58

---- config acl intf 4/23
interface Ethernet4/23
  ip port access-group tcpany ingress

---- To filter udp at ingress interface, change intf 4/23 as below:
interface Ethernet4/23
```

---

For more information, see the configuration guide for Nexus 7000 Series switches.
ip port access-group udpany ingress

----
config monitor session
monitor session 1 type acl-capture
destination analysis module 3 data-port 1
no shut

See Nexus 7000 ACL Capture/ VACL Support & Limitations FAQ for details.

Understanding How the Prime NAM Uses NetFlow

The Prime NAM uses NetFlow as a format for the ongoing streaming of aggregated data, based on the configured set of descriptors or queries of the data attributes in NAM. NetFlow Data Export (NetFlow) is a remote device that allows you to monitor port traffic on the NAM; the Prime NAM can collect NetFlow from local or remote switches or routers for traffic analysis.

To use an NetFlow data source for the Prime NAM, you must configure the remote device to export the NetFlow packets. The default UDP port is 3000, but you can configure it from the Prime NAM CLI as follows:

root@nam3-61.cisco.com# netflow input port ?
<port> - input NetFlow port number

The distinguishing feature of the NetFlow v9 format, which is the basis for an IETF standard, is that it is template-based. Templates provide an extensible design to the record format, a feature that must allow future enhancements to NetFlow services without requiring concurrent changes to the basic flow-record format.

For more detailed information about Prime NAM and NetFlow, see Forwarding NetFlow Traffic, page 6-16.

For specific information about creating and managing NetFlow queries, see the Cisco Network Analysis Module API Programmer’s Guide (contact your Cisco account representative if you need to refer to this document).

Understanding NetFlow Interfaces

To use a device as an NetFlow packet data source for the Prime NAM, you must configure the device itself to export NetFlow packets to UDP port 3000 on the NAM. You might need to configure the device itself on a per-interface basis. A NetFlow packet device is identified by its IP address. In the NAM, the default UDP port of 3000 can be changed with a Prime NAM CLI command (see Configuring NetFlow on Devices, page 6-16).

You can define additional NetFlow packet devices by specifying the IP addresses and (optionally) the community strings. Community strings are used to upload convenient text strings for interfaces on the managed devices that are monitored in NetFlow records.

Remote NetFlow packet devices may export information pertaining to any or all of their individual interfaces. The Prime NAM keeps track of the interface associated with any flow information received from the device. On the NDE Interface Analysis page (Analyze > Traffic > NDE Interface), you can view information for any selected interface on the device. This page will display the interface utilization or throughput over time, as well as show the top Applications, Hosts, and DSCP groups in both the input and output directions for the interface.
Understanding NetFlow Flow Records

A NetFlow packet contains multiple flow records. Each flow record has two fields:

- Input SNMP ifIndex
- Output SNMP ifIndex

Note

This information might not be available because of NetFlow feature incompatibility with your Cisco IOS version, or because of a NetFlow flow-mask configuration.

In most cases, turning on NetFlow on an interface populates the NetFlow cache in the device with flows that are in the input direction of the interface. As a result, the input SNMP ifIndex field in the flow record has the ifIndex of the interface on which NetFlow was turned on. Sample NetFlow Network, Figure A-1, shows a sample network configuration with a NetFlow router.

Figure A-1  Sample NetFlow Network

![Sample NetFlow Network Diagram]

Table A-5 lists the reported flows if NetFlow is enabled on interface a.

Table A-5  Reporting Flow Records

<table>
<thead>
<tr>
<th>Input Interface</th>
<th>Output Interface</th>
<th>Are Flows Reported?</th>
</tr>
</thead>
<tbody>
<tr>
<td>a</td>
<td>b</td>
<td>Yes</td>
</tr>
<tr>
<td>a</td>
<td>c</td>
<td>Yes</td>
</tr>
<tr>
<td>b</td>
<td>c</td>
<td>No</td>
</tr>
<tr>
<td>b</td>
<td>a</td>
<td>No</td>
</tr>
<tr>
<td>c</td>
<td>a</td>
<td>No</td>
</tr>
<tr>
<td>c</td>
<td>b</td>
<td>No</td>
</tr>
</tbody>
</table>

Managing NetFlow Data Sources

A data source entry must exist on Prime NAM in order for it to accept NetFlow records from an external device. Data source entries may be created manually using the Prime NAM web GUI or the CLI. When manually creating a data source, you may specify any name you want for the data source.
For convenience, manual creation of NetFlow data sources is not necessary. There is an “autocreate” feature which is enabled by default. With the autocreate feature, a new data source will automatically be created for each device which sends NetFlow packet traffic to the Prime NAM when the first packet is received.

Autocreated NetFlow data sources will be assigned a name in the format NetFlow-<IP Address>-ID-<Integer>, where <IP Address> is the IP address of the exporting device, and <Integer> is the Engine-ID that the device populates in the packets (part of the NetFlow Data Export standard). An example might be “NetFlow-10.10.0.1-ID-12” for device 10.10.0.1 sending NetFlow packets with the Engine ID field set to 12. You can edit these autocreated data sources and change the name if you want to, as well as optionally specifying SNMP credentials for the device, as described later in this guide.

Understanding How the Prime NAM Uses WAAS

Cisco Wide Area Application Services (WAAS) software optimizes the performance of TCP-based applications operating in a wide area network (WAN) environment and preserves and strengthens branch security. The WAAS solution consists of a set of devices called Wide Area Application Engines (WAEs) that work together to optimize WAN traffic over your network.

When client and server applications attempt to communicate with each other, the network devices intercepts and redirects this traffic to the WAES to act on behalf of the client application and the destination server.

WAES provide information about packet streams traversing through both LAN and WAN interfaces of WAAS WAES. Traffic of interest can include specific servers and types of transaction being exported. Prime NAM processes the data exported from the WAAS and performs application response time and other metrics calculations and enters the data into reports you set up.

The WAES examine the traffic and using built-in application policies to determine whether to optimize the traffic or allow it to pass through your network not optimized.

You can use the WAAS Central Manager GUI to centrally configure and monitor the WAES and application policies in your network. You can also use the WAAS Central Manager GUI to create new application policies so that the WAAS system will optimize custom applications and less common applications. Prime NAM is accessible from within the Central Manager interface. The Cisco Prime NAM integration with WAAS Central Manager provides for easier viewing of Prime NAM reports that are directly associated with Application Response Time measurements through the WAN, in both WAAS optimized and non-optimized environments. See Using the WAAS Central Manager, page 6-25.

For more information about WAAS data sources and managing WAAS devices, see Understanding WAAS, page 6-23.

Understanding How the Prime NAM uses CEF

NAM uses CEF to monitor all IP traffic on a router interface. For Cisco 2900 Series or Cisco 3900 Series Integrated Services Router Generation 2 (Cisco ISR G2) support Prime NAM, you can configure to monitor CEF traffic on many data ports to copy and forward all IP traffic to NAM monitoring interface on a Cisco ISR G2.

The Cisco Unified Computing Server type E (Cisco UCSE) can host Prime NAM and other services. See UCSE product introduction for more details:

For the list of router platforms and IOS releases support UCSE, see section “Verifying Compatibility” in *Getting Started Guide for Cisco UCS E-Series Servers and the Cisco UCS E-Series Network Compute Engine*.

**Understanding UCSE Physical Interfaces**

Internal PCIE/MGF ports are named as GE0/GE1 and the front panel ports are named as GE2/GE3. In CIMC GUI, PCIE/MGF ports are named as GE1/GE2 and front panel ports are named as GE3/GE4.
Configuring NAM Security

The Cisco Prime NAM software provides a number of security features with user-customizable parameters. This appendix provides an overview of the security features, and describes the parameters that can be customized.

This section consists of the following security features:

- Idle Timeout, page B-1
- SSL/TLS Security, page B-1
- SSH Security, page B-4

**Idle Timeout**

To prevent unauthorized access to the NAM GUI or CLI, an idle/inactivity timeout is supported.

On the CLI, the idle timeout is disabled by default. An idle timeout can be configured using the following command:

```
cli idle-timeout <timeout-in-seconds>
```

The CLI idle timeout can be disabled using the `no cli idle-timeout` command.

**SSL/TLS Security**

The NAM GUI supports HTTPS for secured connections. The HTTPS server can be enabled using the following command:

```
ip http secure server enable
```

**Configuring a Self-Signed Certificate**

NAM is configured with a built-in self-signed certificate, by default. If you intend to continue using a self-signed certificate, we recommend that you generate a unique self-signed certificate using the following command:

```
ip http secure generate self-signed-certificate [lifetime-in-days]
```
SSL/TLS Security

The lifetime defaults to 730 days (2 years), but you can specify a different lifetime, if desired. This command will prompt you for organizational details that are customarily included in SSL/TLS certificates to help identify the server. You must ensure that the "Common Name" field matches whatever name you use to access your NAM, as this is the field a web browser uses to verify that an SSL/TLS certificate properly matches the host that is presenting it.

- If you access the NAM through an IP address (For example, https://10.0.0.10/, enter just the IP address "10.0.0.10").
- If you access the NAM through a hostname (For example, https://nam.cisco.com/, enter just the hostname "nam.cisco.com").

The first time you connect to the NAM using a particular web browser, it must show a warning that the certificate of NAM is untrusted (because it is self-signed, rather than signed by a trusted Certificate Authority). You need to click the warning each time your browser is restarted, unless you save it to your local certificate store. The procedure for saving the certificate depends on your browser and/or operating system.

Note

Ensure that the Common Name of your certificate is set correctly, before saving the certificate.

- Some browsers (such as Mozilla Firefox) maintain their own certificate store, and adding a new certificate is as simple as selecting "Add Exception", and then making sure that the “Permanently store this exception” option is checked.
- Other browsers (such as Microsoft Internet Explorer and Google Chrome) use the operating system’s certificate store. On Windows, one possible procedure is:
  - Run the show certificate command from the NAM CLI and copy the entire certificate text (including the "BEGIN CERTIFICATE" and "END CERTIFICATE" markers) into a .cer file (for example, "nam-cert.cer").
  - Run the "certmgr.msc" program (you may have to enter the Win+R key sequence to access the Run menu). Right-click the "Trusted Root Certification Authorities" item, select All Tasks > Import to start the Certificate Import wizard, and then import the certificate file (for example, "nam-cert.cer").
  - Your browser should now show the NAM as a trusted host. In some cases, you may need to restart the browser to recognize the new certificate.
- For other browsers or operating systems, consult your local documentation.

Configuring a CA-Signed Certificate

For optimal security, it is recommended that the NAM must be configured with a certificate signed by a trusted Certificate Authority (CA). This configuration will avoid the browser warning messages without the hassle of installing a self-signed certificate on each individual machine used to access the NAM. Many larger enterprises have an in-house CA that can sign certificates for internal use. There are also external CAs that can sign a certificate, typically for a fee.

To configure the NAM to use a CA-signed certificate, first issue the following CLI command to generate a certificate request, which will be output to the screen:

```
ip http secure generate certificate-request
```

Copy and paste the text of the certificate request and submit it to the CA for signing. Once the CA-signed certificate is received, use the following CLI command and paste the signed certificate text into the terminal window:
ip http secure install certificate
The NAM will read the text and install the certificate.

Configuring SSL/TLS Parameters

The NAM is configured for a balance between security and usability in the enterprise, by default. However, some users have particular requirements for the SSL/TLS ciphersuites and protocol versions that must be allowed by HTTPS servers on their networks, so the NAM also offers the ability to customize the parameters.

Configuring SSL/TLS Ciphersuites

To configure the ciphersuites that the NAM HTTPS server will accept, use this command:

ssl-tls ciphersuites set <ciphersuite-specification>

This command sets the SSLCipherSuite directive of the Apache web server built into the NAM software. For details about the format of the ciphersuite-specification argument, refer to the following links:

http://httpd.apache.org/docs/2.4/mod/mod_ssl.html#sslcipher
http://www.openssl.org/docs/apps/ciphers.html

To evaluate a ciphersuite-specification argument using the NAM's particular version of OpenSSL, use this command:

ssl-tls ciphersuites eval <ciphersuite-specification>

This command displays the list of ciphersuites that a given ciphersuite-specification represents.

To examine or verify the currently-configured ciphersuite specification, use this command:

show ssl-tls ciphersuites

Configuring SSL/TLS Protocols

To configure the SSL/TLS protocol versions that the NAM HTTPS server will accept, use this command:

ssl-tls protocols set <protocol-directive>

This command sets the SSLProtocol directive of the Apache web server built into the NAM software. For details about the format of the protocol-directive argument, refer to the following link:

http://httpd.apache.org/docs/2.4/mod/mod_ssl.html#sslprotocol

TLS v1.0, v.1.1, and v1.2 are enabled by default, while SSLv2 and SSLv3 are disabled. Note that you must not attempt to enable SSLv2 or SSLv3 protocols, as these versions of SSL have severe security flaws, and the industry as a whole is transitioning towards removing support for these protocols entirely.

For best security, enabling only TLS v1.2 is recommended (for example., ssl-tls protocols set TLSv1.2). However, some older browser versions do not enable support for the more recent versions of TLS, so you may have to visit an advanced settings dialog or similar to enable such TLS versions explicitly. Make sure that enabling the newer TLS versions may expose incompatibilities with other web servers (particularly older versions) that may be running in your environment.
SSH Security

The NAM CLI supports SSH for secured connections. The SSH server can be enabled using the following command:

```
exsession on ssh
```

Configuring SSH Authorized Keys

In addition to logging into the CLI using password, the NAM also supports logins using an SSH private key. To enable this functionality, a list of authorized keys must first be imported using the command:

```
ssh authorized-keys import <user> <key-file-url>
```

where `<user>` is "root" (for password-less CLI access) or a valid web username (for password-less access to capture or report files via SFTP). The format of this file is the standard OpenSSH authorized_keys file described in the "AUTHORIZED_KEYS FILE FORMAT" section in the following URL:

http://www.openbsd.org/cgi-bin/man.cgi?query=sshd&sektion=8

Note that SSH key options, if present, are removed when a key is imported.

The authorized keys for a given user can be displayed using the command:

```
show ssh authorized-keys "checksums" | "file" <user>
```

where `checksums` displays just the checksums (to facilitate comparison with your local copy of the file) and `file` displays the full contents.

Configuring SSH Ciphers and MACs

The NAM is configured for a balance between security and usability in the enterprise, by default. However, some users have particular requirements for the ciphers and MACs that must be allowed by SSH servers on their networks, so the NAM also offers the ability to customize the parameters.

To configure the ciphers that the NAM SSH server will accept, use this command:

```
ssh ciphers set <ciphers-directive>
```

The `ciphers-directive` is simply a comma-separated list of the ciphers to be allowed, in order of preference (highest first).

The NAM is configured to allow only SSH connections using AES CTR mode ciphers, by default. To examine or verify the currently-configured ciphers directive, or to see the list of available cipher options, use this command:

```
show ssh ciphers
```

To configure the MACs that the NAM SSH server will accept, use the following analogous commands:

```
ssh macs set <macs-directive>

show ssh macs
```

The NAM is configured to allow only SSH connections using HMAC-SHA1 and HMAC-RIPEMD160 MACs, by default.
Secure File Transfers

The NAM has many commands that involve transferring files between the NAM and external servers. A few examples of such commands are:

- NAM software image upgrades: `upgrade <image_url>`
- NAM software patch installation: `patch <patch_url>`
- NAM configuration backup to network location: `config upload <url>`
- NAM configuration restore from network location: `config network <url>`

In all these cases, the URL provided is allowed to utilize an insecure plain text protocol like FTP or HTTP, if desired. However, for optimal security, using a secure protocol is recommended. The secure protocols supported by the NAM are:

- SCP (Secure Copy) - relies on SSH for secure transport.
- SFTP (Secure File Transfer Protocol) - relies on SSH for secure transport.
- HTTPS (Hypertext Transfer Protocol Secure) - relies on SSL/TLS for secure transport.

Here are some examples of commands that perform file transfers:

- `upgrade https://files.cisco.com/upgrade_image.bin.gz`
- `patch scp://user:pass@ssh-server.cisco.com/patch.rpm`
- `config upload sftp://user:pass@ssh-server.cisco.com/~`

Protecting Against Man-in-the-Middle Attacks

A man-in-the-middle (MITM) attack is one in which a user unknowingly communicates with an impostor server, either because the impostor is positioned to intercept traffic en route to the legitimate server, or because the legitimate server is offline and the impostor has taken its place. To protect against such attacks, we recommend that the NAM be configured such that it can verify that an external server it is communicating with is legitimate.

SSH Known Hosts

For SSH, the `known_hosts` file is a list of the public keys of SSH servers that the NAM must consider "known" (legitimate). A known_hosts file can be imported using the command:

```
ssh known-hosts import <known-hosts-file-url>
```

The format of this file is the standard OpenSSH known_hosts file described in the "SSH_KNOWN_HOSTS FILE FORMAT" section in the following URL:

http://www.openbsd.org/cgi-bin/man.cgi?query=sshd&sektion=8

After importing a known_hosts file, enable host key verification to ensure that only connections to known hosts are successful (connections to unknown hosts fail with an error message). Host key verification can be enabled using the command:

```
ssh host-key-verification
```
SSL/TLS CA Certificates

For SSL/TLS, the CA certificates file contains the list of Certificate Authority (CA) root certificates that the NAM must trust. This file must contain PEM-formatted X.509 certificates (the format used by the cURL tool). An example of such a file can be found at the following URL:

http://curl.haxx.se/ca/cacert.pem

If you have HTTPS servers with self-signed certificates that the NAM must consider trusted, simply include the self-signed certificate in this file.

A CA certificates file can be imported using the command:

```text
ssl-tls ca-certs import <ca-certs-file-url>
```

After importing CA certificates file, enable CA certificate verification to ensure that only connections to hosts with valid signed certificates are successful (connections to hosts with invalid certificates fail with an error message). The CA certificate verification can be enabled using the command:

```text
ssl-tls cert-verification
```

Software Image Upgrades

For software image upgrades, the `upgrade` command displays MD5 and SHA-512 checksums for the downloaded image file prior to installation. The checksums are useful for ensuring that the image was not corrupted during download, but in the event that the image was downloaded to the NAM without CA certificate or SSH host key verification enabled, the checksums can also be used to verify the authenticity of the image by comparing them to the checksums published on Cisco.com for the given software image.
Understanding Prime NAM Behavior Reference

This appendix includes details on how Cisco Prime Network Analysis Module (Prime NAM) works including how to navigate and use the control elements in the user interface.

This section includes the following topics:

- Menu Bar, page B-2
- Filters, page B-2
- Displaying Detailed Views, page B-3
- Accessing Context Menus, page B-3
- Performing a Quick Capture, page B-4
- Determining How to Use Sites to View Data, page B-4
- Filtering Traffic for Viewing on the Dashboards, page B-4
- Switching Chart Formats Using the Chart View / Table View, page B-5
- Accessing Other Tasks Using Mouse-Over for Details, page B-6
- Changing the Time Interval Using Zoom/Pan Charts, page B-6
- Using Sort Grid to Change Sort Order, page B-6
- Displaying Bits or Bytes or Packets in Charts, page B-7
- Statistics, page B-7
- Context-Sensitive Online Help, page B-7
- Feedback, page B-7

For the location of the release-specific documentation for the command line interface or the application programming interface, see the Cisco Prime NAM Documentation Overview on Cisco.com.
Menu Bar

For a description of common tasks in Prime NAM, see Table B-1.

Table B-1 Summary of Menu Tasks

<table>
<thead>
<tr>
<th>Menu Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Home</td>
<td>Brings you to the Traffic Summary Dashboard (Monitor &gt; Overview &gt; Traffic Summary).</td>
</tr>
<tr>
<td>Monitor</td>
<td>View summary dashboards with network traffic, application performance, site performance, and alarms information at a glance.</td>
</tr>
<tr>
<td>Analyze</td>
<td>See various views for traffic over a time period, WAN optimization, response time, managed device, and media functions.</td>
</tr>
<tr>
<td>Capture</td>
<td>Configure multiple sessions for capturing, filtering, and decoding packet data, manage the data in local or remote storage, and display the contents of the packets.</td>
</tr>
<tr>
<td>Setup</td>
<td>Perform setup options needed to access Prime NAM features.</td>
</tr>
<tr>
<td>Administration</td>
<td>Set dashboard preferences, perform user and system administration tasks, and generate diagnostic information for obtaining technical assistance.</td>
</tr>
</tbody>
</table>

Filters

You can use the Filter feature to display specific information on the Prime NAM interface. The Filter icon is provided wherever the data is displayed in a tabular format. The following types of filters are available:

- **Quick Filter**
- **Advanced Filter**

Quick Filter

This filter allows you to narrow down the data inside a table by applying a filter to a specific table column or columns. To apply different operators, use the Advanced Filter option.

To launch the quick filter, choose **Quick Filter** from the Filter drop-down menu.

To clear the Quick Filter, click the Filter icon.
**Advanced Filter**

This filter allows you to narrow down the data in a table by applying a filter using multiple operators such as Does not contain, Does not equal, Ends with, Is empty, and so on. For example, you can choose the filter pattern by table column names and operator from the drop-down menu. In addition, you must enter filter criteria based on the data available in the Prime NAM database.

To launch advance filtering, choose **Advanced Filter** from the Filter drop-down list.

To clear the Advanced Filter, click the Filter icon.

**Displaying Detailed Views**

You can access additional details from the Dashboard and Monitor and Analyze mega-menus that provide packet and bits per second data as well as identify host, application, DCSP, and other categories. Select a graph element and left-click to view menu options. These may include options titled **Details** or **Detailed Views**. For an example of the Applications submenu see **Figure B-1 on page B-3**.

**Accessing Context Menus**

On most charts that appear on the dashboards (except for pie charts), you can left-click on a colored bar of data to get a context menu, with which you can get more detailed information about that item. See **Figure B-1 on page B-3**.

**Figure B-1  Context Menu Showing Application Submenus**

The example above is from the Response Time Summary Dashboard, Top N Applications by Transaction Time chart. The description to the right of “Selected Application” in the menu shows what item you had clicked on (in this case, *dce-rpc*).

The menu items above the separator line are specific to the selected element of the Top N chart. The items below the separator line are not specific to the selected element, but apply to the Top N chart. The selections with no icons display in the current page. Selections with icons open in a separate page.
Performing a Quick Capture

From the Context menu of many of the bar charts that show Applications or Hosts or VLANs, you can start a Capture. For example, when you click on an Application in a bar chart (as in Figure B-1 on page B-3) and choose Capture, the following is done automatically:

- A memory-based capture session is created
- A software filter is created using that application
- The capture session is started
- The decode window pops open and you can immediately see packets being captured.

Note

Quick Capture does not use site definition/filter.

From both the selectors in the upper left of the dashboards and from the item the user clicks on in the barchart, the following are carried into the context for the capture session:

- Application
- VLAN
- Host
- Data Source (if it is a DATA PORT)

If you open up the associated Capture Session and its associated Software Filter, the above settings will be shown.

Determining How to Use Sites to View Data

A site is an optional collection of hosts, or network endpoints, partitioned into views that help you monitor traffic and troubleshoot problems (see Configuring Sites, page 6-47 for more detailed information).

If you have set up sites, you will be able to select a particular site to view in the Interactive Report and view data relevant to that site only. In some cases, you can select both a Client Site and a Server Site to view data pertaining to interaction between hosts at different sites.

Filtering Traffic for Viewing on the Dashboards

You can use the Interactive Report on most Monitor and Analyze windows to filter the parameters of the information displayed in the dashboards. Use the Monitor windows to view at a glance data and the Analyze windows to view data over time.

Step 1

Click the Filter button to change the parameters of the information displayed in the charts. An asterisk represents required fields.

Step 2

To search for a specific site’s VLAN traffic, select the Site name from the drop-down menu. Then select Encapsulation Edit button and enter the Layer 1 VLAN options on which you want to filter. You can select multiple values and additional layers.
To set a custom time range, select the **Custom** option from the Time Range drop-down menu. Then enter the dates and times. The From and To fields are only enabled when the Time Range is set to **Custom**.

You may need to enter the time range filter several times before seeing the data that you need. The default filter time range is for the last hour.

The reporting time interval selection changes depends upon both the dashboard you are viewing and your NAM platform.

**Step 3** To view your updated filter results in the dashboard, click **Apply**.

**Step 4** To save your filter for future use, enter a Filter Name and click **Submit**.

The software supports up to five saved filters. Saved reports display at the bottom of the Interactive Report panel. You can also edit or delete filters after creating them using the icons in the saved filter dialog box.

---

**Filtering Data Using Global Search**

You can use the global search filter to limit your overall view to specific host data. The global search tool appears in the top-right corner of the user interface. Enter the host IP address in the global search tool. The host search dashboard appears. On the Top N Applications chart, you can left-click a colored bar to get the context menu, and choose Analyze Host Traffic to see the host dashboard and analyze the host traffic for the selected application using Over Time chart.

**Step 1** From your Monitor or Analyze dashboard enter your IPv4, IPv6, and Layer 2 traffic MAC addresses. You may also search using hostnames if you have enabled hostname (DNS lookup) in Prime NAM.

Specified host filters are also in effect for context menu charts. For example, if you specify a hostname filter in Monitor > Response Time Summary, the dashboard refreshes with only data specific to this host (including the IP address and site, if applicable). You can hover over table data for instant details. drill down menus also reflect this host’s data.

**Step 2** To change the time range, select one of the default ranges or create a custom range.

---

**Switching Chart Formats Using the Chart View / Table View**

Using the Chart view lets you see an overview of the data in an integrated manner, and can show you trending information. To get the exact value of any data in the graphical view, hover over a data point to see the tool tip. The chart view may be To toggle between the two views, use the Chart and Table icons at the bottom of the panel:
Accessing Other Tasks Using Mouse-Over for Details

When in Chart view, you can mouse over the chart to get more detailed information about what occurred at a specific time.

Many of the line charts in Prime NAM are dual-axis, meaning there is one metric shown on the left axis of the chart and another metric shown on the right axis of the chart.

For example, in the DCSP Group Traffic chart, Megabits per second is shown on the left axis, and Packets per second is shown on the right axis.

Changing the Time Interval Using Zoom/Pan Charts

For many charts, you can drag the beginning or end to change the time interval, as shown below.

The time interval change on the zoom/pan chart affects the data presented in the charts in the bottom of the window. The zoom/pan time interval also affects the drill down navigations; if the zoom/pan interval is modified, the context menu drill downs from that dashboard will use the zoom/pan time interval.

Note

In a bar chart which you can zoom/pan, each block represents data collected during the previous interval (the time stamp displayed at the bottom of each block is the end of the time range). Therefore, you may have to drag the zoom/pan one block further than expected to get the desired data to populate in the charts in the bottom of the window.

Using Sort Grid to Change Sort Order

When looking at information in Grid view, you can sort the information by clicking the heading of any column. Click it again to sort in reverse order.
Displaying Bits or Bytes or Packets in Charts

To change the display on most Monitor and Analyze charts from bits to bytes, you can use the Bits and Bytes radio buttons to specify which information you would like the chart to display. To change this preference to display bytes use the Administration > System > Preferences.

On most Monitor and Analyze charts, you can use the Bits and Packets check boxes at the top to specify which information you would like the chart to display. To change this preference to display bytes use the Administration > System > Preferences.

Statistics

The Statistics legend gives you the minimum, maximum, and average statistics of the data. This will display the initial data retrieved for the selector.

Context-Sensitive Online Help

Click the Help link on the top-right corner of the Prime NAM interface to bring you to the Help page for that particular window of the GUI.

If available, the Help link appears on the top-right corner of each page; some pages also have a blue “i”, which provides help for that specific subject.

On some fields, hovering over the field displays tip information.

Feedback

Click the feedback link on the top-right corner of the Prime NAM interface to view the email id to which you can send your feedback. You can click the Product Info button to view the Network Analysis Module (NAM) Products page.
GUI Field Descriptions

This appendix describes critical field descriptions for the following windows. Not all fields are described as some are self-explanatory and others have tips that appear in the user interface.

- Setup User Interface Windows
- Monitor User Interface Windows
- Capture User Interface Windows
- Administration User Interface Windows
- Report Descriptions

Setup User Interface Windows

This section describes the field descriptions for the following dialog boxes:

- Create SPAN Session Dialog Box
- Prime NAM Data Sources
- Edit SPAN Session Dialog Box
- SNMP Credential Options in NAM Data Sources Window
- Device System Information Dialog Box
- Alarm Configuration Window
- Threshold Configuration
- Host Alarm Thresholds
- Conversation Alarm Thresholds
- Application Alarm Thresholds
- Response Time Thresholds
- DSCP Alarm Thresholds
- RTP Streams Thresholds
- Voice Signaling Thresholds
- NetFlow Interface Alarm Thresholds
- Router/Managed Device System Information
- Switch Device Information
Create SPAN Session Dialog Box

Table D-1 describes the critical fields on the Create SPAN Session dialog box. Depending on NAM platform and SPAN configuration options such as SNMP, NetConf, or RISE the fields will vary in the Create SPAN Session Dialog Box.

**Table D-1 Create SPAN Session Dialog Box**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Managed Device</td>
<td>Managed device IP address and VDC on the managed device.</td>
</tr>
<tr>
<td>Session ID</td>
<td>ID of the SPAN session.</td>
</tr>
</tbody>
</table>
| Span Session Options | • Extended: Allows for IP extended input ACLs to receive a copy of a dropped packet on a destination port even if the actual incoming packet is dropped.  
                      • Multicast Best Effort: Multicast packets are delivered to a group using best-effort reliability, just like IPv6 unicast packets.  
                      • Sampling: Collects NetFlow statistics for a subset of incoming (ingress) IPv4 traffic on the interface, selecting only one out of "N" sequential packets, where "N" is a configurable parameter.  
                      • MTU Truncation: Maximum bytes allowed for each replicated packet in a SPAN session  
                      • Rate Limit: Sets Committed Access Rate and Distributed Committed Access Rates for the interface's bandwidth |
| SPAN Type        | • Switch Port  
                      • VLAN  
                      • EtherChannel  
                      • RSPAN VLAN  
                      You can have only one RSPAN VLAN source per SPAN session. |
Table D-1  Create SPAN Session Dialog Box (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SPAN Destination Interface</td>
<td>The NAM interface to which you want to send data.</td>
</tr>
<tr>
<td>Switch Module</td>
<td>Module of the switch</td>
</tr>
<tr>
<td>SPAN Traffic Direction</td>
<td>Direction of the SPAN traffic.</td>
</tr>
<tr>
<td>Available and Selected</td>
<td>SPAN sources available for the selected SPAN type.</td>
</tr>
<tr>
<td>Sources</td>
<td></td>
</tr>
</tbody>
</table>

Prime NAM Data Sources Dialog Box

Table D-2 describes the critical fields on the Prime NAM Data Sources dialog box.

Table D-2  Prime NAM Data Sources

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device</td>
<td>DATA PORT if it is a local physical port or the IP address of the device that is sending NAM data.</td>
</tr>
<tr>
<td>Type</td>
<td>The source of traffic for the NAM.</td>
</tr>
<tr>
<td></td>
<td>DATA PORT if it is a local physical port.</td>
</tr>
<tr>
<td></td>
<td>WAAS, ERSPAN, or NETFLOW, if a data stream exported from the router or switch or WAE device.</td>
</tr>
<tr>
<td>Activity</td>
<td></td>
</tr>
<tr>
<td>Status</td>
<td>ACTIVE or INACTIVE.</td>
</tr>
<tr>
<td>Data Source</td>
<td></td>
</tr>
<tr>
<td>Data Source Details</td>
<td>Physical Port or information about the data source being Enabled or Disabled.</td>
</tr>
</tbody>
</table>

Edit SPAN Session Dialog Box

Table D-3 describes the critical fields on the Edit SPAN Session dialog box. Depending on NAM platform and SPAN configuration options such as SNMP, NetConf, or RISE the fields will vary in the Create SPAN Session Dialog Box.

Table D-3  Edit SPAN Session Dialog Box

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Managed Device</td>
<td>Managed device IP address and VDC on the managed device.</td>
</tr>
<tr>
<td>Session ID</td>
<td>ID of the SPAN session.</td>
</tr>
</tbody>
</table>
SNMP Credential Options in NAM Data Sources Window

Table D-4 describes the options on the NAM Data Sources window for SNMP Credentials.

Table D-4 SNMP Credential Options in NAM Data Sources Window

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mode: No Auth, No Priv</td>
<td>SNMP will be used in a mode with no authentication and no privacy.</td>
</tr>
<tr>
<td>Mode: Auth, No Priv</td>
<td>SNMP will be used in a mode with authentication, but no privacy.</td>
</tr>
<tr>
<td>Mode: Auth and Priv</td>
<td>SNMP will be used in a mode with both authentication and privacy.</td>
</tr>
<tr>
<td>User Name</td>
<td>Enter a username, which will match the username configured on the device.</td>
</tr>
<tr>
<td>Auth Password</td>
<td>Enter the authentication password associated with the username that was configured on the device. Verify the password.</td>
</tr>
<tr>
<td>Auth Algorithm</td>
<td>Choose the authentication standard which is configured on the device (MD5 or SHA-1).</td>
</tr>
</tbody>
</table>
### Table D-4  SNMP Credential Options in NAM Data Sources Window (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Privacy Password</td>
<td>Enter the privacy password, which is configured on the device. Verify the password.</td>
</tr>
<tr>
<td>Privacy Algorithm</td>
<td>Enter the privacy algorithm, which is configured on the device (AES or DES).</td>
</tr>
</tbody>
</table>

### Device System Information Dialog Box

Table D-5 describes the critical fields on the Device System Information dialog box.

### Table D-5  Device System Information Dialog Box

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hardware</td>
<td></td>
</tr>
<tr>
<td>Device Software Version</td>
<td>The current software version running on the device.</td>
</tr>
<tr>
<td>System Uptime</td>
<td>Total time the device has been running since the last reboot.</td>
</tr>
<tr>
<td>SNMP read from device</td>
<td>SNMP read test result. For the local device only.</td>
</tr>
</tbody>
</table>

### Alarm Configuration Window

Table D-6 describes the critical fields on the Alarm Configuration Window.

### Table D-6  Alarm Configuration Window

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name given to the alarm at setup.</td>
</tr>
<tr>
<td>E-mail</td>
<td>Enable if turned on. Disable if turned off. Choose Administration &gt; System &gt; E-Mail Setting.</td>
</tr>
<tr>
<td>Trap</td>
<td>Community: xxxxx if configured. If not configured it is blank. Choose Administration &gt; System &gt; SNMP Trap Setting.</td>
</tr>
<tr>
<td>Trigger Capture</td>
<td>Session: xxxxx if configured. If no captures are configured it is blank. Choose Capture &gt; Packet Capture/Decode &gt; Sessions.</td>
</tr>
<tr>
<td>Syslog Remote</td>
<td>Enable if turned on. Disable if turned off. Choose Administration &gt; System &gt; Syslog Setting.</td>
</tr>
<tr>
<td>Status</td>
<td>Missing Trap means that the trap configured for that alarm action has been deleted. OK means the Alarm action was successfully created.</td>
</tr>
</tbody>
</table>

### Threshold Configuration Window

Table D-7 describes the critical fields on the Threshold Configuration window.
Appendix D   GUI Field Descriptions

Table D-7  Threshold Configuration

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>You can configure eight types of thresholds.</td>
</tr>
<tr>
<td>Application</td>
<td>Site</td>
</tr>
<tr>
<td>Host</td>
<td></td>
</tr>
<tr>
<td>Severity</td>
<td>High or Low (user-configured classification). These alarms are displayed on the Alarm Summary dashboard (Monitor &gt; Overview &gt; Alarm Summary). You can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td>Action</td>
<td>Rising action and Falling action (if configured). Alarms are predefined conditions based on a rising data threshold, a falling data threshold, or both.</td>
</tr>
<tr>
<td>Status</td>
<td>OK if configuration is complete. Otherwise, the issue displays (for example, Missing Src Site).</td>
</tr>
<tr>
<td>Add Metrics (button)</td>
<td>Adds another row.</td>
</tr>
<tr>
<td>Delete (button)</td>
<td>Removes that Metrics row.</td>
</tr>
</tbody>
</table>

Host Alarm Thresholds Window

Table D-8 describes the critical fields on the Hold Alarm Threshold window.

Table D-8  Host Alarm Thresholds

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td></td>
</tr>
<tr>
<td>Site</td>
<td>Choose a site from the list. See Configuring Sites, page 6-47 for information on setting up a site.</td>
</tr>
<tr>
<td>Host</td>
<td>Choose a host from the list. You can enter the name of the host if the drop-down list does not contain the desired host.</td>
</tr>
<tr>
<td>Application</td>
<td>Choose an application from the list. You can enter the first few characters to narrow the selection in the drop-down list.</td>
</tr>
<tr>
<td>DSCP</td>
<td>Choose a DSCP value from the list. You can enter the first few characters to narrow the selection in the drop-down list.</td>
</tr>
<tr>
<td>Severity</td>
<td>Choose High or Low. These display on the Alarm Summary dashboard (Monitor &gt; Overview &gt; Alarm Summary), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td>Actions</td>
<td>From the drop-down lists, choose a Rising action and a Falling action (optional). During threshold creation, by default, the falling action is the same as rising action. See Viewing Alarm Actions, page 6-33 for information on setting up alarm actions.</td>
</tr>
<tr>
<td>Host Metrics (per second)</td>
<td>Choose the type of metric from the list, and then enter a value for a Rising threshold and a Falling threshold.</td>
</tr>
</tbody>
</table>
Conversation Alarm Thresholds Window

Table D-9 describes the critical fields on the Conversation Alarm Thresholds window.

**Table D-9  Conversation Alarm Thresholds**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td></td>
</tr>
<tr>
<td>Application</td>
<td>Choose an application from the list. You can start typing the first few characters to narrow the list.</td>
</tr>
<tr>
<td>Severity</td>
<td>Choose High or Low. These display on the Alarm Summary dashboard (<a href="#">Monitor &gt; Overview &gt; Alarm Summary</a>), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td>Source Site/Host</td>
<td>Make a selection from the drop-down lists, or leave as Any. See <a href="#">Configuring Sites, page 6-47</a> for information on setting up a site.</td>
</tr>
<tr>
<td>Destination Site/Host</td>
<td>Make a selection from the drop-down lists, or leave as Any. See <a href="#">Configuring Sites, page 6-47</a> for information on setting up a site.</td>
</tr>
<tr>
<td>Actions</td>
<td>From the lists, choose a Rising action and a Falling action (optional). See <a href="#">Viewing Alarm Actions, page 6-33</a> for information on setting up alarm actions.</td>
</tr>
<tr>
<td>Conversation Metrics (per second)</td>
<td>Choose from one of the six metrics, and then enter a Rising threshold and a Falling threshold.</td>
</tr>
</tbody>
</table>

Application Alarm Thresholds Configuration Window

Table D-10 describes the critical fields on the Application Alarm Thresholds Configuration window.

**Table D-10  Application Alarm Thresholds**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td></td>
</tr>
<tr>
<td>Site</td>
<td>Choose a site from the list. See <a href="#">Configuring Sites, page 6-47</a> for information on setting up a site.</td>
</tr>
<tr>
<td>Application</td>
<td>Choose an application from the list. You can start typing the first few characters to narrow the list.</td>
</tr>
<tr>
<td>DSCP</td>
<td>Choose a DSCP value 0-63, or Any.</td>
</tr>
<tr>
<td>Severity</td>
<td>Choose High or Low. These display on the Alarm Summary dashboard (<a href="#">Monitor &gt; Overview &gt; Alarm Summary</a>), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td>Actions</td>
<td>From the lists, choose a Rising action and a Falling action (optional). See <a href="#">Configuring Alarm Actions, page 6-31</a> for information on setting up alarm actions.</td>
</tr>
<tr>
<td>Application Metrics (per second)</td>
<td>Choose Bits or Bytes, and then enter a Rising threshold and a Falling threshold.</td>
</tr>
</tbody>
</table>
**Response Time Alarm Threshold Configuration Window**

Table D-11 describes the critical fields on the Response Time Alarm Threshold Configuration window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Application</strong></td>
<td>Choose an application from the list. You can start typing the first few characters to narrow the list.</td>
</tr>
<tr>
<td><strong>Severity</strong></td>
<td>Choose High or Low. These display on the Alarm Summary dashboard (<a href="#">Monitor &gt; Overview &gt; Alarm Summary</a>), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td><strong>Client Site/Host</strong></td>
<td>Make a selection from the lists. See <a href="#">Configuring Sites, page 6-47</a> for information on setting up a site.</td>
</tr>
<tr>
<td><strong>Server Site/Host</strong></td>
<td>Make a selection from the lists, or leave as “Any.” See <a href="#">Configuring Sites, page 6-47</a> for information on setting up a site.</td>
</tr>
<tr>
<td><strong>Actions</strong></td>
<td>From the lists, choose a Rising action and a Falling action (optional). See <a href="#">Viewing Alarm Actions, page 6-33</a> for information on setting up alarm actions.</td>
</tr>
<tr>
<td><strong>Response Time Metrics</strong></td>
<td>Choose a metric from the list, and then enter a Rising threshold and a Falling threshold. For the Packets and Bytes-related metrics, the entry is per second. For the time-related metrics, the unit is per microseconds (u).</td>
</tr>
</tbody>
</table>

**DSCP Alarm Threshold Configuration Window**

Table D-12 describes the critical fields on the DSCP Alarm Threshold Configuration window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
<td>Give the DSCP Alarm Threshold a name.</td>
</tr>
<tr>
<td><strong>Site</strong></td>
<td>Choose a site from the list. See <a href="#">Configuring Sites, page 6-47</a> for information on setting up a site.</td>
</tr>
<tr>
<td><strong>DSCP</strong></td>
<td>Choose a DSCP value from the list.</td>
</tr>
<tr>
<td><strong>Severity</strong></td>
<td>Choose High or Low. These display on the Alarm Summary dashboard (<a href="#">Monitor &gt; Overview &gt; Alarm Summary</a>), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td><strong>Actions</strong></td>
<td>From the drop-down lists, choose a Rising action and a Falling action (optional).</td>
</tr>
<tr>
<td><strong>DSCP Metrics (per second)</strong></td>
<td>Choose one of the metric types from the list, and then enter a Rising threshold and a Falling threshold.</td>
</tr>
</tbody>
</table>
RTP Streams Threshold Configuration Window

Table D-13 describes the critical fields on the RTP Threshold Configuration window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td></td>
</tr>
<tr>
<td>Severity</td>
<td>Choose High or Low. These display on the Alarm Summary dashboard (Monitor &gt; Overview &gt; Alarm Summary), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td>Codec</td>
<td>Choose a Codec from the list.</td>
</tr>
<tr>
<td>Source Site/Host</td>
<td>Make a selection from the drop-down lists, or leave as “Any.” See Configuring Sites, page 6-47 for information on setting up a site.</td>
</tr>
<tr>
<td>Severity</td>
<td>Choose High or Low. These display on the Alarm Summary dashboard (Monitor &gt; Overview &gt; Alarm Summary), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td>Actions</td>
<td>From the drop-down lists, choose a Rising action and a Falling action (optional). See Viewing Alarm Actions, page 6-33 for information on setting up alarm actions.</td>
</tr>
<tr>
<td>RTP Stream Metrics</td>
<td></td>
</tr>
<tr>
<td>Jitter</td>
<td>Variation of packet arrival time compare to expected arrival time.</td>
</tr>
<tr>
<td>Adjusted packet loss percent</td>
<td>Percent of packet loss which includes packets actually lost and packets that arrived beyond the expected buffering capability of the endpoint.</td>
</tr>
<tr>
<td>Actual packet loss percent</td>
<td>Percent of packets that Prime NAM has never seen.</td>
</tr>
<tr>
<td>MOS</td>
<td>Mean opinion score that is composed of both jitter and adjusted packet loss.</td>
</tr>
<tr>
<td>Concealment seconds</td>
<td>Number of seconds in which Prime NAM detected packets lost.</td>
</tr>
<tr>
<td>Severe concealment seconds</td>
<td>Number of seconds in which Prime NAM detected packets lost of more than 5%.</td>
</tr>
</tbody>
</table>

Enter a Rising threshold and a Falling threshold.

Voice Signaling Threshold Configuration Window

Table D-14 describes the critical fields on the Voice Signaling Threshold Configuration window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td></td>
</tr>
<tr>
<td>Severity</td>
<td>Choose High or Low. These display on the Alarm Summary dashboard (Monitor &gt; Overview &gt; Alarm Summary), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
</tbody>
</table>
Table D-14  Voice Signaling Thresholds (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actions</td>
<td>Choose a Rising action and a Falling action from the lists (optional). See Viewing Alarm Actions, page 6-33 for information on setting up alarm actions.</td>
</tr>
<tr>
<td>Voice Signaling Metrics</td>
<td>Choose Jitter to enable an alarm when the software detects jitter to be more than the value set here. Check Packet Loss % to enable an alarm when the software detects Packet Loss percentage to be outside of the values you entered.</td>
</tr>
</tbody>
</table>

NetFlow Interface Threshold Configuration Window

Table D-15 describes the critical fields on the Network Interface Threshold Configuration window.

Table D-15  NetFlow Interface Alarm Thresholds

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Direction</td>
<td>Choose Ingress or Egress.</td>
</tr>
<tr>
<td>Severity</td>
<td>Choose High or Low. These display on the Alarm Summary dashboard (Monitor &gt; Overview &gt; Alarm Summary), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td>Actions</td>
<td>Choose a Rising action and a Falling action from the lists (optional). See Viewing Alarm Actions, page 6-33 for information on setting up alarm actions.</td>
</tr>
<tr>
<td>Application Metrics (per second)</td>
<td>Choose Bytes or Packets, and enter a Rising and Falling threshold.</td>
</tr>
</tbody>
</table>

Video Stream Threshold Configuration Window

Table D-16 describes the critical fields on the Video Stream Threshold Configuration window.

Table D-16  Video Stream Thresholds

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name given to the video stream,</td>
</tr>
<tr>
<td>Severity</td>
<td>Choose High or Low. These display on the Alarm Summary dashboard (Monitor &gt; Overview &gt; Alarm Summary), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td>Codec</td>
<td>Choose a Codec from the list.</td>
</tr>
<tr>
<td>Source Site/Host</td>
<td>Make a selection from the drop-down lists, or leave as “Any.” See Configuring Sites, page 6-47 for information on setting up a site.</td>
</tr>
<tr>
<td>Severity</td>
<td>Choose High or Low. These display on the Alarm Summary dashboard (Monitor &gt; Overview &gt; Alarm Summary), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
</tbody>
</table>
### Video Stream Thresholds (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actions</td>
<td>From the drop-down lists, choose a Rising action and a Falling action (optional). See Viewing Alarm Actions, page 6-33 for information on setting up alarm actions.</td>
</tr>
<tr>
<td>Video Stream Metrics</td>
<td>Choose a metric from the list:</td>
</tr>
<tr>
<td></td>
<td>• I Frame Loss%: Percentage of I frame loss.</td>
</tr>
<tr>
<td></td>
<td>• I Frame Loss Count: The loss count of I frames.</td>
</tr>
<tr>
<td></td>
<td>• All Frame Loss%: Percentage of frame loss of all types.</td>
</tr>
<tr>
<td></td>
<td>• All Frame Loss Count: The loss count of all types of frames.</td>
</tr>
<tr>
<td></td>
<td>Enter a Rising threshold and a Falling threshold.</td>
</tr>
</tbody>
</table>

### Video MDI Stream Threshold Configuration Window

Table D-17 describes the critical fields on the Video MDI Stream Threshold Configuration window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name given to the video MDI Stream.</td>
</tr>
<tr>
<td>Severity</td>
<td>Choose High or Low. These display on the Alarm Summary dashboard (Monitor &gt; Overview &gt; Alarm Summary), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td>Source Site/Host</td>
<td>Make a selection from the drop-down lists, or leave as “Any.” See Configuring Sites, page 6-47 for information on setting up a site.</td>
</tr>
<tr>
<td>Severity</td>
<td>Choose High or Low. These display on the Alarm Summary dashboard (Monitor &gt; Overview &gt; Alarm Summary), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td>Actions</td>
<td>From the drop-down lists, choose a Rising action and a Falling action (optional). See Viewing Alarm Actions, page 6-33 for information on setting up alarm actions.</td>
</tr>
<tr>
<td>Video Stream Metrics</td>
<td>Choose a metric from the list:</td>
</tr>
<tr>
<td></td>
<td>• Delay Factor: RFC-4445 delay factor.</td>
</tr>
<tr>
<td></td>
<td>• Media Loss Rate: RFC-4445 media loss rate.</td>
</tr>
<tr>
<td></td>
<td>Enter a Rising threshold and a Falling threshold.</td>
</tr>
</tbody>
</table>
Router System Information Window

Table D-18 describes the critical fields on the Router System Information window.

Table D-18  Router/Managed Device System Information

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td></td>
</tr>
<tr>
<td>Hardware</td>
<td></td>
</tr>
<tr>
<td>Managed Device Software Version</td>
<td>Current software version of the router.</td>
</tr>
<tr>
<td>Managed Device System Uptime</td>
<td>Total time the router or switch has been running.</td>
</tr>
<tr>
<td>Location</td>
<td></td>
</tr>
<tr>
<td>Contact</td>
<td></td>
</tr>
<tr>
<td>Managed Device</td>
<td>IP address of the router.</td>
</tr>
<tr>
<td>SNMP v1/v2c RW Community String</td>
<td></td>
</tr>
<tr>
<td>Verify String</td>
<td></td>
</tr>
<tr>
<td>Enable SNMP V3</td>
<td>Check the check box to enable SNMP Version 3. If SNMPv3 is not enabled, the community string is used.</td>
</tr>
<tr>
<td>Mode: No Auth, No Priv</td>
<td>SNMP is used in a mode with no authentication and no privacy.</td>
</tr>
<tr>
<td>Mode: Auth, No Priv</td>
<td>SNMP is used in a mode with authentication, but no privacy.</td>
</tr>
<tr>
<td>Mode: Auth and Priv</td>
<td>SNMP is used in a mode with both authentication and privacy.</td>
</tr>
<tr>
<td>User Name</td>
<td>Enter a username, which will match the username configured on the device.</td>
</tr>
<tr>
<td>Auth Password</td>
<td>Enter the authentication password associated with the username that was configured on the device. Verify the password.</td>
</tr>
<tr>
<td>Auth Algorithm</td>
<td>Choose the authentication standard which is configured on the device (MD5 or SHA-1).</td>
</tr>
<tr>
<td>Privacy Password</td>
<td>Enter the privacy password, which is configured on the device. Verify the password.</td>
</tr>
<tr>
<td>Privacy Algorithm</td>
<td>Enter the privacy algorithm, which is configured on the device (AES or DES).</td>
</tr>
</tbody>
</table>

Switch/Managed Device System Information

Table D-19 describes the critical fields on the Switch System Information window.

Table D-19  Switch Device Information

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SNMP Test information</td>
<td>Displays the IP address of the NAM and the switch on which the SNMP test occurred.</td>
</tr>
<tr>
<td>Name</td>
<td></td>
</tr>
</tbody>
</table>
Table D-19  Switch Device Information (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Hardware</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Supervisor Software Version</strong></td>
<td></td>
</tr>
<tr>
<td><strong>System Uptime</strong></td>
<td>Total time the device has been running.</td>
</tr>
<tr>
<td><strong>SNMP read from chassis</strong></td>
<td>SNMP read test result.</td>
</tr>
<tr>
<td><strong>SNMP write to chassis</strong></td>
<td>SNMP write test result.</td>
</tr>
<tr>
<td><strong>Mini-RMON on chassis</strong></td>
<td>For Cisco IOS devices, displays the status if there are any ports with Mini-RMON configured (Available) or not (Unavailable).</td>
</tr>
<tr>
<td><strong>NBAR on chassis</strong></td>
<td>Displays if NBAR is available on the device.</td>
</tr>
<tr>
<td><strong>VLAN Traffic Statistics on chassis</strong></td>
<td>Displays if VLAN data is Available or Unavailable.</td>
</tr>
<tr>
<td><strong>NetFlow Status</strong></td>
<td>For Catalyst 6500 Series devices running Cisco IOS, if NetFlow is configured on the device, Remote export to NAM &lt;address&gt; on port &lt;number&gt; displays, otherwise the status displays Configuration unavailable.</td>
</tr>
</tbody>
</table>

**NBAR Interfaces Window**

Table D-20 describes the critical fields on the NBAR Interfaces window.

Table D-20  NBAR Interface Details

<table>
<thead>
<tr>
<th>Field / Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Enable</strong> (check box)</td>
<td>Check indicates that NBAR is enabled.</td>
</tr>
<tr>
<td><strong>Interface</strong></td>
<td>Depending on the IOS running on the Supervisor, port names are displayed differently. Newer versions of IOS software display a port name as Gi2/1 to represent a Gigabit port on module 2 port 1. In the Virtual Switch software (VSS), a port name might be displayed as Gi1/2/1 to represent a Gigabit port on switch 1, module2, port 1.</td>
</tr>
<tr>
<td><strong>Interface Description</strong></td>
<td>Description of the interface.</td>
</tr>
</tbody>
</table>

**Site Configuration Window**

Table D-21 describes the critical fields on the Site Configuration window.

Table D-21  Site Configuration

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td></td>
</tr>
<tr>
<td><strong>Description</strong></td>
<td></td>
</tr>
</tbody>
</table>
Table D-21 Site Configuration (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disable Site (check box)</td>
<td>If you check this check box, the software will skip this site when classifying traffic. This is useful if the site is no longer active, but the user would still like to access historical site data in the database. Otherwise, the user should delete sites that are not needed.</td>
</tr>
<tr>
<td>Subnet</td>
<td>IP address subnet (IPv4/IPv6 address and mask); for example, 10.1.1.0/24. Click the blue i to get information about Site Rules. You can click the Detect button to tell the software to look for subnets in the traffic. See Configuring Sites Using Subnets, page 6-49.</td>
</tr>
<tr>
<td>Data Source</td>
<td>Specify the data source from where the site traffic originates. Leave this field blank if the site traffic can come from multiple data sources.</td>
</tr>
</tbody>
</table>

**Subnet Detection Window**

Table D-22 describes the critical fields on the Subnet Detection window.

Table D-22 Subnet Detection

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Subnet Mask</td>
<td>Enter the subnet mask.</td>
</tr>
<tr>
<td>Note</td>
<td>If the bit mask is 32 or less, the software will detect an IPv4 subnet. If the bit mask is between 33 and 64, then it will detect an IPv6 subnet.</td>
</tr>
<tr>
<td>Data Source</td>
<td>Choose the data source in which you would like to detect subnets.</td>
</tr>
<tr>
<td>Interface</td>
<td>Choose the interface in which you would like to detect subnets.</td>
</tr>
<tr>
<td>Filter Subnets Within Network</td>
<td>Enter an IPv4 or IPv6 address</td>
</tr>
<tr>
<td>Unassigned Site (check box)</td>
<td>The “Unassigned” site includes any that do not match any of your site configurations. Sites are classified at the time of packet processing.</td>
</tr>
</tbody>
</table>

**Sites Window**

Table D-23 describes the critical fields on the Sites window.

Table D-23 Sites Window

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td></td>
</tr>
<tr>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>Rule</td>
<td>Lists the first rule assigned to the selected site. If you see periods next to the site rule (...), then multiple rules were created for that site. To see the list of all rules, click the quick view icon (after highlighting the site, click the small arrow on the right).</td>
</tr>
<tr>
<td>Status</td>
<td>Shows if the site is Enabled or Disabled.</td>
</tr>
</tbody>
</table>
Add NetFlow Interface Window

Table D-24 describes the critical fields on the NetFlow Interface Add window.

Table D-24  Add NetFlow Interface Capacity

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device</td>
<td>Enter the IPv4 or IPv6 address.</td>
</tr>
<tr>
<td>ifIndex</td>
<td>Unique identifying number associated with a physical or logical interface. Valid characters: 0-9.</td>
</tr>
<tr>
<td>ifName</td>
<td>Name of the interface. Valid characters are A-Z, a-z, 0-9.</td>
</tr>
<tr>
<td>ifSpeed(Mbps)</td>
<td>An estimate of the interface’s current bandwidth in bits per second.</td>
</tr>
</tbody>
</table>

DSCP Group Setup Dialog Box

Table D-25 describes the critical fields on the DSCP Group Setup dialog box.

Table D-25  DSCP Group Setup Dialog Box

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the profile.</td>
<td>Enter the name of the profile you are creating. The maximum is 64 characters.</td>
</tr>
<tr>
<td>Label Format</td>
<td>DSCP</td>
<td>DSCP numbers from 0 to 63. After selecting the DSCP radio button, you can freely choose any of the 64 possible values and assign them to Groups.</td>
</tr>
<tr>
<td></td>
<td>AF / EF / CS</td>
<td>Assured Forwarding (AF) guarantees a certain amount of bandwidth to an AF class and allows access to extra bandwidth, Expedited Forwarding (EF) is used for traffic that is very sensitive to delay, loss and jitter, such as voice or video traffic. Class Selector (CS) the last 3 bits of the 6-bit DSCP field, so these correspond to DSCP 0 through DSCP 7.</td>
</tr>
<tr>
<td>Bit Field</td>
<td>Six bits in the IP header of a packet.</td>
<td></td>
</tr>
</tbody>
</table>

DSCP Group Label Formats

Table D-26 describes the DSCP Group label formats.

Table D-26  DSCP Group Label Formats

<table>
<thead>
<tr>
<th>DSCP Format (DSCP 0 through DSCP 63)</th>
<th>AF/EF/CS Format</th>
<th>Bit Field Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>DSCP 0</td>
<td>-</td>
<td>000000</td>
</tr>
<tr>
<td>DSCP 8</td>
<td>CS1</td>
<td>001000</td>
</tr>
</tbody>
</table>
Table D-26  DSCP Group Label Formats (continued)

<table>
<thead>
<tr>
<th>DSCP Format (DSCP 0 through DSCP 63)</th>
<th>AF/EF/CS Format</th>
<th>Bit Field Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>DSCP 10</td>
<td>AF11</td>
<td>001010</td>
</tr>
<tr>
<td>DSCP 12</td>
<td>AF12</td>
<td>001100</td>
</tr>
<tr>
<td>DSCP 14</td>
<td>AF13</td>
<td>001110</td>
</tr>
<tr>
<td>DSCP 16</td>
<td>CS2</td>
<td>010000</td>
</tr>
<tr>
<td>DSCP 18</td>
<td>AF21</td>
<td>010010</td>
</tr>
<tr>
<td>DSCP 20</td>
<td>AF22</td>
<td>010100</td>
</tr>
<tr>
<td>DSCP 22</td>
<td>AF23</td>
<td>010110</td>
</tr>
<tr>
<td>DSCP 24</td>
<td>CS3</td>
<td>011000</td>
</tr>
<tr>
<td>DSCP 26</td>
<td>AF31</td>
<td>011010</td>
</tr>
<tr>
<td>DSCP 28</td>
<td>AF32</td>
<td>011100</td>
</tr>
<tr>
<td>DSCP 30</td>
<td>AF33</td>
<td>011110</td>
</tr>
<tr>
<td>DSCP 32</td>
<td>CS4</td>
<td>100000</td>
</tr>
<tr>
<td>DSCP 34</td>
<td>AF41</td>
<td>100010</td>
</tr>
<tr>
<td>DSCP 36</td>
<td>AF42</td>
<td>100100</td>
</tr>
<tr>
<td>DSCP 38</td>
<td>AF43</td>
<td>100110</td>
</tr>
<tr>
<td>DSCP 40</td>
<td>CS5</td>
<td>101000</td>
</tr>
<tr>
<td>DSCP 46</td>
<td>EF</td>
<td>101110</td>
</tr>
<tr>
<td>DSCP 48</td>
<td>CS6</td>
<td>110000</td>
</tr>
<tr>
<td>DSCP 56</td>
<td>CS7</td>
<td>111000</td>
</tr>
</tbody>
</table>

Application Window

Table D-27 describes the critical fields on the Add Application Window.

Table D-27  Create or Edit Applications

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Unique 1 to 64 character descriptive name.</td>
</tr>
<tr>
<td>Description</td>
<td>(Optional) Leave blank. An arbitrary number up to 4-digits, unique within an engine-id. It is automatically assigned if left blank. Identification number is autogenerated if left blank. Range is from 1 to 65535.</td>
</tr>
<tr>
<td>Selector</td>
<td>This allows you to configure applications consistently across multiple NAMs, so that the same user-created application is exported with the same value. This should be used when configuring the same custom applications on multiple NAMs. The application tag for user-created applications is a combination of the engine ID and the Selector. The 32 bit is generated by using the engine ID as the highest order byte, and the Selector makes up the other 3 bytes. For standard application/protocols, the application tag is predefined.</td>
</tr>
</tbody>
</table>
Table D-27  Create or Edit Applications (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application Classification Rule</td>
<td>Select application type: Protocol, HTTP URL-based or Server IP Address.</td>
</tr>
<tr>
<td>Application Rule: Protocol/Port</td>
<td>Add the application protocol and port you want to track.</td>
</tr>
<tr>
<td>Protocol—Lists predefined protocols. If your option is not included, you can create a custom URL-based application classification.</td>
<td></td>
</tr>
<tr>
<td>Port—Enter the port number or port number range to monitor. The port is an arbitrary number you assign to handle the additional ports for the protocol family. This protocol number must be unique so it does not conflict with standard protocol/port assignments.</td>
<td></td>
</tr>
<tr>
<td>The port number range will vary depending on the protocol type selected. You can create additional ports to enable Prime NAM to handle additional traffic for standard applications.</td>
<td></td>
</tr>
<tr>
<td>Application Rule: HTTP URL</td>
<td>Create custom URL-based applications by selecting this option. Enter at least one of the values below.</td>
</tr>
<tr>
<td>URL Host—The host name identified in the header from which the traffic is originating.</td>
<td></td>
</tr>
<tr>
<td>URL Path—The specific URL path that identifies the traffic.</td>
<td></td>
</tr>
<tr>
<td>Engine ID</td>
<td>Identifies the type of application (including ethertype, iana-14, iana-13, lic, L7, or custom).</td>
</tr>
<tr>
<td>Application Tag</td>
<td>System generated tag which can be used when multiple NAMs are being monitored.</td>
</tr>
<tr>
<td>Description</td>
<td>(Optional) Custom description to define your application. Limited to 75 characters.</td>
</tr>
<tr>
<td>Status</td>
<td>Active means that network traffic is being analyzed. Inactive means that the application is not being analyzed, possibly due to a duplication of effort. The Interactive Report filter may still list inactive applications if there is any historical data for the inactive application in the database, but it is not collecting new data.</td>
</tr>
</tbody>
</table>

Applications Window

Table D-28 describes the critical fields on the Applications Window.

Table D-28  Applications

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application</td>
<td>Unique 1 to 64 character descriptive name.</td>
</tr>
<tr>
<td>Rule</td>
<td>Displays application type: Protocol, HTTP URL-based or Server IP Address.</td>
</tr>
</tbody>
</table>
Table D-28  Applications (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selector</td>
<td>An arbitrary number up to 4-digits, unique within an engine-id. It is automatically assigned if left blank. This allows you to configure applications consistently across multiple NAMs, so that the same user-created application is exported with the same value. This should be used when configuring the same custom applications on multiple NAMs. The application tag for user-created applications is a combination of the engine ID and the selector. The 32 bit number is generated by using the engine ID as the highest order byte, and the selector makes up the other 3 bytes. For standard application/protocols, the application tag is predefined.</td>
</tr>
<tr>
<td>Engine ID</td>
<td>Identifies the type of application (including ethertype, iana-14, iana-13, lic, L7, or custom)</td>
</tr>
<tr>
<td>Application ID</td>
<td>System generated tag which can be used when multiple NAMs are being monitored.</td>
</tr>
<tr>
<td>Description</td>
<td>If a system-defined, contains system information about the application type. If user-defined, enter custom description to define your application. Limited to 75 characters.</td>
</tr>
<tr>
<td>Status</td>
<td>Active means that network traffic is being analyzed. Inactive means that the application is not being analyzed, possibly due to a duplication of effort. The Interactive Report filter may still list inactive applications, but it is not monitored by NAM and is therefore not classified or displayed on NAM dashboards.</td>
</tr>
</tbody>
</table>

**URL-Based Applications Window**

Table D-29 describes the critical fields on the URL-Based Applications window.

Table D-29  URL-Based Applications

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Index</td>
<td>A unique number (1-64) of each URL-based application. You can define up to 64 URL-based applications in NAM.</td>
</tr>
<tr>
<td>Host</td>
<td>Matching criteria in the host portion of the URL string appears in HTTP packets. This match is a POSIX Regular Expression¹.</td>
</tr>
<tr>
<td>Path</td>
<td>Matching criteria in the path portion of the URL string appears in HTTP packets. This match is a POSIX Regular Expression¹.</td>
</tr>
<tr>
<td>Content-Type</td>
<td>Matching criteria in the Content-Type field of the HTTP packets. This match is a POSIX Regular Expression¹.</td>
</tr>
<tr>
<td>Protocol Description</td>
<td>Description of this URL-based application.</td>
</tr>
</tbody>
</table>
1. A regular expression provides a concise and flexible means for matching strings of text, such as particular characters, words, or patterns of characters. A regular expression is written in a formal language that can be interpreted by a regular expression processor, a program that either serves as a parser generator or examines text and identifies parts that match the provided specification. The IEEE POSIX Basic Regular Expressions (BRE) standard (released alongside an alternative flavor called Extended Regular Expressions or ERE) was designed mostly for backward compatibility with the traditional (Simple Regular Expression) syntax but provided a common standard which has since been adopted as the default syntax of many Unix regular expression tools, though there is often some variation or additional features. Many such tools also provide support for ERE syntax with command line arguments. In the BRE syntax, most characters are treated as literals - they match only themselves (in other words, a matches "a").

Response Time Configuration Window

Table D-30 describes the critical fields on the Response Time Configuration Window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Range 1 (µs)</td>
<td>Upper response time limit for the first container</td>
<td>Enter a number in microseconds. The default is 1 to 1,000 µs</td>
</tr>
<tr>
<td>Range 2 (µs)</td>
<td>Upper response time limit for the second container</td>
<td>Enter a number in microseconds. The default is 1,001 to 5,000 µs</td>
</tr>
<tr>
<td>Range 3 (µs)</td>
<td>Upper response time limit for the third container</td>
<td>Enter a number in microseconds. The default is 5,001 to 10,000 µs</td>
</tr>
<tr>
<td>Range 4 (µs)</td>
<td>Upper response time limit for the fourth container</td>
<td>Enter a number in microseconds. The default is 10,001 to 50,000 µs</td>
</tr>
<tr>
<td>Range 5 (µs)</td>
<td>Upper response time limit for the fifth container</td>
<td>Enter a number in microseconds. The default is 50,001 to 100,000 µs</td>
</tr>
<tr>
<td>Range 6 (µs)</td>
<td>Upper response time limit for the sixth container</td>
<td>Enter a number in microseconds. The default is 100,001 to 500,000 µs</td>
</tr>
<tr>
<td>Range 7 (µs)</td>
<td>Upper response time limit for the seventh container</td>
<td>Enter a number in microseconds. The default is 500,001 to 1,000,000 µs</td>
</tr>
<tr>
<td>Range 8 (µs)</td>
<td>Upper response time limit for the eighth container. This is the maximum interval that Prime NAM waits for a server response to a client request.</td>
<td>This range cannot be edited. Enter a number in microseconds. The default is 1,000,001 µs to infinity.</td>
</tr>
</tbody>
</table>

Media Monitor Setup Window

Table D-31 describes the critical fields on the Media Monitor Setup Window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Voice Monitoring</td>
<td>Enables voice monitoring. Ensure this check box is selected if you are interested in voice monitoring.</td>
</tr>
</tbody>
</table>

| MOS Values |
**URL Collection Configuration Window**

Table D-32 describes the critical fields on the URL Collection Configuration Window.

**Table D-32**  **URL Collection Configuration Dialog Box**

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Source</td>
<td>Identifies type of traffic incoming from the application.</td>
<td>Select one of the options from the drop-down box.</td>
</tr>
</tbody>
</table>
**Table D-32**  
*URL Collection Configuration Dialog Box (continued)*

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Max Entries</td>
<td>Maximum number of URLs to collect.</td>
<td>Select one of the following options from the drop-down box:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 100</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 500</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 1000</td>
</tr>
<tr>
<td>Match only</td>
<td>The application URL to match.</td>
<td>Optional parameter to limit collection of URLs that match the regular</td>
</tr>
<tr>
<td></td>
<td></td>
<td>expression of this field.</td>
</tr>
</tbody>
</table>

**NetFlow Export Template Window**

*Table D-33* describes the critical fields on the NetFlow Export Template Window.

**Table D-33**  
*NetFlow Export Template Window*

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>A description of the NetFlow Export.</td>
</tr>
<tr>
<td>Destination IP Address</td>
<td>The IP address of the device to be exported to. IPv4 and IPv6 addresses are supported.</td>
</tr>
<tr>
<td>Destination Port</td>
<td>The port number of the device to be exported to. Valid characters: 1-9. Length: Min 1, Max 65535.</td>
</tr>
<tr>
<td>Export Record Type</td>
<td>The record types supported by NAM for NetFlow are:</td>
</tr>
<tr>
<td></td>
<td>• Client Server Response Time</td>
</tr>
<tr>
<td></td>
<td>• Application Conversation</td>
</tr>
<tr>
<td></td>
<td>• Network Conversation</td>
</tr>
<tr>
<td></td>
<td>• RTP Metrics</td>
</tr>
<tr>
<td>Export Interval</td>
<td>This will be five minutes for Client Server Response Time and one minute for the other record type.</td>
</tr>
</tbody>
</table>
Monitor User Interface Windows

Table D-34 and Table D-35 describe the various optional and data templates.

Table D-34  Optional Templates

<table>
<thead>
<tr>
<th>ID</th>
<th>Length</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application Template</td>
<td></td>
<td></td>
</tr>
<tr>
<td>95</td>
<td>4</td>
<td>Application ID</td>
</tr>
<tr>
<td>96</td>
<td>24</td>
<td>Application Name</td>
</tr>
<tr>
<td>94</td>
<td>55</td>
<td>Application Description</td>
</tr>
<tr>
<td>Site Template</td>
<td></td>
<td></td>
</tr>
<tr>
<td>42006</td>
<td>4</td>
<td>Site ID</td>
</tr>
<tr>
<td>42016</td>
<td>24</td>
<td>Site Name</td>
</tr>
<tr>
<td>42017</td>
<td>55</td>
<td>Site Description</td>
</tr>
<tr>
<td>Data Source Template</td>
<td></td>
<td></td>
</tr>
<tr>
<td>42001</td>
<td>4</td>
<td>Data source ID</td>
</tr>
<tr>
<td>42018</td>
<td>24</td>
<td>Data source name</td>
</tr>
<tr>
<td>42019</td>
<td>55</td>
<td>Data source description</td>
</tr>
</tbody>
</table>
### Table D-35  Data Templates

<table>
<thead>
<tr>
<th>ID</th>
<th>Length</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Network Conversation IPv4 Template</td>
</tr>
<tr>
<td>8</td>
<td>4</td>
<td>IPv4 source address</td>
</tr>
<tr>
<td>12</td>
<td>4</td>
<td>IPv4 destination address</td>
</tr>
<tr>
<td>42002</td>
<td>4</td>
<td>source site ID</td>
</tr>
<tr>
<td>42003</td>
<td>4</td>
<td>destination site ID</td>
</tr>
<tr>
<td>42001</td>
<td>4</td>
<td>data source ID</td>
</tr>
<tr>
<td>10</td>
<td>4</td>
<td>input SNMP if-index</td>
</tr>
<tr>
<td>14</td>
<td>4</td>
<td>output SNMP if-index</td>
</tr>
<tr>
<td>58</td>
<td>2</td>
<td>input VLAN ID</td>
</tr>
<tr>
<td>59</td>
<td>2</td>
<td>output VLAN ID</td>
</tr>
<tr>
<td>195</td>
<td>1</td>
<td>input DSCP</td>
</tr>
<tr>
<td>98</td>
<td>1</td>
<td>output DSCP</td>
</tr>
<tr>
<td>151</td>
<td>4</td>
<td>flow end seconds</td>
</tr>
<tr>
<td>1</td>
<td>8</td>
<td>byte count</td>
</tr>
<tr>
<td>2</td>
<td>8</td>
<td>packet count</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Network Conversation IPv6 Template</td>
</tr>
<tr>
<td>27</td>
<td>16</td>
<td>IPv6 source address</td>
</tr>
<tr>
<td>28</td>
<td>16</td>
<td>IPv6 destination address</td>
</tr>
<tr>
<td>42002</td>
<td>4</td>
<td>source site ID</td>
</tr>
<tr>
<td>42003</td>
<td>4</td>
<td>destination site ID</td>
</tr>
<tr>
<td>42001</td>
<td>4</td>
<td>data source ID</td>
</tr>
<tr>
<td>10</td>
<td>4</td>
<td>input SNMP if-index</td>
</tr>
<tr>
<td>14</td>
<td>4</td>
<td>output SNMP if-index</td>
</tr>
<tr>
<td>58</td>
<td>2</td>
<td>input VLAN ID</td>
</tr>
<tr>
<td>59</td>
<td>2</td>
<td>output VLAN ID</td>
</tr>
<tr>
<td>195</td>
<td>1</td>
<td>input DSCP</td>
</tr>
<tr>
<td>98</td>
<td>1</td>
<td>output DSCP</td>
</tr>
<tr>
<td>151</td>
<td>4</td>
<td>flow end seconds</td>
</tr>
<tr>
<td>1</td>
<td>8</td>
<td>byte count</td>
</tr>
<tr>
<td>2</td>
<td>8</td>
<td>packet count</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Application Conversation IPv4 Templates</td>
</tr>
<tr>
<td>8</td>
<td>4</td>
<td>IPv4 source address</td>
</tr>
<tr>
<td>12</td>
<td>4</td>
<td>IPv4 destination address</td>
</tr>
<tr>
<td>42002</td>
<td>4</td>
<td>source site ID</td>
</tr>
<tr>
<td>42003</td>
<td>4</td>
<td>destination site ID</td>
</tr>
</tbody>
</table>
### Table D-35: Data Templates (continued)

<table>
<thead>
<tr>
<th>ID</th>
<th>Length</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>42001</td>
<td>4</td>
<td>data source ID</td>
</tr>
<tr>
<td>95</td>
<td>4</td>
<td>application ID</td>
</tr>
<tr>
<td>42010</td>
<td>4</td>
<td>network encapsulation ID</td>
</tr>
<tr>
<td>10</td>
<td>4</td>
<td>input SNMP if-index</td>
</tr>
<tr>
<td>14</td>
<td>4</td>
<td>output SNMP if-index</td>
</tr>
<tr>
<td>58</td>
<td>2</td>
<td>input VLAN ID</td>
</tr>
<tr>
<td>59</td>
<td>2</td>
<td>output VLAN ID</td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>protocol</td>
</tr>
<tr>
<td>195</td>
<td>1</td>
<td>input DSCP</td>
</tr>
<tr>
<td>98</td>
<td>1</td>
<td>output DSCP</td>
</tr>
<tr>
<td>151</td>
<td>4</td>
<td>flow end seconds</td>
</tr>
<tr>
<td>1</td>
<td>8</td>
<td>byte count</td>
</tr>
<tr>
<td>2</td>
<td>8</td>
<td>packet count</td>
</tr>
</tbody>
</table>

#### Application Conversation IPv6 Templates

<table>
<thead>
<tr>
<th>ID</th>
<th>Length</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>8</td>
<td>4</td>
<td>IPv4 source address</td>
</tr>
<tr>
<td>12</td>
<td>4</td>
<td>IPv4 destination address</td>
</tr>
<tr>
<td>27</td>
<td>16</td>
<td>IPv6 source address</td>
</tr>
<tr>
<td>28</td>
<td>16</td>
<td>IPv6 destination address</td>
</tr>
</tbody>
</table>

#### Application Response Time IPv4 Templates

<table>
<thead>
<tr>
<th>ID</th>
<th>Length</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>42004</td>
<td>4</td>
<td>server site</td>
</tr>
<tr>
<td>42007</td>
<td>4</td>
<td>server IPv4 address</td>
</tr>
<tr>
<td>42005</td>
<td>4</td>
<td>client site</td>
</tr>
<tr>
<td>42008</td>
<td>4</td>
<td>client IPv4 address</td>
</tr>
<tr>
<td>95</td>
<td>4</td>
<td>app ID</td>
</tr>
<tr>
<td>42001</td>
<td>4</td>
<td>data source</td>
</tr>
<tr>
<td>58</td>
<td>2</td>
<td>VLAN ID</td>
</tr>
<tr>
<td>195</td>
<td>1</td>
<td>DSCP</td>
</tr>
<tr>
<td>151</td>
<td>4</td>
<td>duration of the flow</td>
</tr>
<tr>
<td>42010</td>
<td>4</td>
<td>net encapsulation</td>
</tr>
<tr>
<td>32792</td>
<td>2</td>
<td>server port</td>
</tr>
<tr>
<td>42020</td>
<td>1</td>
<td>waas optimization segments</td>
</tr>
<tr>
<td>42060</td>
<td>4</td>
<td>number of responses</td>
</tr>
<tr>
<td>42061</td>
<td>4</td>
<td>number of responses in bucket1</td>
</tr>
<tr>
<td>42062</td>
<td>4</td>
<td>number of responses in bucket2</td>
</tr>
<tr>
<td>42063</td>
<td>4</td>
<td>number of responses in bucket3</td>
</tr>
<tr>
<td>42064</td>
<td>4</td>
<td>number of responses in bucket4</td>
</tr>
</tbody>
</table>
### Table D-35  Data Templates (continued)

<table>
<thead>
<tr>
<th>ID</th>
<th>Length</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>42065</td>
<td>4</td>
<td>number of responses in bucket5</td>
</tr>
<tr>
<td>42066</td>
<td>4</td>
<td>number of responses in bucket6</td>
</tr>
<tr>
<td>42067</td>
<td>4</td>
<td>number of responses in bucket7</td>
</tr>
<tr>
<td>42068</td>
<td>4</td>
<td>number of late responses</td>
</tr>
<tr>
<td>42071</td>
<td>4</td>
<td>sum response time</td>
</tr>
<tr>
<td>42072</td>
<td>4</td>
<td>maximum response time</td>
</tr>
<tr>
<td>42073</td>
<td>4</td>
<td>minimum response time</td>
</tr>
<tr>
<td>42074</td>
<td>4</td>
<td>sum application response time</td>
</tr>
<tr>
<td>42075</td>
<td>4</td>
<td>maximum application response time</td>
</tr>
<tr>
<td>42076</td>
<td>4</td>
<td>minimum application response time</td>
</tr>
<tr>
<td>42077</td>
<td>4</td>
<td>sum total response time</td>
</tr>
<tr>
<td>42078</td>
<td>4</td>
<td>maximum total response time</td>
</tr>
<tr>
<td>42079</td>
<td>4</td>
<td>minimum total response time</td>
</tr>
<tr>
<td>42040</td>
<td>4</td>
<td>sum number of transaction</td>
</tr>
<tr>
<td>42041</td>
<td>4</td>
<td>sum transaction time</td>
</tr>
<tr>
<td>42042</td>
<td>4</td>
<td>maximum transaction time</td>
</tr>
<tr>
<td>42043</td>
<td>4</td>
<td>minimum transaction time</td>
</tr>
<tr>
<td>42050</td>
<td>4</td>
<td>number of new connections</td>
</tr>
<tr>
<td>42054</td>
<td>4</td>
<td>sum session duration</td>
</tr>
<tr>
<td>42084</td>
<td>4</td>
<td>sum client network time</td>
</tr>
<tr>
<td>42085</td>
<td>4</td>
<td>maximum client network time</td>
</tr>
<tr>
<td>42086</td>
<td>4</td>
<td>minimum client network time</td>
</tr>
<tr>
<td>42087</td>
<td>4</td>
<td>sum server network time</td>
</tr>
<tr>
<td>42088</td>
<td>4</td>
<td>maximum server network time</td>
</tr>
<tr>
<td>42089</td>
<td>4</td>
<td>minimum server network time</td>
</tr>
<tr>
<td>42081</td>
<td>4</td>
<td>sum network delay</td>
</tr>
</tbody>
</table>

### Application Response Time IPv6 Templates

<table>
<thead>
<tr>
<th>ID</th>
<th>Length</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>42004</td>
<td>4</td>
<td>server site</td>
</tr>
<tr>
<td>28</td>
<td>16</td>
<td>server IPv6 address</td>
</tr>
<tr>
<td>42005</td>
<td>4</td>
<td>client site</td>
</tr>
<tr>
<td>27</td>
<td>16</td>
<td>client IPv6 address</td>
</tr>
<tr>
<td>95</td>
<td>4</td>
<td>app ID</td>
</tr>
<tr>
<td>42001</td>
<td>4</td>
<td>data source</td>
</tr>
<tr>
<td>58</td>
<td>2</td>
<td>VLAN ID</td>
</tr>
<tr>
<td>195</td>
<td>1</td>
<td>DSCP</td>
</tr>
<tr>
<td>151</td>
<td>4</td>
<td>duration of the flow</td>
</tr>
</tbody>
</table>
### Table D-35  Data Templates (continued)

<table>
<thead>
<tr>
<th>ID</th>
<th>Length</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>42010</td>
<td>4</td>
<td>net encapsulation</td>
</tr>
<tr>
<td>32792</td>
<td>2</td>
<td>server port</td>
</tr>
<tr>
<td>42020</td>
<td>1</td>
<td>waas optimization segments</td>
</tr>
<tr>
<td>42060</td>
<td>4</td>
<td>number of responses</td>
</tr>
<tr>
<td>42061</td>
<td>4</td>
<td>number of responses in bucket1</td>
</tr>
<tr>
<td>42062</td>
<td>4</td>
<td>number of responses in bucket2</td>
</tr>
<tr>
<td>42063</td>
<td>4</td>
<td>number of responses in bucket3</td>
</tr>
<tr>
<td>42064</td>
<td>4</td>
<td>number of responses in bucket4</td>
</tr>
<tr>
<td>42065</td>
<td>4</td>
<td>number of responses in bucket5</td>
</tr>
<tr>
<td>42066</td>
<td>4</td>
<td>number of responses in bucket6</td>
</tr>
<tr>
<td>42067</td>
<td>4</td>
<td>number of responses in bucket7</td>
</tr>
<tr>
<td>42068</td>
<td>4</td>
<td>number of late responses</td>
</tr>
<tr>
<td>42071</td>
<td>4</td>
<td>sum response time</td>
</tr>
<tr>
<td>42072</td>
<td>4</td>
<td>maximum response time</td>
</tr>
<tr>
<td>42073</td>
<td>4</td>
<td>minimum response time</td>
</tr>
<tr>
<td>42074</td>
<td>4</td>
<td>sum application response time</td>
</tr>
<tr>
<td>42075</td>
<td>4</td>
<td>maximum application response time</td>
</tr>
<tr>
<td>42076</td>
<td>4</td>
<td>minimum application response time</td>
</tr>
<tr>
<td>42077</td>
<td>4</td>
<td>sum total response time</td>
</tr>
<tr>
<td>42078</td>
<td>4</td>
<td>maximum total response time</td>
</tr>
<tr>
<td>42079</td>
<td>4</td>
<td>minimum total response time</td>
</tr>
<tr>
<td>42040</td>
<td>4</td>
<td>sum number of transaction</td>
</tr>
<tr>
<td>42041</td>
<td>4</td>
<td>sum transaction time</td>
</tr>
<tr>
<td>42042</td>
<td>4</td>
<td>maximum transaction time</td>
</tr>
<tr>
<td>42043</td>
<td>4</td>
<td>minimum transaction time</td>
</tr>
<tr>
<td>42050</td>
<td>4</td>
<td>number of new connections</td>
</tr>
<tr>
<td>42054</td>
<td>4</td>
<td>sum session duration</td>
</tr>
<tr>
<td>42084</td>
<td>4</td>
<td>sum client network time</td>
</tr>
<tr>
<td>42085</td>
<td>4</td>
<td>maximum client network time</td>
</tr>
<tr>
<td>42086</td>
<td>4</td>
<td>minimum client network time</td>
</tr>
<tr>
<td>42087</td>
<td>4</td>
<td>sum server network time</td>
</tr>
<tr>
<td>42088</td>
<td>4</td>
<td>maximum server network time</td>
</tr>
<tr>
<td>42089</td>
<td>4</td>
<td>minimum server network time</td>
</tr>
</tbody>
</table>

### RTP IPv4 Templates

<table>
<thead>
<tr>
<th>ID</th>
<th>Length</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>8</td>
<td>4</td>
<td>source IPv4 Address</td>
</tr>
<tr>
<td>12</td>
<td>4</td>
<td>destination IPv4 Address</td>
</tr>
</tbody>
</table>
### Table D-35  Data Templates (continued)

<table>
<thead>
<tr>
<th>ID</th>
<th>Length</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>42002</td>
<td>4</td>
<td>source site</td>
</tr>
<tr>
<td>42003</td>
<td>4</td>
<td>destination site</td>
</tr>
<tr>
<td>42101</td>
<td>4</td>
<td>rtp ssrc</td>
</tr>
<tr>
<td>42102</td>
<td>1</td>
<td>rtp payload type</td>
</tr>
<tr>
<td>7</td>
<td>2</td>
<td>source port</td>
</tr>
<tr>
<td>11</td>
<td>2</td>
<td>destination port</td>
</tr>
<tr>
<td>195</td>
<td>1</td>
<td>DSCP</td>
</tr>
<tr>
<td>58</td>
<td>2</td>
<td>VLAN ID</td>
</tr>
<tr>
<td>151</td>
<td>4</td>
<td>flow end seconds</td>
</tr>
<tr>
<td>42001</td>
<td>4</td>
<td>data source</td>
</tr>
<tr>
<td>42010</td>
<td>4</td>
<td>net encap</td>
</tr>
<tr>
<td>42112</td>
<td>4</td>
<td>rtp duration</td>
</tr>
<tr>
<td>42113</td>
<td>4</td>
<td>average MOSx100</td>
</tr>
<tr>
<td>42115</td>
<td>4</td>
<td>worst/lowest MOSx100</td>
</tr>
<tr>
<td>37023</td>
<td>4</td>
<td>jitter x 100</td>
</tr>
<tr>
<td>37019</td>
<td>4</td>
<td>actual packet loss count</td>
</tr>
<tr>
<td>37014</td>
<td>4</td>
<td>expected packet count</td>
</tr>
</tbody>
</table>

**RTP IPv6 Templates**

<table>
<thead>
<tr>
<th>ID</th>
<th>Length</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>27</td>
<td>4</td>
<td>source IPv6 Address</td>
</tr>
<tr>
<td>28</td>
<td>4</td>
<td>destination IPv6 Address</td>
</tr>
<tr>
<td>42002</td>
<td>4</td>
<td>source site</td>
</tr>
<tr>
<td>42003</td>
<td>4</td>
<td>destination site</td>
</tr>
<tr>
<td>42101</td>
<td>4</td>
<td>rtp ssrc</td>
</tr>
<tr>
<td>42102</td>
<td>1</td>
<td>rtp payload type</td>
</tr>
<tr>
<td>7</td>
<td>2</td>
<td>source port</td>
</tr>
<tr>
<td>11</td>
<td>2</td>
<td>destination port</td>
</tr>
<tr>
<td>195</td>
<td>1</td>
<td>DSCP</td>
</tr>
<tr>
<td>58</td>
<td>2</td>
<td>VLAN ID</td>
</tr>
<tr>
<td>151</td>
<td>4</td>
<td>flow end seconds</td>
</tr>
<tr>
<td>42001</td>
<td>4</td>
<td>data source</td>
</tr>
<tr>
<td>42010</td>
<td>4</td>
<td>net encap</td>
</tr>
<tr>
<td>42112</td>
<td>4</td>
<td>rtp duration</td>
</tr>
<tr>
<td>42113</td>
<td>4</td>
<td>average MOSx100</td>
</tr>
<tr>
<td>42115</td>
<td>4</td>
<td>worst/lowest MOSx100</td>
</tr>
<tr>
<td>37023</td>
<td>4</td>
<td>jitter x 100</td>
</tr>
</tbody>
</table>
This section describes field descriptions for the following windows:

- All Alarms Table
- Applications Detail
- Application Groups Detail
- Client-Server Application Responses Window
- Client-Server Application Transactions Window
- Client-Server Network Responses Window
- DSCP Detail
- Host Detail
- Interfaces Stats Table
- Last 50 Alarms
- Server Application Responses Metrics
- Server Application Transactions Metrics
- Server Network Responses Window

### Table D-35 Data Templates (continued)

<table>
<thead>
<tr>
<th>ID</th>
<th>Length</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>37019</td>
<td>4</td>
<td>actual packet loss count</td>
</tr>
<tr>
<td>37014</td>
<td>4</td>
<td>expected packet count</td>
</tr>
</tbody>
</table>

---

"Cisco Prime Network Analysis Module User Guide"
# All Alarms Table

Table D-36 describes the critical fields on the All Alarms table.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Site</strong></td>
<td>This contains site or source and destination sites (source - destination) of the network traffic that generated the alarm message.</td>
</tr>
<tr>
<td><strong>Alarm Triggered By</strong></td>
<td>Details information of the network traffic that generated the alarm message. The format of the alarm triggered by string are:</td>
</tr>
<tr>
<td></td>
<td>• Triggered by application threshold: application</td>
</tr>
<tr>
<td></td>
<td>• Triggered by application with DSCP threshold: DSCP:codepoint - application</td>
</tr>
<tr>
<td></td>
<td>• Triggered by host threshold: host</td>
</tr>
<tr>
<td></td>
<td>• Triggered by host with application threshold: host - application</td>
</tr>
<tr>
<td></td>
<td>• Triggered by host with application and DSCP: DSCP: code point - host - application</td>
</tr>
<tr>
<td></td>
<td>• Triggered by host with DSCP: DSCP: code point - host</td>
</tr>
<tr>
<td></td>
<td>• Triggered by conversation: source - destination</td>
</tr>
<tr>
<td></td>
<td>• Triggered by conversation with application: source - application - destination</td>
</tr>
<tr>
<td></td>
<td>• Triggered by response time: IAP: client - application - server.</td>
</tr>
<tr>
<td></td>
<td>• Triggered by DSCP: DSCP: code point</td>
</tr>
<tr>
<td></td>
<td>• Triggered by RTP stream: source - source port - codec(codec string) - SSRC(number) - destination - destination port</td>
</tr>
<tr>
<td></td>
<td>• Triggered by voice signaling: Calling (address - number) Called (address - number) ID/References (id() - ref (calling:called))</td>
</tr>
<tr>
<td></td>
<td>• Triggered by NetFlow interfaces: NetFlow: Device (address) - If-Index(number) - Ingress/Egress</td>
</tr>
<tr>
<td><strong>Threshold Variable</strong></td>
<td>Parameter of the threshold that is used to evaluate alarm condition.</td>
</tr>
<tr>
<td><strong>Threshold Value</strong></td>
<td>User defined rising value of the threshold variable.</td>
</tr>
<tr>
<td><strong>Triggered Time</strong></td>
<td>Time when the alarm condition was found occurred.</td>
</tr>
<tr>
<td><strong>Triggered Value</strong></td>
<td>Parameter value when the alarm condition was raised. Note: The triggered value could be - when the viewing window does not included the alarm when it was occurring.</td>
</tr>
<tr>
<td><strong>Clear Time</strong></td>
<td>Time when the alarm condition was resolved. The alarm variable has fallen below the falling threshold value.</td>
</tr>
</tbody>
</table>
Applications Detail Window

Table D-37 describes the critical fields in this window.

Table D-37  Applications Detail

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application</td>
<td>Software services classified by NAM from analyze and monitor traffic.</td>
</tr>
<tr>
<td>Application Group</td>
<td>The application group (set of applications that can be</td>
</tr>
<tr>
<td></td>
<td>monitored as a whole).</td>
</tr>
<tr>
<td>Bytes/sec</td>
<td>Traffic rate; number of bytes per second</td>
</tr>
<tr>
<td>Packets/sec</td>
<td>Traffic rate; number of packets per second</td>
</tr>
</tbody>
</table>

Application Groups Detail Window

Table D-38 describes the critical fields in this window.

Table D-38  Application Groups Detail

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application Group</td>
<td>The application group (set of applications that can be</td>
</tr>
<tr>
<td>Site</td>
<td>Applicable site (or Unassigned if no site)</td>
</tr>
<tr>
<td>Bytes/sec</td>
<td>Traffic rate; number of bytes per second</td>
</tr>
<tr>
<td>Packets/sec</td>
<td>Traffic rate; number of packets per second</td>
</tr>
</tbody>
</table>

Application Response Time (ART) Metrics

Table D-39 describes the metrics measured for response time.

Table D-39  Application Response Time (ART) Metrics

<table>
<thead>
<tr>
<th>Metric</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average Response Time</td>
<td>Response Time is the time between the client request and the first response packet from the server, as observed at the NAM probing point. Increases in the response time usually indicate problems with server resources, such as the CPU, Memory, Disk, or I/O due to a lack of necessary resources or a poorly written application. This and other Response Time metrics are in microseconds (µs) units.</td>
</tr>
<tr>
<td>Min Response Time</td>
<td></td>
</tr>
<tr>
<td>Max Response Time</td>
<td></td>
</tr>
<tr>
<td>Number of Responses</td>
<td>Total number of request-response pairs observed during the monitoring interval</td>
</tr>
<tr>
<td>Number of Late Responses</td>
<td>Total number of responses that exceed the Max Response Time</td>
</tr>
<tr>
<td>Number of Responses 1</td>
<td>Number of responses with a response time less than RspTime1 threshold</td>
</tr>
<tr>
<td>Number of Responses 2</td>
<td>Number of responses with response time less than RspTime2 and larger than RspTime1</td>
</tr>
<tr>
<td>Number of Responses 3</td>
<td>Number of responses with response time less than RspTime3 and larger than RspTime2</td>
</tr>
<tr>
<td>Number of Responses 4</td>
<td>Number of responses with response time less than RspTime4 and larger than RspTime3</td>
</tr>
<tr>
<td>Number of Responses 5</td>
<td>Number of responses with response time less than RspTime5 and larger than RspTime4</td>
</tr>
</tbody>
</table>
### Table D-39 Application Response Time (ART) Metrics (continued)

<table>
<thead>
<tr>
<th>Metric</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Responses 6</td>
<td>Number of responses with response time less than RspTime6 and larger than RspTime5</td>
</tr>
<tr>
<td>Number of Responses 7</td>
<td>Number of responses with response time less than LateRsp and larger than RspTime6</td>
</tr>
<tr>
<td>Client Bits</td>
<td>Number of TCP payload bits sent from the client(s) during the monitoring interval</td>
</tr>
<tr>
<td>Server Bits</td>
<td>Number of TCP payload bits sent from the server(s) during the monitoring interval</td>
</tr>
<tr>
<td>Client Packets</td>
<td>Number of TCP packets sent from the client(s) during the monitoring interval</td>
</tr>
<tr>
<td>Server Packets</td>
<td>Number of TCP packets sent from the server(s) during the monitoring interval</td>
</tr>
<tr>
<td>Average number of concurrent connections</td>
<td>Average number of concurrent TCP connections during the reporting interval</td>
</tr>
<tr>
<td>Number of new connections</td>
<td>Number of new TCP connections made (TCP 3-way handshake) during the monitoring interval</td>
</tr>
<tr>
<td>Number of closed connections</td>
<td>Number of TCP connections closed during the monitoring interval</td>
</tr>
<tr>
<td>Number of unresponsive connections</td>
<td>Number of TCP connection requests (SYN) that are not responded during the monitoring interval</td>
</tr>
<tr>
<td>Number of refused connections</td>
<td>Number of TCP connection requests (SYN) that are refused during the monitoring interval</td>
</tr>
<tr>
<td>Average Connection duration</td>
<td>Average duration of TCP connections during the monitoring interval</td>
</tr>
<tr>
<td>Average Server Response Time</td>
<td>Server Response Time is the time it takes an application server (for example, a web server) to respond to a request. This is the server think time, which is the time between the client request arriving at the server and the first response packet being returned by the server. Increases in the server response time usually indicate problems with application and/or server resources, such as the CPU, Memory, Disk, or I/O.</td>
</tr>
<tr>
<td>Min Server Response Time</td>
<td>Server Response Time is the time it takes an application server (for example, a web server) to respond to a request. This is the server think time, which is the time between the client request arriving at the server and the first response packet being returned by the server. Increases in the server response time usually indicate problems with application and/or server resources, such as the CPU, Memory, Disk, or I/O.</td>
</tr>
<tr>
<td>Max Server Response Time</td>
<td>Server Response Time is the time it takes an application server (for example, a web server) to respond to a request. This is the server think time, which is the time between the client request arriving at the server and the first response packet being returned by the server. Increases in the server response time usually indicate problems with application and/or server resources, such as the CPU, Memory, Disk, or I/O.</td>
</tr>
<tr>
<td>Average Network Time</td>
<td>Network time between a client and a server. Network Time is the sum of Client Network Time and Server Network Time. NAM measures the Network Time using TCP 3-way handshakes. If there are no new TCP connections made during the monitoring interval, this metric is not reported.</td>
</tr>
<tr>
<td>Min Network Time</td>
<td>Network time between a client and a server. Network Time is the sum of Client Network Time and Server Network Time. NAM measures the Network Time using TCP 3-way handshakes. If there are no new TCP connections made during the monitoring interval, this metric is not reported.</td>
</tr>
<tr>
<td>Max Network Time</td>
<td>Network time between a client and a server. Network Time is the sum of Client Network Time and Server Network Time. NAM measures the Network Time using TCP 3-way handshakes. If there are no new TCP connections made during the monitoring interval, this metric is not reported.</td>
</tr>
<tr>
<td>Average Client Network Time</td>
<td>Client Network Time is the network time between a client and the NAM switch or router.</td>
</tr>
<tr>
<td>Min Client Network Time</td>
<td>In WAAS monitoring, Client Network Time from a WAE client data source represents the network RTT between the client and its edge WAE, while Client Network Time from the WAE server data source represents the WAN RTT (between the edge and core WAES).</td>
</tr>
<tr>
<td>Max Client Network Time</td>
<td>In WAAS monitoring, Client Network Time from a WAE client data source represents the network RTT between the client and its edge WAE, while Client Network Time from the WAE server data source represents the WAN RTT (between the edge and core WAES).</td>
</tr>
<tr>
<td>Average Server Network Time</td>
<td>Server Network Time is the network time between a server and NAM probing point.</td>
</tr>
<tr>
<td>Min Server Network Time</td>
<td>Server Network Time is the network time between a server and NAM probing point.</td>
</tr>
<tr>
<td>Max Server Network Time</td>
<td>Server Network Time is the network time between a server and NAM probing point.</td>
</tr>
<tr>
<td>Average Total Response Time</td>
<td>Total Response Time is the total amount of time between the client request and when the client receives the first response packet from the server.</td>
</tr>
<tr>
<td>Min Total Response Time</td>
<td>Total Response Time is the total amount of time between the client request and when the client receives the first response packet from the server.</td>
</tr>
<tr>
<td>Max Total Response Time</td>
<td>Total Response Time is the total amount of time between the client request and when the client receives the first response packet from the server.</td>
</tr>
<tr>
<td>Average Transaction Time</td>
<td>Transaction Time is the total amount of time between the client request and the final response packet from the server.</td>
</tr>
<tr>
<td>Min Transaction Time</td>
<td>Transaction Time is the total amount of time between the client request and the final response packet from the server.</td>
</tr>
<tr>
<td>Max Transaction Time</td>
<td>Transaction Time is the total amount of time between the client request and the final response packet from the server.</td>
</tr>
</tbody>
</table>

Transaction times may vary depending upon client usages and application types. Transaction Time is a key indicator for monitoring client experiences and detecting application performance anomalies.
Table D-39  Application Response Time (ART) Metrics (continued)

<table>
<thead>
<tr>
<th>Metric</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Transactions</td>
<td>The number of transactions completed during the monitoring interval.</td>
</tr>
<tr>
<td>Average Data Transmission Time</td>
<td>Elapsed time from the first server-response packet to the last server-response packet, excluding retransmission time.</td>
</tr>
<tr>
<td>Average Data Time</td>
<td>Data Time: Average data time portion of transaction time.</td>
</tr>
<tr>
<td>Packets Retransmitted</td>
<td>Number of retransmitted packets detected during the monitoring interval.</td>
</tr>
<tr>
<td>Bits Retransmitted</td>
<td>Number of retransmitted bits detected during the monitoring interval.</td>
</tr>
<tr>
<td>Average Retransmission Time</td>
<td>Average time to retransmit lost packets per transaction</td>
</tr>
<tr>
<td>Client ACK Round Trip Time</td>
<td>Average network time for the client to acknowledge (ACK) a server data packet as observed at NAM probing point</td>
</tr>
<tr>
<td>Number of Client ACK Round Trips</td>
<td>Number of client ACK RTs observed during the monitoring interval.</td>
</tr>
</tbody>
</table>

Client Server Application Responses Window

Table D-40 provides definitions of the critical fields of the Client-Server Application Responses window.

Table D-40  Client-Server Application Responses Window

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Responses</td>
<td>Total number of responses observed during the monitoring interval</td>
</tr>
<tr>
<td>Minimum Client Network Time (ms)</td>
<td>Minimum network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
<tr>
<td>Average Client Network Time (ms)</td>
<td>Average network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
<tr>
<td>Maximum Client Network Time (ms)</td>
<td>Maximum network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
<tr>
<td>Minimum Server Network Time (ms)</td>
<td>Minimum network time between a server and NAM probing point.</td>
</tr>
<tr>
<td>Average Server Network Time (ms)</td>
<td>Average network time between a server and NAM probing point.</td>
</tr>
<tr>
<td>Maximum Server Network Time (ms)</td>
<td>Maximum network time between a server and NAM probing point.</td>
</tr>
<tr>
<td>Minimum Total Response Time (ms)</td>
<td>The total amount of time between the client request and the final response packet from the server.</td>
</tr>
<tr>
<td>Average Total Time (ms)</td>
<td>Average time (ms) elapsed from the start of a client request to the completion of server response. Transaction times might vary significantly depending upon application types. Relative thresholds are useful in this situation. Transaction time is a key indicator when detecting application performance anomalies.</td>
</tr>
<tr>
<td>Maximum Total Time (ms)</td>
<td>The total amount of time between the client request and the final response packet from the server.</td>
</tr>
</tbody>
</table>
Client-Server Application Transactions Window

Table D-41 provides definitions of critical fields in the Client-Server Application Transactions window.

**Table D-41  Client-Server Application Transactions Window**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Transactions</td>
<td>Total number of transactions observed during the monitoring interval.</td>
</tr>
<tr>
<td>Average Transaction Time (ms)</td>
<td>Average time elapsed from the start of a client request to the completion of server response. Transaction times might vary significantly depending upon application types. Relative thresholds are useful in this situation. Transaction time is a key indicator when detecting application performance anomalies.</td>
</tr>
<tr>
<td>Average Server Response Time (ms)</td>
<td>Amount of time it takes a server to send the initial response to a client request as seen by the NAM.</td>
</tr>
<tr>
<td>Average DataTransmission Time (ms)</td>
<td>Elapsed time from the first server-response packet to the last server-response packet, excluding retransmission time.</td>
</tr>
<tr>
<td>Average Retransmission Time (ms)</td>
<td>Average time to retransmit lost packets per transaction</td>
</tr>
<tr>
<td>Client ACK Round Trip Time (ms)</td>
<td>Average network time for the client to acknowledge (ACK) a server data packet as observed at NAM probing point</td>
</tr>
</tbody>
</table>

Client-Server Network Responses Window

Table D-42 describes the critical fields of the Client-Server Network Response Time window.

**Table D-42  Client-Server Network Responses Window**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimum Client Network Time (ms)</td>
<td>Minimum network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
<tr>
<td>Average Client Network Time (ms)</td>
<td>Average network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
<tr>
<td>Maximum Client Network Time (ms)</td>
<td>Maximum network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
<tr>
<td>Minimum Server Network Time (ms)</td>
<td>Minimum network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
<tr>
<td>Average Server Network Time (ms)</td>
<td>Average network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
<tr>
<td>Maximum Server Network Time (ms)</td>
<td>Maximum network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
<tr>
<td>Minimum Network Time (ms)</td>
<td>Minimum of the network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
<tr>
<td></td>
<td>Network Time is the sum of Client Network Time and Server Network Time. NAM measures the Network Time using TCP 3-way handshakes. If there are no new TCP connections made during the monitoring interval, this metric is not reported.</td>
</tr>
</tbody>
</table>
Table D-42  Client-Server Network Responses Window (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average Network Time (ms)</td>
<td>Average of the network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
<tr>
<td>Maximum Network Time (ms)</td>
<td>Maximum of the network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
</tbody>
</table>

**DSCP Detail Window**

Table D-43 describes the critical fields in this window.

Table D-43  DSCP Detail

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bytes/sec</td>
<td>Traffic rate; number of bytes per second. In Administration &gt; System &gt; Preferences, you can choose to display NAM data in Bits or Bytes.</td>
</tr>
<tr>
<td>Packets/sec</td>
<td>Traffic rate; number of packets per second</td>
</tr>
</tbody>
</table>

**Host Detail Window**

Table D-44 describes the critical fields in this window.

Table D-44  Host Detail

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>InBits/sec</td>
<td>Number of bits per second incoming</td>
</tr>
<tr>
<td>InPackets/sec</td>
<td>Number of packets per second incoming</td>
</tr>
<tr>
<td>OutBits/sec</td>
<td>Number of bits per second outgoing</td>
</tr>
<tr>
<td>OutPackets/sec</td>
<td>Number of packets per second outgoing</td>
</tr>
</tbody>
</table>

**Interfaces Stats Table**

Table D-45 describes the critical fields in the Interfaces Stats table.

Table D-45  Interfaces Stats Table

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interface</td>
<td>Interface number.</td>
</tr>
<tr>
<td>In % Utilization</td>
<td>Utilization percentage of the port.</td>
</tr>
<tr>
<td>Out % Utilization</td>
<td>Utilization percentage of the port.</td>
</tr>
<tr>
<td>In Packets/s</td>
<td>Number of incoming packets collected per second.</td>
</tr>
<tr>
<td>Out Packets/s</td>
<td>Number of outgoing packets sent out per second.</td>
</tr>
<tr>
<td>In Bits/s</td>
<td>Number of bits collected per second.</td>
</tr>
<tr>
<td>Out Bits/s</td>
<td>Number of bits sent out per second.</td>
</tr>
</tbody>
</table>
**Table D-45 Interfaces Stats Table (continued)**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>In Non-Unicast/s</td>
<td>Number of non-unicasts collected per second.</td>
</tr>
<tr>
<td>Out Non-Unicast/s</td>
<td>Number of non-unicasts sent out per second.</td>
</tr>
<tr>
<td>In Discards/s</td>
<td>Number of discards collected per second.</td>
</tr>
<tr>
<td>Out Discards/s</td>
<td>Number of discards sent out per second.</td>
</tr>
<tr>
<td>In Errors/s</td>
<td>Number of errors collected per second.</td>
</tr>
<tr>
<td>Out Errors/s</td>
<td>Number of errors sent out per second.</td>
</tr>
</tbody>
</table>

**Last 50 Alarms Table**

Table D-46 describes the critical fields on the Last 50 Alarms table.

**Table D-46 Last 50 Alarms**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Site</td>
<td>This contains site or source and destination sites (source - destination) of the network traffic that generated the alarm message.</td>
</tr>
<tr>
<td>Alarm Triggered By</td>
<td>Details information of the network traffic that generated the alarm message. The format of the alarm triggered by string are:</td>
</tr>
<tr>
<td></td>
<td>• Triggered by application threshold: application</td>
</tr>
<tr>
<td></td>
<td>• Triggered by application with DSCP threshold: DSCP:codepoint - application</td>
</tr>
<tr>
<td></td>
<td>• Triggered by host threshold: host</td>
</tr>
<tr>
<td></td>
<td>• Triggered by host with application threshold: host - application</td>
</tr>
<tr>
<td></td>
<td>• Triggered by host with application and DSCP: DSCP: code point - host - application</td>
</tr>
<tr>
<td></td>
<td>• Triggered by host with DSCP: DSCP: code point - host</td>
</tr>
<tr>
<td></td>
<td>• Triggered by conversation: source - destination</td>
</tr>
<tr>
<td></td>
<td>• Triggered by conversation with application: source - application - destination</td>
</tr>
<tr>
<td></td>
<td>• Triggered by response time: IAP: client - application - server.</td>
</tr>
<tr>
<td></td>
<td>• Triggered by DSCP: DSCP: code point</td>
</tr>
<tr>
<td></td>
<td>• Triggered by RTP stream: source - source port - codec(codec string) - SSRC(number) - destination - destination port</td>
</tr>
<tr>
<td></td>
<td>• Triggered by voice signaling: Calling (address - number) Called (address - number) ID/References (id() - ref (calling:called))</td>
</tr>
<tr>
<td></td>
<td>• Triggered by NetFlow interfaces: NetFlow: Device (address) - If-Index(number) - Ingress/Egress</td>
</tr>
<tr>
<td>Threshold Variable</td>
<td>Parameter of the threshold that is used to evaluate alarm condition.</td>
</tr>
<tr>
<td>Threshold Value</td>
<td>User defined rising value of the threshold variable.</td>
</tr>
<tr>
<td>Triggered Time</td>
<td>Time when the alarm condition was found occurred.</td>
</tr>
</tbody>
</table>
Table D-46       Last 50 Alarms (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Triggered Value</td>
<td>Parameter value when the alarm condition was raised. Note: The triggered value could be - when the viewing window does not included the alarm when it was occurring.</td>
</tr>
<tr>
<td>Clear Time</td>
<td>Time when the alarm condition was resolved. The alarm variable has fallen below the falling threshold value.</td>
</tr>
</tbody>
</table>

Server Application Responses Window

Table D-47 provides definitions of the critical fields of the Server Application Responses window.

Table D-47       Server Application Responses Metrics

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average Client Network Time (ms)</td>
<td>Client Network Time is the network time between a client and the NAM switch or router.</td>
</tr>
<tr>
<td>Maximum Client Network Time (ms)</td>
<td>In WAAS monitoring, Client Network Time from a WAE client data source represents the network RTT between the client and its edge WAE, while Client Network Time from the WAE server data source represents the WAN RTT (between the edge and core WAEs).</td>
</tr>
<tr>
<td>Average Server Response Time (ms)</td>
<td>Server Response Time is the time it takes an application server (for example, a web server) to respond to a request. This is the server think time, which is the time between the client request arriving at the server and the first response packet being returned by the server. Increases in the server response time usually indicate problems with application and/or server resources, such as the CPU, Memory, Disk, or I/O.</td>
</tr>
<tr>
<td>Maximum Server Response Time (ms)</td>
<td>Total Response Time is the total amount of time between the client request and when the client receives the first response packet from the server.</td>
</tr>
</tbody>
</table>
Server Application Transactions Window

Table D-48 provides definitions of the critical fields of the Server Application Transactions window.

### Table D-48 Server Application Transactions Metrics

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average Transaction Time (ms)</td>
<td>Average time (ms) elapsed from the start of a client request to the completion of server response. Transaction times might vary significantly depending upon application types. Relative thresholds are useful in this situation. Transaction time is a key indicator when detecting application performance anomalies.</td>
</tr>
<tr>
<td>Average Server Response Time (ms)</td>
<td>Amount of time it takes a server to send the initial response to a client request as seen by the NAM.</td>
</tr>
<tr>
<td>Average Data Transfer Time (ms)</td>
<td>Average elapsed time from the first server-response packet to the last server-response packet, excluding retransmission time. Data transfer time is always measured in the server-to-client direction and can be used to detect problems for a particular type of transaction of an application.</td>
</tr>
<tr>
<td>Average Retransmission Time (ms)</td>
<td>Average time to retransmit lost packets, per transaction.</td>
</tr>
<tr>
<td>Client ACK Round Trip Time (ms)</td>
<td>Average round trip time for the client to acknowledge (ACK) a server TCP packet.</td>
</tr>
</tbody>
</table>

Server Network Responses Window

Table D-49 provides definitions of the critical fields of the Server Network Response Times window.

### Table D-49 Server Network Responses Window

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average Server Network Time (ms)</td>
<td>Average of the Server Network Time (network time between a server and NAM probing point).</td>
</tr>
<tr>
<td>Maximum Server Network Time (ms)</td>
<td>Maximum of the Server Network Time (network time between a server and NAM probing point).</td>
</tr>
<tr>
<td>Average Network Time</td>
<td>Average of the network time between client and server. Network Time is the sum of Client Network Time and Server Network Time. NAM measures the Network Time using TCP 3-way handshakes. If there are no new TCP connections made during the monitoring interval, this metric is not reported.</td>
</tr>
<tr>
<td>Maximum Network Time</td>
<td>Maximum of the network time between client and server.</td>
</tr>
<tr>
<td>Server Bytes</td>
<td>Number of TCP payload bytes sent from the server(s) during the monitoring interval.</td>
</tr>
<tr>
<td>Client Bytes</td>
<td>Number of TCP payload bytes sent from the client(s) during the monitoring interval.</td>
</tr>
</tbody>
</table>
Calls Table

Table D-50 provides definitions of the critical fields of the Calls Table.

Table D-50  Calls Table

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calling Number</td>
<td>Calling number as it appears in the signaling protocol.</td>
</tr>
<tr>
<td>Called Number</td>
<td>Called number as it appears in the signaling protocol.</td>
</tr>
<tr>
<td>Calling Host Address</td>
<td>RTP receiving address of the calling party detected by the NAM from inspecting the call signaling protocol.</td>
</tr>
<tr>
<td>Calling Port</td>
<td>RTP receiving port of the calling party detected by NAM from inspecting call signaling protocol.</td>
</tr>
<tr>
<td>Calling Alias</td>
<td>Calling party name detected by NAM from inspecting call signaling protocol.</td>
</tr>
<tr>
<td>Called Host Address</td>
<td>IP address of the phone receiving the call.</td>
</tr>
<tr>
<td>Called Port</td>
<td>Port of the phone receiving the call.</td>
</tr>
<tr>
<td>Called Alias</td>
<td>Alias name, MGCP endpoint ID, or SIP URI of the called party phone.</td>
</tr>
<tr>
<td>Calling Reported Jitter (ms)</td>
<td>Jitter value reported by calling party at the end of the call.</td>
</tr>
<tr>
<td>Calling Reported Packet Loss (%)</td>
<td>Percentage of packet loss reported by calling party at the end of the call.</td>
</tr>
<tr>
<td>Start Time</td>
<td>Time when the call was detected to start.</td>
</tr>
<tr>
<td>End Time</td>
<td>Time when the call was detected to end.</td>
</tr>
<tr>
<td>Duration</td>
<td>Duration of the call.</td>
</tr>
</tbody>
</table>

Note  When the call signaling’s call tear down sequence is not detected by the NAM, the NAM will assume:
- the call ended after 3 hours in low call volume per interval
- the call ended after 1 hour in high call volume per interval (high call volume is defined as call table filled up during the interval.)

RTP Stream for Selected Call Report Statistics

Table D-51 provides definitions of the critical fields of the RTP stream statistics of a selected call calculated by the NAM.

Table D-51  RTP Streams for the Selected Call Table

<table>
<thead>
<tr>
<th>Field</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source Address</td>
<td>IP Address of the originator of the RTP stream</td>
</tr>
<tr>
<td>Source Port</td>
<td>UDP port of the originator of the RTP stream</td>
</tr>
<tr>
<td>Destination Address</td>
<td>IP address of the receiver of the RTP stream</td>
</tr>
</tbody>
</table>
**Table D-52 Video Signaling Channel**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Video Source IP/Port</td>
<td>Video stream sending IP address/L4 port of the signaling session detected by the NAM from the media signaling protocol.</td>
</tr>
<tr>
<td>Video Destination IP/Port</td>
<td>Video stream receiving IP address/L4 port of the signaling session detected by the NAM from the media signaling protocol.</td>
</tr>
<tr>
<td>Signaling Protocol</td>
<td>Signaling protocol.</td>
</tr>
<tr>
<td>Codec</td>
<td>Encoding decoding format/algorithm of the video stream.</td>
</tr>
<tr>
<td>Payload Type</td>
<td>RTP payload type in video stream detected by NAM from inspecting call signaling protocol.</td>
</tr>
<tr>
<td>Media Transport Protocol</td>
<td>Transport protocol of video stream detected by NAM from inspecting call signaling protocol.</td>
</tr>
<tr>
<td>Source Alias</td>
<td>Video source host name or calling party name detected by NAM from inspecting call signaling protocol.</td>
</tr>
<tr>
<td>Destination Alias</td>
<td>Video destination host name or calling party name detected by NAM from inspecting call signaling protocol.</td>
</tr>
<tr>
<td>SSRC</td>
<td>Synchronization source number in the RTP header from inspecting call signaling protocol.</td>
</tr>
<tr>
<td>Start Time</td>
<td>Time when the video channel was setup and detected by the NAM.</td>
</tr>
<tr>
<td>End Time</td>
<td>Time when the video channel was ended and detected by the NAM.</td>
</tr>
<tr>
<td>Duration</td>
<td>Video stream duration.</td>
</tr>
<tr>
<td>Signaling Server IP/Port</td>
<td>IP Address/L4 port of signaling server.</td>
</tr>
<tr>
<td>Signaling Client IP/Port</td>
<td>IP Address/L4 port of signaling client.</td>
</tr>
<tr>
<td>Signaling Session VLAN</td>
<td>VLAN of signaling session packets.</td>
</tr>
<tr>
<td>Signaling Transport Protocol</td>
<td>Transport layer protocol of signaling session.</td>
</tr>
</tbody>
</table>
Video Stream Conversations

Table D-53 provides definitions of the critical fields of the Video Stream Conversations.

Table D-53  Video Stream Conversations

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source Address/Port</td>
<td>IP Address/L4 port of the originator of video stream.</td>
</tr>
<tr>
<td>Destination Address/Port</td>
<td>IP Address/L4 port of the receiver of video stream.</td>
</tr>
<tr>
<td>SSRC</td>
<td>Synchronization source number as it appears in the RTP header of the video stream.</td>
</tr>
<tr>
<td>Program ID: Sortable</td>
<td>Program ID for MPEG2-TS video traffic.</td>
</tr>
<tr>
<td>Codec</td>
<td>Encoding decoding format/algorithm of the video stream.</td>
</tr>
<tr>
<td>Protocol</td>
<td>Codec protocol, it could be H264, MPEG2-TS or the others supported by NAM.</td>
</tr>
<tr>
<td>Avg I Frame Loss Rate (%)</td>
<td>I-Frame loss rate in average of this period in percentage.</td>
</tr>
<tr>
<td>Avg All Frame Loss Rate (%)</td>
<td>Frame loss rate in average of this period in percentage.</td>
</tr>
<tr>
<td>Avg DF(ms)</td>
<td>Delay Factor average of this period in unit of ms.</td>
</tr>
<tr>
<td>Avg MLR (packet(s))</td>
<td>Media Loss Rate in average of this period, it is the percentage rate of packets loss.</td>
</tr>
</tbody>
</table>

Media Signaling Sessions

Table D-54 provides definitions of the critical fields of the media signaling sessions.

Table D-54  Media Signaling Sessions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Called or Server IP/Port</td>
<td>IP Address/L4 port of video server or video sender of calling party.</td>
</tr>
<tr>
<td>Calling or Client IP/Port</td>
<td>IP Address/L4 port of video client or video receiver of calling party.</td>
</tr>
<tr>
<td>Called or Server alias</td>
<td>Calling party name detected by NAM from inspecting call signaling protocol or video server alias. It could be MGCP endpoint ID, or SIP URI of the called party phone and so on.</td>
</tr>
<tr>
<td>Calling or Client Alias</td>
<td>Called party name detected by NAM from inspecting call signaling protocol or video client alias. It could be MGCP endpoint ID, or SIP URI of the called party phone etc.</td>
</tr>
<tr>
<td>Protocol</td>
<td>Signaling protocol of this media session.</td>
</tr>
<tr>
<td>Start Time</td>
<td>Time when the signaling session was detected to start.</td>
</tr>
<tr>
<td>End Time</td>
<td>Time when the signaling session was detected to end.</td>
</tr>
<tr>
<td>Duration</td>
<td>Duration of this signaling session.</td>
</tr>
<tr>
<td>Calling Number</td>
<td>Calling number as it appears in the signaling protocol, if it is a VoIP call.</td>
</tr>
<tr>
<td>Called Number</td>
<td>Called number as it appears in the signaling protocol, if it is a VoIP call.</td>
</tr>
</tbody>
</table>
RTP Stream for Selected Media Signaling Session

Table D-55 provides definitions of the critical fields of the RTP stream statistics of a selected media signaling session.

**Table D-55  RTP Streams for the Selected Media Signaling Session**

<table>
<thead>
<tr>
<th>Field</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source Address/Port</td>
<td>IP address or UDP port of the originator of the RTP stream.</td>
</tr>
<tr>
<td>Destination Address/Port</td>
<td>IP address or UDP port of the receiver of the RTP stream.</td>
</tr>
<tr>
<td>Codec</td>
<td>Encoding decoding format/algorith of the RTP stream.</td>
</tr>
<tr>
<td>SSRC</td>
<td>Synchronization source number as it appears in the RTP header.</td>
</tr>
<tr>
<td>Duration Weighted MOS</td>
<td>NAM calculated score that takes into account of the duration of the stream.</td>
</tr>
</tbody>
</table>

RTP Conversations Table

Table D-56 provides definitions of the critical fields of the RTP Conversations Table.

**Table D-56  RTP Conversations Table**

<table>
<thead>
<tr>
<th>Field</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Time</td>
<td>Time when the RTP stream was discovered by the NAM</td>
</tr>
<tr>
<td>Source Address</td>
<td>IP Address of the originator of the RTP stream</td>
</tr>
<tr>
<td>Source Port</td>
<td>UDP port of the originator of the RTP stream</td>
</tr>
<tr>
<td>Destination Address</td>
<td>IP address of the receiver of the RTP stream</td>
</tr>
<tr>
<td>Destination Port</td>
<td>UDP port of the receiver of the RTP stream</td>
</tr>
<tr>
<td>Codec</td>
<td>Encoding decoding format/algorith of the RTP stream</td>
</tr>
<tr>
<td>SSRC</td>
<td>Synchronization source number as it appear in the RTP header</td>
</tr>
<tr>
<td>Duration Weighted MOS</td>
<td>NAM calculated score that takes into account of the duration of the stream.</td>
</tr>
</tbody>
</table>

Capture User Interface Windows

This section includes the following topics:

- Capture Analysis Window, page D-42
- Capture Session Fields, page D-42
- Capture Setting Fields, page D-43
- Custom Decode Filter Dialog Box, page D-45
- Custom Decode Subexpressions Fields, page D-46
- Error Scan Window, page D-47
- Hardware Filter Dialog Box, page D-47
- NAM Packet Analyzer Decode Window, page D-48
- Software Filter Dialog Box, page D-48
Capture Analysis Window

Table D-57 describes the Capture Analysis window fields.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Capture Overview</td>
<td>Provides a summary of the displayed capture including number of packets captured, bytes captured, average packet size, capture start time, duration of capture, and data transfer rate (both bytes and bits per second)</td>
</tr>
<tr>
<td>Traffic over Time</td>
<td>Displays a graphic image of network traffic (KB/second)</td>
</tr>
<tr>
<td>Protocol Statistics</td>
<td>Displays packets and bytes transferred for each protocol</td>
</tr>
<tr>
<td>Hosts Statistics</td>
<td>Displays packets and bytes transferred for each host address</td>
</tr>
</tbody>
</table>

Capture Session Fields

Table D-58 describes the critical fields on the Capture > Packet Capture/Decode > Sessions page.

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Time</td>
<td>Time the capture was last started. You can stop and restart the capture as many times as necessary.</td>
</tr>
<tr>
<td>Size (MB) (Capture to Memory)</td>
<td>Size of the session</td>
</tr>
<tr>
<td>Size (MB) x No. files (Capture to Files)</td>
<td>Note: Capture to files indicates the capture is being stored in one or more files and is a link to those files. The capture file size is limited to 500 MB on Nexus 1000V and vNAM. On all other NAM platforms, the capture file size limit is 2,000 MB.</td>
</tr>
<tr>
<td>State</td>
<td>The current status of the capture:</td>
</tr>
<tr>
<td></td>
<td>• Running—Packet capture is in progress</td>
</tr>
<tr>
<td></td>
<td>• Stopped—Packet capture is stopped. Captured packets remain in buffer, but no new packets are captured</td>
</tr>
<tr>
<td></td>
<td>• Full—The memory or file is full, and no new packets will be captured.</td>
</tr>
<tr>
<td>Location</td>
<td>The location of the capture (Memory, Local Disk, and external storage).</td>
</tr>
</tbody>
</table>

Capture Operation Buttons

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create</td>
<td>Create a new capture session. See Configuring Capture Sessions, page 3-6.</td>
</tr>
<tr>
<td>Edit</td>
<td>Edit the settings of the selected capture.</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete a selected session. Not available if capture session is running.</td>
</tr>
<tr>
<td>Start</td>
<td>Start capturing to a selected session. The number in the Packets column for that session will start to increase.</td>
</tr>
<tr>
<td>Stop</td>
<td>Stop capturing to the selected session (no packets will go through). Capture data remains in the capture memory buffer, but no new data is stored. Click Start to resume the capture.</td>
</tr>
<tr>
<td>Clear</td>
<td>Clear captured data from memory.</td>
</tr>
</tbody>
</table>
### Table D-58 Capture Session Fields (continued)

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decode</td>
<td>Display details of the capture session.</td>
</tr>
<tr>
<td>Save to File</td>
<td>Save a session to a file on the NAM hard disk.</td>
</tr>
<tr>
<td></td>
<td>See Working with Capture Files, page 3-21.</td>
</tr>
</tbody>
</table>

### Capture Setting Fields

Table D-59 describes the Capture Settings fields.

### Table D-59 Capture Settings Fields

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Packet Slice Size</td>
<td>The slice size in bytes; used to limit the size of the captured packets.</td>
</tr>
<tr>
<td>(bytes)</td>
<td>Enter a value between 64 and 9000. Enter zero (0) to not perform slicing.</td>
</tr>
<tr>
<td></td>
<td>If you have a small session but want to capture as many packets as possible,</td>
</tr>
<tr>
<td></td>
<td>use a small slice size. If the packet size is larger than the specified sli</td>
</tr>
<tr>
<td></td>
<td>ce size, the packet is sliced before it is saved in the capture session.</td>
</tr>
<tr>
<td></td>
<td>For example, if the packet is 1000 bytes and slice size is 200 bytes, only</td>
</tr>
<tr>
<td></td>
<td>the first 200 bytes of the packet is stored in the capture session.</td>
</tr>
<tr>
<td></td>
<td>Enter values for Memory Size for this capture. Enter a number from 1 up to</td>
</tr>
<tr>
<td></td>
<td>your platform maximum. If system memory is low, the actual session size alco</td>
</tr>
<tr>
<td></td>
<td>might be less than the number specified here.</td>
</tr>
<tr>
<td></td>
<td>Check (if desired) Wrap when Full to enable continuous capture (when the</td>
</tr>
<tr>
<td></td>
<td>session is full, older packet data is removed to make room for new incoming</td>
</tr>
<tr>
<td></td>
<td>packets). If you do not check Wrap when Full, the capture will end when the</td>
</tr>
<tr>
<td></td>
<td>amount of data reaches size of session.</td>
</tr>
</tbody>
</table>

- **Capture Source**: Data-Ports or ERSPAN
  - Data-ports: This accepts SPAN, RSPAN, and VACL capture. On NAM-NX1, you can select only one data-port at a time.
  - ERSPAN: Locally terminated is recommended.

- **Note**: On some platforms, you may be limited to selecting only one of the dataports at a time. Most platforms allow you to select both dataports at once.
### Table D-59  Capture Settings Fields (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Storage Type: File(s)</td>
<td></td>
<td><strong>File Size (MB)</strong> Enter a value for <strong>File Size</strong> (file size can be from 1 MB to 500/2000 MB depending on your platform). If disk space is not available, you are not able to start new capture-to-disk sessions.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Number of Files</strong> Enter a value for <strong>Number Of Files</strong> to use for capture. The maximum is determined on the size of the file, numbers of files stored, and the amount of disk space available at the location where these files are stored.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Rotate Files</strong> Use this feature if you plan to capture sets of small files that allow you to perform instantaneous downloads, decodes, and analysis. Rotating files allows you to automatically maintain your storage space. Check the <strong>Rotate Files</strong> check box to rotate files. Available only for remote storage or NAM appliances. For information about configuring remote storage, see About Capturing to Data Storage, page 3-25. If you choose the <strong>Rotate Files</strong> option, when you reach the highest number file, the earliest file is overwritten. For example, if you specify <strong>No. Files</strong> to 10, file <strong>CaptureA_1</strong> is overwritten after the NAM writes capture data to file <strong>CaptureA_10</strong>. To determine the most recent capture, check each file’s time stamp.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>File Location</strong> If file data storage is available, choose one of the storage targets in the drop-down list. The drop-down list displays only those targets in the Ready state. Local disk is the default, or choose a previously configured remote storage location if available. Each option shows the amount of disk space available for capture packet storage. Maximum capture session size for capture to disk is determined by the available space on the capture target. You can manage these locations from the <strong>Capture &gt; Data Storage</strong> page (see Utilizing Capture Data Storage, page 3-24).</td>
</tr>
</tbody>
</table>
Custom Decode Filter Dialog Box

Table D-60 describes the critical fields on the custom decode filter window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Protocol</td>
<td>The protocol to match with the packet.</td>
<td>Choose a protocol from the list. (Select All to match all packets regardless of protocol.)</td>
</tr>
<tr>
<td>Address (MAC or IP)</td>
<td>Indicates whether to filter by MAC or IP address.</td>
<td>Choose MAC to filter using the source/destination MAC address of the packets.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Choose IP to filter using the source/destination IP addresses of the packets.</td>
</tr>
<tr>
<td>Both Directions</td>
<td>Indicates whether the filter is applied to traffic in both directions.</td>
<td>If the source is host A and the destination is host B, enabling both directions filters packets from A to B and B to A. If the source is host A and the destination is not specified, enabling both directions filters packets both to and from host A.</td>
</tr>
<tr>
<td>Offset</td>
<td>The offset (in bytes) from the Base where packet data-matching begins.</td>
<td>Enter a decimal number.</td>
</tr>
<tr>
<td>Base</td>
<td>The base from which the offset is calculated.</td>
<td>Choose absolute or a protocol.</td>
</tr>
<tr>
<td></td>
<td>If you select absolute, the offset is calculated from the absolute beginning of the packet (for example, the beginning of the Ethernet frame).</td>
<td></td>
</tr>
<tr>
<td></td>
<td>If you select protocol, the offset is calculated from the beginning of the protocol portion of the packet. If the packet does not contain the protocol, the packet fails this match.</td>
<td></td>
</tr>
</tbody>
</table>
**Table D-60 Custom Decode Filter Dialog Box (continued)**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Pattern</td>
<td>The data to be matched with the packet.</td>
<td>Enter ( hh ; hh ; hh \ldots ), where ( hh ) are hexadecimal numbers from 0-9 or a-f. Leave blank if not applicable.</td>
</tr>
<tr>
<td>Filter Expression</td>
<td>An advanced feature to set up complex filter conditions. The simplest filter allows you to check for the existence of a protocol or field. For example, to see all packets that contain the IPX protocol, you can use the simple filter expression ipx.</td>
<td>See Tips for Creating Custom Decode Filter Expressions, page 3-35.</td>
</tr>
</tbody>
</table>

**Custom Decode Subexpressions Fields**

Table D-61 describes the custom decode fields and provides filter and format details.

**Table D-61 Custom Decode Field Subexpressions**

<table>
<thead>
<tr>
<th>Field</th>
<th>Filter By</th>
<th>Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>eth.addr</td>
<td>MAC address</td>
<td>( hh:hh:hh:hh:hh:hh ), where ( h ) is a hexadecimal number from 0 to 9 or a to f.</td>
</tr>
<tr>
<td>eth.src</td>
<td>MAC address</td>
<td>( hh:hh:hh:hh:hh:hh ), where ( h ) is a hexadecimal number from 0 to 9 or a to f.</td>
</tr>
<tr>
<td>eth.dst</td>
<td>MAC address</td>
<td>( hh:hh:hh:hh:hh:hh ), where ( h ) is a hexadecimal number from 0 to 9 or a to f.</td>
</tr>
<tr>
<td>ip.addr</td>
<td>IP address</td>
<td>( n.n.n.n ) or ( n.n.n.n/s ), where ( n ) is a number from 0 to 255 and ( s ) is a 0-32 hostname that does not contain a hyphen.</td>
</tr>
<tr>
<td>ip.src</td>
<td>IP address</td>
<td>( n.n.n.n ) or ( n.n.n.n/s ), where ( n ) is a number from 0 to 255 and ( s ) is a 0-32 hostname that does not contain a hyphen.</td>
</tr>
<tr>
<td>ip.dst</td>
<td>IP address</td>
<td>( n.n.n.n ) or ( n.n.n.n/s ), where ( n ) is a number from 0 to 255 and ( s ) is a 0-32 hostname that does not contain a hyphen.</td>
</tr>
<tr>
<td>tcp.port</td>
<td>TCP port number</td>
<td>A decimal number from 0 to 65535.</td>
</tr>
<tr>
<td>tcp.srcport</td>
<td>TCP port number</td>
<td>A decimal number from 0 to 65535.</td>
</tr>
<tr>
<td>tcp.dstport</td>
<td>TCP port number</td>
<td>A decimal number from 0 to 65535.</td>
</tr>
<tr>
<td>udp.port</td>
<td>UDP port number</td>
<td>A decimal number from 0 to 65535.</td>
</tr>
<tr>
<td>udp.srcport</td>
<td>UDP port number</td>
<td>A decimal number from 0 to 65535.</td>
</tr>
<tr>
<td>udp.dstport</td>
<td>UDP port number</td>
<td>A decimal number from 0 to 65535.</td>
</tr>
<tr>
<td>protocol</td>
<td>Protocol</td>
<td>Click the Protocol list in the Custom Decode Filter dialog box to see the list of protocols on which you can filter.</td>
</tr>
<tr>
<td>protocol [offset:length]</td>
<td>Protocol data pattern</td>
<td>( hh:hh:hh:hh\ldots ), where ( hh ) is a hexadecimal number from 0 to 9 or a to f. offset and length are decimal numbers. offset starts at 0 and is relative to the beginning of the protocol portion of the packet.</td>
</tr>
<tr>
<td>frame.pkt_len</td>
<td>Packet length</td>
<td>A decimal number that represents the packet length, not the truncated capture packet length.</td>
</tr>
</tbody>
</table>
Error Scan Window

Table D-62 describes the Error Scan window fields.

Table D-62  Error Scan Window Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Severity</td>
<td><strong>Warn</strong>: Warning; for example, an application returned an unusual error code</td>
</tr>
<tr>
<td></td>
<td><strong>Error</strong>: A serious problem, such as malformed packets</td>
</tr>
<tr>
<td>Group</td>
<td><strong>Checksum</strong>: A checksum was invalid</td>
</tr>
<tr>
<td></td>
<td><strong>Sequence</strong>: Protocol sequence is problematic</td>
</tr>
<tr>
<td></td>
<td><strong>Response Code</strong>: Problem with the application response code</td>
</tr>
<tr>
<td></td>
<td><strong>Request Code</strong>: An application request</td>
</tr>
<tr>
<td></td>
<td><strong>Undecoded</strong>: Dissector incomplete or data can’t be decoded</td>
</tr>
<tr>
<td></td>
<td><strong>Reassemble</strong>: Problems while reassembling</td>
</tr>
<tr>
<td></td>
<td><strong>Malformed</strong>: Malformed packet or dissector has a bug; dissection of this packet aborted</td>
</tr>
</tbody>
</table>

Hardware Filter Dialog Box

Table D-63 describes the Create Hardware Filter dialog box.

Table D-63  Create Hardware Filter Dialog

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Options</th>
<th>Range</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Ports</td>
<td>Both Ports, Data Port 1, Data Port 2</td>
<td>—</td>
</tr>
<tr>
<td>Frame Length</td>
<td>Equal To, Not Equal To, Greater Than, Less Than</td>
<td>Min. 64, Max 65535</td>
</tr>
<tr>
<td>VLAN IDs</td>
<td>Equal To, Not Equal To, Greater Than, Less Than</td>
<td>Min. 1, Max 4095</td>
</tr>
<tr>
<td>MPLS Label</td>
<td>Equal To, Not Equal To</td>
<td>Min. 0, Max 1048575</td>
</tr>
<tr>
<td>Source Address / Mask</td>
<td>Equal To, Not Equal To</td>
<td>IPv4 address</td>
</tr>
<tr>
<td>Destination Address / Mask</td>
<td>Equal To, Not Equal To</td>
<td>IPv4 address</td>
</tr>
<tr>
<td>L4 Protocol</td>
<td>Equal To, Not Equal To, ICMP, IGMP, IP in IP, GRE, L2T, TCP, UDP, Integer</td>
<td>With Custom, you can enter a custom value that is not in the list of common protocols. Enter min. 1, max 255.</td>
</tr>
<tr>
<td>L4 Source Port</td>
<td>Equal To, Not Equal To</td>
<td>Min. 1, Max 65535</td>
</tr>
<tr>
<td>L4 Destination Port</td>
<td>Equal To, Not Equal To</td>
<td>Min. 1, Max 65535</td>
</tr>
<tr>
<td>Pattern Match</td>
<td>Filters packets based on 4-byte hexadecimal patterns anywhere in the first 256 bytes. Equal To, Not Equal To</td>
<td>—</td>
</tr>
</tbody>
</table>
# NAM Packet Analyzer Decode Window

Table D-64 describes the critical fields on the NAM Packet Analyzer window.

**Table D-64**  
Packet Browser

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No.</td>
<td>Packet numbers, listed numerically in capture sequence. If the decode (display) filter is active, the packet numbers might not be consecutive.</td>
</tr>
<tr>
<td>Time</td>
<td>Time the packet was captured relative to the first packet displayed (not the first packet in the session). To see the absolute time, see the Detail window.</td>
</tr>
<tr>
<td>Source</td>
<td>Packet source, which might be displayed as hostname, IP, IPX, or MAC address. To turn hostname resolution on and off for IP addresses, choose the Setup tab and change this setting under Preferences.</td>
</tr>
<tr>
<td>Destination</td>
<td>Packet destination, which might be displayed as hostname, IP, IPX, or MAC address.</td>
</tr>
<tr>
<td>Protocol</td>
<td>Top-level protocol of the packet.</td>
</tr>
<tr>
<td>Length</td>
<td>Size of the packet, in bytes.</td>
</tr>
<tr>
<td>Info</td>
<td>Brief text information about the packet contents.</td>
</tr>
</tbody>
</table>

# Software Filter Dialog Box

Table D-65 describes key Software Filter dialog box fields.

**Table D-65**  
Software Filter Dialog Box

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the software filter.</td>
<td>Enter the name of the software filter.</td>
</tr>
</tbody>
</table>
| Source Address / Mask | Source address of the packets.                                              | • For IP, IPIP4, GRE.IP, or GTP.IPv4 addresses, enter a valid IPv4 address in dotted-quad format n.n.n.n, where n is 0 to 255. The default (if blank) is 255.255.255.255.  
• For IPv6 or GTP.IPv6 addresses, enter a valid IPv6 address in any allowed IPv6 address format. For example:  
  - 1080::8:800:200C:417A  
  - ::FF:129.144.52.38  
  Note  
  See RFC 5952 for valid text representations.  
For MAC address, enter hh hh hh hh hh hh, where hh is a hexadecimal number from 0 to 9 or a to f. The default is ff ff ff ff ff ff.  
• If a bit in the Source Mask is set to 1, the corresponding bit in the address is relevant.  
• If a bit in the Source Mask is set to 0, the corresponding bit in the address is ignored. |
### Field Description Usage Notes

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
</table>
| Destination Address / Mask    | Destination address of the packets.                                         | • For IP, IPIP4, GRE.IP, or GTP.IPv4 addresses, enter a valid IPv4 address in dotted-quad format n.n.n.n, where n is 0 to 255. The default (if blank) is 255.255.255.255.  
  • For IPv6 or GTP.IPv6 addresses, enter a valid IPv6 address in any allowed IPv6 address format. For example:  
    – 1080::8:800:200C:417A  
  Note: See RFC 5952 for valid text representations.  
  For MAC address, enter hh hh hh hh hh hh, where hh is a hexadecimal number from 0 to 9 or a to f. The default is ff ff ff ff ff. |
| The mask applied to the destination address. | • If a bit in the Dest. Mask is set to 1, the corresponding bit in the address is relevant.  
  • If a bit in the Dest. Mask is set to 0, the corresponding bit in the address is ignored. |
| Network Encapsulation         | The protocol to match with the packet.                                       |                                                                              |
| Both Directions (check box)   | This check box indicates whether the filter is applied to traffic in both directions. | If the source is host A and the destination is host B, enabling both directions filters packets from A to B and B to A.  
  If the source is host A and the destination is not specified, enabling both directions filters packets both to and from host A.  
  The “both directions” check box also affects the ports and not only the addresses (the same logic applies). |
| VLAN Identifier(s)            | The 12-bit field specifying the VLAN to which the packet belongs.            | Choose a VLAN Range or enter an individual VLAN IDs.  
  Prime NAM filters the first VLAN only. If you include a range, note this limitation.  
  The VLAN ID can range from 1-4095. |
Table D-65  Software Filter Dialog Box (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>TCP Flag Bits</td>
<td>• URG – Indicates that the urgent pointer field is significant.</td>
<td>This is for TCP packets only. The six flags can be selected individually or combined with other flag(s) using AND/OR logic. Only packets that have those selected flags set will be captured.</td>
</tr>
<tr>
<td></td>
<td>• ACK – Indicates that the acknowledgment field is significant.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• PSH – Indicates Push function.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• RST – Indicates to reset the connection (You can see this on rejected connections).</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• SYN – Indicates that it synchronizes sequence numbers (You can see this on new connections).</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• FIN – Indicates that there is no more data from sender (You can see this after a connection is closed).</td>
<td></td>
</tr>
</tbody>
</table>

| Application¹   | Select the Application drop list to filter by application.                  | Select one protocol to capture from the Application drop-down list.                                                                         |
| Source Port(s) | Select the Port radio button to filter by port.                              | Enter one or more ports separated by commas.                                                                                                 |
| Destination Port(s) | Select one protocol to capture from the Application drop-down list.   | Enter one or more ports separated by commas.                                                                                                 |
| IP Protocol    | Choose TCP, UDP, or SCTP. No selection (default) means that any will be allowed. |                                                                                                                                            |

1. The application filter can be used to filter on the highest layer of the protocol parsing; that is usually a layer 4 protocol (based on port). If you want to filter on the transport protocol (for example, UDP or TCP), you will need to use the “IP Protocol” selector. Selecting, for example, TCP in the “IP Protocol” selector will filter on all packets using TCP.

Administration User Interface Windows

This section includes the following sections:

- System Overview
- SNMP Agent
- Preferences
- New User Dialog Box
- User Privileges
- Current User Sessions
System Overview

Table D-66  System Overview

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inputs Tab</td>
<td></td>
</tr>
<tr>
<td>Cumulative Input Statistics</td>
<td>Health and usage information on all the traffic received by the NAM. It shows the number of packets received (Rx Packets), number of packets lost or dropped (Rx Packets Lost), and number of bytes received (Rx Bytes). The Cumulative column shows cumulative counts since the start of the NAM, and the Rate column one shows the same counters for the last ten seconds.</td>
</tr>
<tr>
<td>Input Traffic</td>
<td>Usage information in bytes and packets based on the input you select. You can toggle between a chart or table format. Data is updated every 30 seconds and contains data from the past hour. The table time interval cannot be changed. The input table rate is calculated every 10 seconds. A table legend provides data for standard statistics provided by the software for data collected over a period of time. To reset the traffic counters, click on Reset Traffic at the bottom of Input Traffic chart.</td>
</tr>
<tr>
<td>Resources Tab</td>
<td></td>
</tr>
<tr>
<td>Date</td>
<td>Current date and time synchronized with the switch, router, or NTP server.</td>
</tr>
<tr>
<td>IPv4 Address</td>
<td>Based on your configuration, IPv4 address and/or IPv6 address displays.</td>
</tr>
<tr>
<td>IPv6 Address</td>
<td></td>
</tr>
<tr>
<td>System Uptime</td>
<td>Length of time the host has been running uninterrupted.</td>
</tr>
<tr>
<td>Disk Usage</td>
<td>Config, data, and root partitions with their total and free space. Also shows the amount of disk space used by the performance data base files (DB) and the packet capture to disk (capture files). Use this information to ensure you have enough disk space and perform the needed maintenance as necessary.</td>
</tr>
<tr>
<td>Utilization</td>
<td>Percentage of memory resources being consumed by the NAM as well as the total memory available.</td>
</tr>
<tr>
<td>CPU Usage</td>
<td>Percentage of CPU resources being consumed by the NAM. Each individual CPU in a multi-CPU platform is listed separately.</td>
</tr>
</tbody>
</table>
SNMP Agent

Table D-67  System SNMP Agent Dialog Box

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Location</td>
<td>(Optional) The physical location of the switch or router in which the NAM is installed.</td>
</tr>
<tr>
<td>Community String</td>
<td>Add permission and community string information.</td>
</tr>
</tbody>
</table>

E-Mail Setting

Table D-68  Mail Configuration Options

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Mail</td>
<td>Enables e-mail of reports and notification of alarms</td>
</tr>
<tr>
<td>External Mail Server</td>
<td>IP address or hostname of external mail server</td>
</tr>
<tr>
<td>Send Test Mail to</td>
<td>Optional. List e-mail addresses for up to three e-mail recipients. Use this as a verification of your mail setup.</td>
</tr>
<tr>
<td>Mail Alarm to</td>
<td>This recipient will receive alarm notifications and scheduled exports. Enter multiple addresses using space or comma delimiters.</td>
</tr>
<tr>
<td>Advanced Settings</td>
<td>Enables you to designate an e-mail access server port, as well as select a encryption protocol.</td>
</tr>
<tr>
<td>Mail Server Port</td>
<td>Optional. Designate an e-mail port for the NAM. If your mail server is configured with a non-default server port number, use this field to ensure it works with Prime NAM.</td>
</tr>
<tr>
<td>Mail Server Encryption</td>
<td>Optional. Select Secure Sockets Layer (SSL) or Transport Layer Security (TLS) encryption for e-mail messaging. Use these encryption protocols to authenticate servers and clients and encrypt messages between you and Prime NAM.</td>
</tr>
</tbody>
</table>

Preferences

Table D-69 describes the critical fields of the Preferences window.

Table D-69  System View and Logging Preferences

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Idle Timeout (1-1440 min)</td>
<td>An idle timeout is supported to prevent unauthorized access to the NAM GUI or CLI. Default value is 30 minutes.</td>
</tr>
<tr>
<td>Refresh Interval (60-3600 sec)</td>
<td>Amount of time between refresh of information on dashboards. Default is 300.</td>
</tr>
<tr>
<td>Top N Entries (1-10)</td>
<td>Number of entries on the Top N charts. Default is 5. To view up to 100 entries, use the Table view versus the chart view.</td>
</tr>
</tbody>
</table>
### Table D-70  System View and Logging Preferences (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Perform IP Host Name Resolution</strong></td>
<td>Display hostnames instead of IP Addresses. This option performs translation using DNS lookup. Ensure you set your DNS nameserver parameters. See Setting Network Parameters, page 4-3.</td>
</tr>
<tr>
<td><strong>Traffic Display Unit</strong></td>
<td>Data displayed in graph and tables; Bits (default) or Bytes.</td>
</tr>
<tr>
<td><strong>Response Time Display Unit</strong></td>
<td>Default is automatic. Options include: microseconds, milliseconds, and seconds.</td>
</tr>
<tr>
<td><strong>International Notation</strong></td>
<td>Display options for numbering. May affect report accuracy; see the Cisco Bug Search tool for details.</td>
</tr>
<tr>
<td><strong>Audit Trail</strong></td>
<td>Display a listing of recent events that have been recorded. This includes CLI and GUI configuration events. To view, choose Administration &gt; Diagnostics &gt; Audit Trail.</td>
</tr>
<tr>
<td><strong>IP TOS Flow Key</strong></td>
<td>Include type of service (TOS) data in the NAM network flow. Select only if you are measuring Differentiated Services Code Point (DSCP) for monitored traffic. If you require ART and other flow-based analysis and expect that the TOS information in your network may change in an on-going flow, do not select TOS information to be part of flow configuration. <strong>Note</strong> If TOS byte changes in an on-going flow this results in a new flow being created. If this option is not selected, the entire flow transaction is treated as one flow regardless of a TOS change in this flow. If your network configuration allows the IP TOS value to change dynamically during the life of a flow, and you enable the IP TOS Flow Key option, then the ART and application classification features may not work accurately. These features are based on the state of each flow, and rely on seeing all the packets for a flow grouped together. However, if the IP TOS value changes during a flow, then that flow will be broken into two or more flows when the IP TOS is used as a key. Disabling the IP TOS Flow Key option will correct these issues. However, in this case your DSCP statistics becomes inaccurate because only the first IP TOS value will be recorded for each monitored flow. See Using NAM to Monitor QoS/DiffServ (DSCP).</td>
</tr>
</tbody>
</table>

### New User Dialog Box

Table D-70 describes the critical fields in the New User dialog box.
User Privileges

Table D-71 describes the critical fields in the User Privileges window.

<table>
<thead>
<tr>
<th>Privilege</th>
<th>Access Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report</td>
<td>Enables a user to schedule and view the saved reports through the web interface, as well as access the saved reports through file sharing. See Sharing Files, page 6-41 for details.</td>
</tr>
<tr>
<td>AccountMgmt</td>
<td>Enables a user to create, delete, and edit user accounts.</td>
</tr>
<tr>
<td>SystemConfig</td>
<td>Enables a user to edit basic NAM system parameters such as IP address, gateway, HTTP port, and so on.</td>
</tr>
<tr>
<td>Capture</td>
<td>Enables a user to perform packet captures, manage capture sessions, use the NAM packet analyzer to decode packet data and access capture files through file sharing.</td>
</tr>
<tr>
<td>AlarmConfig</td>
<td>Enables a user to create, delete, and edit alarms on the switch/router and NAM.</td>
</tr>
</tbody>
</table>
| MonitorConfig         | Enables a user to create, delete, and edit the following:  
                          • Collections and reports  
                          • Protocol directory entries  
                          • Protocol groups  
                          • URL-based applications |
| MonitorView           | Enables a user to view monitoring data and reports (granted to all users). |

TACACs+ Authentication and Authorization

Table D-72  

<table>
<thead>
<tr>
<th>Field</th>
<th>Usage Notes</th>
</tr>
</thead>
</table>
| Enable TACACs+ Authentication and Authorization | Determines whether TACACs+ authentication and authorization is enabled.  
                                                   • To enable, check the check box.  
                                                   • To disable, uncheck the check box. |
| Primary TACACs+ Server                     | Enter the IP address of the primary server.                                 |
Table D-72  TACACS+ Authentication and Authorization Dialog Box (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Backup TACACS+ Server</td>
<td>Enter the IP address of the backup server (optional).</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> If the primary server does not respond after 30 seconds, the backup server will be contacted.</td>
</tr>
<tr>
<td>Secret Key</td>
<td>Enter the TACACS+ secret key.</td>
</tr>
<tr>
<td>Verify Secret Key</td>
<td>Reenter the TACACS+ secret key.</td>
</tr>
</tbody>
</table>

Current User Sessions

Table D-73 describes the critical fields in the Current User Sessions window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>From</td>
<td>The name of the machine the user logged in from.</td>
</tr>
<tr>
<td>Last Activity</td>
<td>The time stamp of the last user activity.</td>
</tr>
</tbody>
</table>

Report Descriptions

Table D-74 lists the MIB objects supported by the NAM.

<table>
<thead>
<tr>
<th>Description</th>
<th>Source</th>
</tr>
</thead>
<tbody>
<tr>
<td>MIB-II: All groups except Exterior Gateway Protocol (EGP) and transmission.</td>
<td>RFC 1213</td>
</tr>
<tr>
<td>RMON-MIB: Alarm and Event groups only</td>
<td>RFC 2819</td>
</tr>
<tr>
<td>RMON2: trapDestTable only</td>
<td>RFC 2021</td>
</tr>
<tr>
<td>CDP-MIB: Cisco Discovery Protocol</td>
<td></td>
</tr>
<tr>
<td>EntityMIB</td>
<td>RFC 2737</td>
</tr>
</tbody>
</table>
Troubleshooting Network and NAM Issues

This appendix addresses some common issues you might encounter while using Cisco Prime Network Analysis Module as well as how to use NAM to troubleshoot NAM network connection issues.

This appendix contains the following topics:

- Resolving Typical NAM Issues, page D-1
- Troubleshooting Login Issues, page D-2
- Understanding Typical Error Messages, page D-3
- Troubleshooting WAAS Data Issues, page D-4
- Troubleshooting Video Streams, page D-5
- Using the CLI to Troubleshoot Issues, page D-5

Resolving Typical NAM Issues

**Q.** I see a notification message No data for selected time interval on my dashboard reports. What should I do?

**A.** You may have created a filter that needs to be changed in order to see data. Use the Interactive Report Filter to do any or all of the following actions until your data displays:

- Change the site filters
- Change the application filter
- Incrementally expand the time range from the default to a greater time range

Review the following question for additional details if this does not resolve your issue.

**Q.** I am sending traffic to the NAM but nothing comes up on the default monitoring page. What could be wrong?

**A.** There are two typical issues that are seen when first setting up traffic to the NAM:

- Wait for at least five minutes after traffic is sent to the NAM. Prime NAM collects and displays information at intervals and traffic may not display in charts immediately.
- Ensure the client time is synchronized with the NAM time. Typically this means setting your NTP server to synchronize your NAM time. For details, see Synchronizing Your System Time, page 4-5.

**Q.** What information should I collect and what else should I do when the NAM is not responding?
Troubleshooting Login Issues

Log into the NAM by using the username and password that the NAM administrator provided you, and click the Login button. If you are having problems logging in:

- Make sure you are using a browser that is currently supported for use with NAM:
  English Firefox 3.6+ or Microsoft Internet Explorer 8+ (Microsoft Internet Explorer 7 is not supported)

- Make sure you are using a platform that is currently supported for use with NAM:
  Microsoft Windows XP or Microsoft Windows 7. The Macintosh platform is not supported on this release.

- Make sure you have JavaScript enabled.

- Clear the browser cache and restart the browser (not necessary if installing NAM for the first time).

- Make sure cookies are enabled in your browser.

- If you see the following message: “Initializing database. Please wait until initialization process finishes,” you must wait until the process finishes.

- Make sure your username and password does not use any special characters.

- If your platform requires licensing, make sure you accepted the license agreement and that the license has not expired.

A. Determine the answers to the following questions and gather the following information:

- Does session from the switch/router CLI work?
- Does ping over EOBC (127 subnet) work?
- Does ping to the management IP address work?
- Collect output of show tech-support command from both the NAM and the switch or router.
- Collect core files.
- Check if NAM hardware is seated correctly in chassis
  Perform the following tasks to troubleshoot your issue:
  - Reset NAM
  - Reset into maintenance image or helper
  - Clear the configuration
  - Reinstall the application image (using the --reformat option)

Q. What can I do to increase my Prime vNAM performance level?

A. Prime NAM virtual appliance (vNAM) supports different traffic monitoring speeds based on your deployments. For more details about licensing options and hypervisor dependencies, see the Prime vNAM Data Sheet on Cisco.com.

Q. How can I view NAM log files and send them to TAC for review?

A. From the GUI, go to Administration -> Diagnostics -> Tech Support. After the support screen dump is complete, click Download log files. Save the files to your local disk. You can analyze the files locally or, if requested forward on to your technical support team for review.
• If the Prime vNAM permanent license is installed and you log in for the first time and accept the EULA, you may be logged out so the permanent license can take effect. We recommend you wait several minutes before you attempt another logon.

To view the full documentation set (including the User Guide and Release Notes) for the Cisco Prime NAM software, go to the NAM software Technical Documentation area on Cisco.com:


Understanding Typical Error Messages

Q. I’m waiting for the graphical data to populate on a dashboard. What does this red error “Request Error -- Please Try Again” mean?
A. This means an internal error has occurred, or the login session may have timed out.

Q. I’m waiting for the graphical data to populate on a dashboard. What does this red error “Query resulted in no data” mean?
A. The NAM does not have any data for the specified time frame and specified filter. Go to the Interactive Report (the pane on the left side of the window) and click the Filter button to check the filter settings and data sources to make sure the NAM is getting data. You can also check the Overview page to ensure the traffic is reaching the NAM. If no traffic appears, check your data sources and SPAN session configuration.

Q. What does the message “Client or NAM time is incorrect” mean?
A. The browser or client time and the NAM time must be synchronized to avoid this error. See Synchronizing Your System Time, page 4-5.

Frequently Asked Questions about Prime NAM Behavior

Q. How does NAM calculate network latency?
A. To calculate network latency, the software looks at each packet and associates it to a transaction. For example, NAM looks at SYN and SYN-ACK and timestamps these packets to perform these calculations.

Q. How can Prime NAM be restricted to one tenant’s traffic when using SPAN or ERSPAN on a Nexus 1000V?
A. Prime NAM can be deployed per tenant so they each NAM has their own portal. NAM processes VxLAN, LISP, FabricPath, and OTV for multiple tenants.

Q. Why is the browser behaving strangely? It is displaying data for no apparent reason or is not displaying expected data.
A. Clear the browser cache, close the browser, and open a new session and try again. Also, make sure you are using a supported browser (see the Cisco Prime Network Analysis Module Release Notes).

Q. Why is the NAM performance lower than expected?
A. Disk capture will reduce the NAM performance considerably. It is due to the disk input/output speed. You will see a warning in the top right corner of the window.
Q. Why won’t the system change the storage option for my capture session from disk to memory and then back to disk?

A. If you set up a capture session to disk and later modify the same packet session to save into memory, Prime NAM is unable to change the storage selection back to disk because it is in the in use state. You cannot delete the capture session to release the disk for capture. The workaround is to reboot the NAM. This has been fixed in the latest patch (patch 5) on the Cisco software download web page.

Q. What MIBs do the Prime NAM support?

A. Table D-1 lists the MIB objects supported by Prime NAM.

Table D-1  Supported MIBs

<table>
<thead>
<tr>
<th>Description</th>
<th>Source</th>
</tr>
</thead>
<tbody>
<tr>
<td>MIB-II: All groups except Exterior Gateway Protocol (EGP) and transmission.</td>
<td>RFC 1213</td>
</tr>
<tr>
<td>RMON2: trapDestTable only</td>
<td>RFC 2021</td>
</tr>
<tr>
<td>CDP-MIB: Cisco Discovery Protocol¹</td>
<td></td>
</tr>
<tr>
<td>EntityMIB</td>
<td>RFC 2737</td>
</tr>
</tbody>
</table>

¹. CDP is received on NAM management ports only. NAM does not transmit CDP packets.

Q. Why do all platforms except for NAM-NX1 need if-mib (ifTable) to provide Analyze > Managed Device interface data?

A. NAM-NX1 gets this data by exchanging messaging with the Supervisor Engine on EOBC channel. There is no MIB involved.

Q. Which platforms require MIBs?

A. All NAM platforms except NAM-NX1 and NAM appliance platform require the Entity-mib, mib-2, if-mib, and… (don't remember) to get and configure SPAN sessions. NAM-NX1 uses EOBC and proprietary messaging with SUP on EOBC to get and configure SPAN session. Appliance NAM platforms have two options: For the SNMP option, the requirements are the same as other NAM platforms. With a NetConf interface, there is not any MIB involved.

Troubleshooting WAAS Data Issues

Q. Why does Prime NAM display the status of WAAS devices as pending?

A. Prime NAM is unable to monitor WAAS traffic until you set up WAAS monitored servers. To change the pending status, you must set up WAAS monitored servers. See your product documentation for more details.

Q. Why is no WAAS data seen in the Monitor windows?

A. Perform the following steps:

- Use the NAM GUI to verify that the Monitored Servers list is configured with the correct server IP addresses.
Use the NAM GUI to verify that WAAS data sources have data collection enabled for applicable segments.

Use the WAAS CLI `show statistics flow filters` to verify that the servers have active traffic flows that are optimized and monitored.

Use the WAAS CLI `show statistics flow mon tcpstat` to verify that WAAS Flow Agent exports flow data to the correct NAM IP address.

**Q.** The WAAS is not sending data to the NAM, and the reports are not showing any values.

**A.** The WAAS will not send data unless filtering is enabled on the NAM. Enable filtering at **Setup > Data Sources > WAAS > Monitored Servers**, and check the “Filter Response Time for all Data Sources by Monitored Servers” check box.

---

## Troubleshooting Video Streams

Use Prime NAM to monitor the network to ensure that the video quality is good. If quality issues appear, isolate and troubleshoot the problem rapidly as follows:

- Choose **Analyze > Media** to view the Video Streams. You can access this from the Video Streams Conversation table by clicking a specific stream or from the Video Channels Table window by clicking the stream that is associated with the video signaling stream. This chart indicates current video quality of all video streams that are being monitored. I/All frame loss rate are the main metrics to indicate the video quality. High loss rate indicates poor quality and low loss rate indicates excellent quality. Use the Top N Video Streams source and destination endpoints to view whether there are video streams in the poor range.

- To isolate video streams that have poor quality, scroll down to Top N Video streams and click the chart to drill down into the Video Stream details. You can examine the I/All frame loss rate together with other metrics to determine the main cause for poor quality. If the video stream is MPEG-TS stream, you can also look at the MDI metrics to determine whether DF/MLR is large.

- With the endpoint’s IP addresses, you can look at the network topology to identify where your subnet is located in the network.

---

## Using the CLI to Troubleshoot Issues

- **Locating Packet Drops, page D-5**
- **Handling an Unresponsive NAM, page D-6**
- **Using the CLI to Troubleshoot Performance Agent (PA), page D-6**

---

## Locating Packet Drops

**Q.** How can I find out using the CLI if packets are being dropped?

**A.** The following CLI command shows packet drops at different layers of the NAM system at 5 minute intervals and up to the last 24 hours:

```
root@NAM3-18.cisco.com# show pkt-drop-counters Hour-0
```

*Start time of the hour: 2010-11-05 13:00 PDT*

<table>
<thead>
<tr>
<th>Time</th>
<th>hardware pkts dropped</th>
<th>FM pkts dropped</th>
<th>ART pkts dropped</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Handling an Unresponsive NAM

**Q.** Why is my NAM Blade not responding?

**A.** Do the following:

- Check the NAM IP configuration (using the CLI command `show ip`)
- Check VLAN configuration of management port on Sup:
  
  \[ \text{analysis module <slot> management-port access-vlan <#>} \]

- Does the session from the switch/router work?
- Does a ping to NAM mgmt IP address work?
- What is the module status on Sup/router?
  
  \[ \text{show modules CLI} \]

Using the CLI to Troubleshoot Performance Agent (PA)

**Q.** Why is the NAM not receiving data from PA?

**A.** Prime NAM no longer uses Performance Agent as a remote data source. Use Prime Infrastructure or Prime Assurance to collect PA data.