Cisco Prime Network Analysis Module
User Guide

Release 6.0
December 2013

Cisco Systems, Inc.
www.cisco.com

Cisco has more than 200 offices worldwide. Addresses, phone numbers, and fax numbers are listed on the Cisco website at www.cisco.com/go/offices.
CONTENTS

Preface 1

CHAPTER 1
Introducing Cisco Prime NAM 1-1

CHAPTER 2
Planning Cisco NAM Network Deployment 2-1
- Overview of the Cisco NAM Platforms 2-1
- Understand the Network Performance Management Lifecycle 2-1
- How to Use Prime NAM to Solve Network Problems 2-3
- Places in the Network Where NAMs Are Deployed 2-4

CHAPTER 3
Setting Up Cisco Prime NAM 3-1
- Configuration Overview 3-2
  - Monitoring Traffic Analysis 3-4
  - Analyzing Application Response Time Metrics 3-4
  - Voice Signaling/RTP Stream Monitoring 3-4
  - Traffic Usage Statistics 3-5
- Setting Traffic Parameters 3-5
  - Configuring Monitored Traffic 3-6
    - About SPAN/RSPAN/ERSPAN and NetFlow Sessions 3-6
    - Creating a SPAN Session 3-8
    - Editing a SPAN Session 3-8
- Setting Up Prime NAM Data Sources 3-8
  - Ports and Hardware Details 3-9
    - SPAN 3-10
    - ERSSPAN 3-10
    - VACL 3-17
    - NetFlow 3-19
    - WAAS 3-27
    - Performance Agent 3-33
  - Configuring Hardware Deduplication 3-36
- Setting Up Alarms and Alarm Thresholds 3-37
  - Configuring Alarm Actions 3-37
  - Viewing Alarm Actions 3-38
Editing Alarm Actions 3-39
Deleting Alarm Actions 3-39
Understanding Trigger Capture 3-39
Defining Thresholds 3-40
  Setting Host Thresholds 3-41
  Setting Conversation Thresholds 3-41
  Setting Application Thresholds 3-41
  Setting Response Time Thresholds 3-42
  Setting DSCP Thresholds 3-42
  Setting RTP Stream Thresholds 3-42
  Setting Voice Signaling Thresholds 3-43
  Setting NetFlow Interface Thresholds 3-43
  Editing or Deleting an Alarm Threshold 3-44
Setting Up and Managing Scheduled Exports Reports 3-44
  Creating a Schedule Export Report 3-45
  Editing a Scheduled Export Job 3-45
  Deleting a Scheduled Export Job 3-46
  Reviewing a Scheduled Export Report 3-46
Accessing Device Interface and Health Details 3-46
  Configuring Managed Device Information 3-47
    Configuring Managed Device Information on Blades or Modules 3-47
    Configuring Managed Device Information on Appliances and other Virtual Platforms 3-47
  Viewing Managed Device Information 3-48
  Setting Up NBAR Protocol Discovery on a Managed Device 3-48
Configuring Network Parameters 3-49
  Configuring Sites 3-49
    Defining a Site 3-49
    Viewing Defined Sites 3-50
    Editing a Site 3-50
    About Site Definitions and Rules 3-51
  Setting Interface Speed using NetFlow Interface Capacity 3-52
    Creating an NetFlow Interface 3-53
  Configuring DSCP Groups 3-53
    Creating a DSCP Group 3-53
    Editing a DSCP Group 3-54
    Deleting a DSCP Group 3-55
  Configuring Application Awareness 3-55
    Creating Deeper Visibility Into Application Traffic 3-55
    Creating New Application Classifications 3-56
Sites Detailed Views 4-12
Site Conversations Detailed Views 4-12
Applications Detailed Views 4-13
Application Groups Detailed Views 4-13
Application Traffic By Hosts Detailed Views 4-13
Top Application Traffic Detailed Views 4-13
Hosts Detailed Views 4-13
Host Conversations Detailed Views 4-14
Network Conversation Detailed Views 4-14
DCSPs Detailed Views 4-14

About Analyze Traffic Charts 4-14

Optimizing WAN 4-15
Ensuring WAN Optimization 4-15
Analyzing Traffic for Optimization Using the Top Talkers Detail 4-16
Analyzing Application Performance after WAAS Optimization 4-16
Comparing Transaction Time (Client Experience) 4-17
Comparing Traffic Volume and Compression Ratio 4-17
Planning Capacity Using Average Concurrent Connections (Optimized vs. Passthru) 4-17
Optimizing Usage Using Multi-Segment Network Time (Client LAN - WAN - Server LAN) 4-17

Monitoring WAAS Traffic Across Multi-Segments 4-17
Monitoring WAAS Single-Segment Traffic 4-17

Measuring Response Time 4-18
Application Response Time 4-21
Network Response Time 4-21
Server Response Time 4-22
Client Response Time 4-22
Client-Server Response Time 4-22
Server Application Responses 4-22
Server Application Transactions 4-23
Server Network Responses 4-24
Client-Server Application Responses 4-25
Client-Server Application Transactions 4-26
Client-Server Network Responses 4-27

Analyzing Device Interface, Health, and Application Data 4-29
Interface 4-29
Health 4-30
Switch Health 4-30
Router Health 4-34
NBAR 4-36
Contents

Analyzing Media 4-36
  RTP Streams 4-37
    Understanding the RTP Stream Data 4-37
    Monitoring RTP Streams 4-38
  Voice Call Statistics 4-39
  Calls Table 4-39
  RTP Conversation 4-41
  Site MOS 4-42
Setting Up Northbound Interface 4-42

CHAPTER 5
Capturing and Decoding Packets 5-1
  Analyzing Packet Basics 5-1
  Using Quick Capture 5-2
  Creating and Managing Capture Sessions 5-3
    Understanding Hardware and Software Capture Sessions Filters 5-3
    Viewing Capture Sessions 5-4
    Configuring Capture Sessions 5-5
    Understanding Global Capture Settings 5-7
  Network Traffic Using Software Filters 5-8
    Creating a Software Capture Filter for Customized Applications 5-9
    Creating an On-Demand Capture 5-9
    Editing a Software Capture Filter 5-9
    Understanding Software Capture Filter Options 5-9
  Supporting Hardware Filters 5-12
    Creating NAM Service Module Hardware Filters 5-12
    Creating Other NAM Hardware Filters 5-18
  Working with Capture Files 5-21
    Understanding Session Files 5-21
    Analyzing Capture Files 5-23
      Drilling Down into Packet Error Details 5-24
    Downloading Capture Files 5-25
    Deleting a Capture File 5-26
    Deleting Multiple Capture Files 5-26
  Utilizing Capture Data Storage 5-26
    Capturing to Data Storage 5-27
      Preparing LUNs 5-27
      Using LUNs 5-27
      Decoding Files 5-28
      Logging In and Out of External Storage LUNs 5-28
Connecting and Disconnecting External Storage  5-28
Recovering Data Storage  5-29
Inspecting Packet Decode Information for Suspicious Traffic  5-30
Browsing Packets in the Packet Decoder  5-30
Filtering Packets Displayed in the Packet Decoder  5-31
Viewing Detailed Protocol Decode Information  5-31
Understanding Packet Decoder  5-32
Understanding the Packet Decoder Window and Browser Pane  5-32
Using Alarm-Triggered Captures  5-34
Using Time-Based Captures  5-35
Customizing Display Filters  5-35
Creating Custom Display Filters  5-36
Editing Custom Display Filters  5-38
Deleting Custom Display Filters  5-39

**CHAPTER 6**

**Administering the Network**  6-1
Managing System Data  6-1
  Handling Backups  6-1
  Shrinking Storage Requirements  6-1
Performing System Administration  6-2
  Monitoring Prime NAM Health and Traffic Statistics  6-2
  Setting Network Parameters  6-4
  Setting the SNMP Agent  6-4
    Working with NAM Community Strings  6-5
  Synchronizing Your System Time  6-6
    Synchronizing NAM System Time for Specific Platforms  6-7
  Setting Up E-Mail Notifications for Alarms  6-10
  Sharing NAM Data by Enabling Web Data Publication  6-10
  Setting Remote Servers to Receive Syslog Messages  6-11
  Configuring Hosts to Receive SNMP Traps from Prime NAM  6-11
  Resetting System Preferences  6-12
Troubleshooting Using Diagnostics Tools  6-12
  System Alerts  6-12
  Audit Trail  6-13
  Tech Support  6-13
Controlling User Access  6-14
  Local Database  6-14
    Resetting Passwords  6-14
    Changing Predefined NAM User Accounts on the Switch or Router  6-15
Contents

Creating a New User 6-15
Establishing TACACS+ Authentication and Authorization 6-17
Configuring a TACACS+ Server to Support NAM Authentication and Authorization 6-18
  Configuring a Cisco ACS Server, Version 4.2 6-18
  Configuring a Cisco ACS Server, Version 5.x 6-20
  Configuring a Generic TACACS+ Server 6-21
Current User Sessions 6-22

CHAPTER 7

NAM Deployment 7-1
  Deploying in the Data Center 7-1
  Deploying in a Campus Environment 7-2
  Deploying in the Branch 7-2
  General Usage Scenarios 7-2
  NAM Integrations with Monitoring and Reporting Applications 7-2
Deployment Examples 7-3
  Using NAMs to Monitor VoIP Quality 7-3
  Autodiscovery Capabilities of NAM 7-4
  Creating Custom Applications 7-5
  Utilizing Sites to Create a Geographically- or Organizationally-Familiar Deployment 7-5
  Integrating NAM with Third Party Reporting Tools 7-6
  Integrating NAM with LMS 7-6
  Visibility in the Branch 7-7
  Monitoring Cisco WAAS and Measuring Its Impact 7-7
Monitoring 7-10
  Real-Time Traffic Monitoring and Analysis 7-11
  Using NAM to Monitor QoS/DiffServ (DSCP) 7-13
  Using NAM for Historical Trends via Interactive Report 7-17
  Using NAM to Evaluate Application-Level Performance Monitoring for TCP-Interactive Applications 7-20
  Using NAM to Evaluate Application-Level Performance Monitoring for UDP Realtime Applications 7-20
  Monitoring the Nexus 1000V Switch Environment 7-20
Troubleshooting 7-23
  Using NAM for Problem Isolation 7-24
  Using NAM for SmartGrid Visibility 7-24

APPENDIX A

Troubleshooting Network and NAM Issues A-1
  Resolving Typical NAM Issues A-1
  Troubleshooting Login Issues A-2
<table>
<thead>
<tr>
<th>Contents</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Understanding Typical Error Messages</td>
<td>A-2</td>
</tr>
<tr>
<td>Understanding NAM Behavior</td>
<td>A-3</td>
</tr>
<tr>
<td>Understanding Common Navigation and Control Elements</td>
<td>A-3</td>
</tr>
<tr>
<td>Understanding the Menu Bar</td>
<td>A-3</td>
</tr>
<tr>
<td>Displaying Detailed Views</td>
<td>A-4</td>
</tr>
<tr>
<td>Accessing Context Menus</td>
<td>A-4</td>
</tr>
<tr>
<td>Performing a Quick Capture</td>
<td>A-5</td>
</tr>
<tr>
<td>Determining How to Use Sites to View Data</td>
<td>A-5</td>
</tr>
<tr>
<td>Filtering Data Using the Interactive Report</td>
<td>A-5</td>
</tr>
<tr>
<td>Switching Chart Formats Using the Chart View / Table View</td>
<td>A-6</td>
</tr>
<tr>
<td>Accessing Other Tasks Using Mouse-Over for Details</td>
<td>A-6</td>
</tr>
<tr>
<td>Changing the Time Interval Using Zoom/Pan Charts</td>
<td>A-6</td>
</tr>
<tr>
<td>Using Sort Grid to Change Sort Order</td>
<td>A-7</td>
</tr>
<tr>
<td>Displaying Bits or Bytes or Packets in Charts</td>
<td>A-7</td>
</tr>
<tr>
<td>Statistics</td>
<td>A-7</td>
</tr>
<tr>
<td>Context-Sensitive Online Help</td>
<td>A-7</td>
</tr>
<tr>
<td>Understanding How the Prime NAM Traffic Sources Work</td>
<td>A-7</td>
</tr>
<tr>
<td>Understanding How the Prime NAM Uses SPAN</td>
<td>A-8</td>
</tr>
<tr>
<td>Synchronizing the Clock on Prime NAM</td>
<td>A-8</td>
</tr>
<tr>
<td>Understanding How the Prime NAM Uses VACLs</td>
<td>A-8</td>
</tr>
<tr>
<td>Understanding How the Prime NAM Uses NetFlow</td>
<td>A-9</td>
</tr>
<tr>
<td>Understanding How the Prime NAM Uses WAAS</td>
<td>A-10</td>
</tr>
<tr>
<td>Understanding How the Prime NAM Uses PA</td>
<td>A-10</td>
</tr>
<tr>
<td>Frequently Asked Questions about Prime NAM Behavior</td>
<td>A-11</td>
</tr>
<tr>
<td>Troubleshooting WAAS Data Issues</td>
<td>A-12</td>
</tr>
<tr>
<td>Using the CLI to Troubleshoot Issues</td>
<td>A-12</td>
</tr>
<tr>
<td>Locating Packet Drops</td>
<td>A-13</td>
</tr>
<tr>
<td>Handling an Unresponsive NAM</td>
<td>A-13</td>
</tr>
<tr>
<td>Using the CLI to Troubleshoot Performance Agent (PA)</td>
<td>A-13</td>
</tr>
</tbody>
</table>

**APPENDIX B**

<table>
<thead>
<tr>
<th>References</th>
<th>B-1</th>
</tr>
</thead>
<tbody>
<tr>
<td>GUI Field Descriptions</td>
<td>B-1</td>
</tr>
<tr>
<td>Setup User Interface Window</td>
<td>B-1</td>
</tr>
<tr>
<td>Capture User Interface Windows</td>
<td>B-17</td>
</tr>
<tr>
<td>Report Descriptions</td>
<td>B-18</td>
</tr>
</tbody>
</table>
Preface

This preface discusses the objectives, audience, conventions, and organization of the *Cisco Prime Network Analysis Module User Guide* and provides general information about Cisco Prime NAM software documentation. This preface has the following sections:

- Chapter Overview, page xiii
- Audience, page xiv
- Conventions, page xiv
- Notices, page xv
- Obtaining Documentation and Submitting a Service Request, page xv

For a list of the platforms that Prime NAM supports, see *Cisco Prime Network Analysis At-a-Glance*.

Chapter Overview

This guide contains the following chapters:

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chapter 1</td>
<td>Overview</td>
<td>Summary of how Prime NAM provides deeper visibility into the network to accelerate troubleshooting and optimization decisions.</td>
</tr>
<tr>
<td>Chapter 2</td>
<td>Planning Cisco NAM Deployment</td>
<td>Information about planning the deployment of your NAM in the network to solve your performance and optimization goals.</td>
</tr>
<tr>
<td>Chapter 3</td>
<td>Setting Up Cisco Prime NAM</td>
<td>Setup details you can review to determine if you want to use advanced features.</td>
</tr>
<tr>
<td>Chapter 4</td>
<td>Monitoring and Analyzing Traffic</td>
<td>Options for viewing and monitoring various types data.</td>
</tr>
<tr>
<td>Chapter 5</td>
<td>Capturing and Decoding Packets</td>
<td>Information about setting up multiple sessions for capturing, filtering, and decoding packet data, managing the data in a file control system, and displaying the contents of the packets.</td>
</tr>
</tbody>
</table>
## Audience

This publication is intended primarily for network administrators who are responsible for setting up and configuring Network Analysis Modules (NAMs) to monitor traffic and diagnose emerging problems on network segments. As a network administrator, you should be familiar with:

- Basic concepts and terminology used in internetworking.
- Network topology and protocols.
- Basic UNIX commands or basic Windows operations.

## Conventions

This document uses the following conventions:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>boldface</strong></td>
<td>Commands and keywords.</td>
</tr>
<tr>
<td><em>italic</em></td>
<td>Command input that is supplied by you.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Keywords or arguments that appear within square brackets are optional.</td>
</tr>
<tr>
<td>{ x</td>
<td>x</td>
</tr>
<tr>
<td>^ or Ctrl</td>
<td>Represent the key labeled Control. For example, when you read ^D or Ctrl-D, you should hold down the Control key while you press the D key.</td>
</tr>
<tr>
<td><strong>screen font</strong></td>
<td>Examples of information displayed on the screen.</td>
</tr>
<tr>
<td><strong>boldface screen font</strong></td>
<td>Examples of information that you must enter.</td>
</tr>
<tr>
<td><em>italic screen font</em></td>
<td>Examples of variables that you must enter.</td>
</tr>
<tr>
<td>&lt; &gt;</td>
<td>Nonprinting characters, such as passwords, appear in angled brackets.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Default responses to system prompts appear in square brackets.</td>
</tr>
<tr>
<td><strong>Option &gt; Network Preferences</strong></td>
<td>Selecting a menu item.</td>
</tr>
</tbody>
</table>
Note

Means reader take note. Notes contain helpful suggestions or references to material not covered in the publication.

Caution

Means reader be careful. In this situation, you might do something that could result in equipment damage or loss of data.

Notices

The Cisco Prime Network Analysis Module Third Party and Open Source Copyright Notices contains the licenses and notices for open source software used in Prime NAM. Prime NAM includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/). This document is available on www.cisco.com with the Prime NAM technical documentation.

Obtaining Documentation and Submitting a Service Request

For information on obtaining documentation, using the Cisco Bug Search Tool (BST), submitting a service request, and gathering additional information, see What's New in Cisco Product Documentation at: http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html.

Subscribe to What's New in Cisco Product Documentation, which lists all new and revised Cisco technical documentation, as an RSS feed and deliver content directly to your desktop using a reader application. The RSS feeds are a free service.
Overview

This chapter contains information about the Cisco Prime Network Analysis Module (NAM) software and describes task overviews.

This chapter contains the following sections:

- Introducing Cisco Prime NAM

Introducing Cisco Prime NAM

The Cisco Prime Network Analysis Module (Prime NAM) software is a network monitoring and analysis tool that combines flow-based and packet-based analysis into a single toolset. Prime NAM software provides network operations and engineering with user, command line, and application programming interfaces that you use for traffic analysis of applications, hosts, and conversations, performance-based measurements on application, server, and network latency, quality of experience metrics, as well as ways to see deeper into your network. The robust graphical user interface makes traffic monitoring and troubleshooting simple and cost-effective.

This chapter contains an overview on ways to use Prime NAM to monitor and analyze your network traffic. See Table 1-1 for details on high-level task areas and how they map to the user interface.

For a list of the key features in this release, see the Cisco Prime Network Analysis Module Release Notes.
## Table 1-1  Prime NAM Task Areas

<table>
<thead>
<tr>
<th>Task Area</th>
<th>Menu Mapping</th>
<th>Task Description</th>
<th>Used By</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plan and Prepare</td>
<td>Setup menu</td>
<td>Create a list of your network performance goals. Set expected goals and limits for response time, expected ranges for MOS values, bandwidth usage per application, and utilization on critical WAN links. You can also plan which existing management assets can integrate with NAM application programming interface (API). See Planning Cisco NAM Deployment, page 2-1.</td>
<td>Network Engineers, Designers, and Architects</td>
</tr>
<tr>
<td>Deploy</td>
<td>Setup and Admin menus</td>
<td>Determine which locations are ingress or egress points of a logical network boundary (aggregation layer, core, campus edge, and so on) that can offer valuable insights into the network activity within that partition. Create a baseline of current metrics including applications, bandwidth per application, top conversations and hosts, QoS values used in the network, unrecognized protocols, and current server and end-to-end response time measurements. Configure devices to share data with NAM. Configure managed devices and data sources. See Setting Up Cisco Prime NAM, page 3-1.</td>
<td>Network Engineers, Designers, and Architects</td>
</tr>
<tr>
<td>Monitor and Analyze</td>
<td>Home, Capture, Analyze &amp; Monitor menus</td>
<td>View dashboards, which give you a quick view of devices, performance information, and various incidents. Use interactive reports to filter data when monitoring specific network traffic and troubleshooting problems. Monitor your network on a daily basis and perform other day-to-day or ad hoc operations related to network device monitoring, inventory and configuration management, as well as troubleshooting. Enforce policies using alarms, syslogs, traps, and e-mail alerts. Configure any enterprise-wide network management tools and monitoring applications to receive alerts from NAM. See Monitoring and Analyzing Traffic, page 4-1 and Capturing and Decoding Packets, page 5-1.</td>
<td>Network Engineers, NOC Operators, and Service Operators</td>
</tr>
</tbody>
</table>
### Table 1-1  Prime NAM Task Areas (continued)

<table>
<thead>
<tr>
<th>Task Area</th>
<th>Menu Mapping</th>
<th>Task Description</th>
<th>Used By</th>
</tr>
</thead>
<tbody>
<tr>
<td>Administer</td>
<td>Administer menu</td>
<td>Specify system configuration settings and data collection settings, and manage access control. See Administering the Network, page 6-1.</td>
<td>Network Engineers</td>
</tr>
</tbody>
</table>
Planning Cisco NAM Deployment

This chapter contains information about how to plan the deployment of NAM in your network to solve your performance and optimization goals.

This chapter contains the following sections:

- Overview of the Cisco NAM Platforms, page 2-1
- Understand the Network Performance Management Lifecycle, page 2-1
- How to Use Prime NAM to Solve Network Problems, page 2-3
- Places in the Network Where NAMs Are Deployed, page 2-4

Overview of the Cisco NAM Platforms

The portfolio of Cisco NAM models differ in memory, performance, disk size, and other capabilities. Therefore, some allow for more features and capabilities (for example, the amount of memory allocated for capture).

Throughout this guide, there may be notes explaining that some features apply only to specific platforms. If there is no note, then that feature or aspect applies to all Cisco NAM platforms.

For more information about where you may choose to deploy certain platforms, see Places in the Network Where NAMs Are Deployed, page 2-4 or Cisco.com.

For a list of Cisco NAM models and their features and capabilities, see the data sheets in Products & Services on Cisco.com.

For details on memory, performance, disk size, and other capabilities, see the NAM Compatibility Matrix.

Understand the Network Performance Management Lifecycle

In any network, the administrator must define normal and abnormal behavior patterns. Once this is accomplished, the goal is to maintain the network in its normal state and take any actions needed to prevent it from going into an abnormal state. When such an abnormal situation occurs, such as an outage, tools must be available to quickly isolate and fix the problem.
Understand the Network Performance Management Lifecycle

**Figure 2-1** The Network Performance Management Lifecycle

![Network Performance Management Lifecycle Diagram](image)

**Figure 2-1** depicts the network management performance lifecycle with the Operational Network cycle located at the center of the figure. This is where the network should ideally be at all times. The other two cycles indicate the process of repairing a network problem and the process of planning a change to the network. The following is a brief example of how Prime NAM can help you solve some of the performance management tasks:

1. **Monitor your network and report on network trends**—Use Prime NAM to focus on various network trends you want to monitor. For example, whether your business-critical applications are getting adequate network resources and operating at target performance levels. You can get proactive notification when the performance falls below an acceptable level (such as alerts by e-mail, traps, and syslogs). Configure enterprise-wide network management tools and monitoring applications to accept alerts from Prime NAM.

2. **Analyze collected data**—Use Prime NAM to collect data from a variety of sources in the network such as SPAN, RSPAN, ERSPAN, and NetFlow. The data can be analyzed in the context of the specific application, site, client, server encapsulations and overlay networks. This enables network administrators to quickly get the critical network information to accelerate operational decisions. For example, when there is a degradation for a business-critical application, you can analyze application and network performance statistics, such as application transaction times, network round-trip times, and packet retransmit times to quickly isolate and resolve the network issue. Using these analytics you can maintain consistent visibility across physical and virtual environments.

3. **Diagnose problems and troubleshoot**—Prime NAM lets you look inside virtualization and overlay technologies such as OTV to provide traffic statistics and application performance metrics. Data can be specified by host, applications, conversations, and other ways to help you analyze and ensure effective use of these technologies. Accelerate troubleshooting with interactive reports, contextual packet captures, and real-time packet decodes.

4. **Optimize the use of network resources**—Prime NAM allows for better understanding of network traffic trends and effective use of control and optimization technologies embedded in the network. For example, while deploying QoS the visibility from NAM can help to validate whether the network behavior conforms to the implemented QoS policies. Similarly, when deploying Cisco WAAS solution, Prime NAM helps validate the benefits as a result of application and network optimization.

The goal is for all important network metrics to be within the normal ranges. Knowing the normal range of the network is a constant learning process, and as the network evolves and grows, it can be a moving target. Therefore the lifecycle described above is a continuous process of fine-tuning the network and the metrics that are most important to normal behavior.
How to Use Prime NAM to Solve Network Problems

The Cisco Prime NAM software helps you to address the following major areas:

- **Network Layer Traffic Analysis.** Prime NAM provides comprehensive traffic analysis to identify what applications are running over the network, how much network resources are consumed, and who is using these applications. Prime NAM software offers a rich set of reports with which to view traffic by Hosts, Application or Conversations. See the discussions about Dashboards, starting with Using Traffic Summary, page 4-1.

- **Application Response Time.** Prime NAM can provide passive measurement of TCP-based applications for any given server or client, supplying a wide variety of statistics like response time, network flight time, and transaction time.

- **WAN Optimization insight.** Prime NAM provides insight into WAN Optimization offerings that compress and optimize WAN Traffic for pre- and post-deployment scenarios. This is applicable for Optimized and Passthru traffic.

- **Voice Quality Analysis.** Prime NAM provides application performance for real time applications like Voice and Video. Prime NAM can compute MOS, as well as provide RTP analysis for the media stream. See Analyzing Media, page 4-28.

- **Advanced Troubleshooting.** Prime NAM provides robust capture and decode capabilities for packet traces that can be triggered or terminated based on user-defined thresholds.

- **Open instrumentation.** Prime NAM is a mediation and instrumentation product offering, and provides a robust API that can be used by partner products as well as work with customer-created applications. Contact your account representative for a copy of the Cisco Prime Network Analysis Module API Programmer’s Guide.

Prime NAM delivers the above functionality by analyzing a wide variety of data sources that include:

- **Port mirroring technology like SPAN and RSPAN/ERSPAN.** Prime NAM can analyze Ethernet VLAN traffic from the following sources: Ethernet, Fast Ethernet, Gigabit Ethernet, trunk port, or Fast EtherChannel SPAN, RSPAN, or ERSPAN source port.

- **VACL**

- **NetFlow Data Export (NDE).** Prime NAM analyzes NetFlow from Managed Devices (Routers/Switches)

- **WAAS**

- **SNMP**

- **Performance Agent (PA)**

- **Network Tap Device.** Applies to Cisco NAM appliances only.

Prime NAM uses SNMP as a southbound interface for configuration and data retrieval from switches and routers. Prime NAM uses web services as the northbound interface for data objects. The software continues to support baseline manageability features of SNMP such as MIB-2 and IF-TABLE for the NAM, and the health status and interface statistics that can be used by external products like Fault and Configuration Management offerings (for example, CiscoWorks LMS and Prime Infrastructure).

For more information about SPAN, RSPAN, and ERSPAN, see your platform configuration guide on Cisco.com. For information about which traffic sources are supported on each platform, see the Compatibility Matrix.

Table 2-1 summarizes the traffic sources that are used for Prime NAM monitoring.
Places in the Network Where NAMs Are Deployed

Because NAM is available in various form factors, it allows significant flexibility in deployment. At the same time, the available NAMs must be deployed in locations that are most effective in helping you monitor, measure, and report on the network’s health. Any location that is the ingress or egress point of a logical network boundary (aggregation layer, core, campus edge, and so on) can offer valuable insights into the network activity within that partition. Therefore, such boundary locations are usually good choices for NAM deployment.

Figure 2-2 shows various possible locations at which NAMs can be deployed. The access and distribution layers, the data center, WAN edge, and branch office are all valid choices, and you should make deployment decisions based on the specific issue at hand. The following is a list of common places in the network where NAMs are deployed and the information available at each place:

- **Data center**—Over the past few years, data center consolidation has been a common theme across enterprises. The centralized data center becomes a critical hub of activity within the enterprise network and helps cut costs, focus IT efforts in one location, and offer a rich variety of services across the enterprise. Placing a NAM in such data centers offers excellent visibility into the most business-critical applications and transactions.

- **Server farms**—Place near server farms (for example, web, FTP, and Domain Name System (DNS)), data centers, or near IP telephony devices (Cisco Unified Communications Manager), IP phones, and gateways where the Cisco NAM can monitor request-response exchanges between servers and clients and provide rich traffic analysis, including IAP.

- **Campus and WAN edge**—This location is very often a good choice—it offers visibility into traffic entering and exiting the campus. It provides a central point from which to measure voice quality of all streams leaving the campus and going across the WAN. The WAN is typically the smallest bandwidth link, and therefore, call metrics such as latency, jitter, and so on might require close monitoring for deterioration in quality. It is also an excellent location to measure WAN utilizations and health metrics of various branch routers using NetFlow. Place Cisco NAMs at the WAN edge to gather WAN statistics from the Optical Services Module (OSM) or FlexWAN interfaces or to collect NetFlow packet statistics on remote NetFlow-enabled routers. This can provide usage statistics for links, applications (protocol distributions), hosts, and conversations, which can be useful for trending data and capacity planning.

- **Branch office**—Place Cisco NAMs at the edge of the branch office to troubleshoot issues at remote sites. This place offers the advantage of visibility into all traffic crossing the branch boundary. Headquarters personnel can troubleshoot issues remotely through the NAM GUI.

<table>
<thead>
<tr>
<th>Traffic Source</th>
<th>LAN Ports</th>
<th>LAN VLANs</th>
<th>WAN Ports</th>
<th>WAN VLANs</th>
</tr>
</thead>
<tbody>
<tr>
<td>VACL capture</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>N/A</td>
</tr>
<tr>
<td>NetFlow Data Export NDE (local)</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>NetFlow Data Export NDE (remote)</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>SPAN</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>ERSAN</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
</tbody>
</table>

| Table 2-1 Summary of Traffic Sources for Prime NAM Monitoring |
- **Distribution layer**—The distribution layer is typically a convergence point for traffic from smaller networks; for example, three buildings of a company might feed into a distribution layer switch. Placing the Cisco NAMs at the distribution layer allows visibility into the application trends specific to that set of buildings. In troubleshooting situations, you might start working with an edge NAM and then log in to a distribution NAM to isolate and fix the problem. Also, it is a good location to capture RTP voice streams. If phone calls in one building in the campus need to be monitored for quality, the aggregation layer is a good choice, as the switch in this layer will typically “catch” all calls being made in that building.

- **Access layer**—The access layer is the layer closest to users and is not a typical location for NAMs. However, with the rapid increase in network traffic over the years, it has become somewhat common to have Cisco Catalyst 6500 Series Switches in the closet of each floor. Cisco NAMs can be very useful, especially for those access layer switches that serve critical company-wide meetings or conferences and other business-critical needs. Once again, close monitoring of IP phones is a good application in this layer as well.

**Figure 2-2**  *Places in the Network in Which NAMs Can Be Deployed*
Places in the Network Where NAMs Are Deployed
Setting Up Cisco Prime NAM

Cisco Prime Network Analysis Module, or Prime NAM, starts collecting data once your network device’s IP address is shared with the NAM. You can view the monitor or dashboard, troubleshoot suspicious traffic using the capture tool, and decode capture sessions without any additional configuration on your part.

This chapter provides set up details for advanced tools. You can use these tools to take your network monitoring to another level. It provides information about functions that will begin automatically, optional tasks, and other setup tasks you will need to perform for advanced feature configuration.

This chapter contains the following sections:

- Configuration Overview, page 3-2
- Setting Traffic Parameters, page 3-5
- Setting Up Alarms and Alarm Thresholds, page 3-36
- Scheduling Data Report Exports, page 3-45
- Accessing Device Interface and Health Details, page 3-47
- Configuring Network Parameters, page 3-49
- Configuring Application Awareness, page 3-55
- Setting Up Prime NAM Monitoring, page 3-61

For information about how to install the product, configure it, and log in, see the installation guide for your specific Cisco NAM platform.
Configuration Overview

Table 3-1 leads you through the basic configuration steps you can follow for Prime NAM.

These are not necessarily in the order in which you need to perform them, and many are optional features.

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
<th>GUI Location</th>
<th>User Guide Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Install Prime NAM (upgrade is supported for NAM 5.x platforms)</td>
<td>--</td>
<td>--</td>
<td>See your platform-specific Installation and Configuration Guides</td>
</tr>
<tr>
<td>Configure the Managed Device information</td>
<td>If you want to monitor an extended level of your managed device’s data (health and interface information), you can set up your managed device using Cisco NAM. If you do not set up this feature, your data collection is limited to Depending on your NAM platform, managed device health and interface information will display in Analyze &gt; Managed Device GUI. For service module NAM blades such as NAM-1X, NAM-2X, NAM-3, NAM-NX1, and SM-SRE NAM, the NAM managed device is the switch or router where NAM is located. Managed device SNMP credentials are automatically synchronized to the NAM upon NAM boot up. For other NAM platforms, the NAM managed device IP address, SNMP, and/or NetConf interface credential must be provided for NAM to get managed device health and interface information.</td>
<td>Setup &gt; Managed Device &gt; Device Information</td>
<td>See Accessing Device Interface and Health Details, page 3-47.</td>
</tr>
<tr>
<td>Set up the System Time</td>
<td>NAM assumes that your system time is synchronized. If you do not have the time synchronized between the NAM and the standard time source outside the NAM, then you may see either incorrect data or no data. If you suspect inaccurate time stamps, you need to set up the System Time so that NAM data presentation is accurate. You can configure NAM system time to synchronize with NTP servers. You can synchronize NAM blade time with the managed device time. For best practice, use the NTP server for NAM system time.</td>
<td>Administration &gt; System &gt; System Time</td>
<td>See Synchronizing Your System Time, page 6-6.</td>
</tr>
</tbody>
</table>
### Table 3-1  Configuration Overview (continued)

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
<th>GUI Location</th>
<th>User Guide Location</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Verify that traffic has started</strong>&lt;sup&gt;1&lt;/sup&gt;</td>
<td>Traffic usage statistics for applications, hosts, conversations, VLANs, and DSCP are available on the Traffic Summary Dashboard.</td>
<td>Home (Traffic Summary Dashboard) or Monitor &gt; Overview &gt; Traffic Summary</td>
<td>See Monitoring Traffic Analysis, page 3-4.</td>
</tr>
<tr>
<td><strong>Verify that Application Response Time Metrics are being gathered</strong>&lt;sup&gt;1&lt;/sup&gt;</td>
<td>The Prime NAM software provides response time measurements and various user-experience-related metrics, which are computed by monitoring and time-stamping packets sent from the user to the server providing services.</td>
<td>Analyze &gt; Response Time. You can view response times for applications, networks, servers, and clients.</td>
<td>See Analyzing Application Response Time Metrics, page 3-4.</td>
</tr>
<tr>
<td><strong>Verify that Voice/RTP Stream Traffic is being gathered</strong>&lt;sup&gt;1&lt;/sup&gt;</td>
<td>After Prime NAM is started, Voice/RTP stream traffic will automatically start being monitored. Prime NAM enables you to monitor all RTP stream traffic among all SPAN traffic, without having to know the signaling traffic used in negotiating the RTP channels.</td>
<td>Analyze &gt; Media &gt; RTP Streams or Analyze &gt; Media &gt; Voice Call Statistics.</td>
<td>See Voice Signaling/RTP Stream Monitoring, page 3-5.</td>
</tr>
<tr>
<td><strong>Configure sites</strong>&lt;sup&gt;(Optional, but recommended)&lt;/sup&gt;</td>
<td>A site is a collection of hosts (network endpoints) partitioned into views that help you monitor traffic and troubleshoot problems. If you want to limit the view of your network data to a specific city, a specific building, or even a specific floor of a building, you can use the sites function. We recommend that sites are configured using prefix-based subnets instead of based on data source.</td>
<td>Setup &gt; Network &gt; Sites</td>
<td>See Configuring Sites, page 3-50.</td>
</tr>
<tr>
<td><strong>Define Alarms and Thresholds</strong></td>
<td>Alarms are predefined conditions based on a rising data threshold, a falling data threshold, or both. You can choose for what types of events you want the software to notify you, and how you want to be notified. Create alarms that will be used for thresholds first, then create the thresholds second.</td>
<td>Setup &gt; Alarms &gt; Actions and Setup &gt; Alarms &gt; Thresholds</td>
<td>See Viewing Alarm Actions, page 3-38. See Defining Thresholds, page 3-39.</td>
</tr>
<tr>
<td><strong>Configure Capture</strong></td>
<td>Capture allows you to configure up to ten sessions for capturing, filtering, and decoding packet data, manage the data in a local or remote file control system, and display the contents of the packets. Per file location, you can have only one capture session. We support up to ten capture sessions.</td>
<td>Capture &gt; Packet Capture/Decode</td>
<td>See Capturing and Decoding Packets, page 5-1.</td>
</tr>
</tbody>
</table>

Note: NAM virtual blades do not support capture.
Table 3-1  Configuration Overview (continued)

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
<th>GUI Location</th>
<th>User Guide Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure Scheduled Export</td>
<td>You can set up scheduled jobs that generate daily reports at a specified time, in a specified interval, and then e-mail it to a specified e-mail address or addresses. Some windows may not support data export.</td>
<td>In the Interactive Report (left side of the dashboard), click the Export button. Scheduled Export can only be done from a Monitor or Analyze window.</td>
<td>See Scheduling Data Report Exports, page 3-45.</td>
</tr>
<tr>
<td>Set up TACACS+ Server</td>
<td>TACACS+ is a Cisco Systems enhancement that provides additional support for authentication and authorization. When a user logs into Prime NAM, TACACS+ determines if the username and password are valid and what the access privileges are. For TACACS+ to work, both NAM and the TACACS+ server has to be configured.</td>
<td>Administration &gt; Users &gt; TACACS+</td>
<td>See Configuring a TACACS+ Server to Support NAM Authentication and Authorization, page 6-18.</td>
</tr>
<tr>
<td>Change System Preferences</td>
<td>You can change many preferences, such as refresh interval, Top N Entries, Data Displayed, and enabling Audit Trail, as needed.</td>
<td>Administration &gt; System &gt; Preferences</td>
<td>See Performing User and System Administration</td>
</tr>
</tbody>
</table>

Monitoring Traffic Analysis

Traffic usage statistics for applications, application groups, hosts, IP distributions, conversations, VLANs, DSCP, and encapsulations will begin populating on the Traffic Summary dashboard (Monitor > Overview > Traffic Summary). To view detailed views of Traffic Summary data, select the Detailed Views submenu.

If no data displays on the Traffic Summary, you can see what might be occurring by going to the Administration > System > Overview page. This page displays the network traffic coming into the Cisco NAM as well as data about its health (such as server network details and CPU, memory, and data usage). You may need to check to be sure that your NAM is configured properly from any devices are sharing network traffic.

Analyzing Application Response Time Metrics

You can view response time measurements and various user-experience-related metrics on the Response Time dashboard. These measurements are computed by monitoring and time-stamping packets sent from the user to the server providing services.

Use Analyze > Response Time to access this information. You can view response times for applications, networks, servers, and clients. To view detailed views of Response Time data, select the Detailed Views submenu.

After Prime NAM starts, these metrics are populated. TCP traffic is required to display data.
Voice Signaling/RTP Stream Monitoring

You can monitor RTP stream traffic among all SPAN traffic without having to know the signaling traffic used in negotiating the RTP channels. After Prime NAM starts, monitoring of voice signaling and RTP stream traffic starts automatically.

Note

This feature is not supported on Prime NAM on Nexus 1000V.

RTP Stream Monitoring:

- Identifies all RTP streams among the SPAN traffic
- Monitors the identified RTP traffic

You can set up thresholds at Setup > Alarms > Thresholds.

You can define filter entries to narrow down to the subset of RTP streams so the software monitors only those RTP streams matching the filter criteria.

To verify that the voice signaling/RTP traffic has begun, choose Analyze > Media > RTP Streams or Analyze > Media > Voice Call Statistics.

Traffic Usage Statistics

Prime NAM provides traffic statistics broken out by applications, application groups, hosts, IP distributions, conversations, VLANs, DSCP code point, and encapsulations. Summary dashboards show Top N charts broken out by these attributes, as well as detailed views in tabular form. Analysis dashboards show usage over time by one particular application, host, and so forth, as well as other interesting measurements for the particular element being analyzed over a user-specified period of time.

Setting Traffic Parameters

To set up Prime NAM traffic, you should perform the following:

- Configuring Monitored Traffic, page 3-5
- (Optional) Setting Up Prime NAM Data Sources, page 3-8
- (Optional) Configuring Hardware Deduplication, page 3-36  (For specific NAM appliances only)

To view which traffic sources are supported on specific NAM platforms, see the NAM Compatibility Matrix.

Configuring Monitored Traffic

Prime NAM can monitor your network traffic to perform many tasks including helping you to optimize your network resources and troubleshoot performance issues. Before you can monitor data, you must direct specific traffic flowing through a switch or router to the Prime NAM software for monitoring purposes.

A switched port analyzer (SPAN) session is an association of a destination port with a set of source ports, configured with parameters that specify the monitored network traffic.
The following sections describe SPAN sessions on devices running **Prime NAM**:

- About SPAN/RSPAN/ERSPAN and NetFlow Sessions, page 3-6
- Creating a SPAN Session, page 3-7
- Editing a SPAN Sessions, page 3-8

**Note**

This functionality is only available when working with devices that support the CISCO-RMON-CONFIG-MIB. If you are using a switch that does not support this MIB, the SPAN screen may not show the existing span sessions and will not allow SPAN configuration.

### About SPAN/RSPAN/ERSPAN and NetFlow Sessions

Before you can monitor data, you must direct specific traffic flowing through a switch or router to the **Prime NAM** software for monitoring purposes. Use the methods described in Table 3-2.

**Table 3-2 Methods of Directing Traffic**

<table>
<thead>
<tr>
<th>Method</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch SPAN</td>
<td>You can direct a set of physical ports, a set of VLANs, or a set of EtherChannels to the NAM. Selecting an EtherChannel as a SPAN source is the same as selecting all physical ports comprising the EtherChannel as the SPAN source. On some NAM platforms, using SPAN allows for NAM configuration without having to use the switch.</td>
</tr>
<tr>
<td>Switch Remote SPAN (RSPAN)</td>
<td>You can monitor packet streams from remote switches, assuming that all traffic from a remote switch arrives at the local switch on a designated RSPAN VLAN. Use the RSPAN VLAN as the SPAN source for the NAM.</td>
</tr>
<tr>
<td>Encapsulated Remote Switched Port Analyzer (ERSPAN)</td>
<td>You can monitor traffic on one or more ports, or one or more VLANs, and send the monitored traffic to one or more destination ports using ERSPAN. ERSPAN sends traffic to a network analyzer such as a SwitchProbe device or other Remote Monitoring (RMON) probe. ERSPAN supports source ports, source VLANs, and destination ports on different routers or switches, which provides remote monitoring of multiple routers or switches across your network</td>
</tr>
<tr>
<td>NetFlow Data Export (NDE)</td>
<td>You can monitor NetFlow records directly from remote switches or routers. You must configure the NetFlow packet source to the Cisco NAM from a local switch or remote router using the switch CLI. For received NetFlow traffic, a default site will be created including all interfaces from that device. See Configuring Sites, page 3-50. SPAN and NetFlow sources can be in effect simultaneously.</td>
</tr>
</tbody>
</table>

Table 3-3 describes the types of SPAN sources and the possible ways to configure them.
Creating a SPAN Session

To create a SPAN session on a switch:

Step 1  Choose Setup > Traffic > SPAN Sessions. The SPAN window displays.

Step 2  Click the Create button.

The Create SPAN Session Dialog displays. DataPort is the default for the SPAN Type. Contents of this window may be different depending on your NAM platform.

Step 3  Fill in the appropriate information on the Create SPAN Session window. See Table B-3.

Step 4  To create the SPAN session, click Submit. The Active Sessions window displays.

Step 5  To save the current active SPAN session in the running-configuration to the startup-configuration for switches running Cisco IOS software only, click Save in the active SPAN session window.

Note  For switches running Cisco IOS software, all pending running-configuration changes will be saved to the startup-configuration.

Table 3-3  SPAN Sources

<table>
<thead>
<tr>
<th>SPAN Source</th>
<th>Configured with one of the following:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Any set of physical ports</td>
<td>• Prime NAM (the GUI)</td>
</tr>
<tr>
<td></td>
<td>• Switch CLI</td>
</tr>
<tr>
<td>Any EtherChannel</td>
<td>• Prime NAM (the GUI)</td>
</tr>
<tr>
<td></td>
<td>• Switch CLI</td>
</tr>
<tr>
<td>Any set of VLANs configured on the local switch</td>
<td>• Prime NAM (the GUI)</td>
</tr>
<tr>
<td></td>
<td>• Switch CLI</td>
</tr>
</tbody>
</table>

1. See the NAM Compatibility Matrix for detailed list of NAM devices that can be configured using the GUI.

See Table B-3 for a description of the fields on the SPAN Sessions window.

Table 3-4  Possible SPAN States

<table>
<thead>
<tr>
<th>State</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Active</td>
<td>SPAN source is valid and packet traffic from the source is copied to the SPAN</td>
</tr>
<tr>
<td></td>
<td>destination (NAM Dataport).</td>
</tr>
<tr>
<td>Inactive</td>
<td>Packet traffic from the source is not copied to the SPAN destination (NAM</td>
</tr>
<tr>
<td></td>
<td>Dataport).</td>
</tr>
<tr>
<td>Up</td>
<td>For NAM-NX1 only, the Supervisor displays this when packets are forwarded to</td>
</tr>
<tr>
<td></td>
<td>the NAM.</td>
</tr>
<tr>
<td>Down</td>
<td>For NAM-NX1 only, the Supervisor displays this when packets are not forwarding</td>
</tr>
<tr>
<td></td>
<td>to the NAM.</td>
</tr>
</tbody>
</table>
Setting Traffic Parameters

Chapter 3 Setting Up Cisco Prime NAM

Setting Traffic Parameters

Step 6 To verify the SPAN session was created and to view the data, go to the Top N charts on the Traffic Analysis dashboard (Monitor > Overview > Traffic Summary).

Editing a SPAN Sessions

You can only edit SPAN sessions that have been directed to the NAM. You can only delete certain SPAN sessions using the user interface.

Note Editing an existing SPAN session that has multiple SPAN destinations will affect all destinations.

To edit a SPAN session:

Step 1 Choose Setup > Traffic > SPAN Sessions. The Active SPAN Sessions dialog box displays.

Step 2 Select the SPAN session to edit, then click Edit. The Edit SPAN Session Dialog Box displays. The fields are described in Table 3-3. Depending on your NAM platform, there may be different fields that display.

Step 3 Make the appropriate changes on the Edit SPAN Session window.

Setting Up Prime NAM Data Sources

Data sources are where the traffic sent to Prime NAM originates. Some examples are: physical dataports of the Prime NAM where you get SPAN data, a specific router or switch that sends NetFlow to the NAM, a WAAS device segment that sends data to Prime NAM or ERSPAN and which goes to NAM management port.

Caution If you have configured sites (see Configuring Sites, page 3-50), you can assign data sources to that particular site. If you do this, and you also configure data sources, the two could overlap since sites can also be a primary “view” into data sources. If there is a mismatch between the two, you will not see any data.

Note We recommend that you configure a site using subnets instead of selecting a data source. For examples on how to specify a site using subnets, see About Site Definitions and Rules, page 3-51.

The following sections contains setup steps and specific information about the types of data sources available:

- Data Source Overview, page 3-9
- Forwarding SPAN Traffic, page 3-9
- Forwarding ERSPAN Traffic, page 3-10
- Forwarding VACL Traffic, page 3-17
Data Source Overview

The Data Sources page (Setup > Traffic > NAM Data Sources) lists the data sources configured for your Cisco NAM.

Table B-4 describes the fields in the NAM Data Sources window.

Ports and Hardware Details

NAM-2X, NAM-3, and NAM-NX1 each have two dataports. Each dataport can accept one SPAN session. Depending on the managed device operating system (OS) version, the number of SPAN sessions allowed may vary. Most IOS versions support two SPAN sessions. Nexus OS may support more than two SPAN sessions.

Depending on the IOS running on the Supervisor, port names are displayed differently. Newer versions of IOS software display a port name as Gi2/1 to represent a Gigabit port on module 2 port 1. In the VSS, a port name might be displayed as Gi1/2/1 to represent a Gigabit port on switch 1, module2, port 1. On NAM-NX1, a port name might be displayed at Ethernet1/1/1.

On NAM hardware, one of the two interfaces must be selected as the Prime NAM management port for IP traffic (such as HTTP and SNMP). Prime NAM can monitor traffic for analysis on the internal interface, the external interface, or both simultaneously. A typical configuration is to monitor LAN and WAN traffic on the internal interface. However, the external interface can be used to monitor LAN traffic.

NAM-1X devices can have only one active SPAN session. You can select a switch port or EtherChannel as the SPAN source; however, you may select only one SPAN type.

Some Cisco switches do not support SNMP MIB objects that are required by NAM when configuring SPAN sessions. On these switches, you can use the switch device CLI command to configure the SPAN session for NAM. Alternatively, for the NAM appliances only, if the NAM managed device supports NetConf interface over SSH, you can configure the NAM to use NetConf to configure SPAN sessions on the managed device.

Before you can monitor data, you must configure a way to direct traffic through a switch or router to the NAM. See Table 3-2 on page 3-6.

For details on supported data sources, see the NAM Compatibility Matrix.

Forwarding SPAN Traffic

A switched port analyzer (SPAN) session is an association of a destination port with a set of source ports, configured with parameters that specify the monitored network traffic. Depending on your platform, you can configure multiple SPAN sessions. For details on what platforms support ERSPAN, see the NAM Compatibility Matrix.

For more information about SPAN sessions, see Configuring Monitored Traffic, page 3-5 or your platform operating system documentation.
Forwarding ERSPAN Traffic

This section describes how to configure Encapsulated Remote Switched Port Analyzer (ERSPAN) on your remote device as a Prime NAM data source. You configure ERSPAN as a Prime NAM data source from the remote device command line interface, not the Prime NAM GUI.

For details on which NAM platforms support ERSPAN, see the NAM Compatibility Matrix.

As an ERSPAN consumer, Prime NAM can receive ERSPAN packets on its management port from devices such as Cisco routers and switches. Those packets are analyzed as if that traffic had appeared on one of the Prime NAM dataports. Prime NAM supports ERSPAN versions 1 and 3. Incoming ERSPAN data is parsed by Prime NAM, stored in its internal database, and presented in the GUI in the same way as traffic from other data sources.

For the Prime NAM to receive ERSPAN from an external switch or router, that device must be configured to send ERSPAN packets to the IP address of the Cisco NAM.

To enable ERSPAN as a data source:
- Enabling Autocreation of ERSPAN Data Sources Using the Web GUI, page 3-10
- Enabling Autocreation of ERSPAN Data Sources Using the CLI, page 3-11
- Disabling Autocreation of ERSPAN Data Sources Using the Web GUI, page 3-11
- Disabling Autocreation of ERSPAN Data Sources Using the CLI, page 3-11
- Creating ERSPAN Data Sources Using the Web GUI, page 3-12
- Creating ERSPAN Data Sources Using the CLI, page 3-12
- Deleting ERSPAN Data Sources Using the Web GUI, page 3-14
- Deleting ERSPAN Data Sources Using the CLI, page 3-14
- Configuring ERSPAN on Devices, page 3-15

Note: Depending on the Cisco IOS/Nexus OS version on the managed device, the CLI format for configuring an ERSPAN session may be different than what appears in this document. For details on using ERSPAN as a data source, see your specific OS product documentation.

Enabling Autocreation of ERSPAN Data Sources Using the Web GUI

There is a convenient autocreate feature for data sources, which is enabled by default. With the autocreate feature, a new data source will automatically be created for each device that sends ERSPAN traffic to the NAM, after the first packet is received. Manual creation of ERSPAN data sources using the Prime NAM GUI or the CLI is typically not necessary. When manually creating a data source, you may specify any name you want for the data source. A data source entry must exist on the Prime NAM in order for it to accept ERSPAN packets from an external device.

Autocreated ERSPAN data sources will be assigned a name in the format ERSPAN-<IP Address>-<ID>-<Integer>, where IP Address is the IP address of the sending device, and Integer is the Session-ID of the ERSPAN session on that device. For example, device 192.168.0.1 sending ERSPAN packets with the Session ID field set to 12 would be named ERSPAN-192.168.0.1-ID-12. You can edit these autocreated data sources and change the name if desired.

One device can be configured to send multiple separate ERSPAN sessions to the same NAM. Each session will have a unique Session ID. Prime NAM can either group all sessions from the same device into one data source, or have a different data source for each Session ID. When data sources are autocreated, they will be associated with one particular Session ID. When manually created, you can instruct Prime
NAM to group all traffic from the same device into one data source. If you check the Session check box, and enter a Session ID in the Value field, the data source will only apply to that specific session. If you leave the check box unchecked, all ERSPAN traffic from the device will be grouped together into this data source, regardless of Session ID.

To configure Prime NAM to automatically create data sources when it receives ERSPAN packets from an external device, use the following steps. Remember however, that the autocreate feature is turned on by default, so these steps are typically not necessary.

**Step 1** Choose Setup > Traffic > NAM Data Sources.

**Step 2** Click the Auto Create button on the bottom left of the window.

**Step 3** Check the ERSPAN check box to toggle autocreation of ERSPAN data sources to “on”.

**Step 4** Click the Submit button.

---

### Enabling Autocreation of ERSPAN Data Sources Using the CLI

Configuration of the autocreate feature is also possible using the Prime NAM CLI. Because the autocreate feature is turned on by default, in most cases these steps are not necessary.

To configure Prime NAM to automatically create data sources when it receives ERSPAN packets from an external device, use the autocreate-data-source command as follows:

```
root@172-20-104-107.cisco.com# autocreate-data-source erspan
```

ERSPAN data source autocreate successfully ENABLED

Prime NAM will now automatically create a ERSPAN data source for each device that sends ERSPAN packets to it. The data source will have the specific Session ID that is populated by the device in the ERSPAN packets sent to the NAM. If the same device happens to send ERSPAN packets to the Prime NAM with different Session ID values, a separate data source will be created for each unique Session ID sent from the device.

---

### Disabling Autocreation of ERSPAN Data Sources Using the Web GUI

**Step 1** Choose Setup > Traffic > NAM Data Sources.

**Step 2** Click the Auto Create button on the bottom left of the window.

**Step 3** Uncheck the ERSPAN check box to toggle autocreation of ERSPAN data sources to “off”.

**Step 4** Click the Submit button.

---

### Disabling Autocreation of ERSPAN Data Sources Using the CLI

To disable autocreation of ERSPAN data sources, use the no autocreate-data-source command as follows:

```
root@172-20-104-107.cisco.com# no autocreate-data-source erspan
```

ERSPAN data source autocreate successfully DISABLED

```
root@172-20-104-107.cisco.com#
```
Creating ERSPAN Data Sources Using the Web GUI

To manually configure a ERSPAN data source on the GUI, for example if the autocreation feature is turned off, use the following steps:

**Step 1** Choose **Setup > Traffic > NAM Data Sources**.

**Step 2** Click the **Create** button along the bottom of the window.

**Step 3** From the Type drop-down list, choose “ERSPAN”.

**Step 4** Enter the IP address of the device that will export ERSPAN to the NAM.

**Step 5** Give the Data Source a name. This name will appear anywhere there is a Data Source drop-down list.

**Step 6** (Optional) Check the **Session** check box and enter an Session ID into the Value field if the data source should only apply to that specific session. If you leave the check box unchecked, all ERSPAN traffic from the device will be grouped together into this data source, regardless of Session ID.

Devices can be configured with multiple ERSPAN Sessions. The packets exported may have the same source IP address, but the Session ID exported will be different for each session. If you want to include only one Session in the data source, you must check the “Session” box and provide the value of that Session ID.

**Step 7** Click the **Submit** button.

Creating ERSPAN Data Sources Using the CLI

To manually configure a ERSPAN data source on the **Prime NAM** using the CLI (for example if the autocreation feature is turned off), use the following steps. Note that when using the CLI, there are two separate phases involved: First, you must create a “device” entry on the **Prime NAM** and remember the device ID, and then you must create a data source entry using this device ID. In the **Prime NAM** GUI, these two phases for creating ERSPAN data sources are combined together.

**Step 1** Enter the command `device erspan`. You will now be in erspan device subcommand mode as shown here:

```
root@172-20-104-107.cisco.com# device erspan
```

Entering into subcommand mode for this command.
Type ‘exit’ to apply changes and come out of this mode.
Type ‘cancel’ to discard changes and come out of this mode.

```
root@172-20-104-107.cisco.com(sub-device-erspan)#
```

**Step 2** Enter `?` to see all the command options available, as in the example below:

```
root@172-20-104-107.cisco.com(sub-device-netflow)# ?
?                   - display help
address            - device IP address (*)
cancel             - discard changes and exit from subcommand mode
exit               - create device and exit from sub-command mode
help               - display help
show               - show current config that will be applied on exit

(*) - denotes a mandatory field for this configuration.
```

```
root@172-20-104-107.cisco.com(sub-device-netflow)#
```

**Step 3** Enter the IP address of the device as shown in this example (required):
Chapter 3  Setting Up Cisco Prime NAM

Setting Traffic Parameters

Step 4  Type `show` to look at the device configuration that will be applied and verify that it is correct:

```
root@172-20-104-107.cisco.com(sub-device-erspan)# show

DEVICE TYPE          : ERSPAN (Encapsulated Remote SPAN)
DEVICE ADDRESS       : 192.168.0.1
```

Step 5  Type `exit` to come out of the subcommand mode and create the device. Remember the ID value that was assigned to the new device (you will need it to create the data source).

```
root@172-20-104-107.cisco.com(sub-device-erspan)# exit
Device created successfully, ID = 1
root@172-20-104-107.cisco.com#
```

Step 6  Enter the command `data-source erspan`. You will now be in erspan data source subcommand mode as shown here:

```
root@172-20-104-107.cisco.com# data-source erspan

Entering into subcommand mode for this command.
Type 'exit' to apply changes and come out of this mode.
Type 'cancel' to discard changes and come out of this mode.
```

Step 7  Enter `?` to see all the command options available, as in the example below:

```
root@172-20-104-107.cisco.com(sub-data-source-erspan)# ?
?
  - display help
cancel  - discard changes and exit from subcommand mode
device-id  - erspan device ID (*)
exit  - create data-source and exit from sub-command mode
help  - display help
name  - data-source name (*)
session-id  - erspan Session ID
show  - show current config that will be applied on exit

(*) - denotes a mandatory field for this configuration.
```

Step 8  Enter the device ID from Step 4.

```
root@172-20-104-107.cisco.com(sub-data-source-erspan)# device-id 1
```

Step 9  Enter the name you would like for the data source (required):

```
root@172-20-104-107.cisco.com(sub-data-source-erspan)# name MyFirstErspanDataSource
```

Step 10  If desired, supply the specific Session ID for this ERSPAN data source (optional):

```
root@172-20-104-107.cisco.com(sub-data-source-erspan)# session-id 123
```

Step 11  Enter `show` to look at the data source configuration that will be applied and verify that it is correct:

```
root@172-20-104-107.cisco.com(sub-data-source-netflow)# show

DATA SOURCE NAME       : MyFirstErspanDataSource
DATA SOURCE TYPE       : ERSPAN (Encapsulated Remote SPAN)
DEVICE ID              : 1
DEVICE ADDRESS         : 192.168.0.1
```
SESSION ID : 123

root@172-20-104-107.cisco.com(sub-data-source-erspan)#

**Step 12**  Enter `exit` to come out of the subcommand mode and create the data source:

```
root@172-20-104-107.cisco.com(sub-data-source-erspan)# exit
```

Data source created successfully, ID = 3

The data source is now created, and ERSPAN records from the device will be received and accepted by Prime NAM as they arrive.

**Deleting ERSPAN Data Sources Using the Web GUI**

To delete an existing ERSPAN data source, use the following steps. Note that if the autocreation feature is turned on, and the device continues to send ERSPAN packets to the NAM, the data source will be recreated again automatically as soon as the next ERSPAN packet arrives. Therefore, if you wish to delete an existing ERSPAN data source, it is usually advisable to first turn the ERSPAN autocreate feature off, as described earlier.

**Step 1**  Choose **Setup > Traffic > NAM Data Sources**.

**Step 2**  Choose the data source you would like to delete.

**Step 3**  Click the **Delete** button along the bottom of the window.

**Deleting ERSPAN Data Sources Using the CLI**

To delete a ERSPAN data source using the CLI, use the following steps. Note that when using the CLI, there are generally two separate phases involved. First you should delete the data source, then delete the device if you have no other data sources using the same device (for example with a different Engine ID value). As a shortcut, if you simply delete the device, then all data sources using that device will also be deleted.

**Step 1**  Show all data sources so you can find the ID of the one you want to delete:

```
root@172-20-104-107.cisco.com# show data-source
```

```
DATA SOURCE ID : 1
DATA SOURCE NAME : DATA PORT 1
TYPE : Data Port
PORT NUMBER : 1
-----------
DATA SOURCE ID : 2
DATA SOURCE NAME : DATA PORT 2
TYPE : Data Port
PORT NUMBER : 2
-----------
DATA SOURCE ID : 3
DATA SOURCE NAME : MyFirstErspanDataSource
TYPE : ERSPAN (Encapsulated Remote SPAN)
DEVICE ID : 2
DEVICE ADDRESS : 192.168.0.1
```
ENGINE ID        : 123

root@172-20-104-107.cisco.com#

**Step 2**  Use the **no data-source** command to delete the data source:

root@172-20-104-107.cisco.com# **no data-source 3**
Successfully deleted data source 3
root@172-20-104-107.cisco.com#

**Step 3**  Show all devices so you can find the ID of the one you want to delete:

root@172-20-104-107.cisco.com# **show device**

| DEVICE ID | : 1 |
| DEVICE TYPE | : ERSPAN (Encapsulated Remote SPAN) |
| IP ADDRESS | : 192.168.0.1 |
| INFORMATION | : No packets received |
| STATUS | : Inactive |

root@172-20-104-107.cisco.com#

**Step 4**  Use the **no device** command to delete the device:

root@172-20-104-107.cisco.com# **no device 1**
Successfully deleted device 1
root@172-20-104-107.cisco.com#

Note that if the autocreation mode is on, and the device continues to send ERSPAN packets to the NAM, the data source (and device entry) will be recreated again automatically as soon as the next ERSPAN packet arrives. Therefore, if you wish to delete an existing ERSPAN data source, it is usually advisable to first turn the ERSPAN autocreate feature off, as described earlier.

### Configuring ERSPAN on Devices

There are two ways to configure ERSPAN so that the Prime NAM receives the data:

- **Sending ERSPAN Data to Layer 3 Interface, page 3-15**
- **Sending ERSPAN Data Directly to the Cisco NAM Management Interface, page 3-16**

**Note**  Depending on the Cisco IOS or NX-OS version on your managed device, the CLI format for configuring an ERSPAN session may be different than what appears in this document. For details on using ERSPAN as a data source, see your specific OS product documentation.

### Sending ERSPAN Data to Layer 3 Interface

To send the data to a layer 3 interface on the Switch housing the NAM, configure the ERSPAN source session. The ERSPAN destination session then sends the traffic to a Prime NAM data-port. After performing this configuration, you can select the DATA PORT X data source to analyze the ERSPAN traffic.
Setting Traffic Parameters

Note This method causes the ERSPAN traffic to arrive on one of the NAM dataports, which is the most efficient method and will not have any adverse effect on the NAM’s IP connectivity. Therefore, we recommend this method. The configuration below may be different depending on your platform and OS version. See your OS product documentation for additional help.

Sample Configuration of ERSPAN Source

```
monitor session 48 type erspan-source
  erspan-id N
  vrf default
  destination ip aa.bb.cc.dd
  source interface Ethernet7/47
  no shut
mon
```

Where:
- `erspan-id N` is the ERSPAN ID
- `aa.bb.cc.dd` is the IP address of the destination switch (loopback address or any routable IP address)
- `ee.ff.gg.hh` is the source IP address of the ERSPAN traffic

Sample Configuration of ERSPAN Destination

```
monitor session 48 type erspan-destination
  erspan-id N
  vrf default
  source ip aa.bb.cc.dd
  no shut
```

Where:
- `erspan-id N` matches the ERSPAN ID at the source switch
- `aa.bb.cc.dd` is the IP address defined at the destination

You can now connect to the Prime NAM to monitor and capture traffic of the Data Port 2 data source.

Sending ERSPAN Data Directly to the Cisco NAM Management Interface

To send the data directly to the Cisco NAM management IP address (management-port), configure the ERSPAN source session. No ERSPAN destination session configuration is required. After performing this configuration on the Catalyst 6500 switch, when ERSPAN packets are sent to the NAM, it will automatically create a data source for that packet stream. If the autocr eat feature is not enabled, you will have to manually create the data source for this ERSPAN stream of traffic (see Creating ERSPAN Data Sources Using the Web GUI, page 3-12).

Note This method causes the ERSPAN traffic to arrive on the Cisco NAM management port. If the traffic level is high, this could have negative impact on the NAM’s performance and IP connectivity.

Sample Configuration

```
monitor session 1 type erspan-source
  no shut
  source interface Fa3/47
  destination
    erspan-id Y
    ip address aa.bb.cc.dd
    origin ip address ee.ff.gg.hh
```
Where:

- Interface `fa3/47` is a local interface on the erspan-source switch to be monitored
- `Y` is any valid span session number
- `aa.bb.cc.dd` is the management IP address of the NAM
- `ee.ff.gg.hh` is the source IP address of the ERSPAN traffic

**Forwarding VACL Traffic**

You can use VLAN access control (VACL) lists to filter packet data and expand your device’s capability beyond the two SPAN session limitation. For details on which devices support VACL, see the NAM Compatibility Matrix.

VACL can forward traffic from either a WAN interface or VLANs to a dataport on some of the NAM platforms. A VACL provides an alternative to using SPAN; a VACL can provide access control based on Layer 3 addresses for IP and IPX protocols. The unsupported protocols are access controlled through the MAC addresses. A MAC VACL cannot be used to access control IP or IPX addresses.

**Configuring VACL on a WAN Interface**

Because WAN interfaces do not support the SPAN function, you must use the switch CLI to manually configure a VACL in order to monitor WAN traffic with the NAM. This feature only works for IP traffic over the WAN interface.

VACL can also be used if there is no available SPAN session to direct traffic to the NAM. In this case, a VACL can be set up in place of a SPAN for monitoring VLAN traffic.

The following example shows how to configure a VACL on an ATM WAN interface and forward both ingress and egress traffic to the NAM. These commands are for switches running Cisco IOS version 12.1(13)E1 or higher. For more information on using these features, see your accompanying switch documentation.

```
Cat6509# config terminal
Cat6509(config)# access-list 100 permit ip any any
Cat6509(config)# vlan access-map wan 100
Cat6509(config-access-map)# match ip address 100
Cat6509(config-access-map)# action forward capture
Cat6509(config-access-map)# exit
Cat6509(config)# vlan filter wan interface AM6/0/0.1
Cat6509(config)# analysis module 3 data-port 1 capture allowed-vlan 1-4094
Cat6509(config)# analysis module 3 data-port 1 capture
Cat6509(config)# exit
```

To monitor egress traffic only, get the VLAN ID that is associated with the WAN interface by using the following command:

```
Cat6509# show cwan vlan
```

```
Hidden VLAN swidb->i_number Interface
1017 94 ATM6/0/0.1
```

After you have the VLAN ID, configure the Cisco NAM dataport using the following command:

```
Cat6509(config)# analysis module 3 data-port 1 capture allowed-vlan 1017
```

To monitor ingress traffic only, replace the VLAN number in the capture configuration with the native VLAN ID that carries the ingress traffic. For example, if VLAN 1 carries the ingress traffic, you would use the following command:

```
Cat6509(config)# analysis module 3 data-port 1 capture allowed-vlan 1
```
Setting Traffic Parameters

Chapter 3  Setting Up Cisco Prime NAM

Setting Traffic Parameters

Chapter 3

Setting Traffic Parameters

Setting Traffic Parameters

Cat6509(config)# analysis module 3 data-port 1 capture allowed-vlan 1

Configuring VACL on a LAN VLAN

For VLAN Traffic monitoring on a LAN, traffic can be sent to Cisco NAM by using the SPAN feature of the switch. However, in some instances when the traffic being spanned exceeds the monitoring capability of the NAM, you might want to pre-filter the LAN traffic before it is forwarded. This can be done by using VACL.

The following example shows how to configure VACL for LAN VLAN interfaces. In this example, all traffic directed to the server 172.20.10.221 on VLAN 1 is captured and forwarded to the Cisco NAM located in slot 3.

Cat6509# config terminal
Cat6509#(config)# access-list 100 permit ip any any
Cat6509#(config)# access-list 110 permit ip any host 172.20.10.221
Cat6509#(config)# vlan access-map lan 100
Cat6509#(config-access-map)#match ip address 110
Cat6509#(config-access-map)#action forward capture
Cat6509#(config-access-map)#exit
Cat6509#(config)# vlan access-map lan 200
Cat6509#(config-access-map)#match ip address 100
Cat6509#(config-access-map)#action forward
Cat6509#(config-access-map)#exit
Cat6509#(config)# vlan filter lan vlan-list 1
Cat6509#(config)# analysis module 3 data-port 1 capture allowed-vlan 1
Cat6509#(config)# analysis module 3 data-port 1 capture
Cat6509#(config)# exit

Forwarding NetFlow Traffic

Prime NAM functions as a NetFlow consumer.

You can configure NetFlow on the device side so that Prime NAM can receive NetFlow packets from devices such as Cisco routers and switches. Those records are stored in its collection database as if that traffic had appeared on one of the Cisco NAM dataports. Prime NAM understands NetFlow version 5 and version 9. Incoming NetFlow data is parsed by Prime NAM, stored in its internal database, and presented in the user interface in the same way as traffic from other data sources.

For Prime NAM to receive NetFlow packets from an external switch or router, you must configure that device to forward export flow records to the NAM’s IP address and the correct UDP port number. The default port number on which Prime NAM listens for NetFlow packets is port 3000. This port can be modified using the Prime NAM CLI, but it is critical that the same port be configured on the Cisco NAM and the exporting device or devices. Depending on the external device, you may need to enable the NetFlow feature on a per-interface basis.

See the following sections about NetFlow as a data source:

- Understanding NetFlow Interfaces, page 3-19
- Understanding NetFlow Flow Records, page 3-19
- Managing NetFlow Data Sources, page 3-20
- Configuring NetFlow on Devices, page 3-20
Understanding NetFlow Interfaces

To use a device as a NetFlow packet data source for the Prime NAM, you must configure the device itself to export NetFlow packets to UDP port 3000 on the NAM. You might need to configure the device itself on a per-interface basis. A NetFlow packet device is identified by its IP address. In the NAM, the default UDP port of 3000 can be changed with a Prime NAM CLI command (see Configuring NetFlow on Devices, page 3-20).

You can define additional NetFlow packet devices by specifying the IP addresses and (optionally) the community strings. Community strings are used to upload convenient text strings for interfaces on the managed devices that are monitored in NetFlow records.

Remote NetFlow packet devices may export information pertaining to any or all of their individual interfaces. The Prime NAM keeps track of the interface associated with any flow information received from the device. On the NDE Interface Analysis page (Analyze > Traffic > NDE Interface), you can view information for any selected interface on the device. This page will display the interface utilization or throughput over time, as well as show the top Applications, Hosts, and DSCP groups in both the input and output directions for the interface.

Understanding NetFlow Flow Records

A NetFlow packet contains multiple flow records. Each flow record has two fields:

- Input SNMP ifIndex
- Output SNMP ifIndex

This information might not be available because of NetFlow feature incompatibility with your Cisco IOS version, or because of a NetFlow flow-mask configuration.

In most cases, turning on NetFlow on an interface populates the NetFlow cache in the device with flows that are in the input direction of the interface. As a result, the input SNMP ifIndex field in the flow record has the ifIndex of the interface on which NetFlow was turned on. Sample NetFlow Network, Figure 3-1, shows a sample network configuration with a NetFlow router.

![Sample NetFlow Network](image)

Table 3-5 lists the reported flows if NetFlow is enabled on interface a.
Managing NetFlow Data Sources

A data source entry must exist on Prime NAM in order for it to accept NetFlow records from an external device. Data source entries may be created manually using the Prime NAM web GUI or the CLI. When manually creating a data source, you may specify any name you want for the data source.

For convenience, manual creation of NetFlow data sources is not necessary. There is an “autocreate” feature which is enabled by default. With the autocreate feature, a new data source will automatically be created for each device which sends NetFlow packet traffic to the Prime NAM when the first packet is received.

Autocreated NetFlow data sources will be assigned a name in the format NetFlow-<IP Address>-ID-<Integer>, where <IP Address> is the IP address of the exporting device, and <Integer> is the Engine-ID that the device populates in the packets (part of the NetFlow Data Export standard). An example might be “NetFlow-10.10.0.1-ID-12” for device 10.10.0.1 sending NetFlow packets with the Engine ID field set to 12. You can edit these autocreated data sources and change the name if you want to, as well as optionally specifying SNMP credentials for the device, as described later in this guide.

Configuring NetFlow on Devices

The configuration commands for NetFlow devices to export NetFlow packets to Prime NAM are platform and device specific. The example configuration commands provided here are the ones most commonly found for devices running Cisco IOS. For more detailed NetFlow configuration information, see your device documentation.

Enabling Autocreation of NetFlow Data Sources Using the Web GUI

To configure Prime NAM to automatically create data sources when it receives NetFlow packets from an external device, use the following steps. Remember however, that the autocreate feature is turned on by default, so these steps are typically not necessary.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Choose Setup &gt; Traffic &gt; NAM Data Sources.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Click the Auto Create button on the bottom left of the window.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Check the Netflow check box to toggle autocreation of NetFlow data sources on.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Click the Submit button.</td>
</tr>
</tbody>
</table>
Enabling Autocreation of NetFlow Data Sources Using the CLI

Configuration of the autocreate feature is also possible using the Prime NAM CLI. Remember that the autocreate feature is turned ON by default, so in most cases these steps are not necessary.

To configure the Prime NAM to automatically create data sources when it receives NetFlow packets from an external device, use the following steps:

Use the `autocreate-data-source` command as follows:

```
root@172-20-104-107.cisco.com# autocreate-data-source netflow
NetFlow data source autocreate successfully ENABLED
```

Prime NAM will now automatically create a NetFlow data source for each device that sends NetFlow packets to it. The data source will have the specific Engine ID that is populated by the device in the NetFlow packets sent to the NAM. If the same device happens to send NetFlow packets to the NAM with different Engine ID values, a separate data source will be created for each unique Engine ID sent from the device.

Disabling Autocreation of NetFlow Data Sources Using the Web GUI

```
Step 1  Choose Setup > Traffic > NAM Data Sources.
Step 2  Click the Auto Create button on the bottom left of the window.
Step 3  Uncheck the Netflow check box to toggle autocreation of NetFlow data sources off.
Step 4  Click the Submit button.
```

Disabling Autocreation of NetFlow Data Sources Using the CLI

To disable autocreation of NetFlow data sources, use the `no autocreate-data-source` command as follows:

```
root@172-20-104-107.cisco.com# no autocreate-data-source netflow
NetFlow data source autocreate successfully DISABLED
root@172-20-104-107.cisco.com#
```

Creating NetFlow Data Sources Using the Web GUI

To manually configure a NetFlow data source using the Prime NAM GUI, for example if the autocreation feature is turned OFF, use the following steps:

```
Step 1  Choose Setup > Traffic > NAM Data Sources.
Step 2  Click the Create button along the bottom of the window.
Step 3  Give the Data Source a name. This name will appear anywhere there is a Data Source drop-down list.
Step 4  From the Type drop-down list, choose NetFlow.
Step 5  Enter the IP address of the device that will export NetFlow to Prime NAM (required).
Step 6  (Optional) If you know the specific value of the Engine ID on the device you would like to monitor, check the Engine check box, and enter the value of the Engine ID. If the Engine check box is left unchecked, then all NetFlow records exported by the device will be grouped into the same data source, regardless of the Engine ID populated in the NetFlow packets (in most cases the Engine check box can be left blank and you don't have to worry about the Engine ID value).
```
Some devices have multiple Engines which independently export NetFlow records. For example, on some Cisco routers, NetFlow records can be exported by the Supervisor module as well as individual line cards. The packets exported may have the same source IP address, but the Engine ID exported by the Supervisor will be a different value than the Engine ID(s) exported by the line card(s). If you want to include only one Engine in the data source, you must check the “Engine” box and provide the value of that Engine ID.

**Step 7**  
(Optional) **SNMP v1/v2c RO Community String:** If SNMP v1 or v2c will be used to communicate with the device, enter the community string that is configured on the device that is going to export NetFlow packets to the NAM.

**Step 8**  
(Optional) **“Enable SNMP v3”:** If SNMP v3 will be used to communicate with the device, fill in the fields within the v3-specific dialog.

**Step 9**  
(Optional) If desired, fill in the SNMP credentials for the device. If valid SNMP credentials are provided, **Prime NAM** can upload readable text strings from the device to describe the interfaces on that device rather than just displaying the interfaces as numbers. You may specify either SNMPv2c or SNMPv3 credentials. See Table B-6.

**Step 10**  
Click **Test Connectivity** to see if the information you provided is accurate.

**Step 11**  
Click the **Submit** button.

---

**Creating NetFlow Data Sources Using the CLI**

To manually configure a NetFlow data source on the Prime NAM using the CLI, for example if the autocreation feature is turned off, use the following steps. Note that when using the CLI, there are two separate phases involved. First you must create a “device” entry on the Prime NAM and remember the device ID. Then you must create a data source entry using this device ID. For convenience, these two phases are combined together when using the GUI to create NetFlow data sources.

**Step 1**  
Enter the command `device netflow`. You will now be in netflow device subcommand mode as shown here:

```
root@172-20-104-107.cisco.com# device netflow
```

Entering into subcommand mode for this command.  
Type ‘exit’ to apply changes and come out of this mode.  
Type ‘cancel’ to discard changes and come out of this mode.

```
root@172-20-104-107.cisco.com(sub-device-netflow)#
```

**Step 2**  
Enter `?` to see all the command options available, as in the example below:

```
root@172-20-104-107.cisco.com(sub-device-netflow)# ?
?  - display help
address  - device IP address (*
cancel  - discard changes and exit from subcommand mode
community  - SNMPv2c community string
exit  - create device and exit from sub-command mode
help  - display help
show  - show current config that will be applied on exit
snmp-version  - SNMP version to use to communicate with device
v3-auth-passphrase  - SNMPv3 authentication passphrase
v3-auth-protocol  - SNMPv3 authentication protocol
v3-priv-passphrase  - SNMPv3 privacy passphrase
v3-priv-protocol  - SNMPv3 privacy protocol
v3-sec-level  - SNMPv3 security level
v3-username  - SNMPv3 username
```
Chapter 3  Setting Up Cisco Prime NAM

Setting Traffic Parameters

(*) - denotes a mandatory field for this configuration.

root@172-20-104-107.cisco.com(sub-device-netflow)#

**Step 3** Enter the IP address of the device as shown in this example (required):
root@172-20-104-107.cisco.com(sub-device-netflow)# address 192.168.0.1

**Step 4** If desired, enter the SNMP credentials for the device, as in the example below. If you specify snmp-version v2c, then you should enter the community string for the device. If you specify snmp-version v3, then you should enter the security level, username, authentication protocol, authentication passphrase, privacy protocol, and privacy passphrase.
root@172-20-104-107.cisco.com(sub-device-netflow)# snmp-version v2c
root@172-20-104-107.cisco.com(sub-device-netflow)# community public

**Step 5** Enter `show` to look at the device configuration that will be applied and verify that it is correct:
root@172-20-104-107.cisco.com(sub-device-netflow)# show
 DEVICE TYPE         : NDE (Netflow Data Export)
 DEVICE ADDRESS      : 192.168.0.1
 SNMP VERSION        : SNMPv2c
 V2C COMMUNITY       : public
 V3 USERNAME         :
 V3 SECURITY LEVEL   : No authentication, no privacy
 V3 AUTHENTICATION   :
 V3 AUTH PASSPHRASE  :
 V3 PRIVACY          : DES
 V3 PRIV PASSPHRASE  :

root@172-20-104-107.cisco.com(sub-device-netflow)#

**Step 6** Enter `exit` to come out of the subcommand mode and create the device. Remember the ID value that was assigned to the new device, you will need it to create the data source!
root@172-20-104-107.cisco.com(sub-device-netflow)# exit
Device created successfully, ID = 1
root@172-20-104-107.cisco.com#

**Step 7** Enter the command `data-source netflow`. You will now be in netflow data source subcommand mode as shown here:
root@172-20-104-107.cisco.com# data-source netflow
Entering into subcommand mode for this command.
Type 'exit' to apply changes and come out of this mode.
Type 'cancel' to discard changes and come out of this mode.
root@172-20-104-107.cisco.com(sub-data-source-netflow)#

**Step 8** Enter `?` to see all the command options available, as in the example below:
root@172-20-104-107.cisco.com(sub-data-source-netflow)# ?
 ? - display help
 cancel - discard changes and exit from subcommand mode
 device-id - netflow device ID (*)
 engine-id - netflow Engine ID
 exit - create data-source and exit from sub-command mode
 help - display help
 name - data-source name (*)
 show - show current config that will be applied on exit
Setting Traffic Parameters

(*) - denotes a mandatory field for this configuration.

root@172-20-104-107.cisco.com(sub-data-source-netflow)#

Step 9  Enter the device ID from Step 4 (required):
root@172-20-104-107.cisco.com(sub-data-source-netflow)# device-id 1

Step 10 Enter the name you would like for the data source (required):
root@172-20-104-107.cisco.com(sub-data-source-netflow)# name MyFirstNdeDataSource

Step 11 If desired, supply the specific Engine ID for this NetFlow data source (optional):
root@172-20-104-107.cisco.com(sub-data-source-netflow)# engine-id 123

Step 12 Enter show to look at the data source configuration that will be applied and verify that it is correct:
root@172-20-104-107.cisco.com(sub-data-source-netflow)# show

DATA SOURCE NAME : MyFirstNdeDataSource
DATA SOURCE TYPE : NDE (Netflow Data Export)
DEVICE ID : 1
DEVICE ADDRESS : 192.168.0.1
ENGINE ID : 123

root@172-20-104-107.cisco.com(sub-data-source-netflow)#

Step 13 Enter exit to come out of the subcommand mode and create the data source:
root@172-20-104-107.cisco.com(sub-data-source-netflow)# exit
Data source created successfully, ID = 3

The data source is now created, and NetFlow records from the device will be received and accepted by the Prime NAM as they arrive.

Deleting NetFlow Data Sources Using the Web GUI

To delete an existing NetFlow data source, use the following steps. If the autocreation feature is turned on, and the device continues to send NetFlow packets to the NAM, the data source will be recreated again automatically as soon as the next NetFlow packet arrives. Therefore, if you wish to delete an existing NetFlow data source, it is usually advisable to first turn the NetFlow autocreate feature off, as described earlier.

Step 1 Choose Setup > Traffic > NAM Data Sources.
Step 2 Click on the data source you would like to delete.
Step 3 Click the Delete button along the bottom of the window.
Deleting NetFlow Data Sources Using the CLI

To delete a NetFlow data source using the CLI, use the following steps. Note that when using the CLI, there are generally two separate phases involved. First you should delete the data source, then delete the device if you have no other data sources using the same device (for example with a different Engine ID value). As a shortcut, if you simply delete the device, then all data sources using that device will also be deleted.

Step 1  Show all data sources so you can find the ID of the one you want to delete:

```
root@172-20-104-107.cisco.com# show data-source

DATA SOURCE ID   : 1
DATA SOURCE NAME : DATA PORT 1
TYPE             : Data Port
PORT NUMBER      : 1
-----------

DATA SOURCE ID   : 2
DATA SOURCE NAME : DATA PORT 2
TYPE             : Data Port
PORT NUMBER      : 2
-----------

DATA SOURCE ID   : 3
DATA SOURCE NAME : MyFirstNdeDataSource
TYPE             : NDE (Netflow Data Export)
DEVICE ID        : 2
DEVICE ADDRESS   : 192.168.0.1
ENGINE ID        : 123
-----------

root@172-20-104-107.cisco.com#
```

Step 2  Use the `no data-source` command to delete the data source:

```
root@172-20-104-107.cisco.com# no data-source 3
Successfully deleted data source 3
root@172-20-104-107.cisco.com#
```

Step 3  Show all devices so you can find the ID of the one you want to delete:

```
root@172-20-104-107.cisco.com# show device

DEVICE ID            : 1
DEVICE TYPE          : NDE (Netflow Data Export)
IP ADDRESS           : 192.168.0.1
SNMP VERSION         : SNMPv2c
V2C COMMUNITY        : public
V3 USERNAME          :
V3 SECURITY LEVEL    : No authentication, no privacy
V3 AUTHENTICATION    : MD5
V3 AUTH PASSPHRASE   :
V3 PRIVACY           : DES
V3 PRIV PASSPHRASE   :
INFORMATION          : No packets received
STATUS               : Inactive
------

root@172-20-104-107.cisco.com#
```

Step 4  Use the `no device` command to delete the device:
Setting Traffic Parameters

root@172-20-104-107.cisco.com# no device 1
Successfully deleted device 1
root@172-20-104-107.cisco.com#

Note that if the autocreation mode is on, and the device continues to send NetFlow packets to the NAM, the data source (and device entry) will be re-created again automatically as soon as the next NetFlow packet arrives. Therefore, if you wish to delete an existing NetFlow data source, it is usually advisable to first turn the NetFlow autocreate feature off, as described earlier.

Testing NetFlow Devices

You can test the SNMP community strings for the devices in the Devices table. To test a device, select it from the Devices table, then click Test. The Device System Information Dialog Box displays. See Table B-7 for a description of the fields.

If the device is sending NetFlow Version 9 (V9) and the Prime NAM has received the NetFlow templates, then a V9 Templates button appears below the Device System Information window.

Note

NetFlow v9 templates do not appear in all NetFlow packets. When there are no templates, the V9 Templates button does not appear.

Performance Agent

The Performance Agent (PA) can monitor interface traffic and collect, analyze, aggregate, and export key performance analytics to the Prime NAM software for further processing and GUI visualization. PA integration with Prime NAM enables you to have a lower cost way to gain visibility into Application Response Time at the branch. Prime NAM integration with PA also reduces complexity of needing to manage a separate Prime NAM product within the branch.

PA has the ability to consolidate and filter information before it is exported, ensuring that only contextually-required data is exported and consumed versus all data. As an example, NetFlow supports a number of functions, including response time and traffic analysis. Instead of exporting multiple different flows, the PA has the intelligence to consolidate, filter, and export flow data that addresses the particular user’s need. Besides consolidating and filtering information, PA's mediation capabilities also includes the ability to use key Cisco IOS-embedded functionality (for example, Embedded Event Manager, or Class-Based QoS) to enrich both PA functionality and router value.

PA uses NetFlow to export data to the NAM. NAM uses the same port to receive NetFlow records and PA records. The default port is 3000, but you can change it using the NAM CLI.

Prime NAM provides five different collection points, each represented by a data source. Figure 3-2 shows an example of the data collection points. The solid line represents WAAS FA flows from the Core WAE. The broken line represents data exported from an ISR device only.
You can use the Prime NAM GUI to configure data sources at the locations in the network described in Table 3-6. Prime NAM automatically creates a data source for each PA optimization segment: Client, Client WAN, Passthrough, and Non-optimized.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client</td>
<td>This setting configures the WAE device to export the original (LAN side) TCP flows originated from its clients to Prime NAM for monitoring. To monitor this point, configure a Client data source.</td>
</tr>
<tr>
<td>Client WAN</td>
<td>This setting configures the WAE device to export the optimized (WAN side) TCP flows originated from its clients to Prime NAM for monitoring. To monitor this point, configure a Client WAN data source.</td>
</tr>
<tr>
<td>Passthrough</td>
<td>This is traffic that can be optimized, but is not because the traffic exceeds the WAAS Express’ capability.</td>
</tr>
<tr>
<td>Non-Optimized</td>
<td>This is traffic that is not optimized, because this kind of traffic is not defined in the optimization policy.</td>
</tr>
</tbody>
</table>

You can also configure a data source to use Export Passthrough data.

For information about configuring PA data sources, continue to Managing ISR PA Devices, page 3-27.

Managing ISR PA Devices

Before you can monitor Performance Agent (PA) traffic, you must first configure the device to export PA flow record data to the NAM. See the “Configuring Other System Settings” chapter of the Cisco Wide Area Application Services Configuration Guide:


After you enable flow export to the NAM, ISR devices will export data to the NAM, and they will be detected and automatically added to the Prime NAM’s device list.

If you want to see PA traffic in the NAM Health UDP settings options include port 3000 for all monitoring and detailed reports.
This section contains the following topics about using the Prime NAM GUI to manage data sources:

- Enabling Autocreation of PA Data Sources Using the Prime NAM GUI, page 3-28
- Creating PA Data Sources Using the Prime NAM GUI, page 3-28
- Disabling Autocreation of PA Data Sources Using the Prime NAM GUI, page 3-28

Enabling Autocreation of PA Data Sources Using the Prime NAM GUI

To configure Prime NAM to automatically create data sources when it receives PA packets from an external device, use the following steps. Remember however, that the autocreate feature is turned on by default, so these steps are typically not necessary.

**Step 1** Choose Setup > Traffic > NAM Data Sources.

**Step 2** Click the Auto Create button on the bottom left of the window.

**Step 3** Check the PA check box to toggle autocreation of PA data sources on.

**Step 4** Click the Submit button.

Creating PA Data Sources Using the Prime NAM GUI

To manually configure a PA data source using the Prime NAM GUI, for example if the autocreation feature is turned OFF, use the following steps. The autocreate feature is turned on by default, so these steps are typically not necessary.

**Step 1** Choose Setup > Traffic > NAM Data Sources.

**Step 2** Click the Create button along the bottom of the window.

**Step 3** From the Type drop-down list, choose “PA.”

**Step 4** Enter the IP address of the device that will export PA to the Prime NAM (required).

**Step 5** Click the “Version v1/v2c” radio button if SNMP v1 or v2c will be used to communicate with the device. Enter the community string that is configured on the device that is going to export PA packets to the NAM. Enter the same string in the “Verify” field. If you chose SNMPv1 or v2c, skip to **Step 8**.

**Step 6** Click the “Version v3” radio button if SNMP v3 will be used to communicate with the device.

**Step 7** Click the “Mode” radio button that corresponds with the desired credentials, and fill in the necessary fields. If valid SNMP credentials are provided, Prime NAM can upload readable text strings from the device to describe the interfaces on that device rather than just displaying the interfaces as numbers. You may specify either SNMPv2c or SNMPv3 credentials. See Table B-6 for more information.

**Step 8** Click the Test Connectivity button. You will be shown a success or failure message.

**Step 9** Click the Submit button.

Disabling Autocreation of PA Data Sources Using the Prime NAM GUI

**Step 1** Choose Setup > Traffic > NAM Data Sources.

**Step 2** Click the Auto Create button on the bottom left of the window.
Step 3 Uncheck the PA check box to toggle autocreation of PA data sources off.

Step 4 Click the Submit button.

Managing WAAS and WAN Traffic

This section contains the following topics about using the Prime NAM GUI to manage WAAS data sources:

- Understanding WAAS, page 3-29
- Considering Deployment Scenarios, page 3-30
- Using the WAAS Central Manager, page 3-31
- Monitoring Response Time from WAAS Data Sources, page 3-31
- Monitoring Client Data Sources, page 3-32
- Monitoring WAN Data Sources, page 3-33
- Monitoring Server Data Sources, page 3-33
- Enabling WAAS Flow Agent, page 3-33
- Adding Data Sources for New WAAS Device, page 3-34
- Editing WAAS Data Sources, page 3-34
- Deleting a WAAS Data Source, page 3-35
- Auto Create of New WAAS Devices, page 3-35

Understanding WAAS

Cisco Wide Area Application Services (WAAS) software optimizes the performance of TCP-based applications operating in a wide area network (WAN) environment and preserves and strengthens branch security. The WAAS solution consists of a set of devices called Wide Area Application Engines (WAEs) that work together to optimize WAN traffic over your network.

When client and server applications attempt to communicate with each other, the network devices intercept and redirect this traffic to the WAEs to act on behalf of the client application and the destination server.

WAEs provide information about packet streams traversing through both LAN and WAN interfaces of WAAS WAEs. Traffic of interest can include specific servers and types of transaction being exported. Prime NAM processes the data exported from the WAAS and performs application response time calculations and enters the data into reports you set up.

The WAEs examine the traffic and use built-in application policies to determine whether to optimize the traffic or allow it to pass through your network not optimized.

You can use the WAAS Top Talkers Detail Dashboard to analyze the traffic for optimization. See Analyzing Traffic for Optimization Using the Top Talkers Detail, page 4-14 for more information.

Cisco WAAS helps enterprises to meet the following objectives:

- Provide branch office employees with LAN-like access to information and applications across a geographically distributed network.
- Migrate application and file servers from branch offices into centrally managed data centers.
• Minimize unnecessary WAN bandwidth consumption through the use of advanced compression algorithms.
• Provide print services to branch office users. WAAS allows you to configure a WAE as a print server so you do not need to deploy a dedicated system to fulfill print requests.
• Improve application performance over the WAN by addressing the following common issues:
  - Low data rates (constrained bandwidth)
  - Slow delivery of frames (high network latency)
  - Higher rates of packet loss (low reliability)

For more information about WAAS and configuring the WAAS components, see the Cisco Wide Area Application Services Configuration Guide.

### Considering Deployment Scenarios

Table 3-7 lists six different deployment scenarios you might consider to monitor the optimized traffic on your WAAS network. Scenario #1 is typical when using NAM-1X, -2X or -3 blades.

<table>
<thead>
<tr>
<th>Deployment Scenario</th>
<th>Edge WAE Data Source</th>
<th>Core WAE Data Source</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Client</td>
<td>Server</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Server WAN</td>
</tr>
<tr>
<td>2</td>
<td>Client</td>
<td>Server</td>
</tr>
<tr>
<td></td>
<td>Client WAN</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Server</td>
<td>Client</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Client WAN</td>
</tr>
<tr>
<td>4</td>
<td>Server</td>
<td>Client</td>
</tr>
<tr>
<td></td>
<td>Server WAN</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Client</td>
<td>Client</td>
</tr>
<tr>
<td></td>
<td>Server</td>
<td>Client WAN</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Server WAN</td>
</tr>
<tr>
<td>6</td>
<td>Client</td>
<td>Client</td>
</tr>
<tr>
<td></td>
<td>Server</td>
<td>Client WAN</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Server WAN</td>
</tr>
</tbody>
</table>

Consider Table 3-7 for planning your deployment scenario on your WAAS network.
Using the WAAS Central Manager

The Cisco WAAS is centrally managed by a scalable, secure, and simple function called the Cisco WAAS Central Manager, which runs on Cisco WAE Appliances. The Cisco WAAS Central Manager provides a centralized mechanism for configuring features, reporting, and monitoring, and can manage a topology containing thousands of Cisco WAE nodes.

Prime NAM is accessible from within the Central Manager interface. Prime NAM integration with WAAS Central Manager provides for easier viewing of Prime NAM reports that are directly associated with Application Response Time measurements through the WAN, in both WAAS optimized and non-optimized environments.

Below is a standard configuration workflow that you can follow.

Prerequisites are that the WAAS Central Manager is installed and functional, and the Cisco NAM (device or virtual blade) is installed and functional.

---

**Step 1**  From the WAAS Central Manager, configure the Cisco NAM IP address and login credentials.

**Step 2**  From the router or switch, configure the data source(s) for baseline (SPAN).

**Step 3**  From the WAAS Central Manager, configure the Site definition. See Configuring Sites, page 3-50 for more information.

**Step 4**  In the Monitor section of WAAS Central Manager, one can observe the Top Talkers under the Network Analysis tab. See Analyzing Traffic for Optimization Using the Top Talkers Detail, page 4-14 for more information.

**Step 5**  From the WAAS Central Manager, configure the WAAS Flow Agent and branch/data center WAEs.

**Step 6**  Create Device Groups for the branch and data center on the WAAS Central Manager, and assign a device to the Device Groups.

**Step 7**  Enable the Flow Agent on the WAAS, pointing to the Cisco NAM IP. Segments are automatically selected (enabled only if Cisco NAM is configured). Prime NAM will start to compute baseline ART, protocol distribution, and Top Talkers. See Enabling WAAS Flow Agent, page 3-33.

**Step 8**  Turn on WAAS optimization. See Optimizing WAN, page 4-13 for more information.

**Step 9**  Turn on the Flow Agent and identify the servers to monitor to get ART improvements. See Editing WAAS Data Sources, page 3-34.

---

**Monitoring Response Time from WAAS Data Sources**

Prime NAM processes the TCP flow data exported from the WAAS and performs application response time (ART) calculations and reports. You use the Prime NAM GUI to create a WAAS data source to monitor WAAS traffic statistics. In addition to ART, Prime NAM monitors and reports other traffic statistics of the WAAS data sources including application, host, and conversation information.

Prime NAM provides different ART metrics by collecting data at different points as packets flow along their paths. Prime NAM provides five different collection points, each represented by a WAAS data source. Figure 3-3, WAAS Data Sources (Data Collection Points), shows an example of the data collection points. The solid line represents data exported from a WAAS device and/or directly monitored traffic like SPAN. The broken line represents data exported from a WAAS device only.
You can use the Prime NAM GUI to configure data sources at the locations in the network described in Table 3-8.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client</td>
<td>This setting configures the WAE device to export the original (LAN side) TCP flows originated from its clients to Prime NAM for monitoring. To monitor this point, configure a Client data source.</td>
</tr>
<tr>
<td>Client WAN</td>
<td>This setting configures the WAE device to export the optimized (WAN side) TCP flows originated from its clients to Prime NAM for monitoring. To monitor this point, configure a Client WAN data source.</td>
</tr>
<tr>
<td>Server WAN</td>
<td>This setting configures the WAE device to export the optimized (WAN side) TCP flows from its servers to Prime NAM for monitoring. To monitor this point, configure a Server WAN data source.</td>
</tr>
<tr>
<td>Server</td>
<td>This setting configures the WAE device to export the original (LAN side) TCP flows from its servers to Prime NAM for monitoring. To monitor this point, configure a Server data source.</td>
</tr>
<tr>
<td>Passthrough</td>
<td>This setting configures the WAE device to export the TCP flows that are passed through unoptimized.</td>
</tr>
</tbody>
</table>

You can also configure a data source to use Export Passthrough data. For more information about configuring WAAS data sources, see Editing WAAS Data Sources, page 3-34.

Monitoring Client Data Sources

By monitoring the TCP connections between the client and the WAE device (Client segment in Figure 3-3), you can measure the following ART metrics:

- Total Response Time as experienced by the client
- Total Transaction Time as experienced by the client
- Bandwidth usage (bits/packets) before optimization
- Number of transactions and connections.
• Network Time broken down into two segments: client-edge and edge-server

To view detailed views of this data, select the Analyze > Response Time. > Detailed Views submenu.

Monitoring WAN Data Sources

By monitoring the TCP connections between the edge and core WAE devices (Client WAN and Server WAN segments in Figure 3-3), you can measure the following:

• Bandwidth usage (bits/packets) after optimization
• Network Time of the WAN segment

Monitoring Server Data Sources

By monitoring the TCP connections between the core WAE devices and the servers (Server segment in Figure 3-3), you can measure the following ART metrics:

• Server Response Time (without proxy acceleration/caching server)
• Network Time between the core WAE device and the servers

Note: Prime NAM measures Network Time by monitoring the TCP three-way handshake between the devices.

Enabling WAAS Flow Agent

Before you can monitor WAAS traffic, you must first configure the WAAS device to export WAAS flow record data to the Prime NAM. Use the following WAAS command-line interface (CLI) flow monitor command to enable the Flow Agent on the WAAS:

```
flow monitor tcpstat-v1 host <nam IP address>
flow monitor tcpstat-v1 enable
```

After you enable flow export to the Prime NAM using WAAS CLI commands like those above, WAAS devices will be detected and automatically added to the NAM’s WAAS device list.

You must then configure the WAAS segments you want to monitor as WAAS data sources: Client, Client WAN, Server WAN, and/or Server. See Editing WAAS Data Sources, page 3-34, for more detailed information.

You can also use the WAAS Central Manager to centrally issue WAAS CLI commands to configure a large number of WAEs at one time. Prime NAM is accessible from within the WAAS Central Manager interface. For more information about WAAS Central Manager, refer to the WAAS technical documentation.

Note: In addition to configuring the WAAS devices, you must specify which application servers you want to monitor among the servers being optimized by WAAS devices. See Configuring WAAS Monitored Servers, page 3-66, for more detailed information.

For more information about WAAS and configuring the WAAS components, see the Cisco Wide Area Application Services Configuration Guide.

This section contains the following topics:

• Adding Data Sources for New WAAS Device, page 3-34
Setting Traffic Parameters

- Editing WAAS Data Sources, page 3-34
- Deleting a WAAS Data Source, page 3-35

Adding Data Sources for New WAAS Device

Prime NAM uses WAAS data sources to monitor traffic collected from different WAAS segments: Client, Client WAN, Server WAN, and Server. Each WAAS segment is represented by a data source. You can set up Prime NAM to monitor and report other traffic statistics of the WAAS data sources such as application, host, and conversation information in addition to the monitored Response Time metrics.

Note

This step is not usually necessary because export-enabled WAAS devices are detected and added automatically. See Enabling WAAS Flow Agent, page 3-33, for more information about how to enable WAAS export to the NAM.

To manually add a WAAS device to the list of devices monitored by Prime NAM:

Step 1 Choose Setup > Traffic > NAM Data Sources.

Step 2 Click Create.

The Prime NAM Data Source Configuration Dialog appears.

Step 3 Choose “WAAS” from the list of Types.

Step 4 Enter the device IP address in the IP field.

Step 5 Check the check boxes for the appropriate WAAS Segments. See Table 3-8.

Step 6 Click Submit to add the new WAAS custom data source.

Editing WAAS Data Sources

Prime NAM uses WAAS data sources to monitor traffic collected from different WAAS segments: Client, Client WAN, Server WAN, and Server. Each WAAS segment is represented by a data source. You can set up Prime NAM to monitor and report other traffic statistics of the WAAS data sources such as application, host, and conversation information in addition to the monitored Response Time metrics.

To edit a WAAS device’s custom data source:

Step 1 Choose Setup > Traffic > NAM Data Sources. The data sources are displayed.

Step 2 Choose the WAAS device you want to modify, and then click Edit.

You can configure the WAAS data sources to monitor the following WAAS segments as shown in Figure 3-3, WAAS Data Sources (Data Collection Points):

- Client—This setting configures the WAE device to export the original (LAN side) TCP flows originated from its clients to Prime NAM for monitoring.
- Client WAN—This setting configures the WAE device to export the optimized (WAN side) TCP flows originated from its clients to Prime NAM for monitoring.
- Server WAN—This setting configures the WAE device to export the optimized (WAN side) TCP flows from its servers to Prime NAM for monitoring.
Chapter 3  Setting Up Cisco Prime NAM

Setting Traffic Parameters

- **Server**—This setting configures the WAE device to export the original (LAN side) TCP flows from its servers to **Prime NAM** for monitoring.

SPAN data sources might take the place of the WAE Server data sources listed in Table 3-7. For example, if you already configure SPAN to monitor the server LAN traffic, it is not necessary to enable the Server data source on the WAE device.

---

**Note**

The following step is optional and applies only when **Prime NAM** is configured to export data to an External Response Time Reporting Console, such as the NetQos Super Agent.

---

Deleting a WAAS Data Source

To delete a WAAS custom data source:

**Step 1** Choose **Setup > Traffic > NAM Data Sources**. The data sources are displayed.

**Step 2** Choose the WAAS custom data source you want to delete, then click the **Delete** button.

A dialog box displays the device address and asks if you are sure you want to delete the device.

---

Auto Create of New WAAS Devices

If you have numerous WAE devices, you can set up **Prime NAM** to configure newly discovered WAE devices using a predefined configuration template using the **Prime NAM** auto configuration option.

**Note**

If most of your WAE devices are edge WAE, you might want to set the auto configuration to be that of the edge device, then manually configure the data center WAE. For example, select the Client segment for monitoring.

To configure WAAS autoconfiguration:

**Step 1** Choose **Setup > Traffic > NAM Data Sources**. The data sources are displayed.

**Step 2** Click the **Auto Create** button.

The Prime NAM Data Source Configuration Dialog displays.

**Step 3** Check the **WAAS** check box.

**Step 4** Check the check boxes for the desired Segments. See **Editing WAAS Data Sources, page 3-34**, for more information.
Configuring Hardware Deduplication

This section applies only to Cisco NAM 2320, 2220, and 2204 appliances.

Prime NAM supports hardware-based detection of duplicate packets and allows you to configure a single deduplication filter that reduces the amount of duplicate traffic across all adapter ports.

You can use deduplication to eliminate redundant data. This can help to significantly shrink storage requirements and improve bandwidth efficiency on tasks like backup and recovery.

After you enable deduplication, the NAM appliance detects and filters the duplicated packets. The packet is identified as duplicated if all inspected segments match another packet within the specific time window.

In addition to the duration-based timeout, there is also a fixed packet-count timeout. There cannot be more than 7 packets between the duplicate packets. If packets 0 and 8 are identical, packet 8 will be dropped. If packets 0 and 9 are identical, packet 9 will not be dropped.

To configure packet deduplication:

**Step 1** Choose Setup > Traffic > Hardware Deduplication.

**Step 2** Check the Enabled check box to enable packet deduplication.

Enter a value in the Time Window (1-127 in microseconds ($\mu s$)) for the search or buffer period.

The value you set in the Time Window indicates the length of time (n microseconds) in which two packets can be considered duplicates. If the Time Window is 100 $\mu s$ but two identical packets arrive 120 $\mu s$ apart, the second packet would not be dropped. If the identical packets arrive 80 $\mu s$ apart, the second packet would be dropped.

**Step 3** Click to choose a segment of the packet to inspect for deduplication.

The default inspects the entire packet. The second option inspects all segments except the ISL portion of the packet. The third option inspects all segments except the ISL, MAC, and VLAN portions of the packet. The fourth option inspects all segments except the ISL, MAC, and VLAN portions of the packet. The final (bottom) option inspects only the UDP/TCP and payload segments of the packet.

**Step 4** Click Submit to enable the settings you have entered, or click Reset to cancel any change.

Setting Up Alarms and Alarm Thresholds

Alarms are predefined conditions based on a rising data threshold, a falling data threshold, or both. You can choose what types of events for which you want Prime NAM to notify you, and how you want to be notified. Monitoring alarms enables you to watch problem areas and collect data on areas such as increased utilization, severe application response delays, and voice quality degradation.
Chapter 3 Setting Up Cisco Prime NAM

This is the order that you typically follow for setting up alarms and alarm thresholds:

**Step 1** Depending on the type of alarm action you would like to configure, define the way you would like to be notified (by e-mail, trap, trigger capture, or syslog).
- For e-mail server settings: Choose **Administration > System > E-Mail Setting**
- For trap settings: Choose **Administration > System > SNMP Trap Setting**
- For capture session settings: Choose **Capture > Packet Capture/Decode > Sessions**
- For syslog settings: Choose **Administration > System > Syslog Setting**

**Step 2** Define the Alarm Action at **Setup > Alarms > Actions**.

**Step 3** Define the Threshold for this alarm at **Setup > Alarms > Thresholds**.

The tasks for setting up alarms are:
- Configuring Alarm Actions, page 3-37
- Viewing Alarm Actions, page 3-38
- Defining Thresholds, page 3-39

### Configuring Alarm Actions

When a threshold’s rising water mark is crossed, the alarm condition is met. This will trigger the alarm action to take effect. Prime NAM supports the following alarm actions:

- **E-mail syslog**: An alarm action that e-mails the syslog content of the alarm condition. To avoid e-mail flooding the network, Prime NAM does not send more than five e-mails in any given hour.
- **Trap**: An alarm action that sends Prime NAM trap messages to one or more trap servers. Any trap server that has the same community string will receive the trap message. Prime NAM uses Cisco Syslog MIB in the trap message. To avoid trap flooding, the limit is ten trap messages per interval.
- **Trigger capture**: An alarm action to start or stop a pre-defined capture sessions or stop a capture to save it to a file.
- **Remote syslog**: An alarm action that sends syslog messages to remote syslog servers. The limit is ten syslog messages per interval to avoid flooding the network.

Prime NAM supports any combination of the above four actions in one alarm condition.

To configure e-mail alarm actions:

**Step 1** Choose **Setup > Alarms > Actions**.
The Alarm Action page displays any configured actions. If none of the four actions (e-mail, trap, capture, or syslog) are configured, you will see **No data available**.

**Step 2** Click the **Create** button.

**Step 3** Enter a Name for the action (up to 63 characters).

**Step 4** Choose the type of alarm action:
- **E-mail**: Configure the e-mail address in **Administration > System > E-Mail Setting**. Prime NAM alarm mail is sent as a result of Prime NAM alarms, not router or switch alarms.
Prime NAM sends up to five e-mails per hour per function (traffic and NetFlow, voice signaling, RTP, and application response time). Also, in each e-mail, there could be up to five alarm messages. These limits are in place to avoid e-mail overload.

If you have configured e-mail alarms and do not receive e-mail, then your Prime NAM does not have any alarms.

If Prime NAM is planning to send you many alarm messages, the e-mail may state, for example, “5 of 2,345 alarm messages.”

- **Trap**: Choose the SNMP community where you would like traps to be sent. Configure the community string in **Administration > System > SNMP Trap Setting**. After the “Community field appears, choose the community string from the drop-down list.

- **Trigger Capture**: From the Session drop-down, choose the session (the list will be empty if there is no capture session configured in **Capture > Packet Capture/Decode > Sessions**). Click the Start, Stop, or Stop Capture and Save to File radio button. For more details, see **Understanding Trigger Capture, page 3-39**.

- **Syslog**: This will log syslog messages. The default setting is to log syslog messages locally to Prime NAM. If you want to log syslog messages to remote servers, set up the destination information at **Administration > System > Syslog Setting**.

**Step 5** Click Submit.
The Alarm Action table displays the newly configured action in its list.

**Step 6** To edit or delete alarm actions, see **Editing Alarm Actions, page 3-38** and **Deleting Alarm Actions, page 3-39**.

### Viewing Alarm Actions

Alarms are predefined conditions based on a rising data threshold, a falling data threshold, or both. You can set thresholds and alarms on various network parameters such as increased utilization, severe application response delays, and voice quality degradation and be alerted to potential problems.

Prime NAM supports IPv6 for all alarm functionality.

**Note** You could see two alarms for the same occurrence if both the source and the destination are in the same site.

To see events that have been created, choose **Setup > Alarms > Actions**. See **Table B-8 for descriptions of the fields on the Alarm Configuration window.**

To configure alarm actions, see **Configuring Alarm Actions, page 3-37**.

### Editing Alarm Actions

To edit an alarm action:

**Step 1** Choose **Setup > Alarms > Actions**.
The Alarm Action table displays any configured Alarms.
Step 2  Choose the alarm event you want to modify, and click the Edit button.

Deleting Alarm Actions

To delete an alarm:

Step 1  Choose Setup > Alarms > Actions.
The Alarm Action table displays any configured Alarms.

Step 2  Choose the alarm event you want to remove, and click the Delete button.

Understanding Trigger Capture

This section describes how to use a trigger capture to start a capture session based on the alarm parameters you set. For example, you can set alarm parameters on various thresholds to start a capture session which can be used to investigate some kind of questionable network activity.

You must set your alarm threshold parameters so that Prime NAM has defined rising or falling numbers that will cause an action, or trigger, to start a capture session. You can also use the stop-and-save option. The actions are defined below:

- **Trigger Capture Start**—An alarm condition occurs based on threshold parameters you have set; the capture session starts automatically.
- **Trigger Capture Stop**—An alarm condition occurs based on the threshold parameters you have set; the capture session stops automatically.
- **Trigger Capture Stop Capture and Save to File**—An alarm condition occurs, stopping the capture session. If the captured packet data is in memory, it is saved to a file. The buffer memory is then clear to wait for next alarm event.

When an event occurs that you have defined as an alarm threshold, NAM stops any existing capture session and saves the captured packets from memory into a file. The capture session then restarts. NAM can save up to five files, depending on your local hard disk storage.

NAM monitors for threshold parameters every minute. For real-time data, the default is 5 minutes.

Defining Thresholds

Prime NAM can inspect incoming performance records and apply a configured set of thresholds to the most recent interval of data. Using thresholds allows you to target specific network traffic issues and set up notifications that are triggered when certain thresholds are crossed. For example:

- if a server's CPU load exceeds 90%
- if a device or the whole network uses more bandwidth than usual, or
- if the remaining file size on a disk drive is less than 15% or 100 MB.

In general, you should set thresholds so that only severe traffic problems that impact quality of service generate events. These critical events are intended to provide actionable notification of problems to network operators. When setting thresholds try to identify a traffic level that will have a noticeable effect on network service levels. Set a duration that corresponds to an unacceptable period of poor service. The
goal is to generate very few, significant events indicating severe problems that require immediate attention. Thresholds are not intended as a reporting tool to generate statistical information about network traffic.

To set up alarm thresholds for variables with values that trigger alarms, see Viewing Alarm Actions, page 3-38.

You could receive two alarms for the same occurrence if both the source and the destination are in the same site.

You can also decide whether you want to be notified if the threshold is being crossed just once, or whether you only want an alarm to be triggered if this state persists for a certain time. This helps you to ensure an effective network monitoring system, which will not bombard you with unnecessary notifications.

Prime NAM Threshold Alarms window (Setup > Alarms > Thresholds) displays thresholds you have configured. If you hover over the arrow next to the threshold Name a detailed view of the selected threshold displays.

For descriptions of the fields on the Threshold window, see Table B-9.

You can set up alarm thresholds by defining threshold conditions for monitored variables on the NAM.

You can configure the following thresholds:

- Setting Host Thresholds, page 3-40
- Setting Conversation Thresholds, page 3-41
- Setting Application Thresholds, page 3-41
- Setting Response Time Thresholds, page 3-42
- Setting DSCP Thresholds, page 3-42
- Setting RTP Stream Thresholds, page 3-42
- Setting Voice Signaling Thresholds, page 3-43
- Setting NetFlow Interface Thresholds, page 3-44

Related Topics

- Configuring Alarm Actions, page 3-37
- Viewing Alarm Actions, page 3-38

Setting Host Thresholds

Step 1 Choose Setup > Alarms > Thresholds.

Step 2 Click the Create button and choose the Host tab.

Step 3 The Host Alarm Threshold Configuration window displays. Fill in the fields as appropriate.

Table B-10 describes the fields available on this window.

Note If you leave a selection blank, it means that the parameter will not be considered. If you select Any, it will use any of the selections for that parameter, if encountered.
Setting Up Alarms and Alarm Thresholds

Setting Conversation Thresholds

Step 1 Choose Setup > Alarms > Thresholds.

Step 2 Click the Create button and choose the Conversation tab.

Step 3 The Conversation Alarm Threshold Configuration window displays. Fill in the fields as appropriate.

Table B-11 describes the fields available in this window.

Note If you leave a selection blank, it means that that parameter will not be considered. If you select Any, it will use any of the selections for that parameter, if encountered.

Step 4 Click Submit to set the thresholds, click Reset to reset the thresholds to their default value, or click Cancel to remove any changes you might have made.

Step 5 When finished, click Submit.

Setting Application Thresholds

Step 1 Choose Setup > Alarms > Thresholds.

Step 2 Click the Create button and choose the Application tab.

Step 3 The Application Alarm Threshold Configuration window displays. Fill in the fields as appropriate.

Table B-12 describes the fields available in this window.

Note If you leave a selection blank, it means that parameter will not be considered. If you select Any, it will use any of the selections for that parameter, if encountered.

Step 4 Click Submit to set the thresholds, click Reset to reset the thresholds to their default value, or click Cancel to remove any changes you might have made.

Step 5 When finished, click Submit.
Setting Response Time Thresholds

Step 1  Choose Setup > Alarms > Thresholds.
Step 2  Click the Create button and choose the Response Time tab.
Step 3  The Response Time Alarm Threshold Configuration window displays. Fill in the fields as appropriate. Table B-13 describes the fields available in this window.

Note  If you leave a selection blank, it means that that parameter will not be considered. If you select Any, it will use any of the selections for that parameter, if encountered.

Step 4  Click Submit to set the thresholds, click Reset to reset the thresholds to their default value, or click Cancel to remove any changes you might have made.
Step 5  When finished, click Submit.

Setting DSCP Thresholds

Step 1  Choose Setup > Alarms > Thresholds.
Step 2  Click the Create button and choose the DSCP tab.
Step 3  The DSCP Alarm Threshold Configuration window displays. Fill in the fields as appropriate. Table B-14 describes the fields available in this window.

Note  If you leave a selection blank, it means that that parameter will not be considered. If you select Any, it will use any of the selections for that parameter, if encountered.

Step 4  Click Submit to set the thresholds, click Reset to reset the thresholds to their default value, or click Cancel to remove any changes you might have made.
Step 5  When finished, click Submit.

Setting RTP Stream Thresholds

Prime NAM sends syslog, trap, e-mail, and trigger captures for RTP streams that violate stream statistics thresholds on the following metrics:

– Number of Consecutive Packet Loss

Each RTP packet has an RTP header that contains a sequence number. The sequence number increments by one for each RTP packet received in the same RTP stream. A gap in the sequence numbers identifies a packet loss. If the gap in sequence numbers jump is more than the threshold, the software raises an alarm condition.
Setting Up Alarms and Alarm Thresholds

- Packet Loss percent

There are two types of percent packet loss percent: Adjusted Packet Loss and Actual Packet Loss. Actual Packet Loss indicates expected packets that never appear in Prime NAM. Adjusted Packet Loss includes actual packets lost and packets that arrive with large delay beyond the expected buffer capacity of the endpoint.

- Jitter: Packets delay compare to the expected receiving time

- Concealment Seconds: Seconds in which there is one or more packets lost

- Severe Concealment Seconds: Seconds in which there is more than 5% of packet lost

To set thresholds for RTP streams:

1. Choose Setup > Alarms > Thresholds.
2. Click the Create button and choose the RTP Streams tab.
3. The RTP Stream Alarm Threshold Configuration window displays. Fill in the fields as appropriate. Table B-15 describes the fields available in this window.

Note: If you leave a selection blank, it means that that parameter will not be considered. If you select Any, it will use any of the selections for that parameter, if encountered.

4. Click Submit to set the thresholds, click Reset to reset the thresholds to their default value, or click Cancel to remove any changes you might have made.
5. When finished, click Submit.

Setting Voice Signaling Thresholds

You can set up software to monitor voice call quality. When Cisco Unified Communication Manager’s call detail records option is enabled, Cisco IP phones, both SCCP and SIP, will report the call’s jitter and packet loss at the end of the call. Prime NAM intercepts this information and raises an alarm when the alarm condition crosses the rising threshold.

To set up a voice signaling threshold:

1. Choose Setup > Alarms > Thresholds.
2. Click the Create button and choose Voice Signaling tab.
3. The Voice Signaling Alarm Threshold Configuration window displays. Fill in the fields as appropriate. Table B-16 describes the fields available under the Voice Signaling Metrics drop-down menu.

Note: If you leave a selection blank, it means that that parameter will not be considered. If you select Any, it will use any of the selections for that parameter, if encountered.
Step 4  Click **Submit** to set the voice signaling thresholds, click **Reset** to reset the thresholds to their default value, or click **Cancel** to remove any changes you might have made.

Step 5  When finished, click **Submit**.

---

**Setting NetFlow Interface Thresholds**

**Step 1**  Choose **Setup > Alarms > Thresholds**.

**Step 2**  Click the **Create** button and choose the **NDE Interface** tab.

The NDE Interface Alarm Threshold Configuration window displays. The fields are described in Table B-17.

**Note**  If you leave a selection blank, it means that that parameter will not be considered. If you select **Any**, it will use any of the selections for that parameter, if encountered.

**Step 3**  Click **Submit** to set the thresholds, click **Reset** to reset the thresholds to their default value, or click **Cancel** to remove any changes you might have made.

---

**Editing or Deleting an Alarm Threshold**

You can edit alarm thresholds on an as-needed basis. You can delete thresholds when you no longer need them. Any changes take effect immediately.

To edit or delete an alarm threshold:

**Step 1**  Choose **Setup > Alarms > Thresholds**.

The Thresholds table displays.

**Step 2**  Select the alarm, then click **Edit** or **Delete**.

**Step 3**  Depending on your selection:

- If you selected to edit, the dialog box displays for the type of alarm; for example, **Host Threshold**. Make the necessary changes. Then
  - click **Submit** to save your changes
  - click **Reset** to reset the thresholds to the values set before you edited them, or
  - click **Cancel** to cancel the edit and return to the previous page.

- If you selected to delete, click **OK** to confirm deletion, or click **Cancel** to leave the configuration unchanged.
Scheduling Data Report Exports

You can use Prime NAM to schedule data collection over a period of time for trend analysis and troubleshooting activities and then export the reports to be viewed at your convenience. For example, if you see a spike in application response time on a certain day or time you can set up a scheduled report. The report exports collected data from a specific range of time so that you have a snapshot of what might be causing issues.

You can set up scheduled jobs that will generate a daily report at a specified time, in a specified interval, and e-mail it to a specified e-mail address or addresses.

You can also obtain a report immediately by clicking the **Preview** button, rather than wait for the scheduled time. This report can also be sent after you preview it.

Tip

Prime NAM displays time in this report based on the browser that initiated the report. So if your browser is in San Jose, CA, the time zone displayed in the report is based on the time zone of that machine. The data is not based on the Cisco NAM server time if the two machines are not synchronized. To synchronize your time, see **Synchronizing Your System Time, page 6-6**.

This section covers the following topics:

- Creating a Scheduled Report Export, page 3-45
- Editing a Scheduled Export Job, page 3-46
- Deleting a Scheduled Export Job, page 3-46

Creating a Scheduled Report Export

Scheduled export of data reports is a convenient way to collect traffic of interest in Prime NAM. We strongly recommend you to define your data report time range first and then set your export time right after your report end time. This is the most straight-forward way to use this feature.

To set up a scheduled report and export it to an e-mail address or addresses:

**Step 1**

From any Monitor or Analyze window, click the **Export** button in the Interactive Report pane to select your export preferences. If you want the report to contain filtered data, enter the filters before selecting **Export**.

**Step 2**

Choose the Report Time by selecting a time range for the interval of time you want data measured. The time range is limited to a 24 hour period. Any time range that includes midnight will have a **from** time larger than **to** time.

**Step 3**

Choose the Export Time (which is the day of the week on which to generate the weekly report and hour that report will be sent). Multiple days are supported. You can also specify what time to start the export.

The actual data time range used to generate the report for export is always the last available and complete time span specified in the Report Time step above. Prime NAM does not generate reports using data in any future time. For example:
Scheduling Data Report Exports

Chapter 3  Setting Up Cisco Prime NAM

### Export Time  Report Time  Data Reported and Exported

<table>
<thead>
<tr>
<th>Export Time</th>
<th>Report Time</th>
<th>Data Reported and Exported</th>
</tr>
</thead>
<tbody>
<tr>
<td>If Every Day and Hour is 09:00</td>
<td>07:00 to 08:00</td>
<td>07:00 to 08:00 the same day (recommended use case)</td>
</tr>
<tr>
<td>If Monday and Friday and Hour is 03:00</td>
<td>05:00 to 05:59</td>
<td>Sunday and Thursday 05:00 to 05:59</td>
</tr>
<tr>
<td>If Every Day and Hour is 00:00</td>
<td>18:00 to 01:00</td>
<td>Previous day from 18:00 to 01:00</td>
</tr>
</tbody>
</table>

**Tip**
Set your Export Time to occur right after the end of Report Time. This gives you the most recent data and is the easiest way to use this feature.

**Step 4**
Enter the e-mail address to which you would like the report delivered.

**Step 5**
Choose the delivery option (CSV or PDF).

**Step 6**
Enter the Report Name and Report Description, which appear at the end of the report delivered to you.

**Step 7**
Click:
- **Submit** to submit the request for the scheduled job.
- **Preview** to generate the report immediately.

**Note**
Remember that report results are based on the local time of the browser that initiated the report.

### Editing a Scheduled Export Job

**Step 1**
Choose **Setup > Data Export > Scheduled Exports**.

**Step 2**
Click the job you want to edit.

**Step 3**
Click the **Edit** button.

**Step 4**
Modify the information as desired.

**Step 5**
Click:
- **Submit** to submit the request for the scheduled job
- **Reset** to clear the values in the dialog box
- **Cancel** to close the dialog box and return to the previous window.

### Deleting a Scheduled Export Job

**Step 1**
Choose **Setup > Data Export > Scheduled Exports**.
**Accessing Device Interface and Health Details**

You can enable your NAM to access interface and health device details if they are available on the device you identify using the Prime NAM Managed Device feature.

This section contains the following topics:

- Understanding How Platform-Specific NAMs Handle Managed Device Data, page 3-47
- Configuring Managed Device Information, page 3-48
- Viewing Managed Device Information, page 3-49
- Setting Up NBAR Protocol Discovery on a Managed Device, page 3-49

**Understanding How Platform-Specific NAMs Handle Managed Device Data**

A managed device can represent a router or switch being monitored by Prime NAM. Depending on your Cisco NAM platform, the managed device is accessed by the NAM differently and may support different MIBs based on the device support.

The following details list how NAM accesses the managed device:

- For a physical or virtual blade or service module, the managed device is the device in which NAM software or hardware is located. The managed device information is automatically updated without user intervention and cannot be modified on the NAM. One of the benefits of having a blade or service module is that there is no configuration required for this feature.

- For a physical appliance, you identify the managed device as a switch or router that shares its traffic using SPAN or user credentials. You must enter the device address and either the SNMP credentials or NetConf credentials to configure the NAM SPAN session on the managed device. On certain platforms, NetConf is an alternative for NAM to configure a NAM SPAN session on a managed device which does not support configuring NAM SPAN sessions using SNMP. If you choose to use NetConf, you must enable NetConf on the managed device interface and enable SSH to support the SPAN session. This enables you to monitor managed device information such as interface statistics.

- All supported NAM platforms, except NAM-NX1 and vNAM, require if-mib (ifTable) to provide the managed device interface data. NAM-NX1 gets this data by exchanging messaging with the Supervisor card (SUP) on the EOBC channel. SPAN session configuration from a managed device is not allowed on Cisco Prime vNAMs.

- All supported NAM platforms, except for NAM-NX1, vNAM, and NAM appliance platforms, require entity-mib and if-mib to get and configure SPAN sessions. NAM-NX1 uses EOBC and proprietary messages with SUP on EOBC to get and configure SPAN sessions. Appliances have two options to get and configure SPAN sessions: SNMP (which use the MIBs required by the other NAM platforms) or NetConf interface (which require no MIBs). SPAN session configuration from a managed device is not allowed on Cisco Prime vNAMs.

To see a list of the available platforms and supported devices, see the NAM Compatibility Matrix. For MIB support, see Table B-55 on page B-46.
Configuring Managed Device Information

The managed device information that is required is dependent on your platform device type. For details, see Understanding How Platform-Specific NAMs Handle Managed Device Data, page 3-47.

For details on how to ensure NAM is managing your device interface and other traffic, see:

- Configuring Managed Device Information on Blades or Modules, page 3-48
- Configuring Managed Device Information on Appliances and other Virtual Platforms, page 3-48

Configuring Managed Device Information on Blades or Modules

You are not required to configure NAM blades or modules on the NAM side.

Note

NAM-1X, -2X, and -3 platforms require SNMP MIBs (SNMPv3 is not required). SNMP requests and responses are communicated over an internal interface within the chassis and SNMPv3 is not used. NAM-NX1 requires some SNMP MIBs.

Ensure you follow the configuration instructions in your platform documentation so that your managed device communicates network traffic to NAM.

Once NAM automatically updates your managed device details, you can view that information using Setup > Managed Device > Device Information. For details, see Viewing Managed Device Information, page 3-49.

For details about how NAM treats managed devices, see Accessing Device Interface and Health Details, page 3-47.

Configuring Managed Device Information on Appliances and other Virtual Platforms

For appliances and some virtual NAM platforms, you must set up your managed device using the NAM Setup > Managed Device > Device Information window. Enter your device address and credentials to allow NAM SPAN session configuration. You will need to configure SNMP credentials to receive details about managed device interface statistics. You may need to configure NetConf credentials to enable a NAM SPAN session to and from the managed device. To use NetConf, your managed device must support the NetConf interface and have SSH enabled. You can use NetConf as an alternative to configuring a NAM SPAN session on your managed device if your device does not support configuring NAM SPAN sessions via SNMP.

Note

This section applies to all Cisco NAM platforms except the NAM-NX1, NAM-1X, NAM-2X, and NAM-3 blades. SPAN session configuration via managed device is not allowed on vNAMs.

To set your managed device parameters:

Step 1 Choose Setup > Managed Device > Device Information.

Depending on your managed device, either the Router System Information displays as show in Table B-18 or the Switch System Information displays as shown in Table B-19.

Step 2 Click the Test Connectivity button to perform an SNMP test. Click Close when finished.
Step 3  Click Submit to submit the information and close the window.

Viewing Managed Device Information

To view the switch information, choose Setup > Managed Device > Device Information.
Depending on your platform, the System Information may display some or all of the fields shown in Table B-18 or Table B-19.

Setting Up NBAR Protocol Discovery on a Managed Device

This section describes how to use Network Based Application Recognition (NBAR) application classification to provide detailed status information on a specific interface.

Note

NBAR is supported on ISR routers and switches with the Catalyst 6500 Supervisor Engine 32 Programmable Intelligent Services Accelerator (PISA) running IOS 12.2(18)ZY (or later).

To set up NBAR Protocol Discovery, choose Setup > Managed Device > NBAR Protocol Discovery.
From the NBAR Protocol Discovery window, you can view the NBAR Status information and enable or disable NBAR on all interfaces.
For Prime NAM to provide information about Ethernet ports, you must enable the NBAR Interfaces feature.

Note

If your switch does not support NBAR, a message displays indicating that NBAR is not supported on your switch.

If NBAR Protocol Discovery is enabled, the NBAR Interfaces window lists known interfaces by name and type. See Table B-20 for a description of the fields in the window.

To narrow the list of interfaces, choose Interface Name or Interface Description from the drop-down list, enter any part of the interface name or description in the text box, and click the Filter button. To clear the Filter text box, click Clear. To return to showing all interfaces, check the All check box and click the Submit button.
Check the check box to enable an interface, and then click the Submit button.
The Save button will save the router’s running configuration to startup configuration.

Configuring Network Parameters

This section describes how to set up the network parameters including:

- Configuring Sites, page 3-50
- Setting Interface Speed using NetFlow Interface Capacity, page 3-53
- Configuring DSCP Groups, page 3-54
Configuring Sites

Cisco Prime Network Analysis Module makes it easier to monitor traffic and identify issues across your network by providing a way to manage large campuses using different views of your network, referred to as **sites**.

A **site** is a collection of hosts (network endpoints) partitioned into views. You can limit the view of your network analysis data to a specific city, a specific building, or even a specific floor of a building, and can use sites to focus collection and analysis of data. Sites are optional, but recommended.

See the following sections to set up sites:

- Defining a Site, page 3-50
- Viewing Defined Sites, page 3-50
- About Site Definitions and Rules, page 3-51

Defining a Site

A site can be defined as a set of subnets specified by an address prefix and mask, or using other criteria such as a remote device data source (for example, remote WAE device and segment information).

*About Site Definitions and Rules, page 3-51* gives specific information about various scenarios.

To set up a site or sites:

1. Choose **Setup > Network > Sites**.
2. Click the **Create** button.
3. The Site Configuration window appears. Enter a Name, Description, Subnet, and Data Source as appropriate.
   
   See Table B-21 for field descriptions.
4. Enter the subnet and data source, then click the **Detect** button to tell the software to look for subnets in the traffic. See *Detecting Site Subnets, page 3-50*.
5. Click the **Submit** button.

   **Note** The “Unassigned” site (with a description of “Unclassified hosts”) includes any that do not match any of your site configurations. Sites are classified at the time of packet processing.

Detecting Site Subnets

When you click the **Detect** button at **Setup > Network > Sites > Sites Configuration**, Prime NAM looks for subnets detected within in the past hour. See Table B-22 for information about the fields.

When you click the **Detect** button, Prime NAM will find those subnets that meet the criteria that you entered.

Viewing Defined Sites

To view already-defined sites:
Chapter 3  Setting Up Cisco Prime NAM

Configuring Network Parameters

Step 1  Choose **Setup > Network > Sites**.
Step 2  The Sites window appears. Defined sites will be listed in the table.
         The fields are described in Table B-23.

---

**Editing a Site**

You can edit sites that have been created. The Unassigned site cannot be edited or deleted.

Step 1  Choose **Setup > Network > Sites**.
Step 2  Highlight the site that you have configured.
Step 3  Click the **Edit** button.
Step 4  Edit the desired field.
         The fields are described in Table B-21.
Step 5  Click **Submit** to save the changes, or click **Reset** and **OK** to reinstate the site’s previous settings, or click **Cancel** to cancel any changes and return to the main Sites page.

---

**About Site Definitions and Rules**

The site definition is very flexible and can accommodate various scenarios. Prime NAM uses the site definition not only for viewing of data, but for data export and data retention as well. The same rule cannot be defined in multiple sites. The preferred way to define a site is to use its subnets. See Table 3-9 for examples of site definitions.

**Note**  VLAN option is removed from the Site definition.
For details on how Prime NAM resolves overlapping IP addresses, see Resolving Ambiguity (Overlapping Site Definitions), page 3-53

Table 3-9  Site Definition Details

<table>
<thead>
<tr>
<th>Site Definition</th>
<th>Example</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Subnet (IP address prefix)</td>
<td>Site Data-Center = subnet 172.20.0.0/16</td>
<td>Preferred. Normally, subnets alone are sufficient to define a site.</td>
</tr>
<tr>
<td>Overlapping IP addresses (subnet from data source)</td>
<td>Site NewYork = subnet 10.11.0.0/16 from &quot;NetFlow-NewYork&quot; data source. Site LosAngeles = subnet 10.11.0.0/16 from &quot;NetFlow-LosAngeles&quot; data source. Site Sale-Dept = subnet 10.11.0.0/16 from &quot;DATA PORT 1&quot; data source. Site Finance-Dept = subnet 10.11.0.0/16 from &quot;DATA PORT 1&quot; data source.</td>
<td>In certain scenarios when there are overlapping IP address spaces in the networks (for example, in private networks where hosts from different sites have the same IP addresses), then data sources can be used to differentiate the subnets.</td>
</tr>
<tr>
<td>WAE device serving the site</td>
<td>For WAAS traffic, you can define a site associated with a WAE device without specifying the site’s subnets. Simply select all of the WAAS data sources coming from the WAE device(s) serving that site. Site SanJose = WAE-SJ-Client, WAE-SJ-CI-WAN, and WAE-SJ-Passthrough data sources.</td>
<td>We recommend that you use subnets to specify WAAS-optimized sites. Use this method only if the site’s subnets cannot be determined. If you are configuring a WAAS device, you will need to add WAAS servers to Prime NAM. See Auto Create of New WAAS Devices, page 3-35.</td>
</tr>
<tr>
<td>Multiple Rules</td>
<td>You can define a site using a combination of multiple rules described in this table. For example, if a site has both optimized and non-optimized traffic, it can be defined using a combination of WAAS data sources and a subnet from a NetFlow data source.</td>
<td>When defining a site using multiple data sources, be careful to make sure that those data sources do not have duplicated traffic to avoid double counting the site traffic statistics.</td>
</tr>
<tr>
<td>Unassigned site</td>
<td>The Unassigned site includes any that do not match any of your site configurations. Sites are classified at the time of packet processing.</td>
<td>Cannot be edited or deleted.</td>
</tr>
</tbody>
</table>
Resolving Ambiguity (Overlapping Site Definitions)

Conflicting rules are not allowed in site definitions. Of the following two scenarios, the second one is not allowed.

1. 1.2.3.0/24 from DATASOURCE1 = SiteA
2. 1.2.3.0/24 from DATASOURCE1 = SiteB

Using a prefix is the preferred method. Data source is secondary. In the following two scenarios, the first would receive the higher priority.

1. 1.2.3.0/24 = Site D
   WAE1-Client datasrc = Site E

The longest prefix has higher priority (same data source). In the following two scenarios, the first would receive the higher priority.

1. 1.2.3.0/24 from DATASOURCE1 = Site A
2. 1.2.0.0/16 from DATASOURCE1 = Site C

The more refined (specific) rule has higher priority. In the following two scenarios, the first would receive the higher priority.

1. 1.2.3.0/24 from DATASOURCE1 = Site A
2. 1.2.3.0/24 (any datasrc) = Site D

Setting Interface Speed using NetFlow Interface Capacity

After you have set up NetFlow data sources (see Forwarding NetFlow Traffic, page 3-18), you can go to the NDE Interface Capacity window at Setup > Network > NDE Interface Capacity to specify the speed of each interface. This allows the software to calculate interface utilization on the NDE Interface Traffic Analysis window (Analyze > Traffic > NDE Interface). Otherwise, the Prime NAM software can only display the throughput of the interface, but cannot show its utilization.

The interface name and speed will be automatically discovered by the Prime NAM if you configure the device SNMP credentials in Setup > NAM Data Sources > Create > Type: NETFLOW.

To add a new or edit an existing interface, continue to Creating or Editing a NetFlow Interface, page 3-53.

Creating or Editing a NetFlow Interface

To add a new interface if it has not been automatically discovered, at the NetFlow Data Export (NetFlow) Interface Capacity window (Setup > Network > NDE Interface Capacity), click Add. Then fill in the fields as described in Table B-24.

Note
It is normally not necessary to manually create NetFlow interfaces. They should be discovered automatically when the device sends NetFlow packets to the NAM.

To edit an existing interface, choose the device, then click Edit. Fill in the fields as described in Table B-24.
Configuring DSCP Groups

Differentiated services monitoring (DiffServ) is designed to monitor the network traffic usage of Differentiated Services Code Point (DSCP) values. To monitor DSCP, you must configure at least one aggregation profile, and one aggregation groups associated with each profile. This section describes how to set up the DSCP groups.

You can define two or three different groups of traffic, and assign the various DSCP values to each group. Or you can assign one particular value for the first group and give it a name, and then assign all the rest to the other (or default) group and give that a name.

For detailed information about setting DSCP values, see Implementing Quality of Service Policies with DSCP:

The following tasks help you set up and manage the DSCP groups:

- Creating a DSCP Group, page 3-54
- Editing a DSCP Group, page 3-54
- Deleting a DSCP Group, page 3-55

Creating a DSCP Group

To create a DSCP Group:

**Step 1** Choose Setup > Network > DSCP Groups.
The DSCP Groups table displays.
**Step 2** Click the Create button.
The DSCP Group Configuration window displays.
**Step 3** Fill in the fields as described in Table B-25.
Table B-26 shows the available formats and associated values.
**Step 4** Click Submit to save your changes, or click Reset to cancel.

Editing a DSCP Group

To edit a DSCP group:

**Step 1** Choose Setup > Network > DSCP Groups.
The DSCP groups window displays.
**Step 2** Select the profile to edit, then click Edit.
**Step 3** Make the necessary changes, then click Submit to save your changes, or click Reset to cancel.
Deleting a DSCP Group

To delete a DSCP group, select the profile from the DSCP Groups table, then click Delete.

Configuring Application Awareness

This section covers how you can use Prime NAM application awareness to get deeper packet inspection data from your network.

Prime NAM uses the application ID classification system. When defining applications, you can view and select from a list of protocols and port numbers, and candidate IP addresses and port numbers for the traffic being analyzed. You can also create URL-based application classifications. For an in-depth overview of application types, see Understanding Application Traffic, page 3-56.

Note

Layer 7 application visibility is a unsupported, early field trial (EFT) feature. If you are interested in participating in the early field trial, contact Cisco at nam-info@cisco.com.

You can also configure custom applications using the Application Programming Interface (API), also referred to as the North Bound Interface (NBI). This is needed to ensure uniform application classification across a number of NAMs. See your customer service representative for details on how to get access to the NBI documentation.

To set up classifications use the following tasks:

- Creating Deeper Visibility Into Application Traffic, page 3-55
- Configuring Application Groups, page 3-59
- Filtering Encapsulations, page 3-60

Creating Deeper Visibility Into Application Traffic

You can use Prime NAM to monitor pre-determined or custom applications in your Data Center so that your traffic analysis is more focused and therefore optimal.

Without configuring application classification, applications running on a certain servers or specific ports are classified as unknown. This means that you may not have enough insight into the monitoring traffic. After configuring your application or ports, you can gain visibility into those application details on the monitoring screens. Similarly for the URL-based applications, instead of having all web traffic being grouped under the HTTP URL, you can specify a more granular layer of monitoring by using the application and port.

This section describes the following tasks:

- Understanding Application Traffic, page 3-56
- Creating Custom Applications, page 3-57
- Editing Custom Application Classifications, page 3-58
- Deleting an Application Rule, page 3-59
- Customizing Your Application List, page 3-59
Configuring Application Awareness

Chapter 3  Setting Up Cisco Prime NAM

Understanding Application Traffic

This section contains information on application types, rules, and other details you may find helpful.

There are three types of application classification rules:

1. **Protocol** rules define a port or protocol-based application (for example, based on a TCP port). You can create additional ports to enable Prime NAM to handle additional traffic for standard applications. Port ranges for IP are 1-255 for IP, TCP, UDP and SMTP port ranges are 1-65535. Ranges are reflected in the user interface for your convenience.

2. **HTTP-based URL** rules define URL-based application extensions to the existing list of supported applications. When the URL in an HTTP request matches the criteria of a URL-based application, the traffic is classified as that protocol. The HTTP request is a URL on any port that is part of the iana-l4:http protocol, or protocol named http under the iana-l4 engine ID.

3. **Server IP address** rules define a server IP address (as well as an optional port number). For server-based application classification, Prime NAM analyzes traffic for the candidate IP addresses and port number or numbers you specify.

To create Protocol or Server IP Address applications, you can check the Application Configuration table in Analyze > Traffic > Application. To create an HTTP URL-based application, you can analyze the incoming URLs on Analyze > Traffic > URL Hits. NBAR is enabled through CLI.

Prime NAM recognizes an application based on either:

- A set list of application IDs—The protocol, port number, or port number range, along with the focused inspection of traffic (for example, voice signaling traffic or FTP), heuristics (for example, DCE-RPC or SUN-RPC), or standardized application identifiers exported by Cisco platforms with NetFlow. If Prime NAM is not able to recognize an application using any of these mechanisms, the application type of the traffic is reported as **unknown**. You can configure the application reported as unknown to create custom applications.

- A custom application based on a URL-based HTTP request—You can include URL Host, URL Path, or a Prime NAM Content Type. This allows you to gain additional visibility instead of grouping all web traffic HTTP. For details, see Understanding URL-Based Application Classification, page 3-57.

- An application which resides on a specific server IP address—You can filter using an IP address, a protocol, and a port or range of port numbers. After configuring the server information, the monitoring dashboard displays more detailed application information instead of just the **unknown** grouping.

To add custom applications and view or edit any user-defined applications, choose Setup > Classification > Applications. Use this window to add custom applications and view and edit the user-defined applications.

**Caution**

There is no limit on the number of URL-based applications that can be created. It is important to consider that these types of applications use large amounts of CPU bandwidth and may impact your performance if too many are defined.

Table B-28 describes the fields on the Applications view page.
### Understanding URL-Based Application Classification

URL-based applications are extensions to the list of applications. When the URL in an HTTP request (a URL on any port that is part of the iana-l4:http protocol, or protocol named http under the iana-l4 engine ID) matches the criteria of a URL-based application, the traffic is classified as that protocol. The device interface statistics are collected by regularly (once a minute) polling the ifTable statistics of all interfaces on the managed device.

A URL-based application can be used the same way as any other application. For example, a URL-based application can be used in collections, captures, and reports.

An incoming URL is matched against the criteria of the configured URL-based applications in the order of the selector in ascending order. When a match is found, the remaining URL-based applications are not considered.

A URL consists of the following parts:

- a host (host.domain.com)
- a path (dir_nam/dir_name)
- an argument/content type

#### Tip

Content-type argument should rarely be used in combination with the other two fields. It can be used alone, for example to identify WAP traffic you could define an application with a content type of *wap.*. In almost all other cases, we recommend you use host and path only.

#### Example—Creating an URL-Based Application

This example provides steps on how to create a URL to allow you to control the displayed traffic data. For example, the URL `www.cisco.com/go/nam` are broken down when sent to the web server into two fields: a host field (`www.cisco.com`) and a path field (`/go/nam`). By defining different values for the fields in the application, you can control the granularity of URLs that are classified as this new application. If you want to group all traffic to `www.cisco.com` together and only define the host part, then use the host only part. If you have multiple hosts that map to the same end resource and only want to define the path part, then use only the path entry (`go/nam`).

To collect traffic for a particular host and path for the URL `http://cisco.com/go/nam` enter:

- the *host* part is `host.domain.com`, for example, `Cisco.com`
- the *path* part is `/go/nam`
- the *argument* part is `null/empty`

In the configuration of an URL-based application, the path part and the argument path are combined and called the *path part*. For detailed descriptions, see Table B-29.

#### Note

The host, path, and argument parts of a URL are matched against the corresponding POSIX regular expressions specified in the application definition. For details on regular expression syntax, refer to the IEEE Std.

### Creating Custom Applications

You can create a custom applications using the list of rules based on HTTP URL, Protocol, or Server IP addresses. If you create a custom application, you can later edit it if you choose. Standard, pre-defined applications cannot be edited.
For details on application types or other options, see Understanding Application Traffic, page 3-56.
To create a new application classification:

**Step 1** Choose Setup > Classification > Applications.
For a description of the Applications window, see Table B-27.

**Step 2** Enter a classification name.

**Step 3** (Optional) Enter an application description that gets displayed in the view table. There is a 75 character limit.

**Step 4** (Optional) You can skip the Selector value. This is an arbitrary number, unique within an engine-id. It will be automatically assigned if left blank.

**Step 5** Choose the application classification rule type and click Create.
   a. To choose a Protocol application rule, select Protocol in the Application Classification Rule drop-down menu, enter the required protocol and optional port information, if desired.
   b. To choose the URL-based application rule, select HTTP URL in the Application Classification Rule drop-down menu. (See Understanding URL-Based Application Classification, page 3-57 for additional field details.)
   c. To choose a server IP address, select Server IP Address in the Application Classification Rule drop-down menu, enter the required information.

**Step 6** Repeat Step 5 as many times as desired.

**Step 7** Click Submit to create the new application.
You can now monitor the new applications using the Interactive Report filter with the application dashboards.

---

**Editing Custom Application Classifications**

In Prime NAM you can only modify the custom, or user-defined, applications, and not the preconfigured system applications. You can only edit an application for which it states Custom in the Engine ID column.

To edit an application:

**Step 1** Choose Setup > Classification > Applications.

**Step 2** Select the application to edit, and click Edit.
The Application configuration window displays.

**Step 3** Make the desired changes.

**Step 4** Do one of the following:
   - To accept the changes, click Submit.
   - To leave the configuration unchanged, click Cancel.
   - To delete the application rule, click Delete.
Deleting an Application Rule

You may want to delete an application rule when you are no longer using it in your network.

To delete an application rule, simply select it from the Application list, then click **Delete**.

You cannot delete preconfigured system applications, only custom applications.

Customizing Your Application List

Applications are activated by default to enable specific classes of traffic to be analyzed by Prime NAM.

Only system applications can be activated and inactivated; custom, user-defined applications cannot be inactivated.

An activated application means that network traffic is being analyzed by NAM. Inactive applications are not being analyzed, possibly due to a duplication of effort. The Interactive Report filter may still list inactive applications, but NAM does not monitor or display data on NAM dashboards, unless there is historical data present in the database.

To inactivate a predefined application, choose the application from the Application Configuration list and then click **Activate/Inactivate**. When you are prompted to confirm the selection, choose **OK**.

An instance in which you may want to inactivate an application might be when the same application appears in the list two times but under two different names, and you would like to hide one of the instances.

Configuring Application Groups

An application group is a set of applications that can be monitored as a whole. The following topics help you set up and manage the application group:

- Creating an Application Group, page 3-59
- Editing or Deleting an Application Group, page 3-60
- Deleting an Application Group, page 3-60

Creating an Application Group

To create an application group:

**Step 1** Choose **Setup > Classification > Application Groups**.

The Application Groups window displays.

**Step 2** Click the **Create** button.

**Step 3** Enter the name in the Application Group Name field.

**Step 4** Use the next Application field and the Filter button to narrow the list of selectable applications.

**Step 5** Select an application and click the **Add** button. Applications appear in the Selected Applications box. You can select multiple applications at once by using the Shift button, and then click **Add**.

**Step 6** Click **Submit** to save your changes, or click **Reset** to cancel.
Configuring Application Awareness

Chapter 3  Setting Up Cisco Prime NAM

Editing or Deleting an Application Group

To edit or delete an application group:

**Step 1**  Choose **Setup > Classification > Application Groups**.

**Step 2**  Select the Application Group by clicking the radio button, then click **Edit** or **Delete**.

**Note**  You can only delete one application group at a time.

Deleting an Application Group

To delete an application group, simply select the application and then click the **Delete** button.

Filtering Encapsulations

Using encapsulation gives you increased flexibility when trying to view different types of application traffic (such as counting or grouping). The encapsulation settings affect how traffic of certain IP-based tunneling protocols are treated.

You can use this software to set up the way you want to view different types of encapsulations in network traffic for the following protocols:

- CAPWAP Data—Control And Provisioning of Wireless Access Points
- ERSPAN—Encapsulated Remote Switched Port Analyzer
- FabricPath
- GRE—IP over GRE tunneling (Generic Routing Encapsulation)
- GTP—GPRS (General Packet Radio Service) Tunneling Protocol
- IP.IP4—IP4 over IP4/IP6
- IP.IP6—IP6 over IP6
- IPESP—IP with Encapsulating Security Payload
- L2TP Data—Layer 2 Tunneling Protocol
- LISP Data—Locator/ID Separation Protocol
- LWAP Data—Lightweight Access Point Protocol
- MPLS—Multiprotocol Label Switching
- OTV—Overlay Transport Virtualization
- PPPoE—Point to Point Protocol over Ethernet
- Segment ID—Rule to match one or more fields with a regular expression.
- SGT—Security Group Tag
- VNTAG—Virtual Network Tag
- VxLAN—Virtual Extensible LAN
To filter encapsulations:

- **Step 1**: Select **Analyze > Traffic > Encapsulation**.
- **Step 2**: From the Interactive Report pane, click **Filter** to display the filter options.
- **Step 3**: Use the available options to select filtering for the encapsulation traffic reports. Unavailable options will be grayed out.
- **Step 4**: Enter whether you want to include filtering on the site and specify the data source.
- **Step 5**: Select encapsulation options to filter on including the time range.
- **Step 6**: If you add a filter name, the filter is saved below the Interactive Report pane for reuse.
- **Step 7**: Click **Submit** to run the filter and update the Encapsulation Traffic graphs and Top N dashboards based on your filter settings.

If you want to revert to the previous settings since your last submission, click **Reset**.

---

### Setting Up Prime NAM Monitoring

This section discusses how to set up monitoring over and above the default monitoring parameters. You can customize these monitoring parameters.

To set up Prime NAM monitoring perform these tasks:
- Setting Aggregation Intervals, page 3-61
- Configuring Response Time, page 3-62
- Setting Up Voice Monitoring, page 3-63
- Creating RTP Filters, page 3-63
- Configuring URL Collections, page 3-64
- Configuring WAAS Monitored Servers, page 3-66

### Setting Aggregation Intervals

Prime NAM has short-term and long-term aggregation intervals (this was referred to as long-term reporting in earlier NAM releases). Aggregated data is displayed in the dashboards if the query is longer than one day.

The purpose of gathering short term aggregation interval data is for troubleshooting. It has a finer granularity than long term data (by default, the short term aggregation interval for Traffic/Media is one minute, and short term response time interval is five minutes).

The purpose of gathering long term interval data is for trending analysis. The smallest aggregation interval for long term data is one hour (60 minutes).

⚠️ **Caution**

If you modify the aggregation intervals, existing collected data that is not in the same aggregation interval will be completely removed. Data will then start being collected from the beginning again at the moment the intervals are modified and applied.
Traffic and Media refer to applications, hosts, RTP streams, and voice calls monitoring. Response Time refers only to application response time. Prime NAM does not support long term aggregations of data for the following media: conversations, RTP streams, and voice signaling calls monitoring.

To set up aggregation intervals:

**Step 1** Choose Setup > Monitoring > Aggregation Intervals.

**Step 2** Choose the desired durations for Short Term Interval and Long Term Interval.

**Step 3** Check the Collect only hosts from user-defined sites (exclude hosts from Unassigned site) check box if you want the Prime NAM long term data to contain information only for hosts classified to the user-defined sites. This check box only applies to the long term data; short term always collects all hosts.

**Note** Enabling the “Collect only hosts from user-defined sites” option can significantly speed up report queries, because it excludes unclassified hosts’ statistics from the database.

When you first start the NAM, in monitoring windows that show site information, you will see a site named “Unassigned” and with a description of “Unclassified Hosts.” The Unassigned site includes any that do not match the site configurations. By default, long-term storage will include data for all sites, including the Unassigned site. In some cases, you may not want to view long term data of hosts that are not in your network, in which case you would check the check box.

**Step 4** Click Submit.

The aggregation intervals determine how much data can be stored in the Prime NAM database. See Table 3-10 for information about short and long-term data retention. This calculation is based on a worst case scenario where tables are full or almost full. It is based on recommended database sizes.

<table>
<thead>
<tr>
<th></th>
<th>Short-Term Aggregated Data (Normal)</th>
<th>Short-Term Aggregated Data (Minimum)</th>
<th>Long-Term Aggregated Data (Normal)</th>
<th>Long-Term Aggregated Data (Minimum)</th>
</tr>
</thead>
<tbody>
<tr>
<td>NAM-1X</td>
<td>24 hours</td>
<td>5 hours</td>
<td>30 days</td>
<td>10 days</td>
</tr>
<tr>
<td>NAM-2X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>All other platforms</td>
<td>72 hours</td>
<td>14 hours</td>
<td>100 days (with default polling interval)</td>
<td>30 days (with default polling interval)</td>
</tr>
</tbody>
</table>

1. Can depend on how the user configures the LT polling interval. The more frequent polling, the shorter the duration.

### Configuring Response Time

To configure the timing parameters for response time data collections:

**Step 1** Choose Setup > Monitoring > Response Time.

The Response Time Configuration page displays. The settings you make on this window comprise the time distribution in microseconds for the detailed Server Application Response Time data collection.

**Step 2** Check the Enable Response Time Monitor check box.
Step 3  After “Monitored Server Filter”, you will see “Disabled” or “Enabled.” If a WAAS server has been configured under Setup > Monitoring > WAAS Servers, you will see “Enabled.” Click the Configure Filter button to configure a filter.

Step 4  Enter the Response Time settings as described in Table B-30.

Step 5  Accept the default settings or change the settings to the values you want to monitor. Click Submit to save your changes, or click Reset to cancel.

---

## Setting Up Voice Monitoring

You can use the Mean Opinion Score (MOS) to quantify the perceived level of quality you are receiving in your network voice traffic. This allows you to assess the work of codecs, or algorithms, which compress audio traffic to save on bandwidth utilization but may result in a drop in quality.

After you set up the software to monitor voice data, you will be able to view the collected voice data under Analyze > Media. For more information on viewing the voice data, see Analyzing Media, page 4-28.

**Note**  Voice monitoring features are supported with Cisco IP telephony devices only.

To set up voice monitoring:

---

**Step 1**  Choose Setup > Monitoring > Voice.

The Voice Monitoring page displays.

**Step 2**  Check the Enable Call Signal Monitoring check box.

**Step 3**  Accept the default MOS Score value range or modify the values as you prefer. See Table B-31.

**Note**  To report jitter and packet loss for the SCCP protocol, you must enable CDR on Cisco Unified Communications Manager. For more information on Cisco Unified Communications Manager, see the Cisco Unified Communications Manager documentation. [http://www.cisco.com/en/US/products/sw/voicesw/ps556/tsd_products_support_series_home.html](http://www.cisco.com/en/US/products/sw/voicesw/ps556/tsd_products_support_series_home.html)

**Step 4**  Click Submit to save your changes, or click Reset to cancel and revert to the previous settings.

---

## Creating RTP Filters

When the software is initially started, RTP stream traffic will automatically start being monitored. Prime NAM enables you to monitor all RTP stream traffic among all SPAN traffic, without having to know the signaling traffic used in negotiating the RTP channels. RTP Stream Monitoring is enabled by default under Setup > Monitoring > RTP Filter. To disable it, uncheck the Enable RTP Stream Monitoring check box and click the Submit button to apply the change.
To create an RTP filter:

- **Step 1** Choose **Setup > Monitoring > RTP Filter**.
- **Step 2** Click the **Create** button.
- **Step 3** From the drop-down menu, choose the protocol (IP or IPv6).
- **Step 4** Enter the Source Address, Source Mask, Destination Address, and Destination Mask.
- **Step 5** Click **OK**.

### Configuring URL Collections

The URL collection listens to traffic on TCP port 80 of a selected data source and collects URLs. Any protocol which has its master port set to TCP port 80 can be used for URL collections. Only one collection on a single data source can be enabled at a time.

A URL, for example: `http://host.domain.com/intro?id=123`, consists of a host part (`host.domain.com`), a path part (`intro`), and an arguments part (`?id=123`).

**Note**

Since the argument is matched against a regular expression, a literal `?id=123` is not a valid regular expression. The `?` needs to be escaped with a backslash character, \, so the actual regular expression needed is `\?id=123`.

The collection can be configured to collect all parts or it can configured to collect only some of the parts and ignore others.

This section contains the following procedures:

- **Enabling a URL Collection**
- **Changing a URL Collection**
- **Disabling a URL Collection**

### Enabling a URL Collection

To enable a URL collection:

- **Step 1** Choose **Setup > Monitoring > URL**.
- **Step 2** Check the **Enable** check box to initiate URL Collection.

**Note**

The collection will not begin until you click **Submit**.

- **Step 3** Provide the information described in Table B-32.

You can enter a partial name of a data source and click **Filter** to find data sources that match. Choose **Clear** to return to the entire list of data sources.
Note Depending on which radio button option is collected, the format of the URL varies. For example, the leading http: part is only present if the host part is collected. Keep this variable in mind, when configuring a match only expression.

Step 4 Check the Recycle Entries check box to recycle entries.

Step 5 Select the check box for one of the following:

- Collect complete URL (Host, Path and Arguments)—You might use this if you are a network security engineer and suspect a virus infection may be caused by a website. This information could be used to identify which web page has the virus embedded and how it may have spread. It can also be shared for further analysis to help create a solution to stop the spread.
- Collect Host only (ignore Path and Arguments)—You might use this if your network administrator changed your firewall policies to block certain hosts.
- Collect Host and Path (ignore Arguments)
- Collect Path and Arguments (ignore Host)
- Collect Path only (ignore Host and Arguments)

Step 6 Click Submit to save your changes, or click Reset to cancel.

Changing a URL Collection

To change a URL collection:

Step 1 Choose Setup > Monitoring > URL.

Step 2 Change the URL Collection Configuration field information as described in Table B-32.

Note Changing any parameters and applying the changes flushes the collected URLs and restarts the collection process.

Step 3 Click Submit to save your changes, or click Reset to cancel.

Disabling a URL Collection

When you disable URL collection monitoring, all collection stops immediately and any collection that was in progress is deleted.

To disable a URL collection:

Step 1 Choose Setup > Monitoring > URL.

Step 2 Uncheck the Enable check box.

Step 3 Click Submit.
Configuring WAAS Monitored Servers

WAAS monitored servers specify the servers from which WAAS devices export traffic flow data to the Prime NAM monitors. To enable WAAS monitoring, you must list the servers to be monitored by Prime NAM using the WAAS device's flow monitoring.

You must configure WAAS monitored servers to enable Prime NAM to monitor WAAS traffic. Prime NAM displays status of WAAS devices as pending until you set up WAAS monitored servers.

To configure a WAAS monitored server:

Step 1 Choose Setup > Monitoring > WAAS Servers. The WAAS Servers page displays.

Step 1 Check the Filter Response Time for all Data Sources by Monitored Servers check box if you want Prime NAM to compute response time data only for the servers from this list for all data sources, including non-WAAS data sources. All other servers will be ignored in response time monitoring views. This enables you to reduce Prime NAM workload and to improve its overall performance.

Step 2 Click Add and enter the server IP address in the Server Address field. You can paste multiple IP addresses here as well.

Tip Specify the WAAS monitored servers from which WAAS devices export traffic flow data to the Prime NAM monitors. Do not use the WAE device IP address.

Step 3 Click Submit.
Monitoring and Analyzing Traffic

Cisco Prime Network Analysis Module provides several dashboards and tools to help you to monitor and analyze your network traffic data. You can view traffic in a summary view (available from the Monitor menu) which can then be further analyzed using the more in-depth analysis view (available from the Analyze menu).

The Monitor dashboards allow you to view network traffic, application performance, site performance, and alarms at a glance. From there, you can isolate one area, for example an application with response time issues, and then drill-down to the Analyze dashboard for further investigation.

This chapter provides information about monitoring your network traffic and analyzing the information presented.

This chapter contains the following topics:

- Using Traffic Summary, page 4-1
- Using Response Time Summary, page 4-3
- Using Site Summary, page 4-3
- Using Alarm Summary, page 4-4
- Analyzing Traffic, page 4-6
- Optimizing WAN, page 4-13
- Measuring Response Time, page 4-16
- Analyzing Device Interface, Health, and Application Data, page 4-21
- Analyzing Media, page 4-28
- Using the NAM Application Programming Interface, page 4-34

Using Traffic Summary

The Traffic Summary Dashboard allows you to view the Top N Applications, Top N Application Groups, Top N Hosts (In and Out), IP Distribution, Top N DSCP, and Top N Encapsulations being monitored on your network. It provides automatic monitoring of traffic from all potential data sources (for example, SPAN, NetFlow, and WAAS). You can get to the Traffic Summary Dashboard by going to Monitor > Overview > Traffic Summary.
You can use the Interactive Report on the left to filter the information for a particular Site, Data Source, VLAN, or reporting time distribution. You can specify just one type of criteria and leave the others blank, or specify all of them. You can also choose to view the rate or cumulative data from the Interactive Report. To set a system preference for bytes instead of bits, go to Administration > System > Preferences.

When you log into Prime NAM for the first time, the default view will be the Traffic Summary dashboard, and the top data source is selected by default.

For each chart described below, you can left-click on any colored bar to get to a context menu, with which you can get more detailed information about that item.

The charts shown on this dashboard are:

- **Top N Applications**
  The Top N Applications Chart enables you to view the traffic rate (bits per second or bytes per second) or traffic volume (bits or bytes), depending on the Interactive Report filter selection (data rate or cumulative, respectively). When you place your cursor over the colored bar, you will see the number of bits per second collected or the total bits over the last time interval. This chart reports application-level (L7 payload) bits.
  If you left-click on a colored bar and choose “Capture” from the context menu, you can start a capture on this data (see Capturing and Decoding Packets for more information about Capture).

- **Top N Application Groups**
  This chart shows a detailed analysis of the Top N application groups and the traffic rate or volume for this interval. In the Interactive Report, you can select either rate or cumulative, where rate is the bits per second, and cumulative is the total number of bits.

- **Top N Hosts (In and Out)**
  This chart displays the traffic rate (bits per second or bytes per second) or traffic volume (bytes or bits). To get more specific details about the host activity, left-click on the colored bar and make a selection. You can also choose “Capture” from the context menu to start a capture on this data (see Capturing and Decoding Packets for more information about Capture).

- **IP Distribution**
  This chart shows the percentages of bits being distributed to IP protocols (for example, IPv4 TCP).

  **Tip**  
  To change from bits to bytes, choose Administration > System > Preferences and change the “Data displayed in” selection.

- **Top N DSCP**
  This chart shows statistics for the top DSCP Aggregation Groups.

- **Top N Encapsulations**
  This chart shows encapsulation traffic over time. You can select a VLAN and filter specific encapsulation protocols from within this chart (including OTV, VxLAN, LISP, and others) to analyze. You can also narrow your data by filtering on certain time ranges. The default time range is 15 minutes.

To see a chart in table format, use the Show Chart/Show Table toggle buttons on the bottom left corner of the chart.

When viewing the data as a Grid, the numbers are formatted according to what you have configured in Administration > System > Preferences. On that page, you can also configure the number of Top N entries you would like to display.
Using Response Time Summary

The NAM software provides response time measurements and various user-experience-related metrics, which are computed by monitoring and time-stamping packets sent from the user to the server providing services. These Application Response Time Metrics are available to view under the Response Time Summary Dashboard (Monitor > Overview > Response Time Summary). In NAM 4.x, this was referred to as Intelligent Application Performance (IAP) analytics.

After the NAM is started, these metrics will begin to populate automatically. When you first navigate to Response Time Summary dashboard, the top data source is selected by default. This dashboard shows you performance statistics for Site, Data Source, VLAN, and a specific amount of time.

Use the Interactive Report window on the left side of the window to change the parameters for the information displayed. To see a chart in table format, use the Show Chart / Show Table toggle button on the bottom right corner of the chart.

The dashboard charts will show you the following information:

- **Top N Applications by Server Response Time**
  This chart displays the server response times for the applications in the site, data source, VLAN, or site clients or servers you selected in the Interactive Report window. For example, a selection “http” would show you the average response time of http servers seen in the traffic category you have selected in the Interactive Report window. The data is shown in microseconds (μ).

- **Top N Site-to-Site Network Time**
  This chart displays the top network time between the client site and the server site in the category you selected. The data is shown in microseconds.

- **Top N Servers By Server Response Time**
  This chart allows you to see how well servers are performing, by showing you the server that has the longest response time (the item appearing at the top). The data is shown in microseconds.

- **Top N Servers By Bits (or Bytes)**
  This chart displays the total bits or rate of traffic for the top servers. You can choose to display NAM data in either Bits or Bytes in Administration > System > Preferences.

- **Top N Clients By Transaction Time**
  This chart displays the transaction time per client. The client with the highest response time appears on top. The data is shown in microseconds.

- **Top N Clients By Bits (or Bytes)**
  This chart displays the total bits or rate of traffic for the top clients.

Using Site Summary

The Site Summary Dashboard (accessed by choosing Monitor > Overview > Site Summary) will show you information about the sites in your network. You can use the Interactive Report on the left side of the window to change the information displayed. For more information about sites, see Configuring Sites.

The charts displayed on the Alarm Summary dashboard are:

- **Top N Sites by Average Transaction Time**
  This chart shows the average transaction time by site.


- **Top N Site Pairs by Traffic**
  This chart shows top site to site traffic.

- **Top N Sites by Average MOS**
  This chart shows sites that have the highest average Mean Opinion Score (MOS).
  MOS will normally range from 1-5, denoting the perceived quality of the transmission, where 1 is the lowest perceived quality, and 5 is the highest perceived quality measurement. The MOS is weighted depending on the duration.

- **Top N Sites by Traffic**
  This chart shows the sites that have the most traffic (which are the most active). It is a total of all the traffic sent or received for hosts that belong to the particular site, which means that this traffic includes intra-site traffic as well.

To see any of the charts in table format, use the Show Chart / Show Table toggle button on the bottom right corner of the chart.

### Using Alarm Summary

The Alarm Summary Dashboard (accessed by choosing Monitor > Overview > Alarm Summary) will show you the top alarms occurring in the network.

To display network traffic information for a particular amount of time, use the Interactive Report on the left side of the window. The Severity Selector in the Interactive Report allows you to choose to view high severity alarms only, low severity alarms only, or both high and low severity alarms (these settings are configured under Setup > Alarms > Thresholds). You can also choose the desired amount of time from the Time Range drop-down menu, or you can customize the time range.

On any chart on the Alarm Summary Dashboard, you can click on a colored bar to see the Context menu, with which you can get more information.

If you do not set any alarms or thresholds, the Alarm Summary Dashboard will have no data. For information on setting up alarms and thresholds, see Setting Up Alarms and Alarm Thresholds, page 3-36.

---

**Note**

You could see a count of two alarms for the same occurrence if:
- both the source and the destination are in the same site in the Top N Site - Host Pair chart.
- both the source and the destination are in the same site in the Top N Site chart.
- both the source and the destination are in the same site using the same application in the Top N Site - Application Pair chart.

---

**Note**

You will not have any data in Top N Site - Application and Top N Application if there is no threshold configured that involves an application (for example: Response Time threshold or Application threshold).

NetFlow Interface alarms are not related to any site; therefore, they will not appear on the four colored site alarm charts on the Alarm Summary dashboard. Instead, the New Alarms Raised and Last 50 Alarms tables at the bottom of this window will contain NetFlow Interface alarms raised.
The five charts displayed on the Alarm Summary dashboard are:

- **Top N Sites by Alarm Count**
  This chart will list the Top N sites (maximum of 10) that have the most alarm triggers during the selected time range. If no thresholds are configured, this chart will have no data. The number on the bottom of the chart is the alarm count.

  You can configure thresholds under **Setup > Alarms > Thresholds**. You can configure the Top N entries under **Administration > System > Preferences**.

- **Top N Hosts by Site and Alarm Count**
  This chart shows the number of alarm messages during the selected time range that are triggered for Hosts across all sites, by the Site - Host Pair.

- **Top N Applications by Alarm Count**
  This chart shows the number of alarms during the selected time range for Applications across all sites.

- **Top N Applications by Site and Alarm Count**
  This chart shows the most alarm triggers during the selected time range by the application and site pair.

- **New Alarms Raised**
  The New Alarms Raised table shows you all alarms that occurred during the interval selected in the Interactive Report window. Some alarms may have been triggered outside of the time period, but may still be occurring.

  You can use the Filter drop-down menu to filter the alarms.

- **Last 50 Alarms**
  The Last 50 Alarms table shows you the alarms that occurred during the interval selected in the Interactive Report window. Some alarms may have been triggered outside of the time period, but may still be occurring. See **Table B-42**.

  You can click the **All Alarms** button at the bottom to bring up a separate window, which will show you all 50 alarms without the need for scrolling.

  You can also use the Filter button, both in this window and the All Alarms window, to display only alarms that meet the criteria you enter.

---

**Utilizing Sites to Create a Geographically- or Organizationally-Familiar Deployment**

In Prime NAM you can define a site, which enables you to aggregate and organize performance statistics. If you want to limit the view of your network analysis data to a specific city, a specific building, or even a specific floor of a building, you can use the sites function.

**Figure 4-1** shows a centralized NAM deployment analyzing multiple data sources from different locations in the network.
For this deployment, multiple sites can be created such as SanJose-Campus, SanJose-Datacenter, NewYork-NetFlow-Bldg1, and NewYork-WAAS-Bldg2. The data that does not match the site configuration will be displayed in the Default site. This helps to isolate the view and information for monitoring and troubleshooting so you can drill down to the specific area of interest.

You can also include multiple types of data sources in the site definition, and you can then get an aggregated view of all network traffic.

The predefined *Unassigned Site* makes it easy to bring up a NAM without having to configure user-defined sites. Hosts that do not belong to any user-defined site will automatically belong to the Unassigned Site.

You can create, view, or edit your sites by selecting **Setup > Network > Sites**. Unassigned sites cannot be changed.

The interactive dashboard can be used to drill down into either San Jose or New York sites to see Top applications, hosts, Encapsulations, DSCP, and application response time.

From each of the charts in the dashboard, you can access the context menu to further drill down to analyze data such as detailed application, host, and conversation traffic.

**Analyzing Traffic**

Prime NAM offers many ways to analyze your network traffic data using graphs, charts, and detailed views.

Use the links below to locate information about:

- Analyzing Site Traffic, page 4-7
- Application, page 4-7
- Host, page 4-7
- NetFlow Interface Traffic Analysis, page 4-8
- DSCP, page 4-9
- Encapsulation, page 4-9
- URL Hits, page 4-9
Analyzing Site Traffic

To show you the traffic level for a given site over a selected period of time, use Analyze > Traffic > Site. You can also see the following:

- A graph of site traffic over time
- Site conversations link to display detailed data
- Top applications transmitting and receiving traffic for the selected time period
- Application Distribution -- Shows the criteria by which the NAM classifies the amount of application traffic on this site over this period of time.

Application

The Application Analysis window shows you the traffic level for a given application over a selected period of time. It is available under the menu option Analyze > Traffic > Application. It shows you:

- A graph of site traffic over time
- Top hosts transmitting and receiving traffic on that application for the selected time period
- Application Configuration -- Shows the criteria by which the NAM classifies packets as that application. This is typically a list of TCP and/or UDP ports that identify the application. Note that some applications are identified by heuristic or other state-based algorithms.

Hosts Detail

On the Top N Hosts - Traffic In or Top N Hosts - Traffic Out chart, you can left-click a colored bar to get the context menu, and choose Hosts Detail to see the All Hosts window and the detailed information about all hosts. Table B-40 describes the fields in this window.

Host

The Host Traffic Analysis window will show you at a quick glance the input and output of a particular host over time. It is available under the menu option Analyze > Traffic > Host. It will show you:

- Input and output traffic for the host over time
- Top N application activity of the host over the selected interval
- Total application usage distribution for the host

Applications Detail

On the Top N Applications chart, you can left-click a colored bar to get the context menu, and choose Applications Detail to see the All Applications window and the detailed information about all applications. Table B-33 describes the fields in this window.
NetFlow Interface Traffic Analysis

To view data collected for individual interfaces on a switch or router that is exporting NetFlow packets to the NAM, use the NetFlow Interface Analysis page. The displayed information represents the total data collected since the collection was created, or since the NAM was restarted.

**Before Your Begin**

1. Ensure Auto-create is enabled for the NetFlow Data Export (NDE) data source. Once NDE data is sent to the NAM, an NDE data source is created.

2. Edit the NDE data source to enter SNMP credential information that allows the NAM to properly query the router/switch interface information. Go to Setup > Traffic > NAM Data Sources. For more information, see Creating NetFlow Data Sources Using the Web GUI, page 3-21 or Creating NetFlow Data Sources Using the CLI, page 3-22.

3. Go to NetFlow Interface Capacity page (Setup > Network > NDE Interface Capacity) to ensure all information is populated.

To view NetFlow Interface Analysis:

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Choose <strong>Analyze &gt; Traffic NDE Interface</strong>. The default view is Interface View.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Select an interface from the Interface Selector to see traffic in the charts. Click the arrow icon to the left of the NetFlow data source name to display all interfaces, and then select an interface to see data for that interface.</td>
</tr>
</tbody>
</table>

When you go to the Group View tab, you see all interfaces and NetFlow data sources grouped into two static groups. You can select combinations of interfaces from each group and click **Submit**, and the charts on the right will sum up the metrics and display them for each group.

**Note** If the charts show no data, and you see a message “Interface needs to be selected,” you have not yet chosen an interface.

Once you have chosen the interface, you will see the following charts populated:

- Interface Traffic (Ingress % Utilization and Egress % Utilization)
- Top N Applications - Ingress
- Top N Applications - Egress
- Top N Hosts - Ingress
- Top N Hosts - Egress
- Top N DSCP Aggr - Ingress
- Top N DSCP Aggr - Egress

The interface speed can be entered manually through the Interface capacity table, or it can be auto configured if the SNMP settings for the NetFlow device are entered in data source table.
DSCP Detail

On the Top N DSCP Aggr - Ingress and Top N DSCP Aggr - Egress chart, you can left-click a colored bar to get the context menu, and choose DSCP Detail to see the All DSCP window. You can also get to this window by choosing Analyze > Traffic > DSCP Traffic from the menu and clicking the All DSCP button on the right.

Table B-39 describes the fields in the All Applications window.

DSCP

Differentiated services monitoring (DiffServ) is designed to monitor the network traffic usage of differentiated services code point (DSCP) values.

To monitor DSCP groups, you must configure at least one aggregation profile and one or more aggregation groups associated with each profile. For more information on configuring an aggregation profile, see Configuring DSCP Groups, page 3-54.

You can monitor the DSCP information by going to Analyze > Traffic > DSCP Traffic Analysis. The data provided to you includes:

- Traffic volume over time for the selected DSCP group
- Top N applications and application groups using that DSCP group
- Top N hosts transmitting and receiving traffic on that DSCP group

Encapsulation

You can analyze the encapsulation traffic collected by Prime NAM (for setup, see Filtering Encapsulations, page 3-60). This section contains the following use cases:

- Viewing Collected Encapsulation Data—see Viewing Collected URLs, page 4-10
- Filtering Various Encapsulations—see Filtering a URL Collection List, page 4-10

URL Hits

You can analyze the URLs collected by the NAM (for setup, see Configuring URL Collections, page 3-64).

This can help you determine what URLs are used in the network and then see what applications are affiliated with those URLs.

This section contains the following procedures:

- Viewing Collected URLs
- Filtering a URL Collection List
Viewing Collected URLs

To view collected URLs and optionally create URL-based custom applications:

Step 1  Choose **Analyze > Traffic > URL Hits**.

The URL Hits Window displays with the collected URLs. The columns are described in Table 4-1.

### Table 4-1  **URLs Table**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Index</td>
<td>URL index</td>
</tr>
<tr>
<td>URL</td>
<td>URL text</td>
</tr>
<tr>
<td>Hits</td>
<td>Number of hits</td>
</tr>
</tbody>
</table>

**Note**  Only one URL collection can be active at one time. The data source is for information only.

Step 2  To create a URL-based custom application, click **Create URL-Based Application**.

For details on the URL-Based Applications window, see Table B-29.

Filtering a URL Collection List

To filter a URL collection list:

Step 1  From the drop-down list in the URLs Window (**Analyze > Traffic > URL Hits**), choose which part of the URL to filter:

- **URL**—You can filter on any part of the URL
- **Host**—This filter applies only to the host part of collected URLs.
- **Path**—This filter applies only to the path part of the collected URLs
- **Arguments**—This filter applies only to the argument part of the collected URLs

Step 2  Enter filter string.

Step 3  Click **Filter** to apply the filter.

**Note**  To remove any display filter and show all URLs collected, click **Clear**.

Detailed Traffic Analysis Views

Prime NAM offers several detailed traffic analysis views which allow you to analyze the following data:

- **Sites Detailed Views**, page 4-11
Sites Detailed Views

Displays data for each site (including all unassigned sites) and see packet per second and bits per second details. Use the Interactive report filter to pinpoint specific attributes. There are no filter time limits for this data.

Site Conversations Detailed Views

Displays site traffic for all or selected sites. To pinpoint site traffic data between two devices, select the Interactive Report Filter.

Applications Detailed Views

To view the All Applications window and the detailed information about all application and filter on specific applications or other filter attributes, use the Interactive Report filter.

Application Groups Detailed Views

To see the All Application Groups window and the detailed information about all application groups, left-click a colored bar on the Top N Application Groups chart to get the context menu, and choose Applications Groups Detail. Table B-34 describes the fields in the All Applications window.

Application Traffic By Hosts Detailed Views

Shows the traffic for a given application broken out by individual hosts using the application. You may specify the time period to view, as well as the application, site (optional), data source (optional), and VLAN (optional).

The NAM only supports a maximum Time Range of one hour filter for the Host Conversations, Network Conversation, RTP Streams, Voice Calls Statistics, Calls Table, and RTP Conversations.

Top Application Traffic Detailed Views

Shows the top applications by traffic rate over a selected time and for the specified site and/or data source.

Top Application Traffic Detailed Views shows you all of the applications that have been running for the time period interval. The color-coded legend shows you what the applications are running.
The Display Other check box (which is underneath the Top Application Traffic heading) corresponds to the data for the applications not in the N list. If you check this check box, the chart will display the Other data in addition to the data for the N number of applications.

If you place your cursor over any of the data points, you will get more details about the exact values for each of the applications that are running.

**Hosts Detailed Views**

Shows the input and output of a particular host over time. Use the Filter button in the Interactive Report (left side of the window) to change the parameters of the information displayed.

**Host Conversations Detailed Views**

Shows detailed lists of all the conversations for a particular host.

You can view the following data:

- A table of hosts which are sending and receiving packets to the selected host, along with application, encapsulation, and traffic rate information.
- A breakout of application usage for the selected host.

Use the Filter button in the Interactive Report (left side of the window) to change the parameters of the information displayed.

The NAM only supports a maximum time range of one hour filter for the Host Conversations, Network Conversation, RTP Streams, Voice Calls Statistics, Calls Table, and RTP Conversations.

**Network Conversation Detailed Views**

Shows a detailed analysis of all network conversations (including packets and bytes information).

Use the Filter button in the Interactive Report to change the information displayed and target data.

The NAM only supports a maximum Time Range of one hour filter for the Host Conversations, Network Conversation, RTP Streams, Voice Calls Statistics, Calls Table, and RTP Conversations.

**DCSPs Detailed Views**

Shows a detailed analysis of all the network traffic usage of differentiated services code point (DSCP) values, choose Analyze > Traffic > Detailed Views > DSCPs.

Use the Filter button in the Interactive Report to change the information displayed and target data.

**About Analyze Traffic Charts**

The charts available under the Analyze menu show statistics that occur over time. You can use the Zoom/Pan feature, with which you can drag the beginning or end to change the time interval or distribution, as shown below.
The time interval change on the zoom/pan chart will affect the data presented in the charts in the bottom of the window. The zoom/pan time interval also affects the drill-down navigations; if the zoom/pan interval is modified, the context menu drill-downs from that dashboard will use the zoom/pan time interval.

**Note**

In a bar chart which you can zoom/pan, each block represents data collected during the previous interval (the time stamp displayed at the bottom of each block is the end of the time range). Therefore, you may have to drag the zoom/pan one block further than expected to get the desired data to populate in the charts in the bottom of the window.

### Optimizing WAN

Prime NAM can provide insight into WAN Optimization offerings that compress and optimize WAN traffic for pre- and post-deployment scenarios. This is applicable for optimized and passthru traffic.

WAN Optimization tasks include:

- **Ensuring WAN Optimization**, page 4-13
- **Analyzing Traffic for Optimization Using the Top Talkers Detail**, page 4-14
- **Analyzing Application Performance after WAAS Optimization**, page 4-15
- **Monitoring WAAS Traffic Across Multi-Segments**, page 4-16
- **Monitoring WAAS Single-Segment Traffic**, page 4-16

**Note**

To monitor the WAAS data, you must select the correct WAAS data source.

### Ensuring WAN Optimization

In order to ensure that your applications are performing optimally, use these summary steps to determine your best course of action:

- Identify sites with application performance challenges
- Quantify the application performance
- Validate the impact of WAN optimization
- Perform ongoing monitoring of WAN optimization
- Troubleshoot WAN optimized traffic

To ensure your WAN is optimized:

**Step 1**

To identify sites with application performance challenges, choose **Monitor > Site Summary**.
If you do not have sites identified, you can use the Unknown site category or to learn about how to create sites, see Configuring Sites, page 3-50.

**Step 2** Look for sites with the highest average transaction time and highest traffic rate.

**Step 3** To quantify the application performance:

a. Choose **Monitor > Response Time Summary**.

b. Set up a filter that targets key areas such as a specific location and different time ranges (one day and one week). This allows you to focus in on exactly the data you want to analyze.

c. Right-click the application with the highest server response time and choose Analyze Application Response Time.

d. Specify a filter time range using the Interactive Filter. We recommend viewing data over a one day range to allow for possible peak times.

e. Identify applications with poor performance and quantify the response time by network time, server response time, and data transfer time.

**Step 4** To validate the impact of WAN optimization:

a. Choose **Analyze > WAN optimization > Application Performance Analysis**.

b. Minimize WAN Opt Impact analysis filter (on the left pane).

c. View the effect of optimizing one of your applications (for example, to determine if your HTTP browser has lower transaction times and thus better end-client experience, lower compression ratios for better utilization of the WAN, and fewer average concurrent connections for better utilization of server through connection reuse).

**Step 5** To perform ongoing monitoring of WAN optimization and troubleshoot WAN optimized traffic:

a. Choose **Analyze > Conversation Multi Segment**.

b. View a detailed breakdown of latency and bandwidth measures for the server, WAN, and client network segments.

---

### Analyzing Traffic for Optimization Using the Top Talkers Detail

While you are in the process of deploying WAAS devices, you can get data to assist in the WAAS planning and configuration.

This window allows you to display response time and concurrent connections for the top Application, Network Links, Clients, and Servers from WAN data sources before WAAS optimization.

To analyze traffic for optimization using the Top Talkers Detail:

**Step 1** Choose **Analyze > WAN Optimization > Top Talkers Detail** and filter data using the Interactive Report window to select the traffic you want to analyze for optimization.

If the data source is from SPAN, PA, or WAAS, it does not include the packet header; if the data source is NetFlow, it will include the packet header.

**Note** You can choose to display NAM data in either Bits or Bytes in Administration > System > Preferences.
Based on the results, you can then configure the WAAS products to optimize your network.

**Related Topics**
- Adding Data Sources for New WAAS Device, page 3-34
- Understanding Global Capture Settings, page 5-5
- Resetting System Preferences, page 6-11

**Analyzing Application Performance after WAAS Optimization**

WAN optimization allows you to display response time, concurrent connections, traffic volume and compression ratio from WAN data sources after WAAS optimization. To analyze the WAAS traffic, choose Analyze > WAN Optimization > Application Performance Analysis.

The tasks associated with this analysis include:
- Comparing Transaction Time (Client Experience), page 4-15
- Comparing Traffic Volume and Compression Ratio, page 4-15
- Planning Capacity Using Average Concurrent Connections (Optimized vs. Passthru), page 4-15
- Optimizing Usage Using Multi-Segment Network Time (Client LAN - WAN - Server LAN), page 4-15

**Comparing Transaction Time (Client Experience)**

You can compare client transaction time using this chart. It displays the average client transaction time. One line represents pass-through traffic (in which optimization is turned off), and the second represents optimized traffic. After setting up optimization for a certain period, you can compare the two lines and see where the vertical drop in the chart occurs. The data is shown in microseconds.

**Comparing Traffic Volume and Compression Ratio**

You can compare the bandwidth reduction ratio between the number of bits before compression and the number of bits after compression using this chart.

**Planning Capacity Using Average Concurrent Connections (Optimized vs. Passthru)**

You can use the number of concurrent connections during a specified time to assist with peak and off-period identification. This information can be used for capacity planning.

**Optimizing Usage Using Multi-Segment Network Time (Client LAN - WAN - Server LAN)**

You can use the network time between the multiple segments to identify lagging performance issues. The data is shown in microseconds.
Chapter 4  Monitoring and Analyzing Traffic

Measuring Response Time

The NAM monitors TCP packet flow between client and server, and measures response time data to provide more visibility into application response times (ART) and network latency. Prime NAM response time monitoring provides end-to-end response times to help you locate possible network and application delays.

Note

Prime NAM software supports IPv6 for response time monitoring.

You can set up the NAM to measure network time, client response time, server response time, and total transaction time to improve application performance. Figure 4-2 shows the various points in network packet flow where the NAM gathers data and the trip times you can monitor. This is one example that represents only a subset of measurements.

Monitoring WAAS Traffic Across Multi-Segments

To monitor WAAS traffic across multiple segments use the Conversation Multiple Segments window. This window provides a correlation of data from different data sources, and allows you to view and compare response time metrics from multiple WAAS segments (data sources). You can access this window from Analyze > WAN Optimization > Conversation Multi-segments.

The window shows network time, server response time, and other metrics of the selected server or client-server pair from applicable segments. The relevant metrics from all segments are combined into one row per client-server conversation.

Monitoring WAAS Single-Segment Traffic

To monitor WAAS traffic across a single segment use the data in the Conversation Single-Segments window to see data from different data sources, and view and compare response time metrics from different WAAS segments (data sources). You can access this window from Analyze > WAN Optimization > Conversation Single-Segment.

The window shows network time, server response time, and other metrics of the selected server or client-server pair (one row per segment).
Figure 4-2  NAM Application Response Time Measurements

Figure 4-3 shows a representation of total transaction time as opposed to application response time.

Figure 4-3  Transaction Time versus Response Time Measurements

Table B-35 lists and describes the ART metrics measured by Prime NAM.

Application Response Time Metrics are available on the response Response Time Summary Dashboard (Monitor > Response Time Summary), which allows you to see a summary view of the data.

To analyze Response Time data over time, use the selections found under Analyze > Response Time:

- Application Response Time, page 4-18
- Network Response Time, page 4-18
- Server Response Time, page 4-18
- Client Response Time, page 4-19
- Client-Server Response Time, page 4-19
When you select Analyze > Response Time > Detailed Views, you will be able to select one of the following, each of which contains detailed lists of the response events.

- Server Application Responses, page 4-19
- Server Application Transactions, page 4-19
- Server Network Responses, page 4-20
- Client-Server Application Responses, page 4-20
- Client-Server Application Transactions, page 4-20
- Client-Server Network Responses, page 4-21

**Application Response Time**

The Application Analysis window allows you to view the performance of a particular application over time. It is accessed from Analyze > Response Time > Application.

The Transaction Time chart shows you the average transaction time for the application you have selected. It is broken down into three components: Network Time, Server Response Time, and Data Time.

The Other Metrics chart allows you to see information over time after you have selected the desired metrics from the Metric1 and Metric2 drop-down.

Next are the Top Clients and Top Servers charts. These show you the clients and servers with the most bits of traffic for the chosen application.

**Note**
You can choose to display NAM data in either Bits or Bytes in Administration > System > Preferences.

**Network Response Time**

After you have selected a client site and a server site, the chart will show you the transaction time of the network link between the client site and server site. It is accessed from Analyze > Response Time > Network.

**Note**
If you do not specify any application, the chart will show the network time instead of transaction time.

The Other Metrics chart allows you to see information about the network link between sites, after you have selected the desired metrics from the Metric1 and Metric2 drop-down.

The Top Clients and Top Servers charts show you the top clients and servers that are communicating through the network link (in bits or bytes).

**Server Response Time**

Choose the Client Site and Server Site from the Interactive Report on the left, and enter the IP address for the server that you want to analyze. The Server Transaction Time Composition chart will display the network time, server response time, data time, and transaction time.
The Other Metrics chart allows you to see information about the server performance after you have selected the desired metrics from the Metric1 and Metric2 drop-down.

Top Client shows you top client talking to the server you have selected; Server Top Clients Sites shows the top client sites (traffic bits).

**Note** You can choose to display NAM data in either Bits or Bytes in Administration > System > Preferences.

### Client Response Time

After entering the client IP address and application in the Interactive Report Filter, you can analyze the transaction time of that client in the Client Transaction Time Composition chart.

The Other Metrics chart allows you to see client performance over time after you have selected the desired metrics from the Metric1 and Metric2 drop-down.

The Clients Top Applications chart show you the applications being used the most by the client selected, and the Top Servers chart show you the servers being used most by the client.

### Client-Server Response Time

After you enter the client IP address and server IP address in the Interactive Report, you can analyze the transaction times between the client and server you have selected in the Client-Server Transaction Composition Over Time chart.

The Other Metrics chart allows you to see Client-Server transaction information after you have selected the desired metrics from the Metric1 and Metric2 drop-down.

### Server Application Responses

The Server Application Responses Table displays when you choose Analyze > Response Time > Detailed Views > Server Application Responses.

If you click on a row of data, you can then choose Response Time Details to see more information.

Table B-43 provides definitions of each field of the Server Application Responses window.

### Server Application Transactions

The Server Application Transaction window displays when you click Analyze > Response Time > Detailed Views > Server Application Transactions.

The Server Application Transactions window provides a summary of the server application transaction response times (ART) per server application displaying the server IP address, application used, and minimum, average, and maximum response times for the following:

- Application Response Time
- Data Transfer Time
- Retransmit Time
Measuring Response Time

- Round Trip Time

**Note**
NAM uses the TCP three-way handshake to calculate network delay. If there are no new TCP connections during the polling interval, the NAM GUI displays a dash (-) for the delay value indicating there is no delay data for that interval.

Table B-44 provides definitions of each field of the Server Application Transactions window.

### Server Network Responses

The Server Network Responses window shows the network connectivity and responsiveness between the server and the switch. It is located at Analyze > Response Time > Detailed Views > Server Network Responses.

**Note**
NAM uses the TCP three-way handshake to calculate network delay. If there are no new TCP connections during the polling interval, the NAM GUI displays a dash (-) for the delay value indicating there is no delay data for that interval.

Table B-45 provides definitions of each field of the Server Network Response Times window.

### Client-Server Application Responses

To view the Client-Server Application Responses window, click Analyze > Response Time > Detailed Views > Client-Server Application Responses.

The Client-Server Application Responses window displays. Table B-36 provides definitions of each field of the Client-Server Application Responses window.

**Note**
NAM uses the TCP three-way handshake to calculate network delay. If there are no new TCP connections during the polling interval, the NAM GUI displays a dash (-) for the delay value indicating there is no delay data for that interval.

### Client-Server Application Transactions

The Client-Server Application Transactions window provides a summary of the server application transaction response times (ART) per server application displaying the server IP address, application used, and minimum, average, and maximum response times for the following:

- Application Response Time
- Data Transfer Time
- Retransmit Time
- Round Trip Time
Analyzing Device Interface, Health, and Application Data

You can view interface information, system health data, and Network Based Application Recognition (NBAR) data using the Analyze > Managed Device window. The menu selections for analyzing Managed Devices are:

- Viewing Interface Information, page 4-21
- Viewing Health Data, page 4-22
- Viewing NBAR Data, page 4-28

Viewing Interface Information

You can view the following interface information:

- Interfaces Stats Table, page 4-21
- Interface Statistics Over Time, page 4-22

Interfaces Stats Table

To view packet distribution details on the interfaces, choose Analyze > Managed Device > Interface. The Interfaces Stats table displays and shows the total packet distribution on all interfaces. Depending on the interface chosen, the chart below the table refreshes with that information. Use the Interactive Report and the Filter button on the left to change the time range displayed. The Discards and Errors are measured in packets per second.
Analyzing Device Interface, Health, and Application Data

Chapter 4 Monitoring and Analyzing Traffic

Interface Statistics Over Time
When you select an interface in the Interface Statistics Table, the statistics for that interface updates in
the graph below the Interface Statistics Table.

You can check the check boxes for the information you would like displayed in the graph:

- Bits: In Bits, Out Bits
- Packets: In Packets (inUcastPkts + inNUcastPkts), Out Packets (outUcastPkts + outNUcastPkts)
- Discards: In Discards, Out Discards
- Errors: In Errors, Out Errors

**Note** You can choose to display NAM data in either Bits or Bytes in Administration > System > Preferences.

Viewing Health Data
You can use the NAM to view system health data. To view system health data collected for the switch or
router, choose Analyze > Managed Device > Health from the menu.

For more details on the options available in each windows, see:

- Switch Health Options, page 4-22
- Router Health Options, page 4-26

**Note** This section applies to all NAM platforms except the NAM-NX1.

Switch Health Options

For a switch, the Health window is displayed with a drop-down menu that provides the following options:

- Chassis Health, page 4-22
- Chassis Information, page 4-23
- Crossbar Switching Fabric, page 4-24
- Ternary Content Addressable Memory Information, page 4-25

**Chassis Health**

The Chassis Health window displays two real-time graphs: CPU usage and Backplane Utilization.

**CPU usage**

**CPU type**

- Usage for last 1 minute (%)
- Usage for last 5 minutes (%)

**Backplane Utilization**

- Peak %
• Peak Time (For example: Mon October 1 2007, 15:26:55)
The Health window also displays a matrix with the following information:
• Minor Alarm (on, off)
• Major Alarm (on, off)
• Temperature Alarm (on, off)
• Fan Status (other, ok, minorFault, majorFault, unknown)

Table 4-2 Chassis Memory Information

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Memory Type</td>
<td>Type of memory including DRAM, FLASH, NVRAM, MBUF, CLUSTER, MALLOC.</td>
</tr>
<tr>
<td>Used</td>
<td>Number of used MB for a particular memory type.</td>
</tr>
<tr>
<td>Free</td>
<td>Number of free MB for a particular memory type.</td>
</tr>
<tr>
<td>Largest Free</td>
<td>Number of largest contiguous free MB for a particular memory type.</td>
</tr>
</tbody>
</table>

Chassis Information

Table 4-3 describes the Chassis Information window.

Table 4-3 Chassis Information

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name an administrator assigned to this managed node, this is the node's fully-qualified domain name.</td>
</tr>
<tr>
<td>Hardware</td>
<td>A textual description which should contain the manufacturer's name for the physical entity and be set to a distinct value for each version or model of the physical entity.</td>
</tr>
<tr>
<td>Backplane</td>
<td>The chassis backplane type.</td>
</tr>
<tr>
<td>Supervisor Software</td>
<td>The full name and version identification of the system’s software operating-system and networking software.</td>
</tr>
<tr>
<td>Version</td>
<td></td>
</tr>
<tr>
<td>UpTime</td>
<td>The time (in hundredths of a second) since the network management portion of the system was last re-initialized.</td>
</tr>
<tr>
<td>Location</td>
<td>The physical location of this node.</td>
</tr>
<tr>
<td>Contact</td>
<td>The textual identification of the contact person for this managed node and information on how to contact this person.</td>
</tr>
<tr>
<td>Modem</td>
<td>Indicates whether the RS-232 port modem control lines are enabled.</td>
</tr>
<tr>
<td>Baud rate</td>
<td>The baud rate in bits per second of the RS-232 port.</td>
</tr>
<tr>
<td>Power Supply</td>
<td>Description of the power supply being instrumented.</td>
</tr>
</tbody>
</table>
Table 4-3  Chassis Information (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power Supply Type</td>
<td>The power supply source:</td>
</tr>
<tr>
<td></td>
<td>• unknown</td>
</tr>
<tr>
<td></td>
<td>• ac</td>
</tr>
<tr>
<td></td>
<td>• dc</td>
</tr>
<tr>
<td></td>
<td>• externalPowerSupply</td>
</tr>
<tr>
<td></td>
<td>• internalRedundant</td>
</tr>
<tr>
<td>Power Supply Status</td>
<td>The current state of the power supply being instrumented.</td>
</tr>
<tr>
<td></td>
<td>1: normal</td>
</tr>
<tr>
<td></td>
<td>2: warning</td>
</tr>
<tr>
<td></td>
<td>3: critical</td>
</tr>
<tr>
<td></td>
<td>4: shutdown</td>
</tr>
<tr>
<td></td>
<td>5: notPresent</td>
</tr>
<tr>
<td></td>
<td>6: notFunctioning</td>
</tr>
<tr>
<td>Power Redundancy Mode</td>
<td>Power Redundancy Mode:</td>
</tr>
<tr>
<td></td>
<td>The power-supply redundancy mode.</td>
</tr>
<tr>
<td></td>
<td>1: not supported</td>
</tr>
<tr>
<td></td>
<td>2: redundant</td>
</tr>
<tr>
<td></td>
<td>3: combined</td>
</tr>
<tr>
<td>Power Total</td>
<td>Total current available for FRU usage.</td>
</tr>
<tr>
<td></td>
<td>When Redundancy Mode is redundant, the total current available will be the capability of a power supply with the lesser power capability of the two power supplies.</td>
</tr>
<tr>
<td></td>
<td>When Redundancy Mode is combined, the total current available will be the sum of the capacities of all operating power supplies.</td>
</tr>
<tr>
<td>Power Drawn</td>
<td>Total Current Drawn by powered-on FRUs.</td>
</tr>
</tbody>
</table>

Crossbar Switching Fabric

Table 4-4 describes the Crossbar Switching Fabric information.
Table 4-4 Crossbar Switching Fabric Information

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Crossbar Switching Fabric</td>
<td>Physical and configuration information about the module:</td>
</tr>
<tr>
<td>Active slot</td>
<td>Indicates the slot number of the active switching fabric module. A value of NONE indicates that the active switching fabric module is either powered down or not present in the chassis.</td>
</tr>
<tr>
<td>Backup slot</td>
<td>Indicates the slot number of the backup switching fabric module. A value of NONE indicates that the backup switching fabric module is either powered down or not present in the chassis.</td>
</tr>
<tr>
<td>Bus Only Mode Allowed</td>
<td>Determines the value of each module. If set to True, each and every module is allowed to run in bus-only mode. If set to False, none of the modules are allowed to run in bus-only mode. (All the non-fabric capable modules will be powered off.) Absence of fabric module results in all the fabric capable modules being powered off.</td>
</tr>
<tr>
<td>Truncated Mode Allowed</td>
<td>Indicates whether truncated mode is administratively enabled on the device or not.</td>
</tr>
<tr>
<td>Module Switching Mode</td>
<td>Indicates switching mode of the module:</td>
</tr>
<tr>
<td>busmode</td>
<td>Module does not use fabric. Backplane is used for both lookup and data forwarding.</td>
</tr>
<tr>
<td>crossbarmode</td>
<td>Module uses the backplane for forwarding decision and fabric for data forwarding.</td>
</tr>
<tr>
<td>dcefmode</td>
<td>Module uses fabric for data forwarding and local forwarding is enabled.</td>
</tr>
<tr>
<td>Module-Channel</td>
<td>Module slot number</td>
</tr>
<tr>
<td>Module-Status</td>
<td>Status of the fabric channel at the module</td>
</tr>
<tr>
<td>Fabric Status</td>
<td>Status of the fabric channel at the slot</td>
</tr>
<tr>
<td>Speed (MB)</td>
<td>Speed (MB/second) of the module</td>
</tr>
<tr>
<td>Module-Channel</td>
<td>Channel for the module</td>
</tr>
<tr>
<td>In Errors</td>
<td>The total number of error packets received since this entry was last initialized.</td>
</tr>
<tr>
<td>Our Errors</td>
<td>The total number of error packets transmitted since this entry was last initialized.</td>
</tr>
<tr>
<td>Dropped</td>
<td>The total number of dropped packets transmitted since this entry was last initialized.</td>
</tr>
<tr>
<td>In Utilization (%)</td>
<td>Input utilization of the channel for the module.</td>
</tr>
<tr>
<td>Out Utilization (%)</td>
<td>Output utilization of the channel for the module.</td>
</tr>
</tbody>
</table>

Ternary Content Addressable Memory Information

Shows the Ternary Content Addressable Memory (TCAM) usage information. Table 4-5 lists and describes the TCAM information.
Table 4-5  Ternary Content Addressable Memory Information

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Security Acl Mask</td>
<td>Indicates that TCAM space is allocated to store ACL masks.</td>
</tr>
<tr>
<td>Security Acl Value</td>
<td>Indicates that TCAM space is allocated to store ACL value.</td>
</tr>
<tr>
<td>Dynamic Security Acl Mask</td>
<td>Indicates that TCAM space is allocated to dynamically store ACL masks.</td>
</tr>
<tr>
<td>Dynamic Security Acl Value</td>
<td>Indicates that TCAM space is allocated to dynamically store ACL values.</td>
</tr>
<tr>
<td>Qos Acl Mask</td>
<td>Indicates that TCAM space is allocated to store QoS masks.</td>
</tr>
<tr>
<td>Qos Acl Value</td>
<td>Indicates that TCAM space is allocated to store QoS value.</td>
</tr>
<tr>
<td>Dynamic Qos Acl Mask</td>
<td>Indicates that TCAM space is allocated to dynamically store QoS masks.</td>
</tr>
<tr>
<td>Dynamic Qos Acl Value</td>
<td>Indicates that TCAM space is allocated to dynamically store ACL values.</td>
</tr>
<tr>
<td>Layer 4 Port Operator</td>
<td>Indicates that TCAM space is allocated for layer 4 port operators purpose.</td>
</tr>
<tr>
<td>Interface Mapping Module</td>
<td>Indicates that TCAM space is allocated for interface mapping purpose.</td>
</tr>
</tbody>
</table>

Router Health Options

If your device is a router, the Router Health window displays with a drop-down box that provides the following options:

- Router Health, page 4-26
- Router Information, page 4-27

Router Health

The Router Health window displays a real-time graph and information about the health of a router. Table 4-6 describes the contents of the Router Health window.

Table 4-6  Router Health Information

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPU Usage (graph)</td>
<td>Overall CPU busy percentage in the last 5 minute period</td>
</tr>
<tr>
<td>CPU Type</td>
<td>Describes type of CPU being monitored</td>
</tr>
<tr>
<td>Last 1 minute</td>
<td>Overall CPU busy percentage in the last 1 minute period.</td>
</tr>
<tr>
<td>Last 5 minutes</td>
<td>Overall CPU busy percentage in the last 5 minute period.</td>
</tr>
<tr>
<td>Temperature Description</td>
<td>Description of the test point being measured</td>
</tr>
</tbody>
</table>
### Table 4-6 Router Health Information (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Temperature Status</td>
<td>The current state of the test point being instrumented; one of the following are the states:</td>
</tr>
<tr>
<td></td>
<td>- Normal</td>
</tr>
<tr>
<td></td>
<td>- Warning</td>
</tr>
<tr>
<td></td>
<td>- Critical</td>
</tr>
<tr>
<td></td>
<td>- Shutdown</td>
</tr>
<tr>
<td></td>
<td>- Not Present</td>
</tr>
<tr>
<td></td>
<td>- Not Functioning</td>
</tr>
<tr>
<td></td>
<td>- Unknown</td>
</tr>
<tr>
<td>Failures</td>
<td>The failing component of the power supply being measured:</td>
</tr>
<tr>
<td></td>
<td>- None—No failure</td>
</tr>
<tr>
<td></td>
<td>- inputVoltage—Input power lost in one of the power supplies</td>
</tr>
<tr>
<td></td>
<td>- dcOutputVoltage—DC output voltage lost in one of the power supplies</td>
</tr>
<tr>
<td></td>
<td>- Thermal—Power supply thermal failure.</td>
</tr>
<tr>
<td></td>
<td>- Multiple—Multiple failures.</td>
</tr>
<tr>
<td></td>
<td>- Fan—Fan failure</td>
</tr>
<tr>
<td></td>
<td>- Overvoltage—Over voltage</td>
</tr>
<tr>
<td>Memory Type</td>
<td>Type of memory including processor and I/O.</td>
</tr>
<tr>
<td>Used</td>
<td>Number of used MB for a particular memory type.</td>
</tr>
<tr>
<td>Free</td>
<td>Number of free MB for a particular memory type.</td>
</tr>
<tr>
<td>Largest Free</td>
<td>Number of largest contiguous free MB for a particular memory type.</td>
</tr>
</tbody>
</table>

### Router Information

The Router Information window displays router information. Table 4-7 lists and describes the fields of the Router Information window.

### Table 4-7 Router Information

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name an administrator assigned to this managed node, this is the node's fully-qualified domain name.</td>
</tr>
<tr>
<td>Hardware</td>
<td>A textual description which should contain the manufacturer's name for the physical entity and be set to a distinct value for each version or model of the physical entity.</td>
</tr>
<tr>
<td>Supervisor Software Version</td>
<td>The full name and version identification of the system's software operating-system and networking software.</td>
</tr>
<tr>
<td>Up Time</td>
<td>The time (in hundredths of a second) since the network management portion of the system was last re-initialized.</td>
</tr>
</tbody>
</table>
Chapter 4      Monitoring and Analyzing Traffic

Analyzing Media

Viewing NBAR Data

You can use the NAM to view Network Based Application Recognition (NBAR) protocol discovery data. To view the NBAR data collected for a switch or router, choose Analyze > Managed Device > NBAR Protocol Discovery.

If NBAR is not enabled on your switch or router, you will see a message stating that you cannot see NBAR information without an IOS version that supports NBAR. After you acquire the correct IOS version, you can enable the feature under Setup > Managed Devices > NBAR Protocol Discovery.

Note

This section applies to all NAM platforms except the NAM-NX1.

Analyzing Media

The menu selections for Analyzing Media are:

- RTP Streams, page 4-29
- Voice Call Statistics, page 4-31
- Calls Table, page 4-31
- RTP Conversation, page 4-33
RTP Streams

Understanding the RTP Stream Data

To view RTP stream information, summary statistics on the stream, and per-interval statistics, use the RTP Streams.

This window shows you three pieces of information:

**RTP Stream Information**
- Source IP Address and Port: IP address and UDP port of the originator of the RTP stream.
- Destination IP Address and Port: IP address and UDP port of the receiver of the RTP stream.
- SSRC: Synchronization source number as it appeared in the RTP header of the RTP stream.
- codec: encoding decoding format of the RTP stream.

**RTP Stream Stats Summary**
This shows you the summary of the RTP stream for the entire duration of RTP stream.
- Duration: duration of the RTP stream. This may not be the entire duration of the stream. It depends on the viewing time interval of the window which launched this RTP stream detail window.
- Worst / Duration Weighted / Max MOS: the lowest score among per-interval reports, the score of all per-interval reports that takes duration into account, and the highest score among per-interval reports of the stream.

Note: Duration-weighted is calculated with the following formula:
\[
\frac{\sum (\text{per-minute-mos} \times \text{duration})}{\sum \text{duration}}
\]

- Worst / Duration Weighted / Min Jitter: the largest jitter among per-interval reports, the jitter that takes into account of the duration of all per-interval reports, and the smallest jitter values among per-interval reports of the stream.

Note: Duration-weighted are used with the following formula:
\[
\frac{\sum (\text{per-interval-jitter} \times \text{duration})}{\sum \text{duration}}
\]

- Worst / Overall / Min Actual Packet Loss: Loss percent of RTP packets that are not seen by NAM and RTP packets that arrived beyond the buffer capability of the receiving endpoint. This includes the highest percentile among per-interval reports, the sum of packets loss against total packets of all per-interval reports, and the lowest percentile loss among per-interval reports.
- Worst / Overall / Min Actual Packet Loss: Similar to above, but the percent loss only includes RTP packets that were not seen by the NAM.
Worst / Total / Min Concealment Seconds: Number of seconds in which NAM detected packet loss during the duration of the stream. This includes lowest concealment seconds among per-interval reports, total concealment seconds of the entire duration of the stream, and highest concealment seconds among per-minute stream reports.

Severe Concealment Seconds: Similar to above; severe condition is met when the seconds have more than 5 percent loss.

RTP Stream Stats Details
This table shows the per-interval stats calculated by NAM at each interval. The columns of the tables are:

- Report Time: time when the stats were calculated. This is the end time of the interval.
- Report Duration: the stream duration during the report interval.
- Worst MOS: the lowest score of the stream among 3-second MOS score. NAM internally evaluates the MOS value of the stream every 3 seconds. This is the lowest score among them.
- Average MOS: average score of the 3-second score values during the duration of the stream in the interval. This value is used in deriving the Duration Weighted MOS value in NAM.
- Jitter: variation of packet arrival time compare to the expected time.
- Actual Packet Loss percentile: percentile of packets that are not seen by NAM.
- Adjusted Packet Loss percentile: percentile of packets that include the actual packets lost and packets that had arrived too late to get into buffer prior to paying back at the endpoint.
- Concealment Seconds: number of seconds in which the NAM sees packet loss.
- Severe Concealment Seconds: number of seconds in which the NAM detected more 5 percent of packet loss.
- Packets: total packets NAM have seen for the interval.

Monitoring RTP Streams
To monitor the RTP streams, choose Analyze > Media > RTP Streams. You can also arrive at this page by:

- From the RTP Conversation table, clicking on a specific stream
- From the Call Detail window, clicking on the stream that is associated with the call

In this window, at least one of the following is required: Site or data source.

The five charts available in this window are:

- RTP Streams: Number of streams that fall in the quality bands of excellent, good, fair, and poor during the selected interval.
- Top N Source End Points: Endpoints that generated the lowest duration weighted MOS during the selected interval.
- Top N Destination Endpoints: Endpoints that experienced the lowest duration weighted MOS during the selected interval.
- Top N RTP streams: RTP streams that have the lowest duration weighted MOS during the selected interval.
- Top N RTP streams by Adjusted Packet Loss: RTP streams that have the highest overall adjusted packet loss percent during the selected interval.
Voice Call Statistics

To monitor voice quality, choose Analyze > Media > Voice Call Statistics. The charts will provide an overview of voice quality.

The charts available are:

- **Voice Call Statistics**: Number of calls per signaling protocol (SCCP, SIP, MGCP, and H.323) at each interval during the selected interval.
- **Top N End Points by Jitter (ms)**: Endpoints that have the largest average of endpoint reported jitter during the selected interval.
- **Top N End Points by Packet Loss (%)**: Endpoints that have the largest average of endpoint reported packet loss during the selected interval.
- **Top N Calls by Jitter (ms)**: Calls that have the longest endpoint-reported jitter during the selected interval.
- **Top N Calls by Packet Loss (%)**: Calls that have the most endpoint reported packet loss percent during the selected interval.

Calls Table

The Calls Table shows you calls that the NAM detected by inspecting voice signaling protocols’ payload. For this table to have data, the NAM must see:

- SCCP protocol: Call Information message of the call.
- SIP protocol: SIP INVITE message of the call. Note that SIP protocol will be detected as per call leg.
- H.323 protocol: Call SETUP of the call.
- MGCP protocol: Create connection message of the call. Note that MGCP will be detected per call leg.

**Note**

SIP and MGCP will be detected per call leg. Each call could be two or more parties. Each party has its own call leg from the call party to control entity; for example, Cisco Unified Communications Manager or MGCP gateway. Any information that is not detected by NAM will be displayed as “-” or blank.

To view the active calls, choose Analyze > Media > Detailed Views > Call Table. The Calls Table and RTP Streams for the Selected Call Table display. These tables show a list of all currently active calls.

**Note**

Some values in the Calls table are not available until the end of the call, and Cisco Unified Communications Manager must be configured to have the IP phones send out the call status and quality information.

**Note**

All calculated metrics in Table 4-8, Calls Table, are based on a one minute interval.

Table 4-8 provides descriptions of the fields of the Calls Table.
Analyzing Media

If you click on a call row in the table, in the RTP Streams for the Selected Call display at the bottom of the page you will see all streams that are associated with the call. It will display the RTP streams that:

- have source address and port matched the call’s calling host address and calling port or called host address and called port
- have destination address and port that matched the call’s calling host address and calling port or called address and called port

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calling Number</td>
<td>Calling number as it appears in the signaling protocol.</td>
</tr>
<tr>
<td>Called Number</td>
<td>Called number as it appears in the signaling protocol.</td>
</tr>
<tr>
<td>Calling Host Address</td>
<td>RTP receiving address of the calling party detected by the NAM from inspecting the call signaling protocol.</td>
</tr>
<tr>
<td>Calling Port</td>
<td>RTP receiving port of the calling party detected by NAM from inspecting call signaling protocol.</td>
</tr>
<tr>
<td>Calling Alias</td>
<td>Calling party name detected by NAM from inspecting call signaling protocol.</td>
</tr>
<tr>
<td>Called Host Address</td>
<td>IP address of the phone receiving the call.</td>
</tr>
<tr>
<td>Called Port</td>
<td>Port of the phone receiving the call.</td>
</tr>
<tr>
<td>Called Alias</td>
<td>Alias name, MGCP endpoint ID, or SIP URI of the called party phone.</td>
</tr>
<tr>
<td>Calling Reported Jitter (ms)</td>
<td>Jitter value reported by calling party at the end of the call.</td>
</tr>
<tr>
<td>Calling Reported Packet Loss (%)</td>
<td>Percentage of packet loss reported by calling party at the end of the call.</td>
</tr>
<tr>
<td>Start Time</td>
<td>Time when the call was detected to start.</td>
</tr>
<tr>
<td>End Time</td>
<td>Time when the call was detected to end.</td>
</tr>
<tr>
<td>Duration</td>
<td>Duration of the call.</td>
</tr>
</tbody>
</table>

| Note                   | When the call signaling’s call tear down sequence is not detected by the NAM, the NAM will assume: |
|                        | - the call ended after 3 hours in low call volume per interval               |
|                        | - the call ended after 1 hour in high call volume per interval (high call volume is defined as call table filled up during the interval.) |

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Called Reported Jitter (ms)</td>
<td>Jitter value reported by called party at the end of the call.</td>
</tr>
<tr>
<td>Called Reported Pkt Loss (%)</td>
<td>Percentage of packet loss reported by called party at the end of the call.</td>
</tr>
</tbody>
</table>

There is a delay of two minutes of RTP streams statistics. As the result, there may not be any RTP stream information of the call.

The RTP Streams of the Selected Call table shows the overall RTP streams statistics that are calculated by the NAM. You can use this information to compare the views of the call endpoints and the NAM regarding the call’s qualities. The columns of the RTP Stream are described in Table 4-9.
Analyzing Media

You can see more detailed information about each RTP stream by selecting the RTP stream and clicking on the **RTP Stream Details** button. A pop up window will show more detailed information of the stream displayed.

### RTP Conversation

To get detailed information about RTP conversations, choose **Analyze > Media > Detailed Views > RTP Conversations**. This table shows you the overview of RTP streams analyzed by NAM during the selected interval. You can drill-down to each stream to get stream statistics, which are analyzed by the NAM at each interval. To get more detailed information, you can:

- Click on the RTP stream for which you want to see more information.
- Click on the “RTP Stream Details” context menu. A pop up window will show you the detailed information of the stream.

The columns of the RTP Conversation tables are described in **Table 4-10, RTP Conversations Table**.

#### Table 4-9  RTP Streams for the Selected Call Table

<table>
<thead>
<tr>
<th>Field</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source Address</td>
<td>IP Address of the originator of the RTP stream</td>
</tr>
<tr>
<td>Source Port</td>
<td>UDP port of the originator of the RTP stream</td>
</tr>
<tr>
<td>Destination Address</td>
<td>IP address of the receiver of the RTP stream</td>
</tr>
<tr>
<td>Destination Port</td>
<td>UDP port of the receiver of the RTP stream</td>
</tr>
<tr>
<td>Codec</td>
<td>Encoding decoding format/algorithm of the RTP stream</td>
</tr>
<tr>
<td>SSRC</td>
<td>Synchronization source number as it appear in the RTP header</td>
</tr>
<tr>
<td>Duration Weighted MOS</td>
<td>NAM calculated score that takes into account of the duration of the stream</td>
</tr>
<tr>
<td>Duration Weighted Jitter</td>
<td>Jitter that takes into account of the duration of the RTP stream among all per-interval reports</td>
</tr>
<tr>
<td>Overall Adjusted Packet Loss</td>
<td>Percentile of adjust packets lost against total packets of all per-interval RTP reports</td>
</tr>
</tbody>
</table>

#### Table 4-10  RTP Conversations Table

<table>
<thead>
<tr>
<th>Field</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Time</td>
<td>Time when the RTP stream was discovered by the NAM</td>
</tr>
<tr>
<td>Source Address</td>
<td>IP Address of the originator of the RTP stream</td>
</tr>
<tr>
<td>Source Port</td>
<td>UDP port of the originator of the RTP stream</td>
</tr>
<tr>
<td>Destination Address</td>
<td>IP address of the receiver of the RTP stream</td>
</tr>
<tr>
<td>Destination Port</td>
<td>UDP port of the receiver of the RTP stream</td>
</tr>
<tr>
<td>Codec</td>
<td>Encoding decoding format/algorithm of the RTP stream</td>
</tr>
</tbody>
</table>
Site MOS

You can use the Mean Opinion Score (MOS) to quantify the perceived level of quality you are receiving in your network voice traffic. This allows you to assess the work of codecs, or algorithms, which compress audio traffic to save on bandwidth utilization but may result in a drop in quality.

You must first set up the software to monitor voice data, then you can view the collected voice data using Analyze > Media > Detailed Views > Site MOS.

For details on Site MOS scores, see Table B-31.

Using the NAM Application Programming Interface

NAM provides an Application Programming Interface (API) that allows you to configure and retrieve data from the NAM. The API follows the commonly used Representational State Transfer (REST) style of providing services over HTTP or HTTPS. The NAM REST API is also referred to as the Northbound Interface (NBI).

For application developers who want to use the NAM REST API, ask your Cisco representative about the Cisco Prime Network Analysis Module REST API Guide.
Capturing and Decoding Packets

You can set up multiple sessions to capture, filter, and decode packet data using the Capture feature. You can then manage the data in a local or remote file control system and display the contents of the packets.

Note
This software feature may be limited depending on your hardware platform. For details, see the NAM Compatibility Matrix.

This chapter contains the following sections:

- Analyzing Packet Basics, page 5-1
- Using Quick Capture, page 5-2
- Creating and Managing Capture Sessions, page 5-3
- Working with Capture Files, page 5-16
- Utilizing Capture Data Storage, page 5-20
- Inspecting Packet Decode Information for Suspicious Traffic, page 5-24

Analyzing Packet Basics

This section provides an overview of how to collect and analyze performance data to ensure your network is running well or pinpoint network issues.

There are many ways to collect data and analyze it using Prime NAM. In order to collect data, the prerequisite is to have set up SPAN or ERSPAN through your NAM dataports. Table 5-1 provides an overview of some of capture basics you can perform to ensure your network is optimized and trouble-free.

<table>
<thead>
<tr>
<th>Basics</th>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Collect traffic data quickly from any NAM dashboard</td>
<td>Quick Capture</td>
<td>Targets data collection based on the dashboard graph you select and provides a capture session and decode window to analyze the traffic immediately. See Using Quick Capture, page 5-2.</td>
</tr>
<tr>
<td>Proactively collect data to learn about a network issue</td>
<td>Continuous capture or Time-based capture</td>
<td>Allows you to set up data collection to:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Use existing data collected prior to network problem</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Set up data collection based on an anomaly that reoccurs</td>
</tr>
</tbody>
</table>
You do not have to perform any configuration and can quickly collect traffic data using the drill-down menu option, **Capture**.

You can start a capture from many of the dashboard bar charts which show Applications or Hosts or VLANs. For example, when you click on an Application in a bar chart (as shown in Figure 5-1) and choose **Capture**, the following happens automatically:

- A memory-based capture session is created
- A software filter is created using that application
- The capture session is started
- The decode window pops open and you can immediately see packets being captured

For details on how to use the decode window to analyze your data, see **Inspecting Packet Decode Information for Suspicious Traffic**, page 5-24.

### Table 5-1 Data Collection and Analysis

<table>
<thead>
<tr>
<th>Basics</th>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create hardware and software filters to focus on specific long-term performance data</td>
<td>Capture &gt; Packet Capture/Decode &gt; Sessions</td>
<td>On supported NAM hardware, helps to limit the amount of traffic allowed into the NAM for processing. See <strong>Supporting Hardware Filters</strong>, page 5-8 and <strong>Filtering Network Traffic Using Software Filters</strong>, page 5-6.</td>
</tr>
<tr>
<td>Create non-stop monitoring for performance checking</td>
<td>Continuous capture</td>
<td>Allows you to save data for extended periods either to memory or storage. See <strong>Capturing to Data Storage</strong>, page 5-20.</td>
</tr>
<tr>
<td>Create targeted monitoring for problem isolation</td>
<td>Start/Stop/Stop Capture and Save to File</td>
<td>Allows you to manipulate capture sessions. See <strong>Configuring Alarm Actions</strong>, page 3-37 and <strong>Using Alarm-Triggered Captures</strong>, page 5-28.</td>
</tr>
<tr>
<td>Set up storage for data collection</td>
<td>Capture &gt; Packet Capture/Decode &gt; Data Storage</td>
<td>Allows you to save data for extended periods either to memory or storage. See <strong>Capturing to Data Storage</strong>, page 5-20.</td>
</tr>
<tr>
<td>Analyze data for potential issues</td>
<td>Decode</td>
<td>Example scenario: Analyze Application and Host Data for Abnormal Behavior in a Wireless Environment Use traffic analysis measurements for applications and host conversations to identify potential issues via CAPWAP or LWAPP encapsulation; for example, network congestion, abnormal traffic utilization and application performance issues. Then view the monitor and analyze screens and customize the time range to find when the abnormal behavior occurred.</td>
</tr>
</tbody>
</table>
Creating and Managing Capture Sessions

The purpose of Capture Sessions is to capture, filter, and decode packet data, manage the data in a local or remote file control system, and display the contents of the packets. The captured packets can then be decoded and analyzed on the NAM for more efficient problem isolation.

This section contains the following topics:
- Understanding Hardware and Software Capture Sessions Filters, page 5-3
- Viewing Capture Sessions, page 5-4
- Configuring Capture Sessions, page 5-5
- Understanding Global Capture Settings, page 5-5
- Filtering Network Traffic Using Software Filters, page 5-6
- Supporting Hardware Filters, page 5-8

Understanding Hardware and Software Capture Sessions Filters

You can filter specific packet data and manage that information in a local or remote file control system. This increases your visibility into network issues and allows you to filter out unnecessary information. You can use either hardware or software filters to target specific packet data to receive.

As shown in Figure 5-2, if network packets coming into the NAM pass through the hardware filters you have configured, the packets go on to the next step. If no hardware filters are configured, all packets pass through. See Supporting Hardware Filters, page 5-8 for more information about hardware filters.

Note

Hardware filters are supported on specific Prime NAM platforms. See the Cisco Prime Network Analysis Module Release Notes for details.
Packets must then pass at least one software filter in that particular session to be saved by that session. If no software filters are configured for a session, then all packets are captured. For more information about software filters, see Filtering Network Traffic Using Software Filters, page 5-6.

For better performance for the supported NAM platforms, hardware filters are recommended over software filters, and fewer sessions are recommended over more sessions.

You do not have to configure the items in Figure 5-2 in any particular order. For example, you can set Global Capture Settings first, and then configure Capture Sessions, and then create filters; or, you can create Hardware and Software filters first, and then configure Capture Sessions, and finally apply Global Capture Settings. We recommend that you “Start” the session last; otherwise, you will start capturing before you have configured any filters and before doing any packet slicing.

Global Capture Settings and Hardware Filters can be changed at any time, even when the session is running; they will affect running capture sessions immediately. See Understanding Global Capture Settings, page 5-5 for details.

**Figure 5-2 NAM Capture Sessions Example**

[Diagram showing the flow of packets through filters and capture sessions]

**Viewing Capture Sessions**

To access the basic operations for capturing, viewing and decoding packet data on the NAM, choose Capture > Packet Capture/Decode > Sessions.

The Capture Sessions window shows the list of capture sessions. If none have been configured, the list will be blank. Table B-47, describes the Capture Sessions fields and operations that you can perform from the Capture Sessions window.
Chapter 5 Capturing and Decoding Packets

Creating and Managing Capture Sessions

Configuring Capture Sessions

Because it may be important for you to collect data over time and have various locations for which you want to analyze data, we support multiple sessions per capture location/target. You can collect data using multiple sessions per target, but only one session can be running per target. Prime NAM now supports up to 25 capture sessions. If you have external storage you can save to local disk and some number of LUNs. As part of configuring a capture session, you can also create software filters, if desired (see Creating a Software Capture Filter for Customized Applications, page 5-6).

To configure a new capture session:

**Step 1** Choose Capture > Packet/Capture Decode > Sessions.
**Step 2** Click Create to set up a new capture. The NAM displays the Configure Capture Session window.
**Step 3** Enter information in the Capture Settings Fields (Table B-48) as appropriate.

When capturing to multiple files, a suffix is added to the file name. For example, the first file for a capture named CaptureA would be labeled as CaptureA_1, the second CaptureA_2, and so on.

**Step 4** Click Submit to finish configuration for this session, or configure Software Filters for this session (see Understanding Global Capture Settings, page 5-5).

Understanding Global Capture Settings

Global Capture Settings allow you to apply your custom packet slice and error settings for all capture sessions. It is located on the Capture Sessions window (above the Hardware Filters window).

The Global Capture Settings dialog includes:

- **Global Packet Slicing**
- **Error Packets**

**Global Packet Slicing**

Packet slicing is a filtering method performed at the monitoring application layer. You can set the size of a packet coming into the NAM and store only a portion in your data storage. This allows you to store more traffic data or limit your data to header information.

The default setting for Global Packet Slicing is Disabled. To enable global packet slicing, click the Enable radio button and select a Packet Slice Size from the drop-down menu. The menu includes values from 56 to 504, in 16-byte increments.

This setting affects all capture sessions and overrides individual capture session software slicing settings (if shorter). For example, if you have a capture session with the slicing field set to 100, but you also have Global Packet Slicing set to 56, then all packets will be sliced down to 56 bytes.

For details on error packet settings, see Error Packets, page 5-5.

**Error Packets**

The Error Packets setting is used to specify if you want error packets to be forwarded into the packet capture. Error packets are packets that would normally be dropped by the network interface card, such as under size and over size packets, as well as packets with CRC errors. Error packets can be very helpful for troubleshooting the network.
The options are:

- **Include in capture** (Default)—Includes packets with and without errors.
- **Exclude from capture**—Omits error packets. The packet capture only includes packets without errors.
- **Only error packets in capture**—Omits packets without errors. The packet capture includes only packets with errors. This option will save disk space but may not be as helpful since you may be unable to see the big picture view of all packet details.

This setting is applied to all capture sessions. For details on global packet slicing settings, see Global Packet Slicing, page 5-5.

### Filtering Network Traffic Using Software Filters

You can create and save specialized filters that will disregard all capture data except the information in which you are interested (see Figure 5-2). You can configure multiple software filters for each session (up to six). This allows you to narrow in on the traffic that you are interested in, and it also saves resources (either memory or disk space).

For NAM-3 and NAM-NX1 service modules, multiple software filters use the “OR” logic; in other words, if a packet passes any software filter, it is captured.

If you create a session and then start it, you cannot edit the session or analyze it without stopping it. If you edit a session containing already captured data, you get a warning stating that the session will be cleared and the data removed. If clearing the session and removing the data is acceptable, ignore the warning dialog message, then add a filter to the session and click **Submit** to enable the new filter settings.

The application filter can be used to filter on the highest layer of the protocol parsing; that is usually a layer 4 protocol (based on port). If you want to filter on the transport protocol (for example, UDP or TCP), you will need to use the “IP Protocol” selector. Selecting, for example, TCP in the “IP Protocol” selector will filter on all packets using TCP.

**Tip**

Be careful when setting capture software filtering for encapsulation. If you set a software capture filter with encapsulation for the top three network traffic layers only, data displays only if the top three layers match the specified encapsulation type.

Use the following topics for help on filtering network traffic using software filters:

- Creating a Software Capture Filter for Customized Applications, page 5-6
- Editing a Software Capture Filter, page 5-7
- Understanding Software Capture Filter Options, page 5-7

### Creating a Software Capture Filter for Customized Applications

You can create software capture filter for many variables. This workflow examines how to create a filter for a specific customized application.

To create a software capture filter:

**Step 1** Choose **Capture > Packet Capture/Decode > Sessions**.
The bottom half of the Configure Capture Session window displays any configured software filters.

**Step 2** Click **Create** at the bottom of the Software Filters pane to create a new software filter.

**Step 3** Enter information in each of the fields as appropriate. See Table B-54 for descriptions of the fields.

**Step 4** Click **Submit** to create the filter, or click **Cancel** to close the dialog box without creating a software filter.

---

### Editing a Software Capture Filter

To edit software capture filters:

**Step 1** Choose **Capture > Packet Capture/Decode > Sessions**.

The Software Filters box is displayed at the bottom of the page.

**Step 2** Choose the filter to edit, then click **Edit**.

The Software Filter dialog box displays. See Table B-54.

**Step 3** Enter information in each of the fields as appropriate.

**Step 4** Do one of the following:

- To apply the changes, click **Submit**.
- To cancel the changes, click **Cancel**.

---

### Understanding Software Capture Filter Options

You can define a software filter to filter based on any of the following options:

- Source host address
- Destination host address
- Network encapsulation
- VLAN or VLAN range
- Application
- Source port or port range
- Destination port or port range

Software capture filtering is not supported on URL-based applications.

Table B-53 contains descriptions of the Software Filter dialog box fields.
The parameters described in the table above are independently evaluated by the NAM. Therefore, the NAM will allow you to enter parameters that are contradictory, but you will not be able to get meaningful results if they do not match.

For example, the parameters Network Encapsulation and Source/Destination Address are independently evaluated. If a filter is specified with contradicting parameters such as “Network Encapsulation=IP4” and “Source Address=an IPv6 address”, it will never match any traffic, and the result will be 0 packets captured.

Supporting Hardware Filters

You can use hardware filtering to help limit the amount of traffic allowed into the NAM for processing. In service modules, there is a hardware datapath throughput limitation and hardware filtering helps to reduce the traffic into the NAM. The NAM hardware platforms that support hardware filtering include:

- Service Modules—NAM-3 and NAM-NX1
- Specific NAM 2000 Series Appliances—2204, 2220, and 2320

Depending on your NAM, the hardware filter support varies:

- Creating NAM Service Module Hardware Filters, page 5-8
- Creating Other NAM Hardware Filters, page 5-13

Creating NAM Service Module Hardware Filters

This section is applicable only for NAM-3 and NAM-NX1 service modules.

NAM-3 and NAM-NX1 service modules have specific hardware filter logic. These hardware filters allow you to improve capture performance by eliminating extraneous traffic, since packets filtered out by hardware filters are not processed by the NAM. Also, because you can tell the NAM to capture only a portion of the packet and discard the rest, you may want to use hardware filters to look for specific packets in a capture decode.

Hardware filters and global packet slicing affect all capture sessions, except for ERSPAN capture sessions. See Figure 5-2, “NAM Capture Sessions Example” for an architectural overview.

Prime NAM supports up to four hardware filters. You can disable hardware filters without deleting them. Within each filter, you can set up conditions with the AND/OR logic. Only the same logic type can be used within the same filter; you cannot mix the AND/OR logic within the same filter. Also, you can combine the filters together with the AND/OR logic. See Figure 5-3 for examples of filter logic you can use.
The selections are described in the following sections. For information about how you can achieve specific results, see Configuring Hardware Filter Examples, page 5-10.

Software filters add flexibility to your filtering, but hardware filters are most efficient. The less traffic that requires software filtering, the more efficient the filtering.

See these topics for information about setting up and managing hardware filters:

- Creating a Hardware Filter, page 5-9
- Configuring Hardware Filter Settings, page 5-10
- Configuring Hardware Filter Examples, page 5-10

Choose Capture > Packet Capture/Decode > Sessions to view the status and settings of hardware filters that are configured on the Cisco NAM. The Hardware Filters box appears at the bottom of the Sessions page.

Creating a Hardware Filter

The Hardware Filters window displays the status and settings of the hardware filters if they have been defined. To configure a capture with hardware filters:

**Step 1** Choose Capture > Packet Capture/Decode > Sessions. The top half of the window shows Capture Sessions, and the bottom half of the window shows Hardware Filters.

**Step 2** In the Hardware Filters section on the bottom of the window, click the Create button. The Hardware Filter Dialog appears.

**Step 3** Enter a name for the hardware filter in the Name field.

**Step 4** Check the “Enable” check box to enable the filter. If the filter is created with the Enable check box unchecked, the filter will be saved but inactive. It can be enabled at a later time by editing the filter and checking the “Enable” check box.

**Step 5** Choose either the “AND” or the “OR” radio button. This selection will apply to all of the selections you make in the next step (the selections are described in Table 5-3).

**Step 6** Check the boxes for the attributes you want to filter on, and then in the corresponding drop-down menu, select the desired option. The Check All check box selects all check boxes. See Table B-52.

**Step 7** Click:
- **Apply** to complete the configuration of the hardware filter
- **Cancel** to abort and return to the previous window
Creating and Managing Capture Sessions

Chapter 5      Capturing and Decoding Packets

- Reset to revert to the previous settings

Configuring Hardware Filter Settings

The Hardware Filter Settings allows you to set global settings for all capture hardware filters. To add settings that apply to all hardware filters:

**Step 1** Choose Capture > Packet Capture/Decode > Sessions.

**Step 2** In the Hardware Filters section at the bottom, click the Hardware Filter Settings button.

**Step 3** Choose the AND or OR Combination Logic, which will be applied to all configured hardware filters. This logic is used to combine the filters; see the green text in Figure 5-3.

**Step 4** Choose the Include in capture or Exclude from capture Packet Match Logic. This selection will apply to all configured hardware filters.

**Exclude from capture** will drop packets that match all of the hardware filters you have configured. Meanwhile, all packets that do not match will be captured.

**Step 5** Click Apply.

Configuring Hardware Filter Examples

Use these topics to configure the following network traffic:

- IP Subunit + L4 Port (Application), page 5-10
- VLAN + L4 Protocol, page 5-11
- Multiple Hosts, page 5-11
- VLAN Range, page 5-12
- Data Port + Frame Length, page 5-12
- MPLS, page 5-12

**IP Subunit + L4 Port (Application)**

To capture all HTTP traffic emanating from the 10.1.1.0/24 subunit:

**Step 1** On the Hardware Filters window, click the Create button.

**Step 2** Enter a name in the Name field.

**Step 3** Choose the Logic “AND” radio button (this will combine the selections you make below).

**Step 4** Check the “Source IP Address” check box and enter the subnet “10.1.1.0/24”.

**Step 5** Check the “L4 Source Port” check box and enter the port “80” for HTTP.

**Step 6** Click Apply.

To see the opposite direction of the HTTP conversations:
Chapter 5 Capturing and Decoding Packets

Creating and Managing Capture Sessions

---

**Step 1** On the Hardware Filters window, click the **Create** button.

**Step 2** Enter a name in the Name field.

**Step 3** Choose the Logic **AND** radio button.

**Step 4** Select **Destination IP Address** and enter the same subnet as before, 10.1.1.0/24

**Step 5** Select **L4 Destination Port** and enter the same port, 80.

**Step 6** Click **Apply**.

**Step 7** To see the incoming and the outgoing, click **Hardware Filter Settings** and select the **OR** logic. This will combine the two hardware filters with the OR logic.

---

**VLAN + L4 Protocol**

To see all TCP traffic from VLAN 100:

**Step 1** On the Hardware Filters window, click the **Create** button.

**Step 2** Enter a name in the Name field.

**Step 3** Choose the Logic **AND** radio button.

**Step 4** Select **VLAN** and enter the VLAN, 100.

**Step 5** Select **L4 Protocol** and choose TCP.

**Step 6** Click **Apply**.

---

**Multiple Hosts**

To see traffic sent to and from multiple hosts: 1.1.1.1, 2.2.2.2, ...

**Step 1** On the Hardware Filters window, click the **Create** button.

**Step 2** Enter a name in the Name field.

**Step 3** Choose the Logic “**OR**” radio button.

**Step 4** Check the Source IP Address check box and enter the first host: 1.1.1.1.

**Step 5** Check the “Destination IP Address” and enter the same host: 1.1.1.1.

**Step 6** Click **Apply**.

**Step 7** Click **Create** to make a second hardware filter.

**Step 8** Enter a name for the hardware filter in the Name field.

**Step 9** Choose the Logic “**OR**” radio button.

**Step 10** Check the “Source IP Address” check box and enter the second host, “2.2.2.2”.

**Step 11** Check the “Destination IP Address” check box and enter the second host, “2.2.2.2”.

**Step 12** Click **Apply**.

**Step 13** Repeat **Step 7** through **Step 12** for a third and fourth host, if desired.

**Step 14** Click **Hardware Filter Settings** and select the logic “**OR**” radio button.
**VLAN Range**

To see all traffic from VLANS 10 through 20:

---

**Step 1** On the Hardware Filters window, click the **Create** button.

**Step 2** Enter a name in the Name field.

**Step 3** Check the check box for “VLAN IDs” and choose “Greater Than” from the drop-down menu.

**Step 4** In the empty field, enter the bottom VLAN range boundary, “9.”

**Step 5** Click **Apply**.

**Step 6** Click **Create** to make a second filter.

**Step 7** Enter a name in the Name field.

**Step 8** Check the check box for “VLAN IDs” and choose “Less Than” from the drop-down menu.

**Step 9** In the empty field, enter the bottom VLAN range boundary, “21.”

**Step 10** Click **Apply**.

**Step 11** Click **Hardware Filter Settings** and select the “AND” radio button, which will combine the logic of all hardware filters.

---

**Data Port + Frame Length**

To see all traffic spanned to DATA PORT 1 that is less than 200 bytes:

---

**Step 1** On the Hardware Filters window, click the **Create** button.

**Step 2** Enter a name in the Name field.

**Step 3** Choose the Logic “AND” radio button.

**Step 4** In the “Data Port” drop-down list, select **DATA PORT 1**.

**Step 5** Check the check box for “Frame Length” and choose “Less Than” from the drop-down menu.

**Step 6** In the empty field, enter the frame length ceiling, “200.”

**Step 7** Click **Apply**.

---

**MPLS**

To see traffic in which the first MPLS label is 300:

---

**Step 1** On the Hardware Filters window, click the **Create** button.

**Step 2** Enter a name in the Name field.

**Step 3** Check the check box for “MPLS Label”.

**Step 4** In the empty field, enter the label, “300.”

**Step 5** Click **Apply**.
### Bi-Direction Conversation

To see both directions of a conversation between hosts 1.1.1.1 and 2.2.2.2:

1. **Step 1** On the Hardware Filters window, click the Create button.
2. **Step 2** Enter a name in the Name field.
3. **Step 3** Choose the Logic “AND” radio button.
4. **Step 4** Click the Source IP Address/Mask check box, select “Equal To” from the drop-down menu, and enter the first host: “1.1.1.1”.
5. **Step 5** Select the Destination Address/Mask check box, select “Equal To” from the drop-down menu, and enter the second host: “2.2.2.2”.
6. **Step 6** Click Apply.
7. **Step 7** Click Create to make a second hardware filter.
8. **Step 8** Enter a name for the hardware filter in the Name field.
9. **Step 9** Choose the Logic “AND” radio button.
10. **Step 10** Click the Source IP Address/Mask check box, select “Equal To” from the drop-down menu, and enter the second host: 2.2.2.2.
11. **Step 11** Select the Destination Address/Mask check box, select “Equal To” from the drop-down menu, and enter the first host: 1.1.1.1.
12. **Step 12** Click Apply.
13. **Step 13** Click the Hardware Filter Settings button and click the OR radio button.
14. **Step 14** Click Apply.

### Negative Filter Logic

In the previous example, you set up filters that match the packets. For negative filter logic, these now need to be blocked.

To see everything except the conversation from the previous example:

1. **Step 1** On the Hardware Filters window, click the Hardware Filter Settings button.
2. **Step 2** For “Packet Match Logic,” select the “Exclude from capture” radio button.
3. **Step 3** Click Apply.

Go to the next section, Understanding Global Capture Settings, page 5-5, for information about configuring software filters for capture sessions.

### Creating Other NAM Hardware Filters

Hardware Filters enable you to improve capture performance by providing hardware-specific filters that eliminate as much extraneous traffic as possible. The packets filtered out by hardware filters are not processed by the NAM, and therefore capture performance improves. This section is applicable to all NAM platforms except the NAM service modules. See Creating NAM Service Module Hardware Filters, page 5-8 for details.
Software filters add flexibility to your filtering, but a capture session is most efficient when you use only hardware filters. The less traffic requiring software filtering, the more efficient the filtering.

Of the NAM appliances that support hardware filtering, you can set up to five hardware filters per appliance.

See Configuring a Hardware Filter, page 5-14 for detailed steps.

**Configuring a Hardware Filter**

The Hardware Filters window appears at the bottom of the Capture > Packet Capture/Decode > Sessions window. To configure a hardware filter:

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Choose Capture &gt; Packet Capture/Decode &gt; Sessions.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>At the bottom of the window, in the Hardware Filters section, click the Create button.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Enter a name in the Name field.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Choose one of the following types of filters from the Type drop-down list:</td>
</tr>
<tr>
<td></td>
<td>• VLAN</td>
</tr>
<tr>
<td></td>
<td>• VLAN and IP</td>
</tr>
<tr>
<td></td>
<td>• IP</td>
</tr>
<tr>
<td></td>
<td>• IP and TCP/UDP</td>
</tr>
<tr>
<td></td>
<td>• IP and Payload Data</td>
</tr>
<tr>
<td></td>
<td>• Payload Data</td>
</tr>
<tr>
<td>Step 5</td>
<td>Data fields will then appear that correspond with the type of hardware filter you selected. Fill in the desired fields. Select the links above for more specific information.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Click Submit to complete the configuration of the capture session. Otherwise, click Reset to revert to the previous settings, or click Cancel to abort.</td>
</tr>
</tbody>
</table>

**VLAN**

To configure a VLAN hardware filter:

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Enter a Filter Name.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>From the Type drop-down menu, choose VLAN.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Choose either the Range or Individuals radio button. For Range, enter a range of VLANs. For Individuals, enter up to four individual VLANs.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Click Submit.</td>
</tr>
</tbody>
</table>

**VLAN and IP**

To configure a VLAN and IP hardware filter:

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Enter a Filter Name.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>From the Type drop-down menu, choose VLAN and IP.</td>
</tr>
</tbody>
</table>
Step 3: Enter the ID of the desired VLAN. The VLAN ID can range from 1-4095.

Step 4: Enter a Source Address / Mask (optional).

Step 5: Enter a Destination Address / Mask (optional).

Step 6: Choose a Layer 4 Protocol (optional).

Step 7: Click Submit.

---

IP

To configure an IP hardware filter:

Step 1: Enter a Filter Name.

Step 2: From the Type drop-down menu, choose IP.

Step 3: Enter a Source Address / Mask (optional).

Step 4: Enter a Destination Address / Mask (optional).

Step 5: Choose a Layer 4 IP Protocol (optional).

Step 6: Click Submit.

---

IP and TCP/UDP

To configure an IP and TCP/UDP hardware filter:

Step 1: Enter a Filter Name.

Step 2: From the Type drop-down menu, choose IP and TCP/UDP

Step 3: Enter a Source Address / Mask (optional).

Step 4: Enter a Destination Address / Mask (optional).

Step 5: Choose an IP Protocol, either TCP or UDP.

Step 6: Enter a TCP/UDP Source Port (optional).

Step 7: Enter a TCP/UDP Destination Port (optional).

Step 8: Click Submit.

---

IP and Payload Data

To configure an IP and Payload Data hardware filter:

Step 1: Enter a Filter Name.

Step 2: From the Type drop-down menu, choose IP and Payload Data.

Step 3: Enter a Source Address / Mask (optional).

Step 4: Enter a Destination Address / Mask (optional).

Step 5: Choose an IP Protocol, either TCP or UDP.

Step 6: Enter the values for Payload Data:
Working with Capture Files

To decode, download, rename, convert/merge, delete, analyze, or error-scan saved packet capture files use the Files option.

This section covers the following topics:

- Understanding Capture Sessions, page 5-17
- Analyzing Capture Files, page 5-18
- Downloading Capture Files, page 5-19
- Deleting a Capture File, page 5-19

payload data

To configure a Payload Data hardware filter:

Step 1 Enter a Filter Name.
Step 2 From the Type drop-down menu, choose Payload Data.
Step 3 Choose an IP Protocol, either TCP or UDP.
Step 4 Enter the values for Payload Data:
  - Enter an Offset from 1-1023. The offset is relative to the beginning of the payload (Layer 5).
  - Enter a Value of up to four bytes (eight hex characters).
  - Enter a Mask of up to four bytes (eight hex characters).
Step 5 Repeat Step 4 for up to four payload data segments.

Note Only one payload segment (one row) is required. Be careful not to create overlapping payload segments. If overlapping segments have different values the filter will never match anything due to the inherent AND logic.

Step 6 Click Submit.

Chapter 5  Capturing and Decoding Packets

Step 7 Repeat Step 6 for up to four payload data segments.

Note Only one payload segment (one row) is required. Be careful not to create overlapping payload segments. If overlapping segments have different values the filter will never match anything due to the inherent AND logic.

Step 8 Click Submit.
Understanding Capture Sessions

To understand how Prime NAM creates capture files with saved packet data, it is important to learn about how NAM handles capture sessions triggers. If there are existing capture sessions already running on the same storage target, this means there is a conflicting alarm trigger. An alarm trigger is created when you configure an alarm threshold to start collecting packet data. Each alarm has a severity option.

Packet capture sessions can be triggered on the Prime NAM in several ways:

- Manually, by starting a capture using the Capture menu option or clicking the Start capture button.
- Scheduled, by specifying a start date/time and maximum duration when you create or edit a capture session.
- Alarmed, by creating an alarm with an associated trigger capture action that starts a particular capture session.

Prime NAM supports multiple capture sessions associated with the same capture storage location, but only one of these sessions can be running at any given time. Since there are several ways for such capture session to be started, it is possible for conflicts to arise among such capture sessions.

For example, suppose one capture session is started manually, but another capture session is scheduled to begin capturing while the first is still running. If these two sessions capture to the same storage location, there is a conflict. In this case, Prime NAM resolves the conflict by automatically stopping the manual session and allowing the scheduled session to begin.

In general, NAM resolves capture session conflicts by prioritizing them in the following (descending) order:

1. High-severity alarm triggered capture
2. Low-severity alarm triggered capture
3. Scheduled capture
4. Manual capture

For example, if a manually started capture session is saving data to the local disk and a scheduled capture is set to begin capturing to the same local disk, Prime NAM stops the manual session before the scheduled session begins.

For an overview of tasks you can complete in the Capture Files Operations window, see Table 5-2.

For information about how to save capture sessions to files, see Creating and Managing Capture Sessions, page 5-3. You can download files in either .enc or .pcap file formats. For information about setting the download file format, see Resetting System Preferences, page 6-11.

⚠️ Caution

If you have capture files with a state of Full and the NAM is rebooted, the capture is triggered again and these files may be overwritten by the new capture. If you want to retain the file, save the file before you reboot.
Chapter 5  Capturing and Decoding Packets

Table 5-2  Actions You Can Complete in the Capture Files Operations Window

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decode</td>
<td>Display the packets in a file.</td>
</tr>
<tr>
<td>Download</td>
<td>Download a file to your computer in .enc or .pcap file format (based on your settings in Administration &gt; System &gt; Preferences).</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>Do not add a file suffix when you provide the filename. The suffix .pcap is added automatically.</td>
</tr>
<tr>
<td>Rename</td>
<td>Give the file a new name. A dialog box displays and asks you to enter the new name for the selected capture file.</td>
</tr>
<tr>
<td>Merge</td>
<td>Merges capture files that were captured simultaneously in chronological order.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>Merged files cannot exceed the supported maximum file size for the NAM platform. For 32-bit NAM and those categorized as low-end performance platforms (NAM-1X/-2X, Nexus 1000V, SM-SRE, and vNAM) the maximum file size is recommended at 500 MB. For all other platforms it is 2,000 MB.</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete selected capture files.</td>
</tr>
<tr>
<td>Analyze</td>
<td>View statistical analysis of the selected capture. See Analyzing Capture Files, page 5-18.</td>
</tr>
<tr>
<td>Errors Scan</td>
<td>View more information about the file (Packed ID, Protocol, Severity, Group, and Description). From here you can also decode the packet. For more information see Drilling Down into Packet Error Details, page 5-19.</td>
</tr>
</tbody>
</table>

Note: Capture files on the Cisco NAM 2200 appliances are stored in native NAM format. You can convert the capture file format to .pcap using the Rename/Merge button on the Capture > Packet Capture/Decode > Files window. Other NAMs use .pcap by default. With .pcap files, you can download to .enc when you have the appropriate download format option selected in Administration > System > Preferences.

Analyzing Capture Files

The Capture Files window (available at Capture > Packet Capture/Decode > Files) enables you to obtain various statistics including traffic rate (bytes/second) over a capture period and lists of hosts and protocols associated with network traffic.

This window also enables you to drill-down for a more detailed look at a particular set of network traffic. The pane above the Traffic over Time graph displays the time shown in the graph in the From: and To: fields. It also provides fields for Protocol and Host/subnet, and a Drill-Down button.

Note: After clicking the Drill-Down button, the Host Statistics results table will display both source and destination hosts, if either the source or destination host of the traffic belongs to the Host/Subnet that you had specified.

Each slice in the Traffic over Time graph displays the amount of traffic for the amount of time set in the Granularity of the capture file.
You can view more detail about a specific time frame by entering the time in the From and To fields and choosing Drill-Down. You can also drill-down on a specific Protocol or Host/subnet address. Table B-46 describes the different areas of the Capture Analysis window.

Drilling Down into Packet Error Details

You can further investigate, or drill down, into packet error details by viewing the decode packet data available on Prime NAM.

The Capture Errors and Warnings Information window shows warnings and errors, and packet irregularities. From here, you can launch the Packet Decode Window, where you can drill-down to packet details.

To get to the Capture Errors and Warnings Information window, choose Capture > Packet Capture/Decode > Files. Highlight a file and click the Errors Scan button. The Error Scan window displays. The fields are described in Table B-51. Then select the packet details by selecting a row and clicking the Decode Packets button.

Downloading Capture Files

You can only download one capture file at a time. To download a capture file to your computer:

2. Choose a capture file from the list of captures.
3. Click Download.
   A File Download dialog box displays and asks “Do you want to save this file?”
4. Click Save.
   A Save As dialog box opens and provides a way for you to rename and save the file at a location of your choice.

Deleting a Capture File

To delete a capture file:

2. Check the check box to select a capture file from the list of captures, or select more than one if desired.
3. Click Delete. A dialog box displays and asks “Delete the following file(s)?” and displays the file name.
4. Click OK to delete the file(s) or Cancel to allow the file(s) to remain.
Utilizing Capture Data Storage

The Cisco Prime Network Analysis Module (NAM) on all platforms offer external storage connectivity for extended capture durations and higher capture bandwidths. All platforms support iSCSI data storage. This section covers:

- Capturing to Data Storage, page 5-20
- Recovering Data Storage, page 5-22

Figure 5-4  External Storage Setup

For instructions on installing and configuring external storage, see your platform-specific guides on Cisco.com or related documentation in the Cisco NAM Documentation Overview.

Capturing to Data Storage

To avoid filling up the local server disk on the NAM, you can capture files to external storage. One of the benefits of using external storage is that it can provide larger capacities, higher read/write speeds, and can be moved from one Cisco NAM to another. The capture files are decoded in the same manner as the Capture > Packet Capture/Decode > Files page.

Using Prime NAM, you can perform internal and external storage management using Capture > Packet Capture/Decode > Data Storage. This window lists detected storage devices, including the internal hard drive, if one is available.

This release supports 32 external data storage targets (Logical Unit Numbers or LUNs combined).
You can create multiple capture sessions per target. Only one capture per storage target (file location) is allowed at a time. Additionally you can have multiple sessions to memory.

This topic covers:

- Preparing LUNs for File Storage, page 5-21
- Using LUNs to Store a Capture Session, page 5-21
- Logging In and Out of External Storage LUNs, page 5-22
- Connecting and Disconnecting External Storage, page 5-22

**Preparing LUNs for File Storage**

Some arrays come with multiple storage controller modules, and the module ownership must often be mapped to each LUN (Logical Unit Numbers). This is a common security feature.

To see if the NAM can access the storage array LUNs and prepare them to store files:

---

**Step 1** Choose Capture > Packet Capture/Decode > Data Storage.

New LUNs which have not been used by the NAM show a status of Unformatted.

**Step 2** To prepare these LUNs for capture use, select the LUN and click **Format**. After a few minutes, the status should change to **Ready**.

**Step 3** To apply optional user labels to the LUNs to help differentiate between them, select the LUN and click **Label**.

The Label dialog appears with information about the current label and the last time the LUN was formatted.

---

**Using LUNs to Store a Capture Session**

To use a LUN for a capture session:

---

**Step 1** Go to Capture > Packet Capture/Decode > Sessions.

**Step 2** Under the Capture Sessions table, click **Create**.

**Step 3** Fill in the appropriate fields for creating a session, and for Storage Type choose the **Files** option.

**Step 4** Use the File Location table to select the LUN you wish to use. Each list entry includes the protocol and either the model or the user label if it is set. Note that the list will only include targets which are in the Ready state.

**Step 5** Click **Submit** to create the session, or **Cancel** to return to the previous window.

---

When a session is **STARTED**, the associated LUN state changes to In Use. At that point, no other session can use that LUN until the session is deleted. This prevents contention, corrupted data, and write bandwidth degradation.
Logging In and Out of External Storage LUNs

You can use iSCSI to facilitate data transfers over intranets and to manage your remote capture data storage.

Prime NAM provides a more streamlined workflow to log in and out of your data storage targets. You must log into iSCSI in order to save capture sessions to remote storage. If you do not log in, capture sessions are saved to either local disk or memory locations.

To log in or out of your available remote data storage LUNs:

Step 1  Ensure you have configured your target iSCSI system with read/write permission to your NAM for at least one LUN in the storage array. For details, see Capturing to Data Storage, page 5-20.

Step 2  Choose Capture > Packet Capture/Decode > Data Storage and click iSCSI Login.

Step 3  To enable auto discovery of any iSCSI Qualified Name (IQN) target, enter the target IP address of the storage location and click Search IQN Targets.

All available IQNs for that location display in the table.

Step 4  To log out, click iSCSI Logout. The list of IQNs to which you are currently logged into displays in a table.

Step 5  To view the LUNs which the system will log you out, select one of the IQNs and a popup displays the associated LUNs to select.

Connecting and Disconnecting External Storage

Before physically disconnecting an external storage device, it is highly recommended to use the Unmount button on the Capture > Packet Capture/Decode > Storage window. This notifies the Cisco NAM that the device will be disconnected, so that the Prime NAM can perform important cleanup procedures. After this is done, the storage target displays as Unmounted in the status column, and it is safe to remove the external storage device. External storage is automatically unmouted in this manner when the Cisco NAM is powered down.

Caution  If this step is skipped, it is possible to corrupt the storage data upon physical disconnect.

If a device has been logically disconnected using the Unmount button, but the storage is still physically connected, it can be reactivated using the Mount button. It will restore the storage target’s previous state. This makes it unnecessary to physically disconnect and reconnect the storage, which can be particularly useful if the storage is located far away from you.

Recovering Data Storage

In the event that a previously working target displays as Unformatted, you can use the CLI to determine what happened by running a filesystem check on it. Use the command remote-storage <protocol> fsck <storage ID>, when you know the protocol. You can find the storage ID using remote-storage <protocol> list. The filesystem check can potentially resolve filesystem corruption or state issues. If the command succeeds, it automatically mounts the storage and displays as Ready.
The following shows a iSCSI recovery example:

```
root@nam.cisco.com# remote-storage iscsi list
Storage ID: 16
  Label:  
  Status: Unformatted
  Protocol: ISCSI
  Target IP: 172.20.10.81
  Target IQN: iqn.2011-09:celeros.target11
  Model: IET VIRTUAL-DISK
  LUN: 4
  Capacity: 24.98GB
  Available: 24.98GB

Storage ID: 15
  Label: target 16
  Status: In Use
  Protocol: ISCSI
  Target IP: 172.20.10.81
  Target IQN: iqn.2011-09:celeros.target16
  Model: IET VIRTUAL-DISK
  LUN: 5
  Capacity: 24.98GB
  Available: 16.47GB

Active iSCSI Sessions:
```

```
root@nam.cisco.com# remote-storage iscsi fsck 16
FS check completed successfully.
```

```
root@nam.cisco.com# remote-storage iscsi list
Storage ID: 16
  Label:  
  Status: Ready
  Protocol: ISCSI
  Target IP: 172.20.10.81
  Target IQN: iqn.2011-09:celeros.target11
  Model: IET VIRTUAL-DISK
  LUN: 4
  Capacity: 24.98GB
  Available: 9.87GB

Storage ID: 15
  Label: target 16
  Status: In Use
  Protocol: ISCSI
  Target IP: 172.20.10.81
  Target IQN: iqn.2011-09:celeros.target16
  Model: IET VIRTUAL-DISK
  LUN: 5
  Capacity: 24.98GB
  Available: 16.47GB
```

```
Active iSCSI Sessions:
```
Inspecting Packet Decode Information for Suspicious Traffic

After you have captured some traffic data packets, you can use the Packet Decoder to view the packet contents and inspect for suspicious traffic.

This section includes the following tasks:

- Browsing Packets in the Packet Decoder, page 5-24
- Filtering Packets Displayed in the Packet Decoder, page 5-24
- Viewing Detailed Protocol Decode Information, page 5-25
- Understanding the Packet Decoder, page 5-26

Browsing Packets in the Packet Decoder

You can use the packet browser to browse the list of captured packets and do the following:

- Filter by Display Filter dialog box or quick filter.
- Show the number of packets over time. This is known as Packet Histogram. Provides visual of packet capture flow and enables you to navigate through the packet list. You can apply a filter to display only the distribution of the packets that match your filter.
- Change the layout preferences for the decoder panes.
- Enable or disable the color of a specific protocol to allow you to visually track more easily.
- Change the font size for the hex data pane. Hover over the top-right corner of the pane to see options.
- Display the current range of packets in the packet list using the Packet Range button.
- Save filters for future use. You can also edit or remove existing filters as needed.

Note

To use these decode features, you must be capturing to memory with the no rotate option selected. Otherwise, captures must be paused or stopped.

To inspect packet decode information for suspicious traffic:

Step 1

Choose Capture > Packet Capture/Decode > Sessions, or Capture > Packet Capture/Decode > Files (depending on which type you would like to decode).

Step 2

Choose a capture session or file, and then click the Decode button. The Packet Decoder window displays. See Table B-53 for table descriptions.

Filtering Packets Displayed in the Packet Decoder

To filter packets displayed in the packet decoder:

Step 1

From the Packet Decoder window, click the Display Filter button. The Packet Decoder - Display Filter Window displays.
Step 2 Do the following:

- Choose a Filter Mode:
  - Inclusive displays packets that match the condition(s.)
  - Exclusive displays packets that do not match the condition(s).

- Choose an Address Filter:
  - IP address filters on IP address.
  - MAC Address filter on MAC address.
  - Source allows you to specify the source address, or leave it blank if not applicable.
  - Destination allows you to specify the destination address, or leave it blank if not applicable.
  - Both Directions allows you to match of packets travelling in both directions.

- Define a Protocol Filter.
  - Click Match any to display packets that match any of the protocols or fields or
  - Click Match all to display packets that match all of the protocols or fields.
  - Choose a protocol from the Protocols list.

  Note You can enter the first few letters of the protocol name to go directly to the protocol. If you make a typo, press ESC or SPACE to reset.

  - Choose a protocol field from the Fields list, then specify the field value if applicable.

Step 3 To add more protocol filters, click + sign.
Step 4 To delete a defined Protocol Filter, click - sign.
Step 5 Click OK to apply the filter and close the window or Apply to apply the filter and keep the window open.

**Viewing Detailed Protocol Decode Information**

To view detailed protocol information:

Step 1 Highlight the packet number about which you want more information.

Detailed information about that packet is displayed in the Protocol Decode and hexadecimal dump panes at the bottom of the window.

Note If you highlight the details in the Protocol Decode pane, the corresponding bytes are highlighted in the hexadecimal dump pane below it.

Step 2 To review the information, use the scrolling bar in the lower panes.
When you decode SCCP traffic, Prime NAM lists the protocol as skinny, not SCCP.

Tip
- Protocols are color coded both in the Packet Browser and the Protocol Decode pane.
- Choose the protocol name in the Protocol Decode pane to collapse and expand protocol information.
- To adjust the size of any of the panes, click and drag the pane frame up or down.

Understanding the Packet Decoder

The NAM packet decoder, also known as the NAM Packet Analyzer, uses two levels of packet analysis: basic and full. Because preparing a large capture file for full analysis can take a long time, NAM automatically chooses which level to use based on your filtering complexity. This allows you to browse your captured packet data more quickly without having to wait for analysis.

When you select a capture file to analyze for the first time, NAM limits some of the more complex display filters you can use. For example, you can filter using protocol identifiers such as tcp, udp, sdp, and sip which allow the packet decode to display more quickly than an advanced filtering selection.

If you enter more advanced filters (such as those with and/or logic operators on the protocol field), NAM automatically begins the full analysis of the capture file and then applies your complex filter to display the results. For example, if you filter using ‘ip.src==192.168.1.1 && tcp.dstport==80’, the NAM Packet Analyzer starts the full analysis and displays it only after the results have been filtered.

For details on the packet decoder window, see Understanding the Packet Decoder Window and Browser Pane, page 5-26.

Understanding the Packet Decoder Window and Browser Pane

The Packet Decoder window shows three views of a packet:
- a summary line briefly describes the packet type
- the protocol field of interest can be shown and analyzed in the portion of the window directly below the summary line
- a hexadecimal dump shows exactly what the packet looks like when it goes across the wire.

There are many unique features in the NAM Packet Analyzer decode window; for example, it can assemble all the packets in a TCP conversation and highlight the ASCII data in that conversation. You can use the expanded display filter functionality to allow you to view more focused data.

Figure 5-5 is an example of the NAM Packet Analyzer window. Table B-53 describes the packet decoder operations on the NAM - Packet Decoder window.
You can use the Capture Decode features to do the following:

- **Show Packet histogram**—show the number of packets over time. This provides a feel of the packet flow for the capture. You can use the histogram selector control to navigate through the packet list as well. You can apply a display filter to make the histogram show the distribution of the packets that match the applied filter. Can set time range and move across histogram. Firefox is faster than IE performance with this feature.

- **Toggles to Show Packet Paging Controls**—display the buffer divided into pages.

- **Toggle layout**—change how the three content panes in the decoder are arranged.

- **Hex data font size**—display two buttons when you hover over the top right corner of the hex data content pane of the decoder. You can increase or decrease the font size of the contents.

- **Packet range button**—show the current range of packets in the packet list and you can enter the range of packets to view.

- **Display Filter button** is the same as the Display Filter menu—display Saved Display Filters and Manage Display Filters windows.

- **Protocol coloring**—allows you to use coloring. You cannot map custom colors in this release.

- **Tools menu**—options have limited support. Options include:
  - **TCP Checksum Validation** check box—filter on TCP in the decode window and use the TCP pane to verify that the checksum has been validated.
  - **UDP Checksum Validations** check box—filter on UDP in the decode window and use the UDP pane to verify that the checksum has been validated.
  - **IP Host Name Resolution**—perform global host name resolution for NAM. Synchronizes with the Administration preferences.
Inspecting Packet Decode Information for Suspicious Traffic

- Display Filter input field—allow manual entry of display filters.

Table B-53 describes the columns displayed in the packet browser pane.

Using Alarm-Triggered Captures

You can configure multiple alarm-triggered captures that start and stop automatically by alarm events you define. To set up an alarm-triggered capture:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Create an alarm event from the Setup &gt; Alarms &gt; Alarm Events window. Configure an Alarm Event for the type of event for which you want to capture data. See Configuring Alarm Actions, page 3-37, for more information.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Set a threshold for the event from the Setup &gt; Alarms &gt; Alarm Thresholds window. Configure the threshold of parameters of interest in the associated Alarm Event. See Defining Thresholds, page 3-39, for more information.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Set up a capture session from the Capture &gt; Packet Capture/Decode &gt; Sessions window. Click Create. Choose the Start Event and/or the Stop Event for the associated Alarm Event. See Configuring Capture Sessions, page 5-5, for more information.</td>
</tr>
</tbody>
</table>

Using Time-Based Captures

You can configure multiple time-based triggered captures that start and stop automatically based on a certain time or period of time that you define. The following is an example of setting a 60 minute window to capture packet data.

To set up an time-based triggered capture:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Create a new capture from the Capture &gt; Packet Capture/Decode &gt; Sessions window.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Check the Auto Capture Enable check box.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Set the Start Date and Time and Duration (in minutes) to 60.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Select an appropriate storage type to store your capture data. For example, select capture to memory HDD.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Select appropriate software filters.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Click Submit.</td>
</tr>
<tr>
<td>Step 7</td>
<td>To start the capture session, return to the Capture &gt; Packet Capture/Decode &gt; Sessions menu and select the capture session you previously created and click Start.</td>
</tr>
</tbody>
</table>

Customizing Display Filters

Use custom display filters to create and save customized filters to use in the NAM Packet Analyzer decode window to limit which packets are displayed.
NAM supports most software display filters with the following exceptions:

- Filters using Perl Regular Expressions. For example:
  
  \texttt{http.request.uri matches \textquoteleft gl=se\textquoteright\textquoteright}

- Filters on a protocol payload (a protocol section in a packet). For example:
  
  \texttt{udp[8:3]==81:60:03}

See these topics for help setting up and managing custom display filters:

- Creating Custom Display Filters, page 5-29
- Editing Custom Display Filters, page 5-31
- Deleting Custom Display Filters, page 5-31

### Creating Custom Display Filters

To create custom display filters:

**Step 1** Choose \texttt{Capture > Packet Capture/Decode > Sessions.}

The Hardware Filters box is displayed at the bottom of the page.

**Step 2** Click \texttt{Create}. The Custom Decode Filter Dialog Box displays. See Table B-49.

**Step 3** Enter information in each of the fields as appropriate.

**Step 4** Do one of the following:

- To create the filter, click \texttt{Submit}.
- To cancel filter creation, click \texttt{Cancel}.

### Tips for Creating Custom Decode Filter Expressions

You can construct custom decode filter expressions using the following logical and comparison operators listed in \textit{Table 5-3}.

\textbf{Table 5-3 Logical and Comparison Operators}

<table>
<thead>
<tr>
<th>Operator</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>and</td>
<td>Logical AND</td>
</tr>
<tr>
<td>or</td>
<td>Logical OR</td>
</tr>
<tr>
<td>xor</td>
<td>Logical XOR</td>
</tr>
<tr>
<td>not</td>
<td>Logical NOT</td>
</tr>
<tr>
<td>==</td>
<td>Equal</td>
</tr>
<tr>
<td>!=</td>
<td>Not equal</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
</tr>
</tbody>
</table>

To group subexpressions within parentheses, use the fields in Table B-50 to help you add filter expressions.
Examples of Custom Decode Filter Expressions

Table 5-4 provides some examples of basic NAM display filters you can use to filter on application types.

<table>
<thead>
<tr>
<th>Filter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>tcp</td>
<td>Find all TCP-based applications</td>
</tr>
<tr>
<td>udp</td>
<td>Find all UDP-based applications</td>
</tr>
<tr>
<td>! eth</td>
<td>Find all packets other than Ethernet</td>
</tr>
<tr>
<td>tcp and not vlan</td>
<td>Find all TCP traffic NOT running over vlan</td>
</tr>
<tr>
<td>http</td>
<td>Find all src/dst HTTP application packets (may be not standard port 80 if different application 'decode as' port specified; e.g. 'tcp.port==8080,http')</td>
</tr>
<tr>
<td>ftp</td>
<td></td>
</tr>
<tr>
<td>not tcp</td>
<td>Exclude all TCP packets</td>
</tr>
<tr>
<td>! tcp</td>
<td>Exclude all TCP packets</td>
</tr>
<tr>
<td>! (ftp</td>
<td></td>
</tr>
</tbody>
</table>

Table 5-5 provides some examples of complex NAM display filters.

<table>
<thead>
<tr>
<th>Filter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>tcp.port eq 80</td>
<td>Find all src/dst HTTP packets on standard HTTP port 80</td>
</tr>
<tr>
<td>ip.addr == 192.168.1.0/24</td>
<td>Find all packets in Class C network (subnet)</td>
</tr>
<tr>
<td>tcp.flags.reset == 1</td>
<td>Find all TCP resets</td>
</tr>
<tr>
<td>tcp.window_size == 0 &amp;&amp; tcp.flags.reset != 1</td>
<td>Src is instructing dst to stop sending data (TCP buffer full)</td>
</tr>
<tr>
<td>Ipv6.addr == ::1</td>
<td>Correct statement with IPv6 label and IPv6 address.</td>
</tr>
</tbody>
</table>

Table 5-6 provides some examples of protocol field hexbyte filters.

<table>
<thead>
<tr>
<th>Filter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>eth.src==00:3c:06:0a:02:68</td>
<td>Find source MAC</td>
</tr>
<tr>
<td>eth.dst==00:3c:06:0a:02:68</td>
<td>Find destination MAC</td>
</tr>
<tr>
<td>eth.addr==00:3c:06:0a:02:68</td>
<td>Find source or dest MAC</td>
</tr>
<tr>
<td>! (eth.addr==00:3c:06:0a:02:68)</td>
<td>Find all MAC except specific address</td>
</tr>
<tr>
<td>eth.addr contains 00:3c</td>
<td>Find bytes in any protocol field subrange</td>
</tr>
</tbody>
</table>

Table 5-6 provides some examples of protocol field hexbyte subrange filters.
Table 5-7  Protocol Field Hexbyte Subrange Filters

<table>
<thead>
<tr>
<th>Filter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>eth.addr[0:2]==00:3c</td>
<td>Find specific subrange in MAC</td>
</tr>
<tr>
<td>eth.addr[1:3]==3c:06:0a</td>
<td>Find specific subrange in MAC</td>
</tr>
</tbody>
</table>

Table 5-6 provides some examples of hexbyte data representations syntax.

Table 5-8  Hexbyte Data Representations (Syntax)

<table>
<thead>
<tr>
<th>Filter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>eth.dst == ff:ff:ff:ff:ff:ff</td>
<td>Hexbyte separators can be colons</td>
</tr>
<tr>
<td>eth.dst == ff-ff-ff-ff-ff-ff</td>
<td>Hexbyte separators can be dashes</td>
</tr>
<tr>
<td>eth.dst == ffff.ffff.ffff</td>
<td>Hexbyte separators can be dots (one or two bytes)</td>
</tr>
</tbody>
</table>

Note: You can use a filter expression with other fields in the Custom Decode Filter dialog box. In this case, the filter expression is ANDed with other conditions. Invalid or conflicting filter expressions result in no packet match.

Editing Custom Display Filters

To edit custom display filters:

Step 1 Choose Capture > Packet Capture/Decode > Display Filters.
Step 2 Choose the filter to edit, then click Edit.
Step 3 Change the information in each of the fields as appropriate.
Step 4 Do one of the following:
   • To apply the changes, click Submit.
   • To clear the page of your changes, click Reset.
   • To exit the page without applying the changes, click Cancel.

Deleting Custom Display Filters

To delete custom display filters:

Step 1 Choose Capture > Packet Capture/Decode > Display Filters.
Step 2 Choose the filter to delete, then click Delete.
Step 3 In the confirmation dialog box, do one of the following:
   • To delete the filter, click OK.
To cancel, click Cancel.
Performing User and System Administration

This chapter provides information about what user and system administration tasks are required or optional, how to generate diagnostic information when requesting technical assistance, and provide user access.

This chapter contains the following topics:

- Managing System Data, page 6-1
- Performing System Administration, page 6-2
- Troubleshooting Using Diagnostics Tools, page 6-12
- Controlling User Access, page 6-14

Managing System Data

One of the roles of an administrator is to manage Prime NAM’s network data collection and retention so that it:

- Scales to fit the real needs of the system’s users.
- Minimizes the burden on monitored devices, applications, and network bandwidth.
- Survives hardware failures.

The following sections explain how to achieve these goals, and how to perform other data management tasks.

- Handling Backups, page 6-1
- Shrinking Storage Requirements, page 6-1

Handling Backups

It is critical to have your system backed up so that you can restore your configuration and data if required. Ensure you have sufficient data backups scheduled.

Shrinking Storage Requirements

Network administrators are consistently looking for ways to shrink their network storage requirements and improve bandwidth efficiency on tasks like backup and recovery.
By configuring Prime NAM packet deduplication on supported platforms, packets whose inspected segments match another packet within the specific time window are marked as duplicates and not forwarded.

For configuration guidelines and instructions, see Configuring Hardware Deduplication, page 3-36.

You can also move capture files to an external storage location to save on local disk space. See Capturing to Data Storage, page 5-20.

Performing System Administration

You can perform the following system administration tasks:

- Setting Network Parameters, page 6-4
- Setting the SNMP Agent, page 6-4
- Synchronizing Your System Time, page 6-6
- Setting Up E-Mail Notifications for Alarms, page 6-9
- Sharing NAM Data by Enabling Web Data Publication, page 6-10
- Setting Remote Servers to Receive Syslog Messages, page 6-10
- Configuring Hosts to Receive SNMP Traps from Prime NAM, page 6-11
- Resetting System Preferences, page 6-11

Monitoring Prime NAM Health and Traffic Statistics

Ensuring that your Cisco NAM processes your traffic efficiently and effectively without becoming overloaded is a critical task.

To view the network traffic coming into the Cisco NAM as well as data about its health (such as server network details and CPU, memory, and data usage) use Administration > System > Overview.

Use the data provided in the Inputs and Resources tabs to determine scalability issues and to assist with troubleshooting.

Table 6-1 describes the types of information of the System Overview window.
### Table 6-1 System Overview

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Inputs Tab</strong></td>
<td></td>
</tr>
<tr>
<td>Cumulative Input</td>
<td>Health and usage information on all the traffic received by the NAM. It shows the number of packets received (Rx Packets), number of packets lost or dropped (Rx Packets Lost), and number of bytes received (Rx Bytes). The Cumulative column shows cumulative counts since the start of the NAM, and the Rate column one shows the same counters for the last ten seconds.</td>
</tr>
<tr>
<td>Input Traffic</td>
<td>Usage information in bytes and packets based on the input you select. You can toggle between a chart or table format. Data is updated every 30 seconds and contains data from the past hour. The table time interval cannot be changed. The input table rate is calculated every 10 seconds. A table legend provides data for standard statistics provided by the software for data collected over a period of time. Note: In order to view PA traffic on this page, you must configure your device to use port 3000 to send PA traffic to the NAM. To reset the traffic counters, click on <strong>Reset Traffic</strong> at the bottom of Input Traffic chart.</td>
</tr>
<tr>
<td><strong>Resources Tab</strong></td>
<td></td>
</tr>
<tr>
<td>Date</td>
<td>Current date and time synchronized with the switch, router, or NTP server.</td>
</tr>
<tr>
<td>Host Name</td>
<td>NAM host name.</td>
</tr>
<tr>
<td>IPv4 Address</td>
<td>Based on your configuration, IPv4 address and/or IPv6 address displays.</td>
</tr>
<tr>
<td>IPv6 Address</td>
<td></td>
</tr>
<tr>
<td>System Uptime</td>
<td>Length of time the host has been running uninterrupted.</td>
</tr>
<tr>
<td>Disk Usage</td>
<td>Config, data, and root partitions with their total and free space. Also shows the amount of disk space used by the performance data base files (DB) and the packet capture to disk (capture files). Use this information to ensure you have enough disk space and perform the needed maintenance as necessary.</td>
</tr>
<tr>
<td>Utilization</td>
<td>Percentage of memory resources being consumed by the NAM as well as the total memory available.</td>
</tr>
<tr>
<td>CPU Usage</td>
<td>Percentage of CPU resources being consumed by the NAM. Each individual CPU in a multi-CPU platform is listed separately.</td>
</tr>
</tbody>
</table>
Setting Network Parameters

To view and set network parameters such as your site’s name servers:

Step 1  Choose **Administration > System > Network Parameters**.

The Network Parameters window displays.

Step 2  Enter or change the information.

Step 3  Do one of the following:

- To save the changes, click **Submit**.
- To cancel the changes, click **Reset**.

Setting the SNMP Agent

An SNMP Agent is a network management software module that resides in a managed device. It has local knowledge of management information and translates that information into a form compatible with SNMP.

You can manage devices with SNMPv3 in addition to SNMPv2 and SNMPv1. The NAM polls the managed device to get its basic health and interface statistics. For NAM blades, the managed device is the switch in which the NAM is inserted, and the NAM software negotiates with the switch to use SNMP and a community string to do the polling. This community string is only valid for use with the NAM. For security purposes, the switch associates the community string with the NAM’s IP address only, and no other SNMP application can use this community string to communicate with the switch. For more information about community strings, see **Working with NAM Community Strings, page 6-5**.

Also, to further alleviate any security concerns, the SNMP exchanges between NAM blades and the switch take place on an internal backplane bus. These SNMP packets are not visible on any network, nor any interface outside of the switch. It is a completely secure out-of-band channel inside the switch.

For other platforms, such as Cisco NAM appliances, you can type in any IP address and use it as the managed device. In setting managed devices, virtual NAM platforms managed devices function just like the NAM appliances. On all platforms, NAM can only monitor and display data for one managed device at a time.

In this case, the managed device may only want to use SNMPv3 since it is more secure.

**Note**

NAM blades use SNMPv2 to manage the locally managed device.

To view and set the NAM SNMP Agent:

Step 1  Choose **Administration > System > SNMP Agent**.

Step 2  Enter or change the information in the NAM SNMP window. The fields are detailed in **Table 6-2**.
Step 3 To create community strings, see Creating NAM Community Strings, page 6-5.

Step 4 To delete community strings, select the entry and click **Delete**.

Step 5 Do one of the following:
- To save the changes, click **Submit**.
- To cancel the changes, click **Reset**.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contact</td>
<td>The name of the person responsible for the NAM.</td>
</tr>
<tr>
<td>Name</td>
<td>The name of the NAM.</td>
</tr>
<tr>
<td>Location</td>
<td>(Optional) The physical location of the switch or router in which the NAM is installed.</td>
</tr>
</tbody>
</table>

**Working with NAM Community Strings**

You use community strings so that other applications can send SNMP get and set requests to the NAM, set up collections, poll data, and so on.

**Creating NAM Community Strings**

To create the NAM community strings:

**Step 1** Choose **Administration > System > SNMP Agent**.
At the bottom of the window, the **NAM Community Strings Dialog Box** displays.

**Step 2** Click **Create**.
The **SNMP Agent Dialog Box** displays.

**Step 3** Enter the community string (use a meaningful name).

**Step 4** Enter the community string again in the Verify Community field.

**Step 5** Assign read-only or read-write permissions using the following criteria:
- Read-only allows only read access to SNMP MIB variables (get).
- Read-write allows full read and write access to SNMP MIB variables (get and set).

**Step 6** Do one of the following:
- To make the changes, click **Submit**.
- To reset, click **Reset**.
- To cancel and return to the previous window, click **Cancel**.
Deleting NAM Community Strings

To delete the NAM community strings:

Step 1  Choose Administration > System > SNMP Agent.
At the bottom of the window, the NAM Community Strings Dialog Box displays.
Step 2  Select an entry, then click Delete.

⚠️ Caution
Deleting the NAM community strings blocks SNMP requests to the NAM from outside SNMP agents.

The community string is deleted.

Testing the Router Community Strings

Before the router can send information to the NAM using SNMP, the router community strings set in the NAM must match the community strings set on the actual router. The Router Parameters dialog box displays the router name, hardware, Supervisor engine software version, system uptime, location, and contact information.

The local router IP address and the SNMP community string must be configured so that the NAM can communicate with the local router.

To set the community strings on the router, use the router CLI. For information on using the CLI, see the documentation that accompanied your device.

⚠️ Caution
The router community string you enter must match the read-write community strings on the router. Otherwise you cannot communicate with the router.

To test router community strings:

Step 1  Choose Setup > Managed Device > Device Information.
The Device Information dialog box displays.
Step 2  Enter the Device’s Community String.
Step 3  Click Test Connectivity.
Step 4  Wait for a while for NAM to communicate with the Device. If it comes back OK, then click on Submit.

Synchronizing Your System Time

Ensure that the Prime NAM software application’s Linux system time is synchronized with the packet timestamp and the standard time source outside of the NAM platform. Packet timing analysis uses system time to support application response time measurements, voice and video quality metrics, packet decode data, reporting, and many other network statistics.
The NAM gets the UTC (GMT) time from several sources, depending on its NAM platform type. All NAMs can be set up to get their time from an external NTP server. Other NAM platforms may prefer to use an IEEE 1588 Precision Time Protocol (PTP)-based time master due to its high accuracy and precision.

You should also configure any PTP switches that are between the NAM and the master clock to use Edge-to-Edge (E2E) mode. E2E is preferred because it reduces PTP messaging bandwidth and eliminates delay accumulation when daisy chaining many nodes. If the master clock and/or PTP switches are not configured correctly, all of the clocks on the NAM will be synced with each other, but to the wrong time.

**Caution**

Both the client computer and the NAM server must have the time set accurately for their respective time zones. If either the client or the server time is incorrect, then the data shown in the GUI is incorrect.

The clock identity is the first three octets of the MAC address, followed by “ff:fe,” and then the last three octets of the MAC address, as shown in the example below.

```
0xec:44:76:ff:fe:5d:12:0
```

After the NAM acquires the time, you can set the local time zone using the NAM System Time configuration window.

For details on how to configure the NAM system time for your specific hardware platform, see **Synchronizing NAM System Time for Specific Platforms, page 6-7**.

**Synchronizing NAM System Time for Specific Platforms**

Ensure that the NAM system time is configured correctly. If the system time is incorrect, NAM data presentation may be inaccurate due to time ranges, hence providing incorrect interpretations of NAM data.

Some platforms are synchronized automatically, but client browsers need to be synchronized in addition to the NAM and the router or switch in order for the data to be accurate. We recommend you perform the time synchronization for your platform.

You can configure the NAM system time by using one of the following methods:

- **Synchronizing the NAM System Time with the Switch or Router, page 6-8**
  This option is valid only for NAM-1X, NAM-2X, NAM-3, SM-SREs, and NAM-NX1.

- **Synchronizing the NAM System Time Locally, page 6-8**
  This option is valid for Cisco NAM appliances, Nexus 1000 VSB, and vNAM.

- **Configuring the NAM System Time with an NTP Server, page 6-8**
  This is valid for all platforms and is the recommended option.

- **Configuring the NAM System Time with Precision Time Protocol (IEEE 1588), page 6-9**
  This option is valid for NAM-3 and NAM-NX1.
Synchronizing the NAM System Time with the Switch or Router

Note

This section is valid only for NAM-1X, NAM-2X, NAM-3, SM-SREs, and NAM-NX1. For additional platform options, see Synchronizing NAM System Time for Specific Platforms, page 6-7.

To configure the NAM system time from the switch or router:

Step 1 Choose Administration > System > System Time.
Step 2 Choose the Switch or NTP Server radio button.
Step 3 Select the Region and local time zone from the lists.
Step 4 Do one of the following:
   • To save the changes click Submit.
   • To leave the configuration unchanged, click Reset.

Synchronizing the NAM System Time Locally

Note

This section is valid for Cisco NAM appliances, Nexus 1000V, and vNAM. For additional platform options, see Synchronizing NAM System Time for Specific Platforms, page 6-7.

To configure the NAM system time locally using the NAM command line:

Step 1 Log into the NAM command line interface.
Step 2 Set the clock using the CLI clock set command.
   
   \texttt{clock set <hh:mm:ss:> <mm/dd/yyyy>}
   
Step 3 On the Prime NAM GUI, choose Administration > System > System Time.
Step 4 Click the Local radio button.
Step 5 Select the Region and local time zone from the lists.
Step 6 Do one of the following:
   • To save the changes click Submit.
   • To leave the configuration unchanged, choose Reset.

Configuring the NAM System Time with an NTP Server

To configure the NAM system time with an NTP server:

Step 1 On the NAM appliance GUI, choose Administration > System > System Time.
Step 2 Choose the NTP Server radio button.
Step 3 Enter one or two NTP server names or IP address in the NTP server name/IP Address text boxes.
Performing System Administration

Step 4
Select the Region and local time zone from the lists.

Step 5
To save the changes, click Submit.

Configuring the NAM System Time with Precision Time Protocol (IEEE 1588)

To use Precision Time Protocol (PTP), you will need a PTP-aware or multicast-enabled switch connected to the sync port on the front of the NAM-3, as well as a PTP master connected to the switch.

Note
This section is applicable to the NAM-3 and NAM-NX1. For details on any hardware setup requirements related to this feature, see your specific NAM installation guide. For additional platform options, see Synchronizing NAM System Time for Specific Platforms, page 6-7.

To configure the NAM system time using PTP:

Step 1
On the NAM, choose Administration > System > System Time.

Step 2
Choose the PTP radio button.

Step 3
Enter the IP address of the PTP interface in the PTP Interface IP Address field.

Tip
Set the PTP interface IP address so that it is not in the same subnet as the management interface. If they are in the same subnet, there may be routing issues for outbound management traffic (http, for example).

Step 4
Enter the subnet mask in the PTP Interface Subnet Mask field.

Step 5
For NAM Local Time Zone, select the Region and the Zone from the drop-down lists.

Step 6
To save the changes, click Submit.

Setting Up E-Mail Notifications for Alarms

You can configure Prime NAM to provide e-mail notification of alarms and to e-mail reports.

To set up e-mail notifications:

Step 1
Choose Administration > System > E-Mail Setting.

Step 2
Check the Enable Mail check box and enter the required or optional field information.

Table 6-3 describes the Mail Configuration Options.

Step 3
Check the optional Advanced Settings check box and enter the details in the fields provided.

Step 4
Click Submit to save your modifications, or click Reset to clear the dialog of any characters you entered or restore the previous settings.
Performing System Administration

Chapter 6          Performing User and System Administration

Table 6-3          Mail Configuration Options

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Mail</td>
<td>Enables e-mail of reports and notification of alarms</td>
</tr>
<tr>
<td>External Mail Server</td>
<td>Distinguished name of external mail server</td>
</tr>
</tbody>
</table>
| Send Test Mail to            | Optional. List e-mail addresses for up to three e-mail recipients.
| Mail Alarm to                | This recipient will receive alarm notifications and scheduled exports.
| Advanced Settings            | Enables you to designate an e-mail access server port, as well as select a encryption protocol. |
| Mail Server Port            | Optional. Designate an e-mail port for the NAM.                   |
| Mail Server Encryption       | Optional. Select Secure Sockets Layer (SSL) or Transport Layer Security (TLS) encryption for e-mail messaging. |

Sharing NAM Data by Enabling Web Data Publication

Web Data Publication allows general web users and websites to access (or link to) selected NAM monitor and report windows without a login session.

Web Data Publication can be open or restricted using Access Control List (ACL) and/or publication code. The publication code, if required, must be present in the URL address or cookie to enable access to published data.

To enable Web Data Publishing:

Step 1 Choose Administration > System > Web Data Publication.

Step 2 Check the Enable Web Data Publication check box.

Step 3 Enter a Publication Code (Optional). This is the pass code required in a URL’s cookie to access the published page. For example, a publication code set to abc123 would be able to access the following published window:

http://<nam-hostname>/application-analysis/index?publicationcode=abc123

Step 4 Enter an ACL Permit IP Address/Subnets to permit only those IP addresses or subnets access to web publications. No entry provides open access to all.

Step 5 Click Submit to enable web publishing, or click Reset to clear the dialog of any characters you entered.

Note Before the new iSCSI storage entry takes effect, you must reboot the NAM system.

Setting Remote Servers to Receive Syslog Messages

NAM syslogs are created for alarm threshold events, voice threshold events, or system alerts. You can specify whether syslog messages should be logged locally on the NAM, on a remote host, or both. You can use the NAM to view the local NAM syslogs.
If logging on a remote host, in most Unix-based systems, the syslog collector that handles the incoming syslog messages uses the facility field to determine what file to write the message to, and it will use a facility called `local7`. Check the syslog collector configuration to ensure that `local7` is handled properly.

To set up the NAM syslog:

---

**Step 1** Choose Administration > System > Syslog Setting.

The NAM Syslog Setting window displays.

**Step 2** In the Remote Server Names field, enter the IP address or DNS name of up to five remote systems where syslog messages are logged. Each address you enter receives syslog messages from all three alarms (Alarm Thresholds, Voice Signaling Thresholds, and System).

**Step 3** Click **Submit** to save your changes, or click **Reset** to cancel.

---

### Configuring Hosts to Receive SNMP Traps from Prime NAM

Traps are used to store alarms triggered by threshold crossing events. When an alarm is triggered, you can trap the event and send it to a separate host. Trap-directed notifications can result in substantial savings of network and agent resources by eliminating the need for frivolous SNMP requests.

To configure, edit, or delete a host destination to which Prime NAM will send traps:

---

**Step 1** Choose Administration > System > SNMP Trap Setting.

The SNMP Trap Setting window displays.

**Step 2** Click the **Create** button.

**Step 3** In the “Community” field, enter the community string set in the NAM Thresholds.

**Step 4** In the “IP Address” field, enter the IP address to which the trap is sent if the alarm and trap community strings match.

**Step 5** In the “UDP Port” field, enter the UDP port number.

**Step 6** Click **Submit** to save your changes, or click **Reset** to cancel and leave the configuration unchanged.

---

### Resetting System Preferences

To change the Prime NAM display or logging characteristics, choose Administration > System > Preferences. Table 6-4 describes the fields of the Preferences window.

<table>
<thead>
<tr>
<th><strong>Field</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Refresh Interval (60-3600 sec)</td>
<td>Amount of time between refresh of information on dashboards.</td>
</tr>
<tr>
<td>Top N Entries (1-10)</td>
<td>Number of colored bars on the Top N charts.</td>
</tr>
</tbody>
</table>
Troubleshooting Using Diagnostics Tools

The Diagnostics option of the Administration menu provides tools to aid in troubleshooting. You can use these tools when you have a problem that might require assistance from the Cisco Technical Assistance Center (TAC). There are options for:

- System Alerts, page 6-12
- Audit Trail, page 6-12
- Tech Support, page 6-13

For additional information on troubleshooting NAM, see Troubleshooting Network and NAM Issues.

### System Alerts

You can view any failures or problems that the NAM has detected during normal operations. To view System Alerts, choose Administration > Diagnostics > System Alerts.

Each alert includes a date, the time the alert occurred, and a message describing the alert. The NAM displays up to one thousand (1,000) of the most-recent alerts. If more than 1,000 alerts have occurred, you need to use the NAM CLI command `show tech-support` to see all of the alerts.

If you notice an alert condition and troubleshoot and attempt to solve the condition causing the alert, you might want to click **Clear** to remove the list of alerts to see if additional alerts occur.

### Audit Trail

The Audit Trail option displays a listing of recent critical activities that have been recorded in an internal syslog log file. Syslog messages can also be sent to an external log.

The following user activities are logged in the audit trail:

- All CLI commands
- User logins (including failed attempts)
- Unauthorized access attempts
- SPAN changes
Troubleshooting Using Diagnostics Tools

- NetFlow data source changes
- Enabling and disabling data collections
- Starting and stopping captures
- Adding and deleting users

Each log entry will contain the following:
- User ID
- Time stamp
- IP address (in case of remote web access)
- Activity description

To access the audit trail window:

**Step 1** Choose **Administration > Diagnostics > Audit Trail.**

The Audit Trail Window displays.

The Audit Trail window provides a way to view the user access log and filter entries based on time, user, (IP address) from or activity. The internal log files are rotated after reaching certain size limits.

---

**Tech Support**

The NAM syslog records NAM system alerts that contain event descriptions and date and time stamps, indicating unexpected or potentially noteworthy conditions. This feature generates a potentially extensive display of the results of various internal system troubleshooting commands and system logs. For a list of user activities logged in the audit trail window, see **Audit Trail, page 6-12.**

This information is unlikely to be meaningful to the average user. It is intended to be used by the Cisco TAC for debugging purposes. You are not expected to understand this information; instead, you should save the information and attach it to an e-mail message to the Cisco TAC.

Before you can view the Tech-Support page, you must enable the System Config user privilege on the **Administration > Users > Local Database** page. For more information on editing user privileges, see **Establishing TACACS+ Authentication and Authorization, page 6-17.**

**Note** You can also view this information from the NAM CLI. For information on using the NAM CLI, see **Cisco Network Analysis Module Command Reference.**

To view tech support:

**Step 1** Choose **Administration > Diagnostics > Tech Support.**

After a few minutes, extensive diagnostic information is generated and displayed in the Diagnostics Tech Support Window.

**Step 2** To save the information, either select **File>Save As...** from the browser menu, or scroll to the bottom, click on **NAM-logs.tar.bz2**, and save it to your local PC.
Downloading Core Files

To download core files from the Tech-Support page, scroll down to the Core Files section and click on the filename and follow the instructions.

Controlling User Access

You can control your user’s access using the Administration options:

- Local Database, page 6-14
- Establishing TACACS+ Authentication and Authorization, page 6-17
- Configuring a TACACS+ Server to Support NAM Authentication and Authorization, page 6-18
- Current User Sessions, page 6-22

Local Database

When you first install the NAM, use the NAM command-line interface (CLI) to enable the HTTP server and establish a username and password to access the NAM for the first time.

After setting up the initial user accounts (root, admin, and webuser), you can create additional accounts, enabling or disabling different levels of access independently for each user.

Table 6-7 provides information about User Privileges and describes each privilege.

For additional information about creating and editing users, see Creating a New User, page 6-15 and Establishing TACACS+ Authentication and Authorization, page 6-17.

If you have forgotten your password, use the helper utility to reset your root or user passwords (see Resetting Passwords, page 6-14).

Resetting Passwords

There are several methods you can use to reset your NAM passwords. Use the options documented in Table 6-5 based on your needs.

Table 6-5 Password Reset Options

<table>
<thead>
<tr>
<th>NAM User</th>
<th>Method</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Root, Admin, and webuser</td>
<td>Boot into helper utility</td>
<td>Restart your NAM and choose option 5 or enter reboot -helper at the NAM CLI.</td>
</tr>
<tr>
<td>Root and webuser</td>
<td>clear system-passwords NAM CLI command</td>
<td>The easiest way to reset NAM passwords. This command resets both the root and guest user passwords to the factory default state. You must have appropriate privileges to reset passwords.</td>
</tr>
<tr>
<td>Root, Admin, and webuser</td>
<td>CLI commands on the switch or router</td>
<td>See your platform installation guide.</td>
</tr>
</tbody>
</table>
Controlling User Access

Changing Predefined NAM User Accounts on the Switch or Router

The predefined root and guest NAM user accounts (accessible through either a switch or router session command or a Telnet login to the NAM CLI) are static and independent of the NAM. You cannot change these static accounts nor can you add other CLI-based users with the NAM.

Creating a New User

To create a new user:

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Choose Administration &gt; Users &gt; Local Database. The GUI displays the users in the local database. Checks indicate the privileges each user has for the functions listed.</td>
</tr>
<tr>
<td>2</td>
<td>Click Create. The GUI displays the New User Dialog Box.</td>
</tr>
<tr>
<td>3</td>
<td>Enter the information required to create new user and select each privilege to grant to the user. See Table 6-7 for an explanation of user privileges. Table 6-6 describes the fields in the New User Dialog Box.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The account name</td>
<td>Enter the user’s account name.</td>
</tr>
<tr>
<td>Password</td>
<td>The account password</td>
<td>Enter a password that adheres to your site security policies.</td>
</tr>
<tr>
<td>Verify Password</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Privileges</td>
<td>Privileges associated with this account</td>
<td>Select each privilege to grant to the user.</td>
</tr>
</tbody>
</table>

Note: If you delete user accounts while users are logged in, they remain logged in and retain their privileges. The session remains in effect until they log out. Deleting an account or changing permissions in mid-session affects only future sessions. To force off a user who is logged in, restart the NAM.

<table>
<thead>
<tr>
<th>Step 4</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>Select a single or multiple check box to set user privileges. Table 6-7 provides information about each privilege.</td>
</tr>
</tbody>
</table>
Table 6-7  User Privileges

<table>
<thead>
<tr>
<th>Privilege</th>
<th>Access Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>AccountMgmt</td>
<td>Enables a user to create, delete, and edit user accounts.</td>
</tr>
<tr>
<td>SystemConfig</td>
<td>Enables a user to edit basic NAM system parameters such as IP address,</td>
</tr>
<tr>
<td></td>
<td>gateway, HTTP port, and so on.</td>
</tr>
<tr>
<td>Capture</td>
<td>Enables a user to perform packet captures and manage capture sessions and</td>
</tr>
<tr>
<td></td>
<td>use the NAM protocol decode.</td>
</tr>
<tr>
<td>AlarmConfig</td>
<td>Enables a user to create, delete, and edit alarms on the switch/router and</td>
</tr>
<tr>
<td></td>
<td>NAM.</td>
</tr>
<tr>
<td>MonitorConfig</td>
<td>Enables a user to create, delete, and edit the following:</td>
</tr>
<tr>
<td></td>
<td>• Collections and reports</td>
</tr>
<tr>
<td></td>
<td>• Protocol directory entries</td>
</tr>
<tr>
<td></td>
<td>• Protocol groups</td>
</tr>
<tr>
<td></td>
<td>• URL-based applications</td>
</tr>
<tr>
<td>MonitorView</td>
<td>Enables a user to view monitoring data and reports (granted to all users).</td>
</tr>
</tbody>
</table>

Step 5  Click Submit to create the user or Reset to clear the dialog of any characters you entered.

Invalid User Name and Password Characters

For usernames, do not use the following:

- Exclamation point !
- At sign @
- Pound sign #
- Dollar sign $
- Percent %
- Carot ^
- Ampersand &
- Asterisk *
- Left or right parentheses ( )
- Greater than <
- Less than >
- Comma ,
- Period .
- Double quote “
- Single quote ’
- Forward slash /
- Backward slash \
For web user passwords, do not use the following:
- Double quote "
- Single quote ’
- Greater than <
- Less than <

For root or guest user passwords, only the single quote is not allowed.

Establishing TACACS+ Authentication and Authorization

Terminal Access Controller Access Control System (TACACS) is an authentication protocol that provides remote access authentication, authorization, and related services such as event logging. With TACACS, user passwords and privileges are administered in a central database instead of an individual switch or router to provide scalability.

TACACS+ is a Cisco Systems enhancement that provides additional support for authentication and authorization.

When a user logs into the NAM, TACACS+ determines if the username and password are valid and what the access privileges are.

To establish TACACS+ authentication and authorization:

**Step 1** Choose Administration > Users > TACACS+. The TACACS+ Authentication and Authorization Dialog Box displays.

**Step 2** Enter or select the appropriate information in the TACACS+ Authentication and Authorization Dialog Box (Table 6-8).

<table>
<thead>
<tr>
<th>Table 6-8 TACACS+ Authentication and Authorization Dialog Box</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Field</strong></td>
</tr>
<tr>
<td>Enable TACACS+ Authentication and Authorization</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Primary TACACS+ Server</td>
</tr>
<tr>
<td>Backup TACACS+ Server</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Secret Key</td>
</tr>
<tr>
<td>Verify Secret Key</td>
</tr>
</tbody>
</table>
Controlling User Access

Step 3

Do one of the following:

- To save the changes, click **Submit**.
- To cancel, click **Reset**.

Tip

If you cannot log into the NAM with TACACS+ configured, verify that you entered the correct TACACS+ server name and secret key.

Configuring a TACACS+ Server to Support NAM Authentication and Authorization

In addition to enabling the TACACS+ option, you must configure your TACACS+ server so that it can authenticate and authorize NAM users. NAM supports ACS versions 5.2, 5.1 (including Patch 1), and 4.2.

Note

Configuration methods vary depending on the type of TACACS+ server you use. When configuring NAM within ACS 5.x, deselect the check box for the Single Connect Device option under the TACACS+ settings.

Continue to the section specific to your particular version:

- Configuring a Cisco ACS Server, Version 4.2
- Configuring a Cisco ACS Server, Version 5.x
- Configuring a Generic TACACS+ Server

Configuring a Cisco ACS Server, Version 4.2

To configure a version 4.2 Cisco ACS server, you must perform two tasks:

- Add a NAM user or user group. See **Adding a NAM User or User Group for Version 4.2**, page 6-19.

Configuring NAM on ACS for Windows NT and 2000 Systems for Version 4.2

To configure a Cisco ACS TACACS+ server (version 4.2):

Step 1 Log into the ACS server.
Step 2 Click **Network Configuration**.
Step 3 Click **Add Entry**.
Step 4 For the Network Access Server, enter the NAM hostname and IP address.
Step 5 Enter the secret key.
Chapter 6      Performing User and System Administration

Contains User Access

Note The secret key must be the same as the one configured on the NAM.

Step 6 In the Authenticate Using field, select TACACS+.
Step 7 Click Submit+Apply.
Step 8 Continue to Adding a NAM User or User Group for Version 4.2 to complete the next configuration task.

Adding a NAM User or User Group for Version 4.2

To add a NAM user or user group:

Step 1 Click User Setup.
Step 2 Enter the user login name.
Step 3 Click Add/Edit.
Step 4 Enter the user data.
Step 5 Enter a user password.
Step 6 If necessary, assign a user group.
Step 7 In the TACACS+ settings:
   a. Select Shell.
   b. Select IOS Command.
   c. Select Permit.
   d. Select Command.
   e. Enter web.
   f. In the Arguments field, enter:
      
      
      permit capture
      permit system
      permit collection
      permit account
      permit alarm
      permit view

Step 8 In Unlisted Arguments, select Deny.
Step 9 Click Submit.

Configuring a Cisco ACS Server, Version 5.x

To configure a version 5.1 (Patch 1) or 5.2 Cisco ACS server, you must perform these tasks. There is an additional configuration task that enables you to set up policy rules for your users or groups.

Use the following sections to configure your Cisco ACS server:
Controlling User Access

- Add a NAM user or user group. See Adding a NAM User or User Group for Version 5.x, page 6-20.

Configuring NAM on ACS For Windows NT and 2000 Systems for Version 5.x

To configure a Cisco ACS TACACS+ server (version 5.1(P1) or 5.2):

**Step 1** Log into the ACS server.

**Step 2** To set up an optional device type for NAM, click Network Resources > Network Device Groups > Device Type and create a device type. For example, you may choose to name your device type NAM_Module.

**Step 3** Click Network Resources > Network Devices and AAA Clients to add NAM devices.

**Step 4** For the Network Access Server, enter the NAM hostname and IP address.

**Step 5** Under Authentication Options field, select TACACS+.

**Step 6** Enter the secret key and deselect the check box for the Single Connect Device option under the TACACS+ settings.

**Note** The secret key must be the same as the one configured on the NAM.

**Step 7** Click Submit.

**Step 8** Continue to Adding a NAM User or User Group for Version 5.x, page 6-20 to complete the next configuration task.

Adding a NAM User or User Group for Version 5.x

To add a NAM user or user group:

**Step 1** Click Users and Identity Stores > Internal Identity Stores > Users.

**Step 2** Click Create.

**Step 3** Enter the user login name.

**Step 4** Enter the user data.

**Step 5** If necessary, assign a user group.

**Step 6** Enter the password information.

**Step 7** Click Submit.

Configuring Access Policies for ACS and NAM for Version 5.x

In versions 5.1(P1), 5.2, and 5.3 you must set up access policies to complete your ACS and NAM configuration.
Step 1 On the ACS server, click Policy Elements > Authorization and Permissions > Device Administration > Command Sets and click Create to create NAM command sets.

For example, if you want to provide full access to the NAM, create a command set called NAMfullAccess and check the check box Permit any command that is not in the table below.

Step 2 Click Submit when you have completed entering the NAM command sets. Ensure you include all of the following commands:

```text
permit capture
permit system
permit collection
permit account
permit alarm
permit view
```

Step 3 Click Access Policies > Access Services > Create to create a new Service (for example, name = namAdmin; Service Type = Device Administration.)

Step 4 Go to Access Policies > Access Services > namAdmin > Authorization > Customize to set up customized conditions which are needed in later step. For example, you may choose: NDG: Device Type, Device IP Address, and so on). Replace namAdmin with the service you created in this step.

Step 5 Go to Access Policies > Access Services > namAdmin > Authorization > Create to set up the condition to qualify all login requests. NAM devices use these conditions and follow the command set (created in Step 1). For example, your condition may be == NDG: Device Type is All Device Types: NAM device which you set up in Step 2.

Step 6 Click Access Policies > Service Selection Rules to choose a service (for example, the service you created in Step 3).

Step 7 Log into the NAM and click NAM > Administration > Users > TACACS+ to set up the ACS server IP and secret key.

---

**Configuring a Generic TACACS+ Server**

To configure a generic TACACS+ server:

Step 1 Specify the NAM IP address as a Remote Access Server.

Step 2 Configure a secret key for the TACACS+ server to communicate with the NAM.

**Note** The secret key must be the same as the one configured on the NAM.
Step 3  
For each user or group to be allowed access to the NAM, configure the following TACACS+ parameters:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Enter</th>
</tr>
</thead>
<tbody>
<tr>
<td>service</td>
<td>shell</td>
</tr>
<tr>
<td>cmd</td>
<td>web</td>
</tr>
<tr>
<td>cmd-arg</td>
<td>One or more the following: accountmgmt, system, capture, alarm, collection, view</td>
</tr>
<tr>
<td>password authentication method—Password Authentication Protocol (PAP)</td>
<td>pap</td>
</tr>
</tbody>
</table>

Current User Sessions

The Current User Sessions table is a record of the users who are logged into the application. The user session times out after 30 minutes of inactivity. After a user session times out, that row is removed from the table.

To view the current user sessions table:

Step 1  
Choose Administration > Users > Current Users.

The Current User Sessions Table (Table 6-9) displays.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User ID</td>
<td>The user ID used to log into the NAM.</td>
</tr>
<tr>
<td>From</td>
<td>The name of the machine the user logged in from.</td>
</tr>
<tr>
<td>Login Time</td>
<td>The time the user logged in.</td>
</tr>
<tr>
<td>Last Activity</td>
<td>The time stamp of the last user activity.</td>
</tr>
</tbody>
</table>
NAM Deployment

This describes some usage cases on how to deploy NAM in your networks. It contains details on network performance management as well as usage scenarios for the Cisco Prime Network Analysis Module Software.

To view which release versions run on the supported NAM platforms, see the NAM Compatibility Matrix. The use cases focus on a specific need to be addressed or a problem to be solved. Each scenario takes into account the deployment considerations discussed in Overview and then uses one or more of NAM’s features to meet the need or solve the problem. The goal of these use cases is to provide real-world examples. These examples discuss best practices and approaches to effective NAM deployment and are grouped into several categories.

This contains the following sections:

- Deploying in the Data Center
- Deploying in a Campus Environment
- Deploying in the Branch
- General Usage Scenarios
- NAM Integrations with Monitoring and Reporting Applications

Note: Some of the graphics represented in this section may be different than what you see on the screen. These illustrations are for examples only.

Deploying in the Data Center

- Monitoring the Nexus 1000V Switch Environment, page 7-20
- Real-Time Traffic Monitoring and Analysis, page 7-11
- Using NAM to Evaluate Application-Level Performance Monitoring for TCP-Interactive Applications, page 7-20
- Using NAM to Evaluate Application-Level Performance Monitoring for UDP Real-Time Applications, page 7-20
- Using NAM to Monitor QoS/DiffServ (DSCP), page 7-13
- Monitoring Cisco WAAS and Measuring Its Impact, page 7-7
Deploying in a Campus Environment

- Real-Time Traffic Monitoring and Analysis, page 7-11
- Using NAM to Evaluate Application-Level Performance Monitoring for TCP-Interactive Applications, page 7-20
- Using NAM to Evaluate Application-Level Performance Monitoring for UDP Real-Time Applications, page 7-20
- Using NAM to Monitor QoS/DiffServ (DSCP), page 7-13
- Using NAMs to Monitor VoIP Quality, page 7-3

Deploying in the Branch

- Visibility in the Branch, page 7-6
- Real-Time Traffic Monitoring and Analysis, page 7-11
- Using NAM to Evaluate Application-Level Performance Monitoring for TCP-Interactive Applications, page 7-20
- Using NAM to Evaluate Application-Level Performance Monitoring for UDP Real-Time Applications, page 7-20
- Using NAM to Monitor QoS/DiffServ (DSCP), page 7-13
- Monitoring Cisco WAAS and Measuring Its Impact, page 7-7
- Using NAMs to Monitor VoIP Quality, page 7-3

General Usage Scenarios

These use cases are applicable to any part of the network:

- Using NAM for Historical Trends via Interactive Report, page 7-17
- Using NAM for Problem Isolation, page 7-22
- Creating Custom Applications, page 7-5
- Autodiscovery Capabilities of NAM, page 7-4
- Using NAM for SmartGrid Visibility, page 7-23

NAM Integrations with Monitoring and Reporting Applications

- Integrating NAM with LMS, page 7-6
- Integrating NAM with Third Party Reporting Tools, page 7-5

Deployment Examples

- Using NAMs to Monitor VoIP Quality, page 7-3
- Autodiscovery Capabilities of NAM, page 7-4
Using NAMs to Monitor VoIP Quality

Voice quality analysis has been significantly enhanced in Cisco NAM. The software is now capable of accurately measuring voice quality by using the industry-standard MOS algorithm. Call quality measurements are computed every 1 minute and made available through the GUI. Note that the voice-related screens on the NAM GUI are significantly different from previous releases. Changes have been made to provide useful information quickly and automatically, while allowing easy navigation to details.

Deployment: NAM deployments for voice quality analysis require that NAM be able to monitor VoIP packets from the calling phone to the called phone. The branch edge location in the network provides visibility into all calls entering and leaving the branch; similarly a campus edge location monitors calls crossing the campus boundary. Often, the distribution layer is a good location to deploy NAMs for this purpose, especially if specific phones or particular portions of the network are to be monitored. For example, a new Multiprotocol Label Switching (MPLS) link is being piloted and three buildings that are part of Company X's headquarters are part of the pilot. In order to monitor voice quality for those three buildings, a NAM could be deployed at the distribution Catalyst 6500 that serves those users.

Note
The data center is typically not an appropriate location for RTP stream analysis because calls will seldom go through the data center. However, the data center is a good location to monitor signaling messages between phones and Cisco Unified Communications Manager. NAM decodes signaling messages to track call history, caller names, phone numbers, and other relevant call details.

Use the following steps to monitor the network to make sure that call quality is good. If quality issues appear, isolate and troubleshoot the problem rapidly.

Step 1
View RTP Streams using the menu selection Analyze > Media. This chart indicates current voice quality of all RTP streams being monitored. MOS values range from 1 to 5, where 1 is poor and 5 is excellent (see the legend for a breakdown into categories-Poor, Fair, Good and Excellent). The figure below displays the Top N RTP Source and Destination endpoints. Notice that there are calls that are in the poor range.

Step 2
To isolate calls that had a poor MOS, scroll down to Top N RTP Streams and click on the chart to drill down into the RTP Stream Details. As shown in Figure 7-1, notice that the MOS value for the calls listed on top is 2.88, which is low. Further, looking at the other metrics provided in the same row (for example, row one), notice that jitter is 3.49 and the packet loss rate is 11 percent, resulting in the low MOS value. This information tells you that jitter is the root cause of the poor calls; instead, it is packet loss somewhere in the network.
Step 3  With the endpoints’ IP addresses, you can look at the network topology to identify where in the network the 50.5.10.38 subnet is located. For the purposes of this use case, this subnet is in Building 3 of the main campus. You know that the Building 3 distribution switch has a NAM located in it.

Navigate to that NAM and go to the menu selection Analyze > Managed Device > Interface. This page lists all interfaces and errors or discards on each interface. Look up the link that leaves Building 3 and connects to the core. That interface is likely the source of the packet loss. Check the interface for faults and fix as needed.


Autodiscovery Capabilities of NAM

If you are an existing NAM 4.x or NAM 6 user, you will not need to configure the SPAN sessions, and they will be automatically created on the NAM (not on the device). If you are a new NAM 5.x user, you will need to configure SPAN or NetFlow.

SPAN or NetFlow must be already configured on the device to forward traffic to NAM for auto creating the data source. See Setting Up Prime NAM Data Sources, page 3-8.
Creating Custom Applications

NAM identifies applications/protocols based on the TCP/UDP port number, so if there are applications using custom ports, the NAM can be configured to identify those applications by name instead of the port.


Integrating NAM with Prime Infrastructure

Cisco Prime supports integrated lifecycle management of networks, services, and endpoints for Cisco borderless network, data center, and collaboration architectures with end-to-end assurance. You can use Cisco Prime Infrastructure to centrally manage the Cisco Prime NAM platforms such as the NAM appliance to track inventory, view configurations, and perform image and fault management. Prime Infrastructure also rolls up the performance intelligence from NAMs deployed across the network into a consolidated dashboard.

The following overview describes the steps to complete in Prime Infrastructure to set up NAM to view multiple NAMs on your dashboard. For details steps, see the Prime Infrastructure User Guide on Cisco.com.

**Step 1**
Add the NAM HTTPS credentials from the Prime Infrastructure’s Device Work Center Edit Device window so that Prime Infrastructure can retrieve data from them. You must add them only after the discovery process is complete or the modules have been added to the Prime Infrastructure inventory.

If you have licensed Assurance features, most Assurance features depend on NAM data to work so this is a required step.

You can repeat this task for all NAMs from which you want Prime Infrastructure to collect data.

**Step 2**
To ensure that you can collect data from your Network Analysis Modules (NAMs) using Prime Assurance, you must enable NAM data collection and configure your NetFlow-enabled switches, routers, and other devices (ISR/ASR) to export this data to Prime Infrastructure. You can do this for each discovered or added NAM, or for all NAMs at the same time.

**Step 3**
To manage and troubleshoot a network problem such as a suspected network attack, you can use multiple NAMs to create packet captures, save them as files, and then decode them to inspect the suspicious traffic.

For other troubleshooting tips on how to use NAM with Prime Infrastructure, see the Prime Infrastructure User Guide. For application developers who want to use the NAM REST API to connect with Prime NAM, ask your Cisco representative about using the Cisco Prime Network Analysis Module REST API.

Integrating NAM with Third Party Reporting Tools

Prime NAM integrates with the CA NetQoS SuperAgent for the purpose of aggregating Application Response Times. Prime NAM also integrates with CompuWare Vantage and InfoVista 5View for Host, Conversation, RTP, and Response Time.
Ask your Cisco representative about the Prime NAM API Programmer’s Guide to find out more about the NAM Northbound Interface, also referred to as the REST API (Application Programming Interface). The API enables you to provision Prime NAM and extract performance data.

You can write your own scripts based on the Prime NAM Northbound API, but you must perform some setup in the GUI.

For details on what data can be collected, see Using Response Time Summary.

Integrating NAM with LMS

The NAM GUI can be placed on the LMS (LAN Management Suite) 4.0 dashboard and accessed through the LMS GUI. See technical documentation for LMS on http://www.cisco.com.

Currently, this functionality includes:

- NAM discovery as part of the network topology that LMS builds
- NAM alarms persistent in LMS
- Ease of software updates to multiple NAMs via LMS
- Portal Integration to bring in NAM GUI inside of LMS

You can also check out supported devices for LMS to see what features of FCAPS are covered by what type of NAM:


Visibility in the Branch

There are three options for providing visibility in the branch:

1. A purpose-built SM-SRE that works in Cisco Integrated Service Router
2. NAM as an application, running in SM-SRE-7xx or SM-SRE-9xx for Cisco Integrated Service Router Generation 2 (ISR G2) deployment
3. Using Performance Agent (PA), a Cisco IOS feature available on ISR G2 that encapsulates traffic statistics as well as application response statistics. Underlying Netflow v9 can be exported to a central NAM in a Data Center (DC) or Campus. PA complements WAAS Express (another IOS feature) and when used together, delivers end-to-end visibility before and after WAN Optimization using only one traffic source, as compared to two traffic sources NetFlow and WAAS Flow Agent from the traditional WAAS deployment in the branch. See the scenario Monitoring Cisco WAAS and Measuring Its Impact, page 7-7.

The first two options are similar and provide visibility for the local branch as well as branch to branch and the ability to capture all traffic going in and out of the branch.

Ideal deployment for these branch NAM modules would be a small number of remote sites or an empowered branch. The third option provides visibility only for the local branch and is more scalable than deploying NAM modules in multiple remote locations e.g. 100’s/1000’s remote sites. Based on network monitoring and troubleshooting requirements, a hybrid option can be considered such as deploying NAM modules and PA in empowered branches and PA in smaller branches. In this model, a central NAM in the DC can provide end to end visibility from DC to branch and offers the ability to capture branch to branch traffic on super branches (empowered branch).
For further details on installing NAM on SM-SRE, see the Installation Guides on Cisco.com. For further details on configuring PA, see “Setting Up Cisco Prime NAM”. For further details about the release, see the Cisco Prime Network Analysis Module Release Notes.

Monitoring Cisco WAAS and Measuring Its Impact

Cisco Wide Area Application Services (WAAS) is a comprehensive WAN optimization solution that accelerates applications over the WAN, delivers video to the branch office, and provides local hosting of branch-office IT services. Cisco WAAS allows IT departments to centralize applications and storage in the data center while maintaining LAN-like application performance and provides locally hosted IT services while reducing the branch-office device footprint.

One of the challenges facing IT personnel who deploy WAAS is to measure and report on the benefits provided by their WAN optimization deployment. Accurate measurement provides many benefits: IT can show return on investment; IT can assess whether the improvement gained meets originally advertised expectations from the solution; and finally, IT can use WAAS ongoing for monitoring, troubleshooting, and planning information for expanding the deployment.

The NAM can monitor WAAS-optimized flows by using WAE devices or Performance Agent (PA) as data sources. Using this capability, the NAM is able to provide visibility into optimization-related metrics for the three distinct segments that are created by WAAS: the branch, the WAN, and the data center segments.

Placing a Cisco NAM appliance or NAM-2X blade at the edge of the data center is recommended for WAAS deployments. From this location in the network, the NAM can measure local metrics using SPAN technology, and for information on the remote branch segment, it relies on flow agent exports from the remote WAE device, or PA with WAAS Express from an ISR G2 branch router. If SM-SREs are available, deploying one at the remote branch site is very useful. This SM-SRE can provide user experience at the site before WAAS is enabled and then contrast it to user experience after WAAS is enabled. See Figure 7-2.
To deploy this solution:

**Step 1** Using a NAM 2x20 deployed at the data center, measure application response time before WAAS is enabled using Analyze > WAN Optimization > Top Talker Detail. The Top Talker display includes such data as utilization, concurrent connections, and average transaction time for top applications, network links, clients, and servers that are possible candidates for optimization.

**Step 2** Create a WAAS Client Side and WAAS Server Side for the WAAS flows from the DC and Branch WAEs.

**Step 3** The NAM provides an interactive dashboard to view the analyzed data. Figure 7-3 displays Client Transaction Time, Traffic Volume and Compression Ratio, Number of Concurrent Connections (Optimized vs. Passthru), and Multi-Segment Network Time (Client LAN - WAN - Server LAN). As you can see in the first graph, all non-optimized traffic is displayed as Passthru.
Figure 7-3  Application Performance Analysis -- Optimized

The screen shot above illustrates the significant improvement experienced by users in the branch when WAAS is turned on. Such reports are very useful to justify an investment in WAN optimization technologies and to show returns on those investments in terms of increase in employee productivity and improved user experience from remote sites.
Step 4

From the perspective of the NAM located in the data center, there are two sources of information for response time measurements. SPAN provides measurement at the data center and exports from the branch; WAAS flow or PA provides measurements from the branch. Using these two sources of information, the NAM at the data center can continuously monitor current response times for each branch and help IT personnel keep user experience within known bounds. When abnormal response times are detected, the NAM can be configured to send alerts to appropriate personnel with information relevant to troubleshooting the problem.

Note

The NAM 2x20 in the above scenario can be substituted with the NAM Virtual Blade on the WAVE-574 and WAE-674 to obtain the same type of reports.

Monitoring

- Real-Time Traffic Monitoring and Analysis, page 7-11
- Using NAM to Monitor QoS/DiffServ (DSCP), page 7-13
- Using NAM for Historical Trends via Interactive Report, page 7-17
• Using NAM to Evaluate Application-Level Performance Monitoring for TCP-Interactive Applications, page 7-20
• Using NAM to Evaluate Application-Level Performance Monitoring for UDP Real-Time Applications, page 7-20
• Monitoring the Nexus 1000V Switch Environment, page 7-20

Real-Time Traffic Monitoring and Analysis

One of your Network Operations Center (NOC) responsibilities is to monitor the campus network and two branch offices and follow up on any abnormalities that you find in these networks.

The following steps lead you through managing a NAM-2 blade located in the Cisco Catalyst 6500 Series Switch at the campus edge. There is local SPAN and remote NetFlow traffic being monitored by this NAM. You have defined sites based on those data sources.

---

**Step 1**

On the Traffic Summary dashboard (Monitor > Overview > Traffic Summary), use the Interactive Report and the Filter button on the left side of the screen to narrow the data on the dashboard to a particular site. Then, you will be able to view the Top Applications, Hosts, VLANs, and DSCP for that site. Take note of the Top Host, or in other words, top bandwidth generator (see Figure 7-5).

---

**Figure 7-5 Top Applications and Hosts**

---

**Step 2**

Click on the Top Applications graph to drill down to see all the hosts using the GRE application. Notice that this application traffic is being generated by three hosts (see Figure 7-6).
Step 3 Go back to Traffic Summary > Top N Hosts In and Out and click on the host (in the example shown in Figure 7-6, “192.168.152.10”).

Step 4 Select Analyze > Traffic > Host to see how long this host and application have been generating this traffic. The Time Range can be changed using the Interactive Report and the Filter button on the left; a shorter or longer period of time may be needed to understand the pattern and trend.

Step 5 Based on those patterns, thresholds can be configured to alert via e-mail, trap, and syslog. The alert can be used to start a packet capture as well. On the context menu (found by left-clicking on the colored bar), there is an option to initiate a packet capture if desired (see Figure 7-8).
Although the NAM was deployed at the campus edge, other possible locations that offer similar information include the core, distribution (NAM-2X or appliance), and branch office (with NAM on ISR G2 SM-SRE).

This use case illustrates some of the benefits of real-time analysis. You were able to study applications and conversations in real time and were able to take a capture of a particular stream that was of interest.

### Using NAM to Monitor QoS/DiffServ (DSCP)

Differentiated Services (DiffServ) provides insight into how traffic is being classified by QoS and detects incorrectly marked or unauthorized traffic. The NAM identifies the application/protocol based on the type of service (ToS) bits setting. The administrator can configure DSCP Groups or use the ones provided (as shown in Figure 7-9). The voice template can be used to monitor whether voice traffic is marked properly. Figure 7-11 displays the DiffServ application statistics for all DSCP value. Looking at this, you will notice that RTP and Session Initiation Protocol (SIP) are listed, which indicates that they are not being correctly marked throughout its path.

In the following scenario, IT has deployed QoS to prioritize VoIP traffic to improve voice quality across the network. The NAMs are deployed in the data center and branches and utilized to monitor the DSCP to validate QoS policies.

#### Step 1
Choose **Setup > Media > DSCP Groups** to display the default groups.
Step 2  Choose **Analyze > Traffic > DSCP** to find any misclassified traffic. In **Figure 7-10**, the RTP protocol is displayed for ToS0 classification.
Step 3  Click on the All DSCP button to view all DSCP and applications.
Step 4 In Figure 7-11, RTP and SIP are highlighted. The protocols are listed for DSCP 0, which is incorrect since the standard classification for voice traffic is DSCP 46 and 24. This means that some of the voice traffic is misclassified on the network. You can also view the branch NAMs to investigate whether voice traffic is being misclassified.

Figure 7-11 All DSCP Table

<table>
<thead>
<tr>
<th>DSCP</th>
<th>Application</th>
<th>Bits/sec</th>
<th>Packets</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>RTP</td>
<td>11,273,998</td>
<td>439,795,213</td>
</tr>
<tr>
<td>16</td>
<td>ntp</td>
<td>69,799,561</td>
<td>136,175,501</td>
</tr>
<tr>
<td>9</td>
<td>ftp-data</td>
<td>2,073,13</td>
<td>9,024,376</td>
</tr>
<tr>
<td>0</td>
<td>ftp-data</td>
<td>1,685,723</td>
<td>5,080,116</td>
</tr>
<tr>
<td>8</td>
<td>ftp</td>
<td>1,678,239</td>
<td>22,321,398</td>
</tr>
<tr>
<td>0</td>
<td>ntp</td>
<td>709,044</td>
<td>2,732,247</td>
</tr>
<tr>
<td>0</td>
<td>ftp</td>
<td>702,676</td>
<td>11,656,256</td>
</tr>
<tr>
<td>0</td>
<td>gnp</td>
<td>674,333</td>
<td>1,492,730</td>
</tr>
<tr>
<td>0</td>
<td>flowmonitor</td>
<td>111,941</td>
<td>201,382</td>
</tr>
<tr>
<td>0</td>
<td>sip</td>
<td>245,70</td>
<td>116,138</td>
</tr>
<tr>
<td>0</td>
<td>unknown</td>
<td>22,462</td>
<td>352,068</td>
</tr>
<tr>
<td>0</td>
<td>snmp</td>
<td>8,294</td>
<td>104,991</td>
</tr>
<tr>
<td>0</td>
<td>h323hostcall</td>
<td>8,246</td>
<td>180,703</td>
</tr>
<tr>
<td>0</td>
<td>sftp</td>
<td>8,069</td>
<td>152,056</td>
</tr>
<tr>
<td>0</td>
<td>vrcp</td>
<td>4,025</td>
<td>102,304</td>
</tr>
<tr>
<td>0</td>
<td>icmp</td>
<td>997</td>
<td>17,090</td>
</tr>
<tr>
<td>0</td>
<td>any</td>
<td>553</td>
<td>14,557</td>
</tr>
<tr>
<td>0</td>
<td>bootps</td>
<td>498</td>
<td>1,616</td>
</tr>
<tr>
<td>48</td>
<td>smtp</td>
<td>445</td>
<td>12,440</td>
</tr>
<tr>
<td>0</td>
<td>dnet</td>
<td>373</td>
<td>10,160</td>
</tr>
<tr>
<td>n</td>
<td>netflow</td>
<td>381</td>
<td>3,676</td>
</tr>
</tbody>
</table>

Step 5 Left-click on the RTP graph and select Application Traffic by Host to display the clients using those protocols. This helps to troubleshoot why RTP or SIP traffic from these clients is not marked correctly. As shown in Figure 7-12, the NAM displays the IP addresses of the phones using those protocols. This helps you review the QoS policy implemented on the routers and switches between the clients.
Using NAM for Historical Trends via Interactive Report

Historical trending is an important component of network performance management. While real-time analysis provides information about events, historical trending provides visibility into event sequences. Such sequences offer valuable information about various aspects of the network such as changes in network traffic behavior, anomalies and unusual activities, and network usage in peak times versus low times. It is also helpful in planning future network upgrades, application rollouts, and hardware buildouts. Here are some things to take note of regarding NAM’s historical trending capabilities:

- Use the Interactive Report > Filter button (located on the left side of the NAM window) to look at short term and long term trends by changing the Time Range. The interactive reports can be exported or the filter setting saved for quick view in the future. The exported data can be sent via e-mail in CSV or PDF format.
- Figure 7-13 displays host traffic for the last day, and using the middle graph you can zoom down to the time range of 10:00 - 16:00 to view what other application this host is using.

In the following deployment scenario, you will predict the capacity needed for a new branch build out due in six months by studying the usage of an existing branch office of a similar size. To deploy a NAM located in the branch router (ISR) of the existing branch:

**Step 1** Start capturing traffic rates between the branch and the data center. View the traffic for the last month from Interactive Report > Filter > Time Range > Custom (enter a date covering a month).
Step 2  Open a conversation report from today and find a stream that has a mildly increasing trend but is unable to confirm the rate at which it is increasing (see Figure 7-14).

**Figure 7-14  A Stream with a Mildly Increasing Trend**

![Graph showing a mildly increasing trend](Image)

Step 3  Change the Time Range dynamically in the Interactive Report to study the trend with a granularity of one month. You may find that the pattern does show periodic increases, but it always hits a ceiling between 4.5 KBps and 5.x KBps (see Figure 7-15). You are then able to conclude that the ISP link needed at the new site would be similar, and so a standard T1 line would be more than sufficient for the needs of the new remote office.

**Figure 7-15  The Trend Shown with a Granularity of 1 Month**

![Graph showing a trend with granularity of 1 month](Image)

Studying historical trends is a valuable exercise in planning and creating baselines in a network. Monitor and trend on business critical applications and servers. These trends should provide handy information in a variety of day-to-day decisions.
Using NAM to Evaluate Application-Level Performance Monitoring for TCP-Interactive Applications

Application Performance Response Time Analysis provides up to 45 metrics. You can configure thresholds based on many of these metrics, and receive an alert when the thresholds are passed. Thresholds should be set for critical applications or servers using Average Server Response Time, or Average Transaction Time, or Average Network Time and Average Server Network Time. These thresholds will help identify where the problem lies in the application performance, and show whether the problem is a server or network issue. Depending on the alarm, you can access the NAM to see the applications and clients accessing the server, or to check the devices in the traffic path monitoring device and interface utilization.

See Application Response Time, page 4-18.

Using NAM to Evaluate Application-Level Performance Monitoring for UDP Real-Time Applications

The NAM monitors and analyzes RTP streams and voice calls statistics by intercepting the data collected by endpoints. So, when a phone call ends, the endpoints calculate the information and send it to the Unified Communications Manager (aka the Call Manager), the NAM collects the data (as long as it is along that path).

NAM uses the voice call statistics from the endpoint with the RTP stream to correlate the phone number with the IP address of the endpoint. Alerts are sent based on analysis of the RTP streams for MOS, Jitter, and Packet Loss.

To use NAM to monitor the application-level performance for UDP real-time applications:

1. Set up thresholds to focus on which types of performance metrics you want to monitor at Setup > Alarms > Thresholds.
2. View voice signaling/RTP traffic at Analyze > Media > RTP Streams or Analyze > Media > Voice Call Statistics.
   See Analyzing Traffic, page 4-6, RTP Streams, page 4-29.
   See Table B-31, Voice Monitor Setup Window.

Monitoring the Nexus 1000V Switch Environment

As networks and applications move into the virtualization environment, the challenge for you is to find tools to gain insight into that environment. The NAM VSB provides that function by integrating with the Cisco Nexus 1010 virtualization appliance. Using the NAM VSB, you can gain operational visibility into the virtual switching layer and is able to see virtual machine (VM) to VM statistics. See Figure 7-16.

The Nexus 1000V switch can also be monitored by other NAM platforms running the Prime NAM software.

In this scenario, there are two options:
You are deploying applications in the virtualized environment and the Nexus 1000V switch is providing the network connectivity. The NAM VSB installed on the Nexus 1010 Virtual Services Appliance is used to monitor the environment.

You have a NAM-2 deployed in the data center switch and a Nexus 1000V switch for the virtualized environment, and you want to monitor the virtual switch traffic.

If Nexus 1000V switches and NAMs are already deployed in the network, ERSPAN or NetFlow data source can be directed by any one of those NAMs. You should directly connect the 1000V switch and NAM to the same physical switch.

To monitor the Nexus 1000V environment:

**Step 1** Install and configure either the NAM VSB on the Nexus 1010 Virtual Services Appliance or the Nexus switch to the NAM-2. See the Installation and Configuration Guides for the NAM on Cisco.com: [http://www.cisco.com/en/US/products/sw/cscowork/ps5401/prod_installation_guides_list.html](http://www.cisco.com/en/US/products/sw/cscowork/ps5401/prod_installation_guides_list.html)

**Step 2** For the NAM VSB:

1. Verify that ERSPAN or NetFlow are configured on the Cisco 1000V Switch Virtual Supervisor Module (VSM) that is providing data to NAM.
2. Configure the ERSPAN or NetFlow data source, depending on your NAM:
3. Enable all applicable monitoring parameters in NAM for ERSPAN and NetFlow. Use the Traffic Summary window to display Top N information such as applications, hosts, protocol, and server response time. You can view and display details for each of the categories listed.

4. Using the Interactive Report, configure reports for trending on the application response time, hosts, and conversation traffic patterns.

   The physical and virtual interfaces table provides VM-to-VM traffic utilization. Because one virtual interface connects to one VM, the data shows which VMs are utilizing the switch resources. You can then view the hosts and conversations tables to identify the culprit utilizing the resources.

Note: NAM VSB provides the same complement of features except that it supports only ERSPAN and NetFlow data sources and performs no voice monitoring and packet capture.

Step 3: For other NAM platforms (NAM-2X):

   1. Configure the Nexus 1000V Switch to direct ERSPAN or NetFlow to the NAM-2X.
   2. Verify that ERSPAN or NetFlow are configured on the Cisco 1000V Switch Virtual Supervisor Module (VSM) that is providing data to NAM by choosing Setup > Traffic > NAM Data Sources.
   3. Create a site for this data source using Setup > Network > Sites.

Troubleshooting

- Using NAM for Problem Isolation, page 7-22
- Using NAM for SmartGrid Visibility, page 7-23
- Real-Time Traffic Monitoring and Analysis, page 7-11

Using NAM for Problem Isolation

The alarm details (found in the Cisco Prime Network Analysis Module Software under Monitor > Overview > Alarm Summary) provides information you can use to drill-down on the threshold that was violated. You may also receive this alarm in e-mail (Setup > Alarms > E-mail). An example of the alarm is:

2013 SEPT 28 9:17:0:Application:Exceeded rising value(1000);packets;60653;Site(San Jose), Application(http)

After receiving this alarm, you can access the NAM GUI to view the application in your specific site to determine why there was a spike. Click on Analyze > Traffic > Application; in the Interactive Report window on the left, change Site to “San Jose,” Application to “HTTP,” and Time Range to the range when the alert was received. This will display all the hosts using this protocol. You can see the Top hosts and verify there are no unauthorized hosts accessing this application. You can also access Analyze > Traffic > Host to view which conversations are chatty, and therefore causing the increase traffic for this application.
If the alarm is for an Application Response Time issue, you can access **Monitor > Response Time Summary** or **Analyze > Response Time > Application** to drill-down on what hosts are accessing the application. Identify the application server and view what other applications are hosted and all the clients accessing that server.

See Analyze: Measuring Response Time, page 4-16.

### Using NAM for SmartGrid Visibility

The NAM will not recognize the IEC 60870 protocol out of the box (this is one of the main protocols used by power distribution companies). You will have to add a custom protocol, because it is a specific port you will be using. When you choose **Setup > Classification > Application Configuration**, you will see all hosts using that application. It will be identified as a Telnet application.
Resolving Typical NAM Issues

Q. I am sending traffic to the NAM but nothing comes up on the default monitoring page. What could be wrong?

A. There are two typical issues that are seen when first setting up traffic to the NAM:
   - Wait for at least five minutes after traffic is sent to the NAM. Prime NAM collects and displays information at intervals and traffic may not display in charts immediately.
   - Ensure the client time is synchronized with the NAM time. Typically this means setting your NTP server to synchronize your NAM time. For details, see Synchronizing Your System Time, page 6-6.

Q. What information should I collect and what else should I do when the NAM is not responding?

A. Determine the answers to the following questions and gather the following information:
   - Does session from the switch/router CLI work?
   - Does ping over EOBC (127 subnet) work?
   - Does ping to the management IP address work?
   - Collect output of show tech-support command from both the NAM and the switch or router.
   - Collect core files.
   - Check if NAM hardware is seated correctly in chassis
     Perform the following tasks to troubleshoot your issue:
   - Reset NAM
Troubleshooting Login Issues

Log into the NAM by using the username and password that the NAM administrator provided you, and click the Login button. If you are having problems logging in:

- Make sure you are using a browser that is currently supported for use with NAM:
  - English Firefox 3.6+ or Microsoft Internet Explorer 8+ (Microsoft Internet Explorer 7 is not supported)
- Make sure you are using a platform that is currently supported for use with NAM:
  - Microsoft Windows XP or Microsoft Windows 7. The Macintosh platform is not supported on this release.
- Make sure you have JavaScript enabled.
- Clear the browser cache and restart the browser (not necessary if installing NAM for the first time).
- Make sure cookies are enabled in your browser.
- If you see the following message: “Initializing database. Please wait until initialization process finishes,” you must wait until the process finishes.
- Make sure your username and password does not use any special characters.
- If your platform requires licensing, make sure you accepted the license agreement and that the license has not expired.
- If the Prime vNAM permanent license is installed and you log in for the first time and accept the EULA, you may be logged out so the permanent license can take effect. We recommend you wait several minutes before you attempt another logon.

To view the full documentation set (including the User Guide and Release Notes) for the Cisco Prime NAM software, go to the NAM software Technical Documentation area on Cisco.com:

Understanding Typical Error Messages

**Q.** I’m waiting for the graphical data to populate on a dashboard. What does this red error “Request Error -- Please Try Again” mean?

**A.** This means an internal error has occurred, or the login session may have timed out.

**Q.** I’m waiting for the graphical data to populate on a dashboard. What does this red error “Query resulted in no data” mean?

**A.** The NAM does not have any data for the specified time frame and specified filter. Go to the Interactive Report (the pane on the left side of the window) and click the Filter button to check the filter settings and data sources to make sure the NAM is getting data. You can also check the Overview page to ensure the traffic is reaching the NAM. If no traffic appears, check your data sources and SPAN session configuration.

**Q.** What does the message “Client or NAM time is incorrect” mean?

**A.** The browser or client time and the NAM time must be synchronized to avoid this error. See Synchronizing Your System Time, page 6-6.

Frequently Asked Questions about Prime NAM Behavior

**Q.** How does NAM calculate network latency?

**A.** To calculate network latency, NAM looks at each packet and associates it to a transaction. For example, NAM looks at SYN and SYN-ACK and timestamps these packets to perform these calculations.

**Q.** How can Prime NAM be restricted to one tenant’s traffic when using SPAN or ERSPAN on a Nexus 1000V?

**A.** Prime NAM can be deployed per tenant so they each NAM has their own portal. NAM processes VxLAN, LISP, FabricPath, and OTV for multiple tenants.

**Q.** Why is the browser behaving strangely? It is displaying data for no apparent reason or is not displaying expected data.

**A.** Clear the browser cache, close the browser, and open a new session and try again. Also, make sure you are using a supported browser (see the Cisco Prime Network Analysis Module Release Notes).

**Q.** Why is the NAM performance lower than expected?

**A.** Disk capture will reduce the NAM performance considerably. It is due to the disk input/output speed. You will see a warning in the top right corner of the window.

**Q.** Why won’t the system change the storage option for my capture session from disk to memory and then back to disk?

**A.** If you set up a capture session to disk and later modify the same packet session to save into memory, Prime NAM is unable to change the storage selection back to disk because it is in the in use state. You cannot delete the capture session to release the disk for capture. The workaround is to reboot the NAM. This has been fixed in the latest patch (patch 5) on the Cisco software download web page.

**Q.** What MIBs do the Prime NAM support?
A. Table A-1 lists the MIB objects supported by Prime NAM.

Table A-1  Supported MIBs

<table>
<thead>
<tr>
<th>Description</th>
<th>Source</th>
</tr>
</thead>
<tbody>
<tr>
<td>MIB-II: All groups except Exterior Gateway Protocol (EGP) and transmission.</td>
<td>RFC 1213</td>
</tr>
<tr>
<td>RMON2: trapDestTable only</td>
<td>RFC 2021</td>
</tr>
<tr>
<td>CDP-MIB: Cisco Discovery Protocol</td>
<td></td>
</tr>
<tr>
<td>EntityMIB</td>
<td>RFC 2737</td>
</tr>
</tbody>
</table>

1. CDP is received on NAM management ports only. NAM does not transmit CDP packets.

Troubleshooting WAAS Data Issues

Q. Why does Prime NAM display the status of WAAS devices as pending?
A. Prime NAM is unable to monitor WAAS traffic until you set up WAAS monitored servers. To change the pending status, you must set up WAAS monitored servers. See your product documentation for more details.

Q. Why is no WAAS data seen in the Monitor windows?
A. Perform the following steps:
   - Use the NAM GUI to verify that the Monitored Servers list is configured with the correct server IP addresses.
   - Use the NAM GUI to verify that WAAS data sources have data collection enabled for applicable segments.
   - Use the WAAS CLI `show statistics flow filters` to verify that the servers have active traffic flows that are optimized and monitored.
   - Use the WAAS CLI `show statistics flow mon tcpstat` to verify that WAAS Flow Agent exports flow data to the correct NAM IP address.

Q. The WAAS is not sending data to the NAM, and the reports are not showing any values.
A. The WAAS will not send data unless filtering is enabled on the NAM. Enable filtering at Setup > Data Sources > WAAS > Monitored Servers, and check the “Filter Response Time for all Data Sources by Monitored Servers” check box.

Using the CLI to Troubleshoot Issues

- Handling an Unresponsive NAM, page A-5
- Handling an Unresponsive NAM, page A-5
Locating Packet Drops

**Q.** How can I find out using the CLI if packets are being dropped?

**A.** The following CLI command shows packet drops at different layers of the NAM system at 5 minute intervals and up to the last 24 hours:

```plaintext
root@NAM1x-18.cisco.com# show pkt-drop-counters Hour-0
```

Start time of the hour: 2010-11-05 13:00 PDT

<table>
<thead>
<tr>
<th>Time</th>
<th>hardware pkts dropped</th>
<th>FM pkts dropped</th>
<th>ART pkts dropped</th>
</tr>
</thead>
<tbody>
<tr>
<td>13:05</td>
<td>3548</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>13:10</td>
<td>3354</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>13:15</td>
<td>2843</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>13:20</td>
<td>2629</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>13:25</td>
<td>3592</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>13:30</td>
<td>3298</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>13:35</td>
<td>1823</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>13:40</td>
<td>2549</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>00:00</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>00:00</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>00:00</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

Handling an Unresponsive NAM

**Q.** Why is my NAM Blade not responding?

**A.** Do the following:

- Check the NAM IP configuration (using the CLI command `show ip`)
- Check VLAN configuration of management port on Sup:
  ```plaintext
  analysis module <slot> management-port access-vlan <#>
  ```
- Does the session from the switch/router work?
- Does a ping to NAM mgmt IP address work?
- What is the module status on Sup/router?

  ```plaintext
  show modules CLI
  ```

Using the CLI to Troubleshoot Performance Agent (PA)

**Q.** Why is the NAM not receiving data from PA?

**A.** First troubleshoot Flexible NetFlow (FNF). Check whether FNF sent data to the NAM with `show flow exporter statistics`. If FNF did not send data, check Performance Agent with `show mace metrics summary`. Check whether flows are exported. If flows are not exported by PA, debug PA to identify the error with `debug mace cp`. 
References

This section provides reference information on the following topics:

- Understanding NAM Behavior
- GUI Field Descriptions
- Report Descriptions

Understanding NAM Behavior

This section includes details on how NAM works including how to navigate and use the control elements in the user interface as well as Prime NAM uses the traffic sources available on each platform.

Use these sections to understand Prime NAM behavior:

- Understanding Common Navigation and Control Elements, page B-1
- Understanding How the Prime NAM Traffic Sources Work, page B-6
- Frequently Asked Questions about Prime NAM Behavior, page A-3

Understanding Common Navigation and Control Elements

This section includes the following topics:

- Understanding the Menu Bar, page B-2
- Displaying Detailed Views, page B-2
- Accessing Context Menus, page B-2
- Performing a Quick Capture, page B-3
- Filtering Data Using the Interactive Report, page B-4
- Switching Chart Formats Using the Chart View / Table View, page B-4
- Accessing Other Tasks Using Mouse-Over for Details, page B-4
- Changing the Time Interval Using Zoom/Pan Charts, page B-5
- Using Sort Grid to Change Sort Order, page B-5
- Displaying Bits or Bytes or Packets in Charts, page B-5
- Statistics, page B-6
• Context-Sensitive Online Help, page B-6
• Synchronizing the Clock on Prime NAM, page B-7

Understanding the Menu Bar

For a description of common tasks in Prime NAM, see Table B-1.

<table>
<thead>
<tr>
<th>Table B-1</th>
<th>Summary of Menu Tasks</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Menu Name</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>Home</td>
<td>Brings you to the Traffic Summary Dashboard (Monitor &gt; Overview &gt; Traffic Summary).</td>
</tr>
<tr>
<td>Monitor</td>
<td>View summary dashboards with network traffic, application performance, site performance, and alarms information at a glance.</td>
</tr>
<tr>
<td>Analyze</td>
<td>See various views for traffic over a time period, WAN optimization, response time, managed device, and media functions.</td>
</tr>
<tr>
<td>Capture</td>
<td>Configure multiple sessions for capturing, filtering, and decoding packet data, manage the data in a local or remote file control system, and display the contents of the packets.</td>
</tr>
<tr>
<td>Setup</td>
<td>Perform setup options needed to access Prime NAM features.</td>
</tr>
<tr>
<td>Administration</td>
<td>Set dashboard preferences, perform user and system administration tasks, and generate diagnostic information for obtaining technical assistance.</td>
</tr>
</tbody>
</table>

Displaying Detailed Views

You can access additional details from the Dashboard and Monitor and Analyze mega-menus that provide packet and bits per second data as well as identify host, application, DCSP, and other categories. Look for menus titled Details or Detailed Views. If a small arrow appears to the right of the menu selection, click it to see the submenu and the functions available. For an example of the Applications submenu see Figure B-1 on page B-3.

Accessing Context Menus

On most charts that appear on the dashboards (except for pie charts), you can left-click on a colored bar of data to get a context menu, with which you can get more detailed information about that item. See Figure B-1 on page B-3.
The example above is from the Traffic Summary Dashboard, Top N Applications chart. The description to the right of “Selected Application” in the menu shows what item you had clicked on (in this case, *ftp-data*).

The menu items above the separator line are specific to the selected element of the Top N chart. The items below the separator line are not specific to the selected element, but apply to the Top N chart.

### Performing a Quick Capture

From the Context menu of many of the bar charts that show Applications or Hosts or VLANs, you can start a Capture. For example, when you click on an Application in a bar chart (as in Figure B-1 on page B-3) and choose Capture, the following is done automatically:

- A memory-based capture session is created
- A software filter is created using that application
- The capture session is started
- The decode window pops open and you can immediately see packets being captured.

**Note**

Quick Capture does not use site definition/filter.

From both the selectors in the upper left of the dashboards and from the item the user clicks on in the barchart, the following are carried into the context for the capture session:

- Application
- VLAN
- Host
- Data Source (if it is a DATA PORT)

If you open up the associated Capture Session and its associated Software Filter, the above settings will be shown.
Determining How to Use Sites to View Data

A site is a collection of hosts, or network endpoints, partitioned into views that help you monitor traffic and troubleshoot problems (see Configuring Sites, page 3-50 for more detailed information).

If you have set up sites, you will be able to select a particular site to view in the Interactive Report and view data relevant to that site only. In some cases, you can select both a Client Site and a Server Site to view data pertaining to interaction between hosts at different sites.

Filtering Data Using the Interactive Report

You can use the Interactive Report on most Monitor and Analyze windows to filter the parameters of the information displayed in the dashboards. Click the Filter button to change the parameters of the information displayed in the charts. Use the Monitor windows to view at a glance data and the Analyze windows to view data over time.

You can choose from various parameters, such as the time range for the data being displayed. An asterisk represents required fields.

The reporting time interval selection changes depending upon the dashboard you are viewing, and the NAM platform you are using. The Prime NAM supports up to five saved Interactive Reports. Saved reports display at the bottom of the interactive report panel.

The From and To fields are only enabled when the Time Range is set to Custom.

Switching Chart Formats Using the Chart View / Table View

Using the Chart view lets you see an overview of the data in an integrated manner, and can show you trending information. To get the exact value of any data in the graphical view, hover over a data point to see the tool tip. To toggle between the two views, use the Chart and Table icons at the bottom of the panel:

Accessing Other Tasks Using Mouse-Over for Details

When in Chart view, you can mouseover the chart to get more detailed information about what occurred at a specific time.

Many of the line charts in Prime NAM are dual-axis, meaning there is one metric shown on the left axis of the chart and another metric shown on the right axis of the chart.

For example, in the DCSP Group Traffic chart, Megabits per second is shown on the left axis, and Packets per second is shown on the right axis.
Changing the Time Interval Using Zoom/Pan Charts

For many charts, you can drag the beginning or end to change the time interval, as shown below.

![Diagram showing zoom/pan chart and time interval change](image)

The time interval change on the zoom/pan chart will affect the data presented in the charts in the bottom of the window. The zoom/pan time interval also affects the drill-down navigations; if the zoom/pan interval is modified, the context menu drill-downs from that dashboard will use the zoom/pan time interval.

**Note**

In a bar chart which you can zoom/pan, each block represents data collected during the previous interval (the time stamp displayed at the bottom of each block is the end of the time range). Therefore, you may have to drag the zoom/pan one block further than expected to get the desired data to populate in the charts in the bottom of the window.

Using Sort Grid to Change Sort Order

When looking at information in Grid view, you can sort the information by clicking the heading of any column. Click it again to sort in reverse order.

![Grid view example](image)

Displaying Bits or Bytes or Packets in Charts

To change the display on most Monitor and Analyze charts from bits to bytes, you can use the Bits and Bytes radio buttons to specify which information you would like the chart to display. To change this preference to display bytes use the **Administration > System > Preferences**.

On most Monitor and Analyze charts, you can use the Bits and Packets check boxes at the top to specify which information you would like the chart to display. To change this preference to display bytes use the **Administration > System > Preferences**.
Statistics

The Statistics legend gives you the minimum, maximum, and average statistics of the data. This will display the initial data retrieved for the selector.

Context-Sensitive Online Help

The Help link on the top-right corner of the Prime NAM interface will bring you to the Help page for that particular window of the GUI.

If available, the Help link appears on the top-right corner of each page; some pages also have a blue “i”, which provides help for that specific subject.

Understanding How the Prime NAM Traffic Sources Work

The next section describes how the Prime NAM uses the supported data sources:

- Understanding How the Prime NAM Uses SPAN, page B-6
- Understanding How the Prime NAM Uses VACLs, page B-7
- Understanding How the Prime NAM Uses Netflow, page B-8
- Understanding How the Prime NAM Uses WAAS, page B-8
- Understanding How the Prime NAM Uses PA, page B-9

Understanding How the Prime NAM Uses SPAN

A switched port analyzer (SPAN) session is an association of a destination port with a set of source ports, configured with parameters that specify the monitored network traffic. You can configure up to two SPAN sessions in a Catalyst 6500 chassis. Newer Cisco IOS images may support more than two SPAN sessions. Consult the Cisco IOS document for the number of SPAN sessions supported per switch or router.

The NAM-1 platform provides a single destination port for SPAN sessions. The NAM-2 and NAM-3 platform provides two possible destination ports for SPAN and VLAN access control list (VACL) sessions. Multiple SPAN sessions to the Prime NAM are supported, but they must be destined for different ports. The Prime NAM destination ports for use by the SPAN graphical user interface (GUI) are named DATA PORT 1 and DATA PORT 2 by default. In the CLI, SPAN ports are named as shown in Table B-2.

<table>
<thead>
<tr>
<th>Module</th>
<th>Cisco IOS Software</th>
</tr>
</thead>
<tbody>
<tr>
<td>NAM-1X</td>
<td>dataport</td>
</tr>
<tr>
<td>NAM-2X or NAM-3</td>
<td>dataport 1 and dataport 2</td>
</tr>
</tbody>
</table>

For more information about SPAN and how to configure it on the various NAM platforms, see your device documentation on Cisco.com.
Due to potentially very high volume of ERSPAN traffic from the source, we recommend that you do not terminate the ERSPAN session on the NAM management port. Instead, you should terminate ERSPAN on the switch, and use the switch’s SPAN feature to SPAN the traffic to NAM dataports.

**Synchronizing the Clock on Prime NAM**

All times in the Prime NAM are typically displayed in 24-hour clock format. For example, 3:00 p.m. is displayed as 15:00. For details on how to synchronize your clock, see [Synchronizing Your System Time, page 6-6](#).

**Understanding How the Prime NAM Uses VACLs**

A VLAN access control list can forward traffic from either a WAN interface or VLANs to a dataport on the NAM. A VACL provides an alternative to using SPAN; a VACL can provide access control based on Layer 3 addresses for IP and IPX protocols. The unsupported protocols are access controlled through the MAC addresses. A MAC VACL cannot be used to access control IP or IPX addresses.

There are two types of VACLs: one that captures all bridged or routed VLAN packets and another that captures a selected subset of all bridged or routed VLAN packets. Catalyst operating system VACLs can only be used to capture VLAN packets because they are initially routed or bridged into the VLAN on the switch.

A VACL can provide access control for all packets that are bridged within a VLAN or that are routed into or out of a VLAN or, with Release 12.1(13)E or later releases, a WAN interface. Unlike regular Cisco IOS standard or extended ACLs that are configured on router interfaces only and are applied on routed packets only, the VACLs apply to all packets and can be applied to any VLAN or WAN interface. The VACLs are processed in the hardware.

A VACL uses Cisco IOS access control lists (ACLs). A VACL ignores any Cisco IOS ACL fields that are not supported in the hardware. Standard and extended Cisco IOS ACLs are used to classify packets. Classified packets can be subject to a number of features, such as access control (security), encryption, and policy-based routing. Standard and extended Cisco IOS ACLs are only configured on router interfaces and applied on routed packets.

After a VACL is configured on a VLAN, all packets (routed or bridged) entering the VLAN are checked against the VACL. Packets can either enter the VLAN through a switch port or through a router port after being routed. Unlike Cisco IOS ACLs, the VACLs are not defined by direction (input or output).

A VACL contains an ordered list of access control entries (ACEs). Each ACE contains a number of fields that are matched against the contents of a packet. Each field can have an associated bit mask to indicate which bits are relevant. Each ACE is associated with an action that describes what the system should do with the packet when a match occurs. The action is feature dependent. Catalyst 6500 series switches and Cisco 7600 series routers support three types of ACEs in the hardware: IP, IPX, and MAC-Layer traffic. The VACLs that are applied to WAN interfaces support only IP traffic.

When you configure a VACL and apply it to a VLAN, all packets entering the VLAN are checked against this VACL. If you apply a VACL to the VLAN and an ACL to a routed interface in the VLAN, a packet coming into the VLAN is first checked against the VACL and, if permitted, is then checked against the input ACL before it is handled by the routed interface. When the packet is routed to another VLAN, it is first checked against the output ACL applied to the routed interface and, if permitted, the VACL configured for the destination VLAN is applied. If a VACL is configured for a packet type and a packet of that type does not match the VACL, the default action is deny.
Understanding NAM Behavior

When configuring VACLs, note the following:

- VACLs and context-based access control (CBAC) cannot be configured on the same interface.
- TCP Intercepts and Reflexive ACLs take precedence over a VACL action on the same interface.
- Internet Group Management Protocol (IGMP) packets are not checked against VACLs.

**Note**

You cannot set up VACL using the Prime NAM interface.

For details on how to configure a VACL with Cisco IOS software, see Cisco.com.

For details on how to configure a VACL on a WAN interface and on a LAN VLAN, see Forwarding VACL Traffic, page 3-17.

Understanding How the Prime NAM Uses NetFlow

The Prime NAM uses NetFlow as a format for the ongoing streaming of aggregated data, based on the configured set of descriptors or queries of the data attributes in NAM. NetFlow Data Export (NetFlow) is a remote device that allows you to monitor port traffic on the NAM; the Prime NAM can collect NetFlow from local or remote switch or router for traffic analysis.

To use a NetFlow data source for the Prime NAM, you must configure the remote device to export the NetFlow packets. The default UDP port is 3000, but you can configure it from the Prime NAM CLI as follows:

```
root@nam2x-61.cisco.com# netflow input port ?
<port>                    - input NetFlow port number
```

The distinguishing feature of the NetFlow v9 format, which is the basis for an IETF standard, is that it is template-based. Templates provide an extensible design to the record format, a feature that must allow future enhancements to NetFlow services without requiring concurrent changes to the basic flow-record format.

For more detailed information about Prime NAM and NetFlow, see Forwarding NetFlow Traffic, page 3-18.

For specific information about creating and managing NetFlow queries, see the Cisco Network Analysis Module API Programmer’s Guide (contact your Cisco account representative if you need to refer to this document).

Understanding How the Prime NAM Uses WAAS

Cisco Wide Area Application Services (WAAS) software optimizes the performance of TCP-based applications operating in a wide area network (WAN) environment and preserves and strengthens branch security. The WAAS solution consists of a set of devices called Wide Area Application Engines (WAEs) that work together to optimize WAN traffic over your network.

When client and server applications attempt to communicate with each other, the network devices intercepts and redirects this traffic to the WAEs to act on behalf of the client application and the destination server.

WAEs provide information about packet streams traversing through both LAN and WAN interfaces of WAAS WAEs. Traffic of interest can include specific servers and types of transaction being exported. Prime NAM processes the data exported from the WAAS and performs application response time and other metrics calculations and enters the data into reports you set up.
The WAEs examine the traffic and using built-in application policies to determine whether to optimize the traffic or allow it to pass through your network not optimized.

You can use the WAAS Central Manager GUI to centrally configure and monitor the WAEs and application policies in your network. You can also use the WAAS Central Manager GUI to create new application policies so that the WAAS system will optimize custom applications and less common applications. Prime NAM is accessible from within the Central Manager interface. The Cisco Prime NAM integration with WAAS Central Manager provides for easier viewing of Prime NAM reports that are directly associated with Application Response Time measurements through the WAN, in both WAAS optimized and non-optimized environments. See Using the WAAS Central Manager, page 3-31.

For more information about WAAS data sources and managing WAAS devices, see Understanding WAAS, page 3-29.

Understanding How the Prime NAM Uses PA

The Performance Agent (PA) can monitor interface traffic and collect, analyze, aggregate, and export key performance analytics to a NAM for further processing. PA integration with Prime NAM enables you to have a lower cost way to gain visibility into Application Response Time at the branch. Prime NAM integration with PA also reduces complexity of needing to manage a separate Prime NAM product within the branch.

Using Cisco PA, you can gain visibility into application response time and traffic statistics at remote branches. It is supported on ISR 880, ISR 890, and ISR G2 platforms with Cisco IOS Software Release 15.1(4)T. Deployed with WAAS Express, this feature allows an end-to-end view into the WAN-optimized network, delivering a cost-effective and scalable solution.

PA has the ability to consolidate and filter information before it is exported, ensuring that only contextually-required data is exported and consumed versus all data. As an example, NetFlow Export supports a number of functions, including response time and traffic analysis. Instead of exporting multiple different flows, the PA has the intelligence to consolidate, filter, and export flow data that addresses the particular user’s need. Besides consolidating and filtering information, PA’s mediation capabilities also includes the ability to use key Cisco IOS-embedded functionality (for example, Embedded Event Manager, or Class-Based QoS) to enrich both PA functionality and router value.

For information about configuring PA data sources, see Managing ISR PA Devices, page 3-27.

GUI Field Descriptions

This section describes the following window field descriptions:

- Setup User Interface Windows
- Monitor User Interface Windows
- Capture User Interface Windows

Setup User Interface Windows

- Create SPAN Session Dialog Box
- Prime NAM Data Sources
• Edit SPAN Session Dialog Box
• SNMP Credential Options in NAM Data Sources Window
• Device System Information Dialog Box
• Alarm Configuration Window
• Threshold Configuration
• Host Alarm Thresholds
• Conversation Alarm Thresholds
• Application Alarm Thresholds
• Response Time Thresholds
• DSCP Alarm Thresholds
• RTP Streams Thresholds
• Voice Signaling Thresholds
• NetFlow Interface Alarm Thresholds
• Router/Managed Device System Information
• Switch Device Information
• NBAR Interface Details
• Site Configuration
• Subnet Detection
• Sites Window
• Add NetFlow Interface Capacity
• Create or Edit Applications
• DSCP Group Setup Dialog Box
• Applications
• URL-Based Applications
• Response Time Configuration Window
• Voice Monitor Setup Window
• URL Collection Configuration Dialog Box

Create SPAN Session Dialog Box

Table B-3 describes the fields on the Create SPAN Session dialog box.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Session ID</td>
<td>Monitor session of the SPAN.</td>
</tr>
<tr>
<td>SPAN Session Options</td>
<td>Select to include the following options: Extended, Multicast Best Effort,</td>
</tr>
<tr>
<td></td>
<td>Sampling, MTU Truncation, and Rate Limit.</td>
</tr>
</tbody>
</table>
GUI Field Descriptions

### Table B-4 Prime NAM Data Sources

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device</td>
<td>DATA PORT if it is a local physical port or the IP address of the device that is sending NAM data.</td>
</tr>
<tr>
<td>Type</td>
<td>The source of traffic for the NAM. DATA PORT if it is a local physical port. WAAS, ERSPAN, NETFLOW, or PA if a data stream exported from the router or switch or WAE device.</td>
</tr>
<tr>
<td>Activity</td>
<td>Shows the most recent activity.</td>
</tr>
<tr>
<td>Status</td>
<td>ACTIVE or INACTIVE.</td>
</tr>
<tr>
<td>Data Source</td>
<td>The Name given to the data source.</td>
</tr>
<tr>
<td>Data Source Details</td>
<td>Physical Port or information about the data source being Enabled or Disabled.</td>
</tr>
</tbody>
</table>

### Edit SPAN Session Dialog Box

Table B-5 describes the fields on the Edit SPAN Session dialog box.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Session ID</td>
<td>Monitor session of the SPAN.</td>
</tr>
<tr>
<td>SPAN Type</td>
<td>Type of SPAN session.</td>
</tr>
<tr>
<td>SPAN Destination Interface</td>
<td>The Prime NAM interface to which you want to send data.</td>
</tr>
<tr>
<td>SPAN Traffic Direction</td>
<td>Direction of the SPAN traffic.</td>
</tr>
<tr>
<td>Available and Selected Sources</td>
<td>SPAN sources available for the selected SPAN type.</td>
</tr>
</tbody>
</table>
SNMP Credential Options in NAM Data Sources Window

Table B-6 describes the options on the NAM Data Sources window for SNMP Credentials.

### Table B-6 SNMP Credential Options in NAM Data Sources Window

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mode: No Auth, No Priv</td>
<td>SNMP will be used in a mode with no authentication and no privacy.</td>
</tr>
<tr>
<td>Mode: Auth, No Priv</td>
<td>SNMP will be used in a mode with authentication, but no privacy.</td>
</tr>
<tr>
<td>Mode: Auth and Priv</td>
<td>SNMP will be used in a mode with both authentication and privacy.</td>
</tr>
<tr>
<td>User Name</td>
<td>Enter a username, which will match the username configured on the device.</td>
</tr>
<tr>
<td>Auth Password</td>
<td>Enter the authentication password associated with the username that was configured on the device. Verify the password.</td>
</tr>
<tr>
<td>Auth Algorithm</td>
<td>Choose the authentication standard which is configured on the device (MD5 or SHA-1).</td>
</tr>
<tr>
<td>Privacy Password</td>
<td>Enter the privacy password, which is configured on the device. Verify the password.</td>
</tr>
<tr>
<td>Privacy Algorithm</td>
<td>Enter the privacy algorithm, which is configured on the device (AES or DES).</td>
</tr>
</tbody>
</table>

Device System Information Dialog Box

Table B-7 describes the fields on the Device System Information dialog box.

### Table B-7 Device System Information Dialog Box

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the device.</td>
</tr>
<tr>
<td>Hardware</td>
<td>Hardware description of the device.</td>
</tr>
<tr>
<td>Device Software Version</td>
<td>The current software version running on the device.</td>
</tr>
<tr>
<td>System Uptime</td>
<td>Total time the device has been running since the last reboot.</td>
</tr>
<tr>
<td>Location</td>
<td>Location of the device.</td>
</tr>
<tr>
<td>Contact</td>
<td>Contact information for the device.</td>
</tr>
<tr>
<td>SNMP read from device</td>
<td>SNMP read test result. For the local device only.</td>
</tr>
</tbody>
</table>

Alarm Configuration Window

Table B-8 describes the fields on the Alarm Configuration Window.
Table B-8  Alarm Configuration Window

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name given to the alarm at setup.</td>
</tr>
<tr>
<td>E-mail</td>
<td>If turned on, will show “Enable.” If not turned on, will show “Disable.” E-mail server settings are configured on Administration &gt; System &gt; E-Mail Setting.</td>
</tr>
<tr>
<td>Trap</td>
<td>If configured, will show “Community: xxxxx” as configured on Administration &gt; System &gt; SNMP Trap Setting. If not configured, will be blank.</td>
</tr>
<tr>
<td>Trigger Capture</td>
<td>If configured, will show “Session: xxxxx” as configured on Capture &gt; Packet Capture/Decode &gt; Sessions. If no captures are configured, will be blank.</td>
</tr>
<tr>
<td>Syslog Remote</td>
<td>If turned on, will say “Enable”. If turned off, will say “Disable.” Settings configured on Administration &gt; System &gt; Syslog Setting.</td>
</tr>
<tr>
<td>Status</td>
<td>Missing Trap means that the trap configured for that alarm action has been deleted. OK means the Alarm action was successfully created.</td>
</tr>
</tbody>
</table>

Threshold Configuration Window
Table B-9 describes the fields on the Threshold Configuration window.

Table B-9  Threshold Configuration

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the threshold.</td>
</tr>
<tr>
<td>Type</td>
<td>You can configure eight types of thresholds.</td>
</tr>
<tr>
<td>Application</td>
<td>Application associated with this threshold.</td>
</tr>
<tr>
<td>Site</td>
<td>Site associated with this threshold.</td>
</tr>
<tr>
<td>Host</td>
<td>Host associated with this threshold.</td>
</tr>
<tr>
<td>Severity</td>
<td>High or Low (user-configured classification). These alarms are displayed on the Alarm Summary dashboard (Monitor &gt; Overview &gt; Alarm Summary). You can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td>Action</td>
<td>Rising action and Falling action (if configured). Alarms are predefined conditions based on a rising data threshold, a falling data threshold, or both.</td>
</tr>
<tr>
<td>Status</td>
<td>“OK” if configuration is complete. Otherwise, the issue will be listed (for example, “Missing Src Site”).</td>
</tr>
<tr>
<td>Add Metrics (button)</td>
<td>Click the Add Metrics button to add another row.</td>
</tr>
<tr>
<td>Delete (button)</td>
<td>Click the Delete button to remove that Metrics row.</td>
</tr>
</tbody>
</table>
Host Alarm Thresholds Window

Table B-10 describes the fields on the Hold Alarm Threshold window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Give the Host Alarm Threshold a name.</td>
</tr>
<tr>
<td>Site</td>
<td>Choose a site from the list. See Configuring Sites, page 3-50 for information on setting up a site.</td>
</tr>
<tr>
<td>Host</td>
<td>Choose a host from the list. You can enter the name of the host if the drop-down list does not contain the desired host.</td>
</tr>
<tr>
<td>Application</td>
<td>Choose an application from the list. You can enter the first few characters to narrow the selection in the drop-down list.</td>
</tr>
<tr>
<td>DSCP</td>
<td>Choose a DSCP value from the list. You can enter the first few characters to narrow the selection in the drop-down list.</td>
</tr>
<tr>
<td>Severity</td>
<td>Choose High or Low. These will display on the Alarm Summary dashboard (Monitor &gt; Overview &gt;Alarm Summary), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td>Actions</td>
<td>From the drop-down lists, choose a Rising action and a Falling action (optional). During threshold creation, by default, the falling action is the same as rising action. See Viewing Alarm Actions, page 3-38 for information on setting up alarm actions.</td>
</tr>
<tr>
<td>Host Metrics (per second)</td>
<td>Choose the type of metric from the list, and then enter a value for a Rising threshold and a Falling threshold.</td>
</tr>
</tbody>
</table>

Conversation Alarm Thresholds Window

Table B-11 describes the fields on the Conversation Alarm Thresholds window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Give the Conversation Alarm Threshold a name.</td>
</tr>
<tr>
<td>Application</td>
<td>Choose an application from the list. You can start typing the first few characters to narrow the list.</td>
</tr>
<tr>
<td>Severity</td>
<td>Choose High or Low. These will display on the Alarm Summary dashboard (Monitor &gt; Overview &gt;Alarm Summary), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td>Source Site/Host</td>
<td>Make a selection from the drop-down lists, or leave as Any. See Configuring Sites, page 3-50 for information on setting up a site.</td>
</tr>
<tr>
<td>Destination Site/Host</td>
<td>Make a selection from the drop-down lists, or leave as Any. See Configuring Sites, page 3-50 for information on setting up a site.</td>
</tr>
</tbody>
</table>
Table B-11  Conversation Alarm Thresholds (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actions</td>
<td>From the lists, choose a Rising action and a Falling action (optional). See Viewing Alarm Actions, page 3-38 for information on setting up alarm actions.</td>
</tr>
<tr>
<td>Conversation Metrics (per second)</td>
<td>Choose from one of the six metrics, and then enter a Rising threshold and a Falling threshold.</td>
</tr>
</tbody>
</table>

Application Alarm Thresholds Configuration Window

Table B-11 describes the fields on the Application Alarm Thresholds Configuration window.

Table B-12  Application Alarm Thresholds

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Give the Application Alarm Threshold a name.</td>
</tr>
<tr>
<td>Site</td>
<td>Choose a site from the list. See Configuring Sites, page 3-50 for information on setting up a site.</td>
</tr>
<tr>
<td>Application</td>
<td>Choose an application from the list. You can start typing the first few characters to narrow the list.</td>
</tr>
<tr>
<td>DSCP</td>
<td>Choose a DSCP value 0-63, or Any.</td>
</tr>
<tr>
<td>Severity</td>
<td>Choose High or Low. These will display on the Alarm Summary dashboard (Monitor &gt; Overview &gt; Alarm Summary), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td>Actions</td>
<td>From the lists, choose a Rising action and a Falling action (optional). See Configuring Alarm Actions, page 3-37 for information on setting up alarm actions.</td>
</tr>
<tr>
<td>Application Metrics (per second)</td>
<td>Choose Bits or Bytes, and then enter a Rising threshold and a Falling threshold.</td>
</tr>
</tbody>
</table>

Response Time Alarm Threshold Configuration Window

Table B-13 describes the fields on the Response Time Alarm Threshold Configuration window.

Table B-13  Response Time Thresholds

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Give the Response Time Alarm Threshold a name.</td>
</tr>
<tr>
<td>Application</td>
<td>Choose an application from the list. You can start typing the first few characters to narrow the list.</td>
</tr>
<tr>
<td>Severity</td>
<td>Choose High or Low. These will display on the Alarm Summary dashboard (Monitor &gt; Overview &gt; Alarm Summary), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td>Client Site/Host</td>
<td>Make a selection from the lists. See Configuring Sites, page 3-50 for information on setting up a site.</td>
</tr>
<tr>
<td>Server Site/Host</td>
<td>Make a selection from the lists, or leave as “Any.” See Configuring Sites, page 3-50 for information on setting up a site.</td>
</tr>
</tbody>
</table>
GUI Field Descriptions

### DSCP Alarm Threshold Configuration Window

Table B-14 describes the fields on the DSCP Alarm Threshold Configuration window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Give the DSCP Alarm Threshold a name.</td>
</tr>
<tr>
<td>Site</td>
<td>Choose a site from the list. See Configuring Sites, page 3-50 for information on setting up a site.</td>
</tr>
<tr>
<td>DSCP</td>
<td>Choose a DSCP value from the list.</td>
</tr>
<tr>
<td>Severity</td>
<td>Choose High or Low. These will display on the Alarm Summary dashboard (Monitor &gt; Overview &gt; Alarm Summary), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td>Actions</td>
<td>From the drop-down lists, choose a Rising action and a Falling action (optional).</td>
</tr>
<tr>
<td>DSCP Metrics (per second)</td>
<td>Choose one of the metric types from the list, and then enter a Rising threshold and a Falling threshold.</td>
</tr>
</tbody>
</table>

### RTP Streams Threshold Configuration Window

Table B-15 describes the fields on the RTP Threshold Configuration window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Give the RTP Streams Alarm Threshold a name.</td>
</tr>
<tr>
<td>Severity</td>
<td>Choose High or Low. These will display on the Alarm Summary dashboard (Monitor &gt; Overview &gt; Alarm Summary), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td>Codec</td>
<td>Choose a Codec from the list.</td>
</tr>
<tr>
<td>Source Site/Host</td>
<td>Make a selection from the drop-down lists, or leave as “Any.” See Configuring Sites, page 3-50 for information on setting up a site.</td>
</tr>
<tr>
<td>Severity</td>
<td>Choose High or Low. These will display on the Alarm Summary dashboard (Monitor &gt; Overview &gt; Alarm Summary), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
</tbody>
</table>
GUI Field Descriptions

### Voice Signaling Threshold Configuration Window

**Table B-15**  
*RTP Streams Thresholds (continued)*

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actions</td>
<td>From the drop-down lists, choose a Rising action and a Falling action (optional). See Viewing Alarm Actions, page 3-38 for information on setting up alarm actions.</td>
</tr>
</tbody>
</table>
| RTP Stream Metrics | Choose a metric from the list:  
  - Jitter: Variation of packet arrival time compared to expected arrival time.  
  - Adjusted packet loss percent: Percent of packet loss which includes packets actually lost and packets that arrived beyond the expected buffering capability of the endpoint.  
  - Actual packet loss percent: Percent of packets that Prime NAM has never seen.  
  - MOS: Mean opinion score that is composed of both jitter and adjusted packet loss.  
  - Concealment seconds: Number of seconds in which Prime NAM detected packets lost.  
  - Severe concealment seconds: Number of seconds in which Prime NAM detected packets lost of more than 5%. Enter a Rising threshold and a Falling threshold. |

**Voice Signaling Threshold Configuration Window**

*Table B-16* describes the fields on the Voice Signaling Threshold Configuration window.

**Table B-16**  
*Voice Signaling Thresholds*

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Give the Voice Signaling Alarm Threshold a name.</td>
</tr>
<tr>
<td>Severity</td>
<td>Choose High or Low. These will display on the Alarm Summary dashboard (<em>Monitor &gt; Overview &gt;Alarm Summary</em>), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td>Actions</td>
<td>Choose a Rising action and a Falling action from the lists (optional). See Viewing Alarm Actions, page 3-38 for information on setting up alarm actions.</td>
</tr>
</tbody>
</table>
| Voice Signaling Metrics | Choose Jitter to enable an alarm when the software detects jitter to be more than the value set here.  
Check Packet Loss % to enable an alarm when the software detects Packet Loss percentage to be outside of the values you entered. |
**NetFlow Interface Threshold Configuration Window**

Table B-17 describes the fields on the Network Interface Threshold Configuration window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Give the NetFlow Interface Alarm Threshold a name.</td>
</tr>
<tr>
<td>Data Source</td>
<td>Choose a data source from the list.</td>
</tr>
<tr>
<td>Interface</td>
<td>Choose an interface from the list.</td>
</tr>
<tr>
<td>Direction</td>
<td>Choose Ingress or Egress.</td>
</tr>
<tr>
<td>Severity</td>
<td>Choose High or Low. These will display on the Alarm Summary dashboard (Monitor &gt; Overview &gt; Alarm Summary), where you can choose to view High, Low, or High and Low alarms.</td>
</tr>
<tr>
<td>Actions</td>
<td>Choose a Rising action and a Falling action from the lists (optional). See Viewing Alarm Actions, page 3-38 for information on setting up alarm actions.</td>
</tr>
<tr>
<td>Application Metrics (per second)</td>
<td>Choose Bytes or Packets, and enter a Rising and Falling threshold.</td>
</tr>
</tbody>
</table>

**Router System Information Window**

Table B-18 describes the fields on the Router System Information window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the device.</td>
</tr>
<tr>
<td>Hardware</td>
<td>Hardware description of the router.</td>
</tr>
<tr>
<td>Managed Device Software Version</td>
<td>Current software version of the router.</td>
</tr>
<tr>
<td>Managed Device System Uptime</td>
<td>Total time the router or switch has been running.</td>
</tr>
<tr>
<td>Location</td>
<td>Physical location of the router.</td>
</tr>
<tr>
<td>Contact</td>
<td>Name of the network administrator for the router.</td>
</tr>
<tr>
<td>Managed Device</td>
<td>IP address of the router.</td>
</tr>
<tr>
<td>SNMP v1/v2c RW Community String</td>
<td>Name of the SNMP read-write community string configured on the router.</td>
</tr>
<tr>
<td>Verify String</td>
<td>Verify the SNMP.</td>
</tr>
<tr>
<td>Enable SNMP V3</td>
<td>Check the check box to enable SNMP Version 3. If SNMPv3 is not enabled, the community string is used.</td>
</tr>
<tr>
<td>Mode: No Auth, No Priv</td>
<td>SNMP will be used in a mode with no authentication and no privacy.</td>
</tr>
<tr>
<td>Mode: Auth, No Priv</td>
<td>SNMP will be used in a mode with authentication, but no privacy.</td>
</tr>
<tr>
<td>Mode: Auth and Priv</td>
<td>SNMP will be used in a mode with both authentication and privacy.</td>
</tr>
<tr>
<td>User Name</td>
<td>Enter a username, which will match the username configured on the device.</td>
</tr>
</tbody>
</table>
### Table B-18  Router/Managed Device System Information (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auth Password</td>
<td>Enter the authentication password associated with the username that was configured on the device. Verify the password.</td>
</tr>
<tr>
<td>Auth Algorithm</td>
<td>Choose the authentication standard which is configured on the device (MD5 or SHA-1).</td>
</tr>
<tr>
<td>Privacy Password</td>
<td>Enter the privacy password, which is configured on the device. Verify the password.</td>
</tr>
<tr>
<td>Privacy Algorithm</td>
<td>Enter the privacy algorithm, which is configured on the device (AES or DES).</td>
</tr>
</tbody>
</table>

### Switch/Managed Device System Information

Table B-19 describes the fields on the Switch System Information window.

### Table B-19  Switch Device Information

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SNMP Test information</td>
<td>Displays the IP address of the NAM and the switch on which the SNMP test occurred.</td>
</tr>
<tr>
<td>Name</td>
<td>Name of the device.</td>
</tr>
<tr>
<td>Hardware</td>
<td>Hardware description of the device.</td>
</tr>
<tr>
<td>Supervisor Software Version</td>
<td>Current software version of the Supervisor.</td>
</tr>
<tr>
<td>System Uptime</td>
<td>Total time the device has been running.</td>
</tr>
<tr>
<td>SNMP read from chassis</td>
<td>SNMP read test result.</td>
</tr>
<tr>
<td>SNMP write to chassis</td>
<td>SNMP write test result.</td>
</tr>
<tr>
<td>Mini-RMON on chassis</td>
<td>For Cisco IOS devices, displays the status if there are any ports with Mini-RMON configured (Available) or not (Unavailable).</td>
</tr>
<tr>
<td>NBAR on chassis</td>
<td>Displays if NBAR is available on the device.</td>
</tr>
<tr>
<td>VLAN Traffic Statistics on chassis</td>
<td>Displays if VLAN data is Available or Unavailable.</td>
</tr>
<tr>
<td>NetFlow Status</td>
<td>For Catalyst 6500 Series devices running Cisco IOS, if NetFlow is configured on the device, Remote export to NAM &lt;address&gt; on port &lt;number&gt; displays, otherwise the status will display Configuration unavailable.</td>
</tr>
</tbody>
</table>

*Note*  
Catalyst 6500 Series switches require a Supervisor 2 or MSFC2 card.
GUI Field Descriptions

**Table B-20  NBAR Interface Details**

<table>
<thead>
<tr>
<th>Field / Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable (check box)</td>
<td>Check indicates that NBAR is enabled.</td>
</tr>
<tr>
<td>Interface</td>
<td>Name of the interface. Depending on the IOS running on the Supervisor, port</td>
</tr>
<tr>
<td></td>
<td>names are displayed differently.</td>
</tr>
<tr>
<td></td>
<td>Newer versions of IOS software display a port name as Gi2/1 to represent a</td>
</tr>
<tr>
<td></td>
<td>Gigabit port on module 2 port 1.</td>
</tr>
<tr>
<td></td>
<td>In the Virtual Switch software (VSS), a port name might be displayed as</td>
</tr>
<tr>
<td></td>
<td>Gi1/2/1 to represent a Gigabit port on switch 1, module 2, port 1.</td>
</tr>
<tr>
<td>Interface Description</td>
<td>Description of the interface.</td>
</tr>
</tbody>
</table>

**Site Configuration Window**

Table B-21 describes the fields on the Site Configuration window.

**Table B-21  Site Configuration**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Unique text string for naming a site.</td>
</tr>
<tr>
<td>Description</td>
<td>Optional text string for describing site.</td>
</tr>
<tr>
<td>Disable Site (check box)</td>
<td>If you check this check box, the software will skip this site when classifying traffic. This is useful if the site is no longer active, but the user would still like to access historical site data in the database. Otherwise, the user should delete sites that are not needed.</td>
</tr>
<tr>
<td>Subnet</td>
<td>IP address subnet (IPv4/IPv6 address and mask); for example, 10.1.1.0/24. Click the blue i to get information about Site Rules. You can click the Detect button to tell the software to look for subnets in the traffic. See Detecting Site Subnets, page 3-50.</td>
</tr>
<tr>
<td>Data Source</td>
<td>Specify the data source from where the site traffic originates. Leave this field blank if the site traffic can come from multiple data sources.</td>
</tr>
</tbody>
</table>
Subnet Detection Window

Table B-22 describes the fields on the Subnet Detection window.

Table B-22  Subnet Detection

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Subnet Mask</td>
<td>Enter the subnet mask.</td>
</tr>
<tr>
<td>Data Source</td>
<td>Choose the data source in which you would like to detect subnets.</td>
</tr>
<tr>
<td>Interface</td>
<td>Choose the interface in which you would like to detect subnets.</td>
</tr>
<tr>
<td>Filter Subnets Within Network</td>
<td>Enter an IPv4 or IPv6 address</td>
</tr>
<tr>
<td>Unassigned Site (check box)</td>
<td>The “Unassigned” site includes any that do not match any of your site configurations. Sites are classified at the time of packet processing.</td>
</tr>
</tbody>
</table>

Note
If the bit mask is 32 or less, the software will detect an IPv4 subnet. If the bit mask is between 33 and 64, then it will detect an IPv6 subnet.

Sites Window

Table B-23 describes the fields on the Sites window.

Table B-23  Sites Window

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the site.</td>
</tr>
<tr>
<td>Description</td>
<td>Description of what the site includes.</td>
</tr>
<tr>
<td>Rule</td>
<td>Lists the first rule assigned to the selected site. If you see periods next to the site rule (...), then multiple rules were created for that site. To see the list of all rules, click the quick view icon (after highlighting the site, click the small arrow on the right).</td>
</tr>
<tr>
<td>Status</td>
<td>Shows if the site is Enabled or Disabled.</td>
</tr>
</tbody>
</table>

Add NetFlow Interface Window

Table B-24 describes the fields on the NetFlow Interface Add window.

Table B-24  Add NetFlow Interface Capacity

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device</td>
<td>Enter the IPv4 or IPv6 address.</td>
</tr>
<tr>
<td>ifIndex</td>
<td>Unique identifying number associated with a physical or logical interface. Valid characters: 0-9.</td>
</tr>
<tr>
<td>ifName</td>
<td>Name of the interface. Valid characters are A-Z, a-z, 0-9</td>
</tr>
<tr>
<td>ifSpeed(Mbps)</td>
<td>An estimate of the interface’s current bandwidth in bits per second.</td>
</tr>
</tbody>
</table>
DSCP Group Setup Dialog Box

Table B-25 describes the fields on the DSCP Group Setup dialog box.

Table B-25  DSCP Group Setup Dialog Box

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the profile.</td>
<td>Enter the name of the profile you are creating. The maximum is 64 characters.</td>
</tr>
<tr>
<td>Label Format</td>
<td>DSCP</td>
<td>DSCP numbers from 0 to 63. After selecting the DSCP radio button, you can freely choose any of the 64 possible values and assign them to Groups.</td>
</tr>
<tr>
<td></td>
<td>AF / EF / CS</td>
<td>Assured Forwarding (AF) guarantees a certain amount of bandwidth to an AF class and allows access to extra bandwidth. Expedited Forwarding (EF) is used for traffic that is very sensitive to delay, loss and jitter, such as voice or video traffic. Class Selector (CS) the last 3 bits of the 6-bit DSCP field, so these correspond to DSCP 0 through DSCP 7.</td>
</tr>
<tr>
<td>Bit Field</td>
<td>Six bits in the IP header of a packet.</td>
<td></td>
</tr>
</tbody>
</table>

DSCP Group Label Formats

Table B-25 describes the DSCP Group label formats.

Table B-26  DSCP Group Label Formats

<table>
<thead>
<tr>
<th>DSCP Format (DSCP 0 through DSCP 63)</th>
<th>AF/EF/CS Format</th>
<th>Bit Field Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>DSCP 0</td>
<td>-</td>
<td>000000</td>
</tr>
<tr>
<td>DSCP 8</td>
<td>CS1</td>
<td>001000</td>
</tr>
<tr>
<td>DSCP 10</td>
<td>AF11</td>
<td>001010</td>
</tr>
<tr>
<td>DSCP 12</td>
<td>AF12</td>
<td>001100</td>
</tr>
<tr>
<td>DSCP 14</td>
<td>AF13</td>
<td>001110</td>
</tr>
<tr>
<td>DSCP 16</td>
<td>CS2</td>
<td>010000</td>
</tr>
<tr>
<td>DSCP 18</td>
<td>AF21</td>
<td>010010</td>
</tr>
<tr>
<td>DSCP 20</td>
<td>AF22</td>
<td>010100</td>
</tr>
<tr>
<td>DSCP 22</td>
<td>AF23</td>
<td>010110</td>
</tr>
<tr>
<td>DSCP 24</td>
<td>CS3</td>
<td>011000</td>
</tr>
<tr>
<td>DSCP 26</td>
<td>AF31</td>
<td>011010</td>
</tr>
<tr>
<td>DSCP 28</td>
<td>AF32</td>
<td>011100</td>
</tr>
<tr>
<td>DSCP 30</td>
<td>AF33</td>
<td>011110</td>
</tr>
<tr>
<td>DSCP 32</td>
<td>CS4</td>
<td>100000</td>
</tr>
<tr>
<td>DSCP 34</td>
<td>AF41</td>
<td>100010</td>
</tr>
</tbody>
</table>
Table B-26  DSCP Group Label Formats (continued)

<table>
<thead>
<tr>
<th>DSCP Format (DSCP 0 through DSCP 63)</th>
<th>AF/EF/CS Format</th>
<th>Bit Field Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>DSCP 36</td>
<td>AF42</td>
<td>100100</td>
</tr>
<tr>
<td>DSCP 38</td>
<td>AF43</td>
<td>100110</td>
</tr>
<tr>
<td>DSCP 40</td>
<td>CS5</td>
<td>101000</td>
</tr>
<tr>
<td>DSCP 46</td>
<td>EF</td>
<td>101110</td>
</tr>
<tr>
<td>DSCP 48</td>
<td>CS6</td>
<td>110000</td>
</tr>
<tr>
<td>DSCP 56</td>
<td>CS7</td>
<td>111000</td>
</tr>
</tbody>
</table>

Table B-27  Create or Edit Applications

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Unique 1 to 64 character descriptive name.</td>
</tr>
<tr>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>Selector</td>
<td>(Optional) Leave blank. An arbitrary number up to 4-digits, unique within an</td>
</tr>
<tr>
<td></td>
<td>engine-id. It is automatically assigned if left blank. Identification number</td>
</tr>
<tr>
<td></td>
<td>is autogenerated if left blank. Range is from 1 to 65535. This allows you</td>
</tr>
<tr>
<td></td>
<td>to configure applications consistently across multiple NAMs, so that the</td>
</tr>
<tr>
<td></td>
<td>same user-created application is exported with the same value. This should</td>
</tr>
<tr>
<td></td>
<td>be used when configuring the same custom applications on multiple NAMs.</td>
</tr>
<tr>
<td></td>
<td>The application tag for user-created applications is a combination of the</td>
</tr>
<tr>
<td></td>
<td>engine ID and the Selector. The 32 bit is generated by using the engine ID</td>
</tr>
<tr>
<td></td>
<td>as the highest order byte, and the Selector makes up the other 3 bytes. For</td>
</tr>
<tr>
<td></td>
<td>standard application/protocols, the application tag is predefined.</td>
</tr>
<tr>
<td>Application</td>
<td>Select application type: Protocol, HTTP URL-based or Server IP Address.</td>
</tr>
<tr>
<td>Classification Rule</td>
<td></td>
</tr>
<tr>
<td>Application Rule:</td>
<td>Add the application protocol and port you want to track.</td>
</tr>
<tr>
<td>Protocol/Port</td>
<td>Protocol—Lists predefined protocols. If your option is not included, you</td>
</tr>
<tr>
<td></td>
<td>can create a custom URL-based application classification.</td>
</tr>
<tr>
<td></td>
<td>Port—Enter the port number or port number range to monitor. The port is an</td>
</tr>
<tr>
<td></td>
<td>arbitrary number you assign to handle the additional ports for the protocol</td>
</tr>
<tr>
<td></td>
<td>family. This protocol number must be unique so it does not conflict with</td>
</tr>
<tr>
<td></td>
<td>standard protocol/port assignments. The port number range will vary</td>
</tr>
<tr>
<td></td>
<td>depending on the protocol type selected. You can create additional ports</td>
</tr>
<tr>
<td></td>
<td>to enable Prime NAM to handle additional traffic for standard applications.</td>
</tr>
</tbody>
</table>
Table B-27  Create or Edit Applications (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>
| Application Rule: HTTP URL | Create custom URL-based applications by selecting this option. Enter at least one of the values below.  
|                        | **URL Host**—The host name identified in the header from which the traffic is originating.  
|                        | **URL Path**—The specific URL path that identifies the traffic.  
|                        | **Content Type**—Only a valid selection in NAM classification mode.  
| Engine ID              | Identifies the type of application (including ethtype, iana-14, iana-13, lic, L7, or custom).  
| Application Tag        | System generated tag which can be used when multiple NAMs are being monitored.  
| Description            | (Optional) Custom description to define your application. Limited to 75 characters.  
| Status                 | Active means that network traffic is being analyzed. Inactive means that the application is not being analyzed, possibly due to a duplication of effort. The Interactive Report filter may still list inactive applications if there is any historical data for the inactive application in the database, but it is not collecting new data.  

Applications Window

Table B-28 describes the fields on the Applications Window.

Table B-28  Applications

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>
| Application  | Unique 1 to 64 character descriptive name.  
| Rule         | Displays application type: Protocol, HTTP URL-based or Server IP Address.  
| Selector     | An arbitrary number up to 4-digits, unique within an engine-id. It is automatically assigned if left blank.  
|              | This allows you to configure applications consistently across multiple NAMs, so that the same user-created application is exported with the same value. This should be used when configuring the same custom applications on multiple NAMs.  
|              | The application tag for user-created applications is a combination of the engine ID and the selector. The 32 bit number is generated by using the engine ID as the highest order byte, and the selector makes up the other 3 bytes. For standard application/protocols, the application tag is predefined.  
| Engine ID    | Identifies the type of application (including ethtype, iana-14, iana-13, lic, L7, or custom)  
| Application ID | System generated tag which can be used when multiple NAMs are being monitored.  


### Table B-29  URL-Based Applications

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Index</td>
<td>A unique number (1-64) of each URL-based application. You can define up to 64 URL-based applications in NAM.</td>
</tr>
<tr>
<td>Host</td>
<td>Matching criteria in the host portion of the URL string appears in HTTP packets. This match is a POSIX Regular Expression¹.</td>
</tr>
<tr>
<td>Path</td>
<td>Matching criteria in the path portion of the URL string appears in HTTP packets. This match is a POSIX Regular Expression¹.</td>
</tr>
<tr>
<td>Content-Type</td>
<td>Matching criteria in the Content-Type field of the HTTP packets. This match is a POSIX Regular Expression¹.</td>
</tr>
<tr>
<td>Protocol Description</td>
<td>Description of this URL-based application.</td>
</tr>
</tbody>
</table>

¹. A regular expression provides a concise and flexible means for matching strings of text, such as particular characters, words, or patterns of characters. A regular expression is written in a formal language that can be interpreted by a regular expression processor, a program that either serves as a parser generator or examines text and identifies parts that match the provided specification. The IEEE POSIX Basic Regular Expressions (BRE) standard (released alongside an alternative flavor called Extended Regular Expressions or ERE) was designed mostly for backward compatibility with the traditional (Simple Regular Expression) syntax but provided a common standard which has since been adopted as the default syntax of many Unix regular expression tools, though there is often some variation or additional features. Many such tools also provide support for ERE syntax with command line arguments. In the BRE syntax, most characters are treated as literals - they match only themselves (in other words, a matches "a").

### Table B-30  Response Time Configuration Window

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Range 1 (µs)</td>
<td>Upper response time limit for the first container</td>
<td>Enter a number in microseconds. The default is 1 to 1,000 µs</td>
</tr>
<tr>
<td>Range 2 (µs)</td>
<td>Upper response time limit for the second container</td>
<td>Enter a number in microseconds. The default is 1,001 to 5,000 µs</td>
</tr>
<tr>
<td>Range 3 (µs)</td>
<td>Upper response time limit for the third container</td>
<td>Enter a number in microseconds. The default is 5,001 to 10,000 µs</td>
</tr>
</tbody>
</table>
Voice Monitor Setup Window

Table B-31 describes the fields on the Voice Monitor Setup Window.

**Table B-31 Voice Monitor Setup Window**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Voice Monitoring</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Enabled</td>
<td>Enables voice monitoring. Ensure this check box is selected if you are interested in voice monitoring.</td>
<td></td>
</tr>
<tr>
<td>MOS Values</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Excellent</td>
<td>MOS scores listed here indicate excellent quality voice transmission (where 5.0 is the highest score). The default setting considers the range between 4.34 to 5.0 as excellent.</td>
<td></td>
</tr>
<tr>
<td>Good</td>
<td>MOS score listed here indicate good quality voice transmission. The default setting considers the range between 4.03 to 4.33 as good.</td>
<td></td>
</tr>
<tr>
<td>Fair</td>
<td>MOS score listed here indicate fair quality voice transmission. The default setting considers the range between 3.6 to 4.02 as fair.</td>
<td></td>
</tr>
<tr>
<td>Poor</td>
<td>MOS score listed here indicate poor quality voice transmission. The default setting considers the range between 0.0 and 3.59 as poor. This default cannot be changed.</td>
<td></td>
</tr>
</tbody>
</table>
**URL Collection Configuration Window**

*Table B-32* describes the fields on the URL Collection Configuration Window.

*Table B-32  URL Collection Configuration Dialog Box*

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Source</td>
<td>Identifies type of traffic incoming from the application.</td>
<td>Select one of the options from the drop-down box.</td>
</tr>
<tr>
<td>Max Entries</td>
<td>Maximum number of URLs to collect.</td>
<td>Select one of the following options from the drop-down box:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 100</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 500</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 1000</td>
</tr>
<tr>
<td>Match only</td>
<td>The application URL to match.</td>
<td>Optional parameter to limit collection of URLs that match the regular expression of this field.</td>
</tr>
</tbody>
</table>

**Monitor User Interface Windows**

This section describes the following window field descriptions:

- Applications Detail
- Application Groups Detail
- Client-Server Application Responses Window
- Client-Server Application Transactions Window
- Client-Server Network Responses Window
- DSCP Detail
- Host Detail
- Interfaces Stats Table
- Last 50 Alarms
- Server Application Responses Metrics
- Server Application Transactions Metrics
- Server Network Responses Window

**Applications Detail Window**

*Table B-33* describes the fields in this window.

*Table B-33  Applications Detail*

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application</td>
<td>Software services classified by NAM from analyze and monitor traffic.</td>
</tr>
<tr>
<td>Application Group</td>
<td>The application group (set of applications that can be monitored as a whole).</td>
</tr>
</tbody>
</table>
Table B-33 Applications Detail (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bytes/sec</td>
<td>Traffic rate; number of bytes per second</td>
</tr>
<tr>
<td>Packets/sec</td>
<td>Traffic rate; number of packets per second</td>
</tr>
</tbody>
</table>

Application Groups Detail Window

Table B-34 describes the fields in this window.

Table B-34 Application Groups Detail

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application Group</td>
<td>The application group (set of applications that can be monitored as a whole).</td>
</tr>
<tr>
<td>Site</td>
<td>Applicable site (or Unassigned if no site)</td>
</tr>
<tr>
<td>Bytes/sec</td>
<td>Traffic rate; number of bytes per second</td>
</tr>
<tr>
<td>Packets/sec</td>
<td>Traffic rate; number of packets per second</td>
</tr>
</tbody>
</table>

Application Response Time (ART) Metrics

Table B-35 describes the metrics measured for response time.

Table B-35 Application Response Time (ART) Metrics

<table>
<thead>
<tr>
<th>Metric</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average Response Time</td>
<td>Response Time is the time between the client request and the first response packet from the server, as observed at the NAM probing point. Increases in the response time usually indicate problems with server resources, such as the CPU, Memory, Disk, or I/O due to a lack of necessary resources or a poorly written application. This and other Response Time metrics are in microseconds (μs) units.</td>
</tr>
<tr>
<td>Min Response Time</td>
<td></td>
</tr>
<tr>
<td>Max Response Time</td>
<td></td>
</tr>
<tr>
<td>Number of Responses</td>
<td>Total number of request-response pairs observed during the monitoring interval</td>
</tr>
<tr>
<td>Number of Late Responses</td>
<td>Total number of responses that exceed the Max Response Time</td>
</tr>
<tr>
<td>Number of Responses 1</td>
<td>Number of responses with a response time less than RspTime1 threshold</td>
</tr>
<tr>
<td>Number of Responses 2</td>
<td>Number of responses with response time less than RspTime2 and larger than RspTime1</td>
</tr>
<tr>
<td>Number of Responses 3</td>
<td>Number of responses with response time less than RspTime3 and larger than RspTime2</td>
</tr>
<tr>
<td>Number of Responses 4</td>
<td>Number of responses with response time less than RspTime4 and larger than RspTime3</td>
</tr>
<tr>
<td>Number of Responses 5</td>
<td>Number of responses with response time less than RspTime5 and larger than RspTime4</td>
</tr>
<tr>
<td>Number of Responses 6</td>
<td>Number of responses with response time less than RspTime6 and larger than RspTime5</td>
</tr>
<tr>
<td>Number of Responses 7</td>
<td>Number of responses with response time less than LateRsp and larger than RspTime6</td>
</tr>
<tr>
<td>Client Bits</td>
<td>Number of TCP payload bits sent from the client(s) during the monitoring interval</td>
</tr>
<tr>
<td>Server Bits</td>
<td>Number of TCP payload bits sent from the server(s) during the monitoring interval</td>
</tr>
<tr>
<td>Client Packets</td>
<td>Number of TCP packets sent from the client(s) during the monitoring interval</td>
</tr>
<tr>
<td>Server Packets</td>
<td>Number of TCP packets sent from the server(s) during the monitoring interval</td>
</tr>
<tr>
<td>Average number of concurrent connections</td>
<td>Average number of concurrent TCP connections during the reporting interval</td>
</tr>
<tr>
<td>Metric</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Number of new connections</td>
<td>Number of new TCP connections made (TCP 3-way handshake) during the monitoring interval</td>
</tr>
<tr>
<td>Number of closed connections</td>
<td>Number of TCP connections closed during the monitoring interval</td>
</tr>
<tr>
<td>Number of unresponsive</td>
<td>Number of TCP connection requests (SYN) that are not responded during the monitoring interval</td>
</tr>
<tr>
<td>connections</td>
<td></td>
</tr>
<tr>
<td>Number of refused connections</td>
<td>Number of TCP connection requests (SYN) that are refused during the monitoring interval</td>
</tr>
<tr>
<td>Average Connection duration</td>
<td>Average duration of TCP connections during the monitoring interval</td>
</tr>
<tr>
<td>Average Server Response Time</td>
<td>Server Response Time is the time it takes an application server (for example, a web server) to respond to a request. This is the server think time, which is the time between the client request arriving at the server and the first response packet being returned by the server. Increases in the server response time usually indicate problems with application and/or server resources, such as the CPU, Memory, Disk, or I/O.</td>
</tr>
<tr>
<td>Min Server Response Time</td>
<td></td>
</tr>
<tr>
<td>Max Server Response Time</td>
<td></td>
</tr>
<tr>
<td>Average Network Time</td>
<td>Network time between a client and a server. Network Time is the sum of Client Network Time and Server Network Time. NAM measures the Network Time using TCP 3-way handshakes. If there are no new TCP connections made during the monitoring interval, this metric is not reported.</td>
</tr>
<tr>
<td>Min Network Time</td>
<td></td>
</tr>
<tr>
<td>Max Network Time</td>
<td></td>
</tr>
<tr>
<td>Average Client Network Time</td>
<td>Client Network Time is the network time between a client and the NAM switch or router.</td>
</tr>
<tr>
<td>Min Client Network Time</td>
<td>In WAAS monitoring, Client Network Time from a WAE client data source represents the network RTT between the client and its edge WAE, while Client Network Time from the WAE server data source represents the WAN RTT (between the edge and core WAEs).</td>
</tr>
<tr>
<td>Max Client Network Time</td>
<td></td>
</tr>
<tr>
<td>Average Server Network Time</td>
<td>Server Network Time is the network time between a server and NAM probing point.</td>
</tr>
<tr>
<td>Min Server Network Time</td>
<td>In WAAS monitoring, Server Network Time from a server data source represents the network time between the server and its core WAE.</td>
</tr>
<tr>
<td>Max Server Network Time</td>
<td></td>
</tr>
<tr>
<td>Average Total Response Time</td>
<td>Total Response Time is the total amount of time between the client request and when the client receives the first response packet from the server.</td>
</tr>
<tr>
<td>Min Total Response Time</td>
<td>Use Total Response Time with care because it is not measured directly and mixes the server response time metric with the network time metric.</td>
</tr>
<tr>
<td>Max Total Response Time</td>
<td></td>
</tr>
<tr>
<td>Average Transaction Time</td>
<td>Transaction Time is the total amount of time between the client request and the final response packet from the server. Transaction times may vary depending upon client usages and application types. Transaction Time is a key indicator for monitoring client experiences and detecting application performance anomalies.</td>
</tr>
<tr>
<td>Min Transaction Time</td>
<td></td>
</tr>
<tr>
<td>Max Transaction Time</td>
<td></td>
</tr>
<tr>
<td>Number of Transactions</td>
<td>The number of transactions completed during the monitoring interval.</td>
</tr>
<tr>
<td>Average Data Transmission Time</td>
<td>Elapsed time from the first server-response packet to the last server-response packet, excluding retransmission time.</td>
</tr>
<tr>
<td>Average Data Time</td>
<td>Data Time: Average data time portion of transaction time.</td>
</tr>
<tr>
<td>Packets Retransmitted</td>
<td>Number of retransmitted packets detected during the monitoring interval</td>
</tr>
<tr>
<td>Bits Retransmitted</td>
<td>Number of retransmitted bits detected during the monitoring interval</td>
</tr>
<tr>
<td>Average Retransmission Time</td>
<td>Average time to retransmit lost packets per transaction</td>
</tr>
</tbody>
</table>
### Table B-35  **Application Response Time (ART) Metrics (continued)**

<table>
<thead>
<tr>
<th>Metric</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client ACK Round Trip Time</td>
<td>Average network time for the client to acknowledge (ACK) a server data packet as observed at NAM probing point</td>
</tr>
<tr>
<td>Number of Client ACK Round Trips</td>
<td>Number of client ACK RTs observed during the monitoring interval</td>
</tr>
</tbody>
</table>

**Client Server Application Responses Window**

Table B-36 provides definitions of each field of the Client-Server Application Responses window.

### Table B-36  **Client-Server Application Responses Window**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client Site</td>
<td>Name of the client site</td>
</tr>
<tr>
<td>Server Site</td>
<td>Name of the server site</td>
</tr>
<tr>
<td>Data Source</td>
<td>Name of the data source.</td>
</tr>
<tr>
<td>VLAN</td>
<td>VLAN</td>
</tr>
<tr>
<td>Server</td>
<td>Name or IP address of the server.</td>
</tr>
<tr>
<td>Client</td>
<td>Host address of the client.</td>
</tr>
<tr>
<td>Application</td>
<td>Application being used by server.</td>
</tr>
<tr>
<td>Number of Responses</td>
<td>Total number of responses observed during the monitoring interval</td>
</tr>
<tr>
<td>Minimum Client Network Time (ms)</td>
<td>Minimum network time measured by analyzing TCP three-way handshake sequence</td>
</tr>
<tr>
<td>Average Client Network Time (ms)</td>
<td>Average network time measured by analyzing TCP three-way handshake sequence</td>
</tr>
<tr>
<td>Maximum Client Network Time (ms)</td>
<td>Maximum network time measured by analyzing TCP three-way handshake sequence</td>
</tr>
<tr>
<td>Minimum Server Network Time (ms)</td>
<td>Minimum network time between a server and NAM probing point.</td>
</tr>
<tr>
<td>Average Server Network Time (ms)</td>
<td>Average network time between a server and NAM probing point.</td>
</tr>
<tr>
<td>Maximum Server Network Time (ms)</td>
<td>Maximum network time between a server and NAM probing point.</td>
</tr>
<tr>
<td>Minimum Total Response Time (ms)</td>
<td>The total amount of time between the client request and the final response packet from the server.</td>
</tr>
<tr>
<td>Average Total Time (ms)</td>
<td>Average time (ms) elapsed from the start of a client request to the completion of server response. Transaction times might vary significantly depending upon application types. Relative thresholds are useful in this situation. Transaction time is a key indicator when detecting application performance anomalies.</td>
</tr>
<tr>
<td>Maximum Total Time (ms)</td>
<td>The total amount of time between the client request and the final response packet from the server.</td>
</tr>
</tbody>
</table>
### Client-Server Application Transactions Window

Table B-37 provides definitions of each field of the Client-Server Application Transactions window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client Site</td>
<td>Name of the client site.</td>
</tr>
<tr>
<td>Server Site</td>
<td>Name of the server site.</td>
</tr>
<tr>
<td>Data Source</td>
<td>Name of the data source.</td>
</tr>
<tr>
<td>VLAN</td>
<td>VLAN</td>
</tr>
<tr>
<td>Server</td>
<td>Name or IP address of the server.</td>
</tr>
<tr>
<td>Client</td>
<td>Host address of the client.</td>
</tr>
<tr>
<td>Application</td>
<td>Application being used by server.</td>
</tr>
<tr>
<td>Number of Transactions</td>
<td>Total number of transactions observed during the monitoring interval</td>
</tr>
<tr>
<td>Average Transaction Time (ms)</td>
<td>Average time (ms) elapsed from the start of a client request to the completion of server response. Transaction times might vary significantly depending upon application types. Relative thresholds are useful in this situation. Transaction time is a key indicator when detecting application performance anomalies.</td>
</tr>
<tr>
<td>Average Server Response Time (ms)</td>
<td>Amount of time it takes a server to send the initial response to a client request as seen by the NAM.</td>
</tr>
<tr>
<td>Average Data Transmission Time (ms)</td>
<td>Elapsed time from the first server-response packet to the last server-response packet, excluding retransmission time.</td>
</tr>
<tr>
<td>Average Retransmission Time (ms)</td>
<td>Average time to retransmit lost packets per transaction</td>
</tr>
<tr>
<td>Client ACK Round Trip Time (ms)</td>
<td>Average network time for the client to acknowledge (ACK) a server data packet as observed at NAM probing point</td>
</tr>
</tbody>
</table>

### Client-Server Network Responses Window

Table B-38 describes the fields of the Server-Client Network Response Time window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client Site</td>
<td>Name of the client site.</td>
</tr>
<tr>
<td>Server Site</td>
<td>Name of the server site.</td>
</tr>
<tr>
<td>Data Source</td>
<td>Name of the data source.</td>
</tr>
<tr>
<td>VLAN</td>
<td>VLAN</td>
</tr>
<tr>
<td>Server</td>
<td>Name or IP address of the server.</td>
</tr>
<tr>
<td>Client</td>
<td>Host address of the client.</td>
</tr>
<tr>
<td>Application</td>
<td>Application being used by server.</td>
</tr>
<tr>
<td>Number of Connections</td>
<td>Number of connections.</td>
</tr>
</tbody>
</table>
### Table B-38 Client-Server Network Responses Window (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimum Client Network Time (ms)</td>
<td>Minimum network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
<tr>
<td>Average Client Network Time (ms)</td>
<td>Average network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
<tr>
<td>Maximum Client Network Time (ms)</td>
<td>Maximum network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
<tr>
<td>Minimum Server Network Time (ms)</td>
<td>Minimum network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
<tr>
<td>Average Server Network Time (ms)</td>
<td>Average network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
<tr>
<td>Maximum Server Network Time (ms)</td>
<td>Maximum network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
<tr>
<td>Minimum Network Time (ms)</td>
<td>Minimum of the network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
<tr>
<td></td>
<td>Network Time is the sum of Client Network Time and Server Network Time. NAM measures the Network Time using TCP 3-way handshakes. If there are no new TCP connections made during the monitoring interval, this metric is not reported.</td>
</tr>
<tr>
<td>Average Network Time (ms)</td>
<td>Average of the network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
<tr>
<td>Maximum Network Time (ms)</td>
<td>Maximum of the network time measured by analyzing TCP three-way handshake sequence.</td>
</tr>
</tbody>
</table>

#### DSCP Detail Window

Table B-39 describes the fields in this window.

### Table B-39 DSCP Detail

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DSCP</td>
<td>DSCP value</td>
</tr>
<tr>
<td>Application</td>
<td>Application type</td>
</tr>
<tr>
<td>Bytes/sec</td>
<td>Traffic rate; number of bytes per second. In Administration &gt; System &gt; Preferences, you can choose to display NAM data in Bits or Bytes.</td>
</tr>
<tr>
<td>Packets/sec</td>
<td>Traffic rate; number of packets per second</td>
</tr>
</tbody>
</table>
Host Detail Window

Table B-40 describes the fields in this window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Host</td>
<td>Host address</td>
</tr>
<tr>
<td>Application</td>
<td>Application type</td>
</tr>
<tr>
<td>In Bits/sec</td>
<td>Number of bits per second incoming</td>
</tr>
<tr>
<td>In Packets/sec</td>
<td>Number of packets per second incoming</td>
</tr>
<tr>
<td>Out Bits/sec</td>
<td>Number of bits per second outgoing</td>
</tr>
<tr>
<td>Out Packets/sec</td>
<td>Number of packets per second outgoing</td>
</tr>
</tbody>
</table>

Interfaces Stats Table

The fields in the Interfaces Stats table are described in Table B-41.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interface</td>
<td>Interface number.</td>
</tr>
<tr>
<td>In % Utilization</td>
<td>Utilization percentage of the port.</td>
</tr>
<tr>
<td>Out % Utilization</td>
<td>Utilization percentage of the port.</td>
</tr>
<tr>
<td>In Packets/s</td>
<td>Number of incoming packets collected per second.</td>
</tr>
<tr>
<td>Out Packets/s</td>
<td>Number of outgoing packets sent out per second.</td>
</tr>
<tr>
<td>In Bits/s</td>
<td>Number of bits collected per second.</td>
</tr>
<tr>
<td>Out Bits/s</td>
<td>Number of bits sent out per second.</td>
</tr>
<tr>
<td>In Non-Unicast/s</td>
<td>Number of non-unicasts collected per second.</td>
</tr>
<tr>
<td>Out Non-Unicast/s</td>
<td>Number of non-unicasts sent out per second.</td>
</tr>
<tr>
<td>In Discards/s</td>
<td>Number of discards collected per second.</td>
</tr>
<tr>
<td>Out Discards/s</td>
<td>Number of discards sent out per second.</td>
</tr>
<tr>
<td>In Errors/s</td>
<td>Number of errors collected per second.</td>
</tr>
<tr>
<td>Out Errors/s</td>
<td>Number of errors sent out per second.</td>
</tr>
</tbody>
</table>
**Last 50 Alarms Table**

Table B-42 describes the fields on the Last 50 Alarms table.

**Table B-42 Last 50 Alarms**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Site</td>
<td>This contains site or source and destination sites (source - destination) of</td>
</tr>
<tr>
<td></td>
<td>the network traffic that generated the alarm message.</td>
</tr>
<tr>
<td>Alarm Triggered By</td>
<td>Details information of the network traffic that generated the alarm message.</td>
</tr>
<tr>
<td></td>
<td>The format of the alarm triggered by string are:</td>
</tr>
<tr>
<td></td>
<td>• Triggered by application threshold: application</td>
</tr>
<tr>
<td></td>
<td>• Triggered by application with DSCP threshold: DSCP:codepoint - application</td>
</tr>
<tr>
<td></td>
<td>• Triggered by host threshold: host</td>
</tr>
<tr>
<td></td>
<td>• Triggered by host with application threshold: host - application</td>
</tr>
<tr>
<td></td>
<td>• Triggered by host with application and DSCP: DSCP: code point - host -</td>
</tr>
<tr>
<td></td>
<td>application</td>
</tr>
<tr>
<td></td>
<td>• Triggered by host with DSCP: DSCP: code point - host</td>
</tr>
<tr>
<td></td>
<td>• Triggered by conversation: source - destination</td>
</tr>
<tr>
<td></td>
<td>• Triggered by conversation with application: source - application -</td>
</tr>
<tr>
<td></td>
<td>destination</td>
</tr>
<tr>
<td></td>
<td>• Triggered by response time: IAP: client - application - server.</td>
</tr>
<tr>
<td></td>
<td>• Triggered by DSCP: DSCP: code point</td>
</tr>
<tr>
<td></td>
<td>• Triggered by RTP stream: source - source port - codec(codec string) -</td>
</tr>
<tr>
<td></td>
<td>SSRC(number) - destination - destination port</td>
</tr>
<tr>
<td></td>
<td>• Triggered by voice signaling: Calling (address - number) Called (address</td>
</tr>
<tr>
<td></td>
<td>- number) ID/References (id() - ref (calling:called))</td>
</tr>
<tr>
<td></td>
<td>• Triggered by NetFlow interfaces: NetFlow: Device (address) - If-Index</td>
</tr>
<tr>
<td></td>
<td>(number) - Ingress/Egress</td>
</tr>
<tr>
<td>Threshold Variable</td>
<td>Parameter of the threshold that is used to evaluate alarm condition.</td>
</tr>
<tr>
<td>Threshold Value</td>
<td>User defined rising value of the threshold variable.</td>
</tr>
<tr>
<td>Triggered Time</td>
<td>Time when the alarm condition was found occurred.</td>
</tr>
<tr>
<td>Triggered Value</td>
<td>Parameter value when the alarm condition was raised. Note: The triggered</td>
</tr>
<tr>
<td></td>
<td>value could be - when the viewing window does not included the alarm when</td>
</tr>
<tr>
<td></td>
<td>it was occurring.</td>
</tr>
<tr>
<td>Clear Time</td>
<td>Time when the alarm condition was resolved. The alarm variable has fallen</td>
</tr>
<tr>
<td></td>
<td>below the falling threshold value.</td>
</tr>
</tbody>
</table>
Server Application Responses Window

Table B-43 provides definitions of each field of the Server Application Responses window.

**Table B-43  Server Application Responses Metrics**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client Site</td>
<td>Name of the client site.</td>
</tr>
<tr>
<td>Server Site</td>
<td>Name of the server site.</td>
</tr>
<tr>
<td>Data Source</td>
<td>Name of the data source</td>
</tr>
<tr>
<td>VLAN</td>
<td>VLAN</td>
</tr>
<tr>
<td>Server</td>
<td>Name or IP address of the server</td>
</tr>
<tr>
<td>Application</td>
<td>Application currently running</td>
</tr>
<tr>
<td>Number of Clients</td>
<td>Total number of clients</td>
</tr>
<tr>
<td>Number of Responses</td>
<td>Total number of responses</td>
</tr>
<tr>
<td>Average Client Network Time (ms)</td>
<td>Client Network Time is the network time between a client and the NAM switch or router.</td>
</tr>
<tr>
<td>Maximum Client Network Time (ms)</td>
<td>In WAAS monitoring, Client Network Time from a WAE client data source represents the network RTT between the client and its edge WAE, while Client Network Time from the WAE server data source represents the WAN RTT (between the edge and core WAEs).</td>
</tr>
<tr>
<td>Average Server Response Time (ms)</td>
<td>Server Response Time is the time it takes an application server (for example, a web server) to respond to a request. This is the server think time, which is the time between the client request arriving at the server and the first response packet being returned by the server. Increases in the server response time usually indicate problems with application and/or server resources, such as the CPU, Memory, Disk, or I/O.</td>
</tr>
<tr>
<td>Maximum Server Response Time (ms)</td>
<td>Total Response Time is the total amount of time between the client request and when the client receives the first response packet from the server.</td>
</tr>
</tbody>
</table>

Server Application Transactions Window

Table B-44 provides definitions of each field of the Server Application Transactions window.

**Table B-44  Server Application Transactions Metrics**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client Site</td>
<td>Name of the client site.</td>
</tr>
<tr>
<td>Server Site</td>
<td>Name of the server site.</td>
</tr>
<tr>
<td>Data Source</td>
<td>Name of the data source</td>
</tr>
<tr>
<td>VLAN</td>
<td>VLAN</td>
</tr>
<tr>
<td>Server</td>
<td>Name or IP address of the server</td>
</tr>
<tr>
<td>Application</td>
<td>Application currently running</td>
</tr>
</tbody>
</table>
Table B-44  Server Application Transactions Metrics (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Clients</td>
<td>Total number of clients</td>
</tr>
<tr>
<td>Number of Transactions</td>
<td>Total number of transactions</td>
</tr>
<tr>
<td><strong>Average Transaction Time (ms)</strong></td>
<td>Average time (ms) elapsed from the start of a client request to the completion of server response. Transaction times might vary significantly depending upon application types. Relative thresholds are useful in this situation. Transaction time is a key indicator when detecting application performance anomalies.</td>
</tr>
<tr>
<td><strong>Average Server Response Time (ms)</strong></td>
<td>Amount of time it takes a server to send the initial response to a client request as seen by the NAM.</td>
</tr>
<tr>
<td><strong>Average Data Transfer Time (ms)</strong></td>
<td>Average elapsed time from the first server-response packet to the last server-response packet, excluding retransmission time. Data transfer time is always measured in the server-to-client direction and can be used to detect problems for a particular type of transaction of an application.</td>
</tr>
<tr>
<td><strong>Average Retransmission Time (ms)</strong></td>
<td>Average time to retransmit lost packets, per transaction.</td>
</tr>
<tr>
<td><strong>Client ACK Round Trip Time (ms)</strong></td>
<td>Average round trip time for the client to acknowledge (ACK) a server TCP packet.</td>
</tr>
</tbody>
</table>

Server Network Responses Window

Table B-45 provides definitions of each field of the Server Network Response Times window.

Table B-45  Server Network Responses Window

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client Site</td>
<td>Name of the client site</td>
</tr>
<tr>
<td>Server Site</td>
<td>Name of the server site</td>
</tr>
<tr>
<td>Data Source</td>
<td>Name of the data source.</td>
</tr>
<tr>
<td>VLAN</td>
<td>VLAN</td>
</tr>
<tr>
<td>Server</td>
<td>Name or IP address of the server</td>
</tr>
<tr>
<td>Application</td>
<td>Application being used by server</td>
</tr>
<tr>
<td>Number of Clients</td>
<td>Total number of clients during the monitoring interval</td>
</tr>
<tr>
<td>Number of Connections</td>
<td>Total number of connections during the monitoring interval</td>
</tr>
<tr>
<td><strong>Average Server Network Time (ms)</strong></td>
<td>Average of the Server Network Time (network time between a server and NAM probing point).</td>
</tr>
<tr>
<td><strong>Maximum Server Network Time (ms)</strong></td>
<td>Maximum of the Server Network Time (network time between a server and NAM probing point).</td>
</tr>
<tr>
<td><strong>Average Network Time</strong></td>
<td>Average of the network time between client and server. Network Time is the sum of Client Network Time and Server Network Time. NAM measures the Network Time using TCP 3-way handshakes. If there are no new TCP connections made during the monitoring interval, this metric is not reported.</td>
</tr>
<tr>
<td><strong>Maximum Network Time</strong></td>
<td>Maximum of the network time between client and server.</td>
</tr>
</tbody>
</table>
Table B-45  Server Network Responses Window (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server Bytes</td>
<td>Number of TCP payload bytes sent from the server(s) during the monitoring interval.</td>
</tr>
<tr>
<td>Client Bytes</td>
<td>Number of TCP payload bytes sent from the client(s) during the monitoring interval.</td>
</tr>
</tbody>
</table>

Capture User Interface Windows

This section includes the following topics:

- Capture Analysis Window, page B-37
- Capture Session Fields, page B-37
- Capture Setting Fields, page B-38
- Custom Decode Filter Dialog Box, page B-40
- Custom Decode Subexpressions Fields, page B-42
- Error Scan Window, page B-42
- Hardware Filter Dialog Box, page B-43
- NAM Packet Analyzer Decode Window, page B-44
- Software Filter Dialog Box, page B-44

Capture Analysis Window

Table B-46 describes the Capture Analysis window fields.

Table B-46  Capture Analysis Window Fields

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Capture Overview</td>
<td>Provides a summary of the displayed capture including number of packets captured, bytes captured, average packet size, capture start time, duration of capture, and data transfer rate (both bytes and bits per second)</td>
</tr>
<tr>
<td>Traffic over Time</td>
<td>Displays a graphic image of network traffic (KB/second)</td>
</tr>
<tr>
<td>Protocol Statistics</td>
<td>Displays packets and bytes transferred for each protocol</td>
</tr>
<tr>
<td>Hosts Statistics</td>
<td>Displays packets and bytes transferred for each host address</td>
</tr>
</tbody>
</table>

Capture Session Fields

Table B-47 describes the fields on the Capture > Packet Capture/Decode > Sessions page.

Table B-47  Capture Session Fields

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the capture session</td>
</tr>
<tr>
<td>Start Time</td>
<td>Time the capture was last started. You can stop and restart the capture as many times as necessary.</td>
</tr>
</tbody>
</table>
### Table B-47  
**Capture Session Fields (continued)**

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Size (MB) (Capture to Memory)</td>
<td>Size of the session</td>
</tr>
<tr>
<td>Size (MB) x No. files (Capture to Files)</td>
<td>Note  <em>Capture to files</em> indicates the capture is being stored in one or more files and is a link to those files.</td>
</tr>
<tr>
<td>Packets</td>
<td>Number of packets</td>
</tr>
<tr>
<td>State</td>
<td>The current status of the capture:</td>
</tr>
<tr>
<td></td>
<td>• Running—Packet capture is in progress</td>
</tr>
<tr>
<td></td>
<td>• Stopped—Packet capture is stopped. Captured packets remain in buffer, but no new packets are captured</td>
</tr>
<tr>
<td></td>
<td>• Full—The memory or file is full, and no new packets will be captured.</td>
</tr>
<tr>
<td>Location</td>
<td>The location of the capture (Memory, Local Disk, and external storage).</td>
</tr>
<tr>
<td>Capture Operation Buttons</td>
<td></td>
</tr>
<tr>
<td>Create</td>
<td>Create a new capture session. See Configuring Capture Sessions, page 5-5.</td>
</tr>
<tr>
<td>Edit</td>
<td>Edit the settings of the selected capture.</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete a selected session. Not available if capture session is running.</td>
</tr>
<tr>
<td>Start</td>
<td>Start capturing to a selected session. The number in the Packets column for that session will start to rise.</td>
</tr>
<tr>
<td>Stop</td>
<td>Stop capturing to the selected session (no packets will go through). Capture data remains in the capture memory buffer, but no new data is stored. Click Start to resume the capture.</td>
</tr>
<tr>
<td>Clear</td>
<td>Clear captured data from memory.</td>
</tr>
<tr>
<td>Decode</td>
<td>Display details of the capture session.</td>
</tr>
<tr>
<td>Save to File</td>
<td>Save a session to a file on the NAM hard disk. See Working with Capture Files, page 5-16.</td>
</tr>
</tbody>
</table>

**Capture Setting Fields**

Table B-48 describes the Capture Settings fields.
Table B-48  Capture Settings Fields

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Packet Slice Size</td>
<td>The slice size in bytes; used to limit the size of the captured packets.</td>
<td>Enter a value between 64 and 9000. Enter zero (0) to not perform slicing. If you have a small</td>
</tr>
<tr>
<td>(bytes)</td>
<td></td>
<td>session but want to capture as many packets as possible, use a small slice size. If the packet</td>
</tr>
<tr>
<td></td>
<td></td>
<td>size is larger than the specified slice size, the packet is <em>sliced</em> before it is saved in the</td>
</tr>
<tr>
<td></td>
<td></td>
<td>capture session. For example, if the packet is 1000 bytes and slice size is 200 bytes, only</td>
</tr>
<tr>
<td></td>
<td></td>
<td>the first 200 bytes of the packet is stored in the capture session.</td>
</tr>
<tr>
<td>Capture Source</td>
<td>Data-Ports or ERSPAN</td>
<td>Choose the capture source (check one or more check boxes):</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Data-ports: This accepts SPAN, RSPAN, and VACL capture. For NAM on ISR G2 SM-SRE, internal,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>external, or both.¹ On NAM-NX1, you can select only one data-port at a time.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• ERSPAN: Locally terminated is recommended.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Note On some platforms, you may be limited to selecting only one of the dataports at a time.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Most platforms allow you to select both dataports at once.</td>
</tr>
<tr>
<td>Storage Type:</td>
<td>Check to store captures in memory</td>
<td>Enter values for <strong>Memory Size</strong> for this capture. Enter a number from 1 up to your platform</td>
</tr>
<tr>
<td>Memory</td>
<td></td>
<td>maximum. If system memory is low, the actual session size allocated might be less than the</td>
</tr>
<tr>
<td></td>
<td></td>
<td>number specified here.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Check (if desired) <strong>Wrap when Full</strong> to enable continuous capture (when the session is full,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>older packet data is removed to make room for new incoming packets). If you do not check **</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wrap when Full**, the capture will end when the amount of data reaches size of session.</td>
</tr>
</tbody>
</table>
Table B-48  Capture Settings Fields (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Storage Type: File(s)</td>
<td>File Size (MB)</td>
<td>Enter a value for File Size (file size can be from 1 MB to 500/2000 MB depending on your platform). If disk space is not available, you are not able to start new capture-to-disk sessions.</td>
</tr>
<tr>
<td></td>
<td>Number of Files</td>
<td>Enter a value for Number Of Files to use for capture. The maximum is determined on the size of the file, numbers of files stored, and the amount of disk space available at the location where these files are stored.</td>
</tr>
<tr>
<td></td>
<td>Rotate Files</td>
<td>Use this feature if you plan to capture sets of small files that allow you to perform instantaneous downloads, decodes, and analysis. Rotating files allows you to automatically maintain your storage space. Check the Rotate Files check box to rotate files. Available only for remote storage or NAM appliances. For information about configuring remote storage, see Capturing to Data Storage, page 5-20. If you choose the Rotate Files option, when you reach the highest number file, the earliest file is overwritten. For example, if you specify No. Files to 10, file CaptureA_1 is overwritten after the NAM writes capture data to file CaptureA_10. To determine the most recent capture, check each file’s time stamp.</td>
</tr>
<tr>
<td></td>
<td>File Location</td>
<td>If file data storage is available, choose one of the storage targets in the drop-down list. The drop-down list displays only those targets in the Ready state. Local disk is the default, or choose a previously configured remote storage location if available. Each option shows the amount of disk space available for capture packet storage. Maximum capture session size for capture to disk is determined by the available space on the capture target. You can manage these locations from the Capture &gt; Data Storage page (see Utilizing Capture Data Storage, page 5-20).</td>
</tr>
</tbody>
</table>

1. The Nexus virtual blade (VB) does not have dataports, so this option is not supported.

Custom Decode Filter Dialog Box

Table B-49 describes the fields on this window.

Table B-49  Custom Decode Filter Dialog Box

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter Name</td>
<td>The name of the capture filter.</td>
<td>Enter the name of the filter to be created.</td>
</tr>
<tr>
<td>Description</td>
<td>The description of the capture filter.</td>
<td>Enter a description of the filter.</td>
</tr>
<tr>
<td>Protocol</td>
<td>The protocol to match with the packet.</td>
<td>Choose a protocol from the list. (Select All to match all packets regardless of protocol.)</td>
</tr>
<tr>
<td>Address (MAC or IP)</td>
<td>Indicates whether to filter by MAC or IP address.</td>
<td>Choose MAC to filter using the source/destination MAC address of the packets. Choose IP to filter using the source/destination addresses of the packets.</td>
</tr>
</tbody>
</table>
### Both Directions
Indicates whether the filter is applied to traffic in both directions. If the source is host A and the destination is host B, enabling both directions filters packets from A to B and B to A. If the source is host A and the destination is not specified, enabling both directions filters packets both to and from host A.

### Offset
The offset (in bytes) from the Base where packet data-matching begins. Enter a decimal number.

### Base
The base from which the offset is calculated. If you select absolute, the offset is calculated from the absolute beginning of the packet (for example, the beginning of the Ethernet frame). If you select protocol, the offset is calculated from the beginning of the protocol portion of the packet. If the packet does not contain the protocol, the packet fails this match. Choose `absolute` or a protocol.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Both Directions</td>
<td>Indicates whether the filter is applied to traffic in both directions.</td>
<td>If the source is host A and the destination is host B, enabling both directions filters packets from A to B and B to A. If the source is host A and the destination is not specified, enabling both directions filters packets both to and from host A.</td>
</tr>
<tr>
<td>Offset</td>
<td>The offset (in bytes) from the Base where packet data-matching begins.</td>
<td>Enter a decimal number.</td>
</tr>
<tr>
<td>Base</td>
<td>The base from which the offset is calculated.</td>
<td>Choose <code>absolute</code> or a protocol.</td>
</tr>
</tbody>
</table>
GUI Field Descriptions

### Table B-49 Custom Decode Filter Dialog Box (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Data Pattern</strong></td>
<td>The data to be matched with the packet.</td>
<td>Enter hh hh hh ..., where hh are hexadecimal numbers from 0-9 or a-f. Leave blank if not applicable.</td>
</tr>
<tr>
<td><strong>Filter Expression</strong></td>
<td>An advanced feature to set up complex filter conditions. The simplest filter allows you to check for the existence of a protocol or field. For example, to see all packets that contain the IPX protocol, you can use the simple filter expression ipx.</td>
<td>See Tips for Creating Custom Decode Filter Expressions, page 5-29.</td>
</tr>
</tbody>
</table>

**Custom Decode Subexpressions Fields**

Table B-50 describes the custom decode fields and provides filter and format details.

### Table B-50 Custom Decode Field Subexpressions

<table>
<thead>
<tr>
<th>Field</th>
<th>Filter By</th>
<th>Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>eth.addr</td>
<td>MAC address</td>
<td>hh:hh:hh:hh:hh:hh, where h is a hexadecimal number from 0 to 9 or a to f.</td>
</tr>
<tr>
<td>eth.src</td>
<td></td>
<td></td>
</tr>
<tr>
<td>eth.dst</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ip.addr</td>
<td>IP address</td>
<td>n.n.n.n or n.n.n.n/s, where n is a number from 0 to 255 and s is a 0-32 hostname that does not contain a hyphen.</td>
</tr>
<tr>
<td>ip.src</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ip.dst</td>
<td></td>
<td></td>
</tr>
<tr>
<td>tcp.port</td>
<td>TCP port number</td>
<td>A decimal number from 0 to 65535.</td>
</tr>
<tr>
<td>tcp.srcport</td>
<td></td>
<td></td>
</tr>
<tr>
<td>tcp.dstport</td>
<td></td>
<td></td>
</tr>
<tr>
<td>udp.port</td>
<td>UDP port number</td>
<td>A decimal number from 0 to 65535.</td>
</tr>
<tr>
<td>udp.srcport</td>
<td></td>
<td></td>
</tr>
<tr>
<td>udp.dstport</td>
<td></td>
<td></td>
</tr>
<tr>
<td>protocol</td>
<td>Protocol</td>
<td>Click the Protocol list in the Custom Decode Filter dialog box to see the list of protocols on which you can filter.</td>
</tr>
<tr>
<td>protocol [offset: length]</td>
<td>Protocol data pattern</td>
<td>hh:hh:hh:hh..., where hh is a hexadecimal number from 0 to 9 or a to f. offset and length are decimal numbers. offset starts at 0 and is relative to the beginning of the protocol portion of the packet.</td>
</tr>
<tr>
<td>frame.pkt_len</td>
<td>Packet length</td>
<td>A decimal number that represents the packet length, not the truncated capture packet length.</td>
</tr>
</tbody>
</table>

**Error Scan Window**

Table B-51 describes the Error Scan window fields.
Appendix B References

GUI Field Descriptions

Table B-51  Error Scan Window Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Packet ID</td>
<td>ID of the packet in the capture file.</td>
</tr>
<tr>
<td>Protocol</td>
<td>Protocol the packet arrived on.</td>
</tr>
</tbody>
</table>
| Severity      | **Warn**: Warning; for example, an application returned an unusual error code  
|               | **Error**: A serious problem, such as malformed packets                     |
| Group         | **Checksum**: A checksum was invalid                                        |
|               | **Sequence**: Protocol sequence is problematic                             |
|               | **Response Code**: Problem with the application response code               |
|               | **Request Code**: An application request                                     |
|               | **Undecoded**: Dissector incomplete or data can’t be decoded                 |
|               | **Reassemble**: Problems while reassembling                                 |
|               | **Malformed**: Malformed packet or dissector has a bug; dissection of this packet aborted |
| Description   | Description of the error or warning                                          |

Hardware Filter Dialog Box

Table B-52 describes the Create Hardware Filter dialog box.

Table B-52  Create Hardware Filter Dialog

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Ports</td>
<td>Both Ports, Data Port 1, Data Port 2</td>
</tr>
<tr>
<td>Frame Length</td>
<td>Equal To, Not Equal To, Greater Than, Less Than</td>
</tr>
<tr>
<td>VLAN IDs</td>
<td>Equal To, Not Equal To, Greater Than, Less Than</td>
</tr>
<tr>
<td>MPLS Label</td>
<td>Equal To, Not Equal To</td>
</tr>
<tr>
<td>Source Address / Mask</td>
<td>Equal To, Not Equal To</td>
</tr>
<tr>
<td>Destination Address / Mask</td>
<td>Equal To, Not Equal To</td>
</tr>
<tr>
<td>L4 Protocol</td>
<td>Equal To, Not Equal To ICMP, IGMP, IP in IP, GRE, L2Tp, TCP, UDP, Integer</td>
</tr>
<tr>
<td>L4 Source Port</td>
<td>Equal To, Not Equal To</td>
</tr>
<tr>
<td>L4 Destination Port</td>
<td>Equal To, Not Equal To</td>
</tr>
<tr>
<td>Pattern Match</td>
<td>Filters packets based on 4-byte hexadecimal patterns anywhere in the first 256 bytes. Equal To, Not Equal To</td>
</tr>
</tbody>
</table>

With Custom, you can enter a custom value that is not in the list of common protocols. Enter min. 1, max 255.
NAM Packet Analyzer Decode Window

Table B-53 describes the fields on the NAM Packet Analyzer window.

Table B-53   Packet Browser

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No.</td>
<td>Packet numbers, listed numerically in capture sequence. If the decode (display) filter is active, the packet numbers might not be consecutive.</td>
</tr>
<tr>
<td>Time</td>
<td>Time the packet was captured relative to the first packet displayed (not the first packet in the session). To see the absolute time, see the Detail window.</td>
</tr>
<tr>
<td>Source</td>
<td>Packet source, which might be displayed as hostname, IP, IPX, or MAC address. To turn hostname resolution on and off for IP addresses, choose the Setup tab and change this setting under Preferences.</td>
</tr>
<tr>
<td>Destination</td>
<td>Packet destination, which might be displayed as hostname, IP, IPX, or MAC address.</td>
</tr>
<tr>
<td>Protocol</td>
<td>Top-level protocol of the packet.</td>
</tr>
<tr>
<td>Length</td>
<td>Size of the packet, in bytes.</td>
</tr>
<tr>
<td>Info</td>
<td>Brief text information about the packet contents.</td>
</tr>
</tbody>
</table>

Software Filter Dialog Box

Table B-54 describes the Software Filter dialog box fields.

Table B-54   Software Filter Dialog Box

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter a name of the new filter.</td>
<td></td>
</tr>
<tr>
<td>Source Address / Mask</td>
<td>Source address of the packets.</td>
<td>• For IP, IP4, GRE.IP, or GTP.IPv4 addresses, enter a valid IPv4 address in dotted-quad format n.n.n.n, where n is 0 to 255. The default (if blank) is 255.255.255.255.</td>
</tr>
</tbody>
</table>
|                      | The mask applied to the source address.        | • For IPv6 or GTP.IPv6 addresses, enter a valid IPv6 address in any allowed IPv6 address format. For example:  
|                      | • If a bit in the Source Mask is set to 1, the corresponding bit in the address is relevant. |   - 1080::8:800:200C:417A  
|                      | • If a bit in the Source Mask is set to 0, the corresponding bit in the address is ignored.  |   - ::FFFF:129.144.52.38  
|                      | Note                                           | See RFC 5952 for valid text representations. For MAC address, enter hh hh hh hh hh hh hh, where hh is a hexadecimal number from 0 to 9 or a to f. The default is ff ff ff ff ff ff. |

Note See RFC 5952 for valid text representations.
### Table B-54  Software Filter Dialog Box (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
</table>
| **Destination Address / Mask**| Destination address of the packets.| • For IP, IPIP4, GRE.IP, or GTP.IPv4 addresses, enter a valid IPv4 address in dotted-quad format n.n.n.n, where n is 0 to 255. The default (if blank) is 255.255.255.255.  
  • For IPv6 or GTP.IPv6 addresses, enter a valid IPv6 address in any allowed IPv6 address format. For example:  
    - 1080::8:800:200C:417A  
  Note See RFC 5952 for valid text representations.  
  For MAC address, enter hh hh hh hh hh hh, where hh is a hexadecimal number from 0 to 9 or a to f. The default is ff ff ff ff ff ff. |
|                               | The mask applied to the destination address. | • For IP, IPIP4, GRE.IP, or GTP.IPv4 addresses, enter a valid IPv4 address in dotted-quad format n.n.n.n, where n is 0 to 255. The default (if blank) is 255.255.255.255.  
  • For IPv6 or GTP.IPv6 addresses, enter a valid IPv6 address in any allowed IPv6 address format. The default mask (if blank) for IPv6 addresses is ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff  
  Note See RFC 5952 for valid text representations.  
  For MAC address, enter hh hh hh hh hh hh, where hh is a hexadecimal number from 0 to 9 or a to f. The default is ff ff ff ff ff ff. |
| **Network Encapsulation**     | The protocol to match with the packet. | Choose the protocol from the drop-down list.  
  • Choose IP to use the source/destination IP addresses of the packets.  
  • Choose IPIP4 for IP addresses including those tunneled over IP protocol 4.  
  • Choose GRE.IP for IP addresses including those tunneled over GRE.  
  • Choose IPv6 for addresses using IP version 6.  
  • Choose GTP.IPv4 for IPv4 address for tunneled packet over GTP.  
  • Choose GTP.IPv6 for IPv6 address for tunneled packet over GTP. |
| **Both Directions** (check box)| This check box indicates whether the filter is applied to traffic in both directions. | If the source is host A and the destination is host B, enabling both directions filters packets from A to B and B to A.  
If the source is host A and the destination is not specified, enabling both directions filters packets both to and from host A.  
The “both directions” check box also affects the ports and not only the addresses (the same logic applies). |
| **VLAN Identifier(s)**        | The 12-bit field specifying the VLAN to which the packet belongs. | Choose a VLAN Range or enter from one to four individual VLAN IDs.  
For better performance, use as narrow a range as possible. The VLAN ID can range from 1-4095. |
Table B-54  Software Filter Dialog Box (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Usage Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application¹</td>
<td>Select the Application drop list to filter by application.</td>
<td>Select one protocol to capture from the Application drop-down list.</td>
</tr>
</tbody>
</table>
| Port    | Select the Port radio button to filter by Port. | In the Source Port(s) field, enter one or more ports separated by commas.  
In the Destination Port(s) field, enter one or more ports separated by commas.  
From the IP Protocol pull-down menu, choose TCP, UDP, or SCTP. No selection (default) means that any will be allowed. |

¹ The application filter can be used to filter on the highest layer of the protocol parsing; that is usually a layer 4 protocol (based on port). If you want to filter on the transport protocol (for example, UDP or TCP), you will need to use the "IP Protocol" selector. Selecting, for example, TCP in the "IP Protocol" selector will filter on all packets using TCP.

Report Descriptions

Table B-55 lists the MIB objects supported by the NAM.

Table B-55  NAM RMON Support

<table>
<thead>
<tr>
<th>Description</th>
<th>Source</th>
</tr>
</thead>
<tbody>
<tr>
<td>MIB-II: All groups except Exterior Gateway Protocol (EGP) and transmission.</td>
<td>RFC 1213</td>
</tr>
<tr>
<td>RMON-MIB: Alarm and Event groups only</td>
<td>RFC 2819</td>
</tr>
<tr>
<td>RMON2: trapDestTable only</td>
<td>RFC 2021</td>
</tr>
<tr>
<td>CDP-MIB: Cisco Discovery Protocol</td>
<td></td>
</tr>
<tr>
<td>EntityMIB</td>
<td>RFC 2737</td>
</tr>
</tbody>
</table>
INDEX

A

access policies, setting in ACS 5.x  6-21
access policy configuration, ACS v5.x  6-21
administration (see system administration)  6-1
alarm thresholds, setting
  NAM thresholds  3-40
    editing  3-44
  syslog, setting up  6-11
API guide  7-6
ART  4-23, 4-26
Audit trail  6-13

capture
  error scan  5-25
  Global Capture Settings  5-7
capture files
  about  5-21
  analyze  5-23
  Drill-Down button  5-23
capture sessions
  about  5-3
  configuring  5-5
  viewing  5-5
capture storage, logging in/out  5-28
capturing data  2-3, 5-1
capture buffer
  downloading to a file  5-21
capture settings, configuring  5-5
custom display filters
  creating  5-36

custom display filters, setting up  5-35
  deleting  5-39
  editing  5-38
packet decode information, viewing  5-30
protocol decode information, viewing  5-31
CAPWAP (Control And Provisioning of Wireless Access Points)  3-61
cautions
  regarding
    NAM community strings, deleting  6-6
    switch string and read-write community string matching  6-6
Cisco Prime Network Analysis Module User Guide, 5.1  1-1
community switch strings, setting and viewing  6-6
configuring NAM
  community switch strings, setting and viewing  6-6
data collection, setting up
  voice data, collecting  3-63
data sources, setting up  3-8
traffic, directing for spanning  3-8
  creating a SPAN session  3-8
  editing a SPAN session  3-8
  NetFlow, configuring on devices  3-21
  NetFlow records, understanding  3-20
  SPAN sources (table)  3-7
  traffic directing methods (table)  3-6
  VACL, configuring on LAN VLANs  3-18
  VACL, configuring on WAN interfaces  3-18
Consecutive Packets Loss threshold  3-5
Control And Provisioning of Wireless Access Points  3-61
creating
  custom display filters  5-36
  protocol  3-57
SPAN sessions 3-8

custom display filters, managing
creating 5-36
deleting 5-39
editing 5-38
setting up 5-35

dashboards
Alarm Summary 4-4
Performance Overview 4-3
Response Time Summary 4-3
Traffic Analysis 4-1
data collection
setting up
voice data 3-63
data export to NAM 2-3
data sources, setting up 3-8
data storage 5-26
deleting
custom display filters 5-39
DiffServ profiles 3-55, 3-60
protocols 3-59
diagnostics, generating 6-12
configuration information, monitoring and capturing 6-13
system alerts, capturing 6-13
system alerts, viewing 6-12
DiffServ profile, managing
creating 3-53, 3-60
deleting 3-55, 3-60
editing 3-54, 3-60
directing traffic for spanning 3-8
methods (table) 3-6
NetFlow, configuring on devices 3-21
NetFlow devices, managing
testing 3-26
SPAN session

creating 3-8
editing 3-8
SPAN sources (table) 3-7
VACL, configuring on LAN VLANs 3-18
VACL, configuring on WAN interfaces 3-18
DSCP groups, managing
setting up 3-53
dashboards
Alarm Summary 4-4
Performance Overview 4-3
Response Time Summary 4-3
Traffic Analysis 4-1
data collection
setting up
voice data 3-63
data export to NAM 2-3
data sources, setting up 3-8
data storage 5-26
deleting
custom display filters 5-39
DiffServ profiles 3-55, 3-60
protocols 3-59
diagnostics, generating 6-12
configuration information, monitoring and capturing 6-13
system alerts, capturing 6-13
system alerts, viewing 6-12
DiffServ profile, managing
creating 3-53, 3-60
deleting 3-55, 3-60
editing 3-54, 3-60
directing traffic for spanning 3-8
methods (table) 3-6
NetFlow, configuring on devices 3-21
NetFlow devices, managing
testing 3-26
SPAN session

creating 3-8
editing 3-8
SPAN sources (table) 3-7
VACL, configuring on LAN VLANs 3-18
VACL, configuring on WAN interfaces 3-18
DSCP groups, managing
setting up 3-53

e-mail alarms 3-37
Enabling
voice monitoring 3-63
Encapsulation 3-60
Encapsulation Configuration 3-60
ERSPAN 3-17
configuring as datasource 3-10
sending data directly to NAM 3-17
external storage
about 5-26
capturing 5-27
LUNs 5-27

filtering
audit trail 6-13
Filter Response Time for all Data Sources by Monitored Servers  3-66

G

GPRS (General Packet Radio Service) Tunneling Protocol  3-60
GREIP  3-60
GTP  3-60

H

hardware filter
configuring  5-13
logic  5-13
hardware filters
about  5-18
configuring  5-18
help
(see also troubleshooting)  A-1
diagnostics, generating for technical assistance  6-12
configuration information, monitoring and capturing  6-13
system alerts, capturing  6-13
system alerts, viewing  6-12

I

IGMP  A-9
interface data, viewing
detail  4-9, 4-29
IPESP  3-60
IPIP4  3-60
IP tunnel encapsulations  3-60
IQN  5-28

L

Lightweight Access Point Protocol  3-61
LWAPP (Lightweight Access Point Protocol)  3-61

M

Monitored servers filters  3-66
Monitoring
Application response times  4-26
monitoring
port traffic  A-9
traffic  2-3
monitoring data
voice  4-11
Multiple WAAS segments
viewing response time  4-17

N

NAM
alarm thresholds
editing  3-44
setting  3-40
community strings, working with  6-5
creating  6-5
deleting  6-6
SNMP system groups, setting and viewing  6-4
system time, setting  6-6
configuring with an NTP server  6-8
synchronizing with switch or router  6-8
traps
setting  6-11
navigation and control elements  A-3
NetFlow
configuring on devices  3-21
devices, managing
testing  3-26
exporting data  A-9
interfaces, understanding  3-19
records, understanding  3-20
NetFlow Data Export to NAM  3-7
network parameters, setting and viewing  6-4
northbound interface (NBI)  4-42
Index

O

overview of NAM  A-3

navigation and control elements

P

Packet Loss threshold  3-5

passwords
invalid characters  6-16

passwords, recovering  6-14

Performance Agent
aggregation  3-33, A-10

port traffic
monitoring  A-9

protocol directory
managing
creating protocols  3-57

deleting protocols  3-59

editing protocols  3-59

R

recovering passwords  6-14

response time
application  4-21

client  4-22

client-server  4-22

network  4-21

server  4-22

response time data, viewing
reports
server  4-24

RTP Stream Monitoring  3-5

S

SCCP traffic  5-32

Server Response Time table, using

reports  4-24

sessions
SPAN  3-6, 3-10, A-8

setting
alarm thresholds
NAM thresholds  3-40

syslog  6-11

community switch strings  6-6

NAM SNMP system groups  6-4

network parameters  6-4

Single WAAS segment
viewing response time  4-17

sites

defining  3-49

definition rules  3-51

editing  3-50

SPAN
sessions  3-6, 3-10, A-8

creating  3-8

editing  3-8

spanning, directing traffic for
methods (table)  3-6

NetFlow, configuring on devices  3-21

NetFlow devices, managing

testing  3-26

SPAN session
creating  3-8

editing  3-8

SPAN sources (table)  3-7

VACL, configuring
on LAN VLANs  3-18

on WAN interfaces  3-18

SPAN states  3-7

Switch Remote SPAN  3-6

Switch SPAN  3-6

symbols
invalid for NAM login  6-16

syslog alarm threshold, setting up  6-11

system administration  6-1
Index

diagnostics, generating for technical assistance 6-12

overview of system administration tasks 6-2
  NAM community strings, working with 6-5
  NAM SNMP system group, setting and viewing 6-4
  NAM system time, setting 6-6
  network parameters, setting and viewing 6-4

overview of user administration tasks 6-14
  passwords, recovering 6-14
  predefined NAM user accounts, changing 6-15
  TACACS+ authentication and authorization, establishing 6-17
  TACACS+ server, configuring to support NAM 6-18
  user privileges (table) 6-16
  users, creating new 6-15
  users, editing 6-17
  user sessions table, viewing 6-22

system alerts
  capturing 6-13
  viewing 6-12

T

TAC (Technical Assistance Center)
  (see also troubleshooting) A-1

TACACS+
  authentication and authorization, establishing 6-17
  server, configuring to support NAM 6-18
  secret key, requirements for in v4.2 6-19
  secret key, requirements for in v5.x 6-20
  version 4.2 6-18
  version 5.x 6-20

technical assistance, obtaining
  (see also troubleshooting) A-1

diagnostics, generating for configuration information, monitoring and capturing 6-13
  system alerts, capturing 6-13
  system alerts, viewing 6-12

testing NetFlow devices 3-26

traffic analysis 2-3

traffic sources
  monitoring 2-3

troubleshooting A-1
  switch, cannot communicate with 6-6

U

user
  administration (see system administration) 6-1
  privileges (table) 6-16
  sessions table, viewing 6-22

username
  invalid characters 6-16

V

VACL 3-17, A-8
  VLAN access control list 3-17, A-8

VACL, configuring
  on LAN VLANs 3-18
  on WAN interfaces 3-18

viewing
  community switch strings 6-6
  DiffServ data 4-10
  NAM SNMP system groups 6-4
  network parameters 6-4
  response time data
    server 4-24
  system alerts 6-12
  user sessions table 6-22
  voice data 4-11

Viewing audit trail 6-13

Virtual Switch Software (VSS) B-11

VLAN access control list
  VACL 3-17, A-8

voice data
  collecting 3-63
viewing 4-11
Voice signaling thresholds 3-43
VSS
  see Virtual Switch Software 3-10

WAAS
  about 3-27
  adding data sources 3-31
  ART calculations 3-27
  configuring a device 3-31
WAAS Central Manager 3-30
WAAS data sources 4-17