CH A P T E R

10

Viewing Network Topology

Note

The web interface does not support viewing the network topology. You can view the network topology
in the MWTM client interface only.
In addition to tabular (text) views of your network, the Cisco Mobile Wireless Transport Manager
(MWTM) client provides a topological (graphical) view of the objects in your ITP or RAN-O network,
including:
•

Nodes

•

RAN-O service modules

•

Interfaces

•

ITP signaling points

•

ITP application servers

•

ITP application server process associations

•

ITP linksets

•

Adjacent legacy nodes

Note

The MWTM does not manage legacy nodes (such as BSC, BTS, RNC, or Node B objects),
but displays them in the topology map to help you visualize the interconnections between
network objects.

Any associated alarms also appear in the topology window. You can use the MWTM to customize the
topological view (for details, see Chapter 6, “Managing Views”).
To view the topology of your network, use one of these procedures:
•

Choose View > Topology from the MWTM main menu.

•

Right-click an object, then choose View > Center in Topo in the right-click menu.

The topology window appears.
The topology window shows tabular information about MWTM objects in the left pane and the graphical
topology map in the right pane. Alarms associated with the chosen object appear in the bottom pane.
The topology window contains:
•

Topology Menu, page 10-2

•

Topology Toolbar Buttons, page 10-3
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•

Topology Panes, page 10-5

•

Topology Map, page 10-8

•

Topology Alarm Pane, page 10-14

The MWTM provides these functions related to the topology map:
•

Creating a Custom Layout, page 10-14

•

Finding an Object, page 10-14

•

Centering the Topology Map on an Object, page 10-15

•

Displaying Detailed Information About a Topology Map Element, page 10-16

•

Printing the Topology Map, page 10-16

•

Saving the Topology Map as a JPEG File, page 10-16

•

Selecting a Directory for the JPEG File, page 10-17

•

Activating a Magnetic Grid on the Topology Map, page 10-18

•

Specifying a Color for the Magnetic Grid, page 10-19

•

Specifying a Background Color for the Topology Map, page 10-20

•

Aligning Objects on the Topology Map, page 10-22

•

Hiding and Displaying Non-ITP Nodes and Linksets, page 10-23

•

Locking and Unlocking the Position of an Icon, page 10-23

•

Improving Topology Performance, page 10-23

•

Saving the Topology Map, page 10-24

•

Restoring the Topology Map, page 10-25

Related Topics
•

Diagnosing a Typical Network Problem, page D-5

•

Changing MWTM Server Poller Settings, page 4-2

•

Chapter 6, “Managing Views”

Topology Menu
The topology window is identical to the MWTM main menu. For detailed descriptions of the options it
provides, see Using the MWTM Main Menu, page 3-18.

Note

The menu option Go does not display in the Topology window, instead you can view Topology Tools
menu command. The Topology Tools menu contains the options as in the table under Topology
Right-Click Menu: Map, page 10-13.
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Topology Toolbar Buttons
The topology window contains these toolbar buttons:
Button

Description
Close view tab

Closes the currently visible view in the topology window.
This option is dimmed if the currently visible view is the
highest-level parent view.

Open parent view

Opens the parent view of the currently visible view in the
topology window.
This option is dimmed if the currently visible view is the
highest-level parent view.

Lay out nodes in a circle

Shows the map in a circular layout.

Lay out nodes in a spring

Shows the map in a spring layout. That is, the MWTM draws
nodes with the most lines closer to the center of the map, and
draws nodes with fewer lines farther away. This is the default
setting the first time the map appears.
Note

You can change how far apart to space the nodes when
the MWTM draws the spring layout (see Changing
Topology Settings, page 5-13).

Zoom in by a factor of 200% Makes the map twice as large.

Zoom out by a factor of 50% Makes the map half as large.

Zoom by percentage

Zooms the map by a chosen percentage. You can choose a
percentage from the drop-down list box; or, enter a percentage
and click Enter. Valid values are integers in the range
5 through 400.

Zoom in on an area

Zooms in on the selected area of the map. Click the button, then
click in the topology map and drag a rectangle around the area
on which you want to zoom. The MWTM expands the selected
area to fill the topology map.

Zoom to fit window

Adjusts the size of the map to fit in the window. This is the
default setting the first time the map appears.

Find objects

Opens the Find Objects dialog box, which you use to find and
highlight an object in the topology window.
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Button

Description
Set magnetic grid properties Opens the Magnetic Grid Settings dialog box, which you use to
activate and deactivate the magnetic topology grid, and
modifies how it appears. With the grid activated, when you
move objects on the topology map they automatically align
with the grid.
Align objects on map

Opens the Align Objects dialog box, which you use to align two
or more objects on the topology map.
Hides or shows all non-ITP signaling points and linksets on the
topology map. (Hidden signaling points and linksets still
appear in the left pane.)

The process determines whether the node's parent (visible on
Hiding/Showing non-ITP nodes (ITP
the topology maps) has an ITP MIB or not. If not, it is classified
only)
as a non-ITP node and it will be hidden or visible when the
button is toggled.
The MWTM automatically saves this setting (with non-ITP
nodes and linksets either hidden or visible) with your
preferences.
Node Dragging Optimizer

Turns the Node Dragging Optimizer on or off:
•

When the Node Dragging Optimizer is On, the MWTM
hides linkset lines as you drag an object around the
topology map. The MWTM draws the linkset lines when
you drop the object in its final position. This is the default
setting.

•

When the Node Dragging Optimizer is Off, the MWTM
continually redraws linkset lines as you drag an object
around the topology map.

The MWTM automatically saves this setting (with the Node
Dragging Optimizer on or off) with your preferences.
Hiding/Showing Dangling
Connections

Hides or shows connections to objects that are not visible in the
current view, which are called dangling connections. When the
Hiding Dangling Connections is set to:
•

Hide, the MWTM hides dangling connections. This is the
default setting.

•

Show, the MWTM shows dangling connections, drawing
the objects in shades of gray to distinguish them from
actual objects in the current view.

The MWTM does not save this setting (with the Hiding
Dangling Connections set to Show or Hide) when you save the
view.
To include a dangling connections in the current view, select the
connection, then select Include In View.
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Button

Description
Show/Hide alarm pane

Lock position

or
Unlock position

Shows or hides the alarm pane at bottom.

Locks or unlocks the position of an icon on the topology map.
Locking the position of an icon can be useful if you want to
keep the icon in its position, and you want to ensure you do not
move it inadvertently. Locked icons do not appear in the
circular or spring layouts. To lock the position of an icon,
select:
•

An unlocked icon, then select Lock position.

•

A locked icon, then select Unlock position. This is the
default setting.

The MWTM automatically saves this setting (with icon
positions locked or unlocked) with your view.

Topology Panes
In the topology window, you can access:
•

View Objects and Connections Panes, page 10-5

•

Topology Map, page 10-8

View Objects and Connections Panes
The View Objects pane in the left pane of the topology window shows information about the MWTM
objects that are currently visible in the topology map. The Connections pane shows information about
the connections associated with the object that you chose in the View Objects table, or the object
currently chosen in the topology map.

Tip

If you cannot see the View Objects or Connections tables, click on the arrow bar

to expand.

•

To redraw the topology map centered on a specific object, double-click the object in this table.

•

You cannot select more than one object at a time in this table.

•

To see the tooltip for each column in the table, place the cursor over a column heading.

•

If a cell is too small to show all of its data, place the cursor over the cell to see the full data in a
tooltip.

You can resize each column, or sort the table based on the information in one of the columns. By default,
the MWTM sorts this table by Severity.
To:
•

Display hidden columns, right-click in the table heading and check the check boxes for the columns
you want to display.

•

Hide columns, right-click in the table heading and uncheck the check boxes for the columns you
want to hide.
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For more information about resizing, sorting, displaying, or hiding columns, see Navigating Table
Columns, page 5-23.
The View Objects or Connections table contains:
Column

Description

Internal ID

Internal ID of the object. The internal ID is a unique ID for every object, that
MWTM assigns for its own internal use. It can also be useful when the TAC
is debugging problems.

Type (View Objects)

Object types can be ITP only, RAN-O only, or General to all types of
networks.
General object types include:
•

Node—Any interconnecting node that is not an ITP node.

•

View—Custom view (if one exists).

ITP only object types include:
•

ASP—An application server process.

•

SP—A signaling point.

RAN-O only object types include:

Type (Connections)

•

CSR—Cell Site Router (CSR) node.

•

RAN SVC Node—A RAN service card in an Optical Networking
System (ONS) node.

Connection types can be ITP only, RAN-O only, or General to all types of
networks.
ITP only object types include:
•

Linkset—A linkset associated with a signaling point.

•

ASPA—An application server process association associated with a
signaling point.

RAN-O only object types include:
•

RAN Backhaul—Virtual RAN backhaul associated with a RAN node or
RAN SVC node.

•

PWE3 Backhaul

•

GSM Interface—GSM interface associated with a RAN node or RAN
SVC node.

•

Universal Mobile Telecommunications System (UMTS)
Interface—UMTS interface associated with a RAN node or RAN SVC
node.

Name

Name of the object.

Node

Name of the node associated with the object.

Notes

Indicates whether a note is associate with the object.
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Column

Description

Events

Indicates whether the object has a recent event. (Even if the server purges all
of the events associated with the object, the MWTM continues to display the
event icon
in this field.)
During discovery, the MWTM might flag most objects with an event
icon
. If the event icons are too distracting, choose Edit > Clear All
Events from the MWTM main menu to remove them.

Last Status Change

Date and time that the status of the object last changed.

Severity

Severity of the alarm. Possible severities are:
Critical
Major
Minor
Warning
Informational
Indeterminate
Unmanaged
Normal
You can customize this field (see Right-Click Menu for a Specific Alarm or
Event, page 9-11).

Status

Current status of the object. Possible values are:
•

Active

•

Unknown

•

Unmanaged

•

Warning

For detailed definitions of each status, see the “Status Definitions” section
on page E-1.
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Column

Description

Status Reason

Reason for the current status of the object.
For a full list of possible reasons, see the stateReasons.html file. If you
installed MWTM in:
•

The default directory, /opt, then the file resides at
/opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

•

A different directory, then the help directory and file reside in that
directory.

If the cell is too small to show all of the status reason, place the cursor over
the cell to see the full status reason in a tooltip.
The MWTM lists status reasons in order of decreasing magnitude. If two or
more reasons apply, the reason of greatest magnitude appears.
If the status reason is Unsupported Configuration, correct the configuration
and enter the mwtm cleandiscover command to delete all current network
data and begin a discovery of the network. If the status reason remains
Unsupported Configuration, enter the mwtm clean command to restore the
MWTM server to a state that would exist after a new installation of the
MWTM, excluding the log files, which the MWTM retains. To also remove
the log files, enter the mwtm cleanall command. For more information on
the use of these commands, see Appendix B, “Command Reference.”
Ignored

Indicates whether the object should be included when aggregating and
displaying MWTM status information:
•

Uncheck the check box to include the object. This is the default setting.

•

Check the check box to exclude the object.

Users with authentication level Power User (level 2) and higher can edit this
field.

Topology Map
The topology map in the right pane of the topology window shows the objects and views in your network
in an easy-to-read graphical format.
Views

If you have defined custom views, you can view them in the topology map. The MWTM shows a tab for
each visible view. Each tab shows a colored ball that indicates the current status of that view:

Note

•

Active

•

Warning

For detailed definitions of each status, see Appendix E, “Status Definitions.”
Excluded and Unmanaged Objects

The MWTM removes from the topology map any objects and their associated objects (including adjacent
legacy nodes) that you exclude from the current view and Creating a New View, page 6-7).
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If you unmanage an object from the topology map right-click menu (see Topology Right-Click Menu:
Object, page 10-13) the MWTM marks the object status as Unmanaged and removes any adjacent legacy
nodes from the topology map.
Tooltips

To see a tooltip, place the cursor over an object. For details on turning off tooltips, see Changing
Topology Settings, page 5-13.
Viewing Associated Objects

To view objects associated with a chosen object, in the:
•

Tabs in the View Objects pane, click an object. Any associated objects (such as signaling points with
associated linksets) appear in the Connections pane.

•

Content area, click a single line, a heavy line
double-triangle
to:

, a diamond

, circle

, arrowhead

, or

– Highlight the closest associated node in the View Objects pane in a tab. For example, if a line

connects node sgm-2600a and node sgm-2600b, and you click the line closer to node
sgm-2600a, then the MWTM highlights that node in the View Objects pane.
– Display all objects (if any) associated with that node in the Connections pane in a tab.
– Highlight the clicked object (if it is configured) in the Connections pane in a tab.

Viewing Details for an Object

To display the Details tab for any object in the map, double-click it. If multiple options are possible, the
Selection dialog box appears. Highlight the object, then click Select.
Navigating and Scrolling

To:
•

Scroll around in the topology map using keyboard options, click anywhere in the map, then click the
arrow, Page Up, and Page Down keys.

•

Redraw the topology map centered on a specific object, double-click the object in the View Objects
pane in a tab.

•

Activate or change the magnetic topology grid, which can help you align objects when you move
them, use the Magnetic Grid Settings dialog box (see Activating a Magnetic Grid on the Topology
Map, page 10-18).

•

Align two or more objects on the topology map, use the Align Objects dialog box (see Aligning
Objects on the Topology Map, page 10-22).

Saving the Topology Map

To save the topology map as a JPEG file, use the Save as JPEG dialog box (see Saving the Topology Map
as a JPEG File, page 10-16).
Hiding or Showing Dangling Connections

To hide objects that connect to objects that are not in the current view (called dangling connections),
click the Hiding/Showing Dangling Connections button to set it to Hide. To show dangling
connections, click the Hiding/Showing Dangling Connections button to set it to Show. The MWTM
draws the objects in shades of gray to distinguish them from actual objects in the current view. The
MWTM does not save this setting (with the Hiding Dangling Connections set to Show or Hide). To
include a dangling object in the current view, right-click the object and select Include In View.
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Locking and Unlocking Icon Positions

To lock the position of an icon on the topology map, select an unlocked icon, then select Lock position.
Locking the position of an icon can be useful if you want to keep the icon in its position, and you want
to ensure that you do not move it inadvertently. The MWTM does not include locked icons in the circular
or spring layouts.
To unlock the position of an icon on the topology map, click a locked icon, then select Unlock position.
Object Types in the Topology Map

The topology map might contain graphical elements for any of these objects, which the MWTM
automatically assigns:

Note

Icon colors vary. The color of a graphical element indicates its current severity. If more than one object
is configured on the connection, the color associated with the object that is in the most compromised
state represents the severity color of the connection.

Object Type

Notes

ASP

N/A

BSC

Base Station Controller

BTS

Base Transceiver Station
Cisco 2650, Cisco 2650XM, Cisco 2651, Cisco 2651XM

Cisco 2600 series router
N/A
Cisco 2811 series router
N/A
Cisco 7202 series router
Cisco 7204, Cisco 7204VXR
Cisco 7204 series router
Cisco 7206, Cisco 7206VXR
Cisco 7206 series router
N/A
Cisco 7301 series router
N/A
Cisco 7304 series router
N/A
Cisco 7505 series router
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Object Type

Notes

Cisco 7507 series router

Cisco 7507, Cisco 7507mx, Cisco 7507z

Cisco 7513 series router

Cisco 7513, Cisco 7513mx, Cisco 7513z

Cisco 7600 series router

Cisco 7603, Cisco 7603s, Cisco 7604, Cisco 7606, Cisco 7606s,
Cisco 7609, Cisco 7609s, Cisco 7613
N/A

Cisco MWR 1900 series router
Cloud

A collection of objects, called a submap. A submap can also
contain other submaps.

IP device

Other than those listed previously (if assigned by a user; see
Editing Properties, page 7-49)

PGW

Cisco Public Switched Telephone Network (PSTN) Gateway
(PGW) 2200 Softswitch

Signaling point

•

An SCP, SSP, or STP, or an ITP instance (if the ITP is configured
for multi-instance)

A line indicates a single logical connection configured between two nodes. A line that:
– Ends in a diamond

indicates that the connection has at least one configured interface or
linkset associated with the node.

– Ends in a circle

indicates that the connection is a virtual linkset, associated with a signaling

point.
– Does not end in a diamond

or circle
indicates that the interface or linkset is not
configured on the node or cannot be shown because the MWTM is not managing the node.

– Ends in an arrowhead

indicates that the connection is an application server process

association.
– Ends in a double-triangle
•

indicates a connection to a view that has multiple interfaces.

A heavy line
indicates that two or more interfaces or linksets exist between two nodes, or
between views and other objects.

In addition, users can assign graphical elements for these objects (see Editing Properties, page 7-49):
Object Type
Building

Description
Icon representing a collection of objects in a building.

City

Icon representing a collection of objects in a city.

Database

Icon representing a database object.
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Object Type
MatedPair

Description
Mated pair of signaling points.

MSC

Mobile switching center.

Node-B

Radio transmission (or reception) unit for communication between radio
cells in a UMTS network (Node-B resides at the cell site).
Note

RAN SVC Node
RNC

RAN service module card.
Radio Network Controller used in a UMTS network to aggregate
multiple Node-B units.
Note

192.168.1.2/24

The MWTM does not manage the RNC but displays the object in
the topology window to help you visualize the network.

SCP

Service control point.

SSP

Service switching point.

STP

Signal transfer point.

Tower

Icon representing a PC tower.

TrafficGenerator

Icon representing a device or emulator used to generate traffic, usually in
a test environment.

Unknown

Node that does not respond to SNMP requests for supported MIBs.

Workstation

Icon representing a workstation.

Workstation2

Icon representing a different workstation.

204082

10.0.0.2/24

MWTM 10.0.0.1/24 MWTM 192.168.1.1/24 MWTM
Client B
Server
Client A

The MWTM does not manage the Node B but displays the object
in the topology window to help you visualize the network.

The topology map also provides right-click menus for elements. For more information, see these
sections:
•

Topology Right-Click Menu: Map, page 10-13

•

Topology Right-Click Menu: Object, page 10-13
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Topology Right-Click Menu: Map
The topology window provides a subset of the MWTM main menu as a right-click menu. To see this
menu for a map, right-click in a blank area of the topology map. The topology map right-click menu
displays:
Command

Description

Zoom > Zoom In
(Ctrl-=)

Makes the map twice as large.

Zoom > Zoom Out
(Ctrl-- or Ctrl-Minus)

Makes the map half as large.

Zoom > Zoom Area

Zooms in on the selected area of the map.

Zoom > Zoom Fit

Adjusts the size of the map to fit in the window. This is the default setting the
first time the map appears.

Layout > Circular

Shows the map in a circular layout.

Layout > Spring

Shows the map in a spring layout. That is, the MWTM draws nodes with the
most links closer to the center of the map, and draws nodes with fewer links
farther away. This is the default setting the first time the map appears.

Find (Ctrl-F)

Opens the Find Objects dialog box, which you use to find and highlight an
object in the topology window.

Restore Positions

Restores the view to the last saved view.

Save As JPEG
(Ctrl-J)

Opens the Save as JPEG dialog box, enabling you to save the topology map to
a JPEG file.

Magnetic Grid

Opens the Magnetic Grid Settings dialog box.

Change Background
Color

Opens the Select Background Color dialog box, which you use to select a
color for the background of the topology map.

Align

Opens the Align Objects dialog box, which you use to align two or more
objects on the topology map.

Open Parent View

Opens the parent view of the currently visible view in the topology window.
This option is dimmed if the currently visible view is the highest level parent
view.

Close View

Closes the currently visible view in the topology window.
This option is dimmed if the currently visible view is the highest level parent
view.

Topology Right-Click Menu: Object
The topology window displays a subset of the MWTM main menu as a right-click menu. To see this
menu for any object in the topology window, right-click on an object in the topology map in the right
pane. Options may vary depending on the chosen object type.
For a list of right-click menu options, see Viewing the Right-Click Menu for an Object, page 8-2.
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Topology Alarm Pane
The Alarm pane at the bottom of the topology window shows any current alarms on the chosen object.
For details about the buttons and fields in the Alarm pane, see Chapter 9, “Managing Alarms and
Events.”

Creating a Custom Layout
You can use the MWTM to create a custom layout for the topology map by manually moving objects on
the map and by grouping them or isolating them to meet your needs. To move:
•

A single object, click and drag the object to its new position.

•

More than one object at the same time, press the Shift key and at the same time, select the objects
and drag them. Objects keep their positions relative to one another.

When you are satisfied with the new topology map layout, choose File > Save View from the MWTM
main menu. The MWTM saves the changes you have made to the network view, including any changes
you have made to the topology map layout.

Finding an Object
Some topology maps are so large and complex that it can be difficult to find a specific object.
If the object appears in the tabs in the left pane, select the object, and the MWTM highlights it in the
topology map.
If the object does not appear in the tabs in the left pane, click the Find objects button
in the
topology window; or, choose Edit > Find from the MWTM main menu. The Find Object dialog box
appears.
You can search by using the:
•

Name

•

Point code (for ITP signaling points)

•

IP address (for RAN-O nodes)

User Guide for the Cisco Mobile Wireless Transport Manager 6.1.4

10-14

OL-23290-01

Chapter 10

Viewing Network Topology
Centering the Topology Map on an Object

The Find Object dialog box contains:
Field or Button

Description

Search string

Character string for which the MWTM should search.

OK

Launches the search. If:

Cancel

•

No matching object is found, the MWTM shows an appropriate
message.

•

Exactly one object is found that matches the Search string, the
MWTM highlights the object in the Tables pane of the topology
window, and zooms in on the chosen object in the topology map.

•

More than one object is found that matches the Search string, the
Choose dialog box appears, in which you can select from a list of the
found objects (see Using the Selection Dialog, page 10-15).

Closes the Find Objects dialog box without launching the search.

Using the Selection Dialog
If more than one object matches the Search string in the Find Objects dialog box, the Selection dialog
box appears.
The Selection dialog box contains:
Field or Button

Description

Select one in list

Type, Name, or Status of the found objects. Select the object you want
to find.

Select

Highlights the chosen object in the left pane of the topology window,
and zooms in on the chosen object in the topology map.

Cancel

Closes the Selection dialog box without selecting an object.

Centering the Topology Map on an Object
To redraw the topology map centered on a specific object, double-click the object in one of the tabs.
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Displaying Detailed Information About a Topology Map Element
To display detailed information about an element in the map, double-click it in the map, then respond to
the prompts. Double click:
•

An object to view the Details tab in the MWTM main menu for that object.

•

A single line, or a diamond
, circle
, or arrowhead
at the end of a single line, to display
the MWTM main window details for that linkset or application server process association.

•

A double-triangle
at the end of a heavy line
to display the Selection dialog box. (A heavy
line indicates that two or more interfaces or linksets exist between two objects, or between views
and other objects.) Then, select one of the interfaces or linksets to display the Selection dialog box
for that interface or linkset.

Printing the Topology Map
To print the topology map, see Printing Windows, page 5-24.

Saving the Topology Map as a JPEG File
You can use the MWTM to save the topology map to a JPEG file. You can save the entire topology map,
or just the current window.
To save the topology map to a JPEG file, choose Topology Tools > Save as JPEG from the topology
window.
The Save as JPEG dialog box appears. The Save as JPEG dialog box contains:
Field or Button

Description

All

Saves the entire topology map as a JPEG file. This check box is checked by
default.

Current Window

Saves just the portion of the topology map visible in the current window as a
JPEG file. This check box is unchecked by default, which saves the entire map;
not just the current window.

Quality

Specifies the quality of the JPEG file, from 0 (lowest quality) to 1.0 (highest
quality). The default setting is 0.7, which is sufficient for most JPEG files.

Max. Size

Specifies the size of the JPEG file, in pixels. Choose a value from the
drop-down list box. The valid range is 400-2400 pixels. The default value is
400 pixels, which is sufficient for most JPEG files.
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Field or Button

Description

Name

Enter a name for the JPEG file, or accept the default filename, out.jpg.
The default directory for the JPEG file is the directory in which you installed
the MWTM client:
•

In Solaris/Linux, the default installation directory for the MWTM client is
/opt/CSCOsgmClient.

•

In Windows, the default installation directory for the MWTM client is
C:\Program Files\SGMClient\.

•

If you installed the MWTM client in a different directory, then the
installation directory resides in that directory.

If you do not want to save the JPEG file to the default directory, click Browse
to select a different directory.
Browse

Opens the Save dialog box for a topology map, which you use to specify or
select a name when you save the JPEG file. If you do not want to save the JPEG
file to the default directory, click Browse to select a different directory.

Save

Saves the JPEG file and closes the Save as JPEG dialog box.

Cancel

Closes the Save as JPEG dialog box without saving the JPEG file.

Selecting a Directory for the JPEG File
You can use the MWTM to specify or select a name or directory when you save a topology map to a
JPEG file. You can save the entire topology map, or just the current window.
To specify a name or directory for the JPEG file, click Browse in the Save as JPEG dialog box.
The Save dialog box appears for a topology map. The Save dialog box for a topology map contains:
Field or Button

Description

Save In

Selects the directory in which you want to save the topology map JPEG file.
You can accept the default directory, or select a new directory from the
drop-down list box.

File Name

Enter a name for the JPEG file, or select a file from those listed in the Save In
field.

Files of Type

Specifies the type of file to save, and shows all files of that type in the chosen
directory. Choose a file type from the drop-down list box:
•

All files—Shows all files in the chosen directory, and saves the topology
map file as a JPEG file.

•

jpg files—Shows only JPEG files in the chosen directory, and saves the
topology map file as a JPEG file. This is the default value.

Up One Level

Shows the subfolders and files that are in the folder that is up one level from
the currently visible folder.

Desktop

Shows the subfolders and files that are on your workstation desktop.
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Field or Button

Description
Creates a new subfolder in the currently visible folder.

Create New Folder
List

Shows only icons for subfolders and files.

Details

Shows detailed information for subfolders and files, including their size, type,
date they were last modified, and so on.

Save

Saves the file and closes the Save dialog box for a topology map.
When you are satisfied with the settings, click Save. The MWTM closes the
Save dialog box for a topology map and populates the Name field in the Save
as JPEG dialog box with the new name and directory.

Cancel

Closes the Save dialog box for a topology map without saving the file.

Activating a Magnetic Grid on the Topology Map
You can use the MWTM to activate the magnetic topology grid and change how it appears. With the grid
activated, when you move objects on the topology map they align with the grid.

Note

Magnetic grid settings are not saved when you save the view.
To activate or change the magnetic topology grid, choose Topology Tools > Magnetic Grid from the
topology window. The Magnetic Grid Settings dialog box appears. The Magnetic Grid Settings dialog
box contains:
Field or Button

Description

Grid Activated

Specifies whether the magnetic topology grid is activated. To:

Display Grid

•

Activate the grid, check this check box.

•

Deactivate the grid, uncheck this check box. This is the default setting.

Specifies whether the grid should be visible on the topology map. To:
•

Display the grid, check this check box. This is the default setting.

•

Hide the grid, uncheck this check box.

If Grid Activated is not checked, this check box is dimmed.
Grid Spacing

Specifies the spacing between lines on the grid, in pixels.
To specify the spacing between lines on the grid, in pixels, check the Grid
Activated check box, then select a Grid Spacing level. The valid range is
0-150 pixels. The default setting is 50 pixels, which is sufficient for most
topology maps.
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Field or Button

Description

Grid Color

Opens the Select Grid Color dialog box.
To specify a color for the grid, check the Grid Activated check box, then click
Change Color in the Grid Color field. The MWTM opens the Select Grid
Color dialog box.

OK

Sets the new grid settings and closes the Magnetic Grid Settings dialog box.
When you are satisfied with the magnetic grid settings, click OK.

Cancel

Closes the Magnetic Grid Settings dialog box without changing any settings.

Specifying a Color for the Magnetic Grid
You can use the MWTM to customize the color of the magnetic topology grid.

Note

The grid color is not saved when you save the view.
To specify a color for the grid, check the Grid Activated check box in the Magnetic Grid Settings dialog
box, then click Select in the Grid Color field.
The Select Grid Color dialog box opens. The Select Grid Color dialog box contains:
•

Swatches Pane (Recommended), page 10-19

•

HSB Pane, page 10-19

•

RGB Pane, page 10-20

•

Select Grid Color Field and Buttons, page 10-20

Related Topic:

Activating a Magnetic Grid on the Topology Map, page 10-18.

Swatches Pane (Recommended)
You can use the Swatches pane of the Select Grid Color dialog box to select a grid color from a set of
color swatches. This is the recommended method for selecting a grid color.
To display the Swatches pane, click the Swatches tab in the Select Grid Color dialog box.
To select a grid color, select a swatch. The chosen color appears in the Preview field. When you are
satisfied with the color, click OK.

HSB Pane
You can use the HSB pane of the Select Grid Color dialog box to select a grid color based on color hue,
saturation, and brightness (HSB).
To display the HSB pane, click the HSB tab in the Select Grid Color dialog box.
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To select a grid color, use one of these procedures:
•

Select a color range on the vertical color bar, then select a specific color by moving the cursor around
on the color square.

•

Enter specific values in the hue (H), saturation (S), and brightness (B) fields.

The chosen color appears in the Preview field. When you are satisfied with the color, click OK.

RGB Pane
You can use the RGB pane of the Select Grid Color dialog box to select a grid color based on the red,
green, and blue (RGB) content of the color.
To display the RGB pane, click the RGB tab in the Select Grid Color dialog box.
To select a grid color, select values for the Red, Green, and Blue fields. The chosen color appears in the
Preview field. When you are satisfied with the color, click OK.

Select Grid Color Field and Buttons
The Select Grid Color dialog box contains:
Field

Description

Preview

Shows a preview of the currently chosen grid color.
Whichever method you choose to select a grid color, the chosen color appears
in the Preview field. When you are satisfied with the color, click OK.

OK

Sets the grid color as shown in the Preview field, and closes the Select Grid
Color dialog box.

Cancel

Closes the Select Grid Color dialog box without selecting a grid color.

Reset

Resets the grid color to its initial setting.

Specifying a Background Color for the Topology Map
You can use the MWTM to customize the background color of the topology map.

Note

The background color is not saved when you save the view.
To specify a background color for the topology map, right-click in a blank area of the topology map, then
select Change Background Color from the right-click menu.
The Select Background Color dialog box contains:
•

Swatches Pane (Recommended), page 10-21

•

HSB Pane, page 10-21

•

RGB Pane, page 10-21

•

Select Background Color Field and Buttons, page 10-21
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Swatches Pane (Recommended)
You can use the Swatches pane of the Select Background Color dialog box to select a background color
from a set of color swatches. This is the recommended method for selecting a background color.
To display the Swatches pane, click the Swatches tab in the Select Background Color dialog box.
To select a background color, select a swatch. The chosen color appears in the Preview field. When you
are satisfied with the color, click OK.

HSB Pane
You can use the HSB pane of the Select Background Color dialog box to select a background color based
on color hue, saturation, and brightness (HSB).
To display the HSB pane, click the HSB tab in the Select Background Color dialog box.
To select a grid color, use one of these procedures:
•

Select a color range on the vertical color bar, then select a specific color by moving the cursor around
on the color square.

•

Enter specific values in the hue (H), saturation (S), and brightness (B) fields.

The chosen color appears in the Preview field. When you are satisfied with the color, click OK.

RGB Pane
You can use the RGB pane of the Select Background Color dialog box to select a background color based
on the red, green, and blue (RGB) content of the color.
To display the RGB pane, click the RGB tab in the Select Background Color dialog box.
To select a background color, select values for the Red, Green, and Blue fields. The chosen color appears
in the Preview field. When you are satisfied with the color, click OK.

Select Background Color Field and Buttons
The Select Background Color dialog box contains:
Field

Description

Preview

Shows a preview of the currently chosen background color.
Whichever method you choose to select a background color, the chosen color
appears in the Preview field. When you are satisfied with the color, click OK.

OK

Sets the background color as shown in the Preview field, and closes the Select
Background Color dialog box.

Cancel

Closes the Select Background Color dialog box without selecting a
background color.

Reset

Resets the background color to its initial setting.
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Aligning Objects on the Topology Map
Note

To unalign objects, drag and drop the object to move it on the topology map.
You can use the MWTM to align two or more objects on the topology map. You can align the objects
based on their left, right, top, or bottom edges, or you can center them in the map. The MWTM saves the
alignment when you save the view.
To align objects, choose the objects that you want to align, then choose Topology Tools > Align from
the topology window. The Align dialog box appears. The Align dialog box contains:
Field

Description

Vertically: None

Does not align the chosen objects vertically.

Vertically: Left

Aligns the chosen objects vertically, aligned with the left edge of the left
chosen object.

Vertically: Center

Aligns the chosen objects vertically, with centers aligned.

Vertically: Right

Aligns the chosen objects vertically, aligned with the right edge of the
right chosen object.

Vertically: Side by side

Aligns the chosen objects vertically, aligned side-by-side, with no
horizontal space between the objects. (There might still be vertical space
between the objects.)

Horizontally: None

Does not align the chosen objects horizontally.

Horizontally: Top

Aligns the chosen objects horizontally, aligned with the top edge of the
top chosen object.

Horizontally: Center

Aligns the chosen objects horizontally, with centers aligned.

Horizontally: Bottom

Aligns the chosen objects horizontally, aligned with the bottom edge of
the bottom chosen object.

Horizontally: Side by side

Aligns the chosen objects horizontally, aligned side-by-side, with no
vertical space between the objects. (There might still be horizontal space
between the objects.)

Apply

Aligns the chosen objects and keeps the Align dialog box open, enabling
you to continue aligning objects.

OK

Aligns the chosen objects and closes the Align dialog box.

Cancel

Closes the Align dialog box. Changes you applied are saved; other
changes are not saved.

Help

Opens the Help window for this object.
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Hiding and Displaying Non-ITP Nodes and Linksets
Note

This function applies only to ITP objects. If you have not discovered ITP objects in your network, the
Hiding/Showing Non-ITP Nodes button does not appear.
To hide all non-ITP nodes and linksets on the topology map (the default setting), click the
Hiding/Showing Non-ITP Devices button. (The hidden signaling points and linksets are still visible in
the left pane.)
To display all hidden nodes and linksets on the topology map, click the Hiding/Showing Non-ITP
Devices button again.
The MWTM automatically saves this setting (with non-ITP nodes and linksets either hidden or visible)
with your preferences.

Locking and Unlocking the Position of an Icon
You can use the MWTM to lock the position of an icon on the topology map. Locking the position of an
icon can be useful if you want to keep the icon in its position, and you want to ensure that you do not
move it inadvertently. The MWTM does not include locked icons in the circular or spring layouts.
•

To lock the position of an icon on the topology map, right-click an unlocked icon, then select Lock
Position.

•

To unlock the position of an icon on the topology map, right-click a locked icon, then select Unlock
Position. This is the default setting.

The MWTM saves this setting (with icon positions locked or unlocked) when you save the view.

Improving Topology Performance
In certain cases, you can enhance topology performance by:
•

Turning Off Antialiasing, page 10-23

•

Connecting Locally for Large Networks—Solaris Clients Only, page 10-24

•

Hiding and Redrawing Connections When Redrawing, page 10-24

•

Hiding and Showing Connections When Redrawing, page 10-24

Turning Off Antialiasing
Antialiasing, which is on by default, improves the appearance of the icons and connections in the
topology map. However, antialiasing can cause an unexpected delay in the MWTM client on a remote
workstation (that is, a Solaris/Linux workstation using xhost, or a Windows workstation by using an
X-Window system emulator such as eXceed or Reflection X).
You can use the MWTM to turn off antialiasing to improve the performance of the MWTM client on a
remote workstation. To do so, check the X Performance Enhancer (AntiAliasing Off) check box in the
Topology settings in the Preferences window (see Changing Topology Settings, page 5-13).
To turn antialiasing back on, uncheck the check box.

User Guide for the Cisco Mobile Wireless Transport Manager 6.1.4
OL-23290-01

10-23

Chapter 10

Viewing Network Topology

Saving the Topology Map

Tip

Keep in mind that for small networks, performance is always better if you access the MWTM by
installing the MWTM client on the remote workstation.

Connecting Locally for Large Networks—Solaris Clients Only
If you are using a remote Solaris client and you have a large network, use a local Solaris client with a
graphics card and an attached monitor, rather than remote access, to improve topology performance.

Note

This issue might also cause an unexpected delay in the unsupported Linux client.

Hiding and Redrawing Connections When Redrawing
To aid performance, you can use the MWTM to hide connection lines as you drag an object around the
topology map, then re-draw the connection lines when you drop the object in its final position. To do so,
click the Node Dragging Optimizer button to turn it on. This is the default setting.
To have the MWTM continually redraw connection lines as you drag an object around the topology map,
click the Node Dragging Optimizer button to turn it off.
The MWTM automatically saves this setting (with the Node Dragging Optimizer on or off) with your
preferences.

Hiding and Showing Connections When Redrawing
To aid performance, you can use the MWTM to hide connections linked to objects that are not in the
current view, called dangling connections. To do so, click the Hiding/Showing Dangling Connections
button to set it to Hide. This is the default setting.
To show dangling connections, click the Hiding/Showing Dangling Connections button to set it to
Show. The MWTM draws the connections in shades of gray to distinguish them from actual objects in
the current view.
The MWTM does not save this setting (with the Hiding Dangling Connections set to Show or Hide) when
you save the view.
To include a dangling connection in the current view, right-click the connection and select Include In
View.

Saving the Topology Map
When you are ready to close the topology window, choose File > Save View from the MWTM main
menu. The MWTM prompts you to save any changes you made to the network view, including any
changes you have made to the topology map layout, and closes the window (see Closing the View Editor
Window, page 6-13).
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Restoring the Topology Map
You can use the MWTM to restore the topology map to the way it looked in the last saved view. To do
so, choose Topology Tools > Restore Positions from the topology window. The MWTM restores the
view.
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